关于优化包的说明

优化包简介：

实达铭泰公司在成立四周年之际，特别推出《东方快车XP》。《东方快车XP》是实达铭泰继东方快车3000之后，推出的业界领先的智能多语翻译平台，领先一代的《东方快车XP》已经实现了别的翻译软件没有的功能！其超强功能体现在：软件汉化可达到中文版水平，连软件里的"帮助"都汉化得很准确！支持软件的各种版本，支持英日文软件汉化，繁体软件简体本地化，可对软件、html、chm、 acrobat文件进行自动翻译等。

优化包作为《东方快车XP》中的一个组成部分，主要是为了帮助广大的计算机爱好者能够在尽短时间内学习掌握一些常用软件的使用方法，希望您在使用过程中，感受到无穷的乐趣，同时希望您多提宝贵意见。

优化包版权声明：

在本次优化包的制作过程中，参考和借鉴了一些文章，由于大多是网络内容，无法找到作者，希望相关作者与本公司联系。

联系方式

地址：北京市海淀区中关村南大街6号中电信息大厦六层实达铭泰公司

信箱：北京市海淀区中关村南大街6号中电信息大厦十号信箱

邮编：100086

电话：（8610）62501955

传真：（8610）62501718

客户服务部电话：62501955-610、611、612、613

Email：youhuabao@sunv.com

优化包详细内容：

本次优化包的内容包括有：

网络工具：OICQ2000、ICQ、NetMeeting、NetAnts、NetPhone、MSN Messenger、MediaRing、iMesh、Go!Zilla、FlashGet、CuteFTP、IPhone

系统工具：CpuIdle、Regcleaner、Daemon Tools、Norton Clear Sweep、Norton Utility

杀毒工具：Norton Antivirus

邮件工具：Outlook Express、Foxmail、Eudora Pro、The Bat!

图形图像工具：ACDSee、Ulead GIF Animator、Ulead PhotoImpact、Adobe Photoshop、ArtIcons、Fireworks、CorelDraw、Flash

压缩工具：WinRAR、WinZip

多媒体工具：Windows Media Player、Win DVD、RealPlayer、Power DVD、Winamp

编辑工具：UltraEdit、Adobe Table

浏览工具：WebZIP、IE6、Netscape、NetCaptor、MSN Explorer

网页制作工具：Dreamweaver

其它：ssReader、Adaptec Easy Cd Creator、Acrobat Reader、eXeScope

征集优化包：

本公司现向全社会征集优化包。根据制作的优劣本公司将给予制作人100-300元/个不等的报酬，并在软件中署作者姓名。

要求：1、优化包具有原创性、实用性、不涉及他人版权。

2、制作精良，通俗易懂，内容丰富。

3、若优化包未被采纳，将不予支付报酬。

4、本活动最终解释权归实达铭泰公司所有。


UltraEdit简介

UltraEdit是一套功能强大的文本编辑器，可以编辑文字、Hex、ASCII 码，可以取代记事本，内建英文单字检查、C++ 及 VB 指令突显，可同时编辑多个文件，而且即使开启很大的文件速度也不会慢。软件附有 HTML Tag 颜色显示、搜寻替换以及无限制的还原功能，一般大家喜欢用其来修改EXE 或 DLL 文件，众多的游戏玩家喜欢用它来修改存盘文件或是可执行文件。


UltraEdit的下载和安装

要想获得UltraEdit的安装文件你可以到以下网站去下载http://www.ultraedit.com/、洪恩在线，一般下载下来的文件是一个包含两个运行程序的压缩文件 [image] ，解压缩后会出现两个文件，运行 uedit32i.exe 程序。

接下来会出现以下窗口：

按OK往下运行就行了。接下来会出现一个窗口让你选择安装类型：

Normal Installation：正常安装。一般都使用这个选项。
From Netword：从网络安装。
To Network：安装到网络。

一路“Next”下来，安装就算完毕了。安装完毕后会询问你是否把 Ultraedit 的启动快捷方式加入到开始菜单、桌面或鼠标右键中，然后选择 OK 即可。


UltraEdit的启动和使用

单击开始>程序>UltraEdit>UltraEdit-32 text editor，即可启动 UltraEdit 程序。

也可以通过桌面上的快捷方式打开 UltraEdit-32，如果你没有注册，每次运行时都会有一个注册窗口，上面显示你还可以试用的天数 45 天，等一会这个窗口就会自动消失。

现在你就可以看到UltraEdit完整的界面了。

从这里你可以开始编辑你的东西了。


UltraEdit工具栏介绍

启动UltraEdit后你会看到界面上的工具栏，但这些工具都有些什么用途呢？

用于新建一个文件，可以是一个Txt文件，也可以是十六进制文件，C、HTML等格式的文件；

用于打开一个文件；

关闭已打开文件；

保存正在编辑的文件；

打印文件；

打印预览；

插入一个分页符；

设置是否自动折行；

这个按钮上写个H，作用就是将文件转为十六进制文件；

剪切；

复制；

粘贴；

查找；

向上查找；

向下查找；

替换；

定位，可以跳到某一行或某页；

用于文件切换，向前跳转；

用于文件切换，向后跳转；

将打开的多文件水平平铺；

将打开的文件竖直平铺；

文件层叠；

用浏览器查看当前文件；

提供帮助；

提供在线帮助；


UltraEdit十六进制编辑模式

     UltraEdit具有十六进制编辑功能，编辑二进制代码文件，就不用退回DOS下用古老PCTOOLS了。我们可以打开一个文件，然后选择“Edit”菜单下的“Hex Edit”，文件就变为十六进制的了，做了相应的修改后，你可以用同样的方法将退出十六进制编辑状态。


UltraEdit多文件的查找和替换

    UltraEdit支持多文件的查找替换，所以用起来十分方便。例如，我们要把打开的几个文件中的“../../123.htm”全部替换为“../123.htm”，在选择菜单上的"search”并点击“replace”

那就会弹出如下窗口：

然后分别输入要查找的词和要替换的词（如上图所示）。在“Replace Where”区域中，提供了三个选项，“Current File”是指当前激活的文档，“Selected Text”是指选中的文字，“All Open Files”是指所有打开文件，我们就选这一项，然后点“Replace All”，就开始替换操作，完成操作后会告诉我们一共替换了多少处。


UltraEdit同时编辑多个文件

     如果要同时修改很多文件，可以将要修改的文件全部选中，然后用右键菜单中的“UltraEdit-32”命令如图：

这样可以一次把文件全打开，打开多个文件后，UltraEdit界面显示如下：

在工具条下面会出现文件切换条，你既可以用鼠标单击相应条目来切换文件，也可以按下Ctrl+F6键或Ctrl+Shift+F6键按顺序切换。 这样进行编辑和修改就非常得心应手了。


UltraEdit拼写检查

    我们在编辑文件的时候，经常会有许多外语单词出现，怎样才能检查这些外语单词的拼写是否正确呢？选择“Edit”菜单下的“Spell Check”命令，可以进行拼写检查，这项功能很好用，感觉很象Word。

利用单词库，UltraEdit能检查文章中的每个单词，如果单词库中不包含所书写的单词，会弹出对话框让用户作出相应处理：改正错误或添加新单词。 在第一次使用拼写检查时，如果UltraEdit报告如下错误：说明系统没找到配套的字典文件*.txt。一般从网上下载的UltraEdit都内置了三个字典文件： Html.tlx --超文本语法单词； Autocorr.tlx和Condcorr.tlx--易拼写错误的单词。 UltraEdit支持英文、法文、德文、西班牙文等八种文字的拼写检查，当然前提是你下载了相应的字典文件。


UltraEdit功能详解

Ultraedit 是一个文本编辑器软件，启动速度很快，体积小巧，占用内存较少，编辑功能强大全面。为了更好地介绍它功能，我们分普通功能与特色功能介绍。

（一）普通功能

普通功能就是指它作为一个文本工具所应该具有的功能。

Edit 菜单：恢复/重复操作、剪切和拷贝及粘贴、多项选择、多项删除等全面的编辑功；Date/Time 能在文章中自动加入日期；Toggle Word-Wrap 是类似 Word 的自动换行功能。
Search 菜单：提供了查找、替换功能，换行定位、书签标记、字数统计功能。
Window 菜单：可以将多个编辑框进行有序排列，并在它们之间随意切换，也可通过直接点击编辑框上的标签在各个文本间切换；Show File In Browser 将直接启动默认浏览器，查看用 HTML 语言所编辑的网页的实际效果；直接拖放、文件长度不限制等常规功能。

（二）特色功能

１、Read Only：可以将正在阅读的文件设成只读属性，防止对重要文件进行误操作；
２、拼写检查：Edit\Spell Check提供的拼写检查功能相当好使，感觉很像Word。利用单词库，UltraEdit-32能检查文章中的每个单词，如单词库中不包含所书写的单词，会弹出对话框让用户作出相应处理：改正错词或添加新单词。
在第一次使用拼写检查时，如果 UltraEdit-32 报告 Error opening dictionary C:\PROGRAM FILES\ULTRAEDT\ssceam.tlx，这是因为 UltraEdit-32 没有找到配套的字典文件*.tlx所至。UltraEdit-32总共支持英文、法文、德文、西班牙文等八种文字拼写检查，但是需要你下载安装相应的字典文件。
3、Web 列表功能：这是其他文本编辑工具所不具备的，UltraEdit-32 的这个功能可以很好地对你本机或者通过局域网映射的 Web 站点发布文件进行编辑，大大方便了我们这些经常更新站点的同志，好功能。
4、支持多种文件格式：UltraEdit-32 支持的文件包括：*.TXT、*.DOC、*.BAT、*.INI、C 语言源程序 *.C和*.CPP、头文件 *.H 和 *.HPP、HTML/Java 语言*.HTML、*.HTM、*.JAVA、*.JAV，基本上覆盖了所有的常见文件类型。如果你想让 UltraEdit-32 支持新类型的文件，可以在 Advanced\Configuration…\File Associations 中添加。如果采用默认安装，鼠标右键中会自动添加 UltraEdit-32 项。
使用 File\Conversions 可以展开 UltraEdit-32 的文本格式转换菜单，提供了在 UNIX/MAC 与 DOS、EBCDIC 与 ASCII、OEM 与 ANSI 之间文本的相互转换。
5、宏功能：Macro 菜单下提供了丰富的宏功能处理：宏记录、宏编辑、宏调用等，可以简化文本编辑中经常重复的操作，提高效率。
6、颜色显示：UltraEdit-32 附有 HTML Tag 颜色显示功能，能够对所编辑的文件的标识起到很重要的作用。
7、点击 DOS Command（热键 F9）会弹出 DOS 命令框，可以运行 DOS 指令。如果指令运行后有输出结果，如DIR、MEM、Chkdsk等指令，这些结果便会输出到 UltraEdit-32 的编辑框中。可以使用 UE 的此项功能截取 DOS 下的文本信息。
8、点击 Run Windows Program（热键 F10）会弹出 Windows 程序调用框，可以调用 Windows 应用程序。如果程序有输出结果，同 DOS 命令框一样，这些结果也会输出到 UE 的编辑框去。
9、十六进制编辑模式：现在玩家对 Windows95 下的游戏进行静态修改时，都喜欢以 UltraEdit-32 作为首选工具。使用 Edit\Hex Edit 将以十六进制显示文件，最右边是 ASCII 码形式，UE 的这项功能可以代替 DOS 下 PC Tools 的位置。
10、v8.0 版本增加了许多更新的功能：支持功能列表搜索；整合支持 HTML Tidy；不同项目使用不同工具；功能列表排序选择；允许在工程中添加一组文件；可以不生成临时文件就直接对文档进行操作；添加 Copy-append 和 Cut-append 等剪贴板增强功能；提供文本颜色选择；模板增加到了 50 个。


UltraEdit文件添加与格式转换

     UltraEdit支持的文件包括： *.txt、*.doc、*.Bat、*.ini、（C语言源程序）*.c和*.cpp、头文件*.h和*.hpp、HTML语言*.html和*.htm、JAVA语言*.java和*jav，这些文件类型基本覆盖了所有的常见文件类型。 我们还可以让UltraEdit打开指定类型的文件，添加方法为：单击“Advanced”菜单，选“configuration”，在“File Association”选项卡中可以的添加新的文件类型。

单击“File”菜单下的“Conversions”可以展开UltraEdit的文本格式转换菜单，这里提供了UNIX/MAC与DOS、EBCDIC与ASCII、OEM与ANS等之间文本的相互转换，如图：


UltraEdit宏功能

    在Macro菜单下，提供了丰富的宏功能处理：宏记录、宏编辑、宏调用等，可以简化文本编辑中经常重复的操作，以提供使用效率。


UltraEdit字体显示

    UltraEdit可以支持系统里安装的所有字体，包括中文Windows和其它外挂字体--RichWin、中文之星等软件中所提供的。 如果要选择显示屏幕字体，可以单击“View”菜单，从中选择“Set Font”命令，如果要设置打印字体，可以选择“Set Printer Font”命令。

所有编辑器均能设定不同的字体、大小及风格，并且按照你设定的字体进行打印，唯一不同的是UltraEdit，它的显示字体及打印字体是分开设置的，这就意味着你可以以不同于显示的字体来进行打印，毕竟显示器和打印机有着巨大的差别，显示出来字体好看，打印出来未必就好看。


UltraEdit命令调用

   使用Advanced菜单下的选项，可以在UltraEdit环境下直接调用DOS和Windows命令： 单击DOS Command命令（快捷按键F9），会弹出DOS命令框，我们可以在里面运行DOS命令，比如DIR、MEM等，如下图：

按下OK键后，这些结果便会直接输出到UltraEdit的编辑区中，如下图：

利用这项功能可以截取DOS下的文本信息。单击Run Windows Program命令（快捷按键F10），弹出Windows程序调用框，可以调用Windows应用程序，程序的输出结果也输出到UltraEdit的编辑区中。


UltraEdit如何对文件按列排序

     有时，我们需要对文件的内容按照某列进行排序，比如对一些报表或者数字资料，具体操作步骤如下

     1、 选择菜单“File/Sort/Advanced Sort and Options”，出现列排序设置窗口

     2、 选中“Remove Duplicates”，表示删除掉重复的行内容，保证每行都是唯一的内容

     3、 在“Starting Column”处设置按哪一列进行排序，既可以指定列的数目，也可以按照“光标”所在的列进行排序

     4、 在“sort order”处选择“递增”或者“递减”排序方式

     5、 单击“start”按钮开始执行排序


UltraEdit如何查找关键字

     有时候，我们需要在打开的文件中查找一个关键字，而这个关键字可能在文件中的不同地方出现许多次，利用下面的步骤，可以很好地显示、操作查找的内容。

     1、 选择菜单“Search/Find In Files”，出现“Find In Files”窗口

     2、 在“Find”栏中输入查找的关键字，比如：你好；在“InFiles/Types”处输入想查找的文件类型，比如“*.txt”； 在“Directory”处选择想查找的目录

     3、 单击“Find”按钮，开始查找，完成后出现查找列表窗口

     从窗口可以看到列出了查找结果，查找到几次，就有几行，每行内容包括：查找的文件全路径、查找关键字出现的行数、该行的内容。用鼠标双击某行，在上面的编辑窗口中，光标就会自动定位到相应的行。


UltraEdit如何批量替换多个文件的关键字

有时候，我们需要对某个目录下所有后缀名为txt（或者其他后缀名）的文件进行某个关键字的批量替换，比如：将所有D：*.txt文件中的“你好”关键字替换为“您好”。一般情况下，完成这项工作需要专门的字符串替换程序。但是在UltraEdit中，只需要简单的几步，就能轻松搞定：

     1、 选择菜单“Search/Replace In Files”，出现“Replace In Files”设置窗口

     2、 在“Find”处输入“你好”，在“Replace With：”处输入“您好”，在“InFiles/Types”处输入想处理的文件类型：“*.txt”； 在“Directory”处选择想处理的目录“D:”

     3、 单击“Replace All”按钮，开始将D:*.txt文件进行上述条件的字符串替换。


UltraEdit如何固定显示某列

     当我们想查看一行很长内容的后半部分时，经常需要固定左边的某列，为达到这个目的，就需要设置列标记，步骤如下：

     1、 选择菜单“view/display rule”，在编辑窗口上部显示出横向标尺

     2、 选择菜单“view/Set Column Markers”，出现列标记设置窗口

     3、 在“1st column marker after”栏中输入“17”，单击“OK”

     4、 选择菜单“view/show column marker 1”，再选择菜单“view/no scroll left side of marker1”，经过上面这几步设置，当浏览后边的内容时，最左边的内容就会始终固定显示。


UltraEdit如何添加自定义程序到菜单

     为了更好地在UltraEdit中使用其他应用程序，UltraEdit提供了“添加自定义程序到菜单”的功能。

     比如：将windows自带的计算器添加到菜单中，步骤如下：

     1、 选择菜单“Advanced/Tools Configuration”；

     2、 在“command line”处输入或者选择“C:WINDOWSCalc.exe”，在“Menu Item Name”处输入“计算器”；

     3、 单击“insert”按钮，完成添加；

     现在你会发现在“advanced”菜单下边出现了“计算器”条目，单击它，就调用了计算器程序。其它程序的添加参照此方法就行了。


UltraEdit如何进行删除

直接删除当前打开的文件

    选择菜单“File/Special/Delete Active File”，直接关闭并删除当前编辑的文件。

  行的几种删除方法

    对于一行内容，可能有多种删除的要求，在UltraEdit中，提供了热键，大大地方便了编辑操作。

删除整行

将光标定位于要删除行的任意位置，按“Ctrl+E”，删除本行内容，下面的行依次上移

删除从光标到行首的内容

将光标定位于要删除行，按“Ctrl+F11”，删除本行从光标到行首的所有内容

删除从光标到行尾的内容

将光标定位于要删除行，按“Ctrl+F12”，删除本行从光标到行尾的所有内容

删除所有行尾的空格内容

选择菜单“Format/Trim Trailing Spaces”，删除文件中所有行的尾巴空格


网上UltraEdit

官方网站

http://www.ultraedit.com/

国内网站

洪恩在线

天空软件站

国内下载

天府网

新浪网