PHP 参考手册

w3school 在线教程
  • HTML教程
  • XML教程
  • 浏览器脚本
  • 服务器脚本
  • dot net教程
  • 多媒体教程
  • 建站手册

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 参考手册

  • Next Page

PHP 参考手册

在 W3School，我们为您提供包括所有 PHP 函数的完整参考手册：

  • Array 函数
  • PHP Calendar 函数
  • PHP Date 函数
  • Directory 函数
  • PHP Error 函数
  • Filesystem 函数
  • PHP Filter 函数
  • FTP 函数
  • HTTP 函数
  • LibXML 函数
  • Mail 函数
  • Math 函数
  • MySQL 函数
  • SimpleXML 函数
  • String 函数
  • XML Parser 函数
  • Zip 函数
  • 杂项函数
  • Next Page

PHP 参考手册
PHP 测验

W3School提供的内容仅用于培训。我们不保证内容的正确性。通过使用本站内容随之而来的风险与本站无关。当使用本站时，代表您已接受了本站的使用条款和隐私条款。

版权所有，保留一切权利。未经书面许可，不得转载。W3School 简体中文版的所有内容仅供测试，对任何法律问题及风险不承担任何责任。上海赢科投资有限公司。


PHP __construct() 函数

  • 浏览器脚本
  • 服务器脚本
  • dot net教程
  • 多媒体教程
  • 建站手册

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP __construct() 函数

PHP SimpleXML 函数

定义和用法

__construct() 函数创建一个新的 SimpleXMLElement 对象。

如果成功，则该函数返回一个对象。如果失败，则返回 false。

语法

__construct(data,options,is_url,ns,is_prefix)
参数 | 描述
data | 必需。形式良好的 XML 字符串或 XML 文档的路径或 URL。
options | 可选。规定附加的 Libxml 参数。
is_url | 可选。规定 data 参数是否是 URL。默认是 false。
ns | 可选。
is_prefix | 可选。

返回值

返回一个表示数据的 SimpleXMLElement 对象。

例子

<?php
$xmlstring = <<<XML
<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>
XML;

$xml = new SimpleXMLElement($xmlstring);

echo $xml->body[0];
?>

输出类似：

Don't forget the meeting!

PHP SimpleXML 函数

PHP 参考手册
PHP 测验

W3School提供的内容仅用于培训。我们不保证内容的正确性。通过使用本站内容随之而来的风险与本站无关。当使用本站时，代表您已接受了本站的使用条款和隐私条款。


PHP abs() 函数

  • 多媒体教程
  • 建站手册

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP abs() 函数

PHP Math 函数

定义和用法

abs() 函数返回一个数的绝对值。

语法

abs(x)
参数 | 描述
x | 必需。一个数。

说明

返回参数 x 的绝对值。如果参数 x 是 float，则返回的类型也是 float，否则返回 integer（因为 float 通常比 integer 有更大的取值范围）。

例子

<?php
echo(abs(6.7));
echo(abs(-3));
echo(abs(3));
?>

输出：

6.7
3
3

PHP Math 函数

PHP 参考手册
PHP 测验


PHP acos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP acos() 函数

PHP Math 函数

定义和用法

acos() 函数返回一个数的反余弦。

语法

acos(x)
参数 | 描述
x | 必需。一个数，范围在 -1 到 1 之间。

说明

返回 x 的反余弦值，单位是弧度。acos() 是 cos() 的反函数，它的意思是在 acos() 范围里的每个值都是 a==cos(acos(a)) 。

如果 x 的值在 -1 到 1 之外，则返回 -1.#IND。如果为 -1，则返回 PI 的值。

例子

在本例中，我们将计算不同值的反余弦：

<?php
echo(acos(0.64));
echo(acos(0));
echo(acos(-1));
echo(acos(1));
echo(acos(2));
?>

输出：

0.876298061168
1.57079632679
3.14159265359
0
-1.#IND

PHP Math 函数

PHP 参考手册
PHP 测验


PHP acosh() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP acosh() 函数

PHP Math 函数

定义和用法

acosh() 函数返回一个数的反双曲余弦。

语法

acosh(x)
参数 | 描述
x | 必需。一个数。

说明

返回 x 的反双曲余弦值，即，其双曲余弦为 x 的那个值。

提示和注释

注释：本函数未在 Windows 平台下实现。

PHP Math 函数

PHP 参考手册
PHP 测验


PHP addAttribute() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP addAttribute() 函数

PHP SimpleXML 函数

定义和用法

addAttribute() 函数给 SimpleXML 元素添加一个属性。

该函数无返回值。

语法

class SimpleXMLElement
{
string addAttribute(name,value,ns)
}

参数 | 描述
name | 必需。规定属性的名称。
value | 必需。规定属性的值。
ns | 可选。规定属性的命名空间。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
$xml = simplexml_load_file("test.xml");

$xml->body[0]->addAttribute("type", "small");

foreach($xml->body[0]->attributes() as $a => $b)
  {
  echo $a,'="',$b,'"';
  }
?>

输出：

type="small"

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP addChild() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP addChild() 函数

PHP SimpleXML 函数

定义和用法

addChild() 函数向指定的 XML 节点添加一个子节点。

该函数返回一个 SimpleXMLElement 对象，这个对象表示添加到 XML 节点的子元素。

语法

class SimpleXMLElement
{
string addChild(name,value,ns)
}
参数 | 描述
name | 必需。规定子元素的名称。
value | 必需。规定子元素的值。
ns | 可选。规定子元素的命名空间。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
$xml = simplexml_load_file("test.xml");

$xml->body[0]->addChild("date", "2008-08-08");

foreach ($xml->body->children() as $child)
  {
  echo "Child node: " . $child;
  }
?>

输出：

Child node: 2008-08-08

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP addcslashes() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP addcslashes() 函数

PHP String 函数

定义和用法

addcslashes() 函数在指定的字符前添加反斜杠。

语法

addcslashes(string,characters)
参数 | 描述
string | 必需。规定要检查的字符串。
characters | 可选。规定受 addcslashes() 影响的字符或字符范围。

提示和注释

注释：在对 0，r，n 和 t 应用 addcslashes() 时要小心。在 PHP 中，\0，\r，\n 和 \t 是预定义的转义序列。

例子

例子 1

在本例中，我们要向字符串中的特定字符添加反斜杠：

<?php
$str = "Hello, my name is John Adams.";
echo $str;
echo addcslashes($str,'m');
echo addcslashes($str,'J');
?>

输出：

Hello, my name is John Adams.
Hello, \my na\me is John Ada\ms.
Hello, my name is \John Adams.

例子 2

在本例中，我们要向字符串中的一个范围内的字符添加反斜杠：

<?php
$str = "Hello, my name is John Adams.";
echo $str;
echo addcslashes($str,'A..Z');
echo addcslashes($str,'a..z');
echo addcslashes($str,'a..h');
?>

输出：

Hello, my name is John Adams.
\Hello, my name is \John \Adams.
H\e\l\l\o, \m\y \n\a\m\e \i\s \J\o\h\n \A\d\a\m\s.
H\ello, my n\am\e is Jo\hn A\d\ams.

PHP String 函数

PHP 参考手册
PHP 测验


PHP addslashes() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP addslashes() 函数

PHP String 函数

定义和用法

addslashes() 函数在指定的预定义字符前添加反斜杠。

这些预定义字符是：

  • 单引号 (')
  • 双引号 (")
  • 反斜杠 (\)
  • NULL

语法

addslashes(string)
参数 | 描述
string | 必需。规定要检查的字符串。

提示和注释

提示：该函数可用于为存储在数据库中的字符串以及数据库查询语句准备合适的字符串。

注释：默认情况下，PHP 指令 magic_quotes_gpc 为 on，对所有的 GET、POST 和 COOKIE 数据自动运行 addslashes()。不要对已经被 magic_quotes_gpc 转义过的字符串使用 addslashes()，因为这样会导致双层转义。遇到这种情况时可以使用函数 get_magic_quotes_gpc() 进行检测。

例子

在本例中，我们要向字符串中的预定义添加反斜杠：

<?php
$str = "Who's John Adams?";
echo $str . " This is not safe in a database query.<br />";
echo addslashes($str) . " This is safe in a database query.";
?>

输出：

Who's John Adams? This is not safe in a database query.
Who\'s John Adams? This is safe in a database query.

PHP String 函数

PHP 参考手册
PHP 测验


PHP array_change_key_case() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_change_key_case() 函数

PHP Array 函数

定义和用法

array_change_key_case() 函数将数组的所有的 KEY 都转换为大写或小写。

数组的数字索引不发生变化。如果未提供可选参数（即第二个参数），则默认转换为小写字母。

语法

array_change_key_case(array,case)
参数 | 描述
array | 必需。规定要使用的数组。
case

可选。可能的值：

  • CASE_LOWER - 默认值。以小写字母返回数组的键。
  • CASE_UPPER - 以大写字母返回数组的键。

提示和注释：

注释：如果在运行该函数时两个或多个键相同，则最后的元素会覆盖其他元素（参见例子 2）。

例子 1

<?php
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
print_r(array_change_key_case($a,CASE_UPPER));
?>

输出：

Array ( [A] => Cat [B] => Dog [C] => Horse )

例子 2

<?php
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse","B"=>"Bird");
print_r(array_change_key_case($a,CASE_UPPER));
?>

输出：

Array ( [A] => Cat [B] => Bird [C] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_chunk() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_chunk() 函数

PHP Array 函数

定义和用法

array_chunk() 函数把一个数组分割为新的数组块。

其中每个数组的单元数目由 size 参数决定。最后一个数组的单元数目可能会少几个。

可选参数 preserve_key 是一个布尔值，它指定新数组的元素是否有和原数组相同的键（用于关联数组），还是从 0 开始的新数字键（用于索引数组）。默认是分配新的键。

语法

array_chunk(array,size,preserve_key)
参数 | 描述
array | 必需。规定要使用的数组。
size | 必需。规定每个新数组包含多少个元素。
preserve_key

可选。可能的值：

  • true - 保留原始数组中的键名。
  • false - 默认。每个结果数组使用从零开始的新数组索引。

例子 1

<?php
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse","d"=>"Cow");
print_r(array_chunk($a,2));
?>

输出：

Array (
[0] => Array ( [0] => Cat [1] => Dog )
[1] => Array ( [0] => Horse [1] => Cow )
)

例子 2

<?php
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse","d"=>"Cow");
print_r(array_chunk($a,2,true));
?>

输出：

Array (
[0] => Array ( [a] => Cat [b] => Dog )
[1] => Array ( [c] => Horse [d] => Cow )
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_combine() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_combine() 函数

PHP Array 函数

定义和用法

array_combine() 函数通过合并两个数组来创建一个新数组，其中的一个数组是键名，另一个数组的值为键值。

如果其中一个数组为空，或者两个数组的元素个数不同，则该函数返回 false。

语法

array_combine(array1,array2)
参数 | 描述
array1 | 必需。规定键名。
array2 | 必需。规定值。

提示和注释

注释：两个参数必须有相同数目的元素。

例子

<?php
$a1=array("a","b","c","d");
$a2=array("Cat","Dog","Horse","Cow");
print_r(array_combine($a1,$a2));
?>

输出：

Array ( [a] => Cat [b] => Dog [c] => Horse [d] => Cow )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_count_values() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_count_values() 函数

PHP Array 函数

定义和用法

array_count_values() 函数用于统计数组中所有值出现的次数。

本函数返回一个数组，其元素的键名是原数组的值，键值是该值在原数组中出现的次数。

语法

array_count_values(array)
参数 | 描述
array | 必需。规定输入的数组。

例子

<?php
$a=array("Cat","Dog","Horse","Dog");
print_r(array_count_values($a));
?>

输出：

Array ( [Cat] => 1 [Dog] => 2 [Horse] => 1 )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_diff_assoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_diff_assoc() 函数

PHP Array 函数

定义和用法

array_diff_assoc() 函数返回两个数组的差集数组。该数组包括了所有在被比较的数组中，但是不在任何其他参数数组中的键和值。

和 array_diff() 函数 不同，本函数要求键名和键值都进行比较。返回的数组中键名保持不变。

语法

array_diff_assoc(array1,array2,array3...)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。

提示和注释

提示：可用一个或任意多个数组与第一个数组进行比较。

注释：键和值都用于比较。

例子

<?php
$a1=array(0=>"Cat",1=>"Dog";,2=>"Horse");
$a2=array(0=>"Rat",1=>"Horse";,2=>"Dog");
$a3=array(0=>"Horse",1=>"Dog",2=>"Cat");
print_r(array_diff_assoc($a1,$a2,$a3));
?>

输出：

Array ( [0] => Cat [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_diff_key() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_diff_key() 函数

PHP Array 函数

定义和用法

array_diff_key() 函数返回一个数组，该数组包括了所有在被比较的数组中，但是不在任何其他参数数组中的键。

语法

array_diff_key(array1,array2,array3...)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。

提示和注释

提示：可用一个或任意多个数组与第一个数组进行比较。

注释：仅仅键名用于比较。

例子

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(2=>"Bird",3=>"Rat",4=>"Fish");
$a3=array(5=>"Horse",6=>"Dog",7=>"Bird");
print_r(array_diff_key($a1,$a2,$a3));
?>

输出：

Array ( [0] => Cat [1] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_diff_uassoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_diff_uassoc() 函数

PHP Array 函数

定义和用法

array_diff_uassoc() 函数使用用户自定义的回调函数 (callback) 做索引检查来计算两个或多个数组的差集。返回一个数组，该数组包括了在 array1 中但是不在任何其他参数数组中的值。

注意，与 array_diff() 函数 不同的是，键名也要进行比较。

参数 function 是用户自定义的用来比较两个数组的函数，该函数必须带有两个参数 - 即两个要进行对比的键名。因此与函数 array_diff_assoc() 的行为正好相反，后者是用内部函数进行比较的。

返回的数组中键名保持不变。

语法

array_diff_uassoc(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。
function | 必需。用户自定义函数的名称。

例子 1

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(3=>"Dog",1=>"Cat",5=>"Horse");
print_r(array_diff_uassoc($a1,$a2,"myfunction"));
?>

输出：

Array ( [0] => Dog [2] => Horse )

例子 2

如何为该函数分配多个数组：

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(3=>"Dog",1=>"Cat",5=>"Horse");
$a3=array(6=>"Bird",0=>"Dog",5=>"Horse");
print_r(array_diff_uassoc($a1,$a2,$a3,"myfunction"));
?>

输出：

Array ( [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_diff_ukey() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_diff_ukey() 函数

PHP Array 函数

定义和用法

array_diff_ukey() 返回一个数组，该数组包括了所有出现在 array1 中但是未出现在任何其它参数数组中的键名的值。注意关联关系保留不变。与 array_diff() 不同的是，比较是根据键名而不是值来进行的。

此比较是通过用户提供的回调函数来进行的。如果认为第一个参数小于，等于，或大于第二个参数时必须分别返回一个小于零，等于零，或大于零的整数。

语法

array_diff_ukey(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。
function | 必需。用户自定义函数的名称。

例子 1

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(3=>"Rat",1=>"Bird",5=>"Monkey");
print_r(array_diff_ukey($a1,$a2,"myfunction"));
?>

输出：

Array ( [0] => Dog [2] => Horse )

例子 2

如何为该函数分配多个数组：

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(3=>"Rat",1=>"Bird",5=>"Monkey");
$a3=array(6=>"Dog",7=>"Donkey",0=>"Horse");
print_r(array_diff_ukey($a1,$a2,$a3,"myfunction"));
?>

输出：

Array ( [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_diff() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_diff() 函数

PHP Array 函数

定义和用法

array_diff() 函数返回两个数组的差集数组。该数组包括了所有在被比较的数组中，但是不在任何其他参数数组中的键值。

在返回的数组中，键名保持不变。

语法

array_diff(array1,array2,array3...)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。

提示和注释

提示：可用一个或任意多个数组与第一个数组进行比较。

注释：仅有值用于比较。

例子

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(3=>"Horse",4=>"Dog",5=>"Fish");
print_r(array_diff($a1,$a2));
?>

输出：

Array ( [0] => Cat )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_fill() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_fill() 函数

PHP Array 函数

定义和用法

array_fill() 函数用给定的值填充数组，返回的数组有 number 个元素，值为 value。返回的数组使用数字索引，从 start 位置开始并递增。如果 number 为 0 或小于 0，就会出错。

语法

array_fill(start,number,value)
参数 | 描述
start | 必需。数值，规定键的起始索引。
number | 必需。数值，规定填充的数量，其值必须大于 0。
value | 必需。规定要插入的值。

例子

<?php
$a=array_fill(2,3,"Dog");
print_r($a);
?>

输出：

Array ( [2] => Dog [3] => Dog [4] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_filter() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_filter() 函数

PHP Array 函数

定义和用法

array_filter() 函数用回调函数过滤数组中的元素，如果自定义过滤函数返回 true，则被操作的数组的当前值就会被包含在返回的结果数组中， 并将结果组成一个新的数组。如果原数组是一个关联数组，键名保持不变。

语法

array_filter(array,function)
参数 | 描述
array | 必需。规定输入的数组。
function | 必需。自定义函数的名称。

例子

<?php
function myfunction($v)
{
if ($v==="Horse")
    {
    return true;
    }
return false;
}
$a=array(0=>"Dog",1=>"Cat",2=>"Horse");
print_r(array_filter($a,"myfunction"));
?>

输出：

Array ( [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_flip() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_flip() 函数

PHP Array 函数

定义和用法

array_flip() 函数返回一个反转后的数组，如果同一值出现了多次，则最后一个键名将作为它的值，所有其他的键名都将丢失。

如果原数组中的值的数据类型不是字符串或整数，函数将报错。

语法

array_flip(array)
参数 | 描述
array | 必需。规定输入的数组。

例子

<?php
$a=array(0=>"Dog",1=>"Cat",2=>"Horse");print_r(array_flip($a));
?>

输出：

Array ( [Dog] => 0 [Cat] => 1 [Horse] => 2 )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_intersect_assoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_intersect_assoc() 函数

PHP Array 函数

定义和用法

array_intersect_assoc() 函数返回两个或多个数组的交集数组。

与 array_intersect() 函数 不同的是，本函数除了比较键值，还比较键名。返回的数组中元素的键名保持不变。

语法

array_intersect_assoc(array1,array2,array3...)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。

例子 1

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(3=>"Horse",1=>"Dog",0=>"Cat");
print_r(array_intersect_assoc($a1,$a2));
?>

输出：

Array ( [0] => Cat [1] => Dog )

例子 2

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(3=>"Horse",1=>"Dog",5=>"Fish");
$a3=array(6=>"Cow",1=>"Dog",8=>"Fish");
print_r(array_intersect_assoc($a1,$a2,$a3));
?>

输出：

Array ( [1] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_intersect_key() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_intersect_key() 函数

PHP Array 函数

定义和用法

array_intersect_key() 函数使用键名比较计算数组的交集。

array_intersect_key() 返回一个数组，该数组包含了所有出现在被比较的数组中并同时出现在所有其它参数数组中的键名的值。

注释：仅有键名用于比较。

语法

array_intersect_key(array1,array2,array3...)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。

例子 1

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(2=>"Bird",0=>"Cat",4=>"Fish");
print_r(array_intersect_key($a1,$a2));
?>

输出：

Array ( [0] => Cat [2] => Horse )

例子 2

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(2=>"Bird",3=>"Rat",4=>"Fish");
$a3=array(2=>"Dog",6=>"Cow",7=>"Bird");
print_r(array_intersect_key($a1,$a2,$a3));
?>

输出：

Array ( [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_intersect_uassoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_intersect_uassoc() 函数

PHP Array 函数

定义和用法

array_intersect_uassoc() 函数使用用户自定义的回调函数计算数组的交集，用回调函数比较索引。

array_intersect_uassoc() 返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。返回的数组中键名保持不变。

注意，与 array_intersect() 不同的是除了比较键值，还要比较键名。

此比较是通过用户提供的回调函数来进行的。该函数带有两个参数，即两个要进行对比的键名。如果第一个参数小于第二个参数，则函数要返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个参数，则返回一个正数。

语法

array_intersect_uassoc(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。
function | 用户自定义函数的名称。

例子 1

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(3=>"Dog",1=>"Cat",5=>"Horse");
print_r(array_intersect_uassoc($a1,$a2,"myfunction"));
?>

输出：

Array ( [1] => Cat )

例子 2

如何为函数分配多个数组：

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(0=>"Dog",1=>"Cat",5=>"Horse");
$a3=array(6=>"Bird",0=>"Dog",5=>"Horse");
print_r(array_intersect_uassoc($a1,$a2,$a3,"myfunction"));
?>

输出：

Array ( [0] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_intersect_ukey() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_intersect_ukey() 函数

PHP Array 函数

定义和用法

array_intersect_ukey() 函数用回调函数比较键名来计算数组的交集。

array_intersect_ukey() 返回一个数组，该数组包含了所有出现在 array1 中并同时出现在所有其它参数数组中的键名的值。

此比较是通过用户提供的回调函数来进行的。该函数带有两个参数，即两个要进行对比的键名。如果第一个参数小于第二个参数，则函数要返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个参数，则返回一个正数。

语法

array_intersect_uassoc(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。
function | 用户自定义函数的名称。

例子 1

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(3=>"Rat",1=>"Bird",5=>"Monkey");
print_r(array_intersect_ukey($a1,$a2,"myfunction"));
?>

输出：

Array ( [1] => Cat )

例子 2

如何为函数分配多个数组：

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(0=>"Rat",1=>"Bird",5=>"Monkey");
$a3=array(6=>"Dog",7=>"Donkey",0=>"Horse");
print_r(array_intersect_ukey($a1,$a2,$a3,"myfunction"));
?>

输出：

Array ( [0] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_intersect() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_intersect() 函数

PHP Array 函数

定义和用法

array_intersect() 函数返回两个或多个数组的交集数组。

结果数组包含了所有在被比较数组中，也同时出现在所有其他参数数组中的值，键名保留不变。

注释：仅有值用于比较。

语法

array_intersect(array1,array2,array3...)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。

例子

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(3=>"Horse",4=>"Dog",5=>"Fish");
print_r(array_intersect($a1,$a2));
?>

输出：

Array ( [1] => Dog [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_key_exists() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_key_exists() 函数

PHP Array 函数

定义和用法

array_key_exists() 函数判断某个数组中是否存在指定的 key，如果该 key 存在，则返回 true，否则返回 false。

语法

array_key_exists(key,array)
参数 | 描述
key | 必需。规定键名。
array | 必需。规定输入的数组。

例子 1

<?php
$a=array("a"=>"Dog","b"=>"Cat");
if (array_key_exists("a",$a))
    {
    echo "Key exists!";
    }
else
    {
    echo "Key does not exist!";
    }
?>

输出：

Key exists!

例子 2

<?php
$a=array("a"=>"Dog","b"=>"Cat");
if (array_key_exists("c",$a))
    {
    echo "Key exists!";
    }
else
    {
    echo "Key does not exist!";
    }
?>

输出：

Key does not exist!

例子 2

<?php
$a=array("Dog",Cat");
if (array_key_exists(0,$a))
    {
    echo "Key exists!";
    }
else
    {
    echo "Key does not exist!";
    }
?>

输出：

Key exists!

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_keys() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_keys() 函数

PHP Array 函数

定义和用法

array_keys() 函数返回包含数组中所有键名的一个新数组。

如果提供了第二个参数，则只返回键值为该值的键名。

如果 strict 参数指定为 true，则 PHP 会使用全等比较 (===) 来严格检查键值的数据类型。

语法

array_keys(array,value)
参数 | 描述
array | 必需。规定输入的数组。
value | 可选。指定值的索引（键）。
strict

可选。与 value 参数一起使用。可能的值：

  • true - 根据类型返回带有指定值的键名。
  • false - 默认值。不依赖类型。

例子 1

<?php
$a=array("a"=>"Horse","b"=>"Cat","c"=>"Dog");
print_r(array_keys($a));
?>

输出：

Array ( [0] => a [1] => b [2] => c )

例子 2

使用 value 参数：

<?php
$a=array("a"=>"Horse","b"=>"Cat","c"=>"Dog");
print_r(array_keys($a,"Dog"));
?>

输出：

Array ( [0] => c)

例子 3

使用 strict 参数 (false)：

<?php
$a=array(10,20,30,"10");
print_r(array_keys($a,"10",false));
?>

输出：

Array ( [0] => 0 [1] => 3 )

例子 4

使用 strict 参数 (true)：

<?php
$a=array(10,20,30,"10");
print_r(array_keys($a,"10",true));
?>

输出：

Array ( [0] => 3)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_map() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_map() 函数

PHP Array 函数

定义和用法

array_map() 函数返回用户自定义函数作用后的数组。回调函数接受的参数数目应该和传递给 array_map() 函数的数组数目一致。

语法

array_map(function,array1,array2,array3...)
参数 | 描述
function | 必需。用户自定义函数的名称，或者是 null。
array1 | 必需。规定数组。
array2 | 可选。规定数组。
array3 | 可选。规定数组。

例子 1

<?php
function myfunction($v)
{
if ($v==="Dog")
    {
    return "Fido";
    }
return $v;
}
$a=array("Horse","Dog","Cat");
print_r(array_map("myfunction",$a));
?>

输出：

Array ( [0] => Horse [1] => Fido [2] => Cat )

例子 2

使用多个参数：

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return "same";
    }
return "different";
}
$a1=array("Horse","Dog","Cat");
$a2=array("Cow","Dog","Rat");
print_r(array_map("myfunction",$a1,$a2));
?>

输出：

Array ( [0] => different [1] => same [2] => different )

例子 3

请看当自定义函数名设置为 null 时的情况：

<?php
$a1=array("Dog","Cat");
$a2=array("Puppy","Kitten");
print_r(array_map(null,$a1,$a2));
?>

输出：

Array (
[0] => Array ( [0] => Dog [1] => Puppy )
[1] => Array ( [0] => Cat [1] => Kitten )
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_merge_recursive() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_merge_recursive() 函数

PHP Array 函数

定义和用法

array_merge_recursive() 函数与 array_merge() 函数 一样，将一个或多个数组的元素的合并起来，一个数组中的值附加在前一个数组的后面。并返回作为结果的数组。

但是，与 array_merge() 不同的是，当有重复的键名时，值不会被覆盖，而是将多个相同键名的值递归组成一个数组。（参见例子 1）

语法

array_merge_recursive(array1,array2,array3...)
参数 | 描述
array1 | 必需。输入的第一个数组。
array2 | 必需。输入的第二个数组。
array3 | 可选。可指定的多个输入数组。

提示和注释

注释：当向 array_merge_recursive() 函数仅仅输入一个数组时，结果与 array_merge() 相同。

例子 1

<?php
$a1=array("a"=>"Horse","b"=>"Dog");
$a2=array("c"=>"Cow","b"=>"Cat");
print_r(array_merge_recursive($a1,$a2));
?>

输出：

Array (
[a] => Horse
[b] => Array ( [0] => Dog [1] => Cat )
[c] => Cow
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_merge() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_merge() 函数

PHP Array 函数

定义和用法

array_merge() 函数把两个或多个数组合并为一个数组。

如果键名有重复，该键的键值为最后一个键名对应的值（后面的覆盖前面的）。如果数组是数字索引的，则键名会以连续方式重新索引。

注释：如果仅仅向 array_merge() 函数输入了一个数组，且键名是整数，则该函数将返回带有整数键名的新数组，其键名以 0 开始进行重新索引。（参见例子 2）

语法

array_merge(array1,array2,array3...)
参数 | 描述
array1 | 必需。输入的第一个数组。
array2 | 必需。输入的第二个数组。
array3 | 可选。可指定的多个输入数组。

例子 1

<?php
$a1=array("a"=>"Horse","b"=>"Dog");
$a2=array("c"=>"Cow","b"=>"Cat");
print_r(array_merge($a1,$a2));
?>

输出：

Array ( [a] => Horse [b] => Cat [c] => Cow )

例子 2

仅使用一个数组参数：

<?php
$a=array(3=>"Horse",4=>"Dog");
print_r(array_merge($a));
?>

输出：

Array ( [0] => Horse [1] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_multisort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_multisort() 函数

PHP Array 函数

定义和用法

array_multisort() 函数对多个数组或多维数组进行排序。

参数中的数组被当成一个表的列并以行来进行排序 - 这类似 SQL 的 ORDER BY 子句的功能。第一个数组是要排序的主要数组。数组中的行（值）比较为相同的话，就会按照下一个输入数组中相应值的大小进行排序，依此类推。

第一个参数是数组，随后的每一个参数可能是数组，也可能是下面的排序顺序标志（排序标志用于更改默认的排列顺序）之一：

  • SORT_ASC - 默认，按升序排列。(A-Z)
  • SORT_DESC - 按降序排列。(Z-A)

随后可以指定排序的类型：

  • SORT_REGULAR - 默认。将每一项按常规顺序排列。
  • SORT_NUMERIC - 将每一项按数字顺序排列。
  • SORT_STRING - 将每一项按字母顺序排列。

语法

array_multisort(array1,sorting order,sorting type,array2,array3...)
参数 | 描述
array1 | 必需。规定输入的数组。
sorting order | 可选。规定排列顺序。可能的值是 SORT_ASC 和 SORT_DESC。
sorting type | 可选。规定排序类型。可能的值是SORT_REGULAR、SORT_NUMERIC和SORT_STRING。
array2 | 可选。规定输入的数组。
array3 | 可选。规定输入的数组。

提示和注释

注释：字符串键名将被保留，但是数字键将被重新索引，从 0 开始，并以 1 递增。

注释：您可以在每个数组后设置排序顺序和排序类型。如果没有设置，每个数组参数会使用默认值。

例子 1

<?php
$a1=array("Dog","Cat");
$a2=array("Fido","Missy");
array_multisort($a1,$a2);
print_r($a1);
print_r($a2);
?>

输出：

Array ( [0] => Cat [1] => Dog )
Array ( [0] => Missy [1] => Fido )

例子 2

当两个值相同时如何排序：

<?php
$a1=array("Dog","Dog","Cat");
$a2=array("Pluto","Fido","Missy");
array_multisort($a1,$a2);
print_r($a1);
print_r($a2);
?>

输出：

Array ( [0] => Cat [1] => Dog [2] => Dog )
Array ( [0] => Missy [1] => Fido [2] => Pluto )

例子 3

带有排序参数：

<?php
$a1=array("Dog","Dog","Cat");
$a2=array("Pluto","Fido","Missy");
array_multisort($a1,SORT_ASC,$a2,SORT_DESC);
print_r($a1);
print_r($a2);
?>

输出：

Array ( [0] => Cat [1] => Dog [2] => Dog )
Array ( [0] => Missy [1] => Pluto [2] => Fido )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_pad() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_pad() 函数

PHP Array 函数

定义和用法

array_pad() 函数向一个数组插入带有指定值的指定数量的元素。

语法

array_pad(array,size,value)
参数 | 描述
array | 必需。规定数组。
size | 必需。指定的长度。整数则填补到右侧，负数则填补到左侧。
value | 必需。用来填补的值。

提示和注释

提示：如何设置了负的长度值，该函数会在原始数组之前插入新的元素。（参见例子 2）

注释：如果 size 参数小于原始数组的长度，该函数不会删除任何元素。

例子 1

<?php
$a=array("Dog","Cat");
print_r(array_pad($a,5,0));
?>

输出：

Array ( [0] => Dog [1] => Cat [2] => 0 [3] => 0 [4] => 0 )

例子 2

带有负的 size 参数：

<?php
$a=array("Dog","Cat");
print_r(array_pad($a,-5,0));
?>

输出：

Array ( [0] => 0 [1] => 0 [2] => 0 [3] => Dog [4] => Cat )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_pop() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_pop() 函数

PHP Array 函数

定义和用法

array_pop() 函数删除数组中的最后一个元素。

语法

array_pop(array)
参数 | 描述
array | 必需。规定输入的数组参数。

例子

<?php
$a=array("Dog","Cat","Horse");
array_pop($a);
print_r($a);
?>

输出：

Array ( [0] => Dog [1] => Cat )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_product() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_product() 函数

PHP Array 函数

定义和用法

array_product() 函数计算并返回数组中所有值的乘积。

语法

array_product(array)
参数 | 描述
array | 必需。规定输入的数组参数。

例子

<?php
$a=array(5,5);
echo(array_product($a));
?>

输出：

25

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_push() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_push() 函数

PHP Array 函数

定义和用法

array_push() 函数向第一个参数的数组尾部添加一个或多个元素（入栈），然后返回新数组的长度。

该函数等于多次调用 $array[] = $value。

语法

array_push(array,value1,value2...)
参数 | 描述
array | 必需。规定一个数组。
value1 | 必需。规定要添加的值。
value2 | 可选。规定要添加的值。

提示和注释

注释：即使数组中有字符串键名，您添加的元素也始终是数字键。（参见例子 2）

注释：如果用 array_push() 来给数组增加一个单元，还不如用 $array[] =，因为这样没有调用函数的额外负担。

注释：如果第一个参数不是数组，array_push() 将发出一条警告。这和 $var[] 的行为不同，后者会新建一个数组。

例子 1

<?php
$a=array("Dog","Cat");
array_push($a,"Horse","Bird");
print_r($a);
?>

输出：

Array ( [0] => Dog [1] => Cat [2] => Horse [3] => Bird )

例子 2

带有字符串键的数组：

<?php
$a=array("a"=>"Dog","b"=>"Cat");
array_push($a,"Horse","Bird");
print_r($a);
?>

输出：

Array ( [a] => Dog [b] => Cat [0] => Horse [1] => Bird )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_rand() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_rand() 函数

PHP Array 函数

定义和用法

array_rand() 函数从数组中随机选出一个或多个元素，并返回。

第二个参数用来确定要选出几个元素。如果选出的元素不止一个，则返回包含随机键名的数组，否则返回该元素的键名。

注释：自 PHP 4.2.0 起，不再需要用 srand() 或 mt_srand() 函数给随机数发生器播种，现已被自动完成。

语法

array_rand(array,number)
参数 | 描述
array | 必需。规定输入的数组参数。
number | 可选。默认是 1。规定返回多少个随机的元素。

例子 1

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse");
print_r(array_rand($a,1));
?>

输出：

b

例子 2

带有字符串键的数组：

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse");
print_r(array_rand($a,2));
?>

输出：

Array ( [0] => c [1] => b )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_reduce() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_reduce() 函数

PHP Array 函数

定义和用法

array_reduce() 函数用回调函数迭代地将数组简化为单一的值。如果指定第三个参数，则该参数将被当成是数组中的第一个值来处理，或者如果数组为空的话就作为最终返回值。

语法

array_reduce(array,function,initial)
参数 | 描述
array | 必需。规定输入的数组。
function | 必需。规定自定义回调函数的名称。
initial | 可选。如果规定了该参数，该参数将作为数组中的第一个值来处理。

例子 1

<?php
function myfunction($v1,$v2)
{
return $v1 . "-" . $v2;
}
$a=array("Dog","Cat","Horse");
print_r(array_reduce($a,"myfunction"));
?>

输出：

-Dog-Cat-Horse

例子 2

带有 initial 参数：

<?php
function myfunction($v1,$v2)
{
return $v1 . "-" . $v2;
}
$a=array("Dog","Cat","Horse");
print_r(array_reduce($a,"myfunction",5));
?>

输出：

5-Dog-Cat-Horse

例子 3

返回总和：

<?php
function myfunction($v1,$v2)
{
return $v1+$v2;
}
$a=array(10,15,20);
print_r(array_reduce($a,"myfunction",5));
?>

输出：

50

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_reverse() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_reverse() 函数

PHP Array 函数

定义和用法

array_reverse() 函数将原数组中的元素顺序翻转，创建新的数组并返回。如果第二个参数指定为 true，则元素的键名保持不变，否则键名将丢失。

语法

array_reverse(array,preserve)
参数 | 描述
array | 必需。规定数组。
preserve | 可选。规定是否保留原始数组的键名。可能的值：true 和 false。 这个参数是 PHP 4.0.3 中新加的。

例子

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse");
print_r(array_reverse($a));
?>

输出：

Array ( [c] => Horse [b] => Cat [a] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_search() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_search() 函数

PHP Array 函数

定义和用法

array_search() 函数与 in_array() 一样，在数组中查找一个键值。如果找到了该值，匹配元素的键名会被返回。如果没找到，则返回 false。

在 PHP 4.2.0 之前，函数在失败时返回 null 而不是 false。

如果第三个参数 strict 被指定为 true，则只有在数据类型和值都一致时才返回相应元素的键名。

语法

array_search(value,array,strict)
参数 | 描述
value | 必需。规定在数组中搜索的值。
array | 必需。被搜索的数组。
strict

可选。可能的值：

  • true
  • false - 默认

如果值设置为 true，还将在数组中检查给定值的类型。（参见例子 2）

例子 1

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse");
echo array_search("Dog",$a);
?>

输出：

a

例子 2

<?php
$a=array("a"=>"5","b"=>5,"c"=>"5");
echo array_search(5,$a,true);
?>

输出：

b

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_shift() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_shift() 函数

PHP Array 函数

定义和用法

array_shift() 函数删除数组中的第一个元素，并返回被删除元素的值。

注释：如果键是数字的，所有元素都将获得新的键，从 0 开始，并以 1 递增。（参见例子 2）。

语法

array_shift(array)
参数 | 描述
array | 必需。规定输入的数组。

例子 1

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse");
echo array_shift($a);
print_r ($a);
?>

输出：

Dog
Array ( [b] => Cat [c] => Horse )

例子 2

带有数字键：

<?php
$a=array(0=>"Dog",1=>"Cat",2=>"Horse");
echo array_shift($a);
print_r ($a);
?>

输出：

Dog
Array ( [0] => Cat [1] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_slice() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_slice() 函数

PHP Array 函数

定义和用法

array_slice() 函数在数组中根据条件取出一段值，并返回。

注释：如果数组有字符串键，所返回的数组将保留键名。（参见例子 4）

语法

array_slice(array,offset,length,preserve)
参数 | 描述
array | 必需。规定输入的数组。
offset

必需。数值。规定取出元素的开始位置。

如果是正数，则从前往后开始取，如果是负值，从后向前取 offset 绝对值。
length

可选。数值。规定被返回数组的长度。

如果是负数，则从后向前，选取该值绝对值数目的元素。如果未设置该值，则返回所有元素。
preserve

可选。可能的值：

  • true - 保留键
  • false - 默认 - 重置键

例子 1

<?php
$a=array(0=>"Dog",1=>"Cat",2=>"Horse",3=>"Bird");
print_r(array_slice($a,1,2));
?>

输出：

Array ( [0] => Cat [1] => Horse )

例子 2

带有负的 offset 参数：

<?php
$a=array(0=>"Dog",1=>"Cat",2=>"Horse",3=>"Bird");
print_r(array_slice($a,-2,1));
?>

输出：

Array ( [0] => Horse )

例子 3

preserve 参数设置为 true：

<?php
$a=array(0=>"Dog",1=>"Cat",2=>"Horse",3=>"Bird");
print_r(array_slice($a,1,2,true));
?>

输出：

Array ( [1] => Cat [2] => Horse )

例子 4

带有字符串键：

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse","d"=>"Bird");
print_r(array_slice($a,1,2));
?>

输出：

Array ( [b] => Cat [c] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_splice() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_splice() 函数

PHP Array 函数

定义和用法

array_splice() 函数与 array_slice() 函数类似，选择数组中的一系列元素，但不返回，而是删除它们并用其它值代替。

如果提供了第四个参数，则之前选中的那些元素将被第四个参数指定的数组取代。

最后生成的数组将会返回。

语法

array_splice(array,offset,length,array)
参数 | 描述
array | 必需。规定数组。
offset | 必需。数值。如果 offset 为正，则从输入数组中该值指定的偏移量开始移除。如果 offset 为负，则从输入数组末尾倒数该值指定的偏移量开始移除。
length | 可选。数值。如果省略该参数，则移除数组中从 offset 到 结尾的所有部分。如果指定了 length 并且为正值，则移除这么多元素。如果指定了 length 且为负值，则移除从 offset 到数组末尾倒数 length 为止中间所有的元素。
array | 被移除的元素由此数组中的元素替代。如果没有移除任何值，则此数组中的元素将插入到指定位置。

提示和注释

提示：如果函数没有删除任何元素 (length=0)，则替代数组将从 start 参数的位置插入。（参见例子 3）

注释：不保留替代数组中的键。

例子 1

<?php
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse",3=>"Bird");
$a2=array(0=>"Tiger",1=>"Lion");
array_splice($a1,0,2,$a2);
print_r($a1);
?>

输出：

Array ( [0] => Tiger [1] => Lion [2] => Horse [3] => Bird )

例子 2

与例子 1 相同，但是输出返回的数组：

<?php
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse",3=>"Bird");
$a2=array(0=>"Tiger",1=>"Lion");
print_r(array_splice($a1,0,2,$a2));
?>

输出：

Array ( [0] => Dog [1] => Cat )

例子 3

length 参数设置为 0：

<?php
$a1=array(0=>"Dog",1=>"Cat");
$a2=array(0=>"Tiger",1=>"Lion");
array_splice($a1,1,0,$a2);
print_r($a1);
?>

输出：

Array ( [0] => Dog [1] => Tiger [2] => Lion [3] => Cat )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_sum() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_sum() 函数

PHP Array 函数

定义和用法

array_sum() 函数返回数组中所有值的总和。

如果所有值多是整数，则返回一个整数值。如果其中有一个或多个值是浮点数，则返回浮点数。

PHP 4.2.1 之前的版本修改了传入的数组本身，将其中的字符串值转换成数值（大多数情况下都转换成了零，根据具体制而定）。

语法

array_sum(array)
参数 | 描述
array | 必需。规定输入的数组。

例子

<?php
$a=array(0=>"5",1=>"15",2=>"25");
echo array_sum($a);
?>

输出：

45

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_udiff_assoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_udiff_assoc() 函数

PHP Array 函数

定义和用法

array_udiff_assoc() 函数返回 array1 中存在但其它数组中都不存在的部分。

注意与 array_diff() 以及 array_udiff() 不同的是键名也用于比较。同时进行键名和键值的比较。如 "a"=>1 和 "b"=>1 这两个元素是不相等的。

数组数据的比较是用用户提供的回调函数进行的。在此方面和 array_diff_assoc() 的行为正好相反，后者是用内部函数进行比较的。

array_udiff_assoc() 函数的 function 参数指定的函数用于比较元素是否相等。function 函数带有两个将进行比较的参数。如果第一个参数小于第二个参数，则函数返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个，则返回一个正数。

语法

array_udiff_assoc(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。被比较的数组。
array2 | 必需。用来做比较的数组。
array3 | 可选。用来做比较的数组，可有多个。
function | 可选。自定义的比较回调函数。

例子

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}
$a1=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
$a2=array("a"=>"Cat","b"=>"Horse","c"=>"Dog");
print_r(array_udiff_assoc($a1,$a2,"myfunction"));
?>

输出：

Array ( [b] => Dog [c] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_udiff_uassoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_udiff_uassoc() 函数

PHP Array 函数

定义和用法

array_udiff_uassoc() 函数返回 array1 数组中存在但其它数组中都不存在的部分。返回的数组中键名保持不变。

注意与 array_diff() 以及 array_udiff() 不同的是键名也用于比较。同时进行键名和键值的比较，如 "a"=>1 和 "b"=>1 这两个元素是不相等的。

对键名（索引）的检查也是由回调函数 function1 进行的。这和 array_udiff_assoc() 的行为不同，后者是用内部函数比较索引的。

数组数据的比较是使用用户提供的回调函数 function2 进行的。在此方面和 array_diff_assoc() 的行为正好相反，后者是用内部函数进行比较的。

这两个函数都带有两个将进行比较的参数。如果第一个参数小于第二个参数，则函数返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个，则返回一个正数。

语法

array_udiff_uassoc(array1,array2,array3...,function1,function2)
参数 | 描述
array1 | 必需。被比较的数组。
array2 | 必需。用来做比较的数组。
array3 | 可选。用来做比较的数组，可有多个。
function1 | 必需。比较键名的自定义函数。
function2 | 必需。比较值的自定义函数。

注释：function1 指定的函数用于比较键名是否相等。function2 指定的函数用于比较键值是否相等。

例子

<?php
function myfunction_key($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}
function myfunction_value($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}
$a1=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
$a2=array("a"=>"Cat","b"=>"Dog","c"=>"Fish");
print_r(array_udiff_uassoc($a1,$a2,"myfunction_key","myfunction_value"));
?>

输出：

Array ( [c] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_udiff() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_udiff() 函数

PHP Array 函数

定义和用法

array_udiff() 函数返回一个数组，该数组包括了所有在被比较数组中，但是不在任何其它参数数组中的值，键名保留不变。

array_udiff() 函数与 array_diff() 函数 的行为不同，后者用内部函数进行比较。

数据的比较是用 array_udiff() 函数的 function 进行的。function 函数带有两个将进行比较的参数。如果第一个参数小于第二个参数，则函数返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个，则返回一个正数。

语法

array_udiff(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。被比较的数组。
array2 | 必需。用来做比较的数组。
array3 | 可选。用来做比较的数组，可有多个。
function | 可选。自定义的比较回调函数。

注释和提示

注释：该函数只进行键值的比较，不比较键名。如 "a"=>1 和 "b"=>1 这两个元素视作相等的。

注释：array_udiff() 函数仅检查多维数组中的一维。

例子

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}
$a1=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
$a2=array(1=>"Cat",2=>"Dog",3=>"Fish");
print_r(array_udiff($a1,$a2,"myfunction"));
?>

输出：

Array ( [c] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_uintersect_assoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_uintersect_assoc() 函数

PHP Array 函数

定义和用法

array_uintersect_assoc() 函数带索引检查计算数组的交集，用回调函数比较数据。

array_uintersect_assoc() 返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。

注意，与 array_uintersect() 不同的是键名也要比较。数据（键值）是用回调函数比较的。

语法

array_uintersect_assoc(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。被比较的数组。
array2 | 必需。用来做比较的数组。
array3 | 可选。用来做比较的数组，可有多个。
function | 必需。自定义函数的名称。

说明

使用用户自定义的回调函数 function 来计算两个或多个数组的交集（即在 array1 中存在，同时也在其它任何数组中存在的所有数组元素），并返回结果数组。

同时进行键名和键值的比较，如 "a"=>1 和 "b"=>1 这两个元素是不相等的。

function 参数指定的函数用于比较元素是否相等。function 函数带有两个将进行比较的参数。如果第一个参数小于第二个参数，则函数返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个，则返回一个正数。

返回的数组中键名保持不变。

例子

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}
$a1=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
$a2=array("a"=>"Cat","b"=>"Horse","c"=>"Dog");
print_r(array_uintersect_assoc($a1,$a2,"myfunction"));
?>

输出：

Array ( [a] => Cat )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_uintersect_uassoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_uintersect_uassoc() 函数

PHP Array 函数

定义和用法

array_uintersect_uassoc 函数带索引检查计算数组的交集，用回调函数来比较数据和索引。

array_uintersect_uassoc() 返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。

注意，与 array_uintersect() 不同的是键名也要比较。键值和键名（索引）都是用回调函数比较的。

语法

array_uintersect_uassoc(array1,array2,array3...,function1,function2)
参数 | 描述
array1 | 必需。被比较的数组。
array2 | 必需。用来做比较的数组。
array3 | 可选。用来做比较的数组，可有多个。
function1 | 必需。比较键名的自定义函数。
function2 | 必需。比较键值的自定义函数。

说明

使用用户自定义的回调函数 function1 和 function2 来计算两个或多个数组的交集（即在 array1 中存在，同时也在其它任何数组中存在的所有数组元素），并返回结果数组。

同时进行键名和键值的比较，如 "a"=>1 和 "b"=>1 这两个元素是不相等的。

function1 指定的函数用于比较键名是否相等。function2 指定的函数用于比较键值是否相等。这两个函数都带有两个将进行比较的参数。如果第一个参数小于第二个参数，则函数返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个，则返回一个正数。

返回的数组中键名保持不变。

例子

<?php
function myfunction_key($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}

function myfunction_value($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}
$a1=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
$a2=array("a"=>"Cat","b"=>"Dog","c"=>"Dog");
print_r(array_uintersect_uassoc($a1,$a2,"myfunction_key","myfunction_value"));
?>

输出：

Array ( [a] => Cat [b] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_uintersect() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_uintersect() 函数

PHP Array 函数

定义和用法

array_uintersect() 函数计算数组的交集，用回调函数比较数据。

array_uintersect() 返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。数据（键值）比较是用回调函数进行的。

语法

array_uintersect(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。被比较的数组。
array2 | 必需。用来做比较的数组。
array3 | 可选。用来做比较的数组，可有多个。
function | 必需。自定义函数的名称。

说明

使用用户自定义的回调函数 function 来计算两个或多个数组的交集（即在 array1 中存在同时也在其它任何数组中存在的所有数组元素），并返回结果数组。

只进行键值的比较，不比较键名，如 "a"=>1 和 "b"=>1 这两个元素视作相等的。

function 参数指定的函数用于比较元素是否相等。function 函数带有两个将进行比较的参数。如果第一个参数小于第二个参数，则函数返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个，则返回一个正数。

返回的数组中键名保持不变。

例子

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
  {
  return 0;
  }
if ($v1 > $v2) return 1;
  {
  return -1;
  }
return 1;
}
$a1=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
$a2=array(1=>"Cat",2=>"Dog",3=>"Fish");
print_r(array_uintersect($a1,$a2,"myfunction"));
?>

输出：

Array ( [a] => Cat [b] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_unique() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_unique() 函数

PHP Array 函数

定义和用法

array_unique() 函数移除数组中的重复的值，并返回结果数组。

当几个数组元素的值相等时，只保留第一个元素，其他的元素被删除。

返回的数组中键名不变。

语法

array_unique(array)
参数 | 描述
array | 必需。规定输入的数组。

说明

array_unique() 先将值作为字符串排序，然后对每个值只保留第一个遇到的键名，接着忽略所有后面的键名。这并不意味着在未排序的 array 中同一个值的第一个出现的键名会被保留。

提示和注释

注释：被返回的数组将保持第一个数组元素的键类型。

例子

<?php
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Cat");
print_r(array_unique($a));
?>

输出：

Array ( [a] => Cat [b] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_unshift() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_unshift() 函数

PHP Array 函数

定义和用法

array_unshift() 函数在数组开头插入一个或多个元素。

被加上的元素作为一个整体添加，这些元素在数组中的顺序和在参数中的顺序一样。

该函数会返回数组中元素的个数。

语法

array_unshift(array,value1,value2,value3...)
参数 | 描述
array | 必需。规定输入的数组。
value1 | 必需。规定插入的值。
value2 | 可选。规定插入的值。
value3 | 可选。规定插入的值。

提示和注释

注释：所有的数值键名将修改为从零开始重新计数，所有的字符串键名保持不变。

例子 1

<?php
$a=array("a"=>"Cat","b"=>"Dog");
array_unshift($a,"Horse");
print_r($a);
?>

输出：

Array ( [0] => Horse [a] => Cat [b] => Dog )

例子 2

返回键值：

<?php
$a=array("a"=>"Cat","b"=>"Dog");
print_r(array_unshift($a,"Horse"));
?>

输出：

3

例子 3

数组带有数值键：

<?php
$a=array(0=>"Cat",1=>"Dog");
array_unshift($a,"Horse");
print_r($a);
?>

输出：

Array ( [0] => Horse [1] => Cat [2] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_values() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_values() 函数

PHP Array 函数

定义和用法

array_values() 函数返回一个包含给定数组中所有键值的数组，但不保留键名。

语法

array_values(array)
参数 | 描述
array | 必需。规定给定的数组。

提示和注释

提示：被返回的数组将使用数值键，从 0 开始且以 1 递增。

例子

<?php
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
print_r(array_values($a));
?>

输出：

Array ( [0] => Cat [1] => Dog [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_walk_recursive() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_walk_recursive() 函数

PHP Array 函数

定义和用法

与 array_walk() 函数 类似，array_walk_recursive() 函数对数组中的每个元素应用回调函数。不一样的是，如果原数组中的元素也是数组，就会递归地调用回调函数，也就是说，会递归到更深层的数组中去。

典型情况下，function 接受两个参数。array 参数的值作为第一个，键名作为第二个。如果提供了可选参数 userdata ，将被作为第三个参数传递给回调函数。

如果回调函数需要直接作用于数组中的值，可以将回调函数的第一个参数指定为引用，这样对这些单元的任何改变也将会改变原始数组本身。

语法

array_walk_recursive(array,function,userdata)
参数 | 描述
array | 必需。规定数组。
function | 必需。用户自定义函数的名称。
userdata | 可选。用户输入的值，可作为回调函数的参数。

例子

<?php
function myfunction($value,$key)
{
echo "The key $key has the value $value<br />";
}
$a1=array("a"=>"Cat","b"=>"Dog");
$a2=array($a1,"1"=>"Bird","2"=>"Horse");
array_walk_recursive($a2,"myfunction");
?>

输出：

The key a has the value Cat
The key b has the value Dog
The key 1 has the value Bird
The key 2 has the value Horse

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_walk() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_walk() 函数

PHP Array 函数

定义和用法

array_walk() 函数对数组中的每个元素应用回调函数。如果成功则返回 TRUE，否则返回 FALSE。

典型情况下 function 接受两个参数。array 参数的值作为第一个，键名作为第二个。如果提供了可选参数 userdata ，将被作为第三个参数传递给回调函数。

如果 function 函数需要的参数比给出的多，则每次 array_walk() 调用 function 时都会产生一个 E_WARNING 级的错误。这些警告可以通过在 array_walk() 调用前加上 PHP 的错误操作符 @ 来抑制，或者用 error_reporting()。

语法

array_walk(array,function,userdata...)
参数 | 描述
array | 必需。规定数组。
function | 必需。用户自定义函数的名称。
userdata | 可选。用户输入的值，可作为回调函数的参数。

提示和注释

提示：您可以为函数设置一个或多个参数。

注释：如果回调函数需要直接作用于数组中的值，可以将回调函数的第一个参数指定为引用：&$value。（参见例子 3）

注释：将键名和 userdata 传递到 function 中是 PHP 4.0 新增加的。

例子 1

<?php
function myfunction($value,$key)
{
echo "The key $key has the value $value<br />";
}
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
array_walk($a,"myfunction");
?>

输出：

The key a has the value Cat
The key b has the value Dog
The key c has the value Horse

例子 2

带有一个参数：

<?php
function myfunction($value,$key,$p)
{
echo "$key $p $value<br />";
}
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
array_walk($a,"myfunction","has the value");
?>

输出：

a has the value Cat
b has the value Dog
c has the value Horse

例子 3

改变数组元素的值（请注意 &$value）：

<?php
function myfunction(&$value,$key)
{
$value="Bird;
}
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
array_walk($a,"myfunction");
print_r($a);
?>

输出：

Array ( [a] => Bird [b] => Bird [c] => Bird )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP Array 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Array 函数

  • Previous Page
  • Next Page

PHP Array 简介

array 函数允许您对数组进行操作。

PHP 支持单维和多维的数组。同时提供了用数据库查询结果来构造数组的函数。

安装

array 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP Array 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
array() | 创建数组。 | 3
array_change_key_case() | 返回其键均为大写或小写的数组。 | 4
array_chunk() | 把一个数组分割为新的数组块。 | 4
array_combine() | 通过合并两个数组来创建一个新数组。 | 5
array_count_values() | 用于统计数组中所有值出现的次数。 | 4
array_diff() | 返回两个数组的差集数组。 | 4
array_diff_assoc() | 比较键名和键值，并返回两个数组的差集数组。 | 4
array_diff_key() | 比较键名，并返回两个数组的差集数组。 | 5
array_diff_uassoc() | 通过用户提供的回调函数做索引检查来计算数组的差集。 | 5
array_diff_ukey() | 用回调函数对键名比较计算数组的差集。 | 5
array_fill() | 用给定的值填充数组。 | 4
array_filter() | 用回调函数过滤数组中的元素。 | 4
array_flip() | 交换数组中的键和值。 | 4
array_intersect() | 计算数组的交集。 | 4
array_intersect_assoc() | 比较键名和键值，并返回两个数组的交集数组。 | 4
array_intersect_key() | 使用键名比较计算数组的交集。 | 5
array_intersect_uassoc() | 带索引检查计算数组的交集，用回调函数比较索引。 | 5
array_intersect_ukey() | 用回调函数比较键名来计算数组的交集。 | 5
array_key_exists() | 检查给定的键名或索引是否存在于数组中。 | 4
array_keys() | 返回数组中所有的键名。 | 4
array_map() | 将回调函数作用到给定数组的单元上。 | 4
array_merge() | 把一个或多个数组合并为一个数组。 | 4
array_merge_recursive() | 递归地合并一个或多个数组。 | 4
array_multisort() | 对多个数组或多维数组进行排序。 | 4
array_pad() | 用值将数组填补到指定长度。 | 4
array_pop() | 将数组最后一个单元弹出（出栈）。 | 4
array_product() | 计算数组中所有值的乘积。 | 5
array_push() | 将一个或多个单元（元素）压入数组的末尾（入栈）。 | 4
array_rand() | 从数组中随机选出一个或多个元素，并返回。 | 4
array_reduce() | 用回调函数迭代地将数组简化为单一的值。 | 4
array_reverse() | 将原数组中的元素顺序翻转，创建新的数组并返回。 | 4
array_search() | 在数组中搜索给定的值，如果成功则返回相应的键名。 | 4
array_shift() | 删除数组中的第一个元素，并返回被删除元素的值。 | 4
array_slice() | 在数组中根据条件取出一段值，并返回。 | 4
array_splice() | 把数组中的一部分去掉并用其它值取代。 | 4
array_sum() | 计算数组中所有值的和。 | 4
array_udiff() | 用回调函数比较数据来计算数组的差集。 | 5
array_udiff_assoc() | 带索引检查计算数组的差集，用回调函数比较数据。 | 5
array_udiff_uassoc() | 带索引检查计算数组的差集，用回调函数比较数据和索引。 | 5
array_uintersect() | 计算数组的交集，用回调函数比较数据。 | 5
array_uintersect_assoc() | 带索引检查计算数组的交集，用回调函数比较数据。 | 5
array_uintersect_uassoc() | 带索引检查计算数组的交集，用回调函数比较数据和索引。 | 5
array_unique() | 删除数组中重复的值。 | 4
array_unshift() | 在数组开头插入一个或多个元素。 | 4
array_values() | 返回数组中所有的值。 | 4
array_walk() | 对数组中的每个成员应用用户函数。 | 3
array_walk_recursive() | 对数组中的每个成员递归地应用用户函数。 | 5
arsort() | 对数组进行逆向排序并保持索引关系。 | 3
asort() | 对数组进行排序并保持索引关系。 | 3
compact() | 建立一个数组，包括变量名和它们的值。 | 4
count() | 计算数组中的元素数目或对象中的属性个数。 | 3
current() | 返回数组中的当前元素。 | 3
each() | 返回数组中当前的键／值对并将数组指针向前移动一步。 | 3
end() | 将数组的内部指针指向最后一个元素。 | 3
extract() | 从数组中将变量导入到当前的符号表。 | 3
in_array() | 检查数组中是否存在指定的值。 | 4
key() | 从关联数组中取得键名。 | 3
krsort() | 对数组按照键名逆向排序。 | 3
ksort() | 对数组按照键名排序。 | 3
list() | 把数组中的值赋给一些变量。 | 3
natcasesort() | 用“自然排序”算法对数组进行不区分大小写字母的排序。 | 4
natsort() | 用“自然排序”算法对数组排序。 | 4
next() | 将数组中的内部指针向前移动一位。 | 3
pos() | current() 的别名。 | 3
prev() | 将数组的内部指针倒回一位。 | 3
range() | 建立一个包含指定范围的元素的数组。 | 3
reset() | 将数组的内部指针指向第一个元素。 | 3
rsort() | 对数组逆向排序。 | 3
shuffle() | 把数组中的元素按随机顺序重新排列。 | 3
sizeof() | count() 的别名。 | 3
sort() | 对数组排序。 | 3
uasort() | 使用用户自定义的比较函数对数组中的值进行排序并保持索引关联。 | 3
uksort() | 使用用户自定义的比较函数对数组中的键名进行排序。 | 3
usort() | 使用用户自定义的比较函数对数组中的值进行排序。 | 3

PHP Array 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
CASE_LOWER | 用在 array_change_key_case() 中将数组键名转换成小写字母。 |
CASE_UPPER | 用在 array_change_key_case() 中将数组键名转换成大写字母。 |
SORT_ASC | 用在 array_multisort() 函数中，使其升序排列。 |
SORT_DESC | 用在 array_multisort() 函数中，使其降序排列。 |
SORT_REGULAR | 用于对对象进行通常比较。 |
SORT_NUMERIC | 用于对对象进行数值比较。 |
SORT_STRING | 用于对对象进行字符串比较。 |
SORT_LOCALE_STRING | 基于当前区域来对对象进行字符串比较。 | 4
COUNT_NORMAL |  |
COUNT_RECURSIVE |  |
EXTR_OVERWRITE |  |
EXTR_SKIP |  |
EXTR_PREFIX_SAME |  |
EXTR_PREFIX_ALL |  |
EXTR_PREFIX_INVALID |  |
EXTR_PREFIX_IF_EXISTS |  |
EXTR_IF_EXISTS |  |
EXTR_REFS |  |
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP array()

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array()

PHP Array 函数

定义和用法

array() 创建数组，带有键和值。如果在规定数组时省略了键，则生成一个整数键，这个 key 从 0 开始，然后以 1 进行递增。

要用 array() 创建一个关联数组，可使用 => 来分隔键和值。

要创建一个空数组，则不传递参数给 array()：

$new = array();

注意：array() 实际上是一种语言结构 (language construct)，通常用来定义直接量数组，但它的用法和函数的用法很相似，所以我们把它也列到手册中。

语法

array(key => value)
参数 | 描述
key | 可选。规定 key，类型是数值或字符串。如果未设置，则生成整数类型的 key。
value | 必需。规定值。

例子 1

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse");
print_r($a);
?>

输出：

Array ( [a] => Dog [b] => Cat [c] => Horse )

例子 2

<?php
$a=array("Dog","Cat","Horse");
print_r($a);
?>

输出：

Array ( [0] => Dog [1] => Cat [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP arsort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP arsort() 函数

PHP Array 函数

定义和用法

arsort() 函数对数组进行逆向排序并保持索引关系。主要用于对那些单元顺序很重要的结合数组进行排序。

可选的第二个参数包含了附加的排序标识。

如果成功则返回 TRUE，否则返回 FALSE。

语法

arsort(array,sorttype)
参数 | 描述
array | 必需。输入的数组。
sorttype

可选。规定如何排列数组的值。可能的值：

  • SORT_REGULAR - 默认。以它们原来的类型进行处理（不改变类型）。
  • SORT_NUMERIC - 把值作为数字来处理
  • SORT_STRING - 把值作为字符串来处理
  • SORT_LOCALE_STRING - 把值作为字符串来处理，基于本地设置*。

*：该值是 PHP 4.4.0 和 5.0.2 新加的。在 PHP 6 之前，使用了系统的区域设置，可以用 setlocale() 来改变。自 PHP 6 起，必须用 i18n_loc_set_default() 函数。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");

arsort($my_array);
print_r($my_array);
?>

输出：

Array
(
[c] => Horse
[a] => Dog
[b] => Cat
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP asin() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP asin() 函数

PHP Math 函数

定义和用法

asin() 函数返回不同数值的反正弦，返回的结果是介于 -PI/2 与 PI/2 之间的弧度值。

语法

asin(x)
参数 | 描述
x | 必需。一个数，范围在 -1 到 1 之间。

说明

返回 x 的反正弦值，单位是弧度。asin() 是 sin() 的反函数，它的意思是在 asin() 范围里的每个值都是 a==sin(asin(a))。

如果 x 的值在 -1 到 1 之外，则返回 -1.#IND。如果为 1，则返回 PI/2 的值。

例子

在本例中，我们将计算不同值的反正弦：

<?php
echo(asin(0.64));
echo(asin(0));
echo(asin(-1));
echo(asin(1));
echo(asin(2))
?>

输出：

0.694498265627
0
-1.57079632679
1.57079632679
-1.#IND

PHP Math 函数

PHP 参考手册
PHP 测验


PHP asinh() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP asinh() 函数

PHP Math 函数

定义和用法

asinh() 函数返回一个数的反双曲正弦。

语法

asinh(x)
参数 | 描述
x | 必需。一个数。

说明

返回 x 的反双曲正弦值，即，其双曲正弦为 x 的那个值。

提示和注释

注释：本函数未在 Windows 平台下实现。

PHP Math 函数

PHP 参考手册
PHP 测验


PHP asort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP asort() 函数

PHP Array 函数

定义和用法

asort() 函数对数组进行排序并保持索引关系。主要用于对那些单元顺序很重要的结合数组进行排序。

可选的第二个参数包含了附加的排序标识。

如果成功则返回 TRUE，否则返回 FALSE。

语法

asort(array,sorttype)
参数 | 描述
array | 必需。输入的数组。
sorttype

可选。规定如何排列数组的值。可能的值：

  • SORT_REGULAR - 默认。以它们原来的类型进行处理（不改变类型）。
  • SORT_NUMERIC - 把值作为数字来处理
  • SORT_STRING - 把值作为字符串来处理
  • SORT_LOCALE_STRING - 把值作为字符串来处理，基于本地设置*。

*：该值是 PHP 4.4.0 和 5.0.2 新加的。在 PHP 6 之前，使用了系统的区域设置，可以用 setlocale() 来改变。自 PHP 6 起，必须用 i18n_loc_set_default() 函数。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");

asort($my_array);
print_r($my_array);
?>

输出：

Array
(
[b] => Cat
[a] => Dog
[c] => Horse
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP asXML() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP asXML() 函数

PHP SimpleXML 函数

定义和用法

asXML() 函数以字符串的形式从 SimpleXMLElement 对象返回 XML 文档。

若失败，则返回 false。

语法

class SimpleXMLElement
{
string asXML(file)
}
参数 | 描述
file | 可选。如果规定了此参数，则该函数会把 XML 写入一个文件，而不是返回它。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
if (file_exists('test.xml'))
  {
  $xml = simplexml_load_file('test.xml');
  }

echo $xml->asXML();
?>

输出：

George John Reminder Don't forget the meeting!

如果在浏览器窗口中选择“查看源文件”，会看到这些 HTML：

<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP atan() 和 atan2() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP atan() 和 atan2() 函数

PHP Math 函数

定义和用法

atan() 函数返回一个数值的反正切，返回值介于 -PI/2 与 PI/2 之间。

atan2() 函数返回两个参数的反正切，返回值为弧度，其值在 -PI 和 PI 之间（包括 -PI 和 PI）。

语法

atan(x)

atan2(x,y)
参数 | 描述
x | 必需。一个数。
y | 必需。一个数。

说明

atan() 函数返回 x 的反正切值，单位是弧度。atan() 是 tan() 的反函数，它的意思是在 atan() 范围里的每个值都是 a==tan(atan(a))。

atan2() 函数计算两个变量 x 和 y 的反正切值。和计算 y / x 的反正切相似，不同的是两个参数的符号是用来确定结果的象限之外。

例子 1

本例计算不同值的反正切：

<?php
echo(atan(0.50));
echo(atan(-0.50));
echo(atan(5));
echo(atan(10));
echo(atan(-5));
echo(atan(-10))
?>

输出：

0.463647609001
-0.463647609001
1.37340076695
1.4711276743
-1.37340076695
-1.4711276743

例子 2

本例计算不同的变量 x 和 y 的反正切值：

<?php
echo(atan2(0.50,0.50));
echo(atan2(-0.50,-0.50));
echo(atan2(5,5));
echo(atan2(10,20));
echo(atan2(-5,-5));
echo(atan2(-10,10))
?>

输出：

0.785398163397
-2.35619449019
0.785398163397
0.463647609001
-2.35619449019
-0.785398163397

PHP Math 函数

PHP 参考手册
PHP 测验


PHP atanh() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP atanh() 函数

PHP Math 函数

定义和用法

atanh() 函数返回一个角度的反双曲正切。

语法

atanh(x)
参数 | 描述
x | 必需。一个数。

说明

atanh() 函数返回 x 的反双曲正切值，即，其双曲正切为 x 的那个值。

提示和注释

注释：本函数未在 Windows 平台下实现。

PHP Math 函数

PHP 参考手册
PHP 测验


PHP attributes() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP attributes() 函数

PHP SimpleXML 函数

定义和用法

attributes() 函数获取 SimpleXML 元素的属性。

该函数提供在一个 XML 标签中定义的属性和值。

语法

class SimpleXMLElement
{
string attributes(ns,is_prefix)
}
参数 | 描述
ns | 可选。被检索的属性的命名空间。
is_prefix | 可选。默认是 false。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
$xml = simplexml_load_file("test.xml");

foreach($xml->body[0]->attributes() as $a => $b)
  {
  echo $a,'="',$b,'"';
  }
?>

输出：

type="small" important="low"

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP base_convert() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP base_convert() 函数

PHP Math 函数

定义和用法

base_convert() 函数在任意进制之间转换数字。

语法

base_convert(number,frombase,tobase)
参数 | 描述
number | 必需。原始值。
frombase | 必需。数字原来的进制。
tobase | 必需。要转换的进制。

说明

返回一个字符串，包含 number 以 tobase 进制的表示。number 本身的进制由 frombase 指定。frombase 和 tobase 都只能在 2 和 36 之间（包括 2 和 36）。高于十进制的数字用字母 a-z 表示，例如 a 表示 10，b 表示 11 以及 z 表示 35。

例子 1

把八进制数转换为十进制数：

<?php
$oct = "0031";
$dec = base_convert($oct,8,10);
echo "八进制的 $oct 等于十进制的 $dec。";
?>

输出：

八进制的 0031 等于十进制的 25。

例子 2

把八进制数转换为十六进制数：

<?php
$oct = "364";
$hex = base_convert($oct,8,16);
echo "八进制的 $oct 等于十六进制的 $hex。";
?>

输出：

八进制的 364 等于十六进制的 f4。

PHP Math 函数

PHP 参考手册
PHP 测验


PHP basename() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP basename() 函数

PHP Filesystem 函数

定义和用法

basename() 函数返回路径中的文件名部分。

语法

basename(path,suffix)
参数 | 描述
path | 必需。规定要检查的路径。
suffix | 可选。规定文件扩展名。如果文件有 suffix，则不会输出这个扩展名。

例子

<?php
$path = "/testweb/home.php";

//显示带有文件扩展名的文件名
echo basename($path);

//显示不带有文件扩展名的文件名
echo basename($path,".php");
?>

输出：

home.php
home

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP bin2hex() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP bin2hex() 函数

PHP String 函数

定义和用法

bin2hex() 函数把 ASCII 字符的字符串转换为十六进制值。

语法

bin2hex(string)
参数 | 描述
string | 必需。规定要转换的字符串。

例子

在本例中，我们将把一个字符串值从二进制转换为十六进制，再转换回去：

<?php
$str = "Hello world!";
echo bin2hex($str);
echo pack("H*",bin2hex($str));
?>

输出：

48656c6c6f20776f726c6421
Hello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP bindec() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP bindec() 函数

PHP Math 函数

定义和用法

bindec() 函数把二进制转换为十进制。

语法

bindec(binary_string)
参数 | 描述
binary_string | 必需。规定要转换的二进制数。

说明

返回 binary_string 参数所表示的二进制数的十进制等价值。

bindec() 函数将一个二进制数转换成 integer。可转换的最大的数为 31 位 1 或者说十进制的 2147483647。PHP 4.1.0 开始，该函数可以处理大数值，这种情况下，它会返回 float 类型。

例子

<?php
echo bindec("0011");
echo bindec("01");
echo bindec("11000110011");
echo bindec("111");
?>

输出：

3
1
1587
7

PHP Math 函数

PHP 参考手册
PHP 测验


PHP cal_days_in_month() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP cal_days_in_month() 函数

PHP Array 函数

定义和用法

cal_days_in_month() 函数针对指定的年份和日历，返回一个月中的天数。

语法

cal_days_in_month(calendar,month,year)
参数 | 描述
calendar | 必需。规定要使用的历法。
month | 必须。规定月。
year | 必须。规定年。

例子

<?php
$d=cal_days_in_month(CAL_GREGORIAN,10,2005);
echo("There was $d days in October 2005");
?>

输出：

There was 31 days in October 2005

PHP Array 函数

PHP 参考手册
PHP 测验


PHP cal_from_jd() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP cal_from_jd() 函数

PHP Array 函数

定义和用法

cal_from_jd() 函数把儒略日计数转换为指定历法的日期。

语法

cal_from_jd(jd,calendar)
参数 | 描述
jd | 必需。一个数字（儒略日计数）。
calendar

必需。规定要使用的历法。可以使用下面这些常量：

  • CAL_GREGORIAN
  • CAL_JULIAN
  • CAL_JEWISH
  • CAL_FRENCH

例子

<?php
$d=unixtojd(mktime(0,0,0,1,18,2006));
print_r(cal_from_jd($d,CAL_GREGORIAN));
?>

输出：

Array
(
[date] => 1/18/2006
[month] => 1
[day] => 18
[year] => 2006
[dow] => 3
[abbrevdayname] => Wed
[dayname] => Wednesday
[abbrevmonth] => Jan
[monthname] => January
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP cal_info() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP cal_info() 函数

PHP Array 函数

定义和用法

cal_info() 函数返回一个数组，其中包含了关于给定历法的信息。

所返回的数组包含这些元素：calname, calsymbol, month, abbrevmonth 以及 maxdaysinmonth。

语法

cal_from_jd(jd,calendar)
参数 描述
calendar

必需。规定要使用的历法。可以使用下面这些常量：

  • CAL_GREGORIAN
  • CAL_JULIAN
  • CAL_JEWISH
  • CAL_FRENCH

提示和注释

提示：在 PHP 5 中，如果没有指定 calendar 参数，则返回所有被支持的历法的信息。

例子

<?php
$calinfo=cal_info(0);
print_r($calinfo);
?>

输出：

Array
(
[months] => Array
(
[1] => January
[2] => February
[3] => March
[4] => April
[5] => May
[6] => June
[7] => July
[8] => August
[9] => September
[10] => October
[11] => November
[12] => December
)

[abbrevmonths] => Array
(
[1] => Jan
[2] => Feb
[3] => Mar
[4] => Apr
[5] => May
[6] => Jun
[7] => Jul
[8] => Aug
[9] => Sep
[10] => Oct
[11] => Nov
[12] => Dec
)

[maxdaysinmonth] => 31
[calname] => Gregorian
[calsymbol] => CAL_GREGORIAN
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP cal_to_jd() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP cal_to_jd() 函数

PHP Array 函数

定义和用法

cal_to_jd() 函数把指定的日期转换为儒略日计数。

语法

cal_to_jd(calendar,month,day,year)
参数 | 描述
calendar

必需。规定要使用的历法。可以使用下面这些常量：

  • CAL_GREGORIAN
  • CAL_JULIAN
  • CAL_JEWISH
  • CAL_FRENCH
month | 必需。规定月。
day | 必需。规定日。
year | 必需。规定年。

例子

<?php
$d=cal_to_jd(CAL_GREGORIAN,10,03,2005);
echo($d);
?>

输出：

2453647

PHP Array 函数

PHP 参考手册
PHP 测验


PHP Calendar 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Calendar 函数

  • Previous Page
  • Next Page

PHP Calendar 简介

当使用不同的历法格式时，calendar 函数很有用。它所基于的标准是儒略日计数 (Julian day count)。

编者注：Julian day count 是从 January 1, 4713 B.C. 开始计算的，中文译为儒略日计数或恺撒日计数。

请注意，Julian day count（儒略日计数） 与 Julian calendar（儒略历） 不是一回事。

注释：如需在日历格式之间转换，必须首先转换为 Julian day count，然后再转换为日历格式。

安装

PHP 的 windows 版本已内建了对日历扩展的支持。因此，Calendar 函数会自动工作。

不过，如果您运行的是 PHP 的 Linux 版本，就不得不通过 --enable-calendar 编译 PHP，这样日历函数才能工作。

PHP Calendar 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
cal_days_in_month() | 针对指定的年份和日历，返回一个月中的天数。 | 4
cal_from_jd() | 把儒略日计数转换为指定日历的日期。 | 4
cal_info() | 返回有关给定日历的信息。 | 4
cal_to_jd() | 把日期转换为儒略日计数。 | 4
easter_date() | 返回指定年份的复活节午夜的 Unix 时间戳。 | 3
easter_days() | 返回指定年份的复活节与 3 月 21 日之间的天数。 | 3
FrenchToJD() | 将法国共和历法转换成为儒略日计数。 | 3
GregorianToJD() | 将格利高里历法转换成为儒略日计数。 | 3
JDDayOfWeek() | 返回日期在周几。 | 3
JDMonthName() | 返回月的名称。 | 3
JDToFrench() | 把儒略日计数转换为法国共和国历法。 | 3
JDToGregorian() | 把儒略日计数转换为格利高里历法。 | 3
jdtojewish() | 把儒略日计数转换为犹太历法。 | 3
JDToJulian() | 把儒略日计数转换为儒略历。 | 3
jdtounix() | 把儒略日计数转换为 Unix 时间戳。 | 4
JewishToJD() | 把犹太历法转换为儒略日计数。 | 3
JulianToJD() | 把儒略历转换为儒略日计数。 | 3
unixtojd() | 把 Unix 时间戳转换为儒略日计数。 | 4

PHP Calendar 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
CAL_GREGORIAN | Gregorian calendar | 3
CAL_JULIAN | Julian calendar | 3
CAL_JEWISH | Jewish calendar | 3
CAL_FRENCH | French Republican calendar | 3
CAL_NUM_CALS |  | 3
CAL_DOW_DAYNO |  | 3
CAL_DOW_SHORT |  | 3
CAL_DOW_LONG |  | 3
CAL_MONTH_GREGORIAN_SHORT |  | 3
CAL_MONTH_GREGORIAN_LONG |  | 3
CAL_MONTH_JULIAN_SHORT |  | 3
CAL_MONTH_JULIAN_LONG |  | 3
CAL_MONTH_JEWISH |  | 3
CAL_MONTH_FRENCH |  | 3
CAL_EASTER_DEFAULT |  | 4
CAL_EASTER_DEFAULT |  | 4
CAL_EASTER_ROMAN |  | 4
CAL_EASTER_ALWAYS_GREGORIAN |  | 4
CAL_EASTER_ALWAYS_JULIAN |  | 4
CAL_JEWISH_ADD_ALAFIM_GERESH |  | 5
CAL_JEWISH_ADD_ALAFIM |  | 5
CAL_JEWISH_ADD_GERESHAYIM |  | 5
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP ceil() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ceil() 函数

PHP Math 函数

定义和用法

ceil() 函数向上舍入为最接近的整数。

语法

ceil(x)
参数 | 描述
x | 必需。一个数。

说明

返回不小于 x 的下一个整数，x 如果有小数部分则进一位。ceil() 返回的类型仍然是 float，因为 float 值的范围通常比 integer 要大。

例子

在本例中，我们将对不同的值应用 ceil() 函数：

<?php
echo(ceil(0.60);
echo(ceil(0.40);
echo(ceil(5);
echo(ceil(5.1);
echo(ceil(-5.1);
echo(ceil(-5.9));
?>

输出：

1
1
5
6
-5
-5

PHP Math 函数

PHP 参考手册
PHP 测验


PHP chdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chdir() 函数

PHP Directory 函数

定义和用法

chdir() 函数把当前的目录改变为指定的目录。

若成功，则该函数返回 true，否则返回 false。

语法

chdir(directory)
参数 | 描述
directory | 必需。规定新的当前目录。

例子

<?php
//获得当前目录
echo getcwd();
echo "<br />";

//改变为 images 目录
chdir("images");
echo "<br />";
echo getcwd();
?>

输出：

C:\testweb\main
C:\testweb\main\images

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP checkdate() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP checkdate() 函数

PHP Date / Time 函数

定义和用法

checkdate() 函数验证一个格里高里日期。

如果指定的值合法，则该函数返回 true，否则返回 false。

日期在下列情况下为合法：

  • month 介于且包括 1 - 12
  • Day 的值在给定的 month 所应该具有的天数范围之内，闰年已经考虑进去了。
  • year 介于且包括 1 到 32767

语法

checkdate(month,day,year)
参数 | 描述
month | 必需。规定月。
day | 必需。规定日。
year | 必需。规定年。

例子

<?php
var_dump(checkdate(12,31,2000));
var_dump(checkdate(2,29,2003));
var_dump(checkdate(2,29,2004));
?>

输出：

bool(true)
bool(false)
bool(true)

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP chgrp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chgrp() 函数

PHP Filesystem 函数

定义和用法

chgrp() 函数改变文件所属的组。

如果成功则返回 TRUE，否则返回 FALSE。

语法

chgrp(file,group)
参数 | 描述
file | 必需。规定要检查的文件。
group | 可选。规定新的组。可以是组名或组的 ID。

说明

尝试将文件 file 所属的组改成 group （通过组名或组 ID 指定）。

只有超级用户可以任意修改文件的组，其它用户可能只能将文件的组改成该用户自己所在的组。

例子

<?php
chgrp("test.txt","admin")
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP children() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP children() 函数

PHP SimpleXML 函数

定义和用法

children() 函数获取指定节点的子节点。

语法

class SimpleXMLElement
{
string children(ns,is_prefix)
}
参数 | 描述
ns | 可选。
is_prefix | 可选。默认是 false。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
$xml = simplexml_load_file("test.xml");

foreach ($xml->children() as $child)
  {
  echo "Child node: " . $child;
  }
?>

输出类似：

Child node: George
Child node: John
Child node: Reminder
Child node: Don't forget the meeting!

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP chmod() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chmod() 函数

PHP Filesystem 函数

定义和用法

chmod() 函数改变文件模式。

如果成功则返回 TRUE，否则返回 FALSE。

语法

chmod(file,mode)
参数 | 描述
file | 必需。规定要检查的文件。
mode

可选。规定新的权限。

mode 参数由 4 个数字组成：

  • 第一个数字永远是 0
  • 第二个数字规定所有者的权限
  • 第二个数字规定所有者所属的用户组的权限
  • 第四个数字规定其他所有人的权限

可能的值（如需设置多个权限，请对下面的数字进行总计）：

  • 1 - 执行权限
  • 2 - 写权限
  • 4 - 读权限

例子

<?php
// 所有者可读写，其他人没有任何权限
chmod("test.txt",0600);

// 所有者可读写，其他人可读
chmod("test.txt",0644);

// 所有者有所有权限，其他所有人可读和执行
chmod("test.txt",0755);

// 所有者有所有权限，所有者所在的组可读
chmod("test.txt",0740);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP chop() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chop() 函数

PHP String 函数

定义和用法

chop() 函数从字符串的末端开始删除空白字符或其他预定义字符。

该函数的 rtrim() 函数的别名。

语法

chop(string,charlist)
参数 | 描述
string | 必需。规定要转换的字符串。
charlist

可选。规定从字符串中删除哪些字符。

如果未设置该参数，则全部删除以下字符：

  • "\0" - ASCII 0, NULL
  • "\t" - ASCII 9, 制表符
  • "\n" - ASCII 10, 新行
  • "\x0B" - ASCII 11, 垂直制表符
  • "\r" - ASCII 13, 回车
  • " " - ASCII 32, 空格

例子

在本例中，我们将使用 chop() 函数从字符串右端删除字符：

<?php
$str = "Hello World!\n\n";
echo $str;
echo chop($str);
?>

以上代码输出的源代码：

<html>

<body>
Hello World!

Hello World!</body>

</html>

输出：

Hello World! Hello World!

PHP String 函数

PHP 参考手册
PHP 测验


PHP chown() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chown() 函数

PHP Filesystem 函数

定义和用法

chown() 函数改变指定文件的所有者。

如果成功则返回 TRUE，否则返回 FALSE。

语法

chown(file,owner)
参数 | 描述
file | 必需。规定要检查的文件。
owner | 规定新的所有者。可以是用户名或用户的 ID。

说明

尝试将文件 file 的所有者改成用户 owner （由用户名或用户 ID 指定）。只有超级用户可以改变文件的所有者。

例子

<?php
chown("test.txt","charles")
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP chr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chr() 函数

PHP String 函数

定义和用法

chr() 函数从指定的 ASCII 值返回字符。

语法

chr(ascii)
参数 | 描述
ascii | 必需。ASCII 值。

提示和注释

注释：ascii 参数可以是十进制、八进制或十六进制。通过前置 0 来规定八进制，通过前置 0x 来规定十六进制。

例子

<?php
echo chr(52);
echo chr(052);
echo chr(0x52);
?>

输出：

4
*
R

PHP String 函数

PHP 参考手册
PHP 测验


PHP chroot() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chroot() 函数

PHP Directory 函数

定义和用法

chroot() 函数把当前进程的根目录改变为指定的目录。

若成功，则该函数返回 true，否则返回 false。

语法

chroot(directory)
参数 | 描述
directory | 必需。规定新的根目录。

提示和注释

提示：该函数没有在 Windows 平台上实现。

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP chunk_split() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chunk_split() 函数

PHP String 函数

定义和用法

chunk_split() 函数把字符串分割为一连串更小的部分。

语法

chunk_split(string,length,end)
参数 | 描述
string | 必需。规定要分割的字符串。
length | 可选。一个数字，定义字符串块的长度。
end | 可选。字符串值，定义在每个字符串块之后放置的内容。

提示和注释

注释：本函数不改变原始字符串。

例子

例子 1

本例分隔每个字符，并添加 "."：

<?php
$str = "Hello world!";
echo chunk_split($str,1,".");
?>

输出：

H.e.l.l.o. .w.o.r.l.d.!.

例子 2

本例将在六个字符之后分割一次字符串，并添加 "..."：

<?php
$str = "Hello world!";
echo chunk_split($str,6,"...");
?>

输出：

Hello ...world!...

PHP String 函数

PHP 参考手册
PHP 测验


PHP clearstatcache() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP clearstatcache() 函数

PHP Filesystem 函数

定义和用法

clearstatcache() 函数清除文件状态缓存。

clearstatcache() 函数会缓存某些函数的返回信息，以便提供更高的性能。但是有时候，比如在一个脚本中多次检查同一个文件，而该文件在此脚本执行期间有被删除或修改的危险时，你需要清除文件状态缓存，以便获得正确的结果。要做到这一点，就需要使用 clearstatcache() 函数。

会进行缓存的函数，即受 clearstatcache() 函数影响的函数：

  • stat()
  • lstat()
  • file_exists()
  • is_writable()
  • is_readable()
  • is_executable()
  • is_file()
  • is_dir()
  • is_link()
  • filectime()
  • fileatime()
  • filemtime()
  • fileinode()
  • filegroup()
  • fileowner()
  • filesize()
  • filetype()
  • fileperms()

语法

clearstatcache()

例子

<?php
//检查文件大小
echo filesize("test.txt");

$file = fopen("test.txt", "a+");

// 截取文件
ftruncate($file,100);
fclose($file);

//清除缓存并再次检查文件大小
clearstatcache();
echo filesize("test.txt");
?>

输出：

792
100

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP clearstatcache() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP clearstatcache() 函数

PHP Filesystem 函数

定义和用法

clearstatcache() 函数拷贝文件。

语法

copy(source,destination)
参数 | 描述
source | 必需。规定要复制的文件。
destination | 必需。规定复制文件的目的地。

说明

将文件从 source 拷贝到 destination。如果成功则返回 TRUE，否则返回 FALSE。

提示和注释

提示：如果要移动文件的话，请使用 rename() 函数。

注释：从 PHP 4.3.0 开始，如果启用了 "fopen wrappers" 的话，source 和 destination 都可以是 URL。更多信息见 fopen()。如果 destination 是一个 URL，则如果封装协议不支持覆盖已有的文件时拷贝操作会失败。

重要事项：如果目标文件已存在，将会被覆盖。

例子

<?php
echo copy("source.txt","target.txt");
?>

输出：

1

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP closedir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP closedir() 函数

PHP Directory 函数

定义和用法

closedir() 函数关闭由 opendir() 函数打开的目录句柄。

语法

closedir(dir_stream)
参数 | 描述
dir_stream | 必需。规定要关闭的目录句柄。

例子

<?php
//打开 images 目录
$dir = opendir("images");

//列出 images 目录中的文件
while (($file = readdir($dir)) !== false)
  {
  echo "filename: " . $file . "<br />";
  }
  closedir($dir);
?>

输出：

filename: .
filename: ..
filename: cat.gif
filename: dog.gif
filename: food
filename: horse.gif

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP compact() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP compact() 函数

PHP Array 函数

定义和用法

compact() 函数创建一个由参数所带变量组成的数组。如果参数中存在数组，该数组中变量的值也会被获取。

本函数返回的数组是一个关联数组，键名为函数的参数，键值为参数中变量的值。

本函数执行的行为与 extract() 正好相反。

语法

compact(var1,var2...)
参数 | 描述
var1 | 必需。可以是带有变量名的字符串，或者是一个变量数组。
var2 | 可选。可以是带有变量名的字符串，或者是一个变量数组。允许多个参数。

注释和提示

注释：任何没有变量名与之对应的字符串都被略过。

例子 1

<?php
$firstname = "Peter";
$lastname = "Griffin";
$age = "38";

$result = compact("firstname", "lastname", "age");

print_r($result);
?>

输出：

Array
(
[firstname] => Peter
[lastname] => Griffin
[age] => 38
)

例子 2

使用没有对应变量名的字符串，以及一个变量名数组：

<?php
$firstname = "Peter";
$lastname = "Griffin";
$age = "38";

$name = array("firstname", "lastname");
$result = compact($name, "location", "age");

print_r($result);
?>

输出：

Array
(
[firstname] => Peter
[lastname] => Griffin
[age] => 38
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP connection_aborted() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP connection_aborted() 函数

PHP 杂项函数

定义和用法

connection_aborted() 函数检查是否断开客户机。

如果已终止连接，则该函返回 1，否则返回 0。

语法

connection_aborted()

例子

创建一个函数，在客户机终止脚本时写入一条日志消息：

<?php
function check_abort()
  {
  if (connection_aborted())
  error_log ("Script $GLOBALS[SCRIPT_NAME]" .
  "$GLOBALS[SERVER_NAME] was aborted by the user.");
  }

//要执行的一些代码

// 在脚本结束时调用 check_abort 函数
register_shutdown_function("check_abort");
?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP connection_status() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP connection_status() 函数

PHP 杂项函数

定义和用法

connection_status() 函数返回当前的连接状态。

可返回的可能值：

  • 0 - CONNECTION_NORMAL - 连接运行正常
  • 1 - CONNECTION_ABORTED - 连接由用户或网络错误终止
  • 2 - CONNECTION_TIMEOUT - 连接超时
  • 3 - CONNECTION_ABORTED & CONNECTION_TIMEOUT

语法

connection_status()

例子

<?php

switch (connection_status())
{
case CONNECTION_NORMAL:
   $txt = 'Connection is in a normal state';
   break;
case CONNECTION_ABORTED:
   $txt = 'Connection aborted';
   break;
case CONNECTION_TIMEOUT:
   $txt = 'Connection timed out';
   break;
case (CONNECTION_ABORTED & CONNECTION_TIMEOUT):
   $txt = 'Connection aborted and timed out';
   break;
default:
   $txt = 'Unknown';
   break;
}

echo $txt;
?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP constant() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP constant() 函数

PHP 杂项函数

定义和用法

constant() 函数返回常量的值。

语法

constant(constant)
参数 | 描述
constant | 必需。规定要检查的常量的名称。

提示和注释

注释：该函数仅适用于 class 常量。

例子

<?php
//定义一个常量
define("GREETING","Hello world!");

echo constant("GREETING");
?>

输出：

Hello world!

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP convert_cyr_string() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP convert_cyr_string() 函数

PHP String 函数

定义和用法

convert_cyr_string() 函数把字符由一种 Cyrillic 字符转换成另一种。

被支持的 Cyrillic 字符集是：

  • k - koi8-r
  • w - windows-1251
  • i - iso8859-5
  • a - x-cp866
  • d - x-cp866
  • m - x-mac-cyrillic

语法

convert_cyr_string(string,from,to)
参数 | 描述
string | 必需。规定要转换的字符串。
from | 必需。源 Cyrillic 字符集。
to | 必需。目标 Cyrillic 字符集。

提示和注释

注释：本函数可安全用于二进制对象。

PHP String 函数

PHP 参考手册
PHP 测验


PHP convert_uudecode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP convert_uudecode() 函数

PHP String 函数

定义和用法

convert_uudecode() 函数对 uuencode 编码的字符串进行解码。

语法

convert_uudecode(string)
参数 | 描述
string | 必需。规定要解码的字符串。

例子

在本例中，我们将通过使用 convert_uudecode() 对 uuencode 编码的字符串进行解码：

<?php
$str = ",2&5L;&\@=V]R;&0A `";
echo convert_uudecode($str);
?>

输出：

Hello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP convert_uuencode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP convert_uuencode() 函数

PHP String 函数

定义和用法

convert_uuencode() 函数使用 uuencode 算法对字符串进行编码。

语法

convert_uuencode(string)
参数 | 描述
string | 必需。规定进行 uuencode 的字符串。

提示和注释

注释：本函数把所有字符串（包括二进制的）转换为可打印的字符串，确保其网络传输的安全。

注释：uuencode 的字符串比原字符串增大大约 35%。

例子

在本例中，我们将使用 convert_uuencode() 对字符串进行编码：

<?php
$str = "Hello world!";
echo convert_uuencode($str);
?>

输出：

,2&5L;&\@=V]R;&0A `

PHP String 函数

PHP 参考手册
PHP 测验


PHP cos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP cos() 函数

PHP Math 函数

定义和用法

cos() 函数返回一个数的余弦。

语法

cos(x)
参数 | 描述
x | 必需。一个数。

说明

cos() 返回参数 x 的余弦值。参数 x 的单位为弧度。

提示和注释

注释：cos() 返回的数值在 -1 和 1 之间。

例子

在本例中，我们将计算不同值的余弦：

<?php
echo(cos(3));
echo(cos(-3));
echo(cos(0));
echo(cos(M_PI));
echo(cos(2*M_PI));
?>

输出：

-0.9899924966004454
-0.9899924966004454
1
-1
1

PHP Math 函数

PHP 参考手册
PHP 测验


PHP cosh() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP cosh() 函数

PHP Math 函数

定义和用法

cosh() 函数返回一个数的双曲余弦。

语法

cosh(x)
参数 | 描述
x | 必需。一个数。

说明

返回 x 的双曲余弦值，定义为 (exp(arg) + exp(-arg))/2。

例子

在本例中，我们将返回不同数的双曲余弦：

<?php
echo(cosh(3);
echo(cosh(-3);
echo(cosh(0);
echo(cosh(M_PI);
echo(cosh(2*M_PI));
?>

输出：

10.0676619958
10.0676619958
1
11.5919532755
267.746761484

PHP Math 函数

PHP 参考手册
PHP 测验


PHP count_chars() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP count_chars() 函数

PHP String 函数

定义和用法

count_chars() 函数返回字符串所用字符的信息。

语法

count_chars(string,mode)
参数 | 描述
string | 必需。规定要检查的字符串。
mode

可选。规定返回模式。默认是 0。有以下不同的返回模式：

  • 0 - 数组，ASCII 值为键名，出现的次数为键值
  • 1 - 数组，ASCII 值为键名，出现的次数为键值，只列出出现次数大于 0 的值
  • 0 - 数组，ASCII 值为键名，出现的次数为键值，只列出出现次数等于 0 的值
  • 3 - 字符串，带有所有使用过的不同的字符
  • 3 - 字符串，带有所有未使用过的不同的字符

例子

例子 1

在本例中，我们将使用 count_chars() 来检查字符串，返回模式设置为 1：

<?php
$str = "Hello World!";
print_r(count_chars($str,1));
?>

输出：

Array
(
[32] => 1
[33] => 1
[72] => 1
[87] => 1
[100] => 1
[101] => 1
[108] => 3
[111] => 2
[114] => 1
)

例子 2

在本例中，我们将使用 count_chars() 来检查字符串，返回模式设置为 3：

<?php
$str = "Hello World!";
echo count_chars($str,3);
?>

输出：

 !HWdelor

PHP String 函数

PHP 参考手册
PHP 测验


PHP count() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP count() 函数

PHP Array 函数

定义和用法

count() 函数计算数组中的单元数目或对象中的属性个数。

对于数组，返回其元素的个数，对于其他值，返回 1。如果参数是变量而变量没有定义，则返回 0。如果 mode 被设置为 COUNT_RECURSIVE（或 1），则会递归底计算多维数组中的数组的元素个数。

语法

count(array,mode)
参数 | 描述
array | 必需。规定要计数的数组或对象。
mode

可选。规定函数的模式。可能的值：

  • 0 - 默认。不检测多维数组（数组中的数组）。
  • 1 - 检测多维数组。

注释：该参数是 PHP 4.2 中加入的。

提示和注释

注释：当变量未被设置，或是变量包含一个空的数组，该函数会返回 0。可使用 isset() 变量来测试变量是否被设置。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");
$result = count($people);

echo $result;
?>

输出：

4

PHP Array 函数

PHP 参考手册
PHP 测验


PHP crc32() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP crc32() 函数

PHP String 函数

定义和用法

crc32() 函数计算一个字符串的 crc32 多项式。

该函数可用于验证数据的完整性。

语法

crc32(string)
参数 | 描述
string | 必需。规定要计算的字符串。

说明

生成 string 参数的 32 位循环冗余校验码多项式。这通常用于检查传输的数据是否完整。

提示和注释

提示：由于 PHP 的整数是带符号的，许多 crc32 校验码将返回负整数，因此您需要使用 sprintf() 或 printf() 的 "%u" 格式符来获取表示无符号 crc32 校验码的字符串。

例子

例子 1

在本例中，我们将在使用以及不使用 "%u" 格式符的情况下，输出 crc32() 的结果（注意结果是相同的）：

<?php
$str = crc32("Hello world!");
echo 'Without %u: '.$str."<br />";
echo 'With %u: ';
printf("%u",$str);
?>

输出：

Without %u: 461707669
With %u: 461707669

例子 2

在本例中，我们将在使用以及不使用 "%u" 格式符的情况下，输出 crc32() 的结果（注意结果是不相同的）：

<?php
$str = crc32("Hello world.");
echo 'Without %u: '.$str."<br />";
echo 'With %u: ';
printf("%u",$str);
?>

输出：

Without %u: -1959132156
With %u: 2335835140

PHP String 函数

PHP 参考手册
PHP 测验


PHP crypt() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP crypt() 函数

PHP String 函数

定义和用法

crypt() 函数返回使用 DES、Blowfish 或 MD5 加密的字符串。

在不同的操作系统上，本函数的行为不同，某些操作系统支持一种以上的算法类型。在安装时，PHP 会检查什么算法可用以及使用什么算法。

语法

crypt(str,salt)
参数 | 描述
str | 必需。规定要编码的字符串。
salt | 可选。用于增加被编码字符数目的字符串，以使编码更加安全。 如果未提供 salt 参数，则每次调用该函数时会随机生成一个。

说明

确切的算法依赖于 salt 参数的格式和长度。

下面是与 crypt() 函数一起使用的一些常量。在安装时，由 PHP 设置这些常量：

  • [CRYPT_SALT_LENGTH]
  • [CRYPT_STD_DES]
  • [CRYPT_EXT_DES]
  • [CRYPT_MD5]
  • [CRYPT_BLOWFISH]

提示和注释

提示：解密函数是没有的。crypt() 函数使用一种单向算法。

例子

在本例中，我们将测试不同的算法：

<?php
if (CRYPT_STD_DES == 1)
{
echo "Standard DES: ".crypt("hello world")."\n<br />";
}
else
{
echo "Standard DES not supported.\n<br />";
}

if (CRYPT_EXT_DES == 1)
{
echo "Extended DES: ".crypt("hello world")."\n<br />";
}
else
{
echo "Extended DES not supported.\n<br />";
}

if (CRYPT_MD5 == 1)
{
echo "MD5: ".crypt("hello world")."\n<br />";
}
else
{
echo "MD5 not supported.\n<br />";
}

if (CRYPT_BLOWFISH == 1)
{
echo "Blowfish: ".crypt("hello world");
}
else
{
echo "Blowfish DES not supported.";
}
?>

输出类似（依赖于操作系统）：

Standard DES: $1$r35.Y52.$iyiFuvM.zFGsscpU0aZ4e.
Extended DES not supported.
MD5: $1$BN1.0I2.$8oBI/4mufxK6Tq89M12mk/
Blowfish DES not supported.

PHP String 函数

PHP 参考手册
PHP 测验


PHP current() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP current() 函数

PHP Array 函数

定义和用法

current() 函数返回数组中的当前元素（单元）。

每个数组中都有一个内部的指针指向它“当前的”元素，初始指向插入到数组中的第一个元素。

current() 函数返回当前被内部指针指向的数组元素的值，并不移动指针。如果内部指针指向超出了单元列表的末端，current() 返回 FALSE。

语法

current(array)
参数 | 描述
array | 必需。规定要使用的数组。

提示和注释

注释：如果有空的元素，或元素没有值，该函数也返回 FALSE。

提示：该函数不会移动内部指针。要做到这一点，请使用 next() 和 prev() 函数。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

echo current($people) . "<br />";
?>

输出：

Peter

PHP Array 函数

PHP 参考手册
PHP 测验


PHP Date / Time 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Date / Time 函数

  • Previous Page
  • Next Page

PHP Date / Time 简介

date/time 函数允许您提取并格式化服务器上的日期和时间。

注释：这些函数依赖于服务器的本地设置。

安装

date/time 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

Runtime 配置

日期/时间函数的行为受到 php.ini 中设置的影响。

Date/Time 配置选项：

名称 | 默认 | 描述 | 可改变
date.default_latitude | "31.7667" | 规定默认纬度（从 PHP 5 开始可用）。date_sunrise() 和 date_sunset() 使用该选项。 | PHP_INI_ALL
date.default_longitude | "35.2333" | 规定默认经度（从 PHP 5 开始可用）。date_sunrise() 和 date_sunset() 使用该选项。 | PHP_INI_ALL
date.sunrise_zenith | "90.83" | 规定日出天顶（从 PHP 5 开始可用）。date_sunrise() 和 date_sunset() 使用该选项。 | PHP_INI_ALL
date.sunset_zenith | "90.83" | 规定日落天顶（从 PHP 5 开始可用）。date_sunrise() 和 date_sunset() 使用该选项。 | PHP_INI_ALL
date.timezone | "" | 规定默认时区（从 PHP 5.1 开始可用）。 | PHP_INI_ALL

PHP Date / Time 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
checkdate() | 验证格利高里日期。 | 3
date_default_timezone_get() | 返回默认时区。 | 5
date_default_timezone_set() | 设置默认时区。 | 5
date_sunrise() | 返回给定的日期与地点的日出时间。 | 5
date_sunset() | 返回给定的日期与地点的日落时间。 | 5
date() | 格式化本地时间／日期。 | 3
getdate() | 返回日期／时间信息。 | 3
gettimeofday() | 返回当前时间信息。 | 3
gmdate() | 格式化 GMT/UTC 日期/时间。 | 3
gmmktime() | 取得 GMT 日期的 UNIX 时间戳。 | 3
gmstrftime() | 根据本地区域设置格式化 GMT/UTC 时间／日期。 | 3
idate() | 将本地时间/日期格式化为整数 | 5
localtime() | 返回本地时间。 | 4
microtime() | 返回当前时间的微秒数。 | 3
mktime() | 返回一个日期的 Unix 时间戳。 | 3
strftime() | 根据区域设置格式化本地时间／日期。 | 3
strptime() | 解析由 strftime 生成的日期／时间。 | 5
strtotime() | 将任何英文文本的日期或时间描述解析为 Unix 时间戳。 | 3
time() | 返回当前时间的 Unix 时间戳。 | 3

PHP Date / Time 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
DATE_ATOM | 原子钟格式 (如: 2005-08-15T16:13:03+0000) |
DATE_COOKIE | HTTP Cookies 格式 (如: Sun, 14 Aug 2005 16:13:03 UTC) |
DATE_ISO8601 | ISO-8601 (如: 2005-08-14T16:13:03+0000) |
DATE_RFC822 | RFC 822 (如: Sun, 14 Aug 2005 16:13:03 UTC) |
DATE_RFC850 | RFC 850 (如: Sunday, 14-Aug-05 16:13:03 UTC) |
DATE_RFC1036 | RFC 1036 (如: Sunday, 14-Aug-05 16:13:03 UTC) |
DATE_RFC1123 | RFC 1123 (如: Sun, 14 Aug 2005 16:13:03 UTC) |
DATE_RFC2822 | RFC 2822 (如: Sun, 14 Aug 2005 16:13:03 +0000) |
DATE_RSS | RSS (如: Sun, 14 Aug 2005 16:13:03 UTC) |
DATE_W3C | World Wide Web Consortium (如: 2005-08-14T16:13:03+0000) |
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP date_default_timezone_get() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP date_default_timezone_get() 函数

PHP Date / Time 函数

定义和用法

date_default_timezone_get() 函数返回脚本中所有日期时间函数所使用的默认时区。

语法

date_default_timezone_get(void)
参数 | 描述
void | 可选。

说明

本函数返回默认时区，使用如下“假定”的顺序：

  • 用 date_default_timezone_set() 函数设定的时区（如果设定了的话）
  • TZ 环境变量（如果非空）
  • date.timezone 配置选项（如果设定了的话）
  • 自己推测（如果操作系统支持）
  • 如果以上选择都不成功，则返回 UTC

例子

<?php
echo(date_default_timezone_get());
?>

输出：

Europe/Paris

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP date_default_timezone_set() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP date_default_timezone_set() 函数

PHP Date / Time 函数

定义和用法

date_default_timezone_set() 函数设置用在脚本中所有日期/时间函数的默认时区。

语法

date_default_timezone_set(timezone)
参数 | 描述
timezone | 必需。时区标识符，比如 "UTC" 或 "Europe/Paris"。 合法时区的列表：http://www.php.net/manual/en/timezones.php

说明

注释：自 PHP 5.1.0 起（此版本日期时间函数被重写了），如果时区不合法则每个对日期时间函数的调用都会产生一条 E_NOTICE 级别的错误信息，如果使用系统设定或 TZ 环境变量则还会产生 E_STRICT 级别的信息。

例子

<?php
echo(date_default_timezone_set("Europe/Paris"));
?>

输出：

1

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP date_sunrise() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP date_sunrise() 函数

PHP Date / Time 函数

定义和用法

date_sunrise() 函数返回指定的日期与地点的日出时间。

语法

date_sunrise(timestamp,format,latitude,longitude,zenith,gmt_offset)
参数 | 描述
timestamp | 必需。
format

可选。规定如何返回结果：

  • SUNFUNCS_RET_STRING (以 string 格式返回结果，比如 16:46)
  • SUNFUNCS_RET_DOUBLE (以 float 格式返回结果，比如 16.78243132)
  • SUNFUNCS_RET_TIMESTAMP (以 integer 格式（时间戳）返回结果，比如 1095034606)
latitude | 可选。规定地点的纬度。默认是指北纬。因此如果要指定南纬，必须传递一个负值。
longitude | 可选。规定地点的经度。默认是指东经。因此如果要指定西经，必须传递一个负值。
zenith | 可选。
gmt_offset | 可选。规定 GMT 与本地时间的差值。单位是小时。

例子

<?php
//计算葡萄牙里斯本的日出时间
//Latitude: 北纬 38.4 度
//Longitude: 西经 9 度
//Zenith ~= 90
//offset: +1 GMT
echo("Date: " . date("D M d Y") . "<br />");
echo("Sunrise time: ");
echo(date_sunrise(time(),SUNFUNCS_RET_STRING,38.4,-9,90,1));
?>

输出：

Date: Tue Jan 24 2006
Sunrise time: 08:52

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP date_sunset() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP date_sunset() 函数

PHP Date / Time 函数

定义和用法

date_sunset() 函数返回指定的日期与地点的日落时间。

语法

date_sunset(timestamp,format,latitude,longitude,zenith,gmt_offset)
参数 | 描述
timestamp | 必需。
format

可选。规定如何返回结果：

  • SUNFUNCS_RET_STRING (以 string 格式返回结果，比如 16:46)
  • SUNFUNCS_RET_DOUBLE (以 float 格式返回结果，比如 16.78243132)
  • SUNFUNCS_RET_TIMESTAMP (以 integer 格式（时间戳）返回结果，比如 1095034606)
latitude | 可选。规定地点的纬度。默认是指北纬。因此如果要指定南纬，必须传递一个负值。
longitude | 可选。规定地点的经度。默认是指东经。因此如果要指定西经，必须传递一个负值。
zenith | 可选。
gmt_offset | 可选。规定 GMT 与本地时间的差值。单位是小时。

例子

<?php
//计算葡萄牙里斯本的日出时间
//Latitude: 北纬 38.4 度
//Longitude: 西经 9 度
//Zenith ~= 90
//offset: +1 GMT
echo("Date: " . date("D M d Y") . "<br />");
echo("Sunrise time: ");
echo(date_sunset(time(),SUNFUNCS_RET_STRING,38.4,-9,90,1));
?>

输出：

Date: Tue Jan 24 2006
Sunrise time: 18:44

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP date() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP date() 函数

PHP Date / Time 函数

定义和用法

date() 函数格式化一个本地时间／日期。

语法

date(format,timestamp)
参数 | 描述
format | 必需。规定如何返回结果。
timestamp | 可选。

例子

<?php
echo("Result with date():<br />");
echo(date("l") . "<br />");
echo(date("l dS \of F Y h:i:s A") . "<br />");
echo("Oct 3,1975 was on a ".date("l", mktime(0,0,0,10,3,1975))."<br />");
echo(date(DATE_RFC822) . "<br />");
echo(date(DATE_ATOM,mktime(0,0,0,10,3,1975)) . "<br /><br />");

echo("Result with gmdate():<br />");
echo(gmdate("l") . "<br />");
echo(gmdate("l dS \of F Y h:i:s A") . "<br />");
echo("Oct 3,1975 was on a ".gmdate("l", mktime(0,0,0,10,3,1975))."<br />");
echo(gmdate(DATE_RFC822) . "<br />");
echo(gmdate(DATE_ATOM,mktime(0,0,0,10,3,1975)) . "<br />");
?>

输出：

Result with date():
Tuesday
Tuesday 24th of January 2006 02:41:22 PM
Oct 3,1975 was on a Friday
Tue, 24 Jan 2006 14:41:22 CET
1975-10-03T00:00:00+0100

Result with gmdate():
Tuesday
Tuesday 24th of January 2006 01:41:22 PM
Oct 3,1975 was on a Thursday
Tue, 24 Jan 2006 13:41:22 GMT
1975-10-02T23:00:00+0000

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP debug_backtrace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP debug_backtrace() 函数

PHP Error 和 Logging 函数

定义和用法

PHP debug_backtrace() 函数生成一个 backtrace。

该函数返回一个关联数组。下面是可能返回的元素：

名称 | 类型 | 描述
function | 字符串 | 当前的函数名。
line | 整数 | 当前的行号。
file | 字符串 | 当前的文件名。
class | 字符串 | 当前的类名
object | 对象 | 当前对象。
type 字符串 当前的调用类型，可能的调用：
  • 返回: "->" - 方法调用
  • 返回: "::" - 静态方法调用
  • 返回 nothing - 函数调用
args | 数组 | 如果在函数中，列出函数参数。如果在被引用的文件中，列出被引用的文件名。

语法

debug_backtrace()

例子

<?php
function one($str1, $str2)
 {
 two("Glenn", "Quagmire");
 }
function two($str1, $str2)
 {
 three("Cleveland", "Brown");
 }
function three($str1, $str2)
 {
 print_r(debug_backtrace());
 }

one("Peter", "Griffin");
?>

输出：

Array
(
[0] => Array
 (
 [file] => C:\webfolder\test.php
 [line] => 7
 [function] => three
 [args] => Array
  (
  [0] => Cleveland
  [1] => Brown
  )
 )
[1] => Array
 (
 [file] => C:\webfolder\test.php
 [line] => 3
 [function] => two
 [args] => Array
  (
  [0] => Glenn
  [1] => Quagmire
  )
 )
[2] => Array
 (
 [file] => C:\webfolder\test.php
 [line] => 14
 [function] => one
 [args] => Array
  (
  [0] => Peter
  [1] => Griffin
  )
 )
)

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP debug_print_backtrace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP debug_print_backtrace() 函数

PHP Error 和 Logging 函数

定义和用法

debug_print_backtrace() 函数输出 backtrace。

语法

debug_print_backtrace()

例子

<?php
function one($str1, $str2)
 {
 two("Glenn", "Quagmire");
 }
function two($str1, $str2)
 {
 three("Cleveland", "Brown");
 }
function three($str1, $str2)
 {
 debug_print_backtrace();
 }

one("Peter", "Griffin");
?>

输出：

#0 three(Cleveland, Brown) called at [C:\webfolder\test.php:8]
#1 two(Glenn, Quagmire) called at [C:\webfolder\test.php:4]
#2 one(Peter, Griffin) called at [C:\webfolder\test.php:15]

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP decbin() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP decbin() 函数

PHP Math 函数

定义和用法

decbin() 函数把十进制转换为二进制。

语法

decbin(dec_number)
参数 | 描述
dec_number | 必需。规定要转换的十进制数。

说明

返回一个字符串，包含有给定 dec_number 参数的二进制表示。所能转换的最大数值为十进制的 4294967295，其结果为 32 个 1 的字符串。

例子

<?php
echo decbin("3");
echo decbin("1");
echo decbin("1587");
echo decbin("7");
?>

输出：

11
1
11000110011
111

PHP Math 函数

PHP 参考手册
PHP 测验


PHP dechex() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP dechex() 函数

PHP Math 函数

定义和用法

dechex() 函数把十进制转换为十六进制。

语法

dechex(dec_number)
参数 | 描述
dec_number | 必需。规定要转换的十进制数。

说明

返回一个字符串，包含有给定 binary_string 参数的十六进制表示。所能转换的最大数值为十进制的 4294967295，其结果为 ""ffffffff"。

例子

<?php
echo dechex("30");
echo dechex("10");
echo dechex("1587");
echo dechex("70");
?>

输出：

1e
a
633
46

PHP Math 函数

PHP 参考手册
PHP 测验


PHP decoct() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP decoct() 函数

PHP Math 函数

定义和用法

decoct() 函数把十进制转换为八进制。

语法

decoct(dec_number)
参数 | 描述
dec_number | 必需。规定要转换的十进制数。

说明

返回一个字符串，包含有给定 dec_number 参数的八进制表示。所能转换的最大数值为十进制的 4294967295，其结果为 "37777777777"。

例子

<?php
echo decoct("30");
echo decoct("10");
echo decoct("1587");
echo decoct("70");
?>

输出：

36
12
3063
106

PHP Math 函数

PHP 参考手册
PHP 测验


PHP define() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP define() 函数

PHP 杂项函数

定义和用法

define() 函数定义一个常量。

常量类似变量，不同之处在于：

  • 在设定以后，常量的值无法更改
  • 常量名不需要开头的美元符号 ($)
  • 作用域不影响对常量的访问
  • 常量值只能是字符串或数字

语法

define(name,value,case_insensitive)
参数 | 描述
name | 必需。规定常量的名称。
value | 必需。规定常量的值。
case_insensitive | 必需。规定常量的名称是否对大小写敏感。 若设置为 true，则对大小写不敏感。默认是 false（大小写敏感）。

例子

例子 1

定义一个大小写敏感的常量：

<?php
define("GREETING","Hello world!");
echo constant("GREETING");
?>

输出：

Hello world!

例子 2

定义一个大小写不敏感的常量：

<?php
define("GREETING","Hello world!",TRUE);
echo constant("greeting");
?>

输出：

Hello world!

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP defined() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP defined() 函数

PHP 杂项函数

定义和用法

defined() 函数检查某常量是否存在。

若常量存在，则返回 true，否则返回 false。

语法

defined(name)
参数 | 描述
name | 必需。规定要检查的常量的名称。

例子

<?php
define("GREETING","Hello world!");
echo defined("GREETING");
?>

输出：

1

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP deg2rad() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP deg2rad() 函数

PHP Math 函数

定义和用法

deg2rad() 函数将角度转换为弧度。

语法

deg2rad(degree_number)
参数 | 描述
degree_number | 必需。规定要转换的角度。

说明

本函数把 degree_number 从角度转换成弧度。

例子 1

<?php
echo deg2rad("30");
echo deg2rad("10");
echo deg2rad("1587");
echo deg2rad("70");
?>

输出：

0.523598775598
0.174532925199
27.6983752292
1.2217304764

例子 2

<?php
$deg = 180;
$rad = deg2rad($deg);
echo "角度 $deg 等于弧度 $rad";
?>

输出：

角度 180 等于弧度 3.14159265359

PHP Math 函数

PHP 参考手册
PHP 测验


PHP die() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP die() 函数

PHP 杂项函数

定义和用法

die() 函数输出一条消息，并退出当前脚本。

该函数是 exit() 函数的别名。

语法

die(status)
参数 | 描述
status | 必需。规定在退出脚本之前写入的消息或状态号。状态号不会被写入输出。

说明

如果 status 是字符串，则该函数会在退出前输出字符串。

如果 status 是整数，这个值会被用作退出状态。退出状态的值在 0 至 254 之间。退出状态 255 由 PHP 保留，不会被使用。状态 0 用于成功地终止程序。

提示和注释

注释：如果 PHP 的版本号大于等于 4.2.0，那么在 status 是整数的情况下，不会输出该参数。

例子

<?php
$site = "http://www.w3school.com.cn/";
fopen($site,"r")
or die("Unable to connect to $site");
?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP dir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP dir() 函数

PHP Directory 函数

定义和用法

dir() 函数打开一个目录句柄，并返回一个对象。这个对象包含三个方法：read() , rewind() 以及 close()。

若成功，则该函数返回一个目录流，否则返回 false 以及一个 error。可以通过在函数名前加上 "@" 来隐藏 error 的输出。

语法

dir(directory)
参数 | 描述
directory | 必需。规定目录。

例子

例子 1

<?php
//打开 images 目录
$dir = dir("images");

//列出 images 目录中的文件
while (($file = $dir->read()) !== false)
{
echo "filename: " . $file . "<br />";
}

$dir->close();
?>

输出：

filename: .
filename: ..
filename: cat.gif
filename: dog.gif
filename: food
filename: horse.gif

例子 2

如果 dir() 的输出失败，本例会隐藏错误：

<?php
//打开 images 目录
$dir = @ dir("images");

//列出 images 目录中的文件
while (($file = $dir->read()) !== false)
  {
  echo "filename: " . $file . "<br />";
  }

$dir->close();
?>

输出：

filename: .
filename: ..
filename: cat.gif
filename: dog.gif
filename: food
filename: horse.gif

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP Directory 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Directory 函数

  • Previous Page
  • Next Page

PHP Directory 简介

Directory 函数允许您获得关于目录及其内容的信息。

安装

Directory 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP Directory 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
chdir() | 改变当前的目录。 | 3
chroot() | 改变当前进程的根目录。 | 4
dir() | 打开一个目录句柄，并返回一个对象。 | 3
closedir() | 关闭目录句柄。 | 3
getcwd() | 返回当前目录。 | 4
opendir() | 打开目录句柄。 | 3
readdir() | 返回目录句柄中的条目。 | 3
rewinddir() | 重置目录句柄。 | 3
scandir() | 列出指定路径中的文件和目录。 | 5

PHP Directory 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
DIRECTORY_SEPARATOR |  | 3
PATH_SEPARATOR |  | 4
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP dirname() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP dirname() 函数

PHP Filesystem 函数

定义和用法

dirname() 函数返回路径中的目录部分。

语法

dirname(path)
参数 | 描述
path | 必需。规定要检查的路径。

说明

path 参数是一个包含有指向一个文件的全路径的字符串。该函数返回去掉文件名后的目录名。

例子

<?php
echo dirname("c:/testweb/home.php");
echo dirname("/testweb/home.php");
?>

输出：

c:/testweb
/testweb

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP disk_free_space() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP disk_free_space() 函数

PHP Filesystem 函数

定义和用法

disk_free_space() 函数返回目录中的可用空间

语法

disk_free_space(directory)
参数 | 描述
directory | 必需。规定要检查的目录。

说明

directory 参数是一个目录的字符串。该函数将根据相应的文件系统或磁盘分区返回可用的字节数。

例子

<?php
echo disk_free_space("C:");
?>

输出：

209693288558

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP disk_total_space() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP disk_total_space() 函数

PHP Filesystem 函数

定义和用法

disk_total_space() 函数返回指定目录的磁盘总大小。

语法

disk_total_space(directory)
参数 | 描述
directory | 必需。规定要检查的目录。

说明

directory 参数是一个目录的字符串。该函数将根据相应的文件系统或磁盘分区返回所有的字节数。

提示和注释

提示：本函数返回的是该目录所在的磁盘分区的总大小，因此在给出同一个磁盘分区的不同目录作为参数所得到的结果完全相同。在 Unix 和 Windows 200x/XP 中都支持将一个磁盘分区加载为一个子目录，这时正确使用本函数就很有意义。

例子

<?php
echo disk_total_space("C:");
?>

输出类似这样：

509693888668

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP diskfreespace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP diskfreespace() 函数

PHP Filesystem 函数

定义和用法

diskfreespace() 函数返回目录中的可用空间。该函数是 disk_free_space() 函数的别名。

语法

diskfreespace(directory)
参数 | 描述
directory | 必需。规定要检查的目录。

说明

directory 参数是一个目录的字符串。该函数将根据相应的文件系统或磁盘分区返回可用的字节数。

例子

<?php
echo diskfreespace("C:");
?>

输出：

209693288558

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP each() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP each() 函数

PHP Array 函数

定义和用法

each() 函数生成一个由数组当前内部指针所指向的元素的键名和键值组成的数组，并把内部指针向前移动。

返回的数组中包括的四个元素：键名为 0，1，key 和 value。单元 0 和 key 包含有数组单元的键名，1 和 value 包含有数据。

如果内部指针越过了数组范围，本函数将返回 FALSE。

语法

each(array)
参数 | 描述
array | 必需。规定要使用的数组。

例子 1

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");
print_r (each($people));
?>

输出：

Array ( [1] => Peter [value] => Peter [0] => 0 [key] => 0 )

例子 2

each() 经常和 list() 结合使用来遍历数组。本例与上例类似，不过循环输出了整个数组：

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

reset($people);

while (list($key, $val) = each($people))
  {
  echo "$key => $val<br />";
  }
?>

输出：

0 => Peter
1 => Joe
2 => Glenn
3 => Cleveland

例子解释

因为将一个数组赋值给另一个数组时会重置原来的数组指针，因此在上例中如果我们在循环内部将 $people 赋给了另一个变量的话将会导致无限循环。

PHP Array 函数

PHP 参考手册
PHP 测验


PHP easter_date() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP easter_date() 函数

PHP Array 函数

定义和用法

easter_date() 函数返回指定年份的复活节午夜的 Unix 时间戳。

输入一个年份，则以 UNIX 时间戳记的格式返回该年的复活节日期，若没有输入年份，则计算当年的日期。

语法

easter_date(year)
参数 | 描述
year | 可选。定义用于计算复活节日期的年份。若省略，使用当年。

提示和注释

注释：如果年份在 Unix 时间戳的范围之外（1970 之前或 2037 之后），该函数会生成一个警告。可使用 easter_days() 代替 easter_date() 来计算年份在范围之外的复活节日期。

例子

<?php
echo(easter_date() . "<br />");
echo(date("M-d-Y",easter_date()) . "<br />");
echo(date("M-d-Y",easter_date(2000)) . "<br />");
echo(date("M-d-Y",easter_date(2001)) . "<br />");
echo(date("M-d-Y",easter_date(2002)));
?>

输出：

1145138400
Apr-16-2006
Apr-23-2000
Apr-15-2001
Mar-31-2002

PHP Array 函数

PHP 参考手册
PHP 测验


PHP easter_days() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP easter_days() 函数

PHP Array 函数

定义和用法

easter_days() 函数返回指定年份的复活节与 3 月 21 日之间的天数。

输入一个年份，则计算该年复活节与三月二十一日之间的日期数，若没有输入年份，则以当年计算。这个函数可以用来替代 easter_date() 在 1970-2037 年范围外无法计算的问题。

语法

easter_date(year)
参数 | 描述
year | 可选。定义用于计算复活节日期的年份。若省略，使用当年。
method | 可选。允许你计算机与其它历法的复活节日期。例如，如果设置为 CAL_EASTER_ROMAN，则使用 1582 - 1752 年期间的格利高里历法。

例子

<?php
echo(easter_days() . "<br />");
echo(easter_days(1990) . "<br />");
echo(easter_days(1342) . "<br />");
echo(easter_days(2050);
?>

输出：

26
25
10
20

PHP Array 函数

PHP 参考手册
PHP 测验


PHP echo() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP echo() 函数

PHP String 函数

定义和用法

echo() 函数输出一个或多个字符串。

语法

echo(strings)
参数 | 描述
strings | 必需。一个或多个要发送到输出的字符串。

提示和注释

注释：echo() 实际上不是一个函数，因此您无需对其使用括号。不过，如果您希望向 echo() 传递一个或多个参数，那么使用括号会发生解析错误。

提示：echo() 函数比 print() 函数快一点点。

提示：echo() 函数可以使用简化语法。参见例子 5。

例子

例子 1

<?php
$str = "Who's John Adams?";
echo $str;
echo "<br />";
echo $str."<br />I don't know!";
?>

输出：

Who's John Adam?
Who's John Adam?
I don't know!

例子 2

<?php
echo "This text
spans multiple
lines.";
?>

输出：

This text spans multiple lines.

例子 3

<?php
echo 'This ','string ','was ','made ','with multiple parameters';
?>

输出：

This string was made with multiple parameters

例子 4

单引号和双引号的不同之处。单引号仅输出变量名，而不是值：

<?php
$color = "red";
echo "Roses are $color";
echo "<br />";
echo 'Roses are $color';
?>

输出：

Roses are red
Roses are $color

例子 5

简化语法：

<html>
<body>

<?php
$color = "red";
?>

<p>Roses are <?=$color?></p>

</body>
</html>

PHP String 函数

PHP 参考手册
PHP 测验


PHP end() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP each() 函数

PHP Array 函数

定义和用法

end() 函数将数组内部指针指向最后一个元素，并返回该元素的值（如果成功）。

语法

end(array)
参数 | 描述
array | 必需。规定要使用的数组。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

echo current($people) . "<br />";
echo end($people);
?>

输出：

Peter
Cleveland

PHP Array 函数

PHP 参考手册
PHP 测验


PHP error_get_last() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP error_get_last() 函数

PHP Error 和 Logging 函数

定义和用法

error_get_last() 函数获取最后发生的错误。

该函数以数组的形式返回最后发生的错误。

返回的数组包含 4 个键和值：

  • [type] - 错误类型
  • [message] - 错误消息
  • [file] - 发生错误所在的文件
  • [line] - 发生错误所在的行

语法

error_get_last()

例子

<?php
echo $test;
print_r(error_get_last());
?>

输出：

Array
(
[type] => 8
[message] => Undefined variable: test
[file] => C:\webfolder\test.php
[line] => 2
)

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP error_log() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP error_log() 函数

PHP Error 和 Logging 函数

定义和用法

error_log() 函数向服务器错误记录、文件或远程目标发送一个错误。

若成功，返回 true，否则返回 false。

语法

error_log(error,type,destination,headers)
参数 | 描述
error | 必需。要记录的错误消息。
type

可选。规定错误记录的类型。

可能的记录类型：

  • 0 - 默认。根据在 php.ini 文件中的 error_log 配置，错误被发送到服务器日志系统或文件。
  • 1 - 错误被发送到 destination 参数中的地址。只有该类型使用 headers 参数。
  • 2 - 通过 PHP debugging 连接来发送错误。该选项只在 PHP 3 中可用。
  • 3 - 错误发送到文件目标字符串。
destination | 可选。规定向何处发送错误消息。该参数的值依赖于 "type" 参数的值。
headers

可选。只在 "type" 为 1 时使用。

规定附加的头部，比如 From, Cc 以及 Bcc。由 CRLF (\r\n) 分隔。

注释：在发送电子邮件时，必须包含 From 头部。可以在 php.ini 文件中或者通过此参数设置。

例子

本例发送一封带有自定义错误的电子邮件：

<?php
$test=2;

if ($test>1)
{
error_log("A custom error has been triggered",
1,"someone@example.com","From: webmaster@example.com");
}
?>

输出：

A custom error has been triggered

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP error_reporting() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP error_reporting() 函数

PHP Error 和 Logging 函数

定义和用法

error_reporting() 设置 PHP 的报错级别并返回当前级别。

语法

error_reporting(report_level)

如果参数 level 未指定，当前报错级别将被返回。下面几项是 level 可能的值：

值 | 常量 | 描述
1 | E_ERROR | Fatal run-time errors. Errors that can not be recovered from. Execution of the script is halted
2 | E_WARNING | Non-fatal run-time errors. Execution of the script is not halted
4 | E_PARSE | Compile-time parse errors. Parse errors should only be generated by the parser
8 | E_NOTICE | Run-time notices. The script found something that might be an error, but could also happen when running a script normally
16 | E_CORE_ERROR | Fatal errors at PHP startup. This is like an E_ERROR in the PHP core
32 | E_CORE_WARNING | Non-fatal errors at PHP startup. This is like an E_WARNING in the PHP core
64 | E_COMPILE_ERROR | Fatal compile-time errors. This is like an E_ERROR generated by the Zend Scripting Engine
128 | E_COMPILE_WARNING | Non-fatal compile-time errors. This is like an E_WARNING generated by the Zend Scripting Engine
256 | E_USER_ERROR | Fatal user-generated error. This is like an E_ERROR set by the programmer using the PHP function trigger_error()
512 | E_USER_WARNING | Non-fatal user-generated warning. This is like an E_WARNING set by the programmer using the PHP function trigger_error()
1024 | E_USER_NOTICE | User-generated notice. This is like an E_NOTICE set by the programmer using the PHP function trigger_error()
2048 | E_STRICT | Run-time notices. PHP suggest changes to your code to help interoperability and compatibility of the code
4096 | E_RECOVERABLE_ERROR | Catchable fatal error. This is like an E_ERROR but can be caught by a user defined handle (see also set_error_handler())
8191 | E_ALL | All errors and warnings, except level E_STRICT (E_STRICT will be part of E_ALL as of PHP 6.0)

例子

任意数目的以上选项都可以用“或”来连接（用 OR 或 |），这样可以报告所有需要的各级别错误。例如，下面的代码关闭了用户自定义的错误和警告，执行了某些操作，然后恢复到原始的报错级别：

<?php
//禁用错误报告
error_reporting(0);

//报告运行时错误
error_reporting(E_ERROR | E_WARNING | E_PARSE);

//报告所有错误
error_reporting(E_ALL);
?>

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP Error 和 Logging 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Error 和 Logging 函数

  • Previous Page
  • Next Page

PHP Error 和 Logging 简介

error 和 logging 函数允许你对错误进行处理和记录。

error 函数允许用户定义错误处理规则，并修改记录错误的方式。

logging 函数允许用户对应用程序进行日志记录，并把日志消息发送到电子邮件、系统日志或其他的机器。

安装

error 和 logging 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP Error 和 Logging 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
debug_backtrace() | 生成 backtrace。 | 4
debug_print_backtrace() | 输出 backtrace。 | 5
error_get_last() | 获得最后发生的错误。 | 5
error_log() | 向服务器错误记录、文件或远程目标发送一个错误。 | 4
error_reporting() | 规定报告哪个错误。 | 4
restore_error_handler() | 恢复之前的错误处理程序。 | 4
restore_exception_handler() | 恢复之前的异常处理程序。 | 5
set_error_handler() | 设置用户自定义的错误处理函数。 | 4
set_exception_handler() | 设置用户自定义的异常处理函数。 | 5
trigger_error() | 创建用户自定义的错误消息。 | 4
user_error() | trigger_error() 的别名。 | 4

PHP Error 和 Logging 常量

PHP：指示支持该常量的最早的 PHP 版本。

值 | 常量 | 描述 | PHP
1 | E_ERROR | 致命的运行时错误。错误无法恢复。脚本的执行被中断。 |
2 | E_WARNING | 非致命的运行时错误。脚本的执行不会中断。 |
4 | E_PARSE | 编译时语法解析错误。解析错误只应该由解析器生成。 |
8 | E_NOTICE | 运行时提示。可能是错误，也可能在正常运行脚本时发生。 |
16 | E_CORE_ERROR | 由 PHP 内部生成的错误。 | 4
32 | E_CORE_WARNING | 由 PHP 内部生成的警告。 | 4
64 | E_COMPILE_ERROR | 由 Zend 脚本引擎内部生成的错误。 | 4
128 | E_COMPILE_WARNING | 由 Zend 脚本引擎内部生成的警告。 | 4
256 | E_USER_ERROR | 由于调用 trigger_error() 函数生成的运行时错误。 | 4
512 | E_USER_WARNING | 由于调用 trigger_error() 函数生成的运行时警告。 | 4
1024 | E_USER_NOTICE | 由于调用 trigger_error() 函数生成的运行时提示。 | 4
2048 | E_STRICT | 运行时提示。对增强代码的互用性和兼容性有益。 | 5
4096 | E_RECOVERABLE_ERROR | 可捕获的致命错误。（参阅 set_error_handler()） | 5
8191 | E_ALL | 所有的错误和警告，除了 E_STRICT。 | 5
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP eval() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP eval() 函数

PHP 杂项函数

定义和用法

eval() 函数把字符串按照 PHP 代码来计算。

该字符串必须是合法的 PHP 代码，且必须以分号结尾。

如果没有在代码字符串中调用 return 语句，则返回 NULL。如果代码中存在解析错误，则 eval() 函数返回 false。

语法

eval(phpcode)
参数 | 描述
phpcode | 必需。规定要计算的 PHP 代码。

提示和注释

注释：返回语句会立即终止对字符串的计算。

注释：该函数对于在数据库文本字段中供日后计算而进行的代码存储很有用。

例子

<?php
$string = "beautiful";
$time = "winter";

$str = 'This is a $string $time morning!';
echo $str. "<br />";

eval("\$str = \"$str\";");
echo $str;
?>

输出：

This is a $string $time morning!
This is a beautiful winter morning!

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP exit() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP exit() 函数

PHP 杂项函数

定义和用法

exit() 函数输出一条消息，并退出当前脚本。

该函数是 die() 函数的别名。

语法

exit(status)
参数 | 描述
status | 必需。规定在退出脚本之前写入的消息或状态号。状态号不会被写入输出。

说明

如果 status 是字符串，则该函数会在退出前输出字符串。

如果 status 是整数，这个值会被用作退出状态。退出状态的值在 0 至 254 之间。退出状态 255 由 PHP 保留，不会被使用。状态 0 用于成功地终止程序。

提示和注释

注释：如果 PHP 的版本号大于等于 4.2.0，那么在 status 是整数的情况下，不会输出该参数。

例子

<?php
$site = "http://www.w3school.com.cn/";
fopen($site,"r")
or exit("Unable to connect to $site");
?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP exp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP exp() 函数

PHP Math 函数

定义和用法

exp() 函数计算 e 的指数。

语法

exp(x)
参数 | 描述
x | 必需。一个数。

说明

返回 e 的 x 次方值。。

提示和注释

提示：用 'e' 作为自然对数的底 2.718282。

例子

在本例中，我们将对不同的数应用 exp() 函数：

<?php
echo(exp(1));
echo(exp(-1));
echo(exp(5));
echo(exp(10))
?>

输出：

2.718281828459045
0.36787944117144233
148.4131591025766
22026.465794806718

PHP Math 函数

PHP 参考手册
PHP 测验


PHP explode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP explode() 函数

PHP String 函数

定义和用法

explode() 函数把字符串分割为数组。

语法

explode(separator,string,limit)
参数 | 描述
separator | 必需。规定在哪里分割字符串。
string | 必需。要分割的字符串。
limit | 可选。规定所返回的数组元素的最大数目。

说明

本函数返回由字符串组成的数组，其中的每个元素都是由 separator 作为边界点分割出来的子字符串。

separator 参数不能是空字符串。如果 separator 为空字符串（""），explode() 将返回 FALSE。如果 separator 所包含的值在 string 中找不到，那么 explode() 将返回包含 string 中单个元素的数组。

如果设置了 limit 参数，则返回的数组包含最多 limit 个元素，而最后那个元素将包含 string 的剩余部分。

如果 limit 参数是负数，则返回除了最后的 -limit 个元素外的所有元素。此特性是 PHP 5.1.0 中新增的。

提示和注释

注释：参数 limit 是在 PHP 4.0.1 中加入的。

注释：由于历史原因，虽然 implode() 可以接收两种参数顺序，但是 explode() 不行。你必须保证 separator 参数在 string 参数之前才行。

例子

在本例中，我们将把字符串分割为数组：

<?php
$str = "Hello world. It's a beautiful day.";
print_r (explode(" ",$str));
?>

输出：

Array
(
[0] => Hello
[1] => world.
[2] => It's
[3] => a
[4] => beautiful
[5] => day.
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP expm1() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP expm1() 函数

PHP Math 函数

定义和用法

expm1() 函数返回 exp(x) - 1，甚至当 number 的值接近零也能计算出准确结果。

语法

expm1(x)
参数 | 描述
x | 必需。一个数。

说明

expm1() 返回 'exp(x) - 1'，甚至当 x 的值接近零也能计算出准确结果。但是当两个数值趋近于相等的时候， 'exp (x) - 1' 就会变得不太准确。

提示和注释

警告：本函数是实验性的。本函数的行为，包括函数名称以及其它任何关于本函数的文档可能会在没有通知的情况下随 PHP 以后的发布而改变。使用本函数风险自担。

提示：用 'e' 作为自然对数的底 2.718282。

注释：本函数未在 Windows 平台下实现。

例子

在本例中，我们将对不同的数应用 expm1() 函数：

<?php
echo(expm1(1));
echo(expm1(-1));
echo(expm1(5));
echo(expm1(10))
?>

PHP Math 函数

PHP 参考手册
PHP 测验


PHP extract() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP extract() 函数

PHP Array 函数

定义和用法

PHP extract() 函数从数组中把变量导入到当前的符号表中。

对于数组中的每个元素，键名用于变量名，键值用于变量值。

第二个参数 type 用于指定当某个变量已经存在，而数组中又有同名元素时，extract() 函数如何对待这样的冲突。

本函数返回成功设置的变量数目。

语法

extract(array,extract_rules,prefix)
参数 | 描述
array | 必需。规定要使用的输入。
extract_rules

可选。extract() 函数将检查每个键名是否为合法的变量名，同时也检查和符号表中的变量名是否冲突。

对非法、数字和冲突的键名的处理将根据此参数决定。可以是以下值之一：

可能的值：

  • EXTR_OVERWRITE - 默认。如果有冲突，则覆盖已有的变量。
  • EXTR_SKIP - 如果有冲突，不覆盖已有的变量。（忽略数组中同名的元素）
  • EXTR_PREFIX_SAME - 如果有冲突，在变量名前加上前缀 prefix。自 PHP 4.0.5 起，这也包括了对数字索引的处理。
  • EXTR_PREFIX_ALL - 给所有变量名加上前缀 prefix（第三个参数）。
  • EXTR_PREFIX_INVALID - 仅在非法或数字变量名前加上前缀 prefix。本标记是 PHP 4.0.5 新加的。
  • EXTR_IF_EXISTS - 仅在当前符号表中已有同名变量时，覆盖它们的值。其它的都不处理。可以用在已经定义了一组合法的变量，然后要从一个数组例如 $_REQUEST 中提取值覆盖这些变量的场合。本标记是 PHP 4.2.0 新加的。
  • EXTR_PREFIX_IF_EXISTS - 仅在当前符号表中已有同名变量时，建立附加了前缀的变量名，其它的都不处理。本标记是 PHP 4.2.0 新加的。
  • EXTR_REFS - 将变量作为引用提取。这有力地表明了导入的变量仍然引用了 var_array 参数的值。可以单独使用这个标志或者在 extract_type 中用 OR 与其它任何标志结合使用。本标记是 PHP 4.3.0 新加的。
prefix

可选。请注意 prefix 仅在 extract_type 的值是 EXTR_PREFIX_SAME，EXTR_PREFIX_ALL，EXTR_PREFIX_INVALID 或 EXTR_PREFIX_IF_EXISTS 时需要。如果附加了前缀后的结果不是合法的变量名，将不会导入到符号表中。

前缀和数组键名之间会自动加上一个下划线。

例子 1

<?php
$a = 'Original';
$my_array = array("a" => "Cat","b" => "Dog", "c" => "Horse");
extract($my_array);
echo "\$a = $a; \$b = $b; \$c = $c";
?>

输出：

$a = Cat; $b = Dog; $c = Horse

例子 2

使用全部参数：

<?php
$a = 'Original';
$my_array = array("a" => "Cat","b" => "Dog", "c" => "Horse");

extract($my_array, EXTR_PREFIX_SAME, 'dup');

echo "\$a = $a; \$b = $b; \$c = $c; \$dup_a = $dup_a;";
?>

输出：

$a = Original; $b = Dog; $c = Horse; $dup_a = Cat;

PHP Array 函数

PHP 参考手册
PHP 测验


PHP fclose() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fclose() 函数

PHP Filesystem 函数

定义和用法

fclose() 函数关闭一个打开文件。

语法

fclose(file)
参数 | 描述
file | 必需。规定要关闭的文件。

说明

file 参数是一个文件指针。fclose() 函数关闭该指针指向的文件。

如果成功则返回 true，否则返回 false。

文件指针必须有效，并且是通过 fopen() 或 fsockopen() 成功打开的。

例子

<?php
$file = fopen("test.txt","r");

//执行的一些代码...

fclose($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP feof() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP feof() 函数

PHP Filesystem 函数

定义和用法

feof() 函数检测是否已到达文件末尾 (eof)。

如果文件指针到了 EOF 或者出错时则返回 TRUE，否则返回一个错误（包括 socket 超时），其它情况则返回 FALSE。

语法

feof(file)
参数 | 描述
file | 必需。规定要检查的打开文件。

说明

file 参数是一个文件指针。这个文件指针必须有效，并且必须指向一个由 fopen() 或 fsockopen() 成功打开（但还没有被 fclose() 关闭）的文件。

提示和注释

提示：feof() 函数对遍历长度未知的数据很有用。

注意：如果服务器没有关闭由 fsockopen() 所打开的连接，feof() 会一直等待直到超时而返回 TRUE。默认的超时限制是 60 秒，可以使用 stream_set_timeout() 来改变这个值。

注意：如果传递的文件指针无效可能会陷入无限循环中，因为 EOF 不会返回 TRUE。

例子

<?php
$file = fopen("test.txt", "r");

//输出文本中所有的行，直到文件结束为止。
while(! feof($file))
  {
  echo fgets($file). "<br />";
  }

fclose($file);
?>

输出：

Hello, this is a test file.
There are three lines here.
This is the last line.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fflush() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fflush() 函数

PHP Filesystem 函数

定义和用法

fflush() 函数将缓冲内容输出到文件。

语法

fflush(file)
参数 | 描述
file | 必需。规定要检查的文件流。

说明

本函数强制将所有缓冲的输出写入 file 文件句柄所指向的资源。如果成功则返回 true，否则返回 false。

文件指针必须有效，并且必须指向一个由 fopen() 或 fsockopen() 成功打开（但还没有被 fclose() 关闭）的文件。

例子

<?php
file = fopen("test.txt","r+");

// 一些代码

fflush($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fgetc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fgetc() 函数

PHP Filesystem 函数

定义和用法

fgetc() 函数从文件指针中读取一个字符。

语法

fgetc(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

返回一个包含有一个字符的字符串，该字符从 file 指向的文件中得到。碰到 EOF 则返回 false。

文件指针必须有效，并且必须指向一个由 fopen() 或 fsockopen() 成功打开（但还没有被 fclose() 关闭）的文件。

提示和注释

注意：该函数可能返回布尔值 false，但也可能返回一个与 false 等值的非布尔值，例如 0 或者 ""。

注释：该函数可安全用于二进制对象。

例子

例子 1

<?php

$file = fopen("test.txt","r");
echo fgetc($file);
fclose($file);

?>

输出类似：

H

例子 2

<?php

$file = fopen("test.txt","r");

while (! feof ($file))
  {
  echo fgetc($file);
  }

fclose($file);
?>

输出类似：

Hello, this is a test file.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fgetcsv() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fgetcsv() 函数

PHP Filesystem 函数

定义和用法

fgetcsv() 函数从文件指针中读入一行并解析 CSV 字段。

与 fgets() 类似，不同的是 fgetcsv() 解析读入的行并找出 CSV 格式的字段，然后返回一个包含这些字段的数组。

fgetcsv() 出错时返回 FALSE，包括碰到文件结束时。

注释：从 PHP 4.3.5 起，fgetcsv() 的操作是二进制安全的。

语法

fgetcsv(file,length,separator,enclosure)
参数 | 描述
file | 必需。规定要检查的文件。
length | 可选。规定行的最大长度。必须大于 CVS 文件内最长的一行。 在 PHP 5 中该参数是可选的。在 PHP 5 之前是必需的。 如果忽略（在 PHP 5.0.4 以后的版本中设为 0）该参数的话，那么长度就没有限制，不过可能会影响执行效率。
separator | 可选。设置字段分界符（只允许一个字符），默认值为逗号。
enclosure | 可选。设置字段环绕符（只允许一个字符），默认值为双引号。 该参数是在 PHP 4.3.0 中添加的。

提示和注释

注释：CSV 文件中的空行将被返回为一个包含有单个 null 字段的数组，不会被当成错误。

注释：该函数对区域设置是敏感的。比如说 LANG 设为 en_US.UTF-8 的话，单字节编码的文件就会出现读取错误。

注释：如果碰到 PHP 在读取文件时不能识别 Macintosh 文件的行结束符，可以激活 auto_detect_line_endings 运行时配置选项。

例子

例子 1

<?php

$file = fopen("contacts.csv","r");
print_r(fgetcsv($file));
fclose($file);

?>

CSV 文件：

George, John, Thomas, USA
James, Adrew, Martin, USA

输出类似：

Array
(
[0] => George
[1] => John
[2] => Thomas
[3] => USA
)

例子 2

<?php

$file = fopen("contacts.csv","r");

while(! feof($file))
  {
  print_r(fgetcsv($file));
  }

fclose($file);

?>

CSV 文件：

George, John, Thomas, USA
James, Adrew, Martin, USA

输出类似：

Array
(
[0] => George
[1] => John
[2] => Thomas
[3] => USA

Array
(
[0] => James
[1] => Adrew
[2] => Martin
[3] => USA
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fgets() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fgets() 函数

PHP Filesystem 函数

定义和用法

fgets() 函数从文件指针中读取一行。

语法

fgets(file,length)
参数 | 描述
file | 必需。规定要读取的文件。
length | 可选。规定要读取的字节数。默认是 1024 字节。

说明

从 file 指向的文件中读取一行并返回长度最多为 length - 1 字节的字符串。碰到换行符（包括在返回值中）、EOF 或者已经读取了 length - 1 字节后停止（要看先碰到那一种情况）。如果没有指定 length，则默认为 1K，或者说 1024 字节。

若失败，则返回 false。

提示和注释

注释：length 参数从 PHP 4.2.0 起成为可选项，如果忽略，则行的长度被假定为 1024 字节。从 PHP 4.3 开始，忽略掉 length 将继续从流中读取数据直到行结束。如果文件中的大多数行都大于 8 KB，则在脚本中指定最大行的长度在利用资源上更为有效。

注释：从 PHP 4.3 开始本函数可以安全用于二进制文件。早期的版本则不行。

注释：如果碰到 PHP 在读取文件时不能识别 Macintosh 文件的行结束符，可以激活 auto_detect_line_endings 运行时配置选项。

例子

例子 1

<?php

$file = fopen("test.txt","r");
echo fgets($file);
fclose($file);

?>

输出类似：

Hello, this is a test file.

例子 2

<?php

$file = fopen("test.txt","r");

while(! feof($file))
  {
  echo fgets($file). "<br />";
  }

fclose($file);
?>

输出类似：

Hello, this is a test file.
There are three lines here.
This is the last line.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fgetss() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fgetss() 函数

PHP Filesystem 函数

定义和用法

fgetss() 函数从打开的文件中读取一行并过滤掉 HTML 和 PHP 标记。

与 fgets() 相同，不同的是 fgetss 尝试从读取的文本中去掉任何 HTML 和 PHP 标记。

语法

fgetss(file,length,tags)
参数 | 描述
file | 必需。规定要读取的文件。
length | 可选。规定要读取的字节数。默认是 1024 字节。该参数在 PHP 5 之前是必需的。
tags | 可选。规定将被删除的标签。

说明

可以用可选的第三个参数 tags 指定哪些标记不被去掉。

若失败，则返回 false。

例子

例子 1

<?php

$file = fopen("test.htm","r");
echo fgetss($file);
fclose($file);

?>

输出类似：

This is a paragraph.

例子 2

<?php

$file = fopen("test.htm","r");
echo fgetss($file,1024,"<p>,<b>");
fclose($file);

?>

输出类似：

This is a paragraph.

输出的源代码是：

<p><b>This is a paragraph.</b></p>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP file_exists() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP file_exists() 函数

PHP Filesystem 函数

定义和用法

file_exists() 函数检查文件或目录是否存在。

如果指定的文件或目录存在则返回 true，否则返回 false。

语法

file_exists(path)
参数 | 描述
path | 必需。规定要检查的路径。

例子

<?php
echo file_exists("test.txt");
?>

输出：

1

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP file_get_contents() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP file_get_contents() 函数

PHP Filesystem 函数

定义和用法

file_get_contents() 函数把整个文件读入一个字符串中。

和 file() 一样，不同的是 file_get_contents() 把文件读入一个字符串。

file_get_contents() 函数是用于将文件的内容读入到一个字符串中的首选方法。如果操作系统支持，还会使用内存映射技术来增强性能。

语法

file_get_contents(path,include_path,context,start,max_length)
参数 | 描述
path | 必需。规定要读取的文件。
include_path | 可选。如果也想在 include_path 中搜寻文件的话，可以将该参数设为 "1"。
context | 可选。规定文件句柄的环境。 context 是一套可以修改流的行为的选项。若使用 null，则忽略。
start | 可选。规定在文件中开始读取的位置。该参数是 PHP 5.1 新加的。
max_length | 可选。规定读取的字节数。该参数是 PHP 5.1 新加的。

说明

对 context 的支持是 PHP 5.0.0 添加的。

提示和注释

注释：本函数可安全用于二进制对象。

例子

<?php
print_r(file("test.txt"));
?>

输出：

Array
(
[0] => Hello World. Testing testing!
[1] => Another day, another line.
[2] => If the array picks up this line,
[3] => then is it a pickup line?
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP file_put_contents() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP file_put_contents() 函数

PHP Filesystem 函数

定义和用法

file_put_contents() 函数把一个字符串写入文件中。

与依次调用 fopen()，fwrite() 以及 fclose() 功能一样。

语法

file_put_contents(file,data,mode,context)
参数 | 描述
file | 必需。规定要写入数据的文件。如果文件不存在，则创建一个新文件。
data | 可选。规定要写入文件的数据。可以是字符串、数组或数据流。
mode

可选。规定如何打开/写入文件。可能的值：

  • FILE_USE_INCLUDE_PATH
  • FILE_APPEND
  • LOCK_EX
context

可选。规定文件句柄的环境。

context 是一套可以修改流的行为的选项。若使用 null，则忽略。

说明

参数 data 可以是数组（但不能是多维数组）。

自 PHP 5.1.0 起，data 参数也可以被指定为 stream 资源，stream 中所保存的缓存数据将被写入到指定文件中，这种用法就相似于使用 stream_copy_to_stream() 函数。

对 context 参数的支持是 PHP 5.0.0 添加的。

返回值

该函数将返回写入到文件内数据的字节数。

提示和注释

提示：使用 FILE_APPEND 可避免删除文件中已有的内容。

注释：本函数可安全用于二进制对象。

例子

<?php
echo file_put_contents("test.txt","Hello World. Testing!");
?>

输出：

26

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP file() 函数

PHP Filesystem 函数

定义和用法

file() 函数把整个文件读入一个数组中。

与 file_get_contents() 类似，不同的是 file() 将文件作为一个数组返回。数组中的每个单元都是文件中相应的一行，包括换行符在内。

如果失败，则返回 false。

语法

file(path,include_path,context)
参数 | 描述
path | 必需。规定要读取的文件。
include_path | 可选。如果也想在 include_path 中搜寻文件的话，可以将该参数设为 "1"。
context | 可选。规定文件句柄的环境。 context 是一套可以修改流的行为的选项。若使用 null，则忽略。

说明

对 context 的支持是 PHP 5.0.0 添加的。

返回的数组中每一行都包括了行结束符，因此如果不需要行结束符时还需要使用 rtrim() 函数。

提示和注释

注释：从 PHP 4.3.0 开始，可以用 file_get_contents() 来将文件读入到一个字符串并返回。

注释：从 PHP 4.3.0 开始，file() 可以安全用于二进制文件。

注释：如果碰到 PHP 在读取文件时不能识别 Macintosh 文件的行结束符，可以激活 auto_detect_line_endings 运行时配置选项。

例子

<?php
print_r(file("test.txt"));
?>

输出：

Array
(
[0] => Hello World. Testing testing!
[1] => Another day, another line.
[2] => If the array picks up this line,
[3] => then is it a pickup line?
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fileatime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fileatime() 函数

PHP Filesystem 函数

定义和用法

fileatime() 函数返回指定文件的上次访问时间。

该函数返回文件上次被访问的时间。如果出错则返回 false。时间以 Unix 时间戳的方式返回。

语法

fileatime(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

注释：文件的 atime 应该在不论何时读取了该文件中的数据块时被更改。当一个应用程序定期访问大量文件或目录时很影响性能。有些 Unix 文件系统可以在加载时关闭 atime 的更新以提高这类程序的性能。USENET 新闻组假脱机是一个常见的例子。在这种文件系统下，本函数没有用处。

例子

<?php
echo fileatime("test.txt");
echo "Last access: ".date("F d Y H:i:s.",fileatime("test.txt"));
?>

输出：

1140684501
Last access: February 23 2006 09:48:21.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP filectime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filectime() 函数

PHP Filesystem 函数

定义和用法

filectime() 函数返回指定文件的上次 inode 修改时间。

该函数返回文件上次 inode 被修改的时间。如果出错则返回 false。时间以 Unix 时间戳的方式返回。

语法

fileatime(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

注意：在大多数 Unix 文件系统中，当一个文件的 inode 数据被改变时则该文件被认为是修改了。也就是说，当文件的权限，所有者，所有组或其它 inode 中的元数据被更新时。参见 filemtime()（这才是你想用于在 Web 页面中建立“最后更新时间”脚注的函数）和 fileatime()。

注释：某些 Unix 说明文本中把 ctime 说成是该文件建立的时间，这是错的。在大多数 Unix 文件系统中，没有 Unix 文件的建立时间。

例子

<?php
echo filectime("test.txt");
echo "Last change: ".date("F d Y H:i:s.",filectime("test.txt"));
?>

输出：

1138609592
Last change: January 30 2006 09:26:32.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP filegroup() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filegroup() 函数

PHP Filesystem 函数

定义和用法

filegroup() 函数返回指定文件的组 ID。

若成功，则返回指定文件所属组的 ID。若失败，则返回 false 以及一个 E_WARNING 级别的错误。

组 ID 以数字格式返回。

语法

filegroup(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

提示：请使用 posix_getgrgid() 来将组 ID 转换为组名。

例子

<?php
echo filegroup("test.txt");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fileinode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fileinode() 函数

PHP Filesystem 函数

定义和用法

fileinode() 函数返回文件的 inode 编号。

若成功，则返回指定文件的 inode 节点号。若失败，则返回 false。

语法

fileinode(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
echo fileinode("test.txt");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP filemtime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filemtime() 函数

PHP Filesystem 函数

定义和用法

filemtime() 函数返回文件内容上次的修改时间。

若成功，则时间以 Unix 时间戳的方式返回。若失败，则返回 false。

语法

filemtime(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

说明

本函数返回文件中的数据块上次被写入的时间，也就是说，文件的内容上次被修改的时间。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
echo filemtime("test.txt");
echo "Last modified: ".date("F d Y H:i:s.",filemtime("test.txt"));
?>

输出：

1139919766
Last modified: February 14 2006 13:22:46.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fileowner() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fileowner() 函数

PHP Filesystem 函数

定义和用法

fileowner() 函数返回文件的所有者。

若成功，则返回文件所有的用户 ID。若失败，则返回 false。用户 ID 以数字格式返回。

语法

fileowner(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

提示：用户 ID 以数字格式返回，请使用 posix_getpwuid() 来把用户 ID 转换为用户名。

例子

<?php
echo fileowner("test.txt");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fileperms() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fileperms() 函数

PHP Filesystem 函数

定义和用法

fileperms() 函数返回文件或目录的权限。

若成功，则返回文件的访问权限。若失败，则返回 false。

语法

fileperms(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

例子 1

<?php
echo fileperms("test.txt");
?>

输出：

33206

例子 2

以八进制值返回权限：

<?php
echo substr(sprintf("%o",fileperms("test.txt")),-4);
?>

输出：

1777

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP filesize() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filesize() 函数

PHP Filesystem 函数

定义和用法

filesize() 函数返回指定文件的大小。

若成功，则返回文件大小的字节数。若失败，则返回 false 并生成一条 E_WARNING 级的错误。

语法

filesize(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
echo filesize("test.txt");
?>

输出：

20

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP Filesystem 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Filesystem 函数

  • Previous Page
  • Next Page

PHP Filesystem 简介

Filesystem 函数允许您访问和操作文件系统。

安装

Filesystem 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

Runtime 配置

文件系统函数的行为受到 php.ini 中设置的影响。

文件系统配置选项：

名称 | 默认 | 描述 | 可改变
allow_url_fopen | "1" | 本选项激活了 URL 形式的 fopen 封装协议使得可以访问 URL 对象例如文件。默认的封装协议提供用 ftp 和 http 协议来访问远程文件，一些扩展库例如 zlib 可能会注册更多的封装协议。 （PHP 4.0.4 版以后可用。） | PHP_INI_SYSTEM
user_agent | NULL | 定义 PHP 发送的 User-Agent。 （PHP 4.3.0 版以后可用。） | PHP_INI_ALL
default_socket_timeout | "60" | 基于 socket 的流的默认超时时间(秒)。 （PHP 4.3.0 版以后可用。） | PHP_INI_ALL
from | "" | 定义匿名 ftp 的密码（您的 email 地址）。 | PHP_INI_ALL
auto_detect_line_endings | "0" | 当设为 On 时，PHP 将检查通过 fgets() 和 file() 取得的数据中的行结束符号是符合 Unix，MS-DOS，还是 Macintosh 的习惯。 这使得 PHP 可以和 Macintosh 系统交互操作，但是默认值是 Off，因为在检测第一行的 EOL 习惯时会有很小的性能损失，而且在 Unix 系统下使用回车符号作为项目分隔符的人们会遭遇向下不兼容的行为。 （PHP 4.3.0 版以后可用。） | PHP_INI_ALL

Unix / Windows 兼容性

当在 Unix 平台上规定路径时，正斜杠 (/) 用作目录分隔符。而在 Windows 平台上，正斜杠 (/) 和反斜杠 (\) 均可使用。

PHP Filesystem 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
basename() | 返回路径中的文件名部分。 | 3
chgrp() | 改变文件组。 | 3
chmod() | 改变文件模式。 | 3
chown() | 改变文件所有者。 | 3
clearstatcache() | 清除文件状态缓存。 | 3
copy() | 复制文件。 | 3
delete() | 参见 unlink() 或 unset()。 |
dirname() | 返回路径中的目录名称部分。 | 3
disk_free_space() | 返回目录的可用空间。 | 4
disk_total_space() | 返回一个目录的磁盘总容量。 | 4
diskfreespace() | disk_free_space() 的别名。 | 3
fclose() | 关闭打开的文件。 | 3
feof() | 测试文件指针是否到了文件结束的位置。 | 3
fflush() | 向打开的文件输出缓冲内容。 | 4
fgetc() | 从打开的文件中返回字符。 | 3
fgetcsv() | 从打开的文件中解析一行，校验 CSV 字段。 | 3
fgets() | 从打开的文件中返回一行。 | 3
fgetss() | 从打开的文件中读取一行并过滤掉 HTML 和 PHP 标记。 | 3
file() | 把文件读入一个数组中。 | 3
file_exists() | 检查文件或目录是否存在。 | 3
file_get_contents() | 将文件读入字符串。 | 4
file_put_contents | 将字符串写入文件。 | 5
fileatime() | 返回文件的上次访问时间。 | 3
filectime() | 返回文件的上次改变时间。 | 3
filegroup() | 返回文件的组 ID。 | 3
fileinode() | 返回文件的 inode 编号。 | 3
filemtime() | 返回文件的上次修改时间。 | 3
fileowner() | 文件的 user ID （所有者）。 | 3
fileperms() | 返回文件的权限。 | 3
filesize() | 返回文件大小。 | 3
filetype() | 返回文件类型。 | 3
flock() | 锁定或释放文件。 | 3
fnmatch() | 根据指定的模式来匹配文件名或字符串。 | 4
fopen() | 打开一个文件或 URL。 | 3
fpassthru() | 从打开的文件中读数据，直到 EOF，并向输出缓冲写结果。 | 3
fputcsv() | 将行格式化为 CSV 并写入一个打开的文件中。 | 5
fputs() | fwrite() 的别名。 | 3
fread() | 读取打开的文件。 | 3
fscanf() | 根据指定的格式对输入进行解析。 | 4
fseek() | 在打开的文件中定位。 | 3
fstat() | 返回关于一个打开的文件的信息。 | 4
ftell() | 返回文件指针的读/写位置 | 3
ftruncate() | 将文件截断到指定的长度。 | 4
fwrite() | 写入文件。 | 3
glob() | 返回一个包含匹配指定模式的文件名/目录的数组。 | 4
is_dir() | 判断指定的文件名是否是一个目录。 | 3
is_executable() | 判断文件是否可执行。 | 3
is_file() | 判断指定文件是否为常规的文件。 | 3
is_link() | 判断指定的文件是否是连接。 | 3
is_readable() | 判断文件是否可读。 | 3
is_uploaded_file() | 判断文件是否是通过 HTTP POST 上传的。 | 3
is_writable() | 判断文件是否可写。 | 4
is_writeable() | is_writable() 的别名。 | 3
link() | 创建一个硬连接。 | 3
linkinfo() | 返回有关一个硬连接的信息。 | 3
lstat() | 返回关于文件或符号连接的信息。 | 3
mkdir() | 创建目录。 | 3
move_uploaded_file() | 将上传的文件移动到新位置。 | 4
parse_ini_file() | 解析一个配置文件。 | 4
pathinfo() | 返回关于文件路径的信息。 | 4
pclose() | 关闭有 popen() 打开的进程。 | 3
popen() | 打开一个进程。 | 3
readfile() | 读取一个文件，并输出到输出缓冲。 | 3
readlink() | 返回符号连接的目标。 | 3
realpath() | 返回绝对路径名。 | 4
rename() | 重名名文件或目录。 | 3
rewind() | 倒回文件指针的位置。 | 3
rmdir() | 删除空的目录。 | 3
set_file_buffer() | 设置已打开文件的缓冲大小。 | 3
stat() | 返回关于文件的信息。 | 3
symlink() | 创建符号连接。 | 3
tempnam() | 创建唯一的临时文件。 | 3
tmpfile() | 建立临时文件。 | 3
touch() | 设置文件的访问和修改时间。 | 3
umask() | 改变文件的文件权限。 | 3
unlink() | 删除文件。 | 3

PHP Filesystem 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
GLOB_BRACE |  |
GLOB_ONLYDIR |  |
GLOB_MARK |  |
GLOB_NOSORT |  |
GLOB_NOCHECK |  |
GLOB_NOESCAPE |  |
PATHINFO_DIRNAME |  |
PATHINFO_BASENAME |  |
PATHINFO_EXTENSION |  |
FILE_USE_INCLUDE_PATH |  |
FILE_APPEND |  |
FILE_IGNORE_NEW_LINES |  |
FILE_SKIP_EMPTY_LINES |  |
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP filetype() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filetype() 函数

PHP Filesystem 函数

定义和用法

filetype() 函数返回指定文件或目录的类型。

若成功，则返回 7 种可能的值。若失败，则返回 false。

可能的值：

  • fifo
  • char
  • dir
  • block
  • link
  • file
  • unknown

语法

filetype(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

例子 1

<?php
echo filetype("test.txt");
?>

输出：

file

例子 2

<?php
echo filetype("images");
?>

输出：

dir

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP filter_has_var() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_has_var() 函数

PHP Filter 函数

定义和用法

filter_has_var() 函数检查是否存在指定输入类型的变量。

若成功，则返回 true，否则返回 false。

语法

filter_has_var(type, variable)
参数 | 描述
type

必需。规定要检查的类型。可能的值：

  • INPUT_GET
  • INPUT_POST
  • INPUT_COOKIE
  • INPUT_SERVER
  • INPUT_ENV
variable | 必需。规定要检查的变量。

例子

在本例中，输入变量 "name" 被发送到 PHP 页面：

<?php
if(!filter_has_var(INPUT_GET, "name"))
 {
 echo("Input type does not exist");
 }
else
 {
 echo("Input type exists");
 }
?>

输出类似：

Input type exists

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP filter_id() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_id() 函数

PHP Filter 函数

定义和用法

filter_id() 函数返回指定过滤器的 ID 号。

若成功，则返回过滤器的 ID 号。如果该过滤器不存在，则返回 NULL。

语法

filter_id(filter_name)
参数 | 描述
type | 必需。规定被获取 ID 号的过滤器。必须是过滤器名称（不是过滤器 ID 名）。 请使用 filter_list() 函数来获取所有被支持的过滤器的名称。

例子

<?php
echo(filter_id("validate_email"));
?>

输出类似：

274

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP filter_input_array() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_input_array() 函数

PHP Filter 函数

定义和用法

filter_input_array() 函数从脚本外部获取多项输入，并进行过滤。

本函数无需重复调用 filter_input()，对过滤多个输入变量很有用。

本函数可从各种来源获取输入：

  • INPUT_GET
  • INPUT_POST
  • INPUT_COOKIE
  • INPUT_ENV
  • INPUT_SERVER
  • INPUT_SESSION (Not yet implemented)
  • INPUT_REQUEST (Not yet implemented)

如果成功，则返回被过滤的数据，如果失败，则返回 false。

语法

filter_input(input_type, args)
参数 | 描述
input_type | 必需。规定输入类型。参见上面的列表中可能的类型。
args | 可选。规定过滤器参数数组。 合法的数组键是变量名。合法的值是过滤器 ID，或者规定过滤器、标志以及选项的数组。 该参数也可以是一个单独的过滤器 ID，如果是这样，输入数组中的所有值由指定过滤器进行过滤。

提示和注释

提示：参见完整的 PHP Filter 参考手册，查看可与该函数一同使用的过滤器。

例子

在本例中，我们使用 filter_input_array() 函数来过滤三个 POST 变量。所接受的 POST 变量是姓名、年龄以及电子邮件地址：

<?php
$filters = array
 (
 "name" => array
  (
  "filter"=>FILTER_CALLBACK,
  "flags"=>FILTER_FORCE_ARRAY,
  "options"=>"ucwords"
  ),
 "age" => array
  (
  "filter"=>FILTER_VALIDATE_INT,
  "options"=>array
   (
   "min_range"=>1,
   "max_range"=>120
   )
  ),
 "email"=> FILTER_VALIDATE_EMAIL,
 );
print_r(filter_input_array(INPUT_POST, $filters));
?>

输出类似：

Array
 (
 [name] => Peter
 [age] => 41
 [email] => peter@example.com
 )

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP filter_input() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_input() 函数

PHP Filter 函数

定义和用法

filter_input() 函数从脚本外部获取输入，并进行过滤。

本函数用于对来自非安全来源的变量进行验证，比如用户的输入。

本函数可从各种来源获取输入：

  • INPUT_GET
  • INPUT_POST
  • INPUT_COOKIE
  • INPUT_ENV
  • INPUT_SERVER
  • INPUT_SESSION (Not yet implemented)
  • INPUT_REQUEST (Not yet implemented)

如果成功，则返回被过滤的数据，如果失败，则返回 false，如果 variable 参数未设置，则返回 NULL。

语法

filter_input(input_type, variable, filter, options)
参数 | 描述
input_type | 必需。规定输入类型。参见上面的列表中可能的类型。
variable | 规定要过滤的变量。
filter | 可选。规定要使用的过滤器的 ID。默认是 FILTER_SANITIZE_STRING。 请参见完整的 PHP Filter 函数参考手册，获得可能的过滤器。 过滤器 ID 可以是 ID 名称 （比如 FILTER_VALIDATE_EMAIL），或 ID 号（比如 274）。
options | 规定包含标志/选项的数组。检查每个过滤器可能的标志和选项。

例子

在本例中，我们使用 filter_input() 函数来过滤一个 POST 变量。所接受的 POST 变量是合法的 e-mail 地址。

<?php
if (!filter_input(INPUT_POST, 'email', FILTER_VALIDATE_EMAIL))
 {
 echo "E-Mail is not valid";
 }
else
 {
 echo "E-Mail is valid";
 }
?>

输出类似：

E-Mail is valid

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP filter_list() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_list() 函数

PHP Filter 函数

定义和用法

filter_list() 函数返回包含所有得到支持的过滤器的一个数组。

语法

filter_list()

提示和注释

注释：该函数的结果不是过滤器的 ID，而是过滤器名称。请使用 filter_id() 函数来获取过滤器 ID。

例子

<?php
print_r(filter_list());
?>

输出类似：

Array
 (
 [0] => int
 [1] => boolean
 [2] => float
 [3] => validate_regexp
 [4] => validate_url
 [5] => validate_email
 [6] => validate_ip
 [7] => string
 [8] => stripped
 [9] => encoded
 [10] => special_chars
 [11] => unsafe_raw
 [12] => email
 [13] => url
 [14] => number_int
 [15] => number_float
 [16] => magic_quotes
 [17] => callback
 )

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP filter_var_array() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_var_array() 函数

PHP Filter 函数

定义和用法

filter_var_array() 函数获取多项变量，并进行过滤。

由于无需重复调用 filter_input()，因此本函数对过滤多个变量很有用。

如果成功，则返回包含被过滤的变量值的数组，如果失败，则返回 false。

语法

filter_var_array(array, args)
参数 | 描述
array | 必需。规定带有字符串键的数组，包含要过滤的数据。
args | 可选。规定过滤器参数数组。 合法的数组键是变量名。合法的值是过滤器 ID，或者规定过滤器、标志以及选项的数组。 该参数也可以是一个单独的过滤器 ID，如果是这样，输入数组中的所有值由指定过滤器进行过滤。

提示和注释

提示：参见完整的 PHP Filter 参考手册，查看可与该函数一同使用的过滤器。

例子

<?php
$arr = array
 (
 "name" => "peter griffin",
 "age" => "41",
 "email" => "peter@example.com",
 );

$filters = array
 (
 "name" => array
  (
  "filter"=>FILTER_CALLBACK,
  "flags"=>FILTER_FORCE_ARRAY,
  "options"=>"ucwords"
  ),
 "age" => array
  (
  "filter"=>FILTER_VALIDATE_INT,
  "options"=>array
   (
   "min_range"=>1,
   "max_range"=>120
   )
  ),
 "email"=> FILTER_VALIDATE_EMAIL,
 );

print_r(filter_var_array($arr, $filters));
?>

输出类似：

Array
 (
 [name] => Peter Griffin
 [age] => 41
 [email] => peter@example.com
 )

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP filter_var() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_var() 函数

PHP Filter 函数

定义和用法

filter_var() 函数通过指定的过滤器过滤变量。

如果成功，则返回已过滤的数据，如果失败，则返回 false。

语法

filter_var(variable, filter, options)
参数 | 描述
variable | 必需。规定要过滤的变量。
filter | 可选。规定要使用的过滤器的 ID。
options | 规定包含标志/选项的数组。检查每个过滤器可能的标志和选项。

提示和注释

提示：参见完整的 PHP Filter 参考手册，查看可与该函数一同使用的过滤器。

例子

<?php
if(!filter_var("someone@example....com", FILTER_VALIDATE_EMAIL))
 {
 echo("E-mail is not valid");
 }
else
 {
 echo("E-mail is valid");
 }
?>

输出类似：

E-mail is not valid

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP Filter 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Filter 函数

  • Previous Page
  • Next Page

PHP Filter 简介

PHP 过滤器用于对来自非安全来源的数据（比如用户输入）进行验证和过滤。

安装

filter 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP Filter 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
filter_has_var() | 检查是否存在指定输入类型的变量。 | 5
filter_id() | 返回指定过滤器的 ID 号。 | 5
filter_input() | 从脚本外部获取输入，并进行过滤。 | 5
filter_input_array() | 从脚本外部获取多项输入，并进行过滤。 | 5
filter_list() | 返回包含所有得到支持的过滤器的一个数组。 | 5
filter_var_array() | 获取多项变量，并进行过滤。 | 5
filter_var() | 获取一个变量，并进行过滤。 | 5

PHP Filters

ID 名称 | 描述
FILTER_CALLBACK | 调用用户自定义函数来过滤数据。
FILTER_SANITIZE_STRING | 去除标签，去除或编码特殊字符。
FILTER_SANITIZE_STRIPPED | "string" 过滤器的别名。
FILTER_SANITIZE_ENCODED | URL-encode 字符串，去除或编码特殊字符。
FILTER_SANITIZE_SPECIAL_CHARS | HTML 转义字符 '"<>& 以及 ASCII 值小于 32 的字符。
FILTER_SANITIZE_EMAIL | 删除所有字符，除了字母、数字以及 !#$%&'*+-/=?^_`{|}~@.[]
FILTER_SANITIZE_URL | 删除所有字符，除了字母、数字以及 $-_.+!*'(),{}|\\^~[]`<>#%";/?:@&=
FILTER_SANITIZE_NUMBER_INT | 删除所有字符，除了数字和 +-
FILTER_SANITIZE_NUMBER_FLOAT | 删除所有字符，除了数字、+- 以及 .,eE。
FILTER_SANITIZE_MAGIC_QUOTES | 应用 addslashes()。
FILTER_UNSAFE_RAW | 不进行任何过滤，去除或编码特殊字符。
FILTER_VALIDATE_INT | 在指定的范围以整数验证值。
FILTER_VALIDATE_BOOLEAN | 如果是 "1", "true", "on" 以及 "yes"，则返回 true，如果是 "0", "false", "off", "no" 以及 ""，则返回 false。否则返回 NULL。
FILTER_VALIDATE_FLOAT | 以浮点数验证值。
FILTER_VALIDATE_REGEXP | 根据 regexp，兼容 Perl 的正则表达式来验证值。
FILTER_VALIDATE_URL | 把值作为 URL 来验证。
FILTER_VALIDATE_EMAIL | 把值作为 e-mail 来验证。
FILTER_VALIDATE_IP | 把值作为 IP 地址来验证。
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP flock() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP flock() 函数

PHP Filesystem 函数

定义和用法

flock() 函数锁定或释放文件。

若成功，则返回 true。若失败，则返回 false。

语法

flock(file,lock,block)
参数 | 描述
file | 必需。规定要锁定或释放的已打开的文件。
lock | 必需。规定要使用哪种锁定类型。
block | 可选。若设置为 1 或 true，则当进行锁定时阻挡其他进程。

说明

flock() 操作的 file 必须是一个已经打开的文件指针。

lock 参数可以是以下值之一：

  • 要取得共享锁定（读取的程序），将 lock 设为 LOCK_SH（PHP 4.0.1 以前的版本设置为 1）。
  • 要取得独占锁定（写入的程序），将 lock 设为 LOCK_EX（PHP 4.0.1 以前的版本中设置为 2）。
  • 要释放锁定（无论共享或独占），将 lock 设为 LOCK_UN（PHP 4.0.1 以前的版本中设置为 3）。
  • 如果不希望 flock() 在锁定时堵塞，则给 lock 加上 LOCK_NB（PHP 4.0.1 以前的版本中设置为 4）。

提示和注释

提示：可以通过 fclose() 来释放锁定操作，代码执行完毕时也会自动调用。

注释：由于 flock() 需要一个文件指针， 因此可能不得不用一个特殊的锁定文件来保护打算通过写模式打开的文件的访问（在 fopen() 函数中加入 "w" 或 "w+"）。

例子

<?php

$file = fopen("test.txt","w+");

// 排它性的锁定
if (flock($file,LOCK_EX))
  {
  fwrite($file,"Write something");
  // release lock
  flock($file,LOCK_UN);
  }
else
  {
  echo "Error locking file!";
  }

fclose($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP floor() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP floor() 函数

PHP Math 函数

定义和用法

floor() 函数向下舍入为最接近的整数。

语法

floor(x)
参数 | 描述
x | 必需。一个数。

说明

返回不大于 x 的下一个整数，将 x 的小数部分舍去取整。floor() 返回的类型仍然是 float，因为 float 值的范围通常比 integer 要大。

例子

在本例中，我们将对不同的数应用 floor() 函数：

<?php
echo(floor(0.60));
echo(floor(0.40));
echo(floor(5));
echo(floor(5.1));
echo(floor(-5.1));
echo(floor(-5.9))
?>

输出：

0
0
5
5
-6
-6

PHP Math 函数

PHP 参考手册
PHP 测验


PHP fmod() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fmod() 函数

PHP Math 函数

定义和用法

fmod() 函数返回除法的浮点数余数。

语法

fmod(x,y)
参数 | 描述
x | 必需。一个数。
y | 必需。一个数。

说明

返回被除数（x）除以除数（y）所得的浮点数余数。余数（r）的定义是：x = i * y + r，其中 i 是整数。如果 y 是非零值，则 r 和 x 的符号相同并且其数量值小于 y 。

例子

在本例中，我们将使用 fmod() 函数来返回 5/2 的余数：

<?php
$r = fmod(5,2);
echo $r
?>

输出：

1

PHP Math 函数

PHP 参考手册
PHP 测验


PHP fmod() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fmod() 函数

PHP Math 函数

定义和用法

fmod() 函数显示随机数最大的可能值。

语法

getrandmax()

说明

返回调用 rand() 可能返回的最大值。

例子

<?php
echo(getrandmax());
?>

输出类似：

38265

PHP Math 函数

PHP 参考手册
PHP 测验


PHP fnmatch() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fnmatch() 函数

PHP Filesystem 函数

定义和用法

fnmatch() 函数根据指定的模式来匹配文件名或字符串。

语法

fnmatch(pattern,string,flags)
参数 | 描述
pattern | 必需。规定要检索的模式。
string | 必需。规定要检查的字符串或文件。
flags | 可选。

说明

此函数对于文件名尤其有用，但也可以用于普通的字符串。普通用户可能习惯于 shell 模式或者至少其中最简单的形式 '?' 和 '*' 通配符，因此使用 fnmatch() 来代替 ereg() 或者 preg_match() 来进行前端搜索表达式输入对于非程序员用户更加方便。

提示和注释

重要事项：目前该函数无法在 Windows 或其它非 POSIX 兼容的系统上使用。

例子

根据 shell 通配符来检查颜色名：

<?php
$txt = "My car is darkgrey..."
if (fnmatch("*gr[ae]y",$txt))
  {
  echo "some form of gray ...";
  }
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fopen() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fopen() 函数

PHP Filesystem 函数

定义和用法

fopen() 函数打开文件或者 URL。

如果打开失败，本函数返回 FALSE。

语法

fopen(filename,mode,include_path,context)
参数 | 描述
filename | 必需。规定要打开的文件或 URL。
mode | 必需。规定要求到该文件/流的访问类型。可能的值见下表。
include_path | 可选。如果也需要在 include_path 中检索文件的话，可以将该参数设为 1 或 TRUE。
context | 可选。规定文件句柄的环境。Context 是可以修改流的行为的一套选项。

mode 参数的可能的值

mode | 说明
"r" | 只读方式打开，将文件指针指向文件头。
"r+" | 读写方式打开，将文件指针指向文件头。
"w" | 写入方式打开，将文件指针指向文件头并将文件大小截为零。如果文件不存在则尝试创建之。
"w+" | 读写方式打开，将文件指针指向文件头并将文件大小截为零。如果文件不存在则尝试创建之。
"a" | 写入方式打开，将文件指针指向文件末尾。如果文件不存在则尝试创建之。
"a+" | 读写方式打开，将文件指针指向文件末尾。如果文件不存在则尝试创建之。
"x" | 创建并以写入方式打开，将文件指针指向文件头。如果文件已存在，则 fopen() 调用失败并返回 FALSE，并生成一条 E_WARNING 级别的错误信息。如果文件不存在则尝试创建之。 这和给底层的 open(2) 系统调用指定 O_EXCL|O_CREAT 标记是等价的。 此选项被 PHP 4.3.2 以及以后的版本所支持，仅能用于本地文件。
"x+" | 创建并以读写方式打开，将文件指针指向文件头。如果文件已存在，则 fopen() 调用失败并返回 FALSE，并生成一条 E_WARNING 级别的错误信息。如果文件不存在则尝试创建之。 这和给底层的 open(2) 系统调用指定 O_EXCL|O_CREAT 标记是等价的。 此选项被 PHP 4.3.2 以及以后的版本所支持，仅能用于本地文件。

说明

fopen() 将 filename 指定的名字资源绑定到一个流上。如果 filename 是 "scheme://..." 的格式，则被当成一个 URL，PHP 将搜索协议处理器（也被称为封装协议）来处理此模式。如果该协议尚未注册封装协议，PHP 将发出一条消息来帮助检查脚本中潜在的问题并将 filename 当成一个普通的文件名继续执行下去。

如果 PHP 认为 filename 指定的是一个本地文件，将尝试在该文件上打开一个流。该文件必须是 PHP 可以访问的，因此需要确认文件访问权限允许该访问。如果激活了安全模式或者 open_basedir 则会应用进一步的限制。

如果 PHP 认为 filename 指定的是一个已注册的协议，而该协议被注册为一个网络 URL，PHP 将检查并确认 allow_url_fopen 已被激活。如果关闭了，PHP 将发出一个警告，而 fopen 的调用则失败。

对 context 的支持是 PHP 5.0.0 添加的。

提示和注释

注释：不同的操作系统家族具有不同的行结束习惯。当写入一个文本文件并想插入一个新行时，需要使用符合操作系统的行结束符号。基于 Unix 的系统使用 \n 作为行结束字符，基于 Windows 的系统使用 \r\n 作为行结束字符，基于 Macintosh 的系统使用 \r 作为行结束字符。 如果写入文件时使用了错误的行结束符号，则其它应用程序打开这些文件时可能会表现得很怪异。

Windows 下提供了一个文本转换标记（"t"）可以透明地将 \n 转换为 \r\n。与此对应还可以使用 "b" 来强制使用二进制模式，这样就不会转换数据。要使用这些标记，要么用 "b" 或者用 "t" 作为 mode 参数的最后一个字符。

默认的转换模式依赖于 SAPI 和所使用的 PHP 版本，因此为了便于移植鼓励总是指定恰当的标记。如果是操作纯文本文件并在脚本中使用了 \n 作为行结束符，但还要期望这些文件可以被其它应用程序例如 Notepad 读取，则在 mode 中使用 "t"。在所有其它情况下使用 "b"。

在操作二进制文件时如果没有指定 "b" 标记，可能会碰到一些奇怪的问题，包括坏掉的图片文件以及关于 \r\n 字符的奇怪问题。

注释：为移植性考虑，强烈建议在用 fopen() 打开文件时总是使用 "b" 标记。

注释：再一次，为移植性考虑，强烈建议你重写那些依赖于 "t" 模式的代码使其使用正确的行结束符并改成 "b" 模式。

例子

<?php
$file = fopen("test.txt","r");
$file = fopen("/home/test/test.txt","r");
$file = fopen("/home/test/test.gif","wb");
$file = fopen("http://www.example.com/","r");
$file = fopen("ftp://user:password@example.com/test.txt","w");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fpassthru() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fpassthru() 函数

PHP Filesystem 函数

定义和用法

fpassthru() 函数输出文件指针处的所有剩余数据。

该函数将给定的文件指针从当前的位置读取到 EOF，并把结果写到输出缓冲区。

语法

fpassthru(file)
参数 | 描述
file | 必需。规定要读取的打开文件或资源。

说明

如果发生错误， fpassthru() 返回 false。否则 fpassthru() 返回从 file 读取并传递到输出的字符数目。

文件指针必须有效，并且必须指向一个由 fopen() 或 fsockopen() 成功打开（但还没有被 fclose() 关闭）的文件。

提示和注释

提示：如果已经向文件写入数据，就必须调用 rewind() 来将文件指针指向文件头。

提示：如果既不修改文件也不在特定位置检索，只想将文件的内容下载到输出缓冲区，应该使用 readfile()，这样可以省去 fopen() 调用。

注释：当在 Windows 系统中将 fpassthru() 用于二进制文件时，要确保在用 fopen() 打开文件时在 mode 中附加了 b 来将文件以二进制方式打开。鼓励在处理二进制文件时使用 b 标志，即使系统并不需要，这样可以使脚本的移植性更好。

例子

例子 1

<?php
$file = fopen("test.txt","r");

// 读取第一行
fgets($file);

// 把文件的其余部分发送到输出缓存
echo fpassthru($file);

fclose($file);
?>

输出：

There are three lines in this file.
This is the last line.59

注：59 指示被传递的字符数。

例子 2

转储 www 服务器的 index 页：

<?php
$file = fopen("http://www.example.com","r");
fpassthru($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fprintf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fprintf() 函数

PHP String 函数

定义和用法

fprintf() 函数把格式化的字符串写到指定的输出流（例如：文件或数据库）。

该函数返回被写字符串的长度。

语法

fprintf(stream,format,arg1,arg2,arg++)
参数 | 描述
stream | 可选。规定在哪里写/输出字符串。
format | 必需。转换格式。
arg1 | 必需。规定插到 format 字符串中第一个 % 符号处的参数。
arg2 | 可选。规定插到 format 字符串中第二个 % 符号处的参数。
arg++ | 可选。规定插到 format 字符串中第三、四等等 % 符号处的参数。

说明

参数 format 是转换的格式，以百分比符号 ("%") 开始到转换字符结束。下面的可能的 format 值：

  • %% - 返回百分比符号
  • %b - 二进制数
  • %c - 依照 ASCII 值的字符
  • %d - 带符号十进制数
  • %e - 可续计数法（比如 1.5e+3）
  • %u - 无符号十进制数
  • %f - 浮点数(local settings aware)
  • %F - 浮点数(not local settings aware)
  • %o - 八进制数
  • %s - 字符串
  • %x - 十六进制数（小写字母）
  • %X - 十六进制数（大写字母）

arg1, arg2, ++ 等参数将插入到主字符串中的百分号 (%) 符号处。该函数是逐步执行的。在第一个 % 符号中，插入 arg1，在第二个 % 符号处，插入 arg2，依此类推。

提示和注释

注释：如果 % 符号多于 arg 参数，则您必须使用占位符。占位符被插入 % 符号之后，由数字和 "\$" 组成。请参见例子 3。

提示：
相关函数：
printf()、
sprintf()、
vfprintf()、
vprintf() 以及
vsprintf()。

例子

例子 1

<?php
$arr = array('Hello','World!','Beautiful','Day!');
echo implode(" ",$arr);
?>

输出：

Hello World! Beautiful Day!

例子 2

<?php
$arr = array('Hello','World!','Beautiful','Day!');
echo implode(" ",$arr);
?>

输出：

Hello World! Beautiful Day!

例子 3

<?php
$arr = array('Hello','World!','Beautiful','Day!');
echo implode(" ",$arr);
?>

输出：

Hello World! Beautiful Day!

PHP String 函数

PHP 参考手册
PHP 测验


PHP fputcsv() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fputcsv() 函数

PHP Filesystem 函数

定义和用法

fputcsv() 函数将行格式化为 CSV 并写入一个打开的文件。

该函数返回写入字符串的长度。若出错，则返回 false。。

语法

fputcsv(file,fields,seperator,enclosure)
参数 | 描述
file | 必需。规定要写入的打开文件。
fields | 必需。规定要从中获得数据的数组。
seperator | 可选。规定字段分隔符的字符。默认是逗号 (,)。
enclosure | 可选。规定字段环绕符的字符。默认是双引号 "。

说明

fputcsv() 将一行（用 fields 数组传递）格式化为 CSV 格式并写入由 file 指定的文件。

提示和注释

提示：参见 fgetcsv() 函数。

例子

<?php
$list = array
(
"George,John,Thomas,USA",
"James,Adrew,Martin,USA",
);

$file = fopen("contacts.csv","w");

foreach ($list as $line)
  {
  fputcsv($file,split(',',$line));
  }

fclose($file);
?>

以上代码执行后，CSV 文件会类似这样：

George,John,Thomas,USA
James,Adrew,Martin,USA

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fputs() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fputs() 函数

PHP Filesystem 函数

定义和用法

fputs() 函数写入文件（可安全用于二进制文件）。

fputs() 函数是 fwrite() 函数的别名。

语法

fputs(file,string,length)
参数 | 描述
file | 必需。规定要写入的打开文件。
string | 必需。规定要写入文件的字符串。
length | 可选。规定要写入的最大字节数。

说明

fwrite() 把 string 的内容写入文件指针 file 处。 如果指定了 length，当写入了 length 个字节或者写完了 string 以后，写入就会停止，视乎先碰到哪种情况。

fwrite() 返回写入的字符数，出现错误时则返回 false。

例子

<?php
$file = fopen("test.txt","w");
echo fputs($file,"Hello World. Testing!");
fclose($file);
?>

输出：

21

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fread() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fread() 函数

PHP Filesystem 函数

定义和用法

fread() 函数读取文件（可安全用于二进制文件）。

语法

fread(file,length)
参数 | 描述
file | 必需。规定要读取打开文件。
length | 必需。规定要读取的最大字节数。

说明

fread() 从文件指针 file 读取最多 length 个字节。该函数在读取完最多 length 个字节数，或到达 EOF 的时候，或（对于网络流）当一个包可用时，或（在打开用户空间流之后）已读取了 8192 个字节时就会停止读取文件，视乎先碰到哪种情况。

返回所读取的字符串，如果出错返回 false。

提示和注释

提示：如果只是想将一个文件的内容读入到一个字符串中，请使用 file_get_contents()，它的性能比 fread() 好得多。

例子

例子 1

从文件中读取 10 个字节：

<?php
$file = fopen("test.txt","r");
fread($file,"10");
fclose($file);
?>

例子 2

读取整个文件：

<?php
$file = fopen("test.txt","r");
fread($file,filesize("test.txt"));
fclose($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP FrenchToJD() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FrenchToJD() 函数

PHP Array 函数

定义和用法

FrenchToJD() 函数将法国共和历法转换成为儒略日计数。

语法

frenchtojd(month,day,year)
参数 | 描述
month | 必需。规定月
day | 必需。规定日
year | 可选。必须在 1 到 14 的范围内。

提示和注释

法国共和历法是法国革命期间提出的一种历法，从 1793 年晚期开始，法国政府使用了大约 12 年。该函数只转换 1 到 14 年内的日期 （格利高里历 1792 年 9 月 22 日 - 1806 年 9 月 22 日）。

例子

<?php
$d=frenchtojd(3,3,14);
echo($d);
?>

输出：

2380650

PHP Array 函数

PHP 参考手册
PHP 测验


PHP fscanf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fscanf() 函数

PHP Filesystem 函数

定义和用法

fscanf() 函数根据指定的格式对来自打开的文件的输入进行解析。

语法

fscanf(file,format,mixed)
参数 | 描述
file | 必需。规定要检查的文件。
format | 必需。规定格式。
mixed | 可选。

说明

fscanf() 函数与 sscanf() 相似，但是它从与 file 关联的文件中接受输入并根据指定的 format 来解释输入。如果只给此函数传递了两个参数，解析后的值会被作为数组返回。否则，如果提供了可选参数，此函数将返回被赋值的数目。可选参数必须用引用传递。

提示和注释

注释：格式字符串中的任何空白会与输入流中的任何空白匹配。这意味着甚至格式字符串中的制表符 \t 也会与输入流中的一个空格字符匹配。

注释：在 PHP 4.3.0 之前，从文件中读入的最大字符数是 512（或者第一个 \n，看先碰到哪种情况）。从 PHP 4.3.0 起可以读取任意长的行。

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fseek() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fseek() 函数

PHP Filesystem 函数

定义和用法

fseek() 函数在打开的文件中定位。

该函数把文件指针从当前位置向前或向后移动到新的位置，新位置从文件头开始以字节数度量。

成功则返回 0；否则返回 -1。注意，移动到 EOF 之后的位置不会产生错误。

语法

fseek(file,offset,whence)
参数 | 描述
file | 必需。规定要在其中定位的文件。
offset | 必需。规定新的位置（从文件头开始以字节数度量）。
whence 可选。可能的值：
  • SEEK_SET - 设定位置等于 offset 字节。默认。
  • SEEK_CUR - 设定位置为当前位置加上 offset。
  • SEEK_END - 设定位置为文件末尾加上 offset （要移动到文件尾之前的位置，offset 必须是一个负值）。

说明

whence 参数是 PHP 4.0.0 之后增加的。

提示和注释

提示：通过使用 ftell() 来找到当前位置。

例子

<?php
$file = fopen("test.txt","r");

// 读取第一行
fgets($file);

// 倒回文件的开头
fseek($file,0);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fstat() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fstat() 函数

PHP Filesystem 函数

定义和用法

fstat() 函数返回关于打开文件的信息。

语法

fstat(file)
参数 | 描述
pipe | 必需。规定要检查的打开文件。

说明

获取由文件指针 handle 所打开文件的统计信息。

该函数返回的数组具有该文件的统计信息，该数组包含以下元素：

数字下标 | 关联键名（自 PHP 4.0.6） | 说明
0 | dev | 设备名
1 | ino | 号码
2 | mode | inode 保护模式
3 | nlink | 被连接数目
4 | uid | 所有者的用户 id
5 | gid | 所有者的组 id
6 | rdev | 设备类型，如果是 inode 设备的话
7 | size | 文件大小的字节数
8 | atime | 上次访问时间（Unix 时间戳）
9 | mtime | 上次修改时间（Unix 时间戳）
10 | ctime | 上次改变时间（Unix 时间戳）
11 | blksize | 文件系统 IO 的块大小
12 | blocks | 所占据块的数目

提示和注释

提示：本函数与 stat() 函数相似，不同的是，它是作用于已打开的文件指针而不是文件名。

例子

<?php
$file = fopen("test.txt","r");
print_r(fstat($file));
fclose($file);
?>

输出类似：

Array
(
[0] => 0
[1] => 0
[2] => 33206
[3] => 1
[4] => 0
[5] => 0
[6] => 0
[7] => 92
[8] => 1141633430
[9] => 1141298003
[10] => 1138609592
[11] => -1
[12] => -1
[dev] => 0
[ino] => 0
[mode] => 33206
[nlink] => 1
[uid] => 0
[gid] => 0
[rdev] => 0
[size] => 92
[atime] => 1141633430
[mtime] => 1141298003
[ctime] => 1138609592
[blksize] => -1
[blocks] => -1
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP ftell() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftell() 函数

PHP Filesystem 函数

定义和用法

ftell() 函数在打开文件中的当前位置。

该函数返回文件指针的当前位置。若失败，则返回 false。

语法

ftell(file)
参数 | 描述
file | 必需。规定要检查的已打开文件。

说明

文件指针 file 必须是有效的，且必须指向一个通过 fopen() 或 popen() 成功打开的文件。

在附加模式（加参数 "a" 打开文件）中 ftell() 会返回未定义错误。

例子

<?php
$file = fopen("test.txt","r");

// 输出当前位置
echo ftell($file);

// 改变当前位置
fseek($file,"15");

// 再次输出当前位置
echo ftell($file);

fclose($file);
?>

输出：

0
15

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP ftp_alloc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_alloc() 函数

PHP FTP 函数

定义和用法

ftp_alloc() 函数为要上传到 FTP 服务器的文件分配空间。

若成功，则返回 true。否则返回 false。

语法

ftp_alloc(ftp_connection,size,return)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接。
size | 可选。规定要分配的字节数。
return | 可选。规定存储服务器响应的字节数。

提示和注释

注释：很多服务器不支持该命令。

例子

例子 1

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_alloc($conn,"160",$response);
echo $response;

ftp_close($conn);
?>

例子 2

<?php

$file = "myfile.txt";

$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

if (ftp_alloc($conn, filesize($file), $response))
  {
  echo "Space allocated on server.";
  }
else
  {
  echo "Unable to allocate space. " . $response;
  }

ftp_close($conn);

?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_cdup() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_cdup() 函数

PHP FTP 函数

定义和用法

ftp_cdup() 函数把当前目录改变为 FTP 服务器上的父目录。

若成功，则返回 true。否则返回 false。

语法

ftp_cdup(ftp_connection)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

//输出当前目录
echo "Dir: ".ftp_pwd($conn);
echo "<br />";

//更改为 images 目录
ftp_chdir($conn,"images");
echo "Dir: ".ftp_pwd($conn);
echo "<br />";

//把当前目录切换为父目录
ftp_cdup($conn);
echo "Dir: ".ftp_pwd($conn);

ftp_close($ftp_server);
?>

输出：

Dir: /
Dir: /images
Dir: /

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_chdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_chdir() 函数

PHP FTP 函数

定义和用法

ftp_chdir() 函数改变 FTP 服务器上的当前目录。

若成功，则返回 true。否则返回 false。如果切换目录失败，PHP 还会发出一条警告。

语法

ftp_chdir(ftp_connection,directory)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
directory | 必需。规定要切换到的目录。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

//输出当前目录
echo "Dir: ".ftp_pwd($conn);
echo "<br />";

//切换为 images 目录
ftp_chdir($conn,"images");
echo "Dir: ".ftp_pwd($conn);

ftp_close($ftp_server);
?>

输出：

Dir: /
Dir: /images

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_chmod() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_chmod() 函数

PHP FTP 函数

定义和用法

ftp_chmod() 函数设置 FTP 服务器上指定文件的权限。

若成功，则该函数返回新的权限。否则返回 false。

语法

ftp_chmod(ftp_connection,mode,file)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
mode | 必需。规定新的权限。
file | 必需。规定要修改权限的文件的名称。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"user","pass");

// 所有者可读写，其他人没有任何权限
ftp_chmod($conn,"0600","test.txt");

// 所有者可读写，其他人可读
ftp_chmod($conn,"0644","test.txt");

// 所有者拥有所有权限，其他人可读可执行
ftp_chmod($conn,"0755","test.txt");

// 所有者拥有所有权限，所有者所属的组可读
ftp_chmod($conn,"0740","test.txt");

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_close() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_close() 函数

PHP FTP 函数

定义和用法

ftp_close() 函数关闭 FTP 连接。

该函数关闭给出的连接标识符并释放资源。

语法

ftp_close(ftp_connection)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");

//要执行的一些代码

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_connect() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_connect() 函数

PHP FTP 函数

定义和用法

ftp_connect() 函数建立一个新的 FTP 连接。

若成功，则返回一个连接标识，否则返回 false。

语法

ftp_connect(host,port,timeout)
参数 | 描述
host | 必需。规定要连接的 FTP 服务器。可以是域名或 IP 地址。 后面不应以斜线结尾，前面也不需要用 ftp:// 开头。
port | 可选。规定 FTP 服务器的端口。
timeout | 可选。规定该 FTP 服务器的超时时间。默认是 90 秒。

说明

提示：超时时间可以在任何时候通过函数 ftp_set_option() 及 ftp_get_option() 来改变和获取。

参数 timeout 仅适用于 PHP 4.2.0 及以上版本。

例子

本例尝试连接一个 FTP 服务器。如果连接失败，则 die() 函数将终止脚本，并输出一条消息：

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_delete() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_delete() 函数

PHP FTP 函数

定义和用法

ftp_delete() 函数删除 FTP 服务器上的一个文件。

若成功，则返回 true，否则返回 false。

语法

ftp_delete(ftp_connection,path)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
path | 必需。规定要删除的文件的路径。

说明

ftp_delete() 函数用来删除 FTP 服务器上的一个由参数 path 指定的的文件。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_delete($conn,"test.txt");

ftp_close($conn);
?>

输出：

1

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_exec() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_exec() 函数

PHP FTP 函数

定义和用法

ftp_exec() 函数请求在 FTP 服务器上执行一个程序或命令。

若成功（服务器发送响应代码 200），则返回 true，否则返回 false。

语法

ftp_exec(ftp_connection,command)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
command | 必需。规定发送到服务器的命名请求。

说明

该函数发送一个 SITE EXEC command 请求到 FTP 服务器。

提示和注释

与 ftp_raw() 函数 不同，ftp_exec() 只有在登录到 FTP 服务器后才能发送命令。

例子

<?php
$command = "ls-al > test.txt";
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

if (ftp_exec($conn,$command))
  {
  echo "Command executed successfully";
  }
else
  {
  echo "Execution of command failed";
  }

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_fget() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_fget() 函数

PHP FTP 函数

定义和用法

ftp_fget() 函数从 FTP 服务器上下载一个文件并保存到本地一个已经打开的文件中。

若成功则返回 true，失败则返回 false。

语法

ftp_fget(ftp_connection,local,remote,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
local | 必需。本地已经打开的文件的句柄。
remote | 必需。规定从中进行拷贝的文件的路径。
mode 必需。规定传输模式。可能的值有：
  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在远程文件中的何处开始拷贝。默认是 0。

说明

参数 resume 仅适用于 PHP 4.3.0 以上版本

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$source = "source.txt";
$target = fopen("target.txt", "w");

$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_fget($conn,$target,$source,FTP_ASCII);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_fput() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_fput() 函数

PHP FTP 函数

定义和用法

ftp_fput() 函数上传一个已经打开的文件到 FTP 服务器。

若成功则返回 true，失败则返回 false。

语法

ftp_fput(ftp_connection,remote,local,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
remote | 必需。上传到服务器上的文件名。
local | 必需。规定所打开文件的句柄。
mode 必需。规定传输模式。可能的值有：
  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在本地文件中的何处开始拷贝。默认是 0。

说明

参数 resume 仅适用于 PHP 4.3.0 以上版本

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$source = fopen("source.txt","r");

$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_fput($conn,"target.txt",$source,FTP_ASCII);

ftp_close($conn);
?>

输出：

1

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_get_option() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_get_option() 函数

PHP FTP 函数

定义和用法

ftp_get_option() 函数返回当前 FTP 连接的各种不同的选项设置。

语法

ftp_get_option(ftp_connection,option)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
option

必需。规定要返回的选项。可能的值有：

  • FTP_TIMEOUT_SEC - 返回网络操作的时间限制
  • FTP_AUTOSEEK - 如果设置该选项，则返回 true，否则返回 false

说明

如果成功，则返回选项的值，否则，如果给定的参数 option 选项若不被支持，则返回 false 同时会提示一条错误信息。

此函数会返回连接句柄为 ftp_connection，指定键值 option 的值。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_get_option($conn,FTP_TIMEOUT_SEC);

ftp_close($conn);
?>

输出：

90

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_get() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_get() 函数

PHP FTP 函数

定义和用法

ftp_get() 函数从 FTP 服务器上下载一个文件。

若成功则返回 true，失败则返回 false。

语法

ftp_get(ftp_connection,local,remote,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
local | 必需。规定本地文件。
remote | 必需。规定从中进行拷贝的文件的路径。
mode 必需。规定传输模式。可能的值有：
  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在远程文件中的何处开始拷贝。默认是 0。

说明

参数 resume 仅适用于 PHP 4.3.0 以上版本

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_get($conn,"target.txt","source.txt",FTP_ASCII);

ftp_close($conn);
?>

输出：

1

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_login() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_login() 函数

PHP FTP 函数

定义和用法

ftp_login() 函数登录 FTP 服务器。

若成功则返回 true，失败则返回 false 并发出一个警告。

语法

ftp_login(ftp_connection,username,password)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
username | 必需。规定用于登录的用户名。
password | 必需。规定用于登录的密码。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");
ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_mdtm() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_mdtm() 函数

PHP FTP 函数

定义和用法

ftp_mdtm() 函数返回指定文件的最后修改时间。

语法

ftp_login(ftp_connection,file)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
file | 必需。规定要检查的文件。

提示和注释

注释：并非所有 FTP 服务器都支持该函数。

注释：该函数不适用于检查目录。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

$mod = ftp_mdtm($conn,"test.txt");

//以 Unix 时间戳返回结果
echo $mod;
echo "<br />";

//把 Unix 时间戳格式化为日期
echo date(DATE_RFC822,$mod);

ftp_close($conn);
?>

输出：

1140082571
Thu, 16 Feb 2006 10:36:11 CET

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_mkdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_mkdir() 函数

PHP FTP 函数

定义和用法

ftp_mkdir() 函数在 FTP 服务器上建立新目录。

语法

ftp_mkdir(ftp_connection,dir)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
dir | 必需。规定要创建的目录的名称。

说明

在 FTP 服务器上建立一个目录名为参数 dir 的新目录。

如果成功，则返回新建的目录名，否则返回 false。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_mkdir($conn,"testdir");

ftp_close($conn);
?>

输出：

/testdir

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_nb_continue() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_nb_continue() 函数

PHP FTP 函数

定义和用法

ftp_nb_continue() 函数连续获取 / 发送文件。

该函数返回下列值：

  • FTP_FAILED (send/receive failed)
  • FTP_FINISHED (send/receive completed)
  • FTP_MOREDATA (send/receive in progress)

该函数异步地发送/获取文件。这意味着您的程序可以在文件下载时执行其他操作。

语法

ftp_nb_continue(ftp_connection)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。

例子

<?php
$source = "source.txt";
$target = fopen("target.txt", "w");

$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

$status = ftp_nb_fget($conn,$source,$target,FTP_ASCII);

while ($status == FTP_MOREDATA)
  {
  $status = ftp_nb_continue($conn);
  }

if ($status != FTP_FINISHED)
  {
  echo "Download error";
  }

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_nb_fget() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_nb_fget() 函数

PHP FTP 函数

定义和用法

ftp_nb_fget() 函数从 FTP 服务器上下载一个文件并保存到本地已经打开的一个文件中 (non-blocking)。

该函数返回下列值：

  • FTP_FAILED (send/receive failed)
  • FTP_FINISHED (send/receive completed)
  • FTP_MOREDATA (send/receive in progress)

与 ftp_fget() 不同，该函数异步地获取文件。这意味着您的程序可以在文件下载时执行其他操作。

语法

ftp_nb_fget(ftp_connection,local,remote,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
local | 必需。规定本地文件。
remote | 必需。规定从中进行拷贝的文件的路径。
mode

必需。规定传输模式。可能的值有：

  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在远程文件中的何处开始拷贝。默认是 0。

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$source = "source.txt";
$target = fopen("target.txt", "w");

$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_nb_fget($conn,$target,$source,FTP_ASCII);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_nb_fput() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_nb_fput() 函数

PHP FTP 函数

定义和用法

ftp_nb_fput() 函数上传一个已打开的文件，并在 FTP 服务器上把它保存为文件 (non-blocking)。

该函数返回下列值：

  • FTP_FAILED (send/receive failed)
  • FTP_FINISHED (send/receive completed)
  • FTP_MOREDATA (send/receive in progress)

与 ftp_fput() 不同，该函数异步地获取文件。这意味着您的程序可以在文件下载时执行其他操作。

语法

ftp_nb_fput(ftp_connection,remote,local,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
remote | 必需。上传到服务器上的文件名。
local | 必需。规定所打开文件的句柄。
mode

必需。规定传输模式。可能的值有：

  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在本地文件中的何处开始拷贝。默认是 0。

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$source = fopen("source.txt","r");

$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_nb_fput($conn,"target.txt",$source,FTP_ASCII);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_nb_get() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_nb_get() 函数

PHP FTP 函数

定义和用法

ftp_nb_get() 函数从 FTP 服务器上获取文件并写入本地文件 (non-blocking)。

该函数返回下列值：

  • FTP_FAILED (send/receive failed)
  • FTP_FINISHED (send/receive completed)
  • FTP_MOREDATA (send/receive in progress)

与 ftp_get() 不同，该函数异步地获取文件。这意味着您的程序可以在文件传输时执行其他操作。

语法

ftp_nb_get(ftp_connection,local,remote,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
local | 必需。规定要写入的本地文件。若该文件已存在，则将被覆盖。
remote | 必需。规定从中进行拷贝的文件的路径。
mode

必需。规定传输模式。可能的值有：

  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在远程文件中的何处开始拷贝。默认是 0。

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_nb_get($conn,"target.txt","source.txt",FTP_ASCII);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_nb_put() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_nb_put() 函数

PHP FTP 函数

定义和用法

ftp_nb_put() 函数把文件上传到服务器 (non-blocking)。

该函数返回下列值：

  • FTP_FAILED (send/receive failed)
  • FTP_FINISHED (send/receive completed)
  • FTP_MOREDATA (send/receive in progress)

与 ftp_put() 不同，该函数异步地获取文件。这意味着您的程序可以在文件传输时执行其他操作。

语法

ftp_nb_fput(ftp_connection,remote,local,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
remote | 必需。上传到服务器上的文件名。
local | 必需。规定要上传的本地文件的路径。
mode

必需。规定传输模式。可能的值有：

  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在本地文件中的何处开始拷贝。默认是 0。

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_nb_put($conn,"target.txt","source.txt",FTP_ASCII);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_nlist() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_nlist() 函数

PHP FTP 函数

定义和用法

ftp_nlist() 函数返回指定目录的文件列表。

如果成功，则返回给定目录下的文件名组成的数组，否则返回 false。

语法

ftp_nlist(ftp_connection,dir)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
dir | 必需。规定要检查的目录。使用 "." 来获得当前目录。

提示和注释

注释：该函数不适用于 IIS (Internet Information Server)。它返回 nothing。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

print_r(ftp_nlist($conn,"images"));

ftp_close($conn);
?>

输出类似：

array(3)
{
[0]=> "flower.gif"
[1]=> "car.gif"
[2]=> "house.gif"
}

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_pasv() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_pasv() 函数

PHP FTP 函数

定义和用法

ftp_pasv() 函数把被动模式设置为打开或关闭。

在被动模式中，数据连接是由客户机来初始化的，而不是服务器。这在客户机位于防火墙之后时比较有用。

语法

ftp_pasv(ftp_connection,mode)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
mode

必需。规定模式。

  • TRUE = passive mode on
  • FALSE = passive mode off

说明

如果参数 mode 为真，打开被动模式传输 (PASV MODE) ，否则，如果参数 mode 为假，则关闭被动传输模式。在被动模式打开的情况下，数据的传送由客户机启动，而不是由服务器开始。

如果成功则返回 true，失败则返回 false。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_pasv($conn,TRUE);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_put() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_put() 函数

PHP FTP 函数

定义和用法

ftp_put() 函数把文件上传到服务器。

若成功则返回 true，失败则返回 false。

语法

ftp_put(ftp_connection,remote,local,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
remote | 必需。上传到服务器上的文件名。
local | 必需。规定要上传的本地文件的路径。
mode

必需。规定传输模式。可能的值有：

  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在本地文件中的何处开始拷贝。默认是 0。

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_put($conn,"target.txt","source.txt",FTP_ASCII);

ftp_close($conn);
?>

输出：

1

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_pwd() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_pwd() 函数

PHP FTP 函数

定义和用法

ftp_pwd() 函数返回当前目录名。

语法

ftp_pwd(ftp_connection)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

// 输出当前目录
echo ftp_pwd($conn) . "<br />";

// 把目录改为 images
ftp_chdir($conn,"images");

// 输出当前目录
echo ftp_pwd($conn);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_quit() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_quit() 函数

PHP FTP 函数

定义和用法

ftp_quit() 函数关闭 FTP 连接。

该函数关闭给出的连接标识符并释放资源。

语法

ftp_quit(ftp_connection)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。

提示和注释

提示：该函数是 ftp_close() 函数的别名。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");

//要执行的一些代码

ftp_quit($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_raw() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_raw() 函数

PHP FTP 函数

定义和用法

ftp_raw() 函数向 FTP 服务器发送一个 raw 命令。

语法

ftp_raw(ftp_connection,command)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
command | 必需。规定要执行的命令。

提示和注释

注释：该函数以字符串数组的形式返回服务器的响应。不执行解析，且 ftp_raw() 不检查命令是否正确。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");

print_r (ftp_raw($conn,"USER admin"));
print_r (ftp_raw($conn,"PASS ert456"));

ftp_close($conn);
?>

输出：

Array ([0] => 331 User admin, password please)
Array ([0] => 230 Password Ok, User logged in)

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_rawlist() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_rawlist() 函数

PHP FTP 函数

定义和用法

ftp_rawlist() 函数返回指定目录中文件的详细列表。

语法

ftp_rawlist(ftp_connection,dir,recursive)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
dir | 必需。规定目录。使用 "." 来规定当前目录。
recursive | 可选。默认地，该函数向服务器发送 "LIST" 命令。如果，如果 recursive 参数设置为 true，则发送 "LIST -R" 命令。

说明

ftp_rawlist() 函数将执行 FTP LIST 命令，并把结果返回为一个数组。数组的每个元素为返回文本的每一行，输出结构不会被解析。

使用函数 ftp_systype() 可以用来判断 FTP 服务器的类型，从而可以用来判断返回列表的类型。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

print_r (ftp_rawlist($conn,"."));

ftp_close($conn);
?>

输出类似：

Array
(
[0] => dr--r--r-- 1 user group 0 Feb 15 13:02 .
[1] => dr--r--r-- 1 user group 0 Feb 15 13:02 ..
[2] => drw-rw-rw- 1 user group 0 Jan 03 08:33 images
[3] => -rw-rw-rw- 1 user group 160 Feb 16 13:54 test.php
[4] => -rw-rw-rw- 1 user group 20 Feb 14 12:22 test.txt
)

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_rename() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_rename() 函数

PHP FTP 函数

定义和用法

ftp_rename() 函数更改 FTP 服务器上的文件或目录名。

如果成功，则返回 true，否则返回 false。

语法

ftp_rename(ftp_connection,from,to)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
from | 必需。规定要改名的文件或目录。
to | 必需。规定文件或目录的新名称。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_rename($conn,"oldname.txt","newname.txt");

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_rmdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_rmdir() 函数

PHP FTP 函数

定义和用法

ftp_rmdir() 函数删除一个目录。

如果成功，则返回 true，否则返回 false。

语法

ftp_rmdir(ftp_connection,dir)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
dir | 必需。规定要删除的目录。

说明

删除由参数 dir 指定的目录。dir 必须是一个空目录的绝对或相对路径。

如果成功，则返回 true，否则返回 false。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_rmdir($conn,"testdir");

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_set_option() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_set_option() 函数

PHP FTP 函数

定义和用法

ftp_set_option() 函数设置各种 FTP 运行时选项。

语法

ftp_set_option(ftp_connection,option,value)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
option

必需。规定要删设置的运行时选项。可能的值：

  • FTP_TIMEOUT_SEC
  • FTP_AUTOSEEK

详细信息见下面的说明。
value | 必需。设置 option 参数的值。

说明

FTP_TIMEOUT_SEC 选项改变网络传输的超时时间。参数 value 必须为整数且大于 0。默认的超时时间为 90 秒。

当 FTP_AUTOSEEK 选项打开时，带 resumepos 或 startpos 参数的 GET 或 PUT 请求将先检索到文件中指定的位置。此选项默认是打开的。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_set_option($conn,FTP_TIMEOUT_SEC,120);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_site() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_site() 函数

PHP FTP 函数

定义和用法

ftp_site() 函数向服务器发送 SITE 命令。

SITE 命令没有标准化。不同的服务器不尽相同。对于处理文件权限或组关系方面的事情，SITE 命令很有用。

语法

ftp_site(ftp_connection,command)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
command | 必需。规定向 FTP 发送的 SITE 命令。

说明

ftp_site() 函数向 FTP 服务器发送由参数 command 指定的命令。

如果成功则返回 true，失败则返回 false。

提示和注释

提示：如需查看哪些命令可用，请通过 ftp_raw() 函数发送 REMOTEHELP 命令。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_site($conn,"CHMOD 0600 sitetest.txt");

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_size() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_size() 函数

PHP FTP 函数

定义和用法

ftp_size() 函数返回指定文件的大小。

语法

ftp_size(ftp_connection,remote_file)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
remote_file | 必需。规定要检查的文件。

说明

ftp_size() 函数以字节返回远程文件 remote_file 的大小。如果指定文件不存在或发生错误，则返回 -1。有些 FTP 服务器可能不支持此特性。

如果获取成功，则返回文件大小，否则返回 -1。

提示和注释

注释：并非所有 FTP 服务器均支持该函数。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_size($conn,"test.txt");

ftp_close($conn);
?>

输出类似：

160

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_ssl_connect() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_ssl_connect() 函数

PHP FTP 函数

定义和用法

ftp_ssl_connect() 函数打开一个安全的 SSL-FTP 连接。

当连接打开，您就可以在服务器运行 FTP 函数。

语法

ftp_ssl_connect(host,port,timeout)
参数 | 描述
host | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。 可以是域名或 IP 地址。该参数不能包含 "ftp://" 或 斜杠。
port | 可选。规定 FTP 服务器的端口。默认是 21。
timeout | 可选。规定 FTP 连接的超时时间。默认是 90 秒。

例子

本例尝试连接一个 FTP 服务器。如果连接失败，die() 函数会终止脚本的执行，并输出一条消息：

<?php
$conn = ftp_ssl_connect("ftp.testftp.com") or die("Could not connect");
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_systype() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_systype() 函数

PHP FTP 函数

定义和用法

ftp_systype() 函数返回远程 FTP 服务器的系统类型标识符。

该函数返回远程服务器的系统类型。若发生错误，则返回 false。

语法

ftp_systype(ftp_connection)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_systype($conn);

ftp_close($conn);
?>

输出类似：

UNIX

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP FTP 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FTP 函数

  • Previous Page
  • Next Page

PHP FTP 简介

FTP 函数通过文件传输协议 (FTP) 提供对文件服务器的客户端访问。

FTP 函数用于打开、登录以及关闭连接，同时用于上传、下载、重名命、删除及获取文件服务器上的文件信息。不是所有 FTP 函数对每个服务器都起作用或返回相同的结果。自 PHP 3 起，FTP 函数可用。

这些函数用于对 FTP 服务器进行细致的访问。如果您仅仅需要对 FTP 服务器进行读写操作，建议使用 Filesystem 函数中的 ftp:// wrapper。

安装

PHP 的 Windows 版本已经内置该 FTP 扩展模块的支持。无需加载任何附加扩展库即可使用这些函数。

不过，如果您运行的是 PHP 的 Linux 版本，在编译的时候请添加 --enable-ftp 选项 (PHP4 或以上版本) 或者 --with-ftp (PHP3 版本)。

PHP FTP 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
ftp_alloc() | 为要上传到 FTP 服务器的文件分配空间。 | 5
ftp_cdup() | 把当前目录改变为 FTP 服务器上的父目录。 | 3
ftp_chdir() | 改变 FTP 服务器上的当前目录。 | 3
ftp_chmod() | 通过 FTP 设置文件上的权限。 | 5
ftp_close() | 关闭 FTP 连接。 | 4
ftp_connect() | 打开 FTP 连接。 | 3
ftp_delete() | 删除 FTP 服务器上的文件。 | 3
ftp_exec() | 在 FTP 上执行一个程序/命令。 | 4
ftp_fget() | 从 FTP 服务器上下载一个文件并保存到本地一个已经打开的文件中。 | 3
ftp_fput() | 上传一个已打开的文件，并在 FTP 服务器上把它保存为一个文件。 | 3
ftp_get_option() | 返回当前 FTP 连接的各种不同的选项设置。 | 4
ftp_get() | 从 FTP 服务器下载文件。 | 3
ftp_login() | 登录 FTP 服务器。 | 3
ftp_mdtm() | 返回指定文件的最后修改时间。 | 3
ftp_mkdir() | 在 FTP 服务器创建一个新目录。 | 3
ftp_nb_continue() | 连续获取／发送文件 (non-blocking)。 | 4
ftp_nb_fget() | 从FTP服务器上下载文件并保存到本地已经打开的文件中(non-blocking) | 4
ftp_nb_fput() | 上传已打开的文件，并在FTP服务器上把它保存为文件(non-blocking)。 | 4
ftp_nb_get() | 从 FTP 服务器下载文件 (non-blocking)。 | 4
ftp_nb_put() | 把文件上传到服务器 (non-blocking)。 | 4
ftp_nlist() | 返回指定目录的文件列表。 | 3
ftp_pasv() | 返回当前 FTP 被动模式是否打开。 | 3
ftp_put() | 把文件上传到服务器。 | 3
ftp_pwd() | 返回当前目录名称。 | 3
ftp_quit() | ftp_close() 的别名。 | 3
ftp_raw() | 向 FTP 服务器发送一个 raw 命令。 | 5
ftp_rawlist() | 返回指定目录中文件的详细列表。 | 3
ftp_rename() | 重命名 FTP 服务器上的文件或目录。 | 3
ftp_rmdir() | 删除 FTP 服务器上的目录。 | 3
ftp_set_option() | 设置各种 FTP 运行时选项。 | 4
ftp_site() | 向服务器发送 SITE 命令。 | 3
ftp_size() | 返回指定文件的大小。 | 3
ftp_ssl_connect() | 打开一个安全的 SSL-FTP 连接。 | 4
ftp_systype() | 返回远程 FTP 服务器的系统类型标识符。 | 3

PHP FTP 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
FTP_ASCII |  | 3
FTP_TEXT |  | 3
FTP_BINARY |  | 3
FTP_IMAGE |  | 3
FTP_TIMEOUT_SEC |  | 3
FTP_AUTOSEEK |  | 4
FTP_AUTORESUME | 为 GET 和 PUT 请求自动决定恢复和开始的位置 只能工作在 FTP_AUTOSEEK 打开的情况下 | 4
FTP_FAILED | 异步传输失败 | 4
FTP_FINISHED | 异步传输成功 | 4
FTP_MOREDATA | 异步传输是活动状态的 | 4
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP ftruncate() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftruncate() 函数

PHP Filesystem 函数

定义和用法

ftruncate() 函数把文件截断到指定的长度。

语法

ftruncate(file,size)
参数 | 描述
file | 必需。规定要截断的打开文件。
size | 必需。规定新的文件大小。

说明

接受文件指针 file 作为参数，并将文件大小截取为 size。如果成功则返回 TRUE，否则返回 FALSE。

提示和注释

注释：文件只会在 append 模式下改变。在 write 模式下，必须加上 fseek() 操作。

注释：在 PHP 4.3.3 之前，ftruncate() 在成功时返回一个整数值 1，而不是布尔值的 TRUE。

例子

<?php
//检查文件大小
echo filesize("test.txt");
echo "<br />";

$file = fopen("test.txt", "a+");
ftruncate($file,100);
fclose($file);

//清空缓存，再次检查文件大小
clearstatcache();
echo filesize("test.txt");
?>

输出类似：

792
100

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fwrite() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fwrite() 函数

PHP Filesystem 函数

定义和用法

fwrite() 函数写入文件（可安全用于二进制文件）。

语法

fwrite(file,string,length)
参数 | 描述
file | 必需。规定要写入的打开文件。
string | 必需。规定要写入文件的字符串。
length | 可选。规定要写入的最大字节数。

说明

fwrite() 把 string 的内容写入文件指针 file 处。 如果指定了 length，当写入了 length 个字节或者写完了 string 以后，写入就会停止，视乎先碰到哪种情况。

fwrite() 返回写入的字符数，出现错误时则返回 false。

例子

<?php
$file = fopen("test.txt","w");
echo fwrite($file,"Hello World. Testing!");
fclose($file);
?>

输出：

21

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP get_browser() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP get_browser() 函数

PHP 杂项函数

定义和用法

get_browser() 函数返回用户浏览器的性能。

该函数通过查阅用户的 browscap.ini 文件，来测定用户浏览器的性能。

若成功，则该函数返回包含用户浏览器信息的一个对象或一个数组，若失败，则返回 false。

语法

get_browser(user_agent,return_array)
参数 | 描述
user_agent | 可选。规定 HTTP 用户代理的名称。默认是 $HTTP_USER_AGENT 的值。 您可以通过设置 NULL 绕过该参数。
return_array | 可选。如果该参数设置为 true，本函数会返回一个数组而不是对象。

提示和注释

注释：返回语句会立即终止对字符串的计算。

注释：该函数对于在数据库文本字段中供日后计算而进行的代码存储很有用。

例子

<?php
echo $_SERVER['HTTP_USER_AGENT'] . "<br /><br />";
$browser = get_browser(null,true);
print_r($browser);
?>

输出：

Mozilla/4.0
(compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Array
(
[browser_name_regex] => ^mozilla/.\.0
(compatible; msie 6\.0.*;.*windows nt 5\.1.*\.net clr.*).*$
[browser_name_pattern] => Mozilla/?.0
(compatible; MSIE 6.0*;*Windows NT 5.1*.NET CLR*)*
[parent] => IE 6.0
[platform] => WinXP
[netclr] => 1
[browser] => IE
[version] => 6.0
[majorver] => 6
[minorver] => 0
[css] => 2
[frames] => 1
[iframes] => 1
[tables] => 1
[cookies] => 1
[backgroundsounds] => 1
[vbscript] => 1
[javascript] => 1
[javaapplets] => 1
[activexcontrols] => 1
[cdf] => 1
[aol] =>
[beta] =>
[win16] =>
[crawler] =>
[stripper] =>
[wap] =>
[ak] =>
[sk] =>
)

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP get_html_translation_table() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP get_html_translation_table() 函数

PHP String 函数

定义和用法

get_html_translation_table() 函数返回被 htmlentities() 和 htmlspecialchars() 函数使用的翻译表。

语法

get_html_translation_table(function,quotestyle)
参数 描述
function

可选。规定返回哪个翻译表。默认是 HTML_SPECIALCHARS。

可能的值：

  • HTML_ENTITIES - 翻译所有需要 URL 编码的字符，以便正确地显示在网页上。
  • HTML_SPECIALCHARS - 翻译某些需要 URL 编码的字符，以便正确地显示在网页上。
salt

可选。定义如何对单引号和双引号进行编码。默认是 ENT_COMPAT。

可能的值：

  • ENT_COMPAT - 编码双引号，不编码单引号。
  • ENT_QUOTES - 编码双引号和单引号。
  • ENT_NOQUOTES - 不编码单引号或双引号。

说明

提示和注释

提示：一些字符可以按照若干种方式进行编码。get_html_translation_table() 返回最普通的编码。

例子

在本例中，我们将展示两种翻译表：

<?php
print_r (get_html_translation_table());
echo "<br />";
print_r (get_html_translation_table(HTML_ENTITIES));
?>

输出：

PHP String 函数

PHP 参考手册
PHP 测验


PHP getcwd() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP getcwd() 函数

PHP Directory 函数

定义和用法

getcwd() 函数返回当前目录。

若成功，则返回当前工作目录，否则返回 false。

语法

getcwd()

例子

<?php
echo getcwd();
?>

输出：

C:\testweb\main

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP getdate() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP getdate() 函数

PHP Date / Time 函数

定义和用法

getdate() 函数取得日期／时间信息。

语法

getdate(timestamp)
参数 | 描述
timestamp | 可选。规定 Unix 时间格式中的时间。

说明

返回一个根据 timestamp 得出的包含有日期信息的结合数组。如果没有给出时间戳，则认为是当前本地时间。

数组中的单元如下：

键名 | 说明 | 返回值例子
"seconds" | 秒的数字表示 | 0 到 59
"minutes" | 分钟的数字表示 | 0 到 59
"hours" | 小时的数字表示 | 0 到 23
"mday" | 月份中第几天的数字表示 | 1 到 31
"wday" | 星期中第几天的数字表示 | 0（表示星期天）到 6（表示星期六）
"mon" | 月份的数字表示 | 1 到 12
"year" | 4 位数字表示的完整年份 | 例如：1999 或 2003
"yday" | 一年中第几天的数字表示 | 0 到 365
"weekday" | 星期几的完整文本表示 | Sunday 到 Saturday
"month" | 月份的完整文本表示 | January 到 December
0 | 自从 Unix 纪元开始至今的秒数，和 time() 的返回值以及用于 date() 的值类似。 | 系统相关，典型值为从 -2147483648 到 2147483647。

例子

例子 1

<?php
print_r(getdate());
?>

输出：

Array
(
[seconds] => 45
[minutes] => 52
[hours] => 14
[mday] => 24
[wday] => 2
[mon] => 1
[year] => 2006
[yday] => 23
[weekday] => Tuesday
[month] => January
[0] => 1138110765
)

例子 2

<?php
$my_t=getdate(date("U"));
print("$my_t[weekday], $my_t[month] $my_t[mday], $my_t[year]");
?>

输出：

Wednesday, January 25, 2006

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP getDocNamespaces() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP getDocNamespaces() 函数

PHP SimpleXML 函数

定义和用法

getDocNamespaces() 函数从 SimpleXMLElement 对象返回在 XML 文档中声明的命名空间。

如果成功，该函数返回包含命名空间名称（带有关联的 URL）的数组。如果失败，则返回 false。

语法

class SimpleXMLElement
{
string getDocNamespaces(recursive)
}
参数 | 描述
recursive | 可选。规定是否返回父子节点中的所有命名空间。默认是 false。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note xmlns:b="http://www.w3school.com.cn/example/">
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<b:body>Don't forget the meeting!</b:body>
</note>

PHP 代码：

<?php
if (file_exists('test.xml'))
  {
  $xml = simplexml_load_file('test.xml');
  }

print_r($xml->getDocNamespaces());
?>

输出类似：

Array
(
[b] => http://www.w3school.com.cn/example/
)

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP getName() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP getName() 函数

PHP SimpleXML 函数

定义和用法

getName() 函数从 SimpleXMLElement 对象获取 XML 元素的名称。

如果成功，该函数返回当前的 XML 元素的名称。如果失败，则返回 false。

语法

class SimpleXMLElement
{
string getName()
}

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<b:body>Don't forget the meeting!</b:body>
</note>

PHP 代码：

<?php
if (file_exists('test.xml'))
  {
  $xml = simplexml_load_file('test.xml');
  }

echo $xml->getName();

foreach($xml->children() as $child)
  {
  echo $child->getName();
  }
?>

输出类似：

note
to
from
heading
body

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP getNamespace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP getNamespace() 函数

PHP SimpleXML 函数

定义和用法

getNamespace() 函数获取在 XML 文档中使用的命名空间。

如果成功，该函数返回命名空间（带有关联的 URL）的一个数组。如果失败，则返回 false。

语法

class SimpleXMLElement
{
string getNamespace(recursive)
}
参数 | 描述
recursive | 可选。规定是否返回父子节点中使用的所有命名空间。默认是 false。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note xmlns:b="http://www.w3school.com.cn/example/">
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<b:body>Don't forget the meeting!</b:body>
</note>

PHP 代码：

<?php
if (file_exists('test.xml'))
  {
  $xml = simplexml_load_file('test.xml');
  }

print_r($xml->getNamespaces());
?>

输出类似：

Array
(
[b] => http://www.w3school.com.cn/example/
)

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP gettimeofday() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP gettimeofday() 函数

PHP Date / Time 函数

定义和用法

gettimeofday() 函数返回一个包含当前时间信息的数组。

自 PHP 5.1.0 起有个可选参数 return_float，当其设置为 TRUE 时，gettimeofday() 会返回一个浮点数。

所返回的数组键的含义是：

  • "sec" - 自 Unix 纪元起的秒数
  • "usec" - 微秒数
  • "minuteswest" - 格林威治向西的分钟数
  • "dsttime" - 夏令时修正的类型

语法

gettimeofday(return_float)
参数 | 描述
return_float | 可选。当其设置为 TRUE 时，gettimeofday() 会返回一个浮点数。

例子

例子 1

<?php
echo(gettimeofday(true) . "<br /><br />");
print_r(gettimeofday());
?>

输出：

1138111447.4

Array
(
[sec] => 1138111447
[usec] => 395863
[minuteswest] => -60
[dsttime] => 0
)

例子 2

<?php
$my_t=gettimeofday();
print("$my_t[sec].$my_t[usec]");
?>

输出：

1138197006.988273

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP glob() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP glob() 函数

PHP Filesystem 函数

定义和用法

glob() 函数返回匹配指定模式的文件名或目录。

该函数返回一个包含有匹配文件 / 目录的数组。如果出错返回 false。

语法

glob(pattern,flags)
参数 | 描述
file | 必需。规定检索模式。
size

可选。规定特殊的设定。

  • GLOB_MARK - 在每个返回的项目中加一个斜线
  • GLOB_NOSORT - 按照文件在目录中出现的原始顺序返回（不排序）
  • GLOB_NOCHECK - 如果没有文件匹配则返回用于搜索的模式
  • GLOB_NOESCAPE - 反斜线不转义元字符
  • GLOB_BRACE - 扩充 {a,b,c} 来匹配 'a'，'b' 或 'c'
  • GLOB_ONLYDIR - 仅返回与模式匹配的目录项
  • GLOB_ERR - 停止并读取错误信息（比如说不可读的目录），默认的情况下忽略所有错误

注释：GLOB_ERR 是 PHP 5.1 添加的。

例子

例子 1

<?php
print_r(glob("*.txt"));
?>

输出类似：

Array
(
[0] => target.txt
[1] => source.txt
[2] => test.txt
[3] => test2.txt
)

例子 2

<?php
print_r(glob("*.*"));
?>

输出类似：

Array
(
[0] => contacts.csv
[1] => default.php
[2] => target.txt
[3] => source.txt
[4] => tem1.tmp
[5] => test.htm
[6] => test.ini
[7] => test.php
[8] => test.txt
[9] => test2.txt
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP gmdate() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP gmdate() 函数

PHP Date / Time 函数

定义和用法

gmdate() 函数格式化 GMT/UTC 日期/时间。

同 date() 函数 类似，不同的是返回的时间是格林威治标准时（GMT）。

语法

gmdate(format,timestamp)

参数 | 描述
format | 可选。规定如何返回结果。
timestamp | 可选。

提示和注释

注释：在 PHP 5.1.0 之前，负的时间戳（1970 年之前的日期）在某些系统下（例如 Windows）不能工作。

例子

例子 1

当在中国（GMT +0800）运行以下程序时，第一行显示“Jan 01 2000 00:00:00”，而第二行显示“Dec 31 1999 16:00:00”。

<?php
echo date("M d Y H:i:s", mktime (0,0,0,1,1,2000));
echo gmdate("M d Y H:i:s", mktime (0,0,0,1,1,2000));
?>

输出：

Jan 01 2000 00:00:00
Dec 31 1999 16:00:00

例子 2

<?php
echo("Result with date():<br />");
echo(date("l") . "<br />");
echo(date("l dS \of F Y h:i:s A") . "<br />");
echo("Oct 3,1975 was on a ".date("l", mktime(0,0,0,10,3,1975))."<br />");
echo(date(DATE_RFC822) . "<br />");
echo(date(DATE_ATOM,mktime(0,0,0,10,3,1975)) . "<br /><br />");

echo("Result with gmdate():<br />");
echo(gmdate("l") . "<br />");
echo(gmdate("l dS \of F Y h:i:s A") . "<br />");
echo("Oct 3,1975 was on a ".gmdate("l", mktime(0,0,0,10,3,1975))."<br />");
echo(gmdate(DATE_RFC822) . "<br />");
echo(gmdate(DATE_ATOM,mktime(0,0,0,10,3,1975)) . "<br />");
?>

输出：

Result with date():
Tuesday
Tuesday 24th of January 2006 02:41:22 PM
Oct 3,1975 was on a Friday
Tue, 24 Jan 2006 14:41:22 CET
1975-10-03T00:00:00+0100

Result with gmdate():
Tuesday
Tuesday 24th of January 2006 01:41:22 PM
Oct 3,1975 was on a Thursday
Tue, 24 Jan 2006 13:41:22 GMT
1975-10-02T23:00:00+0000

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP gmmktime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP gmmktime() 函数

PHP Date / Time 函数

定义和用法

gmmktime() 函数取得 GMT 日期的 UNIX 时间戳。

与 mktime() 类似，不同的是返回值是格林威治标准时的时间戳。

参数总是表示 GMT 日期，因此 is_dst 对结果没有影响。

与 mktime() 一样，参数可以从右到左依次空着，空着的参数会被设为相应的当前 GMT 值。

语法

gmmktime(hour,minute,second,month,day,year,is_dst)
参数 | 描述
hour | 可选。规定小时。
minute | 可选。规定分钟。
second | 可选。规定秒。
month | 可选。规定用数字表示的月。
day | 可选。规定天。
year | 可选。规定年。在某些系统上，合法值介于 1901 - 2038 之间。不过在 PHP 5 中已经不存在这个限制了。
is_dst | 可选。如果时间在日光节约时间(DST)期间，则设置为1，否则设置为0，若未知，则设置为-1。 自 5.1.0 起，is_dst 参数被废弃。因此应该使用新的时区处理特性。

提示和注释

注释：gmmktime() 内部使用了 mktime()，因此只有转换成本地时间也合法的时间才能用在其中。

例子

<?php
$my_birthday = gmmktime(0,0,0,10,3,1975);
print($my_birthday . "<br />");
print(date("M-d-Y",$my_birthday));
?>

输出：

181526400
Oct-03-1975

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP gmstrftime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP gmstrftime() 函数

PHP Date / Time 函数

定义和用法

gmstrftime() 函数根据本地区域设置格式化 GMT/UTC 时间／日期。

语法

gmstrftime(format,timestamp)
参数 | 描述
format | 可选。规定如何返回结果。
timestamp | 可选。

提示和注释

提示：与 strftime() 的行为相同，不同的是返回时间是格林威治标准时（GMT）。

例子

输出 strftime() 和 gmstrftime() 的结果：

<?php
echo(strftime("%b %d %Y %X", mktime(20,0,0,12,31,98)));
echo(gmstrftime("%b %d %Y %X", mktime(20,0,0,12,31,98)));

//输出当前日期、时间和时区
echo(gmstrftime("It is %a on %b %d, %Y, %X time zone: %Z",time()));
?>

输出：

Dec 31 1998 20:00:00
Dec 31 1998 19:00:00
It is Wed on Jan 25, 2006, 11:32:10 time zone: W. Europe Standard Time

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP GregorianToJD() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP GregorianToJD() 函数

PHP Array 函数

定义和用法

GregorianToJD() 函数将格利高里历法转换成为儒略日计数。

语法

gregoriantojd(month,day,year)
参数 | 描述
month | 必需。规定月
day | 必需。规定日
year | 可选。合法的范围是 4714 B.C. 到 9999 A.D。

提示和注释

尽管该函数可处理 4714 B.C. 之前的日期，您还是要注意格利高里历法在 1582 年才建立，一些国家甚至更晚才接受它（大不列颠在 1752 年，苏联在 1918 年，希腊在 1923 年）。大部分欧洲国家使用罗马儒略历（公历）先于格利高里历法。

例子

<?php
$jd = gregoriantojd(10,3,1975);
echo($jd . "<br />");

$gregorian = jdtogregorian($jd);
echo($gregorian);
?>

输出：

2442689
10/3/1975

PHP Array 函数

PHP 参考手册
PHP 测验


PHP header() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP header() 函数

PHP HTTP 函数

定义和用法

header() 函数向客户端发送原始的 HTTP 报头。

认识到一点很重要，即必须在任何实际的输出被发送之前调用 header() 函数（在 PHP 4 以及更高的版本中，您可以使用输出缓存来解决此问题）：

<html>
<?php
// 结果出错
// 在调用 header() 之前已存在输出
header('Location: http://www.example.com/');
?>

语法

header(string,replace,http_response_code)
参数 | 描述
string | 必需。规定要发送的报头字符串。
replace | 可选。指示该报头是否替换之前的报头，或添加第二个报头。 默认是 true（替换）。false（允许相同类型的多个报头）。
http_response_code | 可选。把 HTTP 响应代码强制为指定的值。（PHP 4 以及更高版本可用）

提示和注释

注释：从 PHP 4.4 之后，该函数防止一次发送多个报头。这是对头部注入攻击的保护措施。

例子

例子 1

<?php
// Date in the past
header("Expires: Mon, 26 Jul 1997 05:00:00 GMT");
header("Cache-Control: no-cache");
header("Pragma: no-cache");
?>

<html>
<body>

...
...

注释：用户可能会设置一些选项来更改浏览器的默认缓存设置。通过发送上面的报头，您可以覆盖任何这些设置，强制浏览器不进行缓存！

例子 2

提示用户保存一个生成的 PDF 文件（Content-Disposition 报头用于提供一个推荐的文件名，并强制浏览器显示保存对话框）：

<?php
header("Content-type:application/pdf");

// 文件将被称为 downloaded.pdf
header("Content-Disposition:attachment;filename='downloaded.pdf'");

// PDF 源在 original.pdf 中
readfile("original.pdf");
?>

<html>
<body>

...
...

注释：微软 IE 5.5 存在一个阻止以上机制的 bug。通过升级为 Service Pack 2 或更高的版本，可以解决该 bug。

PHP HTTP 函数

PHP 参考手册
PHP 测验


PHP headers_list() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP headers_list() 函数

PHP HTTP 函数

定义和用法

headers_list() 函数返回已发送的（或待发送的）响应头部的一个列表。

该函数返回包含报头的数组。

语法

headers_list()

提示和注释

提示：如需确定是否已发送报头，请使用 headers_sent() 函数。

例子

<?php
setcookie("TestCookie","SomeValue"');
header("X-Sample-Test: foo");
header('Content-type: text/plain');
?>

<html>
<body>

<?php
// 发送哪些报头？
var_dump(headers_list());
?>

</body>
</html>

PHP HTTP 函数

PHP 参考手册
PHP 测验


PHP headers_sent() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP headers_sent() 函数

PHP HTTP 函数

定义和用法

headers_sent() 函数检查 HTTP 报头是否发送/已发送到何处。

如果报头已发送，则返回 true，否则返回 false。

语法

headers_sent(file,line)
参数 | 描述
file,line | 可选。如果设置 file 和 line 参数，headers_sent() 会把输出开始的 PHP 源文件名和行号存入 file 和 line 变量中。

提示和注释

注释：一旦报头块已经发送，就不能使用 header() 添加多个报头行。

注释：可选的 file 和 line 参数是 PHP 4.3 中新加的。

例子

例子 1

<?php
// 如果报头未发送，则发送一个
if (!headers_sent())
  {
  header("Location: http://www.w3school.com.cn/");
  exit;
  }
?>

<html>
<body>

...
...

例子 2

使用可选的 file 和 line 参数：

<?php
// 传递 $file 和 $line，供日后使用
// 不要预先为它们赋值
if (!headers_sent($file, $line))
  {
  header("Location: http://www.w3school.com.cn/");
  exit;
  // Trigger an error here
  }
else
  {
  echo "Headers sent in $file on line $line";
  exit;
  }
?>

<html>
<body>

...
...

PHP HTTP 函数

PHP 参考手册
PHP 测验


PHP hebrev() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP hebrev() 函数

PHP String 函数

定义和用法

hebrev() 函数把希伯来文本从右至左的流转换为左至右的流。

只有 224 至 251 之间的 ASCII 字符，以及标点符号受到影响。

语法

hebrev(string,maxcharline)
参数 | 描述
string | 必需。希伯来文本。
salt | 规定每行的最大字符数。如果可能，hebrev() 将避免把单词断开。

提示和注释

提示：hebrev() 和 hebrevc() 可以把希伯来逻辑文本转换为希伯来可见文本。希伯来可见文本不需要特殊的右至左字符支持，这使它对于在 web 上显示希伯来文本很有用处。

PHP String 函数

PHP 参考手册
PHP 测验


PHP hebrevc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP hebrevc() 函数

PHP String 函数

定义和用法

hebrevc() 函数把希伯来文本从右至左的流转换为左至右的流。它也会把新行 (\n) 转换为 <br />。

只有 224 至 251 之间的 ASCII 字符，以及标点符号受到影响。

语法

hebrev(string,maxcharline)
参数 | 描述
string | 必需。希伯来文本。
salt | 规定每行的最大字符数。如果可能，hebrev() 将避免把单词断开。

提示和注释

提示： hebrev() 和 hebrevc() 可以把希伯来逻辑文本转换为希伯来可见文本。希伯来可见文本不需要特殊的右至左字符支持，这使它对于在 web 上显示希伯来文本很有用处。

PHP String 函数

PHP 参考手册
PHP 测验


PHP hexdec() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP hexdec() 函数

PHP Math 函数

定义和用法

hexdec() 函数把十六进制转换为十进制。

语法

hexdec(hex_string)
参数 | 描述
hex_string | 必需。规定要转换的十六进制数。

说明

返回与 hex_string 参数所表示的十六进制数等值的的十进制数。hexdec() 将一个十六进制字符串转换为十进制数。所能转换的最大数值为 7fffffff，即十进制的 2147483647。PHP 4.1.0 开始，该函数可以处理大数字，这种情况下，它会返回 float 类型。

hexdec() 将遇到的所有非十六进制字符替换成 0。这样，所有左边的零都被忽略，但右边的零会计入值中。

例子

<?php
echo hexdec("1e");
echo hexdec("a");
echo hexdec("11ff");
echo hexdec("cceeff");
?>

输出：

30
10
4607
13430527

PHP Math 函数

PHP 参考手册
PHP 测验


PHP highlight_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP highlight_file() 函数

PHP 杂项函数

定义和用法

highlight_file() 函数对文件进行语法高亮显示。

语法

highlight_file(filename,return)
参数 | 描述
filename | 必需。要进行高亮处理的 PHP 文件的路径。
return | 可选。如果设置 true，则本函数返回高亮处理的代码。

说明

本函数通过使用 PHP 语法高亮程序中定义的颜色，输出或返回包含在 filename 中的代码的语法高亮版本。

许多服务器被配置为对带有 phps 后缀的文件进行自动高亮处理。例如，在查看 example.phps 时，将显示该文件被语法高亮显示的源代码。要启用该功能，请把下面这一行添加到 httpd.conf：

AddType application/x-httpd-php-source .phps

返回值

如果 return 参数被设置为 true，那么该函数会返回被高亮处理的代码，而不是输出它们。否则，若成功，则返回 true，失败则返回 false。

提示和注释

警告：需要注意的是，在使用 highlight_file() 函数时，请不要因为疏忽而泄露诸如密码或其他类型的敏感信息，否则会出现潜在的安全风险。

例子

"test.php":

<html>
<body>
<?php
highlight_file("test.php");
?>
</body>
</html>

输出：

<html>
<body>
<?php
highlight_file("test.php");
?>
</body>
</html>

在浏览器中查看的结果类似这样：

<html>
<body>
<code>
<span style="color: #000000">&lt;html&gt;
<br />
&lt;body&gt;
<br />
<span style="color: #0000BB">&lt;?php
<br />highlight_file</span>
<span style="color: #007700">(</span>
<span style="color: #DD0000">"test.php"</span>
<span style="color: #007700">);<br /></span>
<span style="color: #0000BB">?&gt;<br /></span>
&lt;/body&gt;
<br />
&lt;/html&gt;</span>
</code>
</body>
</html>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP highlight_string() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP highlight_string() 函数

PHP 杂项函数

定义和用法

highlight_string() 函数对字符串进行语法高亮显示。

语法

highlight_string(string,return)
参数 | 描述
string | 必需。要进行高亮处理的字符串。
return | 可选。如果设置 true，则本函数返回高亮处理的代码。

说明

本函数通过使用 PHP 语法高亮程序中定义的颜色，输出或返回给定的 PHP 代码的语法高亮版本。

返回值

如果 return 参数被设置为 true，那么该函数会以字符串返回被高亮处理的代码，而不是输出它们。否则，若成功，则返回 true，失败则返回 false。

例子

<html>
<body>
<?php
highlight_string("Hello world! <?php phpinfo(); ?>");
?>
</body>
</html>

输出：

Hello world! <?php phpinfo();?>

在浏览器中查看的结果类似这样：

<html>
<body>
 <code>
  <span style="color: #000000">Hello&nbsp;world!&nbsp;
  <span style="color: #0000BB">&lt;?php&nbsp;phpinfo</span>
  <span style="color: #007700">();</span>
  <span style="color: #0000BB">?&gt;</span>
  </span>
 </code>
</body>
</html>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP html_entity_decode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP htmlspecialchars_decode() 函数

PHP String 函数

定义和用法

htmlspecialchars_decode() 函数把一些预定义的 HTML 实体转换为字符。

会被解码的 HTML 实体是：

  • &amp; 成为 & （和号）
  • &quot; 成为 " （双引号）
  • &#039; 成为 ' （单引号）
  • &lt; 成为 < （小于）
  • &gt; 成为 > （大于）

语法

htmlspecialchars_decode(string,quotestyle)
参数 | 描述
string | 必需。规定要解码的字符串。
quotestyle

可选。规定如何解码单引号和双引号。

  • ENT_COMPAT - 默认。仅解码双引号。
  • ENT_QUOTES - 解码双引号和单引号。
  • ENT_NOQUOTES - 不解码任何引号。

例子

<?php
$str = "John &amp; &#039;Adams&#039;";
echo htmlspecialchars_decode($str);
echo "<br />";
echo htmlspecialchars_decode($str, ENT_QUOTES);
echo "<br />";
echo htmlspecialchars_decode($str, ENT_NOQUOTES);
?>

浏览器输出：

John & 'Adams'
John & 'Adams'
John & 'Adams'

如果在浏览器中查看源代码，会看到这些 HTML：

<html>
<body>
John & &#039;Adams&#039;<br />
John & 'Adams'<br />
John & &#039;Adams&#039;
</body>
</html>

PHP String 函数

PHP 参考手册
PHP 测验


PHP html_entity_decode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP html_entity_decode() 函数

PHP String 函数

定义和用法

html_entity_decode() 函数把 HTML 实体转换为字符。

html_entity_decode() 是 htmlentities() 的反函数。

语法

html_entity_decode(string,quotestyle,character-set)
参数 | 描述
string | 必需。规定要解码的字符串。
quotestyle

可选。规定如何解码单引号和双引号。

  • ENT_COMPAT - 默认。仅解码双引号。
  • ENT_QUOTES - 解码双引号和单引号。
  • ENT_NOQUOTES - 不解码任何引号。
character-set

可选。字符串值，规定要使用的字符集。

  • ISO-8859-1 - 默认。西欧。
  • ISO-8859-15 - 西欧（增加 Euro 符号以及法语、芬兰语字母）。
  • UTF-8 - ASCII 兼容多字节 8 比特 Unicode
  • cp866 - DOS 专用 Cyrillic 字符集
  • cp1251 - Windows 专用 Cyrillic 字符集
  • cp1252 - Windows 专用西欧字符集
  • KOI8-R - 俄语
  • GB2312 - 简体中文，国家标准字符集
  • BIG5 - 繁体中文
  • BIG5-HKSCS - Big5 香港扩展
  • Shift_JIS - 日语
  • EUC-JP - 日语

提示和注释

提示：无法被识别的字符集将被忽略，并由 ISO-8859-1 代替。

例子

<?php
$str = "John &amp; &#039;Adams&#039;";
echo html_entity_decode($str);
echo "<br />";
echo html_entity_decode($str, ENT_QUOTES);
echo "<br />";
echo html_entity_decode($str, ENT_NOQUOTES);
?>

浏览器输出：

John & 'Adams'
John & 'Adams'
John & 'Adams'

如果在浏览器中查看源代码，会看到这些 HTML：

<html>
<body>
John & &#039;Adams&#039;<br />
John & 'Adams'<br />
John & &#039;Adams&#039;
</body>
</html>

PHP String 函数

PHP 参考手册
PHP 测验


PHP htmlentities() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP htmlentities() 函数

PHP String 函数

定义和用法

htmlentities() 函数把字符转换为 HTML 实体。

语法

htmlentities(string,quotestyle,character-set)
参数 | 描述
string | 必需。规定要转换的字符串。
quotestyle

可选。规定如何编码单引号和双引号。

  • ENT_COMPAT - 默认。仅编码双引号。
  • ENT_QUOTES - 编码双引号和单引号。
  • ENT_NOQUOTES - 不编码任何引号。
character-set

可选。字符串值，规定要使用的字符集。

  • ISO-8859-1 - 默认。西欧。
  • ISO-8859-15 - 西欧（增加 Euro 符号以及法语、芬兰语字母）。
  • UTF-8 - ASCII 兼容多字节 8 比特 Unicode
  • cp866 - DOS 专用 Cyrillic 字符集
  • cp1251 - Windows 专用 Cyrillic 字符集
  • cp1252 - Windows 专用西欧字符集
  • KOI8-R - 俄语
  • GB2312 - 简体中文，国家标准字符集
  • BIG5 - 繁体中文
  • BIG5-HKSCS - Big5 香港扩展
  • Shift_JIS - 日语
  • EUC-JP - 日语

提示和注释

提示：无法被识别的字符集将被忽略，并由 ISO-8859-1 代替。

例子

<html>
<body>
<?php
$str = "John & 'Adams'";
echo htmlentities($str, ENT_COMPAT);
echo "<br />";
echo htmlentities($str, ENT_QUOTES);
echo "<br />";
echo htmlentities($str, ENT_NOQUOTES);
?>
</body>
</html>

浏览器输出：

John & 'Adams'
John & 'Adams'
John & 'Adams'

如果在浏览器中查看源代码，会看到这些 HTML：

<html>
<body>
John &amp; 'Adams'<br />
John &amp; &#039;Adams&#039;<br />
John &amp; 'Adams'
</body>
</html>

PHP String 函数

PHP 参考手册
PHP 测验


PHP htmlspecialchars() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP htmlspecialchars() 函数

PHP String 函数

定义和用法

htmlspecialchars() 函数把一些预定义的字符转换为 HTML 实体。

预定义的字符是：

  • & （和号） 成为 &amp;
  • " （双引号） 成为 &quot;
  • ' （单引号） 成为 &#039;
  • < （小于） 成为 &lt;
  • > （大于） 成为 &gt;

语法

htmlspecialchars(string,quotestyle,character-set)
参数 | 描述
string | 必需。规定要转换的字符串。
quotestyle

可选。规定如何编码单引号和双引号。

  • ENT_COMPAT - 默认。仅编码双引号。
  • ENT_QUOTES - 编码双引号和单引号。
  • ENT_NOQUOTES - 不编码任何引号。
character-set

可选。字符串值，规定要使用的字符集。

  • ISO-8859-1 - 默认。西欧。
  • ISO-8859-15 - 西欧（增加 Euro 符号以及法语、芬兰语字母）。
  • UTF-8 - ASCII 兼容多字节 8 比特 Unicode
  • cp866 - DOS 专用 Cyrillic 字符集
  • cp1251 - Windows 专用 Cyrillic 字符集
  • cp1252 - Windows 专用西欧字符集
  • KOI8-R - 俄语
  • GB2312 - 简体中文，国家标准字符集
  • BIG5 - 繁体中文
  • BIG5-HKSCS - Big5 香港扩展
  • Shift_JIS - 日语
  • EUC-JP - 日语

提示和注释

提示：无法被识别的字符集将被忽略，并由 ISO-8859-1 代替。

例子

<html>
<body>
<?php
$str = "John & 'Adams'";
echo htmlspecialchars($str, ENT_COMPAT);
echo "<br />";
echo htmlspecialchars($str, ENT_QUOTES);
echo "<br />";
echo htmlspecialchars($str, ENT_NOQUOTES);
?>
</body>
</html>

浏览器输出：

John & 'Adams'
John & 'Adams'
John & 'Adams'

如果在浏览器中查看源代码，会看到这些 HTML：

<html>
<body>
John &amp; 'Adams'<br />
John &amp; &#039;Adams&#039;<br />
John &amp; 'Adams'
</body>
</html>

PHP String 函数

PHP 参考手册
PHP 测验


PHP HTTP 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP HTTP 函数

  • Previous Page
  • Next Page

PHP HTTP 简介

HTTP 函数允许您在其他输出被发送之前，对由 web 服务器发送到浏览器的信息进行操作。

安装

HTTP 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP HTTP 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
header() | 向客户端发送原始的 HTTP 报头。 | 3
headers_list() | 返回已发送的（或待发送的）响应头部的一个列表。 | 5
headers_sent() | 检查 HTTP 报头是否发送/已发送到何处。 | 3
setcookie() | 向客户端发送一个 HTTP cookie。 | 3
setrawcookie() | 不对 cookie 值进行 URL 编码，发送一个 HTTP cookie。 | 5
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP hypot() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP hypot() 函数

PHP Math 函数

定义和用法

hypot() 函数计算一直角三角形的斜边长度。

语法

hypot(x,y)
参数 | 描述
x | 必需。边 x 的长度。
y | 必需。边 y 的长度。

说明

hypot() 函数将会跟据直角三角形的两直解边长度 x 和 y 计算其斜边的长度。或者是从标点 (x , y) 到原点的距离。该函数的算法等同于 sqrt(x*x + y*y)。

例子

<?php
echo hypot(2,3);
echo hypot(3,6);
echo hypot(3,6);
echo hypot(1,3);
?>

输出：

3.60555127546
6.7082039325
6.7082039325
3.16227766017

PHP Math 函数

PHP 参考手册
PHP 测验


PHP idate() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP idate() 函数

PHP Date / Time 函数

定义和用法

idate() 函数将本地时间/日期格式化为整数。

语法

strftime(format,timestamp)
参数 | 描述
format | 可选。规定如何返回结果。
timestamp | 可选。

说明

根据给定的格式字符对 timestamp 进行格式化，并返回数字结果。

timestamp 为可选项，默认值为本地当前时间，即 time() 的值。

提示和注释

注释：与 date() 不同，idate() 只接受一个字符作为 format 参数。

format 参数可识别以下字符

format 字符 | 描述
B | Swatch Beat/Internet Time
d | 月份中的第几天
h | 小时（12 小时格式）
H | 小时（24 小时格式）
i | 分钟
I | 如果启用夏时制则返回 1，否则返回 0
L | 如果是闰年则返回 1，否则返回 0
m | 月份的数字
s | 秒数
t | 本月的总天数
U | 自 Unix 纪元（January 1 1970 00:00:00 GMT）起的秒数――这和 time() 作用相同
w | 星期中的第几天（星期天是 0）
W | ISO-8601 格式年份中的第几个星期，每星期从星期一开始
y | 年份（1 或 2 位数字――见下面说明）
Y | 年份（4 位数字）
z | 年份中的第几天
Z | 以秒为单位的时区偏移量

例子

<?php
echo(idate("Y"));
?>

输出：

2008

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP ignore_user_abort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ignore_user_abort() 函数

PHP 杂项函数

定义和用法

ignore_user_abort() 函数设置与客户机断开是否会终止脚本的执行。

本函数返回 user-abort 设置的之前的值（一个布尔值）。

语法

ignore_user_abort(setting)
参数 | 描述
setting | 可选。如果设置为 true，则忽略与用户的断开，如果设置为 false，会导致脚本停止运行。 如果未设置该参数，会返回当前的设置。

提示和注释

注释：PHP 不会检测到用户是否已断开连接，直到尝试向客户机发送信息为止。简单地使用 echo 语句无法确保信息发送，参阅 flush() 函数。

例子

<?php
ignore_user_abort();
?>

输出：

0

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP implode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP implode() 函数

PHP String 函数

定义和用法

implode() 函数把数组元素组合为一个字符串。

语法

implode(separator,array)
参数 | 描述
separator | 可选。规定数组元素之间放置的内容。默认是 ""（空字符串）。
array | 必需。要结合为字符串的数组。

说明

虽然 separator 参数是可选的。但是为了向后兼容，推荐您使用使用两个参数。

提示和注释

注释：implode() 可以接收两种参数顺序。但是由于历史原因，explode() 是不行的。你必须保证 separator 参数在 string 参数之前才行。

例子

<?php
$arr = array('Hello','World!','Beautiful','Day!');
echo implode(" ",$arr);
?>

输出：

Hello World! Beautiful Day!

PHP String 函数

PHP 参考手册
PHP 测验


PHP in_array() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP in_array() 函数

PHP Array 函数

定义和用法

in_array() 函数在数组中搜索给定的值。

语法

in_array(value,array,type)
参数 | 描述
value | 必需。规定要在数组搜索的值。
array | 必需。规定要搜索的数组。
type | 可选。如果设置该参数为 true，则检查搜索的数据与数组的值的类型是否相同。

说明

如果给定的值 value 存在于数组 array 中则返回 true。如果第三个参数设置为 true，函数只有在元素存在于数组中且数据类型与给定值相同时才返回 true。

如果没有在数组中找到参数，函数返回 false。

注释：如果 value 参数是字符串，且 type 参数设置为 true，则搜索区分大小写。

例子 1

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

if (in_array("Glenn",$people))
  {
  echo "Match found";
  }
else
  {
  echo "Match not found";
  }
?>

输出：

Match found

例子 2

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland", 23);

if (in_array("23",$people, TRUE))
  {
  echo "Match found<br />";
  }
else
  {
  echo "Match not found<br />";
  }if (in_array("Glenn",$people, TRUE))
  {
  echo "Match found<br />";
  }
else
  {
  echo "Match not found<br />";
  }if (in_array(23,$people, TRUE))
  {
  echo "Match found<br />";
  }
else
  {
  echo "Match not found<br />";
  }
?>

输出：

Match not found
Match found
Match not found

PHP Array 函数

PHP 参考手册
PHP 测验


PHP is_dir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_dir() 函数

PHP Filesystem 函数

定义和用法

is_dir() 函数检查指定的文件是否是目录。

语法

is_dir(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果文件名存在并且为目录，则返回 true。如果 file 是一个相对路径，则按照当前工作目录检查其相对路径。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$file = "images";
if(is_dir($file))
  {
  echo ("$file is a directory");
  }
else
  {
  echo ("$file is not a directory");
  }
?>

输出：

images is a directory

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_executable() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_executable() 函数

PHP Filesystem 函数

定义和用法

is_executable() 函数检查指定的文件是否可执行。

语法

is_executable(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果文件存在且可执行，则返回 true。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

注释：is_executable() 自 PHP 5.0.0 版起可用于 Windows。

例子

<?php
$file = "setup.exe";
if(is_executable($file))
  {
  echo ("$file is executable");
  }
else
  {
  echo ("$file is not executable");
  }
?>

输出：

setup.exe is executable

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_file() 函数

PHP Filesystem 函数

定义和用法

is_file() 函数检查指定的文件名是否是正常的文件。

语法

is_file(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果文件存在且为正常的文件，则返回 true。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

例子 1

<?php
$file = "test.txt";
if(is_file($file))
  {
  echo ("$file is a regular file");
  }
else
  {
  echo ("$file is not a regular file");
  }
?>

输出：

test.txt is a regular file

例子 2

<?php
var_dump(is_file('a_file.txt')) . "\n";
var_dump(is_file('/usr/bin/')) . "\n";
?>

输出：

bool(true)
bool(false)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_finite() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_finite() 函数

PHP Math 函数

定义和用法

is_finite() 函数判断是否为有限值。

语法

is_finite(x)
参数 | 描述
x | 必需。规定要检查的值。

说明

如果 x 是本机平台上 PHP 浮点数所允许范围中的一个合法的有限值，则返回 true。

例子

<?php
echo is_finite(2);
echo is_finite(log(0));
echo is_finite(2000);
?>

输出：

1

1

PHP Math 函数

PHP 参考手册
PHP 测验


PHP is_infinite() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_infinite() 函数

PHP Math 函数

定义和用法

is_infinite() 判断是否为无限值。

语法

is_infinite(x)
参数 | 描述
x | 必需。规定要检查的值。

说明

如果 x 为无穷大（正的或负的），例如 log(0) 的结果或者任何超出本平台的浮点数范围的值，则返回 true。

例子

<?php
echo is_infinite(2);
echo is_infinite(log(0));
echo is_infinite(2000);
?>

输出：

1

PHP Math 函数

PHP 参考手册
PHP 测验


PHP is_link() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_link() 函数

PHP Filesystem 函数

定义和用法

is_link() 函数判断指定文件名是否为一个符号连接。

语法

is_link(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果文件存在并且是一个符号连接，则返回 true。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$link = "images";
if(is_link($link))
  {
  echo ("$link is a link");
  }
else
  {
  echo ("$link is not a link");
  }
?>

输出：

images is not a link

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_nan() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_nan() 函数

PHP Math 函数

定义和用法

is_nan() 判断是否为合法数值。

语法

is_nan(x)
参数 | 描述
x | 必需。规定要检查的值。

说明

如果 x 为“非数值”，例如 acos(1.01) 的结果，则返回 true。

例子

<?php
echo is_nan(200);
echo is_nan(acos(1.01));
?>

输出：

1

PHP Math 函数

PHP 参考手册
PHP 测验


PHP is_readable() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_readable() 函数

PHP Filesystem 函数

定义和用法

is_readable() 函数判断指定文件名是否可读。

语法

is_readable(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果由 file 指定的文件或目录存在并且可读，则返回 TRUE。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$file = "test.txt";
if(is_readable($file))
  {
  echo ("$file is readable");
  }
else
  {
  echo ("$file is not readable");
  }
?>

输出：

test.txt is readable

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_uploaded_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_uploaded_file() 函数

PHP Filesystem 函数

定义和用法

is_uploaded_file() 函数判断指定的文件是否是通过 HTTP POST 上传的。

语法

is_uploaded_file(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果 file 所给出的文件是通过 HTTP POST 上传的则返回 TRUE。

该函数可以用于确保恶意的用户无法欺骗脚本去访问本不能访问的文件，例如 /etc/passwd。

这种检查显得格外重要，如果上传的文件有可能会造成对用户或本系统的其他用户显示其内容的话。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$file = "test.txt";
if(is_uploaded_file($file))
  {
  echo ("$file is uploaded via HTTP POST");
  }
else
  {
  echo ("$file is not uploaded via HTTP POST");
  }
?>

输出：

test.txt is not uploaded via HTTP POST

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_writable() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_writable() 函数

PHP Filesystem 函数

定义和用法

is_writable() 函数判断指定的文件是否可写。

语法

is_writable(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果文件存在并且可写则返回 true。file 参数可以是一个允许进行是否可写检查的目录名。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$file = "test.txt";
if(is_writable($file))
  {
  echo ("$file is writeable");
  }
else
  {
  echo ("$file is not writeable");
  }
?>

输出：

test.txt is writeable

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_writeable() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_writeable() 函数

PHP Filesystem 函数

定义和用法

is_writeable() 函数判断指定的文件是否可写。

该函数是 is_writable() 函数的别名。

语法

is_writeable(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果文件存在并且可写则返回 true。file 参数可以是一个允许进行是否可写检查的目录名。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$file = "test.txt";
if(is_writeable($file))
  {
  echo ("$file is writeable");
  }
else
  {
  echo ("$file is not writeable");
  }
?>

输出：

test.txt is writeable

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP JDDayOfWeek() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDDayOfWeek() 函数

PHP Array 函数

定义和用法

JDDayOfWeek() 函数返回日期在周几。

语法

jddayofweek(jd,mode)
参数 | 描述
jd | 必需。数字（儒略日计数）。
mode

可选。定义返回的内容（数字还是字符串）。模式值：

  • 0 - 默认。以整数返回周的天。（0 为周日, 1 为周一... 余类推）
  • 1 - 返回包含周的天的字符串。（英文-格里高里历）
  • 2 - 返回包含周的天的简写的字符串。（英文-格里高里历）

例子

<?php
$jd=cal_to_jd(CAL_GREGORIAN,date("m"),date("d"),date("Y"));
echo(jddayofweek($jd,1));
?>

输出：

Thursday

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JDMonthName() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDMonthName() 函数

PHP Array 函数

定义和用法

JDMonthName() 函数返回指定历法的月份字符串。

语法

jdmonthname(jd,mode)
参数 | 描述
jd | 必需。数字（儒略日计数）。
mode

可选。定义把儒略日计数转换为哪种历法，以及返回哪种月份名称。模式值：

  • 0 - 格里高里历 (缩写) (Jan, Feb, Mar, ...)
  • 1 - 格里高里历 (January, February, March, ...)
  • 2 - 凯撒历 (缩写) (Jan, Feb, Mar, ...)
  • 3 - 凯撒历 (January, February, March, ...)
  • 4 - 犹太历 (Tishri, Heshvan, Kislev, ...)
  • 5 - 法国共和历 (Vendemiaire, Brumaire, Frimaire, ...)

例子

<?php
$jd=cal_to_jd(CAL_GREGORIAN,date("m"),date("d"),date("Y"));
echo(jdmonthname($jd,1));
?>

输出：

January

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JDToFrench() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDToFrench() 函数

PHP Array 函数

定义和用法

JDToFrench() 函数把儒略日计数转换为法国共和国历法。

语法

jdtofrench(jd)
参数 | 描述
jd | 必需。数字（儒略日计数）。

提示和注释：

注释：该函数以 "month/day/year" 的格式返回一个字符串。

提示：法国共和历法是法国革命期间提出的一种历法，从 1793 年晚期开始，法国政府使用了大约 12 年。

例子

<?php
$d=jdtofrench(2380650);
echo($d);
?>

输出：

3/3/14

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JDToGregorian() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDToGregorian() 函数

PHP Array 函数

定义和用法

JDToGregorian() 函数把儒略日计数转换为格利高里历法。

语法

jdtogregorian(jd)
参数 | 描述
jd | 必需。数字（儒略日计数）。

提示和注释：

注释：该函数以 "month/day/year" 的格式返回一个字符串。

例子

<?php
$jd = gregoriantojd(10,3,1975);
echo($jd . "<br />");

$gregorian = jdtogregorian($jd);
echo($gregorian);
?>

输出：

2442689
10/3/1975

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JDToGregorian() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDToJewish() 函数

PHP Array 函数

定义和用法

JDToJewish() 函数把儒略日计数转换为犹太历法

语法

JDToJewish(jd)
参数 | 描述
jd | 必需。数字（儒略日计数）。
hebrew | 可选。True 指示希伯来语输出格式。
fl

可选。定义希伯来语输出格式，可用的格式有：

  • CAL_JEWISH_ADD_ALAFIM_GERESH
  • CAL_JEWISH_ADD_ALAFIM
  • CAL_JEWISH_ADD_GERESHAYIM

例子

<?php
echo(jdtojewish(gregoriantojd(10,8,2002)));
?>

输出：

2/2/5763

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JDToGregorian() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDToJulian() 函数

PHP Array 函数

定义和用法

JDToJulian() 函数把儒略日计数转换为儒略历。

语法

JDToJulian(jd)
参数 | 描述
jd | 必需。数字（儒略日计数）。

提示和注释：

注释：该函数以 "month/day/year" 的格式返回一个字符串。

例子

<?php
$jd = juliantojd(10,3,1975);
echo($jd . "<br />");

$julian = jdtojulian($jd);
echo($julian);
?>

输出：

2442702
10/3/1975

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JDToUnix() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDToUnix() 函数

PHP Array 函数

定义和用法

JDToUnix() 函数把儒略日计数转换为 Unix 时间戳。

语法

JDToUnix(jd)
参数 | 描述
jd | 必需。数字（儒略日计数）。

提示和注释：

注释：如果参数 jd 不在 Unix 新纪元之中（意味着格利高里年必须介于 1970 和 2037 之间，或者 jd >= 2440588 且 jd <= 2465342），则该函数将返回 false。所返回的时间是本地时间。

例子

<?php
$jd = gregoriantojd(10,3,1970);
$unix = jdtounix($jd);
echo($unix);
?>

输出：

23760000

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JewishToJD() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JewishToJD() 函数

PHP Array 函数

定义和用法

JewishToJD() 函数把犹太历法转换为儒略日计数。

语法

JDToUnix(jd)
参数 | 描述
month | 必需。规定月。
day | 必需。规定日。
year | 必需。规定年。

提示和注释：

注释：有效的范围为犹太历法公元前 3761 年起。犹太历法存在了数千年，但早期并没有公式化的开始月份计算法。每年的第一个月为首次观测到的新月。

例子

<?php
echo(jewishtojd(2,2,5763));
?>

输出：

2452556

PHP Array 函数

PHP 参考手册
PHP 测验


PHP join() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP join() 函数

PHP String 函数

定义和用法

join() 函数把数组元素组合为一个字符串。

join() 函数是 implode() 函数的别名。

语法

join(separator,array)
参数 | 描述
separator | 可选。规定数组元素之间放置的内容。默认是 ""（空字符串）。
array | 必需。要结合为字符串的数组。

说明

虽然 separator 参数是可选的。但是为了向后兼容，推荐您使用使用两个参数。

提示和注释

注释：join() 可以接收两种参数顺序。但是由于历史原因，explode() 是不行的。你必须保证 separator 参数在 string 参数之前才行。

例子

<?php
$arr = array('Hello','World!','Beautiful','Day!');
echo join(" ",$arr);
?>

输出：

Hello World! Beautiful Day!

PHP String 函数

PHP 参考手册
PHP 测验


PHP JulianToJD() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JulianToJD() 函数

PHP Array 函数

定义和用法

JulianToJD() 函数把儒略历转换为儒略日计数。

语法

JDToUnix(jd)
参数 | 描述
month | 必需。规定月。
day | 必需。规定日。
year | 必需。规定年。合法的范围是 4713 B.C. 到 9999 A.D。

提示和注释：

注释：有效的范围为凯撒历法公元前 4713 年至公元 9999 年。该函数能计算到公元前 4713 年，但这是不太有意义的。凯撒历法是在公元前 46 年建立的，但一些细节等到公元 8 年才稳定下来。

例子

<?php
$jd = juliantojd(10,3,1975);
echo($jd . "<br />");

$julian = jdtojulian($jd);
echo($julian);
?>

输出：

2442702
10/3/1975

PHP Array 函数

PHP 参考手册
PHP 测验


PHP key() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP key() 函数

PHP Array 函数

定义和用法

key() 函数返回数组内部指针当前指向元素的键名。

若失败，则返回 FALSE。

该函数与 current() 类似，只是返回的结果不同。current() 函数返回的是元素的值，而 key() 函数返回的是元素的键名。

语法

key(array)
参数 | 描述
array | 必需。规定要使用的数组。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");
echo "The key from the current position is: " . key($people);
?>

输出：

The key from the current position is: 0

PHP Array 函数

PHP 参考手册
PHP 测验


PHP krsort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP krsort() 函数

PHP Array 函数

定义和用法

krsort() 函数将数组按照键逆向排序，为数组值保留原来的键。

可选的第二个参数包含附加的排序标志。

若成功，则返回 TRUE，否则返回 FALSE。

语法

krsort(array,sorttype)
参数 | 描述
array | 必需。规定要排序的数组。
sorttype

可选。规定如何排列数组的值。可能的值：

  • SORT_REGULAR - 默认。以它们原来的类型进行处理（不改变类型）。
  • SORT_NUMERIC - 把值作为数字来处理
  • SORT_STRING - 把值作为字符串来处理
  • SORT_LOCALE_STRING - 把值作为字符串来处理，基于本地设置*。

*：该值是 PHP 4.4.0 和 5.0.2 新加的。在 PHP 6 之前，使用了系统的区域设置，可以用 setlocale() 来改变。自 PHP 6 起，必须用 i18n_loc_set_default() 函数。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");
krsort($my_array);
print_r($my_array);
?>

输出：

Array
(
[c] => Horse
[b] => Cat
[a] => Dog
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP ksort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ksort() 函数

PHP Array 函数

定义和用法

ksort() 函数按照键名对数组排序，为数组值保留原来的键。

可选的第二个参数包含附加的排序标志。

若成功，则返回 TRUE，否则返回 FALSE。

语法

ksort(array,sorttype)
参数 | 描述
array | 必需。规定要排序的数组。
sorttype

可选。规定如何排列数组的值。可能的值：

  • SORT_REGULAR - 默认。以它们原来的类型进行处理（不改变类型）。
  • SORT_NUMERIC - 把值作为数字来处理
  • SORT_STRING - 把值作为字符串来处理
  • SORT_LOCALE_STRING - 把值作为字符串来处理，基于本地设置*。

*：该值是 PHP 4.4.0 和 5.0.2 新加的。在 PHP 6 之前，使用了系统的区域设置，可以用 setlocale() 来改变。自 PHP 6 起，必须用 i18n_loc_set_default() 函数。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");
ksort($my_array);
print_r($my_array);
?>

输出：

Array
(
[a] => Dog
[b] => Cat
[c] => Horse
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP lcg_value() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP lcg_value() 函数

PHP Math 函数

定义和用法

lcg_value() 组合线性同余发生器。

语法

lcg_value()

说明

lcg_value() 返回范围为 (0, 1) 的一个伪随机数。本函数组合了周期为 2^31 - 85 和 2^31 - 249 的两个同余发生器。本函数的周期等于这两个素数的乘积。

例子

<?php
echo lcg_value();
?>

输出类似：

0.508212039328

PHP Math 函数

PHP 参考手册
PHP 测验


PHP levenshtein() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP levenshtein() 函数

PHP String 函数

定义和用法

levenshtein() 函数返回两个字符串之间的 Levenshtein 距离。

Levenshtein 距离，又称编辑距离，指的是两个字符串之间，由一个转换成另一个所需的最少编辑操作次数。许可的编辑操作包括将一个字符替换成另一个字符，插入一个字符，删除一个字符。

例如把 kitten 转换为 sitting：

  1. sitten （k→s）
  2. sittin （e→i）
  3. sitting （→g）

levenshtein() 函数给每个操作（替换、插入和删除）相同的权重。不过，您可以通过设置可选的 insert、replace、delete 参数，来定义每个操作的代价。

语法

levenshtein(string1,string2,insert,replace,delete)
参数 | 描述
string1 | 必需。要对比的第一个字符串。
string2 | 必需。要对比的第二个字符串。
insert | 可选。插入一个字符的代价。默认是 1。
replace | 可选。替换一个字符的代价。默认是 1。
delete | 可选。删除一个字符的代价。默认是 1。

提示和注释

注释：如果其中一个字符串超过 255 个字符，levenshtein() 函数返回 -1。

注释：levenshtein() 函数对大小写不敏感。

注释：levenshtein() 函数比 similar_text() 函数更快。不过，similar_text() 函数提供需要更少修改的更精确的结果。

例子

<?php
echo levenshtein("Hello World","ello World");
echo "<br />";
echo levenshtein("Hello World","ello World",10,20,30);
?>

输出：

1
30

PHP String 函数

PHP 参考手册
PHP 测验


PHP libxml_clear_errors() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP libxml_clear_errors() 函数

PHP libxml 函数

定义和用法

libxml_clear_errors() 函数清空 libxml 错误缓冲。

语法

libxml_clear_errors()

例子

<?php
libxml_clear_errors()
?>

PHP libxml 函数

PHP 参考手册
PHP 测验


PHP libxml_get_errors() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP libxml_get_errors() 函数

PHP libxml 函数

定义和用法

libxml_get_errors() 函数从 libxml 错误缓冲中获取错误。

该函数返回错误对象的一个数组，如果 libxml 错误缓冲中没有错误，则返回一个空数组。

语法

libxml_get_errors()

例子

<?php
libxml_get_errors()
?>

PHP libxml 函数

PHP 参考手册
PHP 测验


PHP libxml_get_last_error() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP libxml_get_last_error() 函数

PHP libxml 函数

定义和用法

libxml_get_last_error() 函数从 libxml 错误缓冲中获取最后一个错误。

若成功，则返回一个错误对象。若失败，或 libxml 错误缓冲中没有错误，则返回 false。

语法

libxml_get_last_error()

例子

<?php
libxml_get_last_error()
?>

PHP libxml 函数

PHP 参考手册
PHP 测验


PHP libxml_use_internal_errors() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP libxml_use_internal_errors() 函数

PHP libxml 函数

定义和用法

libxml_use_internal_errors() 函数禁用标准的 libxml 错误，并启用用户错误处理。

语法

libxml_use_internal_errors(user_errors)
参数 | 描述
user_errors | 可选。规定是否应该启用用户错误处理。默认是 false。

说明

该函数返回 user_errors 参数之前的值。

例子

<?php
libxml_use_internal_errors()
?>

PHP libxml 函数

PHP 参考手册
PHP 测验


PHP libxml 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP libxml 函数

  • Previous Page
  • Next Page

PHP libxml 简介

libxml 函数和常量与 SimpleXML, XSLT 以及 DOM 一起使用。

安装

这些函数需要 libxml 程序包。在 xmlsoft.org 下载。

PHP libxml 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
libxml_clear_errors() | 清空 libxml 错误缓冲。 | 5
libxml_get_errors() | 检索错误数组。 | 5
libxml_get_last_error() | 从 libxml 检索最后的错误。 | 5
libxml_set_streams_context() | 为下一次 libxml 文档加载或写入设置流环境。 | 5
libxml_use_internal_errors() | 禁用 libxml 错误，允许用户按需读取错误信息。 | 5

PHP libxml 常量

函数 | 描述 | PHP
LIBXML_COMPACT | 设置小型节点分配优化。会改善应用程序的性能。 | 5
LIBXML_DTDATTR | 设置默认 DTD 属性。 | 5
LIBXML_DTDLOAD | 加载外部子集。 | 5
LIBXML_DTDVALID | 通过 DTD 进行验证。 | 5
LIBXML_NOBLANKS | 删除空节点。 | 5
LIBXML_NOCDATA | 把 CDATA 设置为文本节点。 | 5
LIBXML_NOEMPTYTAG | 更改空标签（比如 <br/> 改为 <br></br>）。 仅在 DOMDocument->save() 和 DOMDocument->saveXML() 函数中可用。 | 5
LIBXML_NOENT | 替代实体。 | 5
LIBXML_NOERROR | 不显示错误报告。 | 5
LIBXML_NONET | 在加载文档时停止网络访问。 | 5
LIBXML_NOWARNING | 不显示警告报告。 | 5
LIBXML_NOXMLDECL | 在保存文档时，撤销 XML 声明。 | 5
LIBXML_NSCLEAN | 删除额外的命名空间声明。 | 5
LIBXML_XINCLUDE | 使用 XInclude 置换。 | 5
LIBXML_ERR_ERROR | 获得可恢复的错误。 | 5
LIBXML_ERR_FATAL | 获得致命错误。 | 5
LIBXML_ERR_NONE | 获得无错误。 | 5
LIBXML_ERR_WARNING | 获得简单警告。 | 5
LIBXML_VERSION | 获得 libxml 版本（例如：20605 或 20617）。 | 5
LIBXML_DOTTED_VERSION | 获得有点号的 libxml 版本（例如：2.6.5 或 2.6.17）。 | 5
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP link() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP link() 函数

PHP Filesystem 函数

定义和用法

link() 函数建立一个硬连接。

如果成功，则返回 true，失败则返回 false。

提示：创建的连接不是 HTML 链接，而是文件系统中的连接。

语法

link(target,link)
参数 | 描述
target | 必需。
link | 必需。

提示和注释

注释：本函数不能作用于远程文件，被检查的文件必须通过服务器的文件系统访问。

注释：本函数不能工作在 windows 平台上。

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP linkinfo() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP linkinfo() 函数

PHP Filesystem 函数

定义和用法

linkinfo() 函数返回连接的信息。

本函数返回设备 ID。若出错，则返回 0 或 FALSE。

语法

linkinfo(path)
参数 | 描述
path | 必需。规定要检查的路径

提示和注释

注释：本函数不能工作在 windows 平台上。

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP list() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP list() 函数

PHP Array 函数

定义和用法

list() 函数用数组中的元素为一组变量赋值。

注意，与 array() 类似，list() 实际上是一种语言结构，不是函数。

语法

list(var1,var2...)
参数 | 描述
var1 | 必需。第一个需要赋值的变量。
var2 | 可选。可以有多个变量。

提示和注释

注释：该函数只用于数字索引的数组，且假定数字索引从 0 开始。

例子 1

<?php
$my_array = array("Dog","Cat","Horse");

list($a, $b, $c) = $my_array;
echo "I have several animals, a $a, a $b and a $c.";
?>

输出：

I have several animals, a Dog, a Cat and a Horse.

例子 2

<?php
$my_array = array("Dog","Cat","Horse");

list($a, , $c) = $my_array;
echo "Here I only use the $a and $c variables.";
?>

输出：

Here I only use the Dog and Horse variables.

PHP Array 函数

PHP 参考手册
PHP 测验


PHP localeconv() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP localeconv() 函数

PHP String 函数

定义和用法

localeconv() 函数返回包含本地数字及货币信息格式的数组。

localeconv() 函数返回以下数组元素：

  • [decimal_point] - 小数点字符
  • [thousands_sep] - 千位分隔符
  • [int_curr_symbol] - 货币符号 （例如：USD）
  • [currency_symbol] - 货币符号 （例如：$）
  • [mon_decimal_point] - 货币小数点符号
  • [mon_thousands_sep] - 货币千位分隔符
  • [positive_sign] - 正值符号
  • [negative_sign] - 负值符号
  • [int_frac_digits] - 国际小数数字
  • [frac_digits] - 本地小数数字
  • [p_cs_precedes] - if 如果货币符号在正值之前，则是 True (1)，否则是 False (0)。
  • [p_sep_by_space] - True (1) 如果货币符号与正值之间有空间，则是 True (1)，否则是 False (0)。
  • [n_cs_precedes] - True (1) if 货币符号在负值之前，则是 True (1)，否则是 False (0)。
  • [p_sep_by_space] - True (1) 如果货币符号与负值之间有空间，则是 True (1)，否则是 False (0)。
  • [p_sign_posn] - 格式化选项：
    • 0 - 在数量和货币符号周围的圆括号
    • 1 - 数量和货币符号之前的 + 号
    • 2 - 数量和货币符号之后的 + 号
    • 3 - 货币符号之前的 + 号
    • 4 - 货币符号之后的 + 号
  • [n_sign_posn] - 格式化选项：
    • 0 - 在数量和货币符号周围的圆括号
    • 1 - 数量和货币符号之前的 - 号
    • 2 - 数量和货币符号之后的 - 号
    • 3 - 货币符号之前的 - 号
    • 4 - 货币符号之后的 - 号
  • [grouping] - 显示如何分组数字的 Array（例如：3 指示 1 000 000）
  • [mon_grouping] - 显示如何分组货币数字的 Array（例如：2 指示 1 00 00 00）

语法

localeconv()

提示和注释

提示：如需定义本地设置，请使用 setlocale() 函数。

例子

在本例中，我们将获得美国本地的数字格式化信息：

<?php
setlocale(LC_ALL, 'US');
$locale_info = localeconv();
print_r($locale_info);
?>

输出：

Array
(
[decimal_point] => .
[thousands_sep] => ,
[int_curr_symbol] => USD
[currency_symbol] => $
[mon_decimal_point] => .
[mon_thousands_sep] => ,
[positive_sign] =>
[negative_sign] => -
[int_frac_digits] => 2
[frac_digits] => 2
[p_cs_precedes] => 1
[p_sep_by_space] => 0
[n_cs_precedes] => 1
[n_sep_by_space] => 0
[p_sign_posn] => 3
[n_sign_posn] => 0
[grouping] => Array ([0] => 3)
[mon_grouping] => Array ([0] => 3)
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP localtime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP localtime() 函数

PHP Date / Time 函数

定义和用法

localtime() 函数返回本地时间（一个数组）。

localtime() 的第一个参数是时间戳，如果没有给出则使用从 time() 返回的当前时间。

第二个参数是 is_associative，如果设为 false 或未提供则返回的是普通的数字索引数组。如果该参数设为 true 则 localtime() 函数返回一个关联数组。

关联数组中不同的键名是：

  • "tm_sec" - 秒数
  • "tm_min" - 分钟数
  • "tm_hour" - 小时
  • "tm_mday" - 月份中的第几日
  • "tm_mon" - 年份中的第几个月，从 0 开始表示一月
  • "tm_year" - 年份，从 1900 开始
  • "tm_wday" - 星期中的第几天
  • "tm_yday" - 一年中的第几天
  • "tm_isdst" - 夏令时当前是否生效

注释：月份从 0（一月）到 11（十二月），星期数从 0（星期天）到 6（星期六）。

语法

localtime(timestamp,is_associative)
参数 | 描述
timestamp | 可选。规定被格式化的日期或时间。若未规定 timestamp，则使用当前的本地时间。
is_associative | 可选。规定返回索引数组还是关联数组。

例子

<?php
$localtime = localtime();
$localtime_assoc = localtime(time(), true);
print_r($localtime);
print_r($localtime_assoc);
?>

输出：

Array
(
    [0] => 24
    [1] => 3
    [2] => 19
    [3] => 3
    [4] => 3
    [5] => 105
    [6] => 0
    [7] => 92
    [9] => 1
)

Array
(
    [tm_sec] => 24
    [tm_min] => 3
    [tm_hour] => 19
    [tm_mday] => 3
    [tm_mon] => 3
    [tm_year] => 105
    [tm_wday] => 0
    [tm_yday] => 92
    [tm_isdst] => 1
)

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP log() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP log() 函数

PHP Math 函数

定义和用法

log() 返回自然对数。

语法

log(x,base)
参数 | 描述
x | 必需。一个数。
base | 可选。如果规定了该参数，则返回 logbasex。

说明

如果指定了可选的参数 base，log() 返回 logbasex ，否则 log() 返回参数 x 的自然对数。

注释：参数 base 自 PHP 4.3.0 开始可用。你可以计算任意以 b 为底 n 的对数，但其实使用的是数学等式：logb(n) = log(n)/log(b)，其中 log 是自然对数。

例子

<?php
echo lcg_value();
?>

输出类似：

0.508212039328

PHP Math 函数

PHP 参考手册
PHP 测验


PHP log10() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP log10() 函数

PHP Math 函数

定义和用法

log10() 以 10 为底的对数。

语法

log10(x)
参数 | 描述
x | 必需。一个数。

说明

返回参数 x 以 10 为底的对数。

提示和注释：

注释：如果参数 x 是负数，则返回 -1.#IND。

例子

在本例中，我们对不同的数应用 log10() 函数：

<?php
echo(log10(2.7183));
echo(log10(2));
echo(log10(1));
echo(log10(0));
echo(log10(-1));
?>

输出类似：

0.434297385125
0.301029995664
0
-1.#INF
-1.#IND

PHP Math 函数

PHP 参考手册
PHP 测验


PHP log1p() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP log1p() 函数

PHP Math 函数

定义和用法

log1p() 以返回 log(1 + x)，甚至当 x 的值接近零也能计算出准确结果。

语法

log1p(x)
参数 | 描述
x | 必需。一个数。

说明

警告：本函数是实验性的。本函数的行为，包括函数名称以及其它任何关于本函数的文档可能会在没有通知的情况下随 PHP 以后的发布而改变。使用本函数风险自担。

PHP Math 函数

PHP 参考手册
PHP 测验


PHP lstat() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP lstat() 函数

PHP Filesystem 函数

定义和用法

lstat() 函数返回关于文件或符号连接的信息。

语法

lstat(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

获取由 file 参数指定的文件或符号连接的统计信息。

lstat() 的返回格式

数字下标 | 关联键名（自 PHP 4.0.6） | 说明
0 | dev | 设备名
1 | ino | 号码
2 | mode | inode 保护模式
3 | nlink | 被连接数目
4 | uid | 所有者的用户 id
5 | gid | 所有者的组 id
6 | rdev | 设备类型，如果是 inode 设备的话
7 | size | 文件大小的字节数
8 | atime | 上次访问时间（Unix 时间戳）
9 | mtime | 上次修改时间（Unix 时间戳）
10 | ctime | 上次改变时间（Unix 时间戳）
11 | blksize | 文件系统 IO 的块大小
12 | blocks | 所占据块的数目

提示和注释

提示：本函数与 stat() 函数相同，不同之处只有一点：如果 file 参数是符号连接的话，则该符号连接的状态被返回，而不是该符号连接所指向的文件的状态。

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
print_r(lstat("test.txt"));
?>

输出类似：

Array
(
[0] => 0
[1] => 0
[2] => 33206
[3] => 1
[4] => 0
[5] => 0
[6] => 0
[7] => 92
[8] => 1141633430
[9] => 1141298003
[10] => 1138609592
[11] => -1
[12] => -1
[dev] => 0
[ino] => 0
[mode] => 33206
[nlink] => 1
[uid] => 0
[gid] => 0
[rdev] => 0
[size] => 92
[atime] => 1141633430
[mtime] => 1141298003
[ctime] => 1138609592
[blksize] => -1
[blocks] => -1
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP ltrim() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ltrim() 函数

PHP String 函数

定义和用法

ltrim() 函数从字符串左侧删除空格或其他预定义字符。

语法

ltrim(string,charlist)
参数 | 描述
string | 必需。规定要转换的字符串。
charlist

可选。规定从字符串中删除哪些字符。

如果未设置该参数，则全部删除以下字符：

  • "\0" - ASCII 0, NULL
  • "\t" - ASCII 9, 制表符
  • "\n" - ASCII 10, 新行
  • "\x0B" - ASCII 11, 垂直制表符
  • "\r" - ASCII 13, 回车
  • " " - ASCII 32, 空格

例子

例子 1

<html>
<body>
<?php
$str = "    Hello World!";
echo "Without ltrim: " . $str;
echo "<br />";
echo "With ltrim: " . ltrim($str);
?>
<body>
<html>

输出：

Without ltrim: Hello World!
With ltrim: Hello World!

如果在浏览器中查看源代码，会看到以下 HTML：

<html>
<body>
Without ltrim:     Hello World!<br />With ltrim: Hello World!
</body>
</html>

例子 2

<?php
$str = "\r\nHello World!";
echo "Without ltrim: " . $str;
echo "<br />";
echo "With ltrim: " . ltrim($str);
?>

输出：

Without ltrim: Hello World!
With ltrim: Hello World!

如果在浏览器中查看源代码，会看到以下 HTML：

<html>
<body>
Without ltrim:
Hello World!<br />With ltrim: Hello World!
</body>
</html>

PHP String 函数

PHP 参考手册
PHP 测验


PHP Mail 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Mail 函数

  • Previous Page
  • Next Page

PHP Mail 简介

HTTP 函数允许您从脚本中直接发送电子邮件。

需求

要使邮件函数可用，PHP 需要已安装且正在运行的邮件系统。要使用的程序是由 php.ini 文件中的配置设置定义的。

安装

邮件函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

运行时配置

邮件函数的行为受 php.ini 的影响。

Mail 配置选项

名称 | 默认 | 描述 | 可更改
SMTP | "localhost" | Windows 专用：SMTP 服务器的 DNS 名称或 IP 地址。 | PHP_INI_ALL
smtp_port | "25" | Windows 专用：SMTP 段口号。自 PHP 4.3 起可用。 | PHP_INI_ALL
sendmail_from | NULL | Windows 专用：规定从 PHP 发送的邮件中使用的 "from" 地址。 | PHP_INI_ALL
sendmail_path | NULL | Unix 系统专用：规定sendmail 程序的路径（通常 /usr/sbin/sendmail 或 /usr/lib/sendmail） | PHP_INI_SYSTEM

PHP Mail 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
ezmlm_hash() | 计算 EZMLM 邮件列表系统所需的散列值。 | 3
mail() | 允许您从脚本中直接发送电子邮件。 | 3
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP mail() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mail() 函数

PHP Mail 函数

定义和用法

mail() 函数允许您从脚本中直接发送电子邮件。

如果邮件的投递被成功地接收，则返回 true，否则返回 false。

语法

mail(to,subject,message,headers,parameters)
参数 | 描述
to | 必需。规定邮件的接收者。
subject | 必需。规定邮件的主题。该参数不能包含任何换行字符。
message | 必需。规定要发送的消息。
headers | 必需。规定额外的报头，比如 From, Cc 以及 Bcc。
parameters | 必需。规定 sendmail 程序的额外参数。

说明

在 message 参数规定的消息中，行之间必须以一个 LF（\n）分隔。每行不能超过 70 个字符。

（Windows 下）当 PHP 直接连接到 SMTP 服务器时，如果在一行开头发现一个句号，则会被删掉。要避免此问题，将单个句号替换成两个句号。

<?php
$text = str_replace("\n.", "\n..", $text);
?>

提示和注释

注释：您需要紧记，邮件投递被接受，并不意味着邮件到达了计划的目的地。

例子

例子 1

发送一封简单的邮件：

<?php

$txt = "First line of text\nSecond line of text";

// 如果一行大于 70 个字符，请使用 wordwrap()。
$txt = wordwrap($txt,70);

// 发送邮件
mail("somebody@example.com","My subject",$txt);
?>

例子 2

发送带有额外报头的 email：

<?php

$to = "somebody@example.com";
$subject = "My subject";
$txt = "Hello world!";
$headers = "From: webmaster@example.com" . "\r\n" .
"CC: somebodyelse@example.com";

mail($to,$subject,$txt,$headers);
?>

例子 3

发送一封 HTML email：

<?php

$to = "somebody@example.com, somebodyelse@example.com";
$subject = "HTML email";

$message = "
<html>
<head>
<title>HTML email</title>
</head>
<body>
<p>This email contains HTML Tags!</p>
<table>
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td>John</td>
<td>Doe</td>
</tr>
</table>
</body>
</html>
";

// 当发送 HTML 电子邮件时，请始终设置 content-type
$headers = "MIME-Version: 1.0" . "\r\n";
$headers .= "Content-type:text/html;charset=iso-8859-1" . "\r\n";

// 更多报头
$headers .= 'From: <webmaster@example.com>' . "\r\n";
$headers .= 'Cc: myboss@example.com' . "\r\n";

mail($to,$subject,$message,$headers);
?>

PHP Mail 函数

PHP 参考手册
PHP 测验


PHP Math 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Math 函数

  • Previous Page
  • Next Page

PHP Math 简介

数学 (Math) 函数能处理 integer 和 float 范围内的值。

安装

数学 (Math) 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP Math 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
abs() | 绝对值。 | 3
acos() | 反余弦。 | 3
acosh() | 反双曲余弦。 | 4
asin() | 反正弦。 | 3
asinh() | 反双曲正弦。 | 4
atan() | 反正切。 | 3
atan2() | 两个参数的反正切。 | 3
atanh() | 反双曲正切。 | 4
base_convert() | 在任意进制之间转换数字。 | 3
bindec() | 把二进制转换为十进制。 | 3
ceil() | 向上舍入为最接近的整数。 | 3
cos() | 余弦。 | 3
cosh() | 双曲余弦。 | 4
decbin() | 把十进制转换为二进制。 | 3
dechex() | 把十进制转换为十六进制。 | 3
decoct() | 把十进制转换为八进制。 | 3
deg2rad() | 将角度转换为弧度。 | 3
exp() | 返回 Ex 的值。 | 3
expm1() | 返回 Ex - 1 的值。 | 4
floor() | 向下舍入为最接近的整数。 | 3
fmod() | 返回除法的浮点数余数。 | 4
getrandmax() | 显示随机数最大的可能值。 | 3
hexdec() | 把十六进制转换为十进制。 | 3
hypot() | 计算直角三角形的斜边长度。 | 4
is_finite() | 判断是否为有限值。 | 4
is_infinite() | 判断是否为无限值。 | 4
is_nan() | 判断是否为合法数值。 | 4
lcg_value() | 返回范围为 (0, 1) 的一个伪随机数。 | 4
log() | 自然对数。 | 3
log10() | 以 10 为底的对数。 | 3
log1p() | 返回 log(1 + number)。 | 4
max() | 返回最大值。 | 3
min() | 返回最小值。 | 3
mt_getrandmax() | 显示随机数的最大可能值。 | 3
mt_rand() | 使用 Mersenne Twister 算法返回随机整数。 | 3
mt_srand() | 播种 Mersenne Twister 随机数生成器。 | 3
octdec() | 把八进制转换为十进制。 | 3
pi() | 返回圆周率的值。 | 3
pow() | 返回 x 的 y 次方。 | 3
rad2deg() | 把弧度数转换为角度数。 | 3
rand() | 返回随机整数。 | 3
round() | 对浮点数进行四舍五入。 | 3
sin() | 正弦。 | 3
sinh() | 双曲正弦。 | 4
sqrt() | 平方根。 | 3
srand() | 播下随机数发生器种子。 | 3
tan() | 正切。 | 3
tanh() | 双曲正切。 | 4

PHP Math 常量

常量名 | 常量名 | 常量值 | PHP
M_E | e | 2.7182818284590452354 | 4
M_EULER | Euler 常量 | 0.57721566490153286061 | 5.2.0
M_LNPI | log_e(pi) | 1.14472988584940017414 | 5.2.0
M_LN2 | log_e 2 | 0.69314718055994530942 | 4
M_LN10 | log_e 10 | 2.30258509299404568402 | 4
M_LOG2E | log_2 e | 1.4426950408889634074 | 4
M_LOG10E | log_10 e | 0.43429448190325182765 | 4
M_PI | Pi | 3.14159265358979323846 | 3
M_PI_2 | pi/2 | 1.57079632679489661923 | 4
M_PI_4 | pi/4 | 0.78539816339744830962 | 4
M_1_PI | 1/pi | 0.31830988618379067154 | 4
M_2_PI | 2/pi | 0.63661977236758134308 | 4
M_SQRTPI | sqrt(pi) | 1.77245385090551602729 | 5.2.0
M_2_SQRTPI | 2/sqrt(pi) | 1.12837916709551257390 | 4
M_SQRT1_2 | 1/sqrt(2) | 0.70710678118654752440 | 4
M_SQRT2 | sqrt(2) | 1.41421356237309504880 | 4
M_SQRT3 | sqrt(3) | 1.73205080756887729352 | 5.2.0
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP max() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP max() 函数

PHP Math 函数

定义和用法

max() 返回最大值。

语法

max(x,y)
参数 | 描述
x | 必需。一个数。
y | 必需。一个数。

说明

max() 返回参数中数值最大的值。

如果仅有一个参数且为数组，max() 返回该数组中最大的值。如果第一个参数是整数、字符串或浮点数，则至少需要两个参数而 max() 会返回这些值中最大的一个。可以比较无限多个值。

提示和注释

注释：PHP 会将非数值的字符串当成 0，但如果这个正是最大的数值则仍然会返回一个字符串。如果多个参数都求值为 0 且是最大值，max() 会返回其中数值的 0，如果参数中没有数值的 0，则返回按字母表顺序最大的字符串。

例子

在本例中，我们将使用 max() 来返回两个指定的数中的最大值：

<?php
echo(max(5,7));
echo(max(-3,5));
echo(max(-3,-5));
echo(max(7.25,7.30));
?>

输出类似：

7
5
-3
7.3

PHP Math 函数

PHP 参考手册
PHP 测验


PHP md5_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP md5_file() 函数

PHP String 函数

定义和用法

md5_file() 函数计算文件的 MD5 散列。

md5() 函数使用 RSA 数据安全，包括 MD5 报文摘译算法。

如果成功，则返回所计算的 MD5 散列，如果失败，则返回 false。

语法

md5(string,raw)
参数 | 描述
string | 必需。规定要计算的文件。
charlist

可选。规定十六进制或二进制输出格式：

  • TRUE - 原始 16 字符二进制格式
  • FALSE - 默认。32 字符十六进制数

注释：该参数是 PHP 5.0 中添加的。

例子

例子 1

<?php
$filename = "test.txt";
$md5file = md5_file($filename);
echo $md5file;
?>

输出：

5d41402abc4b2a76b9719d911017c592

例子 2

存储 "test.txt" 文件的 MD5 散列：

<?php
$md5file = md5_file("test.txt");
file_put_contents("md5file.txt",$md5file);
?>

在本例中，我们将检测 "test.txt" 是否已被更改（即是否 MD5 散列已被更改）：

<?php
$md5file = file_get_contents("md5file.txt");
if (md5_file("test.txt") == $md5file)
  {
  echo "The file is ok.";
  }
else
  {
  echo "The file has been changed.";
  }
?>

输出：

The file is ok.

PHP String 函数

PHP 参考手册
PHP 测验


PHP md5() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP md5() 函数

PHP String 函数

定义和用法

md5() 函数计算字符串的 MD5 散列。

md5() 函数使用 RSA 数据安全，包括 MD5 报文摘译算法。

如果成功，则返回所计算的 MD5 散列，如果失败，则返回 false。

语法

md5(string,raw)
参数 | 描述
string | 必需。规定要计算的字符串。
charlist

可选。规定十六进制或二进制输出格式：

  • TRUE - 原始 16 字符二进制格式
  • FALSE - 默认。32 字符十六进制数

注释：该参数是 PHP 5.0 中添加的。

例子

例子 1

<?php
$str = "Hello";
echo md5($str);
?>

输出：

8b1a9953c4611296a827abf8c47804d7

例子 2

<?php
$str = "Hello";
echo md5($str);

if (md5($str) == '8b1a9953c4611296a827abf8c47804d7')
  {
  echo "<br />Hello world!";
  exit;
  }
?>

输出：

8b1a9953c4611296a827abf8c47804d7
Hello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP metaphone() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP metaphone() 函数

PHP String 函数

定义和用法

metaphone() 函数计算字符串的 metaphone 键。

metaphone 键字符串的英语发音。

metaphone() 函数可用于拼写检查应用程序。

如果成功，则返回字符串的 metaphone 键，如果失败，则返回 false。

语法

metaphone(string,length)
参数 | 描述
string | 必需。规定要检查的字符串。
length | 可选。规定 metaphone 键的最大长度。

提示和注释

注释：metaphone() 为发音相似的单词创建相同的键。

注释：所生成的 metaphone 键长度可变。

提示：metaphone() 比 soundex() 函数更精确，因为 metaphone() 了解基本的英语发音规则。

例子

例子 1

<?php
echo metaphone("world");
?>

输出：

WRLT

例子 2

在本例中，我们对两个发音相似的单词应用 metaphone() 函数：

<?php
$str = "Sun";
$str2 = "Son";

echo metaphone($str);
echo metaphone($str2);
?>

输出：

SN
SN

PHP String 函数

PHP 参考手册
PHP 测验


PHP microtime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP microtime() 函数

PHP Date / Time 函数

定义和用法

microtime() 函数返回当前 Unix 时间戳和微秒数。

语法

microtime(get_as_float)
参数 | 描述
get_as_float | 如果给出了 get_as_float 参数并且其值等价于 TRUE，该函数将返回一个浮点数。

说明

本函数仅在支持 gettimeofday() 系统调用的操作系统下可用。

如果调用时不带可选参数，本函数以 "msec sec" 的格式返回一个字符串，其中 sec 是自 Unix 纪元（0:00:00 January 1, 1970 GMT）起到现在的秒数，msec 是微秒部分。字符串的两部分都是以秒为单位返回的。

例子

<?php
echo(microtime());
?>

输出：

0.25139300 1138197510

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP min() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP min() 函数

PHP Math 函数

定义和用法

min() 返回最小值。

语法

min(x,y)
参数 | 描述
x | 必需。一个数。
y | 必需。一个数。

说明

min() 返回参数中数值最小的。

如果仅有一个参数且为数组，min() 返回该数组中最小的值。如果第一个参数是整数、字符串或浮点数，则至少需要两个参数而 min() 会返回这些值中最小的一个。可以比较无限多个值。

提示和注释

注释：PHP 会将非数值的 string 当成 0，但如果这个正是最小的数值则仍然会返回一个字符串。如果多个参数都求值为 0 且是最小值，min() 会返回按字母表顺序最小的字符串，如果其中没有字符串的话，则返回数值的 0。

例子

在本例中，我们将使用 min() 来返回两个指定的数中的最小值：

<?php
echo(min(5,7));
echo(min(-3,5));
echo(min(-3,-5));
echo(min(7.25,7.30));
?>

输出类似：

5
-3
-5
7.25

PHP Math 函数

PHP 参考手册
PHP 测验


PHP mkdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mkdir() 函数

PHP Filesystem 函数

定义和用法

mkdir() 函数创建目录。

若成功，则返回 true，否则返回 false。

语法

mkdir(path,mode,recursive,context)
参数 | 描述
path | 必需。规定要创建的目录的名称。
mode | 必需。规定权限。默认是 0777。
recursive | 必需。规定是否设置递归模式。
context | 必需。规定文件句柄的环境。Context 是可修改流的行为的一套选项。

说明

mkdir() 尝试新建一个由 path 指定的目录。

默认的 mode 是 0777，意味着最大可能的访问权。

提示和注释

注释：mode 在 Windows 下被忽略。自 PHP 4.2.0 起成为可选项。

注释：对 context 的支持是 PHP 5.0.0 添加的。

注释：recursive 参数是 PHP 5.0.0 添加的。

例子

<?php
mkdir("testing");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP mktime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mktime() 函数

PHP Date / Time 函数

定义和用法

mktime() 函数返回一个日期的 Unix 时间戳。

参数总是表示 GMT 日期，因此 is_dst 对结果没有影响。

参数可以从右到左依次空着，空着的参数会被设为相应的当前 GMT 值。

语法

mktime(hour,minute,second,month,day,year,is_dst)
参数 | 描述
hour | 可选。规定小时。
minute | 可选。规定分钟。
second | 可选。规定秒。
month | 可选。规定用数字表示的月。
day | 可选。规定天。
year | 可选。规定年。在某些系统上，合法值介于 1901 - 2038 之间。不过在 PHP 5 中已经不存在这个限制了。
is_dst | 可选。如果时间在日光节约时间(DST)期间，则设置为1，否则设置为0，若未知，则设置为-1。 自 5.1.0 起，is_dst 参数被废弃。因此应该使用新的时区处理特性。

提示和注释

注释：在 PHP 5.1 之前，如果该函数的参数非法，则会返回 false。

例子

mktime() 函数对于日期运算和验证非常有用。它可以自动校正越界的输入：

<?php
echo(date("M-d-Y",mktime(0,0,0,12,36,2001)));
echo(date("M-d-Y",mktime(0,0,0,14,1,2001)));
echo(date("M-d-Y",mktime(0,0,0,1,1,2001)));
echo(date("M-d-Y",mktime(0,0,0,1,1,99)));
?>

输出：

Jan-05-2002
Feb-01-2002
Jan-01-2001
Jan-01-1999

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP money_format() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP money_format() 函数

PHP String 函数

定义和用法

money_format() 函数把字符串格式化为货币字符串。

语法

money_format(string,number)
参数 | 描述
string | 必需。规定要格式化的字符串。
number | 可选。被插入格式化字符串中 % 符号位置的数字。

提示和注释

注释：money_format() 函数无法在 windows 平台上工作。

例子

例子 1

国际 en_US 格式：

<?php
$number = 1234.56;
setlocale(LC_MONETARY, "en_US");
echo money_format("The price is %i", $number);
?>

输出：

The price is USD 1,234.56

例子 2

负数，带有 () 指示负数的 US 国际格式，右侧精度为 2，"*" 为填充字符：

<?php
$number = -1234.5672;

echo money_format("%=*(#10.2n", $number);
?>

输出：

($********1,234.57)

PHP String 函数

PHP 参考手册
PHP 测验


PHP move_uploaded_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP move_uploaded_file() 函数

PHP Filesystem 函数

定义和用法

move_uploaded_file() 函数将上传的文件移动到新位置。

若成功，则返回 true，否则返回 false。

语法

move_uploaded_file(file,newloc)
参数 | 描述
file | 必需。规定要移动的文件。
newloc | 必需。规定文件的新位置。

说明

本函数检查并确保由 file 指定的文件是合法的上传文件（即通过 PHP 的 HTTP POST 上传机制所上传的）。如果文件合法，则将其移动为由 newloc 指定的文件。

如果 file 不是合法的上传文件，不会出现任何操作，move_uploaded_file() 将返回 false。

如果 file 是合法的上传文件，但出于某些原因无法移动，不会出现任何操作，move_uploaded_file() 将返回 false，此外还会发出一条警告。

这种检查显得格外重要，如果上传的文件有可能会造成对用户或本系统的其他用户显示其内容的话。

提示和注释

注释：本函数仅用于通过 HTTP POST 上传的文件。

注意：如果目标文件已经存在，将会被覆盖。

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP mt_getrandmax() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mt_getrandmax() 函数

PHP Math 函数

定义和用法

mt_getrandmax() 显示随机数的最大可能值。

语法

mt_getrandmax()

说明

返回调用 mt_rand() 所能返回的最大的随机数。

例子

<?php
echo mt_getrandmax();
?>

输出类似：

3147483649

PHP Math 函数

PHP 参考手册
PHP 测验


PHP mt_rand() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mt_rand() 函数

PHP Math 函数

定义和用法

mt_rand() 使用 Mersenne Twister 算法返回随机整数。

语法

mt_rand(min,max)

说明

如果没有提供可选参数 min 和 max，mt_rand() 返回 0 到 RAND_MAX 之间的伪随机数。例如想要 5 到 15（包括 5 和 15）之间的随机数，用 mt_rand(5, 15)。

很多老的 libc 的随机数发生器具有一些不确定和未知的特性而且很慢。PHP 的 rand() 函数默认使用 libc 随机数发生器。mt_rand() 函数是非正式用来替换它的。该函数用了 Mersenne Twister 中已知的特性作为随机数发生器，它可以产生随机数值的平均速度比 libc 提供的 rand() 快四倍。

提示和注释

注释：自 PHP 4.2.0 起，不再需要用 srand() 或 mt_srand() 函数给随机数发生器播种，现在已自动完成。

注释：在 3.0.7 之前的版本中，max 的含义是 range 。要在这些版本中得到和上例相同 5 到 15 的随机数，简短的例子是 mt_rand (5, 11)。

例子

在本例中，我们会返回一些随机数：

<?php
echo(mt_rand());
echo(mt_rand());
echo(mt_rand(10,100));
?>

输出类似：

3150906288
513289678
35

PHP Math 函数

PHP 参考手册
PHP 测验


PHP mt_srand() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mt_srand() 函数

PHP Math 函数

定义和用法

mt_srand() 播种 Mersenne Twister 随机数生成器。

语法

mt_srand(seed)
参数 | 描述
seed | 必需。用 seed 来给随机数发生器播种。

说明

从 PHP 4.2.0 版开始，seed 参数变为可选项，当该项为空时，会被设为随时数。

提示和注释

注释：自 PHP 4.2.0 起，不再需要用 srand() 或 mt_srand() 函数给随机数发生器播种，现已自动完成。

例子

在本例中，我们将播种随机数生成器：

<?php
mt_srand(mktime());
echo(mt_rand());
?>

输出类似：

1132656473

PHP Math 函数

PHP 参考手册
PHP 测验


PHP mysql_affected_rows() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_affected_rows() 函数

PHP MySQL 函数

定义和用法

mysql_affected_rows() 函数返回前一次 MySQL 操作所影响的记录行数。

语法

mysql_affected_rows(link_identifier)
参数 | 描述
link_identifier | 必需。MySQL 的连接标识符。如果没有指定，默认使用最后被 mysql_connect() 打开的连接。如果没有找到该连接，函数会尝试调用 mysql_connect() 建立连接并使用它。如果发生意外，没有找到连接或无法建立连接，系统发出 E_WARNING 级别的警告信息。

说明

取得最近一次与 link_identifier 关联的 INSERT，UPDATE 或 DELETE 查询所影响的记录行数。

返回值

执行成功，则返回受影响的行的数目，如果最近一次查询失败的话，函数返回 -1。

如果最近一次操作是没有任何条件（WHERE）的 DELETE 查询，在表中所有的记录都会被删除，但本函数返回值在 4.1.2 版之前都为 0。

当使用 UPDATE 查询，MySQL 不会将原值与新值一样的列更新。这样使得 mysql_affected_rows() 函数返回值不一定就是查询条件所符合的记录数，只有真正被修改的记录数才会被返回。

REPLACE 语句首先删除具有相同主键的记录，然后插入一个新记录。该函数返回的是被删除的记录数加上被插入的记录数。

例子

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die("Could not connect: " . mysql_error());
  }

mysql_select_db("mydb");
mysql_query("DELETE FROM mytable WHERE id < 5");
$rc = mysql_affected_rows();
echo "Records deleted: " . $rc;

mysql_close($con);
?>

输出：

Records deleted: 4

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_client_encoding() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_client_encoding() 函数

PHP MySQL 函数

定义和用法

mysql_client_encoding() 函数返回当前连接的字符集的名称。

语法

mysql_client_encoding(link_identifier)
参数 | 描述
link_identifier | 必需。MySQL 的连接标识符。如果没有指定，默认使用最后被 mysql_connect() 打开的连接。如果没有找到该连接，函数会尝试调用 mysql_connect() 建立连接并使用它。如果发生意外，没有找到连接或无法建立连接，系统发出 E_WARNING 级别的警告信息。

说明

从 MySQL 中取得 character_set 变量的值。

返回值

返回当前连接的默认字符集名称。

例子

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die("Could not connect: " . mysql_error());
  }

$charset = mysql_client_encoding($con);
echo "The current character set is: $charset";

mysql_close($con);
?>

输出：

The current character set is: latin1

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_close() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_close() 函数

PHP MySQL 函数

定义和用法

mysql_close() 函数关闭非持久的 MySQL 连接。

语法

mysql_close(link_identifier)
参数 | 描述
link_identifier | 必需。MySQL 的连接标识符。如果没有指定，默认使用最后被 mysql_connect() 打开的连接。如果没有找到该连接，函数会尝试调用 mysql_connect() 建立连接并使用它。如果发生意外，没有找到连接或无法建立连接，系统发出 E_WARNING 级别的警告信息。

说明

本函数关闭指定的连接标识所关联的到 MySQL 服务器的非持久连接。如果没有指定 link_identifier，则关闭上一个打开的连接。

返回值

如果成功则返回 true，失败则返回 false。

提示和注释

提示：通常不需要使用 mysql_close()，因为已打开的非持久连接会在脚本执行完毕后自动关闭。

注释：mysql_close() 不会关闭由 mysql_pconnect() 建立的持久连接。

例子

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

// 一些代码...

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_connect() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_connect() 函数

PHP MySQL 函数

定义和用法

mysql_connect() 函数打开非持久的 MySQL 连接。

语法

mysql_connect(server,user,pwd,newlink,clientflag)
参数 | 描述
server

可选。规定要连接的服务器。

可以包括端口号，例如 "hostname:port"，或者到本地套接字的路径，例如对于 localhost 的 ":/path/to/socket"。

如果 PHP 指令 mysql.default_host 未定义（默认情况），则默认值是 'localhost:3306'。
user | 可选。用户名。默认值是服务器进程所有者的用户名。
pwd | 可选。密码。默认值是空密码。
newlink | 可选。如果用同样的参数第二次调用 mysql_connect()，将不会建立新连接，而将返回已经打开的连接标识。参数 new_link 改变此行为并使 mysql_connect() 总是打开新的连接，甚至当 mysql_connect() 曾在前面被用同样的参数调用过。
clientflag

可选。client_flags 参数可以是以下常量的组合：

  • MYSQL_CLIENT_SSL - 使用 SSL 加密
  • MYSQL_CLIENT_COMPRESS - 使用压缩协议
  • MYSQL_CLIENT_IGNORE_SPACE - 允许函数名后的间隔
  • MYSQL_CLIENT_INTERACTIVE - 允许关闭连接之前的交互超时非活动时间

返回值

如果成功，则返回一个 MySQL 连接标识，失败则返回 FALSE。

提示和注释

注释：脚本一结束，到服务器的连接就被关闭，除非之前已经明确调用 mysql_close() 关闭了。

提示：要创建一个持久连接，请使用 mysql_pconnect() 函数。

例子

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

// 一些代码...

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_data_seek() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_data_seek() 函数

PHP MySQL 函数

定义和用法

mysql_data_seek() 函数移动内部结果的指针。

语法

mysql_data_seek(data,row)
参数 | 描述
data | 必需。返回类型为 resource 的结果集。该结果集从 mysql_query() 的调用中得到。
row | 必需。想要设定的新的结果集指针的行数。0 指示第一个记录。

说明

mysql_data_seek() 将 data 参数指定的 MySQL 结果内部的行指针移动到指定的行号。

接着调用 mysql_fetch_row() 将返回那一行。

row 从 0 开始。row 的取值范围应该从 0 到 mysql_num_rows - 1。

但是如果结果集为空（mysql_num_rows() == 0），要将指针移动到 0 会失败并发出 E_WARNING 级的错误，mysql_data_seek() 将返回 false。

返回值

如果成功则返回 true，失败则返回 false。

提示和注释

注释：mysql_data_seek() 只能和 mysql_query() 一起使用，而不能用于 mysql_unbuffered_query()。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_row($result));

mysql_data_seek($result,3);
print_r(mysql_fetch_row($result));

mysql_close($con);
?>

输出：

Array
(
[0] => Adams
[1] => John
[2] => London
)

Array
(
[0] => Carter
[1] => Thomas
[2] => Beijing
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_db_name() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_db_name() 函数

PHP MySQL 函数

定义和用法

mysql_db_name() 函数取得 mysql_list_dbs() 调用所返回的数据库名。

语法

mysql_db_name(list,row,field)
参数 | 描述
list | 必需。mysql_list_dbs() 调用所返回的结果指针。
row | 必需。规定结果集中的行号。以 0 开始。
field | 可选。规定字段名。

说明

如果成功，则返回数据库名，失败返回 false。如果返回了 false，用 mysql_error() 来判断错误的种类。

例子

<?php
$con = mysql_connect("localhost", "peter", "abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_list = mysql_list_dbs($con);

$i = 0;
$db_count = mysql_num_rows($db_list);
while ($i < $db_count)
  {
  echo mysql_db_name($db_list, $i) . "<br />";
  $i++;
  }

mysql_close($con);
?>

输出类似：

mysql
customers
movies

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_errno() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_errno() 函数

PHP MySQL 函数

定义和用法

mysql_errno() 函数返回上一个 MySQL 操作中的错误信息的数字编码。

返回上一个 MySQL 函数的错误号码，如果没有出错则返回 0（零）。

语法

mysql_errno(connection)
参数 | 描述
connection | 可选。规定 SQL 连接标识符。如果未规定，则使用上一个打开的连接。

例子

在本例中，我们将尝试使用错误的用户名和密码来登录一个 MySQL 服务器：

<?php
$con = mysql_connect("localhost","wrong_user","wrong_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_errno());
  }
mysql_close($con);
?>

输出类似：

Could not connect: 1045

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_error() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_error() 函数

PHP MySQL 函数

定义和用法

mysql_error() 函数返回上一个 MySQL 操作产生的文本错误信息。

本函数返回上一个 MySQL 函数的错误文本，如果没有出错则返回 ''（空字符串）。

语法

mysql_error(connection)
参数 | 描述
connection | 可选。规定 SQL 连接标识符。如果未规定，则使用上一个打开的连接。

例子

在本例中，我们将尝试使用错误的用户名和密码来登录一个 MySQL 服务器：

<?php
$con = mysql_connect("localhost","wrong_user","wrong_pwd");
if (!$con)
  {
  die(mysql_error());
  }
mysql_close($con);
?>

输出类似：

Access denied for user 'wrong_user'@'localhost'
(using password: YES)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_fetch_array() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_fetch_array() 函数

PHP MySQL 函数

定义和用法

mysql_fetch_array() 函数从结果集中取得一行作为关联数组，或数字数组，或二者兼有

返回根据从结果集取得的行生成的数组，如果没有更多行则返回 false。

语法

mysql_fetch_array(data,array_type)
参数 | 描述
data | 可选。规定规定要使用的数据指针。该数据指针是 mysql_query() 函数产生的结果。
array_type

可选。规定返回哪种结果。可能的值：

  • MYSQL_ASSOC - 关联数组
  • MYSQL_NUM - 数字数组
  • MYSQL_BOTH - 默认。同时产生关联和数字数组

提示和注释

注释：mysql_fetch_array() 是 mysql_fetch_row() 的扩展版本。除了将数据以数字索引方式储存在数组中之外，还可以将数据作为关联索引储存，用字段名作为键名。

提示：有很重要的一点必须指出，用 mysql_fetch_array() 并不明显比用 mysql_fetch_row() 慢，而且还明显提供了更多的值。

注释：本函数返回的字段名是区分大小写的。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);
$sql = "SELECT * from Person WHERE Lastname='Adams'";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_array($result));

mysql_close($con);
?>

输出类似：

Array
(
[0] => Adams
[LastName] => Adams
[1] => John
[FirstName] => John
[2] => London
[City] => London
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_fetch_assoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_fetch_assoc() 函数

PHP MySQL 函数

定义和用法

mysql_fetch_assoc() 函数从结果集中取得一行作为关联数组。

返回根据从结果集取得的行生成的关联数组，如果没有更多行，则返回 false。

语法

mysql_fetch_assoc(data)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。

提示和注释

注释：mysql_fetch_assoc() 和用 mysql_fetch_array() 加上第二个可选参数 MYSQL_ASSOC 完全相同。它仅仅返回关联数组。这也是 mysql_fetch_array() 初始的工作方式。

提示：如果在关联索引之外还需要数字索引，用 mysql_fetch_array()。

注释：本函数返回的字段名是区分大小写的。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);
$sql = "SELECT * from Person WHERE Lastname='Adams'";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_assoc($result));

mysql_close($con);
?>

输出：

Array
(
[LastName] => Adams
[FirstName] => John
[City] => London
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_fetch_field() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_fetch_field() 函数

PHP MySQL 函数

定义和用法

mysql_fetch_field() 函数从结果集中取得列信息并作为对象返回。

mysql_fetch_field() 可以用来从查询结果中取得字段的信息。如果没有指定字段偏移量，则提取下一个尚未被 mysql_fetch_field() 取得的字段。

该函数返回一个包含字段信息的对象。

被返回的对象的属性为：

  • name - 列名
  • table - 该列所在的表名
  • max_length - 该列最大长度
  • not_null - 1，如果该列不能为 NULL
  • primary_key - 1，如果该列是 primary key
  • unique_key - 1，如果该列是 unique key
  • multiple_key - 1，如果该列是 non-unique key
  • numeric - 1，如果该列是 numeric
  • blob - 1，如果该列是 BLOB
  • type - 该列的类型
  • unsigned - 1，如果该列是无符号数
  • zerofill - 1，如果该列是 zero-filled

语法

mysql_fetch_field(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。规定从哪个字段开始。0 指示第一个字段。如果未设置，则取回下一个字段。

提示和注释

注释：本函数返回的字段名是区分大小写的。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

while ($property = mysql_fetch_field($result))
  {
  echo "Field name: " . $property->name . "<br />";
  echo "Table name: " . $property->table . "<br />";
  echo "Default value: " . $property->def . "<br />";
  echo "Max length: " . $property->max_length . "<br />";
  echo "Not NULL: " . $property->not_null . "<br />";
  echo "Primary Key: " . $property->primary_key . "<br />";
  echo "Unique Key: " . $property->unique_key . "<br />";
  echo "Mutliple Key: " . $property->multiple_key . "<br />";
  echo "Numeric Field: " . $property->numeric . "<br />";
  echo "BLOB: " . $property->blob . "<br />";
  echo "Field Type: " . $property->type . "<br />";
  echo "Unsigned: " . $property->unsigned . "<br />";
  echo "Zero-filled: " . $property->zerofill . "<br /><br />";
  }

mysql_close($con);
?>

输出：

Field name: LastName
Table name: Person
Default value:
Max length: 8
Not NULL: 0
Primary Key: 0
Unique Key: 0
Mutliple Key: 0
Numeric Field: 0
BLOB: 0
Field Type: string
Unsigned: 0
Zero-filled: 0

Field name: FirstName
Table name: Person
Default value:
Max length: 7
Not NULL: 0
Primary Key: 0
Unique Key: 0
Mutliple Key: 0
Numeric Field: 0
BLOB: 0
Field Type: string
Unsigned: 0
Zero-filled: 0

Field name: City
Table name: Person
Default value:
Max length: 9
Not NULL: 0
Primary Key: 0
Unique Key: 0
Mutliple Key: 0
Numeric Field: 0
BLOB: 0
Field Type: string
Unsigned: 0
Zero-filled: 0

Field name: Age
Table name: Person
Default value:
Max length: 2
Not NULL: 0
Primary Key: 0
Unique Key: 0
Mutliple Key: 0
Numeric Field: 1
BLOB: 0
Field Type: int
Unsigned: 0
Zero-filled: 0

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_fetch_lengths() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_fetch_lengths() 函数

PHP MySQL 函数

定义和用法

mysql_fetch_lengths() 函数取得一行中每个字段的内容的长度。

行是由这些函数返回的：mysql_fetch_array()、mysql_fetch_assoc()、mysql_fetch_object() 或 mysql_fetch_row()。

若成功，则该函数返回一个数字数组，若出错或没有其他的行，则返回 false。

语法

mysql_fetch_lengths(data)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。

例子

<?php
$con = mysql_connect("localhost", "peter", "abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);
$sql = "SELECT * from Person WHERE Lastname='Refsnes'";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_row($result));
print_r(mysql_fetch_lengths($result));

mysql_close($con);
?>

输出：

Array
(
[0] => Adams
[1] => John
[2] => London
)

Array
(
[0] => 5
[1] => 4
[2] => 6
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_fetch_object() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_fetch_object() 函数

PHP MySQL 函数

定义和用法

mysql_fetch_object() 函数从结果集（记录集）中取得一行作为对象。

若成功的话，本函数从 mysql_query() 获得一行，并返回一个对象。如果失败或没有更多的行，则返回 false。

语法

mysql_fetch_object(data)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。

提示和注释

注释：每个随后对 mysql_fetch_object() 的调用都会返回记录集中的下一行。

注释：mysql_fetch_object() 与 mysql_fetch_array() 类似，只有一点区别 - 返回的是对象而不是数组。间接地，也意味着只能通过字段名来访问数组，而不是偏移量。

例子

<?php
$con = mysql_connect("localhost", "peter", "abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);
$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

while ($row = mysql_fetch_object($result))
  {
  echo $row->FirstName . "<br />";
  }

mysql_close($con);
?>

输出：

John
George
Thomas

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_fetch_row() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_fetch_row() 函数

PHP MySQL 函数

定义和用法

mysql_fetch_row() 函数从结果集中取得一行作为数字数组。

语法

mysql_fetch_row(data)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。

说明

mysql_fetch_row() 从和结果标识 data 关联的结果集中取得一行数据并作为数组返回。每个结果的列储存在一个数组的单元中，偏移量从 0 开始。

依次调用 mysql_fetch_row() 将返回结果集中的下一行，如果没有更多行则返回 FALSE。

返回值

返回根据所取得的行生成的数组，如果没有更多行则返回 false。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);
$sql = "SELECT * from Person WHERE Lastname='Adams'";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_row($result));

mysql_close($con);
?>

输出：

Array
(
[0] => Adams
[1] => John
[2] => London
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_field_flags() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_field_flags() 函数

PHP MySQL 函数

定义和用法

mysql_field_flags() 函数从结果中取得和指定字段关联的标志。

本函数返回指定字段的字段标志。

如果 MySQL 版本足够新，则会支持以下的标志：

  • auto_intcrement
  • binary
  • blob
  • enum
  • multiple_key
  • not_null
  • primary_key
  • timestamp
  • unique_key
  • unsigned
  • zerofill

语法

mysql_field_flags(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。指示从哪个字段开始返回。0 指示第一个字段。

提示和注释

提示：每个标志都用一个单词表示，之间用一个空格分开，因此，您可以通过 explode() 函数把返回的字符串打散到一个数组中。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

$flags = mysql_field_flags($result, 0);
echo $flags;

mysql_close($con);
?>

输出：

not_null primary_key auto_increment

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_field_len() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_field_len() 函数

PHP MySQL 函数

定义和用法

mysql_field_len() 函数返回指定字段的长度。

如果成功，则返回字段的长度，如果失败，则返回 false。

语法

mysql_field_len(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。指示从哪个字段开始返回。0 指示第一个字段。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

$length = mysql_field_len($result, 0);

echo $length;

mysql_close($con);
?>

输出：

20

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_field_name() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_field_name() 函数

PHP MySQL 函数

定义和用法

mysql_field_name() 函数取得结果中指定字段的字段名。

如果成功，则返回字段的名称，如果失败，则返回 false。

语法

mysql_field_name(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。指示从哪个字段开始返回。0 指示第一个字段。

提示和注释

注释：本函数返回的字段名是区分大小写的。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

$name = mysql_field_name($result, 0);

echo $name;

mysql_close($con);
?>

输出：

LastName

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_field_seek() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_field_seek() 函数

PHP MySQL 函数

定义和用法

mysql_field_seek() 函数将结果集中的指针设定为指定的字段偏移量。

如果成功，则返回 true，如果失败，则返回 false。

语法

mysql_field_seek(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。指示从哪个字段开始返回。0 指示第一个字段。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

// 跳到第四个字段
mysql_field_seek($result,3);
print_r(mysql_fetch_field($result));

mysql_close($con);
?>

输出：

stdClass Object
(
[name] => Age
[table] => Person
[def] =>
[max_length] => 2
[not_null] => 0
[primary_key] => 0
[multiple_key] => 0
[unique_key] => 0
[numeric] => 1
[blob] => 0
[type] => int
[unsigned] => 0
[zerofill] => 0
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_field_table() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_field_table() 函数

PHP MySQL 函数

定义和用法

mysql_field_table() 函数返回指定字段所在的表名。

如果成功，则返回指定字段的表名，如果失败，则返回 false。

语法

mysql_field_table(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。指示从哪个字段开始返回。0 指示第一个字段。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

$table = mysql_field_table($result, 0);

echo $table;

mysql_close($con);
?>

输出：

Person

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_field_type() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_field_type() 函数

PHP MySQL 函数

定义和用法

mysql_field_type() 函数返回结果集中指定字段的类型。

如果成功，则返回指定字段的类型，如果失败，则返回 false。

语法

mysql_field_type(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。指示从哪个字段开始返回。0 指示第一个字段。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

$type = mysql_field_type($result, 0);

echo $type;

mysql_close($con);
?>

输出：

string

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_free_result() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_free_result() 函数

PHP MySQL 函数

定义和用法

mysql_free_result() 函数释放结果内存。

如果成功，则返回 true，如果失败，则返回 false。

语法

mysql_free_result(data)
参数 | 描述
data | 必需。要释放的结果标识符。该结果标识符是从 mysql_query() 返回的结果。

提示和注释

注释：mysql_free_result() 仅需要在考虑到返回很大的结果集时会占用多少内存时调用。在脚本结束后所有关联的内存都会被自动释放。

例子

<?php
$con = mysql_connect("localhost", "peter", "abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_row($result));

// 释放内存
mysql_free_result($result);

$sql = "SELECT * from Customers";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_row($result));

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_get_client_info() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_get_client_info() 函数

PHP MySQL 函数

定义和用法

mysql_get_client_info() 函数返回 MySQL 客户端信息。

如果成功，则返回 MySQL 客户端的版本号，如果失败，则返回 false。

语法

mysql_get_client_info()

例子

<?php
echo "MySQL client info: " . mysql_get_client_info();
?>

输出：

MySQL client info: 5.0.18

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_get_host_info() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_get_host_info() 函数

PHP MySQL 函数

定义和用法

mysql_get_host_info() 函数返回 MySQL 主机的信息。

如果成功，则返回当前正在使用的 MySQL 连接的类型，如果失败，则返回 false。

语法

mysql_get_host_info(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

说明

mysql_get_host_info() 返回一个字符串，说明了连接 connection 所使用的连接方式，包括服务器的主机名。如果省略 connection，则使用上一个打开的连接。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
echo "MySQL host info: " . mysql_get_host_info($con);
?>

输出：

MySQL host info: localhost via TCP/IP

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_get_proto_info() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_get_proto_info() 函数

PHP MySQL 函数

定义和用法

mysql_get_proto_info() 函数返回 MySQL 协议的信息。

如果成功，则返回 MySQL 协议的版本，如果失败，则返回 false。

语法

mysql_get_proto_info(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
echo "MySQL protocol info: " . mysql_get_proto_info($con);
?>

输出：

MySQL protocol info: 10

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_get_server_info() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_get_server_info() 函数

PHP MySQL 函数

定义和用法

mysql_get_server_info() 函数返回 MySQL 服务器的信息。

如果成功，则返回 MySQL 服务器的版本号，如果失败，则返回 false。

语法

mysql_get_server_info(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
echo "MySQL server info: " . mysql_get_server_info($con);
?>

输出：

MySQL server info: 5.0.18-nt

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_info() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_info() 函数

PHP MySQL 函数

定义和用法

mysql_info() 函数返回最近一条查询的信息。

如果成功，则返回有关该语句的信息，如果失败，则返回 false。

语法

mysql_info(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

说明

mysql_info() 返回通过给定的 connection 所进行的最新一条查询的详细信息。如果没有指定 connection，则假定为上一个打开的连接。

mysql_info() 对以下列出的所有语句返回一个字符串：

INSERT INTO ... SELECT ...

INSERT INTO ... VALUES (...),(...),(...)...

LOAD DATA INFILE ...

ALTER TABLE

UPDATE

对于其它任何语句返回 false。字符串的格式取决于给出的语句。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);
$sql = "INSERT INTO person VALUES ('John','Doe','Utah','17')";
$result = mysql_query($sql,$con);

$info = mysql_info($con);
echo $info;

mysql_close($con);
?>

输出类似：

String format: Records: 15 Duplicates: 0 Warnings: 0

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_insert_id() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_insert_id() 函数

PHP MySQL 函数

定义和用法

mysql_insert_id() 函数返回上一步 INSERT 操作产生的 ID。

如果上一查询没有产生 AUTO_INCREMENT 的 ID，则 mysql_insert_id() 返回 0。

语法

mysql_insert_id(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

说明

mysql_insert_id() 返回给定的 connection 中上一步 INSERT 查询中产生的 AUTO_INCREMENT 的 ID 号。如果没有指定 connection ，则使用上一个打开的连接。

提示和注释

注释：如果需要保存该值以后使用，要确保在产生了值的查询之后立即调用 mysql_insert_id()。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "INSERT INTO person VALUES ('Carter','Thomas','Beijing')";
$result = mysql_query($sql,$con);
echo "ID of last inserted record is: " . mysql_insert_id();

mysql_close($con);
?>

输出类似：

ID of last inserted record is: 5

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_list_dbs() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_list_dbs() 函数

PHP MySQL 函数

定义和用法

mysql_list_dbs() 函数列出 MySQL 服务器中所有的数据库。

语法

mysql_list_dbs(connection)
参数 | 描述
connection | 可选。规定 SQL 连接标识符。如果未规定，则使用上一个打开的连接。

说明

mysql_list_dbs() 将返回一个结果指针，包含了当前 MySQL 进程中所有可用的数据库。

用 mysql_tablename() 函数来遍历此结果指针，或者任何使用结果表的函数，例如 mysql_fetch_array()。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_list = mysql_list_dbs($con);

while ($db = mysql_fetch_object($db_list))
  {
  echo $db->Database . "<br />";
  }

mysql_close($con);
?>

输出类似：

mysql
test
test_db

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_list_processes() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_list_processes() 函数

PHP MySQL 函数

定义和用法

mysql_list_processes() 函数列出 MySQL 进程。

若成功，则 mysql_list_processes() 返回一个结果指针，说明了当前服务器的线程。如果失败，则返回 false。

语法

mysql_list_processes(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$my_list = mysql_list_processes($con);
while ($row = mysql_fetch_assoc($my_list))
  {
  print_r($row);
  }

mysql_close($con);
?>

输出类似：

Array
(
[Id] => 2
[User] => hello
[Host] => localhost:1038
[db] =>
[Command] => Processlist
[Time] => 0
[State] =>
[Info] =>
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_num_fields() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_num_fields() 函数

PHP MySQL 函数

定义和用法

mysql_num_fields() 函数返回结果集中字段的数。

如果失败，则返回 false。

语法

mysql_num_fields(data)
参数 | 描述
data | 必需。规定规定要使用的数据指针。该数据指针是 mysql_query() 函数产生的结果。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * FROM person";
$result = mysql_query($sql,$con);
echo mysql_num_fields($result);

mysql_close($con);
?>

输出类似：

3

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_num_rows() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_num_rows() 函数

PHP MySQL 函数

定义和用法

mysql_num_rows() 函数返回结果集中行的数目。

语法

mysql_num_rows(data)
参数 | 描述
data | 必需。结果集。该结果集从 mysql_query() 的调用中得到。

说明

mysql_num_rows() 返回结果集中行的数目。此命令仅对 SELECT 语句有效。要取得被 INSERT，UPDATE 或者 DELETE 查询所影响到的行的数目，用 mysql_affected_rows()。

提示和注释

注释：如果使用 mysql_unbuffered_query()，则直到结果集中的所有行都被提取后 mysql_num_rows() 才能返回正确的值。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * FROM person";
$result = mysql_query($sql,$con);
echo mysql_num_rows($result);

mysql_close($con);
?>

输出类似：

3

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_pconnect() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_pconnect() 函数

PHP MySQL 函数

定义和用法

mysql_pconnect() 函数打开一个到 MySQL 服务器的持久连接。

mysql_pconnect() 和 mysql_connect() 非常相似，但有两个主要区别：

  1. 当连接的时候本函数将先尝试寻找一个在同一个主机上用同样的用户名和密码已经打开的（持久）连接，如果找到，则返回此连接标识而不打开新连接。
  2. 其次，当脚本执行完毕后到 SQL 服务器的连接不会被关闭，此连接将保持打开以备以后使用（mysql_close() 不会关闭由 mysql_pconnect() 建立的连接）。

语法

mysql_pconnect(server,user,pwd,clientflag)
参数 | 描述
server

可选。规定要连接的服务器。

可以包括端口号，例如 "hostname:port"，或者到本地套接字的路径，例如对于 localhost 的 ":/path/to/socket"。

如果 PHP 指令 mysql.default_host 未定义（默认情况），则默认值是 'localhost:3306'。
user | 可选。用户名。默认值是服务器进程所有者的用户名。
pwd | 可选。密码。默认值是空密码。
clientflag

可选。client_flags 参数可以是以下常量的组合：

  • MYSQL_CLIENT_SSL - 使用 SSL 加密
  • MYSQL_CLIENT_COMPRESS - 使用压缩协议
  • MYSQL_CLIENT_IGNORE_SPACE - 允许函数名后的间隔
  • MYSQL_CLIENT_INTERACTIVE - 允许关闭连接之前的交互超时非活动时间

返回值

如果成功，则返回一个 MySQL 持久连接标识符，出错则返回 FALSE。

提示和注释

注释：可选参数 clientflag 自 PHP 4.3.0 版起可用。

提示：要创建一个非持久连接，请使用 mysql_connect() 函数。

例子

<?php
$con = mysql_pconnect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_ping() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_ping() 函数

PHP MySQL 函数

定义和用法

mysql_ping() 函数 Ping 一个服务器连接，如果没有连接则重新连接。

如果存在连接，则返回 true。如果失败，则返回 false。

语法

mysql_ping(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

提示和注释

注释：本函数可用于空闲很久的脚本来检查服务器是否关闭了连接。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
{
die('Could not connect: ' . mysql_error());
}

$db_selected = mysql_select_db("test_db", $con);
$sql = "SELECT * from Person";
$result = mysql_query($sql,$link);

mysql_ping();

// 一些代码...

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_query() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_query() 函数

PHP MySQL 函数

定义和用法

mysql_query() 函数执行一条 MySQL 查询。

语法

mysql_query(query,connection)
参数 | 描述
query | 必需。规定要发送的 SQL 查询。注释：查询字符串不应以分号结束。
connection | 可选。规定 SQL 连接标识符。如果未规定，则使用上一个打开的连接。

说明

如果没有打开的连接，本函数会尝试无参数调用 mysql_connect() 函数来建立一个连接并使用之。

返回值

mysql_query() 仅对 SELECT，SHOW，EXPLAIN 或 DESCRIBE 语句返回一个资源标识符，如果查询执行不正确则返回 FALSE。

对于其它类型的 SQL 语句，mysql_query() 在执行成功时返回 TRUE，出错时返回 FALSE。

非 FALSE 的返回值意味着查询是合法的并能够被服务器执行。这并不说明任何有关影响到的或返回的行数。很有可能一条查询执行成功了但并未影响到或并未返回任何行。

提示和注释

注释：该函数自动对记录集进行读取和缓存。如需运行非缓存查询，请使用 mysql_unbuffered_query()。

例子

例子 1

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$sql = "SELECT * FROM Person";
mysql_query($sql,$con);

// 一些代码

mysql_close($con);
?>

例子 2

通过 mysql_query() 函数创建一个新数据库：

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$sql = "CREATE DATABASE my_db";
if (mysql_query($sql,$con))
  {
  echo "Database my_db created";
  }
else
  {
  echo "Error creating database: " . mysql_error();
  }
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_real_escape_string() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_real_escape_string() 函数

PHP MySQL 函数

定义和用法

mysql_real_escape_string() 函数转义 SQL 语句中使用的字符串中的特殊字符。

下列字符受影响：

  • \x00
  • \n
  • \r
  • \
  • '
  • "
  • \x1a

如果成功，则该函数返回被转义的字符串。如果失败，则返回 false。

语法

mysql_real_escape_string(string,connection)
参数 | 描述
string | 必需。规定要转义的字符串。
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

说明

本函数将 string 中的特殊字符转义，并考虑到连接的当前字符集，因此可以安全用于 mysql_query()。

提示和注释

提示：可使用本函数来预防数据库攻击。

例子

例子 1

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

// 获得用户名和密码的代码

// 转义用户名和密码，以便在 SQL 中使用
$user = mysql_real_escape_string($user);
$pwd = mysql_real_escape_string($pwd);

$sql = "SELECT * FROM users WHERE
user='" . $user . "' AND password='" . $pwd . "'"

// 更多代码

mysql_close($con);
?>

例子 2

数据库攻击。本例演示如果我们不对用户名和密码应用 mysql_real_escape_string() 函数会发生什么：

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$sql = "SELECT * FROM users
WHERE user='{$_POST['user']}'
AND password='{$_POST['pwd']}'";
mysql_query($sql);

// 不检查用户名和密码
// 可以是用户输入的任何内容，比如：
$_POST['user'] = 'john';
$_POST['pwd'] = "' OR ''='";

// 一些代码...

mysql_close($con);
?>

那么 SQL 查询会成为这样：

SELECT * FROM users
WHERE user='john' AND password='' OR ''=''

这意味着任何用户无需输入合法的密码即可登陆。

例子 3

预防数据库攻击的正确做法：

<?php
function check_input($value)
{
// 去除斜杠
if (get_magic_quotes_gpc())
  {
  $value = stripslashes($value);
  }
// 如果不是数字则加引号
if (!is_numeric($value))
  {
  $value = "'" . mysql_real_escape_string($value) . "'";
  }
return $value;
}

$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

// 进行安全的 SQL
$user = check_input($_POST['user']);
$pwd = check_input($_POST['pwd']);
$sql = "SELECT * FROM users WHERE
user=$user AND password=$pwd";

mysql_query($sql);

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_result() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_result() 函数

PHP MySQL 函数

定义和用法

mysql_result() 函数返回结果集中一个字段的值。

如果成功，则该函数返回字段值。如果失败，则返回 false。

语法

mysql_result(data,row,field)
参数 | 描述
data | 必需。规定要使用的结果标识符。该标识符是 mysql_query() 函数返回的。
row | 必需。规定行号。行号从 0 开始。
field | 可选。规定获取哪个字段。可以是字段偏移值，字段名或 table.fieldname。 如果该参数未规定，则该函数从指定的行获取第一个字段。

说明

当作用于很大的结果集时，应该考虑使用能够取得整行的函数。这些函数在一次函数调用中返回了多个单元的内容，比 mysql_result() 快得多。

此外请注意，在字段参数中指定数字偏移量比指定字段名或者 tablename.fieldname 要快得多。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db", $con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

echo mysql_result($result,0);

mysql_close($con);

?>

输出类似：

Adams

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_select_db() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_select_db() 函数

PHP MySQL 函数

定义和用法

mysql_select_db() 函数设置活动的 MySQL 数据库。

如果成功，则该函数返回 true。如果失败，则返回 false。

语法

mysql_select_db(database,connection)
参数 | 描述
database | 必需。规定要选择的数据库。
connection | 可选。规定 MySQL 连接。如果未指定，则使用上一个连接。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db", $con);

if (!$db_selected)
  {
  die ("Can\'t use test_db : " . mysql_error());
  }

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_stat() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_stat() 函数

PHP MySQL 函数

定义和用法

mysql_stat() 函数返回 MySQL 服务器的当前系统状态。

如果成功，则该函数返回状态。如果失败，则返回 false。

语法

mysql_stat(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未指定，则使用上一个连接。

提示和注释

注释：mysql_stat() 目前只返回 uptime、threads、queries、open tables、flush tables 和 queries per second。要得到其它状态变量的完整列表，只能使用 SQL 命令 SHOW STATUS。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db", $con);

echo mysql_stat();
?>

输出类似：

Uptime: 99410 Threads: 1 Questions: 162
Slow queries: 0 Opens: 0 Flush tables: 1
Open tables: 0 Queries per second avg: 0.002

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_thread_id() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_thread_id() 函数

PHP MySQL 函数

定义和用法

mysql_thread_id() 函数返回当前线程的 ID。

如果成功，则该函数线程的 ID。如果失败，则返回 false。

语法

mysql_thread_id(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未指定，则使用上一个连接。

提示和注释

注释：每个 MySQL 连接的 线程 ID 是不同的。

例子

<?php
$con = mysql_connect("localhost", "peter", "abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

echo mysql_thread_id();

mysql_close($con);
?>

输出类似：

38

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_unbuffered_query() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_unbuffered_query() 函数

PHP MySQL 函数

定义和用法

mysql_unbuffered_query() 函数向 MySQL 发送一条 SQL 查询（不获取 / 缓存结果）。

语法

mysql_unbuffered_query(query,connection)
参数 | 描述
query | 必需。规定要发送的 SQL 查询。注释：查询字符串不应以分号结束。
connection | 可选。规定 SQL 连接标识符。如果未规定，则使用上一个打开的连接。

说明

mysql_unbuffered_query() 向 MySQL 发送一条 SQL 查询 query ，但不像 mysql_query() 那样自动获取并缓存结果集。一方面，这在处理很大的结果集时会节省可观的内存。另一方面，可以在获取第一行后立即对结果集进行操作，而不用等到整个 SQL 语句都执行完毕。

当使用多个数据库连接时，必须指定可选参数 connection。

提示和注释

注释：mysql_unbuffered_query() 的好处是有代价的：在 mysql_unbuffered_query() 返回的结果集之上不能使用 mysql_num_rows() 和 mysql_data_seek()。此外在向 MySQL 发送一条新的 SQL 查询之前，必须提取所有未缓存的 SQL 查询所产生的结果行。

例子

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

// 大型查询
$sql = "SELECT * FROM Person";

mysql_unbuffered_query($sql,$con);

// 开始处理数据...

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP MySQL 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP MySQL 函数

  • Previous Page
  • Next Page

PHP MySQL 简介

MySQL 函数允许您访问 MySQL 数据库服务器。

安装

为了能够顺利的使用本类函数，必须在编译 PHP 时添加对 MySQL 的支持。

编译时，只要使用 --with-mysql[=DIR] 配置选项即可，其中可选的 [DIR] 指向 MySQL 的安装目录。

虽然本 MySQL 扩展库兼容 MySQL 4.1.0 及其以后版本，但是它不支持这些版本提供的额外功能。要使用这些功能，请使用 MySQLi 扩展库。

如果要同时安装 mysql 扩展库和 mysqli 扩展库，必须使用同一个客户端库以避免任何冲突。

在 Linux 系统上安装

PHP 4

默认开启了 --with-mysql 选项。此默认行为可以用 --without-mysql 配置选项来禁止。如果启用 MySQL 而不指定安装目录的话，PHP 将使用绑定的 MySQL 客户端连接库。

还有其它应用程序使用 MySQL（例如 auth-mysql）的用户不要用绑定的库，而要指定 MySQL 的安装目录，如这样：--with-mysql=/path/to/mysql。这将强制 PHP 使用随 MySQL 安装的客户端连接库，就可以避免任何冲突。

PHP 5+

MySQL 默认未启用，也没有绑定的 MySQL 库。使用 --with-mysql[=DIR] 配置选项来加入 MySQL 的支持。可以从 MySQL 下载头文件和库。

在 Windows 系统上安装

PHP 4

PHP MySQL 扩展已经编译入 PHP。

PHP 5+

MySQL 默认未启用，因此必须在 php.ini 中激活 php_mysql.dll 动态连接库。此外，PHP 还需要访问 MySQL 客户端连接库。PHP 的 Windows 发行版包括了一个 libmysql.dll，为了让 PHP 能和 MySQL 对话，此文件必须放在 Windows 的系统路径 PATH 中。

要激活任何 PHP 扩展库（例如 php_mysql.dll），PHP 指令 extension_dir 要被设为 PHP 扩展库所在的目录。PHP 5 下 extension_dir 取值的一个例子是 c:\php\ext。

注释：如果启动 web 服务器时出现类似如下的错误："Unable to load dynamic library './php_mysql.dll'"，这是因为系统找不到 php_mysql.dll 和 / 或 libmysql.dll。

Runtime 配置

MySQL 函数的行为受到 php.ini 中设置的影响。

MySQL 配置选项：

名称 | 默认 | 描述 | 可更改
mysql.allow_persistent | "1" | 是否允许 MySQL 的持久连接。 | PHP_INI_SYSTEM
mysql.max_persistent | "-1" | 每个进程中最大的持久连接数目。 | PHP_INI_SYSTEM
mysql.max_links | "-1" | 每个进程中最大的连接数，包括持久连接。 | PHP_INI_SYSTEM
mysql.trace_mode | "0" | 跟踪模式。从 PHP 4.3.0 起可用。 | PHP_INI_ALL
mysql.default_port | NULL | 指定默认连接数据库的 TCP 端口号。 | PHP_INI_ALL
mysql.default_socket | NULL | 默认的 socket 名称。PHP 4.0.1起可用。 | PHP_INI_ALL
mysql.default_host | NULL | 默认的服务器地址。不适用于SQL安全模式。 | PHP_INI_ALL
mysql.default_user | NULL | 默认使用的用户名。不适用于SQL安全模式。 | PHP_INI_ALL
mysql.default_password | NULL | 默认使用的密码。不适用于SQL安全模式。 | PHP_INI_ALL
mysql.connect_timeout | "60" | 连接超时秒数。 | PHP_INI_ALL

资源类型

在 MySQL 模块中使用了两种资源类型。第一种是数据库的连接句柄，第二种是 SQL 查询返回的结果集。

PHP MySQL 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
mysql_affected_rows() | 取得前一次 MySQL 操作所影响的记录行数。 | 3
mysql_change_user() | 不赞成。改变活动连接中登录的用户 | 3
mysql_client_encoding() | 返回当前连接的字符集的名称 | 4
mysql_close() | 关闭非持久的 MySQL 连接。 | 3
mysql_connect() | 打开非持久的 MySQL 连接。 | 3
mysql_create_db() | 不赞成。新建 MySQL 数据库。使用 mysql_query() 代替。 | 3
mysql_data_seek() | 移动记录指针。 | 3
mysql_db_name() | 从对 mysql_list_dbs() 的调用返回数据库名称。 | 3
mysql_db_query() | 不赞成。发送一条 MySQL 查询。 使用 mysql_select_db() 和 mysql_query() 代替。 | 3
mysql_drop_db() | 不赞成。丢弃（删除）一个 MySQL 数据库。 使用 mysql_query() 代替。 | 3
mysql_errno() | 返回上一个 MySQL 操作中的错误信息的数字编码。 | 3
mysql_error() | 返回上一个 MySQL 操作产生的文本错误信息。 | 3
mysql_escape_string() | 不赞成。转义一个字符串用于 mysql_query。 使用 mysql_real_escape_string() 代替。 | 4
mysql_fetch_array() | 从结果集中取得一行作为关联数组，或数字数组，或二者兼有。 | 3
mysql_fetch_assoc() | 从结果集中取得一行作为关联数组。 | 4
mysql_fetch_field() | 从结果集中取得列信息并作为对象返回。 | 3
mysql_fetch_lengths() | 取得结果集中每个字段的内容的长度。 | 3
mysql_fetch_object() | 从结果集中取得一行作为对象。 | 3
mysql_fetch_row() | 从结果集中取得一行作为数字数组。 | 3
mysql_field_flags() | 从结果中取得和指定字段关联的标志。 | 3
mysql_field_len() | 返回指定字段的长度。 | 3
mysql_field_name() | 取得结果中指定字段的字段名。 | 3
mysql_field_seek() | 将结果集中的指针设定为指定的字段偏移量。 | 3
mysql_field_table() | 取得指定字段所在的表名。 | 3
mysql_field_type() | 取得结果集中指定字段的类型。 | 3
mysql_free_result() | 释放结果内存。 | 3
mysql_get_client_info() | 取得 MySQL 客户端信息。 | 4
mysql_get_host_info() | 取得 MySQL 主机信息。 | 4
mysql_get_proto_info() | 取得 MySQL 协议信息。 | 4
mysql_get_server_info() | 取得 MySQL 服务器信息。 | 4
mysql_info() | 取得最近一条查询的信息。 | 4
mysql_insert_id() | 取得上一步 INSERT 操作产生的 ID。 | 3
mysql_list_dbs() | 列出 MySQL 服务器中所有的数据库。 | 3
mysql_list_fields() | 不赞成。列出 MySQL 结果中的字段。 使用 mysql_query() 代替。 | 3
mysql_list_processes() | 列出 MySQL 进程。 | 4
mysql_list_tables() | 不赞成。列出 MySQL 数据库中的表。 使用Use mysql_query() 代替。 | 3
mysql_num_fields() | 取得结果集中字段的数目。 | 3
mysql_num_rows() | 取得结果集中行的数目。 | 3
mysql_pconnect() | 打开一个到 MySQL 服务器的持久连接。 | 3
mysql_ping() | Ping 一个服务器连接，如果没有连接则重新连接。 | 4
mysql_query() | 发送一条 MySQL 查询。 | 3
mysql_real_escape_string() | 转义 SQL 语句中使用的字符串中的特殊字符。 | 4
mysql_result() | 取得结果数据。 | 3
mysql_select_db() | 选择 MySQL 数据库。 | 3
mysql_stat() | 取得当前系统状态。 | 4
mysql_tablename() | 不赞成。取得表名。使用 mysql_query() 代替。 | 3
mysql_thread_id() | 返回当前线程的 ID。 | 4
mysql_unbuffered_query() | 向 MySQL 发送一条 SQL 查询（不获取 / 缓存结果）。 | 4

PHP MySQL 常量

在 PHP 4.3.0 以后的版本中，允许在 mysql_connect() 函数和 mysql_pconnect() 函数中指定更多的客户端标记：

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
MYSQL_CLIENT_COMPRESS | 使用压缩的通讯协议。 | 4.3
MYSQL_CLIENT_IGNORE_SPACE | 允许在函数名后留空格位。 | 4.3
MYSQL_CLIENT_INTERACTIVE | 在关闭连接前所允许的交互超时非活动时间。 | 4.3
MYSQL_CLIENT_SSL | 使用 SSL 加密（仅在 MySQL 客户端库版本为 4+ 时可用）。 | 4.3

mysql_fetch_array() 函数使用一个常量来表示所返回数组的类型：

常量 | 描述 | PHP
MYSQL_ASSOC | 返回的数据列使用字段名作为数组的索引名。 |
MYSQL_BOTH | 返回的数据列使用字段名及数字索引作为数组的索引名。 |
MYSQL_NUM | 返回的数据列使用数字索引作为数组的索引名。 索引从 0 开始，表示返回结果的第一个字段。 |
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP natcasesort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP natcasesort() 函数

PHP Array 函数

定义和用法

natcasesort() 函数用不区分大小写的自然顺序算法对给定数组中的元素排序。

natcasesort() 函数实现了“自然排序”，即数字从 1 到 9 的排序方法，字母从 a 到 z 的排序方法，短者优先，该函数不区分大小写。数组的索引与单元值保持关联。

如果成功，则该函数返回 TRUE，否则返回 FALSE。

语法

natcasesort(array)
参数 | 描述
array | 必需。规定要进行排序的数组。

提示和注释

提示：natcasesort() 是 natsort() 函数 的不区分大小写字母的版本。

例子

<?php
$temp_files = array("temp15.txt","Temp10.txt",
"temp1.txt","Temp22.txt","temp2.txt");

natsort($temp_files);
echo "Natural order: ";
print_r($temp_files);
echo "<br />";

natcasesort($temp_files);
echo "Natural order case insensitve: ";
print_r($temp_files);
?>

输出：

Natural order:
Array
(
[0] => Temp10.txt
[1] => Temp22.txt
[2] => temp1.txt
[4] => temp2.txt
[3] => temp15.txt
)

Natural order case insensitve:
Array
(
[2] => temp1.txt
[4] => temp2.txt
[0] => Temp10.txt
[3] => temp15.txt
[1] => Temp22.txt
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP natsort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP natsort() 函数

PHP Array 函数

定义和用法

natsort() 函数用自然顺序算法对给定数组中的元素排序。

natsort() 函数实现了“自然排序”，即数字从 1 到 9 的排序方法，字母从 a 到 z 的排序方法，短者优先。数组的索引与单元值保持关联。

如果成功，则该函数返回 TRUE，否则返回 FALSE。

语法

natsort(array)
参数 | 描述
array | 必需。规定要进行排序的数组。

例子

本函数所用的自然排序算法，与通常的计算机字符串排序算法（用于 sort()）的区别，见下面示例：

<?php
$temp_files = array("temp15.txt","temp10.txt",
"temp1.txt","temp22.txt","temp2.txt");

sort($temp_files);
echo "Standard sorting: ";
print_r($temp_files);
echo "<br />";

natsort($temp_files);
echo "Natural order: ";
print_r($temp_files);
?>

输出：

Standard sorting: Array
(
[0] => temp1.txt
[1] => temp10.txt
[2] => temp15.txt
[3] => temp2.txt
[4] => temp22.txt
)

Natural order: Array
(
[0] => temp1.txt
[3] => temp2.txt
[1] => temp10.txt
[2] => temp15.txt
[4] => temp22.txt
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP next() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP next() 函数

PHP Array 函数

定义和用法

next() 函数把指向当前元素的指针移动到下一个元素的位置，并返回当前元素的值。

如果内部指针已经超过数组的最后一个元素，函数返回 false。

语法

next(array)
参数 | 描述
array | 必需。规定要使用的数组。

说明

next() 和 current() 的行为类似，只有一点区别，在返回值之前将内部指针向前移动一位。这意味着它返回的是下一个数组单元的值并将数组指针向前移动了一位。如果移动指针的结果超出了数组单元的末端，则 next() 返回 FALSE。

注意：如果数组包含空的单元，或者单元的值是 0 则该函数碰到这些单元也返回 FALSE。要正确遍历可能含有空单元或者单元值为 0 的数组，请参见 each() 函数。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

echo current($people) . "<br />";
echo next($people);
?>

输出：

Peter
Joe

PHP Array 函数

PHP 参考手册
PHP 测验


PHP nl_langinfo() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP nl_langinfo() 函数

PHP String 函数

定义和用法

nl_langinfo() 函数返回指定的本地信息。

如果成功，则返回指定的本地信息。如果失败，则返回 false。

语法

nl_langinfo(element)
参数 | 描述
element | 必需。规定要返回哪个元素。必须是说明中列出的元素之一。

说明

时间和日历：

  • ABDAY_(1-7) - Abbreviated name of the numbered day of the week
  • DAY_(1-7) - Name of the numbered day of the week (DAY_1 = Sunday)
  • ABMON_(1-12) - Abbreviated name of the numbered month of the year
  • MON_(1-12) - Name of the numbered month of the year
  • AM_STR - String for Ante meridian
  • PM_STR - String for Post meridian
  • D_T_FMT - String that can be used as the format string for strftime() to represent time and date
  • D_FMT - String that can be used as the format string for strftime() to represent date
  • T_FMT - String that can be used as the format string for strftime() to represent time
  • T_FMT_AMPM - String that can be used as the format string for strftime() to represent time in 12-hour format with ante/post meridian
  • ERA - Alternate era
  • ERA_YEAR - Year in alternate era format
  • ERA_D_T_FMT - Date and time in alternate era format (string can be used in strftime())
  • ERA_D_FMT - Date in alternate era format (string can be used in strftime())
  • ERA_T_FMT - Time in alternate era format (string can be used in strftime())

货币类别：

  • INT_CURR_SYMBOL - Currency symbol (example: USD)
  • CURRENCY_SYMBOL - Currency symbol (example: $)
  • CRNCYSTR - Same as CURRENCY_SYMBOL
  • MON_DECIMAL_POINT - Monetary decimal point character
  • MON_THOUSANDS_SEP - Monetary thousands separator
  • POSITIVE_SIGN - Positive value character
  • NEGATIVE_SIGN -Negative value character
  • MON_GROUPING - Array displaying how monetary numbers are grouped (example: 1 000 000)
  • INT_FRAC_DIGITS - International fractional digits
  • FRAC_DIGITS - Local fractional digits
  • P_CS_PRECEDES - True (1) if currency symbol is placed in front of a positive value, False (0) if it is placed behind
  • P_SEP_BY_SPACE - True (1) if there is a spaces between the currency symbol and a positive value, False (0) otherwise
  • N_CS_PRECEDES - True (1) if currency symbol is placed in front of a negative value, False (0) if it is placed behind
  • N_SEP_BY_SPACE - True (1) if there is a spaces between the currency symbol and a negative value, False (0) otherwise
  • P_SIGN_POSN - Formatting setting. Possible return values:
    • 0 - Parentheses surround the quantity and currency symbol
    • 1 - The sign string is placed in front of the quantity and currency symbol
    • 2 - The sign string is placed after the quantity and currency symbol
    • 3 - The sign string is placed immediately in front of the currency symbol
    • 4 - The sign string is placed immediately after the currency symbol
  • N_SIGN_POSN - Formatting setting. Possible return values:
    • 0 - Parentheses surround the quantity and currency symbol
    • 1 - The sign string is placed in front of the quantity and currency symbol
    • 2 - The sign string is placed after the quantity and currency symbol
    • 3 - The sign string is placed immediately in front of the currency symbol
    • 4 - The sign string is placed immediately after the currency symbol

数字类别：

  • DECIMAL_POINT - Decimal point character
  • RADIXCHAR - Same as DECIMAL_POINT
  • THOUSANDS_SEP - Separator character for thousands
  • THOUSEP - Same as THOUSANDS_SEP
  • GROUPING - Array displaying how numbers are grouped (example: 1 000 000)

通信类别：

  • YESEXPR - Regex string for matching 'yes' input
  • NOEXPR - Regex string for matching 'no' input
  • YESSTR - Output string for 'yes'
  • NOSTR - Output string for 'no'

代码集类别：

  • CODESET Return a string with the name of the character encoding.

提示和注释

注释：money_format() 函数无法在 windows 平台上工作。

提示：与返回所有本地格式化信息的 localeconv() 函数不同，nl_langinfo() 返回指定的信息。

PHP String 函数

PHP 参考手册
PHP 测验


PHP nl2br() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP nl2br() 函数

PHP String 函数

定义和用法

nl2br() 函数在字符串中的每个新行 (\n) 之前插入 HTML 换行符 (<br />)。

语法

nl2br(string)
参数 | 描述
string | 必需。规定要检查的字符串。

例子

<?php
echo nl2br("One line.\nAnother line.");
?>

输出：

One line.
Another line.

HTML 代码：

One line.<br />
Another line.

PHP String 函数

PHP 参考手册
PHP 测验


PHP number_format() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP number_format() 函数

PHP String 函数

定义和用法

number_format() 函数通过千位分组来格式化数字。

语法

number_format(number,decimals,decimalpoint,separator)
参数 | 描述
number | 必需。要格式化的数字。 如果未设置其他参数，则数字会被格式化为不带小数点且以逗号 (,) 作为分隔符。
decimals | 可选。规定多少个小数。如果设置了该参数，则使用点号 (.) 作为小数点来格式化数字。
decimalpoint | 可选。规定用作小数点的字符串。
separator | 可选。规定用作千位分隔符的字符串。 仅使用该参数的第一个字符。比如 "xyz" 仅输出 "x"。 注释：如果设置了该参数，那么所有其他参数都是必需的。

提示和注释

注释：该函数支持一个、两个或四个参数（不是三个）。

例子

<?php
echo number_format("1000000");
echo number_format("1000000",2);
echo number_format("1000000",2,",",".");
?>

输出：

1,000,000
1,000,000.00
1.000.000,00

PHP String 函数

PHP 参考手册
PHP 测验


PHP octdec() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP octdec() 函数

PHP Math 函数

定义和用法

octdec() 函数把八进制转换为十进制。

语法

octdec(octal_string)
参数 | 描述
octal_string | 必需。规定要转换的八进制数。

说明

返回 octal_string 参数所表示的八进制数的十进制等值。可转换的最大的数值为 17777777777 或十进制的 2147483647。从 PHP 4.1.0 开始，该函数可以处理大数字，这种情况下，它会返回 float 类型。

例子

<?php
echo octdec("36");
echo octdec("12");
echo octdec("3063");
echo octdec("106");
?>

输出类似：

30
10
1587
70

PHP Math 函数

PHP 参考手册
PHP 测验


PHP opendir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP opendir() 函数

PHP Directory 函数

定义和用法

opendir() 函数打开一个目录句柄，可由 closedir()，readdir() 和 rewinddir() 使用。

若成功，则该函数返回一个目录流，否则返回 false 以及一个 error。可以通过在函数名前加上 "@" 来隐藏 error 的输出。

语法

opendir(path,context)
参数 | 描述
path | 必需。规定要打开的目录路径。
context | 可选。规定目录句柄的环境。context 是可修改目录流的行为的一套选项。

提示和注释

注释：从 PHP 5.0.0 开始，path 参数支持 ftp:// URL wrapper。

注释：在 PHP 4.3.0 中， path 参数可以是任何支持目录列表的 URL，不过在 PHP 4 中只有 file:// URL wrapper 支持此功能。

例子

例子 1

<?php
//打开 images 目录
$dir = opendir("images");

//列出 images 目录中的文件
while (($file = readdir($dir)) !== false)
  {
  echo "filename: " . $file . "<br />";
  }
  closedir($dir);
?>

输出：

filename: .
filename: ..
filename: cat.gif
filename: dog.gif
filename: food
filename: horse.gif

例子 2

如果 opendir() 的输出失败，本例会隐藏错误：

<?php
//打开 images 目录
$dir = @ opendir("images");

//列出 images 目录中的文件
while (($file = readdir($dir)) !== false)
  {
  echo "filename: " . $file . "<br />";
  }
  closedir($dir);
?>

输出：

filename: .
filename: ..
filename: cat.gif
filename: dog.gif
filename: food
filename: horse.gif

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP ord() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ord() 函数

PHP String 函数

定义和用法

ord() 函数返回字符串第一个字符的 ASCII 值。

语法

ord(string)
参数 | 描述
string | 必需。要从中获得 ASCII 值的字符串。

例子

<?php
echo ord("h");
echo ord("hello");
?>

输出：

104
104

PHP String 函数

PHP 参考手册
PHP 测验


PHP pack() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP pack() 函数

PHP 杂项函数

定义和用法

pack() 函数把数据装入一个二进制字符串。

语法

pack(format,args+)
参数 | 描述
format | 必需。规定在包装数据时所使用的格式。
args+ | 可选。规定被包装的一个或多个参数。

format 参数的可能值：

  • a - NUL-padded string
  • A - SPACE-padded string
  • h - Hex string, low nibble first
  • H - Hex string, high nibble first
  • c - signed char
  • C - unsigned char
  • s - signed short (always 16 bit, machine byte order)
  • S - unsigned short (always 16 bit, machine byte order)
  • n - unsigned short (always 16 bit, big endian byte order)
  • v - unsigned short (always 16 bit, little endian byte order)
  • i - signed integer (machine dependent size and byte order)
  • I - unsigned integer (machine dependent size and byte order)
  • l - signed long (always 32 bit, machine byte order)
  • L - unsigned long (always 32 bit, machine byte order)
  • N - unsigned long (always 32 bit, big endian byte order)
  • V - unsigned long (always 32 bit, little endian byte order)
  • f - float (machine dependent size and representation)
  • d - double (machine dependent size and representation)
  • x - NUL byte
  • X - Back up one byte
  • @ - NUL-fill to absolute position

例子

例子 1

<?php
echo pack("C3",80,72,80);
?>

输出：

PHP

例子 2

<?php
echo pack("C*",80,72,80);
?>

输出：

PHP

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP parse_ini_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP parse_ini_file() 函数

PHP Filesystem 函数

定义和用法

parse_ini_file() 函数解析一个配置文件，并以数组的形式返回其中的设置。

语法

parse_ini_file(file,process_sections)
参数 | 描述
file | 必需。规定要检查的 ini 文件。
process_sections | 可选。如果设置为 true，则返回一个多维数组，包括了配置文件中每一节的名称和设置。默认是 false。

说明

ini 文件的结构和 php.ini 的相似。

常量也可以在 ini 文件中被解析，因此如果在运行 parse_ini_file() 之前定义了常量作为 ini 的值，将会被集成到结果中去。只有 ini 的值会被求值。

由数字组成的键名和小节名会被 PHP 当作整数来处理，因此以 0 开头的数字会被当作八进制而以 0x 开头的会被当作十六进制。

提示和注释

注释：本函数可以用来读取你自己的应用程序的配置文件。本函数与 php.ini 文件没有关系，该文件在运行脚本时就已经处理过了。

注释：如果 ini 文件中的值包含任何非字母数字的字符，需要将其括在双引号中（"）。

注释：有些保留字不能作为 ini 文件中的键名，包括：null，yes，no，true 和 false。值为 null，no 和 false 等效于 ""，值为 yes 和 true 等效于 "1"。字符 {}|"~![()" 也不能用在键名的任何地方，而且这些字符在选项值中有着特殊的意义。

注释：自 PHP 5.0 版本开始，该函数也处理选项值内的新行。

例子

例子 1

"test.ini" 的内容：

[names]
me = Robert
you = Peter

[urls]
first = "http://www.example.com"
second = "http://www.w3school.com.cn"

PHP 代码：

<?php
print_r(parse_ini_file("test.ini"));
?>

输出：

Array
(
[me] => Robert
[you] => Peter
[first] => http://www.example.com
[second] => http://www.w3school.com.cn
)

例子 2

"test.ini" 的内容：

[names]
me = Robert
you = Peter

[urls]
first = "http://www.example.com"
second = "http://www.w3school.com.cn"

PHP 代码（process_sections 设置为 true）：

<?php
print_r(parse_ini_file("test.ini",true));
?>

输出：

Array
(
[names] => Array
  (
  [me] => Robert
  [you] => Peter
  )
[urls] => Array
  (
  [first] => http://www.example.com
  [second] => http://www.w3school.com.cn
  )
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP parse_str() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP parse_str() 函数

PHP String 函数

定义和用法

parse_str() 函数把查询字符串解析到变量中。

语法

parse_str(string,array)
参数 | 描述
string | 必需。规定要解析的字符串。
array | 可选。规定存储变量的数组名称。该参数指示变量存储到数组中。

提示和注释

注释：如果未设置 array 参数，由该函数设置的变量将覆盖已由同名变量。

注释：php.ini 中的 magic_quotes_gpc 设置影响该函数的输出。如果已启用，那么在 parse_str() 解析之前，变量会被 addslashes() 转换。

例子

例子 1

<?php
parse_str("id=23&name=John%20Adams");
echo $id."<br />";
echo $name;
?>

输出：

23
John Adams

例子 2

<?php
parse_str("id=23&name=John%20Adams",$myArray);
print_r($myArray);
?>

输出：

Array
(
[id] => 23
[name] => John Adams
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP pathinfo() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP pathinfo() 函数

PHP Filesystem 函数

定义和用法

pathinfo() 函数以数组的形式返回文件路径的信息。

语法

pathinfo(path,options)
参数 | 描述
path | 必需。规定要检查的路径。
process_sections

可选。规定要返回的数组元素。默认是 all。

可能的值：

  • PATHINFO_DIRNAME - 只返回 dirname
  • PATHINFO_BASENAME - 只返回 basename
  • PATHINFO_EXTENSION - 只返回 extension

说明

pathinfo() 返回一个关联数组包含有 path 的信息。

包括以下的数组元素：

  • [dirname]
  • [basename]
  • [extension]

提示和注释

注释：如果不是要求取得所有单元，则 pathinfo() 函数返回字符串。

例子

例子 1

<?php
print_r(pathinfo("/testweb/test.txt"));
?>

输出：

Array
(
[dirname] => /testweb
[basename] => test.txt
[extension] => txt
)

例子 2

<?php
print_r(pathinfo("/testweb/test.txt",PATHINFO_BASENAME));
?>

输出：

test.txt

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP pclose() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP pclose() 函数

PHP Filesystem 函数

定义和用法

pclose() 函数关闭由 popen() 打开的管道。

语法

pclose(pipe)
参数 | 描述
pipe | 必需。规定由 popen() 打开的管道。

说明

该函数返回运行的进程的终止状态。

若出错，则返回 false。

例子

<?php
$file = popen("/bin/ls","r");

//一些要执行的代码

pclose($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP pi() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP pi() 函数

PHP Math 函数

定义和用法

pi() 函数返回圆周率的值。

语法

pi()

说明

返回圆周率的近似值。返回值的 float 精度是由 php.ini 中的 precision 指令确定。默认值是 14。您也可以使用 M_PI 常量，该常量产生与 pi() 完全相同的结果。

例子

<?php
echo pi();
?>

输出类似：

3.14159265359

PHP Math 函数

PHP 参考手册
PHP 测验


PHP popen() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP popen() 函数

PHP Filesystem 函数

定义和用法

popen() 函数打开进程文件指针。

语法

popen(command,mode)
参数 | 描述
command | 必需。规定要执行的命令。
mode 必需。规定连接模式。 可能的值：
  • r: 只读。
  • w: 只写 (打开并清空已有文件或创建一个新文件)

说明

打开一个指向进程的管道，该进程由派生指定的 command 命令执行而产生。

返回一个和 fopen() 所返回的相同的文件指针，只不过它是单向的（只能用于读或写）并且必须用 pclose() 来关闭。此指针可以用于 fgets()，fgetss() 和 fwrite()。

若出错，则返回 false。

例子

<?php
$file = popen("/bin/ls","r");

//一些要执行的代码

pclose($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP pos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP pos() 函数

PHP Array 函数

定义和用法

pos() 函数是 current() 函数 的别名。它可返回数组中当前元素的值。

语法

pos(array)
参数 | 描述
array | 必需。规定要使用的数组。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");
echo pos($people) . "<br />";
?>

输出：

Peter

PHP Array 函数

PHP 参考手册
PHP 测验


PHP pow() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP pow() 函数

PHP Math 函数

定义和用法

pow() 函数返回 x 的 y 次方。

语法

pow(x,y)
参数 | 描述
x | 必需。一个数。
y | 必需。一个数。

说明

返回 x 的 y 次方的幂。如果可能，本函数会返回 integer。

如果不能计算幂，将发出一条警告，pow() 将返回 false。PHP 4.2.0 版开始 pow() 不要产生任何的警告。

例子

<?php
echo pow(4,2);
echo pow(6,2);
echo pow(-6,2);
echo pow(-6,-2);
echo pow(-6,5.5);
?>

输出类似：

16
36
36
0.0277777777778
-1.#IND

PHP Math 函数

PHP 参考手册
PHP 测验


PHP prev() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP prev() 函数

PHP Array 函数

定义和用法

next() 函数把指向当前元素的指针移动到上一个元素的位置，并返回当前元素的值。

如果内部指针已经超过数组的第一个元素之前，函数返回 false。

语法

next(array)
参数 | 描述
array | 必需。规定要使用的数组。

说明

prev() 和 next() 的行为类似，不过它将内部指针倒回一位而不是前移一位。

注意：如果数组包含空的单元，或者单元的值是 0 则该函数碰到这些单元也返回 FALSE。要正确遍历可能含有空单元或者单元值为 0 的数组，请参见 each() 函数。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

echo current($people) . "<br />";
echo next($people) . "<br />";
echo prev($people);
?>

输出：

Peter
Joe
Peter

PHP Array 函数

PHP 参考手册
PHP 测验


PHP print() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP print() 函数

PHP String 函数

定义和用法

print() 函数输出一个或多个字符串。

语法

print(strings)
参数 | 描述
strings | 必需。发送到输出的一个或多个字符串。

提示和注释

注释：print() 函数实际上不是函数，所以您不必对它使用括号。

注释：print() 函数稍慢于 echo()。

例子

例子 1

<?php
$str = "Who's John Adams?";
print $str;
print "<br />";
print $str."<br />I don't know!";
?>

输出：

Who's John Adams?
Who's John Adams?
I don't know!

例子 2

<?php
print "This text
spans multiple
lines.";
?>

输出：

This text spans multiple lines.

例子 3

<?php
$color = "red";
print "Roses are $color";
print "<br />";
print 'Roses are $color';
?>

输出：

Roses are red
Roses are $color

PHP String 函数

PHP 参考手册
PHP 测验


PHP printf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP printf() 函数

PHP String 函数

定义和用法

printf() 函数输出格式化的字符串。

语法

printf(format,arg1,arg2,arg++)
参数 | 描述
format | 必需。规定字符串以及如何格式化其中的变量。
arg1 | 必需。规定插到格式化字符串中第一个 % 符号处的参数。
arg2 | 可选。规定插到格式化字符串中第二个 % 符号处的参数。
arg++ | 可选。规定插到格式化字符串中第三、四等等 % 符号处的参数。

说明

arg1, arg2, ++ 等参数将插入到主字符串中的百分号 (%) 符号处。该函数是逐步执行的。在第一个 % 符号中，插入 arg1，在第二个 % 符号处，插入 arg2，依此类推。

提示和注释

注释：如果 % 符号多于 arg 参数，则您必须使用占位符。占位符被插入 % 符号之后，由数字和 "\$" 组成。请参见例子 3。

注释：
相关函数：
fprintf()、
sprintf()、
vfprintf()、
vprintf() 以及
vsprintf()。

例子

例子 1

<?php
$str = "Hello";
$number = 123;
printf("%s world. Day number %u",$str,$number);
?>

输出：

Hello world. Day number 123

例子 2

<?php
$number = 123;
printf("%f",$number);
?>

输出：

123.000000

例子 3

使用占位符：

<?php
$number = 123;
printf("With 2 decimals: %1\$.2f<br />With no decimals: %1\$u",$number);
?>

输出：

With 2 decimals: 123.00
With no decimals: 123

PHP String 函数

PHP 参考手册
PHP 测验


PHP quoted_printable_decode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP quoted_printable_decode() 函数

PHP String 函数

定义和用法

quoted_printable_decode() 函数对经过 quoted-printable 编码后的字符串进行解码，返回 8 位的字符串。

该函数类似于 imap_qprint() 函数。不同的是，应用 imap_qprint() 函数需要让系统加载 IMAP 模块，而本函数不需要加载 IMAP 模块。

语法

quoted_printable_decode(string)
参数 | 描述
string | 必需。规定要解码的 quoted-printable 字符串。

例子

在本例中，应用 quoted_printable_decode() 函数对经过 quoted-printable 编码后的字符串 "=0A" 进行解码，并返回 8 位的字符串：

<?php
$str = "Hello=0Aworld.";
echo quoted_printable_decode($str);
?>

输出：

Hello world.

HTML 源代码：

Hello
world.

PHP String 函数

PHP 参考手册
PHP 测验


PHP quotemeta() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP quotemeta() 函数

PHP String 函数

定义和用法

quotemeta() 函数在字符串中某些预定义的字符前添加反斜杠。

这些预定义字符是：

  • 句号 (.)
  • 反斜杠 (\)
  • 加号 (+)
  • 星号 (*)
  • 问号 (?)
  • 方括号 ([])
  • 脱字符号 (^)
  • 美元符号 ($)
  • 圆括号 (())

语法

quotemeta(string)
参数 | 描述
string | 必需。规定要检查的字符串。

提示和注释

提示：该函数可用于转义拥有特殊意义的字符，比如 SQL 中的 ( )、[ ] 以及 *。

例子

<?php
$str = "Hello world. (can you hear me?)";
echo quotemeta($str);
?>

输出：

Hello world\. \(can you hear me\?\)

PHP String 函数

PHP 参考手册
PHP 测验


PHP rad2deg() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rad2deg() 函数

PHP Math 函数

定义和用法

rad2deg() 函数把弧度数转换为角度数。

语法

rad2deg(radian_number)
参数 | 描述
radian_number | 必需。规定要转换的弧度。

说明

本函数将 radian_number 从弧度转换为角度。

例子

<?php
$rad = M_PI;
$deg = rad2deg($rad);
echo "$rad radians is equal to $deg degrees";
?>

输出类似：

3.14159265359 radians is equal to 180 degrees

PHP Math 函数

PHP 参考手册
PHP 测验


PHP rand() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rand() 函数

PHP Math 函数

定义和用法

rand() 函数返回随机整数。

语法

rand(min,max)
参数 | 描述
min,max | 可选。规定随机数产生的范围。

说明

如果没有提供可选参数 min 和 max，rand() 返回 0 到 RAND_MAX 之间的伪随机整数。例如，想要 5 到 15（包括 5 和 15）之间的随机数，用 rand(5, 15)。

提示和注释

注释：在某些平台下（例如 Windows）RAND_MAX 只有 32768。如果需要的范围大于 32768，那么指定 min 和 max 参数就可以生成大于 RAND_MAX 的数了，或者考虑用 mt_rand() 来替代它。

注释：自 PHP 4.2.0 起，不再需要用 srand() 或 mt_srand() 函数给随机数发生器播种，现在已自动完成。

注释：在 3.0.7 之前的版本中，max 的含义是 range 。要在这些版本中得到和上例相同 5 到 15 的随机数，简短的例子是 rand (5, 11)。

例子

本例会返回一些随机数：

<?php
echo(rand();
echo(rand();
echo(rand(10,100))
?>

输出：

17757
3794
97

PHP Math 函数

PHP 参考手册
PHP 测验


PHP range() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP range() 函数

PHP Array 函数

定义和用法

range() 函数创建并返回一个包含指定范围的元素的数组。

语法

range(first,second,step)
参数 | 描述
first | 必需。规定数组元素的最小值。
second | 必需。规定数组元素的最大值。
step | 可选。规定元素之间的步进制。默认是 1。 注释：该参数是 PHP 5 中加入的。

说明

该函数创建一个数组，包含从 first 到 second （包含 first 和 second）之间的整数或字符。如果 second 比 first 小，则返回反序的数组。

例子 1

<?php
$number = range(0,5);
print_r ($number);
?>

输出：

Array
(
[0] => 0
[1] => 1
[2] => 2
[3] => 3
[4] => 4
[5] => 5
)

例子 2

<?php
$number = range(0,50,10);
print_r ($number);
?>

输出：

Array
(
[0] => 0
[1] => 10
[2] => 20
[3] => 30
[4] => 40
[5] => 50
)

例子 3

<?php
$letter = range("a","d");
print_r ($letter);
?>

输出：

Array
(
[0] => a
[1] => b
[2] => c
[3] => d
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP readdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP readdir() 函数

PHP Directory 函数

定义和用法

readdir() 函数返回由 opendir() 打开的目录句柄中的条目。

若成功，则该函数返回一个文件名，否则返回 false。

语法

readdir(dir_stream)
参数 | 描述
dir_stream | 必需。规定要使用的目录句柄。

说明

返回目录中下一个文件的文件名。文件名以在文件系统中的排序返回。

例子

<?php
//打开 images 目录
$dir = opendir("images");

//列出 images 目录中的文件
while (($file = readdir($dir)) !== false)
  {
  echo "filename: " . $file . "<br />";
  }
  closedir($dir);
?>

输出：

filename: .
filename: ..
filename: cat.gif
filename: dog.gif
filename: food
filename: horse.gif

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP readfile() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP readfile() 函数

PHP Filesystem 函数

定义和用法

readfile() 函数输出一个文件。

该函数读入一个文件并写入到输出缓冲。

若成功，则返回从文件中读入的字节数。若失败，则返回 false。您可以通过 @readfile() 形式调用该函数，来隐藏错误信息。

语法

readfile(filename,include_path,context)
参数 | 描述
filename | 必需。规定要读取的文件。
include_path | 必需。如果也想在 include_path 中搜索文件，可以使用该参数并将其设为 true。
context | 必需。规定文件句柄的环境。Context 是可以修改流的行为的一套选项。

说明

对 context 参数的支持是 PHP 5.0.0 添加的。

提示和注释

提示：如果在 php.ini 文件中 "fopen wrappers" 已经被激活，则在本函数中可以把 URL 作为文件名来使用。

例子

<?php
echo readfile("test.txt");
?>

输出：

There are two lines in this file.
This is the last line.
57

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP readlink() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP readlink() 函数

PHP Filesystem 函数

定义和用法

readlink() 函数返回符号连接指向的目标。

若成功，则该函数返回连接的目标。若失败，则返回 false。

语法

readlink(linkpath)
参数 | 描述
linkpath | 必需。规定要检查的连接路径。

提示和注释

注释：本函数未在 Windows 平台下实现。。

例子

<?php
echo readlink("/user/testlink");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP realpath() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP realpath() 函数

PHP Filesystem 函数

定义和用法

realpath() 函数返回绝对路径。

该函数删除所有符号连接（比如 '/./', '/../' 以及多余的 '/'），返回绝对路径名。

若失败，则返回 false。比如说文件不存在的话。

语法

readlink(linkpath)
参数 | 描述
linkpath | 必需。规定要检查的连接路径。

说明

在 BSD 系统上，如果仅仅是 linkpath 不存在的话，PHP 并不会像其它系统那样返回 false。

例子

<?php
echo realpath("test.txt");
?>

输出：

C:\Inetpub\testweb\test.txt

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP registerXPathNamespace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP registerXPathNamespace() 函数

PHP SimpleXML 函数

定义和用法

registerXPathNamespace() 函数为下一次 XPath 查询创建命名空间语境。

语法

class SimpleXMLElement
{
string registerXPathNamespace(prefix,ns)
}
参数 | 描述
prefix | 必需。规定命名空间前缀。
ns | 必需。规定命名空间 URL。必须匹配 XML 文档中的命名空间。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note xmlns:b="http://www.w3school.com.cn/example/">
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<b:body>Don't forget the meeting!</b:body>
</note>

PHP 代码：

<?php
$xml = simplexml_load_file("test.xml");

$xml->registerXPathNamespace("msg", "http://www.w3school.com.cn/example/");
$result = $xml->xpath("msg:body");

foreach ($result as $message)
  {
  echo $message;
  }
?>

输出类似：

Don't forget the meeting!

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP rename() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rename() 函数

PHP Filesystem 函数

定义和用法

rename() 函数重命名文件或目录。

若成功，则该函数返回 true。若失败，则返回 false。

语法

rename(oldname,newname,context)
参数 | 描述
oldname | 必需。规定要重命名的文件或目录。
newname | 必需。规定文件或目录的新名称。
context | 必需。规定文件句柄的环境。Context 是可修改流的行为的一套选项。

提示和注释

注释：在 PHP 4.3.3 之前，rename() 不能在基于 *nix 的系统中跨磁盘分区重命名文件。

注释：用于 oldname 中的封装协议必须和用于 newname 中的相匹配。

注释：对 context 的支持是 PHP 5.0.0 添加的。

例子

<?php
rename("images","pictures");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP reset() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP reset() 函数

PHP Array 函数

定义和用法

reset() 函数把数组的内部指针指向第一个元素，并返回这个元素的值。

若失败，则返回 FALSE。

语法

reset(array)
参数 | 描述
array | 必需。规定要使用的数组。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

echo current($people) . "<br />";
echo next($people) . "<br />";
echo reset($people);
?>

输出：

Peter
Joe
Peter

PHP Array 函数

PHP 参考手册
PHP 测验


PHP restore_error_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP restore_error_handler() 函数

PHP Error 和 Logging 函数

定义和用法

restore_error_handler() 函数恢复之前的错误处理程序，该程序是由 set_error_handler() 函数改变的。

该函数永远返回 true。

语法

restore_error_handler()

提示和注释

提示：之前的错误处理程序可能是在错误处理程序或用户自定义函数中构建的。

例子

<?php
//custom error handler function
function customError($errno, $errstr, $errfile, $errline)
 {
 echo "<b>Custom error:</b> [$errno] $errstr<br />";
 echo " Error on line $errline in $errfile<br />";
 }

//set user-defined error handler
set_error_handler("customError");

$test=2;

//trigger error
if ($test>1)
 {
 trigger_error("A custom error has been triggered");
 }

//restore built-in error handler
restore_error_handler

//trigger error again
if ($test>1)
 {
 trigger_error("A custom error has been triggered");
 }
?>

输出：

Custom error: [1024] A custom error has been triggered
Error on line 14 in C:\webfolder\test.php

Notice: A custom error has been triggered in
C:\webfolder\test.php on line 21

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP restore_exception_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP restore_exception_handler() 函数

PHP Error 和 Logging 函数

定义和用法

restore_exception_handler() 函数恢复之前的异常处理程序，该程序是由 set_exception_handler() 函数改变的。

该函数永远返回 true。

语法

restore_exception_handler()

提示和注释

提示：之前的异常处理程序可能是在异常处理程序或用户自定义函数中构建的。

例子

<?php
restore_exception_handler();

throw new Exception('Uncaught Exception occured');
?>

输出：

Fatal error: Uncaught exception 'Exception' with message
'Uncaught Exception occured' in C:\webfolder\test.php:4
Stack trace: #0 {main} thrown in C:\webfolder\test.php on line 4

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP rewind() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rewind() 函数

PHP Filesystem 函数

定义和用法

rewind() 函数将文件指针的位置倒回文件的开头。

若成功，则返回 true。若失败，则返回 false。

语法

rewind(file)
参数 | 描述
file | 必需。规定已打开的文件。

例子

<?php
$file = fopen("test.txt","r");

//改变文件指针的位置
fseek($file,"15");

//把文件指针设定为 0
rewind($file);

fclose($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP rewinddir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rewinddir() 函数

PHP Directory 函数

定义和用法

rewinddir() 函数重置由 opendir() 打开的目录句柄。

本函数什么都不会返回。

语法

rewinddir(dir_stream)
参数 | 描述
dir_stream | 必需。规定要使用的目录句柄。

提示和注释

提示：本函数重读目录，并可用于检查目录中的变化。

例子

<?php
//打开 images 目录
$dir = opendir("images");

//列出 images 目录中的文件
while (($file = readdir($dir)) !== false)
  {
  echo "filename: " . $file . "<br />";
  }

//重置目录流
rewinddir($dir);

//供检查变化的代码

closedir($dir);
?>

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP rmdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rmdir() 函数

PHP Filesystem 函数

定义和用法

rmdir() 函数删除空的目录。

若成功，则该函数返回 true。若失败，则返回 false。

语法

rmdir(dir,context)
参数 | 描述
dir | 必需。规定要删除的目录。
context | 必需。规定文件句柄的环境。Context 是可修改流的行为的一套选项。

说明

尝试删除 dir 所指定的目录。 该目录必须是空的，而且要有相应的权限。

提示和注释

注释：对 context 的支持是 PHP 5.0.0 添加的。

例子

<?php
$path = "images";
if(!rmdir($path))
  {
  echo ("Could not remove $path");
  }
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP round() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP round() 函数

PHP Math 函数

定义和用法

round() 函数对浮点数进行四舍五入。

语法

round(x,prec)
参数 | 描述
x | 可选。规定要舍入的数字。
prec | 可选。规定小数点后的位数。

说明

返回将 x 根据指定精度 prec （十进制小数点后数字的数目）进行四舍五入的结果。prec 也可以是负数或零（默认值）。

提示和注释

注释：PHP 默认不能正确处理类似 "12,300.2" 的字符串。

注释：prec 参数是在 PHP 4 中被引入的。。

例子

<?php
echo(round(0.60));
echo(round(0.50));
echo(round(0.49));
echo(round(-4.40));
echo(round(-4.60));
?>

输出：

1
1
0
-4
-5

PHP Math 函数

PHP 参考手册
PHP 测验


PHP rsort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rsort() 函数

PHP Array 函数

定义和用法

rsort() 函数对数组的元素按照键值进行逆向排序。与 arsort() 的功能基本相同。

注释：该函数为 array 中的单元赋予新的键名。这将删除原有的键名而不仅是重新排序。

如果成功则返回 TRUE，否则返回 FALSE。

可选的第二个参数包含另外的排序标志。

语法

rsort(array,sorttype)
参数 | 描述
array | 必需。输入的数组。
sorttype

可选。规定如何排列数组的值。可能的值：

  • SORT_REGULAR - 默认。以它们原来的类型进行处理（不改变类型）。
  • SORT_NUMERIC - 把值作为数字来处理
  • SORT_STRING - 把值作为字符串来处理
  • SORT_LOCALE_STRING - 把值作为字符串来处理，基于本地设置*。

*：该值是 PHP 4.4.0 和 5.0.2 新加的。在 PHP 6 之前，使用了系统的区域设置，可以用 setlocale() 来改变。自 PHP 6 起，必须用 i18n_loc_set_default() 函数。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");
rsort($my_array);
print_r($my_array);
?>

输出：

Array
(
[0] => Horse
[1] => Dog
[2] => Cat
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP rtrim() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rtrim() 函数

PHP String 函数

定义和用法

chop() 函数从字符串的末端开始删除空白字符或其他预定义字符。

语法

rtrim(string,charlist)
参数 | 描述
string | 必需。规定要转换的字符串。
charlist

可选。规定从字符串中删除哪些字符。

如果未设置该参数，则全部删除以下字符：

  • "\0" - ASCII 0, NULL
  • "\t" - ASCII 9, 制表符
  • "\n" - ASCII 10, 新行
  • "\x0B" - ASCII 11, 垂直制表符
  • "\r" - ASCII 13, 回车
  • " " - ASCII 32, 空格

例子

在本例中，我们将使用 rtrim() 函数从字符串右端删除字符：

<?php
$str = "Hello World!\n\n";
echo $str;
echo rtrim($str);
?>

以上代码输出的源代码：

<html>

<body>
Hello World!

Hello World!</body>

</html>

输出：

Hello World! Hello World!

PHP String 函数

PHP 参考手册
PHP 测验


PHP scandir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP scandir() 函数

PHP Directory 函数

定义和用法

scandir() 函数返回一个数组，其中包含指定路径中的文件和目录。

若成功，则返回一个数组，若失败，则返回 false。如果 directory 不是目录，则返回布尔值 false 并生成一条 E_WARNING 级的错误。

语法

scandir(directory,sort,context)
参数 | 描述
directory | 必需。规定要扫描的目录。
sort | 可选。规定排列顺序。默认是 0 （升序）。如果是 1，则为降序。
context | 可选。规定目录句柄的环境。context 是可修改目录流的行为的一套选项。

例子

<?php
print_r(scandir("images"));
?>

输出：

Array
(
[0] => .
[1] => ..
[2] => dog.jpg
[3] => house.jpg
[4] => logo.gif
)

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP set_error_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP set_error_handler() 函数

PHP Error 和 Logging 函数

定义和用法

set_error_handler() 函数设置用户自定义的错误处理函数。

该函数用于创建运行时期间的用户自己的错误处理方法。

该函数会返回旧的错误处理程序，若失败，则返回 null。

语法

set_error_handler(error_function,error_types)
参数 | 描述
error_function | 必需。规定发生错误时运行的函数。
error_types | 可选。规定在哪个错误报告级别会显示用户定义的错误。默认是 "E_ALL"。

提示和注释

提示：如果使用了该函数，会完全绕过标准的 PHP 错误处理函数，如果必要，用户定义的错误处理程序必须终止 (die() ) 脚本。

注释：如果在脚本执行前发生错误，由于在那时自定义程序还没有注册，因此就不会用到这个自定义错误处理程序。

例子

<?php
//error handler function
function customError($errno, $errstr, $errfile, $errline)
 {
 echo "<b>Custom error:</b> [$errno] $errstr<br />";
 echo " Error on line $errline in $errfile<br />";
 echo "Ending Script";
 die();
 }

//set error handler
set_error_handler("customError");

$test=2;

//trigger error
if ($test>1)
 {
 trigger_error("A custom error has been triggered");
 }
?>

输出：

Custom error: [1024] A custom error has been triggered
Error on line 19 in C:\webfolder\test.php
Ending Script

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP set_exception_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP set_exception_handler() 函数

PHP Error 和 Logging 函数

定义和用法

set_exception_handler() 函数设置用户自定义的异常处理函数。

该函数用于创建运行时期间的用户自己的异常处理方法。

该函数会返回旧的异常处理程序，若失败，则返回 null。

语法

set_exception_handler(exception_function)
参数 | 描述
error_function | 必需。规定未捕获的异常发生时调用的函数。 该函数必须在调用 set_exception_handler() 函数之前定义。 这个异常处理函数需要需要一个参数，即抛出的 exception 对象。

提示和注释

提示：在这个异常处理程序被调用后，脚本会停止执行。

例子

<?php
function myException($exception)
{
echo "<b>Exception:</b> " , $exception->getMessage();
}

set_exception_handler('myException');

throw new Exception('Uncaught Exception occurred');
?>

输出：

Exception: Uncaught Exception occurred

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP set_exception_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP set_exception_handler() 函数

PHP Error 和 Logging 函数

定义和用法

trigger_error() 函数创建用户定义的错误消息。

trigger_error() 用于在用户指定的条件下触发一个错误消息。它与内建的错误处理器一同使用，也可以与由 set_error_handler() 函数创建的用户自定义函数使用。

如果指定了一个不合法的错误类型，该函数返回 false，否则返回 true。

语法

trigger_error(error_message,error_types)
参数 | 描述
error_message | 必需。规定错误消息。长度限制为 1024 个字符。
error_types 可选。规定错误消息的错误类型。 可能的值：
  • E_USER_ERROR
  • E_USER_WARNING
  • E_USER_NOTICE

例子

<?php
$test=2;
if ($test>1)
{
trigger_error("A custom error has been triggered");
}
?>

输出：

Notice: A custom error has been triggered
in C:\webfolder\test.php on line 6

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP set_file_buffer() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP set_file_buffer() 函数

PHP Filesystem 函数

定义和用法

set_file_buffer() 函数设置打开文件的缓冲大小。

若成功，则该函数返回 0。若失败，则返回 EOF。

语法

set_file_buffer(file,buffer)
参数 | 描述
file | 必需。规定打开的文件。
buffer | 必需。规定缓冲大小，以字节计。

提示和注释

注释：该函数是 stream_set_write_buffer() 的别名。

例子

创建无缓冲的流：

<?php
$file = fopen("test.txt","w");
if ($file)
  {
  set_file_buffer($file,0);
  fwrite($file,"Hello World. Testing!");
  fclose($file);
  }
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP setcookie() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP setcookie() 函数

PHP HTTP 函数

定义和用法

setcookie() 函数向客户端发送一个 HTTP cookie。

cookie 是由服务器发送到浏览器的变量。cookie 通常是服务器嵌入到用户计算机中的小文本文件。每当计算机通过浏览器请求一个页面，就会发送这个 cookie。

cookie 的名称指定为相同名称的变量。例如，如果被发送的 cookie 名为 "name"，会自动创建名为 $user 的变量，包含 cookie 的值。

必须在任何其他输出发送前对 cookie 进行赋值。

如果成功，则该函数返回 true，否则返回 false。

语法

setcookie(name,value,expire,path,domain,secure)
参数 | 描述
name | 必需。规定 cookie 的名称。
value | 必需。规定 cookie 的值。
expire | 可选。规定 cookie 的有效期。
path | 可选。规定 cookie 的服务器路径。
domain | 可选。规定 cookie 的域名。
secure | 可选。规定是否通过安全的 HTTPS 连接来传输 cookie。

提示和注释

注释：可以通过 $HTTP_COOKIE_VARS["user"] 或 $_COOKIE["user"] 来访问名为 "user" 的 cookie 的值。

注释：在发送 cookie 时，cookie 的值会自动进行 URL 编码。接收时会进行 URL 解码。如果你不需要这样，可以使用 setrawcookie() 代替。

例子

例子 1

设置并发送 cookie：

<?php
$value = "my cookie value";

// 发送一个简单的 cookie
setcookie("TestCookie",$value);
?>

<html>
<body>

...
...
<?php
$value = "my cookie value";

// 发送一个 24 小时候过期的 cookie
setcookie("TestCookie",$value, time()+3600*24);
?>

<html>
<body>

...
...

例子 2

检索 cookie 值的不同方法：

<html>
<body>

<?php

// 输出个别的 cookie
echo $_COOKIE["TestCookie"];
echo "<br />";
echo $HTTP_COOKIE_VARS["TestCookie"];
echo "<br />";

// 输出所有 cookie
print_r($_COOKIE);
?>

</body>
</html>

输出：

my cookie value
my cookie value
Array ([TestCookie] => my cookie value)

例子 3

通过把失效日期设置为过去的日期/时间，删除一个 cookie：

<?php
// 把失效日期设置为一小时前
setcookie ("TestCookie", "", time() - 3600);
?>

<html>
<body>

...
...

例子 4

创建一个数组 cookie：

<?php
setcookie("cookie[three]","cookiethree");
setcookie("cookie[two]","cookietwo");
setcookie("cookie[one]","cookieone");

// 输出 cookie （在重载页面后）
if (isset($_COOKIE["cookie"]))
  {
  foreach ($_COOKIE["cookie"] as $name => $value)
    {
    echo "$name : $value <br />";
    }
  }
?>

<html>
<body>

...
...

输出：

three : cookiethree
two : cookietwo
one : cookieone

PHP HTTP 函数

PHP 参考手册
PHP 测验


PHP setlocale() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP setlocale() 函数

PHP String 函数

定义和用法

setlocale() 函数设置地区信息（地域信息）。

地区信息是针对一个地理区域的语言、货币、时间以及其他信息。

该函数返回当前的地区设置，若失败则返回 false。

语法

setlocale(constant,location)
参数 描述
constant

必需。规定应该设置什么地区信息。

可用的常量：

  • LC_ALL - 包括下面的所有选项
  • LC_COLLATE -排序次序
  • LC_CTYPE - 字符类别及转换（例如所有字符大写或小写）
  • LC_MESSAGES - 系统消息格式
  • LC_MONETARY - 货币格式
  • LC_NUMERIC - 数字格式
  • LC_TIME - 日期/时间格式
location

必需。规定把地区信息设置为什么国家/地区。如果 location 参数是数组，setlocale() 会尝试每个数组元素，直到找到合法的语言或地区代码为止。如果某个地区在不同的系统上拥有不同的名称，这一点很有用。

注释：在此查找语言和地区代码。

提示和注释

注释：setlocale() 函数仅针对当前脚本改变地区信息。

提示：可以通过 setlocale(LC_ALL,NULL) 把地区信息设置为系统默认。

例子

在本例中，我们将把 locale 设置为 US English，然后再设置回系统默认：

<?php
echo setlocale(LC_ALL,"En-Us");
echo setlocale(LC_ALL,NULL);
?>

PHP String 函数

PHP 参考手册
PHP 测验


PHP setrawcookie() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP setrawcookie() 函数

PHP HTTP 函数

定义和用法

setrawcookie() 函数不对 cookie 值进行 URL 编码，发送一个 HTTP cookie。

cookie 是由服务器发送到浏览器的变量。cookie 通常是服务器嵌入到用户计算机中的小文本文件。每当计算机通过浏览器请求一个页面，就会发送这个 cookie。

cookie 的名称指定为相同名称的变量。例如，如果被发送的 cookie 名为 "name"，会自动创建名为 $user 的变量，包含 cookie 的值。

必须在任何其他输出发送前对 cookie 进行赋值。

如果成功，则该函数返回 true，否则返回 false。

语法

setcookie(name,value,expire,path,domain,secure)
参数 | 描述
name | 必需。规定 cookie 的名称。
value | 必需。规定 cookie 的值。
expire | 可选。规定 cookie 的有效期。
path | 可选。规定 cookie 的服务器路径。
domain | 可选。规定 cookie 的域名。
secure | 可选。规定是否通过安全的 HTTPS 连接来传输 cookie。

提示和注释

注释：可以通过 $HTTP_COOKIE_VARS["user"] 或 $_COOKIE["user"] 来访问名为 "user" 的 cookie 的值。

注释：setrawcookie() 与 setcookie() 几乎完全相同，不同的是不会在发往客户机时，对 cookie 值进行自动 URL 编码。

例子

例子 1

设置并发送 cookie：

<?php
$value = "my cookie value";

// 发送一个简单的 cookie
setrawcookie("TestCookie",$value);
?>

<html>
<body>

...
...
<?php
$value = "my cookie value";

// 发送一个 24 小时候过期的 cookie
setrawcookie("TestCookie",$value, time()+3600*24);
?>

<html>
<body>

...
...

例子 2

检索 cookie 值的不同方法：

<html>
<body>

<?php

// 输出个别的 cookie
echo $_COOKIE["TestCookie"];
echo "<br />";
echo $HTTP_COOKIE_VARS["TestCookie"];
echo "<br />";

// 输出所有 cookie
print_r($_COOKIE);
?>

</body>
</html>

输出：

my cookie value
my cookie value
Array ([TestCookie] => my cookie value)

例子 3

通过把失效日期设置为过去的日期/时间，删除一个 cookie：

<?php
// 把失效日期设置为一小时前
setrawcookie ("TestCookie", "", time() - 3600);
?>

<html>
<body>

...
...

例子 4

创建一个数组 cookie：

<?php
setrawcookie("cookie[three]","cookiethree");
setrawcookie("cookie[two]","cookietwo");
setrawcookie("cookie[one]","cookieone");

// 输出 cookie （在重载页面后）
if (isset($_COOKIE["cookie"]))
  {
  foreach ($_COOKIE["cookie"] as $name => $value)
    {
    echo "$name : $value <br />";
    }
  }
?>

<html>
<body>

...
...

输出：

three : cookiethree
two : cookietwo
one : cookieone

PHP HTTP 函数

PHP 参考手册
PHP 测验


PHP sha1_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sha1_file() 函数

PHP String 函数

定义和用法

sha1_file() 函数计算文件的 SHA-1 散列。

sha1() 函数使用美国 Secure Hash 算法 1。

如果成功，则返回所计算的 SHA-1 散列，如果失败，则返回 false。

语法

sha1_file(file,raw)
参数 | 描述
string | 必需。规定要计算的文件。
charlist

可选。规定十六进制或二进制输出格式：

  • TRUE - 原始 20 字符二进制格式
  • FALSE - 默认。40 字符十六进制数

注释：该参数是 PHP 5.0 中添加的。

例子

例子 1

<?php
$filename = "test.txt";
$sha1file = sha1_file($filename);
echo $sha1file;
?>

输出：

aaf4c61ddcc5e8a2dabede0f3b482cd9aea9434d

例子 2

在一个文件中存储 "test.txt" 的 SHA-1 散列：

<?php
$sha1file = sha1_file("test.txt");
file_put_contents("sha1file.txt",$sha1file);
?>

在本例中，我们将测试 "test.txt" 是否已更改（即 SHA-1 hash 是否已更改）：

<?php
$sha1file = file_get_contents("sha1file.txt");
if (sha1_file("test.txt") == $sha1file)
  {
  echo "The file is ok.";
  }
else
  {
  echo "The file has been changed.";
  }
?>

输出：

The file is ok.

PHP String 函数

PHP 参考手册
PHP 测验


PHP sha1() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sha1() 函数

PHP String 函数

定义和用法

sha1() 函数计算字符串的 SHA-1 散列。

sha1() 函数使用美国 Secure Hash 算法 1。

如果成功，则返回所计算的 SHA-1 散列，如果失败，则返回 false。

语法

sha1(string,raw)
参数 | 描述
string | 必需。规定要计算的字符串。
charlist

可选。规定十六进制或二进制输出格式：

  • TRUE - 原始 20 字符二进制格式
  • FALSE - 默认。40 字符十六进制数

注释：该参数是 PHP 5.0 中添加的。

例子

例子 1

<?php
$str = 'Hello';
echo sha1($str);
?>

输出：

f7ff9e8b7bb2e09b70935a5d785e0cc5d9d0abf0

例子 2

在本例中，我们将输出 sha1() 的结果，然后对其测试：

<?php
$str = 'Hello';
echo sha1($str);

if (sha1($str) == 'f7ff9e8b7bb2e09b70935a5d785e0cc5d9d0abf0')
  {
  echo "<br />Hello world!";
  exit;
  }
?>

输出：

f7ff9e8b7bb2e09b70935a5d785e0cc5d9d0abf0
Hello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP show_source() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP show_source() 函数

PHP 杂项函数

定义和用法

show_source() 函数对文件进行语法高亮显示。

本函数是 highlight_file() 的别名。

语法

show_source(filename,return)
参数 | 描述
filename | 必需。要进行高亮处理的 PHP 文件的路径。
return | 可选。如果设置 true，则本函数返回高亮处理的代码。

说明

本函数通过使用 PHP 语法高亮程序中定义的颜色，输出或返回包含在 filename 中的代码的语法高亮版本。

许多服务器被配置为对带有 phps 后缀的文件进行自动高亮处理。例如，在查看 example.phps 时，将显示该文件被语法高亮显示的源代码。要启用该功能，请把下面这一行添加到 httpd.conf：

AddType application/x-httpd-php-source .phps

返回值

如果 return 参数被设置为 true，那么该函数会返回被高亮处理的代码，而不是输出它们。否则，若成功，则返回 true，失败则返回 false。

提示和注释

警告：需要注意的是，在使用 show_source() 函数时，请不要因为疏忽而泄露诸如密码或其他类型的敏感信息，否则会出现潜在的安全风险。

例子

"test.php":

<html>
<body>
<?php
show_source("test.php");
?>
</body>
</html>

输出：

<html>
<body>
<?php
show_source("test.php");
?>
</body>
</html>

在浏览器中查看的结果类似这样：

<html>
<body>
<code>
<span style="color: #000000">&lt;html&gt;
<br />
&lt;body&gt;
<br />
<span style="color: #0000BB">&lt;?php
<br />show_source</span>
<span style="color: #007700">(</span>
<span style="color: #DD0000">"test.php"</span>
<span style="color: #007700">);<br /></span>
<span style="color: #0000BB">?&gt;<br /></span>
&lt;/body&gt;
<br />
&lt;/html&gt;</span>
</code>
</body>
</html>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP shuffle() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP shuffle() 函数

PHP Array 函数

定义和用法

shuffle() 函数把数组中的元素按随机顺序重新排列。

若成功，则返回 TRUE，否则返回 FALSE。

注释：本函数为数组中的单元赋予新的键名。这将删除原有的键名而不仅是重新排序。

注释：自 PHP 4.2.0 起，不再需要用 srand() 或 mt_srand() 函数给随机数发生器播种，现已被自动完成。

语法

shuffle(array)
参数 | 描述
array | 必需。规定要使用的数组。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");
shuffle($my_array);
print_r($my_array);
?>

输出：

Array ( [0] => Cat [1] => Horse [2] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP similar_text() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP similar_text() 函数

PHP String 函数

定义和用法

similar_text() 函数计算两个字符串的匹配字符的数目。

该函数也可以计算两个字符串的相似度（以百分比计）。

语法

similar_text(string1,string2,percent)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。
percent | 可选。规定供存储百分比相似度的变量名。

提示和注释

注释： levenshtein() 函数比 similar_text() 函数更快。不过，similar_text() 函数通过更少的必需修改次数提供更精确的结果。

例子

例子 1

<?php
echo similar_text("Hello World","Hello Peter");
?>

输出：

7

例子 2

<?php
similar_text("Hello World","Hello Peter",$percent);
echo $percent;
?>

输出：

63.6363636364

PHP String 函数

PHP 参考手册
PHP 测验


PHP simplexml_import_dom() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP simplexml_import_dom() 函数

PHP SimpleXML 函数

定义和用法

simplexml_import_dom() 函数把 DOM 节点转换为 SimpleXMLElement 对象。

如果失败，则该函数返回 false。

语法

simplexml_import_dom(data,class)
参数 | 描述
data | 必需。规定要使用的 DOM 节点。
class | 必需。规定新对象的 class。

例子

<?php
$dom = new domDocument;
$dom->loadXML('<note><from>John</from></note>');

$xml = simplexml_import_dom($dom);

echo $xml->from;
?>

输出类似：

John

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP simplexml_load_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP simplexml_load_file() 函数

PHP SimpleXML 函数

定义和用法

simplexml_load_file() 函数把 XML 文档载入对象中。

如果失败，则返回 false。

语法

simplexml_load_file(file,class,options,ns,is_prefix)
参数 | 描述
file | 必需。规定要使用的 XML 文档。
class | 可选。规定新对象的 class。
options | 可选。规定附加的 Libxml 参数。
ns | 可选。
is_prefix | 可选。

返回值

返回类 SimpleXMLElement 的一个对象，该对象的属性包含 XML 文档中的数据。如果失败，则返回 false。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
if (file_exists('test.xml'))
  {
  $xml = simplexml_load_file('test.xml');
  var_dump($xml);
  }

else
  {
  exit('Error.');
  }
?>

输出：

object(SimpleXMLElement)#1 (4)
{
["to"]=> string(4) "George"
["from"]=> string(4) "John"
["heading"]=> string(8) "Reminder"
["body"]=> string(29) "Don't forget the meeting!"
}

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP simplexml_load_string() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP simplexml_load_string() 函数

PHP SimpleXML 函数

定义和用法

simplexml_load_string() 函数把 XML 字符串载入对象中。

如果失败，则返回 false。

语法

simplexml_load_file(string,class,options,ns,is_prefix)
参数 | 描述
string | 必需。规定要使用的 XML 字符串。
class | 可选。规定新对象的 class。
options | 可选。规定附加的 Libxml 参数。
ns | 可选。
is_prefix | 可选。

返回值

返回类 SimpleXMLElement 的一个对象，该对象的属性包含 XML 文档中的数据。如果失败，则返回 false。

例子

<?php
$xmlstring = <<<XML
<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>
XML;

$xml = simplexml_load_string($xmlstring);

var_dump($xml);
?>

输出：

object(SimpleXMLElement)#1 (4)
{
["to"]=> string(4) "George"
["from"]=> string(4) "John"
["heading"]=> string(8) "Reminder"
["body"]=> string(29) "Don't forget the meeting!"
}

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP SimpleXML 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP SimpleXML 函数

  • Previous Page
  • Next Page

PHP SimpleXML 简介

SimpleXML 函数允许您把 XML 转换为对象。

通过普通的属性选择器或数组迭代器，可以处理这个对象，就像处理任何其他对象一样。

其中的一些函数需要最新的 PHP 版本。

安装

SimpleXML 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP SimpleXML 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
__construct() | 创建一个新的 SimpleXMLElement 对象。 | 5
addAttribute() | 给 SimpleXML 元素添加一个属性。 | 5
addChild() | 给 SimpleXML 元素添加一个子元素。 | 5
asXML() | 从 SimpleXML 元素获取 XML 字符串。 | 5
attributes() | 获取 SimpleXML 元素的属性。 | 5
children() | 获取指定节点的子。 | 5
getDocNamespaces() | 获取 XML 文档的命名空间。 | 5
getName() | 获取 SimpleXML 元素的名称。 | 5
getNamespaces() | 从 XML 数据获取命名空间。 | 5
registerXPathNamespace() | 为下一次 XPath 查询创建命名空间语境。 | 5
simplexml_import_dom() | 从 DOM 节点获取 SimpleXMLElement 对象。 | 5
simplexml_load_file() | 从 XML 文档获取 SimpleXMLElement 对象。 | 5
simplexml_load_string() | 从 XML 字符串获取 SimpleXMLElement 对象。 | 5
xpath() | 对 XML 数据运行 XPath 查询。 | 5

PHP SimpleXML 常量

无。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP sin() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sin() 函数

PHP Math 函数

定义和用法

sin() 函数返回一个数的正弦。

语法

sin(x)
参数 | 描述
x | 必需。一个数。

说明

sin() 返回参数 x 的正弦值。参数 x 的单位为弧度。

提示和注释

注释：sin() 函数返回的数值介于 -1 和 1 之间。

例子

在本例中，我们将计算不同值的正弦：

<?php
echo(sin(3));
echo(sin(-3));
echo(sin(0));
echo(sin(M_PI));
echo(sin(M_PI_2))
?>

输出：

0.14112000806
-0.14112000806
0
1.22460635382E-016
1

PHP Math 函数

PHP 参考手册
PHP 测验


PHP sinh() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sinh() 函数

PHP Math 函数

定义和用法

sinh() 函数返回一个数的双曲正弦。

语法

sinh(x)
参数 | 描述
x | 必需。一个数字。

说明

返回 x 的双曲正弦值，定义为 (exp(arg) - exp(-arg))/2。

例子

在本例中，我们将返回不同数的双曲正弦：

<?php
echo(sinh(3));
echo(sinh(-3));
echo(sinh(0));
echo(sinh(M_PI));
echo(sinh(M_PI_2));
?>

输出：

10.0178749274
-10.0178749274
0
11.5487393573
2.30129890231

PHP Math 函数

PHP 参考手册
PHP 测验


PHP sizeof() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sizeof() 函数

PHP Array 函数

定义和用法

sizeof() 函数计算数组中的单元数目或对象中的属性个数。

该函数是 count() 的别名。

语法

sizeof(array,mode)
参数 | 描述
array | 必需。规定要计数的数组或对象。
mode

可选。规定函数的模式。可能的值：

  • 0 - 默认。不检测多维数组（数组中的数组）。
  • 1 - 检测多维数组。

注释：该参数是 PHP 4.2 中加入的。

提示和注释

注释：当变量未被设置，或是变量包含一个空的数组，该函数会返回 0。可使用 isset() 变量来测试变量是否被设置。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");
$result = sizeof($people);

echo $result;
?>

输出：

4

PHP Array 函数

PHP 参考手册
PHP 测验


PHP sleep() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sleep() 函数

PHP 杂项函数

定义和用法

sleep() 函数延迟代码执行若干秒。

语法

sleep(seconds)
参数 | 描述
seconds | 必需。以秒计的暂停时间。

返回值

若成功，返回 0，否则返回 false。

错误／异常

如果指定的描述 seconds 是负数，该函数将生成一个 E_WARNING。

例子

<?php
echo date('h:i:s') . "<br />";

//暂停 10 秒
sleep(10);

//重新开始
echo date('h:i:s');

?>

输出：

12:00:08
12:00:18

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP sort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sort() 函数

PHP Array 函数

定义和用法

sort() 函数按升序对给定数组的值排序。

注释：本函数为数组中的单元赋予新的键名。原有的键名将被删除。

如果成功则返回 TRUE，否则返回 FALSE。

语法

sort(array,sorttype)
参数 | 描述
array | 必需。输入的数组。
sorttype

可选。规定如何排列数组的值。可能的值：

  • SORT_REGULAR - 默认。以它们原来的类型进行处理（不改变类型）。
  • SORT_NUMERIC - 把值作为数字来处理
  • SORT_STRING - 把值作为字符串来处理
  • SORT_LOCALE_STRING - 把值作为字符串来处理，基于本地设置*。

*：该值是 PHP 4.4.0 和 5.0.2 新加的。在 PHP 6 之前，使用了系统的区域设置，可以用 setlocale() 来改变。自 PHP 6 起，必须用 i18n_loc_set_default() 函数。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");

sort($my_array);
print_r($my_array);
?>

输出：

Array
(
0] => Cat
[1] => Dog
[2] => Horse
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP soundex() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP soundex() 函数

PHP String 函数

定义和用法

soundex() 函数计算字符串的 soundex 键。

soundex 键是 4 字符长的字母数字字符串，表示一个单词的英文发音。

soundex() 函数可用于拼写检查程序。

如果成功，则返回字符串的 soundex 键，如果失败，则返回 false。

语法

soundex(string)
参数 | 描述
string | 必需。规定要检查的字符串。
提示和注释

注释：soundex() 为发音相似的单词创建相同的键。

提示： metaphone() 比 soundex() 函数更精确，因为 metaphone() 了解基本的英语发音规则。

例子

例子 1

<?php
$str = "hello";
echo soundex($str);
?>

输出：

H400

例子 2

在本例中，我们对两个发音相似的单词应用 soundex() 函数：

<?php
$str = "Sun";
$str2 = "Son";

echo soundex($str);
echo "<br />";
echo soundex($str2);
?>

输出：

S500
S500

PHP String 函数

PHP 参考手册
PHP 测验


PHP sprintf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sprintf() 函数

PHP String 函数

定义和用法

sprintf() 函数把格式化的字符串写写入一个变量中。

语法

sprintf(format,arg1,arg2,arg++)
参数 | 描述
format | 必需。转换格式。
arg1 | 必需。规定插到 format 字符串中第一个 % 符号处的参数。
arg2 | 可选。规定插到 format 字符串中第二个 % 符号处的参数。
arg++ | 可选。规定插到 format 字符串中第三、四等等 % 符号处的参数。

说明

参数 format 是转换的格式，以百分比符号 ("%") 开始到转换字符结束。下面的可能的 format 值：

  • %% - 返回百分比符号
  • %b - 二进制数
  • %c - 依照 ASCII 值的字符
  • %d - 带符号十进制数
  • %e - 可续计数法（比如 1.5e+3）
  • %u - 无符号十进制数
  • %f - 浮点数(local settings aware)
  • %F - 浮点数(not local settings aware)
  • %o - 八进制数
  • %s - 字符串
  • %x - 十六进制数（小写字母）
  • %X - 十六进制数（大写字母）

arg1, arg2, ++ 等参数将插入到主字符串中的百分号 (%) 符号处。该函数是逐步执行的。在第一个 % 符号中，插入 arg1，在第二个 % 符号处，插入 arg2，依此类推。

提示和注释

注释：如果 % 符号多于 arg 参数，则您必须使用占位符。占位符插到 % 符号后面，由数字和 "\$" 组成。请参见例子 3。

提示：
相关函数：
fprintf()、
printf()、
vfprintf()、
vprintf() 以及
vsprintf()。

例子

例子 1

<?php
$str = "Hello";
$number = 123;
$txt = sprintf("%s world. Day number %u",$str,$number);
echo $txt;
?>

输出：

Hello world. Day number 123

例子 2

<?php
$number = 123;
$txt = sprintf("%f",$number);
echo $txt;
?>

输出：

123.000000

例子 3

<?php
$number = 123;
$txt = sprintf("With 2 decimals: %1\$.2f<br />With no decimals: %1\$u",$number);
echo $txt;
?>

输出：

With 2 decimals: 123.00
With no decimals: 123

PHP String 函数

PHP 参考手册
PHP 测验


PHP sqrt() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sqrt() 函数

PHP Math 函数

定义和用法

sqrt() 函数返回一个数的平方根。

语法

sqrt(x)
参数 | 描述
x | 必需。一个数字。

说明

返回 x 的平方根。

提示和注释

注释：如果参数 x 是负数，则 sqrt() 函数返回 -1.#IND。

例子

在本例中，我们将返回不同数的平方根：

<?php
echo(sqrt(0));
echo(sqrt(1));
echo(sqrt(9));
echo(sqrt(0.64));
echo(sqrt(-9));
?>

输出：

0
1
3
0.8
-1.#IND

PHP Math 函数

PHP 参考手册
PHP 测验


PHP srand() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP srand() 函数

PHP Math 函数

定义和用法

srand() 函数播下随机数发生器种子。

语法

srand(seed)
参数 | 描述
seed | 可选。用 seed 播下随机数发生器种子。

说明

从 PHP 4.2.0 版开始，seed 参数变为可选项，当该项为空时，会被设为随时数。

提示和注释

注释：自 PHP 4.2.0 起，不再需要用 srand() 或 mt_srand() 函数给随机数发生器播种，现在已自动完成。

例子

在本例中，我们将播种随机数发生器：

<?php
srand(mktime());
echo(rand());
?>

输出：

23054

PHP Math 函数

PHP 参考手册
PHP 测验


PHP sscanf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sscanf() 函数

PHP String 函数

定义和用法

sscanf() 函数根据指定的格式解析来自一个字符串的输入。

如果只向该函数传递两个参数，数据将以数组的形式返回。否则，如果传递了额外的参数，那么被解析的数据会存储在这些参数中。如果区分符的数目大于包含它们的变量的数目，则会发生错误。不过，如果区分符少于变量，则额外的变量包含 NULL。

语法

sscanf(string,format,arg1,arg2,arg++)
参数 | 描述
string | 必需。规定要读取的字符串。
format | 必需。规定要使用的格式。
arg1 | 可选。存储数据的第一个变量。
arg2 | 可选。存储数据的第二个变量。
arg++ | 可选。存储数据的第三、四个变量。依此类推。

说明

参数 format 是转换的格式，以百分比符号 ("%") 开始到转换字符结束。下面的可能的 format 值：

  • %% - 返回百分比符号
  • %b - 二进制数
  • %c - 依照 ASCII 值的字符
  • %d - 带符号十进制数
  • %e - 可续计数法（比如 1.5e+3）
  • %u - 无符号十进制数
  • %f - 浮点数(local settings aware)
  • %F - 浮点数(not local settings aware)
  • %o - 八进制数
  • %s - 字符串
  • %x - 十六进制数（小写字母）
  • %X - 十六进制数（大写字母）

例子

<?php
$string = "age:30 weight:60kg";
sscanf($string,"age:%d weight:%dkg",$age,$weight);
// show types and values
var_dump($age,$weight);
?>

输出：

int(30)
int(60)

PHP String 函数

PHP 参考手册
PHP 测验


PHP stat() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP stat() 函数

PHP Filesystem 函数

定义和用法

stat() 函数返回关于文件的信息。

语法

fstat(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

获取由 file 指定的文件的统计信息。如果 file 是符号连接，则统计信息是关于被连接文件本身的，而不是符号连接。

如果出错，stat() 返回 false，并且发出一条警告。

返回的数组包含有文件的统计信息，该数组具有以下列出的单元，数组下标从零开始。除了数字索引之外，从 PHP 4.0.6 起还可以通过关联索引来访问。

stat() 的返回格式

数字下标 | 关联键名（自 PHP 4.0.6） | 说明
0 | dev | 设备名
1 | ino | 号码
2 | mode | inode 保护模式
3 | nlink | 被连接数目
4 | uid | 所有者的用户 id
5 | gid | 所有者的组 id
6 | rdev | 设备类型，如果是 inode 设备的话
7 | size | 文件大小的字节数
8 | atime | 上次访问时间（Unix 时间戳）
9 | mtime | 上次修改时间（Unix 时间戳）
10 | ctime | 上次改变时间（Unix 时间戳）
11 | blksize | 文件系统 IO 的块大小
12 | blocks | 所占据块的数目

提示和注释

提示： lstat() 与 stat() 类似，不同的是，它会返回符号连接的状态。

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$file = fopen("test.txt","r");
print_r(stat($file));
fclose($file);
?>

输出类似：

Array
(
[0] => 0
[1] => 0
[2] => 33206
[3] => 1
[4] => 0
[5] => 0
[6] => 0
[7] => 92
[8] => 1141633430
[9] => 1141298003
[10] => 1138609592
[11] => -1
[12] => -1
[dev] => 0
[ino] => 0
[mode] => 33206
[nlink] => 1
[uid] => 0
[gid] => 0
[rdev] => 0
[size] => 92
[atime] => 1141633430
[mtime] => 1141298003
[ctime] => 1138609592
[blksize] => -1
[blocks] => -1
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP str_ireplace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_ireplace() 函数

PHP String 函数

定义和用法

str_ireplace() 函数使用一个字符串替换字符串中的另一些字符。

语法

str_ireplace(find,replace,string,count)
参数 | 描述
find | 必需。规定要查找的值。
replace | 必需。规定替换 find 中的值的值。
string | 必需。规定被搜索的字符串。
count | 可选。一个变量，对替换数进行计数。

提示和注释

注释：该函数对大小写敏感。请使用 str_replace() 执行对大小写不敏感的搜索。

注释：该函数是二进制安全的。

例子

例子 1

<?php
echo str_ireplace("world","John","Hello world!");
?>

输出：

Hello John!

例子 2

在本例中，我们将演示带有数组和 count 变量的 str_ireplace() 函数：

<?php
$arr = array("blue","red","green","yellow");
print_r(str_ireplace("red","pink",$arr,$i));
echo "Replacements: $i";
?>

输出：

Array
(
[0] => blue
[1] => pink
[2] => green
[3] => yellow
)
Replacements: 1

例子 3

<?php
$find = array("Hello","world");
$replace = array("B");
$arr = array("Hello","world","!");
print_r(str_ireplace($find,$replace,$arr));
?>

输出：

Array
(
[0] => B
[1] =>
[2] => !
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_pad() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_pad() 函数

PHP String 函数

定义和用法

str_pad() 函数把字符串填充为指定的长度。

语法

str_pad(string,length,pad_string,pad_type)
参数 | 描述
string | 必需。规定要填充的字符串。
length | 必需。规定新字符串的长度。如果该值小于原始字符串的长度，则不进行任何操作。
pad_string | 可选。规定供填充使用的字符串。默认是空白。
pad_type

可选。规定填充字符串的那边。

可能的值：

  • STR_PAD_BOTH - 填充到字符串的两头。如果不是偶数，则右侧获得额外的填充。
  • STR_PAD_LEFT - 填充到字符串的左侧。
  • STR_PAD_RIGHT - 填充到字符串的右侧。这是默认的。

例子

例子 1

<?php
$str = "Hello World";
echo str_pad($str,20,".");
?>

输出：

Hello World.........

例子 2

<?php
$str = "Hello World";
echo str_pad($str,20,".",STR_PAD_LEFT);
?>

输出：

.........Hello World

例子 3

<?php
$str = "Hello World";
echo str_pad($str,20,".:",STR_PAD_BOTH);
?>

输出：

.:.:Hello World.:.:.

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_repeat() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_repeat() 函数

PHP String 函数

定义和用法

str_repeat() 函数把字符串重复指定的次数。

语法

str_repeat(string,repeat)
参数 | 描述
string | 必需。规定要重复的字符串。
repeat | 必需。规定字符串将被重复的次数。必须大于等于 0。

例子

<?php
echo str_repeat(".",13);
?>

输出：

.............

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_replace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_replace() 函数

PHP String 函数

定义和用法

str_replace() 函数使用一个字符串替换字符串中的另一些字符。

语法

str_replace(find,replace,string,count)
参数 | 描述
find | 必需。规定要查找的值。
replace | 必需。规定替换 find 中的值的值。
string | 必需。规定被搜索的字符串。
count | 可选。一个变量，对替换数进行计数。

提示和注释

注释：该函数对大小写敏感。请使用 str_ireplace() 执行对大小写不敏感的搜索。

注释：该函数是二进制安全的。

例子

例子 1

<?php
echo str_replace("world","John","Hello world!");
?>

输出：

Hello John!

例子 2

在本例中，我们将演示带有数组和 count 变量的 str_replace() 函数：

<?php
$arr = array("blue","red","green","yellow");
print_r(str_replace("red","pink",$arr,$i));
echo "Replacements: $i";
?>

输出：

Array
(
[0] => blue
[1] => pink
[2] => green
[3] => yellow
)
Replacements: 1

例子 3

<?php
$find = array("Hello","world");
$replace = array("B");
$arr = array("Hello","world","!");
print_r(str_replace($find,$replace,$arr));
?>

输出：

Array
(
[0] => B
[1] =>
[2] => !
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_rot13() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_rot13() 函数

PHP String 函数

定义和用法

str_rot13() 函数对字符串执行 ROT13 编码。

ROT-13 编码是一种每一个字母被另一个字母代替的方法。这个代替字母是由原来的字母向前移动 13 个字母而得到的。数字和非字母字符保持不变。

语法

str_rot13(string)
参数 | 描述
string | 必需。规定要编码的字符串。

提示和注释

提示：编码和解码都是由相同的函数完成的。如果您把一个已编码的字符串作为参数，那么将返回原始字符串。

例子

在本例中，我们将通过使用 str_rot13() 函数对字符串进行编码和解码：

<?php
echo str_rot13("Hello World");
echo "<br />";
echo str_rot13("Uryyb Jbeyq");
?>

输出：

Uryyb Jbeyq
Hello World

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_shuffle() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_shuffle() 函数

PHP String 函数

定义和用法

str_shuffle() 函数随机地打乱字符串中的所有字符。

语法

str_shuffle(string)
参数 | 描述
string | 必需。规定要打乱的字符串。

例子

<?php
echo str_shuffle("Hello World");
?>

输出：

H elooWlrdl

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_split() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_split() 函数

PHP String 函数

定义和用法

str_split() 函数把字符串分割到数组中。

语法

str_split(string,length)
参数 | 描述
string | 必需。规定要分割的字符串。
length | 可选。规定每个数组元素的长度。默认是 1。

说明

如果 length 小于 1，str_split() 函数将返回 false。

如果 length 大于字符串的长度，整个字符串将作为数组的唯一元素返回。

例子

例子 1

<?php
print_r(str_split("Hello"));
?>

输出：

Array
(
[0] => H
[1] => e
[2] => l
[3] => l
[4] => o
)

例子 2

<?php
print_r(str_split("Hello",3));
?>

输出：

Array
(
[0] => Hel
[1] => lo
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_word_count() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_word_count() 函数

PHP String 函数

定义和用法

str_word_count() 函数计算字符串中的单词数。

语法

str_word_count(string,return,char)
参数 | 描述
string | 必需。规定要检查的字符串。
return

可选。规定 str_word_count() 函数的返回值。

可能的值：

  • 0 - 默认。返回找到的单词的数目。
  • 1 - 返回包含字符串中的单词的数组。
  • 2 - 返回一个数组，其中的键是单词在字符串中的位置，值是实际的单词。
return | 可选。规定被认定为单词的特殊字符。该参数是 PHP 5.1 中新加的。

例子

例子 1

<?php
echo str_word_count("Hello world!");
?>

输出：

2

例子 2

<?php
print_r(str_word_count("Hello world!",1));
?>

输出：

Array
(
[0] => Hello
[1] => world
)

例子 3

<?php
print_r(str_word_count("Hello world!",2));
?>

输出：

Array
(
[0] => Hello
[6] => world
)

例子 4

<?php
print_r(str_word_count("Hello world & good morning!",1));
print_r(str_word_count("Hello world & good morning!",1,"&"));
?>

输出：

Array
(
[0] => Hello
[1] => world
[2] => good
[3] => morning
)

Array
(
[0] => Hello
[1] => world
[2] => &
[3] => good
[4] => morning
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP strcasecmp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strcasecmp() 函数

PHP String 函数

定义和用法

strcasecmp() 函数比较两个字符串。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

语法

strcasecmp(string1,string2)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。

提示和注释

注释：该函数是二进制安全的，且对大小写不敏感。

例子

<?php
echo strcasecmp("Hello world!","HELLO WORLD!");
?>

输出：

0

PHP String 函数

PHP 参考手册
PHP 测验


PHP strchr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strchr() 函数

PHP String 函数

定义和用法

strchr() 函数搜索一个字符串在另一个字符串中的第一次出现。

该函数返回字符串的其余部分（从匹配点）。如果未找到所搜索的字符串，则返回 false。

该函数是 strstr() 函数的别名。

语法

strchr(string,search)
参数 | 描述
string | 必需。规定被搜索的字符串。
search | 必需。规定所搜索的字符串。如果该参数是数字，则搜索匹配数字 ASCII 值的字符。

提示和注释

注释：该函数是二进制安全的。

注释：该函数对大小写敏感。如需进行大小写不敏感的搜索，请使用 stristr()。

例子

例子 1

<?php
echo strchr("Hello world!","world");
?>

输出：

world!

例子 2

在本例中，我们将搜索 "o" 的 ASCII 值所代表的字符：

<?php
echo strchr("Hello world!",111);
?>

输出：

o world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strcmp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strcmp() 函数

PHP String 函数

定义和用法

strcmp() 函数比较两个字符串。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

语法

strcmp(string1,string2)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。

提示和注释

注释：该函数是二进制安全的，且对大小写敏感。

例子

<?php
echo strcmp("Hello world!","Hello world!");
?>

输出：

0

PHP String 函数

PHP 参考手册
PHP 测验


PHP strcoll() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strcoll() 函数

PHP String 函数

定义和用法

strcoll() 函数比较两个字符串。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

字符串的比较会根据本地设置而变化。（A<a 或 A>a）。

语法

strcoll(string1,string2)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。

提示和注释

注释：该函数对大小写敏感，但不是二进制安全的。

注释：如果本地设置是 C 或 POSIX，则该函数的工作方式与 strcmp() 相同。

例子

<?php
setlocale (LC_COLLATE, 'NL');
echo strcoll("Hello World!","Hello WORLD!");
echo "<br />";

setlocale (LC_COLLATE, 'en_US');
echo strcoll("Hello World!","Hello WORLD!");
?>

输出：

-1
1

PHP String 函数

PHP 参考手册
PHP 测验


PHP strcspn() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strcspn() 函数

PHP String 函数

定义和用法

strcspn() 函数返回在找到任何指定的字符之前，在字符串查找的字符数。

语法

strcspn(string,char,start,length)
参数 | 描述
string | 必需。规定要搜索的字符串。
char | 必需。规定要查找的字符。
start | 可选。规定开始查找的位置。该参数是 PHP 4.3 中新加的。
length | 可选。规定字符串的长度（搜索多少字符）。该参数是 PHP 4.3 中新加的。

提示和注释

注释：该函数是二进制安全的。

例子

<?php
echo strcspn("Hello world!","w");
?>

输出：

6

PHP String 函数

PHP 参考手册
PHP 测验


PHP strftime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strftime() 函数

PHP Date / Time 函数

定义和用法

strftime() 函数根据区域设置格式化本地时间／日期。

语法

strftime(format,timestamp)
参数 | 描述
format | 可选。规定如何返回结果。
timestamp | 可选。

提示和注释

提示：与 gmstrftime() 的行为相同，不同的是返回时间是本地时间。

例子

输出 strftime() 和 gmstrftime() 的结果：

<?php
echo(strftime("%b %d %Y %X", mktime(20,0,0,12,31,98)));
echo(gmstrftime("%b %d %Y %X", mktime(20,0,0,12,31,98)));

//输出当前日期、时间和时区
echo(gmstrftime("It is %a on %b %d, %Y, %X time zone: %Z",time()));
?>

输出：

Dec 31 1998 20:00:00
Dec 31 1998 19:00:00
It is Wed on Jan 25, 2006, 11:32:10 time zone: W. Europe Standard Time

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP String 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP String 函数

  • Previous Page
  • Next Page

PHP String 简介

String 字符串函数允许您对字符串进行操作。

安装

String 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP String 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
addcslashes() | 在指定的字符前添加反斜杠。 | 4
addslashes() | 在指定的预定义字符前添加反斜杠。 | 3
bin2hex() | 把 ASCII 字符的字符串转换为十六进制值。 | 3
chop() | rtrim() 的别名。 | 3
chr() | 从指定的 ASCII 值返回字符。 | 3
chunk_split() | 把字符串分割为一连串更小的部分。 | 3
convert_cyr_string() | 把字符由一种 Cyrillic 字符转换成另一种。 | 3
convert_uudecode() | 对 uuencode 编码的字符串进行解码。 | 5
convert_uuencode() | 使用 uuencode 算法对字符串进行编码。 | 5
count_chars() | 返回字符串所用字符的信息。 | 4
crc32() | 计算一个字符串的 32-bit CRC。 | 4
crypt() | 单向的字符串加密法 (hashing)。 | 3
echo() | 输出字符串。 | 3
explode() | 把字符串打散为数组。 | 3
fprintf() | 把格式化的字符串写到指定的输出流。 | 5
get_html_translation_table() | 返回翻译表。 | 4
hebrev() | 把希伯来文本从右至左的流转换为左至右的流。 | 3
hebrevc() | 同上，同时把(\n) 转为 <br />。 | 3
html_entity_decode() | 把 HTML 实体转换为字符。 | 4
htmlentities() | 把字符转换为 HTML 实体。 | 3
htmlspecialchars_decode() | 把一些预定义的 HTML 实体转换为字符。 | 5
htmlspecialchars() | 把一些预定义的字符转换为 HTML 实体。 | 3
implode() | 把数组元素组合为一个字符串。 | 3
join() | implode() 的别名。 | 3
levenshtein() | 返回两个字符串之间的 Levenshtein 距离。 | 3
localeconv() | 返回包含本地数字及货币信息格式的数组。 | 4
ltrim() | 从字符串左侧删除空格或其他预定义字符。 | 3
md5() | 计算字符串的 MD5 散列。 | 3
md5_file() | 计算文件的 MD5 散列。 | 4
metaphone() | 计算字符串的 metaphone 键。 | 4
money_format() | 把字符串格式化为货币字符串。 | 4
nl_langinfo() | 返回指定的本地信息。 | 4
nl2br() | 在字符串中的每个新行之前插入 HTML 换行符。 | 3
number_format() | 通过千位分组来格式化数字。 | 3
ord() | 返回字符串第一个字符的 ASCII 值。 | 3
parse_str() | 把查询字符串解析到变量中。 | 3
print() | 输出一个或多个字符串。 | 3
printf() | 输出格式化的字符串。 | 3
quoted_printable_decode() | 解码 quoted-printable 字符串。 | 3
quotemeta() | 在字符串中某些预定义的字符前添加反斜杠。 | 3
rtrim() | 从字符串的末端开始删除空白字符或其他预定义字符。 | 3
setlocale() | 设置地区信息（地域信息）。 | 3
sha1() | 计算字符串的 SHA-1 散列。 | 4
sha1_file() | 计算文件的 SHA-1 散列。 | 4
similar_text() | 计算两个字符串的匹配字符的数目。 | 3
soundex() | 计算字符串的 soundex 键。 | 3
sprintf() | 把格式化的字符串写写入一个变量中。 | 3
sscanf() | 根据指定的格式解析来自一个字符串的输入。 | 4
str_ireplace() | 替换字符串中的一些字符。（对大小写不敏感） | 5
str_pad() | 把字符串填充为新的长度。 | 4
str_repeat() | 把字符串重复指定的次数。 | 4
str_replace() | 替换字符串中的一些字符。（对大小写敏感） | 3
str_rot13() | 对字符串执行 ROT13 编码。 | 4
str_shuffle() | 随机地打乱字符串中的所有字符。 | 4
str_split() | 把字符串分割到数组中。 | 5
str_word_count() | 计算字符串中的单词数。 | 4
strcasecmp() | 比较两个字符串。（对大小写不敏感） | 3
strchr() | 搜索字符串在另一字符串中的第一次出现。strstr() 的别名 | 3
strcmp() | 比较两个字符串。（对大小写敏感） | 3
strcoll() | 比较两个字符串（根据本地设置）。 | 4
strcspn() | 返回在找到任何指定的字符之前，在字符串查找的字符数。 | 3
strip_tags() | 剥去 HTML、XML 以及 PHP 的标签。 | 3
stripcslashes() | 删除由 addcslashes() 函数添加的反斜杠。 | 4
stripslashes() | 删除由 addslashes() 函数添加的反斜杠。 | 3
stripos() | 返回字符串在另一字符串中第一次出现的位置(大小写不敏感) | 5
stristr() | 查找字符串在另一字符串中第一次出现的位置(大小写不敏感) | 3
strlen() | 返回字符串的长度。 | 3
strnatcasecmp() | 使用一种“自然”算法来比较两个字符串（对大小写不敏感） | 4
strnatcmp() | 使用一种“自然”算法来比较两个字符串（对大小写敏感） | 4
strncasecmp() | 前 n 个字符的字符串比较（对大小写不敏感）。 | 4
strncmp() | 前 n 个字符的字符串比较（对大小写敏感）。 | 4
strpbrk() | 在字符串中搜索指定字符中的任意一个。 | 5
strpos() | 返回字符串在另一字符串中首次出现的位置（对大小写敏感） | 3
strrchr() | 查找字符串在另一个字符串中最后一次出现的位置。 | 3
strrev() | 反转字符串。 | 3
strripos() | 查找字符串在另一字符串中最后出现的位置(对大小写不敏感) | 5
strrpos() | 查找字符串在另一字符串中最后出现的位置(对大小写敏感) | 3
strspn() | 返回在字符串中包含的特定字符的数目。 | 3
strstr() | 搜索字符串在另一字符串中的首次出现（对大小写敏感） | 3
strtok() | 把字符串分割为更小的字符串。 | 3
strtolower() | 把字符串转换为小写。 | 3
strtoupper() | 把字符串转换为大写。 | 3
strtr() | 转换字符串中特定的字符。 | 3
substr() | 返回字符串的一部分。 | 3
substr_compare() | 从指定的开始长度比较两个字符串。 | 5
substr_count() | 计算子串在字符串中出现的次数。 | 4
substr_replace() | 把字符串的一部分替换为另一个字符串。 | 4
trim() | 从字符串的两端删除空白字符和其他预定义字符。 | 3
ucfirst() | 把字符串中的首字符转换为大写。 | 3
ucwords() | 把字符串中每个单词的首字符转换为大写。 | 3
vfprintf() | 把格式化的字符串写到指定的输出流。 | 5
vprintf() | 输出格式化的字符串。 | 4
vsprintf() | 把格式化字符串写入变量中。 | 4
wordwrap() | 按照指定长度对字符串进行折行处理。 | 4

PHP String 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
CRYPT_SALT_LENGTH | 包含系统默认加密方法的长度。对于标准 DES 加密，长度是 2。 |
CRYPT_STD_DES | 如果支持 2 字符 salt 的 DES 加密，则设置为 1，否则为 0。 |
CRYPT_EXT_DES | 如果支持 9 字符 salt 的 DES 加密，则设置为 1，否则为 0。 |
CRYPT_MD5 | 如果支持以$1$开始的 12 字符 salt 的MD5加密，则设置为1，否则为0。 |
CRYPT_BLOWFISH | 如果支持以 $2$ 或 $2a$ 开始的 16 字符 salt 的 Blowfish 加密，则设置为 1，否则为 0。 |
HTML_SPECIALCHARS |  |
HTML_ENTITIES |  |
ENT_COMPAT |  |
ENT_QUOTES |  |
ENT_NOQUOTES |  |
CHAR_MAX |  |
LC_CTYPE |  |
LC_NUMERIC |  |
LC_TIME |  |
LC_COLLATE |  |
LC_MONETARY |  |
LC_ALL |  |
LC_MESSAGES |  |
STR_PAD_LEFT |  |
STR_PAD_RIGHT |  |
STR_PAD_BOTH |  |
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP strip_tags() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strip_tags() 函数

PHP String 函数

定义和用法

strip_tags() 函数剥去 HTML、XML 以及 PHP 的标签。

语法

strip_tags(string,allow)
参数 | 描述
string | 必需。规定要检查的字符串。
allow | 可选。规定允许的标签。这些标签不会被删除。

提示和注释

注释：该函数始终会剥离 HTML 注释。这点无法通过 allow 参数改变。

例子

例子 1

<?php
echo strip_tags("Hello <b>world!</b>");
?>

输出：

Hello world!

例子 2

<?php
echo strip_tags("Hello <b><i>world!</i></b>","<b>");
?>

输出：

Hello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strip_whitespace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strip_whitespace() 函数

PHP 杂项函数

定义和用法

strip_whitespace() 函数返回已删除 PHP 注释以及空白字符的源代码文件。

该函数对于检测脚本中的实际代码量很有用。

语法

strip_whitespace(filename)
参数 | 描述
filename | 必需。规定文件名。

说明

若成功，则返回被剥离的源代码，若失败，则返回空字符串。

注释：在 PHP 5.0.1，该函数的行为与上面的描述一致。在这之前，它仅返回空字符串。

例子

"test.php":

<?php
// PHP comment

/*
*  Another PHP comment
*/

echo php_strip_whitespace      ("test.php");
?>

输出：

<?php
echo php_strip_whitespace ("test.php"); ?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP stripcslashes() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP stripcslashes() 函数

PHP String 函数

定义和用法

stripcslashes() 函数删除由 addcslashes() 函数添加的反斜杠。

语法

stripcslashes(string)
参数 | 描述
string | 必需。规定要检查的字符串。

提示和注释

注释：该函数用于清理从数据库中取回的数据。

例子

<?php
echo stripcslashes("Hello, \my na\me is Kai Ji\m.");
?>

输出：

Hello, my name is Kai Jim.

PHP String 函数

PHP 参考手册
PHP 测验


PHP stripos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP stripos() 函数

PHP String 函数

定义和用法

stripos() 函数返回字符串在另一个字符串中第一次出现的位置。

如果没有找到该字符串，则返回 false。

语法

strpos(string,find,start)
参数 | 描述
string | 必需。规定被搜索的字符串。
find | 必需。规定要查找的字符。
start | 可选。规定开始搜索的位置。

提示和注释

注释：该函数对大小写不敏感。如需进行对大小写敏感的搜索，请使用 strpos() 函数。

例子

<?php
echo stripos("Hello world!","WO");
?>

输出：

6

PHP String 函数

PHP 参考手册
PHP 测验


PHP stripslashes() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP stripslashes() 函数

PHP String 函数

定义和用法

stripslashes() 函数删除由 addslashes() 函数添加的反斜杠。

语法

stripslashes(string)
参数 | 描述
string | 必需。规定要检查的字符串。

提示和注释

注释：该函数用于清理从数据库或 HTML 表单中取回的数据。

例子

<?php
echo stripslashes("Who\'s John Adams?");
?>

输出：

Who's John Adams?

PHP String 函数

PHP 参考手册
PHP 测验


PHP stristr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP stristr() 函数

PHP String 函数

定义和用法

stristr() 函数查找字符串在另一个字符串中第一次出现的位置。

如果成功，则返回字符串的其余部分（从匹配点）。如果没有找到该字符串，则返回 false。

语法

stristr(string,search)
参数 | 描述
string | 必需。规定被搜索的字符串。
find | 必需。规定要查找的字符。如果该参数是数字，则搜索匹配该数字对应的 ASCII 值的字符。

提示和注释

注释：该函数是二进制安全的。

注释：该函数对大小写不敏感。如需对大小写敏感的搜索，请使用 strstr()。

例子

例子 1

<?php
echo stristr("Hello world!","WORLD");
?>

输出：

world!

例子 2

<?php
echo stristr("Hello world!",111);
?>

输出：

o world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strlen() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strlen() 函数

PHP String 函数

定义和用法

strlen() 函数返回字符串的长度。

语法

strlen(string)
参数 | 描述
string | 必需。规定要检查的字符串。

例子

<?php
echo strlen("Hello world!");
?>

输出：

12

PHP String 函数

PHP 参考手册
PHP 测验


PHP strnatcasecmp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strnatcasecmp() 函数

PHP String 函数

定义和用法

strnatcasecmp() 函数使用一种“自然”算法来比较两个字符串。

在自然算法中，数字 "2" 小于数字 "10"。在计算机排序中，"2" 大于 "10"，这是因为 "2" 大于 "10" 的第一个数字。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

语法

strnatcasecmp(string1,string2)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。

提示和注释

注释：该函数对大小写不敏感。

例子

<?php
echo strnatcasecmp("2Hello world!","10Hello world!");
echo "<br />";
echo strnatcasecmp("10Hello world!","2Hello world!");
?>

输出：

-1
1

PHP String 函数

PHP 参考手册
PHP 测验


PHP strnatcmp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strnatcmp() 函数

PHP String 函数

定义和用法

strnatcmp() 函数使用一种“自然”算法来比较两个字符串。

在自然算法中，数字 "2" 小于数字 "10"。在计算机排序中，"2" 大于 "10"，这是因为 "2" 大于 "10" 的第一个数字。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

语法

strnatcmp(string1,string2)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。

提示和注释

注释：该函数对大小写敏感。

例子

<?php
echo strnatcmp("2Hello world!","10Hello world!");
echo "<br />";
echo strnatcmp("10Hello world!","2Hello world!");
?>

输出：

-1
1

PHP String 函数

PHP 参考手册
PHP 测验


PHP strncasecmp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strncasecmp() 函数

PHP String 函数

定义和用法

strncasecmp() 函数比较两个字符串。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

语法

strncasecmp(string1,string2,length)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。
length | 必需。规定每个字符串用于比较的字符数。

提示和注释

注释：该函数是二进制安全的，且对大小写不敏感。

例子

<?php
echo strncasecmp("Hello world!","Hello earth!",6);
?>

输出：

0

PHP String 函数

PHP 参考手册
PHP 测验


PHP strncmp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strncmp() 函数

PHP String 函数

定义和用法

strncmp() 函数比较两个字符串。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

语法

strncmp(string1,string2,length)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。
length | 必需。规定每个字符串用于比较的字符数。

提示和注释

注释：该函数是二进制安全的，且对大小写敏感。

例子

<?php
echo strncmp("Hello world!","Hello earth!",6);
?>

输出：

0

PHP String 函数

PHP 参考手册
PHP 测验


PHP strpbrk() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strpbrk() 函数

PHP String 函数

定义和用法

strpbrk() 函数在字符串中搜索指定字符中的任意一个。

该函数返回指定字符第一次出现的位置开始的剩余部分。如果没有找到，则返回 false。

语法

strpbrk(string,charlist)
参数 | 描述
string | 必需。规定被搜索的字符串。
charlist | 必需。规定要查找的字符。

提示和注释

注释：该函数对大小写敏感。

例子

<?php
echo strpbrk("Hello world!","oe");
?>

输出：

ello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strpos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strpos() 函数

PHP String 函数

定义和用法

strpos() 函数返回字符串在另一个字符串中第一次出现的位置。

如果没有找到该字符串，则返回 false。

语法

strpos(string,find,start)
参数 | 描述
string | 必需。规定被搜索的字符串。
find | 必需。规定要查找的字符。
start | 可选。规定开始搜索的位置。

提示和注释

注释：该函数对大小写敏感。如需进行对大小写不敏感的搜索，请使用 stripos() 函数。

例子

<?php
echo strpos("Hello world!","wo");
?>

输出：

6

PHP String 函数

PHP 参考手册
PHP 测验


PHP strptime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strptime() 函数

PHP Date / Time 函数

定义和用法

strptime() 函数解析由 strftime() 生成的日期／时间。

语法

strptime(date,format)
参数 | 描述
date | 要解析的字符串（例如从 strftime() 返回的）。
format | date 所使用的格式（与 strftime() 中所使用的相同）。

说明

strptime() 返回一个将 date 解析后的数组，如果出错返回 FALSE。

月份和星期几的名字以及其它与语种有关的字符串对应于 setlocale()设定的当前区域（LC_TIME）。

数组中包含以下单元：

键名 | 说明
tm_sec | 当前分钟内的秒数（0-61）
tm_min | 当前小时内的分钟数（0-59）
tm_hour | 午夜起的小时数（0-23）
tm_mday | 月份中的第几天（1-31）
tm_mon | 自一月起过了几个月（0-11）
tm_year | 自 1900 年起过了几年
tm_wday | 自星期天起过了几天（0-6）
tm_yday | 本年自一月一日起过了多少天（0-365）
unparsed date | 中未能通过指定的 format 识别的部分

例子

输出 strftime() 和 strptime() 的结果：

<?php
$format="%d/%m/%Y %H:%M:%S";
$strf=strftime($format);
echo("$strf");
print_r(strptime($strf,$format));
?>

输出：

03/10/2005 13:23:44
Array
(
[tm_sec] => 44
[tm_min] => 23
[tm_hour] => 13
[tm_mday] => 3
[tm_mon] => 9
[tm_year] => 105
[tm_wday] => 0
[tm_yday] => 276
[unparsed] =>
)

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP strrchr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strrchr() 函数

PHP String 函数

定义和用法

strrchr() 函数查找字符串在另一个字符串中最后一次出现的位置，并返回从该位置到字符串结尾的所有字符。

如果成失败，否则返回 false。

语法

strrchr(string,char)
参数 | 描述
string | 必需。规定被搜索的字符串。
char | 必需。规定要查找的字符。如果该参数是数字，则搜索匹配数字 ASCII 值的字符。

提示和注释

注释：该函数是二进制安全的。

例子

例子 1

<?php
echo strrchr("Hello world!","world");
?>

输出：

world!

例子 2

<?php
echo strrchr("Hello world!",111);
?>

输出：

orld!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strrev() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strrev() 函数

PHP String 函数

定义和用法

strrev() 函数反转字符串。

语法

strrev(string)
参数 | 描述
string | 必需。规定要反转的字符串。

例子

<?php
echo strrev("Hello World!");
?>

输出：

!dlroW olleH

PHP String 函数

PHP 参考手册
PHP 测验


PHP strripos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strripos() 函数

PHP String 函数

定义和用法

strripos() 函数查找字符串在另一个字符串中最后一次出现的位置。

如果成功，则返回位置，否则返回 false。

语法

strrpos(string,find,start)
参数 | 描述
string | 必需。规定被搜索的字符串。
find | 必需。规定要查找的字符。
start | 可选。规定开始搜索的位置。

提示和注释

注释：该函数对大小写不敏感。如需进行大小写敏感的查找，请使用 strrpos()。

例子

<?php
echo strripos("Hello world!","WO");
?>

输出：

6

PHP String 函数

PHP 参考手册
PHP 测验


PHP strrpos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strrpos() 函数

PHP String 函数

定义和用法

strrpos() 函数查找字符串在另一个字符串中最后一次出现的位置。

如果成功，则返回位置，否则返回 false。

语法

strrpos(string,find,start)
参数 | 描述
string | 必需。规定被搜索的字符串。
find | 必需。规定要查找的字符。
start | 可选。规定开始搜索的位置。

提示和注释

注释：该函数对大小写敏感。如需进行大小写不敏感的查找，请使用 strripos()。

例子

<?php
echo strrpos("Hello world!","wo");
?>

输出：

6

PHP String 函数

PHP 参考手册
PHP 测验


PHP strspn() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strspn() 函数

PHP String 函数

定义和用法

strspn() 函数返回在字符串中包含的特定字符的数目。

语法

strspn(string,charlist,start,length)
参数 | 描述
string | 必需。规定被搜索的字符串。
charlist | 必需。规定要查找的字符。
start | 可选。规定在字符串的何处开始。
length | 可选。规定字符串的长度。

提示和注释

注释：该函数是二进制安全的。

例子

例子 1

<?php
echo strspn("Hello world!","kHlleo");
?>

输出：

5

例子 2

<?php
echo strspn("abcdefand","abc");
?>

输出：

3

PHP String 函数

PHP 参考手册
PHP 测验


PHP strstr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strstr() 函数

PHP String 函数

定义和用法

strstr() 函数搜索一个字符串在另一个字符串中的第一次出现。

该函数返回字符串的其余部分（从匹配点）。如果未找到所搜索的字符串，则返回 false。

语法

strstr(string,search)
参数 | 描述
string | 必需。规定被搜索的字符串。
search | 必需。规定所搜索的字符串。如果该参数是数字，则搜索匹配数字 ASCII 值的字符。

提示和注释

注释：该函数是二进制安全的。

注释：该函数对大小写敏感。如需进行大小写不敏感的搜索，请使用 stristr()。

例子

例子 1

<?php
echo strstr("Hello world!","world");
?>

输出：

world!

例子 2

在本例中，我们将搜索 "o" 的 ASCII 值所代表的字符：

<?php
echo strstr("Hello world!",111);
?>

输出：

o world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strtok() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strtok() 函数

PHP String 函数

定义和用法

strtok() 函数把字符串分割为更小的字符串。

语法

strtok(string,split)
参数 | 描述
string | 必需。规定要分割的字符串。
split | 必需。规定一个或多个分割字符。

例子

在下面的例子中，请注意，我们仅在第一次调用 strtok() 函数时使用了 string 参数。在首次调用后，该函数仅需要 split 参数，这是因为它清楚自己在当前函数中所在的位置：

<?php
$string = "Hello world. Beautiful day today.";
$token = strtok($string, " ");

while ($token !== false)
  {
  echo "$token<br />";
  $token = strtok(" ");
  }
?>

输出：

Hello
world.
Beautiful
day
today.

PHP String 函数

PHP 参考手册
PHP 测验


PHP strtolower() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strtolower() 函数

PHP String 函数

定义和用法

strtolower() 函数把字符串转换为小写。

语法

strtolower(string)
参数 | 描述
string | 必需。规定要转换的字符串。

例子

<?php
echo strtolower("Hello WORLD!");
?>

输出：

hello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strtotime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strtotime() 函数

PHP Date / Time 函数

定义和用法

strtotime() 函数将任何英文文本的日期时间描述解析为 Unix 时间戳。

语法

strtotime(time,now)
参数 | 描述
time | 规定要解析的时间字符串。
now | 用来计算返回值的时间戳。如果省略该参数，则使用当前时间。

说明

该函数预期接受一个包含美国英语日期格式的字符串并尝试将其解析为 Unix 时间戳（自 January 1 1970 00:00:00 GMT 起的秒数），其值相对于 now 参数给出的时间，如果没有提供此参数，则用系统当前时间。

该函数将使用 TZ 环境变量（如果有的话）来计算时间戳。自 PHP 5.1.0 起有更容易的方法来定义时区用于所有的日期／时间函数。此过程在 date_default_timezone_get() 函数页面中有说明。

返回值

成功则返回时间戳，否则返回 FALSE。在 PHP 5.1.0 之前本函数在失败时返回 -1。

例子

<?php
echo(strtotime("now"));
echo(strtotime("3 October 2005"));
echo(strtotime("+5 hours"));
echo(strtotime("+1 week"));
echo(strtotime("+1 week 3 days 7 hours 5 seconds"));
echo(strtotime("next Monday"));
echo(strtotime("last Sunday"));
?>

输出：

1138614504
1128290400
1138632504
1139219304
1139503709
1139180400
1138489200

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP strtoupper() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strtoupper() 函数

PHP String 函数

定义和用法

strtoupper() 函数把字符串转换为大写。

语法

strtoupper(string)
参数 | 描述
string | 必需。规定要转换的字符串。

例子

<?php
echo strtoupper("Hello WORLD!");
?>

输出：

HELLO WORLD!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strtr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strtr() 函数

PHP String 函数

定义和用法

strtr() 函数转换字符串中特定的字符。

语法

strtr(string,from,to)

或者

strtr(string,array)
参数 | 描述
string1 | 必需。规定要转换的字符串。
from | 必需（除非使用数组）。规定要改变的字符。
to | 必需（除非使用数组）。规定要改变为的字符。
array | 必需（除非使用 from 和 to）。一个数组，其中的键是原始字符，值是目标字符。

说明

如果 from 和 to 的长度不同，则格式化为最短的长度。

例子

例子 1

<?php
echo strtr("Hilla Warld","ia","eo");
?>

输出：

Hello World

例子 2

<?php
$arr = array("Hello" => "Hi", "world" => "earth");
echo strtr("Hello world",$arr);
?>

输出：

Hi earth

PHP String 函数

PHP 参考手册
PHP 测验


PHP substr_compare() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP substr_compare() 函数

PHP String 函数

定义和用法

substr_compare() 函数从指定的开始长度比较两个字符串。

该函数返回：

  • 0 - 如果两字符串相等
  • <0 - 如果 string1 （从开始位置）小于 string2
  • >0 - 如果 string1 （从开始位置）大于 string2

语法

substr_compare(string1,string2,startpos,length,case)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。
startpos | 可选。规定在 string1 中的何处开始比较。
length | 可选。规定在 string1 中参与比较的字符数。
case | 可选。规定是否指定大小写比较。默认是 FALSE （对大小写敏感）。

说明

如果 length 大于或等于 string1 的长度，则函数返回 false。

例子

例子 1

<?php
echo substr_compare("Hello world","Hello world",0);
?>

输出：

0

例子 2

<?php
echo substr_compare("Hello world","world",6);
?>

输出：

0

例子 3

<?php
echo substr_compare("Hello world","WORLD",6,TRUE);
?>

输出：

0

PHP String 函数

PHP 参考手册
PHP 测验


PHP substr_count() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP substr_count() 函数

PHP String 函数

定义和用法

substr_count() 函数计算子串在字符串中出现的次数。

语法

substr_count(string,substring,start,length)
参数 | 描述
string | 必需。规定要检查的字符串。
replacement | 必需。规定要插入的字符串。
start | 可选。规定在字符串中何处开始搜索。
charlist | 可选。规定搜索的长度。

例子

<?php
echo substr_count("Hello world. The world is nice","world");
?>

输出：

2

PHP String 函数

PHP 参考手册
PHP 测验


PHP substr_replace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP substr_replace() 函数

PHP String 函数

定义和用法

substr_replace() 函数把字符串的一部分替换为另一个字符串。

语法

substr_replace(string,replacement,start,length)
参数 | 描述
string | 必需。规定要检查的字符串。
replacement | 必需。规定要插入的字符串。
start

必需。规定在字符串的何处开始替换。

  • 正数 - 在第 start 个偏移量开始替换
  • 负数 - 在从字符串结尾的第 start 个偏移量开始替换
  • 0 - 在字符串中的第一个字符处开始替换
charlist

可选。规定要替换多少个字符。

  • 正数 - 被替换的字符串长度
  • 负数 - 从字符串末端开始的被替换字符数
  • 0 - 插入而非替换

提示和注释

注释：如果 start 是负数且 length 小于等于 start，则 length 为 0。

例子

<?php
echo substr_replace("Hello world","earth",6);
?>

输出：

Hello earth

PHP String 函数

PHP 参考手册
PHP 测验


PHP substr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP substr() 函数

PHP String 函数

定义和用法

substr() 函数返回字符串的一部分。

语法

substr(string,start,length)
参数 | 描述
string | 必需。规定要返回其中一部分的字符串。
start

必需。规定在字符串的何处开始。

  • 正数 - 在字符串的指定位置开始
  • 负数 - 在从字符串结尾的指定位置开始
  • 0 - 在字符串中的第一个字符处开始
charlist

可选。规定要返回的字符串长度。默认是直到字符串的结尾。

  • 正数 - 从 start 参数所在的位置返回
  • 负数 - 从字符串末端返回

提示和注释

注释：如果 start 是负数且 length 小于等于 start，则 length 为 0。

例子

例子 1

<?php
echo substr("Hello world!",6);
?>

输出：

world!

例子 2

<?php
echo substr("Hello world!",6,5);
?>

输出：

world

PHP String 函数

PHP 参考手册
PHP 测验


PHP symlink() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP symlink() 函数

PHP Filesystem 函数

定义和用法

symlink() 函数创建符号连接。

语法

link(target,link)
参数 | 描述
target | 必需。
link | 必需。

说明

symlink() 对于已有的 target 建立一个名为 link 的符号连接。

若成功则返回 true，失败则返回 false。

提示和注释

注释：本函数未在 Windows 平台下实现。

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP tan() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP tan() 函数

PHP Math 函数

定义和用法

tan() 函数返回正切。

语法

tan(x)
参数 | 描述
x | 必需。一个数。

说明

tan() 返回参数 x 的正切值。参数 x 的单位为弧度

例子

在本例中，我们将返回不同的数的正切：

<?php
echo(tan(M_PI_4));
echo(tan(0.50));
echo(tan(-0.50));
echo(tan(5));
echo(tan(10));
echo(tan(-5));
echo(tan(-10));
?>

输出：

1
0.546302489844
-0.546302489844
-3.38051500625
0.648360827459
3.38051500625
-0.648360827459

PHP Math 函数

PHP 参考手册
PHP 测验


PHP tanh() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP tanh() 函数

PHP Math 函数

定义和用法

tanh() 函数返回双曲正切。

语法

tanh(x)
参数 | 描述
x | 必需。一个数。

说明

返回 x 的双曲正切值，定义为 sinh(arg)/cosh(arg)。

例子

在本例中，我们将返回不同的数的双曲正切：

<?php
echo(tanh(M_PI_4));
echo(tanh(0.50));
echo(tanh(-0.50));
echo(tanh(5));
echo(tanh(10));
echo(tanh(-5));
echo(tanh(-10))
?>

输出：

0.655794202633
0.46211715726
-0.46211715726
0.999909204263
0.999999995878
-0.999909204263
-0.999999995878

PHP Math 函数

PHP 参考手册
PHP 测验


PHP tempnam() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP tempnam() 函数

PHP Filesystem 函数

定义和用法

tempnam() 函数创建一个具有唯一文件名的临时文件。

若成功，则该函数返回新的临时文件名。若失败，则返回 false。

语法

tempnam(dir,prefix)
参数 | 描述
dir | 必需。规定创建临时文件的目录。
prefix | 必需。规定文件名的开头。

说明

在指定目录中建立一个具有唯一文件名的文件。如果该目录不存在，tempnam() 会在系统临时目录中生成一个文件，并返回其文件名。

在 PHP 4.0.6 之前，tempnam() 函数的行为取决于系统。在 Windows 下 TMP 环境变量会越过 dir 参数，在 Linux 下 TMPDIR 环境变量优先，而在 SVR4 下总是使用 dir 参数，如果其指向的目录存在的话。

提示和注释

注释：如果 PHP 不能在指定的 dir 参数中创建文件，则退回到系统默认值。

注释：本函数的行为在 4.0.3 版中改变了。也会建立一个临时文件以避免竞争情形，即有可能会在产生出作为文件名的字符串与脚本真正建立该文件之间会在文件系统中存在同名文件。注意，如果不再需要该文件则要删除此文件，不会自动删除的。

提示：参见 tmpfile()

例子

<?php
echo tempnam("C:\inetpub\testweb","TMP0");
?>

输出：

C:\inetpub\testweb\TMP1.tmp

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP time_nanosleep() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP time_nanosleep() 函数

PHP 杂项函数

定义和用法

time_nanosleep() 函数延迟代码执行若干秒和纳秒。

语法

time_nanosleep(seconds,nanoseconds)
参数 | 描述
seconds | 必需。必须是正整数。
nanoseconds | 必需。必须是小于 10 亿的正整数。

说明

延迟程序执行指定的 seconds 和 nanoseconds 数。

返回值

如果成功则返回 TRUE，失败则返回 FALSE

如果延迟被一个信号中断，将返回带有以下组件的关联数组：

  • seconds - 延迟中剩余的秒数
  • nanoseconds - 延迟中剩余的纳秒数

提示和注释

注释：本函数未在 Windows 平台下实现。

例子

<?php
if (time_nanosleep(3,500000000) === true)
  {
  echo "暂停 3 秒半";
  }
?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP time_sleep_until() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP time_sleep_until() 函数

PHP 杂项函数

定义和用法

time_sleep_until() 函数延迟代码执行直到指定的时间。

语法

time_sleep_until(timestamp)
参数 | 描述
timestamp | 必需。脚本唤醒时的时间戳。

说明

使脚本暂停执行，直到指定的 timestamp。

返回值

如果成功则返回 TRUE，失败则返回 FALSE。

错误／异常

如果指定的时间戳位于过去，则该函数将生成一个 E_WARNING。

提示和注释

注释：所有信号都将在脚本唤醒后递送。

注释：本函数未在 Windows 平台下实现。

例子

<?php
// 从现在起 10 秒后唤醒
time_sleep_until(time()+10);
?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP time() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP time() 函数

PHP Date / Time 函数

定义和用法

time() 函数返回当前时间的 Unix 时间戳。

语法

time(void)
参数 | 描述
void | 可选。

说明

返回自从 Unix 纪元（格林威治时间 1970 年 1 月 1 日 00:00:00）到当前时间的秒数。

提示和注释

提示：自 PHP 5.1 起在 $_SERVER['REQUEST_TIME'] 中保存了发起该请求时刻的时间戳。

例子

例子 1

<?php
$t=time();
echo($t . "<br />");
echo(date("D F d Y",$t));
?>

输出：

1138618081
Mon January 30 2006

例子 2

<?php
$nextWeek = time() + (7 * 24 * 60 * 60); // 7 days; 24 hours; 60 mins; 60secs
echo 'Now:       '. date('Y-m-d') ."\n";
echo 'Next Week: '. date('Y-m-d', $nextWeek) ."\n";
?>

输出：

Now:       2005-03-30
Next Week: 2005-04-07

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP tmpfile() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP tmpfile() 函数

PHP Filesystem 函数

定义和用法

tmpfile() 函数以读写（w+）模式建立一个具有唯一文件名的临时文件。

文件会在关闭后（用 fclose()）自动被删除，或当脚本结束后。

语法

tmpfile()

提示和注释

提示：参见 tempnam()。

例子

<?php
$temp = tmpfile();

fwrite($temp, "Testing, testing.");

//倒回文件的开头
rewind($temp);

//从文件中读取 1k
echo fread($temp,1024);

//删除文件
fclose($temp);
?>

输出：

Testing, testing.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP touch() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP touch() 函数

PHP Filesystem 函数

定义和用法

touch() 函数设置指定文件的访问和修改时间。

语法

touch(filename,time,atime)
参数 | 描述
filename | 必需。规定要接触的文件。
time | 可选。设置时间。默认是当前系统时间。
atime | 可选。设置访问时间。默认是当前系统时间。

说明

尝试将由 filename 给出的文件的访问和修改时间设定为指定的时间。如果没有设置可选参数 time，则使用当前系统时间。如果给出了第三个参数 atime，则指定文件的访问时间会被设为 atime 。

如果成功则返回 true，失败则返回 false。

提示和注释

注释：如果文件不存在，则会被创建。

例子

<?php
touch("test.txt");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP trim() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP trim() 函数

PHP String 函数

定义和用法

trim() 函数从字符串的两端删除空白字符和其他预定义字符。

语法

trim(string,charlist)
参数 | 描述
string | 必需。规定要检查的字符串。
charlist | 可选。规定要转换的字符串。

例子

<?php
echo ucfirst("hello world");
?>

输出：

Hello world

PHP String 函数

PHP 参考手册
PHP 测验


PHP uasort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP uasort() 函数

PHP Array 函数

定义和用法

uasort() 函数使用用户自定义的比较函数对数组排序，并保持索引关联（不为元素分配新的键）。

如果成功则返回 TRUE，否则返回 FALSE。

该函数主要用于对那些单元顺序很重要的结合数组进行排序。

语法

uasort(array,sorttype)
参数 | 描述
array | 必需。规定要排序的数组。
function

必需。用户自定义的函数。

函数必须设计为返回 -1, 0, 或 1，并应该接受两个供比较的参数，同时以类似下面这样的方式来工作：

  • 如果 a = b, 返回 0
  • 如果 a > b, 返回 1
  • 如果 a < b, 返回 -1

例子

<?php
function my_sort($a, $b)
  {
  if ($a == $b) return 0;
  return ($a > $b) ? -1 : 1;
  }

$people = array("Swanson" => "Joe",
"Griffin" => "Peter", "Quagmire" => "Glenn",
"swanson" => "joe", "griffin" => "peter",
"quagmire" => "glenn");

uasort($people, "my_sort");

print_r ($people);
?>

输出：

Array
(
[griffin] => peter
[swanson] => joe
[quagmire] => glenn
[Griffin] => Peter
[Swanson] => Joe
[Quagmire] => Glenn
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP ucfirst() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ucfirst() 函数

PHP String 函数

定义和用法

ucfirst() 函数把字符串中的首字符转换为大写。

语法

ucfirst(string)
参数 | 描述
string | 必需。规定要转换的字符串。

例子

<?php
echo ucfirst("hello world");
?>

输出：

Hello world

PHP String 函数

PHP 参考手册
PHP 测验


PHP ucwords() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ucwords() 函数

PHP String 函数

定义和用法

ucwords() 函数把字符串中每个单词的首字符转换为大写。

语法

ucwords(string)
参数 | 描述
string | 必需。规定要转换的字符串。

例子

<?php
echo ucwords("hello world");
?>

输出：

Hello World

PHP String 函数

PHP 参考手册
PHP 测验


PHP uksort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP uksort() 函数

PHP Array 函数

定义和用法

uksort() 函数使用用户自定义的比较函数按照键名对数组排序，并保持索引关系。

如果成功则返回 TRUE，否则返回 FALSE。

如果要排序的数组需要用一种不寻常的标准进行排序，那么应该使用此函数。

自定义函数应接受两个参数，该参数将被数组中的一对键名填充。比较函数在第一个参数小于，等于，或大于第二个参数时必须分别返回一个小于零，等于零，或大于零的整数。

语法

uksort(array,sorttype)
参数 | 描述
array | 必需。规定要排序的数组。
function

必需。用户自定义的函数。

函数必须设计为返回 -1, 0, 或 1，并应该接受两个供比较的参数，同时以类似下面这样的方式来工作：

  • 如果 a = b, 返回 0
  • 如果 a > b, 返回 1
  • 如果 a < b, 返回 -1

例子

<?php
function my_sort($a, $b)
  {
  if ($a == $b) return 0;
  return ($a > $b) ? -1 : 1;
  }

$people = array("Swanson" => "Joe",
"Griffin" => "Peter", "Quagmire" => "Glenn",
"swanson" => "joe", "griffin" => "peter",
"quagmire" => "glenn");

uksort($people, "my_sort");

print_r ($people);
?>

输出：

Array
(
[swanson] => joe
[quagmire] => glenn
[griffin] => peter
[Swanson] => Joe
[Quagmire] => Glenn
[Griffin] => Peter
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP umask() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP umask() 函数

PHP Filesystem 函数

定义和用法

umask() 函数改变当前的 umask。

umask() 将 PHP 的 umask 设定为 mask & 0777 并返回原来的 umask。当 PHP 被作为服务器模块使用时，在每个请求结束后 umask 会被恢复。

无参数调用 umask() 会返回当前的 umask。

语法

umask(mask)
参数 | 描述
mask | 必需。规定新的权限。默认是 0777。

提示和注释

注释：在多线程的服务器上尽量避免使用这个函数。创建文件后要改变其权限最好还是使用 chmod()。使用 umask() 会导致并发程序和服务器发生不可预知的情况，因为它们使用相同的 umask。

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP uniqid() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP uniqid() 函数

PHP 杂项函数

定义和用法

uniqid() 函数基于以微秒计的当前时间，生成一个唯一的 ID。

语法

uniqid(prefix,more_entropy)
参数 | 描述
prefix | 可选。为 ID 规定前缀。如果两个脚本在相同的微妙生成 ID，该参数很有用。
more_entropy | 可选。规定位于返回值末尾的更多的熵。

说明

如果 prefix 参数为空，则返回的字符串有 13 个字符串长。如果 more_entropy 参数设置为 true，则是 23 个字符串长。

如果 more_entropy 参数设置为 true，则在返回值的末尾添加额外的熵（使用组合线形同余数生成程序），这样可以结果的唯一性更好。

返回值

以字符串的形式返回唯一标识符。

提示和注释

注释：由于基于系统时间，通过该函数生成的 ID 不是最佳的。如需生成绝对唯一的 ID，请使用 md5() 函数（请在字符串函数参考中查找）。

例子

<?php
echo uniqid();
?>

输出类似：

4415297e3af8c

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP UnixToJD() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP UnixToJD() 函数

PHP Array 函数

定义和用法

UnixToJD() 函数把 Unix 时间戳转换为儒略日计数。

语法

unixtojd(timestamp)
参数 | 描述
timestamp | 可选。

提示和注释：

注释：Unix 时间戳指示的是从格利高里历（不是罗马儒略历）的 1970 年 1 月 1 日至今的秒数。

例子

<?php
echo(unixtojd());
?>

输出：

2453755

PHP Array 函数

PHP 参考手册
PHP 测验


PHP unlink() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP unlink() 函数

PHP Filesystem 函数

定义和用法

unlink() 函数删除文件。

若成功，则返回 true，失败则返回 false。

语法

unlink(filename,context)
参数 | 描述
filename | 必需。规定要删除的文件。
context | 可选。规定文件句柄的环境。Context 是可修改流的行为的一套选项。

提示和注释

注释：对 context 的支持是 PHP 5.0.0 添加的。

例子

<?php
$file = "test.txt";
if (!unlink($file))
  {
  echo ("Error deleting $file");
  }
else
  {
  echo ("Deleted $file");
  }
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP unpack() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP unpack() 函数

PHP 杂项函数

定义和用法

unpack() 函数从二进制字符串对数据进行解包。

语法

unpack(format,data)
参数 | 描述
format | 必需。规定在解包数据时所使用的格式。
data | 可选。规定被解包的二进制数据。

format 参数的可能值：

  • a - NUL-padded string
  • A - SPACE-padded string
  • h - Hex string, low nibble first
  • H - Hex string, high nibble first
  • c - signed char
  • C - unsigned char
  • s - signed short (always 16 bit, machine byte order)
  • S - unsigned short (always 16 bit, machine byte order)
  • n - unsigned short (always 16 bit, big endian byte order)
  • v - unsigned short (always 16 bit, little endian byte order)
  • i - signed integer (machine dependent size and byte order)
  • I - unsigned integer (machine dependent size and byte order)
  • l - signed long (always 32 bit, machine byte order)
  • L - unsigned long (always 32 bit, machine byte order)
  • N - unsigned long (always 32 bit, big endian byte order)
  • V - unsigned long (always 32 bit, little endian byte order)
  • f - float (machine dependent size and representation)
  • d - double (machine dependent size and representation)
  • x - NUL byte
  • X - Back up one byte
  • @ - NUL-fill to absolute position

例子

例子 1

<?php
$data = "PHP";
print_r(unpack("C*",$data));
?>

输出：

Array
(
[1] => 80
[2] => 72
[3] => 80
)

例子 2

<?php
$data = "PHP";
print_r(unpack("C*myint",$data));
?>

输出：

Array
(
[myint1] => 80
[myint2] => 72
[myint3] => 80
)

例子 3

<?php
$bin = pack("c2n2",0x1234,0x5678,65,66);
print_r(unpack("c2chars/n2int",$bin));
?>

输出：

Array
(
[chars1] => 52
[chars2] => 120
[int1] => 65
[int2] => 66
)

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP usleep() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP usleep() 函数

PHP 杂项函数

定义和用法

usleep() 函数延迟代码执行若干微秒。

语法

usleep(microseconds)
参数 | 描述
microseconds | 必需。以微秒计的暂停时间。

返回值

无返回值。

提示和注释

注释：在 PHP 5 之前，该函数无法工作于 Windows 系统上。

注释：一微秒等于百万分之一秒。

例子

<?php
echo date('h:i:s') . "<br />";

//延迟 10 描述
usleep(10000000);

//再次开始
echo date('h:i:s');
?>

输出：

09:23:14
09:23:24

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP usort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP usort() 函数

PHP Array 函数

定义和用法

usort() 函数使用用户自定义的函数对数组排序。

注释：如果两个元素比较结果相同，则它们在排序后的数组中的顺序未经定义。到 PHP 4.0.6 之前，用户自定义函数将保留这些元素的原有顺序。但是由于在 4.1.0 中引进了新的排序算法，结果将不是这样了，因为对此没有一个有效的解决方案。

注释：本函数为 array 中的元素赋予新的键名。这会删除原有的键名。

语法

usort(array,sorttype)
参数 | 描述
array | 必需。规定要排序的数组。
function

必需。用户自定义的函数。

函数必须设计为返回 -1, 0, 或 1，并应该接受两个供比较的参数，同时以类似下面这样的方式来工作：

  • 如果 a = b, 返回 0
  • 如果 a > b, 返回 1
  • 如果 a < b, 返回 -1

例子

<?php
function my_sort($a, $b)
  {
  if ($a == $b) return 0;
  return ($a > $b) ? -1 : 1;
  }

$arr = array("Peter", "glenn","Cleveland","peter","cleveland", "Glenn");

usort($arr, "my_sort");

print_r ($arr);
?>

输出：

Array
(
[0] => peter
[1] => glenn
[2] => cleveland
[3] => Peter
[4] => Glenn
[5] => Cleveland
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP utf8_decode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP utf8_decode() 函数

PHP XML Parser 函数

定义和用法

utf8_decode() 函数把 UTF-8 字符串解码为 ISO-8859-1。

该函数把用 UTF-8 方式编码的 ISO-8859-1 字符串转换成单字节的 ISO-8859-1 字符串。

如果成功，该函数将返回解码字符串；否则返回 false。

语法

utf8_decode(string)
参数 | 描述
string | 必需。规定要解码的字符串。

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP utf8_encode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP utf8_encode() 函数

PHP XML Parser 函数

定义和用法

utf8_encode() 函数把 ISO-8859-1 字符串编码为 UTF-8。

Unicode 是全球标准，已经发展到能够通过唯一的编码来描述所有语言中的字符，外加大量的符号。

不过，并不是总能可靠地在计算机之间传递 Unicode 字符。UTF-8 可用于在计算机之间传输 Unicode 字符。

如果成功，该函数将返回编码字符串；否则返回 false。

语法

utf8_encode(string)
参数 | 描述
string | 必需。规定要编码的字符串。

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP vfprintf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP vfprintf() 函数

PHP String 函数

定义和用法

vfprintf() 函数把格式化的字符串写到指定的输出流。

与 fprintf() 不同，vfprintf() 中的 arg 参数位于数组中。数组的元素会被插入主字符串的百分比 (%) 符号处。该函数是逐步执行的。在第一个 % 符号中，插入 arg1，在第二个 % 符号处，插入 arg2，依此类推。

该函数返回被写的字符串的长度。

语法

vfprintf(stream,format,argarray)
参数 | 描述
stream | 必需。规定在何处写/输出字符串。
format | 必需。转换格式。
argarray | 必需。带有参数的一个数组，这些参数会被插到 format 字符串中的 % 符号处。

说明

参数 format 是转换的格式，以百分比符号 ("%") 开始到转换字符结束。下面的可能的 format 值：

  • %% - 返回百分比符号
  • %b - 二进制数
  • %c - 依照 ASCII 值的字符
  • %d - 带符号十进制数
  • %e - 可续计数法（比如 1.5e+3）
  • %u - 无符号十进制数
  • %f - 浮点数(local settings aware)
  • %F - 浮点数(not local settings aware)
  • %o - 八进制数
  • %s - 字符串
  • %x - 十六进制数（小写字母）
  • %X - 十六进制数（大写字母）

提示和注释

注释：如果 % 符号多于 arg 参数，则您必须使用占位符。占位符插到 % 符号后面，由数字和 "\$" 组成。请参见例子 3。

提示：
相关函数：
fprintf()、
printf()、
sprintf()、
vprintf() 以及
vsprintf()。

例子

例子 1

<?php
$str = "Hello";
$number = 123;
$txt = sprintf("%s world. Day number %u",$str,$number);
echo $txt;
?>

输出：

Hello world. Day number 123

例子 2

<?php
$number = 123;
$txt = sprintf("%f",$number);
echo $txt;
?>

输出：

123.000000

例子 3

<?php
$number = 123;
$txt = sprintf("With 2 decimals: %1\$.2f<br />With no decimals: %1\$u",$number);
echo $txt;
?>

输出：

With 2 decimals: 123.00
With no decimals: 123

PHP String 函数

PHP 参考手册
PHP 测验


PHP vprintf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP vprintf() 函数

PHP String 函数

定义和用法

vprintf() 函数输出格式化的字符串。

与 printf() 不同，vprintf() 中的 arg 参数位于数组中。数组的元素会被插入主字符串的百分比 (%) 符号处。该函数是逐步执行的。在第一个 % 符号中，插入 arg1，在第二个 % 符号处，插入 arg2，依此类推。

语法

vprintf(format,argarray)
参数 | 描述
format | 必需。转换格式。
argarray | 必需。带有参数的一个数组，这些参数会被插到 format 字符串中的 % 符号处。

说明

参数 format 是转换的格式，以百分比符号 ("%") 开始到转换字符结束。下面的可能的 format 值：

  • %% - 返回百分比符号
  • %b - 二进制数
  • %c - 依照 ASCII 值的字符
  • %d - 带符号十进制数
  • %e - 可续计数法（比如 1.5e+3）
  • %u - 无符号十进制数
  • %f - 浮点数(local settings aware)
  • %F - 浮点数(not local settings aware)
  • %o - 八进制数
  • %s - 字符串
  • %x - 十六进制数（小写字母）
  • %X - 十六进制数（大写字母）

提示和注释

注释：如果 % 符号多于 arg 参数，则您必须使用占位符。占位符插到 % 符号后面，由数字和 "\$" 组成。请参见例子 3。

提示：
相关函数：
fprintf()、
printf()、
sprintf()、
vfprintf() 以及
vsprintf()。

例子

例子 1

<?php
$str = "Hello";
$number = 123;
vprintf("%s world. Day number %u",array($str,$number));
?>

输出：

Hello world. Day number 123

例子 2

<?php
$num1 = 123;
$num2 = 456;
vprintf("%f%f",array($num1,$num2));
?>

输出：

123.000000456.000000

例子 3

使用占位符：

<?php
$number = 123;
vprintf("With 2 decimals: %1\$.2f<br />With no decimals: %1\$u",array($number));
?>

输出：

With 2 decimals: 123.00
With no decimals: 123

PHP String 函数

PHP 参考手册
PHP 测验


PHP vsprintf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP vsprintf() 函数

PHP String 函数

定义和用法

vsprintf() 函数把格式化字符串写入变量中。

与 sprintf() 不同，vsprintf() 中的 arg 参数位于数组中。数组的元素会被插入主字符串的百分比 (%) 符号处。该函数是逐步执行的。在第一个 % 符号中，插入 arg1，在第二个 % 符号处，插入 arg2，依此类推。

语法

vsprintf(format,argarray)
参数 | 描述
format | 必需。转换格式。
argarray | 必需。带有参数的一个数组，这些参数会被插到 format 字符串中的 % 符号处。

说明

参数 format 是转换的格式，以百分比符号 ("%") 开始到转换字符结束。下面的可能的 format 值：

  • %% - 返回百分比符号
  • %b - 二进制数
  • %c - 依照 ASCII 值的字符
  • %d - 带符号十进制数
  • %e - 可续计数法（比如 1.5e+3）
  • %u - 无符号十进制数
  • %f - 浮点数(local settings aware)
  • %F - 浮点数(not local settings aware)
  • %o - 八进制数
  • %s - 字符串
  • %x - 十六进制数（小写字母）
  • %X - 十六进制数（大写字母）

提示和注释

注释：如果 % 符号多于 arg 参数，则您必须使用占位符。占位符插到 % 符号后面，由数字和 "\$" 组成。请参见例子 3。

提示：
相关函数：
fprintf()、
printf()、
sprintf()、
vfprintf() 以及
vprintf()。

例子

例子 1

<?php
$str = "Hello";
$number = 123;
$txt = vsprintf("%s world. Day number %u",array($str,$number));
echo $txt;
?>

输出：

Hello world. Day number 123

例子 2

<?php
$num1 = 123;
$num2 = 456;
$txt = vsprintf("%f%f",array($num1,$num2));
echo $txt;
?>

输出：

123.000000456.000000

例子 3

使用占位符：

<?php
$number = 123;
$txt = vsprintf("With 2 decimals: %1\$.2f
<br />With no decimals: %1\$u",array($number));
echo $txt;
?>

输出：

With 2 decimals: 123.00
With no decimals: 123

PHP String 函数

PHP 参考手册
PHP 测验


PHP wordwrap() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP wordwrap() 函数

PHP String 函数

定义和用法

wordwrap() 函数按照指定长度对字符串进行折行处理。

如果成功，则返回折行后的字符串。如果失败，则返回 false。

语法

wordwrap(string,width,break,cut)
参数 | 描述
string | 必需。规定要进行折行的字符串。
width | 可选。规定最大行宽度。默认是 75。
break | 可选。规定作为分隔符使用的字符（字串断开字符）。默认是 "\n"。
cut | 可选。规定是否对大约指定宽度的单词进行折行。默认是 FALSE (no-wrap)。

例子

例子 1

<?php
$str = "An example on a long word is: Supercalifragulistic";
echo wordwrap($str,15);
?>

浏览器输出：

An example on a long word is: Supercalifragulistic

HTML 源代码：

<html>
<body>
An example on a
long word is:
Supercalifragulistic
</body>
</html>

例子 2

<?php
$str = "An example on a long word is: Supercalifragulistic";
echo wordwrap($str,15,"<br />\n");
?>

输出：

An example on a
long word is:
Supercalifragulistic

例子 3

<?php
$str = "An example on a long word is: Supercalifragulistic";
echo wordwrap($str,15,"<br />\n",TRUE);
?>

输出：

An example on a
long word is:
Supercalifragul
istic

PHP String 函数

PHP 参考手册
PHP 测验


PHP xml_error_string() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_error_string() 函数

PHP XML Parser 函数

定义和用法

xml_error_string() 函数获取 XML 解析器的错误描述。

语法

xml_error_string(errorcode)
参数 | 描述
errorcode | 必需。规定要使用的错误代码。该错误码是 xml_get_error_code() 函数的返回值。

说明

返回与 errorcode 描述的错误代码参数对应的文本描述字符串，若没有与之对应的描述，则返回 false。

例子

<?php
//无效的 xml 文件
$xmlfile = 'test.xml';

$xmlparser = xml_parser_create();

// open a file and read data
$fp = fopen($xmlfile, 'r');
while ($xmldata = fread($fp, 4096))
  {
  // parse the data chunk
  if (!xml_parse($xmlparser,$xmldata,feof($fp)))
    {
    die( print "ERROR: "
    . xml_error_string(xml_get_error_code($xmlparser))
    . "<br />"
    . "Line: "
    . xml_get_current_line_number($xmlparser)
    . "<br />"
    . "Column: "
    . xml_get_current_column_number($xmlparser)
    . "<br />");
    }
  }

xml_parser_free($xmlparser);
?>

输出：

ERROR: Mismatched tag
Line: 8
Column: 51

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_get_current_byte_index() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_get_current_byte_index() 函数

PHP XML Parser 函数

定义和用法

xml_get_current_byte_index() 函数获取 XML 解析器的当前字节索引。

语法

xml_get_current_byte_index(parser)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。

说明

如果 parser 没有指向一个合法的解析器，该函数将返回 false，否则将返回解析器当前在其数据缓冲区中的字节索引（起始值为 0）。

例子

<?php
//无效的 xml 文件
$xmlfile = 'test.xml';

$xmlparser = xml_parser_create();

// 打开文件并读取数据
$fp = fopen($xmlfile, 'r');
while ($xmldata = fread($fp, 4096))
  {
  // parse the data chunk
  if (!xml_parse($xmlparser,$xmldata,feof($fp)))
    {
    die( print "ERROR: "
    . xml_error_string(xml_get_error_code($xmlparser))
    . "<br />"
    . "Line: "
    . xml_get_current_line_number($xmlparser)
    . "<br />"
    . "Column: "
    . xml_get_current_column_number($xmlparser)
    . "<br />"
    . "Byte Index: "
    . xml_get_current_byte_index($xmlparser)
    . "<br />");
    }
  }

xml_parser_free($xmlparser);
?>

输出：

ERROR: Mismatched tag
Line: 8
Column: 51
Byte Index: 96

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_get_current_column_number() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_get_current_column_number() 函数

PHP XML Parser 函数

定义和用法

xml_get_current_column_number() 函数获取 XML 解析器的当前列号。

语法

xml_get_current_byte_index(parser)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。

说明

如果 parser 参数没有指向一个合法的解析器，该函数将返回 false。否则将返回指定解析器所在行（由函数 xml_get_current_line_number() 给定）的当前列号。

例子

<?php
//无效 xml 文件
$xmlfile = 'test.xml';

$xmlparser = xml_parser_create();

// 打开文件并读取数据
$fp = fopen($xmlfile, 'r');
while ($xmldata = fread($fp, 4096))
  {
  // parse the data chunk
  if (!xml_parse($xmlparser,$xmldata,feof($fp)))
    {
    die( print "ERROR: "
    . xml_error_string(xml_get_error_code($xmlparser))
    . "<br />"
    . "Line: "
    . xml_get_current_line_number($xmlparser)
    . "<br />"
    . "Column: "
    . xml_get_current_column_number($xmlparser)
    . "<br />");
    }
  }

xml_parser_free($xmlparser);
?>

输出：

ERROR: Mismatched tag
Line: 8
Column: 61

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_get_current_line_number() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_get_current_line_number() 函数

PHP XML Parser 函数

定义和用法

xml_get_current_line_number() 函数获取 XML 解析器的当前行号。

语法

xml_get_current_line_number(parser)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。

说明

如果 parser 参数没有指向一个合法的解析器，该函数将返回 FALSE，否则将返回指定解析器在其缓存中的当前行号。

例子

<?php
//无效 xml 文件
$xmlfile = 'test.xml';

$xmlparser = xml_parser_create();

// 打开文件并读取数据
$fp = fopen($xmlfile, 'r');
while ($xmldata = fread($fp, 4096))
  {
  // parse the data chunk
  if (!xml_parse($xmlparser,$xmldata,feof($fp)))
    {
    die( print "ERROR: "
    . xml_error_string(xml_get_error_code($xmlparser))
    . "<br />"
    . "Line: "
    . xml_get_current_line_number($xmlparser)
    . "<br />"
    . "Column: "
    . xml_get_current_column_number($xmlparser)
    . "<br />");
    }
  }

xml_parser_free($xmlparser);
?>

输出：

ERROR: Mismatched tag
Line: 8
Column: 61

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_get_error_code() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_get_error_code() 函数

PHP XML Parser 函数

定义和用法

xml_get_error_code() 函数获取 XML 解析器错误代码。

如果成功，则返回错误代码。否则，返回 false。

语法

xml_get_error_code(parser)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。

例子

<?php
//无效的 xml 文件
$xmlfile = 'test.xml';

$xmlparser = xml_parser_create();

// 打开文件并读取数据
$fp = fopen($xmlfile, 'r');
while ($xmldata = fread($fp, 4096))
  {
  // parse the data chunk
  if (!xml_parse($xmlparser,$xmldata,feof($fp)))
    {
    die( print "ERROR: "
    . xml_get_error_code($xmlparser)
    . "<br />"
    . "Line: "
    . xml_get_current_line_number($xmlparser)
    . "<br />"
    . "Column: "
    . xml_get_current_column_number($xmlparser)
    . "<br />");
    }
  }

xml_parser_free($xmlparser);
?>

输出：

ERROR: 76
Line: 8
Column: 61

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parse_into_struct() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parse_into_struct() 函数

PHP XML Parser 函数

定义和用法

xml_parse_into_struct() 函数把 XML 数据解析到数组中。

该函数把 XML 数据解析到 2 个数组中：

  • Value 数组 - 包含来自被解析的 XML 的数据
  • Index 数组 - 包含指向Value 数组中值的位置的指针

如果成功，则该函数返回 1。否则返回 0。

语法

xml_parse_into_struct(parser,xml,value_arr,index_arr)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
xml | 必需。规定要解析的 XML 数据。
parser | 必需。规定 XML 数据的目标数组。
parser | 可选。规定 index 数据的目标数组。

提示和注释

注释：xml_parse_into_struct() 若失败返回 0，成功则返回 1。这和 false 与 true 不同，使用例如 === 运算符时要注意。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
//无效 xml 文件
$xmlfile = 'test.xml';
$xmlparser = xml_parser_create();

// 打开文件并读取数据
$fp = fopen($xmlfile, 'r');
$xmldata = fread($fp, 4096);

xml_parse_into_struct($xmlparser,$xmldata,$values);

xml_parser_free($xmlparser);
print_r($values);
?>

输出：

Array
(
[0] => Array
  (
  [tag] => NOTE
  [type] => open
  [level] => 1
  [value] =>
  )
  [1] => Array
    (
    [tag] => TO
    [type] => complete
    [level] => 2
    [value] => George
    )
[2] => Array
  (
  [tag] => NOTE
  [value] =>
  [type] => cdata
  [level] => 1
  )
  [3] => Array
    (
    [tag] => FROM
    [type] => complete
    [level] => 2
    [value] => John
    )
[4] => Array
  (
  [tag] => NOTE
  [value] =>
  [type] => cdata
  [level] => 1
  )
  [5] => Array
    (
    [tag] => HEADING
    [type] => complete
    [level] => 2
    [value] => Reminder
    )
[6] => Array
  (
  [tag] => NOTE
  [value] =>
  [type] => cdata
  [level] => 1
  )
  [7] => Array
    (
    [tag] => BODY
    [type] => complete
    [level] => 2
    [value] => Don't forget the meeting!
    )
[8] => Array
  (
  [tag] => NOTE
  [value] =>
  [type] => cdata
  [level] => 1
  )
[9] => Array
  (
  [tag] => NOTE
  [type] => close
  [level] => 1
  )
)

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parse() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parse() 函数

PHP XML Parser 函数

定义和用法

xml_parse() 函数解析 XML 文档。

如果成功，则返回 true。否则，返回 false。

语法

xml_parse(parser,xml,end)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
xml | 必需。规定要解析的 XML 数据。
end | 可选。如果该参数是 true，则 xml 参数中的数据为当前解析中最后一段数据。

提示和注释

提示：要创建 XML 解析器，请使用 xml_parser_create() 函数。

例子

<?php
//无效的 xml 文件
$xmlfile = 'test.xml';

$xmlparser = xml_parser_create();

// 打开文件并读取数据
$fp = fopen($xmlfile, 'r');
while ($xmldata = fread($fp, 4096))
  {
  // parse the data chunk
  if (!xml_parse($xmlparser,$xmldata,feof($fp)))
    {
    die( print "ERROR: "
    . xml_get_error_code($xmlparser)
    . "<br />"
    . "Line: "
    . xml_get_current_line_number($xmlparser)
    . "<br />"
    . "Column: "
    . xml_get_current_column_number($xmlparser)
    . "<br />");
    }
  }

xml_parser_free($xmlparser);
?>

输出：

ERROR: 76
Line: 8
Column: 61

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parser_create_ns() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parser_create_ns() 函数

PHP XML Parser 函数

定义和用法

xml_parser_create_ns() 函数创建带有命名空间支持的 XML 解析器。

该函数建立一个新的 XML 解析器并返回可被其它 XML 函数使用的资源句柄。

语法

xml_parser_create_ns(encoding,separator)
参数 | 描述
encoding | 可选。规定输出编码。
encoding | 可选。规定标签名和命名空间的输出分隔符。默认是 ":"。

说明

可选参数 encoding 在 PHP 4 中用来指定要被解析的 XML 输入的字符编码方式。

PHP 5 开始，自动侦测输入的 XML 的编码，因此 encoding 参数仅用来指定解析后输出数据的编码。

在 PHP 4 中，默认输出的编码与输入数据的编码是相同的。如果传递了空字符串，解析器会尝试搜索头 3 或 4 个字节以确定文档的编码。

在 PHP 5.0.0 和 5.0.1 中，默认输出的字符编码是 ISO-8859-1，而 PHP 5.0.2 及以上版本是 UTF-8。

解析器支持的编码有 ISO-8859-1, UTF-8 和 US-ASCII。

提示和注释

提示：要释放 XML 解析器，请使用 xml_parser_free() 函数。

提示：要创建没有命名空间支持的 XML 解析器，请使用 xml_parser_create() 函数。

例子

<?php
$xmlparser = xml_parser_create_ns();

xml_parser_free($xmlparser);
?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parser_create() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parser_create() 函数

PHP XML Parser 函数

定义和用法

xml_parser_create() 函数创建 XML 解析器。

该函数建立一个新的 XML 解析器并返回可被其它 XML 函数使用的资源句柄。

语法

xml_parser_create(encoding)
参数 | 描述
encoding | 可选。规定输出编码。

说明

可选参数 encoding 在 PHP 4 中用来指定要被解析的 XML 输入的字符编码方式。

PHP 5 开始，自动侦测输入的 XML 的编码，因此 encoding 参数仅用来指定解析后输出数据的编码。

在 PHP 4 中，默认输出的编码与输入数据的编码是相同的。如果传递了空字符串，解析器会尝试搜索头 3 或 4 个字节以确定文档的编码。

在 PHP 5.0.0 和 5.0.1 中，默认输出的字符编码是 ISO-8859-1，而 PHP 5.0.2 及以上版本是 UTF-8。

解析器支持的编码有 ISO-8859-1, UTF-8 和 US-ASCII。

提示和注释

提示：要释放 XML 解析器，请使用 xml_parser_free() 函数。

提示：要创建带有命名空间支持的 XML 解析器，请使用 xml_parser_create_ns() 函数。

例子

<?php
$xmlparser = xml_parser_create();

xml_parser_free($xmlparser);
?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parser_free() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parser_free() 函数

PHP XML Parser 函数

定义和用法

xml_parser_free() 函数释放 XML 解析器。

如果成功，则返回 true。否则返回 false。

语法

xml_parser_free(parser)
参数 | 描述
parser | 必需。规定要释放的 XML 解析器。

提示和注释

提示：要创建 XML 解析器，请使用 xml_parser_create() 函数。

例子

<?php
$xmlparser = xml_parser_create();

xml_parser_free($xmlparser);
?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parser_get_option() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parser_get_option() 函数

PHP XML Parser 函数

定义和用法

xml_parser_get_option() 函数从 XML 解析器获取选项设置信息。

语法

xml_parser_get_option(parser,option)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
option

必需。规定要获取的设置选项名称。可能的值：

  • XML_OPTION_CASE_FOLDING
  • XML_OPTION_TARGET_ENCODING

说明

如果 parser 参数没有指向一个合法的解析器或者 option 参数无效，该函数将返回 FALSE（同时产生 E_WARNING 警告）。否则将返回指定设置选项的值。

例子

<?php
$xmlparser = xml_parser_create();

echo xml_parser_get_option($xmlparser, XML_OPTION_CASE_FOLDING);

xml_parser_free($xmlparser);
?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parser_set_option() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parser_set_option() 函数

PHP XML Parser 函数

定义和用法

xml_parser_set_option() 函数为 XML 解析器进行选项设置。

如果成功，则返回 true。如果失败，则返回 false。

语法

xml_parser_set_option(parser,option,value)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
option

必需。规定要设置的设置选项名称。可能的值：

  • XML_OPTION_CASE_FOLDING
  • XML_OPTION_SKIP_TAGSTART
  • XML_OPTION_SKIP_WHITE
  • XML_OPTION_TARGET_ENCODING
value | 必需。规定选项的新值。

例子

<?php
$xmlparser = xml_parser_create();

xml_parser_set_option($xmlparser, XML_OPTION_SKIP_WHITE, 1);

xml_parser_free($xmlparser);
?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP XML Parser 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP XML Parser 函数

  • Previous Page
  • Next Page

PHP XML Parser 简介

XML 函数允许我们解析 XML 文档，但无法对其进行验证。

XML 是一种用于标准结构化文档交换的数据格式。您可以在我们的 XML 教程 中找到更多有关 XML 的信息。

该扩展使用 Expat XML 解析器。

Expat 是一种基于事件的解析器，它把 XML 文档视为一系列事件。当某个事件发生时，它调用一个指定的函数处理它。

Expat 是无验证的解析器，忽略任何链接到文档的 DTD。但是，如果文档的形式不好，则会以一个错误消息结束。

由于它基于事件，且无验证，Expat 具有快速并适合 web 应用程序的特性。

XML 解析器函数允许我们创建 XML 解析器，并为 XML 事件定义句柄。

安装

XML 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP XML Parser 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
utf8_decode() | 把 UTF-8 字符串解码为 ISO-8859-1。 | 3
utf8_encode() | 把 ISO-8859-1 字符串编码为 UTF-8。 | 3
xml_error_string() | 获取 XML 解析器的错误描述。 | 3
xml_get_current_byte_index() | 获取 XML 解析器的当前字节索引。 | 3
xml_get_current_column_number() | 获取 XML 解析器的当前列号。 | 3
xml_get_current_line_number() | 获取 XML 解析器的当前行号。 | 3
xml_get_error_code() | 获取 XML 解析器错误代码。 | 3
xml_parse() | 解析 XML 文档。 | 3
xml_parse_into_struct() | 把 XML 数据解析到数组中。 | 3
xml_parser_create_ns() | 创建带有命名空间支持的 XML 解析器。 | 4
xml_parser_create() | 创建 XML 解析器。 | 3
xml_parser_free() | 释放 XML 解析器。 | 3
xml_parser_get_option() | 从 XML 解析器获取选项设置信息。 | 3
xml_parser_set_option() | 为 XML 解析进行选项设置。 | 3
xml_set_character_data_handler() | 建立字符数据处理器。 | 3
xml_set_default_handler() | 建立默认的数据处理器。 | 3
xml_set_element_handler() | 建立起始和终止元素处理器。 | 3
xml_set_end_namespace_decl_handler() | 建立终止命名空间声明处理器。 | 4
xml_set_external_entity_ref_handler() | 建立外部实体处理器。 | 3
xml_set_notation_decl_handler() | 建立注释声明处理器。 | 3
xml_set_object() | 在对象中使用 XML 解析器。 | 4
xml_set_processing_instruction_handler() | 建立处理指令（PI）处理器。 | 3
xml_set_start_namespace_decl_handler() | 建立起始命名空间声明处理器。 | 4
xml_set_unparsed_entity_decl_handler() | 建立未解析实体定义声明处理器。 | 3

PHP XML Parser 常量

Constant
XML_ERROR_NONE (integer)
XML_ERROR_NO_MEMORY (integer)
XML_ERROR_SYNTAX (integer)
XML_ERROR_NO_ELEMENTS (integer)
XML_ERROR_INVALID_TOKEN (integer)
XML_ERROR_UNCLOSED_TOKEN (integer)
XML_ERROR_PARTIAL_CHAR (integer)
XML_ERROR_TAG_MISMATCH (integer)
XML_ERROR_DUPLICATE_ATTRIBUTE (integer)
XML_ERROR_JUNK_AFTER_DOC_ELEMENT (integer)
XML_ERROR_PARAM_ENTITY_REF (integer)
XML_ERROR_UNDEFINED_ENTITY (integer)
XML_ERROR_RECURSIVE_ENTITY_REF (integer)
XML_ERROR_ASYNC_ENTITY (integer)
XML_ERROR_BAD_CHAR_REF (integer)
XML_ERROR_BINARY_ENTITY_REF (integer)
XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF (integer)
XML_ERROR_MISPLACED_XML_PI (integer)
XML_ERROR_UNKNOWN_ENCODING (integer)
XML_ERROR_INCORRECT_ENCODING (integer)
XML_ERROR_UNCLOSED_CDATA_SECTION (integer)
XML_ERROR_EXTERNAL_ENTITY_HANDLING (integer)
XML_OPTION_CASE_FOLDING (integer)
XML_OPTION_TARGET_ENCODING (integer)
XML_OPTION_SKIP_TAGSTART (integer)
XML_OPTION_SKIP_WHITE (integer)
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP xml_set_character_data_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_character_data_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_character_data_handler() 函数建立字符数据处理器。

该函数规定当解析器在 XML 文件中找到字符数据时所调用的函数。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

语法

xml_set_character_data_handler(parser,handler)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
handler | 必需。规定作为事件处理器使用的函数。

由 handler 参数规定的函数必须有两个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
data | 必需。规定包含字符数据的变量。

说明

handler 参数也可以是一个数组，其中包含对象引用和方法名。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php

$parser=xml_parser_create();

function char($parser,$data)
  {
  echo $data;
  }

xml_set_character_data_handler($parser,"char");
$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);
?>

输出：

George John Reminder Don't forget the meeting!

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_default_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_default_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_default_handler() 函数为 XML 解析器建立默认的数据处理器。

该函数规定在只要解析器在 XML 文件中找到数据时，所调用的函数。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

语法

xml_set_default_handler(parser,handler)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
handler | 必需。规定作为事件处理器使用的函数。

由 handler 参数规定的函数必须有三个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
data | 必需。规定包含数据的变量。

说明

handler 参数也可以是一个数组，其中包含对象引用和方法名。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php

$parser=xml_parser_create();

function default($parser,$data)
  {
  echo $data;
  }

xml_set_default_handler($parser,"default");
$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);
?>

输出：

George John Reminder Don't forget the meeting!

如果在浏览器中查看源代码，会看到下列 HTML：

<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_element_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_element_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_element_handler() 函数建立起始和终止元素处理器。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

语法

xml_set_element_handler(parser,start,end)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
start | 必需。规定在元素开始调用的函数。
end | 必需。规定在元素结束调用的函数。

由 start 参数规定的函数必须有三个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
name | 必需。规定一个变量，包含元素的名称，这个元素触发该函数。
data | 必需。规定一个数组，包含元素属性。

由 end 参数规定的函数必须有三个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
name | 必需。规定一个变量，包含元素的名称，这个元素触发该函数。

说明

start 和 end 参数也可以是一个数组，其中包含对象引用和方法名。

例子

<?php

$parser=xml_parser_create();

function start($parser,$element_name,$element_attrs)
  {
  switch($element_name)
    {
    case "NOTE":
    echo "-- Note --<br />";
    break;
    case "TO":
    echo "To: ";
    break;
    case "FROM":
    echo "From: ";
    break;
    case "HEADING":
    echo "Heading: ";
    break;
    case "BODY":
    echo "Message: ";
    }
  }

function stop($parser,$element_name)
  {
  echo "<br />";
  }

function char($parser,$data)
  {
  echo $data;
  }

xml_set_element_handler($parser,"start","stop");
xml_set_character_data_handler($parser,"char");
$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);

?>

输出：

-- Note --
To: George
From: John
Heading: Reminder
Message: Don't forget the meeting!

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_external_entity_ref_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_external_entity_ref_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_external_entity_ref_handler() 函数规定当解析器在 XML 文档中找到外部实体时被调用的函数。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

语法

xml_set_external_entity_ref_handler(parser,handler)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
handler | 必需。规定当解析器找到外部实体时被调用的函数。

由 handler 参数规定的函数必须有六个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
name | 必需。规定包含外部实体名称的变量。
base | 必需。规定一个变量，包含解析外部实体的系统标识符（system_id ）的基础。 当前该参数通常都被设置为空字符串。
system_id | 必需。规定包含外部实体的系统标识符的变量。
public_id | 必需。规定包含外部实体的公共标识符的变量。

说明

handler 参数也可以是一个数组，其中包含对象引用和方法名。

例子

<?php

$parser=xml_parser_create();

function char($parser,$data)
  {
  echo $data;
  }

function ext_ent_handler($parser,$ent,$base,$sysID,$pubID)
  {
  echo "$ent";
  echo "$sysID";
  echo "$pubID";
  }

xml_set_character_data_handler($parser,"char");
xml_set_external_entity_ref_handler($parser, "ext_ent_handler");
$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);

?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_notation_decl_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_notation_decl_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_notation_decl_handler() 函数规定当解析器在 XML 文档中找到符号声明时被调用的函数。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

注释：“符号声明”，英文为 notation declaration，也有部分文献译为“注释声明”。

语法

xml_set_notation_decl_handler(parser,handler)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
handler | 必需。规定当解析器找到符号声明时被调用的函数。

由 handler 参数规定的函数必须有六个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
name | 必需。规定包含实体名称的变量。
base | 必需。规定一个变量，包含解析实体的系统标识符（system_id ）的基础。 当前该参数通常都被设置为空字符串。
system_id | 必需。规定包含实体的系统标识符的变量。
public_id | 必需。规定包含实体的公共标识符的变量。
notation | 必需。规定一个变量，包含标识实体数据类型的符号。

说明

handler 参数也可以是一个数组，其中包含对象引用和方法名。

例子

<?php

$parser=xml_parser_create();

function char($parser,$data)
  {
  echo $data;
  }

function not_decl_handler($parser,$not,$base,$sysID,$pubID)
  {
  echo "$not<br />";
  echo "$sysID<br />";
  echo "$pubID<BR />";
  }

xml_set_character_data_handler($parser,"char");
xml_set_notation_decl_handler($parser, "not_decl_handler");
$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);

?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_object() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_object() 函数

PHP XML Parser 函数

定义和用法

xml_set_object() 函数允许在对象中使用 XML 解析器。

语法

xml_set_object(parser,object)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
object | 必需。规定设置解析器的对象。

说明

该函数使得 parser 指定的解析器可以被用在 object 对象中。所有的回叫函数（callback function）都可以由 xml_set_element_handler() 等函数来设置，它们被假定为 object 对象的方法。

例子

<?php
class XMLParser
{
var $xmlparser;

function XMLParser()
  {
  $this->xmlparser = xml_parser_create();
  xml_set_object($this->xmlparser, $this);
  xml_set_character_data_handler($this->xmlparser,"char");
  xml_set_element_handler($this->xmlparser, "start_tag","end_tag");
  }

function parse($data)
  {
  xml_parse($this->xmlparser, $data);
  }

function parse_File($xmlfile)
  {
  $fp = fopen($xmlfile, 'r');
  while ($xmldata = fread($fp, 4096))
    {
    if
    (!xml_parse($this->xmlparser, $xmldata))
      {
      //If error
      die( print "ERROR: "
      . xml_error_string(xml_get_error_code($this->xmlparser))
      . "<br />Line: "
      . xml_get_current_line_number($this->xmlparser)
      . "<br />Column: "
      . xml_get_current_column_number($this->xmlparser)
      . "<br />");
      }
    }
  }

function start_tag($xmlparser, $tag, $attributes)
  {
  print $tag . "<br />";
  }

function end_tag(){}

function char($xmlparser,$data)
  {
  echo $data . "<br />";
  }

function close_Parser()
  {
  xml_parser_free($this->xmlparser);
  }
}

$myxmlparser = new XMLParser();
$myxmlparser->parse_File("test.xml");
$myxmlparser->close_parser();

?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_processing_instruction_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_processing_instruction_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_processing_instruction_handler() 函数规定当解析器在 XML 文档中找到处理指令时所调用的函数。

处理指令包含在 <? 和 ?> 分隔符中。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

例子：在本例中，处理指令把一个样式表与 XML 文档关联起来：

<?xml version="1.0" encoding="ISO-8859-1"?>
<?xml-stylesheet href="default.xsl" type="text/xml"?>
<note>
<to>Tove</to>
<from>Jani</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>

语法

xml_set_processing_instruction_handler(parser,handler)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
handler | 必需。规定一个函数。

由 handler 参数规定的函数必须有三个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
target | 必需。规定包含处理指令目标的变量。
data | 必需。规定包含处理指令数据的变量。

说明

handler 参数也可以是一个数组，其中包含对象引用和方法名。

例子

<?php

$parser=xml_parser_create();

function char($parser,$data)
  {
  echo $data;
  }

function pi_handler($parser, $target, $data)
  {
  echo "Target: $target<br />";
  echo "Data: $data<br />";
  }

xml_set_character_data_handler($parser,"char");
xml_set_processing_instruction_handler($parser, "pi_handler");
$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);

?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_unparsed_entity_decl_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_unparsed_entity_decl_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_unparsed_entity_decl_handler() 函数规定在遇到无法解析的实体名称（NDATA）声明时被调用的函数。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

语法

xml_set_unparsed_entity_decl_handler(parser,handler)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
handler | 必需。规定一个函数。

由 handler 参数规定的函数必须有六个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
name | 必需。规定包含实体名称的变量。
base | 必需。规定一个变量，包含解析实体的系统标识符（system_id ）的基础。 当前该参数通常都被设置为空字符串。
system_id | 必需。规定包含实体的系统标识符的变量。
public_id | 必需。规定包含实体的公共标识符的变量。
notation | 必需。规定一个变量，包含标识实体数据类型的符号。

说明

handler 参数也可以是一个数组，其中包含对象引用和方法名。

例子

<?php

$parser=xml_parser_create();

function char($parser,$data)
  {
  echo $data;
  }

function unparsed_ent_handler($parser,$entname,
$base,$sysID,$pubID,$notname)
  {
  print "$entname";
  print "$sysID";
  print "$pubID";
  print "$notname";
  }

xml_set_character_data_handler($parser,"char");
xml_set_unparsed_entity_decl_handler($parser,
"unparsed_ent_handler");

$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);

?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xpath() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xpath() 函数

PHP SimpleXML 函数

定义和用法

xpath() 函数运行对 XML 文档的 XPath 查询。

如果成功，则返回包含 SimpleXMLElement 对象的一个数组。如果失败，则返回 false。

语法

class SimpleXMLElement
{
string xpath(path)
}
参数 | 描述
path | 必需。XPath 路径。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
$xml = simplexml_load_file("test.xml");

$result = $xml->xpath("from");

print_r($result);
?>

输出：

Array
(
[0] => SimpleXMLElement Object
  (
  [0] => John
  )
)

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP zip_close() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_close() 函数

PHP Zip File 函数

定义和用法

zip_close() 函数关闭由 zip_open() 函数打开的 zip 档案文件。

语法

zip_close(zip)
参数 | 描述
zip | 必需。规定要关闭的 zip 资源（由 zip_open() 打开的 zip 文件）。

例子

<?php
$zip = zip_open("test.zip");

zip_read($zip);

// 一些代码...

zip_close($zip);
?>

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_close() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_close() 函数

PHP Zip File 函数

定义和用法

zip_entry_close() 函数关闭由 zip_entry_open() 函数打开的 zip 档案文件。

语法

zip_entry_close(zip_entry)
参数 | 描述
zip_entry | 必需。规定要关闭的 zip 项目资源（由 zip_read() 打开的 zip 项目）。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "<p>";
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";

    if (zip_entry_open($zip, $zip_entry))
      {
      // 一些代码...
      zip_entry_close($zip_entry);
      }
    echo "</p>";
  }
zip_close($zip);
}
?>

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_compressedsize() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_compressedsize() 函数

PHP Zip File 函数

定义和用法

zip_entry_compressedsize() 函数返回 zip 档案项目的压缩文件尺寸。

语法

zip_entry_compressedsize(zip_entry)
参数 | 描述
zip_entry | 必需。规定要读取的 zip 项目资源（由 zip_read() 打开的 zip 项目）。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "<p>";
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";
    echo "Compressed Size: "
    . zip_entry_compressedsize($zip_entry);
    echo "</p>";
    }
  zip_close($zip);
  }
?>

输出：

Name: ziptest.txt
Compressed Size: 68

Name: htmlziptest.html
Compressed Size: 159

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_compressionmethod() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_compressionmethod() 函数

PHP Zip File 函数

定义和用法

zip_entry_compressionmethod() 函数返回 zip 档案项目的压缩方法。

语法

zip_entry_compressionmethod(zip_entry)
参数 | 描述
zip_entry | 必需。规定要读取的 zip 项目资源（由 zip_read() 打开的 zip 项目）。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "<p>";
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";
    echo "Compression Method: "
    . zip_entry_compressionmethod($zip_entry);
    echo "</p>";
    }
  zip_close($zip);
  }
?>

输出：

Name: ziptest.txt
Compression Method: deflated

Name: htmlziptest.html
Compression Method: deflated

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_filesize() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_filesize() 函数

PHP Zip File 函数

定义和用法

zip_entry_filesize() 函数返回 zip 档案项目的原始大小（在压缩之前）。

语法

zip_entry_filesize(zip_entry)
参数 | 描述
zip_entry | 必需。规定要读取的 zip 项目资源（由 zip_read() 打开的 zip 项目）。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "<p>";
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";
    echo "Original size: " . zip_entry_filesize($zip_entry);
    echo "</p>";
    }
  zip_close($zip);
  }
?>

输出：

Name: ziptest.txt
Original size: 68

Name: htmlziptest.html
Original size: 159

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_name() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_name() 函数

PHP Zip File 函数

定义和用法

zip_entry_name() 函数返回 zip 档案项目的名称。

语法

zip_entry_name(zip_entry)
参数 | 描述
zip_entry | 必需。规定要读取的 zip 项目资源（由 zip_read() 打开的 zip 项目）。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";
    }
  zip_close($zip);
  }
?>

输出类似：

Name: ziptest.txt
Name: htmlziptest.html

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_open() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_open() 函数

PHP Zip File 函数

定义和用法

zip_entry_open() 函数打开一个 ZIP 档案项目以供读取。

语法

zip_entry_open(zip,zip_entry,mode)
参数 | 描述
zip | 必需。规定要读取的 zip 资源（由 zip_open() 打开的 zip 文件）。
zip_entry | 必需。规定要打开的 zip 项目资源（由 zip_read() 打开的 zip 项目）。
mode | 可选。规定 zip 档案项目的访问类型。

说明

在 PHP 5 中，mode 会被忽略，且总为 "rb"。这是因为在 PHP 中的 zip 支持是只读的。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "<p>";
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";

    if (zip_entry_open($zip, $zip_entry))
      {
      // some code
      }
    echo "</p>";
  }

zip_close($zip);

}
?>

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_read() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_read() 函数

PHP Zip File 函数

定义和用法

zip_entry_read() 函数从打开的 zip 档案项目中获取内容。

如果成功，则返回项目的内容。如果失败，则返回 false。

语法

zip_entry_read(zip_entry,length)
参数 | 描述
zip_entry | 必需。规定要读取的 zip 项目资源（由 zip_read() 打开的 zip 项目）。
length | 可选。规定返回的字节数。默认是 1024。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "<p>";
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";

    if (zip_entry_open($zip, $zip_entry))
      {
      echo "File Contents:<br/>";
      $contents = zip_entry_read($zip_entry);
      echo "$contents<br />";
      zip_entry_close($zip_entry);
      }
    echo "</p>";
  }

zip_close($zip);

}
?>

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP Zip File 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Zip File 函数

  • Previous Page
  • Next Page

PHP Zip File 简介

压缩文件函数允许我们读取压缩文件。

安装

如需在服务器上运行 Zip File 函数，必须安装这些库：

  • Guido Draheim 的 ZZIPlib 库：下载 ZZIPlib 库
  • Zip PELC 扩展：下载 Zip PELC 扩展

在 Linux 系统上安装

PHP 5+：Zip 函数和 Zip 库默认不会启用，必须从上面的链接下载。请使用 --with-zip=DIR 配置选项来包含 Zip 支持。

在 Windows 系统上安装

PHP 5+：Zip 函数默认不会启用，必须从上面的链接下载 php_zip.dll 和 ZZIPlib 库。必须在php.ini 之内启用 php_zip.dll。

如需启用任何 PHP 扩展，PHP extension_dir 设置（在 php.ini 文件中）应该设置为该 PHP 扩展所在的目录。举例 extension_dir 的值可能是 c:\php\ext。

PHP Zip File 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
zip_close() | 关闭 ZIP 文件。 | 4
zip_entry_close() | 关闭 ZIP 文件中的一个项目。 | 4
zip_entry_compressedsize() | 返回 ZIP 文件中的一个项目的被压缩尺寸。 | 4
zip_entry_compressionmethod() | 返回 ZIP 文件中的一个项目的压缩方法。 | 4
zip_entry_filesize() | 返回 ZIP 文件中的一个项目的实际文件尺寸。 | 4
zip_entry_name() | 返回 ZIP 文件中的一个项目的名称。 | 4
zip_entry_open() | 打开 ZIP 文件中的一个项目以供读取。 | 4
zip_entry_read() | 读取 ZIP 文件中的一个打开的项目。 | 4
zip_open() | 打开 ZIP 文件。 | 4
zip_read() | 读取 ZIP 文件中的下一个项目。 | 4

PHP Zip File 常量

无。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP zip_open() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_open() 函数

PHP Zip File 函数

定义和用法

zip_open() 函数打开 ZIP 文件以供读取。

如果成功，则返回 zip 文件档案资源。如果失败，则返回 false。

语法

zip_open(filename)
参数 | 描述
filename | 必需。规定要打开的 zip 文件的文件名和路径。

提示和注释

提示：新打开的 zip 文件资源之后可被 zip_read() 和 zip_close() 函数使用。

例子

<?php
$zip = zip_open("test.zip");

zip_read($zip);

// 一些代码...

zip_close($zip);
?>

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_read() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_read() 函数

PHP Zip File 函数

定义和用法

zip_read() 函数读取打开的 zip 档案中的下一个文件。

如果成功，则返回包含 zip 档案中一个文件的资源。如果没有更多的项目可供读取，则返回 false。

语法

zip_read(zip)
参数 | 描述
zip | 必需。规定要读取的 zip 资源（由 zip_open() 打开的 zip 文件）。

提示和注释

提示：由 zip_read() 函数返回的资源可供 zip_entry... 类的函数使用。

例子

<?php
$zip = zip_open("test.zip");

zip_read($zip);

// 一些代码...

zip_close($zip);
?>

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP 杂项函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 杂项函数

  • Previous Page
  • Next Page

PHP 杂项函数简介

我们把不属于其他类别的函数归纳到这个页面。

安装

杂项函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

Runtime 配置

杂项函数函数的行为受到 php.ini 中设置的影响。

杂项函数配置选项：

名称 | 默认 | 描述 | 可更改
ignore_user_abort | "0" | FALSE 指示只要脚本在客户机终止连接后尝试进行输出，脚本将被终止。 | PHP_INI_ALL
highlight.string | "#DD0000" | 供突出显示符合 PHP 语法的字符串而使用的颜色。 | PHP_INI_ALL
highlight.comment | "#FF8000" | 供突出显示 PHP 注释而使用的颜色。 | PHP_INI_ALL
highlight.keyword | "#007700" | 供突出显示 PHP 关键词而使用的颜色（比如圆括号和分号）。 | PHP_INI_ALL
highlight.bg | "#FFFFFF" | 背景颜色。 | PHP_INI_ALL
highlight.default | "#0000BB" | PHP 语法的默认颜色。 | PHP_INI_ALL
highlight.html | "#000000" | HTML 代码的颜色。 | PHP_INI_ALL
browscap | NULL | 浏览器性能文件的名称和位置（例如：browscap.ini）。 | PHP_INI_SYSTEM

PHP 杂项函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
connection_aborted() | 检查是否断开客户机。 | 3
connection_status() | 返回当前的连接状态。 | 3
connection_timeout() | 在 PHP 4.0.5 中不赞成使用。 | 3
constant() | 返回一个常量的值。 | 4
define() | 定义一个常量。 | 3
defined() | 检查某常量是否存在。 | 3
die() | 输出一条消息，并退出当前脚本。 | 3
eval() | 把字符串按照 PHP 代码来计算。 | 3
exit() | 输出一条消息，并退出当前脚本。 | 3
get_browser() | 返回用户浏览器的性能。 | 3
highlight_file() | 对文件进行语法高亮显示。 | 4
highlight_string() | 对字符串进行语法高亮显示。 | 4
ignore_user_abort() | 设置与客户机断开是否会终止脚本的执行。 | 3
pack() | 把数据装入一个二进制字符串。 | 3
php_check_syntax() | 在 PHP 5.0.5 中不赞成使用。 | 5
php_strip_whitespace() | 返回已删除 PHP 注释以及空白字符的源代码文件。 | 5
show_source() | highlight_file() 的别名。 | 4
sleep() | 延迟代码执行若干秒。 | 3
time_nanosleep() | 延迟代码执行若干秒和纳秒。 | 5
time_sleep_until() | 延迟代码执行指定的时间。 | 5
uniqid() | 生成唯一的 ID。 | 3
unpack() | 从二进制字符串对数据进行解包。 | 3
usleep() | 延迟代码执行若干微秒。 | 3

PHP Date / Time 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
CONNECTION_ABORTED |  |
CONNECTION_NORMAL |  |
CONNECTION_TIMEOUT |  |
__COMPILER_HALT_OFFSET__ |  | 5
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验