Flash 技巧汇粹

□ 资料来源：5D精英网

本书由“ E书时空 ”免费制作；
想要更多的免费电子图书，请光临
http://www.eshunet.com/


如何制作幻影效果(1)

    特效说明:“新潮电子”四个字会分别变大并逐渐淡化，此起彼伏，连绵不断。

1.设置FLASH动画的大小，在这个动画中我选择了350X60，并把背景选择为淡黄色;

8Dy1-1 copy.JPG (17501 bytes)

2.把“新潮电子”四个字分别做四个Symbol（注意:只有smybol才能做色彩的变化）;

8Dy1-2 copy.JPG (8337 bytes)

3.选择字体输入工具;

8Dy1-3 copy.JPG (6843 bytes)

4.选择字体，大小后，输入字;

8Dy1-4 copy.JPG (3567 bytes)

5.建立好symbol后，我们现在开始做动画效果了！你现在将liberiry中的“新”的symbol拖到scence场景中，你会看到第一帧出现一个实心的黑点，这表示场景中有了可以编辑的物件了;

8Dy1-5 copy.JPG (7428 bytes)

6.现在场景中出现一个带虚框的“新”字;

8Dy1-6 copy.JPG (5743 bytes)

7.刚才我们把动画的第一帧作好了，动画还需要另一个结束帧，（中间过渡帧由FLASH软件自己来完成）;好了，我们定在20帧为结束帧;现在我们在第20帧设置一个keyframe关键帧;

8Dy1-7 copy.JPG (8188 bytes)

目　录
下一篇

□ 资料来源：5D精英网

本书由“E书时空”免费制作；


如何制作幻影效果(2)

8.关键帧的选取方法:从菜单Insert中找到，也可以从右键菜单中找到;

8Dy1-8 copy.JPG (8564 bytes)

9.下面我们来设置动画的模式，（即由计算机来决定做如何效果）首先我们要决定哪些帧需要做变化，我们把第一帧到结束帧之间的frames选中;

8Dy1-9 copy.JPG (9584 bytes)

10.再选择motion，方法:菜单Modify--->Frames--->Tweening;

8Dy1-10 copy.JPG (15833 bytes)

11.动画完成了，但这时如果你移动timeline，不会感到什么变化，这是因为第一帧和结束帧的物体完全一样，下面我们来改变一下，作出幻影的效果。
选择第一帧中的“新”字，选择该物件的属性，我们可以看到color Effect属性，我们选择Alpha，这个效果最为神奇！我们将数设为0，我们将看到一个完全透明的“新”字;

8Dy1-11 copy.JPG (8175 bytes)

12.下面我们开始做大小变化，选择变形工具，如下图中已经点中的工具，这时我们的物件会出现带方格的虚框;

8Dy1-12 copy.JPG (6586 bytes)

13.用鼠标拖动虚框，直到我们想要的大小;

8Dy1-13 copy.JPG (10231 bytes)

14.同样的方法，我们分别建立各自的层来建立其它3个字，并错开时间

15.我们可以看到动画效果如下:

8Dy1-15 copy.JPG (8844 bytes)

16.输出动画:export Movie...
由于现在网上还是比较流行flash3，所以我输出了FLASH3的格式。
告诉你一个小窍门，用FLASH做gif动画，效果也很不错！只要将输出的格式改为*.gif就可以了！

上一篇
目　录


层次菜单的制作

    我们对Windows风格的菜单可以说是极其熟悉了，它良好的交互性以及科学的空间利用率使得操作系统的人机界面非常清晰合理。在我们处理WWW这个操作平台时，能否也创建这么一个使用界面呢？答案当然时肯定的！在网络时代，只有你想不到的，没有你作不到的！

    动态菜单的制作关键是熟悉按钮的使用以及MovieClip的嵌套关系等等。下面我们进行教程的制作。

按钮的制作：

    FLASH中，按钮可以说是事件触发的最佳工具，我们的菜单当然也需要它。创建任意两个按钮，但是要注意按钮的形状最好可以在组合时重叠上。这样我们就可以省下一些额外的时间。关于这点，我们今后的教程会详细解释。本例中的两个按钮如下所示：

    注意：不要在按钮上安放任何文字。按钮是要重复利用的。

层次菜单的布局设置

    下面我们来生成层次菜单的框架结构。（注意：本教程为了计量减小图片尺寸，教程中只使用了两桢。在实际应用中，这样作可扩展方面表示很灵活。请读者注意！）

    新建一MovieClip并且命名为track。在track中，建立5层，分别命名如图所示：

    现在，以mainbutton层为活动层，放置一个按钮main并且在text层上的相应位置设置说明这个主菜单的文字。本例中，操作结果如下：

    现在以subbutton为活动层，在第二桢增加一个关键桢。以子菜单数为n（注意：此处n仅仅是一个数字，本教程中n为4），在第二关键桢中放置n个sub按钮。为了节省时间，不要将这四个按钮的边际间留有空隙。最后一不工作就是在text层上进行相应的菜单文字注解。本例结果如下：


层次菜单控制部分的制作

    首先我们进行整体控制的制作。在control层的第一桢设置动作为：Stop()，并且生成一个新的关键桢2设置LABEL为showsub。

    现在以mainbutton为活动层。我们知道主菜单的作用就是当鼠标经过或点击后显示它所包含的子菜单。因此，对于它的动作我们要达到在鼠标点击它时影片前进到显示子菜单的那一桢。因此我们设置main按钮的动作如下：

On (Release)
Go to and Stop ("showsub")
End On

    其中， 标记为“showsub”的桢就是对应于整个菜单显示的桢。

    以subbutton层为活动层。我们试想当鼠标点击了子菜单中的某一个后，会发生什么呢？当然是整个子菜单要全部隐藏起来，也就是说回复到不显示子菜单的第一桢了。设置每个子菜单行为如下：

On (Release)
Go to and Stop (1)
End On

改进工作

    到这里我们以可以进行测试了！看看你的菜单有什么问题？当你的鼠标离开菜单区域会发生什么问题呢？菜单无法消隐!

    针对子菜单的消隐问题，一般的最简单解决方法是使用一个按钮来得到鼠标离开菜单区域这一事件，并进行消隐操作。这里我们使用了一个矩形按钮并且放置在invibutton层上。对这个invibutton进行缩放使它稍微大于整个菜单区域。对invibutton这个按钮赋予相应的行为：

On (Roll Over)
Go to and Stop (1)
End On

    另外一个问题，即菜单回馈问题我们这里使用一种比较简单的解决方案：变量设置。在每个子菜单对应的按钮中设置相应的行为为：

Set Variable: "/:out" = "你选择了第n个教程！祝贺你，这是一个明智的选择！"

    其中变量out为主时线上的一个变量名称，这里我们使用了EditableTextFeild来进行输出（使用方法以及设置方法略）。这样我们就可以从菜单得到相应的反馈了！

    到这里我们的教程基本结束了，下面的工作就是将track的一个实例放置到相应的场景中并根据相应的反馈来进行不同的跳转、处理等等了。

    现在让我们来测试一下我们的成果吧！


文字的辉光模拟

    很多朋友在掌握了Flash的基本技巧和应用以后，就希望做一些更深的拓展，比如引入３Ｄ，光照等一些看起来非常绚的东东！我们这里所要讲的是用Flash4模拟文字的辉光效果，在Flash动画中如果能加入一些光的效果一定可使你的影片增色不少。

    在开始以前我想先提一点，这篇文章属于一个特效的制作方法，文中提到的一些基本Flash技能不会单独解释，默认读者已经掌握了Flash的基本用法！ＯＫ，先来看下面的例子：

    这是引自国外作品中的段落。你可能感觉做起来比较难，其实并不难，我们在来看下面的一个例子，这个是辉光的最精简方法，效果虽然不好，但是你可以看出她是如何实现的：

    现在你明白了吧！　:)　其实就是一个普通的过度，实现方法是这样的，首先新建一个文件，然后设置背景色为黑色，然后敲入欲显示的文字，然后建立一个新层，使用矩形绘画工具画出一个框，大小根据字体大小自己掌握，然后对其进行过度填充，一边为透明，一边为淡黄色。初步的光就做好了，现在将他的形状调整为上面那样的梯形，调整好以后建立一个新的符号，将其剪切进去。这样做的目的是所有的文字都使用同一束光，避免重复工作。

    现在我们来做光的变化效果，注意每一个字的光都是独立的一层，打开Library窗口，拖动辉光至第一个字的位置，调整大小和位置，然后点右键属性，设置Alpha透明度为０，然后在第５桢的位置插入关键桢，设置Alpha的透明度为１００，然后在第１５桢插入关键桢，并将光束距离缩短变小，然后在２０桢插入关键桢设置Alpha透明度为０，让他们以Motion形式过度，ＯＫ！一个光的效果就做好了。其他字的方法一样。

    你可能注意到了，当光扫到最中间的文字时，显示的不同，其实这个效果实现起来最简单，在这个字上画一个圆，将其填充为透明，删除外边线，调整大小至小于文字大小。然后向后几桢（到底几桢？根据情况自己感觉拉 ：）插入关键桢，调整大小为比文字稍大一些，进行过度填充，中间为淡黄色，四周为透明以表现光晕效果。然后在向后几桢插入关键桢，并调整大小为文字的２～３倍，接着向后几桢插入关键桢并设置这个圆形为透明，调整他们过度就可以了！

    好了，基本的辉光模拟你已经做出来了，可以看出，这个效果所用到的都是Flash最基本的技巧，但是效果却非常好，从第二个例子中你学会了制作方法，而如果要做出象第一个例子中的感觉，就要靠你自己慢慢来画拉，在这里我给你一个提示，看这副图片： 仔细观察，你不难发现，其实就是几束不同大小，不同透明度的光线的组合，从而表现出强烈的光照感觉。也就是说，要做的效果更好，你就必须根据文字结构的不同来画出不同层次的光线来实现这个效果。看到这里你明白了吗？赶紧打开Flash试一下吧！


《速度》---用Flash模拟物体快速运动

    这次我们要讲的是在Flash影片中如何模拟物体快速运动，首先我们因该清楚物体静止与移动之间的区别，在快速移动的过程中，你并不能看清物体的具体形状，因为它运动的很快，就好象快速抛出一个球，感觉好象只是一团影子，因为它太快了。

    先来看下面的例子：

    这个例子中是模拟一个金属秋体在做快速运动，在运动过程中我们只能看到一个模糊的影子，而当速度相对比较慢的时候才能看清他的具体形状。

    其中快速移动的模糊影子是在非常少的３侦里做了比较远距离的移动以突出速度感，影片中播放３侦的时间是非常少的，而它运动的距离相对较远，自然就感觉速度很快了 :)

    好了！我们开始制作，这个影片中有两个物件，一个是金属球，另一个是模糊的影子，都是独立的Symbol。首先运行Flash，新文件，然后要建立两个Symbol Graphic，一个为影子，使用矩形工具画一长方形，然后删除边线，选择油漆桶工具。打开Windows菜单下的Color属性面板，选择渐变填充的线形(Linear)模式，然后拖动一个色标至中间稍右的位置选择黑色，将其Alpha数调为50%，然后将两边色标的颜色选为透明，这样增加模糊的感觉。当然也不一定非要是矩形，在实际应用中也可选择椭圆等形状。影子做好了，现在来制作另一个金属球的　Symbol　首先选择圆形工具画一圆，删除边线，打开Color属性面版，选择渐变填充的放射(Radial)模式。在填充金属球的时候要注意反光部位，过度，背光等部位，在这里我们只简单介绍一下，一共４个色标，由左至右将第一个色标设置为白色，移动到四分之一位置为反光部分，第二个在大约五分之三的位置，灰色，第三个四分之三，黑色，最后一个白色，然后将油漆桶在圆型的右上角进行填充，这样一个金属效果的球就基本出来了，至于精细的部分可以自己在琢磨琢磨！

    物件做好以后开始将其放入TimeLine中，先来看看这副图片：

    可以看到，这个影片一共三层，其中两个层是影子，用了３桢来进行移动，而中间的则为金属球运动相对较慢时的桢，使用Motion进行过度！

    至此你对这个效果的做法已经基本掌握了，可以看出这个效果中并不包含非常复杂的技法而是通过一些常用的技巧来实现。其实在很多情况下好看的效果并不难做，关键在于对事物的理解，要多考虑考虑！


在FLASH中引入3D

    这次我们来讨论制作有3D效果的Flash动画，朋友们可能在其他一些网站上见过包含3D效果的FLASH，这是如何实现的呢？能不能用Flash自带的绘画功能画出来呢？答案是肯定的，但是未免有些牵强，我们不得不承认，在新版的Flash4.0中还不具备对3D的支持，虽然你也可以用足够的时间和很好的耐心来绘出在Flash中绘出一个"3D"物件，但和专业的3D建模软件比起来效果可能很糟糕。

    鉴于此，要在Flash中实现3D效果，我们需要借助于第三方的3D软件来建立我们需要的模型，然后导出通用的标准向量格式*.AI序列，再由Flash进行引入从而实现目的！这里我们所用到的软件是Adobe公司的 Dimensions 3.0 。她是一个面向桌面应用，操作简便，功能相对强大的3D建模软件，在开始制作之前我们先看下面的范例：

    怎么样！效果还可以吧 :) ＯＫ！开始我们的3D之旅，在制作这个动画之前，我们必须先生成影片中所需要的三维物件，这就要用到刚才说到的　Adobe Dimensions 3.0。这个软件可在我的个人主页　http://only.soim.net/ 得到。安装运行她，可以看到她的工具拦，菜单等都和PhotoShop有一定的相似性，毕竟是一家公司出的嘛。会用PhotoShop的朋友很容易上手

    建立三维物件之前首先在左上角的下拉菜单中选择PostScript模式，然后从工具拦选择立方体工具画一个立方体。上面例子中的立方体是旋转着的，而　Dimensions3.0　就给我们提供了生成动画序列的功能。立方体做好之后选择 Operations 菜单中的 Generate Sequence 选项，然后点击出现窗口中的 OK 按钮；告诉Dimensions要生成动画序列。然后双击 Rotate 图标调出 Rotate 对话框对3D模型的旋转角度进行精确控制；在Rotate对话框中设置角度Y:为90度。Coordinates：设置为Relative，然后点　Apple，角度调整好后再次点击 Operations 菜单，选择 End Sequence 选项；这时会弹出Sequence对话框生成桢数范围。默认为24桢，数字越大越精确，相应的旋转也越慢。

    在File Type中选择标准的矢量格式　Adobe Illustrator[*.ai]，然后点击Generate，给她指定一个目录后确定，然后接着硬盘一阵响动，序列生成完成！:)

    这时候我们在打开Flash4.0，选择Insert菜单下的 New Symbol，设置Behavior为 Movie Clip后确定，建立一个影片夹子。不直接从场景中导入是为了便于管理和操作，将三维动画做成一个影片夹子作为独立对象来处理非常方便。然后选择　File菜单下的 Import，指定目录选择动画序列的第一个文件然后确定，这时候Flash会弹出一个对话框告诉你这是一个序列图形，是否导入全部的序列文件？选择　ＹＥＳ　。至此，制作这个旋转的立方体动画基本完成
然后你把他放入场景并输入相应的文字，同时复制一个调整一定的透明度做下面的影子就做成了上面例子中的动画！

    差点忘了!例子中还有两个空心的3D物件，制作方法和上面的立方体完全一样，唯一的区别就是将 PostScript 模式改为 Wireframe　！

    当然，这里说的只是非常初级的３Ｄ接触，我们还可以用 Dimensions　的　Artwork制作相对复杂的３Ｄ物件，除此之外还有功能更加强大的　3D Studio Max　，现在也可以通过插件来输出Flash可以识别的向量文件。其他的可以制作３Ｄ的软件也还有很多，我只是希望这篇文章可以起到一个抛砖引玉的作用来使更多的朋友步入三维的Flash应用中来！

    最后，祝你也做出一个优秀的３Ｄ动画！


视觉欺骗---3D矩阵

    这次我们所说的三维完全不是真正意义上的三维，不借助外部３Ｄ软件建模，也不用耐心的勾勒线条，那是怎么回事呢？只是一个视觉欺骗，借助视觉误差来使用２Ｄ模拟出三维效果

    小时候你可能玩过魔方，一个个立方体转来转去，我们这里说的就类似这个，不管我在怎么说，你可能还不太明白。ok!先来看下面的例子吧。

    能骗过你的眼睛吗？呵呵，这个例子同样是最基本的motion变化，没有其他复杂的技巧，主要的难点在于对矩形位置的控制，大小，间距和行距等，制作过程中就会用到很多小的技巧拉，以后做其他影片就不会为位置问题发愁拉　:)

    不废话拉，我们赶紧开始吧！运行Flash4(标准的废话)，选择Modify菜单下的Movie将影片背景设置为黑色，这样做好之后知觉反差大，更有立体感。然后选择Insert 建立一个新的Craphic Symbol。在View菜单下打开Grid以显示坐标网格方便定位。选择矩形工具在中心位置画一正方形，大小为坐标网格的最小单位，画的时候可以明显感觉到，网格自动将矩形吸附到与之对齐的位置。我们要求这个矩形在中心十字坐标周围网格围起的四个矩形中右下方那个。将周围的四条边线删除，然后选择油漆桶工具将矩形填充为蓝色（其他颜色也可以拉，反正随你喜欢）。原材料我们就做好了！现在开始做动画。

    再次建立一个新的 Craphic Symbol ，选择 Windows 菜单打开 Library 对话框，把刚才做的正方形拖到工作区中，一共放八个（为什么非要放八个？），把他们排成一行，排的不整齐没关系，先大概排成一行。现在我们就用Flash给我们提供的非常方便的对齐功能将他们排列整齐，先把工作区的八个矩形全部选中，然后选择 Modify 菜单下的 Align ，弹出排列对话框如下图：

    按照图中所示设置好后按ＯＫ。你能看到，那些矩形已经被整齐的排列起来了！然后我们还要调整他在工作区中的位置，虽然可以将比例放大来减少误差，但毕竟还是会出现一定的偏差。如果能用坐标数字精确控制那多好？Flash又给我们提供了方便的功能,仍将八个矩形处于选中状态，选择Windows菜单下 Inspectors　的 Object子项，弹出 Object 属性对话框，其中有四个标签，默认在Object.将 Dimensions 下，Ｘ和Ｙ的坐标数值都改为 "0" 然后 Apply 现在，排列整齐的八个正方形又按照我们的设置到了我们希望的位置。

    现在，建立一个影片夹子( Movie Clip ) ，将刚才做好的长条从 Library 中拖入工作区然后设置Ｘ和Ｙ做坐标为 "0" ，在TimeLine上选中这一侦点右键选择 Copy Frames，然后建立一个新层 (Layer)在第一侦 Past Frames，这样做的目的是使他们的位置保持一致，然后在这两个层的第15侦按 F6 插入关键侦。然后将第一层第一桢长条选中，右键选择 Scale 将其大小调整为一个正方型的宽度即 18*18，然后设置坐标位置在 x=188,y=0 ，然后选中点友键选择 Properties ,在属性对话框选择 Color Effect 标签下的 Alpha 并将透明度设置为"0"然后设置 Motion 变化。在第二层的第15桢用同样方法制作，坐标位置在 x=0,y=0 做好以后按回车测试下效果，再次建立影片夹子，新建立八个层，每一层插入一个长条(注意不是长条动画)，然后全部选中，使用Modify菜单下的Align调整他们对齐。

    到生成阵列的时候了，在第一层的第二桢插入空白关键桢，然后插入动画长条，位置与第一桢的长条位置相同，以此类推做完八层，不过注意的是每一层的动画长条之间都空出几桢来表现扭转效果！我们已经说了使用对齐，坐标来控制物件位置，相信对他们的精确位置控制对你不成问题，是吧! :) 排列好以后要留出适当的桢以保证所有的长条动画都顺利播放完成。现在你可以按下回车键看下效果了。有点感觉了吧。

    最后将她插入场景中，并在希望的地方做一些调整，比如使用Rotate旋转45'角，在做简单的修饰就成例子中那样了！有任何问题，欢迎来信讨论。


电流波动

    想必大家还记得前段时间闭幕的Infact全球Flash大赛,其中的前十名作品代表了当时全球Flash技术的最高境界，华丽的声光效果倾倒了无数Flash爱好者，其中很多的技巧着实让很多人研究了一番。虽然大作容量比较大，最大的有1.8MB，但是和其他工具生成的影片文件相比却有天壤之别，而且效果毫不逊色。也足以证实Flash的优势所在。

    其作品之一Den Ivanov的 "f.u.z.z." 中有一个场景，蓝色的电流围绕文字"FLASH"波动。效果确实够酷，够闪!笔者当时就被这个效果迷住了，后来抽空花了一定的时间终于研究出来了。看到这里，你一定感觉到了，我们今天所说的正是这个ＣＯＯＬ的电流波动效果。无论怎样，先看下面的范例吧：

    挺“闪”的吧，如果能配上兹拉兹拉的电流声，那效果更是.....没说的,由于是范例教程的原因，考虑到文件大小，所以就没有放，不过这次我会在后面给出源文件。有兴趣了可以自己找段音乐加上。

    仔细观察，多 Play Again 几遍，对文字周围那些“电流”好好研究。考虑是用什么方法实现的。你可能会说，一个简单的遮罩( Mask )。对！就是用Mask来实现的。但要模拟电流的波动，就要让它尽可能的无规则，拖一个渐隐的尾巴，而且速度要快，这样看起来才有感觉。做这个效果的技术非常简单，先输入文字，然后做出文字的线条轮廓，应用Mask至这些轮廓以实现效果。但存在以下难点：

  • 线(line)的遮罩
  • 无规则运动
  • 无规则播放

    现在我就来详细描述制作过程，在制作过程中，朋友们还会学到一些小技巧哟！　:)　好了，废话少说，我们开始吧。

    启动Flash，建立400*300大小的新文件,选择Modify菜下的Movie将背景设置为黑色。然后选择文字工具输入FLASH(其他字也可以，随你喜欢)，颜色设置为深蓝，字体选择 ArenaBlack或其他的粗体字形。然后按Ctrl+B将其打散。接着选择工具栏的 [image] Ink Bottle工具来制作轮廓。在每个文字上都点一下画出轮廓线，至于颜色无所谓，因为要做Mask，但不要选择黑色，以免分不出来。我选择的是白色。填好以后会如下图所示：

    选择箭头(Arrow)工具并按Shift键将蓝色的文字一一选中，然后Ctrl+X剪切，注意不要选到轮廓线。选择 Insert 菜单下的 New Symbol 建立新Graphic，按Ctrl+V 将文字拷贝到其中备用。我们知道，在Flash中，线( Line )是不能做 Mask 效果的，所以要先将其Fills转化。回到场景１中，选中所有文字轮廓线，选择 Modify 菜单下 Curves 子菜单的 Lines to Fills命令将轮廓线转换为Fills.

    接着我们要做轮廓线的Mask动画，为了实现无规则效果，每个文字都需要单独做。选中其中一个文字的轮廓线Ctrl+X，建立新的影片夹子后Ctrl+V，其他文字用同样方法依次做５个影片夹子。我们以文字"F"为例说明其制作过程。在文字Ｆ轮廓线所在的影片夹子中将轮廓线层锁定。然后建立一个新层，并使其处于轮廓线层之下用来做Mask的过度。选择矩形工具画一长方型，删除周围边线，然后用渐变填充工具进行填充。选择Windows菜单下的Colors打开颜色设置窗口。为渐变标签最左边的滑杆选择一个相对较亮的蓝色来表示电流，色彩参考( R:58 G:60 B:239)将最右边的滑杆拖到1/2的位置，然后对矩形填充。矩形大小和填充效果参见下图：

    为了让读者能更清楚矩形和文字的比例，在上图中用了边框线，在实际制作中你可不要用呀。因为要表示无规则，我们选中矩形，然后用旋转(Rotate)工具将其旋转一定角度，然后在第七桢插入关键桢(F6)并将矩形移动到文字右侧，然后进行Shape变化。操作方法为在矩形所在层的时间线上点右键选择Properties，选择Tweening标签，设置变化为 Shape模式，然后按确定。

    在文字轮廓线所在的层名字上点鼠标右键，选择Mask命令。第一个文字的效果就做好了。其他文字方法相同，制作的时候注意矩形的位置都要不同，例如Ｆ的矩形过度是左下到右上，那Ａ可以是右下到左上。反正你自己掌握，每个文字的Mask都让它不同就好了。我们几乎要大功告成了，在这里还有一个问题要注意，虽然边线动画做好了，也实现了无规则播放，但是一旦将其放入场景中，可能还有一些规则感。为什么呢？因为在场景中插入的影片夹子都在同一时间从第一侦开始播放，而这些文字轮廓线动画也遵循这个规则，所以电流看似从四面八方而来，但却是在同一个时间来，同一个时间去，所以对这几个文字轮廓线的影片夹子还要做一次设置，在有的影片夹子前插入空白桢，有的空两桢，有的空三桢，有的则不空，这样应用到场景中以后就更显无绪拉！:)

    现在我们做最后的工作，将最早的文字Graphic插入场景，然后建立新层，并依次插入这些轮廓线动画，对齐位置，然后用Ctrl+Enter来测试，效果出来了吧，我们最后在做一些修饰性的工作。在文字层的８，１５，２５侦分别插入关键侦，设置Alpha透明度为，第１侦50%,第８侦40%，第１５侦0%，２５侦100%然后设置轮廓动画层从第１５侦开始到２５侦过度到透明。这样就有了隐现的感觉。在最后一侦设置一个Stop，在加上一个Play Again的按扭，就做成了范例中的效果。怎么样？你明白了吗，如果还没有就赶紧打开Flash自己试着做一次。

    思考一下吧，用Mask可以做出其他很多的效果呢。例如两头渐隐的线，以前用其他方法总做的不很精确，而且线也不够“细”现在我们可以用Lines to Fills命令将很细的线条转换然后用两头渐隐的矩形填充做Mask，就可以得到我们需要的效果了。:)　希望这篇文章在使你学会这个效果制作方法的同时能够打开你的思路琢磨出更多的东西出来。


文字绕排

    我们见过许多文字绕排的效果，使用得当，会给作品增色不少，而且现在可以做这个效果的工具也非常多，例如 CorelDraw ; FreeHand 等，把这应用进 Flash 该如何做呢？通常我们都是使用外部绘画工具如 FreeHand 做好绕排效果，然后输出标准的 *.AI 格式文件，然后再导入 Flash 来实现目的。

    那如果我们没有这样的第三方工具怎么办？可以独立在 Flash 中做出这个效果吗？答案是肯定的，虽然现在 Macromedia 已经将最新的 FreeHand 9 和　Flash 4 以 Studio 形式发送，或者你现在已经可以通过诸如 Adobe Illustrator8.0 这样的外部软件来完成。但我想还是有充足的理由让我们来学习独立在 Flash 中做文字饶排效果的。除非你愿意悠闲的坐在家里等到可能结合了 Freehand 强大绘画功能的 Flash5.0 的问世。但这个时间对于网络的发展来说是太漫长了，估计没有人会这样做。

    好了，让我们开始吧，先看下面的动画范例：

    这个旋转效果非常简单，在 Motion 变化中设置 Rotate 一次，相信对你不成问题，而关键是我们要得到饶排的文字。象这样：

    当我们做出这个绕排的文字后，范例中的动画可很顺利的做出来！这也是这篇文章花大量的文字进行讲述的地方。在制作这个效果的过程中，你可以在依次学到 Guide 和 Onion 一些小技巧，你是否有些着急了？其实我和你一样！GO! Mark it !

    启动 Flash 并建立新文件，然后选择文字工具输入一个字符，例如 "M" 然后在第 15 侦的地方插入关键侦，注意，有多少侦就代表有多少字符，注意不要将字打散。例如我上面做的这个绕排一共是16个字符，那么我就在第 16 侦插入关键侦，然后设置 Motion 变化，然后在此层上点右键选择 Add Motion Guide ，Flash会自动插入 Gudie 层，然后选择圆形工具画一个圆，大小要根据文字的大小自己掌握，将圆中间的区域删除，边线作为文字移动的引导线，给字符设置起点和终点做一个文字的环行路径运动，打开文字所在层的 Tweening 对话框 (在TimeLine上点右键选Properties)将 Orient to path direction 项选中后按确定，这样文字在按环行路径运动的时候就能与圆形的切线保持垂直了。

    接着将文字层的1至16侦全部选中，插入关键侦(F6)，这样就成为一个逐侦的动画，删除 Guide层，现在用不上他了。接着就是本次内容的精彩部分，点 TimeLine 下的 [image] Edit Multiple Frames按扭，然后点旁边的 [image] Modify Onion Markers按扭，在弹出的下拉菜单中选择 Onion All ，这样每一侦的文字就全部显现出来了，如下图所示：

    在工作区将他们全部选中，Ctrl+C 拷贝，选择 Insert 下的 New Symbol 建立新的 Graphic Symbol 然后 Ctrl+V 粘贴，这时候，你就选择文字工具依次在每一个字符上点一下替换成自己想要的文字。现在明白刚才说千万别打散的原因了吧! :) 替换完成以后按 Ctrl+B打散，如果不打散也可以，或者你还可以象我那样将其中一个字符换成红色加以点缀。

    在建立一个新的影片夹子，将这个圆形绕排文字的 Graphic 拖进去，在第 100 侦的地方插入关键侦。100 侦呀！这么多？是为了让他转的比较慢嘛，设置 Motion 变化，在 Rotate中选择顺时针或逆时针旋转一周。好了，你现在可以把这个影片夹子拖进场景了，也可以适当的做个阴影，调整变形增加立体效果，很显然，范例中的动画你做出来了！

    怎么样！洋葱皮 ( Onion ) 的作用很有趣吧！一如既往，还是希望这些东西能启发你的思维，对普通技法的灵活运用，最终作出一个出色的作品，到时候别忘记请我吃饭呀！^-^


电视干扰

    你在收看电视节目的时候有没有碰到过信号被干扰的情况？一个很喜欢的节目突然中断确实非常扫兴！有没有想过用Flash也来模拟下这个效果呢？如果使用的当，将干扰信号放进你的Flash影片中也可增色不少。至于如何实现，看了范例在说吧：

    这个效果不知道你以前见到过没？最早的时候老是想不明白，Flash是基于矢量图形的工具，这么多小点点，画起来不麻烦死了，而且还不好控制！其实不是这样做的，而是通过导入外部的位图来达到目的。

    首先需要做出干扰画面，这就需要用到 PhotoShop 了，运行 PS ，建立新文件，图象大小根据需要调整，范例中的是　200*150　，然后选择 滤镜( Filter )菜单下的噪音(Noise)项，选择 增加噪音( Add Noise ) ,弹出如下对话框：

    设置 Amount 为 50 ，Distribution 为　Uniform 并勾选 Monochromatic 项，然后按确定。起名保存。然后按 Ctrl+A 全选, Del 删除，重复 Add Noise 并在次保存。现在需要的干扰图象已经得到了，关闭 PS 启动 Flash ，选择 Insert 菜单下的 New Symbol 建立一个新的影片夹子 ( Movie Clip ) ,切换到影片夹子工作区，选择 File 菜单下的 Import 将刚才做的两幅图象导入，注意每副图象都占两侦。

    然后在次建立新的 Movie Clip ，从 Windows 菜单下选择 Library 打开库窗口，将干扰动画的影片夹子拖入新建的影片夹子中，然后建立一个新层，新层处于上方。双击工具篮的矩形工具，弹出调整对话框 ( Rectangle Settings ) ，设置 Corner 为 10 Points 然后按确定，设置好之后拖一个矩形出来，你可以看到，矩形的四角已变成圆形的过度了，将位置调整好，在名称区域点右键选择 MASK ，将这个带圆形过度角的矩形做出来。将其拖入场景中。

    你可以在给他加上一条黑色的边框线，然后在做几个范例中那样的文字渐变，ＯＫ！一个电视的干扰效果就做出来了。这个效果主要就是要先用ＰＳ做两张黑白噪音图，然后导入。如果单用Flash 画一个干扰效果几乎是不可能的，在这里点阵图形的优势又得到体现拉。 :)

    以后看到什么效果的时候可不要单纯的只从 Flash 方面考虑，看看是否用到了其他外部工具！


渐进按钮

    上星期圈圈没在，就偷懒拉。这个星期眼看就要蒙混过去了，结果星期一晚上被圈圈逮住拉 :( 没办法，还没想好写什么呢，我想呀想，急呀急，终于想出写这么个东东拉！

    至于这个效果嘛......　其实我也不知道具体应该叫什么，用到按扭上就叫了个这名字，也可以用在其他地方，反正说也说不清楚，先看看范例你就知道了：

    把光标在按扭周围移动移动，看到了吧，就这个效果。这是国外一个网站提供的Flash范例文件，其中有两个按扭，按扭1比较简单，按扭2相对复杂一些，而且按扭2中也包括了1中的所有技巧。我就以按扭2为例子讲解整个制作过程。

    你可以看到，按扭2有很多圆形排列的圆点，这个东西如何画？跟我来，你会学到 Line 的灵活运用。其次，当光标在按扭周围移动的时候，带园点的环就开始闪烁，由大到小，你可以想到，能感应光标事件的就只有按扭了，这东西其实就是将环型按扭饶中心依次排列最后实现我们要做的效果。

    ＯＫ！我们开始吧，运行你的 Flash ，建立新文件。第一步，建立环形圆点。选择Insert菜单下的 New Symbol 建立一个 Graphic .为了便于定位，选择 View 菜单下的 Grid命令打开网格线。然后点工具栏的圆形工具按扭。接着在 Line Style 下拉菜单中选择Custom... ( Line Style 在那里？我怎么没发现？好拉，给你张图，应该知道位置了吧！)

    选择以后会弹出 Line Style 设置对话框,设置 Type 为 Dotted ; Dot Spacing 为2Pts 然后按确定。接着在刚才新建的 Graphic 工作区画一圆形，删除中间区域，注意中心位置对准工作区的中心坐标。在次选择 Insert 菜单下的New Symbol 建立一个 Button ，然后在其Hit位置插入关键侦，选择 Windows 菜单下的 Library 打开库窗口。将刚才做的圆点环形图形符号拖进去，与坐标中心对齐。这个按扭是用来做触发事件的，因为在按扭的 Up 位置没有放任何东西，在以后的拖放过程中不太方便，所以我们给 Up 里也放一个环形，过后再删除它。

    现在，需要建立一个影片夹子，然后在影片夹子的第一侦插入按扭，然后在Timeline中选中第一侦点右键选择属性设置Actions为Stop,在第二侦插入空白关键侦关键侦，第三侦插入关键侦，并将刚才建立的园环图形符号拖进去，点右键盘属性，设置其颜色透明度为20%，接着在第四侦插入关键侦，设置图形符号透明度为100%，然后在第十侦插入关键侦，设置图形透明度为20%，并由第四侦至第十侦Motion变化，第十一侦插入空白关键侦。从而体现圆环的闪耀。然后回到第一侦，在工作区选择刚才放进去的按扭，点又键属性，选择Actions标签，点加号选择On MouseEvent ，接着在右边的控制项勾选 Roll Over ，在次点加号选择 Go to,然后在友边的控制项 Number 处填入2,并勾选Countrol的 Go to and Play,然后按确定。正确设置以后Actions中的代码应该是：

On (Roll Over)
  Go to and Play (2)
End On

    按确定。现在回到主场景中，将刚才建立的影片夹子拖入场景中，注意中心与坐标中心对齐。对其以后在次拖入这个影片夹子，并设置大小比刚才的小一圈！如果感觉对大小控制有困难就打开Windows菜单下Inspectors子菜单的Object控制面版来由数字精确控制,排列好以后应该类似图中显示的样子：

    马上就要完成了，还记得我前面说的，为了方便定位，给按扭的Up位置也放了一个环形吗？现在用不上他了，进入按扭编辑状态，删除Up区的图形符号。然后回到场景中，给环形的中心输几个文字，例如My Button ，然后 Ctrl+Enter测试一下，是不是很有意思？

    这个效果其实就是将按扭的激发事件组合起来实现效果，不错的思路，你能想到吗？还有就是线的不同风格，Flash 给我们提供了非常丰富的线条效果，多试你种风格，不同参数，你能得到意想不到的效果。

    如果你还没有彻底明白，那么，附上源文件 tracer.fla 29.5k | Download Now


精确控制物体变形过程

    我们知道，在Flash中有两种基本的变化，Motion 和 Shape ，对于 Motion 我们可以控制任意 Object 的大小，透明度，色彩，但前提是这个 Object 必须是一个 Group ,而应用在Shape上的变化则要求 Object 为打散装态，例如输入一个文字按 Ctrl+B ，我们可以通过Shape让物件从形态1变形为形态2，就好象电影异形的变化过程，当然与Shape比起来，哪个要刺激的多！

    而经常喜欢变形的朋友一定感觉到Shape似乎不象我们想象的那样乖巧，总是出现一些奇怪甚至莫名其妙的变化过程，甚至相同的Shape两次做出来变化效果也不同，难道她就真的象你的恋爱经历那样不能随意控制吗？

    你时常抱怨与你情人的关系不能随心所欲？这我帮不了你，但对于想让Shape变的更加听话一些，我却是可以给你一个好方法。这也是 Flash 提供的功能之一，也是很多人都忽略的一个功能之一 Add Shape Hint 此命令位于 Modify 菜单下 Transform 子菜单的倒数第二项，我想在这里引用 Macromedia 在 Flash4.0 帮助里的语句 :

    Use shape hints to control more complex or improbable shape changes.
Shape hints identify points that should correspond in starting and ending shapes.

    怎么样，你有没有稍微明白一点？假如仍未清楚也没有关系，你只需在看看下面的范例就一定可以清楚怎么回事了:

    看到了吧，范例中左边图片1-2的变化过程比较怪异也不是那么友好，而增加了两个 Hint 之后她变的友善多了，也更容易与我们亲近。

    现在我想你一定与我一样清楚　她---Hint　的作用是什么了，如果仍未明白，那就无能为力了! OK！我们实际行动一次吧。启动你的 Flash ，建立新文件，然后选择文字工具(快捷键Ｔ)输入一个１，为了观察仔细方便，请尽量用粗体并用大的尺寸。输入完成以后在第20桢的地方按 F6 插入关键侦，并将文字１换成２，然后将这两个字符 Ctrl+B 打散并在 TimeLine 上点友键选属性建立 Shape 变化，现在请点一下你的回键看看效果。如你所想，变化过程是很怪异也不那么平滑美观。现在我们就要对其 Hint 控制了。

    回到第一侦，选中文字１，然后选择 Modify 菜单下 Transform 子菜单的 Add Shape Hint 或按快捷键 Ctrl+H ，我们看到，１上出现了控制点 a ，我们将其移动到１的左上角位置，然后在按 Ctrl+H 增加一个控制点 b 并移动它到１的右下角，现在切换至第20侦，在文字２上也相应的有两个控制点 a 和 b ，我们按照在１上的位置将他们分别移动到２的左上角和右下角，移动正确后你的工作区显示的应类似下图：

    调整好之后再次按下你的回车键进行测试，看到什么了？哦！比较平滑可爱，那么我们的目的也就达到了，当然这里描述的也只是一个非常简单的例子而已，你可以根据自己的需要而将她用在更加复杂的 Shape 变化上并使之随你心意！

    ＯＫ！写完拉，收工。


光波效果

    不知道各位是否经常看电影，我是非常喜欢那些大片，有时候一场电影开场字幕的时候就能感觉到这部片子是否精彩，比如一些片子开头干巴巴的打几个字，感觉就不大型，而梦工厂的很多片子光片头的字幕就效果十足，配合光影和音乐，你一定会被牢牢吸引。可以想象，从小的地方就能体现出一部作品的专业程度，同样，观赏者也一样赏心悦目！

    扯的远了，赶紧回到正题。这次给大家带来的就是这样一个非常酷的过场光波效果，其中用到了外部的位图，因为单用 FLASH 目前还实现不了。看下面的范例

    随着动听的音乐把你的片头信息播放完毕，相信在这个时候，用户已经被这部作品吸引住了。怎么样，用在过场很不错吧！

    我刚开始看到这效果感觉太神奇了，想了半天想不明白,最后才知道要用位图的，做法其实太简单了，一共三层。文字放在中间，背景图片放在第三层，然后用一个遮罩在最上面，效果就做成了。

    首先你需要准备一张背景图片，象这样的一张：

    当然，这张是经过我缩小的，类似这样的效果可以用 PhotoShop 的滤镜轻松实现，这里就不多说了。然后打开 Flash 导入图片，作为背景层琐起来，然后建立一新层，输入相应的文字，范例中的文字是　FLASH KIT 你喜欢什么随意了，然后把文字层也锁定。现在是最后的遮罩层了，在背景层与文字层之间建立一个新层，现在 Insert 一个　Graphic Symbol 并用矩形工具画一黑色长方形，删除边先，选择填充工具选择放射填充方式，将黑色的长方形填充为中间有一个透明的圆形，参照下面示范：

    在色彩参数面版将白色设置为透明，黑色划杆拖动至白色划杆附近，然后回到主场景中并将中间有圆形透明区的黑色举行放在中间层，设置一个移动变化就得到我们需要的效果了，怎么样？是不是特别的简单，其关键就在于位图的应用。因为那样的背景用 Flash 实现也确实太困难了，这样可引导我们在看到什么特殊效果的时候拓展一下思路，不要只从 Flash 上想是如何实现的，换个角度，或许就会豁然贯通了 :)


The Matrix

    同志们同志们，记得去年轰动的大片22世纪杀人网络---骇客任务吗？相信所有看过的人都会震惊于片中华丽的声光效果以及幻想中的未来 VR 世界，片中人物所使用的计算机好象处理能力极强大，大量的数据流不断从屏幕上方流入屏幕下放，那些流动的绿色字符，带表着科技，带表着希望，代表着强大......

    ONLY回忆着片中的场景已经陶醉了~~~ 这时圈圈一板凳摔过来：“赶紧写，我们的读者都等着那！！！”（ONLY捂着头蹲在地上，好疼啊...... 重新把键盘拾起来）

    OK，这次我们要说的正是这效果，模拟骇客任务中的字符 Matrix ，相信所有看到的人都会说 酷！我知道，你很着急了，我和你一样急，到底 Flash 模拟的这个效果有多棒，我们一起看看就知道了：

    怎么样？酷吧。：） 相信only，没错的。（圈圈在旁边喊：严禁做广告）其实要做这个效果很容易，其中不包括任何脚本及其他复杂控制。而仅仅用到了一个遮罩 MASK 效果，你可别告诉我你不会 MASK 。所以，即使你是昨天才接触 Flash 的用户也别失去信心，跟我走。一样让你完成这个酷的效果。而对于熟练用户更是小菜一碟。只是建议大家思考思考，在很简单的基础上实现很棒的效果，就象上面这个，我个人认为她已经不仅仅是一个效果技巧而已，更是一种思路，一种精神。

    好了，我也不在这里罗嗦了，赶紧开始吧。运行你的 Flash ，选择 Modift 菜单下的 Movie 设置背景为黑色，然后选择 Insert 菜单下的 New Symbol 建立一个新 Graphic 图形符号,我们来输入出现的那些文字，由于要做遮罩 MASK ,所以字符颜色无所谓，但你可千万别选择黑色，除非你告诉我你能分的清。字符必须竖直排列，也就是说你敲一个字母就要回车一次，别嫌麻烦，字体选择一种黑体吧，反正其他很细的字体不好看，你可以参照下面的图片：

注：由于空间关系，次图仅做参考，在实际制作中文字为竖直排列。

文字输好以后还要建一个遮罩,使文字变为绿色的渐隐效果。在次建立一个图形符号，在工具栏选择矩形工具画一个竖直长条，然后删除边线，并选择渐变色工具填充为下图所示的样子：

记得宽度一定要比字符稍大一点，不然就“罩”不住拉。

    现在就是关键的部分了，回到主场景，选择 Windows 菜单下的 Library 打开库面版，将刚才建立的文字符号拖入场景，然后建立一个新层，并使新层处于文字层之下，然后将绿色的遮罩条拖入场景位置在文字的顶端，然后在第40桢的位置插入关键侦，并移动绿色遮罩条到文字底端位置并社定 Motion 变化。现在回到文字层的层名称区域点右键，选择 Mask ，这时候最基本的变化已经完成了。按回车测试一下。

    在场景中一个文字层和遮罩层为一组，然后按相同方法在场景中密密麻麻排列起来，按回车测试效果，发现问题了？一同出现一同消失，并且速度一样。而要模拟矩阵效果则要求有些速度快有些速度慢，有些出现了有些刚开始，有些消失了有些正显示。所以。你就需要设置他们不同的起点和终点，不同的速度。这个就需要你自己具体掌握。我所能告诉你的就是范例中一共是 22 组既 44 层 第一组起点位置在12桢，终点在46侦。第二组为40至74侦。其中最快的是20侦过度。最慢的是60侦过度。而在场景中的排列位置都不同。关于这个我就只能说这么多了。

    因为实在没法把每一组的具体位置坐标和速度都告诉你，那样的话太死板也没有灵活性了，而且恐怕圈圈也会骂我凑字数了 ：）

    好了，你对照范例满满排吧，我要休息一下了~~~，如果你实在感觉困难，我把原文件给你，打开看看应该不难理解。

  matrix.fla Size :111K | Download


关 于 本 书

    本书为免费电子图书，感谢 5D精英网 提供资料来源。本书分中文简体GB和中文繁体BIG5两种版本，您可以到“E书时空”免费下载。

    在不对本书做任何修改的前提下，任何人都可以在互联网上自由下载、传播本书，也可以放在自己的站点供人下载。

    如果您有资料愿意发行免费电子图书，请与我们联络，我们在确认内容的情况下，愿意为您免费制作。

    “E书时空”会不断给大家提供各方面最新的免费电子图书，欢迎订阅“E书时空”的“新书速递”免费电子杂志。您可以到“E书时空”网站订阅，或者通过发信的方式订阅和退订：

简体中文版

订阅：

  • 发一封空信到eshu-subscribe@cn.egroups.com。
  • 系统会给您回信，需要您的确认，回复该信即可。

退订：

  • 发一封空信到eshu-unsubscribe@cn.egroups.com即可。

繁体中文版

订阅：

  • 发一封空信到eshu5-subscribe@tw.egroups.com。
  • 系统会给您回信，需要您的确认，回复该信即可。

退订：

  • 发一封空信到eshu5-unsubscribe@tw.egroups.com即可。


Flash 技巧汇粹——目录

目　录
第 一 篇　Flash 制作幻影效果(1)
第 一 篇　Flash 制作幻影效果(2)
第 二 篇　层次菜单的制作(1)
第 二 篇　层次菜单的制作(2)
第 三 篇　文字的辉光模拟
第 四 篇　速度
第 五 篇　在Flash中使用3D
第 六 篇　Flash3D矩阵
第 七 篇　电流波动
第 八 篇　文字绕排
第 九 篇　电视干扰
第 十 篇　渐进按钮
第十一篇　精确控制物体变形过程
第十二篇　光波效果
第十三篇　《The Matrix》

·关于本书