Dreamweaver 入门

本指南介绍如何使用 Macromedia Dreamweaver 8。本指南中的教程将引导您完成创建一个简单但具备一定功能的 Web 站点的过程。

本指南包含以下各章：

简介

学习 Dreamweaver

Dreamweaver 基础

教程：设置站点和项目文件

教程：创建基于表格的页面布局

教程：向页面添加内容

教程：使用 CSS 设置页面格式

教程：发布站点

教程：使用代码

教程：创建基于 CSS 的页面布局

教程：显示 XML 数据

教程：开发 Web 应用程序教程

了解 Web 应用程序

安装 Web 服务器

示例 ColdFusion 站点的设置

示例 ASP.NET 站点的设置

示例 ASP 站点的设置

示例 JSP 站点的设置

示例 PHP 站点的设置

在 LiveDocs 中查看评论


简介

Macromedia Dreamweaver 8 是一款专业的 HTML 编辑器，用于对 Web 站点、Web 页和 Web 应用程序进行设计、编码和开发。无论您是喜欢直接编写 HTML 代码的驾驭感还是偏爱在可视化编辑环境中工作，Dreamweaver 都会为您提供帮助良多的工具，丰富您的 Web 创作体验。

本指南将介绍如何使用 Macromedia Dreamweaver 8，其对象是对该软件的主要特性尚不熟悉的用户。本指南中的教程将引导您完成创建一个简单但具备一定功能的 Web 站点的过程。

本章包含以下主题：

Dreamweaver 8 的功能

Dreamweaver 8 的新增功能

安装 Dreamweaver 8

注册 Dreamweaver 8

字形约定


Dreamweaver 8 的功能

利用 Dreamweaver 中的可视化编辑功能，您可以快速创建 Web 页面而无需编写任何代码。您可以查看所有站点元素或资源并将它们从易于使用的面板直接拖到文档中。您可以在 Macromedia Fireworks 或其它图形应用程序中创建和编辑图像，然后将它们直接导入 Dreamweaver，从而优化您的开发工作流程。Dreamweaver 还提供了其它工具，可以简化向 Web 页中添加 Flash 资源的过程。

除了可帮助您生成 Web 页的拖放功能外，Dreamweaver 还提供了功能全面的编码环境，其中包括代码编辑工具（例如代码颜色、标签完成、“编码”工具栏和代码折叠）；有关层叠样式表 (CSS)、JavaScript、ColdFusion 标记语言 (CFML) 和其它语言的语言参考资料。Macromedia 的可自由导入导出 HTML 技术可导入您手工编码的 HTML 文档而不会重新设置代码的格式，您可以随后用您首选的格式设置样式来重新设置代码的格式。

Dreamweaver 还使您可以使用服务器技术（如 CFML、ASP.NET、ASP、JSP 和 PHP）生成动态的、数据库驱动的 Web 应用程序。如果您偏爱使用 XML 数据，Dreamweaver 也提供了相关工具，可帮助您轻松创建 XSLT 页、附加 XML 文件并在 Web 页中显示 XML 数据。

Dreamweaver 可以完全自定义。您可以创建您自己的对象和命令，修改快捷键，甚至编写 JavaScript 代码，用新的行为、属性检查器和站点报告来扩展 Dreamweaver 的功能。

有关可用来学习 Dreamweaver 的资源的更多信息，请参见学习 Dreamweaver。


Dreamweaver 8 的新增功能

Dreamweaver 8 包括许多新增功能，使您只需花费最少的时间和精力便可生成 Web 站点和应用程序。Dreamweaver 使复杂的技术变得简单而方便，以帮助您达到事半功倍的效果。

下面是 Dreamweaver 8 中的一些主要新增功能：

  • “缩放”工具和辅助线
  • 可视化 XML 数据绑定
  • 新的 CSS 样式面板
  • CSS 布局的可视化
  • 代码折叠
  • “编码”工具栏
  • 后台文件传输
  • “插入 Flash 视频”命令

有关 Dreamweaver 8 中新增功能的完整列表和描述，请参见《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中的 Dreamweaver 8 中的新功能。


安装 Dreamweaver 8

本节介绍如何安装 Dreamweaver。

请务必阅读 Macromedia 网站 (www.macromedia.com/go/dw_documentation_cn) 中的发行说明，以了解最新信息或指导。

若要安装 Dreamweaver，请执行以下操作：

  1. 将 Dreamweaver CD 插入计算机的 CD-ROM 驱动器。
  2. 执行下列操作之一：
    • 在 Windows 中，Dreamweaver 安装程序将自动启动。
    • 在 Macintosh 中，请双击桌面上出现的 Dreamweaver 安装程序图标。
  3. 按照屏幕上的指导执行。

    安装程序将提示您输入所需信息。

  4. 如果出现相应提示，请重新启动计算机。


注册 Dreamweaver 8

若要获得更多的 Macromedia 支持，最好以电子方式或通过邮件注册您的 Macromedia Dreamweaver8 的副本。

在注册后，您可以登录以接收与 Macromedia 升级产品和新产品有关的最新通知。您还可以登录，以获得与 www.macromedia.com 和 www-euro.macromedia.com Web 站点上提供的产品更新和新内容有关的即时电子邮件通知。

若要注册 Macromedia Dreamweaver 8，请执行以下操作之一：

  • 选择“帮助”>“联机注册”并填写电子表格。
  • 选择“帮助”>“书面注册”，打印该表格，并将表格邮寄到表格中所示的地址。


字形约定

本指南中采用以下字形约定：

  • 菜单项按如下格式显示：“菜单名称”>“菜单项名称”。子菜单中的项按如下格式显示：“菜单名称”>“子菜单名称”>“菜单项名称”。
  • Code 字体指示 HTML 标签和属性名称以及在示例中使用的文字。
  • Italic code 字体 指示代码中可替换的项（有时称作元符号）。
  • Bold roman 文本指示您需要逐字输入的文本。


学习 Dreamweaver

Macromedia Dreamweaver 8 包括了多种资源，将帮助您快速了解该程序并熟练创建您自己的 Web 页面。所有 Dreamweaver 文档均以电子帮助和 PDF 两种格式提供。

本章包含以下主题：

从哪里开始

高效使用 Dreamweaver 文档

使用 Dreamweaver 帮助系统


从哪里开始

Dreamweaver 文档包含为各种不同背景的读者提供的信息。本节帮助您了解如何根据您的背景来学习该文档，以及使用 Dreamweaver 可以实现的功能。

本节包含以下主题：

  • Web 设计初学者
  • 有经验的 Web 设计人员
  • 有经验的手工代码编写者
  • Web 应用程序开发人员


Web 设计初学者

如果您对 Web 设计比较生疏，本节将为您指出 Dreamweaver 文档中最适合您的背景的章节。

对于 Web 设计初学者：

  1. 首先阅读 Dreamweaver 基础。然后继续阅读本书中的教程。这些教程分为两部分。前五个教程面向初学者，指导您完成开发一个小型但具有一定功能的 Web 站点的过程。教程的第二部分介绍了更高级的概念。最好在您已具备一些建立 Web 页面的经验后，您再学习更高级的教程。
  2. 在《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中，您将通过阅读了解工作区、设置 Dreamweaver 站点、管理您的文件和创建和打开文档对在《Dreamweaver 入门》中所学的内容有更全面的了解。
  3. 阅读《使用 Dreamweaver》中的使用 CSS 对页进行布局和使用表格显示内容了解有关页面布局的更多信息。
  4. 若要了解如何设置文本格式和在页面中包含图像，请阅读《使用 Dreamweaver》中的插入文本和设置文本格式和插入图像。
  5. 如果您希望创作高质量的 Web 站点，则只需了解上述内容，但如果您准备了解如何使用更为高级的工具，则可以按顺序阅读《使用 Dreamweaver》中静态页章节的其余部分。最好在较为了解如何创建 Web 页后，才开始阅读动态页章节。


有经验的 Web 设计人员

如果您是个有经验的 Web 设计者，本节将为您指出 Dreamweaver 文档中最适合您的背景的章节。有两种不同的方法：一种针对不熟悉 Dreamweaver 的设计者，另一种针对熟悉 Dreamweaver 但是想了解有关创建动态页的更多内容的设计者。

对于有经验但不熟悉 Dreamweaver 的 Web 设计人员：

  1. 首先阅读本《Dreamweaver 入门》指南中的教程。
  2. 在《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中，请阅读了解工作区，以了解有关 Dreamweaver 用户界面的更多信息。
  3. 虽然您可能已熟悉设置 Dreamweaver 站点和管理您的文件中的许多内容，但还请大致浏览这些章节，以了解这些熟悉的概念在 Dreamweaver 中是如何实现的。尤其请注意有关设置 Dreamweaver 站点的章节。
  4. 有关使用 Dreamweaver 创建基本的 HTML 页的详尽信息，请阅读插入文本和设置文本格式和插入图像。
  5. 有关在 Dreamweaver 中进行编码的信息，请参见设置您的编码环境、在 Dreamweaver 中编写代码、优化和调试代码和在设计视图中编辑代码。
  6. 请阅读《使用 Dreamweaver》中其它各章开头的概述，确定您是否对其中的主题感兴趣。

对于有经验、熟悉 Dreamweaver 但要详细了解如何创建动态页的 Web 设计者：

  1. 首先阅读了解 Web 应用程序和教程：开发 Web 应用程序教程。首先阅读了解 Web 应用程序和教程：开发 Web 应用程序教程。
  2. 在《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中，大致浏览了解工作区以了解 Dreamweaver 用户界面的新内容，然后阅读为可视化开发优化工作区。
  3. 通过阅读动态页设计工作流程来熟悉使用 Dreamweaver 制作动态页的工作流程。
  4. 设置 Web 服务器和应用程序服务器。（请参见设置 Web 应用程序。）
  5. 连接到数据库。（请参见设置 Web 应用程序中的连接到数据库。）
  6. 请阅读《使用 Dreamweaver》中各章开头的概述，确定您是否对其中的主题感兴趣。


有经验的手工代码编写者

如果您是个有经验的手工编码人员，本节将向您指出 Dreamweaver 文档中最适合您的背景的章节。

对于有经验的手工代码编写者：

  1. 首先阅读《Dreamweaver 入门》指南中的教程：使用代码。
  2. 在《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中，请阅读了解工作区，了解有关 Dreamweaver 用户界面的更多信息。
  3. 虽然您可能已熟悉设置 Dreamweaver 站点和管理您的文件中的许多内容，但还请大致浏览这些章节，以了解这些熟悉的概念在 Dreamweaver 中是如何实现的。尤其请注意有关设置 Dreamweaver 站点的章节。
  4. 请在设置您的编码环境、在 Dreamweaver 中编写代码、优化和调试代码和在设计视图中编辑代码中阅读更多有关使用 Dreamweaver 进行编码的内容。
  5. 请阅读《使用 Dreamweaver》中各章开头的概述，确定您是否对其中的主题感兴趣。


Web 应用程序开发人员

如果您是 Web 应用程序开发人员，本节将为您指出 Dreamweaver 文档中最适合您的背景的章节。根据您以前是否使用过 Dreamweaver，可以采用两种不同的方法。

对于没有使用过 Dreamweaver 的 Web 应用程序开发人员：

  1. 首先快速阅读《Dreamweaver 入门》指南，以便熟悉使用 Dreamweaver 的基本知识。
  2. 在《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中，请阅读了解工作区，了解有关 Dreamweaver 用户界面的更多信息。
  3. 虽然您可能已熟悉设置 Dreamweaver 站点和管理您的文件中的许多内容，但还请大致浏览这些章节，以了解这些熟悉的概念在 Dreamweaver 中是如何实现的。尤其请注意有关设置 Dreamweaver 站点的章节。
  4. 使用 Dreamweaver 设置 Web 服务器和应用程序服务器。（请参见设置 Web 应用程序。）
  5. 连接到数据库。（请参见设置 Web 应用程序中的连接到数据库。）
  6. 请阅读《使用 Dreamweaver》中各章开头的概述，确定您是否对其中的主题感兴趣。

对于有经验且使用过 Dreamweaver 的 Web 应用程序开发人员：

  1. 首先阅读《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中的 Dreamweaver 8 中的新功能。“新增功能”一节位于简介中。
  2. 浏览了解工作区，以了解 Dreamweaver 用户界面的新内容。


高效使用 Dreamweaver 文档

Dreamweaver 包含了多种媒体，可帮助您快速学习此程序并熟练掌握 Web 页的创建。 Dreamweaver 帮助系统中包含多个文档，可帮助您学习 Dreamweaver、Dreamweaver 扩展功能和 ColdFusion。 在学习如何建立 Web 页时，还可以查看许多其它在线资源。

本节包含以下主题：

  • 访问 Dreamweaver 文档
  • 访问其它 Dreamweaver 在线资源

访问 Dreamweaver 文档

下表概述了 Dreamweaver 帮助系统中包含的文档。

您可以购买所选标题名的印刷版本。有关更多信息，请参见 www.macromedia.com/go/buy_books。

标题

说明/目标用户

位置

Dreamweaver 入门

提供 Dreamweaver 概念和界面的基本介绍，附带详尽的初级教程。 面向初级用户以及希望了解新功能的中级和高级用户。
  • 在 Dreamweaver 中查看： 选择“帮助”>“Dreamweaver 入门”
  • 在线查看：http://livedocs.macromedia.com/go/livedocs_dreamweaver_cn/
  • 获取 PDF：www.macromedia.com/go/dw_documentation_cn

使用 Dreamweaver

关于所有 Dreamweaver 功能的详尽信息。 面向所有 Dreamweaver 用户。
  • 在 Dreamweaver 中查看： 选择“帮助”>“Dreamweaver 帮助”或“帮助”>“使用 Dreamweaver”
  • 在线查看：http://livedocs.macromedia.com/go/livedocs_dreamweaver_cn/
  • 获取 PDF：www.macromedia.com/go/dw_documentation_cn

扩展 Dreamweaver

介绍 Dreamweaver 框架和应用程序编程接口 (API)。 面向希望创建扩展功能或自定义 Dreamweaver 界面的高级用户。
  • 在 Dreamweaver 中查看： 选择“帮助”>“扩展 Dreamweaver”
  • 在线查看：http://livedocs.macromedia.com/go/livedocs_dreamweaver_cn/
  • 获取 PDF：www.macromedia.com/go/dw_documentation_cn

Dreamweaver API 参考

介绍实用程序 API 和 JavaScript API，它们使您能够在开发 Dreamweaver 扩展功能时执行各种支持任务。 面向希望创建扩展功能或自定义 Dreamweaver 界面的高级用户。
  • 在 Dreamweaver 中查看： 选择“帮助”>“Dreamweaver API 参考”
  • 在线查看：http://livedocs.macromedia.com/go/livedocs_dreamweaver_cn/
  • 获取 PDF：www.macromedia.com/go/dw_documentation_cn

使用 ColdFusion

收集了 ColdFusion 文档集中最重要的手册。 （LiveDocs 上有完整的文档集。） 适用于对 ColdFusion 感兴趣的所有人，包括初级用户和高级开发人员。
  • 在 Dreamweaver 中查看： 选择“帮助”>“使用 ColdFusion”
  • 在线查看：http://livedocs.macromedia.com/go/livedocs_coldfusion/
  • 获取 PDF：www.macromedia.com/go/cf_documentation

参考资料

包括介绍 HTML、服务器模型和其它主题的各种参考手册，主要由 O’Reilly 发行。 面向需要进一步了解编码语法、概念等信息的所有人。
  • 在 Dreamweaver 中查看： 选择“帮助”>“参考”。 若要查看这些手册的完整列表，请单击“参考”面板中的“书籍”弹出式菜单。

访问其它 Dreamweaver 在线资源

下表概述了用于学习 Dreamweaver 的其它在线资源。

资源 | 说明/目标用户 | 位置
Dreamweaver 支持中心 | 为 Dreamweaver 用户提供的技术说明、支持和帮助解决问题的信息。 | www.macromedia.com/go/dreamweaver_support_cn
Dreamweaver 开发人员中心 | 提供文章和教程，可帮助您提高技能并学习新技能。 | www.macromedia.com/go/dreamweaver_devcenter_cn
Dreamweaver 文档资源中心 | 获取 PDF 格式的产品手册、勘误表、教程和发行说明。 | www.macromedia.com/go/dw_documentation_cn
Macromedia 在线论坛 | Dreamweaver 用户、技术支持代表和 Dreamweaver 开发小组在此开展讨论并提供解决问题的信息。 | www.macromedia.com/go/dreamweaver_newsgroup
Macromedia 培训 | 提供注重实地任务和实际方案的课程。 | www.macromedia.com/go/dreamweaver_training_cn


使用 Dreamweaver 帮助系统

“帮助”菜单中的联机帮助系统提供了有关使用 Dreamweaver 可执行的各种任务的详细信息。若要查看该帮助中提供的文档列表，请参见访问 Dreamweaver 文档。

本节包含以下主题：

  • 打开帮助
  • 搜索帮助
  • 使用索引
  • 更改字体大小
  • 使用起始页
  • 打印 Dreamweaver 文档
  • 讨论 LiveDocs 格式的 Dreamweaver 文档


打开帮助

当您在 Dreamweaver 中工作时，可以访问产品中的帮助。

若要打开 Dreamweaver 帮助，请执行以下操作：

  • 选择“帮助”>“Dreamweaver 帮助”。


搜索帮助

可以对 Dreamweaver 帮助执行全文搜索。

若要搜索产品中的帮助 (Windows)，请执行以下操作：

  1. 在 Dreamweaver 帮助中，单击“搜索”选项卡。
  2. 在文本框中键入一个单词或短语，然后单击“列出主题”。
  3. 双击结果列表中的一个主题，可显示该主题。

    提示

    若要搜索特定短语，请用双引号将其引起来。

若要搜索产品中的帮助 (Macintosh)，请执行以下操作：

  1. 在 Dreamweaver 帮助中，在“提出问题”文本框中键入一个单词或短语，然后按 Enter。
  2. 双击结果列表中的一个主题，可显示该主题。


使用索引

使用索引可以快速找到信息。

若要使用索引 (Windows)，请执行以下操作：

  1. 在 Dreamweaver 帮助中，单击“索引”选项卡。
  2. 滚动到字母列表中的一个索引项，然后双击该项可显示索引信息。

    提示

    可以在文本框中键入一个关键字，以快速滚动到某一索引项。

若要使用索引 (Macintosh)，请执行以下操作：

  1. 在 Dreamweaver 帮助中，在目录中单击“索引”链接。
  2. 单击某个字母以滚动到列表中的某一索引项。
  3. 单击该项旁边的数字，可显示索引信息。


更改字体大小

可以更改帮助系统所使用的字体大小。

若要更改 Windows 帮助查看器中的字体大小，请执行以下操作：

  1. 打开 Internet Explorer。

    Windows 帮助查看器中的字体大小可在 Internet Explorer 中进行设置。

  2. 选择“查看”>“文字大小”，然后选择一个大小。

若要更改 Apple 帮助查看器中的字体大小，请执行以下操作：

  • 在帮助中，选择“编辑”>“减少字体大小”，或“编辑”>“增加字体大小”。


使用起始页

当您启动 Dreamweaver 而未打开文档时，工作环境中将显示 Dreamweaver 起始页。使用起始页，您可以快速访问 Dreamweaver 教程、最近使用的文件以及 Dreamweaver Exchange；在 Dreamweaver Exchange 中您可以向某些 Dreamweaver 功能添加新的功能。使用起始页的方法与使用 Web 页很相似。单击要使用的任一功能即可。

若要禁用起始页，请执行以下操作：

  1. 运行 Dreamweaver 而不打开文档。

    将显示起始页。

  2. 单击“不再显示”。


打印 Dreamweaver 文档

Macromedia 的 Web 站点 www.macromedia.com/go/dw_documentation_cn 中提供有 PDF 格式的下列书籍：

  • 《使用 Dreamweaver》
  • 《Dreamweaver 入门》
  • 《扩展 Dreamweaver》
  • 《Dreamweaver API 参考》

可以在自己的打印机中打印 PDF 的部分或全部，或将 PDF 文档送到复印店进行复印。


讨论 LiveDocs 格式的 Dreamweaver 文档

Dreamweaver 文档还通过 LiveDocs 格式在线提供。Dreamweaver 帮助的 LiveDocs 版本看起来与产品中的帮助非常类似，但它允许您对各个帮助页的内容进行注释。可以根据您自己的经验对特定的 Dreamweaver 主题添加有用的信息，或恳请 Dreamweaver 设计和开发人员提供建议。

Dreamweaver LiveDocs 位于以下位置：http://livedocs.macromedia.com/go/livedocs_dreamweaver_cn


Dreamweaver 基础

为了最有效地使用 Macromedia Dreamweaver 8，您应了解 Dreamweaver 工作区的基本元素。本章介绍最重要且最常用的工作区元素，并讲述如何在 Dreamweaver 中完成一些基本任务。

本章包含下列章节：

了解 Dreamweaver 8 工作区

自定义 Dreamweaver 8 工作区

在 Dreamweaver 8 中完成基本任务


了解 Dreamweaver 8 工作区

Dreamweaver 工作区使您可以查看文档和对象属性。工作区还将许多常用操作放置于工具栏中，使您可以快速更改文档。

本节旨在提供 Dreamweaver 8 工作区的概述。有关本节中介绍的任一工作区的更多信息，请参见《使用 Dreamweaver》中的了解工作区。

本节包含以下主题：

  • 工作区布局
  • “文档”窗口
  • “文档”工具栏
  • 状态栏
  • “插入”栏
  • “编码”工具栏
  • “属性”检查器
  • “文件”面板
  • “CSS 样式”面板


工作区布局

在 Windows 中，Dreamweaver 提供了一个将全部元素置于一个窗口中的集成布局。在集成的工作区中，全部窗口和面板都被集成到一个更大的应用程序窗口中。

注意

Windows 工作区还有一个“编码器”选项，它默认将面板组停靠在左侧，并在“代码”视图中显示“文档”窗口。有关更多信息，请参见《使用 Dreamweaver》中的使用面向编码器的工作区（仅限 Windows）。若要使用此选项，请参见选择工作区布局（仅限 Windows）。

在 Macintosh 中，Dreamweaver 可在一个窗口中显示多个文档，并使用选项卡来标识每个文档。Dreamweaver 也可显示为浮动工作区的一部分，此时每个文档都显示在自己独立的窗口中。面板组最初停靠在一起，但是可以将它们取消停靠使其位于自己的窗口中。当您拖动窗口或调整它们的大小时，窗口将自动彼此对齐或者与屏幕的边沿、“文档”窗口对齐。

您可以在 Windows 和 Macintosh 中的不同布局之间进行切换。有关更多信息，请参见选择工作区布局（仅限 Windows）和显示选项卡式文档 (Macintosh)。


“文档”窗口

“文档”窗口显示当前文档。可以选择下列任一视图：

“设计”视图是一个用于可视化页面布局、可视化编辑和快速应用程序开发的设计环境。在该视图中，Dreamweaver 显示文档的完全可编辑的可视化表示形式，类似于在浏览器中查看页面时看到的内容。

“代码”视图是一个用于编写和编辑 HTML、JavaScript、服务器语言代码（如 PHP 或 ColdFusion 标记语言 (CFML)）以及任何其它类型代码的手工编码环境。有关更多信息，请参见《使用 Dreamweaver》中的在 Dreamweaver 中编写代码。

“代码和设计”视图使您可以在单个窗口中同时看到同一文档的“代码”视图和“设计”视图。

当“文档”窗口有一个标题栏时，标题栏显示页面标题，并在括号中显示文件的路径和文件名。如果您做了更改但尚未保存，Dreamweaver 将在文件名后显示一个星号。

当“文档”窗口在集成工作区布局（仅限 Windows）中处于最大化状态时，它没有标题栏；在这种情况下，页面标题以及文件的路径和文件名显示在主工作区窗口的标题栏中。

此外，当“文档”窗口处于最大化状态时，出现在“文档”窗口区域顶部的选项卡显示所有打开文档的文件名。若要切换到某个文档，请单击它的选项卡。

有关使用“文档”窗口的更多信息，请参见《使用 Dreamweaver》中的了解工作区。


“文档”工具栏

“文档”工具栏中包含按钮，这些按钮使您可以在文档的不同视图间快速切换：“代码”视图、“设计”视图、同时显示“代码”和“设计”视图的拆分视图。

工具栏中还包含一些与查看文档、在本地和远程站点间传输文档有关的常用命令和选项。

以下选项出现在“文档”工具栏中：

显示代码视图仅在“文档”窗口中显示“代码”视图。

显示代码视图和设计视图在“文档”窗口的一部分中显示“代码”视图，而在另一部分中显示“设计”视图。当选择了这种组合视图时，“视图选项”菜单中的“在顶部查看设计视图”选项变为可用。请使用该选项指定在“文档”窗口的顶部显示哪种视图。

显示设计视图仅在“文档”窗口中显示“设计”视图。

服务器调试显示一个报告，帮助您调试当前 ColdFusion 页。该报告包括您的页面中的错误（如果有的话）。

文档标题允许您为文档输入一个标题，它将显示在浏览器的标题栏中。如果文档已经有了一个标题，则该标题将显示在该区域中。

没有浏览器/检查错误使您可以检查跨浏览器兼容性。

验证标记使您可以验证当前文档或选中的标签。

文件管理显示“文件管理”弹出式菜单。

在浏览器中预览/调试允许您在浏览器中预览或调试文档。从弹出式菜单中选择一个浏览器。

刷新设计视图当您在“代码”视图中进行更改后刷新文档的“设计”视图。在执行某些操作（如保存文件或单击该按钮）之前，您在“代码”视图中所做的更改不会自动显示在“设计”视图中。

视图选项允许您为“代码”视图和“设计”视图设置选项，其中包括选择哪个视图显示在最上面。该菜单中的选项用于当前视图：“设计”视图、“代码”视图或两者。

可视化助理使您可以使用不同的可视化助理来设计页面。

有关使用“文档”工具栏的更多信息，请参见《使用 Dreamweaver》中的了解工作区。


状态栏

“文档”窗口底部的状态栏提供与您正创建的文档有关的其它信息。

标签选择器显示环绕当前选定内容的标签的层次结构。单击该层次结构中的任何标签以选择该标签及其全部内容。单击 <body> 可以选择文档的整个正文。若要设置标签选择器中某个标签的 class 或 id 属性，请右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 该标签，然后从上下文菜单中选择一个类或 ID。标签选择器是选择标签的首选方法，因为它可以确保您始终准确地选择标签。

手形工具使您可以单击文档并将其拖入“文档”窗口。单击“选择”工具可禁用手形工具。

“缩放”工具和“设置缩放比率”弹出式菜单可以让您为文档设置缩放比率。有关更多信息，请参见《使用 Dreamweaver》中的放大和缩小。

“窗口大小”弹出式菜单（仅在“设计”视图中可见）用来将“文档”窗口的大小调整到预定义或自定义的尺寸。有关更多信息，请参见《使用 Dreamweaver》中的调整“文档”窗口的大小。

“窗口大小”弹出式菜单的右侧是页面（包括全部相关的文件，如图像和其它媒体文件）的文档大小和估计下载时间。有关更多信息，请参见《使用 Dreamweaver》中的设置下载时间和大小首选参数。

有关使用状态栏的更多信息，请参见《使用 Dreamweaver》中的了解工作区。


“插入”栏

“插入”栏包含用于创建和插入对象（如表格、层和图像）的按钮。当鼠标指针滚动到一个按钮上时，会出现一个工具提示，其中含有该按钮的名称。

这些按钮被组织到几个类别中，您可以在“插入”栏的左侧切换它们。当前文档包含服务器代码时（例如 ASP 或 CFML 文档），还会显示其它类别。当您启动 Dreamweaver 时，系统会打开您上次使用的类别。

某些类别具有带弹出式菜单的按钮。从弹出式菜单中选择一个选项时，该选项将成为该按钮的默认操作。例如，如果从“图像”按钮的弹出式菜单中选择“图像占位符”，下次单击“图像”按钮时，Dreamweaver 会插入一个图像占位符。每当从弹出式菜单中选择一个新选项时，该按钮的默认操作都会改变。

“插入”栏按以下的类别进行组织：

“常用”类别使您可以创建和插入最常用的对象，例如图像和表格。

“布局”类别使您可以插入表格、div 标签、层和框架。您还可以从三个表格视图中进行选择：“标准”（默认）、“扩展表格”和“布局”。当选择“布局”模式后，您可以使用 Dreamweaver 布局工具：“绘制布局单元格”和“绘制布局表格”。

“表单”类别包含用于创建表单和插入表单元素的按钮。

“文本”类别使您可以插入各种文本格式设置标签和列表格式设置标签，例如 b、em、p、h1 和 ul。

“HTML”类别使您可以插入用于水平线、文件头内容、表格、框架和脚本的 HTML 标签。

“服务器代码”类别仅适用于使用特定服务器语言的页面，这些服务器语言包括 ASP、ASP.NET、CFML Basic、CFML Flow、CFML Advanced、JSP 和 PHP。这些类别中的每一个都提供了服务器代码对象，您可以将这些对象插入“代码”视图中。

“应用程序”类别使您可以插入动态元素，例如记录集、重复区域以及记录插入和更新表单。

“Flash 元素”类别使您可以插入 Macromedia Flash 元素。

“收藏夹”类别使您可以将“插入”栏中最常用的按钮分组和组织到某一公共位置。

有关使用“插入”栏的更多信息，请参见《使用 Dreamweaver》中的了解工作区。


“编码”工具栏

“编码”工具栏包含可用于执行多种标准编码操作的按钮，例如折叠和展开所选代码、高亮显示无效代码、应用和删除注释、缩进代码、插入最近使用过的代码片断，等等。“编码”工具栏仅在“代码”视图中才是可见的，它垂直显示在“文档”窗口的左侧。

您不能取消停靠或移动“编码”工具栏，但可以将其隐藏。有关更多信息，请参见《使用 Dreamweaver》中的显示工具栏。

有关使用“编码”工具栏的更多信息，请参见《使用 Dreamweaver》中的使用编码工具栏迅速插入代码。


“属性”检查器

“属性”检查器使您可以检查和编辑当前选定页面元素（如文本和插入的对象）的最常用属性。“属性”检查器中的内容根据选定的元素会有所不同。例如，如果您选择页面上的一个图像，则“属性”检查器将改为显示该图像的属性（如图像的文件路径、图像的宽度和高度、图像周围的边框（如果有），等等）。

默认情况下，“属性”检查器位于工作区的底部，但是如果需要的话，您可以将它停靠在工作区的顶部。或者，您可以将它变为工作区中的浮动面板。有关移动“属性”检查器的更多信息，请参见《使用 Dreamweaver》中的停靠和取消停靠面板和面板组。

有关使用“属性”检查器的更多信息，请参见《使用 Dreamweaver》中的使用“属性”检查器。


“文件”面板

“文件”面板用于查看和管理 Dreamweaver 站点中的文件。

在“文件”面板中查看站点、文件或文件夹时，您可以更改查看区域的大小，还可以展开或折叠“文件”面板。当“文件”面板折叠时，它以文件列表的形式显示本地站点、远程站点或测试服务器的内容。在展开时，它显示本地站点和远程站点或者显示本地站点和测试服务器。“文件”面板还可以显示本地站点的视觉站点地图。

对于 Dreamweaver 站点，您还可以通过更改默认显示在折叠面板中的视图（本地站点或远程站点）来对“文件”面板进行自定义。

有关使用“文件”面板来管理站点的更多信息，请参见《使用 Dreamweaver》中的管理您的文件。


“CSS 样式”面板

使用“CSS 样式”面板可以跟踪影响当前所选页面元素的 CSS 规则和属性（“当前”模式），或影响整个文档的规则和属性（“所有”模式）。使用“CSS 样式”面板顶部的切换按钮可以在两种模式之间切换。使用“CSS 样式”面板还可以在“所有”和“当前”模式下修改 CSS 属性。

可以通过拖放窗格之间的边框来调整任一窗格的大小。

在“当前”模式下，“CSS 样式”面板显示三个窗格：“所选内容的摘要”窗格，其中显示文档中当前所选内容的 CSS 属性；“规则”窗格，其中显示所选属性的位置（或所选标签的规则的层叠，具体取决于您的选择）；以及“属性”窗格，它允许您编辑用于定义所选内容的规则的 CSS 属性。

在“所有”模式下，“CSS 样式”面板显示两个窗格：“所有规则”窗格（顶部）和“属性”窗格（底部）。“所有规则”窗格显示当前文档中定义的规则以及附加到当前文档的样式表中定义的所有规则的列表。使用“属性”窗格可以编辑“所有规则”窗格中任何所选规则的 CSS 属性。

对“属性”窗格所做的任何更改都将立即应用，这使您可以在操作的同时预览效果。

有关“CSS 样式”面板的更多信息，请参见《使用 Dreamweaver》中的关于“CSS 样式”面板。


自定义 Dreamweaver 8 工作区

使用一些基本技巧，可以自定义 Dreamweaver 使其适合您的需要，而无须了解复杂的代码或编辑文本文件。

本节包含以下主题：

  • 选择工作区布局（仅限 Windows）
  • 显示选项卡式文档 (Macintosh)
  • 隐藏和显示起始页


选择工作区布局（仅限 Windows）

在 Windows 中，您可以选择“设计器”和“编码器”工作区布局。第一次启动 Dreamweaver 时，会出现一个对话框，让您选择工作区布局。您可以随时切换到不同的工作区。

若要在首次启动 Dreamweaver 时选择一种工作区样式，请执行以下操作：

  1. 选择以下布局之一：

    设计器是一个使用 MDI（多文档界面）的集成工作区，其中全部“文档”窗口和面板被集成在一个较大的应用程序窗口中，并将面板组停靠在右侧。

    编码器同样是集成的工作区，但是它将面板组停靠在左侧，布局类似于 Macromedia HomeSite 和 Macromedia ColdFusion Studio 所用的布局，而且“文档”窗口在默认情况下显示“代码”视图。

    注意

    您可以将面板组停靠在任意布局中的工作区的任意一端。
  2. 单击“确定”。

若要在选择一种工作区后切换到另一种工作区，请执行以下操作：

  • 选择“窗口”>“工作区布局”，然后选择您喜欢的工作区布局。

除了选择“编码器”和“设计器”外，您还可以选择“双重屏幕”。如果您另外还有一个显示器，“双重屏幕”可将所有面板放在该显示器上，而将“文档”窗口保留在主显示器上。


显示选项卡式文档 (Macintosh)

在 Macintosh 中，Dreamweaver 可以在一个“文档”窗口中显示多个文档，并使用选项卡来标识每个文档。Dreamweaver 还可以将这些文档显示为浮动工作区的一部分，此时每个文档都显示在自己单独的窗口中。

若要在单独的窗口中打开选项卡式文档，请执行以下操作：

  • 右键单击或按住 Control 键单击选项卡并从上下文菜单中选择“移至新窗口”。

若要将独立的文档合并到选项卡式窗口中，请执行以下操作：

  • 选择“窗口”>“合并为选项卡”。

若要更改默认选项卡式文档的设置，请执行以下操作：

  1. 选择“Dreamweaver”>“首选参数”，然后选择“常规”类别。
  2. 选择或取消选择“以选项卡方式打开文档”并单击“确定”。

    注意

    在您更改首选参数时，Dreamweaver 不会更改当前打开的文档的显示。但是，在选择新的首选参数之后打开的文档将按照您所选的首选参数进行显示。


隐藏和显示起始页

在启动 Dreamweaver 时以及在每次没有打开文档时，都会显示 Dreamweaver 起始页。您可以选择隐藏起始页，以后再显示它。当起始页被隐藏并且没有打开的文档时，“文档”窗口处于空白状态。

若要隐藏起始页，请执行以下操作：

  • 选择起始页上的“不再显示此对话框”复选框。

    在启动 Dreamweaver 时，或在打开然后关闭一个文档后将不再显示起始页。

若要显示起始页，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)。

    出现“首选参数”对话框，其中显示了“常规”首选项类别。

  2. 选择“显示起始页”复选框。

    在启动 Dreamweaver 时，或在打开然后关闭一个文档后将显示起始页。


在 Dreamweaver 8 中完成基本任务

本节介绍如何完成创建、打开和保存文件等基本任务。有关更多信息，请参见《使用 Dreamweaver》中的创建和打开文档。

本节包含以下主题：

  • 关于 Dreamweaver 文件
  • 在 Dreamweaver 中创建新文件
  • 在 Dreamweaver 中保存文件
  • 在 Dreamweaver 中打开文件


关于 Dreamweaver 文件

在Dreamweaver 中可以使用多种文件类型。使用的主要文件类型是 HTML 文件。HTML 文件（或超文本标记语言文件）包含基于标签的语言，负责在浏览器中显示 Web 页面。可以使用 .html 或 .htm 扩展名保存 HTML 文件。Dreamweaver 默认情况下使用 .html 扩展名保存文件。

下面是您在 Dreamweaver 中工作时可能会用到的其它一些常见文件类型：

CSS 层叠样式表 (Cascading Style Sheet) 文件，具有 .css 扩展名。它们用于设置 HTML 内容的格式并控制各个页面元素的位置。有关使用这些文件类型的更多信息，请参见《使用 Dreamweaver》中的了解层叠样式表。

GIF 图形交换格式 (Graphics Interchange Format) 文件，具有 .gif 扩展名。GIF 格式是用于卡通、徽标、具有透明区域的图形、动画的常用 Web 图形格式。GIF 最多包含 256 种颜色。

JPEG 联合图像专家组文件 (Joint Photographic Experts Group)，根据创建该格式的组织命名，具有 .jpg 扩展名，通常是照片或色彩较鲜明的图像。JPEG 格式最适合用于数码照片或扫描的照片、使用纹理的图像、具有渐变色过渡的图像以及需要 256 种以上颜色的任何图像。

XML 可扩展标记语言 (Extensible Markup Language) 文件，具有 .xml 扩展名。它们包含原始形式的数据，可使用 XSL（Extensible Stylesheet Language：可扩展样式表语言）设置这些数据的格式。有关使用这些文件类型的更多信息，请参见《使用 Dreamweaver》中的在 Web 页面中显示 XML 数据。

XSL 可扩展样式表语言 (Extensible Stylesheet Language) 文件，具有 .xsl 或 .xslt 扩展名。它们用于设置要在 Web 页中显示的 XML 数据的样式。有关使用这些文件类型的更多信息，请参见《使用 Dreamweaver》中的在 Web 页面中显示 XML 数据。

CFML ColdFusion 标记语言 (ColdFusion Markup Language) 文件，具有 .cfm 扩展名。它们用于处理动态页面。有关使用这些文件类型的更多信息，请参见《使用 Dreamweaver》中的快速构建 ColdFusion 应用程序。

ASPX ASP.NET 文件，具有 .aspx 扩展名。它们用于处理动态页面。有关使用这些文件类型的更多信息，请参见《使用 Dreamweaver》中的快速生成 ASP.NET 应用程序。

PHP PHP: 超文本处理器 (PHP: Hypertext Preprocessor) 文件，具有 .php 扩展名。它们用于处理动态页面。有关使用这些文件类型的更多信息，请参见《使用 Dreamweaver》中的快速生成 PHP 应用程序。


在 Dreamweaver 中创建新文件

本节讲述如何在 Dreamweaver 中创建新的空白文档。

您也可以在 Dreamweaver 中基于Dreamweaver 设计文件或现有模板创建新文档。有关更多信息，请参见《使用 Dreamweaver》中的创建新文档。

若要创建新的空白文档，请执行以下操作：

  1. 选择“文件”>“新建”。

    即出现“新建文档”对话框。“常规”选项卡已被选定。

  2. 从“类别”列表中选择“基本页”、“动态页”、“模板页”、“其它”或“框架集”；然后从右侧的列表中选择要创建的文档的类型。

    例如，选择“基本页”创建 HTML 文档，或选择“动态页”创建 ColdFusion 或 ASP 文档，诸如此类。

    有关此对话框中的选项的更多信息，请单击对话框中的“帮助”按钮。

  3. 单击“创建”按钮。

    新文档在“文档”窗口中打开。

  4. 保存该文档（请参见在 Dreamweaver 中保存文件）。


在 Dreamweaver 中保存文件

创建新文档后，需要保存它。

若要保存新文档，请执行以下操作：

  1. 选择“文件”>“保存”。

    提示

    最好将您的文件保存在 Dreamweaver 站点中。有关更多信息，请参见教程：设置站点和项目文件。
  2. 在出现的对话框中，定位到要用来保存文件的文件夹。
  3. 在“文件名称”文本框中，键入文件名。

    请不要在文件名和文件夹名中使用空格和特殊字符，文件名也不要以数字开头。具体说来就是不要在打算放到远程服务器上的文件名中使用特殊字符（如 é、ç 或 ¥）或标点符号（如冒号、斜杠或句号）；很多服务器在上传时会更改这些字符，这会导致与这些文件的链接中断。

  4. 单击“保存”。


在 Dreamweaver 中打开文件

在 Dreamweaver 中，可以轻松打开和编辑文档。

若要打开文件，请执行以下操作：

  1. 选择“文件”>“打开”。
  2. 在“打开”对话框中，选择文件并单击“打开”。


教程：设置站点和项目文件

本教程介绍 Macromedia Dreamweaver 8 站点的概念，并演示如何为 Cafe Townsend 示例 Web 站点设置项目文件。在 Dreamweaver 中，站点通常包含两部分：本地计算机（本地站点）上的一组文件和远程 Web 服务器上的一个位置（远程站点）。当您准备好将本地计算机上的文件提供给公众访问时，需要将这些文件上传到该位置。可以使用 Dreamweaver 的“文件”面板管理站点文件。

使用 Dreamweaver 创建 Web 站点最常见的方法是在本地磁盘上创建并编辑页面，然后将这些页面的副本上传到一个远程 Web 服务器以便通过网络查看。在本教程中，您只学习如何设置本地站点，以便立即着手构建 Web 页面。在设置完本地 Web 站点之后，您将学习如何创建远程站点，以便将文件上传到 Web 服务器。

在本教程中，您将完成以下任务：

了解 Dreamweaver 站点

设置项目文件

定义本地文件夹


了解 Dreamweaver 站点

在 Dreamweaver 中，“站点”一词既表示 Web 站点，又表示属于 Web 站点的文档的本地存储位置。在开始构建 Web 站点之前，您需要建立站点文档的本地存储位置。Dreamweaver 站点可组织与 Web 站点相关的所有文档，跟踪和维护链接，管理文件，共享文件以及将站点文件传输到 Web 服务器。

注意

Macromedia HomeSite 和 ColdFusion Studio 用户可以将 Dreamweaver 站点视为 HomeSite 或 Studio 项目。

Dreamweaver 站点最多由三部分组成，具体取决于您的计算机环境和所开发的 Web 站点的类型：

本地文件夹是您的工作目录。Dreamweaver 将此文件夹称为本地站点。本地文件夹通常是硬盘上的一个文件夹。

远程文件夹是存储文件的位置，这些文件用于测试、生产、协作和发布等，具体取决于您的环境。Dreamweaver 将此文件夹称为远程站点。远程文件夹是运行 Web 服务器的计算机上的某个文件夹。运行 Web 服务器的计算机通常是（但不总是）使您的站点可在 Web 上公开访问的计算机。

动态页文件夹（“测试服务器”文件夹）是 Dreamweaver 用于处理动态页的文件夹。此文件夹与远程文件夹通常是同一文件夹。除非您在开发 Web 应用程序，否则无需考虑此文件夹。有关“测试服务器”文件夹的更多信息，请参见《使用 Dreamweaver》中的指定可在哪里处理动态页。

可以使用“站点定义向导”设置 Dreamweaver 站点，该向导会引领您完成设置过程。或者，也可以使用“站点定义”的“高级”设置，根据需要分别设置本地文件夹、远程文件夹和测试文件夹。在本教程中，您将使用“站点定义”的“高级”设置来设置项目文件的本地文件夹。在本书后面的部分，您将学习如何设置远程文件夹，以便将页面发布到 Web 服务器，从而提供给公众访问。

有关如何使用“站点定义向导”来设置 Dreamweaver 站点的更多信息，请参见《使用 Dreamweaver》中的设置新的 Dreamweaver 站点。

有关如何设置远程站点的更多信息，请参见教程：发布站点。

有关 Dreamweaver 站点的更多一般信息，请参见《使用 Dreamweaver》中的“设置 Dreamweaver 站点”。


设置项目文件

创建本地站点时，可将任何现有资源（图像或其它内容）放在本地站点的根文件夹（站点的主文件夹）下。当您准备向页面中添加内容时，可随时使用这些资源。

Dreamweaver 中附带的示例文件包含您使用这些《Dreamweaver 入门》教程构建示例 Web 站点时所需的资源。创建站点的第一步是将示例文件从 Dreamweaver 应用程序文件夹复制到您的硬盘上相应的文件夹中。

  1. 在硬盘上创建名为 local_sites 的新文件夹。

    例如，在下面两个位置之一创建一个名为 local_sites 的文件夹：

    • 在 Windows 中：C:\Documents and Settings\your_user_name\My Documents\local_sites
    • 在 Macintosh 中：Macintosh HD/Users/your_user_name/Documents/local_sites

      注意

      在 Macintosh 上，在用户文件夹中已经有一个名为 Sites 的文件夹。不要使用该 Sites 文件夹作为本地文件夹；该 Sites 文件夹是您在将 Macintosh 用作 Web 服务器时放置页面以使它们可供公开访问的位置。
  2. 在硬盘上的 Dreamweaver 应用程序文件夹中找到 cafe_townsend 文件夹。

    如果将 Dreamweaver 安装到其默认位置，则该文件夹的路径如下所示：

    • 在 Windows 中：C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\。
    • 在 Macintosh 中：Macintosh HD/Applications/Macromedia Dreamweaver 8/Tutorial_assets/cafe_townsend。

      关于…

      关于本地“根”文件夹和远程“根”文件夹 您的 Dreamweaver 站点的本地“根”文件夹通常是 Web 站点的主文件夹或顶级文件夹。该文件夹通常对应于远程站点（Web 服务器）上的一个完全相同的文件夹。根文件夹通常还定义 Web 站点的 URL 的第一部分，跟在域名的后面。例如，如果您的本地根文件夹为 mywebsite，且远程站点上定义了一个完全相同的根文件夹，那么您的 Web 站点的 URL 的形式将类似于 http://www.yahoo.com/mywebsite。

      在有些情况下，本地根文件夹的名称与它在远程站点上的名称不一定完全相同。例如，如果您拥有域名 www.mywebsite.com，该站点的远程根目录为 public_html，则您仍然可以将该站点的本地根文件夹命名为 mywebsite。本地根目录和远程根目录中的文件应完全相同；只是这两个文件夹的名称不同而已（在远程站点上为 public_html，在本地计算机上为 mywebsite）。
  3. 将 cafe_townsend 文件夹复制到 local_sites 文件夹中。

    您将使用 cafe_townsend 文件夹作为 Dreamweaver 站点的根文件夹（主文件夹）。


定义本地文件夹

您必须为创建的每一个新 Web 站点定义 Dreamweaver 本地文件夹。本地文件夹是您在硬盘上用来存储站点文件的工作副本的文件夹。如果不定义本地文件夹，Dreamweaver 中的某些功能可能无法正确运行。

如果定义了本地文件夹，您还可以管理文件，并使用一些文件传输方法在本地与 Web 服务器之间传输文件。

下面将复制到 local_sites 文件夹中的 cafe_townsend 文件夹定义为您的本地文件夹。

  1. 启动 Dreamweaver，选择“站点 ”>“管理站点”。

    出现“管理站点”对话框。

  2. 单击“新建”按钮，然后选择“站点”。

    出现“站点定义”对话框。

  3. 如果显示向导（“基本”选项卡），请单击“高级”选项卡，然后从“分类”列表中选择“本地信息”（它应当是默认选项）。
  4. 在“站点名称”文本框中，输入 Cafe Townsend 作为站点名称。
  5. 在“本地根文件夹”文本框中，指定在上一节中复制到 local_sites 文件夹中的 cafe_townsend 文件夹。

    可以单击文件夹图标来浏览并选择该文件夹，或者在“本地根文件夹”文本框中输入路径。

  6. 在“默认图像文件夹”文本框中，指定 cafe_townsend 文件夹中已有的 images 文件夹。

    可以单击文件夹图标来浏览并选择该文件夹，或者在“默认图像文件夹”文本框中输入路径。

    现在，“站点定义”对话框看起来应如下所示：

  7. 单击“确定”。

    随即出现“管理站点”对话框，显示您的新站点。

  8. 单击“完成”关闭“管理站点”对话框。

此时“文件”面板显示当前站点的新本地根文件夹。“文件”面板中的文件列表将充当文件管理器，允许您复制、粘贴、删除、移动和打开文件，就象在计算机桌面上一样。

有关“文件”面板使用方式的更多信息，请参见“文件”面板。

现在，已经为您的站点定义了一个本地根文件夹。本地根文件夹是本地计算机上用来存储 Web 页面的工作副本的文件夹。如果您以后想要发布页面并使其可供公众访问，则需要在运行 Web 服务器的远程计算机上定义一个远程文件夹，用来存储本地文件的已发布副本。

您可以按照本指南的其余教程来创建 Cafe Townsend 示例站点，也可以处理自己的 Web 页。完成了页面的创建和编辑后，可继续在服务器上定义远程文件夹并发布页面。有关更多信息，请参见教程：发布站点。


教程：创建基于表格的页面布局

本教程介绍如何在 Macromedia Dreamweaver 8 中创建基于表格的页面布局。页面布局将确定您的页面在浏览器中会如何显示，例如，显示菜单、图像和 Macromedia Flash 内容将如何放置。

表格是用于在 HTML 页上显示表格式数据以及对文本和图形进行布局的强有力的工具。您可以使用表格快速轻松地创建布局。在本教程中，您将在一个新的 Dreamweaver 文档中创建若干表格。这些表格的行和单元格实际上用作您将在以后添加的内容的“容器框”。

在本教程中，您将完成以下任务：

检查设计草样

创建并保存新页面

插入表格

设置表格属性

插入图像占位符

向页面添加颜色


检查设计草样

通常，创建 Web 站点并不是以打开 Dreamweaver 并立即对页面进行布局开始的。创建 Web 站点的初始工作从纸张或图形编辑应用程序（如 Macromedia Fireworks）开始。图形设计人员通常会画出 Web 站点综合图形的草图（也称为“草样”），以便向客户展示并确保站点的初始构思能让客户满意。

设计草样由客户要求其 Web 站点具有的任意数目的页面元素组成。例如，客户可能会提出：“页面顶端要有徽标，要有能链接到其它页面的导航功能，有用于联机存储的部分和可以插入视频剪辑的位置。”根据这些讨论，设计人员开始对站点布局进行规划，并制作满足客户要求的示例页面草图。

本教程向您提供为 Cafe Townsend（一个需要制作 Web 站点的虚构餐馆）设计的、完整的和符合要求的设计草样。作为 Web 设计人员，您需要对草样进行转换，使之最终形成可以使用的 Web 页面（通常需要其他图形设计人员与 Flash 开发人员的帮助）。

您可以看到，图形设计人员已经向您提供了 Web 页面设计草样，其中包括一些内容区域和图形方案。在下面的部分，您将使用 Dreamweaver 展示此设计。

您也可以打开原始草样文件以便在计算机屏幕上查看该设计草样。可以在 cafe_townsend 文件夹（在教程：设置站点和项目文件中已将该文件夹复制到了硬盘上）的 fireworks_assets 文件夹中找到设计草样 homepage-mockup.jpg。在创建页面时，还可以打印草样以便随时查看。


创建并保存新页面

建立站点并检查设计草样后，您就可以开始创建 Web 页面了。首先您将创建一个新页面，并将它保存到您的 Web 站点的本地根文件夹 cafe_townsend 中。该页面最终将成为虚构餐馆 Cafe Townsend 的主页。

如果您尚未创建本地根文件夹 cafe_townsend，则必须先完成创建，然后再继续。有关说明，请参见教程：设置站点和项目文件

  1. 在 Dreamweaver 中，选择“文件”>“新建”。
  2. 在“新建文档”对话框的“常规”选项卡上，从“类别”列表中选择“基本页”，从“基本页”列表中选择“HTML”，然后单击“创建”。
  3. 选择“文件”>“另存为”。
  4. 在“另存为”对话框中，浏览至定义为站点的本地根文件夹的 cafe_townsend 文件夹并打开该文件夹。

    在教程：设置站点和项目文件中，您在名为 local_sites 的文件夹中创建了此文件夹。

  5. 在“文件名”文本框中输入 index.html，然后单击“保存”。

    文件名即出现在应用程序窗口顶部的标题栏中。

  6. 在新文档顶部的“文档标题”文本框中，键入 Cafe Townsend。

    这就是页面的标题（与文件名不同）。站点访问者在 Web 浏览器中查看页面时将在浏览器窗口的标题栏中看到此标题。

  7. 选择“文件”>“保存”来保存该页面。


插入表格

接下来，您将添加一个表格，用于放置文本、图形和 Macromedia Flash 资源。

  1. 在页面上单击一次，在页面左上角放置插入点。

  2. 选择“插入”>“表格”。
  3. 在“插入表格”对话框中，执行下面的操作：
    • 在“行数”文本框中，输入 3。
    • 在“列数”文本框中，输入 1。
    • 在“表格宽度”文本框中，输入 700。
    • 在“表格宽度”弹出式菜单中，选择“像素”。
    • 在“边框粗细”文本框中，输入 0。
    • 在“单元格边距”文本框中，输入 0。
    • 在“单元格间距”文本框中，输入 0。

  4. 单击“确定”。

    一个三行一列的表格即出现在文档中。该表格的宽度为 700 像素，边框、单元格边距和单元格间距均为 0。

    关于…

    关于表格的更多信息 表格是用来在 HTML 页上显示表格式数据以及对文本和图形进行布局的强有力工具。表格由一行或多行组成；每行又由一个或多个单元格组成。当您创建包含多个单元格的多行表格时，这些单元格形成列。从技术上来说，一个单元格是水平行中的一个区域，而一列是由这些单元格区域垂直堆积而成的。

    当选定了表格或表格中有插入点时，Dreamweaver 会显示表格宽度和表格选择器（由绿色线条指示）中的每个表格列的列宽。

    宽度旁边是表格标题菜单与列标题菜单的箭头。使用菜单可以快速访问一些与表格相关的常用命令。还可以通过选择“查看”>“可视化助理”>“表格宽度”来启用或禁用宽度和菜单的显示。

    表格可以具有边框，表格的单元格可以具有边距、间距或同时具有边距和间距。单元格边距是指单元格内容和单元格边界之间的像素数。单元格间距是指相邻的表格单元格之间的像素数。

    如果您没有明确指定单元格边距和单元格间距的值，则大多数浏览器按单元格边距设置为 1、单元格间距设置为 2 来显示表格。若要确保浏览器显示的表格没有边距和间距，请将单元格边距和单元格间距设置为 0。

    有关表格的更多信息，请参见《使用 Dreamweaver》中的使用表格显示内容。
  5. 单击一次该表格右侧取消对它的选择。
  6. 选择“插入”>“表格”以插入另一个表格。
  7. 在“插入表格”对话框中，对第二个表格执行下面的操作：
    • 在“行数”文本框中，输入 1。
    • 在“列数”文本框中，输入 3。
    • 在“表格宽度”文本框中，输入 700。
    • 在“表格宽度”弹出式菜单中，选择“像素”。
    • 在“边框粗细”文本框中，输入 0。
    • 在“单元格边距”文本框中，输入 0。
    • 在“单元格间距”文本框中，输入 0。
  8. 单击“确定”。

    第二个表格（该表格具有一行三列）即出现在第一个表格下方。

  9. 单击该表格右侧取消对它的选择。
  10. 通过选择“插入”>“表格”，然后在“插入表格”对话框中输入以下值来插入第三个表格：
    • 在“行数”文本框中，输入 1。
    • 在“列数”文本框中，输入 1。
    • 在“表格宽度”文本框中，输入 700。
    • 在“表格宽度”弹出式菜单中，选择“像素”。
    • 在“边框粗细”文本框中，输入 0。
    • 在“单元格边距”文本框中，输入 0。
    • 在“单元格间距”文本框中，输入 0。
  11. 单击“确定”。

    第三个表格（该表格具有一行一列）即出现在第二个表格下方。

    单击该表格右侧取消对它的选择。您的页面现在应如下所示：

    注意

    插入表格后可能会看到表格选择器（由绿色线条指示）。通过在表格外单击，通常可以隐藏表格选择器。也可以通过选择“查看”>“可视化助理”>“表格宽度”禁用表格选择器。


设置表格属性

现在将使用“扩展表格”模式设置具体的表格属性，“扩展表格”模式是用于临时添加表格的单元格边距和间距并增加表格边框以简化编辑的一种功能。特别需要指出的是，它使您能够精确地放置插入点，而不会意外选择错误的表格或其它表格内容。

注意

在“扩展表格”模式下完成对表格属性的设置后，应总是返回到“标准”模式。“扩展表格”模式不属于所见即所得环境，因此某些操作（如调整大小）不会得到预期的结果
  1. 选择“查看”>“表格模式”>“扩展表格模式”。

    注意

    如果出现“开始使用扩展表格模式”对话框，请单击“确定”。
  2. 在第一个表格的第一行内单击一次。

  3. 在“属性”检查器（“窗口”>“属性”）的“单元格高度”文本框中输入 90，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    注意

    如果未出现“单元格高度”文本框，请单击“属性”检查器右下角的展开箭头。
  4. 在第一个表格的第二行内单击一次。

  5. 在“属性”检查器的“单元格高度”文本框中输入 166，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
  6. 在第一个表格的第三行内单击一次。
  7. 在“属性”检查器的“单元格高度”文本框中输入 24，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    现在第一个表格中的三行应具有不同的高度。

    接下来，您将设置第二个表格（该表格包含三列）的属性。

  8. 在第二个表格的第一列内单击一次。

  9. 在“属性”检查器的“单元格宽度”文本框中输入 140，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
  10. 在第二个表格的第二列内单击一次。
  11. 在“属性”检查器的“单元格宽度”文本框中输入 230，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

  12. 将第三列的宽度设置为 330 个像素。

    如果已打开表格选择器（“查看”>“可视化助理”>“表格宽度”），将能看到刚才在各个表格列上输入的三个像素值。

    您无需为这个表格的单元格输入任何高度值，因为这些单元格的高度将取决于您以后添加的内容。

  13. 最后，在最后一个表格（该表格包含一行和一列）内单击一次。
  14. 在“属性”检查器的“单元格高度”文本框中输入 24，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    您的布局现在应如下所示：

  15. 单击“文档”窗口顶部的“退出扩展表格模式”链接，返回到“标准”模式。
  16. 保存页面。


插入图像占位符

图像占位符是在准备好将最终图形添加到 Web 页面之前使用的图形。在对 Web 页面进行布局时图像占位符很有用，因为通过使用图像占位符，您可以在真正创建图像之前确定图像在页面上的位置。

  1. 在文档窗口中，在第一个表格的第一行内单击一次。
  2. 选择“插入”>“图像对象”>“图像占位符”。
  3. 在“图像占位符”对话框中，执行下面的操作：
    • 在“名称”文本框中，键入 banner_graphic。
    • 在“宽度”文本框中，输入 700。
    • 在“高度”文本框中，输入 90。
    • 单击颜色框并从颜色选择器中选择一种颜色。在本教程中，我们选择了红棕色 (#993300)。
    • 保留“替换文本”文本框为空。

      关于…

      关于替换文本的说明 替换文本是 Web 页面上的图像的文字描述。它属于 HTML 代码，不会显示在页面上。对于大多数图像，提供替换文本是很重要的，这样使用屏幕阅读器或只显示文本的浏览器用户就可以访问这些图像所提供的文本信息。而对于仅显示 Web 站点徽标的横幅图形，无需提供替换文本。将“图像占位符”对话框中的“替换文本”文本框保留为空时，Dreamweaver 会在 img 标签中添加一个 alt="" 属性。以后，如果您要向某个图像添加替换文本，就可以选择该图像并在“属性”检查器中输入替换文本。例如，如果以后您想更改徽标以包括电话号码或地址，则能够以替换文本方式提供此信息。
  4. 单击“确定”。

    图像占位符出现在第一个表格内。图像占位符显示最终放置于此处的图像的标签和大小属性。

    注意

    当在浏览器中查看时，不显示图像占位符的标签文字和大小文本。
  5. 保存页面。

    关于…

    关于图像占位符 图像占位符是在将最终图形添加到 Web 页面之前使用的临时图形；它不是显示在浏览器中的图形图像。在您发布站点之前，应该用适用于 Web 的图形文件（例如 GIF 或 JPEG）替换所有添加的图像占位符。

    如果您有 Macromedia Fireworks，则可以根据 Dreamweaver 图像占位符创建新的图形。当您选择图像占位符并在“属性”检查器中单击“创建”按钮时，Fireworks 将打开并呈现一个新的画布。新图像的尺寸设置为与占位符图像相同的大小。接着，您可以随意创建并编辑图像，并替换 Dreamweaver 中的占位符图像。有关根据图像占位符在 Fireworks 中创建图像的信息，请参见《使用 Dreamweaver》中的使用 Fireworks 修改 Dreamweaver 图像占位符。


向页面添加颜色

现在，您将通过设置某些表格单元格以及页面背景的颜色，向页面添加更多颜色。

  1. 在上述包含三列的表格的第一个单元格内单击一次。
  2. 单击标签选择器中的 <td> 标签（单元格标签）以选择该单元格。

  3. 在“属性”检查器（“窗口”>“属性”）中，在“背景颜色”文本框内单击一次。

    “背景颜色”文本框位于“背景颜色”(Bg) 颜色框旁。

    注意

    如果未出现“背景颜色”文本框，请单击“属性”检查器右下角的展开箭头。
  4. 在“背景颜色”文本框中，输入十六进制值 #993300，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    表格单元格的颜色即变为红棕色。

  5. 在上述包含三列的表格的第二个单元格内单击一次。
  6. 单击标签选择器中的 <td> 标签（单元格标签）以选择该单元格。
  7. 在“属性”检查器中，在“背景颜色”文本框内单击一次，输入十六进制值 #F7EEDF，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    表格单元格的颜色即变为浅棕色。

  8. 重复第 5 － 7 步，将第三个表格单元格的颜色也更改为浅棕色。
  9. 设置完这三个单元格的颜色后，单击一次表格的外部，取消选择该表格。

接下来，您将通过修改页面属性来更改整个页面的背景颜色。通过“页面属性”对话框可以设置一些页面属性，包括页面字体的大小和颜色、已访问链接的颜色以及页面边距等。

  1. 选择“修改”>“页面属性”。
  2. 在“页面属性”对话框的“外观”类别中，单击“背景颜色”颜色框，然后从颜色选择器中选择黑色 (#000000)。

    关于…

    选择颜色 在 HTML 中，颜色或者表示成十六进制值（如 #FF0000）或者表示为颜色名称（如红色）。网页安全色是指使用 256 色模式时，无论在 Windows 还是在 Macintosh 系统中，在 Netscape Navigator 和 Microsoft Internet Explorer 中都显示相同的颜色。有 216 种常见颜色，而且任何结合了 00、33、66、99、CC 或 FF 对（RGB 值分别为 0、51、102、153、204 和 255）的十六进制值都代表网页安全色。

    在 Dreamweaver 中，可以通过在相应的文本框中输入十六进制值或从颜色选择器中选择颜色来选择颜色。颜色选择器使用 216 色 Web 安全的调色板；从此调色板选择颜色即显示颜色的十六进制值。若要使用颜色选择器，只需单击颜色框并使用滴管选择颜色。

    您还可以使用颜色选择器匹配颜色。例如，如果页面上的某一图像包含某种蓝色阴影，并且您希望表格单元格的背景颜色与之匹配，那么可以选择该表格单元格，单击颜色框打开颜色选择器，将滴管移动到图像的蓝色阴影上，并单击鼠标按钮。颜色选择器将使用与通过滴管单击的颜色最接近的匹配颜色来填充您选择的区域。如果您通过这种方法选择颜色，颜色选择器为您选择的颜色可能不是网页安全色。
  3. 单击“确定”。

    页面的背景即变为黑色。

  4. 保存您的工作。

您的页面布局现已完成。该布局包含一些表格，用于放置各种资源，如图像、文本和 Flash 视频 (FLV) 文件。在下一教程中，即教程：向页面添加内容中，您将学习如何使用 Dreamweaver 提供的各种插入功能向页面添加资源。


教程：向页面添加内容

本教程介绍如何在 Macromedia Dreamweaver 8 中向 Web 页面添加内容。您可以向 Web 页面添加多种内容，包括图形、Macromedia Flash 文件、Macromedia Flash 视频文件、文本等。向页面添加内容后，即可在浏览器中进行预览，这样可以查看页面在 Web 上会如何显示。

在本教程中，您将完成以下任务：

查找文件

复查您的任务

插入图像

插入并播放 Flash 文件

插入 Flash 视频

插入文本

创建链接

在浏览器中预览页面


查找文件

在本教程中，您将从在教程：创建基于表格的页面布局中创建的基于表格的页面布局 (index.html) 开始。如果您没有完成该教程，则在继续本教程之前，可以先完成该教程，也可以打开该教程的完成版本，并从那里开始。

该教程的完成版本 table_layout.html 位于 cafe_townsend 文件夹的 completed_files/dreamweaver 文件夹中，在教程：设置站点和项目文件中您已将 cafe_townsend 文件夹复制到了硬盘上。

注意

如果从已完成的 table_layout.html 文件开始本教程，而不使用在教程：创建基于表格的页面布局中创建的 index.html 文件，则本教程中的某些步骤和插图将与屏幕上的内容不一致。


复查您的任务

在本教程中，您将向虚构餐馆 Cafe Townsend 的主页添加资源。您将学习如何添加图像、Macromedia Flash 文件、Macromedia Flash 视频文件和文本。完成后的页面将如下所示：

您可以看到，尚未对页面上的文本进行格式设置。这是因为您将在下一教程中才学习如何使用层叠样式表 (CSS) 设置文本格式。

本教程所需的资源位于在教程：设置站点和项目文件中复制到硬盘上的 cafe_townsend 根文件夹中。如果您还没有完成该教程，则在继续之前，必须先完成该教程。在学习该教程过程中，您将确切了解如何找到资源。


插入图像

创建页面布局之后，您就可以将资源添加到页面。您将从添加图像开始。可以在 Dreamweaver 中使用多种方法向 Web 页面添加图像。本节中，您将使用不同的方法将四个不同的图像添加到 Cafe Townsend 的索引页。


替换图像占位符

  1. 在 Dreamweaver 中，打开您在教程：创建基于表格的页面布局中创建的 index.html 文件。

    注意

    如果您还没有完成教程：创建基于表格的页面布局，请参见查找文件了解如何继续。
  2. 双击页面顶部的图像占位符 banner_graphic。

  3. 在“选择图像源文件”对话框中，浏览至您定义为站点根文件夹的 cafe_townsend 文件夹中的 images 文件夹。
  4. 选择 banner_graphic.jpg 文件并单击“确定”。

    Dreamweaver 将图像占位符替换为 Cafe Townsend 的横幅图形。

  5. 在表格外单击一次以取消选中该图像。
  6. 保存该页（“文件”>“保存”）。


使用“插入”菜单插入图像

  1. 在第一个表格的第三行（低于刚插入的横幅图形两行，彩色表格单元格之上）内单击一次。

  2. 选择“插入”>“图像”。
  3. 在“选择图像源文件”对话框中，浏览至 cafe_townsend 文件夹中的 images 文件夹，选择 body_main_header.gif 文件，然后单击“确定”。

    注意

    如果出现“图像标签辅助功能属性”对话框，则单击“确定”。

    一个长的彩色图形出现在该表格行中。它看上去更像表格单元格的背景色，而不是图形，但如果仔细看，您将看到该图形具有圆角。添加完所有资源之后，这种圆角效果将使页面的下半部分呈现一种有趣的外观。


通过拖动插入图像

  1. 在页面上最后一个表格的最后一行（彩色表格单元格之下）中单击一次。
  2. 在“文件”面板（“窗口”>“文件”）中，找到 body_main_footer.gif 文件（它位于 images 文件夹中），将该文件拖到最后一个表格的插入点。

    注意

    如果出现“图像标签辅助功能属性”对话框，则单击“确定”。

  3. 在表格外单击一次，并保存该页面（“文件”>“保存”）。


从“资源”面板插入图像

  1. 在由三列组成的表格（第一个浅棕色表格单元格）的中间一列内单击一次。
  2. 在“属性”检查器（“窗口”>“属性”）中，从“水平”弹出式菜单中选择“居中对齐”，然后从“垂直”弹出式菜单中选择“顶端”。该操作将表格单元格的内容对齐到单元格的中间，并使单元格的内容从单元格顶端开始。

    注意

    如果您无法看到“垂直”或“水平”弹出式菜单，请单击“属性”检查器右下角的展开箭头。
  3. 按一次 Enter 键 (Windows) 或 Return 键 (Macintosh)，创建更多空间。

  1. 单击“文件”面板中的“资源”选项卡，或选择“窗口”>“资源”。

    则会显示您的站点资源。

  2. 如果未选择“图像”视图，则单击“图像”以查看您的图像资源。
  3. 在“资源”面板中，选择 street_sign.jpg 文件。

    关于…

    “资源”面板 可以使用“资源”面板查看和管理当前站点中的资源。“资源”面板显示与文档窗口中的活动文档相关联的站点资源。

    必须首先定义一个本地站点，然后才能在“资源”面板中查看资源。有关更多信息，请参见《使用 Dreamweaver》中的使用资源。

    “资源”面板提供两种视图：

    站点列表显示您的站点的所有资源，包括在该站点的所有文档中使用的颜色和 URL。

    收藏列表仅显示您明确选择的资源。若要将某个资源添加到“收藏”列表，请在“站点”列表中选择该资源，然后从“文件”面板右上角的“选项”菜单中选择“添加到收藏夹”。

    在“资源”面板中单击某个资源时，预览区域会显示您所选择的资源。若要更改预览区域的大小，请拖动预览区域与资源列标题之间的分隔线。

    有关更多信息，请参见《使用 Dreamweaver》中的使用资源。
  4. 执行下列操作之一：
    • 将 street_sign.jpg 文件拖到中心位置的表格单元格中的插入点。
    • 单击“资源”面板底部的“插入”。

      注意

      如果出现“图像标签辅助功能属性”对话框，则单击“确定”。

    street_sign.jpg 图形即显示在页面上。

  5. 在表格外单击一次以取消选中该图像。
  6. 保存该页。


插入并播放 Flash 文件

接下来，您将插入一个 Flash 文件，它将播放 Cafe Townsend 的特色食品的照片幻灯片。要插入的 Flash 文件是一个灵活消息区域 (FMA) 文件。FMA 是向访问者显示告知性信息的一种常见的 Flash 应用程序类型。可以根据业务需要更改告知性信息。例如，如果 Cafe Townsend 在举行一项特殊活动，则可以轻松地更改 FMA（不影响 Web 页面的其它内容）以显示该活动的信息，而不显示特色食品内容。

若要插入该 Flash FMA 文件，您需要插入 HTML 代码，将文件嵌入 Dreamweaver 页面。执行此操作的最简单方法是将 SWF 文件（导出的 Flash 影片文件）插入页面。将 SWF 文件插入 Dreamweaver 时，Dreamweaver 会替您写入所有必需的 Flash HTML 代码。

  1. 在 Dreamweaver 的“文档”窗口中打开 index.html 页面的情况下，在第一个表格的第二行内单击一次。

    即紧接上一节中插入的横幅图形的表格行。

  2. 在“属性”检查器（“窗口”>“属性”）中，从“水平”弹出式菜单中选择“居中”，然后从“垂直”弹出式菜单中选择“居中”。

    该操作将表格单元格的内容放置到单元格的中间。

    注意

    如果您无法看到“垂直”或“水平”弹出式菜单，请单击“属性”检查器右下角的展开箭头。
  3. 选择“插入”>“媒体”>“Flash”。

    在“选择文件”对话框中，浏览至站点的 cafe_townsend 根文件夹中的 flash_fma.swf 文件，选择该文件，然后单击“确定”。

    如果出现“对象标签辅助功能属性”对话框，则单击“确定”。

    Flash 内容占位符（而不是 FMA 本身的场景）将显示在文档窗口中。这是因为 HTML 代码“指向”SWF 文件 flash_fma.swf。当用户载入 index.html 页面时，浏览器会播放该 SWF 文件。

    关于…

    关于 Flash 文件 在 Macromedia Flash 中构建资源时，您是在 FLA 文件中进行操作，FLA 是 Flash 应用程序的默认文件类型。FLA 文件由 .fla 扩展名指定。例如，如果处理的是 Web 站点的动画徽标，则 Flash 文件的文件名可以是 animated_logo.fla。

    在 Flash 中完成 FLA 文件之后，您必须将该文件导出为可用 Flash Player 在 Web 上播放的格式。在 Flash 中导出 FLA 文件时，这些文件将转换为 SWF 文件并由 .swf 扩展名指定。SWF 文件（不是 FLA 文件）在 Web 浏览器中播放 Flash 内容。SWF 文件是您使用 Dreamweaver 构建 Web 页面时必须插入到页面的文件类型。

  1. 在插入 SWF 文件之后，只要您不单击页面上的其它位置，Flash 内容占位符就会保持为选中状态。

    如果它不处于选中状态，通过单击 Flash 内容占位符即可将其选中。

  2. 在“属性”检查器（“窗口”>“属性”）中单击“播放”。

    注意

    如果看不到 Flash“播放”按钮，请单击“属性”检查器右下角的展开箭头。

    Dreamweaver 在“文档”窗口中播放 Flash 文件，显示站点访问者在浏览器中查看页面时将看到的内容。

  3. 在“属性”检查器中，单击“停止”可以结束 Flash 文件播放。
  4. 保存该页。


插入 Flash 视频

接下来，使用提供的资源插入 Flash 视频文件。

  1. 在 Dreamweaver 的“文档”窗口中打开 index.html 页面的情况下，在由三列组成的表格的中间一列中放置的图形之上单击一次。

    在上一节中，您在插入图形之前创建了一些空间，这就是您应单击的位置。

  2. 选择“插入”>“媒体”>“Flash 视频”。
  3. 在“插入 Flash 视频”对话框中，从“视频类型”弹出式菜单中选择“渐进式下载视频”。

    关于…

    关于 Flash 视频 使用 Dreamweaver 中的“插入 Flash 视频”命令，可将 Flash 视频内容插入 Web 页面，而无需使用 Flash 创作工具。该命令可以插入 Flash 组件；当您在浏览器中查看它时，它显示您选择的 Flash 视频内容以及一组播放控件。

    “插入 Flash 视频”命令提供以下选项，用于将视频内容发送给站点访问者：

    累进式下载视频将 Flash 视频 (FLV) 文件下载到站点访问者的硬盘上，然后播放。但是，与传统的“下载并播放”视频传送方法不同，累进式下载允许在下载完成之前就开始播放视频文件。

    流视频将 Flash 视频内容进行流处理并立即在 Web 页面中播放。若要在 Web 页面中启用流视频，您必须具有对 Macromedia Flash Communication Server 的访问权限，这是唯一可对 Flash 视频内容进行流处理的服务器。

    有关使用 Flash 视频的更多信息，请参见《使用 Dreamweaver》中的插入 Flash 视频内容。
  4. 在 URL 文本框中，指定 cafe_townsend_home.flv 文件的相对路径，方法是单击“浏览”，浏览至 cafe_townsend_home.flv 文件（位于站点的 cafe_townsend 根文件夹中），并选择该 FLV 文件。

  5. 从“外观”弹出式菜单中选择 Halo Skin 2。

    所选外观的预览会出现在“外观”弹出式菜单下方。“外观”选项指定将包含 Flash 视频内容的 Flash 视频组件的外观。

    有关选择 Flash 视频组件不同外观的更多信息，请访问 www.macromedia.com/go/flv_tutorial。

  6. 在“宽度”和“高度”文本框中，执行以下操作：
    • 在“宽度”文本框中，键入 180。
    • 在“高度”文本框中，键入 135 ，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

      提示

      单击“检测大小”以确定 FLV 文件的准确宽度和高度。但是，有时 Dreamweaver 无法确定 FLV 文件的尺寸大小。在这种情况下，必须手动输入宽度和高度值。

    “宽度”和“高度”文本框中的值以像素为单位指定 FLV 文件的宽度和高度。可以任意调整这些值以更改 Web 页面上的 Flash 视频的大小。增加视频的尺寸时，视频的图片品质通常会下降。

    注意

    “包括外观”是 FLV 文件的宽度和高度与所选外观的宽度和高度的加和。
  7. 其余选项保留默认的选择值：

    限制高宽比保持 Flash 视频组件的宽度和高度之间的高宽比不变。默认情况下会选择此选项。

    自动播放指定在 Web 页面打开时是否播放视频。默认情况下取消选择该选项。

    自动重新播放指定播放控件在视频播放完之后是否返回起始位置。默认情况下取消选择该选项。

  8. 单击“确定”关闭对话框并将 Flash 视频内容添加到 Web 页面。

    “插入 Flash 视频”命令生成一个视频播放器 SWF 文件和一个外观 SWF 文件，它们用于在 Web 页面上显示 Flash 视频内容。（您可能需要单击“文件”面板中的“刷新”按钮来查看新的文件。）这些文件与 Flash 视频内容（在此情况下，为 cafe_townsend 根文件夹）所添加到的 HTML 文件存储在同一目录中。当您上传包含 Flash 视频内容的 HTML 页面时，Dreamweaver 将这些文件作为相关文件上传（只要单击“要上传相关文件？”对话框中的“是”）。

  9. 保存该页。


插入文本

现在您将向页面添加一些文本。您可以在 Dreamweaver 文档窗口中直接键入文本，也可以从其它源（如 Microsoft Word 或纯文本文件）复制并粘帖文本。然后，您将使用层叠样式表 (CSS) 设置文本格式。


插入正文文本

  1. 在“文件”面板中，找到 sample_text.txt 文件（在 cafe_townsend 根文件夹中）并双击该文件的图标，在 Dreamweaver 中打开它。

    您可以看到，此窗口处于“代码”视图中，并且不能切换到“设计”视图（到现在为止您一直使用的视图），因为该文件不是 HTML 文件。

  2. 在 sample_text.txt“文档”窗口中，按 Control+A 组合键 (Windows) 或 Command+A 组合键 (Macintosh) 选择所有文本，然后选择“编辑”>“复制”以复制该文本。
  3. 单击文档右上角中的 X 关闭 sample_text.txt 文件。
  4. 在 index.html“文档”窗口中，在由三列组成的表格的第三个表格单元格（包含图形和 Flash 视频的列的右侧的单元格）内单击一次。
  5. 选择“编辑”>“粘贴”。

    文本文件中的文本出现在所选表格单元格中。

    根据显示器的分辨率，该表格（由三列组成）将伸展以适合该文本。现在请不要担心它的外观。在下一教程中，您将学习如何使用 CSS 设置文本样式，以使所有内容恰当地适合表格。

  6. 确保插入点仍在刚才粘贴文本的表格单元格中。如果插入点不在，则在表格单元格内单击。
  7. 在“属性”检查器（“窗口”>“属性”）中，从“垂直”弹出式菜单中选择“顶端”。这会将您刚刚粘贴的文本沿表格单元格的顶端对齐。如果您无法看到“垂直”弹出式菜单，请单击“属性”检查器右下角的展开箭头。

  8. 保存该页。


插入导航条文本

接下来您将插入导航条文本。但是，您需要在下一教程中设置这些文本格式之后，它们看上去才会像导航条。

  1. 在由三列组成的表格的第一列（红棕色的列）中单击一次。
  2. 键入单词 Cuisine。

  3. 按空格键并键入 Chef Ipsum。
  4. 重复前面的步骤，直到输入以下单词，并且在每个单词之间留一个空格：Articles、Special Events、Location、Menu、Contact Us。

    键入时不要按 Enter 键 (Windows) 或 Return 键 (Macintosh)。只使用空格键分隔单词，并使这些单词自然换行。表格单元格的固定宽度确定了一行中可容纳的单词个数。

  5. 在插入点仍旧处于由三列组成的表格的第一个单元格中时，在标签选择器中单击 <td> 标签。

  6. 在“属性”检查器（“窗口”>“属性”）中，从“垂直”弹出式菜单中选择“顶端”。

    这会将您刚刚键入的文本沿表格单元格的顶端对齐。

    注意

    如果您无法看到“垂直”弹出式菜单，请单击“属性”检查器右下角的展开箭头。
  7. 保存页面。


创建链接

链接是在 Web 页面中插入的指向其它文档的引用。可以将任何类型的资源转换为链接，但最常用的链接类型是文本链接。

您可以在站点创建过程的任何阶段创建链接。在本节中，您将为导航条创建链接，即使您尚未将该文本格式设置为导航条的形式。

cafe_townsend 站点根文件夹包含可以链接的已完成的 HTML 页面（Cafe Townsend 的菜单页）。您将把此页面用于导航中的所有链接，即使您在建立实际站点时，这些链接中的每一个链接将对应于不同的页面。

  1. 当 index.html 页面在文档窗口中处于打开的情况下，选择您在由三列组成的表格的第一个单元格中键入的单词 Cuisine。请小心只选择单词 Cuisine，不要选中它后面的空格。

  2. 在属性检查器中（“窗口”>“属性”），单击“链接”文本框旁的文件夹图标。

  3. 在“选择文件”对话框中，浏览至 menu.html 文件（与 index.html 文件处于同一个文件夹中），并单击“确定”(Windows) 或“选择”(Macintosh)。
  4. 在页面上单击一次以取消选择单词 Cuisine。Cuisine 文本出现下划线并变成蓝色，表示它现在是一个链接。
  5. 重复上述步骤，为作为导航而键入的每个单词或一组单词建立链接。您还需要创建 6 个链接：为 Chef Ipsum、Articles、Special Events、Location、Menu 和 Contact Us 分别创建一个链接。

    将每个单词或一组单词链接到 menu.html 页面，并在创建链接时注意避免在单词或单词组前后出现空格。这仅仅是一组空白链接；在现实站点中，您会将导航中的每个单词链接到各自不同的页面。

    注意

    当在 Dreamweaver 的“文档”窗口中单击链接时，它们并不起作用；链接只在浏览器中才起作用。为确保链接正常工作，请在浏览器中预览页面。有关如何执行此操作的说明，请转到在浏览器中预览页面。
  6. 保存页面。


在浏览器中预览页面

“设计”视图为您提供了页面在 Web 上显示时的大致外观，但是要查看确切的最终结果，则必须在浏览器中预览页面。虽然浏览器通常会生成相同的结果，但是每个浏览器版本显示 HTML 页面的方式可能会不同。Dreamweaver 试图生成在各种浏览器中看起来尽可能相似的 HTML；但有时候差别难以避免。因此，在浏览器中预览您的工作是使您了解在发布页面后站点访问者将看到的外观的唯一方式。

  1. 请确保 index.html 文件在文档窗口中打开。
  2. 按 F12 键 (Windows) 或 Option+F12 组合键 (Macintosh)。

    您的主浏览器启动（如果尚未运行）并显示索引页面。

    注意

    Dreamweaver 自动检测到您的主浏览器并使用它进行预览。如果预览未显示出来，或者如果它未显示在您预期的浏览器中，请切换回 Dreamweaver（如果需要）并选择“文件”>“在浏览器中预览”>“编辑浏览器列表”。当“在浏览器中预览的“首选参数”对话框出现时，将正确的浏览器添加到列表中。有关更多信息，请单击“首选参数”对话框中的“帮助”按钮。
  3. （可选）切换回 Dreamweaver 以执行任何必要的更改。

    然后保存您的工作并再次按 F12 键以确保您的更改生效。

您现在已经有了一个内容丰富的 Web 页面。下一步是设置某些内容的格式以使其更加吸引人。在下一教程中，您将学习如何使用 CSS 为添加的文本设置格式。


教程：使用 CSS 设置页面格式

本教程介绍如何在 Dreamweaver 中使用层叠样式表 (CSS) 设置页面中的文本格式。您可以使用 CSS 以 HTML 无法提供的方式来设置文本格式和定位文本，从而能更加灵活自如地控制页面的外观。

在本教程中，您将完成以下任务：

查找文件

复查您的任务

了解 CSS

创建新的样式表

研究“CSS 样式”面板

附加样式表

创建新的 CSS 规则

将类样式应用到文本

设置导航条文本的格式

（可选）居中对齐页面内容


查找文件

在本教程中，您将首先从在教程：向页面添加内容中添加了内容的 Cafe Townsend 索引页开始。如果您还没有完成该教程，则在继续之前，可以完成该教程，也可以打开该教程的完成版本，从完成版本开始。该教程的完成版本 add_content.html 位于 cafe_townsend 文件夹的 completed_files/dreamweaver 文件夹中，在教程：设置站点和项目文件中您已将 cafe_townsend 文件夹复制到了硬盘上。

注意

如果从已完成的 add_content.html 文件开始本教程，而不使用在教程：向页面添加内容中创建的 index.html 文件，则教程中的某些步骤和插图将与屏幕上的内容不一致。


复查您的任务

在本教程中，您将使用层叠样式表 (CSS) 设置虚构餐馆 Cafe Townsend 主页上文本的格式。您将创建不同类型的 CSS 规则来设置正文文本的格式，还将设置该页左侧的链接文本的格式来创建导航条。完成后的页面类似于下面的示例：

有关 CSS 的更多信息，请继续学习下一节。若要立即开始创建 CSS，则请转到创建新的样式表。


了解 CSS

层叠样式表 (CSS) 是一系列格式设置规则，它们控制 Web 页面内容的外观。使用 CSS 设置页面格式时，内容与表现形式是相互分开的。页面内容（HTML 代码）位于自身的 HTML 文件中，而定义代码表现形式的 CSS 规则位于另一个文件（外部样式表）或 HTML 文档的另一部分（通常为 <head> 部分）中。使用 CSS 可以非常灵活并更好地控制页面的外观，从精确的布局定位到特定的字体和样式等。

CSS 使您可以控制许多仅使用 HTML 无法控制的属性。例如，您可以为所选文本指定不同的字体大小和单位（像素、磅值等）。通过使用 CSS 从而以像素为单位设置字体大小，还可以确保在多个浏览器中以更一致的方式处理页面布局和外观。

CSS 格式设置规则由两部分组成：选择器和声明。选择器是标识已设置格式元素（如 P、H1、类名称或 ID）的术语，而声明则用于定义样式元素。在下面的示例中，H1 是选择器，介于大括号 ({}) 之间的所有内容都是声明：

H1 {
font-size:16 pixels;
font-family:Helvetica;
font-weight:bold;
}

声明由两部分组成：属性（如 font-family）和值（如 Helvetica）。上述示例为 H1 标签创建了样式：链接到此样式的所有 H1 标签的文本都将是 16 像素大小并使用 Helvetica 字体和粗体。

术语“层叠”是指对同一个元素或 Web 页面应用多个样式的能力。例如，可以创建一个 CSS 规则来应用颜色，创建另一个规则来应用边距，然后将两者应用于一个页面中的同一文本。所定义的样式“层叠”到您的 Web 页面上的元素，并最终创建您想要的设计。

CSS 的主要优点是容易更新；只要对一处 CSS 规则进行更新，则使用该定义样式的所有文档的格式都会自动更新为新样式。

在 Dreamweaver 中可以定义以下规则类型：

  • 自定义 CSS 规则（也称为“类样式”）使您可以将样式属性应用到任何文本范围或文本块。所有类样式均以句点 (.) 开头。例如，您可以创建称为 .red 的类样式，设置规则的 color 属性为红色，然后将该样式应用到一部分已定义样式的段落文本中。
  • HTML 标签规则重定义特定标签（如 p 或 h1）的格式。创建或更改 h1 标签的 CSS 规则时，所有用 h1 标签设置了格式的文本都会立即更新。
  • CSS 选择器规则（高级样式）重定义特定元素组合的格式，或其它 CSS 允许的选择器形式的格式（例如，每当 h2 标题出现在表格单元格内时，就应用选择器 td h2）。高级样式还可以重定义包含特定 id 属性的标签的格式（例如，由 #myStyle 定义的样式可以应用到所有包含属性/值对 id="myStyle" 的标签）。

有关更多信息，请参见《使用 Dreamweaver》中的关于 Dreamweaver。


创建新的样式表

首先，您将创建包含 CSS 规则（定义段落文本样式）的外部样式表。在外部样式表中创建样式时，可以在一个中央位置同时控制多个 Web 页面的外观，而不需要为每个 Web 页面分别设置样式。

关于…

关于 CSS 规则的更多信息

CSS 规则可以位于以下位置：

外部 CSS 样式表是存储在一个单独的外部 .css 文件（并非 HTML 文件）中的一系列 CSS 规则。利用文档 head 部分中的链接，该 .css 文件被链接到 Web 站点中的一个或多个页面。

内部（或嵌入式）CSS 样式表是包含在 HTML 文档 head 部分的 style 标签内的一系列 CSS 规则。例如，下面的示例为已设置段落标签的文档中的所有文本定义字体大小：

<head>
<style>
   p{
   font-size:80px
   }
</style>
</head>

内联样式是在 HTML 文档中的特定标签实例中定义的。例如，<p style=“font-size: 9px”> 仅对用含有内联样式的标签设置了格式的段落定义字体大小。

Dreamweaver 会呈现您所应用的大多数样式属性并在“文档”窗口中显示它们。您也可以在浏览器窗口中预览文档以查看样式的应用情况。有些 CSS 样式属性在 Microsoft Internet Explorer、Netscape Navigator、Opera 和 Apple Safari 中呈现的外观不相同。
  1. 选择“文件”>“新建”。
  2. 在“新建文档”对话框中的“类别”列中选择“基本页”，在“基本页”列中选择“CSS”，然后单击“创建”。

    空白样式表将出现在“文档”窗口中。“设计”视图和“代码”视图按钮已被禁用。CSS 样式表是纯文本文件，其内容将不会用于在浏览器中查看。

  3. 将该页保存（“文件”>“保存”）为 cafe_townsend.css。

    保存样式表时，请确保将其保存到 cafe_townsend folder 文件夹（您的 Web 站点的根文件夹）中。

  4. 在样式表中键入以下代码：
    p{
font-family: Verdana, sans-serif;
font-size: 11px;
color: #000000;
line-height: 18px;
padding: 3px;
}

    当您键入代码时，Dreamweaver 将使用代码提示为您建议一些选项，以帮您完成输入。当看到希望 Dreamweaver 为您完成键入的代码时，请按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    不要忘记在每行结尾处的属性值后面加上一个分号。

    完成后的代码类似于下面的示例：

    提示

    有关 CSS 属性的更多信息，请参见 Dreamweaver 中包含的 O’Reilly 参考指南。若要显示该指南，请选择“帮助”>“参考”，然后从“参考”面板的弹出式菜单中选择“O’Reilly CSS 参考”。
  5. 保存样式表。

接下来，将该样式表附加到 index.html 页面中。


附加样式表

当您将样式表附加到 Web 页面中时，在样式表中定义的规则将应用到页面上的相应元素。例如，当您将 cafe_townsend.css 样式表附加到 index.html 页时，将根据您定义的 CSS 规则设置所有段落文本（用 HTML 代码中的 <p> 标签设置格式的文本）的格式。

  1. 在“文档”窗口中，打开 Cafe Townsend 的 index.html 文件。（如果该文件已打开，则请单击它的选项卡。）
  2. 选择在教程：向页面添加内容中粘贴到页面中的第一段文本。

  3. 在“属性”检查器中查看，并确保使用段落标签设置了该段落的格式。

    如果“属性”检查器中的“格式”弹出式菜单显示“段落”，则已使用段落标签设置了段落的格式。如果“属性”检查器中的“格式”弹出式菜单显示“无”或其它内容，则选择“段落”来设置段落的格式。

  4. 对第二段重复第 3 步。
  5. 在“CSS 样式”面板（“窗口”>“CSS 样式”）中，单击位于面板右下角的“附加样式表”按钮。

  6. 在“附加外部样式表”对话框中，单击“浏览”并浏览到上一节创建的 cafe_townsend.css 文件。
  7. 单击“确定”。

    “文档”窗口中的文本将根据外部样式表中的 CSS 规则来设置格式。


研究“CSS 样式”面板

“CSS 样式”面板可让您跟踪影响当前所选页面元素的 CSS 规则和属性，或影响整个文档的规则和属性，还可以在不打开外部样式表的情况下修改 CSS 属性。

  1. 请确保 index.html 页在“文档”窗口中打开。
  2. 在“CSS 样式”面板（“窗口”>“CSS 样式”）中，单击面板顶部的“所有”，然后检查您的 CSS 规则。

    在“所有”模式下，CSS 面板向您显示应用到当前文档的所有 CSS 规则，不管这些规则是在外部样式表中，还是在自身文档中。您应在“所有规则”窗格中看到两个主要类别：一个 <style> 标签类别和一个 cafe_townsend.css 类别。

  3. 若未展开 <style> 标签类别，则请单击加号 (+) 展开该类别。
  4. 单击正文规则。

    值为 #000000 的 background-color 属性出现在下面的“属性”窗格中。

    注意

    您可能需要折叠其它面板，如“文件”面板，以便看到完整的“CSS 样式”面板，还可以通过拖动窗格之间的边界来更改“CSS 样式”面板的长度。

    您在教程：创建基于表格的页面布局中通过使用“修改页面属性”对话框设置了页面的背景色。以此方式设置页面属性时，Dreamweaver 会编写一个内置于文档的 CSS 样式。

  5. 单击加号 (+) 展开 cafe_townsend.css 类别。
  6. 单击 p 规则。

    在外部样式表中为 p 规则定义的所有属性和值将显示在下面的“属性”窗格中。

  7. 在“文档”窗口中，在刚设置格式的两个段落中的任何位置单击一次。
  8. 在“CSS 样式”面板中，单击面板顶部的“当前”，然后检查您的 CSS 样式。在“当前”模式中，CSS 面板向您显示当前所选内容的属性的摘要。显示的属性与外部样式表中 p 规则的属性相对应。

在下一节中，您将使用“CSS 样式”面板创建新规则。使用“CSS 样式”面板创建新规则比手动键入规则容易得多，后者如同最初创建外部样式表时的操作一样。


创建新的 CSS 规则

在本节中，您将使用“CSS 样式”面板创建自定义的 CSS 规则或类样式。类样式使您可以设置任何范围或文本块的样式属性，并可以应用到任何 HTML 标签。有关不同类型的 CSS 规则的更多信息，请参见了解 CSS。

  1. 在“CSS 样式”面板中，单击面板右下角的“新建 CSS 规则”。

  2. 在“新建 CSS 规则”对话框中，从“选择器类型”选项中选择“类”。该选项应该是默认选中的。
  3. 在“名称”文本框中输入 .bold。

    确保在单词“bold”前键入句点 (.)。所有类样式必须以句点开头

  4. 在“定义在”弹出式菜单中，选择 cafe_townsend.css。该文件应该是默认选中的。

  5. 单击“确定”。

    出现“CSS 规则定义”对话框，表示您正在 cafe_townsend.css 文件中创建一个称为 .bold 的类样式。

  6. 在“CSS 规则定义”对话框中，执行下面的操作：
    • 在“字体”文本框中，输入 Verdana, sans-serif。
    • 在“大小”文本框中，输入 11，并在紧靠其右的弹出式菜单中选择像素。
    • 在“行高”文本框中，输入 18，并在紧靠其右的弹出式菜单中选择像素。
    • 从“粗细”弹出式菜单中选择“粗体”。
    • 在“颜色”文本框中，输入 #990000。

      这是所描述的功能的图片。.

      提示

      有关 CSS 属性的更多信息，请参见 Dreamweaver 中包含的 O’Reilly 参考指南。若要显示该指南，请选择“帮助”>“参考”，然后从“参考”面板的弹出式菜单中选择“O’Reilly CSS 参考”。
  7. 单击“确定”。
  8. 单击“CSS 样式”面板顶部的“所有”按钮。
  9. 若未展开 cafe_townsend.css 类别，则单击该类别旁边的加号 (+) 按钮。

    您可以看到，Dreamweaver 已将 .bold 类样式添加到在外部样式表中定义的规则列表中。如果您在“所有规则”窗格中单击 .bold 规则，则该规则的属性将出现在“属性”窗格中。新规则还出现在“属性”检查器的“样式”弹出式菜单中。


将类样式应用到文本

现在，您已经创建了一个类规则，并将该规则应用到某些段落文本。

  1. 在“文档”窗口中，选择第一段中文本的前四个单词：Cafe Townsend’s visionary chef。
  2. 在“属性”检查器（“窗口”>“属性”）中，从“样式”弹出式菜单中选择“bold”。

    “粗体”类样式将应用到您的文本。

  3. 重复第 2 步，将“粗体”类样式应用到第二段的前四个单词。

  4. 保存页面。


设置导航条文本的格式

接下来，您将使用 CSS 将样式应用到导航条的链接文本。许多 Web 页面使用内含文本的彩色矩形图像来创建导航条。但是，如果使用 CSS，您所需要设置的只是链接文本和一些格式。通过使用 display: block 属性并设置块的宽度，您可以有效地创建矩形，而不需要另外使用图像。


为导航创建新规则

  1. 若未打开 cafe_townsend.css 文件，则打开该文件，或单击其选项卡来显示该文件。
  2. 定义一个新规则，方法是在该文件的 .bold 类样式后面键入以下代码：
    .navigation {
}

    这是一个空规则。

    文件中的代码应类似于下面的示例：

  3. 保存 cafe_townsend.css 文件。

    接下来，您将使用“CSS 样式”面板向规则添加属性。

  4. 若未打开 index.html 文件，则打开该文件。
  5. 在“CSS 样式”面板中，确保选中了“全部”模式，选择新的 .navigation 规则，然后单击面板右下角的“编辑样式”。

  6. 在“CSS 规则定义”对话框中，执行下面的操作：
    • 在“字体”文本框中，输入 Verdana, sans-serif。
    • 从“大小”弹出式菜单中选择 16，然后从紧靠其右的弹出式菜单中选择像素。
    • 从“样式”弹出式菜单中选择“正常”。
    • 从“修饰”列表中选择“无”。
    • 从“粗细”弹出式菜单中选择“粗体”。
    • 在“颜色”文本框中，输入 #FFFFFF。

      提示

      有关 CSS 属性的更多信息，请参见 Dreamweaver 中包含的 O’Reilly 参考指南。若要显示该指南，请选择“帮助”>“参考”，然后从“参考”面板的弹出式菜单中选择“O’Reilly CSS 参考”。
  7. 单击“确定”。

    现在，您将使用“CSS 样式”面板向 .navigation 规则添加更多属性。

  8. 在“CSS 样式”面板中，确保选中了 .navigation 规则，然后单击“显示列表视图”。

    列表视图可使“属性”窗格按字母顺序显示所有可用属性（与“设置属性”视图不同，“设置属性”视图只显示已设置的属性）。

  9. 单击 background-color 属性右边的列。

    若要查看属性的完整内容，请将鼠标指针停留在该属性上。

  10. 输入十六进制值 #993300，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    提示

    若要查看您的工作对外部样式表的影响，请在您工作时保持 cafe_townsend.css 文件在“文档”窗口中处于打开状态。当您在“CSS 样式”面板中做出选择时，同时将看到 Dreamweaver 在样式表中写入 CSS 代码。
  11. 找到 display 属性（可能需要向下滚动），在右边的列中单击一次，然后从弹出式菜单中选择 block。

  12. 找到 padding 属性，在右边的列中单击一次，输入值 8px，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
  13. 找到 width 属性，在右边的列中单击一次，在第一个文本框中输入 140，从弹出式菜单中选择像素，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
  14. 单击“显示设置属性”，以便在“属性”窗格中仅显示您设置的属性。

  15. 单击 cafe_townsend.css 文件以显示该文件。您将看到，Dreamweaver 已经将您指定的所有属性添加到该文件中。
  16. 保存并关闭 cafe_townsend.css 文件。

现在，您已经创建了一个设置导航条文本格式的规则。接下来，您要将该规则应用到所选链接。


应用规则

  1. 在“文档”窗口中打开 index.html 页，单击单词 Cuisine 将插入点置于该单词中的某个位置。

  2. 在标签选择器中，单击最右边的 <a> 标签。

    此操作将为指定的 <a> 标签或链接选择所有文本。

  3. 在“属性”检查器（“窗口”>“属性”）中，从“样式”弹出式菜单中选择“navigation”。

    在“文档”窗口中，Cuisine 文本的外观完全发生了变化。根据您在上一节中为 .navigation 规则所定义的属性，该文本的格式现在已被设置为导航条按钮。

  4. 对于导航条中的每个链接，重复第 1 步到第 3 步。

    您必须为每个 <a> 标签或链接分配一个导航类样式，因此，使用标签选择器分别选择每个链接，然后逐个为每一个链接分配类样式是很重要的。

    在设置链接文本的格式时如果有困难，请确保每个（或每组）链接的单词之间有空格（不是回车）。还要确保两个链接之间的空格本身未被链接。如果空格已链接，请小心选择链接的空格，在“属性”检查器中清除“链接”文本框，并按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

  5. 完成对导航条的所有单词的格式设置后，保存该页面，然后在浏览器中预览您的工作（“文件”>“在浏览器中预览”）。

    您可以单击链接以确保其有效。


添加鼠标经过效果

现在，您将添加一个鼠标经过效果，使导航条块的背景色在每次鼠标指针经过某个链接时改变颜色。若要添加鼠标经过效果，请添加包含 :hover 伪类的新规则。

关于…

关于 :hover 伪类 伪类是一种影响 HTML 文档中的某些元素的方式，它不是基于文档本身的 HTML 代码，而是基于 Web 浏览器应用的其它外部条件。伪类可以是动态的，这表明当用户与文档交互时，页面上的元素可能会获取或丢失伪类。

当用户把鼠标指针停留在已设置格式的页面元素上时，:hover 伪类会影响该元素的变化。例如，将 :hover 伪类添加到 .navigation 类样式 (.navigation:hover) 以创建新规则时，根据 .navigation:hover 规则的属性，所有用 .navigation 规则设置格式的文本元素都会发生变化。
  1. 打开 cafe_townsend.css 文件。
  2. 选择整个 .navigation 规则。

  3. 复制文本（“编辑”>“复制”）。
  4. 在该规则的末尾单击一下，然后多按几次 Enter 键 (Windows) 或 Return 键 (Macintosh) 以创建一些空格。

  5. 将已复制的文本粘贴（“编辑”>“粘贴”）到刚创建的空格中。
  6. 将 :hover 伪类添加到已粘贴的 .navigation 选择器中，如下所示：

  7. 在新的 .navigation:hover 规则中，将当前的背景色 (#993300) 替换为 #D03D03。

  8. 保存并关闭该文件。
  9. 在“文档”窗口中打开 index.html 文件，然后在浏览器中预览该页面（“文件”>“在浏览器中预览”）。

    当您将鼠标指针停留在任何一个链接上时，可以看到新的鼠标经过效果。


（可选）居中对齐页面内容

最后，您将使用标签选择器选择文档中的所有 HTML，然后居中对齐文档内容。

注意

当您使用本节中描述的方法时，有些浏览器（如 Internet Explorer 6）会居中对齐表格单元格上下文中的页面文本。如果您不喜欢在浏览器中预览页面时看到此效果，可以跳过本节，并保留页面内容左对齐。
  1. 在“文档”窗口中打开 index.html 页面时，单击标签选择器中的 <body> 标签。

    在“文档”窗口中，单击 <body> 标签选择打开和关闭 <body> 标签之间的所有内容。若要查看选择，则单击“文档”窗口顶部的“代码”视图。

  2. 在“属性”检查器中（“窗口”>“属性”），单击“居中对齐”按钮。

    Dreamweaver 将插入用于居中对齐页面正文内容的 CSS <div> 标签。在“设计”视图中，<div> 标签居中对齐的区域周围有虚线边框。

  3. 保存该页。

您的页面现已完成。构建 Web 页面的最后一项任务是发布页面。要发布页面，必须在远程站点定义一个文件夹，然后将您的文件上传到该文件夹。有关说明，请继续学习下一教程。


教程：发布站点

本教程说明如何使用 Macromedia Dreamweaver 8 设置远程站点，以及如何发布 Web 页。远程站点通常是运行 Web 服务器的远程计算机上保存本地文件副本的位置。用户在浏览器中查看您的页时，就是在访问在 Web 服务器上运行的远程站点。

在本教程中，您将完成以下任务：

了解远程站点

定义远程文件夹

上传本地文件

解决远程文件夹设置问题（可选）


了解远程站点

创建了 Web 站点后，下一步就是通过将文件上传到远程文件夹来发布该站点。远程文件夹是存储文件的位置，这些文件用于测试、生产、协作和发布，具体取决于您的环境。Dreamweaver 将此文件夹称为远程站点。

在继续之前，您必须能够访问远程 Web 服务器（例如您的 ISP 的服务器、您的客户所拥有的服务器、公司中的 Intranet 服务器，或者 Windows 计算机上的 Internet 信息服务 (IIS) 服务器）。如果您尚不具有对这样一个服务器的访问权，请与您的 ISP、客户或系统管理员联系。

您也可以在本地计算机上运行一个 Web 服务器，如 IIS (Windows) 或 Apache (Macintosh)。有关在本地计算机上设置 Web 服务器的更多信息，请参见安装 Web 服务器。

如果远程根文件夹为空，则本教程中所描述的过程效果最佳。如果您的远程站点已经包含文件，则在远程站点（在服务器上）中创建一个空文件夹，然后将该空文件夹用作您的远程根文件夹。

继续操作之前，您还需要定义一个本地站点。有关更多信息，请参见教程：设置站点和项目文件。

有关 Dreamweaver 站点的更多信息，请参见《使用 Dreamweaver》中的设置 Dreamweaver 站点。


定义远程文件夹

现在，您需要设置一个远程文件夹，以便发布您的 Web 页。远程文件夹通常具有与本地文件夹相同的名称，因为远程站点通常完全就是本地站点的副本。也就是说，您发布到远程文件夹的文件和子文件夹是本地创建的文件和子文件夹的副本。

  1. 在您的远程服务器上，在服务器的 Web 根文件夹中创建一个空文件夹。

    将新的空文件夹命名为 cafe_townsend（与本地根文件夹的名称相同）。

    关于…

    使用 Dreamweaver 创建一个远程文件夹 如果 Dreamweaver 是您访问远程服务器的唯一方式，则在完成 Dreamweaver 中的远程设置并建立连接之前，您无法在远程服务器上创建一个空的文件夹。如果情况是这样，您可以将主机目录定义为远程文件夹，或者在建立与服务器的连接后创建一个远程文件夹。无论在何种情况下，在连接到远程服务器之前，都要按照本教程中的说明继续操作。建立连接之后，您可以使用 Dreamweaver 的“文件”面板创建一个新的远程文件夹。

    建立与远程服务器的连接后，“文件”面板在“远程”视图中显示远程服务器上的所有文件（就像它在“本地”视图中显示计算机上的所有本地文件一样）。要显示“远程”视图，请从“文件”面板顶部的弹出式菜单中选择“远程”视图，或者单击“文件”面板工具栏中的“扩展/折叠”。单击“扩展/折叠”后，“文件”面板同时显示“本地”视图和“远程”视图。

    要在“远程”视图中添加一个空的文件夹，请首先使用前面描述的方法之一显示“远程”视图。（如果您最初没有看到连接，请单击“文件”面板工具栏中的“刷新”。）看到您已经连接到 Web 服务器之后，在“远程”视图中右键单击“(Windows)”或按住 Control 键并单击“(Macintosh)”，然后选择“新建文件夹”。

    有关更多信息，请参见《使用 Dreamweaver》中的管理您的文件。
  2. 在 Dreamweaver 中，选择“站点”>“管理站点”。
  3. 在“管理站点”对话框中，选择“Cafe Townsend 站点”。

    如果您没有定义 Cafe Townsend 站点，请在继续之前为该站点创建一个本地文件夹。有关更多信息，请参见教程：设置站点和项目文件。

  4. 单击“编辑”。
  5. 在“站点定义”对话框中，如果未显示“高级”设置，请单击“高级”选项卡。
  6. 从左侧的“类别”列表中选择“远程信息”。
  7. 选择一个“访问”选项。

    连接到 Internet 上的服务器的最常见方法是“FTP”和“SFTP”；连接您的 Intranet 上的服务器的最常见方法，或者如果您使用本地计算机作为 Web 服务器，连接到本地计算机的最常见方法是“本地/网络”。如果您不确定选择哪种方法，请询问服务器的系统管理员。

    有关更多信息，请单击对话框上的“帮助”按钮。

  8. 如果您选择“FTP”，请输入以下选项：
    • 输入服务器的主机名（例如 ftp.macromedia.com）。
    • 在“主机目录”文本框中，输入从 FTP 根文件夹到远程站点的根文件夹 (cafe_townsend) 的服务器路径。如果您不确定该路径，请咨询您的系统管理员。

      在许多情况下，此文本框应该留空。

    • 在相应的文本框中输入用户名和密码。
    • 如果您的服务器支持 SFTP，选择“使用安全 FTP (SFTP)”选项。
    • 单击“测试”测试连接。
    • 如果连接不成功，请咨询您的系统管理员。

    有关更多信息，请单击对话框上的“帮助”按钮。

  9. 如果您选择“本地/网络”，请单击文本框旁边的文件夹图标，然后浏览到远程站点的根文件夹。

    有关更多信息，请单击对话框上的“帮助”按钮。

  10. 单击“确定”。

    Dreamweaver 创建到远程文件夹的连接。

  11. 单击“完成”关闭“管理站点”对话框。


上传本地文件

在设置了本地文件夹和远程文件夹之后，可以将文件从本地文件夹上传到 Web 服务器。要使公众可以访问您的网页，必须将它们上传到 Web 服务器，即使 Web 服务器运行在您的本地计算机上也必须进行上传。

  1. 在“文件”面板（“窗口”>“文件”）中，选择站点的本地根文件夹 (cafe_townsend)。
  2. 单击“文件”面板工具栏上的“上传文件”蓝色箭头图标。

    . 这是所描述的功能的图片。

  3. 当 Dreamweaver 询问您是否要上传整个站点时，单击“确定”。

    Dreamweaver 将所有文件复制到您在定义远程文件夹中定义的远程文件夹。此操作可能需要一些时间，因为 Dreamweaver 必须上传本站点中的所有文件。

  4. 在浏览器中打开您的远程站点以确保正确上传了所有文件。


解决远程文件夹设置问题（可选）

可以通过多种方式来配置 Web 服务器。下面的列表提供有关设置远程文件夹时可能遇到的一些常见问题以及如何解决它们的信息：

  • Dreamweaver FTP 实现方案可能不适用于某些代理服务器、多级防火墙和其它形式的间接服务器访问。

    如果遇到 FTP 访问方面的问题，请询问本地系统管理员。

  • 对于 Dreamweaver FTP 实现，必须连接到远程系统的根文件夹。（在许多应用程序中，可以连接到任何远程目录，然后在远程文件系统中查找所需的目录。）

    确保将远程系统的根文件夹指定为主机目录。

    如果存在连接问题，并且使用了一个单斜杠 (/) 指定主机目录，则可能需要指定从所连接目录到远程根文件夹的相对路径。

    例如，如果远程根文件夹是一个更高级别的目录，则需要使用 ../../ 指定主机目录。

  • 包含空格和特殊字符的文件名和文件夹名在传输到远程站点时经常引起问题。

    请使用下划线替换空格，并尽可能避免在文件名和文件夹名中使用特殊字符。具体说来，文件名或文件夹名中的冒号 (:)、斜杠 (/)、句点 (.) 和撇号 (‘) 会引起问题。文件名或文件夹名中的特殊字符有时还可能妨碍 Dreamweaver 创建站点地图。

  • 如果遇到长文件名问题，请用较短的名称重命名。在 Macintosh 中，文件名长度不能超过 31 个字符。
  • 许多服务器使用符号链接 (UNIX)、快捷方式 (Windows) 或别名 (Macintosh) 将服务器磁盘某部分中的一个文件夹和其它地方的另一个文件夹连接起来。

    例如，服务器上主目录的 public_html 子目录实际上可能是到服务器另一部分的链接。在大多数情况下，这样的别名对您连接到适当的文件夹或目录的能力没有影响，但如果您可以连接到服务器的一部分而不能连接到另一部分，则可能存在别名差异。

  • 如果遇到如“无法上传文件”这样的错误信息，说明远程文件夹的空间可能不足。有关更多详细信息，请查看 FTP 记录。

    注意

    总的来说，当遇到 FTP 传输方面的问题时，请检查 FTP 记录，方法是选择“站点”>“高级”>“FTP 记录”。


教程：使用代码

当您向 Web 页面中添加文本、图像和其它内容时，Dreamweaver 8 将生成 HTML 代码。本教程介绍如何使用“代码”视图显示文档的基础代码，以及如何手动添加和编辑代码。

如果您已经设置了站点并完成了前面的教程，则可以继续使用同一 index.html 文件。

如果您已经完成了前面的教程，则仍可以完成本教程。首先，按照教程：设置站点和项目文件中的说明设置站点。然后，使用 cafe_townsend/completed_files/dreamweaver 文件夹中的 index_code.html 文件完成本教程。index_code.html 是教程：使用 CSS 设置页面格式中已完成的 index.html 文件的重复副本。

注意

如果使用已完成的 index_code.html 文件开始本教程，而不使用在教程：使用 CSS 设置页面格式中创建的 index.html 文件，则教程中的某些步骤和插图将与屏幕上的内容不一致。

在本教程中，您将完成以下任务：

查看代码

切换到编码工作区（仅限 Windows）

使用标签选择器添加标签

编辑标签

查找与标签有关的信息

使用代码提示添加图像

检查您的更改

打印您的代码


查看代码

Dreamweaver 允许您以下面两种方式中的任意一种查看页面：“设计”视图（在“设计”视图中文档看起来与它在浏览器中的外观非常相似）或“代码”视图（您可以在“代码”视图中看到基础 HTML 代码）。您还可以使用同时显示“代码”视图和“设计”视图的拆分视图。

  1. 请确保 index.html 文件在文档窗口中打开。

    注意

    如果您未通过完成前面的教程来完成 index.html 文件，请参见本教程中的介绍以了解如何继续操作。
  2. 在“文档”工具栏中，单击“显示代码视图和设计视图”按钮（它标记为“拆分”）。

    注意

    如果未显示“文档”工具栏，请选择“视图”>“工具栏”>“文档”。

    该窗口会拆分，同时显示“设计”视图和基础 HTML 代码。

    您可以在“代码”视图中编辑代码。除非单击“文档”工具栏中的“刷新”，或在“设计”视图中的任意位置单击，否则对代码所做的更改不会在“设计”视图中显示。

  3. （可选）若要仅显示“设计”视图，请单击“设计”视图。
  4. （可选）若要仅显示“代码”视图，请单击“代码”视图。

当您处理自己的页面时，可以使用任何一个最适合的视图。本指南中的大部分教程都假定您使用的是“设计”视图。


切换到编码工作区（仅限 Windows）

如果您在安装期间未执行此操作，则现在可以（可选）使 Windows 工作区在外观上更类似于 Macromedia HomeSite 和 ColdFusion Studio 的流行编码环境。

注意

Macintosh 用户不能更改工作区。

若要切换到编码工作区，请执行下面的操作：

  • 选择“窗口”>“工作区布局”>“编码器”。


使用标签选择器添加标签

接下来，使用标签选择器在页面上某个图像的两侧添加 div 标签。然后，可以根据需要为图像设置边距、边框或颜色。有多种方法可以在图像的两侧添加 div 标签；本节介绍如何使用标签选择器来添加标签。标签选择器可以帮助您插入任何标签，并添加相应的属性值。

  1. 如果尚未打开 index.html 文件，则打开它。
  2. 在“设计”视图中，单击 Cafe Townsend 横幅图形 (banner_graphic.jpg) 以选中它。

  3. 通过单击“文档”工具栏中的“代码”视图或通过选择“查看”>“代码视图”切换到“代码”视图。

    您将看到，选定图像的代码在“代码”视图中处于选中状态。确保选定了整个 img 标签，包括左尖括号和右尖括号。

  4. 如果未启用自动换行，则选择“查看”>“代码视图选项”>“自动换行”启用自动换行。
  5. 右键单击 (Windows) 或在按住 Control 键的同时单击 (Macintosh) 选定的文本，然后从弹出式菜单中选择“插入标签”。

    即会显示标签选择器。

  6. 在标签选择器中，展开“HTML 标签”类别，然后展开“格式和布局”子类别，然后选择“常规”。

    右窗格中将出现一个标签名列表；从该列表中选择 div。

    注意

    您也可以选择“HTML 标签”类别，然后在右窗格中选择 div 标签，而无需先展开“格式和布局”。
  7. 单击“插入”。

    将出现一个标签编辑器，用于编辑 div 标签。

  8. 在标签编辑器中，选择“样式表/辅助功能”类别，然后在“ID”文本框中输入 banner。

  9. 单击“确定”关闭该标签编辑器并插入标签。

    Dreamweaver 将在页中图像标签的两侧插入 div 标签。

  10. 单击“关闭”以关闭标签选择器。
  11. 保存页面。


编辑标签

接下来，将使用标签检查器对标签的属性快速进行更改。标签检查器显示“文档”窗口中选定的标签的属性。

  1. 如果 index.html 页面尚未打开，则在“代码”视图中打开它。
  2. 如果标签检查器尚未打开，则通过选择“窗口”>“标签检查器”打开它。
  3. 选择“属性”选项卡。
  4. 单击标签检查器中的“显示列表视图”，按字母顺序查看所有选定标签的属性。

  5. 在“文档”窗口的“代码”视图中，单击任何标签的左尖括号和右尖括号之间的任何位置。

    标签检查器的“属性”选项卡显示有关标签的 HTML 属性的信息。

  6. 在“代码”视图中，找到并单击页面顶部 banner_graphic.jpg 图像的 img 标签。

    标签检查器的“属性”选项卡将显示有关该 img 标签的属性的信息。

  7. 在标签检查器中，单击 alt 属性旁边的空文本框，键入 Cafe Townsend，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    Dreamweaver 将显示标签检查器中的新值，并更改“文档”窗口中的代码。

  8. 保存页面。


查找与标签有关的信息

如果您需要与标签属性和属性值有关的帮助，可以在 Dreamweaver 中查找参考信息。

  1. 如果 index.html 页面尚未打开，则在“代码”视图中打开它。
  2. 在“文档”窗口中，选定 img 标签中 alt 属性名（而不是属性值）。
  3. 右键单击 (Windows) 或在按住 Control 键的同时单击 (Macintosh) 选定的文本，然后从弹出式菜单中选择“参考”。

    随即出现“参考”面板，并显示与 alt 属性有关的信息。

    注意

    您还可以通过选择“窗口”>“参考”来显示“参考”面板。
  4. 有关其它标签或属性的信息，请从“参考”面板相应的弹出式菜单中选择标签或属性。


使用代码提示添加图像

要手动将代码添加到页面中，请在“代码”视图中单击，然后开始键入。您可以使用代码提示功能来提高编写代码的速度。

本节中，您将使用代码提示将路标图像添加到 Cafe Townsend 索引页面中。

  1. 如果 index.html 页面尚未打开，则打开它。
  2. 在“设计”视图中，选择 street_sign.jpg 图像（它位于 Flash 视频占位符的下方）并按 Delete 键。

    现在，您将使用代码提示重新插入该图像，而不是像在教程：向页面添加内容中那样从“资源”面板中拖动它。

  3. 通过单击“文档”工具栏中的“代码”视图或通过选择“查看”>“代码视图”切换到“代码”视图。

    在“代码”视图中，插入点应位于开始段落标签和结束段落标签之间，如下所示：

    如果在封闭表单元格 </td> 标签之前未看到开始段落标签和结束段落标签，则按如下所示键入它们：

    将插入点放置在开始 <p> 标签和结束 <p> 标签之间。

  4. 删除可能位于开始 <p> 标签和结束 <p> 标签之间的所有内容，例如，不中断空格 (&nbsp;)。
  5. 将插入点放置在开始<p> 标签和结束 <p> 标签之间后，键入一个左尖括号 (<)。

    在插入点处出现标签列表。

    注意

    您可以通过选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)，然后从左侧的分类列表中选择“代码提示”，来设置该列表出现前的延迟时间长度。在“代码”视图中，您可以通过按下 Control+空格键随时显示代码提示菜单，通过按下 Esc 键可以随时关闭代码提示菜单。
  6. 从列表中选择 img 标签，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh) 插入该标签的第一个部分。

    提示

    若要快速滚动到某个标签，可以开始键入该标签名。
  7. 按空格键可以显示该标签的属性列表。
  8. 开始键入 src，在提示菜单中选定 src 属性，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    在您刚键入的代码下随即出现浏览 一词，并且处于选定状态。

  9. 按 Enter 键 (Windows) 或 Return 键 (Macintosh) 浏览至一个文件。
  10. 在“选择文件”对话框中，定位到 street_sign.jpg 文件（它位于 cafe_townsend 根文件夹的 images 文件夹中），然后单击“确定”(Windows) 或“选择”(Macintosh)。

    该图像的 URL 会作为 src 属性的值插入，插入点出现在右引号之后。

  11. 按空格键，从提示菜单中选择 alt 属性，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
  12. 不要在引号中填写内容，因为此图像只是一个插图。

    使用右箭头键将插入点移动到引号的右侧。

  13. 键入一个右尖括号 (>) 完成该标签。

  14. 保存页面。

    提示

    要将属性添加到现有标签中，请将插入点放置在标签的最终属性值之后并按空格键。显示属性列表时，添加一个属性并指定一个值（如果存在）。


检查您的更改

在对您的代码进行任何更改后，您可以立即获得可视化的反馈。

若要看到您的代码的可视化表示形式，请执行以下两个操作之一：

  • 单击文档工具栏中的“设计”视图或“代码”和“设计”视图（标记为“拆分”）。
  • 按 F12 (Windows) 键或 Option+F12 (Macintosh) 键在 Web 浏览器中预览该页面。若要关闭浏览器并返回到您的代码，请按 Alt+F4 组合键（仅限 Windows）。


打印您的代码

可以打印代码以用于脱机编辑、存档或分发。

若要打印代码，请执行以下操作：

  1. 在“代码”视图中查看一页。
  2. 选择“文件”>“打印代码”。
  3. 指定打印选项，然后单击“确定”(Windows) 或“打印”(Macintosh)。


教程：创建基于 CSS 的页面布局

在教程：创建基于表格的页面布局中，您学习了如何使用 Dreamweaver 的表格设计功能来创建页面布局。在本教程中，您将学习如何使用层叠样式表 (CSS) 创建一个类似的布局。许多设计者首选基于 CSS 的布局，这是因为使用 CSS 可以在定位元素方面进行更好地控制，减少所需的代码数量，并可以使用边距、边框、颜色等设置布局块格式。

如果您尚未定义 Dreamweaver 站点和创建 cafe_townsend 本地根文件夹，则在继续之前必须执行此操作。有关说明，请参见教程：设置站点和项目文件。

在本教程中您将完成以下任务：

了解基于 CSS 的页面布局

检查设计草样

创建并保存新页面

插入层

向页面添加颜色


了解基于 CSS 的页面布局

许多 Web 站点都使用基于表格的布局显示其页面上的信息。表格对于显示表格数据（如重复元素的行和列）很有用，并且很容易在页面上创建。但表格往往还会生成大量难于阅读和维护的代码。此外，由于所需的标签数量很大，并且可能需要进行“嵌套”，因此表格可能会给使用屏幕读取器查看 Web 页的残障人士带来不便。

基于 CSS 的布局（即，使用块元素代替表格行和列的布局）所包含的代码数量要比具有相同特性的基于表格的布局中的代码数量少很多。基于 CSS 的布局通常使用 <div> 标签，而不是 <table> 标签来创建用于布局的 CSS 布局块。可以将这些 CSS 布局块放置在页面上的任意位置，并为它们指定属性，如边框、边距、背景颜色等。此外，由于代码更为简单和短小，因此使用屏幕读取器查看 Web 页的用户可以更容易地浏览使用 CSS 构建的页面。

使用 Dreamweaver 可以创建层。Dreamweaver 层是一个 HTML 页面元素，您可以将它放置在页面上的任意位置。更具体地说，它是一个包含绝对位置的 <div> 标签（或其它任何标签）。可以使用 Dreamweaver 将层拖动到页面上，然后将其放置在所需的位置。层充当保存资源（如图像、Flash 文件、文本等）的内容块。

Dreamweaver 层是绝对定位元素。也就是说，它们包含一个相对于页面的上边距和左边距设置的特定位置。不能使用层创建基于 CSS 的布局，然后将页面内容居中显示。因此，本教程中的布局与您在教程：创建基于表格的页面布局中创建的布局略有不同。

有关 Dreamweaver 层的更多信息，请参见《使用 Dreamweaver》中的使用 CSS 对页进行布局。


检查设计草样

注意

如果您已经完成了教程：创建基于表格的页面布局并检查了设计草样，则可以继续学习下一节以立即开始创建基于 CSS 的布局。

通常，创建 Web 站点并不是以打开 Dreamweaver 并立即对页面进行布局开始的。创建 Web 站点的初始工作从纸张或图形编辑应用程序（如 Macromedia Fireworks）开始。图形设计人员通常会画出 Web 站点综合图形的草图（也称为“草样”），以便向客户展示并确保站点的初始构思能让客户满意。

设计草样由客户要求其 Web 站点具有的任意数目的页面元素组成。例如，客户可能会提出：“页面顶端要有徽标，要有能链接到其它页面的导航功能，有用于联机存储的部分和可以插入视频剪辑的位置。”根据这些讨论，设计人员开始对站点布局进行规划，并制作满足客户要求的示例页面草图。

本教程向您提供了为 Cafe Townsend（一个需要制作 Web 站点的虚构餐馆）设计的、完整的和符合要求的设计草样。作为 Web 设计人员，您需要对草样进行转换，使之最终形成可以使用的 Web 页面（通常需要其他图形设计人员与 Flash 开发人员的帮助）。

您可以看到，图形设计人员已经向您提供了 Web 页面设计草样，其中包括一些内容区域和图形方案。在下面的部分，您将使用 Dreamweaver 展示此设计。

您也可以打开原始草样文件以便在计算机屏幕上查看该设计草样。可以在 cafe_townsend 文件夹（在教程：设置站点和项目文件中已将该文件夹复制到了硬盘上）的 fireworks_assets 文件夹中找到设计草样 homepage-mockup.jpg。在创建页面时，还可以打印草样以便随时查看。


创建并保存新页面

建立站点并检查设计草样后，您就可以开始创建 Web 页面了。首先您将创建一个新页面，并将它保存到您的 Web 站点的本地根文件夹 cafe_townsend 中。该页面最终将成为虚构餐馆 Cafe Townsend 的主页。

如果您尚未创建 cafe_townsend 本地根文件夹，则在继续之前必须执行此操作。有关说明，请参见教程：设置站点和项目文件。

  1. 在 Dreamweaver 中，选择“文件”>“新建”。
  2. 在“新建文档”对话框的“常规”选项卡上，从“类别”列表中选择“基本页”，从“基本页”列表中选择“HTML”，然后单击“创建”。
  3. 选择“文件”>“另存为”。
  4. 在“另存为”对话框中，浏览至定义为站点的本地根文件夹的 cafe_townsend 文件夹并打开该文件夹。

    在教程：设置站点和项目文件中，已在名为 local_sites 的文件夹中创建了此文件夹。

  5. 在“文件名”文本框中输入 index_css.html ，然后单击“保存”。

    文件名随即显示在应用程序窗口顶部标题栏的括号中。

  6. 在新文档顶部的“文档标题”文本框中，键入 Cafe Townsend。

    这就是页面的标题（与文件名不同）。站点访问者在 Web 浏览器中查看页面时将在浏览器窗口标题栏中看到此标题。

  7. 选择“文件”>“保存”保存该页面。


插入层

接下来，向页面中添加层。层是一个绝对定位元素，可以用它来保存图像、文本、Flash 文件和其它内容。有关层的更多信息，请参见了解基于 CSS 的页面布局。


绘制一个新层

  1. 在“文档”窗口中打开 index_css.html 页面后，从“插入”栏中选择“布局”模式。

  2. 单击“绘制层”。

    将鼠标指针移动到页面上时，它将变为交叉线。

  3. 将任意大小的层拖动到页面上，然后释放鼠标按钮。
  4. 单击该层左上角的选择柄，确保选中它。
  5. 选中新层后，在“属性”检查器（“窗口”>“属性”）中执行以下操作：
    • 单击“层编号”文本框，然后将该层重命名为 banner_graphic。
    • 在“宽 (W)”文本框中，输入 700px。
    • 在“高 (H)”文本框中，输入 90px。
    • 在“左 (L)”文本框中，输入 20px。
    • 在“上 (T)”文本框中，输入 20px。
    • 按 Enter 键 (Windows) 或 Return 键 (Macintosh) 应用最后一项。

    Dreamweaver 设置 banner_graphic 新层的大小并对其进行定位。banner_graphic 层的宽度为 700 像素，高度为 90 像素。同时，该层的左边距为 20 像素，上边距为 20 像素。

    提示

    前面您使用了“属性”检查器中的精确像素值对 banner_graphic 层进行定位，您还可以通过拖动选定层左上角的选择柄将层放置在页面上的任意位置。
  6. 打开“层”面板（“窗口”>“层”）。将看到 Dreamweaver 已将新层 (banner_graphic) 添加到了层列表中。
  7. 在新层外部单击一下，取消对其的选择。
  8. 保存页面。


添加更多层

现在，将向页面添加更多层。第一层 (banner_graphic) 将用作定位其它层的参考点。您还将使用“CSS 层背景”功能帮您定位和区分层。

  1. 在“插入”栏的“布局”类别中，单击“绘制层”，然后将另一个任意大小的层拖动到页面上。

  2. 单击新层的选择柄以选中它。
  3. 选中新层后，在“属性”检查器中执行以下操作：
    • 单击“层编号”文本框，然后将该层重命名为 flash_fma。
    • 在“宽 (W)”文本框中，输入 700px。
    • 在“高 (H)”文本框中，输入 166px。
    • 在“左 (L)”文本框中，输入 20px。
    • 在“上 (T)”文本框中，输入 111px。
    • 按 Enter 键 (Windows) 或 Return 键 (Macintosh) 应用最后一项。

    Dreamweaver 设置 flash_fma 新层的大小并对其进行定位。

    这是所描述的功能的图片。.

    flash_fma 层的宽度为 700 像素，高度为 166 像素。同时，该层的左边距为 20 像素，上边距为 111 像素。将该层放置在距页面顶部 111 像素的位置，这样它便不会与 banner_graphic 层重叠。

    当层重叠时，您会注意到，某个层（具体而言，是指下面的图层）的边框为虚线。

  4. 在新层外部单击一下，取消对其的选择。
  5. 选择“查看”>“可视化助理”>“CSS 布局背景”。

    Dreamweaver 向层中添加背景颜色。这些颜色是随机选择的，并且不显示在已发布的 Web 页面上。它们只是 Dreamweaver 提供的可视化助理，用来帮助您查看层以及其它各种块元素在页面上显示的位置。

    也可以通过选择“查看”>“可视化助理”并取消选择“CSS 布局背景”来再次禁用“CSS 布局背景”。

  6. 接下来，将另外三个层拖动到页面上，置于 banner_graphic 层和 flash_fma 层的下面。

    每次拖动新层之前一定要单击“插入”栏中的“绘制层”。

  7. 将另外三个层拖动到页面上之后，请使用“属性”检查器执行以下操作：
    • 选择第一个层，将它命名为 header，并将它的大小设置为宽 700 像素，高 24 像素。
    • 按 Enter 键 (Windows) 或 Return 键 (Macintosh) 应用最后一项。

      提示

      选择层时，请确保在层边框或层选择柄上的某个位置单击，而不要在层的内部单击。如果在层的边框上看到调整大小手柄，并在“属性”检查器中看到宽度和高度属性，则可以确保层已被选中。还可以通过在“层”面板（“窗口”>“层”）中单击层的名称来选择层。
    • 选择第二个层，将它命名为 center_content，然后将它的大小设置为宽 700 像素，高 350 像素。
    • 按 Enter 键 (Windows) 或 Return 键 (Macintosh) 应用最后一项。

      注意

      将 center_content 层的高度调整为 350 像素时，它将与页面上的剩余层重叠。在继续执行下一步之前，请将剩余层移动到 center_content 层之下，方法是选择剩余层，然后将选择柄拖动到页面底部。
    • 选择第三个层，将其命名为 footer，并将它的大小设置为宽 700 像素，高 24 像素。按 Enter 键 (Windows) 或 Return 键 (Macintosh) 应用最后一项。

    完成操作后，您的页面应如下所示：

  8. 接下来，选择 header 层，并拖动选择柄，直到 header 层直接定位到 flash_fma 层之下。

    可以在拖动层时随时检查所处的位置，方法是在该层的外部单击以取消选择它。

    提示

    还可以按键盘上的方向键，一次一个像素地移动选定层。尝试使用“属性”检查器使 header 层与距离页面左边距 20 像素的位置对齐。然后，使用向上箭头键向上移动该层，直到它接触到 flash_fma 层的底部。
  9. 选择并拖动 center_content 层和 footer 层，或使用计算机上的方向键定位层，如以下示例所示：

    提示

    还可以使用文档工具栏上的“可视化助理”按钮启用或禁用“CSS 布局背景”。
  10. 当各层就位后，通过选择“查看”>“可视化助手”并取消选择“CSS 布局背景”来禁用“CSS 布局背景”（如果它尚未禁用）。


在层的内部添加层

您将要绘制的最后一些层将位于大型 center_content 层的内部。如果您已经完成了教程：创建基于表格的页面布局，则这些层等效于您添加到页面上的表单元格。

  1. 在层的右侧单击一下，确保取消选择所有内容。
  2. 在“插入”栏的“布局”类别中，单击“绘制层”并将另一个层拖动到 center_content 层的内部，如以下示例所示：

  3. 单击新层的选择柄，确保选中该层。
  4. 选中新层后，在“属性”检查器中执行以下操作：
    • 单击“层编号”文本框，然后将该层重命名为 navigation。
    • 在“宽 (W)”文本框中，输入 140px。
    • 在“高 (H)”文本框中，输入 350px。
    • 在“左 (L)”文本框中，输入 20px。
    • 按 Enter 键 (Windows) 或 Return 键 (Macintosh) 应用最后一项。
  5. 使用键盘上的向上箭头键移动该 navigation 层，直到它恰好适合 center_content 层，如以下示例所示：

  6. 通过单击“绘制层”并拖动其它层在 center_content 层中创建另一个层，如以下示例所示：

  7. 单击新层的选择柄，确保选中该层。
  8. 选中新层后，在“属性”检查器中执行以下操作：
    • 单击“层编号”文本框，然后将该层重命名为 flash_video。
    • 在“宽 (W)”文本框中，输入 230px。
    • 在“高 (H)”文本框中，输入 350px。
    • 按 Enter 键 (Windows) 或 Return 键 (Macintosh) 应用最后一项。
  9. 拖动 flash_video 层或使用键盘上的方向键定位该层，如以下示例所示：

  10. 在 center_content 层中再创建一个层，方法是单击“绘制层”并拖动另一个层，如以下示例所示：

  11. 单击新层的选择柄，确保选中该层。
  12. 选中新层后，在“属性”检查器中执行以下操作：
    • 单击“层编号”文本框，然后将该层重命名为 text。
    • 在“宽 (W)”文本框中，输入 330px。
    • 在“高 (H)”文本框中，输入 350px。
    • 按 Enter 键 (Windows) 或 Return 键 (Macintosh) 应用最后一项。
  13. 拖动 text 层或使用键盘上的方向键定位该层，如以下示例所示：

    注意

    在层的边框上看到虚线是正常现象。这意味着各层间有部分区域（一个或两个像素）重叠。
  14. 保存页面。


向页面添加颜色

提示

可以通过将列标题的右边框向左或向右拖动来更改“层”面板中“名称”列的宽度。
  1. 现在，您将通过设置某些层以及整个页面背景的颜色，向页面添加颜色。通过在“层”面板（“窗口”>“层”）中单击 navigation 层的名称选择该层。

  2. 在“属性”检查器中的“背景颜色”文本框内单击一次。

    “背景颜色”文本框位于“背景颜色”(Bg) 颜色框旁。

  3. 在“背景颜色”文本框中，输入十六进制值 #993300，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    navigation 层的背景颜色即变为红棕色。

  4. 在“层”面板中单击 flash_video 层的名称选择该层。
  5. 在“属性”检查器中，在“背景颜色”文本框内单击一次，输入十六进制值 #F7EEDF，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    flash_video 层的颜色即变为浅棕色。

  6. 重复上述步骤将 text 层的颜色也更改为浅棕色。
  7. 设置所有三个层的背景颜色后，单击它们的右侧，确保未选中任何内容。

    接下来，您将通过修改页面属性来更改整个页面的背景颜色。通过“页面属性”对话框可以设置一些页面属性，包括页面字体的大小和颜色、已访问链接的颜色以及页面边距等。

  8. 选择“修改”>“页面属性”。
  9. 在“页面属性”对话框的“外观”类别中，单击“背景颜色”颜色框，然后从颜色选择器中选择黑色 (#000000)。

  10. 单击“确定”。

    页面的背景即变为黑色。

  11. 保存页面。

您的 CSS 页面布局现在已经完成。该布局包含一些可以保存资源（如图像、文本和 Flash 视频文件）的层。下一步是添加内容。

如果您已经完成了教程：向页面添加内容，那么即可以使用 Dreamweaver 轻松地将资源插入到页面中。如果未完成该教程，则在向刚刚完成的基于 CSS 的页面布局中添加内容时，可以使用插图作为参考。

在 cafe_townsend/completed_files/dreamweaver 文件夹中可找到本教程的完成版本。


教程：显示 XML 数据

本教程介绍如何创建显示 XML 数据的 Web 页面。显示 XML 数据需要检索存储在本地或远程 XML 文件中的信息以及将该信息呈现在页面中。在 Web 页面上使用 XML 数据的主要优点是能够将内容与表示形式分开。即，页面的内容（数据）与页面的表示形式（布局和文本样式等）完全保持相互独立。这样，任何人都可以在 XML 文件中工作，不必改变表示形式页面，反之亦然。

在学习本教程之前，尽管不是非得熟悉层叠样式表 (CSS) 不可，但还是应该在层叠样式表方面掌握一定的知识。如果您对此不熟悉，则可能需要先学习教程：使用 CSS 设置页面格式。

在本教程中您将完成以下任务：

查找文件

复查您的任务

了解在 Web 页面中使用 XML 和 XSL

了解 XSLT 页面

将 HTML 页面转换成 XSLT 页面

将 XML 数据源附加到 XSLT 页面

改变 XSLT 页面布局

将 XML 数据绑定到 XSLT 页面

将样式应用于 XML 数据

创建动态链接

添加重复区域 XSLT 对象

将 XSLT 页面附加到 XML 页面

了解其它部署选项


查找文件

完成本教程所需的文件位于 cafe_townsend 根文件夹内的 xml 文件夹中，您先前在教程：设置站点和项目文件中已将此文件夹复制到计算机上。如果尚未学习该教程，则必须先完成这部分，然后再继续。

此 xml 文件夹包含本教程中将使用的主要文件 (xml_menu.html)、菜单页面的 CSS 样式表 (xml_menu.css)、包含 XML 数据的文件 (specials.xml)、图像文件夹及其它一些 HTML 页面。

教程的完成版本 xml_menu.xsl 位于 cafe_townsend/completed_files/dreamweaver/xml 目录中。


复查您的任务

一家虚构的餐馆 Cafe Townsend 目前在他们的 Web 站点上公布了每日特价清单。他们使用一个包含一系列表格行的 HTML 表格来显示这些信息。每行左列显示项目名称和项目说明。每行右列显示项目的价格。页面上的所有信息均采用手工编码（即信息不来自动态数据源），文本是通过外部样式表进行格式设置的。

Cafe Townsend 的所有者已经决定“采用动态方式”，并使用 XML 文件中的数据来显示他们的每日特价。使用 XML 可以使页面内容（菜单特价）和表现形式（布局和文本样式等）保持独立。对 HTML 或 Web 页面维护一无所知的员工通过编辑 XML 文件可以轻松地更新信息，而显示菜单信息的页面在样式上不会有丝毫变化。

在本教程中，可以将现有特价页面（HTML 页面）转换为 XSLT 页面，以便能够在页面上显示 XML 数据。您还将对 XML 数据应用样式，以便使数据的外观与页面的其它内容一致。

如果能够轻松自如地处理 XML、XSLT 和客户端转换，则可以跳到将 HTML 页面转换成 XSLT 页面。如果不熟悉这些概念中的任何一个，请阅读下面各节。


了解在 Web 页面中使用 XML 和 XSL

可扩展标记语言 (XML) 可对信息进行结构化处理。与 HTML 一样，XML 允许您使用标签使信息结构化，但 XML 标签与 HTML 标签不一样，它不是预定义的。XML 允许您创建对数据结构进行最佳定义的标签。标签嵌套在其它标签中可创建一种父子标签的架构。与大多数 HTML 标签一样，XML 架构中的所有标签都有一个开始标签和一个结束标签。

下面的示例介绍 XML 文件的基本结构：

<?xml version=“1.0”>
<mybooks>
   <book bookid=“1”>
      <pubdate>03/01/2004</pubdate>
      <title>Displaying XML Data with Macromedia Dreamweaver</title>
      <author>Charles Brown</author>
   </book>
   <book bookid=“2”>
      <pubdate>04/08/2004</pubdate>
      <title>Understanding XML</title>
      <author>John Thompson</author>
   </book>
</mybooks>

在此示例中，每一个 <book> 父标签都包含三个子标签：<pubdate>、<title> 和 <author>。但每个 <book> 标签也是 <mybooks> 标签的子标签，后者在架构中的级别比前者高一级。只要相应地将标签嵌套在其它标签中，并为每个开始标签指定一个对应的结束标签，您就可以随意命名 XML 标签并安排它们的结构。

XML 文档不包含任何格式设置—这类文档只是结构化信息的容器。（您将注意到，此示例代码不包含字体、表格或标题标签。）有了 XML 架构之后，就可以使用可扩展样式表语言 (XSL) 来显示信息。与层叠样式表 (CSS) 允许您设置 HTML 的格式一样，XSL 也允许您设置 XML 数据的格式。您可以在 XSL 文件中定义样式、页面元素和布局等，并将 XSL 文件附加到 XML 文件，以便当用户在浏览器中查看 XML 数据时，根据您在 XSL 文件中的定义对数据进行格式设置。内容（XML 数据）与表现形式（由 XSL 文件定义）是完全独立的，这使您可以更好地控制信息在 Web 页面上的显示方式。本质上，XSL 是 XML 的一种表示形式技术，其中的主要输出是 HTML 页面。

可扩展样式表语言转换 (XSLT) 是 XSL 的子集语言，它允许您在 Web 页面上显示 XML 数据，并将 XML 数据和 XSL 样式“转换”为 HTML 形式的可读的样式化信息。您可以使用 Dreamweaver 创建 XSLT 页面，这种页面允许您使用应用程序服务器或浏览器执行 XSL 转换。当您执行服务器端 XSL 转换时，服务器执行 XML 和 XSL 的转换工作，并将其显示在页面上。当您执行客户端转换时，浏览器（如 Internet Explorer）可执行此项工作。

最终采用的方法（服务器端转换与客户端转换）取决于想要达到的最终结果、可供使用的技术、对 XML 源文件的访问级别及其它因素。两种方法都有它们自己的优点和局限性。例如，服务器端转换适用于所有浏览器，而客户端转换仅局限于新型浏览器（Internet Explorer 6、Netscape 8、Mozilla 1.8 和 Firefox 1.0.2）。服务器端转换允许您动态地显示您自己的服务器上或 Web 上任何地方的 XML 数据，而客户端转换必须使用自己的 Web 服务器上本地承载的那些 XML 数据。最后，服务器端转换要求将页面部署到已配置的应用程序服务器，而客户端转换只要求访问 Web 服务器。

本教程将指导您完成创建 XSLT 页面和执行客户端转换（主要是因为客户端工作流程更容易执行，且不需要使用应用程序服务器）的步骤。有关部署 XSLT 页面的其它方法的更多信息，请参见了解其它部署选项。


了解 XSLT 页面

当处理服务器端 XSL 转换时，您可以使用 Dreamweaver 来创建生成整个 HTML 文档的 XSLT 页面（整个 XSLT 页面），也可以创建生成部分 HTML 文档的 XSLT 片断。

整个 XSLT 页面类似于常规 HTML 页面。它包含一个 <body> 标签和一个 <head> 标签，允许在页面上显示 HTML 数据和 XML 数据的组合。XSLT 片断是由单独的文档使用的一段代码，它显示带格式的 XML 数据。与整个 XSLT 页面不同，它是一个独立的文件，不包含任何 <body> 或 <head> 标签。

如果要在 XML 数据自己的页面上显示 XML 数据，则需要创建整个 XSLT 页面，并将 XML 数据绑定到该页面。另一方面，如果要在现有动态页的特定部分中显示 XML 数据—例如，在体育用品商店的动态主页的一侧显示来自 RSS 源的体育比分—则需要创建 XSLT 片断，并在动态页中插入对该片断的引用。在处理服务器端转换时，创建 XSLT 片断并与其它动态页一起使用这些片断来显示 XML 数据是较常用的方法。

在本教程中，您将创建完整的 XSLT 页面并使用它转换示例 XML 文件。此转换将是使用新型浏览器（Internet Explorer 6、Netscape 8、Mozilla 1.8 或 Firefox 1.0.2）的客户端转换。服务器端转换不在本教程的讨论范围之内，因为服务器端转换要求您具有配置了转换引擎的应用程序服务器。

有关服务器端和客户端 XSL 转换的综合概述，请参见《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中的关于服务器端 XSL 转换和关于客户端 XSL 转换。

若想获取其它资源，包括详细讲授服务器端转换的教程，请访问 www.macromedia.com/go/dw_xsl_cn。


将 HTML 页面转换成 XSLT 页面

可以先将 Cafe Townsend 的现有特价页面（HTML 页面）转换为可以显示 XML 数据的 XSLT 页面。

  1. 在“文件”面板中（“窗口”>“文件”），查找 xml_menu.html，然后双击该文件打开它。xml_menu.html 文件位于 cafe_townsend 根文件夹内的 xml 文件夹中。有关更多信息，请参见查找文件。
  2. 选择“文件”>“转换”>“XSLT 1.0”。

    Dreamweaver 将在“文档”窗口中打开 xml_menu 页面的副本。新页面是以 .xsl 扩展名保存的 XSL 样式表。

  3. 单击 xml_menu.html 页面并关闭它，以便“文档”窗口中仅显示新的 xml_menu.xsl 页面。


将 XML 数据源附加到 XSLT 页面

接下来，使用“绑定”面板将 XML 数据源附加到此页面。

  1. 在“绑定”面板（“窗口”>“绑定”）中，单击 XML 链接。

    注意

    您还可以单击“绑定”面板右上角的“源”链接，添加 XML 数据源。
  2. 选择“附加本地文件”（默认情况下应该已被选中），单击“浏览”按钮，浏览到计算机上的 specials.xml 文件（它也位于 cafe_townsend/xml 文件夹中），然后单击“确定”。
  3. 单击“确定”，关闭“定位 XML 源”对话框。

    Dreamweaver 使用您的 XML 数据源的架构填充“绑定”面板。

    有关架构中的符号指南，请参见《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中的创建 XSLT 页面。


改变 XSLT 页面布局

既然将在页面上使用 XML 数据代替静态文本，您就不需要所有表格行。接着，将删除某个表格行之外的所有其它表格行，然后使用剩下的这个表格行来显示数据。

  1. 单击最后一个表格行（“New York Cheesecake”行）一次，然后在标签选择器中单击最右侧的 <tr> 标签以选择此行。

  2. 按 Delete 键。
  3. 重复前面的步骤删除“Grilled Pacific Salmon”行和“Thai Noodle Salad”行。当您完成后，页面上应该剩下一行 -“Summer Salad”行。
  4. 选择左侧表格单元格中的所有文本。

  5. 在“属性”检查器（“窗口”>“属性”）中，从“样式”弹出式菜单中选择“无”。

    此步骤会从选定文本中删除菜单类样式。在正常工作流程中，您可能不会这么做。在此，您将删除所有样式，以便稍后能够学习将样式应用于 XML 数据。

  6. 在文本仍处于选定状态时，按 Delete 键。
  7. 保存您的工作（“文件”>“保存”）。


将 XML 数据绑定到 XSLT 页面

现在，您已经为将 XML 数据绑定到此页面做好了准备。

  1. 在“绑定”面板中（“窗口”>“绑定”），请选择项目元素并将其拖到空的表格单元格中。

    页面上即显示一个 XML 数据占位符。该占位符突出显示在花括号中。它使用 XPath（XML 路径语言）语法描述 XML 架构的层次结构。

  2. 按键盘上的向右箭头键，将插入点移到 XML 数据占位符的右侧。
  3. 按空格键，键入一个连字符，然后再次按空格键。

  4. 在“绑定”面板中，选择说明元素并将其拖入插入点。

    页面上即显示另一个 XML 数据占位符。根据您的显示器分辨率，此占位符可能会移到下一行。现在不必为此担心。稍后在浏览器中显示页面时，数据将相应地填入表格中。

  5. 最后，在右边的表格单元格中选择价格 (7)。
  6. 在“绑定”面板中，双击价格元素。

    此时，XML 数据占位符还是会影响页面的布局。现在不必为此担心。

    注意

    价格的 XML 数据占位符仍然通过菜单类样式进行格式设置，因为您没有像删除左边表格单元格样式那样去删除它的样式。
  7. 保存页面，然后按 F12 键 (Windows) 或 Option+F12 (Macintosh) 在浏览器中预览所执行的操作。

    该浏览器显示的页面显示了 XML 文件中的一行数据。


将样式应用于 XML 数据

现在，您可以将样式应用于项目和说明的 XML 数据占位符。在对 XML 数据占位符应用样式时，占位符本身的文本将显示样式。稍后，在浏览器中预览页面时，所产生的 XML 数据也将显示指定的样式。

  1. 单击左侧的表格单元格一次，然后在标签选择器中单击最右侧的 <td> 标签以选择此单元格。

    您将选择此单元格，以便能够立即对此单元格的整个内容（包括连字符）进行格式设置。

  2. 在“属性”检查器中，从“样式”弹出式菜单的类样式列表中选择菜单。
  3. 在左边的表格单元格内单击一次，以取消选择此单元格。
  4. 单击一次项目的 XML 数据占位符以选择此占位符。
  5. 在“属性”检查器中，单击“斜体”按钮。

  6. 保存页面，然后按 F12 键 (Windows) 或 Option+F12 (Macintosh) 在浏览器中预览所执行的操作。

有关对 XML 数据应用样式的更多信息，请参见《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中的将样式应用于 XSLT 片断。


创建动态链接

接下来，将创建动态链接，以便让特价菜单上的项目名称链接到包含项目图片的页面。

  1. 在“文档”窗口中，单击项目的 XML 数据占位符以选择此占位符。
  2. 在“属性”检查器中，单击“链接”文本框旁边的“浏览文件”图标。

  3. 在“选择文件”对话框中，选择“数据源”。

    如果在 Windows 计算机上，则此选项位于该对话框的顶部。如果在 Macintosh 计算机上，则此选项位于该对话框的底部。

  4. 当 XML 架构出现在对话框中时，选择链接元素。
  5. 单击“确定”。

    Dreamweaver 将创建一个动态链接。在 XML 文件中，每个链接元素均指向包含各自菜单项目图片的 HTML 页面。

    注意

    如果打开 specials.xml 文件并查看代码，则会发现每个<链接>元素均包含一个 HTML 文件名，该文件包含对应菜单项的图片。这实际上是 HTML 文件的路径，因为含有图片的 HTML 页面与您正在处理的 XSLT 页面位于相同的 xml 目录中。链接元素始终是链接页面的完整路径，通常以 HTTP 地址的形式写出。
  6. 保存页面，然后按 F12 键 (Windows) 或 Option+F12 (Macintosh) 在浏览器中预览所执行的操作。

    浏览器将显示带有一个活动链接的页面。如果单击该链接，您将进入一个新页面。


添加重复区域 XSLT 对象

重复区域 XSLT 对象允许在 Web 页面上显示来自 XML 数据源的重复元素。接下来，把重复区域 XSLT 对象添加到表格行中，以便能够在页面上显示多个特价。

  1. 在“文档”窗口中，在含有 XML 数据占位符的表格行内的任何位置单击一次。
  2. 在标签选择器中，单击最右侧的 <tr> 标签以选择此表格行。
  3. 选择“插入”>“XSLT 对象”>“重复区域”。

  4. 在 XPath 表达式创建器中，选择重复的元素 menu_item。（重复的元素带有一个小加号）。

  5. 单击“确定”。

    在“文档”窗口中，重复的区域周围会出现一个灰色的选项卡式细轮廓。（您将需要取消选择该表格才能看到它。）稍后，在浏览器中预览工作时，灰色的外框将会消失，选项将展开以显示 XML 文件中指定的重复元素。

    Dreamweaver 还缩短了 XML 数据占位符的长度。这是因为 Dreamweaver 更新了 XML 数据占位符的 Xpath，使它成了一个相对于重复元素路径的路径。有关此主题的更多信息，请参见《使用 Dreamweaver》中的关于 XML 数据和重复元素。

  6. 保存页面，然后按 F12 键 (Windows) 或 Option+F12 (Macintosh) 在浏览器中预览所执行的操作。

    浏览器中现在将出现一个页面，该页面显示各个菜单项。


将 XSLT 页面附加到 XML 页面

一旦完成了 XSLT 页面，则必须将其附加到 XML 页面。使用 Dreamweaver 附加页面时，Dreamweaver 将在 XML 页面顶部插入指向 XSLT 页面的链接。

XML 页面是站点访问者联机查看页面时将浏览到的页面。这是因为他们必须浏览到包含数据的“内容”页面（XML 文件），而不是浏览到包含样式的页面（XSLT 页面）。

注意

用于客户端转换的 XML 和 XSL 文件必须位于相同的目录中。否则，浏览器将读取 XML 文件并查找用于转换的 XSLT 页面，但无法找到 XSLT 页面中的相对链接所定义的资源（样式表、图像等）。
  1. 在“文档”窗口中打开 xml_menu.xsl 页面后，如果尚未打开“绑定”面板，请打开它（“窗口”>“绑定”）。
  2. 在“绑定”面板中，双击 specials.xml 的“架构”以打开 specials.xml 文件。（必须双击文字，而不是页面图标。）
  3. 选择“命令”>“附加 XSLT 样式表”。
  4. 在“附加 XSLT 样式表”对话框中，单击“浏览”按钮，浏览到 xml_menu.xsl 页面，选择该页面，然后单击“确定”。
  5. 单击“确定”关闭“附加 XSLT 样式表”对话框。

    Dreamweaver 将在 XML 文档的顶部插入对 XSLT 页面的引用。

  6. 保存 specials.xml 页面。
  7. 按 F12 键 (Windows) 或 Option+F12 (Macintosh) 在浏览器中预览 XML 页面（不是 XSLT 页面）。

    XML 页面将采用您创建的 XSLT 页面的样式显示在浏览器中。

    请记住，将这两个页面都部署到服务器中后，站点访问者将浏览到 XML 页面（而不是 XSLT 页面）。有关更多信息，请参见《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中的关于客户端 XSL 转换。


了解其它部署选项

在本教程中，您学习了如何创建作为客户端转换中的一部分的一个完整 XSLT 页面。不过，您也可以使用整个 XSLT 页面进行服务器端转换。在使用整个 XSLT 页面进行服务器端转换时，构建页面的方法与进行客户端转换完全相同。

然而，执行服务器端转换的更常见的方法是使用 XSLT 片断。XSLT 片断是由单独的文档使用的一段代码，它显示带格式的 XML 数据。

有关整个 XSLT 页面和 XSLT 片断的简要概述，请参见了解 XSLT 页面。有关整个 XSLT 页面和 XSLT 片断如何工作的更全面的概述，请参见《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中的关于服务器端 XSL 转换。

有关介绍如何处理 XSLT 片断的教程和其它资源，请访问 www.macromedia.com/go/dw_xsl_cn。

以下是通过 XSLT 页面执行服务器端转换的工作流程：

  • 设置 Dreamweaver 站点。请参见《使用 Dreamweaver》中的设置 Dreamweaver 站点。
  • 选择服务器技术并设置应用程序服务器。请参见《使用 Dreamweaver》中的设置应用程序服务器。
  • 测试应用程序服务器以确保它正常工作。例如，创建一个需要处理的页面，然后确保应用程序服务器能处理该页面。有关如何执行此操作的教程，请访问 www.macromedia.com/go/dw_xsl_cn。
  • 执行下列操作之一：
    • 在 Dreamweaver 站点，创建一个 XSLT 片断或整个 XSLT 页面。请参见《使用 Dreamweaver》中的创建 XSLT 页面。
    • 将现有 HTML 页面转换为整个 XSLT 页面。请参见《使用 Dreamweaver》中的将 HTML 页面转换为 XSLT 页面。
  • 如尚未执行此操作，请将 XML 数据源附加到页面。请参见《使用 Dreamweaver》中的附加 XML 数据源。
  • 将 XML 数据绑定到 XSLT 片断或整个 XSLT 页面。请参见《使用 Dreamweaver》中的在 XSLT 页面中显示 XML 数据。
  • 如适用，将重复区域 XSLT 对象添加到包含 XML 数据占位符的表格或表格行。请参见《使用 Dreamweaver》中的显示重复 XML 元素。
  • 执行下列操作之一：
    • 使用 XSL 转换服务器行为在动态页中插入对 XSLT 片断的引用。请参见《使用 Dreamweaver》中的在动态页中插入 XSLT 片断。
    • 从动态页中删除所有 HTML 代码，然后使用 XSL 转换服务器行为在动态页中插入对整个 XSLT 页面的引用。
  • 将动态页和 XSLT 片断（或整个 XSLT 页面）发送到应用程序服务器。如果正在使用本地 XML 文件，则还需要发送该文件。
  • 在浏览器中查看动态页。执行此操作时，应用程序服务器会转换 XML 数据，将数据插入动态页，然后在浏览器中显示数据。


教程：开发 Web 应用程序教程

在本教程中，您将了解如何使用 Macromedia Dreamweaver 8 快速着手开发动态数据库驱动 Web 应用程序，从而实现在 Web 页面上显示从数据库中检索的信息。

使用随 Dreamweaver 提供的示例数据库，可以在 Cafe Townsend 站点的 Web 页面上显示数据。您还将使用 Dreamweaver 创建一个插入记录表单，以便访问者留下意见。

在本教程中，您将完成以下任务：

开始前的准备工作

复查您的任务

打开要使用的文档

定义记录集

显示数据库记录

向表格添加动态字段

设置重复的区域

查看您的页面

创建插入记录表单

将文件复制到服务器

其它参考资料


开始前的准备工作

要完成本教程，必须设置用于应用程序开发的 Dreamweaver 工作环境。有关设置信息，请参见下表中适用于您的应用程序服务器的相应设置章节。如果不确定所使用的是何种应用程序服务器，请询问系统管理员。

  • 示例 ColdFusion 站点的设置
  • 示例 ASP.NET 站点的设置
  • 示例 ASP 站点的设置
  • 示例 JSP 站点的设置
  • 示例 PHP 站点的设置

通过这些设置章节，您将学习如何完成以下任务：

  • 配置您的系统。
  • 配置 Dreamweaver 以用于您选定的应用程序服务器。
  • 定义与数据库的连接

在您完成这些任务后才能完成本教程。

本教程中的屏幕示例显示“Macromedia ColdFusion”对话框。不过，使用 Dreamweaver 支持的任何服务器模型均可完成本教程中的课程。


复查您的任务

您的任务是为 Cafe Townsend Web 站点创建以下动态页面：

  • 可显示数据库中现有客户意见的页面。
  • 使站点访问者能够将意见发送到公司的页面，这些意见被存储在数据库中。

使 Cafe Townsend 人员可以查看数据库中的客户意见的页面如下所示：

使访问者可以发送意见的页面如下所示：


打开要使用的文档

开发数据库应用程序的一个很好的起始点就是创建可列出存储在数据库中的记录的页面。在您在本教程中构建的应用程序中，创建一个动态 Web 页面，该 Web 页将列出数据库客户意见表中的信息。然后，创建另一个动态 Web 页面，该 Web 页面使客户可以将意见或问题直接插入数据库。

在创建这些页面时，应该从确定要使用的文档着手。

  1. 选择“窗口”>“文件”以打开“文件”面板。

    “文件”面板随即打开。

  2. 在“站点”弹出式菜单中，选择在设置过程中定义的“Cafe Townsend”站点。

    有关更多信息，请参见开始前的准备工作中所列的设置章节。

  3. 在“文件”面板中，双击名为 view 的文件将其打开。

    文档在文档窗口中打开。

  4. 如果您当前正在“代码”视图中查看文档，则在“文档”工具栏中单击“显示设计视图”按钮（标记为“设计”）或“显示代码视图和设计视图”按钮（标记为“拆分”），以便您在完成本教程时可以使用所提供的屏幕示例作为检查点。


定义记录集

现在，创建一个记录集以选择要显示的数据。记录集是通过数据库查询从数据库中提取的信息集。（在 ASP.NET 中，记录集称为数据集。）数据库查询是使用指定的搜索条件（通常使用称为 SQL 的语言）从数据库中请求数据的一种方式。然后，使用提取的信息作为动态页面的内容来源。

Dreamweaver 为创建简单的 SQL 查询提供了一个易于使用的界面（不了解 SQL 也可以在 Dreamweaver 中创建记录集。）

您将创建一个记录集，该记录集选择来自教程数据库的 COMMENTS 表中的所有值。

注意

在完成此过程前，必须设置与数据库的连接。有关更多信息，请参见开始前的准备工作。
  1. 在 Dreamweaver 中打开的 Cafe Townsend 文档中，将插入点置于“客户意见”标题下。
  2. 通过执行下列操作之一打开“记录集”对话框或“数据集”(ASP.NET) 对话框：
    • 在“插入”栏的“应用程序”类别中，单击“记录集”或“数据集”(ASP.NET)。 这是所描述的功能的图片。
    • 选择“窗口”>“绑定”以打开“绑定”面板，然后单击加号 (+) 按钮并选择“记录集”或“数据集”(ASP.NET)。

    出现“记录集”对话框或“数据集”(ASP.NET) 对话框。

    注意

    如果您所看到的对话框看起来比前面的对话框更复杂，则单击“简单”按钮。
  3. 在“名称”文本框中，输入 rs_Comment。
  4. 在“数据源”弹出式菜单 (ColdFusion) 或“连接”弹出式菜单（其它服务器页面类型）中，选择“connTownsend”。

    “记录集”或“数据集”对话框根据来自数据库的数据更新。

  5. 如果有与数据源或连接相关联的用户名和密码，则输入它们。如果您在设置数据源时没有提供用户名或密码，则保留这些框为空。
  6. 在“表格”弹出式菜单中，保持“COMMENTS”的选中状态。
  7. 在“列”中，确保选择“全部”以选中表格中的所有列。
  8. 将“筛选”弹出式菜单的设置保留为“无”，以选中表格中的所有行。
  9. 在第一个“排序”弹出式菜单中，选择“LAST_NAME”，然后在第二个弹出式菜单中选择“升序”。

    此步骤指定检索出的记录将按客户姓氏的字母顺序列出。

  10. 单击“测试”以测试记录集或数据集。

    数据库中与您的记录集或数据集选择条件匹配的记录显示在“测试 SQL 指令”窗口中。这种情况表明您选择了表格中的所有数据。

  11. 单击“确定”关闭“测试 SQL 指令”窗口。
  12. 单击“确定”，关闭“记录集”或“数据集”对话框并创建记录集或数据集。

    记录集随即出现在“绑定”面板中。“文档”窗口不会发生更改。

    提示

    如果您没有在“绑定”面板中看到所有记录集字段，则单击“记录集”(rs_Comment) 旁的加号 (+) 按钮 (Windows) 或扩展箭头 (Macintosh) 以展开此记录集结构。


显示数据库记录

接下来，创建一个页面，该页面列出当前存在于 COMMENTS 表格中的记录。您将动态生成该页，而不用手动输入相关信息。

您将从创建一个表格以建立数据列表的结构着手。

  1. 在 Cafe Townsend 文档中，将插入点置于“客户意见”标题后的空行中。
  2. 通过执行以下操作之一插入一个表：
    • 在“插入”栏中，选择“常用”类别，然后单击“表格”按钮或将该按钮拖动到文档中。 这是所描述的功能的图片。
    • 选择“插入”>“表格”。

    将出现“表格”对话框。

  3. 在该对话框中，设置下列选项：
    • 在“行数”中，输入 2。
    • 在“列数”中，输入 4。
    • 保留“表格宽度”设置为 100%。
    • 保留“边框粗细”设置为 1。
    • 在“单元格边距”中，输入 2。
    • 在“单元格间距”中，输入 2。
    • 在“页眉”部分，选择“顶部”选项。

    在“摘要”文本框中，为使用屏幕阅读器的访问者提供了表的文本描述，如下所示：

    This table lists all the comments that visitors to this site have entered into the database.

    完成后的对话框应类似于以下示例：

  4. 单击“确定”。

    该表格即会插入到文档中。

  5. 在该表格的顶行中，添加用于表格项的标签文字：
    • 在该表格的第一个单元格中，输入 First Name。
    • 在下一个单元格中，输入 Last Name。
    • 在随后的单元格中，输入 E-mail。
    • 在最后的单元格中，输入 Comments。
  6. 保存页面。


向表格添加动态字段

现在准备好向表格添加记录集字段。

  1. 如果“绑定”面板尚未打开，则通过执行以下操作之一打开它。
    • 选择“窗口”>“绑定”。
    • 单击“应用程序”面板组的扩展箭头，然后选择“绑定”面板。
  2. 通过执行以下操作之一将“FIRST_NAME”字段添加到该表格中：
    • 将插入点置于“First Name”标签下的表格单元格中；在“绑定”面板中选择“FIRST_NAME”然后单击“插入”。
    • 将 FIRST_NAME 从“绑定”面板中拖动到“First Name”标签文字下的表格单元格中。
  3. 重复第 2 步以将“LAST_NAME”、“EMAIL”和“COMMENTS”（不是 COMMENT_ID）添加到该表格中。

    您的表格应类似于以下示例。您可能需要加宽“文档”窗口，以便看到整个表格。

  4. 保存页面。


设置重复的区域

您创建的表格只包含一行数据。要显示所有记录，必须将该表格行设置为重复的区域。当在浏览器中查看该表格时，其中包含与符合记录集搜索要求的各个记录相对应的行。

  1. 在“文档”窗口中，通过执行以下操作之一选择底部的表格行：
    • 单击其中的某个单元格，然后在标签选择器中单击列表中最后一个 <tr> 标签。
    • 将指针置于该表格行的左侧，在指针更改为右向箭头后单击表格行边框以选择该行。
  2. 通过执行以下操作之一创建重复的区域：
    • 在“服务器行为”面板中，单击加号 (+) 按钮，然后选择“重复区域”。
    • 在“插入”栏的“应用程序”类别中，单击“重复的区域”。
    • 选择“插入”>“应用程序对象”>“重复区域”。

    “重复区域”对话框随即出现。

  3. 在该对话框中，单击“确定”以接受默认设置。

    在表格行的周围会显示一个轮廓，在它的上面会显示一个选项卡，而在它的左侧会指明这是一个重复区域。（该选项卡标签文字会随您使用的服务器技术的不同而有所变化。）

  4. 保存页面。


查看您的页面

接下来，将要查看页面。要查看 Dreamweaver 中的页面在服务器对其进行处理时的外观，可以使用“动态数据视图”。

在 Cafe Townsend 文档仍处于活动状态时，执行下列操作之一以查看页面中的数据：

  • 在文档工具栏中，单击“动态数据视图”。 这是所描述的功能的图片。
  • 选择“查看”>“动态数据”。

    此页面会进行更新以显示从数据库中提取的数据。


创建插入记录表单

您将为 Cafe Townsend Web 站点创建的下一页面使客户可以向数据库中添加意见。

Dreamweaver 包含几个帮助您快速方便地创建 Web 应用程序页面的应用程序对象。您将使用应用程序对象创建插入页。“插入记录”应用程序对象创建 HTML 表单、与数据库中的字段相对应的数据字段以及创建动态页所必需的服务器脚本。

本节包含以下主题：

  • 添加“插入记录表单”应用程序对象
  • 创建插入表单


添加“插入记录表单”应用程序对象

您可以使用“插入记录表单”应用程序对象来创建允许访问者向数据库中输入数据的表单。应用程序对象使您可以选择要包括在该表单中的字段，对字段进行标记，以及选择要插入的表单对象的类型。用户在表单字段中输入数据并单击“提交”按钮后，新的记录即插入数据库中。还可以设置在成功提交记录后要打开的页面，以使提交者知道该数据库已更新。

  1. 在“文件”面板中，找到名为“send”的文件，然后双击该文件将其打开。

    文档在文档窗口中打开。

  2. 将插入点置于包含段落的行下的空表格行中。

    该应用程序对象随即插入到该空行中。

  3. 若要将插入记录对象添加到页面上，请执行以下操作之一：
    • 在“插入”栏的“应用程序”类别中，从“插入记录”弹出式菜单中选择“插入记录表单向导” 这是所描述的功能的图片。 。
    • 选择“插入”>“应用程序对象”>“插入记录”>“插入记录表单向导”。

    即会显示“插入记录表单”对话框。

  4. 在“数据源”(ColdFusion) 或“连接”弹出式菜单中，选择“connTownsend”。
  5. 如果有与数据源或连接相关联的用户名和密码，则输入它们。

    如果您在设置数据源或连接时没有提供用户名或密码，则保留这些框为空。

  6. 在“表格”弹出式菜单中，确保已选择“COMMENTS”。
  7. 单击“插入后，转到”文本框或“如果成功，则转到”文本框 (ASP.NET) 旁的“浏览”按钮。
  8. 在出现的对话框中，选择名为“view”的文件，然后单击“确定”以关闭该对话框。

    出于测试目的，您需要查看在输入意见后显示所有意见的页面。测试 Web 应用程序后，更改此设置以显示感谢访问者发表意见的页面。

  9. 按照下一节中的过程完成此向导的其余部分。
  10. 按照创建插入表单中的过程完成此向导的其余部分。


创建插入表单

在“插入记录表单向导”的“表单字段”部分中，定义访问者将数据输入到的表单。

  1. 在“插入记录表单向导”中，通过执行以下操作删除不希望包含在该表单中的字段。
    • 选择 COMMENT_ID 然后单击减号 (-)。
    • 选择 TELEPHONE 然后单击减号 (-)。
    • 选择 SUBMIT_DATE 然后单击减号 (-)。
    • 选择 ANSWERED 然后单击减号 (-)。
  2. 如果您为 ASP.NET 创建一页，则通过执行以下操作更改表单字段的字母顺序：
    • 在“列”列表中，选择“COMMENTS”，然后单击向下箭头以将 COMMENTS 置于 LAST_NAME 下。
    • 在“列”列表中，选择“EMAIL”，然后单击向下箭头以将 EMAIL 置于 LAST_NAME 下。
  3. 在“表单字段”列表中，选择 FIRST_NAME 以指定该字段在表单中显示的方式。
  4. 在“标签文字”文本框中，键入 FIRST NAME 以替代默认文字。

    该标签文字将显示在 HTML 表单中文本框的旁边。

  5. 通过执行以下操作之一为字段设置表单对象类型：
    • 如果您使用 ASP.NET，则在“显示为”弹出式菜单中接受默认值“文本域”，并且在“提交为”弹出式菜单中，将默认值 WChar 更改为 VARCHAR。
    • 如果您使用非 ASP .NET 的服务器技术，则在“显示为”弹出式菜单中接受默认值“文本字段”，并且在“提交为”弹出式菜单中接收默认值“文本”。
  6. 保持“默认值”字段为空。

    对于某些 Web 应用程序，应使用此字段来设置字段初始文本，让用户知道要提供哪一类型的信息。这种情况下，字段的标签文字“FIRST NAME”表明访问者需要输入他们的名字。

    完成设置后，“FIRST_NAME”项应类似于以下示例：

  7. 使用标签文字 LAST NAME 对“LAST_NAME”表单字段重复第 3 步到第 6 步，显示为“文本字段”，并且提交为“文本”。
  8. 使用标签文字 EMAIL 对“EMAIL”表单字段重复第 3 步到第 6 步，显示为“文本字段”，并且提交为“文本”。
  9. 在“表单字段”列表中，选择“COMMENTS”。
  10. 在“标签文字”字段中，输入 COMMENTS。
  11. 通过执行以下操作之一为“COMMENTS”表单字段设置表单对象类型：
    • 如果使用 ASP.NET，则在“显示为”弹出式菜单中选择“文本区域”；在“提交为”弹出式菜单中选择“VARCHAR”。
    • 如果使用的是非 ASP.NET 的服务器技术，则在“显示为”弹出式菜单中选择“文本区域”，在“提交为”弹出式菜单中接受默认值“文本”。

    在您完成设置后，对话框应类似于以下示例：

  12. 单击“确定”以关闭该对话框并创建插入记录表单。

    “插入记录表单”应用程序对象即被插入文档中。

  13. 保存页面。


将文件复制到服务器

接下来，将更新后的文件复制到服务器。复制这些文件后，查看插入记录页面，添加意见或问题，并提交数据以测试该应用程序。

  1. 在“文件”面板中，按住 Control 键并单击 (Windows) 或者按住 Command 键并单击 (Macintosh) 名为“view”和“send”的文件，然后单击蓝色的“上传文件”箭头图标，将文件上传到服务器。
  2. 如果 Dreamweaver 询问您是否要将关联文件复制到服务器，选择“是”。

    注意

    对于某些服务器模型，Dreamweaver 将在您的本地文件夹中创建 Connections 文件夹。您还必须将该文件夹复制到远程服务器上，以使 Web 应用程序能够正常工作。在“文件”面板中，选择 Connections 文件夹，然后单击“上传文件”按钮将该文件夹复制到您的服务器。
  3. 当名为 send 的文件作为活动文档时，在“浏览器”中选择“文件”>“预览”，或按 F12 在浏览器中查看您的页面。
  4. 在表单中输入测试数据，然后在文档中单击“插入记录”按钮以提交您的数据。

    应用程序服务器接收已提交的信息，更新数据库，并显示包含更新信息的意见页面。


其它参考资料

本教程提供了有关一小部分工具的信息，这些工具可用来创建数据驱动的动态页。您已了解如何创建记录集来定义要在您的 Web 站点中使用的数据。您还使用 Dreamweaver 应用程序对象创建了有效的 Web 应用程序，您可以通过该应用程序与数据库存储的数据进行交互。

有关如何开发 Web 应用程序的详细信息，请参见《使用 Dreamweaver》中的以下主题：

  • 为页面获取数据
  • 定义动态内容源
  • 向 Web 页中添加动态内容
  • 显示数据库记录


了解 Web 应用程序

Web 应用程序是许多 Web 页的集合，这些 Web 页可以与访问者进行交互、相互之间进行交互，还与 Web 服务器上的多种资源（包括数据库）进行交互。在开始建立您自己的 Web 应用程序之前，您应该熟悉本章中讨论的主题。

本章包含以下主题：

关于 Web 应用程序

Web 应用程序如何工作

创作动态页

选择服务器技术

Web 应用程序术语


关于 Web 应用程序

Web 应用程序是一个包含多个页的 Web 站点，这些页的部分内容或全部内容是未确定的。只有当访问者请求 Web 服务器中的某个页时，才确定该页的最终内容。由于页面最终内容根据访问者操作请求的不同而变化，因此这种页称为动态页。

建立 Web 应用程序就是为了解决多种问题。本节介绍 Web 应用程序的一般用途并给出一个简单的示例。


Web 应用程序的一般用途

对于站点访问者和开发人员而言，Web 应用程序有许多用途，包括以下几方面：

  • 使访问者可以快速方便地在一个内容丰富的 Web 站点上查找信息。

    这种 Web 应用程序使访问者能够搜索、组织和浏览所需的内容。典型的示例包括公司的 Intranet、microsoft Msdn (www.msdn.microsoft.com) 和 Amazon.com (www.amazon.com)。

  • 收集、保存和分析站点访问者提供的数据。

    过去，在 HTML 表单中输入的数据以电子邮件消息的形式发送给员工或 CGI 应用程序进行处理。而 Web 应用程序可以将表单数据直接保存到数据库，并且可以提取数据并创建基于 Web 的报表以进行分析。典型的示例包括网上银行页、商店结帐页、调查和用户反馈表单。

  • 对内容不断变化的 Web 站点进行更新。

    Web 应用程序使 Web 设计人员不必再不断更新站点的 HTML。内容提供方（例如新闻编辑）向 Web 应用程序提供内容，Web 应用程序将自动更新站点。典型的示例包括 Economist (www.economist.com) 和 CNN (www.cnn.com)。


Web 应用程序示例

Janet 是一名专业的 Web 设计人员，同时也是 Dreamweaver 的长期用户，他负责为一个拥有 1000 名员工的中型公司维护 Intranet 和 Internet 站点。一天，人力资源部的 Chris 来询问 Janet 一个问题。人力资源部正在实施一个员工健身计划，该计划对员工完成的每英里步行、骑自行车或跑步进行积分。每个员工都必须通过电子邮件将他/她每月所完成的总英里数报告给 Chris。月末，Chris 将收集所有电子邮件并根据每个员工的总积分奖励他们少量现金。

Chris 的问题是这个健身计划太成功了。参与这个计划的员工太多，以致于每个月末 Chris 都要被这些电子邮件淹没。Chris 询问 Janet 是否有一个基于 Web 的解决方案。

Janet 建议采用一个基于 Intranet 的 Web 应用程序来执行以下任务：

  • 让员工使用简单的 HTML 表单在 Web 页上输入他们的英里数
  • 将员工的英里数存储在数据库中
  • 根据英里数数据计算健身积分
  • 允许员工跟踪他们每月的进展情况
  • 使 Chris 在每个月末只要点击一下就可以访问总积分

Janet 利用 Dreamweaver（其中包含多种快速方便地建立此类应用程序所需的工具）使这个应用程序在午餐时间前便得以完成并开始运行。


Web 应用程序如何工作

Web 应用程序是一组静态和动态 Web 页的集合。静态 Web 页是这样一种页，当站点访问者请求该页时它不会发生更改：Web 服务器将该页发送到请求 Web 浏览器，而不对其进行修改。相反，动态 Web 页要在经过服务器的修改后才被发送到请求浏览器。页发生更改的特性便是称其为动态的原因。

例如，您可以设计一个页来显示健身结果，同时让某些信息（例如员工姓名和结果）在接到特定员工请求时再确定。

本节包含以下主题：

  • 处理静态 Web 页
  • 处理动态页
  • 访问数据库


处理静态 Web 页

静态 Web 站点由一组相关的 HTML 页和文件组成，这些页和文件驻留在运行 Web 服务器的计算机上。

Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。当访问者单击 Web 页上的某个链接、在浏览器中选择一个书签或在浏览器的地址文本框中输入一个 URL 时，便生成一个页请求。

静态 Web 页的最终内容由网页设计人员确定，当接到请求时，内容不发生更改。这里提供了一个示例：

<html>
   <head>
      <title>Trio Motors Information Page</title>
   </head>
   <body>
      <h1>About Trio Motors</h1>
      <p>Trio Motors is a leading automobile manufacturer.</p>
   </body>
</html>

将页面放置到服务器上之前，页面的每一行 HTML 代码均由设计者编写。由于 HTML 在放置到服务器后不发生更改，因此这种页称为静态页。

注意

严格来说，“静态”页可能不是完全静态的。例如，一个鼠标经过图像或一个 Flash 内容（SWF 文件）可以使静态页活动起来。因此，本文档所说的静态页是在发送到浏览器时不进行修改的页。

当 Web 服务器接收到对静态页的请求时，服务器将读取该请求，查找该页，然后将其发送到发出请求浏览器，如下图所示：

此图像显示 Web 服务器是如何为静态页处理请求的。

至于 Web 应用程序，当访问者请求某个页时，代码的某些行尚未确定。必须先由某种机制确定这些行才能将该页发送到浏览器。这种机制将在下一节中进行讨论。


处理动态页

当 Web 服务器接收到对静态 Web 页的请求时，服务器将该页直接发送到请求浏览器。但是，当 Web 服务器接收到对动态页的请求时，它将作出不同的反应：它会将该页传递给一个负责完成页的特殊软件。这个特殊软件叫做应用程序服务器。

应用程序服务器读取页上的代码，根据代码中的指令完成页，然后将代码从页上删除。所得的结果将是一个静态页，应用程序服务器将该页传递回 Web 服务器，然后 Web 服务器将该页发送到请求浏览器。当该页到达时，浏览器得到的全部内容都是纯 HTML。下面是此过程的示意图：

此图像显示 Web 服务器是如何为动态页处理请求的。


访问数据库

应用程序服务器使您可以使用服务器端的资源，例如数据库。例如，动态页可以指示应用程序服务器从数据库中提取数据并将其插入页面的 HTML 中。有关更多信息，请参见《使用 Dreamweaver》中的数据库初学者指南。

从数据库中提取数据的指令叫做数据库查询。查询是由名为 SQL（结构化查询语言）的数据库语言所表示的搜索条件组成的。SQL 查询被写入页的服务器端脚本或标签中。

应用程序服务器不能直接与数据库进行通信，因为数据库的专用格式所呈现的数据无法解密，这与在“记事本”或 BBEdit 中打开的 Microsoft Word 文档无法解密非常类似。应用程序服务器只能通过数据库驱动程序作为媒介才能与数据库进行通信：数据库驱动程序是在应用程序服务器和数据库之间充当解释器的软件。

在驱动程序建立通信之后，将对数据库执行查询并创建一个记录集。记录集是从数据库的一个或多个表中提取的一组数据。记录集将返回给应用程序服务器，应用程序服务器使用该数据完成页面。

下面是一个用 SQL 编写的简单的数据库查询：

SELECT lastname, firstname, fitpoints
FROM employees

该语句将创建一个三列的记录集，并用包含数据库中所有员工的姓、名和健身积分的行填充该记录集。有关更多信息，请参见《使用 Dreamweaver》中的 SQL 入门。

下面的插图说明了对数据库进行查询并将数据返回给浏览器的过程：

此图像显示 Web 服务器在请求动态页时是如何与一个数据库进行交互的。

只要服务器上安装有相应的数据库驱动程序，您几乎可以将任何数据库用于您的 Web 应用程序。

如果您计划建立小型低成本的应用程序，则可以使用基于文件的数据库，例如用 Microsoft Access 创建的数据库。如果您计划建立稳定的、对业务至关重要的应用程序，则可以使用基于服务器的数据库，例如用 Microsoft SQL Server、Oracle 9i 或 MySQL 创建的数据库。

如果您的数据库位于 Web 服务器之外的系统上，则应确保两个系统间有快速连接，以便您的 Web 应用程序可以快速有效地工作。


创作动态页

创作动态页就是先编写 HTML，然后将服务器端脚本或标签添加到 HTML 中，使该页成为动态页。当您查看结果代码时，将显示语言嵌入在页的 HTML 中。因此，这些语言称为 HTML 嵌入式编程语言。以下基本示例使用 ColdFusion 标记语言 (CFML)：

<html>
   <head>
      <title>Trio Motors Information Page</title>
   </head>
   <body>
      <h1>About Trio Motors</h1>
      <p>Trio Motors is a leading automobile manufacturer.</p>
      <!--- embedded instructions start here --->
      <cfset department="Sales">
      <cfoutput>
      <p>Be sure to visit our #department# page.</p>
      </cfoutput>
      <!--- embedded instructions end here --->
   </body>
</html>

此页中嵌入的指令执行以下操作：

  1. 创建一个名为 department 的变量并为其分配字符串 "Sales"。
  2. 在 HTML 代码中插入变量的值 "Sales"。

应用程序服务器将以下页返回给 Web 服务器：

<html>
   <head>
      <title>Trio Motors Information Page</title>
   </head>
   <body>
      <h1>About Trio Motors</h1>
      <p>Trio Motors is a leading automobile manufacturer.</p>
      <p>Be sure to visit our Sales page.</p>
   </body>
</html>

Web 服务器将该页发送到请求浏览器，浏览器将其显示如下：

About Trio Motors

Trio Motors is a leading automobile manufacturer.

Be sure to visit our Sales page.

根据服务器上可用的服务器技术，选择要使用的脚本撰写语言或基于标记的语言。以下是 Dreamweaver 所支持的五种服务器技术最常用的语言：

服务器技术 | 语言
ColdFusion | ColdFusion 标记语言 (CFML)
ASP.NET | Visual Basic C#
Active Server Pages (ASP) | VBScript JavaScript
Java Server Pages (JSP) | Java
PHP | PHP

有关更多信息，请参见选择服务器技术。

Dreamweaver 可以创建让页面工作所必需的服务器端脚本或标签，您也可以在 Dreamweaver 编码环境中手工编写这些脚本或标签。


选择服务器技术

可以使用 Dreamweaver 通过以下五种服务器技术中的任何一种生成 Web 应用程序：ColdFusion, ASP.NET, ASP, JSP, 或 PHP。每种技术都与 Dreamweaver 中的一种文档类型相对应。为您的 Web 应用程序选择一种技术取决于多个因素，其中包括您对各种脚本撰写语言的熟悉程度以及所要使用的应用程序服务器。

如果您在 Web 应用程序开发或一般的应用程序开发方面还是个新手，则可能更愿意使用 ColdFusion，因为它同样提供了与 Dreamweaver 紧密集成的易于学习的服务器脚本撰写环境。如果您熟悉其它服务器技术，例如 JSP、PHP、ASP 或 ASP.NET，Dreamweaver 同时还提供对这些技术的最佳支持。

选择哪种服务器技术还取决于您计划用于 Web 应用程序的应用程序服务器。应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。例如，如果您有 ColdFusion MX 7 Server，则可以选择 ColdFusion 作为服务器技术。如果您能够访问运行 Microsoft Internet Information Server 5 (IIS)（与 .NET Framework一起运行）的服务器，则可以选择 ASP.NET。如果能够访问包含 PHP 应用程序服务器的 Web 服务器，则可以选择 PHP；如果能够访问包含 JSP 应用程序服务器（如 Macromedia JRun）的 Web 服务器，则可以选择 JSP。

ColdFusion MX 7 的开发人员版本可以从 Dreamweaver CD（仅限 Windows 版本）和 Macromedia Web 站点 (www.macromedia.com/go/coldfusion/) 上获得。

有关更多信息，请参见《使用 Dreamweaver》中的设置应用程序服务器。

要了解有关 ColdFusion 的更多信息，请从“帮助”菜单中选择“使用 ColdFusion”。

要了解有关 ASP.NET 的更多信息，请访问 Microsoft Web 站点 (http://msdn.microsoft.com/asp.net/)。

要了解有关 ASP 的更多信息，请访问 Microsoft Web 站点 (http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnanchor/html/activeservpages.asp)。

要了解有关 JSP 的更多信息，请访问 Sun Microsystems Web 站点 (java.sun.com/products/jsp/)。

要了解有关 PHP 的更多信息，请访问 PHP Web 站点 (www.php.net/)。


Web 应用程序术语

本节定义有关 Web 应用程序的常用术语。

应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。当从服务器请求这样一个页时，Web 服务器先将该页传递给应用程序服务器进行处理，然后再将该页发送到浏览器。有关更多信息，请参见 Web 应用程序如何工作。

常见的应用程序服务器包括 Macromedia ColdFusion、Macromedia JRun Server、Microsoft .NET 框架、IBM WebSphere 和 Apache Tomcat。

数据库是存储在表中的数据的集合。表的每一行组成一条记录，每一列组成记录中的一个域，如下面的示例所示。

数据库驱动程序是在 Web 应用程序和数据库之间充当解释器的软件。数据库中的数据是以专用格式存储的。数据库驱动程序使 Web 应用程序可以读取和操作本来无法解密的数据。

数据库管理系统（DBMS，或数据库系统）是用于创建和操作数据库的软件。常见的数据库系统包括 Microsoft Access、Oracle 9i 和 MySQL。

数据库查询是从数据库中提取记录集的操作。查询是由名为 SQL 的数据库语言所表示的搜索条件组成的。例如，查询可以指定在记录集中只包含某些列或某些记录。

动态页是在发送到浏览器之前由应用程序服务器自定义的 Web 页。有关更多信息，请参见 Web 应用程序如何工作。

记录集是从数据库中一个或多个表中提取的一组数据，如下面的示例所示：

关系型数据库是包含两个或多个表的数据库，这些表共享数据。下面的数据库中有两个表共享 DepartmentID 列，所以是关系型数据库。

服务器技术是应用程序服务器用来在运行时修改动态页的技术。

Dreamweaver 开发环境支持以下服务器技术：

  • Macromedia ColdFusion
  • Microsoft ASP.NET
  • Microsoft Active Server Pages (ASP)
  • Sun Java Server Pages (JSP)
  • PHP：Hypertext Preprocessor (PHP)

也可以使用 Dreamweaver 编码环境为任何未列出的其它服务器技术开发页。

静态页是在发送到浏览器之前不会被应用程序服务器修改的 Web 页。有关更多信息，请参见处理静态 Web 页。

Web 应用程序是一个包含多个页的 Web 站点，这些页的部分内容或全部内容是未确定的。只有当访问者请求 Web 服务器中的某页时，才确定该页的最终内容。由于页面最终内容根据访问者的操作请求的不同而变化，因此这种页称为动态页。

Web 服务器是响应来自 Web 浏览器的请求发送出 Web 页的软件。当访问者单击浏览器中的 Web 页上的某个链接、在浏览器中选择一个书签，或在浏览器的地址文本框中输入一个 URL 时，便生成一个页请求。

常见的 Web 服务器包括 Microsoft Internet Information Server、Microsoft Personal Web Server、Apache HTTP Server、Netscape Enterprise Server 和 Sun ONE Web Server。


安装 Web 服务器

若要开发和测试动态 Web 页，您需要一个正常工作的 Web 服务器。本章介绍大多数 Windows 用户如何在本地计算机上安装和使用 Microsoft Web 服务器。

如果您是 Windows 用户并要开发 ColdFusion 站点，则可以使用 Macromedia ColdFusion MX 7 应用程序服务器的开发人员版本中包括的 Web 服务器，您可以免费安装和使用此版本。有关更多信息，请参见示例 ColdFusion 站点的设置。

如果您是 Macintosh 用户，则可以使用网络计算机上或网络托管公司所提供的 Web 服务器。如果要开发 PHP 应用程序，您可以使用已安装在 Macintosh 上的 Apache Web 服务器。

本章包含下列章节：

入门

安装 Internet Information Server

测试 IIS

测试 Macintosh Web 服务器（PHP 开发人员）

Web 服务器基础

注意

Macromedia 不为第三方软件（例如 Microsoft Internet Information Server）提供技术支持。如果您需要关于 Microsoft 产品的帮助，请与 Microsoft 技术支持联系。


入门

如果您是 Windows 用户，则可以在您的系统上安装并运行 Internet Information Server (IIS)。您还可以在联网的 Windows 计算机上安装 Web 服务器以供工作组中的其他开发人员使用。

如果您是 Windows 用户并要开发 ColdFusion 应用程序，您可以改用与 ColdFusion MX 7 的开发人员版本一起安装的 Web 服务器。有关更多信息，请参见示例 ColdFusion 站点的设置。

您的计算机上可能已经安装了 IIS。请检查文件夹结构中是否包含一个 C:\Inetpub 或 D:\Inetpub 文件夹。IIS 在安装过程中将创建该文件夹。

如果该文件夹不存在，请安装 IIS。有关更多信息，请参见安装 Internet Information Server。

如果您是 Macintosh 用户并想开发 PHP 应用程序，则可以使用 Macintosh 上已安装的 Apache Web 服务器。有关更多信息，请参见测试 Macintosh Web 服务器（PHP 开发人员）。

相关主题

  • Web 服务器基础


安装 Internet Information Server

Windows 2000 和 Windows XP Professional 用户应该安装 Internet Information Server (IIS)。

如果您是 Windows 2000 或 Windows XP Professional 用户，请检查您的系统上是否安装并运行了 IIS。方法是查找 C:\Inetpub 文件夹。如果该文件夹不存在，则您的系统上可能没有安装 IIS。

要在 Windows 2000 和 XP Professional 上安装 IIS，请执行以下操作：

  1. 选择“开始”>“设置”>“控制面板”>“添加或删除程序”，或者选择“开始”>“控制面板”>“添加或删除程序”。
  2. 选择“添加/删除 Windows 组件”。
  3. 选择“Internet 信息服务 (IIS)”，然后单击“下一步”。
  4. 按照安装说明进行操作。

安装了 Web 服务器后，您可以对其进行测试。请参见测试 IIS。

相关主题

  • Web 服务器基础


测试 IIS

若要测试 Web 服务器，请创建一个名为“myTestFile.html”的简单 HTML 页，并将其保存在运行 Web 服务器的计算机上的 Inetpub\wwwroot 文件夹中。该 HTML 页可以由一行组成，例如：

<p>My web server is working.</p>

然后，通过一个 HTTP 请求在 Web 浏览器中打开该测试页。如果 IIS 正在您的本地计算机上运行，则在 Web 浏览器中输入以下 URL：

http://localhost/myTestFile.html

如果 IIS 运行在联网的计算机上，则将联网计算机名用作域名。例如，如果运行 IIS 的计算机的名称是“rockford-pc”，则在浏览器中输入以下 URL ：

http://rockford-pc/myTestFile.html

注意

有关计算机名的更多信息，请参见 Web 服务器基础。

如果浏览器显示您的页，则说明 Web 服务器运行正常。

如果浏览器未能显示该页，请检查服务器是否正在运行。如果仍无法打开该页，请检查您的测试页是否位于 Inetpub\wwwroot 文件夹中并且文件扩展名为 .htm 或 .html。


测试 Macintosh Web 服务器（PHP 开发人员）

您可以使用已经安装在 Macintosh 上的 Apache Web 服务器开发 PHP 应用程序。

若要测试该服务器，请创建一个名为“myTestFile.html”的简单 HTML 页并将其保存在 Macintosh 上的 /Users/your_user_name/Sites/ 文件夹中（其中 your_user_name 是您的 Macintosh 用户名）。该 HTML 页可以由一行组成，例如：

<p>My web server is working.</p>

然后，在 Web 浏览器中输入以下 URL，通过一个 HTTP 请求在 Web 浏览器中打开该测试页：

http://localhost/~your_user_name/myTestFile.html

注意

默认情况下，Apache 服务器运行在端口 80 上。

如果浏览器显示您的页，则说明 Web 服务器运行正常。如果浏览器无法显示该页，则打开“系统首选项”查看“共享”首选项面板，查看 Web 服务器是否已启动。“个人 Web 共享”选项应该是启用的。

默认情况下，Apache Web 服务器不能处理 PHP；必须对其进行配置，才能使用 PHP。有关更多信息，请参见配置您的系统 (PHP)。


Web 服务器基础

Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。Web 服务器有时也称为 HTTP 服务器。

假设您使用 IIS 开发 Web 应用程序。Web 服务器的默认名称是计算机的名称。您可以通过更改计算机名来更改服务器名称。如果您的计算机没有名称，则服务器使用“localhost”。

服务器名称对应于服务器的根文件夹，根文件夹（在 Windows 计算机上）通常是 C:\Inetpub\wwwroot。通过在计算机上运行的浏览器中输入以下 URL 可以打开存储在根文件夹中的任何 Web 页：

http://your_server_name/your_file_name

例如，如果服务器名称是“mer_noire”并且 C:\Inetpub\wwwroot\ 中存有名为“soleil.html”的 Web 页，则您可以通过在本地计算机上运行的浏览器中输入以下 URL 打开该页：

http://mer_noire/soleil.html

注意

请记住，在 URL 中使用正斜杠而不是反斜杠。

您还可以通过在 URL 中指定子文件夹来打开存储在根文件夹的任何子文件夹中的任何 Web 页。例如，假设 soleil.html 文件存储在名为“gamelan”的子文件夹中，如下所示：

C:\Inetpub\wwwroot\gamelan\soleil.html

您可以通过在计算机上运行的浏览器中输入以下 URL 打开该页：

http://mer_noire/gamelan/soleil.html

如果 Web 服务器运行在您的计算机上，您可以用 localhost 来代替服务器名称。例如，以下两个 URL 在浏览器中打开同一页：

http://mer_noire/gamelan/soleil.html

http://localhost/gamelan/soleil.html

注意

除服务器名称或“localhost”之外，还可以使用另一种表示方式：127.0.0.1（例如 http://127.0.0.1/gamelan/soleil.html）。

相关主题

  • 安装 Internet Information Server
  • 测试 IIS
  • 测试 Macintosh Web 服务器（PHP 开发人员）


示例 ColdFusion 站点的设置

Macromedia Dreamweaver 8 随附有示例 ColdFusion 页，可以帮助您建立一个小型 Web 应用程序。本章介绍如何设置示例应用程序。

设置 Web 应用程序的过程分为三步。第一步，配置您的系统。第二步，定义 Dreamweaver 站点。第三步，将应用程序连接到您的数据库。本设置指南按照该三步过程进行说明。

本章包含下列章节：

ColdFusion 开发人员的设置清单

配置您的系统 (ColdFusion)

定义 Dreamweaver 站点 (ColdFusion)

连接到示例数据库 (ColdFusion)


ColdFusion 开发人员的设置清单

若要设置 Web 应用程序，您必须配置系统、定义 Dreamweaver 站点并连接到数据库。本节提供每项任务的清单。本章的其余部分将对这些任务进行详细介绍。

配置您的系统：

  1. 安装 ColdFusion 应用程序服务器（包括 Web 服务器）。
  2. 创建根文件夹。

定义 Dreamweaver 站点：

  1. 将示例文件复制到您硬盘上的文件夹中。
  2. 将此文件夹定义为 Dreamweaver 本地文件夹。
  3. 将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。
  4. 指定一个处理动态页的文件夹。
  5. 将示例文件上传到 Web 服务器。

连接到数据库：

  1. 如果要将远程计算机用作服务器，请将示例数据库复制到远程计算机。
  2. 在 Dreamweaver 中创建连接。

相关主题

  • 配置您的系统 (ColdFusion)
  • 定义 Dreamweaver 站点 (ColdFusion)
  • 连接到示例数据库 (ColdFusion)


配置您的系统 (ColdFusion)

本节提供两种常见系统配置的说明：在一种系统配置中，ColdFusion 安装在您的硬盘上；在另一种系统配置中，ColdFusion 安装在远程 Windows 计算机上。要使用其它配置，请参见《使用 Dreamweaver》中的设置 Web 应用程序。

下面的插图显示了本节中所介绍的两种配置：

用于 Windows 用户的本地配置，以及用于 Macintosh 和 Windows 用户的远程服务器配置。

若要配置您的系统，请执行以下操作：

  1. 安装 ColdFusion 应用程序服务器（请参见安装 ColdFusion MX 7）。
  2. 创建根文件夹（请参见创建根文件夹）。

    注意

    安装应用程序服务器是只需进行一次的任务。


安装 ColdFusion MX 7

若要处理动态 Web 页，您需要 Web 服务器和应用程序服务器。ColdFusion MX 7 提供这两个服务器。Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。当浏览器请求这样一个页时，Web 服务器先将该页传递给应用程序服务器进行处理，然后再发送到浏览器。有关更多信息，请参见了解 Web 应用程序。

您可以从 Macromedia Web 站点（网址为 www.macromedia.com/go/coldfusion/）下载并安装具备完整功能的 ColdFusion MX 7 开发人员版本。确保选择了 ColdFusion MX 7 Developer Edition 的 Windows 版本。在 Dreamweaver CD 上也提供 ColdFusion MX 7 Developer Edition 的副本（仅限 Windows 版本）。

注意

您也可以在运行有 J2EE 服务器（如 JRun 或 Tomcat）的 Mac OS X 计算机上安装 ColdFusion。有关更多信息，请参见 Macromedia Web 站点，网址为 www.macromedia.com/go/cfmx7_mac。安装过程很复杂，而且 Dreamweaver 并没有在 Macintosh 上用 ColdFusion 测试过。另外，将 Macintosh 上的 ColdFusion 连接到数据库服务器（如 MySQL）可能会很困难。

若要安装 ColdFusion MX 7，请执行以下操作：

  1. 如果可行，使用管理员用户帐户登录到 Windows 系统。
  2. 关闭所有打开的应用程序。
  3. 双击 ColdFusion MX 7 安装程序文件。
  4. 按照屏幕上的安装说明进行操作。

    安装向导中的某些屏幕一看就能明白。但是，对于下列屏幕，请选择其相应的选项：

    • 在“Installer Configuration（安装程序配置）”屏幕，选择“Server Configuration（服务器配置）”选项。

    • 在“Select Installation Directory（选择安装目录）”屏幕，单击“Next（下一步）”接受默认的 C:\CFusionMX7 文件夹。

    • 在“Configure Web Server（配置 Web 服务器）”屏幕，选择屏幕底部的“Built-in Web Server（内置 Web 服务器）”选项。

    • 在“RDS Password（RDS 密码）”屏幕，确保选择了“Enable RDS（启用 RDS）”选项，然后输入并确认密码。

有关更多信息，请参见 Dreamweaver 中的 ColdFusion 文档（“帮助”>“使用 ColdFusion”）。

在安装并启动 ColdFusion 之后，为您的 Web 应用程序创建根文件夹。请参见创建根文件夹。


创建根文件夹

安装了服务器软件之后，在运行 ColdFusion 的系统上为您的 Web 应用程序创建根文件夹，并确保该文件夹具有必要的权限。

若要为您的 Web 应用程序创建根文件夹，请执行以下操作：

  • 在运行 ColdFusion 的系统上的 CFusionMX7\wwwroot 文件夹中创建一个名为“MySampleApps”的文件夹。

    注意

    写下此文件夹名称，以备将来使用。以后键入时，应确保使用与创建时一致的大小写。

默认情况下，ColdFusion 设置其 Web 服务器以从 CFusionMX7\wwwroot 文件夹提供页。Web 服务器将根据来自 Web 浏览器的 HTTP 请求提供此文件夹中的任何页或其子文件夹中的任何页。

在配置完系统后，您必须定义 Dreamweaver 站点。请参见定义 Dreamweaver 站点 (ColdFusion)。


定义 Dreamweaver 站点 (ColdFusion)

在配置完系统后，将示例文件复制到本地文件夹，并定义 Dreamweaver 站点来管理这些文件。

若要定义 Dreamweaver 站点，请执行以下操作：

  1. 将示例文件复制到您硬盘上的文件夹中（请参见复制示例文件）。
  2. 将该文件夹定义为 Dreamweaver 本地文件夹（请参见定义本地文件夹）。
  3. 将 Web 服务器上的根文件夹定义为 Dreamweaver 远程文件夹（请参见定义远程文件夹）。
  4. 指定一个处理动态页的文件夹（请参见指定处理动态页的位置）。
  5. 将示例文件上传到 Web 服务器（请参见上传示例文件）。


复制示例文件

如果尚未进行此操作，则将示例文件从 Dreamweaver 应用程序文件夹复制到硬盘上的文件夹中。

若要复制示例文件，请执行以下操作：

  1. 在硬盘上的用户文件夹中创建一个名为 local_sites 的新文件夹。

    例如，创建下列文件夹之一：

    • C:\Documents and Settings\your_user_name\My Documents\local_sites (Windows)
    • /Users/your_user_name/Documents/local_sites (Macintosh)。

      注意

      在 Macintosh 上，在用户文件夹中已经有一个名为 Sites 的文件夹。不要使用该 Sites 文件夹作为本地文件夹；该 Sites 文件夹是您在将 Macintosh 用作 Web 服务器时放置页面以使它们可供公开访问的位置。
  2. 在硬盘上的 Dreamweaver 应用程序文件夹中找到 cafe_townsend 文件夹。

    如果将 Dreamweaver 安装到其默认位置，则该文件夹的路径如下所示：

    • 在 Windows 中：C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\
    • 在 Macintosh 中：Macintosh HD/Applications/Macromedia Dreamweaver 8/Tutorial_assets/cafe_townsend
  3. 将 cafe_townsend 文件夹复制到 local_sites 文件夹中。

    您将使用 cafe_townsend 文件夹作为 Dreamweaver 站点的根文件夹（主文件夹）。

复制 cafe_townsend 文件夹之后，将该文件夹定义为 Dreamweaver 本地文件夹。（请参见定义本地文件夹。）


定义本地文件夹

复制 cafe_townsend 文件夹之后，将包含 ColdFusion 示例文件的文件夹定义为 Dreamweaver 本地文件夹。

若要定义 Dreamweaver 本地文件夹，请执行以下操作：

  1. 在 Dreamweaver 中，选择“站点”>“管理站点”。

    在“管理站点”对话框中，单击“新建”，然后选择“站点”。

    出现“站点定义”对话框。

  2. 如果显示“基本”选项卡，则单击“高级”选项卡。
  3. 在“站点名称”文本框中，输入 Cafe Townsend ColdFusion。

    该名称在 Dreamweaver 中标识您的站点。

  4. 单击“本地根文件夹”文本框旁边的文件夹图标，然后浏览到包含 ColdFusion 示例文件的以下文件夹：
    • C:\Documents and Settings\your_user_name\My Documents\local_sites\cafe_townsend \contact\coldfusion (Windows)
    • /Users/your_user_name/Documents/local_sites/cafe_townsend/contact/coldfusion (Macintosh)
  5. 单击“选择”完成定义 Dreamweaver 本地文件夹。

将“站点定义”对话框保持为打开状态。下一步，将一个 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。（请参见定义远程文件夹。）


定义远程文件夹

在定义了本地文件夹之后，将一个 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。

若要定义 Dreamweaver 远程文件夹，请执行以下操作：

  1. 在“站点定义”对话框中的“高级”选项卡中，选择“类别”列表中的“远程信息”。

    即会出现“远程信息”屏幕。

  2. 在“访问”弹出式菜单中，选择将文件移入和移出服务器的方式：通过本地网络（“本地/网络”选项）或使用 FTP。

    注意

    在“访问”弹出式菜单中还有其它选项，但本指南将不对它们进行介绍。有关其它选项的信息，请参见《使用 Dreamweaver》。
  3. 输入您在创建根文件夹中创建的 Web 服务器文件夹的路径或 FTP 设置。

    该文件夹可能位于您的硬盘或远程计算机上。即使您是在硬盘上创建该文件夹，该文件夹仍被视作远程文件夹。如果您选择“本地/网络”访问，并且远程文件夹在 Windows 硬盘上，那么远程文件夹的路径可能如下所示：

    远程文件夹：C:\CFusionMX7\wwwroot\MySampleApps

    有关 FTP 的更多信息，请参见“使用 Dreamweaver 帮助”中的设置 FTP 访问的远端选项。

将“站点定义”对话框保持为打开状态。下一步，定义一个文件夹以处理动态页。（请参见指定处理动态页的位置。）


指定处理动态页的位置

定义 Dreamweaver 远程文件夹之后，请指定处理动态页的文件夹。在您开发应用程序时，Dreamweaver 使用此文件夹显示动态页并连接到数据库。

若要指定处理动态页的文件夹，请执行以下操作：

  1. 在高级“站点定义”对话框中，单击“类别”列表中的“测试服务器”。

    即会出现“测试服务器”屏幕。Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是本地计算机、开发服务器、中间服务器或生产服务器，只要能够处理 ColdFusion 页即可。在许多情况下，包括设置 Cafe Townsend 站点，您都可以使用与“远程信息”类别相同的设置（请参见定义远程文件夹），因为它们指向能够处理 ColdFusion 页的服务器。

  2. 从“服务器模型”弹出式菜单中选择“ColdFusion”。
  3. 在“访问”弹出式菜单中，选择您指定的访问远程文件夹的相同方法（“本地/网络”或“FTP”）。

    Dreamweaver 输入您在“远程信息”类别中指定的设置。不要更改这些设置。

  4. 在“URL 前缀”文本框中，输入当在 Web 应用程序中请求页时您会在 Web 浏览器中输入的根 URL。

    若要在您工作时在页中显示动态数据，Dreamweaver 将创建一个临时文件，将其复制到 Web 站点的根文件夹，然后尝试使用 URL 前缀请求该文件。

    注意

    Dreamweaver 根据您在“站点定义”对话框中提供的信息对 URL 前缀进行最接近的推测。但是，如果建议的 URL 前缀不正确，请修正该 URL 或输入一个新的 URL 前缀。有关更多信息，请参见《使用 Dreamweaver》中的“设置 URL 前缀”。

    如果在“远程文件夹”文本框中指定的文件夹是 c:\CFusionMX7\wwwroot\MySampleApps，则 URL 前缀应该如下所示：

    http://localhost:8500/MySampleApps/

    注意

    默认情况下，ColdFusion Web 服务器在端口 8500 上运行。

    提示

    URL 前缀应始终指定一个文件夹，而不是站点上特定的页。另外，请确保使用与创建该文件夹时一致的大小写。
  5. 单击“确定”定义站点并退出“站点定义”对话框，然后单击“完成”退出“管理站点”对话框。

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。（请参见上传示例文件。）


上传示例文件

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。即使 Web 服务器运行在本地计算机上，您也必须上传这些文件。

如果不上传文件，则某些功能（例如“动态数据”视图和“在浏览器中预览”）对动态页可能不能正常工作。例如，由于图像文件尚未在服务器上，“动态数据”视图中的图像链接可能是断开的。同样，如果服务器上没有详细页，则在浏览器中预览主页时单击指向详细页的链接也将导致错误。

若要将示例文件上传到 Web 服务器，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）的“本地视图”窗格中，选择站点的根文件夹。

    根文件夹是列表中的第一个文件夹。

  2. 单击“文件”面板工具栏中的蓝色“上传文件”箭头图标，然后确认您要上传整个站点。

    Dreamweaver 将所有文件复制到您在定义远程文件夹中定义的 Web 服务器文件夹。

这便完成了 Dreamweaver 站点的定义。下一步是连接到随 Dreamweaver 一起安装的示例数据库。（请参见连接到示例数据库 (ColdFusion)。）


连接到示例数据库 (ColdFusion)

在安装过程中，Dreamweaver 将示例 Microsoft Access 数据库复制到您的硬盘。本节介绍如何创建到示例数据库的连接。

注意

有关连接到另一个数据库的信息，请参见《使用 Dreamweaver》中的“用于 ColdFusion 开发人员的数据库连接”。

若要创建数据库连接，请执行以下操作：

  1. 如果要将远程计算机用作服务器，请将示例数据库复制到远程计算机。（请参见设置数据库（远程计算机上的服务器））。
  2. 创建一个 ColdFusion 数据源，并在 Dreamweaver 中查看该连接（请参见连接到数据库）。


设置数据库（远程计算机上的服务器）

只有在 Web 服务器运行在远程计算机上的情况下本节才适用。如果您的 Web 服务器与 Dreamweaver 运行在同一台计算机上，则跳到连接到数据库。

在尝试连接到示例数据库之前，请将数据库复制到远程计算机的硬盘。如果将 Dreamweaver 安装到其默认位置，则本地硬盘上数据库文件 (tutorial.mdb) 的路径如下所示：

  • C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\data\tutorial.mdb (Windows)
  • /Applications/Macromedia Dreamweaver 8/Tutorial_assets/cafe_townsend/data/tutorial.mdb (Macintosh)

您可以将该文件上传到远程计算机上的任何文件夹中，或者可以为它创建一个新文件夹。

注意

如果将数据库文件放在远程计算机的 Inetpub 文件夹中，则可能存在安全隐患。最好将文件放在不能公开访问的文件夹中。

数据库准备就绪之后，创建 ColdFusion 数据源。（请参见连接到数据库。）


连接到数据库

要连接到数据库，必须创建一个名为 connTownsend 的指向示例数据库文件的 ColdFusion 数据源。

要连接到数据库，请执行下列操作：

  1. 在 Dreamweaver 中，打开一个 ColdFusion 页，如 send.cfm 和 view.cfm。
  2. 在“数据库”面板（“Window”>“数据库”）中，单击“RDS 登录”链接，输入 RDS 密码，然后单击“确定”。
  3. 单击“数据库”面板工具栏上的加号 (+)，然后从弹出式菜单中选择“Microsoft Access 连接”。

    注意

    如果“数据库”面板上未显示加号按钮，请重新启动 Dreamweaver。
  4. 在“CF 数据源名称”文本框中，输入 connTownsend。
  5. 在“数据库文件”文本框中，输入指向 tutorial.mdb 数据库文件的路径。

    如果 ColdFusion 运行在您的本地计算机上并且您将 Dreamweaver 安装在默认位置，则路径如下所示：

    C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\data\tutorial.mdb

    如果 ColdFusion 运行在远程计算机上，则输入您在设置数据库（远程计算机上的服务器）中放到远程计算机上的数据库文件的路径。

    有关更多信息，请参见 Dreamweaver 中的 ColdFusion 文档（“帮助”>“使用 ColdFusion”）。

  6. 单击“确定”创建该连接。

    该连接出现在“数据库”面板上。

    如果该连接未出现在该面板中，请执行以下操作之一：

    • 检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定处理动态页的位置）。
    • 查看《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中的“数据库连接答疑”。
  7. 扩展 connTownsend 分支，然后扩展 Tables 分支。

    如果 Tables 分支包含三个如下所示的表格，则为《Dreamweaver 入门》教程设置示例 ColdFusion 应用程序即告完成。有关更多信息，请参见教程：开发 Web 应用程序教程。

    如果 Tables 分支不包含表格，请单击“数据库”面板工具栏中的“修改数据源”图标，并仔细检查 Configuring and Administering ColdFusion MX （《配置和管理 ColdFusion MX》）中的连接参数。尤其是，要确保指向数据库文件的路径正确。


示例 ASP.NET 站点的设置

Macromedia Dreamweaver 8 随附有示例 ASP.NET 页，可以帮助您建立一个小型 Web 应用程序。本章讲述了一种设置示例应用程序的方法。

本章适用于 ASP.NET 开发人员。有关 ASP 的更多信息，请参见示例 ASP 站点的设置。

设置 Web 应用程序的过程分为三步。第一步，配置您的系统。第二步，定义 Dreamweaver 站点。第三步，将应用程序连接到您的数据库。本章按照该三步过程对设置进行说明。

本章包含下列章节：

ASP.NET 开发人员的设置清单

配置您的系统 (ASP.NET)

定义 Dreamweaver 站点 (ASP.NET)

连接到示例数据库 (ASP.NET)


ASP.NET 开发人员的设置清单

若要设置 Web 应用程序，您必须配置系统、定义 Dreamweaver 站点并连接到数据库。本节提供每项任务的清单。本章的其余部分将对这些任务进行详细介绍。

配置您的系统：

  1. 确保您具有 Web 服务器。
  2. 安装 Microsoft .NET Framework。
  3. 创建根文件夹。

定义 Dreamweaver 站点：

  1. 将示例文件复制到您硬盘上的文件夹中。
  2. 将此文件夹定义为 Dreamweaver 本地文件夹。
  3. 将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。
  4. 指定一个处理动态页的文件夹。
  5. 将示例文件上传到 Web 服务器。

连接到数据库：

  1. 如果要将远程计算机用作服务器，请将示例数据库复制到远程计算机。
  2. 在 Dreamweaver 中创建连接。

相关主题

  • 配置您的系统 (ASP.NET)
  • 定义 Dreamweaver 站点 (ASP.NET)
  • 连接到示例数据库 (ASP.NET)


配置您的系统 (ASP.NET)

本节提供两种常见系统配置的说明：在一种系统配置中，Windows 2000 或 Windows XP Professional 安装在您的硬盘上；在另一种系统配置中，Windows 2000 或 Windows XP Professional 安装在远程计算机上。如果要使用不同的配置，请参见《使用 Dreamweaver》中的设置 Web 应用程序。

下面的插图显示了本节中所介绍的两种配置：

用于 Windows 2000 或 XP 用户的本地配置，以及用于 Macintosh 和其他 Windows 用户的远程服务器配置。

若要配置您的系统，请执行以下操作：

  1. 确保您有 Web 服务器（请参见检查是否存在 Web 服务器）。
  2. 安装 .NET Framework（请参见安装 .NET Framework）。
  3. 创建根文件夹（请参见创建根文件夹）。

    注意

    安装 Web 服务器和 .NET Framework 是只需进行一次的任务。


检查是否存在 Web 服务器

若要开发和测试动态 Web 页，您需要一个 Web 服务器。Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。

ASP.NET 页仅使用一个 Web 服务器：Microsoft IIS 5 或更高版本。因为 IIS 5 是 Windows 2000 和 Windows XP Professional 操作系统提供的服务，所以您可以使用这两个版本的 Windows 来运行 ASP.NET 应用程序。

确保在运行 Windows 2000 或 Windows XP Professional 的计算机上安装了 IIS 5，并且正在运行。如果您有 Windows 2000 或 Windows XP Professional，则可以将您的本地计算机用作服务器。

一种快速检查计算机上是否安装有 IIS 的方法是查看文件夹结构，看它是否包含 C:\Inetpub 或 D:\Inetpub 文件夹。IIS 在安装过程中将创建该文件夹。

如果未安装 IIS，则现在进行安装。有关更多信息，请参见安装 Internet Information Server。

安装了 Web 服务器之后，安装 .NET Framework。（请参见安装 .NET Framework。）


安装 .NET Framework

若要处理动态 Web 页，您需要应用程序服务器。应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。当浏览器请求这样一个页时，Web 服务器先将该页传递给应用程序服务器进行处理，然后再发送到浏览器。有关更多信息，请参见了解 Web 应用程序。

在 ASP.NET 中，应用程序服务器称为 Microsoft .NET Framework 1.1。要开发 ASP.NET Web 应用程序，您还需要安装 Microsoft .NET Framework 1.1 Software Development Kit (SDK)。确保在运行 IIS 5 或更高版本的 Windows 2000 或 Windows XP Professional 系统上安装了 Framework 和 SDK 并且正在运行。

要安装 .NET Framework 和 SDK，请执行下列操作：

  1. 查看您的系统上是否已安装 .NET Framework，方法是，查看“添加或删除程序”对话框（“开始”>“控制面板”>“添加或删除程序”）中的应用程序列表。

    如果列出了 Microsoft .NET Framework 1.1，则该 Framework 已经安装，您不必再次安装。跳至步骤 3。

  2. 如果您的系统上尚未安装 .NET Framework，请安装 Microsoft .NET Framework 1.1 可再发行包，该包可从 Microsoft Web 站点 http://msdn.microsoft.com/netframework/downloads/framework1_1/ 获得，然后按照 Web 站点上的说明进行操作。

    您可以将该 Framework 作为 Windows 更新进行安装。

  3. 从同一 Web 站点下载 Microsoft .NET Framework 1.1 软件开发包 (SDK)，然后按照安装说明进行操作。

在安装 Framework 和 SDK 后，为您的 Web 应用程序创建根文件夹。（请参见创建根文件夹。）


创建根文件夹

安装了服务器软件之后，在运行 Microsoft IIS 的系统上为您的 Web 应用程序创建根文件夹，并确保该文件夹具有必要的权限。

若要为您的 Web 应用程序创建根文件夹，请执行以下操作：

  1. 在运行 IIS 的系统上创建一个名为“MySampleApps”的文件夹。

    注意

    写下此文件夹名称，以备将来使用。以后键入时，应确保使用与创建时一致的大小写。

    创建该文件夹的合适位置是 C:\Inetpub\wwwroot\。默认情况下，您的 IIS Web 服务器被设置为从 Inetpub\wwwroot 文件夹提供页。Web 服务器将根据来自 Web 浏览器的 HTTP 请求提供此文件夹中的任何页或其子文件夹中的任何页。

  2. 要确保为该文件夹启用了脚本权限，请启动 IIS 管理工具（在 Windows XP 中，选择“开始”>“控制面板”或者选择“开始”>“设置”>“控制面板”，双击“管理工具”，然后双击“Internet 信息服务”）。展开“本地计算机”列表，展开“Web 站点”文件夹，然后展开“默认 Web 站点”文件夹。右键单击“MySampleApps”文件夹，然后从弹出式菜单中选择“属性”。在“执行权限”弹出式菜单中，确保选择了“仅限脚本”选项。（出于安全原因，请不要选中“脚本和可执行文件”选项）然后单击“确定”。

现在已完成了 Web 服务器的配置，它将根据来自 Web 浏览器的 HTTP 请求提供根文件夹中的 Web 页。

在配置完系统后，您必须定义 Dreamweaver 站点。（请参见定义 Dreamweaver 站点 (ASP.NET)。）


定义 Dreamweaver 站点 (ASP.NET)

在配置完系统后，将示例文件复制到本地文件夹，并定义 Dreamweaver 站点来管理这些文件。

若要定义 Dreamweaver 站点，请执行以下操作：

  1. 将示例文件复制到您硬盘上的文件夹中（请参见复制示例文件）。
  2. 将该文件夹定义为 Dreamweaver 本地文件夹（请参见定义本地文件夹）。
  3. 将 Web 服务器上的根文件夹定义为 Dreamweaver 远程文件夹（请参见定义远程文件夹）。
  4. 指定一个处理动态页的文件夹（请参见指定处理动态页的位置）。
  5. 将示例文件上传到 Web 服务器（请参见上传示例文件）。


复制示例文件

如果尚未进行此操作，则将示例文件从 Dreamweaver 应用程序文件夹复制到硬盘上的文件夹中。

若要复制示例文件，请执行以下操作：

  1. 在硬盘上的用户文件夹中创建一个名为 local_sites 的新文件夹。

    例如，创建下列文件夹之一：

    • C:\Documents and Setting\your_user_name\My Documents\local_sites (Windows)
    • /Users/your_user_name/Documents/local_sites (Macintosh)。

      注意

      在 Macintosh 上，在用户文件夹中已经有一个名为 Sites 的文件夹。不要使用该 Sites 文件夹作为本地文件夹；该 Sites 文件夹是您在将 Macintosh 用作 Web 服务器时放置页面以使它们可供公开访问的位置。
  2. 在硬盘上的 Dreamweaver 应用程序文件夹中找到 cafe_townsend 文件夹。

    如果将 Dreamweaver 安装到其默认位置，则该文件夹的路径如下所示：

    • 在 Windows 中：C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_assets\ cafe_townsend\。
    • 在 Macintosh 中：Macintosh HD/Applications/Macromedia Dreamweaver 8/Tutorial_assets/cafe_townsend。
  3. 将 cafe_townsend 文件夹复制到 local_sites 文件夹中。

    您将使用 cafe_townsend 文件夹作为 Dreamweaver 站点的根文件夹（主文件夹）。

复制 cafe_townsend 文件夹之后，将该文件夹定义为 Dreamweaver 本地文件夹。（请参见定义本地文件夹。）


定义本地文件夹

复制 cafe_townsend 文件夹之后，将包含 ASP.NET 示例文件的文件夹定义为 Dreamweaver 本地文件夹。

若要定义 Dreamweaver 本地文件夹，请执行以下操作：

  1. 在 Dreamweaver 中，选择“站点”>“管理站点”。在“管理站点”对话框中，单击“新建”按钮，然后选择“站点”。

    出现“站点定义”对话框。

  2. 如果显示“基本”选项卡，则单击“高级”选项卡。
  3. 在“站点名称”文本框中，输入 Cafe Townsend ASP.NET。

    该名称在 Dreamweaver 中标识您的站点。

  4. 单击“本地根文件夹”文本框旁边的文件夹图标，然后浏览到包含 ASP.NET 示例文件的以下文件夹：
    • C:\Documents and Setting\your_user_name\My Documents\local_sites\cafe_townsend\contact\aspnet (Windows)
    • /Users/your_user_name/Documents/local_sites/cafe_townsend/contact/aspnet (Macintosh)
  5. 单击“选择”完成定义 Dreamweaver 本地文件夹。

将“站点定义”对话框保持为打开状态。下一步，将一个 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。（请参见定义远程文件夹。）


定义远程文件夹

在定义了本地文件夹之后，将一个 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。

若要定义 Dreamweaver 远程文件夹，请执行以下操作：

  1. 在“站点定义”对话框中的“高级”选项卡中，选择“类别”列表中的“远程信息”。

    即会出现“远程信息”屏幕。

  2. 在“访问”弹出式菜单中，选择将文件移入和移出服务器的方式：通过本地网络（“本地/网络”选项）或使用 FTP。

    注意

    在“访问”弹出式菜单中还有其它选项，但本指南将不对它们进行介绍。有关这些选项的信息，请参见《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）。
  3. 输入您在创建根文件夹中创建的 Web 服务器文件夹的路径或 FTP 设置。

    该文件夹可能位于您的硬盘或远程计算机上。即使您是在硬盘上创建该文件夹，该文件夹仍被视作远程文件夹。如果您选择“本地/网络”访问，并且远程文件夹在 Windows 硬盘上，那么远程文件夹的路径可能如下所示：

    远程文件夹：C:\Inetpub\wwwroot\MySampleApps

    有关 FTP 的更多信息，请参见“使用 Dreamweaver 帮助”中的设置 FTP 访问的远端选项。

将“站点定义”对话框保持为打开状态。下一步，定义一个文件夹以处理动态页。（请参见指定处理动态页的位置。）


指定处理动态页的位置

定义 Dreamweaver 远程文件夹之后，指定一个文件夹来处理动态页。在您开发应用程序时，Dreamweaver 使用该文件夹显示动态页并连接到数据库。

若要指定处理动态页的文件夹，请执行以下操作：

  1. 在高级“站点定义”对话框中，单击“类别”列表中的“测试服务器”。

    即会出现“测试服务器”屏幕。Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是本地计算机、开发服务器、中间服务器或生产服务器，只要能够处理 ASP.NET 页即可。在许多情况下，包括设置 Cafe Townsend 站点，您都可以使用与“远程信息”类别相同的设置（请参见定义远程文件夹），因为它们指向能够处理 ASP.NET 页的服务器。

  2. 从“服务器模型”弹出式菜单中选择 ASP.NET VB 或 ASP.NET C#。
  3. 在“访问”弹出式菜单中，选择您指定的访问远程文件夹的相同方法（“本地/网络”或“FTP”）。

    Dreamweaver 输入您在“远程信息”类别中指定的设置。不要更改这些设置。

  4. 在“URL 前缀”文本框中，输入当在 Web 应用程序中请求页时您将在 Web 浏览器中输入的根 URL。

    若要在您工作时在页中显示动态数据，Dreamweaver 将创建一个临时文件，将其复制到 Web 站点的根文件夹，然后尝试使用 URL 前缀请求该文件。

    Dreamweaver 根据您在“站点定义”对话框中提供的信息对 URL 前缀进行最接近的推测。然而，建议的 URL 前缀可能并不正确。如果 Dreamweaver 中的建议不正确，请更正该 URL 前缀或输入一个新的 URL 前缀。有关更多信息，请参见《使用 Dreamweaver》中的“设置 URL 前缀”。

    如果在“远程文件夹”文本框中指定的文件夹是 C:\Inetpub\wwwroot\MySampleApps，则 URL 前缀应该如下所示：

    http://localhost/MySampleApps/

    提示

    URL 前缀应始终指定一个目录，而不是站点上特定的页。另外，请确保使用与创建该文件夹时一致的大小写。
  5. 单击“确定”定义站点并退出“站点定义”对话框，然后单击“完成”退出“管理站点”对话框。

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。（请参见上传示例文件。）


上传示例文件

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。即使 Web 服务器运行在本地计算机上，您也必须上传这些文件。

如果不上传文件，则某些功能（例如“动态数据”视图和“在浏览器中预览”）对动态页可能不能正常工作。例如，由于图像文件尚未在服务器上，“动态数据”视图中的图像链接可能是断开的。同样，如果服务器上没有详细页，则在浏览器中预览主页时单击指向详细页的链接也将导致错误。

若要将示例文件上传到 Web 服务器，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）的“本地视图”窗格中，选择站点的根文件夹。

    根文件夹是列表中的第一个文件夹。

  2. 单击“文件”面板工具栏中的蓝色“上传文件”箭头图标，然后确认您要上传整个站点。

    Dreamweaver 将所有文件复制到您在定义远程文件夹中定义的 Web 服务器文件夹。

这便完成了 Dreamweaver 站点的定义。下一步是连接到随 Dreamweaver 一起安装的示例数据库。（请参见连接到示例数据库 (ASP.NET)。）


连接到示例数据库 (ASP.NET)

在安装过程中，Dreamweaver 将示例 Microsoft Access 数据库复制到您的硬盘。本节介绍如何创建到示例数据库的连接。

注意

有关连接到其它数据库的信息，请参见《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中的 ASP.NET 开发人员的数据库连接。

若要创建数据库连接，请执行以下操作：

  1. 如果要将远程计算机用作服务器，请将示例数据库复制到远程计算机。（请参见设置数据库（远程计算机上的服务器））。
  2. 在 Dreamweaver 中创建连接（请参见创建数据库连接）。


设置数据库（远程计算机上的服务器）

只有在 Web 服务器运行在远程计算机上的情况下本节才适用。如果您的 Web 服务器与 Dreamweaver 运行在同一台计算机上，则跳到创建数据库连接。

在尝试连接到示例数据库之前，请将数据库复制到远程计算机的硬盘。如果将 Dreamweaver 安装到其默认位置，则本地硬盘上数据库文件 (tutorial.mdb) 的路径如下所示：

  • C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\data\tutorial.mdb (Windows)
  • /Applications/Macromedia Dreamweaver 8/Tutorial_assets/cafe_townsend/data/tutorial.mdb (Macintosh)

您可以将该文件上传到远程计算机上的任何文件夹中，或者可以为它创建一个新文件夹。不管是哪种情况，都在一张纸上记下到数据库文件的完整路径。

注意

如果将数据库文件放在远程计算机的 Inetpub 文件夹中，则可能存在安全隐患。最好将文件放在不能公开访问的文件夹中。

数据库复制完成之后，连接到该数据库。（请参见创建数据库连接。）


创建数据库连接

设置过程的最后一步是创建数据库连接。

若要在 Dreamweaver 中创建数据库连接，请执行以下操作：

  1. 在 Dreamweaver 中打开任何一个 ASP.NET 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 单击“数据库”面板上的加号 (+) 按钮，然后从弹出式菜单中选择“OLE DB 连接”。

    随即出现“OLE DB 连接”对话框。

  3. 输入 connTownsend 作为连接名称。
  4. 单击“模板”按钮。

    随即会出现“连接字符串模板”对话框。

  5. 从模板列表中选择“Microsoft Access 2000（Microsoft Jet 4.0 提供程序）”，然后单击“确定”。

    Dreamweaver 随即在“OLE DB 连接”对话框中添加一个连接字符串模板。该模板包含连接字符串中所缺少信息的占位符。

  6. 在“数据源”文本框中，输入示例数据库文件在您的硬盘或远程计算机硬盘上的完整路径。如果 ASP.NET 正在您的本地计算机上运行，而您将 Dreamweaver 安装在其默认位置，则使用如下路径：

    C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_assets\data\tutorial.mdb

    注意

    根据安装 Dreamweaver 位置的不同，该路径也有所不同。

    例如，您可能会输入此路径作为本地硬盘上数据库的“数据源”值：

    Data Source=C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_assets\data\tutorial.mdb；

    或者您可能会为远程服务器上的数据库输入此路径：

    Data Source=C:\users\Denman\Sites\data\tutorial.mdb；

  7. 删除“用户 ID”和“密码”行。

    Access 数据库不需要用户 ID 和密码。

  8. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请执行以下操作：

    • 复查到数据库的路径。
    • 检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定处理动态页的位置）。
    • 部署支持文件，方法是选择“站点”>“高级”>“部署支持文件”。
    • 查看《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中的数据库连接答疑。
  9. 单击“确定”。

    新连接出现在“数据库”面板上。

为《Dreamweaver 入门》教程设置示例 ASP.NET 应用程序即告完成。有关更多信息，请参见教程：开发 Web 应用程序教程。


示例 ASP 站点的设置

Macromedia Dreamweaver 8 随附有示例 Microsoft Active Server Pages (ASP) Web 页，可以帮助您建立一个小型 Web 应用程序。本章说明如何使用 Microsoft Internet Information Server (IIS) 设置示例应用程序。有关该 Web 服务器的更多信息，请参见安装 Web 服务器。

本章只适用于 ASP 开发人员。有关 ASP.NET 的信息，请参见示例 ASP.NET 站点的设置。

设置 Web 应用程序的过程分为三步。第一步，配置您的系统。第二步，定义 Dreamweaver 站点。第三步，将应用程序连接到您的数据库。本章按照该三步过程对设置进行说明。

本章包含下列章节：

ASP 开发人员的设置清单

配置您的系统 (ASP)

定义 Dreamweaver 站点 (ASP)

连接到示例数据库 (ASP)


ASP 开发人员的设置清单

若要设置 Web 应用程序，您必须配置系统、定义 Dreamweaver 站点并连接到数据库。本节提供每项任务的清单。本章的其余部分将对这些任务进行详细介绍。

配置您的系统：

  1. 确保您具有 Web 服务器。
  2. 安装应用程序服务器。
  3. 测试您的安装。
  4. 创建根文件夹。

定义 Dreamweaver 站点：

  1. 将示例文件复制到您硬盘上的文件夹中。
  2. 将此文件夹定义为 Dreamweaver 本地文件夹。
  3. 将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。
  4. 指定一个处理动态页的文件夹。
  5. 将示例文件上传到 Web 服务器。

连接到数据库：

  1. 如果要将远程计算机用作服务器，请将示例数据库复制到远程计算机。
  2. 在 Dreamweaver 中创建连接。

相关主题

  • 配置您的系统 (ASP)
  • 定义 Dreamweaver 站点 (ASP)
  • 连接到示例数据库 (ASP)


配置您的系统 (ASP)

本节提供 ASP 的两种最常见的系统配置的说明：在一种系统配置中，Microsoft IIS 安装在您的硬盘上；在另一种系统配置中，IIS 安装在远程 Windows 计算机上。

下面的插图显示了本节中所介绍的两种配置：

用于 Windows 用户的本地配置，以及用于 Macintosh 和 Windows 用户的远程服务器配置。

若要配置您的系统，请执行以下操作：

  1. 确保您有 Web 服务器（请参见检查是否存在 Web 服务器）。
  2. 如果需要，安装应用程序服务器（请参见安装 ASP 应用程序服务器）。
  3. 测试您的安装（请参见测试安装）。
  4. 创建根文件夹（请参见创建根文件夹）。

    注意

    安装 Web 服务器和应用程序服务器是只需进行一次的任务。


检查是否存在 Web 服务器

若要开发和测试动态 Web 页，您需要一个 Web 服务器。Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。

确保 Microsoft IIS 安装并运行在您的硬盘或远程 Windows 计算机上。（Macintosh 用户需要将 Microsoft IIS 安装在远程 Windows 计算机上。）一种快速检查计算机上是否安装有 IIS 的方法是查看文件夹结构，看它是否包含 C:\Inetpub 或 D:\Inetpub 文件夹。IIS 在安装过程中将创建该文件夹。

如果未安装 IIS，则现在进行安装。有关说明，请参见安装 Web 服务器。

安装了 Web 服务器之后，您需要安装应用程序服务器。（请参见安装 ASP 应用程序服务器。）


安装 ASP 应用程序服务器

若要处理动态 Web 页，您需要应用程序服务器。应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。当浏览器请求这样一个页时，Web 服务器先将该页传递给应用程序服务器进行处理，然后再发送到浏览器。有关更多信息，请参见了解 Web 应用程序。

如果在 Windows 计算机上安装了 IIS，则不需要单独的 ASP 应用程序服务器。IIS 也可以发挥 ASP 应用程序服务器的功能。有关安装和测试 IIS 的更多信息，请参见安装 Web 服务器。

您应测试服务器以确保它正常工作。（请参见测试安装。）


测试安装

您可以通过运行测试页测试 IIS 的 ASP 引擎。

若要测试 IIS 的 ASP 引擎，请执行以下操作：

  1. 在 Dreamweaver 或任何文本编辑器中，创建一个纯文本文件并将其命名为 timetest.asp。
  2. 在该文件中，输入以下代码：
    <p>This page was created at <b>
<%= Time %>
</b> on the computer running ASP.</p>

    此代码显示在服务器上处理该页的时间。

  3. 将此文件复制到运行 IIS 的 Windows 计算机上的 C:\Inetpub\wwwroot 文件夹中。
  4. 在 Web 浏览器中输入测试页的 URL，然后按回车键。

    如果 IIS 运行在您的本地计算机上，则可以输入以下 URL：

    http://localhost/timetest.asp

测试页应该打开并显示时间，如下所示：

该指定的时间称作动态内容，因为您每次请求该页它都发生变化。单击浏览器上的“刷新”按钮生成具有不同时间的新页。

注意

查看源代码（Internet Explorer 中的“查看”>“源文件”）将确认该页没有使用任何客户端 JavaScript 来实现此效果。

如果该页未按预期方式工作，则检查是否可能存在以下错误：

  • 该文件不具有 .asp 扩展名。
  • 在浏览器的“地址”文本框中键入该页的文件路径 (C:\Inetput\wwwroot\timetest.asp) 而不是其 URL（例如，http://localhost/timetest.asp）。

    如果您（像处理普通 HTML 页那样）在浏览器中键入了文件路径，则将绕过 Web 服务器和应用程序服务器。结果，您的页将无法得到服务器的处理。

  • URL 中包含键入错误。检查是否存在错误并确保文件名后没有斜杠，例如 http://localhost/timetest.asp/。
  • 页代码中包含键入错误。

安装并测试服务器软件之后，为您的 Web 应用程序创建根文件夹。（请参见创建根文件夹。）


创建根文件夹

安装了服务器软件之后，在运行 Microsoft IIS 的系统上为您的 Web 应用程序创建根文件夹，并确保该文件夹具有必要的权限。

若要为您的 Web 应用程序创建根文件夹，请执行以下操作：

  1. 在运行 IIS 的系统上创建一个名为“MySampleApps”的文件夹。

    注意

    写下此文件夹名称，以备将来使用。以后键入时，应确保使用与创建时一致的大小写。

    创建该文件夹的合适位置是 C:\Inetpub\wwwroot\。默认情况下，您的 IIS Web 服务器被设置为从 Inetpub\wwwroot 文件夹提供页。Web 服务器将根据来自 Web 浏览器的 HTTP 请求提供此文件夹中的任何页或其子文件夹中的任何页。

  2. 要确保为该文件夹启用了读权限和脚本权限，请执行以下操作：
    1. 启动 IIS 管理工具（在 Windows XP 中选择“开始”>“控制面板”或者选择“开始”>“设置”>“控制面板”，双击“管理工具”，然后双击“Internet 信息服务”）。
    2. 展开“本地计算机”列表，展开“Web 站点”文件夹，然后展开“默认 Web 站点”文件夹。
    3. 右键单击“MySampleApps”文件夹，然后从弹出式菜单中选择“属性”。
    4. 在“执行权限”弹出式菜单中，确保选择了“仅限脚本”选项。（出于安全原因，请不要选择“脚本和可执行文件”选项。）
    5. 单击“确定”。

现在已完成了 Web 服务器的配置，它将根据来自 Web 浏览器的 HTTP 请求提供根文件夹中的 Web 页。

在配置完系统后，您必须定义 Dreamweaver 站点。（请参见定义 Dreamweaver 站点 (ASP)。）


定义 Dreamweaver 站点 (ASP)

在配置完系统后，将示例文件复制到本地文件夹，并定义 Dreamweaver 站点来管理这些文件。

若要定义 Dreamweaver 站点，请执行以下操作：

  1. 将示例文件复制到您硬盘上的文件夹中（请参见复制示例文件）。
  2. 将该文件夹定义为 Dreamweaver 本地文件夹（请参见定义本地文件夹）。
  3. 将 Web 服务器上的根文件夹定义为 Dreamweaver 远程文件夹（请参见定义远程文件夹）。
  4. 指定一个处理动态页的文件夹（请参见指定处理动态页的位置）。
  5. 将示例文件上传到 Web 服务器（请参见上传示例文件）。


复制示例文件

如果尚未进行此操作，则将示例文件从 Dreamweaver 应用程序文件夹复制到硬盘上的文件夹中。

若要复制示例文件，请执行以下操作：

  1. 在硬盘上的用户文件夹中创建一个名为 local_sites 的新文件夹。

    例如，创建下列文件夹之一：

    • C:\Documents and Setting\your_user_name\My Documents\local_sites (Windows)
    • /Users/your_user_name/Documents/local_sites (Macintosh)。

      注意

      在 Macintosh 上，在用户文件夹中已经有一个名为 Sites 的文件夹。不要使用该 Sites 文件夹作为本地文件夹；该 Sites 文件夹是您在将 Macintosh 用作 Web 服务器时放置页面以使它们可供公开访问的位置。
  2. 在硬盘上的 Dreamweaver 应用程序文件夹中找到 cafe_townsend 文件夹。

    如果将 Dreamweaver 安装到其默认位置，则该文件夹的路径如下所示：

    • 在 Windows 中：C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\。
    • 在 Macintosh 中：Macintosh HD/Applications/Macromedia Dreamweaver 8/Tutorial_assets/cafe_townsend。
  3. 将 cafe_townsend 文件夹复制到 local_sites 文件夹中。

    您将使用 cafe_townsend 文件夹作为 Dreamweaver 站点的根文件夹（主文件夹）。

    复制 cafe_townsend 文件夹之后，将该文件夹定义为 Dreamweaver 本地文件夹。（请参见定义本地文件夹。）


定义本地文件夹

复制 cafe_townsend 文件夹之后，将包含 ASP 示例文件的文件夹定义为 Dreamweaver 本地文件夹。

若要定义 Dreamweaver 本地文件夹，请执行以下操作：

  1. 在 Dreamweaver 中，选择“站点”>“管理站点”。在“管理站点”对话框中，单击“新建”按钮，然后选择“站点”。

    出现“站点定义”对话框。

  2. 如果显示“基本”选项卡，则单击“高级”选项卡。
  3. 在“站点名称”文本框中，输入 Cafe Townsend ASP。

    该名称在 Dreamweaver 中标识您的站点。

  4. 单击“本地根文件夹”文本框旁边的文件夹图标，然后浏览到包含 ASP 示例文件的以下文件夹：
    • C:\Documents and Setting\your_user_name\My Documents\local_sites\cafe_townsend\contact\asp (Windows)
    • /Users/your_user_name/Documents/local_sites/cafe_townsend/contact/asp (Macintosh)
  5. 单击“选择”完成定义 Dreamweaver 本地文件夹。

将“站点定义”对话框保持为打开状态。下一步，将一个 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。（请参见定义远程文件夹。）


定义远程文件夹

在定义了本地文件夹之后，将一个 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。

若要定义 Dreamweaver 远程文件夹，请执行以下操作：

  1. 在“站点定义”对话框中的“高级”选项卡中，选择“类别”列表中的“远程信息”。

    随即显示“远程信息”对话框。

  2. 在“访问”弹出式菜单中，选择将文件移入和移出服务器的方式：通过本地网络（“本地/网络”选项）或使用 FTP。

    注意

    在“访问”弹出式菜单中还有其它选项，但本指南将不对它们进行介绍。有关这些选项的信息，请参见《使用 Dreamweaver》。
  3. 输入您在创建根文件夹中创建的 Web 服务器文件夹的路径或 FTP 设置。

    该文件夹可能位于您的硬盘或远程计算机上。即使您是在硬盘上创建该文件夹，该文件夹仍被视作远程文件夹。如果您选择“本地/网络”访问，并且远程文件夹在 Windows 硬盘上，那么远程文件夹的路径可能如下所示：

    远程文件夹：C:\Inetpub\wwwroot\MySampleApps

    有关 FTP 的更多信息，请参见“使用 Dreamweaver 帮助”中的设置 FTP 访问的远端选项。

将“站点定义”对话框保持为打开状态。下一步，定义一个文件夹以处理动态页。（请参见指定处理动态页的位置。）


指定处理动态页的位置

定义 Dreamweaver 远程文件夹之后，指定处理动态页的文件夹。在您开发应用程序时，Dreamweaver 使用此文件夹显示动态页并连接到数据库。

若要指定处理动态页的文件夹，请执行以下操作：

  1. 在高级“站点定义”对话框中，单击“类别”列表中的“测试服务器”。

    即会出现“测试服务器”屏幕。Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是本地计算机、开发服务器、中间服务器或生产服务器，只要能够处理 ASP 页即可。在许多情况下，包括设置 Cafe Townsend 站点，您都可以使用与“远程信息”类别相同的设置（请参见定义远程文件夹），因为它们指向能够处理 ASP 页的服务器。

  2. 从“服务器模型”弹出式菜单选择“ASP JavaScript”或“ASP VBScript”。
  3. 在“访问”弹出式菜单中，选择您指定的访问远程文件夹的相同方法（“本地/网络”或“FTP”）。

    Dreamweaver 输入您在“远程信息”类别中指定的设置。不要更改这些设置。

  4. 在“URL 前缀”文本框中，输入当在 Web 应用程序中请求页时您将在 Web 浏览器中输入的根 URL。

    若要在您工作时在页中显示动态数据，Dreamweaver 将创建一个临时文件，将其复制到 Web 站点的根文件夹，然后尝试使用 URL 前缀请求该文件。

    Dreamweaver 根据您在“站点定义”对话框中提供的信息对 URL 前缀进行最接近的推测。然而，建议的 URL 前缀可能并不正确。如果 Dreamweaver 中的建议不正确，请更正该 URL 前缀或输入一个新的 URL 前缀。有关更多信息，请参见《使用 Dreamweaver》中的“设置 URL 前缀”。

    如果在“远程文件夹”文本框中指定的文件夹是 C:\Inetpub\wwwroot\MySampleApps，则 URL 前缀应该如下所示：

    http://localhost/MySampleApps/

    提示

    URL 前缀应始终指定一个目录，而不是站点上特定的页。另外，请确保使用与创建该文件夹时一致的大小写。
  5. 单击“确定”定义站点并退出“站点定义”对话框，然后单击“完成”退出“管理站点”对话框。

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。（请参见上传示例文件。）


上传示例文件

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。即使 Web 服务器运行在本地计算机上，您也必须上传这些文件。

如果不上传文件，则某些功能（例如“动态数据”视图和“在浏览器中预览”）对动态页可能不能正常工作。例如，由于图像文件尚未在服务器上，“动态数据”视图中的图像链接可能是断开的。同样，如果服务器上没有详细页，则在浏览器中预览主页时单击指向详细页的链接将导致错误。

若要将示例文件上传到 Web 服务器，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）的“本地视图”窗格中，选择站点的根文件夹。

    根文件夹是列表中的第一个文件夹。

  2. 单击“文件”面板工具栏中的蓝色“上传文件”箭头图标，然后确认您要上传整个站点。

    Dreamweaver 将所有文件复制到您在定义远程文件夹中定义的 Web 服务器文件夹。

这便完成了 Dreamweaver 站点的定义。下一步是连接到随 Dreamweaver 一起安装的示例数据库。（请参见连接到示例数据库 (ASP)。）


连接到示例数据库 (ASP)

在安装过程中，Dreamweaver 将示例 Microsoft Access 数据库复制到您的硬盘。本节介绍如何创建到示例数据库的连接。

注意

有关连接到其它数据库的信息，请参见《使用 Dreamweaver》中的 ASP 开发人员的数据库连接。

若要创建数据库连接，请执行以下操作：

  1. 如果要将远程计算机用作服务器，则在远程计算机上设置示例数据库（请参见设置数据库（远程计算机上的服务器））。
  2. 在 Dreamweaver 中创建连接（请参见创建数据库连接）。


设置数据库（远程计算机上的服务器）

只有在 Web 服务器运行在远程计算机上的情况下本节才适用。如果您的 Web 服务器与 Dreamweaver 运行在同一台计算机上，则跳到创建数据库连接。

在尝试连接到示例数据库之前，请在运行 Web 服务器的远程计算机上执行以下任务：将示例数据库复制到计算机的硬盘并在计算机上创建指向该数据库的 DSN。

若要在远程计算机上设置示例数据库，请执行以下操作：

  1. 将数据库复制至远程计算机的硬盘上。如果将 Dreamweaver 安装到其默认位置，则本地硬盘上数据库文件 (tutorial.mdb) 的路径如下所示：
    • C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\data\tutorial.mdb (Windows)
    • /Applications/Macromedia Dreamweaver 8/Tutorial_assets/cafe_townsend/data/tutorial.mdb (Macintosh)

    您可以将该文件上传到远程计算机上的任何文件夹中，或者可以为它创建一个新文件夹。

    注意

    如果将数据库文件放在远程计算机的 Inetpub 文件夹中，则可能存在安全隐患。最好将文件放在不能公开访问的文件夹中。
  2. 确保在远程计算机上安装了 Microsoft Access Driver 版本 4.0 或更高版本。

    要查看是否已经安装了该驱动程序，请参见《使用 Dreamweaver》中的查看安装在 Windows 系统上的 ODBC 驱动程序。

    如果未安装该驱动程序，请下载 Microsoft 数据访问组件 (MDAC) 2.5 和 2.7 软件包并将其安装在远程计算机上。您可以从 Microsoft Web 站点 http://msdn.microsoft.com/data/mdac/downloads/ 免费下载 MDAC。这些软件包包含最新的 Microsoft 驱动程序，其中包括 Microsoft Access 驱动程序。

    注意

    在安装 MDAC 2.7 前安装 MDAC 2.5
  3. 设置名为“CafeTownsend”的 DSN，该 DSN 指向远程计算机上的示例数据库。

    有关指导，请参见 Microsoft Web 站点上的下列文章：

    • 如果远程计算机运行的是 Windows 2000，请参见文章 300596（网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;300596）。
    • 如果远程计算机运行的是 Windows XP，请参见文章 305599（网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;305599）。

在数据库、数据库驱动程序和 DSN 准备就绪之后，在 Dreamweaver 中创建数据库连接。（请参见创建数据库连接。）


创建数据库连接

设置过程的最后一步是创建数据库连接。

如果您的 Web 服务器运行在本地计算机上，则可以使用 Dreamweaver 在安装过程中创建的数据源名称 (DSN) 快速连接到示例数据库。要了解有关 DSN 的更多内容，请参见《使用 Dreamweaver》中的使用 DSN。

若要在 Dreamweaver 中创建数据库连接，请执行以下操作：

  1. 在 Dreamweaver 中打开任何一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 单击该面板上的加号 (+) 按钮，然后从弹出式菜单中选择“数据源名称 (DSN)”。

    出现“数据源名称 (DSN)”对话框。

  3. 输入 connTownsend 作为连接名称。
  4. （仅限于 Windows）执行下列操作之一：
    • 如果您的服务器运行在本地计算机上，则选择“使用本地 DSN”选项。
    • 如果您的服务器运行在远程系统上，则选择“使用测试服务器上的 DSN”选项。

    Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用测试服务器上的 DSN。

  5. 单击“DSN”按钮，然后从 DSN 列表中选择“CafeTownsend”。

    如果您在 Windows 计算机上使用 Dreamweaver，在安装期间，Dreamweaver 会创建一个名为 CafeTownsend 的 DSN，该 DSN 指向 Dreamweaver 应用程序文件夹中的 Microsoft Access 数据库。

  6. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请执行以下操作：

    • 复查 DSN。
    • 检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定处理动态页的位置）。
    • 查看《使用 Dreamweaver》中的数据库连接答疑。
  7. 单击“确定”。

    新连接出现在“数据库”面板上。

《Dreamweaver 入门》教程中的示例 ASP 应用程序设置过程即告完成。有关更多信息，请参见教程：开发 Web 应用程序教程。


示例 JSP 站点的设置

Macromedia Dreamweaver 8 随附有示例 Java Server Pages (JSP) Web 页，可以帮助您建立一个小型 Web 应用程序。本章介绍一种使用 Microsoft Internet Information Server (IIS) 设置示例应用程序的方法。有关这些 Web 服务器的更多信息，请参见安装 Web 服务器。如果您使用的是其它 Web 服务器，请参见《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中的设置 Web 应用程序。

设置 Web 应用程序的过程分为三步。第一步，配置您的系统。第二步，定义 Dreamweaver 站点。第三步，将应用程序连接到您的数据库。本章按照该三步过程对设置进行说明。

本章包含下列章节：

JSP 开发人员的设置核对表

配置您的系统 (JSP)

定义 Dreamweaver 站点 (JSP)

连接到示例数据库 (JSP)


JSP 开发人员的设置核对表

若要设置 Web 应用程序，您必须配置系统、定义 Dreamweaver 站点并连接到数据库。本节提供每项任务的清单。本章的其余部分将对这些任务进行详细介绍。

配置您的系统：

  1. 确保您具有 Web 服务器。
  2. 安装 JSP 应用程序服务器。
  3. 创建根文件夹。

定义 Dreamweaver 站点：

  1. 将示例文件复制到您硬盘上的文件夹中。
  2. 将此文件夹定义为 Dreamweaver 本地文件夹。
  3. 将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。
  4. 指定一个处理动态页的文件夹。
  5. 将示例文件上传到 Web 服务器。

连接到数据库：

  1. 安装 JDBC-ODBC 桥驱动程序。
  2. 如果要将远程计算机用作服务器，请将示例数据库复制到远程计算机。
  3. 在 Dreamweaver 中创建连接。

相关主题

  • 配置您的系统 (JSP)
  • 定义 Dreamweaver 站点 (JSP)
  • 连接到示例数据库 (JSP)


配置您的系统 (JSP)

本节提供两种常见系统配置的说明：在一种系统配置中，Microsoft IIS 安装在您的硬盘上；在另一种系统配置中，IIS 安装在远程 Windows 计算机上。如果要使用不同的配置，请参见《使用 Dreamweaver》中的设置 Web 应用程序。

下面的插图显示了本节中所介绍的两种配置：

用于 Windows 用户的本地配置，以及用于 Macintosh 和 Windows 用户的远程服务器配置。

若要配置您的系统，请执行以下操作：

  1. 确保您有 Web 服务器（请参见检查是否存在 Web 服务器）。
  2. 安装 JSP 应用程序服务器（请参见安装 JSP 应用程序服务器）。
  3. 创建根文件夹（请参见创建根文件夹）。

    注意

    安装 Web 服务器和应用程序服务器是只需进行一次的任务。


检查是否存在 Web 服务器

若要开发和测试动态 Web 页，您需要一个 Web 服务器。Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。

确保 Microsoft IIS 安装并运行在您的硬盘或远程 Windows 计算机上。（Macintosh 用户需要将 Microsoft IIS 安装在远程 Windows 计算机上。）一种快速检查计算机上是否安装有 IIS 的方法是查看文件夹结构，看它是否包含 C:\Inetpub 或 D:\Inetpub 文件夹。IIS 在安装过程中将创建该文件夹。

如果未安装 IIS，则现在进行安装。有关说明，请参见安装 Web 服务器。

在安装了 Web 服务器之后，请安装应用程序服务器。（请参见安装 JSP 应用程序服务器。）


安装 JSP 应用程序服务器

若要处理动态 Web 页，您需要应用程序服务器。应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。当浏览器请求这样一个页时，Web 服务器先将该页传递给应用程序服务器进行处理，然后再发送到浏览器。有关更多信息，请参见了解 Web 应用程序。

确保 JSP 应用程序服务器安装并运行在运行 IIS 的系统上。（IIS 可能位于您的本地硬盘或远程计算机上。）

如果您没有 JSP 应用程序服务器，则可以从 Macromedia Web 站点下载并安装 Macromedia JRun 的开发人员版本（全功能的 JSP 应用程序服务器），网址为 www.macromedia.com/go/jrun/。

JRun 有 Windows 和 Macintosh 两种版本。但是，本指南不介绍在 Macintosh 上使用 JRun 的知识。

若要安装 JRun，请执行以下操作：

  1. 如果可行，使用管理员帐户登录到 Windows 系统。
  2. 关闭所有打开的应用程序。
  3. 双击 JRun Developer Edition 安装程序文件。

    随即会出现启动屏幕。

  4. 如果您的系统上没有 Java Runtime Environment（Java 运行时环境，JRE），则在启动屏幕上选择该选项进行安装。

    因为 JRun 应用程序服务器依赖于 Java，所以必须首先在将要运行应用程序服务器的系统上安装 JRE。安装了 JRE 之后，您便可以安装 JRun 应用程序服务器了。

  5. 在启动屏幕上选择该选项安装 JRun。
  6. 按照屏幕上的说明完成安装和测试程序的步骤。
  7. 安装完成后，创建一个指向 IIS Web 服务器的 JRun 连接器，方法是选择“开始”>“程序”>“Macromedia JRun 4”>“Web 服务器配置”。

    有关说明，请参见 JRun 文档。

在安装并启动 JRun 之后，为您的 Web 应用程序创建根文件夹。（请参见创建根文件夹。）


创建根文件夹

安装了服务器软件之后，在运行 Microsoft IIS 的系统上为您的 Web 应用程序创建根文件夹，并确保该文件夹具有必要的权限。

若要为您的 Web 应用程序创建根文件夹，请执行以下操作：

  1. 在运行 IIS 的系统上创建一个名为“MySampleApps”的文件夹。

    注意

    写下此文件夹名称，以备将来使用。以后键入时，应确保使用与创建时一致的大小写。

    创建该文件夹的合适位置是 C:\Inetpub\wwwroot\。默认情况下，您的 IIS Web 服务器被设置为从 Inetpub\wwwroot 文件夹提供页。Web 服务器将根据来自 Web 浏览器的 HTTP 请求提供此文件夹中的任何页或其子文件夹中的任何页。

  2. 要确保为该文件夹启用了读权限和脚本权限，执行以下操作：
    1. 启动 IIS 管理工具（在 Windows XP 中选择“开始”>“控制面板”或者选择“开始”>“设置”>“控制面板”，双击“管理工具”，然后双击“Internet 信息服务”）。
    2. 展开“本地计算机”列表，展开“Web 站点”文件夹，然后展开“默认 Web 站点”文件夹。
    3. 右键单击“MySampleApps”文件夹，然后从弹出式菜单中选择“属性”。
    4. 在“执行权限”弹出式菜单中，确保选择了“仅限脚本”选项。（出于安全原因，请不要选择“脚本和可执行文件”选项。）
    5. 单击“确定”。

现在已完成了 Web 服务器的配置，它将根据来自 Web 浏览器的 HTTP 请求提供根文件夹中的 Web 页。

在配置完系统后，您必须定义 Dreamweaver 站点。（请参见定义 Dreamweaver 站点 (JSP)。）


定义 Dreamweaver 站点 (JSP)

在配置完系统后，将示例文件复制到本地文件夹，并定义 Dreamweaver 站点来管理这些文件。

若要定义 Dreamweaver 站点，请执行以下操作：

  1. 将示例文件复制到您硬盘上的文件夹中（请参见复制示例文件）。
  2. 将该文件夹定义为 Dreamweaver 本地文件夹（请参见定义本地文件夹）。
  3. 将 Web 服务器上的根文件夹定义为 Dreamweaver 远程文件夹（请参见定义远程文件夹）。
  4. 指定一个处理动态页的文件夹（请参见指定处理动态页的位置）。
  5. 将示例文件上传到 Web 服务器（请参见上传示例文件）。


定义本地文件夹

复制 cafe_townsend 文件夹之后，将包含 JSP 示例文件的文件夹定义为 Dreamweaver 本地文件夹。

若要定义 Dreamweaver 本地文件夹，请执行以下操作：

  1. 在 Dreamweaver 中，选择“站点”>“管理站点”。在“管理站点”对话框中，单击“新建”按钮，然后选择“站点”。

    出现“站点定义”对话框。

  2. 如果显示“基本”选项卡，则单击“高级”选项卡。
  3. 在“站点名称”文本框中，输入 Cafe Townsend JSP。

    该名称在 Dreamweaver 中标识您的站点。

  4. 单击“本地根文件夹”文本框旁边的文件夹图标，然后浏览到包含 JSP 示例文件的以下文件夹：
    • C:\Documents and Setting\your_user_name\My Documents\local_sites\cafe_townsend \contact\jsp (Windows)
    • /Users/your_user_name/Documents/local_sites/cafe_townsend/contact/jsp (Macintosh)
  5. 单击“选择”完成定义 Dreamweaver 本地文件夹。

将“站点定义”对话框保持为打开状态。下一步，将一个 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。（请参见定义远程文件夹。）


定义远程文件夹

在定义了本地文件夹之后，将一个 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。

若要定义 Dreamweaver 远程文件夹，请执行以下操作：

  1. 在“站点定义”对话框中的“高级”选项卡中，选择“类别”列表中的“远程信息”。

    即会出现“远程信息”屏幕。

  2. 在“访问”弹出式菜单中，选择将文件移入和移出服务器的方式：通过本地网络（“本地/网络”选项）或使用 FTP。

    注意

    在“访问”弹出式菜单中还有其它选项，但本指南将不对它们进行介绍。有关这些选项的信息，请参见《使用 Dreamweaver》。
  3. 输入您在创建根文件夹中创建的 Web 服务器文件夹的路径或 FTP 设置。

    该文件夹可能位于您的硬盘或远程计算机上。即使您是在硬盘上创建该文件夹，该文件夹仍被视作远程文件夹。如果您选择“本地/网络”访问，并且远程文件夹在 Windows 硬盘上，那么远程文件夹的路径可能如下所示：

    远程文件夹：C:\Inetpub\wwwroot\MySampleApps

    有关 FTP 的更多信息，请参见《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中的设置 FTP 访问的远端选项。

将“站点定义”对话框保持为打开状态。下一步，定义一个文件夹以处理动态页。（请参见指定处理动态页的位置。）


指定处理动态页的位置

定义 Dreamweaver 远程文件夹之后，指定处理动态页的文件夹。在您开发应用程序时，Dreamweaver 使用此文件夹显示动态页并连接到数据库。

若要指定处理动态页的文件夹，请执行以下操作：

  1. 在高级“站点定义”对话框中，单击“类别”列表中的“测试服务器”。

    即会出现“测试服务器”屏幕。Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是本地计算机、开发服务器、中间服务器或生产服务器，只要能处理 JSP 页即可。在许多情况下，包括设置 Cafe Townsend 站点，您都可以使用与“远程信息”类别相同的设置（请参见定义远程文件夹），因为它们指向能够处理 JSP 页的服务器。

  2. 从“服务器模型”弹出式菜单中选择“JSP”。
  3. 在“访问”弹出式菜单中，选择您指定的访问远程文件夹的相同方法（“本地/网络”或“FTP”）。

    Dreamweaver 输入您在“远程信息”类别中指定的设置。不要更改这些设置。

  4. 在“URL 前缀”文本框中，输入当在 Web 应用程序中请求页时您将在 Web 浏览器中输入的根 URL。

    若要在您工作时在页中显示动态数据，Dreamweaver 将创建一个临时文件，将其复制到 Web 站点的根文件夹，然后尝试使用 URL 前缀请求该文件。

    Dreamweaver 根据您在“站点定义”对话框中提供的信息对 URL 前缀进行最接近的推测。然而，建议的 URL 前缀可能并不正确。如果 Dreamweaver 中的建议不正确，请更正该 URL 前缀或输入一个新的 URL 前缀。有关更多信息，请参见《使用 Dreamweaver》中的设置 URL 前缀。

    如果在“远程文件夹”文本框中指定的文件夹是 C:\Inetpub\wwwroot\MySampleApps，则 URL 前缀应该如下所示：

    http://localhost/MySampleApps/

    提示

    URL 前缀应始终指定一个目录，而不是站点上特定的页。另外，请确保使用与创建该文件夹时一致的大小写。
  5. 单击“确定”定义该站点，并关闭“站点定义”对话框，然后单击“完成”关闭“管理站点”对话框。

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。（请参见上传示例文件。）


上传示例文件

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。即使 Web 服务器运行在本地计算机上，您也必须上传这些文件。

如果不上传文件，则某些功能（例如“动态数据”视图和“在浏览器中预览”）对动态页可能不能正常工作。例如，由于图像文件尚未在服务器上，“动态数据”视图中的图像链接可能是断开的。同样，如果服务器上没有详细页，则在浏览器中预览主页时单击指向详细页的链接也将导致错误。

若要将示例文件上传到 Web 服务器，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）的“本地视图”窗格中，选择站点的根文件夹。

    根文件夹是列表中的第一个文件夹。

  2. 单击“文件”面板工具栏中的蓝色“上传文件”箭头图标，然后确认您要上传整个站点。

    Dreamweaver 将所有文件复制到您在定义远程文件夹中定义的 Web 服务器文件夹。

这便完成了 Dreamweaver 站点的定义。下一步是连接到随 Dreamweaver 一起安装的示例数据库。（请参见创建数据库连接。）


连接到示例数据库 (JSP)

在安装过程中，Dreamweaver 将示例 Microsoft Access 数据库复制到您的硬盘。本节介绍如何创建到示例数据库的连接。

注意

有关连接到其它数据库的信息，请参见《使用 Dreamweaver》中的用于 JSP 开发人员的数据库连接。

若要创建数据库连接，请执行以下操作：

  1. 安装桥驱动程序（请参见安装桥驱动程序）。
  2. 如果要将远程计算机用作服务器，则在远程计算机上设置示例数据库（请参见设置数据库（远程计算机上的服务器））。
  3. 在 Dreamweaver 中创建连接（请参见创建数据库连接）。


安装桥驱动程序

在尝试连接到示例数据库之前，请在运行 Web 服务器的计算机上安装 Sun JDBC-ODBC Bridge 驱动程序。桥驱动程序允许您使用 Windows 数据源名称 (DSN) 来创建连接。该驱动程序和用于 Windows 的 Sun Java 2 SDK 标准版一起提供。

若要确定是否已具有带有该驱动程序的 Java 2 SDK，请检查您的硬盘上是否有以下目录中的任何一个：

C:\jdk1.2.x

C:\jdk1.3.x

C:\j2sdk1.4.x

注意

术语“Java 2”是指 Java 1.2 及其更高版本。

如果没有 SDK，请从 Sun Web 站点 http://java.sun.com/j2se/ 下载。下载完安装文件之后，双击该文件以运行安装程序。按照屏幕上的说明进行操作并确保在“选择组件”对话框中选择了 Java 2 运行时环境组件。该组件应该是默认选中的。在安装 SDK 时将自动安装驱动程序。

尽管 Sun JDBC-ODBC Bridge 驱动程序用于开发低端数据库系统（例如 Microsoft Access）绰绰有余，但它不适用于进行生产。例如，该驱动程序一次只让一个 JSP 页连接到数据库（它不支持多个线程并发使用）。有关驱动程序限制的更多信息，请参见 Macromedia 支持中心上的 TechNote 17392，网址为 www.macromedia.com/go/17392。

在安装桥驱动程序之后，如果需要，设置数据库（请参见设置数据库（远程计算机上的服务器）），然后在 Dreamweaver 中创建数据库连接。（请参见创建数据库连接。）


设置数据库（远程计算机上的服务器）

只有在 Web 服务器运行在远程计算机上的情况下本节才适用。如果您的 Web 服务器与 Dreamweaver 运行在同一台计算机上，则跳到创建数据库连接。

在尝试连接到示例数据库之前，请在运行 Web 服务器的远程计算机上执行以下任务：将示例数据库复制到计算机的硬盘，在计算机上创建指向该数据库的 DSN，然后在计算机上安装 Sun JDBC-ODBC Bridge 驱动程序。

若要在远程计算机上设置示例数据库，请执行以下操作：

  1. 将数据库复制至远程计算机的硬盘上。如果将 Dreamweaver 安装到其默认位置，则本地硬盘上数据库文件 (tutorial.mdb) 的路径如下所示：
    • C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\data\tutorial.mdb (Windows)
    • /Applications/Macromedia Dreamweaver 8/Tutorial_assets/cafe_townsend/data/tutorial.mdb (Macintosh)

    您可以将该文件上传到远程计算机上的任何文件夹中，或者可以为它创建一个新文件夹。

    注意

    如果将数据库文件放在远程计算机的 Inetpub 文件夹中，则可能存在安全隐患。最好将文件放在不能公开访问的文件夹中。
  2. 确保在远程计算机上安装了 Microsoft Access Driver 版本 4.0 或更高版本。

    要查看是否已经安装了该驱动程序，请参见《使用 Dreamweaver》中的查看安装在 Windows 系统上的 ODBC 驱动程序。

    如果未安装该驱动程序，请下载 Microsoft 数据访问组件 (MDAC) 2.5 和 2.7 软件包并将其安装在远程计算机上。您可以从 Microsoft Web 站点 http://msdn.microsoft.com/data/mdac/downloads/ 免费下载 MDAC。这些软件包包含最新的 Microsoft 驱动程序，其中包括 Microsoft Access 驱动程序。

    注意

    在安装 MDAC 2.7 前安装 MDAC 2.5
  3. 设置名为“CafeTownsend”的 DSN，该 DSN 指向远程计算机上的示例数据库。

    有关指导，请参见 Microsoft Web 站点上的下列文章：

    • 如果远程计算机运行的是 Windows 2000，请参见文章 300596（网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;300596）。
    • 如果远程计算机运行的是 Windows XP，请参见文章 305599（网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;305599）。
  4. 确保在远程计算机上安装了 Sun JDBC-ODBC Bridge 驱动程序。

    您将使用该驱动程序和 DSN 来创建到数据库的连接。有关说明，请参见安装桥驱动程序。

数据库、DSN 和桥驱动程序准备就绪后，在 Dreamweaver 中创建数据库连接。（请参见创建数据库连接。）


创建数据库连接

设置过程的最后一步是创建数据库连接。

若要在 Dreamweaver 中创建数据库连接，请执行以下操作：

  1. 在 Dreamweaver 中打开任何一个 JSP 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 在该面板上单击加号 (+) 按钮并从弹出式菜单中选择“ODBC 数据库（Sun JDBC-ODBC 驱动程序）”。

    即会出现“ODBC 数据库（Sun JDBC-ODBC 驱动程序）”对话框。

  3. 输入 connTownsend 作为连接名称。
  4. （仅限于 Windows）执行下列操作之一：
    • 如果您的服务器运行在本地计算机上，则选择“使用此计算机上的驱动程序”选项。
    • 如果您的服务器运行在远程系统上，则选择“使用测试服务器上的驱动程序”选项。

    Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用测试服务器上的驱动程序。

  5. 用 CafeTownsend 替换“URL”文本框中的 [odbc dsn] 占位符。

    “URL”文本框应类似于：

    jdbc:odbc:CafeTownsend

    如果您在 Windows 计算机上使用 Dreamweaver，在安装期间，Dreamweaver 会创建一个名为 CafeTownsend 的 DSN，该 DSN 指向 Dreamweaver 应用程序文件夹中的 Microsoft Access 数据库。

  6. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请执行以下操作：

    • 复查 DSN 和其它连接参数。
    • 检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定处理动态页的位置）。
    • 查看《使用 Dreamweaver》（“帮助”>“使用Dreamweaver”）中的数据库连接答疑。
  7. 单击“确定”。

    新连接出现在“数据库”面板上。

为《Dreamweaver 入门》教程设置示例 JSP 应用程序即告完成。有关更多信息，请参见教程：开发 Web 应用程序教程。


示例 PHP 站点的设置

Macromedia Dreamweaver 8 随附有示例 PHP 页，可以帮助您建立一个小型 Web 应用程序。本章介绍一种使用 Microsoft Internet Information Server (IIS) 设置示例应用程序的方法。有关该 Web 服务器的更多信息，请参见安装 Web 服务器。如果您使用的是其它 Web 服务器，请参见《使用 Dreamweaver》中的设置 Web 应用程序。

如果您是 Macintosh 用户，则可以使用随您的操作系统一起安装的 Apache Web 服务器和 PHP 应用程序服务器连接到远程 PHP 服务器或者在本地开发 PHP 站点。有关设置信息，请参见以下 Web 站点：

  • http://developer.apple.com/internet/opensource/php.html
  • www.entropy.ch/software/macosx/php/

设置 Web 应用程序的过程分为三步。第一步，配置您的系统。第二步，定义 Dreamweaver 站点。第三步，将应用程序连接到您的数据库。本设置指南按照该三步过程进行说明。

本章包含下列章节：

PHP 开发人员的设置清单

配置您的系统 (PHP)

定义 Dreamweaver 站点 (PHP)

连接到示例数据库 (PHP)


PHP 开发人员的设置清单

若要设置 Web 应用程序，您必须配置系统、定义 Dreamweaver 站点并连接到数据库。本节提供每项任务的清单。本章的其余部分将对这些任务进行详细介绍。

配置您的系统：

  1. 确保您具有 Web 服务器。
  2. 安装 PHP 应用程序服务器。
  3. 测试您的安装。
  4. 创建根文件夹。

定义 Dreamweaver 站点：

  1. 将示例文件复制到您硬盘上的文件夹中。
  2. 将此文件夹定义为 Dreamweaver 本地文件夹。
  3. 将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。
  4. 指定一个处理动态页的文件夹。
  5. 将示例文件上传到 Web 服务器。

连接到数据库：

  1. 创建示例 MySQL 数据库。
  2. 在 Dreamweaver 中创建连接。

相关主题

  • 配置您的系统 (PHP)
  • 定义 Dreamweaver 站点 (PHP)
  • 连接到示例数据库 (PHP)


配置您的系统 (PHP)

您必须先配置系统才可以在其上运行 PHP 页。具体而言，您必须确保 Web 服务器和 PHP 应用程序服务器安装并运行在您的系统上，然后必须为您的 PHP 文件创建根文件夹。

本节包含以下主题：

  • 配置您的 Windows 系统 (PHP)
  • 配置您的 Macintosh 系统 (PHP)


配置您的 Windows 系统 (PHP)

本节提供两种常见 Windows 配置的说明：在一种系统配置中，Microsoft IIS 安装在您的硬盘上；在另一种系统配置中，IIS 安装在远程 Windows 计算机上。如果要使用不同的配置，请参见《使用 Dreamweaver》中的设置 Web 应用程序。

下面的插图显示了本节中所介绍的两种配置：

用于 Windows 用户的本地配置，以及用于 Macintosh 和 Windows 用户的远程服务器配置。

若要配置您的系统，请执行以下操作：

  1. 确保您有 Web 服务器（请参见检查是否存在 Web 服务器 (Windows)）。
  2. 安装 PHP 应用程序服务器（请参见安装 PHP 应用程序服务器 (Windows)）。
  3. 测试您的安装（请参见测试 PHP 安装 (Windows)）。
  4. 创建根文件夹（请参见创建根文件夹 (Windows)）。

    注意

    安装 Web 服务器和应用程序服务器是只需进行一次的任务。


检查是否存在 Web 服务器 (Windows)

若要开发和测试动态 Web 页，您需要一个 Web 服务器。Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。

确保 Microsoft IIS 安装并运行在您的硬盘或远程 Windows 计算机上。一种快速检查计算机上是否安装有 IIS 的方法是查看文件夹结构，看它是否包含 C:\Inetpub 或 D:\Inetpub 文件夹。IIS 在安装过程中将创建该文件夹。

如果未安装 IIS，则现在进行安装。有关说明，请参见安装 Web 服务器。

在安装了 Web 服务器之后，请安装应用程序服务器。（请参见安装 PHP 应用程序服务器 (Windows)。）


安装 PHP 应用程序服务器 (Windows)

若要处理动态 Web 页，您需要应用程序服务器。应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。当浏览器请求这样一个页时，Web 服务器先将该页传递给应用程序服务器进行处理，然后再发送到浏览器。有关更多信息，请参见了解 Web 应用程序。

确保运行 IIS 的系统上安装了 PHP 应用程序服务器并且正在运行。（IIS 可能位于您的硬盘或远程 Windows 计算机上。）您可以从 PHP Web 站点（网址为 www.php.net/downloads.php）下载并安装 PHP 应用程序服务器。

在 PHP 5 中，默认情况下，Windows 安装程序并未安装或启用允许 PHP 处理 MySQL 数据库服务器的扩展。您必须手动安装并启用该扩展。

若要在 Windows 系统上安装 PHP 5，请执行以下操作：

  1. 如果可行，使用管理员帐户登录到 Windows 系统。
  2. 从 PHP Web 站点 www.php.net/downloads.php 下载 Windows PHP 5.x 安装程序。
  3. 双击下载的安装程序文件，并按照屏幕上的安装说明进行操作。
  4. 成功安装 PHP 后，从 PHP Web 站点 www.php.net/downloads.php 下载 Windows PHP 5.x 压缩包，然后将该包解压缩到您硬盘上的临时文件夹中。

    该压缩包包含处理 MySQL 所需的扩展。

  5. 在包含解压缩后的文件的临时文件夹中，找到名为 ext 的文件夹，并将其复制到 C:\PHP\ 文件夹中。

    该 ext 文件夹包含常用 PHP 扩展，包括 MySQL 扩展。

  6. 在 C:\Windows 文件夹中，找到名为 php.ini 的文件，并在记事本中打开该文件。

    必须编辑该文件以启用 MySQL 扩展。

  7. 在 php.ini 文件中找到以下行：

    extension_dir = "./"

    该行指定 PHP 查找扩展的位置。

  8. 编辑该行，如下所示：

    提示

    不要忽略最后的斜杠。

    extension_dir = "C:\PHP\ext\"

  9. 在 php.ini 文件中找到以下行：

    ;extension=php_mysql.dll

    该行开始的分号 (;) 指示 PHP 忽略该行。

  10. 删除该行开始的分号以启用扩展。

    extension=php_mysql.dll

  11. 保存并关闭 php.ini 文件。
  12. 在包含解压缩后的 PHP 文件的临时文件夹中，找到名为 libmysql.dll 的文件，并将其复制到 C:\Windows\system32 文件夹中。

    IIS 处理 PHP 5 和 MySQL 需要该文件。

  13. 重新启动 IIS。

有关启用 MySQL 扩展的更多信息，请访问 PHP Web 站点 www.php.net/manual/en/ref.mysql.php。有关应用程序服务器的更多信息，请参见 PHP 文档，您可以从 PHP Web 站点（网址为 www.php.net/download-docs.php）下载该文档。

安装了 PHP 之后，您可以测试服务器以确保它正常工作。（请参见测试 PHP 安装 (Windows)。）


测试 PHP 安装 (Windows)

您可以通过运行测试页来测试 PHP 应用程序服务器。

若要测试 PHP 应用程序服务器，请执行以下操作：

  1. 在 Dreamweaver 或任何文本编辑器中，创建一个纯文本文件并将其命名为 timetest.php。
  2. 在该文件中，输入以下代码：
    <p>This page was created at <b>
<?php echo date("h:i:s a", time()); ?>
</b> on the computer running PHP.</p>

    此代码显示在服务器上处理该页的时间。

  3. 将此文件复制到运行 IIS 的 Windows 计算机上的 C:\Inetpub\wwwroot 文件夹中。
  4. 在 Web 浏览器中输入测试页的 URL，然后按 Enter 键。

    如果您将 PHP 安装在本地计算机上，则可以输入以下 URL：

    http://localhost/timetest.php

测试页应该打开并显示时间，如下所示：

该指定的时间称作动态内容，因为您每次请求该页它都发生变化。单击浏览器上的“刷新”按钮生成具有不同时间的新页。

注意

查看源代码（Internet Explorer 中的“查看”>“源文件”）将确认该页没有使用任何客户端 JavaScript 来实现此效果。

如果该页未按预期方式工作，则检查是否可能存在以下错误：

  • 该文件不具有 .php 扩展名。
  • 在浏览器的“地址”文本框中键入该页的文件路径 (C:\Inetput\wwwroot\timetest.php) 而不是其 URL（例如，http://localhost/timetest.php）。

    如果您（像处理普通 HTML 页那样）在浏览器中键入了文件路径，则将绕过 Web 服务器和应用程序服务器。结果，您的页将无法得到服务器的处理。

  • URL 中包含键入错误。检查是否存在错误并确保文件名后没有斜杠，例如 http://localhost/timetest.php/。
  • 页代码中包含键入错误。

安装并测试服务器软件之后，为您的 Web 应用程序创建根文件夹。（请参见创建根文件夹 (Windows)。）


创建根文件夹 (Windows)

安装了服务器软件之后，在运行 Microsoft IIS 的系统上为您的 Web 应用程序创建根文件夹，并确保该文件夹具有必要的权限。

若要为您的 Web 应用程序创建根文件夹，请执行以下操作：

  1. 在运行 IIS 的系统上创建一个名为“MySampleApps”的文件夹。

    注意

    写下此文件夹名称，以备将来使用。以后键入时，应确保使用与创建时一致的大小写。

    创建该文件夹的合适位置是 C:\Inetpub\wwwroot\。默认情况下，您的 IIS Web 服务器被设置为从 Inetpub\wwwroot 文件夹提供页。Web 服务器将根据来自 Web 浏览器的 HTTP 请求提供此文件夹中的任何页或其子文件夹中的任何页。

  2. 要确保为该文件夹启用了读权限和脚本权限，执行以下操作：
    1. 启动 IIS 管理工具（在 Windows XP 中选择“开始”>“控制面板”或者选择“开始”>“设置”>“控制面板”，双击“管理工具”，然后双击“Internet 信息服务”）。
    2. 展开“本地计算机”列表，展开“Web 站点”文件夹，然后展开“默认 Web 站点”文件夹。
    3. 右键单击“MySampleApps”文件夹，然后从弹出式菜单中选择“属性”。
    4. 在“执行权限”弹出式菜单中，确保选择了“仅限脚本”选项。（出于安全原因，请不要选择“脚本和可执行文件”选项。）
    5. 单击“确定”。

现在已完成了 Web 服务器的配置，它将根据来自 Web 浏览器的 HTTP 请求提供根文件夹中的 Web 页。

在配置完系统后，您必须定义 Dreamweaver 站点。（请参见定义 Dreamweaver 站点 (PHP)。）


配置您的 Macintosh 系统 (PHP)

如果您是 Macintosh 用户，则可以使用随您的操作系统一起安装的 Apache Web 服务器和 PHP 应用程序服务器在您的计算机上运行 PHP 页。配置系统包括确保 Web 服务器和 PHP 应用程序服务器正在工作以及随后为 PHP 文件创建根文件夹。

本节包含以下主题：

  • 测试 PHP 安装 (Macintosh)
  • 创建根文件夹 (Macintosh)

有关 Macintosh 上的 Apache 和 PHP 的更多信息，请访问以下 Web 站点：

  • http://developer.apple.com/internet/opensource/php.html
  • www.entropy.ch/software/macosx/php/


测试 PHP 安装 (Macintosh)

您可以通过运行测试页测试 Macintosh 上的 Apache Web 服务器和 PHP 应用程序服务器。

但是，在使用 Web 服务器处理 PHP 页和 MySQL 数据库的内容时，必须先配置该服务器，使之能够使用 PHP 和 MySQL。有关此过程的信息，请参见 www.macromedia.com/go/php_macintosh。

若要测试 Apache Web 服务器和 PHP 应用程序服务器，请执行以下操作：

  1. 按照 Macromedia Web 站点上的文章的说明配置该服务器。
  2. 在 Dreamweaver 或任何文本编辑器中，创建一个纯文本文件并将其命名为 timetest.php。
  3. 在该文件中，输入以下代码：
    <p>This page was created at <b>
<?php echo date("h:i:s a", time()); ?>
</b> on the computer running PHP.</p>

    此代码显示在服务器上处理该页的时间。

  4. 将此文件复制到 Macintosh 上的 /Users/your_user_name/Sites 文件夹中。

    该 Sites 文件夹是您的 Apache Web 服务器个人根文件夹。

  5. 在您的 Web 浏览器中，输入以下 URL，然后按 Return 键：

    http://localhost/~your_user_name/timetest.php

测试页应该打开并显示时间，如下所示：

该指定的时间称作动态内容，因为您每次请求该页它都发生变化。单击浏览器上的“刷新”按钮生成具有不同时间的新页。

注意

查看源代码（Safari 中的“查看”>“查看源文件”）将确认该页没有使用任何客户端 JavaScript 来实现此效果。

如果该页未按预期方式工作，则检查是否可能存在以下错误：

  • 该文件不具有 .php 扩展名。
  • URL 中包含键入错误。检查是否存在错误并确保文件名后没有斜杠，例如 http://localhost/~your_user_name/timetest.php/。同时确保您的用户名之前有代字号 (~)。
  • 页代码中包含键入错误。
  • Apache 服务器没有运行。打开“系统首选项”，在“共享”类别中，查看是否启用了“个人 Web 共享”。

测试服务器软件之后，为您的 Web 应用程序创建根文件夹。（请参见创建根文件夹 (Macintosh)。）


创建根文件夹 (Macintosh)

安装服务器软件之后，在 Macintosh 上为您的 Web 应用程序创建根文件夹。

若要为您的 Web 应用程序创建根文件夹，请执行以下操作：

  • 在 /Users/your_user_name/Sites 文件夹中创建一个名为“MySampleApps”的文件夹。

    Apache 将根据来自 Web 浏览器的 HTTP 请求处理此文件夹或其子文件夹中的任何页。

在配置完系统后，您必须定义 Dreamweaver 站点。（请参见定义 Dreamweaver 站点 (PHP)。）


定义 Dreamweaver 站点 (PHP)

在配置完系统后，将示例文件复制到本地文件夹，并定义 Dreamweaver 站点来管理这些文件。

若要定义 Dreamweaver 站点，请执行以下操作：

  1. 将示例文件复制到您硬盘上的文件夹中（请参见复制示例文件）。
  2. 将该文件夹定义为 Dreamweaver 本地文件夹（请参见定义本地文件夹）。
  3. 将 Web 服务器上的根文件夹定义为 Dreamweaver 远程文件夹（请参见定义远程文件夹）。
  4. 指定一个处理动态页的文件夹（请参见指定处理动态页的位置 (PHP)）。
  5. 将示例文件上传到 Web 服务器（请参见上传示例文件）。


定义本地文件夹

复制 cafe_townsend 文件夹之后，将包含 PHP 示例文件的文件夹定义为 Dreamweaver 本地文件夹。

若要定义 Dreamweaver 本地文件夹，请执行以下操作：

  1. 在 Dreamweaver 中，选择“站点”>“管理站点”。在“管理站点”对话框中，单击“新建”按钮，然后选择“站点”。

    出现“站点定义”对话框。

  2. 如果显示“基本”选项卡，则单击“高级”选项卡。
  3. 在“站点名称”文本框中，输入 Cafe Townsend PHP。

    该名称在 Dreamweaver 中标识您的站点。

  4. 单击“本地根文件夹”文本框旁边的文件夹图标，然后浏览到包含 PHP 示例文件的以下文件夹：
    • C:\Documents and Setting\your_user_name\My Documents\local_sites\cafe_townsend\contact\php (Windows)
    • /Users/your_user_name/Documents/local_sites/cafe_townsend/contact/php (Macintosh)
  5. 单击“选择”完成定义 Dreamweaver 本地文件夹。

将“站点定义”对话框保持为打开状态。下一步，将一个 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。（请参见定义远程文件夹。）


定义远程文件夹

在定义了本地文件夹之后，将一个 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。

若要定义 Dreamweaver 远程文件夹，请执行以下操作：

  1. 在“站点定义”对话框中的“高级”选项卡中，选择“类别”列表中的“远程信息”。

    即会出现“远程信息”屏幕。

  2. 在“访问”弹出式菜单中，选择将文件移入和移出服务器的方式：通过本地网络（“本地/网络”选项）或使用 FTP。

    注意

    在“访问”弹出式菜单中还有其它选项，但本章将不对它们进行介绍。有关这些选项的信息，请参见《使用 Dreamweaver》。
  3. 输入您在创建根文件夹 (Windows) 中创建的 Web 服务器文件夹的路径或 FTP 设置。

    该文件夹可能位于您的硬盘或远程计算机上。即使您是在硬盘上创建该文件夹，该文件夹仍被视作远程文件夹。如果您选择“本地/网络”访问，并且远程文件夹在 Windows 硬盘上，那么远程文件夹的路径可能如下所示：

    远程文件夹：C:\Inetpub\wwwroot\MySampleApps

    在 Macintosh 上，该文件夹可能如下所示：

    远程文件夹：/Users/your_user_name/Sites/MySampleApps

    有关 FTP 的更多信息，请参见“使用 Dreamweaver 帮助”中的设置 FTP 访问的远端选项。

将“站点定义”对话框保持为打开状态。下一步，定义一个文件夹以处理动态页。（请参见指定处理动态页的位置 (PHP)。）


指定处理动态页的位置 (PHP)

定义 Dreamweaver 远程文件夹之后，指定处理动态页的文件夹。在您开发应用程序时，Dreamweaver 使用此文件夹显示动态页并连接到数据库。

若要指定处理动态页的文件夹，请执行以下操作：

  1. 在高级“站点定义”对话框中，单击“类别”列表中的“测试服务器”。

    即会出现“测试服务器”屏幕。Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是本地计算机、开发服务器、中间服务器或生产服务器，只要能处理 PHP 页即可。在许多情况下，包括设置 Cafe Townsend 站点，您都可以使用与“远程信息”类别相同的设置（请参见定义远程文件夹），因为它们指向能够处理 PHP 页的服务器。

  2. 从“服务器模型”弹出式菜单中选择“PHP MySQL”。
  3. 在“访问”弹出式菜单中，选择您指定的访问远程文件夹的相同方法（“本地/网络”或“FTP”）。

    Dreamweaver 输入您在“远程信息”类别中指定的设置。不要更改这些设置。

  4. 在“URL 前缀”文本框中，输入当在 Web 应用程序中请求页时您将在 Web 浏览器中输入的根 URL。

    若要在您工作时在页中显示动态数据，Dreamweaver 将创建一个临时文件，将其复制到 Web 站点的根文件夹，然后尝试使用 URL 前缀请求该文件。

    Dreamweaver 根据您在“站点定义”对话框中提供的信息对 URL 前缀进行最接近的推测。然而，建议的 URL 前缀可能并不正确。如果 Dreamweaver 中的建议不正确，请更正该 URL 前缀或输入一个新的 URL 前缀。有关更多信息，请参见《使用 Dreamweaver》（“帮助”>“使用 Dreamweaver”）中的设置 URL 前缀。

    对于 Windows 中的 PHP 示例内容，前缀应该如下所示：

    URL 前缀：http://localhost/MySampleApps/

    在 Macintosh 上，前缀应该如下所示：

    URL 前缀：http://localhost/~your_user_name/MySampleApps/

    提示

    URL 前缀应始终指定一个目录，而不是站点上特定的页。另外，请确保使用与创建该文件夹时一致的大小写。
  5. 单击“确定”定义站点并退出“站点定义”对话框，然后单击“完成”退出“管理站点”对话框。

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。（请参见上传示例文件。）


上传示例文件

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。即使 Web 服务器运行在本地计算机上，您也必须上传这些文件。

如果不上传文件，则某些功能（例如“动态数据”视图和“在浏览器中预览”）对动态页可能不能正常工作。例如，由于图像文件尚未在服务器上，“动态数据”视图中的图像链接可能是断开的。同样，如果服务器上没有详细页，则在浏览器中预览主页时单击指向详细页的链接也将导致错误。

若要将示例文件上传到 Web 服务器，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）的“本地视图”窗格中，选择站点的根文件夹。

    根文件夹是列表中的第一个文件夹。

  2. 单击“文件”面板工具栏中的蓝色“上传文件”箭头图标，然后确认您要上传整个站点。

    Dreamweaver 将所有文件复制到您在定义远程文件夹中定义的 Web 服务器文件夹。

这便完成了 Dreamweaver 站点的定义。下一步是连接到随 Dreamweaver 一起安装的示例数据库。（请参见连接到示例数据库 (PHP)。）


连接到示例数据库 (PHP)

在安装过程中，Dreamweaver 将 SQL 脚本复制到您的硬盘。您可以使用此脚本自动创建示例 MySQL 数据库。本节介绍如何创建到示例数据库的连接。

本节假设您已在本地或远程计算机上安装并配置了 MySQL。若要下载和安装数据库系统，请访问 MySQL Web 站点，网址为 www.mysql.com。

若要创建数据库连接，请执行以下操作：

  1. 使用 SQL 脚本创建示例 MySQL 数据库（请参见创建 MySQL 数据库）。
  2. 在 Dreamweaver 中创建连接（请参见创建数据库连接）。


创建 MySQL 数据库

Dreamweaver 的示例文件包含能够创建和填充示例 MySQL 数据库的 SQL 脚本。

在开始之前，确保在本地或远程计算机上安装并配置了 MySQL。从 MySQL Web 站点 http://dev.mysql.com/downloads/ 下载最新的版本。为了开发，请下载并安装 MySQL 数据库服务器的 Windows Essentials 版本。

若要创建示例 MySQL 数据库，请执行以下操作：

  1. 将 SQL 脚本文件 (insert.sql) 复制到安装有 MySQL 的计算机上的相应文件夹中。

    如果将 Dreamweaver 安装到其默认位置，则该脚本文件夹的路径如下所示：

    • C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\data\insert.sql (Windows)
    • /Applications/Macromedia Dreamweaver 8/Tutorial_assets/cafe_townsend/data/insert.sql (Macintosh)

    如果运行 MySQL 的是 Windows 计算机，则将 insert.sql 脚本复制到 Program Files\MySQL\MySQL Server 4.x\bin。如果运行 MySQL 的是 Macintosh 计算机，则将 insert.sql 脚本复制到主文件夹中的“Documents”文件夹。

  2. 在安装了 MySQL 的计算机上，启动 MySQL 命令行客户端 (Windows) 或终端 (Macintosh)。
    • 在 Windows 中，启动 MySQL 命令行客户端，方法是选择“开始”>“MySQL”>“MySQL Server 4.x”>“MySQL 命令行客户端”。
    • 在 Macintosh 中，通过转到“应用程序”文件夹，打开“实用程序”文件夹，然后双击“终端”，可以启动“终端”。
  3. 在 Windows 中，输入您的用户名（如果有）和密码，然后按 Enter 键。

    即会显示 MySQL 客户端的命令提示符，如下所示：

    mysql>
  4. 在 Macintosh 中，输入以下命令：
    mysql -uUser -pPassword

    例如，如果您的 MySQL 用户名（也称作帐户名）和密码分别为“Tara”和“Telly3”，则输入以下命令：

    mysql -uTara -pTelly3

    如果您没有密码，则省略 -p 参数，如下所示：

    mysql -uTara

    如果您在配置 MySQL 安装时未定义用户名，则输入“root”作为用户名，如下所示：

    mysql -uroot

    即会显示 MySQL 客户端的命令提示符，如下所示：

    mysql>
  5. 通过在 MySQL 提示符处输入以下命令创建一个新数据库：
    mysql>CREATE DATABASE CafeTownsend;

    MySQL 将创建一个新数据库，但它尚不包含任何表或记录。

  6. 通过在提示符处输入以下命令从 MySQL 客户端注销：
    mysql>quit;
  7. (Windows) 打开 Windows 命令提示窗口，方法是选择“开始”>“运行”，然后在“运行”对话框中输入 cmd。
  8. 在系统命令提示符下，填充 MySQL 中的新 CafeTownsend 数据库。

    在 Windows 中，使用如下命令：

    cd \
cd Program Files\MySQL\MySQL Server 4.x\bin
mysql -uUser -pPassword CafeTownsend < insert.sql

    在 Macintosh 中，使用如下命令：

    mysql -uUser -pPassword CafeTownsend < ~/Documents/insert.sql

    此命令使用 insert.sql 文件将表和记录添加到您在步骤 5 中创建的 CafeTownsend 数据库。

创建了 MySQL 数据库之后，在 Dreamweaver 中创建到该数据库的数据库连接。（请参见创建数据库连接。）


创建数据库连接

设置过程的最后一步是创建数据库连接。

若要在 Dreamweaver 中创建数据库连接，请执行以下操作：

  1. 在 Dreamweaver 中打开任何一个 PHP 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 单击面板上的加号 (+) 按钮并从弹出式菜单中选择“MySQL 连接”。

    即会出现“MySQL 连接”对话框。

  3. 输入 connTownsend 作为连接名称。
  4. 在“MySQL 服务器”文本框中，指定承载 MySQL 的计算机。

    输入 IP 地址或服务器名称。如果 MySQL 与 Dreamweaver 运行在同一台计算机上，则输入 localhost。

  5. 输入您的 MySQL 用户名和密码。

    如果您在配置 MySQL 安装时未定义用户名，则在“用户名”文本框中输入 root。如果您没有密码，则将“密码”文本框留空。

  6. 在“数据库”文本框中，输入 CafeTownsend。

    CafeTownsend 是您创建的示例 MySQL 数据库的名称（请参见创建 MySQL 数据库）。

  7. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请执行以下操作：

    • 复查服务器名称、用户名和密码。
    • 检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定处理动态页的位置 (PHP)）。
    • 查看《使用 Dreamweaver》（“帮助”>“使用Dreamweaver”）中的数据库连接答疑。
  8. 单击“确定”。

    新连接出现在“数据库”面板上。

为《Dreamweaver 入门》教程设置示例 PHP 应用程序即告完成。有关更多信息，请参见教程：开发 Web 应用程序教程。


Dreamweaver 基础

学习如何使用 Macromedia Dreamweaver 8 文档和其它资源，以及了解如何设置 Dreamweaver 工作区使其符合您自己的工作习惯。然后计划并设置站点，开始创建页面。

此部分包含以下各章：

简介

了解工作区

设置 Dreamweaver 站点

创建和打开文档


简介

Macromedia Dreamweaver 8 是一款专业的 HTML 编辑器，用于对 Web 站点、Web 页和 Web 应用程序进行设计、编码和开发。无论您愿意享受手工编写 HTML 代码时的驾驭感还是偏爱在可视化编辑环境中工作，Dreamweaver 都会为您提供有用的工具，使您拥有更加完美的 Web 创作体验。

利用 Dreamweaver 中的可视化编辑功能，您可以快速地创建页面而无需编写任何代码。您可以查看所有站点元素或资源并将它们从易于使用的面板直接拖到文档中。您可以在 Macromedia Fireworks 或其他图形应用程序中创建和编辑图像，然后将它们直接导入 Dreamweaver，或者添加 Macromedia Flash 对象，从而优化您的开发工作流程。

Dreamweaver 还提供了功能全面的编码环境，其中包括代码编辑工具（例如代码颜色和标签完成），以及有关层叠样式表 (CSS)、JavaScript 和 ColdFusion 标记语言 (CFML) 等的语言参考资料。Macromedia 的可自由导入导出 HTML 技术可导入您手工编码的 HTML 文档而不会重新设置代码的格式，您可以随后用您首选的格式设置样式来重新设置代码的格式。

Dreamweaver 还使您可以使用服务器技术（如 CFML、ASP.NET、ASP、JSP 和 PHP）生成由动态数据库支持的 Web 应用程序。

Dreamweaver 可以完全自定义。您可以创建您自己的对象和命令，修改快捷键，甚至编写 JavaScript 代码，用新的行为、属性检查器和站点报告来扩展 Dreamweaver 的功能。

本章包含下列章节：

Dreamweaver 8 中的新功能

从哪里开始

Dreamweaver 创建 Web 站点的工作流程

与其他应用程序一起使用 Dreamweaver

Dreamweaver 和辅助功能

Dreamweaver 教学媒体指南

字形约定

HTML 和 Web 技术资源


Dreamweaver 8 中的新功能

Dreamweaver 8 包含了许多新增的功能，这些新增功能改善了软件的易用性，并使您无论处于设计环境还是编码环境都可以方便地制作页面。

首先，Dreamweaver 8 为最佳做法和业界标准提供了支持，其中包括对高级 CSS 使用、XML 和 RSS 源以及辅助功能要求的支持。

使用最佳做法
利用 XML 数据进行可视化创作 | 使用功能强大的可视化工具，可快速利用 XML 将源集成到工作中，并揭开 XML 到 HTML 转换的神秘面纱。使用简单的拖放工作流程，可将基于 XML 的数据（如 RSS 源）集成到 Web 页中。使用改善的 XML 和 XSLT 代码提示功能，可跳转到“代码”视图来自定义转换。有关更多信息，请参见在 Web 页面中显示 XML 数据。
新的标准 CSS 面板 | 可以通过新的标准 CSS 面板集中学习、了解和使用以可视化方式应用于页面的 CSS 样式。全部 CSS 功能已合并到一个面板集合中，并已得到增强，可以更加轻松、更有效率地使用 CSS 样式。使用新的界面可以更方便地看到应用于具体元素的样式层叠，从而能够轻松地确定在何处定义了属性。属性网格允许进行快速编辑。有关更多信息，请参见使用“CSS 样式”面板。
CSS 布局可视化 | 在设计时应用可视化助理来描画 CSS 布局边框或为 CSS 布局加上颜色。应用可视化助理可揭示出复杂的嵌套方案，并改善所选内容。单击 CSS 布局可看到十分有用的工具提示，这些提示有助于了解设计的控制元素。请参见使用 CSS 对页进行布局。
“样式呈现”工具栏 | 利用新的 CSS 媒体类型支持，可按照与用户所看到内容相同的方式查看内容，而不管传送机制如何。使用“样式呈现”工具栏可切换到“设计”视图，以查看它在印刷品、手持设备或屏幕上的显示方式。请参见“样式呈现”工具栏。
改善的 CSS 呈现功能 | “设计”视图的准确性有了显著改善，从而能够在大多数浏览器中呈现复杂的 CSS 布局。Dreamweaver 现在完全支持高级 CSS 技术，如溢出、伪元素和表单元素。
辅助功能：支持 WCAG/W3C 优先级 2 检查点 | 除了第 508 款和 WCAG 优先级 1 检查点的集成辅助功能评估工具外，Dreamweaver 现在还利用包括 WCAG 优先级 2 检查点在内的升级评估工具同时支持 CSS 和辅助功能。
改进的 WebDAV | Dreamweaver 8 中的 WebDAV 现在支持为安全文件传送使用摘要身份验证和 SSL，并且连接也有所改善，可连接到更多的服务器。请参见使用 WebDAV 存回和取出文件。

利用经过优化的用户工作流程（缩短了完成常见任务所需的时间），可以在更短的时间内完成更多的工作。Dreamweaver 8 消除了完成一些繁琐操作的麻烦，因此您能够花费更多的时间来设计和开发出色的 Web 站点和应用程序。

完成更多工作
后台文件传输 | 在 Dreamweaver 8 将文件上载到服务器时继续工作。有关更多信息，请参见管理文件传输。
缩放 | 使用缩放可以更好地控制设计。放大并检查图像，或使用复杂的嵌套表格布局。缩小可预览页面的显示方式。有关更多信息，请参见放大和缩小。
辅助线 | 使用辅助线来测量页面布局，将页面布局和页面模型加以比较，精度可达至像素级别。可视化反馈有助于准确地测量距离，并且支持智能靠齐。有关更多信息，请参见使用辅助线。
“编码”工具栏 | 新的“编码”工具栏在“代码”视图一侧的沟槽栏中提供了用于常见编码功能的按钮。有关更多信息，请参见使用编码工具栏迅速插入代码。
代码折叠 | 通过隐藏和展开代码块，重点显示您想要查看的代码。有关更多信息，请参见折叠和展开代码片断。
工作区布局 | 自定义和保存工作区配置。Dreamweaver 8 自带了针对设计人员和编码人员的需求定制的四种不同配置。也可以构建自定义工作区。有关更多信息，请参见保存自定义工作区布局。
用于 Mac 的选项卡式文档 | Mac 上新的文档选项卡可帮助简化用户界面，并使选择文档变得更加容易。有关更多信息，请参见显示选项卡式文档 (Macintosh)。
新的起始页面 | 新的布局和设计使您能够快速地创建站点。
改进的站点同步和存回/取出功能 | 更可靠并且更有把握地管理站点。改进的站点同步功能有助于确保所使用的文件是最新版本。利用改进的存回/取出功能，可防止意外覆盖其他人的工作。有关更多信息，请参见同步本地和远端站点上的文件。
比较文件 | 快速比较文件以确定变更之处。可以比较两个本地文件、本地计算机上的文件和远程计算机上的文件，或者远程计算机上的两个文件。在 Macintosh 和 Windows 平台上，将您最常用的文件比较工具和 Dreamweaver 结合使用。有关更多信息，请参见比较文件的差别。
选择性粘贴 | 利用 Dreamweaver 中新的粘贴选项，您可以保留在 Microsoft Word 中创建的所有源格式设置，也可以只粘贴文本。有关更多信息，请参见将文本添加到文档中。
站点相关引用 | 通过确保引用与站点（而不是本地文件）相关，从而可在设计时和运行时与服务器端包括紧密结合使用。有关更多信息，请参见设置新链接的相对路径。
改进的代码编辑功能 | 可更好地控制 Dreamweaver 如何提供代码提示和完全标签以适合您的编码风格。有关更多信息，请参见设置代码提示首选参数选项。

Dreamweaver 8 支持学习和利用新的技术，其中包括 PHP 5、Flash 视频、ColdFusion MX 7 和 Macromedia Web Publishing System。

与最新技术和标准集成
支持 ColdFusion MX 7 | 更新的 ColdFusion MX 7 支持功能包括新的服务器行为和代码提示。为了将代码提示和调试功能与 ColdFusion 的正确版本相匹配，Dreamweaver 将在第一次连接到站点时自动检测服务器版本。Dreamweaver 与 ColdFusion 的紧密集成使您能够直接从“数据库”面板中添加和删除数据库，并查看当前站点中定义的 ColdFusion 专有组件。有关更多信息，请参见启用 ColdFusion 增强功能。
支持 PHP 5 | 利用更新的 PHP 5 支持功能，其中包括服务器行为和代码提示。
Flash 视频 | 快速便捷地将 Flash 视频文件插入 Web 页。有关更多信息，请参见插入 Flash 视频内容。
Macromedia Web Publishing System：通知和事件记录 | 跟踪在站点内进行的每项操作。Dreamweaver 中的事件可通知 Macromedia Web Publishing System 服务器，以便记录 WPS 系统中的所有 Web 站点变更。
O'Reilly 提供的更新参考资料 | 参考新的 XML、XSLT 和 Xpath 参考内容，以及 ASP 和 JSP 的更新内容。


从哪里开始

Dreamweaver 文档包含为各个不同背景的读者提供的信息。若要充分利用该文档，请首先阅读对您最适合的部分。

有关 Dreamweaver 资源的信息，请参见 Dreamweaver 教学媒体指南。

本节包含以下主题：

  • Web 设计初学者
  • 有经验的 Web 设计人员
  • 有经验的手工编码人员
  • Web 应用程序开发人员


Web 设计初学者

如果您对 Web 设计比较生疏，本节将给您指出 Dreamweaver 文档中最适合您的背景的章节。

对于 Web 设计初学者：

  1. 从阅读《Dreamweaver 入门》中的教程开始。
  2. 在“使用 Dreamweaver”（“帮助”>“使用 Dreamweaver”）中，请阅读了解工作区、设置 Dreamweaver 站点、管理您的文件和创建和打开文档。
  3. 通过阅读在“布局模式”对页进行布局了解页面布局。
  4. 若要了解如何设置文本格式和在页面中包含图像，请阅读插入文本和设置文本格式和插入图像。

如果您要开始创作高质量的 Web 站点，则只需了解上述内容，但如果您准备了解如何使用更为高级的工具，则可以按顺序阅读“使用 Dreamweaver”中的静态页章节的其余部分。最好在较为了解如何创建 Web 页后，才开始阅读动态页章节。


有经验的 Web 设计人员

如果您是个有经验的 Web 设计者，本节将给您指出 Dreamweaver 文档中最适合您的背景的章节。有两种不同的方法：一种针对不熟悉 Dreamweaver 的设计者，另一种针对熟悉 Dreamweaver 但是想了解有关创建动态页的更多内容的设计者。

对于有经验但不熟悉 Dreamweaver 的 Web 设计人员：

  1. 从阅读《Dreamweaver 入门》中的教程开始。
  2. 在“使用 Dreamweaver”中，请阅读了解工作区，详细了解 Dreamweaver 的用户界面。
  3. 虽然您可能已熟悉设置 Dreamweaver 站点和管理您的文件中的许多内容，但还应大致浏览这些章节，以了解这些熟悉的概念在 Dreamweaver 中是如何实现的。尤其请注意有关设置 Dreamweaver 站点的章节。
  4. 有关使用 Dreamweaver 创建基本的 HTML 页的详细内容的有用信息，请阅读插入文本和设置文本格式和插入图像。
  5. 有关在 Dreamweaver 中进行编码的信息，请参见设置您的编码环境、在 Dreamweaver 中编写代码、优化和调试代码和在设计视图中编辑代码。
  6. 请阅读《使用 Dreamweaver》中其他每一章开头的概述，确定您是否对其中的主题感兴趣。

对于有经验、熟悉 Dreamweaver 但要详细了解如何创建动态页的 Web 设计者：

  1. 从阅读《Dreamweaver 入门》中的了解 Web 应用程序和教程：开发 Web 应用程序教程开始。
  2. 在《使用 Dreamweaver》中，大致浏览了解工作区以了解 Dreamweaver 用户界面的新内容，然后阅读为可视化开发优化工作区。
  3. 通过阅读动态页设计工作流程来熟悉制作动态页的 Dreamweaver 工作流程。
  4. 设置 Web 服务器和应用程序服务器。（请参见设置 Web 应用程序。）
  5. 连接到数据库。（请参见连接到数据库。）
  6. 请阅读《使用 Dreamweaver》中各章开头的概述，确定您是否对其中的主题感兴趣。
  7. 如果您对手动自定义 Dreamweaver 感兴趣，请阅读 Macromedia 支持中心上的《自定义 Dreamweaver》，网址为：www.macromedia.com/go/customizing_dreamweaver_cn。如果要为 Dreamweaver 编写功能扩展，请阅读“扩展 Dreamweaver”。


有经验的手工编码人员

如果您是个有经验的手工编码人员，本节将给您指出 Dreamweaver 文档中最适合您的背景的章节。

对于有经验的手工代码编写者：

  1. 在《使用 Dreamweaver》中，请阅读了解工作区，详细了解 Dreamweaver 的用户界面。
  2. 虽然您可能已熟悉设置 Dreamweaver 站点和管理您的文件中的许多内容，但还请大致浏览这些章节，以了解这些熟悉的概念在 Dreamweaver 中是如何实现的。尤其请注意有关设置 Dreamweaver 站点的章节。
  3. 请在设置您的编码环境、在 Dreamweaver 中编写代码、优化和调试代码和在设计视图中编辑代码中阅读更多有关使用 Dreamweaver 编码的内容。
  4. 请阅读“使用 Dreamweaver”中各章开头的概述，确定您是否对其中的主题感兴趣。


Web 应用程序开发人员

如果您是 Web 应用程序开发人员，本节将给您指出 Dreamweaver 文档中最适合您的背景的章节。根据您以前是否使用过 Dreamweaver，可以采用两种不同的方法。

对于没有使用过 Dreamweaver 的 Web 应用程序开发人员：

  1. 首先快速阅读《Dreamweaver 入门》，以便熟悉使用 Dreamweaver 的基本知识。
  2. 在“使用 Dreamweaver”中，请阅读了解工作区，详细了解 Dreamweaver 的用户界面。
  3. 虽然您可能已熟悉设置 Dreamweaver 站点和管理您的文件中的许多内容，但还请大致浏览这些章节，以了解这些熟悉的概念在 Dreamweaver 中是如何实现的。尤其请注意有关设置 Dreamweaver 站点的章节。
  4. 使用 Dreamweaver 设置 Web 服务器和应用程序服务器。（请参见设置 Web 应用程序。）
  5. 连接到数据库。（请参见连接到数据库。）
  6. 请阅读“使用 Dreamweaver”中各章开头的概述，确定您是否对其中的主题感兴趣。

对于有经验且使用过 Dreamweaver 的 Web 应用程序开发人员：

  1. 首先阅读 Dreamweaver 8 中的新功能。
  2. 在《使用 Dreamweaver》中，大致浏览了解工作区以了解 Dreamweaver 用户界面的新内容。
  3. 如果您对手动自定义 Dreamweaver 感兴趣，请阅读 Macromedia 支持中心上的“自定义 Dreamweaver”，网址为：www.macromedia.com/go/customizing_dreamweaver_cn。如果要为 Dreamweaver 编写功能扩展，请阅读《扩展 Dreamweaver》。


Dreamweaver 创建 Web 站点的工作流程

可以用多种方式创建 Web 站点。本文档中介绍的工作流程首先定义站点的策略或目标。如果您正在开发 Web 应用程序，则必须根据需要设置服务器和数据库。然后再设计该站点的外观。当外观设计完成后，将生成该站点并编写页代码，以添加内容和交互控件；然后将页面链接在一起，并对该站点进行功能测试，以验证它是否符合定义的目标。您还可以在站点中包含动态页。在这一工作流程的最后，在服务器上发布该站点。许多开发人员还会安排定期的维护，以确保站点保持最新并且工作正常。

本节包含以下主题：

  • 规划站点
  • 管理您的站点文件
  • 设计 Web 页面布局
  • 向页面添加内容
  • 手工编码
  • 设置 Web 应用程序
  • 创建动态页
  • 快速开发应用程序


规划站点

如果在一开始就对站点进行仔细的规划和组织，将可以为后期的工作节约时间。组织站点不仅包括确定将在哪里发布文件，还包括检查站点要求、访问者情况以及站点目标。此外，还应考虑诸如用户访问以及浏览器、插件和下载限制等技术要求。

当组织好信息并确定结构后，就可以开始创建站点。

  • 使用 Dreamweaver“文件”面板设置站点的组织结构。在“文件”面板中，您可以方便地添加、删除和重命名文件及文件夹，以根据需要更改组织结构。（请参见设置 Dreamweaver 站点和管理您的文件。）
  • 您可以开始创建简单的页面，随后可将这些页面转换为更复杂的设计。创建新的空白页或根据预先设计的页面设计创建页面。（请参见创建和打开文档。）

如果您是在 Web 开发小组中工作，可能还会对以下主题感兴趣：

  • 设置一个系统以防止小组成员覆盖文件。（请参见存回和取出文件。）
  • 使用设计备注与 Web 小组成员沟通。（请参见在设计备注中存储文件信息。）


管理您的站点文件

Dreamweaver“文件和资源”面板使您可以轻松管理站点文件。

  • 在 Dreamweaver“文件”面板中，您可以找到多个工具来管理站点，向远程服务器和从远程服务器传输文件，设置存回/取出过程来防止文件被覆盖，以及同步本地和远程站点上的文件。（请参见管理您的文件。）
  • 使用“资源”面板可方便地组织站点中的资源；然后可以将大多数资源直接从“资源”面板拖到 Dreamweaver 文档中。（请参见管理站点资源和库。）
  • 您可以使用 Dreamweaver 管理 Contribute 站点的各个方面。（请参见使用 Dreamweaver 管理 Contribute 站点。）


设计 Web 页面布局

当您创建实体模型并设计页面的最终布局时，Dreamweaver 为您提供了很大的灵活性。选择您要使用的布局方法，或综合使用 Dreamweaver 布局选项创建站点的外观。

  • 可以使用 Dreamweaver 层或 CSS 定位样式创建布局。（请参见使用 CSS 对页进行布局。）
  • 利用 Dreamweaver 中的表格工具和布局模式，您可以通过拖动并重新安排页面结构来快速地设计 Web 页。（请参见使用表格显示内容和在“布局模式”对页进行布局。）
  • 如果要在 Web 浏览器中同时显示多个文档，则可以使用框架对文档进行布局。（请参见使用框架。）
  • Dreamweaver 模板使您可以方便地将可重新使用的内容和页面设计应用于站点。您可以基于 Dreamweaver 模板创建新的页面，然后在模板更改时自动更新这些页面的布局。（请参见管理模板。）


向页面添加内容

利用 Dreamweaver，您可以方便地在 Web 页中添加多种内容。添加资源和设计元素，如文本、图像、颜色、影片以及其他形式的媒体。

  • Dreamweaver 页面创建功能使您可以指定 Web 页的属性，如页标题、背景图像和颜色。此外，Dreamweaver 还提供了工具以帮助您最优化 Web 站点的性能，并且测试页面以确保能够兼容不同的 Web 浏览器。（请参见使用页面。）
  • 在 Dreamweaver 文档中直接键入或从其他文档中导入文本，然后使用 Dreamweaver 属性检查器设置文本格式。您也可以方便地创建您自己的层叠样式表。（请参见插入文本和设置文本格式。）
  • 插入图像（包括鼠标经过图像、图像地图和 Fireworks 切割图像），然后使用对齐工具在页面上定位图像。您也可以直接在 Dreamweaver 中调整图像的大小。（请参见插入图像和使用其它应用程序。）
  • 利用 Dreamweaver，您可以创建标准的 HTML 链接（包括锚记链接和电子邮件链接），也可以方便地设置图形导航系统（如跳转菜单和导航条）。（请参见链接与导航。）
  • 在 Web 页中插入其他类型的媒体，如 Flash、Shockwave 和 QuickTime 影片、声音和applets。（请参见添加音频、视频和交互式元素。）
  • 使用行为来控制任务执行以响应特定的事件，例如当访问者在按钮上移过鼠标时高亮显示该按钮，在访问者单击“提交”按钮时验证表单，或者在主要页完成加载时打开另一个浏览器窗口。（请参见使用 JavaScript 行为。）


手工编码

手工编写 Web 页代码是创建页的另一种方法。Dreamweaver 提供了易于使用的可视化编辑工具，但同时也提供了高级的编码环境；您可以采用任一种方法（或同时采用这两种方法）来创建和编辑页面。

  • 您可以在没有可视化工具的编码环境中工作；编码工具将帮助您创建和编辑代码，设置代码格式，确保代码符合标准。（请参见设置您的编码环境、在 Dreamweaver 中编写代码和优化和调试代码。）
  • 您也可以在“设计”视图这一可视化设计环境中使用某些 Dreamweaver 编码工具。（请参见在设计视图中编辑代码。）


设置 Web 应用程序

许多 Web 站点都包含了动态页，动态页使访问者能够查看存储在数据库中的信息，并且一般会允许某些访问者在数据库中添加新信息或编辑信息。若要创建动态页，则必须先完成几个预备步骤。

  • 设置一个 Web 服务器和应用程序服务器，然后创建或修改 Dreamweaver 站点。（请参见设置 Web 应用程序。）
  • 连接到数据库。（请参见连接到数据库）。


创建动态页

在 Dreamweaver 中，您可以定义动态内容的多种来源，其中包括从数据库提取的记录集、表单参数和 JavaBeans 组件。若要在页面上添加动态内容，只需将该内容拖动到页面上即可。

您可以通过设置页面来同时显示一个记录或多个记录，显示多页记录，添加用于在记录页之间来回移动的特殊链接，以及创建记录计数器来帮助用户跟踪记录。

  • 如果您不熟悉如何在 Dreamweaver 中创建 Web 应用程序，请学习使用 Dreamweaver 生成动态页。（请参见为可视化开发优化工作区和动态页设计工作流程。）
  • 在页面上定义和显示动态内容。（请参见为页面获取数据、定义动态内容源、向 Web 页中添加动态内容和显示数据库记录。）
  • 使用 Macromedia ColdFusion 组件和 Web 服务等前沿技术来封装应用程序或业务逻辑。（请参见使用 ColdFusion 组件和使用 Web 服务。）
  • 如果您需要更多的灵活性，则可以创建您自己的服务器行为和交互式表单。（请参见添加自定义服务器行为和创建表单。）


快速开发应用程序

Dreamweaver 提供了大量的快速应用程序开发 (RAD) 工具（包括服务器行为和应用程序对象），它们将帮助您生成高级的 Web 应用程序，而无需编写任何服务器端代码。

  • 快速创建对数据库进行搜索和修改并显示结果的页面。通过限制对页面的访问来提供安全性。（请参见快速构建 ColdFusion 应用程序、快速生成 ASP.NET 应用程序、快速生成 ASP 和 JSP 应用程序和快速生成 PHP 应用程序。）


与其他应用程序一起使用 Dreamweaver

Dreamweaver 通过使您容易地使用其他应用程序，方便了网页设计和开发过程。有关使用浏览器、HTML 编辑器、图像编辑器和动画工具等其他应用程序的信息，请参见以下主题：

  • 有关与 HomeSite 或 BBEdit 等其他 HTML 编辑器一起使用 Dreamweaver 的信息，请参见将外部 HTML 编辑器用于 Dreamweaver。
  • 您可以指定用来预览站点的首选浏览器。（请参见在浏览器中预览和测试页面。）
  • 您可以从 Dreamweaver 内启动外部图像编辑器，如 Macromedia Fireworks 或 Adobe Photoshop。（请参见使用外部图像编辑器。）
  • 您可以配置 Dreamweaver 使其为每个文件类型启动不同的编辑器。（请参见为媒体文件启动外部编辑器。）
  • 有关使用 Macromedia Flash 向站点添加互动控件的信息，请参见插入和修改 Flash 按钮对象、插入 Flash 文本对象或下载和安装 Flash 元素。
  • 有关使用 ColdFusion 的信息，请参见“使用 ColdFusion”（“帮助”>“使用 ColdFusion”）。


Dreamweaver 和辅助功能

辅助功能是指使 Web 站点和 Web 产品可供具有视觉、听觉、运动和其他残疾的人士使用。软件产品和 Web 站点的辅助功能示例包括屏幕阅读器支持、图形的等效文本、快捷键、将显示颜色更改为高对比度等。

注意

有关两项重要的辅助功能倡议的更多信息，请参见“WWW 联合会 Web 辅助功能倡议”(www.w3.org/wai)和“联邦康复法案第 508 款”(www.section508.gov)。

Dreamweaver 提供了为产品创建辅助功能的工具，并且还提供帮助您创作具有辅助功能的内容的工具：

使用 Dreamweaver 辅助功能 面向需要使用辅助功能的 Dreamweaver Web 设计人员，Dreamweaver 提供了屏幕阅读器支持、键盘导航和操作系统辅助功能支持。

有关更多信息，请参见使用 Dreamweaver 辅助功能。

为辅助功能而创作 面向需要创建具有辅助功能的内容的 Dreamweaver Web 设计人员，Dreamweaver 帮助您创建具有辅助功能的页面，这些页面包含可用于屏幕阅读器并符合政府准则的有用内容。

Dreamweaver 提供的对话框将在您插入页面元素时提示您输入辅助功能属性（请参见优化工作区以进行有辅助功能的页面设计）。例如，用于图像的辅助功能对话框将提醒您添加图形的等效项目。然后，当该图像显示在页面上以供有视觉障碍的用户使用时，屏幕阅读器将阅读该说明。

Dreamweaver 还提供了为辅助功能设计的示例 Web 页（请参见创建基于 Dreamweaver 设计文件的文档）和辅助功能报告，您可以运行该报告测试页面或站点，确定其是否符合第 508 款辅助功能准则（请参见测试站点）。

注意

请记住，没有任何创作工具能够实现该开发流程的自动化。如果要设计具有辅助功能的 Web 站点，您需要了解辅助功能要求，并不断做出大量有关有障碍的用户如何与 Web 页进行交互的主观决定。确保 Web 站点具有辅助功能的最佳方法是精心的规划、开发、测试和评估。


Dreamweaver 辅助功能验证功能

Dreamweaver 中的辅助功能验证功能利用 UsableNet 提供的技术。在开发易于使用的软件，使可用性和辅助功能测试及修复过程自动化这一领域，UsableNet 处于行业领先的地位。有关辅助功能测试的进一步帮助，请试用 UsableNet LIFT for Macromedia Dreamweaver，它是用于开发可用 Web 站点的完整解决方案。UsableNet LIFT for Macromedia Dreamweaver 包括用于复杂表、表单和图像的修复向导；全局 ALT 编辑器；可自定义的报告；以及一个新增的活动监控模式，它确保内容在页生成的过程中即可使用。从 www.usablenet.com 可请求获取 LIFT for Macromedia Dreamweaver 的演示版。


Dreamweaver 教学媒体指南

Dreamweaver 包含了多种媒体，可帮助您快速学习此程序并熟练掌握 Web 页的创建。 Dreamweaver 帮助系统中包含多个文档，可帮助您学习 Dreamweaver、Dreamweaver 扩展功能和 ColdFusion。 在学习如何建立 Web 页时，还可以查看许多其它在线资源。

本节包含以下主题：

  • 访问 Dreamweaver 文档
  • 访问其它 Dreamweaver 在线资源

访问 Dreamweaver 文档

下表概述了 Dreamweaver 帮助系统中包含的文档。

您可以购买所选标题名的印刷版本。有关更多信息，请参见 www.macromedia.com/go/buy_books。

标题

说明/目标用户

位置

Dreamweaver 入门

提供 Dreamweaver 概念和界面的基本介绍，附带详尽的初级教程。 面向初级用户以及希望了解新功能的中级和高级用户。
  • 在 Dreamweaver 中查看： 选择“帮助”>“Dreamweaver 入门”
  • 在线查看：http://livedocs.macromedia.com/go/livedocs_dreamweaver_cn/
  • 获取 PDF：www.macromedia.com/go/dw_documentation_cn

使用 Dreamweaver

关于所有 Dreamweaver 功能的详尽信息。 面向所有 Dreamweaver 用户。
  • 在 Dreamweaver 中查看： 选择“帮助”>“Dreamweaver 帮助”或“帮助”>“使用 Dreamweaver”
  • 在线查看：http://livedocs.macromedia.com/go/livedocs_dreamweaver_cn/
  • 获取 PDF：www.macromedia.com/go/dw_documentation_cn

扩展 Dreamweaver

介绍 Dreamweaver 框架和应用程序编程接口 (API)。 面向希望创建扩展功能或自定义 Dreamweaver 界面的高级用户。
  • 在 Dreamweaver 中查看： 选择“帮助”>“扩展 Dreamweaver”
  • 在线查看：http://livedocs.macromedia.com/go/livedocs_dreamweaver_cn/
  • 获取 PDF：www.macromedia.com/go/dw_documentation_cn

Dreamweaver API 参考

介绍实用程序 API 和 JavaScript API，它们使您能够在开发 Dreamweaver 扩展功能时执行各种支持任务。 面向希望创建扩展功能或自定义 Dreamweaver 界面的高级用户。
  • 在 Dreamweaver 中查看： 选择“帮助”>“Dreamweaver API 参考”
  • 在线查看：http://livedocs.macromedia.com/go/livedocs_dreamweaver_cn/
  • 获取 PDF：www.macromedia.com/go/dw_documentation_cn

使用 ColdFusion

收集了 ColdFusion 文档集中最重要的手册。 （LiveDocs 上有完整的文档集。） 适用于对 ColdFusion 感兴趣的所有人，包括初级用户和高级开发人员。
  • 在 Dreamweaver 中查看： 选择“帮助”>“使用 ColdFusion”
  • 在线查看：http://livedocs.macromedia.com/go/livedocs_coldfusion/
  • 获取 PDF：www.macromedia.com/go/cf_documentation

参考资料

包括介绍 HTML、服务器模型和其它主题的各种参考手册，主要由 O’Reilly 发行。 面向需要进一步了解编码语法、概念等信息的所有人。
  • 在 Dreamweaver 中查看： 选择“帮助”>“参考”。 若要查看这些手册的完整列表，请单击“参考”面板中的“书籍”弹出式菜单。

访问其它 Dreamweaver 在线资源

下表概述了用于学习 Dreamweaver 的其它在线资源。

资源 | 说明/目标用户 | 位置
Dreamweaver 支持中心 | 为 Dreamweaver 用户提供的技术说明、支持和帮助解决问题的信息。 | www.macromedia.com/go/dreamweaver_support_cn
Dreamweaver 开发人员中心 | 提供文章和教程，可帮助您提高技能并学习新技能。 | www.macromedia.com/go/dreamweaver_devcenter_cn
Dreamweaver 文档资源中心 | 获取 PDF 格式的产品手册、勘误表、教程和发行说明。 | www.macromedia.com/go/dw_documentation_cn
Macromedia 在线论坛 | Dreamweaver 用户、技术支持代表和 Dreamweaver 开发小组在此开展讨论并提供解决问题的信息。 | www.macromedia.com/go/dreamweaver_newsgroup
Macromedia 培训 | 提供注重实地任务和实际方案的课程。 | www.macromedia.com/go/dreamweaver_training_cn

要充分利用 Dreamweaver 资源，请参见从哪里开始。


字形约定

Dreamweaver 帮助中采用以下字形约定：

  • 菜单项按如下格式显示：“菜单名称”>“菜单项名称”。子菜单中的项按如下格式显示：“菜单名称”>“子菜单名称”>“菜单项名称”。
  • Code 字体指示 HTML 标签和属性的名称以及在示例中使用的文字。
  • Italic code 字体指示代码中可替换的项（有时称作元符号）。
  • Bold roman 文本指示让您逐字输入的文本。

有关 Dreamweaver 资源的完整列表，请参见 Dreamweaver 教学媒体指南。


HTML 和 Web 技术资源

下面是在 Web 上提供的一些有用资源：

注意

有关 Dreamweaver 资源的列表，请参见 Dreamweaver 教学媒体指南。

层叠样式表、第 1 级规范 (CSS1) (www.w3.org/TR/REC-CSS1) 和第 2 级规范 (CSS2) (www.w3.org/TR/REC-CSS2/) 是 WWW 联合会为样式表制定的正式规范。

HTML 4.01 规范 (www.w3.org/TR/REC-html40/) 是 WWW 联合会为 HTML 制定的正式规范。

Index DOT HTML (www.blooberry.com/indexdot/html/) 是 HTML 标签、属性和值以及它们与各种浏览器的兼容性的综合列表。

XHTML 1.0 规范 (www.w3.org/TR/xhtml1/) 是可扩展超文本标记语言的正式规范。

O’Reilly XML.com 站点 (www.xml.com/) 提供有关可扩展标记语言 (XML) 的信息、教程和提示以及其他 Web 技术。

xFront 站点 (www.xfront.com/rescuing-xslt.html) 为新用户介绍 XSL 转换。

Microsoft ASP 概述页 ( http://msdn.microsoft.com/library/en-us/dnasp/html/ASPover.asp) 提供有关 Active Server Pages (ASP) 的信息。

Microsoft ASP.NET 页 (http://msdn.microsoft.com/asp.net/) 提供有关 ASP.NET 的信息。

Sun JSP 页 (http://java.sun.com/products/jsp/) 提供有关 JavaServer Pages (JSP) 的信息。

PHP Web 站点 (www.php.net/) 提供有关 PHP 的信息。

MySQL 站点 (www.mysql.com/) 提供有关 MySQL 的信息。

实体表 (www.bbsinc.com/iso8859.html) 列出在 ISO 8859-1 (Latin-1) 中使用的实体名称。

Macromedia ColdFusion 产品页 (www.macromedia.com/go/coldfusion/) 提供有关 ColdFusion 的信息。

Macromedia JRun Server 产品页 (www.macromedia.com/go/jrun/) 提供有关 JRun Java 应用程序服务器的信息。

Web Services Demystified (www.sitepoint.com/article/692) 解释 Web 服务是什么以及它们如何工作。

JavaScript Bible（作者 Danny Goodman，出版商 IDG Books）全面地介绍 JavaScript 1.2 语言。

JavaScript:The Definitive Guide（作者 David Flanagan，出版商 O’Reilly & Associates) 提供有关每个 JavaScript 函数、对象、方法、属性和事件处理程序的参考信息。

CGI 资源索引 (www.cgi-resources.com/) 是一个 CGI 所有相关内容的存储库，其中包括现成的脚本、文档、书籍甚至还有求职的编程人员。

Common Gateway Interface 站点 (http://hoohoo.ncsa.uiuc.edu/cgi/) 包括对 CGI 的介绍。


了解工作区

若要从使用 Macromedia Dreamweaver 8 的经验中最大程度地获益，您应了解 Dreamweaver 工作区背后的基本概念，并且了解如何选择选项、如何使用检查器和面板以及如何设置最适合您工作风格的首选参数。

本章包含下列章节：

关于 Dreamweaver 工作区

在“文档”窗口中工作

使用工具栏、检查器和上下文菜单

使用面板和面板组

使用 Dreamweaver 辅助功能

优化工作区以进行有辅助功能的页面设计

使用可视化助理 Dreamweaver

Dreamweaver 自定义基础

相关主题

  • 为可视化开发优化工作区


关于 Dreamweaver 工作区

Dreamweaver 工作区使您可以查看文档和对象属性。工作区还将许多常用操作放置于工具栏中，使您可以快速更改文档。

本节包含以下主题：

  • 工作区布局
  • Dreamweaver 工作区元素
  • “文档”窗口
  • “文档”工具栏
  • “标准”工具栏
  • 状态栏
  • “插入”栏
  • “编码”工具栏
  • “样式呈现”工具栏
  • 报告 Dreamweaver
  • 关于在多用户系统中自定义 Dreamweaver


工作区布局

在 Windows 中，Dreamweaver 提供了一个将全部元素置于一个窗口中的集成布局。在集成的工作区中，全部窗口和面板都被集成到一个更大的应用程序窗口中。

注意

Windows 工作区还有一个“编码器”选项，它默认将面板组停靠在左侧，并在“代码”视图中显示“文档”窗口。有关更多信息，请参见使用面向编码器的工作区（仅限 Windows）。若要使用此选项，请参见选择工作区布局（仅限 Windows）。

在 Macintosh 上，Dreamweaver 可以在带有标识每个文档的标签的单个窗口中显示多个文档。Dreamweaver 还可显示一个浮动工作区，其中的每个文档都显示在它自己的单独窗口中。面板组最初停靠在一起，但是可以将它们取消停靠使其位于自己的窗口中。当您拖动窗口或调整它们的大小时，窗口将自动彼此对齐或者与屏幕的边沿、“文档”窗口对齐。

您可以在 Windows 和 Macintosh 中的不同布局之间进行切换。有关更多信息，请参见选择工作区布局（仅限 Windows）和显示选项卡式文档 (Macintosh)。

相关主题

  • Dreamweaver 工作区元素
  • 使用工具栏、检查器和上下文菜单
  • 使用面板和面板组


Dreamweaver 工作区元素

本节简要介绍 Dreamweaver 工作区的一些元素。

注意

Dreamweaver 另外提供了许多面板、检查器和窗口。若要打开 Dreamweaver 面板、检查器和窗口，请使用“窗口”菜单。如果您找不到一个标记为打开的面板、检查器或窗口，请选择“窗口”>“排列面板”以整齐地列出所有打开的面板。

起始页使您可以打开最近使用过的文档或创建新文档。您还可以从起始页通过产品介绍或教程了解关于 Dreamweaver 的更多信息。

“插入”栏包含用于将各种类型的“对象”（如图像、表格和层）插入到文档中的按钮。每个对象都是一段 HTML 代码，允许您在插入它时设置不同的属性。例如，您可以在“插入”栏中单击“表格”按钮，插入一个表格。如果您愿意，可以不使用“插入”栏而使用“插入”菜单插入对象。

“文档”工具栏包含各种按钮，它们提供各种“文档”窗口视图（如“设计”视图和“代码”视图）的选项、各种查看选项和一些常用操作（如在浏览器中预览）。

“标准”工具栏（在默认工作区布局中不显示）包含来自“文件”和“编辑”菜单中的一般操作的按钮：“新建”、“打开”、“保存”、“保存全部”、“剪切”、“复制”、“粘贴”、“撤消”和“重做”。若要显示“标准”工具栏，请选择“查看”>“工具栏”>“标准”。

编码工具栏（只在“代码”视图中显示）包含允许您执行许多标准编码操作的按钮。

“样式呈现”工具栏（默认情况下隐藏）包含一些按钮，如果使用了依赖于媒体的样式表，这些按钮使您能够查看设计在不同媒体类型中的呈现方式。它还包含一个允许您启用或禁用 CSS 样式的按钮。

“文档”窗口显示您当前创建和编辑的文档。

“属性”检查器用于查看和更改所选对象或文本的各种属性。每种对象都具有不同的属性。在“编码器”工作区布局中，“属性”检查器默认是不展开的。

标签选择器位于“文档”窗口底部的状态栏中，它显示环绕当前选定内容的标签的层次结构。单击该层次结构中的任何标签可以选择该标签及其全部内容。

面板组是组合在一个标题下面的相关面板的集合。若要展开一个面板组，请单击组名称左侧的展开箭头；若要取消停靠一个面板组，请拖动该组标题条左边缘的手柄。

“文件”面板使您可以管理文件和文件夹，无论它们属于 Dreamweaver 站点的一部分还是位于远程服务器上。“文件”面板还使您可以访问本地磁盘上的全部文件，非常类似于 Windows 资源管理器 (Windows) 或 Finder (Macintosh)。

相关主题

  • 在“文档”窗口中工作
  • 使用工具栏、检查器和上下文菜单
  • 使用面板和面板组
  • 在“文件”面板中管理文件和文件夹


“文档”窗口

“文档”窗口显示当前文档。可以选择下列任一视图：

“设计”视图是一个用于可视化页面布局、可视化编辑和快速应用程序开发的设计环境。在该视图中，Dreamweaver 显示文档的完全可编辑的可视化表示形式，类似于在浏览器中查看页面时看到的内容。您可以配置“设计”视图以在处理文档时显示动态内容（请参见在“设计”视图中查看动态数据）。

“代码”视图是一个用于编写和编辑 HTML、JavaScript、服务器语言代码（如 PHP 或 ColdFusion 标记语言 (CFML)）以及任何其他类型代码的手工编码环境。有关更多信息，请参见在 Dreamweaver 中编写代码。

“代码和设计”视图使您可以在单个窗口中同时看到同一文档的“代码”视图和“设计”视图。

当“文档”窗口有一个标题栏时，标题栏显示页面标题，并在括号中显示文件的路径和文件名。如果您做了更改但仍未保存，则 Dreamweaver 在文件名后显示一个星号。

当“文档”窗口在集成工作区布局（仅限 Windows）中处于最大化状态时，它没有标题栏；在这种情况下，页面标题以及文件的路径和文件名显示在主工作区窗口的标题栏中。

当“文档”窗口处于最大化状态时，出现在“文档”窗口区域顶部的选项卡显示所有打开的文档的文件名。若要切换到某个文档，请单击它的选项卡。

相关主题

  • 在“文档”窗口中工作


“文档”工具栏

“文档”工具栏中包含按钮，这些按钮使您可以在文档的不同视图间快速切换：“代码”视图、“设计”视图、同时显示“代码”和“设计”视图的拆分视图。

工具栏中还包含一些与查看文档、在本地和远程站点间传输文档有关的常用命令和选项。

以下选项出现在“文档”工具栏中：

显示代码视图仅在“文档”窗口中显示“代码”视图。

显示代码视图和设计视图在“文档”窗口的一部分中显示“代码”视图，而在另一部分中显示“设计”视图。当选择了这种组合视图时，“视图选项”菜单中的“在顶部查看设计视图”选项变为可用。请使用该选项指定在“文档”窗口的顶部显示哪种视图。

显示设计视图仅在“文档”窗口中显示“设计”视图。

服务器调试显示一个报告，帮助您调试当前 ColdFusion 页。该报告包括您的页面中的错误（如果有的话）。

文档标题允许您为文档输入一个标题，它将显示在浏览器的标题栏中。如果文档已经有了一个标题，则该标题将显示在该区域中。

没有浏览器/检查错误使您可以检查跨浏览器兼容性。

验证标记允许您验证当前文档或选定的标签。

文件管理显示“文件管理”弹出菜单。

在浏览器中预览/调试允许您在浏览器中预览或调试文档。从弹出菜单中选择一个浏览器。

刷新设计视图当您在“代码”视图中进行更改后刷新文档的“设计”视图。在执行某些操作（如保存文件或单击该按钮）之前，您在“代码”视图中所做的更改不会自动显示在“设计”视图中。

视图选项允许您为“代码”视图和“设计”视图设置选项，其中包括对哪个视图显示在上面进行选择。该菜单中的选项用于当前视图：“设计”视图、“代码”视图或两者。有关“代码”视图选项的信息，请参见设置编码首选参数。有关“设计”视图选项的信息，请参见在“文档”窗口中选择元素、查看和编辑文件头内容和使用可视化助理 Dreamweaver。

可视化助理允许您使用不同的可视化助理来设计页面。

相关主题

  • 显示工具栏


“标准”工具栏

“标准”工具栏中包含“文件”和“编辑”菜单中一般操作的按钮：“新建”、“打开”、“保存”、“保存全部”、“剪切”、“复制”、“粘贴”、“撤消”和“重做”。可像使用等效的菜单命令一样使用这些按钮。

有关诸如“打开”和“保存”等操作的更多信息，请参见创建和打开文档。

相关主题

  • 显示工具栏


状态栏

“文档”窗口底部的状态栏提供与您正创建的文档有关的其它信息。

标签选择器显示环绕当前选定内容的标签的层次结构。单击该层次结构中的任何标签以选择该标签及其全部内容。单击 <body> 可以选择文档的整个正文。若要设置标签选择器中某个标签的 class 或 id 属性，请右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 该标签，然后从上下文菜单中选择一个类或 ID。

手形工具允许您单击文档并将其拖到“文档”窗口中。单击选取工具可禁用手形工具。

缩放工具和“设置缩放比率”弹出式菜单允许您为文档设置缩放级别。有关更多信息，请参见放大和缩小。

“窗口大小”弹出菜单（仅在“设计”视图中可见）允许您将“文档”窗口的大小调整到预定义或自定义的尺寸。有关更多信息，请参见调整“文档”窗口的大小。

“窗口大小”弹出菜单的右侧是页面（包括全部相关的文件，如图像和其它媒体文件）的文档大小和估计下载时间。有关更多信息，请参见设置下载时间和大小首选参数。

相关主题

  • 设置“状态栏”首选参数


“插入”栏

“插入”栏包含用于创建和插入对象（如表格、层和图像）的按钮。当鼠标指针滚动到一个按钮上时，会出现一个工具提示，其中含有该按钮的名称。

这些按钮被组织到几个类别中，您可以在“插入”栏的左侧切换它们。当前文档包含服务器代码时（例如 ASP 或 CFML 文档），还会显示其他类别。当您启动 Dreamweaver 时，系统会打开您上次使用的类别。

注意

如果您喜欢以横跨“插入”栏顶部的选项卡的形式查看类别，您可以更改“插入”栏的布局（请参见设置 Dreamweaver 显示的“字体”首选参数）。

某些类别具有带弹出菜单的按钮。从弹出菜单中选择一个选项时，该选项将成为该按钮的默认操作。例如，如果从“图像”按钮的弹出菜单中选择“图像占位符”，下次单击“图像”按钮时，Dreamweaver 会插入一个图像占位符。每当从弹出菜单中选择一个新选项时，该按钮的默认操作都会改变。

“插入”栏按以下的类别进行组织：

“常用”类别使您可以创建和插入最常用的对象，例如图像和表格。

“布局”类别使您可以插入表格、div 标签、层和框架。您还可以从三个表格视图中进行选择：“标准”（默认）、“扩展表格”和“布局”。当选择“布局”模式后，您可以使用 Dreamweaver 布局工具：“绘制布局单元格”和“绘制布局表格”。

“表单”类别包含用于创建表单和插入表单元素的按钮。

“文本”类别使您可以插入各种文本格式设置标签和列表格式设置标签，例如 b、em、p、h1 和 ul。

“HTML”类别使您可以插入用于水平线、头内容、表格、框架和脚本的 HTML 标签。

“服务器代码”类别仅适用于使用特定服务器语言的页面，这些服务器语言包括 ASP、ASP.NET、CFML Basic、CFML Flow、CFML Advanced、JSP 和 PHP。这些类别中的每一个都提供了服务器代码对象，您可以将这些对象插入“代码”视图中。

“应用程序”类别使您可以插入动态元素，例如记录集、重复区域以及记录插入和更新表单。

“Flash 元素”类别使您可以插入 Macromedia Flash 元素。

“收藏”类别使您可以将“插入”栏中最常用的按钮分组和组织到某一常用位置。

您可以修改“插入”栏中的任何对象或创建您自己的对象（请参见 Macromedia 支持中心上的“自定义 Dreamweaver”，网址为：www.macromedia.com/go/customizing_dreamweaver_cn）。

相关主题

  • 使用“插入”栏


“编码”工具栏

编码工具栏包含可以让您执行多种标准编码操作的按钮，例如折叠和展开代码的选定内容、高亮显示无效代码、应用和删除注释、缩进代码以及插入最近使用过的代码片断。编码工具栏仅在“代码”视图中可见，它以垂直方式显示在“文档”窗口的左侧。

您不能取消停靠或移动“编码”工具栏，但可以将其隐藏。有关更多信息，请参见显示工具栏。

您还可以编辑“编码工具栏”来显示更多按钮（例如“自动换行”、“隐藏字符”和“自动缩进”）或隐藏您不想使用的按钮。不过，为此您必须编辑生成该工具栏的 XML 文件。有关更多信息，请参见“扩展 Dreamweaver”。

相关主题

  • 使用编码工具栏迅速插入代码
  • 显示工具栏


“样式呈现”工具栏

“样式呈现”工具栏（默认情况下隐藏）包含一些按钮，如果使用依赖于媒体的样式表，这些按钮使您能够查看设计在不同媒体类型中的呈现方式。它还包含一个允许您启用或禁用 CSS 样式的按钮。若要显示该工具栏，请选择“查看”>“工具栏”>“样式呈现”。

只有在文档使用依赖于媒体的样式表时，此工具栏才有用。例如，样式表可能为打印指定某种正文规则，而为手持设备则指定另一种正文规则。有关创建依赖于媒体的样式表的更多信息，请参见 WWW 联合会 Web 站点，网址为 www.w3.org/TR/CSS21/media.html。

默认情况下，Dreamweaver 会显示屏幕媒体类型的设计（该类型显示页面在计算机屏幕上的呈现方式）。您可以在“样式呈现”工具栏中单击相应的按钮来查看下列媒体类型的呈现。

呈现屏幕媒体类型显示页面在计算机屏幕上的显示方式。

呈现打印媒体类型显示页面在打印纸张上的显示方式。

呈现手持型媒体类型显示页面在手持设备（如手机或 BlackBerry 设备）上的显示方式。

呈现投影媒体类型显示页面在投影设备上的显示方式。

呈现 TTY 媒体类型显示页面在电传打字机上的显示方式。

呈现 TV 媒体类型显示页面在电视屏幕上的显示方式。

切换 CSS 样式的显示允许您启用或禁用 CSS 样式。此按钮可独立于其他媒体按钮之外工作。

相关主题

  • 显示工具栏


报告 Dreamweaver

可以在 Dreamweaver 中运行报告来查找内容、排除故障或测试内容。可以生成以下类型的报告：

搜索使您可以搜索标签、属性和标签中的特定文本。若要在代码中搜索，请参见搜索和替换标签和属性。

验证使您可以检查代码或语法错误。若要验证代码，请参见验证标签。

目标浏览器检查使您可以对文档中的 HTML 进行测试，检查是否有目标浏览器所不支持的任何标签或属性。若要运行目标浏览器检查，请参见检查浏览器的兼容性。

链接检查器使您可以查找和修复断开的链接、外部连接和孤立的链接。若要运行链接检查器，请参见查找断开的、外部的和孤立的链接。

站点报告使您可以改进工作流程，并对站点中的 HTML 属性进行测试。工作流程报告包含取出者、最近修改日期和设计备注；HTML 报告包含可合并的嵌套字体标签、辅助功能、遗漏的替换文本、冗余的嵌套标签、可删除的空标签和无标题文档。若要运行站点报告，请参见测试站点。

FTP 日志使您可以查看所有 FTP 文件传输活动。若要查看 FTP 日志，请参见从远程服务器获取文件或将文件上传到远端服务器上。

服务器调试使您可以查看信息以便调试 ColdFusion 应用程序。若要查看调试信息，请参见使用 ColdFusion 调试器（仅限 Windows）。


关于在多用户系统中自定义 Dreamweaver

即使在多用户操作系统如 Windows XP 或 Mac OS X 中，您也可以自定义 Dreamweaver 以适合自己的需要。

Dreamweaver 能够防止任何用户的自定义配置影响任何其他用户的自定义配置。为了达到这个目的，当您首次在 Dreamweaver 可以识别的某个多用户操作系统中运行它时，该应用程序将为您创建各种配置文件的副本。这些用户配置文件存储在一个属于您的文件夹中。

例如，在 Windows XP 中，它们存储在 C:\Documents and Settings\用户名\Application Data\Macromedia\Dreamweaver 8\Configuration 文件夹中（该文件夹可能在一个隐藏的文件夹中）。

在 Mac OS X 中，它们存储在您的主文件夹中；具体地说就是存储在 Users/用户名/Library/Application Support/Macromedia/Dreamweaver 8/Configuration 文件夹中。

如果您重新安装或升级了 Dreamweaver，Dreamweaver 会自动制作现有用户配置文件的备份副本，这样一来，如果您已手工自定义了这些文件，您仍然可以访问已做的更改。

相关主题

  • Dreamweaver 自定义基础


在“文档”窗口中工作

“文档”窗口显示当前文档。您可以在“设计”视图、“代码”视图或“设计和代码”视图中查看文档。“文档”窗口的状态栏提供了有关当前文档的信息。

本节包含以下主题：

  • 在“文档”窗口中的视图间进行切换
  • 以层叠或平铺方式放置“文档”窗口
  • 调整“文档”窗口的大小
  • 设置“状态栏”首选参数

相关主题

  • “文档”窗口
  • 状态栏


在“文档”窗口中的视图间进行切换

您可以在“文档”窗口中通过“代码”视图、“设计”视图或“代码和设计”视图查看文档。

要在“文档”窗口中切换视图，请执行下列操作之一：

  • 使用“查看”菜单：
    • 选择“查看”>“代码”。
    • 选择“查看”>“设计”。
    • 选择“查看”>“代码和设计”。
  • 使用“文档”工具栏：
    • 单击“显示代码视图”按钮。

    • 单击“显示代码视图和设计视图”按钮。

    • 单击“显示设计视图”按钮。

要在“代码”视图和“设计”视图之间切换，请执行以下操作：

  • 按 Ctrl+代字号 (~) (Windows) 或 Command+反引号 (‘) (Macintosh)。

    注意

    如果两个视图都显示在“文档”窗口中，此快捷键会将键盘焦点从一个视图更改到另一个视图。

相关主题

  • “文档”窗口


以层叠或平铺方式放置“文档”窗口

如果一次打开了多个文档，您可以采用层叠或平铺方式放置这些文档。

若要以层叠方式放置“文档”窗口，请执行以下操作：

  • 选择“窗口”>“层叠”。

若要以平铺方式放置“文档”窗口，请执行下列操作之一：

  • 在 Windows 中，选择“窗口”>“水平平铺”，或选择“窗口”>“垂直平铺”。
  • 在 Macintosh 上，选择“窗口”>“平铺”。

相关主题

  • 选择工作区布局（仅限 Windows）
  • 显示选项卡式文档 (Macintosh)
  • 保存自定义工作区布局


调整“文档”窗口的大小

状态栏显示“文档”窗口的当前尺寸（以像素为单位）。若要设计在某个特定大小时看起来效果最好的页面，您可以将“文档”窗口调整到任一预定义大小、编辑这些预定义大小或者创建新的大小。

若要将“文档”窗口的大小调整为预定义的大小，请执行以下操作：

  • 从“文档”窗口底部的“窗口大小”弹出菜单中选择一种大小。

    注意

    在 Windows 中，您可以将“文档”窗口最大化以便它填充集成窗口的整个文档区域。当“文档”窗口最大化时，您无法调整它的大小。

显示的窗口大小反映浏览器窗口的内部尺寸（不包括边框）；显示器大小列在括号中。例如，如果您的访问者可能按其默认配置在 640 x 480 显示器上使用 Microsoft Internet Explorer 或 Netscape Navigator，则您应使用“536 x 196（640 x 480，默认）”的大小。

提示

对于不是很精确的大小调整，请使用操作系统的标准窗口大小调整方法，如拖动窗口的右下角。

若要更改“窗口大小”弹出菜单中所列的值，请执行以下操作：

  1. 从“窗口大小”弹出菜单中选择“编辑大小”。
  2. 在“窗口大小”列表中单击任一宽度或高度值，然后键入一个新值。

    若要使“文档”窗口仅调整为某个特定的宽度（高度保持不变），请选择一个高度值然后删除它。

  3. 单击“描述”文本框以输入关于某个特定大小的说明性文本。
  4. 单击“确定”保存更改并返回到“文档”窗口。

若要向“窗口大小”弹出菜单中添加新的大小，请执行以下操作：

  1. 从“窗口大小”弹出菜单中选择“编辑大小”。
  2. 单击“宽度”列中最后一个值下面的空白。
  3. 输入“宽度”和“高度”的值。

    若要仅设置“宽度”或“高度”，只需将一个字段保留为空。

  4. 单击“描述”字段以输入关于所添加大小的说明性文本。
  5. 单击“确定”保存更改并返回到“文档”窗口。

    例如，您可能在一个 800 x 600 像素显示器项的旁边键入 SVGA 或平均 PC，而在一个 832 x 624 像素显示器项的旁边键入 17 英寸 Mac。大多数显示器可以调整为不同的像素尺寸。


设置“状态栏”首选参数

使用“首选参数”对话框设置状态栏的首选参数。

若要设置状态栏的首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从位于左侧的“类别”列表中选择“状态栏”。
  3. 设置首选参数选项。

    有关更多信息，请参见设置“状态栏”首选参数。

  4. 单击“确定”。

相关主题

  • 状态栏


使用工具栏、检查器和上下文菜单

Dreamweaver 提供了多个工具，在创建或编辑文档时可以使用这些工具快速作出更改。

“文档”、“标准”和“代码”工具栏可用于编辑和处理当前文档。“插入”栏包含的按钮可用于创建和插入表、层和图像等对象，而使用“属性”检查器可以编辑这些对象的属性。

注意

您也可以使用标签检查器查看和编辑属性（请参见使用标签检查器更改属性）。标签检查器使您可以查看和编辑与给定标签关联的每个属性，而“属性”检查器只显示最常用的属性。

上下文菜单为“插入”栏和“属性”检查器的提供了一种替代方法，可用于创建和编辑对象。

本节包含以下主题：

  • 显示工具栏
  • 使用“插入”栏
  • 使用“属性”检查器
  • 使用上下文菜单


显示工具栏

使用“文档”和“标准”工具栏可以执行与文档相关的操作和标准编辑操作；使用“编码”工具栏可以快速插入代码；而使用“样式呈现”工具栏可以显示页面在不同媒体类型中的显示方式。您可以按需要选择显示或隐藏工具栏。

若要显示或隐藏某个工具栏，请执行以下操作之一：

  • 选择“查看”>“工具栏”，然后选择该工具栏。
  • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 任何工具栏，然后从上下文菜单中选择该工具栏。

    注意

    若要在代码检查器（“窗口”>“代码检查器”）中显示或隐藏编码工具栏，请从该检查器顶部的“视图选项”弹出式菜单中选择“编码工具栏”。

相关主题

  • “文档”工具栏
  • “标准”工具栏
  • “编码”工具栏
  • “样式呈现”工具栏


使用“插入”栏

“插入”栏包含用于创建和插入对象（如表格和图像）的按钮。这些按钮被组织到类别中。当鼠标指针滚动到一个按钮上时，会出现一个工具提示，其中含有该按钮的名称。

本节包含以下主题：

  • 显示“插入”栏及其类别和菜单
  • 使用“插入”栏插入对象
  • 在“插入”栏中自定义和使用“收藏”类别

相关主题

  • “插入”栏


显示“插入”栏及其类别和菜单

您可以根据需要隐藏或显示、折叠或展开“插入”栏。您还可以显示“插入”栏的不同类别。“插入”栏的某些类别中的按钮包含带有常用命令的菜单。

如果您喜欢以横跨“插入”栏顶部的选项卡的形式查看类别，您可以更改“插入”栏的布局。

若要隐藏或显示“插入”栏，请执行下面操作之一：

  • 选择“窗口”>“插入”。
  • 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh)“插入”栏、“文档”、“标准”或编码工具栏，然后选择“插入”栏。

若要显示特定类别中的按钮，请执行下面的操作：

  • 单击“插入”栏最左侧的类别名称旁边的箭头，然后从弹出菜单中选择另一个类别。

若要显示按钮的弹出菜单，请执行以下操作：

  • 单击按钮图标旁边的向下箭头。

若要以选项卡形式显示“插入”栏类别，请执行以下操作：

  • 单击“插入”栏最左侧的类别名称旁的箭头，然后选择“显示为选项卡”。

“插入”栏将以横跨“插入”栏顶部的选项卡的形式显示类别。

注意

您可能需要单击“插入”栏标题栏重新打开“插入”栏。

若要以菜单形式显示“插入”栏类别，请执行以下操作：

  • 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh)“插入”栏，然后选择“显示为菜单”。

“插入”栏将以菜单形式而不是以选项卡的形式显示类别。

相关主题

  • 使用“插入”栏插入对象
  • 在“插入”栏中自定义和使用“收藏”类别


使用“插入”栏插入对象

“插入”栏是用于创建和插入对象的一种方便的方法。

若要插入对象，请执行以下操作：

  1. 从“插入”栏的左侧选择相应的类别。
  2. 执行下列操作之一：
    • 单击一个对象按钮或将该按钮的图标拖到“文档”窗口中。
    • 单击按钮上的箭头，然后从菜单中选择一个选项。

根据对象的不同，可能会出现一个相应的对象插入对话框，提示您浏览到一个文件或者为对象指定参数。或者，Dreamweaver 还可能会在文档中插入代码，或者打开标签编辑器（请参见使用标签编辑器编辑标签）或面板，以供您在插入代码之前指定信息。

对于有些对象，如果您在“设计”视图中插入对象则不会出现对话框，而如果在“代码”视图中插入对象则会出现一个标签编辑器。对于少数对象，在“设计”视图中插入对象会导致 Dreamweaver 在插入对象前切换到“代码”视图。

注意

在浏览器窗口中查看页面时，有些对象（如命名锚记）不可见。若要在“设计”视图中显示标记此类不可见对象的位置的图标，请参见显示和隐藏不可见元素。

若要绕过对象插入对话框并插入空的占位符对象，请执行以下操作：

  • 按住 Ctrl 键并单击 (Windows) 或者按住 Option 键并单击 (Macintosh) 该对象的按钮。

    例如，若要为一个图像插入一个占位符而不指定图像文件，请按住 Ctrl 键并单击或者按住 Option 键并单击“图像”按钮。

    注意

    该过程不会绕过所有对象插入对话框。包括导航条、层、Flash 按钮和框架集在内的许多对象都不插入占位符或采用默认值的对象。

若要修改“插入”栏的首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)。

    “首选参数”对话框显示了“常规”首选参数类别。

  2. 取消选择“插入对象时显示对话框”，以在插入图像、表、脚本和文件头元素等对象时禁止显示对话框，也可在创建对象时显按下 Ctrl 键 (Windows) 或 Option 键 (Macintosh)。

    提示

    当您在禁用该选项的情况下插入对象时，将给该对象指定默认属性值。插入对象后，可以使用“属性”检查器更改对象的属性。
  3. 单击“确定”。

相关主题

  • 显示“插入”栏及其类别和菜单
  • 在“插入”栏中自定义和使用“收藏”类别


在“插入”栏中自定义和使用“收藏”类别

“插入”栏的“收藏”类别使您可以分组和组织最常用的“插入”栏按钮。您可以在“收藏”类别中添加、管理和删除按钮。

若要在“收藏”类别中添加、删除或管理项目，请执行以下操作：

  1. 在“插入”栏中选择任意类别。
  2. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 显示按钮的区域（不要右键单击类别名称），然后选择“自定义对象”。

    出现“自定义收藏对象”对话框。

  3. 按需要进行更改。

    有关更多信息，请参见设置“自定义收藏对象”对话框选项。

  4. 单击“确定”。

    “收藏”类别会反映出您所作的更改。

    提示

    您如果没有位于“收藏”类别中，请选择该类别以查看所作的更改。

若要在“收藏”类别中插入使用按钮的对象，请执行以下操作：

  • 从“插入”栏左侧选择“收藏”类别，然后单击您添加的任意“收藏”对象的按钮。

    注意

    在您自定义“类别”以添加对象之前，“收藏”类别不包含任何按钮。

相关主题

  • 显示“插入”栏及其类别和菜单
  • 使用“插入”栏插入对象


使用“属性”检查器

“属性”检查器使您可以检查和编辑当前选定页面元素（如文本和插入的对象）的最常用属性。“属性”检查器中的内容根据选定的元素会有所不同。

注意

使用标签检查器可以查看和编辑与给定的标签属性关联的每个属性（请参见使用标签检查器更改属性）。

提示

默认情况下，“属性”检查器位于工作区的底部，但是如果需要的话，您可以将它停靠在工作区的顶部。或者，您可以将它变为工作区中的浮动面板。有关移动“属性”检查器的更多信息，请参见停靠和取消停靠面板和面板组。

若要显示或隐藏“属性”检查器，请执行以下操作：

  • 选择“窗口”>“属性”。

若要展开或折叠“属性”检查器，请执行以下操作：

  • 单击“属性”检查器右下角的扩展箭头。

若要查看页面元素的属性，请执行以下操作：

  • 在“文档”窗口中选择页面元素。

    注意

    可能需要展开“属性”检查器才能查看选定元素的所有属性。

若要更改页面元素的属性，请执行以下操作：

  1. 在“文档”窗口中选择页面元素。
  2. 在“属性”检查器中更改任意属性。

    注意

    有关特定属性的信息，请在“文档”窗口中选择一个元素，然后单击“属性”检查器右上角的“帮助”图标。

    您对属性所做的大多数更该会立刻应用在“文档”窗口中。

  3. 如果您所作的更改没有被立即应用，请执行以下操作之一：
    • 在属性编辑文本字段外单击。
    • 按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
    • 按 Tab 键可以切换到另一属性。


使用上下文菜单

Dreamweaver 广泛使用了上下文菜单，使用这种菜单可以很方便地访问与正在处理的对象或窗口有关的最有用的命令和属性。上下文菜单仅列出那些适用于当前选定内容的命令。

若要使用上下文菜单，请执行以下操作：

  1. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 对象或窗口。

    选定对象或窗口的上下文菜单随即出现。

  2. 从该上下文菜单中选择一个命令。


使用面板和面板组

Dreamweaver 中的面板被组织到面板组中。面板组中选定的面板显示为一个选项卡。每个面板组都可以展开或折叠，并且可以和其它面板组停靠在一起或取消停靠。

面板组还可以停靠到集成的应用程序窗口中（仅限 Windows）。这使得能够很容易地访问所需的面板，而不会使工作区变得混乱。

注意

当一个面板组处于浮动（取消停靠）状态时，面板组的顶部会显示一个窄的空白条。在本文档中，“面板组的标题栏”这个术语指的是面板组名称出现的区域，而不是这个窄的空白条。

本节包含以下主题：

  • 查看面板和面板组
  • 停靠和取消停靠面板和面板组
  • 重新调整面板组大小和重命名面板组
  • 设置“面板”首选参数


查看面板和面板组

您可以按需要显示或隐藏工作区中的面板组和面板。

若要展开或折叠一个面板组，请执行下列操作之一：

  • 单击面板组标题栏左侧的展开箭头。 这是所描述的功能的图片。
  • 单击面板组的标题。

若要关闭面板组使之在屏幕上不可见，请执行以下操作：

  • 从面板组标题栏中的“选项”菜单中选择“关闭面板组”。 这是所描述的功能的图片。

    该面板组即从屏幕上消失。

若要打开屏幕上不可见的面板组或面板，请执行以下操作：

  • 选择“窗口”菜单，然后从菜单中选择一个面板名称。

    “窗口”菜单中项目旁的复选标记表示指定的项目当前是打开的（虽然它可能隐藏在其它窗口后面）。

    提示

    如果您找不到一个标记为打开的面板、检查器或窗口，请选择“窗口”>“排列面板”以整齐地列出所有打开的面板。

若要在展开的面板组中选择一个面板，请执行以下操作：

  • 单击该面板的名称。

若要查看面板组的“选项”菜单（如果未显示），请执行以下操作：

  • 通过单击面板组名称或它的展开箭头展开该面板组。 这是所描述的功能的图片。

    “选项”菜单仅在面板组展开时才可见。

    提示

    即使在面板组处于折叠状态时，面板组的上下文菜单中的某些选项仍然可用；右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 面板组的标题栏可以查看上下文菜单。


停靠和取消停靠面板和面板组

您可以按需要移动面板和面板组，并能够对它们进行排列，使之浮动或停靠在工作区中。

大多数面板仅能停靠在集成工作区中“文档”窗口区域的左侧或右侧，而另外一些面板（如“属性”检查器和“插入”栏）则仅能停靠在集成窗口的顶部或底部。

若要取消停靠一个面板组，请执行以下操作：

  • 通过手柄（在面板组标题栏的左侧）拖动面板组，直到其轮廓表明它不再处于停靠状态为止。 这是所描述的功能的图片。

若要将一个面板组停靠到其它面板组（浮动工作区）或停靠到集成窗口（仅限 Windows），请执行以下操作：

  • 通过手柄拖动面板组，直到其轮廓表明它处于停靠状态为止。

若要从面板组中取消停靠一个面板，请执行以下操作：

  • 从面板组标题栏中的“选项”菜单中选择“组合至”>“新建面板组”。（“组合至”命令的名称根据活动面板的名称而改变。） 这是所描述的功能的图片。

    该面板出现在一个由它自己组成的新的面板组中。

若要在面板组中停靠一个面板，请执行以下操作：

  • 从面板组的“选项”菜单的“组合至”子菜单中选择一个面板组名称。（“组合至”命令的名称根据活动面板的名称而改变。）

若要拖动一个浮动（取消停靠）面板组而不停靠它，请执行以下操作：

  • 通过面板组标题栏上方的条来拖动它。只要您不是通过手柄拖动面板组，它就不会停靠。


重新调整面板组大小和重命名面板组

您可以根据自己的需要更改面板组的大小和名称。

若要更改面板组的大小，请执行以下操作：

  • 对于浮动面板，可像通过拖动方式调整操作系统中任何窗口的大小一样，通过拖动来调整面板组集合的大小。

    例如，您可以拖动面板组集合的右下角的调整大小区域。

  • 对于停靠的面板，可拖动面板与“文档”窗口之间的拆分条。

若要最大化一个面板组，请执行下列操作之一：

  • 从面板组标题栏中的“选项”菜单中选择“最大化面板组”。 这是所描述的功能的图片。
  • 在面板组标题栏的任何位置双击。

    面板组将垂直增长以填充全部可用垂直空间。

若要重命名面板组，请执行以下操作：

  1. 从面板组标题栏中的“选项”菜单中选择“重命名面板组”。
  2. 输入一个新的名称，然后单击“确定”。


保存面板组

Dreamweaver 允许您保存和恢复不同的面板组，以便针对不同的活动自定义您的工作区。当您保存工作区布局时，Dreamweaver 会记住指定布局中的面板以及其他属性，例如面板的位置和大小、面板的展开或折叠状态、应用程序窗口的位置和大小，以及“文档”窗口的位置和大小。

有关更多信息，请参见保存自定义工作区布局。


设置“面板”首选参数

您可以设置首选参数，指定哪些面板和检查器总是显示在“文档”窗口的前面，而哪些可以被“文档”窗口遮盖。

若要设置面板的首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从左侧的“类别”列表中选择“面板”。
  3. 选择选项。

    有关更多信息，请参见设置“面板”首选参数。

  4. 单击“确定”。


使用 Dreamweaver 辅助功能

Dreamweaver 提供了使它可供具有残疾的用户使用的功能。具体而言，Dreamweaver 支持屏幕阅读器、操作系统辅助功能和键盘导航。

本节包含以下主题：

  • 将屏幕阅读器用于 Dreamweaver
  • 操作系统辅助功能支持
  • 使用键盘导航 Dreamweaver

相关主题

  • Dreamweaver 和辅助功能


将屏幕阅读器用于 Dreamweaver

屏幕阅读器会朗读计算机屏幕上显示的文字。它还会在创作过程中朗读在辅助功能标签或属性中提供的非文本信息，例如应用程序中的按钮标签文字或图像说明。

作为 Dreamweaver 用户，您可以使用屏幕阅读器来协助您创建 Web 页。屏幕阅读器会从“文档”窗口的左上角开始朗读。

Dreamweaver 支持 Freedom Scientific (www.freedomscientific.com) 的 JAWS for Windows 和 GW Micro (www.gwmicro.com) 的 Window Eyes 屏幕阅读器。

相关主题

  • 操作系统辅助功能支持
  • 使用键盘导航 Dreamweaver


操作系统辅助功能支持

Dreamweaver 支持 Windows 和 Macintosh 操作系统中的辅助功能。例如，在 Macintosh 上，您可以在“通用访问首选参数”对话框（“Apple”>“系统首选参数”）中设置可视化首选参数。您的设置反映在 Dreamweaver 工作区中。

Dreamweaver 还支持 Windows 操作系统的高对比度设置。您可以通过 Windows 控制面板激活此选项。当启用高对比度后，它会按以下方式影响 Dreamweaver：

  • 对话框和面板使用系统颜色设置。

    例如，如果您将颜色设置为“黑底白字”，则所有 Dreamweaver 对话框和面板都会显示为白色的前景色和黑色的背景颜色。

  • “代码”视图语法颜色被禁用。

    “代码”视图使用系统窗口和窗口文本颜色而忽略“首选参数”中的颜色设置。例如，如果您将系统颜色设置为“黑底白字”，然后在“首选参数”>“代码颜色”中更改文本颜色，则 Dreamweaver 会忽略在“首选参数”中设置的颜色并以白色前景色和黑色背景颜色显示代码文本。

  • 设计视图使用您在“修改”>“页面属性”中设置的背景颜色和文本颜色，使您设计的页面像浏览器一样呈现颜色。

相关主题

  • 将屏幕阅读器用于 Dreamweaver
  • 使用键盘导航 Dreamweaver


使用键盘导航 Dreamweaver

您可以使用键盘来导航 Dreamweaver 面板、检查器、对话框、框架和表格，而无需使用鼠标。

本节包含以下主题：

  • 导航面板
  • 导航“属性”检查器
  • 导航对话框
  • 导航框架
  • 导航表格

相关主题

  • 将屏幕阅读器用于 Dreamweaver
  • 操作系统辅助功能支持


导航面板

您可以使用键盘来导航面板。

注意

Windows 仅支持使用 Tab 键和箭头键。

若要导航面板，请执行以下操作：

  1. 在“文档”窗口中，按 Ctrl+Alt+Tab 可将焦点切换到某一面板。

    面板标题栏周围的白色轮廓指示焦点位于该面板。屏幕阅读器会朗读具有焦点的面板标题栏。

  2. 再次按 Ctrl+Alt+Tab 可将焦点切换到下一面板。

    继续切换，直到焦点位于您要在其中工作的面板。

  3. 如有必要，按 Ctrl+Alt+Shift+Tab 将焦点切换到前一个面板。
  4. 如果您要在其中工作的面板尚未打开，请使用 Windows 菜单中列出的快捷键显示相应的面板，然后按 Ctrl+Alt+Tab 将焦点切换到该面板。

    如果您要在其中工作的面板已打开但未展开，请将焦点置于该面板标题栏，然后按空格键。再次按空格键可折叠该面板。

  5. 按 Tab 键在该面板上的各个选项之间移动。

    选项周围的虚轮廓线指示焦点位于该选项。

  6. 正确地使用箭头键：
    • 如果某一选项包含若干选择，请使用箭头键滚动查看这些选择，然后按空格键做出选择。
    • 如果面板组中有选项卡可以打开其它面板，请将焦点置于打开的选项卡，然后使用左箭头键或右箭头键打开其它选项卡。当打开一个新的选项卡后，按 Tab 键便可在该面板上的各个选项之间移动。

相关主题

  • 导航“属性”检查器
  • 导航对话框
  • 导航框架
  • 导航表格


导航“属性”检查器

您可以使用键盘导航“属性”检查器并对文档做出更改。

注意

只有 Windows 才支持使用箭头键。

若要导航“属性”检查器，请执行以下操作：

  1. 按 Ctrl+F3 (Windows) 或 Command+F3 (Macintosh) 显示“属性”检查器（如果它不可见）。
  2. (Windows) 按 Ctrl+Alt+Tab，直到将焦点切换到“属性”检查器。
  3. 按 Tab 键在各个“属性”检查器选项之间移动。
  4. (Windows) 适当地使用箭头键在选项的各项选择之间移动。
  5. 在必要时按 Ctrl+Tab (Windows) 或 Option+Tab (Macintosh) 打开和关闭“属性”检查器的展开部分，或者在焦点位于右下部的展开箭头上时按空格键。

相关主题

  • 导航面板
  • 导航对话框
  • 导航框架
  • 导航表格


导航对话框

您可以使用键盘来导航对话框。

注意

只有 Windows 才支持使用箭头键。

若要导航对话框，请执行以下操作：

  1. 按 Tab 键在对话框中的各个选项之间移动。
  2. (Windows) 使用箭头键在选项的各项选择之间移动。

    例如，如果选项有弹出菜单，请将焦点移动到该选项，然后使用向下箭头键在各个选项之间移动。

  3. 如果该对话框包含“类别”列表，请按 Ctrl+Tab (Windows) 或 Option+Tab (Macintosh) 将焦点切换到“类别”列表，然后使用箭头键在列表中向上或向下移动。
  4. 再次按 Ctrl+Tab (Windows) 或 Option+Tab (Macintosh) 以切换到某一类别的选项。
  5. 按 Enter 键 (Windows) 或 Return 键 (Macintosh) 退出该对话框。

相关主题

  • 导航面板
  • 导航“属性”检查器
  • 导航框架
  • 导航表格


导航框架

如果您的文档包含框架，则可以使用箭头键将焦点切换到框架上。

注意

只有 Windows 才支持使用箭头键。

若要选择一个框架，请执行以下操作：

  1. 将插入点放在“文档”窗口中。
  2. 按 Alt+向上箭头键，以选择当前具有焦点的框架。

    虚线指示具有焦点的框架。

  3. 继续按 Alt+向上箭头，将焦点切换到框架集，如果存在嵌套框架集，则再切换到父框架集。
  4. 按 Alt+向下箭头键，将焦点切换到子框架集或该框架集中的一个框架。
  5. 当焦点位于单个框架中时，按 Alt+左箭头键或右箭头键在各个框架之间移动。
  6. 按 Alt+向下箭头键，将插入点放在“文档”窗口中。

相关主题

  • 导航面板
  • 导航“属性”检查器
  • 导航对话框
  • 导航表格


导航表格

当选择一个表格后，可以使用键盘在该表中导航。

若要导航表格，请执行以下操作：

  1. 如有必要，使用箭头键或按 Tab 键移动到表格中的其它单元格。

    提示

    如果在最右侧的单元格中按 Tab 键，则会将另一行添加到表格中。
  2. 若要选择一个单元格，请在插入点位于该单元格时按 Ctrl+A (Windows) 或 Command+A (Macintosh)。
  3. 若要选择表格，如果插入点位于单元格中，请按 Ctrl+A (Windows) 或 Command+A (Macintosh) 两次，如果单元格处于选定状态，则按一次。
  4. 若要退出表格，请按 Ctrl+A (Windows) 或 Command+A (Macintosh) 三次（如果插入点位于单元格中）、两次（如果单元格处于选定状态）或一次（如果表格处于选定状态），然后按向上、向左或向右箭头键。

相关主题

  • 导航面板
  • 导航“属性”检查器
  • 导航对话框
  • 导航框架


优化工作区以进行有辅助功能的页面设计

当您创建可用的页面时，需要将标签文字和说明等信息与页面对象相关联，以使您的内容可供所有用户使用。

要这样做，请激活每个对象的“辅助功能”对话框，以便 Dreamweaver 在您插入对象时提示您输入辅助功能信息。您可以在“首选参数”的“辅助功能”类别中为任何对象激活对话框。

若要激活辅助功能对话框，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从左侧的“类别”列表中选择“辅助功能”。

    “首选参数”对话框显示了辅助功能选项。

  3. 选择要为其激活“辅助功能”对话框的对象。

    有关更多信息，请参见设置“辅助功能”首选参数。

    注意

    当您插入新表格时，辅助功能属性会自动显示在“插入表格”对话框中。
  4. 单击“确定”。

对于您选择的每个对象，当您在文档中插入该对象时，“辅助功能”对话框会提示您输入辅助功能标签和属性。

相关主题

  • Dreamweaver 和辅助功能
  • 插入图像
  • 验证 HTML 表单数据
  • 创建框架和框架集
  • 插入和编辑媒体对象
  • 插入一个表格并添加内容


使用可视化助理 Dreamweaver

Dreamweaver 提供了几种可视化助理，帮助您设计文档和（大概）估计文档在浏览器中的外观。您可以执行以下任一操作：

  • 立即将“文档”窗口与所需的窗口大小对齐，查看元素如何适应页面。（请参见调整“文档”窗口的大小。）
  • 用跟踪图像作为页面背景，帮助您复制在图表或图像编辑应用程序（如 Macromedia Fireworks）中创建的设计。（请参见使用跟踪图像。）
  • 用标尺和辅助线为精确定位和调整页面元素提供可视的提示。（请参见使用标尺、辅助线和网格设计页面布局。）
  • 使用网格精确定位层和调整层大小。（请参见使用网格。）

    页面上的网格标记有帮于对齐层，启用对齐后，移动层或调整层大小时层自动与最近的网格点对齐。（其它对象，如图像和段落，不与网格对齐。）不论网格是否可见，对齐都有效。


Dreamweaver 自定义基础

使用一些基本技巧，可以自定义 Dreamweaver 使其适合您的需要，而无须了解复杂的代码或编辑文本文件。例如，您可以更改工作区布局、隐藏或显示“起始”页、设置参数、创建自己的快捷键以及向 Dreamweaver 添加功能扩展。

有关在工作区中自定义面板布局的信息，请参见使用面板和面板组。

注意

有关手动自定义配置文件的信息，请参见 Macromedia 支持中心上的“自定义 Dreamweaver”，网址为：www.macromedia.com/go/customizing_dreamweaver_cn。

本节仅描述首选参数选项中最常用的部分。有关其他各种首选参数选项的信息，请参见设置 Dreamweaver 首选参数。

本节包含以下主题：

  • 选择工作区布局（仅限 Windows）
  • 显示选项卡式文档 (Macintosh)
  • 保存自定义工作区布局
  • 隐藏和显示起始页
  • 设置 Dreamweaver 的“常规”首选参数
  • 设置 Dreamweaver 显示的“字体”首选参数
  • 自定义快捷键
  • 添加功能扩展 Dreamweaver

相关主题

  • 关于在多用户系统中自定义 Dreamweaver
  • 扩展 Dreamweaver


选择工作区布局（仅限 Windows）

在 Windows 中，您可以选择“设计器”和“编码器”工作区布局。首次启动 Dreamweaver 时，会出现一个对话框让您选择一种工作区布局。您可以随时切换到不同的工作区。

若要在首次启动 Dreamweaver 时选择一种工作区样式，请执行以下操作：

  1. 选择以下布局之一：

    设计器是一个使用 MDI（多文档界面）的集成工作区，其中全部“文档”窗口和面板被集成在一个较大的应用程序窗口中，并将面板组停靠在右侧。

    编码器同样是集成的工作区，但是将面板组停靠在左侧，布局类似于 Macromedia HomeSite 和 Macromedia ColdFusion Studio 所用的布局，而且“文档”窗口在默认情况下显示“代码”视图。

    注意

    您可以将面板组停靠在任意布局中的工作区的任意一端。
  2. 单击“确定”。

若要在选择一种工作区后切换到另一种工作区，请执行以下操作：

  • 选择“窗口”>“工作区布局”，然后选择您喜欢的工作区布局。

除了选择“编码器”和“设计器”外，您还可以选择“双重屏幕居右”或“双重屏幕居左”。如果主显示器右边有一个辅助显示器，“双重屏幕居右”可将所有面板放在右边的显示器上，而将“文档”窗口保留在主显示器上。如果主显示器左边有一个辅助显示器，“双重屏幕居左”可将所有面板放在左边的显示器上，而将“文档”窗口保留在主显示器上。

相关主题

  • 工作区布局
  • 保存自定义工作区布局
  • 以层叠或平铺方式放置“文档”窗口
  • 显示选项卡式文档 (Macintosh)


显示选项卡式文档 (Macintosh)

在 Macintosh 上，通过使用选项卡来标识每个文档，Dreamweaver 可以在单个窗口中显示多个文档。Dreamweaver 还可以将它们显示为浮动工作区的一部分，其中的每个文档都显示在它自己的窗口中。

若要在单独的窗口中打开选项卡式文档，请执行以下操作：

  • 右键单击或按住 Ctrl 键单击选项卡，然后从上下文菜单中选择“移至新窗口”。

若要将单独的文档合并为选项卡式窗口，请执行以下操作：

  • 选择“窗口”>“合并为选项卡”。

若要更改默认选项卡式文档的设置，请执行以下操作：

  1. 选择“Dreamweaver”>“首选参数”，然后选择“常规”类别。
  2. 选择或取消选择“以选项卡方式打开文档”，然后单击“确定”。

    注意

    在您更改首选参数时，Dreamweaver 不会更改当前打开的文档的显示。但是，在选择新的首选参数之后打开的文档将按照您所选的首选参数进行显示。

相关主题

  • 工作区布局
  • 保存自定义工作区布局
  • 以层叠或平铺方式放置“文档”窗口


保存自定义工作区布局

Dreamweaver 使您可以保存和恢复不同的面板设置，以便为不同的活动自定义您的工作区。当您保存工作区布局时，Dreamweaver 会记住指定布局中的面板以及其他属性，例如面板的位置和大小、面板的展开或折叠状态以及应用程序窗口的位置和大小

若要保存自定义工作区布局，请执行以下操作：

  1. 根据需要排列面板。
  2. 选择“窗口”>“工作区布局”>“保存当前”。
  3. 输入布局的名称并单击“确定”。

若要切换到另一自定义工作区布局，请执行以下操作：

  • 选择“窗口”>“工作区布局”，然后选择您的自定义布局。

若要重命名或删除自定义工作区布局，请执行以下操作：

  1. 选择“窗口”>“工作区布局”>“管理”。
  2. 选择一个布局，然后执行以下操作之一：
    • 若要重命名布局，请单击“重命名”按钮，输入新的布局名称，然后单击“确定”。
    • 若要删除布局，请单击“删除”按钮。
  3. 单击“确定”。

相关主题

  • 使用面板和面板组
  • 选择工作区布局（仅限 Windows）
  • 显示选项卡式文档 (Macintosh)


隐藏和显示起始页

在启动 Dreamweaver 时以及在每次没有打开文档时，都会显示 Dreamweaver 起始页。您可以选择隐藏起始页，以后再显示它。当起始页被隐藏并且没有打开的文档时，“文档”窗口处于空白状态。

注意

您可以选择 Dreamweaver 每次启动时打开上次处理的文档。有关更多信息，请参见设置 Dreamweaver 的“常规”首选参数。

若要隐藏起始页，请执行以下操作：

  • 选择起始页上的“不再显示此对话框”复选框。

在启动 Dreamweaver 时，或在打开然后关闭一个文档后将不再显示起始页。

若要显示起始页，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)。

    出现“首选参数”对话框，其中显示了“常规”首选项类别。

  2. 选择“显示起始页”复选框。

在启动 Dreamweaver 时，或在打开然后关闭一个文档后将显示起始页。


设置 Dreamweaver 的“常规”首选参数

“常规”首选参数控制 Dreamweaver 的常规外观。

若要更改“常规”首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)。

    出现“首选参数”对话框，其中显示了“常规”首选项类别。

  2. 设置首选参数选项。

    有关更多信息，请参见设置“常规”首选参数。

  3. 单击“确定”。


设置 Dreamweaver 显示的“字体”首选参数

文档的编码方式确定如何在浏览器中显示文档。Dreamweaver 字体首选参数使您能够以喜爱的字体和大小查看给定的编码，而不影响其他人在浏览器中查看时文档的显示方式。

若要为每种编码方式设置在 Dreamweaver 中使用的字体，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从左侧的“类别”列表中选择“字体”。
  3. 从“字体设置”列表中选择一种编码类型，如西欧语系 (Latin1) 或日语，然后使用“字体设置”列表下面的字体弹出菜单选择该编码方式在 Dreamweaver 中使用的字体。

    有关更多信息，请参见设置 Dreamweaver 显示的“字体”首选参数。

    注意

    您选择的字体不会影响文档在访问者的浏览器中的显示方式。
  4. 单击“确定”。

相关主题

  • 了解文档编码


自定义快捷键

使用快捷键编辑器可以创建自己的快捷键，包括代码片断的快捷键。您也可以在快捷键编辑器中删除快捷键、编辑现有的快捷键以及选择一组预定义的快捷键。

注意

Macromedia Web 站点上以快速参考指南方式提供了显示默认 Dreamweaver 配置中所有快捷键的图表，网址为 www.macromedia.com/go/dw_documentation_cn。

要自定义快捷键，请执行以下操作：

  1. 选择“编辑”>“快捷键”(Windows) 或 Dreamweaver>“快捷键”(Macintosh)。

    出现“快捷键”对话框。

  2. 添加、删除或编辑快捷键。

    有关更多信息，请参见设置“快捷键”对话框选项。

  3. 单击“确定”。


添加功能扩展 Dreamweaver

功能扩展是一些您可以容易地添加到 Dreamweaver 中的新功能。您可以使用许多类型的功能扩展，例如用来重新格式化表格、连接到后端数据库或者帮助您为浏览器撰写脚本的功能扩展。

注意

若要在多用户操作系统中安装所有用户都能访问的功能扩展，您必须作为管理员 (Windows) 或根 (Mac OS X) 登录。有关多用户系统的更多信息，请参见关于在多用户系统中自定义 Dreamweaver。

若要查找 Dreamweaver 的最新功能扩展，请使用 Macromedia Exchange Web 站点，网址为：www.macromedia.com/go/dreamweaver_exchange_cn/。您可以在此处登录并下载功能扩展（其中的许多功能扩展是免费的），还可以加入讨论组、查看用户的评论以及安装和使用功能扩展管理器。在安装功能扩展前必须安装功能扩展管理器。

功能扩展管理器是一个独立的应用程序，可用于安装和管理 Macromedia 应用程序中的功能扩展。通过从 Dreamweaver 中选择“命令”>“管理扩展功能”启动功能扩展管理器。

若要安装和管理功能扩展，请执行以下操作：

  1. 在 Macromedia Exchange 站点上，单击某个功能扩展的下载链接。

    浏览器可能会让您选择是直接从站点打开并安装它还是将它保存到磁盘。

    • 如果您直接从站点打开功能扩展，则功能扩展管理器将自动处理安装。
    • 如果您将功能扩展保存到磁盘，最好将功能扩展包文件 (.mxp) 保存到计算机上 Dreamweaver 应用程序文件夹内的 Downloaded Extensions 文件夹中。
  2. 双击功能扩展包文件，或者打开功能扩展管理器并选择“文件”>“安装功能扩展”。

    功能扩展将被安装在 Dreamweaver 中。有些功能扩展在 Dreamweaver 重新启动前不可访问；可能会提示您退出然后重新启动该应用程序。

    注意

    使用功能扩展管理器可删除功能扩展或者查看有关功能扩展的更多信息。


参考资料

本节提供了有关本章中介绍的以下对话框和检查器的信息，以及有关设置 Dreamweaver 首选参数的信息：

  • 设置“字体”首选参数
  • 设置“常规”首选参数
  • 设置“标记色彩”参数
  • 设置“面板”首选参数
  • 设置“状态栏”首选参数
  • 设置“自定义收藏对象”对话框选项
  • 设置“重命名面板组”对话框选项
  • 设置“首字母缩写词或缩写”对话框选项
  • 设置“辅助功能”首选参数
  • 设置“快捷键”对话框选项
  • 设置 Dreamweaver 首选参数


设置“字体”首选参数

此对话框允许您指定 Dreamweaver 用来显示每种字体编码的字体。有关为新文档设置默认编码方式的信息，请参见创建和打开文档。

注意

您选择的字体不会影响文档在访问者的浏览器中的显示方式。

若要为每种编码方式设置在 Dreamweaver 中使用的字体，请执行以下操作：

  1. 从“字体设置”列表中选择一种编码类型（如西欧语系或日语）。

    字体设置用以指定在 Dreamweaver 中针对使用给定编码类型的文档所用的字体集。例如，若要指定日语文档使用的字体，请从“字体设置”列表中选择“日语”，然后从下面的菜单中选择一种均衡字体、一种固定字体、一种代码视图字体和一种标签检查器字体；所有采用日语编码方式的文档在 Dreamweaver 中随后都将使用这些指定的字体显示。

    若要指定用于美国英语和全部西欧语言的字体，请从“字体设置”列表中选择“西欧语系”，然后从字体弹出菜单中选择包含四种字体的一组字体。若要为亚洲语言设置适当的双字节字体，请选择“日语”、“繁体中文”、“简体中文”或“韩文”。（若要显示亚洲语言，您必须使用支持双字节字体的操作系统。）您还可以为“中欧”、“西里尔语”、“希腊语”、“冰岛 Mac”或“其它”编码方式选择字体。

  2. 使用“字体设置”列表下方的字体弹出菜单，选择在 Dreamweaver 中用于所选编码方式的字体。请为每个类别选择一种字体和大小。

    注意

    若要在字体弹出菜单中显示一种字体，该字体必须安装在计算机上。例如，若要查看日语文本，必须安装日语字体。

    均衡字体是 Dreamweaver 用以显示普通文本（如段落、标题和表格中的文本）的字体。其默认值取决于系统上安装的字体。对于大多数美国系统，在 Windows 中默认值为 Times New Roman 12 pt（中），在 Macintosh 中为 Times 12 pt。

    固定字体是 Dreamweaver 用以显示 pre、code 和 tt 标签内文本的字体。其默认值取决于系统上安装的字体。对于大多数美国系统，在 Windows 中默认值为 Courier New 10 pt（小），在 Macintosh 中默认值为 Monaco 12 pt。

    代码视图是用以显示“代码”视图和代码检查器中所有文本的字体。其默认值取决于系统上安装的字体。

    使用动态字体映射是一种可用于 Windows 平台上的 Unicode 编码的选项。如果选择此选项，Dreamweaver 将检查选定的字体家族是否具有用于呈现每个字符的必需字形。如果字体家族缺少字形，Dreamweaver 将用可显示所需字符的适当字体家族代替。当您在单一文档中使用多种语言时，这样可防止出现不需要的字符。

    如果启用此选项，将页面加载到浏览器中所花的时间会稍微增长。

    注意

    此选项只可在 Windows 平台上使用。在 Macintosh 上，字体始终是动态映射的。
  3. 单击“确定”以保存您的首选参数。


设置“常规”首选参数

此对话框允许您为 Dreamweaver 的常规外观指定首选参数。“常规”首选参数分为两个子类别：“文档选项”和“编辑选项”。

若要指定常规首选参数，请执行以下操作：

  1. 指定以下选项：

    以选项卡方式打开文档将在带有选项卡的单个窗口中打开所有的文档，使您可以在文档之间进行切换（仅限 Macintosh）。

    显示起始页用于在启动 Dreamweaver 或没有打开任何文档时显示 Dreamweaver 起始页。

    启动时重新打开文档打开在关闭 Dreamweaver 时处于打开状态的任何文档。如果未选择此选项，Dreamweaver 会在启动时显示起始页或空白屏幕（这取决于“显示起始页”设置）。

    打开只读文件时发出警告在打开只读文件（锁定的文件）时发出警告。为您提供了解锁/取出文件、查看文件或取消的选项。

    移动文件时更新链接确定当您移动、重命名或删除站点中的文档时 Dreamweaver 所执行的操作。您可以将该参数设置为总是自动更新链接、从不更新链接或提示您执行更新。（请参见管理链接。）

    更改工作区（仅限 Windows）使您可以选择“设计器”布局（面板位于右侧的集成工作区）或“编码器”布局（面板位于左侧的集成工作区）。在“设计器”布局中，文档默认在“设计”视图中显示，而在“编码器”布局中，文档默认在“代码”视图中显示。选择新工作区后，退出 Dreamweaver 然后重新启动它以查看所作的更改。有关更多信息，请参见工作区布局。

    插入对象时显示对话框确定当您使用“插入”栏或“插入”菜单插入图像、表格、Shockwave 影片和其它某些对象时 Dreamweaver 是否提示您输入附加的信息。如果禁用该选项，则不出现对话框，您必须使用“属性”检查器指定图像的源文件和表格中的行数等。对于鼠标经过图像和 Fireworks HTML，当您插入对象时总是出现一个对话框，而与该选项的设置无关。（若要暂时覆盖该设置，请在创建和插入对象时按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh)。）

    允许行内双字节输入使您能够直接将双字节文本输入到“文档”窗口中（如果您正在使用适合于双字节文本（如日语字符）处理的开发环境或语言工具包）。如果取消选择该选项，将显示一个用于输入和转换双字节文本的文本输入窗口；文本被接受后显示在“文档”窗口中。（请参见设置 Dreamweaver 显示的“字体”首选参数。）

    标题后切换到普通段落指定在“设计”视图中于一个标题段落的结尾按下 Enter 键 (Windows) 或 Return 键 (Macintosh) 时，将创建一个用 p 标签进行标记的新段落。（标题段落是用 h1 或 h2 等标题标签进行标记的段落。）当禁用该选项时，在标题段落的结尾按下 Enter 健或 Return 键将创建一个用同一标题标签进行标记的新段落（允许您在一行中键入多个标题，然后返回并填入详细信息）。

    允许多个连续的空格指定在“设计”视图中键入两个或更多的空格时将创建不中断的空格，这些空格在浏览器中显示为多个空格。（例如，您可以在句子之间键入两个空格，就如同在打字机上一样。）该选项主要针对习惯于在字处理程序中键入的用户。当禁用该选项时，多个空格将被当作单个空格（因为浏览器将多个空格当作单个空格）。

    使用 <strong> 和 <em> 代替 <b> 和 <i>规定：只要您执行的操作通常会用到 b 标签和 i 标签，Dreamweaver 就应分别使用 strong 标签和 em 标签取代它们。此类操作包括在 HTML 模式下的文本“属性”检查器中单击“粗体”或“斜体”按钮和选择“文本”>“样式”>“粗体”或“文本”>“样式”>“斜体”。若要在您的文档中使用 b 和 i 标签，请取消选择此选项。

    注意

    WWW 联合会不鼓励使用 b 和 i 标签；strong 和 em 标签在提供的语义信息上比 b 和 i标签更明确。

    使用 CSS 而不是 HTML 标签指定 Dreamweaver 在您使用“属性”检查器设置文本格式时使用 CSS 样式而不是 HTML 标签。默认情况下，Dreamweaver 使用 CSS 来设置文本格式。每次对所选文本定义字体、大小或颜色时，Dreamweaver 会创建一个特定于该文档的新样式，该样式仅在此时可以从“属性”检查器的“样式”弹出式菜单中看到。唯一的例外情况就是粗体和斜体，Dreamweaver 会使用 HTML 标签而不是 CSS。

    即使该文档链接到外部样式表，新的样式声明仍会写入到文档头中，而不是 CSS 文件中。

    在下列情况下，该常规行为可能会有所不同：

    • 如果该文档已经使用 font 标签对所有内容设置了格式，Dreamweaver 会假定它应该使用 font 标签，并用 HTML 代码修改 body 标签。
    • 如果该文档的 body 标签使用 HTML 设置页面的外观，但页面并不以独占方式使用 font 标签，则 Dreamweaver 仍会使用 CSS 来设置文本格式。

    如果取消选择该选项，Dreamweaver 会使用 HTML 标签，例如使用 font 标签设置文本格式，在 body 标签中使用 HTML 代码设置页面的外观。

    在 <p> 或 <h1><h6> 标签内放置可编辑区域时发出警告指定 Dreamweaver 在您保存一个段落或标题标签内具有可编辑区域的 Dreamweaver 模板时是否发出警告信息。该警告信息会通知您用户将无法在此区域中创建更多段落。该选项默认是打开的。

    历史步骤最多次数确定“历史记录”面板中保留和显示的步骤数。（默认值对于大多数用户来说应该足够使用。）如果您超过了“历史记录”面板中的给定步骤数，则将丢弃最早的步骤。（请参见任务自动化。）

    拼写字典列出可用的拼写字典。如果字典中包含多种方言或拼写惯例（如“英语（美国）”和“英语”（英国）），则方言单独列在“字典”弹出菜单中。

  2. 单击“确定”以保存您的首选参数。

相关主题

  • 设置 Dreamweaver 的“常规”首选参数


设置“标记色彩”参数

“标记色彩”首选参数使您可以自定义 Dreamweaver 用以标识模板区域、库项目、第三方标签、布局元素和代码的颜色。

若要更改标记色彩，请执行以下操作：

  • 在您要为其更改标记色彩的对象的旁边，单击颜色框，然后使用颜色选择器选择一种新颜色或输入一个十六进制值。

    注意

    有关使用颜色选择器的更多信息，请参见使用颜色

若要为对象激活或禁用标记色彩，请执行以下操作：

  • 在要激活或禁用标记色彩功能的对象的旁边，选择或取消选择“显示”复选框。

相关主题

  • 若要为表格、布局单元格和 CSS 布局块指定高亮颜色，请参见选择表格元素、绘制布局单元格和表格或更改 div 标签的高亮颜色。
  • 若要为模板或基于模板的文件中的可编辑区域和锁定区域指定高亮颜色，请参见设置模板区域的高亮显示首选参数。
  • 若要指定库项目的高亮颜色，请参见设置库高亮显示参数。
  • 若要为使用第三方标签进行标记的内容指定标记色彩，请为“第三方标签”选项选择一种颜色。有关第三方标签的更多信息，请参见 Macromedia 支持中心上的“自定义 Dreamweaver”。
  • 有关查看动态数据的更多信息，请参见在“设计”视图中查看动态数据。


设置“面板”首选参数

此对话框使您可以指定哪些面板和检查器总是显示在“文档”窗口的前面，而哪些可以被“文档”窗口遮盖。

若要指定面板首选参数，请执行以下操作：

  1. 执行下列操作之一：
    • 取消选择您不想为其应用“总在最上层”选项的所有面板和检查器。

      注意

      当全部面板都被停靠时，“总在最上层”选项在集成工作区中不适用。

      应用“总在最上层”选项后，所有面板、检查器及其他类似的“浮动”窗口在默认情况下都将显示在“文档”窗口的前面。如果您在该列表中取消选择一个项目，则您可以将“文档”窗口移动到该项目的前面。

      例如，若要允许“文档”窗口遮盖“属性”检查器，可以取消选择“属性”选项。这样，仅当“属性”检查器处于活动状态时，它才显示在“文档”窗口的前面。

    • 若要允许“文档”窗口遮盖任何您已通过自定义 Dreamweaver 添加的浮动面板，请取消选择“所有其它面板”。
  2. 单击“确定”以保存您的首选参数。

相关主题

  • 设置“面板”首选参数


设置“状态栏”首选参数

此对话框允许您为状态栏中显示的元素指定首选参数。

若要指定“状态栏”首选参数，请执行以下操作：

  1. 指定以下选项：

    窗口大小使您可以自定义出现在状态栏弹出菜单中的窗口大小。（请参见调整“文档”窗口的大小。）

    连接速度确定用以计算下载大小的连接速度（以 KB/秒为单位）。页面的下载大小显示在状态栏中。当在“文档”窗口中选定一个图像时，该图像的下载大小显示在“属性”检查器中。

  2. 单击“确定”以保存您的首选参数。

相关主题

  • 状态栏
  • 设置“状态栏”首选参数


设置“自定义收藏对象”对话框选项

此对话框使您可以对“插入”栏中最常用的按钮进行分组和组织。

若要完成“自定义收藏对象”对话框，请执行以下操作：

  1. 执行以下任何操作：
    • 要添加对象，在左侧“可用对象”窗格中选择一个对象，然后单击两个窗格之间的箭头，或在“可用对象”窗格中双击该对象。

      注意

      每次只能添加一个对象。不能选择类别名称（如“常用”）将整个类别添加到收藏列表中。

      该对象会出现在右侧的“收藏对象”窗格中。

    • 若要删除对象或分隔符，请在右侧的“收藏对象”窗格中选择一个对象，然后单击窗格上方的“删除‘收藏对象’列表中选择的对象”按钮。

      该对象将从“收藏对象”窗格中消失。

    • 若要移动对象，请在右侧的“收藏对象”窗格中选择一个对象，然后单击窗格上方的向上或向下箭头按钮。

      该对象将在“收藏对象”窗格中移动。

    • 若要在对象下面添加分隔符，请在右侧的“收藏对象”窗格中选择一个对象，然后单击窗格下方的“添加分隔符”按钮。

      一个分隔符将出现在所选对象的下方。

  2. 单击“确定”。

    “插入”栏的“收藏”类别会反映出您所作的更改。

相关主题

  • 在“插入”栏中自定义和使用“收藏”类别


设置“重命名面板组”对话框选项

此对话框允许您更改面板组的名称。

若要重命名面板组，请执行以下操作：

  1. 在“面板组名称”文本框中输入新的名称。
  2. 单击“确定”。

相关主题

  • 使用面板和面板组


设置“首字母缩写词或缩写”对话框选项

此对话框用于输入首字母缩写词或缩写的完整文本。

若要完成“首字母缩写词或缩写”对话框，请执行以下操作：

  1. 输入该首字母缩写词或缩写的完整文本。
  2. 输入语言的名称。
  3. 单击“确定”。


设置“辅助功能”首选参数

此对话框用于激活辅助功能对话框。

若要激活辅助功能对话框，请执行以下操作：

  1. 在“插入时显示属性”下，选择要为其激活辅助功能对话框的对象。

    对于您选择的每个对象，当您在文档中插入该对象类型时，一个“辅助功能”对话框会提示您输入辅助功能标签或属性。

    注意

    当您插入新表格时，辅助功能属性会自动显示在“插入表格”对话框中。
  2. 如果要在打开某个面板后访问该面板，请选择“保持焦点”选项。

    默认情况下，当您打开某个面板后，Dreamweaver 会将焦点保持在“设计”视图或“代码”视图中。如果要使用屏幕阅读器，这将使得访问面板十分困难。选择此选项将使您能够访问面板。

  3. 如果无法使用屏幕阅读器，则取消选择“屏幕外呈现”复选框。
  4. 单击“确定”。

相关主题

  • 优化工作区以进行有辅助功能的页面设计


设置“快捷键”对话框选项

此对话框用于创建您自己的快捷键、编辑现有的快捷键或选择一组预定义的快捷键。

若要完成“快捷键”对话框，请执行以下操作：

  1. 设置以下任一选项：

    当前设置允许您选择 Dreamweaver 中提供的一组预定义快捷键或者任何一组您自定义的快捷键。预定义的快捷键组列在菜单的上方。例如，如果您很熟悉 HomeSite 或 BBEdit 中的快捷键，则可以通过选择相应的预定义组来使用这些快捷键。

    命令允许您选择要编辑的命令类别。例如，您可以编辑菜单命令（如“打开”命令）或代码编辑命令（如“平衡大括弧”）。

    提示

    若要为代码片断添加或编辑快捷键，请从“命令”弹出菜单中选择“代码片断”。有关创建代码片断的信息，请参见使用代码片断。

    命令列表显示与您从“命令”弹出菜单中选择的类别相关联的命令以及指定的快捷键。“菜单命令”类别将该列表显示为一个树状视图，该视图复制了菜单的结构。其它的类别在一个平面列表中按名称（如“退出应用程序”）顺序列出命令。

    快捷键显示分配给选定命令的全部快捷键。

    添加项 (+) 向当前命令添加一个新的快捷键。单击该按钮可以向“快捷键”文本框添加一个新的空行。输入一个新的键组合，然后单击“更改”为该命令添加一个新的快捷键。您可以为每个命令分配两个不同的快捷键；如果已经为某个命令分配了两个快捷键，则“添加项”按钮将不执行任何操作。

    删除项 (-) 从快捷键列表中删除选定的快捷键。

    按键在您添加或更改快捷键时显示您输入的键组合。

    更改将显示在“按键”文本框中的键组合添加到快捷键列表中，或者将选定的快捷键更改为指定的键组合。

    复制副本复制当前的快捷键组。为新的快捷键组指定一个名称；它的默认名称为当前快捷键组的名称后面追加单词 copy。

    重命名设置重命名当前的快捷键组。

    将集合导出为 HTML 文件以 HTML 表格的格式保存当前的快捷键组，以便于查看和打印。为了便于参考，您可以在浏览器中打开该 HTML 文件并将快捷键打印出来。

    删除设置删除一个快捷键组。（不能删除活动快捷键组。）

  2. 单击“确定”。

若要删除命令的快捷键，请执行以下操作：

  1. 从“命令”弹出菜单中选择一个命令类别。

    “命令”列表显示该类别中的命令。

  2. 在“命令”列表中选择一个命令。

    分配给该命令的快捷键显示在“快捷键”文本框中。

  3. 选择一个快捷键。
  4. 单击“删除项 (-)”按钮。

若要向命令添加快捷键，请执行以下操作：

  1. 从“命令”弹出菜单中选择一个命令类别。

    “命令”列表显示该类别中的命令。

  2. 在“命令”列表中选择一个命令。

    提示

    若要为代码片断添加快捷键，请从“命令”弹出菜单中选择“代码片断”。有关创建代码片断的信息，请参见使用代码片断。

    分配给该命令的快捷键显示在“快捷键”文本框中。

  3. 执行下列操作之一添加一个快捷键：
    • 如果已经分配给该命令的快捷键少于两个，请单击“添加项 (+)”按钮。“快捷键”文本框中显示一个新的空行，并且插入点移动到“按键”文本框中。
    • 如果已经分配给该命令两个快捷键，则选择其中之一（该快捷键将被新的快捷键替代）。然后在“按键”文本框中单击。
  4. 按下一个键组合。

    该键组合显示在“按键”文本框中。

    注意

    如果该键组合存在问题（例如，该键组合已经分配给另一个命令），则紧跟“快捷键”文本框下面会显示一条解释性信息，并且您可能无法添加或编辑该快捷键。
  5. 单击“更改”。新的键组合就被分配给该命令。

若要编辑现有的快捷键，请执行以下操作：

  1. 从“命令”弹出菜单中选择一个命令类别。

    “命令”列表显示该类别中的命令。

  2. 在“命令”列表中选择一个命令。

    分配给该命令的快捷键显示在“快捷键”文本框中。

  3. 选择要更改的快捷键。
  4. 在“按键”文本框中单击，然后输入一个新的键组合。
  5. 单击“更改”按钮以更改该快捷键。

    注意

    如果该键组合存在问题（例如，该键组合已经分配给另一个命令），则紧跟“快捷键”字段下面会显示一条解释性信息，并且您可能无法添加或编辑该快捷键。

相关主题

  • 自定义快捷键


设置 Dreamweaver 首选参数

Dreamweaver 具有用来控制 Dreamweaver 用户界面的常规外观和行为的首选参数设置以及与特定功能（如层、样式表、显示 HTML 和 JavaScript 代码、外部编辑器和在浏览器中预览等）相关的选项。

有关设置 Dreamweaver 首选参数的信息，请参见以下章节：

  • 设置 Dreamweaver 的“常规”首选参数
  • 优化工作区以进行有辅助功能的页面设计
  • 设置“代码颜色”首选参数
  • 设置代码格式首选参数选项
  • 设置代码提示首选参数
  • 设置“代码改写”首选参数
  • 设置 CSS 样式首选参数
  • 在 Dreamweaver 中指定比较工具
  • 设置“文件类型/编辑器”首选参数选项
  • 设置外部图像编辑器首选参数
  • 为媒体文件启动外部编辑器
  • 设置 Dreamweaver 显示的“字体”首选参数
  • 设置“标记色彩”参数
  • 设置“不可见元素”首选参数
  • 设置层首选参数
  • 设置“布局”模式的首选参数
  • 设置“新建文档”的“首选参数”对话框中的选项
  • 插入指向 Word 或 Excel 文档的链接
  • 设置“面板”首选参数
  • 设置“在浏览器中预览”首选参数选项
  • 设置“站点”首选参数选项
  • 设置“状态栏”首选参数
  • 设置验证程序首选参数


设置 Dreamweaver 站点

Web 站点是一组具有共享属性（如相关主题、类似的设计或共同目的）的链接文档和资源。Macromedia Dreamweaver 8 是一个站点创建和管理工具，因此使用它不仅可以创建单独的文档，还可以创建完整的 Web 站点。

创建 Web 站点的第一步是规划。为了达到最佳效果，在创建任何 Web 站点页面之前，应对站点的结构进行设计和规划。

下一步是设置 Dreamweaver 以使您可以在站点的基本结构上工作。如果在 Web 服务器上已经具有一个站点，则可以使用 Dreamweaver 来编辑该站点。

提示

开发站点内容时，请考虑基于 Dreamweaver 模板创建页面。请参见关于 Dreamweaver 模板和创建 Dreamweaver 模板。

本章包括以下几节：

关于 Dreamweaver 站点

设置新的 Dreamweaver 站点

使用“高级”设置来设置 Dreamweaver 站点

编辑 Dreamweaver 站点设置

编辑现有 Web 站点 Dreamweaver


关于 Dreamweaver 站点

Dreamweaver 站点提供一种组织所有与 Web 站点关联的文档的方法。通过在站点中组织文件，可以利用 Dreamweaver 将站点上传到 Web 服务器、自动跟踪和维护链接、管理文件以及共享文件。若要充分利用 Dreamweaver 的功能，需要定义一个站点。

Dreamweaver 站点由三部分（或文件夹）组成，具体取决于开发环境和所开发的 Web 站点类型：

本地文件夹是您的工作目录。Dreamweaver 将该文件夹称为“本地站点”。此文件夹可以位于本地计算机上，也可以位于网络服务器上。这就是为 Dreamweaver 站点所处理的文件的存储位置。

只需建立本地文件夹即可定义 Dreamweaver 站点。若要向 Web 服务器传输文件或开发 Web 应用程序，还需添加远端站点和测试服务器信息。

远端文件夹是存储文件的位置，这些文件用于测试、生产、协作等，具体取决于开发环境。Dreamweaver 在“文件”面板中将该文件夹称为“远端站点”。一般说来，远端文件夹位于运行 Web 服务器的计算机上。

本地文件夹和远端文件夹使您能够在本地磁盘和 Web 服务器之间传输文件；这使您可以轻松管理 Dreamweaver 站点中的文件。

测试服务器文件夹是 Dreamweaver 处理动态页的文件夹。有关更多信息，请参见指定可在哪里处理动态页。

注意

有关设置本地和远端文件夹的信息，请参见了解本地和远端文件夹的结构。

相关主题

  • 设置新的 Dreamweaver 站点


了解本地和远端文件夹的结构

设置 Dreamweaver 站点远端文件夹访问权限时（请参见设置远端文件夹），必须确定远端文件夹的主机目录。指定的主机目录应该对应于本地文件夹的根文件夹。下面的示意图在左侧显示一个本地文件夹示例，在右侧显示一个远端文件夹示例。

如果远端文件夹结构与本地文件夹的结构不匹配，Dreamweaver 会将文件上传到错误的位置，站点的访问者将无法看到这些文件。图像和链接路径也可能被破坏。

远端根目录必须存在，Dreamweaver 才能连接到它。如果远端文件夹没有根目录，请创建一个根目录，或者请服务器管理员为您创建一个根目录。

即使只打算编辑远端站点的一部分，也必须在本地复制远端站点相关分支的整个结构，即从远端站点的根文件夹直到要编辑的文件。

例如，如果远端站点的根文件夹名为 public_html，它包含两个文件夹 Project1 和 Project2，而您仅想处理 Project1 中的 HTML 文件，则不需要下载 Project2 中的文件，但是必须将本地根文件夹映射为 public_html，而不是 Project1。

相关主题

  • 关于 Dreamweaver 站点
  • 设置远端文件夹


设置新的 Dreamweaver 站点

规划站点结构后，或者如果已经存在一个站点，应该先在 Dreamweaver 中定义站点，然后才能进行开发。设置 Dreamweaver 站点是一种组织所有与 Web 站点关联的文档的方法。有关更多信息，请参见关于 Dreamweaver 站点。

注意

您也可以在不设置 Dreamweaver 站点的情况下编辑文件。有关更多信息，请参见访问站点、服务器和本地驱动器。

设置好 Dreamweaver 站点后，最好将该站点导出，以便拥有一个本地备份副本。有关更多信息，请参见导入和导出站点。

若要设置 Dreamweaver 站点，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

    注意

    如果您没有定义任何 Dreamweaver 站点，则会出现“站点定义”对话框，您可以跳过下一步。
  2. 单击“新建”按钮。

    出现“站点定义”对话框。

  3. 执行下列操作之一：
    • 单击“基本”选项卡以使用“站点定义向导”，它将引导您逐步完成设置过程。

      注意

      鼓励不熟悉 Dreamweaver 的用户使用“站点定义向导”；有经验的 Dreamweaver 用户可能更喜欢使用“高级”设置。
    • 单击“高级”选项卡以使用“高级”设置，它使您可以根据需要分别设置本地、远端和测试文件夹。

      注意

      若要开始，可以完整地设置一个 Dreamweaver 站点，或者就以第一步开始，设置本地文件夹。
  4. 完成 Dreamweaver 站点设置过程：
    • 在“站点定义向导”中，回答每一屏上出现的问题，然后单击“下一步”继续进行设置，或者单击“上一步”返回到前一屏。
    • 对于“高级”设置，根据需要完成“本地信息”类别、“远端信息”类别和“测试服务器”类别（请参见使用“高级”设置来设置 Dreamweaver 站点）。

      提示

      设置好 Dreamweaver 站点后，最好将该站点导出，以便拥有一个本地备份副本。有关更多信息，请参见导入和导出站点。

如果您要为 Web 应用程序设置 Dreamweaver 站点，请参见设置 Web 应用程序。


使用“高级”设置来设置 Dreamweaver 站点

使用“站点定义”对话框中的“高级”设置来设置 Dreamweaver 站点。“高级”设置使您可以根据需要分别设置本地、远端和测试（用于处理动态页）文件夹。建议熟悉 Dreamweaver 的用户使用这种方法。

注意

若要快速开始，可以从设置 Dreamweaver 站点的第一步开始，设置本地文件夹。然后，您可以以后再添加远端和测试信息。开始使用 Dreamweaver 前至少应设置一个本地文件夹。

如果您不熟悉 Dreamweaver，可以使用“站点定义向导”（不要使用“高级”设置），该向导可以指导您逐步完成设置过程。（请参见设置新的 Dreamweaver 站点。）

如果要为 Web 应用程序设置 Dreamweaver 站点，请跳过本部分并参见设置 Web 应用程序。

提示

设置好 Dreamweaver 站点后，最好将该站点导出，以便拥有一个本地备份副本。有关更多信息，请参见导入和导出站点。

本节包含以下主题：

  • 设置本地文件夹
  • 设置远端文件夹
  • 解决远端文件夹设置问题

相关主题

  • 关于 Dreamweaver 站点
  • 指定可在哪里处理动态页


设置本地文件夹

本地文件夹是 Dreamweaver 站点的工作目录。此文件夹可以位于本地计算机上，也可以位于网络服务器上。

若要设置本地文件夹，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

    注意

    如果您没有定义任何 Dreamweaver 站点，则会出现“站点定义”对话框，您可以跳过下一步。
  2. 单击“新建”。

    出现“站点定义”对话框。

  3. 如果未显示“高级”设置，请单击“高级”按钮。

    “站点定义”对话框的“高级”选项卡显示“本地信息”类别选项。

  4. 输入“本地信息”选项。

    有关更多信息，请参见设置“本地信息”类别选项。

  5. （可选）如果已经做好了设置远端服务器的准备，请跳过剩下的步骤；选择左侧的“远端信息”类别，然后完成该对话框。

    有关更多信息，请参见设置“远端信息”类别选项。

  6. 单击“确定”。

    Dreamweaver 创建初始站点缓存，新的 Dreamweaver 站点显示在“文件”面板中。

设置本地文件夹之后，还可以添加远端和测试文件夹（请参见设置远端文件夹和指定可在哪里处理动态页）。

相关主题

  • 关于 Dreamweaver 站点
  • 管理您的文件
  • 设置远端文件夹


设置远端文件夹

为 Dreamweaver 站点设置本地文件夹（请参见设置本地文件夹）后，可以设置远端文件夹。根据开发环境的不同，远端文件夹是您存储用于进行测试、协作、生产、部署等的文件的位置。

注意

如果指定的本地文件夹与运行 Web 服务器的系统上为站点文件创建的文件夹相同，则不需要指定远端文件夹。这意味着该 Web 服务器正在您的本地计算机上运行。

确定如何访问远端文件夹并记下连接信息。这一节描述如何设置远端文件夹并与它连接。

若要设置远程文件夹，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 选择现有的 Dreamweaver 站点。

    如果没有定义任何 Dreamweaver 站点，请在继续前创建一个本地文件夹（请参见设置本地文件夹）。

  3. 单击“编辑”。

    出现“站点定义”对话框。

  4. 如果未显示“高级”设置，请单击“高级”按钮。
  5. 从左侧的“类别”列表中选择“远程信息”。
  6. 选择一个“访问”选项。

    有关更多信息，请参见设置“远端信息”类别选项。

  7. 单击“确定”。

    Dreamweaver 创建到远端文件夹的连接。如果是开发动态站点，可以添加一个用于处理动态页的“测试服务器”文件夹（请参见指定可在哪里处理动态页）。

若要使用 FTP 访问连接到远端文件夹，请执行以下操作：

  • 在“文件”面板中，单击工具栏中的“连接到远端主机”按钮。

若要使用 FTP 访问从远端文件夹断开，请执行以下操作：

  • 在“文件”面板中，单击工具栏上的“断开”按钮。

若要使用网络访问连接或断开远端文件夹，请执行以下操作：

  • 您无需连接到远端文件夹，因为您一直处在连接状态。单击“刷新”按钮查看远端文件。

相关主题

  • 关于 Dreamweaver 站点
  • 了解本地和远端文件夹的结构
  • 解决远端文件夹设置问题


解决远端文件夹设置问题

可以使用多种方法配置 Web 服务器。下面的列表提供了关于设置远端文件夹时可能遇到的一些常见问题（请参见设置远端文件夹）以及如何解决它们的信息：

  • Dreamweaver FTP 实现方案可能不适用于某些代理服务器、多级防火墙和其他形式的间接服务器访问。

    如果遇到 FTP 访问方面的问题，请询问本地系统管理员。

  • 对于 Dreamweaver FTP 实现，必须连接到远端系统的根文件夹。（在许多应用程序中，可以连接到任何远端目录，然后在远端文件系统中查找所需的目录。）

    确保将远端系统的根文件夹指定为主机目录。

    如果存在连接问题，并且使用了一个单斜杠 (/) 指定主机目录，则可能需要指定从所连接目录到远端根文件夹的相对路径。

    例如，如果远端根文件夹是一个更高级别的目录，则需要为主机目录指定 ../../。

  • 包含空格和特殊字符的文件名和文件夹名在传输到远端站点时经常引起问题。

    请使用下划线替换空格，并尽可能避免在文件名和文件夹名中使用特殊字符。具体说来，文件名或文件夹名中的冒号、斜杠、句点和撇号会引起问题。文件名或文件夹名中的特殊字符有时还可能妨碍 Dreamweaver 创建站点地图。

  • 如果遇到长文件名问题，请用较短的名称重命名。在 Macintosh 中，文件名长度不能超过 31 个字符。
  • 需要注意的是，许多服务器使用符号链接 (UNIX)、快捷键 (Windows) 或别名 (Macintosh) 将服务器磁盘某部分中的一个文件夹和其他地方的另一个文件夹连接起来。

    例如，服务器上主目录的 public_html 子目录实际上可能是到服务器另一部分的链接。在大多数情况下，这样的别名对您连接到适当的文件夹或目录的能力没有影响，但如果您可以连接到服务器的一部分而不能连接到另一部分，则可能存在别名差异。

  • 如果遇到如“无法上传文件”这样的错误信息，说明远端文件夹的空间可能不足。有关更多详细信息，请查看 FTP 记录。

    注意

    总的说来，当遇到 FTP 传输方面的问题时，请检查 FTP 记录，方法是选择“窗口”>“结果”(Windows)，或者选择“站点”>“FTP 记录”(Macintosh)，然后单击“FTP 记录”标签。


编辑 Dreamweaver 站点设置

使用“站点定义”对话框的“高级”设置编辑 Dreamweaver 站点。

若要编辑 Dreamweaver 站点设置，请执行以下操作之一：

  • 选择“站点”>“管理站点”，在“管理站点”对话框中选择一个站点，然后单击“编辑”。
  • 在“文件”面板中，从弹出式菜单中选择“管理站点”（当前站点、服务器或驱动器显示在该菜单中），从“管理站点”对话框中选择一个站点，然后单击“编辑”。

相关主题

  • 设置新的 Dreamweaver 站点


编辑现有 Web 站点 Dreamweaver

即使创建原始站点时没有使用 Dreamweaver，仍可以使用 Dreamweaver 编辑现有站点。您可以编辑本地系统上的现有站点或远端系统上的站点。

本节包含以下主题：

  • 编辑现有本地 Web 站点，使用 Dreamweaver
  • 编辑现有远端 Web 站点 Dreamweaver


编辑现有本地 Web 站点，使用 Dreamweaver

即使创建原始站点时没有使用 Dreamweaver，仍可以使用 Dreamweaver 编辑本地磁盘中的现有 Web 站点。

注意

本节设置 Dreamweaver 站点来编辑现有本地 Web 站点。您也可以编辑现有站点，而不用创建 Dreamweaver 站点。有关更多信息，请参见访问站点、服务器和本地驱动器。

若要编辑现有本地 Web 站点，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 单击“新建”。

    出现“站点定义”对话框。

  3. 如果未显示“高级”设置，请单击“高级”按钮。

    “站点定义”对话框的“高级”选项卡显示“本地信息”类别选项。

  4. 完成对话框。

    有关更多信息，请参见设置“本地信息”类别选项。

  5. 单击“确定”。

相关主题

  • 编辑现有远端 Web 站点 Dreamweaver


编辑现有远端 Web 站点 Dreamweaver

即使创建原始站点时没有使用 Dreamweaver，仍可以使用 Dreamweaver 将现有远端站点（或远端站点的任何分支）复制到本地磁盘中并在那里编辑它。

注意

本节设置 Dreamweaver 站点以编辑现有远端 Web 站点。您也可以编辑现有站点，而不用创建 Dreamweaver 站点。有关更多信息，请参见访问站点、服务器和本地驱动器。

若要编辑现有远端站点，请执行以下操作：

  1. 创建一个本地文件夹以包含现有站点，然后将它设置为站点的本地文件夹（请参见设置本地文件夹）。

    注意

    必须在本地复制现有远端站点相关分支的整个结构。有关更多信息，请参见了解本地和远端文件夹的结构。
  2. 使用现有站点的信息来设置远端文件夹（请参见设置远端文件夹）。

    确保为远端站点选择正确的根文件夹。

  3. 在“文件”面板（“窗口”>“文件”）中，单击工具栏上的“连接到远端主机”按钮（FTP 访问）或“刷新”按钮（网络访问）来查看远端站点。
  4. 根据要编辑的远端站点的内容量，执行以下操作之一：
    • 如果想对整个站点进行处理，请在“文件”面板中选择远端站点的根文件夹，然后单击工具栏上的“获取”将整个站点下载到本地磁盘。
    • 如果仅想处理站点的其中一个文件或文件夹，请在“文件”面板的“远端”视图中找到该文件或文件夹，然后单击工具栏上的“获取”将其下载到本地磁盘。

    Dreamweaver 会自动复制必要的远端站点结构，将下载的文件放在站点层次结构的正确部分中。当仅编辑站点的一部分时，通常应该选择包括相关文件。

  5. 使用 Dreamweaver 在站点上工作。

相关主题

  • 编辑现有本地 Web 站点，使用 Dreamweaver


参考资料

本节描述本章中介绍的下列对话框：

  • 设置站点定义向导的“编辑文件”选项
  • 设置站点定义向导的“编辑文件”选项
  • 设置站点定义向导的“编辑文件”选项
  • 设置站点定义向导的“测试文件”选项
  • 设置用于测试的本地/网络访问选项
  • 设置用于测试的 FTP 访问选项
  • 设置用于测试的 RDS 访问选项
  • 设置站点定义向导的“测试文件”选项
  • 设置站点定义向导的“共享文件”选项
  • 设置站点定义向导的“共享文件”选项
  • 设置远端访问的本地/网络选项
  • 设置远端访问的 FTP 选项
  • 设置远端访问的 WebDAV 选项
  • 设置站点定义向导的“共享文件”选项
  • 站点定义向导的“摘要”选项
  • 设置“本地信息”类别选项
  • 设置“远端信息”类别选项
  • 设置“本地/网络”访问的远端选项
  • 设置 FTP 访问的远端选项
  • 设置 RDS 访问
  • 设置 Microsoft Visual SourceSafe 访问
  • 设置 WebDAV 访问的远端选项
  • 设置“管理站点”对话框选项


设置站点定义向导的“编辑文件”选项

“站点定义”向导有三个区域来帮助您设置 Dreamweaver 站点：“编辑文件”、“测试文件”和“共享文件”。根据所选的设置不同，每个区域可能有多个屏幕。在对话框的顶部，以粗体表示的区域名称表示您在设置过程中所处的位置。可能无需在这三个区域中都设置文件夹；向导提出的问题会帮助您确定需要。

此对话框的作用是命名您的 Dreamweaver 站点并指定它的 URL。

若要命名 Dreamweaver 站点，请执行以下操作：

  • 输入 Dreamweaver 站点的名称。

若要指定站点的 URL，请执行以下操作：

  • 输入 Dreamweaver 站点的 URL（HTTP 地址）。

    Dreamweaver 使用此地址来确保站点根目录相对链接可在远端服务器上工作，该远端服务器可能以其他文件夹作为站点根目录。例如，如果您链接到硬盘上 C:\Sales\images\ 文件夹中的某个图像文件（Sales 是您的本地根文件夹），您完成的站点 URL 是 http://www.mysite.com/SalesApp/（SalesApp 是您的远端根文件夹），那么应该在“HTTP 地址”文本框中输入 URL 以确保远端服务器上的链接图像路径为 /SalesApp/images/。

相关主题

  • 关于 Dreamweaver 站点


设置站点定义向导的“编辑文件”选项

此对话框的作用是指出您是否正在生成 Web 应用程序。Web 应用程序是许多网页的集合，这些网页与用户进行交互、相互之间进行交互，还与 Web 服务器上的多种资源（包括数据库）进行交互。

如果生成 Web 应用程序，则需要选择 Web 服务器上运行的服务器技术。

若要选择服务器技术，请执行以下操作：

  1. 如果不打算使用服务器技术创建 Web 应用程序，请选择“否”；如果打算使用服务器技术创建 Web 应用程序，请选择“是”。
  2. 如果选择“是”，请选择一种服务器技术。

    可以使用 Dreamweaver 通过五种服务器技术生成 Web 应用程序：Macromedia ColdFusion、ASP.NET、ASP、JSP 或 PHP。每种技术都与 Dreamweaver 中的一种文档类型相对应。为您的 Web 应用程序选择一种技术取决于多个因素，其中包括您对各种脚本编制语言的熟悉程度以及所要使用的应用程序服务器。

相关主题

  • 选择应用程序服务器


设置站点定义向导的“编辑文件”选项

此对话框的作用是选择开发环境。

若要选择开发环境，请执行以下操作：

  1. 选择开发过程中用以处理文件的方法。
  2. 输入存储文件的位置，或者单击文件夹图标浏览选择文件夹。

    这是 Dreamweaver 站点的工作目录，即为 Dreamweaver 站点存储“创建中的”文件的位置。在 Dreamweaver“文件”面板中，该文件夹被称为本地站点。

  3. 如果选择了使用 FTP、SFTP、RDS 或 WebDAV 的方法，则可以选择每次保存时自动将文件上传到服务器。


设置站点定义向导的“测试文件”选项

此对话框的作用是为 Dreamweaver 选择一种访问测试服务器的方法。

Dreamweaver 在您工作的同时，与一个测试服务器一起工作以生成并显示动态内容。测试服务器可以是本地计算机、开发服务器、中间服务器或生产服务器。只要服务器能够处理您打算开发的动态页类型，选择哪个都无关紧要。

若要选择一种访问测试服务器的方法，请执行以下操作：

  • 从弹出菜单中选择一种访问方法：

    本地/网络，如果访问网络文件夹，或者如果在本地计算机上运行测试服务器。

    FTP 如果使用 FTP 连接到测试服务器。

    “RDS”（远端开发服务），如果使用 RDS 连接到 Web 服务器。

    注意

    若要使用 RDS，远端文件夹必须位于运行 ColdFusion 的计算机上。


设置用于测试的本地/网络访问选项

此对话框的作用是在本地计算机或网络上选择一个文件夹来存储测试的文件。

若要选择一个文件夹来存储测试文件，请执行以下操作：

  • 输入存储测试文件的本地或网络文件夹的路径，或者单击文件夹图标浏览到该文件夹。


设置用于测试的 FTP 访问选项

此对话框的作用是提供有关对存储测试文件的测试服务器的 FTP 访问的信息。

若要为测试服务器设置 FTP 选项，请执行以下操作：

  1. 输入测试文件上传到的 FTP 主机的主机名。

    FTP 主机是计算机系统的完整 Internet 名称，如 ftp.mindspring.com。请输入完整的主机名，不要带任何其他的文本。特别是不要在主机名前面添加协议名。

    注意

    如果不知道 FTP 主机，请与网站托管服务商联系。
  2. 输入存储测试文件的文件夹路径，或者单击文件夹图标浏览到该文件夹。
  3. 输入用于连接到 FTP 服务器的登录名和密码。
  4. 选择“使用安全 FTP (SFTP)”复选框以使用 SFTP 进行安全身份验证。

    SFTP 使用加密密钥和共用密钥保护到测试服务器的连接的安全。

    注意

    测试服务器必须在运行 SFTP 服务器。
  5. 单击“测试连接”测试登录名和密码。

相关主题

  • 了解本地和远端文件夹的结构


设置用于测试的 RDS 访问选项

此对话框的作用是提供有关对存储文件的测试服务器的 RDS 访问的信息。

若要为测试服务器设置 RDS 选项，请执行以下操作：

  • 单击“设置”按钮输入访问信息。


设置站点定义向导的“测试文件”选项

此对话框的作用是指定一个 URL 前缀，以便在您工作时 Dreamweaver 可以使用测试服务器显示数据并连接到数据库。URL 前缀由域名和 Web 站点的主目录的任何一个子目录或虚拟目录组成。

若要指定 URL 前缀，请执行以下操作：

  1. 输入用户在浏览器中键入的 URL 以打开 Web 应用程序，但不要包括任何文件名。

    假设应用程序的 URL 是 www.macromedia.com/mycoolapp/start.jsp。您需要输入以下 URL 前缀：www.macromedia.com/mycoolapp/。

    如果 Dreamweaver 与 Web 服务器运行在同一计算机上，则可以使用 localhost 这个词来代替域名。例如，假设应用程序的 URL 是 buttercup_pc/mycoolapp/start.jsp，那么可以输入以下 URL 前缀：http://localhost/mycoolapp/。

  2. 单击“测试 URL”确保 URL 正常工作。

相关主题

  • 连接到数据库


设置站点定义向导的“共享文件”选项

此对话框的作用是确定是否设置远端服务器文件夹。

根据环境的不同，该文件夹是您存储用于测试、协作、生产、部署或许多其他方案的文件的位置。一般说来，远端文件夹位于运行 Web 服务器的计算机上。

在 Dreamweaver“文件”面板中，该文件夹被称为远端站点。远端文件夹使您能够在本地磁盘和 Web 服务器之间传输文件，这使您可以很容易地共享和管理 Dreamweaver 站点中的文件。

若要选择是否要设置远端文件夹，请执行以下操作：

  • 请选择“是”设置一个远端文件夹，或者选择“否”跳过远端文件夹设置。


设置站点定义向导的“共享文件”选项

此对话框的作用是为 Dreamweaver 选择一种访问远端文件夹的方法。

若要为远端文件夹选择访问方法，请执行以下操作：

  • 从弹出菜单中选择一种访问方法：

    本地/网络，如果访问网络文件夹，或者如果在本地计算机上运行测试服务器。请参见设置远端访问的本地/网络选项。

    FTP 如果使用 FTP 连接到测试服务器。请参见设置远端访问的 FTP 选项。

    “RDS”（远端开发服务），如果使用 RDS 连接到 Web 服务器。

    对于这种访问方法，远端文件夹必须位于运行 ColdFusion 的计算机上。

    Microsoft Visual SourceSafe 如果使用 Microsoft Visual SourceSafe 连接到 Web 服务器。

    只有 Windows 支持 Microsoft Visual SourceSafe。若要在 Windows 中使用 Microsoft Visual SourceSafe，必须安装了 Microsoft Visual SourceSafe Client 第 6 版。

    WebDAV（基于 Web 的分布式创作和版本控制），如果使用 WebDAV 协议连接到 Web 服务器。请参见设置远端访问的 FTP 选项。

    对于这种访问方法，必须有支持此协议的服务器，如 Microsoft Internet Information Server (IIS) 5.0 或经正确配置安装的 Apache Web 服务器。


设置远端访问的本地/网络选项

此对话框的作用是在本地计算机或网络上选择一个文件夹来存储文件。此文件夹通常是可以通过本地网络连接到的文件夹或远端 Web 服务器。

若要选择服务器文件夹，请执行以下操作：

  • 输入存储文件的本地或网络文件夹的路径，或者单击文件夹图标浏览到该文件夹。


设置远端访问的 FTP 选项

此对话框的作用是完成有关存储文件的远端服务器的 FTP 访问信息。

若要完成远端服务器 FTP 信息，请执行以下操作：

  1. 输入文件上传到的 FTP 主机的主机名。

    FTP 主机是计算机系统的完整 Internet 名称，如 ftp.mindspring.com。请输入完整的主机名，不要带任何其他的文本。特别是不要在主机名前面添加协议名。

    注意

    如果不知道 FTP 主机，请与网站托管服务商联系。
  2. 输入存储文件的文件夹路径，或者单击文件夹图标浏览到该文件夹。
  3. 输入用于连接到 FTP 服务器的登录名和密码。
  4. 选择“使用安全 FTP (SFTP)”复选框以使用 SFTP 进行安全身份验证。

    SFTP 使用加密密钥和共用密钥保护到测试服务器的连接的安全。

    注意

    测试服务器必须在运行 SFTP 服务器。
  5. 单击“测试连接”测试登录名和密码。

相关主题

  • 了解本地和远端文件夹的结构


设置远端访问的 WebDAV 选项

这些选项的作用是指定到 WebDAV 服务器的连接设置。

若要指定 WebDAV 设置，请执行以下操作：

  1. 输入 WebDAV 服务器上您要连接到的目录的完整 URL。

    此 URL 包括协议、端口和目录（如果不是根目录）。例如，http://webdav.mydomain.net/mysite。

  2. 在相应的文本框中输入登录名和密码。

    此信息用于服务器身份验证，与 Dreamweaver 无关。如果不能确定用户名和密码，请询问系统管理员或网站管理员。

  3. 如果希望在每次开始新会话时 Dreamweaver 都记住密码，请单击“保存”复选框。
  4. 单击“测试连接”测试连接设置。
  5. 如果希望在添加和删除文件时自动更新“文件”面板的“远端”窗格，请选择“自动刷新远端文件列表”选项。

    若要在将文件复制到远端站点时提高速度，请不要选择此选项。

    注意

    若要在任何时候手动刷新“文件”面板，请单击工具栏中的“刷新”按钮。

相关主题

  • 设置站点定义向导的“共享文件”选项


设置站点定义向导的“共享文件”选项

如果您是在协作环境中工作（或者在多台计算机上独自工作），则此对话框的作用是设置文件“存回/取出”系统。

取出文件使该文件在服务器上不可用，这样一来其他小组成员就不能使用 Dreamweaver 编辑该文件。存回文件使其他人可以使用该文件，取出和编辑它。

若要设置存回/取出系统，请执行以下操作：

  1. 如果您是在小组环境中工作（或在几台不同的计算机上独自工作），请选择“是”启用文件存回/取出，或者选择“否”禁用文件存回/取出。

    该选项有助于让其他人知道您已取出文件进行编辑，或者提醒您自己可能将文件的最新版本留在了另一台计算机上。

  2. 如果想在从“文件”面板中打开文件时自动取出它们，请选择“是”；如果不想在打开文件时自动取出它们，请选择“否”。

    注意

    即使选择了该选项，使用“文件”>“打开”这种方法打开文件也不会取出该文件。
  3. 输入您的名称。

    您的名称出现在“文件”面板中任何您取出的文件旁；这使小组成员能够在共享文件时相互交流。

    如果您在几台不同的计算机上独自工作，请在每台计算机上使用不同的取出名称（如 AmyR-HomeMac 和 AmyR-OfficePC），这样一来，当您忘记存回文件时，就可以知道文件最新版本的位置。

  4. 输入您的电子邮件地址。

    如果您输入了电子邮件地址，然后当您取出某个文件时，您的名称将以链接的形式（蓝色并带下划线）显示在“文件”面板中该文件旁边。如果小组成员单击该链接，他们的默认电子邮件程序会打开一个新邮件，其中已填上您的电子邮件地址和对应于该文件和站点名的主题。

相关主题

  • 存回和取出文件


站点定义向导的“摘要”选项

该页显示您为站点选择的设置。

若要结束站点设置，请执行以下操作之一：

  • 单击“后退”按钮返回到上一页更改设置。
  • 如果对设置感到满意并想让 Dreamweaver 创建站点，请单击“完成”按钮。

    当您单击“完成”时，Dreamweaver 将创建站点并在“文件”面板中显示它。

  • 如果不想让 Dreamweaver 创建站点，请单击“取消”按钮。


设置“本地信息”类别选项

此对话框的作用是为 Dreamweaver 站点（也称为本地站点）设置本地文件夹。

若要为 Dreamweaver 站点设置本地文件夹，请执行以下操作：

  1. 在“站点名称”文本框中，输入 Dreamweaver 站点的名称。

    站点名称显示在“文件”面板和“管理站点”对话框中。使用您喜欢的任何名称；该名称仅供您参考，并不出现在浏览器中。

  2. 在“本地根文件夹”文本框中，输入本地磁盘中存储站点文件、模板和库项目的文件夹的名称，或者单击文件夹图标浏览到该文件夹。

    当 Dreamweaver 解析根目录相对链接时，它是相对于该文件夹来解析的（请参见站点根目录相对路径）。如果本地根文件夹尚不存在，请从文件浏览对话框中创建。

  3. 使用“自动刷新本地文件列表”选项来指定每次将文件复制到本地站点时，Dreamweaver 是否自动刷新本地文件列表。

    取消选择此选项可在复制此类文件时提高 Dreamweaver 的速度，但也意味着“文件”面板的“本地”视图不会自动刷新。您可以单击“文件”面板工具栏中的“刷新”按钮来手动刷新面板。

  4. （可选）在“默认图像文件夹”文本框中，输入此站点的默认图像文件夹的路径，或者单击文件夹图标浏览到该文件夹。

    此文件夹是 Dreamweaver 上传您添加到站点上的图像的位置。例如，将图像从桌面拖动到活动文档中时，Dreamweaver 将该图像添加到当前站点的默认图像文件夹中。

  5. （可选）如果要更改所创建的到站点其他页面的链接的相对路径，请选择“相对链接于”选项。

    默认情况下，Dreamweaver 使用文档相对路径创建链接。请选择“站点根目录”选项以更改路径设置。有关“相对路径”的更多信息，请参见了解文档位置和路径。

    如果您选择“站点根目录”选项，一定要在下一步中指定 HTTP 地址。

    单击“确定”后，更改此设置将不会转换现有链接的路径。此设置仅适用于用 Dreamweaver 以可视方式创建的新链接。

    注意

    使用本地浏览器预览文档时，除非指定了测试服务器，或在“编辑”>“首选参数”>“在浏览器中预览”中选择“使用临时文件预览”选项，否则文档中用站点根目录相对路径链接的内容将不会被显示。这是因为浏览器不能识别站点根目录，而服务器能够识别。（请参见在浏览器中预览和测试页面。）
  6. （可选）在“HTTP 地址”文本框中，输入已完成的 Web 站点将使用的 URL。

    这使 Dreamweaver 能够验证站点中使用绝对 URL 或站点根目录相对路径的链接（请参见查找断开的、外部的和孤立的链接）。Dreamweaver 还使用此地址来确保站点根目录相对链接可在远端服务器上工作，其站点根目录可能不同。例如，如果您链接到位于硬盘上 C:\Sales\images\ 文件夹中的某个图像文件（Sales 是您的本地根文件夹），您完成的站点 URL 是 http://www.mysite.com/SalesApp/（SalesApp 是您的远端根文件夹），那么应该在“HTTP 地址”文本框中输入 URL 以确保远端服务器上的链接文件路径为 /SalesApp/images/。

  7. 在 Dreamweaver 检查链接时如果要确保链接的大小写与文件名的大小写匹配，请选择“使用区分大小写的链接检查”。

    此选项用于文件名区分大小写的 UNIX 系统。

  8. 对于“启用缓存”选项，指定是否创建本地缓存以提高链接和站点管理任务的速度。

    如果不选择此选项，Dreamweaver 在创建站点前将再次询问您是否希望创建缓存。最好选择此选项，因为只有在创建缓存后“资源”面板（在“文件”面板组中）才有效。有关更多信息，请参见模板表达式。

相关主题

  • 关于 Dreamweaver 站点
  • 设置本地文件夹
  • 设置新链接的相对路径


设置“远端信息”类别选项

此对话框的作用是为 Dreamweaver 向远端文件夹（也称为远端站点）所在的 Web 服务器上传文件，或从其中下载文件选择访问方法。

若要选择访问方法，请执行以下操作：

  1. 从弹出菜单中选择一种访问方法。对话框随您的选择而改变。选择以下项之一：

    “无”如果不打算将站点上传到服务器。

    “本地/网络”如果访问网络文件夹，或者如果在本地计算机上运行 Web 服务器。

    “FTP” 如果使用 FTP 连接到 Web 服务器。

    “RDS”（远端开发服务），如果使用 RDS 连接到 Web 服务器。

    对于这种访问方法，远端文件夹必须位于运行 ColdFusion 的计算机上。

    Microsoft Visual SourceSafe 如果使用 Microsoft Visual SourceSafe 连接到 Web 服务器。

    只有 Windows 支持 Microsoft Visual SourceSafe。若要在 Windows 中使用 Microsoft Visual SourceSafe，必须安装了 Microsoft Visual SourceSafe Client 第 6 版。

    WebDAV（基于 Web 的分布式创作和版本控制），如果使用 WebDAV 协议连接到 Web 服务器。有关说明，请参见设置 WebDAV 访问的远端选项。

    对于这种访问方法，必须有支持此协议的服务器，如 Microsoft Internet Information Server (IIS) 5.0 或经正确配置安装的 Apache Web 服务器。

  2. 根据您选用的访问方法，完成此对话框。

    有关说明，请参见下列主题：

    • 如果选择了“无”，请跳过此步骤。
    • 如果选择了“本地/网络”，请参见设置“本地/网络”访问的远端选项。
    • 如果选择了 FTP，请参见设置 FTP 访问的远端选项。
    • 如果选择了 WebDAV，请参见设置 WebDAV 访问的远端选项
    • 如果选择了 RDS，请参见设置 RDS 访问
    • 如果选择了 Microsoft Visual SourceSafe，请参见设置 Microsoft Visual SourceSafe 访问。
  3. 单击“确定”来关闭“站点定义”对话框中的“远端信息”类别。


相关主题

  • 设置远端文件夹
  • 存回和取出文件


设置“本地/网络”访问的远端选项

此对话框的作用是提供有关本地网络访问的信息。

若要提供有关本地网络访问的信息，请执行以下操作：

  1. 单击“远端文件夹”文本框旁边的文件夹图标，浏览到并选择存储站点文件的文件夹。
  2. 如果希望在添加和删除文件时自动更新“文件”面板的“远端”窗格，请选择“自动刷新远端文件列表”复选框。

    若要在将文件复制到远端站点时提高速度，请不要选择此选项。

    注意

    若要在任何时候手动刷新“文件”面板，请单击工具栏中的“刷新”按钮。
  3. 如果您希望 Dreamweaver 自动同步本地和远端文件，请选择“维护同步信息”复选框。（默认情况下选择该选项。）

    有关更多信息，请参见同步本地和远端站点上的文件。

  4. 如果希望在保存文件时 Dreamweaver 将文件上传到远程站点，请选择“保存时自动将文件上传到服务器”复选框。
  5. 如果希望激活“存回/取出”系统，请选择“启用存回和取出”。

    有关更多信息，请参见存回和取出文件。

  6. 单击“确定”。

相关主题

  • 设置“远端信息”类别选项
  • 了解本地和远端文件夹的结构


设置 FTP 访问的远端选项

此对话框的作用是提供有关 FTP 访问的信息。

若要提供有关 FTP 访问的信息，请执行以下操作：

  1. 输入 Web 站点的文件上传到的 FTP 主机的主机名。

    FTP 主机是计算机系统的完整 Internet 名称，如 ftp.mindspring.com。请输入完整的主机名，不要带任何其他的文本。特别是不要在主机名前面添加协议名。

    注意

    如果不知道 FTP 主机，请与网站托管服务商联系。
  2. 输入您在远端站点上存储公共可见的文档的主机目录。

    如果不能确定输入哪些内容作为主机目录，请与服务器管理员联系。或者尝试将该文本框保留为空白。在有些服务器上，根目录就是您首次使用 FTP 连接到的目录。若要确定这一点，请连接到服务器。如果出现在“文件”面板“远端文件”视图中的文件夹具有像 public_html、www 或您的登录名这样的名称，它可能就是您应该在“主机目录”文本框中使用的目录。

  3. 输入用于连接到 FTP 服务器的登录名和密码。
  4. 单击“测试”测试登录名和密码。
  5. 默认情况下，Dreamweaver 保存密码。如果希望每次连接到远端服务器时 Dreamweaver 都提示输入密码，请取消选择“保存”复选框。
  6. 如果防火墙配置要求使用被动式 FTP，请选中“使用被动式 FTP”复选框。

    “被动式 FTP”使您的本地软件能够建立 FTP 连接，而不是请求远端服务器来设置它。如果不能确定是否使用被动式 FTP，请询问系统管理员。

    有关更多信息，请参阅 Macromedia 网站上的 TechNote 15220，网址为 www.macromedia.com/go/15220。

  7. 如果从防火墙后面连接到远程服务器，请选中“使用防火墙”复选框。
  8. 单击“防火墙设置”编辑防火墙主机或端口。

    有关更多信息，请参见设置“文件”面板的首选参数。

  9. 如果您希望 Dreamweaver 自动同步本地和远端文件，请选择“维护同步信息”复选框。（默认情况下选择该选项。）

    有关更多信息，请参见同步本地和远端站点上的文件。

  10. 如果希望在保存文件时 Dreamweaver 将文件上传到远程站点，请选择“保存时自动将文件上传到服务器”复选框。
  11. 如果希望激活“存回/取出”系统，请选择“启用存回和取出”。

    有关更多信息，请参见存回和取出文件。

  12. 单击“确定”。

相关主题

  • 设置“远端信息”类别选项
  • 了解本地和远端文件夹的结构


设置 RDS 访问

此对话框的作用是使用 RDS 与远端服务器建立连接。

若要使用 RDS 建立与远端服务器的连接，请执行以下操作：

  1. 单击“设置”按钮并在“配置 RDS 服务器”对话框中提供以下信息：
    • 输入安装 Web 服务器的主机的名称。

      主机名可能是 IP 地址或 URL。如果不能确定，请询问管理员。

    • 输入要连接的端口号。
    • 输入根远端文件夹作为主机目录。

      例如，c:\inetpub\wwwroot\myHostDir\。

    • 输入您的 RDS 用户名和密码。

      注意

      如果在“ColdFusion 管理员”安全设置中设置了用户名和密码，则这些选项可能不会出现。
    • 如果希望 Dreamweaver 记住这些设置，请选择“保存”复选框。
  2. 单击“确定”以关闭“配置 RDS 服务器”对话框。
  3. 如果希望在保存文件时 Dreamweaver 将文件上传到远程站点，请选择“保存时自动将文件上传到服务器”复选框。
  4. 如果希望激活“存回/取出”系统，请选择“启用存回和取出”。

    有关更多信息，请参见存回和取出文件。

相关主题

  • 设置“配置服务器”对话框选项
  • 设置“远端信息”类别选项


设置 Microsoft Visual SourceSafe 访问

此对话框的作用是建立与 Microsoft Visual SourceSafe 数据库的连接。

注意

只有 Windows 支持 Microsoft Visual SourceSafe 数据库。

若要建立与 Microsoft Visual SourceSafe 数据库的连接，请执行以下操作：

  1. 单击“设置”按钮并在“打开 Microsoft Visual SourceSafe 数据库”对话框中提供以下信息：
    • 在“数据库路径”文本框中，单击“浏览”浏览所需的 Visual SourceSafe 数据库，或者输入完整的文件路径。

      所选文件变成用于初始化 Visual SourceSafe 的 srcsafe.ini 文件。

    • 在“项目”文本框中，输入要在 Visual SourceSafe 数据库中用作远端站点根目录的项目。
    • 在“用户名”和“密码”文本框中，输入所选数据库的登录用户名和密码。

      如果不知道用户名和密码，请询问系统管理员。

    • 如果希望 Dreamweaver 记住这些设置，请选择“保存”复选框。
  2. 单击“确定”返回到“站点定义”对话框。
  3. 如果您希望 Dreamweaver 自动同步本地和远端文件，请选择“维护同步信息”复选框。（默认情况下选择该选项。）

    有关更多信息，请参见同步本地和远端站点上的文件。

  4. 如果希望在保存文件时 Dreamweaver 将文件上传到远程站点，请选择“保存时自动将文件上传到服务器”复选框。

相关主题

  • 设置“远端信息”类别选项


设置 WebDAV 访问的远端选项

这些选项的作用是使用 WebDAV 协议与远端服务器建立连接。

若要建立 WebDAV 连接，请执行以下操作：

  1. 在“URL”文本框中，输入 WebDAV 服务器上您要连接到的目录的完整 URL。

    此 URL 包括协议、端口和目录（如果不是根目录）。例如，http://webdav.mydomain.net/mysite。

  2. 在相应的文本框中输入用户名和密码。

    此信息用于服务器身份验证，与 Dreamweaver 无关。如果不能确定用户名和密码，请询问系统管理员或网站管理员。

  3. 单击“测试”测试连接设置。
  4. 如果希望在每次开始新会话时 Dreamweaver 都记住密码，请单击“保存”复选框。
  5. 如果希望在添加和删除文件时自动更新“文件”面板的“远端”窗格，请选择“自动刷新远端文件列表”选项。

    若要在将文件复制到远端站点时提高速度，请不要选择此选项。

    注意

    若要在任何时候手动刷新“文件”面板，请单击工具栏中的“刷新”按钮。
  6. 如果您希望 Dreamweaver 自动同步本地和远端文件，请选择“维护同步信息”复选框。（默认情况下选择该选项。）

    有关更多信息，请参见同步本地和远端站点上的文件。

  7. 如果希望在保存文件时 Dreamweaver 将文件上传到远程站点，请选择“保存时自动将文件上传到服务器”复选框。
  8. 如果希望激活“存回/取出”系统，请选择“启用存回和取出”。

    有关更多信息，请参见存回和取出文件。

相关主题

  • 设置“远端信息”类别选项
  • 使用 WebDAV 存回和取出文件


设置“管理站点”对话框选项

该对话框的作用是创建新站点、编辑站点、复制站点、删除站点以及导入或导出站点。

若要创建、编辑或删除站点，请执行以下操作：

  1. 从窗口中选择一个站点。
  2. 单击一个按钮选择以下选项之一：

    新建使您可以创建新站点。

    有关更多信息，请参见设置新的 Dreamweaver 站点。

    编辑使您可以编辑现有站点。

    有关更多信息，请参见编辑 Dreamweaver 站点设置。

    重制创建所选站点的副本。

    副本将出现在站点列表窗口中。

    删除删除所选站点。

    Dreamweaver 会提醒您该操作无法撤消。

    导出使您可以将导出的站点保存为 XML 文件。

    有关更多信息，请参见导入和导出站点。

    导入使您可以为站点选择要导入的 XML 文件。

    有关更多信息，请参见导入和导出站点。

  3. 单击“完成”关闭对话框。


创建和打开文档

Macromedia Dreamweaver 8 为处理各种 Web 设计和开发文档提供了灵活的环境。除了 HTML 文档以外，您还可以创建和打开各种基于文本的文档，如 CFML、ASP、JavaScript 和 CSS。Dreamweaver 还支持源代码文件，如 Visual Basic、.NET、C# 和 Java。

Dreamweaver 为创建新文档提供了若干选项。您可以创建以下任意文档：

  • 新的空白文档或模板
  • 基于 Dreamweaver 附带的某预定义页面布局的文档
  • 基于某现有模板的文档

另外还支持其它一些文档。例如，如果经常使用某种文档类型，可以将其设置为创建的新页面的默认文档类型。

在 Dreamweaver 中，可以在“设计”视图或“代码”视图中轻松定义文档属性，如 meta 标签、文档标题、背景颜色和其他几种页面属性。

本章包含下列章节：

创建新文档

保存新文档

设置默认的新文档类型

设置新建 HTML 文档的默认文件扩展名

打开现有文档

清理 Microsoft Word 的 HTML 文件


创建新文档

Dreamweaver为您提供了几种选择新的工作文档的选项。可以用下列方法创建新文档：

  • 从空白文档开始（请参见创建新的空白文档）。
  • 创建基于 Dreamweaver 设计文件的空白文档或模板（请参见创建基于 Dreamweaver 设计文件的文档）。
  • 使用模板定义文档外观并设置文档哪些部分可以编辑（请参见创建基于现存模板的文档）。

    提示

    如果经常使用某种特定的文档类型，您可以设置默认文档并根据已定义的默认文档自动打开一个新文档。有关信息，请参见设置默认的新文档类型。


创建新的空白文档

可以选择要创建的空白文档的类型。

若要创建新的空白文档，请执行以下操作：

  1. 选择“文件”>“新建”。

    即出现“新建文档”对话框。“常规”选项卡已被选定。

  2. 从“类别”列表中选择“基本页”、“动态页”、“模板页”、“其他”或“框架集”；然后从右侧的列表中选择要创建的文档的类型。

    例如，选择“基本页”创建 HTML 文档，或选择“动态页”创建 ColdFusion 或 ASP 文档，诸如此类。

    有关此对话框中的选项的更多信息，请参见设置“新建文档”对话框的“常规”选项卡中的选项。

  3. 单击“创建”按钮。

    新文档在“文档”窗口中打开。

  4. 保存该文档（请参见保存新文档）。

相关主题

  • 创建基于 Dreamweaver 设计文件的文档
  • 创建基于现存模板的文档


创建基于 Dreamweaver 设计文件的文档

Dreamweaver 附带了几种以专业水准开发的页面布局和设计元素文件。可以将这些设计文件 作为设计站点页面的起点。当您创建基于设计文件的文档时，Dreamweaver 会创建文件的副本。

注意

如果创建基于预定义框架集的文档，则仅复制框架集结构，而不复制框架内容。另外，需要分别保存每个框架文件。有关保存框架的信息，请参见保存框架和框架集文件。

若要通过 Dreamweaver 设计文件创建新文档，请执行以下操作：

  1. 选择“文件”>“新建”。

    即出现“新建文档”对话框。“常规”选项卡已被选定。

  2. 在“类别”列表中，选择“CSS 样式表”、“基于表格的布局”、“页面设计 (CSS)”、“页面设计”或“页面设计（有辅助功能的）”，然后从右侧的列表中选择一个设计文件。

    您可以预览设计文件并阅读关于文档设计元素的简要说明。

    有关此对话框中的选项的更多信息，请参见设置“新建文档”对话框的“常规”选项卡中的选项。

  3. 单击“创建”按钮。

    新文档在“文档”窗口中打开。如果选择了一个 CSS 样式表，则“文档”窗口会显示 CSS 文档，而该 CSS 样式表会在“代码”视图中打开。

  4. 保存该文档（请参见保存新文档）。

    如果该文件包含指向资源文件的链接，将会出现“复制相关文件”对话框，使您可以保存相关文件的副本。

  5. 如果出现“复制相关文件”对话框，请设置选项，然后单击“复制”，将资源复制到所选的文件夹中。

    可以为相关文件选择您自己的位置或使用 Dreamweaver 生成的默认文件夹位置（基于设计文件的源名称）。

相关主题

  • 创建新的空白文档
  • 创建基于现存模板的文档


创建基于现存模板的文档

您可以通过现有模板选择、预览和创建新文档。您可以使用“新建文档”对话框从 Dreamweaver 定义的任何站点中选择模板，您也可以使用“资源”面板从现有模板创建新的文档。

有关创建模板的信息，请参见创建 Dreamweaver 模板。

提示

如果您的站点中没有任何模板，可以将文档在“新建文档”对话框的一种设计文件类别中另存为模板，然后创建基于该模板的页面。有关将设计文件另存为模板的信息，请参见创建基于 Dreamweaver 设计文件的文档。

若要创建基于模板的新文档，请执行以下操作：

  1. 选择“文件”>“新建”。

    “新建文档”对话框随即打开。

  2. 单击“模板”选项卡。
  3. 在“模板用于”列表中，选择包含要使用的模板的 Dreamweaver 站点，然后从右侧的列表中选择一个模板。

    有关此对话框中的选项的更多信息，请参见设置“新建文档”对话框的“常规”选项卡中的选项。

  4. 单击“创建”。

    新文档在“文档”窗口中打开。

  5. 保存该文档（请参见保存新文档）。

若要在“资源”面板中从模板创建新文档，请执行以下操作：

  1. 如果“资源”面板（“窗口”>“资源”）尚未打开，请将其打开。
  2. 在“资源”面板中，单击左侧的“模板”图标以查看当前站点中的模板列表。 这是所描述的功能的图片。

    提示

    如果您刚刚创建了想要应用的模板，可能需要单击“刷新”按钮才能看到。
  3. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 要应用的模板，然后选择“从模板新建”。

    文档在文档窗口中打开。

相关主题

  • 创建新的空白文档
  • 创建基于 Dreamweaver 设计文件的文档


保存新文档

创建新文档后，需要保存它。

若要保存新文档，请执行以下操作：

  1. 选择“文件”>“保存”。
  2. 在出现的对话框中，定位到要用来保存文件的文件夹。

    提示

    最好将您的文件保存在 Dreamweaver 站点中。有关更多信息，请参见设置新的 Dreamweaver 站点。
  3. 在“文件名称”文本框中，键入文件名。

    请不要在文件名和文件夹名中使用空格和特殊字符，文件名也不要以数字开头。具体说来就是不要在打算放到远程服务器上的文件名中使用特殊字符（如 é、ç、或 ¥）或标点符号（如冒号、斜杠或句号）；很多服务器在上传时会更改这些字符，这会导致与这些文件的链接中断。

  4. 单击“保存”。


设置默认的新文档类型

可以定义被 Dreamweaver 用作站点默认文档的文档类型。

例如，如果站点的大多数页面都是特定的文件类型（如 Cold Fusion、HTML 或 ASP 文档），可以设置自动创建指定文件类型的新文档的文档首选参数。

若要设置默认的新建文档类型和首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或Dreamweaver>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

    提示

    也可以在创建新文档时（请参见创建新的空白文档），单击“新建文档”对话框中的“首选参数”按钮来设置新文档的首选参数。
  2. 在左侧的类别列表中单击“新建文档”。
  3. 根据需要设置或更改首选参数。

    有关此对话框中的选项的信息，请参见设置“新建文档”的“首选参数”对话框中的选项。

  4. 单击“确定”。

    Dreamweaver 将保存您的首选参数。


设置新建 HTML 文档的默认文件扩展名

您可以定义在 Dreamweaver 中创建的 HTML 文档的默认文件扩展名。例如，可以令 Dreamweaver 将 .htm 或 .html 扩展名用于所有的新建 HTML 文档。

若要设置新建 HTML 文档的默认文件扩展名，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或Dreamweaver>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

    提示

    也可以在创建新文档时（请参见创建新的空白文档），单击“新建文档”对话框中的“首选参数”按钮来设置新文档的首选参数。
  2. 在左侧的类别列表中单击“新建文档”。
  3. 请确保在“默认文档类型”中选择了“HTML”。
  4. 在“默认扩展名”文本框中，为在 Dreamweaver 中新建的 HTML 文档指定您想要的文件扩展名。

    对于 Windows 来说，可以指定下列扩展名：.html、.htm、.shtml、.shtm、.stm、.tpl、.lasso 和 .xhtml。

    对于 Macintosh 来说，可以指定下列扩展名：.html、.htm、.shtml、.shtm、.tpl、.lasso、.xhtml 和 .ssi。


打开现有文档

在 Dreamweaver 中可打开现有 Web 页或基于文本的文档，即使它们不是用 Dreamweaver 创建的。可打开该文档并用 Dreamweaver 在“设计”视图或“代码”视图中编辑该文档。

如果打开的文档是一个另存为 HTML 文档的 Microsoft Word 文件，则可以使用“清理 Word 的 HTML”命令来清除 Word 插入到 HTML 文件中的无关标记标签。有关更多信息，请参见清理 Microsoft Word 的 HTML 文件。

若要清理不是由 Microsoft Word 生成的 HTML 或 XHTML，请参见清理代码。

也可以打开非 HTML 文本文件，如 JavaScript 文件、XML 文件、CSS 样式表或用字处理程序或文本编辑器保存的文本文件。

若要打开现有的文件，请执行以下操作：

  1. 选择“文件”>“打开”。

    出现“打开”对话框。

    提示

    也可以使用“文件”面板来打开文件。有关更多信息，请参见在“文件”面板中处理文件。
  2. 定位到并选择要打开的文件。

    注意

    如果您尚未这样做，那么您最好在 Dreamweaver 站点中组织要打开和编辑的文件，而不是从其他位置打开这些文件。有关如何设置 Dreamweaver 站点的信息，请参见设置新的 Dreamweaver 站点。
  3. 单击“打开”。

    文档在文档窗口中打开。

    默认情况下，JavaScript、文本和 CSS 样式表在“代码”视图中打开。可以在 Dreamweaver 中工作时更新文档，然后保存文件中的更改。有关设置用于查看这些文件类型的外部文本编辑器的信息，请参见为媒体文件启动外部编辑器。


清理 Microsoft Word 的 HTML 文件

在 Dreamweaver 中，可以打开在 Microsoft Word 中保存为 HTML 文件的文档，然后使用“清理 Word 的 HTML”命令删除 Word 生成的无关 HTML 代码。“清理 Word 的 HTML”命令适用于由 Word 97 或更高版本另存为 HTML 文件的文档。

Dreamweaver 删除的代码主要是 Word 用来格式化和显示 Word 文档的，在显示 HTML 文件时并不需要。保留原始 Word (.doc) 文件的一份副本作为备份，因为一旦应用了“清理 Word 的 HTML”功能，可能就无法在 Word 中再次打开该 HTML 文档。

若要清理不是由 Microsoft Word 生成的 HTML 或 XHTML，请参见清理代码。

若要打开和清理 Microsoft Word HTML 文件，请执行以下操作：

  1. 在 Microsoft Word 中，将文档另存为 HTML 文件（如果您尚未这样做）。

    注意

    在 Windows 中，在 Word 中关闭文件以避免共享冲突。
  2. 在 Dreamweaver 中打开 HTML 文件。

    要查看 Word 生成的 HTML 代码，请切换到“代码”视图（“查看”>“代码”）。

  3. 选择“命令”>“清理 Word 的 HTML”。

    此时会显示“清理 Word 的 HTML”对话框。

    Dreamweaver 试图确定使用哪个版本的 Word 保存文件时，可能会有一点延迟。如果 Dreamweaver 无法确定这一点，请使用弹出菜单选择正确的版本。

  4. 如果需要，取消对该对话框中的选项的选择。

    有关此对话框中的选项的更多信息，请参见设置“清理 Word 的 HTML”对话框的选项。

  5. 单击“确定”。

    Dreamweaver 将清理设置应用于 HTML 文档，而且出现一个更改记录（除非您在对话框中取消了对该选项的选择）。

相关主题

  • 导入 Microsoft Office 文档（仅限 Windows）


参考资料

本节提供在本章中介绍的下列对话框的有关信息：

  • 设置“新建文档”对话框选项
  • 设置“新建文档”对话框的“常规”选项卡中的选项
  • 设置“新建文档”对话框的“模板”选项卡中的选项
  • 设置“新建文档”的“首选参数”对话框中的选项
  • 设置“清理 Word 的 HTML”对话框的选项


设置“新建文档”对话框选项

“新建文档”对话框用于创建新文档。

该对话框包含两个选项卡，并带有用于新文档类型的选项：

“常规”选项卡中包含可用于创建新的空白页和预设计页的文档类型，空白页和预设计页可作为您自己的页面的基础。（有关设置“常规”选项卡上的选项的信息，请参见设置“新建文档”对话框的“常规”选项卡中的选项。）可以从下列类别中选择文档类型：

  • “基本页”、“动态页”、“框架集”和“模板”类别使您可以创建新的空白文档或模板。
  • “其它”类别可使您创建基于特殊文件类型（如 CSS、JavaScript、VBScript 或文本文件）的空白页。
  • “CSS 样式表”、“页面设计”、“页面设计 (CSS)”和“页面设计（有辅助功能的）”类别为您提供了预置的设计文件，您可以使用它们创建自己的页面。

    如果选择了“CSS 样式表”类别，您可以复制预先设计的样式表，然后将其应用于您的文档。

“模板”选项卡中包含您定义的 Dreamweaver 站点的列表。可以从列出的任何站点中选择一个模板，以创建基于该模板的新文档。有关设置“模板”选项卡中的选项的信息，请参见设置“新建文档”对话框的“模板”选项卡中的选项。

相关主题

  • 创建新的空白文档
  • 创建基于 Dreamweaver 设计文件的文档
  • 创建基于现存模板的文档


设置“新建文档”对话框的“常规”选项卡中的选项

“新建文档”对话框的“常规”选项卡使您可以创建新的空白页或使用预定义的页。

若要完成“新建文档”对话框的“常规”选项卡，请执行以下操作：

  1. 从左侧的“类别”列表中选择一个文档类别。

    右侧的列表根据您的选择而更改。同时显示的还有所选文档的说明及预览（大多数的类别的文档都有预览）。

  2. 从右侧的“基本页”列表中选择一个文档类型。
  3. 如果选择“基本”、“动态”或“模板”页面类型，则可以从“文档类型 (DTD)”弹出式菜单中选择一种 XHTML 文档类型从而使页面符合 XHTML。

    例如，可从弹出式菜单中选择“XHTML 1.0 Transitional”或“XHTML 1.0 Strict”，使 HTML 文档与 XHTML 兼容。有关更多信息，请参见关于由 Dreamweaver 生成的 XHTML 代码。

    XHTML（可扩展超文本标记语言）是以 XML 应用程序形式重新组织的 HTML。通常，利用 XHTML，您可以实现 XML 的优点，同时还能确保 Web 文档的向后和向前兼容性。

    有关 XHTML 的更多信息，请参见 WWW 联合会 (W3C) Web 站点，它包含有关 XHTML 1.1—基于模块的 XHTML (www.w3.org/TR/xhtml11/) 和 XHTML 1.0 (www.w3c.org/TR/xhtml1/) 的规范以及基于 Web 的文件 (http://validator.w3.org/) 和本地文件 (http://validator.w3.org/file-upload.html) 的 XHTML 验证程序站点。

    • 如果选择了“基于表格的布局”页面类型，可以根据保存新文档的方式来选中“文档”或“模板”选项。
  4. 如果要设置默认文档首选参数（如文档类型、编码和文件扩展名），请单击对话框底部的“首选参数”选项。
  5. 如果要启动可在其中下载更多页面设计内容的 Dreamweaver Exchange，请单击对话框底部的“获取更多内容”链接。
  6. 单击“创建”按钮。

    新文档在“文档”窗口中打开。

相关主题

  • 设置“新建文档”对话框选项


设置“新建文档”对话框的“模板”选项卡中的选项

“新建文档”对话框的“模板”选项卡使您可以基于任何已定义站点中的模板创建新文档。

若要完成“新建文档”对话框的“模板”选项卡，请执行以下操作：

  1. 从左侧的列表中选择一个站点。
  2. 从右侧的列表中选择一个模板。
  3. 如果您不希望在每次更改模板后 Dreamweaver 都更新基于该模板的页面，请取消选择“当模板改变时更新页面”复选框。

    如果取消选择该选项，该文档将成为一个独立的 HTML。

  4. 如果要设置默认文档首选参数（如文档类型、编码和文件扩展名），请单击对话框底部的“首选参数”选项。
  5. 如果要启动可在其中下载更多页面设计内容的 Dreamweaver Exchange，请单击对话框底部的“获取更多内容”链接。
  6. 单击“创建”按钮。

    基于选定模板的新文档出现在“文档”窗口中。

相关主题

  • 设置“新建文档”对话框选项


设置“新建文档”的“首选参数”对话框中的选项

该对话框用于建立默认的新文档类型和首选参数。

若要设置新文档参数，请执行以下操作：

  1. 设置要应用的选项：
    • 若要设置要打开的默认文档类型，请在“默认文档”弹出式菜单下，选择在站点中创建的新页面所基于的文档。
    • 如果选择 HTML 作为默认文档，可以使用“默认扩展名”文本框为 Dreamweaver 中新建的 HTML 页面指定您喜欢的文件扩展名（.htm 或 .html）。有关更多信息，请参见设置新建 HTML 文档的默认文件扩展名。

      注意

      其他文件类型禁用此选项。
    • 若要使用新页面符合 XHTML，请从“默认文档类型 (DTD)”弹出式菜单中选择一种 XHTML 文档类型定义 (DTD)。

      例如，可从弹出式菜单中选择“XHTML 1.0 Transitional”或“XHTML 1.0 Strict”，使 HTML 文档与 XHTML 兼容。有关更多信息，请参见关于由 Dreamweaver 生成的 XHTML 代码。

    • 若要设置文档编码，请使用“默认编码”弹出式菜单。

      “默认编码”指定在创建新页面时要使用的编码，以及指定在未指定任何编码的情况下打开一个文档时要使用的编码。有关更多信息，请参见了解文档编码。

      如果选择 Unicode (UTF-8) 作为文档编码，则不需要实体编码，因为 UTF-8 可以安全地表示所有字符。如果选择其他文档编码，则可能需要用实体编码来表示某些字符。有关字符实体的更多信息，请参见 www.w3.org/TR/REC-html40/sgml/entities.html。

    • 如果选择 Unicode (UTF-8) 作为默认编码，请选择一个 Unicode 标准化表单。

      有四种 Unicode 标准化表单。最重要的是标准化表单 C，因为它是用于万维网的字符模型的最常用表单。Macromedia 提供其他三种 Unicode 标准化表单作为补充。

      在 Unicode 中，有些字符看上去很相似，但可用不同的方法存储在文档中。例如，“ë”（e 变音符）可表示为单个字符“e 变音符”，或两个字符“正常拉丁语 e”+“组合变音符”。Unicode 组合字符是与前一个字符结合使用的字符，因此变音符会显示在“拉丁语 e”的上方。这两种形式都显示为相同的印刷样式，但保存在文件中的每种形式是不同的。

      标准化是指确保可用不同形式保存的所有字符都使用相同的形式进行保存的过程。即，文档中所有“ë”字符都保存为单个“e 变音符”或“e”+“组合变音符”，而不是在一个文档中保存为这两种形式。

      有关 Unicode 标准化和可以使用的特定表单的更多信息，请参见 Unicode Web 站点，网址是 www.unicode.org/reports/tr15。

    • 如果选择 Unicode (UTF-8) 作为默认编码，则可以选择“包括 Unicode 签名 (BOM)”选项以在文档中包括字节顺序标记 (BOM)。

      BOM 是位于文本文件开头的 2 到 4 个字节，可将文件标识为 Unicode，还标识后面字节的字节顺序。由于 UTF-8 没有字节顺序，因此可以选择添加 UTF-8 BOM。对于 UTF-16 和 UTF-32，这是必需的。

    • 取消选中“Ctrl+N 时显示新文档对话框”(Windows)（“Command+N 时显示新文档对话框”(Macintosh)）选项，在使用键命令时将自动创建默认文档类型的新文档。
  2. 单击“确定”。

相关主题

  • 设置默认的新文档类型


设置“清理 Word 的 HTML”对话框的选项

该对话框用于删除 Microsoft Word 创建的无关 HTML 代码。

若要清理 Microsoft Word 的 HTML，请执行以下操作：

  1. 选择该功能应使用“基本”选项卡中的哪些选项：

    删除所有 Word 特定的标记删除所有 Microsoft Word 特定的 HTML，包括 HTML 标签中的 XML、文档头中的 Word 自定义元数据和链接标签、Word XML 标记、条件标签及其内容以及样式中的空段落和边距。可以使用“详细”选项卡分别选择各个选项。

    清理 CSS删除所有 Word 特定的 CSS，包括尽可能地删除内联 CSS 样式（当父样式有相同的样式属性时）、以“mso”开头的样式属性、非 CSS 样式声明、表格中的 CSS 样式属性以及文档头中所有未使用的样式定义。使用“详细”选项卡可以进一步自定义此选项。

    清理 <font> 标签删除 HTML 标签，将默认的正文文本转换成 2 号字的 HTML 文本。

    修复无效的嵌套标签删除由 Word 在段落和标题（块级）标签外部插入的字体标记标签。

    设定背景颜色允许输入十六进制值设置文档的背景颜色。如果不设定背景颜色，Word HTML 页面的背景颜色将是灰色的。Dreamweaver 设置的默认十六进制值为白色。

    应用源格式将“HTML 格式”首选参数和 SourceFormat.txt 中指定的源格式选项应用于文档。

    完成时显示动作记录在完成清理时显示一个警告框，其中包含有关文档改动的详细信息。

  2. 如果需要进一步自定义“删除所有 Word 特定的标签”和“清理 CSS”选项，请单击“详细”选项卡。
  3. 单击“确定”。

    根据文档大小和所选选项数目的不同，可能需要几秒钟完成清理。您输入的首选参数自动保存为默认的“清理 Word 的 HTML”设置。

相关主题

  • 打开现有文档
  • 清理 Microsoft Word 的 HTML 文件


使用 Dreamweaver 站点

学习如何管理 Macromedia Dreamweaver 8 站点和站点特定的资源。

此部分包含以下各章：

管理您的文件

管理站点资源和库

使用 Dreamweaver 管理 Contribute 站点


管理您的文件

Macromedia Dreamweaver 8 可帮助您组织和管理文件。

Dreamweaver 提供全面的用于管理文件以及与远端服务器进行文件传输的功能。当您在本地和远端站点之间传输文件时，Dreamweaver 会在这两种站点之间维持平行的文件和文件夹结构。在这两种站点之间传输文件时，如果站点中不存在必需的文件夹，则 Dreamweaver 将自动创建这些文件夹。您也可以在本地和远端站点之间同步文件；Dreamweaver 会根据需要在两个方向上复制文件，并且在适当的情况下删除不需要的文件。

Dreamweaver 具有能使 Web 站点上的协作更为容易的功能。您可以在远端服务器中存回和取出文件，使 Web 开发小组的其他成员能够看到谁正在处理哪个文件。您可以向自己的文件添加设计备注，以便同小组成员共享文件状态、优先级等方面的信息。您还可以使用“工作流程报告”功能在自己的站点上运行报告，以显示有关存回/取出状态的信息并搜索附加到文件的设计备注。

本章包含下列章节：

关于站点管理

访问站点、服务器和本地驱动器

查看文件和文件夹

比较文件的差别

复原文件（Contribute 用户）

在“文件”面板中管理文件和文件夹

使用站点的视觉地图

导入和导出站点

从站点列表中删除 Dreamweaver 站点

存回和取出文件

从服务器获取文件和将文件上传到服务器

同步本地和远端站点上的文件

标识和删除未使用的文件

遮盖站点中的文件夹和文件

在设计备注中存储文件信息

测试站点


关于站点管理

Dreamweaver 中包含很多功能，用于管理站点并与远端服务器之间传输文件。Dreamweaver 还包含能使 Web 站点上的协作更为容易的功能，如“存回/取出”和“设计备注”。

本节包含以下概念性主题：

  • 关于存回/取出系统
  • 关于后台文件传输
  • 关于站点遮盖
  • 关于设计备注
  • 关于相关文件


关于存回/取出系统

如果您在协作环境中工作，则可以在本地和 中存回和取出文件。

注意

您可以将“获取”和“上传”功能用于测试服务器，但不能将存回/取出系统用于测试服务器。有关使用“获取”和“上传”功能的更多信息，请参见从服务器获取文件和将文件上传到服务器。

取出文件等同于声明“我正在处理这个文件，请不要动它！”文件被取出后，Dreamweaver 会在“文件”面板中显示取出这个文件的人的姓名，并在文件图标的旁边显示一个红色选中标记（如果取出文件的是小组成员）或一个绿色选中标记（如果取出文件的是您）。

存回文件使文件可供其他小组成员取出和编辑。当您在编辑文件后将其存回时，本地版本将变为只读，一个锁形符号出现在“文件”面板上该文件的旁边，以防止您更改该文件。

Dreamweaver 不会使远端服务器上的取出文件成为只读。如果您使用 Dreamweaver 之外的应用程序传输文件，则可能会覆盖取出文件。但是，在 Dreamweaver 之外的应用程序中，LCK 文件显示在该文件所在的目录结构中取出文件的旁边，以防止出现这种意外。

有关 LCK 文件和“存回/取出”系统如何工作的更多信息，请参见 Macromedia Web 站点上的 TechNote 15447（网址为 www.macromedia.com/go/15447）。

相关主题

  • 设置存回/取出系统
  • 将文件存回远端文件夹和从远端文件夹中取出


关于后台文件传输

Dreamweaver 使您可以在获取或上传文件期间执行其他与服务器无关的活动。背景文件传输对于 Dreamweaver 所支持的所有传输协议都适用：FTP、SFTP、LAN、WebDAV、Microsoft Visual SourceSafe 和 RDS。

与服务器无关的活动包括如键入、编辑外部样式表、生成站点范围的报告以及创建新站点之类的常用操作。

Dreamweaver 在文件传输期间无法执行的与服务器相关的活动包括：

  • 上传/获取/存回/取出文件。
  • 撤消取出。
  • 创建数据库连接。
  • 绑定动态数据。
  • 预览动态数据。
  • 插入 Web 服务。
  • 删除远端文件或文件夹。
  • 在测试服务器上的浏览器中预览。
  • 将文件保存到远端服务器。
  • 从远端服务器插入图像。
  • 从远端服务器打开文件。
  • 在保存时自动上传文件。
  • 将文件拖动到远端站点。
  • 剪切、复制或粘贴远端站点上的文件。
  • 刷新“远程”视图。

相关主题

  • 管理文件传输


关于站点遮盖

利用站点遮盖功能，您可以从“获取”或“上传”等操作中排除某些文件夹和文件类型。您可以遮盖单独的文件夹，但不能遮盖单独的文件。若要遮盖文件，必须选择文件类型，而 Dreamweaver 会遮盖该类型的所有文件。Dreamweaver 会记住每个站点的设置，因此您不必每次在该站点上工作时都进行选择。

例如，如果您在一个大型站点上工作，并且不想每天都上传多媒体文件，则可以使用站点遮盖功能遮盖您的多媒体文件夹，而系统会从您执行的站点操作中排除该文件夹中的文件。

您可以遮盖远程或本地站点上的文件夹和文件类型。遮盖功能会从以下操作中排除遮盖的文件夹和文件：

  • 执行上传、获取、存回和取出操作
  • 生成报告
  • 查找较新的本地文件和查找较新的远端文件
  • 执行站点范围的操作，如检查和更改链接
  • 同步
  • 使用“资源”面板内容
  • 更新模板和库

    注意

    Dreamweaver 仅从“获取”和“上传”操作中排除遮盖的模板和库项。Dreamweaver 并不从批处理操作中排除这些项，因为这可能会使这些项与它们的实例不同步。

相关主题

  • 遮盖站点中的文件夹和文件


关于设计备注

设计备注是您为文件创建的备注。设计备注与它们所描述的文件相关联，但存储在单独的文件中。您可以在展开的“文件”面板上看到哪些文件有设计备注：“设计备注”图标会出现在“备注”列中。

您可以使用设计备注来记录与文档关联的其他文件信息，如图像源文件名称和文件状态说明。例如，如果将一个源文件从一个站点复制到另一个站点，则可以为该文件添加设计备注，说明原始文件位于另一站点的文件夹。

您也可以使用设计备注来记录因安全原因而不能放在文档中的敏感信息，例如，您可以记录某一价格或配置是如何选定的或哪些市场因素影响了某一设计决策等信息。

如果您在 Macromedia Fireworks 或 Flash 中打开一个文件并将其导出为其他格式，则 Fireworks 和 Flash 自动在设计备注文件中保存源文件的名称。例如，如果您在 Fireworks 中打开 myhouse.png 并将其导出为 myhouse.gif，则 Fireworks 会创建一个名为 myhouse.gif.mno 的设计备注文件。此设计备注文件包含原始文件的名称，作为绝对 file:URL。因此，myhouse.gif 的设计备注可能包含此行：

fw_source="file:///Mydisk/sites/assets/orig/myhouse.png"

类似的 Flash 设计备注可能包含此行：

fl_source="file:///Mydisk/sites/assets/orig/myhouse.fla"

注意

若要共享设计备注，用户应定义相同的站点根路径（例如 sites/assets/orig）。

当您将图形导入 Dreamweaver 中时，设计备注文件随该图形一起被自动复制到站点中。当您在 Dreamweaver 中选择图像并选择使用 Fireworks 编辑它时（请参见为媒体文件启动外部编辑器），Fireworks 将打开源文件以供编辑。

相关主题

  • 对站点启用和禁用设计备注
  • 建立设计备注与文件的关联


关于相关文件

当使用“文件”面板在本地和远端文件夹之间传输文档时，Dreamweaver 会为您提供选项以传输文档的相关文件。相关文件是文档中引用的图像、外部样式表和其他文件，浏览器在载入该文档时会载入这些相关文件。

Dreamweaver 将库项目也视为相关文件。有关更多信息，请参见关于库项目。

某些服务器会在上传库项目时报告错误。但是，可以遮盖这些文件以阻止其传输。有关说明，请参见遮盖站点中的文件夹和文件。

相关主题

  • 从远程服务器获取文件
  • 将文件上传到远端服务器上


访问站点、服务器和本地驱动器

您可以访问、修改和保存 Dreamweaver 站点中的文件和文件夹，以及不属于 Dreamweaver 站点的文件和文件夹。除了 Dreamweaver 站点外，您还可以访问服务器、本地驱动器或者您的桌面。

在访问远端服务器之前，必须对 Dreamweaver 进行设置，使之能够使用该服务器（请参见设置 Dreamweaver 在不定义站点的情况下工作）。

注意

管理文件的最佳方式是创建 Dreamweaver 站点（请参见设置新的 Dreamweaver 站点）。

若要打开现有的 Dreamweaver 站点，请执行以下操作：

  • 在“文件”面板（“窗口”>“文件”）中，从弹出菜单（当前站点、服务器或驱动器显示在该菜单中）中选择一个站点。

有关更改站点视图（例如查看远端文件夹）的信息，请参见查看文件和文件夹。有关打开站点中的文件的信息，请参见在“文件”面板中处理文件。

若要打开远程 FTP 或 RDS 服务器上的文件夹，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，从弹出式菜单（当前站点、服务器或驱动器显示在该菜单中）中选择一个服务器名称。

    注意

    您配置用 Dreamweaver 进行处理的服务器名称会显示出来。如果您还没有配置服务器，请参见设置 Dreamweaver 在不定义站点的情况下工作。
  2. 和往常一样定位到文件并编辑这些文件。

    有关更多信息，请参见在“文件”面板中处理文件。

若要访问本地驱动器或您的桌面，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，从弹出式菜单（当前站点、服务器或驱动器显示在该菜单中）中选择“桌面”、“本地磁盘”或“CD 驱动器”。

  2. 浏览到一个文件，然后执行以下任意操作：
    • 在 Dreamweaver 或其他应用程序中打开文件
    • 重命名文件
    • 复制文件
    • 删除文件
    • 拖动文件

      当您将文件从一个 Dreamweaver 站点拖至另一个站点（或一个不属于 Dreamweaver 站点的文件夹）时，Dreamweaver 会将该文件复制到目标位置。如果您在同一 Dreamweaver 站点中拖放文件，Dreamweaver 会将该文件移动到目标位置。如果您将不属于 Dreamweaver 站点的文件拖放到不属于 Dreamweaver 站点的文件夹，Dreamweaver 会将该文件移动到目标位置。

      注意

      若要移动 Dreamweaver 在默认情况下复制的文件，请在拖动时按住 Shift 键 (Windows) 或 Command 键 (Macintosh)。若要复制 Dreamweaver 在默认情况下移动的文件，请在拖动时按住 Ctrl 键 (Windows) 或 Option 键 (Macintosh)。

相关主题

  • 查看文件和文件夹
  • 在“文件”面板中管理文件和文件夹


设置 Dreamweaver 在不定义站点的情况下工作

Dreamweaver 允许您连接到 FTP 或 RDS 服务器处理文档而不创建 Dreamweaver 站点。

注意

如果您在不创建 Dreamweaver 站点的情况下处理文件，则不能执行站点范围的操作，例如链接检查。若要设置 Dreamweaver 站点，请参见设置新的 Dreamweaver 站点。

若要设置 Dreamweaver 从“文档”窗口使用服务器，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 单击“新建”，然后选择“FTP & RDS 服务器”。

    随即显示“配置服务器”对话框。

  3. 完成对话框。

    有关更多信息，请参见设置“配置服务器”对话框选项。

    注意

    您只需为要连接的每台服务器完成一次此对话框。
  4. 单击“确定”。

    “文件”面板将显示连接到的远端服务器文件夹的内容，该服务器名称显示在面板顶部的弹出菜单中。

若要设置 Dreamweaver 通过“文件”面板使用服务器，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，从弹出式菜单中（当前站点、服务器或驱动器显示在该菜单中）选择“桌面”。

  2. 在“文件”面板中右键单击 (Windows) 或按住 Control 键单击 (Macintosh)“FTP & RDS 服务器”节点，然后选择“添加 FTP 服务器”或“添加 RDS 服务器”。

    随即显示“配置服务器”对话框。

  3. 完成对话框。

    有关更多信息，请参见设置“配置服务器”对话框选项。

    注意

    您只需为要连接的每台服务器完成一次此对话框。
  4. 单击“确定”。

    “文件”面板将显示连接到的远端服务器文件夹的内容，该服务器名称显示在面板顶部的弹出菜单中。

    注意

    对于大文件夹，“文件”面板可能需要一点时间显示它。

相关主题

  • 访问站点、服务器和本地驱动器


查看文件和文件夹

您可以在“文件”面板中查看文件和文件夹，而无论它们是否与 Dreamweaver 站点相关联。在“文件”面板中查看站点、文件或文件夹时，您可以更改查看区域的大小。对于 Dreamweaver 站点，您还可以展开或折叠“文件”面板。

对于 Dreamweaver 站点，您还可以通过更改默认显示在折叠的面板中的视图（本地站点或远端站点）来对“文件”面板进行自定义。或者，您可以使用“总是显示”选项在展开的“文件”面板中切换内容视图（请参见设置“文件”面板的首选参数）。

若要打开或关闭“文件”面板，请执行以下操作：

  • 选择“窗口”>“文件”。

若要在展开的“文件”面板中更改视图区域的大小，请执行以下操作：

  • 在“文件”面板（“窗口”>“文件”）中（面板处于展开状态），执行以下操作之一：
    • 拖动两个视图之间的分隔条以增加或减少右窗格或左窗格的视图区域。
    • 使用“文件”面板底部的滚动条滚动查看视图的内容。
    • 在站点地图中，拖动文件之上的箭头以更改文件之间的空间。

若要展开或折叠“文件”面板（仅限 Dreamweaver 站点），请执行以下操作：

  • 在“文件”面板（“窗口”>“文件”）中，单击工具栏上的“扩展/折叠”按钮。 这是所描述的功能的图片。

    注意

    如果单击“扩展/折叠”按钮展开停靠的面板，面板就会最大化，使您无法在“文档”窗口中工作。若要返回到“文档”窗口，请再次单击“扩展/折叠”按钮折叠面板。如果单击“扩展/折叠”按钮展开没有停靠的面板，您仍可在“文档”窗口中工作。再次停靠面板之前，您必须先折叠该面板。

当“文件”面板折叠时，它以文件列表的形式显示本地站点、远端站点或测试服务器的内容。在展开时，它显示本地站点和远端站点或者显示本地站点和测试服务器。“文件”面板还可以显示本地站点的视觉站点地图。

若要更改“文件”面板中的站点视图，请执行以下操作之一（仅限 Dreamweaver 站点）：

  • 在折叠的“文件”面板（“窗口”>“文件”）中，从“站点视图”弹出式菜单中选择“本地视图”、“远程视图”、“测试服务器”或“地图视图”。

    注意

    默认情况下，“本地视图”出现在该弹出菜单中。

  • 在展开的“文件”面板（“窗口”>“文件”）中，单击工具栏上的“站点文件”按钮（对于远端站点）、“测试服务器”按钮或“站点地图”按钮。

    如果您单击“站点地图”按钮，则可以选择查看包含站点文件的站点地图或仅查看站点地图。有关更多信息，请参见查看站点地图。

    注意

    在查看远端站点或测试服务器之前，必须先设置一个远端站点或测试服务器（请参见设置远端文件夹或指定可在哪里处理动态页）。在查看站点地图之前，必须先设置一个主页（请参见查看站点地图）。

相关主题

  • 访问站点、服务器和本地驱动器
  • 对在展开的“文件”面板中显示的文件和文件夹详细信息进行自定义
  • 在“文件”面板中管理文件和文件夹


对在展开的“文件”面板中显示的文件和文件夹详细信息进行自定义

在展开的“文件”面板中查看 Dreamweaver 站点时（请参见查看文件和文件夹），Dreamweaver 将在列中显示有关文件和文件夹的信息。例如，您可以看到文件类型或文件的修改日期。

您可以通过以下任何操作对列进行自定义（某些操作仅适用于添加的列，不适用于默认列）：

  • 更改列的顺序，或将列重新排列
  • 添加新列（最多 10 列）
  • 隐藏列（文件名列除外）
  • 指定将与连接到站点的所有用户共享的列
  • 删除列（仅限自定义的列）
  • 重命名列（仅限自定义的列）
  • 与设计备注关联（仅限自定义的列）

若要在“文件”面板中按任何详细列排序，请执行以下操作：

  • 单击要排序的列的标题。

    提示

    再次单击该标题将颠倒 Dreamweaver 用以对列排序的顺序（升序或降序）。

若要添加、删除或更改详细列，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 选择一个站点，然后单击“编辑”。

    出现“站点定义”对话框。

  3. 从左侧的类别列表中选择“文件视图列”。

    “站点定义”对话框显示“文件视图列”选项。

  4. 完成对话框。

    有关更多信息，请参见设置“文件视图列”类别选项。

  5. 单击“确定”。


比较文件的差别

Dreamweaver 可以使用文件比较工具（也称为“diff 工具”）比较同一文件的本地和远程版本的代码、两个不同的远端文件的代码或两个不同的本地文件的代码。在本地处理某个文件并怀疑该文件在服务器上的副本已由他人进行了修改时，比较本地和远程版本十分有用。可以在将文件上传到服务器之前查看远程更改并将这些更改合并到本地版本中，而无需离开 Dreamweaver。

当保留以前的已重命名的文件版本时，比较两个本地文件或两个远端文件也十分有用。如果忘记了在以前的版本中对文件所做的更改，则快速比较会向您提示这些更改。

在开始之前，必须在系统上安装一个第三方文件比较工具。有关文件比较工具的更多信息，请参见 Macromedia Web 站点，网址为 www.macromedia.com/go/dw8_compare_util。安装之后，还必须在 Dreamweaver 中指定该工具，如本节稍后所述。

本节包含以下主题：

  • 比较两个文件
  • 在上传文件之前进行比较
  • 同步文件时进行比较
  • 在 Dreamweaver 中指定比较工具


比较两个文件

在系统上安装了文件比较工具并在 Dreamweaver 中指定了该工具后，您可以通过 Dreamweaver 执行以下任意任务：

  • 比较两个本地文件单字加两个标点
  • 比较两个远端文件
  • 将本地文件与远端文件进行比较
  • 将远端文件与本地文件进行比较
  • 将打开的文件与远端文件进行比较

相关主题

  • 在上传文件之前进行比较
  • 同步文件时进行比较


比较两个本地文件单字加两个标点

可以比较位于计算机上任意位置的两个文件。

若要比较两个本地文件，请执行以下操作：

  1. 在“文件”面板中，按住 Ctrl 键单击 (Windows) 或按住 Command 键单击 (Macintosh) 选择这两个文件。

    提示

    若要选择您定义的站点之外的文件，请在“文件”面板中从左侧弹出式菜单中选择本地磁盘，然后选择文件。
  2. 右键单击一个所选文件，然后从上下文菜单中选择“比较本地文件”。

    注意

    如果您用的是单按钮鼠标，则请按住 Ctrl 键单击一个所选文件。

    文件比较工具会启动并比较这两个文件。


比较两个远端文件

可以比较位于远端服务器上的两个文件。完成该任务前，必须用远程设置定义一个 Dreamweaver 站点。有关更多信息，请参见设置新的 Dreamweaver 站点。

若要比较两个远端文件，请执行以下操作：

  1. 在“文件”面板中，从右侧弹出式菜单中选择“远程视图”以显示远端服务器上的文件。
  2. 按住 Ctrl 键单击 (Windows) 或按住 Command 键单击 (Macintosh) 选择这两个文件
  3. 右键单击一个所选文件，然后从上下文菜单中选择“比较远端文件”。

    注意

    如果您用的是单按钮鼠标，则请按住 Ctrl 键单击一个所选文件。

    文件比较工具会启动并比较这两个文件。


将本地文件与远端文件进行比较

可以将本地文件与位于远端服务器上的文件进行比较。为此，必须先用远程设置定义一个 Dreamweaver 站点。有关更多信息，请参见设置新的 Dreamweaver 站点。

若要将本地文件与远端文件进行比较，请执行以下操作：

  • 在“文件”面板中，右键单击一个本地文件并从上下文菜单中选择“与远端比较”。

    注意

    如果您用的是单按钮鼠标，则请按住 Ctrl 键单击该本地文件。

    文件比较工具会启动并比较这两个文件。


将远端文件与本地文件进行比较

可以将远端文件与本地文件进行比较。完成该任务前，必须用远程设置定义一个 Dreamweaver 站点。有关更多信息，请参见设置新的 Dreamweaver 站点。

若要将远端文件与本地文件进行比较，请执行以下操作：

  1. 在“文件”面板中，从右侧弹出式菜单中选择“远程视图”以显示远端服务器上的文件。
    • 在该面板中右键单击一个文件，然后从上下文菜单中选择“与本地比较”。

      注意

      如果您用的是单按钮鼠标，则请按住 Ctrl 键单击该文件。


将打开的文件与远端文件进行比较

可以将在 Dreamweaver 中打开的文件与其在远端服务器上的副本进行比较。

若要将在 Dreamweaver 打开的文件与其远程副本进行比较，请执行以下操作：

  • 在“文档”窗口中，选择“文件”>“与远端比较”。

    文件比较工具会启动并比较这两个文件。

    提示

    也可以在“文档”窗口顶部右键单击“文档”选项卡，然后从上下文菜单中选择“与远端比较”。


在上传文件之前进行比较

如果您在本地编辑某个文件，然后尝试将其上传到远端服务器，则该文件的远程版本发生更改时 Dreamweaver 会通知您。Dreamweaver 会为您提供选项以便在您上传文件并覆盖远程版本之前比较这两个文件。

在您开始之前，必须在系统上安装一个文件比较工具并在 Dreamweaver 中指定该工具。有关更多信息，请参见在 Dreamweaver 中指定比较工具。

若要在上传文件时比较文件，请执行以下操作：

  1. 在对 Dreamweaver 站点中的某个文件进行编辑之后，将该文件上传（“站点”>“上传”）到远端站点。

    如果该文件的远程版本发生修改，Dreamweaver 会通知您并为您提供选项以查看其中的差别。

  2. 若要查看差别，请单击“比较”按钮。

    文件比较工具会启动并比较这两个文件。

    如果尚未指定文件比较工具，Dreamweaver 会提示您指定一个。

  3. 在该工具中对更改进行查看或合并之后，可以继续执行上传操作或取消该操作。

相关主题

  • 比较两个文件
  • 同步文件时进行比较


同步文件时进行比较

当您对站点文件与 Dreamweaver 进行同步时，可以将文件的本地版本与远程版本进行比较。

在您开始之前，必须在系统上安装一个文件比较工具并在 Dreamweaver 中指定该工具。有关更多信息，请参见在 Dreamweaver 中指定比较工具。

若要在同步过程中比较文件，请执行以下操作：

  1. 在“文件”面板中的任意位置单击右键，然后从上下文菜单中选择“同步”。

    出现“同步文件”对话框。

  2. 完成“同步文件”对话框，然后单击“预览”。

    有关更多信息，请参见同步本地和远端站点上的文件。

    单击“预览”后，Dreamweaver 会列出所选文件以及它将在同步过程中所执行的动作。

  3. 在该列表中，选择要比较的每个文件，然后单击“比较”按钮（具有两个小页面的图标）。

    注意

    必须是基于文本的文件（如 HTML 或 ColdFusion 文件）。

    Dreamweaver 会启动比较工具，对您选择的每个文件的本地版本和远程版本进行比较。

相关主题

  • 比较两个文件
  • 在上传文件之前进行比较


在 Dreamweaver 中指定比较工具

必须在系统上安装第三方文件比较工具来比较 Dreamweaver 中的文件。有关文件比较工具的更多信息，请参见 Macromedia Web 站点，网址为 www.macromedia.com/go/dw8_compare_util。

安装文件比较工具之后，必须在 Dreamweaver 中指定该工具，如本节所述。

若要指定文件比较工具，请执行以下操作：

  1. 在与 Dreamweaver 所在的同一系统上安装文件比较工具。
  2. 在 Dreamweaver 中，选择“编辑”>“首选参数”(Windows)，或者选择“Dreamweaver”>“首选参数”(Macintosh)，以打开“首选参数”对话框，然后选择“文件比较”类别。
  3. 在 Windows 中，请单击“浏览”按钮，然后选择用于比较文件的应用程序。
  4. 在 Macintosh 上，请单击“浏览”按钮，然后选择从命令行启动文件比较工具的工具或脚本，而不是实际的比较工具本身。

    启动工具或脚本通常位于 Macintosh 上的 usr/bin 文件夹中。例如，如果要使用 FileMerge，请浏览至 usr/bin 并选择 opendiff（启动 FileMerge 的工具）。

    下表列出了针对 Macintosh 的常用文件比较工具，以及它们的启动工具或脚本在硬盘上的位置：

    如果使用

    请选择下面的文件

    FileMerge

    usr/bin/opendiff

    BBEdit

    usr/bin/bbdiff

    TextWrangler

    usr/bin/twdiff

    注意

    usr 文件夹通常隐藏在 Finder 中。不过，可以在 Dreamweaver 中使用“浏览”按钮访问该文件夹。

相关主题

  • 比较两个文件
  • 在上传文件之前进行比较
  • 同步文件时进行比较


复原文件（Contribute 用户）

如果启用了 Contribute 兼容性，则 Dreamweaver 会自动保存文档的多个版本。若要启用 Contribute 兼容性，请参见准备站点以用于 Contribute。

注意

必须将 Contribute 与 Dreamweaver 安装在同一计算机上。

还必须在 Contribute 管理设置中启用文件复原。有关更多信息，请参见“管理 Contribute”。

回退到文件的以前版本：

  1. 在“文件”面板中，右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 文件。
  2. 选择回退页。

    如果有要回退的页面的任何以前版本，将出现“回退”对话框。

  3. 选择要回退到的页面版本，然后单击“回退”。

相关主题

  • 删除、移动或重命名 Contribute 站点中的远端文件


在“文件”面板中管理文件和文件夹

您可以组织和管理站点文件和文件夹，无论它们是 Dreamweaver 站点的一部分（位于连接的服务器上），还是位于您的本地驱动器或桌面上。

注意

在以前的 Dreamweaver 版本中，“文件”面板称为“站点”面板。

本节包含以下主题：

  • 设置“文件”面板的首选参数
  • 在“文件”面板中处理文件
  • 在 Dreamweaver 站点中查找文件

相关主题

  • 使用“文件”面板
  • 访问站点、服务器和本地驱动器
  • 查看文件和文件夹


设置“文件”面板的首选参数

您可以在“文件”面板中选择首选参数来控制文件传输功能。

若要编辑“文件”面板的首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或Dreamweaver>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从左侧的类别列表中选择“站点”。

    即会出现“站点”首选参数的选项。

  3. 按需要更改选项。

    有关更多信息，请参见设置“站点”首选参数选项

  4. 单击“确定”。

    提示

    您可以通过自定义 Dreamweaver/Configuration 文件夹中的 FTPExtensionMap.txt 文件（在 Macintosh 上为 FTPExtensionMapMac.txt）来定义所传输的文件类型是 ASCII（文本）文件还是二进制文件。有关更多信息，请参见“扩展 Dreamweaver”。

相关主题

  • 对在展开的“文件”面板中显示的文件和文件夹详细信息进行自定义


在“文件”面板中处理文件

您可以打开文件、更改文件名；添加、移动或删除文件；或者在进行更改后刷新“文件”面板。

对于 Dreamweaver 站点，您还可以确定哪些文件（本地站点或远端站点上）在上次传输后进行了更新。有关将本地站点与远程站点同步的信息，请参见同步本地和远端站点上的文件。

若要打开文件，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，从弹出式菜单（当前站点、服务器或驱动器显示在该菜单中）中选择站点、服务器或驱动器。
  2. 定位到要打开的文件。
  3. 执行下列操作之一：
    • 双击该文件的图标。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该文件的图标，然后选择“打开”。

Dreamweaver 会在“文档”窗口中打开该文件。

若要创建新的文件或文件夹，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，选择一个文件或文件夹。

    Dreamweaver 将在当前选定的文件夹中（或者在与当前选定文件所在的同一个文件夹中）新建文件或文件夹。

  2. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“新建文件”或“新建文件夹”。
  3. 输入新文件或新文件夹的名称。
  4. 按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

若要删除文件或文件夹，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，选择要删除的文件或文件夹。
  2. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh)，然后选择“删除”。

若要重命名文件或文件夹，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，选择要重命名的文件或文件夹。
  2. 执行以下操作之一，激活文件或文件夹的名称：
    • 单击文件名，稍停片刻，然后再次单击。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该文件的图标，然后选择“重命名”。
  3. 键入新名称，覆盖现有名称。
  4. 按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

若要移动文件或文件夹，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，选择要移动的文件或文件夹。
  2. 执行下列操作之一：
    • 复制该文件或文件夹，然后粘贴在新位置。
    • 将该文件或文件夹拖到新位置。
  3. 刷新“文件”面板可以看到该文件或文件夹在新位置上。

若要刷新“文件”面板，请执行以下操作之一：

  • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 任意文件或文件夹，然后选择“刷新”。
  • (仅对 Dreamweaver 站点）单击“文件”面板工具栏上的“刷新”按钮（此选项刷新两个窗格）。

    注意

    当您在另一个应用程序中进行了更改并返回到 Dreamweaver 时，Dreamweaver 会自动刷新“文件”面板。

相关主题

  • 查看文件和文件夹
  • 访问站点、服务器和本地驱动器
  • 设置“文件”面板的首选参数
  • 在 Dreamweaver 站点中查找文件


在 Dreamweaver 站点中查找文件

Dreamweaver 可使您更容易地在站点中查找选定的、打开的、取出的或最近修改过的文件。您也可以在本地站点或远端站点中查找较新的文件。

若要在站点中查找打开的文件，请执行以下操作：

  1. 在“文档”窗口中打开文件。
  2. 选择“站点”>“在站点定位”。

Dreamweaver 在“文件”面板中选取文件。

注意

如果“文档”窗口中打开的文件不属于“文件”面板中的当前站点，Dreamweaver 将尝试确定该文件属于您的哪个 Dreamweaver 站点；如果当前文件仅属于一个本地站点，则 Dreamweaver 将在“文件”面板中打开该站点，然后突出显示该文件。

若要定位并选择 Dreamweaver 站点中已取出的文件，请执行以下操作：

  • 在折叠的“文件”面板（“窗口”>“文件”）中，单击“文件”面板右上角的“选项”菜单，然后选择“编辑”>“选择取出的文件”。

Dreamweaver 在“文件”面板中选取文件。

若要在本地或远端站点中查找选定的文件，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）的“本地”或“远程”视图中选中该文件。
  2. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“本地站点中定位”或“远端站点中定位”（取决于您选择文件的位置）。

Dreamweaver 在“文件”面板中选取文件。

若要定位并选择在本地站点比在远端站点新的文件，请执行以下操作：

  • 在折叠的“文件”面板（“窗口”>“文件”）中，单击“文件”面板右上角的“选项”菜单，然后选择“编辑”>“选择较新的本地文件”。

Dreamweaver 在“文件”面板中选取文件。

若要定位并选择在远端站点比在本地站点新的文件，请执行以下操作：

  • 在折叠的“文件”面板（“窗口”>“文件”）中，单击“文件”面板右上角的“选项”菜单，然后选择“编辑”>“选择较新的远端文件”。

Dreamweaver 在“文件”面板中选取文件。

若要在站点中查找最近修改的文件，请执行以下操作：

  1. 在折叠的“文件”面板（“窗口”>“文件”）中，单击“文件”面板右上角的“选项”菜单，然后选择“编辑”>“选择最近修改的文件”。

    出现“选择最近修改的文件”对话框。

  2. 完成对话框。

    有关更多信息，请参见设置“选择最近修改的文件”对话框选项。

  3. 单击“确定”以保存您的设置。

Dreamweaver 在“文件”面板中高亮显示在指定时间段内修改的文件。

相关主题

  • 访问站点、服务器和本地驱动器
  • 查看文件和文件夹
  • 在“文件”面板中处理文件


使用站点的视觉地图

您可以将 Dreamweaver 站点的本地文件夹视作链接的图标的视觉地图，此视觉地图称为站点地图。可以使用站点地图将新文件添加到 Dreamweaver 站点，或者添加、修改或删除链接。

站点地图从主页开始显示两个级别深度的站点结构。站点地图将页面显示为图标，并按在源代码中出现的顺序来显示链接。

站点地图是理想的站点结构布局工具。您可以快速地设置整个站点结构，然后创建站点地图的图形图像。

注意

站点地图仅适用于本地站点。若要创建远端站点的地图，请将远端站点的内容复制到本地磁盘上的一个文件夹中，然后使用“管理站点”命令将该站点定义为本地站点（请参见设置本地文件夹）。

本节包含以下主题：

  • 查看站点地图
  • 修改站点地图布局
  • 在站点地图中处理页
  • 显示和隐藏站点地图文件
  • 通过分支查看站点
  • 保存站点地图

相关主题

  • 使用站点地图链接文档


查看站点地图

在显示站点地图之前，必须先定义站点的主页。站点的主页可以是站点中的任意页面；它不必是站点的主要页面。这种情况下，主页只是地图的起点。

若要定义站点的主页，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，从弹出式菜单（当前站点、服务器或驱动器显示在该菜单中）中选择一个站点。
  2. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 要设为主页的文件，然后选择“设置为主页”。

    注意

    还可以在“站点定义”对话框的“站点地图布局”选项中设置主页（请参见修改站点地图布局）。

若要查看站点地图，请执行以下操作：

  1. 若要显示站点地图，请在“文件”面板（“窗口”>“文件”）中，执行以下操作之一：
    • 在折叠的“文件”面板中，选择“站点视图”弹出式菜单中的“地图视图”。

    • 在展开的“文件”面板中，单击工具栏中的“站点地图”按钮，然后选择“仅地图”或“地图和文件”。

      选择“仅地图”以查看不包含本地文件结构的站点地图，或者选择“地图和文件”以查看包含本地文件结构的站点地图。

      注意

      如果尚未定义主页或者 Dreamweaver 在当前站点中找不到要用作主页的 index.html 或 index.htm 页面，Dreamweaver 将提示您选择一个主页。

    “文件”面板显示的站点地图中将显示两个级别深度的站点结构。

    注意

    默认情况下，站点地图不显示隐藏文件和相关文件。有关更多信息，请参见显示和隐藏站点地图文件。
  2. 单击文件名旁的加号 (+) 和减号 (-) 可显示或隐藏链接在第二级之下的页面。
  3. 请注意站点地图中的颜色：
    • 以红色显示的文本指示断开的链接。
    • 以蓝色显示并标有地球图标的文本指示其他站点上的文件或特殊链接（如电子邮件或脚本链接）。
    • 绿色选中标记指示您已取出的文件。
    • 红色选中标记指示他人取出的文件。
    • 锁形图标指示只读 (Windows) 或锁定 (Macintosh) 的文件。

相关主题

  • 修改站点地图布局
  • 在站点地图中处理页
  • 显示和隐藏站点地图文件
  • 通过分支查看站点


修改站点地图布局

使用“站点地图布局”选项可自定义站点地图的外观。您可以更改主页、显示的列数、图标标签显示文件名还是显示页标题以及是否显示隐藏文件和相关文件。

若要修改站点地图布局，请执行以下操作：

  1. 执行以下操作之一，打开“站点定义”对话框：
    • 选择“站点”>“管理站点”。
    • 在“文件”面板中，从弹出菜单中选择“管理站点”（当前站点、服务器或驱动器显示在该菜单中）。

    出现“管理站点”对话框。

  2. 单击“编辑”。

    出现“站点定义”对话框。

  3. 在左侧的“类别”列表中选择“站点地图布局”。

    “站点定义”对话框显示了“站点地图布局”选项。

  4. 按需要进行更改。

    有关更多信息，请参见设置“站点地图布局”类别选项。

  5. 单击“确定”关闭“站点定义”对话框。
  6. 单击“完成”关闭“管理站点”对话框（如果它尚未关闭）。

相关主题

  • 查看站点地图
  • 在站点地图中处理页
  • 显示和隐藏站点地图文件
  • 保存站点地图


在站点地图中处理页

当您在站点地图中工作时，可以选择页、打开页进行编辑、向站点添加新页、创建文件之间的链接以及更改页标题。

若要在站点地图中选择多个页，请执行以下操作之一：

  • 按住 Shift 键单击以选择某一范围的相邻页。
  • 从视图的空白部分开始在一组文件周围拖动，以选择这些文件。
  • 按住 Ctrl 键单击 (Windows) 或按住 Command 键单击 (Macintosh)，以选择不相邻的页。

若要在站点地图中打开某页进行编辑，请执行以下操作之一：

  • 双击该文件。
  • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该文件，然后选择“打开”。

若要向站点添加现有文件，请执行以下操作之一：

  • 将文件从 Windows 资源管理器或 Macintosh Finder 中拖至站点地图中的一个文件。该页被添加到站点中，同时会在它和您拖至的文件之间创建一个链接。
  • 在站点地图中右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该文件，然后选择“链接到现存文件”，然后浏览到该文件。

若要创建新文件并在站点地图中添加链接，请执行以下操作：

  1. 在站点地图中选择一个文件。
  2. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“链接到新文件”。

    出现“链接到新文件”对话框。

  3. 输入该链接的名称、标题和文本。
  4. 单击“确定”。

    Dreamweaver 将该文件保存在与选定文件相同的文件夹中。如果向隐藏的分支目录添加一个新文件，则该新文件也会隐藏起来（请参见显示和隐藏站点地图文件）。

若要在站点地图中修改页的标题，请执行以下操作：

  1. 单击折叠的“文件”面板右上角的“选项”菜单，然后选择“文件”>“重命名”“查看”>“显示页面标题”，这样可以确保显示页面标题。

  2. 从站点地图中选择一个文件，然后执行以下操作之一：
    • 单击标题。当标题可以编辑时，输入新的标题。
    • 单击右上角的“选项”菜单，然后选择“文件”>“重命名”。
  3. 键入新名称后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    注意

    当您在“文件”面板中工作时，Dreamweaver 会自动更新指向名称已更改的文件的所有链接。

若要在站点地图中更改主页，请执行以下操作之一：

  • 在“文件”面板的“本地”视图中，选择一个文件；右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“设置为主页”。
  • 在“文件”面板中，从弹出菜单中选择“管理站点”（当前站点、服务器或驱动器显示在该菜单中），然后单击“编辑”。在“站点定义”对话框类别列表中选择“站点地图布局”。浏览到新主页，然后单击“确定”。

若要在进行更改后更新站点地图显示，请执行以下操作：

  1. 在站点地图中的任意位置单击，取消选定的文件。
  2. 单击“文件”面板工具栏中的“刷新”按钮。

相关主题

  • 查看站点地图
  • 修改站点地图布局
  • 保存站点地图


显示和隐藏站点地图文件

您可以修改站点地图的布局，以显示或隐藏隐藏文件和相关文件。当您需要强调关键主题或内容而隐藏不太重要的材料时，此功能非常有用。

若要使用站点地图隐藏文件，您必须将该文件标记为隐藏。当您隐藏某文件时，该文件的链接也会隐藏起来。当您显示标记为隐藏的文件时，它的图标和链接将显示在站点地图中，但名称以斜体显示。

注意

默认情况下，相关文件已经被隐藏。

若要在站点地图中将文件标记为隐藏，请执行以下操作：

  1. 在站点地图中选择一个或多个文件。
  2. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“显示/隐藏链接”。

若要在站点地图中取消文件的隐藏标记，请执行以下操作：

  1. 在站点地图中选择一个或多个文件。
  2. 执行下列操作之一：
    • 在站点地图中右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“显示/隐藏链接”。
    • 在折叠的“文件”面板（“窗口”>“文件”）中，单击右上角的“选项”菜单，然后选择“查看”>“显示标记为隐藏的文件”。
    • 在折叠的“文件”面板（“窗口”>“文件”）中，单击右上角的“选项”菜单，然后选择“查看”>“显示/隐藏链接”。

若要在站点地图中显示或隐藏标记为隐藏的文件，请执行以下操作：

  1. 在折叠的“文件”面板（“窗口”>“文件”）中，单击右上角的“选项”菜单。

  2. 执行下列操作之一：
    • 选择“查看”>“显示标记为隐藏的文件”。
    • 选择“查看”>“布局”以打开“站点定义”对话框，然后选择“显示标记为隐藏的文件”选项。

若要在站点地图中显示相关文件，请执行以下操作：

  1. 在折叠的“文件”面板（“窗口”>“文件”）中，单击右上角的“选项”菜单。
  2. 执行下列操作之一：
    • 选择“查看”>“显示相关文件”。
    • 选择“查看”>“布局”以打开“站点定义”对话框，然后选择“显示相关文件”选项。

相关主题

  • 查看站点地图
  • 修改站点地图布局
  • 在站点地图中处理页
  • 保存站点地图


通过分支查看站点

通过使某个分支成为站点地图的焦点，可以查看站点特定部分的详细信息。

若要查看站点地图中的另一分支，请执行以下操作：

  1. 选择您要查看的页。
  2. 执行下列操作之一：
    • 在站点地图中右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“作为根查看”。
    • 在折叠的“文件”面板（“窗口”>“文件”）中，单击右上角的“选项”菜单，然后选择“查看”>“作为根查看”。

站点地图在窗口中重新绘制，就象指定页位于站点的根目录一样。站点地图之上的“站点导航”文本框显示从主页到指定页的路径。通过一次单击选择路径中的任意项，从该级别开始查看站点地图。

若要展开和收缩站点地图中的分支，请执行以下操作：

  • 单击分支的加号 (+) 或减号 (-) 按钮。

相关主题

  • 查看站点地图
  • 修改站点地图布局
  • 在站点地图中处理页


保存站点地图

您可以将站点地图保存为图像，然后在图像编辑器中查看（或打印）该图像。

若要创建当前站点地图的图像文件，请执行以下操作：

  1. 在折叠的“文件”面板（“窗口”>“文件”）中，单击右上角的“选项”菜单，然后选择“文件”>“保存站点地图”。

    出现“保存站点地图”对话框。

  2. 在“文件名”文本框中输入一个名称。
  3. 在“文件类型”弹出菜单中，选择 .bmp 或 .png。
  4. 选择该文件的保存位置并输入图像的名称。
  5. 单击“保存”。

相关主题

  • 查看站点地图
  • 修改站点地图布局
  • 在站点地图中处理页


导入和导出站点

可以将站点导出为包含站点设置的 XML 文件，并在以后将该站点导入 Dreamweaver。这样，您就可以在各计算机和产品版本之间移动站点，或者与其他用户共享这些设置。

提示

最好定期导出您的站点，如果该站点出现意外，您还有它的备份副本。

若要导出站点，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 选择要导出的一个或多个站点，然后单击“导出”按钮。

    若要选择多个站点，请按住 Ctrl 键单击 (Windows) 或按住 Command 键单击 (Macintosh) 每个站点。若要选择某一范围的站点，请按住 Shift 键单击该范围中的第一个和最后一个站点。

  3. 对于要导出的每个站点，请浏览至要保存站点的位置，然后单击“保存”。

    如果导出为远端服务器指定用户名和密码的站点，则 Dreamweaver 会询问您是否要备份设置或是否要将您的设置与其他用户共享。如果要将您的设置与其他用户共享，则选择第二个选项并单击“确定”。Dreamweaver 不会保存不适用于其他用户的信息（如您的远端服务器登录信息和本地路径）。

    Dreamweaver 会在指定位置将每个站点保存为带 .ste 文件扩展名的 XML 文件。

  4. 单击“完成”关闭“管理站点”对话框。

若要导入站点，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 单击“导入”按钮。

    出现“导入站点”对话框。

  3. 浏览并选择要导入的一个或多个在具有 .ste 文件扩展名的文件中定义的站点。

    若要选择多个站点，请按住 Ctrl 键单击 (Windows) 或按住 Command 键单击 (Macintosh) 每个 .ste 文件。若要选择某一范围的站点，请按住 Shift 键单击该范围中的第一个和最后一个文件。

  4. 单击“打开”开始导入站点。

    Dreamweaver 导入该站点之后，站点名称会出现在“管理站点”对话框中。

  5. 单击“完成”关闭“管理站点”对话框。


从站点列表中删除 Dreamweaver 站点

如果您不再需要使用 Dreamweaver 中的某一站点，则可以从站点列表中将该站点删除。站点中的文件不会被删除。

注意

当从列表中删除站点后，有关该站点的所有设置信息将永久丢失。

若要从站点列表中删除站点，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 选择一个站点名称。
  3. 单击“删除”。

    出现一个对话框，要求您确认删除。

  4. 单击“是”从列表中删除站点，或单击“否”保留站点名称。

    如果单击“是”，该站点名称将从列表中消失。

  5. 单击“完成”关闭“管理站点”对话框。


存回和取出文件

如果您在协作环境中工作，则可以使用存回/取出系统存回和取出本地和远端服务器中的文件。

如果只有您一个人在远端服务器上工作，则可以使用“上传”和“获取”命令，而不用存回或取出文件（请参见从服务器获取文件和将文件上传到服务器）。

本节包含以下主题：

  • 设置存回/取出系统
  • 使用 WebDAV 存回和取出文件
  • 将文件存回远端文件夹和从远端文件夹中取出
  • 撤消文件取出

相关主题

  • 关于存回/取出系统


设置存回/取出系统

在使用存回/取出系统之前，必须先将本地站点与远端服务器相关联（请参见设置远端文件夹）。

若要设置存回/取出系统，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 选择一个站点，然后单击“编辑”。

    出现“站点定义”对话框。

  3. 从左侧的类别列表中选择“远程信息”。

    “站点定义”对话框显示远程信息选项。“存回/取出”部分出现在该对话框的底部。

  4. 选择“启用存回和取出”选项。

    将出现其他选项。

    注意

    如果您没有看到“存回/取出”选项，则说明没有设置远程服务器（请参见设置远端文件夹）。
  5. 完成“存回/取出”部分。

    有关更多信息，请参见设置“存回/取出”选项。

  6. 单击“确定”。

相关主题

  • 关于存回/取出系统
  • 使用 WebDAV 存回和取出文件
  • 将文件存回远端文件夹和从远端文件夹中取出
  • 撤消文件取出


使用 WebDAV 存回和取出文件

Dreamweaver 可以连接到使用 WebDAV（基于 Web 的分布式创作和版本控制）的服务器，WebDAV 是一组对 HTTP 协议的扩展，允许用户以协作方式编辑和管理远程 Web 服务器上的文件。有关更多信息，请参见 www.webdav.org。

若要在 Dreamweaver 中设置 WebDAV 访问，请执行以下操作：

  1. 如果尚未定义指定用于存储项目文件的本地文件夹的 Dreamweaver 站点，则请定义。

    有关更多信息，请参见设置本地文件夹。

  2. 选择“站点”>“管理站点”，然后在列表中双击您的站点。

    出现“站点定义”对话框。

  3. 如果“基本”选项卡已经选中，则单击“高级”选项卡。
  4. 单击“远程信息”类别，然后从“访问”弹出式菜单中选择“WebDAV”。

  5. 指定 Dreamweaver 应如何连接到 WebDAV 服务器。

    有关说明，请单击对话框中的“帮助”按钮。

  6. 选择“启用存回和取出”选项并输入以下信息：
    • 在“取出名称”文本框中，输入将您与其他小组成员区分开来的名称。
    • 在“电子邮件地址”文本框中，输入您的电子邮件地址。

    名称和电子邮件地址用于标识 WebDAV 服务器的所有权，并出于联系目的出现在“文件”面板中。

  7. 单击“确定”。

    Dreamweaver 会配置站点以进行 WebDAV 访问。

若要使用 WebDAV 存回和取出文件，请执行以下操作：

  • 使用存回和取出文件中介绍的标准存回和取出方法。

    对任何站点文件使用存回或取出命令时，Dreamweaver 都会使用 WebDAV 传输文件。


将文件存回远端文件夹和从远端文件夹中取出

设置完存回/取出系统（请参见设置存回/取出系统）后，可以使用“文件”面板或从“文档”窗口存回和取出远端服务器中的文件。

若要使用“文件”面板取出文件，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，选择要从远端服务器取出的文件。

    注意

    可以在“本地”或“远程”视图中选择文件，但不能在“测试服务器”视图中选择。

    红色选中标记指示该文件已由其他小组成员取出，锁形符号指示该文件为只读 (Windows) 或锁定 (Macintosh) 状态。

  2. 执行以下操作之一以取出文件：
    • 单击“文件”面板工具栏上的“取出”按钮。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后从上下文菜单中选择“取出”。

    出现“相关文件”对话框。

  3. 单击“是”将相关文件随选定文件一起下载，或者单击“否”禁止下载相关文件。

    注意

    在取出新文件时下载相关文件通常是一种不错的做法，但是如果本地磁盘上已经有最新版本的相关文件，则无需再次下载它们。

    一个绿色选中标记出现在本地文件图标的旁边，表示您已将其取出。

若要使用“文件”面板存回文件，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，选择取出的或新的文件。

    注意

    可以在“本地”或“远程”视图中选择文件，但不能在“测试服务器”视图中选择。
  2. 请执行以下操作之一以存回文件：
    • 单击“文件”面板工具栏上的“存回”按钮。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后从上下文菜单中选择“存回”。

    出现“相关文件”对话框。

  3. 单击“是”将相关文件随选定文件一起存回，或者单击“否”禁止存回相关文件。

    注意

    在存回新文件时上传相关文件通常是一种不错的做法，但是如果远端服务器上已经有最新版本的相关文件，则无需再次上传它们。

    一个锁形符号出现在本地文件图标的旁边，表示该文件现在为只读状态。

若要从“文档”窗口存回或取出打开的文件，请执行以下操作：

  1. 确保要存回或取出的文件在“文档”窗口中处于活动状态。

    注意

    您每次只能存回一个打开的文件。
  2. 执行下列操作之一：
    • 选择“站点”>“存回”或“站点”>“取出”。
    • 单击“文档”窗口工具栏中的“文件管理”图标，然后从弹出菜单中选择“存回”或“取出”。

      注意

      如果当前文件不属于“文件”面板中的当前站点，Dreamweaver 将尝试确定当前文件属于哪一个本地定义的站点。如果当前文件仅属于一个本地站点，则 Dreamweaver 将打开该站点，然后执行存回或取出操作。

如果您取出当前处于活动状态的文件，则新的取出版本会覆盖该文件的当前打开的版本。如果您存回当前处于活动状态的文件，则根据您设置的首选参数选项，该文件可能会在存回前自动保存（请参见设置“文件”面板的首选参数）。

相关主题

  • 关于存回/取出系统
  • 设置存回/取出系统
  • 撤消文件取出


撤消文件取出

如果您取出了一个文件，然后决定不对它进行编辑（或者决定放弃所做的更改），则可以撤消取出操作，文件会返回到原来的状态。

若要撤消文件取出，请执行以下操作之一：

  • 在“文档”窗口中打开文件，然后选择“站点”>“撤消取出”。
  • 在“文件”面板（“窗口”>“文件”）中，右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“撤消取出”。

    该文件的本地副本成为只读文件，您对它进行的任何更改都会丢失。

相关主题

  • 关于存回/取出系统
  • 设置存回/取出系统
  • 将文件存回远端文件夹和从远端文件夹中取出


从服务器获取文件和将文件上传到服务器

如果您在协作环境中工作，则可以使用存回/取出系统在本地和远端站点之间传输文件（请参见存回和取出文件）。但是，如果只有您一个人在远端站点上工作，则可以使用“获取”和“上传”命令传输文件，而不用存回或取出文件。

本节包含以下主题：

  • 从远程服务器获取文件
  • 将文件上传到远端服务器上
  • 管理文件传输


从远程服务器获取文件

使用“获取”命令可以将文件从远程站点复制到本地站点。您可以使用“文件”面板或“文档”窗口来获取文件。

Dreamweaver 在传输期间创建文件活动的日志。若要查看或保存此日志，请参见管理文件传输。

Dreamweaver 还会记录所有 FTP 文件传输活动。如果您使用 FTP 传输文件时出错，则可以借助于站点 FTP 日志来确定问题所在。

若要使用“文件”面板从远端服务器获取文件，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，选择要下载的文件。

    通常在“远程”视图中选择这些文件，但如果您愿意，也可以在“本地”视图中选择相应的文件。如果“远程”视图处于活动状态，则 Dreamweaver 会将选定的文件复制到本地站点；如果“本地”视图处于活动状态，则 Dreamweaver 会将选定的本地文件的远程版本复制到本地站点。

    注意

    若要仅获取那些远程版本比本地版本新的文件，请使用“同步”命令（请参见同步本地和远端站点上的文件）。
  2. 执行以下操作之一以获取文件：
    • 单击“文件”面板工具栏上的“获取”按钮。
    • 在“文件”面板中右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该文件，然后从上下文菜单中选择“获取”。

    出现“相关文件”对话框。

  3. 若要下载相关文件，请单击“是”；若要跳过这些文件，请单击“否”。

    注意

    如果已经有相关文件的本地副本，则单击“否”。

    Dreamweaver 将下载选定的文件，如下所示：

    • 如果您使用存回/取出系统，则获取文件操作将产生该文件的只读 本地副本；该文件仍将留在远端站点或测试服务器上，可供其他小组成员取出（请参见存回和取出文件）。
    • 如果您没有使用存回/取出系统，则获取文件操作将传输具有读写 特权的副本。

    注意

    如果您在协作环境中工作（即，其他人正在处理同一文件），则不要禁用“启用存回和取出”功能。如果其他人在该站点上使用了存回/取出系统，则您也应该使用该系统。

若要在任意时刻停止文件传输，请单击状态对话框中的“取消”按钮。传输可能不会立即停止。

若要使用“文档”窗口从远端服务器获取文件，请执行以下操作：

  1. 确保文档在“文档”窗口中处于活动状态。
  2. 执行以下操作之一以获取文件：
    • 选择“站点”>“获取”。
    • 单击“文档”窗口工具栏中的“文件管理”图标，然后从弹出菜单中选择“获取”。

      注意

      如果当前文件不属于“文件”面板中的当前站点，Dreamweaver 将尝试确定当前文件属于哪一个本地定义的站点。如果当前文件仅属于一个本地站点，则 Dreamweaver 将打开该站点，然后执行“获取”操作。

若要显示 FTP 日志，请执行以下操作：

  • 单击“文件”面板右上角的“选项”菜单，然后选择“查看”>“站点 FTP 日志”。

相关主题

  • 关于存回/取出系统
  • 关于后台文件传输
  • 将文件上传到远端服务器上


将文件上传到远端服务器上

您可以将文件从本地站点上传到远端站点，这通常不会更改文件的取出状态。

在两种常见的情况下，您可能会使用“上传”命令来代替“存回”：

  • 当您不在协作环境中并且没有使用存回/取出系统时。
  • 当您要将文件的当前版本上传到服务器上但要继续编辑它时。

    注意

    如果您上传先前在远端站点上不存在的文件并且正在使用存回/取出系统，则该文件将被复制到远端站点，然后再为您取出，使您可以继续编辑。

您可以使用“文件”面板或“文档”窗口来上传文件。Dreamweaver 在传输期间创建文件活动的日志。若要查看或保存此日志，请参见管理文件传输。

Dreamweaver 还会记录所有 FTP 文件传输活动。如果您使用 FTP 传输文件时出错，则可以借助于站点 FTP 日志来确定问题所在。

若要使用“文件”面板将文件上传到远程或测试服务器上，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，选择要上传的文件。

    通常在“本地”视图中选择这些文件，但如果愿意的话，可以在“远程”视图中选择相应的文件。

    注意

    若要仅上传那些本地版本比远程版本新的文件，请参见同步本地和远端站点上的文件。
  2. 执行以下操作之一以放置文件：
    • 单击“文件”面板工具栏上的“上传”按钮。
    • 在“文件”面板中右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该文件，然后从上下文菜单中选择“上传”。

    如果该文件尚未保存，则可能会出现一个对话框（取决于您在“首选参数”对话框的“站点”类别中设置的首选参数），让您在将文件上传到远端服务器之前进行保存。

  3. 如果出现对话框，请单击“是”保存该文件，或者单击“否”将以前保存的版本上传到远端服务器上。

    注意

    如果不保存文件，则自上次保存以后所做的所有更改都不会上传到远端服务器上。但是，该文件会继续保持打开状态，如果需要，在将文件上传到服务器上之后，您仍可以保存更改。

    出现“相关文件”对话框。

  4. 若要上传相关文件，请单击“是”；若要跳过这些文件，请单击“否”。

    注意

    如果远端站点上已经有相关文件的副本，则单击“否”。

若要停止文件传输，请单击状态对话框中的“取消”按钮。传输可能不会立即停止。

若要使用“文档”窗口将文件上传到远端服务器，请执行以下操作：

  1. 确保文档在“文档”窗口中处于活动状态。
  2. 执行以下操作之一以放置文件：
    • 选择“站点”>“上传”。
    • 单击“文档”窗口工具栏上的“文件管理”图标，然后从弹出菜单中选择“上传”。

      注意

      如果当前文件不属于“文件”面板中的当前站点，Dreamweaver 将尝试确定当前文件属于哪一个本地定义的站点。如果当前文件仅属于一个本地站点，则 Dreamweaver 将打开该站点，然后执行“上传”操作。

若要显示 FTP 日志，请执行以下操作：

  • 单击“文件”面板右上角的“选项”菜单，然后选择“查看”>“站点 FTP 日志”。

相关主题

  • 关于存回/取出系统
  • 从远程服务器获取文件
  • 关于后台文件传输
  • 管理文件传输


管理文件传输

可以查看文件传输操作的状态，以及被传输的文件和其结果（传输成功、跳过或传输失败）的列表。还可以保存文件活动日志。

注意

Dreamweaver 使您可以在将文件传输到服务器或从服务器传输文件时执行其他与服务器无关的活动。有关更多信息，请参见关于后台文件传输。

若要取消文件传输，请执行以下操作：

  • 单击“取消”按钮或关闭“后台文件活动”对话框。

若要在传输期间隐藏“后台文件活动”对话框，请执行以下操作：

  • 请单击“后台文件活动”对话框上的“隐藏”按钮。

若要查看最近文件传输的详细信息，请执行以下操作：

  1. 单击“文件”面板底部的“日志”按钮，打开“后台文件活动”对话框。
  2. 单击“详细信息”扩展箭头。

若要保存最近文件传输的日志，请执行以下操作：

  1. 单击“文件”面板底部的“日志”按钮，打开“后台文件活动”对话框。
  2. 单击“保存记录”按钮，将信息保存为文本文件。

可以在 Dreamweaver 或任何文本编辑器中打开日志文件来查看文件活动。

相关主题

  • 从服务器获取文件和将文件上传到服务器


同步本地和远端站点上的文件

当您在本地和远端站点上创建文件后，可以在这两种站点之间进行文件同步。

注意

如果远端服务设置为 FTP 服务器（而不是网络服务器），则 Dreamweaver 将通过 FTP 来同步文件。

在同步站点之前，您可以验证要上传、获取、删除或忽略哪些文件。Dreamweaver 还将在您完成同步后确认哪些文件进行了更新。

若要在不进行同步的情况下查看哪些文件在本地站点或远端站点上较新，请执行以下操作之一：

  • 在“文件”面板的右上角单击“选项”菜单，然后选择“编辑”>“选择较新的本地文件”或“选择较新的远端文件”。

  • 在“文件”面板中，右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“编辑”>“选择较新的本地文件”或“选择较新的远端文件”。

若要同步文件，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，从弹出式菜单（当前站点、服务器或驱动器显示在该菜单中）中选择一个站点。
  2. （可选）选择特定的文件或文件夹。

    如果要同步整个站点，请跳过此步骤。

  3. 单击“文件”面板右上角的“选项”菜单，然后选择“站点”>“同步”。

    出现“同步文件”对话框。

  4. 完成对话框。

    有关更多信息，请参见设置“同步文件”对话框选项。

  5. 单击“预览”按钮。

    Dreamweaver 会显示将要同步的文件，并使您可以在执行同步前更改对这些文件进行的动作（上传、获取、删除和忽略）。如果所有文件都已同步，则 Dreamweaver 会通知您不必进行同步。

    有关更多信息，请参见设置“同步文件”对话框选项。

相关主题

  • 将文件存回远端文件夹和从远端文件夹中取出
  • 从远程服务器获取文件
  • 将文件上传到远端服务器上
  • 比较文件的差别


标识和删除未使用的文件

可以标识和删除站点中其他文件不再使用的文件。

若要标识和删除未使用的文件，请执行以下操作：

  1. 选择“站点”>“检查站点内所有链接”。

    Dreamweaver 检查站点中的所有链接，并在“结果”面板中显示断开的链接。

  2. 从“链接检查器”面板上的弹出式菜单中选择“孤立的文件”。

    Dreamweaver 显示没有入站链接的所有文件。这意味着站点中没有链接到这些文件的文件。

  3. 选择要删除的文件，然后按 Delete (Windows) 键或 Command+Delete (Macintosh) 键。

    小心

    尽管站点中没有链接到这些文件的其他文件，但列出的某些文件可能链接到其他文件。删除文件要小心。

相关主题

  • 查找断开的、外部的和孤立的链接
  • 遮盖站点中的文件夹和文件


遮盖站点中的文件夹和文件

利用站点遮盖功能，您可以从“获取”或“上传”等站点范围操作中排除站点中的某些文件夹和文件类型。

本节包含以下主题：

  • 启用和禁用站点遮盖
  • 遮盖站点文件夹和取消遮盖站点文件夹
  • 遮盖特定文件类型和取消遮盖特定文件类型
  • 取消遮盖所有文件夹和文件

相关主题

  • 关于站点遮盖
  • 标识和删除未使用的文件


启用和禁用站点遮盖

默认情况下启用站点遮盖功能。您可以永久禁用遮盖功能，也可以为了对所有文件（包括遮盖的文件）执行某一操作而临时禁用遮盖功能。当禁用站点遮盖功能之后，所有遮盖文件都会取消遮盖。当再次启用站点遮盖功能时，所有先前遮盖的文件将恢复遮盖。

注意

您也可以使用“取消所有遮盖”选项来取消所有文件的遮盖，但这不会禁用遮盖；而且，若要重新遮盖所有先前被遮盖的文件夹和文件，只能逐个对各个文件夹和文件类型重新设置遮盖，没有其他方法。

若要启用或禁用站点遮盖功能，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，从弹出式菜单（当前站点、服务器或驱动器显示在该菜单中）中选择一个站点。
  2. 选择一个文件或文件夹。
  3. 右键单击 (Windows) 或按住 Control 建单击 (Macintosh)，然后执行以下操作之一：
    • 选择“启用/禁用遮盖”。
    • 选择“设置”，然后从“高级站点定义”对话框左侧的类别列表中选择“遮盖”。选择或取消选择“启用遮盖”，然后单击“确定”。

对该站点启用或禁用遮盖功能。

相关主题

  • 关于站点遮盖
  • 遮盖站点文件夹和取消遮盖站点文件夹
  • 遮盖特定文件类型和取消遮盖特定文件类型
  • 取消遮盖所有文件夹和文件


遮盖站点文件夹和取消遮盖站点文件夹

您可以遮盖特定文件夹，但不能遮盖所有文件夹或整个站点。当您遮盖特定文件夹时，可以同时遮盖多个文件夹。

若要遮盖站点中的特定文件夹或取消其遮盖，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，从弹出式菜单（当前站点、服务器或驱动器显示在该菜单中）中选择一个启用了站点遮盖功能的站点。
  2. 选择要遮盖或取消遮盖的文件夹。
  3. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后从上下文菜单中选择“遮盖”>“遮盖”或“遮盖”>“取消遮盖”。

一条穿过文件夹图标的红线将出现或消失，指示该文件夹已遮盖或取消遮盖。

注意

您可以对特定的遮盖文件夹执行操作，方法是在“文件”面板上选择该项，然后对它执行操作。直接对文件或文件夹执行的操作会取代遮盖设置。

相关主题

  • 关于站点遮盖
  • 启用和禁用站点遮盖
  • 遮盖特定文件类型和取消遮盖特定文件类型
  • 取消遮盖所有文件夹和文件


遮盖特定文件类型和取消遮盖特定文件类型

您可以遮盖指定的特定文件类型，以便 Dreamweaver 遮盖以指定形式结尾的所有文件。例如，您可以遮盖所有以 .txt 扩展名结尾的文件。您输入的文件类型不一定是文件扩展名；它们可以是任何形式的文件名结尾。

若要遮盖站点中的特定文件类型，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，从弹出式菜单（当前站点、服务器或驱动器显示在该菜单中）中选择一个启用了站点遮盖功能的站点。
  2. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh)，然后选择“设置”。

    “站点定义”对话框显示“遮盖”选项。

  3. 选择“遮盖文件名以如下内容结束的文件”复选框。
  4. 在文本框中输入要遮盖的文件类型。

    例如，您可以输入 .jpg 以遮盖站点中名称以 .jpg 结尾的所有文件。

    注意

    用一个空格分隔多个文件类型；不要使用逗号或分号。
  5. 单击“确定”。

一条红线将穿过受影响的文件，指示它们已被遮盖。

提示

某些软件会创建以特定后缀（如 .bak）结尾的备份文件。您可以遮盖这些文件。

注意

您可以对特定的遮盖文件夹执行操作，方法是在“文件”面板上选择该项，然后对它执行操作。直接对文件或文件夹执行的操作会取代遮盖设置。

若要取消站点中特定文件类型的遮盖，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，从弹出式菜单（当前站点、服务器或驱动器显示在该菜单中）中选择一个启用了站点遮盖功能的站点。
  2. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“遮盖”>“设置”。

    出现“高级站点定义”对话框。

  3. 执行下列操作之一：
    • 取消选择“遮盖具有以下扩展名的文件”复选框，以取消在文本框中列出的所有文件类型的遮盖。
    • 从文本框中删除特定文件类型，以取消这些文件类型的遮盖。
  4. 单击“确定”。

    红线从受影响的文件上消失，指示它们已取消遮盖。

相关主题

  • 关于站点遮盖
  • 启用和禁用站点遮盖
  • 遮盖站点文件夹和取消遮盖站点文件夹
  • 取消遮盖所有文件夹和文件


取消遮盖所有文件夹和文件

您可以同时取消站点中所有文件夹和文件的遮盖。此操作无法撤消；没有任何方法可以重新遮盖先前遮盖的所有项。您必须逐一重新遮盖这些项。

提示

如果要临时取消所有文件夹和文件的遮盖，然后重新遮盖这些项，请禁用站点遮盖功能（请参见启用和禁用站点遮盖）。

若要取消站点中所有文件夹和文件的遮盖，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）中，从弹出式菜单（当前站点、服务器或驱动器显示在该菜单中）中选择一个启用了站点遮盖功能的站点。
  2. 选择该站点中的任意文件或文件夹。
  3. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“遮盖”>“全部取消遮盖”。

    注意

    该步骤还会取消对“站点”>“遮盖”>“设置”中“遮盖具有以下扩展名的文件”复选框的选择。

穿过文件夹和文件图标的红线消失，指示站点中的所有文件和文件夹都已取消遮盖。

相关主题

  • 关于站点遮盖
  • 启用和禁用站点遮盖
  • 遮盖站点文件夹和取消遮盖站点文件夹
  • 遮盖特定文件类型和取消遮盖特定文件类型


在设计备注中存储文件信息

设计备注是与文件相关联的备注，但存储于独立的文件中。可以使用设计备注来记录与文档关联的其他文件信息，如图像源文件名称和文件状态说明。

本节包含以下主题：

  • 对站点启用和禁用设计备注
  • 建立设计备注与文件的关联
  • 使用设计备注

相关主题

  • 关于设计备注


对站点启用和禁用设计备注

您可以在“站点定义”对话框的“设计备注”类别中对站点启用和禁用设计备注。当启用设计备注后，如果需要，可以选择仅在本地使用它们。

若要对站点启用或禁用设计备注或者仅在本地使用设计备注，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 选择一个站点，然后单击“编辑”。

    出现“站点定义”对话框。

  3. 从左侧的“分类”列表中选择“设计备注”。

    “站点定义”对话框显示“设计备注”选项。

  4. 完成对话框。

    有关更多信息，请参见设置“设计备注”类别选项。

  5. 单击“确定”。

相关主题

  • 关于设计备注
  • 建立设计备注与文件的关联
  • 使用设计备注


建立设计备注与文件的关联

您可以为站点中的每一文档或模板创建设计备注文件。您还可以为文档中的 applet、ActiveX 控件、图像、Flash 内容、Shockwave 对象以及图像域创建设计备注。

注意

如果在模板文件中添加设计备注，用该模板创建的文档不会继承这些设计备注。

若要将设计备注添加到文档中，请执行以下操作：

  1. 执行下列操作之一：
    • 在“文档”窗口中打开文件，然后选择“文件”>“设计备注”。
    • 在“文件”面板中，右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该文件，然后选择“设计备注”。

      注意

      如果该文件驻留在远程站点上，则您必须首先取出或获取该文件，然后在本地文件夹中选择它（请参见将文件存回远端文件夹和从远端文件夹中取出或从服务器获取文件和将文件上传到服务器）。

    出现“设计备注”对话框。

  2. 完成对话框。

    有关更多信息，请参见设置“设计备注”对话框选项。

  3. 单击“确定”以保存备注。

    Dreamweaver 将您的备注保存到名为 _notes 的文件夹中，与当前文件处在相同的位置。文件名是文档的文件名加上 .mno 扩展名。

    例如，如果文件名是 index.html，则关联的设计备注文件名为 index.html.mno。

相关主题

  • 关于设计备注
  • 对站点启用和禁用设计备注
  • 使用设计备注


使用设计备注

将设计备注关联到文件（请参见建立设计备注与文件的关联）之后，您可以打开设计备注，更改它的状态或者删除它。

若要打开与文件关联的设计备注，请执行以下操作之一：

  • 在“文档”窗口中打开文件，然后选择“文件”>“设计备注”。
  • 在“文件”面板中，右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该文件，然后选择“设计备注”。
  • 在“文件”面板的“备注”列中，双击黄色的“设计备注”图标。

若要指定自定义设计备注状态，请执行以下操作：

  1. 打开文件或对象的设计备注（请参见前面的步骤）。
  2. 单击“所有信息”标签。
  3. 单击加号 (+) 按钮。
  4. 在“名称”字段中，输入 status 一词。
  5. 在“值”域中，输入状态。

    如果已存在状态值，则该值将被新状态值取代。

  6. 单击“基本信息”标签并记下在“状态”弹出菜单中显示的新状态值。

    注意

    状态菜单中一次只能有一个自定义值。如果再次执行此步骤，则 Dreamweaver 将用您输入的新状态值替代第一次输入的状态值。

若要从站点中删除未关联的设计备注，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 选择站点，然后单击“编辑”。

    出现“站点定义”对话框。

  3. 从左侧的“分类”列表中选择“设计备注”。
  4. 单击“清理”按钮。

    Dreamweaver 提示您确认它应删除任何不再与站点中的文件关联的设计备注。

    如果使用 Dreamweaver 删除具有关联的设计备注文件的文件，则 Dreamweaver 同时也删除设计备注文件；所以，通常只有当您在 Dreamweaver 外删除或重命名文件后，才会出现孤立的设计备注文件。

    注意

    如果在单击“清理”前取消对“维护设计备注”选项的选择，则 Dreamweaver 删除站点的所有设计备注文件。

相关主题

  • 关于设计备注
  • 对站点启用和禁用设计备注


测试站点

Dreamweaver 提供了多项功能以帮助您测试站点，其中包括预览页面和检查浏览器兼容性。还可以运行各种报告，如断开的链接的报告。

本节包含以下主题：

  • 站点测试指南
  • 使用报告测试站点


站点测试指南

在将站点上传到服务器并声明其可供浏览之前，建议您先在本地对其进行测试。（实际上，在站点建设过程中，建议您不断地对站点进行测试并解决所发现的问题，以便尽早发现问题，避免重复出错。）

应该确保页面在目标浏览器中如预期的那样显示和工作，而且没有断开的链接，页面下载也不占用太长时间。还可以通过运行站点报告测试整个站点并解决出现的问题。

下面的指南将帮助您为您站点的访问者提供愉快的访问经历：

  • 确保页面在目标浏览器中能够如预期的那样工作，并确保这些页面在其他浏览器中要么工作正常，要么“明确地拒绝工作”。

    页面在不支持样式、层、插件或 JavaScript 的浏览器中应清晰可读且功能正常（请参见检查浏览器的兼容性）。对于在较早版本的浏览器中根本无法运行的页面，应考虑使用“检查浏览器”行为，自动将访问者重定向到其他页面（请参见检查浏览器）。

  • 应尽可能多地在不同的浏览器和平台上预览页面。

    这使您有机会查看布局、颜色、字体大小和默认浏览器窗口大小等方面的区别，这些区别在目标浏览器检查中是无法预见的（请参见在浏览器中预览和测试页面）。

  • 检查站点是否有断开的链接，并修复断开的链接。

    由于其他站点也在重新设计、重新组织，所以您所链接的页面可能已被移动或删除。可运行链接检查报告对链接进行测试（请参见查找断开的、外部的和孤立的链接和修复断链接）。

  • 监测页面的文件大小以及下载这些页面所占用的时间（请参见设置下载时间和大小首选参数）。

    要知道对于由大型表格组成的页面，在某些浏览器中，在整张表完全载入之前，访问者将什么也看不到。应考虑将大型表格分为几部分；如果不可能这样做，请考虑将少量内容（例如欢迎辞或广告横幅）放在表格以外的页面顶部，这样用户可以在下载表格的同时查看这些内容。

  • 运行一些站点报告来测试并解决整个站点的问题。

    您可以检查整个站点是否存在问题，例如无标题文档、空标签以及冗余的嵌套标签等（请参见测试站点）。

  • 检查您的代码中是否存在标签或语法错误（请参见验证标签）。
  • 在完成对大部分站点的大部分发布以后，应继续对站点进行更新和维护。

    站点的发布（即激活站点）可以通过多种方式完成，而且是一个持续的过程。这一过程的一个重要部分是定义并实现一个版本控制系统，既可以使用 Dreamweaver 中所包含的工具，也可以使用外部的版本控制应用程序。

  • 使用 Macromedia Web 站点上的 Dreamweaver 论坛，网址为 www.macromedia.com/go/dreamweaver_newsgroup。

    这些论坛是很好的资源，可以获取有关各种浏览器、平台等的信息。您还可以与其他 Dreamweaver 用户讨论技术问题并共享有用的技巧。


使用报告测试站点

您可以对当前文档、选定的文件或整个站点的工作流程或 HTML 属性（包括辅助功能）运行站点报告。

工作流程报告可以改进 Web 小组中各成员之间的协作。您可以运行工作流程报告，这些报告显示谁取出了某个文件，哪些文件具有与之关联的设计备注以及最近修改了哪些文件。您可以通过指定名称/值参数来进一步完善设计备注报告。

注意

您必须定义远端站点连接才能运行工作流程报告。若要定义远程站点，请参见设置远端文件夹。

HTML 报告使您可为对多个 HTML 属性编辑和生成报告。您可以检查可合并的嵌套字体标签、辅助功能、遗漏的替换文本、冗余的嵌套标签、可删除的空标签和无标题文档。

运行报告后，可将报告保存为 XML 文件，然后将其导入模板实例、数据库或电子表格中，再将其打印出来或显示在 Web 站点上。

注意

还可以通过 Macromedia Dreamweaver Exchange Web 站点向 Dreamweaver 添加其他不同的报告类型（请参见添加功能扩展 Dreamweaver）。

若要使用“报告”命令检查站点中的链接，请参见查找断开的、外部的和孤立的链接。

若要运行报告以测试站点，请执行以下操作：

  1. 选择“站点”>“报告”。

    提示

    若要仅为站点运行辅助功能报告，可以选择“文件”>“检查页”>“检查辅助功能”，报告将出现在“结果”面板组的“站点报告”面板中。

    出现“报告”对话框。

  2. 选择要报告的类别和要运行的报告类型。

    有关更多信息，请参见设置“报告”对话框选项。

  3. 单击“运行”，创建报告。

    根据运行的报告的类型，可能会提示您保存文件、定义站点或选择文件夹（如果尚未执行这些操作）。

    结果列表出现在“站点报告”面板（在“结果”面板组中）中。

若要使用和保存报告，请执行以下操作：

  1. 运行报告（请参见前面的步骤）。
  2. 在“站点报告”面板中，执行以下任意操作以查看报告：
    • 单击要按其排序的列标题以对结果进行排序。

      您可以按文件名、行号或说明进行排序。您还可以运行若干不同的报告并让不同的报告保持打开状态。

    • 在报告中选择任意行，然后单击“站点报告”面板左侧的“更多信息”按钮以了解有关问题的说明。

      信息即会出现在“参考”面板中。

    • 双击报告中的任意行可以在“文档”窗口中查看相应的代码。

      注意

      如果您正在使用“设计”视图，则 Dreamweaver 将更改显示来拆分视图，从而以代码的形式显示报告的问题。
  3. 单击“保存报告”保存该报告。

    在保存报告时，您可以将其导入到现有模板文件中。然后您可以将该文件导入到数据库或电子表格中并进行打印，或者使用该文件在 Web 站点上显示报告。

    提示

    运行 HTML 报告后，使用“清理 HTML”命令更正报告列出的所有 HTML 错误（请参见清理代码）。

相关主题

  • 报告 Dreamweaver


参考资料

本节提供在本章中介绍的下列对话框的有关信息：

  • 设置“配置服务器”对话框选项
  • 设置用于 FTP 的“配置服务器”对话框选项
  • 设置用于 RDS 的“配置服务器”对话框选项
  • 使用“文件”面板
  • 设置“站点”首选参数选项
  • 设置“文件视图列”类别选项
  • 设置“选择最近修改的文件”对话框选项
  • 设置“站点地图布局”类别选项
  • 设置“存回/取出”选项
  • 设置“同步文件”对话框选项
  • 设置“设计备注”类别选项
  • 设置“设计备注”对话框选项
  • 设置“遮盖”类别选项
  • 设置“报告”对话框选项
  • 设置“最近修改”对话框选项
  • 设置“导出站点”对话框选项


设置“配置服务器”对话框选项

此对话框的作用是连接到远程服务器以编辑文件。您可以使用此对话框执行以下任务：

  • 设置用于 FTP 的“配置服务器”对话框选项
  • 设置用于 RDS 的“配置服务器”对话框选项

相关主题

  • 设置 Dreamweaver 在不定义站点的情况下工作


设置用于 FTP 的“配置服务器”对话框选项

此对话框的作用是使用 FTP 访问连接到远端服务器。

若要配置远端服务器以用于 FTP 访问，请执行以下操作：

  1. 在“描述”文本域中输入服务器连接的名称。

    此名称将显示在“文件”面板顶部的弹出菜单中。

  2. 从“访问类型”弹出菜单中选择“FTP”。
  3. 输入 Web 站点的文件上传到的 FTP 主机的主机名。

    FTP 主机是计算机系统的完整 Internet 名称，如 ftp.mindspring.com。请输入完整的主机名，不要带任何其他的文本。特别是不要在主机名前面添加协议名。

    注意

    如果不知道 FTP 主机，请与 ISP 联系。
  4. 输入您在远端站点上存储公共可见的文档的主机目录。
  5. 输入用来连接到 FTP 服务器的登录名和密码，然后单击“测试”以测试登录名和密码。
  6. 如果希望 Dreamweaver 保存您的密码，请选中“保存”复选框。

    如果不选中此复选框，Dreamweaver 将在您每次连接到远端服务器时都提示您输入密码。

  7. 如果防火墙配置要求使用被动式 FTP，请选中“使用被动式 FTP”复选框。

    “被动式 FTP”使您的本地软件能够建立 FTP 连接，而不是请求远端服务器来设置它。如果不能确定是否使用被动式 FTP，请询问系统管理员。

  8. 如果从防火墙后面连接到远程服务器，请选中“使用防火墙”复选框，然后单击“防火墙设置”以编辑防火墙主机或端口。

    有关更多信息，请参见设置“文件”面板的首选参数。

  9. 选择“使用安全 FTP (SFTP)”选项以使用 FTP 进行安全身份验证。

    SFTP 使用加密密钥和共用密钥保护到测试服务器的连接的安全。

    注意

    服务器必须正在运行 SFTP 服务器。
  10. 单击“确定”。

相关主题

  • 设置 Dreamweaver 在不定义站点的情况下工作


设置用于 RDS 的“配置服务器”对话框选项

此对话框的作用是使用 RDS 访问连接到远端服务器。

若要配置远端服务器以用于 RDS 访问，请执行以下操作：

  1. 在“描述”文本域中输入服务器的名称。

    此名称将显示在“文件”面板顶部的弹出菜单中。

  2. 从“访问类型”弹出菜单中选择“RDS”。
  3. 输入用户在浏览器中键入的 URL 以打开 Web 应用程序，但不要包括任何文件名。

    假设应用程序的 URL 是 www.macromedia.com/mycoolapp/start.jsp。您需要输入以下 URL 前缀：www.macromedia.com/mycoolapp/。

  4. 单击“设置”按钮完成访问信息。

    出现“配置 RDS 服务器”对话框。

  5. 完成此对话框设置，然后单击“确定”。

    有关更多信息，请参见设置 RDS 访问。

  6. 单击“确定”。

相关主题

  • 设置 Dreamweaver 在不定义站点的情况下工作


使用“文件”面板

“文件”面板使您能够查看文件和文件夹（无论这些文件和文件夹是否与 Dreamweaver 站点相关联），并能够执行标准文件维护操作，如打开和移动文件。

注意

在以前的 Dreamweaver 版本中，“文件”面板称为“站点”面板。

如有必要，您可以移动“文件”面板（请参见停靠和取消停靠面板和面板组），还可以设置“文件”面板的首选参数（请参见设置“文件”面板的首选参数）。

使用此面板可以执行以下任务：

  • 访问站点、服务器和本地驱动器
  • 查看文件和文件夹
  • 在“文件”面板中管理文件和文件夹
  • 使用站点的视觉地图

对于 Dreamweaver 站点，可以使用以下选项显示或传输文件：

注意

“站点文件”视图、“测试服务器”视图、“站点地图”视图和“同步”按钮仅出现在展开的“文件”面板上。

站点文件视图在“文件”面板的窗格中显示远程和本地站点的文件结构。（有一个首选参数设置确定哪一种站点出现在左窗格，哪一种站点出现在右窗格；请参见设置“文件”面板的首选参数。）“站点文件”视图是“文件”面板的默认视图。

测试服务器视图显示测试服务器和本地站点的目录结构。

站点地图视图根据文档相互链接的方式显示站点的图形地图。按下此按钮可从弹出菜单中选择“仅地图”或“地图和文件”。

当前的弹出式菜单列出您的 Dreamweaver 站点和您连接到的服务器，并提供对您的本地驱动器和桌面的访问途径。

连接/断开（FTP、RDS、WebDAV 协议和 Microsoft Visual SourceSafe）用于连接到远端站点或断开与远端站点的连接。默认情况下，如果 Dreamweaver 已空闲 30 分钟以上，则将断开与远端站点的连接（仅限 FTP）。若要更改时间限制，请选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)，然后从左侧的类别列表中选择“站点”。

刷新用于刷新本地和远程目录列表。如果您已取消选择“站点定义”对话框中的“自动刷新本地文件列表”或“自动刷新远端文件列表”（请参见设置远端文件夹），则可以使用此按钮手动刷新目录列表。

获取文件用于将选定文件从远端站点复制到本地站点（如果该文件有本地副本，则将其覆盖）。如果打开了“启用存回和取出”，则本地副本为只读，文件仍将留在远端站点上，可供其他小组成员取出。如果关闭了“启用存回和取出”，则获取文件将传输具有读写权限的副本。

Dreamweaver 所复制的文件是您在“文件”面板的活动窗格中选择的文件。如果“远程”窗格处于活动状态，则选定的远程或测试服务器文件将复制到本地站点；如果“本地”窗格处于活动状态，则 Dreamweaver 会将选定的本地文件的远程或测试服务器版本复制到本地站点。有关更多信息，请参见从远程服务器获取文件。

上传文件用于将选定的文件从本地站点复制到远端站点。

Dreamweaver 所复制的文件是您在“文件”面板的活动窗格中选择的文件。如果“本地”窗格处于活动状态，则选定的本地文件将复制到远端站点或测试服务器；如果“远程”窗格处于活动状态，则 Dreamweaver 会将选定的远端服务器文件的本地版本复制到远端站点。有关更多信息，请参见将文件上传到远端服务器上。

如果所上传的文件在远端站点上尚不存在，并且“启用存回和取出”已打开，则 Dreamweaver 会以“取出”状态将该文件添加到远端站点。如果要不以取出状态添加文件，则单击“存回文件”按钮。

取出文件用于将文件的副本从远端服务器传输到本地站点（如果该文件有本地副本，则将其覆盖），并且在服务器上将该文件标记为取出。如果对当前站点关闭了“站点定义”对话框中的“启用存回和取出”，则此选项不可用。有关更多信息，请参见将文件存回远端文件夹和从远端文件夹中取出。

存回文件用于将本地文件的副本传输到远端服务器，并且使该文件可供他人编辑。本地文件变为只读。如果对当前站点关闭了“站点定义”对话框中的“启用存回和取出”，则此选项不可用。有关更多信息，请参见将文件存回远端文件夹和从远端文件夹中取出。

同步可以同步本地和远程文件夹之间的文件。有关更多信息，请参见同步本地和远端站点上的文件。

“扩展/折叠”按钮可以展开或折叠“文件”面板，以显示一个或两个窗格。


设置“站点”首选参数选项

此对话框用于为“文件”面板设置站点首选参数。

若要为“文件”面板设置站点首选参数，请执行以下操作：

  1. 根据需要更改以下选项：

    总是显示指定始终显示哪个站点（远程或本地），以及本地和远端文件显示在哪个“文件”面板窗格（左窗格还是右窗格）中。

    默认情况下，本地站点始终显示在右侧。未被选择的那个窗格（默认情况下是左窗格）是可更改窗格：此窗格可以显示另一个站点（默认情况下是远端站点）的站点地图或文件。

    相关文件为浏览器加载 HTML 文件时传输它加载的相关文件（例如图像、外部样式表和在 HTML 文件中引用的其他文件）显示提示。默认情况下选择“获取/取出时提示”和“放置/存回时提示”。

    提示

    若要强制显示“包括相关文件”提示（即使已取消对这些选项的选择），请在选择“获取”、“上传”、“存回”或“取出”命令的同时按住 Alt 键 (Windows) 或 Option 键 (Macintosh)。

    FTP 连接确定在闲置时间超出指定分钟数后，是否终止与远端站点的连接。

    FTP 超时指定 Dreamweaver 尝试与远端服务器进行连接所用的秒数。

    如果在指定时间长度之后没有响应，则 Dreamweaver 显示一个警告对话框，提示您注意这一情况。

    FTP 传输选项确定在文件传输过程中显示对话框时，如果经过指定的秒数用户没有响应，Dreamweaver 是否选择默认选项。

    防火墙主机指定您从防火墙后面与外部服务器连接时所使用的代理服务器的地址。

    如果您不在防火墙后，则此项留空不填。如果您位于防火墙后，则在“站点定义”对话框中选择“使用防火墙”选项。（请参见设置远端文件夹。）

    防火墙端口指定通过防火墙中的哪个端口与远端服务器相连。如果您不使用端口 21（FTP 的默认端口）进行连接，则需要在此处输入端口号。

    上传选项：上载前先保存文件”指示在将文件上载到远端站点前自动保存未保存的文件。

    管理站点打开“管理站点”对话框，您可以在此对话框中编辑现有的站点或创建新站点。

  2. 单击“确定”。

相关主题

  • 设置“文件”面板的首选参数


设置“文件视图列”类别选项

此对话框用于在“文件”面板中对文件视图列进行更改。您可以更改列的顺序、添加新列或删除列。

若要更改列的顺序，请执行以下操作：

  • 选择列名称，然后单击向上箭头按钮或向下箭头按钮更改选定列的位置。

    注意

    您可以更改除“名称”列之外任何列的顺序。“名称”列始终是第一列。

若要添加新列，请执行以下操作：

  1. 单击加号 (+) 按钮。
  2. 在“列名称”文本框中，输入列的名称。
  3. 从“与设计备注关联”弹出菜单中选择一个值，或者键入您自己的值。

    必须将一个新列与设计备注关联，“文件”面板中才会有数据显示。

  4. 选择对齐选项以确定 Dreamweaver 在该列中对齐文本的方式。
  5. 选择或取消选择“显示”选项以显示或隐藏列。
  6. 选择“与该站点所有用户共享”选项与连接到该远端站点的所有用户共享该列。

若要删除添加的列，请执行以下操作：

  • 选择要删除的列，然后单击减号 (-) 按钮。

    注意

    该列将立即被删除，且不经确认，因此在单击减号 (-) 按钮前，请务必弄清是否确实要删除该列。

相关主题

  • 对在展开的“文件”面板中显示的文件和文件夹详细信息进行自定义


设置“选择最近修改的文件”对话框选项

此对话框用于设置选项，以选择站点中最近修改的文件，这样您就可以将这些文件上传到服务器。

若要设置选项以选择最近修改的文件，请执行以下操作：

  1. 执行以下操作之一为报告指定搜索日期：
    • 要报告最近几天修改的所有文件，请选择“最近几天内创建或修改的文件”单选按钮，然后在文本框中输入一个数字。
    • 要报告特定时间段内修改的所有文件，请单击“特定时间段内创建或修改的文件”单选按钮，然后指定一个日期范围。
  2. （可选）在“修改者”文本框中输入用户名，将搜索限制到指定日期范围内由特定用户修改的文件。

    注意

    此选项仅适用于对 Contribute 站点的报告。
  3. 单击“确定”。

Dreamweaver 在“文件”面板中高亮显示文件。

相关主题

  • 在 Dreamweaver 站点中查找文件


设置“站点地图布局”类别选项

此对话框用于自定义站点地图的外观。

若要自定义站点地图的外观，请执行以下操作：

  1. 在“主页”文本框中，输入指向站点主页的文件路径或单击文件夹图标浏览到该文件。

    主页必须位于本地站点上。如果未指定主页，或者如果 Dreamweaver 在根目录下找不到名为 index.html 或 index.htm 的文件，则当您打开站点地图时，Dreamweaver 会提示您选择主页。

  2. 从“列”选项中选择：
    • 在“列数”文本框中，键入一个数字以设置在站点地图窗口中每行要显示的页数。
    • 在“列宽”文本框中，键入一个数字以设置站点地图列的宽度（以像素为单位）。
  3. 在“图标标签”下，选择在站点地图中与文档图标一起显示的名称表示为文件名还是页标题。
  4. 在“选项”下，选择要在站点地图中显示的文件：
    • 选择“显示标记为隐藏的文件”在站点地图中显示您已标记为隐藏的 HTML 文件。

      如果隐藏了某页，则其名称和链接以斜体显示。有关隐藏文件的信息，请参见显示和隐藏站点地图文件。

    • 选择“显示相关文件”显示该站点层次结构中的所有相关文件。

      相关文件是在浏览器加载主页时加载的图像或其他非 HTML 内容。

相关主题

  • 修改站点地图布局


设置“存回/取出”选项

“存回/取出”类别用于设置文件“存回/取出”选项。

若要设置文件“存回/取出”的选项，请执行以下操作：

  1. 如果您在小组环境中工作（或独自工作但使用几台不同的计算机），则选择“启用存回和取出”选项。

    该选项有助于让其他人知道您已取出文件进行编辑，或者提醒您自己可能将文件的最新版本留在了另一台计算机上。

    注意

    如果您的远程访问选项是“本地/网络”、“Microsoft Visual SourceSafe”或“WebDAV”，则“启用存回和取出”选项是唯一的“存回/取出”选项。此部分中的其余选项只适用于 FTP 访问。
  2. 如果要在“文件”面板中双击打开文件时自动取出这些文件，请选择“打开时取出文件”选项。

    注意

    即使选择了该选项，使用“文件”>“打开”这种方法打开文件也不会取出该文件。
  3. 输入取出名称。

    取出名称显示在“文件”面板中已取出文件的旁边；这使小组成员在他们需要的文件已被取出时可以和相关的人员联系。

    如果您在几台不同的计算机上独自工作，请在每台计算机上使用不同的取出名称（如 AmyR-HomeMac 和 AmyR-OfficePC），这样一来，当您忘记存回文件时，就可以知道文件最新版本的位置。

  4. 输入电子邮件地址。

    如果您取出文件时输入电子邮件地址，您的名称会以链接（蓝色并且带下划线）形式出现在“文件”面板中的该文件旁边。如果某个小组成员单击该链接，则其默认电子邮件程序将打开一个新邮件，该邮件使用该用户的电子邮件地址以及与该文件和站点名称对应的主题。

相关主题

  • 设置存回/取出系统


设置“同步文件”对话框选项

此对话框用于设置进行文件同步的选项。

若要设置同步文件的选项，请执行以下操作：

  1. 在“同步”弹出菜单中，选择以下选项之一：
    • 若要同步整个站点，请选择“整个‘站点名称’站点”。
    • 若要只同步选定的文件，请选择“仅限选定的本地文件”（如果您最近一次的选择是在“文件”面板的“远程”视图中进行的，请选择“仅限选定的远端文件”）。
  2. 选择复制文件的方向：

    放置更新的文件到远程上传在远端服务器上不存在的或自从上次上传以来已更改的所有本地文件。

    从远程获得更新的文件下载本地不存在的或自从上次下载以来已更改的所有远端文件。

    获得和放置更新的文件将所有文件的最新版本放置在本地和远端站点上。

  3. 选择是否在目的地站点上删除在原始站点上没有副本的文件。（在“方向”弹出式菜单中选择了“获取和上传”时该选项不可用。）

    如果选择“放置更新的文件到远程”并选择“删除”选项，则 Dreamweaver 将删除远端站点中没有相应本地文件的所有文件。如果选择“从远程获得更新文件”，则 Dreamweaver 将删除本地站点中没有相应远端文件的所有文件。

  4. 单击“预览”。

    在同步文件之前，必须预览 Dreamweaver 完成此任务将执行的操作。

    如果每个选定文件的最新版本都已位于本地和远端站点并且不需要删除任何文件，则将显示一个警告，通知您不需要进行任何同步。否则，将显示“同步”对话框。有关更多信息，请参见设置“同步”对话框选项。

相关主题

  • 同步本地和远端站点上的文件


设置“同步”对话框选项

该对话框用于预览 Dreamweaver 同步文件时将执行的操作，并可根据需要更改一个或多个这些操作。

若要更改同步文件所执行的操作，请执行以下操作：

  1. 验证对每个文件将要执行的操作。
  2. 若要更改特定文件的动作，请选择该文件，然后单击“预览”窗口底部的动作图标之一。

    如果操作图标呈灰色，则无法执行该操作。

    只有当您在 Dreamweaver 中安装并指定了文件比较工具时，“比较”操作才可用。有关更多信息，请参见比较文件的差别。

    使用“将所选文件标记为已同步”按钮可以告诉 Dreamweaver 所选择的一个或多个文件已同步。

  3. 单击“确定”同步文件。

可以查看同步的详细信息或将同步的详细信息保存到本地文件中。有关更多信息，请参见管理文件传输。

相关主题

  • 同步本地和远端站点上的文件


设置“设计备注”类别选项

此对话框用于启用或禁用站点的设计备注。

若要启用设计备注，请执行以下操作：

  1. 选择“维护设计备注”。
  2. 选择“上传并共享设计备注”将与站点关联的设计备注与其余的文档一起上传。

    如果选择该选项，则您可以和小组的其余成员共享设计备注。在您放置或获取某个文件时，Dreamweaver 自动放置或获取关联的设计备注文件。

    如果未选择此选项，则 Dreamweaver 在本地维护设计备注，但不将这些备注与您的文件一起上传。如果您独自在站点上工作，则可以取消对该选项的选择来提供文件传输的性能。

  3. 单击“确定”。

若要禁用设计备注，请执行以下操作：

  1. 取消对“维护设计备注”的选择。
  2. 单击“清理”，如果要 Dreamweaver 删除站点的所有本地设计备注文件，请单击“是”。
  3. 单击“确定”。

    出现一个对话框，询问您是否要删除现有的设计备注文件。

  4. 单击“是”将删除设计备注文件，或单击“否”将这些备注文件保留在原处。
  5. 单击“确定”关闭“站点定义”对话框。

若要仅在本地使用设计备注，请执行以下操作：

  • 取消对“上传并共享”的选择。

当您存回/放置文件时，不会将设计备注传输到远端站点。您将仍能够从本地为站点添加和修改设计备注。

相关主题

  • 在设计备注中存储文件信息
  • 建立设计备注与文件的关联


设置“设计备注”对话框选项

此对话框用于向文件添加设计备注。

若要将设计备注添加到文件中，请执行以下操作：

  1. 在“基本信息”选项卡中，从“状态”弹出菜单中选择文档的状态。
  2. 单击日期图标（在“备注”文本框的上方）在您的备注中插入当前本地日期。
  3. 在“备注”文本框中键入注释。
  4. 选择“文件打开时显示”在每次打开文件时显示设计备注文件。
  5. 在“所有信息”选项卡中，单击加号 (+) 按钮可以添加新的键/值对；选择一个键/值对并单击减号 (-) 按钮可以将其删除。

    例如，您可以将一个键命名为 Author（在“名称”文本框中），并将值定义为 Heidi（在“值”文本框中）。

  6. 单击“确定”。

相关主题

  • 在设计备注中存储文件信息
  • 建立设计备注与文件的关联


设置“遮盖”类别选项

此对话框用于启用或禁用遮盖以及遮盖特定的文件类型。

若要设置遮盖选项，请执行以下操作：

  1. 选择或取消选择“启用遮盖”复选框以启用或禁用遮盖。
  2. 选择或取消选择“遮盖具有以下扩展名的文件”复选框以启用或禁用对特定文件类型的遮盖。
  3. 在文本框中输入或删除要遮盖或取消遮盖的文件的后缀。
  4. 单击“确定”。

相关主题

  • 启用和禁用站点遮盖
  • 遮盖特定文件类型和取消遮盖特定文件类型


设置“报告”对话框选项

此对话框用于对文档或站点运行报告。您可以运行报告来改进工作流程、测试站点以及检查辅助功能。

若要对文档或站点运行报告，请执行以下操作：

  1. 从“报告在”弹出菜单中选择要报告的内容。

    注意

    只有在“文件”面板中已经有选定文件的情况下，才能运行“站点中的已选文件”报告。
  2. 如果要在“工作流程”部分中运行报告，可以选择以下任何报告：

    取出者创建一个报告，列出某特定小组成员取出的所有文档。

    设计备注创建一个报告，列出选定文档或站点的所有设计备注。

    最近修改创建一个报告，列出在指定时间段内发生更改的文件。

  3. 如果要在“HTML”部分中运行报告，可以选择以下任何报告：

    可合并嵌套字体标签创建一个报告，列出所有可以为清理代码而合并的嵌套字体标签。

    例如，将报告 <font color="#FF0000"><font size="4">STOP!</font></font>。

    没有替换文本会创建一个报告，列出所有没有替换文本的 img 标签。

    替换文本在纯文本浏览器或设为手动下载图像的浏览器中，替代图像出现在应显示图像的位置。屏幕阅读器读取替换文本，而且有些浏览器可在用户鼠标滑过图像时显示替换文本。

    辅助功能创建一个报告，详细列出您的内容与 1998 年康复法案的第 508 号辅助功能准则之间的冲突。

    多余的嵌套标签创建一个报告，详细列出应该清理的嵌套标签。

    例如，将报告 <i> The rain <i> in</i> Spain stays mainly in the plain</i>。

    可移除的空标签创建一个报告，详细列出所有可以为清理 HTML 代码而移除的空标签。

    例如，可能在“代码”视图中已删除了某项或图像，却留下了应用于该项的标签。

    无标题文档创建一个报告，列出在选定参数中找到的所有无标题的文档。Dreamweaver 报告所有具有默认标题、重复标题或缺少标题标签的文档。

  4. 如果您选择了工作流程报告，请单击“报告设置”按钮。否则，跳过这一步。

    注意

    如果选择不止一个工作流程报告，则对每个报告，都需要单击“报告设置”按钮进行设置。选择报告，单击“报告设置”，输入设置；然后对每个工作流程报告重复该过程。
    • 对于“取出者”，请输入小组成员的名称，然后单击“确定”，返回到“报告”对话框。
    • 对于“设计备注”，请输入一对或多对名称和值，然后从相应的弹出菜单中选择对比值。单击“确定”，返回到“报告”对话框。
    • 有关“最近修改”报告，请参见设置“最近修改”对话框选项。
  5. 单击“运行”以创建报告。

    根据运行的报告的类型，可能会提示您保存文件、定义站点或选择文件夹（如果尚未执行这些操作）。

相关主题

  • 测试站点


设置“最近修改”对话框选项

此对话框用于为关于站点中最近修改文件的报告设置选项，这样您便可以将这些文件上传到服务器。

若要设置最近修改的文件报告的选项，请执行以下操作：

  1. 执行以下操作之一为报告指定搜索日期：
    • 要报告最近几天修改的所有文件，请选择“最近几天内创建或修改的文件”单选按钮，然后在文本框中输入一个数字。
    • 要报告特定时间段内修改的所有文件，请单击“特定时间段内创建或修改的文件”单选按钮，然后指定一个日期范围。
  2. （可选）在“修改者”文本框中输入用户名，将搜索限制到指定日期范围内由特定用户修改的文件。

    注意

    此选项仅适用于对 Contribute 站点的报告。
  3. 如果需要，可以选择一个单选按钮，以指示您要在何处查看报告中列出的文件：

    本地计算机，如果站点中含有静态页。

    测试服务器，如果站点中含有动态页。

    注意

    此选项假定您已在“站点定义”对话框 (XREF) 中定义了测试服务器。如果您没有定义测试服务器并输入该服务器的 URL 前缀，或者如果您正在为多个站点运行报告，则此选项将不可用。

    其他位置，如果您要在文本框中输入一个路径。

    注意

    如果您输入无效路径，Dreamweaver 会在生成报告时提醒您。
  4. 单击“确定”，返回到“报告”对话框。

相关主题

  • 设置“报告”对话框选项


设置“导出站点”对话框选项

此对话框在导出为远端服务器指定用户名和密码的站点时出现。

若要设置对话框的选项，请执行以下操作：

  • 如果要备份站点设置，请选择第一个选项并单击“确定”。

    Dreamweaver 会保存远端服务器登录信息（如用户名和密码）以及本地路径信息。

  • 如果要将您的设置与其他用户共享，则选择第二个选项并单击“确定”。

    Dreamweaver 不会保存不适用于其他用户的信息（如您的远端服务器登录信息和本地路径）。

Dreamweaver 会将站点保存为具有 STE 文件扩展名的 XML 文件。

相关主题

  • 导入和导出站点


管理站点资源和库

随着 Web 站点开发的进行，您积累的资源会越来越多。在某些情况下，您可能在多个站点上使用同一资源，或者可能在所有站点上使用一组您特别喜欢的资源。您可以使用 Macromedia Dreamweaver 8 来管理站点资源。您可以轻松地跟踪和预览已存储在站点中的多种资源，如图像、影片、颜色、脚本和链接。您也可以将某种资源直接拖至当前文档以将其插入到某一页中。

Dreamweaver 还可以访问两种特殊类型的资源，即库和模板。库项目和模板是链接资源：编辑库项目或模板将更新已应用这些资源的所有文档。库项目用于个别设计元素，如站点的版权信息或徽标。模板使您可以控制更大的设计区域。（有关更多信息，请参见管理模板。）

本章包含下列主题：

关于库项目

使用资源

创建和管理喜爱的资源的列表

使用库项目


关于库项目

库是一种特殊的 Dreamweaver 文件，其中包含您已创建以便放在 Web 页上的单独的资源 或资源副本的集合。库里的这些资源称为库项目。每当更改某个库项目的内容时，可以更新所有使用该项目的页面。可以在库中存储各种各样的页面元素，如图像、表格、声音和 Flash 文件。

这里有一个如何使用库项目的示例：假定您正在为某公司建立一个大型站点。公司想让其广告语出现在站点的每个页面上，但是销售部门还没有最后确定广告语的文字。如果创建一个包含该广告语的库项目并在每个页面上使用，那么当销售部门提供该广告语的最终版本时，您可以更改该库项目并自动更新每一个使用它的页面。

Dreamweaver 将库项目存储在每个站点的本地根文件夹内的 Library 文件夹中。每个站点都有自己的库。

注意

如果库项目中包含链接，链接可能无法在新站点中工作。此外，库项目中的图像不会被复制到新站点中。

使用库项目时，Dreamweaver 不是在 Web 页中插入库项目，而是插入一个指向库项目的链接。即，Dreamweaver 向文档中插入该项目的 HTML 源代码副本，并添加一个包含对原始外部项目的引用的 HTML 注释。

对外部库项目的引用使您可以一次更新整个站点上的内容，方法是更改该库项目，然后使用“修改”>“库”子菜单中的更新命令。例如，如果需要更改某些文本或者图像，则更新库项目时将自动更新任何包含插入的库项目的页面中该库的实例。

当您创建一个库项目，并且它包括一个附有 Dreamweaver 行为的元素时，Dreamweaver 会将该元素及其事件处理程序（用于指定哪个事件触发动作，如 onClick、onLoad 或 onMouseOver，以及事件发生时调用哪个动作的属性）复制到库项目文件。Dreamweaver 不会将关联的 JavaScript 函数复制到库项目中。相反，当向文档中插入库项目时，Dreamweaver 将自动向该文档的 head 部分插入适当的 JavaScript 函数（如果此处尚无这些函数）。

注意

如果手工编写 JavaScript 代码（也就是说，如果不使用 Dreamweaver 行为进行创建），并且如果使用“调用 JavaScript”脚本执行代码，则可以使代码成为库项目的一部分。如果不使用 Dreamweaver 行为来执行代码，将不会把代码保留为库项目的一部分。

对于编辑库项目中的行为，有一些特殊的要求（请参见编辑库项目中的行为）。库项目不能包含样式表，因为这些元素的代码属于 head 部分。


相关主题

  • 使用库项目


使用资源

资源包括存储在站点中的各种元素，如图像或影片文件。

可以从各种来源获取资源。例如，您可能在应用程序（如 Macromedia Fireworks 或 Macromedia Flash）中创建资源，从同事那里接收资源，从剪辑作品 CD 或图片 Web 站点中复制资源。

本节包含以下主题：

  • 在“资源”面板中查看资源
  • 刷新“资源”面板
  • 将资源添加到文档
  • 使用“资源”面板将颜色应用于文本
  • 使用“资源”面板将 URL 应用于图像或文本
  • 选择和编辑资源
  • 在另外的站点中重新使用资源

相关主题

  • 创建和管理喜爱的资源的列表
  • 使用库项目


在“资源”面板中查看资源

可以使用“资源”面板查看和管理当前站点中的资源。“资源”面板显示与“文档”窗口中的活动文档相关联的站点资源。

注意

必须首先定义一个本地站点，然后才能在“资源”面板中查看资源。有关设置站点的更多信息，请参见设置新的 Dreamweaver 站点。

“资源”面板提供两种视图：

“站点”列表显示您的站点的所有资源，包括在该站点的任何文档中使用的颜色和 URL。

“收藏”列表仅显示您明确选择的资源。

在这两个列表中，资源被分成多个类别（沿着“资源”面板的左侧排列）。“站点”列表和“收藏”列表都可用于除 模板和库项目之外的所有资源类别。

注意

大多数“资源”面板操作在“站点”列表和“收藏”列表中的工作方式相同。但是，有几个任务只能在“收藏”列表中执行（请参见创建和管理喜爱的资源的列表）。

默认情况下，给定类别中的资源按名称的字母顺序列出。您可以根据其它几种条件的任意一种列出资源或者更改列的大小。您可以预览某一类别中的资源，并更改预览区域的大小。

若要打开“资源”面板，请执行以下操作：

  • 选择“窗口”>“资源”。

    出现“资源”面板。默认情况下，“图像”类别处于选定状态。

若要查看“站点”列表，请执行以下操作：

  • 在“资源”面板（“窗口”>“资源”）中，选择位于面板顶部的“站点”选项。

    注意

    在“模板”和“库”类别（位于“资源”面板的左侧）中，“站点”和“收藏”选项不可用。

若要查看“收藏”列表，请执行以下操作：

  • 在“资源”面板（“窗口”>“资源”）中，选择位于面板顶部的“收藏”选项。

    “收藏”列表为空，直到您向其中显式添加资源。

    注意

    在“模板”和“库”类别（位于“资源”面板的左侧）中，“站点”和“收藏”选项不可用。

若要显示特定类别的资源，请执行以下操作：

  • 单击“资源”面板（“窗口”>“资源”）左侧相应的图标。

若要按不同顺序列出资源，请执行以下操作：

  • 单击某个列标题。

    例如，若要根据类型对图像列表进行排序（以便使所有 GIF 图像在一起，所有 JPEG 图像在一起，等等），请单击“类型”列标题。

若要更改列的宽度，请执行以下操作：

  • 拖动分隔两个列标题的线。

若要预览资源，请执行以下操作：

  • 在“资源”面板中选取资源。

    面板顶部的预览区域将显示该资源的可视化预览。

    例如，当您选择一个影片资源时，预览区域将显示一个图标。若要查看该影片，请单击预览区域右上角的“播放”按钮（绿色三角形）。

若要更改预览区域的大小，请执行以下操作：

  • 向上或向下拖动拆分条（在预览区域和资源列表之间）。

相关主题

  • 使用“资源”面板
  • 刷新“资源”面板
  • 将资源添加到文档
  • 选择和编辑资源


刷新“资源”面板

“资源”面板可能需要花几秒钟才能创建“站点”列表，因为它需要读取站点缓存以创建该列表。

某些更改不会立即出现在“资源”面板中：

  • 当您在站点中添加或删除资源时，所做的更改不会立即出现在“资源”面板中，直到您单击“刷新站点列表”按钮刷新“站点”列表为止。如果您在 Dreamweaver 外部添加或删除资源（例如，使用 Windows 资源管理器或 Finder），则必须重新生成站点缓存以更新“资源”面板。
  • 当您删除站点中特定颜色或 URL 的唯一实例时，或者当您保存一个包含尚未在站点中使用的颜色或 URL 的新文件时，所做更改在您刷新“站点”列表之后才会出现在“资源”面板中。

若要手动刷新“站点”列表，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，选择位于面板顶部的“站点”选项以查看“站点”列表。
  2. 单击“资源”面板底部的“刷新站点列表”按钮。 这是所描述的功能的图片。

    Dreamweaver 会在必要时创建站点缓存或更新站点，同时“资源”面板会进行更新，从而显示站点资源。

若要手动重新生成站点缓存并刷新“站点”列表，请执行以下操作：

  • 在“资源”面板（“窗口”>“资源”）中右键单击 (Windows) 或者按住 Command 键 (Macintosh) 单击“资源”列表，然后选择“刷新站点列表”。

相关主题

  • 选择和编辑资源
  • 在另外的站点中重新使用资源


将资源添加到文档

可以将大多数类型的资源插入到文档中，方法是将它们拖动到“文档”窗口中的“代码”视图或“设计”视图，或者使用“插入”按钮。您可以插入颜色和 URL，也可以将它们应用于“设计”视图中的选定文本。（还可以将 URL 应用于“设计”视图中的其它元素，如图像。

若要将资源插入文档，请执行以下操作：

  1. 将插入点放置在“设计”视图中您希望资源出现的位置。
  2. 在“资源”面板（“窗口”>“资源”）中，在面板左侧选择要插入的资源类型的类别。

    注意

    选择除“模板”之外的任何类别。只能将模板应用于整个文档；不能将它插入文档中。有关模板的更多信息，请参见管理模板。
  3. 在面板顶部选择“站点”或“收藏”，然后选择要插入的资源。

    对于库项目而言，没有“站点”或“收藏”列表；如果插入的是库项目，则跳过此步骤。

  4. 执行下列操作之一：
    • 将资源从面板拖动到文档。

      可以将脚本拖动到“文档”窗口的文件头内容区域；如果该区域未显示，则选择“查看”>“文件头内容”。

    • 在面板中选择资源，然后单击面板的底部的“插入”。

    资源即被插入文档中。（如果资源为颜色，则该颜色将在插入点开始应用；也就是说，随后键入的内容将以该颜色显示。

相关主题

  • 使用“资源”面板将颜色应用于文本
  • 使用“资源”面板将 URL 应用于图像或文本
  • 选择和编辑资源
  • 在另外的站点中重新使用资源


使用“资源”面板将颜色应用于文本

“资源”面板中的颜色表示已应用于站点中各种元素的颜色，这些元素包括文本、表格边框和背景颜色等。可以使用“颜色”类别中的颜色样本将所选的颜色一致地应用于页面中的对象。

有关如何将颜色添加到“颜色”类别的信息，请参见在“收藏”列表中添加和删除资源。

若要更改文档中选定文本的颜色，请执行以下操作：

  1. 在文档中选择文本。
  2. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“颜色”类别。 这是所描述的功能的图片。
  3. 选择所需的颜色。
  4. 单击面板底部的“应用”按钮。

相关主题

  • 将资源添加到文档
  • 使用“资源”面板将 URL 应用于图像或文本
  • 选择和编辑资源
  • 在另外的站点中重新使用资源


使用“资源”面板将 URL 应用于图像或文本

您可以使用“资源”面板将所选的文本或图像做成一个活动链接。

若要将链接添加到文档中的选定内容，请执行以下操作：

  1. 选择要应用 URL 的文本或图像。
  2. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“URL”类别。 这是所描述的功能的图片。
  3. 选择所需的 URL。
  4. 执行下列操作之一：
    • 将 URL 从面板拖动到“设计”视图中的选定内容。
    • 选择 URL，然后单击“插入”按钮。

相关主题

  • 将资源添加到文档
  • 使用“资源”面板将颜色应用于文本
  • 选择和编辑资源
  • 在另外的站点中重新使用资源


选择和编辑资源

“资源”面板使您可以同时选择多个资源。它还提供了开始编辑资源的快速方法。

若要选择多个资源，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，选择其中一个资源。
  2. 以下列方法之一选择其它资源：
    • 按 Shift 键单击可选择一系列连续的资源。
    • 按住 Control 键 (Windows) 或 Command 键 (Macintosh) 并单击可以将个别资源添加到选定内容（不管该资源是否与现有的选定内容相邻）。按住 Control 键或 Command 键并单击选定的资源可取消选择该资源。

若要编辑资源，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，执行以下操作之一：
    • 双击资源。
    • 选择资源，然后单击面板底部的“编辑”按钮。 这是所描述的功能的图片。

    对于某些类型的资源（如图像），编辑资源时将启动一个外部编辑应用程序。对于颜色和 URL，编辑资源时只能在“收藏”列表中更改资源值。（您不能在“站点”列表中编辑颜色和 URL。）对于模板和库项目，编辑资源时您可以在 Dreamweaver 内部更改资源。

    注意

    如果没有为需要使用编辑器的资源打开外部编辑器，则选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)，选择“文件类型/编辑器”类别，并且确保已为该资源的文件类型定义了外部编辑器。（请参见为媒体文件启动外部编辑器。）
  2. 根据需要更改资源。
  3. 完成对资源的编辑后，执行下列操作之一：
    • 如果该资源是基于文件的资源（除颜色和 URL 以外的任何资源），则保存它（使用编辑该资源时所用的任何编辑器）并将它关闭。
    • 如果该资源是 URL，则在“编辑 URL”对话框中完成编辑后单击“确定”。
    • 如果该资源是颜色，则当您挑选颜色时 Dreamweaver 颜色选择器将自动退出。

      注意

      若要在不挑选颜色的情况下退出颜色选择器，请按 Escape 键。

相关主题

  • 在“资源”面板中查看资源
  • 刷新“资源”面板
  • 在另外的站点中重新使用资源


在另外的站点中重新使用资源

“资源”面板显示当前站点中的所有资源（属于可识别的类型）。）若要将当前站点中的资源用于另外的站点，您必须将该资源复制到另外的站点。可以一次复制一个单独的资源、一组单独的资源或整个收藏夹。

在向远程站点传输资源或从远程站点传输资源之前，可能需要在“文件”面板中定位与“资源”面板中的该资源相应的文件。

注意

“文件”面板可能与“资源”面板显示不同的站点。这是因为“资源”面板与活动文档相关联。

若要在“文件”面板中定位资源的文件，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，在面板左侧选择要查找的资源类型的类别。
  2. 在“资源”面板中右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 资源的名称或图标，然后从上下文菜单中选择“在站点定位”。

    注意

    “在站点定位”不能用于颜色和 URL，因为它们不与站点中的文件相对应。

    “文件”面板将打开，其中的资源文件处于选定状态。“在站点定位”命令定位与资源本身对应的文件；它不定位使用该资源的文件。

若要从“资源”面板的“站点”列表或“收藏”列表向另外的站点复制资源，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，在面板左侧选择要复制的资源类型的类别。
  2. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 要复制的资源，选择“复制到站点”，然后从子菜单中选择目标站点的名称。（子菜单列出已定义的所有站点。）

    注意

    在“收藏”列表中，除了可以复制单独的资源以外，还可以复制收藏夹。有关收藏夹的信息，请参见将资源归类到收藏夹中。

    资源被复制到指定的站点中与其在当前站点中所处位置相对应的位置。Dreamweaver 将根据需要在目标站点的层次结构中创建新文件夹。资源还被添加到指定站点的“收藏”列表中。

当在目标站点中打开文档时，“资源”面板将切换到该站点，并显示已复制的资源。

注意

如果所复制的资源是颜色或 URL，则该资源只会出现在另一个站点的“收藏”列表中，而不会出现在另一个站点的“站点”列表中。这是因为没有与颜色或 URL 相对应的文件，所以没有要复制到另一个站点中的文件。

相关主题

  • 在“资源”面板中查看资源
  • 刷新“资源”面板
  • 选择和编辑资源


创建和管理喜爱的资源的列表

因为“资源”面板的“站点”列表总是显示站点内的所有可识别资源，所以该列表对于某些大型站点来说可能会变得难以使用。您可以将常用的资源添加到“收藏”列表，也可以将相关的资源归成一类，给它们起别名以提醒您它们的用途，并方便地在“资源”面板中查找它们。

注意

“收藏”资源不是作为单独的文件存储在磁盘上的；它们是对“站点”列表中资源的引用。Dreamweaver 跟踪在“收藏”列表中显示“站点”列表中的哪些资源。

对于“收藏”列表和“站点”列表，“资源”面板的大多数操作都是相同的。但是，有几种任务只能在“收藏”列表中执行。

本节包含以下主题：

  • 在“收藏”列表中添加和删除资源
  • 为喜爱的资源创建别名
  • 将资源归类到收藏夹中


在“收藏”列表中添加和删除资源

有多种方法可在“资源”面板中向站点的“收藏”列表添加资源。

向“收藏”列表中添加颜色或 URL 需要额外的步骤。请注意，不能向“站点”列表中添加新颜色或 URL；“站点”列表只包含站点中已经在使用的资源。

注意

模板和库项目没有“收藏”列表。

若要向“收藏”列表中添加资源，请执行下列操作之一：

  • 在“资源”面板的“站点”列表中选择一种或多种资源，然后单击该面板底部的“添加到收藏”按钮。 这是所描述的功能的图片。
  • 在“资源”面板的“站点”列表中选择一个或多个资源，右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“添加到收藏”。
  • 在“文件”面板中选择一个或多个文件，右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“添加到收藏”。

    Dreamweaver 会忽略不符合“资源”面板中的类别的文件。

  • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)“文档”窗口的“设计”视图中的一个元素，然后选择上下文菜单命令将该元素添加到适当的“收藏”类别。

    请注意，文本的上下文菜单中包含“添加到颜色收藏”或“添加到 URL 收藏”，具体取决于文本是否附着了链接。同时还要注意，只有符合“资源”面板中类别之一的元素才可以添加到“收藏”列表中。

要将新颜色或 URL 添加到“收藏”列表，请执行以下操作：

  1. 这是所描述的功能的图片。 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“颜色”或“URL”类别。
  2. 选择位于面板顶部的“收藏”选项以显示“收藏”列表。
  3. 单击面板底部的“新建颜色”或“新建 URL”按钮。 这是所描述的功能的图片。
  4. 执行下列操作之一：
    • 使用颜色选择器选择一种颜色，然后根据需要为该颜色指定一个别名（请参见为喜爱的资源创建别名）。

      若要从颜色选择器中退出而不选择颜色，请按 Escape 键或单击颜色选择器顶部的灰色条。有关使用颜色选择器的更多信息，请参见使用颜色。

    • 在“将新 URL 添加到库”对话框中输入 URL 以及别名，然后单击“确定”。

若要从“收藏”列表中删除资源，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，选择位于面板顶部的“收藏”选项。
  2. 在“收藏”列表中选择一种或多种资源（或一个文件夹）。
  3. 单击面板底部的“从收藏中删除”按钮。 这是所描述的功能的图片。

    资源将被从“收藏”列表中删除，但它们仍出现在“站点”列表中。如果删除一个收藏夹，则该文件夹及其中的所有资源都被从“收藏”列表中删除。

相关主题

  • 在“资源”面板中查看资源
  • 为喜爱的资源创建别名
  • 将资源归类到收藏夹中


为喜爱的资源创建别名

可以给“收藏”列表中的资源起别名。然后将显示该资源的别名而不是其文件名或值。例如，如果某颜色名为 #999900，则可以使用一个更具描述性的别名，如 PageBackgroundColor 或 ImportantTextColor。

在“资源”面板中，您可以给“收藏”列表中的资源起别名。在“站点”列表中，资源用其真实的文件名（或者在资源为颜色和 URL 的情况下，用其值）列出。

若要给喜爱的资源起别名，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的包含您的资源的类别。
  2. 选择位于面板顶部的“收藏”选项以显示“收藏”列表。
  3. 执行下列操作之一：
    • 在“资源”面板中右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 资源的名称或图标，然后选择“编辑别名”。
    • 单击一次资源的名称，暂停，然后再次单击。
  4. 为该资源键入一个别名，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    该别名出现在“昵称”列中。

相关主题

  • 在“资源”面板中查看资源
  • 在“收藏”列表中添加和删除资源
  • 将资源归类到收藏夹中


将资源归类到收藏夹中

在“资源”面板中，您可以将资源归类到文件夹形式的“收藏”列表中。例如，如果有一组在电子商务站点的许多目录页面上都使用的图像，可以将它们归类到一起，放入一个称为 CatalogImages 的文件夹中。

注意

将资源放入收藏夹并不会更改资源文件在磁盘上的位置。

若要创建收藏夹，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，选择位于面板顶部的“收藏”选项。
  2. 单击面板底部的“新建收藏夹”按钮。 这是所描述的功能的图片。
  3. 为该文件夹键入一个名称，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
  4. 将资源拖动到文件夹中。

相关主题

  • 在“资源”面板中查看资源
  • 在“收藏”列表中添加和删除资源
  • 为喜爱的资源创建别名


使用库项目

库是一种用来存储要在整个 Web 站点上经常重复使用或更新的页面元素（如图像、文本和其他对象）的方法。这些元素称为库项目。

本节包含以下主题：

  • 创建库项目
  • 在文档中插入库项目
  • 编辑库项目
  • 设置库高亮显示参数
  • 编辑库项目属性
  • 使文档中的库项目可编辑
  • 编辑库项目中的行为

相关主题

  • 关于库项目


创建库项目

可以从文档 body 部分中的任意元素创建库项目，这些元素包括文本、表格、表单、Java applet、插件、ActiveX 元素、导航条和图像。

对于链接项（如图像），库只存储对该项的引用。原始文件必须保留在指定的位置，才能使库项目正确工作。

尽管如此，在库项目中存储图像还是很有用的；例如，可以在库项目中存储一个完整的 img 标签，它将使您可以方便地在整个站点中更改图像的 alt 文本，甚至更改它的 src 属性。（但是，请勿使用此方法更改图像的宽度和高度属性，除非还使用图像编码器更改图像的实际尺寸）。

若要基于选定内容创建库项目，请执行以下操作：

  1. 在“文档”窗口中，选择文档的一部分并另存为库项目。
  2. 执行下列操作之一：
    • 将选定内容拖到“资源”面板（“窗口”>“资源”）的“库”类别中。
    • 在“资源”面板（“窗口”>“资源”）中，单击“资源”面板的“库”类别底部的“新建库项目”按钮。 这是所描述的功能的图片。
    • 选择“修改”>“库”>“增加对象到库”。
  3. 为新的库项目键入一个名称，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    Dreamweaver 在站点本地根文件夹的 Library 文件夹中，将每个库项目都保存为一个单独的文件（文件扩展名为 .lbi）。

若要创建一个空白库项目，请执行以下操作：

  1. 确保没有在“文档”窗口中选择任何内容。

    如果选择了内容，则该内容将被放入新的库项目中。

  2. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“库”类别。 这是所描述的功能的图片。
  3. 单击“资源”面板底部的“新建库项目”按钮。 这是所描述的功能的图片。

    一个新的、无标题的库项目将被添加到面板中的列表。

  4. 在项目仍然处于选定状态时，为该项目输入一个名称，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

相关主题

  • 在文档中插入库项目
  • 编辑库项目
  • 设置库高亮显示参数


在文档中插入库项目

库项目 当向页面添加库项目时，将把实际内容以及对该库项目的引用一起插入到文档中。

若要在文档中插入库项目，请执行以下操作：

  1. 将插入点放在“文档”窗口中。
  2. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“库”类别。 这是所描述的功能的图片。
  3. 执行下列操作之一：
    • 将一个库项目从“资源”面板拖动到“文档”窗口中。

      提示

      若要在文档中插入库项目的内容而不包括对该项目的引用，请在从“资源”面板向外拖动该项目时按 Control 键 (Windows) 或 Option 键 (Macintosh)。如果用这种方法插入项目，则可以在文档中编辑该项目，但当更新使用该库项目的页面时，文档不会随之更新。
    • 选择一个库项目，然后单击面板底部的“插入”按钮。

相关主题

  • 创建库项目
  • 编辑库项目
  • 编辑库项目属性
  • 使文档中的库项目可编辑


编辑库项目

当编辑库项目时，可以更新使用该项目的所有文档。如果选择不更新，那么文档将保持与库项目的关联；可以在以后更新它们。

对库项目的其他种类的更改包括：重命名项目以断开其与文档或模板的连接，从站点的库中删除项目，以及重新创建丢失的库项目。

注意

编辑库项目时，“CSS 样式”面板不可用，因为库项目中只能包含 body 元素，而 CSS 样式表代码却插入到文档的 head 部分。“页面属性”对话框也不可用，因为库项目中不能包含 body 标签或其属性。

若要编辑库项目，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“库”类别。 这是所描述的功能的图片。
  2. 选择库项目。

    库项目的预览出现在“资源”面板的顶部。（预览时不能进行任何编辑操作。）

  3. 执行下列操作之一：
    • 单击面板底部的“编辑”按钮。 这是所描述的功能的图片。
    • 双击库项目。

    Dreamweaver 将打开一个用于编辑该库项目的新窗口。此窗口非常类似于“文档”窗口，但它的“设计”视图的背景为灰色，表示您正在编辑库项目而不是文档。

  4. 编辑库项目然后保存更改。
  5. 在出现的对话框中，选择是否更新本地站点上那些使用编辑过的库项目的文档：
    • 选择“更新”将更新本地站点中所有包含编辑过的库项目的文档。
    • 选择“不更新”将不更改任何文档，直到使用“修改”>“库”>“更新当前页”或“更新页面”才进行更改。

若要更改当前文档以使用所有库项目的当前版本，请执行以下操作：

  • 选择“修改”>“库”>“更新当前页”。

若要更新整个站点或所有使用特定库项目的文档，请执行以下操作：

  1. 选择“修改”>“库”>“更新页面”。

    即会出现“更新页面”对话框。

  2. 在“查看”弹出式菜单中执行下列操作之一：
    • 选择“整个站点”，然后从相邻的弹出式菜单中选择站点名称。

      这会更新所选站点中的所有页面，使其使用所有库项目的当前版本。

    • 选择“文件使用”，然后从相邻的弹出菜单中选择库项目名称。

      这会更新当前站点中所有使用所选库项目的页面。

  3. 请确保在“更新”选项中选择了“库项目”。

    提示

    若要同时更新模板，请确保“模板”也被选中。有关更多信息，请参见打开要编辑的模板。
  4. 单击“开始”。

    Dreamweaver 按照指示更新文件。如果选择了“显示记录”选项，Dreamweaver 将提供关于它试图更新的文件的信息，包括它们是否成功更新的信息。

若要重命名库项目，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“库”类别。
  2. 选择要重命名的库项目，暂停，然后再次单击。
  3. 当名称变为可编辑时，输入一个新名称。

    注意

    这种重命名方法与在 Windows 资源管理器 (Windows) 或 Finder (Macintosh) 中重命名文件的方法一样。对于 Windows 资源管理器和 Finder，请确保在前后两次单击之间稍作停顿。不要双击名称；那样将打开库项目进行编辑。
  4. 单击别处或者按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
  5. Dreamweaver 将询问是否要更新使用该项目的文档。
    • 若要更新站点中所有使用该项目的文档，请单击“更新”。
    • 若要避免更新任何使用该项目的文档，请单击“不更新”。

若要从库中删除库项目，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“库”类别。
  2. 选择要删除的库项目。
  3. 执行下列操作之一：
    • 单击面板底部的“删除”按钮，然后确认要删除该项目。
    • 按“删除”键，然后确认要删除该项目。

      小心

      请务必小心；删除一个库项目后，将无法使用“撤消”来找回它。但可以重新创建它，如下一过程所述。

    Dreamweaver 将从库中删除该库项目，但是不会更改任何使用该项目的文档的内容。

若要重新创建丢失或已删除的库项目，请执行以下操作：

  1. 在某个文档中选择该项目的一个实例。
  2. 在属性检查器（“窗口”>“属性”）中单击“重新创建”按钮。

相关主题

  • 创建库项目
  • 使文档中的库项目可编辑
  • 编辑库项目中的行为


设置库高亮显示参数

您可以通过设置“标记色彩”首选参数来自定义库项目的高亮颜色，并显示或隐藏库项目的高亮显示。

若要更改库项目的高亮颜色，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从左侧的类别列表中选择“标记色彩”类别。
  3. 单击“库项目”颜色框然后使用颜色选择器来选择一种高亮颜色（或在文本框中输入高亮颜色的十六进制值）。

    有关使用颜色选择器的信息，请参见使用颜色。

  4. 选择“显示”以在“文档”窗口中显示高亮库颜色。
  5. 单击“确定”。

若要在“文档”窗口中查看高亮颜色，请执行以下操作：

  • 选择“查看”>“可视化助理”>“不可见元素”。

    只有在启用了“查看”>“可视化助理”>“不可见元素”，并且在“标记色彩”首选参数中启用了适当选项时，高亮颜色才会出现在文档窗口中。

相关主题

  • 创建库项目
  • 编辑库项目
  • 编辑库项目属性


编辑库项目属性

您可以对库项目使用属性检查器以打开库项目进行编辑，将所选库项目与源文件分离，或用当前选择的库项目来覆盖一个项目。

若要编辑库项目属性，请执行以下操作：

  1. 在文档中插入库项目。
  2. 在属性检查器（“窗口”>“属性”）中，根据您要执行的任务，单击其中一个按钮。

    有关更多信息，请参见设置库项目属性。

相关主题

  • 创建库项目
  • 在文档中插入库项目
  • 设置库高亮显示参数
  • 使文档中的库项目可编辑


使文档中的库项目可编辑

如果您已经向文档中添加了库项目，并希望专门针对该页编辑此项目，则必须断开文档中的项目和库之间的链接。在使库项目的实例可编辑之后，当库项目发生更改时不会更新该实例。

若要使库项目可编辑，请执行以下操作：

  1. 在当前文档中选择库项目。
  2. 在属性检查器（“窗口”>“属性”）中，单击“从源文件中分离”。

    所选的库项目实例将不再高亮显示（如果已使其高亮显示），并且当原始库项目更改时，它也不会再更新。

相关主题

  • 创建库项目
  • 在文档中插入库项目
  • 编辑库项目
  • 编辑库项目属性


编辑库项目中的行为

若要编辑库项目中的行为，必须首先在文档中插入该项目，然后使该项目在此文档中可编辑。在进行所需的更改之后，即可重新创建该库项目，用文档中的已编辑项目来替换库中的项目。

有关行为的更多信息，请参见使用 JavaScript 行为。

若要编辑库项目中的行为，请执行以下操作：

  1. 打开包含该库项目的文档。

    请注意库项目的名称以及它所包含的准确的标签。您将在以后需要用到这些信息。

  2. 选择该库项目，并在属性检查器（“窗口”>“属性”）中单击“从源文件中分离”。
  3. 选择附着了该行为的元素。
  4. 在“行为”面板（“窗口”>“行为”）中双击想要更改的动作。
  5. 在出现的对话框中进行必要的更改，然后单击“确定”。
  6. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“库”类别。
  7. 确保您已经记录了原始库项目的准确名称；选择该原始库项目，然后单击面板底部的“删除”按钮。
  8. 在“文档”窗口中选择组成该库项目的所有元素。

    小心选择与原始库项目中完全相同的元素。

  9. 在“资源”面板中单击“新建库项目”按钮，并给新项目起一个与删除的项目相同的名称。

    务必使用完全相同的拼写和大小写。

  10. 若要更新站点的其他文档中的库项目，请选择“修改”>“库”>“更新页面”。
  11. 在“更新页面”对话框的“查看”弹出菜单中选择“文件使用”。
  12. 在相邻的弹出菜单中，选择刚创建的库项目的名称。
  13. 在“更新”选项中，确保选择了“库项目”，然后单击“开始”。
  14. 当完成更新时，单击“关闭”退出“更新页面”对话框。

相关主题

  • 创建库项目
  • 在文档中插入库项目
  • 编辑库项目


参考资料

本节提供有关本章中介绍的面板和“属性”检查器的信息。

  • 使用“资源”面板
  • 设置库项目属性


使用“资源”面板

资源包括存储在站点中的各种元素，如图像或影片文件。“资源”面板提供了两种查看资源的方式：

“站点”列表显示站点的所有资源。

“收藏”列表仅显示您明确选择的资源。

有关更改视图的信息，请参见在“资源”面板中查看资源。

在这两个列表中，资源被分成下列类别，显示在“资源”面板的左侧：

图像是 GIF、JPEG 或 PNG 格式的图像文件。（请参见插入图像。 这是所描述的功能的图片。 ）

颜色是站点的文档和样式表中使用的颜色，包括文本颜色、背景颜色和链接颜色。 这是所描述的功能的图片。

URLs 是当前站点文档中的外部链接。此类别包括下列类型的链接：FTP、gopher、HTTP、HTTPS、JavaScript、电子邮件 (mailto) 和本地文件 (file://) 这是所描述的功能的图片。 。

Flash 文件是任意版本的 Macromedia Flash 格式文件。“资源”面板仅显示 SWF 文件（压缩的 Flash 文件），而不显示 FLA （Flash 源）文件。（请参见插入和修改 Flash 按钮对象。） 这是所描述的功能的图片。

Shockwave 影片是任意版本的 Macromedia Shockwave 格式文件。（请参见插入 Shockwave 影片。） 这是所描述的功能的图片。

影片是 QuickTime 或 MPEG 格式文件。（请参见添加音频、视频和交互式元素。） 这是所描述的功能的图片。

脚本是 JavaScript 或 VBScript 文件。请注意，HTML 文件中的脚本（而不是独立的 JavaScript 或 VBScript 文件）不出现在“资源”面板中。 这是所描述的功能的图片。

模板提供了一种方便的方法，用于在多个页面上重复使用同一页面布局，以及在修改模板的同时修改附加到该模板的所有页面上的布局。（请参见关于 Dreamweaver 模板。） 这是所描述的功能的图片。

库项目是在多个页面中使用的元素；当修改一个库项目时，所有包含该项目的页面都将被更新。（请参见使用库项目。） 这是所描述的功能的图片。

注意

“资源”面板中仅显示属于这些类别的文件。某些其他类型的文件有时也称为资源，但这些文件不在面板中显示。

相关主题

  • 在“资源”面板中查看资源
  • 刷新“资源”面板
  • 将资源添加到文档
  • 使用“资源”面板将颜色应用于文本
  • 选择和编辑资源
  • 在另外的站点中重新使用资源


设置库项目属性

使用库项目属性可以指定项目的源文件，使其可编辑或在文档中编辑其实例后重新创建原始库项目。

要设置库项目属性，请执行以下操作：

选择以下任一选项：

Src 显示库项目源文件的文件名和位置。不能编辑此信息。

打开打开库项目的源文件进行编辑。这等同于在“资源”面板中选择项目并单击“编辑”按钮。

从源文件中分离用于断开所选库项目及其源文件之间的链接。分离项目后，可以在文档中对其进行编辑，但它不再是库项目并且不能在更改原始库项目时更新。

重新创建用当前选定内容改写原始库项目。使用此选项可以在丢失或意外删除原始库项目时重新创建库项目。

相关主题

  • 创建库项目
  • 编辑库项目属性


使用 Dreamweaver 管理 Contribute 站点

Macromedia Contribute 结合了 Web 浏览器和基本的 Web 页编辑器。它使您的同事或客户可浏览您创建的站点中的页面，如果他们有相应权限的话，还可以编辑或更新该页面。Contribute 用户可添加和更新基本的 Web 内容，包括带格式的文本、图像、表格和链接。Contribute 站点管理员可限制普通用户（非管理员）在站点中能够进行的操作。

注意

本章假定您是 Contribute 管理员。

作为站点管理员，您可以创建连接密钥并将其发送给其他不具备管理员权限的人员，以便使他们能够编辑页面。（有关更多信息，请参见使用 Contribute。）您也可以使用 Macromedia Dreamweaver 8 建立与 Contribute 站点的连接；这样，您或其他用户便可以象修改任何其他 Dreamweaver 站点中的文件一样修改这种站点中的文件了。如果希望使用 Dreamweaver 而不是 Contribute 来连接到 Contribute 站点，这一功能非常有用。例如，站点设计者希望连接到 Contribute 站点，但是他们需要使用 Dreamweaver 的所有编辑功能。

Contribute 可借助 Contribute Publishing Server (CPS) 丰富 Web 站点的功能；CPS 是一套发布应用程序和用户管理的工具，使您可以将 Contribute 与您的组织的 Lightweight Directory Access Protocol (LDAP) 或 Active Directory 等用户目录服务集成。如果作为 Contribute 站点启用 Dreamweaver 站点，每次连接到远程站点时，Dreamweaver 都会读取 Contribute 的管理设置。如果 Dreamweaver 检测到已启用了 CPS，它将直接与 CPS 通信。这样，Dreamweaver 便可以继承 CPS 的某些功能，如文件复原和事件记录等。

本章包含下列章节：

关于管理 Contribute 站点

准备站点以用于 Contribute

使用 Dreamweaver 管理 Contribute 站点

使用 Dreamweaver 管理 Contribute 文件

Contribute 站点答疑


关于管理 Contribute 站点

您可以使用 Dreamweaver 连接到 Contribute 站点，并可以像修改任何 Dreamweaver 站点中的文件一样修改这种站点中的文件。大多数 Dreamweaver 功能在 Contribute 站点上和在任何其它站点上的工作方式相同。在 Contribute 站点上管理文件与在其它站点上管理文件只有几个不同的方面。

本节包含以下概念性主题：

  • Contribute 站点的站点结构和页面设计
  • Contribute 兼容性站点连接
  • 与 Contribute 站点传输文件
  • 服务器上的 Contribute 文件和文件夹权限
  • Contribute 特殊文件


Contribute 站点的站点结构和页面设计

若要使 Contribute 用户能够编辑 Web 站点，需适当地组织站点结构。

创建 Contribute 用户应使用的包含其页面的文件夹，为这些文件夹创建索引页，并向这些页面添加基本的导航功能。您可能需要创建用户用来进行练习的特定于用户的文件夹。您可能还需要创建定义每个页面或文件夹样式的 CSS 样式表。您可在 Contribute 中进行一些此类设置工作，但使用 Dreamweaver 设置站点更为简便。

另外，您还可创建一些模板，以便 Contribute 用户可以用来创建新页面（请参见为 Contribute 站点创建模板）。

以下建议可能有助于使您创建的站点便于 Contribute 用户轻松提供内容：

  • 站点结构应尽量简单。

    嵌套文件夹级数不要过多。将相关项目组合在一个文件夹中。

  • 为服务器上的文件夹设置适当的读写权限。

    有关更多信息，请参见允许 Contribute 用户在没有根文件夹访问权限的情况下访问模板。

  • 在创建文件夹结构时，请将索引页添加到文件夹中，以引导 Contribute 用户将新页面放在正确的文件夹中。

    例如，如果 Contribute 用户将要提供包含会议纪要的页面，则您可在站点根文件夹中创建一个名为“meeting_minutes”的文件夹，并在该文件夹中创建一个索引页。随后您可在站点主页提供一个指向会议纪要索引页的链接。Contribute 用户随后就可导航到该索引页，并新建一个该索引页链接的特定会议纪要的页面；新页面会自动在“meeting_minutes”文件夹内创建。

  • 在每个文件夹的索引页上，提供一列指向该文件夹中各内容页面和文档的链接。
  • 页面设计应尽量简单，尽量减少复杂格式。
  • 清楚地命名 CSS 样式。

    如果使用您站点的 Contribute 用户使用的是 Microsoft Word 中的标准样式集，则使用与相应 Word 样式相同的名称命名 CSS 样式，这样当用户从 Word 文档中复制信息并将其粘贴到 Contribute 页面中时，Contribute 即可映射这些样式。

  • 若要使某 CSS 样式对 Contribute 用户不可用，可更改该样式的名称，使名称以 mmhide_ 开头。

    例如，如果您在页面中使用名为 RightJustified 的样式，但不希望 Contribute 用户能够使用该样式，则可将该样式重命名为 mmhide_RightJustified。

    注意

    必须在“代码”视图中向样式名称中添加 mmhide_，不能在“CSS”面板中添加。
  • 使用 CSS 而不使用 HTML 标签。

    Contribute 可以识别 CSS 样式，并允许用户应用这些样式。

  • 尽量少用 CSS 样式，以使内容简单、明晰。
  • 如果您使用用于 HTML 页面元素（例如标题或脚注）的服务器端包含文件，请创建一个未链接的包含指向这些包含文件的链接的简单 HTML 页面。

    Contribute 用户即可将该页面作为书签，而且可以用它来导航到包含文件并对这些文件进行编辑。

相关主题

  • 设置 Dreamweaver 站点
  • 创建新文档
  • 使用层叠样式表设置文本格式
  • 使用 server-side include（服务器端包括）


Contribute 兼容性站点连接

在 Dreamweaver 中，您可以连接到现有的 Contribute 站点，并且可以象修改任何 Dreamweaver 站点中的文件一样修改这种站点中的文件（请参见设置新的 Dreamweaver 站点）。当连接到已设置为 Contribute 站点（并已具有管理员）的站点时，Dreamweaver 将提示您启用 Contribute 的兼容性功能。

如果您正在为 Contribute 用户准备现有的 Dreamweaver 站点，那么，您需要显式启用 Contribute 兼容性功能才能使用 Contribute 相关的功能；Dreamweaver 不会提示您。有关更多信息，请参见准备站点以用于 Contribute。

Dreamweaver 允许以各种方式连接到远程站点（包括 Contribute 站点），但并不是所有的连接类型都支持 Contribute 的兼容性功能。具体来说，连接类型有下列限制：

  • 如果使用 WebDAV 或 Microsoft Visual SourceSafe 连接到远程站点，则不能启用 Contribute 的兼容性功能，因为这些源控制系统与 Dreamweaver 用于 Contribute 站点的“设计备注”和“存回/取出”系统不兼容。
  • 如果使用 RDS 连接到远程站点，则可以启用 Contribute 的兼容性功能，但必须随后自定义该连接，才可以与 Contribute 用户共享它。
  • 如果您使用本地计算机作为 Web 服务器，则必须使用到该计算机的 FTP 或网络连接来设置站点（而不是仅仅设置本地文件夹路径），才能与 Contribute 用户共享连接。


与 Contribute 站点传输文件

Contribute 使用和 Dreamweaver 的“存回/取出”系统十分相似的系统，以确保一次只有一个用户可以编辑给定的 Web 页。在 Dreamweaver 中启用 Contribute 的兼容性功能后，将自动启用 Dreamweaver 的“存回/取出”系统。

若要使用 Dreamweaver 向或从 Contribute 站点传输文件，请务必使用存回文件和取出文件命令。如果改用上传文件和获取文件命令传输文件，则可能会覆盖 Contribute 用户最近对文件所进行的修改。

注意

如果确实在 Contribute 站点中使用了“上传”命令，Dreamweaver 将自动存回此文件，然后再将其取出，以减少您的更改和其他用户的更改发生冲突的机会。

从 Contribute 站点中取出文件和在任何其它站点中取出文件一样。

当将文件存回到 Contribute 站点中时，Dreamweaver 将在 _baks 文件夹自动生成一个以前存回文件版本的备份副本，并将用户名和日期戳添加到“设计备注”文件中，以便其他人可以知道是谁在什么时候存回了文件。有关自动备份副本的更多信息，请参见允许 Contribute 用户在没有根文件夹访问权限的情况下访问模板。

相关主题

  • 存回和取出文件
  • 准备站点以用于 Contribute


服务器上的 Contribute 文件和文件夹权限

Contribute 为您定义的每个用户角色提供一种管理文件和文件夹权限的方法。有关更多信息，请参见“管理 Contribute”。Dreamweaver 用户不受这些权限的影响，但 Contribute 对 Contribute 用户强制执行这些权限。

但是，Contribute 并未提供方法来管理由服务器分配给文件和文件夹的基础读写权限。您可以直接在服务器上管理那些权限。

您可以将 Contribute 用户角色想象成服务器读写权限的上层权限；例如，如果用户没有服务器上文件夹的写权限，那么即使他们属于允许写入该文件夹（根据 Contribute 权限）的角色的成员，也不能在该文件夹中进行保存。

如果 Contribute 用户没有服务器上相关文件（如在页面中显示的图像）的读访问权限，那么相关文件的内容就不会出现在 Contribute 窗口中。例如，如果用户没有某图像文件夹的读访问权限，则那个文件夹中的图像将在 Contribute 中显示为断开的图像图标。类似地，Dreamweaver 模板存储在站点根文件夹的子文件夹中，所以，如果 Contribute 用户没有根文件夹的读访问权限，那么除非您将模板复制到适当的文件夹中，否则他们将不能使用该站点中的模板。

设置站点时，必须将服务器上的以下文件夹的读访问权限授予用户：/_mm 文件夹（根文件夹的 _mm 子文件夹）、/Templates 文件夹以及包含他们需要使用的资源的所有文件夹。

如果由于某种原因不能授予用户 /Templates 文件夹的读访问权限，请参见允许 Contribute 用户在没有根文件夹访问权限的情况下访问模板为用户提供模板。


Contribute 特殊文件

Contribute 使用各种特殊文件，这些文件不是供站点访问者查看的。这些文件包括：

  • 共享设置文件，它拥有一个带有 CSI 扩展名的模糊文件名，出现在站点根文件夹中名为 _mm 的文件夹中，包含 Contribute 用来管理站点的信息
  • 旧版本文件，这些文件位于名为 _baks 的文件夹中（请参见允许 Contribute 用户在没有根文件夹访问权限的情况下访问模板）
  • 页面的临时版本，以便用户可以预览更改
  • 临时锁定文件，指示某给定页面正在被编辑或预览
  • “设计备注”文件，其中包含有关站点页面的元数据

一般来说，不应使用 Dreamweaver 来编辑这些 Contribute 特殊文件；Dreamweaver 会自动管理它们。

如果不希望这些 Contribute 特殊文件出现在可公开访问的服务器上，那么可以设置一个中间服务器，Contribute 用户可在这里处理页面。然后，可以定期地将那些 Web 页从中间服务器复制到 Web 上的生产服务器中。如果采用这种中间服务器的方法，则只需将 Web 页复制到生产服务器上，而不必复制上述任何 Contribute 特殊文件。尤其不要将 _mm 和 _baks 文件夹复制到生产服务器上。

注意

有关如何设置服务器以防止访问者查看以下划线开头的文件夹中的文件的信息，请参见“使用 Contribute”中的“Web 站点安全”。

在有些情况下，可能需要手动删除 Contribute 特殊文件。例如，有时用户完成预览后 Contribute 未能删除临时的预览页，在这种情况下，您可能需要手动删除这些临时页。临时预览页的文件名以 TMP 开头。

类似地，在某些情况下，可能偶然会有过时的锁定文件残留在服务器上。如果发生这种情况，您必须手动删除锁定文件以允许其他人编辑此页。有关如何删除锁定文件的信息，请参见解锁 Contribute 站点中的文件。


准备站点以用于 Contribute

在使用 Dreamweaver 管理 Contribute 站点之前，必须启用 Contribute 兼容性功能。根据您连接的站点，可能会自动提示您启用 Contribute 兼容性功能。

注意

启用 Contribute 的兼容性功能时，Dreamweaver 将自动启用“设计备注”（包括“上传并共享设计备注”选项）和“存回/取出”系统。

为已定义的 Dreamweaver 站点启用 Contribute 的兼容性功能：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 选择一个站点，然后单击“编辑”。

    出现“站点定义”对话框。

  3. 单击“高级”选项卡。
  4. 从左侧的“类别”列表中选择“Contribute”类别。
  5. 选择“启用 Contribute 兼容性功能”选项，然后完成该对话框。

    有关更多信息，请参见设置“站点定义”对话框中“Contribute”类别的选项。

  6. 单击“确定”关闭“站点定义”对话框。
  7. 单击“完成”关闭“管理站点”对话框。

相关主题

  • Contribute 兼容性站点连接
  • 使用 Dreamweaver 管理 Contribute 站点


使用 Dreamweaver 管理 Contribute 站点

启用 Contribute 兼容性功能（请参见准备站点以用于 Contribute）之后，可以使用 Dreamweaver 启动 Contribute 来执行站点管理任务。

注意

必须将 Contribute 与 Dreamweaver 安装在同一计算机上。

作为 Contribute 站点的管理员，您可以执行以下任何操作：

  • 更改该站点的管理设置。

    Contribute 管理设置是适用于 Web 站点的所有用户的设置集合。这些设置使您可以精确调整 Contribute 以提供更好的用户体验。

  • 更改授予 Contribute 用户角色的权限。
  • 设置 Contribute 用户。

    Contribute 用户需要站点的特定相关信息才可连接到站点。您可将所有这些信息打包到一个称为连接密钥 的文件中，并将此文件发送给 Contribute 用户。

    注意

    连接密钥不同于 Dreamweaver 导出的站点文件。若要导出站点信息以用于 Dreamweaver，请参见导入和导出站点。

    提示

    在为 Contribute 用户提供编辑页面所需的连接信息之前，应使用 Dreamweaver 为站点创建基本的文件夹层次结构（请参见 Contribute 站点的站点结构和页面设计），并为站点创建所需的所有模板和 CSS 样式表（请参见为 Contribute 站点创建模板。

使用 Dreamweaver 管理 Contribute Web 站点：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 选择一个站点，然后单击“编辑”。

    出现“站点定义”对话框。

  3. 单击“高级”选项卡。
  4. 从左侧的“类别”列表中选择“Contribute”类别。
  5. 单击“在 Contribute 中管理站点”按钮。

    注意

    如果没有启用 Contribute 的兼容性功能，则不会显示此按钮。有关如何启用此选项的信息，请参见准备站点以用于 Contribute。
  6. 如果出现提示，请输入管理员密码，然后单击“确定”。

    随即出现“管理网站”对话框。

  7. 执行以下操作之一：
    • 若要更改管理设置，请从左边的列表中选择类别，然后根据需要更改设置。
    • 若要更改角色设置，请在“用户和角色”类别中单击“编辑角色设置”按钮，然后根据需要进行更改。
    • 若要发送连接密钥以设置用户，请在“用户和角色”类别中单击“发送连接密钥”按钮，然后完成“连接向导”。

      提示

      有关管理设置、管理用户角色或创建连接密钥的更多信息，请参见“使用 Contribute”。
  8. 单击“关闭”关闭“管理网站”对话框。
  9. 单击“确定”关闭“站点定义”对话框。
  10. 单击“完成”关闭“编辑站点”对话框。

相关主题

  • 使用 Dreamweaver 管理 Contribute 文件


使用 Dreamweaver 管理 Contribute 文件

大多数 Dreamweaver 功能在 Contribute 站点上和在任何其它站点上的工作方式相同。但是，当将 Dreamweaver 用于 Contribute 站点时，Dreamweaver 将自动执行某些文件管理操作，例如保存文档的多个修订版，在 CPS 控制台上记录某些事件等。

本节描述在 Contribute 站点上管理文件与在其它站点上管理文件的不同之处。

有关与 Contribute 站点之间传输文件的信息，请参见与 Contribute 站点传输文件。有关 Contribute 特殊文件的信息，请参见 Contribute 特殊文件。

注意

Contribute 管理员可以向用户分配角色，并可以指定每个角色的成员能够执行哪些操作。当您使用 Dreamweaver 管理 Contribute 站点中的文件时，基于角色的限制对您没有影响；唯一适用的限制是服务器上的读写权限。有关不同种类的权限的更多信息，请参见服务器上的 Contribute 文件和文件夹权限。

本节包含以下主题：

  • 删除、移动或重命名 Contribute 站点中的远端文件
  • 删除、移动或重命名 Contribute 站点中的远端文件
  • 允许 Contribute 用户在没有根文件夹访问权限的情况下访问模板
  • 解锁 Contribute 站点中的文件
  • 记录事件


删除、移动或重命名 Contribute 站点中的远端文件

从承载 Contribute 站点的远程服务器中删除文件和从任何 Dreamweaver 站点的服务器中删除文件十分类似。但是，当从 Contribute 站点删除文件时，Dreamweaver 会询问是否删除此文件的所有旧版本。如果选择保存旧版本，Dreamweaver 将同时保存当前版本的副本，以便您可在以后恢复它。

在 Contribute 站点中重命名远程文件或将其从一个文件夹移动到另一个文件夹与在任何 Dreamweaver 站点中进行这一操作的方法相同。在 Contribute 站点中，Dreamweaver 还将重命名或移动相关联的此文件的以前版本（它们保存在 _baks 文件夹中）。

若要删除远程文件，请执行以下操作：

  1. 在“文件”面板（“窗口”>“文件”）的“远程”窗格中选择该文件，然后按 Backspace 键 (Windows) 或 Delete 键 (Macintosh)。

    出现一个对话框，要求您确认是否要删除此文件。

  2. 如果在确认对话框中出现“删除回退版本”选项，则执行下列操作之一：
    • 若要删除此文件所有的以前版本和当前版本，请选择“删除回退版本”选项。
    • 若要在服务器上保留以前的版本，请取消选择“删除回退版本”选项。
  3. 单击“是”删除该文件。

    此文件即被删除。如果选择删除以前的版本，则这些版本也将被删除。如果选择不删除以前的版本，则将当前版本的副本作为此文件新的修订版保存在 _baks 文件夹中。

相关主题

  • 允许 Contribute 用户在没有根文件夹访问权限的情况下访问模板
  • 解锁 Contribute 站点中的文件


允许 Contribute 用户在没有根文件夹访问权限的情况下访问模板

在 Contribute 站点中，您可以直接在服务器上管理基础文件和文件夹权限。有关更多信息，请参见服务器上的 Contribute 文件和文件夹权限。

设置站点时，必须将服务器上的以下文件夹的读访问权限授予用户：/_mm 文件夹（根文件夹的 _mm 子文件夹）、/Templates 文件夹以及包含他们需要使用的资源的所有文件夹。授予用户对服务器上的 /Templates 文件夹的读访问权也是一个非常好的方法。

如果由于某种原因而无法授予用户对 /Templates 文件夹的读访问权限，您仍能使模板对于用户可用。

若要允许 Contribute 用户在没有对主站点根文件夹的读访问权限的情况下使用模板，请执行以下操作：

  1. 设置 Contribute 站点，使其根文件夹显示为希望用户视为根的文件夹。
  2. 使用“文件”面板，手动将模板文件夹从主站点的根文件夹复制到 Contribute 站点的根文件夹中。
  3. 为主站点更新模板之后，请根据需要将已更改的模板重新复制到适当的子文件夹中。

如果采用这种方法，则不要在子文件夹中使用站点根目录相对链接。站点根目录相对链接是相对于服务器上主根文件夹的链接，而不是相对于在 Dreamweaver 中定义的根文件夹的链接。Contribute 用户不能创建站点根目录相对链接。有关站点根目录相对链接的更多信息，请参见了解文档位置和路径。

如果 Contribute 页中的链接显示为已断开，则可能是文件夹权限有问题，特别是当链接指向的页位于 Contribute 用户的根文件夹外部时，容易出现这种现象。请检查服务器上文件夹的读写权限。


解锁 Contribute 站点中的文件

有时 Contribute 站点中的远程文件看上去已被取出，但文件实际并未在用户计算机上锁定。发生这种情况时，请将此文件解锁，以允许用户编辑它。

注意

在执行此过程之前，请确保此文件实际并未取出。如果 Contribute 用户编辑文件时您对文件进行解锁，则多个用户可以同时编辑此文件。

若要解锁取出的文件，请执行以下操作：

  1. 执行下列操作之一：
    • 在“文档”窗口中打开文件，然后选择“站点”>“撤消取出”。
    • 在“文件”面板（“窗口”>“文件”）中，右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“撤消取出”。

    可能会出现一个对话框，它指示谁已取出此文件，并要求您确认是否要解锁此文件。

  2. 如果出现此对话框，请单击“是”进行确认。

    此文件在服务器上被解锁。


记录事件

如果在您连接到的远端站点上启用了 Contribute Publishing Server (CPS)，则每次触发网络操作（如存回、回退或发布文件）时，Dreamweaver 都会通知 CPS。CPS 将记录这些事件，您可以在 CPS 管理控制台中查看日志。

注意

CPS 使用 Contribute 启用。有关更多信息，请参见“管理 Contribute”。

若要开始记录事件，请执行以下操作：

  • 在 Dreamweaver 中启用 Contribute 兼容性功能。

    有关更多信息，请参见准备站点以用于 Contribute。

若要查看事件记录，请执行以下操作：

  • 切换到 CPS 管理控制台。

    有关更多信息，请参见“管理 Contribute”。

若要停止记录事件，请执行以下操作：

  • 禁用 Contribute 兼容性功能。


Contribute 站点答疑

如果您在使用 Contribute 站点时遇到问题，请参见下列特定主题，以获得有关如何解决这些问题的信息：

  • 有关连接到 Contribute 站点的问题，请参见 Contribute 站点连接问题答疑。
  • 有关使用管理工具的问题，请参见 Contribute 管理工具答疑。

有关的更多答疑信息，请参见“管理 Contribute”中的答疑部分。


Contribute 站点连接问题答疑

在单击与 Contribute 站点管理相关的任何按钮之后，Dreamweaver 都要验证它是否能连接到该远程站点，以及您给出的站点根 URL 是否有效。如果 Dreamweaver 无法连接，或者如果 URL 无效，则显示一条错误信息。

检查 Contribute 连接：

  1. 在浏览器中打开“站点定义”对话框的“Contribute”类别中的站点根 URL，检查该 URL，以便确定打开了正确的页面。
  2. 使用“站点定义”对话框“远程信息”类别中的“测试”按钮来确保可以连接到该站点。
  3. 如果 URL 是正确的但“测试”按钮导致出现错误信息，请向系统管理员寻求帮助。

相关主题

  • Contribute 站点连接问题答疑


Contribute 管理工具答疑

如果管理工具不能正确工作，则可能是 _mm 文件夹有问题。

若要检查 _mm 文件夹，请执行以下操作：

  1. 在服务器上，确保您具有 _mm 文件夹的读写权限以及执行权限（如有必要）。
  2. 确保 _mm 文件夹包含一个带有 CSI 扩展名的共享设置文件。
  3. 如果其中不包含共享设置文件，请使用“连接向导”(Windows) 或“连接帮助”(Macintosh) 建立到该站点的连接，并成为该站点的管理员。

    共享设置文件在您成为管理员后将自动创建。有关成为现有 Contribute Web 站点管理员的更多信息，请参见“管理 Contribute”。

相关主题

  • Contribute 站点连接问题答疑


参考资料

本节提供有关“站点定义”对话框中的 Contribute 类别的信息：

  • 设置“站点定义”对话框中“Contribute”类别的选项


设置“站点定义”对话框中“Contribute”类别的选项

使用“站点定义”对话框的该类别中的选项启用 Macromedia Contribute 兼容性功能。

注意

必须将 Contribute 与 Dreamweaver 安装在同一计算机上。

要将 Dreamweaver 用于 Contribute，请执行以下操作：

  1. 选择“启用 Contribute 兼容性功能”选项，使用 Dreamweaver 管理 Contribute 站点。

    启用 Contribute 的兼容性功能时，Dreamweaver 将自动启用“设计备注”（包括“上传并共享设计备注”选项）和“存回/取出”系统。

  2. 如果出现一个对话框，告诉您必须启用“设计备注”和“存回/取出”，则请单击“确定”。
  3. 如果您尚未提供“存回/取出”联系信息，则出现一个对话框，要求您输入该信息；请在该对话框中键入您的姓名和电子邮件地址，然后单击“确定”。

    回退状态、CPS 状态、“站点根 URL”文本框和“管理站点”按钮都将显示在“站点定义”对话框中。

    如果 Contribute 中启用了“回退”，则能回退到在 Dreamweaver 中更改过的文件的以前版本。有关更多信息，请参见复原文件（Contribute 用户）。

    如果在远程站点上启用了 CPS，则每次触发网络操作（如存回、回退或发布文件）时，Dreamweaver 都会通知 CPS。CPS 将记录这些事件，您可以在 CPS 管理控制台中查看日志。有关更多信息，请参见记录事件。

    注意

    您必须连接到远程站点才能启用 Contribute 兼容性。否则，Dreamweaver 无法读取 Contribute 的管理设置，以确定是否启用了 CPS 和回退。
  4. 检查 Dreamweaver 在“站点根 URL”文本框中提供的 URL，如果不正确，请更正它。

    Dreamweaver 基于您提供的其他站点定义信息构造站点根 URL，但有时构造的 URL 并不十分正确。必须确保 Dreamweaver 使用正确的站点根 URL，然后才能管理 Contribute 站点。

  5. 单击“测试”按钮来验证输入的 URL 是否正确。

    注意

    如果现在您已准备好发送连接密钥或执行 Contribute 站点管理任务，请跳过其余步骤，并请参见使用 Dreamweaver 管理 Contribute 站点。
  6. 单击“在 Contribute 中管理站点”按钮以管理。
  7. 单击“确定”关闭“站点定义”对话框。


对页进行布局

使用 Macromedia Dreamweaver 8 中的可视化设计工具创建复杂的页面布局。

此部分包含以下各章：

使用 CSS 对页进行布局

使用表格显示内容

在“布局模式”对页进行布局

使用框架

管理模板


使用 CSS 对页进行布局

在 Macromedia Dreamweaver 8 中，可以使用 CSS 样式对页面进行布局。可以手动插入 div 标签并对其应用 CSS 定位样式，也可以使用 Dreamweaver 层来创建布局。Dreamweaver 中的层是被分配了绝对位置的 HTML 页面元素 － 具体地说，是 div 标签或任何其他标签。

注意

Dreamweaver 会将具有绝对位置的所有 div 标签视为层，即使未使用“层”绘制工具创建那些 div 标签也是如此。

提示

您可以将 Dreamweaver 设计文件用作 CSS 布局的起始点。从“新建文档”对话框的“页面设计 (CSS)”类别中选择一个文件（请参见创建基于 Dreamweaver 设计文件的文档）。

无论使用 CSS、表格还是框架对页面进行布局，Dreamweaver 都用标尺和网格来作为布局中的可视化指导。Dreamweaver 还提供跟踪图像功能，可以使用该功能来重新创建已经使用图形应用程序创建的页面设计。

注意

如果您对使用层和层叠样式表 (CSS) 不熟悉，但是熟悉使用表格，请尝试在页面布局中使用表格或“布局”模式（请参见使用表格显示内容和在“布局模式”对页进行布局）。

本章包含下列章节：

关于 Dreamweaver 中的层

插入层

设置层首选参数和属性

管理层

操作层

将层转换为表格

制作层动画

插入 div 标签进行布局

使用 div 标签进行布局

更改 div 标签的高亮颜色

处理 CSS 布局可视化

使用标尺、辅助线和网格设计页面布局

使用跟踪图像


关于 Dreamweaver 中的层

层是被分配了绝对位置的 HTML 页面元素 － 具体地说，是 div 标签或任何其他标签。层可以包含文本、图像或其他任何可在 HTML 文档正文中放入的内容。

注意

本章中所说的层属于 Dreamweaver 的布局概念，而不是 layer 标签。

本节包含以下概念性主题：

  • 理解层的概念
  • 关于层的 HTML 代码


理解层的概念

通过 Dreamweaver，您可以使用层来设计页面的布局。您可以将层前后放置，隐藏某些层而显示其他层，以及在屏幕上移动层。您可以在一个层中放置背景图像，然后在该层的前面放置第二个层，它包含带有透明背景的文本。

利用层可以非常灵活地放置内容。但是，使用旧版本的 Web 浏览器的站点访问者查看层时可能会遇到麻烦。若要确保所有人都能够查看您的 Web 页，可以使用层设计页面布局，然后将层转换为表。有关更多信息，请参见将层转换为表格。但是，如果您所面对的访问者很可能使用某种最新的浏览器，则可以完全用层来设计布局，而无需将层转换为表格。

相关主题

  • 关于层的 HTML 代码
  • 管理层


关于层的 HTML 代码

当您在文档中放置层时，Dreamweaver 将在代码中插入该层的 HTML 标签。默认情况下，Dreamweaver 会使用 div 标签创建层。

注意

您还可以使用另外两种标签来创建层：layer 和 ilayer。但是，只有 Netscape Navigator 4 支持这些标签；Internet Explorer 不支持这些标签，而 Netscape 在较新的浏览器中也不再支持这些标签。Dreamweaver 可以识别 layer 和 ilayer 标签，但不使用这些标签来创建层。

在使用“绘制层”工具绘制层时，Dreamweaver 会在文档中插入 div 标签，并为层分配 id 值（默认情况下，Layer1 表示绘制的第一层，Layer2 表示绘制的第二层，依此类推）。稍后，可以使用“层”面板或“属性”检查器将层重新命名为想要的任何名称。Dreamweaver 还使用文档头中的嵌入式 CSS 来定位层和确定层的确切尺寸。

下面是一个层的 HTML 代码示例：

<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Sample Layers Page</title>
<style type="text/css">
<!--
#Layer1 {

position:absolute;
left:62px;
top:67px;
width:421px;
height:188px;
z-index:1;

}
-->
</style>
</head>

<body>
<div id="Layer1"></div>
</body>
</html>

您可以设置页面上层的属性，其中包括 x 和 y 坐标、z 轴（也称作堆叠顺序）以及可见性。有关更多信息，请参见设置层首选参数和属性。

相关主题

  • 理解层的概念


插入层

Dreamweaver 使您可以方便地在页面上创建层并精确地将层定位。您还可以创建嵌套层。有关更多信息，请参见嵌套层。

注意

您可以将 Dreamweaver 设计文件用作 CSS 布局的起始点。从“新建文档”对话框的“页面设计 (CSS)”类别中选择一个文件（请参见创建基于 Dreamweaver 设计文件的文档）。

插入层时，Dreamweaver 将显示层的边框，默认情况下，在将指针移到块上时它还会高亮显示块。通过在“查看”>“可视化助理”菜单中禁用“层外框”和“CSS 布局外框”，可以启用层边框。在设计时，还可以启用层的背景和框模型，作为可视化助理。有关更多信息，请参见处理 CSS 布局可视化。

若要更改层的高亮颜色或禁用高亮显示，请参见更改 div 标签的高亮颜色。

创建层后，只需将插入点放置于该层中，然后像在页面中添加内容一样，就可以将内容添加到层中。

若要连续绘制一个或多个层，请执行以下操作：

  1. 在“插入”栏的“布局”类别中单击“绘制层”按钮。 这是所描述的功能的图片。
  2. 在“文档”窗口的“设计”视图中，执行下列操作之一：
    • 拖动以绘制一个层。
    • 通过按住 Ctrl 键并拖动 (Windows) 或通过按住 Command 键并拖动 (Macintosh) 来连续绘制多个层。

      只要不松开 Ctrl 或 Command 键，就可以继续绘制新的层。

若要在文档中的特定位置插入层，请执行以下操作：

  • 将插入点放置在“文档”窗口中，然后选择“插入”>“布局对象”>“层”。

    注意

    此过程会将层标签放置到您在“文档”窗口中单击的任何位置。因此层的可视化呈现可能会影响层周围的其他页面元素（如文本）。

若要在层中放置插入点，请执行以下操作：

  • 在该层边框内的任意位置单击。

该层的边框会突出显示，并且选择柄将出现，但该层本身尚未选定。有关选择层的信息，请参见选择层。

若要显示层边框，请执行以下操作：

  • 选择“查看”>“可视化助理”，然后选择“层外框”或“CSS 布局外框”。

    注意

    同时选择这两个选项可获得同样的效果。

若要隐藏层边框，请执行以下操作：

  • 选择“查看”>“可视化助理”，然后取消选择“层外框”和“CSS 布局外框”。

相关主题

  • 嵌套层
  • 设置层首选参数和属性
  • 管理层
  • 操作层


嵌套层

嵌套层是其代码包含在另一个层中的层。嵌套通常用于将层组织在一起。嵌套层随其父层一起移动，并且可以设置为继承其父级的可见性。

可以启用“嵌套”选项，这样，当您从另一个层内开始绘制层时将实现层的自动嵌套。

若要绘制嵌套层，请执行以下操作：

  1. 在“插入”栏的“布局”类别中单击“绘制层”按钮。 这是所描述的功能的图片。
  2. 在“文档”窗口的“设计”视图中，拖动以在现有层中绘制层：

    如果已经在层首选参数中关闭了“嵌套”功能，请通过按住 Alt 键并拖动 (Windows) 或按住 Option 键并拖动 (Macintosh) 在现有层中嵌套一个层。

    提示

    在不同的浏览器中，嵌套层的外观可能会有所不同。当创建嵌套层时，请在设计过程中频繁地检查它们在不同浏览器中的外观。

若要插入嵌套层，请执行以下操作：

  • 在“文档”窗口的“设计”视图中将插入点放置在一个现有层中，然后选择“插入”>“层”。

若要使用“层”面板将现有层嵌套在另一个层中，请执行以下操作：

  1. 选择“窗口”>“层”，打开“层”面板。
  2. 在“层”面板中选择一个层，然后通过按住 Ctrl 键并拖动 (Windows) 或按住 Command 键并拖动 (Macintosh) 将层移动到“层”面板上的目标层。
  3. 当目标层的名称突出显示时，请松开鼠标按钮。

若要在从另一个层中开始绘制层时自动嵌套层，请执行以下操作：

  • 选择“层”首选参数中的“嵌套”选项。

    有关更多信息，请参见设置层首选参数。

相关主题

  • 插入层
  • 管理层
  • 操作层


设置层首选参数和属性

您可以指定层的默认设置。也可以使用“属性”检查器来查看和设置一个层或多个层的各种属性。

本节包含以下主题：

  • 设置层首选参数
  • 查看和设置单个层的属性
  • 查看和设置多个层的属性


设置层首选参数

使用“首选参数”对话框中的“层”类别可指定新建层的默认设置。

若要查看或设置层首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或Dreamweaver>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从左侧的“类别”列表中选择“层”。
  3. 按需要进行更改。

    有关更多信息，请参见设置“层首选参数”对话框选项。

  4. 单击“确定”。

相关主题

  • 查看和设置单个层的属性
  • 查看和设置多个层的属性


查看和设置单个层的属性

当您选择一个层时，“属性”检查器将显示层的属性。

若要查看和设置层属性，请执行以下操作：

  1. 选择一个层（请参见选择层）。
  2. 在“属性”检查器（“窗口”>“属性”）中，单击右下角的展开箭头（如果它尚未展开）以查看所有属性。

  3. 根据需要设置属性来更改层的属性。

    有关更多信息，请参见设置层属性。

相关主题

  • 设置层首选参数
  • 查看和设置多个层的属性
  • 管理层


查看和设置多个层的属性

当您选择两个或更多个层时，层“属性”检查器会显示文本属性以及全部层属性的一部分，从而允许您同时修改多个层。

若要选择多个层，请执行以下操作：

  • 选择层时请按下 Shift 键（请参见选择层）。

若要查看和设置多个层的所有属性，请执行以下操作：

  1. 选择多个层。
  2. 在“属性”检查器（“窗口”>“属性”）中，单击右下角的展开箭头（如果它尚未展开）以查看所有属性。

  3. 通过设置属性来更改层的属性。

    有关更多信息，请参见设置多个层的属性。

相关主题

  • 设置层首选参数
  • 查看和设置单个层的属性
  • 管理层


管理层

您可以选择层，然后对层进行处理。还可以更改层的堆叠顺序和可见性。“层”面板为管理层提供了方便的方法。

本节包含以下主题：

  • 使用“层”面板
  • 选择层
  • 更改层的层叠顺序
  • 更改层可见性


使用“层”面板

通过“层”面板可以管理文档中的层。使用“层”面板可防止重叠，更改层的可见性，将层嵌套或层叠，以及选择一个或多个层。

若要打开“层”面板，请执行以下操作：

  • 选择“窗口”>“层”。

层显示为按 z 轴顺序排列的名称列表；默认情况下，首先创建的层（z 轴顺序为 1）出现在列表的底部，最新创建的层（z 轴顺序大于 1）出现在列表的顶部。但是可以通过更改层的 z 轴来更改层在堆叠顺序中的位置。例如，如果创建了 8 个层，并且想将第 4 层设为堆叠顺序中的“最高”层，则可以为它分配一个比所有其他层都高的 z 轴。

有关使用“层”面板的更多信息，请参见以下主题：

  • 插入层
  • 选择层
  • 更改层的层叠顺序
  • 更改层可见性
  • 防止层重叠


选择层

您可以选择一个或多个层进行操作或更改它们的属性。

要在“层”面板中选择一个层，请执行以下操作：

  • 在“层”面板（“窗口”>“层”）中，单击该层的名称。

若要在“文档”窗口中选择一个层，请执行以下操作之一：

  • 单击一个层的选择柄。

    如果选择柄不可见，请在该层中的任意位置单击以显示该选项柄。

  • 单击一个层的边框。
  • 在一个层中按住 Ctrl-Shift 键并单击 (Windows) 或按住 Command-Shift 键并单击 (Macintosh)。
  • 在层内单击并按 Ctrl+A (Windows) 或 Command+A (Macintosh) 以选择层的内容。再次按 Ctrl+A 或 Command+A 以选择层。
  • 在层内单击并在标签选择器中选择层的标签。

若要选择多个层，请执行以下操作之一：

  • 在“层”面板（“窗口”>“层”）中，请按住 Shift 键并单击两个或更多的层名称。
  • 在“文档”窗口中，在两个或更多个层的边框内（或边框上）按住 Shift 键并单击。

相关主题

  • 插入层
  • 设置层首选参数和属性
  • 管理层
  • 操作层


更改层的层叠顺序

使用“属性”检查器或“层”面板可更改层的层叠顺序。“层”面板列表顶部的层将位于堆叠顺序的顶部，并且会出现在其他层之前。

在 HTML 代码中，层的堆叠顺序或 z 轴确定层在浏览器中的绘制顺序。层的 z 轴值越高，该层的堆叠顺序就越高。您可以使用“层”面板或“属性”检查器来更改每个层的 z 轴。

若要在“层”面板中更改层的层叠顺序，请执行以下操作：

  1. 选择“窗口”>“层”，打开“层”面板。
  2. 将层向上或向下拖至所需的堆叠顺序。

    当您移动层时会出现一条线，它指示该层将出现的位置。当放置线出现在层叠顺序中的所需位置时，请松开鼠标按钮。

若要用“属性”检查器更改层的层叠顺序，请执行以下操作：

  1. 选择“窗口”>“层”，打开“层”面板以查看当前堆叠顺序。
  2. 在“层”面板或“文档”窗口中选择一个层。
  3. 在层的“属性”检查器（“窗口”>“属性”）中，在 Z 轴文本框中键入一个编号。
    • 键入一个较大的数字可将该层在层叠顺序中上移。
    • 键入一个较小的数字可将该层在层叠顺序中下移。

相关主题

  • 使用“层”面板
  • 选择层
  • 更改层可见性


更改层可见性

当处理文档时，可以使用“层”面板手动显示和隐藏层，以查看页在不同条件下的显示方式。

注意

当前选定层始终会变为可见，它在选定时将出现在其他层的前面。

若要更改层可见性，请执行以下操作：

  1. 选择“窗口”>“层”，打开“层”面板。
  2. 在层的眼形图标列内单击可以更改其可见性。
    • 眼睛睁开表示该层是可见的。
    • 眼睛闭合表示该层是不可见的。
    • 如果没有眼形图标，该层通常会继承其父级的可见性。（如果层没有嵌套，父级就是文档正文，而文档正文始终是可见的。）另外，如果未指定可见性，则不会显示眼形图标（这在“属性”检查器中表示为“默认”可见性）。

若要同时更改所有层的可见性，请执行以下操作：

  • 在“层”面板（“窗口”>“层”）中，单击该列顶部的标题眼形图标。

    注意

    此过程可以将所有层设置为“可见”或“隐藏”，但不能设置为“继承”。

相关主题

  • 使用“层”面板
  • 更改层的层叠顺序


操作层

当处理页面布局时，可以对层进行选择、移动、大小调整和对齐。在对一个层进行移动、大小调整或对齐之前，必须先选择该层。

若要防止在对层进行移动和大小调整时使层相互重叠，请使用“防止重叠”选项（请参见防止层重叠）。

本节包含以下主题：

  • 调整层大小
  • 移动层
  • 对齐层


调整层大小

您可以调整单个层的大小，也可以同时调整多个层的大小以使其具有相同的宽度和高度。

如果已启用“防止重叠”选项，那么在调整层的大小时将无法使该层与另一个层重叠（请参见防止层重叠）。

若要调整层的大小，请执行以下操作：

  1. 在“设计”视图中，选择一个层（请参见选择层）。
  2. 执行以下操作之一以调整层的大小：
    • 若要通过拖动来调整大小，请拖动该层的任一大小调整柄。
    • 若要一次调整一个像素的大小，请在按箭头键时按住 Ctrl 键 (Windows) 或 Option 键 (Macintosh)。

      箭头键移动层的右边框和下边框；对于此方法，不能使用上边框和左边框来调整大小。

    • 若要按网格靠齐增量来调整大小，请在按箭头键时按住 Shift-Ctrl 键 (Windows) 或 Shift-Option (Macintosh) 键。

      有关设置网格靠齐增量的信息，请参见使用跟踪图像。

    • 在“属性”检查器（“窗口”>“属性”）中，键入宽度 (W) 和高度 (H) 的值。

调整层的大小会更改该层的宽度和高度。它并不定义该层的多少内容是可见的。若要定义一个层中的可见区域，请参见设置层首选参数和属性。

若要同时调整多个层的大小，请执行以下操作：

  1. 在“设计”视图中，选择两个或更多个层（请参见选择层）。
  2. 执行下列操作之一：
    • 选择“修改”>“对齐”>“设成宽度相同”或“修改”>“对齐”>“设成高度相同”。

      先选定的层将与最后选定的一个层的宽度或高度一致。

    • 在“属性”检查器（“窗口”>“属性”）中的“多个层”下输入宽度和高度值。

    这些值将应用于所有选定层。

相关主题

  • 移动层
  • 对齐层
  • 使用跟踪图像


移动层

您可以按照在基本的图形应用程序中移动对象的相同方法在设计视图中移动层。

如果已启用“防止重叠”选项，那么在移动层时将无法使层相互重叠。（请参见防止层重叠。）

若要移动一个或多个选定的层，请执行以下操作：

  1. 在“设计”视图中，选择一个或多个层（请参见选择层）。
  2. 执行下列操作之一：
    • 若要通过拖动来移动，请拖动最后一个选定层（黑色突出显示）的选择柄。
    • 若要一次移动一个像素，请使用箭头键。

      按箭头键时按住 Shift 键可按当前网格靠齐增量来移动层。有关设置网格靠齐增量的信息，请参见使用跟踪图像。

相关主题

  • 调整层大小
  • 对齐层
  • 使用跟踪图像


对齐层

使用层对齐命令可利用最后一个选定层的边框来对齐一个或多个层。

当对层进行对齐时，未选定的子层可能会因为其父层被选定并移动而移动。若要避免这种情况，请不要使用嵌套层。

若要对齐两个或更多个层，请执行以下操作：

  1. 在“设计”视图中，选择该层（请参见选择层）。
  2. 选择“修改”>“排列”，然后选择一个对齐选项。

    例如，如果选择“顶对齐”，所有层都会像它们的上边框与最后一个选定层（黑色突出显示）的上边框处于同一垂直位置一样移动。

相关主题

  • 调整层大小
  • 移动层
  • 使用跟踪图像


将层转换为表格

一些 Web 设计人员可能不喜欢使用表格或“布局”模式来创建自己的布局，而是喜欢通过层来进行设计。Dreamweaver 使您可以使用层来创建自己的布局，然后将它们转换为表格（如果愿意的话）。例如，如果您需要支持 4.0 版之前的浏览器，您可能需要将层转换为表格。

注意

在模板文档或已应用模板的文档中，不能将层转换为表格或将表格转换为层。相反，应该在非模板文档中创建布局，然后在将该文档另存为模板之前进行转换。

您可以在层和表格之间来回转换，以调整布局并优化网页设计。不能转换页面上特定的表格或层，必须将整个页面上的层转换为表格或将表格转换为层。

注意

从层转换为表格可能会生成包含大量空单元格的表。

本节包含以下主题：

  • 防止层重叠
  • 在层和表之间转换


防止层重叠

由于表单元格不能重叠，Dreamweaver 无法从重叠层创建表格。如果您要将文档中的层转换为表格，请使用“防止重叠”选项来约束层的移动和定位，使层不会重叠。

在启用该选项后，可以在现有层前面创建层，在现有层上移动层或调整层大小，或者将某个层嵌套在现有层中。如果您在创建重叠层后激活此选项，请拖动每个重叠层以使其离开其他层。当您启用“防止层重叠”选项后，Dreamweaver 不会自动修正页面上的现有重叠层。

在启用此选项和靠齐后，如果靠齐会使两个层重叠，则层将不会靠齐到网格。相反，层将靠齐到最接近的层的边缘。

注意

这是一个新的注释表。此表已附加到 ta Table_anchor 段落标签。要创建一个表，请在参考页面中进行复制和粘贴。

注意即使在启用“防止重叠”选项后，仍可以执行某些操作来将层重叠。如果您使用“插入”菜单插入一个层，在“属性”检查器中输入数字或者通过编辑 HTML 源代码来重定位层，则可以在此选项已启用时使层重叠或嵌套。如果出现重叠，请在设计视图中拖动各重叠层以使其分离。

若要防止层重叠，请执行以下操作之一：

  • 在“层”面板（“窗口”>“层”）中，请选择“防止重叠”选项。
  • 在“文档”窗口中，选择“修改”>“排列”>“防止层重叠”。

相关主题

  • 在层和表之间转换


在层和表之间转换

您可以使用层创建布局，然后将层转换为表格，以使您的布局可以在较早的浏览器中进行查看。

在转换为表格之前，请确保层没有重叠（请参见防止层重叠）。

若要将层转换为表格，请执行以下操作：

  1. 选择“修改”>“转换”>“层到表格”。

    即可显示“转换层为表格”对话框。

  2. 选择所需的选项。

    有关更多信息，请参见设置“将层转换为表格”对话框选项。

  3. 单击“确定”。

    层即转换为一个表格。

若要将表格转换为层，请执行以下操作：

  1. 选择“修改”>“转换”>“表格到层”。

    即可显示“转换表格为层”对话框。

  2. 选择所需的选项。

    有关更多信息，请参见设置“转换表格为层”对话框选项。

  3. 单击“确定”。

    表格即转换为层。空单元格不会转换为层（除非它们具有背景颜色）。

    注意

    位于表格外的页面元素也会放入层中。


制作层动画

动态 HTML（即 DHTML）是指 HTML 与一种脚本撰写语言的组合，您可以使用该脚本撰写语言更改 HTML 元素的样式或定位属性。在 Dreamweaver 中，时间轴使用动态 HTML 来更改层和图像在一段时间内的属性。使用时间轴可创建不需要任何 ActiveX 控件、插件或 Java Applet（但需要 JavaScript）的动画。

注意

动态一词在与 Web 相关的不同上下文中具有不同含义。不要将动态 HTML 与动态 Web 页的概念相混淆，后者表示在向访问者提供 Web 页之前由服务器端代码动态生成的 Web 页。

利用时间轴，您可以更改层的位置、大小、可见性和层叠顺序。（时间轴的层功能只能在 4.0 或更高版本的浏览器中使用。）对于要在页加载后执行的其他操作，时间轴也非常有用。例如，时间轴可以更改图像标签的源文件，因此一段时间内有不同的图像出现在页面上。

若要查看由时间轴生成的 JavaScript 代码，请打开“文档”窗口的代码视图。时间轴代码位于 MM_initTimelines 函数中（在文档的文件头部分的脚本标签中）。

当编辑包含时间轴的文档的 HTML 时，请确保没有移动、重命名或删除时间轴所引用的任何内容。


使用“时间轴”面板

“时间轴”面板显示层和图像的属性在一段时间内如何更改。选择“窗口”>“时间轴”，打开“时间轴”面板。

“时间轴”弹出式菜单指定当前在“时间轴”面板中显示文档的哪些时间轴。

播放栏显示当前在“文档”窗口中显示时间轴的哪一帧。

帧编号指示帧的序号。“后退”和“播放”按钮之间的数字是当前帧编号。您可以通过设置帧的总数和每秒帧数 (fps) 来控制动画的持续时间。每秒 15 帧这一默认设置是比较适当的平均速率，可用于在通常的 Windows 和 Macintosh 系统上运行的大多数浏览器。

注意

较快的速率可能不会提高性能。浏览器始终会播放动画的每一帧，即使它们无法达到指定的帧速率。如果帧速率超过浏览器可以支持的速率，则将被忽略。

上下文菜单包含各种与时间轴相关的命令。

“行为”通道是应该在时间轴中特定帧处执行的行为的通道。

动画条显示每个对象的动画的持续时间。一个行可以包含表示不同对象的多个条。不同的条无法控制同一帧中的同一对象。

关键帧是动画条中已经为对象指定属性（如位置）的帧。Dreamweaver 会计算关键帧之间帧的中间值。小圆标记表示关键帧。

“动画”通道显示用于制作层和图像动画的条。


播放选项

下面是用于查看动画的播放选项。

后退至起点将播放栏移至时间轴中的第一帧。

后退将播放栏向左移动一帧。单击“后退”并按住鼠标按钮可向后播放时间轴。

播放将播放栏向右移动一帧。单击“播放”并按住鼠标按钮可向前播放时间轴。

自动播放使时间轴于当前页在浏览器中加载时自动开始播放。“自动播放”将一个行为附加到页的 body 标签，该行为在页加载时执行“播放时间轴”操作。

循环使当前时间轴于页在浏览器中打开时无限地循环。“循环”在动画的最后一帧之后将“转到时间轴帧”行为插入到“行为”通道中。在“行为”通道中双击该行为的标记可编辑此行为的参数并更改循环的次数。


使用时间轴动画移动层

最常见的时间轴动画都涉及到沿着一条轨迹移动层。时间轴只能移动层。若要使图像或文本移动，请使用“插入”栏上的“绘制层”按钮创建一个层，然后在该层中插入图像、文本或其他任何类型的内容（请参见插入层）。

时间轴也可以更改层和图像的其他属性；有关更多信息，请参见用时间轴更改图像和层的属性。

若要使用时间轴制作层动画，请执行以下操作：

  1. 将层移至它在动画开始时应处于的位置。
  2. 选择“窗口”>“时间轴”。
  3. 选择您要制作动画的层。

    确保您已选择了所需的元素。单击层标记或层选择柄，或者使用“层”面板选择一个层。有关更多信息，请参见操作层。当选定一个层后，它的周围将出现调整柄，如下图所示。

    在层中单击会将一个闪烁的插入点放入层中，但不会选定该层。

  4. 选择“修改”>“时间轴”>“在时间轴上添加对象”，或者直接将选定层拖至“时间轴”面板中。

    一个条将出现在时间轴的第一个通道中。层的名称将在该条中出现。

  5. 单击位于条末端的关键帧标记。
  6. 在页面上将层移至它在动画结束时应处于的位置。

    将出现一条线，它显示“文档”窗口中动画的轨迹。

  7. 如果要让层沿曲线移动，请选择其动画条，然后按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 动画条中部的一个帧，从而在您单击的帧处添加一个关键帧，或者单击动画条中部的一个帧并从上下文菜单中选择“添加关键帧”。

    重复此步骤，定义其他关键帧。

  8. 按住“播放”按钮，预览页面上的动画。

    重复此过程，在时间轴上添加其他层和图像并创建更为复杂的动画。


通过拖动轨迹创建时间轴

如果要用复杂的轨迹创建动画，更为有效的方法可能是记录您拖动层时经过的轨迹，而不是创建各个关键帧。

若要通过拖动轨迹来创建时间轴，请执行以下操作：

  1. 选择一个层。
  2. 将该层移至它在动画开始时应处于的位置。

    确保您已选定该层；如果插入点位于该层中，则说明尚未选定该层。若要选择一个层，请单击层标记或层的选择柄，或者使用“层”面板。有关更多信息，请参见操作层。

  3. 选择“修改”>“时间轴”>“记录层的轨迹”。
  4. 在页面上拖动层以创建轨迹。
  5. 当到达动画应停止的点时释放该层。

    Dreamweaver在时间轴上添加一个动画条，其中包含适当数量的关键帧。

  6. 在“时间轴”面板中，单击“后退”按钮；然后按住“播放”按钮预览动画。


修改时间轴

定义完时间轴的基本组成部分后，可以进行一些更改，如添加和删除帧、更改动画开始时间等。

若要修改时间轴，请执行以下任一操作：

  • 若要使动画的播放时间更长，请将结束帧标记向右拖动。动画中的所有关键帧都会移动，以保持它们的相对位置不变。若要阻止其他关键帧移动，请按住 Ctrl 键并拖动结束帧标记。
  • 若要使层更早或更晚地到达某一关键帧位置，请在动画条中将关键帧向左或向右移动。
  • 若要更改动画的开始时间，请选择一个或多个与该动画关联的动画条（按 Shift 可一次选择多个动画条），然后向左或向右移动。
  • 若要移动整个动画轨迹的位置，请选择整个动画条，然后在页面上拖动该对象。Dreamweaver 会调整所有关键帧的位置。在整个动画条上所做出的任何更改将更改所有关键帧。
  • 若要在时间轴上添加或删除帧，请选择“修改”>“时间轴”>“添加帧”或“修改”>“时间轴”>“删除帧”。
  • 若要使时间轴于页在浏览器中打开时自动播放，请单击“自动播放”。“自动播放”会向页附加一个行为，该行为将在页加载时执行“播放时间轴”操作。
  • 若要使时间轴连续循环，请单击“循环”。“循环”将“转到时间轴帧”操作插入到动画最后一帧后的“行为”通道。您可以编辑此行为的参数以定义循环的次数。


用时间轴更改图像和层的属性

除了用时间轴移动层之外，您还可以更改层的可见性、大小和层叠顺序并更改图像的源文件。

若要用时间轴更改图像和层的属性，请执行以下操作：

  1. 在“时间轴”面板中，执行以下操作之一：
    • 在控制要更改的对象的动画条中选择一个现有关键帧。（起始帧和结束帧始终是关键帧。）
    • 单击动画条中部的一个帧并选择“修改”>“时间轴”>“添加关键帧”，创建一个新的关键帧。或者，可以通过按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 动画条中的一个帧来创建一个新的关键帧。
  2. 通过执行以下操作之一定义对象的新属性：
    • 若要更改图像的源文件，请单击“属性”检查器中“源文件”文本框旁的文件夹图标，然后浏览到新图像并将其选定。
    • 若要更改层的可见性，请从“属性”检查器“可见性”文本框中的弹出式菜单选择“继承”、“可见”或“隐藏”。或者，您也可以使用“层”面板中的眼形图标。请参见更改层可见性。
    • 若要更改层的大小，请拖动该层的大小调整柄或在“属性”检查器的“宽”和“高”文本框中输入新的值。并非所有浏览器都会动态更改层的大小。
    • 若要更改层的堆叠顺序，请在“Z 轴”文本框中输入新值，或使用“层”面板更改当前层的堆叠顺序（请参见更改层的层叠顺序）。
  3. 按住“播放”按钮以查看动画。


使用多个时间轴

与尝试用一个时间轴控制页面上的所有操作相比，使用单独的时间轴来控制页的各个离散部分会更容易一些。例如，一个页可能包含多个互动元素，每个元素都触发不同的时间轴。

若要管理多个时间轴，请执行以下任一操作：

  • 若要新建时间轴，请选择“修改”>“时间轴”>“添加时间轴”。
  • 若要删除选定的时间轴，请选择“修改”>“时间轴”>“删除时间轴”。这将永久删除选定时间轴中的所有动画。
  • 若要重命名选定时间轴，请选择“修改”>“时间轴”>“重命名时间轴”，或者在“时间轴”面板的“时间轴”弹出式菜单中输入新的名称。
  • 若要在“时间轴”面板中查看另一个时间轴，请从“时间轴”面板的“时间轴”弹出式菜单中选择一个新的时间轴。


拷贝和粘贴动画

一旦有您喜爱的动画序列，就可以将其拷贝并粘贴到当前时间轴的另一区域、同一文档中的另一时间轴或者另一文档中的时间轴。您还可以同时拷贝并粘贴多个序列。

若要剪切（或拷贝）并粘贴动画序列，请执行以下操作：

  1. 单击一个动画条以选择一个序列。若要选择多个序列，请按住 Shift 键并单击多个动画条；若要选择所有序列，请按 Ctrl+A 键 (Windows) 或 Command+A 键 (Macintosh)。
  2. 拷贝或剪切选定内容。
  3. 执行下列操作之一：
    • 将播放栏移至当前时间轴中的另一处。
    • 从“时间轴”弹出式菜单中选择另一个时间轴。
    • 打开另一个文档或创建一个新文档，然后在“时间轴”面板中单击。
  4. 将选定内容粘贴到时间轴中。

    同一对象的动画条不能重叠，因为一个层不能同时处于两个位置（一个图像也不能同时具有两个不同的源）。如果您所粘贴的动画条与同一对象的另一动画条重叠，Dreamweaver 会自动将选定内容移至第一个不重叠的帧。

在将动画序列粘贴到另一文档时，应牢记两条原则：

  • 如果您拷贝层的动画序列且新文档包含同名的层，Dreamweaver 会将动画属性应用于新文档中的现有层。
  • 如果您拷贝层的动画序列且新文档不包含同名的层，Dreamweaver会将层和它的内容随动画序列一起从初始文档中拷贝下来。若要将粘贴的动画序列应用于新文档中的另一个层，请从上下文菜单中选择“更改对象”并从弹出式菜单中选择第二个层的名称。如果需要，删除所粘贴的层。请参见将动画序列应用于另一对象。


将动画序列应用于另一对象

为了节约时间，您可以只创建一次动画序列，然后将其应用于文档中剩余的每个层。

若要将现有动画序列应用于其他对象，请执行以下操作：

  1. 在“时间轴”面板中，选择动画序列并将其拷贝。
  2. 单击“时间轴”面板的任一帧，然后在该帧处粘贴动画序列。
  3. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 粘贴的动画序列，然后从上下文菜单中选择“更改对象”。
  4. 在出现的对话框中，从弹出式菜单中选择另一对象并单击“确定”。
  5. 对于要遵循同一动画序列的其他所有对象，重复第 2 步到第 4 步。

创建动画序列后，您也可以改变关于制作哪一个层的动画的决定；只需执行上面的第 3 步和第 4 步即可（不必进行拷贝或粘贴）。


重命名时间轴

可以重命名时间轴。

若要重命名当前在“时间轴”面板中显示的时间轴，请执行以下操作：

  1. 选择“修改”>“时间轴”>“重命名时间轴”。
  2. 在“重命名时间轴”对话框中输入新的名称。

如果您的文档包含“播放时间轴”行为操作（例如，如果它包含访问者必须单击才能启动时间轴的按钮），则必须编辑该行为以反映新的时间轴名称。


时间轴动画小技巧

以下建议可以提高动画的性能并使动画更易于创建：

  • 显示和隐藏层，而不是更改多图像动画的源文件。由于新的图像必须进行下载，所以切换图像的源文件会降低动画的速度。如果所有图像都在动画运行前在隐藏层中同时下载，将不会出现明显的停顿，并且不会缺少图像。
  • 扩展动画条以创建更顺畅的动作。如果动画断断续续并且图像在不同位置之间跳动，请拖动该层动画条的结束帧，使动作延伸到更多的帧。通过延长动画条，可以在运动的开始点和结束点之间创建更多的数据点，同时也会使对象更为缓慢地移动。请尝试增加每秒帧数 (fps) 以提高速度，但应注意在普通系统上运行的大多数浏览器都不能支持超过 15 fps 的动画速度。请在不同的系统上用不同的浏览器对动画进行测试，以找到最佳的设置。
  • 不要制作大型位图的动画。制作大型图像的动画会导致动画速度减慢。相反，应创建合成图像，并移动图像中较小的部分。例如，可以通过仅制作汽车轮胎的动画来显示汽车的运动。
  • 创建简单的动画。不要创建对当前浏览器要求过高的动画。即使在系统或 Internet 性能降低时，浏览器始终会播放时间轴动画中的每一帧。


插入 div 标签进行布局

可以使用 div 标签创建 CSS 布局块并在文档中对它们进行定位。如果有一个带有附加到文档的定位样式的现有 CSS 样式表，使用该标签将非常有用。Dreamweaver 使您能够快速插入 div 标签并对其应用现有样式。

注意

您可以将 Dreamweaver 设计文件用作 CSS 布局的起始点。从“新建文档”对话框的“页面设计 (CSS)”类别中选择一个文件（请参见创建基于 Dreamweaver 设计文件的文档）。

若要插入 div 标签，请执行以下操作：

  1. 在“文档”窗口中，将插入点放置在要显示 div 标签的位置。
  2. 执行下列操作之一：
    • 选择“插入”>“布局对象”>“Div 标签”。
    • 在“插入”栏的“布局”类别中单击“Div 标签”按钮。 这是所描述的功能的图片。

    出现“插入 Div 标签”对话框。

  3. 完成对话框。

    有关更多信息，请参见设置“插入 Div 标签”对话框选项。

  4. 单击“确定”。

    div 标签以一个框的形式出现文档中，并带有占位符文本。将指针移到该框的边缘上时，Dreamweaver 会高亮显示该框。

如果已经给 div 标签分配了绝对位置，它就可充当一个 Dreamweaver 层。有关使用层的信息，请参见设置层首选参数和属性、管理层或操作层。

有关处理未绝对定位的 div 标签的信息，请参见使用 div 标签进行布局。

相关主题

  • 更改 div 标签的高亮颜色
  • 使用 div 标签进行布局


使用 div 标签进行布局

插入 div 标签（请参见插入 div 标签进行布局）后，您可以对其进行操作或者在其中添加内容。

注意

绝对定位的 div 标签为 Dreamweaver 层。有关使用这些 div 标签的信息，请跳过本部分，并参见设置层首选参数和属性、管理层或操作层。

在为 div 标签分配了边框后，或者在选定了“CSS 布局外框”后，Div 标签便具有可视边框。（默认情况下，“查看”>“可视化助理”菜单中已经选定了“CSS 布局外框”。）将指针移到 div 标签上时，Dreamweaver 将高亮显示此标签。要更改高亮颜色或禁用高亮显示功能，请参见更改 div 标签的高亮颜色。

在选择 div 标签时，可以在“CSS 样式”面板中查看和编辑它的规则。您也可以向 div 标签添加内容，方法是：将插入点放在 div 标签中，然后就像在页面中添加内容那样添加内容。

若要查看和编辑应用于 div 标签的规则，请执行以下操作：

  1. 执行以下操作之一以选择 div 标签：
    • 单击 div 标签的边框。

      提示

      查找标记色彩以查看边框。
    • 在 div 标签内单击，然后按两次 Ctrl+A (Windows) 或 Command+A (Macintosh)。
    • 在 div 标签内单击，然后从“文档”窗口底部的标签选择器中选择 div 标签。
  2. 如果“CSS 样式”面板尚未打开，请选择“窗口”>“CSS 样式”以打开“CSS 样式”面板。

    应用于 div 标签的规则显示在面板中。

  3. 根据需要进行编辑。

若要在 div 标签中放置插入点以添加内容，请执行以下操作：

  • 在该标签边框内的任意位置单击。

若要更改 div 标签中的占位符文本，请执行以下操作：

  • 选择该文本，然后在它上面键入内容或按 Delete 键。

    注意

    就像在页面中添加内容那样，可以将内容添加到 div 标签中。

相关主题

  • 插入 div 标签进行布局
  • 使用“CSS 样式”面板


更改 div 标签的高亮颜色

在“设计”视图中将指针移到 div 标签的边缘上时，Dreamweaver 将高亮显示标签的边框。如果需要，可以启用或禁用高亮显示功能，或者在“首选参数”对话框中更改高亮颜色。

若要更改 div 标签的高亮显示首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或Dreamweaver>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从左侧的类别列表中选择“标记色彩”。
  3. 进行下面其中一项更改：
    • 若要更改 div 标签的高亮颜色，请单击“鼠标滑过”颜色框并使用颜色选择器来选择一种高亮颜色（或在文本框中输入高亮颜色的十六进制值）。

      有关使用颜色选择器的信息，请参见使用颜色。

    • 若要对 div 标签启用或禁用高亮显示功能，请选择或取消选择“鼠标滑过”的“显示”复选框。

      注意

      这些选项会影响当指针滑过时 Dreamweaver 会高亮显示的所有对象，例如表格。
  4. 单击“确定”。


处理 CSS 布局可视化

Dreamweaver 包括许多可视化功能，这些功能允许在“设计”视图中显示 CSS 布局的元素。例如，可以显示未分配有边框的 div 标签的外框，也可以显示 div 标签的临时背景颜色，以便能够在页面上查看它们的位置。

本节包括以下主题：

  • 关于 CSS 布局可视化
  • 查看 CSS 布局块
  • 将设计时间样式表与 CSS 布局块一起使用


关于 CSS 布局可视化

在“设计”视图中工作时，Dreamweaver 允许您显现 CSS 布局块。CSS 布局块是一个 HTML 页面元素，您可以将它定位在页面上的任意位置。更具体地说，CSS 布局块是不带 display:inline 的 div 标签，或者是包括 display:block、position:absolute 或 position:relative CSS 声明的任何其他页面元素。下面是几个在 Dreamweaver 中被视为 CSS 布局块的元素示例：

  • div 标签
  • 指定了绝对或相对位置的图像
  • 指定了 display:block 样式的 a 标签
  • 指定了绝对或相对位置的段落

    注意

    出于可视化呈现的目的，CSS 布局块不包含内联元素（也就是代码位于一行文本中的元素）或段落之类的简单块元素。

Dreamweaver 提供了多个可视化助理，供您查看 CSS 布局块。例如，在设计时可以为 CSS 布局块启用外框、背景和框模型。将鼠标指针移动到布局块上时，也可以查看显示有选定 CSS 布局块属性的工具提示。

下面的 CSS 布局块可视化助理列表描述 Dreamweaver 为每个助理呈现的可视化内容：

CSS 布局外框向您显示页面上所有 CSS 布局块的外框。

CSS 布局背景向您显示各个 CSS 布局块的临时指定背景颜色，并隐藏通常出现在页面上的所有其他背景颜色或图像。

每次启用可视化助理查看 CSS 布局块背景时，Dreamweaver 都会自动为每个 CSS 布局块分配一种不同的背景颜色。（Dreamweaver 使用算法自动选择颜色 － 您无法自行指定颜色。）指定的颜色在视觉上与众不同，可帮助您区分不同的 CSS 布局块。

CSS 布局框模型向您显示所选 CSS 布局块的框模型（即填充和边界）。

相关主题

  • 查看 CSS 布局块
  • 将设计时间样式表与 CSS 布局块一起使用


查看 CSS 布局块

如果需要，可以启用或禁用 CSS 布局块可视化助理。有关每个可视化助理所呈现的内容的说明，请参见关于 CSS 布局可视化。

若要查看 CSS 布局块外框，请执行以下操作：

  • 选择“查看”>“可视化助理”>“CSS 布局外框”。

若要查看 CSS 布局块背景，请执行以下操作：

  • 选择“查看”>“可视化助理”>“CSS 布局背景”。

若要查看 CSS 布局块框模型，请执行以下操作：

  • 选择“查看”>“可视化助理”>“CSS 布局框模型”。

通过单击“文档”工具栏上的“可视化助理”按钮，也可以使用 CSS 布局块可视化助理选项。

相关主题

  • 将设计时间样式表与 CSS 布局块一起使用


将设计时间样式表与 CSS 布局块一起使用

可以使用设计时间样式表来显示通常未被视为 CSS 布局块的元素的背景、边框或框模型。为此，必须首先创建设计时间样式表，此表会将 display:block 属性分配给相应页面元素。

若要将 CSS 布局块可视化助理与非 CSS 布局块的元素一起使用，请执行以下操作：

  1. 创建外部 CSS 样式表，方法是：选择“文件”>“新建”，然后在“类别”列中选择“基本页”，在“基本页”列中选择“CSS”，然后单击“创建”。
  2. 在新样式表中，创建规则，这些规则会将 display:block 属性分配给要显示为 CSS 布局块的页面元素。

    例如，如果要显示段落和列表项目的背景颜色，可以创建具有以下规则的样式表：

    p{
display:block;
}
li{
display:block;
}
  3. 保存此文件。
  4. 在“设计”视图中，打开要附加新样式的页面。
  5. 选择“文本”>“CSS 样式”>“设计时间”。
  6. 在“设计时间样式表”对话框中，单击“只在设计时显示”文本框上方的加号 (+) 按钮，选择刚才创建的样式表，然后单击“确定”。
  7. 单击“确定”以关闭“设计时间样式表”对话框。

    样式表将附加到文档中。如果使用上面的示例创建了样式表，则会使用 display:block 属性对所有段落和列表项目进行格式设置，从而允许对段落和列表项目启用或禁用 CSS 布局块可视化助理。

相关主题

  • 关于 CSS 布局可视化
  • 查看 CSS 布局块
  • 使用设计时间样式表


使用标尺、辅助线和网格设计页面布局

在“文档”窗口的“设计”视图中，可以使用标尺、辅助线和网格等可视化助理对元素进行定位、测量或调整元素大小。


使用标尺

标尺可帮助您测量、组织和规划布局。标尺可以显示在页面的左边框和上边框中，以像素、英寸或厘米为单位来标记。

若要更改标尺设置，请执行以下操作之一：

  • 若要在打开和关闭状态之间切换标尺，请选择“查看”>“标尺”>“显示”。
  • 要更改原点，请将标尺原点图标（在“文档”窗口的“设计”视图左上角）拖到页面上的任意位置。

    若要将原点重设到它的默认位置，请选择“查看”>“标尺”>“重设原点”。

  • 若要更改度量单位，请从“查看”>“标尺”子菜单中选择“像素”、“英寸”或“厘米”。


使用辅助线

辅助线是您从标尺拖动到文档上的线条。它们有助于更加准确地放置和对齐对象。您还可以使用辅助线来测量页面元素的大小，或者模拟 Web 浏览器的重叠部分（可见区域）。

为了帮助您对齐元素，Dreamweaver 允许您将元素靠齐辅助线，以及将辅助线靠齐元素。（只有在将元素绝对定位的情况下，才可使用靠齐功能。）您还可以锁定辅助线，以防止其他用户不小心移动它们。

若要创建水平辅助线或垂直辅助线，请执行以下操作：

  1. 从相应的标尺拖动。
  2. 在“文档”窗口中定位辅助线，然后松开鼠标按钮。

    可以通过再次拖动辅助线来重新定位辅助线。

    注意

    默认情况下，以绝对像素度量值来记录辅助线与文档顶部或左侧的距离，并相对于标尺原点显示辅助线。若要以百分比形式记录辅助线，可在创建或移动辅助线时按住 Shift 键。

若要显示或隐藏辅助线，请执行以下操作：

  • 选择“查看”>“辅助线”>“显示辅助线”。

若要将元素靠齐辅助线，请执行以下操作：

  • 选择“查看”>“辅助线”>“靠齐辅助线”。

    注意

    当您调整元素（例如层、表格和图像）大小时，被调整大小的元素会靠齐辅助线。

若要将辅助线靠齐元素，请执行以下操作：

  • 选择“查看”>“辅助线”>“辅助线靠齐元素”。

若要锁定或解锁所有辅助线，请执行以下操作：

  • 选择“查看”>“辅助线”>“锁定辅助线”。

若要将辅助线移至特定位置，请执行以下操作：

  1. 双击该辅助线。
  2. 在“移动辅助线”对话框中输入新的位置，然后单击“确定”。

若要查看辅助线的位置，请执行以下操作：

  • 将鼠标指针停留在辅助线上。

若要查看辅助线之间的距离，请执行以下操作：

  • 按下 Ctrl 键 (Windows) 或 Command 键 (Macintosh)，并将鼠标指针保持在两条辅助线之间的任何位置。

    注意

    度量单位与用于标尺的度量单位相同。

若要更改辅助线颜色，请执行以下操作：

  1. 选择“查看”>“辅助线”>“编辑辅助线”。
  2. 从“辅助线颜色”弹出式菜单中选择新的辅助线颜色，然后单击“确定”。

若要更改表示辅助线之间距离的颜色，请执行以下操作：

  1. 选择“查看”>“辅助线”>“编辑辅助线”。
  2. 从“距离颜色”弹出式菜单中选择颜色，然后单击“确定”。

若要模拟 Web 浏览器的重叠部分（可见区域），请执行以下操作：

  • 选择“查看”>“辅助线”，然后从菜单中选择一个预设的浏览器大小。

若要删除一个辅助线，请执行以下操作：

  • 将辅助线拖离文档。

若要清除所有辅助线，请执行以下操作：

  • 选择“查看”>“辅助线”>“清除辅助线”。

将辅助线用于模板

将辅助线添加到 Dreamweaver 模板之后，模板的所有实例都会继承辅助线。不过，模板实例中的辅助线被视为可编辑区域，因此用户可以修改它们。当模板实例被主模板更新时，模板实例中经过修改的辅助线总会恢复到它们的原始位置。

还可以向模板实例中添加自己的辅助线。当模板实例被主模板更新时，不会覆盖以这种方式添加的辅助线。

相关主题

  • 调整层大小
  • 移动层
  • 对齐层


使用网格

网格在“文档”窗口中显示一系列的水平线和垂直线。它对于精确地放置对象很有用。您可以让经过绝对定位的页元素在移动时自动靠齐网格，还可以通过指定网格设置更改网格或控制靠齐行为。无论网格是否可见，都可以使用靠齐。

若要显示或隐藏网格，请执行以下操作：

  • 选择“查看”>“网格”>“显示网格”。

若要启用或禁用靠齐，请执行以下操作：

  • 选择“查看”>“网格”>“靠齐到网格”。

若要更改网格设置，请执行以下操作：

  1. 选择“查看”>“网格”>“网格设置”。

    出现“网格设置”对话框。

  2. 按需要设置选项。

    有关更多信息，请参见设置“网格设置”对话框选项。

  3. 单击“确定”。

相关主题

  • 调整层大小
  • 移动层
  • 对齐层


使用跟踪图像

可以使用跟踪图像作为重新创建已经使用图形应用程序（如 Macromedia Freehand 或 Fireworks）创建的页面设计的指导。

跟踪图像是放在“文档”窗口背景中的 JPEG、GIF 或 PNG 图像。可以隐藏图像、设置图像的不透明度和更改图像的位置。

若要将跟踪图像放在“文档”窗口中，请执行以下操作：

  1. 执行下列操作之一：
    • 选择“查看”>“跟踪图像”>“载入”。
    • 选择“修改”>“页面属性”，然后单击“跟踪图像”文本框旁边的“浏览”按钮。
  2. 在出现的对话框中，选择图像文件并单击“选择”(Windows) 或“选择”(Macintosh)。

    “页面属性”对话框随即出现。

  3. 拖动“图像透明度”滑块指定图像的透明度，然后单击“确定”。

若要随时切换到另一跟踪图像或更改当前跟踪图像的透明度，请选择“修改”>“页面属性”。

若要显示或隐藏跟踪图像，请执行以下操作：

  • 选择“查看”>“跟踪图像”>“显示”。

仅在 Dreamweaver 中跟踪图像是可见的。当在浏览器中查看页面时，跟踪图像永远不可见。当跟踪图像可见时，“文档”窗口将不会显示页面的实际背景图像和颜色；但是，在浏览器中查看页面时，背景图像和颜色是可见的。

若要更改跟踪图像的位置，请执行以下操作：

  1. 选择“查看”>“跟踪图像”>“调整位置”。
  2. 执行下列操作之一：
    • 若要准确地指定跟踪图像的位置，请在“X”和“Y”文本框中输入坐标值。
    • 若要逐个像素地移动图像，请使用箭头键。
    • 若要一次五个像素地移动图像，请按 Shift 键和箭头键。

若要重设跟踪图像的位置，请执行以下操作：

  • 选择“查看”>“跟踪图像”>“重设位置”。

    跟踪图像随即返回到“文档”窗口的左上角 (0,0)。

若要将跟踪图像与所选元素对齐，请执行以下操作：

  1. 在“文档”窗口中选择一个元素。
  2. 选择“查看”>“跟踪图像”>“对齐所选范围”。

    跟踪图像的左上角随即与所选元素的左上角对齐。


参考资料

本节提供在本章介绍的下列对话框和检查器的有关信息：

  • 设置“插入 Div 标签”对话框选项
  • 设置 Div 标签属性
  • 设置“层首选参数”对话框选项
  • 设置层属性
  • 设置多个层的属性
  • 设置“将层转换为表格”对话框选项
  • 设置“转换表格为层”对话框选项
  • 设置“网格设置”对话框选项
  • 设置“辅助线”对话框选项


设置“插入 Div 标签”对话框选项

该对话框用于插入 div 标签来创建 CSS 布局块。

若要完成“插入 Div 标签”对话框，请执行以下操作：

  1. 从“插入”弹出式菜单中选择一个插入点，以指示要显示 div 标签的位置。
  2. （可选）单击“新建 CSS 规则”按钮，打开“新建 CSS 规则”对话框，并创建新的样式。
  3. 如果选择“标签之前”、“标签结束之前”、“标签之后”或“标签开始之后”，请从右边的弹出式菜单中选择标签。
  4. （可选）从弹出式菜单中选择一个类。

    如果附加了样式表，则该样式表中定义的类将出现在列表中。

  5. （可选）从弹出式菜单中选择一个 ID。

    如果附加了样式表，则该样式表中定义的 ID 将出现在列表中。Dreamweaver 不会列出文档中现有块的 ID。

    注意

    Dreamweaver 会在您在文档中输入与其他标签相同的 ID 时提醒您。

相关主题

  • 插入 div 标签进行布局


设置 Div 标签属性

使用“属性”检查器来设置用于创建 CSS 布局块的 div 标签的属性。

若要设置 div 标签的属性，请执行以下操作：

  • 设置以下任一选项：

    Div ID 允许您更改用于标识 div 标签的名称。

    类显示了当前应用于标签的类样式。使用此弹出式菜单执行下列任何操作：

    • 选择要应用于标签的样式。
    • 选择“无”删除当前所选样式。
    • 选择“附加样式表”以打开一个允许您附加外部样式表的对话框。

    “编辑 CSS”将打开“CSS 样式”面板。


设置“层首选参数”对话框选项

此对话框用于设置层首选参数。

若要完成“层首选参数”对话框，请执行以下操作：

  1. 指定以下任意选项：

    可见性确定层在默认情况下是否可见。

    其选项为“默认”、“继承”、“可见”和“隐藏”。有关这些选项的更多信息，请参见设置层属性。

    宽和高指定您使用“插入”>“层”创建的层的默认宽度和高度（以像素为单位）。

    背景颜色指定默认的背景颜色。

    请从颜色选择器中选择颜色。

    背景图像指定默认的背景图像。

    单击“浏览”可在计算机上查找图像文件。

    嵌套：在层中创建时嵌套指定从现有层边界内的某点开始绘制的层是否应该是嵌套层。当绘制层时，按下 Alt 键 (Windows) 或 Option 键 (Macintosh) 可临时更改此设置。

    Netscape 4 兼容性：插入层时添加调整大小修复在文档的 head 内容中插入 JavaScript 代码以修正 Netscape 4 浏览器中的一个已知问题，该问题使层在访问者调整浏览器窗口大小时失去它们的定位坐标。

    每当调整浏览器窗口大小时，JavaScript 会强制页重新加载，从而将层重分配到正确的位置。您也可以手动添加或删除 JavaScript 代码，方法是选择“命令”>“添加/删除 Netscape 调整大小修复”。

  2. 单击“确定”。

相关主题

  • 设置层首选参数


设置层属性

使用“属性”检查器查看和设置层的属性。

若要设置层的属性，请执行以下操作：

  1. 设置以下任一选项：

    层 ID 用于指定一个名称，以便在“层”面板和 JavaScript 代码中标识该层。

    请输入一个名称。只应使用标准的字母数字字符，而不要使用空格、连字符、斜杠或句号等特殊字符。每个层都必须有它自己的唯一 ID。

    左和上（左侧和顶部）指定层的左上角相对于页面（如果嵌套，则为父层）左上角的位置。

    宽和高指定层的宽度和高度。

    注意

    如果层的内容超过指定大小，层的底边缘（按照在Dreamweaver设计视图中的显示）会延伸以容纳这些内容。（如果“溢出”属性没有设置为“可见”，那么当层在浏览器中出现时，底边缘将不会延伸。）

    位置和大小的默认单位为像素 (px)。您也可以指定以下单位：pc (pica)、pt（点）、in（英寸）、mm（毫米）、cm（厘米）或 %（父层相应值的百分比）。缩写必须紧跟在值之后，中间不留空格：例如，3mm 表示 3 毫米。

    Z 轴确定层的 z 轴（即堆叠顺序）。

    在浏览器中，编号较大的层出现在编号较小的层的前面。值可以为正，也可以为负。当更改层的堆叠顺序时，使用“层”面板要比输入特定的 z 轴值更为简便（请参见更改层的层叠顺序）。

    注意

    Netscape 层（使用 layer 或 ilayer 标签的层）可以相对于页面上的其他层进行堆叠。当选择 Netscape 层时，“属性”检查器的右下角会出现两个附加的选项。请从右下角的新弹出式菜单中选择另一个层的名称（只有已定义的层名称才会出现在此菜单中）；然后使用之上/之下选项指示指定的层应出现在当前层之上（之前）还是当前层之下（之后）。请注意，不能同时为某一给定层指定“之上/之下”堆叠顺序和 z 轴。

    可见性指定该层最初是否是可见的。从以下选项中选择：

    • “默认”不指定可见性属性。

      当未指定可见性时，大多数浏览器都会默认为“继承”。

    • “继承”使用该层父级的可见性属性。
    • “可见”显示这些层的内容，而不管父级的值是什么。
    • “隐藏”隐藏这些层的内容，而不管父级的值是什么。

      请注意，用 ilayer 创建的隐藏层会像它们是可见层一样占用相同的空间。

    使用脚本撰写语言（如 JavaScript）可控制可见性属性并动态地显示层的内容。

    背景图像指定层的背景图像。

    单击其文件夹图标可浏览到一个图像文件并将其选定。

    背景颜色指定层的背景颜色。

    如果将此选项留为空白，则可以指定透明的背景。

    标签指定用来定义该层的 HTML 标签。

    溢出控制当层的内容超过层的指定大小时如何在浏览器中显示层。

    “可见”指示在层中显示额外的内容；实际上，该层会通过延伸来容纳额外的内容。“隐藏”指定不在浏览器中显示额外的内容。“滚动”指定浏览器应在层上添加滚动条，而不管是否需要滚动条。“自动”使浏览器仅在需要时（即，当层的内容超过其边界时）才显示层的滚动条。

    注意

    “选项在不同的浏览器中会获得不同程度的支持。

    使用左、上或页 X、页 Y（仅限 layer 和 ilayer）来指定是相对于层的父级还是相对于页来定位层。

    “左、上”选项相对于层父级的左上角来放置层。“页 X、页 Y”选项相对于页面左上角将层放置于某一绝对位置，而不考虑父层的位置。

    剪辑定义层的可见区域。

    指定左侧、顶部、右侧和底边坐标可在层的坐标空间中定义一个矩形（从层的左上角开始计算）。层经过“剪辑”后，只有指定的矩形区域才是可见的。例如，若要使一个层中左上角 50 像素宽 75 像素高的矩形区域可见而其他内容均不可见，请将“左”设置为 0，将“上”设置为 0，将“右”设置为 50，将“下”设置为 75。

    注意

    虽然层叠样式表规范为 clip 指定了不同的语义，但 Dreamweaver 解释 clip 的方式与大多数浏览器相同。

    源文件（仅限 layer 和 ilayer）用于在层中显示另一个 HTML 文档。单击其文件夹图标可浏览到该文档并将其选定。

    请注意，Dreamweaver 不在层中显示另一文档。

  2. 如果您在文本框中输入了值，则可以按 Tab 键或Enter 键 (Windows) 或 Return 键 (Macintosh) 来应用该值。

相关主题

  • 查看和设置单个层的属性


设置多个层的属性

使用“属性”检查器查看和设置多个层的属性。

若要同时设置多个层的属性，请执行以下操作：

  1. 设置以下任一选项：

    左和上（左侧和顶部）指定层的左上角相对于页（如果嵌套，则为父层）的左上角的位置。

    宽和高指定层的宽度和高度。

    注意

    如果任何层的内容超过指定的大小，该层的底边缘（按照在Dreamweaver设计视图中的显示）会延伸以容纳这些内容。（如果“溢出”属性没有设置为“可见”，那么当层在浏览器中出现时，底边缘将不会延伸。）

    位置和大小的默认单位为像素 (px)。您也可以指定以下单位：pc (pica)、pt（点）、in（英寸）、mm（毫米）、cm（厘米）或 %（父层相应值的百分比）。缩写必须紧跟在值之后，中间不留空格：例如，3mm 表示 3 毫米。

    可见性指定这些层最初是否是可见的。从以下选项中选择：

    • “默认”不指定可见性属性。

      当未指定可见性时，大多数浏览器都会默认为“继承”。

    • “继承”使用该层父级的可见性属性。
    • “可见”显示这些层的内容，而不管父级的值是什么。
    • “隐藏”隐藏这些层的内容，而不管父级的值是什么。

      请注意，用 ilayer 创建的隐藏层会像它们是可见层一样占用相同的空间。

    使用脚本撰写语言（如 JavaScript）可控制可见性属性并动态地显示层的内容。

    标签指定用来定义这些层的 HTML 标签。

    背景图像指定这些层的背景图像。

    单击其文件夹图标可浏览到一个图像文件并将其选定。

    背景颜色指定这些层的背景颜色。

    如果将此选项留为空白，则可以指定透明的背景。

  2. 如果您在文本框中输入了值，则可以按 Tab 键或Enter 键 (Windows) 或 Return 键 (Macintosh) 来应用该值。

相关主题

  • 查看和设置多个层的属性


设置“将层转换为表格”对话框选项

此对话框用于将层转换为表格，以更好地兼容较早的浏览器。

若要完成“转换层为表格”对话框，请执行以下操作：

  1. 指定以下任意选项：

    最精确为每个层创建一个单元格，并附加保留层之间的空间所必需的任何单元格。

    最小:合并空白单元指定如果层定位在指定数目的像素内，则层的边缘应对齐。

    如果选择此选项，结果表将包含较少的空行和空列，但可能不与您的布局精确匹配。

    使用透明 GIF 用透明的 GIF 填充表的最后一行。这将确保该表在所有浏览器中以相同的列宽显示。

    当启用此选项后，不能通过拖动表列来编辑结果表。当禁用此选项后，结果表将不包含透明 GIF，但在不同的浏览器中可能会具有不同的列宽。

    置于页面中央将结果表放置在页面的中央。

    如果禁用此选项，表将在页面的左边缘开始。

  2. 选择所需的布局工具和网格选项，然后单击“确定”。

相关主题

  • 将层转换为表格


设置“转换表格为层”对话框选项

此对话框用于将表格转换为层。

若要完成“转换表格为层”对话框，请执行以下操作：

  1. 指定以下任意选项：

    显示网格和靠齐到网格使您能够使用网格来协助对层进行定位（请参见使用跟踪图像）。

    防止层重叠在创建、移动层和调整层大小时约束层的位置，使层不会重叠（请参见防止层重叠）。

    显示层面板显示“层”面板（请参见使用“层”面板）。

  2. 单击“确定”。

表格即转换为层。空单元格不会转换为层（除非它们具有背景颜色）。

注意

位于表格外的页面元素也会放入层中。

相关主题

  • 将层转换为表格


设置“网格设置”对话框选项

此对话框用于编辑网格设置。

若要完成“网格设置”对话框，请执行以下操作：

  1. 根据需要设置以下选项：

    颜色指定网格线的颜色。

    请单击色样表并从颜色选择器中选择一种颜色，或者在文本框中键入一个十六进制数字。

    显示网格使网格在“设计”视图中可见。

    靠齐到网格使页面元素靠齐到网格线。

    间距控制网格线的间距。

    在文本框中输入一个数字并从菜单中选择“像素”、“英寸”或“厘米”。

    显示指定网格线是显示为线条还是显示为点。

  2. 单击“应用”可应用更改而不关闭对话框，单击“确定”可应用更改并关闭对话框。

    注意

    如果未选择“显示网格”，将不会显示网格，并且看不到更改。

相关主题

  • 使用跟踪图像


设置“辅助线”对话框选项

此对话框用于编辑辅助线设置。

若要完成“辅助线”对话框，请执行以下操作：

  1. 设置以下选项：

    辅助线颜色指定辅助线的颜色。

    请单击色样表并从颜色选择器中选择一种颜色，或者在文本框中键入一个十六进制数字。

    距离颜色指定当您将鼠标指针保持在辅助线之间时，作为距离指示器出现的线条的颜色。

    请单击色样表并从颜色选择器中选择一种颜色，或者在文本框中键入一个十六进制数字。

    显示辅助线使辅助线在“设计”视图中可见。

    靠齐辅助线使页面元素在页面中移动时能靠齐辅助线。

    锁定辅助线将辅助线锁定在适当位置。

    辅助线靠齐元素在您拖动辅助线时将辅助线靠齐页面上的元素。

    清除全部从页面上清除所有辅助线。

  2. 单击“确定”。

相关主题

  • 使用辅助线


使用表格显示内容

表格是用于在页面上显示表格式数据以及对文本和图形进行布局的强有力的工具。

很多设计人员使用表格来对 Web 页进行布局。Macromedia Dreamweaver 8 提供了两种查看和操作表格的方式：在“标准”模式中，表格显示为行和列的网格，而“布局”模式允许您在将表格用作基础结构的同时在页面上绘制、调整方框的大小以及移动方框（请参见在“布局模式”对页进行布局）。

注意

您还可以使用 CSS 定位来对页进行布局（请参见使用 CSS 对页进行布局）。

本章包含下列章节：

关于表格

插入一个表格并添加内容

导入和导出表格式数据

选择表格元素

使用“扩展表格”模式更容易编辑表格

设置表格和单元格的格式

调整表格、列和行的大小

添加及删除行和列

拆分和合并单元格

复制、粘贴和删除单元格

嵌套表格

对表格进行排序


关于表格

表格是用于在 HTML 页上显示表格式数据以及对文本和图形进行布局的强有力的工具。表格由一行或多行组成；每行又由一个或多个单元格组成。虽然 HTML 代码中通常不明确指定列，但 Dreamweaver 允许您操作列、行和单元格。

当选定了表格或表格中有插入点时，Dreamweaver 会显示表格宽度和每个表格列的列宽。宽度旁边是表格标题菜单与列标题菜单的箭头。使用菜单可以快速访问一些与表格相关的常用命令。根据需要可以启用或禁用宽度和菜单（请参见显示表格和列的宽度和菜单）。

如果您未看到表的宽度或列的宽度，说明没有在 HTML 代码中指定该表或列的宽度。如果出现两个数字，说明“设计”视图中显示的可视宽度与 HTML 代码中指定的宽度不一致。当拖动表格的右下角来调整表格的大小，或将内容添加到比设置宽度大的单元格时会发生这种情况。

例如，如果您将某列的宽度设置为 200 像素，而添加的内容将宽度延长为 250 像素，则该列将显示两个数字：“200”（代码中指定的宽度）和“(250)”（位于括号中，表示该列呈现在屏幕上的可视宽度）。

要协调列宽度，请参见使代码中的列宽与可视宽度一致。

本节包含以下概念性主题：

  • HTML 中的表格格式设置优先顺序
  • 关于拆分和合并表格单元格

相关主题

  • 插入一个表格并添加内容


HTML 中的表格格式设置优先顺序

当在“设计”视图中对表格进行格式设置时，您可以设置整个表格或表格中所选行、列或单元格的属性。如果将整个表格的某个属性（例如背景颜色或对齐）设置为一个值，而将单个单元格的属性设置为另一个值，则单元格格式设置优先于行格式设置，行格式设置又优先于表格格式设置。

表格格式设置的优先顺序如下：

  1. 单元格
  2. 行
  3. 表格

例如，如果将单个单元格的背景颜色设置为蓝色，然后将整个表格的背景颜色设置为黄色，则蓝色单元格不会变为黄色，因为单元格格式设置优先于表格格式设置。

注意

当设置列的属性时，Dreamweaver 更改对应于该列中每个单元格的 td 标签的属性。

相关主题

  • 设置表格和单元格的格式


关于拆分和合并表格单元格

只要整个选择部分的单元格形成一行或一个矩形，您便可以合并任意数目的相邻的单元格，以生成一个跨多个列或行的单元格。您可以将单元格拆分成任意数目的行或列，而不管之前它是否是合并的。Dreamweaver 可以自动重新构造表格（添加任何必需的 colspan 或 rowspan 属性），以创建指定的排列方式。

在下面的插图中，前两行中间的单元格已经合并成一个跨两行的单元格。

相关主题

  • 拆分和合并单元格


插入一个表格并添加内容

使用“插入”栏或“插入”菜单来创建一个新表格。然后，按照在表格外添加文本和图像的方式，向表格单元格中添加文本和图像（请参见插入文本和设置文本格式和插入图像）。

若要插入表格，请执行以下操作：

  1. 在“文档”窗口的“设计”视图中，将插入点放在需要表格出现的位置。

    注意

    如果您的文档是空白的，则只能将插入点放置在文档的开头。
  2. 执行下列操作之一：
    • 选择“插入”>“表格”。
    • 在“插入”栏的“常用”类别中，单击“表格”按钮。

    即会出现“表格”对话框。

  3. 完成对话框。

    有关更多信息，请参见设置“表格”对话框选项。

  4. 单击“确定”。

表格即出现在文档中。

相关主题

  • 查看和设置表格、单元格、行和列的属性
  • 编辑表格的辅助功能属性


导入和导出表格式数据

可以将在另一个应用程序（例如 Microsoft Excel）中创建并以分隔文本的格式（其中的项以制表符、逗号、冒号、分号或其他分隔符隔开）保存的表格式数据导入到 Dreamweaver 中并设置为表格的格式。

您也可以将表格数据从 Dreamweaver 导出到文本文件中，相邻单元格的内容由分隔符隔开。您可以使用逗号、冒号、分号或空格作为分隔符。当导出表格时，将导出整个表格，您不能选择导出部分表格。

提示

如果只需要表格中的某些数据（例如前六行或前六列），则复制包含这些数据的单元格，将这些单元格粘贴到表格外（创建新表格），然后导出这个新表格。

若要导入表格数据，请执行以下操作：

  1. 执行下列操作之一：
    • 选择“文件”>“导入”>“表格式数据”。
    • 选择“插入”>“表格对象”>“导入表格式数据”。

    即会出现“导入表格式数据”对话框。

  2. 在该对话框中，输入有关包含数据的文件的信息。

    有关更多信息，请参见设置“导入表格式数据”对话框选项。

  3. 单击“确定”。

若要导出表格，请执行以下操作：

  1. 请将插入点放置在表格中的任意单元格中。
  2. 选择“文件”>“导出”>“表格”。

    即会出现“导出表格”对话框。

  3. 在“导出表格”对话框中，指定导出表格的选项。

    有关更多信息，请参见设置“导出表格”对话框选项。

  4. 单击“导出”。

    即会出现“导出表格为”对话框。

  5. 输入文件名称。
  6. 单击“保存”。


选择表格元素

可以一次选择整个表、行或列。也可以选择一个或多个单独的单元格。

当您将鼠标指针移动到表格、行、列或单元格上时，Dreamweaver 将高亮显示选择区域中的所有单元格，以便您确切了解选中了哪些单元格。当您的表格没有边框、单元格跨多列或多行或者表格嵌套时，这一点很有用。可以在首选参数中更改高亮颜色。

提示

如果您将鼠标指针定位到表格边框上，则按住 Ctrl 键 (Windows) 或 Command (Macintosh)，则该表格的整个表格结构（即表格中的所有单元格）将高亮显示。当您的表格有嵌套并且希望查看其中一个表格的结构时，这一点很有用。

若要更改用于选择表格元素的高亮显示颜色，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或Dreamweaver>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从左侧的类别列表中选择“标记色彩”。
  3. 进行下面其中一项更改：
    • 要更改表格元素的高亮颜色，请单击“鼠标滑过”颜色框并使用颜色选择器来选择一种高亮颜色（或在文本框中输入高亮颜色的十六进制值）。

      有关使用颜色选择器的信息，请参见使用颜色。

    • 若要对表格元素启用或禁用高亮显示功能，请选择或取消选择“鼠标滑过”的“显示”复选框。

      注意

      这些选项会影响鼠标指针所到之处 Dreamweaver 高亮显示的所有对象，例如层和“布局”模式视图表格及单元格。
  4. 单击“确定”。

本节包含以下主题：

  • 选取表格
  • 选择行或列
  • 选择单元格

相关主题

  • 设置表格和单元格的格式
  • 调整表格、列和行的大小
  • 复制、粘贴和删除单元格


选取表格

可以使用多种方法一次选择整个表格。

若要选择整个表格，请执行以下操作之一：

  • 单击表格的左上角、表格的顶边缘或底边缘的任何位置或者行或列的边框。

    注意

    当您可以选择表格时，鼠标指针会变成表格网格图标（除非您单击行或列边框）。 这是所描述的功能的图片。

  • 单击某个表格单元格，然后在“文档”窗口左下角的标签选择器中选择 <table> 标签。
  • 单击某个表格单元格，然后选择“修改”>“表格”>“选择表格”。
  • 单击某个表格单元格，单击表格标题菜单，然后选择“选择表格”。

    所选表格的下边缘和右边缘出现选择柄。

相关主题

  • 选择行或列
  • 选择单元格


选择行或列

可以选择单个行或列或者多个行或列。

若要选择单个或多个行或列，请执行以下操作：

  1. 定位鼠标指针使其指向行的左边缘或列的上边缘。
  2. 当鼠标指针变为选择箭头时，单击以选择单个行或列，或进行拖动以选择多个行或列。

若要选择单个列，请执行以下操作：

  1. 在该列中单击。
  2. 单击列标题菜单，然后选择“选择列”。

相关主题

  • 选取表格
  • 选择单元格


选择单元格

可以选择单个单元格、一行单元格或单元格块或者不相邻的单元格。若要选择整个行或列，请参见选择行或列。

若要选择单个单元格，请执行以下操作之一：

  • 单击单元格，然后在“文档”窗口左下角的标签选择器中选择 <td> 标签。
  • 按住 Ctrl 键单击 (Windows) 或按住 Command 键单击 (Macintosh) 该单元格。
  • 单击单元格，然后选择“编辑”>“全选”。

    提示

    选择了一个单元格后再次选择“编辑”>“全选”可以选择整个表格。

若要选择一行或矩形的单元格块，请执行以下操作之一：

  • 从一个单元格拖到另一个单元格。
  • 单击一个单元格，在同一个单元格中按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 的同时单击以选中它，然后按住 Shift 键单击另一个单元格。

    这两个单元格定义的直线或矩形区域中的所有单元格都将被选中。

若要选择不相邻的单元格，请执行以下操作：

  • 在按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 的同时单击要选择的单元格、行或列。

    如果按住 Ctrl 键或 Command 键单击尚未选中的单元格、行或列，则会将其选中。如果它已经被选中，则再次单击会将其从选择中删除。

相关主题

  • 选取表格


使用“扩展表格”模式更容易编辑表格

“扩展表格”模式临时向文档中的所有表格添加单元格边距和间距，并且增加表格的边框以使编辑操作更加容易。利用这种模式，您可以选择表格中的项目或者精确地放置插入点。

例如，您可能扩展一个表格以便将插入点放置在图像的左边或右边，从而避免无意中选中该图像或表格单元格。

注意

一旦做出选择或放置插入点，您应该回到“设计”视图的“标准”模式来进行编辑。调整大小等的一些可视操作在“扩展表格”模式中不会产生预期结果。

若要切换到“扩展表格”模式，请执行以下操作：

  1. 如果您正在“代码”视图中工作，请选择“查看”>“设计”或“查看”>“代码和设计”。

    在“代码”视图中，您无法切换到“扩展表格”模式。

  2. 执行下列操作之一：
    • 选择“查看”>“表格模式”>“扩展表格模式”。
    • 在“插入”栏的“布局”类别中单击“扩展表格模式”按钮。

在“文档”窗口的顶部出现标有“扩展表格模式”的条。Dreamweaver 可向页上的所有表格添加单元格边距与间距，并增加表格边框。

若要切换到“扩展表格”模式，请执行下列操作之一：

  • 在“文档”窗口顶部标有“扩展表格模式”的条中，单击“退出”。
  • 选择“查看”>“表模式”>“标准模式”。
  • 在“插入”栏的“布局”类别中单击“标准模式”按钮。

Dreamweaver 返回到“标准”模式。


设置表格和单元格的格式

可以通过设置表格及表格单元格的属性或将预先设置的设计应用于表格来更改表格的外观。在设置表格和单元格的属性前，最好了解哪些属性优先于其他属性（请参见 HTML 中的表格格式设置优先顺序）。

提示

请按照设置表格外文本格式的过程，设置表格单元格内文本的格式。有关更多信息，请参见插入文本和设置文本格式。

本节包含以下主题：

  • 查看和设置表格、单元格、行和列的属性
  • 编辑表格的辅助功能属性
  • 使用设计方案对表格进行格式设置

相关主题

  • 调整表格、列和行的大小


查看和设置表格、单元格、行和列的属性

当选择了某个表格或单元格后，使用属性检查器可以查看和更改它的属性。

注意

在更改表格元素的属性前，最好了解哪些属性优先于其他属性（请参见 HTML 中的表格格式设置优先顺序）。

若要查看和设置表格或表格元素的属性，请执行以下操作：

  1. 选择表格、单元格、行或列（请参见选择表格元素）。
  2. 在“属性”检查器（“窗口”>“属性”）中，单击右下角的展开箭头，查看所有属性。
  3. 根据需要更改属性。

    有关更多信息，请参见设置表格属性或设置单元格、行和列属性。

    注意

    当设置列的属性时，Dreamweaver 更改对应于该列中每个单元格的 td 标签的属性。但是，当设置行的某些属性时，Dreamweaver 将更改 tr 标签的属性而不是行中每个 td 标签的属性。在将同一种格式应用于行中的所有单元格时，将格式应用于 tr 标签会生成更简明易懂的 HTML 代码。

相关主题

  • 编辑表格的辅助功能属性


编辑表格的辅助功能属性

如果您插入表格时没有为表格添加辅助功能属性（请参见插入一个表格并添加内容），但是以后需要添加这些属性，或者如果需要编辑辅助功能属性，您可以在“代码”视图或“设计”视图中添加或编辑辅助功能属性。

若要在“代码”视图中添加或编辑表格的辅助功能值，请执行以下操作：

  • 在代码中编辑适当的属性。

    提示

    若要快速找到代码中的标签，请单击表格，然后选择“文档”窗口底部的标签选择器中的 <table> 标签。

若要在“设计”视图中添加或编辑表格的辅助功能值，请执行以下操作之一：

  • 若要编辑表格题注，请高亮显示此题注，然后键入新题注。
  • 若要编辑题注对齐，请将插入点放置在表格的题注中，右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“编辑标签代码”。
  • 若要编辑表格摘要，请选择该表格，右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“编辑标签代码”。

相关主题

  • 查看和设置表格、单元格、行和列的属性


使用设计方案对表格进行格式设置

使用“表格格式设置”命令将预先设置的设计快速应用到表格。然后，您可以选择选项进一步自定义该设计。

注意

只有简单的表格才能使用预先设置的设计进行格式设置。您不能使用这些设计对包含合并单元格（colspan 或 rowspan）、列组或任何其他表格（这些表格不是由简单的矩形单元格网格组成）的表格进行格式设置。

若要使用预先设置的表格设计，请执行以下操作：

  1. 选择表格（请参见选取表格）。
  2. 选择“命令”>“表格格式设置”。

    即会出现“表格格式设置”对话框。

  3. 按需要自定义选项。

    有关更多信息，请参见设置“表格格式设置”对话框选项。

  4. 单击“应用”或“确定”用所选的设计对表格进行格式设置。


调整表格、列和行的大小

表格单元格如果调整大小比较麻烦，可以清除列宽或行高并重新开始。

有时 HTML 代码中设置的列宽度与它们在屏幕上的外观宽度不匹配。发生这种情况时，您可以使宽度一致。Dreamweaver 中可以显示表格与列的宽度和标题菜单，能够帮助您对表格进行布局；您可以根据需要启用或禁用宽度和菜单。

本节包含以下主题：

  • 调整表格大小
  • 调整列和行的大小
  • 使代码中的列宽与可视宽度一致
  • 清除设置的宽度和高度
  • 显示表格和列的宽度和菜单


调整表格大小

您可以通过拖动表格的一个选择柄来调整表格的大小。当选中表格或表格中有插入点时，Dreamweaver 将在该表格的顶部或底部显示表格宽度和表格标题菜单。

注意

如果需要，您可以禁用表格宽度和表格标题菜单（请参见显示表格和列的宽度和菜单）。

当调整整个表格的大小时，表格中的所有单元格按比例更改大小。如果表格的单元格指定了明确的宽度或高度，则调整表格大小将更改“文档”窗口中单元格的可视大小，但不更改这些单元格的指定宽度和高度。若要清除设置的宽度或高度，请参见清除设置的宽度和高度。

若要调整表格的大小，请执行以下操作：

  1. 选择该表格（请参见选取表格）。

    该表格周围出现选择柄。

  2. 执行下列操作之一：
    • 若要在水平方向调整表格的大小，请拖动右边的选择柄。
    • 若要在垂直方向调整表格的大小，请拖动底部的选择柄。
    • 若要在两个方向调整表格的大小，请拖动右下角的选择柄。

相关主题

  • 调整列和行的大小


调整列和行的大小

可在属性检查器中或通过拖动列或行的边框来更改列宽或行高。如果调整大小比较麻烦，可以清除列宽或行高然后重新开始（请参见清除设置的宽度和高度）。

注意

您还可以使用“代码”视图直接在 HTML 代码中更改单元格的宽度和高度。有关更多信息，请参见在 Dreamweaver 中编写代码。

当选中表格或表格中有插入点时，Dreamweaver 将在列的顶部或底部显示列宽度和列标题菜单。有关更多信息，请参见关于表格。

注意

如果需要，您可以禁用列宽度和列标题菜单（请参见显示表格和列的宽度和菜单）。

若要更改列宽度并保持整个表的宽度不变，请执行以下操作：

  • 拖动您想更改的列的右边框。

    相邻列的宽度也更改了，因此实际上调整了两列的大小。可视化反馈将显示如何对列进行调整；表格的总度不改变。

    注意

    在基于百分比宽度（而不是像素）的表格中，如果您拖动最右边的列的右边框，整个表格的宽度会变化，并且所有的列都会按比例的变宽或变窄。

若要更改某个列的宽度并保持其他列的大小不变，请执行以下操作：

  • 按住 Shift 键，然后拖动列的边框。

    这个列的宽度就会改变。可视化反馈将显示各列如何调整；表的总宽度将更改以容纳正在调整的列。

若要以可视方式调整行高，请执行以下操作：

  • 拖动行的下边框。

若要使用属性检查器设置列宽或行高，请执行以下操作：

  1. 选择列或行（请参见选择行或列）。
  2. 在属性检查器（“窗口”>“属性”）的“宽”文本字段中输入列宽，或在“高”文本字段中输入行高。

    有关更多信息，请参见设置单元格、行和列属性。

    提示

    您可以按像素或百分比指定宽度和高度，并且可以在像素和百分比之间互相转换。
  3. 按 Tab 键或 Enter 键 (Windows) 或 Return 键 (Macintosh) 以应用该值。

相关主题

  • 调整表格大小
  • 使代码中的列宽与可视宽度一致
  • 清除设置的宽度和高度
  • 显示表格和列的宽度和菜单


使代码中的列宽与可视宽度一致

如果您看到一个列的宽度有两个数字，说明 HTML 代码中设置的列宽度与这些列在屏幕上的外观宽度不匹配。可以使代码中指定的宽度与可视宽度相匹配。有关更多信息，请参见关于表格。

若要使宽度一致，请执行以下操作：

  1. 单击一个单元格。
  2. 单击表格标题菜单，然后选择“使所有宽度一致”。

    Dreamweaver 重置代码中指定的宽度以匹配可视宽度。

相关主题

  • 调整表格大小
  • 调整列和行的大小
  • 清除设置的宽度和高度


清除设置的宽度和高度

在调整表格大小前或调整表格或单个列或行遇到困难而想重新开始时，您可能需要清除设置的宽度和高度。

注意

当拖动其中一个选择柄来调整表格的大小时，改变了表格中的单元格的可视大小，但是没有更改单元格的任何指定的宽度或高度。调整大小前最好清除设置的宽度和高度。

若要清除表格中所有设置的宽度和高度，请执行以下操作：

  1. 选择该表格（请参见选取表格）。
  2. 执行下列操作之一：
    • 选择“修改”>“表格”>“清除单元格宽度”或“修改”>“表格”>“清除单元格高度”。
    • 这是所描述的功能的图片。 在属性检查器（“窗口”>“属性”）中，单击“清除行高”按钮或“清除列宽”按钮。 这是所描述的功能的图片。
    • 单击表格标题菜单，然后选择“清除所有高度”或“清除所有宽度”

若要清除列的设置宽度，请执行以下操作：

  1. 在该列中单击。
  2. 单击列标题菜单，然后选择“清除列宽”。

相关主题

  • 调整表格大小
  • 调整列和行的大小
  • 使代码中的列宽与可视宽度一致


显示表格和列的宽度和菜单

当选中表格或表格中有插入点时，Dreamweaver 会显示表格和列的宽度以及访问表格标题菜单和列标题菜单的箭头。（有关更多信息，请参见关于表格。）根据需要可以启用和禁用宽度和菜单。

若要启用或禁用表格和列的宽度和菜单，请执行下列操作之一：

  • 选择“查看”>“可视化助理”>“表格宽度”。
  • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该表格，然后选择“表格”>“表格宽度”。

相关主题

  • 调整表格大小
  • 调整列和行的大小


添加及删除行和列

若要添加和删除行和列，请使用“修改”>“表格”或列标题菜单。

提示

在表格的最后一个单元格中按 Tab 键会自动在表格中另外添加一行。

若要添加单个行或列，请执行以下操作：

  1. 单击一个单元格。
  2. 执行下列操作之一：
    • 选择“修改”>“表格”>“插入行”或“修改”>“表格”>“插入列”。

      在插入点的上面出现一行或在插入点的左侧出现一列。

    • 单击列标题菜单，然后选择“左侧插入列”或“右侧插入列”。

      在插入点的左侧或右侧出现一列。

若要添加多行或多列，请执行以下操作：

  1. 单击一个单元格。
  2. 选择“修改”>“表格”>“插入行或列”。

    即出现“插入行或列”对话框。

  3. 选择“行”或“列”，然后完成该对话框。

    有关更多信息，请参见设置“插入行或列”对话框选项。

  4. 单击“确定”。

行或列出现在表格中。

若要删除某行或列，请执行以下操作之一：

  • 单击要删除的行或列中的一个单元格，然后选择“修改”>“表格”>“删除行”或“修改”>“表格”>“删除列”。
  • 选择完整的一行或列（请参见选择行或列），然后选择“编辑”>“清除”或按 Delete 键。

整个行或列即从表格中消失。

若要使用属性检查器添加或删除行或列，请执行以下操作：

  1. 选择该表格（请参见选取表格）。
  2. 在属性检查器（“窗口”>“属性”）中，执行以下操作之一：
    • 增加或减少“行数”值以添加或删除行。

      Dreamweaver 在表格的底部添加和删除行。

    • 增加或减少“列数”值以添加或删除列。

      Dreamweaver 在表格的右边添加和删除列。

      注意

      当删除包含数据的行和列时，Dreamweaver 不发出警告。

相关主题

  • 拆分和合并单元格
  • 插入重复表格
  • 显示多个记录集结果


拆分和合并单元格

使用属性检查器或“修改”>“表格”子菜单中的命令拆分或合并单元格。有关更多信息，请参见关于拆分和合并表格单元格。

另一种合并和拆分单元格的方法是使用 Dreamweaver 中提供的增加和减少单元格所跨行数或列数的工具。

若要合并表格中的两个或多个单元格，请执行以下操作：

  1. 选择连续行中形状为矩形的单元格。

    在下面的插图中，所选部分是矩形的单元格，因此可以合并这些单元格。

    在下面的插图中，所选部分不是矩形，因此不能合并这些单元格。

  2. 执行下列操作之一：
    • 选择“修改”>“表格”>“合并单元格”。
    • 在展开的属性检查器（“窗口”>“属性”）中，单击“合并单元格”按钮。 这是所描述的功能的图片。

      注意

      如果没有看到按钮，请单击“属性”检查器右下角的箭头，以便看到所有选项。

    单个单元格的内容放置在最终的合并单元格中。所选的第一个单元格的属性将应用于合并的单元格。

若要拆分单元格，请执行以下操作：

  1. 单击单元格。
  2. 执行下列操作之一：
    • 选择“修改”>“表格”>“拆分单元格”。
    • 在展开的属性检查器（“窗口”>“属性”）中，单击“拆分单元格”按钮。 这是所描述的功能的图片。

      注意

      如果没有看到按钮，请单击“属性”检查器右下角的箭头，以便看到所有选项。
  3. 在“拆分单元格”对话框中，指定如何拆分单元格。

    有关更多信息，请参见设置“拆分单元格”对话框选项。

若要增加或减少单元格所跨的行或列的数目，请执行以下操作：

  1. 选择一个单元格。
  2. 执行下列操作之一：
    • 选择“修改”>“表格”>“增加行宽”或“修改”>“表格”>“增加列宽”。
    • 选择“修改”>“表格”>“减少行宽”或“修改”>“表格”>“减少列宽”。


复制、粘贴和删除单元格

您可以一次复制、粘贴或删除单个表格单元格或多个单元格，并保留单元格的格式设置。

您可以在插入点或替换现有表格中的所选部分粘贴单元格。若要粘贴多个表格单元格，剪贴板的内容必须和表格的结构或表格中将粘贴这些单元格的所选部分兼容。

若要剪切或复制表格单元格，请执行以下操作：

  1. 选择连续行中形状为矩形的一个或多个单元格。

    在下面的插图中，所选部分是矩形的单元格，因此可以剪切或复制这些单元格。

    在下面的插图中，所选部分不是矩形，因此不能剪切或复制这些单元格。

  2. 选择“编辑”>“剪切”或“编辑”>“复制”。

    注意

    如果您选择了整个行或列然后选择“编辑”>“剪切”，则将从表格中删除整个行或列（而不仅仅是单元格的内容）。

若要粘贴表格单元格，请执行以下操作：

  1. 选择要粘贴单元格的位置：
    • 若要用您正在粘贴的单元格替换现有的单元格，请选择一组与剪贴板上的单元格具有相同布局的现有单元格。

      例如，如果您复制或剪切了一块 3 x 2 的单元格，则可以选择另一块 3 x 2 的单元格通过粘贴进行替换。

    • 若要在特定单元格上方粘贴一整行单元格，请单击该单元格。
    • 若要在特定单元格左侧粘贴一整列单元格，请单击该单元格。

      注意

      如果剪贴板中的单元格不到一整行或一整列，并且您单击某个单元格然后粘贴剪贴板中的单元格，则您所单击的单元格和与它相邻的单元格可能（根据它们在表格中的位置）被您粘贴的单元格替换。
    • 若要用粘贴的单元格创建一个新表格，请将插入点放置在表格之外。
  2. 选择“编辑”>“粘贴”。

    如果您将整个行或列粘贴到现有的表格中，则这些行或列将被添加到该表格中。如果您粘贴单个单元格，则将替换所选单元格的内容。如果您在表格外进行粘贴，则这些行、列或单元格用于定义一个新表格。

若要删除单元格内容，但使单元格保持原样，请执行以下操作：

  1. 选择一个或多个单元格。

    注意

    确保所选部分不是完全由完整的行或列组成的。
  2. 选择“编辑”>“清除”或按 Delete 键。

    注意

    如果在您选择“编辑”>“清除”或按 Delete 键时只选择了完整的行或列，则将从表格中删除整个行或列，而不仅仅是它们的内容。

若要删除包含合并单元格的行或列，请执行以下操作：

  1. 选择行或列。
  2. 选择“修改”>“表格”>“删除行”或“修改”>“表格”>“删除列”。


嵌套表格

嵌套表格是在另一个表格的单元格中的表格。可以像对任何其他表格一样对嵌套表格进行格式设置；但是，其宽度受它所在单元格的宽度的限制。

若要在表格单元格中嵌套表格，请执行以下操作：

  1. 单击现有表格中的一个单元格。
  2. 选择“插入”>“表格”。

    即会出现“插入表格”对话框。

  3. 完成对话框。

    有关更多信息，请参见设置“表格”对话框选项。

  4. 单击“确定”。

    该表格即出现在现有表格中。


对表格进行排序

您可以根据单个列的内容对表格中的行进行排序。您还可以根据两个列的内容执行更加复杂的表格排序。

您不能对包含 colspan 或 rowspan 属性的表格（即包含合并单元格的表格）进行排序。有关更多信息，请参见拆分和合并单元格。

若要对表格进行排序，请执行以下操作：

  1. 选择该表格（请参见选取表格）或单击任意单元格。
  2. 选择“命令”>“排序表格”。

    即会出现“排序表格”对话框。

  3. 完成对话框。

    有关更多信息，请参见设置“排序表格”对话框选项。

  4. 单击“确定”。


参考资料

本节提供在本章介绍的下列对话框和检查器的有关信息：

  • 设置“表格”对话框选项
  • 设置“导入表格式数据”对话框选项
  • 设置表格属性
  • 设置单元格、行和列属性
  • 设置“表格格式设置”对话框选项
  • 设置“插入行或列”对话框选项
  • 设置“拆分单元格”对话框选项
  • 设置“排序表格”对话框选项
  • 设置“导出表格”对话框选项


设置“表格”对话框选项

此对话框允许您在插入表格之前指定其属性。

若要完成“插入表格”对话框，请执行以下操作：

  1. 在“表格大小”部分中指定以下选项：

    行数确定表格具有的行的数目。

    列数确定表格具有的列的数目。

    表格宽度以像素为单位或按占浏览器窗口宽度的百分比指定表格的宽度。

    边框粗细指定表格边框的宽度（以像素为单位）。

    提示

    如果您没有明确指定边框粗细的值，则大多数浏览器按边框粗细设置为 1 显示表格。若要确保浏览器显示的表格没有无边框，请将边框粗细设置为 0。若要在边框粗细设置为 0 时查看单元格和表格边框，请选择“查看”>“可视化助理”>“表格边框”。

    单元格边距确定单元格边框和单元格内容之间的像素数。

    单元格间距确定相邻的表格单元格之间的像素数。

    提示

    如果没有明确指定单元格间距和单元格边距的值，大多数浏览器按单元格边距都设置为 1，单元格间距设置为 2 显示表格。若要确保浏览器不显示表格中的边距和间距，请将“单元格边距”和“单元格间距”设置为 0。
  2. 在“标题”部分选择一个标题选项：

    无对表不启用列或行标题。

    左侧可以将表的第一列作为标题列，以便您为表中的每一行 输入一个标题。

    顶部可以将表的第一行作为标题行，以便您为表中的每一列 输入一个标题。

    两者使您能够在表中输入列标题和行标题。

    提示

    最好使用标题以方便使用屏幕阅读器的 Web 站点访问者。屏幕阅读器读取表格标题并且帮助屏幕阅读器用户跟踪表格信息，
  3. 在“辅助功能”部分指定以下选项：

    标题提供了一个显示在表格外的表格标题。

    对齐标题指定表格标题相对于表格的显示位置。

    摘要给出了表格的说明。屏幕阅读器可以读取摘要文本，但是该文本不会显示在用户的浏览器中。

  4. 单击“确定”创建表格。

相关主题

  • 插入一个表格并添加内容


设置“导入表格式数据”对话框选项

此对话框允许您指定有关表格式数据文件的信息，并指定要使用这些数据创建的表格的属性。

若要完成“导入表格式数据”对话框，请执行以下操作：

  1. 指定以下选项：

    数据文件是要导入的文件的名称。单击“浏览”按钮选择一个文件。

    定界符是正在导入的文件中所使用的分隔符。

    如果您选择“其他”，则一个文本框出现在弹出式菜单的右侧。输入您的文件中使用的定界符。

    注意

    确保指定保存数据文件时使用的定界符。如果未能指定定界符，则无法正确地导入文件，也无法在表格中对您的数据进行正确的格式设置。

    表格宽度是将创建的表格的宽度。

    • 选择“匹配内容”使每个列足够宽以适应该列中最长的文本字符串。
    • 选择“设置”以像素为单位指定固定的表格宽度，或按占浏览器窗口宽度的百分比指定表格宽度。

    单元格边距是单元格内容和单元格边框之间的像素数。

    单元格间距确定相邻的表格单元格之间的像素数。

    提示

    如果没有明确指定单元格间距和单元格边距的值，大多数浏览器都按单元格边距设置为 1，单元格间距设置为 2 显示表格。若要确保浏览器不显示表格中的边距和间距，请将“单元格边距”和“单元格间距”设置为 0。

    格式化首行确定应用于表格首行的格式设置（如果存在）。从四个格式设置选项中进行选择：无格式、粗体、斜体或加粗斜体。

    边框指定表格边框的宽度（以像素为单位）。

    提示

    如果您没有明确指定边框的值，则大多数浏览器按边框设置为 1 显示表格。若要确保浏览器显示的表格没有边框，请将“边框”设置为 0。若要在边框设置为 0 时查看单元格和表格边框，请选择“查看”>“可视化助理”>“表格边框”。
  2. 单击“确定”。

相关主题

  • 导入和导出表格式数据


设置表格属性

此“属性”检查器允许您设置表格的属性。

若要设置表格属性，请执行以下操作：

  1. 设置以下任一选项：

    表格 ID 是表格的 ID。

    行和列是表格中行和列的数目。

    宽和高是以像素为单位或按占浏览器窗口宽度的百分比计算的表格宽度和高度。

    注意

    通常不需要设置表格的高度。

    单元格边距是单元格内容和单元格边框之间的像素数。

    单元格间距是相邻的表格单元格之间的像素数。

    提示

    如果没有明确指定单元格间距和单元格边距的值，大多数浏览器都按单元格边距设置为 1，单元格间距设置为 2 显示表格。若要确保浏览器不显示表格中的边距和间距，请将“单元格边距”和“单元格间距”设置为 0。

    对齐确定表格相对于同一段落中其他元素（例如文本或图像）的显示位置。

    “左对齐”沿其他元素的左侧对齐表格（因此同一段落中的文本在表格的右侧换行）；“右对齐”沿其他元素的右侧对齐表格（文本在表格的左侧换行）；“居中对齐”将表格居中（文本显示在表格的上方和/或下方）。“缺省”指示浏览器应该使用其默认对齐方式。

    提示

    当将对齐方式设置为“默认”时，其他内容不显示在表格的旁边。若要在其他内容旁边显示表格，请使用“左对齐”或“右对齐”。

    边框指定表格边框的宽度（以像素为单位）。

    提示

    如果您没有明确指定边框的值，则大多数浏览器按边框设置为 1 显示表格。若要确保浏览器显示的表格没有边框，请将“边框”设置为 0。若要在边框设置为 0 时查看单元格和表格边框，请选择“查看”>“可视化助理”>“表格边框”。

    清除列宽和清除行高按钮从表格中删除所有明确指定的行高或列宽。

    将表格宽度转换成像素和将表格高度转换成像素按钮将表格中每列的宽度或高度设置为以像素为单位的当前宽度（还将整个表格的宽度设置为以像素为单位的当前宽度）。

    将表格宽度转换成百分比和将表格高度转换成百分比按钮将表格中每列的宽度或高度设置为按占“文档”窗口宽度百分比表示的当前宽度（还将整个表格的宽度设置为按占“文档”窗口宽度百分比表示的当前宽度）。

    背景颜色是表格的背景颜色。

    边框颜色是表格边框的颜色。

    背景图像是表格的背景图像。

  2. 如果您在文本框中输入了值，则可以按 Tab 键或Enter 键 (Windows) 或 Return 键 (Macintosh) 来应用该值。

相关主题

  • 查看和设置表格、单元格、行和列的属性
  • 使用颜色
  • 链接文件和文档
  • 选择表格元素
  • 查看和设置表格、单元格、行和列的属性


设置单元格、行和列属性

此“属性”检查器允许您设置表格元素（单元格、行和列）的属性。

注意

当设置列的属性时，Dreamweaver 更改对应于该列中每个单元格的 td 标签的属性。但是，当设置行的某些属性时，Dreamweaver 将更改 tr 标签的属性而不是行中每个 td 标签的属性。在将同一种格式应用于行中的所有单元格时，将格式应用于 tr 标签会生成更简明易懂的 HTML 代码。

若要设置表格元素的属性，请执行以下操作：

  1. 设置以下任一选项：

    水平指定单元格、行或列内容的水平对齐方式。您可以将内容对齐到单元格的左侧、右侧或使之居中对齐，也可以指示浏览器使用其默认的对齐方式（通常常规单元格为左对齐，标题单元格为居中对齐）。

    垂直指定单元格、行或列内容的垂直对齐方式。您可以将内容对齐到单元格的顶端、中间、底部或基线，或者指示浏览器使用其默认的对齐方式（通常是居中对齐）。

    宽和高是以像素为单位或按占整个表格宽度或高度百分比计算的所选单元格的宽度和高度。若要指定百分比，请在值后面使用百分比符号 (%)。若要让浏览器根据单元格的内容以及其他列和行的宽度和高度确定适当的宽度或高度，请将此域留空（默认设置）。

    默认情况下，浏览器选择一列的宽度来容纳列中最宽的图像或最长的行。这就是为什么当您将内容添加到某个列时，该列有时变得比表格中其他列宽得多的原因。

    默认情况下，浏览器选择一行的高度来容纳该行中的所有文本和图像。

    注意

    您可以按占表格总高度的百分比指定一个高度，但是浏览器中行可能不以指定的百分比高度显示。

    背景（上面的文本字段）是单元格、列或行的背景图像的文件名。单击文件夹图标浏览到某个图像，或使用“指向文件”图标选择某个图像文件。

    背景（下面的颜色样本和文本字段）是使用颜色选择器选择的单元格、列或行的背景颜色。

    边框是单元格的边框颜色。

    合并单元格按钮可以将所选的单元格、行或列合并为一个单元格（请参见拆分和合并单元格）。只有当单元格形成矩形或直线的块时才可以合并这些单元格。

    拆分单元格按钮可以将一个单元格分成两个或更多单元格（请参见拆分和合并单元格）。一次只能拆分一个单元格；如果选择的单元格多于一个，则此按钮将禁用。

    不换行可以防止换行，从而使给定单元格中的所有文本都在一行上。如果启用了“不换行”，则当您键入数据或将数据粘贴到单元格时单元格会加宽来容纳所有数据。（通常，单元格在水平方向扩展以容纳单元格中最长的单词或最宽的图像，然后根据需要在垂直方向进行扩展以容纳其他内容。）

    标题 可以将所选的单元格格式设置为表格标题单元格。默认情况下，表格标题单元格的内容为粗体并且居中。

  2. 如果您在文本框中输入了值，则可以按 Tab 键或Enter 键 (Windows) 或 Return 键 (Macintosh) 来应用该值。

相关主题

  • 查看和设置表格、单元格、行和列的属性
  • 选择表格元素
  • 查看和设置表格、单元格、行和列的属性
  • 使用颜色
  • 链接文件和文档


设置“表格格式设置”对话框选项

此对话框允许您选择预先设置好格式的表格设计应用到表格中。

若要完成“表格格式设置”对话框，请执行以下操作：

  1. 从左边的列表中选择设计方案。

    示例表格显示所选设计的示例。

  2. 指定以下选项：

    行颜色选项指定应用于行的颜色，以及颜色交替的频率。

    首行选项指定表格第一行（可能包含列标题）的对齐方式、文本样式、背景颜色和文本颜色。

    最左列选项指定表格最左列（可能包含行标题）的对齐方式和文本样式。

    边框指表格边框的宽度（以像素为单位）。

    提示

    如果您没有明确指定边框的值，则大多数浏览器按边框设置为 1 显示表格。若要确保浏览器显示的表格没有边框，请将“边框”设置为 0。若要在边框设置为 0 时查看单元格和表格边框，请选择“查看”>“可视化助理”>“表格边框”。

    将所有属性应用于 TD 标签而不是 TR 标签可以将设计应用于表格单元格（td 标签）而不是表格行（tr 标签）。

    默认情况下，“表格格式设置”对话框中指定的格式设置应用于整个行而不是单个单元格。在将同一种格式应用于行中的所有单元格时，将格式应用于 tr 标签会生成更简明易懂的 HTML 代码。但是，此选项允许您将格式设置应用于单个单元格（如果这是您的编码偏好的话）。有关更多信息，请参见设置表格和单元格的格式。

  3. 执行下列操作之一：
    • 单击“应用”在不关闭对话框的情况下将格式设置应用于您的表格。然后对格式设置进行更改，或者单击“确定”或“取消”关闭对话框。
    • 单击“确定”将格式设置应用于您的表格并关闭对话框。


设置“插入行或列”对话框选项

此对话框允许您将一个或多个行或列插入到表格中。

若要完成“插入行或列”对话框，请执行以下操作：

  1. 指定以下选项：

    插入指示是插入行还是列。

    行数或列数是要插入的行或列的数目。

    位置指定新行或新列应该显示在所选单元格所在行或列的前面还是后面。

  2. 单击“确定”。

相关主题

  • 添加及删除行和列


设置“拆分单元格”对话框选项

此对话框允许您指定如何拆分表格单元格。

若要完成“拆分单元格”对话框，请执行以下操作：

  1. 指定以下选项：

    拆分单元格指定将单元格拆分成行还是列。

    行数/列数指定将单元格拆分成多少行或列。

  2. 单击“确定”。


设置“排序表格”对话框选项

此对话框允许您指定表格的排序方式。

若要完成“排序表格”对话框，请执行以下操作：

  1. 指定以下选项：

    排序方式可以确定哪个列的值将用于对表格的行进行排序。

    顺序确定是按字母还是按数字顺序以及是以升序（A 到 Z，小数字到大数字）还是降序对列进行排序。

    当列的内容是数字时，选择“按数字顺序”。如果按字母顺序对一组由一位或两位数组成的数字进行排序，则会将这些数字作为单词进行排序（排序结果如 1、10、2、20、3、30），而不是将它们作为数字进行排序（排序结果如 1、2、3、10、20、30）。

    再按/顺序确定在不同列上第二种排序方法的排序顺序。在“再按”弹出式菜单中指定应用第二种排序方法的列，并在“顺序”弹出式菜单中指定第二种排序方法的排序顺序。

    排序包含第一行指定表格的第一行应该包括在排序中。如果第一行是不应移动的标题，则不选择此选项。

    对标题行进行排序指定使用与 body 行相同的条件对表格 thead 部分（如果存在）中的所有行进行排序。（请注意，即使在排序后 thead 行仍将保留在 thead 部分中并仍显示在表格的顶部。）有关 thead 标签的信息，请参见“参考”面板（选择“帮助”>“参考”）。

    对脚注行进行排序指定使用与 body 行相同的条件对表格 tfoot 部分（如果存在）中的所有行进行排序。（请注意，即使在排序后 tfoot 行仍将保留在 tfoot 部分中并仍显示在表格的底部。）有关 tfoot 标签的信息，请参见“参考”面板（选择“帮助”>“参考”）。

    排序完成后使所有行的颜色保持相同指定排序之后表格行属性（如颜色）应该与同一内容保持关联。如果表格行使用两种交替的颜色，则不要选择此选项以确保排序后的表格仍具有颜色交替的行。如果行属性特定于每行的内容，则选择此选项以确保这些属性保持与排序后表格中正确的行关联在一起。

  2. 单击“应用”或“确定”。


设置“导出表格”对话框选项

此对话框允许您设置分隔符和换行符样式以通过从表格中导出数据来创建文本文件。

若要完成“导出表格”对话框，请执行以下操作：

  1. 指定以下选项：

    定界符指定应该使用哪个分隔符字符在导出的文件中隔开各项。

    换行符指定您将在哪个操作系统中打开导出的文件：Windows、Macintosh 还是 UNIX。（不同的操作系统具有不同的指示文本行结尾的方式。）

  2. 单击“导出”。


在“布局模式”对页进行布局

创建页布局的一种常用的方法是使用 HTML 表格对元素进行定位。但是，使用表格进行布局不太方便，因为最初创建表格是为了显示表格数据，而不是用于对 Web 页进行布局。为了简化使用表格进行页面布局的过程，Macromedia Dreamweaver 8 提供了“布局”模式。

在“布局”模式中，您可以使用表格作为基础结构来设计您的页，同时避免使用传统的方法创建基于表格的设计时经常出现的一些问题。

注意

有关使用“标准”模式表格的详细信息，请参见使用表格显示内容。或者作为使用“标准”模式或“布局”模式表格的替代方式，您可以使用 CSS 定位来对页面进行布局（请参见插入 div 标签进行布局）。

本章包含以下几节：

关于“布局”模式

从“标准”模式切换到“布局”模式

在“布局”模式中绘制

将内容添加到布局单元格中

清除自动设置的单元格高度

调整布局单元格和表格的大小以及移动它们

设置布局单元格和表格的格式

设置列宽度

设置“布局”模式的首选参数


关于“布局”模式

在“布局”模式中，您可以在添加内容前使用布局单元格和表格来对页面进行布局。例如，您可以沿页的顶部绘制一个单元格放置标题图形，在页的左边绘制另一个单元格放置导航条，在右边绘制第三个单元格放置内容。添加内容时，您可以按需要在四周移动单元格，以调整布局。

提示

为实现最大灵活性，您可以仅在准备添加内容时绘制每一个单元格。这使您能够将布局表格中的更多空白空间保留更长一段时间，这样您可以更方便地移动单元格或调整单元格的大小。

页面上显示的布局表格外框为绿色，而布局单元格外框为蓝色。（若要更改默认的外框颜色，请参见设置“布局”模式的首选参数）。当您将鼠标指针移动到表格单元格上时，Dreamweaver 会高亮显示该单元格。（若要启用或禁用高亮显示，或者若要更改高亮颜色，请参见绘制布局单元格和表格）。

您可以在一个布局表格中使用多个布局单元格对页进行布局，这是进行 Web 页布局最常用的方法，您也可以使用多个单独的布局表格进行更复杂的布局。使用多个布局表格会将您的布局隔离为多个部分，这样它们不会在其他部分被更改时受到影响。

您还可以通过将一个新的布局表格放置在现有的布局表格中进行布局表格嵌套（请参见绘制嵌套布局表格）。当布局中某一部分的行或列与布局中另一部分的行或列没有对齐时，该结构使您可以简化表格结构。例如，使用嵌套布局表格您可以方便地创建一个两列布局，左边一列有四行，右边一列有三行。

本节包含以下概念性主题：

  • 关于在“布局”模式中查看表格与单元格宽度
  • 布局表格与单元格网格线
  • 固定的列宽度和自动伸展列
  • 间隔图像

相关主题

  • 从“标准”模式切换到“布局”模式
  • 在“布局”模式中绘制


关于在“布局”模式中查看表格与单元格宽度

当选定了表格或表格中有插入点时，布局表格和单元格的宽度（以像素为单位，或按占页宽度的百分比表示）会出现在该表格的顶部或底部。宽度旁边是表格标题菜单与列标题菜单的箭头。使用菜单可以快速访问一些常用命令。

注意

若要禁用列宽以及表格标签与标题菜单，您必须禁用所有可视化助理（“查看”>“可视化助理”>“隐藏全部”）。

有时可能不出现列宽；您可能会看到以下任何一种情况：

  • 无宽度。如果您未看到表的宽度或列的宽度，说明没有在 HTML 代码中指定该表或列的宽度。若要指定一个固定宽度，请参见将列设置为自动伸展或固定宽度。
  • 两个数字。如果出现两个数字，说明“设计”视图中显示的可视宽度与 HTML 代码中指定的宽度不一致。当拖动表格的右下角来调整表格的大小，或将内容添加到比设置宽度大的单元格时会发生这种情况。

    例如，如果您将某列的宽度设置为 200 像素，而添加的内容将宽度延长为 250 像素，则该列的顶部将显示两个数字：“200”（代码中指定的宽度）和“(250)”（位于括号中，表示该列呈现在屏幕上的可视宽度）。

    要协调列宽度，请参见使代码中的列宽与可视宽度一致。

  • 波浪线。出现波浪线表示这种列是置为自动伸展的列。有关将列设置为自动伸展的信息，请参见将列设置为自动伸展或固定宽度。
  • 双线。包含间隔图像的列在列宽周围具有双线。有关间隔图像的信息，请参见使用间隔图像。

相关主题

  • 设置列宽度


布局表格与单元格网格线

当您在布局表格中绘制布局单元格时会出现一条明亮的网格线，从任何新布局单元格的边缘向外延伸到包含该单元格的布局表格的边缘。这些线可以帮助您将新单元格和以前的单元格对齐，并帮助您显现基础 HTML 表格的结构。

Dreamweaver 将新单元格的边缘与旁边现有单元格的边缘自动靠齐。（布局单元格不能重叠。）如果绘制单元格靠近包含它的布局表格的边缘，则单元格的边缘也会与该表格的边缘自动靠齐。

您还可以使用 Dreamweaver 网格来帮助您对页进行布局，这种网格经过设置，不会根据单元格的位置发生更改（请参见使用跟踪图像）。

相关主题

  • 关于“布局”模式


固定的列宽度和自动伸展列

“布局”模式中的表格列可以具有固定的宽度，或者其宽度可以自动扩展以填充浏览器窗口中尽量大的部分（自动伸展）。

固定宽度的列具有特定的宽度值，如 300 像素。Dreamweaver 在每一个固定宽度的列的顶部或底部显示列的列宽。

自动伸展列可根据浏览器窗口的宽度自动进行调整。如果您的布局中包括自动伸展列，则该布局始终填充访问者浏览器窗口的整个宽度。在给定的布局表格中，您只能让一个列自动伸展。自动伸展列会在列宽区域显示波浪线。

常见的布局是让页上包含主要内容的列自动伸展，这会将所有其他列自动设置为固定宽度。例如，假设您的布局在页的左边有一个较宽的图像，在右边有一列文本。您可能将左边的列设置为固定宽度，让侧栏区域自动伸展。

当您让某个列自动伸展时，Dreamweaver 会在固定宽度的列中插入间隔图像以确保这些列保持应有的宽度，除非您指定不使用间隔图像。间隔图像是透明的图像，用于控制间距，它在浏览器窗口中是不可见的。有关更多信息，请参见间隔图像。

相关主题

  • 将列设置为自动伸展或固定宽度


间隔图像

间隔图像（也叫做间隔 GIF）是透明的图像，用来控制自动伸展表格中的间距。间隔图像由一个单像素的透明 GIF 图像组成，向外伸展到指定像素数的宽度。浏览器绘制的表格列不能窄于该列的单元格中所包含的最宽图像，因此在表格列中放置间隔图像要求浏览器至少应该保持该列与该图像一样宽。

当您设置某列自动伸展时，Dreamweaver 将自动添加间隔图像，除非您指定不使用任何间隔图像。如果愿意，您可以在每个列中手动插入和删除间隔图像。包含间隔图像的列在显示列宽的区域中具有双线。

您可以手动插入和删除特定列中的间隔图像或删除页中的所有间隔图像。

相关主题

  • 使用间隔图像


从“标准”模式切换到“布局”模式

在绘制布局表格或布局单元格之前，必须从“标准”模式切换到“布局”模式。如果在“布局”模式中创建布局表格，则在向表格中添加内容或对表格进行编辑之前最好切换回“标准”模式。

注意

如果您在“标准”模式中创建了一个表格，然后切换到“布局”模式，则结果可能使布局表格包含空布局单元格。您可能需要先删除这些空布局单元格才能创建新的布局单元格或移动布局单元格。

若要切换到“布局”模式，请执行以下操作：

  1. 如果您正在“代码”视图中工作，请选择“查看”>“设计”或“查看”>“代码和设计”。

    在“代码”视图中您无法切换到“布局”模式。

  2. 执行下列操作之一：
    • 选择“查看”>“表格模式”>“布局模式”。
    • 在“插入”栏的“布局”类别中单击“布局模式”按钮。

“文档”窗口的顶部会出现标有“布局模式”的条。如果您的页上存在表格，则它们显示为布局表格。

若要切换出“布局”模式，请执行以下操作之一：

  • 在“文档”窗口的顶部，单击标有“布局模式”的条中的“退出”。
  • 选择“查看”>“表模式”>“标准模式”。
  • 在“插入”栏的“布局”类别中单击“标准模式”按钮。

Dreamweaver 返回到“标准”模式。


在“布局”模式中绘制

“布局”模式允许您绘制单元格和表格，包括嵌套在其他表格中的表格。靠齐网格可以帮助您对齐单元格（请参见使用跟踪图像）。

本节包含以下主题：

  • 绘制布局单元格和表格
  • 绘制嵌套布局表格


绘制布局单元格和表格

在“布局”模式中，您可以在页上绘制布局单元格和表格。如果您不是在布局表格中绘制布局单元格，Dreamweaver 会自动创建一个布局表格以容纳该单元格。布局单元格不能存在于布局表格之外。

注意

在“布局”模式中，您不能使用在“标准”模式中可以使用的“插入表格”和“绘制层”工具。若要使用这些工具，您必须先切换到“标准”模式。

当 Dreamweaver 自动创建布局表格时，该表格最初显示为填满整个“设计”视图，即使您更改“文档”窗口的大小也是如此。这种全窗默认布局表格使您可以在“设计”视图中的任意位置绘制布局单元格。您可以将该表格设置为特定的大小，方法是单击表格边框然后拖动表格的大小调整手柄。

当您将鼠标指针移动到布局单元格上时，Dreamweaver 会高亮显示它。您可以启用或禁用高亮显示或在首选参数中更改高亮颜色。

若要绘制布局单元格，请执行以下操作：

  1. 确保您处于“布局”模式中（请参见从“标准”模式切换到“布局”模式）。
  2. 在“插入”栏的“布局”类别中，单击“绘制布局单元格”按钮。 这是所描述的功能的图片。

    鼠标指针变为加号 (+)。

  3. 将鼠标指针放置在页中要开始绘制单元格的位置，然后拖动指针以创建布局单元格。

    提示

    若要绘制多个布局单元格而不必重复选择“绘制布局单元格”，请在绘制布局单元格时按住 Control 键拖动 (Windows) 或者按住 Command 键拖动 (Macintosh)。只要继续按住 Control 键或 Command 键，便可以连续绘制出多个布局单元格。

    如果您在靠近布局表格边缘的位置绘制单元格，则单元格的边缘会自动与包含它的布局表格的边缘对齐。若要临时禁用靠齐，可在绘制单元格时按住 Alt 键 (Windows) 或 Option 键 (Macintosh)。

页上显示的单元格外框为蓝色。若要更改外框颜色，请参见设置“布局”模式的首选参数。

若要绘制布局表格，请执行以下操作：

  1. 确保您处于“布局”模式中（请参见从“标准”模式切换到“布局”模式）。
  2. 在“插入”栏的“布局”类别中，单击“绘制布局表格”按钮。 这是所描述的功能的图片。

    鼠标指针变为加号 (+)。

  3. 将鼠标指针放置在页上，然后拖动指针以创建布局表格。

    提示

    若要绘制多个布局表格而不必重复选择“绘制布局表格”，请在绘制布局表格时按住 Control 键拖动 (Windows) 或者按住 Command 键拖动 (Macintosh)。只要继续按住 Control 键或 Command 键，便可以连续绘制出多个布局表格。

    您可以在页布局的空白区域中创建布局表格，也可以在现有布局单元格和表格的周围或嵌套在现有布局表格中创建布局表格。如果您的页面已包含内容，而且要在页面布局的空白区域添加布局表格，则只能在现有内容的下方绘制新的布局表格。

    提示

    如果您尝试在现有内容下面绘制布局表格但是出现禁止绘制鼠标指针，请调整“文档”窗口的大小以使现有内容底部和窗口底部之间产生更多的空白空间。

    注意

    表格不能互相重叠，但一个表格可以完全包含在另一个表格当中。有关更多信息，请参见绘制嵌套布局表格。

页上显示的布局表格外框为绿色。若要更改外框颜色，请参见设置“布局”模式的首选参数。

若要更改布局单元格的标记色彩首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或Dreamweaver>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从左侧的类别列表中选择“标记色彩”。
  3. 进行下面其中一项更改：
    • 若要更改高亮颜色，请单击“鼠标滑过”颜色框，然后使用颜色选择器选择一种高亮颜色（或在文本框中输入高亮颜色的十六进制值）。

      有关使用颜色选择器的信息，请参见使用颜色。

    • 若要启用或禁用高亮显示功能，请在“鼠标滑过”上选择或取消选择“显示”复选框。

      注意

      这些选项会影响当鼠标指针滑过时 Dreamweaver 会高亮显示的所有对象，例如表格和层。
  4. 单击“确定”。


绘制嵌套布局表格

您可以将一个布局表格绘制在另一个布局表格中，创建嵌套表格。对外部表格所进行的更改不会影响嵌套表格中的单元格；例如，当您更改外部表格中行或列的大小时，内部表格中单元格的大小不发生变化。

您可以插入多级嵌套表格。嵌套布局表格的大小不能超过包含它的表格。

注意

如果您在绘制任何布局单元格之前在页的中央绘制一个布局表格，则绘制的表格将自动嵌套在一个更大的表格中。

若要绘制嵌套布局表格，请执行以下操作：

  1. 确保您处于“布局”模式中（请参见从“标准”模式切换到“布局”模式）。
  2. 在“插入”栏的“布局”类别中，单击“绘制布局表格”按钮。 这是所描述的功能的图片。

    鼠标指针变为加号 (+)。

  3. 指向现有布局表格中的空白（灰色）区域，然后拖动指针以创建嵌套布局表格。

    注意

    您不能在布局单元格中创建布局表格。您只能在现有布局表格的空白区域中或在现有单元格周围创建嵌套布局表格。

若要在现有布局单元格或表格周围绘制布局表格，请执行以下操作：

  1. 确保您处于“布局”模式中（请参见从“标准”模式切换到“布局”模式）。
  2. 在“插入”栏的“布局”类别中，单击“绘制布局表格”按钮。

    鼠标指针变为加号 (+)。

  3. 在一组现有布局单元格或表格的周围绘制一个矩形。

    出现一个新的嵌套布局表格，围起现有的单元格或表格。

    提示

    若要使现有布局单元格紧贴到新嵌套表格的一个角上，请在靠近该单元格一角的位置开始拖动；新表格的一角将靠齐到该单元格的一角上。您不能在布局单元格的中央开始拖动，因为您不能完全在一个布局单元格中创建布局表格。


将内容添加到布局单元格中

在“布局”模式中您可以将文本、图像和其他内容添加到布局单元格中，就像在“标准”模式中将内容添加到表格单元格一样。单击您要添加内容的单元格，然后键入文本或插入其他内容。

您只能将内容插入布局单元格中，而不是布局表格的空白（灰色）区域，因此在可以添加内容之前，必须先创建布局单元格（请参见在“布局”模式中绘制）。

若要将文本添加到布局单元格，请执行以下操作：

  1. 将插入点放置在您要添加文本的布局单元格中。
  2. 执行下列操作之一：
    • 在单元格中键入文本。

      当进行键入时，单元格将按需要自动扩展。

    • 粘贴从其他文档复制的文本。

      有关更多信息，请参见插入文本。

当您添加宽度大于布局单元格的内容时，该单元格将自动扩展。当单元格扩展时，该单元格所在的列也随之扩展，这可能会改变周围单元格的大小。该列的列宽变为显示代码中出现的宽度，后面的括号中是该列的可视宽度（屏幕上显示的宽度）。（有关列宽度的更多信息，请参见设置列宽度。）

若要将图像添加到布局单元格中，请执行以下操作：

  1. 将插入点放置在您要添加图像的布局单元格中。
  2. 执行下列操作之一：
    • 选择“插入”>“图像”。
    • 在“插入”栏的“常用”类别中，单击“图像”按钮上的箭头，然后选择“图像”。

      提示

      如果“图像”按钮显示（如以下示例所示）在“插入”栏中，则可以单击该按钮而不必使用弹出菜单。

    出现“选择图像源文件”对话框。

  3. 选择一个图像文件。

    有关更多信息，请参见插入图像。

  4. 单击“确定”。

该图像出现在布局单元格中。


清除自动设置的单元格高度

当创建布局单元格时，Dreamweaver 自动指定单元格的高度，使单元格以您绘制的高度显示，即使单元格是空的也是如此。将内容插入到单元格之后，您可能不再需要指定高度，因此您可以从表格中删除显式单元格高度。

若要清除单元格高度，请执行以下操作之一：

  • 单击表格标题菜单，然后选择“清除所有高度”。

  • 通过单击表格顶部的选项卡选择一个布局表格，然后单击属性检查器（“窗口”>“属性”）中的“清除行高”按钮 这是所描述的功能的图片。
    。

Dreamweaver 清除该表格中指定的所有高度。某些表格单元格可能在垂直方向上会收缩。


调整布局单元格和表格的大小以及移动它们

为了调整页布局，您可以对布局单元格和嵌套布局表格进行移动并调整它们的大小。（最外面的布局表格只能调整大小。）

注意

若要在移动单元格和表格或调整它们的大小时使用 Dreamweaver 网格作为参考，请参见使用跟踪图像。

本节包含以下主题：

  • 调整布局单元格的大小以及移动它们
  • 调整布局表格的大小以及移动它们


调整布局单元格的大小以及移动它们

可以调整布局单元格的大小或移动它们，但是不能使它们重叠。对单元格进行移动或调整大小之后，该单元格不能跨包含它的布局表格的边框。布局单元格不能小于其内容的大小。

有关如何调整布局表格大小或如何移动它们的信息，请参见调整布局表格的大小以及移动它们。

若要调整布局单元格的大小，请执行以下操作：

  1. 选择一个单元格，方法是单击该单元格的边缘，或者在按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 的同时单击该单元格中的任何位置。

    该单元格周围出现选择控制点。

  2. 拖动选择控制点来调整单元格的大小。

    单元格边缘会自动与其他单元格的边缘靠齐。

若要移动布局单元格，请执行以下操作：

  1. 选择一个单元格，方法是单击该单元格的边缘，或者在按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 的同时单击该单元格中的任何位置。

    该单元格周围出现选择控制点。

  2. 执行下列操作之一：
    • 将该单元格拖到其布局表格中的另一个位置。
    • 按箭头键移动该单元格，每次移动 1 个像素。

      提示

      在按住 Shift 键的同时按箭头键移动该单元格，每次 10 个像素。


调整布局表格的大小以及移动它们

调整布局表格的大小后，该布局表格不能小于包含所有其单元格的最小矩形的大小。调整布局表格的大小后还不能使其与其他表格或单元格重叠。

若要调整布局单元格的大小或移动它们，请参见调整布局单元格的大小以及移动它们。

若要调整布局表格的大小，请执行以下操作：

  1. 通过单击表格顶部的标签选择一个表格。

    该表格周围出现选择控制点。

  2. 拖动选择控制点来调整表格的大小。

    表格边缘与其他单元格和表格的边缘自动靠齐。

若要移动布局表格，请执行以下操作：

  1. 通过单击表格顶部的标签选择一个表格。

    该表格周围出现选择控制点。

    注意

    只有当布局表格嵌套在另一个布局表格中时，您才可以移动该布局表格。
  2. 执行下列操作之一：
    • 将表格拖到页上的另一个位置。
    • 按箭头键移动该表格，每次移动 1 个像素。

      提示

      在按住 Shift 键的同时按箭头键移动该表格，每次 10 个像素。


设置布局单元格和表格的格式

您可以通过使用属性检查器来更改任何布局单元格或表格的外观。

本节包含以下主题：

  • 设置布局单元格的格式
  • 设置布局表格的格式


设置布局单元格的格式

您可以在“属性”检查器中设置布局单元格的多种属性，包括宽度和高度、背景颜色以及单元格内容的对齐方式。

若要在属性检查器中设置布局单元格的格式，请执行以下操作：

  1. 选择一个单元格，方法是单击该单元格的边缘，或者在按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 的同时单击该单元格中的任何位置。
  2. 如果“属性”检查器尚未打开，请打开“属性”检查器（“窗口”>“属性”）。

  3. 通过设置属性更改单元格的格式设置。

    有关更多信息，请参见设置布局单元格属性。


设置布局表格的格式

您可以在“属性”检查器中设置布局表格的多种属性，包括宽度、高度、边距和间距。

若要设置布局表格的格式，请执行以下操作：

  1. 通过单击表格顶部的标签选择一个表格。
  2. 如果“属性”检查器尚未打开，请打开“属性”检查器（“窗口”>“属性”）。

  3. 通过设置属性更改表格的格式设置。

    有关更多信息，请参见设置布局表格属性。


设置列宽度

可以为列指定一个特定的宽度或让它延伸以填充浏览器窗口尽量大的部分。也可以使用间隔图像为列指定一个最小宽度。

有时 HTML 代码中设置的列宽度与屏幕上的外观宽度不匹配。发生这种情况时，您可以使宽度一致。

本节包含以下主题：

  • 将列设置为自动伸展或固定宽度
  • 使用间隔图像
  • 使代码中的列宽与可视宽度一致


将列设置为自动伸展或固定宽度

表格中的列可以具有固定的宽度或自动延伸。有关更多信息，请参见固定的列宽度和自动伸展列。

在布局完成之前让某个列自动伸展可能会对表格布局产生无法预料的效果。为了防止列变得出乎意料得宽或窄，在让某个列自动伸展之前，请先创建完整的布局，并在使列自动伸展时使用间隔图像。（但是，如果每个列都包含其他内容，可以使该列保持所需的宽度，则无需使用间隔图像。）

使列自动伸展：

  1. 执行下列操作之一：
    • 单击列标题菜单，然后选择“列设置为自动伸展”。

    • 通过单击列中的一个单元格的边缘来选择该单元格，然后在属性检查器中单击“自动伸展”。

      注意

      在给定的表格中您只能让一个列自动伸展。

    如果尚未给该站点设置间隔图像，将出现“选择间隔图像”对话框。

  2. 如果出现“选择间隔图像”对话框，请选择一个选项，然后单击“确定”。

    有关更多信息，请参见设置“选择间隔图像”对话框选项。

在自动伸展列的顶部或底部会出现波浪线。在包含间隔图像的列的顶部或底部会出现双线。

若要将某个列设置为固定宽度，请执行以下操作之一：

  • 单击列标题菜单，然后选择“使列宽度固定”。

    “使列宽度固定”（在代码中）为该列指定一个宽度，该宽度与该列的当前可视宽度匹配。

  • 通过单击列中的一个单元格的边缘来选择该单元格，然后在属性检查器中单击“固定”并键入一个数值。

    如果您输入的数值小于列内容的宽度，则 Dreamweaver 将自动设置宽度以匹配内容的宽度。

在列的顶部或底部会出现列宽度。

相关主题

  • 使用间隔图像
  • 使代码中的列宽与可视宽度一致


使用间隔图像

若要将列的最小宽度限制到某一特定值，可在该列中插入一个间隔图像。有关更多信息，请参见间隔图像。您可以从单个列或整个表格中删除间隔图像。

第一次插入间隔图像时，您可以为站点设置间隔图像。您可以为间隔图像设置首选参数（请参见设置“布局”模式的首选参数）。

若要将间隔图像插入到列中，请执行以下操作：

  1. 单击列标题菜单，然后选择“添加间隔图像”。

    如果尚未给该站点设置间隔图像，将出现“选择间隔图像”对话框。

  2. 如果出现“选择间隔图像”对话框，请选择一个选项，然后单击“确定”。

    有关更多信息，请参见设置“选择间隔图像”对话框选项。

Dreamweaver 可以将间隔图像插入到列中。该图像是不可见的，但该列可能稍有移位，顶部或底部会显示双线以表明它包含一个间隔图像。

若要从单个列中删除间隔图像，请执行以下操作：

  • 单击列标题菜单，然后选择“删除间隔图像”。

Dreamweaver 删除间隔图像。列可能会产生移位。

若要从表格中删除所有间隔图像，请执行以下操作之一：

  • 单击表格标题菜单，然后选择“删除所有间隔图像”。
  • 选择该表格，然后单击属性检查器（“窗口”>“属性”）中的“删除所有间隔图像”按钮。 这是所描述的功能的图片。

整个表格的布局可能会产生移位。如某些列中没有内容，则这些列可能从“设计”视图中完全消失。


使代码中的列宽与可视宽度一致

如果您看到一个列的宽度有两个数字，说明 HTML 代码中设置的列宽度与这些列在屏幕上的外观宽度不匹配。可以使代码中指定的宽度与可视宽度相匹配。有关更多信息，请参见关于在“布局”模式中查看表格与单元格宽度。

若要使宽度一致，请执行以下操作：

  1. 单击一个单元格。
  2. 执行下列操作之一：
    • 单击表格标题菜单，然后选择“使所有宽度一致”。

    • 选择该表格，然后单击属性检查器（“窗口”>“属性”）中的“删除所有间隔图像”按钮。 这是所描述的功能的图片。

    Dreamweaver 重置代码中指定的宽度以匹配可视宽度。

相关主题

  • 将列设置为自动伸展或固定宽度
  • 使用间隔图像


设置“布局”模式的首选参数

您可以指定间隔图像文件的首选参数以及 Dreamweaver 用来绘制布局表格和布局单元格的颜色的首选参数。

若要设置“布局”模式首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或Dreamweaver>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从左侧的类别列表中选择“布局模式”。
  3. 按需要进行更改。

    有关更多信息，请参见设置“布局模式首选参数”对话框选项。

  4. 单击“确定”。


参考资料

本节提供在本章介绍的对话框和检查器的有关信息：

  • 设置布局单元格属性
  • 设置布局表格属性
  • 设置“选择间隔图像”对话框选项
  • 设置“布局模式首选参数”对话框选项


设置布局单元格属性

此属性检查器允许您设置布局单元格的属性。

若要设置布局单元格的属性，请执行以下操作：

  1. 设置以下任一选项：

    固定将单元格设置为固定宽度。在旁边的文本框中输入宽度（以像素为单位）（请参见设置列宽度）。

    自动伸展使单元格自动伸展（请参见设置列宽度）。

    高度是单元格的高度（以像素为单位）。

    背景颜色是布局单元格的背景颜色。单击颜色框并在颜色选择器中选择一种颜色，或在旁边的文本框中输入对应于某种颜色的十六进制数字。

    水平设置单元格内容的水平对齐方式。您可以将该对齐设置为“左对齐”、“居中对齐”、“右对齐”或“默认”。

    垂直设置单元格内容的垂直对齐方式。您可以将该对齐设置为“顶对齐”、“居中”、“底部”、“基线”或“默认”。

    不换行禁止文字换行。当选择了此选项后，布局单元格按需要加宽以适应文本，而不是在新的一行上继续该文本。

  2. 如果您在文本框中输入了值，则可以按 Tab 键或Enter 键 (Windows) 或 Return 键 (Macintosh) 来应用该值。

相关主题

  • 设置布局单元格和表格的格式


设置布局表格属性

此属性检查器允许您设置布局表格的属性。

若要设置布局表格的属性，请执行以下操作：

  1. 设置以下任一选项：

    固定将表格设置为固定宽度。

    在旁边的文本框中输入宽度（以像素为单位）（请参见设置列宽度）。

    自动伸展使表格最右边的列自动伸展（请参见设置列宽度）。

    高度是表格的高度（以像素为单位）。

    单元格边距设置布局单元格内容和单元格边框之间的间隔（以像素为单位）。

    如果您更改单元格边距时出现一个带有括号的布局表格列宽，请使用“使单元格宽度一致”选项。

    单元格间距设置相邻布局单元格之间的间隔（以像素为单位）。

    如果您更改单元格间距时出现一个带有括号的布局表格列宽，请使用“使单元格宽度一致”选项。

    清除行高删除布局表格中所有单元格的显式高度设置。

    即使某些单元格是空的，Dreamweaver 也会在您绘制单元格时指定显式单元格高度以显示您的布局。因此，您应该先将内容放置到布局单元格后再单击该按钮；否则，空单元格将在垂直方向收缩。

    注意

    清除行高可能会对布局表格中的空白（灰色）区域（即不包含任何单元格的区域）产生无法预料的效果。特别是某些空白行可能从表格中被完全删除，表格看上去在垂直方向发生收缩。

    使单元格宽度一致如果您的布局中有固定宽度的单元格，则该选项使 HTML 代码中的单元格宽度与它们在屏幕上的外观宽度匹配。

    当您单击“使单元格宽度一致”时，Dreamweaver 将重置表格中每个单元格在 HTML 中指定的宽度以匹配该单元格中内容的宽度。

    删除所有间隔图像从您的布局表格中删除间隔图像（用来在布局中控制间距的透明图像）。（有关更多信息，请参见使用间隔图像。）

    注意

    删除间隔图像可能导致表格中的某些列变得非常窄。通常情况下，您应该在适当的位置保留间隔图像，除非每个列都包含其他内容可以将该列保持在所需的宽度。

    删除嵌套删除嵌套在另一个布局表格中的布局表格，而不丢失它的任何内容。

    内部的布局表格消失；它包含的布局单元格成为外部表格的一部分。

  2. 如果您在文本框中输入了值，则可以按 Tab 键或Enter 键 (Windows) 或 Return 键 (Macintosh) 来应用该值。

相关主题

  • 设置布局单元格和表格的格式


设置“选择间隔图像”对话框选项

如果要使列自动伸展，则此对话框允许您选择是否使用间隔图像以及使用哪一个间隔图像。

如果要将间隔图像添加到列中，则此对话框允许您选择使用哪一个间隔图像。

若要完成“选择间隔图像”对话框，请执行以下操作：

  1. 选择以下选项之一：

    创建间隔图像文件创建一个 GIF 图像以用作间隔图像，并允许您选择一个存储该间隔图像文件的文件夹，例如您的站点的图像文件夹。如果您没有为站点创建间隔图像文件，将使用这个推荐的选项。

    使用现有的间隔图像文件允许您指定现有的间隔图像文件用于自动伸展表格中。间隔图像应该是单像素的透明 GIF。

    不要对自动伸展表格使用间隔图像指定 Dreamweaver 应该避免向表格中自动添加间隔图像。（如果您插入间隔图像时没有使列自动伸展，则不会出现此选项。）如果您选择此选项，则布局中固定宽度的列可能收缩到一个较小的宽度，甚至收缩为零宽度；间隔图像帮助将布局的结构维持在最初绘制它时的状态。只有当您已经将足够的内容放置在固定宽度的列中以防止它们收缩时或者已经手动添加了间隔图像时，才使用此选项。

  2. 单击“确定”。

相关主题

  • 使用间隔图像


设置“布局模式首选参数”对话框选项

此对话框允许您设置“布局”模式首选参数。

若要完成“布局模式首选参数”对话框，请执行以下操作：

  1. 指定以下任意选项：

    自动插入间隔图像指定 Dreamweaver 是否应该在您将列设置为自动伸展时自动插入间隔图像（请参见设置列宽度）。

    注意

    如果选择不在自动伸展的表格中使用间隔图像，则固定宽度的列可能会改变大小，如果列中不包含内容，它们甚至会从“设计”视图中完全消失。（即使这些列不显示在“设计”视图中，它们仍将存在于代码中。）

    间隔图像为您的站点设置间隔图像文件。

    从“站点”菜单中选择一个站点，然后单击“创建”按钮创建一个新的间隔图像文件，或单击“浏览”按钮定位该站点中现有的间隔图像文件。

    单元格外框设置布局单元格外框的颜色。

    单元格高亮设置当移动鼠标指针移动到某个单元格时该布局单元格外框的颜色。

    表格外框设置布局表格外框的颜色。

    表格背景设置布局表格中没有布局单元格的区域的颜色。

  2. 单击“确定”。

相关主题

  • 设置“布局”模式的首选参数


使用框架

框架提供将一个浏览器窗口划分为多个区域、每个区域都可以显示不同 HTML 文档的方法。使用框架的最常见的情况就是，一个框架显示包含导航控件的文档，而另一个框架显示含有内容的文档。

注意

有关设计和使用框架的所有方式的详细论述以及对它们进行硬编码所需的代码，并不在本章论述的范围之内。如果您需要有关在高级框架布局中使用的代码的详细信息，请参见有关框架和框架集的手册。

本章包含下列章节：

关于框架和框架集

在“文档”窗口中使用框架集

创建框架和框架集

选择框架和框架集

在框架中打开文档

保存框架和框架集文件

查看和设置框架属性

查看和设置框架集属性

控制具有链接的框架内容

处理不能显示框架的浏览器

将 JavaScript 脚本用于框架


关于框架和框架集

框架 是浏览器窗口中的一个区域，它可以显示与浏览器窗口的其余部分中所显示内容无关的 HTML 文档。

框架集 是 HTML 文件，它定义一组框架的布局和属性，包括框架的数目、框架的大小和位置以及在每个框架中初始显示的页面的 URL。框架集文件本身不包含要在浏览器中显示的 HTML 内容，但 noframes 部分除外（请参见处理不能显示框架的浏览器）；框架集文件只是向浏览器提供应如何显示一组框架以及在这些框架中应显示哪些文档的有关信息。

本节包含以下概念性主题：

  • 了解框架和框架集如何工作
  • 决定是否使用框架
  • 了解嵌套的框架集

相关主题

  • 在“文档”窗口中使用框架集
  • 创建框架和框架集


了解框架和框架集如何工作

框架 是浏览器窗口中的一个区域，它可以显示与浏览器窗口的其余部分中所显示内容无关的 HTML 文档。框架集 是 HTML 文件，它定义一组框架的布局和属性。

要在浏览器中查看一组框架，请输入框架集文件的 URL；浏览器随后打开要显示在这些框架中的相应文档。通常将一个站点的框架集文件命名为 index.html，以便当访问者未指定文件名时默认显示该名称。

下面的示例显示了一个由三个框架组成的框架布局：一个较窄的框架位于侧面，其中包含导航条；一个框架横放在顶部，其中包含 Web 站点的徽标和标题；一个大框架占据了页面的其余部分，其中包含主要内容。这些框架中的每一个都显示单独的 HTML 文档。

在此示例中，当访问者浏览站点时，在顶部框架中显示的文档永远不更改。侧面框架导航条包含链接；单击其中某一链接会更改主要内容框架的内容，但侧面框架本身的内容保持静态。无论访问者在左侧单击了哪一个链接，右侧主要内容框架都会显示适当的文档。

请注意，框架不是文件。您很可能会以为当前显示在框架中的文档是构成框架的一部分，但该文档实际上并不是框架的一部分。框架是存放文档的容器 － 任何一个框架都可以显示任意一个文档。

注意

页面一词含义较为宽泛，既可以表示单个 HTML 文档，也可以表示给定时刻浏览器窗口中的全部内容，即使当时同时显示有几个 HTML 文档。例如，短语“使用框架的页面”通常表示一组框架以及最初在这些框架中显示的文档。

如果一个站点在浏览器中显示为包含三个框架的单个页面，则它实际上至少由四个单独的 HTML 文档组成：框架集文件以及三个文档，这三个文档包含这些框架内初始显示的内容。当您在 Dreamweaver 中设计使用框架集的页面时，您必须保存全部这四个文件，以便该页面可以在浏览器中正常工作。

相关主题

  • 决定是否使用框架
  • 了解嵌套的框架集


决定是否使用框架

框架的最常见用途就是导航。一组框架通常包括一个含有导航条的框架和另一个要显示主要内容页面的框架。

但是，框架的设计可能比较复杂；并且在许多情况下，您可以创建没有框架的 Web 页，它可以达到使用一组框架所能达到的许多同样效果。例如，如果您想让导航条显示在页面的左侧，则既可以用一组框架代替您的页面，也可以只是在站点中的每一页上包含该导航条。（Dreamweaver 可以帮助您创建使用相同布局的多个页面；请参见关于 Dreamweaver 模板。）下图显示了具有类似框架布局的页面设计，但在设计中并没有使用框架。

许多专业 Web 设计人员不喜欢使用框架，并且许多浏览 Web 的人也不喜欢框架。在大多数情况下，这种反感是因为遇到了那些使用框架效果不佳或不必要地使用框架的站点（例如，每当访问者单击导航按钮时就重新加载导航框架内容的框架集）。如果框架使用得法（例如，在允许其他框架的内容发生更改的同时，使一个框架中的导航控件保持静态），则这些框架对于某些站点可能非常有用。

并不是所有的浏览器都提供良好的框架支持，框架对于无法导航的访问者而言可能难以显示。所以，如果您确实要使用框架，应始终在您的框架集中提供 noframes 部分，以方便不能查看这些框架的访问者。（请参见处理不能显示框架的浏览器）。您最好还要提供指向站点的无框架版本的显式链接，以用于那些虽然其浏览器支持框架但不喜欢使用框架的访问者。

使用框架具有以下优点：

  • 访问者的浏览器不需要为每个页面重新加载与导航相关的图形。
  • 每个框架都具有自己的滚动条（如果内容太大，在窗口中显示不下），因此访问者可以独立滚动这些框架。

    例如，当框架中的内容页面较长时，如果导航条位于不同的框架中，那么向下滚动到页面底部的访问者就不需要再滚动回顶部来使用导航条。

使用框架具有以下缺点：

  • 可能难以实现不同框架中各元素的精确图形对齐。
  • 对导航进行测试可能很耗时间。
  • 各个带有框架的页面的 URL 不显示在浏览器中，因此访问者可能难以将特定页面设为书签（除非您提供了服务器代码，使访问者可以加载特定页面的带框架版本。）

相关主题

  • 了解框架和框架集如何工作
  • 处理不能显示框架的浏览器


了解嵌套的框架集

在另一个框架集之内的框架集称作嵌套的框架集。一个框架集文件可以包含多个嵌套的框架集。大多数使用框架的 Web 页实际上都使用嵌套的框架，并且在 Dreamweaver 中大多数预定义的框架集也使用嵌套。如果在一组框架里，不同行或不同列中有不同数目的框架，则要求使用嵌套的框架集。

例如，最常见的框架布局在顶行有一个框架（框架中显示公司的徽标），并且在底行有两个框架（一个导航框架和一个内容框架）。此布局要求嵌套的框架集：一个两行的框架集，在第二行中嵌套了一个两列的框架集。

Dreamweaver 会根据需要自动嵌套框架集；如果您在 Dreamweaver 中使用框架拆分工具，则您就不需要考虑哪些框架将被嵌套、哪些框架不被嵌套这样的细节。有关框架拆分工具的更多信息，请参见设计框架集。

有两种方法可在 HTML 中嵌套框架集：内部框架集可以与外部框架集在同一文件中定义，也可以在不同文件中单独定义。Dreamweaver 中每个预定义的框架集均在同一文件中定义其所有框架集。

这两种类型的嵌套均产生相同的视觉效果；如果没有看到代码，很难判断使用的是哪种类型的嵌套。在 Dreamweaver 中使用外部框架集文件的最常见情况如下：使用“在框架中打开”命令在框架内打开框架集文件时，可能导致设置链接目标时出现问题。通常最简单的方法是在单个文件中定义所有的框架集。

相关主题

  • 了解框架和框架集如何工作
  • 决定是否使用框架


在“文档”窗口中使用框架集

Dreamweaver 使您可以在一个“文档”窗口中查看和编辑与一组框架关联的所有文档。此方法使您可以在编辑带有框架的页面时大致看到它们在浏览器中的显示方式。但是，在您熟练使用它们之前，此方法的某些方面可能会令人混淆。

尤其要记住，每个框架都显示单独的 HTML 文档。即使文档是空的，您也必须将它们全部保存以预览它们（因为只有当框架集包含要在每个框架中显示的文档的 URL 时，才可以准确预览该框架集）。

要确保框架集在浏览器中正确显示，请执行以下操作：

  1. 创建框架集并指定要在每个框架中显示的文档（请参见创建框架和框架集）。
  2. 保存将要在框架中显示的每个文件（请参见保存框架和框架集文件）。

    请记住，每个框架都显示单独的 HTML 文档，必须保存每个文档以及该框架集文件。

  3. 为每个框架以及该框架集设置属性（请参见查看和设置框架属性和查看和设置框架集属性）。

    这包括命名每个框架、设置滚动和不滚动选项等。

  4. 确保在“属性”检查器中为所有链接设置了“目标”属性，以便所链接的内容显示在正确区域中（请参见控制具有链接的框架内容）。


创建框架和框架集

在 Dreamweaver 中有两种创建框架集的方法：您既可以从若干预定义的框架集中选择，也可以自己设计框架集。

选择预定义的框架集将自动设置创建布局所需的所有框架集和框架，它是迅速创建基于框架的布局的最简单方法。您只能在“文档”窗口的“设计”视图中插入预定义的框架集。

本节包含以下主题：

  • 使用预定义的框架集
  • 设计框架集


使用预定义的框架集

通过预定义的框架集，您可以很容易地选择您要创建的框架集类型。如果您想设计自己的框架集，请参见设计框架集。

创建预定义的框架集有两种方法：

  • 通过插入栏，您可以创建框架集并在某一个新的框架中显示当前文档。
  • “新建文档”对话框创建新的空框架集。

要创建预定义的框架集并在某一框架中显示现有文档，请执行以下操作：

  1. 将插入点放置在文档中。
  2. 执行下列操作之一：
    • 从“插入”>“HTML”>“框架”子菜单中选择预定义的框架集。
    • 在“插入”栏的“布局”类别中，单击“框架”按钮上的下拉箭头，然后选择预定义的框架集。

    框架集图标提供应用于当前文档的每个框架集的可视化表示形式。框架集图标的蓝色区域表示当前文档，而白色区域表示将显示其它文档的框架。

    注意

    当您应用框架集时，Dreamweaver 将自动设置该框架集，以便在某一框架中显示当前文档（插入点所在的文档）。

    如果已将 Dreamweaver 设置为提示您输入框架辅助功能属性，则会出现“框架标签辅助功能属性”对话框（请参见优化工作区以进行有辅助功能的页面设计）。

  3. 如果出现“框架标签辅助功能属性”对话框，请为每个框架完成此对话框，然后单击“确定”。

    有关更多信息，请参见设置“框架标签辅助功能属性”对话框选项。

    注意

    如果您单击“取消”，该框架集将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

    要编辑框架标签辅助功能属性，请参见查看和设置框架属性。

要创建新的空预定义框架集，请执行以下操作：

  1. 选择“文件”>“新建”。
  2. 在“新建文档”对话框中，选择“框架集”类别。
  3. 从“框架集”列表选择框架集。
  4. 单击“创建”。

    则框架集出现在文档中，并且如果已经在“首选参数”中激活了“框架标签辅助功能属性”对话框，那么该对话框也将出现（请参见优化工作区以进行有辅助功能的页面设计）。

  5. 如果出现“框架标签辅助功能属性”对话框，请为每个框架完成此对话框，然后单击“确定”。

    有关更多信息，请参见设置“框架标签辅助功能属性”对话框选项。

    注意

    如果您按“取消”，该框架集将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

    要编辑框架标签辅助功能属性，请参见查看和设置框架属性。


设计框架集

您可以通过向窗口添加“拆分器”，在 Dreamweaver 中设计您自己的框架集。如果您喜欢使用预定义的框架集，请参见使用预定义的框架集。

提示

在创建框架集或使用框架前，通过选择“查看”>“可视化助理”>“框架边框”，使框架边框在“文档”窗口的“设计”视图中可见。

若要创建框架集，请执行以下操作：

  • 选择“修改”>“框架集”，然后从子菜单选择拆分项（例如“拆分左框架”或“拆分右框架”）。

    Dreamweaver 将窗口拆分成几个框架。如果打开一个现有的文档，它将出现在其中一个框架中。

要将一个框架拆分成几个更小的框架，请执行以下操作：

  • 要拆分插入点所在的框架，从“修改”>“框架集”子菜单选择拆分项。
  • 要以垂直或水平方式拆分一个框架或一组框架，请将框架边框从“设计”视图的边缘拖入“设计”视图的中间。
  • 要使用不在“设计”视图边缘的框架边框拆分一个框架，请在按住 Alt 键的同时拖动框架边框 (Windows) 或在按住 Option 键的同时拖动框架边框 (Macintosh)。
  • 要将一个框架拆分成四个框架，请将框架边框从“设计”视图一角拖入框架的中间。

    提示

    若要创建三个框架，请首先创建两个框架，然后拆分其中一个框架。不编辑框架集代码是很难合并两个相邻框架的，所以将四个框架转换成三个框架要比将两个框架转换成三个框架更难。

若要删除一个框架，请执行以下操作：

  • 将边框框架拖离页面或拖到父框架的边框上。

    如果要删除的框架中的文档有未保存的内容，则 Dreamweaver 将提示您保存该文档。

    注意

    您不能通过拖动边框完全删除一个框架集。要删除一个框架集，请关闭显示它的“文档”窗口。如果该框架集文件已保存，则删除该文件。

若要调整框架的大小，请执行以下操作之一：

  • 若要设置框架的粗略大小，请在“文档”窗口的“设计”视图中拖动框架边框。
  • 若要指定准确大小，并指定当浏览器窗口大小不允许框架以全大小显示时，浏览器分配给框架的行或列的大小，可使用“属性”检查器（请参见查看和设置框架集属性）。


选择框架和框架集

要更改框架或框架集的属性，首先要选择您要更改的框架或框架集。您既可以在“文档”窗口中选择框架或框架集，也可以通过“框架”面板进行选择。

本节包含以下主题：

  • 在“框架”面板中选择框架和框架集
  • 在“文档”窗口中选择框架和框架集


在“框架”面板中选择框架和框架集

“框架”面板提供框架集内各框架的可视化表示形式。它能够显示框架集的层次结构，而这种层次在“文档”窗口中的显示可能不够直观。在“框架”面板中，环绕每个框架集的边框非常粗；而环绕每个框架的是较细的灰线，并且每个框架由框架名称标识。

要显示“框架”面板，请执行以下操作：

  • 选择“窗口”>“框架”。

要在“框架”面板中选择一个框架，请执行以下操作：

  • 在“框架”面板中单击框架。

    在“框架”面板和“文档”窗口的“设计”视图中，框架周围都会显示一个选择轮廓。

要在“框架”面板中选择一个框架集，请执行以下操作：

  • 在“框架”面板中单击环绕框架集的边框。

    在“框架”面板和“文档”窗口的“设计”视图中，框架集周围都会显示一个选择轮廓。

相关主题

  • 在“文档”窗口中选择框架和框架集
  • 查看和设置框架属性
  • 查看和设置框架集属性


在“文档”窗口中选择框架和框架集

在“文档”窗口的“设计”视图中，在选定了一个框架后，其边框被虚线环绕；在选定了一个框架集后，该框架集内各框架的所有边框都被淡颜色的虚线环绕。

注意

将插入点放置在框架内显示的文档中并不等同于选择一个框架。有多种不同的操作（例如设置框架属性）要求您必须选择框架。

要在“文档”窗口中选择一个框架，请执行以下操作：

  • 在“设计”视图中，按住 Alt 键的同时单击框架内部 (Windows) 或在按住 Option 和 Shift 键的同时单击框架内部 (Macintosh)。

    在框架周围显示一个选择轮廓。

要在“文档”窗口中选择一个框架集，请执行以下操作：

  • 在“设计”视图中，单击框架集的某一内部框架边框。（要执行这一操作，框架边框必须是可见的；如果看不到框架边框，则选择“查看”>“可视化助理”>“框架边框”以使框架边框可见。）

    在框架集周围显示一个选择轮廓。

    注意

    在“框架”面板中选择框架集通常比在“文档”窗口中选择框架集容易。有关更多信息，请参见在“框架”面板中选择框架和框架集。

要选择不同的框架或框架集，请执行以下操作之一：

  • 要在当前选定内容的同一层次级别上选择下一框架（框架集）或前一框架（框架集），请在按住 Alt 键的同时按下左箭头键或右箭头键 (Windows)，或在按住 Command 键的同时按下左箭头键或右箭头键 (Macintosh)。使用这些键，您可以按照框架和框架集在框架集文件中定义的顺序依次选择这些框架和框架集。
  • 要选择父框架集（包含当前选定内容的框架集），请在按住 Alt 键的同时按上箭头键 (Windows) 或在按住 Command 键的同时按上箭头键 (Macintosh)。
  • 要选择当前选定框架集的第一个子框架或框架集（即，按在框架集文件中定义顺序中的第一个），按住 Alt 键的同时按下箭头键 (Windows) 或在按住 Command 键的同时按下箭头键 (Macintosh)。

相关主题

  • 在“框架”面板中选择框架和框架集
  • 查看和设置框架属性
  • 查看和设置框架集属性


在框架中打开文档

您可以通过将新内容插入框架的空文档中，或通过在框架中打开现有文档，来指定框架的初始内容。

要在框架中打开现有文档，请执行以下操作：

  1. 将插入点放置在框架中。
  2. 选择“文件”>“在框架中打开”。
  3. 选择要在该框架中打开的文档，然后单击“确定”(Windows) 或“选择”(Macintosh)。

    该文档随即显示在框架中。

  4. （可选）要令该文档成为在浏览器中打开框架集时在框架中显示的默认文档，请保存该框架集。有关更多信息，请参见保存框架和框架集文件。


保存框架和框架集文件

在浏览器中预览框架集前，您必须保存框架集文件以及要在框架中显示的所有文档。您可以单独保存每个框架集文件和带框架的文档，您也可以同时保存框架集文件和框架中出现的所有文档。

注意

在您使用 Dreamweaver 中的可视工具创建一组框架时，框架中显示的每个新文档将获得一个默认文件名。例如，第一个框架集文件被命名为“UntitledFrameset-1”，而框架中第一个文档被命名为“UntitledFrame-1”。

要保存框架集文件，请执行以下操作：

  1. 在“框架”面板或“文档”窗口中选择框架集（请参见选择框架和框架集）。
  2. 执行下列操作之一：
    • 若要保存框架集文件，请选择“文件”>“保存框架集”。
    • 若要将框架集文件另存为新文件，请选择“文件”>“框架集另存为”。

    如果以前没有保存过该框架集文件，则这两个命令是等效的。

若要保存框架中显示的文档，请执行以下操作：

  • 在框架中单击，然后选择“文件”>“保存框架”或选择“文件”>“框架另存为”。

要保存与一组框架关联的所有文件，请执行以下操作：

  • 选择“文件”>“保存所有框架”。

    该命令将保存在框架集中打开的所有文档，包括框架集文件和所有带框架的文档。如果该框架集文件未保存过，则在“设计”视图中框架集的周围将出现粗边框，并且出现一个对话框，您可从中选择文件名。对于尚未保存的每个框架，在框架的周围都将显示粗边框，并且出现一个对话框，您可从中选择文件名。

    注意

    如果您使用“文件”>“在框架中打开”在框架中打开文档，则当您保存框架集时，您在框架中打开的文档将成为在该框架中显示的默认文档。如果您不希望该文档成为默认文档，则不要保存框架集文件。


查看和设置框架属性

使用属性检查器可以查看和设置大多数框架属性。

您还可以设置某些框架属性，如 title 属性（它和 name 属性不同），以改进辅助功能。在创建框架时，可以使用用于框架的辅助功能创作选项来设置属性（请参见优化工作区以进行有辅助功能的页面设计），或者可以在插入框架后设置属性。若要编辑框架的辅助功能属性，请直接使用标签检查器编辑 HTML 代码。

若要设置框架集属性，请参见查看和设置框架集属性。

要查看或设置框架属性，请执行以下操作：

  1. 通过执行以下操作之一选择框架：
    • 在“文档”窗口的“设计”视图中，按住 Alt 键的同时单击一个框架 (Windows) 或在按住 Shift 和 Option 键的同时单击一个框架 (Macintosh)。
    • 在“框架”面板（“窗口”>“框架”）中单击框架。
  2. 在“属性”检查器（“窗口”>“属性”）中，单击右下角的展开箭头，查看所有框架属性。

  3. 按需要进行更改。

    有关如何在框架“属性”检查器中设置特定选项的信息，请参见设置框架属性检查器选项。

    提示

    要更改框架的背景颜色，请在页面属性中设置该框架中文档的背景颜色。

若要设置框架的辅助功能值，请执行以下操作：

  1. 在“框架”面板（“窗口”>“框架”）中，通过将插入点放在一个框架中来选择框架。
  2. 选择“修改”>“编辑标签”。

    即会显示标签编辑器。

  3. 从左侧的类别列表中选择“样式表/辅助功能”。
  4. 按需要输入值。
  5. 单击“确定”。

若要编辑框架的辅助功能值，请执行以下操作：

  1. 如果您当前正在“设计”视图中，请显示文档的“代码”视图或“代码和设计”视图。
  2. 在“框架”面板（“窗口”>“框架”）中，通过将插入点放在一个框架中来选择框架。

    Dreamweaver 高亮显示代码中的框架标签。

  3. 在代码中右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“编辑标签”。

    即会显示标签编辑器。

  4. 按需要进行更改。
  5. 单击“确定”。

若要更改框架中文档的背景颜色，请执行以下操作：

  1. 将插入点放置在框架中。
  2. 选择“修改”>“页面属性”。

    “页面属性”对话框随即出现。

  3. 单击“背景颜色”弹出式菜单，选择一种颜色。
  4. 单击“确定”。

相关主题

  • 创建框架和框架集


查看和设置框架集属性

使用“属性”检查器可以查看和设置大多数框架集属性。若要设置框架的属性，请参见查看和设置框架属性。

要查看或设置框架集属性，请执行以下操作：

  1. 通过执行以下操作之一选择框架集：
    • 在“文档”窗口的“设计”视图中单击框架集中两个框架之间的边框。
    • 在“框架”面板（“窗口”>“框架”）中单击围绕框架集的边框。
  2. 在“属性”检查器（“窗口”>“属性”）中，单击右下角的展开箭头，查看所有框架集属性。

  3. 按需要进行更改。

    有关如何在框架集“属性”检查器中设置特定选项的信息，请参见设置框架集“属性”检查器选项。

要设置框架集文档的标题，请执行以下操作：

  1. 通过执行以下操作之一选择框架集：
    • 在“文档”窗口的“设计”视图中单击框架集中两个框架之间的边框。
    • 在“框架”面板（“窗口”>“框架”）中单击围绕框架集的边框。
  2. 在“文档”工具栏的“标题”字段中，键入框架集文档的名称。

    当访问者在浏览器中查看该框架集时，标题显示在浏览器的标题栏中。

相关主题

  • 创建框架和框架集


控制具有链接的框架内容

要在一个框架中使用链接以打开另一个框架中的文档，您必须设置链接目标。链接的 target 属性指定在其中打开链接的内容的框架或窗口。

例如，如果您的导航条位于左框架，并且您希望链接的材料显示在右侧的主要内容框架中，则您必须将主要内容框架的名称指定为每个导航条链接的目标。当访问者单击导航链接时，将在主框架中打开指定的内容。

若要设置目标框架，请执行以下操作：

  1. 在“设计”视图中，选择文本或对象。
  2. 在属性检查器（“窗口”>“属性”）的“链接”字段中，执行以下操作之一：
    • 单击文件夹图标并选择要链接到的文件。
    • 将“指向文件”图标拖动到“文件”面板以选择要链接到的文件。
  3. 在属性检查器的“目标”弹出式菜单中，选择链接的文档应在其中显示的框架或窗口：
    • _blank 在新的浏览器窗口中打开链接的文档，同时保持当前窗口不变。
    • _parent 在显示链接的框架的父框架集中打开链接的文档，同时替换整个框架集。
    • _self 在当前框架中打开链接，同时替换该框架中的内容。
    • _top 在当前浏览器窗口中打开链接的文档，同时替换所有框架。

    框架名称也出现在该菜单中。选择一个命名框架以打开该框架中链接的文档。

    注意

    只有当您在框架集内编辑文档时才显示框架名称。当您在文档自身的“文档”窗口中编辑该文档时，框架名称不显示在“目标”弹出式菜单中。如果您正在编辑框架集外的文档，则您可以将目标框架的名称键入“目标”文本框中。

    提示

    如果您正链接到您的站点外的某一页面，请始终使用 target="_top" 或 target="_blank" 来确保该页面不会显示为您站点的一部分。

相关主题

  • 设置框架属性检查器选项


处理不能显示框架的浏览器

Dreamweaver 允许您指定要在不支持框架的基于文本的浏览器和较旧的图形浏览器中显示的内容。此类内容存储在框架集文件中，用 noframes 标签括起来。当不支持框架的浏览器加载该框架集文件时，浏览器只显示用 noframes 标签括起来的内容。

注意

noframes 区域中的内容应该不只是“您应升级到可以处理框架的浏览器”这样的注释。某些人士会因一些合理的原因而使用不允许其查看框架的系统。尝试尽可能使此类访问者也可以访问您的内容。

若要为不支持框架的浏览器提供内容，请执行以下操作：

  1. 选择“修改”>“框架集”>“编辑无框架内容”。

    Dreamweaver 将清除“设计”视图中的内容，并且在“设计”视图顶部将显示“无框架内容”字样。

  2. 要创建无框架内容，请执行以下操作之一：
    • 在“文档”窗口中，像处理普通文档一样键入或插入内容。
    • 选择“窗口”>“代码检查器”，将插入点置于 noframes 标签中的 body 标签之间，然后键入内容的 HTML 代码。
  3. 再次选择“修改”>“框架集”>“编辑无框架内容”以返回到框架集文档的普通视图。


将 JavaScript 脚本用于框架

有几个特别适合用于框架的 JavaScript 行为和与导航相关的命令：

“设置框架文本”用您指定的内容代替给定框架的内容和格式。内容可以包括任何有效的 HTML。使用此操作可以动态显示框架中的信息。（请参见设置框架文本。）

“转到 URL”在当前窗口中或在指定框架中打开新页面。此操作尤其适用于通过一次单击更改两个或多个框架的内容。（请参见转到 URL。）

“插入导航条”将导航条添加到页面上；在插入导航条后，您可以将行为附加到其图像上，并设置基于访问者的操作显示哪个图像。例如，您可能想要按朝上或朝下的状态显示按钮图像，以便让访问者知道正在查看站点的哪个页面。（请参见插入导航条。）

“插入跳转菜单”设置当单击时在浏览器窗口中打开文件的链接的菜单列表。您还可以设置要在其中打开文档的特定目标窗口或框架。（请参见插入跳转菜单。）


参考资料

本节提供在本章介绍的下列对话框和检查器的有关信息：

  • 设置框架属性检查器选项
  • 设置框架集“属性”检查器选项
  • 设置“框架标签辅助功能属性”对话框选项


设置框架属性检查器选项

使用此属性检查器可以命名一个框架并设置边框和边距。

提示

务必单击“属性”检查器左下角的展开箭头，查看所有框架属性。

设置框架属性将重写框架集中该属性的设置。例如，在框架中设置的边框属性将重写在框架集中设置的边框属性。

若要指定选定框架的属性，请执行以下操作：

  1. 命名框架：

    “框架名称”是链接的 target 属性或脚本在引用该框架时所用的名称。

    框架名称必须是单个单词；允许使用下划线 (_)，但不允许使用连字符 (-)、句点 (.) 和空格。框架名称必须以字母起始（而不能以数字起始）。框架名称区分大小写。不要使用 JavaScript 中的保留字（例如 top 或 navigator）作为框架名称。

    提示

    要令链接更改其它框架的内容，您必须命名目标框架。要令以后创建跨框架链接更容易一些，请在创建框架时命名每个框架。
  2. 根据需要更改以下选项：

    “源文件”指定在框架中显示的源文档。单击文件夹图标可以浏览到一个文件并选择一个文件。

    “滚动”指定在框架中是否显示滚动条。将此选项设置为“默认”将不设置相应属性的值，从而使各个浏览器使用其默认值。大多数浏览器默认为“自动”，这意味着只有在浏览器窗口中没有足够空间来显示当前框架的完整内容时才显示滚动条。

    “不能调整大小”令访问者无法通过拖动框架边框在浏览器中调整框架大小。

    注意

    您始终可以在 Dreamweaver 中调整边框大小；该选项仅适用于在浏览器中查看框架的访问者。

    “边框”在浏览器中查看框架时显示或隐藏当前框架的边框。为框架选择“边框”选项将重写框架集的边框设置。

    “边框”选项为“是”（显示边框）、“否”（隐藏边框）和“默认值”；大多数浏览器默认为显示边框，除非父框架集已将“边框”设置为“否”。只有当共享该边框的所有框架都将“边框”设置为“否”时，或者当父框架集的“边框”属性设置为“否”并且共享该边框的框架都将“边框”设置为“默认值”时，边框才是隐藏的。

    “边框颜色”为所有框架的边框设置边框颜色。此颜色应用于和框架接触的所有边框，并且重写框架集的指定边框颜色。

    注意

    关于给定边框颜色应用到哪些框架边框有一个基础逻辑，但该逻辑十分复杂；理解为什么某些边框在指定边框颜色后还会更改颜色可能十分困难。有关指定边框颜色的效果的详细信息，请参见有关框架和框架集的书籍。
  3. 您可以根据需要设置以下边距选项（如果看不到边距选项，则单击“属性”检查器右下角的扩展箭头）：

    “边距宽度”以像素为单位设置左边距和右边距的宽度（框架边框和内容之间的空间）。

    “边距高度”以像素为单位设置上边距和下边距的高度（框架边框和内容之间的空间）。

    注意

    设置框架的边距宽度和高度并不等同于在“修改”>“页面属性”对话框中设置边距。

相关主题

  • 查看和设置框架属性


设置框架集“属性”检查器选项

使用此“属性”检查器设置框架集的边框和框架大小。

提示

务必单击“属性”检查器左下角的展开箭头，查看所有框架集属性。

设置框架属性将重写框架集中该属性的设置。例如，在框架中设置的边框属性将重写在框架集中设置的边框属性。

要指定选定框架集的边框属性，请执行以下操作：

  1. 根据需要更改以下边框选项：

    “边框”确定在浏览器中查看文档时在框架周围是否应显示边框。要显示边框，则选择“是”；要使浏览器不显示边框，则选择“否”。要允许浏览器确定如何显示边框，则选择“默认值”。

    “边框宽度”指定框架集中所有边框的宽度。

    “边框颜色”设置边框的颜色。使用颜色选择器选择一种颜色，或者键入颜色的十六进制值。

  2. 若要设置选定框架集的各行和各列的框架的大小，请单击“行列选择范围”区域左侧或顶部的选项卡；然后在“值”文本框中，输入高度或宽度。

  3. 若要指定浏览器分配给每个框架的空间大小，请从“单位”菜单中选择以下选项：

    “像素”将选定列或行的大小设置为一个绝对值。对于应始终保持相同大小的框架（例如导航条）而言，此选项是最佳选择。在为以百分比或相对值指定大小的框架分配空间前，为以像素为单位指定大小的框架分配空间。设置框架大小的最常用方法是将左侧框架设置为固定像素宽度，将右侧框架大小设置为相对大小，这样在分配像素宽度后，能够使右侧框架伸展以占据所有剩余空间。

    注意

    如果所有宽度都是以像素为单位指定的，而指定的宽度对于访问者查看框架集所使用的浏览器而言太宽或太窄，则框架将按比例伸缩以填充可用空间。这同样适用于以像素为单位指定的高度。因此，将至少一个宽度和高度指定为相对大小通常是一个不错的主意。

    “百分比”指定选定列或行应相当于其框架集的总宽度或总高度的百分比。以“百分比”为单位的框架分配空间是在以“像素”为单位的框架之后，但在将单位设置为“相对”的框架之前。

    “相对”指定在为“像素”和“百分比”框架分配空间后，为选定列或行分配其余可用空间；剩余空间在大小设置为“相对”的框架中按比例划分。

    注意

    当您从“单位”菜单中选择“相对”时，您在“值”域中输入的所有数字均消失；如果您想要指定一个数字，则必须重新输入。不过，如果只有一行或一列设置为“相对”，则不需要输入数字，因为该行或列在其他行和列已分配空间后，将接受所有剩余空间。为了确保完全的跨浏览器兼容性，您可以在“值”字段中输入 1；这等效于不输入任何值。

    框架的空间分配是十分复杂的；有关详细信息，请参见有关框架和框架集的书籍。

相关主题

  • 查看和设置框架集属性


设置“框架标签辅助功能属性”对话框选项

此对话框用于设置框架辅助功能选项。

若要设置框架辅助功能选项，请执行以下操作：

  1. 从弹出式菜单中选择一个框架。
  2. 为该框架输入一个有意义的名称。

    提示

    选择“窗口”>“框架”以查看您所命名的框架的关系图。

    对于使用屏幕阅读器的访问者，屏幕阅读器在遇到页面中的框架时，将读取此名称。

  3. 对于每个框架重复以上步骤。
  4. 单击“确定”。

    注意

    如果您按“取消”，该框架集将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

如果您没有对该对话框做出任何更改就按“确定”，则 Dreamweaver 会为该框架提供与其名称相同的标题。框架名称与其在框架集中的名称相对应（左框架、右框架等等）。

相关主题

  • 使用预定义的框架集
  • 设计框架集


管理模板

Macromedia Dreamweaver 8 模板是一种特殊类型的文档，用于设计“固定的”页面布局；您可以基于模板创建文档，从而使创建的文档继承模板的页面布局。设计模板时，可以指定在基于模板的文档中用户可以编辑文档的哪些区域。

注意

使用模板可以控制大的设计区域，以及重复使用完整的布局。如果要重复使用个别设计元素，如站点的版权信息或徽标，可以创建库项目。有关更多信息，请参见管理站点资源和库。

本章包含下列章节：

关于 Dreamweaver 模板

创建 Dreamweaver 模板

为 Contribute 站点创建模板

创建可编辑区域

创建重复区域

使用可选区域

定义可编辑标签属性

创建嵌套模板

编辑和更新模板

管理模板

导出和导入模板 XML 内容

导出不具有模板标记的站点

在现有文档中应用或删除模板

在基于模板的文档中编辑内容


关于 Dreamweaver 模板

模板创作者在模板中设计“固定的”页面布局。然后创作者在模板中创建可在基于该模板的文档中进行编辑的区域；如果创作者没有将某个区域定义为可编辑区域，那么模板用户就无法编辑该区域中的内容。使用模板，模板创作者控制哪些页面元素可以由模板用户（如作家、图形艺术家或其他 Web 开发人员）进行编辑。模板创作者可以在文档中包括数种类型的模板区域。

模板最强大的用途之一在于一次更新多个页面。从模板创建的文档与该模板保持连接状态（除非您以后分离该文档）。可以修改模板并立即更新基于该模板的所有文档中的设计。

本节包含以下概念性主题：

  • 模板区域的类型
  • “设计”视图和“代码”视图中的模板和基于模板的文档
  • 模板标签语法
  • 模板中的链接
  • 嵌套模板
  • 模板以及基于模板的文档中的服务器脚本
  • 模板参数
  • 模板表达式

相关主题

  • 创建 Dreamweaver 模板


模板区域的类型

将文档另存为模板时，Dreamweaver 自动锁定文档的大部分区域。模板创作者指定基于模板的文档中的哪些区域可编辑，方法是在模板中插入可编辑区域或可编辑参数。

创建模板时，可编辑区域和锁定区域都可以更改。但是，在基于模板的文档中，模板用户只能在可编辑区域中进行更改；无法修改锁定区域。

共有四种类型的模板区域：

可编辑区域是基于模板的文档中的未锁定区域；它是模板用户可以编辑的部分。模板创作者可以将模板的任何区域指定为可编辑的。要让模板生效，它应该至少包含一个可编辑区域；否则，将无法编辑基于该模板的页面。有关插入可编辑区域的信息，请参见插入可编辑区域。

重复区域是文档中设置为重复的布局部分。例如，可以设置重复一个表格行。通常重复部分是可编辑的，这样模板用户可以编辑重复元素中的内容，同时使设计本身处于模板创作者的控制之下。在基于模板的文档中，模板用户可以根据需要使用重复区域控制选项添加或删除重复区域的副本。

您可以在模板中插入两种类型的重复区域：重复区域和重复表格。有关在模板中插入重复区域的信息，请参见在模板中创建重复区域。有关创建重复表格的信息，请参见插入重复表格。有关在基于模板的页面中使用重复区域的信息，请参见添加、删除重复区域项以及更改其顺序。

可选区域是您在模板中指定为可选的部分，用于保存有可能在基于模板的文档中出现的内容（如可选文本或图像）。在基于模板的页面上，模板用户通常控制是否显示内容。有关在模板中设置可选区域的信息，请参见插入可选区域。有关在基于模板的页面中编辑可选区域的信息，请参见修改模板属性。

可编辑标签属性使您可以在模板中解锁标签属性，以便该属性可以在基于模板的页面中编辑。例如，可以“锁定”在文档中出现的图像，但让模板用户将对齐设为左对齐、右对齐或居中对齐。有关设置可编辑标签属性的信息，请参见在模板中指定可编辑标签属性。有关在基于模板的页面中编辑标签的信息，请参见修改模板属性。

相关主题

  • 创建可编辑区域
  • 创建重复区域
  • 使用可选区域
  • 定义可编辑标签属性


“设计”视图和“代码”视图中的模板和基于模板的文档

您可以在“设计”或“代码”视图中查看模板和基于模板的文档。

本节包含以下主题：

  • 在“设计”视图中查看模板
  • 在“代码”视图中查看模板
  • 在“设计”视图中查看基于模板的文档
  • 在“代码”视图中查看基于模板的文档


在“设计”视图中查看模板

在模板中，可编辑区域出现在“文档”窗口的“设计”视图中，并且周围环绕预设高亮颜色的矩形边框。每个区域的左上角都出现一个小的选项卡，其中显示了相应区域的名称。

注意

有关设置标记色彩首选参数的信息，请参见设置模板区域的高亮显示首选参数。

通过查看“文档”窗口中的标题栏，可以识别模板文件。模板文件的标题栏中包含单词 <<模板>>，并且模板文件的扩展名为 .dwt。

相关主题

  • 在“代码”视图中查看模板
  • 在“设计”视图中查看基于模板的文档
  • 在“代码”视图中查看基于模板的文档


在“代码”视图中查看模板

在“代码”视图中，模板中的可编辑和锁定 HTML 源代码都可以更改。

提示

可以使用代码颜色首选参数设置自己的配色方案，以便在“代码”视图中查看文档时可以轻松地区分模板区域（请参见为模板自定义代码颜色首选参数）。

可编辑内容区域在 HTML 中使用以下注释标记：

<!-- TemplateBeginEditable> 和 <!-- TemplateEndEditable -->

这些注释之间的任何内容都可以在基于模板的文档中编辑。可编辑区域的 HTML 源代码可能类似于下列形式：

<table width="75%"  border="1"  cellspacing="0" cellpadding="0">
  <tr bgcolor="#333366">
    <td>Name</td>
    <td><font color="#FFFFFF">Address</font></td>
    <td><font color="#FFFFFF">Telephone Number</font></td>
  </tr>
  <!-- TemplateBeginEditable name="LocationList" -->
  <tr>
    <td>Enter name</td>
    <td>Enter Address</td>
    <td>Enter Telephone</td>
  </tr>
  <!-- TemplateEndEditable -->
</table>

注意

请务必小心，在“代码”视图中编辑模板代码时不要更改 Dreamweaver 所依赖的任何与模板相关的注释标记。

相关主题

  • 在“设计”视图中查看模板
  • 在“设计”视图中查看基于模板的文档
  • 在“代码”视图中查看基于模板的文档


在“设计”视图中查看基于模板的文档

在基于模板的文档中，可编辑区域出现在“文档”窗口的“设计”视图中，并且周围环绕着预设高亮颜色的矩形边框。每个区域的左上角都出现一个小的选项卡，其中显示了相应区域的名称。

注意

有关设置标记色彩首选参数的信息，请参见设置模板区域的高亮显示首选参数。

除可编辑区域的边框之外，整个页面都是由不同颜色的边框环绕的，右上角的选项卡给出该文档所基于的模板的名称。这个高亮显示的矩形用于提醒您：该文档是基于模板的，并且您不能更改可编辑区域之外的任何内容。

相关主题

  • 在“设计”视图中查看模板
  • 在“代码”视图中查看模板
  • 在“代码”视图中查看基于模板的文档


在“代码”视图中查看基于模板的文档

在“代码”视图中，派生自模板的文档的可编辑区域用与不可编辑区域中的代码不同的颜色显示。可以只更改可编辑区域中的代码或可编辑参数；Dreamweaver 禁止您在锁定区域中键入内容。

可编辑内容在 HTML 中用以下 Dreamweaver 注释标记：

<!-- InstanceBeginEditable> 和 <!--InstanceEndEditable -->

这些注释之间的任何内容都可以在基于模板的文档中编辑。可编辑区域的 HTML 源代码可能类似于下列形式：

<body bgcolor="#FFFFFF" leftmargin="0">
<table width="75%"  border="1"  cellspacing="0" cellpadding="0">
  <tr bgcolor="#333366">
    <td>Name</td>
    <td><font color="#FFFFFF">Address</font></td>
    <td><font color="#FFFFFF">Telephone Number</font></td>
  </tr>
  <!-- InstanceBeginEditable name="LocationList" -->
  <tr>
    <td>Enter name</td>
    <td>Enter Address</td>
    <td>Enter Telephone</td>
  </tr>
  <!-- InstanceEndEditable -->
</table>
</body>

不可编辑文本的默认颜色是灰色；您可以在“首选参数”对话框中为可编辑区域和不可编辑区域选择不同的颜色。有关更多信息，请参见为模板自定义代码颜色首选参数。

相关主题

  • 在“设计”视图中查看模板
  • 在“代码”视图中查看模板
  • 在“设计”视图中查看基于模板的文档


模板标签语法

本节介绍一般语法规则并列出 Dreamweaver 用于指定模板和基于模板的文档中区域的 HTML 注释标签。当您插入模板对象时，Dreamweaver 会自动在代码中插入模板标签。

注意

Dreamweaver 使用 HTML 注释标签定义模板区域，所以基于模板的文档依然是有效的 HTML 文件。

本节包含以下主题：

  • 一般语法规则
  • 模板标签
  • 实例标签


一般语法规则

下面是一般语法规则：

  • 无论哪里出现空格，都可以用任何数量的空白（空格、制表符和换行符）代替。除了在注释开头和结尾，空白都是强制性的。
  • 可以以任何顺序给出属性。例如，在 TemplateParam 中，可以在名称之前指定类型。
  • 注释和属性名称是区分大小写的。
  • 所有属性必须用引号引起来。可以使用单引号或双引号。

有关检查语法的信息，请参见检查模板语法。

相关主题

  • 模板标签
  • 实例标签


模板标签

Dreamweaver 使用以下模板标签：

<!-- TemplateBeginEditable name="..." -->
<!-- TemplateEndEditable -->

<!-- TemplateParam name="..." type="..." value="..." -->

<!-- TemplateBeginRepeat name="..." -->
<!-- TemplateEndRepeat -->

<!-- TemplateBeginIf cond="..." -->
<!-- TemplateEndIf -->

<!-- TemplateBeginPassthroughIf cond="..." -->
<!-- TemplateEndPassthroughIf -->

<!-- TemplateBeginMultipleIf -->
<!-- TemplateEndMultipleIf -->

<!-- TemplateBeginPassthroughMultipleIf -->
<!-- TemplateEndPassthroughMultipleIf -->

<!-- TemplateBeginIfClause cond="..." -->
<!-- TemplateEndIfClause -->

<!-- TemplateBeginPassthroughIfClause cond="..." -->
<!-- TemplateEndPassthroughIfClause -->

<!-- TemplateExpr expr="..." --> (equivalent to @@...@@)

<!-- TemplatePassthroughExpr expr="..." -->

<!-- TemplateInfo codeOutsideHTMLIsLocked="..." -->

相关主题

  • 一般语法规则
  • 实例标签


实例标签

Dreamweaver 使用以下实例标签：

<!-- InstanceBegin template="..." codeOutsideHTMLIsLocked="..." -->
<!-- InstanceEnd -->
<!-- InstanceBeginEditable name="..." -->
<!-- InstanceEndEditable -->
<!-- InstanceParam name="..." type="..." value="..." passthrough="..." -->
<!-- InstanceBeginRepeat name="..." -->
<!-- InstanceEndRepeat -->
<!-- InstanceBeginRepeatEntry -->
<!-- InstanceEndRepeatEntry -->

相关主题

  • 一般语法规则
  • 模板标签


模板中的链接

若要在模板文件中创建链接，可以使用“属性”检查器中的文件夹图标或“指向文件”图标；不要键入要链接到的文件的名称。如果键入名称，链接可能不能工作。本节解释 Dreamweaver 如何处理模板中的链接。

当从现有页面创建模板文件并将该页另存为模板时，Dreamweaver 将更新链接，使其与以前指向相同的文件。因为模板保存在 Templates 文件夹中，当将页面另存为模板时，文档相对链接的路径将更改。在 Dreamweaver 中，当基于该模板创建新文档并保存新文档时，所有文档相对链接将被更新以继续指向正确的文件。

但是，当向模板文件中添加新的文档相对链接时，如果在“属性”检查器的链接文本框中键入路径，很容易输入错误的路径名。正确的路径是从 Templates 文件夹到链接文档的路径，而不是从基于模板的文档的文件夹到链接文档的路径。

有关使用“指向文件”图标进行链接的信息，请参见链接文件和文档。

注意

有些情况下（如模板中的事件处理程序中的文件路径），不能使用文件夹图标或“指向文件”图标；在这些情况下，必须输入正确的路径名。


嵌套模板

嵌套模板是指其设计和可编辑区域都基于另一个模板的模板。若要创建嵌套模板，必须首先保存原始模板或基本模板，然后基于该模板创建新文档，最后将该文档另存为模板。在新模板中，可以在原来在基本模板中定义为可编辑的区域中进一步定义可编辑区域。

嵌套模板对于控制共享许多设计元素的站点页面中的内容很有用，但在各页之间有些差异。例如，基本模板中可能包含更宽广的设计区域，并且可以由站点的许多内容提供者使用，而嵌套模板可能进一步定义站点内特定部分页面中的可编辑区域。

基本模板中的可编辑区域被传递到嵌套模板，并在根据嵌套模板创建的页面中保持可编辑，除非在这些区域中插入了新的模板区域。

对基本模板所做的更改在基于基本模板的模板中自动更新，并在所有基于主模板和嵌套模板的文档中自动更新。

在下面的示例中，模板包含三个可编辑区域，名称分别为 Body、Nav Bar 和 Footer：

为了创建嵌套模板，我们已经基于该模板创建了一个新文档，然后将该文档保存为模板并命名为 TrioNested。在嵌套模板中，在名为 Body 的可编辑区域中，添加了两个具有内容的可编辑区域。

当您在传递到嵌套模板的可编辑区域内添加新的可编辑区域时，该可编辑区域的高亮颜色变为橙色。您在可编辑区域中添加的内容，如 editableColumn 中的图形，在基于该嵌套模板的文档中不再是可编辑的。蓝色的高亮显示可编辑区域（无论是添加到嵌套模板的还是从基本模板传递的）在基于该嵌套模板的文档中仍然是可编辑的。您没有在其中插入可编辑区域的模板区域作为可编辑区域传递到基于模板的文档。

相关主题

  • 创建嵌套模板


模板以及基于模板的文档中的服务器脚本

一些服务器脚本被插入到文档的起始或结尾处（在 <html> 标签之前或 </html> 标签之后）。此类脚本要求在模板和基于模板的文档中特殊处理。正常情况下，如果对模板中 <html> 标签之前或 </html> 标签之后的脚本代码进行更改，这些更改将不会复制到基于该模板的文档中。如果模板主体内部的其他服务器脚本依赖于没有副本的脚本，则这将导致服务器错误。因此，如果您更改模板中 <html> 标签之前或 </html> 标签之后的脚本，Dreamweaver 将发出警告。

若要避免此问题，可以在模板的 head 部分插入下列代码：

<!-- TemplateInfo codeOutsideHTMLIsLocked="true" -->

如果模板中包含此代码，则对 <html> 标签之前或 </html> 标签之后的脚本所作的更改将被复制到基于该模板的文档中。但是，您将无法编辑基于该模板的文档中的那些脚本。因而，可以选择能够在模板中或在基于该模板的文档中编辑这些脚本，但不能同时选择两者。


模板参数

模板参数指示控制基于模板的文档中的内容的值。可以使用模板参数来定义可选区域、可编辑标签属性或设置想要传递到附着文档的值。需要为每个参数选择名称、数据类型和默认值。每个参数都必须有一个唯一的名称且区分大小写。

模板参数作为实例参数传递到文档中。大多数情况下，模板用户可以编辑参数的默认值，以便自定义出现在基于模板的文档中的内容。在其他情况下，模板创作者可以根据模板表达式的值来确定出现在文档中的内容（请参见模板表达式）。

相关主题

  • 使用可选区域
  • 定义可编辑标签属性


模板表达式

模板表达式是用于计算或估算值的语句。

可以使用表达式存储值并在文档中显示它。例如，表达式可能像一个参数的值一样简单，如 @@(Param)@@，也可能复杂到需要计算用于替换表格行背景颜色的值，如
@@((_index & 1) ? red :blue)@@。

您还可以为假设和多重假设条件定义表达式（有关示例，请参见模板代码中的多重假设条件）。当表达式被用在条件语句中时，Dreamweaver 将把它计算为 true 或 false。如果条件为真，则将在基于模板的文档中显示可选区域；如果条件为假，则不显示。

插入可选区域时，可以在“代码”视图或“可选区域”对话框中定义表达式。有关编写模板表达式的更多信息，请参见模板表达式语言。

在“代码”视图中，定义模板表达式的方法有两种：使用 <!-- TemplateExpr expr=“your expresson”--> 注释或 @@(your expression)@@。在模板代码中插入表达式时，“设计”视图中将出现表达式标记。应用模板时，Dreamweaver 计算表达式并在基于模板的文档中显示其值。

本节包含以下主题：

  • 模板表达式语言
  • 模板代码中的多重假设条件


模板表达式语言

模板表达式语言是 JavaScript 的一个小子集，并使用 JavaScript 语法和优先级规则。可以使用 JavaScript 运算符来编写这样的表达式：

@@(firstName+lastName)@@

支持下列功能和运算符：

  • 数字文本、字符串文本（仅限于双引号语法）和布尔值文本（true 或 false）
  • 变量引用（请参见本节后面的定义变量列表）
  • 域引用（“点”运算符）
  • 一元运算符：+、-、~、!
  • 二元运算符：+、-、*、/、%、&、|、^、&&、||、<、<=、>、>=、==、!=、<<、>>
  • 条件运算符：?:
  • 括号：()

使用下列数据类型：布尔型、IEEE 64 位浮点型、字符串和对象。Dreamweaver 模板不支持使用 JavaScript“空”类型或“未定义”类型。而且不允许将标量类型隐式转换为对象；因此，表达式 "abc".length 将引起错误，而不是得出值 3。

唯一可用的对象是由表达式对象模型定义的对象。定义了下列变量：

_document

包含文档级模板数据，模板中每个参数都有一个字段。

_repeat

仅为出现在重复区域内的表达式定义。提供关于区域的内置信息：

_index 当前项的数字索引（从 0 开始）

_numRows 该重复区域内的总项数

_isFirst 如果当前项是其重复区域内的第一项，则为真

_isLast 如果当前项是其重复区域内的最后一项，则为真

_prevRecord 前一项的 _repeat 对象。访问该区域内第一项的此属性是一个错误。

_nextRecord 下一项的 _repeat 对象。访问该区域内最后一项的此属性是一个错误。

_parent 在嵌套的重复区域内，该项给出封闭（外层）重复区域的 _repeat 对象。在嵌套的重复区域外部访问此属性是一个错误。

在表达式计算过程中，_document 对象和 _repeat 对象的所有域都默认为可用。例如，为访问文档的标题参数，可以输入 title 而不是 _document.title。

在出现域冲突的情况下，_repeat 对象的域优先于 _document 对象的域。因此，不需要明确引用 _document 或 _repeat，除非可能需要在重复区域内使用 _document 引用被重复区域参数隐藏了的文档参数。

使用嵌套的重复区域时，只有最内层重复区域的域为默认为可用。外层区域必须使用 _parent 明确引用。


模板代码中的多重假设条件

您可以为假设和多重假设条件定义模板表达式（请参见模板表达式）。下面的示例讲述了如何定义名为“Dept”的参数、如何设置初始值以及如何定义用来确定显示哪个徽标的多重假设条件。

以下是在模板的 head 部分输入的代码示例：

<!-- TemplateParam name="Dept" type="number" value="1" -->

下面的条件语句检查指定给 Dept 参数的值。如果条件为真或匹配，则显示适当的图像。

<!-- TemplateBeginMultipleIf -->
<!-- checks value of Dept and shows appropriate image-->

<!-- TemplateBeginClause cond="Dept == 1" --> <img src=".../sales.gif"> <!-- TemplateEndIfClause -->
<!-- TemplateBeginIfClause cond="Dept == 2" --> <img src=".../support.gif"> <!-- TemplateEndIfClause-->
<!-- TemplateBeginIfClause cond="Dept == 3" --> <img src=".../hr.gif"> <!-- TemplateEndIfClause -->
<!-- TemplateBeginIfClause cond="Dept != 3" --> <img src=".../spacer.gif"> <!-- TemplateEndIfClause -->

<!-- TemplateEndMultipleIf -->

创建基于模板的文档后，模板参数将自动传递到该文档。模板用户决定显示哪个图像（请参见修改模板属性）。


创建 Dreamweaver 模板

可以从现有文档（如 HTML、Macromedia ColdFusion 或 Microsoft Active Server Pages 文档）中创建模板，或者从新建的空白文档中创建模板。

创建模板后，可以插入模板区域（请参见模板区域的类型）。您也可以为代码颜色和模板区域高亮颜色设置模板首选参数（请参见为模板自定义代码颜色首选参数和设置模板区域的高亮显示首选参数）。

提示

您可以在模板的“设计备注”文件中存储关于模板的附加信息（如创作者、最后一次更改的时间或作出某些布局决定的原因）（请参见建立设计备注与文件的关联）。基于模板的文档不继承模板的设计备注。

若要创建模板，请执行以下操作：

  1. 打开要另存为模板的文档：
    • 若要打开一个现有文档，请选择“文件”>“打开”，然后选择该文档。
    • 若要打开一个新的空文档，请选择“文件”>“新建”。在出现的对话框中，选择“基本页”或“动态页”，选择要使用的页面类型，然后单击“创建”。

      注意

      有关创建新文档的更多信息，请参见创建新的空白文档。
  2. 文档打开时，执行下列操作之一：
    • 选择“文件”>“另存为模板”。
    • 在“插入”栏的“常用”类别中，单击“模板”按钮上的箭头，然后选择“创建模板”。

      注意

      除非您以前选择了“不再显示此对话框”，否则您将收到一个警告，表示您正在保存的文档中没有可编辑区域。单击“确定”将文档另存为模板，或单击“取消”退出此对话框而不创建模板。

    出现“另存为模板”对话框。

  3. 从“站点”弹出菜单中选择一个用来保存模板的站点，并在“另存为”文本框中为模板输入一个唯一的名称。
  4. 单击“保存”。

    Dreamweaver 将模板文件保存在站点的本地根文件夹中的 Templates 文件夹中，使用文件扩展名 .dwt。如果该 Templates 文件夹在站点中尚不存在，Dreamweaver 将在您保存新建模板时自动创建该文件夹。

    注意

    不要将模板移动到 Templates 文件夹之外或者将任何非模板文件放在 Templates 文件夹中。此外，不要将 Templates 文件夹移动到本地根文件夹之外。这样做将在模板中的路径中引起错误。

使用“资源”面板创建新模板

  1. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“模板”类别。 这是所描述的功能的图片。

    即会显示“资源”面板的“模板”类别。

  2. 单击“资源”面板底部的“新建模板”按钮。 这是所描述的功能的图片。

    一个新的、无标题模板将被添加到“资源”面板的模板列表中。

  3. 在模板仍处于选定状态时，输入模板的名称，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    Dreamweaver 在“资源”面板和 Templates 文件夹中创建一个新的空模板。

相关主题

  • 为模板自定义代码颜色首选参数
  • 设置模板区域的高亮显示首选参数
  • 为 Contribute 站点创建模板
  • 插入可编辑区域


为模板自定义代码颜色首选参数

代码颜色首选参数控制在“代码”视图中显示的文本的文本颜色、背景颜色和样式属性。您可以设置自己的配色方案，以便在“代码”视图中查看文档时可以轻松地区分模板区域。

若要为模板设置“代码”视图配色方案，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或Dreamweaver>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从左侧的“类别”列表中选择“代码颜色”。
  3. 从“文档类型”列表中选择“HTML”，然后单击“编辑颜色方案”按钮。

    即会出现“编辑代码颜色方案”对话框。

  4. 在“样式”列表中选择“模板标记”。
  5. 为“代码”视图文本设置颜色、背景颜色和样式属性，方法是执行下列操作之一：
    • 如果想要更改文本颜色，请在“文本颜色”文本框中键入想要应用于所选文本的颜色的十六进制值，或者使用颜色选择器来选择一种应用于文本的颜色。在“背景颜色”域进行相同操作，添加或更改所选文本的现有背景颜色。
    • 如果想要向所选代码添加样式属性，请单击“B”（粗体）、“I”（斜体）或“U”（下划线）按钮来设置所需样式。
  6. 单击“确定”。

相关主题

  • 设置模板区域的高亮显示首选参数


设置模板区域的高亮显示首选参数

在“设计”视图中，可以使用 Dreamweaver 高亮显示首选参数来自定义模板的可编辑区域和锁定区域周围边框的高亮颜色。可编辑区域的颜色出现在模板和基于该模板的文档中。

有关在“设计”视图中查看模板和基于模板的文档的更多信息，请参见在“设计”视图中查看模板和在“设计”视图中查看基于模板的文档。

若要更改模板高亮颜色，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或Dreamweaver>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从左侧的类别列表中选择“标记色彩”。
  3. 单击“可编辑区域”、“嵌套区域”或“锁定区域”颜色框，然后使用颜色选择器来选择一种高亮颜色（或在文本框中输入高亮颜色的十六进制值）。

    有关使用颜色选择器的信息，请参见使用颜色。

  4. （可选）根据需要，对其他模板区域类型重复执行上述过程。
  5. 单击“显示”选项在“文档”窗口中启用或禁用颜色显示。

    注意

    “嵌套区域”没有“显示”选项；它的显示由“可编辑区域”选项控制。
  6. 单击“确定”。

若要在“文档”窗口中查看高亮颜色，请执行以下操作：

  • 选择“查看”>“可视化助理”>“不可见元素”。

    只有在启用了“查看”>“可视化助理”>“不可见元素”并且在“标记色彩”首选参数中启用了适当的选项时，高亮颜色才会出现在文档窗口中。

    注意

    如果显示了不可见元素，但是未显示高亮颜色，请选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)，然后选择“高亮”类别。确保选中了相应的高亮颜色旁边的“显示”选项。还要确保所需的颜色在页面背景颜色上可见。

相关主题

  • 为模板自定义代码颜色首选参数


为 Contribute 站点创建模板

您可以使用 Dreamweaver 来创建模板，以帮助 Macromedia Contribute 用户创建新页面，为您的站点提供一致的外观和使用体验，并使您可以同时更新多个页面的布局。

在您创建模板并将其上传到服务器之后，连接到您的站点的所有 Contribute 用户都将可以使用该模板，除非您已为某些 Contribute 角色设置了模板使用限制。如果您已设置了模板使用限制，您可能需要将每一个新模板添加到 Contribute 用户可使用的模板的列表中。（请参见管理 Contribute）。

注意

请确保每个 Contribute 用户的站点定义中定义的站点根文件夹与在 Dreamweaver 站点定义中定义的站点根文件夹相同。如果用户的站点根文件夹与您的根文件夹不匹配，则该用户将无法使用模板。

除了 Dreamweaver 模板之外，您还可使用 Contribute 管理工具创建非 Dreamweaver 模板。非 Dreamweaver 模板是 Contribute 用户可用来创建新页面的现有页面；它类似于 Dreamweaver 模板，只不过基于它的页面在您更改该模板时不会更新。另外，非 Dreamweaver 模板不能包含 Dreamweaver 模板元素，例如可编辑的、锁定的、重复的和可选的区域。

当 Contribute 用户在包含 Dreamweaver 模板的站点内创建新文档时，Contribute 会在“新建页面”对话框中列出可用的模板（包括 Dreamweaver 和非 Dreamweaver 模板）。

若要在站点中包含使用非 Latin-1 编码的页面，您可能需要创建模板（Dreamweaver 模板或非 Dreamweaver 模板）。Contribute 可编辑使用任何编码的页面，但当 Contribute 用户创建新的空白页面时，它将使用 Latin-1 编码。若要创建使用其它编码的页面，Contribute 用户可创建一个使用其它编码的现有页面的副本，或可利用使用其它编码的模板。但是，如果站点中没有使用其它编码的页面和模板，则必须先在 Dreamweaver 中创建使用其它编码的页面或模板。

有关创建、编辑和更新 Dreamweaver 模板的信息，请参见关于 Dreamweaver 模板。

若要创建非 Dreamweaver 模板，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 选择一个站点，然后单击“编辑”。

    出现“站点定义”对话框。

  3. 单击“高级”选项卡。
  4. 从左侧的“类别”列表中选择“Contribute”类别。
  5. 如果尚未这样做，则需要启用 Contribute 兼容性。

    选择“启用 Contribute 兼容性”选项，然后输入站点根 URL。

    有关更多信息，请参见准备站点以用于 Contribute。

  6. 单击“在 Contribute 中管理站点”按钮。
  7. 如果出现提示，请输入管理员密码，然后单击“确定”。

    随即出现“管理网站”对话框。

  8. 在“用户和角色”类别中，选择角色，然后单击“编辑角色设置”按钮。
  9. 选择“新建页面”类别，然后将现有页面添加到“通过从此列表中复制页面来创建新页面”选项下的列表中。

    有关更多信息，请参见“管理 Contribute”。

  10. 单击“确定”关闭“编辑设置”对话框。
  11. 单击“关闭”关闭“管理网站”对话框。

相关主题

  • 创建 Dreamweaver 模板


创建可编辑区域

可编辑模板区域控制在基于模板的页面中用户可以编辑哪些区域。

本节包含以下主题：

  • 插入可编辑区域
  • 选择可编辑区域
  • 删除可编辑区域
  • 更改可编辑区域的名称

相关主题

  • 模板区域的类型


插入可编辑区域

在插入可编辑区域之前，应该将您正在其中工作的文档另存为模板（请参见创建 Dreamweaver 模板）。

注意

如果您在文档（而不是模板文件）中插入一个可编辑区域，Dreamweaver 会警告您该文档将自动另存为模板。

您可以将可编辑区域放在页面中的任何位置，但如果要使表格或层可编辑，则需考虑以下情况：

  • 可以将整个表格或单独的表格单元格标记为可编辑的，但不能将多个表格单元格标记为单个可编辑区域。如果选定 <td> 标签，则可编辑区域中包括单元格周围的区域；如果未选定，则可编辑区域将只影响单元格中的内容。
  • 层和层内容是单独的元素；使层可编辑时可以更改层的位置及其内容，而使层的内容可编辑时只能更改层的内容而不能更改其位置。

若要插入可编辑模板区域，请执行以下操作：

  1. 在“文档”窗口中，执行下列操作之一选择区域：
    • 选择想要设置为可编辑区域的文本或内容。
    • 将插入点放在想要插入可编辑区域的地方。
  2. 执行下列操作之一插入可编辑区域：
    • 选择“插入”>“模板对象”>“可编辑区域”。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“模板”>“新建可编辑区域”。
    • 在“插入”栏的“常用”类别中，单击“模板”按钮上的箭头，然后选择“可编辑区域”。

    出现“新建可编辑区域”对话框。

  3. 在“名称”文本框中为该区域输入唯一的名称。（不能对特定模板中的多个可编辑区域使用相同的名称。

    注意

    不要在“名称”文本框中使用特殊字符。
  4. 单击“确定”。

    可编辑区域在模板中由高亮显示的矩形边框围绕，该边框使用在首选参数中设置的高亮颜色。该区域左上角的选项卡显示该区域的名称。如果在文档中插入空白的可编辑区域，则该区域的名称会出现在该区域内部。

    注意

    有关设置模板高亮显示选项的信息，请参见设置模板区域的高亮显示首选参数。

相关主题

  • 选择可编辑区域
  • 删除可编辑区域
  • 更改可编辑区域的名称


选择可编辑区域

在模板文档和基于模板的文档中，都可以容易地标识和选择模板区域。

要在“文档”窗口中选择一个可编辑区域，请执行以下操作：

  • 单击可编辑区域左上角的选项卡。

若要在文档中查找可编辑区域并选择它，请执行以下操作：

  • 选择“修改”>“模板”，然后从该子菜单底部的列表中选择区域的名称。

    注意

    重复区域内的可编辑区域不会出现在该菜单中。必须通过在“文档”窗口中查找选项卡式的边框来定位这些区域。

可编辑区域在文档中被选定。

相关主题

  • 设置模板区域的高亮显示首选参数
  • 插入可编辑区域
  • 删除可编辑区域
  • 更改可编辑区域的名称


删除可编辑区域

如果已经将模板文件的一个区域标记为可编辑，而现在想要再次锁定它（使其在基于模板的文档中不可编辑），请使用“删除模板标记”命令。

若要删除可编辑区域，请执行以下操作：

  1. 单击可编辑区域左上角的选项卡以选中它。
  2. 执行下列操作之一：
    • 选择“修改”>“模板”>“删除模板标记”。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“模板”>“删除模板标记”。

    现在，该区域不再是可编辑区域。

相关主题

  • 插入可编辑区域


更改可编辑区域的名称

插入可编辑区域后，可以在以后更改它的名称。

若要更改可编辑区域的名称，请执行以下操作：

  1. 单击可编辑区域左上角的选项卡以选中它。
  2. 在属性检查器（“窗口”>“属性”）中，输入一个新名称。
  3. 按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

Dreamweaver 将新名称应用于可编辑区域。

相关主题

  • 插入可编辑区域


创建重复区域

重复区域是可以根据需要在基于模板的页面中复制任意次数的模板部分。重复区域通常用于表格；但是，也可以为其他页面元素定义重复区域。

使用重复区域，您可以通过重复特定项目来控制页面布局，例如目录项、说明布局或者重复数据行（如项目列表）。

重复区域可以使用两种重复区域模板对象：重复区域和重复表格。

本节包含以下主题：

  • 在模板中创建重复区域
  • 插入重复表格
  • 在重复表格中设置替换的背景颜色

相关主题

  • 模板区域的类型


在模板中创建重复区域

模板用户可以使用重复区域在模板中复制任意次数的指定区域。重复区域不是可编辑区域。

若要使重复区域中的内容可编辑（例如，让用户可以在基于模板的文档的表格单元格中输入文本），必须在重复区域内插入可编辑区域（请参见插入可编辑区域）。

有关创建可编辑重复表格的信息，请参见插入重复表格。

若要在模板中插入重复区域，请执行以下操作：

  1. 在“文档”窗口中执行下列操作之一：
    • 选择想要设置为重复区域的文本或内容。
    • 将插入点放入文档中想要插入重复区域的地方。
  2. 执行下列操作之一创建重复区域：
    • 选择“插入”>“模板对象”>“重复区域”。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“模板”>“新建重复区域”。
    • 在“插入”栏的“常用”类别中，单击“模板”按钮上的箭头，然后选择“重复区域”。

    出现“新建重复区域”对话框。

  3. 在“名称”文本框中为模板区域输入唯一的名称。（不能对一个模板中的多个重复区域使用相同的名称。）

    注意

    命名区域时，不要使用特殊字符。
  4. 单击“确定”。

    重复区域被插入到模板中。

    注意

    重复区域在基于模板的文档中是不可编辑的，除非其中包含可编辑区域。有关插入可编辑区域的信息，请参见插入可编辑区域。


插入重复表格

可以使用重复表格创建包含重复行的表格格式的可编辑区域。可以定义表格属性并设置哪些表格单元格可编辑。

若要插入重复表格，请执行以下操作：

  1. 在“文档”窗口中，将插入点放在文档中想要插入重复表格的位置。
  2. 执行下列操作之一：
    • 选择“插入”>“模板对象”>“重复表格”。
    • 在“插入”栏的“常用”类别中，单击“模板”按钮上的箭头，然后选择“重复表格”。

    即会出现“插入重复表格”对话框。

  3. 按需要输入新值。

    有关更多信息，请参见设置“插入重复表格”对话框选项。

  4. 单击“确定”。

    重复表格即出现在模板中。

相关主题

  • 在重复表格中设置替换的背景颜色


在重复表格中设置替换的背景颜色

在模板中插入重复表格后（请参见插入重复表格），可以通过替换表格行的背景颜色来自定义重复表格。

若要重复区域（模板）替换颜色，请执行以下操作：

  1. 在“文档”窗口中，选择重复表格中的一行。
  2. 在“文档”窗口中选择重复区域表格行。单击“文档”工具栏中的“显示代码视图”或“显示代码视图和设计视图”按钮，以便可以访问所选表格行的代码。
  3. 在“代码”视图中编辑 <tr> 标签，使其包括下列代码：
    <tr bgcolor="@@( _index & 1 ? '#FFFFFF' : '#CCCCCC' )@@">

    可以用其它颜色值替换 #FFFFFF 和 #CCCCCC 十六进制值。

  4. 保存该模板。

以下是一个包含替换背景表格行颜色的表格的代码范例：

<table width="75%"  border="1"  cellspacing="0" cellpadding="0">
<tr><th>Name</th><th>Phone Number</th><th>Email Address</th></tr>

<!-- TemplateBeginRepeat name="contacts" -->
<tr bgcolor="@@(_index & 1 ? '#FFFFFF' : '#CCCCCC')@@">
<td> <!-- TemplateBeginEditable name="name" --> name <!-- TemplateEndEditable -->
</td>
<td> <!-- TemplateBeginEditable name="phone" --> phone <!-- TemplateEndEditable -->
</td>
<td> <!-- TemplateBeginEditable name="email" --> email <!-- TemplateEndEditable -->
</td>
</tr>
  <!-- TemplateEndRepeat -->

</table>


使用可选区域

可选区域是模板中的区域，用户可将其设置为在基于模板的文档中显示或隐藏。当想要为在文档中显示内容设置条件时，请使用可选区域。

插入可选区域时，可以为模板参数设置特定值或在模板中定义条件语句；可以根据需要在以后修改可选区域。根据您定义的条件，模板用户可以在他们创建的基于模板的文档中编辑参数并控制是否显示可选区域（请参见修改模板属性）。

本节包含以下主题：

  • 插入可选区域
  • 修改可选区域

相关主题

  • 模板区域的类型


插入可选区域

使用可选区域可以控制不一定在基于模板的文档中显示的内容。有两种可选区域对象：

  • 使用可选区域，模板用户可以显示和隐藏特别标记的区域，在这些区域中用户无法编辑内容。

    可选区域的模板选项卡在单词 if 之后。根据模板中设置的条件，模板用户可以定义该区域在他们所创建的页面中是否可见。

  • 使用可编辑可选区域，模板用户可以设置是否显示或隐藏该区域，并使用户可以编辑该区域中的内容。

    例如，如果可选区域中包括图像或文本，模板用户即可设置该内容是否显示，并根据需要对该内容进行编辑。可编辑区域是由条件语句控制的。

    注意

    要将可选区域设置为在基于模板的文档中显示或隐藏，请参见修改模板属性。

若要插入可选区域，请执行以下操作：

  1. 在“文档”窗口中，选择想要设置为可选区域的元素。
  2. 执行下列操作之一：
    • 选择“插入”>“模板对象”>“可选区域”。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 所选内容，然后选择“模板”>“新建可选区域”。
    • 在“插入”栏的“常用”类别中，单击“模板”按钮上的箭头，然后选择“可选区域”。

    出现“新建可选区域”对话框。

  3. 为可选区域指定选项。

    有关定义可选区域的信息，请参见设置“可选区域”对话框选项。

  4. 单击“确定”。

若要插入可编辑的可选区域，请执行以下操作：

  1. 在“文档”窗口中，将插入点放置在您要插入可选区域的地方。

    提示

    不能环绕选定内容来创建可编辑的可选区域。应插入区域，然后在该区域内插入内容。
  2. 执行下列操作之一打开“新建可选区域”对话框：
    • 选择“插入”>“模板对象”>“可编辑的可选区域”。
    • 在“插入”栏的“常用”类别中，单击“模板”按钮上的箭头，然后选择“可编辑可选区域”。

    出现“新建可选区域”对话框。

  3. 为可选区域输入名称，如果要设置其他选项请单击“高级”选项卡。

    有关定义可选区域的信息，请参见设置“可选区域”对话框选项。

  4. 单击“确定”。

相关主题

  • 修改可选区域


修改可选区域

在模板中插入可选区域之后，可以编辑该区域的设置。例如，可以对是否显示内容默认值的设置进行更改，将参数链接到现有可选区域，或者修改模板表达式。

注意

要将可选区域设置为在基于模板的文档中显示或隐藏，请参见修改模板属性。

若要重新打开“新建可选区域”对话框，请执行以下操作：

  1. 在“文档”窗口中执行下列操作之一：
    • 在“设计”视图中，单击要修改的可选区域的模板选项卡。
    • 在“设计”视图中，将插入点放置在模板区域中；然后在“文档”窗口底部的标签选择器中选择模板标签 <mmtemplate:if>。
    • 在“代码”视图中，单击想要修改的模板区域的注释标记。
  2. 在属性检查器（“窗口”>“属性”）中单击“编辑”。

    出现“新建可选区域”对话框。

  3. 按需要进行更改。

    有关该对话框中的选项的信息，请参见设置“可选区域”对话框选项。

  4. 单击“确定”。


定义可编辑标签属性

您可以允许模板用户在从模板创建的文档中修改指定标签属性。

例如，您可以在模板文档中设置背景颜色，但仍允许模板用户为他们创建的页面设置不同的背景颜色。用户只能更新您指定为可编辑的属性。

注意

若要修改基于模板的文档中的可编辑标签属性，请参见修改模板属性。

本节包含以下主题：

  • 在模板中指定可编辑标签属性
  • 使可编辑标签属性不可编辑

相关主题

  • 模板区域的类型


在模板中指定可编辑标签属性

您可以在页面中设置多个可编辑属性，这样模板用户就可以在基于模板的文档中修改这些属性。支持下列数据类型：文本、布尔值 (true/false)、颜色和 URL。

若要定义可编辑标签属性，请执行以下操作：

  1. 在“文档”窗口中，选择想要为其设置可编辑标签属性的项目。
  2. 选择“修改”>“模板”>“使属性可编辑”。

    出现“可编辑标签属性”对话框。

  3. 对于要使其可编辑的每个属性，完成该对话框。

    有关完成该对话框的信息，请参见设置“可编辑标签属性”对话框选项。

  4. 单击“确定”。

    创建可编辑标签属性时将在代码中插入一个模板参数。该属性的初始值在模板文档中设置；当创建基于模板的文档时，它将继承该参数。模板用户即可在基于模板的文档中编辑该参数（请参见修改模板属性）。

相关主题

  • 使可编辑标签属性不可编辑


使可编辑标签属性不可编辑

可以将先前标为可编辑的标记标为不可编辑。

若要重置可编辑标签属性，请执行以下操作：

  1. 在模板文档中，单击与可编辑属性相关联的元素，或使用标签选择器来选择标记。
  2. 选择“修改”>“模板”>“使属性可编辑”。

    出现“可编辑标签属性”对话框。

  3. 在“属性”弹出式菜单中，选择您要影响的属性。
  4. 取消选择“使属性可编辑”复选框。
  5. 单击“确定”。
  6. 更新基于该模板的文档。

相关主题

  • 在模板中指定可编辑标签属性


创建嵌套模板

嵌套模板使您可以创建基本模板的变体。您可以通过保存一个基于模板的文档，然后将该文档另存为一个新模板来创建嵌套模板。您可以嵌套多个模板来定义更加精确的布局。有关更多信息，请参见嵌套模板。

默认情况下，基本模板中的所有可编辑模板区域都通过嵌套模板传递到基于该嵌套模板的文档。这意味着，如果在基本模板中创建一个可编辑区域，然后再创建一个嵌套模板，只要您没有在嵌套模板的该区域中插入任何新的模板区域，该可编辑区域将会出现在基于嵌套模板的文档中。

在嵌套模板中，传递的可编辑区域具有蓝色边框。在可编辑区域内可以插入模板标记，这样它就不会作为可编辑区域在基于该嵌套模板的文档中传递。这种区域具有橙色的边框，而不是蓝色的边框。

若要创建嵌套模板，请执行以下操作：

  1. 若要从想作为嵌套模板的基础的模板中创建一个文档，请执行以下操作：
    • 在“资源”面板的“模板”类别中，右键单击 (Windows) 或在按住 Control 键单击 (Macintosh) 要作为创建新文档基础的模板，然后从上下文菜单中选择“从模板新建”。
    • 选择“文件”>“新建”。在“新建文档”对话框中，单击“模板”选项卡，然后选择包含要使用的模板的站点；在文档列表中双击该模板以创建新文档。

    新文档出现在“文档”窗口中。

  2. 若要将新文档另存为嵌套模板，请执行下列操作之一：
    • 选择“文件”>“另存为模板”。
    • 在“插入”栏的“常用”类别中，单击“模板”按钮上的箭头，然后选择“创建嵌套模板”。

    出现“另存为模板”对话框。

  3. 在“另存为”文本框中输入名称，然后单击“确定”。

在基于嵌套模板的文档中，可以添加或更改从基本模板传递的可编辑区域（以及在新模板中创建的可编辑区域）中的内容。

若要防止可编辑区域传递到嵌套模板，请执行以下操作：

  1. 在“代码”视图中，找到要阻止传递的可编辑区域。

    可编辑区域由模板注释标签定义。

  2. 使用以下标记环绕可编辑区域（包括注释标签）：
    @@(" ")@@

    有关更多信息，请参阅 Macromedia 网站上的 TechNote 16416，网址为 www.macromedia.com/go/16416。


编辑和更新模板

更改并保存模板时，Dreamweaver 可以自动更新基于该模板的所有文档。如果需要您也可以手动更新基于模板的文档。

注意

若要编辑 Contribute 站点的模板，必须使用 Dreamweaver；无法在 Contribute 中编辑模板。

当保存模板时，Dreamweaver 自动检查模板语法。在编辑模板时您可能也想检查模板语法。

注意

有关编辑基于模板的文档的信息，请参见在基于模板的文档中编辑内容。

本节包含以下主题：

  • 打开要编辑的模板
  • 手动更新基于模板的文档
  • 更新 Contribute 站点中的模板
  • 检查模板语法


打开要编辑的模板

可以直接打开一个模板文件进行编辑，或者可以打开一个基于模板的文档，然后打开附着的模板进行编辑。

当您更改模板时，Dreamweaver 将提示您更新基于该模板的文档。

注意

如果需要，在模板更改后，也可以手动更新基于模板的文档（请参见手动更新基于模板的文档）。

若要打开并编辑模板文件，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“模板”类别。 这是所描述的功能的图片。

    “资源”面板列出站点可用的所有模板并显示选定模板的预览。

  2. 在可用模板列表中，执行下列操作之一：
    • 双击您要编辑的模板名称。
    • 选择要编辑的模板，然后单击“资源”面板底部的“编辑”按钮 这是所描述的功能的图片。 。

    模板在“文档”窗口中打开。

  3. 根据需要修改模板的内容。

    提示

    若要修改模板的页面属性，请选择“修改”>“页面属性”。（基于模板的文档将继承该模板的页面属性。）
  4. 保存该模板。

    Dreamweaver 提示您更新基于该模板的页面。

  5. 单击“更新”更新基于修改后的模板的所有文档；如果不想更新基于修改后的模板的文档，请单击“不更新”。

    Dreamweaver 显示一个记录，指示已经更新的文件。

若要打开并修改附加到当前文档的模板，请执行以下操作：

  1. 在“文档”窗口中打开基于该模板的文档。
  2. 执行下列操作之一：
    • 选择“修改”>“模板”>“打开附加模板”。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“模板”>“打开附加模板”。
  3. 根据需要修改模板的内容。

    提示

    若要修改模板的页面属性，请选择“修改”>“页面属性”。（基于模板的文档将继承该模板的页面属性。）
  4. 保存该模板。

    Dreamweaver 提示您更新基于该模板的页面。

  5. 单击“更新”更新基于修改后的模板的所有文档；如果不想更新基于修改后的模板的文档，请单击“不更新”。

    Dreamweaver 显示一个记录，指示已经更新的文件。

相关主题

  • 手动更新基于模板的文档
  • 更新 Contribute 站点中的模板
  • 检查模板语法


手动更新基于模板的文档

修改模板后，Dreamweaver 会提示您更新基于该模板的文档，但您可以根据需要手动更新当前文档或整个站点。手动更新基于模板的文档与重新应用模板相同。

若要将模板更改应用于当前基于模板的文档，请执行以下操作：

  1. 在“文档”窗口中打开该文档。
  2. 选择“修改”>“模板”>“刷新当前页”。

Dreamweaver 基于所有的模板更改更新该文档。

若要更新整个站点或所有使用指定模板的文档，请执行以下操作：

  1. 选择“修改”>“模板”>“更新页面”。

    即会出现“更新页面”对话框。

  2. 完成此对话框，然后单击“开始”。

    有关更多信息，请参见设置“更新页面”对话框选项。

    Dreamweaver 按照指示更新文件。如果选择了“显示记录”选项，Dreamweaver 将提供关于它试图更新的文件的信息，包括它们是否成功更新的信息。

  3. 单击“关闭”关闭对话框。

相关主题

  • 打开要编辑的模板
  • 更新 Contribute 站点中的模板
  • 检查模板语法


更新 Contribute 站点中的模板

Contribute 用户不能对 Dreamweaver 模板进行更改。但您可以使用 Dreamweaver 更改 Contribute 站点的模板

以下是在更新 Contribute 站点中的模板时需要注意的重要事项：

  • 仅当 Contribute 启动并且 Contribute 用户更改了他们的连接信息时，Contribute 才从站点检索新的和已更改的模板。如果当 Contribute 用户正在编辑基于该模板的文件时您对该模板进行了更改，则用户不会看到对此模板所进行的更改，直到他们重新启动 Contribute 为止。
  • 如果您从模板中删除一个可编辑区域，那么编辑基于该模板的页面的 Contribute 用户可能会不知道应如何处理该可编辑区域中的内容。

若要编辑 Contribute 站点中的模板，请执行以下操作：

  1. 使用 Dreamweaver 编辑该模板。

    有关更多信息，请参见打开要编辑的模板。

  2. 通知所有正在此站点上工作的 Contribute 用户退出 Contribute 并重新启动它。


检查模板语法

当您保存模板时 Dreamweaver 会自动检查模板语法，但您可以在保存模板前手动检查模板语法。例如，如果您在“代码”视图中添加模板参数或表达式，可检查代码是否遵循正确的语法。

若要检查有效模板语法，请执行以下操作：

  1. 在“文档”窗口中打开要检查的文档。
  2. 选择“修改”>“模板”>“检查模板语法”。

如果语法格式错误，则会出现一个错误信息。错误信息将描述错误并指出代码中存在错误的特定行。

相关主题

  • 模板标签语法
  • 模板表达式


管理模板

使用“资源”面板的“模板”类别可以管理现有模板，包括重命名模板文件和删除模板文件。

注意

也可以使用“资源”面板将模板应用于文档（参见编辑和更新模板）或编辑模板（参见打开要编辑的模板）。

若要在“资源”面板中重命名模板，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“模板”类别。 这是所描述的功能的图片。
  2. 崇命名 单击模板的名称以选择该模板。
  3. 再次单击模板的名称以便使文本可选，然后输入一个新名称。

    这种重命名方式与在 Windows 资源管理器 (Windows) 或 Finder (Macintosh) 中对文件进行重命名的方式相同。对于 Windows 资源管理器和 Finder，请确保在前后两次单击之间稍微暂停一下。不要双击该名称，因为这样会打开模板进行编辑。

  4. 在“资源”面板中的另一个区域中单击，或者按 Enter 键 (Windows) 或 Return 键 (Macintosh) 使更改生效。

    Dreamweaver 将询问是否要更新基于此模板的文档。

  5. 若要更新站点中所有基于此模板的文档，请单击“更新”。如果不想更新基于此模板的任何文档，则单击“不更新”。

若要删除模板文件，请执行以下操作：

  1. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“模板”类别。 这是所描述的功能的图片。
  2. 重命名单击模板的名称以选择该模板。
  3. 单击面板底部的“删除”按钮，然后确认要删除该模板。 这是所描述的功能的图片。

    小心

    一旦删除模板文件，则无法对其进行检索。该模板文件将被从站点中删除。

    基于已删除模板的文档不会与此模板分离；它们保留该模板文件在被删除前所具有的结构和可编辑区域。要将文档转换为不带可编辑区域或锁定区域的普通 HTML 文件，请参见从模板分离文档。

相关主题

  • 创建 Dreamweaver 模板
  • 在现有文档中应用或删除模板
  • 编辑和更新模板


导出和导入模板 XML 内容

您可以将基于模板的文档当作包含由名称/值对表示的数据。每一对由可编辑区域的名称及该区域的内容组成。

Dreamweaver 使您可以将名称/值对导出到 XML 文件中，这样您就可以在 Dreamweaver 外部（例如，在 XML 编辑器或文本编辑器中，或者在数据库应用程序中）使用数据了。反之，如果您的 XML 文档经过适当的组织，则可以将该文档中的数据导入到基于 Dreamweaver 模板的文档中。

若要将文档的可编辑区域导出为 XML，请执行以下操作：

  1. 打开基于模板并包含可编辑区域的文档。
  2. 选择“文件”>“导出”>“作为 XML 的数据模板”。

    此时出现“以 XML 形式导出模板数据”对话框。

  3. 选择“符号”选项之一：
    • 如果模板中包含重复区域或模板参数，请选择“使用标准 Dreamweaver XML 标签”。
    • 如果模板中不包含重复区域或模板参数，请选择“使用可编辑区域名称作为 XML 标签”。
  4. 单击“确定”。

    即会出现一个用于保存该 XML 文件的对话框。

  5. 选择文件夹位置，输入 XML 文件的名称，然后单击“保存”。

    Dreamweaver 生成一个 XML 文件，其中包含文档的参数和可编辑区域（包括重复区域或可选区域内的可编辑区域）中的资料。此 XML 文件中包括原始模板的名称以及每个模板区域的名称和内容。

    注意

    不可编辑区域中的内容不会导出到此 XML 文件中。

若要导入 XML 内容，请执行以下操作：

  1. 选择“文件”>“导入”>“XML 到模板”。

    即会出现“导入 XML”对话框。

  2. 选择该 XML 文件，然后单击“打开”。

Dreamweaver 基于 XML 文件中指定的模板创建一个新的文档。它还使用 XML 文件中的数据填充该文档中每个可编辑区域的内容。结果文档出现在新的“文档”窗口中。

提示

如果您的 XML 文件并非完全按照 Dreamweaver 所期望的方式设置，您可能无法导入数据。此问题的一个解决方法是从 Dreamweaver 导出一个空白 XML 文件，这样您将得到一个结构完全正确的 XML 文件。然后从原始 XML 文件向导出的 XML 文件中副本数据。结果生成一个包含适当数据且结构正确的 XML 文件，为导入操作做好准备。

相关主题

  • 导出不具有模板标记的站点


导出不具有模板标记的站点

如果不想在导出到其它站点的基于模板的文档中包含模板标记，请使用“导出不具有模板标记的站点”命令。

若要导出不具有模板标记的站点，请执行以下操作：

  1. 选择“修改”>“模板”>“不带标记导出”。

    即会出现“导出不具有模板标记的站点”对话框。

  2. 选择要将站点导出到的文件夹，然后根据需要选择附加的导出选项。

    注意

    必须选择当前站点以外的文件夹。

    有关更多信息，请参见设置“导出不具有模板标记的站点”对话框选项。

  3. 单击“确定”。


在现有文档中应用或删除模板

将模板应用到现有文档时，Dreamweaver 会将内容与模板中的区域进行匹配或要求您解决不匹配。如果需要更改锁定区域可以随后删除该模板。

本节包含以下主题：

  • 将模板应用到现有文档
  • 从模板分离文档


将模板应用到现有文档

当您将模板应用到包含现有内容的文档时，Dreamweaver 将尝试将现有内容与模板中的区域进行匹配。如果您应用的是现有模板之一的修订版本，则名称可能会匹配。

如果您将模板应用到一个尚未应用模板的文档时，则没有可编辑的区域可以进行比较，且会出现不匹配。Dreamweaver 跟踪这些不匹配的情况，这样您可以选择将当前页的内容移动到哪些区域，或者您可以删除这些不匹配的内容。

利用“资源”面板或通过“文档”窗口您可以将模板应用于现有文档。如果需要，可以撤消模板应用。

若要利用“资源”面板将模板应用于现有文档，可执行以下操作：

  1. 打开要应用模板的文档。
  2. 在“资源”面板（“窗口”>“资源”）中，选择面板左侧的“模板”类别。 这是所描述的功能的图片。
  3. 执行下列操作之一：
    • 将要应用的模板从“资源”面板拖到“文档”窗口。
    • 选择要应用的模板，然后单击“资源”面板底部的“应用”按钮。

    如果文档中存在不能自动指定到模板区域的内容，将出现“不一致的区域名称”对话框。

  4. 如果您有未解决的内容，请为该内容选择一个目标，然后单击“确定”。

    有关将现有内容移动到文档中可编辑区域的信息，请参见解决不一致的区域名称。

若要通过“文档”窗口将模板应用于现有文档，可执行以下操作：

  1. 打开要应用模板的文档。
  2. 选择“修改”>“模板”>“应用模板到页”。

    即会出现“选择模板”对话框。

  3. 从列表中选择一个模板并单击“选择”。

    如果文档中存在不能自动指定到模板区域的内容，将出现“不一致的区域名称”对话框。

  4. 如果您有未解决的内容，请为该内容选择一个目标，然后单击“确定”。

    有关将现有内容移动到文档中可编辑区域的信息，请参见解决不一致的区域名称。

若要撤消模板更改，请执行以下操作：

  • 选择“编辑”>“撤消应用模板”。

该文档回复到应用该模板前的状态。

相关主题

  • 从模板分离文档


从模板分离文档

若要更改基于模板的文档的锁定区域，必须将该文档从模板分离。将文档分离之后，整个文档都将变为可编辑的。

若要从模板分离文档，请执行以下操作：

  1. 打开想要分离的基于模板的文档。
  2. 选择“修改”>“模板”>“从模板中分离”。

    文档被从模板分离，所有模板代码都被删除。

相关主题

  • 将模板应用到现有文档


在基于模板的文档中编辑内容

Dreamweaver 模板为基于该模板的文档指定了锁定区域（不可编辑区域）和其它可编辑区域（请参见关于 Dreamweaver 模板）。

在基于模板的页面中（请参见创建基于现存模板的文档），模板用户只能编辑可编辑区域中的内容。您可以容易地标识和选择可编辑区域来编辑内容（请参见选择可编辑区域）。模板用户不能编辑锁定区域中的内容

注意

当禁用高亮显示时，如果您尝试在基于模板的文档中编辑锁定区域，鼠标指针将更改，指示您不能在锁定区域内单击。 这是所描述的功能的图片。

模板用户也可以在基于模板的文档中修改属性并编辑重复区域的项目。

本节包含以下主题：

  • 修改模板属性
  • 添加、删除重复区域项以及更改其顺序


修改模板属性

在模板创作者在模板中创建参数时（请参见模板参数），基于该模板的文档会自动继承这些参数以及它们的初始值设置。模板用户可以更新可编辑标签属性和其他模板参数（如可选区域设置）。

若要修改可编辑标签属性，请执行以下操作：

  1. 打开基于模板的文档。
  2. 选择“修改”>“模板属性”。

    “模板属性”对话框打开，其中显示了可用属性的列表。该对话框将显示可选区域和可编辑标签属性。

  3. 在“名称”列表中选择该属性。

    对话框的底部区域将更新，以显示所选属性的标签及其指定值。

  4. 在属性标签右侧的域中，编辑该值以修改文档中的属性。

    注意

    域名称和可更新的值在模板中定义。不出现在“名称”列表中的属性在基于模板的文档中不可更新。
  5. 如果想将可编辑属性一直传递到基于嵌套模板的文档，请选中“允许嵌套模板以控制此”复选框。

若要修改可选区域模板参数，请执行以下操作：

  1. 打开基于模板的文档。
  2. 选择“修改”>“模板属性”。

    “模板属性”对话框打开，其中显示了可用属性的列表。该对话框将显示可选区域和可编辑标签属性。

  3. 在“名称”列表中选择一个属性。

    该对话框将更新以显示所选属性的标签及其指定值。

  4. 选择“显示”复选框以显示文档中的可选区域，或取消选择该复选框将其隐藏。

    注意

    域名称和默认设置在模板中定义。
  5. 如果想将可编辑属性一直传递到基于嵌套模板的文档，请选中“允许嵌套模板以控制此”复选框。

相关主题

  • 定义可编辑标签属性
  • 使用可选区域


添加、删除重复区域项以及更改其顺序

使用重复区域控件在基于模板的文档中添加、删除或更改项的顺序。编辑区域 使用重复区域控件可以添加、删除项或更改项的顺序。若要更新重复区域中的内容，原始模板必须在重复区域中包括可编辑区域。

若要添加、删除重复区域或更改重复区域的顺序，请执行以下操作：

  1. 将插入点放在重复区域中以选中它。
  2. 执行下列操作之一：
    • 单击加号 (+) 按钮在当前所选项下面添加一个重复区域项。
    • 单击减号 (-) 按钮删除所选重复区域项。
    • 单击“向下箭头”按钮将所选项向下移动一个位置。
    • 单击“向上箭头”按钮将所选项向上移动一个位置。

      注意

      或者，您可以选择“修改”>“模板”，然后选择靠近上下文菜单底部的其中一个重复项选项。可以使用此菜单插入新的重复项或移动所选项的位置。

若要剪切、复制和删除项，请执行以下操作：

  1. 将插入点放在重复区域中以选中它。
  2. 执行下列操作之一：
    • 要剪切重复项，可选择“编辑”>“重复项”>“剪切重复项”。
    • 要复制重复项，可选择“编辑”>“重复项”>“复制重复项”。
    • 要删除重复项，可选择“编辑”>“重复项”>“删除重复项”。
    • 要粘贴重复项，可选择“编辑”>“粘贴”。

      注意

      粘贴操作将插入新项；它并不替换现有项。

相关主题

  • 创建重复区域


参考资料

本节提供在本章介绍的下列对话框和面板的有关信息：

  • 设置“另存为模板”对话框选项
  • 设置“新建可编辑区域”对话框选项
  • 设置“新建重复区域”对话框选项
  • 设置“插入重复表格”对话框选项
  • 设置“可选区域”对话框选项
  • 解决不一致的区域名称
  • 设置“可编辑标签属性”对话框选项
  • 使用“资源”面板管理模板
  • 设置“更新页面”对话框选项
  • 设置“以 XML 形式导出模板数据”对话框
  • 设置“导出不具有模板标记的站点”对话框选项
  • 设置“模板描述”对话框选项


设置“另存为模板”对话框选项

此对话框用于将文档另存为模板。

若要完成“另存为模板”对话框，请执行以下操作：

  1. 从“站点”弹出菜单中选择保存该模板的站点。
  2. 在“另存为”文本框中输入该模板的唯一名称。
  3. 单击“保存”。

    Dreamweaver 将模板文件保存在站点的本地根文件夹中的 Templates 文件夹中，使用文件扩展名 .dwt。如果该 Templates 文件夹在站点中尚不存在，Dreamweaver 将在您保存新建模板时自动创建该文件夹。

    注意

    不要将模板移动到 Templates 文件夹之外或者将任何非模板文件放在 Templates 文件夹中。此外，不要将 Templates 文件夹移动到本地根文件夹之外。这样做将在模板中的路径中引起错误。

相关主题

  • 创建 Dreamweaver 模板


设置“新建可编辑区域”对话框选项

此对话框用于命名模板中的可编辑区域。

若要完成“新建可编辑区域”对话框，请执行以下操作：

  1. 为该区域输入一个唯一名称。（不能对特定模板中的多个可编辑区域使用相同的名称。

    注意

    不要在“名称”域中使用特殊字符。
  2. 单击“确定”。

    可编辑区域在模板中由高亮显示的矩形边框围绕，该边框使用在首选参数中设置的高亮颜色。该区域左上角的选项卡显示该区域的名称。如果在文档中插入空白的可编辑区域，则该区域的名称会出现在该区域内部。

相关主题

  • 插入可编辑区域


设置“新建重复区域”对话框选项

此对话框用于命名模板中新的重复区域。重复区域是可以根据需要在基于模板的页面中复制任意次数的模板部分。

若要完成“新建重复区域”对话框，请执行以下操作：

  1. 在“名称”文本框中为模板区域输入唯一的名称。（不能对一个模板中的多个重复区域使用相同的名称。

    注意

    不要在“名称”文本框中使用特殊字符。
  2. 单击“确定”。

    重复区域被插入到文档中

    注意

    重复区域在基于模板的文档中是不可编辑的，除非其中包含可编辑区域。有关插入可编辑区域的信息，请参见插入可编辑区域。

相关主题

  • 在模板中创建重复区域


设置“插入重复表格”对话框选项

此对话框用于在插入重复表格前指定其属性。

若要完成“插入重复表格”对话框，请执行以下操作：

  1. 指定以下选项：

    行数确定表格具有的行的数目。

    列数确定表格具有的列的数目。

    单元格边距确定单元格内容和单元格边框之间的像素数。

    单元格间距确定相邻的表格单元格之间的像素数。

    提示

    如果没有明确指定单元格边距和单元格间距的值，大多数浏览器都按单元格边距设置为 1，单元格间距设置为 2 显示表格。若要确保浏览器不显示表格中的边距和间距，请将“单元格边距”和“单元格间距”设置为 0。

    宽度以像素为单位或按占浏览器窗口宽度的百分比指定表格的宽度。

    边框指定表格边框的宽度（以像素为单位）。

    提示

    如果您没有明确指定边框的值，则大多数浏览器按边框设置为 1 显示表格。若要确保浏览器显示的表格没有边框，请将“边框”设置为 0。若要在边框设置为 0 时查看单元格和表格边框，请选择“查看”>“可视化助理”>“表格边框”。

    重复表格行指定表格中的哪些行包括在重复区域中。

    起始行将输入的行号设置为包括在重复区域中的第一行。

    结束行将输入的行号设置为包括在重复区域中的最后一行。

    区域名称让您为重复区域设置唯一的名称。

  2. 单击“确定”插入表格。

相关主题

  • 插入重复表格


设置“可选区域”对话框选项

使用此对话框可以创建模板参数并为模板区域定义条件语句（If...else 语句）。可以使用简单的真/假操作，或定义更复杂的条件语句和表达式。

在“高级”选项卡中，可以将多个可选区域链接到一个已命名的参数。在基于模板的文档中，两个区域将作为一个整体显示或隐藏。例如，可以显示销售产品的“出清存货”图像和销售价格文本区域。

您还可以使用“高级”选项卡编写一个用来计算可选区域的值的模板表达式（请参见模板表达式），并根据该值来显示或隐藏可选区域。

若要完成“可选区域”对话框，请执行以下操作：

  1. 在“基本”选项卡中，把参数的名称输入“名称”文本框中。
  2. 选中“按默认值显示”复选框以设置要在文档中显示的选定区域。取消选择该复选框将把默认值设置为假。

    注意

    若要为参数设置不同的值，请在“代码”视图中文档的 head 部分定位该参数，然后编辑它的值。
  3. （可选）单击“高级”选项卡，然后设置以下选项：
    • 如果要链接可选区域参数，请单击“高级”选项卡，选择“使用参数”，然后从弹出式菜单中选择要将所选内容链接到的现有参数。
    • 如果要编写模板表达式来控制可选区域的显示，请单击“高级”选项卡，选择“输入表达式”，然后在文本框中输入表达式。

      注意

      Dreamweaver 自动在您输入的文本两侧插入双引号。
  4. 单击“确定”。

当使用“可选区域”模板对象时，Dreamweaver 将在代码中插入模板注释。模板参数在 head 部分中定义，如以下示例所示：

<!-- TemplateParam name="departmentImage" type="boolean" value="true" -->

在插入可选区域的位置，将出现类似于下列代码的代码：

<!-- TemplateBeginIf cond="departmentImage" -->
<p><img src="/images/airfare_on.gif" width="85" height="22"> </p>
<!-- TemplateEndIf -->

可以在基于模板的文档中访问和编辑模板参数（请参见修改模板属性）。

相关主题

  • 插入可选区域


解决不一致的区域名称

此对话框用于将文档中的内容指定给模板区域。

若要将现有内容指定给新文档中的可编辑区域，请执行以下操作：

  1. 在“将内容移动到新区域”弹出式菜单中，执行以下操作之一：
    • 在新模板中选择一个要将现有内容移动到其中的区域。
    • 选择“不在任何地方”可将该内容从文档中删除。
  2. 若要将所有未解决的内容移到选定的区域，请单击“用于所有内容”。
  3. 单击“确定”应用模板，或单击“取消”取消将模板应用到文档的操作。

相关主题

  • 将模板应用到现有文档


设置“可编辑标签属性”对话框选项

此对话框用于将选定标签的属性设置为可编辑。

  1. 执行以下操作之一以选择属性：
    • 如果想要使其可编辑的属性列在“属性”弹出式菜单中，请选定它。
    • 如果要将其设置为可编辑的属性没有列在“属性”弹出式菜单中，请单击“添加”，然后在打开的对话框中输入想要添加的属性的名称，再单击“确定”。
  2. 请确保“使属性可编辑”选项被选定。
  3. 在“标签文字”文本框中，为属性输入唯一的名称。

    提示

    若要使以后标识特定的可编辑标签属性变得更加容易，请使用标识元素和属性的标签。例如，可以将具有可编辑源的图像标为 logoSrc，或者将 body 标签的可编辑背景颜色标为 bodyBgcolor。
  4. 在“类型”弹出式菜单中，选择该属性所允许具有的值的类型，方法是设置下列选项之一：
    • 若要让用户为属性输入文本值，请选择“文本”。

      例如，可以使用带有 align 属性的文本；然后，用户就可以将该属性的值设置为左对齐、右对齐 或居中对齐。

    • 若要插入元素的链接（如图像的文件路径），请选择“URL”。

      使用 URL 可以让 Dreamweaver 自动更新链接中使用的路径。如果用户将图像移动到新的文件夹，则会出现“更新链接”对话框。

    • 若要使颜色选择器可用于选择值，请选择“颜色”。
    • 若要让模板用户可以键入数值以更新属性（例如，更改图像的高度或宽度值），请选择“数字”。
  5. “默认值”文本框显示模板中所选标签属性的值。在此文本框中输入一个新值，为基于模板的文档中的参数设置一个不同的初始值。
  6. （可选）如果您要更改所选标签的其他属性，请选择该属性，然后完成该属性的对话框。
  7. 单击“确定”。

相关主题

  • 在模板中指定可编辑标签属性


使用“资源”面板管理模板

“资源”面板的“模板”类别用于创建和管理站点的模板。

您可以使用此对话框执行以下任务：

  • 创建 Dreamweaver 模板
  • 在现有文档中应用或删除模板
  • 编辑和更新模板
  • 管理模板


设置“更新页面”对话框选项

该对话框用于在模板更改后更新页面。可以更新站点的所有页面，也可以只更新特定模板的页面。

若要完成“更新页面”对话框，请执行以下操作：

  1. 在“查看”弹出式菜单中执行下列操作之一：
    • 若要更新站点中的所有文件，可选择“整个站点”，然后从相邻的弹出菜单中选择站点名称。

      此选项将根据相应的模板更新所选站点中的所有页面。

    • 要根据特定模板更新文件，请选择“文件使用”，然后从相邻的弹出菜单中选择模板名称。

      此选项将更新当前站点中使用所选模板的所有页面。

  2. 请确保在“更新”选项中选定了“模板”。
  3. 如果您不想查看 Dreamweaver 更新文件的记录，可取消选择“显示记录”选项；否则，可让该选项处于选中状态。
  4. 单击“开始”。

    Dreamweaver 按照指示更新文件。如果选择了“显示记录”选项，Dreamweaver 将提供关于它试图更新的文件的信息，包括它们是否成功更新的信息。

  5. 单击“关闭”关闭对话框。

相关主题

  • 手动更新基于模板的文档


设置“以 XML 形式导出模板数据”对话框

该对话框用于设置导出模板的可编辑区域的选项。

要完成“以 XML 形式导出模板数据”对话框，请执行以下操作：

  1. 选择“符号”选项之一：
    • 如果模板中包含重复区域或模板参数，请选择“使用标准 Dreamweaver XML 标签”。
    • 如果模板中不包含重复区域或模板参数，请选择“使用可编辑区域名称作为 XML 标签”。
  2. 单击“确定”。

相关主题

  • 导出和导入模板 XML 内容


设置“导出不具有模板标记的站点”对话框选项

此对话框用于将站点中基于模板的文档导出到另一个站点，而不包括模板标记。

若要完成“导出不具有模板标记的站点”对话框，请执行以下操作：

  1. 在“文件夹”文本框中，输入要将文件导出到的文件夹的文件路径，或者单击“浏览”并选择该文件夹。

    必须在当前站点外部选择一个将该站点解压缩到的文件夹。

  2. 如果要保存已导出的基于模板的文档的 XML 版本，请选择“保留模板数据文件”。
  3. 若要将更改更新到以前导出的文件，请选择“只解压缩已更改的文件”。
  4. 单击“确定”。

相关主题

  • 导出不具有模板标记的站点


设置“模板描述”对话框选项

此对话框用于提供模板描述。选择模板时，描述将出现在“新建文档”对话框中。

若要提供模板描述，请执行以下操作：

  • 输入描述并单击“确定”。


向页面添加内容

使用 Macromedia Dreamweaver 8 中的可视化工具向 Web 页添加各种内容。添加元素并设置元素的格式，这些元素包括文本、图像、颜色、影片、声音和其它媒体形式等。确保有障碍的访问者也能够访问您的页面。

此部分包含以下各章：

使用页面

插入文本和设置文本格式

插入图像

链接与导航

使用其它应用程序

添加音频、视频和交互式元素

使用 JavaScript 行为


使用页面

Macromedia Dreamweaver 8 提供了许多帮助您创建新 Web 页面的功能。这些页面创建功能可以帮助您更容易地指定 Web 页面属性，例如页标题、背景图像和颜色及文本和链接的颜色。此外，Dreamweaver 还提供了工具以帮助您最优化 Web 站点的性能，并且创建和测试页面以确保能够兼容不同的 Web 浏览器。

本章包含下列章节：

关于使用页面

保存 Web 页面

指定 HTML 而不是 CSS

设置页面属性

使用颜色

在“文档”窗口中选择元素

放大和缩小

使用“历史记录”面板

任务自动化

使用 JavaScript 行为检测浏览器和插件

在浏览器中预览和测试页面

设置下载时间和大小首选参数


关于使用页面

创建 Web 页面时，您必须考虑用户将使用什么浏览器和操作系统来查看您的 Web 页面，以及您可能需要支持哪些语言设置。下面的部分将帮助您了解三方面的内容：如何选择能够在不同的 Web 浏览器中正确显示的颜色，不同字符（字母形式）在不同语言中的编码及如何检查 Web 浏览器与 Web 站点的兼容性。

本节包含以下主题：

  • 关于设置页面属性
  • 关于“历史记录”面板
  • 关于网页安全色
  • 了解文档编码
  • 关于使用保存命令与重放步骤


关于设置页面属性

对于您在 Dreamweaver 中创建的每一页，可以使用“页面属性”对话框（“修改”>“页面属性”）指定布局和格式设置属性。“页面属性”对话框让您可以指定页面的默认字体家族和字体大小、背景颜色、边距、链接样式及页面设计的许多其他方面。您可以为创建的每个新页面指定新的页面属性，也可以修改现有页面的属性

默认情况下，Dreamweaver 使用 CSS（层叠样式表）设置文本格式。可以使用“首选参数”对话框（“编辑”>“首选参数”）更改 HTML 格式设置的页面格式设置首选参数。使用 CSS 页面属性时，Dreamweaver 对在“页面属性”对话框的“外观”、“链接”和“标题”类别中定义的所有属性使用 CSS 标签。定义这些属性的 CSS 标签会嵌入到页面的 head 部分中。

注意

您选择的页面属性仅应用于活动文档。如果一个页面使用了外部 CSS 样式表，Dreamweaver 将不会覆盖在该样式表中设置的标签，因为这将影响使用该样式表的其他所有页面。

CSS 页面属性与 HTML 页面属性

默认情况下，Dreamweaver 使用 CSS 指定页面属性。如果您想使用 HTML 标签，则必须在“首选参数”对话框中进行指定（有关更多信息，请参见指定 HTML 而不是 CSS）。

如果选择使用 HTML 而不是 CSS，“属性”检查器仍显示“样式”弹出式菜单。不过，字体、大小、颜色和对齐方式控件将只显示使用 HTML 标签的属性设置。应用于当前选择的 CSS 属性值将是不可见的，“大小”弹出式菜单也将被禁用。

相关主题

  • 指定 HTML 而不是 CSS
  • 设置页面属性
  • 设置“标题/编码页面属性”选项


关于“历史记录”面板

“历史记录”面板显示自从您创建或打开某个文档以来在该活动文档中所执行的步骤列表，列表中步骤的数目最多为指定的数目。（“历史记录”面板并不显示您在其他框架、其他“文档”窗口或“站点”面板中执行的步骤。）它允许您撤消一个或多个步骤；它还允许您重放步骤以及创建将重复任务自动化的新命令。

“历史记录”面板中的滑块（游标）最初指向所执行的最后一个步骤。

相关主题

  • 使用“历史记录”面板


关于网页安全色

在 HTML 中，颜色或者表示成十六进制值（如 #FF0000）或者表示为颜色名称 (red)。网页安全色是指以 256 色模式运行时，无论在 Windows 还是在 Macintosh 系统中，在 Netscape Navigator 和 Microsoft Internet Explorer 中的显示相同的颜色。传统经验是，有 216 种常见颜色，而且任何结合了 00、33、66、99、CC 或 FF 对（RGB 值分别为 0、51、102、153、204 和 255）的十六进制值都代表网页安全色。

但测试显示仅有 212 种网页安全色而不是全部 216 种，原因在于 Windows Internet Explorer 不能正确呈现颜色 #0033FF (0,51,255)、#3300FF (51,0,255)、#00FF33 (0,255,51) 和 #33FF00 (51,255,0)。

当 Web 浏览器第一次设置它们的外观时，大部分计算机只显示 265 色（8 位）。今天，大多数计算机都能显示数以千计或数以百万计的颜色（16 位和 32 位），所以如果您为使用当前计算机系统的用户开发站点时，完全没有必要使用浏览器安全调色板。

使用网页安全颜色调色板的一种情况是开发适用于替代 Web 设备，如 PDA 和手机显示屏的站点。许多这类设备只提供黑白色（1 位）或 256 色（8 位）显示屏。

Dreamweaver 中的“立方色”（默认）和“连续色调”调色板使用 216 色网页安全调色板，从这些调色板中选择颜色会显示颜色的十六进制值。

若要选择网页安全范围外的颜色，请单击 Dreamweaver 颜色选择器右上角的“调色盘”按钮打开系统颜色选择器。系统颜色选择器不限于网页安全色。

Netscape Navigator 的 UNIX 版本使用与 Windows 和 Macintosh 版本不同的调色板。如果专门为 UNIX 浏览器开发（或者目标用户是使用 24 位显示器的 Windows 或 Macintosh 用户或使用 8 位显示器的 UNIX 用户），请考虑使用结合了 00、40、80、BF 或 FF 对的十六进制值，这些值产生用于 Sun 系统的网页安全色。

相关主题

  • 使用颜色


了解文档编码

文档编码指定文档中字符所用的编码。文档编码在文档头中的 meta 标签内指定，它告诉浏览器和 Dreamweaver 应如何对文档进行解码以及使用哪些字体来显示解码的文本。

例如，如果您指定“西欧字符 (Latin1)”，则插入此 meta 标签：<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">。Dreamweaver 使用您在“字体首选参数”中为“西欧字符 (Latin1)”编码指定的字体显示文档；浏览器使用浏览器用户为“西欧字符 (Latin1)”编码指定的字体显示文档。

如果您指定“日语 (Shift JIS)”，则插入此 meta 标签：<meta http-equiv="Content-Type" content="text/html; charset=Shift_JIS">。Dreamweaver 使用您为日语编码指定的字体来显示文档；浏览器使用浏览器用户为日语编码指定的字体来显示文档。

若要更改页面的文档编码，请参见设置页面属性。若要更改 Dreamweaver 创建新文档时使用的默认编码，请参见设置默认的新文档类型。若要更改 Dreamweaver 显示每种编码时使用的字体，请参见设置 Dreamweaver 显示的“字体”首选参数。


关于使用保存命令与重放步骤

Dreamweaver 使您可以录制短期使用的临时命令，您还可以从“历史记录”面板重放步骤。

当您录制临时命令时：

  • 您执行步骤时，这些步骤会被录制下来，所以您无需在重放它们之前在“历史记录”面板中选择它们。
  • 在录制过程中，Dreamweaver 禁止执行不可录制的鼠标移动（如单击选择窗口中的某个对象，或将页面元素拖动到新位置）。
  • 如果在录制时切换到另一个文档，Dreamweaver 不会录制在另一个文档中所做的改动。若要随时确定是否在进行录制，请查看鼠标指针。

相关主题

  • 任务自动化
  • 重复步骤
  • 录制命令


保存 Web 页面

可以使用当前的文档名和位置来保存文档，或者使用一个不同的名称和位置来保存文档的副本。

给文件命名时，应避免在文件名和文件夹名中使用空格和特殊字符。具体说来就是不要在打算放到远程服务器上的文件名中使用特殊字符（如 é、ç、或 ¥）或标点符号（如冒号、斜杠或句号）；很多服务器在上传时会更改这些字符，这会导致与这些文件的链接中断。而且，文件名不要以数字开头。

若要保存文档，请执行以下操作：

  1. 执行下列操作之一：
    • 若要在磁盘上覆盖当前版本，并保存所做的任何更改，请选择“文件”>“保存”。
    • 若要在一个不同的文件夹中保存文件或使用不同的名称保存文件，请选择“文件”>“另存为”。
  2. 在出现的“另存为”对话框中，定位到要用来保存文件的文件夹。
  3. 在“文件名称”文本框中，键入文件名。
  4. 单击“保存”保存文件。

若要保存所有打开的文档，请执行以下操作：

  1. 选择“文件”>“保存全部”。
  2. 如果有已打开但未保存的文档，将会为每个未保存的文档显示“另存为”对话框。

    在出现的对话框中，定位到要用来保存文件的文件夹。

  3. 在“文件名称”文本框中，键入文件名。
  4. 单击“保存”保存文件。

若要回复到文档上次保存的版本，请执行以下操作：

  1. 选择“文件”>“回复”。

    将出现一个对话框询问您，是否要放弃所作的修改并回复到上一次保存的版本。

  2. 若要回复到上次的版本，请单击“是”；若要保留所作的修改，请单击“否”。

    注意

    如果您保存了一个文档，然后退出 Dreamweaver，当您重新启动 Dreamweaver 时，不能回复到该文档的以前版本。

相关主题

  • 创建新文档
  • 保存新文档


指定 HTML 而不是 CSS

默认情况下，Dreamweaver 使用 CSS 标签指定页面属性。如果要改用 HTML 标签，您必须在“首选参数”对话框的“常规”类别中取消对“使用 CSS 而不是 HTML 标签”选项的选择。

若要指定 HTML 而不是 CSS 标签来设置页面属性，请执行以下操作：

  1. 选择“编辑”>“首选参数”。

    显示“首选参数”对话框。

  2. 在“页面属性”对话框的“常规”类别中，取消选中“使用 CSS 而不是 HTML 标签”复选框。

    该复选框位于“常规首选参数”面板的“编辑选项”部分中。

  3. 单击“确定”。

相关主题

  • 关于设置页面属性


设置页面属性

页面标题、背景图像和颜色、文本和链接颜色以及边距是每个 Web 文档的基本属性。可以使用“页面属性”对话框设置或更改页面属性。

若要设置文档属性，请执行以下操作：

  1. 选择“修改”>“页面属性”，或单击文本“属性”检查器中的“页面属性”按钮。

    即会打开“页面属性”对话框。

  2. 根据需要更改页面属性。

    有关完成“页面属性”对话框的信息，请参见关于设置页面属性。

  3. 单击“确定”。

相关主题

  • 关于设置页面属性
  • 更改文档标题
  • 设置 CSS 链接的下划线样式
  • 设置背景图像或背景页面颜色


更改文档标题

HTML 页面的标题可以帮助站点访问者在浏览时明确所查看的内容，并在访问者的历史记录和书签列表中标识页面。如果不给页面加标题，页面会在浏览器窗口、书签列表和历史记录列表中显示为无标题文档。

注意

给文档起一个文件名（通过保存该文件）不同于给页面加标题。

若要定位站点中的所有无标题文档，请使用“站点”>“报告”命令。（请参见测试站点。）

若要更改页面标题，请执行以下操作：

  1. 文档打开时，执行下列操作之一：
    • 选择“修改”>“页面属性”。
    • 选择“查看”>“工具栏”>“文档”（如果尚未选定）。
    • 在文档中的空白区域右键单击 (Windows) 或按住 Control 键并单击 (Macintosh)，然后选择“页面属性”。
  2. 在“标题”文本框中，输入页面标题，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
  3. 如果要在“页面属性”对话框中编辑标题，请单击“确定”。

    标题会出现在“文档”窗口的标题栏中（如果显示，也会出现在“文档”工具栏中）。页面的文件名和保存文件的文件夹显示在标题栏中标题旁边的括号中。星号表示文档包含尚未保存的更改。

相关主题

  • 关于设置页面属性


设置 CSS 链接的下划线样式

如果使用默认的“CSS 页面属性”对话框，Dreamweaver 很容易指定特殊的 CSS 链接样式。使用 CSS 链接选项，可以选择从不对链接加下划线、仅当鼠标指针移过该链接时对它加下划线或当鼠标指针移过链接时禁用链接。

若要设置 CSS 链接样式，请执行以下操作：

  1. 选择“修改”>“页面属性”，或从“文档”窗口的“设计”视图中的上下文菜单中选择“页面属性”。
  2. 在“CSS 页面属性”对话框中选择“链接”类别。
  3. 从“下划线样式”弹出式菜单中，选择您的页面的默认下划线样式。
  4. 单击“确定”。

相关主题

  • 关于设置页面属性
  • 链接与导航

设置背景图像或背景页面颜色

若要定义页面背景的图像或颜色，请使用“页面属性”对话框。

如果同时使用背景图像和背景颜色，下载图像时会出现颜色，然后图像覆盖颜色。如果背景图像包含任何透明像素，则背景颜色会透过背景图像显示出来。

若要定义背景图像或颜色，请执行以下操作：

  1. 选择“修改”>“页面属性”，或从“文档”窗口的“设计”视图中的上下文菜单中选择“页面属性”。
  2. 在“页面属性”对话框中选择“外观”类别。
  3. 若要设置背景图像，请单击“浏览”按钮，然后浏览并选择图像。或者，可以在“背景图像”对话框中输入背景图像的路径。

    如果背景图像没有填满整个窗口，Dreamweaver 会平铺（重复）背景图像，就像浏览器所做的那样。（若要防止背景图像平铺，请使用层叠样式表禁用图像平铺。请参见定义 CSS 样式背景属性。）

  4. 若要设置背景颜色，请单击“背景”颜色框并从颜色选择器中选择颜色。

相关主题：

  • 关于设置页面属性


使用颜色

在 Dreamweaver 中，很多对话框与许多页面元素的“属性”检查器一样，都包含可打开颜色选择器的颜色框。使用颜色选择器选择页面元素的颜色。

若要在 Dreamweaver 中选择颜色，请执行以下操作：

  1. 在任何对话框或“属性”检查器中单击颜色框。

    出现颜色选择器。

  2. 执行下列操作之一：
    • 用滴管从调色板中选择颜色样本。“立方色”（默认）和“连续色调”调色板中的所有颜色都是网页安全色，其他调色板中的则不是。有关更多信息，请参见关于网页安全色。
    • 用滴管从屏幕上的任何位置取色，即使从 Dreamweaver 窗口外也可以。要从桌面或其他应用程序中取色，可按住鼠标按钮；这样滴管仍能保持焦点，可以从 Dreamweaver 外选择颜色。如果您单击桌面或其他应用程序，Dreamweaver 会选取您单击的位置的颜色。不过，如果切换到其他应用程序，可能需要单击 Dreamweaver 窗口才能在 Dreamweaver 中继续工作。
    • 若要展开颜色选项，请使用颜色选择器右上角的弹出式菜单。可以选择“立方色”、“连续色调”、“Windows 系统”、“Mac 系统”、“灰度等级”和“调整到网页安全色”。

      注意

      “立方色”和“连续色调”调色板的颜色是网页安全色，而“Windows 系统”、“Mac 系统”和“灰度等级”的颜色则不是。如果使用的调色板颜色不是网页安全色，然后选择“调整到网页安全色”，则 Dreamweaver 会用最接近的网页安全色替换所选颜色。换句话说，您得到的可能并不是所看见的颜色。

      若要清除当前颜色而不选择另一种颜色，请单击“默认颜色” 这是所描述的功能的图片。 按钮。

      若要打开系统颜色选择器，请单击“调色盘” 这是所描述的功能的图片。 按钮。有关更多信息，请参见关于网页安全色。


定义默认文本颜色

在“页面属性”对话框中为常规文本、链接、访问过的链接和活动链接定义默认颜色，或者选择预设配色方案定义页面背景和文本颜色。（请参见使用颜色。）

注意

活动链接颜色是单击链接时链接变成的颜色。有些 Web 浏览器可能不使用指定的颜色。

若要定义默认文本颜色，请执行下列操作之一：

  • 选择“修改”>“页面属性”，然后为“文本颜色”、“链接颜色”、“访问过的链接”和“活动链接”选项选择颜色。
  • 选择“命令”>“设置配色方案”，然后选择背景颜色以及为文本和链接设置的颜色。

    示例对话框显示配色方案在浏览器中的外观。

    注意

    如果您使用“页面属性”对话框，用默认 CSS 标签定义这些设置，“配色方案”命令不会影响您的页面外观。这是因为 CSS 标签的优先级高于 HTML 标签。

相关主题

  • 关于设置页面属性


在“文档”窗口中选择元素

若要在“文档”窗口的“设计”视图中选择元素，通常可以单击元素。如果元素不可见，必须使其可见后才能选择它。有关不可见元素的更多信息，请参见显示和隐藏不可见元素.

若要选择元素，请使用下列方法：

  • 若要选择“文档”窗口中的可见元素，请单击元素或在元素上拖过。
  • 若要选择不可见元素，请选择“查看”>“可视化助理”>“不可见元素”（如果还没有选择该菜单项），然后在“文档”窗口中单击元素的标记。

    有些对象出现在页面上的位置并不是其代码插入的位置。例如，层可以出现在页面上的任何地方，但定义该层的代码在固定的位置。当不可见元素显示时，Dreamweaver 在“文档”窗口中显示标记以指示这类元素的代码的位置。选择标记时将选择整个元素，例如，选择层的标记将选择整个层。（请参见显示和隐藏不可见元素。）

  • 若要选择完整的标签（包括其内容，如果有内容），请单击“文档”窗口左下角的标签选择器中的标签。（标签选择器在“设计”视图和“代码”视图中都出现。）标签选择器总是显示包含当前选择或插入点的标签。最左边的标签是包含当前选择或插入点的最外边的标签。下一个标签包含在那个最外边的标签中，依此类推；最右边的标签是包含当前选择或插入点的最里边的标签。

    在下面的示例中，插入点是段落标签 <p>。若要选择包含您要选择的段落的表格，请选择 <p> 标签左侧的 <table> 标签。

若要查看与所选文本或对象关联的 HTML 代码，请执行下列操作之一：

  • 在“文档”工具栏中，单击“显示代码视图”按钮。
  • 选择“查看”>“代码”。
  • 在“文档”工具栏中，单击“显示代码视图和设计视图”按钮。
  • 选择“查看”>“代码和设计”。
  • 选择“窗口”>“代码检查器”。

有关“代码”视图的更多信息，请参见查看您的代码。

在两个代码编辑器（“代码”视图或代码检查器）中的任何一个中选择对象后，该对象通常在“文档”窗口中也被选中。在选定内容出现前，可能需要同步两个视图；请参见查看您的代码。


显示和隐藏不可见元素

有些 HTML 代码在浏览器中没有可见的表示形式。例如，comment 标签不会出现在浏览器中。但是，此标签在创建能够选择、编辑、移动和删除这类不可见元素的页面时很有用。

Dreamweaver 使您可以指定在“文档”窗口的“设计”视图中是否显示标记不可见元素位置的图标。若要指明在选择“查看”>“可视化助理”>“不可见元素”时显示哪些元素标记，可以在“不可见元素”首选参数中设置选项。例如，可以指定命名锚记可见，而换行符不可见。

可以使用“插入”栏“常用”类别中的按钮创建某些不可见元素（如注释和命名锚记）（请参见使用“插入”栏）。然后可以使用“属性”检查器修改这些元素。

若要显示或隐藏不可见元素的标记图标，请执行以下操作：

  • 选择“查看”>“可视化助理”>“不可见元素”。

    注意

    显示不可见元素可能会稍微更改页面的布局，将其他元素移动几个像素，因此为了精确布局，请隐藏不可见元素。

若要更改“不可见元素”首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)，然后单击“不可见元素”。
  2. 选择哪种元素应该是可见的。

    对话框中元素名称旁边的选中标记表示当选择“查看”>“可视化助理”>“不可见元素”时，该元素是可见的。

    有关更多信息，请参见设置“不可见元素”首选参数。

  3. 单击“确定”。


放大和缩小

Dreamweaver 允许您使用缩放工具放大或缩小文档，以便查看图形的像素精确度、更加轻松地选择小项目、设计包含小文本的页面、设计大页面，等等。

注意

缩放工具只在“设计”视图中可用。

若要在页面上进行放大，请执行以下操作：

  1. 选择“文档”窗口右下角中的“缩放工具”（放大镜图标）。
  2. 执行下列操作之一：
    • 在页面上需要放大的位置上单击，直到获得所需的放大比率。
    • 在页面上需要放大的区域上拖出一个框，然后释放鼠标按钮。
    • 从“缩放”弹出式菜单中选择一个预先设置的缩放比率。
    • 在“缩放”文本框中键入一个缩放比率。

      提示

      也可以不使用“缩放工具”，而是通过按 Control+= (Windows) 键或 Command+= (Macintosh) 键进行放大。

若要缩小，请执行以下操作：

  1. 选择“缩放工具”。
  2. 按住 Alt 键 (Windows) 或 Option 键 (Macintosh) 并在页面上单击。

    提示

    也可以不使用“缩放工具”，而是通过按 Control+- (Windows) 键或 Command+- (Macintosh) 键进行缩小。

若要在缩放后编辑页面，请执行以下操作：

  • 选择“文档”窗口右下角中的“指针工具”（指针图标），然后在页面内单击。

若要在缩放后平移页面，请执行以下操作：

  1. 选择“文档”窗口右下角中的“手形工具”（手形图标）。
  2. 拖动页面。

若要用所选内容填充“文档”窗口，请执行以下操作：

  1. 选择页面上的元素。
  2. 选择“查看”>“符合所选”。

若要用整个页面填充“文档”窗口，请执行以下操作：

  • 选择“查看”>“符合全部”。

若要用页面的整个宽度填充“文档”窗口，请执行以下操作：

  • 选择“查看”>“符合宽度”。

相关主题

  • 状态栏


使用“历史记录”面板

“历史记录”面板跟踪您在 Dreamweaver 中工作的每一个步骤。您可以使用“历史记录”面板一次撤消多个步骤。

若要撤消您对文档执行的最后操作，请选择“编辑”>“撤消”，就像您在其他应用程序中所执行的那样。（“编辑”菜单中的“撤消”命令的名称将更改以反映所执行的最后一个操作。）

“历史记录”面板还用来重放已经执行过的步骤，并且可以通过创建新的命令自动执行任务。有关更多信息，请参见任务自动化。

若要打开“历史记录”面板，请执行以下操作：

  • 选择“窗口”>“历史记录”。

若要撤消最后一个步骤，请执行以下操作：

  • 在列表中将“历史记录”面板的滑块向上拖动一个步骤。这与选择“编辑”>“撤消”具有相同的效果。

    撤消的步骤变为灰色。

若要一次撤消多个步骤，请执行下列操作之一：

  • 拖动滑块以指向任何一个步骤。
  • 在滑块路径上的某个步骤的左侧单击，滑块将自动滚动到该步骤，并在滚动的时候撤消所经过的步骤。

    注意

    若要自动滚到某个特定的步骤，您必须单击该步骤的左侧；单击该步骤本身只是选择该步骤。选择一个步骤不同于在您的撤消历史记录中返回到该步骤。

对于撤消单个步骤来说，如果您撤消了一系列步骤，然后在文档中执行了新的操作，则您不能够重做撤消过的步骤；它们将从“历史记录”面板中消失。

若要设置“历史记录”面板保留和显示的步骤数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或Dreamweaver>“首选参数”(Macintosh)。
  2. 从左侧的“类别”列表中选择“常规”。
  3. 为“历史步骤最多次数”输入一个数字。

    默认值应该足够满足大多数用户的需要。这个数字越高，“历史记录”面板需要的内存就越大。这会明显地影响性能并使计算机变慢。当“历史记录”面板达到该最大步骤数时，将放弃最早的步骤。

    注意

    不能对“历史记录”面板中的步骤进行重新排序。不要将“历史记录”面板看作一个任意的命令集合；应将它看作一种以您执行的先后顺寻来查看所执行的步骤的方法。

若要删除当前文档的历史记录列表，请执行以下操作：

  • 在“历史记录”面板的上下文菜单中，选择“清除历史记录”。

    该命令还清除当前文档的全部撤消信息；选择“清除历史记录”后，您将无法撤消被清除的步骤。（请注意“清除历史记录”并不撤消步骤；它只是从 Dreamweaver 的记录中删除这些步骤的记录。）

相关主题

  • 关于“历史记录”面板


任务自动化

创建文档时，可能需要多次执行同一任务。

若要一次或两次重复执行一系列步聚，请直接从“历史记录”面板中重放它们。“历史记录”面板在您使用文档时记录您的步骤。（有关“历史记录”面板的基本信息，请参见关于“历史记录”面板。）若要使经常执行的任务自动执行，可以创建一个新命令来自动执行该任务。

一些鼠标动作（如在“文档”窗口通过单击或拖动选择对象）不能重放或作为已保存命令的一部分进行保存。当您进行这样的移动时，“历史记录”面板中会出现一条黑线（尽管直到您执行另一个动作时，这条线才变得明显）。若要避免不能重放的动作，请在“文档”窗口内使用箭头键而不是鼠标来移动插入点。若要进行选择或扩展选择，请按住 Shift 键并按箭头键。

提示

在执行以后要重复执行的任务时，如果出现一条黑色的鼠标移动指示线，您可以撤消原来的步骤并尝试另外的方法（多半是使用箭头键）。

还有其他一些步骤也是不能重复执行的，如将页面元素拖动到页面上的其他位置。当您执行这样的步骤时，“历史记录”面板中会出现一个带有红色小 X 的菜单命令图标。

相关主题

  • 重复步骤
  • 将步骤应用于另一个对象
  • 将步骤应用于多个对象
  • 在文档间复制和粘贴步骤
  • 用历史步骤创建新命令
  • 录制命令


重复步骤

您可以使用“历史记录”面板重复所执行的最后一个步骤，重复一系列连续的步骤，或重复一系列不连续的步骤。（有关“历史记录”面板的基本信息，请参见关于“历史记录”面板。）

若要重复一个步骤，请执行以下操作之一：

  • 选择“编辑”>“重做”。

    此命令的名称在“编辑”菜单中会发生变化，以反映所执行的最后一步；例如，如果刚键入了一些文本，则此命令的名称为“重复键入”。

  • 在“历史记录”面板中，选择一个步骤然后单击“重放”按钮。

    该步骤随即重放，并且“历史记录”面板中会出现它的一个副本。

若要重复一系列相邻的步骤，请执行以下操作：

  1. 执行下列操作之一在“历史记录”面板中选择步骤：
    • 从一个步骤拖动到另一步骤。（不要拖动滑块，只能从一个步骤的文本标签拖动到另一个步骤的文本标签。）
    • 选择第一步，然后按住 Shift 键并单击最后一步；或选择最后一步，然后按住 Shift 键并单击第一步。

    播放的是被选中的步骤（高亮显示），而不一定是滑块当前指示的步骤。

    注意

    虽然可以选择一系列包括黑色的鼠标移动指示线的步骤，但重放这些步骤时会跳过该鼠标移动。
  2. 单击“重放”。

    步骤随即按顺序重放，并且“历史记录”面板中出现一个新步骤（“重放步骤”）。

若要重复不相邻的步骤，请执行以下操作：

  1. 选择一个步骤，然后按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 并单击其他步骤。

    也可以按住 Ctrl 键或 Command 键并单击以取消选择所选步骤。

  2. 单击“重放”。

    所选步骤随即按顺序重放，并且“历史记录”面板中出现一个标记为“重放步骤”的新步骤。

相关主题

  • 将步骤应用于另一个对象
  • 将步骤应用于多个对象


将步骤应用于另一个对象

可以将“历史记录”面板中的一系列步骤应用于“文档”窗口中的任何对象。

若要将“历史记录”面板步骤应用于新对象，请执行以下操作：

  1. 选择对象。
  2. 在“历史记录”面板中选择相关步骤，然后单击“重放”。


将步骤应用于多个对象

如果选择文档中的多个对象然后从“历史记录”面板中将步骤应用于这些对象，则它们被看成是单个选择，并且 Dreamweaver 尝试将步骤应用于这个组合选择。

例如，不能选择五个图像并同时对它们中的每一个应用相同的大小更改。大小更改操作必须对单独的图像逐个应用，而不能对图像组合应用。

若要将一系列步骤应用于一组对象中的每一个对象，必须使这些步骤中的最后一步选择对象组中的下一个对象。下列过程说明了此原则在具体情况下的应用：设置一系列图像的垂直和水平间距。

若要设置一系列图像的垂直和水平间距，请执行以下操作：

  1. 从一个文档开始，其中的每一行由一个后跟文本的小图像（如图形项目符号或图标）组成。目的是设置图像同文本以及它上方和下方的其他图像分开。

  2. 如果“属性”检查器尚未打开，请打开“属性”检查器（“窗口”>“属性”）。
  3. 选择第一个图像。
  4. 在“属性”检查器中的“垂直边距”和“水平边距”文本框中输入数字以设置图像的间距。
  5. 再次单击图像，使“文档”窗口激活但不移动插入点。
  6. 按左箭头键将插入点移到图像左侧。然后按下箭头键将插入点向下移动一行，使其正好位于系列中的第二个图像的左侧。然后按 Shift 和右箭头键选择第二个图像。

    注意

    不要通过单击图像来选择它，否则您将无法重放所有步骤。
  7. 在“历史记录”面板中，选择对应于更改图像间距的步骤，然后选择下一个图像。单击“重放”按钮重放这些步骤。

    当前图像的间距随即改变并选定下一个图像。

  8. 继续单击“重放”直到所有图像的间距正确为止。

若要将步骤应用于另一个文档中的对象，请使用“复制步骤”按钮。（请参见在文档间复制和粘贴步骤。）


在文档间复制和粘贴步骤

每一个打开的文档都有自己的步骤历史记录。可以复制一个文档中的步骤并将其粘贴到另一个文档中。

关闭文档时将清除历史记录。如果您打算在关闭文档后要使用该文档中的步骤，则在关闭文档前请用“复制步骤”复制这些步骤（或将这些步骤另存为命令；请参见用历史步骤创建新命令）。

若要在另一个文档中重新使用一个文档中的步骤，请执行以下操作：

  1. 从包含要重新使用的步骤的文档开始。
  2. 在“历史记录”面板中选择步骤。
  3. 单击“历史记录”面板的“复制步骤”按钮复制这些步骤。 这是所描述的功能的图片。

    注意

    “复制步骤”（“历史记录”面板中的一个按钮）与“复制”（“编辑”菜单中）是不同的。不能使用“编辑”>“复制”复制步骤，尽管确实可以使用“编辑”>“粘贴”粘贴它们。

    复制包括“复制”或“粘贴”命令的步骤时要注意：

    • 如果步骤中有一个是“复制”命令，则不要使用“复制步骤”命令；因为可能无法按您希望的方式粘贴这些步骤。
    • 如果步骤中包括一个“粘贴”命令，则不能粘贴这些步骤，除非步骤中的“粘贴”命令前还有一个“复制”命令。
  4. 打开另一个文档。
  5. 将插入点放入所需位置，或选择一个应用步骤的对象。
  6. 选择“编辑”>“粘贴”粘贴步骤。

    步骤会在粘贴到文档的“历史记录”面板时重放。“历史记录”面板以一个名为“粘贴步骤”的步骤显示它们。

    如果将步骤粘贴到文本编辑器或“代码”视图或代码检查器中，则它们以 JavaScript 代码的形式出现。这对于您学习编写自己的脚本很有用。有关在 Dreamweaver 中使用 JavaScript 的更多信息，请参见编写和编辑代码。


用历史步骤创建新命令

可以将一组历史步骤保存为一个命名命令，然后这个命令会成为“命令”菜单中的可用命令。

如果以后有可能再次使用特定的一系列步骤，尤其是希望在下次启动 Dreamweaver 时再次使用那些步骤，请创建并保存一个新命令。保存的命令会永久保留（除非删除它们）；而录制的命令将在您退出 Dreamweaver 时被丢弃，复制的步骤序列会在您复制其他内容时被丢弃。（有关录制的命令的更多信息，请参见录制命令。）

您可以编辑放入“命令”菜单中的命令名称，也可将它们从“命令”菜单中删除。编辑和删除“命令”菜单中内置的命令（即不是您明确添加的命令）更为复杂。

若要创建命令，请执行以下操作：

  1. 在“历史记录”面板中选择一个步骤或一系列步骤。
  2. 单击“保存为命令”按钮，或从“历史记录”面板的上下文菜单中选择“另存为命令”。
  3. 输入命令的名称并单击“确定”。

    该命令随即出现在“命令”菜单中。

    注意

    在 Dreamweaver/Configuration/Commands 文件夹中，该命令保存为 JavaScript 文件（有时为 HTML 文件）。如果您是在多用户操作系统上使用 Dreamweaver，该文件将保存在特定用户的 Commands 文件夹中。

若要使用保存的命令，请执行以下操作：

  1. 选择一个应用命令的对象，或将插入点放在所需的位置。
  2. 从“命令”菜单中选择命令。

若要在“命令”菜单中编辑命令的名称，请执行以下操作：

  1. 选择“命令”>“编辑命令列表”。
  2. 选择命令重命名并输入该命令的新名称。
  3. 单击“关闭”。

若要从“命令”菜单中删除名称，请执行以下操作：

  1. 选择“命令”>“编辑命令列表”。
  2. 选择命令。
  3. 单击“删除”，然后单击“关闭”。


录制命令

可以录制一个短期使用的临时命令。Dreamweaver 一次仅保留一个录制的命令；一旦开始录制新命令，旧命令就会丢失。

若要保存新命令但不丢失已录制的命令，请从“历史记录”面板中保存命令。（有关更多信息，请参见用历史步骤创建新命令。）有关“使用录制的命令与从‘历史记录’面板重放步骤”之比较的更多信息，请参见使用“历史记录”面板。

若要暂时录制一系列经常使用的步骤，请执行以下操作：

  1. 选择“命令”>“开始录制”，或按 Ctrl+Shift+X (Windows) 或 Command+Shift+X (Macintosh)。

    指针会发生变化，表明您正在录制命令。

  2. 完成录制后，选择“命令”>“停止录制”，或按 Ctrl+Shift+X (Windows) 或 Command+Shift+X (Macintosh)。

若要重放录制的命令，请执行以下操作：

  • 选择“命令”>“播放录制命令”，或按 Ctrl+Shift+R (Windows) 或 Command+Shift+R (Macintosh)。

若要保存录制的命令，请执行以下操作：

  1. 选择“命令”>“播放录制命令”重放命令。

    “历史记录”面板的步骤列表中会出现一个名为“运行命令”的步骤。

  2. 选择“运行命令”步骤并单击“保存为命令”按钮。
  3. 输入命令的名称并单击“确定”。

    该命令随即出现在“命令”菜单中。


使用 JavaScript 行为检测浏览器和插件

可以使用行为来确定访问者所使用的浏览器，以及他们是否安装有某个特定插件。有关行为的更多信息，请参见使用 JavaScript 行为。

检查浏览器根据访问者浏览器的类型和版本，引导他们前往不同的页面（请参见检查浏览器）。例如，您可能希望这样：如果访问者使用 Netscape Navigator 4.0 或更高版本，则使他们前往某一个页面；如果访问者使用 Microsoft Internet Explorer 4.0 或更高版本，则使他们前往另一个页面；如果访问者使用任何其他种类的浏览器，则使他们停留在当前页面。

检查插件根据访问者是否安装有指定插件，引导他们前往不同的页面（请参见检查插件）。例如，您可能希望这样：如果访问者有 Macromedia Shockwave，则使他们前往某一页面；而如果没有，则使他们前往另一个页面。


在浏览器中预览和测试页面

可以随时在浏览器中预览文档，而不必先保存文档或将文档上传到 Web 服务器。

本节包含以下主题：

  • 在浏览器中预览
  • 设置预览首选参数
  • 在 Internet Explorer (Windows) 中预览活动内容


在浏览器中预览

可以使用 Dreamweaver 在浏览器中预览和测试文档。

若要在浏览器中预览和测试您的文档，请执行以下操作：

  1. 执行以下操作之一以预览页面：
    • 选择“文件”>“在浏览器中预览”，然后选择一个列出的浏览器。

      注意

      如果您尚未选择浏览器，请选择“编辑”>首选参数”，或者选择“Dreamweaver”>“首选参数”(Macintosh)，然后选择左边的“在浏览器中预览”类别，以选择一个浏览器。（请参见设置“在浏览器中预览”首选参数选项。）
    • 按 F12 (Windows) 键或 Option+F12 (Macintosh) 键在主浏览器中显示当前文档。
    • 按 Ctrl+F12（在 Windows 中）或 Command+F12（在 Macintosh 中）可在候选浏览器中显示当前文档。
  2. 单击链接然后测试页面内容。

    在大多数情况下，如果您的浏览器已安装了必需的插件或 ActiveX 控件，则与浏览器相关的所有功能（包括 JavaScript 行为、文档相对链接和绝对链接、ActiveX 控件和 Netscape Navigator 插件）都会起作用。

    如果在安装有 Service Pack 2 的 Windows XP 计算机上使用 Internet Explorer，则浏览器会显示一条消息告诉您已限制文件显示活动内容。可以通过在文件中包括 Web 标记代码来解决此问题。有关更多信息，请参见在 Internet Explorer (Windows) 中预览活动内容。

    注意

    使用本地浏览器预览文档时，除非指定了测试服务器，或在“编辑”>“首选参数”>“在浏览器中预览”中选择“使用临时文件预览”选项，否则文档中用站点根目录相对路径链接的内容将不会被显示。这是因为浏览器不识别站点根目录，而服务器能够识别。

    提示

    若要预览用根目录相对路径所链接的内容，请将文件上传到远程服务器上，然后选择“文件”>“在浏览器中预览”查看它（请参见站点根目录相对路径）。
  3. 完成测试后请在浏览器中关闭该页面。


设置预览首选参数

最多可定义 20 个用于预览的浏览器。最好在下列浏览器中进行预览：Internet Explorer 6.0、Netscape Navigator 7.0 和仅用于 Macintosh 的 Safari 浏览器。除了这些比较流行的图形化浏览器之外，您可能想使用只显示文本的浏览器如 Lynx 测试您的页面。

若要设置或更改主浏览器或候选浏览器的首选参数，请执行以下操作：

  1. 选择下列方法之一打开“在浏览器中预览”选项：
    • 选择“编辑”>“首选参数”(Windows) 或者“Dreamweaver”>“首选参数”(Macintosh)，然后从左边的类别列表中选择“在浏览器中预览”。
    • 选择“文件”>“在浏览器中预览”>“编辑浏览器列表”。

    出现带有“在浏览器中预览”选项的“首选参数”对话框。

  2. 按需要进行更改。

    有关更多信息，请参见设置“在浏览器中预览”首选参数选项。

  3. 单击“确定”。


在 Internet Explorer (Windows) 中预览活动内容

如果在安装了 Windows XP Service Pack 2 更新后，在 Internet Explorer 中预览包含活动内容的文档，浏览器可能无法正确显示文档。浏览器将显示一条消息告诉您已限制文件显示活动内容。可以通过在文档中插入 Web 标记代码来解决此问题。

Internet Explorer 阻止尝试在本地计算机区域中运行的活动内容和脚本。因为攻击者会尝试利用本地计算机区域，所以 Microsoft 对默认情况下可以在此区域中运行的内容增加了限制。Web 标记代码将告知浏览器在其他区域（在本例中为 Internet 区域）中运行活动内容。

若要在 Windows XP SP2 上，在 Internet Explorer 中预览活动内容，请执行以下操作：

  • 在 Dreamweaver 中打开文档，然后选择“命令”>“插入 Web 标记”。

    Dreamweaver 将在代码中插入以下行：

    <!-- saved from url=(0014)about:internet -->

    该行告诉浏览器绕过本地计算机区域，在 Internet 区域中运行活动内容。

还可以在使某文件处于活动状态之前，删除 Web 标记代码。

若要删除 Web 标记代码，请执行以下操作：

  1. 在 Dreamweaver 中，打开包含 Web 标记代码的文档。
  2. 选择“命令”>“删除 Web 标记”。

有关更多信息，请参见 Macromedia Web 站点上的 TechNote 19578，网址为 www.macromedia.com/go/19578。


设置下载时间和大小首选参数

Dreamweaver 根据页面的全部内容（包括所有的链接对象，例如图像和插件）来计算大小。Dreamweaver 根据“状态栏”首选参数中输入的连接速度估计下载时间。实际下载时间因一般的 Internet 条件不同而有所不同。

提示

检查某一特定网页的下载时间时，一个不错的标准是“8 秒钟原则”。即，大多数用户等待载入一个页面的时间不会超过 8 秒钟。

若要设置下载时间和下载页面大小首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或Dreamweaver>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从位于左侧的“类别”列表中选择“状态栏”。

    即显示“状态栏”首选参数选项。

  3. 选择用于计算下载时间的连接速度。

    在美国的平均连接速度是 28.8。如果是为 Intranet 设计页面，可能要选择 1500（T1 速度）。

    有关状态栏首选参数的更多信息，请参见设置“状态栏”首选参数。

  4. 单击“确定”。


参考资料

本节提供在本章中介绍的下列对话框的有关信息：

  • 设置“页面属性”（“文档类型”）对话框选项
  • 设置“标题/编码页面属性”选项
  • 设置“HTML 外观页面属性”选项
  • 设置“CSS 外观页面属性”选项
  • 设置“CSS 链接页面属性”选项
  • 设置“CSS 标题页面属性”选项
  • 设置“跟踪图像页面属性”选项
  • 设置“不可见元素”首选参数
  • 设置“在浏览器中预览”首选参数选项


设置“页面属性”（“文档类型”）对话框选项

该对话框用于在没有对文档做任何指定时选择文档类型。它可以使您指定特定于用于创作 Web 页面的语言的文档编码类型。还可以指定与该编码类型一起使用哪种 Unicode 标准化表单。

文档类型 (DTD) 指定文档类型定义。例如，可从弹出式菜单中选择“XHTML 1.0 Transitional”或“XHTML 1.0 Strict”，使 HTML 文档与 XHTML 兼容。有关更多信息，请参见关于由 Dreamweaver 生成的 XHTML 代码。

文档编码指定文档中字符所用的编码。有关文档编码的更多信息，请参见了解文档编码。

如果选择 Unicode (UTF-8) 作为文档编码，则不需要实体编码，因为 UTF-8 可以安全地表示所有字符。如果选择其他文档编码，则可能需要用实体编码来表示某些字符。有关字符实体的更多信息，请参见 www.w3.org/TR/REC-html40/sgml/entities.html。

Unicode 标准化表单仅在选择 UTF-8 作为文档编码时启用。有四种 Unicode 标准化表单。最重要的是标准化表单 C，因为它是用于万维网的字符模型的最常用表单。Macromedia 提供其他三种 Unicode 标准化表单作为补充。

在 Unicode 中，有些字符看上去很相似，但可用不同的方法存储在文档中。例如，“ë”（e 变音符）可表示为单个字符“e 变音符”，或两个字符“正常拉丁语 e”+“组合变音符”。Unicode 组合字符是与前一个字符结合使用的字符，因此变音符会显示在“拉丁语 e”的上方。这两种形式都显示为相同的印刷样式，但保存在文件中的每种形式是不同的。

标准化是指确保可用不同形式保存的所有字符都使用相同的形式进行保存的过程。即，文档中所有“ë”字符都保存为单个“e 变音符”或“e”+“组合变音符”，而不是在一个文档中保存为这两种形式。

有关 Unicode 标准化和可以使用的特定表单的更多信息，请参见 Unicode Web 站点，网址是 www.unicode.org/reports/tr15。

包括 Unicode 签名 (BOM) 可在文档中包括字节顺序标记 (BOM)。BOM 是位于文本文件开头的 2 到 4 个字节，可将文件标识为 Unicode，如果是这样，还标识后面字节的字节顺序。由于 UTF-8 没有字节顺序，因此可以选择添加 UTF-8 BOM。对于 UTF-16 和 UTF-32，这是必需的。

重新载入使您能够使用新的编码类型重新打开现有文档。


设置“标题/编码页面属性”选项

“标题/编码页面属性”类别可指定特定于制作 Web 页面时所用语言的文档编码类型，以及指定要用于该编码类型的 Unicode 标准化表单。

标题指定在“文档”窗口和大多数浏览器窗口的标题栏中出现的页面标题。请参见更改文档标题。

文档类型 (DTD) 指定文档类型定义。例如，可从弹出式菜单中选择“XHTML 1.0 Transitional”或“XHTML 1.0 Strict”，使 HTML 文档与 XHTML 兼容。有关更多信息，请参见关于由 Dreamweaver 生成的 XHTML 代码。

编码指定文档中字符所用的编码。有关文档编码的更多信息，请参见了解文档编码。

Unicode 标准化表单仅在选择 UTF-8 作为文档编码时启用。有四种 Unicode 标准化表单。最重要的是标准化表单 C，因为它是用于万维网的字符模型的最常用表单。Macromedia 提供其他三种 Unicode 标准化表单作为补充。

在 Unicode 中，有些字符看上去很相似，但可用不同的方法存储在文档中。例如，“ë”（e 变音符）可表示为单个字符“e 变音符”，或两个字符“正常拉丁语 e”+“组合变音符”。Unicode 组合字符是与前一个字符结合使用的字符，因此变音符会显示在“拉丁语 e”的上方。这两种形式都显示为相同的印刷样式，但保存在文件中的每种形式是不同的。

标准化是指确保可用不同形式保存的所有字符都使用相同的形式进行保存的过程。即，文档中所有“ë”字符都保存为单个“e 变音符”或“e”+“组合变音符”，而不是在一个文档中保存为这两种形式。

有关 Unicode 标准化和可以使用的特定表单的更多信息，请参见 Unicode Web 站点，网址是 www.unicode.org/reports/tr15。

包括 Unicode 签名 (BOM) 可在文档中包括字节顺序标记 (BOM)。BOM 是位于文本文件开头的 2 到 4 个字节，可将文件标识为 Unicode，如果是这样，还标识后面字节的字节顺序。由于 UTF-8 没有字节顺序，因此可以选择添加 UTF-8 BOM。对于 UTF-16 和 UTF-32，这是必需的。


设置“HTML 外观页面属性”选项

“HTML 外观页面属性”类别让您为 Web 页面指定多种基本页面布局选项：

背景图像和背景为页面指定背景图像和背景颜色。请参见设置背景图像或背景页面颜色。

文本和链接为文本、链接、访问过的链接和活动链接定义默认颜色（请参见使用颜色）。也可以使用 CSS 样式表来控制这些颜色（请参见应用类样式）。

左边距和顶部边距指定 body 标签中的页边距大小，仅适用于 Microsoft Internet Explorer。Netscape Navigator 忽略这些值，而是使用“边距宽度”和“边距高度”。若要获得最好的跨浏览器效果，请为两个浏览器（而不只是一个浏览器）都提供边距值，并填写四个边距值而不只是填写两个。要确保在任何一个浏览器中都不出现边距，请将四个值都设置为 0。Dreamweaver 在“文档”窗口中不显示页边距；若要查看边距，请使用“在浏览器中预览”。

边距宽度和边距高度指定 body 标签中的页边距大小，仅适用于 Netscape Navigator。Internet Explorer 忽略这些值，而是使用“左边距”和“顶部边距”。若要获得最好的跨浏览器效果，请为两个浏览器（而不只是一个浏览器）都提供边距值，并填写四个边距值而不只是填写两个。要确保在任何一个浏览器中都不出现边距，请将四个值都设置为 0。Dreamweaver 在“文档”窗口中不显示页边距；若要查看边距，请使用“在浏览器中预览”。

相关主题

  • 关于设置页面属性
  • 指定 HTML 而不是 CSS


设置“CSS 外观页面属性”选项

“CSS 外观页面属性”类别让您为 Web 页指定多种基本页面布局选项：

字体指定在 Web 页面中使用的默认字体家族。Dreamweaver 将使用您指定的字体家族，除非已为某一文本元素专门指定了另一种字体。

大小指定在 Web 页面中使用的默认字体大小。Dreamweaver 将使用您指定的字体大小，除非已为某一文本元素专门指定了另一种字体大小。

文本颜色指定显示字体的默认颜色。

背景颜色指定页面使用的背景颜色。

背景图像指定页面的背景图像。请参见设置背景图像或背景页面颜色。

重复指定背景图像在页面上的显示方式：

  • 选择非重复选项将仅显示背景图像一次。
  • 选择“重复”选项横向和纵向重复或平铺图像。
  • 选择“横向重复”选项横向平铺图像。
  • 选择“纵向重复”选项纵向平铺图像。

左边距和右边距指定左右页边距的大小。

上边距和下边距指定上下页边距的大小。

相关主题

  • 关于设置页面属性
  • 指定 HTML 而不是 CSS


设置“CSS 链接页面属性”选项

“CSS 链接页面属性”类别让您定义默认的字体、字体大小，以及链接、访问过的链接和活动链接的颜色：

字体指定链接文本使用的默认字体家族。默认情况下，Dreamweaver 使用为整个页面指定的字体家族（除非您指定了另一种字体）。

大小指定链接文本使用的默认的字体大小。

链接颜色指定应用于链接文本的颜色。

已访问链接的颜色指定应用于访问过的链接的颜色。

鼠标经过时链接的颜色指定当鼠标（或指针）位于链接上时应用的颜色。

活动链接的颜色指定当鼠标（或指针）在链接上单击时应用的颜色。

下划线样式指定了应用于链接的下划线样式。

如果页面已经定义（例如通过外部的 CSS 样式表）了下划线链接样式，“下划线样式”弹出式菜单默认为“不更改”选项。该选项警告您链接样式已经被定义的事实，您可能不想改变下划线链接样式。如果您使用“页面属性”对话框修改了下划线链接样式，Dreamweaver 将会更改以前的链接定义。

相关主题

  • 关于设置页面属性
  • 指定 HTML 而不是 CSS


设置“CSS 标题页面属性”选项

“CSS 标题”类别让您指定 CSS 页中的标题使用的字体家族和字体大小：

字体指定在 Web 页面中使用的默认字体家族。Dreamweaver 将使用您指定的字体家族，除非已为某一文本元素专门指定了另一种字体。

标题 1 至标题 6 指定最多六种标题标签使用的字体大小和颜色。

相关主题

  • 关于设置页面属性
  • 指定 HTML 而不是 CSS


设置“跟踪图像页面属性”选项

“跟踪图像”类别让您在设计页面时插入用作参考的图像文件：

跟踪图像指定在复制设计时作为参考的图像。该图像只供参考，当文档在浏览器中显示时并不出现。

透明度确定跟踪图像的不透明度，从完全透明到完全不透明。

相关主题

  • 关于设置页面属性
  • 指定 HTML 而不是 CSS


设置“不可见元素”首选参数

使用“不可见元素”首选参数可以指定当选择“查看”>“可视化助理”>“不可见元素”时可见的元素种类。

若要更改“不可见元素”首选参数，请执行以下操作：

  • 选择哪些元素应设置为可见，然后单击“确定”。

下面是可以显示或隐藏其标记的不可见元素：

命名锚记显示标记文档中的每个命名锚记 (a name = "") 位置的图标。

脚本显示用来标记文档正文中的 JavaScript 或 VBScript 代码位置的图标。选择该图标可在“属性”检查器中编辑脚本或链接到外部脚本文件。

注释显示用来标记 HTML 注释位置的图标。选择该图标可在“属性”检查器中查看注释。

换行符显示用来标记每个换行符 (BR) 位置的图标。默认情况下取消选择该选项。

客户端图像地图显示用来标记文档中每个客户端图像地图的位置的图标。

嵌入样式显示用来标记文档正文中嵌入的 CSS 样式的位置的图标。如果 CSS 样式放置在文档的 head 部分，则它们不出现在“文档”窗口中。

表单隐藏区域显示标记 type 属性设置为“隐藏”的表单域位置的图标。

表单范围在表单周围显示一个边框，以便您可以看到插入表单元素的位置。该边框显示 form 标签的范围，因此该边框内的任何表单元素都正确地包括在 form 标签中。

层锚记显示用来标记定义层的代码的位置的图标。层本身可以在页面中的任何位置。（层不是不可见元素，只有定义层的代码才是不可见的。）选择该图标可选择层；这样即使层标记为隐藏，还是可以看见层中的内容。

对齐元素锚记显示标记接受对齐属性的元素的 HTML 代码位置的图标。包括图像、表格、ActiveX 对象、插件和小应用程序。在有些情况下，元素的代码可能与可见对象分开。

可视化服务器标签和非可视化服务器标签显示其内容不能在“文档”窗口中显示的服务器标签（如 Active Server Pages 标签和 ColdFusion 标签）的位置。

相关主题

  • 显示和隐藏不可见元素


设置“在浏览器中预览”首选参数选项

此对话框用于为“在浏览器中预览”类别设置用户首选参数。此对话框显示当前定义的主浏览器和候选浏览器以及它们的设置。

若要设置浏览器预览的首选参数，请执行以下操作：

  1. 若要向列表添加浏览器，请单击加号 (+) 按钮，完成“添加浏览器”对话框，然后单击“确定”。

    新浏览器的名称出现在列表中。

  2. 若要从列表中删除浏览器，请选择要删除的浏览器，然后单击减号 (-) 按钮。

    浏览器名称从列表中消失。

  3. 若要更改选定浏览器的设置，请单击“编辑”按钮，在“编辑浏览器”对话框中进行更改，然后单击“确定”。
  4. 选择“主浏览器”或“候选浏览器”选项，可指定所选浏览器是主浏览器还是候选浏览器。

    F12 (Windows) 或 Option+F12 (Macintosh) 将打开主浏览器，Control+F12 (Windows) 或 Command+F12 (Macintosh) 将打开侯选浏览器。

  5. 选择“用临时文件预览”选项，可为预览和服务器调试创建临时副本。

    如果要直接更新文档，可撤销对此选项的选择。

相关主题

  • 在浏览器中预览和测试页面


插入文本和设置文本格式

Macromedia Dreamweaver 8 提供了多种向文档中添加文本和设置文本格式的方法。您可以插入文本、设置字体类型、大小、颜色和对齐属性，以及使用层叠样式表 (CSS) 创建和应用您自己的自定义样式。

本章包含以下主题：

关于 Dreamweaver

插入文本

设置段落格式和文档结构

设置文本格式

使用层叠样式表设置文本格式

检查拼写

搜索和替换文本


关于 Dreamweaver

Dreamweaver 提供了多个工具和命令，使您可以使用 CSS 或 HTML 设置文本格式。

本节包含以下主题：

  • 关于插入文本
  • 关于设置文本格式
  • 了解层叠样式表
  • 关于冲突的 CSS 规则
  • 速记 CSS 属性
  • 属性检查器和文本格式设置
  • 关于“CSS 样式”面板


关于插入文本

Dreamweaver 允许您通过以下方式向 Web 页面添加文本：直接将文本键入页面，从其他文档复制和粘贴文本，或从其他应用程序拖放文本。Web 专业人员接收的、包含需要合并到 Web 页面的文本内容的典型文档类型有 ASCII 文本文件、RTF 文件和 Microsoft Office 文档。Dreamweaver 使您可以从这些文档类型中的任何一种取出文本，然后将文本并入 Web 页面中。

相关主题

  • 插入文本
  • 将文本添加到文档中
  • 导入表格式数据文档
  • 导入 Microsoft Office 文档（仅限 Windows）


关于设置文本格式

Dreamweaver 中的文本格式设置与使用标准字处理程序类似。您可以为文本块设置默认格式设置样式（段落、标题 1、标题 2 等）、更改所选文本的字体、大小、颜色和对齐方式，或者应用文本样式（如粗体、斜体、代码（等宽字体）和下划线）。

默认情况下，Dreamweaver 使用层叠样式表 (CSS) 设置文本格式。CSS 使 Web 设计人员和开发人员能更好地控制 Web 页设计，同时改进功能以提供辅助功能并减小文件大小。当您使用 Dreamweaver 的格式设置命令设置文本格式和对齐文本时，CSS 规则将嵌入到当前文档中。这使您可以更轻松地重用现有样式，以及命名您创建的样式。CSS 正逐渐成为设置文本格式和 Web 页面布局的首选方法。

如果愿意，您可以使用 HTML 标记标签在 Web 页面中设置文本格式和对齐方式。如果需要使用 HTML 标签而不是 CSS，则必须更改 Dreamweaver 的默认文本格式设置首选参数。（有关更多信息，请参见指定 HTML 而不是 CSS。）

使用 CSS 是一种能控制 Web 页面样式而不损坏其结构的方式。通过将可视化设计元素（字体、颜色、边距等）与 Web 页面的结构逻辑分离，CSS 为 Web 设计人员提供了可视化控制和版式控制，而不牺牲内容的完整性。此外，在单独的代码块中定义版式设计和页面布局 － 无需对图像地图、font 标签、表格和 GIF 间隔图像重新排序 － 从而加快下载速度，简化站点维护，并能集中控制多个 Web 页面的设计属性。

CSS 为特定类中的所有文本定义格式设置，或者为特定 HTML 标签（如 h1、h2、p 或 li）重新定义格式设置。

您可以将使用 CSS 创建的样式直接存储在文档中（当您使用属性检查器设置文本格式时，这是默认设置），如果要获得更多功能和灵活性，也可以将样式存储在外部样式表中。如果将某一外部样式表附加到多个 Web 页面，则所有这些页面都会自动反映对该样式表所做的任何更改。若要访问页面的所有 CSS 规则，请使用“CSS 样式”面板（“窗口”>“CSS 样式”）。

有关如何使用文本属性检查器应用 HTML 或 CSS 的更多信息，请参见“使用 Dreamweaver 帮助”中的设置文本属性选项。有关使用“CSS 样式”面板应用样式的更多信息，请参见“使用 Dreamweaver 帮助”中的使用“CSS 样式”面板。

注意

您可以在同一页面中组合使用 CSS 和 HTML 3.2 格式。格式按不同的等级应用：HTML 3.2 格式将覆盖外部 CSS 样式表所应用的格式，而嵌入在文档中的 CSS 将覆盖外部 CSS 样式。有关更多信息，请参见使用层叠样式表设置文本格式。

相关主题

  • 插入文本
  • 设置文本格式


了解层叠样式表

层叠样式表 (CSS) 是一系列格式设置规则，它们控制 Web 页面内容的外观。使用 CSS 设置页面格式时，请将内容与表现形式分开。页面内容（即 HTML 代码）驻留在 HTML 文件自身中，而用于定义代码表现形式的 CSS 规则驻留在另一个文件（外部样式表）或 HTML 文档的另一部分（通常为文件头部分）中。使用 CSS 可以非常灵活并更好地控制具体的页面外观，从精确的布局定位到特定的字体和样式。

CSS 允许您控制 HTML 无法独自控制的许多属性。例如，可以为选定的文本指定不同的字体大小和单位（像素、磅值等）。通过使用 CSS 以像素为单位设置字体大小，还可以确保在多个浏览器中以更一致的方式处理页面布局和外观。

除设置文本格式外，还可以使用 CSS 控制 Web 页面中块级别元素的格式和定位。例如，可以设置块级元素的边距和边框、其他文本周围的浮动文本等。

CSS 格式设置规则由两部分组成：选择器和声明。选择器是标识格式元素的术语（如 P、H1、类名或 ID），声明用于定义元素样式。在下面的示例中，H1 是选择器，介于括号 ({}) 之间的所有内容都是声明：

H1 {

font-size:16 pixels;
font-family:Helvetica;
font-weight:bold;

}

声明由两部分组成：属性（如 font-family）和值（如 Helvetica）。上面的 CSS 规则为 H1 标签创建了一个特定的样式：链接到此样式的所有 H1 标签的文本都将是 16 个像素大小、Helvetica 字体和粗体。

术语 cascading 表示向同一个元素应用多种样式的能力。例如，可以创建一个 CSS 规则来应用颜色，创建另一个 CSS 规则来应用边距，然后将两者应用于页面上的同一个文本。所定义的样式向下“层叠”到您的 Web 页面上的元素，并最终创建您想要的设计。

CSS 的主要优点是它提供了便利的更新功能；更新一处的 CSS 规则时，使用该已定义样式的所有文档的格式都会自动更新为新样式。

在 Dreamweaver 中可以定义以下样式类型：

  • 自定义 CSS 规则（也称为类样式）使您可以将样式属性应用于任何文本范围或文本块。（请参见应用类样式。）
  • HTML 标签样式重定义特定标签（如 h1）的格式。创建或更改 h1 标签的 CSS 样式时，所有用 h1 标签设置了格式的文本都会立即更新。
  • CSS 选择器样式（高级样式）重新定义特定元素组合的格式设置，或重新定义 CSS 允许的其他选择器表单的格式设置（例如，每当 h2 标题出现在表格单元格内时都应用选择器 td h2）。高级样式还可以重新定义包含特定 id 属性的标签的格式设置（例如，#myStyle 定义的样式可应用于包含属性值对 id="myStyle" 的所有标签）。

CSS 规则可以位于以下位置：

外部 CSS 样式表是一系列存储在一个单独的外部 CSS (.css) 文件（并非 HTML 文件）中的 CSS 规则。利用文档文件头部分中的链接，该文件被链接到 Web 站点中的一个或多个页面。

内部（或嵌入式）CSS 样式表是一系列包含在 HTML 文档文件头部分的 style 标签内的 CSS 规则。

内联样式是在标签的特定实例中在整个 HTML 文档内定义的。

Dreamweaver 识别现有文档中定义的样式，只要这些样式符合 CSS 样式准则。

提示

若要显示 Dreamweaver 中包含的 O’Reilly CSS 参考指南，请选择“帮助”>“参考”，然后从“参考”面板的弹出式菜单中选择“O’Reilly CSS 参考”。

手动设置的 HTML 格式设置会覆盖通过 CSS 应用的格式设置。要使 CSS 规则能够控制段落格式，必须删除所有手动设置的 HTML 格式。

Dreamweaver 会呈现您在“文档”窗口中直接应用的大多数样式属性。您也可以在浏览器窗口中预览文档以查看样式的应用情况。有些 CSS 样式属性在 Microsoft Internet Explorer、Netscape Navigator、Opera 和 Apple Safari 中呈现的外观不相同，有些目前不受任何浏览器支持。


关于冲突的 CSS 规则

将两个或更多 CSS 规则应用于同一文本时，这些规则可能会发生冲突并产生意外的结果。浏览器按以下方式应用 CSS 规则：

  • 如果将两种规则应用于同一文本，浏览器显示这两种规则的所有属性，除非特定的属性发生冲突。例如，一种规则可能指定文本颜色为蓝色，而另一种规则可能指定文本颜色为红色。
  • 如果应用于同一文本的两种规则的属性发生冲突，则浏览器显示最里面的规则（离文本本身最近的规则）的属性。因此，如果外部样式表和内联样式同时影响文本元素，则应用内联样式。
  • 如果有直接冲突，则自定义 CSS 规则（使用 class 属性应用的规则）中的属性将覆盖 HTML 标签样式中的属性。

在下面的示例中，为 h1 定义的样式可以指定所有 h1 段落的字体、大小和颜色，但应用于该段落的自定义 CSS 规则 .Blue 将覆盖 h1 样式中的颜色设置。另一个自定义 CSS 规则 .Red 将覆盖 .Blue，因为它位于 .Blue 样式的内部。

<h1><span class="Blue">This paragraph is controlled by the .Blue custom style and h1
HTML tag style.<span class="Red">Except this sentence is controlled by the .Red style.</span>
Now we're back to the .Blue style.</span></h1>


速记 CSS 属性

CSS 规范允许使用称作速记 CSS 的简略语法创建样式。速记 CSS 使您可以用一个属性标签指定多个属性的值。例如，您可以使用 font 属性在一行语法中设置 font-style、font-variant、font-weight、font-size、line-height 和 font-family 属性。

使用速记 CSS 时需要注意的关键问题是速记 CSS 属性省略的值会被指定为属性的默认值。当两个或多个 CSS 规则指定给同一标签时，这可能会导致页面无法正确显示。

例如，下面显示的 H1 标签使用了普通的 CSS 语法。注意，font-variant、font-stretch、font-size-adjust 和 font-style 属性的值都被指定为它们的默认值。

H1 {

font-weight: bold;
font-size: 16pt;
line-height: 18pt;
font-family: Arial;
font-variant: normal;
font-style: normal;
font-stretch: normal;
font-size-adjust: none

}

下面用一个速记属性重写这一标签：

H1 { font: bold 16pt/18pt Arial }

使用速记符号编写时，会自动将省略的值指定为它们的默认值。因此，上述速记示例省略了 font-variant、font-style、font-stretch 和 font-size-adjust 标签。

如果您使用 CSS 语法的速记形式和普通形式在不只一个位置定义了样式（如在 HTML 页面中嵌入样式并从外部样式表中导入样式），一定要注意省略的属性可能会覆盖（或层叠）在其他位置明确设置的属性。

因此，Dreamweaver 默认情况下使用 CSS 符号的普通形式撰写语法。这样可以防止能够覆盖普通规则的速记规则所引起的潜在问题。在 Dreamweaver 中打开使用速记 CSS 符号编写代码的 Web 页面时，请注意 Dreamweaver 将使用普通形式创建新的 CSS 规则。通过更改“首选参数”对话框（在 Windows 中为“编辑”>“首选参数”；在 Macintosh 中为“Dreamweaver”>“首选参数”）中“CSS 样式”类别中的 CSS 编辑首选参数，您可以指定 Dreamweaver 创建和编辑 CSS 规则的方式。

注意

“CSS 样式”面板仅使用普通符号创建规则。如果您使用“CSS 样式”面板创建页面或 CSS 样式表，一定要知道对速记 CSS 规则进行手工编码可能会导致速记属性覆盖那些用普通形式创建的属性。因此，请使用普通的 CSS 符号创建您的样式。

相关主题

  • 关于冲突的 CSS 规则
  • 关于“CSS 样式”面板


属性检查器和文本格式设置

使用文本属性检查器可以设置当前所选文本的格式。使用属性检查器设置文本格式时，Dreamweaver 将跟踪您为每个文本元素指定的格式设置属性，并使用命名约定为每个元素指定一个标签：Style1、Style2、Style3、Stylen。如果为两个或更多文本元素指定相同的格式属性，Dreamweaver 将使用相同的标题标记这些元素，减少了不必要的样式名称。Dreamweaver 应用到一段给定文本正文的标签稍后即可使用“样式”弹出式菜单进行应用，使您可以在页面内生成一个样式库，然后只需选择页面中的文本元素，从“样式”弹出式菜单中选择一个样式，即可应用这些相同的样式。您可以使用更具有意义的标签重命名这些样式，例如 Heading1、Heading2、Body 和 TableBody。

“样式”弹出式菜单同时显示页面中样式的名称和样式属性的预览。预览中显示的属性有字体 (font-family)、字体大小、字体粗细、文本颜色和背景颜色。

相关主题

  • 设置段落格式
  • 设置和更改字体及样式
  • 重命名样式
  • 使用层叠样式表设置文本格式


关于“CSS 样式”面板

使用“CSS 样式”面板可以跟踪影响当前所选页面元素（“当前”模式）的 CSS 规则和属性，或影响整个文档的规则和属性（“所有”模式）。使用“CSS 样式”面板顶部的切换按钮可以在两种模式之间切换。使用“CSS 样式”面板还可以在“所有”和“当前”模式下修改 CSS 属性。

本节包含以下主题：

  • “当前”模式下的“CSS 样式”面板
  • “所有”模式下的“CSS 样式”面板


“当前”模式下的“CSS 样式”面板

在“当前”模式下，“CSS 样式”面板显示三个窗格：显示文档中当前所选内容的 CSS 属性的“所选内容的摘要”窗格，显示所选属性的位置（或所选标签的规则的层叠，具体取决于您的选择）的“规则”窗格，以及允许您编辑用于定义所选内容的规则的 CSS 属性的“属性”窗格。

可以通过拖动窗格间的边框来调整任何窗格大小。

“所选内容的摘要”窗格显示活动文档中当前所选项目的 CSS 属性的摘要。该摘要显示直接应用于所选内容的所有规则的属性。仅显示已设置的属性。

例如，下列规则创建一个类样式和一个标签（在此例中为段落）样式：

.foo{

color:green;
font-family: ‘Arial’;

}

P{

font-family: ‘serif’;
font-size:12px;

}

当您在“文档”窗口中选择带有类样式 .foo 的段落文本时，“所选内容的摘要”窗格将同时显示两个规则的相关属性，因为两个规则都应用于所选内容。在这种情况下，“所选内容的摘要”窗格将列出以下属性：

font-size:12px
font-family: ‘Arial’’
color:green

“所选内容的摘要”窗格按逐级细化的顺序排列属性。在上面的示例中，标签样式定义字体大小，类样式定义字体 (font-family) 和颜色。（类样式定义的字体 (font-family) 属性覆盖标签样式定义的字体 (font-family) 属性，因为类选择器比标签选择器更为具体。有关 CSS 具体程度的更多信息，请参见 www.w3.org/TR/CSS2/cascade.html。）

“规则”窗格根据您的选择显示两个不同视图：“关于”视图或“规则”视图。在“关于”视图（默认视图）中，此窗格显示定义所选 CSS 属性的规则的名称，以及包含该规则的文件的名称。在“规则”视图中，此窗格显示直接或间接应用于当前所选内容的所有规则的层叠（或层次结构）。（直接应用规则的标签显示在右列。）您可以通过单击“规则”窗格右上角的“显示信息”和“显示层叠”按钮在两种视图之间切换。

在“所选内容的摘要”窗格中选择某个属性时，定义规则的所有属性出现在“属性”窗格中。（如果选择了“规则”视图，则也会在“规则”窗格中选择定义规则。）例如，如果您有一个定义字体 (font-family)、字体大小和颜色的名为 .maintext 的规则，那么在“所选内容的摘要”窗格中选择其中任何属性都将在“属性”窗格中显示 .maintext 规则定义的所有属性，并在“规则”窗格中显示选定的 .maintext 规则。（此外，在“规则”窗格中选择任何规则都将在“属性”窗格中显示该规则的属性。）然后您可以使用“属性”窗格快速修改 CSS，而无论它是嵌入在当前文档中还是通过附加的样式表链接的。默认情况下，“属性”窗格仅显示那些先前已设置的属性，并按字母顺序排列它们。

您可以选择在其他两种视图中显示“属性”窗格。“类别”视图显示按类别分组的属性（如“字体”、“背景”、“区块”、“边框”等），已设置的属性位于每个类别的顶部，以蓝色文本显示。“列表”视图显示所有可用属性的按字母顺序排列的列表，同样，已设置的属性排在顶部，以蓝色文本显示。若要在视图之间切换，请单击“显示类别视图”、“显示列表视图”或“只显示设置属性”按钮，这些按钮位于“属性”窗格的左下角。

在所有视图中，已设置的属性以蓝色显示；与选择无关的属性显示时伴有一条红色删除线。将鼠标指针置于无关规则上方时将显示一条消息解释该属性为何无关。通常，某个属性无关的原因是其被覆盖或不是继承的属性。

对“属性”窗格所做的任何更改都将立即应用，这使您可以在操作的同时预览效果。

相关主题

  • “所有”模式下的“CSS 样式”面板
  • 使用“CSS 样式”面板


“所有”模式下的“CSS 样式”面板

在“所有”模式下，“CSS 样式”面板显示两个窗格：“所有规则”窗格（顶部）和“属性”窗格（底部）。“所有规则”窗格显示当前文档中定义的规则以及附加到当前文档的样式表中定义的所有规则的列表。使用“属性”窗格可以编辑“所有规则”窗格中任何所选规则的 CSS 属性。

可以通过拖动窗格间的边框调整任一窗格的大小。

当您在“所有规则”窗格中选择某个规则时，该规则中定义的所有属性都将出现在“属性”窗格中。然后您可以使用“属性”窗格快速修改 CSS，而无论它是嵌入在当前文档中还是通过附加的样式表链接的。默认情况下，“属性”窗格仅显示那些先前已设置的属性，并按字母顺序排列它们。

您可以选择在其他两种视图中显示属性。“类别”视图显示按类别分组的属性（如“字体”、“背景”、“区块”、“边框”等），已设置的属性位于每个类别的顶部。“列表”视图显示所有可用属性的按字母顺序排列的列表，同样，已设置的属性排在顶部。若要在视图之间切换，请单击“显示类别视图”、“显示列表视图”或“只显示设置属性”按钮，这些按钮位于“属性”窗格的左下角。在所有视图中，已设置的属性均以蓝色显示。

对“属性”窗格所做的任何更改都将立即应用，这使您可以在操作的同时预览效果。

相关主题

  • “当前”模式下的“CSS 样式”面板
  • 使用“CSS 样式”面板


插入文本

Dreamweaver 使您可以通过直接键入、复制和粘贴或导入方式轻松地将文本插入文档中。您还可以在文本的字符与行之间插入额外的空格。

相关主题

  • 将文本添加到文档中
  • 导入表格式数据文档
  • 导入 Microsoft Office 文档（仅限 Windows）
  • 设置段落格式和文档结构
  • 添加段落间距


将文本添加到文档中

若要向 Dreamweaver 文档添加文本，您可以直接在 Dreamweaver“文档”窗口中键入文本，也可以剪切并粘贴。您还可以从其他文档导入文本（请参见导入表格式数据文档和导入 Microsoft Office 文档（仅限 Windows））。

当您将文本粘贴到 Dreamweaver 文档中时，可以使用“粘贴”或“选择性粘贴”命令。“选择性粘贴”命令允许您以不同的方式指定所粘贴的文本的格式。例如，如果要将文本从带格式的 Microsoft Word 文档粘贴到 Dreamweaver 文档中，但是想要去掉所有格式设置，以便能够向所粘贴的文本应用自己的 CSS 样式表，您可以在 Word 中选择文本，将它复制到剪贴板，然后使用“选择性粘贴”命令选择只粘贴文本的选项。

此外，当使用“粘贴”命令从其他应用程序粘贴文本时，可以将粘贴首选参数设置为默认选项。有关更多信息，请参见设置复制/粘贴首选参数。

若要将文本添加到文档，请执行下列操作之一：

  • 直接在“文档”窗口中键入文本。
  • 从其他应用程序中复制文本，切换到 Dreamweaver，将插入点定位在“文档”窗口的“设计”视图中，然后选择“编辑”>“粘贴”或“编辑”>“选择性粘贴”。

    当您选择“编辑”>“选择性粘贴”时，将出现一个对话框为您提供几个粘贴格式设置选项。有关更多信息，请单击对话框上的“帮助”按钮。

    还可以使用下列快捷键粘贴文本：

    粘贴选项

    快捷键

    粘贴

    Ctrl+V (Windows)

    Command+V (Macintosh)

    选择性粘贴

    Ctrl+Shift+V (Windows)

    Command+Shift+V (Macintosh)

    注意

    Control+V (Windows) 和 Command+V (Macintosh) 在“代码”视图中始终仅粘贴文本（无格式设置）。


设置复制/粘贴首选参数

当使用“编辑”>“粘贴”从其他应用程序粘贴文本时，可以将选择性粘贴首选参数设置为默认选项。例如，如果始终想要将文本粘贴为纯文本或带有基本格式设置的文本，可以在“复制/粘贴首选参数”对话框中设置默认选项。

注意

“复制/粘贴首选参数”对话框中设置的首选参数仅应用于粘贴到“设计”视图中的内容。

若要设置复制和粘贴的默认选项，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)。
  2. 单击“复制/粘贴”类别。
  3. 完成对话框设置，然后单击“确定”。

    有关更多信息，请单击“帮助”按钮。


导入表格式数据文档

通过首先将文件（如 Microsoft Excel 文件或数据库文件）保存为分隔文本文件，可以将表格式数据导入到文档中。

有关导入表格数据和设置表格数据格式的信息，请参见导入和导出表格式数据。有关从 Microsoft Word HTML 文档导入文本的信息，请参见打开现有文档。

您还可以将文本从 Microsoft Excel 文档添加到 Dreamweaver 文档中，方法是将 Excel 文件的内容导入到 Web 页面中（请参见导入 Microsoft Office 文档（仅限 Windows））。

若要导入表格式数据，请执行以下操作：

  1. 选择“文件”>“导入”>“导入表格式数据”，或选择“插入”>“表格对象”>“导入表格式数据”。

    出现“导入表格”对话框。

  2. 浏览所需的文件或在文本框中输入所需文件的名称。
  3. 选择将文件保存为分隔文本时使用的分隔符。选项包括“制表符”、“逗号”、“分号”、“冒号”和“其他”。

    如果选择“其他”，则该选项旁边将出现一个空白字段。输入用作分隔符的字符。

  4. 使用其余的选项格式化或定义要向其中导入数据的表格。
  5. 单击“确定”。


导入 Microsoft Office 文档（仅限 Windows）

您可以将 Microsoft Word 或 Excel 文档的完整内容插入到新的或现有的 Web 页面中。导入 Word 或 Excel 文档时，Dreamweaver 接收已转换的 HTML 并将它插入到您的 Web 页面上。Dreamweaver 接收已转换的 HTML 后，文件大小必须小于 300K。

提示

您还可以粘贴部分 Word 文档内容并保留格式设置，而不是导入整个文件内容。有关更多信息，请参见将文本添加到文档中。

注意

如果使用 Microsoft Office 97，您将无法导入 Word 或 Excel 文档的内容，您必须插入指向该文档的链接。有关信息，请参见插入指向 Word 或 Excel 文档的链接。

若要将 Word 或 Excel 文档插入到新的或现有的 Web 页面中，请执行以下操作：

  1. 打开要插入 Word 或 Excel 文档的 Web 页面。
  2. 确保您处于“设计”视图中。如果不是，请单击“设计”视图按钮。
  3. 执行以下操作之一选择文件：
    • 将文件从当前位置拖放到要在其中显示内容的页面中。当“插入文档”对话框出现时，设置选项并单击“确定”。有关更多信息，请单击对话框上的“帮助”按钮。
    • 选择“文件”>“导入”>“Word 文档”或“文件”>“导入”>“Excel 文档”。在“导入文档”对话框中，浏览到要添加的文件，在对话框底部选择格式设置选项，然后单击“打开”。

      格式设置选项中包含如下选项：

      仅文本可以插入无格式文本。如果原始文本带格式，所有格式将被删除。

      带结构的文本可以插入文本并保留结构，但不保留基本格式设置。例如，您可以粘贴文本并保留段落、列表和表格的结构，但是不保留粗体、斜体和其他格式设置。

      带结构的文本以及基本格式可以插入结构化并带简单 HTML 格式的文本（例如，段落和表格以及带有 b、i、u、strong、em、hr、abbr 或 acronym 标签的格式化文本）。

      带结构的文本以及全部格式可以插入文本并保留所有结构、HTML 格式设置和 CSS 样式。

      如果选择了“带结构的文本”或“基本格式”，则粘贴文本时可以使用清理 Word 段落间距清除段落间的多余空格。

    Word 或 Excel 文档的内容即出现在页面中。

相关主题

  • 插入指向 Word 或 Excel 文档的链接


插入指向 Word 或 Excel 文档的链接

您可以将指向 Microsoft Word 或 Excel 文档的链接插入到现有页面中。

若要创建指向 Word 或 Excel 文档的链接，请执行以下操作：

  1. 打开要在其中显示链接的页面。
  2. 将文件从当前位置拖放到 Dreamweaver 页面中，随心所欲将链接放在任何位置。

    出现“插入文档”对话框。

  3. 选择“创建链接”，然后单击“确定”。
  4. 如果您正链接到的文档位于站点的根文件夹以外，Dreamweaver 将提示您将文档复制到站点根文件夹中。

    通过将文档复制到站点的根文件夹中，可以确保发布 Web 站点时该文档可用。

  5. 将页面上传到 Web 服务器时，请确保同时上传 Word 或 Excel 文件。

现在，页面包含指向 Word 或 Excel 文档的链接了。链接文本是链接文件的名称；若要更改链接文本，请参见管理链接。


设置段落格式和文档结构

Dreamweaver 支持页面格式设置和对象格式设置中使用的所有 Web 标准。本节介绍如何设置段落格式，以及如何插入水平线和日期。

相关主题

  • 设置页面属性
  • 设置段落格式
  • 对齐文本
  • 缩进文本
  • 添加段落间距
  • 使用水平线
  • 插入日期


设置段落格式

使用“属性”检查器中的“格式”弹出式菜单或“文本”>“段落格式”子菜单可以应用标准段落和标题标签。

若要应用段落或标题标签，请执行以下操作：

  1. 将插入点放在段落中，或者选择段落中的一些文本。
  2. 使用“文本”>“段落格式”子菜单或“属性”检查器中的“格式”弹出式菜单，选择一个选项：
    • 选择段落格式（例如，“标题 1”、“标题 2”、“已编排格式”等）。与所选样式关联的 HTML 标签（例如，表示“标题 1”的 h1、表示“标题 2”的 h2、表示“已编排格式”文本的 pre 等）即应用于整个段落。
    • 选择“无”删除段落格式。

对段落应用标题标签时，Dreamweaver 自动添加下一行文本作为标准段落。若要更改此设置，请选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)；然后在“常规”类别中的“编辑选项”下确保取消选择“标题后切换到普通段落”。

相关主题

  • 设置文本属性选项
  • 定义 CSS 类型属性


对齐文本

使用“属性”检查器或“文本”>“对齐”子菜单可以对齐页面上的文本。使用“文本”>“对齐”>“居中对齐”命令可以将页面元素居中对齐。

若要对齐文本，请执行以下操作：

  1. 选择要对齐的文本，或者只需将指针插入到文本开头。
  2. 单击“属性”检查器中的对齐选项（“左对齐”、“右对齐”或“居中对齐”），或者选择“文本”>“对齐”，然后选择对齐命令。

若要将元素居中对齐，请执行以下操作：

  1. 选择要居中对齐的元素（图像、插件、表格或其他页面元素）。
  2. 选择“文本”>“对齐”>“居中对齐”。

    注意

    可以对齐和居中对齐整个文本块；但不能对齐和居中对齐标题或段落的某一部分。


缩进文本

使用“缩进”命令可以将 blockquote HTML 标签应用于文本段落，缩进页面两侧的文本。

若要缩进文本和取消缩进，请执行以下操作：

  1. 将插入点放在要缩进的段落中。
  2. 单击“属性”检查器中的“缩进”或“凸出”按钮，选择“文本”>“缩进”或“凸出”，或从上下文菜单中选择“列表”>“缩进”或“凸出”。

    注意

    可以对段落应用多重缩进。每选择一次该命令，文本就从文档的两侧进一步缩进。


添加段落间距

Dreamweaver 的工作机制与许多字处理应用程序类似：按 Enter 键 (Windows) 或 Return 键 (Macintosh) 可以创建一个新段落。Web 浏览器在段落之间自动插入一个空白空格行。通过插入一个换行符，可以在段落之间添加一个空格行。

若要添加段落换行，请执行以下操作：

  • 按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

若要添加换行符，请执行下列操作之一：

  • 按 Shift+Enter 键 (Windows) 或 Shift+Return 键 (Macintosh)。
  • 在“插入”栏中的“文本”类别中，选择“字符”，然后单击“换行符”图标。
  • 选择“插入”>“HTML”>“特殊字符”>“换行符”。


使用水平线

水平线对于组织信息很有用。在页面上，可以使用一条或多条水平线以可视方式分隔文本和对象。

若要创建水平线，请执行以下操作：

  1. 在“文档”窗口中，将插入点放在要插入水平线的位置。
  2. 执行下列操作之一：
    • 选择“插入”>“HTML”>“水平线”。
    • 在“插入”栏的“HTML”类别中，单击“水平线”按钮。

若要修改水平线，请执行以下操作：

  1. 在“文档”窗口中，选择水平线。
  2. 选择“窗口”>“属性”打开“属性”检查器，然后根据需要对属性进行修改：

    宽和高以像素为单位或以页面尺寸百分比的形式指定水平线的宽度和高度。

    对齐指定水平线的对齐方式（“默认”、“左对齐”、“居中对齐”或“右对齐”）。仅当水平线的宽度小于浏览器窗口的宽度时，该设置才适用。

    阴影指定绘制水平线时是否带阴影。取消选择此选项将使用纯色绘制水平线。


创建项目列表和编号列表

在“文档”窗口中键入时，可以用现有文本或新文本创建编号（排序）列表、项目符号（不排序）列表和定义列表。

定义列表不使用项目符号点或数字这样的前导字符，通常用在词汇表或说明中。列表还可以嵌套。嵌套列表是包含其他列表的列表。例如，您可能希望编号或项目列表嵌套在其他编号列表中。

有关如何为整个列表或特定列表项设置特定列表类型和其他列表选项（例如，重置编号或在编号列表中使用罗马数字，或设置方形项目符号）的信息，请参见设置“列表属性”对话框选项。

若要创建新列表，请执行以下操作：

  1. 在 Dreamweaver 文档中，将插入点放在要添加列表的位置，然后执行下列操作之一：
    • 单击“属性”检查器中的“项目列表”或“编号列表”按钮
    • 选择“文本”>“列表”，然后选择所需的列表类型：“项目列表”、“编号列表”或“定义列表”。

    指定列表项目的前导字符出现在“文档”窗口中。

  2. 键入列表项目文本，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh) 创建其他列表项目。
  3. 若要完成列表，请按两次 Enter 键 (Windows) 或按两次 Return 键 (Macintosh)。

若要使用现有文本创建列表，请执行以下操作：

  1. 选择一系列段落组成一个列表。
  2. 单击“属性”检查器中的“项目列表”或“编号列表”按钮，或选择“文本”>“列表”，然后选择所需的列表类型：“项目列表”、“编号列表”或“定义列表”。

若要创建嵌套列表，请执行以下操作：

  1. 选择要嵌套的列表项目。
  2. 单击“属性”检查器中的“缩进”按钮，或选择“文本”>“缩进”。

    Dreamweaver 缩进文本并创建一个单独的列表，该列表具有原始列表的 HTML 属性。

  3. 按照上面使用的同一过程，对缩进的文本应用新的列表类型或样式。


设置文本格式

您可以将文本格式应用于一个字母或整个站点段落和文本块。

相关主题

  • 设置和更改字体及样式
  • 修改字体组合
  • 更改文本颜色
  • 插入日期
  • 插入特殊字符
  • 在字符之间添加空格
  • 创建新的 CSS 规则


设置和更改字体及样式

使用“属性”检查器或“文本”菜单中的选项可以设置或更改所选文本的字体特性。可以设置字体类型、样式（如粗体或斜体）和大小。

若要设置或更改字体特性，请执行以下操作：

  1. 选择文本。如果未选择文本，更改将应用于随后键入的文本。
  2. 从以下选项中选择：
    • 若要更改字体，请从“属性”检查器或“文本”>“字体”子菜单中选择字体组合。

      选择“默认”删除先前应用的字体；“默认”对所选文本应用默认字体（或者是浏览器的默认字体，或者是在 CSS 样式表中指定给该标签的字体）。

    • 若要更改字体样式，请单击“属性”检查器中的“粗体”或“斜体”，或者从“文本”>“样式”子菜单中选择字体样式（“粗体”、“斜体”、“下划线”等）。

      注意

      在使用“属性”检查器应用粗体或斜体样式时，Dreamweaver 自动分别应用 <strong> 或 <em> 标签。如果正在为使用 3.0 或更早版本的浏览器的查看者设计页面，则应该在“首选参数”对话框（“编辑”>“首选参数”）的“常规”类别中更改此首选参数。
    • 若要更改字体大小，请从“属性”检查器或“文本”>“大小”子菜单中选择大小（从 1 到 7）。

      HTML 字体大小是相对而不是特定的点数。用户为他们的浏览器设置默认字体的点数；这是用户在“属性”检查器或“文本”>“大小”子菜单中选择“默认”或“3”时所看到的字体大小。大小 1 和 2 显得比默认字体小；大小 4 到 7 显得比默认字体大。此外，尽管 Macintosh Internet Explorer 5 与 Windows 使用相同的默认字体大小，但是 Windows 中的字体通常显得比 Macintosh 中的字体大。

      提示

      一个确保字体大小一致的方法是使用 CSS 样式并且以像素为单位设置字体大小。有关 CSS 的更多信息，请参见使用层叠样式表设置文本格式。
    • 若要增加或减小所选文本的大小，请从“属性”检查器或“文本”>“改变大小”子菜单中选择相对大小（+1 或 -1 到 +4 或 -3）。

      注意

      这些数字指示与基准字体大小的相对差值。默认基准字体值为 3。因此，+4 值将产生字体大小 3 + 4（即 7）。字体大小值之和的最大值为 7。如果试图将它们设置得更高，它们会显示为 7。Dreamweaver 不显示 basefont 标签（该标签位于 head 部分），但字体大小应在浏览器中正确显示。若要对此进行测试，请比较设置为 3 的文本和设置为 +3 的文本。

相关主题

  • 修改字体组合


重命名样式

设置文本格式时，Dreamweaver 将跟踪在每个页面中创建的样式，并生成可以重复使用的样式库。这使得对文本块应用相同的格式更加简单，同时使您可以为页面创建更加一致的外观。

若要重命名样式，请执行以下操作：

  1. 从文本“属性”检查器“样式”弹出式菜单中选择“重命名”。

    出现“重命名样式”对话框。

  2. 从“重命名样式”弹出式菜单中选择要重命名的样式。
  3. 在“新名称”文本字段中输入新的名称。
  4. 单击“确定”。


修改字体组合

使用“编辑字体列表”命令可以设置出现在属性检查器和“文本”>“字体”子菜单中的字体组合。

字体组合确定浏览器显示 Web 页面中的文本的方式。浏览器使用用户系统上安装的字体组合中的第一种字体；如果字体组合中未安装任何一种字体，则浏览器按用户的浏览器首选参数指定的方式显示文本。

若要修改字体组合，请执行以下操作：

  1. 选择“文本”>“字体”>“编辑字体列表”。
  2. 从对话框顶部的列表中选择字体组合。

    所选组合中的字体在对话框左下角的“选择的字体”列表中列出。右侧是系统上安装的所有可用字体的列表。

  3. 执行下列操作之一：
    • 若要向字体组合中添加字体或从中删除字体，请单击“选择的字体”列表和“可用字体”列表之间的箭头按钮（<< 或 >>）。
    • 若要添加或删除字体组合，请单击对话框顶部的加号 (+) 和减号 (-) 按钮。
    • 若要添加系统上未安装的字体，请在“可用字体”列表下面的文本字段中键入字体名称，然后单击 << 按钮将它添加到组合中。添加系统上未安装的字体在很多情况下都很有用，例如，当在 Macintosh 上开发页面时指定仅限 Windows 使用的字体。
    • 若要在列表中上下移动字体组合，请单击对话框顶部的箭头按钮。

若要向字体列表中添加新组合，请执行以下操作：

  1. 选择“文本”>“字体”>“编辑字体列表”。
  2. 从“可用字体”列表中选择一种字体，然后单击 << 按钮将该字体移动到“选择的字体”列表中。
  3. 对组合中随后的每个字体重复第 2 步。

    若要添加系统上未安装的字体，请在“可用字体”列表下面的文本字段中键入字体名称，然后单击 << 按钮将该字体添加到组合中。添加系统上未安装的字体在很多情况下都很有用，例如，当在 Macintosh 上开发页面时指定仅限 Windows 使用的字体。

  4. 选择完特定的字体后，从“可用字体”菜单中选择一个一般字体 (font-family)，然后单击 << 按钮将该一般字体 (font-family) 移动到“选择的字体”列表中。

    一般字体 (font-family) 包括：cursive、fantasy、monospace、sans-serif 和 serif。如果用户系统上的“选择的字体”列表中没有任何字体，则文本以一般字体 (font-family) 的关联默认字体显示。例如，大多数系统上的默认等宽字体是 Courier。


更改文本颜色

可以更改所选文本的颜色，使新颜色覆盖“页面属性”中设置的文本颜色。（如果未在“页面属性”中设置任何文本颜色，则默认文本颜色为黑色。）

若要更改文本颜色，请执行以下操作：

  1. 选择文本。
  2. 执行下列操作之一：
    • 单击“属性”检查器中的颜色选择器，从调色板中选择一种颜色。
    • 选择“文本”>“颜色”。出现系统颜色选择器对话框。选择一种颜色，然后单击“确定”。
    • 直接在“属性”检查器字段中输入颜色名称或十六进制数字。
    • 若要定义默认文本颜色，请使用“修改”>“页面属性”命令（请参见定义默认文本颜色）。

若要使文本返回到默认颜色，请执行以下操作：

  1. 在“属性”检查器中，单击颜色框打开网页安全色面板。
  2. 单击删除线按钮（位于右上角的白色方形按钮，中间有一条红线）。


插入日期

Dreamweaver 提供了一个方便的日期对象，该对象使您可以以任何喜欢的格式插入当前日期（包含或不包含时间都可以），您可以选择在每次保存文件时都自动更新该日期。

注意

“插入日期”对话框中显示的日期和时间不是当前日期，也不反映访问者在显示您的站点时所看到的时期/时间。它们只是说明此信息的显示方式的示例。

若要将当前日期插入到文档中，请执行以下操作：

  1. 在“文档”窗口中，将插入点放在要插入日期的位置。
  2. 执行下列操作之一：
    • 选择“插入”>“日期”。
    • 在“插入”栏的“常用”类别中，单击“日期”按钮。
  3. 在出现的对话框中，选择星期格式、日期格式和时间格式。
  4. 如果希望在每次保存文档时都更新插入的日期，请选择“储存时自动更新”。如果希望日期在插入后变成纯文本并永远不自动更新，请取消选择该选项。
  5. 单击“确定”插入日期。

    提示

    如果选择了“储存时自动更新”，则在日期格式插入到文档中后可以对其进行编辑，方法是单击已设置格式的文本，然后在“属性”检查器中选择“编辑日期格式”。


插入特殊字符

某些特殊字符在 HTML 中以名称或数字的形式表示，它们称为实体。HTML 包含版权符号 (&copy;)、“与”符号 (&amp;)、注册商标符号 (&reg;) 等字符的实体名称。每个实体都有一个名称（如 &mdash;）和一个数字等效值（如 &#151;）。

提示

HTML 在代码中使用尖括号 <>，但您可能需要表示大于或小于这样的特殊字符，而不要 Dreamweaver 将它们解释为代码。在这种情况下，请使用 &gt; 表示大于 (>)，使用 &it; 表示小于 (<)。

遗憾的是，许多浏览器（尤其是旧版本的浏览器以及除 Netscape Navigator 和 Internet Explorer 外的其他浏览器）无法正确显示很多已命名的实体。

若要将特殊字符插入到文档中，请执行以下操作：

  1. 在“文档”窗口中，将插入点放在要插入特殊字符的位置。
  2. 执行下列操作之一：
    • 从“插入”>“HTML”>“特殊字符”子菜单中选择字符名称。
    • 在“插入”栏中的“文本”类别中，单击“字符”按钮选择需要的字符。

      提示

      还有很多其他特殊字符可供使用；若要选择其中的某个字符，请选择“插入”>“HTML”>“特殊字符”>“其他”或选择“插入”栏的“HTML”类别，单击“字符”菜单，然后选择“其他字符”。从“插入其他字符”对话框中选择一个字符，然后单击“确定”。


在字符之间添加空格

HTML 只允许字符之间包含一个空格；若要在文档中添加其他空格，必须插入连续空格。可以设置一个在文档中自动添加不换行空格的首选参数。

若要插入不换行空格，请执行下列操作之一：

  • 在“插入”栏中的“HTML”类别中，单击“字符”按钮并选择“插入不换行空格”。
  • 选择“插入”>“HTML”>“特殊字符”>“不换行空格”。
  • 按 Ctrl+Shift+空格键 (Windows) 或 Option+空格键 (Macintosh)。

若要设置添加不换行空格的首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)。
  2. 在“常规”类别中确保选中“允许多个连续的空格”。


使用层叠样式表设置文本格式

默认情况下，Dreamweaver 使用层叠样式表 (CSS) 设置文本格式。您使用“属性”检查器或菜单命令应用于文本的样式将创建 CSS 规则，这些规则嵌入在当前文档的头部。CSS 样式使您可以更加灵活并更好地控制页面外观 － 从精确的布局定位到特定的字体和文本样式。

还可以使用“CSS 样式”面板创建和编辑 CSS 规则和属性。“CSS 样式”面板是一个比属性检查器强大得多的编辑器，它显示为当前文档定义的所有 CSS 规则，而不管这些规则是嵌入在文档的头部还是在外部样式表中。Macromedia 建议您使用“CSS 样式”面板（而不是“属性”检查器）作为创建和编辑 CSS 的主要工具。这样，您的代码将更清晰，更易于维护。

除了所创建的样式和样式表外，还可以使用 Dreamweaver 附带的样式表对文档应用样式。（请参见创建基于 Dreamweaver 设计文件的文档。）

相关主题

  • 了解层叠样式表
  • 关于“CSS 样式”面板
  • 使用“CSS 样式”面板
  • 创建新的 CSS 规则
  • 应用类样式
  • 导出样式以创建 CSS 样式表
  • 链接到或导出外部 CSS 样式表
  • 编辑 CSS 规则
  • 编辑 CSS 样式表
  • 使用设计时间样式表
  • 关于冲突的 CSS 规则


使用“CSS 样式”面板

您可以使用“CSS 样式”面板查看、创建、编辑和删除 CSS 样式，并且可以将外部样式表附加到文档。（有关此面板的概述，请参见关于“CSS 样式”面板。）

若要打开“CSS 样式”面板，请执行以下操作：

  • 执行下列操作之一：
    • 选择“窗口”>“CSS 样式”。
    • 按 Shift+F11 键。
    • 单击属性检查器中的“CSS”按钮。

若要在“CSS 样式”面板中编辑规则（“当前”模式），请执行以下操作：

  1. 单击“CSS 样式”面板顶部的“当前”按钮。
  2. 选择当前页中的一个文本元素以显示它的属性。
  3. 执行下列操作之一：
    • 双击“所选内容的摘要”窗格中的某个属性以显示“CSS 规则定义”对话框，然后进行更改。
    • 在“所选内容的摘要”窗格中选择一个属性，然后在下面的“属性”窗格中编辑该属性。
    • 在“规则”窗格中选择一条规则，然后在下面的“属性”窗格中编辑该规则的属性。

      注意

      可以通过更改 Dreamweaver 首选参数来更改用于编辑 CSS 的双击行为以及其他行为。有关更多信息，请参见“使用 Dreamweaver 帮助”中的设置 CSS 样式首选参数。

若要在“CSS 样式”面板中编辑规则（“所有”模式），请执行以下操作：

  1. 单击“CSS 样式”面板顶部的“所有”按钮。
  2. 执行下列操作之一：
    • 在“所有规则”窗格中双击某条规则以显示“CSS 规则定义”对话框，然后进行更改。
    • 在“所有规则”窗格中选择一条规则，然后在下面的“属性”窗格中编辑该规则的属性。
    • 在“所有规则”窗格中选择一条规则，然后单击“CSS 样式”面板右下角中的“编辑样式”按钮。

      注意

      可以通过更改 Dreamweaver 首选参数来更改用于编辑 CSS 的双击行为以及其他行为。有关更多信息，请参见“使用 Dreamweaver 帮助”中的设置 CSS 样式首选参数。

若要向规则添加属性，请执行以下操作：

  1. 在“所有规则”窗格中选择一条规则（“所有”模式），或者在“所选内容的摘要”窗格中选择一个属性（“当前”模式）。
  2. 执行下列操作之一：
    • 如果在“属性”窗格中选择了“只显示设置属性”视图，请单击“添加属性”链接并添加属性。
    • 如果在“属性”窗格中选择了“类别”视图或“列表”视图，则为要添加的属性填入一个值。

在“所有”和“当前”模式下，“CSS 样式”面板都包含三个允许您在“属性”窗格（底部窗格）中改变视图的按钮： 这是所描述的功能的图片。

“类别”视图将 Dreamweaver 支持的 CSS 属性划分为 8 个类别：字体、背景、区块、边框、方框、列表、定位和扩展。每个类别的属性都包含在一个列表中，您可以单击类别名称旁边的加号 (+) 按钮展开或折叠它。“设置属性”（蓝色）将出现在列表顶部。

“列表”视图按字母顺序显示 Dreamweaver 所支持的所有 CSS 属性。“设置属性”（蓝色）将出现在列表顶部。

“设置属性”视图仅显示那些已设置的属性。“设置属性”视图为默认视图。

在“所有”和“当前”模式下，“CSS 样式”面板还包含下列按钮：

附加样式表打开“链接外部样式表”对话框。选择要链接到或导入到当前文档中的外部样式表。有关附加外部样式表的信息，请参见链接到或导出外部 CSS 样式表。

新建 CSS 规则会打开一个对话框，您可在其中选择要创建的样式类型（例如，要创建类样式、重新定义 HTML 标签或是要定义 CSS 选择器）。有关更多信息，请参见创建新的 CSS 规则。

编辑样式会打开一个对话框，您可在该对话框中编辑当前文档或外部样式表中的样式。有关如何更新样式表的信息，请参见编辑 CSS 规则。

删除 CSS 规则删除“CSS 样式”面板中的所选规则或属性，并从应用该规则的所有元素中删除格式。（不过，它不删除对该样式的引用）。

提示

右键单击 (Windows) 或按住 Control 键单击 (Macintosh)“CSS 样式”面板，可打开用于处理 CSS 样式表命令的选项的上下文菜单。

相关主题

  • 应用类样式
  • 链接到或导出外部 CSS 样式表
  • 编辑 CSS 样式表


创建新的 CSS 规则

您可以创建一个 CSS 规则来自动完成 HTML 标签的格式设置或 class 属性所标识的文本范围的格式设置。

若要创建新的 CSS 规则，请执行以下操作：

  1. 将插入点放在文档中，然后执行以下操作之一打开“新建 CSS 规则”对话框：
    • 在“CSS 样式”面板（“窗口”>“CSS 样式”）中，单击面板右下侧中的“新建 CSS 规则”(+) 按钮。
    • 选择“文本”>“CSS 样式”>“新建 CSS 规则”。
  2. 定义您要创建的 CSS 样式的类型：
    • 若要创建可作为 class 属性应用于文本范围或文本块的自定义样式，请选择“类”选项，然后在“名称”文本框中输入样式名称。

      注意

      类名称必须以句点开头，并且可以包含任何字母和数字组合（例如，.myhead1）。如果您没有输入开头的句点，Dreamweaver 将自动为您输入。
    • 若要重定义特定 HTML 标签的默认格式设置，请选择“标签”选项，然后在“标签”文本框中输入一个 HTML 标签，或从弹出式菜单中选择一个标签。
    • 若要为具体某个标签组合或所有包含特定 Id 属性的标签定义格式设置，请选择“高级”选项，然后在“选择器”文本框中输入一个或多个 HTML 标签，或从弹出式菜单中选择一个标签。弹出式菜单中提供的选择器（称作伪类选择器）包括 a:active、a:hover、a:link 和 a:visited。
  3. 选择定义样式的位置：
    • 若要创建外部样式表，请选择“新建样式表文件”。
    • 若要在当前文档中嵌入样式，请选择“仅对该文档”。
  4. 单击“确定”。

    出现“CSS 样式定义”对话框。

  5. 选择您要为新的 CSS 规则设置的样式选项。
  6. 设置完样式属性后，单击“确定”。

有关特定 CSS 样式设置的信息，请参见下列主题：

  • 定义 CSS 类型属性
  • 定义 CSS 样式背景属性
  • 定义 CSS 样式区块属性
  • 定义 CSS 样式方框属性
  • 定义 CSS 样式边框属性
  • 定义 CSS 样式列表属性
  • 定义 CSS 样式定位属性
  • 定义 CSS 样式扩展属性

相关主题

  • 使用“CSS 样式”面板
  • 应用类样式
  • 编辑 CSS 规则


应用类样式

类样式是唯一可以应用于文档中任何文本（与控制文本的标签无关）的 CSS 样式类型。与当前文档关联的所有类样式都显示在“CSS 样式”面板中（样式名称前有一个句点 [.]）和文本属性检查器的“样式”弹出式菜单中。

您会看到大多数样式都立即更新了，但您应在浏览器中预览页面，验证样式是否是按预期的方式应用的。将两个或更多的样式应用于同一文本时，这些样式可能发生冲突并产生意外的结果。有关更多信息，请参见关于冲突的 CSS 规则。

提示

当预览外部 CSS 样式表中定义的样式时，务必要保存该样式表以确保当您在浏览器中预览该页面时会反映出所做的更改。

若要应用自定义 CSS 样式，请执行以下操作：

  1. 在文档中，选择要应用 CSS 样式的文本。

    将插入点放在段落中以将样式应用于整个段落。

    如果在单个段落中选择一个文本范围，则 CSS 样式只影响所选范围。

    若要指定要应用 CSS 样式的确切标签，请在位于“文档”窗口左下角的标签选择器中选择标签。

  2. 若要应用类样式，请执行下列操作之一：
    • 在“CSS 样式”面板（“窗口”>“CSS 样式”）中，选择“所有”模式，右键单击要应用的样式的名称，然后从上下文菜单选择“应用”。
    • 在文本“属性”检查器中，从“样式”弹出式菜单中选择要应用的类样式。
    • 在“文档”窗口中，右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 所选文本，在上下文菜单中选择“CSS 样式”，然后选择要应用的样式。
    • 选择“文本”>“CSS 样式”，然后在子菜单中选择要应用的样式。

若要将自定义样式从所选内容中删除，请执行以下操作：

  1. 选择要从其中删除样式的对象或文本。
  2. 在文本属性检查器（“窗口”>“属性”）中，从“样式”弹出式菜单中选择“无”。

相关主题

  • 了解层叠样式表
  • 关于“CSS 样式”面板
  • 编辑 CSS 规则


导出样式以创建 CSS 样式表

可以从文档中导出样式以创建新的 CSS 样式表。然后，可链接到其他文档以应用这些样式。

若要从文档中导出 CSS 样式并创建 CSS 样式表，请执行以下操作：

  1. 选择“文件”>“导出”>“CSS 样式”或选择“文本”>“CSS 样式”>“导出”。

    出现“导出样式为 CSS 文件”对话框。

  2. 输入样式表的名称，然后单击“保存”。

    样式随即保存为 CSS 样式表。

相关主题

  • 使用“CSS 样式”面板
  • 链接到或导出外部 CSS 样式表
  • 编辑 CSS 样式表
  • 使用设计时间样式表


链接到或导出外部 CSS 样式表

编辑外部 CSS 样式表时，链接到该 CSS 样式表的所有文档全部更新以反映所做的编辑。可以导出文档中包含的 CSS 样式以创建新的 CSS 样式表，然后附加或链接到外部样式表以应用那里所包含的样式。

当然，您可以将创建的任何样式表附加到页面或复制到站点中。此外，Dreamweaver 附带了预置的样式表，这些样式表可以自动移入站点并附加到页面。有关如何使用 Dreamweaver 附带的设计样式表的信息，请参见创建基于 Dreamweaver 设计文件的文档。

有关如何应用样式的信息，请参见应用类样式。

若要链接到或导出外部 CSS 样式表，请执行以下操作：

  1. 执行下列操作之一打开“CSS 样式”面板：
    • 选择“窗口”>“CSS 样式”。
    • 按 Shift+F11 键。
  2. 在“CSS 样式”面板中，单击“附加样式表”按钮。（该按钮位于面板的右下角。）
  3. 完成对话框设置，然后单击“确定”。

    有关说明，请单击对话框中的“帮助”按钮。

相关主题

  • 使用“CSS 样式”面板
  • 导出样式以创建 CSS 样式表
  • 编辑 CSS 样式表


使用示例 Dreamweaver 样式表

Dreamweaver 提供示例样式表，您可以将其应用于页面，也可以使用它们作为起点以开发自己的样式。

若要应用 Dreamweaver 样式表，请执行以下操作：

  1. 执行下列操作之一打开“CSS 样式”面板：
    • 选择“窗口”>“CSS 样式”。
    • 按 Shift+F11 键。
  2. 在“CSS 样式”面板中，单击“附加外部样式表”按钮。（该按钮位于面板的右下角。）
  3. 在“附加外部样式表”对话框中，单击“示例样式表”。
  4. 在“示例样式表”对话框中，从列表框中选择样式表。

    在列表框中选择样式表的同时，“预览”窗格将显示所选样式表的文本和颜色格式。

  5. 单击“预览”按钮应用样式表，并确认是否将所需的样式应用到当前页面中。

    如果应用的样式没有达到预期效果，请从列表中选择其他样式表，然后单击“预览”以查看这些样式。

  6. 默认情况下，Dreamweaver 将样式表保存在为页面定义的站点根下的名为“CSS”的文件夹中。如果该文件夹不存在，Dreamweaver 将创建一个。您可以单击“浏览”并浏览到其他文件夹，从而将文件保存在其他位置。
  7. 找到其格式规则满足您的设计标准的样式表后，请单击“确定”。


编辑 CSS 规则

编辑应用于文档的内部和外部规则都很容易。

对控制文档文本的 CSS 样式表进行编辑时，会立刻重新设置该 CSS 样式表控制的所有文本的格式。对外部样式表的编辑影响与它链接的所有文档。

可以设置一个外部编辑器来编辑样式表。有关如何设置外部编辑器的信息，请参见为媒体文件启动外部编辑器。

若要编辑 CSS 规则，请执行以下操作：

  1. 选择“窗口”>“CSS 样式”以打开“CSS 样式”面板。
  2. 将插入点置于要编辑 CSS 规则的文本中。
  3. 使用“CSS 样式”面板编辑规则。有关说明，请参见使用“CSS 样式”面板。

    所作的更改将立即应用于当前文档，使您可以在更改的同时进行预览。如果编辑的是存储在外部样式表中的规则，请务必保存更改，以便查看已应用的更新。

    如果修改由多个文档使用的样式表中的 CSS 规则，所作的更改也将反映在相应页面中。

相关主题

  • 编辑 CSS 样式表
  • 使用设计时间样式表


编辑 CSS 样式表

CSS 样式表通常包含一个或多个规则。可以使用“CSS 样式”面板在 CSS 样式表中编辑单个规则（请参见编辑 CSS 规则），或者，如果您喜欢，可以直接在 CSS 样式表中工作。

若要编辑 CSS 样式表，请执行以下操作：

  1. 在“CSS 样式”面板中（“窗口”>“CSS 样式”），选择“所有”模式。
  2. 在“所有规则”窗格中，双击要编辑的样式表的名称。
  3. 在“文档”窗口中，根据需要修改样式表，然后保存样式表。

相关主题

  • 使用“CSS 样式”面板
  • 编辑 CSS 规则
  • 使用设计时间样式表


更新 Contribute 站点中的 CSS 样式表

Macromedia Contribute 用户不能更改 CSS 样式表。若要更改 Contribute 站点的样式表，请使用 Dreamweaver。

以下是更新 Contribute 站点的样式表时需要注意的重要事项：

  • 如果当 Contribute 用户正在编辑使用样式表的页面时您更改了此样式表，则用户在发布此页面之前不会看到对样式表所做的更改。
  • 如果从样式表中删除了某个样式，此样式名称不会从使用该样式表的页面中删除，但因为此样式已不存在，所以它不会以 Contribute 用户所期望的形式显示。因此，如果用户告诉您当他们应用了某个特定样式后没有任何效果，那么问题可能在于此样式已从样式表中删除。

若要编辑 Contribute 站点中的 CSS 样式表，请执行以下操作：

  1. 使用 Dreamweaver 样式表编辑工具来编辑样式表。有关更多信息，请参见使用层叠样式表设置文本格式。
  2. 通知所有正在此站点上工作的 Contribute 用户发布使用该样式表的页面，然后重新编辑这些页面以查看新样式表。


使用设计时间样式表

设计时间样式表使得当您在处理 Dreamweaver 文档时可以显示或隐藏 CSS 样式表所应用的设计。例如，可以使用此选项在设计页面时包括或排除只限于 Macintosh 或只限于 Windows 的样式表。

只有当您正在处理 Dreamweaver 文档时，设计时间样式表才能得到应用；当页面显示在浏览器窗口中时，只有实际附加或嵌入到文档中的样式才出现在浏览器中。

若要在设计时显示或隐藏 CSS 样式表，请执行以下操作：

  1. 执行下列操作之一，打开“设计时间样式表”对话框：
    • 在“CSS 样式”面板中右键单击，然后在上下文菜单中选择“设计时间”。
    • 选择“文本”>“CSS 样式”>“设计时间”。
  2. 在该对话框中，设置显示或隐藏所选样式表的选项：
    • 若要在设计时显示 CSS 样式表，请单击“只在设计时显示”上方的加号 (+) 按钮，然后在“选择样式表”对话框中浏览到要显示的 CSS 样式表。
    • 若要隐藏 CSS 样式表，请单击“设计时隐藏”上方的加号 (+) 按钮，然后在“选择样式表”对话框中浏览到要隐藏的 CSS 样式表。
    • 若要从任一列表中删除样式表，请单击要删除的样式表，然后单击相应的减号 (-) 按钮。
  3. 单击“确定”关闭该对话框。

“CSS 样式”面板使用所选样式表的名称以及一个指示器（“隐藏”或“设计”）进行更新，以反映样式表的状态。

相关主题

  • 使用“CSS 样式”面板
  • 导出样式以创建 CSS 样式表
  • 链接到或导出外部 CSS 样式表
  • 编辑 CSS 样式表


检查拼写

使用“文本”菜单中的“检查拼写”命令可以检查当前文档中的拼写。“检查拼写”命令忽略 HTML 标签和属性值。

默认情况下，拼写检查器使用美国英语拼写字典。若要更改字典，请选择“编辑”>“首选参数”>“常规”(Windows) 或“Dreamweaver”>“首选参数”>“常规”(Macintosh)，然后在“拼写字典”弹出式菜单中选择要使用的字典。其他语言的字典可从 Dreamweaver 支持中心（网址为 www.macromedia.com/support/dreamweaver）下载。

若要检查和更正拼写，请执行以下操作：

  1. 选择“文本”>“检查拼写”或按 Shift+F7 键。

    当 Dreamweaver 遇到无法识别的单词时，将出现“检查拼写”对话框。

  2. 根据所需的差异处理方法选择相应的选项。

    有关更多信息，请参见设置拼写选项。


搜索和替换文本

您可以使用“查找和替换”命令在一个文档或一组文档中搜索文本、HTML 标签和属性。

注意

若要在站点中搜索文件，请使用不同的命令：“本地站点中定位”和“远程站点中定位”。

若要搜索文档中的文本和 HTML，请执行以下操作：

  1. 打开要在其中搜索内容的文档，或在“文件”面板中选择文档或文件夹。
  2. 选择“编辑”>“查找和替换”。

    出现“查找和替换”对话框。

  3. 指定要在其中搜索内容的文件，然后指定要执行的搜索类型以及要搜索的文本或标签。此外，还可以指定替换文本。然后单击某个“查找”按钮或“替换”按钮。

    有关更多信息，请参见设置“查找和替换”对话框选项。

  4. 完成后，单击“关闭”按钮关闭该对话框。

若要再次搜索而不显示“查找和替换”对话框，请执行以下操作：

  • 按 F3 键 (Windows) 或 Command+G 组合键 (Macintosh)。


参考资料

本节提供有关本章中介绍的以下对话框、“属性”检查器和面板的信息：

  • 设置文本属性选项
  • 设置“列表属性”对话框选项
  • 设置 CSS 样式首选参数
  • 定义 CSS 类型属性
  • 定义 CSS 样式背景属性
  • 定义 CSS 样式区块属性
  • 定义 CSS 样式方框属性
  • 定义 CSS 样式边框属性
  • 定义 CSS 样式列表属性
  • 定义 CSS 样式定位属性
  • 定义 CSS 样式扩展属性
  • 设置“附加外部样式表”对话框选项
  • 设置拼写选项
  • 设置拼写选项
  • 设置“查找和替换”对话框选项
  • 设置“查找和替换”对话框选项以执行特定标签搜索
  • 设置“查找和替换”对话框选项以执行高级文本搜索
  • 设置“搜索”面板选项
  • 设置“选择性粘贴”对话框选项
  • 设置“复制/粘贴首选参数”对话框
  • 设置“插入文档”对话框选项
  • 设置“重命名类”或“重命名样式”对话框选项


设置文本属性选项

文本属性检查器显示文档中选择的文本的当前格式属性。可以通过设置新选项更改格式。样式立即应用于文本。

可以使用文本“属性”检查器应用 HTML 格式或层叠样式表 (CSS) 格式。HTML 格式使您可以选择文本格式选项（如字体、大小、粗体和斜体），而 CSS 格式使您可以将 CSS 类样式应用于所选文本。

在使用“属性”检查器应用粗体或斜体样式时，Dreamweaver 自动分别应用 <strong> 或 <em> 标签。如果正在为使用 3.0 或更早版本的浏览器的查看者设计页面，则应该在“首选参数”对话框（“编辑”>“首选参数”）的“常规”类别中更改此首选参数。

有关如何创建类样式的信息，请参见创建新的 CSS 规则。

若要设置格式选项，请执行以下操作：

  1. 如果“属性”检查器尚未打开，请打开“属性”检查器（“窗口”>“属性”）。
  2. 选择要设置格式的文本。
  3. 设置要应用于所选文本的 CSS 选项：

    格式设置所选文本的段落样式。“段落”应用 <p> 标签的默认格式，“标题 1”添加 H1 标签，等等。

    样式显示当前应用于所选文本的类样式。如果没有对所选内容应用过任何样式，则弹出式菜单显示“无 CSS 样式”。如果已对所选内容应用了多个样式，则弹出式菜单是空的。

    使用“样式”弹出式菜单执行下列任何操作：

    • 选择要应用于所选内容的样式。
    • 选择“无”删除当前所选样式。
    • 选择“附加样式表”以打开一个允许您附加外部样式表的对话框。

    粗体根据在“首选参数”对话框的“常规”类别中设置的样式首选参数，将 <b> 或 <strong> 应用于所选文本。

    斜体根据在“首选参数”对话框的“常规”类别中设置的样式首选参数，将 <i> 或 <em> 应用于所选文本。

    有关设置“常规”首选参数的信息，请参见设置 Dreamweaver 的“常规”首选参数。

若要设置 HTML 格式选项，请执行以下操作：

  1. 如果“属性”检查器尚未打开，请打开“属性”检查器（“窗口”>“属性”）。
  2. 选择要设置格式的文本。
  3. 设置要应用于所选文本的选项：

    格式设置所选文本的段落样式。“段落”应用 <p> 标签的默认格式，“标题 1”添加 H1 标签，等等。

    字体组合对文本应用所选字体组合。使用弹出式菜单选择要应用的字体组合，或选择“编辑字体列表”创建或编辑字体组合。

    大小应用特定的字体大小（1 到 7）或相对于基准字体大小（默认值是 3）的字体大小（+1 或 -1 到 +7 或 -7）。

    文本颜色以所选颜色显示文本。单击颜色框选择网页安全色，或在相邻的文本域中输入十六进制值（例如 #FF0000）。

    粗体根据在“首选参数”对话框的“常规”类别中设置的样式首选参数，将 <b> 或 <strong> 应用于所选文本。

    斜体根据在“首选参数”对话框的“常规”类别中设置的样式首选参数，将 <i> 或 <em> 应用于所选文本。

    有关设置“常规”首选参数的信息，请参见设置 Dreamweaver 的“常规”首选参数。

    左对齐、居中对齐和右对齐应用各自的对齐方式。

    链接使您可以创建所选文本的超文本链接。单击文件夹图标浏览到站点中的文件；键入 URL；将“指向文件”图标拖到“站点”面板中的文件；或将文件从“站点”面板拖到框中。

    目标使您可以指定将在其中加载链接文档的框架或窗口：

    • _blank 将链接文件加载到未命名的新浏览器窗口中。
    • _parent 将链接文件加载到包含该链接的父框架集或窗口中。如果包含链接的框架不是嵌套的，则链接文件加载到整个浏览器窗口中。
    • _self 将链接文件加载到链接所在的同一框架或窗口中。此目标是默认的，因此通常不需要指定它。
    • _top 将链接文件加载到整个浏览器窗口中，并由此删除所有框架。

    项目列表创建所选文本的项目列表。如果未选择文本，则启动一个新的项目列表。

    编号列表创建所选文本的编号列表。如果未选择文本，则启动一个新的编号列表。

    列表项目打开“列表属性”对话框。请参见设置“列表属性”对话框选项。

    缩进和凸出通过应用或删除 blockquote 标签缩进或删除所选文本的缩进。在列表中，缩进创建一个嵌套列表，而删除缩进则取消嵌套列表。

相关主题

  • 设置段落格式
  • 设置和更改字体及样式
  • 创建新的 CSS 规则
  • 设置 Dreamweaver 的“常规”首选参数


设置“列表属性”对话框选项

使用“列表属性”对话框可以设置整个列表或个别列表项的外观。可以设置编号样式，重置计数或设置个别列表项目或整个列表的项目符号样式选项。

有关如何使用 CSS 样式表设置列表属性的信息，请参见定义 CSS 样式列表属性。

若要设置整个列表的列表属性，请执行以下操作：

  1. 在“文档”窗口中，创建至少一个列表项目。新样式将自动应用于添加到列表的其他项目。
  2. 将插入点放到列表项目的文本中，然后选择“文本”>“列表”>“属性”打开“列表属性”对话框。
  3. 在出现的对话框中，设置要用来定义列表的选项：

    列表类型指定列表属性，而列表项目指定列表中的个别项目。使用弹出式菜单选择项目、编号、目录或菜单列表。根据所选的“列表类型”，对话框中将出现不同的选项。

    样式确定用于编号列表或项目列表的编号或项目符号的样式。所有列表项目都将具有该样式，除非为列表项目指定新样式。

    开始计数设置第一个编号列表项的值。

  4. 单击“确定”设置所做的选择并关闭对话框。

若要设置列表项目的列表属性，请执行以下操作：

  1. 在“文档”窗口中，将插入点放在要格式化的列表项目的文本中
  2. 选择“文本”>“列表”>“属性”。
  3. 在出现的对话框的“列表项目”下，设置要用来定义列表项目的选项：

    新建样式使您可以指定所选列表项的样式。“新建样式”弹出式菜单中的样式与“列表类型”弹出式菜单中显示的列表类型相关。例如，如果“列表项目”弹出式菜单显示“项目列表”，则“新建样式”弹出式菜单中只有项目符号选项可用。

    重设计数使您可以设置用来从其开始为列表项编号的特定数字。

  4. 单击“确定”设置选项并关闭对话框。


设置 CSS 样式首选参数

CSS 样式首选参数控制 Dreamweaver 编写定义 CSS 样式的代码的方式。CSS 样式可以以速记形式来编写，有些人觉得这种形式使用起来更容易。但某些较旧版本的浏览器不能正确解释速记。

若要显示 CSS 样式首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)，然后从“类别”列表中选择“CSS 样式”。
  2. 设置要应用的 CSS 样式选项：

    当创建 CSS 规则时使用速记使您可以选择 Dreamweaver 以速记形式编写的 CSS 样式属性。

    当编辑 CSS 规则时使用速记控制 Dreamweaver 是否以速记形式重新编写现有样式。

    选择“如果原来使用速记”使 Dreamweaver 将所有样式保留原样。

    选择“依据以上设置”使 Dreamweaver 以速记形式重新为“使用速记”中选择的属性编写样式。

    当在 CSS 面板中双击时使您可以选择用于在 Dreamweaver 中编辑 CSS 规则的首选工具。

  3. 单击“确定”。

相关主题

  • 速记 CSS 属性
  • 使用“CSS 样式”面板


定义 CSS 类型属性

使用“CSS 规则定义”对话框中的“类型”类别可以定义 CSS 样式的基本字体和类型设置。

另请参见使用层叠样式表设置文本格式和编辑 CSS 规则。

若要定义 CSS 样式的类型设置，请执行以下操作：

  1. 如果尚未打开“CSS 样式”面板，请打开该面板（按 Shift+F11 键）。
  2. 通过下列操作之一打开“CSS 规则定义”对话框：
    • 添加一个新样式。有关更多信息，请参见创建新的 CSS 规则。
    • 双击一个现有样式打开它，以便在“代码”视图或“CSS 属性”选项卡中进行编辑。
  3. 在“CSS 规则定义”对话框中，选择“类型”，然后设置所需的样式属性。

    将下列任意属性保留为空（如果它们对于样式并不重要）：

    字体为样式设置字体 (font-family)（或家族系列）。浏览器使用用户系统上安装的字体系列中的第一种字体显示文本。为了与 Internet Explorer 3.0 兼容，首先列出 Windows 字体。两种浏览器都支持字体属性。

    大小定义文本大小。可以通过选择数字和度量单位选择特定的大小，也可以选择相对大小。以像素为单位可以有效地防止浏览器破坏文本。两种浏览器都支持大小属性。

    样式将“正常”、“斜体”或“偏斜体”指定为字体样式。默认设置是“正常”。两种浏览器都支持样式属性。

    行高设置文本所在行的高度。该设置传统上称为前导。选择“正常”自动计算字体大小的行高，或输入一个确切的值并选择一种度量单位。两种浏览器都支持行高属性。

    修饰向文本中添加下划线、上划线或删除线，或使文本闪烁。常规文本的默认设置是“无”。链接的默认设置是“下划线”。将链接设置设为无时，可以通过定义一个特殊的类删除链接中的下划线。两种浏览器都支持修饰属性。

    粗细对字体应用特定或相对的粗体量。“正常”等于 400；“粗体”等于 700。两种浏览器都支持粗细属性。

    变量设置文本的小型大写字母变量。Dreamweaver 不在“文档”窗口中显示该属性。Internet Explorer 支持变体属性，但 Navigator 不支持。

    大小写将所选内容中的每个单词的首字母大写或将文本设置为全部大写或小写。两种浏览器都支持大小写属性。

    颜色设置文本颜色。两种浏览器都支持颜色属性。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其他的样式属性，或单击“确定”。


定义 CSS 样式背景属性

使用“CSS 规则定义”对话框的“背景”类别可以定义 CSS 样式的背景设置。可以对 Web 页面中的任何元素应用背景属性。例如，创建一个样式，将背景颜色或背景图像添加到任何页面元素中，比如在文本、表格、页面等的后面。还可以设置背景图像的位置。另请参见使用层叠样式表设置文本格式和编辑 CSS 规则。

定义背景设置：

  1. 如果尚未打开“CSS 样式”面板，请打开该面板（按 Shift+F11 键）。
  2. 通过下列操作之一打开“CSS 规则定义”对话框：
    • 添加一个新样式。有关更多信息，请参见创建新的 CSS 规则。
    • 双击一个现有样式打开它，以便在“代码”视图或“CSS 属性”选项卡中进行编辑。
  3. 在“CSS 规则定义”对话框中，选择“背景”，然后设置所需的样式属性。

    将下列任意属性保留为空（如果它们对于样式并不重要）：

    背景颜色设置元素的背景颜色。两种浏览器都支持背景颜色属性。

    背景图像设置元素的背景图像。两种浏览器都支持背景图像属性。

    重复确定是否以及如何重复背景图像。两种浏览器都支持重复属性。

    “不重复”只在元素开始处显示一次图像。

    “重复”在元素的后面水平和垂直平铺图像。

    “横向重复”和“纵向重复”分别显示图像的水平带区和垂直带区。图像被剪辑以适合元素的边界。

    注意

    使用“重复”属性重定义 body 标签并设置不平铺、不重复的背景图像。

    附件确定背景图像是固定在它的原始位置还是随内容一起滚动。注意，某些浏览器可能将“固定”选项视为“滚动”。Internet Explorer 支持该选项，但 Netscape Navigator 不支持。

    水平位置和垂直位置指定背景图像相对于元素的初始位置。这可以用于将背景图像与页面中心垂直和水平对齐。如果附件属性为“固定”，则位置相对于“文档”窗口而不是元素。Internet Explorer 支持该属性，但 Netscape Navigator 不支持。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其他的样式属性，或单击“确定”。


定义 CSS 样式区块属性

使用“CSS 规则定义”对话框的“区块”类别可以定义标签和属性的间距和对齐设置。

若要定义区块设置，请执行以下操作：

  1. 如果尚未打开“CSS 样式”面板，请打开该面板（按 Shift+F11 键）。
  2. 通过下列操作之一打开“CSS 规则定义”对话框：
    • 添加一个新样式。有关更多信息，请参见创建新的 CSS 规则。
    • 双击一个现有样式打开它，以便在“代码”视图或“CSS 属性”选项卡中进行编辑。
  3. 在“CSS 规则定义”对话框中，选择“区块”，然后设置所需的样式属性。

    将下列任意属性保留为空（如果它们对于样式并不重要）：

    单词间距设置单词的间距。若要设置特定的值，请在弹出式菜单中选择“值”，然后输入一个数值。在第二个弹出式菜单中，选择度量单位（例如像素、点等）。

    注意

    可以指定负值，但显示方式取决于浏览器。Dreamweaver 不在“文档”窗口中显示该属性。

    字母间距增加或减小字母或字符的间距。若要减小字符间距，请指定一个负值（例如 -4）。字母间距设置覆盖对齐的文本设置。Internet Explorer 4 和更高版本以及 Netscape Navigator 6 支持“字母间距”属性。

    垂直对齐方式指定应用它的元素的垂直对齐方式。仅当应用于 <img> 标签时，Dreamweaver 才在“文档”窗口中显示该属性。

    文本对齐设置元素中的文本对齐方式。两种浏览器都支持“文本对齐”属性。

    文本缩进指定第一行文本缩进的程度。可以使用负值创建凸出，但显示方式取决于浏览器。仅当标签应用于块级元素时，Dreamweaver 才在“文档”窗口中显示该属性。两种浏览器都支持“文本缩进”属性。

    空白确定如何处理元素中的空白。从下面三个选项中选择：“正常”收缩空白；“保留”的处理方式与文本被括在 pre 标签中一样（即保留所有空白，包括空格、制表符和回车）；“不换行”指定仅当遇到 br 标签时文本才换行。Dreamweaver 不在“文档”窗口中显示该属性。Netscape Navigator 和 Internet Explorer 5.5 支持“空白”属性。

    显示指定是否以及如何显示元素。“无”关闭应用此属性的元素的显示。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其他的样式属性，或单击“确定”。


定义 CSS 样式方框属性

使用“CSS 规则定义”对话框的“方框”类别可以为控制元素在页面上的放置方式的标签和属性定义设置。

可以在应用填充和边距设置时将设置应用于元素的各个边，也可以使用“全部相同”设置将相同的设置应用于元素的所有边。

若要定义元素在页面上的放置方式，请执行以下操作：

  1. 如果尚未打开“CSS 样式”面板，请打开该面板（按 Shift+F11 键）。
  2. 通过下列操作之一打开“CSS 规则定义”对话框：
    • 添加一个新样式。有关更多信息，请参见创建新的 CSS 规则。
    • 双击一个现有样式打开它，以便在“代码”视图或“CSS 属性”选项卡中进行编辑。
  3. 在“CSS 规则定义”对话框中，选择“方框”，然后设置所需的样式属性。

    将下列任意属性保留为空（如果它们对于样式并不重要）：

    宽和高设置元素的宽度和高度。

    浮动设置其他元素（如文本、层、表格等）在哪个边围绕元素浮动。其他元素按通常的方式环绕在浮动元素的周围。两种浏览器都支持“浮动”属性。

    清除定义不允许层的边。如果清除边上出现层，则带清除设置的元素移到该层的下方。两种浏览器都支持“清除”属性。

    填充指定元素内容与元素边框之间的间距（如果没有边框，则为边距）。取消选择“全部相同”选项可设置元素各个边的填充。

    全部相同为应用此属性的元素的“上”、“右”、“下”和“左”侧设置相同的填充属性。

    边界指定一个元素的边框与另一个元素之间的间距（如果没有边框，则为填充）。仅当应用于块级元素（段落、标题、列表等）时，Dreamweaver 才在“文档”窗口中显示该属性。取消选择“全部相同”可设置元素各个边的边距。

    全部相同为应用此属性的元素的“上”、“右”、“下”和“左”侧设置相同的边距属性。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其他的样式属性，或单击“确定”。


定义 CSS 样式边框属性

使用“CSS 规则定义”对话框的“边框”类别可以定义元素周围的边框的设置（如宽度、颜色和样式）。

设置元素的边框样式：

  1. 如果尚未打开“CSS 样式”面板，请打开该面板（按 Shift+F11 键）。
  2. 通过下列操作之一打开“CSS 规则定义”对话框：
    • 添加一个新样式。有关更多信息，请参见创建新的 CSS 规则。
    • 双击一个现有样式打开它，以便在“代码”视图或“CSS 属性”选项卡中进行编辑。
  3. 在“CSS 规则定义”对话框中，选择“边框”，然后设置所需的样式属性。

    将下列任意属性保留为空（如果它们对于样式并不重要）：

    样式设置边框的样式外观。样式的显示方式取决于浏览器。Dreamweaver 在“文档”窗口中将所有样式呈现为实线。两种浏览器都支持样式属性。取消选择“全部相同”可设置元素各个边的边框样式。

    全部相同为应用此属性的元素的“上”、“右”、“下”和“左”侧设置相同的边框样式属性。

    宽度设置元素边框的粗细。两种浏览器都支持“宽度”属性。取消选择“全部相同”可设置元素各个边的边框宽度。

    全部相同为应用此属性的元素的“上”、“右”、“下”和“左”侧设置相同的边框宽度。

    颜色设置边框的颜色。可以分别设置每条边的颜色，但显示方式取决于浏览器。取消选择“全部相同”可设置元素各个边的边框颜色。

    全部相同为应用此属性的元素的“上”、“右”、“下”和“左”侧设置相同的边框颜色。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其他的样式属性，或单击“确定”。


定义 CSS 样式列表属性

“CSS 规则定义”对话框的“列表”类别为列表标签定义列表设置（如项目符号大小和类型）。

若要定义列表样式，请执行以下操作：

  1. 如果尚未打开“CSS 样式”面板，请打开该面板（按 Shift+F11 键）。
  2. 通过下列操作之一打开“CSS 规则定义”对话框：
    • 添加一个新样式。有关更多信息，请参见创建新的 CSS 规则。
    • 双击一个现有样式以打开它进行编辑。
  3. 在“CSS 规则定义”对话框中，选择“列表”，然后设置所需的样式属性。

    将下列任意属性保留为空（如果它们对于样式并不重要）：

    类型设置项目符号或编号的外观。两种浏览器都支持“类型”。

    项目符号图像使您可以为项目符号指定自定义图像。单击“浏览”(Windows) 或“选择”(Macintosh) 通过浏览选择图像，或键入图像的路径。

    位置设置列表项文本是否换行和缩进（外部）以及文本是否换行到左边距（内部）。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其他的样式属性，或单击“确定”。


定义 CSS 样式定位属性

“定位”样式属性使用“层”首选参数中定义层的默认标签，将标签或所选文本块更改为新层。（请参见设置层首选参数和属性。）

若要设置层定位属性，请执行以下操作：

  1. 如果尚未打开“CSS 样式”面板，请打开该面板（按 Shift+F11 键）。
  2. 通过下列操作之一打开“CSS 规则定义”对话框：
    • 添加一个新样式。有关更多信息，请参见创建新的 CSS 规则。
    • 选择一个现有的样式，右键单击以显示内容菜单，然后选择“编辑”打开进行编辑。
    • 选择一个现有样式，然后单击位于“CSS 样式”面板右下角的“编辑样式”按钮。
  3. 在“CSS 规则定义”对话框中，选择“定位”，然后设置所需的样式属性。

    将下列任意属性保留为空（如果它们对于样式并不重要）：

    类型确定浏览器应如何来定位层，如下所示：

    绝对使用“定位”框中输入的坐标相对于页面左上角来放置层。

    相对使用“定位”框中输入的坐标（相对于对象在文档的文本流中的位置）来放置层。该选项不显示在“文档”窗口中。

    静态将层放在它在文本流中的位置。

    显示确定层的初始显示条件。如果不指定可见性属性，则默认情况下大多数浏览器都继承父级的值。选择以下可见性选项之一：

    继承继承层的父级的可见性属性。如果层没有父级，则它将是可见的。

    “可见”显示这些层的内容，而不管父级的值是什么。

    “隐藏”隐藏这些层的内容，而不管父级的值是什么。

    Z 轴确定层的堆叠顺序。编号较高的层显示在编号较低的层的上面。值可以为正，也可以为负。（使用“层”面板更改层的堆叠顺序更容易。请参见更改层的层叠顺序。）

    溢出（仅限于 CSS 层）确定当层的内容超出层的大小时的处理方式。这些属性按以下方式控制层的扩展：

    “可见”增加层的大小，以使其所有内容都可见。层向右下方扩展。

    “隐藏”保持层的大小并剪辑任何超出的内容。不提供任何滚动条。

    “滚动”在层中添加滚动条，不论内容是否超出层的大小。明确提供滚动条可避免滚动条在动态环境中出现和消失所引起的混乱。该选项不显示在“文档”窗口中，并且仅适用于支持滚动条的浏览器。Internet Explorer 和 Netscape Navigator 6 支持此属性。

    “自动”使滚动条仅在层的内容超出层的边界时才出现。该选项不显示在“文档”窗口中。

    “定位”指定层的位置和大小。浏览器如何解释位置取决于“类型”设置。如果层的内容超出指定的大小，则大小值被覆盖。

    位置和大小的默认单位是像素。对于 CSS 层，还可以指定下列单位：pc（十二点活字）、pt（点）、in（英寸）、mm（毫米）、cm（厘米）、(ems)、(exs) 或 %（父级值的百分比）。缩写必须紧跟在值之后，中间不留空格：例如，3mm。

    “剪辑”定义层的可见部分。如果指定了剪辑区域，可以通过脚本语言（如 JavaScript）访问它，并操作属性以创建像擦除这样的特殊效果。使用“改变属性”行为可以设置擦除效果。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其他的样式属性，或单击“确定”。


定义 CSS 样式扩展属性

“扩展”样式属性包括滤镜、分页和指针选项，它们中的大部分不受任何浏览器的支持，或者仅受 Internet Explorer 4.0 和更高版本的支持。

若要指定扩展属性，请执行以下操作：

  1. 如果尚未打开“CSS 样式”面板，请打开该面板（按 Shift+F11 键）。
  2. 通过下列操作之一打开“CSS 规则定义”对话框：
    • 添加一个新样式。有关更多信息，请参见创建新的 CSS 规则。
    • 双击一个现有样式以打开它进行编辑。
  3. 在“CSS 规则定义”对话框中，选择“扩展”，然后设置所需的样式属性。

    将下列任意属性保留为空（如果它们对于样式并不重要）：

    分页在打印期间在样式所控制的对象之前或者之后强行分页。在弹出式菜单中选择要设置的选项。此选项不受任何 4.0 版本浏览器的支持，但可能受未来的浏览器的支持。

    光标当指针位于样式所控制的对象上时改变指针图像。在弹出式菜单中选择要设置的选项。Internet Explorer 4.0 和更高版本以及 Netscape Navigator 6 支持该属性。

    滤镜对样式所控制的对象应用特殊效果（包括模糊和反转）。从弹出式菜单中选择一种效果。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其他的样式属性，或单击“确定”。


设置“附加外部样式表”对话框选项

使用“附加外部样式表”对话框选择 CSS 样式表，并将其附加到当前文档。

若要将外部样式表附加到当前文档，请执行以下操作：

  1. 执行下列操作之一：
    • 单击“浏览”，浏览到外部 CSS 样式表。
    • 在“文件/URL”框中键入该样式表的路径。
  2. 在“添加为”中，选择其中的一个选项：
    • 若要创建当前文档和外部样式表之间的链接，请选择“链接”。该选项在 HTML 代码中创建一个 link href 标签，并引用已发布的样式表所在的 URL。Microsoft Internet Explorer 和 Netscape Navigator 都支持此方法。
    • 不能使用链接标签添加从一个外部样式表到另一个外部样式表的引用。如果要嵌套样式表，必须使用导入指令。某些（但不是所有）浏览器也能识别页面中（而不仅仅在样式表中）的导入命令。当在链接到页面与导入到页面的外部样式表中存在重叠的规则时，解决冲突属性的方式具有细微的差别。如果希望导入而不是链接到外部样式表，请选择“导入”。
  3. 在“媒体”弹出式菜单中，指定样式表的目标媒介。

    有关与媒体相关的样式表的更多信息，请参见 WWW 联合会 Web 站点，网址为 www.w3.org/TR/CSS21/media.html。

  4. 单击“预览”按钮确认样式表是否将所需的样式应用于当前页面。

    如果应用的样式没有达到预期效果，请单击“取消”删除该样式表。页面将回复到原来的外观。

  5. 单击“确定”。

相关主题

  • 链接到或导出外部 CSS 样式表


设置拼写选项

使用“文本”菜单中的“检查拼写”命令可以检查当前文档中的拼写。

若要检查和更正拼写，请执行以下操作：

  1. 选择“文本”>“检查拼写”或按 Shift+F7 键。

    当 Dreamweaver 遇到无法识别的单词时，将出现“检查拼写”对话框。

  2. 根据所需的差异处理方法选择相应的选项：

    添加到私人将无法识别的单词添加到个人字典。

    忽略忽略无法识别的单词的此实例。

    全部忽略忽略无法识别的单词的所有实例。

    更改将无法识别的单词的此实例替换为您在“更改为”文本框中键入的文本或“建议”列表中的选定内容。

    全部更改以相同的方式替换无法识别的单词的所有实例。

相关主题

  • 检查拼写


设置“查找和替换”对话框选项

使用“查找和替换”对话框在文档中搜索文本或标签，并用其他文本或标签替换找到的内容。

若要设置查找和替换选项，请执行以下操作：

  1. 使用“查找在”选项指定要搜索的文件：

    当前文档将搜索范围限制在活动文档。

    打开的文档搜索当前打开的所有文档。

    整个当前本地站点将搜索范围扩展到当前站点中的所有 HTML 文档、库文件和文本文档。

    站点中选定的文件将搜索范围限制在“文件”面板中当前选定的文件和文件夹。

    文件夹将搜索范围限制在特定文件夹。选择“文件夹”后，单击文件夹图标浏览并选择要搜索的文件夹。

    选定文本将搜索范围限定为活动文档中当前选定的文本。

  2. 使用“搜索”弹出式菜单指定要执行的搜索类型：

    源代码使您可以在 HTML 源代码中搜索特定的文本字符串。您可以使用此选项搜索特定标签，但“特定标签”搜索提供了更灵活的搜索标签的方式。

    文本使您可以在文档的文本中搜索特定的文本字符串。文本搜索忽略任何中断字符串的 HTML。例如，对 the black dog 的搜索与 the black dog 和 the <i>black</i> dog 都匹配。

    文本（高级）使您可以搜索或者在标签内或者不在标签内的特定文本字符串。例如，在包含以下 HTML 的文档中，搜索 tries 并指定“不在标签中”，i 标签将只找到单词 tries 的第二个实例：John <i>tries</i> to get his work done on time, but he doesn’t always succeed.He tries very hard.请参见设置“查找和替换”对话框选项以执行高级文本搜索。

    特定标签使您可以搜索特定的标签、属性和属性值，如所有 valign 设置为 top 的 td 标签。（请参见设置“查找和替换”对话框选项以执行特定标签搜索。）

    注意

    按 Ctrl+Enter 键或 Shift+Enter 键 (Windows) 或者按 Control+Return 键、Shift+Return 键或 Command+Return 键 (Macintosh) 可以在文本搜索字段中添加换行符，从而搜索回车符。执行此类搜索时，如果不使用正则表达式，则请取消选择“忽略空白差别”选项。此搜索专门查找回车符，而不是仅查找换行符匹配项；例如，它不查找 <br> 标签或 <p> 标签。回车符在“设计”视图中显示为空格而不是换行符。
  3. 使用下列选项扩展或限制搜索条件：

    区分大小写将搜索范围限制在与要查找的文本的大小写完全匹配的文本。例如，如果搜索 the brown derby，则不会找到 The Brown Derby。

    忽略空白差别将所有空白视为单个空格以便进行匹配。例如，选择该选项后，this text 与 this text 和 this      text 匹配，但不与 thistext 匹配。此选项在选择了“使用正则表达式”选项时不可用；必须显式编写正则表达式以忽略空白。注意，<p> 和 <br> 标签不算作空白。

    匹配整个单词将搜索范围限制在匹配一个或多个完整单词的文本。

    注意

    使用此选项与通过正则表达式搜索以 \b（词边界正则表达式）开始和结束的字符串效果相同。

    使用正则表达式使搜索字符串中的特定字符和短字符串（如 ?、*、\w 和 \b）被解释为正则表达式运算符。例如，对 the b\w*\b dog 的搜索与 the black dog 和 the barking dog 都匹配。（请参见正则表达式。）

    注意

    如果您在“代码”视图中工作并对文档进行了更改，然后试图查找和替换源代码以外的任何内容，这时会出现一个对话框，通知您 Dreamweaver 正在同步两个视图然后再进行搜索。有关同步视图的更多信息，请参见查看您的代码。
  4. 若要进行搜索而不替换，请单击“查找下一个”或“查找全部”按钮：

    查找下一个跳转到并选择当前文档中搜索文本或标签的下一个匹配项。如果当前文档中不存在该标签的更多实例，Dreamweaver 将进入下一个文档（如果您在多个文档中搜索）。

    查找全部在“结果”面板组中打开“搜索”面板。如果正在单个文档中搜索，“查找全部”将显示搜索文本或标签的所有匹配项，并带有部分上下文。如果正在目录或站点中搜索，“查找全部”将显示包含该标签的文档的列表。

  5. 若要替换找到的文本或标签，请单击“替换”或“全部替换”按钮。

相关主题

  • 搜索和替换文本
  • 搜索和替换标签和属性


设置“查找和替换”对话框选项以执行特定标签搜索

使用“查找和替换”对话框在文档中搜索文本或标签，并用其他文本或标签替换找到的内容。

若要设置查找和替换选项执行特定标签搜索，请执行以下操作：

  1. 从“搜索”弹出式菜单中，选择“特定标签”。
  2. 从“搜索”弹出式菜单旁边的弹出式菜单中选择一个特定的标签或 [任何标签]，或在文本框中键入标签名。
  3. （可选。）使用以下标签修饰符之一限制搜索：

    含有属性指定一个属性，匹配的标签必须含有该属性。您可为该属性指定特定的值或者选择 [任何值]。

    不含属性选择一个属性，匹配的标签必须不含该属性。例如，可以选择此选项搜索不具有 alt 属性的所有 img 标签。

    包含指定文本或标签，匹配的原始标签必须包含该文本或标签。例如，在代码 <b><font size="4">heading 1</font></b> 中，font 标签包含在 b 标签内。

    不包含指定文本或标签，匹配的原始标签必须不含该文本或标签。

    在标签中指定一个标签，匹配的目标标签必须包含在该标签内。

    不在标签中指定一个标签，匹配的目标标签必须不在该标签内。

  4. （可选。）若要进一步限制搜索，请单击加号 (+) 按钮并重复第 3 步。
  5. 如果在第 3 步和第 4 步中没有应用任何标签修饰符，则请单击减号 (-) 按钮删除标签修饰符弹出式菜单。
  6. 如果要在找到标签的时候执行某种操作（如删除或替换标签），请从“动作”弹出式菜单中选择操作，如果适用，请指定执行该操作所必需的任何其他信息。
  7. 按照设置“查找和替换”对话框选项中的步骤设置其他选项并启动搜索。


设置“查找和替换”对话框选项以执行高级文本搜索

使用“查找和替换”对话框在文档中搜索文本或标签，并用其他文本或标签替换找到的内容。

若要设置查找和替换选项以执行高级文本搜索，请执行以下操作：

  1. 从“搜索”弹出式菜单中，选择“文本（高级）”。
  2. 在“搜索”弹出式菜单旁边的文本字段中输入文本。

    例如，键入 Untitled 一词。

  3. 选择“在标签中”或“不在标签中”，然后从相邻的弹出式菜单中选择一个标签。

    例如，选择“在标签中”，然后选择 title。

  4. （可选。）单击加号 (+) 按钮使用以下标签修饰符之一限制搜索：

    含有属性指定一个属性，匹配的标签必须含有该属性。您可为该属性指定特定的值或者选择 [任何值]。

    不含属性选择一个属性，匹配的标签必须不含该属性。例如，可以选择此选项搜索不具有 alt 属性的所有 img 标签。

    包含指定文本或标签，匹配的原始标签必须包含该文本或标签。例如，在代码 <b><font size="4">heading 1</font></b> 中，font 标签包含在 b 标签内。

    不包含指定文本或标签，匹配的原始标签必须不含该文本或标签。

    在标签中指定一个标签，匹配的目标标签必须包含在该标签内。

    不在标签中指定一个标签，匹配的目标标签必须不在该标签内。

  5. （可选。）若要进一步限制搜索，请重复第 4 步。
  6. 按照设置“查找和替换”对话框选项中的步骤设置其他选项并启动搜索。


设置“搜索”面板选项

“搜索”面板（位于“结果”面板组中）显示“查找全部”搜索的结果。

若要在上下文中查看特定的搜索结果，请执行以下操作：

  • 在“搜索”面板中双击某行。

    如果正在当前文件中搜索，“文档”窗口将显示包含搜索结果的行。

    如果正在一组文件中搜索，将打开包含搜索结果的文件。

若要再次执行相同的搜索，请执行以下操作：

  • 单击“查找和替换”按钮。

若要停止正在进行中的搜索，请执行以下操作：

  • 单击“停止”按钮。


设置“选择性粘贴”对话框选项

使用“选择性粘贴”对话框可以指定从其他应用程序或从 Dreamweaver 中粘贴的文本的格式设置选项。

若要完成“选择性粘贴”对话框，请执行以下操作：

  1. 选择以下项之一：

    仅文本粘贴无格式的文本。如果原始文本带有格式，所有格式设置（包括分行和段落）都将被删除。

    带结构的文本粘贴文本并保留结构，但不保留基本格式设置。例如，您可以粘贴文本并保留段落、列表和表格的结构，但是不保留粗体、斜体和其他格式设置。

    带结构的文本以及基本格式可以粘贴结构化并带简单 HTML 格式的文本（例如，段落和表格以及带有 b、i、u、strong、em、hr、abbr 或 acronym 标签的格式化文本）。

    带结构的文本以及全部格式可以粘贴文本并保留所有结构、HTML 格式设置和 CSS 样式。

    注意

    “完整格式”选项不能保留来自外部样式表的 CSS 样式，如果要粘贴的应用程序在粘贴到剪贴板时没有保留样式，此选项也不能保留样式。
  2. 选择“保留换行符”可保留所粘贴的文本中的换行符。

    如果选择了“仅文本”，则此选项将被禁用。

  3. 如果选择了“带结构的文本”或“带结构的文本以及基本格式”，并想在粘贴文本时删除段落之间的多余空白，请选择“清理 Word 段落间距”。
  4. 如果需要，可以通过单击“粘贴首选参数”，选择相应的选项，然后单击“确定”，来设置默认选项，以从其他应用程序中进行粘贴。
  5. 单击“确定”。


设置“复制/粘贴首选参数”对话框

使用“复制/粘贴首选参数”对话框设置默认选项，以从其他应用程序中粘贴文本。

注意

在此对话框中设置的首选参数仅应用于粘贴到“设计视图”中的内容。

若要完成“复制/粘贴首选参数”对话框，请执行以下操作：

  1. 选择以下项之一：

    仅文本粘贴无格式的文本。如果原始文本带有格式，所有格式设置（包括分行和段落）都将被删除。

    带结构的文本粘贴文本并保留结构，但不保留基本格式设置。例如，您可以粘贴文本并保留段落、列表和表格的结构，但是不保留粗体、斜体和其他格式设置。

    带结构的文本以及基本格式可以粘贴结构化并带简单 HTML 格式的文本（例如，段落和表格以及带有 b、i、u、strong、em、hr、abbr 或 acronym 标签的格式化文本）。

    带结构的文本以及全部格式可以粘贴文本并保留所有结构、HTML 格式设置和 CSS 样式。

    注意

    “完整格式”选项不能保留来自外部样式表的 CSS 样式，如果要粘贴的应用程序在粘贴到剪贴板时没有保留样式，此选项也不能保留样式。
  2. 选择“保留换行符”可保留所粘贴的文本中的换行符。

    如果选择了“仅文本”，则此选项将被禁用。

  3. 如果选择了“带结构的文本”或“带结构的文本以及基本格式”，并想在粘贴文本时删除段落之间的多余空白，请选择“清理 Word 段落间距”。
  4. 单击“确定”。


设置“插入文档”对话框选项

使用“插入文档”对话框可指定是插入文档的完整内容，还是在 Web 页面中创建一个指向文档的链接。如果插入文档的完整内容，您还可以指定要插入的文本的格式选项。

若要完成对话框选项，请执行以下操作：

  1. 如果要将文档的完整内容插入到页面，请选择“插入内容”，然后选择以下选项之一：

    仅文本可以插入无格式文本。如果原始文本带格式，所有格式将被删除。

    带结构的文本可以插入文本并保留结构，但不保留基本格式设置。例如，您可以粘贴文本并保留段落、列表和表格的结构，但是不保留粗体、斜体和其他格式设置。

    带结构的文本以及基本格式可以插入结构化并带简单 HTML 格式的文本（例如，段落和表格以及带有 b、i、u、strong、em、hr、abbr 或 acronym 标签的格式化文本）。

    带结构的文本以及全部格式可以插入文本并保留所有结构、HTML 格式设置和 CSS 样式。

    注意

    “完整格式”选项不能保留来自外部样式表的 CSS 样式，如果要粘贴的应用程序在粘贴到剪贴板时没有保留样式，此选项也不能保留样式。

    如果选择了“带结构的文本”或“基本格式”，则粘贴文本时可以使用清理 Word 段落间距清除段落间的多余空格。

  2. 但如果要创建指向文档的链接，请选择“创建链接”。
  3. 单击“确定”。


设置“重命名类”或“重命名样式”对话框选项

此对话框使您可以重命名 CSS 类。

若要设置对话框选项，请执行以下操作：

  • 输入一个新的名称，然后单击“确定”。


插入图像

在 Macromedia Dreamweaver 8 中，您可以在“设计”视图或“代码”视图中将图像插入文档。在 Dreamweaver 文档中添加图像时，可以设置或修改图像属性并直接在“文档”窗口中查看所做的更改。

若要建立一个高效的 Web 设计工作流程，您可以选择图像编辑器首选参数，然后当您在 Dreamweaver 中工作时自动启动它来编辑图像。

本章包含下列章节：

关于图像

插入图像

调整图像大小

裁剪图像

使用 Fireworks 优化图像

调整图像的亮度和对比度

锐化图像

创建鼠标经过图像

使用外部图像编辑器

将行为应用于图像


关于图像

虽然存在很多种图形文件格式，但 Web 页面中通常使用的只有三种，即 GIF、JPEG 和 PNG。目前，GIF 和 JPEG 文件格式的支持情况最好，大多数浏览器都可以查看它们。

由于 PNG 文件具有较大的灵活性并且文件大小较小，所以它对于几乎任何类型的 Web 图形都是最适合的；但是，Microsoft Internet Explorer（4.0 和更高版本）和 Netscape Navigator（4.04 和更高版本）只能部分支持 PNG 图像的显示。因此，除非您正在为使用支持 PNG 格式的浏览器的特定目标用户进行设计，否则请使用 GIF 或 JPEG 以迎合更多人的需求。

GIF（图形交换格式）文件最多使用 256 种颜色，最适合显示色调不连续或具有大面积单一颜色的图像，例如导航条、按钮、图标、徽标或其它具有统一色彩和色调的图像。

JPEG（联合图像专家组标准）文件格式是用于摄影或连续色调图像的高级格式，这是因为 JPEG 文件可以包含数百万种颜色。随着 JPEG 文件品质的提高，文件的大小和下载时间也会随之增加。通常可以通过压缩 JPEG 文件在图像品质和文件大小之间达到良好的平衡。

PNG（可移植网络图形）文件格式是一种替代 GIF 格式的无专利权限制的格式，它包括对索引色、灰度、真彩色图像以及 alpha 通道透明的支持。PNG 是 Macromedia Fireworks 固有的文件格式。PNG 文件可保留所有原始层、矢量、颜色和效果信息（例如阴影），并且在任何时候所有元素都是可以完全编辑的。文件必须具有 .png 文件扩展名才能被 Dreamweaver 识别为 PNG 文件。


在 Dreamweaver 中编辑图像

Dreamweaver 提供基本图像编辑功能，使您无需使用外部图像编辑应用程序（例如 Macromedia Fireworks）即可修改图像。Dreamweaver 图像编辑工具旨在使您能与内容设计者（负责创建 Web 站点上使用的图像文件）轻松地协作。

注意

您无需在计算机上安装 Macromedia Fireworks，即可使用 Dreamweaver 图像编辑功能。

Dreamweaver 具有以下图像编辑功能：

图像重新取样添加或减少已调整大小的 JPEG 和 GIF 图像文件中的像素，以与原始图像的外观尽可能地匹配。对图像进行重新取样会减小图像文件的大小，其结果是下载性能的提高。

在 Dreamweaver 中重新调整图像的大小时，您可以对图像进行重新取样，以容纳其新尺寸。重新取样位图对象时，会在图像中添加或删除像素，以使其变大或变小。重新取样图像以取得更高的分辨率一般不会导致品质下降。但重新取样以取得较低的分辨率总会导致数据丢失，并且通常会使品质下降。

裁剪可让您通过减小图像区域编辑图像。通常，您可能需要裁剪图像以强调图像的主题，并删除图像中强调部分周围不需要的部分。

亮度/对比度修改图像中像素的亮度或对比度。这将影响图像的高亮显示、阴影和中间色调。修正过暗或过亮的图像时通常使用“亮度/对比度”。

锐化可通过增加图像中边缘的对比度来调整图像的焦点。扫描图像或拍摄数码照片时，大多数图像捕获软件的默认操作是柔化图像中各对象的边缘。这可以防止特别精细的细节从组成数码图像的像素中丢失。不过，要显示数码图像文件中的细节，经常需要锐化图像，从而提高边缘的对比度，使图像更清晰。

注意

Dreamweaver 图像编辑功能仅适用于 JPEG 和 GIF 图像文件格式。其它位图图像文件格式不能使用这些图像编辑功能编辑。

相关主题

  • 调整图像大小
  • 裁剪图像
  • 调整图像的亮度和对比度
  • 锐化图像


插入图像

在您将图像插入 Dreamweaver 文档时，Dreamweaver 自动在 HTML 源代码中生成对该图像文件的引用。为了确保此引用的正确性，该图像文件必须位于当前站点中。如果图像文件不在当前站点中，Dreamweaver 会询问您是否要将此文件复制到当前站点中。

您还可以动态插入图像。动态图像指那些经常变化的图像。例如，广告横幅旋转系统需要在请求页面时从可用横幅列表中随机选择一个横幅，然后动态显示所选横幅的图像。有关更多信息，请参见将图像动态化。

若要插入图像，请执行以下操作：

  1. 在“文档”窗口中，将插入点放置在您要显示图像的地方，然后执行以下操作之一：
    • 在“插入”栏的“常用”类别中，单击“图像”图标。 这是所描述的功能的图片。
    • 在“插入”栏的“常用”类别中，将“图像”图标拖入“文档”窗口中（或者，如果您正处理代码，则拖入“代码”视图窗口中）。
    • 选择“插入”>“图像”。
    • 将图像从“资源”面板（“窗口”>“资源”）拖到“文档”窗口中的所需位置；然后跳到第 3 步。
    • 将图像从“站点”面板拖到“文档”窗口中的所需位置；然后跳到第 3 步。
    • 将图像从桌面拖到“文档”窗口中的所需位置；然后跳到第 3 步。
  2. 在出现的对话框中执行下列操作之一：
    • 选择“文件系统”以选择一个图形文件。
    • 选择“数据源”以选择一个动态图像源。
  3. 浏览以选择您要插入的图像或内容源。

    如果您正在一个未保存的文档中工作，则 Dreamweaver 生成一个对图像文件的 file:// 引用。将文档保存到站点中的任何位置后，Dreamweaver 将该引用转换为文档相对路径。

  4. 单击“确定”。

    将显示“图像标签辅助功能属性”对话框（如果已在“首选参数”中激活了此对话框，请参见优化工作区以进行有辅助功能的页面设计）。

  5. 在“替代文本”和“长描述”文本框中输入值，然后单击“确定”。

    注意

    根据您的需要，可以在其中一个或两个文本框中输入信息。

    有关更多信息，请参见设置“图像标签辅助功能属性”对话框选项。

    该图像出现在文档中。

    注意

    当您单击“取消”时，该图像将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。
  6. 在“属性”检查器（“窗口”>“属性”）中，设置该图像的属性。

    有关更多信息，请参见设置图像属性。

    若要编辑该图像的辅助功能属性，请参见编辑图像的辅助功能属性。

相关主题

  • 设置背景图像或背景页面颜色
  • 使用间隔图像

编辑图像的辅助功能属性

如果插入了图像的辅助功能属性（请参见插入图像），则可以在 HTML 代码中编辑这些值。

若要编辑图像的辅助功能值，请执行以下操作：

  1. 在“文档”窗口中，选择图像。
  2. 执行下列操作之一：
    • 在“代码”视图中编辑适当的图像属性。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“编辑标签代码”。
    • 编辑“属性”检查器中的 Alt 值。


插入图像占位符

图像占位符是在准备好将最终图形添加到 Web 页面之前使用的图形。

若要插入图像占位符，请执行以下操作：

  1. 在“文档”窗口中，将插入点放置在要插入占位符图形的位置。
  2. 执行下列操作之一：
    • 在“常用”插入栏中，单击“图像占位符”图标。 这是所描述的功能的图片。
    • 选择“插入”>“图像占位符”。

    “图像占位符”对话框随即显示。

  3. 在该对话框中，为图像占位符选择选项。

    您可以设置占位符的大小和颜色，并为占位符提供文本标签。有关设置这些选项的详细信息，请参见完成“图像占位符”对话框。

  4. 单击“确定”。

占位符的颜色、大小属性和标签如下所示：

当在浏览器中查看时，不显示标签文字和大小文本。

相关主题

  • 替换图像占位符
  • 调整图像大小
  • 设置图像占位符属性
  • 使用 Fireworks 修改 Dreamweaver 图像占位符

替换图像占位符

图像占位符不是在浏览器中显示的图形图像。在您发布站点之前，应该用适用于 Web 的图形文件（例如 GIF 或 JPEG）替换所有添加的图像占位符。

如果您有 Fireworks，则可以根据 Dreamweaver 图像占位符创建新的图形。新图像设置为与占位符图像相同的大小。您可以编辑该图像，然后在 Dreamweaver 中替换它。有关在 Fireworks 中创建替换图像的信息，请参见使用 Fireworks 修改 Dreamweaver 图像占位符。

若要更新图像源文件，请执行以下操作：

  1. 在“文档”窗口中执行下列操作之一：
    • 双击图像占位符。
    • 单击图像占位符将其选中，然后在“属性”检查器（“窗口”>“属性”）中单击“源文件”文本框旁的文件夹图标。

    即会出现“图像源文件”对话框。

  2. 在此对话框中，导航到要使用它替换图像占位符的图像。
  3. 单击“确定”。

    选定图像即出现在文档中。


对齐图像

您可以将图像与同一行中的文本、另一个图像、插件或其它元素对齐。还可以设置图像的水平对齐方式。

若要对齐图像，请执行以下操作：

  1. 在“设计”视图中选择该图像。
  2. 在“属性”检查器中设置该图像的对齐属性。

您可以设置相对于同一段落或行中的其它元素的对齐方式。

注意

HTML 不提供某些字处理应用程序中提供的文本环绕图像轮廓换行的方法。

对齐选项如下：

默认值通常指定基线对齐。（根据站点访问者的浏览器的不同，默认值也会有所不同。）

基线和底部将文本（或同一段落中的其它元素）的基线与选定对象的底部对齐。

顶端将图像的顶端与当前行中最高项（图像或文本）的顶端对齐。

居中将图像的中部与当前行的基线对齐。

文本上方将图像的顶端与文本行中最高字符的顶端对齐。

绝对居中将图像的中部与当前行中文本的中部对齐。

绝对底部将图像的底部与文本行（这包括字母下部，例如在字母 g 中）的底部对齐。

左对齐将所选图像放置在左边，文本在图像的右侧换行。如果左对齐文本在行上处于对象之前，它通常强制左对齐对象换到一个新行。

右对齐将图像放置在右边，文本在对象的左侧换行。如果右对齐文本在行上处于对象之前，它通常强制右对齐对象换到一个新行。


调整图像大小

您可以在 Dreamweaver 中以可视化的形式调整元素的大小，这些元素包括图像、插件、Macromedia Shockwave 或 Flash 文件、applet 和 ActiveX 控件等。

在 Dreamweaver 中以可视方式调整图像大小有助于您看到不同尺寸的图像对布局的影响情况。以可视方式调整图像大小不会将图像文件缩放您指定的比例。如果您确实在 Dreamweaver 中以可视方式调整了图像的大小，但是没有使用图像编辑应用程序（例如 Macromedia Fireworks）将图像文件缩放到所需大小，则在载入页面时用户的浏览器必须缩放图像。这可能会导致用户浏览器中页面下载延迟和图像显示不正确。若要缩短下载时间并确保所有图像实例以相同大小显示，请使用图像编辑应用程序缩放图像。

若要以可视方式调整元素的大小，请执行以下操作：

  1. 在“文档”窗口中选择该元素（例如，一个图像或 SWF 文件）。

    元素的底部、右侧及右下角出现调整大小控制点。如果未出现调整大小控制点，则单击要调整大小的元素以外的部分然后重新选择它，或在标签选择器中单击相应的标签以选择该元素。

  2. 执行下列操作之一，调整元素的大小：
    • 若要调整元素的宽度，请拖动右侧的选择控制点。
    • 若要调整元素的高度，请拖动底部的选择控制点。
    • 若要同时调整元素的宽度和高度，请拖动顶角的选择控制点。
    • 若要在调整元素尺寸时保持元素的比例（其宽高比），请在按住 Shift 键的同时拖动顶角的选择控制点。

以可视方式最小可以将元素大小调整到 8 x 8 像素。若要将元素的宽度和高度调整到更小的大小（例如 1 x 1 像素），请使用“属性”检查器输入数值。

若要将已调整大小的元素返回到原始尺寸，请在“属性”检查器中删除“宽”和“高”文本框中的值，或者单击“重设大小”按钮。

若要将图像回复到其原始大小，请执行以下操作：

  • 单击图像“属性”检查器中的“重设大小”按钮。 这是所描述的功能的图片。

若要重新取样已调整大小的图像，请执行以下操作：

  1. 如上所述，调整图像大小。
  2. 单击图像“属性”检查器中的“重新取样”按钮。 这是所描述的功能的图片。

    注意

    无法重新取样图像占位符或位图图像之外的元素。

相关主题

  • 在 Dreamweaver 中编辑图像


裁剪图像

Dreamweaver 支持裁剪（或修剪）位图文件图像。

注意

使用 Dreamweaver 裁剪时，会更改磁盘上的源图像文件，因此，您可能需要备份图像文件，以在需要回复到原始图像时使用。

若要裁剪图像文件，请执行以下操作：

  1. 打开包含要裁剪的图像的页面，选择图像，并执行下列操作之一：
    • 单击图像属性检查器中的“裁减工具”图标。 这是所描述的功能的图片。
    • 选择“修改”>“图像”>“裁剪”。

    所选图像周围会出现裁剪控制点。

  2. 调整裁剪控制点直到边界框包含的图像区域符合所需大小。
  3. 在边界框内部双击或按 Enter 键裁剪所选区域。

    将显示一个对话框通知您正在裁剪的图像文件将在磁盘上更改。单击“确定”。

    所选位图的边界框外的所有像素都将被删除，但将保留图像中的其它对象。

  4. 预览该图像并确保它满足您的要求。

若要撤消裁剪命令的效果，请执行以下操作：

  • 选择“编辑”>“撤消裁剪”回复原始图像。

    在退出 Dreamweaver 或在外部图像编辑应用程序中编辑该文件之前，您可以撤消“裁剪”命令的效果（并回复到原始图像文件）。

相关主题

  • 在 Dreamweaver 中编辑图像
  • 调整图像的亮度和对比度
  • 锐化图像


使用 Fireworks 优化图像

您可以在 Dreamweaver 中优化 Web 页面中的图像。

若要优化图像，请执行以下操作：

  1. 打开包含要优化的图像的页面，选择图像，并执行下列操作之一：
    • 单击图像属性检查器中的“在 Fireworks 中优化”按钮。 这是所描述的功能的图片。
    • 选择“修改”>“图像”>“在 Fireworks 中优化图像”。

    将显示“Fireworks 优化图像”对话框。

  2. 单击“确定”。

相关主题

  • 在 Dreamweaver 中编辑图像
  • 插入图像
  • 裁剪图像
  • 锐化图像


调整图像的亮度和对比度

“亮度/对比度”修改图像中像素的亮度或对比度。这将影响图像的高亮显示、阴影和中间色调。修正过暗或过亮的图像时通常使用“亮度/对比度”。

若要调整图像的亮度和对比度，请执行以下操作：

  1. 打开包含要调整的图像的页面，选择图像，并执行下列操作之一：
    • 单击图像“属性”检查器中的“亮度/对比度”按钮。 这是所描述的功能的图片。
    • 选择“修改”>“图像”>“亮度/对比度”

    将显示“亮度/对比度”对话框。

  2. 拖动亮度和对比度滑动块调整设置。

    值的范围从 -100 到 100。

  3. 单击“确定”。

相关主题

  • 在 Dreamweaver 中编辑图像
  • 插入图像
  • 裁剪图像
  • 锐化图像


锐化图像

锐化将增加对象边缘的像素的对比度，从而增加图像清晰度或锐度。

若要锐化图像，请执行以下操作：

  1. 打开包含要锐化的图像的页面，选择图像，并执行下列操作之一：
    • 单击图像属性检查器中的“锐化”按钮。 这是所描述的功能的图片。
    • 选择“修改”>“图像”>“锐化”。

    将显示“锐化”对话框。

  2. 可以通过拖动滑块控件或在文本框中输入一个 0 到 10 之间的值，来指定 Dreamweaver 应用于图像的锐化程度。

    在使用“清晰度”对话框调整图像的清晰度时，可以预览对该图像所做的更改。

  3. 单击“确定”。
  4. 选择“文件”>“保存”以保存更改，或选择“编辑”>“撤消锐化”回复到原始图像。

若要撤消锐化命令的效果，请执行以下操作：

  • 选择“编辑”>“撤消锐化”回复到原始图像。

    只能在保存包含图像的页面之前撤消“锐化”命令的效果（并回复到原始图像文件）。页面一旦保存，对图像所做更改即永久保存。

相关主题

  • 在 Dreamweaver 中编辑图像
  • 裁剪图像
  • 调整图像的亮度和对比度


创建鼠标经过图像

您可以在页面中插入鼠标经过图像。鼠标经过图像是一种在浏览器中查看并使用鼠标指针移过它时发生变化的图像。

开始前，请选用一对或多对图像用于鼠标经过图像。您将使用两个图像文件创建鼠标经过图像：主图像（当首次载入页时显示的图像）和次图像（当鼠标指针移过主图像时显示的图像）。鼠标经过图像中的这两个图像应大小相等；如果这两个图像大小不同，Dreamweaver 将自动调整第二个图像的大小以匹配第一个图像的属性。

鼠标经过图像自动设置为响应 onMouseOver 事件。有关设置图像以响应不同事件（例如，鼠标单击）或有关编辑鼠标经过图像以显示不同图像的信息，请参见交换图像。

若要创建鼠标经过图像，请执行以下操作：

  1. 在“文档”窗口中，将插入点放置在要显示鼠标经过图像的位置。
  2. 使用以下方法之一插入鼠标经过图像：
    • 在“插入”栏中，选择“常用”，然后单击“鼠标经过图像”图标。
    • 在“插入”栏中，选择“常用”，然后将“鼠标经过图像”图标拖到“文档”窗口中的所需位置。
    • 选择“插入”>“交互式图像”>“鼠标经过图像”。

      随即显示“插入鼠标经过图像”对话框。

  3. 完成对话框。

    有关更多信息，请参见设置“鼠标经过图像”对话框选项。

  4. 单击“确定”。
  5. 选择“文件”>“在浏览器中预览”，或按 F12 键。

    不能在“设计”视图中看到鼠标经过图像的效果。

  6. 在浏览器中，将鼠标指针移过原始图像。

    显示应切换到鼠标经过图像。

相关主题

  • 插入导航条


使用外部图像编辑器

在 Dreamweaver 中工作时，您可以在外部图像编辑器中打开选定的图像；在保存了编辑完的图像文件并返回到 Dreamweaver 时，可以在“文档”窗口中看到您对图像所做的任何更改。

您可以设置 Fireworks 作为首选外部编辑器。有关更多信息，请参见使用 Fireworks。

若要启动外部图像编辑器，请执行以下操作之一：

  • 双击要编辑的图像。
  • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 要编辑的图像，然后选择“编辑以”>“浏览”并选择一个编辑器。
  • 选择要编辑的图像，然后在“属性”检查器中单击“编辑”。
  • 在“站点”面板中双击图像文件，启动主图像编辑器。如果您尚未指定图像编辑器，Dreamweaver 将启动该文件类型的默认编辑器。

    注意

    当您从“站点”面板打开图像时，Fireworks 集成功能不会起作用；Fireworks 不打开原始 PNG 文件。若要使用 Fireworks 的集成功能，请从“文档”窗口内打开图像。

如果在返回到 Dreamweaver 窗口后没有看到更新的图像，则选择该图像，然后在“属性”检查器中单击“刷新”按钮。

相关主题

  • 指定从 Dreamweaver 启动的编辑器
  • 设置外部图像编辑器首选参数


将行为应用于图像

您可以将任何可用行为应用于图像或图像热点。在您将一个行为应用于热点时，Dreamweaver 将 HTML 源代码插入 area 标签中。以下三种行为是专门应用于图像的：预先载入图像、交换图像和恢复交换图像。

“预先载入图像”将不会立即出现在页面上的图像（例如那些将通过行为、层或 JavaScript 换入的图像）载入浏览器缓存中。这样可防止当图像应该出现时由于下载而导致延迟。（请参见预先载入图像。）

“交换图像”通过更改 img 标签的 SRC 属性将一个图像与另一个图像交换。使用此动作可创建按钮鼠标经过图像和其它图像效果（包括一次交换多个图像）。（请参见交换图像。）

“恢复交换图像”将最后一组交换的图像恢复为以前的源文件。每次您将“交换图像”动作附加到某个对象时 Dreamweaver 都默认自动添加该动作；您从不需要手动选择它。（请参见恢复图像交换。）

您还可以使用行为创建更复杂的导航系统，例如导航条或跳转菜单。（请参见使用导航条和插入跳转菜单。）


参考资料

本节提供有关本章中介绍的下列面板、对话框和检查器的信息。

  • 设置图像属性
  • 设置“图像标签辅助功能属性”对话框选项
  • 设置“图像说明”对话框选项
  • 完成“图像占位符”对话框
  • 设置图像占位符属性
  • 设置外部图像编辑器首选参数
  • 设置“鼠标经过图像”对话框选项
  • 设置“亮度和对比度”对话框选项
  • 设置“锐化图像”对话框选项


设置图像属性

此“属性”检查器允许您设置图像的属性。如果您没有看到下面屏幕抓图所示的所有图像属性，请单击右下角的扩展箭头。

若要设置图像属性，请执行以下操作：

  1. 使用缩略图下面的文本框设置名称，以便在使用 Dreamweaver 行为（例如“交换图像”）或脚本撰写语言（例如 JavaScript 或 VBScript）时可以引用该图像。
  2. 设置以下任一选项：

    宽和高以像素为单位指定图像的宽度和高度。当您在页中插入图像时，Dreamweaver 自动用图像的原始尺寸更新这些文本框。

    如果您设置的“宽”和“高”的值与图像的实际宽度和高度不相符，则该图像在浏览器中可能不会正确显示。（若要恢复原始值，请单击“宽”和“高”文本框标签，或单击用于输入新值的“宽”和“高”文本框右侧的“重设图像大小”按钮。）

    注意

    您可以更改这些值来缩放该图像实例的显示大小，但这不会缩短下载时间，因为浏览器在缩放图像前会下载所有图像数据。若要缩短下载时间并确保所有图像实例以相同大小显示，请使用图像编辑应用程序缩放图像。

    源文件指定图像的源文件。单击文件夹图标以浏览到源文件，或者键入路径。

    有关动态图像源文件的信息，请参见将图像动态化。

    链接指定图像的超级链接。将“指向文件”图标拖到“站点”面板中的某个文件，单击文件夹图标浏览到站点上的某个文档，或手动键入 URL。有关创建链接的信息，请参见创建链接。

    对齐对齐同一行上的图像和文本。（请参见对齐图像。）

    替代指定只显示文本的浏览器或已设置为手动下载图像的浏览器中代替图像显示的替代文本。对于使用语音合成器（用于只显示文本的浏览器）的有视觉障碍的用户，将大声读出该文本。在某些浏览器中，当鼠标指针滑过图像时也会显示该文本。

    地图名称和热点工具允许您标注和创建客户端图像地图。（请参见使用图像地图。）

    垂直边距和水平边距沿图像的边缘添加边距（以像素为单位）。“垂直边距”沿图像的顶部和底部添加边距。“水平边距”沿图像左侧和右侧添加边距。

    目标指定链接的页应当在其中载入的框架或窗口。（当图像没有链接到其它文件时，此选项不可用。）当前框架集中所有框架的名称都显示在“目标”列表中。也可选用下列保留目标名：

    • _blank 将链接的文件载入一个未命名的新浏览器窗口中。
    • _parent 将链接的文件载入含有该链接的框架的父框架集或父窗口中。如果包含链接的框架不是嵌套的，则链接文件加载到整个浏览器窗口中。
    • _self 将链接的文件载入该链接所在的同一框架或窗口中。此目标是默认的，所以通常不需要指定它。
    • _top 将链接的文件载入整个浏览器窗口中，因而会删除所有框架。

    低解析度源指定在载入主图像之前应该载入的图像。许多设计人员使用主图像的 2 位（黑和白）版本，因为它可以迅速载入并使访问者对他们等待看到的内容有所了解。

    边框是以像素为单位的图像边框的宽度。默认为无边框。

    编辑启动您在“外部编辑器”首选参数中指定的图像编辑器并打开选定的图像。有关设置外部图像编辑器的信息，请参见使用外部图像编辑器。

    优化打开“优化”对话框。 这是所描述的功能的图片。 有关优化图像的信息，请参见在 Dreamweaver 中优化 Fireworks 图像。

    裁剪 这是所描述的功能的图片。 可让您修剪图像的大小，从所选图像中删除不需要的区域。有关在 Dreamweaver 中编辑图像的信息，请参见在 Dreamweaver 中编辑图像。

    重新取样 这是所描述的功能的图片。 可让您对已调整大小的图像进行重新取样，提高图片在新的大小和形状下的品质。有关在 Dreamweaver 中编辑图像的信息，请参见在 Dreamweaver 中编辑图像。

    亮度和对比度可让您调整图像的亮度和对比度设置。 这是所描述的功能的图片。 有关在 Dreamweaver 中调整图像的亮度和对比度设置的信息，请参见在 Dreamweaver 中编辑图像。

    锐化可让您调整图像的清晰度。 这是所描述的功能的图片。 有关在 Dreamweaver 中调整图像清晰度的信息，请参见在 Dreamweaver 中编辑图像。

    重设大小 这是所描述的功能的图片。 将“宽”和“高”的值重设为图像的原始大小。调整所选图像的值时，此按钮显示在“宽”和“高”文本框的右侧。


设置“图像标签辅助功能属性”对话框选项

此对话框用于设置图像标签辅助功能选项。根据您的需要，可以输入一项或两项属性。屏幕阅读器会朗读图像的 Alt 属性。

若要设置图像标签辅助功能选项，请执行以下操作：

  1. 在“Alt”文本框中，为图像输入一个名称或一段简短描述。

    屏幕阅读器会朗读您在此处输入的信息。您的输入应限制在 50 个字符左右。对于较长的描述，请考虑在“长描述”文本框中提供链接，指向提供该图像更多信息的文件。

  2. 在“长描述”文本框中，输入当用户单击图像时显示的文件的位置，或者单击文件夹图标以浏览到该文件。

    该文本框提供指向与图像相关（或提供有关图像的更多信息）的文件的链接。

  3. 单击“确定”。

    注意

    当您按“取消”时，该图像将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

相关主题

  • 插入图像


设置“图像说明”对话框选项

此对话框用于指定图像说明。屏幕阅读器将阅读此图像说明。

要指定图像说明，请执行以下操作：

  1. 在“图像说明（替代文本）”文本框中，为图像输入一个名称或一段简短描述。

    屏幕阅读器会朗读您在此处输入的信息。您的输入应限制在 50 个字符左右。

  2. 单击“确定”。


完成“图像占位符”对话框

此对话框用于创建图像占位符图形。

若要创建图像占位符图形，请执行以下操作：

  1. 在“名称”文本框中，输入要作为图像占位符的标签文字显示的文本。这是可选步骤；如果不想显示标签文字，可将此文本框留空。

    名称必须以字母开头，并且只能包含字母和数字；不允许使用空格和高位 ASCII 字符。

  2. （必需）在“宽度”和“高度”文本框中，以像素为单位键入数字以设置图像大小。
  3. （可选）对于“颜色”，执行以下操作之一以应用颜色：
    • 使用颜色选择器选择一种颜色。
    • 输入颜色的十六进制值（例如 #FF0000）。
    • 输入网页安全色名称（例如 red）。
  4. （可选）在“替代文本”中，为使用只显示文本的浏览器的访问者输入描述该图像的文本。
  5. 单击“确定”。

    文档中即会出现图像占位符。

    注意

    HTML 代码中将自动插入一个包含空 src 属性的图像标签。


设置图像占位符属性

若要设置图像占位符的属性，请在“文档”窗口中选择图像占位符；然后选择“窗口”>“属性”以显示“属性”检查器。若要看到所有属性，请单击右下角的扩展箭头。

使用“属性”检查器为占位符图像设置名称、宽度、高度、图像源文件、替代文本说明、对齐方式和颜色。

在占位符“属性”检查器中，灰色文本框和“对齐”文本框被禁用。在您用图像替换占位符时，可以在图像“属性”检查器中设置这些属性。

若要设置图像占位符属性，请执行以下操作：

  • 设置以下任一选项：

    “宽”和“高”以像素为单位设置图像占位符的宽度和高度。

    “源文件”指定图像的源文件。对于占位符图像，此文本框为空。单击“浏览”按钮来为占位符图形选择替换图像。

    “链接”为图像占位符指定超级链接。将“指向文件”图标拖到“站点”面板中的某个文件，单击文件夹图标浏览到站点上的某个文档，或手动键入 URL。

    “替代”指定只显示文本的浏览器或已设置为手动下载图像的浏览器中代替图像显示的替代文本。对于使用语音合成器（用于只显示文本的浏览器）的有视觉障碍的用户，将大声读出该文本。在某些浏览器中，当鼠标指针滑过图像时也会显示该文本。

    “创建”使您启动 Fireworks 以创建替换图像。如果在您的计算机上还没有安装 Fireworks，则“创建”按钮将被禁用。有关在 Fireworks 中创建替换图像的信息，请参见使用 Fireworks 修改 Dreamweaver 图像占位符。

    “重设大小”将“宽”和“高”的值重设为图像的原始大小。

    “颜色”使您可以为图像占位符指定颜色。


设置外部图像编辑器首选参数

使用“文件类型/编辑器”首选参数选择用于启动和编辑图形文件的图像编辑器。您可以设置编辑器打开哪些文件类型；并且可以选择多个图像编辑器。例如，可以令 Dreamweaver 在您要编辑 GIF 时启动 Fireworks，而在您要编辑 JPG 或 JPEG 时启动另一个图像编辑器。

若要为现有文件类型设置外部图像编辑器，请执行以下操作：

  1. 通过执行以下操作之一打开“文件类型/编辑器”首选参数对话框：
    • 选择“编辑”>“首选参数”(Windows) 或者“Dreamweaver”>“首选参数”(Macintosh)，然后从左侧的“类别”列表中选择“文件类型/编辑器”。
    • 选择“编辑”>“使用外部编辑器编辑”并选择“文件类型/编辑器”。
  2. 在“扩展名”列表中，选择您要为其设置外部编辑器的文件扩展名。
  3. 单击“编辑器”列表上方的加号 (+) 按钮。
  4. 在“选择外部编辑器”对话框中，浏览到您要作为此文件类型的编辑器启动的应用程序。
  5. 在“首选参数”对话框中，如果您希望该编辑器成为此文件类型的主编辑器，则单击“设为主要”。
  6. 如果您想要为此文件类型设置其它编辑器，则重复第 3 步和第 4 步。

    当您选择要编辑此图像类型时，Dreamweaver 自动使用主编辑器。您可以在“文档”窗口中为该图像从上下文菜单中选择列出的其它编辑器。

若要将新文件类型添加到“扩展名”列表中，请执行以下操作：

  1. 在“文件类型/编辑器”首选参数对话框中，单击“扩展名”列表上方的加号 (+) 按钮。

    在“扩展名”列表中随即显示一个文本框。

  2. 键入您要为其启动编辑器的文件类型的文件扩展名。
  3. 若要为该文件类型选择外部编辑器，请单击“编辑器”列表上方的加号 (+) 按钮。
  4. 在出现的对话框中，选择您要用来编辑此图像类型的应用程序。
  5. 如果您希望该编辑器成为此图像类型的主编辑器，则单击“设为主要”。

若要更改现有编辑器参数，请执行以下操作：

  1. 在“文件类型/编辑器”首选参数对话框中，在“扩展名”列表内选择要更改的文件类型以查看现有编辑器。
  2. 在“编辑器”列表中，选择您要对其进行操作的编辑器，然后执行以下操作之一：
    • 单击“编辑器”列表上方的添加 (+) 或删除 (-) 按钮以添加或删除编辑器。
    • 单击“设为主要”按钮，更改默认情况下启动以用于编辑的编辑器。

有关外部编辑器首选参数中其它选项的更多信息，请参见为媒体文件启动外部编辑器。


设置“鼠标经过图像”对话框选项

鼠标经过图像是一种在浏览器中查看并使用鼠标指针移过它时发生变化的图像。

注意

若要插入鼠标经过图像，必须具有两幅图像：主图像和次图像。鼠标经过图像中的这两个图像应大小相等；如果这两个图像大小不同，Dreamweaver 将自动调整第二个图像的大小以匹配第一个图像的属性。

若要设置“鼠标经过图像”对话框选项，请执行以下操作：

  1. 在“图像名称”文本框中，键入鼠标经过图像的名称。
  2. 在“原始图像”文本框中，单击“浏览”并选择您要在载入页时显示的图像，或在文本框中输入图像文件的路径。
  3. 在“鼠标经过图像”文本框中，单击“浏览”并选择您要在鼠标指针滑过原始图像时显示的图像，或在文本框中输入图像文件的路径。
  4. 如果您希望图像预先载入浏览器的缓存中，以便用户将鼠标指针滑过图像时不发生延迟，请选择“预先载入图像”选项。
  5. （可选）在“替代文本”中，为使用只显示文本的浏览器的访问者输入描述该图像的文本。
  6. 在“单击时，转到 URL”文本框中，单击“浏览”并选择文件，或者键入在用户单击鼠标经过图像时要打开的文件的路径。

    注意

    如果您不为该图像设置链接，Dreamweaver 将在 HTML 源代码中插入一个空链接 (#)，该链接上将附加鼠标经过图像行为。如果删除该空链接，鼠标经过图像将不再起作用。
  7. 单击“确定”关闭“插入鼠标经过图像”对话框。

相关主题

  • 创建鼠标经过图像
  • 交换图像


设置“亮度和对比度”对话框选项

“亮度/对比度”修改图像中像素的亮度或对比度。

若要调整图像的亮度或对比度，请执行以下操作：

  1. 拖动亮度和对比度滑动块调整设置。

    值的范围从 -100 到 100。

  2. 单击“确定”。

相关主题

  • 在 Dreamweaver 中编辑图像
  • 调整图像的亮度和对比度


设置“锐化图像”对话框选项

锐化将增加对象边缘的像素的对比度，从而增加图像清晰度或锐度。

若要锐化图像，请执行以下操作：

  1. 指定要应用于图像的锐化程度，方法是：拖动滑块控件或在文本框中输入 0 到 10 之间的值。

    在使用“清晰度”对话框调整图像的清晰度时，可以预览对该图像所做的更改。

  2. 对针对图像所做的更改满意之后，单击“确定”。
  3. 选择“文件”>“保存”以保存更改，或选择“编辑”>“撤消锐化”回复到原始图像。

相关主题

  • 在 Dreamweaver 中编辑图像
  • 锐化图像


链接与导航

在设置了存储 Web 站点文档的 Macromedia Dreamweaver 8 站点和创建了 HTML 页之后，您需要创建从您的文档到其它文档的连接。

Dreamweaver 提供多种创建超文本链接的方法，可创建到文档、图像、多媒体文件或可下载软件的链接。可以建立到文档内任意位置的任何文本或图像（包括标题、列表、表、层或框架中的文本或图像）的链接。

若要直观地查看文件是如何链接在一起的，可使用站点地图。在站点地图中，可以向站点添加新文档、创建和删除文档链接以及检查到相关文件的链接。有关更多信息，请参见查看站点地图。

链接的创建与管理有几种不同的方法。有些 Web 设计者喜欢在工作时创建一些指向尚未建立的页面或文件的链接；而另一些设计者则倾向于首先创建所有的文件和页面，然后再添加相应的链接。另一种管理链接的方法是创建代替最终文件的占位符页面，使用这种方法可以快速添加链接，而且可在实际完成所有页面之前对这些链接进行检查。有关检查链接的更多信息，请参见查找断开的、外部的和孤立的链接。

本章包含下列章节：

了解文档位置和路径

跳转菜单

导航条

关于图像地图

创建链接

管理链接

插入跳转菜单

使用导航条

使用图像地图

将 JavaScript 脚本附加到链接上

查找断开的、外部的和孤立的链接

修复断链接

在 Dreamweaver 中打开链接的文档


了解文档位置和路径

了解从作为链接起点的文档到作为链接目标的文档之间的文件路径对于创建链接至关重要。

每个网页都有一个唯一的地址，称作统一资源定位器 (URL)。有关 URL 的更多信息，请参见 WWW 联合会 (World Wide Web Consortium) 网站上的命名和编址 www.w3.org/Addressing/。

不过，当创建本地链接（即从一个文档到同一站点上另一个文档的链接）时，通常不指定要链接到的文档的完整 URL，而是指定一个始于当前文档或站点根文件夹的相对路径。

有三种类型的链接路径：

  • 绝对路径（例如 http://www.macromedia.com/support/dreamweaver/contents.html）。有关更多信息，请参见绝对路径。
  • 文档相对路径（例如 dreamweaver/contents.html）。有关更多信息，请参见文档相对路径。
  • 站点根目录相对路径（例如 /support/dreamweaver/contents.html）。有关更多信息，请参见站点根目录相对路径。

使用 Dreamweaver，可以方便地选择要为链接创建的文档路径的类型（请参见链接文件和文档）。

注意

最好使用您最喜欢和最得心应手的链接类型óó站点相对路径或文档相对路径。与键入路径相比，浏览到链接能确保输入的路径始终正确。


绝对路径

绝对路径提供所链接文档的完整 URL，而且包括所使用的协议（如对于 Web 页，通常使用 http://）。例如，http://www.macromedia.com/support/dreamweaver/contents.html 就是一个绝对路径。

必须使用绝对路径，才能链接到其它服务器上的文档。尽管对本地链接（即到同一站点内文档的链接）也可使用绝对路径链接，但不建议采用这种方式，因为一旦将此站点移动到其它域，则所有本地绝对路径链接都将断开。对本地链接使用相对路径还能在需要在站点内移动文件时，提供更大的灵活性。

注意

当插入图像（非链接）时：如果使用图像的绝对路径，而图像又驻留在远程服务器而不在本地硬盘驱动器上，则将无法在文档窗口中查看该图像。此时，必须在浏览器中预览该文档才能看到它。只要情况允许，对于图像，请使用文档或站点根目录相对路径。有关更多信息，请参见插入图像。


文档相对路径

文档相对路径对于大多数 Web 站点的本地链接来说，是最适用的路径。在当前文档与所链接的文档处于同一文件夹内，而且可能保持这种状态的情况下，文档相对路径特别有用。文档相对路径还可用来链接到其它文件夹中的文档，方法是利用文件夹层次结构，指定从当前文档到所链接的文档的路径。

文档相对路径的基本思想是省略掉对于当前文档和所链接的文档都相同的绝对 URL 部分，而只提供不同的路径部分。

例如，假设一个站点的结构如下：

创建从 contents.html 到其它文件的链接，如下所示：

  • 若要从 contents.html 链接到 hours.html（两个文件在同一文件夹中），文件名就是相对路径：hours.html。
  • 若要链接到 tips.html（在名为 resources 的子文件夹中），可使用相对路径
    resources/tips.html。

    每个正斜杠 (/) 表示在文件夹层次结构中下移一级。

  • 若要链接到 index.html（在父文件夹中，contents.html 向上一级），可使用相对路径 ../index.html。

    每个 ../ 表示在文件夹层次结构中上移一级。

  • 若要链接到 catalog.html（在父文件夹的其它子文件夹中），可使用相对路径
    ../products/catalog.html。

    其中 ../ 向上移至父文件夹；products/ 向下移至 products 子文件夹中。

若成组地移动一组文件，例如移动整个文件夹时，该文件夹内所有文件保持彼此间的相对路径不变，此时不需要更新这些文件间的文档相对链接。但是，当移动含有文档相对链接的单个文件或者移动文档相对链接所链接到的单个文件时，则必须更新这些链接。（如果使用“文件”面板移动或重命名文件，则 Dreamweaver 将自动更新所有相关链接。）

相关主题

  • 设置新链接的相对路径
  • 设置“本地信息”类别选项


站点根目录相对路径

站点根目录相对路径提供从站点的根文件夹到文档的路径。如果在处理使用多个服务器的大型 Web 站点，或者在使用承载有多个不同站点的服务器，则可能需要使用这些类型的路径。不过，如果您不熟悉此类型的路径，最好坚持使用文档相对路径。

站点根目录相对路径以一个正斜杠开始，该正斜杠表示站点根文件夹。例如，/support/tips.html 是文件 (tips.html) 的站点根目录相对路径，该文件位于站点根文件夹的 support 子文件夹中。

在某些 Web 站点中，需要经常在不同文件夹之间移动 HTML 文件，在这种情况下，站点根目录相对路径通常是指定链接的最佳方法。移动含有根目录相对链接的文档时，不需要更改这些链接；例如，如果某 HTML 文件对相关文件（如图像）使用根目录相对链接，则移动 HTML 文件后，其相关文件链接依然有效。

但是，如果移动或重命名根目录相对链接所链接的文档，即使文档彼此之间的相对路径没有改变，仍必须更新这些链接。例如，如果移动某个文件夹，则指向该文件夹中文件的所有根目录相对链接都必须更新。（如果使用“文件”面板移动或重命名文件，则 Dreamweaver 将自动更新所有相关链接。）

相关主题

  • 设置新链接的相对路径
  • 设置“本地信息”类别选项


跳转菜单

跳转菜单是文档中的弹出菜单，对站点访问者可见，并列出链接到文档或文件的选项。可以创建到整个 Web 站点内文档的链接、到其它 Web 站点上文档的链接、电子邮件链接、到图形的链接，也可以创建到可在浏览器中打开的任何文件类型的链接。

跳转菜单可包含三个基本部分：

  • （可选）菜单选择提示，如菜单项的类别说明，或一些指导信息等，例如“选择其中一项：”
  • （必需）所链接菜单项的列表：用户选择某个选项，则链接的文档或文件被打开。
  • （可选）“前往”按钮。

相关主题

  • 插入跳转菜单


导航条

导航条由图像或图像组组成，这些图像的显示内容随用户操作而变化。导航条通常为在站点上的页面和文件之间移动提供一条简捷的途径。

导航条项目有四种状态：

  • 一般：用户尚未单击或尚未与此项目交互时所显示的图像。

    例如，此状态下的项目看上去似乎还未被点击。

  • 滑过：指鼠标指针滑过“一般”图像时所显示的图像。项目的外观发生变化（例如变得更亮），以便让用户知道可与这个项目进行交互。

  • 按下：指项目被单击后所显示的图像。

    例如，用户单击某项目后，载入一个新的页面，而导航条仍然显示，只是被单击的项目变暗，表示它曾被选择过。

  • 按下时鼠标经过：指在项目被单击后，鼠标指针滑过“按下”图像时，所显示的图像。

    例如，项目变淡或变灰。此状态可作为一个给用户的可视提示，告诉他们在站点的这一部分，此项目不能再被单击。

不必包含所有这四种状态的导航条图像；例如，可以只选用“一般”和“按下”这两种状态。

相关主题

  • 使用导航条


关于图像地图

图像地图指已被分为多个区域（或称“热点”）的图像；当用户单击某个热点时，会发生某种操作（例如，打开一个新文件）。

客户端图像地图将超文本链接信息存储在 HTML 文档中，而不是像服务器端图像地图那样，存储在单独的地图文件中。当站点访问者单击图像中的热点时，相关 URL 被直接发送到服务器。这样使得客户端图像地图比服务器端图像地图要快，因为服务器不必解释访问者的单击位置。Netscape Navigator 2.0 及后续版本、NCSA Mosaic 2.1 和 3.0 以及 Internet Explorer 的所有版本都支持客户端图像地图。

Dreamweaver 并不改变现有文档中对服务器端图像地图的引用；在同一文档中，可以同时使用客户端图像地图和服务器端图像地图。不过，同时支持这两种图像地图类型的浏览器赋予客户端图像地图以优先权。若要在文档中包含服务器端图像地图，必须编写相应的 HTML 代码。

相关主题

  • 使用图像地图


创建链接

在一个文档中可以创建几种类型的链接：

  • 链接到其它文档或文件（如图形、影片、PDF 或声音文件）的链接。（请参见链接文件和文档。）
  • 命名锚记链接，此类链接跳转至文档内的特定位置。（请参见链接到文档中的特定位置。）
  • 电子邮件链接，此类链接新建一个收件人地址已经填好的空白电子邮件。（请参见创建电子邮件链接。）
  • 空链接和脚本链接，此类链接使您能够在对象上附加行为，或者创建执行 JavaScript 代码的链接。（请参见创建空链接和脚本链接。）

    注意

    创建链接之前，一定要清楚文档相对路径、站点根目录相对路径以及绝对路径的工作方式。（请参见了解文档位置和路径。）


链接文件和文档

属性检查器和“指向文件”图标可用于创建从图像、对象或文本到其它文档或文件的链接。有关使用站点地图创建链接的更多信息，请参见在站点地图中修改链接。

Dreamweaver 使用文档相对路径创建指向站点中其他网页的链接。您还可以让 Dreamweaver 使用站点根目录相对路径创建新链接。

注意

应始终先保存新文件，然后再创建文档相对路径，因为如果没有一个确切的起点，文档相对路径无效。如果在保存文件之前创建文档相对路径，Dreamweaver 将临时使用以 file:// 开头的绝对路径，直至该文件被保存；当保存文件时，Dreamweaver 将 file:// 路径转换为相对路径。

本节包含以下主题：

  • 使用属性检查器链接到文档
  • 使用“指向文件”图标链接文档
  • 使用站点地图链接文档
  • 使用“超级链接”命令
  • 设置新链接的相对路径

相关主题

  • 了解文档位置和路径


使用属性检查器链接到文档

属性检查器文件夹图标和“链接”文本框可用于创建从图像、对象或文本到其它文档或文件的链接。

若要使用属性检查器的文件夹图标或“链接”文本框链接文档，请执行以下操作：

  1. 在“文档”窗口的“设计”视图中选择文本或图像。
  2. 打开属性检查器（“窗口”>“属性”），然后执行下列操作之一：

    • 单击“链接”文本框右侧的文件夹图标，以通过浏览选择一个文件

      在 URL 文本框中显示了被链接的文档的路径。使用“选择 HTML 文件”对话框中的“相对于”弹出菜单，指示该路径是文档相对路径还是根目录相对路径，然后单击“选择”。您选择的路径类型只适用于当前链接。有关更多信息，请参见了解文档位置和路径。

      您可为该站点更改“相对于”文本框的默认设置。有关更多信息，请参见设置新链接的相对路径。

    • 在“链接”文本框中键入文档的路径和文件名。

      若要链接到站点内的文档，请输入文档相对路径或站点根目录相对路径。若要链接到站点外的文档，请输入包含协议（如 http://）的绝对路径。此种方法可用于输入尚未创建的文件的链接。

    对于文档相对路径，请省略对于当前文档和所链接的文档都相同的绝对 URL 部分：如果要链接的目标文件与当前文档位于同一文件夹中，请输入文件名；如果位于子文件夹中，请提供子文件夹的名称，后跟正斜杠 (/)，然后输入文件名；如果位于父文件夹中，请在文件名前添加 ../（其中“..”表示“文件夹层次结构中向上提升一级”）。

  3. 从“目标”弹出菜单中，选择文档打开的位置。

    若要使所链接的文档出现在当前窗口或框架以外的其它位置，可从属性检查器的“目标”弹出菜单中选择一个选项：

    • _blank 将链接的文档载入一个新的、未命名的浏览器窗口。
    • _parent 将链接的文档载入该链接所在框架的父框架或父窗口。如果包含链接的框架不是嵌套框架，则所链接的文档载入整个浏览器窗口。
    • _self 将链接的文档载入链接所在的同一框架或窗口。此目标是默认的，所以通常不需要指定它。
    • _top 将链接的文档载入整个浏览器窗口，从而删除所有框架。

      提示

      如果页面上的所有链接都设置为同一目标，则可以选择“插入”>“Head 标签”>“基础”，然后选择目标信息来指定该目标，这样只需设置一次即可。有关设置目标框架的信息，请参见控制具有链接的框架内容。


使用“指向文件”图标链接文档

“指向文件”图标可用于创建从图像、对象或文本到其它文档或文件的链接。

若要使用“指向文件”图标链接文档，请执行以下操作：

  1. 在“文档”窗口的“设计”视图中选择文本或图像。
  2. 拖动属性检查器中“链接”文本框右侧的“指向文件”图标，然后指向另一个打开的文档、已打开文档中的可见锚记或者指向“文件”面板中的一个文档。

    “链接”文本框将更新，以显示该链接。

    注意

    只有当“文档”窗口中的文档未最大化时，才能链接到打开的文档。如果指向打开的文档，则在进行选择时，该文档移至屏幕的最前面。
  3. 释放鼠标按钮。

若要从已打开文档中的选定内容创建链接，请执行以下操作：

  1. 在“文档”窗口中选择文本。
  2. 按下 Shift 键，从选定内容处开始拖动。

    在拖动过程中，出现“指向文件”图标。

  3. 指向其它打开的文档、已打开文档中的可见锚记，或者指向“文件”面板中的一个文档。

    注意

    只有当“文档”窗口中的文档未最大化时，才能链接到打开的文档。如果指向打开的文档，则在进行选择时，该文档移至屏幕的最前面。
  4. 释放鼠标按钮。

相关主题

  • 设置新链接的相对路径


使用站点地图链接文档

可以使用站点地图创建链接。创建的链接被放置在所选 HTML 文件的底部，使您可以在站点中快速创建链接。

若要使用站点地图和“指向文件”图标链接文档，请执行以下操作：

  1. 展开“文件”面板，然后通过按下“站点地图”图标并选择“地图”和“文件”，同时显示“站点文件”和“站点地图”视图。
  2. 在站点地图中选择一个 HTML 文件。

    在该文件旁边出现“指向文件”图标。

  3. 拖动“指向文件”图标，并指向站点地图中另一个文件，或者指向“站点文件”视图中的某个本地文件。
  4. 释放鼠标按钮。

    名称为所链接文件名称的超文本链接被置于所选 HTML 文件的底部。在构建站点并想快速创建跨站点的链接时，此方法尤其好用。

若要在站点地图中链接文档，请执行以下操作之一：

  • 将某个页面从 Windows 资源管理器或 Macintosh Finder 拖动到站点地图中的一页上。

    注意

    确保“文件”面板已停靠，然后单击“扩展”箭头。按下“站点地图”按钮，然后选择“文件和地图”。
  • 在站点地图中选择一个 HTML 页面，然后选择“站点”>“链接到现存文件”（在 Windows 中）或“站点”>“站点地图视图”>“链接到现存文件”（在 Macintosh 中），或者从上下文菜单中选择“链接到现存文件”。
  • 在站点地图中选择一个 HTML 页面，然后选择“站点”>“链接到新文件”（在 Windows 中）或“站点”>“站点地图视图”>“链接到新文件”（在 Macintosh 中），或者从上下文菜单中选择“链接到新文件”。

相关主题

  • 设置新链接的相对路径


使用“超级链接”命令

“超级链接”命令可以创建到图像、对象或其它文档或文件的文本链接。

若要使用“超级链接”命令添加超级链接，请执行以下操作：

  1. 将插入点放在文档中希望出现超级链接的位置。
  2. 执行如下操作之一，显示“超级链接”对话框：
    • 选择“插入”>“超级链接”。
    • 在“插入”栏的“常用”类别中，单击“超级链接”按钮。

    出现“超级链接”对话框。

  3. 完成对话框。

    有关更多信息，请参见设置超级链接选项。

  4. 单击“确定”。

相关主题

  • 在站点地图中修改链接
  • 链接到文档中的特定位置
  • 创建电子邮件链接
  • 创建空链接和脚本链接
  • 设置新链接的相对路径


设置新链接的相对路径

默认情况下，Dreamweaver 使用文档相对路径创建指向站点中其他网页的链接。您还可改令 Dreamweaver 使用站点根目录相对路径创建链接。有关“相对路径”的更多信息，请参见了解文档位置和路径。

若要使用站点根目录相对路径，必须首先在 Dreamweaver 中定义一个本地文件夹，方法是选择一个本地根文件夹，作为服务器上文档根目录的等效项（请参见设置新的 Dreamweaver 站点）。Dreamweaver 用该文件夹来确定文件的站点根目录相对路径。

在“站点定义”对话框中设置新链接的相对路径。

若要设置新链接的相对路径，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“管理站点”对话框。

  2. 双击列表中的站点。

    出现“站点定义”对话框。

  3. 如果未显示“高级”设置，请单击“高级”选项卡。

    “站点定义”对话框的“高级”选项卡显示“本地信息”类别选项。

  4. 选择“文档”或“站点根目录”选项，从而设置新链接的相对路径。

    单击“确定”后，更改此设置将不会转换现有链接的路径。设置将只应用于您用 Dreamweaver 创建的新链接。

    注意

    使用本地浏览器预览文档时，除非指定了测试服务器，或在“编辑”>“首选参数”>“在浏览器中预览”中选择“使用临时文件预览”选项，否则文档中用站点根目录相对路径链接的内容将不会被显示。这是因为浏览器不能识别站点根目录，而服务器能够识别。（请参见在浏览器中预览和测试页面。）

    提示

    若要预览用根目录相对路径所链接的内容，请将文件上传到远程服务器上，然后选择“文件”>“在浏览器中预览”查看它（请参见站点根目录相对路径）。
  5. 对于站点根目录相对路径，请在“HTTP 地址”文本框中输入已完成的 Web 站点将使用的 URL。

    Dreamweaver 使用此地址确保根目录相对链接在远程服务器上有效，因为远程服务器可能有不同的站点根目录。例如，如果您链接到位于硬盘上 C:\Sales\images\ 文件夹中的某个图像文件（Sales 是您的本地根文件夹），您完成的站点 URL 是 http://www.mysite.com/SalesApp/（SalesApp 是您的远端根文件夹），那么在“HTTP 地址”文本框中输入 URL 将确保远端服务器上的链接文件路径为 /SalesApp/images/。

    注意

    在以往的发布中，Dreamweaver 未能追加正确的远程根目录文件夹，导致网页运行时失败。
  6. 单击“确定”。

新路径设置只适用于当前站点。

相关主题

  • 了解文档位置和路径
  • 使用“高级”设置来设置 Dreamweaver 站点
  • 设置“本地信息”类别选项


链接到文档中的特定位置

通过首先创建命名锚记，可使用属性检查器链接到文档的特定部分。命名锚记使您可以在文档中设置标记，这些标记通常放在文档的特定主题处或顶部。然后可以创建到这些命名锚记的链接，这些链接可快速将访问者带到指定位置。

创建到命名锚记的链接的过程分为两步。首先，创建命名锚记，然后创建到该命名锚记的链接。

若要创建命名锚记，请执行以下操作：

  1. 在“文档”窗口的“设计”视图中，将插入点放在需要命名锚记的地方。
  2. 执行下列操作之一：
    • 选择“插入”>“命名锚记”。
    • 按下 Ctrl+Alt+A（在 Windows 中）；或者按下 Command+Option+A（在 Macintosh 中）。
    • 在“插入”栏的“常用”类别中，单击“命名锚记”按钮。

    出现“命名锚记”对话框。

  3. 在“锚记名称”文本框中，键入锚记的名称，并单击“确定”。

    有关更多信息，请参见设置“命名锚记”选项。

    锚记标记在插入点处出现。

    注意

    如果看不到锚记标记，可选择“查看”>“可视化助理”>“不可见元素”。

若要链接到命名锚记，请执行以下操作：

  1. 在“文档”窗口的“设计”视图中，选择要从其创建链接的文本或图像。
  2. 在属性检查器的“链接”文本框中，键入一个数字符号 (#) 和锚记名称。例如：
    • 若要链接到当前文档中的名为“top”的锚记，请键入 #top。
    • 若要链接到同一文件夹内其它文档中的名为“top”的锚记，请键入 filename.html#top。

      注意

      锚记名称区分大小写。

若要使用指向文件方法链接到命名锚记，请执行以下操作：

  1. 打开含有所需命名锚记的文档。

    注意

    如果看不到锚记，请选择“查看”>“可视化助理”>“不可见元素”使之可见。
  2. 在“文档”窗口的“设计”视图中，选择要从其创建链接的文本或图像。（如果这是其它打开文档，则必须切换到该文档。）
  3. 执行下列操作之一：
    • 单击属性检查器中“链接”文本框右侧的“指向文件”图标，然后将其拖到要链接到的锚记上：可以是同一文档中的锚记，也可以是其它打开文档中的锚记。
    • 在“文档”窗口中，按住 Shift 键进行拖动，从所选文本或图像拖动到要链接到的锚记：可以是同一文档中的锚记，也可以是其它打开文档中的锚记。

相关主题

  • 链接文件和文档
  • 创建电子邮件链接
  • 创建空链接和脚本链接

创建电子邮件链接

单击电子邮件链接时，该链接打开一个新的空白信息窗口（使用的是与用户浏览器相关联的邮件程序）。在电子邮件消息窗口中，“收件人”文本框自动更新为显示电子邮件链接中指定的地址。

若要使用“插入电子邮件链接”命令创建电子邮件链接，请执行以下操作：

  1. 在“文档”窗口的“设计”视图中，将插入点放在希望出现电子邮件链接的位置，或者选择要作为电子邮件链接出现的文本或图像。
  2. 执行下列操作之一，插入该链接：
    • 选择“插入”>“电子邮件链接”。
    • 在“插入”栏的“常用”类别中，单击“插入电子邮件链接”按钮。

    出现“电子邮件链接”对话框。

  3. 完成对话框。

    有关更多信息，请参见设置“电子邮件链接”选项。

  4. 单击“确定”。

若要使用属性检查器创建电子邮件链接，请执行以下操作：

  1. 在“文档”窗口的“设计”视图中选择文本或图像。
  2. 在属性检查器的“链接”文本框中，键入 mailto:，后面跟电子邮件地址。

    在冒号和电子邮件地址之间不能键入任何空格。例如，键入 mailto:jlydon@macromedia.com。

相关主题

  • 链接到文档中的特定位置
  • 链接到文档中的特定位置
  • 创建空链接和脚本链接

创建空链接和脚本链接

最为人所熟知的链接类型是链接到文档和命名锚记的链接（请参见链接文件和文档和链接到文档中的特定位置），但除此之外，还有其它一些链接类型。

空链接是未指派的链接。空链接用于向页面上的对象或文本附加行为。创建空链接后，可向空链接附加行为，以便当鼠标指针滑过该链接时，交换图像或显示层。有关向对象附加行为的信息，请参见应用行为。

脚本链接执行 JavaScript 代码或调用 JavaScript 函数。它非常有用，能够在不离开当前网页的情况下为访问者提供有关某项的附加信息。脚本链接还可用于在访问者单击特定项时，执行计算、表单验证和其它处理任务。

若要创建空链接，请执行以下操作：

  1. 在“文档”窗口的“设计”视图中选择文本、图像或对象。
  2. 在属性检查器中，将 javascript:;（javascript 一词后依次接一个冒号和一个分号）键入“链接”文本框。

若要创建脚本链接，请执行以下操作：

  1. 在“文档”窗口的“设计”视图中选择文本、图像或对象。
  2. 在属性检查器的“链接”文本框中，键入 javascript:后面跟一些 JavaScript 代码或函数调用。

    例如，在“链接”文本框中键入 javascript:alert('This link leads to the index') 可生成这样一个链接：单击该链接时，会显示一个含有“This link leads to the index”消息的 JavaScript 警告框。

    注意

    因为在 HTML 中 JavaScript 代码放在双引号中（作为 href 属性的值），所以在脚本代码中必须使用单引号，或者可通过在双引号前添加反斜杠，将所有双引号“转义”（例如，\"This link leads to the index\"）。

相关主题

  • 链接到文档中的特定位置
  • 创建电子邮件链接


管理链接

为避免站点中出现断链接，可以激活链接管理，使 Dreamweaver 在您作出更改后自动更新链接。也可以使用站点的可视化表示形式来修改链接，或者，可以通过一次更改将所有链接更新到一个特定的文件中。

相关主题

  • 自动更新链接
  • 在站点地图中修改链接
  • 在整个站点范围内更改链接

自动更新链接

每当在本地站点内移动或重命名文档时，Dreamweaver 可更新起自以及指向该文档的链接。当将整个站点（或其中完全独立的一个部分）存储在本地硬盘上时，此项功能最适用。Dreamweaver 不更改远程文件夹中的文件，除非将这些本地文件放在或者存回到远程服务器上。

为了加快更新过程，Dreamweaver 可创建一个缓存文件，用以存储有关本地文件夹中所有链接的信息。在添加、更改或删除指向本地站点上的文件的链接时，该缓存文件以可见的方式进行更新。

若要在 Dreamweaver 中启用链接管理，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)。

    即显示“首选参数”对话框。

  2. 从左侧的“类别”列表中选择“常规”。

    出现“常规”首选参数选项。

  3. 在“文档选项”部分，从“移动文件时更新链接”弹出菜单中选择“总是”或者“提示”。

    若选择“总是”，则每当移动或重命名选定文档时，Dreamweaver 将自动更新起自和指向该文档的所有链接。（有关删除文件时的操作的详尽指导，请参见在整个站点范围内更改链接。）

    如果选择“提示”，Dreamweaver 将显示一个对话框，列出此更改影响到的所有文件。单击“更新”可更新这些文件中的链接，而单击“不更新”将保留原文件不变。

  4. 单击“确定”。

若要为站点创建缓存文件，请执行以下操作：

  1. 选择“站点”>“管理站点”。

    出现“编辑站点”对话框。

  2. 选择一个站点，然后单击“编辑”。

    出现“站点定义”对话框。

  3. 单击“高级”选项卡显示“站点定义”对话框的“高级”类别。
  4. 从左侧的类别列表中选择“本地信息”。

    “站点定义”对话框显示“本地信息”选项。

  5. 在“本地信息”类别中，选中“启用缓存”复选框。

启动 Dreamweaver 之后，第一次更改或删除指向本地文件夹中文件的链接时，Dreamweaver 会提示您载入缓存。如果单击“是”，则载入缓存，并且 Dreamweaver 会更新指向刚刚更改的文件的所有链接。如果单击“否”，则将所做更改记入缓存，但并不载入该缓存，而且 Dreamweaver 也不更新链接。

在较大型的站点上，载入此缓存可能需要一段时间，其中的大部分时间用于将本地站点上文件的时间戳与缓存中记录的时间戳进行比较，以确定缓存是否过期。如果没有在 Dreamweaver 之外更改任何文件，则当“停止”按钮出现时，可以放心地单击该按钮。

若要重新创建站点缓存，请执行以下操作：

  • 在“文件”面板中，选择“站点”>“高级”>“重建站点缓存”。

在站点地图中修改链接

可以通过在站点地图中添加、更改和删除链接来修改站点的结构。Dreamweaver 自动更新站点地图以显示对站点所做的更改。

若要更改链接，请执行以下操作：

  1. 在站点地图中，选择要更改的链接所指向的页面（以便当前链接到此页面的文档指向其它页面），然后执行下列操作之一：
    • 选择“站点”>“更改链接”（在 Windows 中）；或者选择“站点”>“站点地图视图”>“更改链接”（在 Macintosh 中）。

      注意

      使用“文件”面板的“站点”菜单。
    • 右键单击（在 Windows 中）或者按住 Control 键单击（在 Macintosh 中），然后从上下文菜单中选择“更改链接”。
  2. 通过浏览找到希望链接指向的文件，或者键入 URL。
  3. 单击“确定”。

若要删除链接，请执行以下操作：

  1. 在站点地图中选择页面。
  2. 执行下列操作之一：
    • 选择“站点”>“删除链接”（在 Windows 中）；或者选择“站点”>“站点地图视图”>“删除链接”（在 Macintosh 中）。

      注意

      使用“文件”面板的“站点”菜单。
    • 右键单击（在 Windows 中）或者按住 Control 键单击（在 Macintosh 中），然后从上下文菜单中选择“删除链接”。

删除链接不会删除该文件，但会从指向该链接的页面上的 HTML 源代码中删除该链接。

若要打开链接源，请执行以下操作：

  1. 在站点地图中选择一个文件。
  2. 执行下列操作之一：
    • 选择“站点”>“打开链接源”（在 Windows 中）；或者选择“站点”>“站点地图视图”>“打开链接源”（在 Macintosh 中）。
    • 右键单击（在 Windows 中）或者按住 Control 键单击（在 Macintosh 中），然后从上下文菜单中选择“打开链接源”。

在“文档”窗口中打开属性检查器和含有此链接的源文件，同时该链接以高亮显示。

相关主题

  • 链接文件和文档
  • 使用站点的视觉地图


在整个站点范围内更改链接

除了每当移动或重命名文件时让 Dreamweaver 自动更新链接外，您还可以手动更改所有链接（包括电子邮件链接、FTP 链接、空链接和脚本链接），以指向其它位置。

任何时候都可使用此选项（例如，可能已经在整个站点内将“本月电影”这个词链接到了 /movies/july.html，而到了 8 月 1 日，则必须将那些链接更改为指向 /movies/august.html），不过此选项尤其适用于删除其它文件所链接到的某个文件。

若要在整个站点范围内更改链接，请执行以下操作：

  1. 在“文件”面板的“本地”视图中选择一个文件。

    注意

    如果更改的是电子邮件链接、FTP 链接、空链接或脚本链接，则不需要选择文件。
  2. 选择“站点”>“更改整个站点链接”。

    出现“更改整个站点链接”对话框。

  3. 完成对话框。

    有关更多信息，请参见设置“更改整个站点链接”选项。

  4. 单击“确定”。

    Dreamweaver 更新链接到选定文件的所有文档，使这些文档指向新文件，并沿用文档已经使用的路径格式（例如，如果旧路径为文档相对路径，则新路径也为文档相对路径）。不论链接类型是文档相对链接还是根目录相对链接，Dreamweaver 都会自动更新该链接。

在整个站点范围内更改某个链接后，所选文件就成为独立文件（即本地硬盘上没有任何文件指向该文件）。这时可安全地删除此文件，而不会破坏本地 Dreamweaver 站点中的任何链接。

注意

因为这些更改是在本地进行的，所以必须手动删除远程文件夹中的相应独立文件，然后放入或存回链接已经更改的所有文件；否则，站点的访问者将看不到这些更改。


插入跳转菜单

跳转菜单可建立 URL 与弹出菜单列表中的选项之间的关联。通过从列表中选择一项，用户将被重定向（或“跳转”）到指定的 URL。跳转菜单在“跳转菜单”表单对象中插入。

若要插入跳转菜单，请执行以下操作：

  1. 打开一个文档，然后将插入点放在“文档”窗口中。
  2. 执行下列操作之一：
    • 选择“插入”>“表单”>“跳转菜单”。
    • 在“插入”栏的“表单”类别中单击“跳转菜单”按钮。

      出现“插入跳转菜单”对话框。

  3. 完成对话框。

    有关更多信息，请参见设置“插入跳转菜单”选项。

  4. 单击“确定”。

    在文档中出现跳转菜单。

相关主题

  • 跳转菜单
  • 编辑跳转菜单项
  • 解决跳转菜单可能出现的问题

编辑跳转菜单项

若要编辑跳转菜单项，可更改列表顺序或项所链接到的文件，也可添加、删除或重命名项。

若要更改链接文件的打开位置，或者添加或更改菜单选择提示，则必须使用“行为”面板（请参见跳转菜单）。

若要使用属性检查器编辑跳转菜单项，请执行以下操作：

  1. 如果属性检查器尚未打开，请选择“窗口”>“属性”打开它。
  2. 在“文档”窗口的“设计”视图中，单击跳转菜单对象来选定它。

    在属性检查器中出现“列表/菜单”图标。

  3. 在属性检查器中，单击“列表值”按钮。

    出现“列表值”对话框。

  4. 根据需要对菜单项进行更改，然后单击“确定”。

相关主题

  • 跳转菜单
  • 插入跳转菜单
  • 解决跳转菜单可能出现的问题

解决跳转菜单可能出现的问题

用户选择跳转菜单项后，如果用户再次导航回该页面，或者如果“打开 URL 于”文本框指定了一个框架，则无法重新选择此菜单项。解决此问题有两个途径：

  • 使用菜单选择提示（如类别）或用户说明（如“选择其中一项：”）。在选择每个菜单之后将自动重新选择菜单选择提示。
  • 使用“前往”按钮，该按钮允许用户重新访问当前所选链接。

    注意

    由于这些选项应用于整个跳转菜单，因此在“插入跳转菜单”对话框中，每个跳转菜单只能选择这些选项中的一项。

相关主题

  • 跳转菜单
  • 插入跳转菜单
  • 编辑跳转菜单项


使用导航条

导航条由图像或图像组组成，这些图像的显示内容随用户操作而变化。

使用“插入导航条”命令之前，须首先为各个导航项目的显示状态创建一组图像。（可将导航条项目视为按钮，因为单击它时，导航条项目将用户带到其它页面。

为文档创建导航条后，可使用“修改导航条”命令向导航条添加图像，或从导航条中删除图像。此命令可用于更改图像或图像组、更改单击项目时所打开的文件、选择在不同的窗口或框架中打开文件以及重新排序图像。

本节包含以下主题：

  • 插入导航条
  • 修改导航条

相关主题

  • 导航条

插入导航条

插入导航条时，须命名导航条项目，并选择要用于它们的图像。

提示

您可执行下列操作：创建一个导航条、将导航条复制到站点内的其它页面、将导航条与框架一起使用以及编辑页面的行为以便在访问页面时显示不同的状态。

若要创建导航条，请执行以下操作：

  1. 执行下列操作之一：
    • 选择“插入”>“图像对象”>“导航条”。
    • 在“插入”栏的“常用”类别中，单击“图像”菜单并选择“插入导航条”按钮。

    出现“插入导航条”对话框。

  2. 完成对话框。

    有关更多信息，请参见设置“导航条”选项。

  3. 单击“确定”。

相关主题

  • 导航条
  • 修改导航条

修改导航条

为文档创建导航条后，可使用“修改导航条”命令向导航条添加图像，或从导航条中删除图像。

若要修改导航条，请执行以下操作：

  1. 在活动页面中选择导航条。
  2. 选择“修改”>“导航条”。

    出现“修改导航条”对话框。

  3. 在“导航条项目”列表中，选择要编辑的项目。
  4. 按需要进行更改。

    有关更多信息，请参见设置“导航条”选项。

  5. 单击“确定”。

相关主题

  • 导航条
  • 插入导航条


使用图像地图

图像地图指已被分为多个区域（或称“热点”）的图像；当用户单击某个热点时，会发生某种操作（例如，打开一个新文件）。

本节包含以下主题：

  • 插入客户端图像地图
  • 修改图像地图

相关主题

  • 关于图像地图

插入客户端图像地图

在插入客户端图像地图时，请创建一个热点，然后定义用户单击此热点时所打开的链接。

注意

可以创建多个热点，但它们是同一图像地图的一部分。

若要创建客户端图像地图，请执行以下操作：

  1. 在“文档”窗口中，选择图像。
  2. 在属性检查器中，单击右下角的展开箭头，查看所有属性。
  3. 在“地图名称”文本框中为该图像地图输入唯一的名称。

    注意

    如果在同一文档中使用多个图像地图，要确保每个地图都有唯一名称。
  4. 若要定义图像地图区域，请执行下列操作之一：
    • 选择圆形工具，并将鼠标指针拖至图像上，创建一个圆形热点。
    • 选择矩形工具，并将鼠标指针拖至图像上，创建一个矩形热点。
    • 选择多边形工具，在各个顶点上单击一下，定义一个不规则形状的热点。然后单击箭头工具封闭此形状。

    创建热点后，出现热点属性检查器。

  5. 完成热点属性检查器中的有关内容。

    有关更多信息，请参见设置热点属性检查器选项。

  6. 完成绘制图像地图后，在该文档的空白区域单击，以便更改属性检查器。

相关主题

  • 关于图像地图
  • 修改图像地图

修改图像地图

对在图像地图中所创建的热点进行编辑很容易。可以移动热点，调整热点大小，或者在层之间向上或向下移动热点。

还可以将含有热点的图像从一个文档复制到其它文档，或者复制某图像中的一个或多个热点，然后将其粘贴到其它图像上；这样就将与该图像关联的热点也复制到了新文档中。

若要选择图像地图中的多个热点，请执行以下操作：

  1. 使用指针热点工具选择一个热点。
  2. 执行下列操作之一：
    • 按下 Shift 键的同时单击要选择的其它热点。
    • 按 Ctrl+A（在 Windows 中）或者按 Command+A（在 Macintosh 中），选择所有的热点。

若要移动热点，请执行以下操作：

  1. 使用指针热点工具选择要移动的热点。
  2. 执行下列操作之一：
    • 将此热点拖动到新区域。
    • 用 Shift + 箭头键将热点向选定方向一次移动 10 个像素。
    • 使用箭头键将热点向选定方向一次移动 1 个像素。

若要调整热点的大小，请执行以下操作：

  1. 用指针热点工具选择要调整大小的热点。
  2. 拖动热点选择器手柄，更改热点的大小或形状。

相关主题

  • 关于图像地图
  • 插入客户端图像地图


将 JavaScript 脚本附加到链接上

可为文档中的任何链接附加行为（请参见应用行为）。在文档中插入链接项目时，有如下几种行为可供选择：

设置状态栏文本用于确定消息的文本，并将其显示在浏览器窗口左下部的状态栏中。例如，您可以使用此动作在状态栏中说明链接的目标而不是显示与之关联的 URL。（请参见设置状态栏文本。）

打开浏览器窗口用于在新窗口中打开 URL。您可以指定新窗口的属性（包括其大小）、特性（它是否可以调整大小、是否具有菜单栏等）和名称。（请参见打开浏览器窗口。）

跳转菜单用于编辑跳转菜单。可更改菜单列表、指定其它链接文件或者更改打开所链接文档的浏览器位置。（请参见跳转菜单。）

设置导航条图像用于更改导航条的行为。可用此行为对图像在导航条上的显示方式进行自定义。例如，当鼠标指针滑过部分导航条时，导航条或文档中其它图像的显示内容会改变。（请参见设置导航条图像。）


查找断开的、外部的和孤立的链接

“检查链接”功能用于在打开的文件、本地站点的某一部分或者整个本地站点中查找断链接和未被引用的（也称作孤立的）文件（文件仍然位于站点中，但没有其它文件链接到该文件）。

Dreamweaver 只验证那些指向站点内文档的链接；Dreamweaver 将出现在选定文档中的外部链接编辑成一个列表，但并不验证它们。

还可以标识和删除站点中其他文件不再使用的文件。有关更多信息，请参见标识和删除未使用的文件。

若要检查当前文档内的链接，请执行以下操作：

  1. 将此文件保存在本地 Dreamweaver 站点中的某个位置。
  2. 选择“文件”>“检查页”>“检查链接”。

    “断链接”报告出现在“链接检查器”面板中（在“结果”面板组中）。

  3. 在“链接检查器”面板中，从“显示”弹出菜单中选择“外部链接”，可查看其它报告。

    “外部链接”报告出现在“链接检查器”面板中（在“结果”面板组中）。

    提示

    当检查整个站点的链接时可检查孤立的文件。
  4. 若要保存此报告，请单击“链接检查器”面板中的“保存报告”按钮。

    注意

    目标浏览器报告为临时文件，若不保存，将会丢失。

若要检查本地站点某一部分中的链接，请执行以下操作：

  1. 在“文件”面板中，从“当前站点”弹出菜单中选择一个站点。
  2. 在“本地”视图中，选择要检查的文件或文件夹。
  3. 执行下列操作之一，启动该检查：
    • 右键单击（在 Windows 中）或者按住 Control 键单击（在 Macintosh 中）一个选定文件，然后从上下文菜单中选择“检查链接”>“选定的文件/文件夹”。
    • 选择“文件”>“检查页”>“检查链接”。

    “断链接”报告出现在“链接检查器”面板中（在“结果”面板组中）。

  4. 在“链接检查器”面板中，从“显示”弹出菜单中选择“外部链接”，可查看其它报告。

    “外部链接”报告出现在“链接检查器”面板中（在“结果”面板组中）。

    提示

    当检查整个站点的链接时可检查孤立的文件（请参见下一个步骤）。
  5. 若要保存报告，请单击“链接检查器”面板中的“保存报告”按钮。

若要检查整个站点中的链接，请执行以下操作：

  1. 在“文件”面板中，从“当前站点”弹出菜单中选择一个站点。
  2. 选择“站点”>“检查站点内所有链接”。

    “断链接”报告出现在“链接检查器”面板中（在“结果”面板组中）。

  3. 在“链接检查器”面板中，从“显示”弹出菜单中选择“外部链接”或“孤立的文件”，可查看其它报告。

    一个适合所选报告类型的文件列表出现在“链接检查器”面板中。

    注意

    如果选择的报告类型为“孤立的文件”，可以直接从“链接检查器”面板中删除孤立文件，方法是从该列表中选中一个文件后按 Delete 键。
  4. 若要保存报告，请单击“链接检查器”面板中的“保存报告”按钮。


修复断链接

在运行链接报告之后，可直接在“链接检查器”面板中修复断链接和图像引用，也可以从此列表中打开文件，然后在属性检查器中修复链接。

若要在“链接检查器”面板中修复链接，请执行以下操作：

  1. 运行链接检查报告（请参见查找断开的、外部的和孤立的链接）。
  2. 在“链接检查器”面板（在“结果”面板组中）中的“断链接”列（而不是“文件”列），选择该断链接。

    一个文件夹图标出现在此断链接旁边。

  3. 单击文件夹图标以浏览到要链接的正确文件，或者键入正确的路径和文件名。
  4. 按 Tab 键或者 Enter 键（在 Windows 中）；或者按 Return 键（在 Macintosh 中）。

    如果还有对同一文件的其它断开的引用，会出现一个对话框提示您修复其它文件中的这些引用。单击“是”，则 Dreamweaver 更新列表中引用此文件的所有文档。单击“否”，则 Dreamweaver 只更新当前引用。

    注意

    如果为此站点打开了“启用存回和取出”，则 Dreamweaver 将尝试取出需要更改的文件。如果不能取出文件，Dreamweaver 将显示一个警告对话框，并且不更改断开的引用。请参见存回和取出文件。

若要在属性检查器中修复链接，请执行以下操作：

  1. 运行链接检查报告（请参见查找断开的、外部的和孤立的链接）。
  2. 在“链接检查器”面板中（在“结果”面板组中）双击“文件”列中的某个条目。

    Dreamweaver 打开该文档，选择有问题的图像或链接，并在属性检查器中高亮显示其路径和文件名。（如果未出现属性检查器，请选择“窗口”>“属性”将其打开。）

  3. 若要在属性检查器中设置新路径和文件名，请单击文件夹图标以浏览到正确的文件，或者在高亮显示文本上直接键入。

    如果您正在更新一个图像引用，而显示的新图像的大小不正确，请单击属性检查器中的“W”和“H”标签，或者单击“刷新”按钮，重置高度和宽度值。“W”和“H”标签由粗体变为常规类型。

  4. 保存此文件。

链接修复后，该链接的条目在“链接检查器”列表中不再显示。如果在“链接检查器”中输入新的路径或文件名后（或者在属性检查器中保存更改后），某一条目依然显示在列表中，这表明 Dreamweaver 找不到新文件，仍然认为该链接是断开的。


在 Dreamweaver 中打开链接的文档

在 Dreamweaver 内链接是不活动的，即无法通过在“文档”窗口中单击链接打开该链接所指向的文档。

若要在 Dreamweaver 中打开链接的文档，请执行下列操作之一：

  • 选中链接，然后选择“修改”>“打开链接指向的页面”。
  • 按下 Ctrl 键（在 Windows 中）或者按下 Command 键（在 Macintosh 中）同时双击选中的链接。

    注意

    链接的文档必须驻留在本地磁盘上。

相关主题

  • 在浏览器中预览和测试页面
  • 查找断开的、外部的和孤立的链接
  • 修复断链接


参考资料

本节包含本章所介绍的下列对话框的有关信息：

  • 设置“命名锚记”选项
  • 设置超级链接选项
  • 设置“电子邮件链接”选项
  • 设置“更改整个站点链接”选项
  • 设置“插入跳转菜单”选项
  • 设置“导航条”选项
  • 设置热点属性检查器选项


设置“命名锚记”选项

此对话框用于为命名锚记提供名称。

若要指定命名锚记的名称，请执行以下操作：

  1. 为命名锚记输入一个名称。

    锚记名不能含有空格，而且不应置于层内。

  2. 按下“确定”。

相关主题

  • 链接到文档中的特定位置


设置超级链接选项

此对话框用于创建超级链接。

若要设置超级链接选项，请执行以下操作：

  1. 在“文本”文本框中，输入要在文档中作为超级链接显示的文本。
  2. 在“链接”文本框中，输入要链接到的文件的名称，或者单击文件夹图标以通过浏览选择该文件。
  3. 在“目标”弹出菜单中选择一个窗口，在该窗口中，该文件应在“目标”文本框中打开。

    当前文档中所有已命名框架的名称都显示在此弹出式列表中。如果指定的框架不存在，当文档在浏览器中打开时，所链接的页面载入一个新窗口，该窗口使用您所指定的名称。

    也可选用下列保留目标名：

    • _blank 将链接的文件载入一个未命名的新浏览器窗口中。
    • _parent 将链接的文件载入含有该链接的框架的父框架集或父窗口中。如果包含链接的框架不是嵌套的，则链接文件加载到整个浏览器窗口中。
    • _self 将链接的文件载入该链接所在的同一框架或窗口中。此目标是默认的，所以通常不需要指定它。
    • _top 将链接的文件载入整个浏览器窗口中，因而会删除所有框架。
  4. 在“Tab 键索引”文本框中，输入 Tab 键顺序的编号。
  5. 在“标题”文本框中，输入超级链接的标题。
  6. 在“访问键”文本框中，输入键盘等价键（一个字母）以便在浏览器中选择该超级链接。

相关主题

  • 创建电子邮件链接


设置“电子邮件链接”选项

此对话框用于创建电子邮件链接。

若要设置电子邮件链接选项，请执行以下操作：

  1. 在“文本”文本框中，键入或编辑要在文档中作为电子邮件链接出现的文本。
  2. 在“电子邮件”文本框中，键入该邮件将发送到的电子邮件地址。
  3. 单击“确定”。

相关主题

  • 创建电子邮件链接


设置“更改整个站点链接”选项

此对话框用于更改指向站点内文件的链接。

若要指定命名锚记的名称，请执行以下操作：

  1. 在“更改到如下文件的所有链接”文本框旁，单击文件夹图标，然后通过浏览选择要更改其链接的文件。

    注意

    如果更改的是电子邮件链接、FTP 链接、空链接或脚本链接，请键入要更改的链接的完整文本。
  2. 在“更改为到如下文件的链接”文本框旁边，单击文件夹图标，通过浏览选择要链接到的新文件。

    如果更改的是电子邮件链接、FTP 链接、空链接或脚本链接，请键入替换链接的完整文本。例如，若要更新指向旧地址的所有电子邮件链接，可在“更改到如下文件的所有链接”文本框中键入 mailto:juser@isp.com，然后在“更改为到如下文件的链接”文本框中键入 mailto:juser-interface@isp.com。

  3. 单击“确定”。

相关主题

  • 在整个站点范围内更改链接


设置“插入跳转菜单”选项

此对话框用于设置跳转菜单。

若要设置跳转菜单选项，请执行以下操作：

  1. 单击加号 (+) 按钮添加一个菜单项。

    再次单击该按钮添加另一个菜单项。选定一个菜单项，然后单击减号 (-) 按钮可将其删除。

  2. 选定一个菜单项，然后用箭头键在列表中向上或向下移动此菜单项。
  3. 在“文本”文本框中，为菜单项键入要在菜单列表中显示的文本。

    若要使用菜单选择提示（如“选择其中一项”），可在第一个菜单项的“文本”文本框中输入选择提示文本。

  4. 在“选择时，前往的 URL”域中，单击文件夹图标并通过浏览找到要打开的文件，或者在文本框中键入该文件的路径。
  5. 在“打开 URL 于”弹出菜单中，选择文件的打开位置：
    • 如果选择“主窗口”，则在同一窗口中打开文件。
    • 如果选择“框架”，则在所选框架中打开文件。

      注意

      如果想要使用的目标框架未出现在“打开 URL 于”弹出式菜单中，请关闭“插入跳转菜单”对话框，然后在文档中命名该框架。有关命名框架的信息，请参见查看和设置框架属性。
  6. 在“菜单名称”文本框中，键入菜单项的名称。
  7. 选择“选项”下的“菜单之后插入前往按钮”，可添加一个“前往”按钮，而非菜单选择提示。
  8. 如果要使用菜单选择提示（如“选择其中一项”），请选择“选项”下的“更改 URL 后选择第一个项目”。
  9. 单击“确定”。

相关主题

  • 插入跳转菜单
  • 解决跳转菜单可能出现的问题


设置“导航条”选项

此对话框用于命名导航条项目并选择导航条项目所用的图像。

若要设置导航条选项，请执行以下操作：

  1. 在“项目名称”文本框中，键入导航条项目的名称（例如 Home）。

    每一个项目都对应一个按钮，该按钮具有一组状态图像，最多可达四个。项目名称在“导航条项目”列表中显示。用箭头按钮排列项目在导航条中的位置。

  2. 在“一般图像”文本框中，单击“浏览”以选择最初将显示的图像。

    注意

    此文本框为必需项，其它图像状态选项为可选项。
  3. 在“鼠标经过图像”文本框中，单击“浏览”，以选择当一般图像显示时如果用户鼠标指针滑过项目所显示的图像。
  4. 在“按下图像”文本框中，单击“浏览”，以选择用户单击项目后显示的图像。
  5. 在“按下时鼠标经过图像”文本框中，单击“浏览”，以选择当用户将鼠标指针滑过按下图像时所显示的图像。
  6. 在“替换文本”文本框中，输入项目的描述性名称。

    替换文本在纯文本浏览器或设为手动下载图像的浏览器中，替代图像出现在应显示图像的位置。屏幕阅读器读取替换文本，而且有些浏览器在用户鼠标滑过导航条项目时显示替换文本。

  7. 在“按下时，前往的 URL”文本框中，单击“浏览”按钮，以选择要打开的链接文件，然后从弹出菜单中选择打开文件的位置。选择以下项之一：
    • 选择“主窗口”在同一窗口中打开文件。
    • 如果导航条在框架集中，则选择要在其中打开文件的框架。

      注意

      如果想要使用的目标框架未出现在弹出式菜单中，可关闭“插入导航条”对话框，然后命名该框架（请参见查看和设置框架属性）。
  8. 选择“预先载入图像”，可在载入页面时下载图像。

    如果未选择此选项，在用户将鼠标指针滑过鼠标经过图像时可能会出现延迟。

  9. 选择“初始时显示‘按下图像’”，可在显示页面时，以“按下”状态显示所选项目，而不是以默认的“一般”状态显示。

    例如，当载入主页时，导航条上的“主页”项目应处于“按下”状态。

    选择此选项时，在“导航条项目”列表中该项目后面将出现一个星号。

  10. 在“插入”弹出菜单中，可选择在文档中是垂直插入还是水平插入导航条项目。
  11. 选中“使用表格”复选框，可以表的形式插入导航条项目。
  12. 单击加号 (+) 按钮向导航条添加另一个项目，然后重复上述步骤定义该项目。
  13. 完成导航条项目的添加及定义后，单击“确定”。

相关主题

  • 插入导航条
  • 修改导航条


设置热点属性检查器选项

此对话框用于创建客户端图像地图。

若要设置热点属性检查器选项，请执行以下操作：

  1. 在热点属性检查器的“链接”文本框中，单击文件夹图标并通过浏览选择在用户单击该热点时要打开的文件，或者键入此文件的名称。

    如果链接到同一站点内的文件，请输入相对于您的文档的路径。（以 file:// 开头的文件名不是相对路径文件名。）

  2. 在“目标”弹出菜单中选择一个窗口，在该窗口中，该文件应在“目标”文本框中打开。

    当前文档中所有已命名框架的名称都显示在此弹出式列表中。如果指定的框架不存在，当文档在浏览器中打开时，所链接的页面载入一个新窗口，该窗口使用您所指定的名称。也可选用下列保留目标名：

    • _blank 将链接的文件载入一个未命名的新浏览器窗口中。
    • _parent 将链接的文件载入含有该链接的框架的父框架集或父窗口中。如果包含链接的框架不是嵌套的，则链接文件加载到整个浏览器窗口中。
    • _self 将链接的文件载入该链接所在的同一框架或窗口中。此目标是默认的，所以通常不需要指定它。
    • _top 将链接的文件载入整个浏览器窗口中，因而会删除所有框架。

      注意

      只有当所选热点包含链接后，目标选项才可用。
  3. 在“替换文本”框中，键入希望在纯文本浏览器或设为手动下载图像的浏览器中作为替换文本出现的文本。

    有些浏览器在用户鼠标指针暂停于该热点之上时，将此文本显示为工具提示。

  4. 重复第 4 步到第 7 步，定义该图像地图中的其它热点。
  5. 完成绘制图像地图后，在文档中的空白区域单击以更改属性检查器。

相关主题

  • 使用图像地图


使用其它应用程序

Macromedia Fireworks 8 和 Macromedia Flash 8 是功能强大的 Web 开发工具，用于创建可在 Web 页中查看的图形和 SWF 文件。您可以将 Macromedia Dreamweaver 8 与这些工具紧密集成，从而简化 Web 设计的工作流程。

您可以在 Dreamweaver 文档中方便地插入 Fireworks 图像或表和 Flash 内容（SWF 文件）。在 Dreamweaver 文档中插入图像或影片后，还可以利用 Dreamweaver 与 Fireworks 或 Flash 间的集成功能对其进行更改。

注意

若要将 Dreamweaver 与 Fireworks 和 Flash 一起使用，必须将所有这三个应用程序都安装在您的计算机上。

本章包含下列章节：

关于 Fireworks 和 Flash 集成

优化 Fireworks 和 Flash 的工作环境

使用 Fireworks

使用 Flash


关于 Fireworks 和 Flash 集成

可自由导入导出的编辑和“设计备注”使 Dreamweaver 能够将操作与 Fireworks 和 Flash 集成。可自由导入导出的编辑可确保代码更新在 Dreamweaver 和其它这些应用程序之间正确地传输（例如，保留鼠标经过行为或与其它文件的链接）。

“设计备注”是一些小文件，它允许 Dreamweaver 定位导出图像或影片文件的相应源文档。当您将文件从 Fireworks 或 Flash 直接导入到 Dreamweaver 定义站点时，包含对 PNG 或 Flash 创作文件 (FLA) 的引用的“设计备注”将自动随可在 Web 上发布的文件（GIF、JPEG 或 SWF）导出至该站点。有关信息，请参见关于设计备注。

除了位置信息之外，“设计备注”还包含其它有关所导出的文件的相关信息。例如，当导出一个 Fireworks 表时，Fireworks 将为该表中的每个导出图像文件编写一个“设计备注”。如果导出的文件包含热点或变换，这些热点或变换的 JavaScript 将包含在 Fireworks 所导出的 HTML 文档中。


优化 Fireworks 和 Flash 的工作环境

若要建立与 Fireworks 或 Flash 顺利集成的工作流程，关键是优化工作环境。

若要优化 Fireworks 和 Flash 的工作环境，请执行以下操作：

  1. 确保已经对 Dreamweaver 站点启用了“设计备注”。

    除非您更改了默认站点设置，否则“设计备注”将会自动启用。有关启用“设计备注”的信息，请参见对站点启用和禁用设计备注。有关“设计备注”的作用的信息，请参见关于 Fireworks 和 Flash 集成。

  2. 若要从 Dreamweaver 方便地启动 Fireworks，请将 Fireworks 设置为 Dreamweaver 的首要外部图像编辑器。

    将 Fireworks 设置为 GIF、PNG 和 JPEG 等图形文件类型的首要编辑器。有关更多信息，请参见设置外部图像编辑器首选参数。

  3. 请将 Fireworks 和 Flash 源以及可在 Web 上发布的文件保存在一个已定义的 Dreamweaver 站点文件夹中。

    这将确保共享该站点的任何用户都能够在 Dreamweaver 中工作并在编辑 Fireworks 图像或表（或编辑 SWF 影片）时定位源文档。

  4. 当导出 Fireworks 图像文件时，请将它们导出到 Dreamweaver 站点文件夹中。

    当您将 GIF 或 JPEG 图形从 Fireworks 导出至 Dreamweaver 站点文件夹时，Fireworks 将在同一文件夹中创建一个名为 _notes 的文件夹。此文件夹包含 Dreamweaver 需要与 Fireworks 一起使用的“设计备注”。

相关主题

  • 关于 Fireworks 和 Flash 集成


使用 Fireworks

Dreamweaver 和 Fireworks 识别并共享多种相同的文件编辑过程，其中包括对链接、图像映射、表切片等的更改。这两种应用程序一起提供了在 HTML 页中编辑、优化和放置 Web 图形文件的简化工作流程。

本节包含以下主题：

  • 插入 Fireworks 图像
  • 从 Dreamweaver 编辑 Fireworks 图像或表
  • 在 Dreamweaver 中优化 Fireworks 图像
  • 使用 Fireworks 修改 Dreamweaver 图像占位符
  • 在 Dreamweaver 中编辑 Fireworks 弹出式菜单
  • 指定 Fireworks 源文件的启动和编辑首选参数
  • 在 Dreamweaver 文档中插入 Fireworks HTML 代码
  • 将 Fireworks HTML 粘贴到 Dreamweaver 中
  • 更新放置在 Dreamweaver 中的 Fireworks HTML
  • 创建网站相册

相关主题

  • 关于 Fireworks 和 Flash 集成


插入 Fireworks 图像

Fireworks 图形可以通过多种方法放入 Dreamweaver 文档。您可以使用“插入图像”命令将 Fireworks 导出图形直接放入 Dreamweaver 文档，也可以利用 Dreamweaver 图像占位符创建新的 Fireworks 图形（请参见使用 Fireworks 修改 Dreamweaver 图像占位符）。

若要在 Dreamweaver 文档中插入 Fireworks 图像，请执行以下操作：

  1. 在 Dreamweaver 文档中，将插入点放在要让图像出现的地方，然后执行以下操作之一：
    • 选择“插入”>“图像”。
    • 在“插入”栏的“常用”类别中，单击“图像”按钮或将其拖到文档中。
  2. 导航至所需的 Fireworks 导出文件，然后单击“确定”(Windows) 或“打开”(Macintosh)。

    注意

    如果该 Fireworks 文件不在当前的 Dreamweaver 站点中，将显示一则消息，询问您是否要将该文件复制到根文件夹。单击“是”。


从 Dreamweaver 编辑 Fireworks 图像或表

您可以从 Dreamweaver 启动 Fireworks 来编辑在 Dreamweaver 文档中插入的图像。当打开并编辑图像或属于 Fireworks 表的一部分的图像切片时，Dreamweaver 会启动 Fireworks，而后者会打开从其中导出该图像或表的 PNG 文件。

当该图像属于 Fireworks 表的一部分时，只要 HTML 代码中存在 <!--fw table--> 注释，就可以打开整个 Fireworks 表进行编辑。如果源 PNG 是使用 Dreamweaver 样式 HTML 和图像设置从 Fireworks 导出至 Dreamweaver 站点的，该 Fireworks 表注释将自动插入到 HTML 代码中。

若要启动和编辑放置在 Dreamweaver 中的 Fireworks 图像，请执行以下操作：

  1. 在 Dreamweaver 中，选择“窗口”>“属性”以打开属性检查器（如果它尚未打开）。
  2. 单击图像或图像切片以将其选定。

    当您选择从 Fireworks 导出的图像时，属性检查器将选定的内容识别为 Fireworks 图像或表，并显示 PNG 源文件的名称。

  3. 若要启动 Fireworks 来进行编辑，请执行以下操作之一：
    • 在属性检查器中单击“编辑”。
    • 按住 Ctrl (Windows) 或 Command (Macintosh) 并双击选定图像。
    • 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 选定的图像，然后从上下文菜单中选择“用 Fireworks 编辑”。

    Fireworks 启动，并打开关联的 PNG 进行编辑。

    注意

    如果 Fireworks 无法定位源文件，则将提示您定位该 PNG 源文件。当处理 Fireworks 源文件时，更改会保存到源文件和导出的文件中；否则，只有导出的文件会得到更新。
  4. 在 Fireworks 中编辑源 PNG。
  5. 完成编辑后，单击“完成”。

    Fireworks 将更改保存在 PNG 文件中，导出已更新的图像（或 HTML 和图像），然后将焦点返回到 Dreamweaver。在 Dreamweaver 中，出现已更新的图像或表。

相关主题

  • 在 Dreamweaver 中编辑 Fireworks 弹出式菜单


在 Dreamweaver 中优化 Fireworks 图像

您可以从 Dreamweaver 中启动 Fireworks 来对放置的 Fireworks 图像和动画进行快速的导出更改，例如调整图像大小或更改文件类型。Fireworks 允许您更改导出图像的优化设置、动画设置以及大小和区域。

若要更改放置在 Dreamweaver 中的 Fireworks 图像的优化设置，请执行以下操作：

  1. 在 Dreamweaver 中，选择所需的图像并选择“命令”>“在 Fireworks 中优化图像”。
  2. 在出现提示时，指定是否启动所放置的图像的源 Fireworks 文件。
  3. 在 Fireworks 中，在“优化”对话框中做出所需的编辑：
    • 若要编辑优化设置，请单击“选项”选项卡。有关更多信息，请参见“使用 Fireworks”。
    • 若要编辑导出的图像的大小和区域，请单击“文件”选项卡。
  4. 编辑完图像后，单击“更新”。

    当单击“更新”后，将使用新的优化设置导出图像，更新放置在 Dreamweaver 中的 GIF 或 JPEG，并保存 PNG 源文件（如果已选定源文件）。

    如果您更改了图像的格式，Dreamweaver 链接检查器会提示您更新对该图像的引用。例如，如果将名为 my_image 的图像的格式从 GIF 更改为 JPEG，在出现此提示时单击“确定”即会将站点中对 my_image.gif 的所有引用更改为 my_image.jpg。

相关主题

  • 在 Dreamweaver 中编辑 Fireworks 弹出式菜单


使用 Fireworks 修改 Dreamweaver 图像占位符

您可以在 Dreamweaver 文档中创建一个占位符图像，然后启动 Fireworks 来设计图形图像或 Fireworks 表以替换该占位符图像。有关插入图像占位符的信息，请参见插入图像占位符。

若要通过图像占位符创建新图像，您的系统上必须安装 Dreamweaver 和 Fireworks。

若要在 Fireworks 中编辑 Dreamweaver 占位符图像，请执行以下操作：

  1. 确保您已经将 Fireworks 设置为 .png 文件的图像编辑器。有关信息，请参见设置外部图像编辑器首选参数。
  2. 在“文档”窗口中，单击图像占位符以将其选定。
  3. 执行以下操作之一以启动 Fireworks 来进行编辑：
    • 在属性检查器中单击“创建”。
    • 按 Ctrl (Windows) 或 Command (Macintosh)，然后双击该图像占位符。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 图像占位符，然后选择“在 Fireworks 中创建图像”。

    Fireworks 以“从 Dreamweaver 编辑”模式启动。

  4. 使用 Fireworks 选项设计图像。

    Fireworks 识别下面这些您在 Dreamweaver 中使用图像占位符时可能已设置的图像占位符设置：图像大小（它与 Fireworks 画布尺寸相关）、图像 ID（Fireworks 将它用作您创建的源文件和导出文件的默认文档名称）、文本对齐以及 Fireworks 所识别的行为（如交换图像、弹出菜单、导航条和设置文本）。Fireworks 还识别您在 Dreamweaver 中工作时附加到图像占位符的链接。

    注意

    虽然在 Fireworks 中无法看见已添加到图像占位符的链接，但这些链接会保留下来。如果您在 Fireworks 中绘制一个热点并添加一个链接，将不会删除您已在 Dreamweaver 中添加到图像占位符的链接；但是，如果您在 Fireworks 中的新图像上剪切出一个切片，则将在您替换图像占位符时删除 Dreamweaver 文档中的链接。

    由于 Fireworks 不识别以下图像占位符设置，它们会在图像占位符属性检查器中被禁用：图像对齐方式、颜色、Vspace 与 Hspace 以及映射。

  5. 完成后，单击“完成”。

    出现“另存为”对话框。Fireworks 提示您保存该 PNG 文件。

  6. 在“保存位置”文本框中，选择您定义为 Dreamweaver 本地站点文件夹的文件夹。

    如果在 Dreamweaver 文档中插入图像占位符时已经为其命名，Fireworks 将用该名称填充“文件名称”文本框。如果需要，可以更改该名称。

  7. 单击“保存”以保存该 PNG 文件。

    出现“导出”对话框。使用此对话框将图像导出为 GIF、JPEG 形式，或者在切片图像情况下，导出为 HTML 和图像的形式。

  8. 在“导出”对话框中，为“保存位置”选择 Dreamweaver 本地站点文件夹。
  9. “名称”文本框会自动更新为用于 PNG 文件的同一名称。如果需要，输入相应文本以更改该名称。
  10. 对于“保存类型”，请选择要导出的文件的类型，例如“仅限图像”或“HTML 和图像”。
  11. 单击“保存”以保存导出的文件。

    该文件被保存，此时焦点返回到 Dreamweaver。在 Dreamweaver 文档中，导出的文件或 Fireworks 表替换了图像占位符。


在 Dreamweaver 中编辑 Fireworks 弹出式菜单

可以在 Fireworks 8 或更高版本中创建弹出式菜单，然后使用 Dreamweaver 或 Fireworks（使用可自由导入导出的编辑）对其进行编辑，但无法同时使用两者。如果先在 Dreamweaver 再在 Fireworks 中编辑菜单，将会丢失除文本内容外以前的所有编辑内容。

如果您更喜欢使用 Dreamweaver 编辑菜单，则可以使用 Fireworks 创建弹出式菜单，然后单独使用 Dreamweaver 调整和自定义菜单。

如果您更喜欢使用 Fireworks 编辑菜单，则可以在 Dreamweaver 中使用可自由导入导出的编辑功能，但不应直接在 Dreamweaver 中编辑菜单。

若要使用可自由导入导出的编辑功能编辑 Fireworks 弹出式菜单，请执行以下操作：

  1. 在 Dreamweaver 中，选择包含弹出式菜单的 Fireworks 表，然后在属性检查器中单击“编辑”。

    源 PNG 文件将在 Fireworks 中打开。

  2. 在 Fireworks 中，使用弹出式菜单编辑器编辑菜单，然后单击 Fireworks 工具栏上的“完成”。

    Fireworks 将已编辑的弹出式菜单发送回 Dreamweaver。

如果在 Fireworks MX 2004 或更早版本中创建了弹出式菜单，则可以使用“显示弹出式菜单”对话框在 Dreamweaver 中对其进行编辑。

若要编辑在 Fireworks MX 2004 或更早版本中创建的弹出式菜单，请执行以下操作：

  1. 在 Dreamweaver 中，选择将触发该弹出式菜单的热点或图像。
  2. 在“行为”面板 (Shift+F3) 中，双击“操作”列表中的“显示弹出式菜单”。

    出现“显示弹出菜单”对话框。“显示弹出菜单”行为使您能够编辑或更新基于 Fireworks HTML 的弹出菜单的内容。您可以添加、删除或更改菜单项，重新排列菜单项，也可以设置菜单在页中的位置。有关设置或修改弹出式菜单选项的信息，请参见显示弹出菜单。

  3. 对该弹出式菜单做出所需的更改，然后单击“确定”。

相关主题

  • 关于 Fireworks 8 弹出式菜单


指定 Fireworks 源文件的启动和编辑首选参数

当使用 Fireworks 编辑图像时，您在 Web 页中放置的图像通常是由 Fireworks 从一个 PNG 源文件中导出的。当您在 Dreamweaver 中打开（“启动”）图像文件进行编辑时，Fireworks 会自动打开 PNG 源文件，如果未能找到该文件，它会提示您定位 PNG 文件。如果喜欢，您可以在 Fireworks 中设置首选参数以让 Dreamweaver 打开插入的图像，也可以让 Fireworks 在您每次于 Dreamweaver 中打开图像时请您选择是使用插入的图像文件还是 Fireworks 源文件。

注意

只有在一些特定的情况下，Dreamweaver 才识别 Fireworks 启动和编辑首选参数。具体而言，您所开启并优化的图像必须不属于 Fireworks 表的一部分并且包含源 PNG 文件的正确“设计备注”路径。

若要指定 Fireworks 的启动和编辑首选参数，请执行以下操作：

  1. 在 Fireworks 中，选择“编辑”>“首选参数”或“Fireworks”>“首选参数”(Macintosh)，然后单击“启动和编辑”选项卡 (Windows) 或从弹出菜单中选择“启动和编辑”(Macintosh)。
  2. 指定在编辑或优化放置在外部应用程序中的 Fireworks 图像时所使用的首选选项：

    始终使用源 PNG 自动打开在“设计备注”中定义为所放置图像的源的 Fireworks PNG 文件。源 PNG 及其相应的放置图像都会得到更新。

    永不使用源 PNG 自动打开放置的 Fireworks 图像，而不论源 PNG 文件是否存在。只有放置的图像才会得到更新。

    启动时询问使您每次都能够指定是否打开 PNG 源文件。当编辑或优化放置的图像时，Fireworks 将显示一则消息，提示您做出启动和编辑的决定。您也可以通过此消息指定全局的启动和编辑首选参数。


在 Dreamweaver 文档中插入 Fireworks HTML 代码

Fireworks 中的“导出”命令使您能够将优化的图像和 HTML 文件导出并保存至所需的 Dreamweaver 站点文件夹中的某一位置。然后可以在 Dreamweaver 中插入该文件。有关将 Fireworks 文件导出为 HTML 的信息，请参见“使用 Fireworks”。

Dreamweaver 允许您将 Fireworks 生成的 HTML 代码随关联的图像、切片和 JavaScript 一起插入到文档中。这一插入功能使您可以方便地在 Fireworks 中创建设计元素，然后将这些元素纳入现有的 Dreamweaver 文档。

若要将 Fireworks HTML 插入到 Dreamweaver 文档中，请执行以下操作：

  1. 在 Dreamweaver 中，将插入点放置在文档中要让 Fireworks HTML 代码开始的地方。
  2. 执行下列操作之一：
    • 选择“插入”>“交互式图像”>“Fireworks HTML”。
    • 在“插入”栏的“常用”类别中，单击“插入 Fireworks HTML”按钮。
  3. 在出现的对话框中单击“浏览”以选择所需的 Fireworks HTML 文件。
  4. 选择“插入后删除文件”选项，以便在该操作完成后将原始 Fireworks HTML 文件移至“回收站”(Windows) 或“垃圾箱”(Macintosh)。

    如果在插入 Fireworks HTML 文件后不再需要该文件，则应使用此选项。此选项不影响与该 HTML 文件关联的源 PNG 文件。

    注意

    如果该 HTML 文件位于网络驱动器上，则会将其永久删除，而不是移至“回收站”或“垃圾箱”。
  5. 单击“确定”，将 HTML 代码随其关联的图像、切片和 JavaScript 一起插入到 Dreamweaver 文档中。

相关主题

  • 将 Fireworks HTML 粘贴到 Dreamweaver 中


将 Fireworks HTML 粘贴到 Dreamweaver 中

若要在 Dreamweaver 中放置 Fireworks 生成的图像或表，一种较快的方法是复制 Fireworks HTML 代码并直接将其粘贴到 Dreamweaver 文档中。

若要复制 Fireworks HTML 并将其粘贴到 Dreamweaver 中，请执行以下操作：

  1. 在 Fireworks 中，选择“编辑”>“复制 HTML 代码”。
  2. 按照向导的指导完成导出 HTML 和图像的设置。在得到提示时，将您的 Dreamweaver 站点文件夹指定为导出图像的目标文件夹。

    向导会将图像导出至指定的目标并将 HTML 代码复制到剪贴板上。

  3. 在 Dreamweaver 中，将插入点放置在文档中要粘贴 HTML 代码的地方，然后选择“编辑”>“粘贴”。

    与导出的 Fireworks 文件关联的所有 HTML 和 JavaScript 代码都被复制到 Dreamweaver 文档中，而指向图像的所有链接都得到更新。

若要将 Fireworks HTML 导出并粘贴到 Dreamweaver 中，请执行以下操作：

  1. 在 Fireworks 中，选择“文件”>“导出”。
  2. 在“导出”对话框中，将您的 Dreamweaver 站点文件夹指定为导出图像的目标。
  3. 在“另存为”弹出菜单中选择“HTML 和图像”。
  4. 在“HTML”弹出菜单中，选择“复制到剪贴板”，然后单击“保存”。
  5. 在 Dreamweaver 中，将插入点放置在文档中要粘贴导出的 HTML 代码的地方，然后选择“编辑”>“粘贴”。

    与导出的 Fireworks 文件关联的所有 HTML 和 JavaScript 代码都被复制到 Dreamweaver 文档中，而指向图像的所有链接都得到更新。

相关主题

  • 在 Dreamweaver 文档中插入 Fireworks HTML 代码


更新放置在 Dreamweaver 中的 Fireworks HTML

在 Fireworks 中，“文件”>“更新 HTML”命令提供了启动和编辑功能的一种替代方法，用以更新放置在 Dreamweaver 中的 Fireworks 文件。利用“更新 HTML”，您可以在 Fireworks 中编辑源 PNG 图像，然后自动更新任何放置在 Dreamweaver 文档中的导出 HTML 代码和图像文件。即使是在 Dreamweaver 未运行时，此命令仍允许您更新 Dreamweaver 文件。

若要更新放置在 Dreamweaver 中的 Fireworks HTML，请执行以下操作：

  1. 在 Fireworks 中，打开源 PNG 并对其做出所需的编辑。
  2. 选择“文件”>“保存”。
  3. 在 Fireworks 中，选择“文件”>“更新 HTML”。
  4. 导航至包含要更新的 HTML 的 Dreamweaver 文件，然后单击“打开”。
  5. 导航至要将更新后的图像文件放置到的文件夹目标，然后单击“选择”(Windows) 或“选取”(Macintosh)。

    Fireworks 更新 Dreamweaver 文档中的 HTML 和 JavaScript 代码。Fireworks 还会导出与 HTML 关联的已更新图像并将这些图像放置到指定的目标文件夹。

    如果 Fireworks 无法找到匹配的 HTML 代码来更新，它将为您提供一个选项来将新的 HTML 代码插入到 Dreamweaver 文档中。Fireworks 将新代码的 JavaScript 部分放置在文档的开头，将 HTML 表或指向该图像的链接放置在末尾。


创建网站相册

您可以自动生成一个 Web 站点，该站点展示位于给定文件夹中图像的“相册”。Dreamweaver 使用 Fireworks 来为该文件夹中的每个图像创建一个缩略图和一个较大尺寸的图像。然后，Dreamweaver 创建一个 Web 页，它包含所有缩略图以及指向较大图像的链接。若要创建“网站相册”，您的系统上必须安装有 Dreamweaver 和 Fireworks 4（或更高版本）两者。

在开始之前，将相册的所有图像放置在一个文件夹中。（该文件夹不必位于站点中。）另外，确保图像文件名包含以下任意一个扩展名：.gif、.jpg、.jpeg、.png、.psd、.tif 或 .tiff。带有无法识别的文件扩展名的图像不会包含在相册中。

若要创建网站相册，请执行以下操作：

  1. 在 Dreamweaver 中，选择“命令”>“创建网站相册”。
  2. 在“相册标题”文本框中输入一个标题。该标题将显示在包含缩略图的页面的顶部的灰色矩形中。

    如果需要，可以在“副标信息”和“其它信息”文本框中输入最多两行附加文本，该文本将直接在标题下显示。

  3. 单击“源图像文件夹”文本框旁的“浏览”按钮，选择包含源图像的文件夹。然后单击“目标文件夹”文本框旁的“浏览”按钮，选择（或创建）一个目标文件夹，用以放置所有导出的图像和 HTML 文件。

    目标文件夹不应该已包含相册 － 如果已包含相册，并且如果任何新图像与先前使用的图像同名，则可能会覆盖现有的缩略图和图像文件。

  4. 指定缩略图图像的显示选项：
    • 从“缩略图大小”弹出菜单中选择缩略图图像的大小。图像将按比例缩放，以创建适合具有指定像素尺寸的方框的缩略图。
    • 若要在相应的缩略图下显示每个原始图像的文件名，请选择“显示文件名”。
    • 输入显示缩略图的表的列数。
  5. 从“缩略图格式”弹出菜单中选择缩略图图像的格式：

    GIF WebSnap 128 创建 GIF 缩略图，这些缩略图使用包含多达 128 色的 Web 适应性调色板。

    GIF WebSnap 256 创建 GIF 缩略图，这些缩略图使用包含多达 256 色的 Web 适应性调色板。

    JPEG － 品质较高创建品质较高且文件大小较大的 JPEG 缩略图。

    JPEG － 文件较小创建品质较低且文件大小较小的 JPEG 缩略图。

  6. 从“相片格式”弹出菜单中选择大尺寸图像的格式。对于每个原始图像，将创建一个具有指定格式的大尺寸图像。您为大尺寸图像指定的格式可以不同于为缩略图指定的格式。

    注意

    由于 GIF 和 JPEG 之外的原始文件格式可能无法在所有浏览器中正确显示，所以“创建网站相册”命令不允许您将原始图像文件用作大尺寸图像。请注意，如果原始图像是 JPEG 文件，则所生成的大尺寸图像的文件大小可能比原始文件大（或者其品质比原始文件低）。
  7. 选择大尺寸图像的缩放百分比。

    如果将“缩放”设置为 100%，将创建与原始图像等大的大尺寸图像。请注意，缩放百分比将应用于所有图像；如果原始图像的大小不一样，那么按同一百分比缩放就可能不会产生所需的效果。

  8. 选择“为每张相片建立导览页面”，为每个源图像创建一个 Web 页，该 Web 页包含标为“后退”、“主页”、“前进”的导航链接。

    如果选择此选项，缩略图会链接到导航页。如果不选择此选项，缩略图链接将直接链接到大尺寸图像。

  9. 单击“确定”以创建网站相册的 HTML 和图像文件。

    Fireworks 启动（如果它尚未运行）并创建缩略图和大尺寸图像。如果所包含的图像文件数目较多，这可能会需要几分钟的时间。当处理完成后，Dreamweaver 将再次处于活动状态并创建包含缩略图的页。

  10. 当出现指示“相册已经建立”的对话框时，单击“确定”。

    相册页出现之前可能需要等待几秒钟。各缩略图根据文件名按字母顺序显示。

    注意

    如果在处理开始后单击 Dreamweaver 对话框中的“取消”按钮，创建相册的进程并不会停止；这只会防止 Dreamweaver 显示主相册页。


使用 Flash

使用 Dreamweaver 设置 Flash 文件在 Web 页中的播放和显示选项，或者更新影片中的链接。如果安装了 Flash，还可以在 Dreamweaver 文档中选择 SWF 文件并且启动 Flash 来编辑它。

本节包含以下主题：

  • 在 Dreamweaver 中编辑 Flash 内容
  • 更新 SWF 文件中的链接

相关主题

  • 关于 Fireworks 和 Flash 集成
  • 插入和修改 Flash 按钮对象
  • 插入 Flash 文本对象
  • 插入 Flash 内容


在 Dreamweaver 中编辑 Flash 内容

如果安装了 Flash，则可以在 Dreamweaver 文档中选择 SWF 文件并且打开 Flash 来编辑它。Flash 并不直接编辑 SWF 文件；它编辑的是源文档（FLA 文件），然后重新导出 SWF 文件。

若要从 Dreamweaver 中打开和编辑插入的 Flash 内容，请执行以下操作：

  1. 在 Dreamweaver 中，选择“窗口”>“属性”以打开属性检查器（如果它尚未打开）。
  2. 在 Dreamweaver 文档中，执行以下操作之一：
    • 单击 SWF 文件占位符以将其选定；然后在属性检查器中单击“编辑”。

      注意

      如果没有安装 Flash，“编辑”按钮会被禁用。
    • 按住 Ctrl (Windows) 或 Command (Macintosh) 并双击要编辑的影片的影片占位符。
    • 右键单击 (Windows) 或按住 Control 并单击 (Macintosh) 所需的影片，然后从上下文菜单中选择“用 Flash 编辑”。

    Dreamweaver 启动 Flash，而 Flash 将尝试定位选定的 SWF 文件的 Flash 创作文件 (FLA)。如果 Flash 无法定位 Flash 创作文件，则会提示您定位该文件。您不能直接更新 SWF 文件；如果要更新 SWF 文件，请对源文件做出更改，然后将其导出为 SWF 文件。

    注意

    如果 FLA 文件或 SWF 文件被锁定，Dreamweaver 会提示您取出该文件、取消请求或查看该文件。
  3. 在 Flash 中编辑该影片。“文档”窗口指示您正在修改来自 Dreamweaver 的影片。
  4. 完成编辑后，单击“完成”。

    Flash 更新 Flash 创作文档（FLA 文件），重新导出该影片文件（SWF 文件）并关闭，然后将焦点返回到 Dreamweaver 文档。

  5. 若要查看文档中已更新的 SWF，请单击属性检查器中的“播放”，或者按 F12 键在浏览器窗口中对该页进行预览。

更新 SWF 文件中的链接

您可以使用 Dreamweaver 更新 Flash 文件（SWF 文件）中的链接，然后在 Flash 创作文档（FLA 文件）中更新所做的更改。

若要更新 SWF 文件中的 URL 链接，请执行以下操作：

  1. 设置站点的主页（如果尚未设置主页）。

    为了生成站点地图，需要设置主页。在“站点地图”视图中，为了更新 SWF 文件中的链接，需要显示关联的文件。默认情况下，站点地图并不显示关联文件。有关显示相关文件的信息，请参见显示和隐藏站点地图文件。有关“站点地图”视图的信息，请参见查看站点地图。

  2. 打开“站点地图”视图。
  3. 若要显示相关文件，请执行以下操作之一：
    • 选择“查看”>“显示相关文件”。
    • 选择“查看”>“布局”以打开“站点定义”对话框，然后选择“显示相关文件”选项。

    该链接出现在 SWF 文件之下。

  4. 通过执行以下操作之一更改链接：
    • 若要更改选定的 SWF 中的链接，请右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该链接，选择“更改链接”，然后在出现的对话框中的 URL 文本框中键入新的 URL 路径。
    • 若要更新该链接的所有实例，请选择“站点”>“更改站点内所有指定链接”，然后在出现的对话框上：在“将所有链接更改为”文本框中浏览到（或键入）要更改的链接的路径，并且在“新链接”文本框中浏览到（或键入）新的 URL 路径。
  5. 单击“确定”。

当执行启动和编辑时，SWF 文件中已经由 Dreamweaver 更新的所有链接都会转达给 FLA 源文档。Dreamweaver 会自动在“设计备注”中记录对 SWF 文件的所有链接更改，当 Flash 将这些更改传递到 FLA 文件时，它将从“设计备注”中删除这些更改。


添加音频、视频和交互式元素

Macromedia Dreamweaver 8 使您可以快速便捷地向您的 Web 站点添加声音和影片。您可以将“设计备注”附加到这些对象上，以便于您和您的小组成员之间的交流。您还可以在 Dreamweaver 自身内插入 Macromedia Flash 8 按钮和文本对象。

本章包含下列章节：

关于媒体文件

插入和编辑媒体对象

为媒体文件启动外部编辑器

将“设计备注”与媒体对象一起使用

插入和修改 Flash 按钮对象

插入 Flash 文本对象

插入 Flash 内容

下载和安装 Flash 元素

插入 Flash 元素

编辑 Flash 元素属性

插入 FlashPaper 文档

插入 Flash 视频内容

插入 Shockwave 影片

添加视频（非 Flash）

向页面添加声音

插入 Netscape Navigator 插件内容

插入 ActiveX 控件

插入 Java applet

使用行为控制媒体


关于媒体文件

您可以将以下媒体文件合并到 Dreamweaver 页中：Flash 和 Shockwave 影片、QuickTime、AVI、Java applet、Active X 控件以及各种格式的音频文件。

本节包含以下概念性主题：

  • 关于 Flash 文件类型
  • 关于音频文件格式


关于 Flash 文件类型

Dreamweaver 附带了 Flash 对象，无论您的计算机上是否安装了 Flash，您都可以使用这些对象。如果您有 Flash，请参见使用 Flash，了解如何以集成的方式使用这些应用程序的信息。

在使用 Dreamweaver 提供的 Flash 命令前，您应该对以下三种不同的 Flash 文件类型有所了解：

Flash 文件 (.fla) 是所有项目的源文件，在 Flash 程序中创建。此类型的文件只能在 Flash 中打开（而不是在 Dreamweaver 或浏览器中打开）。您可以在 Flash 中打开 Flash 文件，然后将它导出为 SWF 或 SWT 文件以在浏览器中使用。

Flash SWF 文件 (.swf) 是 Flash (.fla) 文件的压缩版本，已进行了优化以便于在 Web 上查看。此文件可以在浏览器中播放并且可以在 Dreamweaver 中进行预览，但不能在 Flash 中编辑此文件。这是您使用 Flash 按钮和 Flash 文本对象时创建的文件类型。有关更多信息，请参见插入和修改 Flash 按钮对象、插入 Flash 文本对象和插入 Flash 内容。

Flash 模板文件 (.swt) 使您能够修改和替换 Flash SWF 文件中的信息。这些文件用于 Flash 按钮对象中，使您能够用自己的文本或链接修改模板，以便创建要插入在您的文档中的自定义 SWF。在 Dreamweaver 中，可以在 Dreamweaver/Configuration/Flash Objects/Flash Buttons 和 Flash Text 文件夹中找到这些模板文件。

您可以从 Macromedia Exchange for Dreamweaver Web 站点 (www.macromedia.com/go/dreamweaver_exchange_cn) 下载新的按钮模板并将它们放置在 Flash Buttons 文件夹中。有关创建新按钮模板的更多信息，请参见 www.macromedia.com/go/flash_buttons 中有关该主题的文章。

Flash 元素文件 (.swc) 是一个 Flash SWF 文件，通过将此类文件合并到 Web 页，您可以创建丰富的 Internet 应用程序。Flash 元素有可自定义的参数，通过修改这些参数可以执行不同的应用程序功能。有关更多信息，请参见插入 Flash 元素和编辑 Flash 元素属性。

Flash 视频文件格式 (.flv)是一种视频文件，它包含经过编码的音频和视频数据，用于通过 Flash Player 传送。例如，如果有 QuickTime 或 Windows Media 视频文件，您可以使用编码器（如 Flash 8 Video Encoder 或 Sorensen Squeeze）将视频文件转换为 FLV 文件。有关更多信息，请访问 Flash 视频开发人员中心，网址为 www.macromedia.com/go/flv_devcenter。

相关主题

  • 使用其它应用程序
  • 插入和修改 Flash 按钮对象
  • 插入 Flash 文本对象
  • 插入 Flash 内容
  • 插入 Flash 视频内容


关于音频文件格式

下表描述了较为常见的音频文件格式以及每一种格式在 Web 设计上的一些优缺点。

.midi 或 .mid（乐器数字接口）格式用于器乐。许多浏览器都支持 MIDI 文件，并且不需要插件。尽管 MIDI 文件的声音品质非常好，但也可能因访问者的声卡而异。很小的 MIDI 文件就可以提供较长时间的声音剪辑。MIDI 文件不能被录制并且必须使用特殊的硬件和软件在计算机上合成。

.wav（Waveform 扩展名）格式文件具有较好的声音品质，许多浏览器都支持此类格式文件并且不要求插件。您可以从 CD、磁带、麦克风等录制您自己的 WAV 文件。但是，其较大的文件大小严格限制了可以在您的 Web 页面上使用的声音剪辑的长度。

.aif（音频交换文件格式，或 AIFF）格式与 WAV 格式类似，也具有较好的声音品质，大多数浏览器都可以播放它并且不要求插件；您也可以从 CD、磁带、麦克风等录制 AIFF 文件。但是，其较大的文件大小严格限制了您可以在您的 Web 页面上使用的声音剪辑的长度。

.mp3（运动图像专家组音频，即 MPEG-音频层-3）格式是一种压缩格式，它可令声音文件明显缩小。其声音品质非常好：如果正确录制和压缩 MP3 文件，其质量甚至可以和 CD 质量相媲美。MP3 技术使您可以对文件进行“流式处理”，以便访问者不必等待整个文件下载完成即可收听该文件。但是，其文件大小要大于 Real Audio 文件，因此通过典型的拨号（电话线）调制解调器连接下载整首歌曲可能仍要花较长的时间。若要播放 MP3 文件，访问者必须下载并安装辅助应用程序或插件，例如 QuickTime、Windows Media Player 或 RealPlayer。

.ra、.ram、.rpm 或 Real Audio 格式具有非常高的压缩程度，文件大小要小于 MP3。全部歌曲文件可以在合理的时间范围内下载。因为可以在普通的 Web 服务器上对这些文件进行“流式处理”，所以访问者在文件完全下载完之前就可听到声音。访问者必须下载并安装 RealPlayer 辅助应用程序或插件才可以播放这些文件。

qt、.qtm、.mov 和 QuickTime 是由 Apple Computer 开发的音频和视频格式。Apple Macintosh 操作系统中包含了 QuickTime，并且大多数使用音频、视频或动画的 Macintosh 应用程序都使用 QuickTime。PC 也可播放 QuickTime 格式的文件，但是要求特殊的 QuickTime 驱动程序。QuickTime 支持大多数编码格式，如 Cinepak、JPEG 和 MPEG。

注意

除了上面列出的比较常用的格式外，还有许多不同的音频和视频文件格式可在 Web 上使用。如果您遇到不熟悉的媒体文件格式，请找到该格式的创建者以获取有关如何以最佳的方式使用和部署该格式的信息。

相关主题

  • 插入和编辑媒体对象
  • 链接到音频文件
  • 嵌入声音文件


插入和编辑媒体对象

您可以在 Dreamweaver 文档中插入 Flash SWF 文件或对象、QuickTime 或 Shockwave 影片、Java applet、ActiveX 控件或者其它音频或视频对象。

若要在页面中插入媒体对象，请执行以下操作：

  1. 将插入点放在“文档”窗口中希望插入该对象的位置。
  2. 执行下列操作之一插入对象：
    • 在“插入”栏的“常用”类别中，单击“媒体”按钮，并选择要插入的对象类型的按钮。

    • 从“插入”>“媒体”子菜单中选择适当的对象。
    • 如果要插入的对象不是 Flash、Shockwave、Applet 或 ActiveX 对象，请使用 Netscape Navigator 插件按钮（“插入”栏中的拼图图标）插入对象。有关更多信息，请参见插入 Netscape Navigator 插件内容。

    在大多数情况下，将显示一个对话框，您可从中选择源文件并为媒体对象指定某些参数。

    提示

    若要不显示此类对话框，请选择“编辑”>“首选参数”>“常规”(Windows) 或“Dreamweaver”>“首选参数”>“常规”(Macintosh)，然后取消对“插入对象时显示对话框”选项的选择。若要忽略为显示对话框设置的任何首选参数，请在插入对象的同时按住 Ctrl 键 (Windows) 或 Option 键 (Macintosh)。（例如，若要在不指定文件的情况下为 Shockwave 影片插入占位符，请在按住 Control 键或 Option 键的同时，单击“常用”插入栏的“媒体”弹出菜单中的“Shockwave”按钮，或选择“插入”>“媒体”>“Shockwave”。）
  3. 完成“选择文件”或“插入 Flash”对话框。
  4. 单击“确定”。

    如果在“首选参数”中激活了“对象标签辅助功能属性”对话框，该对话框将出现（请参见优化工作区以进行有辅助功能的页面设计）。

  5. 如果出现“对象标签辅助功能属性”对话框，请完成此对话框，然后单击“确定”。

    有关更多信息，请参见设置“对象标签辅助功能属性”对话框选项。

    媒体对象随即出现在文档中。

    注意

    如果您单击“取消”，一个媒体对象占位符将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

    若要指定源文件，或设置尺寸以及其它参数和属性，请为每个对象使用属性检查器。有关编辑对象的辅助功能属性的信息，请参见编辑媒体对象的辅助功能属性。


编辑媒体对象的辅助功能属性

如果插入了媒体对象的辅助功能属性（请参见插入和编辑媒体对象），则可以在 HTML 代码中编辑这些值。

若要编辑媒体对象的辅助功能值，请执行以下操作：

  1. 在“文档”窗口中，选择该对象。
  2. 执行下列操作之一：
    • 在“代码”视图中编辑适当的属性。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“编辑标签代码”。


为媒体文件启动外部编辑器

您可以从 Dreamweaver 启动外部编辑器编辑大多数媒体文件。您也可以指定希望 Dreamweaver 启动用以编辑文件的编辑器。

本节包含以下主题：

  • 从 Dreamweaver 启动外部编辑器
  • 指定从 Dreamweaver 启动的编辑器

从 Dreamweaver 启动外部编辑器

您可以从 Dreamweaver 启动外部编辑器编辑大多数媒体文件。

若要从 Dreamweaver 启动外部编辑器，请执行以下操作：

  1. 确保该媒体文件类型与系统上的一个编辑器相关联。

    若要找出哪个编辑器与该文件类型相关联，请在 Dreamweaver 中选择“编辑”>“首选参数”，然后从“类别”列表中选择“文件类型/编辑器”。在“扩展名”列中单击该文件的扩展名以查看“编辑器”列中与之相关联的一个或多个编辑器。您可以更改与某个文件类型相关联的编辑器。有关更多信息，请参见指定从 Dreamweaver 启动的编辑器。

  2. 在“站点”面板中双击该媒体文件，以在外部编辑器中打开该文件。

    您在“站点”面板上双击文件时启动的编辑器称作主编辑器。例如，如果双击一个图像文件，Dreamweaver 将在主外部图像编辑器（如 Macromedia Fireworks）中打开该文件。

  3. 如果不想使用主外部编辑器编辑该文件，通过执行以下操作之一，您可以使用系统上的其它编辑器编辑该文件：
    • 在“站点”面板中，右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 文件名，然后从上下文菜单中选择“打开方式”。
    • 在“设计”视图中，右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 当前页面内的该媒体元素，然后从上下文菜单中选择“编辑方式”


指定从 Dreamweaver 启动的编辑器

您可以指定希望 Dreamweaver 用于编辑某一文件类型的编辑器，并可以添加或删除 Dreamweaver 识别的文件类型。

若要明确指定针对给定文件类型应启动何种外部编辑器，请执行以下操作：

  1. 选择“编辑”>“首选参数”，然后从“类别”列表中选择“文件类型/编辑器”。

    文件扩展名（例如 .gif、.wav 和 .mpg）在左侧的“扩展名”下列出。选定扩展名的关联编辑器在右侧的“编辑器”下列出。

  2. 在“扩展名”列表中选择文件类型扩展名，然后执行以下操作之一：
    • 若要将新的编辑器与该文件类型相关联，请单击“编辑器”列表上方的加号 (+) 按钮，然后完成出现的对话框。

      例如选择 Acrobat 的应用程序图标，使其与该文件类型相关联。

    • 若要使编辑器成为某文件类型的主编辑器（即在“站点”面板双击该文件类型时打开的编辑器），请在“编辑器”列表中选择该编辑器，然后单击“设为主要”。
    • 若要解除编辑器与文件类型的关联，请在“编辑器”列表中选择该编辑器，然后单击该列表上方的减号 (-) 按钮。

若要添加新的文件类型和相关联的编辑器，请执行以下操作：

  1. 单击“扩展名”列表上方的加号 (+) 按钮，然后输入一个文件扩展名（包括扩展名开头处的句点），或者输入由空格分隔的多个相关扩展名。

    例如，如果希望将 xml 和 xsl 文件与系统上安装的 XML 编辑器相关联，可以输入 .xml .xsl。

  2. 单击“编辑器”列表上方的加号 (+) 按钮并完成出现的对话框，为该文件类型选择一个编辑器。

若要删除文件类型，请执行以下操作：

  • 在“扩展名”列表中选择该文件类型，然后单击该列表上方的减号 (-) 按钮。

    注意

    在删除一个文件类型后将无法撤消该删除操作，所以删除文件类型时一定要慎重。

相关主题

  • 设置外部图像编辑器首选参数


将“设计备注”与媒体对象一起使用

与 Dreamweaver 中的其它对象一样，您可以将“设计备注”添加到媒体对象中。“设计备注”是与特定文件相关联的备注，存储于独立的文件中。您可以使用设计备注来记录与文档关联的其它文件信息，如图像源文件名称和文件状态说明。有关使用“设计备注”的更多信息，请参见在设计备注中存储文件信息。

若要将“设计备注”添加到某一媒体对象中，请执行以下操作：

  1. 在“文档”窗口中右键单击对象 (Windows) 或在按住 Control 键的同时单击对象 (Macintosh)。

    注意

    在将“设计备注”添加到任何对象之前，您必须定义站点（请参见对站点启用和禁用设计备注）。
  2. 从上下文菜单中选择“设计备注”。
  3. 在“设计备注”中输入您所需的信息。

    提示

    您还可以从“站点”面板将“设计备注”添加到媒体对象，方法是：选择该文件，显示上下文菜单，然后从上下文菜单中选择“设计备注”。


插入和修改 Flash 按钮对象

您可以在使用 Dreamweaver 时在文档中创建、插入和修改 Flash 按钮；无需使用 Macromedia Flash。Flash 按钮对象是基于 Flash 模板的可更新按钮。您可以自定义 Flash 按钮对象，并添加文本、背景颜色以及指向其它文件的链接。

本节包含以下主题：

  • 创建和插入 Flash 按钮
  • 修改 Flash 按钮对象
  • 在文档中播放 Flash 按钮对象

相关主题

  • 关于 Flash 文件类型
  • 插入 Flash 文本对象
  • 插入 Flash 内容
  • 使用 Flash


创建和插入 Flash 按钮

在“设计”视图或“代码”视图中工作时，您可以在文档中创建和插入 Flash 按钮。

注意

在插入 Flash 按钮或文本对象前，必须保存您的文档。

若要插入 Flash 按钮对象，请执行以下操作：

  1. 在“文档”窗口中，将插入点放置在您要插入 Flash 按钮的位置。
  2. 若要打开“插入 Flash 对象”对话框，请执行以下操作之一：
    • 在“插入”栏的“常用”类别中，选择“媒体”，然后单击“Flash 按钮”图标。 这是所描述的功能的图片。
    • 选择“插入”>“媒体”>“Flash 按钮”。

    即会出现“插入 Flash 按钮”对话框。

  3. 完成“插入 Flash 按钮”对话框，然后单击“应用”或“确定”，将 Flash 按钮插入“文档”窗口中。

    提示

    若要在“设计”视图中预览该按钮，请单击“应用”。该对话框保持打开状态，并且您可以在文档中预览该按钮。

相关主题

  • 修改 Flash 按钮对象
  • 在文档中播放 Flash 按钮对象


修改 Flash 按钮对象

您可以修改 Flash 按钮对象的属性和内容。

若要修改 Flash 按钮对象，请执行以下操作：

  1. 在“文档”窗口中，单击 Flash 按钮对象以选择它。
  2. 如果属性检查器尚未打开，则打开属性检查器。

    属性检查器显示 Flash 按钮属性。您可以使用属性检查器修改按钮的 HTML 属性，例如宽度、高度和背景颜色。

  3. 若要对内容进行更改，请使用以下方法之一显示“插入 Flash 按钮”对话框：
    • 双击 Flash 按钮对象。
    • 在属性检查器中单击“编辑”。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后从上下文菜单中选择“编辑”。
  4. 在“插入 Flash 按钮”对话框中，在之前介绍的文本框中进行编辑（请参见插入和修改 Flash 按钮对象）。

    在“设计”视图中，通过使用调整大小手柄可以很容易地调整对象的大小。您可以通过在属性检查器中选择“重设大小”，将该对象恢复为其初始大小（请参见调整图像大小）。

相关主题

  • 创建和插入 Flash 按钮
  • 在文档中播放 Flash 按钮对象


在文档中播放 Flash 按钮对象

您可以在 Dreamweaver“文档”窗口中预览 Flash 按钮。

若要在“文档”窗口中查看 Flash 按钮对象播放，请执行以下操作：

  1. 在处于“设计”视图中时，在文档中选择 Flash 按钮对象。
  2. 在属性检查器中单击“播放”。
  3. 单击“停止”可以结束预览。

    注意

    在 Flash 按钮对象正在播放时，您不能编辑它。

在浏览器中预览您的文档以查看 Flash 按钮的准确外观也是个不错的主意。

相关主题

  • 创建和插入 Flash 按钮
  • 修改 Flash 按钮对象


插入 Flash 文本对象

Flash 文本对象允许您创建和插入只包含文本的 Flash SWF 文件。这使您可以使用自己选择的设计器字体和文本创建较小的矢量图形影片。

若要插入 Flash 文本对象，请执行以下操作：

  1. 在“文档”窗口中，将插入点放置在您要插入 Flash 文本的地方。
  2. 若要打开“插入 Flash 文本”对话框，请执行以下操作之一：
    • 在“插入”栏的“常用”类别中，选择“媒体”，然后单击“Flash 文本”图标。 这是所描述的功能的图片。
    • 选择“插入”>“媒体”>“Flash 文本”。

    即会出现“插入 Flash 文本”对话框。

  3. 完成“插入 Flash 文本”对话框，然后单击“应用”或“确定”，将 Flash 文本插入“文档”窗口中。

    如果您单击“应用”，则对话框保持打开状态，并且您可以在您的文档中预览文本。

若要修改或播放 Flash 文本对象，所采用的步骤与您对 Flash 按钮进行修改或播放所采用的步骤相同（请参见修改 Flash 按钮对象）。

相关主题

  • 关于 Flash 文件类型
  • 插入和修改 Flash 按钮对象
  • 插入 Flash 内容
  • 使用 Flash


插入 Flash 内容

可以使用 Dreamweaver 将 Flash 内容插入到页面中。

若要插入 SWF 文件（Flash 内容），请执行以下操作：

  1. 在“文档”窗口的“设计”视图中，将插入点放置在您要插入内容的地方，然后执行以下操作之一：
    • 在“插入”栏的“常用”类别中，选择“媒体”，然后单击“插入 Flash”图标。 这是所描述的功能的图片。
    • 选择“插入”>“媒体”>“Flash”。
  2. 在显示的对话框中，选择一个 Flash 文件 (.swf)。

    Flash 占位符随即出现在“文档”窗口中（与 Flash 按钮和文本对象不同）。有关设置 Flash SWF 文件属性的信息，请参见设置 Flash 和 Shockwave 影片属性。

若要在“文档”窗口中预览 Flash 内容，请执行以下操作：

  1. 在“文档”窗口中，单击 Flash 占位符以选择您要预览的 Flash 内容。
  2. 在属性检查器中，单击“播放”按钮。单击“停止”可以结束预览。也可以通过按 F12 键在浏览器中预览 Flash 内容。

    提示

    若要预览某一页面中的所有 Flash 内容，请按下 Control+Alt+Shift+P 组合键 (Windows) 或 Shift+Option+Command+P 组合键 (Macintosh)。所有 Flash 对象和 SWF 文件都将被设置为“播放”。

相关主题

  • 关于 Flash 文件类型
  • 插入和修改 Flash 按钮对象
  • 插入 Flash 文本对象
  • 使用 Flash
  • 插入 Flash 视频内容


下载和安装 Flash 元素

若要在 Web 页中使用 Flash 元素，必须先使用扩展管理器将这些元素添加到 Dreamweaver 中。扩展管理器是一个独立的应用程序，可用于安装和管理 Macromedia 应用程序中的功能扩展。通过从 Dreamweaver 中选择“命令”>“管理扩展功能”启动扩展管理器。

若要为 Dreamweaver 查找最新的 Flash 元素，请使用 Macromedia Exchange Web 站点，网址为 www.macromedia.com/go/dreamweaver_exchange_cn。您可以在此处登录并下载 Flash 元素和其它 Dreamweaver 功能扩展（其中的许多功能扩展是免费的），还可以加入讨论组、查看用户的评论以及安装和使用功能扩展管理器。您必须先安装功能扩展管理器，然后再安装新的 Flash 元素或其它 Dreamweaver 功能扩展。

有关使用扩展管理器安装 Flash 元素（及其它 Dreamweaver 功能扩展）的信息，请参见添加功能扩展 Dreamweaver。


插入 Flash 元素

使用 Dreamweaver，您可以在文档中插入 Flash 元素。Flash 元素使您可以快速、方便地使用预置元素构建丰富的 Internet 应用程序。有关 Flash 元素及如何在 Web 页中使用它们的更多信息，请参见关于 Flash 文件类型。

若要插入 Flash 元素，请执行以下操作：

  1. 在“文档”窗口中，将插入点放置在您要插入 Flash 元素的地方，然后执行以下操作之一：
    • 在“插入”栏的“Flash 元素”类别中，单击要插入的 Flash 元素的图标。
    • 选择“插入”>“媒体”>“Flash 元素名称”。

      Dreamweaver 包含一个名为“图像查看器”的 Flash 元素。

    将出现“保存 Flash 元素”对话框。

  2. 为 Flash 元素输入一个文件名，然后将它保存到站点中的适当位置。
  3. 单击“确定”。

    Flash 元素占位符即出现在文档中。您可以使用标签和属性检查器来修改 Flash 元素的属性。有关更多信息，请参见编辑 Flash 元素属性。

  4. 选择“文件”>“在浏览器中预览”，以便预览 Flash 元素。


编辑 Flash 元素属性

您可以使用属性和标签检查器来编辑 Flash 元素属性。

若要编辑 Flash 元素的属性，请执行以下操作：

  1. 在“文档”窗口中，执行以下操作之一：
    • 在“设计”视图中，选择该 Flash 元素。
    • 在“代码”视图中，单击 Flash 组件名称或其内容中的任意位置。
  2. 如果标签检查器尚未显示，请打开标签检查器（“窗口”>“标签检查器”）。
  3. 使用标签检查器和属性检查器编辑 Flash 元素属性。
  4. 按 Enter 键 (Windows) 或 Return 键 (Macintosh)，或者单击标签检查器中的其它位置，以更新文档中的标签。

    有关完成标签检查器的信息，请参见设置 Flash 元素检查器。

相关主题

  • 插入 Flash 元素


插入 FlashPaper 文档

可以在 Web 页中插入 Macromedia FlashPaper 文档。在浏览器中打开包含 FlashPaper 文档的页面时，用户将能够浏览 FlashPaper 文档中的所有页面，而无需加载新的 Web 页。用户也可以搜索、打印和缩放该文档。

有关 FlashPaper 的更多信息，请参见 Macromedia Web 站点，网址为 www.macromedia.com/go/flashpaper。

若要在 Web 页中插入 FlashPaper 文档，请执行以下操作：

  1. 在“文档”窗口中，将插入点放在页面上想要显示 FlashPaper 文档的位置，然后选择“插入”>“媒体”>“FlashPaper”。
  2. 在“插入 FlashPaper”对话框中，浏览到一个 FlashPaper 文档并将其选定。
  3. 如果需要，通过输入宽度和高度（以像素为单位）指定 FlashPaper 对象在 Web 页上的尺寸。

    FlashPaper 将缩放文档以适合宽度。

  4. 单击“确定”在页面中插入文档。

    由于 FlashPaper 文档是 Flash 对象，因此页面上将出现一个 Flash 占位符。

  5. 若要预览 FlashPaper 文档，请单击该占位符，然后单击属性检查器中的“播放”按钮。

    单击“停止”可以结束预览。也可以通过按 F12 键在浏览器中预览该文档。FlashPaper 工具栏在浏览器中具有全部功能。

    提示

    若要预览某一页面中的所有 Flash 内容，请按下 Control+Alt+Shift+P 组合键 (Windows) 或 Shift+Option+Command+P 组合键 (Macintosh)。所有 Flash 对象和 SWF 文件都将被设置为“播放”。
  6. 如果需要，在属性检查器中设置其他属性。

    作为一种 Flash 对象，FlashPaper 对象将共用 Flash 对象的属性检查器。有关设置这些属性的信息，请单击属性检查器中的“帮助”按钮。


插入 Flash 视频内容

Dreamweaver 使您能够轻松地在 Web 页中插入 Flash 视频内容，而无需使用 Flash 创作工具。Dreamweaver 插入 Flash 视频组件；在浏览器中查看该组件时，它将显示您选择的 Flash 视频内容以及一组播放控件。

本节包含以下主题：

  • 关于插入 Flash 视频
  • 插入 Flash 视频
  • 检测查看 Flash 视频所需的 Flash Player 版本
  • 编辑和删除 Flash 视频组件

有关 Flash 视频的更多信息，请访问 Flash 视频开发人员中心，网址为 www.macromedia.com/go/flv_devcenter。


关于插入 Flash 视频

Dreamweaver 提供了以下选项，用于将 Flash 视频传送给站点访问者：

“累进式下载视频”将 Flash 视频 (FLV) 文件下载到站点访问者的硬盘上，然后播放。但是，与传统的“下载并播放”视频传送方法不同，渐进式下载允许在下载完成之前就开始播放视频文件。

“流视频”对 Flash 视频内容进行流式处理，并在一段很短时间的缓冲（可确保流畅播放）后在 Web 页上播放该内容。若要在 Web 页上启用流视频，您必须具有访问 Macromedia Flash Communication Server 的权限。

必须有一个经过编码的 Flash 视频 (FLV) 文件，然后才能在 Dreamweaver 中使用它。可以插入使用两种编解码器（压缩/解压缩技术）创建的视频文件：Sorenson Squeeze 和 On2。

  • 如果您使用 Sorenson Squeeze 编解码器创建视频，站点访问者将需要 Flash Player 7 或更高版本才能播放累进式下载视频；并且将需要 Flash Player 6.0.79 或更高版本来播放流视频。
  • 如果您使用 On2 编解码器创建视频，站点访问者将需要 Flash Player 8 或更高版本。

将 Flash 视频文件插入页面后，您可以在页面中插入代码，以检测用户是否拥有查看 Flash 视频所需的正确 Flash Player 版本。如果用户没有正确的版本，则会提示用户下载 Flash Player 的最新版本。有关更多信息，请参见检测查看 Flash 视频所需的 Flash Player 版本。

有关 Flash 视频的更多信息，请访问 Flash 视频开发人员中心，网址为 www.macromedia.com/go/flv_devcenter。

相关主题

  • 插入 Flash 视频内容
  • 检测查看 Flash 视频所需的 Flash Player 版本
  • 编辑和删除 Flash 视频组件


插入 Flash 视频

可以使用 Dreamweaver 在页面中插入 Flash 视频内容。在开始之前，必须有一个经过编码的 Flash 视频 (FLV) 文件。有关更多信息，请参见关于 Flash 文件类型。

若要在 Web 页中插入 Flash 视频，请执行以下操作：

  1. 选择“插入”>“媒体”>“Flash 视频”。
  2. 在“插入 Flash 视频”对话框中，从“视频类型”弹出式菜单中选择“累进式下载视频”或“流视频”。

    有关这两个选项的更多信息，请参见关于插入 Flash 视频。

  3. 完成对话框选项的其余部分。

    有关更多信息，请单击对话框上的“帮助”按钮。

    可以选择以下选项：插入检测查看 Flash 视频所需 Flash Player 版本的代码的选项，以及提示用户在没有正确版本时下载最新 Flash Player 版本的选项。有关更多信息，请参见检测查看 Flash 视频所需的 Flash Player 版本。

  4. 单击“确定”。

相关主题

  • 设置“插入 Flash 视频”对话框选项
  • 检测查看 Flash 视频所需的 Flash Player 版本
  • 编辑和删除 Flash 视频组件


检测查看 Flash 视频所需的 Flash Player 版本

将 Flash 视频文件插入页面时，您还可以插入代码以检测用户是否拥有查看 Flash 视频所需的正确 Flash Player 版本。如果用户没有正确的版本，则会提示用户下载 Flash Player 的最新版本。

取决于用于创建视频的编解码器，可能需要不同版本的 Flash Player 来查看 Flash 视频。如果视频是用 Sorenson Squeeze 编解码器创建的，站点访问者将需要 Flash Player 7 或更高版本才能播放累进式下载视频，并且将需要 Flash Player 6.0.79 或更高版本来播放流视频。如果视频是用 On2 编解码器创建的，站点访问者将需要 Flash Player 8 或更高版本。

若要插入检测 Flash Player 版本的代码，请执行以下操作：

  1. 在页面中插入 Flash 视频时，在“插入 Flash 视频”对话框中，选择“如果必要，提示用户下载 Flash Player”选项。

    如果页面中已有 Flash 视频，请将其删除，并使用选定的选项并再次插入它。

    注意

    如果插入另一个 Flash 视频，它需要比第一个视频更高的 Flash Player 版本，则检测代码将提示用户下载该版本。
  2. 接受默认警告消息，或提供您自己的警告消息。

如果决定从页面中删除 Flash 视频，则不再需要检测代码。可以使用 Dreamweaver 将其删除。

若要删除检测 Flash Player 版本的代码，请执行以下操作：

  • 选择“命令”>“删除 Flash 视频检测”。

相关主题

  • 设置“插入 Flash 视频”对话框选项
  • 插入 Flash 视频
  • 编辑和删除 Flash 视频组件


编辑和删除 Flash 视频组件

若要在 Web 页面中更改 Flash 视频内容的设置，您必须在 Dreamweaver 的“文档”窗口中选择 Flash 视频组件占位符并使用属性检查器，或者通过选择“插入”>“媒体”>“Flash 视频”来删除 Flash 视频组件并重新插入它。

编辑 Flash 视频组件:

  1. 在 Dreamweaver 的“文档”窗口中，单击 Flash 视频组件占位符中央的 Flash 视频图标选择该占位符。
  2. 打开属性检查器（“窗口”>“属性”）。
  3. 进行更改。

    属性检查器中的选项与“插入 Flash 视频”对话框中的选项类似。有关更多信息，请参见设置“插入 Flash 视频”对话框选项。

    注意

    您不能使用属性检查器更改视频类型（例如，从“累进式下载”更改为“流式”）。若要更改视频类型，必须删除 Flash 视频组件，然后通过选择“插入”>“媒体”>“Flash 视频”来重新插入它。

删除 Flash 视频组件:

  • 在 Dreamweaver 的“文档”窗口中选择 Flash 视频组件占位符，然后按 Delete 键。

相关主题

  • 插入 Flash 视频内容


插入 Shockwave 影片

可以使用 Dreamweaver 将 Shockwave 影片插入到文档中。Shockwave 作为 Web 上用于交互式多媒体的 Macromedia 标准，是一种经压缩的格式，使得在 Macromedia Director 中创建的多媒体文件能够被快速下载，而且可以在大多数常用浏览器中进行播放。

若要插入 Shockwave 影片，请执行以下操作：

  1. 在“文档”窗口中，将插入点放置在您要插入 Shockwave 影片的地方，然后执行以下操作之一：
    • 在“插入”栏的“常用”类别中，单击“媒体”按钮，然后从菜单中选择“Shockwave”图标。 这是所描述的功能的图片。
    • 选择“插入”>“媒体”>“Shockwave”。
  2. 在显示的对话框中，选择一个影片文件。
  3. 在属性检查器中，在“宽”和“高”文本框中分别输入影片的宽度和高度。

    有关其它属性的信息，请参见设置 Flash 和 Shockwave 影片属性。


添加视频（非 Flash）

您可以通过不同方式和使用不同格式将视频添加到 Web 页面。视频可被下载给用户，或者可以对视频进行流式处理以便在下载它的同时播放它。

若要在页面中包含一个可供用户下载的简短的视频剪辑，请执行以下操作：

  1. 将剪辑放入站点文件夹。

    这些剪辑通常采用 AVI 或 MPEG 文件格式。

  2. 链接到剪辑，或将其嵌入到页面中。

    若要链接到剪辑，请输入链接文本（如“下载剪辑”），选择文本，然后在属性检查器中单击文件夹图标。浏览到视频文件然后选择它。

有关如何在页面中包含流式视频的信息，请参见插入 Netscape Navigator 插件内容。

注意

用户必须下载辅助应用程序才能查看常见的流式处理格式，如 Real Media、QuickTime 和 Windows Media。


向页面添加声音

可以向 Web 页添加声音。有多种不同类型的声音文件和格式，例如 .wav、.midi 和 .mp3。有关更多信息，请参见关于音频文件格式。在确定采用哪一格式和方法添加声音前，需要考虑以下一些因素：添加声音的目的、您的观众、文件大小、声音品质和不同浏览器中的差异。

注意

浏览器不同，处理声音文件的方式也会有很大差异和不一致的地方。您可能需要将声音文件添加到 Flash SWF 文件，然后嵌入 SWF 文件以改善一致性。

本节包含以下主题：

  • 链接到音频文件
  • 嵌入声音文件

链接到音频文件

链接到音频文件是将声音添加到 Web 页面的一种简单而有效的方法。这种集成声音文件的方法可以使访问者能够选择他们是否要收听该文件，并且使文件可用于最广范围的观众。

若要创建指向某一音频文件的链接，请执行以下操作：

  1. 选择您要用作指向音频文件的链接的文本或图像。
  2. 在属性检查器中，单击文件夹图标以浏览音频文件，或者在“链接”文本框中键入文件的路径和名称。


嵌入声音文件

嵌入音频将声音直接并入页面中，但只有在访问您站点的访问者具有所选声音文件的适当插件后，声音才可以播放。如果希望将声音用作背景音乐，或如果希望控制音量、播放器在页面上的外观或者声音文件的开始点和结束点，请嵌入文件。

提示

将声音文件并入 Web 页面时，请仔细考虑它们在 Web 站点内的适当使用方式，以及站点访问者如何使用这些媒体资源。因为访问者有时可能不希望听到音频内容，所以总要提供启用或禁用声音播放的控制。

若要嵌入音频文件，请执行以下操作：

  1. 在“设计”视图中，将插入点放置在您要嵌入文件的地方，然后执行以下操作之一：
    • 在“插入”栏的“常用”类别中，单击“媒体”按钮，然后选择“插件”图标。
    • 选择“插入”>“媒体”>“插件”。

    有关插件对象的更多信息，请参见插入 Netscape Navigator 插件内容。

  2. 在属性检查器中，单击文件夹图标以浏览音频文件，或者在“链接”文本框中键入文件的路径和名称。
  3. 通过在适当的文本框中输入值或者通过在“文档”窗口中调整插件占位符的大小，输入宽度和高度。

    这些值确定音频控件在浏览器中以多大的大小显示。


插入 Netscape Navigator 插件内容

在创建用于 Netscape Navigator 插件的 QuickTime 影片等内容后，可以使用 Dreamweaver 将该内容插入 HTML 文档中。典型的插件包括 RealPlayer 和 QuickTime，而一些内容文件本身包括 MP3 和 QuickTime 影片。

本节包含以下主题：

  • 将插件内容插入到页面中
  • 在“文档”窗口中播放插件
  • Netscape Navigator 插件答疑


将插件内容插入到页面中

页面中可包含将在用户浏览器的插件中运行的内容。

若要插入 Netscape Navigator 插件内容，请执行以下操作：

  1. 在“文档”窗口的“设计”视图中，将插入点放置在您要插入内容的地方，然后执行以下操作之一：
    • 在“插入”栏的“常用”类别中，选择“媒体”，然后单击“插件”图标。 这是所描述的功能的图片。
    • 选择“插入”>“媒体”>“插件”。
  2. 在显示的对话框中，为 Netscape Navigator 插件选择内容文件。

    有关可用属性的信息，请参见设置 Netscape Navigator 插件属性。

相关主题

  • 在“文档”窗口中播放插件
  • Netscape Navigator 插件答疑


在“文档”窗口中播放插件

可以直接在“文档”窗口的“设计”视图中预览基于 Netscape Navigator 插件的影片和动画。）您可以同时播放所有插件元素，以查看用户实际看到的页面效果；或者您也可以单独播放每一元素，以确保您嵌入了正确的媒体元素。

注意

不能预览基于 ActiveX 控件的影片或动画。

若要在“设计”视图中播放影片，必须在您的计算机上安装正确的插件。

若要在“文档”窗口中播放插件内容，请执行以下操作：

  1. 通过选择“插入”>“媒体”>“Shockwave”、“插入”>“媒体”>“Flash”或“插入”>“媒体”>“插件”，插入一个或多个媒体元素。
  2. 执行下列操作之一：
    • 选择您已插入的媒体元素之一，然后选择“查看”>“插件”>“播放”或在属性检查器中单击“播放”按钮。
    • 选择“查看”>“插件”>“播放全部”以播放选定页面上基于插件的所有媒体元素。

      注意

      “播放全部”仅应用于当前文档；例如，它不应用于框架页中的其它文档。

若要停止播放插件内容，请执行以下操作：

  • 选择媒体元素并选择“查看”>“插件”>“停止”，或者在属性检查器中单击“停止”按钮。

    您还可以选择“查看”>“插件”>“停止全部”以停止播放全部插件内容。


Netscape Navigator 插件答疑

如果您遵守上述步骤在“文档”窗口中播放插件内容，但某些插件内容不播放，则尝试执行以下操作：

  • 确保在您的计算机上安装了关联的插件，并且内容与您具有的插件版本兼容。
  • 在文本编辑器中打开文件 Configuration/Plugins/UnsupportedPlugins.txt，查看文件中是否列出了有问题的插件。此文件记录在 Dreamweaver 中导致问题并因此不受支持的插件。（如果您在使用特定插件时出现问题，请考虑将其添加到该文件中。
  • 请检查是否有足够的内存。某些插件要求额外的 2 到 5 MB 的内存才可以运行。


插入 ActiveX 控件

可以在页面中插入 Active X 控件。ActiveX 控件（以前称作 OLE 控件）是可以充当浏览器插件的可重复使用的组件，有些像微型的应用程序。ActiveX 控件在 Windows 系统上的 Internet Explorer 中运行，但它们不在 Macintosh 系统上或 Netscape Navigator 中运行。Dreamweaver 中的 ActiveX 对象使您可为访问者的浏览器中的 ActiveX 控件提供属性和参数。

若要插入 ActiveX 控件内容，请执行以下操作：

  1. 在“文档”窗口中，将插入点放置在您要插入内容的地方，然后执行以下操作之一：
    • 在“插入”栏的“常用”类别中，单击“媒体”按钮上的下拉箭头，然后选择“ActiveX”图标。 这是所描述的功能的图片。
    • 在“插入”栏的“常用”类别中，单击“媒体”按钮上的下拉箭头，然后选择“ActiveX”图标。如果 ActiveX 图标显示在“插入”栏中，您可以将该图标拖放到“文档”窗口中
    • 选择“插入”>“媒体”>“ActiveX”。

    出现的图标标记出 Internet Explorer 中 ActiveX 控件将在页面上出现的位置。

    有关可用属性的信息，请参见设置 ActiveX 属性。


插入 Java applet

可以使用 Dreamweaver 将 Java applet 插入 HTML 文档中。Java 是一种编程语言，通过它可以开发可嵌入 Web 页中的小型应用程序 (applet)。

若要插入 Java applet，请执行以下操作：

  1. 在“文档”窗口中，将插入点放置在您要插入 applet 的地方，然后执行以下操作之一：
    • 在“插入”栏的“常用”类别中，单击“媒体”按钮上的下拉箭头，然后选择“Applet”图标 这是所描述的功能的图片。 。
    • 选择“插入”>“媒体”>“Applet”。
  2. 在出现的对话框中，选择包含 Java applets 的文件。

    有关可用属性的信息，请参见设置 Java applet 属性。


使用行为控制媒体

您可以将行为添加到您的页面上以开始和停止各种媒体对象。

“控制 Shockwave 或 Flash”使您可以播放、停止、倒带或转到 Shockwave 或 Flash SWF 文件中的帧（请参见控制 Shockwave 或 Flash）。

“播放声音”使您可以播放声音；例如，只要用户将鼠标指针移到某一链接上，您就可以播放声音效果（请参见播放声音）。

检查插件使您可以查看您站点上的访问者是否安装有所需的插件，然后根据其是否具有正确的插件将他们转到不同的 URL。这仅适用于 Netscape Navigator 插件，因为“检查插件”行为不检查 ActiveX 控件。有关更多信息，请参见检查插件。


参考资料

本节提供在本章中介绍的以下几个对话框和属性检查器的有关信息：

  • 设置 Flash 对象属性
  • 使用参数控制媒体对象
  • 设置“插入 Flash 视频”对话框选项
  • 设置 Flash 和 Shockwave 影片属性
  • 设置 Netscape Navigator 插件属性
  • 设置 ActiveX 属性
  • 设置 Java applet 属性
  • 设置“对象标签辅助功能属性”对话框选项
  • 设置“插入 Flash 按钮”对话框选项
  • 设置 Flash 元素检查器
  • 设置 Flash 元素“编辑数组”对话框选项


设置 Flash 对象属性

Flash 对象（在 Dreamweaver 中生成的按钮和文本对象）的属性检查器最初显示最常用的属性。单击右下角的扩展箭头可以看到更多的属性。

“名称”指定用来标识按钮以进行脚本撰写的名称。在属性检查器最左侧的未标记文本框中输入名称。

“宽”和“高”以像素为单位指定对象的宽度和高度。

“文件”指定指向 Flash 对象文件的路径。单击文件夹图标以浏览到某一文件，或者键入路径。

“编辑”打开 Flash 对象对话框，可以对选定的 Flash 对象进行编辑。

“重设大小”将选定的对象重设为原始大小。

“垂直边距”和“水平边距”指定按钮上、下、左、右空白的像素数。

“品质”为定义该按钮的 object 和 embed 标签设置 quality 参数。设置越高，Flash 内容的显示效果就越好；但这要求更快的处理器以使内容在屏幕上正确显示。“低品质”设置意味着更看重速度而非外观，而“高品质”设置意味着更看重外观而非速度。“自动低品质”意味着首先看重速度，但如有可能则改善外观。“自动高品质”意味着首先看重这两种品质，但根据需要可能会因为速度而影响外观。

“比例”为定义按钮或文本对象的 object 和 embed 标签设置 scale 参数。此参数定义 Flash 内容在由 width 和 height 值为该 SWF 文件定义的区域内显示的方式。选项有“默认（全部显示）”、“无边框”和“严格匹配”。“全部显示”使在指定区域中可以看到整个 SWF 文件，同时保持 SWF 文件的纵横比并避免扭曲；背景颜色的边框可以出现在 SWF 文件的两侧。“无边框”近似于“全部显示”，只是 SWF 文件的某些部分可能会被裁剪掉。使用“严格匹配”，整个 SWF 文件将填充指定区域，但不保持 SWF 文件的纵横比并且可能会出现扭曲。

“对齐”定义对象在页面上的对齐方式。有关每一选项的说明，请参见对齐图像。

“背景颜色”指定对象的背景颜色。

“播放/停止”使您可以在“文档”窗口中预览 Flash 对象。单击绿色的“播放”按钮可在播放模式下查看对象；单击红色的“停止”按钮可以停止对象播放并能够编辑对象。

“参数”打开一个对话框，可以在其中输入附加参数（请参见使用参数控制媒体对象）。


使用参数控制媒体对象

使用“参数”对话框可为 Shockwave 和 Flash SWF 文件、ActiveX 控件、Netscape Navigator 插件和 Java applets 定义的特殊参数输入值。这些参数与 object、embed 和 applet 标签一起使用。参数设置特定于所插入的对象类型的属性。例如，对于对象标签，Flash 对象可以有 quality 参数 <param name="quality" value="best">。“参数”对话框是在属性检查器中提供的。有关您正使用的对象所需参数的信息，请参见其相关文档。

注意

现在尚没有用于标识 ActiveX 控件的数据文件的广泛接受标准。请查询您正使用的 ActiveX 控件的有关文档，了解要使用哪些参数。

若要打开“参数”对话框，请执行以下操作：

  1. 在“文档”窗口中选择可具有参数的对象（例如 Shockwave 影片、ActiveX 控件、Netscape Navigator 插件或 Java Applet）。
  2. 使用以下方法之一打开对话框：
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该对象，然后从上下文菜单中选择“参数”。
    • 如果属性检查器尚未打开，则打开它；单击在属性检查器下半部分中提供的“参数”按钮。（确保属性检查器已被展开。

若要在“参数”对话框中输入参数的值，请执行以下操作：

  1. 单击加号 (+) 按钮。
  2. 在“参数”列中输入参数的名称。
  3. 在“值”列中输入该参数的值。

若要删除参数，请执行以下操作：

  • 选择一个参数并按减号 (-) 按钮。

若要对参数重新排序，请执行以下操作：

  • 选择某一参数并使用上箭头和下箭头按钮。


设置“插入 Flash 视频”对话框选项

此对话框允许您为插入 Web 页中的 Flash 视频 (FLV) 文件设置选项。

若要针对累进式下载视频完成“插入 Flash 视频”对话框，请执行以下操作：

  1. 从“视频类型”弹出式菜单中选择“累进式下载视频”。
  2. 指定以下选项：

    “URL” 指定 FLV 文件的相对或绝对路径。若要指定相对路径（例如，mypath/myvideo.flv），请单击“浏览”按钮，导航到 FLV 文件并将其选定。若要指定绝对路径，请键入 FLV 文件的 URL（例如，http://www.example.com/myvideo.flv）。

    注意

    要使视频播放器正常工作，FLV 文件必须包含元数据。使用 Flash Communication Server 1.5.2、FLV Exporter 1.2 版和 Sorenson Squeeze 4.0 创建的 FLV 文件自动包含元数据。

    在 Macintosh 上，如果要指向 HTML 文件向上两层或更多层目录中的 FLV 文件，您必须使用绝对路径。

    “外观”指定 Flash 视频组件的外观。所选外观的预览会出现在“外观”弹出式菜单下方。

    “宽度”以像素为单位指定 FLV 文件的宽度。若要让 Dreamweaver 确定 FLV 文件的准确宽度，请单击“检测大小”按钮。如果 Dreamweaver 无法确定宽度，您必须键入宽度值。

    “高度”以像素为单位指定 FLV 文件的高度。若要让 Dreamweaver 确定 FLV 文件的准确高度，请单击“检测大小”按钮。如果 Dreamweaver 无法确定高度，您必须键入高度值。

    注意

    “包括外观”是 FLV 文件的宽度和高度与所选外观的宽度和高度相加得出的和。

    “限制”保持 Flash 视频组件的宽度和高度之间的纵横比不变。默认情况下会选择此选项。

    “自动播放”指定在 Web 页面打开时是否播放视频。

    “自动重新播放”指定播放控件在视频播放完之后是否返回起始位置。

    “必要时提示用户下载 Flash Player”可在页面中插入代码，该代码将检测查看 Flash 视频所需的 Flash Player 版本，并在用户没有所需的版本时提示他们下载 Flash Player 的最新版本。有关更多信息，请参见检测查看 Flash 视频所需的 Flash Player 版本。

    “消息”指定将在用户需要下载查看 Flash 视频所需的 Flash Player 最新版本时显示的消息。

  3. 单击“确定”关闭对话框并将 Flash 视频内容添加到 Web 页。

    “插入 Flash 视频”命令生成一个视频播放器 SWF 文件和一个外观 SWF 文件，它们用于在 Web 页面上显示 Flash 视频内容。（若要查看新的文件，您可能需要在“文件”面板中单击“刷新”按钮。）这些文件与 Flash 视频内容所添加到的 HTML 文件存储在同一目录中。当您上传包含 Flash 视频内容的 HTML 页时，Dreamweaver 将以相关文件的形式上传这些文件（只要您在“要上传相关文件？”对话框中单击了“是”）。

若要针对流视频完成“插入 Flash 视频”对话框，请执行以下操作：

  1. 从“视频类型”弹出式菜单中选择“流视频”。
  2. 指定以下选项：

    “服务器 URI”以 rtmp://www.example.com/app_name/instance_name 的形式指定服务器名称、应用程序名称和实例名称。

    “流名称”指定想要播放的 FLV 文件的名称（例如，myvideo.flv）。.flv 扩展名是可选的。

    注意

    要使视频播放器正常工作，FLV 文件必须包含元数据。使用 Flash Communication Server 1.5.2、FLV Exporter 1.2 版和 Sorenson Squeeze 4.0 创建的 FLV 文件自动包含元数据。

    “外观”指定 Flash 视频组件的外观。所选外观的预览会出现在“外观”弹出式菜单下方。

    “宽度”以像素为单位指定 FLV 文件的宽度。若要让 Dreamweaver 确定 FLV 文件的准确宽度，请单击“检测大小”按钮。如果 Dreamweaver 无法确定宽度，您必须键入宽度值。

    “高度”以像素为单位指定 FLV 文件的高度。若要让 Dreamweaver 确定 FLV 文件的准确高度，请单击“检测大小”按钮。如果 Dreamweaver 无法确定高度，您必须键入高度值。

    注意

    “包括外观”是 FLV 文件的宽度和高度与所选外观的宽度和高度相加得出的和。

    “限制”保持 Flash 视频组件的宽度和高度之间的纵横比不变。默认情况下会选择此选项。

    “实时视频输入”指定 Flash 视频内容是否是实时的。如果选定了“实时视频输入”，Flash Player 将播放从 Flash Communication Server 流入的实时视频输入。实时视频输入的名称是在“流名称”文本框中指定的名称。

    注意

    如果选择了“实时视频输出”，组件的外观上只会显示音量控件，因为您无法操纵实时视频。此外，“自动播放”和“自动重新播放”选项也不起作用。

    “自动播放”指定在 Web 页面打开时是否播放视频。

    “自动重新播放”指定播放控件在视频播放完之后是否返回起始位置。

    “缓冲时间”指定在视频开始播放之前进行缓冲处理所需的时间（以秒为单位）。默认的缓冲时间设置为 0，这样在单击了“播放”按钮后视频会立即开始播放。（如果选择“自动播放”，视频将在建立与服务器的连接后立即开始播放。）如果您要发送的视频的比特率高于站点访问者的连接速度，或者 Internet 通信可能会导致带宽或连接问题，则可能需要设置缓冲时间。例如，如果要在 Web 页面播放视频之前将 15 秒的视频发送到 Web 页面，请将缓冲时间设置为 15。

    “必要时提示用户下载 Flash Player”可在页面中插入代码，该代码将检测查看 Flash 视频所需的 Flash Player 版本，并在用户没有所需的版本时提示他们下载 Flash Player 的最新版本。有关更多信息，请参见检测查看 Flash 视频所需的 Flash Player 版本。

    “消息”指定将在用户需要下载查看 Flash 视频所需的 Flash Player 最新版本时显示的消息。

  3. 单击“确定”关闭对话框并将 Flash 视频内容添加到 Web 页。

    “插入 Flash 视频”命令生成一个视频播放器 SWF 文件和一个外观 SWF 文件，它们用于在 Web 页上显示 Flash 视频。该命令还会生成一个 main.asc 文件，您必须将该文件上传到 Flash Communication Server。（若要查看新的文件，您可能需要在“文件”面板中单击“刷新”按钮。）这些文件与 Flash 视频内容所添加到的 HTML 文件存储在同一目录中。上传包含 Flash 视频内容的 HTML 页面时，请不要忘记将这些 SWF 文件上传到 Web 服务器，并将 main.asc 文件上传到 Flash Communication Server。

    注意

    如果服务器上已有 main.asc 文件，请确保在上传由“插入 Flash 视频”命令生成的 main.asc 文件之前与服务器管理员核实。

    您可以轻松地上传所有所需的媒体文件，方法是在 Dreamweaver 的“文档”窗口中选择 Flash 视频组件占位符，然后在属性检查器（“窗口”>“属性”）中单击“上传媒体”按钮。若要查看所需文件的列表，请单击“显示所需的文件”。

    注意

    “上传媒体”按钮不会上传包含 Flash 视频内容的 HTML 文件。

相关主题

  • 关于插入 Flash 视频
  • 插入 Flash 视频
  • 检测查看 Flash 视频所需的 Flash Player 版本
  • 编辑和删除 Flash 视频组件


设置 Flash 和 Shockwave 影片属性

为了确保在 Internet Explorer 和 Netscape Navigator 中都获得最佳结果，Dreamweaver 同时使用 object 和 embed 标签插入 Flash 和 Shockwave 影片。（object 标签是 Microsoft 为 ActiveX 控件定义的；embed 标签是 Netscape Navigator 为插件定义的。）若要在属性检查器中查看以下属性，请选择一个 Flash SWF 文件或 Shockwave 影片。有关更多信息，请参见插入和修改 Flash 按钮对象和插入 Shockwave 影片。

若要查看所有 Flash SWF 文件属性，请单击属性检查器右下角的扩展箭头。

“名称”指定用来标识影片以进行脚本撰写的名称。在属性检查器最左侧的未标记文本框中输入名称。

“宽”和“高”以像素为单位指定影片的宽度和高度。

“文件”指定指向 Flash 或 Shockwave 文件的路径。单击文件夹图标以浏览到某一文件，或者键入路径。

“源文件”指定 Flash 源文档 (FLA) 的路径（如果计算机上同时安装了 Dreamweaver 和 Flash）。若要编辑 Flash 文件 (SWF)，请更新影片的源文档。

“编辑”允许您启动 Flash 以更新 FLA 文件。如果计算机上没有加载 Flash，此按钮将被禁用。有关编辑插入的 Flash SWF 文件的信息，请参见在 Dreamweaver 中编辑 Flash 内容。

“重设大小”将选定影片返回到其初始大小。

“循环”， 在选中该选项时影片将连续播放；如果没有选中该选项，则影片在播放一次后即停止播放。

“自动播放”， 如果选中该选项，则在加载页面时自动播放影片。

“垂直边距”和“水平边距”指定影片上、下、左、右空白的像素数。

“品质”在影片播放期间控制抗失真。设置越高，影片的观看效果就越好；但这要求更快的处理器以使影片在屏幕上正确显示。“低品质”设置意味着更看重速度而非外观，而“高品质”设置意味着更看重外观而非速度。“自动低品质”意味着首先看重速度，但如有可能则改善外观。“自动高品质”意味着首先看重这两种品质，但根据需要可能会因为速度而影响外观。

“比例”确定影片如何适合在宽度和高度文本框中设置的尺寸。“默认值”设置显示整个影片。

“无边框”使影片适合设定的尺寸，因此无边框显示并维持原始的纵横比。

“严格匹配”对影片进行缩放以适合设定的尺寸，而不管纵横比如何。

“对齐”确定影片在页面上的对齐方式。有关每一对齐选项的说明，请参见对齐图像。

“背景颜色”指定影片区域的背景颜色。在不播放影片时（在加载时和在播放后）也显示此颜色。

“参数”打开一个对话框，可在其中输入传递给影片的附加参数。有关添加或删除参数的更多信息，请参见使用参数控制媒体对象。影片必须已设计好，可以接收这些附加参数。


设置 Netscape Navigator 插件属性

在插入用于 Netscape Navigator 插件的内容后（请参见插入 Netscape Navigator 插件内容），请使用属性检查器为这些内容设置参数。若要在属性检查器中查看以下属性，请选择某一 Netscape Navigator 插件对象。

属性检查器最初显示最常用的属性。单击右下角的扩展箭头可以看到所有属性。

“名称”指定用来标识插件以进行脚本撰写的名称。在属性检查器最左侧的未标记文本框中输入名称。

“宽”和“高”以像素为单位指定在页面上分配给对象的宽度和高度。

“源文件”指定源数据文件。单击文件夹图标以浏览到某一文件，或者输入文件名。

“插件 URL”指定 pluginspace 属性的 URL。输入用户可以从中下载插件的站点的完整 URL。如果正查看您的页面的用户不具有该插件，则浏览器尝试从该 URL 下载它。

对齐确定对象在页面上的对齐方式。有关每一选项的说明，请参见对齐图像。

“垂直边距”和“水平边距”以像素为单位指定插件上、下、左、右的空白量。

“边框”指定环绕插件周围的边框的宽度。

“参数”打开一个对话框，在其中可输入传递给 Netscape Navigator 插件的附加参数（请参见使用参数控制媒体对象）。许多插件都受到特殊参数的控制。例如，Flash 插件包括用于 bgcolor、salign 和 scale 的参数。

您还可以通过单击“属性”按钮，查看指派给选定插件的属性。您可以在此对话框中编辑、添加和删除各种属性，如宽度和高度。


设置 ActiveX 属性

在插入 ActiveX 对象后（请参见插入 ActiveX 控件），请使用属性检查器设置 object 标签的属性以及 ActiveX 控件的参数。在属性检查器中单击“参数”以输入未在属性检查器中显示的属性的名称和值。现在尚没有用于 ActiveX 控件的参数的广泛接受标准格式；若要了解要使用哪些参数，请查询您正使用的 ActiveX 控件的有关文档。

属性检查器最初显示最常用的属性。单击右下角的扩展箭头可以看到所有属性。

“名称”指定用来标识 ActiveX 对象以进行脚本撰写的名称。在属性检查器最左侧的未标记文本框中输入名称。

“宽”和“高”以像素为单位指定对象的宽度和高度。

“类 ID”为浏览器标识 ActiveX 控件。输入一个值或从弹出菜单中选择一个值。在加载页面时，浏览器使用该类 ID 来确定与该页面关联的 ActiveX 控件所需的 ActiveX 控件的位置。如果浏览器未找到指定的 ActiveX 控件，则它将尝试从“基址”指定的位置中下载它。

“嵌入”为该 ActiveX 控件在 object 标签内添加 embed 标签。如果 ActiveX 控件具有等效的 Netscape Navigator 插件，则 embed 标签将激活该插件。Dreamweaver 将您作为 ActiveX 属性输入的值指派给等效的 Netscape Navigator 插件。

对齐确定对象在页面上的对齐方式。有关每一选项的说明，请参见对齐图像。

“参数”打开一个对话框，在其中可输入传递给 ActiveX 对象的附加参数（请参见使用参数控制媒体对象）。许多 ActiveX 控件都受到特殊参数的控制。

“源文件”定义如果启用了“嵌入”选项，将要用于 Netscape Navigator 插件的数据文件。如果您没有输入值，则 Dreamweaver 将尝试根据已输入的 ActiveX 属性确定该值。

“垂直边距”和“水平边距”以像素为单位指定对象上、下、左、右的空白量。

“基址”指定包含该 ActiveX 控件的 URL。如果在访问者的系统中尚未安装该 ActiveX 控件，则 Internet Explorer 从该位置下载它。如果您没有指定“基址”参数并且如果您的访问者尚未安装相应的 ActiveX 控件，则浏览器无法显示 ActiveX 对象。

“替代图像”指定在浏览器不支持 object 标签的情况下要显示的图像。只有在取消对“嵌入”选项的选择后此选项才可用。

“数据”为要加载的 ActiveX 控件指定数据文件。许多 ActiveX 控件（例如 Shockwave 和 RealPlayer）不使用此参数。


设置 Java applet 属性

在插入 Java applet 后（请参见插入 Java applet），请使用属性检查器设置参数。若要在属性检查器中查看以下属性，请选择某一 Java applets。

属性检查器最初显示最常用的属性。单击右下角的扩展箭头可以看到所有属性。

“名称”指定用来标识 applet 以进行脚本撰写的名称。在属性检查器最左侧的未标记文本框中输入名称。

“宽”和“高”以像素为单位指定 applet 的宽度和高度。

“代码”指定包含该 applet 的 Java 代码的文件。单击文件夹图标以浏览到某一文件，或者输入文件名。

“基址”标识包含选定 applet 的文件夹。在您选择了一个 applet 后，此文本框被自动填充。

对齐确定对象在页面上的对齐方式。有关每一选项的说明，请参见对齐图像。

“替代”指定在用户的浏览器不支持 Java applet 或者已禁用 Java 的情况下将要显示的替代内容（通常为一个图像）。如果您输入文本，Dreamweaver 将插入该文本，作为 applet 的 alt 属性的值。如果您选择一个图像，Dreamweaver 将在开始和结束 applet 标签之间插入 img 标签。

注意

若要指定在 Netscape Navigator（已禁用 Java）和 Lynx（基于文本的浏览器）中均可查看的替代内容，请选择一个图像，然后在代码检查器中手动将 alt 属性添加到 img 标签中。

“垂直边距”和“水平边距”以像素为单位指定 applet 上、下、左、右的空白量。

“参数”打开一个对话框，可在其中输入传递给 applet 的附加参数（请参见使用参数控制媒体对象）。许多 applets 都受到特殊参数的控制。


设置“对象标签辅助功能属性”对话框选项

此对话框用于设置媒体对象辅助功能选项。这使得屏幕阅读器会朗读该对象的标题。

若要设置媒体对象辅助功能选项，请执行以下操作：

  1. 在“标题”文本框中输入媒体对象的标题。
  2. 在“快捷键”文本框中输入等效的键盘键（一个字母），用以在浏览器中选择表单对象。

    这使得站点访问者可以使用 Control 键 (Windows) 和 Access 键来访问该对象。例如，如果您输入 B 作为快捷键，则使用 Control+B 在浏览器中选择该对象。

  3. 在“Tab 键索引”文本框中输入一个数字以指定该表单对象的 Tab 键顺序。

    当您的页面上有其它链接和表单对象，并且需要用户用 Tab 键以特定顺序通过这些对象时，设置 Tab 键顺序就会非常有用。如果为一个对象设置 Tab 键顺序，则一定要为所有对象设置 Tab 键顺序。

  4. 单击“确定”。

    注意

    如果您按“取消”，一个媒体对象占位符将出现在文档中，但 Dreamweaver 不会将辅助功能标签或属性与之关联。

相关主题

  • 插入和编辑媒体对象


设置“插入 Flash 按钮”对话框选项

在“设计”视图或“代码”视图中工作时，您可以在文档中创建和插入 Flash 按钮。

若要设置“插入 Flash 按钮”对话框选项，请执行以下操作：

  1. 从“样式”列表中选择您所需的按钮样式。

    您可以在“示例”文本框中查看按钮的示例。单击该示例以查看按钮在浏览器中是如何行使功能的。

    注意

    在定义 Flash 按钮时（例如，更改文本或字体选项），“示例”文本框不会自动更新以反映所做的更改。当关闭对话框并在“设计”视图中查看按钮时，才会体现出这些更改。
  2. （可选）在“按钮文本”文本框中，键入您要显示的文本。

    只有在选定按钮定义了 {Button Text} 参数后，此文本框才接受更改。这显示在“示例”文本框中。在您预览文件时，您键入的文本代替 {Button Text}。

  3. 在“字体”弹出菜单中，选择您要使用的字体。

    如果您的系统上没有提供按钮的默认字体，则从弹出菜单中选择另一种字体。您将不会在“示例”文本框中看到您选择的字体，但可以单击“应用”以将按钮插入到页面中，从而查看文本的显示情形。

  4. 在“大小”文本框中，输入字体大小的数字值。
  5. （可选）在“链接”文本框中，输入该按钮的文档相对或绝对链接。

    当访问者单击该按钮时，浏览器将打开该 URL。

  6. （可选）在“目标”文本框中，指定链接的文档将在其中打开的位置。您可以在弹出菜单中选择框架或窗口选项。只有在框架页中编辑 Flash 对象时，才列出框架名称。
  7. （可选）在“背景颜色”文本框中，设置 Flash SWF 文件的背景颜色。使用颜色选择器或键入 Web 十六进制值（例如 #FFFFFF）。
  8. 在“另存为”文本框中，输入用来保存此新 SWF 文件的文件名。

    您可使用默认文件名（例如 button1.swf）或键入新文件名。如果该文件包含文档相对链接，则您必须将该文件保存到与当前 HTML 文档相同的目录中，以保持文档相对链接的有效性。

  9. 单击“获取更多样式”以转到 Macromedia Exchange 站点并下载更多按钮样式。

    有关更多信息，请参见添加功能扩展 Dreamweaver。

  10. 单击“应用”或“确定”以将 Flash 按钮插入到“文档”窗口中。

    提示

    选择“应用”可以在“设计”视图中看到更改，同时令对话框仍处于打开状态；这样您就可以继续对按钮进行更改。


设置 Flash 元素检查器

使用 Flash 元素检查器可以查看和修改 Flash 元素（组件）的属性。

注意

使用标签检查器和属性检查器都可以查看和编辑 Flash 组件的属性。使用标签检查器可以查看和编辑与给定组件相关的自定义属性（参数）。使用属性检查器可以修改 Flash 元素的高度、宽度和 SRC 属性，还可以修改在“设计”视图中预览 Flash 元素的方式。

若要使用标签检查器编辑 Flash 元素的属性，请执行以下操作：

  • 若要更改属性值，请选择该值并编辑它（请参见下一过程）。
  • 若要为没有值的属性添加一个属性值，请单击属性右侧的属性值列并添加一个值（请参见下面的步骤）。

若要编辑或添加属性值，请执行下列操作之一：

  • 在属性值列（属性名称的右侧）中为该属性键入一个新的值。
  • 如果该属性采用预定义的值，请从属性值列右侧的弹出菜单（或颜色选择器）中选择一个值。
  • 如果属性采用 URL 值，请输入 URL。
  • 如果该属性采用来自动态内容来源（如数据库）的值，请单击属性值列右侧的“动态数据”按钮。然后选择一个来源。

    有关定义动态内容来源的信息，请参见定义动态内容源。

相关主题

  • 设置 Flash 和 Shockwave 影片属性
  • 插入 Flash 元素
  • 编辑 Flash 元素属性


设置 Flash 元素“编辑数组”对话框选项

使用“编辑数组”对话框向表单菜单中添加菜单项。

若要编辑 Flash 元素数组，请执行以下操作：

  • 使用加号 (+) 和减号 (-) 按钮添加和删除列表中的项。

    为要添加的每一数组项输入一个值。

    菜单项在标签检查器中出现的顺序与在“编辑数组”对话框中出现的顺序相同。

相关主题

  • 设置 Flash 和 Shockwave 影片属性
  • 插入 Flash 元素
  • 编辑 Flash 元素属性


使用 JavaScript 行为

Macromedia Dreamweaver 8 行为将 JavaScript 代码放置在文档中，以允许访问者与 Web 页进行交互，从而以多种方式更改页面或引起某些任务的执行。行为是事件和由该事件触发的动作的组合。在“行为”面板中，您可以先指定一个动作，然后指定触发该动作的事件，从而将行为添加到页面中。

注意

行为代码是客户端 JavaScript 代码；即它运行于浏览器中，而不是服务器上。

实际上，事件是浏览器生成的消息，指示该页的访问者执行了某种操作。例如，当访问者将鼠标指针移动到某个链接上时，浏览器为该链接生成一个 onMouseOver 事件；然后浏览器查看是否存在当为该链接生成该事件时浏览器应该调用的 JavaScript 代码（这些代码是在被查看的页中指定的）。不同的页元素定义了不同的事件；例如，在大多数浏览器中，onMouseOver 和 onClick 是与链接关联的事件，而 onLoad 是与图像和文档的 body 部分关联的事件。

动作是由预先编写的 JavaScript 代码组成的，这些代码执行特定的任务，例如打开浏览器窗口、显示或隐藏层、播放声音或停止 Macromedia Shockwave 影片。随 Dreamweaver 提供的动作是由 Dreamweaver 工程师精心编写的，提供了最大的跨浏览器兼容性。

在将行为附加到页元素之后，只要对该元素发生了您所指定的事件，浏览器就会调用与该事件关联的动作（JavaScript 代码）。（可以用来触发给定动作的事件随浏览器的不同而有所不同。）例如，如果将“弹出消息”动作附加到某个链接并指定它将由 onMouseOver 事件触发，那么只要某人在浏览器中用鼠标指针指向该链接，就将在对话框中弹出您的消息。

单个事件可以触发多个不同的动作，您可以指定这些动作发生的顺序。

Dreamweaver 提供大约二十多个行为动作；您可以在 Macromedia Exchange Web 站点以及第三方开发人员站点上找到更多的动作。（请参见下载并安装第三方行为。）如果精通 JavaScript，您可以编写自己的行为动作。有关编写行为动作的更多信息，请参见“扩展 Dreamweaver”（“帮助”>“扩展 Dreamweaver”）。

注意

行为 和动作 这两个术语是 Dreamweaver 术语，而不是 HTML 术语。从浏览器的角度看，动作与其它任何一段 JavaScript 代码完全相同。

本章包含下列章节：

使用“行为”面板

关于事件

应用行为

将行为附加到文本

更改行为

更新行为

创建新动作

下载并安装第三方行为

使用 Dreamweaver 自带的行为动作


使用“行为”面板

使用“行为”面板将行为附加到页元素（更具体地说是附加到标签）并修改以前所附加行为的参数。有关行为是什么以及它们如何工作的背景信息，请参见使用 JavaScript 行为。有关如何将行为附加到事件的信息，请参见应用行为。

若要打开“行为”面板，请执行以下操作：

  • 选择“窗口”>“行为”。

已附加到当前所选页元素的行为显示在行为列表中（面板的主区域），按事件以字母顺序排列。如果同一个事件有多个动作，则将以在列表上出现的顺序执行这些动作。如果行为列表中没有显示任何行为，则没有行为附加到当前所选的页元素。


关于事件

每个浏览器都提供一组事件，这些事件可以与“行为”面板的“动作”(+) 弹出式菜单中列出的动作相关联。当 Web 页的访问者与页进行交互时（例如，单击某个图像），浏览器生成事件；这些事件可用于调用引起动作发生的 JavaScript 函数。（没有用户交互也可以生成事件，例如设置页每 10 秒钟自动重新载入。）Dreamweaver 提供许多可以使用这些事件触发的常用动作。

有关每个浏览器所提供的事件的名称和说明，请参见 Dreamweaver 支持中心，位于 www.macromedia.com/go/dreamweaver_support_cn。

根据所选对象和在“显示事件”子菜单中指定的浏览器的不同，显示在“事件”弹出菜单中的事件将有所不同。若要查明对于给定的页元素给定的浏览器支持哪些事件，请在您的文档中插入该页元素并向其附加一个行为，然后查看“行为”面板中的“事件”弹出菜单。如果页上尚不存在相关的对象或所选的对象不能接收事件，则这些事件将禁用（灰显）。如果未显示预期的事件，请确保选择了正确的对象，或在“显示事件”弹出式菜单中更改目标浏览器。

如果要将行为附加到某个图像，则一些事件（例如 onMouseOver）显示在括号中。这些事件仅用于链接。当选择其中之一时，Dreamweaver 在图像周围使用 a 标签来定义一个空链接。在属性检查器的“链接”文本框中，该空链接表示为 javascript:;。如果要将其变为一个指向另一页的真正链接，您可以更改链接值，但是如果删除了 JavaScript 链接却未用另一个链接来代替它，则将删除该行为。

若要更详细、更进一步地了解具体哪些标签可以在给定的浏览器中与给定的事件一起使用，请在 Dreamweaver/Configuration/Behaviors/Events 文件夹的某个文件中搜索该事件。


应用行为

您可以将行为附加到整个文档（即附加到 body 标签），还可以附加到链接、图像、表单元素或多种其它 HTML 元素中的任何一种。

您选择的目标浏览器确定给定的元素支持哪些事件。例如，对于每个元素，Internet Explorer 4.0 比 Netscape Navigator 4.0 或任何 3.0 版的浏览器具有更多的事件。

注意

不能将行为附加到纯文本。有关更多信息，请参见将行为附加到文本。

您可以为每个事件指定多个动作。动作按照它们在“行为”面板的“动作”列中列出的顺序发生。有关更改动作顺序的信息，请参见更改行为。

若要附加行为，请执行以下操作：

  1. 在页上选择一个元素，例如一个图像或一个链接。

    若要将行为附加到整个页，请在“文档”窗口底部左侧的标签选择器中单击 <body> 标签。

  2. 选择“窗口”>“行为”，打开“行为”面板。
  3. 单击加号 (+) 按钮并从“动作”弹出菜单中选择一个动作。

    菜单中灰显的动作不可选择。它们灰显的原因可能是当前文档中缺少某个所需的对象。例如，如果文档不包含 Shockwave 或 Macromedia Flash SWF 文件，则“控制 Shockwave 或 Flash”动作为灰显。如果所选的对象无可用事件，则所有动作都灰显。

    当您选择某个动作时，将出现一个对话框，显示该动作的参数和说明。

  4. 为该动作输入参数，然后单击“确定”。

    Dreamweaver 提供的所有动作都可以用于 4.0 和更高版本的浏览器中。某些动作不能用于较早版本的浏览器中。请参见使用 Dreamweaver 自带的行为动作。

  5. 触发该动作的默认事件显示在“事件”栏中。如果这不是需要的触发事件，请从“事件”弹出菜单中选择另一个事件。（若要打开“事件”弹出菜单，请在“行为”面板中选择一个事件或动作，然后单击显示在事件名称和动作名称之间的向下的黑色箭头。


将行为附加到文本

不能将行为附加到纯文本。诸如 p 和 span 等标签不在浏览器中生成事件，因此无法从这些标签触发动作。

但是，您可以将行为附加到链接。因此，若要将行为附加到文本，最简单的方法就是向文本添加一个空链接（不指向任何内容），然后将行为附加到该链接上。请注意，如果这样做，您的文本将显示为链接。如果实在不想让它显示为链接，可以更改链接颜色并删除下划线，但这样站点访问者可能不知道可以点击该文本。

若要将某个行为附加到所选的文本，请执行以下操作：

  1. 在属性检查器的“链接”文本框中输入 javascript:;。一定要包括冒号和分号。

    注意

    如果愿意，您可以在“链接”文本框中改用数字符号 (#)。使用数字符号的问题在于当访问者单击该链接时，某些浏览器可能跳到页的顶部。单击 JavaScript 空链接不会在页上产生任何效果，因此 JavaScript 方法通常更可取。
  2. 在文本仍处于选中状态时打开“行为”面板（“窗口”>“行为”）。
  3. 从“动作”弹出菜单中选择一个动作，输入该动作的参数，然后选择一个触发该动作的事件。有关更多信息，请参见应用行为。

若要更改链接文本的外观使它看上去不是一个链接，请执行以下操作：

  1. 选择“查看”>“代码”打开“文档”窗口的“代码”视图。
  2. 查找该链接。
  3. 在该链接的 a href 标签中，插入以下属性：style="text-decoration:none; color:black"。

    此属性设置将禁用下划线并将文本的颜色设置为黑色。（当然，如果周围的文本是其它颜色，则使用该颜色而不是黑色。

    请注意，此属性是一个内联 CSS 样式。应用于单个链接的内联样式覆盖应用于该链接的其它 CSS 样式，但不对该链接外的部分产生任何影响。若要更改页上各处或整个站点中链接文本的外观，请使用 CSS 样式为链接创建一个新的样式。有关更多信息，请参见插入文本和设置文本格式。


更改行为

在附加了行为之后，您可以更改触发动作的事件、添加或删除动作以及更改动作的参数。

若要更改行为，请执行以下操作：

  1. 选择一个附加有行为的对象。
  2. 选择“窗口”>“行为”打开“行为”面板。

    多个行为按事件以字母的顺序显示在面板上。如果同一个事件有多个动作，则以执行的顺序显示这些动作。

  3. 执行下列操作之一：
    • 若要编辑动作的参数，请双击该行为名称或将其选中并按 Enter 键 (Windows) 或 Return 键 (Macintosh)；然后更改对话框中的参数并单击“确定”。
    • 若要更改给定事件的多个动作的顺序，请选择某个动作然后单击上下箭头按钮。或者选择该动作然后剪切它，并将它粘贴到其它动作中所需的位置。
    • 若要删除某个行为，请将其选中然后单击减号 (-) 按钮或按 Delete 键。


更新行为

如果您的页包含用 Dreamweaver 1 或 Dreamweaver 2 创建的行为，则当您在当前版本的 Dreamweaver 中打开该页时不对这些行为进行自动更新。但是，当您（按照本节中的步骤）对页中出现的一个行为进行更新时，此页中所有其它地方出现的该行为都将进行更新。在 Dreamweaver 3 中创建的行为无需修改就可以用在 Dreamweaver 4 中。

注意

如先前所述，当对页面中出现的一个行为进行更新时，在该页中所有其它地方出现的该行为也将被更新。但是，必须对 Web 站点每一页的行为分别进行更新。

若要更新页中的行为，请执行以下操作：

  1. 选择一个附加有该行为的元素。
  2. 打开“行为”面板。
  3. 双击该行为。
  4. 在该行为的对话框中单击“确定”。

该行为在此页中所出现的每一处都将进行更新。


创建新动作

动作是由 JavaScript 和 HTML 代码组成的。如果您精通 JavaScript，则可以编写新动作并将它们添加到“行为”面板的动作弹出菜单中。有关更多信息，请参见“扩展 Dreamweaver”。


下载并安装第三方行为

Dreamweaver 最有用的功能之一就是它的扩展性，即它为精通 JavaScript 的用户提供了编写 JavaScript 代码的机会，使他们可以通过代码扩展 Dreamweaver 的功能。在这些用户中，很多人会选择将他们的扩展提交到 Macromedia Exchange for Dreamweaver Web 站点 (www.macromedia.com/go/dreamweaver_exchange_cn) 与其他用户共享。

若要从 Macromedia Exchange Web 站点下载并安装新行为，请执行以下操作：

  1. 打开“行为”面板并从“动作”(+) 弹出式菜单中选择“获取更多行为”。

    您的主浏览器打开，出现 Exchange 站点。（您必须连接到 Web 才能下载行为。）

  2. 浏览或搜索扩展包。
  3. 下载并安装所需的扩展包。

    有关更多信息，请参见添加功能扩展 Dreamweaver。


使用 Dreamweaver 自带的行为动作

Dreamweaver 自带的行为动作是为在 Netscape Navigator 4.0 和更高版本以及 Internet Explorer 4.0 和更高版本中使用而编写的。其中大多数行为动作也可用于 Netscape Navigator 版本 3.0 和更高版本。（与层相关的行为在 Navigator 3.0 中不起作用。）其中大多数行为动作在 Internet Explorer 3.0 版本中运行时也会偶尔发生问题。

注意

Dreamweaver 动作是经过精心编写的，以便在尽可能多的浏览器中发挥作用。如果您从 Dreamweaver 动作中手工删除代码，或用您自己的代码将其替换，则可能会失去跨浏览器兼容性。

尽管 Dreamweaver 动作经过了精心的编写以提供最大的跨浏览器兼容性，但某些动作仍不能在较早的浏览器中发挥作用。另外，某些浏览器根本不支持 JavaScript，还有很多人在浏览 Web 时经常关闭浏览器中的 JavaScript 功能。为了获得最佳的跨平台效果，可提供一个包括在 noscript 标签中的替换界面，以使没有 JavaScript 的访问者仍然能够使用您的站点。

本节包含以下主题：

  • 调用 JavaScript
  • 改变属性
  • 检查浏览器
  • 检查插件
  • 控制 Shockwave 或 Flash
  • 拖动层
  • 转到 URL
  • 跳转菜单
  • 打开浏览器窗口
  • 播放声音
  • 弹出消息
  • 预先载入图像
  • 设置导航条图像
  • 设置框架文本
  • 设置层文本
  • 设置状态栏文本
  • 设置文本域文本
  • 显示－隐藏层
  • 显示弹出菜单
  • 交换图像
  • 恢复图像交换
  • 检查表单


调用 JavaScript

“调用 JavaScript”动作允许您使用“行为”面板指定当发生某个事件时应该执行的自定义函数或 JavaScript 代码行。（您可以自己编写 JavaScript 或使用 Web 上多个免费的 JavaScript 库中提供的代码。）

若要使用“调用 JavaScript”动作，请执行以下操作：

  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“调用 JavaScript”。
  3. 准确键入要执行的 JavaScript，或键入函数的名称。

    例如，若要创建一个“后退”按钮，您可以键入 if(history.length>0){history.back()}。如果您已将代码封装在一个函数中，则只需键入该函数的名称（例如 hogback()）。

  4. 单击“确定”。
  5. 检查默认事件是否是所需的事件。

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出菜单中更改目标浏览器。


改变属性

使用“改变属性”动作更改对象某个属性（例如层的背景颜色或表单的动作）的值。您可以更改的属性是由浏览器决定的；在 Internet Explorer 4.0 中可以通过此行为更改的属性比 Internet Explorer 3.0 或 Netscape Navigator 3.0 或 4.0 多得多。例如，您可以动态设置层的背景颜色。

注意

只有在您非常熟悉 HTML 和 JavaScript 的情况下才使用此动作。

若要使用“改变属性”动作，请执行以下操作：

  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“更改属性”。
  3. 从“对象类型”弹出菜单中选择您要更改其属性的对象的类型。

    “命名对象”弹出菜单马上列出所有所选类型的命名对象。

  4. 从“命名对象”弹出菜单中选择一个对象。
  5. 从“属性”弹出菜单中选择一个属性，或在文本框中输入该属性的名称。

    若要查看每个浏览器中可以更改的属性，请从浏览器弹出菜单中选择不同的浏览器或浏览器版本。如果您正在键入属性名称，则一定要使用该属性的准确 JavaScript 名称（请记住 JavaScript 属性是区分大小写的）。

  6. 在“新值”文本框中为该属性输入新值，然后单击“确定”。
  7. 检查默认事件是否是所需的事件。（当该事件发生时，将执行动作并更改属性。）

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出菜单中更改目标浏览器。


检查浏览器

使用“检查浏览器”动作可根据访问者不同类型和版本的浏览器将他们转到不同的页。例如，您可能想要将使用 Netscape Navigator 4.0 或更高版本浏览器的访问者转到一页，而将使用 Internet Explorer 4.0 或更高版本的访问者转到另一页，并让使用任何其它类型浏览器的访问者留在当前页上。

将此行为附加到几乎与任何浏览器都兼容的页（该页不使用任何其它 JavaScript）的 body 标签将十分有用；这样，已关闭 JavaScript 功能的访问者在访问此页时仍可以看到内容。

另一个办法是将此行为附加到一个空链接（例如 <a href="javascript:;">）并让该动作根据访问者浏览器的类型和版本确定链接的目标。

若要使用“检查浏览器”动作，请执行以下操作：

  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“检查浏览器”。
  3. 确定您要如何区分访问者：根据浏览器类型；根据浏览器版本；还是既根据类型又根据版本。

    例如，是否要让所有具有 4.0 版浏览器的访问者看到一页，而让所有其他人看到另外一页？或者让 Netscape Navigator 用户看到一页而让 Internet Explorer 用户看到另外一页。

  4. 指定一个 Netscape Navigator 版本。
  5. 在相邻的弹出菜单中，选择选项以指定如果浏览器是您指定的 Netscape Navigator 版本或更高版本时应该进行何种操作，如果是其它情况时又应该进行何种操作。

    选项包括“转到 URL”、“转到替代 URL”和“留在此页”。

  6. 指定一个 Internet Explorer 版本。
  7. 在相邻的弹出菜单中，选择选项以指定如果浏览器是您指定的 Internet Explorer 版本或更高版本时应该进行何种操作，如果是其它情况时又应该进行何种操作。

    选项包括“转到 URL”、“转到替代 URL”和“留在此页”。

  8. 从“其它浏览器”弹出菜单中选择一个选项，以指定如果浏览器既不是 Netscape Navigator 也不是 Internet Explorer 时应该进行何种操作。（例如，该访问者可能正在使用一个诸如 Lynx 的基于文本的浏览器。）

    “留在此页”是用于 Netscape Navigator 和 Internet Explorer 之外浏览器的最佳选项，因为如果它们不能读取此行为，它们大多数不支持 JavaScript，它们无论如何都会留在此页上。

  9. 在对话框底部的文本框中输入 URL 和替代 URL 的路径和文件名。如果您输入一个远程 URL，除了输入 WWW 地址之外您还必须输入 http:// 前缀。
  10. 单击“确定”。
  11. 检查默认事件是否是所需的事件。

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出菜单中更改目标浏览器。请记住，此行为的目的是检查是否存在不同的浏览器版本，因此最好选择一个在 3.0 和更高版本的浏览器上都起作用的事件。


检查插件

使用“检查插件”动作根据访问者是否安装了指定的插件这一情况将他们转到不同的页。例如，您可能想让安装有 Shockwave 的访问者转到一页，让未安装该软件的访问者转到另一页。

注意

不能使用 JavaScript 在 Internet Explorer 中检测特定的插件。但是，选择 Flash 或 Director 会将相应的 VBScript 代码添加到您的页上，以便在 Windows 上的 Internet Explorer 中检测这些插件。Macintosh 上的 Internet Explorer 中不能实现插件检测。

若要使用“检查插件”动作，请执行以下操作：

  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“检查插件”。
  3. 从“插件”弹出菜单中选择一个插件，或单击“输入”并在相邻的文本框中键入插件的确切名称。

    您必须使用 Netscape Navigator 的“关于插件”页上以粗体指定的确切插件名称。（在 Windows 中，选择“Navigator 帮助”>“关于插件”命令；在 Macintosh 上，从“Apple”菜单中选择“关于插件”。）

  4. 在“如果有，转到 URL”文本框中，为具有该插件的访问者指定一个 URL。

    如果您指定一个远程 URL，则必须在地址中包括 http:// 前缀。

    若要让具有该插件的访问者留在同一页上，请将此域留空。

  5. 在“否则，转到 URL”文本框中，为不具有该插件的访问者指定一个替代 URL。

    若要让不具有该插件的访问者留在同一页上，请将此域留空。

  6. Macintosh 上的 Internet Explorer 中不能实现插件检测，在 Windows 上的 Internet Explorer 中也检测不到大多数插件。默认情况下，当不能实现检测时，访问者被发送到“否则”文本框中列出的 URL。若要改为将访问者发送到第一个（“如果有”）URL，则选择“如果无法检测，总是转到第一个 URL”选项。选择此选项实际意味着“假设访问者具有该插件，除非浏览器显式指出该插件不存在”。

    通常，如果插件内容对于您的页是必不可少的一部分，请选择“如果无法检测，总是转到第一个 URL”选项；浏览器通常会提示不具有该插件的访问者下载该插件。如果插件内容对于您的页不是必要的，请保留此选项的未选中状态。

    此选项只适用于 Internet Explorer；Netscape Navigator 总是可以检测到插件。

  7. 单击“确定”。
  8. 检查默认事件是否是所需的事件。

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出菜单中更改目标浏览器。


控制 Shockwave 或 Flash

使用“控制 Shockwave 或 Flash”动作来播放、停止、倒带或转到 Macromedia Shockwave 或 Macromedia Flash SWF 文件中的帧。若要使用“控制 Shockwave 或 Flash”动作，请执行以下操作：

  1. 选择“插入”>“媒体”>“Shockwave”或“插入”>“媒体”>“Flash”分别插入 Shockwave 或 Flash SWF 文件。
  2. 选择“窗口”>“属性”并在左上方文本框（在 Shockwave 或 Flash 图标旁边）中输入影片的名称。若要用“控制 Shockwave 或 Flash”动作对影片进行控制，您必须对该影片进行命名。
  3. 选择要用于控制 Shockwave 或 Flash SWF 文件的项。例如，如果您具有用于播放影片的“播放”按钮的图像，则选择该图像。
  4. 打开“行为”面板（“窗口”>“行为”）。
  5. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“控制 Shockwave 或 Flash”。

    出现一个参数对话框。

  6. 从“影片”弹出菜单中选择一个影片。

    Dreamweaver 自动列出当前文档中所有 Shockwave 和 Flash SWF 文件的名称。（具体来说，Dreamweaver 列出文件名以 .dcr、.dir、.swf 或 .spl 结尾的影片，这些文件扩展名在 object 或 embed 标签中。）

  7. 选择是否播放、停止、倒带或转到影片中的帧。“播放”选项从动作发生的帧开始播放影片。
  8. 单击“确定”。
  9. 检查默认事件是否是所需的事件。

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“事件”弹出菜单的“显示事件”子菜单中更改目标浏览器。


拖动层

“拖动层”动作允许访问者拖动层。使用此动作创建拼板游戏、滑块控件和其它可移动的界面元素。

您可以指定访问者可以向哪个方向拖动层（水平、垂直或任意方向），访问者应该将层拖动到的目标、如果层在目标一定数目的像素范围内是否将层靠齐到目标，当层接触到目标时应该执行的操作和其它更多的选项。

因为在访问者可以拖动层之前必须先调用“拖动层”动作，所以请确保触发该动作的事件发生在访问者试图拖动层之前。最佳的方法是（使用 onLoad 事件）将“拖动层”附加到 body 对象上，不过您也可以使用 onMouseOver 事件将它附加到填满整个层的链接上（例如图像周围的链接）。

若要使用“拖动层”动作，请执行以下操作：

  1. 选择“插入”>“层”或单击“插入”栏上的“绘制层”按钮，并在“文档”窗口的“设计”视图中绘制一个层。
  2. 通过单击“文档”窗口底部标签选择器中的 <body> 选择 body 标签。
  3. 打开“行为”面板。
  4. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“拖动层”。

    如果“拖动层”不可用，则可能是因为您选择了层。因为层在两个 4.0 版本的浏览器中都不接受事件，所以您必须选择一个不同的对象 － 如 body 标签或链接（a 标签）－ 或在“显示事件”弹出式菜单中将目标浏览器更改为 Internet Explorer 4.0。

  5. 在“层”弹出菜单中，选择要使其可拖动的层。
  6. 从“移动”弹出菜单中选择“限制”或“不限制”。

    不限制移动适用于拼板游戏和其它拖放游戏。对于滑块控件和可移动的布景（例如文件抽屉、窗帘和小百叶窗），请选择限制移动。

  7. 对于限制移动，在“上”、“下”、“左”和“右”文本框中输入值（以像素为单位）。

    这些值是相对于层的起始位置的。如果限制在矩形区域中的移动，则在所有四个文本框中都输入正值。如果只允许垂直移动，则在“上”和“下”域中输入正值，在“左”和“右”域中输入 0。如果只允许水平移动，则在“左”和“右”域中输入正值，在“上”和“下”域中输入 0。

  8. 在“左”和“上”文本框中为拖放目标输入值（以像素为单位）。

    拖放目标是一个点，您想要访问者将层拖动到该点上。当层的左坐标和上坐标与在“左”和“上”文本框中输入的值匹配时便认为层已经到达拖放目标。这些值是与浏览器窗口的左上角相对的。单击“取得目前位置”用层的当前位置自动填充这些文本框。

  9. 在“靠齐距离”文本框中输入一个值（以像素为单位）确定访问者必须放目标多近，才能将层靠齐到目标。

    较大的值可以使访问者较容易找到拖放目标。

  10. 对于简单的拼板游戏和布景处理，您可以到此为止了。若要定义层的拖动控制点、在拖动层时跟踪层的移动以及当放下层时触发一个动作，请单击“高级”标签。
  11. 若要指定访问者必须单击层的特定区域才能拖动层，请从“拖动控制点”弹出菜单中选择“层内区域”；然后输入左坐标和上坐标以及拖动控制点的宽度和高度。

    此选项用于层中的图像具有提示拖动元素（例如一个标题栏或抽屉把）的情况。如果要让访问者单击层的任何位置都可以拖动层，则不要设置此选项。

  12. 选择任何要使用的“拖动时”选项：
    • 如果层在被拖动时应该移动到堆叠顺序的顶部，则选择“将层移至最前”。如果选择此选项，则使用弹出菜单选择是否将层保留在最前面或将其恢复到它在堆叠顺序中的原位置。
    • 在“调用 JavaScript”文本框中输入 JavaScript 代码或函数名称（例如 monitorLayer()）以在拖动层时反复执行该代码或函数。例如，您可以编写一个函数，该函数监视层的坐标并在一个文本框中显示提示（如“您正在接近目标”或“您离拖放目标还很远”）。有关更多信息，请参见收集有关可拖动层的信息。
  13. 在第二个“调用 JavaScript”文本框中输入 JavaScript 代码或函数名称（例如，evaluateLayerPos()）以在放下层时执行该代码或函数。如果只有在层到达拖放目标时才执行该 JavaScript，则选择“只有在靠齐时”。
  14. 单击“确定”。
  15. 检查默认事件是否是所需的事件。

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出菜单中更改目标浏览器。请记住 3.0 版的浏览器不支持层。

    注意

    您不能将“拖动层”动作附加到具有 onMouseDown 或 onClick 事件的对象。


收集有关可拖动层的信息

当将“拖动层”动作附加到某个对象时，Dreamweaver 将 MM_dragLayer() 函数插入到您的文档的 head 部分。除了将层注册为可拖动之外，此函数还会为每个可拖动的层定义三项属性：MM_LEFTRIGHT、MM_UPDOWN 和 MM_SNAPPED，您可以在自己的 JavaScript 函数中使用这些属性确定层的相对水平位置、层的相对垂直位置以及层是否达到拖动目标。

注意

此处提供的信息仅供有经验的 JavaScript 编程人员使用。

例如，下面的函数在一个名为 curPosField 的表单域中显示 MM_UPDOWN 属性的值（层当前的垂直位置）。（因为表单域在 Netscape Navigator 和 Internet Explorer 中都是动态的，即您可以在页完成载入之后更改它们的内容，所以它们非常适合用于显示不断更新的信息。）

function getPos(layername){
   var layerRef = MM_findObj(layername);
   var curVertPos = layerRef.MM_UPDOWN;
   document.tracking.curPosField.value = curVertPos;
}

您可以用多种方法来使用这些值，而不在表单域中显示 MM_UPDOWN 或 MM_LEFTRIGHT 的值。例如，您可以编写一个函数，根据该值距离拖放区域的远近程度在表单域中显示一条消息，或者您可以调用另一个函数，根据该值显示或隐藏层。

当页上有多个层并且所有这些层都必须到达它们的目标后访问者才可以前进到下一页或下一个任务时，读取 MM_SNAPPED 属性将特别有用。例如，您可以编写一个函数对 MM_SNAPPED 值为 true 的层进行计数，并在每放下一个层时都调用该函数。当已靠齐的计数达到所需的数目时，您可以将访问者送到下一页或显示一条祝贺消息。

如果您曾使用 onMouseOver 事件将“拖动层”动作附加到多个层中的链接，则您必须对 MM_dragLayer() 函数进行微小的更改，以防止已靠齐的层的 MM_SNAPPED 属性在鼠标指针滑过该层时被重置为 false。（如果您使用“拖动层”来创建图片拼板游戏就可能发生这种情况，因为访问者很可能在放置其它块时将鼠标指针滑过已靠齐的块。MM_dragLayer() 函数不能防止此行为的发生，因为有时这是我们所希望的，例如当您要为单个层设置多个拖放目标时。

若要防止已靠齐的层重新对齐，请执行以下操作：

  1. 在对代码进行任何更改之前先制作文档的备份副本。（您可以在 Dreamweaver 中的“站点”面板，或者在 Windows 资源管理器 (Windows) 或 Finder (Macintosh) 中完成此操作。）
  2. 选择“编辑”>“查找”。
  3. 在“查找内容”弹出菜单中选择“HTML 源代码”。
  4. 在相邻的文本框中键入 (!curDrag)（包括括号）。
  5. 单击“查找下一个”。

    如果 Dreamweaver 询问是否要从文档的开头继续查找，单击“是”。Dreamweaver 找到一个内容如下的语句：

    if (!curDrag) return false;
  6. 关闭“查找”对话框，然后在“文档”窗口的“代码”视图中或“代码”检查器中修改该语句，修改后为：
    if (!curDrag || curDrag.MM_SNAPPED != null) return false;

    两个管道符 (||) 表示或，curDrag 是表示被注册为可拖动的层的变量。该语句的中文意思是“如果 curDrag 不是一个对象，或者如果它已具有 MM_SNAPPED 值，则不必继续执行函数的其余部分。”


转到 URL

“转到 URL”动作在当前窗口或指定的框架中打开一个新页。此操作尤其适用于通过一次单击更改两个或多个框架的内容。

若要使用“转到 URL”动作，请执行以下操作：

  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“转到 URL”。
  3. 从“打开在”列表中选择 URL 的目标。

    “打开在”列表自动列出当前框架集中所有框架的名称以及主窗口。如果没有任何框架，则主窗口是唯一的选项。

    注意

    如果任何框架命名为 top、blank、self 或 parent，则此动作可能产生意想不到的结果。浏览器有时将这些名称误认为保留的目标名称。
  4. 单击“浏览”选择要打开的文档，或在“URL”文本框中输入该文档的路径和文件名。
  5. 重复第 3 步和第 4 步在其它框架中打开其它文档。
  6. 单击“确定”。
  7. 检查默认事件是否是所需的事件。

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出菜单中更改目标浏览器。


跳转菜单

当您使用“插入”>“表单对象”>“跳转菜单”创建跳转菜单时，Dreamweaver 创建一个菜单对象并向其附加一个“跳转菜单”（或“跳转菜单转到”）行为。通常不需要手动将“跳转菜单”动作附加到对象。有关跳转菜单和如何创建它们的信息，请参见跳转菜单。

您可以通过以下两种方式中的任意一种编辑现有的跳转菜单：

  • 您可以通过在“行为”面板中双击现有的“跳转菜单”动作编辑和重新排列菜单项、更改要跳转到的文件、以及更改这些文件在其中打开的窗口。
  • 通过选择该菜单并使用属性检查器中的“列表值”按钮，您可以在菜单中编辑这些项，就象在任何菜单中编辑项一样。有关更多信息，请参见插入 HTML 表单菜单。

若要使用“行为”面板编辑跳转菜单，请执行以下操作：

  1. 如果您的文档中尚无跳转菜单对象，则创建一个跳转菜单对象。
  2. 选择该跳转菜单对象并打开“行为”面板。
  3. 在“动作”列中双击“跳转菜单”。
  4. 在“跳转菜单”对话框中进行所需的更改，然后单击“确定”。


跳转菜单转到

“跳转菜单转到”动作与“跳转菜单”动作密切关联；“跳转菜单转到”允许您将一个“转到”按钮和一个跳转菜单关联起来。（在您使用此动作之前，文档中必须已存在一个跳转菜单。）单击“转到”按钮打开在该跳转菜单中选择的链接。通常情况下，跳转菜单不需要一个“转到”按钮；从跳转菜单中选择一项通常会引起 URL 的载入，不需要任何进一步的用户操作。但是，如果访问者选择已在跳转菜单中选择的同一项，则不发生跳转。通常情况下这不会有多大关系，但是如果跳转菜单出现在一个框架中，而跳转菜单项链接到其它框架中的页，则通常需要使用“转到”按钮，以允许访问者重新选择已在跳转菜单中选择的项。

若要添加一个“跳转菜单转到”动作，请执行以下操作：

  1. 选择一个对象用作“转到”按钮（通常是一个按钮图像），并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“跳转菜单转到”。
  3. 在“选择跳转菜单”弹出菜单中，选择“转到”按钮要激活的菜单。
  4. 单击“确定”。


打开浏览器窗口

使用“打开浏览器窗口”动作在一个新的窗口中打开 URL。您可以指定新窗口的属性（包括其大小）、特性（它是否可以调整大小、是否具有菜单栏等）和名称。例如，您可以使用此行为在访问者单击缩略图时在一个单独的窗口中打开一个较大的图像；使用此行为，您可以使新窗口与该图像恰好一样大。

如果不指定该窗口的任何属性，在打开时它的大小和属性与打开它的窗口相同。指定窗口的任何属性都将自动关闭所有其它未显式打开的属性。例如，如果您不为窗口设置任何属性，它将以 640 x 480 像素的大小打开并具有导航条、地址工具栏、状态栏和菜单栏。如果您将宽度显式设置为 640、将高度设置为 480 并不设置其它属性，则该窗口将以 640 x 480 像素的大小打开，并且不具有任何导航条、地址工具栏、状态栏、菜单栏、调整大小手柄和滚动条。

若要使用“打开浏览器窗口”动作，请执行以下操作：

  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“打开浏览器窗口”。
  3. 单击“浏览”选择一个文件，或输入要显示的 URL。
  4. 设置以下任一选项：

    窗口宽度指定窗口的宽度（以像素为单位）。

    窗口高度指定窗口的高度（以像素为单位）。

    导航工具栏是一行浏览器按钮（包括“后退”、“前进”、“主页”和“重新载入”）。

    地址工具栏是一行浏览器选项（包括地址文本框）。

    状态栏是位于浏览器窗口底部的区域，在该区域中显示消息（例如剩余的载入时间以及与链接关联的 URL）。

    菜单栏是浏览器窗口 (Windows) 或桌面 (Macintosh) 上显示菜单（例如“文件”、“编辑”、“查看”、“转到”和“帮助”）的区域。如果要让访问者能够从新窗口导航，您应该显式设置此选项。如果您不设置此选项，则在新窗口中用户只能关闭或最小化窗口 (Windows) 或者关闭窗口或退出应用程序 (Macintosh)。

    需要时显示滚动条指定如果内容超出可视区域应该显示滚动条。如果不显式设置此选项，则不显示滚动条。如果“调整大小手柄”选项也关闭，则访问者将不容易看到超出窗口原始大小以外的内容。（虽然他们可以拖动窗口的边缘使窗口滚动。

    调整大小手柄指定用户应该能够调整窗口的大小，方法是拖动窗口的右下角或单击右上角的最大化按钮 (Windows) 或大小框 (Macintosh)。如果未显式设置此选项，则调整大小控件将不可用，右下角也不能拖动。

    窗口名称是新窗口的名称。如果您要通过 JavaScript 使用链接指向新窗口或控制新窗口，则应该对新窗口进行命名。此名称不能包含空格或特殊字符。

  5. 单击“确定”。
  6. 检查默认事件是否是所需的事件。

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出菜单中更改目标浏览器。


播放声音

使用“播放声音”动作来播放声音。例如，您可能要在每次鼠标指针滑过某个链接时播放一段声音效果，或在页载入时播放音乐剪辑。

注意

浏览器可能需要用某种附加的音频支持（例如音频插件）来播放声音。因此，具有不同插件的不同浏览器所播放声音的效果通常会有所不同。很难准确地预测出站点的访问者对您提供的声音感受如何。

若要使用“播放声音”动作，请执行以下操作：

  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“播放声音”。
  3. 单击“浏览”选择一个声音文件，或在“播放声音”文本框中输入路径和文件名。
  4. 单击“确定”。
  5. 检查默认事件是否是所需的事件。

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出菜单中更改目标浏览器。


弹出消息

“弹出消息”动作显示一个带有您指定的消息的 JavaScript 警告。因为 JavaScript 警告只有一个按钮（“确定”），所以使用此动作可以提供信息，而不能为用户提供选择。

您可以在文本中嵌入任何有效的 JavaScript 函数调用、属性、全局变量或其它表达式。若要嵌入一个 JavaScript 表达式，请将其放置在大括号 ({}) 中。若要显示大括号，请在它前面加一个反斜杠 (\{)。

示例

The URL for this page is {window.location}, and today is {new Date()}.

注意

您无法控制 JavaScript 警告的外观，它取决于访问者的浏览器。如果您希望对消息的外观进行更多的控制，可考虑使用“打开浏览器窗口”行为。有关更多信息，请参见打开浏览器窗口。

若要使用“弹出消息”动作，请执行以下操作：

  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“弹出消息”。
  3. 在“消息”文本框中输入您的消息。
  4. 单击“确定”。
  5. 检查默认事件是否是所需的事件。

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出菜单中更改目标浏览器。


预先载入图像

“预先载入图像”动作将不会立即出现在页上的图像（例如那些将通过行为或 JavaScript 换入的图像）载入浏览器缓存中。这样可防止当图像应该出现时由于下载而导致延迟。

注意

“交换图像”动作自动预先载入当您在“交换图像”对话框中选择“预先载入图像”选项时所有高亮显示的图像，因此当使用“交换图像”时您不需要手动添加预先载入图像。

若要使用“预先载入图像”动作，请执行以下操作：

  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“预先载入图像”。
  3. 单击“浏览”选择要预先载入的图像文件，或在“图像源文件”文本框中输入图像的路径和文件名。
  4. 单击对话框顶部的加号 (+) 按钮将图像添加到“预先载入图像”列表中。

    注意

    如果在输入下一个图像之前您没有单击加号按钮，则列表中您刚选择的图像将被所选择的下一个图像替换。
  5. 对所有剩下的要预先载入当前页的图像重复第 3 步和第 4 步。
  6. 若要从“预先载入图像”列表中删除某个图像，请在列表中选择该图像，然后单击减号 (-) 按钮。
  7. 单击“确定”。
  8. 检查默认事件是否是所需的事件。

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出菜单中更改目标浏览器。


设置导航条图像

使用“设置导航条图像”动作将某个图像变为导航条图像，或更改导航条中图像的显示和动作。（有关更多信息，请参见插入导航条。）

使用“设置导航条图像”对话框的“基本”标签创建或更新导航条图像或图像组、更改当单击导航条按钮时显示的 URL，以及选择在其中显示 URL 的其它窗口。

使用“设置导航条图像”对话框的“高级”选项卡根据当前按钮的状态更改文档中其它图像的状态。默认情况下，单击导航条中的一个元素将使导航条中的所有其它元素自动返回到它们的一般状态；如果您想将某个图像在所选图像处于按下状态或滑过状态时设置为不同的状态，则使用“高级”标签。

若要编辑“设置导航条图像”动作，请执行以下操作：

  1. 选择导航条中要编辑的图像，然后打开“行为”面板。
  2. 在“行为”面板的“动作”列中，双击与您正在更改的事件相关联的“设置导航条图像”动作。
  3. 在“设置导航条图像”对话框的“基本”标签中，选择图像编辑选项。

若要为某个导航条按钮设置多个图像，请执行以下操作：

  1. 选择导航条中要编辑的图像，然后打开“行为”面板。
  2. 在“行为”面板的“动作”列中，双击与您正在更改的事件相关联的“设置导航条图像”动作。
  3. 单击“设置导航条图像”对话框的“高级”标签。
  4. 在“当元素显示时”弹出菜单中，选择一个图像状态。
    • 如果您想要在一个用户单击了所选的图像之后更改另一个图像的显示，则选择“按下图像”。
    • 如果您想要在鼠标指针滑过所选的图像时更改另一个图像的显示，则选择“鼠标经过图像或按下时鼠标经过图像”。

    有关图像状态的信息，请参见使用导航条。

  5. 在“同时设定图像”列表中，选择页上要设置的另一个图像。
  6. 单击“浏览”选择要显示的图像文件，或在“变成图像文件”文本框中键入图像文件的路径。
  7. 如果您在第 4 步中选择了“鼠标经过图像或按下时鼠标经过图像”，则具有附加的选项。在“按下时，变成图像文件”文本框中，单击“浏览”选择图像文件或键入要显示的图像文件的路径。


设置框架文本

“设置框架文本”动作允许您动态设置框架的文本，用您指定的内容替换框架的内容和格式设置。该内容可以包含任何有效的 HTML 代码。使用此动作动态显示信息。

虽然“设置框架文本”动作将替换框架的格式设置，但您可以选择“保留背景颜色”以保留页背景和文本颜色属性。

您可以在文本中嵌入任何有效的 JavaScript 函数调用、属性、全局变量或其它表达式。若要嵌入一个 JavaScript 表达式，请将其放置在大括号 ({}) 中。若要显示大括号，请在它前面加一个反斜杠 (\{)。

示例

The URL for this page is {window.location}, and today is {new Date()}.

若要创建框架集，请执行以下操作：

  • 选择“修改”>“框架集”>“拆分左框架”、“拆分右框架”、“拆分上框架”或“拆分下框架”。

    有关更多信息，请参见创建框架和框架集。

若要使用“设置框架文本”动作，请执行以下操作：

  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“设置文本”>“设置框架文本”。
  3. 在“设置框架文本”对话框中，从“框架”弹出菜单中选择目标框架。
  4. 单击“获取当前 HTML”按钮复制当前目标框架的 body 部分的内容。
  5. 在“新建 HTML”文本框中输入消息，然后单击“确定”。
  6. 检查默认事件是否是所需的事件。如果不是，请从弹出式菜单中选择另一个事件。

    如果未看到所需的事件，请在“显示事件”弹出式菜单中更改目标浏览器。


设置层文本

“设置层文本”动作用您指定的内容替换页上现有层的内容和格式设置。该内容可以包括任何有效的 HTML 源代码。

虽然“设置层文本”将替换层的内容和格式设置，但保留层的属性，包括颜色。通过在“设置层文本”对话框的“新建 HTML”文本框中包括 HTML 标签，可对内容进行格式设置。

您可以在文本中嵌入任何有效的 JavaScript 函数调用、属性、全局变量或其它表达式。若要嵌入一个 JavaScript 表达式，请将其放置在大括号 ({}) 中。若要显示大括号，请在它前面加一个反斜杠 (\{)。

示例

The URL for this page is {window.location}, and today is {new Date()}.

若要创建层，请执行以下操作：

  1. 选择“插入”>“层”。

    有关更多信息，请参见插入层。

  2. 在属性检查器中键入层的名称。

若要使用“设置层文本”动作，请执行以下操作：

  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“设置文本”>“设置层文本”。
  3. 在“设置层文本”对话框中，使用“层”弹出菜单选择目标层。
  4. 在“新建 HTML”文本框中输入消息，然后单击“确定”。
  5. 检查默认事件是否是所需的事件。如果不是，请从弹出式菜单中选择另一个事件。

    如果未看到所需的事件，请在“显示事件”弹出式菜单中更改目标浏览器。


设置状态栏文本

“设置状态栏文本”动作在浏览器窗口底部左侧的状态栏中显示消息。例如，您可以使用此动作在状态栏中说明链接的目标而不是显示与之关联的 URL。若要查看状态消息的示例，请将您的鼠标滑过“使用 Dreamweaver”。访问者常常会忽略或注意不到状态栏中的消息（而且并不是所有的浏览器都提供设置状态栏文本的完全支持）；如果您的消息非常重要，请考虑将其显示为弹出式消息或层文本。

您可以在文本中嵌入任何有效的 JavaScript 函数调用、属性、全局变量或其它表达式。若要嵌入一个 JavaScript 表达式，请将其放置在大括号 ({}) 中。若要显示大括号，请在它前面加一个反斜杠 (\{)。

示例

The URL for this page is {window.location}, and today is {new Date()}.

若要使用“设置状态栏文本”动作，请执行以下操作：

  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“设置文本”>“设置状态栏文本”。
  3. 在“设置状态栏文本”对话框中，在“消息”文本框中键入您的消息。

    保持该消息简明扼要。如果消息不能完全放在状态栏中，浏览器将截断消息。

  4. 单击“确定”。
  5. 检查默认事件是否是所需的事件。

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出菜单中更改目标浏览器。


设置文本域文本

“设置文本域文本”动作用您指定的内容替换表单文本域的内容。

您可以在文本中嵌入任何有效的 JavaScript 函数调用、属性、全局变量或其它表达式。若要嵌入一个 JavaScript 表达式，请将其放置在大括号 ({}) 中。若要显示大括号，请在它前面加一个反斜杠 (\{)。

示例

The URL for this page is {window.location}, and today is {new Date()}.

若要创建命名的文本域，请执行以下操作：

  1. 选择“插入”>“表单对象”>“文本域”。

    如果 Dreamweaver 提示您添加一个表单标签，则单击“是”。有关更多信息，请参见创建表单。

  2. 在属性检查器中，为该文本域键入一个名称。确保该名称在页上是唯一的（不要对同一页上的多个元素使用相同的名称，即使它们在不同的表单上也应如此）。

若要使用“设置文本域文本”动作，请执行以下操作：

  1. 选择一个文本域并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“设置文本”>“设置文本域文本”。
  3. 在“设置文本域文本”对话框中，从“文本域”弹出菜单中选择目标文本域。
  4. 在“新建文本”文本框中输入文本，然后单击“确定”。
  5. 检查默认事件是否是所需的事件。如果不是，请从弹出式菜单中选择另一个事件。

    如果未看到所需的事件，请在“显示事件”弹出式菜单中更改目标浏览器。


显示－隐藏层

“显示－隐藏层”动作显示、隐藏或恢复一个或多个层的默认可见性。此动作用于在用户与页进行交互时显示信息。例如，当用户将鼠标指针滑过一个植物的图像时，您可以显示一个层给出有关该植物的生长季节和地区、需要多少阳光、可以长到多大等详细信息。

“显示－隐藏层”还可用于创建预先载入层，即一个最初挡住页的内容的较大的层，在所有页组件都完成载入后该层即消失。

若要使用“显示－隐藏层”动作，请执行以下操作：

  1. 选择“插入”>“层”或单击插入栏中的“层”按钮，然后在“文档”窗口中绘制一个层。

    重复此步骤来创建其它的层。

  2. 在“文档”窗口中单击取消对层的选择，然后打开“行为”面板。
  3. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“显示－隐藏层”。

    如果“显示 － 隐藏层”不可用，则可能是因为您选择了层。因为层在两个 4.0 版本的浏览器中都不接受事件，所以您必须选择一个不同的对象—如 body 标签或链接（a 标签）－ 或在“显示事件”弹出式菜单中将目标浏览器更改为 Internet Explorer 4.0。

  4. 在“命名的层”列表中选择要更改其可见性的层。
  5. 单击“显示”以显示该层、单击“隐藏”以隐藏该层、或单击“默认”以恢复层的默认可见性。
  6. 对所有剩下的此时要更改其可见性的层重复第 4 步和第 5 步。（您可以通过单个行为更改多个层的可见性。）
  7. 单击“确定”。
  8. 检查默认事件是否是所需的事件。

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出菜单中更改目标浏览器。

当在 Netscape Navigator 浏览器窗口中查看时，层可能会收缩以适应内容。若要防止这种情况的发生，请将文本或图像添加到层中，或设置层剪贴值。

若要创建预先载入层，请执行以下操作：

  1. 在“插入”栏的“常用”类别中单击“绘制层”按钮，然后在“文档”窗口的“设计”视图中绘制一个较大的层。

    该层一定要覆盖页上的所有内容。

  2. 在“层”面板中，将该层名称拖到层列表的顶部以指定该层应该在堆叠顺序的最前面。
  3. 如果未选择，则选择该层，并使用层属性检查器中最左边的文本框将其命名为 “loading”。
  4. 在层仍处于选中状态时，在属性检查器中将层的背景颜色设置为与页背景相同的颜色。

  5. 如果需要，在层中（该层现在应该挡住其余的页内容）单击并键入消息。

    例如“请稍候，正在载入页”或“正在载入...”，这些消息提示访问者正在发生的操作，以便他们知道该页包含有内容。

  6. 单击“文档”窗口左下角标签选择器中的 <body> 标签。
  7. 在“行为”面板中，从“动作”弹出菜单中选择“显示－隐藏层”。
  8. 从“命名的层”列表中选择名为“loading”的层。
  9. 单击“隐藏”。
  10. 单击“确定”。
  11. 确保行为列表中“显示－隐藏层”动作旁边列出的事件是 onLoad。（如果不是，选择该事件并单击显示在事件和动作之间指向下方的三角形。从弹出菜单的事件列表中选择 onLoad。）


显示弹出菜单

使用“显示弹出菜单”行为来创建或编辑 Dreamweaver 弹出式菜单，或者打开并修改已插入 Dreamweaver 文档的 Fireworks 弹出式菜单。

通过在“显示弹出菜单”对话框中设置选项来创建水平或垂直弹出菜单。您可以使用此对话框来设置或修改弹出菜单的颜色、文本和位置。

注意

您必须使用 Dreamweaver 属性检查器中的“编辑”按钮来编辑 Fireworks 基于图像的弹出菜单中的图像。但是，您可以使用“显示弹出菜单”命令来更改基于图像的弹出菜单中的文本。有关在 Fireworks 中编辑图像的信息，请参见使用其它应用程序。

若要查看文档中的弹出菜单，您必须在浏览器窗口中打开该文档，然后将鼠标指针滑过触发图像或链接。

若要使用“显示弹出菜单”动作，请执行以下操作：

  1. 选择要附加该行为的对象并打开“行为”面板 (Shift+F4)。
  2. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“显示弹出菜单”。
  3. 在出现的“显示弹出菜单”对话框中，使用以下标签来设置弹出菜单的选项：

    内容允许您单独设置各菜单项的名称、结构、URL 和目标。

    外观使您能够设置菜单“一般状态”和“滑过状态”的外观以及设置菜单项文本的字体选择。

    高级允许您设置菜单单元格的属性。例如，您可以设置单元格的宽度和高度、单元格颜色和边框宽度、文本缩进以及在用户将鼠标指针移到触发器上后菜单出现之前的延迟时间长度。

    位置允许您设置菜单相对于触发图像或链接的放置位置。

本节包含以下主题：

  • 添加、删除和更改弹出式菜单项的顺序
  • 设置弹出式菜单的外观
  • 设置高级外观选项
  • 设置弹出式菜单在文档中的位置
  • 修改弹出式菜单


添加、删除和更改弹出式菜单项的顺序

使用“显示弹出菜单”对话框的“内容”标签创建菜单项。您还可以使用此标签删除现有项或更改它们在菜单上出现的顺序。

若要添加弹出菜单项，请执行以下操作：

  1. 在“内容”标签中，通过执行以下操作创建一个弹出菜单项：

    在“文本”文本框中，选择默认文本（“新建项目”），然后键入要显示在弹出菜单中的文本。

  2. 按需要设置其它选项：

    如果您希望在单击该菜单项时打开另一个文件，则在“链接”文本框中键入文件路径或单击文件夹图标并浏览到您要打开的文档。

    如果您要设置文档打开的位置（例如在新窗口中或在特定的框架中），则在“目标”弹出菜单中选择所需的位置。

    注意

    如果想要作为目标的框架未出现在“目标”弹出式菜单中，则关闭“显示弹出菜单”对话框，然后在“文档”窗口中选择并命名该框架。
  3. 单击加号 (+) 按钮将其它项添加到“显示弹出菜单”预览列表中。

    添加完菜单项后，单击“确定”接受默认的设置或选择另一个显示弹出菜单标签来设置其它的选项。

若要创建子菜单项，请执行以下操作：

在“显示弹出菜单”列表中，选择要将其创建为子菜单项的项，然后进行以下操作之一：

  • 若要在菜单列表中缩进项，请单击“缩进项”按钮。
  • 若要删除缩进，请单击“凸出项”按钮。

    注意

    您不能使列表中的第一个菜单项成为子菜单项。

若要更改菜单中某个项的顺序，请执行以下操作：

  • 在“显示弹出菜单”列表中，选择您要向上或向下移动的项，然后单击向上或向下箭头将项移动到想要其显示的位置。

若要从菜单中删除某项，请执行以下操作：

  1. 在“内容”标签中，选择您要从“显示弹出菜单”列表中删除的菜单项。
  2. 单击减号 (-) 按钮。


设置弹出式菜单的外观

在创建了菜单项之后，使用“显示弹出菜单”的“外观”选项卡设置弹出式菜单的方向、字体属性和按钮状态属性。

注意

“外观”选项卡的预览窗格概略显示您在此选项卡中设置的选项。

若要设置弹出菜单的外观，请执行以下操作：

  1. 在“外观”选项卡顶部的弹出式菜单中，选择“垂直菜单”或“水平菜单”来设置菜单的方向。
  2. 设置所需的文本格式设置选项：

    在“字体”弹出菜单中，选择您要应用于菜单项的字体。

    注意

    如果要应用的字体不在字体列表中，则使用“编辑字体列表”选项将所需的字体添加到字体列表中。为了确保按需要的外观显示菜单，您应该选择站点访问者很可能具有的字体。

    设置菜单项文本的字体大小、样式属性、以及文本对齐或版面调整选项。

  3. 在“一般状态”和“滑过状态”框中，使用颜色选择器设置菜单项按钮的文本和单元格颜色。
  4. 设置完外观选项后，单击“确定”或选择另一个显示弹出菜单标签来设置其它的选项。


设置高级外观选项

使用“高级”标签中的选项指定菜单单元格的其它属性。例如，您可以设置菜单按钮的宽度、高度、单元格间距或边距、缩进文本以及设置边框属性。

若要设置弹出菜单的高级格式设置属性，请执行以下操作：

  1. 单击“高级”选项卡，然后设置要应用于菜单项的选项：

    单元格宽度为菜单按钮设置一个特定的宽度（以像素为单位）。单元格宽度是根据最宽的项自动设置的；若要增加单元格宽度，请在弹出菜单中选择“像素”然后输入一个比在“单元格宽度”文本框中显示的值更大的值。

    单元格高度为菜单按钮设置一个特定的高度（以像素为单位）。若要增加单元格高度，请在弹出菜单中选择“像素”然后输入一个比在“单元格高度”文本框中显示的值更大的值。

    单元格边距指定单元格内容和其边框之间的像素数。

    单元格间距指定相邻单元格之间的像素数。

    文本缩进使您可以指定菜单项中的文本在单元格中的缩进距离（以像素为单位）。

    菜单延迟设置从用户将鼠标指针移动到触发图像或链接上，到菜单出现之间的时间间隔。该值以毫秒为单位，因此默认设置 1000 相当于 1 秒。对于所需的每秒延迟，都添加 000；例如，对于 3 秒延迟，请键入 3000。

    弹出菜单边框确定菜单中项周围是否显示边框。如果要在菜单项周围显示边框，则确保选中了“显示边框”复选框。

    边框宽度设置边框的宽度（以像素为单位）。

    阴影、边框颜色和高亮显示允许为这些边框选项选择颜色。阴影和高亮显示不反映在预览中。

  2. 当完成了高级外观选项的设置后，请单击“确定”或选择另一个显示弹出菜单标签来设置其它的选项。


设置弹出式菜单在文档中的位置

使用位置选项设置弹出菜单相对于触发图像或链接的显示位置。您还可以设置当用户将鼠标指针移开触发器之后该菜单是否隐藏。

若要设置弹出菜单位置选项，请执行以下操作：

  1. 在“显示弹出菜单”对话框中，单击“位置”标签。
  2. 通过执行以下操作之一设置弹出菜单的位置：
    • 选择预先设置选项中的一个选项。
    • 设置自定义位置坐标，方法是在“X”文本框中键入一个数字设置水平坐标，在“Y”文本框中键入一个数字设置垂直坐标。坐标以菜单的左上角为基准计算。
  3. 若要在鼠标指针不在其上时隐藏弹出菜单，请确保选中了“在发生 onMouseOut 事件时隐藏菜单”。若要让菜单显示，则取消对该选项的选择。
  4. 创建或修改完弹出菜单之后，单击“确定”。


修改弹出式菜单

“显示弹出菜单”行为允许您编辑或更新弹出菜单的内容。您可以添加、删除或更改菜单项、重新安排它们或设置菜单相对于触发图像或链接的放置位置。

若要打开一个现有的基于 HTML 的弹出菜单，请执行以下操作：

  1. 在 Dreamweaver 文档中，选择触发该弹出菜单的链接或图像。
  2. 打开“行为”面板 (Shift+F4)（如果它尚未打开），然后在“动作”列表中双击“显示弹出菜单”。

    出现“显示弹出菜单”对话框。

  3. 对该弹出菜单做出所需的更改。
  4. 修改完该弹出菜单后，单击“确定”。

有关设置弹出式菜单选项的更多信息，请参见显示弹出菜单。


交换图像

“交换图像”动作通过更改 img 标签的 src 属性将一个图像和另一个图像进行交换。使用此动作创建按钮鼠标经过图像和其它图像效果（包括一次交换多个图像）。插入鼠标经过图像会自动将一个“交换图像”行为添加到您的页中。

注意

因为只有 src 属性受此动作的影响，所以您应该换入一个与原图像具有相同尺寸（高度和宽度）的图像。否则，换入的图像显示时会被压缩或扩展，以使其适应原图像的尺寸。

若要使用“交换图像”动作，请执行以下操作：

  1. 选择“插入”>“图像”或单击“插入”栏的“图像”按钮来插入一个图像。
  2. 在属性检查器中，在最左边的文本框中为该图像输入一个名称。

    如果您未为图像命名，“交换图像”动作仍将起作用；当您将该行为附加到某个对象时，它将为未命名的图像自动命名。但是，如果所有图像都预先命名，则在“交换图像”对话框中就更容易区分它们。

  3. 重复第 1 步和第 2 步插入其它图像。
  4. 选择一个对象（通常是您将交换的图像）并打开“行为”面板。
  5. 单击加号 (+) 按钮并从“动作”弹出菜单中选择“交换图像”。
  6. 从“图像”列表中，选择要更改其源的图像。
  7. 单击“浏览”选择新图像文件，或在“设定源文件为”文本框中输入新图像的路径和文件名。
  8. 对所有要更改的其它图像重复第 6 步和第 7 步。同时对所有要更改的图像使用相同的“交换图像”动作；否则，相应的“恢复交换图像”动作就不能全部恢复它们。
  9. 选择“预先载入图像”选项在载入页时将新图像载入到浏览器的缓存中。

    这防止当图像该出现时由于下载而导致的延迟。

  10. 单击“确定”。
  11. 检查默认事件是否是所需的事件。

    如果不是，请从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出菜单中更改目标浏览器。


恢复图像交换

“恢复交换图像”动作将最后一组交换的图像恢复为它们以前的源文件。每次您将“交换图像”动作附加到某个对象时都会自动添加该动作；如果您在附加“交换图像”时选择了“恢复”选项，则您就不再需要手动选择“恢复交换图像”动作。


检查表单

“检查表单”动作检查指定文本域的内容以确保用户输入了正确的数据类型。使用 onBlur 事件将此动作分别附加到各文本域，在用户填写表单时对域进行检查；或使用 onSubmit 事件将其附加到表单，在用户单击“提交”按钮时同时对多个文本域进行检查。将此动作附加到表单防止表单提交到服务器后任何指定的文本域包含无效的数据。

若要使用“检查表单”动作，请执行以下操作：

  1. 选择“插入”>“表单”或单击“插入”栏的“表单”按钮插入一个表单。
  2. 选择“插入”>“表单对象”>“文本域”或单击“插入”栏的“文本域”按钮来插入文本域。

    重复此步骤以插入其它文本域。

  3. 执行下列操作之一：
    • 若要在用户填写表单时分别检查各个域，请选择一个文本域并选择“窗口”>“行为”。
    • 若要在用户提交表单时检查多个域，请在“文档”窗口左下角的标签选择器中单击 <form> 标签并选择“窗口”>“行为”。
  4. 从“动作”弹出菜单中选择“检查表单”。
  5. 执行下列操作之一：
    • 如果您要检查单个域，则从“命名的域”列表中选择您已在“文档”窗口中选择的同一个域。
    • 如果您要检查多个域，则从“命名的域”列表中选择某个文本域。
  6. 如果该域必须包含某种数据，则选择“必需”选项。
  7. 从以下“接受”选项中选择一个选项：

    如果该域是必需的但不需要包含任何特定类型的数据，则使用“任何数据”。 （如果没有选择“必需”选项，则“任何数据”选项就没有意义了，也就是说它与该域上未附加“检查表单”动作一样。）

    使用“电子邮件地址”检查该域是否包含一个 @ 符号。

    使用“数字”检查该域是否只包含数字。

    使用“数字从”检查该域是否包含特定范围内的数字。

  8. 如果要检查多个域，对要检查的任何其它域重复第 6 步和第 7 步。
  9. 单击“确定”。

    如果在用户提交表单时检查多个域，则 onSubmit 事件自动出现在“事件”弹出菜单中。

  10. 如果要分别检查各个域，则检查默认事件是否是 onBlur 或 onChange。

    如果不是，请从弹出式菜单中选择 onBlur 或 onChange。当用户从域移开时，这两个事件都触发“检查表单”动作。它们之间的区别是 onBlur 不管用户是否在该域中键入内容都会发生，而 onChange 只有在用户更改了该域的内容时才发生。当您指定了该域是必需的域时，最好使用 onBlur 事件。


参考资料

本节包含有关本章中介绍的“行为”页面的信息以及有关 Fireworks 8 弹出式菜单的信息：

  • 设置“行为”面板选项
  • 关于 Fireworks 8 弹出式菜单


设置“行为”面板选项

“行为”面板具有以下选项：

显示设置事件仅显示附加到当前文档的那些事件。事件被分别划归到客户端或服务器端类别中。每个类别的事件都包含在一个可折叠的列表中，您可以单击类别名称旁边的加号/减号按钮展开或折叠该列表。“显示设置事件”是默认的视图。

显示所有事件按字母降序显示给定类别的所有事件。

添加动作 (+) 是一个弹出菜单，其中包含可以附加到当前所选元素的动作。当从该列表中选择一个动作时，将出现一个对话框，您可以在该对话框中指定该动作的参数。如果所有动作都灰显，则没有所选元素可以生成的事件。

删除 (-) 从行为列表中删除所选的事件和动作。

上下箭头按钮将特定事件的所选动作在行为列表中向上或向下移动。给定事件的动作是以特定的顺序执行的。可以为特定的事件更改动作的顺序，例如更改 onLoad 事件的多个动作的发生顺序，但是所有 onLoad 动作在行为列表中都靠在一起。对于不能在列表中上下移动的动作，箭头按钮将被禁用。

事件（当您单击行为列表中所选事件名称旁边的箭头按钮时出现的菜单）是一个弹出菜单，其中包含可以触发该动作的所有事件。只有在选择了行为列表中的某个事件时才显示此菜单。根据所选对象的不同，显示的事件也有所不同。如果未显示预期的事件，请确保选择了正确的页元素或标签。（若要选择特定的标签，请使用“文档”窗口底部左侧的标签选择器。）同时确保您在“显示事件”子菜单中选择了正确的浏览器。

注意

括号中的事件名称只用于链接；选择这些事件名称之一将向所选的页元素自动添加一个空链接，并将行为附加到该链接而不是元素本身。在 HTML 代码中，空链接被指定为 a href="javascript:;"。

显示事件（“事件”菜单中的子菜单）指定当前行为应该在其中起作用的浏览器。您在此菜单中进行的选择确定哪些事件将显示在“事件”弹出菜单中。通常，较早的浏览器比较新的浏览器支持的事件要少，并且在大多数情况下您选择的目标浏览器越普通，所显示的事件越少，因为只显示在所有请求浏览器中都可用的事件。例如，如果您选择“3.0 或更高版本的浏览器”，那么您可以选择的事件仅限于那些在所有 Netscape Navigator 和 Microsoft Internet Explorer 3.0 版和更高版本的浏览器中都可用的事件，这将是一个非常有限的事件列表。


关于 Fireworks 8 弹出式菜单

Fireworks 8 允许您快速方便地创建基于 CSS 的弹出式菜单。与 Dreamweaver 生成的 JavaScript 代码相比，Fireworks 生成的 CSS 代码更易于理解、维护和修改，因为此代码较简朴和短小。

除了提供更强的扩展性和更快的下载速度，通过 Fireworks 创建的弹出式菜单还可以为您增添以下优势：

  • 菜单项可以被搜索引擎编成索引
  • 屏幕阅读器可以读取菜单项，使您的页面更易访问
  • Fireworks 生成的代码符合标准且可进行验证

可以使用 Dreamweaver 或 Fireworks 编辑 Fireworks 弹出式菜单，但不能同时使用二者。在 Dreamweaver 中所做的更改未保存在 Fireworks 中。有关更多信息，请参见在 Dreamweaver 中编辑 Fireworks 弹出式菜单。


使用页代码

使用 Macromedia Dreamweaver 8 中的高级编码工具创建或修改页面。

注意

若要获取语言参考帮助，请在“代码”视图中按 Shift+F1。

此部分包含以下各章：

设置您的编码环境

在 Dreamweaver 中编写代码

优化和调试代码

在设计视图中编辑代码


设置您的编码环境

您可以在 Macromedia Dreamweaver 8 中修改编码环境使之适合您的工作方式。例如，您可以更改查看代码的方式、设置不同的键盘快捷方式、或导入并使用您喜欢的标签库。

本章包含以下主题：

查看您的代码

使用面向编码器的工作区（仅限 Windows）

设置编码首选参数

自定义快捷键

默认以“代码”视图打开文件

设置验证程序首选参数

管理标签库

将自定义标签导入 Dreamweaver

将外部 HTML 编辑器用于 Dreamweaver


查看您的代码

您可以通过多种方式查看当前文档的源代码：您可以通过打开“代码”视图在“文档”窗口中显示源代码，可以拆分“文档”窗口以同时显示页面及其关联的代码，或者，可以在代码检查器（一个单独的编码窗口）中工作。代码检查器与“代码”视图的工作方式相同；您可以把它当作当前文档的一个可分离的“代码”视图。

本节包含更改代码查看方式的说明。

若要在“文档”窗口中查看代码，请执行以下操作：

  • 选择“查看”>“代码”。

若要在“文档”窗口中同时进行编码和以可视化的方式编辑页面，请执行以下操作：

  1. 选择“查看”>“代码和设计”。

    代码显示在顶部窗格中，页面显示在底部窗格中。

  2. 若要在顶部显示页面，请选择“查看”>“在顶部查看设计视图”。
  3. 若要调整“文档”窗口中窗格的大小，请将拆分条拖到所需的位置。

    拆分条位于两个窗格之间。

    当在“设计”视图中进行更改时，“代码”视图自动更新。但是，在“代码”视图中进行更改之后，您必须通过在“设计”视图内单击或按 F5 键手动更新“设计”视图中的文档。

若要在单独的窗口中查看代码，请执行以下操作：

  • 选择“窗口”>“代码检查器”。


使用面向编码器的工作区（仅限 Windows）

在 Windows 中，您可以使用一个与 Macromedia HomeSite 中的工作区外观相似的工作区，其面板组停靠在主窗口的左侧而不是右侧。在这种工作区布局中，属性检查器默认情况下处于折叠状态，“文档”窗口默认情况下以“代码”视图显示。有关使用此选项的信息，请参见选择工作区布局（仅限 Windows）。

相关主题

  • 默认以“代码”视图打开文件


设置编码首选参数

通过设置代码格式、改写、颜色等的首选参数，您可以自定义 Dreamweaver 的代码环境来满足您的特定需要。

注意

若要设置高级首选参数，请使用标签库编辑器（请参见管理标签库）。

本节包含以下主题：

  • 设置代码查看选项
  • 设置代码格式设置首选参数
  • 将新格式设置首选参数应用于现有的文档
  • 设置代码提示首选参数
  • 设置“代码改写”首选参数
  • 设置“代码颜色”首选参数


设置代码查看选项

您可以通过“查看”>“代码视图选项”菜单来设置文本换行、显示代码行号、高亮显示无效代码、设置代码元素的语法颜色、设置缩进和显示隐藏字符。

若要设置“代码”视图和代码检查器的选项，请执行以下操作：

  1. 在“代码”视图或代码检查器中查看文档。
  2. 执行下列操作之一：
    • 选择“查看”>“代码视图选项”
    • 单击位于“代码”视图或代码检查器顶部的工具栏上的“查看选项”按钮。 这是所描述的功能的图片。
  3. 若要启用或禁用以下任何一个选项，请从菜单中选中它。

    “自动换行”对代码进行换行，以便您查看代码时无需水平滚动。此选项不插入换行符；它只是使代码更易于查看。

    “行号”在代码的旁边显示行号。

    “隐藏字符”显示用来替代空白处的特殊字符。例如，用点取代空格，用双人字标记取代制表符，用段落标记取代换行符。

    注意

    Dreamweaver 在文字换行时使用的软换行符不以段落标记的形式显示出来。

    “高亮显示无效代码”使 Dreamweaver 以黄色高亮显示所有无效的 HTML 代码。当选择一个无效的标签时，属性检查器显示有关如何更正该错误的信息。

    语法颜色启用或禁用代码颜色。有关更改颜色方案的信息，请参见设置“代码颜色”首选参数。

    “自动缩进”当您在编写代码过程中按 Enter 键时使代码自动缩进。新一行的缩进级别与上一行的相同。有关更改缩进间距的信息，请参见设置代码格式设置首选参数中的“制表符大小”选项。

相关主题

  • 查看您的代码
  • “编码”工具栏


设置代码格式设置首选参数

您可以通过指定格式设置首选参数（例如缩进、行长度以及标签和属性名称的大小写）更改代码的外观。

请注意，除“覆盖大小写”之外的所有首选参数只影响新文档和新添加到现有文档的部分。也就是说，当您打开一个以前创建的 HTML 文档时，这些格式设置选项将不会应用于该文档；若要对现有的 HTML 文档重新进行格式设置，请使用“应用源格式”命令。有关更多信息，请参见将新格式设置首选参数应用于现有的文档。

若要设置代码格式参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”。
  2. 从左侧的“类别”列表中选择“代码格式”。

    出现“代码格式”首选参数。

  3. 在该对话框中调整任意设置。

    有关更多信息，请参见设置代码格式首选参数选项。


将新格式设置首选参数应用于现有的文档

您在“代码格式”首选参数中指定的代码格式设置选项仅自动应用于您随后使用 Dreamweaver 创建的新文档。但是，您可以将新的格式设置首选参数应用于现有的文档。

若要将新格式设置参数应用于现有的文档，请执行以下操作：

  1. 在 Dreamweaver 中打开该文档。
  2. 选择“命令”>“应用源格式”。


设置代码提示首选参数

代码提示可以使您在“代码”视图或快速标签编辑器中键入代码时迅速插入标签名称、属性和值。有关更多信息，请参见使用代码提示或在快速标签编辑器中使用提示菜单。

提示

即使禁用代码提示，也可以通过按 Ctrl + 空格键在“代码”视图中显示弹出式提示。

若要设置代码提示首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”。
  2. 从左侧的“类别”列表中选择“代码提示”。

    出现代码提示首选参数。

  3. 在该对话框中调整任意设置。

    有关更多信息，请参见设置代码提示首选参数选项。

相关主题

  • 使用代码提示


设置“代码改写”首选参数

当打开文档时，Dreamweaver 会根据您指定的代码改写首选参数来修正（或改写）某种技术上非法的代码。当您在“代码”视图中编辑 HTML 或脚本时，这些首选参数不起作用。

如果您禁用改写选项，则 Dreamweaver 在“文档”窗口中对它本该改写的 HTML 显示无效标记项。

若要设置“代码改写”首选参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或 Dreamweaver>“首选参数”(Macintosh)。
  2. 从左侧的“类别”列表中选择“代码改写”。

    出现“代码改写”首选参数。

  3. 在该对话框中调整任意设置。

    有关更多信息，请参见设置代码改写首选参数选项。

相关主题

  • 清理 Microsoft Word 的 HTML 文件


设置“代码颜色”首选参数

使用代码颜色首选参数来指定常规类别的标签和代码元素（例如，与表单相关的标签或 JavaScript 标识符）的颜色。若要设置特定标签的颜色首选参数，请在标签库编辑器中编辑标签定义。有关更多信息，请参见编辑库、标签和属性。

若要设置“代码颜色”参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或 Dreamweaver>“首选参数”(Macintosh)。
  2. 从左侧的“类别”列表中选择“代码颜色”。

    出现“代码颜色”首选参数。

  3. 在该对话框中调整任意设置。

    有关更多信息，请参见设置代码颜色首选参数选项。

相关主题

  • 为模板自定义代码颜色首选参数


自定义快捷键

您可以在 Dreamweaver 中使用自己喜欢的键盘快捷方式。如果您习惯使用特定的键盘快捷方式（例如使用 Ctrl + Enter 组合键添加一个换行符，使用 Ctrl + G 组合键转到代码中的特定位置，或使用 Shift + F6 组合键验证一个文件），则可以使用键盘快捷方式编辑器将它们添加到 Dreamweaver 中。有关更多信息，请参见自定义快捷键。

相关主题

使用代码片断


默认以“代码”视图打开文件

当您打开一个通常不包含任何 HTML 的文件类型（例如，JavaScript 文件）时，该文件将在“代码”视图（或代码检查器）而不是“设计”视图中打开。您可以指定在“代码”视图中打开的文件类型。

若要设置非 HTML 文件的默认视图，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或 Dreamweaver>“首选参数”(Macintosh)。
  2. 从左侧的“类别”列表中选择“文件类型/编辑器”。

    出现“文件类型/编辑器”首选参数。

  3. 在“在代码视图中打开”文本框中，添加要在“代码”视图中自动打开的文件类型的文件扩展名。

    在文件扩展名之间键入空格。您可以添加任意多的文件扩展名。

相关主题

  • 设置“文件类型/编辑器”首选参数选项


设置验证程序首选参数

您可以在 Dreamweaver 中使用验证程序快速定位代码中的标签或语法错误（请参见验证标签）。您可以指定验证程序应该检查的基于标签的语言、验证程序应该检查的特定问题、以及验证程序应该报告的错误类型。

注意

当您验证文档是否已明确指定 Doctype 时，将忽略验证程序首选参数。

若要设置“验证程序”参数，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或 Dreamweaver>“首选参数”(Macintosh)。
  2. 从左侧的“类别”列表中选择“验证程序”。

    出现“验证程序”首选参数。

  3. 选择要验证的标签库，并为标签库设置选项。

    有关更多信息，请参见设置验证程序首选参数选项。


管理标签库

在 Dreamweaver 中，标签库是一组特定类型的标签，其中还包含 Dreamweaver 应如何设置标签格式的信息。标签库提供了 Dreamweaver 用于代码提示、目标浏览器检查、标签选择器和其它代码功能的标签信息。使用标签库编辑器，您可以添加和删除标签库、标签和属性，设置标签库的属性以及编辑标签和属性。

本节包含以下主题：

  • 打开和关闭标签库编辑器
  • 添加库、标签和属性
  • 编辑库、标签和属性
  • 删除库、标签和属性

另请参见将自定义标签导入 Dreamweaver。


打开和关闭标签库编辑器

若要管理标签库，请使用标签库编辑器。

若要打开标签库编辑器，请执行以下操作：

  • 选择“编辑”>“标签库”。

出现标签库编辑器。（此对话框的内容根据所选的标签有所变化。）

若要关闭标签库编辑器并保存更改，请执行以下操作：

  • 单击“确定”。

若要不保存更改关闭标签库，请执行以下操作：

  • 单击“取消”。

    注意

    当单击“取消”时，在标签库编辑器中进行的任何更改都会丢失。删除的标签或标签库将会恢复。


添加库、标签和属性

您可以在 Dreamweaver 中使用标签库编辑器添加标签库，以及将标签和属性添加到标签库中。

注意

若要导入标签，请参见将自定义标签导入 Dreamweaver。

若要添加标签库，请执行以下操作：

  1. 在标签库编辑器（“编辑”>“标签库”）中，单击加号 (+) 按钮并选择“新建标签库”。

    即会出现“新建标签库”对话框。

  2. 在“库名称”文本框中，键入一个名称（例如：Miscellaneous Tags）。
  3. 单击“确定”。

若要将标签添加到标签库，请执行以下操作：

  1. 在标签库编辑器（“编辑”>“标签库”）中，单击加号 (+) 按钮并选择“新建标签”。

    即会出现“新建标签”对话框。

  2. 在该对话框中调整任意设置。

    有关更多信息，请参见设置“新建标签”对话框选项。

  3. 单击“确定”。

若要将一个或多个属性添加到标签，请执行以下操作：

  1. 在标签库编辑器（“编辑”>“标签库”）中，单击加号 (+) 按钮并选择“新建属性”。

    即会出现“新建属性”对话框。

  2. 在该对话框中调整任意设置。

    有关更多信息，请参见设置“新建属性”对话框选项。

  3. 单击“确定”。

相关主题

  • 管理标签库
  • 编辑库、标签和属性
  • 删除库、标签和属性


编辑库、标签和属性

您可以使用标签库编辑器设置标签库的属性以及对库中的标签和属性进行编辑óó可以编辑它们的属性和属性值以及它们的格式（为了在代码中易于识别）。

若要设置标签库的属性，请执行以下操作：

  1. 在标签库编辑器（“编辑”>“标签库”）中，选择“标签”列中的标签库（不是标签）。

    注意

    只有选中标签库时才会显示标签库的属性。标签库在“标签”列表中以顶级文件夹表示；例如，“HTML 标签”文件夹代表一个标签库，而“HTML 标签”文件夹中的“abbr”文件夹代表一个标签。
  2. 在“用于”列中，选择每个应使用该标签库的文档类型。

    在此处选择的文档类型决定了哪些文档类型为给定标签库提供代码提示。例如，如果没有为某个给定的标签库选择 HTML 选项，该标签库的代码提示不会在 HTML 文件中出现。

  3. 如果标签库中的标签需要前缀，则在“标签前缀”文本框中输入前缀。

    注意

    前缀用于在代码中将标签标识为特定标签库的一部分。有些标签库不使用前缀。
  4. 如果已完成了在标签库编辑器中的更改，则单击“确定”。

若要编辑标签库中的标签，请执行以下操作：

  1. 在标签库编辑器（“编辑”>“标签库”）中，在“标签”列中展开标签库并选择一个标签。
  2. 设置以下任意“标签格式”选项：

    “换行符”指定 Dreamweaver 在何处插入标签的换行符。

    “内容”指定 Dreamweaver 如何插入标签的内容；即是否将换行符、格式设置和缩进规则应用于内容。

    “大小写”指定特定标签的大小写。从“默认”、“小写”、“大写”或“混合大小写”中进行选择。如果选择“混合大小写”，则将出现“标签名称混合大小写”对话框。按照 Dreamweaver 在插入标签时应使用的大小写键入标签（例如，getProperty），然后单击“确定”。

    “设置默认值”设置所有标签的默认大小写。在出现的“默认标签大小写”对话框中，选择“<大写字母>”或“<小写字母>”，然后单击“确定”。

    提示

    您可能要将默认大小写设置为小写字母以遵循 XML 和 XHTML 标准。

若要编辑标签的属性，请执行以下操作：

  1. 在标签库编辑器（“编辑”>“标签库”）中，在“标签”框中展开一个标签库、展开一个标签，然后选择一个标签属性。
  2. 在“属性大小写”弹出菜单中，选择“默认”、“小写”、“大写”或“混合大小写”。

    如果选择“混合大小写”，则将出现“属性名称混合大小写”对话框。按照 Dreamweaver 在插入属性时应使用的大小写键入属性（例如，onClick），然后单击“确定”。

    单击“设置默认值”链接设置所有属性名的默认大小写。

  3. 在“属性类型”弹出菜单中，选择该属性的类型。

    如果您选择“枚举”，则在“值”文本框中为该属性键入每个允许的值。用逗号分隔这些值，但是不要有空格。例如，cfchart 标签的 showborder 属性的枚举值为 yes,no。

相关主题

  • 管理标签库
  • 添加库、标签和属性
  • 删除库、标签和属性


删除库、标签和属性

您可以使用标签库编辑器删除标签库、标签和属性。

若要删除库、标签或属性，请执行以下操作：

  1. 在标签库编辑器（“编辑”>“标签库”）中，在“标签”框中选择一个标签库、标签或属性。
  2. 单击减号 (-) 按钮。
  3. 如果要求您确认删除，请单击“确认”永久删除该项。

    该项将从“标签”框中删除。

  4. 单击“确认”来关闭标签库编辑器并完成删除。

相关主题

  • 管理标签库
  • 添加库、标签和属性
  • 编辑库、标签和属性


将自定义标签导入 Dreamweaver

您可以将自定义标签导入 Dreamweaver 中，使其成为创作环境的组成部分。例如，当您在“代码”视图中开始键入导入的自定义标签时，就会出现代码提示菜单，列出该标签的属性供您选择。

本节包含以下主题：

  • 从 XML 文件导入标签
  • 导入自定义 ASP.NET 标签
  • 从文件导入 JSP 标签
  • 从服务器 (web.xml) 导入 JSP 标签
  • 导入 JRun 标签


从 XML 文件导入标签

您可以从 XML 文档类型定义 (DTD) 文件或架构导入标签。

若要从 XML DTD 或架构导入标签，请执行以下操作：

  1. 打开标签库编辑器（“编辑”>“标签库”）。
  2. 单击加号 (+) 按钮并选择“DTD 架构”>“导入 XML DTD 或架构文件”。
  3. 输入文件名，或者 DTD 或架构文件的 URL。
  4. 输入要用于该标签的前缀。

    注意

    前缀用于在代码中将标签标识为特定标签库的一部分。有些标签库不使用前缀。
  5. 单击“确定”。


导入自定义 ASP.NET 标签

您可以将自定义 ASP.NET 标签导入 Dreamweaver 中。

在开始之前，确保自定义标签安装于在“站点定义”对话框中定义的测试服务器上（请参见指定可在哪里处理动态页）。编译后的标签（.dll 文件）必须放置在站点根目录的 /bin 文件夹中。非编译标签（.ascx 文件）可以贮留在服务器上的任何虚拟目录或子目录中。有关更多信息，请参见 Microsoft ASP.NET 文档。

若要将 ASP.NET 自定义标签导入 Dreamweaver，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 ASP.NET 页。
  2. 打开标签库编辑器（“编辑”>“标签库”）。
  3. 单击加号 (+) 按钮并执行以下操作之一：
    • 若要从应用程序服务器导入所有 ASP.NET 自定义标签，请选择“ASP.NET”>“导入所有 ASP.NET 自定义标签”。
    • 若要从应用程序服务器只导入某些自定义标签，请选择“ASP.NET”>“导入所选的 ASP.NET 自定义标签”。

    即会出现“导入所选的 ASP.NET 自定义标签”对话框，列出安装在应用程序服务器上的每个 ASP.NET 自定义标签。按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 单击列表中的标签，然后单击“确定”。


从文件导入 JSP 标签

您可以从多种文件类型将 JSP 标签库导入 Dreamweaver。

若要将 JSP 标签库导入 Dreamweaver，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 JSP 页。
  2. 打开标签库编辑器（“编辑”>“标签库”）。
  3. 单击加号 (+) 按钮并选择“JSP”>“从文件 (*.tld、*.jar、*.zip) 导入”。
  4. 输入文件名、URI 和前缀。

    有关更多信息，请参见设置“从文件导入 JSP 标签库”对话框选项。

  5. 单击“确定”。


从服务器 (web.xml) 导入 JSP 标签

您可以从 JSP 服务器上的 web.xml 文件中将 JSP 标签库导入 Dreamweaver。

若要从服务器导入 JSP 标签，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 JSP 页。
  2. 打开标签库编辑器（“编辑”>“标签库”）。
  3. 单击加号 (+) 按钮并选择“JSP”>“从服务器 (web.xml) 导入”。

    即会出现“从服务器导入”对话框。

  4. 输入文件名和 URI。

    有关更多信息，请参见设置“从服务器导入 JSP 标签库”对话框选项。

  5. 单击“确定”。


导入 JRun 标签

如果您使用 Macromedia JRun，则可以将您的 JRun 标签导入 Dreamweaver。

若要将 JRun 标签导入 Dreamweaver，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 JSP 页。
  2. 打开标签库编辑器（“编辑”>“标签库”）。
  3. 在标签库编辑器中，单击加号 (+) 按钮并选择“JSP”>“从文件夹导入 JRun Server 标签”。
  4. 输入文件夹名、URI 和前缀。

    有关更多信息，请参见设置“从文件夹导入 JRun 服务器标签”对话框选项。

  5. 单击“确定”。


将外部 HTML 编辑器用于 Dreamweaver

您可以从 Dreamweaver 中启动外部 HTML 或文本编辑器来编辑当前文档的源代码，然后切换回 Dreamweaver 继续以图形方式进行编辑。Dreamweaver 会检测任何已在外部保存到文档的更改，并提示您在返回时重新载入文档。

您可以使用以下集成 HTML 编辑器：Macromedia HomeSite（仅限 Windows）或 BBEdit（仅限 Macintosh）。您还可以使用任何其它文本编辑器，例如“记事本”、WordPad、TextPad、TextEdit、SimpleText、vi 或 emacs。

本节包含以下主题：

  • 使用集成 HTML 编辑器
  • 设置文件类型和外部编辑器首选参数


使用集成 HTML 编辑器

当您安装 Dreamweaver 时，您可以在 Windows 中安装 HomeSite 或在 Macintosh 上安装 BBEdit 的试用版。Dreamweaver 与这两种产品均紧密集成。

由于这种集成，您在 Dreamweaver 和 HomeSite/BBEdit 中都可以进行文档编辑，并从一个应用程序切换到另一个，而且文档在两个应用程序之间保持自动同步。除此之外，两个应用程序都跟踪当前的选定内容；例如，如果您在 Dreamweaver 中选中文本并切换到 BBEdit，相同的元素也在 BBEdit 中选中。

您可以从 Dreamweaver 中打开除 HomeSite 和 BBEdit 之外的其它外部编辑器，但是文档不像在 HomeSite 或 BBEdit 中那样在两个应用程序间保持同步。当您在外部编辑器（非 HomeSite 或 BBEdit）中完成更改后，您必须在 Dreamweaver 中手动刷新文档。


使用 HomeSite（仅限 Windows）

您不需要启用 HomeSite 的集成；在安装两个应用程序后将自动集成 HomeSite。

若要使用 HomeSite，请执行以下操作：

  1. 选择“编辑”>“用 HomeSite 进行编辑”。
  2. 在 HomeSite 中编辑文档并保存您的更改。
  3. 若要返回 Dreamweaver，请单击编辑器工具栏中的“Dreamweaver”。


使用 BBEdit（仅限 Macintosh）

如果您不喜欢使用 BBEdit，您可以禁用 BBEdit 集成。如果禁用了 BBEdit 集成，所选内容将不会在 Dreamweaver 和 BBEdit 之间进行跟踪。然而，如果禁用了 BBEdit 集成，那么 Dreamweaver 的编辑速度会加快。

若要将 BBEdit 与 Dreamweaver 一起使用，请执行以下操作：

  1. 选择“编辑”>“用 BBEdit 进行编辑”。
  2. 在 BBEdit 中编辑文档。
  3. 在 BBEdit 中，单击 HTML 工具板上的 Dreamweaver 按钮，返回到 Dreamweaver。

若要禁用 BBEdit 集成，请执行以下操作：

  1. 选择“编辑”>“首选参数”或“Dreamweaver”>“首选参数”(Mac OS X)，然后选择“文件类型/编辑器”。
  2. 取消选择“启用 BBEdit 集成”，然后单击“确定”。


设置文件类型和外部编辑器首选参数

您可以为多种文件扩展名中的每一个指定使用哪一个外部应用程序进行编辑。

若要选择外部 HTML 编辑器，请执行以下操作：

  1. 选择“编辑”>“首选参数”。
  2. 从左侧的“类别”列表中选择“文件类型/编辑器”。

    出现“文件类型/编辑器”首选参数。

  3. 在该对话框中调整任意设置。

    有关更多信息，请参见设置“文件类型/编辑器”首选参数选项。

  4. 单击“确定”。

若要启动外部 HTML 编辑器，请执行以下操作：

  • 选择“编辑”>“用 [编辑器名称] 进行编辑”。

相关主题

  • 默认以“代码”视图打开文件
  • 设置外部图像编辑器首选参数
  • 为媒体文件启动外部编辑器
  • 使用集成 HTML 编辑器


参考资料

本节提供有关在本章中讨论的以下几个对话框的信息：

  • 设置“标签库编辑器”对话框选项
  • 设置代码格式首选参数选项
  • 设置代码提示首选参数选项
  • 设置代码改写首选参数选项
  • 设置代码颜色首选参数选项
  • 设置验证程序首选参数选项
  • 设置“新建标签”对话框选项
  • 设置“新建属性”对话框选项
  • 设置“从文件导入 JSP 标签库”对话框选项
  • 设置“从服务器导入 JSP 标签库”对话框选项
  • 设置“从文件夹导入 JRun 服务器标签”对话框选项
  • 设置“文件类型/编辑器”首选参数选项
  • 设置代码检查器选项


设置“标签库编辑器”对话框选项

此对话框用于添加、编辑和删除标签库、标签和属性及导入标签库。

任务

  • 添加库、标签和属性
  • 编辑库、标签和属性
  • 删除库、标签和属性
  • 将自定义标签导入 Dreamweaver


设置代码格式首选参数选项

此对话框使您可以指定 Dreamweaver 如何设置代码格式的首选参数。

注意

除了“大小写自动转换”之外的所有首选参数只影响新文档和新添加到现有文档的部分。也就是说，当您打开一个以前创建的 HTML 文档时，这些格式设置选项将不会应用于该文档；若要对现有的 HTML 文档重新进行格式设置，请使用“应用源格式”命令。有关更多信息，请参见将新格式设置首选参数应用于现有的文档。

若要指定代码格式首选参数，请执行以下操作：

  1. 指定以下任意选项：

    “缩进”指示由 Dreamweaver 生成的代码是否应该缩进（根据在这些首选参数中指定的缩进规则）。

    注意

    此对话框中的大多数缩进选项仅应用于由 Dreamweaver 生成的代码，而不应用于您键入的代码。若要使您新键入的每一行的缩进级别都与上一行相同，请使用位于“代码”视图中的“查看选项”菜单中的“自动缩进”选项。有关更多信息，请参见设置代码查看选项。

    “使用”（文本框和弹出菜单）指定 Dreamweaver 使用多少个空格或制表符对它所生成的代码进行缩进。例如，如果在文本框中键入“3”并从弹出菜单中选择“制表符”，则由 Dreamweaver 生成的代码对每个缩进级别使用 3 个制表符进行缩进。

    “制表符大小”确定每个制表符字符在“代码”视图中显示为多少个字符宽度。例如，如果“制表符大小”设置为 4，那么每个制表符在“代码”视图中显示为 4 个字符宽度的空白空间。此外，如果“缩进大小”设置为 3 个制表符，那么由 Dreamweaver 生成的代码对每个缩进级别使用三个制表符进行缩进，在“代码”视图中显示的缩进就是十二个字符宽度的空白空间。

    注意

    Dreamweaver 使用空格或制表符两者之一进行缩进；在插入代码时它并不会把一串空格转换成制表符。

    “自动换行”在一行到达指定的列宽度时插入一个换行符（也称作“硬”回车）。(Dreamweaver 只在添加换行符后不会更改文档在浏览器中外观的位置插入换行符，因此某些行的长度可能大于“自动换行”选项中指定的值。）相比之下，“代码”视图中的“换行”选项在显示较长的行（超过窗口宽度）时使它们看起来似乎含有换行符，但事实上并没有插入换行符。

    “换行符类型”指定承载远程站点的远程服务器的类型（Windows、Macintosh 或 UNIX）。选择正确的换行符类型可以确保您的 HTML 源代码在远程服务器上能够正确显示。）当您使用只识别某些换行符的外部文本编辑器时，此设置也有用。例如，如果将“记事本”作为您的外部编辑器，则使用“CR LF (Windows)”；如果将“SimpleText”作为外部编辑器，则使用“CR (Macintosh)”。

    注意

    如果要连接的服务器使用 FTP，此选项只能应用于二进制传输模式；Dreamweaver 中的 ASCII 传输模式忽略此选项。如果使用 ASCII 模式下载文件，则 Dreamweaver 根据计算机的操作系统设置换行符；如果使用 ASCII 模式上传文件，则换行符都设置为“CR LF”。

    “默认标签大小写”和“默认属性大小写”控制标签和属性名称的大小写。这些选项应用于您在“设计”视图中插入或编辑的标签和属性，但是它们不能应用于您在“代码”视图中直接输入的标签和属性，也不能应用于打开的文档中的标签和属性（除非您还选择了一个或全部两个“覆盖大小写”选项）。

    覆盖大小写：“标签”和“属性”指定是否在任何时候（包括当您打开现有的 HTML 文档时）都强制使用您指定的大小写选项。当您选择其中的一个选项并且单击“确定”退出对话框时，当前文档中的所有标签或属性立即转换为指定的大小写，同样，从这时起打开的每个文档中的所有标签或属性也都转换为指定的大小写（直到您再次取消对此选项的选择为止）。您在“代码”视图和快速标签编辑器中键入的标签或属性也转换为指定的大小写，使用“插入”栏插入的标签或属性同样也转换为指定的大小写。例如，如果您想让标签名称总是转换为小写，则在“默认标签的大小写”选项中指定小写字母，然后选择“覆盖大小写：标签”选项。于是当您打开包含大写标签名称的文档时，Dreamweaver 将它们全部转换为小写。

    注意

    旧版本 HTML 允许标签和属性的名称使用大写或小写，但是 XHTML 要求标签和属性的名称为小写。Web 正在向 XHTML 方向发展，所以一般来讲，标签和属性名称最好使用小写。

    “居中”指定当您单击属性检查器中的“居中对齐”按钮时，是使用 div align="center" 还是使用 center 标签来居中元素。

    注意

    这两种居中方法在 HTML 4.01 规范中均已正式被淘汰；您应该使用 CSS 样式来居中文本。在 XHTML 1.0 Transitional 规范中，这两种方法依然在技术上有效，但是在 XHTML 1.0 Strict 规范中，它们不再有效。


设置代码提示首选参数选项

此对话框允许您指定首选参数，以确定 Dreamweaver 在“代码”视图和快速标签编辑器中显示代码提示的方式和时间。

提示

即使禁用代码提示，也可以通过按 Ctrl + 空格键在“代码”视图中显示弹出式提示。

若要指定代码提示首选参数，请执行以下操作：

  • 指定以下任意选项：

    结束标签允许您指定希望 Dreamweaver 插入结束标签的方式。默认情况下，在键入字符 </ 后，Dreamweaver 会自动插入结束标签。可以更改此默认行为，以便在键入开始标签的最后尖括号 (>) 之后插入结束标签，或者根本就不插入结束标签。

    启用代码提示使得您在“代码”视图中输入代码时，显示代码提示。拖动“延迟”滑块来设置 Dreamweaver 在显示适当的提示之前经过的时间（以秒为单位）。

    菜单允许您设置在键入代码时具体要显示哪种类型的代码提示。您可以使用全部或部分菜单。

相关主题

  • 使用代码提示
  • 在快速标签编辑器中使用提示菜单


设置代码改写首选参数选项

此对话框允许您指定首选参数，以确定在打开文档、复制或粘贴表单元素或在使用 Dreamweaver 工具（例如属性检查器）输入属性值和 URL 时，是否要 Dreamweaver 修改代码，以及如何修改。当您在“代码”视图中编辑代码时，这些首选参数不起作用。

如果您禁用改写选项，则 Dreamweaver 在“文档”窗口中对它本该改写的 HTML 标签显示无效标记项。

若要设置代码改写首选参数，请执行以下操作：

  • 指定以下任意选项：

    “修复非法嵌套标签或未结束标签”改写重叠的标签。例如，将 <b><i>text</b></i> 改写为 <b><i>text</i></b>。如果缺少右引号或右括号，则此选项还将插入右引号或右括号。

    “粘贴时重命名表单项”确保表单对象不会具有重复的名称。默认情况下启用该选项。

    注意

    与此首选参数对话框中的其它选项不同的是，此选项并不在打开文档时应用，只在复制和粘贴表单元素时应用。

    “删除多余的结束标签”删除没有对应开始标签的结束标签。

    “修正或删除标签时发出警告”显示 Dreamweaver 试图更正的、技术上无效的 HTML 的摘要。摘要记录了问题的位置（使用行号和列号），以便您可以找到更正并确保它是按预期方式呈现的。

    “从不改写代码：在带有扩展的文件中”允许您防止 Dreamweaver 改写具有指定文件扩展名的文件中的代码。对于包含第三方标签的文件，此选项特别有用。

    “使用 & 将属性值中的 <、>、& 和 " 编码”确保您使用 Dreamweaver 工具（例如属性检查器）输入或编辑的属性值只包含合法的字符。默认情况下启用该选项。

    注意

    此选项和下面的选项不会应用于您在“代码”视图中键入的 URL。另外，它们不会使已经存在于文件中的代码发生更改。

    “不编码特殊字符”防止 Dreamweaver 更改 URL 从而仅使用合法字符。

    “使用 &# 将 URL 中的特殊字符编码”确保当您使用 Dreamweaver 工具（例如属性检查器）输入或编辑 URL 时，这些 URL 只包含合法的字符。默认情况下启用该选项。

    “使用 % 将 URL 中的特殊字符编码”与前一选项的操作方式相同，但是使用另一方法编码特殊字符。这种编码方法（使用百分号）可能对较早版本的浏览器更为兼容，但对于某些语言中的字符并不适用。


设置代码颜色首选参数选项

此对话框允许您为 Dreamweaver 指定如何将颜色应用于代码的首选参数。

若要设置特定标签的颜色首选参数，请在标签库编辑器中编辑标签定义。有关更多信息，请参见编辑库、标签和属性。

若要设置代码颜色首选参数，请执行以下操作：

  1. 使用“默认背景”选项为“代码”视图和代码检查器选择默认背景颜色。
  2. 在“代码颜色”首选参数对话框中选择文档类型然后单击“编辑颜色方案”。

    出现“编辑颜色方案”对话框。

  3. 选择一项并设置其文本颜色、背景颜色和（如果需要）样式（粗体、斜体或下划线）。

    “预览”窗格中的示例代码将发生变化，以匹配新的颜色和样式。

  4. 完成后，单击“确定”。

相关主题

  • 为模板自定义代码颜色首选参数


设置验证程序首选参数选项

您可以在 Dreamweaver 中使用验证程序快速定位代码中的标签或语法错误（请参见验证标签）。您可以指定验证程序应该检查的基于标签的语言、验证程序应该检查的特定问题、以及验证程序应该报告的错误类型。

注意

当您验证文档是否已明确指定 Doctype 时，将忽略验证程序首选参数。

若要指定验证程序首选参数，请执行以下操作：

  1. 选择要验证的语言。

    不能选择同一种语言的多个版本；例如，如果选择了 HTML 4.0，就不能再选择 HTML 3.2 或 HTML 2.0。选择您希望验证的最早版本；例如，如果文档包含有效的 HTML 2.0 代码，它也将是有效的 HTML 4.0 代码。

  2. 单击“选项”。

    即会出现“验证程序选项”对话框。

  3. 选择要在验证程序报告中包含的错误和警告类型的“显示”选项。
  4. 选择验证程序应该检查的项目：

    “文本中的引用”指示 Dreamweaver 在您每次在文档的文本中使用引号时都向您发出警告；您在 HTML 文档应该使用 &quot; 实体，而不是引号。

    “文本中的实体”指示 Dreamweaver 应建议将特定字符（如“与”(&)、“小于”(<) 和“大于”(>)）更改为等效的 HTML 实体。

  5. 单击“确定”关闭“验证程序选项”对话框。


设置“新建标签”对话框选项

此对话框的作用是向标签库添加新的标签。

注意

有关如何导入标签的信息，请参见将自定义标签导入 Dreamweaver。

若要指定“新建标签”选项，请执行以下操作：

  1. 在“标签库”弹出菜单中，选择一个标签库。
  2. 在“标签名称”文本框中，键入新标签的名称。

    若要添加多个标签，请键入这些标签的名称。以逗号和空格来分隔标签的名称（例如：cfgraph, cfgraphdata）。

  3. 如果新的标签具有相应的结束标签 (</...>)，请选择“具有匹配的结束标签”。


设置“新建属性”对话框选项

此对话框的作用是为标签库中的标签添加新的属性。

若要指定“新建属性”选项，请执行以下操作：

  1. 在“标签库”弹出菜单中，选择一个标签库。
  2. 在“标签”弹出菜单中选择一个标签。
  3. 在“属性名称”文本框中，键入新属性的名称。

    若要添加多个属性，请键入这些属性的名称。以逗号和空格来分隔属性的名称（例如：width, height）。


设置“从文件导入 JSP 标签库”对话框选项

此对话框的作用是从文件将 JSP 标签库导入到 Dreamweaver。

若要指定导入选项，请执行以下操作：

  1. 单击浏览器按钮或键入文件名来指定包含标签库的 .tld、.jar 或 .zip 文件。
  2. 输入一个 URI 以标识该标签库。

    URI（统一资源标识符）通常由维护该标签库的组织的 URL 组成。URL 不用于查看组织的 Web 站点；它用于唯一标识标签库。

  3. 输入要用于该标签的前缀。

    注意

    前缀用于在代码中将标签标识为特定标签库的一部分。有些标签库不使用前缀。


设置“从服务器导入 JSP 标签库”对话框选项

此对话框的作用是从 JSP 服务器将 JSP 标签库导入到 Dreamweaver。

若要指定导入选项，请执行以下操作：

  1. 选择一个标签库。
  2. 输入一个 URI 以标识该标签库。

    URI（统一资源标识符）通常由维护该标签库的组织的 URL 组成。URL 不用于查看组织的 Web 站点；它用于唯一标识标签库。


设置“从文件夹导入 JRun 服务器标签”对话框选项

此对话框在作用是将 JRun 服务器标签导入到 Dreamweaver。

若要指定导入选项，请执行以下操作：

  1. 指定包含 JRun 标签的文件夹。
  2. 输入一个 URI 以标识该标签库。

    URI（统一资源标识符）通常由维护该标签库的组织的 URL 组成。URL 不用于查看组织的 Web 站点；它用于唯一标识标签库。

  3. 输入要用于该标签的前缀。

    注意

    前缀用于在代码中将标签标识为特定标签库的一部分。有些标签库不使用前缀。


设置“文件类型/编辑器”首选参数选项

此对话框允许您为每种文件类型使用何种编辑器指定首选参数。

若要指定文件类型/编辑器首选参数，请执行以下操作：

  1. 指定文件扩展名以便在“代码”视图中自动打开。
  2. （仅限 Macintosh）若要使用 BBEdit 以外的 HTML 编辑器，请取消对“启用 BBEdit 集成”选项的选择。若要使用 BBEdit，保留对“启用 BBEdit 集成”的选择并跳过其余的步骤。
  3. 单击“外部代码编辑器”文本框旁边的“浏览”按钮并选择一个文本编辑器。
  4. 在“重载修改过的文件”选项中，指定当 Dreamweaver 检测到对 Dreamweaver 中打开的文档从外部进行了更改时 Dreamweaver 应该执行的操作。
  5. 在“运行时先保存文件”选项中，指定 Dreamweaver 应该总是在启动编辑器之前保存当前的文档、从不保存文档、还是每次启动外部编辑器时提示询问是否保存文档。
  6. 为各种不同的媒体文件类型指定编辑器。有关更多信息，请参见设置外部图像编辑器首选参数。

相关主题

  • 默认以“代码”视图打开文件
  • 为媒体文件启动外部编辑器
  • 使用集成 HTML 编辑器


设置代码检查器选项

代码检查器用于使您在单独的编码窗口中工作。代码检查器与“代码”视图的工作方式相同；您可以把它当作当前文档的一个可分离的“代码”视图。

若要使用代码检查器选项，请执行任何以下操作：

  • 若要使用“视图选项”按钮，请参见设置代码查看选项。
  • 若要使用“代码导航”按钮，请参见跳转到 JavaScript 或 VBScript 函数。
  • 使用“参考”按钮打开“参考”面板。有关更多信息，请参见使用语言参考资料。
  • 使用“刷新设计视图”按钮更新“设计”视图中的文档，以便它可以反映代码中所做的任何更改。在执行某些操作（如保存文件或单击该按钮）之前，您在代码中所做的更改不会自动显示在“设计”视图中。
  • 使用“在浏览器中预览/调试”按钮在浏览器中预览或调试文档。
  • 使用文件管理上传或获取文件。
  • 若要使用窗口左边的“编码”工具栏，请参见使用编码工具栏迅速插入代码。

相关主题

  • 设置代码格式设置首选参数
  • 设置代码提示首选参数
  • 设置“代码颜色”首选参数


在 Dreamweaver 中编写代码

Macromedia Dreamweaver 8 提供了功能全面的编码环境，这一编码环境是针对各种 Web 开发类型（范围从编写简单的 HTML 页面到设计、测试和部署复杂的 Web 应用程序）而专门设计的。

注意

有关从 Macromedia HomeSite 迁移到 Dreamweaver 的信息，请访问 Dreamweaver 支持中心，网址为 www.macromedia.com/go/migrate_from_homesite。

本章包含以下主题：

关于在 Dreamweaver 中编写代码

编写和编辑代码

搜索和替换标签和属性

对代码的选定内容进行快速更改

使用语言参考资料

打印代码

相关主题

  • 设置您的编码环境
  • 优化和调试代码
  • 在设计视图中编辑代码
  • 比较文件的差别


关于在 Dreamweaver 中编写代码

Dreamweaver 中的编码环境允许您编写、编辑和测试页面中的代码（用多种语言编写的代码）。Dreamweaver 不会改变您手工编写的代码，除非您启用了特定选项以重写某种无效代码。

本节包含以下主题：

  • 支持的语言
  • 关于修正无效标记
  • Dreamweaver 中的自动代码修改
  • 关于由 Dreamweaver 生成的 XHTML 代码
  • Server-side include（服务器端包括）
  • 正则表达式
  • 关于服务器行为代码

相关主题

  • 查看您的代码


支持的语言

除了提供文本编辑功能外，Dreamweaver 还提供了各种各样的功能，例如代码提示（帮助您使用某些特定语言进行编码）。这些语言包括：

  • HTML
  • XHTML
  • CSS
  • JavaScript
  • ColdFusion 标记语言 (CFML)
  • Visual Basic（用于 ASP 和 ASP.NET）
  • C#（用于 ASP.NET）
  • JSP
  • PHP

Dreamweaver 的语言特定编码功能并不支持某些语言（例如 Perl）；您可以使用 Dreamweaver 创建和编写 Perl 文件，但是有些功能（例如代码提示）不能应用于该语言。

相关主题

  • Dreamweaver 中的自动代码修改
  • 使用代码提示


关于修正无效标记

如果文档中包含无效代码，Dreamweaver 会在“设计”视图中显示这些代码，而且会根据需要在“代码”视图中高亮显示它们。在这两种视图的任一种视图中选择这些代码，属性检查器都会显示代码无效的原因，以及如何进行修正的信息。

可以在 Dreamweaver 中指定首选参数，从而在打开文档时自动重写各种无效的代码。

相关主题

  • Dreamweaver 中的自动代码修改
  • 设置“代码改写”首选参数


Dreamweaver 中的自动代码修改

您可以设置选项指示 Dreamweaver 根据您指定的条件自动清理手工编写的代码。但是，Dreamweaver 不会重写您的代码，除非启用了代码重写选项或者您执行了更改代码的操作。例如，Dreamweaver 不会更改空白或更改属性的大小写，除非您使用“应用源格式”命令。

有些代码改写选项在默认情况下处于启用状态。有关如何禁用这些选项或启用其它选项的信息，请参见设置“代码改写”首选参数。

通过 Dreamweaver 的可自由导入导出 HTML 格式的功能，您可以在基于文本的 HTML 编辑器和 Dreamweaver 之间来回移动文档，并且对文档的原始 HTML 源代码的内容和结构只有很小的影响或没有任何影响。这些功能包括：

  • Dreamweaver 允许您启动第三方文本编辑器来编辑当前文档。有关更多信息，请参见将外部 HTML 编辑器用于 Dreamweaver。
  • 默认情况下，Dreamweaver 不更改在其它 HTML 编辑器中创建或编辑的代码（即使该代码无效），除非启用了代码改写选项。
  • Dreamweaver 不更改它不识别的标签（包括 XML 标签），因为它不具有判断这些标签的条件。如果不可识别的标签与另一个标签重叠（例如 <MyNewTag><em>text</MyNewTag></em>），则 Dreamweaver 将它标记为一个错误，但不改写该代码。
  • 此外，您可以将 Dreamweaver 设置为在“代码”视图中高亮显示（用黄色）无效的代码。在您选择高亮显示的部分后，属性检查器将显示有关如何纠正该错误的信息。

相关主题

  • 设置编码首选参数
  • 关于服务器行为代码


关于由 Dreamweaver 生成的 XHTML 代码

Dreamweaver 通过符合大多数 XHTML 要求的方法生成新的 XHTML 代码，并且清理现有的 XHTML 代码。Dreamweaver 还提供了一些用以符合剩余的少数 XHTML 要求所需的工具。

注意

本节所述的一些要求也是不同 HTML 版本中的要求。

下表说明了 Dreamweaver 自动符合的 XHTML 要求。

XHTML 要求

Dreamweaver 为满足此要求而执行的操作

文档中的根元素之前必须有 DOCTYPE 声明，而该声明必须引用 XHTML 的三个文档类型定义 (DTD) 文件（Strict、Transitional 或 Frameset）之一。

在 XHTML 文档中添加一个 XHTML DOCTYPE：

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

或者，如果 XHTML 文档包含框架集：

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">

文档的根元素必须为 html，而 html 元素必须指定 XHTML 命名空间。

将 namespace 属性添加到 html 元素，如下所示：

<html xmlns="http://www.w3.org/1999/xhtml">

标准的文档必须包含 head、title 和 body 结构元素。框架集文档必须包含 head、title 和 frameset 结构元素。

在标准文档中，包含有 head、title 和 body 元素。在框架集文档中，包含有 head、title 和 frameset 元素。

文档中的所有元素必须正确嵌套：

<p>This is a <i>bad example.</p></i>
<p>This is a <i>good example.</i></p>

生成正确嵌套的代码，并且在清理 XHTML 时更正代码中不是由 Dreamweaver 生成的嵌套。

所有元素和属性名称必须为小写。

在它所生成的 XHTML 代码中以及在清理 XHTML 时，不论您设置的标签和属性大小写首选参数如何，都强制使 HTML 元素和属性名称成为小写。

每个元素都必须有结束标签，除非在 DTD 中将其声明为 EMPTY。

在它所生成的代码中以及在清理 XHTML 时插入结束标签。

空元素必须有结束标签，或者开始标签必须以 /> 结束。例如，<br> 无效；正确的形式为 <br></br> 或 <br/>。以下元素为空元素：area、base、basefont、br、col、frame、hr、img、input、isindex、link、meta 和 param。

为了向后兼容不支持 XML 的浏览器，/> 前必须有一个空格（例如 <br />，而不是 <br/>）。

在它所生成的代码中以及在清理 XHTML 时，如果插入空元素，则在空标签中的结束斜杠后添加一个空格。

属性无法实现最小化；例如，<td nowrap> 无效，正确的形式为 <td nowrap="nowrap">。

它会影响以下属性：checked、compact、declare、defer、disabled、ismap、multiple、noresize、noshade、nowrap、readonly 和 selected。

在它所生成的代码中以及在清理 XHTML 时，插入完整的属性/值对。

请注意：如果 HTML 浏览器不支持 HTML 4，则当这些布尔属性以完整形式出现时，该浏览器可能无法解释这些属性。

所有的属性值必须用引号引起来。

在它所生成的代码中以及在清理 XHTML 时，将属性值用引号引起来。

以下元素必须具有 id 属性和 name 属性：a、applet、form、frame、iframe、img 和 map。例如，<a name="intro">Introduction</a> 无效；正确的形式为

<a id="intro">Introduction</a> 或
<a id="section1" name="intro">
Introduction</a>。

在 Dreamweaver 所生成的代码中以及在清理 XHTML 时，只要属性检查器设置 name 属性，就会将 name 和 ID 属性设置为相同的值。

对于具有枚举类型的值的属性，值必须为小写。

枚举类型的值是来自指定的允许值列表中的值；例如，align 属性具有以下允许值：center、justify、left 和 right。

在它所生成的代码中以及在清理 XHTML 时，强制枚举类型的值成为小写。

所有脚本和样式元素都必须具有 type 属性。

（自 HTML 4 开始已经要求 script 元素具有 type 属性，而 language 属性在此期间则使用的越来越少。）

在它生成的代码中以及在清理 XHTML 时，设置 script 元素的 type 和 language 属性， style 元素的 type 属性。

所有 img 和 area 元素都必须具有 alt 属性。

在它生成的代码中设置这些属性，并且在清理 XHTML 时报告缺少的 alt 属性。

相关主题

  • 使页符合 XHTML


Server-side include（服务器端包括）

Server-side include（服务器端包括）是浏览器向服务器请求您的文档时并入您的文档的一个文件。

当访问者浏览器请求含有 include（包括）指令的文档时，服务器处理 include（包括）指令并创建新的文档，在新文档中 include（包括）指令被所包括的文件内容取代。然后服务器将此新文档发送给访问者的浏览器。但当您在浏览器中直接打开一个本地文档时，因为没有服务器可以处理该文档中的 include（包括）指令，所以浏览器不处理这些指令即打开该文档，并且本应包括在内的文件并未在该浏览器中出现。因此，如果不使用 Dreamweaver，可能很难查看到本地文件在放置到服务器后对访问者的显示效果。

通过使用 Dreamweaver，无论是在“设计”视图中还是在浏览器中预览时，您都可以预览文档在放置到服务器后的显示效果。

在将 server-side include（服务器端包括）放置于文档中时，将插入对外部文件的引用，但它并不会在当前文档中插入指定文件的内容。Dreamweaver 在“设计”视图中显示外部文件的内容，这使得页面设计变得更加容易。

您不能在文档中直接编辑包括的文件。若要编辑 server-side include（服务器端包括）的内容，您必须直接编辑您所包括的文件。请注意，对外部文件的任何更改都将自动反映在包括该文件的每一文档中。

有两种类型的 server-side include（服务器端包括）：“虚拟”类型和“文件”类型。选择一种与您使用的 web 服务器类型相应的类型：

  • 如果您的服务器是 Apache Web 服务器，则选择“虚拟”。在 Apache 中，“虚拟”可以适用于所有情况，而“文件”只适用于某些情况。
  • 如果您的服务器是 Microsoft Internet Information Server (IIS)，则选择“文件”。（“虚拟”只在某些特定的情况下才可用于 IIS。）

    注意

    但可惜的是，除非在服务器上已安装了特殊的软件，否则 IIS 不允许您包括在文件夹层次结构中高于当前文件夹的文件夹中的文件。如果您需要在 IIS 服务器上包括来自文件夹层次结构中更高层次的文件夹中的文件，请向您的系统管理员咨询以了解是否安装了必需的软件。
  • 对于其它类型的服务器，或者如果您不知道您正使用哪一类型的服务器，请向您的系统管理员咨询要使用的选项。

某些服务器经过配置，可以检查所有文件以查看它们是否包含 server-side include（服务器端包括）；而其它一些服务器经过配置，只检查具有特定文件扩展名的文件，例如 .shtml、.shtm 或 .inc。如果某一 server-side include（服务器端包括）不适用于您，请向您的系统管理员咨询是否需要在使用 include（包括）的文件的名称中使用特殊扩展名。（例如，如果该文件名为 canoe.html，则您可能需要将其重命名为 canoe.shtml。）如果您希望您的文件保留 .html 或 .htm 扩展名，请要求您的系统管理员对服务器进行配置，以检查所有文件（而不只是具有某一扩展名的文件）是否具有 server-side include（服务器端包括）。但由于为 server-side include（服务器端包括）分析文件需要多花一些时间，所以服务器进行分析的那些页面可能要比其它页面稍晚一点才可使用；因此某些系统管理员将不提供对所有文件进行分析的选项。

相关主题

  • 插入 server-side include（服务器端包括）
  • 编辑 server-side include（服务器端包括）的内容


正则表达式

正则表达式是以文本描述字符组合的模式。在代码搜索中使用它们有助于描述一些概念，例如以“以‘var’开始的行”和“包含数字的属性值”。有关搜索的更多信息，请参见搜索和替换标签和属性。

下表列出了在正则表达式中使用的特殊字符、其含义和用法示例。若要搜索包含该表中某一特殊字符的文本，请在特殊字符前面附加一个反斜杠，令其“转义”。例如，若要在 some conditions apply* 短语中搜索实际的星号，您的搜索模式应类似于：apply\*。如果您没有令星号转义，您将找到“apply”的所有匹配项（以及“appl”、“applyy”和“applyyy”的所有匹配项），而不只是后面跟有星号的那些匹配项。

字符 | 匹配 | 示例
^ | 输入或行的起始部分。 | ^T 匹配“This good earth”中的“T”，但与“Uncle Tom's Cabin”中的“T”不匹配
$ | 输入或行的结尾部分。 | h$ 匹配“teach”中的“h”，但与“teacher”中的“h”不匹配
* | 0 个或多个前置字符。 | um* 匹配“rum”中的“um”、“yummy”中的“umm”和“huge”中的“u”
+ | 1 个或多个前置字符。 | um+ 匹配“rum”中的“um”和“yummy”中的“umm”，但在“huge”中没有任何匹配项
? | 前置字符最多出现一次（即，指示前置字符是可选的）。 | st?on 匹配“Johnson”中的“son”和“Johnston”中的“ston”，但在“Appleton”或“tension”中没有任何匹配项
. | 除换行符外的任何单字符。 | .an 匹配短语“bran muffins can be tasty”中的“ran”和“can”
x|y | x 或 y。 | FF0000|0000FF 匹配 bgcolor=”#FF0000” 中的“FF0000”和 font color=”#0000FF” 中的“0000FF”
{n} | 恰好 n 个前置字符。 | o{2} 匹配“loom”中的“oo”和“mooooo”中前两个“o”，但在“money”中没有任何匹配项
{n,m} | 至少 n 个、至多 m 个前置字符。 | F{2,4} 匹配“#FF0000”中的“FF”和“#FFFFFF”中的前四个“F”
[abc] | 用括号括起来的字符中的任何一个字符。用连字符指定某一范围的字符（例如，[a-f] 等效于 [abcdef]）。 | [e-g] 匹配“bed”中的“e”、“folly”中的“f”和“guard”中的“g”
[^abc] | 未在括号中括起来的任何字符。用连字符指定某一范围的字符（例如，[^a-f] 等效于[^abcdef]）。 | [^aeiou] 最初匹配“orange”中的“r”、“book”中的“b”和“eek!”中的“k”
\b | 词边界（例如空格或回车符）。 | \bb 匹配“book”中的“b”，但在“goober”或“snob”中没有任何匹配项
\B | 词边界之外的任何内容。 | \Bb 匹配“goober”中的“b”，但在“book”中没有任何匹配项
\d | 任何数字字符。等效于 [0-9]。 | \d 匹配“C3PO”中的“3”和“apartment 2G”中的“2”
\D | 任何非数字字符。等效于 [^0-9]。 | \D 匹配“900S”中的“S”和“Q45”中的“Q”
\f | 换页符。 |
\n | 换行符。 |
\r | 回车符。 |
\s | 任何单个空白字符，包括空格、制表符、换页符或换行符。 | \sbook 匹配“blue book”中的“book”，但在“notebook”中没有任何匹配项
\S | 任何单个非空白字符。 | \Sbook 匹配“notebook”中的“book”，但在“blue book”中没有任何匹配项
\t | 制表符。 |
\w | 任何字母数字字符，包括下划线。等效于 [A-Za-z0-9_]。 | b\w* 匹配“the barking dog”中的“barking”和“the big black dog”中的“big”和“black”
\W | 任何非字母数字字符。等效于 [^A-Za-z0-9_]。 | \W 匹配“Jake&Mattie”中的“&”和“100%”中的“%”
Ctrl+Enter 或 Shift+Enter (Windows)、或者 Ctrl+Return 或 Shift+Return 或 Command+ Return (Macintosh) | 回车符。确保如果没有使用正则表达式，则在搜索时取消对“忽略空白差别”的选择。请注意，这匹配特定字符，而不是一般意义上的换行符；例如，它不匹配 <br> 标签或 <p> 标签。回车符在“设计”视图中显示为空格而不是换行符。 |

使用括号在正则表达式内分隔出以后要引用的分组。然后在“替换”域中使用 $1、$2、$3 等来引用第一个、第二个、第三个和更后面的括号分组。

注意

在“查找内容”文本框中使用 \1、\2、\3 等（而不是 $1、$2、$3）来引用正则表达式中更早的括号分组。

例如，通过搜索 (\d+)\/(\d+)\/(\d+) 并用 $2/$1/$3 替换它，可以在由斜杠分隔的日期中交换日和月（因此可以在美国样式日期和欧洲样式日期之间进行转换）。

相关主题

  • 搜索包含在特定标签内的标签、属性或文本
  • 保存搜索模式


关于服务器行为代码

在您开发动态页并从“服务器行为”面板中选择一个服务器行为时，Dreamweaver 将一个或多个代码块插入您的页面，以令服务器行为可以行使其功能。

如果您手动地更改了代码块中的代码，您可能会无法继续使用面板（例如“绑定”面板和“服务器行为”面板）来编辑服务器行为。Dreamweaver 查找页面代码中的特定模式以检测服务器行为并在“服务器行为”面板中显示它们。如果您以任何方式更改了代码块中的代码，Dreamweaver 将无法再检测服务器行为并在“服务器行为”面板中显示它。但是，服务器行为仍存在于该页面上，并且您可以在 Dreamweaver 的编码环境中编辑它。

相关主题

  • Dreamweaver 中的自动代码修改
  • 为可视化开发优化工作区
  • 显示数据库记录


编写和编辑代码

Dreamweaver 提供若干种功能，可帮助您高效率地编写和编辑代码。

本节包含以下主题：

  • 使用代码提示
  • 使用代码片断
  • 使用编码工具栏迅速插入代码
  • 使用“插入”栏迅速插入代码
  • 使用“标签选择器”插入标签
  • 使用标签编辑器编辑标签
  • 折叠代码
  • 缩进代码块
  • 复制和粘贴代码
  • 插入 HTML 注释
  • 跳转到 JavaScript 或 VBScript 函数


使用代码提示

代码提示功能有助于您快速插入和编辑代码，并且不出差错。当您在“代码”视图中键入某些字符时（例如标签或属性或 CSS 属性名称的开始几个字母时），将出现一个列表，列出完成您的输入所需的建议选项。您可以使用该功能插入或编辑代码，或只是查看某一标签的可用属性、某一函数的可用参数或某一对象的可用方法。

各种类型的代码具有代码提示。当您键入表明一段代码开始部分的一个特定字符时会出现一个相应的项目列表；例如，若要显示 HTML 标签名称的代码提示列表，请键入一个左尖括号 (<)。

提示

为了达到最好的效果，尤其是对函数和对象使用代码提示时，请在“代码提示”首选参数对话框中将“延迟”选项设置为延迟 0 秒。有关更多信息，请参见设置代码提示首选参数。

当您按 Backspace 键 (Windows) 或者 Delete 键 (Macintosh) 时代码提示列表消失。

若要在代码提示菜单未能自动显示时显示该代码提示菜单，请执行以下操作：

  • 按 Ctrl+空格键 (Windows) 或 Command+空格键 (Macintosh)。

若要在“代码”视图中使用代码提示插入标记或其它代码，请执行以下操作：

  1. 键入一段代码的开始部分。例如，键入一个左尖括号 (<) 以插入一个标签；将插入点放在紧跟标签名称后面的位置并按空格键以插入一个属性。

    将会出现一个项目（例如标签名称或属性名称）列表。

    提示

    若要随时关闭该列表，请按 Esc 键。
  2. 使用滚动条或向上箭头键和向下箭头键来滚动浏览该列表。
  3. 若要插入列表中的项，请双击该项，或者选中它并按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    提示

    如果最近创建的 CSS 样式没有出现在 CSS 样式的代码提示列表中，请选择代码提示列表中的“刷新样式列表”。如果当前显示的是“设计”视图，在您选择了“刷新样式列表”后，可能会在“设计”视图中临时显示一些无效代码；若要从“设计”视图中删除这些无效代码，在您完成插入样式后，请按 F5 键再次刷新“设计”视图。

若要插入结束标签，请执行以下操作：

  • 键入 </（斜杠）。

    默认情况下，Dreamweaver 会确定需要结束哪个标签，并且会为您结束此标签。您可以更改此默认行为，以便在键入开始标签的最后尖括号 (>) 之后让 Dreamweaver 插入结束标签，或者根本就不插入结束标签。选择“编辑”>“首选参数”>“代码提示”，然后选择其中一个“结束标签”选项。

若要使用代码提示编辑标签，请执行以下操作之一：

  • 若要用一个不同的属性取代某个属性，首先删除该属性和它的值，然后按照前面介绍的步骤添加一个新的属性和值。
  • 若要更改某个值，首先删除该值，然后按照前面介绍的步骤添加一个新的值。

相关主题

  • 设置代码提示首选参数


使用代码片断

使用代码片断，您可以存储内容以便快速重复使用。您可以创建并插入 HTML、JavaScript、CFML、ASP、JSP 等代码片断。Dreamweaver 还包含了一些预定义的代码片段，您可以使用它们作为起始点。

本节介绍如何插入、创建、编辑和删除代码片断。其中还介绍了如何管理您的代码片段及如何与小组的其他成员共享您的代码片段。

注意

通过 Dreamweaver 8，那些含有 <font> 标签以及其它越来越少使用的元素和属性的代码片断已经移至“代码片断”面板中的 Legacy 文件夹中。

若要插入代码片断，请执行以下操作：

  1. 将插入点放在希望插入代码片断的位置，或选择要环绕代码片断的代码。
  2. 在“代码片断”面板（“窗口”>“代码片断”）中，双击该代码片断。

    您还可以用右键单击 (Windows) 或在按住 Control 键的同时单击 (Macintosh) 该代码片断，然后从弹出菜单中选择“插入”。

若要创建代码片断，请执行以下操作：

  1. 在“代码片断”面板中，单击该面板底部的“新建代码片断”图标。

    随即显示“代码片断”对话框。

  2. 完成对话框设置，然后单击“确定”。

    有关更多信息，请参见设置“代码片断”对话框选项。

若要编辑代码片断，请执行以下操作：

  • 在“代码片断”面板中，选择一个代码片断并单击面板底部的“编辑代码片断”按钮。 这是所描述的功能的图片。

若要删除代码片断，请执行以下操作：

  • 在“代码片断”面板中，选择一个代码片断并单击面板底部的“删除”按钮。 这是所描述的功能的图片。

若要创建代码片断文件夹和管理代码片断，请执行以下操作：

  1. 在“代码片断”面板中，单击该面板底部的“新建代码片断文件夹”按钮。
  2. 根据需要将代码片断拖入新文件夹或其它文件夹中。

若要添加或编辑代码片断的快捷键，请执行以下操作：

  1. 在“代码片断”面板中，右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“编辑快捷键”。

    将出现“快捷键编辑器”。

  2. 在“命令”弹出菜单中，选择“代码片断”。

    将出现一个代码片断列表。

  3. 选择一个代码片断并为其指定一个快捷键。

    有关更多信息，请参见自定义快捷键。

若要与小组其他成员共享一个代码片断，请执行以下操作：

  1. 查找与您要在 Dreamweaver 应用程序文件夹的 Configuration/Snippets 文件夹中共享的代码片断相对应的文件。
  2. 将该代码片断文件复制到您的计算机或网络计算机上的共享文件夹中。
  3. 让小组中的其他成员将该代码片断文件复制到他们自己的 Configuration/Snippets 文件夹中。


使用编码工具栏迅速插入代码

您可以使用编码工具栏迅速将代码添加到您的页面中。

若要迅速插入代码，请执行以下操作：

  1. 确保您处于“代码”视图中（视图 > 代码）。
  2. 确定插入点在代码中的位置，或选择一个代码块。
  3. 单击编码工具栏中的一个按钮，或者从工具栏的弹出菜单中选择一个菜单项。

若要了解每个按钮的功能，请将鼠标指针定位于按钮上直至出现工具提示。默认情况下编码工具栏中将显示以下按钮。

“打开的文档”列出已打开的文档。选择了一个文档后，它将显示在“文档”窗口中。

“折叠整个标签”折叠位于一组开始和结束标签之间的内容（例如，位于 <table> 和 </table> 之间的内容）。您必须将插入点放置在开始或结束标签中，然后单击“折叠整个标签”按钮折叠该标签。

提示

通过将插入点放在开始或结束标签中，然后在按住 Alt 键 (Windows) 或 Option 键 (Macintosh) 的同时单击“折叠整个标签”按钮，您还可以折叠整个标签外部的代码。此外，在按住 Ctrl 键的同时单击此按钮将可禁用“智能折叠”，这样 Dreamweaver 就不会调整它在完整标签外部折叠的内容。有关更多信息，请参见关于折叠代码。

折叠所选折叠所选代码。

提示

通过在按住 Alt 键 (Windows) 或 Option 键 (Macintosh) 的同时单击“折叠所选”按钮，您也可以折叠所选部分外部的代码。此外，在按住 Ctrl 键的同时单击此按钮将可禁用“智能折叠”，这样，您就可以准确地折叠所选内容，而不会被 Dreamweaver 篡改。有关更多信息，请参见关于折叠代码。

“扩展全部”可还原所有折叠的代码。

“选择父标签”可选择您放置了插入点的那一行的内容及其两侧的开始和结束标签。如果您反复单击此按钮且您的标签是对称的，则 Dreamweaver 最终将选择最外面的 html 和 /html 标签。

平衡大括弧选择您放置了插入点的那一行的内容及其两侧的圆括号、大括弧或方括号。如果您反复单击此按钮且两侧的符号是对称的，则 Dreamweaver 最终将选择该文档最外面的大括弧、圆括号或方括号。

显示行号使您可以在每个代码行的行首隐藏或显示号码。

“高亮显示无效代码”将以黄色高亮显示无效的代码。

应用注释使您可以在所选代码两侧添加注释标签或打开新的注释标签。

  • “应用 HTML 注释”将在所选代码两侧添加 <!-- 和 --!>，如果未选择代码，则打开一个新标签。
  • “应用 // 注释”将在所选 CSS 或 JavaScript 代码每一行的行首插入 //，如果未选择代码，则单独插入一个 // 标签。
  • “应用 /* */”将在所选 CSS 或 JavaScript 代码两侧添加 /* 和 */。
  • “应用 ' 注释”适用于 Visual Basic 代码。它将在每一行 Visual Basic 脚本的行首插入一个单引号，如果未选择代码，则在插入点插入一个单引号。
  • 如果在处理 ASP、ASP.NET、JSP、PHP 或 Macromedia ColdFusion 文件时选择了“应用服务器注释”选项，则 Dreamweaver 会自动检测正确的注释标签并将其应用到所选内容。

删除注释删除所选代码的注释标签。如果所选内容包含嵌套注释，则只会删除外部注释标签。

环绕标签在所选代码两侧添加选自“快速标签编辑器”的标签。

最近的代码片断使您可以从“代码片断”面板中插入最近使用过的代码片断。有关更多信息，请参见使用代码片断。

缩进代码将选定内容向左移动。

凸出代码将选定内容向左移动。

格式化源代码将先前指定的代码格式应用于所选代码，如果未选择代码块，则应用于整个页面。也可以通过从“格式化源代码”按钮中选择“代码格式设置”来快速设置代码格式首选参数，或通过选择“编辑标签库”来编辑标签库。

编码工具栏上提供的按钮数量取决于“文档”窗口中“代码”视图的大小。若要查看所有可用按钮，请调整“代码”视图窗口的大小或单击编码工具栏底部的展开箭头。

您还可以编辑编码工具栏以显示更多按钮（例如“自动换行”、“隐藏字符”和“自动缩进”）或隐藏您不想使用的按钮。但是，要使用该功能，您必须对生成工具栏的 XML 文件进行编辑。有关更多信息，请参见“扩展 Dreamweaver”。

注意

在“查看”菜单中可以使用用于查看隐藏字符的选项（“查看”>“代码视图选项”>“隐藏字符”），但它不是编码工具栏中的默认按钮。

相关主题

  • “编码”工具栏
  • 显示工具栏
  • 验证标签和括号是否对称


使用“插入”栏迅速插入代码

您可以使用插入栏迅速将代码添加到您的页面中。

若要迅速插入代码，请执行以下操作：

  1. 确定插入点在代码中的位置。
  2. 在“插入”栏中选择适当的类别。
  3. 单击“插入”栏中的一个按钮，或者从“插入”栏中的弹出菜单中选择一个菜单项。

    在您单击一个图标时，代码可以立即出现在您的页面中，或者显示一个对话框，要求您提供完成该代码所需的更多信息。

若要确定每一按钮所代表的功能，请将鼠标指针置于该按钮上并等待工具提示的出现。“插入”栏提供的按钮的数目和类型取决于当前文档的类型。同时还取决于您正使用“代码”视图还是“设计”视图。

尽管插入栏提供常用标签的集合，但这一集合并不是很全面。若要从更全面的标签集合中进行选择，请使用“标签选择器”。

相关主题

  • “插入”栏
  • 使用“标签选择器”插入标签


使用“标签选择器”插入标签

您可以使用“标签选择器”将 Dreamweaver 标签库（包括 Macromedia ColdFusion 标签库和 ASP.NET 标签库）中的任何标签插入您的页面中。有关标签库的更多信息，请参见管理标签库。

若要使用标签选择器插入标签，请执行以下操作：

  1. 确定插入点在代码中的位置，用右键单击 (Windows) 或在按住 Control 键的同时单击 (Macintosh)，然后选择“插入标签”。

    即会显示标签选择器。左窗格包含支持的标签库的列表，右窗格显示选定标签库文件夹中的单独的标签。

  2. 选择并插入标签。

    有关更多信息，请参见设置“标签选择器”对话框选项。

  3. 若要关闭“标签选择器”，请单击“关闭”按钮。

相关主题

  • 使用标签编辑器编辑标签


使用标签编辑器编辑标签

标签编辑器可用于查看、指定和编辑标签的属性。

若要使用标签编辑器编辑标签，请执行以下操作：

  1. 右键单击 (Windows) 或在按住 Control键的同时单击 (Macintosh)“代码”视图中的标签或“设计”视图中的对象，然后从弹出菜单中选择“编辑标签”。
  2. 指定或编辑该标签的属性，然后单击“确定”。

    提示

    若要获得与标签编辑器内的标签有关的更多信息，请单击“标签信息”。


折叠代码

您可通过折叠或扩展所选的代码片断优化“代码”视图，从而可根据自己的意愿显示尽可能多或尽可能少的代码。也可以剪切、粘贴或移动折叠的所选代码。

本节包含以下主题：

  • 关于折叠代码
  • 折叠和展开代码片断
  • 粘贴和移动折叠代码片断


关于折叠代码

Dreamweaver 允许您折叠和扩展代码片断，这样无须使用滚动条即可查看文档的不同部分。例如，如果要查看应用于页面下方较远处的 div 标签的 head 标签中的所有 CSS 规则，您可以折叠 head 标签和 div 标签之间的所有内容，这样就可以同时看到两部分代码。尽管可以通过在“设计”视图或“代码”视图中来选择代码片断，但只能在“代码”视图中折叠代码。

当您选择了代码后，Dreamweaver 将在所选代码的旁边添加一组折叠按钮（在 Windows 中为减号；在 Macintosh 中为垂直三角形）。若要折叠所选代码，请单击其中一个按钮。折叠了代码后，折叠按钮将变为展开按钮（在 Windows 中为加号按钮；在 Macintosh 中为水平三角形）。若要展开折叠的所选代码，请单击展开按钮。有关处理折叠代码的其他方式的信息，请参见折叠和展开代码片断。

有时，Dreamweaver 可能无法确切折叠您所选定的代码片断。Dreamweaver 将使用“智能折叠”来折叠最常用和视觉效果更好的所选内容。例如，如果您选择了一个缩进标签并且选择了该标签之前的缩进空格，Dreamweaver 将不会折叠缩进的空格，因为大多数用户希望保留缩进。如果想要禁用智能折叠，并强制 Dreamweaver 准确折叠所选的内容，您可在折叠代码之前按住 Ctrl 键。

此外，如果片断中包含错误或特定浏览器不支持的代码，Dreamweaver 将会在折叠的代码片断上放置一个警告图标。

注意

依据 Dreamweaver 模板创建的文件将以完全扩展的形式显示所有代码，即使模板文件 (.dwt) 包含折叠的代码片断。

相关主题

  • 折叠和展开代码片断
  • 粘贴和移动折叠代码片断
  • 清理代码
  • 使用编码工具栏迅速插入代码


折叠和展开代码片断

若要折叠代码，请执行以下操作：

  1. 选择一些代码。
  2. 选择“编辑”>“代码折叠”>“折叠所选”，或单击所选代码旁边的折叠按钮。

若要折叠所选代码之外的代码，请执行以下操作：

  1. 在“代码”视图中选择一些代码。
  2. 选择“编辑”>“代码折叠”>“折叠外部所选”。

    提示

    通过在按住 Alt 键 (Windows) 或 Option 键 (Macintosh) 的同时单击其中一个折叠按钮或编码工具栏中的“折叠所选”按钮，您也可以折叠所选代码外部的代码。

若要折叠标签及其包含的所有内容，请执行以下操作：

  1. 在“代码”视图中，将插入点置入开始或结束标签内（例如，在 <table> 或 </table> 标签内）。
  2. 选择“编辑”>“代码折叠”>“折叠完整标签”。

    提示

    您还可通过右键单击标签选择器中的标签并选择“折叠完整标签”来折叠一个完整标签。

若要折叠整个标签之外的代码，请执行以下操作：

  1. 执行下列操作之一：
    • 在“代码”视图中，将插入点置入开始或结束标签内（例如，在 <table> 或 </table> 标签内）。
    • 在“代码”视图中选择开始或结束标签的一部分。
  2. 选择“编辑”>“代码折叠”>“折叠外部完整标签”。

    提示

    还可以通过以下方法来折叠整个标签外部的代码：右键单击标签选择器中的标签，并选择“折叠外部完整标签”，或将插入点放置在开始或结束标签内，然后在按住 Alt 键的同时单击编码工具栏中的“折叠整个标签”按钮。

若要选择折叠的代码片断，请执行以下操作：

  • 在“代码”视图中单击折叠代码片断。

    注意

    当您在“设计”视图中所选择的内容是折叠代码片断的一部分时，Dreamweaver 会自动在“代码”视图中将该片断扩展。当您在“设计”视图中所选择的内容是一个完整的代码片断时，“代码”视图中的片断将保持折叠状态。

若要扩展代码片断：

  • 执行下列操作之一：
    • 在“代码”视图中双击代码片断。
    • 选择“编辑”>“代码折叠”>“扩展所选”。

若要查看折叠代码片断中的代码而不扩展该代码片断，请执行以下操作：

  • 将鼠标指针悬停在折叠代码片断的上方。

若要展开所有折叠代码片断，请执行以下操作：

  • 选择“编辑”>“代码折叠”>“扩展全部”。

也可以使用以下快捷键来执行前面的任何命令：

命令 | Windows | Macintosh
折叠所选 | Ctrl+Shift+C | Command+Shift+C
折叠外部所选 | Ctrl+Alt+C | Command+Alt+C
扩展所选 | Ctrl+Shift+E | Command+Shift+E
折叠完整标签 | Ctrl+Shift+J | Command+Shift+J
折叠外部完整标签 | Ctrl+Alt+J | Command+Alt+J
扩展全部 | Ctrl+Alt+E | Command+Alt+E

相关主题

  • 关于折叠代码
  • 粘贴和移动折叠代码片断
  • 清理代码
  • 使用编码工具栏迅速插入代码


粘贴和移动折叠代码片断

若要复制并粘贴折叠代码片断，请执行以下操作：

  1. 选择折叠代码片断。
  2. 选择“编辑”>“复制”。
  3. 将插入点放在要粘贴代码的地方。
  4. 选择“编辑”>“粘贴”。

    注意

    可以粘贴到其他应用程序中，但代码片断的折叠状态将不会被保留。

若要拖动折叠代码片断，请执行以下操作：

  1. 选择折叠代码片断。
  2. 将所选内容拖动到新位置上。

    提示

    若要拖动所选内容的副本，请按住 Ctrl 键拖动 (Windows) 或按住 Alt 键拖动 (Macintosh)。

    注意

    不可拖动到其他文档。

相关主题

  • 关于折叠代码
  • 折叠和展开代码片断
  • 清理代码
  • 使用编码工具栏迅速插入代码


缩进代码块

在“代码”视图中或代码检查器中编写和编辑代码时，您可以更改所选的代码块或代码行的缩进级别，方法是以制表符为单位向右或向左移动它们。

若要缩进所选的代码块，请执行以下操作之一：

  • 按 Tab 键。
  • 选择“编辑”>“缩进代码”。

若要取消所选的代码块的缩进，请执行以下操作之一：

  • 按 Shift+Tab 键。
  • 选择“编辑”>“凸出代码”。

相关主题

  • 对代码的选定内容进行快速更改
  • 设置代码格式首选参数选项


复制和粘贴代码

您可以从另一个应用程序或从“代码”视图本身复制并粘贴代码。

若要将代码作为文本复制和粘贴，请执行以下操作：

  1. 从 Dreamweaver 或其它应用程序中复制代码。
  2. 将插入点直接置于“代码”视图中，然后选择“编辑”>“粘贴”。

相关主题

  • 粘贴和移动折叠代码片断


插入 HTML 注释

注释是您在 HTML 代码中插入的描述性文本，用来解释该代码或提供其它信息。注释文本只在“代码”视图中出现，不会显示在浏览器中。

若要在插入点插入注释，请执行以下操作：

  • 选择“插入”>“注释”。

    Dreamweaver 在“代码”视图中插入一个注释标签并且将插入点放在标签的中间。请键入您的注释。

    在“设计”视图中，Dreamweaver 显示“注释”对话框。键入您的注释，然后单击“确定”。

若要在“设计”视图中显示注释标记，请执行以下操作：

  • 选择“查看”>“可视化助理”>“不可见元素”。

    确保在“不可见元素”首选参数中选择了“注释”选项，否则将不出现注释标记。

若要编辑现有注释，请执行下列操作之一：

  • 在“设计”视图中选择“注释”标记，并且在属性检查器中编辑注释文本。
  • 在“代码”视图中查找注释并且编辑它的文本。


跳转到 JavaScript 或 VBScript 函数

在“代码”视图和代码检查器中，您都可以查看代码中所有 JavaScript 或 VBScript 函数的列表，并跳转到其中的任意函数。

若要跳转到代码中的某个 JavaScript 或 VBScript 函数，请执行以下操作：

  1. 在“代码”视图（“查看”>“代码”）或代码检查器（“窗口”>“代码检查器”）中查看文档。
  2. 执行下列操作之一：
    • 如果使用“代码”视图，请右键单击 (Windows) 或按住 Control 键单击 (Macintosh)“代码”视图中的任何位置，然后从上下文菜单中选择“函数”子菜单。

      注意

      “设计”视图中不显示“函数”子菜单。

      如果您的代码包含 JavaScript 或 VBScript 函数，则它们将出现在该子菜单中。

      提示

      若要以字母顺序查看列出的函数，请在“代码”视图中按住 Ctrl 键右键单击 (Windows) 或按住 Option 和 Control 键单击 (Macintosh)，然后选择“函数”子菜单。
    • 如果使用代码检查器，请单击工具栏上的“代码导航”按钮。

      该按钮由一对大括号 ({ }) 组成。

  3. 从子菜单中，选择某个函数名称以跳转到代码中的该函数。


搜索和替换标签和属性

您可以使用 Dreamweaver 搜索并替换代码中的标签和属性。

本节包含以下主题：

  • 搜索包含在特定标签内的标签、属性或文本
  • 保存搜索模式

相关主题

  • 正则表达式
  • 搜索和替换文本
  • 比较文件的差别


搜索包含在特定标签内的标签、属性或文本

您可以搜索特定的标签、属性和属性值。例如，您可以搜索不带 alt 属性的所有 img 标签。

您也可以搜索在一组标签区块内或不在一组标签区块内的特定文本字符串。例如，您可以搜索包含在 title 标签内的单词 Untitled，以找到您的站点上的所有无标题页。

若要在代码中查找标签、属性或文本，请执行以下操作：

  1. 打开要在其中搜索内容的文档，或在“文件”面板中选择文档或文件夹。
  2. 选择“编辑”>“查找和替换”。

    出现“查找和替换”对话框。

  3. 指定要在其中搜索内容的文件，然后指定要执行的搜索类型以及要搜索的文本或标签。此外，还可以指定替换文本。然后单击某个“查找”按钮或“替换”按钮。

    有关更多信息，请参见设置“查找和替换”对话框选项。

  4. 完成后，单击“关闭”按钮退出该对话框。

若要再次搜索而不显示“查找和替换”对话框，请执行以下操作：

  • 按 F3 键 (Windows) 或 Command+G 组合键 (Macintosh)。

相关主题

  • 保存搜索模式
  • 正则表达式


保存搜索模式

可以保存搜索模式并在以后重复使用。

若要保存搜索模式，请执行以下操作：

  1. 在“查找和替换”对话框（“编辑”>“查找和替换”）中，设置搜索参数。

    如果您执行标签或高级文本搜索，请参见搜索包含在特定标签内的标签、属性或文本，了解有关设置附加搜索参数的信息。

  2. 单击“保存查询”按钮（磁盘图标）。
  3. 在出现的对话框中，定位到要用来保存查询的文件夹。然后键入一个文件名来标识该查询并单击“保存”。

    例如，如果搜索模式涉及查找不带 alt 属性的 img 标签，则您可以将该查询命名为 img_no_alt.dwr。

    注意

    保存的查询具有 .dwr 文件扩展名。一些用旧版本 Dreamweaver 保存的查询的扩展名可能是 .dwq。

若要重新调用一个搜索模式，请执行以下操作：

  1. 选择“编辑”>“查找和替换”。
  2. 单击“装载查询”按钮（文件夹图标）。
  3. 定位到保存您的查询的文件夹。然后选择一个查询文件，并单击“打开”。
  4. 单击“查找下一个”、“查找全部”、“替换”或“全部替换”可以启动搜索。

相关主题

  • 搜索包含在特定标签内的标签、属性或文本
  • 正则表达式


对代码的选定内容进行快速更改

您可以选择代码然后使用上下文菜单对它进行快速更改。

若要对选定的代码进行快速更改，请执行以下操作：

  1. 在“代码”视图中，选择一些代码然后右键单击 (Windows) 或按住 Control 键单击 (Macintosh)。在上下文菜单中，选择“选定内容”子菜单。
  2. 从子菜单中选择以下选项之一：

    注释掉行在选定行的周围添加注释标签。如果选择了某行的一部分，整个行都会被注释掉。在调试页面的时候，您可以使用这个工具来注释掉有可能不正确的代码。

    取消行注释从注释掉的选定内容的每一行的开始和结束位置删除注释标记。它仅作用于整个行，而不是行内的注释。

    将制表符转换成空格将选定内容中的每一制表符转换成与“代码格式”首选参数中设置的“制表符大小”相等的空格数。有关更多信息，请参见设置代码格式设置首选参数。

    将空格转换成制表符将选定内容中的空格串转换成制表符。具有与制表符大小相等的空格数的每一串空格被转换成一个制表符。

    缩进缩进选定内容，将其向右移动。有关缩进和凸出的更多信息，请参见缩进代码块。

    凸出将选定内容向左移动。

    删除所有标签删除选定内容中的所有标签。

    将行转换成表用不带属性的 table 标签来环绕选定的内容。

    添加换行符在选定内容的每行末尾添加 br 标签。

    转换成大写将选定内容（包括标签和属性的名称和值）中的所有字母转换成大写。

    转换成小写将选定内容（包括标签和属性的名称和值）中的所有字母转换成小写。

    将标签转换成大写将选定内容中的所有标签和属性名称及属性值转换成大写。

    将标签转换成小写将选定内容中的所有标签和属性名称及属性值转换成小写。


使用语言参考资料

“参考”面板为您提供了标记语言、编程语言和 CSS 样式的快速参考工具。它提供了有关您在“代码”视图（或代码检查器）中处理的特定标签、对象和样式的信息。“参考”面板还提供了可粘贴到文档中的示例代码。

若要打开“参考”面板，请执行以下操作：

  1. 在“代码”视图中执行以下操作之一：
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 一个标签、属性或关键字，然后从上下文菜单中选择“参考”。
    • 将插入点放在标签、属性或关键字中，然后按 Shift+F1。

    “参考”面板打开并显示与您所单击的标签、属性或关键字有关的信息。

  2. 若要调整“参考”面板中文本的大小，请从选项菜单（面板右上角的小箭头）中选择“大字体”、“中等字体”或“小字体”。

若要将示例代码粘贴到文档中，请执行以下操作：

  1. 在参考内容的示例代码中的任意位置单击。

    Dreamweaver 将高亮显示整个代码示例。

  2. 选择“编辑”>“复制”，然后将示例代码粘贴到“代码”视图内的文档中。

若要浏览参考内容，请执行以下操作：

  1. 若要显示来自其它书籍的标签、对象或样式，请从“书籍”弹出菜单中选择不同的书籍。
  2. 若要查看有关某个具体项目的信息，请从“标签”、“对象”、“样式”或“CFML”弹出式菜单（取决于选中了哪种书籍）中选择该项目。
  3. 若要查看有关所选项目某个属性的信息，请从“标签”、“对象”、“样式”或“CFML”弹出式菜单旁边的弹出式菜单中选择该属性。

    该菜单包含您选择的项目的属性列表。默认选择是“Description”，它显示所选项目的说明。


打印代码

可以打印代码以用于脱机编辑、存档或分发。

若要打印代码，请执行以下操作：

  1. 在“代码”视图中打开一个页面。
  2. 选择“文件”>“打印代码”。
  3. 指定打印选项，然后单击“确定”(Windows) 或“打印”(Macintosh)。


参考资料

本节提供有关本章中介绍的以下面板和对话框的信息：

  • 设置“代码片断”对话框选项
  • 设置“注释”对话框选项
  • 设置注释属性检查器选项
  • 设置“标签选择器”对话框选项


设置“代码片断”对话框选项

此对话框用于为“代码片断”面板创建或编辑代码片断。

若要创建或编辑代码片断，请执行以下操作：

  1. 在“名称”文本框中，输入代码片断的名称。

    注意

    代码片断名称不能包含在文件名中无效的字符，如斜杠（/ 或 \）、特殊字符或双引号 (“)。
  2. （可选）在“描述”文本框中，输入代码片断的描述性文本。描述性文本可以使其他小组成员更易于使用代码片断。
  3. 对于“代码片断类型”，选择“环绕选定内容”或“插入块”。
  4. 如果您选择“环绕选定内容”，请将代码添加到下面的文本框中：

    前插入键入或粘贴要在当前选定内容前插入的代码。

    后插入键入或粘贴要在当前选定内容后插入的代码。

    若要设置块的默认间距，请使用换行符；在文本框内按 Enter (Windows) 键或按 Return 键 (Macintosh)。

    注意

    由于代码片断只能作为开始块和结束块创建，因此可以使用它们环绕其它标签和内容。这十分适用于插入特殊格式、链接、导航元素和脚本块。只需高亮显示您要环绕的内容，然后插入代码片断。
  5. 如果您选择“插入块”，则通过键入或粘贴您的代码来插入。
  6. （可选）若要选择一种“预览类型”，请执行以下操作：“代码”或“设计”。

    如果您选择“设计”，Dreamweaver 呈现代码并在“代码片断”面板的“预览”窗格中向您显示它。如果您选择“代码”，则 Dreamweaver 在“预览”窗格中显示代码。

  7. 单击“确定”。

相关主题

  • 使用代码片断


设置“注释”对话框选项

此对话框用于在“设计”视图中将 HTML 注释输入到页面中。

若要输入 HTML 注释，请执行以下操作：

  • 输入注释并单击“确定”。

相关主题

  • 插入 HTML 注释


设置注释属性检查器选项

此属性检查器用于修改页面中的 HTML 注释。

若要修改 HTML 注释，请执行以下操作：

  • 编辑注释文本，然后在“文档”窗口中单击。

相关主题

  • 插入 HTML 注释


设置“标签选择器”对话框选项

此对话框用于选择和插入标签。

若要使用标签选择器插入标签，请执行以下操作：

  1. 左窗格包含支持的标签库的列表，右窗格显示选定标签库文件夹中的单独的标签。
  2. 在左窗格展开标签库。
  3. 从标签库选择标签类别，或者展开该类别并选择一个子类别。
  4. 从右窗格中选择一个标签。
  5. 若要在“标签选择器”中查看该标签的语法和用法信息，则单击“标签信息”按钮。

    如果有可用信息，会显示关于该标签的信息。

  6. 若要在“参考”面板中查看该标签的相同信息，请单击 <?> 图标。

    如果有可用信息，会显示关于该标签的信息。

  7. 若要将选定标签插入代码中，请单击“插入”。

    如果该标签出现在右窗格中并带有尖括号（例如，<title></title>），那么它不会要求其它信息就立即插入到文档的插入点。

    如果该标签不要求其它信息，则会出现标签编辑器。

  8. 如果标签编辑器打开，则输入附加信息并单击“确定”。
  9. 若要关闭“标签选择器”，请单击“关闭”按钮。

相关主题

  • 使用标签编辑器编辑标签


优化和调试代码

您可以使用 Macromedia Dreamweaver 8 来优化和调试代码。例如，您可以验证标签、使文档符合 XHTML 标准，或调试 Macromedia ColdFusion 代码。

本章包含以下主题：

清理代码

验证标签和括号是否对称

检查浏览器的兼容性

验证标签

使页符合 XHTML

使用 ColdFusion 调试器（仅限 Windows）


清理代码

Dreamweaver 可以自动删除空标签，合并嵌套 font 标签，以及通过其它方法改善杂乱或不可读的 HTML 或 XHTML 代码。

有关如何清理从 Microsoft Word 文档生成的 HTML 的信息，请参见打开现有文档。

若要清理代码，请执行以下操作：

  1. 打开一个文档：
    • 如果该文档为 HTML 格式，请选择“命令”>“清理 HTML”。
    • 如果该文档为 XHTML 格式，请选择“命令”>“清理 XHTML”。

      对于 XHTML 文档，“清理 XHTML”命令可以修正 XHTML 的语法错误、将标签属性的大小写特性设置为小写，并且，除了执行 HTML 清理操作外，还可以添加或报告标签所缺少的必需属性。

  2. 在出现的对话框中，选择任一选项。

    有关更多信息，请参见设置“清理 HTML”对话框选项。

  3. 单击“确定”。

    根据文档大小和所选选项数目的不同，可能需要几秒钟完成清理。

相关主题

  • 设置代码格式设置首选参数
  • 设置“代码颜色”首选参数


验证标签和括号是否对称

您可以检查以确保页面上的圆括号 (( ))、大括弧 ({ }) 和方括号 ([ ]) 是对称的。对称的意思是每个开始的标签、圆括号、大括号和方括号有相应的结束部分，反之亦然。

若要检查标签是否对称，请执行以下操作：

  1. 在“代码”视图中打开该文档。
  2. 将插入点放在嵌套代码中要进行检查的地方。
  3. 选择“编辑”>“选择父标签”。

    在代码中选中两侧的匹配标签（以及它们之间的内容）。如果您继续选择“编辑”>“选择父标签”且您的标签已对称，则 Dreamweaver 最终将选择最外面的 html 和 /html 标签。

若要检查圆括号、大括弧和方括号是否对称，请执行以下操作：

  1. 在“代码”视图中打开该文档。
  2. 将插入点放在代码中要进行检查的地方。
  3. 选择“编辑”>“平衡大括弧”。

    此时将选中包含在圆括号、大括弧和方括号之间的所有代码。再次选择“编辑”>“平衡大括弧”，选中在新选择的内容中包含在圆括号、大括号和方括号之间的所有代码。


检查浏览器的兼容性

Dreamweaver 使您能够使用由所有主要图形浏览器支持的元素（例如图像和文本）以及只有较新浏览器支持的元素（例如 CSS 样式）来创建 Web 页。

您应该确定站点面向的会是哪些用户，以及用户可能使用的浏览器。如果大多数用户使用 Netscape 4 浏览器（例如，这种情况在一些学术 Intranet 环境下仍然存在），您应该避免使用此浏览器所不支持的标签。

“检查目标浏览器”功能对文档中的代码进行测试，检查是否存在目标浏览器所不支持的任何标签、属性、CSS 属性和 CSS 值。此检查对文档不作任何方式的更改。

目标浏览器检查可提供有关三个级别的潜在问题的信息：错误、警告和告知性信息。下面的说明将解释这三个级别之间的差别：

  • 错误表示代码可能在特定浏览器中导致严重的、可见的问题，例如导致页面的某些部分消失。（某些情况下，具有未知效果的代码也标记为错误。）
  • 警告表示一段代码将不能在特定浏览器中正确显示，但不会导致任何严重的显示问题。
  • 告知性信息表示代码在特定浏览器中不受支持，但没有可见的影响；例如，img 标签的 galleryimg 属性在一些浏览器中不受支持，但那些浏览器会忽略该属性，所以它不会有任何可见的影响。

默认情况下，每当打开一个文档时，Dreamweaver 自动执行目标浏览器检查。可在文档、文件夹或整个站点上运行手动目标浏览器检查。

注意

目标浏览器检查不会连续更新。更改代码后，手动运行目标浏览器检查，以确认您已经去除了不可用于目标浏览器的代码。

目标浏览器检查并不检查站点中的脚本。另外，目标浏览器检查并不是一个语法验证程序，它仅检测目标浏览器不支持的标记。

注意

“检查目标浏览器”功能使用所谓的“浏览器配置文件”的文本文件来确定特定浏览器所支持的标签。有关如何修改现有配置文件或创建新配置文件的信息，请参见位于 www.macromedia.com/go/dreamweaver_support_cn 上的“自定义 Dreamweaver”。

若要选择 Dreamweaver 将进行检查的浏览器，请执行以下操作：

  1. 在“文档”工具栏中的“目标浏览器检查”菜单中选择“设置”。 这是所描述的功能的图片。

    出现“目标浏览器”对话框。

  2. 选择每个您要检查的浏览器旁边的复选框。
  3. 对于每个选定的浏览器，从相应的弹出菜单中选择要检查的浏览器的最低版本。

    例如，若要验证 Microsoft Internet Explorer 3.0 及其更高版本和 Netscape Navigator 4.0 及其更高版本是否支持文档中的所有标记，请选择位于这些浏览器名称旁边的复选框，然后，从 Microsoft Internet Explorer 弹出菜单中选择 3.0，从 Netscape Navigator 弹出菜单中选择 4.0。

若要查看目标浏览器自动检查的结果，请执行以下操作之一：

  • 在“代码”视图中，打开并查看文件（“查看”>“代码”或“查看”>“代码和设计”）。
  • 在“代码”视图中进行更改后，请在属性检查器中单击“刷新”按钮或按 F5 键。

对于每个在其中一个目标浏览器中被认为是错误的项目，其名称下面都将显示红色波浪下划线。（警告和告知性信息不会在“代码”视图中标记出来，若要查看警告和告知性信息，请查看针对整个文档的报告。）如果 Dreamweaver 没有发现不支持的标记，则不会出现下划线，并且“文档”工具栏的“目标浏览器检查”菜单图标将出现变化，提示没有错误。

提示

若要简便地使用与目标浏览器检查有关的各种命令，请通过右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 任一带有红色下划线的项目从上下文菜单中选择一个命令。

若要检查有哪些浏览器不支持某个特定的有红色下划线的项目，请执行以下操作：

  • 将鼠标指针指向带有红色下划线的文本。

此时会出现工具提示，指示有哪些浏览器不支持该项目。

若要查看整篇文档的“检查目标浏览器”报告，请执行以下操作：

  • 在“文档”工具栏的“目标浏览器检查”菜单中，选择“显示所有错误”。

此时会出现“结果”面板组，其中“目标浏览器检查”面板已被选中。错误以红色惊叹号图标标记，警告以黄色惊叹号图标标记，告知性信息以文字气球图标标记。

若要在“目标浏览器检查”面板上查看一条较长的错误信息，请执行以下操作：

  1. 打开“目标浏览器检查”面板。
  2. 选择一条过长的不能在面板中阅读的错误信息。
  3. 单击“更多信息”按钮。 这是所描述的功能的图片。

此时会出现“描述”对话框，显示选定错误信息的完整文本。

若要禁用自动目标浏览器检查，请执行以下操作：

  • 从“文档”工具栏上的“目标浏览器检查”菜单中，取消选择“打开时自动检查”。

若要跳转到代码中的下一个或上一个错误，请执行以下操作：

  • 在“文档”工具栏上的“目标浏览器检查”菜单中选择“下一个错误”或“上一个错误”。

若要从“目标浏览器检查”面板中跳转到某个特定的错误，请执行以下操作：

  • 双击该错误信息。

在“代码”视图中将选中不支持的标记。

若要在当前文件中手动运行目标浏览器检查，请执行以下操作：

  • 选择“文件”>“检查页”>“检查目标浏览器”。

报告将显示在“目标浏览器检查”面板（在“结果”面板组中）中。

若要在站点上或一组选定的文件上手动运行目标浏览器检查，请执行以下操作：

  1. 在“文件”面板上的“本地”视图中，选择一组文件或包含整个站点的文件夹。
  2. 选择“文件”>“检查页”>“检查目标浏览器”。

    报告将显示在“目标浏览器检查”面板（在“结果”面板组中）中。

  3. 若要取消正在运行的报告，请单击位于“目标浏览器检查”面板上的“停止”按钮。

若要在查看当前文档报告和查看整个站点报告之间进行切换，请执行以下操作：

  • 在“目标浏览器检查”面板中，从弹出菜单中选择“当前文档”或“站点报告”。

若要保存目标浏览器检查报告，请执行以下操作：

  • 在“目标浏览器检查”面板中单击“保存报告”按钮。

    注意

    目标浏览器检查报告并不是自动保存的，如果您想保留一份副本作为以后的参考，请保存该报告。

若要在浏览器中查看目标浏览器检查报告，请执行以下操作：

  • 在“目标浏览器检查”面板中单击“浏览报告”按钮。

若要修正错误，请执行以下操作：

  • 删除不支持的代码，或将它更改成目标浏览器能够支持的其它代码。

若要指定 Dreamweaver 应忽略特定类型的错误，请执行以下操作：

  • 右键单击 (Windows) 或者按住 Control 键单击 (Macintosh) 标有红色下划线的代码，然后从上下文菜单中选择“忽略错误”。

该类型的错误即更改为警告，Dreamweaver 将在所有文档中停止对该类型的错误标记下划线。

相关主题

  • 验证标签


验证标签

您可以使用 Dreamweaver 查明代码是否存在标签错误或语法错误。Dreamweaver 可以对多种语言（包括 HTML、XHTML、ColdFusion Markup Language (CFML)、JavaServer Pages (JSP)、Wireless Markup Language (WML) 和 XML）的文档进行验证。

注意

要对文档进行辅助功能验证，请参见测试站点。

您可以验证当前文档或选定的标签。

若要验证标签，请执行以下操作：

  1. 执行下列操作之一：
    • 对于 XML（或 XHTML）文件，选择“文件”>“检查页”>“验证为 XML”。
    • 否则，选择“文件”>“检查页”>“验证标记”。

    “结果”面板的“验证”选项卡将显示“没有错误或警告”消息，或者列出找到的语法错误。

  2. 双击某一错误信息可将此错误在文档中高亮显示。
  3. 若要将此报告保存为 XML 文件，请单击“保存报告”按钮。
  4. 若要在主浏览器（该浏览器允许您打印报告）中查看报告，请单击“浏览报告”按钮。

您可以设置该验证程序的首选参数，例如指定该验证程序应依据哪些基于标签的语言来进行检查、该验证程序应检查哪些特定问题以及该验证程序应报告哪些类型的错误。有关更多信息，请参见设置验证程序首选参数。

相关主题

  • 检查浏览器的兼容性


使页符合 XHTML

当您创建新页时，您可以使该页符合 XHTML。您还可以使现有的 HTML 文档符合 XHTML。

若要新建符合 XHTML 的文档，请执行以下操作：

  1. 选择“文件”>“新建”。

    即出现“新建文档”对话框。

  2. 选择要创建的页面的类别和类型。
  3. 从“文档类型 (DTD)”弹出式菜单中选择一种 XHTML 文档类型定义 (DTD)。

    例如，可从弹出式菜单中选择“XHTML 1.0 Transitional”或“XHTML 1.0 Strict”，使 HTML 文档与 XHTML 兼容。

    注意

    不是所有的文档类型都可以使之符合 XHTML。
  4. 单击“确定”。

若要以默认方式创建符合 XHTML 的文档，请执行以下操作：

  1. 选择“编辑”>“首选参数”或 Dreamweaver>“首选参数”(Mac OS X)，然后选择“新建文档”类别。
  2. 在“新建文档”类别中，选择默认文档并从“默认文档类型 (DTD)”弹出式菜单中选择一种 XHTML 文档类型定义 (DTD)。

    例如，可从弹出式菜单中选择“XHTML 1.0 Transitional”或“XHTML 1.0 Strict”，使 HTML 文档与 XHTML 兼容。

  3. 单击“确定”。

若要使现有 HTML 文档符合 XHTML，请执行以下操作：

  • 打开文档，然后执行下列操作之一：
    • 对于不含框架的文档，请选择“文件”>“转换”，然后选择一种 XHTML 文档类型定义。

      例如，可从弹出式菜单中选择“XHTML 1.0 Transitional”或“XHTML 1.0 Strict”，使 HTML 文档与 XHTML 兼容。

    • 对于含框架的文档，请选择框架并选择“文件”>“转换”，然后选择一种 XHTML 文档类型定义。

      若要转换整个文档，请对每个框架以及框架页文档重复此步骤。

      注意

      您不能转换模板的实例，因为模板的实例必须与它所基于的模板使用相同的语言。例如，基于 XHTML 模板的文档将始终是 XHTML，基于不符合 XHTML 的 HTML 模板的文档将始终是 HTML，并且不能把它转换为 XHTML 或其它语言。

相关主题

  • 关于由 Dreamweaver 生成的 XHTML 代码


使用 ColdFusion 调试器（仅限 Windows）

如果您是将 Macromedia ColdFusion 用作 Dreamweaver 测试服务器的 ColdFusion 开发人员，则无需退出 Dreamweaver 即可查看 ColdFusion 的调试信息。

注意

Macintosh 不支持此功能。Macintosh 开发人员可以使用“在浏览器中预览”(F12) 在另外一个浏览器中打开 ColdFusion 页。如果该页包含错误，有关错误可能原因的信息将出现在该页的底部。

如果您在运行 ColdFusion MX 6.1 或更早期的版本，请在开始调试前确保已经在“ColdFusion 管理员”中启用调试设置。有关更多信息，请参见“使用 Dreamweaver” 中的 ColdFusion 文档（“帮助”>“使用 ColdFusion”）。如果您在运行 ColdFusion MX 7 或更高版本，Dreamweaver 会为您启用设置。

另外，请确保您的 Dreamweaver 测试服务器正在运行 ColdFusion。有关 Dreamweaver 测试服务器的更多信息，请参见指定可在哪里处理动态页。

提示

为了确保每次在内部浏览器中显示页时都刷新调试信息，请确保 Internet Explorer 将在每次请求文件时检查该文件的较新版本。在 Internet Explorer 中，选择“工具”>“Internet 选项”，选择“常规”选项卡，然后单击“Internet 临时文件”区域中的“设置”按钮。在“设置”对话框中，选择“每次访问此页时检查”选项。

若要调试 ColdFusion 页，请执行以下操作：

  1. 在 Dreamweaver 中打开该 ColdFusion 页。
  2. 单击“文档”工具栏上的“服务器调试”图标。 这是所描述的功能的图片。

    Dreamweaver 从 ColdFusion 服务器中请求该页，然后在内部的 Internet Explorer 浏览器窗口中显示该文件。如果该页包含错误，错误的可能原因将出现在该页的底部。

    与此同时，“服务器调试”面板打开。该面板提供了大量的有用信息，例如服务器对其进行处理以呈现该页的所有页、在该页上执行的所有 SQL 查询以及所有服务器变量和它们的值（如果有）。该面板还会提供执行时间摘要。

  3. 如果“异常”类别出现在“服务器调试”面板上，则单击加号 (+) 图标扩展该类别。

    如果服务器遇到该页的问题，则“异常”类别会出现。扩展该类别，对问题进行详细了解。

  4. 在“服务器调试”面板的“位置”列中，单击该页的 URL，在“代码”视图中打开该页并修正该页。

    如果 Dreamweaver 可以定位该页，该页将打开，而一个或多个问题行会在该页中高亮显示。如果 Dreamweaver 无法定位该页，它会向您询问其位置。

  5. 修正错误，将文件保存到服务器，然后单击“浏览”。

    Dreamweaver 在内部浏览器中再次呈现该页，并且更新“服务器调试”面板。如果该页不存在其它问题，则“异常”类别将不会重新出现在此面板上。

  6. 若要退出调试模式，请切换到“代码”视图（“查看”>“代码”）或“设计”视图（“查看”>“设计”）。


参考资料

本节提供此章中介绍的有关以下对话框的信息：

  • 设置“清理 HTML”对话框选项


设置“清理 HTML”对话框选项

此对话框的作用是指定 Dreamweaver 应如何清理代码。

若要指定清理选项，请执行以下操作：

  1. 选择以下任一选项：

    删除空标签区块用于删除中间没有内容的所有标签。例如，<b></b> 和 <font color="#FF0000"></font> 是空标签，但 <b>某些文本</b> 中的 <b> 标签则不是空标签。

    删除多余的嵌套标签用于删除所有多余的标签。例如，在代码 <b>This is what I <b>really</b> wanted to say</b> 中，really 一词两侧的 b 标签为多余的标签，将被删除。

    删除非 Dreamweaver HTML 注释用于删除所有不是由 Dreamweaver 插入的注释。例如，<!--begin body text--> 会被删除，但 <!-- TemplateBeginEditable name="doctitle"--> 则不会被删除，因为它是对模板中可编辑区域的开头进行标记的 Dreamweaver 注释。

    删除 Dreamweaver 特殊标记用于删除 Dreamweaver 加到代码中的注释，这些注释允许模板和库项目更新时自动更新文档。如果在基于模板的文档中清除代码时选择此选项，文档将与模板分离。有关更多信息，请参见从模板分离文档。

    删除特殊标签用于删除在邻近文本框中指定的标签。使用此选项可删除由其它可视化编辑器插入的自定义标签以及其它您不希望在站点中出现的标签（例如，blink）。请用逗号分隔多个标签（例如，font,blink）。

    在情况允许下合并嵌套 <font> 标签用于合并两个或多个控制相同范围文本的 font 标签。例如，<font size="7"><font color="#FF0000">big red</font></font> 将被更改为 <font size="7" color="#FF0000">big red</font>。

    完成时显示动作记录在完成清理时显示一个警告框，其中包含有关文档改动的详细信息。

  2. 单击“确定”。


在设计视图中编辑代码

尽管 Macromedia Dreamweaver 8 允许您以可视方式创建和编辑 Web 页面，而无需为基础源代码操心，但有时候您可能需要编辑源代码以更好地控制您的 Web 页面或解决 Web 页面上出现的问题。Dreamweaver 使您可在“设计”视图中工作的同时编辑代码。

本章面向那些喜欢在“设计”视图中工作、但同时也想要快速访问代码的人士。

本章包含以下主题：

使用属性检查器编辑代码

使用标签检查器更改属性

使用快速标签编辑器编辑代码

使用标签选择器编辑代码

编辑脚本

使用 server-side include（服务器端包括）

使用 JavaScript 行为

查看和编辑文件头内容


使用属性检查器编辑代码

您可以使用属性检查器检查并编辑页面上文本或对象的属性。属性检查器中显示的属性通常对应于标签的属性；在属性检查器中更改属性通常与在“代码”视图中更改相应的属性具有相同的效果。

注意

使用标签检查器和属性检查器都可以查看和编辑标签的属性。使用标签检查器可以查看和编辑与给定标签相关的所有属性。属性检查器只显示最常用的属性，但提供更丰富的控件组用于更改那些属性的值，并允许您编辑不对应于特定标签的某些对象（如表格列）。

若要使用属性检查器，请执行以下操作：

  1. 在文本中单击或选择页面上的对象。

    文本或对象的属性检查器显示在文档窗口的下方。如果看不到属性检查器，请选择“窗口”>“属性”。

  2. 在属性检查器中对属性进行更改。

相关主题

  • 使用标签检查器更改属性
  • 使用“属性”检查器


使用标签检查器更改属性

您可以使用标签检查器在属性表（它类似于在其它集成开发环境 (IDE) 中提供的那些属性表）中编辑标签和对象。

注意

使用标签检查器和属性检查器都可以查看和编辑标签的属性。使用选择检查器可以查看和编辑与给定标签相关的所有属性。属性检查器只显示最常用的属性，但提供更丰富的控件组用于更改那些属性的值，并允许您编辑不对应于特定标签的某些对象（如表格列）。

若要使用标签检查器编辑属性，请执行以下操作：

  1. 在“文档”窗口中，执行以下操作之一：
    • 在“代码”视图（或代码检查器）中，单击标签名称或其内容中的任何地方。
    • 在“设计”视图中，选择一个对象，或在标签选择器中选择一个标签。
  2. 打开标签检查器（“窗口”>“标签检查器”），然后选择属性选项卡。

    所选对象的属性及其当前值出现在标签检查器中。

  3. 在标签检查器中执行以下任意操作：
    • 若要查看按类别组织的属性，请单击“显示类别视图”按钮。 这是所描述的功能的图片。
    • 若要在按字母排序的列表中查看属性，请单击“显示列表视图”按钮。 这是所描述的功能的图片。
    • 若要更改属性值，请选择该值并编辑它（请参见下面的过程）。
    • 若要为没有值的属性添加一个属性值，请单击属性右侧的属性值列并添加一个值（请参见下面的过程）。
    • 若要删除一个属性值，请选择该值然后按 Backspace 键 (Windows) 或 Delete 键 (Macintosh)。
    • 若要更改属性的名称，请选择该属性名称然后进行编辑。

      注意

      如果更改了一个标准属性的名称然后为该属性添加了一个值，则该属性及其新值将移到相应的类别中。
    • 若要添加未列出的新属性，请单击列出的最后一个属性名称下方的空白位置，然后键入一个新的属性名称。
  4. 按 Enter 键 (Windows) 或 Return 键 (Macintosh)，或者单击标签检查器中的其它位置，以更新文档中的标签。

若要编辑或添加属性值，请执行下列操作之一：

  • 在属性值列（属性名称的右侧）中为该属性键入一个新的值。
  • 如果该属性采用预定义的值，请从属性值列右侧的弹出菜单（或颜色选择器）中选择一个值。
  • 如果属性采用 URL 值作为属性值，请单击“浏览”按钮或使用“指向文件”图标选择一个文件，或者在文本框中键入 URL。
  • 如果该属性采用来自动态内容来源（如数据库）的值，请单击属性值列右侧 的“动态数据”按钮。然后选择一个来源。 这是所描述的功能的图片。

    有关定义动态内容来源的信息，请参见定义动态内容源。

相关主题

  • 使用属性检查器编辑代码
  • 使用 JavaScript 行为
  • 使用层叠样式表设置文本格式


使用快速标签编辑器编辑代码

您可以使用快速标签编辑器在不退出“设计”视图的情况下快速检查并编辑 HTML 标签。若要打开快速标签编辑器，请按 Ctrl+T 组合键 (Windows) 或 Command+T 组合键 (Macintosh)。有关更多信息，请参见设置快速标签编辑器选项。

本节包含以下主题：

  • 使用快速标签编辑器插入 HTML 标签
  • 使用快速标签编辑器编辑 HTML 标签
  • 使用快速标签编辑器将 HTML 应用于选定内容
  • 在快速标签编辑器中使用提示菜单


使用快速标签编辑器插入 HTML 标签

您可以使用快速标签编辑器在您的文档中插入 HTML 标签。

若要使用快速标签编辑器插入 HTML 标签，请执行以下操作：

  1. 在设计视图中，在页面上单击以将插入点放置于您要插入代码的地方。
  2. 按 Ctrl+T 组合键 (Windows) 或 Command+T 组合键 (Macintosh)。

    快速标签编辑器以“插入 HTML”模式打开。

  3. 输入 HTML 标签并按 Enter 键。

    该标签被插入到代码中，同时还插入相匹配的结束标签（如果适用）。

  4. 按 Esc 键以在不进行任何更改的情况下退出。

相关主题

  • 使用快速标签编辑器编辑 HTML 标签
  • 使用快速标签编辑器将 HTML 应用于选定内容
  • 在快速标签编辑器中使用提示菜单
  • 设置快速标签编辑器选项


使用快速标签编辑器编辑 HTML 标签

您可以使用快速标签编辑器编辑文档中的 HTML 标签。

若要使用快速标签编辑器编辑 HTML 标签，请执行以下操作：

  1. 在设计视图中选择一个对象。

    您还可以从文档窗口底部的标签选择器中选择要编辑的标签。有关更多信息，请参见使用标签选择器编辑代码。

  2. 按 Ctrl+T 组合键 (Windows) 或 Command+T 组合键 (Macintosh)。

    快速标签编辑器以“编辑标签”模式打开。

  3. 输入新属性，编辑现有属性，或者编辑标签的名称。
  4. 按 Tab 键可以从一个属性前移到下一个属性；按 Shift+Tab 组合键可以返回到上一个属性。

    默认情况下，在您按 Tab 键或 Shift+Tab 组合键后更改将被应用于文档。若要禁用自动更新，请选择“编辑”>“首选参数”>“快速标签编辑器”或“Dreamweaver”>“首选参数”>“快速标签编辑器”(Mac OS X)。随即显示快速标签编辑器“首选参数”对话框。取消对“编辑时立即应用更改”选项的选择，然后单击“确定”。

    有关更多信息，请参见设置“脚本”对话框选项。

  5. 若要关闭快速标签编辑器并应用所有更改，请按 Enter 键。
  6. 若要退出且不再进行任何更改，请按 Esc 键。

相关主题

  • 使用快速标签编辑器插入 HTML 标签
  • 使用快速标签编辑器将 HTML 应用于选定内容
  • 在快速标签编辑器中使用提示菜单
  • 设置快速标签编辑器选项


使用快速标签编辑器将 HTML 应用于选定内容

您可以使用快速标签编辑器用开始和结束 HTML 标签环绕当前选定内容。

若要使用快速标签编辑器将 HTML 应用于选定内容，请执行以下操作：

  1. 在设计视图中选择不含格式的文本或对象。

    注意

    如果您选择包括开始或结束 HTML 标签的文本或对象，则快速标签编辑器将以“编辑标签”模式打开，而不以“环绕标签”模式打开。
  2. 按 Ctrl+T 组合键 (Windows) 或 Command+T 组合键 (Macintosh)，或者在属性检查器中单击“快速标签编辑器”按钮。

    快速标签编辑器以“环绕标签”模式打开。

  3. 输入一个开始标签，如 strong，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    该标签被插入到当前选定内容的起始处，并在结尾处插入匹配的结束标签。

  4. 若要退出且不进行任何更改，请按 Escape 键，而不是按 Enter 键。

相关主题

  • 使用快速标签编辑器插入 HTML 标签
  • 使用快速标签编辑器编辑 HTML 标签
  • 在快速标签编辑器中使用提示菜单
  • 设置快速标签编辑器选项


在快速标签编辑器中使用提示菜单

在快速标签编辑器中，您可以访问某个属性的提示菜单，该菜单将列出您正编辑或插入的标签的所有有效属性。

您还可以在快速标签编辑器中禁用提示菜单或调整菜单弹出前的延迟。

若要查看列出标签有效属性的提示菜单，请在快速标签编辑器中编辑属性名称时暂停片刻。随即显示提示菜单，菜单中列出您正编辑的标签的所有有效属性。

类似地，若要查看列出有效标签名称的提示菜单，请在快速标签编辑器中输入或编辑标签名称时暂停片刻。

注意

快速标签编辑器代码提示首选参数由普通代码提示首选参数来控制。有关更多信息，请参见设置代码提示首选参数。

若要使用提示菜单，请执行以下操作：

  1. 执行下列操作之一：
    • 首先键入一个标签或属性名称。“代码提示”菜单中的选定内容将跳转到以您输入的字母开头的第一项。
    • 使用上下箭头键选择一项。
    • 使用滚动条查找一项。
  2. 按 Enter 键插入选定项，或者双击一项以插入它。
  3. 若不插入项即退出提示菜单，请按 Escape 键或继续键入即可。

若要禁用提示菜单或更改提示菜单出现前的延迟，请执行以下操作：

  1. 选择“编辑”>“首选参数”(Windows) 或“Dreamweaver”>“首选参数”(Macintosh)，然后选择“快速标签编辑器”。

    随即显示快速标签编辑器“首选参数”对话框。

  2. 若要禁用提示菜单，请取消对“启用标签提示”选项的选择。
  3. 若要更改菜单出现前的延迟，请调整“延迟”滑块。

    有关更多信息，请参见设置“脚本”对话框选项。

  4. 单击“确定”。

相关主题

  • 设置快速标签编辑器选项
  • 使用快速标签编辑器编辑 HTML 标签


使用标签选择器编辑代码

您可以在不退出设计视图的情况下使用标签选择器选择、编辑或删除标签。标签选择器位于“文档”窗口底部的状态栏中并显示如下所示的一系列标签：

若要编辑一个标签，请执行以下操作：

  1. 在文档中单击。

    在插入点应用的标签显示在标签选择器中。

  2. 在标签选择器中右键单击标签 (Windows) 或在按住 Control 键的同时单击标签 (Macintosh)。

    随即显示一个弹出菜单。

  3. 从该菜单中选择“编辑标签”。

随即出现快速标签编辑器。有关更多信息，请参见使用快速标签编辑器编辑 HTML 标签。

若要删除一个标签，请执行以下操作：

  1. 在文档中单击。

    在插入点应用的标签显示在标签选择器中。

  2. 在标签选择器中右键单击标签 (Windows) 或在按住 Control 键的同时单击标签 (Macintosh)。

    随即显示一个弹出菜单。

  3. 从该菜单中选择“删除标签”。

若要选择对应于某个标签的对象，请执行以下操作：

  1. 在文档中单击。

    在插入点应用的标签显示在标签选择器中。

  2. 在标签选择器中单击一个标签。

由该标签表示的对象在页面上被选定。

提示

使用此方法可以选择单独的表格行（tr 标签）或单元格（td 标签）。


编辑脚本

您可以在“代码”视图和“设计”视图中使用客户端 JavaScript 和 VBScript。

本节包含以下主题：

  • 在“设计”视图中编写客户端脚本
  • 链接到外部脚本文件
  • 在“设计”视图中编辑脚本


在“设计”视图中编写客户端脚本

您可以在不退出设计视图的情况下为您的页面写入 JavaScript 或 VBScript。

在开始之前，请选择“查看”>“可视化助理”>“不可见元素”，以确保页面上显示脚本标签。

若要在设计视图中插入客户端脚本，请执行以下操作：

  1. 将插入点放置于您需要脚本的地方。
  2. 选择“插入”>“脚本对象”>“脚本”。

    随即显示“脚本”对话框。

  3. 完成对话框设置，然后单击“确定”。

    有关更多信息，请参见设置“脚本”对话框选项。

相关主题

  • 链接到外部脚本文件
  • 在“设计”视图中编辑脚本


链接到外部脚本文件

您可以在不退出设计视图的情况下，在您的文档中创建指向外部脚本文件的链接。

在开始之前，请选择“查看”>“可视化助理”>“不可见元素”，以确保页面上显示脚本标签。

若要链接到外部脚本文件，请执行以下操作：

  1. 将插入点放置于您需要脚本的地方。
  2. 选择“插入”>“脚本对象”>“脚本”。

    随即显示“脚本”对话框。

  3. 单击“确定”，不在“内容”框中键入任何内容。
  4. 在文档窗口的设计视图中选择脚本标签。
  5. 在属性检查器中，单击文件夹图标并浏览选择一个外部脚本文件，或在“源文件”框中键入文件名。

相关主题

  • 在“设计”视图中编写客户端脚本
  • 在“设计”视图中编辑脚本


在“设计”视图中编辑脚本

您可以在不退出“设计”视图的情况下编辑脚本。

在开始之前，请选择“查看”>“可视化助理”>“不可见元素”，以确保页面上显示脚本标签。

若要在设计视图中编辑脚本，请执行以下操作：

  1. 选择脚本标签。
  2. 在属性检查器中，单击“编辑”按钮。

    在“脚本属性”对话框中随即出现该脚本。

    如果您链接到外部脚本文件，则该文件在“代码”视图中打开，您可以在其中进行编辑。

    注意

    如果在脚本标签间存在代码，则“脚本属性”对话框将打开，即使还有指向某一外部脚本文件的链接。
  3. 编辑脚本并单击“确定”。

    有关更多信息，请参见设置“脚本属性”对话框选项。

相关主题

  • 在“设计”视图中编写客户端脚本
  • 链接到外部脚本文件


使用 server-side include（服务器端包括）

server-side include（服务器端包括）是对 Web 服务器的指令，它指示 Web 服务器在将页面提供给浏览器前在 Web 页面中包含指定的文件。有关更多信息，请参见 Server-side include（服务器端包括）。

您可以使用 Dreamweaver 在您的页面中插入 server-side include（服务器端包括），编辑 include（包括），或者预览包含 include（包括）的页面。

本节包含以下主题：

  • 插入 server-side include（服务器端包括）
  • 编辑 server-side include（服务器端包括）的内容


插入 server-side include（服务器端包括）

您可以使用 Dreamweaver 在您的页面中插入 server-side include（服务器端包括）。

若要插入 server-side include（服务器端包括），请执行以下操作：

  1. 选择“插入”>“服务器端包括”。
  2. 在显示的对话框中，浏览到并选择一个文件。

    默认情况下，Dreamweaver 会插入 include（包括）的文件类型。

  3. 要更改 include（包括）的类型，请在“文档”窗口中选择 server-side include（服务器端包括），并在属性检查器（“窗口”>“属性”）中更改类型，如下所示：
    • 如果您的服务器是 Apache Web 服务器，则选择“虚拟”。在 Apache 中，“虚拟”可以适用于所有情况，而“文件”只适用于某些情况。
    • 如果您的服务器是 Microsoft Internet Information Server (IIS)，则选择“文件”。（“虚拟”只在某些特定的情况下才可用于 IIS。）

      注意

      但可惜的是，除非在服务器上已安装了特殊的软件，否则 IIS 不允许您包括在文件夹层次结构中高于当前文件夹的文件夹中的文件。如果您需要在 IIS 服务器上包括来自文件夹层次结构中更高层次的文件夹中的文件，请向您的系统管理员咨询以了解是否安装了必需的软件。
    • 对于其它类型的服务器，或者如果您不知道您正使用哪一类型的服务器，请向您的系统管理员咨询要使用的选项。

若要更改所包括的文件，请执行以下操作：

  1. 在文档窗口中选择 server-side include（服务器端包括）。
  2. 打开属性检查器（“窗口”>“属性”）。
  3. 执行下列操作之一：
    • 单击文件夹图标并浏览到要包括的新文件，然后选择该文件。
    • 在文本框中，键入要包括的新文件的路径和文件名。

相关主题

  • Server-side include（服务器端包括）
  • 编辑 server-side include（服务器端包括）的内容


编辑 server-side include（服务器端包括）的内容

您可以使用 Dreamweaver 编辑 server-side include（服务器端包括）。若要编辑与包括的文件关联的内容，您必须打开该文件。

若要编辑 server-side include（服务器端包括），请执行以下操作：

  1. 在“设计”视图或“代码”视图中选择 server-side include（服务器端包括），然后在属性检查器中单击“编辑”。

    包括的文件在新的文档窗口中打开。

  2. 编辑该文件，然后保存它。

    所做更改将立即在当前文档以及您打开的包括该文件的所有随后文档中反映出来。

  3. 如果需要，将包含文件上传到远程站点。

相关主题

  • Server-side include（服务器端包括）
  • 插入 server-side include（服务器端包括）


使用 JavaScript 行为

使用标签检查器的“行为”选项卡可以轻松将 JavaScript（客户端）行为附加到页面元素。有关更多信息，请参见使用 Dreamweaver 自带的行为动作。


查看和编辑文件头内容

可以使用“查看”菜单、“文档”窗口的“代码”视图或代码检查器查看文档的 head 部分中的元素。

若要查看文档的文件头部分的元素，请执行以下操作：

  • 选择“查看”>“文件头内容”。对于 head 内容的每一个元素，“设计”视图中的“文档”窗口顶部都有一个标记。

    注意

    如果“文档”窗口被设置为仅显示“代码”视图，则“查看”>“文件头内容”将灰显。

若要将元素插入文档的文件头部分，请执行以下操作：

  1. 执行下列操作之一：
    • 在“插入”栏的“文件头”类别中，单击对象按钮之一。
    • 从“插入”>“文件头标签”子菜单中选择一项。
  2. 在出现的对话框中或在属性检查器中输入元素的选项。

若要在文档的文件头部分编辑元素，请执行以下操作：

  1. 选择“查看”>“文件头内容”。
  2. 单击 head 部分中的图标之一以选中它。
  3. 在属性检查器中设置或修改元素的属性。

有关特定 head 元素的属性信息，请参见以下主题：

  • 设置 Meta 属性
  • 设置标题属性
  • 设置关键字属性
  • 设置描述属性
  • 设置刷新属性
  • 设置基础属性
  • 设置链接标签的属性


参考资料

本节提供在本章中介绍的以下几个对话框和属性检查器的有关信息：

  • 设置快速标签编辑器选项
  • 设置“脚本”对话框选项
  • 设置“脚本属性”对话框选项
  • 设置脚本属性检查器选项
  • 设置 server-side include（服务器端包括）属性检查器选项
  • 设置 ColdFusion 标签属性检查器选项
  • 设置 ASP 脚本属性检查器选项
  • 设置 Meta 属性
  • 设置标题属性
  • 设置关键字属性
  • 设置描述属性
  • 设置刷新属性
  • 设置基础属性
  • 设置链接标签的属性
  • 设置代码属性
  • 使用“选择子标签”命令


设置快速标签编辑器选项

快速标签编辑器用于在不退出“设计”视图的情况下快速插入并编辑 HTML 标签。

如果您在快速标签编辑器中键入了无效的 HTML，Dreamweaver 将根据需要尝试通过插入结束引号和结束尖括号帮助您修改该 HTML。

若要设置快速标签编辑器选项，请执行以下操作：

  • 按 Ctrl+T 组合键 (Windows) 或 Command+T 组合键 (Macintosh) 打开快速标签编辑器。

快速标签编辑器具有三种模式：

  • “插入 HTML”模式用于插入新的 HTML 代码。
  • “编辑标签”模式用于编辑现有标签。
  • “环绕标签”模式用新标签环绕当前选定内容。

    注意

    快速标签编辑器打开时所采用的模式取决于设计视图中当前的选定内容。

在所有这三种模式中，使用快速标签编辑器的基本过程是相同的：打开编辑器，输入或编辑标签和属性，然后关闭编辑器。

您可以在快速标签编辑器处于活动状态的情况下，通过按 Ctrl+T 组合键 (Windows) 或 Command+T 组合键 (Macintosh) 在不同模式间切换。

相关主题

  • 使用快速标签编辑器插入 HTML 标签
  • 使用快速标签编辑器编辑 HTML 标签
  • 使用快速标签编辑器将 HTML 应用于选定内容
  • 在快速标签编辑器中使用提示菜单


设置“脚本”对话框选项

此对话框用于将客户端脚本插入代码中。

若要插入脚本，请执行以下操作：

  1. 从“语言”弹出菜单中选择脚本撰写语言。

    如果您使用的是 JavaScript 并且不能确定所使用的版本，请选择 JavaScript 而不是 JavaScript1.1 或 JavaScript1.2。

  2. 在“内容”文本框中键入或粘贴您的脚本代码。

    您不需要包括开始和结束 script 标签。

  3. 在“无脚本”文本框中键入或粘贴 HTML 代码。不支持所选脚本语言的浏览器将显示此代码，而不运行脚本。

相关主题

  • 编辑脚本


设置“脚本属性”对话框选项

此对话框用于修改脚本。

若要修改脚本，请执行以下操作：

  1. 在“语言”文本框中，指定 JavaScript 或 VBScript 作为脚本语言。
  2. 在“类型”弹出菜单中，指定脚本的类型，脚本类型可以是客户端也可以是服务器端。
  3. （可选）在“源文件”文本框中，指定外部链接的脚本文件。

    单击文件夹图标或“浏览”按钮选择一个文件，或者键入路径。

  4. 在“脚本”文本框中，编辑您的脚本。
  5. 单击“确定”以应用所做编辑。

相关主题

  • 在“设计”视图中编辑脚本


设置脚本属性检查器选项

此属性检查器用于检查和修改页面上的脚本。

若要更改脚本选项，请执行以下操作：

  1. 从“语言”弹出菜单中选择脚本撰写语言，或者在“语言”文本框中键入语言名称。

    如果您使用的是 JavaScript 并且不能确定所使用的版本，请选择 JavaScript 而不是 JavaScript1.1 或 JavaScript1.2。

  2. 在“类型”弹出菜单中，指定脚本的类型，脚本类型可以是客户端也可以是服务器端。
  3. （可选）在“源文件”文本框中，指定外部链接的脚本文件。

    单击文件夹图标以选择该文件，或者键入路径。

  4. 单击“编辑”以修改脚本。

    有关更多信息，请参见设置“脚本属性”对话框选项。

相关主题

  • 在“设计”视图中编辑脚本


设置 server-side include（服务器端包括）属性检查器选项

此属性检查器用于在“设计”视图中检查和修改 server-side include（服务器端包括）。

若要更改服务器端包括选项，请执行以下操作：

  1. 若要更改在文档中包括的文件，请执行以下操作之一：
    • 单击文件夹图标并浏览到要包括的新文件，然后选择该文件。
    • 在文本框中，键入要包括的新文件的路径和文件名。
  2. 若要编辑 server-side include（服务器端包括），单击“编辑”按钮，在新的文档窗口中编辑打开的文件，然后保存该文件。

    所做更改将立即在当前文档以及您打开的包括该文件的所有随后文档中反映出来。

  3. 若要更改 server-side include（服务器端包括）的类型，请选择“类型”选项，如下所示：
    • 如果您的服务器是 Apache Web 服务器，则选择“虚拟”。在 Apache 中，“虚拟”可以适用于所有情况，而“文件”只适用于某些情况。
    • 如果您的服务器是 Microsoft Internet Information Server (IIS)，则选择“文件”。（“虚拟”只在某些特定的情况下才可用于 IIS。）

      注意

      但可惜的是，除非在服务器上已安装了特殊的软件，否则 IIS 不允许您包括在文件夹层次结构中高于当前文件夹的文件夹中的文件。如果您需要在 IIS 服务器上包括来自文件夹层次结构中更高层次的文件夹中的文件，请向您的系统管理员咨询以了解是否安装了必需的软件。
    • 对于其它类型的服务器，或者如果您不知道您正使用哪一类型的服务器，请向您的系统管理员咨询要使用的选项。

相关主题

  • 插入 server-side include（服务器端包括）
  • 编辑 server-side include（服务器端包括）的内容
  • Server-side include（服务器端包括）


设置 ColdFusion 标签属性检查器选项

此属性检查器用于在“设计”视图中检查和修改 ColdFusion 标记。

若要更改 ColdFusion 代码选项，请执行以下操作：

  1. 单击“属性”按钮以编辑标签的属性或添加新属性。
  2. 如果该标签在其开始标签和结束标签之间有内容，则单击“内容”按钮以编辑该内容。

    只有当选定标签不是空标签时（即，它具有开始标签和结束标签），才显示“内容”按钮。

  3. 如果该标签包含条件表达式，则在“表达式”文本框中对表达式进行更改。


设置 ASP 脚本属性检查器选项

此属性检查器用于在设计视图中检查和修改 ASP 服务器端脚本。

若要更改 ASP 代码选项，请执行以下操作：

  1. 单击“编辑”按钮。
  2. 在显示的对话框中编辑 ASP 服务器端脚本。
  3. 单击“确定”以应用所做编辑。


设置 Meta 属性

meta 标签是记录有关当前页面的信息（如字符编码、作者、版权信息或关键字）的 head 元素。这些标签也可以用来向服务器提供信息，如页面的失效日期、刷新间隔和 PICS 等级。（PICS 是 Internet 内容选择平台，它提供了向 Web 页分配等级（如电影等级）的方法。）

属性指定 Meta 标签是否包含有关页面的描述性信息 (name) 或 HTTP 标题信息 (http-equiv)。

值指定您在该标签中提供的信息类型。有些值（如 description、keywords和refresh）是已经定义好的，而且在 Dreamweaver 中有它们各自的属性检查器，但是您可以根据实际情况指定任何值，例如 creationdate、documentID 或 level 等。

内容是实际的信息。例如，如果为“值”指定了等级，则可以为“内容”指定 beginner、intermediate 或 advanced。


设置标题属性

只有一种标题属性：页面标题。在大多数浏览器中查看页面时，标题会出现在浏览器标题栏和 Dreamweaver“文档”窗口的标题栏中。标题还出现在工具栏中。在“标题”文本框中输入页面标题。


设置关键字属性

许多搜索引擎装置（自动浏览 Web 页为搜索引擎收集信息以编入索引的程序）读取关键字 meta 标签的内容，并使用该信息在它们的数据库中将您的页面编入索引。因为有些搜索引擎限制索引的关键字或字符的数目，或者当超过了限制的数目时，它将忽略所有的关键字，所以最好只使用几个精选的关键字。

在标记为“关键字”的文本框中输入关键字，并以逗号隔开。


设置描述属性

许多搜索引擎装置（自动浏览 Web 页为搜索引擎收集信息以编入索引的程序）读取说明 meta 标签的内容。有些使用该信息在它们的数据库中将您的页面编入索引，而有些还在搜索结果页面中显示该信息（而不只是显示文档的前几行）。有些搜索引擎限制索引字符的数目，所以最好将说明限制在几个字（例如：Pork barbecue catering in Albany, Georgia，或者 web design at reasonable rates for clients worldwide）。

在标记为“说明”的文本框中输入描述性文本。


设置刷新属性

使用刷新元素可以指定浏览器在一定的时间后应该自动刷新页面，方法是重新载入当前页面或转到不同的页面。该元素通常用于在显示了说明 URL 已改变的文本消息后，将用户从一个 URL 重定向到另一个 URL。

延迟是在浏览器刷新页面之前需要等待的时间（以秒为单位）。若要使浏览器在完成载入后立即刷新页面，请在该文本框中输入 0。

动作指定在指定的延迟后，浏览器是转到另一个 URL 还是刷新当前页面。若要打开另一个 URL 而不是刷新当前页面，请单击“浏览”按钮，然后浏览到并选择要载入的页面。


设置基础属性

使用 Base 元素可以设置页面中所有文档相对路径相对的基础 URL。

Href 是基础 URL。单击“浏览”按钮浏览并选择一个文件，或在文本框中输入路径。

目标指定所有链接的文档都应该在其中打开的框架或窗口。在当前的框架页中选择一个框架，或选择下列保留名称之一：

  • _blank 将链接的文档载入一个新的、未命名的浏览器窗口。
  • _parent 将链接的文档载入包含该链接的框架的父框架集或窗口。如果包含链接的框架没有嵌套，则相当于 _top；链接的文档载入整个浏览器窗口。
  • _self 将链接的文档载入链接所在的同一框架或窗口。此目标是默认的，所以通常不需要指定它。
  • _top 将链接的文档载入整个浏览器窗口，从而删除所有框架。


设置链接标签的属性

使用 link 标签可以定义当前文档与其它文件之间的关系。

注意

head 部分中的 link 标签与 body 部分中的文档之间的 HTML 链接是不一样的。

Href 是您正在为其定义关系的文件的 URL。单击“浏览”按钮浏览并选择一个文件，或在文本框中输入路径。注意，该属性并不表示通常的 HTML 意义上的链接文件；链接元素中指定的关系更复杂。

ID 为链接指定一个唯一标识符。

标题描述关系。该属性与链接的样式表有特别的关系；有关更多信息，请参见 WWW 联合会 Web 站点上的 HTML 4.0 规范的“外部样式表”部分，网址为 www.w3.org/TR/REC-html40/present/styles.html#style-external。

Rel 指定当前文档与 Href 文本框中的文档之间的关系。可能的值包括 Alternate、Stylesheet、Start、Next、Prev、Contents、Index、Glossary、Copyright、Chapter、Section、Subsection、Appendix、Help 和 Bookmark。若要指定多个关系，请用空格将各个值隔开。

Rev 指定当前文档与 Href 文本框中的文档之间的相反关系（与 Rel 相对）。可能的值与 Rel 的可能值相同。


设置代码属性

使用此属性检查器可以在不进入“代码”视图的情况下编辑服务器语言标签（如 ASP 标签）中的代码。

编辑显示“编辑内容”对话框，可在该对话框中编辑标签的内容。编辑完成后，单击“确定”。

相关主题

设置 Web 应用程序


使用“选择子标签”命令

“选择子标签”命令（“编辑”>“选择子标签”）让您能以可视方式选择子标签。

如果您在“设计”视图中选择了一个包含子标签的对象（例如 HTML 表格），您可通过选择“编辑”>“选择子标签”快速选择该对象的第一个子标签。

注意

此命令只有在“设计”视图中才能启用。

例如，<table> 标签通常有 <tr> 子标签。如果您在标签选择器中选择 <table> 标签，您可通过选择“编辑”>“选择子标签”选择表格中的第一行。Dreamweaver 在标签选择器中选择第一个 <tr> 标签。由于 <tr> 标签自身有子标签，即<td> 标签，选择“编辑”>“选择子标签”会再次选择表格中的第一个单元格。


准备建立动态站点

如果您计划建立动态 Web 应用程序，可以从设置应用程序服务器和进行数据库连接开始着手。

此部分包含以下各章：

设置 Web 应用程序

ColdFusion 开发人员的数据库连接

ASP.NET 开发人员的数据库连接

ASP 开发人员的数据库连接

用于 JSP 开发人员的数据库连接

适用于 PHP 开发人员的数据库连接

数据库连接答疑


设置 Web 应用程序

本章介绍如何配置您的系统以在 Macromedia Dreamweaver 8 中生成 Web 应用程序。

本章包含下列章节：

生成 Web 应用程序所需软件

设置 Web 服务器

设置应用程序服务器

为应用程序创建根文件夹

定义 Dreamweaver 站点

连接到数据库


生成 Web 应用程序所需软件

若要在 Dreamweaver 中生成 Web 应用程序，您需要以下软件：

  • Web 服务器（请参见设置 Web 服务器）
  • 运行在 Web 服务器上的应用程序服务器（请参见设置应用程序服务器）

    注意

    在涉及 Web 应用程序的环境中，Web 服务器和应用程序服务器这两个术语均指的是软件，而非硬件。

如果您想要将数据库与应用程序一起使用，还需要以下软件：

  • 数据库系统
  • 支持您的数据库的数据库驱动程序

有关为 Web 应用程序设置数据库的信息，请参见连接到数据库。

有一些网页寄存公司可为您提供服务计划，使您能够利用他们的软件来测试并部署 Web 应用程序。在某些情况下，您可以出于开发目的在 Dreamweaver 所在的同一台计算机上安装所需的软件。您还可以在网络计算机（通常是 Windows 2000 或 XP 计算机）上安装软件，以使小组中的其他开发人员能够处理项目。


设置 Web 服务器

若要运行 Web 应用程序，您需要 Web 服务器。Web 服务器是根据 Web 浏览器的请求提供文件服务的软件。Web 服务器有时也叫做 HTTP 服务器。常见 Web 服务器包括 Microsoft Internet Information Server (IIS)、Netscape Enterprise Server、Sun ONE Web Server 和 Apache HTTP Server。

如果您没有使用虚拟主机服务，则选择一个 Web 服务器并在您的本地计算机或远程计算机上安装它。要开发 ColdFusion Web 应用程序的 Windows 用户可以使用 ColdFusion MX 7 应用程序服务器的开发人员版本提供的 Web 服务器，您可以免费安装并使用。有关更多信息，请参见安装 ColdFusion 应用程序服务器。

其他 Windows 用户可以通过安装 IIS 在其本地计算机上运行 Web 服务器。该 Web 服务器可能已安装在系统上。请检查文件夹结构中是否包含一个 C:\Inetpub 或 D:\Inetpub 文件夹。IIS 在安装过程中将创建该文件夹。如果要安装 IIS，请参见“Dreamweaver 入门”中的安装 Web 服务器。

ASP.NET 页仅使用一个 Web 服务器：Microsoft IIS 5 或更高版本。因为 IIS 5 是 Windows 2000 和 Windows XP Professional 操作系统提供的服务，所以您可以使用这两个版本的 Windows 来承载 ASP.NET 应用程序。但是，您可以在运行 Dreamweaver 的任何计算机（包括 Macintosh）上开发（而不是承载）ASP.NET 应用程序。

如果您是 Macintosh 用户，则您可以使用虚拟主机服务或在远程计算机上安装所需的软件。还可以使用随操作系统一起安装的 Apache Web 服务器和 PHP 应用程序服务器在本地开发 PHP 站点。有关更多信息，请参见安装 PHP 应用程序服务器。

有关安装和配置其它 Web 服务器的信息，请参见服务器供应商的文档或向您的系统管理员咨询。


设置应用程序服务器

若要运行 Web 应用程序，您的 Web 服务器需要使用应用程序服务器。应用程序服务器是一种软件，用来帮助 Web 服务器处理动态页。

本节包含下列主题：

  • 选择应用程序服务器
  • 安装 ColdFusion 应用程序服务器
  • 安装 ASP.NET 应用程序服务器
  • 安装 ASP 应用程序服务器
  • 安装 JSP 应用程序服务器
  • 安装 PHP 应用程序服务器


选择应用程序服务器

您对应用程序服务器的选择取决于多种因素，包括预算、要使用的服务器技术（ColdFusion、ASP.NET、ASP、JSP 或 PHP）和选择的 Web 服务器。

预算 某些供应商出售价格和管理成本都很高的高端应用程序服务器。而其它一些供应商则提供更易使用的、成本效益更高的解决方案（例如 Macromedia ColdFusion 和 JRun 服务器）。某些应用程序服务器被内置到 Web 服务器中（例如 Microsoft IIS），而其它一些应用程序服务器可以从 Internet 上免费下载（例如 Jakarta Tomcat 和 PHP）。

服务器技术 应用程序服务器使用不同的技术。Dreamweaver 支持五种服务器技术：ColdFusion、ASP.NET、ASP、JSP 和 PHP。有关更多信息，请参见“Dreamweaver 入门”中的选择服务器技术。下表列出了可用于 Dreamweaver 支持的五种服务器技术的常见应用程序服务器：

服务器技术 | 应用程序服务器
ColdFusion | Macromedia ColdFusion MX 7
ASP.NET | 具有 .NET 框架的 Microsoft IIS 6
ASP | Microsoft IIS Sun ONE Active Server Page
JSP | Macromedia JRun Sun ONE 应用程序服务器 IBM WebSphere Apache Tomcat BEA WebLogic
PHP | PHP 服务器

Web 服务器 您所选的应用程序服务器还可能取决于您要使用的 Web 服务器。确保应用程序可以和您的 Web 服务器一起使用。例如，.NET 框架只能和 IIS 5 或更高版本一起使用。


安装 ColdFusion 应用程序服务器

若要运行 ColdFusion 页，您需要 ColdFusion 应用程序服务器。此服务器可用于 Windows、Linux、Solaris 和 HP-UX 系统。

Windows 用户可以从 Macromedia Web 站点（网址为 www.macromedia.com/go/coldfusion/）下载并安装 ColdFusion MX 7 的完全功能的开发人员版本。在 Dreamweaver CD 上也提供 ColdFusion MX 7 Developer Edition 的副本（仅限 Windows 版本）。

注意

开发人员版本面向非商业用途的 Web 应用程序开发和测试。此版本没有授权部署。它支持来自本地主机和两个远程 IP 地址的请求。可以在需要时使用它来开发和测试 Web 应用程序，且软件不会过期。有关更多信息，请参见“使用 ColdFusion”（“帮助”>“使用 ColdFusion”）中的“ColdFusion MX 7 产品版本”。

安装过程中，您可以配置 ColdFusion 以使用内置于 ColdFusion 的 Web 服务器或系统中安装的其它 Web 服务器。一般来说，最好使您的开发环境与生产环境尽可能的匹配。因此，如果您的开发计算机上已存在一个 Web 服务器（如 Microsoft IIS），则最好选择该服务器而不是内置的 ColdFusion Web 服务器。

Macintosh 用户可以将虚拟主机服务与 ColdFusion 计划一起使用或在运行 Web 服务器的远程 Windows、Linux、Solaris 或 HP-UX 计算机上安装 ColdFusion。您也可以在运行有 J2EE 服务器（如 JRun 或 Tomcat）的 Mac OS X 计算机上安装 ColdFusion。有关更多信息，请参见 Macromedia Web 站点，网址为 www.macromedia.com/go/cfmx7_mac。

在安装应用程序服务器后，为您的 Web 应用程序创建根文件夹。请参见为应用程序创建根文件夹。


安装 ASP.NET 应用程序服务器

若要开发和运行 ASP.NET 页，您需要以下软件：

  • 运行 IIS 5 或更高版本的 Windows 2000 或 Windows XP Professional 计算机
  • Microsoft .NET Framework 1.1，您可以从 Microsoft Web 站点上下载它
  • Microsoft .NET Framework 1.1 Software Development Kit (SDK)，您可以从 Microsoft Web 站点上下载它

确保在运行 IIS 5 或更高版本的 Windows 2000 或 Windows XP Professional 系统上安装了框架和 SDK 并且正在运行

若要安装 .NET 框架和 SDK，请执行以下操作：

  1. 通过在“添加或删除程序”对话框（“开始”>“控制面板”>“添加或删除程序”）中查看应用程序列表，检查系统是否已安装了 .NET 框架。

    如果列出了 Microsoft .NET Framework 1.1，则已安装了框架，不必再次安装。跳到第 3 步。

  2. 如果系统未安装 .NET 框架，请从 Microsoft Web 站点（http://msdn.microsoft.com/netframework/downloads/framework1_1/）安装 Microsoft .NET Framework 1.1 Redistributable 软件包，并按照 Web 站点上的安装说明进行安装。

    安装框架，并将其作为 Windows 更新。

  3. 从同一 Web 站点下载 Microsoft .NET Framework 1.1 Software Development Kit (SDK)，并按照安装说明进行安装。

强烈建议您在安装 .NET 框架和 SDK 之后，还安装 Microsoft Data Access Components (MDAC) 2.7 软件包。可以从 Microsoft Web 站点免费下载和安装 MDAC 2.7 软件包，网址为：http://msdn.microsoft.com/data/mdac/downloads/。

Macintosh 用户可以将虚拟主机服务与 ASP.NET 计划一起使用，或者在运行 IIS 5 或更高版本的远程 Windows 2000 或 Windows XP Professional 计算机上安装 .NET 框架和 SDK。

在安装 .NET 框架和 SDK 后，为您的 Web 应用程序创建根文件夹。请参见为应用程序创建根文件夹。


安装 ASP 应用程序服务器

若要运行 ASP 页面，您需要支持 Microsoft Active Server Pages 2.0 的应用程序服务器，如 Microsoft IIS，它随 Windows 2000 和 Windows XP Professional 一起提供。

Windows 用户可以在其本地计算机上安装并运行 IIS。有关说明，请参见“Dreamweaver 入门”中的安装 Web 服务器。

Macintosh 用户可以将虚拟主机服务与 ASP 计划一起使用或在远程计算机上安装 IIS。

在安装 IIS 后，为您的 Web 应用程序创建根文件夹。请参见为应用程序创建根文件夹。


安装 JSP 应用程序服务器

若要运行 JSP 页，您需要支持 JavaServer Pages 的应用程序服务器。以下是一些常见选择：

  • 用于 Windows、Mac OS X、Linux、Solaris 或 UNIX 的 Macromedia JRun。您可以从 Macromedia Web 站点（网址为 www.macromedia.com/go/jrun/）下载 JRun 的试用版。
  • 用于 Windows 和 UNIX（包括 Mac OS X）的 Tomcat。您可以从 Jakarta Project Web 站点（网址为 http://jakarta.apache.org/tomcat/）下载 Tomcat 的副本。有关在 Macintosh 上安装 Tomcat 的更多信息，请参见 Apple Web 站点，网址为 http://developer.apple.com/internet/java/tomcat1.html。

在安装 JSP 应用程序服务器后，为您的 Web 应用程序创建根文件夹。请参见为应用程序创建根文件夹。


安装 PHP 应用程序服务器

若要运行 PHP 页，您需要 PHP 应用程序服务器，它是在 Web 上提供的开放源代码软件。应用程序服务器有用于 Windows、Linux、UNIX、HP-UX、Solaris 和 Mac OS X 系统的版本。应用程序服务器可以与下列 Web 服务器一起工作：Apache、Microsoft IIS、Netscape 和 Sun ONE 服务器以及几乎所有支持 CGI 接口的 Web 服务器。

您可以从 PHP Web 站点（网址为 www.php.net/downloads.php）下载 PHP 应用程序服务器。通过 PHP 5，默认情况下，Windows 安装程序不会安装或启用允许 PHP 与 MySQL 数据库服务器一起使用的 MySQL 扩展。必须单独安装和启用它。有关说明，请参见“Dreamweaver 入门”中的安装 PHP 应用程序服务器 (Windows)。有关 MySQL 扩展的更多信息，请参见 PHP Web 站点，网址为：www.php.net/manual/en/ref.mysql.php。

如果您是 Macintosh 用户，则您可以使用随您的操作系统一起安装的 PHP 应用程序服务器。有关更多信息，请访问以下 Web 站点：

  • www.macromedia.com/go/php_macintosh/
  • http://developer.apple.com/internet/opensource/php.html

有关应用程序服务器的更多信息，请参见 PHP 文档，您也可以从 PHP Web 站点（网址为 www.php.net/download-docs.php）下载该文档。

在安装 PHP 应用程序服务器后，为您的 Web 应用程序创建根文件夹。请参见为应用程序创建根文件夹。


为应用程序创建根文件夹

在向虚拟主机服务公司注册或自己设置服务器软件之后，请在运行该 Web 服务器的计算机上为 Web 应用程序创建一个根文件夹。

确保该文件夹已由 Web 服务器发布；换言之，Web 服务器可以提供此文件夹中的任何文件或其子文件夹中的任何文件，以响应 Web 浏览器的 HTTP 请求。例如，在运行 ColdFusion MX 7 的计算机上，\CFusionMX7\wwwroot 文件夹或其子文件夹中的任何文件都可用于 Web 浏览器。

以下是所选 Web 服务器的默认根文件夹：

Web 服务器 | 默认根文件夹
ColdFusion MX 7 | \CFusionMX7\wwwroot
IIS | \Inetpub\wwwroot
Apache (Windows) | \apache\htdocs
Apache (Macintosh) | Users:MyUserName:Sites
Jakarta Tomcat (Windows) | \jakarta-tomcat-4.x.x\webapps\ROOT\

若要测试 Web 服务器，请将一个测试 HTML 页置于默认根文件夹中，然后尝试通过在浏览器中输入该页的 URL 打开该页。URL 由域名（如 www.mysite.com）和 HTML 页的文件名组成，如下所示：

www.mysite.com/testpage.htm

如果该 Web 服务器运行在本地计算机上，则可以使用 localhost 代替域名。使用上面的示例，根据您的 Web 服务器输入以下本地主机 URL：

Web 服务器 | 本地主机 URL
ColdFusion MX 7 | http://localhost:8500/testpage.htm
IIS | http://localhost/testpage.htm
Apache (Windows) | http://localhost:80/testpage.htm
Apache (Macintosh) | http://localhost/~MyUserName/testpage.htm（其中 MyUserName 是您的 Macintosh 用户名）
Jakarta Tomcat (Windows) | http://localhost:8080/testpage.htm

注意

默认情况下，ColdFusion MX 7 Web 服务器运行在端口 8500 上，Jakarta Tomcat Web 服务器运行在端口 8080 上。

如果该页未按预期方式打开，则检查是否存在以下错误：

  • 未启动 Web 服务器。参考 Web 服务器的文档以获取启动指导。
  • 文件不具有 .htm 或 .html 扩展名。
  • 在浏览器的“地址”文本框中输入了该页的文件路径（例如，c:\CFusionMX7\wwwroot\testpage.htm），而不是它的 URL（例如，http://localhost:8500/testpage.htm）。
  • URL 中包含键入错误。检查是否存在错误并确保文件名后没有斜杠，例如 http://localhost:8080/testpage.htm/。

为应用程序创建根文件夹后，定义一个 Dreamweaver 站点管理您的文件。请参见定义 Dreamweaver 站点。


定义 Dreamweaver 站点

在配置了用来开发 Web 应用程序的系统后，定义用来管理您的文件的 Dreamweaver 站点。

在您开始前，确保您满足以下要求：

  • 您具有访问 Web 服务器的权限。Web 服务器可以在您的本地计算机上运行，在像开发服务器这样的远程计算机上运行，或者在网页寄存公司维护的服务器上运行。请参见设置 Web 服务器。
  • 应用程序服务器安装并运行在运行您的 Web 服务器的系统上。请参见设置应用程序服务器。
  • 您已在运行 Web 服务器的系统上为 Web 应用程序创建了根文件夹。有关更多信息，请参见为应用程序创建根文件夹。

为您的 Web 应用程序定义 Dreamweaver 站点需执行以下三步：

  1. 将位于您的硬盘上的文件夹定义为用来存储您的站点文件工作副本的 Dreamweaver 本地文件夹（请参见定义本地文件夹）。
  2. 将位于正运行您的 Web 服务器的计算机上的文件夹定义为 Dreamweaver 远程文件夹（请参见定义远端文件夹）。
  3. 指定 Dreamweaver 应将在工作时要处理的动态页发送到哪里（请参见指定可在哪里处理动态页）。

在定义了 Dreamweaver 站点后，您就可以开始生成 Web 应用程序了。


定义本地文件夹

您可为您创建的每一个新 Web 应用程序定义 Dreamweaver 本地文件夹。本地文件夹是您在硬盘上用来存储站点文件的工作副本的文件夹。定义本地文件夹还使您能够通过单击按钮来管理文件并将文件传输到 Web 服务器和从 Web 服务器接收文件。

若要定义 Dreamweaver 本地文件夹，请执行以下操作：

  1. 创建在本地硬盘上用来存储您的文件的工作副本的文件夹。

    您最好创建子文件夹以存储图像文件和其它资源。

  2. 在 Dreamweaver 中，选择“站点”>“管理站点”，单击“管理站点”对话框中的“新建”按钮，然后从上下文菜单中选择“站点”。

    出现“站点定义”对话框。

  3. 如果显示向导，则单击“高级”，然后从“类别”列表中选择“本地信息”（它应该是默认选项）。
  4. 在“站点名称”文本框中，输入 Dreamweaver 站点的描述性名称。
  5. 在“本地根文件夹”文本框中，指定您在第 1 步中创建的文件夹。

    您可以输入一个路径，或者单击文件夹图标以浏览到并选择该文件夹。

  6. 您可以根据需要完成对“本地信息”类别中的其它选项的设置（这些选项不是站点得以工作所必需的选项）。

    有关这些选项的更多信息，请参见设置“本地信息”类别选项。

将“站点定义”对话框保持为打开状态。接下来您必须指定远程文件夹。请参见定义远端文件夹。


定义远端文件夹

在定义本地文件夹后，您可为 Dreamweaver 站点定义远程文件夹。远端文件夹是您为 Web 应用程序在 Web 服务器上创建的文件夹（请参见为应用程序创建根文件夹）。

如果您在定义本地文件夹中定义的文件夹可以兼具您的 Web 应用程序的根文件夹的功能，则您不需要定义远端文件夹。（这意味着该 Web 服务器正在您的本地计算机上运行。

若要定义 Dreamweaver 远程文件夹，请执行以下操作：

  1. 如果“站点定义”对话框没有打开，请打开“站点定义”对话框，方法是选择“站点”>“管理站点”，从“管理站点”对话框的列表中选择您的站点，然后单击“编辑”。

    出现“站点定义”对话框。

  2. 如果显示向导，则单击“高级”，然后从“类别”列表中选择“远程信息”。

    随即显示“远程信息”对话框。

  3. 在“访问”弹出菜单中，选择以下选项之一：本地/网络、FTP 或 RDS。

    根据您所做的选择，Dreamweaver 将知道您在本地文件夹和远程文件夹之间传输文件的方式。

    注意

    若要使用 RDS，远程文件夹必须位于运行 ColdFusion 的计算机上。

    您还可以通过选择“Microsoft Visual SourceSafe”将文件发送到 Microsoft Visual SourceSafe 应用程序中。（开发人员使用 Microsoft Visual SourceSafe 来进行文件版本控制。）如果您选择此选项，则需要定义单独的文件夹。有关说明，请参见指定可在哪里处理动态页。

  4. 在选择访问方法后，根据需要设置适当的访问选项。

    有关更多信息，请参见设置“远端信息”类别选项。

将“站点定义”对话框保持为打开状态。您接下来需要定义处理动态页的文件夹。请参见指定可在哪里处理动态页。


指定可在哪里处理动态页

在 Dreamweaver 中定义远程文件夹后，指定可在其中处理动态页的文件夹。Dreamweaver 使用此文件夹生成动态内容并在您工作时连接到数据库。

通常，您指定在 Web 服务器上创建的根文件夹（请参见为应用程序创建根文件夹），因为该服务器可能还运行可以处理动态页的应用程序服务器。

注意

根文件夹可以是本地的也可以是远程的，取决于您的 Web 服务器正在哪里运行。

若要指定 Dreamweaver 可在哪里处理动态页，请执行以下操作：

  1. 如果“站点定义”对话框没有打开，请打开“站点定义”对话框，方法是选择“站点”>“管理站点”，从“管理站点”对话框的列表中选择您的站点，然后单击“编辑”。

    出现“站点定义”对话框。

  2. 如果显示向导，则单击“高级”，然后从“类别”列表中选择“测试服务器”。

    随即显示“测试服务器”对话框。Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是本地计算机、开发服务器、中间服务器或生产服务器。只要测试服务器可以处理您计划开发的动态页类型，选择哪个就无关紧要。

  3. 完成对话框设置，然后单击“确定”。

    有关更多信息，请参见设置“测试服务器”类别选项。

定义 Dreamweaver 站点后，您可以连接到数据库。（请参见为应用程序创建根文件夹。）

相关主题

  • 设置 URL 前缀


连接到数据库

如果您要将数据库与 Web 应用程序一起使用，必须首先连接到该数据库。有关数据库连接的一般性论述，请参见理解数据库连接。

根据您所选择的服务器技术，Dreamweaver 处理数据库连接的方式也将有所不同。请参见以下各章：

  • ColdFusion 开发人员的数据库连接
  • ASP.NET 开发人员的数据库连接
  • ASP 开发人员的数据库连接
  • 用于 JSP 开发人员的数据库连接
  • 适用于 PHP 开发人员的数据库连接


参考资料

本节论述了“站点定义”对话框的“测试服务器”类别，并说明了可应用于各类别的字段和设置：

  • 设置“测试服务器”类别选项
  • 设置 URL 前缀


设置“测试服务器”类别选项

此对话框用于指定 Dreamweaver 用来处理动态页以进行网页创作的测试服务器。

Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是本地计算机、开发服务器、中间服务器或生产服务器。只要测试服务器可以处理您计划开发的动态页类型，选择哪个就无关紧要。

确保您在完成此对话框的设置前定义本地和远程文件夹。有关指导，请参见定义本地文件夹和定义远端文件夹。您可能经常将您的远程文件夹的设置用于您的测试服务器，因为在远程文件夹中上传的动态页通常可能是由应用程序服务器处理的。

若要指定测试服务器，请执行以下操作：

  1. 选择服务器技术。
  2. 接受默认的“测试服务器”设置，或者输入不同的设置。

    默认情况下，Dreamweaver 假定应用程序服务器正运行在与您的 Web 服务器相同的系统上。如果您在“站点定义”对话框的“远程信息”类别中定义了远程文件夹，并且如果应用程序服务器运行在与远程文件夹相同的系统上（包括您的本地计算机），则接受“测试服务器”类别中的默认设置。

    如果您没有在“远程信息”类别中定义远程文件夹，则“测试服务器”类别默认为您在“本地信息”类别中定义的本地文件夹。只有在您满足以下两个条件时，您才可以不去改动此默认设置：

    • 您的 Web 服务器和应用程序服务器均在您的本地计算机上运行。例如，您是在本地 Windows 2000 系统上运行 IIS 和 ColdFusion 的 ColdFusion 开发人员。
    • 您的本地根文件夹是您的主目录的子文件夹。例如，如果您正使用 IIS，则您的本地根文件夹是 c:\Inetpub\wwwroot\ 文件夹的子文件夹，或是该文件夹本身。

    如果您的本地根文件夹不是您的主目录的子文件夹，则您必须将本地根文件夹定义为您的 Web 服务器中的虚拟目录。

    有关主目录和虚拟目录的更多信息，请参见设置 URL 前缀。

    应用程序服务器可以在与您的远程站点不同的系统上运行。例如，如果您在“远程信息”类别中选择的“访问”选项是“Microsoft Visual SourceSafe”，则您必须在“测试服务器”类别中指定不同的服务器。

  3. 在“URL 前缀”框中，输入用户在其浏览器中键入用来打开您的 Web 应用程序的 URL，但不包括任何文件名。

    假设应用程序的 URL 是 www.macromedia.com/mycoolapp/start.jsp。您需要输入以下 URL 前缀：www.macromedia.com/mycoolapp/。

    如果 Dreamweaver 运行在与您的 Web 服务器相同的系统上，则可以使用 localhost 一词作为您的域名的替代项。例如，假定您运行 IIS，且应用程序的 URL 如下所示：

    http://buttercup_pc/mycoolapp/start.jsp

    您可以输入以下 URL 前缀：

    http://localhost/mycoolapp/

    有关更多信息，请参见设置 URL 前缀。

  4. 单击“确定”，然后单击“完成”。

Dreamweaver 将该新站点添加到您的站点列表中。

相关主题

  • 指定可在哪里处理动态页


设置 URL 前缀

您必须指定 URL 前缀，这样 Dreamweaver 才能使用测试服务器的服务显示数据并在您工作时连接到数据库。Dreamweaver 使用设计时连接向您提供与数据库有关的有用信息，例如您的数据库中各表的名称以及表中各列的名称。

URL 前缀由域名和 Web 站点的主目录的任何一个子目录或虚拟目录组成。

注意

本节使用在 Microsoft IIS 中使用的术语。服务器不同，术语也可能不同，但相同的概念适用于大多数 Web 服务器。

主目录是服务器上映射到您的站点域名的文件夹。假设您要用来处理动态页的文件夹是 c:\sites\company\，并且该文件夹是您的主目录（即，该文件夹被映射到您站点的域名，例如 www.mystartup.com）。在此情况下，URL 前缀是 http://www.mystartup.com/。

如果您要用来处理动态页的文件夹是您的主目录的子文件夹，则您只需将该子文件夹添加到 URL。假设您的主目录是 c:\sites\company\，您的站点的域名是 www.mystartup.com，并且您要用来处理动态页的文件夹是 c:\sites\company\inventory。输入以下 URL 前缀：

http://www.mystartup.com/inventory/

如果您要用来处理动态页的文件夹不是您的主目录或其任何子目录，则您必须创建虚拟目录。

虚拟目录是实际上不包含在服务器的主目录中的文件夹，即使它看起来像是在 URL 中。若要创建虚拟目录，请为 URL 中的文件夹路径指定一个别名。假设您的主目录是 c:\sites\company，您正处理的文件夹是 d:\apps\inventory，并且您为名为 warehouse 的文件夹定义别名。输入以下 URL 前缀：

http://www.mystartup.com/warehouse/

本地主机是一个术语，表示当客户端（通常是浏览器，但在此情况下为 Dreamweaver）与 Web 服务器运行在同一系统上时您的 URL 中的主目录。假设 Dreamweaver 与 Web 服务器在同一 Windows 系统上运行，您的主目录是 c:\sites\company，并且您已定义了名为 warehouse 的虚拟目录以表示您要用来处理动态页的文件夹。以下是将为所选 Web 服务器输入的 URL 前缀：

Web 服务器 | URL 前缀
ColdFusion MX 7 | http://localhost:8500/warehouse/
IIS | http://localhost/warehouse/
Apache (Windows) | http://localhost:80/warehouse/
Jakarta Tomcat (Windows) | http://localhost:8080/warehouse/

注意

默认情况下，ColdFusion MX 7 Web 服务器运行在端口 8500 上，Apache Web 服务器运行在端口 80 上，而 Jakarta Tomcat Web 服务器运行在端口 8080 上。

对于运行 Apache Web 服务器的 Macintosh 用户，个人主目录是 Users:MyUserName:Sites，其中 MyUserName 是 Macintosh 用户名。安装 Mac OS 10.1 或更高版本时，将自动为该文件夹定义一个名为 ~MyUserName 的别名。因此，在 Dreamweaver 中您的默认 URL 前缀为：

http://localhost/~MyUserName/

假设要用于处理动态页的文件夹为 Users:MyUserName:Sites:inventory，则 URL 前缀如下：

http://localhost/~MyUserName/inventory/

相关主题

  • 设置“测试服务器”类别选项
  • 指定可在哪里处理动态页


ColdFusion 开发人员的数据库连接

您可以在用 Macromedia Dreamweaver 8 开发 Macromedia ColdFusion 应用程序时连接到数据库。

本章假定您已经设置 ColdFusion Web 应用程序（请参见设置 Web 应用程序）。它还假定您已经在本地计算机（或在对其具有网络或 FTP 访问权的系统）上设置了数据库。

本章包含以下主题：

连接到数据库

编辑或删除数据库连接

若要连接到 Dreamweaver 提供的示例数据库，请参见“Dreamweaver 入门”中的“示例 ColdFusion 站点的设置”。要了解有关数据库和数据库连接的更多信息，请参见数据库初学者指南。


连接到数据库

当您在 Dreamweaver 中开发 ColdFusion Web 应用程序时，通过选择在 Dreamweaver 或“ColdFusion 管理员”（服务器的管理控制台）中定义的 ColdFusion 数据源，就可以连接到数据库。

在连接到数据库之前，必须先确保 Dreamweaver 知道去何处查找 ColdFusion 数据源。为了在设计时检索 ColdFusion 数据源，Dreamweaver 会将脚本放在运行 ColdFusion 的计算机上的一个文件夹中。您必须在“站点定义”对话框的“测试服务器”类别中指定该文件夹。有关更多信息，请参见指定可在哪里处理动态页。

接着，您必须在 Dreamweaver 或“ColdFusion 管理员”中创建 ColdFusion 数据源（如果它尚不存在）。有关更多信息，请参见创建或修改 ColdFusion 数据源。

当创建 ColdFusion 数据源后，您可以在 Dreamweaver 中使用它来连接到数据库。有关更多信息，请参见在 Dreamweaver 中连接到数据库。


创建或修改 ColdFusion 数据源

在页面中使用数据库信息之前，您必须创建一个 ColdFusion 数据源。如果您运行的是 ColdFusion MX 7 或更高版本，您可直接在 Dreamweaver 中创建或修改数据源。如果您运行的是 ColdFusion MX，必须使用“ColdFusion MX 管理员”（服务器的管理控制台）创建或修改数据源。在这种情况下，您仍可使用 Dreamweaver 打开“ColdFusion MX 管理员”。

在运行 ColdFusion MX 7 或更高版本时，若要创建或修改 ColdFusion 数据源，请执行以下操作：

  1. 确保运行 ColdFusion MX 7 或更高版本的计算机被定义为站点的测试服务器。

    有关更多信息，请参见启用 ColdFusion 增强功能。

  2. 在 Dreamweaver 中打开任何一个 ColdFusion 页。
  3. 要创建一个新的数据源，请单击“数据库”面板（“窗口”>“数据库”）中的加号 (+) 按钮并在出现的对话框中输入特定于数据库驱动程序的参数值。

    注意

    只有在您运行 ColdFusion MX 7 或更高版本时，Dreamweaver 才会显示加号按钮。

    有关更多信息，请参见驱动程序供应商的文档或向您的系统管理员咨询。

  4. 要修改数据源，请双击“数据库”面板中的数据库连接，并在出现的连接对话框中进行更改。

    除数据源名称外，您可对任何参数进行编辑。有关更多信息，请参见驱动程序供应商的文档或向您的系统管理员咨询。

在运行 ColdFusion MX 6.1 或 6.0 时，若要创建或修改 ColdFusion 数据源，请执行以下操作：

  1. 在 Dreamweaver 中打开任何一个 ColdFusion 页。
  2. 在 Dreamweaver 的“数据库”面板（“窗口”>“数据库”）中，单击面板工具栏上的“修改数据源”图标。

    “ColdFusion MX 管理员”在浏览器中打开。

  3. 登录到“ColdFusion MX 管理员”并创建或修改数据源。

    有关说明，请参见“使用 ColdFusion”（“帮助”>“使用 ColdFusion”）。

    您必须提供某些特定的参数值才能创建 ColdFusion 数据源。有关特定于您的数据库驱动程序的参数值，请参见驱动程序供应商提供的文档或咨询您的系统管理员。

当创建 ColdFusion 数据源后，即可在 Dreamweaver 中使用它。有关更多信息，请参见在 Dreamweaver 中连接到数据库。


在 Dreamweaver 中连接到数据库

创建了 ColdFusion 数据源（请参见创建或修改 ColdFusion 数据源）之后，您可以使用它连接到 Dreamweaver 中的数据库。

在 Dreamweaver 中打开任意 ColdFusion 页，然后打开“数据库”面板（“窗口”>“数据库”）。您的 ColdFusion 数据源会出现在该面板中。

如果数据源没有出现，请确保完成面板中的核对表，还要确保 Dreamweaver 知道到何处去查找 ColdFusion 数据源。在“站点定义”对话框的“测试服务器”类别中，指定运行 ColdFusion 的计算机上的站点根文件夹。有关更多信息，请参见指定可在哪里处理动态页。

相关主题

  • 数据库连接答疑


编辑或删除数据库连接

您可以在“ColdFusion 管理员”中编辑或删除 ColdFusion 数据源。在 Dreamweaver 的“数据库”面板（“窗口”>“数据库”）中，单击面板工具栏上的“修改数据源”图标。“ColdFusion 管理员”在浏览器中打开。登录并修改数据源。有关说明，请参见“使用 ColdFusion”。

若要避免在删除或重命名 ColdFusion 数据源后出错，应在“绑定”面板中双击记录集的名称并选择新的数据源，以更新 Dreamweaver 中每个使用旧数据源的记录集。


参考资料

本节描述本章中介绍的以下对话框：

  • 设置“连接”对话框选项 (ColdFusion)


设置“连接”对话框选项 (ColdFusion)

此对话框用于创建或修改建立到数据库连接的 ColdFusion 数据源。

若要设置对话框的选项，请执行以下操作：

  • 请输入特定于数据库驱动程序的参数值。

    有关更多信息，请参见驱动程序供应商的文档或向您的系统管理员咨询。

相关主题

  • 创建或修改 ColdFusion 数据源


ASP.NET 开发人员的数据库连接

若要将数据库与 ASP.NET 应用程序一起使用，您需要在 Macromedia Dreamweaver 8 中创建数据库连接。本章描述如何创建数据库连接。

注意

如果您正在开发 Microsoft Active Server Pages (ASP) 应用程序，请参见 ASP 开发人员的数据库连接。

本章假定您已经设置了 ASP.NET 应用程序（请参见设置 Web 应用程序）。它还假定您已经在本地计算机（或在对其具有网络或 FTP 访问权的系统）上设置了数据库。

本章包含下列章节：

连接到数据库

编辑或删除数据库连接

若要连接到 Dreamweaver 提供的示例数据库，请参见“Dreamweaver 入门”中的“示例 ASP.NET 站点的设置”。要了解有关数据库和数据库连接的更多信息，请参见数据库初学者指南。


连接到数据库

本节描述在 Dreamweaver 中开发 ASP.NET 应用程序时如何连接到数据库。

在能够连接到数据库以前，必须为您的数据库获取 OLE DB 提供程序。如果想要连接到 Microsoft SQL Server 数据库，您可以使用 .NET Framework Software Development Kit (SDK) 提供的 Managed Data Provider for SQL Server。有关更多信息，请参见为数据库获取 OLE DB 提供程序。

在安装了数据库提供程序之后，您就可以使用它连接到数据库。有关指导，请参见以下几节：

  • 在 Dreamweaver 中创建 ASP.NET 数据库连接
  • 使用“数据链接属性”创建连接

相关主题

  • 适用于 ASP.NET 的示例 OLE DB 连接参数


为数据库获取 OLE DB 提供程序

ASP.NET 应用程序必须通过 OLE DB 提供程序连接到数据库。该提供程序充当允许 ASP.NET 应用程序与数据库进行通信的解释器。有关 OLE DB 和数据库提供程序作用的更多信息，请参见与数据库进行通信。

如果想要连接到 Microsoft SQL Server 数据库，您可以使用 .NET Framework 1.1 SDK 随附的 Managed Data Provider for SQL Server。该提供程序已经针对 SQL Server 进行了优化，速度非常快，并且在安装 SDK 时被同时安装。

如果想要连接到的数据库不是 SQL Server，那么请确保在运行 .NET 框架的计算机上安装了适用于您的数据库的 OLE DB 提供程序。可从 Microsoft Web 站点 http://msdn.microsoft.com/data/mdac/downloads/. 下载和安装 Microsoft Data Access Components (MDAC) 2.7 软件包，获取用于 Microsoft Access 的 OLE DB 提供程序。

用于 Oracle 数据库的 OLE DB 提供程序可以从 Oracle Web 站点下载，网址为 www.oracle.com/technology/software/tech/windows/ole_db/index.html。您还可以从第三方供应商处购买 OLE DB 提供程序。

在拥有适用于数据库的提供程序以后，您就可以使用它在 Dreamweaver 中创建数据库连接。请参见在 Dreamweaver 中创建 ASP.NET 数据库连接。


在 Dreamweaver 中创建 ASP.NET 数据库连接

在获取适用于您的数据库的 OLE DB 提供程序后（请参见为数据库获取 OLE DB 提供程序），您可以使用它在 Dreamweaver 中创建数据库连接。

另一个选择是使用“Microsoft 数据链接属性”对话框帮助您创建连接。有关说明，请参见使用“数据链接属性”创建连接。

若要为 ASP.NET 创建数据库连接，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 ASP.NET 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    该面板显示为该站点定义的连接。

  2. 单击面板上的加号 (+) 按钮并从弹出菜单中选择“OLE DB 连接”或“SQL Server 连接”。

    注意

    只有在希望连接到 Microsoft SQL Server 数据库时，才选择“SQL Server 连接”。

    随即出现“OLE DB 连接”或“SQL Server 连接”对话框。

  3. 完成对话框设置，然后单击“确定”。

    有关更多信息，请参见下列内容：

    • 设置“OLE DB 连接”对话框选项
    • 设置“SQL Server 连接”对话框选项

新连接出现在“数据库”面板上。

相关主题

  • 数据库连接答疑


使用“数据链接属性”创建连接

在获取适用于您的数据库的 OLE DB 提供程序后（请参见为数据库获取 OLE DB 提供程序），您可以通过使用 Windows 中的“数据链接属性”对话框创建数据库连接。

重要：只有所要使用的 OLE DB 提供程序与 Dreamweaver 安装在同一台 Windows 计算机上时，您才可以使用此方法。

若要使用“数据链接属性”创建数据库连接，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 ASP.NET 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    该面板显示为该站点定义的连接。

  2. 单击该面板上的加号 (+) 按钮，然后从弹出菜单中选择“OLE DB 连接”。

    随即出现“OLE DB 连接”对话框。

  3. 单击“建立”按钮。

    出现“数据链接属性”对话框。该 Windows 对话框随即显示运行 Dreamweaver 的 Windows 计算机上当前安装的 OLE DB 提供程序。

  4. 完成“数据链接属性”对话框并单击“确定”。

    Dreamweaver 随即在“OLE DB 连接”对话框中插入一个连接字符串。

  5. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请复查连接字符串。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  6. 单击“确定”。

    新连接出现在“数据库”面板上。

相关主题

  • 数据库连接答疑


适用于 ASP.NET 的示例 OLE DB 连接参数

OLE DB 连接字符串合并了 ASP.NET 应用程序连接到数据库所需的全部信息。Dreamweaver 在页的服务器端脚本中插入该字符串，以便应用程序服务器随后进行处理。

Dreamweaver 为您提供了字符串模板以便为 ASP.NET 应用程序创建 OLE DB 连接字符串（请参见在 Dreamweaver 中创建 ASP.NET 数据库连接）。若要创建连接字符串，请用所需的参数值替换模板中的占位符。本节给出适用于 Microsoft Access 和 SQL Server 数据库的示例参数。

注意

有关特定于其它数据库的参数值，请参见数据库供应商的文档或向您的系统管理员咨询。

案例 1：假设您在本地计算机上具有 .NET 框架并且想连接到名为 sdSchool.mdb 的 Microsoft Access 数据库，该数据库位于硬盘上的下列文件夹中：c:\Inetpub\wwwroot\SkyDiveSchool\data\sdSchool.mdb。下面是用于创建连接字符串的参数：

Provider=Microsoft.Jet.OLEDB.4.0;
Data Source=c:\Inetpub\wwwroot\SkyDiveSchool\data\sdSchool.mdb;

案例 2：假设您在远程开发服务器上使用 .NET 框架并且想连接到名为 mtnSchool.mdb 的 Microsoft Access 数据库，该数据库位于服务器上的下列文件夹中：d:\users\tara\projects\MtnDrivingSchool\data\mtnSchool.mdb。下面是用于创建连接字符串的参数：

Provider=Microsoft.Jet.OLEDB.4.0;
Data Source=d:\users\tara\projects\MtnDrivingSchool\data\mtnSchool.mdb;

案例 3：您在名为 Savant 的联网开发服务器上使用 .NET 框架并且想连接到在服务器上名为 pubs 的 Microsoft SQL Server 数据库。您的 SQL Server 用户名是“sa”，不需要密码。如果您使用 Managed Data Provider for SQL Server（即如果您在“数据库”面板上选择“SQL 连接”），则使用下列用于创建连接字符串的参数：

Data Source=Savant;
Initial Catalog=pubs;
User ID=sa;
Password=;


编辑或删除数据库连接

当您创建数据库连接后，Dreamweaver 会将连接信息存储在站点本地根文件夹下的“Connections”子文件夹中的一个包含文件中。您可以手动编辑或删除文件中的连接信息，或者执行以下操作。

若要更新连接，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 ASP.NET 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    连接列表出现在该面板上。

  2. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 该连接，然后从弹出菜单中选择“编辑连接”。

    出现您曾用来创建该连接的对话框。

  3. 做出更改，然后单击“确定”。

Dreamweaver 自动更新包含文件，该文件自动更新站点中使用该连接的所有页面。

如果您重命名一个连接，则通过在“绑定”面板中双击记录集并在“数据集”对话框中选择新连接名称，可以更新每个使用旧连接名称的数据集。

若要删除连接，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 ASP.NET 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    连接列表出现在该面板上。

  2. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 该连接，然后从弹出菜单中选择“删除连接”。

    出现您曾用来创建该连接的对话框。

  3. 确认您要删除该连接。

    注意

    若要避免在删除一个连接后收到错误信息，请通过在“绑定”面板中双击数据集的名称并在“数据集”对话框中选择新连接，更新使用旧连接的每一数据集。


参考资料

本节描述本章中介绍的下列对话框：

  • 设置“OLE DB 连接”对话框选项
  • 设置“连接字符串模板”对话框选项
  • 设置“SQL Server 连接”对话框选项


设置“OLE DB 连接”对话框选项

此对话框用于为 ASP.NET 应用程序定义数据库连接。

若要定义用于 ASP.NET 应用程序的数据库连接，请执行以下操作：

  1. 输入新连接的名称。

    注意

    不要在该名称中使用任何空格或特殊字符。
  2. 输入连接字符串。

    如果您需要连接字符串方面的帮助，请单击“模板”打开“连接字符串模板”对话框，从模板列表中选择 OLE DB 提供程序，然后单击“确定”。

    Dreamweaver 随即将字符串模板插入到“连接字符串”文本框中。用需要的信息替换字符串中的占位符。有关更多信息，请参见适用于 ASP.NET 的示例 OLE DB 连接参数。

  3. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请复查连接字符串。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  4. 单击“确定”。

    新连接出现在“数据库”面板上。

相关主题

  • 在 Dreamweaver 中创建 ASP.NET 数据库连接
  • 为数据库获取 OLE DB 提供程序
  • 使用“数据链接属性”创建连接


设置“连接字符串模板”对话框选项

该对话框用于在“OLE DB 连接”对话框的“连接字符串”框中插入字符串模板。

若要设置对话框的选项，请执行以下操作：

  • 选择一个 OLE DB 提供程序并单击“确定”。

相关主题

  • 在 Dreamweaver 中创建 ASP.NET 数据库连接
  • 设置“OLE DB 连接”对话框选项


设置“SQL Server 连接”对话框选项

该对话框用于通过 .NET Framework 1.1 SDK 提供的 Managed Data Provider for SQL Server 定义到 SQL Server 数据库的连接。

若要设置对话框的选项，请执行以下操作：

  1. 输入新连接的名称。

    注意

    不要在该名称中使用任何空格或特殊字符。
  2. 输入连接字符串。

    Dreamweaver 在“连接字符串”文本框中提供字符串模板。用需要的信息替换字符串中的占位符。有关更多信息，请参见适用于 ASP.NET 的示例 OLE DB 连接参数。

  3. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请复查连接字符串。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  4. 单击“确定”。

    新连接出现在“数据库”面板上。

相关主题

  • 在 Dreamweaver 中创建 ASP.NET 数据库连接
  • 为数据库获取 OLE DB 提供程序


ASP 开发人员的数据库连接

若要将数据库与 Microsoft Active Server Page (ASP) 应用程序一起使用，需要在 Macromedia Dreamweaver 8 中创建数据库连接。本章介绍如何创建数据库连接。

注意

如果您正在开发 ASP.NET 应用程序，请参见 ASP.NET 开发人员的数据库连接。

本章假定您已经设置 ASP 应用程序（请参见设置 Web 应用程序）。它还假定您已经在本地计算机（或在对其具有网络或 FTP 访问权的系统）上设置了数据库。

本章包含下列章节：

关于 ASP 中的数据库连接

创建 DSN 连接

创建非 DSN (DSN-less) 连接

连接到 ISP 上的数据库

编辑或删除数据库连接

若要连接到 Dreamweaver 提供的示例数据库，请参见“Dreamweaver 入门”中的“示例 ASP 站点的设置”。要了解有关数据库和数据库连接的更多信息，请参见数据库初学者指南。


关于 ASP 中的数据库连接

ASP 应用程序必须通过 ODBC 驱动程序或 OLE DB 提供程序连接到数据库。创建 OLE DB 连接可以提高连接的速度。

本节包含以下概念性主题：

  • ASP 数据库连接
  • OLE DB 连接


ASP 数据库连接

ASP 应用程序必须通过开放式数据库连接 (ODBC) 驱动程序（或对象链接）和嵌入式数据库 (OLE DB) 提供程序连接到数据库。该驱动程序或提供程序用作解释器，能够使 Web 应用程序与数据库进行通信。有关数据库驱动程序的作用的更多信息，请参见与数据库进行通信。下表显示了一些可以与 Microsoft Access、Microsoft SQL Server 和 Oracle 数据库一起使用的驱动程序：

数据库 | 数据库驱动程序
Microsoft Access | Microsoft Access 驱动程序 (ODBC) 用于 Access 的 Microsoft Jet 提供程序 (OLE DB)
Microsoft SQL Server | Microsoft SQL Server 驱动程序 (ODBC) Microsoft SQL Server 提供程序 (OLE DB)
Oracle | Microsoft Oracle 驱动程序 (ODBC) Oracle Provider for OLE DB

您可以使用数据源名称 (DSN) 或连接字符串连接到数据库。

DSN 是单个词的标识符（如 myConnection），它指向数据库并包含连接到该数据库所需的全部信息。您可以在 Windows 中定义 DSN。如果您正在通过安装在 Windows 系统上的 ODBC 驱动程序进行连接，则可以使用 DSN。有关详细指导，请参见创建 DSN 连接。

连接字符串是手动编码的表达式，它标识数据库并列出连接到该数据库所需的信息。下面是一个示例：

Driver={SQL Server};Server=Socrates;Database=AcmeMktg;
UID=wiley;PWD=roadrunner

如果您正在通过以下程序之一进行连接，则必须使用连接字符串：

  • OLE DB 提供程序
  • 未安装在 Windows 系统上的 ODBC 驱动程序

有关详细指导，请参见以下节：

  • 创建非 DSN (DSN-less) 连接
  • 连接到 ISP 上的数据库

    注意

    如果您正在通过安装在 Windows 系统上的 ODBC 驱动程序建立连接，也可以使用连接字符串，但使用 DSN 要简单一些。

相关主题

  • OLE DB 连接


OLE DB 连接

您可以使用 OLE DB 提供程序与数据库进行通信。通过创建直接的数据库特定的 OLE DB 连接，可以消除 Web 应用程序和数据库之间的 ODBC 层，从而提高连接的速度。

如果没有为数据库指定 OLE DB 提供程序，ASP 会使用 ODBC 驱动程序的默认 OLE DB 提供程序与 ODBC 驱动程序进行通信，而后者又与数据库进行通信。

OLE DB 仅在 Windows NT、2000 或 XP 上可用。

对于不同的数据库存在不同的 OLE DB 提供程序。您可以通过下载 Microsoft Data Access Components (MDAC) 2.5 和 2.7 软件包并将其安装在运行 IIS 的 Windows 计算机上来获取用于 Microsoft Access 和 SQL Server 的 OLE DB 提供程序。可以从 Microsoft Web 站点免费下载 MDAC 软件包，网址为 http://msdn.microsoft.com/data/mdac/downloads/。

注意

安装 MDAC 2.7 之前应确保 MDAC 2.5 已安装。

用于 Oracle 数据库的 OLE DB 提供程序可以从 Oracle Web 站点下载，网址为 www.oracle.com/technology/software/tech/windows/ole_db/index.html（要求注册）。

在 Dreamweaver 中，可以通过在连接字符串中包含 Provider 参数来创建 OLE DB 连接（请参见创建非 DSN (DSN-less) 连接）。例如，下面分别是 Access、SQL Server 和 Oracle 数据库的常用 OLE DB 提供程序的参数：

Provider=Microsoft.Jet.OLEDB.4.0;...
Provider=SQLOLEDB;...
Provider=OraOLEDB;...

有关您的 OLE DB 提供程序的参数值，请参见提供程序供应商提供的文档或向您的系统管理员咨询。

相关主题

  • 设置连接字符串选项
  • 创建非 DSN (DSN-less) 连接


创建 DSN 连接

您可以使用 DSN 在 Web 应用程序和数据库之间建立 ODBC 连接。DSN 是一种名称，它包含使用 ODBC 驱动程序连接到指定数据库所需的全部参数。有关更多信息，请参见使用 DSN。

注意

由于在 DSN 中只能指定 ODBC 驱动程序，因此如果要使用 OLE DB 提供程序，就必须使用连接字符串。有关更多信息，请参见 OLE DB 连接。

您可以在本地或远程 Windows 计算机上定义 DSN。以下主题介绍创建这两种连接的方法：

  • 使用本地 DSN 创建连接
  • 使用远程 DSN 创建连接

相关主题

  • 创建非 DSN (DSN-less) 连接


使用本地 DSN 创建连接

您可以使用本地定义的 DSN 在 Dreamweaver 中创建数据库连接。如果要使用本地 DSN，必须在运行 Dreamweaver 的 Windows 计算机上定义该 DSN。

若要使用本地定义的 DSN 创建数据库连接，请执行以下操作：

  1. 在运行 Dreamweaver 的 Windows 计算机上定义一个 DSN。

    有关指导，请参见 Microsoft Web 站点上的下列文章：

    • 如果计算机运行 Windows 2000，请参见 Microsoft 知识库文章 300596，网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;300596
    • 如果计算机运行 Windows XP，请参见 Microsoft 知识库文章 305599，网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;305599
  2. 在 Dreamweaver 中打开一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    Dreamweaver 显示为该站点定义的所有连接。

  3. 单击该面板上的加号 (+) 按钮，然后从弹出菜单中选择“数据源名称 (DSN)”。

    出现“数据源名称 (DSN)”对话框。

  4. 输入新连接的名称。

    注意

    不要在该名称中使用任何空格或特殊字符。
  5. 选择该对话框底部的“使用本地 DSN”选项。
  6. 从“数据源名称 (DSN)”弹出菜单中选择要使用的 DSN。

    如果要使用本地 DSN 但却未定义本地 DSN，请单击“定义”打开 Windows ODBC 数据源管理器。有关说明，请参见创建 DSN 连接。

  7. 如果需要，请填写“用户名”和“密码”文本框。
  8. 如果需要，请单击“高级”并输入一个架构或目录名称，以限制 Dreamweaver 在设计时所检索的数据库项数。

    有关更多信息，请参见限制显示在 Dreamweaver 中的数据库信息。

    注意

    在 Microsoft Access 中不能创建架构或目录。
  9. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请复查该 DSN。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  10. 单击“确定”。

    新连接出现在“数据库”面板上。

相关主题

  • 使用远程 DSN 创建连接
  • 创建非 DSN (DSN-less) 连接
  • 数据库连接答疑

使用远程 DSN 创建连接

您可以使用在远程计算机上定义的 DSN 在 Dreamweaver 中创建数据库连接。如果要使用远程 DSN，则必须在运行应用程序服务器（可能是 IIS）的 Windows 计算机上定义该 DSN。

若要用远程定义的 DSN 创建数据库连接，请执行以下操作：

  1. 在运行应用程序服务器的远程系统上定义一个 DSN。

    有关指导，请参见 Microsoft Web 站点上的下列文章：

    • 如果远程计算机运行 Windows 2000，请参见 Microsoft 知识库文章 300596，网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;300596
    • 如果远程计算机运行 Windows XP，请参见 Microsoft 知识库文章 305599，网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;305599
  2. 在 Dreamweaver 中打开一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    Dreamweaver 显示为该站点定义的所有连接。

  3. 单击该面板上的加号 (+) 按钮，然后从弹出菜单中选择“数据源名称 (DSN)”。

    出现“数据源名称 (DSN)”对话框。

  4. 输入新连接的名称。

    注意

    不要在该名称中使用任何空格或特殊字符。
  5. 选择该对话框底部的“在测试服务器上使用 DSN”选项。

    Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用应用程序服务器上的 DSN。

  6. 输入 DSN。

    您可以单击“DSN”按钮以连接到服务器并从在它上面定义的 DSN 中进行选择。有关更多信息，请参见设置“选择 ODBC DSN”对话框选项。

  7. 如果需要，请填写“用户名”和“密码”文本框。
  8. 如果需要，请单击“高级”并输入一个架构或目录名称，以限制 Dreamweaver 在设计时所检索的数据库项数。

    有关更多信息，请参见限制显示在 Dreamweaver 中的数据库信息。

    注意

    在 Microsoft Access 中不能创建架构或目录。
  9. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请复查该 DSN。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  10. 单击“确定”。

    新连接出现在“数据库”面板上。

相关主题

  • 使用本地 DSN 创建连接
  • 创建非 DSN (DSN-less) 连接
  • 数据库连接答疑


创建非 DSN (DSN-less) 连接

您可以使用非 DSN 连接在 Web 应用程序和数据库之间创建 ODBC 或 OLE DB 连接。您将使用连接字符串来创建这类连接。连接字符串包含 Web 应用程序连接到数据库所需的全部信息。有关连接字符串的更多信息，请参见设置连接字符串选项。

若要创建非 DSN 连接，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    Dreamweaver 显示为该站点定义的所有连接（如果有）。

  2. 单击面板上的加号 (+) 按钮，然后从弹出菜单中选择“自定义连接字符串”。

    “自定义连接字符串”对话框随即出现。

  3. 完成对话框设置，然后单击“确定”。

    有关更多信息，请参见设置“自定义连接字符串”对话框选项。

相关主题

  • OLE DB 连接
  • 使用虚拟路径连接到数据库
  • 数据库连接答疑


连接到 ISP 上的数据库

如果您是通过商业 Internet 服务提供商 (ISP) 来工作的 ASP 开发人员，则通常不知道您上传的文件（包括数据库文件或文件）的物理路径。如果您的 ISP 没有为您定义 DSN 或者迟迟没有这样做，则必须找到另外一种方法来创建与数据库文件的连接。一种替代方法是创建与数据库文件的非 DSN 连接，但只有当知道数据库文件在 ISP 的服务器上的物理路径时，才能定义这样的连接。

本节介绍如何使用 ASP 服务器对象的 MapPath 方法获取数据库文件在服务器上的物理路径。本节包括以下主题：

  • 了解物理和虚拟路径
  • 用虚拟路径查找文件的物理路径
  • 使用虚拟路径连接到数据库

    注意

    只有当您的数据库基于文件（如 Microsoft Access 数据库，它将数据存储在 .mdb 文件中）时，本章讨论的方法才适用。


了解物理和虚拟路径

当使用 Dreamweaver 将文件上传到远程服务器后，这些文件驻留在服务器本地目录树中的某一个文件夹中。例如，在运行 Microsoft IIS 的服务器上，主页的路径可能如下所示：

c:\Inetpub\wwwroot\accounts\users\jsmith\index.htm

此路径通常称为文件的物理路径。

但是，用来打开文件的 URL 并不使用物理路径。它使用服务器名称或域名，后接虚拟路径，如以下示例所示：

www.plutoserve.com/jsmith/index.htm

虚拟路径 /jsmith/index.htm 代替了物理路径 c:\Inetpub\wwwroot\accounts\users\jsmith\index.htm。

相关主题

  • 用虚拟路径查找文件的物理路径
  • 使用虚拟路径连接到数据库


用虚拟路径查找文件的物理路径

如果您通过 ISP 来工作，则通常不知道您上传的文件的物理路径。ISP 通常会为您提供一个 FTP 主机（可能是主机目录）以及一个登录名和密码。ISP 还指定一个 URL，用于在 Internet 上查看您的网页，如 www.plutoserve.com/jsmith/。

如果您知道该 URL，就可以获取该文件的虚拟路径óó它是 URL 中服务器名称或域名后的路径。一旦知道虚拟路径，即可使用 MapPath 方法获取文件在服务器上的物理路径。

此外，MapPath 方法将虚拟路径当作参数，并返回文件的物理路径和文件名。该方法的语法如下：

Server.MapPath("/virtualpath")

假定一个文件的虚拟路径是 /jsmith/index.htm，那么以下表达式将返回它的物理路径：

Server.MapPath("/jsmith/index.htm")

您可以用 MapPath 方法进行如下试验。

  1. 在 Dreamweaver 中打开一个 ASP 页并切换到代码视图（“查看”>“代码”）。
  2. 在该页的 HTML 代码中输入以下表达式。
    <%Response.Write(stringvariable)%>
  3. 使用 MapPath 方法获取 stringvariable 参数的值。

    这里提供了一个示例：

    <% Response.Write(Server.MapPath("/jsmith/index.htm")) %>
  4. 切换到“设计”视图（“查看”>“设计”）并启用“动态数据”（“查看”>“动态数据”）以查看该页。

    该页显示文件在应用程序服务器上的物理路径。当使用本节讨论的示例时，该页将显示以下物理路径：

    c:\Inetpub\wwwroot\accounts\users\jsmith\index.htm

有关 MapPath 方法的更多信息，请查询 Microsoft IIS 附带的联机文档。

相关主题

  • 了解物理和虚拟路径
  • 使用虚拟路径连接到数据库


使用虚拟路径连接到数据库

若要将非 DSN 连接字符串写入位于远程服务器上的数据库文件，您必须知道该文件的物理路径。例如，下面是一个用于 Microsoft Access 的典型非 DSN 连接字符串：

Driver={Microsoft Access Driver (*.mdb)};
DBQ=c:\Inetpub\wwwroot\accounts\users\jsmith\data\statistics.mdb

如果您不知道文件在远程服务器上的物理路径，则可以通过在连接字符串中使用 MapPath 方法来获取该路径。

若要用 MapPath 方法创建非 DSN 连接，请执行以下操作：

  1. 将数据库文件上载到远程服务器。

    记下它的虚拟路径，例如 /jsmith/data/statistics.mdb。

  2. 在 Dreamweaver 中打开一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    Dreamweaver 显示为该站点定义的所有连接。

  3. 单击面板上的加号 (+) 按钮，然后从弹出菜单中选择“自定义连接字符串”。
  4. 输入新连接的名称。

    注意

    不要在该名称中使用任何空格或特殊字符。
  5. 输入连接字符串并使用 MapPath 方法提供 DBQ 参数。

    假定 Microsoft Access 数据库的虚拟路径为 /jsmith/data/statistics.mdb。如果使用 VBScript 作为脚本撰写语言，连接字符串可表示如下：

    “Driver={Microsoft Access Driver (*.mdb)};DBQ=” & Server.MapPath
("/jsmith/data/statistics.mdb")

    & 号用于串联（组合）两个字符串。第一个字符串用引号引起来，第二个字符串是由 Server.MapPath 表达式返回的。当两个字符串组合起来时，将创建以下字符串：

    Driver={Microsoft Access Driver (*.mdb)};
DBQ=C:\Inetpub\wwwroot\accounts\users\jsmith\data\statistics.mdb

    如果使用 JavaScript，表达式将基本相同，只是要使用加号 (+) 而不是 & 号来串联两个字符串：

    “Driver={Microsoft Access Driver (*.mdb)};DBQ=” + Server.MapPath
("/jsmith/data/statistics.mdb")
  6. 选择“在测试服务器上使用驱动程序”选项。

    Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用应用程序服务器。

  7. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请复查连接字符串。

    如果连接仍然失败，请与您的 ISP 联系，确保远程服务器上已经安装了您在连接字符串中指定的数据库驱动程序。另外还需要检查 ISP 是否具有该驱动程序的最新版本。例如，在 Microsoft Access 2000 中创建的数据库将无法与 Microsoft Access Driver 3.5 一起工作。您需要 Microsoft Access 驱动程序 4.0 或更高版本。

  8. 单击“确定”。

    新连接出现在“数据库”面板上。

  9. 更新现有动态页的数据库连接，并将新连接用于您新生成的任何页。

    若要更新动态页的连接，在 Dreamweaver 中打开该页，在“绑定”面板或“服务器行为”面板中双击记录集名称，然后从“连接”弹出菜单中选择您刚创建的连接。

相关主题

  • 了解物理和虚拟路径
  • 用虚拟路径查找文件的物理路径
  • 创建非 DSN (DSN-less) 连接


编辑或删除数据库连接

当您创建数据库连接后，Dreamweaver 会将连接信息存储在站点本地根文件夹下的“Connections”子文件夹中的一个包含文件中。您可以手动编辑或删除文件中的连接信息，或者执行以下操作。

若要更新连接，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    连接列表出现在该面板上。

  2. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 该连接，然后从弹出菜单中选择“编辑连接”。

    出现您曾用来创建该连接的对话框。

  3. 做出更改，然后单击“确定”。

Dreamweaver 自动更新该 包含文件，这将更新该站点中使用此连接的所有页。

若要删除连接，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    连接列表出现在该面板上。

  2. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 该连接，然后从弹出菜单中选择“删除连接”。

    出现您曾用来创建该连接的对话框。

  3. 确认您要删除该连接。

    注意

    若要避免在删除连接后出错，请在“绑定”面板中双击记录集的名称并选择新的连接，以更新每个使用旧连接的记录集。


参考资料

本节描述本章中介绍的下列对话框：

  • 设置“数据源名称 (DSN)”对话框选项
  • 设置“选择 ODBC DSN”对话框选项
  • 设置“自定义连接字符串”对话框选项
  • 设置连接字符串选项
  • 设置“连接”对话框选项
  • 使用“删除连接脚本”命令


设置“数据源名称 (DSN)”对话框选项

此对话框用于使用 DSN 为 ASP 应用程序创建数据库连接。您可以使用此对话框执行以下任务：

  • 使用本地 DSN 创建连接
  • 使用远程 DSN 创建连接

相关主题

  • 使用 DSN


设置“选择 ODBC DSN”对话框选项

此对话框用于在创建 ASP 数据库连接时选择远程服务器上的 DSN。

注意

Dreamweaver 可以只检索用 Windows ODBC 数据源管理器创建的服务器 DSN。

若要创建 DSN，请执行以下操作：

  1. 选择指向所需数据库的 DSN。
  2. 单击“确定”。

相关主题

  • 使用远程 DSN 创建连接
  • 使用 DSN


设置“自定义连接字符串”对话框选项

此对话框用于通过连接字符串定义非 DSN 数据库连接。

若要使用连接字符串定义数据库连接，请执行以下操作：

  1. 在第一个文本框中输入新连接的名称。

    注意

    不要在该名称中使用任何空格或特殊字符。
  2. 在第二个文本框中输入指向数据库的连接字符串。

    有关更多信息，请参见设置连接字符串选项。如果没有在连接字符串中指定 OLE DB 提供程序（即，没有包含 Provider 参数），ASP 将自动使用用于 ODBC 驱动程序的 OLE DB 提供程序。这种情况下，必须为数据库指定适当的 ODBC 驱动程序。

    如果您的站点由 ISP 承载，而您不知道数据库的完整路径，请在连接字符串中使用 ASP 服务器对象的 MapPath 方法。有关更多信息，请参见连接到 ISP 上的数据库。

  3. 如果在连接字符串中指定的数据库驱动程序没有与 Dreamweaver 安装在同一台计算机上，请选择“在测试服务器上使用驱动程序”选项。

    Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用应用程序服务器。

  4. 如果需要，请单击“高级”并输入一个架构或目录名称，以限制 Dreamweaver 在设计时所检索的数据库项数。

    有关更多信息，请参见限制显示在 Dreamweaver 中的数据库信息。

    注意

    在 Microsoft Access 中不能创建架构或目录。
  5. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请复查连接字符串。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  6. 单击“确定”。

    新连接出现在“数据库”面板上。

相关主题

  • 创建非 DSN (DSN-less) 连接
  • OLE DB 连接
  • 使用虚拟路径连接到数据库


设置连接字符串选项

连接字符串包含 Web 应用程序连接到数据库所需的全部信息。Dreamweaver 在页的服务器端脚本中插入该字符串，以便应用程序服务器随后进行处理。

对于 Microsoft Access 和 SQL Server 数据库，连接字符串包含由分号分隔的以下参数：

Provider 指定数据库的 OLE DB 提供程序。例如，下面分别是 Access、SQL Server 和 Oracle 数据库的常用 OLE DB 提供程序的参数：

Provider=Microsoft.Jet.OLEDB.4.0;...
Provider=SQLOLEDB;...
Provider=OraOLEDB;...

有关您的 OLE DB 提供程序的参数值，请参见提供程序供应商提供的文档或向您的系统管理员咨询。

如果没有包含“Provider”参数，则将使用 ODBC 的默认 OLE DB 提供程序，而且您必须为数据库指定适当的 ODBC 驱动程序。

Driver 指定在没有为数据库指定 OLE DB 提供程序时所使用的 ODBC 驱动程序。

Server 指定承载 SQL Server 数据库的服务器（如果您的 Web 应用程序运行在其它服务器上）。

Database 为 SQL Server 数据库的名称。

DBQ 是指向基于文件的数据库（如在 Microsoft Access 中创建的数据库）的路径。该路径是在承载数据库文件的服务器上的路径。

UID 指定用户名。

PWD 指定用户密码。

DSN 为数据源名称（如果已使用）。根据您在服务器上定义 DSN 的方式，可以省略连接字符串的其它参数。例如，如果在创建 DSN（请参见使用 DSN）时定义其它参数，则 DSN=Results 可以是有效的连接字符串。

对于其它类型的数据库，连接字符串可能不使用上面列出的参数，或者可能对于这些参数有不同的名称或用途。有关更多信息，请参见数据库供应商提供的文档或咨询您的系统管理员。

下面是一个连接字符串示例，它将创建与名为 trees.mdb 的 Access 数据库的 ODBC 连接：

Driver={Microsoft Access Driver (*.mdb)};
DBQ=C:\Inetpub\wwwroot\Research\trees.mdb

下面是一个连接字符串示例，它将创建与位于 Gojira 服务器上名为 Mothra 的 SQL Server 数据库的 OLE DB 连接：

Provider=SQLOLEDB;Server=Gojira;Database=Mothra;UID=jsmith;
PWD=orlando8

相关主题

  • 创建非 DSN (DSN-less) 连接
  • OLE DB 连接
  • 使用虚拟路径连接到数据库


设置“连接”对话框选项

此对话框用于管理站点的数据库连接。具体而言，您可以添加、编辑、删除或复制数据库连接。

注意

使用“数据库”面板可以执行相同的任务。

若要管理站点的数据库连接，请执行以下操作之一：

  • 若要添加新连接，请单击“新建”。
  • 若要删除现有连接，请在列表中选择连接，然后单击“删除”。
  • 若要更新现有连接，请在列表中选择连接，然后单击“编辑”。
  • 若要复制现有连接，请在列表中选择连接，然后单击“重制”。


使用“删除连接脚本”命令

“删除连接脚本”命令用于删除 Dreamweaver 在远程文件夹中放置的访问数据库的脚本。仅当在 Dreamweaver 中进行设计时创作才需要使用这些脚本。

在“数据库连接”对话框中选择“在测试服务器上使用驱动程序”选项或“在测试服务器上使用 DSN”选项时，Dreamweaver 会自动将一个 MMHTTPDB 脚本文件上传到测试服务器。该服务器允许 Dreamweaver 通过 HTTP 协议操作远程数据库驱动程序，这样接着可以让 Dreamweaver 获取用于帮助您创建站点所必需的数据库信息。但是，该文件也有可能会泄漏系统上定义的数据源名称（DSN）。如果 DSN 和数据库未设密码保护，该脚本将使得攻击者能够向数据库发出 SQL 命令。

MMHTTPDB 脚本文件位于 _mmServerScripts 文件夹中，该文件夹位于 Web 站点的根目录中。

注意

Dreamweaver 的文件浏览器（即“文件”面板）隐藏了 _mmServerScripts 文件夹。如果您使用的是第三方 FTP 客户端或文件浏览器，则可以看到 _mmServerScripts 文件夹。

在某些配置中，这些脚本毫无必要。在向 Web 站点的访问者提供 Web 页时并不需要这些脚本，所以不要将其放置在生产服务器上。

如果您已将 MMHTTPDB 脚本文件上传到生产服务器，那么您应该删除该 MMHTTPDB 脚本文件。“删除连接脚本”命令会为您自动删除这些脚本文件。

有关更多信息，请参见 Macromedia Web 站点上的 TechNote 19214，网址为 www.macromedia.com/go/19214。


用于 JSP 开发人员的数据库连接

若要将数据库与 JavaServer Page (JSP) 应用程序一起使用，您需要在 Macromedia Dreamweaver 8 中创建数据库连接。本章介绍如何创建该连接。

本章假设您已设置了 JSP 应用程序（请参见设置 Web 应用程序）。它还假定您已经在本地计算机（或在对其具有网络或 FTP 访问权的系统）上设置了数据库。

本章包含下列章节：

关于 JSP 中的数据库连接

连接到数据库

通过 ODBC 驱动程序连接

编辑或删除数据库连接

若要连接到 Dreamweaver 提供的示例数据库，请参见“Dreamweaver 入门”中的“示例 JSP 站点的设置”。要了解有关数据库和数据库连接的更多信息，请参见数据库初学者指南。


关于 JSP 中的数据库连接

JSP 应用程序必须通过 JDBC 驱动程序连接到某一数据库。JDBC 驱动程序充当允许 JSP 应用程序与数据库进行通信的解释器。

本节包含以下概念性主题：

  • JSP 连接
  • JDBC 连接参数


JSP 连接

JSP 应用程序必须通过 JDBC 驱动程序连接到某一数据库。有关 JDBC 和数据库驱动程序作用的更多信息，请参见与数据库进行通信。

您必须指定某些参数值以通过您的 JDBC 驱动程序进行连接。有关更多信息，请参见 JDBC 连接参数。有关特定于您的驱动程序的参数值，请参见驱动程序供应商的文档或向您的系统管理员咨询。

如果您具有 JDBC-ODBC Bridge 驱动程序，您还可以使用 ODBC 驱动程序（因此也可以使用 Windows DSN）。有关更多信息，请参见通过 ODBC 驱动程序连接。


JDBC 连接参数

在 Dreamweaver 中创建 JSP 数据库连接时，通常需要输入 JDBC 连接参数（请参见创建用于 JSP 的数据库连接）。JDBC 连接通常包含四个参数：驱动程序、用户名、密码和 URL（指定数据库的位置）。通常，驱动程序参数和 URL 参数的值取决于驱动程序。

本节以 Oracle Thin JDBC 驱动程序为例，演示如何在 Dreamweaver 中定义连接参数。有关其它驱动程序的连接参数，请查询驱动程序供应商的文档。

Oracle Thin JDBC 驱动程序支持 Oracle 数据库。如果您想要使用此驱动程序连接到您的 Oracle 数据库，请单击“数据库”面板上的加号 (+) 按钮并从弹出菜单中选择 Oracle Thin Driver (Oracle) 驱动程序。随即显示以下部分已完成的对话框：

输入连接名称并用有效的连接参数替代占位符（在方括号中）。对于 [hostname] 占位符，输入系统管理员分配给数据库服务器的 IP 地址或名称。对于 [sid] 占位符，输入数据库系统标识符。如果您在同一系统上运行多个 Oracle 数据库，则使用 SID 来区分这些数据库。

例如，如果您的服务器名为 Aristotle，数据库端口为 1521，并且您在该服务器上定义了名为 patients 的数据库 SID，则您可以在 Dreamweaver 中输入以下参数值：


连接到数据库

本节描述在 Dreamweaver 中开发 JSP 应用程序时如何连接到数据库。

本节假设 JSP 应用程序服务器正在本地或远程计算机上运行。有关更多信息，请参见设置 Web 应用程序。

在能够连接到数据库前，必须为您的数据库获取 JDBC 驱动程序。有关更多信息，请参见为您的数据库获取 JDBC 驱动程序。

在您安装了数据库驱动程序后，就可以通过该驱动程序连接到数据库。有关说明，请参见创建用于 JSP 的数据库连接。

为您的数据库获取 JDBC 驱动程序

在您尝试创建数据库连接前，确保已具有用于您的数据库的 JDBC 驱动程序。一些常见的 JDBC 驱动程序包括 Oracle Thin JDBC 驱动程序、Oracle Java Driver 和用于 Microsoft SQL Server 的 i-net JDBC 驱动程序。

数据库系统供应商（如 Oracle）通常随其系统一起提供驱动程序。您还可以从第三方供应商处购买驱动程序。例如，您可以从 i-net software 获取用于 Microsoft SQL Server 的 JDBC 驱动程序，网址为 www.inetsoftware.de/products/jdbc/。

Sun 还在其 Web 站点上提供 JDBC 驱动程序及其供应商的可搜索数据库，网址为 http://developers.sun.com/product/jdbc/drivers。

一旦具有用于您的数据库的 JDBC 驱动程序后，就可以创建数据库连接。有关说明，请参见创建用于 JSP 的数据库连接。

相关主题

  • 安装 Sun JDBC-ODBC Bridge 驱动程序
  • 与数据库进行通信

创建用于 JSP 的数据库连接

在运行应用程序服务器的计算机上安装了用于您的数据库的适当 JDBC 驱动程序后（请参见为您的数据库获取 JDBC 驱动程序），就可以在 Dreamweaver 中创建数据库连接。

若要创建用于 JSP 的数据库连接，请执行以下操作：

  1. 在 Dreamweaver 中打开 JSP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    Dreamweaver 显示为该站点定义的连接。

  2. 单击加号 (+) 按钮并从弹出菜单中选择驱动程序。

    如果没有列出您的驱动程序，请选择“自定义 JDBC 连接”。

    随即显示一个连接对话框。

  3. 在该连接对话框中输入连接参数。

    有关更多信息，请参见 JDBC 连接参数。

  4. 指定您要使用的 JDBC 驱动程序的位置。
    • 如果您的 JDBC 驱动程序安装在与 Dreamweaver 相同的计算机上，则选择“在此计算机上使用驱动程序”选项。
    • 如果您的 JDBC 驱动程序没有安装在与 Dreamweaver 相同的计算机上，则选择“在测试服务器上使用驱动程序”选项。

    Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用应用程序服务器。

  5. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请复查连接参数。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  6. 单击“确定”。

新连接出现在“数据库”面板上。

相关主题

  • 数据库连接答疑


通过 ODBC 驱动程序连接

尽管 JSP 应用程序必须通过 JDBC 驱动程序与数据库通信，但如果您具有 JDBC-ODBC 桥驱动程序，则 JSP 应用程序可以通过 ODBC 驱动程序通信。JDBC-ODBC 桥驱动程序充当 JSP 应用程序（与 JDBC 通信）和 ODBC 驱动程序（与 ODBC 通信）之间的解释器。此通信方式使您的 JSP 应用程序可与数据库通信。

对于 Windows 用户，此类型的连接有两个优点。首先，您可以使用 Microsoft 提供的免费 ODBC 驱动程序。其次，您可以使用 DSN 简化创建连接的任务。

要通过 ODBC 驱动程序进行连接，您必须满足以下条件：

  • 您的 JSP 应用程序服务器必须运行在 Windows 计算机上。
  • 用于您的数据库的 ODBC 驱动程序必须安装在运行应用程序服务器的 Windows 计算机上。有关更多信息，请参见检查 ODBC 驱动程序。
  • JDBC-ODBC 桥驱动程序必须安装在运行应用程序服务器的 Windows 计算机上。有关更多信息，请参见安装 Sun JDBC-ODBC Bridge 驱动程序。

如果您满足了这些要求，就可以通过 ODBC 驱动程序进行连接了。有关说明，请参见创建 ODBC 连接。

检查 ODBC 驱动程序

确保用于您的数据库的 ODBC 驱动程序安装在运行 JSP 应用程序服务器的 Windows 计算机上。若要确定是否已安装 ODBC 驱动程序，请参见查看安装在 Windows 系统上的 ODBC 驱动程序。如果尚未安装适当的驱动程序，则您可以在运行 JSP 应用程序服务器的计算机上下载和安装 Microsoft Data Access Components (MDAC) 2.5 和 2.7 程序包。可以从 Microsoft Web 站点免费下载 MDAC，网址为 http://msdn.microsoft.com/data/mdac/downloads/。这些程序包包含 Microsoft 提供的最新 ODBC 驱动程序。

注意

在安装 MDAC 2.7 前安装 MDAC 2.5 软件包

如果您具有用于您的数据库的 ODBC 驱动程序，则接下来您可以安装 JDBC-ODBC 驱动程序。有关说明，请参见安装 Sun JDBC-ODBC Bridge 驱动程序。

安装 Sun JDBC-ODBC Bridge 驱动程序

若要通过 ODBC 驱动程序进行连接，您必须在运行 JSP 应用程序服务器的 Windows 计算机上安装 Sun JDBC-ODBC 桥驱动程序。该驱动程序和用于 Windows 的 Sun Java 2 SDK 标准版一起提供。

若要确定是否已具有带有该驱动程序的 Java 2 SDK，请检查您的硬盘上是否有以下文件夹中的任何一个：jdk1.2、jdk1.3 或 j2sdk1.4。

如果没有 SDK，您可以从 Sun Web 站点（网址为 http://java.sun.com/j2se/）下载 SDK 并进行安装。在安装 SDK 时系统将自动安装驱动程序。

尽管 Sun JDBC-ODBC Bridge 驱动程序用于开发低端数据库系统（例如 Microsoft Access）绰绰有余，但它不适用于进行生产。例如，该驱动程序一次只让一个 JSP 页连接到数据库（它不支持多个线程并发使用）。有关驱动程序限制的更多信息，请参见 Macromedia 支持中心上的文章 TechNote 17392，网址为 www.macromedia.com/go/17392。

在安装了桥驱动程序后，您接下来就可以创建数据库连接了。有关说明，请参见创建 ODBC 连接。

创建 ODBC 连接

在通过 ODBC 驱动程序进行连接前，请确保在运行 JSP 应用程序服务器的 Windows 计算机上安装了适当的 ODBC 驱动程序和 Sun JDBC-ODBC Bridge 驱动程序（请参见检查 ODBC 驱动程序和安装 Sun JDBC-ODBC Bridge 驱动程序）。

若要在 JSP 中通过 ODBC 驱动程序进行连接，请执行以下操作：

  1. 在承载您的应用程序服务器的 Windows 系统上定义 DSN。

    有关指导，请参见 Microsoft Web 站点上的下列文章：

    • 对于 Windows 2000 用户，请参见 Microsoft 知识库文章 300596，网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;300596
    • 对于 Windows XP 用户，请参见 Microsoft 知识库文章 305599，网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;305599
  2. 在 Dreamweaver 中打开 JSP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    该面板显示为该站点定义的连接。

  3. 在该面板上单击加号 (+) 按钮并从弹出菜单中选择“Sun JDBC-ODBC 驱动程序（ODBC 数据库）”。

    “Sun JDBC-ODBC 驱动程序（ODBC 数据库）”对话框随即显示。

  4. 输入新连接的名称。

    注意

    不要在该名称中使用任何空格或特殊字符。
  5. 用您在第 1 步中定义的 DSN 替代“URL”框中的 [odbc dsn] 占位符。

    “URL”框应类似于：

    jdbc:odbc:myDSN
  6. 指定用来访问数据库的用户名和密码。

    如果您不需要用户名或密码，则保留这些框为空。例如，如果您的 DSN 名为 Acme 并且您不需要用户名或密码来访问数据库，则输入以下参数值：

    驱动程序：sun.jdbc.odbc.JdbcOdbcDriver

    URL：jdbc:odbc:Acme

    用户名：

    密码：

  7. 指定 JDBC-ODBC Bridge 驱动程序的位置。
    • 如果该驱动程序安装在与 Dreamweaver 相同的计算机上，则选择“在此计算机上使用驱动程序”选项。
    • 如果该驱动程序没有安装在与 Dreamweaver 相同的计算机上，则选择“在测试服务器上使用驱动程序”选项。

    Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用应用程序服务器。

  8. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请复查 DSN 和其它连接参数。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  9. 单击“确定”。

    新连接出现在“数据库”面板上。

相关主题

  • 数据库连接答疑


编辑或删除数据库连接

当您创建数据库连接后，Dreamweaver 会将连接信息存储在站点本地根文件夹下的“Connections”子文件夹中的一个包含文件中。您可以手动编辑或删除文件中的连接信息，或者执行以下操作。

若要更新连接，请执行以下操作：

  1. 在 Dreamweaver 中打开 JSP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    连接列表出现在该面板上。

  2. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 该连接，然后从弹出菜单中选择“编辑连接”。

    出现您曾用来创建该连接的对话框。

  3. 做出更改，然后单击“确定”。

Dreamweaver 自动更新该 包含文件，这将更新该站点中使用此连接的所有页。

如果您重命名一个连接，则应通过在“绑定”面板中双击记录集并在“记录集”对话框中选择新连接名称，更新使用旧连接名称的每一记录集。

若要删除连接，请执行以下操作：

  1. 在 Dreamweaver 中打开 JSP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    连接列表出现在该面板上。

  2. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 该连接，然后从弹出菜单中选择“删除连接”。

    出现您曾用来创建该连接的对话框。

  3. 确认您要删除该连接。

若要避免在删除一个连接后收到错误信息，请通过在“绑定”面板中双击记录集的名称并在“记录集”对话框中选择新连接，更新使用旧连接的每一记录集。


参考资料

本节描述本章中介绍的以下对话框：

  • 设置 JSP 连接对话框选项


设置 JSP 连接对话框选项

此对话框用于为 JSP 应用程序创建数据库连接。

若要创建数据库连接，请执行以下操作：

  1. 输入连接的名称。

    注意

    不要在该名称中使用任何空格或特殊字符。
  2. 输入驱动程序的连接参数。

    有关示例，请参见 JDBC 连接参数。有关特定于驱动程序的要求，请参见驱动程序供应商的文档或向您的系统管理员咨询。

  3. 指定您要使用的 JDBC 驱动程序的位置。
    • 如果您的 JDBC 驱动程序安装在与 Dreamweaver 相同的计算机上，则选择“在此计算机上使用驱动程序”选项。
    • 如果您的 JDBC 驱动程序没有安装在与 Dreamweaver 相同的计算机上，则选择“在测试服务器上使用驱动程序”选项。

      注意

      Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用应用程序服务器。
  4. 如果需要，请单击“高级”并输入一个架构或目录名称，以限制 Dreamweaver 在设计时所检索的数据库项数。

    有关更多信息，请参见限制显示在 Dreamweaver 中的数据库信息。

    注意

    在 Microsoft Access 中不能创建架构或目录。
  5. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请复查 JDBC 连接参数。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  6. 单击“确定”。

    新连接出现在“数据库”面板上。

相关主题

  • 为您的数据库获取 JDBC 驱动程序
  • JDBC 连接参数
  • 通过 ODBC 驱动程序连接


适用于 PHP 开发人员的数据库连接

若要将数据库与 PHP 应用程序一起使用，需要在 Macromedia Dreamweaver 8 中创建数据库连接。本章将描述如何创建数据库连接。

对于 PHP 开发，Dreamweaver 仅支持 MySQL 数据库系统。不支持其它数据库系统，如 Microsoft Access 或 Oracle。MySQL 是可以从 Internet 免费下载并进行非商业应用的开放源码软件。有关更多信息，请参见 MySQL Web 站点，网址为 http://dev.mysql.com/downloads/。

本章假设您已设置了 PHP 应用程序（请参见设置 Web 应用程序）。还假定已在本地计算机或对其具有网络或 FTP 访问权的系统上设置了 MySQL 数据库。

提示

出于开发目的，请下载并安装 MySQL 数据库服务器的 Windows Essentials 版本。

本章包含下列章节：

连接到数据库

编辑或删除数据库连接

若要连接到 Dreamweaver 提供的示例数据库，请参见“Dreamweaver 入门”中的“示例 PHP 站点的设置”。要了解有关数据库和数据库连接的更多信息，请参见数据库初学者指南。


连接到数据库

本节描述在 Dreamweaver 中开发 PHP 应用程序时如何连接到数据库。假定您有一个或多个 MySQL 数据库并已启动 MySQL 服务器。

若要创建到 MySQL 数据库的数据库连接，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 PHP 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 单击面板上的加号 (+) 按钮并从弹出菜单中选择“MySQL 连接”。

    “MySQL 连接”对话框随即出现。

  3. 完成对话框设置，然后单击“确定”。

    有关更多信息，请参见设置“MySQL 连接”对话框选项。

新连接出现在“数据库”面板上。

注意

在测试到 MySQL 4.1 的 PHP 数据库连接时，如果遇到错误消息“客户端不支持请求的验证协议。请考虑升级 MySQL 客户端。”，请参见 MySQL 错误信息答疑。


编辑或删除数据库连接

当您创建数据库连接后，Dreamweaver 会将连接信息存储在站点本地根文件夹下的“Connections”子文件夹中的一个包含文件中。您可以手动编辑或删除文件中的连接信息，或者执行以下操作。

若要更新连接，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 PHP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    连接列表出现在该面板上。

  2. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 该连接，然后从弹出菜单中选择“编辑连接”。

    出现您曾用来创建该连接的对话框。

  3. 做出更改，然后单击“确定”。

Dreamweaver 自动更新该 包含文件，这将更新该站点中使用此连接的所有页。

若要删除连接，请执行以下操作：

  1. 在 Dreamweaver 中打开一个 PHP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    连接列表出现在该面板上。

  2. 右键单击 (Windows) 或按住 Control 键并单击 (Macintosh) 该连接，然后从弹出菜单中选择“删除连接”。

    出现您曾用来创建该连接的对话框。

  3. 确认您要删除该连接。

若要避免在删除一个连接后收到错误信息，请更新使用旧连接的每一记录集，方法是在“绑定”面板中双击记录集的名称并在“记录集”对话框中选择新连接。


参考资料

本节描述本章中介绍的下列对话框：

  • 设置“MySQL 连接”对话框选项
  • 设置“选择数据库”对话框选项


设置“MySQL 连接”对话框选项

此对话框用于为 PHP 应用程序创建数据库连接。

完成此对话框之前，请确保已启动 MySQL 服务器。

若要创建数据库连接，请执行以下操作：

  1. 输入新连接的名称。

    注意

    不要在该名称中使用任何空格或特殊字符。
  2. 在“MySQL 服务器”框中，指定承载 MySQL 的计算机。

    输入 IP 地址或服务器名称。如果 MySQL 与 PHP 运行在同一台计算机上，则可输入 localhost。

  3. 输入您的 MySQL 用户名和密码。
  4. 在“数据库”框中输入数据库名称，或者单击“选择”并从 MySQL 数据库列表中选择数据库。
  5. 单击“测试”。

    Dreamweaver 尝试连接到数据库。如果连接失败，请复查服务器名称、用户名和密码。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  6. 单击“确定”。

    新连接出现在“数据库”面板上。

    注意

    在测试到 MySQL 4.1 的 PHP 数据库连接时，如果遇到错误消息“客户端不支持请求的验证协议。请考虑升级 MySQL 客户端。”，请参见 MySQL 错误信息答疑。

相关主题

  • 连接到数据库


设置“选择数据库”对话框选项

此对话框用于在创建 PHP 数据库连接时从 MySQL 数据库系统中选择一个数据库。

若要选择一个数据库，请执行以下操作：

  • 从列表中选择一个数据库并单击“确定”。

相关主题

  • 设置“MySQL 连接”对话框选项


数据库连接答疑

本章介绍在创建数据库连接后可能会遇到的一些常见问题，并介绍解决这些问题的方法。本章包括以下几节：

权限问题答疑

Microsoft 错误信息答疑

MySQL 错误信息答疑


权限问题答疑

最常见的问题之一是文件夹或文件权限不足。如果您的数据库位于 Windows 2000 或 Windows XP 计算机上，并且您在尝试从 Web 浏览器或以“动态数据”模式查看动态页时收到错误信息，则该错误可能是由权限问题引起的。

试图访问数据库的 Windows 帐户没有足够的权限。如果已针对经过身份验证的访问对该页设置了保护，则该帐户可能是匿名 Windows 帐户（默认情况下为 IUSR_computername）或特定的用户帐户。

您必须更改权限，向 IUSR_computername 帐户提供正确的权限，这样 Web 服务器才能访问该数据库文件。此外，包含该数据库文件的文件夹还必须设置某些权限才能向该数据库写入。

如果该页打算以匿名方式来访问，则请向 IUSR_computername 帐户提供对该文件夹和数据库文件的完全控制权限，如以下步骤所述。

此外，如果使用 UNC (\\Server\Share) 引用数据库的路径，请确保“共享权限”向 IUSR_computername 帐户提供完全访问权限。即使共享位于本地 Web 服务器，此步骤仍然适用。

如果从另一个位置复制数据库，它可能不会自动从目标文件夹继承权限。您可能需要更改数据库的权限。

若要检查或更改数据库文件权限，请执行以下操作 (Windows XP)：

  1. 确保您在计算机上拥有管理员权限。
  2. 在 Windows 资源管理器中，找到该数据库文件或包含该数据库的文件夹，右键单击该文件或文件夹，然后选择“属性”。
  3. 选择“安全”选项卡。

    注意

    此步骤仅适用于 NTFS 文件系统中。如果是 FAT 文件系统，则该对话框没有“安全”选项卡。
  4. 如果 IUSR_computername 帐户未在“组或用户名称”列表中列出，请单击“添加”按钮来添加该帐户。
  5. 在“选择用户或组”对话框中，单击“高级”按钮。

    对话框随即更改以显示更多的选项。

  6. 单击“位置”按钮并选择计算机名称。
  7. 单击“开始查找”按钮。

    出现与该计算机关联的帐户名称的列表。

  8. 选择 IUSR_computername 帐户并单击“确定”，然后再次单击“确定”以清除该对话框。
  9. 若要为 IUSR 帐户分配完全权限，请选择“完全控制”复选框，然后单击“确定”。

若要检查或更改数据库文件权限，请执行以下操作 (Windows 2000)：

  1. 确保您在计算机上拥有管理员权限。
  2. 在 Windows 资源管理器中，找到该数据库文件或包含该数据库的文件夹，右键单击该文件或文件夹，然后选择“属性”。
  3. 选择“安全”选项卡。

    注意

    此步骤仅适用于 NTFS 文件系统中。如果是 FAT 文件系统，则该对话框没有“安全”选项卡。
  4. 如果“文件权限”对话框中的 Windows 帐户中没有列出 IUSR_computername 帐户，请单击“添加”按钮添加该帐户。
  5. 在“选择用户、计算机或组”对话框中，从“查看”弹出菜单中选择计算机名称。

    出现与该计算机关联的帐户名称的列表。

  6. 选择 IUSR_computername 帐户，然后单击“添加”。
  7. 若要给 IUSR 帐户分配完全权限，请从“访问类型”弹出菜单中选择“完全控制”，然后单击“确定”。

对于所添加的安全设置，可以设置权限，以便对包含该数据库的 Web 文件夹关闭读权限。浏览该文件夹将被拒绝，但 Web 页仍可以访问该数据库。

有关 IUSR 帐户和 Web 服务器权限的更多信息，请参见 Macromedia 支持中心上的技术说明：

  • Understanding anonymous authentication and the IUSR account（了解匿名身份验证和 IUSR 帐户），网址为 www.macromedia.com/go/authentication
  • Setting IIS web server permissions（设置 IIS Web 服务器权限），网址为 www.macromedia.com/go/server_permissions


Microsoft 错误信息答疑

本节介绍一些常见的 Microsoft 错误信息以及修正这些错误的方法。如果您将 Internet Information Server (IIS) 与 Microsoft 数据库系统（例如 Access 或 SQL Server）一起使用，则可能发生这些错误。这些错误通常在您向服务器请求动态页时发生。

注意

Macromedia 不对 Microsoft Windows 和 IIS 等第三方软件提供技术支持。如果本节内容无法解决您的问题，请与 Microsoft 技术支持部门联系或访问 Microsoft 支持 Web 站点，网址为 http://support.microsoft.com/。

本节将讨论以下错误信息：

  • 80004005 - 未找到数据源名称并且未指定默认驱动程序（此错误信息的其它形式包括“80004005 - 驱动程序的 SQLSetConnectAttr 失败”和“80004005 - 常规错误：无法打开注册表项‘DriverId’”）
  • 80004005 - 无法使用“（未知）”；文件已在使用中（另一种形式为“80004005 - Microsoft Jet 数据库引擎无法打开文件（未知）”）
  • 80004005 - 登录失败()
  • 80004005 - 操作必须使用可更新的查询
  • 80040e07 - 条件表达式中数据类型不匹配
  • 80040e10 - 参数太少
  • 80040e10 - COUNT 字段不正确
  • 80040e14 - INSERT INTO 语句中出现语法错误
  • 80040e21 - 插入或更新时出现 ODBC 错误
  • 800a0bcd - BOF 或 EOF 为真

有关 80004005 错误的更多信息，请参见“INFO:Troubleshooting Guide for 80004005 Errors in Active Server Pages and Microsoft Data Access Components (Q306518)”（INFO：关于 Active Server Pages 和 Microsoft Data Access Components 中的 80004005 错误的答疑指导 (Q306518)），它位于 Microsoft Web 站点 http://support.microsoft.com/default.aspx?scid=kb;en-us;Q306518。


80004005 - 未找到数据源名称并且未指定默认驱动程序

当您试图在 Web 浏览器中或以“动态数据”模式查看动态页时，会出现此错误。根据您的数据库和 Web 服务器的具体情况，该错误信息可能有所不同。其它形式包括：

  • 80004005 - 驱动程序的 SQLSetConnectAttr 失败
  • 80004005 - 常规错误：无法打开注册表项“DriverId”

可能的原因和解决方案如下：

  • 页面无法找到 DSN。确保已经在 Web 服务器和本地计算机上创建了 DSN。有关更多信息，请参见使用 DSN。
  • DSN 可能已设置为用户 DSN，而不是系统 DSN。请删除用户 DSN 并创建一个系统 DSN 取代它。

    注意

    如果不删除用户 DSN，则重复的 DSN 名称会产生新的 ODBC 错误。
  • 如果使用 Microsoft Access，则可能数据库文件 (.mdb) 已锁定。此锁定可能是因不同名称的 DSN 访问该数据库引起的。在 Windows 资源管理器中，从包含数据库文件 (.mdb) 的文件夹中搜索锁定文件 (.ldb) 并删除该 .ldb 文件。如果另一个 DSN 正指向同一数据库文件，则最好删除该 DSN，以防止以后出错。进行以上更改后务必要重新启动计算机。


80004005 - 无法使用“（未知）”；文件已在使用中

当您使用 Microsoft Access 数据库并试图在 Web 浏览器中或以“动态数据”模式查看动态页时，会出现此错误。此错误信息的另一形式为“80004005 - Microsoft Jet 数据库引擎无法打开文件（未知）”。

可能的原因是存在权限问题。有关更多信息，请参见权限问题答疑。具体的原因和解决方案如下：

  • Internet Information Server 所使用的帐户（通常是 IUSR）对于某个基于文件的数据库或包含该文件的文件夹可能没有正确的 Windows 权限。请在用户管理器中检查该 IIS 帐户 (IUSR) 的权限。
  • 您可能没有创建或销毁临时文件所需的权限。请检查对该文件和文件夹的权限。确保您具有创建或销毁任何临时文件所需的权限。临时文件通常创建在数据库所在的文件夹中，但也可能创建到其它文件夹（如 /Winnt）中。
  • 在 Windows 2000 中，可能需要为 Access 数据库 DSN 更改超时值。若要更改超时值，请选择“开始”>“设置”>“控制面板”>“管理工具”>“数据源 (ODBC)”。单击“系统”选项卡，突出显示正确的 DSN，然后单击“配置”按钮。单击“选项”按钮并将“页超时”值更改为 5000。

如果仍然有问题，请参见下面的 Microsoft 知识库文章：

  • PRB:80004005 “Couldn't Use‘(unknown)’; File Already in Use”（“无法使用‘（未知）’，文件已在使用中”），其网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;Q174943。
  • PRB:Microsoft Access Database Connectivity Fails in Active Server Pages（Active Server Pages 中的 Microsoft Access 数据库连接失败），其网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;Q253604。
  • PRB:Error“Cannot Open File Unknown”Using Access（使用 Access 时出现“无法打开未知文件”错误），http://support.microsoft.com/default.aspx?scid=kb;en-us;Q166029。


80004005 - 登录失败()

当您使用 Microsoft SQL Server 并试图在 Web 浏览器中或以“动态数据”模式查看动态页时，会出现此错误。

如果 SQL Server 不接受或不识别您所提交的登录帐户或密码（假定您使用的是标准安全机制），或者如果 Windows NT 帐户没有映射到 SQL 帐户（假定您使用的是集成安全机制），则 SQL Server 会产生此错误。

可能的解决方案如下：

  • 如果使用标准安全机制，则可能是帐户名称和密码不正确。请尝试使用系统管理员帐户和密码（UID=“sa”且无密码），但这必须在连接字符串语句行中定义。（DSN 不存储用户名和密码。）
  • 如果使用集成安全机制，则请检查调用该页的 Windows 帐户，并找到它映射的 SQL 帐户（如果存在）。
  • SQL Server 不允许在 SQL 帐户名称中使用下划线。如果有人手动将 Windows IUSR_machinename 帐户映射到同名的 SQL 帐户，则会失败。应该将所有使用下划线的帐户映射到 SQL 上不使用下划线的帐户名称。


80004005 - 操作必须使用可更新的查询

当事件更新记录集或在记录集中插入数据时会发生此错误。

可能的原因和解决方案如下：

  • 对包含数据库的文件夹所设置的权限具有太多限制。IUSR 特权必须设置为读/写。（请参见权限问题答疑。）
  • 对数据库文件本身的权限未使完全的读/写特权生效。（请参见权限问题答疑。）
  • 数据库可能位于 Inetpub/wwwroot 目录之外。如果数据库不在 wwwroot 目录中，则您可以查看和搜索数据，但不能更新数据。
  • 记录集基于不可更新的查询。联接正是数据库中的一种不可更新查询。请重新构造查询，以使其可以更新。

有关此错误的更多信息，请参见“PRB:ASP 'Error The Query Is Not Updateable' When You Update Table Record”（PRB：更新表记录时出现 ASP 错误“查询不可更新”），它位于 Microsoft 知识库中，网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;Q174640。


80040e07 - 条件表达式中数据类型不匹配

当服务器尝试处理包含“插入记录”或“更新记录”服务器行为的页面，并且该服务器行为试图将 Microsoft Access 数据库中“日期/时间”列的值设置为空字符串 ("") 时，会出现此错误。

Microsoft Access 具有强数据类型；对于给定的列值有一套严格的规则。SQL 查询中的空字符串值不能存储在 Access“日期/时间”列中。目前已知的唯一解决方法，是避免将空字符串 ("") 或其它任何与该数据类型的指定值范围不对应的值插入 Access 中的“日期/时间”列，也不要使用这些值更新“日期/时间”列。


80040e10 - 参数太少

当数据库表中不存在 SQL 查询中所指定的列时，会出现此错误。请对照 SQL 查询检查数据库表中的列名称。此错误通常是因拼写错误引起。


80040e10 - COUNT 字段不正确

当您在 Web 浏览器中预览包含“插入记录”服务器行为的页并尝试使用它在 Microsoft Access 数据库中插入记录时，此错误会出现。

您可能试图将记录插入字段名中包含问号 (?) 的数据库字段。对于某些数据库引擎（包括 Microsoft Access），问号是特殊字符，不应将它用于数据库表或字段的名称。

打开数据库系统并从字段名中删除问号 (?)，然后更新页上引用该字段的服务器行为。


80040e14 - INSERT INTO 语句中出现语法错误

当服务器尝试处理包含“插入记录”服务器行为的页时，会发生此错误。

此错误通常是因数据库中字段、对象或变量的名称存在以下一个或多个问题所致：

  • 将保留字用作名称。大多数数据库都有一组保留字。例如，“date”是保留字，因而不能用于数据库中的列名称。
  • 名称中使用特殊字符。特殊字符的示例包括：

    . / * : ! # & - ?

  • 在名称中使用空格。

当为数据库中的对象定义了输入掩码并且插入的数据与该掩码不符时，也会出现此错误。

若要解决该问题，在指定数据库中的列名称时，请避免使用“date”、“name”、“select”、“where”和“level”等保留字。另外，请清除空格和特殊字符。

有关常见数据库系统的保留字的列表，请参见以下 Web 页：

  • Microsoft Access，其网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;Q209187
  • Microsoft SQL Server，其网址为 http://msdn.microsoft.com/library/default.asp?url=/library/en-us/tsqlref/ts_ra-rz_9oj7.asp
  • MySQL，其网址为 http://dev.mysql.com/doc/mysql/en/reserved-words.html


80040e21 - 插入或更新时出现 ODBC 错误

当服务器尝试处理包含“更新记录”或“插入记录”服务器行为的页时，会出现此错误。数据库无法处理该服务器行为尝试执行的更新或插入操作。

可能的原因和解决方案如下：

  • 该服务器行为正尝试更新数据库表的自动编号字段或者尝试在自动编号字段中插入记录。由于自动编号域由数据库系统自动填充，因此任何从外部用值填充这些域的尝试都会失败。
  • 服务器行为正在更新或插入的数据对于该数据库字段而言是错误的类型，例如将日期插入布尔型（是/否）字段，将字符串插入数值字段，或者将格式不正确的字符串插入“日期/时间”字段。


800a0bcd - BOF 或 EOF 为真

当您试图在 Web 浏览器中或以“动态数据”模式查看动态页时，此错误会出现。

该问题在动态页试图显示空记录集中的数据时出现。若要解决该问题，请将“显示区域”服务器行为应用于要在页上显示的动态内容，如下所述：

  1. 突出显示页上的动态内容。
  2. 在“服务器行为”面板上，单击加号 (+) 按钮并选择“显示区域”>“如果记录集不为空则显示区域”。
  3. 选择提供动态内容的记录集并单击“确定”。
  4. 对于页上的每个动态内容元素重复步骤 1 至 3。


MySQL 错误信息答疑

本节陈述了在测试到 MySQL 4.1 的 PHP 数据库连接时可能会遇到的一条常见错误信息：“客户端不支持请求的验证协议。请考虑升级 MySQL 客户端。”

您可能必须回复到较早的 MySQL 版本，或者安装 PHP 5 并复制一些动态链接库 (DLL)。有关详细说明，请参见“Dreamweaver 入门”中的安装 PHP 应用程序服务器 (Windows)。

另请参见 Macromedia Web 站点上的以下 TechNote：

  • TechNote c45f8a29，网址为 www.macromedia.com/go/c45f8a29。
  • TechNote 16515，网址为 www.macromedia.com/go/16515。


生成动态页

使用 Macromedia Dreamweaver 8 中的 Web 应用程序开发工具，向页面添加动态内容。

此部分包含以下各章：

为可视化开发优化工作区

动态页设计工作流程

为页面获取数据

定义动态内容源

向 Web 页中添加动态内容

显示数据库记录

在 Web 页面中显示 XML 数据

使用 Web 服务

添加自定义服务器行为

创建表单


为可视化开发优化工作区

您可优化 Macromedia Dreamweaver 8 工作区以可视地开发 Web 应用程序。例如，可以使用面板快速地生成动态页，并且可以在工作时查看页面上的动态数据。

本章包含下列章节：

显示 Web 应用程序开发面板

在 Dreamweaver 中查看数据库

在“设计”视图中查看动态数据

在不显示动态数据的“设计”视图中工作

在浏览器中预览动态页

限制显示在 Dreamweaver 中的数据库信息


显示 Web 应用程序开发面板

单击“插入”栏中的“应用程序”选项卡，以显示一组使您能够将动态内容和服务器行为添加到页面中的按钮，如图所示。

显示的按钮的数量和类型取决于在“文档”窗口中打开的文档类型。“插入”栏中包括可将下列项添加到页面中的按钮：

  • 记录集
  • 动态文本或表
  • 向数据库插入记录或更新其中记录的表单
  • 记录导航条

如果您切换到“代码”视图（“查看”>“代码”），附加的面板可能会显示在各自的“插入”栏类别中，以允许您在页面中插入代码。例如，如果您在“代码”视图中查看 ColdFusion 页，CFML 面板将在“插入”栏的“CFML”类别中变为可用：

若要知道“插入”栏上每个按钮表示的功能，请将鼠标光标移到图标上。此时会出现以下工具提示：

如果希望为页面定义动态内容的源，并将该内容添加到页面中，请选择“窗口”>“绑定”。出现“绑定”面板。

有关更多信息，请参见设置“绑定”面板选项。

如果希望向动态页添加服务器端逻辑，请选择“窗口”>“服务器行为”。出现“服务器行为”面板。

服务器行为是在设计时插入到动态页中的指令组，这些指令在运行时于服务器上执行。有关更多信息，请参见设置“服务器行为”面板选项。

如果希望研究数据库或创建数据库连接，请选择“窗口”>“数据库”。出现“数据库”面板。

有关更多信息，请参见设置“数据库”面板选项。

如果要检查、添加或修改 JavaBean、Macromedia ColdFusion 组件或 Web 服务的代码，请选择“窗口”>“组件”。出现“组件”面板。

注意

“组件”面板只有在您打开 ColdFusion、JSP 或 ASP.NET 页时才被启用。另外，文档有可能不支持某些组件。例如，ColdFusion 文档不支持 JavaBeans。

有关更多信息，请参见设置“组件”面板选项。


在 Dreamweaver 中查看数据库

在连接到数据库后，可在 Dreamweaver 中查看其结构与数据。

若要查看数据库，请执行以下操作：

  1. 打开“数据库”面板（“窗口”>“数据库”）。

    Dreamweaver 会用已为其创建连接的所有数据库填充“数据库”面板。如果您正在开发 ColdFusion 站点，Dreamweaver 会用已在“ColdFusion 管理员”中为其定义了数据源的所有数据库填充该面板。

    注意

    Dreamweaver 可搜索您为当前站点定义的 ColdFusion 服务器。（请参见指定可在哪里处理动态页。）

    如果在该面板中没有显示任何数据库，则您必须创建一个数据库连接。有关更多信息，请参见连接到数据库。

  2. 若要显示数据库中的表、预存过程和视图，请单击列表中连接旁的加号 (+)。
  3. 若要显示表中的列，请单击表。

    列图标可反映数据类型，也可指示主键。

  4. 若要查看表中的数据，请右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 列表中的表名称，然后从弹出菜单中选择“查看数据”。

    Dreamweaver 也可识别每张表的主键和每一列的数据类型。


在“设计”视图中查看动态数据

当您在“设计”视图中处理页面时，Dreamweaver 可以显示页的动态内容。有关“设计”视图的更多信息，请参见在“文档”窗口中的视图间进行切换。

若要在“设计”视图中查看动态内容，请执行以下操作：

  1. 确保 Dreamweaver 正确配置为显示动态数据。

    有关更多信息，请参见显示动态数据的要求。

  2. 选择“查看”>“动态数据”。

    Dreamweaver 将在“设计”视图中显示具有动态内容的完整页面。

当在“设计”视图中启用“动态数据”后，可进行以下操作：

  • 使用页面设计工具调整页面的布局
  • 添加、编辑或删除动态内容
  • 添加、编辑或删除服务器行为

    注意

    链接在“设计”视图中不起作用。若要测试链接，请使用“在浏览器中预览”功能。（请参见在浏览器中预览动态页。）

在您对页面进行的更改影响到动态内容时，可通过单击“刷新”按钮（环形箭头图标）刷新该页面。Dreamweaver 也可自动为您刷新页面。

下面的插图显示了禁用“动态数据”的动态页：

下面的插图显示了启用“动态数据”的同一页：

相关主题

  • 显示动态数据的要求
  • 复制相关文件
  • 向页提供所需参数
  • 刷新页
  • “动态数据”视图答疑
  • 在不显示动态数据的“设计”视图中工作


显示动态数据的要求

若要在“设计”视图中查看动态数据，您必须进行以下操作：

  • 定义一个文件夹以处理动态页。有关说明，请参见指定可在哪里处理动态页。

    在启用“动态数据”后，打开的文档的一份临时副本将被发送到该文件夹进行处理。结果页将被返回并显示在“设计”视图中，服务器上的那份临时副本则被删除。

    如果在启用“动态数据”时该页显示错误信息，请确保“站点定义”对话框中的 URL 前缀是正确的。有关更多信息，请参见连接到数据库。

  • 将相关文件（如果有的话）复制到该文件夹。有关更多信息，请参见复制相关文件。
  • 向页提供用户通常将提供的所有参数。有关说明，请参见向页提供所需参数。

如果在运行“动态数据”视图时遇到困难，请参见“动态数据”视图答疑。

相关主题

  • 在“设计”视图中查看动态数据
  • 在不显示动态数据的“设计”视图中工作


复制相关文件

有些动态页依赖于其它文件才可正常运行。必须将所有相关文件（包括 server-side include（服务器端包括）以及诸如图像文件和 JSP 类文件的相关文件）都上传到为处理动态页所定义的文件夹（请参见指定可在哪里处理动态页）中。您在“设计”视图中启用“动态数据”时，Dreamweaver 不会将相关文件自动复制到该文件夹。

注意

“动态数据”可支持 server-side includes 以及诸如 global.asa (ASP) 和 application.cfm (ColdFusion) 的应用程序文件中的代码。请确保在启用“动态数据”之前将这些文件上传到服务器。

若要将相关文件复制到应用程序服务器，请执行以下操作：

  1. 打开“站点”面板（“窗口”>“站点文件”），然后单击“扩展”按钮（面板工具栏上的最后一个图标）。

    “站点”面板将展开到最大。

  2. 单击展开的“站点”窗口工具栏上的“应用程序服务器”图标（左起第二个图标）。

    应用程序服务器的根文件夹将出现在“远端站点”下。

  3. 在“本地文件夹”下，选择相关文件。
  4. 单击工具条上的蓝色向上箭头，将这些文件复制到应用程序服务器，或将这些文件拖动到“远程站点”下的相应文件夹中。

只需为站点进行一次此操作，除非您要添加更多的相关文件，在这种情况下，您必须也将它们复制到该文件夹。

相关主题

  • 在“设计”视图中查看动态数据
  • 显示动态数据的要求
  • 向页提供所需参数
  • 刷新页
  • “动态数据”视图答疑

向页提供所需参数

为了生成动态内容，有些页需要来自用户的参数，例如，页需要记录的 ID 号才可找到并显示该记录。没有这种数据，Dreamweaver 将无法生成在“设计”视图中显示的动态内容。

如果页需要来自用户的参数，您必须按以下步骤提供参数。

若要向页提供应来自用户的数据，请执行以下操作：

  1. 在“文档”窗口中，从“查看”菜单选择“设置动态数据”。

    “设置动态数据”对话框将出现。

  2. 完成对话框设置，然后单击“确定”。

    有关更多信息，请参见设置“设置动态数据”对话框选项。

如果在“设置动态数据”对话框中指定 GET 方法，则在“设计”视图工具栏上将显示一个文本框。使用此文本框输入不同的 URL 参数；然后单击“刷新”按钮（环形箭头图标），查看这些参数对页面的影响效果。

按以下格式输入每个 URL 参数：

name=value;

在此格式中，name 是页所需的 URL 参数名称，而 value 是该参数具有的值。有关更多信息，请参见 URL 参数。

相关主题

  • 在“设计”视图中查看动态数据
  • 显示动态数据的要求
  • 复制相关文件
  • 刷新页
  • “动态数据”视图答疑


刷新页

若要刷新页面，请执行以下操作：

  • 在启用“动态数据”的情况下，如果希望在进行了影响动态内容的更改后刷新页，请单击文档工具栏上的“刷新”按钮（环形箭头图标）。

    也可以选择工具栏上的“自动刷新”选项。在启用此选项的情况下，无论何时进行了影响动态内容的更改，页面都会刷新。如果您的数据库连接速度较慢，当在“动态数据”窗口中工作时，可能会希望禁用此选项。

相关主题

  • 在“设计”视图中查看动态数据
  • 显示动态数据的要求
  • 复制相关文件
  • 向页提供所需参数
  • “动态数据”视图答疑

“动态数据”视图答疑

“动态数据”视图的许多问题可归因于在“站点定义”对话框（“站点”>“编辑站点”）中缺少值或其中的值不正确。

请检查“站点定义”对话框的“应用程序服务器”类别。“远端文件夹”文本框应指定一个能够处理动态页的文件夹（请参见指定可在哪里处理动态页）。如果在硬盘上运行的是 IIS 或 PWS，则下面是一个合适的远端文件夹示例：

C:\Inetpub\wwwroot\myapp\

请验证“URL 前缀”框是否指定了对应于（或“映射”到）远端文件夹的 URL。例如，如果您的本地计算机上正在运行的是 PWS 或 IIS，则下列远端文件夹具有以下 URL 前缀：

远端文件夹 | URL 前缀
C:\Inetpub\wwwroot\ | http://localhost/
C:\Inetpub\wwwroot\myapp\ | http://localhost/myapp/
C:\Inetpub\wwwroot\fs\planes | http://localhost/fs/planes

有关更多信息，请参见连接到数据库。

相关主题

  • 在“设计”视图中查看动态数据
  • 显示动态数据的要求
  • 复制相关文件
  • 向页提供所需参数
  • 刷新页


在不显示动态数据的“设计”视图中工作

如果禁用了“动态数据”，或者暂时与应用程序服务器断开了连接，您仍可在“设计”视图中处理动态页。Dreamweaver 可使用占位符可视地表示页面中的动态内容。例如，表示从数据库提取的动态文本的占位符使用语法 {RecordsetName.ColumnName}，其中 Recordset 是记录集的名称，而 ColumnName 是从记录集中选择的列的名称。

有时，表示动态文本的占位符的长度会破坏“设计”视图中页面的布局。可通过使用空的大括号作为占位符来解决这个问题。

若要使用空的大括号作为动态文本的占位符，请执行以下操作：

  1. 选择“编辑”>“首选参数”>“不可见元素”或者选择“Dreamweaver”>“首选参数”>“不可见元素”(Mac OS X)。
  2. 在“显示动态文本于”弹出菜单中选择 {}。
  3. 单击“确定”。

相关主题

  • 在“设计”视图中查看动态数据
  • 显示动态数据的要求


在浏览器中预览动态页

Web 应用程序开发人员经常通过在 Web 浏览器中频繁地检查页来对页进行调试。Dreamweaver 通过“在浏览器中预览”命令 (F12) 来适应这种工作风格。该命令可使您快速地在浏览器中查看动态页，而无需先将这些动态页手动上传到服务器。

提示

也可以在处理页时，使用“设计”视图快速地检查页。“设计”视图可显示页的完全可编辑的可视化表示形式，包括动态数据。有关更多信息，请参见在“设计”视图中查看动态数据。

可以指定 Dreamweaver 使用临时文件代替原始文件。通过此选项，在将页显示于浏览器中之前，Dreamweaver 会在 Web 服务器上运行该页的临时副本。（Dreamweaver 随后从服务器中删除该临时文件。）若要设置此选项，请选择“编辑”>“首选参数”>“在浏览器中预览”。

若要预览动态页，您必须完成“站点定义”对话框的“测试服务器”类别。有关更多信息，请参见指定可在哪里处理动态页。

“在浏览器中预览”不会上传诸如结果页或详细页的相关页、诸如图像文件的相关文件或 server-side includes。若要上传缺少的文件，请选择“窗口”>“站点”以打开“站点”面板，在“本地文件夹”下选择该文件，然后单击工具条上的蓝色向上箭头，将该文件复制到 Web 服务器文件夹中。


限制显示在 Dreamweaver 中的数据库信息

类似 Oracle 的大型数据库系统的高级用户应限制在设计时由 Dreamweaver 检索和显示的数据库项的数量。Oracle 数据库可能包含 Dreamweaver 在设计时无法处理的项。您可在 Oracle 中创建一个架构，然后在 Dreamweaver 中使用它在设计时筛选掉不必要的项。

注意

在 Microsoft Access 中不能创建架构或目录。

限制在设计时 Dreamweaver 检索的信息数量后，其他用户可能会从中受益。有些数据库包含几十张、甚至数百张表，您可能不希望 Dreamweaver 在您工作时将其全部列出。架构或目录可限制在设计时 Dreamweaver 获取的数据库项的数量。

必须在数据库系统中创建架构或目录后，才能将其应用于 Dreamweaver 中。请查询数据库系统文档或向系统管理员咨询。

如果正在开发的是 ColdFusion 应用程序，将无法在 Dreamweaver 中应用架构或目录。

若要在 Dreamweaver 中将架构或目录应用于非 ColdFusion 的应用程序，请执行以下操作：

  1. 在 Dreamweaver 中打开动态页，然后打开“数据库”面板（“窗口”>“数据库”）。

    如果数据库连接已经存在，则连接的列表将显示在该面板中。

  2. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该连接，然后从弹出菜单中选择“编辑连接”。对应于该连接的对话框将会出现。

    如果不存在连接，请单击面板顶部的加号 (+) 按钮，然后创建连接。有关更多信息，请参见连接到数据库。

  3. 在该连接的对话框中，单击“高级”。

    “限制”对话框将出现。

  4. 指定架构或目录。
  5. 单击“确定”。


参考资料

本节提供在本章介绍的下列对话框和面板的有关信息：

  • 设置“绑定”面板选项
  • 设置“服务器行为”面板选项
  • 设置“数据库”面板选项
  • 设置“组件”面板选项
  • 设置“设置动态数据”对话框选项
  • 设置“限制”对话框选项


设置“绑定”面板选项

此面板用于为页定义动态内容源以及向页添加该内容。

您可以使用此面板执行以下任务：

  • 定义动态内容源
  • 向 Web 页中添加动态内容
  • 更改或删除内容源
  • 使用预定义的数据格式
  • 附加 XML 数据源
  • 在 XSLT 页面中显示 XML 数据


设置“服务器行为”面板选项

此面板用于向页添加 Dreamweaver 服务器行为、编辑服务器行为以及新建服务器行为。

您可以使用此面板执行以下任务：

  • 显示数据库记录
  • 定义动态内容源
  • 生成主/详细页 (ColdFusion)
  • 建立搜索/结果页（ColdFusion、ASP、JSP、PHP）
  • 建立记录插入页（所有服务器）
  • 建立更新记录的页面 (ColdFusion)
  • 建立删除记录的页面 (ColdFusion)
  • 生成对站点访问进行限制的页（ColdFusion、ASP、JSP、PHP）
  • 生成主/详细页 (ASP.NET)
  • 生成数据库搜索页 (ASP.NET)
  • 生成记录插入页 (ASP.NET)
  • 生成用以更新记录的页面 (ASP.NET)
  • 生成用以删除记录的页 (ASP.NET)
  • 使用预存过程修改数据库 (ASP.NET)
  • 生成对站点访问进行限制的页 (ASP.NET)
  • 生成主/详细页 (PHP)
  • 生成搜索/结果页 (PHP)
  • 生成记录插入页面 (PHP)
  • 生成更新记录的页面 (PHP)
  • 生成删除记录的页面 (PHP)
  • 生成对站点访问进行限制的页 (PHP)
  • 删除动态内容
  • 添加自定义服务器行为


设置“数据库”面板选项

“数据库”面板用于创建数据库连接、检查数据库以及将数据库相关代码插入到页中。

您可以使用此面板执行以下任务：

  • 在 Dreamweaver 中查看数据库
  • 连接到数据库


设置“组件”面板选项

“组件”面板用于创建和检查组件，以及将组件代码插入到页中。

注意

该面板不能在“设计”视图中工作。

您可以使用此面板执行以下任务：

  • 缓存内容源
  • 使用 ColdFusion 组件
  • 使用 Web 服务


设置“设置动态数据”对话框选项

此对话框用于向页提供应来自用户的数据，以便 Dreamweaver 可在“设计”视图中显示具有动态数据的页。

若要提供带有动态数据的页，请执行以下操作：

  1. 在“URL 请求”区域，单击加号 (+) 按钮，然后输入页所需要的参数。

    为每个参数指定名称和测试值。

  2. 在“方法”弹出菜单中，选择页所需的 HTML 构成方法：POST 或 GET。
  3. 在“初始化脚本”文本区域中，请包括希望在页运行前插入到其顶端的所有源代码。

    初始化脚本通常由设置会话变量的代码组成。有关更多信息，请参见了解会话变量。

  4. 若要保存当前页的设置，请单击“保存此文档的设置”。

    注意

    若要保存设置，必须启用“设计注释”（“文件”>“设计注释”）。
  5. 单击“确定”。

相关主题

  • 向页提供所需参数
  • 在“设计”视图中查看动态数据
  • 表单参数
  • URL 参数


设置“限制”对话框选项

此对话框用于使用预定义的数据库架构或目录来限制在设计时 Dreamweaver 检索的数据库项的数量。

必须在数据库应用程序中首先创建架构或目录后，才能将其应用于 Dreamweaver 中。请查询数据库系统文档或向系统管理员咨询。

注意

在 Microsoft Access 中不能创建架构或目录。

若要在数据库应用程序中创建架构或目录，请执行以下操作：

  • 指定架构或目录，然后单击“确定”。

相关主题

  • 限制显示在 Dreamweaver 中的数据库信息


动态页设计工作流程

Macromedia Dreamweaver 8 所提供的关键益处在于使用户能够在没有编程语言使用经验的情况下创建动态 Web 站点。Dreamweaver 的可视化工具使您可以开发动态 Web 站点，而不必亲手编写创建能够显示数据库中存储的动态内容所必需的复杂编程逻辑。Dreamweaver 使您可以使用几种流行的 Web 编程语言和服务器技术中的任意一种来创建动态 Web 站点。这些语言和技术包括 Macromedia ColdFusion、ASP.NET、Microsoft ASP、JavaServer Page (JSP) 和 PHP。

本章概述了要成功设计和创建动态 Web 站点所必须遵循的几个关键步骤。在每一节的结尾处，都可以找到开发动态页所需的特定过程的参考资料。开发动态 Web 页的五个关键步骤如下所示：

设计页面

创建动态内容源

向 Web 页添加动态内容

增强动态页的功能

测试和调试页


设计页面

在设计任何 Web 站点（无论是静态还是动态的）时的一个关键步骤是页面视觉效果的设计。当向网页中添加动态元素时，页面的设计对于其可用性至关重要。请仔细考虑用户将如何既与各个页面又与整个 Web 站点进行交互。

将动态内容合并到 Web 页的常用方法是创建一个显示内容的表格，然后将动态内容导入该表格的一个或多个单元格中。利用此方法，可以用一种结构化的格式来表示各种类型的信息。

有关设计页面的信息，请参见下列章节：

  • 使用表格显示内容
  • 在“布局模式”对页进行布局
  • 使用页面
  • 插入文本和设置文本格式
  • 插入图像
  • 链接与导航
  • 添加音频、视频和交互式元素


创建动态内容源

动态 Web 站点需要一个内容源，在将数据显示在网页上之前，动态 Web 站点需要从该内容源提取这些数据。在 Dreamweaver 中，这些数据源可以是数据库、请求变量、服务器变量、表单变量或预存过程。

能在 Web 页中使用这些内容源之前，必须执行以下操作：

  • 创建动态内容源（如数据库）与处理该页面的应用程序服务器之间的连接
  • 指定要显示数据库中的什么信息，或指定希望在该页面中包括什么变量
  • 使用 Dreamweaver 的指向并单击 (point-and-click) 界面选择动态内容元素并将其插入到选定页面

Dreamweaver 使您可以更容易地连接到数据库并创建从中提取动态内容的记录集。记录集是数据库查询的结果。它提取请求的特定信息，并允许在指定页面内显示该信息。根据包含在数据库中的信息和要显示的内容来定义记录集。

不同的技术供应商可能使用不同的术语来表示记录集。在 ASP 和 ColdFusion 中，记录集被定义为查询。在 JSP 中，记录集被称为结果集。ASP.NET 将记录集称为数据集。如果使用的是其它数据源，如用户输入或服务器变量，则 Dreamweaver 中定义的该数据源的名称与数据源名称本身相同。

若要在 Dreamweaver 中使用内容源，请使用“绑定”面板来创建数据源。“绑定”面板（如下图所示）使您可以为数据库和其它变量类型创建数据源。创建数据源后，该数据源存储在“绑定”面板中，可以从该面板中选择此数据源并将其插入当前页面中。

若要在 Dreamweaver 中创建记录集，请使用“记录集”对话框。可以从“插入”栏的“服务器”面板或者从“绑定”面板打开“记录集”对话框。该简单的“记录集”对话框使您可以选择现有数据库连接，并使您可以通过选择要将其数据包括在记录集中的表来创建数据库查询。甚至还可以使用该对话框的“筛选”部分为查询创建简单的搜索和返回条件。可以在“记录集”对话框内测试查询，并可以进行任何必要的调整，然后再将其添加到“绑定”面板。

建立数据库连接并定义记录集后，该记录集将出现在“绑定”面板中。从该面板中可以将记录集导入到已定义站点内的任何网页中。下面的插图显示的是“绑定”面板，面板中打开的是某雇员数据库的记录集。可以将任何显示的值插入到网页中，方法是先选中该项，然后单击面板底部的“插入”按钮。该选中项将被插入到页面内的指定占位符处。

有关数据库和创建数据库连接所需过程的信息，请参见下列章节：

  • 为页面获取数据
  • 数据库初学者指南


向 Web 页添加动态内容

定义记录集或其它数据源并将其添加到“绑定”面板后，可以将该记录集所代表的动态内容插入到页面中。Dreamweaver 的菜单型 (menu-driven) 界面使得添加动态内容元素非常简单，只需从“绑定”面板中选择动态内容源，然后将其插入到当前页面内的适当文本、图像或表单对象中即可。

将动态内容元素或其它服务器行为插入到页面中时，Dreamweaver 会将一段服务器端脚本插入到该页面的源代码中。该脚本指示服务器从定义的数据源中检索数据，然后将数据呈现在该网页中。

  • 若要在 Web 页中放置动态内容，请执行以下操作之一：
  • 将其放在“代码”视图或“设计”视图中的插入点处。
  • 替换文本字符串或其它占位符。

将其插入到 HTML 属性中。例如，动态内容可以定义图像的 src 属性或表单域的 value 属性。

有关将动态内容添加到页面的详细过程，请参见以下章节：

  • 定义动态内容源
  • 创建表单


增强动态页的功能

除了添加动态内容外，Dreamweaver 还使您可以通过使用服务器行为轻松地将复杂的应用程序逻辑合并到网页中。“服务器行为”是预定义的服务器端代码片段，这些代码向 Web 页添加应用程序逻辑，从而提供更强的交互性能和功能。Dreamweaver 服务器行为允许您向 Web 站点添加应用程序逻辑，而不必您亲自编写代码。随 Dreamweaver 提供的服务器行为支持 ColdFusion、ASP、ASP.NET、JSP 和 PHP 文档类型。

服务器行为经过精心编写和仔细测试，以达到快速、安全和可靠的目的。Dreamweaver 的内置服务器行为被设计为支持跨平台 Web 页，适用于所有浏览器。


向页面添加服务器行为

若要向页面添加服务器行为，请从“插入”栏的“应用程序”类别或“服务器行为”面板中选择它们。若要使用“服务器行为”面板，请选择“窗口”>“服务器行为”，然后单击面板上的加号 (+) 按钮，并从弹出菜单中选择服务器行为。下面的插图显示“插入”栏中可用的“服务器行为”按钮。

Dreamweaver 提供指向并单击 (point-and-click) 界面，这种界面使得将动态内容和复杂行为应用到页面就像插入文本元素和设计元素一样简单。可使用的服务器行为如下所述：

  • 定义来自现有数据库的记录集。所定义的记录集随后存储在“绑定”面板中。
  • 在一个页面上显示多条记录。可以选择整个表、包含动态内容的各个单元格或各行，并指定要在每个页面视图中显示的记录数。
  • 创建动态表并将其插入到页面中，然后将该表与记录集相关联。以后可以分别使用“属性”检查器和“重复区域服务器行为”来修改表的外观和重复区域。
  • 在页面中插入动态文本对象。插入的文本对象是来自预定义记录集的项，可以对其应用任何 Dreamweaver 数据格式。
  • 创建记录导航和状态控件、主/详细页面以及用于更新数据库中信息的表单。
  • 显示来自数据库记录的多条记录。
  • 创建记录集导航链接，这种链接允许用户查看来自数据库记录的前面或后面的记录。
  • 添加记录计数器，以帮助用户跟踪返回了多少条记录以及它们在返回结果中所处的位置。

还可以通过编写您自己的服务器行为，或者安装由第三方编写的服务器行为来扩展 Dreamweaver 服务器行为。

有关使用服务器行为增强网页功能的更多信息，请参见下列章节：

  • 向 Web 页中添加动态内容
  • 显示数据库记录
  • 快速构建 ColdFusion 应用程序
  • 快速生成 ASP.NET 应用程序
  • 快速生成 ASP 和 JSP 应用程序
  • 快速生成 PHP 应用程序


测试和调试页

在 Web 上使用动态页或整个 Web 站点之前，需要测试其功能。有关帮助您测试 Web 站点的可用性和交叉平台兼容性的指导，请参见站点测试指南。有关为有听觉、视觉或其它障碍的人设计 Web 站点的更多信息，请参见使用 Dreamweaver 辅助功能。您应当熟悉本部分讨论的问题，并考虑您的应用程序功能将会如何影响在某些方面有障碍的人。

本节包含以下主题：

  • 测试动态内容
  • 编辑页面上的动态内容
  • 删除动态内容


测试动态内容

Dreamweaver 使您可以使用“动态数据”窗口预览和编辑动态内容。

注意

链接在“动态数据”窗口中不起作用。若要测试链接，请使用 Dreamweaver 的“在浏览器中预览”这一功能。（请参见检查浏览器的兼容性。）

显示动态内容时，可以执行下列任务：

  • 使用 Dreamweaver 的页面设计工具调整页面布局
  • 添加、编辑或删除动态内容
  • 添加、编辑或删除服务器行为

为了实现此功能，Dreamweaver 在服务器上运行动态页，然后再将其显示在“动态数据”窗口中。每当切换到“动态数据”窗口时，打开文档的一个临时副本就被发送到应用程序服务器进行处理。结果页返回并显示在“动态数据”窗口中，然后删除服务器上的临时副本。

可以通过选择“查看”菜单中的“动态数据”，在“文档”窗口和“动态数据”窗口之间切换。如果页面需要来自用户的数据（例如在主页面中选定的记录的 ID 号），您可以在“设置动态数据”对话框中自己向此页面提供该数据。

若要输入动态数据参数，请执行以下操作：

  1. 对页面进行必要的更改。
  2. 如果页面需要来自使用 GET 方法的 HTML 表单的 URL 参数，请在工具栏的文本框中输入名称/值对，然后单击“刷新”按钮（环形箭头图标）。

    以下列格式输入测试数据：

    name=value;

    在此格式中，name 是页面需要的 URL 参数名，value 是该参数所具有的值。

    也可以在“设置动态数据”对话框（“查看”>“设置动态数据”）中定义名称/值对，并将其与页面一起保存。

  3. 如果页面需要刷新，请单击“刷新”按钮。

相关主题

  • 编辑页面上的动态内容
  • 删除动态内容


编辑页面上的动态内容

通过更改提供动态内容的服务器行为可以修改该动态内容，或者通过完全删除该服务器行为可以将该动态内容从页面移除。例如，可以编辑记录集服务器行为，以便向页面返回更多的记录。

在“服务器行为”面板中列出了页面上的动态内容。例如，如果向页面中添加了某记录集，则“服务器行为”面板将其以如下方式列出：

Recordset(myRecordset)

如果向页面中添加另一个记录集，则“服务器行为”面板以如下方式列出这两个记录集：

Recordset(mySecondRecordset)
Recordset(myRecordset)

若要编辑提供动态内容的服务器行为，请执行以下操作：

  1. 打开“服务器行为”面板（“窗口”>“服务器行为”）。
  2. 在“服务器行为”面板中单击加号 (+) 按钮以显示服务器行为，然后双击该服务器行为。

    出现用于定义原始数据源的对话框。

  3. 在该对话框中进行更改，然后单击“确定”。

也可以使用属性检查器编辑页面上的记录集。打开属性检查器（“窗口”>“属性”），然后在“服务器行为”面板（“窗口”>“服务器行为”）中选择该记录集。

相关主题

  • 测试动态内容
  • 删除动态内容


删除动态内容

向页面添加动态内容后，可以通过在页面上选中该动态内容然后按 Delete 键来删除它。也可以通过在“服务器行为”面板中选择该动态内容，然后单击减号 (-) 按钮来删除它。

注意

此操作移除页面中从数据库检索该动态内容的服务器端脚本。它并不删除数据库中的数据。

相关主题

  • 测试动态内容
  • 编辑页面上的动态内容


为页面获取数据

基于 Web 的应用程序和动态 Web 站点都需要一个可以从中检索数据的内容源。不论是数据还是数据源都可以采取多种形式。通常，数据由返回到网页的文本或数字信息组成，并以某种形式显示给用户。

本章包含下列章节：

用数据库存储内容

收集用户提交的数据

访问会话变量中存储的数据


用数据库存储内容

通过用数据库存储内容可以使 Web 站点的设计与要显示给站点用户的内容分开。不必为每个页面都编写单独的 HTML 文件，只需为要呈现的不同类型的信息编写一个页面（或模板）即可。通过使用数据库，只需将内容上传到数据库中，然后让 Web 站点动态地检索该内容以响应用户的请求，即可向 Web 站点提供新的内容。将内容信息存储在数据库中的主要优势是：能够在单个源中更新信息，然后将此更改传播到整个 Web 站点，而不必搜索可能包含该信息的所有页面并手工编辑每个页面。

根据必须存储的数据的数量和复杂性，数据库可以有多种形式。Windows 计算机上通常安装的数据库是 Microsoft Access。对于数据库方面的新手，Access 提供了一种易于使用的界面以便对数据库表进行操作。虽然可以将 Access 用作多数 Web 站点应用程序的数据源，但要注意 Access 的文件大小被限制在 2 GB 以内，并且并发用户数限制为 255 个。因此，可以选择 Access 用于 Web 站点开发和公司工作组。但如果预计有较大的用户群体会访问该站点，则请规划使用专为支持这种站点而设计的数据库，以满足预期用户数的访问要求。

对于在其数据建模时需要较大程度的灵活性，并且要求可以支持大量并发用户群体的 Web 站点，一般都使用基于服务器的关系型数据库（通常称作 RDBMS）。用于存储基于 Web 的应用程序和动态站点的内容的常用关系型数据库包括 MySQL、Microsoft SQL Server 和 Oracle。

无论选用哪种数据库来支持 Web 站点，都可以用 Macromedia Dreamweaver 8 来设计 Web 表单，以便向数据库中插入数据，以及更新或删除数据库中的数据。

若要了解有关数据库的更多内容，请参见数据库初学者指南。


访问数据库中存储的数据

Web 页不能直接访问数据库中存储的数据。而是需要与记录集 进行交互。记录集是从数据库中提取的信息或记录的子集。该信息子集是通过数据库查询 提取出来的。查询是一种专门用于从数据库中查找和提取特定信息的搜索语句。Dreamweaver 使用结构化查询语言 (SQL) 来生成查询。尽管不需要学习 SQL（发音为“sequel”）也能用 Dreamweaver 来创建简单的查询，但具有了这种易于理解的语言的基础知识后，可以创建更为高级的查询，并因此可在设计动态页方面提供更大的灵活性。若要学习有关 SQL 的基础知识，请参见 SQL 入门。

SQL 查询可以生成只包括某些列、只包括某些记录，或者既包括列也包括记录的记录集。记录集也可以包括数据库表中所有的记录和列。但由于应用程序很少要用到数据库中的每个数据片段，所以应该努力使记录集尽可能的小。由于 Web 服务器会将记录集临时放在内存中，所以使用较小的记录集将占用较少内存，并可以潜在地改善服务器的性能。


收集用户提交的数据

可以用 Web 页来收集用户提供的信息，将其存储在服务器的内存中，然后根据用户的输入用这些信息来创建动态响应。收集信息最常用的工具是 HTML 表单和超文本链接选择。

HTML 表单可以收集来自用户的信息并将其存储在服务器的内存中。HTML 表单可以将信息作为表单参数或 URL 参数来发送。如果将表单的 method 属性设为 POST，则浏览器会将表单的值包括在发送给服务器的消息的正文中。如果将表单的 method 属性设为 GET，则浏览器会将表单值追加到 action 属性中指定的 URL 中，并将信息发送给服务器。

超文本链接也可以收集来自用户的信息并将其存储在服务器的内存中。通过将值追加到锚记中指定的 URL 上，可以指定当用户单击链接（如某个首选参数）时要提交的值。当用户单击该链接时，浏览器会将 URL 和追加的值一起发送给服务器。

这一节描述如何创建用于 Web 应用程序的表单和 URL 参数。

本节包含以下主题：

  • 表单参数
  • URL 参数
  • 使用 HTML 链接创建 URL 参数
  • 检索表单和 URL 参数


表单参数

表单参数是由使用 POST 或 GET 方法的 HTML 表单发送给服务器的。使用 POST 方法时，参数是在消息的正文中发送的。与此相反，GET 方法将参数追加到请求的 URL 上。

可使用 Dreamweaver 快速设计向服务器发送表单参数的 HTML 表单。有关说明，请参见创建表单。注意您所使用的从浏览器向服务器传输信息的方法。

表单参数采用其相应表单对象的名称。例如，如果表单中包含一个名为 txtLastName 的文本域，则当用户单击“提交”按钮时，将有如下表单参数发送给服务器：

txtLastName=enteredvalue

如果 Web 应用程序需要一个精确的参数值（例如当该应用程序根据几种选项之一来执行一项操作时），则可以用单选按钮、复选框，或者列表/菜单表单对象来控制用户可以提交的可能值。这样可以防止用户错误地键入某些信息并引起应用程序错误。下面的示例描述一个提供三种选择的弹出菜单表单：

每个菜单选项对应一个作为表单参数提交给服务器的硬编码值。“列表值”对话框（显示在下面）将每个列表项都与一个值（“Add”、“Update”或“Delete”）匹配起来：

相关主题

  • URL 参数
  • 使用 HTML 链接创建 URL 参数
  • 检索表单和 URL 参数


URL 参数

URL 参数是追加到 URL 上的一个名称/值对。参数以问号 (?) 开始并采用 name=value 的格式。如果存在多个 URL 参数，则参数之间用一个 (&) 符隔开。下面的示例显示带有两个名称/值对的 URL 参数：

http://server/path/document?name1=value1&name2=value2

URL 参数可使您将用户提供的信息从浏览器传递到服务器。当服务器收到请求，而且参数被追加到请求的 URL 上时，服务器在将请求的页提供给浏览器之前，于处理该页时放置这些参数。

在该示例中，可以将应用程序设想为一家基于 Web 的店面。由于希望招徕最大范围的可能顾客，所以站点的开发人员将站点设计得可以支持多种外币。用户登录到该站点之后，他们可以选择使用哪种货币来查看所列商品的价格。

  1. 浏览器向服务器请求该页的 report.cfm。该请求包括 URL 参数 Currency="euro"。Currency="euro" 变量指定所有检索到的货币数值都以欧盟的欧元为单位来显示。
  2. 服务器将 URL 参数临时存储在内存中。
  3. report.cfm 页读取并使用该参数来检索以欧元为单位的商品价格。这些货币数值既可以存储在反映不同货币的数据库表中，也可以从与每种商品相关联的单一货币形式转换为应用程序支持的任何货币形式。
  4. 服务器将 report.cfm 页发送给浏览器，并以请求的货币形式显示商品的价格。当该用户终止会话时，服务器将删除 URL 参数的值，释放服务器内存以存放登录进该站点的新用户的请求。

    下图显示应用程序服务器如何处理 URL 参数。

当将 HTTP 的 GET 方法与 HTML 表单一起使用时，将创建 URL 参数。GET 方法指定在提交表单时将参数值追加到 URL 请求上。

URL 参数的典型应用包括根据用户的喜好对 Web 站点进行个性化设置。例如，由用户名和密码组成的 URL 参数可用于验证用户身份，并只显示该用户已经订阅的信息。这种应用的常见示例包括一些金融 Web 站点，这些站点可根据用户以前所选的股票代码来显示个人的股票价格。Web 应用程序开发人员通常使用 URL 参数将值传递给应用程序内的变量。例如，可以将搜索语句传递给 Web 应用程序中的 SQL 变量以产生搜索结果。

相关主题

  • 使用 HTML 链接创建 URL 参数
  • 检索表单和 URL 参数


使用 HTML 链接创建 URL 参数

在 HTML 链接内部创建 URL 参数，包括使用 HTML 锚记的 href 属性。可通过以下方法在属性中直接输入 URL 参数：切换到“代码”视图（“查看”>“代码”），或者在属性检查器中的“链接”文本框中将 URL 参数追加到链接 URL 的末尾。

在下面的示例中，三个链接用三个可能值（Add、Update 和 Delete）来创建一个单独的 URL 参数 (action)。根据用户所单击链接的不同，会将不同的参数值发送给服务器，并且会执行不同的请求操作：

<a href="http://www.mysite.com/index.cfm?action=Add">Add a record</a>
<a href="http://www.mysite.com/index.cfm?action=Update">Update a record</a>
<a href="http://www.mysite.com/index.cfm?action=Delete">Delete a record</a>

“属性”检查器（“窗口”>“属性”）可使您通过以下方式创建相同的 URL 参数：选择该链接，在“链接”文本框中将 URL 参数值追加到链接 URL 的末尾。

相关主题

  • 收集用户提交的数据
  • URL 参数
  • 检索表单和 URL 参数
  • 了解 URL 和表单参数
  • 定义 URL 参数
  • 定义表单参数


检索表单和 URL 参数

创建完表单或 URL 参数后，Dreamweaver 可以读取该值并将其用在 Web 应用程序中。有关更多信息，请参见定义 URL 参数。

在 Dreamweaver 中定义了表单或 URL 参数之后，可将其值插入到页面中。有关更多信息，请参见向 Web 页中添加动态内容。

相关主题

  • 访问数据库中存储的数据
  • 表单参数
  • URL 参数
  • 使用 HTML 链接创建 URL 参数


访问会话变量中存储的数据

会话变量提供了一种机制，通过这种机制，用户信息得以存储和访问，供 Web 应用程序所使用。通常，会话变量存储信息（通常是由用户提交的表单或 URL 参数），并使该信息在用户访问的持续时间中对应用程序的所有页都可用。例如，当用户登录进一个 Web 门户（从该门户可访问电子邮件、股票报价、天气预报和每日新闻）之后，Web 应用程序会将登录信息存储在一个会话变量中，该变量在所有站点页面中标识该用户。这样，当用户浏览整个站点时，他们可以只看到他们已经选中的内容类型。会话变量还可以提供一种超时形式的安全机制，这种机制在用户帐户长时间不活动的情况下，终止该用户的会话。如果用户忘记从 Web 站点注销，这种机制还会释放服务器内存和处理资源。

会话变量通常用于存储用户显示的首选参数、多部分问卷的答案、在所谓“购物车”应用程序中选购的商品，以及网上游戏的所得分数等。

本节包含以下主题：

  • 了解会话变量
  • 收集信息以存储在会话变量中
  • 将信息存储在会话变量中
  • 存储在会话变量中的信息的示例
  • 从会话变量中检索数据


了解会话变量

Web 服务器（或者更具体地说，HTTP 协议）是无状态的，即它们不跟踪连接到它们的浏览器，也不跟踪用户的各个页面请求。Web 服务器每次接收对 Web 页的请求，并通过向用户的浏览器发送相关页面做出响应后，Web 服务器都会“忘记”进行请求的浏览器和它发送出去的 Web 页。当同一用户稍后请求一个相关页时，Web 服务器会发送该页，而并不知道它发给该用户的上一页是什么。

HTTP 的无状态本性使它成为一种简单而易于实现的协议，因此也使得越高级的 Web 应用程序（如个性化所生成的内容）越难实现。例如，为了给单个用户自定义站点内容，必须首先标识出该用户。许多 Web 站点使用某种用户名/密码登录形式来实现此目的。如果需要显示多个自定义的页面，则必需一种跟踪登录用户的机制，因为多数用户将不能接受为站点的每一页都提供其用户名和密码。

为了能够创建复杂的 Web 应用程序和在所有站点页间存储用户提供的数据，多数应用程序服务器技术都包括对会话管理的支持。会话管理使 Web 应用程序能够在多个 HTTP 请求之间维护状态，使用户对网页的请求在给定时间段内可视作同一交互会话的一部分。

会话变量存储着用户的会话生命周期的信息。当用户第一次打开应用程序中的某一页时，用户会话就此开始。当用户一段时间内不再打开该应用程序中的其它页时，或者用户明确终止该会话时（通常是通过单击“注销”链接），会话即告结束。在会话存在期间，会话特定于单个用户，每个用户都有单独的会话。

会话变量用于存储 Web 应用程序中每页都能访问的信息。信息可以多种多样，如用户名、首选字体大小，或者是指示用户是否成功登录的标记等。会话变量的另一个常见用途是保存连续分数，例如在网上测验中到目前为止用户答对的题数，或者到目前为止，用户从网上目录中选择的产品。

请注意，会话变量只有在用户的浏览器配置成接受 Cookie 后才起作用。当首次初始化会话时，服务器创建一个唯一标识该用户的会话 ID 号，然后将包含该 ID 号的 Cookie 发送到用户的浏览器。当用户请求服务器上的另一页时，服务器会读取浏览器中的 Cookie 以识别该用户并检索存储在服务器内存中的该用户的会话变量。

相关主题

  • 收集信息以存储在会话变量中
  • 将信息存储在会话变量中
  • 存储在会话变量中的信息的示例
  • 从会话变量中检索数据


收集信息以存储在会话变量中

创建会话变量前，必须先获得要存储的信息，然后才能将其发送到服务器进行存储。这一节描述如何用 HTML 表单或包含 URL 参数的超文本链接来收集信息并将其发送给服务器。信息的获取来源还包括：存储在用户计算机上的 Cookie、用户浏览器发送的带有页面请求的 HTTP 标头，或者数据库。

本节包含以下主题：

  • 将 URL 参数存储在会话变量中
  • 将表单参数存储在会话变量中

相关主题

  • 了解会话变量
  • 将信息存储在会话变量中
  • 存储在会话变量中的信息的示例
  • 从会话变量中检索数据


将 URL 参数存储在会话变量中

在会话变量中存储 URL 参数的一个典型示例是产品目录，它使用通过超文本链接创建的硬编码 URL 参数将产品信息发送回服务器以存储在一个会话变量中。当用户单击“Add to shopping cart”链接时，产品 ID 将存储在会话变量中，而用户可以继续采购。当用户继续浏览到付款页时，即可检索出存储在会话变量中的产品 ID。


将表单参数存储在会话变量中

基于表单的问卷调查是在会话变量中存储表单参数的一个典型页面示例。表单将选定信息发送回服务器，服务器中的应用程序页将记录调查分数并将响应存储于一个要传递给应用程序的会话变量中，该应用程序可以汇总从调查人群中收集到的响应。也可将这些信息存储于数据库中供以后使用。


将信息存储在会话变量中

信息发送给服务器后，通过向由 URL 或表单参数指定的页中添加适合于服务器模型的代码，即可将信息存储在会话变量中。请参考 destination 页，该页既可在 HTML 表单的 action 属性中指定，也可在起始页上超文本链接的 href 属性中指定。

每种 HTML 语法如下所示：

<form action="destination.html" method="get" name="myform"> </form>
<param name="href"value="destination.html">

所用的服务器技术和用于获取信息的方法共同确定了使用什么代码将信息存储在会话变量中。每种服务器技术的基础语法如下所示：

ColdFusion

<CFSET session.variable_name = value>

ASP 和 ASP.NET

<% Session("variable_name") = value %>

value 表达式通常是如 Request.Form(“lastname”) 之类的服务器表达式。例如，如果使用名为 product 的 URL 参数（或使用利用 GET 方法并且文本域名为 product 的 HTML 表单）收集信息，则下列语句将信息存储在一个名为 prodID 的会话变量中：

ColdFusion

<CFSET session.prodID = url.product>

ASP 和 ASP.NET

<% Session("prodID") = Request.QueryString("product") %>

如果使用包含 post 方法和名为 txtProduct 的文本域的 HTML 表单来收集信息，则下列语句会将信息存储在会话变量中：

ColdFusion

<CFSET session.prodID = form.txtProduct>

ASP 和 ASP.NET

<% Session("prodID") = Request.Form("txtProduct") %>

相关主题

  • 了解会话变量
  • 收集信息以存储在会话变量中
  • 存储在会话变量中的信息的示例
  • 从会话变量中检索数据


存储在会话变量中的信息的示例

假定您正在处理一个拥有大量老年访问者的站点。在 Dreamweaver 中，您向起始页中添加了两个链接，使用户可以对该站点的文本大小进行自定义。如果需要较大的、易读的文本，用户可以单击一个链接；如果需要常规大小的文本，用户可以单击另一个链接。

每个链接都有一个名为 fontsize 的 URL 参数，它可以将用户的文本首选设置提交给服务器，如下面的 Macromedia ColdFusion 示例所示：

<a href="resort.cfm?fontsize=large">Larger Text</a><br>
<a href="resort.cfm?fontsize=small">Normal Text</a>

您决定将用户的文本首选设置存储在会话变量中，并用其设置用户请求的每一页上的字体大小。

在靠近目标页顶端的地方，输入下列代码来创建名为 font_pref 的会话，其中存储用户的字体大小首选设置。

ColdFusion

<CFSET session.font_pref = url.fontsize>

ASP 和 ASP.NET

<% Session("font_pref") = Request.QueryString("fontsize") %>

当用户单击超文本链接时，该页将在 URL 参数中把用户的文本首选设置发送给目标页。目标页中的代码将该 URL 参数存储在 font_pref 会话变量中。在该用户会话的持续时间内，应用程序中的所有页都将检索该值，并显示选定的字体大小。

相关主题

  • 了解会话变量
  • 收集信息以存储在会话变量中
  • 将信息存储在会话变量中
  • 从会话变量中检索数据


从会话变量中检索数据

将值存储在会话变量中后，即可用 Dreamweaver 从会话变量中检索该值并用在 Web 应用程序中。有关更多信息，请参见定义会话变量。

在 Dreamweaver 中定义了会话变量后，可以将其值插入到某个页面中。有关更多信息，请参见向 Web 页中添加动态内容。

相关主题

  • 了解会话变量
  • 收集信息以存储在会话变量中
  • 将信息存储在会话变量中
  • 存储在会话变量中的信息的示例


定义动态内容源

动态 Web 站点要求有一个可从中检索和显示动态内容的数据源。Macromedia Dreamweaver 8 允许使用数据库、请求变量、URL 变量、服务器变量、表单变量、预存过程以及其它动态内容源。根据数据源的不同，您可检索新内容以满足某个请求，也可修改页面以满足用户需要。

本章讲述将数据库和变量定义为动态内容源的过程。要了解有关本章所讨论的技术的更多信息，请参见 HTML 和 Web 技术资源。

本章包含下列章节：

关于动态内容源

定义记录集

定义 URL 参数

定义表单参数

定义会话变量

定义用于 ASP 和 ColdFusion 的应用程序变量

使用变量作为 ColdFusion 记录集的数据源

定义服务器变量

缓存内容源

更改或删除内容源

将记录集从一个页面复制到另一个页面


关于动态内容源

动态内容源是一个可从中检索和显示在 Web 页中使用的动态内容的信息存储区。动态内容源不仅包括存储在数据库中的信息，还包括通过 HTML 表单提交的值、服务器对象中包含的值、JavaBeans 属性值以及其它内容源。

在 Dreamweaver 中定义的任何内容源都被添加到“绑定”面板的内容源列表中。创建内容源并将其加到“绑定”面板后，就可以很容易地将其插入到当前所选的页面中。

本节包含以下概念性主题：

  • 了解记录集
  • 了解 URL 和表单参数
  • 关于会话变量
  • ASP 和 ColdFusion 应用程序变量
  • ASP 服务器变量
  • ColdFusion 服务器变量

相关主题

  • 了解记录集
  • 了解 URL 和表单参数
  • 关于会话变量
  • ASP 和 ColdFusion 应用程序变量
  • ASP 服务器变量
  • ColdFusion 服务器变量


了解记录集

将数据库用作动态 Web 页的内容源时，必须首先创建一个要在其中存储检索数据的记录集。记录集在存储内容的数据库和生成页面的应用程序服务器之间起一种桥梁作用。记录集由数据库查询返回的数据组成，并且临时存储在应用程序服务器的内存中，以便进行快速数据检索。当服务器不再需要记录集时，就会将其丢弃。

记录集本身是从指定数据库中检索到的数据的集合。它可以包括完整的数据库表，也可以包括表的行和列的子集。这些行和列通过在记录集中定义的数据库查询进行检索。数据库查询是用结构化查询语言 (SQL) 编写的。而 SQL 是一种简单的、可用来在数据库中检索、添加和删除数据的语言。使用 Dreamweaver 附带的 SQL 创建器，您可以在不了解 SQL 的情况下创建简单查询。不过，如果想创建复杂的 SQL 查询，则需要学习 SQL 并手动编写输入到 Dreamweaver 中的 SQL 语句。

注意

Microsoft ASP.NET 将记录集称为“数据集”。如果您使用的是 ASP.NET 文档类型，则特定于 ASP.NET 的对话框和菜单选项使用标签“数据集”。Dreamweaver 文档一般将这两种类型都称作“记录集”，但是，在专门描述 ASP.NET 功能时使用的是“数据集”。

有关使用数据库和 SQL 的更多信息，请参见数据库初学者指南和 SQL 入门。

如果要编写用于 ASP.NET 的 SQL，您必须了解一些特定于 ASP.NET 的条件。要了解这些条件，请参见编写用于 ASP.NET 的 SQL。

定义用于 Dreamweaver 的记录集之前，必须先创建数据库连接，并在数据库中输入数据（如果数据库中还没有数据的话）。如果尚未定义站点的数据库连接，请参考数据库连接一章中有关您正在针对其进行开发的服务器技术的内容，并按照创建数据库连接的说明进行操作。

以下各章描述了用于 Dreamweaver 所支持的所有服务器技术的数据库连接：

  • ColdFusion 开发人员的数据库连接
  • ASP 开发人员的数据库连接
  • ASP.NET 开发人员的数据库连接
  • 用于 JSP 开发人员的数据库连接
  • 适用于 PHP 开发人员的数据库连接

相关主题

  • 定义记录集

编写用于 ASP.NET 的 SQL

当在“高级数据集”对话框中编写 SQL 语句时，您必须了解一些特定于 ASP.NET 的条件：这些条件将后面的章节中予以介绍。

参数

用于引用参数的语法因使用的数据库连接（如 OLE DB 或 Microsoft SQL Server）而不同。

OLE DB

使用 OLE DB 连接至数据库时，必须使用问号 (?) 引用参数。例如：

SELECT * FROM Employees WHERE HireDate > ?

Microsoft SQL Server

使用 .NET 框架随附的 Managed Data Provider for SQL Server 连接至 Microsoft SQL Server 时，必须命名所有参数。例如：

SELECT * FROM Employees WHERE HireDate > @hireDate

在 SQL 语句内插入代码

在为 ASP.NET 编写的 SQL 语句内插入代码时，必须将所有字符串括在引号 (" ") 中，并将代码括在括号 ( ) 中。

SELECT * FROM Employees WHERE HireDate > "+ (Request.queryString("hireDate"))

相关主题：

  • ASP.NET 开发人员的数据库连接


了解 URL 和表单参数

URL 参数存储用户输入的检索信息。若要定义 URL 参数，请创建使用 GET 方法提交数据的表单或超文本链接。信息附加到所请求页面的 URL 后面并传送到服务器。使用 URL 变量时，查询字符串包含一个或多个与表单域相关联的名称/值对。这些名称/值对附加在 URL 后面。

表单参数存储包含在 Web 页的 HTTP 请求中的检索信息。如果创建使用 POST 方法的表单，则通过该表单提交的数据将传递到服务器。开始之前，请确保将表单参数传递到服务器。有关说明，请参见为页面获取数据。

相关主题

  • 定义 URL 参数
  • 定义表单参数


关于会话变量

使用会话变量可以存储和显示在用户访问（或会话）期间保持的信息。服务器为每个用户创建不同的阶段对象并保持一段固定时间，或直至该对象被明确终止。有关更多信息，请参见访问会话变量中存储的数据。

因为会话变量在整个用户会话期间持续，并且当用户从 Web 站点内的一个页面移到另一页面时仍持续存在，所以这些变量非常适于存储用户首选参数。会话变量还可用于在页面的 HTML 代码中插入值、将值指定给本地变量或提供计算条件表达式所需的值。

定义页面的会话变量之前，必须先在源代码中创建它们。有关指导，请参见收集用户提交的数据和访问会话变量中存储的数据。

在 Web 应用程序的源代码中创建会话变量后，即可使用 Dreamweaver 检索变量值并将其用于 Web 页中。

相关主题

  • ASP 和 ColdFusion 应用程序变量
  • 定义会话变量


ASP 和 ColdFusion 应用程序变量

在 ASP 和 ColdFusion 中，可以使用应用程序变量来存储和显示某些信息，这些信息在应用程序的生存期内被保持并且在用户改变时仍持续存在。应用程序的生存期是指从第一个用户在该应用程序中请求页面到 Web 服务器停止工作之间的一段时间。（应用程序被定义为一个虚拟目录及其子目录中的所有文件）。

因为应用程序变量在应用程序的整个生存期内存在，并且在用户改变时仍持续存在，所以它们非常适合于存储所有用户都需要的信息，如当前时间和日期。应用程序变量的值在应用程序代码中定义。

有关更多信息，请参见定义用于 ASP 和 ColdFusion 的应用程序变量和向 Web 页中添加动态内容


ASP 服务器变量

可以将下列 ASP 服务器变量定义为动态内容源：Request.Cookie、Request.QueryString、Request.Form、Request.ServerVariables 和 Request.ClientCertificates。

相关主题

  • 定义 ASP 服务器变量


ColdFusion 服务器变量

可以定义下列 ColdFusion 服务器变量：

客户端变量使数据与特定的客户端相关联。当用户在应用程序中从一个页面移动到另一个页面或从一个会话移动到另一个会话时，客户端变量将保持应用程序的状态。“保持状态”指的是将信息从一个页面（或会话）保留到下一个页面（或会话），以便应用程序“记住”用户和用户以前的选择和首选参数。

Cookie 变量访问由浏览器传递给服务器的 Cookie。

CGI 变量提供有关运行 ColdFusion 的服务器的信息、请求页面的浏览器的信息以及其它有关处理环境的信息。

服务器变量可以由服务器上的所有客户端和应用程序访问。它们将一直持续到服务器被停止。

本地变量是在 ColdFusion 页面中用 CFSET 标签或 CFPARAM 标签创建的。

相关主题

  • 定义 ColdFusion 服务器变量
  • 定义 JSP 服务器变量
  • 定义 PHP 服务器变量


定义记录集

使用 Dreamweaver 中的简单“记录集”对话框和高级“记录集”对话框都可以定义记录集，在简单“记录集”对话框中可以轻松构建简单的 SQL 语句，在高级“记录集”对话框中可以编写您自己的 SQL 语句或使用图形化“数据库项”树创建 SQL 语句。

如果您对编写从数据库中检索信息的 SQL 语句并不熟悉，请使用简单“记录集”对话框。

本节包含以下主题：

  • 不通过编写 SQL 来创建记录集
  • 通过编写 SQL 来创建高级记录集
  • 使用“数据库项”树创建 SQL 查询

相关主题

  • 在 ColdFusion 组件中定义记录集


不通过编写 SQL 来创建记录集

本节描述如何使用 Dreamweaver 的“记录集”对话框来定义记录集，该对话框使您无须手动输入 SQL 语句即可创建记录集。使用此方法定义记录集可能只需从“记录集”对话框的弹出菜单中选择数据库连接和表。

如果您想自己编写 SQL 语句，请使用高级“记录集”对话框。（请参见通过编写 SQL 来创建高级记录集。）

若要不通过编写 SQL 来定义记录集，请执行以下操作：

  1. 在“文档”窗口中打开要使用记录集的页面。
  2. 选择“窗口”>“绑定”以显示“绑定”面板。
  3. 在“绑定”面板中，单击加号 (+) 按钮并从弹出菜单中选择“记录集（查询）”。

    出现简单的“记录集”对话框。如果开发的是 ColdFusion 或 ASP.NET 站点，则该“记录集”对话框与下图所示的对话框略有不同。（如果出现的是高级“记录集”对话框，则请通过单击“简单”按钮切换到简单“记录集”对话框。）

  4. 完成对话框。

    有关完成“记录集”对话框的说明，请参见以下各节中适合您的文档类型的一节：

    • 设置简单“记录集”对话框选项
    • 设置简单“记录集”对话框选项 (ColdFusion)
    • 设置简单“数据集”对话框选项 (ASP.NET)
  5. 单击“测试”按钮执行查询，并确保该查询检索到自己想要的信息。

    如果定义了使用用户输入的参数的过滤器，则单击“测试”按钮时将显示“测试值”对话框。在“测试值”文本框中输入一个值，然后单击“确定”。记录集实例成功创建时，将出现一个显示从该记录集中提取的数据的表格。

  6. 单击“确定”将该记录集添加到“绑定”面板的可用内容源列表中。


通过编写 SQL 来创建高级记录集

高级“记录集”对话框使您能够编写自己的 SQL 语句，或使用图形化的“数据库项”树来创建 SQL 语句。

注意

如果编写的 SQL 语句用于 ASP.NET 文档类型，请参考使用“数据库项”树创建 SQL 查询中有关 ASP.NET 特定规则的内容。

如果希望在不手动编写 SQL 语句的情况下创建简单记录集，请参见使用“数据库项”树创建 SQL 查询。

若要通过编写 SQL 来定义记录集，请执行以下操作：

  1. 在“文档”窗口中打开要使用记录集的页面。
  2. 选择“窗口”>“绑定”以显示“绑定”面板。
  3. 在“绑定”面板中，单击加号 (+) 按钮并从弹出菜单中选择“记录集（查询）”。

    出现高级“记录集”对话框。如果开发的是 ColdFusion 或 ASP.NET 站点，则该“记录集”对话框与下图所示的对话框略有不同。（如果出现的是简单“记录集”对话框，则请通过单击“高级”按钮切换到高级“记录集”对话框。）

  4. 完成对话框。

    有关完成“记录集”对话框的说明，请参见以下各节中适合您的文档类型的一节：

    • 设置高级“记录集”对话框
    • 设置高级“记录集”对话框 (ASP.NET)
    • 设置高级“记录集”对话框选项 (ColdFusion)
  5. 单击“测试”按钮执行查询，并确保该查询检索到自己想要的信息。

    如果定义了使用用户输入的参数的过滤器，则单击“测试”按钮时将显示“测试值”对话框。在“测试值”文本框中输入一个值，然后单击“确定”。记录集实例成功创建时，将出现一个显示该记录集中数据的表格。

  6. 单击“确定”将该记录集添加到“绑定”面板的可用内容源列表中。


使用“数据库项”树创建 SQL 查询

可以使用“数据库项”的“指向并单击”界面创建复杂的 SQL 查询，而不必将 SQL 语句手动键入到 SQL 文本框中。“数据库项”树使您可以选取数据库对象，并使用 SQL SELECT、WHERE 和 ORDER BY 子句链接它们。创建 SQL 查询后，即可使用对话框的“变量”部分定义任何变量。

以下示例讲述了两个 SQL 语句以及使用高级“记录集”对话框的“数据库项”树创建它们的步骤。


选取表格

本例选取 Employees 表的全部内容。定义查询的 SQL 语句如下所示：

SELECT * FROM Employees

若要创建此查询，请执行以下操作：

  1. 展开 Tables 分支以显示所选数据库中的全部表。
  2. 选取 Employees 表。
  3. 单击“选择”按钮。
  4. 单击“确定”将记录集添加到“绑定”面板中。


从表中选取特定行并对结果进行排序

下例从 Employees 表中选取两行，并使用必须定义的变量选取职业类型。然后，按雇员姓名对结果进行排序。

SELECT emplNo, emplName
FROM Employees
WHERE emplJob = 'varJob'
ORDER BY emplName

若要创建此查询，请执行以下操作：

  1. 展开 Tables 分支以显示所选数据库中的所有表，然后展开 Employees 表以显示单独的表行。
  2. 按下列步骤生成 SQL 语句：
    • 选取 emplNo 并单击“Select”按钮。
    • 选取 emplName 并单击“Select”按钮。
    • 选取 emplJob 并单击“Where”按钮。
    • 选取 emplName 并单击“Order By”按钮。
  3. 将插入点放在 SQL 文本区域中的 WHERE emplJob 后面，然后键入 ='varJob'（包括等号）。
  4. 定义变量 'varJob'，方法为单击“变量”区域中的加号 (+) 按钮，然后在“名称”、“默认值”和“运行时值”列中分别输入下列值：varJob、CLERK、Request("job")。
  5. 单击“确定”将记录集添加到“绑定”面板中。


定义 URL 参数

URL 参数存储用户输入的检索信息。开始之前，请确保将表单或 URL 参数传递到服务器。有关更多信息，请参见 URL 参数和了解 URL 和表单参数。

若要定义 URL 参数，请执行以下操作：

  1. 在“文档”窗口中打开要使用该变量的页面。
  2. 选择“窗口”>“绑定”以显示“绑定”面板。
  3. 在“绑定”面板中单击加号 (+) 按钮，然后从弹出菜单中选择下列选项之一：

    文档类型

    “绑定”面板中用于 URL 变量的菜单项

    ASP

    请求变量 > Request.QueryString

    ColdFusion

    URL 变量

    JSP

    请求变量

    PHP

    URL 变量

    显示“URL 变量”对话框。

  4. 在文本框中输入 URL 变量的名称并单击“确定”。

    URL 变量的名称通常是用于获得变量值的 HTML 表单域或对象的名称。

  5. URL 变量即会出现在“绑定”面板中。

    定义 URL 变量后，即可在当前所选页面中使用其值。有关更多信息，请参见向 Web 页中添加动态内容。

相关主题：

  • 定义表单参数
  • 定义会话变量


定义表单参数

表单参数存储包含在 Web 页的 HTTP 请求中的检索信息。如果创建使用 POST 方法的表单，则通过该表单提交的数据将传递到服务器。开始之前，请确保将表单参数传递到服务器。有关更多信息，请参见为页面获取数据。

若要定义表单参数，请执行以下操作：

  1. 在“文档”窗口中打开要使用该变量的页面。
  2. 选择“窗口”>“绑定”以显示“绑定”面板。
  3. 在“绑定”面板中单击加号 (+) 按钮，然后从弹出菜单中选择下列选项之一：

    文档类型

    “绑定”面板中用于表单变量的菜单项

    ASP

    请求变量 > Request.Form

    ColdFusion

    表单变量

    JSP

    请求变量

    PHP

    表单变量

    显示“表单变量”对话框：在对话框中输入表单变量的名称并单击“确定”。表单参数的名称通常是用于获得其值的 HTML 表单域或对象的名称。

  4. 表单参数即会出现在“绑定”面板中。

将表单参数定义为内容源后，即可在页面中使用其值。有关更多信息，请参见为页面获取数据。

相关主题

  • 关于动态内容源
  • 了解 URL 和表单参数
  • 定义 URL 参数


定义会话变量

使用会话变量可以存储和显示在用户访问（或会话）期间保持的信息。服务器为每个用户创建不同的阶段对象并保持一段固定时间，或直至该对象被明确终止。有关更多信息，请参见了解会话变量。

定义页面的会话变量之前，必须先在源代码中创建它们。有关说明，请参见下列主题：

  • 收集用户提交的数据
  • 访问会话变量中存储的数据
  • 将信息存储在会话变量中

在 Web 应用程序的源代码中创建会话变量后，即可使用 Dreamweaver 检索变量值并将其用于 Web 页中。

若要定义预定义的会话变量，请执行以下操作：

  1. 在源代码中创建一个会话变量并为其指定值。

    例如，下面的 ColdFusion 示例实例化一个叫做 username 的会话，并为其指定值 Cornelius：

    <CFSET session.username = Cornelius>
  2. 选择“窗口”>“绑定”显示“绑定”面板。
  3. 单击加号 (+) 按钮并从弹出菜单中选择“会话变量”。
  4. 输入在源代码中定义的变量名称。
  5. 单击“确定”。

    会话变量即会出现在“绑定”面板中。

定义了会话变量后，就可以在页面中使用它的值。有关更多信息，请参见向 Web 页中添加动态内容。

相关主题

  • 收集用户提交的数据
  • 访问会话变量中存储的数据
  • 了解会话变量
  • 将信息存储在会话变量中


定义用于 ASP 和 ColdFusion 的应用程序变量

在 ASP 和 ColdFusion 中，可以使用应用程序变量来存储和显示某些信息，这些信息在应用程序的生存期内被保持并且在用户改变时仍持续存在。

注意

JSP 或 PHP 中没有应用程序变量对象。

若要定义用于页面的应用程序变量，请执行以下操作：

  1. 在“文档”窗口中打开动态文档类型。
  2. 选择“窗口”>“绑定”显示“绑定”面板。
  3. 单击加号 (+) 按钮并从弹出菜单中选取“应用程序变量”。
  4. 输入在应用程序源代码中定义的变量名称。
  5. 单击“确定”。

    应用程序变量即会出现在“应用程序”图标下的“绑定”面板中。

    定义了应用程序变量后，就可以在页面中使用它的值。有关更多信息，请参见向 Web 页中添加动态内容。

相关主题：

  • ASP 和 ColdFusion 应用程序变量


使用变量作为 ColdFusion 记录集的数据源

在“绑定”面板中定义页面的记录集时，Dreamweaver 将在页面上的 cfquery 标签中输入 ColdFusion 数据源的名称。要获得更大的灵活性，可将数据源名称存储于一个变量中，并在 cfquery 标签中使用该变量。Dreamweaver 为在记录集中指定类似变量提供了一种可视化方法。

若要以可视化方式将变量指定为记录集的数据源，请执行以下操作：

  1. 确保 ColdFusion 页在“文档”窗口中处于活动状态。
  2. 在“绑定”面板中，单击加号 (+) 按钮并从弹出菜单中选择“数据源名称变量”。

    出现“数据源名称变量”对话框。

  3. 定义一个变量，然后单击“确定”。
  4. 定义记录集时，请选择该变量作为记录集的“数据源”。

    在“记录集”对话框中，该变量与服务器上的 ColdFusion 数据源一起出现在“数据源”弹出菜单中。

  5. 完成“记录集”对话框设置，然后单击“确定”。
  6. 初始化变量。

    Dreamweaver 不为您初始化该变量，这样，您便可以按自己的需要对其进行初始化。您可以在页面代码中（cfquery 标签之前）、包含文件中或在某些其它文件中将该变量初始化为会话变量或应用程序变量。


定义服务器变量

可以将服务器变量定义为动态内容源，以便在 Web 应用程序中使用。

服务器变量因文档类型而异，其中包括表单变量、URL 变量、会话变量和应用程序变量。有关这些变量类型的更多信息，请参见以下各节：

  • 定义 URL 参数
  • 定义表单参数
  • 定义会话变量
  • 定义用于 ASP 和 ColdFusion 的应用程序变量

本节讨论可定义为内容源的用于不同文档类型的服务器变量。文档类型及其相关章节如下所示：

  • 定义 ASP 服务器变量
  • 定义 ColdFusion 服务器变量
  • 定义 JSP 服务器变量


定义 ASP 服务器变量

可以将下列 ASP 服务器变量定义为动态内容源：Request.Cookie、Request.QueryString、Request.Form、Request.ServerVariables 和 Request.ClientCertificates。

若要定义用于 ASP 页面的服务器变量，请执行以下操作：

  1. 打开“绑定”面板（“窗口”>“绑定”）。
  2. 单击加号 (+) 按钮并从弹出菜单中选择“请求变量”。

    显示“请求变量”对话框。从“类型”弹出菜单中选择一个请求集合。

    例如，如果要访问 Request.ServerVariables 集合中的信息，则请选择“服务器变量”。如果要访问 Request.Form 集合中的信息，则选择“表单”。

    有关这些变量的更多信息，请参见设置“请求变量”对话框选项 (ASP)。

  3. 指定集合中想要访问的变量。

    例如，如果要访问 Request.ServerVariables("HTTP_USER_AGENT") 变量中的信息，则请输入参数 HTTP_USER_AGENT。如果要访问 Request.Form("lastname") 变量中的信息，则请输入参数 lastname。

  4. 单击“确定”。

    服务器变量即会出现在“绑定”面板中。


定义 ColdFusion 服务器变量

可以将下列 ColdFusion 服务器变量定义为动态内容源：客户端、Cookie、CGI、服务器和本地变量。要了解有关这些服务器变量的更多信息，请参见 ASP 服务器变量。

若要定义用于 ColdFusion 页面的服务器变量，请执行以下操作：

  1. 打开“绑定”面板（“窗口”>“绑定”）。
  2. 单击加号 (+) 按钮并从弹出菜单中选择该服务器变量。
  3. 输入变量名称。

    有关可能存在的名称项的更多信息，请单击“帮助”按钮。

  4. 单击“确定”。

    ColdFusion 服务器变量即会出现在“绑定”面板中。

相关主题：

  • 定义 URL 参数
  • 定义会话变量
  • 定义用于 ASP 和 ColdFusion 的应用程序变量
  • 向 Web 页中添加动态内容


定义 PHP 服务器变量

可以将 PHP 服务器变量定义为 PHP 文档类型的动态内容源。

若要定义用于 PHP 页面的服务器变量，请执行以下操作：

  1. 打开“绑定”面板（“窗口”>“绑定”）。
  2. 单击加号 (+) 按钮并从弹出菜单中选择该变量。
  3. 输入变量名称。
  4. 单击“确定”。

    PHP 服务器变量即会出现在“绑定”面板中。

相关主题：

  • 定义 URL 参数
  • 向 Web 页中添加动态内容


定义 JSP 服务器变量

可以将请求变量定义为 JSP 页面的动态内容源。

若要定义用于 JSP 页面的请求变量，请执行以下操作：

  1. 打开“绑定”面板（“窗口”>“绑定”）。
  2. 单击加号 (+) 按钮并从弹出菜单中选择“请求变量”。
  3. 输入变量名称。
  4. 单击“确定”。

    JSP 服务器变量即会出现在“绑定”面板中。

相关主题：

  • 定义 URL 参数
  • 向 Web 页中添加动态内容


缓存内容源

可以在“设计备注”中缓存或存储动态内容源。这样，即使您无权访问存储动态内容源的数据库或应用程序服务器，也可以在站点中工作。通过消除对数据库和应用程序服务器的网络重复访问，缓存还可能会加快开发速度。

若要缓存内容源，请执行以下操作：

  • 单击“绑定”面板右上角的箭头按钮，并在弹出菜单中切换“缓存”。

    如果对其中一个内容源进行了更改，可以单击“绑定”面板右上角的“刷新”按钮（圆形箭头图标）刷新缓存。（如果看不到该按钮，请展开面板。）


更改或删除内容源

可以更改或删除任何现有的动态内容源，即“绑定”面板中列出的任何内容源。

在“绑定”面板中更改或删除内容源不会 更改或删除页面中该内容的任何实例。而只是将它作为可能的页面内容源进行更改或删除。若要编辑或删除页面中的内容实例，请参见编辑动态内容和删除动态内容。

若要在“绑定”面板中更改内容源，请执行以下操作：

  1. 在“绑定”面板（“窗口”>“绑定”）中，双击您想要编辑的内容源的名称。
  2. 在出现的对话框中进行更改。
  3. 如果对所做的工作感到满意，请单击“确定”。

若要从“绑定”面板中删除内容源，请执行以下操作：

  1. 在“绑定”面板（“窗口”>“绑定”）中，从列表中选取内容源。
  2. 单击减号 (-) 按钮。

相关主题

  • 关于动态内容源


将记录集从一个页面复制到另一个页面

在定义的站点内，可以将记录集从一个页面复制到另一个页面。

若要将记录集复制到另一个页面，请执行以下操作：

  1. 在“绑定”面板或“服务器行为”面板中选取记录集。
  2. 右键单击该记录集并从弹出菜单中选择“复制”。
  3. 打开您想要向其复制记录集的页面。
  4. 右键单击“绑定”面板或“服务器行为”工具栏，并从弹出菜单中选择“粘贴”。

相关主题：

  • 关于动态内容源
  • 更改或删除内容源


参考资料

本节描述本章中介绍的以下面板和对话框：

  • 设置“绑定”面板选项
  • 设置简单“记录集”对话框选项
  • 设置简单“记录集”对话框选项 (ColdFusion)
  • 设置简单“数据集”对话框选项 (ASP.NET)
  • 设置高级“记录集”对话框
  • 设置高级“记录集”对话框 (ASP.NET)
  • 设置高级“记录集”对话框选项 (ColdFusion)
  • 设置“请求变量”对话框选项 (ASP)
  • 设置“添加参数”对话框选项
  • 设置“添加参数”对话框选项
  • 设置“添加参数”对话框选项 (PHP)
  • 设置“请求变量”对话框选项 (JSP)
  • 设置“会话变量”对话框选项
  • 设置“应用程序变量”对话框选项
  • 设置“URL 变量”对话框选项 (ColdFusion)
  • 设置“表单变量”对话框选项 (ColdFusion)
  • 设置“客户端变量”对话框选项 (ColdFusion)
  • 设置“Cookie 变量”对话框选项
  • 设置“CGI 变量”对话框选项
  • 设置“服务器变量”对话框选项
  • 设置“本地变量”对话框选项


设置“绑定”面板选项

该面板用于定义和编辑动态内容源、向页面添加动态内容以及将数据格式应用于动态文本。使用“绑定”面板的方式取决于您想要执行的任务。下列主题描述了各项任务使用“绑定”面板的方式。

您可以使用此面板执行以下任务：

  • 定义 URL 参数
  • 定义会话变量
  • 定义用于 ASP 和 ColdFusion 的应用程序变量
  • 定义服务器变量
  • 缓存内容源
  • 缓存内容源
  • 更改或删除内容源
  • 将记录集从一个页面复制到另一个页面
  • 将 HTML 属性动态化

相关主题

  • 了解记录集
  • 向 Web 页中添加动态内容


设置简单“记录集”对话框选项

此对话框将记录集定义为动态内容源，而不必手动编写 SQL 语句代码。

设置简单“记录集”对话框选项：

  1. 在“名称”文本框中，输入记录集的名称。

    通常的做法是在记录集名称前添加前缀 rs，以将其与代码中的其他对象名称区分开。例如：rsPressReleases

    注意记录集名称只能包含字母、数字和下划线字符 (_)。不能使用特殊字符或空格。

  2. 从“连接”弹出菜单中选取一个连接。

    如果列表中未出现连接，请单击“定义”创建连接。

  3. 在“表”弹出菜单中，选取为记录集提供数据的数据库表。

    弹出菜单显示指定数据库中的所有表。

  4. 若要使记录集中只包括某些表列，请单击“已选定”，然后按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 列表中的列，以选择所需列。
  5. 若要只包括表的某些记录，请按照下列步骤完成“过滤器”部分：
    • 在第一个弹出菜单中，选取数据库表中的列，以将其与定义的测试值进行比较。
    • 在第二个弹出菜单中选取一个条件表达式，以便将每个记录中的选定值与测试值进行比较。
    • 在第三个弹出菜单中选取“输入的值”。
    • 在文本框中输入测试值。

    如果记录中的指定值符合筛选条件，则将该记录包括在记录集中。

  6. 如果要对记录进行排序，请选取要作为排序依据的列，然后指定是按升序（1、2、3... 或 A、B、C...）还是按降序对记录进行排序。
  7. 单击“测试”连接到数据库并创建数据源实例。

    出现显示返回数据的表格。每行包含一条记录，而每列表示该记录中的一个域。单击“确定”关闭数据源。

  8. 单击“确定”。

    新定义的记录集即会出现在“绑定”面板中。

相关主题

  • 不通过编写 SQL 来创建记录集
  • 通过编写 SQL 来创建高级记录集
  • 数据库初学者指南


设置简单“记录集”对话框选项 (ColdFusion)

使用此对话框可将用于 ColdFusion 文档类型的记录集定义为动态内容源，而无须手动编写 SQL 语句代码。

注意

如果创建的是用于 ColdFusion 5 或更早版本的记录集，则使用其它文档类型（如 ASP 和 JSP）通用的普通“简单记录集”对话框。

若要设置用于 ColdFusion 的简单“记录集”对话框选项，请执行以下操作：

  1. 在“名称”文本框中，输入记录集的名称。

    通常的做法是在记录集名称前添加前缀 rs，以将其与代码中的其它对象名称区分开。例如：rsPressReleases

    注意记录集名称只能包含字母、数字和下划线字符 (_)。不能使用特殊字符或空格。

  2. 如果要定义用于 ColdFusion 组件的记录集（即，如果当前在 Dreamweaver 中打开 CFC 文件），请从“函数”弹出式菜单中选择一个现有的 CFC 函数，或单击“新函数”按钮来创建一个新函数。

    注意

    仅在当前文档为 CFC 文件且您有权访问运行 ColdFusion MX 7 或更高版本的计算机时，才可以使用“函数”弹出式菜单。有关更多信息，请参见启用 ColdFusion 增强功能。

    记录集将在函数中定义。有关更多信息，请参见在 ColdFusion 组件中定义记录集。

  3. 从“数据源”弹出菜单中选取数据源。

    如果弹出菜单中未出现数据源，则需要创建 ColdFusion 数据源。

  4. 如果需要，在“用户名”和“密码”文本框中，输入 ColdFusion 应用程序服务器的用户名和密码。

    访问 ColdFusion 中的数据源时可能需要用户名和密码。如果您没有访问 ColdFusion 中的数据源所需的用户名和密码，请与组织的 ColdFusion 管理员联系。

  5. 在“表”弹出菜单中，选取为记录集提供数据的数据库表。

    “表”弹出菜单显示指定数据库中的所有表。

  6. 若要在记录集中包含表列的子集，请单击“已选定”，然后按住 Ctrl 键单击 (Windows) 或按住 Command 键单击 (Macintosh) 表中的列，以选择所需列。
  7. 通过创建过滤器可以进一步限制从表中返回的记录：
    • 在第一个弹出菜单中，选取数据库表中的列，以将其与定义的测试值进行比较。
    • 在第二个弹出菜单中选取一个条件表达式，以便将每个记录中的选定值与测试值进行比较。
    • 在第三个弹出菜单中选取“输入的值”。
    • 在文本框中输入测试值。

    如果记录中的指定值符合筛选条件，则该记录将包括在记录集中。

  8. 如果要对记录进行排序，请选取要作为排序依据的列，然后指定是按升序（1、2、3... 或 A、B、C...）还是按降序对记录进行排序。
  9. 单击“测试”连接到数据库并创建数据源实例。

    出现显示返回数据的表格。每行包含一条记录，而每列表示该记录中的一个域。单击“确定”关闭测试记录集。

  10. 单击“确定”。

    新定义的 ColdFusion 记录集即会出现在“绑定”面板中。

相关主题

  • ColdFusion 开发人员的数据库连接
  • 不通过编写 SQL 来创建记录集
  • 通过编写 SQL 来创建高级记录集
  • 数据库初学者指南


设置简单“数据集”对话框选项 (ASP.NET)

使用此对话框可以将数据集（在其它动态文档类型中通常称作“记录集”）定义为动态内容源，而无须手动编写 SQL 语句代码。

若要设置用于 ASP.NET 的简单“数据集”选项，请执行以下操作

  1. 在“名称”文本框中，输入数据集的名称。

    通常的做法是在数据集名称前添加前缀 ds，以将其与代码中的其它对象名称区分开。例如：dsPressReleases

    注意数据集名称只能包含字母、数字和下划线字符 (_)。不能使用特殊字符或空格。

  2. 从“连接”弹出菜单中选取一个连接。

    如果列表中未出现连接，请单击“定义”创建连接。

  3. 在“表”弹出菜单中，选取为数据集提供数据的数据库表。

    弹出菜单显示指定数据库中的所有表。

  4. 若要在数据集中包含表列的子集，请单击“已选定”，然后按住 Ctrl 键单击 (Windows) 或按住 Command 键单击 (Macintosh) 表中的列，以选择所需列。
  5. 若要只包括表的某些记录，请按照下列步骤完成“过滤器”部分：
    • 在第一个弹出菜单中，选取数据库表中的列，以将其与定义的测试值进行比较。
    • 在第二个弹出菜单中选取一个条件表达式，以便将每个记录中的选定值与测试值进行比较。
    • 在第三个弹出菜单中选取“输入的值”。
    • 在文本框中输入测试值。

    如果记录中的指定值符合筛选条件，则将该记录包括在数据集中。

  6. 如果要对记录进行排序，请选取要作为排序依据的列，然后指定是按升序（1、2、3... 或 A、B、C...）还是按降序对记录进行排序。
  7. 如果由于某种原因而导致数据集查询失败，则可以指定一个页面，以将用户重定向至该页面。例如，如果在查询过程中数据库变得不可用并且未能返回页面的数据集，则可以显示一个含有到站点主页的链接的错误信息页面。
  8. 单击“测试”连接到数据库并创建数据源实例。

    出现显示返回数据的表格。每行包含一条记录，而每列表示该记录中的一个域。单击“确定”关闭数据集。

  9. 单击“确定”。

    新定义的数据集即会出现在“绑定”面板中。

相关主题

  • ASP.NET 开发人员的数据库连接
  • 不通过编写 SQL 来创建记录集
  • 通过编写 SQL 来创建高级记录集
  • 数据库初学者指南


设置高级“记录集”对话框

使用此对话框可以将记录集定义为动态内容源，方法是编写自定义的 SQL 语句，或使用图形化的“数据库项”树创建 SQL 语句。

若要完成此对话框，请执行以下操作：

  1. 在“名称”文本框中，输入记录集的名称。

    通常的做法是在记录集名称前添加前缀 rs，以将其与代码中的其他对象名称区分开。例如：rsPressRelease

    注意记录集名称只能包含字母、数字和下划线字符 (_)。不能使用特殊字符或空格。

  2. 从“连接”弹出菜单中选取一个连接。
  3. 在 SQL 文本区域中输入一个 SQL 语句，或使用对话框底部的图形化“数据库项”树从所选的记录集生成一个 SQL 语句。

    有关编写 SQL 语句的更多信息，请参见 SQL 入门和使用“数据库项”树创建 SQL 查询。

    如果想要使用“数据库项”树生成 SQL 语句，请执行下列操作：

    • 确保 SQL 文本区域为空。
    • 展开树的分支直到找到所需的数据库对象，例如表中的列或数据库中的预存过程。
    • 选取该数据库对象并单击树右侧的按钮之一。

    例如，如果选取表列，则可用的按钮是“SELECT”、“WHERE”和“ORDER BY”。单击这些按钮之一将关联的子句添加到 SQL 语句中。

    您还可以使用在预存过程中预定义的 SQL 语句，方法是从“数据库项”树中选取该预存过程并单击“过程”按钮。Dreamweaver 自动填充“SQL”和“变量”区域。

  4. 如果 SQL 语句包含变量，请在“变量”区域中定义它们的值，方法是单击加号 (+) 按钮并输入变量名称、默认值（如果未返回运行时值，则变量应取该值）和运行时值。

    如果 SQL 语句包含变量，请确保“变量”框的“默认值”列包含有效的测试值。

    运行时值通常是用户在 HTML 表单域中输入的 URL 或表单参数。有关 URL 和表单参数的更多信息，请参见为页面获取数据。

    “运行时值”列中的 URL 参数。

    服务器模型

    URL 参数的运行时值表达式

    ASP

    Request.QueryString(“formFieldName”)

    JSP

    request.getParameter("formFieldName")

    PHP

    #formFieldName#

    “运行时值”列中的表单参数：

    服务器模型

    表单参数的运行时值表达式

    ASP

    Request.Form(“formFieldName”)

    JSP

    request.getParameter("formFieldName")

    PHP

    #formFieldName#
  5. 单击“测试”连接到数据库并创建一个记录集实例。

    如果 SQL 语句包含变量，则在单击“测试”前，请确保“变量”框的“默认值”列包含有效的测试值。

    如果成功，将出现一个显示记录集中数据的表格。每行包含一条记录，而每列表示该记录中的一个域。单击“确定”清除该记录集。

  6. 如果对所做的工作感到满意，请单击“确定”。

相关主题

  • ASP 开发人员的数据库连接
  • 用于 JSP 开发人员的数据库连接
  • 适用于 PHP 开发人员的数据库连接
  • 通过编写 SQL 来创建高级记录集
  • 使用“数据库项”树创建 SQL 查询
  • 数据库初学者指南
  • SQL 入门


设置高级“记录集”对话框 (ASP.NET)

此对话框用于将数据集定义为动态内容源，方法是编写自定义的 SQL 语句，或使用“数据库项”树创建 SQL 语句。

若要设置用于 ASP.NET 的高级“记录集”对话框选项，请执行以下操作：

  1. 在“名称”文本框中，输入数据集的名称。

    通常的做法是在数据集名称前添加前缀 ds，以将其与代码中的其它对象名称区分开。例如：dsPressRelease

    注意数据集名称只能包含字母、数字和下划线字符 (_)。不能使用特殊字符或空格。

  2. 从“连接”弹出菜单中选取一个连接。
  3. 在 SQL 文本区域中输入一个 SQL 语句，或使用对话框底部的“数据库项”树从所选的数据库表生成 SQL 语句。

    有关编写用于 ASP.NET 的 SQL 语句的更多信息，请参见：

    • 使用“数据库项”树创建 SQL 查询
    • 使用“数据库项”树创建 SQL 查询
    • SQL 入门

    如果想要使用“数据库项”树生成 SQL 语句，请执行下列操作：

    • 确保 SQL 文本区域为空。
    • 展开树的分支直到找到所需的数据库对象，例如表中的列或数据库中的预存过程。
    • 选取该数据库对象并单击树右侧的按钮之一。

    例如，如果选取表列，则可用的按钮是“SELECT”、“WHERE”和“ORDER BY”。单击这些按钮之一将关联的子句添加到 SQL 语句中。

    您还可以使用在预存过程中预定义的 SQL 语句，方法是从“数据库项”树中选取该预存过程并单击“过程”按钮。Dreamweaver 将自动填充“SQL”和“参数”区域。

  4. 如果由于某种原因而导致数据集查询失败，则可以指定一个页面，以将用户重定向至该页面。例如，如果在查询过程中数据库变得不可用并且未能返回页面的数据集，则可以显示一个含有到站点主页的链接的错误信息页面。
  5. 如果 SQL 语句包含参数，请在“参数”区域中定义它们的值，方法是单击加号 (+) 按钮并输入参数名称和默认值（如果未返回运行时值，则参数应取该值）。

    如果 SQL 语句包含参数，请确保“参数”框的“默认值”列包含有效的测试值。

    使用“页面参数”可以为您编写的 SQL 中的运行时值引用提供默认值。例如，下面的 SQL 语句将根据雇员的 ID 值选取一个雇员记录。可以为此参数指定默认值，确保总是返回运行时值。在本例中，FormFieldName 指的是用户可以在其中输入他们的雇员 ID 的表单域：

    “SELECT * FROM Employees WHERE EmpID = “ + (Request.Form(“FormFieldName”))

    “添加页面参数”对话框应包含一个与下面类似的名称/值对：

    名称

    默认值

    FormFieldName

    0001

    运行时值通常是用户在 HTML 表单域中输入的 URL 或表单参数。有关 URL 和表单参数的更多信息，请参见为页面获取数据。

  6. 单击“测试”连接到数据库并创建一个记录集实例。

    如果 SQL 语句包含运行时引用，则在单击“测试”前，请确保“页面参数”域的“默认值”列包含有效的测试值。

    如果成功，则出现一个显示数据集中数据的表格。每行包含一条记录，而每列表示该记录中的一个域。单击“确定”清除该数据集。

  7. 如果对所做的工作感到满意，请单击“确定”。

相关主题

  • ASP.NET 开发人员的数据库连接
  • 定义记录集
  • 数据库初学者指南
  • SQL 入门


设置高级“记录集”对话框选项 (ColdFusion)

使用高级“记录集”对话框可以编写自定义的 SQL 查询，也可以在使用“指向并单击”界面时使用“数据库项”树创建 SQL 查询。

注意

如果创建的是用于 ColdFusion 5 或更早版本的高级记录集，则请使用其它文档类型（如 ASP 和 JSP）通用的普通高级“记录集”对话框。

若要完成此对话框，请执行以下操作：

  1. 在“名称”文本框中，输入记录集的名称。

    通常的做法是在记录集名称前添加前缀 rs，以将其与代码中的其它对象名称区分开。例如：rsPressReleases

    注意记录集名称只能包含字母、数字和下划线字符 (_)。不能使用特殊字符或空格。

    如果要定义用于 ColdFusion 组件的记录集（即，如果当前在 Dreamweaver 中打开 CFC 文件），请从“函数”弹出式菜单中选择一个现有的 CFC 函数，或单击“新函数”按钮来创建一个新函数。

    注意

    仅在当前文档为 CFC 文件且您有权访问运行 ColdFusion MX 7 或更高版本的计算机时，才可以使用“函数”弹出式菜单。有关更多信息，请参见启用 ColdFusion 增强功能。

    记录集将在函数中定义。有关更多信息，请参见在 ColdFusion 组件中定义记录集。

  2. 从“数据源”弹出菜单中选取数据源。

    如果该弹出菜单列表中未出现数据源，则需要首先创建 ColdFusion 数据源。有关更多信息，请参见 ColdFusion 开发人员的数据库连接。

  3. 如果需要，在“用户名”和“密码”文本框中，输入 ColdFusion 应用程序服务器的用户名和密码。

    访问 ColdFusion 中的数据源时可能需要用户名和密码。如果您没有访问 ColdFusion 中的数据源所需的用户名和密码，请与组织的 ColdFusion 管理员联系。

  4. 在 SQL 文本区域中输入一个 SQL 语句，或使用该对话框底部的图形化“数据库项”树从所选的记录集生成一个 SQL 语句。

    有关更多信息，请参见 SQL 入门和使用“数据库项”树创建 SQL 查询

如果想要使用“数据库项”树生成 SQL 语句，请执行下列操作：

  • 确保 SQL 文本区域为空。
  • 展开树的分支直到找到所需的数据库对象，例如表中的列。
  • 选取该数据库对象并单击树右侧的按钮之一。

    例如，如果选取表列，则可用的按钮是“SELECT”、“WHERE”和“ORDER BY”。单击这些按钮之一将关联的子句添加到 SQL 语句中。

  1. 如果 SQL 语句包含参数，请在“参数”区域中定义它们的值，方法是单击加号 (+) 按钮并输入参数名称和默认值（如果未返回运行时值，则参数应取该值)。

    如果 SQL 语句包含参数，请确保“参数”框的“默认值”列包含有效的测试值。

    使用“页面参数”可以为您编写的 SQL 中的运行时值引用提供默认值。例如，下面的 SQL 语句将根据雇员的 ID 值选取一个雇员记录。可以为此参数指定默认值，确保总是返回运行时值。在本例中，FormFieldName 指的是用户可以在其中输入他们的雇员 ID 的表单域：

    SELECT * FROM Employees WHERE EmpID = + (Request.Form(#FormFieldName#))

    “添加页面参数”对话框应包含一个与下面类似的名称/值对：

    名称

    默认值

    FormFieldName

    0001

    运行时值通常是用户在 HTML 表单域中输入的 URL 或表单参数。有关 URL 和表单参数的更多信息，请参见检索表单和 URL 参数。

  2. 单击“测试”连接到数据库并创建一个记录集实例。

    如果 SQL 语句包含运行时引用，则在单击“测试”前，请确保“页面参数”域的“默认值”列包含有效的测试值。

    如果成功，将出现一个显示记录集中数据的表格。每行包含一条记录，而每列表示该记录中的一个域。单击“确定”清除该记录集。

  3. 如果对所做的工作感到满意，请单击“确定”。

相关主题

  • ColdFusion 开发人员的数据库连接
  • 定义记录集
  • 数据库初学者指南
  • SQL 入门


设置“请求变量”对话框选项 (ASP)

此对话框将 ASP 请求变量定义为动态内容源。

若要完成此对话框，请执行以下操作：

  1. 从“类型”弹出菜单中选择一个请求集合。

    例如，如果要访问 Request.ServerVariables 集合中的信息，则请选择“服务器变量”。如果要访问 Request.Form 集合中的信息，则选择“表单”。

    请求集合详述如下：

    QueryString 集合检索附加到发送页面 URL 的信息（例如，当该页面包含使用 GET 方法的 HTML 表单时）。查询字符串由一个或多个名称/值对（例如 last=Smith、first=Winston）组成，这些名称/值对使用一个问号 (?) 附加到 URL 后面。如果查询字符串包含多个名称/值对，则用 & 符号将它们合并在一起。有关更多信息，请参见 URL 参数。

    Form 集合检索表单信息，该信息包含在使用 POST 方法的 HTML 表单所发送的 HTTP 请求的正文中。有关更多信息，请参见表单参数。

    ServerVariables 集合检索预定义环境变量的值。该集合含有一个很长的变量列表，包括 CONTENT_LENGTH（HTTP 请求中所提交内容的长度，可以用它查看表单是否为空）和 HTTP_USER_AGENT（提供有关用户浏览器的信息）。

    例如，Request.ServerVariables("HTTP_USER_AGENT") 包含有关提交浏览器的信息，如 Mozilla/4.07 [en] (WinNT; I) 表示 Netscape Navigator 4.07 浏览器。

    有关 ASP 服务器环境变量的完整列表，请参见与 Microsoft Personal Web Server (PWS) 或 Internet Information Server (IIS) 一起安装的在线文档。

    Cookie 集合检索在 HTTP 请求中发送的 Cookie 的值。例如，假设页面读取用户系统上的一个名为“readMe”的 Cookie。在服务器上，该 Cookie 的值将存储在变量 Request.Cookies("readMe") 中。

    ClientCertificate 集合从浏览器发送的 HTTP 请求中检索认证域。X.509 标准中指定了认证域。

  2. 指定集合中想要访问的变量。

    例如，如果要访问 Request.ServerVariables("HTTP_USER_AGENT") 变量中的信息，则请输入参数 HTTP_USER_AGENT。如果要访问 Request.Form("lastname") 变量中的信息，则请输入参数 lastname。

  3. 单击“确定”。

    请求变量即会出现在“绑定”面板中。

相关主题

  • 表单参数
  • 定义 URL 参数
  • 定义 ASP 服务器变量


设置“添加参数”对话框选项

“添加参数”对话框可用于定义 SQL 语句中包含的参数，方法是输入参数的名称和默认值（如果未返回运行时值，则参数应取该值）。

若要定义 SQL 参数，请执行以下操作：

  1. 从“名称”弹出菜单中选择一个参数名称。
  2. 在“默认参数”文本框中输入该参数的默认值。

    默认值是未返回运行时值的情况下该参数应采用的值。

  3. 单击“确定”。

相关主题

  • 使用预存过程修改数据库 (ColdFusion)
  • 设置“ColdFusion 预存过程”对话框选项
  • 设置高级“记录集”对话框选项 (ColdFusion)
  • 检索表单和 URL 参数


设置“添加参数”对话框选项

“添加参数”对话框可用于定义 SQL 语句中包含的参数，方法是输入参数的名称和默认值（如果未返回运行时值，则参数应取该值）。

若要定义 SQL 参数，请执行以下操作：

  1. 从“名称”弹出菜单中选择一个参数名称。
  2. 在“默认参数”文本框中输入该参数的默认值。

    默认值是未返回运行时值的情况下该参数应采用的值。

  3. 单击“确定”。

相关主题

  • 使用预存过程修改数据库 (ASP.NET)
  • 设置“预存过程”对话框的选项 (ASP.NET)
  • 检索表单和 URL 参数


设置“添加参数”对话框选项 (PHP)

“添加参数”对话框可用于定义 SQL 语句中包含的参数，方法是输入该参数的名称、默认值和运行时值。

若要定义用于 PHP 文档的 SQL 参数，请执行以下操作：

  1. 在“名称”文本框中输入一个参数名称。
  2. 在“默认参数”文本框中输入该参数的默认值。

    默认值是未返回运行时值的情况下该参数应采用的值。

  3. 在“运行时值”文本框中输入参数的运行时值。

    运行时值通常是用户在 HTML 表单域中输入的 URL 或表单参数。

  4. 单击“确定”。

相关主题

  • 检索表单和 URL 参数


设置“请求变量”对话框选项 (JSP)

此对话框将 JSP 请求变量定义为页面的动态内容源。

若要定义 JSP 请求变量，请执行以下操作：

  1. 输入变量名称。

    请求变量通常是表单或 URL 参数。如果参数是通过 HTML 表单传递的，则变量名称就是用于获取该变量值的表单域或对象的名称。

  2. 单击“确定”。

    JSP 请求变量即会出现在“绑定”面板中。

相关主题

  • 定义 URL 参数
  • 定义会话变量


设置“会话变量”对话框选项

此对话框将会话变量定义为页面的动态内容源。

若要定义会话变量，请执行以下操作：

  1. 输入会话变量的名称，即它在应用程序源代码中的名称。

    有关更多信息，请参见将信息存储在会话变量中

  2. 单击“确定”。

    新定义的会话变量即会出现在“绑定”面板中。

相关主题

  • 定义会话变量
  • 定义服务器变量


设置“应用程序变量”对话框选项

此对话框将应用程序变量定义为页面的动态内容源。

若要定义应用程序变量，请执行以下操作：

  1. 在“名称”文本框中，输入应用程序变量的名称，即它在应用程序源代码中的名称。
  2. 单击“确定”。

    新定义的应用程序变量即会出现在“绑定”面板中。

相关主题

  • 定义用于 ASP 和 ColdFusion 的应用程序变量
  • 定义服务器变量


设置“URL 变量”对话框选项 (ColdFusion)

此对话框将 ColdFusion URL 变量定义为页面的动态内容源。

若要定义 ColdFusion URL 变量，请执行以下操作：

  1. 在“名称”文本框中，输入 URL 变量的名称。

    通常情况下，该变量名称是用于获取该变量值的 HTML 表单域或对象的名称。

  2. 单击“确定”。

    新定义的 ColdFusion URL 变量即会出现在“绑定”面板中。

相关主题

  • 使用 HTML 链接创建 URL 参数
  • 定义 URL 参数
  • 定义 ColdFusion 服务器变量


设置“表单变量”对话框选项 (ColdFusion)

此对话框将 ColdFusion 表单变量定义为页面的动态内容源。

若要定义 ColdFusion 表单变量，请执行以下操作：

  1. 在“名称”文本框中，输入表单变量的名称。

    该变量名称是用于获取该变量值的 HTML 表单域或对象的名称。

  2. 单击“确定”。

    ColdFusion 表单变量即会出现在“绑定”面板中。

相关主题

  • 定义 URL 参数
  • 定义服务器变量


设置“客户端变量”对话框选项 (ColdFusion)

此对话框将 ColdFusion 客户端变量定义为页面的动态内容源。

若要定义 ColdFusion 客户端变量，请执行以下操作：

  1. 在“名称”文本框中输入变量名称。

    例如，如果您想访问 Client.LastVisit ColdFusion 变量中的信息，请输入 LastVisit。

    客户端变量是在代码中创建的、用于将数据和特定客户端关联的变量。当用户在应用程序中从一个页面移动到另一个页面或从一个会话移动到另一个会话时，客户端变量将保持应用程序的状态。

    客户端变量可以是用户定义的，也可以是内置的。下表列出了内置的 ColdFusion 客户端变量：

    变量

    描述

    Client.CFID

    每个连接到服务器的客户端的递增 ID。

    Client.CFTOKEN

    随机生成的用于唯一标识特定客户端的编号。

    Client.URLToken

    不使用 Cookie 时，在模板之间传递的 CFID 和 CFTOKEN 的组合。

    Client.LastVisit

    记录客户端所进行的最后一次访问的时间戳。

    Client.HitCount

    单个客户端的页面请求数（使用 CFID 和 CFTOKEN 跟踪）。

    Client.TimeCreated

    记录第一次为特定客户端创建 CFID 和 CFTOKEN 时的时间戳。
  2. 单击“确定”。

    新定义的 ColdFusion 客户端变量即会出现在“绑定”面板中。

相关主题

  • 定义 ColdFusion 服务器变量


设置“Cookie 变量”对话框选项

此对话框用于定义 ColdFusion Cookie 变量。

若要定义 ColdFusion Cookie 变量，请执行以下操作：

  1. 在“名称”文本框中输入 Cookie 变量的名称。

    Cookie 变量即会在代码中创建，并访问由浏览器传递给服务器的 Cookie 中包含的信息。

  2. 单击“确定”。

Cookie 变量即会出现在“绑定”面板中。

相关主题

  • 定义 ColdFusion 服务器变量


设置“CGI 变量”对话框选项

此对话框用于定义 ColdFusion CGI 变量。

若要定义 ColdFusion CGI 变量，请执行以下操作：

  1. 在“名称”文本框中输入变量名称。

    例如，如果您想访问 CGI.HTTP_REFERER 变量中的信息，请输入 HTTP_REFERER。

    下表列出了在服务器中创建的最常见的 ColdFusion CGI 变量：

    变量

    描述

    SERVER_SOFTWARE

    回复请求（以及运行网关）的信息服务器软件的名称和版本。格式:name/version.

    SERVER_NAME

    服务器的主机名、DNS 别名或出现在自引用的 URL 中的 IP 地址。

    GATEWAY_INTERFACE

    该服务器遵守的 CGI 规范的修订版。格式:CGI/修订版。

    SERVER_PROTOCOL

    此请求附带的信息协议的名称和修订版。格式:协议/修订版。

    SERVER_PORT

    该请求发送到的端口号。

    REQUEST_METHOD

    发送该请求时使用的方法。对于 HTTP，即为 Get、Head、Post 等。

    PATH_INFO

    客户端提供的额外路径信息。可以通过后跟额外信息的虚拟路径名访问脚本。额外信息作为 PATH_INFO 发送。

    PATH_TRANSLATED

    服务器提供 PATH_INFO 的转换版本，它采用该路径并对其执行任何虚拟-物理映射。

    SCRIPT_NAME

    所执行脚本的虚拟路径；用于自引用的 URL。

    QUERY_STRING

    引用此脚本的 URL 中问号 (?) 后面的查询信息。

    REMOTE_HOST

    发送请求的主机名。如果服务器没有该项信息，它将设置 REMOTE_ADDR，但不设置 REMOTE_HOST。

    REMOTE_ADDR

    发送请求的远程主机的 IP 地址。

    AUTH_TYPE

    如果服务器支持用户身份验证，并且脚本是受保护的，则此变量是用于验证用户的、协议特定的身份验证方法。

    REMOTE_USER AUTH_USER

    如果服务器支持用户身份验证，并且脚本是受保护的，则此变量为已验证有效的用户名。（也可用作 AUTH_USER。

    REMOTE_IDENT

    如果 HTTP 服务器支持 RFC 931 标识，此变量将设置为从服务器检索到的远程用户名。此变量仅用于日志记录。

    CONTENT_TYPE

    对于含有附加信息的查询（如 HTTP POST 和 PUT），此变量为数据的内容类型。

    CONTENT_LENGTH

    客户端提供的内容的长度。

    下表列出了由浏览器创建并传递给服务器的最常见的 CGI 变量：

    变量

    描述

    HTTP_REFERER

    引用文档。它指的是链接到或提交表单数据的文档。

    HTTP_USER_AGENT

    客户端当前用于发送请求的浏览器。格式:软件/版本 库/版本。

    HTTP_IF_MODIFIED_SINCE

    最后一次修改页面的时间。浏览器负责发送此变量，通常是响应已发送 LAST_MODIFIED HTTP 标题的服务器。此变量可用于利用浏览器端的缓存。
  2. 单击“确定”。

    CGI 变量即会出现在“绑定”面板中。

相关主题

  • 定义 ColdFusion 服务器变量


设置“服务器变量”对话框选项

此对话框用于定义 ColdFusion 服务器变量。

若要定义 ColdFusion 服务器变量，请执行以下操作：

  1. 在“名称”文本框中输入服务器变量的名称。

    例如，如果您想访问 Server.Trademark 变量中存储的信息，请输入 Trademark 作为变量名称。

    所有访问该服务器的客户端以及运行在该服务器上的任何应用程序都可以访问服务器变量。这些变量将一直持续到服务器停止工作。它们是用 ColdFusion CFSET 或 CFPARAM 标签创建的（借助于 CFLOCK）。

    服务器变量可以是用户定义的，也可以是内置的。下表列出了内置的 ColdFusion 服务器变量：

    变量

    描述

    Server.ColdFusion.ProductName

    ColdFusion 产品名。

    Server.ColdFusion.ProductVersion

    ColdFusion 版本号。

    Server.ColdFusion.ProductLevel

    ColdFusion 版本（企业版、专业版）

    Server.ColdFusion.SerialNumber

    当前安装的 ColdFusion 版本的序列号

    Server.OS.Name

    服务器上运行的操作系统的名称（Windows NT、Windows 2000、Linux）

    Server.OS.AdditionalInformation

    有关已安装的操作系统的附加信息（服务包、更新）

    Server.OS.Version

    已安装的操作系统的版本。

    Server.OS.BuildNumber

    已安装的操作系统的版本号。
  2. 单击“确定”。

    ColdFusion 服务器变量即会出现在“绑定”面板中。

相关主题

  • 定义 ColdFusion 服务器变量


设置“本地变量”对话框选项

此对话框用于定义 ColdFusion 本地变量。

若要定义 ColdFusion 本地变量，请执行以下操作：

  1. 在“名称”文本框中输入本地变量的名称。

    本地变量是用 ColdFusion 页面中的 CFSET 或 CFPARAM 标签创建的变量。

  2. 单击“确定”。

    该本地变量即会出现在“绑定”面板中。

相关主题

  • 定义 ColdFusion 服务器变量


向 Web 页中添加动态内容

本章描述了将各种页面元素动态化的最有效的方法。定义一个或多个动态内容源后，可以使用这些源向页面中添加动态内容。内容源可以包括记录集中的列、HTML 表单提交的值、服务器对象中包含的值或其它数据。有关更多信息，请参见定义动态内容源。

在 Macromedia Dreamweaver 8 中，几乎可以将动态内容放在 Web 页或其 HTML 源代码的任何地方。可以将动态内容放在插入点、替换文本字符串，或作为 HTML 属性插入。例如，动态内容可以定义图像的 src 属性或表单域的 value 属性。

本章包含下列章节：

关于添加动态内容

将文本动态化

将图像动态化

将 HTML 属性动态化

将 ActiveX、Flash 和其它对象参数动态化

编辑动态内容

删除动态内容

在 Contribute 站点中创建动态页


关于添加动态内容

通过在“绑定”面板中选择内容源，可以向页面中添加动态内容。Dreamweaver 在页面的代码中插入一个服务器端脚本，以指示服务器在浏览器请求该页面时，将内容源中的数据传输到页面的 HTML 代码中。

通常有多种将给定的页面元素动态化的方法。例如，若要将图像动态化，可以使用“绑定”面板、属性检查器或“插入”菜单中的“图像”命令。

默认情况下，一个 HTML 页面一次只能显示一条记录。若要显示记录集中的其它记录，可以添加一个链接以便逐条显示记录（请参见创建记录集导航链接），也可以创建重复区域以便在单个页面上显示多条记录（请参见显示多个记录集结果）。

本节包含以下概念性主题：

  • 动态文本
  • 更改动态内容


动态文本

动态文本采用应用于现有文本或插入点的任何文本格式。例如，如果堆叠样式表 (CSS) 样式影响所选的文本，则替换该文本的动态内容也将受到这种样式的影响。可以使用任何一种 Dreamweaver 文本格式设置工具添加或更改动态内容的文本格式。（请参见将印刷和页面布局元素应用于动态数据。）

还可以将数据格式应用于动态文本。例如，如果数据中含有日期，则可以指定一种特定的日期格式，如适用于美国访问者的 04/17/00 或适用于加拿大访问者的 17/04/00。（请参见使用预定义的数据格式。）

可以用动态文本替换页面上的常规文本，也可以在页面上的插入点处添加动态文本。


更改动态内容

通过对提供内容的服务器行为进行编辑，可以更改页面上的动态内容。例如，您可以编辑记录集服务器行为，以便向页面提供更多的记录。

在“服务器行为”面板中列出了页面上的动态内容。例如，如果向页面中添加了某记录集，则“服务器行为”面板将其以如下方式列出：

Recordset(myRecordset)

如果向页面中添加另一个记录集，则“服务器行为”面板以如下方式列出这两个记录集：

Recordset(mySecondRecordset)
Recordset(myRecordset)

相关主题：

  • 将文本动态化
  • 编辑动态内容
  • 删除动态内容


将文本动态化

可以用动态文本替换现有文本，也可以将动态文本放置在页面的某个给定插入点处。

若要添加动态文本，请执行以下操作：

  1. 通过选择“窗口”>“绑定”打开“绑定”面板。
  2. 请确保“绑定”面板列出了您要使用的内容源。

    内容源应包含纯文本（ASCII 文本）。纯文本包括 HTML。如果列表中没有内容源，或者可用的内容源不能满足您的需要，请单击加号 (+) 按钮以定义新的内容源。（请参见定义动态内容源。）

  3. 在“设计”视图中，选择页面上的文本，或者单击您要添加动态文本的位置。
  4. 在“绑定”面板中，从列表中选取内容源。如果选择记录集，请在记录集中指定所需的列。

  5. 单击“插入”，或将内容源拖到页面上。

如果您现在使用的是“设计”视图并且启用了“动态数据”（“查看”>“动态数据”），则动态内容将出现在页面上。

如果禁用了“动态数据”，则会出现一个占位符。（如果选择了页面上的文本，则占位符会替换所选文本）。表示记录集内容的占位符使用下面的语法：{RecordsetName.ColumnName}，其中 Recordset 是记录集的名称，而 ColumnName 是从该记录集中选择的列的名称。

有时，表示动态文本的占位符的长度会破坏“文档”窗口中的页面布局。可通过使用空的大括号作为占位符来解决这个问题。

若要创建动态文本占位符，请执行以下操作：

  1. 选择“编辑”>“首选参数”>“不可见元素”(Windows) 或者选择“Dreamweaver”>“首选参数”>“不可见元素”(Macintosh)。
  2. 在“显示动态文本于”弹出菜单中选择 {}。
  3. 单击“确定”。

相关主题

  • 关于添加动态内容
  • 动态文本


将图像动态化

可以将页面上的图像动态化。例如，假设您要设计一个页面，上面显示将要在慈善拍卖会上拍卖的物品。每个页面都将包含描述性文本和一件物品的一张照片。虽然每项的页面总体布局都一样，但照片（和描述性文本）会有所不同。

若要将图像动态化，请执行以下操作：

  1. 在“设计”视图（“查看”>“设计”）中打开页面，将插入点放置在页面上您希望图像出现的位置。
  2. 选择“插入”“图像”。

    出现“选择图像源文件”对话框。

  3. 单击“数据源”选项 (Windows) 或“数据源”按钮 (Macintosh)。

    出现内容源列表。

  4. 从该列表中选择一种内容源。

    内容源应是一个包含图像文件路径的记录集。根据站点的文件结构的不同，这些路径可以是绝对路径、文档相对路径或根目录相对路径。

    注意

    Dreamweaver 目前还不支持存储在数据库中的二进制图像。

    如果列表中没有出现任何记录集，或者可用的记录集不能满足您的需要，请定义新的记录集。有关说明，请参见了解记录集。

  5. 单击“确定”。


将 HTML 属性动态化

通过将 HTML 属性绑定到数据可以动态地更改页面的外观。例如，通过将表格的 background 属性绑定到记录集中的域，可以更改表格的背景图像。

可以使用“绑定”面板或属性检查器绑定 HTML 属性。

若要使用“绑定”面板将 HTML 属性动态化，请执行以下操作：

  1. 通过选择“窗口”>“绑定”打开“绑定”面板。
  2. 确保“绑定”面板列出了您要使用的数据源。

    内容源应包含与您要绑定的 HTML 属性相适合的数据。如果列表中没有出现任何内容源，或者可用的内容源不能满足您的需要，请单击加号 (+) 按钮以定义新的数据源。有关说明，请参见定义动态内容源。

  3. 在“设计”视图中选择 HTML 对象。

    例如，若要选择 HTML 表格，请在表格内单击，然后在位于“文档”窗口左下方的标签选择器内单击 <table> 标签。

  4. 在“绑定”面板中，从列表中选择一种内容源。
  5. 在“绑定到”框中，从弹出菜单中选择一种 HTML 属性。
  6. 单击“绑定”。

当该页面下次在应用程序服务器中运行时，数据源的值将会赋给该 HTML 属性。

若要使用属性检查器将 HTML 属性动态化，请执行以下操作：

  1. 在“设计”视图中选择一个 HTML 对象，然后打开属性检查器（“窗口”>“属性”）。

    例如，若要选择 HTML 表格，请在表格内单击，然后在位于“文档”窗口左下方的标签选择器内单击 <table> 标签。

  2. 将动态内容源绑定到 HTML 属性的方式取决于该属性所在的位置：
    • 如果在属性检查器中您要绑定的属性的旁边有一个文件夹图标，请单击该文件夹图标以打开一个文件选择对话框，然后单击“数据源”选项显示数据源列表。
    • 如果您要绑定的属性旁边没有文件夹图标，请单击检查器左侧的“列表”标签（两个标签中位置较低的那个）。

      “属性”检查器的“列表”视图随即出现。

    • 如果“列表”视图中未列出您要绑定的属性，请单击加号 (+) 按钮，然后输入属性的名称，或者单击小箭头按钮，然后从弹出式菜单中选择该属性。
  3. 若要将属性值动态化，请单击该属性，然后单击位于该属性行末端的闪电图标或文件夹图标。

    如果单击了闪电图标，则将会出现一个数据源列表。

    这里提供了一个示例：

    如果单击了文件夹图标，则将会出现一个文件选择对话框。选择“数据源”选项以显示内容源列表。

  4. 从内容源列表中选择一种内容源。

    该内容源应包含与您要绑定的 HTML 属性相适合的数据。如果列表中没有出现任何内容源，或者可用的内容源不能满足您的需要，请定义新的内容源。有关说明，请参见为页面获取数据。

  5. 单击“确定”。

当该页面下次在应用程序服务器中运行时，数据源的值将会赋给该 HTML 属性。


将 ActiveX、Flash 和其它对象参数动态化

可以将 Java applet 和插件的参数动态化，也可以将 ActiveX、Macromedia Flash、Shockwave、Director 和生成器对象的参数动态化。

开始之前，请确保记录集中的域包含与您要绑定的对象参数相适合的数据。

若要将对象参数动态化，请执行以下操作：

  1. 在“设计”视图中，选择页面上的一个对象，然后打开属性检查器（“窗口”>“属性”）。
  2. 单击“参数”按钮。

    “参数”对话框随即出现。

  3. 如果列表中没有出现您需要的参数，请单击加号 (+) 按钮然后在“参数”列中输入参数名称。
  4. 单击参数的“值”列，然后单击闪电图标以指定一个动态值。

    将出现数据源列表。

  5. 从该列表中选择一种数据源。

    该数据源应包含与您要绑定的对象参数相适合的数据。如果列表中没有显示任何数据源，或者可用的数据源不能满足您的需要，请定义新的数据源。有关说明，请参见定义动态内容源。

  6. 单击“确定”。


编辑动态内容

若要编辑提供动态内容的服务器行为，请在“服务器行为”面板中双击该服务器行为。用于定义原始数据源的那个对话框就会出现。在该对话框中进行更改，然后单击“确定”。

还可以使用属性检查器编辑页面上的记录集。打开“属性”检查器（“窗口”>“属性”），然后在“服务器行为”面板（“窗口”>“服务器行为”）中选择该记录集。

如果在“动态数据”窗口内编辑记录集时未选定“自动刷新”选项，则必须刷新页面才能看到所做的更改。若要刷新页面，请单击“刷新”按钮或选择“查看”>“刷新动态数据”。

相关主题

  • 删除动态内容
  • 编辑动态内容


删除动态内容

向页面添加动态内容后，可以通过在页面上选中该动态内容然后按 Delete 键来删除它。也可以通过在“服务器行为”面板中选择该动态内容，然后单击减号 (-) 按钮来删除它。

注意

此操作移除页面中从数据库检索该动态内容的服务器端脚本。它并不删除数据库中的数据。

相关主题

  • 编辑动态内容
  • 编辑动态内容


在 Contribute 站点中创建动态页

当 Contribute 用户编辑包含动态内容或不可见元素（例如脚本和注释）的页面时，Contribute 会将动态内容和不可见元素显示为黄色标记。默认情况下，Contribute 用户不可选择或删除这些标记。

如果希望 Contribute 用户能够选择和删除页面中的动态内容和其它不可见元素，您可更改权限组设置以允许如此操作。Contribute 用户在任何情况下都不可以编辑动态内容，甚至当您允许他们选择动态内容时也不可以。

注意

利用某些服务器技术，您可使用服务器标签或函数来显示静态文本。若要允许 Contribute 用户编辑使用此类服务器技术的动态页中的静态文本，请将静态文本放在服务器标签之外。

若要允许一组 Contribute 用户从页面中删除代码，请执行以下操作：

  1. 选择“站点”>“管理 Contribute 站点”。
  2. 如果某些 Contribute 兼容性功能要求的选项没有启用，则出现一个对话框，询问是否要启用这些选项。单击“确定”启用这些选项和 Contribute 的兼容性功能。有关更多信息，请参见准备站点以用于 Contribute。
  3. 如果出现提示，请输入管理员密码，然后单击“确定”。

    随即出现“管理网站”对话框。

  4. 在“用户和角色”类别中，选择角色，然后单击“编辑角色设置”按钮。
  5. 选择“编辑”类别，然后取消选择保护脚本和表单的选项。有关更多信息，请参见为 Contribute 站点创建模板和管理 Macromedia Contribute。
  6. 单击“确定”关闭“编辑设置”对话框。
  7. 单击“关闭”关闭“管理网站”对话框。

相关主题

  • 使用 Dreamweaver 管理 Contribute 站点
  • 为 Contribute 站点创建模板


参考资料

本节提供在本章介绍的下列对话框和检查器的有关信息：

  • 设置“动态文本”对话框选项
  • 设置“动态数据”对话框选项
  • 设置记录集的“属性”检查器
  • 为 ColdFusion 预存过程、ASP 命令和 JSP 可调用对象设置“属性”检查器
  • 为 JSP 已准备语句设置“属性”检查器
  • 为重复区域设置“属性”检查器


设置“动态文本”对话框选项

此对话框用于添加动态内容或将现有文本动态化。

若要设置“动态文本”对话框选项，请执行以下操作：

  1. 从数据源列表中选择一种数据源。

    数据源应包含文本信息。如果列表中没有出现任何数据源，或者可用的数据源不能满足您的需要，请单击加号 (+) 按钮以定义新的数据源。有关说明，请参见显示数据库记录。

  2. 如果需要，请为该文本选择一种数据格式。

    有关更多信息，请参见使用预定义的数据格式。

  3. 如果需要，请修改 Dreamweaver 插入到页面中的代码以显示动态文本。
  4. 单击“确定”。

相关主题

  • 将文本动态化
  • 了解记录集


设置“动态数据”对话框选项

此对话框用于将 HTML 属性动态化。如果要将文本动态化，请参见设置“动态文本”对话框选项。

若要将 HTML 属性动态化，请执行以下操作：

  1. 从数据源列表中选择一种数据源。

    该数据源应包含与您要绑定的 HTML 属性相适合的数据。如果列表中没有显示任何数据源，或者可用的数据源不能满足您的需要，请定义新的数据源。有关说明，请参见显示数据库记录。

  2. 如果需要，请为该文本选择一种数据格式。

    有关更多信息，请参见使用预定义的数据格式。

  3. 如果需要，请修改 Dreamweaver 插入到页面中的代码以显示动态文本。
  4. 单击“确定”。

相关主题

  • 将 HTML 属性动态化


设置记录集的“属性”检查器

此“属性”检查器用于修改选定的记录集。

若要修改选定的记录集，请执行以下操作：

  • 编辑所有选项。在检查器中选择了新的选项之后，Dreamweaver 会更新该页面。

    可用选项因服务器模型而异。

相关主题

  • 编辑动态内容


为 ColdFusion 预存过程、ASP 命令和 JSP 可调用对象设置“属性”检查器

此“属性”检查器用于修改选定的预存过程。

若要修改选定的预存过程，请执行以下操作：

  • 编辑所有选项。在检查器中选择了新的选项之后，Dreamweaver 会更新该页面。

    可用选项因服务器技术而异。

相关主题

  • 编辑动态内容


为 JSP 已准备语句设置“属性”检查器

此“属性”检查器用于修改选定的 JSP 已准备语句。

若要修改选定的 JSP 已准备语句，请执行以下操作：

  • 编辑所有选项。在检查器中选择了新的选项之后，Dreamweaver 会更新该页面。

相关主题

  • 编辑动态内容


为重复区域设置“属性”检查器

此“属性”检查器用于修改选定的重复区域。

若要修改选定的重复区域，请执行以下操作：

更改以下各项：

  • 重复区域的名称
  • 为重复区域提供记录的记录集
  • 显示的记录数

选择了新的选项之后，Dreamweaver 会更新该页面。

相关主题

  • 编辑动态内容
  • 显示多个记录集结果


显示数据库记录

显示数据库记录涉及检索储存在数据库或其它内容源中的信息，以及将这些信息呈现到网页上。Macromedia Dreamweaver 8 提供了许多显示动态内容的方法，并提供了若干内置的服务器行为，使您可以增强动态内容的演示，并使用户能够更轻松地查找和导航从数据库返回的信息。

本章包含下列章节：

关于显示数据库记录

使用预定义的数据格式

创建记录集导航链接

基于记录集结果显示和隐藏区域

显示多个记录集结果

使用“重复区域”服务器行为创建表格

创建记录计数器


关于显示数据库记录

数据库和其它动态内容源为您搜索、排序和查看大量存储的信息提供了更多功能和灵活性。如果需要存储大量信息然后以有意义的方式检索并显示这些信息，那么使用数据库存储 Web 站点的内容将是一个不错的方法。Dreamweaver 为您提供了多种工具和预置的行为，以帮助您有效地检索和显示存储在数据库中的信息。以下章节介绍 Dreamweaver 服务器行为和格式元素，以及如何使用它们显示动态内容。

本节包含以下概念性主题：

  • 服务器行为和格式元素
  • 将印刷和页面布局元素应用于动态数据
  • 数据库记录集结果导航
  • 自定义记录集导航条
  • 基于记录集结果显示和隐藏区域
  • 显示多个记录集结果
  • 记录计数器


服务器行为和格式元素

Dreamweaver 提供了下列服务器行为和格式元素，使您可以增强动态内容的显示：

格式使您可以将不同类型的数字、货币、日期和时间以及百分比值应用于动态文本。

例如，如果记录集中某项的价格显示为 10.989，则选择 Dreamweaver 的“货币—用 2 位小数表示”格式后，该价格在页面上显示为 $10.99。这种格式使用两个小数位显示数字。如果数字具有两位以上的小数位，该数据格式会将数字四舍五入到最接近的数。如果数字不带小数位，该数据格式会添加一个小数点和两个零。

重复的区域服务器行为使您可以显示多个从数据库查询返回的项，还可指定每页显示的记录数。

记录集导航服务器行为使您可以插入导航元素，使用户能够移动到从记录集返回的下一组或前一组记录。例如，如果使用“重复的区域”服务器对象选择每页显示 10 条记录，并且记录集返回 40 条记录，则一次可以浏览 10 条记录。

记录集状态栏服务器行为使您可以包括计数器，向用户显示他们在记录集中相对于返回的总记录数的位置。

显示区域服务器行为使您可以根据当前显示的记录的相关性，选择显示或隐藏页面上的项目。例如，如果用户已导航到记录集中的最后一条记录，您可以隐藏“下一个”链接，而只显示“前一个”记录链接。


将印刷和页面布局元素应用于动态数据

Dreamweaver 的强大功能体现在它可以在结构化页面中显示动态数据，并通过 HTML 和 CSS 应用印刷格式。若要将格式应用于 Dreamweaver 中的动态数据，请使用 Dreamweaver 的格式设置工具设置动态数据的表格和占位符的格式。当数据从数据源插入时，它会自动采用您指定的字体、段落和表格格式设置。

要了解 Dreamweaver 的格式设置功能，以及如何将其应用于动态数据元素，请参见使用表格显示内容和插入文本和设置文本格式。


数据库记录集结果导航

记录集导航链接使用户可以从一个记录移到下一个，或者从一组记录移到下一组。例如，在设计了每次显示五条记录的页面后，您可能想要添加诸如“下一页”或“上一页”这类使用户可以显示后五条或前五条记录的链接。

Dreamweaver 允许创建四种类型的导航链接以遍历记录集：第一个、前一个、下一个和最后一个。一个页面可以包含任意数量的上述链接，只要它们都使用单一记录集。在同一页中无法添加遍历另一个记录集的链接。

注意

Microsoft ASP.NET 将记录集称为“数据集”。如果您使用的是 ASP.NET 文档类型，则特定于 ASP.NET 的对话框和菜单选项使用标签“数据集”。Dreamweaver 文档一般将这两种类型都称作“记录集”，但是，在专门描述 ASP.NET 功能时使用的是“数据集”。

记录集导航链接需要下列动态元素：

  • 要导航的记录集
  • 页面上用来显示记录的动态内容
  • 页面上用作可单击导航条的文本或图像
  • 用于导航记录集的一组“移至记录”服务器行为

后两个元素可以通过“记录导航条”服务器对象添加，或者分别通过 Dreamweaver 设计工具和“服务器行为”面板添加。

相关主题

  • 创建记录集导航链接


自定义记录集导航条

如果与通过“记录集导航条”服务器对象创建的简单表格相比，您要创建的记录集导航条所使用的布局和格式化样式更复杂，您可能更愿意创建自己的导航条。为此，您必须首先以文本或图像的形式创建所需的导航链接，并将它们放在“设计”视图的页面中，然后为每个导航链接分配单独的服务器行为。

您可以将以下各个服务器行为指定给导航链接：

  • 移到第一页
  • 移到最后一页
  • 移到下一页
  • 移到前一页

如果您更喜欢使用 Dreamweaver 的内置“记录集导航条”服务器对象创建导航条，请参见通过“记录集导航条”服务器行为创建导航条。


导航条设计任务

创建自定义导航条时，首先要使用 Dreamweaver 的网页设计工具创建它的可视表示形式。您不必为文本字符串或图像创建链接，Dreamweaver 会为您创建一个。

为其创建导航条的页面中必须包含要导航的记录集。有关更多信息，请参见了解记录集。

简单的记录集导航条可能如下图所示，它包含用图像创建的链接按钮或其它内容元素：

在将记录集添加到页面，并且创建了导航条之后，应该将单独的服务器行为应用于每个导航元素。例如，在典型的记录集导航条中，包含下列与适当行为匹配的链接：

导航链接 | 服务器行为
转到第一页 | 移到第一页
转到前一页 | 移到前一页
转到下一页 | 移到下一页
转到最后一页 | 移到最后一页

相关主题

  • 基于记录集结果显示和隐藏区域
  • 显示多个记录集结果


基于记录集结果显示和隐藏区域

Dreamweaver 包含一组允许基于记录集返回的结果来显示或隐藏区域的服务器行为。例如，在通过“前一个”和“下一个”记录链接来导航结果页的页面中，可以指定在除第一个结果页外的所有其它页面上显示“前一个”记录链接（因为在第一个页面之前不存在结果），以及在除最后一个结果页外的所有其它页面上显示“下一个”记录链接（因为在最后一个页面之后不存在结果）。

还可以基于记录集是否为空来指定是显示区域还是隐藏区域。如果记录集为空（例如，在未找到与查询相匹配的记录时），可以显示一条消息通知用户没有记录返回。这在创建依靠用户输入的搜索词来运行查询的搜索页时尤其有用。同样，如果在连接到数据库时有问题，或者当用户的用户名和密码与服务器识别的不匹配时，可以显示错误信息。

“显示区域”服务器行为有：

  • 如果记录集为空则显示
  • 如果记录集非空则显示
  • 如果是第一页则显示
  • 如果不是第一页则显示
  • 如果是最后一页则显示
  • 如果不是最后一页则显示

要了解如何应用“显示区域”服务器行为，请参见基于记录集结果显示和隐藏区域。


显示多个记录集结果

“重复区域”服务器行为允许在页面中显示记录集中的多条记录。任何动态数据选择都可以转变成重复的区域。但最常见的区域是表格、表格行或一系列表格行。

以下示例说明了如何将“重复区域”服务器行为应用于表格行，它指定每页显示九条记录。行本身显示四种不同的记录：市/县、省/自治区、街道地址和邮政编码。

若要创建像上面这样的表格，必须创建包含动态内容的表格，并将“重复区域”服务器行为应用于包含动态内容的表格行。当应用程序服务器处理页面时，会根据“重复区域”服务器对象中指定的次数重复该行，并在每一个新行中插入不同的记录。

要了解如何应用“重复区域”服务器行为，请参见显示多个记录集结果和使用“重复区域”服务器行为创建表格。


记录计数器

记录计数器为用户提供了遍历一组记录时的参考信息。通常情况下，记录计数器显示返回的记录总数以及正在查看的当前记录。例如，如果记录集返回 40 条单独的记录，并且每页显示 8 条记录，则位于首页上的记录计数器将显示“Displaying records 1-8 of 40”（总共 40 条记录，当前显示 1 - 8 条）。

若要为页面创建记录计数器，必须首先创建该页的记录集、包含动态内容的适当页面布局以及记录集导航条。有关如何创建上述元素并将其添加到页面的更多信息，请参见以下各节：

  • 了解记录集
  • 创建记录集导航链接
  • 显示多个记录集结果
  • 使用“重复区域”服务器行为创建表格

在页面中具备了上述元素了，就可以创建记录计数器了。

简单的记录计数器

您可以使用“记录集导航条”服务器对象创建简单的记录计数器。该服务器对象插入一个完整的记录计数器，通过 Dreamweaver 的网页设计工具可以对该计数器应用文本格式。要了解有关这种记录计数器的更多信息，请参见使用“记录集导航条”对象创建记录计数器。

自定义记录计数器

可以使用单独的记录计数行为来创建自定义记录计数器。创建自定义记录计数器使您可以创建比“记录集导航条”服务器对象所插入的简单表格（仅有一行）要复杂的记录计数器。可以通过多种巧妙方式排列设计元素，并将适当的服务器行为应用于每个元素。

“记录计数”服务器行为有：

  • 显示开始记录编号
  • 显示结束记录编号
  • 显示全部记录

创建自定义记录计数器指引您完成通过将各个“记录计数器”服务器行为应用到页面的设计元素从而创建记录计数器的步骤。


使用预定义的数据格式

Dreamweaver 附带了若干预定义的数据格式，它们可以应用于动态数据元素。数据格式的样式包括日期和时间、货币、数字以及百分比格式。

若要将数据格式应用于动态内容，请执行以下操作：

  1. 在“动态数据”窗口中选择动态内容，或者在“文档”窗口中选择它的占位符。
  2. 选择“窗口”>“绑定”显示“绑定”面板。
  3. 单击“格式”列中的向下箭头按钮。

    如果未看见向下箭头，请展开面板。

  4. 从“格式”弹出菜单中选择所需的数据格式类别。

    确保选择的数据格式适合要格式化的数据类型。例如，“货币”格式仅在动态数据是由数字数据构成时才有效。注意，对于同一数据不能应用多个格式。

  5. 验证是否正确应用了格式，方法是在“动态数据”窗口或浏览器中预览页面。

相关主题

  • 自定义现有的数据格式
  • 创建新的数据格式


自定义现有的数据格式

可以自定义 Dreamweaver 的现有数据格式，或者创建自己的数据格式。

若要自定义数据格式，请执行以下操作：

  1. 在“设计”视图中打开包含动态数据的页面。
  2. 选择要自定义其格式的动态数据。
  3. 选择“窗口”>“绑定”显示“绑定”面板。

    动态文本被您选定的绑定数据项将高亮显示。

  4. 单击“格式”列中的向下箭头，展开可用数据格式的弹出菜单。

    如果未看见向下箭头，请展开面板。

  5. 从弹出菜单中选择“编辑格式列表”。

    “编辑格式列表”对话框随即出现。

  6. 完成对话框设置，然后单击“确定”。

    有关说明，请参见设置“编辑格式列表”对话框选项。

相关主题

  • 使用预定义的数据格式
  • 创建新的数据格式


创建新的数据格式

可以创建新的数据格式，以便与要显示的任何动态数据类型相适应。

若要创建新的数据格式，请执行以下操作：

  1. 在“设计”视图中打开包含动态数据的页面。
  2. 选择要为其创建自定义格式的动态数据。
  3. 选择“窗口”>“绑定”显示“绑定”面板，然后单击“格式”列中的向下箭头。

    如果未看见向下箭头，请展开面板。

  4. 从弹出菜单中选择“编辑格式列表”。

    “编辑格式列表”对话框随即出现。

  5. 单击加号 (+) 按钮并选择一种格式类型。
  6. 定义格式，然后单击“确定”。
  7. 在“名称”列中输入新格式的名称。
  8. 单击“确定”关闭“编辑格式列表”对话框。

相关主题

  • 自定义现有的数据格式
  • 创建新的数据格式


创建记录集导航链接

记录集导航链接使用户可以从一个记录移到下一个，或者从一组记录移到下一组。例如，在设计了每次显示五条记录的页面后，您可能想要添加诸如“下一页”或“上一页”这类使用户可以显示后五条或前五条记录的链接。

可以创建记录集导航链接，方法是使用“记录集导航条”服务器行为或创建自定义记录集导航条。

本节包含以下主题：

  • 通过“记录集导航条”服务器行为创建导航条
  • 创建自定义的记录集导航条

相关主题

  • 数据库记录集结果导航
  • 自定义记录集导航条
  • 创建自定义的记录集导航条


通过“记录集导航条”服务器行为创建导航条

使用“记录集导航条”服务器行为，只需一个操作就可以创建记录集导航条。服务器对象在页面上添加以下构造块：

  • 包含文本或图像链接的 HTML 表格
  • 一组“移到”服务器行为
  • 一组“显示区域”服务器行为

“记录集导航条”的文本版本看起来像这样：

“记录集导航条”的图像版本看起来像这样：

在将导航条放到页面上之前，请确保页面包含要导航的记录集和用于显示记录的页面布局。

在将导航条放到页面上之后，可以按照自己的喜好使用 Dreamweaver 的设计工具来自定义它。还可以编辑“移到”和“显示区域”服务器行为，方法是在“服务器行为”面板中双击它们。

如果要使用 Dreamweaver 设计工具和“服务器行为”面板逐块地构建导航条，请参见创建自定义的记录集导航条。

若要使用服务器对象创建记录集导航条，请执行以下操作：

  1. 在“设计”视图中，将插入点放在页面上您希望显示导航条的位置。
  2. 显示“记录集导航条”对话框（“插入”>“应用程序对象”>“记录集导航条”）。

    显示出“记录集导航条”对话框。

  3. 从“记录集”弹出菜单中选择要导航的记录集。
  4. 从“显示方式”部分中选择用以在页面上显示导航链接的格式。“文本”选项在页面上放置文本链接，而“图像”选项则使您可以使用图形图像作为链接。

    在导航条的图像版本中，Dreamweaver 使用自己的图像文件。在将导航条放到页面上之后，您可以用自己的图像文件替换这些图像。

  5. 单击“确定”。

    Dreamweaver 创建包含文本或图像链接的表。单击这些链接后，用户可以遍历所选记录集。当显示记录集中的第一条记录时，会隐藏“第一个”和“前一个”链接或图像。当显示记录集中的最后一条记录时，会隐藏“下一个”和“最后一个”链接或图像。

    使用 Dreamweaver 设计工具可以自定义导航条的布局。

相关主题

  • 创建自定义的记录集导航条


创建自定义的记录集导航条

您可以创建自定义的记录集导航条，使用比“记录集导航条”服务器对象所使用的简单表格提供的布局和格式样式更为复杂的布局和格式样式。

若要创建您自己的记录集导航条，必须：

  • 使用文本或图像设计导航链接
  • 将链接放在“设计”视图中的页面中
  • 为每个导航链接分别指定服务器行为

要了解有关设计自定义记录集导航条的更多信息，请参见自定义记录集导航条。如果您更喜欢使用 Dreamweaver 的内置“记录集导航条”服务器对象创建导航条，请参见通过“记录集导航条”服务器行为创建导航条。

此步骤说明如何为导航链接指定个别的服务器行为。

若要为记录集导航链接分配服务器行为，请执行以下操作：

  1. 在“设计”视图中，选择页面上您希望用作记录导航链接的文本字符串或图像。
  2. 打开“服务器行为”面板（“窗口”>“服务器行为”），然后单击加号 (+) 按钮。
  3. 从弹出菜单中选择“记录集分页”，然后从列出的服务器行为中选择适合于该链接的服务器行为。

    如果记录集中包含大量记录，则当用户单击“移到最后一条记录”链接时，可能要花费较长时间来运行该服务器行为。

  4. 在“记录集”弹出菜单中，选择包含记录的记录集。
  5. 单击“确定”。

    该服务器行为即指定给了导航链接。

相关主题

  • 数据库记录集结果导航
  • 自定义记录集导航条


基于记录集结果显示和隐藏区域

Dreamweaver 包含一组允许基于记录集返回的结果来显示或隐藏区域的服务器行为。要了解有关“显示区域”服务器行为以及如何使用它们来显示或隐藏记录集结果的更多信息，请参见基于记录集结果显示和隐藏区域。

若要仅在需要时显示区域，请执行以下操作：

  1. 在“设计”视图中，选择页面上要显示或要隐藏的区域。
  2. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮。
  3. 从弹出菜单中选择“显示区域”，然后选择一个列出的服务器行为。
  4. 单击“确定”。

相关主题

  • 关于显示数据库记录
  • 显示多个记录集结果
  • 使用“重复区域”服务器行为创建表格


显示多个记录集结果

“重复区域”服务器行为允许在页面中显示记录集中的多条记录。任何动态数据选择都可以转变成重复的区域。但最常见的区域是表格、表格行或一系列表格行。

要了解有关使用“重复区域”服务器行为的更多信息，请参见显示多个记录集结果和使用“重复区域”服务器行为创建表格。

若要创建重复的区域，请执行以下操作：

  1. 在“设计”视图中，选择包含动态内容的区域。

    可以选定任意内容，包括表格、表格行甚至一段文本。

    若要精确选择页面上的区域，可以使用文档窗口左边角上的标签选择器。例如，如果区域为表行，则在页面上的该行内单击，然后单击标签选择器最右侧的 <tr> 标签以选择该表行。

  2. 选择“窗口”>“服务器行为”以显示“服务器行为”面板。
  3. 单击加号 (+) 按钮，并选择“重复区域”。

    “重复区域”对话框随即出现。

  4. 从弹出菜单中选择要使用的记录集的名称。
  5. 选择每页显示的记录数。
  6. 单击“确定”。

    在“文档”窗口中，重复的区域周围会出现一个灰色的选项卡式细轮廓。在“动态数据”窗口（“查看”>“动态数据”）中，灰色轮廓消失，而且选定内容扩展以显示您指定的记录数。

相关主题

  • 关于显示数据库记录
  • 基于记录集结果显示和隐藏区域
  • 使用“重复区域”服务器行为创建表格


使用“重复区域”服务器行为创建表格

“动态表”服务器对象允许创建包含动态内容的表格，还允许从单个对话框应用“重复区域”行为。该服务器对象特别有用，因为它用记录集中的动态内容填充表格并同时应用“重复区域”服务器行为。

注意

使用 ASP.NET 文档类型时，“动态表”服务器对象不可用。若要创建包含动态内容和重复区域的表格，必须手动插入表格，从“绑定”面板插入动态内容，并根据需要应用“重复区域”服务器行为。有关更多信息，请参见显示多个记录集结果。

若要创建动态表，请执行以下操作：

  1. 若要插入动态表，请执行以下操作：
    • 选择“插入”>“应用程序对象”>“动态数据”>“动态表”以显示“动态表”对话框。
    • 从“插入”栏的“应用程序”类别，选择“动态数据”菜单中的“动态表”按钮。

    随即出现“动态表格”对话框。

  2. 从“记录集”弹出菜单中选择要使用的记录集。
  3. 选择每页显示的记录数。
  4. 如果需要，输入表格边框、单元格边距和单元格间距的值。

    “动态表格”对话框会保留您为表格边框、单元格边距和单元格间距输入的值。如果您处理的项目需要若干具有同样外观的动态表格，您可能需要输入表格布局值，因为这会进一步简化页面开发。注意，在通过属性检查器插入表格后，仍可以调整这些值。

  5. 单击“确定”。

    一个表格和在相关记录集中定义的动态内容的占位符随即插入到页面中。

    在本例中，记录集包含四条记录：FIRSTNAME、LASTNAME、TITLE 和 DEPARTMENT。表格的“标题”行用每条记录项的名称填充。可以使用所需的任何描述性文本对标题进行编辑，或者用具有代表性的图像替换它们。


创建记录计数器

记录计数器使用户可以了解相对于返回的记录总数，他们位于给定的一组记录中的位置。由于这个原因，记录计数器是一个有用的行为，可以显著增加 Web 页的可用性。

要了解有关记录计数器的更多信息，请参见记录计数器。

本节包含以下主题：

使用“记录集导航条”对象创建记录计数器

创建自定义记录计数器


使用“记录集导航条”对象创建记录计数器

“记录集导航条”对象在页面上创建显示当前记录状态的文本项。

若要使用“记录集导航条”服务器对象，请执行以下操作：

  1. 将插入点放在想要插入记录计数器的地方。
  2. 选择“插入”>“应用程序对象”>“记录集导航条”。

    出现“记录集导航条”对话框。

    从“记录集”弹出菜单中选择要使用的记录集。

  3. 单击“确定”。

    “记录集导航条”服务器对象随即插入一个类似于下图所示的文本记录计数器：

    可以使用 Dreamweaver 的网页设计工具来自定义记录计数器。

    在“动态数据”窗口或浏览器中查看计数器时，它的外观类似于下面这样：


创建自定义记录计数器

若要为页面创建自定义记录计数器，必须首先创建该页的记录集、包含动态内容的适当页面布局以及记录集导航条。有关如何创建这些元素并将其添加到页面的更多信息，请参见记录计数器。在页面中创建了上述元素后，就可以创建自定义记录计数器了。

本例创建的记录计数器看起来类似于在上一节使用“记录集导航条”对象创建记录计数器中创建的计数器。本例中的记录计数器会显示如下：

Displaying records StartRow thru EndRow of RecordSet.RecordCount.

本例中，用 sans-serif 字体表示的文本代表将要插入到页面中的记录计数器占位符。

若要创建自定义记录计数器，请执行以下操作：

  1. 在“设计”视图中，在页面上输入计数器的文本。该文本可以是您想要的任何内容。例如：
    Displaying records thru of .
  2. 将插入点放在文本字符串的最后。
  3. 打开“服务器行为”面板（“窗口”>“服务器行为”）。
  4. 单击左上角的加号 (+) 按钮，然后单击“显示记录计数”。在这个子菜单中，选择“显示全部记录”。“显示全部记录”行为随即插入到页面中，而且一个占位符插入到插入点所在的位置。文本字符串现在应显示为：
    Displaying records thru of {Recordset1.RecordCount}.
  5. 将插入点放在单词 records 之后，然后从“服务器行为”>加号 (+) 按钮>“记录计数”面板中选择“显示开始记录计数号”。文本字符串现在应显示为：
    Displaying records {StartRow_Recordset1} thru of {Recordset1.RecordCount}.
  6. 现在将插入点放在单词 thru 和 of 之间，然后从“服务器行为”>加号 (+) 按钮>“记录计数”面板中选择“显示开始记录计数号”。文本字符串现在应显示为：
    Displaying records {StartRow_Recordset1} thru {EndRow_Recordset1} of
{Recordset1.RecordCount}.
  7. 确认计数器是否能正常运行，方法是在“动态数据”窗口（“查看”>“动态数据”）中查看页面，计数器看起来应类似于下面的示例：
    Displaying records 1 thru 8 of 40.

    如果结果页面中有移到下一组记录的导航链接，则单击该链接时，记录计数器的显示应更新为：

    Showing records 9 thru 16 of 40.

    链接在“动态数据”窗口中不起作用。若要测试链接，可以使用 Dreamweaver 的“在浏览器中预览”功能。请确保在“首选参数”（“编辑”>“首选参数”>“在浏览器中预览”(Windows) 或“Dreamweaver”>“首选参数”>“在浏览器中预览”(Macintosh)）中选择了“使用动态数据服务器预览”选项，然后选择“文件”>“在浏览器中预览”。


参考资料

本节提供有关本章中介绍的下列面板、对话框和检查器的信息。

  • 设置“记录集导航条”对话框选项
  • 设置“移到”（服务器行为）对话框选项
  • 设置“重复区域”对话框选项
  • 设置“记录集导航状态”对话框选项
  • 设置“编辑格式列表”对话框选项
  • 设置“货币”、“数字”或“百分比”对话框选项
  • 设置“显示当前页号”对话框选项


设置“记录集导航条”对话框选项

该对话框的作用是创建记录集导航条并将其添加到页面。

若要完成“记录集导航条”对话框，请执行以下操作：

  1. 选择要导航的记录集。
  2. 选择文本或图像链接。

    在导航条的图像版本中，Dreamweaver 使用它自己的图像文件。如果愿意，您可以在将导航条放到页面上之后，用自己的图像文件替代它们。

  3. 单击“确定”。

    Dreamweaver 随即生成包含文本或图像链接的表，单击这些链接可以遍历选定记录集。

相关主题

  • 通过“记录集导航条”服务器行为创建导航条
  • 创建记录集导航链接


设置“移到”（服务器行为）对话框选项

该对话框用于添加使用户可以遍历记录集记录的链接。

若要完成“移到”（服务器行为）对话框，请执行以下操作：

  1. 如果没有在页面上选择任何内容，从弹出式菜单中选择一个链接。
  2. 选择包含要逐页浏览的记录的记录集。

    注意

    如果记录集中包含大量记录，则当用户单击“移到最后一条记录”链接时，可能要花费较长时间来运行该服务器行为。
  3. 单击“确定”。

相关主题

  • 创建自定义的记录集导航条


设置“重复区域”对话框选项

该对话框用于创建并添加重复的区域，使您可以在页面上显示多条记录。

若要完成“重复区域”对话框，请执行以下操作：

  1. 指定包含要在重复区域中显示的数据的记录集。
  2. 指定每页显示的记录数。

    如果指定的每页记录数是有限的，并且所请求的记录数可能超过此数目，则添加记录导航链接以使用户能够显示其它记录。（请参见创建记录集导航链接。）

  3. 单击“确定”。

相关主题

  • 显示多个记录集结果


设置“记录集导航状态”对话框选项

该对话框用于创建记录计数器并将其添加到页面。

若要完成对话框选项，请执行以下操作：

  1. 选择要跟踪的记录集。
  2. 单击“确定”。

Dreamweaver 随即创建记录计数器并将它添加到页面。

相关主题

  • 使用“记录集导航条”对象创建记录计数器


设置“编辑格式列表”对话框选项

该对话框用于创建新的数据格式，或者自定义现有的数据格式。

若要完成“编辑格式列表”对话框，请执行以下操作：

  1. 若要创建新的数据格式，请单击加号 (+) 按钮。
  2. 若要编辑现有的数据格式，请从列表中选择该格式，然后单击“编辑”。

    注意

    有些数据格式没有可供自定义的参数。
  3. 完成对话框设置，然后单击“确定”。

    有关说明，请参见设置“货币”、“数字”或“百分比”对话框选项。

  4. 如果创建新格式，请为其指定名称。
  5. 如果修改现有的格式，需要时可以更改其名称。方法是，在列表中单击它的名称，然后进行修改。
  6. 若要删除数据格式，请在列表中单击该格式，然后单击减号 (-) 按钮。
  7. 单击“确定”关闭“编辑格式列表”对话框。

相关主题

  • 自定义现有的数据格式
  • 创建新的数据格式


设置“货币”、“数字”或“百分比”对话框选项

这些对话框用于定义数据格式。

若要完成“货币”、“数字”或“百分比”对话框，请执行以下操作：

  1. 更改下列任何参数：
    • 小数点后显示的位数
    • 是否在小数的开头部分放置前导零
    • 是否对负值使用括号或减号
    • 是否将位数分组
  2. 单击“确定”。

相关主题

  • 设置“编辑格式列表”对话框选项
  • 自定义现有的数据格式
  • 创建新的数据格式


设置“显示当前页号”对话框选项

该对话框用于在 ASP.NET 页面中插入代码，以显示当前的数据集页码。

ASP.NET 中的数据集页是数据网格或数据列表中显示的记录的子集。如果决定在控件中只显示 10 条记录，且数据集包含 24 条记录，则数据集具有三页（分别包含 10 条、10 条和 4 条记录）。

若要显示数据集页，请执行以下操作：

  • 选择数据集并单击“确定”。


在 Web 页面中显示 XML 数据

可以使用 Macromedia Dreamweaver 8 创建显示 XML 数据的 Web 页面。显示 XML 数据涉及检索存储在本地或远端 XML 文件中的信息以及将该信息呈现在 Web 页面中。Dreamweaver 提供了显示 XML 文件中的信息的方法，还提供了内置的 XSLT 对象和设计功能，使用这些对象和功能可以增强 XML 数据的显示。

本章包含下列章节：

关于在 Web 页面中使用 XML 和 XSL

关于服务器端 XSL 转换

关于客户端 XSL 转换

关于 XML 数据和重复元素

关于预览 XML 数据

在服务器上执行 XSL 转换

在客户端执行 XSL 转换

将样式应用于 XSLT 片断

XSL 转换答疑


关于在 Web 页面中使用 XML 和 XSL

可扩展标记语言 (XML) 可对信息进行结构化处理。与 HTML 一样，XML 允许您使用标签使信息结构化，但 XML 标签与 HTML 标签不一样，它不是预定义的。XML 允许您创建对数据结构进行最佳定义的标签。标签嵌套在其他标签中可创建一种父子标签的架构。与大多数 HTML 标签一样，XML 架构中的所有标签都有一个开始标签和一个结束标签。

下面的示例介绍 XML 文件的基本结构：

<?xml version=“1.0”>
<mybooks>
   <book bookid=“1”>
      <pubdate>03/01/2004</pubdate>
      <title>Displaying XML Data with Macromedia Dreamweaver</title>
      <author>Charles Brown</author>
   </book>
   <book bookid=“2”>
      <pubdate>04/08/2004</pubdate>
      <title>Understanding XML</title>
      <author>John Thompson</author>
   </book>
</mybooks>

在此示例中，每一个 <book> 父标签都包含三个子标签：<pubdate>、<title> 和 <author>。但每个 <book> 标签也是 <mybooks> 标签的子标签，后者在架构中的级别比前者高一级。只要相应地将标签嵌套在其他标签中，并为每个开始标签指定一个对应的结束标签，您就可以随意命名 XML 标签并安排它们的结构。

XML 文档不包含任何格式设置 － 这类文档只是结构化信息的容器。有了 XML 架构之后，就可以使用可扩展样式表语言 (XSL) 来显示信息。与层叠样式表 (CSS) 允许您设置 HTML 的格式一样，XSL 也允许您设置 XML 数据的格式。您可以在 XSL 文件中定义样式、页面元素和布局等，并将 XSL 文件附加到 XML 文件，以便当用户在浏览器中查看 XML 数据时，根据您在 XSL 文件中的定义对数据进行格式设置。内容（XML 数据）与表现形式（由 XSL 文件定义）是完全独立的，这使您可以更好地控制信息在 Web 页面上的显示方式。本质上，XSL 是 XML 的一种表现技术，其中的主要输出是 HTML 页面。

可扩展样式表语言转换 (XSLT) 是 XSL 的子集语言，它允许您在 Web 页面上显示 XML 数据，并将 XML 数据和 XSL 样式“转换”为 HTML 形式的可读的样式化信息。您可以使用 Dreamweaver 创建 XSLT 页面，这种页面允许您使用应用程序服务器或浏览器执行 XSL 转换。当您执行服务器端 XSL 转换时，服务器执行 XML 和 XSL 的转换工作，并将其显示在页面上。当您执行客户端转换时，浏览器（如 Internet Explorer）可执行此项工作。

最终采用的方法（服务器端转换与客户端转换）取决于想要达到的最终结果、可供使用的技术、对 XML 源文件的访问级别及其他因素。两种方法都有它们自己的优点和局限性。例如，服务器端转换适用于所有浏览器，而客户端转换仅局限于新型浏览器（Internet Explorer 6、Netscape 8、Mozilla 1.8 和 Firefox 1.0.2）。服务器端转换允许您动态地显示您自己的服务器上或 Web 上任何地方的 XML 数据，而客户端转换必须使用自己的 Web 服务器上本地承载的那些 XML 数据。最后，服务器端转换要求将页面部署到已配置的应用程序服务器，而客户端转换只要求访问 Web 服务器。

有关更多信息，请参见关于服务器端 XSL 转换和关于客户端 XSL 转换。


关于服务器端 XSL 转换

Dreamweaver 提供了一些方法，用于创建可执行服务器端 XSL 转换的 XSLT 页面。当应用程序服务器执行 XSL 转换时，包含 XML 数据的文件可以驻留在您自己的服务器上，也可驻留在 Web 上的任何地方。此外，任何浏览器都可显示已转换的数据。但是，部署服务器端转换的页面有些复杂，并要求您拥有应用程序服务器的访问权。

当处理服务器端 XSL 转换时，您可以使用 Dreamweaver 来创建生成整个 HTML 文档的 XSLT 页面（整个 XSLT 页面），也可以创建生成部分 HTML 文档的 XSLT 片断。整个 XSLT 页面类似于常规 HTML 页面。它包含一个 <body> 标签和一个 <head> 标签，允许在页面上显示 HTML 数据和 XML 数据的组合。XSLT 片断是由单独的文档使用的一段代码，它显示带格式的 XML 数据。与整个 XSLT 页面不同，它是一个独立的文件，不包含任何 <body> 或 <head> 标签。如果要在 XML 数据自己的页面上显示 XML 数据，则需要创建整个 XSLT 页面，并将 XML 数据绑定到该页面。另一方面，如果要在现有动态页的特定部分中显示 XML 数据 － 例如，在体育用品商店的动态主页的一侧显示来自 RSS 源的体育比分 － 则需要创建 XSLT 片断，并在动态页中插入对该片断的引用。创建 XSLT 片断并与其他动态页一起使用这些片断来显示 XML 数据是较常用的方法。

创建这些类型的页面的第一步是创建 XSLT 片断：它是一个单独的文件，该文件包含要最终显示在动态页中的 XML 数据的布局和格式设置等。创建 XSLT 片断之后，请在动态页（如 PHP 或 Macromedia ColdFusion 页面）中插入对该片断的引用。插入的对 XSLT 片断的引用的工作方式与“服务器端包括”(SSI) 很类似 － 带格式的 XML 数据（片断）位于单独文件中，而在“设计”视图中，片断的占位符显示在动态页本身上。如果浏览器请求的动态页包含对该片断的引用，则服务器处理所包含的指令并创建一个新文档，其中显示片断的带格式内容而不是占位符。

使用 XSL 转换服务器行为在动态页中插入对 XSLT 片断的引用。插入引用时，Dreamweaver 在站点的根文件夹中生成一个 includes/MM_XSLTransform/ 文件夹，其中包含一个运行时库文件。转换指定的 XML 数据时，应用程序服务器使用该文件中定义的函数。该文件负责获取 XML 数据和 XSLT 片断、执行 XSL 转换和在 Web 页面上输出结果。

包含 XSLT 片断的文件、包含您的数据的 XML 文件以及生成的运行时库文件都必须在服务器上，页面才能正确显示。（如果您选择远端 XML 文件作为数据源 － 例如，从 RSS 源选择的 XML 文件 － 则该文件当然必须位于 Internet 上的其他位置。）

也可以使用 Dreamweaver 创建整个 XSLT 页面以用于服务器端转换。整个 XSLT 页面的工作方式与 XSLT 片断的工作方式完全相同，只是在使用 XSL 转换服务器行为插入对整个 XSLT 页面的引用时，插入的是 HTML 页面的完整内容。所以，在插入引用之前必须清空动态页（充当容器页面的 .cfm、.php、.asp 或 .net 页面）中的所有 HTML 代码。

Dreamweaver 支持对 ColdFusion、ASP、ASP.NET 和 PHP 页面执行 XSL 转换。

注意

必须正确地配置服务器以执行服务器端转换。有关更多信息，请联系服务器管理员，或访问 www.macromedia.com/go/dw_xsl_cn。

有关创建服务器端 XSL 转换的过程，请参见在服务器上执行 XSL 转换。

相关主题

  • 关于在 Web 页面中使用 XML 和 XSL
  • 关于客户端 XSL 转换
  • 关于预览 XML 数据
  • 将样式应用于 XSLT 片断


关于客户端 XSL 转换

您还可以在客户端执行 XSL 转换，而无需使用应用程序服务器。您可以使用 Dreamweaver 创建整个 XSLT 页面来执行此转换；但客户端转换要求对包含所要显示的数据的 XML 文件进行操作。此外，客户端转换只适用于新型浏览器（Internet Explorer 6、Netscape 8、Mozilla 1.8 和 Firefox 1.0.2）。有关支持和不支持 XSL 转换的浏览器的更多信息，请参见 www.w3schools.com/xsl/xsl_browsers.asp。

先创建整个 XSLT 页面并附加 XML 数据源。（创建新页面时，Dreamweaver 会提示您附加数据源。）可以使用 Dreamweaver 从头创建 XSLT 页面，或者将现有 HTML 页面转换为 XSLT 页面。当您将现有 HTML 页面转换为 XSLT 页面时，必须使用“绑定”面板（“窗口”>“绑定”）附加 XML 数据源。

创建 XSLT 页面后，必须通过在 XML 文件本身中插入对 XSLT 页面的引用（与在 HTML 页面的 <head> 部分中插入对外部 CSS 样式表的引用非常类似），将该页面链接到包含 XML 数据的 XML 文件。站点访问者必须在浏览器中查看 XML 文件（而不是 XSLT 页面）。当站点访问者查看页面时，浏览器执行 XSL 转换，并显示由链接的 XSLT 页面进行格式设置的 XML 数据。

链接的 XSLT 和 XML 页面之间的关系在概念上相似，但不同于外部 CSS/HTML 页面模型。当您拥有一个包含内容（如文本）的 HTML 页面时，可以使用外部样式表对该内容进行格式设置。HTML 页面将决定内容，而用户看不到的外部 CSS 代码则决定表现形式。而对于 XSLT 和 XML，情况相反。XML 文件（用户从未看到它的原始形式）决定内容，而 XSLT 页面决定表现形式。XSLT 页面包含标准 HTML 通常包含的表格、布局和图形等。当用户在浏览器中查看 XML 文件时，XSLT 页面将对内容进行格式设置。

在使用 Dreamweaver 将 XSLT 页面链接到 XML 页面时，Dreamweaver 会在 XML 页面顶部为您插入相应的代码。如果您拥有要链接的 XML 页面（也就是说，如果 XML 文件存在于您的 Web 服务器上），则只需使用 Dreamweaver 插入用于链接这两个页面的相应代码。当您拥有 XML 文件时，客户端所执行的 XSL 转换完全是动态的。也就是说，每当您更新 XML 文件中的数据时，使用链接的 XSLT 页面的任何 HTML 输出都将用新信息自动进行更新。

注意

用于客户端转换的 XML 和 XSL 文件必须位于相同的目录中。否则，浏览器将读取 XML 文件并查找用于转换的 XSLT 页面，但无法找到 XSLT 页面中的相对链接所定义的资源（样式表、图像等）。

如果您不具有要链接的 XML 页面（例如，如果要使用来自 Web 上的其他地方的 RSS 源的 XML 数据），则工作流程将稍微复杂一点。要使用来自外部源的 XML 数据执行客户端转换，必须首先将 XML 源文件下载到 XSLT 页面所在的同一目录。在 XML 页面位于本地站点之后，可以使用 Dreamweaver 添加相应代码，以将 XML 页面链接到 XSLT 页面，然后将这两个页面（下载的 XML 文件和链接的 XSLT 页面）都发送给 Web 服务器。当用户在浏览器中查看 XML 页面时，XSLT 页面将对内容进行格式设置，如上例所述。

对来自外部源的 XML 数据执行客户端 XSL 转换的缺点是：XML 数据只有部分是“动态的”。您下载和更改的 XML 文件仅是位于 Web 中其他位置上的文件的一个“快照”。如果不在 Web 上的原始 XML 文件发生更改，则必须再次下载文件，将其链接到 XSLT 页面，并重新将 XML 文件发送给 Web 服务器。浏览器只呈现它从 Web 服务器上的 XML 文件接收的数据，而不呈现原始 XML 源文件包含的数据。

有关创建客户端 XSL 转换的过程，请参见在客户端执行 XSL 转换。

相关主题

  • 关于在 Web 页面中使用 XML 和 XSL
  • 关于服务器端 XSL 转换
  • 关于预览 XML 数据
  • 将样式应用于 XSLT 片断


关于 XML 数据和重复元素

重复区域 XSLT 对象允许在页面中显示 XML 文件中的重复元素。包含 XML 数据占位符的所有区域均可转换为重复区域。但最常见的区域是表格、表格行或一系列表格行。

下面的示例介绍如何将重复区域 XSLT 对象应用于显示餐馆菜单信息的表格行。初始行显示 XML 架构的以下三个不同元素：项目、描述和价格。将重复区域 XSLT 对象应用于表格行，并由应用程序服务器或浏览器处理页面时，将重复该表格，在每个新表格行中插入唯一的数据。

当您在“文档”窗口中应用重复区域 XSLT 对象时，重复的区域周围会出现一个灰色的选项卡式细轮廓。在浏览器（“文件”>“在浏览器中预览”）中进行预览时，该灰色轮廓消失且所选内容扩展，以显示 XML 文件中的指定重复元素（如以上说明所述）。

您可能还注意到，在将重复区域 XSLT 对象添加到页面中时，Dreamweaver 会截短“文档”窗口中 XML 数据占位符的长度。这是因为 Dreamweaver 更新了 XML 数据占位符的 Xpath，使它成了一个相对于重复元素路径的路径。

例如，以下代码表示包含两个动态占位符的表格，并且没有对此表格应用重复区域 XSLT 对象：

<table width="500" border="1">
   <tr>
      <td><xsl:value-of select="rss/channel/item/title"/></td>
   </tr>
   <tr>
      <td><xsl:value-of select="rss/channel/item/description"/></td>
   </tr>
</table>

以下代码表示同一个表格，但对表格应用了重复区域 XSLT 对象：

<xsl:for-each select="rss/channel/item">
   <table width="500" border="1">
      <tr>
         <td><xsl:value-of select="title"/></td>
      </tr>
      <tr>
         <td><xsl:value-of select="description"/></td>
      </tr>
   </table>
</xsl:for-each>

在上例中，Dreamweaver 对位于重复区域（title 和 description）内的项目的 Xpath 进行了自动更新，从而使该 XPath 相对于封闭标签 <xsl:for-each> 内的 XPath，而没有更新整个文档。

同样，在其他情况下，Dreamweaver 也会生成上下文相关的 XPath 表达式。例如，如果将某个 XML 数据占位符拖放到已应用了重复区域 XSLT 对象的表格中，Dreamweaver 会自动显示相对于封闭标签 <xsl:for-each> 中的现有 XPath 的 XPath。

若要了解如何应用重复区域 XSLT 对象，请参见显示重复 XML 元素。

相关主题

  • 关于在 Web 页面中使用 XML 和 XSL


关于预览 XML 数据

当您使用“在浏览器中预览”（“文件”>“在浏览器中预览”）来预览插入到 XSLT 片断或整个 XSLT 页面的 XML 数据时，执行 XSL 转换的引擎根据情况各不相同。对于包含 XSLT 片断的动态页，应用程序服务器始终执行此转换。在其它情况下，Dreamweaver 或浏览器可能会执行此转换。

下表概述了使用“在浏览器中预览”时的各种情况，以及那些执行各自的转换的引擎：

在浏览器中预览的页面的类型 | 数据转换执行者
包含 XSLT 片断的动态页 | 应用程序服务器
XSLT 片断或整个 XSLT 页面 | Dreamweaver
包含指向整个 XSLT 页面的链接的 XML 文件 | 浏览器

以下主题提供了一些准则，可帮助您根据需要确定适当的预览方法：

  • 预览服务器端转换的页面
  • 预览客户端转换的页面
  • 预览整个 XSLT 页面和 XSLT 片断

预览服务器端转换的页面

如果进行服务器端转换，站点访问者最终看到的内容由应用程序服务器进行转换。创建 XSLT 和动态页以用于服务器端转换时，预览包含 XSLT 片断的动态页（而非 XSLT 片断本身）通常更可取。在前一种情形中，使用应用程序服务器可以确保您预览的内容与站点访问者在访问页面时所看到的内容一致。在后一种情形中，Dreamweaver 执行转换，并可能提供有些不一致的结果。您可以在创建 XSLT 片断时使用 Dreamweaver 预览该片断，但如果在插入 XSLT 片断之后使用应用程序服务器预览动态页，则可以看到数据呈现的最准确结果。

预览客户端转换的页面

如果进行客户端转换，站点访问者最终看到的内容由浏览器转换。通过添加一个从 XML 文件指向 XSLT 页面的链接，您可以达到此目的。如果在 Dreamweaver 中打开 XML 文件，并在浏览器中预览此文件，将强制浏览器载入 XML 文件并执行转换。这将为您提供与站点访问者相同的体验。

此方法的一个缺点是：它使您更难于调试页面，因为浏览器转换了 XML 并在内部生成了 HTML。如果选择浏览器的“查看源文件”选项调试生成的 HTML，您将只看到浏览器接收到的原始 XML，而无法看到负责呈现页面的完整 HTML（标签和样式等）。若要在查看源代码时看到完整的 HTML，则必须改为在浏览器中预览 XSLT 页面。

预览整个 XSLT 页面和 XSLT 片断

创建整个 XSLT 页面和 XSLT 片断时，您希望预览工作结果以确保正确显示数据。如果使用“在浏览器中预览”显示整个 XSLT 页面或 XSLT 片断，Dreamweaver 将使用内置转换引擎执行转换。该方法可使您快速看到结果，并使您能够更轻松地以渐进方式构建和调试页面。它还提供了一种方式，使您可通过在浏览器中选择“查看源文件”选项来查看整个 HTML（标签和样式等）。

注意

在开始创建 XSLT 页面时，不论使用客户端还是服务器来转换数据，都很可能会使用该方法。

相关主题

  • 关于在 Web 页面中使用 XML 和 XSL
  • 关于服务器端 XSL 转换
  • 关于客户端 XSL 转换
  • 将样式应用于 XSLT 片断


在服务器上执行 XSL 转换

可以使用 Dreamweaver 来创建用于动态 Web 页面的整个 XSLT 页面或 XSLT 片断。整个 XSLT 页面在转换后会生成完整的 HTML 页面。XSLT 片断是由单独的文档使用的一段代码，在转换后它会显示 XML 数据。

Macromedia 建议您在继续以下任何过程之前先阅读关于服务器端 XSL 转换。

注意

必须正确地配置服务器以执行服务器端转换。有关更多信息，请联系服务器管理员，或访问 www.macromedia.com/go/dw_xsl_cn。

本节包含以下主题：

  • 执行服务器端 XSL 转换的工作流程
  • 创建 XSLT 页面
  • 将 HTML 页面转换为 XSLT 页面
  • 附加 XML 数据源
  • 在 XSLT 页面中显示 XML 数据
  • 显示重复 XML 元素
  • 编辑重复区域 XSLT 对象
  • 在动态页中插入 XSLT 片断
  • 从动态页删除 XSLT 片断
  • 编辑 XSL 转换服务器行为
  • 使用 XSL 转换参数
  • 创建条件 XSLT 区域
  • 编辑条件区域 XSLT 对象
  • 插入 XSL 注释


执行服务器端 XSL 转换的工作流程

本节为您列出了执行服务器端 XSL 转换所需遵循的步骤，并指引您参阅文档中详细说明每个过程的相应小节。

Macromedia 建议您在构建显示 XML 数据的页面之前，先阅读关于在 Web 页面中使用 XML 和 XSL、关于服务器端 XSL 转换和关于客户端 XSL 转换。

若要执行服务器端 XSL 转换，请遵循以下步骤：

  • 设置 Dreamweaver 站点。请参见设置 Dreamweaver 站点。
  • 选择服务器技术并设置应用程序服务器。请参见设置应用程序服务器。
  • 测试应用程序服务器以确保它正常工作。例如，创建一个需要处理的页面，然后确保应用程序服务器能处理该页面。有关如何执行此操作的教程，请访问 www.macromedia.com/go/dw_xsl_cn。
  • 执行下列操作之一：
    • 在 Dreamweaver 站点，创建一个 XSLT 片断或整个 XSLT 页面。请参见创建 XSLT 页面。
    • 将现有 HTML 页面转换为整个 XSLT 页面。请参见将 HTML 页面转换为 XSLT 页面。
  • 如尚未执行此操作，请将 XML 数据源附加到页面。请参见附加 XML 数据源。
  • 将 XML 数据绑定到 XSLT 片断或整个 XSLT 页面。请参见在 XSLT 页面中显示 XML 数据。
  • 如适用，将重复区域 XSLT 对象添加到包含 XML 数据占位符的表格或表格行。请参见显示重复 XML 元素。
  • 执行下列操作之一：
    • 使用 XSL 转换服务器行为在动态页中插入对 XSLT 片断的引用。请参见在动态页中插入 XSLT 片断。
    • 从动态页中删除所有 HTML 代码，然后使用 XSL 转换服务器行为在动态页中插入对整个 XSLT 页面的引用。
  • 将动态页和 XSLT 片断（或整个 XSLT 页面）发送到应用程序服务器。如果正在使用本地 XML 文件，则还需要发送该文件。
  • 在浏览器中查看动态页。执行此操作时，应用程序服务器会转换 XML 数据，将数据插入动态页，然后在浏览器中显示数据。


创建 XSLT 页面

可以创建在 Web 页面上显示 XML 数据的 XSLT 页面。您可以创建整个 XSLT 页面 － 包含一个 <body> 标签和一个 <head> 标签的 XSLT 页面 － 也可以创建 XSLT 片断。创建 XSLT 片断时，将创建一个独立的文件，其中不包含任何 body 或 head 标签 － 稍后在动态页中插入的一段简单代码。

注意

如果从现有 XSLT 页面开始，则需要将 XML 数据源附加到现有 XSLT 页面，请参见附加 XML 数据源。

若要创建 XSLT 页面，请执行以下操作：

  1. 选择“文件”>“新建”
  2. 在“新建文档”对话框的“常规”选项卡上，从“类别”列选择“基本页”，然后执行以下步骤之一：
    • 从“基本页”列选择“XSLT（整页）”，创建整个 XSLT 页面。
    • 从“基本页”列选择“XSLT（片断）”，创建 XSLT 片断。
  3. 单击“创建”。

    将出现“定位 XML 源”对话框，要求您附加 XML 数据源。

  4. 执行下列操作之一：
    • 选择“附加本地文件”，单击“浏览”按钮，浏览至计算机上的本地 XML 文件，然后单击“确定”。
    • 选择“附加远端文件”，输入 Internet 上的 XML 文件（如来自 RSS 源的 XML 文件）的 URL，然后单击“确定”。

      注意

      单击“取消”按钮将生成一个新的 XSLT 页面，页面中没有附加的 XML 数据源。有关附加 XML 数据源的信息，请参见附加 XML 数据源。

    Dreamweaver 使用您的 XML 数据源的架构填充“绑定”面板。

    下表说明了架构中可能出现的各种元素：

    元素

    表示

    详细信息

    <>

    必选的非重复性 XML 元素

    在其父节点中刚好出现一次的元素

    <>+

    重复的 XML 元素

    在其父节点中出现一次或多次的元素

    <>?

    可选 XML 元素

    在其父节点中出现零次或多次的元素

    粗体类型的元素节点

    当前上下文元素

    当插入点在重复区域中时，通常为重复元素

    @

    XML 属性

  5. 以 .xsl 或 .xslt 扩展名（.xsl 是默认值）保存新页面（“文件”>“保存”）。

相关主题

  • 在 XSLT 页面中显示 XML 数据
  • 关于在 Web 页面中使用 XML 和 XSL
  • 在服务器上执行 XSL 转换
  • 在客户端执行 XSL 转换


将 HTML 页面转换为 XSLT 页面

还可以将现有 HTML 页面转换为 XSLT 页面。例如，如果您拥有一个要将 XML 数据添加到其中的预设计的静态页面，则可以将该页面转换为 XSLT 页面，而不是创建一个 XSLT 页面并从头开始重新设计页面。

若要将现有 HTML 页面转换为 XSLT 页面，请执行以下操作：

  1. 打开要转换的 HTML 页面。
  2. 选择“文件”>“转换”>“XSLT 1.0”。

    Dreamweaver 将在“文档”窗口中打开页面的副本。新页面是以 .xsl 扩展名保存的 XSL 样式表。

相关主题

  • 创建 XSLT 页面


附加 XML 数据源

如果从现有 XSLT 页面开始，或者在使用 Dreamweaver 创建新 XSLT 页面时没有附加 XML 数据源，则需要使用“绑定”面板附加 XML 数据源。

若要附加 XML 数据源，请执行以下操作：

  1. 在“绑定”面板（“窗口”>“绑定”）中，单击 XML 链接。

    注意

    您还可以单击“绑定”面板右上角的“源”链接，添加 XML 数据源。
  2. 执行下列操作之一：
    • 选择“附加本地文件”，单击“浏览”按钮，浏览至计算机上的本地 XML 文件，然后单击“确定”。
    • 选择“附加远端文件”，输入 Internet 上的 XML 文件（如来自 RSS 源的 XML 文件）的 URL。
  3. 单击“确定”，关闭“定位 XML 源”对话框。

    Dreamweaver 使用您的 XML 数据源的架构填充“绑定”面板。有关架构中符号的指南，请参见创建 XSLT 页面。


在 XSLT 页面中显示 XML 数据

创建 XSLT 页面并附加 XML 数据源后，就可以将数据绑定到页面了。

若要显示 XML 数据，请执行以下操作：

  1. 打开带有附加的 XML 数据源的 XSLT 页面。有关说明，请参见创建 XSLT 页面。
  2. （可选）选择“插入”>“表格”，向页面添加表格。表格有助于您组织 XML 数据。有关更多信息，请参见使用表格显示内容。

    注意

    大多数情况下，您需要使用重复区域 XSLT 对象在页面上显示重复 XML 元素。这时，您需要创建具有一列或多列的单行表格，如果希望包含表格标题，则需要创建由两行组成的表格。有关更多信息，请参见显示重复 XML 元素。
  3. 在“绑定”面板中选择一个 XML 元素，将它拖动到页面上要插入数据的位置。

    页面上即显示一个 XML 数据占位符。该占位符突出显示在花括号中。它使用 XPath（XML 路径语言）语法描述 XML 架构的层次结构。例如，如果将子元素“title”拖到页面上，而该元素具有“rss”、“channel”和“item”等父元素，则动态内容占位符的语法是 {rss/channel/item/title}。

    XML 数据占位符位于页面上后，可以双击数据占位符打开 XPath 表达式创建器。XPath 表达式创建器允许您设置选定数据的格式，或从 XML 架构中选择其他项目。有关更多信息，请单击 XPath 表达式创建器中的“帮助”按钮。

  4. （可选）将样式应用于 XML 数据，方法是选择 XML 数据占位符，与将样式应用于内容的任何其他部分一样，使用“属性”检查器或“CSS 样式”面板对该数据占位符应用样式。或者，可以使用设计时间样式表将样式应用于 XSLT 片断。以上这些方法各有其自己的优点和局限性。有关更多信息，请参见将样式应用于 XSLT 片断。
  5. 在浏览器（“文件”>“在浏览器中预览”）中进行预览

    注意

    使用“在浏览器中预览”进行预览时，Dreamweaver 执行内部 XSL 转换，而不使用应用程序服务器。有关更多信息，请参见关于预览 XML 数据。

相关主题

  • 显示重复 XML 元素
  • 在动态页中插入 XSLT 片断
  • 关于在 Web 页面中使用 XML 和 XSL
  • 在服务器上执行 XSL 转换


显示重复 XML 元素

重复区域 XSLT 对象允许在 Web 页面中显示来自 XML 数据源的重复元素。例如，如果要显示新闻源的文章标题和说明，而该新闻源包含 10 至 20 篇文章，则 XML 文件中的每一个标题和说明都很可能是重复元素的一个子元素。

“设计”视图中包含 XML 数据占位符的任何区域都可以转换为重复区域。但最常见的区域是表格、表格行或一系列表格行。

若要了解有关重复区域 XSLT 对象如何处理 XML 数据的更多信息，请参见关于 XML 数据和重复元素。

若要显示重复 XML 元素，请执行以下操作：

  1. 在“设计”视图中，选择包含一个或多个 XML 数据占位符的区域。

    可以选定任意内容，包括表格、表格行甚至一段文本。

    提示

    若要精确选择页面上的区域，可以使用“文档”窗口左下角的标签选择器。例如，如果区域是表格，则在页面上单击表格内部，然后在标签选择器中单击 <table> 标签。
  2. 执行下列操作之一：
    • 选择“插入”>“XSLT 对象”>“重复区域”。
    • 在“插入”栏的“XSLT”类别中，单击“重复区域”按钮。
  3. 在 XPath 表达式创建器中，选择以小加号标明的重复元素。

    有关更多信息，请单击对话框上的“帮助”按钮。

  4. 单击“确定”。

    在“文档”窗口中，重复的区域周围会出现一个灰色的选项卡式细轮廓。在浏览器（“文件”>“在浏览器中预览”）中进行预览时，该灰色轮廓消失且所选内容扩展，以显示 XML 文件中的指定重复元素。

    您还会注意到，在将重复区域 XSLT 对象添加到页面中时，Dreamweaver 会截短“文档”窗口中 XML 数据占位符的长度。这是因为 Dreamweaver 更新了 XML 数据占位符的 Xpath，使它成了一个相对于重复元素路径的路径。

    有关更多信息，请参见关于 XML 数据和重复元素。

相关主题

  • 编辑重复区域 XSLT 对象
  • 关于在 Web 页面中使用 XML 和 XSL
  • 在服务器上执行 XSL 转换
  • 设置“XPath 表达式创建器（动态文本）”对话框选项


编辑重复区域 XSLT 对象

将重复区域 XSLT 对象添加到区域后，可以使用“属性”检查器对它进行更改。

若要编辑重复区域 XSLT 对象，请执行以下操作：

  1. 通过单击重复区域周围的灰色标签选择该对象。
  2. 在“属性”检查器（“窗口”>“属性”）中，单击“选择”文本字段旁的动态图标。
  3. 在 XPath 表达式创建器中进行更改，然后单击“确定”。

相关主题

  • 显示重复 XML 元素
  • 设置“XPath 表达式创建器（重复区域）”对话框选项
  • 关于在 Web 页面中使用 XML 和 XSL
  • 在服务器上执行 XSL 转换


在动态页中插入 XSLT 片断

创建 XSLT 片断之后，可以使用 XSL 转换服务器行为将它插入动态 Web 页面。将服务器行为添加至页面并在浏览器中查看页面时，应用程序服务器执行转换，该转换显示所选的 XSLT 片断的 XML 数据。Dreamweaver 支持对 ColdFusion、ASP、ASP.NET 或 PHP 页面执行 XSL 转换。

注意

如果想要在动态页中插入整个 XSLT 页面的内容，过程完全相同。在使用 XSL 转换服务器行为插入整个 XSLT 页面之前，请删除动态页中的所有 HTML 代码。有关更多信息，请参见关于服务器端 XSL 转换。

若要在 Web 页面中插入 XSLT 片断，请执行以下操作：

  1. 打开一个现有的 ColdFusion、ASP、ASP.NET 或 PHP 页面。
  2. 在“设计”视图中，将插入点放置在要插入 XSLT 片断的位置。

    注意

    当插入 XSLT 片断时，将插入点置于页面上后应该始终单击“显示代码视图和设计视图”按钮，以便可以确保插入点位于正确的位置。如果插入点不在正确的位置，您可能需要单击“代码”视图中的别的地方，将插入点放置在需要的位置。
  3. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后选择“XSL 转换”。

  4. 在“XSL 转换”对话框中，单击“浏览”按钮，浏览到 XSLT 片断或整个 XSLT 页面。有关更多信息，请参见创建 XSLT 页面。

    Dreamweaver 使用附加到指定片断的文件路径或 XML 文件的 URL 自动填充下一个文本字段。若要更改，请单击“浏览”按钮，浏览至其他文件。

  5. （可选）单击加号 (+) 按钮添加 XSLT 参数。有关更多信息，请参见使用 XSL 转换参数。
  6. 单击“确定”。

    Dreamweaver 在页面中插入对 XSLT 片断的引用。该片断不可编辑。您可以双击该片断以打开片断的源文件进行编辑。

    Dreamweaver 还在站点的根文件夹中创建一个 includes/MM_XSLTransform/ 文件夹，其中包含一个运行时库文件。应用程序服务器使用该文件中定义的函数执行转换。有关更多信息，请参见关于服务器端 XSL 转换。

  7. 将动态页上载到服务器（“站点”>“上传”）。Dreamweaver 提供包含相关文件的选项时，单击“是”。包含 XSLT 片断的文件、包含您的数据的 XML 文件以及生成的运行时库文件都必须在服务器上，页面才能正确显示。（如果您选择远端 XML 文件作为数据源，则该文件当然必须位于 Internet 上的其他位置。）

相关主题

  • 创建 XSLT 页面
  • 从动态页删除 XSLT 片断
  • 关于在 Web 页面中使用 XML 和 XSL


从动态页删除 XSLT 片断

通过删除用于插入 XSLT 片断的 XSL 转换服务器行为，可以从页面删除该片断。删除服务器行为只删除该 XSLT 片断 － 它不删除关联的 XML、XSLT 或运行时库文件。

若要从动态页删除 XSLT 片断，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，选择要删除的 XSL 转换服务器行为。
  2. 单击减号 (-) 按钮。

    注意

    Macromedia 建议始终以这种方式删除服务器行为。因为手动删除生成的代码虽然会使服务器行为从“服务器行为”面板中消失，但是并没有彻底完整地删除代码。

相关主题

  • 创建 XSLT 页面
  • 在动态页中插入 XSLT 片断
  • 关于在 Web 页面中使用 XML 和 XSL


编辑 XSL 转换服务器行为

向动态 Web 页面添加 XSLT 片断之后，可以随时编辑 XSL 转换服务器行为。

若要编辑 XSL 转换服务器行为，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，双击要编辑的 XSL 转换服务器行为。
  2. 进行更改并单击“确定”。

相关主题

  • 创建 XSLT 页面
  • 在动态页中插入 XSLT 片断
  • 从动态页删除 XSLT 片断
  • 关于在 Web 页面中使用 XML 和 XSL
  • 使用 XSL 转换参数


使用 XSL 转换参数

将 XSL 转换服务器行为添加到 Web 页面时，可以定义 XSL 转换的参数。参数控制 XML 数据的处理和显示方式。例如，您可以使用参数来标识和列出新闻源的特定文章。页面载入浏览器时，只会显示使用该参数指定的文章。

若要将 XSLT 参数添加到 XSL 转换，请执行以下操作：

  1. 打开“XSL 转换”对话框。您可以通过在“服务器行为”面板（“窗口”>“服务器行为”）中双击某个 XSL 转换服务器行为，或通过添加一个新的 XSL 转换服务器行为来执行此操作。有关说明，请参见在动态页中插入 XSLT 片断。
  2. 在“XSL 转换”对话框中，单击 XSLT 参数旁的加号 (+) 按钮。

  3. 在“添加参数”对话框的“名称”文本框中，输入参数的名称。该名称只能包含字母数字字符。不能包含空格。
  4. 执行下列操作之一：
    • 如果要使用静态值，请在“值”文本框中输入。
    • 如果要使用动态值，请单击“值”文本框旁的动态图标，完成“动态数据”对话框，然后单击“确定”。有关更多信息，请单击“动态数据”对话框中的“帮助”按钮。
  5. 如果页面不接收运行时值，请在“默认值”文本框中输入希望参数使用的值。
  6. 单击“确定”。

若要编辑 XSLT 参数，请执行以下操作：

  1. 打开“XSL 转换”对话框。您可以通过在“服务器行为”面板（“窗口”>“服务器行为”）中双击某个 XSL 转换服务器行为，或通过添加一个新的 XSL 转换服务器行为来执行此操作。有关说明，请参见在动态页中插入 XSLT 片断。
  2. 从 XSLT 参数列表中选择参数。
  3. 单击“编辑”按钮。
  4. 进行更改并单击“确定”。

若要删除 XSLT 参数，请执行以下操作：

  1. 打开“XSL 转换”对话框。您可以通过在“服务器行为”面板（“窗口”>“服务器行为”）中双击某个 XSL 转换服务器行为，或通过添加一个新的 XSL 转换服务器行为来执行此操作。有关说明，请参见在动态页中插入 XSLT 片断。
  2. 从 XSLT 参数列表中选择参数。
  3. 单击减号 (-) 按钮。

相关主题

  • 创建 XSLT 页面
  • 在动态页中插入 XSLT 片断
  • 关于在 Web 页面中使用 XML 和 XSL


创建条件 XSLT 区域

可以使用 Dreamweaver 在 XSLT 页面上创建单个或多个条件区域。可以在“设计”视图中进行选择，然后将条件区域应用于该所选内容，或者可以只在文档中的插入点所在的位置插入条件区域。

例如，如果某物品缺货，您要在该物品的价格旁显示“缺货”这个词，则可以在页面上键入“缺货”，选择该词，然后将条件区域应用于选择的文本。Dreamweaver 会使用标签 <xsl:if> 将所选内容括起来，但是仅当数据与条件表达式的条件相匹配时才在页面上显示该单词。

若要创建条件 XSLT 区域，请执行以下操作：

  1. 选择“插入”>“XSLT 对象”>“条件区域”，或者选择“插入”>“XSLT 对象”>“多条件区域”。
  2. 在“条件区域”或“多条件区域”对话框中，输入要用于区域的条件表达式。

    有关更多信息，请单击对话框上的“帮助”按钮。

  3. 单击“确定”。

相关主题

  • 设置“条件区域”对话框选项
  • 设置“多条件区域”对话框选项
  • 创建 XSLT 页面
  • 关于在 Web 页面中使用 XML 和 XSL
  • 使用 XSL 转换参数


编辑条件区域 XSLT 对象

将条件 XSLT 区域添加到页面后，可以使用“属性”检查器对它进行更改。

若要编辑条件区域 XSLT 对象，请执行以下操作：

  1. 通过单击条件区域周围的灰色标签选择该对象。
  2. 在“属性”检查器（“窗口”>“属性”）中，在“测试”文本框中编辑条件表达式。

相关主题

  • 创建条件 XSLT 区域
  • 设置“条件区域”对话框选项
  • 设置“多条件区域”对话框选项
  • 关于在 Web 页面中使用 XML 和 XSL
  • 在服务器上执行 XSL 转换


插入 XSL 注释

可以向文档添加 XSL 注释标签，或将所选内容括在 XSL 注释标签内。

向文档添加 XSL 注释标签：

  • 执行下列操作之一：
    • 在“设计”视图中，选择“插入”>“XSLT 对象”>“XSL 注释”，键入注释内容（或将文本框留空），然后单击“确定”。
    • 在“代码”视图中，选择“插入”>“XSLT 对象”>“XSL 注释”。

将所选内容括在 XSL 注释标签内：

  1. 切换到“代码”视图（“查看”>“代码”）
  2. 选择要为其注释的代码。
  3. 在“编码”工具栏中，单击“应用注释”按钮，然后选择“应用 <xsl:comment></xsl:comment> 注释”。


在客户端执行 XSL 转换

您可以在客户端执行 XSL 转换，而无需使用应用程序服务器。执行此操作时，浏览器（而不是应用程序服务器）将进行 XML 数据转换工作。您可以使用 Dreamweaver 创建这样一个页面，但客户端转换要求对包含所要显示的数据的 XML 文件进行操作。此外，客户端转换只适用于新型浏览器。

Macromedia 建议您在继续以下任何过程之前先阅读关于客户端 XSL 转换。

本节包含以下主题：

  • 执行客户端 XSL 转换的工作流程
  • 创建整个 XSLT 页面
  • 链接 XSLT 和 XML 文件

相关主题

  • 关于服务器端 XSL 转换


执行客户端 XSL 转换的工作流程

本节为您列出了执行客户端 XSL 转换所需遵循的步骤，并指引您参阅文档中详细说明每个过程的相应小节。

Macromedia 建议您在构建显示 XML 数据的页面之前，先阅读关于在 Web 页面中使用 XML 和 XSL、关于服务器端 XSL 转换和关于客户端 XSL 转换。

若要执行客户端 XSL 转换，请遵循以下步骤：

  • 设置 Dreamweaver 站点。请参见设置 Dreamweaver 站点。
  • 执行下列操作之一：
    • 在 Dreamweaver 站点中，创建整个 XSLT 页面。请参见创建整个 XSLT 页面。
    • 将现有 HTML 页面转换为整个 XSLT 页面。请参见将 HTML 页面转换为 XSLT 页面。
  • 如尚未执行此操作，请将 XML 数据源附加到页面。请参见附加 XML 数据源。您附加的 XML 文件必须位于与 XSLT 页面相同的目录中。
  • 将 XML 数据绑定到 XSLT 页面。请参见在 XSLT 页面中显示 XML 数据。
  • 如适用，将重复区域 XSLT 对象添加到包含 XML 数据占位符的表格或表格行。请参见显示重复 XML 元素。
  • 将 XSLT 页面附加到 XML 页面。请参见链接 XSLT 和 XML 文件。
  • 将 XML 页面和链接的 XSLT 页面发送到 Web 服务器。
  • 在浏览器中查看 XML 页面。在执行此操作时，浏览器转换 XML 数据，用 XSLT 页面对 XML 数据进行格式设置，并在浏览器中显示带样式的页面。


创建整个 XSLT 页面

必须使用整个 XSLT 页面进行客户端转换。（XSLT 片断不适用于这种类型的转换。）有关创建 XSLT 页面、将 XML 数据绑定到 XSLT 页面以及对 XSLT 页面进行格式设置的说明，请参见以下主题：

  • 创建 XSLT 页面
  • 在 XSLT 页面中显示 XML 数据
  • 显示重复 XML 元素
  • 将样式应用于 XSLT 片断

相关主题

  • 在客户端执行 XSL 转换


链接 XSLT 和 XML 文件

当您拥有带有 XML 数据的动态内容占位符的整个 XSLT 页面后，必须在 XML 页面中插入对 XSLT 页面的引用。

注意

用于客户端转换的 XML 和 XSL 文件必须位于相同的目录中。否则，浏览器将读取 XML 文件并查找用于转换的 XSLT 页面，但无法找到 XSLT 页面中的相对链接所定义的资源（样式表、图像等）。

若要将 XSLT 页面链接到 XML 页面，请执行以下操作：

  1. 打开要链接到 XSLT 页面的 XML 文件。
  2. 选择“命令”>“附加 XSLT 样式表”。
  3. 在“附加 XSLT 样式表”对话框中，单击“浏览”按钮，浏览到要链接到的 XSLT 页面，选择该页面，然后单击“确定”。
  4. 单击“确定”关闭“附加 XSLT 样式表”对话框。

    Dreamweaver 将在 XML 文档的顶部插入对 XSLT 页面的引用。

相关主题

  • 在客户端执行 XSL 转换


将样式应用于 XSLT 片断

当您创建整个 XSLT 页面（也就是，包含 <body> 和 <head> 标签的 XSLT 页面）时，可以在页面上显示 XML 数据，然后与设置内容的任何其他部分的格式一样，使用属性检查器或“CSS 样式”面板设置数据的格式。但是，当您创建了要插入到动态页中的 XSLT 片断时（例如，要插入到 ASP、PHP 或 Cold Fusion 页面的片断），片断和动态页中的样式呈现会更复杂。虽然您与动态页分开来创建 XSLT 片断，但请务必记住，片断计划用于动态页内，XSLT 片断的输出最终驻留在动态页 <body> 标签中的某处。假如使用此工作流程，请务必确保 XSLT 片断中不包括 <head> 元素（例如样式定义或与外部样式表的链接）。如果包括的话，将导致应用程序服务器将这些元素放置在动态页的 <body> 部分中，从而生成无效的标记。

例如，假如说您正在创建要在动态页中插入的 XSLT 片断，且需要使用与动态页相同的外部样式表对片断设置格式。如果您将相同的样式表附加到片断，则所产生的 HTML 页面将包含重复的样式表链接（一个在动态页的 <head> 部分中，另一个在该页面的 <body> 部分中，XSLT 片断的内容将出现在这部分中。）您应该使用设计时样式表引用外部样式表，而不应该使用此方法。

当设置 XSLT 片断内容的格式时，Macromedia 建议您使用以下工作流程：

  • 首先，将外部样式表附加到动态页。（此过程采用了最佳做法将样式应用于任何 Web 页内容）。
  • 下一步，将相同的外部样式表作为设计时样式表附加到 XSLT 片断。顾名思义，设计时样式表只用于 Dreamweaver“设计”视图。有关更多信息，请参见使用设计时间样式表。

在完成以上几个步骤之后，您可以使用附加到动态页的相同样式表，在 XSLT 片断中应用现有样式或创建新样式。您将得到更简明的 HTML 输出（因为仅当您在 Dreamweaver 中工作时，对样式表的引用才有效），片断在“设计”视图中仍会显示合适的样式。另外，在“设计”视图中查看动态页或在浏览器中预览动态页时，所有样式都将应用于片断和动态页。

注意

如果在浏览器中预览 XSLT 片断，浏览器不会显示样式。但您应该在浏览器中预览动态页来查看动态页上下文中的 XSLT 片断。

有关使用 CSS 设置 XSLT 片断格式的更多信息，请参见 www.macromedia.com/go/dw_xsl_styles。


XSL 转换答疑

在使 XSL 转换发挥作用时如果有困难，则可以在 www.macromedia.com/go/dw_xsl_faq 中获得答疑指导以及许多常问问题的答案。


参考资料

本节描述本章中介绍的对话框：

  • 设置“定位 XML 源”对话框选项
  • 设置“附加 XSLT 样式表”对话框选项
  • 设置“XPath 表达式创建器（动态文本）”对话框选项
  • 设置“XPath 表达式创建器（重复区域）”对话框选项
  • 设置“条件区域”对话框选项
  • 设置“多条件区域”对话框选项
  • 设置重复区域 (XSL) 属性
  • 设置条件区域 (If) 属性
  • 设置条件区域 (When) 属性
  • 指定缺少的字符实体


设置“定位 XML 源”对话框选项

此对话框用于指定 XLST 页面的 XML 数据源。

若要设置对话框的选项，请执行以下操作：

  • 执行下列操作之一：
    • 选择“附加本地文件”，单击“浏览”按钮，浏览至计算机上的本地 XML 文件，然后单击“确定”。
    • 选择“附加远端文件”，输入 Internet 上的 XML 文件（如来自 RSS 源的 XML 文件）的 URL，然后单击“确定”。

单击“取消”按钮将生成一个新的 XSLT 页面，页面中没有附加的 XML 数据源。有关附加 XML 数据源的信息，请参见附加 XML 数据源。

相关主题

  • 创建 XSLT 页面


设置“附加 XSLT 样式表”对话框选项

此对话框用于将 XSLT 样式表附加到 XML 文件。

若要设置对话框的选项，请执行以下操作：

  • 输入 XSLT 样式表的路径和文件名，或者单击“浏览”并选择此 XSLT 样式表。

相关主题

  • 链接 XSLT 和 XML 文件


设置“XPath 表达式创建器（动态文本）”对话框选项

此对话框用于选择要在页面中显示的 XML 数据中的值。Dreamweaver 会在插入点处插入一个 <xsl:value-of/> 标签。使用此方法代替从 XML 架构树中拖动值的优点是您可以对显示的值设置格式。

XPath 表达式创建器的一个优点是在打开对话框时它可以根据在 XSL 文件中的位置来标识当前上下文。当前上下文在 XML 架构树中为粗体。在此对话框中进行选择时，它可以生成与当前上下文相关的相应 XPath 语句。这为初学者和高级用户简化了编写正确 XPath 表达式的过程。

Xpath（XML 路径语言）是一种非 XML 语法，用于确定 XML 文档各部分的位置。大多数情况下，与 SQL 语言用于查询数据库一样，Xpath 用作 XML 数据的查询语言。有关 XPath 的更多信息，请参见 W3C 网站上的 XPath 语言规范，网址是 www.w3.org/TR/xpath。

请注意此对话框用于帮助您构建简单的 XPath 表达式以标识特定节点，这一点很重要。它不允许您手动编辑表达式。如果需要创建复杂的表达式，请使用此对话框开始创建，然后在“代码”视图中或通过“属性”检查器自定义表达式。

若要选择将在页面上显示的值，请执行以下操作：

  1. 在“XPath 表达式创建器（动态文本）”对话框中，选择 XML 架构树中的任何节点。

    Dreamweaver 将在“表达式”文本框中编写正确的 XPath 表达式以标识节点。

    注意

    如果选择 XML 架构树中的其他节点，表达式将会相应进行更改，以反映您的选择。

    在以下示例中，您需要显示 item 节点的 price 子元素：

    这一选择会将以下代码插入 XSLT 页面：

    <xsl:value-of select="price"/>
  2. 如果需要，请从“格式”弹出式菜单中选择一个格式设置选项。

    当节点值返回一个数字时，对所选内容设置格式非常有用。Dreamweaver 提供了预先定义的格式设置功能的列表。请查看“参考”面板以查看可用的格式设置功能和示例的完整列表。

    在以下示例中，您需要对 price 子元素设置格式，将其设置为具有两个小数位的币种：

    这些选项会将以下代码插入 XSLT 页面：

    <xsl:value-of select="format-number(provider/store/items/item/price,'$#.00')"/>
  3. 单击“确定”。
  4. 若要显示 XML 文件中每个节点的值，请对包含动态文本的元素（例如 HTML 表格行或段落）应用重复区域。

    有关更多信息，请参见显示重复 XML 元素。

有关选择节点以返回值的更多信息和示例，请参见“参考”面板中的 <xsl:value-of/> 部分。


设置“XPath 表达式创建器（重复区域）”对话框选项

此对话框用于选择节点以重复和（可选）筛选结果。在调用此对话框时如果已经选择了内容，则您的内容将包括在 <xsl:for-each> 块内。如果未选择内容，则会在光标插入点处输入 <xsl:for-each> 块。

XPath 表达式创建器的一个优点是在打开对话框时它可以根据在 XSL 文件中的位置来标识当前上下文。当前上下文在 XML 架构树中为粗体。在此对话框中进行选择时，它可以生成与当前上下文相关的相应 XPath 语句。这为初学者和高级用户简化了编写正确 XPath 表达式的过程。

Xpath（XML 路径语言）是一种非 XML 语法，用于确定 XML 文档各部分的位置。大多数情况下，与 SQL 语言用于查询数据库一样，Xpath 用作 XML 数据的查询语言。有关 XPath 的更多信息，请参见 W3C 网站上的 XPath 语言规范，网址是 www.w3.org/TR/xpath。

请注意此对话框用于帮助您为重复区域构建简单的 XPath 表达式，这一点很重要。它不允许您手动编辑表达式。如果需要创建复杂的表达式，请使用此对话框开始创建，然后在“代码”视图中或通过“属性”检查器自定义表达式。

若要选择要重复的节点，请执行以下操作：

  • 在“XPath 表达式创建器（重复区域）”对话框中，选择要在 XML 架构树中重复的项目。

    Dreamweaver 将在“表达式”文本框中编写正确的 XPath 表达式以标识节点。

    注意

    重复的项目在 XML 架构树中以加号 (+) 标识。

在以下示例中，您需要重复 XML 文件中的每个 item 节点。

单击“确定”时，以下代码将插入 XSLT 页面中：

<xsl:for-each select="provider/store/items/item">
   此处为内容
</xsl:for-each>

在某些情况下，您可能需要处理重复节点的子集—例如，您可能只需要属性具有特定值的项目。在此情况下，您需要创建过滤器。

若要筛选要重复的数据，请执行以下操作：

  1. 在 XML 架构树中，选择要重复的节点。
  2. 单击“生成过滤器”扩展按钮。
  3. 单击加号 (+) 按钮。

    Dreamweaver 将创建一个空的过滤器。

  4. 在以下字段中输入筛选标准：

    “筛选条件”指定了包含筛选所依据的数据的重复节点。弹出式菜单提供了与 XML 架构树中所选节点相关的祖先节点的列表。

    位置 指定了将用于限制结果的“筛选条件”节点的属性或子元素。可以从弹出式菜单中选择属性或子元素，或在此字段中输入自己的 XPath 表达式，以标识存在于架构树中较深层的子项。

    “运算符”指定了要在筛选表达式中使用的比较运算符。

    “值”指定了要在“筛选条件”节点中检查的值。输入值。如果为 XSLT 页面定义了动态参数，则可以从弹出式菜单中选择一个参数。

  5. 若要指定其他过滤器，请再次单击加号 (+) 按钮。

    在输入值或在弹出式菜单中进行选择时，Dreamweaver 将更改“表达式”文本框中的 XPath 表达式。

在以下示例中，您需要将结果集局限于 @available 属性值为 true 的那些 item 节点。

单击“确定”时，以下代码将插入 XSLT 页面中：

<xsl:for-each select="provider/store/items/item[@available = &apos;true&apos;]">
     此处为内容
</xsl:for-each>

注意

您需要将字符串值（如 true）用引号引起来。Dreamweaver 会为您对引号 (&apos;) 进行编码以便能够将其输入为有效的 XHTML。

您可以创建允许将父节点指定为筛选标准一部分的更复杂的过滤器。在以下示例中，您需要将结果集局限于满足以下条件的那些 item节点：store 的 @id 属性等于 1，item 的 price 节点大于 5。

单击“确定”时，以下代码将插入 XSLT 页面中：

<xsl:for-each select="provider/store[@id = 1]/items/item[price &gt; 5]">
   此处为内容
</xsl:for-each>

有关重复区域的更多信息和示例，请参见“参考”面板中的 <xsl:for-each> 部分。


设置“条件区域”对话框选项

此对话框用于编写要插入 XSLT 页面中的简单条件表达式。打开此对话框时如果选定了内容，则内容将包括在 <xsl:if> 块中。如果未选择内容，则会在插入点处输入 < xsl:if> 块。

此对话框提供了一种创建简单条件表达式的方法。建议您使用此对话框开始创建，然后在“代码”视图中自定义表达式。

<xsl:if> 元素类似于其他语言中的 if 语句。此元素提供了一种方法，供您测试条件并根据结果采取一系列行动步骤。<xsl:if> 元素允许您测试表达式以得出一个 true 或 false 值。

若要插入条件区域，请执行以下操作：

  1. 在“条件区域”对话框中，输入条件。

    在以下示例中，您需要进行测试以查看上下文节点的 @available 属性值是否为 true。

  2. 单击“确定”。

    以下代码将插入 XSLT 页面中：

    <xsl:if test="@available=&apos;true&apos;">
   此处为内容
</xsl:if>

    注意

    您需要将字符串值（如 true）用引号引起来。Dreamweaver 会为您对引号 (&apos;) 进行编码以便能够将其输入为有效的 XHTML。

除了测试节点值外，您可以在任何条件语句中使用受支持的任何 XSLT 函数。为 XML 文件中的当前节点测试条件。在以下示例中，您需要为结果集中的最后一个节点进行测试：

有关编写条件表达式的更多信息和示例，请参见“参考”面板中的 <xsl:if> 部分。


设置“多条件区域”对话框选项

此对话框用于编写要插入 XSLT 页面中的简单条件表达式。打开此对话框时如果选定了内容，则内容将包括在 <xsl:choose> 块中。如果未选定内容，则会在插入点处输入 <xsl:choose> 块。

此对话框提供了一种创建简单条件表达式的方法。建议您使用此对话框开始创建，然后在“代码”视图中自定义表达式。

<xsl:choose> 元素类似于其他语言中的 case 语句。此元素提供了一种方法，供您测试条件并根据结果采取一系列行动步骤。<xsl:choose> 元素允许您对多个条件进行测试。

若要插入多条件区域，请执行以下操作：

  1. 在“多条件区域”对话框中，输入第一个条件。

    在以下示例中，您需要进行测试以查看上下文节点的 price 子元素是否小于 5。

  2. 单击“确定”。

    在此示例中，以下代码将插入 XSLT 页面中：

    <xsl:choose>
   <xsl:when test="price&lt;5">
      此处为内容
   </xsl:when>
   <xsl:otherwise>
      此处为内容
   </xsl:otherwise>
</xsl:choose>
  3. 若要插入另一个条件，请将插入点置于“代码”视图中的 <xsl:when> 标签对之间，或者就置于 <xsl:otherwise> 标签之前，然后插入条件区域（“插入”>“XSLT 对象”>“条件区域”）。

    指定条件后，单击“确定”，Dreamweaver 会将另一个 <xsl:when> 标签插入 <xsl:choose> 块中。

有关编写条件表达式的更多信息和示例，请参见“参考”面板中的 <xsl:choose> 部分。


设置重复区域 (XSL) 属性

此属性检查器用于选择要重复的不同 XML 节点以创建重复区域。

若要选择不同的 XML 节点，请执行以下操作：

  • 在“选择”文本框中，输入新节点，然后按闪电图标并从出现的 XML 架构树中选择节点。

    有关更多信息，请参见设置“XPath 表达式创建器（重复区域）”对话框选项。


设置条件区域 (If) 属性

此属性检查器用于更改 XSL 页面条件区域中使用的条件。条件区域将测试条件并根据结果采取一系列操作步骤。

若要更改条件区域中使用的条件，请执行以下操作：

  • 在“测试”文本框中，输入新条件，然后按 Enter 键。

    有关更多信息，请参见设置“条件区域”对话框选项。


设置条件区域 (When) 属性

此属性检查器用于更改 XSL 页面多条件区域中使用的条件。多条件区域将测试条件并根据结果采取一系列操作步骤。

若要更改多条件区域中使用的条件，请执行以下操作：

  • 在“测试”文本框中，输入新条件，然后按 Enter 键。

    有关更多信息，请参见设置“多条件区域”对话框选项。


指定缺少的字符实体

在 XSLT 中，某些上下文中不允许存在某些字符。例如，您无法在标签之间的文本或属性值中使用小于号 (<) 和“与”符号 (&)。如果错误地使用了这些字符，XSLT 转换引擎将向您显示错误。要解决此问题，您可以指定用于替代特殊字符的字符实体。

字符实体是表示其他字符的字符串。字符实体已被命名或编号。命名的实体以“与”符号 (&) 开头，后面是名称或字符，并以分号 (;) 结束。例如 &lt; 表示左尖括号字符 (<)。除了用哈希号 (#) 和数字来指定字符之外，编号的实体也以同样的方式开头和结束。

XSLT 具有以下五个预定义的实体：

字符 | 实体代码
<（小于） | &lt;
&（与） | &amp;
>（大于） | &gt;
"（引号） | &quot;
‘（撇号） | &apos;

如果在 XSL 文件中使用其他字符实体，则需要在 XSL 文件的 DTD 部分中定义这些实体。Dreamweaver 提供了一些默认的实体定义，在 Dreamweaver 中创建的 XSL 文件的顶部可以看到这些默认的实体定义。这些默认的实体可以让您广泛地选择最常用的字符。

在浏览器中预览 XSL 文件时，Dreamweaver 将在 XSL 文件中检查未定义的实体。如果找到未定义的实体，Dreamweaver 将在消息框中通知您。

如果预览附加到 XSLT 文件中的 XML 文件，或者预览具有 XSLT 转换的服务器端页面，则服务器或浏览器（而不是 Dreamweaver）会通知您哪些是未定义的实体。例如，在请求由缺少实体定义的 XSL 文件转换的 XML 文件时，在 Internet Explorer 中可能会显示以下消息：

Reference to undefined entity 'auml'. Error processing resource 'http://localhost/testthis/list.xsl'. Line 28, Position 20
<p class="test">&auml;</p>
-------------------^

若要在页面中更正此错误，需要手动将实体定义添加到页面中。

若要指定缺少的实体定义，请执行以下操作：

  1. 在 W3C Web 站点上的字符实体参考页面中查寻缺少的字符，网址为：www.w3.org/TR/REC-html40/sgml/entities.html。

    此 Web 页面包含 HTML 4 和 XHTML 1.0 中允许的 252 个实体。

    例如，如果缺少字符实体 Egrave，请在 W3C Web 页面上搜索“Egrave”。您将发现以下项：

    <!ENTITY Egrave CDATA "&#200;" -- latin capital letter E with grave, U+00C8 ISOlat1 -->
  2. 记录该项中的实体名称和实体代码。

    在此示例中，Egrave 是实体名称，&#200 是实体代码。

  3. 了解此信息后，请切换到 Dreamweaver 的“代码”视图中，在 XSL 文件（在 Doctype 声明之后并且具有其他实体标签）的顶部输入以下实体标签：
    <!ENTITY entityname "entitycode;">

    在此示例中，您需要输入以下实体标签：

    <!ENTITY Egrave "&#200;">
  4. 保存您的文件。

如果要重复使用相同的字符实体，则可能需要在 XSL 文件中永久添加它们的定义，在使用“文件”>“新建”时，默认情况下，Dreamweaver 会创建此 XSL 文件。

若要将实体定义添加到默认情况下 Dreamweaver 创建的 XSL 文件，请执行以下操作：

  1. 在 Dreamweaver 应用程序文件夹中查找以下配置文件，然后在任何文本编辑器中打开此文件：

    Configuration/DocumentTypes/MMDocumentTypeDeclarations.xml

  2. 查找名为 called mm_xslt_1 的声明：
    <documenttypedeclaration id="mm_xslt_1">
  3. 如下所示，请在实体标签列表中输入新的实体标签：
    <!ENTITY entityname "entitycode;">
  4. 保存文件并重新启动 Dreamweaver。


使用 Web 服务

Web 服务是新兴技术，它使 Web 页可以访问分布式应用程序。通过将对信息和应用程序功能的访问作为服务提供给用户，Web 服务可作为服务流提供和出售，这种服务流支持从任意平台进行范围广泛的访问。连接到 Web 服务的 Web 页通称作使用者，而服务本身称作发布者。Macromedia Dreamweaver 8 使您可以创建作为 Web 服务使用者的页面和站点。Dreamweaver 当前支持使用 Macromedia ColdFusion MX、ASP.NET 和 Java Server Pages (JSP) 文档类型创建 Web 服务使用者。具体而言，Dreamweaver 允许您执行以下 Web 服务开发任务：

  • 选择可用于 Internet 的 Web 服务。
  • 生成 Web 服务代理，该代理允许 Web 页与 Web 服务发布者通信。

    代理（也称为抽象类）包含 Web 服务的域、方法和属性，并使它们可用于本地寄存的页。当您为页面生成代理时，Dreamweaver 使您可以在“组件”面板中查看它们。

  • 将方法和数据类型拖入页面的代码中。

在创建使用 Web 服务的 Web 页前，您必须熟悉要使用的应用程序的基础服务器技术以及该应用程序需要的编程结构。

Dreamweaver 允许您创作可以访问 Web 服务并利用这些服务提供的功能的 Web 页。此外，您可以使用 Macromedia ColdFusion MX 创建并发布 Web 服务以进行部署。

本章包含下列章节：

关于 Web 服务

关于代理生成器

使用 WSDL 说明添加 Web 服务代理

向页面添加 Web 服务

编辑 UDDI Web 服务站点列表


关于 Web 服务

通过 Web 服务，不论应用程序使用哪种操作系统或编程语言，都可以在 Internet 上进行通信并共享信息。以下是 Web 服务及其提供的信息和功能的示例：

  • 用户身份验证和授权
  • 信用卡验证
  • 金融市场服务，能够返回与指定的股票行情收录器符号关联的股票价格
  • 允许用户联机订购产品的采购服务
  • 基于所选的兴趣、位置或其它个人信息提供新闻或其它信息类型的信息服务

Web 服务将功能作为一种 Web 页根据需要连接并使用的服务提供给用户，从而使开发人员和服务提供商可以更灵活地设计并部署功能强大的分布式应用程序。

Web 服务由以下基本组件构成：

  • 服务发布者提供宿主应用程序并使它们可供使用。Web 服务既可以免费提供，也可以作为收费服务提供。
  • 服务经纪人负责维护服务提供商的注册表，其中包含所提供服务的说明以及指向其应用程序的链接。
  • 服务使用者是访问和使用远程 Web 服务的 Web 页。

本节包含以下概念性主题：

  • Dreamweaver Web 服务工作流程
  • 查找 Web 服务发布者
  • Web 服务软件组件
  • Web 服务参考资料
  • 获取附加代理生成器


Dreamweaver Web 服务工作流程

若要使用 Dreamweaver 创建作为 Web 服务使用者的页面或站点，您必须执行以下任务：

  1. 安装和配置代理生成器。

    代理生成器能够生成 Web 服务代理，这是 Web 页用来与 Web 服务发布者通信的软件组件。Web 服务代理是从描述 Web 服务的 Web 服务描述语言 (WSDL) 生成的。根据您想要开发 Web 服务使用者所采用的服务器技术，您可能需要安装和配置支持该技术的代理生成器。

    Dreamweaver 附带预配置的 AXIS，它是支持 JSP Web 服务开发的 Apache SOAP 代理生成器。如果您要开发 ColdFusion 6 页面，则 Web 服务代理生成器已包括在 ColdFusion 服务器中。通过建立与 ColdFusion 服务器的连接，您将能够访问该代理生成器。

    如果您要开发用于 ASP.NET 的 Web 服务页，则必须安装 ASP.NET SDK，它可以从 Microsoft 获得。

    有关安装和配置 Dreamweaver 未提供的代理生成器的信息，请参见关于代理生成器。

  2. 使用浏览器，查看 Web 服务的基于 Web 的注册表。

    Web 服务的来源有若干种，从 Web 服务注册表站点到简单的列表都有。注册表使用 UDDI，这是让服务提供商和请求者能够找到彼此并进行事务处理的标准。UDDI 使企业可以在 Web 上找到满足其要求的服务。例如，使用 UDDI，您可以指定某些条件（如某一服务的最低价格）或者要返回的特定信息。

    有关更多信息，请参见设置“UDDI 站点”对话框选项。

  3. 在找到并选择提供所需功能的 Web 服务后，在“添加 Web 服务”对话框中输入 WSDL 的 URL。

    有关更多信息，请参见设置“Web 服务选择器”对话框选项。

  4. 根据服务发布者的 WSDL 说明，为该 Web 服务生成代理。

    若要将 Web 服务嵌入 Web 页中，您必须创建代理。代理向 Web 页提供与 Web 服务通信以及访问 Web 服务所提供方法的必需信息。

    若要从 WSDL 文件创建代理，请使用代理生成器。在创建代理后，您可以在以下两个位置之一安装它：

    • 您正在其上开发 Web 服务使用者的本地计算机。
    • 运行应用程序服务器的服务器计算机。若要部署 Web 页并使其与 Web 服务发布者通信，您必须在服务器上安装代理。

    有关更多信息，请参见关于代理生成器。

  5. 使用 Dreamweaver，将 Web 服务添加到某一页上并编辑所需的参数和方法，以便于利用该服务的功能。

    有关更多信息，请参见向页面添加 Web 服务。


查找 Web 服务发布者

Web 服务本身是由服务发布者提供的。通常，服务发布者通过基于 Web 的注册表（它维护您可以访问的可用服务的目录），使其 Web 服务可用。许多 Web 站点提供此类目录，这些站点包括：

  • X Methods（X 方法），网址为 http://www.xmethods.net
  • IBM Business Registry，网址为 https://uddi.ibm.com/ubr/registry.html
  • Microsoft UDDI registry（Microsoft UDDI 注册表），网址为 http://uddi.microsoft.com/default.aspx

这些注册表使用通用描述、发现和集成 (UDDI) 服务。这是一个开放的电子商务服务注册表，它为企业提供一个论坛，在这里企业可以描述他们自己以及他们向其它企业提供的商品或服务。一组称作运营商的公司维护该注册表。运营商保证在他们之间以及与此项服务的用户共享与注册者有关的所有公共信息，并且保证在 UDDI 服务网络的多个对等节点间维持互操作性。除了公共 Web 服务之外，还有通过订阅提供的专用 UDDI 注册表。

UDDI 规范基于现有的 Internet 标准，从而确保它可用于各种平台和实现。

相关主题

  • 编辑 UDDI Web 服务站点列表


Web 服务软件组件

为了使 Web 页可以访问和使用 Web 服务，此 Web 页必须与该服务通信，并且具有该服务提供的功能、它可以调用的方法以及服务返回的参数的说明。Web 服务描述语言 (WSDL) 是基于 XML 的服务说明。每一 Web 服务均提供 WSDL，它描述如何绑定到该服务、Web 页可以调用的方法以及数据输入和输出。WSDL 可以驻留在某一文件中，也可以在运行时由 Web 服务生成。

请求该服务的 Web 页和该 Web 服务本身之间的通信使用简单对象访问协议 (SOAP)。SOAP 是基于 XML 的协议，它使 Web 客户端可以访问并调用 Web 服务的方法和参数。

相关主题

  • 使用 WSDL 说明添加 Web 服务代理


Web 服务参考资料

若要了解有关 Web 服务以及使这些服务成为可能的基础技术的更多信息，请访问以下 Web 站点：

  • WSDL specification（WSDL 规范），网址为 http://www.w3.org/TR/wsdl
  • UDDI specification（UDDI 规范），网址为 http://www.uddi.org/specification.html
  • XML specification（XML 规范），网址为 http://www.w3.org/TR/REC-xml
  • SOAP specification（SOAP 规范），网址为 http://www.w3.org/TR/SOAP/


关于代理生成器

Dreamweaver 安装支持 JSP Web 服务的 AXIS 代理生成器。AXIS 是通过 Apache SOAP 项目分发的开放源代码的代理生成器。此外，您可以添加支持其它供应商的 Web 服务实现或新 Web 服务技术的代理生成器。本节介绍如何获取代理生成器并配置它们以和 Dreamweaver 一起使用。

若要了解有关 AXIS 的更多信息，请参见 Apache AXIS Web 站点，其网址为 http://ws.apache.org/axis/index.html。

相关主题

  • 获取附加代理生成器
  • 配置代理生成器以用于 Dreamweaver


获取附加代理生成器

如果您想要安装未随 Dreamweaver 一起提供的代理生成器，您必须从供应商处获取该代理生成器和所有相关软件组件。您应该能够从供应商的 Web 站点下载所有必需的文件。

某些代理生成器创建依赖其它软件库的代理，因此必须正确安装这些软件库以便代理生成器可以访问它们。例如，AXIS 代理生成器创建依赖 Apache SOAP 库的代理，而 Apache SOAP 库又依赖其它软件库（请注意，默认情况下，使用 AXIS 所需的所有必要软件都随 Dreamweaver 一起安装）。在选择代理生成器时，请参考提供的文档，并确保您具有所有必需的软件组件和库，以便您可以正确安装和配置它们。

在正确安装和配置代理生成器后，您必须将它配置为能与 Dreamweaver 一起使用。

注意

当前，用 Dreamweaver 进行 Web 服务的开发被限制在 Windows 环境内。若要在 Macintosh 上开发访问 Web 服务的页面，您必须使用单独的应用程序服务器，此服务器运行在 Windows NT/2000/XP 或 UNIX 上，而 Web 服务代理及其应用程序环境将在其上运行。


配置代理生成器以用于 Dreamweaver

当您安装 Web 服务代理生成器时，您必须将它配置为能与 Dreamweaver 一起使用。

若要了解有关代理生成器的更多内容，请参见关于代理生成器。

若要配置代理生成器以便和 Dreamweaver 一起使用，请执行以下操作：

  1. 选择“窗口”>“组件”打开“组件”面板。
  2. 在“组件”面板中，从面板左上角的弹出菜单中选择“Web 服务”，然后单击加号 (+) 按钮并选择“使用 WSDL 添加”。

    随即显示“使用 WSDL 添加”对话框。

  3. 在“使用 WSDL 添加”对话框中，从“代理生成器”弹出菜单中选择“编辑代理生成器列表”。

    随即显示“代理生成器”对话框。

  4. 单击“新建”，从弹出菜单中选择代理生成器，然后单击“完成”。

    如果您想要使用的代理生成器未在列表中出现，则选择“默认代理生成器”以显示“默认代理生成器”对话框。

    您可以通过“默认代理生成器”对话框配置选定的代理生成器，您也可以配置新的代理生成器。根据您选择的代理生成器的不同，对话框的文本框也将有所不同。

    注意

    ColdFusion MX 代理生成器是不可编辑的。

  5. 完成对话框设置，然后单击“确定”。

    有关完成该对话框的文本框设置的信息，请参见设置“默认代理生成器”对话框选项。

  6. 完成对“默认代理生成器”的设置后，单击“确定”。

    在 Dreamweaver 读取 Web 服务的 WSDL 说明时，Dreamweaver 将执行以下与“默认代理生成器”的各域有关的操作：

    • 将 WSDL 作为输入读取以查找 Web 服务。
    • 通过指定的运行时环境生成 Web 服务代理。
    • 使用指定的编译器编译代理。
    • 将代理源代码和编译的代理返回到指定的目标文件夹中。

相关主题

  • 关于代理生成器
  • 获取附加代理生成器


使用 WSDL 说明添加 Web 服务代理

在指定了代理生成器（请参见关于代理生成器）并配置了您想要支持的 Web 服务的服务器模型后，您需要查找提供所需功能的 Web 服务并为该服务生成代理。

若要选择 Web 服务并通过其 WSDL 文件生成代理，请执行以下操作：

  1. 打开您要将 Web 服务添加到的页。
  2. 选择“窗口”>“组件”打开“组件”面板。
  3. 在“组件”面板中，从该面板左上角的弹出菜单中选择“Web 服务”，然后单击加号 (+) 按钮并选择“使用 WSDL 添加”。

    随即显示“使用 WSDL 添加”对话框。

  4. 指定您要使用的 WSDL 文件的 URL。

    如果您知道 WSDL 文件的 URL，则在“WSDL 的 URL”文本框中输入它。

    如果您不知道 WSDL 文件的 URL，则您可以浏览 Web 服务的目录。找到所需的 Web 服务后，将该 Web 服务的 URL 复制并粘贴到 WSDL 编辑框中。若要启动 Web 浏览器，请单击 UDDI 浏览按钮并选择列出的 Web 服务注册表之一。Dreamweaver 将启动该浏览器并打开选定的注册表。找到您要使用的 Web 服务，将其 WSDL 文件的 URL 复制到剪贴板中（在 Windows 中使用 Ctrl+C 组合键，在 Macintosh 中使用 Command+C 组合键）。返回到“Web 服务选择器”并将该 URL 粘贴到对话框中。

    您可以编辑 Web 服务注册表的列表以包括附加的 Web 服务目录或特定的 Web 服务提供商。有关更多信息，请参见编辑 UDDI Web 服务站点列表。

  5. 从“代理生成器”弹出菜单中选择支持所需 Web 服务的服务器模型的代理生成器。

    确保在您的系统上安装并配置了代理生成器。有关更多信息，请参见关于代理生成器。

  6. 单击“确定”。

    代理生成器为 Web 服务创建代理并对其进行内部检查。内部检查是一个过程，在此过程中，代理生成器查询 Web 服务代理的内部结构并通过 Dreamweaver 使其接口、方法和属性可供使用。

Web 服务现在可以用于此站点，并且出现在“组件”面板中。您现在可以将此 Web 服务添加到页面。有关更多信息，请参见向页面添加 Web 服务。

相关主题

  • Web 服务软件组件


向页面添加 Web 服务

在选择 Web 服务、生成其代理并将其添加到“组件”面板后，您可以将它插入页面中。

下面的插图显示该“组件”面板，其中已添加了 Web 服务代理 Helloworld。Helloworld 代理提供一个方法 sayHello，该方法输出“Hello World”。

以下示例使用 ColdFusion 实例化 HelloWorld Web 服务。若要了解有关创建 Web 服务的更多信息，并查看使用 .NET 和 JSP 的更多示例，请访问 Macromedia Support Center（Macromedia 支持中心），其网址为：www.macromedia.com/go/creating_web_services。

若要向页面添加 Web 服务，请执行以下操作：

  1. 在“文档”窗口的“代码”视图中，将 sayHello 方法拖入页面的 HTML 中。

    Dreamweaver 将该方法和伪参数添加到页面中。

  2. 按照 Web 服务的要求，使用适当的服务实例名称、数据类型和参数值编辑插入的代码。该 Web 服务应提供数据类型和参数值的说明。

    在下面所示的 ColdFusion 示例中，该 Web 服务括在 <cfinvoke> 标签里。当在 ColdFusion 中开发 Web 服务时，使用 <cfinvoke> 实例化该 Web 服务并调用其方法。

    <html>
<head>
<title>Web Service</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>

<cfinvoke
webservice="http://www.mysite.com:8500:8500/helloworld/HelloWorld.cfc?wsdl"
method="sayHello"
returnvariable="aString">
</cfinvoke>

</body>
</html>
  3. 如果您想要将返回值绑定到可视化元素，则切换到“设计”视图并将可视化元素放置到可以接受数据绑定的页面上。然后切换回“代码”视图并输入适当的代码将返回值绑定到可视化元素上。在创建 Web 服务时，请参考技术提供商的文档以了解实例化服务并向页面显示返回值所用的正确语法。

    在此示例中，为变量 aString 返回的值是使用 ColdFusion <cfoutput> 标签的输出。这将向页面显示“The web service says:Hello world!”一句。

    <html>
<head>
<title>Web Service</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<cfinvoke
webservice="http://www.mysite.com:8500/helloworld/HelloWorld.cfc?wsdl"
method="sayHello"
returnvariable="aString">
</cfinvoke>

The web service says: <cfoutput>#aString#</cfoutput>
</body>
</html>
  4. 当您将 Web 页部署到生产服务器时，Dreamweaver 自动将这些页、代理和所有必需的库复制到 Web 服务器中。

    注意

    如果用来开发应用程序的代理所安装的计算机不是开发页面所用的计算机，或者您使用的站点管理工具没有将所有相关文件都复制到服务器上，则您一定要部署代理和所有相关库文件。否则，您的页面将不能与 Web 服务应用程序通信。


编辑 UDDI Web 服务站点列表

“Web 服务选择器”提供基于 UDDI 的 Web 服务目录列表，您可以从中选择 Web 服务。您可以编辑该列表以添加或删除 Web 服务目录。有关更多信息，请参见查找 Web 服务发布者。

若要编辑 Web 服务站点列表，请执行以下操作：

  1. 在 Dreamweaver 中，选择“窗口”>“组件”以打开“组件”面板。
  2. 在“组件”面板中，从该面板左上角的弹出菜单中选择“Web 服务”，然后单击加号 (+) 按钮以添加 Web 服务。

    随即显示“使用 WSDL 添加”对话框。

  3. 在“Web 服务选择器”中，单击地球图标并从弹出菜单中选择“编辑 UDDI 站点列表”。

    出现“UDDI 站点”对话框。

  4. 从“UDDI 站点”对话框中，您可以添加新 Web 服务站点，编辑现有站点的名称和 URL，并且删除不需要的站点。
    • 若要添加新站点或修改现有站点，请单击“新建”或“编辑”按钮并完成显示的对话框的设置。
    • 若要删除现有站点，在列表中选择它并单击“删除”按钮。


参考资料

本节提供在本章中介绍的下列对话框的有关信息：

  • 设置“Web 服务选择器”对话框选项
  • 设置“代理生成器”对话框选项
  • 设置“默认代理生成器”对话框选项
  • 设置“选取服务器模型”对话框选项
  • 设置“UDDI 站点”对话框选项
  • “ColdFusion 代理生成器”对话框
  • 设置“使用代理类添加”对话框


设置“Web 服务选择器”对话框选项

此对话框使您可以选择 Web 服务并生成支持页面访问该服务的代理。

若要设置“Web 服务选择器”对话框选项，请执行以下操作：

  1. 设置以下选项：

    WSDL 文件的 URL 输入 WSDL 文件的 URL 或本地文件路径。此信息由 Dreamweaver 作为输入读取，并且用于为 Web 服务生成代理和脚本撰写信息。

    代理生成器 选择支持您选定的文档类型的代理生成器以生成 Web 服务代理。

    浏览器按钮 从包含纯英文名称的 URL 的菜单中进行选择，这些 URL 指向 UDDI 注册表和 WSDL 文件的其它重要储备库。选择了一个菜单项后，浏览器将出现并打开选定的 URL。随即“选择编辑浏览器列表”打开用于编辑浏览器首选参数的对话框。

  2. 单击“确定”。

相关主题

  • 使用 WSDL 说明添加 Web 服务代理


设置“代理生成器”对话框选项

通过此对话框，您可以定义新的代理生成器，或者修改、删除或复制现有的代理生成器。

若要定义、修改或删除代理生成器，请执行以下操作：

  1. 执行以下任何操作：
    • 若要将代理生成器添加到该列表，请单击“新建”并完成显示的对话框的设置。

      有关更多信息，请参见设置“默认代理生成器”对话框选项。

    • 若要删除列表中的代理生成器，请在列表中选择它并单击“删除”。
    • 若要修改代理生成器，请在列表中选择它并单击“编辑”。在生成的对话框中进行更改。

      有关更多信息，请参见设置“默认代理生成器”对话框选项。

    • 若要创建代理生成器的副本，请在列表中选择该代理生成器并单击“重制”。
  2. 单击“完成”。

相关主题

  • 关于代理生成器


设置“默认代理生成器”对话框选项

通过此对话框，您可以设置默认代理生成器的属性。

若要配置默认的代理生成器，请执行以下操作：

  1. 设置下列属性：

    名称 在弹出菜单中出现的代理生成器实例的名称。

    支持的服务器模型 代理生成器支持的服务器模型的列表。可以使用加号 (+) 和减号 (-) 按钮编辑该列表。

    单击加号 (+) 按钮将显示“选取服务器模型”对话框。从可用服务器模型列表中选择一个服务器模型，然后单击“确定”。

    生成代理命令 根据 WSDL 信息生成代理源代码。在代理生成器命令中可以采用以下标记：

    编译代理命令 将代理源代码编译成可执行代码。

    对编译的代理进行内部检查 从弹出菜单中选择内部检查器，以便对编译的代理进行内部检查。

    目标文件夹 用于放置经过编译的 Web 服务代理及其源代码的文件夹。

  2. 单击“确定”。

相关主题

  • 关于代理生成器
  • 使用 WSDL 说明添加 Web 服务代理


设置“选取服务器模型”对话框选项

通过“选取服务器模型”对话框，您可以选择指定代理生成器支持的服务器模型。

若要选择服务器模型，请执行以下操作：

  1. 从列表中选择一个服务器模型。在按 Ctrl 键的同时从列表中进行选择，可以选取多个服务器模型。
  2. 单击“确定”。

相关主题

  • 关于代理生成器
  • 使用 WSDL 说明添加 Web 服务代理


设置“UDDI 站点”对话框选项

通过“UDDI 站点”对话框，您可以添加、编辑或删除 UDDI 目录，以便更加方便地浏览 Web 服务。

若要添加新站点或编辑现有站点，请执行以下操作：

  1. 单击“新建”按钮以显示“新建 UDDI 站点”对话框，或者单击“编辑”按钮以显示“编辑 UDDI 站点”对话框。
  2. 如果您知道 UDDI Web 站点的名称和 URL，请输入这些信息。

    您还可以单击“地址”文本框旁的浏览器按钮（地球图标），从而启动 Web 浏览器以定位 UDDI 站点。

  3. 在您输入了 UDDI Web 站点的名称和 URL 后，单击“确定”。

    新的或修改后的 UDDI 站点将出现在“UDDI 站点”对话框的站点列表中。

  4. 单击“完成”。

若要删除一个站点，请执行以下操作：

  1. 从列表中选择一个站点并单击“删除”按钮。
  2. 单击“完成”。

相关主题

  • 编辑 UDDI Web 服务站点列表


“ColdFusion 代理生成器”对话框

ColdFusion 代理生成器是不可配置的。

相关主题

  • 关于代理生成器
  • 使用 WSDL 说明添加 Web 服务代理


设置“使用代理类添加”对话框

通过此对话框，您可在使用 .NET 或 JSP 开发框架时选择本地 .NET DLL 或 JSP 阅读器，对 Web 服务代理进行内部检查。

若要选择代理类阅读器，请执行以下操作：

  1. 在文本框中输入代理类阅读器的位置。

    可以通过单击文本框右侧的“浏览”按钮浏览该文件。

  2. 从弹出菜单中选择您要使用的代理阅读器。

    有两种默认代理阅读器：

    • .NET DLL 阅读器，用于 ASP .NET 文档类型
    • Java 类阅读器，用于 JSP 文档类型
  3. 单击“确定”。

相关主题

  • 关于代理生成器
  • 设置“默认代理生成器”对话框选项


添加自定义服务器行为

Macromedia Dreamweaver 8 提供了一组内置的服务器行为，使您能够方便地向站点添加动态功能。如果要扩展 Dreamweaver 的功能，可以创建适合开发需要的新服务器行为，也可以从 Macromedia Exchange Web 站点获取服务器行为。

本章包含下列章节：

关于自定义服务器行为

安装第三方服务器行为

使用“服务器行为创建器”

在服务器行为中使用参数

定位代码块

为自定义服务器行为创建对话框

编辑和修改服务器行为


关于自定义服务器行为

在创建您自己的服务器行为之前，请查看 Macromedia Exchange Web 站点，了解是否有人已经创建了能提供您希望添加到 Web 站点的功能的服务器行为。通常，第三方开发人员已经创建了能解决您需要的服务器行为并进行了测试。

利用 Macromedia Exchange Web 站点获取的服务器行为以及其它功能扩展，您能够轻松地向 Dreamweaver 添加新功能。每个服务器行为都包括简短说明、用户评论和讨论组，在其中可以张贴问题并获取对所下载服务器行为的支持。

如果您想创建自己的服务器行为，请熟悉您的 Web 站点使用的 Web 编程语言。本章特别为使用 Dreamweaver 创建服务器行为提供了指南。它并不针对编程语言或服务器行为测试进行指导。

本节包含以下概念性主题：

  • 服务器行为
  • 关于代码块
  • 服务器行为中的参数
  • 条件式代码块
  • 有效使用条件表达式
  • 重复代码块
  • 编码指导原则
  • 测试服务器行为


服务器行为

如果您是一位精通 Macromedia ColdFusion、ASP.NET、JavaScript、VBScript、PHP 或 Java 的开发人员，则可以编写自己的服务器行为。创建服务器行为的步骤包括下列任务：

  • 编写一个或多个执行所需操作的代码块。

    有关利用 Dreamweaver 的“服务器行为创建器”创建服务器行为的信息，请参见使用“服务器行为创建器”。有关 Dreamweaver 服务器行为所支持的语法的信息，请参见在服务器行为中使用参数。

  • 指定代码块在页面的 HTML 代码内的插入位置。

    有关在页面内定位代码块的信息，请参见定位代码块。

  • 如果服务器行为要求为参数指定值，则创建一个对话框，提示使用该行为的 Web 开发人员提供一个适当的值。

    有关使用对话框向服务器行为提供参数值的信息，请参见为自定义服务器行为创建对话框。

  • 在将该服务器行为提供给其他人之前，对其进行测试。

    有关测试服务器行为的指导原则，请参见测试服务器行为。


关于代码块

在“服务器行为创建器”中创建的代码块封装在服务器行为中，该服务器行为显示在“服务器行为”面板中。代码可以是指定服务器模型的任何有效的运行时代码。例如，如果选择 ColdFusion 作为自定义服务器行为的文档类型，则编写的代码必须是能在 ColdFusion 应用程序服务器上运行的有效的 ColdFusion 代码。

相关主题

  • 编码指导原则

代码块

可以直接在“服务器行为创建器”中创建代码块，也可以从其它来源复制和粘贴代码。在“服务器行为创建器”中创建的每个代码块都必须为单个标签或脚本块。如果需要插入多标签代码块，请将它们拆分为单独的代码块。

有关更多信息，请参见使用“服务器行为创建器”

运行时参数

可以在运行时代码中包含参数并由页面设计者提供参数值。为此，请在代码中输入参数标记，如下所示：

@@parameterName@@

有关更多信息，请参见在服务器行为中使用参数。

代码块中的条件和重复元素

如果希望代码块或部分代码块仅在某些条件适用时才执行，请使用以下语法：

<@ if (expression1) @>
   code block1
[<@ elseif (expression2) @>
   code block2]*
[<@ else @>
   code block3]
<@ endif @>

方括号 ([ ]) 表示可选代码，星号 (*) 表示零个或更多实例。条件表达式是任何有效的 JavaScript 条件表达式，并且可能包含服务器行为参数。

如果希望代码块或部分代码块重复使用多次，请使用以下语法：

<@ loop (@@param1@@,@@param2@@) @>
   code block
<@ endloop @>

“loop”指令采用以逗号分隔的参数数组列表作为参数。重复文本将被复制 n 次，其中 n 是参数数组参数的长度。如果指定多个参数数组参数，则所有数组的长度必须相同。在第 i 次循环计算时，参数数组的第 i 个元素将替换代码块中的相关参数实例。

有关编码的常规信息，请参见编码指导原则。

相关主题

  • 条件式代码块
  • 重复代码块

Web 页中的代码块定位

在使用“服务器行为创建器”创建代码块时（有关更多信息，请参见使用“服务器行为创建器”），必须指定这些代码块在页面的 HTML 代码中的插入位置。此操作可以通过“服务器行为创建器”对话框的“插入代码”和“相对位置”弹出式菜单来完成，这两个菜单可让您选择在文档中插入代码块的位置，然后指定相对于页面中另一个标签的位置。

例如，如果您要将代码块插入到开始 <html> 标签上方，就必须指定代码块相对于相应页面 HTML 代码部分的其它标签、脚本和服务器行为的位置。典型示例包括将一个行为定位到也位于开始 <html> 标签之上的页面代码中的任何记录集查询之前或之后。

从“插入代码”弹出菜单选择定位选项时，“相对位置”弹出菜单中的可用选项会随之更改，提供该页面部分的相关选项。例如，如果在“插入代码”弹出式菜单中选择“<html> 标签上方”，“相对位置”弹出式菜单中的可用定位选项将反映该页面部分的相关选项。

代码块插入选项和每个插入选项可用的相对定位选项如下表所示。

插入代码选项

相对位置选项

<html> 标签上方
  • 文件开头处
  • 紧邻记录集之前
  • 紧邻记录集之后
  • 紧邻 <html> 标签上方
  • 自定义位置

</html> 标签下方
  • 文件末尾之前
  • 记录集结束之前
  • 记录集结束之后
  • </html> 标签之后
  • 自定义位置

相对于特定标签

从“标签”弹出菜单中选择一个标签，然后从标签定位选项中选择。

相对于选定内容

选定内容之前

选定内容之后

替换选定内容

环绕选定内容

如果要指定自定义位置，必须为代码块指定一个高度。如果需要按照特定顺序插入多个代码块，请使用“自定义位置”选项。例如，如果要在打开记录集的代码块后依次插入三个代码块，可以为第一个代码块输入高度 60，为第二个代码块输入 65，为第三个代码块输入 70。

默认情况下，Dreamweaver 为插入到 <html> 标签上方的所有打开记录集的代码块指定高度 50。如果两个或更多代码块的地位相当，则 Dreamweaver 将随机设置代码块间的顺序。

相关主题

  • 关于代码块
  • 定位代码块


服务器行为中的参数

可以在服务器行为代码中包含参数，并在将服务器行为代码插入到页面前，让页面设计者提供必需的参数值。若要让页面设计者提供参数值，请在代码内输入参数标记，如下所示：

@@parameterName@@

下面的 ASP 服务器行为示例包含参数 formParam，这要求插入该行为的人员提供表单对象的名称：

<% Session(“lang_pref”) = Request.Form(“formParam”); %>

若要创建允许用户提供必需值的参数，请执行以下操作：

  1. 将 formParam 字符串包含在参数标记中：
    <% Session(“lang_pref”) = Request.Form(“@@formParam@@”); %>
  2. 创建可以提示设计者提供表单对象名称的对话框。有关更多信息，请参见为自定义服务器行为创建对话框。


条件式代码块

Dreamweaver 使您能够开发包含控制语句的代码块，这些代码块将有条件地执行。“服务器行为创建器”使用 if、elseif 和 else 语句，并可能包含服务器行为参数。这允许您根据服务器行为参数间的 OR 关系值插入替换文本块。if、elseif 和 else 语句如下所示。请注意，方括号 ([ ]) 表示可选代码，星号 (*) 表示零个或更多实例：

<@ if (expression1) @>
   conditional text1
[<@ elseif (expression2) @>
   conditional text2]*
[<@ else @>
   conditional text3]
<@ endif @>

条件表达式可以是任何能够使用 JavaScript eval() 函数进行计算的 JavaScript 表达式，并可能包含用 @@ 进行标记的服务器行为参数。（@@ 是区分参数和 JavaScript 变量与关键字所必需的。）

可以在条件指令中嵌套任意数量的条件或循环指令（请参见重复代码块）。例如，可以指定如果表达式为真，则执行循环。

注意

忽略每个“@>”后的新行。

本节包含以下主题：

  • 有效使用条件表达式
  • 重复代码块

相关主题

  • 关于代码块


有效使用条件表达式

当在 insertText XML 标签中使用 if、else 和 elseif 指令时，将对参与的文本进行预处理，以解析 if 指令并确定将在结果中包含哪一文本。if 和 elseif 指令采用表达式作为参数。条件表达式与 JavaScript 条件表达式情况相同，而且也可以包含服务器行为参数。诸如此类的指令使您可以根据服务器行为参数的值或者相互之间的关系来选择替换代码块。

例如，下面的 JSP 代码来自使用条件代码块的 Dreamweaver 服务器行为：

@@rsName@@.close();
<conditional_code>
@@rsName@@_hasData = @@rsName@@.next();

如果服务器行为使用普通的记录集，则 <conditional_code> 占位符将被替换为：

@@rsName@@ = Statement@@rsName@@.executeQuery();

如果服务器行为使用来自可调用对象的记录集，它将改用下列代码：

@@callableName@@.execute();

@@rsName@@ = @@callableName@@.getResultSet();

如果为可调用对象添加服务器行为，则用户应在服务器行为的“参数”对话框中输入 @@callableName@@ 参数的值。否则，@@callableName@@ 参数将为空。因此，可以将 @@callableName@@ 作为 if 参数来重写以前的插入文本。在此示例中，如果为 @@callableName@@ 参数提供了一个值，则选择第一个条件代码块（包含 getResultSet() 方法）：

@@rsName@@.close();
<@ if (@@callableName@@ != '') @>
@@callableName@@.execute();
@@rsName@@ = @@callableName@@.getResultSet();@ else @>
@@rsName@@ = Statement@@rsName@@.executeQuery();
<@ endif @>
@@rsName@@_hasData = @@rsName@@.next();


重复代码块

创建服务器行为时，可以使用循环结构将某个代码块重复指定的次数。循环语法为：

<@ loop (@@param1@@,@@param2@@,@@param3@@,@@param_n@@) @>
   code block
<@ endloop @>

“loop”指令采用逗号分隔的参数数组列表作为参数。在这种情况下，参数数组参数使用户能够为单个参数提供多个值。重复文本将被复制 n 次，其中 n 是参数数组参数的长度。如果指定多个参数数组参数，则所有数组的长度必须相同。在第 i 次循环计算时，参数数组的第 i 个元素将替换代码块中的相关参数实例。有关更多信息，请参见使用“loop”指令的 _length 和 _index 变量。

当以后创建服务器行为对话框（请参见为自定义服务器行为创建对话框）时，可以向该对话框添加控件，使页面设计者能够创建参数数组。Dreamweaver 包括一个简单的数组控件，可用于创建对话框。这个称作“文本域逗号分隔列表”的控件可以通过“服务器行为创建器”获得。若要创建更为复杂的用户界面元素，请参见 API 文档，以创建包含控件（例如，网格控件）的对话框来创建数组。

“loop”指令无法嵌套，但是条件指令（请参见定位代码块）却可以嵌套在“loop”指令中。

下面的示例显示如何使用这样的重复代码块来创建服务器行为（示例为用于访问预存过程的 ColdFusion 行为）：

<CFSTOREDPROC procedure="AddNewBook"
   datasource=#MM_connection_DSN#
   username=#MM_connection_USERNAME#
   password=#MM_connection_PASSWORD#>
<CFPROCPARAM type="IN" dbvarname="@CategoryId" value="#Form.CategoryID#"
   cfsqltype="CF_SQL_INTEGER">
<CFPROCPARAM type="IN" dbvarname="@ISBN" value="#Form.ISBN#"
   cfsqltype="CF_SQL_VARCHAR">
</CFSTOREDPROC>

在该示例中，CFSTOREDPROC 标签可以包含零个或更多个CFPROCPARAM 标签。但是，如果不支持“loop”指令，则没有办法在插入的 CFSTOREDPROC 标签内包括 CFPROCPARAM 标签。如果在不使用“loop”指令的情况下，将该示例创建为服务器行为，则该示例需要分成两部分：主 CFSTOREDPROC 标签，以及有多个涉及类型的 CFPROCPARAM 标签。

使用“loop”指令可以将相同的过程按如下方式编写：

<CFSTOREDPROC procedure="@@procedure@@"
datasource=#MM_@@conn@@_DSN#
username=#MM_@@conn@@_USERNAME#
password=#MM_@@conn@@_PASSWORD#>
<@ loop (@@paramName@@,@@value@@,@@type@@) @>
   <CFPROCPARAM type="IN"
   dbvarname="@@paramName@@"
   value="@@value@@"
   cfsqltype="@@type@@">
<@ endloop @>
</CFSTOREDPROC>

在上述示例以及条件代码块的情况下，@> 后面的换行符将被忽略。

如果用户在“服务器行为创建器”对话框中输入下列参数值：

procedure = "proc1"
conn = "connection1"
paramName = ["@CategoryId", "@Year", "@ISBN"]
value = ["#Form.CategoryId#", "#Form.Year#", "#Form.ISBN#"]
type = ["CF_SQL_INTEGER", "CF_SQL_INTEGER", "CF_SQL_VARCHAR"]

则服务器行为将下列运行时代码插入页面：

<CFSTOREDPROC procedure="proc1"
datasource=#MM_connection1_DSN#
username=#MM_connection1_USERNAME#
password=#MM_connection1_PASSWORD#>

<CFPROCPARAM type="IN" dbvarname="@CategoryId" value="#Form.CategoryId#"
   cfsqltype="CF_SQL_INTEGER">
<CFPROCPARAM type="IN" dbvarname="@Year" value="#Form.Year#"
   cfsqltype="CF_SQL_INTEGER">
<CFPROCPARAM type="IN" dbvarname="@ISBN" value="#Form.ISBN#"
   cfsqltype="CF_SQL_VARCHAR">
</CFSTOREDPROC>

注意

除非是作为条件指令表达式的一部分，否则，参数数组不能在循环外使用。


使用“loop”指令的 _length 和 _index 变量

“loop”指令包括两个内置变量，可用于嵌入的 if 条件。这两个变量为：_length 和 _index。_length 变量计算“loop”指令处理的数组长度，而 _index 变量计算“loop”指令的当前索引。为了确保这两个变量仅被识别为指令，而不是作为传递到循环中的实际参数，请不要将这两个变量中的任何一个包含在 @@ 对中。

使用内置变量的一个示例是将它们应用于 Page 指令的 import 属性。import 属性要求用逗号分隔的导入源。如果 loop 指令围绕整个 import 属性展开执行，您可能希望只在第一次循环迭代中输出属性名称 import=（这将包含右双引号 (")），而在最后一次循环迭代中不输出逗号。使用内置变量可将此表示如下：

<@loop (@@Import@@)@>
<@ if(_index == 0)@>import="
<@endif@>@@Import@@<@if (_index == _length-1)@>"<@else@>,
<@ endif @>
<@endloop@>


编码指导原则

一般说来，服务器行为代码应当紧凑、可靠。Web 应用程序开发人员对添加到他们页面中的代码非常敏感。请遵照广泛接受的文档类型语言（ColdFusion、ASP.NET、JavaScript、VBScript、PHP、Visual Basic 或 Java）的编码惯例。在编写注释时，请考虑可能需要理解代码的不同技术用户，如 Web 和交互程序的设计者或者其他 Web 应用程序开发人员。请包含正确描述代码目的的注释以及有关将其包含在页面内的任何特殊说明。

在创建服务器行为时，请牢记下列编码指导原则：

错误检查是一项重要的要求。服务器行为代码应当妥善处理错误情况。尝试预见所有可能性。例如，如果参数请求失败怎么办？如果查询没有返回记录怎么办？

唯一名称帮助确保代码清楚标识并且避免与现有代码的名称冲突。例如，如果页面包含一个名为 hideLayer() 的函数和名为 ERROR_STRING 的全局变量，而服务器行为插入的代码也使用了这两个名称，则该服务器行为可能与现有代码冲突。

代码前缀允许您在页面中标识您自己的运行时函数和全局变量。约定之一就是使用首字母大写。请不要使用 MM_ 前缀，因为它是仅为 Macromedia 使用而保留的。Macromedia 会在所有函数和全局变量之前添加前缀 MM_，以避免与您编写的代码冲突。

var MM_ERROR_STRING = "...";
function MM_hideLayer() {

避免相似的代码块以便您编写的代码不与其它代码块中的代码太相似。如果某代码块看起来与页面上的另一个代码块非常类似，“服务器行为”面板可能会错误地将第一个代码块标识为第二个代码块的实例（或反之）。一个简单的解决方法是给代码块添加注释，使它更具有唯一性。

相关主题

  • 关于自定义服务器行为
  • 服务器行为


测试服务器行为

Macromedia Exchange 建议您对创建的每个服务器行为执行下列测试：

  • 从“服务器行为”面板应用行为。如果该行为有对话框，请在每个域中输入有效数据，然后单击“确定”。验证在应用该行为时没有错误发生。验证该服务器行为的运行时代码是否出现在代码检查器中。
  • 再次应用该服务器行为，并在每个对话框域中输入无效数据。尝试下列操作：将域保留为空白，使用大数或负数，使用无效字符（例如 /、?、:、* 等等），以及在数字域使用字母。可以编写格式验证例程来处理无效数据（验证例程涉及手工编码，这超出了本书的范围）。

在将服务器行为成功地应用于页面后，请验证下列内容：

  • 检查“服务器行为”面板，确保该服务器行为名称出现在添加到页面的行为的列表中。
  • 验证服务器端脚本图标是否出现在页面上（如果适用的话）。一般服务器端脚本图标是金色的盾牌。若要查看该图标，请启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）。
  • 在“代码”视图（“查看”>“代码”）中，验证没有生成任何无效代码。

另外，如果服务器行为将代码插入与数据库建立连接的文档，请创建一个测试数据库来测试插入到文档中的代码。通过定义查询来验证连接，这些查询应生成不同的数据集以及不同大小的数据集。

最后，将页面上传到服务器并在浏览器中打开。查看页面的 HTML 源代码并验证服务器端脚本未生成任何无效的 HTML。


安装第三方服务器行为

您可以从 Macromedia Exchange Web 站点下载并安装由独立开发人员创建的服务器行为。

若要访问 Macromedia Exchange，请执行以下操作：

  1. 在 Dreamweaver 选择“帮助”>“Dreamweaver Exchange”。

    浏览器打开 Macromedia Exchange for Dreamweaver Web 页。

  2. 使用您的 Macromedia ID 登录该 Exchange，或者如果您尚未创建自己的 Macromedia
    Exchange ID，请按照说明开设一个 Macromedia 帐户。

    注意

    您也可以单击加号 (+) 按钮并选择“获取更多服务器行为”，从“服务器行为”面板（“窗口”>“行为”）访问 Macromedia Exchange。

若要在 Dreamweaver 中安装服务器行为或其它功能扩展，请执行以下操作：

  1. 通过选择“命令”>“管理扩展功能”启动功能扩展管理器。
  2. 在功能扩展管理器中，选择“文件”>“安装软件包”。

    有关更多信息，请参见“使用扩展管理器”。

相关主题

  • 关于自定义服务器行为
  • 服务器行为


使用“服务器行为创建器”

“服务器行为创建器”用于添加由服务器行为插入到页中的代码块。

若要编写服务器行为代码块，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后从弹出菜单中选择“新建服务器行为”。

    出现“新建服务器行为”对话框。

  2. 从“文档类型”弹出菜单中，选择正在为其开发服务器行为的文档类型。
  3. 在“名称”文本框中，输入该服务器行为的名称。
  4. 若要复制现有服务器行为以添加到正在创建的行为，请选择“复制现有服务器行为”复选框。

    当选中此复选框时，可用服务器行为列表将显示在“要复制的行为”弹出菜单中。

  5. 单击“确定”。

    显示“服务器行为创建器”对话框。

  6. 若要添加新的代码块，请单击加号 (+) 按钮。

    显示“创建新代码块”对话框。

  7. 输入想要创建的代码块名称并单击“确定”。

    在对话框中输入的名称显示在“服务器行为创建器”中，相应的脚本标签显示在“代码块”文本框中。

  8. 在“代码块”文本框中，输入实现服务器行为所必需的代码。

    在“代码块”文本框中输入代码时：

    • 仅可为每个命名的代码块（例如，myBehavior_block1、myBehavior_block2、myBehavior_blockn 等）插入一个标签或代码块。如果需要输入多个标签或代码块，则必须使用“服务器行为创建器”为每个标签或代码块创建一个单独的代码块。
    • 若要在代码块中包括运行时参数，请执行下列操作：
    1. 将插入点放在代码块中希望插入参数的位置。
    2. 单击“在代码块中插入参数”按钮。

      出现“在代码块中插入参数”对话框。

    3. 在“参数名称”文本框中输入参数名称。
    4. 单击“确定”。

      参数名称即插入到了代码块中。

    • 为要创建的每个新代码块重复步骤 6 到 8。
  9. 在“参数名称”弹出菜单中输入参数的名称，然后单击“确定”。

    该参数即插入到了代码块中定义参数前放插入点的位置。

  10. 从“插入代码”弹出菜单中选择一个选项，指定嵌入代码块的位置。

    有关更多信息，请参见定位代码块。

  11. 可以使用“高级”选项面板来指定有关所创建服务器的其它信息。
  12. 单击“高级”按钮，显示更多选项。

  13. 若要创建更多的代码块，请根据需要重复步骤 7 至 13。
  14. 如果服务器行为要求向其提供参数，则需要创建一个对话框来接受应用行为人所提供的参数。

    若要创建接受用户输入参数的对话框，请参见为自定义服务器行为创建对话框。

  15. 在完成所创建的服务器行为要求的上述步骤之后，单击“确定”。

    创建服务器行为后，该行为将在“服务器行为”面板中列出。测试服务器行为并确保其正确运行。

相关主题

  • 定位代码块
  • 重复代码块
  • 编码指导原则
  • 定位代码块
  • 在服务器行为中使用参数


在服务器行为中使用参数

可以在服务器行为代码中包含参数（有关更多信息，请参见服务器行为中的参数），并在将服务器行为代码插入到页面前，让页面设计者提供必需的参数值。若要让页面设计者提供参数值，请在代码内输入参数标记，如下所示：

@@parameterName@@

下面的 ASP 服务器行为示例包含参数 formParam，该参数要求插入该行为的人员提供表单对象的名称：

<% Session(“lang_pref”) = Request.Form(“formParam”); %>

若要创建允许用户提供必需值的参数，请执行以下操作：

  1. 将 formParam 字符串包含在参数标记中：
    <% Session(“lang_pref”) = Request.Form(“@@formParam@@”); %>
  2. 创建可以提示设计者提供表单对象名称的对话框。

    有关更多信息，请参见为自定义服务器行为创建对话框。


定位代码块

在使用“服务器行为创建器”创建代码块时（有关更多信息，请参见使用“服务器行为创建器”），必须指定这些代码块在页面的 HTML 代码中的插入位置。“插入代码”和“相对位置”弹出菜单可让您选择在文档中插入代码块的位置，然后指定相对于页面中另一标签的位置。

若要了解有关代码块定位选项和这些选项对自定义服务器行为的影响的更多信息，请参见 Web 页中的代码块定位。

若要定位代码块，请执行以下操作（一般性说明）：

  1. 使用“服务器行为创建器”，根据使用“服务器行为创建器”一节中的说明编写代码块。
  2. 在“服务器行为创建器”对话框中，从“插入代码”弹出菜单中选择一个要放置插入的代码块的位置。
  3. 在“服务器行为创建器”对话框中，选择一个相对于您在“插入代码”弹出菜单中所选位置的位置。
  4. 如果已经完成代码块的创作，请单击“确定”。

    该服务器行为即列在了“服务器行为”面板（“窗口”>“服务器行为”）中，并可通过单击加号 (+) 按钮查看。

  5. 测试服务器行为并确保其正确运行。

    有关更多信息，请参见测试服务器行为。

若要相对于页面上的另一个标签定位代码块，请执行以下操作：

  1. 在“插入代码”弹出菜单中，请选择“相对于特定标签”。
  2. 在“标签”文本框中，输入该标签或从弹出菜单中进行选择。

    如果输入标签，请不要包括尖括号 (< >)。

  3. 在“相对位置”弹出菜单中选择一个选项，指定相对于该标签的某个位置。

    可以将代码块插入到恰好在开始标签之前，或者恰好在结束标签之后。也可以用代码替换该标签，将代码作为标签属性的值插入（出现一个让您选择属性的对话框），或者将代码插入开始标签中。

若要相对于页面设计者的选定标签定位代码块，请执行以下操作：

  1. 在“插入代码”弹出菜单中，选择“相对于选定内容”。
  2. 在“相对位置”弹出菜单中选择一个选项，指定相对于选定内容的某个位置。

    可以将代码块插入到恰好在选定内容之前或之后。也可以用代码块替换选定内容，或者围绕选定内容排列代码块。

    若要围绕选定内容排列代码块，则选定内容必须包含开始和结束标签，且其中不包含任何内容，如下所示：

    <CFIF Day=”Monday”></CFIF>

    代码块的开始标签部分被插入到选定内容的开始标签之前，而代码块的结束标签部分被插入到选定内容的结束标签之后。

相关主题

  • 关于自定义服务器行为
  • Web 页中的代码块定位
  • 使用“服务器行为创建器”


为自定义服务器行为创建对话框

服务器行为经常要求页面设计者提供参数值。该值必须在将服务器行为代码插入到页面之前插入。为此，可以创建一个对话框来提示实现服务器行为的人员输入参数值。

通过定义代码中由设计者提供的参数，可以创建该对话框。在定义所有参数之后，可以生成一个服务器行为对话框。

注意

如果指定代码应当相对于页面设计者选择的特定标签进行插入（即，在“插入代码”弹出菜单中选择“相对于特定标签”），那么将在不需干预的情况下，向代码块添加一个参数。该参数向行为对话框添加一个标签菜单，供页面设计者选择标签。

若要在服务器行为代码中创建参数，请执行以下操作：

  • 在代码中希望插入所提供参数值的位置输入参数标记。参数语法如下：
    @@parameterName@@

例如，如果服务器行为包含以下代码块：

<% Session(“lang_pref”) = Request.Form(“Form_Object_Name”); %>

若要让页面设计者提供 Form_Object_Name 的值，请在参数标记 (@@) 中包含该字符串：

<% Session(“lang_pref”) = Request.Form(“@@Form_Object_Name@@”); %>

也可以高亮显示该字符串，然后单击“在代码块中插入参数”按钮。输入参数名称，然后单击“确定”。Dreamweaver 用包含在参数标记内的指定参数名称替换高亮显示字符串的每个实例。

Dreamweaver 使用参数标记中包含的字符串来标记所生成对话框中的控件（请参见下面的过程）。在前面的示例中，Dreamweaver 创建带有下面的标签的对话框：

注意

服务器行为代码中的参数名称不能有任何空格。因此，对话框标签不能有任何空格。如果要在标签中包含空格，可以编辑生成的 HTML 文件。

若要为服务器行为创建对话框，请执行以下操作：

  1. 在“服务器行为创建器”中，单击“下一步”。

    将出现一个对话框，该对话框列出在代码中定义的所有由设计者提供的参数。

  2. （可选）可以通过选择参数并单击向上或向下箭头来更改对话框控件的显示顺序。
  3. （可选）如果愿意，可以通过选择参数并在“显示为”列中选择另一个控件来更改该参数的控件。
  4. 单击“确定”。

    对于您定义的每个由设计者提供的参数，Dreamweaver 都生成一个具有带标签控件的对话框。

若要查看此对话框，请执行以下操作：

  • 单击“服务器行为”面板（“窗口”>“服务器行为”）中的加号 (+) 按钮，然后从弹出菜单中选择该服务器行为。

若要编辑您创建的服务器行为的对话框，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后从弹出菜单中选择“编辑服务器行为”。
  2. 从列表中选择该服务器行为，并单击“打开”。

    将出现包含该服务器行为的“服务器行为创建器”。

  3. 单击“下一步”。

    将出现一个对话框，该对话框列出在代码中定义的所有由设计者提供的参数。

  4. （可选）可以通过选择参数并单击向上或向下箭头来更改对话框控件的显示顺序。
  5. （可选）如果愿意，可以通过选择参数并在“显示为”列中选择另一个控件来更改该参数的控件。
  6. 单击“确定”。


编辑和修改服务器行为

您可以编辑用“服务器行为创建器”创建的任何服务器行为，其中包括从 Macromedia Exchange Web 站点下载的服务器行为以及由其他第三方开发人员创作的服务器行为。

如果您将一个服务器行为应用于页面，然后在 Dreamweaver 中编辑该行为，则原有行为的实例将不再出现在“服务器行为”面板中。“服务器行为”面板将搜寻页面，查找与已知服务器行为代码相匹配的代码。如果面板已知的服务器行为代码发生更改，则面板将不再识别页面上该行为的以前版本。

如果希望原有的和新的行为都出现在面板中，请执行以下操作：

  • 单击“服务器行为”面板（“窗口”>“服务器行为”）中的加号 (+) 按钮，选择“新建服务器行为”，并创建原有服务器行为的副本。

若要编辑用“服务器行为创建器”创建的服务器行为的代码，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后从弹出菜单中选择“编辑服务器行为”。

    “编辑服务器行为”对话框出现，显示当前服务器技术的所有行为。

  2. 选择该服务器行为并单击“编辑”。

    “服务器行为创建器”对话框出现。

  3. 选择适当的代码块并修改要插入到页面中的代码。
  4. （可选）您可以更改参数标记，或者向代码添加参数标记。

    有关说明，请参见为自定义服务器行为创建对话框。

  5. （可选）如果愿意，可以在“插入代码”弹出式菜单中选择另一个选项，更改代码块在页面 HTML 代码中的插入位置。

    有关说明，请参见定位代码块。

  6. 如果已修改的代码不包含任何由设计者提供的参数，请单击“确定”。

    Dreamweaver 将重新生成不包含对话框的服务器行为。新的服务器行为出现在“服务器行为”面板的加号 (+) 弹出菜单中。

  7. 如果已修改的代码的确包含由设计者提供的参数，请单击“下一步”。

    Dreamweaver 将询问您是否要创建一个新对话框来改写原有的对话框。进行更改并单击“确定”。

Dreamweaver 将所有更改保存在服务器行为的 EDML 文件中。


参考资料

本节提供在本章中介绍的下列对话框的有关信息：

  • 设置“新建服务器行为”对话框选项
  • 设置“服务器行为创建器”对话框选项
  • 设置“在代码块中插入参数”对话框选项
  • 设置“创建新代码块”对话框选项
  • 设置“生成行为对话框”对话框选项
  • 设置“编辑服务器行为”对话框选项


设置“新建服务器行为”对话框选项

该对话框使您能够选择在为其开发服务器行为的文档类型，并命名此新的服务器行为。

若要完成“新建服务器行为”对话框，请执行以下操作：

  1. 从弹出菜单中选择文档类型。

  1. 为该服务器行为输入名称。
  2. 如果希望新的服务器基于随 Dreamweaver 提供的某个服务器行为，请选择“复制现有服务器行为”选项，并在“要复制的行为”弹出菜单中选择 Dreamweaver 服务器行为。
  3. 单击“确定”。

    “新建服务器行为创建器”将出现。

相关主题

  • 服务器行为
  • 使用“服务器行为创建器”


设置“服务器行为创建器”对话框选项

若要完成“服务器行为创建器”对话框，请执行以下操作：

  1. 单击加号 (+) 按钮，输入代码块名称并单击“确定”，以开始一个代码块。

    命名代码块的约定之一如下所示：

    行为的名称_代码块的名称

    这里提供了一个示例：

    MoveToRecord_Init
  2. 在“代码块”文本区域，输入将要插入到页面中的运行时代码。

    运行时代码必须是单个标签块或者脚本块。如果需要插入多个标签或脚本块，请将它们拆分成单独的代码块。也可以从其它页面复制和粘贴代码。

    有关更多信息，请参见以下章节：

    • 在服务器行为中使用参数
    • 定位代码块
    • 重复代码块
    • 编码指导原则
  3. 通过使用“插入代码”弹出式菜单，指定代码块在页面的 HTML 源代码中的插入位置。

    相对于页面中的标签或者页面设计者选定的标签插入代码块。有关更多信息，请参见定位代码块。

  4. 若要指定更高级的设置，请单击“高级”。

    一旦指定每个代码块的源代码和插入位置，服务器行为就被完全定义了。在大多数情况下，不必再指定其它任何信息。

    如果您是一位高级用户，您可能希望通过单击“服务器行为创建器”中的“高级”按钮来修改其它参数。此时生成器将展开，显示几个新选项。

    标识符指定代码块是否应被视为标识符。

    默认情况下，所有代码块都是标识符。如果 Dreamweaver 在文档的任何地方发现标识符代码块，则将该行为列在“服务器行为”面板中。“标识符”复选框用于指定代码块是否应视为标识符。

    服务器行为代码块中至少有一个必须为标识符。如果为下列情况之一，则代码块不应为标识符：同一个代码块被其它服务器行为使用；或者代码块非常简单，可能会在页面上自然发生。

    服务器行为标题指定“服务器行为”面板中的行为的标题。

    当页面设计者单击“服务器行为”面板上的加号 (+) 按钮时，新的服务器行为标题将出现在弹出式菜单中。当设计者将服务器行为的实例应用于文档时，该行为将出现在“服务器行为”面板中的已应用行为列表中。“服务器行为标题”文本框用于指定加号 (+) 弹出菜单和已应用行为列表的内容。

    该对话框中的初始值为“新建服务器行为”对话框中提供的名称。定义参数后，该名称自动更新，以便参数出现在服务器行为名称后面的括号中。

    设置会话变量 (@@Name@@, @@Value@@)

    如果用户接受默认值，括号前面的所有内容（例如，“设置会话变量”）都将出现在加号 (+) 弹出式菜单中。名称和参数将出现在已应用行为列表中，例如，设置会话变量 ("abcd", "5")。

    选定代码块指定当用户在“服务器行为”面板中选择行为时将选定的代码块。

    在应用服务器行为时，行为中的一个代码块被指定为“要选择的代码块”。如果应用服务器行为，然后在“服务器行为”面板中选择该行为，Dreamweaver 将在“文档”窗口中自动选择指定的块。默认情况下，Dreamweaver 将选择不在 html 标签上方的第一个代码块。如果所有代码块都在 html 标签上方，则 Dreamweaver 将选择第一个代码块。高级用户可以指定哪个代码块是选定的代码块。

  5. 为服务器行为中的每个代码块重复步骤 1 至 4。
  6. 如果两个或多个代码块的插入位置相同，可以通过单击向上或向下箭头来更改它们之间的相对位置。
  7. 执行下列操作之一：
    • 如果您在代码中未定义任何由设计者提供的参数，请单击“确定”。

      Dreamweaver 创建不包含对话框的服务器行为。新的服务器行为将出现在“服务器行为”面板的加号 (+) 菜单中。

    • 如果在代码中定义了由设计者提供的参数，Dreamweaver 将提示您在创建该行为之前配置服务器行为的对话框。

      有关更多信息，请参见为自定义服务器行为创建对话框。

相关主题

  • 服务器行为
  • 使用“服务器行为创建器”
  • 在服务器行为中使用参数
  • 在服务器行为中使用参数
  • 定位代码块
  • 重复代码块
  • 编码指导原则
  • 定位代码块
  • 为自定义服务器行为创建对话框


设置“在代码块中插入参数”对话框选项

此对话框可让您替换包含参数标记的代码块中选定字符串的所有实例。

若要替换代码块中的某字符串的所有实例，请执行以下操作：

  1. 输入参数名称。

    例如：Session

  2. 单击“确定”。

Dreamweaver 用参数标记（例如，@@Session@@）替换代码块中选定字符串的所有实例。

相关主题

  • 在服务器行为中使用参数
  • 为自定义服务器行为创建对话框


设置“创建新代码块”对话框选项

该对话框用于在“服务器行为创建器”中命名和创建代码块。

若要使用“服务器行为创建器”命名和创建代码块，请执行以下操作：

  • 在文本框中输入一个名称并单击“确定”。

相关主题

  • 使用“服务器行为创建器”


设置“生成行为对话框”对话框选项

该对话框为要求用户输入的自定义服务器行为生成一个对话框。也用于编辑这样的对话框。

当该对话框打开时，将列出代码中定义的所有应提供的参数。有关更多信息，请参见为自定义服务器行为创建对话框。

若要创建用于用户输入的对话框，请执行以下操作：

  1. 若要更改对话框控件的显示顺序，请选定参数，然后单击向上或向下箭头。
  2. 若要更改参数控件，请选定该参数，然后在“显示为”列中选择另一个控件。
  3. 单击“确定”。

Dreamweaver 为自定义服务器行为生成一个对话框，或者更新现有对话框。

相关主题

  • 为自定义服务器行为创建对话框
  • 在服务器行为中使用参数
  • 使用“服务器行为创建器”


设置“编辑服务器行为”对话框选项

该对话框使您能够选择要编辑的服务器行为。

若要编辑服务器行为，请执行以下操作：

  1. 选择一种文档类型和服务器行为。
  2. 单击“编辑”。

    “编辑服务器行为”对话框出现，该对话框使您能够编辑服务器行为。有关更多信息，请参见编辑和修改服务器行为。

相关主题

  • 编辑和修改服务器行为
  • 使用“服务器行为创建器”
  • 定位代码块


创建表单

您可以使用 Macromedia Dreamweaver 8 创建带有文本域、密码域、单选按钮、复选框、弹出式菜单、可单击按钮以及其它表单对象的表单。Dreamweaver 还可以编写用于验证访问者所提供的信息的代码。例如，可以检查用户输入的电子邮件地址是否包含“@”符号，或者某个必须填写的文本域是否包含了一个值。

本章包含下列章节：

关于表单

创建 HTML 表单

插入 HTML 表单对象

插入动态 HTML 表单对象

验证 HTML 表单数据

将 JavaScript 行为附加到 HTML 表单对象

将自定义脚本附加到 HTML 表单按钮

创建可用的 HTML 表单

相关主题

  • 建立 ColdFusion MX 7 表单
  • 生成 ASP.NET 表单


关于表单

表单的作用是从访问您的 Web 站点的用户那里获得信息。访问者可以使用诸如文本域、列表框、复选框以及单选按钮之类的表单对象输入信息，然后单击某个按钮提交这些信息。

本节包含以下概念性主题：

  • 表单的客户端角色
  • 表单对象
  • 动态表单对象


表单的客户端角色

表单支持客户端-服务器关系中的客户端。当访问者在 Web 浏览器中显示的表单中输入信息，然后单击提交按钮时，这些信息将被发送到服务器，服务器端脚本或应用程序在该处对这些信息进行处理。用于处理表单数据的常用服务器端技术包括 Macromedia ColdFusion、Microsoft Active Server Pages (ASP) 和 PHP。服务器进行响应时会将被请求信息发送回用户（或客户端），或基于该表单内容执行一些操作。

注意

您也可以将表单数据直接发送给某个电子邮件收件人。


表单对象

在 Dreamweaver 中，表单输入类型称为表单对象。表单对象是允许用户输入数据的机制。您可以在表单中添加以下表单对象：

文本域接受任何类型的字母数字文本输入内容。文本可以单行或多行显示，也可以以密码域的方式显示，在这种情况下，输入文本将被替换为星号或项目符号，以避免旁观者看到这些文本。

注意

使用密码域发送到服务器的密码及其它信息并未进行加密处理。所传输的数据可能会以字母数字文本形式被截获并被读取。因此，您始终应对要确保安全的数据进行加密。

隐藏域存储用户输入的信息，如姓名、电子邮件地址或偏爱的查看方式，并在该用户下次访问此站点时使用这些数据。

按钮在单击时执行操作。通常，这些操作包括提交或重置表单。您可以为按钮添加自定义名称或标签，或使用预定义的“提交”或“重置”标签之一。

复选框允许在一组选项中选择多个选项。用户可以选择任意多个适用的选项。下面的示例通过显示三个选中的复选框项来说明这一点：冲浪、山地自行车和漂流。

单选按钮代表互相排斥的选择。在某单选按钮组（由两个或多个共享同一名称的按钮组成）中选择一个按钮，就会取消选择该组中的所有其它按钮。在下面的示例中，漂流 是当前选择的选项。如果用户单击了冲浪，那么漂流 按钮将被自动清除。

“列表”菜单在一个滚动列表中显示选项值，用户可以从该滚动列表中选择多个选项。“菜单”选项在一个菜单中显示选项值，用户只能从中选择单个选项。

注意

HTML 表单上弹出菜单与图形弹出菜单不同。有关创建、编辑、显示和隐藏图形弹出式菜单的信息，请参见显示弹出菜单。

跳转菜单是可导航的列表或弹出菜单，它使您可以插入一种菜单，这种菜单中的每个选项都链接到某个文档或文件。

文件域使用户可以浏览到其计算机上的某个文件并将该文件作为表单数据上传。

图像域使您可以在表单中插入一个图像。图像域可用于生成图形化按钮，例如“提交”或“重置”按钮。

相关主题

  • 动态表单对象
  • 创建 HTML 表单
  • 插入 HTML 表单对象


动态表单对象

作为一种表单对象，动态表单对象的初始状态由服务器在页面被从服务器中请求时确定，而不是由表单设计者在设计时确定。例如，当用户请求的 PHP 页上包含带有菜单的表单时，该页中的 PHP 脚本会自动使用存储在数据库中的值填充该菜单。然后，服务器将完成后的页面发送到该用户的浏览器中。

使表单对象成为动态对象可以简化站点的维护工作。例如，许多站点使用菜单为用户提供一组选项。如果该菜单是动态的，您可以在某一位置（即存储菜单项的数据库表）集中添加、删除或更改菜单项，从而更新该站点上同一菜单的所有实例。

除菜单之外，还有其它类型的动态表单对象。还可以创建和使用动态单选按钮、复选框、文本域和图像域。

相关主题

  • 插入 HTML 表单对象
  • 插入动态 HTML 表单对象


创建 HTML 表单

本节介绍如何在 Dreamweaver 中创建 HTML 表单。

您也可以使用 Dreamweaver 创建 ASP.NET Web 表单。有关更多信息，请参见生成 ASP.NET 表单。

若要创建 HTML 表单，请执行以下操作：

  1. 打开一个页面，将插入点放在希望表单出现的位置。
  2. 选择“插入”>“表单”，或选择“插入”栏上的“表单”类别，然后单击“表单”图标。

    Dreamweaver 将插入一个空的表单。当页面处于“设计”视图中时，用红色的虚轮廓线指示表单。如果没有看到此轮廓线，请检查是否选中了“查看”>“可视化助理”>“不可见元素”。

  3. 指定将处理表单数据的页面或脚本。

    在“文档”窗口中，单击表单轮廓以将其选定。在属性查看器中（“窗口”>“属性”）的“动作”文本框中键入路径，或者单击文件夹图标浏览到适当的页面或脚本。

  4. 指定将表单数据传输到服务器所使用的方法。

    在属性检查器中，在“方法”弹出菜单中选择以下选项之一：

    默认方法使用浏览器的默认设置将表单数据发送到服务器。通常，默认方法为 GET 方法。

    GET 方法将值附加到请求该页面的 URL 中。

    POST 方法将在 HTTP 请求中嵌入表单数据。

    有关更多信息，请参见设置表单属性。

  5. 插入表单对象。

    将插入点放置在希望表单对象在表单中出现的位置，然后在“插入”>“表单”菜单中，或者在“插入”栏的“表单”类别中选择对象。

    有关更多信息，请参见插入 HTML 表单对象或插入动态 HTML 表单对象。

    如果愿意，可在将表单对象插入页面后设置其属性。有关更多信息，请选择该表单对象，然后单击属性检查器中的“帮助”图标。

  6. 根据需要，调整表单的布局。

    可以使用换行符、段落标记、预格式化的文本或表来设置表单的格式。不能将表单插入另一个表单中，即标签不能交迭，但是可以在一个页面中包含多个表单。

    设计表单时，请记住用描述性文本标记表单字段，以使用户知道他们回复的内容。例如，“键入您的名字”请求名字信息。

    使用表格为表单对象和域标签提供结构。当在表单中使用表格时，请确保所有的 table 标签都位于两个 form 标签之间。

相关主题

  • 验证 HTML 表单数据
  • 将 JavaScript 行为附加到 HTML 表单对象
  • 将自定义脚本附加到 HTML 表单按钮
  • 创建可用的 HTML 表单


插入 HTML 表单对象

您可以使用 Dreamweaver 快速将 HTML 表单对象插入到您的表单中。

如果您正在 ASP.NET Web 应用程序上进行工作，则可以使用 Dreamweaver 快速插入 ASP.NET 表单控件。有关更多信息，请参见将 ASP.NET 表单控件添加到页面。

您可以先创建一个空的 HTML 表单（“插入”>“表单”>“表单”），然后在该表单中插入表单对象。有关更多信息，请参见创建 HTML 表单。如果您没有创建空的表单而试图插入一个表单对象，Dreamweaver 将会询问您是否要创建一个空表单。

本节包含以下主题：

  • 插入 HTML 文本域
  • 插入 HTML 复选框
  • 插入 HTML 单选按钮
  • 插入 HTML 表单菜单
  • 插入标准按钮
  • 插入图像按钮
  • 插入隐藏域
  • 插入文件上传域


插入 HTML 文本域

您可以创建一个包含单行或多行的文本域。您也可以创建一个隐藏用户输入的文本的密码文本域。

若要插入一个文本域，请执行以下操作：

  1. 将插入点放在表单轮廓内。
  2. 选择“插入”>“表单”>“文本域”。

    一个文本域随即出现在文档中。

  3. 在属性检查器中，根据需要设置文本域的属性。

    有关更多信息，请参见设置文本域的属性。

  4. 若要在页面中为文本域添加标签，请在该文本域旁边单击，然后键入标签文字。

相关主题

  • 验证 HTML 表单数据
  • 在 HTML 文本域中显示动态内容
  • 表单对象


插入 HTML 复选框

如果您打算让用户可以从一组选项中选择多个选项，则可以使用 HTML 复选框。

注意

在要求用户只能从一组选项中选择一个选项时，请使用单选按钮。有关更多信息，请参见插入 HTML 单选按钮。

若要插入复选框，请执行以下操作：

  1. 将插入点放在表单轮廓内。
  2. 选择“插入”>“表单”>“复选框”。

    一个复选框随即出现在文档中。

  3. 在属性检查器中，根据需要设置复选框的属性。

    有关更多信息，请参见设置复选框的属性。

  4. 若要为复选框添加标签，请在页面上该复选框的旁边单击，然后键入标签文字。

相关主题

  • 动态预先选择 HTML 复选框


插入 HTML 单选按钮

在要求用户只能从一组选项中选择一个选项时，请使用 HTML 单选按钮。单选按钮通常成组地使用。在同一个组中的所有单选按钮必须具有相同的名称。

注意

如果您打算让用户可以选择多个选项，则应使用复选框。有关更多信息，请参见插入 HTML 复选框。

若要插入一组单选按钮，请执行以下操作：

  1. 将插入点放在表单轮廓内。
  2. 选择“插入”>“表单”>“单选按钮组”。

    出现“单选按钮组”对话框。

  3. 完成“单选按钮组”对话框，然后单击“确定”。

    有关说明，请参见设置“单选按钮组”对话框的选项。

Dreamweaver 在 HTML 表单内插入单选按钮组。如果尚未在页面上插入表单，Dreamweaver 会为您插入一个表单。如果愿意，可以更改组的布局。还可以使用属性检查器或直接在“代码”视图中编辑单选按钮。

若要逐个插入单选按钮，请执行以下操作：

  1. 将插入点放在表单轮廓内。
  2. 通过选择“插入”>“表单”>“单选按钮”来插入单选按钮。

    随即在文档中出现一个单选按钮。

  3. 在属性检查器中，根据需要设置单选按钮的属性。

    有关更多信息，请参见设置单选按钮的属性。

  4. 若要为单选按钮添加标签，请在页面上该单选按钮的旁边单击，然后键入标签文字。

相关主题

  • 动态预先选择 HTML 单选按钮


插入 HTML 表单菜单

通过 HTML 表单菜单，访问者可以从一个列表中选择一个或多个项目。当您的空间有限，但需要显示许多菜单项时，菜单非常有用。如果您想要对返回给服务器的值予以控制，也可以使用选择框。菜单与文本域不同，在文本域中用户可以随心所欲键入任何信息，甚至包括无效的数据，对于菜单而言，您可以具体设置某个菜单返回的确切值。

您可以在表单中插入两种类型的菜单：一种菜单是用户单击时下拉的菜单；另一种菜单则显示一个列有项目的可滚动列表，用户可从该列表中选择项目。后者称为列表菜单。

若要插入菜单，请执行以下操作：

  1. 将插入点放在表单轮廓内。
  2. 选择“插入”>“表单”>“列表/菜单”。

    一个菜单随即出现在文档中。

  3. 在属性检查器中，根据需要设置菜单的属性。

    有关更多信息，请参见设置菜单的属性。

相关主题

  • 创建动态 HTML 表单菜单
  • 使现有 HTML 表单菜单成为动态对象


插入标准按钮

按钮控制表单的操作。使用按钮可将表单数据提交到服务器，或者重置该表单。标准表单按钮通常带有“提交”、“重置”或“发送”标签。您还可以分配其他已经在脚本中定义的处理任务。例如，按钮可以根据指定的值计算所选商品的总价。

若要创建一个按钮，请执行以下操作：

  1. 将插入点放在表单轮廓内。
  2. 选择“插入”>“表单”>“按钮”。

    一个按钮随即出现在文档中。

  3. 在属性检查器中，根据需要设置该按钮的属性。

    有关更多信息，请参见设置按钮的属性。

相关主题

  • 插入图像按钮


插入图像按钮

可以使用图像作为按钮图标。如果使用图像来执行任务而不是提交数据，则需要将某种行为附加到表单对象。

若要创建一个图像按钮，请执行以下操作：

  1. 在文档中，将插入点放在表单轮廓内。
  2. 选择“插入”>“表单”>“图像域”。

    即会出现“图像源文件”对话框。

  3. 在“选择图像源”对话框中为该按钮选择图像，然后单击“确定”。

    一个图像域随即出现在表单中。

  4. 在属性检查器中，根据需要设置图像域的属性。

    若要创建一个提交按钮，请在属性检查器的“图像域”文本框中输入“提交”。

    有关更多信息，请参见设置图像域的属性。

  5. 若要将某个 JavaScript 行为附加到该按钮，选择该图像，然后在“行为”面板（“窗口”>“行为”）中选择行为。

    有关更多信息，请参见将 JavaScript 行为附加到 HTML 表单对象和将自定义脚本附加到 HTML 表单按钮。

相关主题

  • 插入标准按钮


插入隐藏域

您可以使用隐藏域存储并提交非用户输入信息。该信息对用户而言是隐藏的。

若要创建隐藏域，请执行以下操作：

  1. 在“设计”视图中，将插入点放在表单轮廓内。
  2. 选择“插入”>“表单”>“隐藏域”。

    随即在文档中出现一个标记。如果您未看到标记，请选择“查看”>“可视化助理”>“不可见元素”来查看标记。

  3. 在属性检查器的“隐藏域”文本框中，为该域键入一个唯一名称。
  4. 在“值”文本框中，键入要为该域指定的值。


插入文件上传域

您可以创建文件上传域，文件上传域使用户可以选择其计算机上的文件，如字处理文档或图形文件，并将该文件上传到服务器。文件域的外观与其它文本域类似，只是文件域还包含一个“浏览”按钮。用户可以手动输入要上传的文件的路径，也可以使用“浏览”按钮定位并选择该文件。

您需要具有服务器端脚本或能够处理文件提交的页面，才可以使用文件上传域。查看用来处理表单数据的服务器技术文档。例如，如果使用 PHP，请参见《PHP 指南》中的“处理文件上传”，网址为：http://us2.php.net/manual/en/features.file-upload.php。

文件域要求使用 POST 方法将文件从浏览器传输到服务器。该文件被发送到表单的“动作”文本框中所指定的地址。

注意

在使用文件域之前，请与服务器管理员联系，确认允许使用匿名文件上传。

若要在表单中创建文件域，请执行以下操作：

  1. 在页面中插入表单（“插入”>“表单”）。
  2. 选择表单以显示其属性检查器。
  3. 将表单“方法”设置为 POST。
  4. 从“MIME 类型”弹出式菜单中，选择 multipart/form-data。
  5. 在“动作”文本框中，请指定服务器端脚本或能够处理上传文件的页面。
  6. 将插入点放置在表单轮廓内，然后选择“插入”>“表单”>“文件域”。

    表单中将插入一个文件域。

  7. 在属性检查器中，根据需要设置文件域的属性。

    有关更多信息，请参见设置文件域的属性。


插入动态 HTML 表单对象

您可以插入 HTML 表单对象，其初始状态由服务器在该页被从服务器中请求时确定，而不是由表单设计者在设计时确定。

本节包含以下主题：

  • 创建动态 HTML 表单菜单
  • 使现有 HTML 表单菜单成为动态对象
  • 在 HTML 文本域中显示动态内容
  • 动态预先选择 HTML 复选框
  • 动态预先选择 HTML 单选按钮

相关主题

  • 动态表单对象
  • 生成 ASP.NET 表单
  • 建立 ColdFusion MX 7 表单


创建动态 HTML 表单菜单

您可以用数据库中的项动态地填充 HTML 表单菜单或列表菜单。

对于大多数页面，您可使用 HTML 菜单对象。对于 ASP.NET 页面，您必须使用“下拉列表”或“列表框”表单对象。有关更多信息，请参见生成 ASP.NET 表单。

在开始之前，您必须在 ColdFusion、PHP、ASP 或 JSP 页中插入一个 HTML 表单，而且必须为该菜单定义记录集或其它动态内容源。有关更多信息，请参见定义记录集。

若要插入动态 HTML 表单菜单，请执行以下操作：

  1. 在页面上的 HTML 表单内单击。
  2. 选择“插入”>“表单”>“列表/菜单”。

    Dreamweaver 在页面中插入一个“列表/菜单”表单对象。

  3. 选择该“列表/菜单”表单对象。

    属性检查器显示该列表/菜单的属性。

  4. 在属性检查器中，单击“动态”按钮显示“动态列表/菜单”对话框。

  5. 完成对话框设置，然后单击“确定”。

    有关更多信息，请参见设置“动态列表/菜单”对话框的选项。

相关主题

  • 使现有 HTML 表单菜单成为动态对象


使现有 HTML 表单菜单成为动态对象

可以使现有的 HTML 表单菜单或列表菜单成为动态对象。

本节讨论 HTML 表单对象。有关 ASP.NET 菜单对象（如“下拉列表”或“列表框”控件）的更多信息，请参见使现有 ASP.NET 菜单成为动态对象。

在开始之前，您必须在 ColdFusion、PHP、ASP 或 JSP 页中创建表单，而且必须为该菜单定义记录集或其它动态内容源。有关更多信息，请参见定义记录集。

若要使现有 HTML 表单菜单成为动态对象，请执行以下操作：

  1. 在“设计”视图中，选择要使之为动态对象的列表/菜单表单对象。
  2. 在属性检查器中，单击“动态”按钮。

    出现“动态列表/菜单”对话框。

  3. 完成对话框设置，然后单击“确定”。

    有关说明，请参见设置“动态列表/菜单”对话框的选项。

相关主题

  • 创建动态 HTML 表单菜单


在 HTML 文本域中显示动态内容

您可以在 HTML 文本域中显示动态内容。

对于 ASP.NET 页面，您必须使用 ASP.NET 文本框控件。有关更多信息，请参见在 ASP.NET 文本框控件中显示动态内容。

在开始之前，您必须在 ColdFusion、PHP、ASP 或 JSP 页中创建表单，而且必须为该文本域定义记录集或其它动态内容源。有关更多信息，请参见定义记录集。

若要使 HTML 文本域成为动态对象，请执行以下操作：

  1. 选择页面上 HTML 表单中的文本域。
  2. 在属性检查器中，单击“初始值”文本框旁边的闪电图标。

    出现“动态数据”对话框。

  3. 选择为文本域提供值的记录集列，然后单击“确定”。

当在浏览器中查看该表单时，该文本域将显示动态内容。


动态预先选择 HTML 复选框

您可以让服务器决定当表单在浏览器中显示时是否选中一个复选框。

对于 ASP.NET 页面，您必须使用 ASP.NET 复选框控件。有关更多信息，请参见动态预先选择 ASP.NET 复选框控件。

在开始之前，您必须在 ColdFusion、PHP、ASP 或 JSP 页中创建表单，而且必须为复选框定义记录集或其它动态内容源。有关更多信息，请参见定义记录集。理想情况下，该内容源应包含布尔数据，如 Yes/No 或 true/false。

若要动态预先选择 HTML 复选框，请执行以下步骤：

  1. 在页面上选择一个复选框表单对象。
  2. 在属性检查器中，单击“动态”按钮。

    出现“动态复选框”对话框。

  3. 完成对话框设置，然后单击“确定”。

    有关说明，请参见设置“动态复选框”对话框的选项。

当在浏览器中查看该表单时，该复选框将显示为选中或未选中状态，这具体取决于数据。


动态预先选择 HTML 单选按钮

您可以让服务器决定当表单在浏览器中显示时是否选中一个 HTML 单选按钮。

如果要动态预先选择 ASP.NET 单选按钮对象，如“单选按钮”或“单选按钮列表”控件，请参见在 ASP.NET 单选按钮列表中动态预先选择一项。

在开始之前，您必须在 ColdFusion、PHP、ASP 或 JSP 页中创建表单，并且插入至少一组 HTML 单选按钮（请参见插入 HTML 单选按钮）。而且必须为单选按钮定义记录集或其它动态内容源。有关更多信息，请参见定义记录集。理想情况下，该内容源应包含布尔数据，如 Yes/No 或 true/false。

若要动态预先选择一个 HTML 单选按钮，请执行以下操作：

  1. 在“设计” 视图中，在单选按钮组中选择一个单选按钮。
  2. 在属性检查器中，单击“动态”按钮。

    出现“动态单选按钮组”对话框。

  3. 完成对话框设置，然后单击“确定”。

    有关指导，请参见设置“动态单选按钮组”对话框的选项或设置“动态单选按钮组”对话框的选项 (ColdFusion, ASP.NET)。


验证 HTML 表单数据

Dreamweaver 可添加用于检查指定文本域中内容的 JavaScript 代码，以确保用户输入了正确的数据类型。

本节适用于 HTML 表单。您还可以在 Dreamweaver 中建立用于验证指定域内容的 ColdFusion 表单。有关更多信息，请参见验证 ColdFusion 表单数据。对于 ASP.NET 表单，您可以在“代码”视图中插入 ASP.NET 验证控件。有关更多信息，请查询 ASP.NET 文档。

若要验证 HTML 表单数据，请执行以下操作：

  1. 创建一个至少包含一个文本域及一个“提交”按钮的 HTML 表单。

    确保要验证的每个文本域具有唯一名称。

  2. 选择“提交”按钮。
  3. 在“行为”面板（“窗口”>“行为”）中，单击加号 (+) 按钮，然后从列表中选择“检查表单”。

    随即会出现“检查表单”对话框。

    注意

    “检查表单”行为仅在文档中已插入了文本域的情况下可用。
  4. 设置每个文本域的验证规则，然后单击“确定”。

    例如，您可以指定人员年龄的文本域仅接受数字。有关更多信息，请参见检查表单。

相关主题

  • 使用 JavaScript 行为
  • 验证 ColdFusion 表单数据


将 JavaScript 行为附加到 HTML 表单对象

您可以将 Dreamweaver 中存储的 JavaScript 行为附加到诸如按钮之类的 HTML 表单对象。

注意

由于 ASP.NET 表单控件在服务器上进行处理，所以此功能不能用于 ASP.NET 表单控件。

若要将 JavaScript 行为附加到 HTML 表单对象，请执行以下操作：

  1. 选择该 HTML 表单对象。
  2. 在“行为”面板（“窗口”>“行为”）中，单击加号 (+) 按钮，然后从列表中选择一个行为。

    有关更多信息，请参见使用 JavaScript 行为。


将自定义脚本附加到 HTML 表单按钮

有些表单使用 JavaScript 或 VBScript 在客户端执行表单处理或其它操作，这与将表单数据发送到服务器进行处理相反。您可使用 Dreamweaver 配置表单按钮以便当用户单击按钮时执行特定的客户端脚本。

注意

此功能不能用于 ASP.NET 表单。

若要在客户端运行脚本，请执行以下操作：

  1. 选择表单中的“提交”按钮。
  2. 在“行为”面板（“窗口”>“行为”）中，单击加号 (+) 按钮，然后从列表中选择“调用 JavaScript”。

    有关此行为的更多信息，请参见调用 JavaScript。

  3. 在出现的“调用 JavaScript”文本框中，输入当用户单击按钮时您想要执行的 JavaScript 函数的名称，然后单击“确定”。

    例如，您可以输入一个尚不存在的函数名，如 processMyForm()。

  4. 如果您的 JavaScript 函数在文档的 head 部分中尚不存在，则添加该函数。

    例如，您可以在文档的 head 部分定义以下 JavaScript 函数：当用户单击“提交”按钮时会显示一条消息。

    function processMyForm(){
   alert('Thanks for your order!');
   }


创建可用的 HTML 表单

当您插入 HTML 表单对象并且已经在“辅助功能”首选参数中选中了“表单对象”选项时，Dreamweaver 会提示您输入使表单对象可用的信息。您也可以在插入对象后更改辅助功能属性。

若要添加可用表单对象，请执行以下操作：

  1. 在第一次添加可用表单对象时，请激活表单对象的“辅助功能”对话框（请参见优化工作区以进行有辅助功能的页面设计）。

    此步骤仅会出现一次。

  2. 在文档中，将插入点放在希望表单对象出现的位置。
  3. 选择“插入”>“表单”，然后选择要插入的表单对象。

    出现“输入标签辅助功能属性”对话框。

  4. 完成对话框。

    有关更多信息，请参见设置“输入标签辅助功能属性”对话框的选项。

  5. 单击“确定”。

    注意

    如果您按“取消”，该表单对象将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。
  6. 如果 Dreamweaver 询问您是否要插入表单标签，请单击“是”。

    该表单对象出现在文档中。

若要编辑表单对象的辅助功能值，请执行以下操作：

  1. 在“文档”窗口中，选择该对象。
  2. 执行下列操作之一：
    • 在“代码”视图中编辑适当的属性。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“编辑标签”。


参考资料

本节讲述本章中介绍的对话框和检查器：

  • 设置表单属性
  • 设置文本域的属性
  • 设置复选框的属性
  • 设置单选按钮的属性
  • 设置菜单的属性
  • 设置按钮的属性
  • 设置图像域的属性
  • 设置隐藏域的属性
  • 设置文件域的属性
  • 设置输入名称的属性
  • 设置“输入标签辅助功能属性”对话框的选项
  • 设置“单选按钮组”对话框的选项
  • 设置“动态单选按钮组”对话框的选项 (ColdFusion, ASP.NET)
  • 设置“动态单选按钮组”对话框的选项
  • 设置“动态文本域”对话框的选项
  • 设置“动态复选框”对话框的选项
  • 设置“动态列表/菜单”对话框的选项
  • 设置“列表值”对话框的选项


设置表单属性

使用该属性检查器设置 HTML 表单的属性。

若要设置表单的属性，请执行以下操作：

  1. 在“表单名称”文本框中，键入标识该表单的唯一名称。

    命名表单后，就可以使用脚本语言（如 JavaScript 或 VBScript）引用或控制该表单。如果不命名表单，则 Dreamweaver 使用语法 formn 生成一个名称，并在向页面中添加每个表单时递增 n 的值。

  2. 在“操作”文本框中，指定处理该表单的动态页或脚本的路径。可以在“操作”文本框中键入完整路径，也可以单击文件夹图标定位到同一站点中包含该脚本或应用程序页的相应文件夹。
  3. 在“方法”弹出菜单中，选择将表单数据传输到服务器的方法。

    POST 方法将在 HTTP 请求中嵌入表单数据。

    GET 方法将值附加到请求该页面的 URL 中。

    默认方法使用浏览器的默认设置将表单数据发送到服务器。通常，默认方法为 GET 方法。

    不要使用 GET 方法发送长表单。URL 的长度限制在 8192 个字符以内。如果发送的数据量太大，数据将被截断，从而导致意外的或失败的处理结果。

    对于由 GET 方法传递的参数所生成的动态页，可添加书签，这是因为重新生成页面所需的全部值都包含在浏览器地址框中显示的 URL 中。与此相反，对于由 POST 方法传递的参数所生成的动态页，不可添加书签。

    如果您要收集机密用户名和密码、信用卡号或其它机密信息，POST 方法看起来比 GET 方法更安全。但是，由 POST 方法发送的信息是未经加密的，容易被黑客获取。若要确保安全性，请通过安全的连接与安全的服务器相连。

  4. 如果需要，可以使用“MIME 类型”弹出菜单指定对提交给服务器进行处理的数据使用 MIME 编码类型。

    默认设置 application/x-www-form-urlencode 通常与 POST 方法协同使用。如果要创建文件上传域，请指定 multipart/form-data MIME 类型。

  5. 如果需要，使用“目标”弹出菜单指定一个窗口，在该窗口中显示被调用程序所返回的数据。

    如果命名的窗口尚未打开，则打开一个具有该名称的新窗口。目标值如下所示：

    _blank 在未命名的新窗口中打开目标文档。

    _parent 在显示当前文档的窗口的父窗口中打开目标文档。

    _self 在提交表单所使用的窗口中打开目标文档。

    _top 在当前窗口的窗体内打开目标文档。此值可用于确保目标文档占用整个窗口，即使原始文档显示在框架中。

相关主题

  • 创建 HTML 表单


设置文本域的属性

使用该属性检查器设置文本域的属性。

若要设置文本域的属性，请执行以下操作：

  1. 在“文本域”文本框中，为该文本域指定一个名称。

    每个文本域都必须有一个唯一名称。所选名称必须在该表单内唯一标识该文本域。表单对象名称不能包含空格或特殊字符。可以使用字母数字字符和下划线 (_) 的任意组合。请注意，为文本域指定的标签是将存储该域的值（输入的数据）的变量名。这是发送给服务器进行处理的值。

  2. 在“属性”检查器中设置以下任一选项：

    字符宽度设置域中最多可显示的字符数。此数字可以小于“最多字符数”，“最多字符数”指定在域中最多可输入的字符数。例如，如果“字符宽度”设置为 20（默认值），而用户输入 100 个字符，则在该文本域中只能看到其中的 20 个字符。请注意，虽然无法在该域中看到这些字符，但域对象可以识别它们，而且它们会被发送到服务器进行处理。

    最多字符数设置单行文本域中最多可输入的字符数。使用“最多字符数”将邮政编码限制为 5 位数，将密码限制为 10 个字符，等等。如果将“最多字符数”文本框保留为空白，则用户可以输入任意数量的文本。如果文本超过域的字符宽度，文本将滚动显示。如果用户输入超过最大字符数，则表单产生警告声。

    行数（在选中了“多行”选项时可用）设置多行文本域的域高度。

    换行（在选中了“多行”选项时可用）指定当用户输入的信息较多，无法在定义的文本区域内显示时，如何显示用户输入的内容。换行选项中包含如下选项：

    • 选择“关闭或默认”，防止文本换行到下一行。当用户输入的内容超过文本区域的右边界时，文本将向左侧滚动。用户必须按 Return 键才能将插入点移动到文本区域的下一行。
    • 选择“虚拟”，在文本区域中设置自动换行。当用户输入的内容超过文本区域的右边界时，文本换行到下一行。当提交数据进行处理时，自动换行并不应用于数据。数据作为一个数据字符串进行提交。
    • 选择“物理”，在文本区域设置自动换行，当提交数据进行处理时，也对这些数据设置自动换行。

    类型指定域为单行、多行还是密码域。

    • 选择“单行”将产生一个 type 属性设置为 text 的 input 标签。“字符宽度”设置映射为 size 属性，“最多字符数”设置映射为 maxlength 属性。
    • 选择“密码”将产生一个 type 属性设置为 password 的 input 标签。“字符宽度”和“最多字符数”设置映射为的属性与在单行文本域中的属性相同。当用户在密码文本域中键入时，输入内容显示为项目符号或星号，以保护它不被其他人看到。
    • 选择“多行”将产生一个 textarea 标签。“字符宽度”设置映射为 cols 属性，“行数”设置映射为 rows 属性。

    初始值指定在首次载入表单时域中显示的值。例如，通过包含说明或示例值，可以指示用户在域中输入信息。

    类使您可以将 CSS 规则应用于对象。

相关主题

  • 插入 HTML 文本域
  • 表单对象
  • 动态表单对象


设置复选框的属性

使用此属性检查器设置复选框的属性。

若要设置复选框的属性，请执行以下操作：

  1. 在“复选框”文本框中，为该对象指定一个名称。

    每个复选框都必须有一个唯一名称。所选名称必须在该表单内唯一标识该复选框。此名称不能包含空格或特殊字符。

  2. 在“属性”检查器中设置以下任一选项：

    选定值设置在该复选框被选中时发送给服务器的值。例如，在一项调查中，可以将值 4 设置为表示非常同意，值 1 设置为表示强烈反对。

    初始状态确定在浏览器中载入表单时，该复选框是否被选中。

    动态使服务器可以动态确定复选框的初始状态。例如，您可以使用复选框直观显示存储在数据库记录中的“Yes/No”信息。在设计时，您并不知道该信息。在运行时，服务器将读取数据库记录，如果该值为“Yes”，则选中该复选框。

    类使您可以将 CSS 规则应用于对象。

相关主题

  • 插入 HTML 复选框
  • 表单对象
  • 动态表单对象
  • 动态预先选择 HTML 复选框


设置单选按钮的属性

使用该属性检查器设置单选按钮的属性。

若要设置单选按钮的属性，请执行以下操作：

  1. 在“单选按钮”文本框中，为该对象指定一个名称。

    对于单选按钮组，如果您希望这些选项为互斥选项，必须共用同一名称。此名称不能包含空格或特殊字符。

  2. 在“属性”检查器中设置以下任一选项：

    选定值设置在该单选按钮被选中时发送给服务器的值。例如，可以在“选定值”文本框中键入滑雪，指示用户选择滑雪。

    初始状态确定在浏览器中载入表单时，该单选按钮是否被选中。

    动态使服务器可以动态确定单选按钮的初始状态。例如，您可以使用单选按钮直观表示存储在数据库记录中的信息。在设计时，您并不知道该信息。在运行时，服务器将读取数据库记录，如果该值与指定的值匹配，则选中该单选按钮。

    类使您可以将 CSS 规则应用于对象。

相关主题

  • 插入 HTML 单选按钮
  • 表单对象
  • 动态表单对象
  • 动态预先选择 HTML 单选按钮


设置菜单的属性

使用该属性检查器设置 HTML 表单中的菜单的属性。

若要设置菜单的属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    列表/菜单为该菜单指定一个名称。该名称必须是唯一的。

    类型指定该菜单是单击时下拉的菜单（“菜单”选项），还是显示一个列有项目的可滚动列表（“列表”选项）。如果您希望表单在浏览器中显示时仅有一个选项可见，则选择“菜单”选项。若要显示其它选项，用户必须单击向下箭头。

    如果您希望表单在浏览器中显示时列出部分或全部选项，如下图所示，或者打算允许用户选择多个菜单项，则选择“列表”选项。

    高度（仅“列表”类型）设置菜单中显示的项数。

    选定范围（仅“列表”类型）指定用户是否可以从列表中选择多个项。

    列表值打开一个对话框，您可以在该对话框中向菜单中添加菜单项。有关更多信息，请参见设置“列表值”对话框的选项。

    动态使服务器可以在该菜单第一次显示时动态选择其中的一个菜单项。

    类使您可以将 CSS 规则应用于对象。

    初始选定设置列表中默认选择的菜单项。单击列表中的一个或多个菜单项。

相关主题

  • 插入 HTML 表单菜单
  • 表单对象
  • 创建动态 HTML 表单菜单


设置按钮的属性

使用此属性检查器设置按钮的属性。

若要设置按钮的属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    按钮名称为该按钮指定一个名称。“提交”和“重置”是两个保留名称，“提交”通知表单将表单数据提交给处理应用程序或脚本，“重置”将所有表单域重置为其原始值。

    标签文字确定按钮上显示的文本。

    操作确定单击该按钮时发生的操作。

    • 如果选中了“提交表单”选项，当单击该按钮时将提交表单数据进行处理，该数据将被提交到表单的“操作”属性中指定的页面或脚本。请参见创建 HTML 表单。
    • 如果选中了“重置表单”选项，当单击该按钮时将清除该表单的内容。
    • 选择“无”选项指定单击该按钮时要执行的操作。例如，您可以添加一个 JavaScript 脚本，使得当用户单击该按钮时打开另一个页面。有关更多信息，请参见将 JavaScript 行为附加到 HTML 表单对象和将自定义脚本附加到 HTML 表单按钮。

    类使您可以将 CSS 规则应用于对象。

相关主题

  • 插入标准按钮
  • 插入图像按钮
  • 表单对象


设置图像域的属性

使用该属性检查器设置表单中的图像域的属性。

若要设置图像域的属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    图像区域为该按钮指定一个名称。“提交”和“重置”是两个保留名称，“提交”通知表单将表单数据提交给处理应用程序或脚本，“重置”将所有表单域重置为其原始值。

    源文件指定要为该按钮使用的图像。

    替代用于输入描述性文本，一旦图像在浏览器中载入失败，将显示这些文本。

    对齐设置对象的对齐属性。

    编辑图像启动默认的图像编辑器并打开该图像文件进行编辑。

    类使您可以将 CSS 规则应用于对象。

相关主题

  • 插入图像按钮
  • 表单对象


设置隐藏域的属性

使用该属性检查器设置 HTML 表单中的隐藏域的属性。

若要设置隐藏域的属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    隐藏域指定该域的名称。

    值设置要为该域指定的值。该值将在提交表单时传递给服务器。

    类使您可以将 CSS 规则应用于对象。

相关主题

  • 插入隐藏域
  • 表单对象


设置文件域的属性

使用该属性检查器设置 HTML 表单中的文件域的属性。

若要设置文件域的属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    文件域名称指定该文件域对象的名称。

    字符宽度指定希望该域最多可显示的字符数。

    最多字符数指定域中最多可容纳的字符数。如果用户通过浏览来定位文件，则文件名和路径可超过指定的“最多字符数”的值。但是，如果用户尝试键入文件名和路径，则文件域仅允许键入“最多字符数”值所指定的字符数。

相关主题

  • 插入文件上传域
  • 表单对象


设置输入名称的属性

当 Dreamweaver 遇到不可识别的输入类型时，出现此属性检查器。通常由于出现键入错误或其它数据输入错误，才会出现这种情况。

如果在属性检查器中将该域类型更改为 Dreamweaver 可识别的值，例如更正拼写错误后，属性检查器将更新以显示该识别类型的属性。

若要设置输入名称的属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    输入名称为该域指定一个名称。此文本框是必需的，而且名称必须是唯一的。

    类型设置该域的输入类型。此文本框的内容反映 HTML 源代码中当前出现的输入类型值。

    值设置该域的值。

    参数打开“参数”对话框，以便可查看域的当前属性以及添加或移除属性。


设置“输入标签辅助功能属性”对话框的选项

此对话框用于设置表单对象辅助功能选项。屏幕阅读器会朗读对象的“标签”属性。

若要设置对话框的选项，请执行以下操作：

  1. 在“标签文字”文本框中输入该表单对象的名称。
  2. 选择一种样式：

    用标签标记环绕会在表单项的两边添加一个标签标记，如下所示：

    <label>
<input type="radio" name="radiobutton" value="radiobutton">
RadioButton1</label>

    使用 for 附加标签标记使用 for 属性在表单项两侧添加一个标签标记，如下所示：

    <input type="radio" name="radiobutton" value="radiobutton" id="radiobutton">
<label for="radiobutton">RadioButton2</label>

    此选项会使浏览器用焦点矩形呈现与复选框和单选按钮关联的文本，并使用户能够通过在关联文本中的任意位置（而不仅是在复选框或单选按钮控件上）单击来选择该复选框和单选按钮。

    注意

    这是辅助功能的首选选项，但是浏览器不同，该功能也可能会有所不同。

    无标签标记不使用标签标记，如下所示：

    <input type="radio" name="radiobutton" value="radiobutton">
RadioButton3
  3. 为标签选择相对于表单对象的位置：“在表单项后”或“在表单项前”。
  4. 在“快捷键”文本框中输入等效的键盘键（一个字母），用以在浏览器中选择表单对象。

    使用 Control 键 (Windows) 和快捷键来访问该对象。例如，如果您输入 B 作为快捷键，则使用 Control+B 在浏览器中选择该对象。

  5. 在“Tab 键索引”文本框中输入一个数字以指定该表单对象的 Tab 键顺序。

    当您的页面上有其它链接和表单对象，并且需要用户用 Tab 键以特定顺序通过这些对象时，设置 Tab 键顺序就会非常有用。如果为一个对象设置 Tab 键顺序，则一定要为所有对象设置 Tab 键顺序。

  6. 单击“确定”。

    注意

    如果您按“取消”，该表单对象将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

相关主题

  • 验证 HTML 表单数据


设置“单选按钮组”对话框的选项

“单选按钮组”对话框创建一组在 HTML 表单中使用的单选按钮。

若要设置对话框的选项，请执行以下操作：

  1. 在“名称”文本框中，输入该单选按钮组的名称。

    如果希望这些单选按钮将参数传递回服务器，则这些参数将与该名称相关联。例如，如果将组命名为 myGroup，并将表单方法设置为 GET（即，希望当用户单击提交按钮时，表单传递 URL 参数而不是表单参数），则会在 URL 中将表达式 myGroup=”选中的值”传递给服务器。

  2. 单击加号 (+) 按钮向组添加一个单选按钮。

    如果需要，可以为新按钮输入标签和选定值。

  3. 单击向上或向下箭头重新排序这些按钮。
  4. 如果希望在浏览器中打开页面时，某特定单选按钮处于选中状态，请在“选取值等于”框中输入一个等于该单选按钮值的值。

    可以输入静态值，或者通过单击该框旁边的闪电图标，然后选择包含可能选定值的记录集，来指定动态值。无论在何种情况下，所指定的值都应与组中单选按钮之一的选定值相匹配。若要查看单选按钮的选定值，请选择每个单选按钮，然后打开其属性检查器（“窗口”>“属性”）。

  5. 选择希望 Dreamweaver 对这些按钮进行布局时使用的格式。

    Dreamweaver 可以使用换行符或表来设置这些按钮的布局。如果选择表选项，则 Dreamweaver 创建一个单列表，并将这些单选按钮放在左侧，将标签放在右侧。

  6. 单击“确定”。

Dreamweaver 在 HTML 表单中插入该单选按钮组。如果尚未在页面上插入表单，Dreamweaver 会为您插入一个表单。可以使用任何布局或格式设置工具精确调整该组的布局。

相关主题

  • 设置“动态单选按钮组”对话框的选项 (ColdFusion, ASP.NET)
  • 插入 HTML 单选按钮
  • 动态预先选择 HTML 单选按钮
  • 定义记录集


设置“动态单选按钮组”对话框的选项 (ColdFusion, ASP.NET)

“动态单选按钮组”对话框使您可以根据记录集或其它动态内容源的值，预先选择组中单选按钮的值。

若要设置对话框的选项，请执行以下操作：

  1. 从“单选按钮组”弹出菜单中选择单选按钮组和表单。
  2. 单击“选取值等于”文本框旁边的闪电图标。

    此时显示“动态数据”对话框。

  3. 从可用动态内容源列表中选择一个记录集或其它动态内容源。还可以使用“格式化”弹出式菜单格式化所选的数据项，并可以具体指定要用于页面内该数据占位符的标签。
  4. 单击“确定”关闭“动态数据”对话框。
  5. 单击“确定”关闭“动态单选按钮组”对话框，并在“单选按钮组”中插入动态内容占位符。

相关主题

  • 设置“动态单选按钮组”对话框的选项
  • 插入 HTML 单选按钮
  • 动态预先选择 HTML 单选按钮
  • 定义记录集


设置“动态单选按钮组”对话框的选项

“动态单选按钮组”对话框使您可以在显示页面时，或者在 HTML 表单中显示记录时，动态地预先选择按钮组中的某个单选按钮。

若要设置对话框的选项，请执行以下操作：

  1. 在“单选按钮组”弹出菜单中，选择页面中的表单和单选按钮组。

    “单选按钮值”文本框将显示该组内所有单选按钮的值。

  2. 从显示的值列表中选择要动态预先选择的值。该值被显示在“值”文本框中。
  3. 该值将显示在“值”域中。单击“选取值等于”框旁边的闪电图标，然后选择包含该组中单选按钮的可能选定值的记录集。

    所选的记录集应包含与单选按钮的选定值匹配的值。若要查看单选按钮的选定值，请选择每个单选按钮，然后打开其属性检查器（“窗口”>“属性”）。

  4. 单击“确定”。

相关主题

  • 动态预先选择 HTML 单选按钮
  • 插入 HTML 单选按钮
  • 定义记录集


设置“动态文本域”对话框的选项

“动态文本域”对话框创建动态文本域。

若要设置对话框的选项，请执行以下操作：

  1. 从“文本域”弹出菜单中选择要设置为动态对象的文本域。
  2. 单击“将值设置为”框旁边的闪电图标，然后从数据源列表中选择一个数据源。

    数据源应包含文本信息。如果列表中没有出现任何数据源，或者可用的数据源不能满足您的需要，请单击加号 (+) 按钮以定义新的数据源。有关说明，请参见关于动态内容源。

  3. 单击“确定”。

相关主题

  • 在 HTML 文本域中显示动态内容
  • 插入 HTML 文本域
  • 设置文本域的属性
  • 定义记录集


设置“动态复选框”对话框的选项

此对话框允许您根据布尔值预先选择某个复选框。

若要设置对话框的选项，请执行以下操作：

  1. 如果希望在记录中的域等于某个特定值时复选框处于选中状态，请执行下列操作：
    • 单击“选取，如果：”框旁边的闪电图标，然后从数据源列表中选择该域。

      该数据源必须包含布尔数据，如 Yes 和 No，或者 true 和 false。如果列表中没有出现任何数据源，或者可用的数据源不能满足您的需要，请单击加号 (+) 按钮以定义新的数据源。有关说明，请参见关于动态内容源。

    • 在“等于”框中，输入一个值，如果要使该复选框显示为选中状态，则该域必须包含此值。

      例如，如果希望记录中的特定域的值为 Yes 时，该复选框显示为选中状态，请在“等于”框中输入 Yes。

      注意

      在用户单击表单的“提交”按钮时，这个值也会返回给服务器。
  2. 单击“确定”。

相关主题

  • 动态预先选择 HTML 复选框
  • 插入 HTML 复选框
  • 定义记录集


设置“动态列表/菜单”对话框的选项

“动态列表/菜单”对话框允许您用数据库或其它内容源的内容填充列表/菜单表单对象。

若要设置对话框的选项，请执行以下操作：

  1. 在“菜单”弹出菜单中，选择要使之成为动态对象的列表/菜单表单对象。
  2. 在“来自记录集的选项”弹出菜单中，选择要用作内容源的记录集。该菜单还允许您以后编辑静态和动态列表/菜单项。
  3. “静态选项”区域允许您在列表或菜单中输入默认项。对话框的这一部分还允许您在添加动态内容后编辑列表/菜单表单对象中的静态项。

    使用加号 (+) 和减号 (-) 按钮添加和删除列表中的项。项的顺序与“初始列表值”对话框中的顺序相同。在浏览器中载入页面时，列表中的第一个项是选中的项。使用向上或向下箭头按钮重新排列列表中的项。

  4. 在“值”弹出菜单中，选择包含菜单项值的域。
  5. 在“标签文字”弹出菜单中，选择包含菜单项标签文字的域。
  6. 如果希望在浏览器中打开页面或者在表单中显示记录时，某个特定菜单项处于选中状态，请在“选取值等于”框中输入一个等于该菜单项的值的值。

    可以输入静态值，或者可通过单击该框旁边的闪电图标，然后从数据源列表中选择动态值来指定动态值。无论在何种情况下，所指定的值都应该与菜单项值之一匹配。

  7. 单击“确定”。

相关主题

  • 创建动态 HTML 表单菜单
  • 使现有 HTML 表单菜单成为动态对象
  • 定义记录集
  • 插入 HTML 表单菜单


设置“列表值”对话框的选项

使用“列表值”对话框向表单菜单中添加菜单项。

若要设置对话框的选项，请执行以下操作：

  1. 使用加号 (+) 和减号 (-) 按钮添加和删除列表中的项。
  2. 输入每个菜单项的标签文本和可选值。

    列表中的每项都有一个标签（在列表中显示的文本）和一个值（选中该项时，发送给处理应用程序的值）。如果没有指定值，则将标签文字发送给处理应用程序。

  3. 使用向上或向下箭头按钮重新排列列表中的项。

    菜单项在菜单中出现的顺序与在“列表值”对话框中出现的顺序相同。在浏览器中载入页面时，列表中的第一个项是选中的项。

相关主题

  • 设置菜单的属性
  • 插入 HTML 表单菜单


迅速开发应用程序

Web 应用程序通常赋予页面一定的功能，例如使用户可以搜索数据库的页面；使用户可以插入、更新或删除数据库中的数据的页面；以及限制对某一 Web 站点的访问的页面。使用 Macromedia Dreamweaver 8 可以迅速建立所有此类页面。

此部分包含以下各章：

快速构建 ColdFusion 应用程序

快速生成 ASP.NET 应用程序

快速生成 ASP 和 JSP 应用程序

快速生成 PHP 应用程序


快速构建 ColdFusion 应用程序

使用 Macromedia Dreamweaver 8 中的工具可以快速构建 ColdFusion Web 应用程序，只需很少甚至不需要编码。

本章包含下列章节：

关于快速应用程序开发（所有服务器）

建立 ColdFusion MX 7 表单

生成主/详细页 (ColdFusion)

建立搜索/结果页（ColdFusion、ASP、JSP、PHP）

建立记录插入页（所有服务器）

建立更新记录的页面 (ColdFusion)

建立删除记录的页面 (ColdFusion)

使用预存过程修改数据库 (ColdFusion)

生成对站点访问进行限制的页（ColdFusion、ASP、JSP、PHP）

保护应用程序 (ColdFusion) 中的文件夹

使用 ColdFusion 组件


关于快速应用程序开发（所有服务器）

快速应用程序开发 (RAD) 是一种软件开发流程，用于更加简单快捷地构建应用程序。RAD 工具通常用于处理软件项目的详细信息，这非常类似于使用计算机辅助设计 (CAD) 工具在建筑设计中处理有关墙体绘制或窗户插入的详细信息。

Dreamweaver 是 Web 站点设计人员和 Web 应用程序开发人员的 RAD 工具。您可以使用 Dreamweaver 建立用于在数据库中搜索、插入、更新或删除记录的页面。Dreamweaver 处理有关创建页面的详细信息；开发人员只需编写少量代码甚至不需要编码。（Dreamweaver 还为那些希望对页面进行全面或部分编码的开发人员提供了功能全面的编码环境。）

本节包含以下概念性主题：

  • 关于主/详细页
  • 关于搜索/结果页
  • 关于高级数据库操作对象


关于主/详细页

主页是指列出了记录以及每条记录的相应链接的页面。当用户单击一个链接时，就会打开一个详细页来显示有关该记录的更多信息。例如，下面是一个虚构的公司的主页。

当用户单击其中的某个已链接的位置名称时，就会打开一个详细页：

结果页是一种常见类型的主页。不过，它与本节所描述的主页不同，结果页上的记录列表不是由您（设计人员）决定的，而是由用户决定的。（用户通过执行数据库搜索来决定记录列表。）有关此类主页的更多信息，请参见关于搜索/结果页。

详细页也可用于更新或删除显示的记录。

相关主题

  • 生成主/详细页 (ColdFusion)
  • 生成主/详细页 (ASP.NET)
  • 生成主/详细页（ASP 和 JSP）
  • 生成主/详细页 (PHP)


关于搜索/结果页

在大多数情况下，至少需要两个页面才能将此功能添加到 Web 应用程序中。第一个页面包含用户可以在其中输入搜索参数的 HTML 表单。尽管此页面不执行任何实际的搜索，但它仍被称为“搜索页”。

所需的第二个页面是结果页，它执行大部分搜索工作。结果页执行以下任务：

  • 读取搜索页提交的搜索参数
  • 连接到数据库并查找记录
  • 使用找到的记录建立记录集
  • 显示记录集的内容

或者，您还可以添加详细页。详细页为用户提供有关结果页上的特定记录的更多信息。

如果使用 ASP.NET，则可以将搜索页和结果页合并成一个页面。

如果只有一个搜索参数，Dreamweaver 会让您将搜索功能添加到 Web 应用程序中，而不必使用 SQL 查询和变量。只需简单地设计页面并完成几个对话框。如果您有多个搜索参数，则需要编写一条 SQL 语句并为其定义多个变量。

Dreamweaver 将 SQL 查询插入到您的页中。当该页面在服务器上运行时，会检查数据库表格中的每一条记录。如果某一记录中的特定字段满足 SQL 查询条件，则将该记录包含在记录集中。SQL 查询将生成一个只包含搜索结果的记录集。

例如，现场销售人员可能知道某个区域中收入超过某一水平的客户的信息。在搜索页上的表单中，该销售人员的同事输入一个地理区域和最低收入水平，然后单击“提交”按钮将这两个值发送给服务器。在服务器上，这两个值被传递给结果页的 SQL 语句，然后该语句创建一个记录集，其中只包含指定区域中收入超过指定水平的客户。

相关主题

  • 建立搜索/结果页（ColdFusion、ASP、JSP、PHP）
  • 生成数据库搜索页 (ASP.NET)


关于高级数据库操作对象

您可以使用服务器行为建立可以修改数据库的页面，也可以使用数据库操作对象（例如预存过程、ASP 命令对象或 JSP 已准备语句）建立这些页面。

本节包含以下概念性主题：

  • 预存过程
  • ASP 命令对象
  • JSP 已准备语句


预存过程

预存过程是一种可以重复使用的数据库项，用于在数据库上执行某些操作。预存过程包含具有一定功能的 SQL 代码，例如能够插入、更新或删除记录的 SQL 代码。预存过程还可以改变数据库本身的结构。例如，您可以使用预存过程添加表格列，或者甚至可以删除表格。

一个预存过程还可以调用另一个预存过程，以及接受输入参数并以输出参数的形式向调用过程返回多个值。

您可以重复使用预存过程的单个编译的版本来多次执行数据库操作，从这种意义上说，预存过程是可以重复使用的。如果您知道将多次执行某个数据库任务（即不同的应用程序将执行相同的任务），则使用预存过程执行该任务可以使数据库操作更有效率。

注意

MySQL 和 Microsoft Access 数据库不支持预存过程。

相关主题

  • 使用预存过程修改数据库 (ColdFusion)
  • 使用预存过程修改数据库 (ASP.NET)
  • 使用预存过程修改数据库（ASP 和 JSP）


ASP 命令对象

ASP 命令对象是对数据库执行某些操作的服务器对象。该对象可以包含任何有效的 SQL 语句，包括返回记录集的语句或在数据库中插入、更新或删除记录的语句。如果 SQL 语句添加或删除表格中的列，则命令对象可以改变数据库的结构。您还可以使用命令对象在数据库中运行预存过程。

应用程序服务器可以重复使用命令对象的单个编译的版本多次执行命令，从这种意义上说，命令对象是可以重复使用的。通过将命令对象的“Prepared”属性设置为 true 可以使该命令能够重复使用，如下面的 VBScript 语句所示：

mycommand.Prepared = true

如果您知道将多次执行该命令，则具有该对象的单个编译的版本可以使数据库操作更加有效。

注意

并不是所有数据库提供程序都支持已准备命令。如果您的数据库不支持已准备命令，则当您将此属性设置为 true 时，它可能返回一个错误。它甚至可能忽略准备命令的请求并将“Prepared”属性设置为 false。

命令对象是由 ASP 页面上的脚本创建的，但是 Dreamweaver 允许您创建命令对象而无需编写 ASP 代码。有关更多信息，请参见使用 ASP 命令修改数据库。


JSP 已准备语句

JSP 已准备语句是包含 SQL 语句的可重复使用的服务器对象。您可以将任何有效的 SQL 语句放置在已准备语句中。例如，已准备语句可以包含返回记录集的 SQL 语句，或在数据库中插入、更新或删除记录的 SQL 语句。

应用程序服务器使用已准备语句对象的单个实例多次查询数据库，从这种意义上说，已准备语句是可以重复使用的。与 JSP 语句对象不同的是，不必为每个新的数据库查询创建已准备语句对象的新实例。如果您知道将多次执行该语句，则具有该对象的单个实例可以使数据库操作更有效并且占用更少的服务器内存。

已准备语句对象是由 JSP 页面上的 Java Scriptlet 创建的。但是，Dreamweaver 允许您创建已准备语句而无需编写 Java 代码。

如果您对代码感兴趣，则以下 Scriptlet 创建了一条已准备语句：

String myquery = “SELECT * FROM EMPLOYEES WHERE DEPARTMENT = ?”;
PreparedStatement mystatement = connection.prepareStatement(myquery);

第一行将 SQL 语句存储在一个名为 myquery 的字符串变量中，问号充当 SQL 变量值的占位符。第二行创建一个名为 mystatement 的已准备语句对象。

下一步，给 SQL 变量赋值，如下所示：

mystatement.setString(1, request.getParameter(“myURLparam”));

setString 方法给变量赋值并采用两个参数。第一个参数通过变量的位置指定受影响的变量（这里是 SQL 语句中的第一个位置）。第二个参数指定变量的值。在本例中，该值是由传递给页面的 URL 参数提供的。

注意

您必须使用不同的方法将非字符串值分配给 SQL 变量。例如，为了将整数分配给变量，您将使用 mystatement.setInt() 方法。

最后，生成记录集，如下所示：

ResultSet myresults = mystatement.execute();

有关更多如何在 Dreamweaver 中使用快速应用程序开发 (RAD) 工具创建 JSP 已准备语句的更多信息，请参见使用 JSP 已准备语句修改数据库。


建立 ColdFusion MX 7 表单

Dreamweaver 为使用 ColdFusion MX 7 或更高版本作为开发服务器的 ColdFusion 开发人员提供了多种增强功能。这些增强功能包括更多的“插入”栏按钮、菜单项和“属性”检查器，以便您可以快速建立 ColdFusion 表单和设置其属性。您还可以使用 Dreamweaver 生成代码以验证由站点访问者提供的信息。例如，您可以检查用户提供的电子邮件地址是否包含 @ 符号，或者必填的文本字段是否包含特定类型的值。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用这些增强功能。

本节包含以下主题：

  • 启用 ColdFusion 增强功能
  • 创建 ColdFusion 表单
  • 插入 ColdFusion 表单控件
  • 以可视方式设置 ColdFusion 表单控件的属性
  • 验证 ColdFusion 表单数据


启用 ColdFusion 增强功能

Dreamweaver 为 ColdFusion 开发人员提供了多种增强功能。这些增强功能中的某些功能要求您将运行 ColdFusion MX 7 或更高版本的计算机定义为 Dreamweaver 的测试服务器。例如，用于表单控件的新“属性”检查器仅当您指定正确的测试服务器时才可用。

只需定义一次测试服务器。然后 Dreamweaver 就可自动检测测试服务器版本并在检测到 ColdFusion MX 7 时使增强功能可用。

若要启用针对 ColdFusion 开发人员的增强功能，请执行以下操作：

  1. 如果尚未为 ColdFusion 项目定义 Dreamweaver 站点，则请定义。

    有关更多信息，请参见设置 Dreamweaver 站点。

  2. 通过选择“站点”>“管理站点”，从列表中选择您的站点，然后单击“编辑”的方式，打开“高级站点定义”对话框。

    如果出现“基本站点定义”对话框，则单击“高级”选项卡切换到高级版本。

  3. 选择“测试服务器”类别并将一个运行 ColdFusion MX 7 或更高版本的计算机指定为您的 Dreamweaver 站点的测试服务器。

    确保指定了有效的 URL 前缀。

    有关更多信息，请参见指定可在哪里处理动态页。

  4. 打开任一 ColdFusion 文档。

    在打开 ColdFusion 文档之前，您将看不到对 Dreamweaver 工作区所做的任何可见的更改。

相关主题

  • 创建 ColdFusion 表单
  • 保护应用程序 (ColdFusion) 中的文件夹
  • 在 Dreamweaver 中查看 ColdFusion 组件
  • 在 ColdFusion 组件中定义记录集
  • 将 CFC 记录集用作动态内容源
  • 创建或修改 ColdFusion 数据源


创建 ColdFusion 表单

您可以使用多个“插入”栏按钮、菜单项和“属性”检查器在 Dreamweaver 中快速创建 ColdFusion 表单并设置其属性。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用这些增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要创建 ColdFusion 表单，请执行以下操作：

  1. 打开一个 ColdFusion 页面，将插入点放在希望 ColdFusion 表单出现的位置。
  2. 选择“插入”>“ColdFusion 对象”>“CFForm”>“CFForm”，或者从“插入”栏选择“CFForm”类别并单击“CF 表单”图标。

    Dreamweaver 随即插入一个空的 ColdFusion 表单。在“设计”视图中，此表单以红色的虚轮廓线指示。如果没有看到此轮廓线，请确定选中了“查看”>“可视化助理”>“不可见元素”。

  3. 确保表单仍处于选定状态，然后使用“属性”检查器指定将处理表单数据的页面或脚本。

    在“属性”检查器中，在“动作”文本框中键入页面或脚本的路径，或单击该文本框旁的文件夹图标并导航至页面或脚本。

    如果在“属性”检查器中看不到“动作”文本框，则在“文档”窗口中单击表单轮廓选择表单。

  4. 在“方法”弹出式菜单中，选择要用来将表单数据传输到服务器的方法：

    默认方法使用浏览器的默认设置将表单数据发送到服务器。通常，默认方法为 get 方法。

    GET 方法将值附加到请求该页面的 URL 中。

    POST 方法将在 HTTP 请求中嵌入表单数据。

    有关更多信息，请单击“属性”检查器中的“帮助”图标。

  5. 插入 ColdFusion 表单控件。

    在 ColdFusion 表单中将插入点放置在希望 ColdFusion 表单控件出现的位置上，然后从“插入”菜单中选择该控件（“插入”>“ColdFusion 对象”>“CFForm”），或者从“插入”栏中的“CFForm”类别中选择该控件。

    有关更多信息，请参见插入 ColdFusion 表单控件。

  6. 如果需要，用“属性”检查器设置该控件的属性。

    确保在“设计”视图中选择了该控件，然后在“属性”检查器中设置属性。有关这些属性的更多信息，请单击“属性”检查器中的“帮助”图标。

  7. 调整 ColdFusion 表单的布局。

    如果要创建基于 HTML 的表单，可以使用换行符、段落标记、预格式化文本或表格来设置表单的格式。不能将一个 ColdFusion 表单插入另一个 ColdFusion 表单中（即标签不能交迭），但是可以在一个页面中包含多个 ColdFusion 表单。

    如果要创建基于 Flash 的表单，则使用 CSS 样式对表单进行布局。ColdFusion 会忽略表单中的所有 HTML。

    请记住用描述性文本作为 ColdFusion 表单字段的标签，以使用户可以知道自己正在对什么内容进行响应。例如，创建一个“键入您的姓名”标签以要求输入姓名信息。

相关主题

  • 验证 ColdFusion 表单数据


插入 ColdFusion 表单控件

可以使用“插入”栏或“插入”菜单快速将 ColdFusion 表单控件插入到 ColdFusion 表单中。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用这些增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

应先创建空的 ColdFusion 表单，然后再将控件插入其中。有关更多信息，请参见创建 ColdFusion 表单。如果您没有创建空的表单而试图插入一个控件，Dreamweaver 会询问您是否要创建一个空表单。

本节包含以下主题：

  • 插入 ColdFusion 文本字段
  • 插入 ColdFusion 隐藏字段
  • 插入 ColdFusion 文本区域
  • 插入 ColdFusion 按钮
  • 插入 ColdFusion 复选框
  • 插入 ColdFusion 单选按钮
  • 插入 ColdFusion 选择框
  • 插入 ColdFusion 图像字段
  • 插入 ColdFusion 文件域


插入 ColdFusion 文本字段

可以以可视方式将 ColdFusion 文本字段或密码字段插入到表单中，然后设置其属性。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此 Dreamweaver 增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要以可视方式插入 ColdFusion 文本字段，请执行以下操作：

  1. 在“设计”视图中，将插入点放在表单轮廓内。
  2. 在“插入”栏的“CFForm”类别中，单击“CF 文本字段”图标。

    一个文本字段随即出现在表单中。

  3. 在“属性”检查器中，设置该文本字段的属性。

    有关更多信息，请单击“属性”检查器中的“帮助”图标。

  4. 若要在页面中为文本字段添加标签，请在该文本字段旁单击，然后键入标签文本。

若要以可视方式插入密码字段，请执行以下操作：

  1. 重复前面步骤中的步骤 1 和步骤 2 以插入文本字段。
  2. 选择插入的文本字段以显示其“属性”检查器。
  3. 在“属性”检查器中，从“文本模式”弹出式菜单中选择值“密码”。

相关主题

  • 验证 ColdFusion 表单数据
  • 以可视方式设置 ColdFusion 表单控件的属性


插入 ColdFusion 隐藏字段

可以以可视方式将 ColdFusion 隐藏字段插入到表单中并设置其属性。使用隐藏字段可以存储或提交无需用户输入的信息。该信息对用户而言是隐藏的。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此 Dreamweaver 增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要以可视方式插入 ColdFusion 隐藏字段，请执行以下操作：

  1. 在“设计”视图中，将插入点放在表单轮廓内。
  2. 在“插入”栏的“CFForm”类别中，单击“CF 隐藏字段”图标。

    一个标记随即出现在 ColdFusion 表单中。如果看不到标记，可选择“查看”>“可视化助理”>“不可见元素”。

  3. 在“属性”检查器中，设置该隐藏字段的属性。

    有关更多信息，请单击“属性”检查器中的“帮助”图标。

相关主题

  • 以可视方式设置 ColdFusion 表单控件的属性


插入 ColdFusion 文本区域

可以以可视方式将 ColdFusion 文本区域插入到表单中并设置其属性。文本区域为包含多行文本的输入元素。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此 Dreamweaver 增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要以可视方式插入 ColdFusion 文本区域，请执行以下操作：

  1. 将插入点放在表单轮廓内。
  2. 在“插入”栏的“CFForm”类别中，单击“CF 文本区域”图标。

    一个文本区域随即出现在 ColdFusion 表单中。

  3. 在“属性”检查器中，设置该文本区域的属性。

    有关更多信息，请单击“属性”检查器中的“帮助”图标。

  4. 若要设置文本区域的标签，请在该文本区域旁单击，然后输入标签文字。

相关主题

  • 验证 ColdFusion 表单数据
  • 以可视方式设置 ColdFusion 表单控件的属性


插入 ColdFusion 按钮

可以以可视方式将 ColdFusion 按钮插入到表单中并设置其属性。ColdFusion 按钮控制 ColdFusion 表单的操作。ColdFusion 按钮可以用于将 ColdFusion 表单数据提交到服务器或重置 ColdFusion 表单。标准 ColdFusion 按钮通常带有“提交”、“重置”或“发送”标签。您还可以分配其他已经在脚本中定义的处理任务。例如，该按钮可以根据指定的值计算所选项目的总价。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此 Dreamweaver 增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要以可视方式插入 ColdFusion 按钮，请执行以下操作：

  1. 将插入点放在 ColdFusion 表单轮廓内。
  2. 在“插入”栏的“CFForm”类别中，单击“CF 按钮”图标。

    一个按钮随即出现在 ColdFusion 表单中。

  3. 在“属性”检查器中，设置该按钮的属性。

    有关更多信息，请单击“属性”检查器中的“帮助”图标。

相关主题

  • 以可视方式设置 ColdFusion 表单控件的属性


插入 ColdFusion 复选框

可以以可视方式将 ColdFusion 复选框插入到表单中并设置其属性。使用复选框使用户可以从一组选项中选择多个选项。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此 Dreamweaver 增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要以可视方式插入 ColdFusion 复选框，请执行以下操作：

  1. 将插入点放在表单轮廓内。
  2. 在“插入”栏的“CFForm”类别中，单击“CF 复选框”图标。

    一个复选框随即出现在 ColdFusion 表单中。

  3. 在“属性”面板中，设置该复选框的属性。

    有关更多信息，请单击“属性”检查器中的“帮助”图标。

  4. 若要为复选框添加标签，请在页面上该复选框的旁边单击，然后键入标签文本。

相关主题

  • 以可视方式设置 ColdFusion 表单控件的属性


插入 ColdFusion 单选按钮

可以以可视方式将 ColdFusion 单选按钮插入到表单中并设置其属性。在要求用户只能从一组选项中选择一个选项时，请使用单选按钮。单选按钮通常成组地使用。同一组中的所有单选按钮都必须具有相同的名称。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此 Dreamweaver 增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要以可视方式插入 ColdFusion 单选按钮，请执行以下操作：

  1. 将插入点放在表单轮廓内。
  2. 在“插入”栏的“CFForm”类别中，单击“CF 单选按钮”图标。

    一个单选按钮随即出现在 ColdFusion 表单中。

  3. 在“属性”检查器中，设置该单选按钮的属性。

    有关更多信息，请单击“属性”检查器中的“帮助”图标。

  4. 若要设置单选按钮的标签，请在页面上该按钮的旁边单击，然后输入标签文本。

相关主题

  • 以可视方式设置 ColdFusion 表单控件的属性


插入 ColdFusion 选择框

可以以可视方式将 ColdFusion 选择框插入到表单中并设置其属性。选择框使访问者可以从列表中选择一个或多个项目。当您的空间有限，但需要显示许多项目时，选择框非常有用。如果您想要对返回给服务器的值予以控制，也可以使用选择框。选择框与文本字段不同，在文本字段中用户可以随心所欲键入任何信息，甚至包括无效的数据，而使用选择框则可以设置某个菜单返回的确切值。

您可以在表单中插入两种类型的选择框：一种是用户单击时“下拉”的菜单；另一种是能显示可滚动的项目列表的菜单，用户可从中选择项目。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此 Dreamweaver 增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要以可视方式插入 ColdFusion 选择框，请执行以下操作：

  1. 将插入点放在表单轮廓内。
  2. 在“插入”栏的“CFForm”类别中，单击“CF 选择”图标。

    一个选择框随即出现在 ColdFusion 表单中。

  3. 在“属性”检查器中，设置该选择框的属性。

    有关更多信息，请单击“属性”检查器中的“帮助”图标。

相关主题

  • 以可视方式设置 ColdFusion 表单控件的属性


插入 ColdFusion 图像字段

可以以可视方式将 ColdFusion 图像字段插入到表单中并设置其属性。使用图像字段制作自定义按钮。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此 Dreamweaver 增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要以可视方式插入 ColdFusion 图像字段，请执行以下操作：

  1. 在“设计”视图中，将插入点放在表单轮廓内。
  2. 在“插入”栏的“CFForm”类别中，单击“CF 图像字段”图标。

    此时将出现一个对话框，提示您浏览至所需的图像。选择要插入的图像并单击“确定”按钮。

    如果该图像位于站点根文件夹之外，则 Dreamweaver 会询问您是否要将该图像复制到根文件夹中。如果图像位于根文件夹之外，则发布站点时可能无法访问。

    您也可以在“属性”检查器的“源文件”文本框中键入要显示的图像文件的路径。

  3. 在“属性”检查器中，设置该图像字段的属性。

    有关更多信息，请单击“属性”检查器中的“帮助”图标。

相关主题

  • 以可视方式设置 ColdFusion 表单控件的属性


插入 ColdFusion 文件域

可以以可视方式将 ColdFusion 文件域插入到表单中并设置其属性。使用文件域使用户可以从其计算机中选择文件（如字处理文档或图形文件）并将其上传到服务器。ColdFusion 文件域的外观与其他文本字段类似，只是文件域还包含一个“浏览”按钮。用户可以手动输入要上传的文件的路径，也可以使用“浏览”按钮定位并选择该文件。

文件域要求使用 POST 方法将文件从浏览器传输到服务器。该文件被发送到表单的“动作”文本框中所指定的地址。在表单中使用文件域之前，请与服务器管理员联系，确认允许使用匿名文件上传。

文本字段还要求将表单编码设置为 multipart/form。Dreamweaver 在您插入文件域控件时自动设置此编码。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此 Dreamweaver 增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要以可视方式插入 ColdFusion 文件域，请执行以下操作：

  1. 在“设计”视图中，选择“CFForm”以显示其“属性”检查器。

    若要快速选择表单，请在表单轮廓中的任意位置单击，并在“文档”窗口底部的标签选择器中单击 <cfform> 标签。

  2. 在“属性”检查器中，将表单方法设置为 POST。
  3. 从“MIME 类型”弹出式菜单中，选择 multipart/form-data。
  4. 将插入点置于表单轮廓内希望文件域出现的位置。
  5. 在“插入”栏的“CFForm”类别中，单击“CF 文件域”图标。

    一个文件域随即出现在文档中。

  6. 在“属性”检查器中，设置该文件域的属性。

    有关更多信息，请单击“属性”检查器中的“帮助”图标。

相关主题

  • 以可视方式设置 ColdFusion 表单控件的属性


插入 ColdFusion 日期字段

虽然在 Dreamweaver 中不能以可视方式插入 ColdFusion 日期字段，但是可以以可视方式设置其属性。ColdFusion 日期字段为特殊类型的文本字段，用户可以从弹出式日历中选择一个日期以将其插入到该文本字段中。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此 Dreamweaver 增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要插入 ColdFusion 日期字段并设置其属性，请执行以下操作：

  1. 在“设计”视图中，选择“CFForm”以显示其“属性”检查器。

    若要快速选择表单，请在表单轮廓中的任意位置单击，并在“文档”窗口底部的标签选择器中单击 <cfform> 标签。

  2. 在“属性”检查器中，将表单的“格式”属性设置为“Flash”。

    日期字段控件只能在基于 Flash 的 ColdFusion 表单中呈现。

  3. 切换到“代码”视图（“视图”>“代码”），然后在开始和结束 CFForm 标签之间的任意位置输入下面的标签：
    <cfinput name="datefield" type="datefield">
  4. 在“属性”检查器中，设置该日期字段的属性。

    有关更多信息，请单击“属性”检查器中的“帮助”图标。


以可视方式设置 ColdFusion 表单控件的属性

无论您是在“设计”视图中工作还是在“代码”视图中工作，都可以以可视方式更改 ColdFusion 表单控件的属性。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此 Dreamweaver 增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要以可视方式更改 ColdFusion 表单控件的属性，请执行以下操作：

  1. 在“设计”视图中，选择页面上的表单控件；在“代码”视图中，在控件标签内的任意位置单击。

    “属性”检查器随即显示该表单控件的属性。

  2. 在“属性”检查器中更改该控件的属性。

    有关更多信息，请单击“属性”检查器中的“帮助”图标。

  3. 若要设置更多属性，请单击“属性”检查器中的“显示标签编辑器”按钮，然后在出现的标签编辑器中设置属性。


验证 ColdFusion 表单数据

在 Dreamweaver 中可以建立具有以下功能的 ColdFusion 表单，即检查指定字段的内容以确保用户输入了正确的数据类型。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此 Dreamweaver 增强功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要验证 ColdFusion 表单数据，请执行以下操作：

  1. 创建一个至少包含一个输入字段及一个“提交”按钮的 ColdFusion 表单。

    确保要验证的每个 ColdFusion 字段都具有唯一名称。

  2. 在表单中选择一个要验证的字段。
  3. 在“属性”检查器中，指定要如何验证该字段。

每个输入“属性”检查器的较下部分都包含可以帮助您定义特定验证规则的控件。例如，您可能希望指定文本字段应包含一个电话号码。为此，请在“属性”检查器中从“值”弹出式菜单中选择“电话”。您还可以从“验证于”弹出式菜单中选择验证的时间。


生成主/详细页 (ColdFusion)

使用 Dreamweaver 可以创建以两个明细级别表示信息的页面集：主页列出记录，详细页显示有关各记录的更多详细信息。本节描述如何生成这些类型的主/详细页。

本节包含以下主题：

  • 在一次操作中生成主/详细页（ColdFusion、ASP、JSP、PHP）
  • 逐块建立主/详细页 (ColdFusion)


在一次操作中生成主/详细页（ColdFusion、ASP、JSP、PHP）

开发 Web 应用程序时，使用主/详细页集应用程序对象可以快速建立主/详细页。应用程序对象可以通过完成一两个对话框来生成一组完整的动态页。

所用方法对于 ColdFusion、ASP、JSP 和 PHP 页完全相同。有关生成 ASP.NET 主/详细页的信息，请参见生成主/详细页 (ASP.NET)。

若要使用应用程序对象完成主/详细页集，请执行以下操作：

  1. 在 Dreamweaver 中创建一个空白动态页面，方法是选择“文件”>“新建”>“动态”，然后选择一个动态页，并单击“创建”。

    该页将成为主页。

  2. 为该页面定义记录集。

    您可以在设计时定义记录集（请参见定义记录集），或者由用户在运行时定义记录集（请参见建立搜索/结果页（ColdFusion、ASP、JSP、PHP））。

    确保该记录集不仅包含主页所需的所有列，还包含详细页所需的所有列。通常，主页上的记录集提取数据库表格中的少数几列，而详细页上的记录集提取同一表格中的更多列以提供额外的详细信息。

  3. 在“设计”视图中打开主页，然后选择“插入”>“应用程序对象”>“主详细页集”。

    随即出现“主详细页集”对话框。

  4. 完成对话框。

    有关更多信息，请参见设置“主详细页集”对话框选项。

  5. 单击“确定”。

    应用程序对象创建一个详细页（如果尚未创建），并且同时向主页和详细页中添加动态内容和服务器行为。

  6. 自定义主页和详细页的布局以符合需要。

    使用 Dreamweaver 页面设计工具可以完全地自定义每个页面的布局。还可以在“服务器行为”面板中双击服务器行为对其进行编辑。

使用应用程序对象创建主/详细页后，使用“服务器行为”面板（“窗口”>“服务器行为”）来修改由应用程序对象插入到页面中的各种构造块。有关更多信息，请参见编辑页面上的动态内容。

您还可以使用单独的服务器行为来建立主/详细页。有关更多信息，请参见以下章节：

  • 逐块建立主/详细页 (ColdFusion)
  • 逐块生成主/详细页（ASP 和 JSP）
  • 逐块生成主/详细页 (PHP)


逐块建立主/详细页 (ColdFusion)

您可以使用“服务器行为”面板分别添加主/详细页的基本构造块。

也可以使用主/详细页集应用程序对象一次性添加所有构造块。有关更多信息，请参见在一次操作中生成主/详细页（ColdFusion、ASP、JSP、PHP）。

本节介绍使用服务器行为建立主/详细页的步骤：

  • 创建主页 (ColdFusion)
  • 创建到详细页的链接 (ColdFusion)
  • 为链接创建 URL 参数 (ColdFusion)
  • 查找请求的记录并在详细页上显示 (ColdFusion)


创建主页 (ColdFusion)

本节介绍如何创建能列出数据库记录的主页。您可以使用动态表格在 ColdFusion 页面上列出记录。

开始之前，请确保为数据库定义了 ColdFusion 数据源。有关更多信息，请参见 ColdFusion 开发人员的数据库连接。

若要创建主页，请执行以下操作：

  1. 在 Dreamweaver 中，创建一个新的 ColdFusion 页面。

    选择“文件”>“新建”>“动态”，选择“ColdFusion”，然后单击“创建”。Dreamweaver 中随即打开一个空白的 ColdFusion 页面。

  2. 为该页面定义记录集。

    在“绑定”面板中，单击加号 (+) 按钮，选择“记录集（查询）”，然后完成该“记录集”对话框。有关更多信息，请单击对话框上的“帮助”按钮。如果您想自己编写 SQL 语句，请单击“高级”按钮，打开“高级记录集”对话框。

    确保记录集包含创建动态表格所需的所有表格列。记录集还必须包含含有每条记录的唯一键的表格列，即记录 ID 列。在下面的示例中，CODE 列包含了唯一标识每条记录的信息。

    通常，主页上的记录集提取数据库表格中的少数几列，而详细页上的记录集提取同一表格中的更多列以提供额外的详细信息。

    记录集可以在运行时由用户定义。有关更多信息，请参见建立搜索/结果页（ColdFusion、ASP、JSP、PHP）。

  3. 插入动态表格以将记录显示在页面中。

    将插入点放在页面上想要显示动态表格的地方，然后选择“插入”>“应用程序对象”>“动态数据”>“动态表格”。

    随即出现“动态表格”对话框。

  4. 完成“动态表格”对话框，然后单击“确定”。

    Dreamweaver 将动态表格插入到页面中。

    如果需要帮助来完成该对话框，请单击该对话框中的“帮助”按钮。

  5. 如果需要，您可以删除包含记录 ID 的动态表格列。

    如果不打算向用户显示记录 ID，可以从动态表格中删除该列。在页面上任意位置单击，将焦点移至页面。将光标移动到动态表格中该列的顶部附近直到列单元格外框为红色，然后单击选择该列。按 Delete 键将该列从表格中删除。

下一步是创建到详细页的链接。请参见创建到详细页的链接 (ColdFusion)。


创建到详细页的链接 (ColdFusion)

将动态表格添加到主页后（请参见创建主页 (ColdFusion)），您必须创建打开详细页的链接。本节介绍如何创建此类链接。下一节介绍如何修改该链接，使之还能传递用户所选记录的 ID。详细页将使用此 ID 在数据库中查找请求的记录并显示该记录。

若要创建指向详细页的链接，请执行以下操作：

  1. 在动态表格的重复行中，选择要用作链接的文本或图像。

    下面的示例选择了 {rsLocations.LOCATION_NAME} 占位符。这些链接将应用于列中的位置名称。

  2. 在“属性”检查器中，单击“链接”文本框旁边的文件夹图标。
  3. 浏览找到并选择该详细页。

    该详细页随即出现在“属性”检查器的“链接”文本框中。

    在动态表格中，所选文本显示为已被链接。当该页面在服务器上运行时，该链接将应用于表格每一行中的文本。

下一步是创建能将记录 ID 传递给详细页的 URL 参数。请参见为链接创建 URL 参数 (ColdFusion)。


为链接创建 URL 参数 (ColdFusion)

动态表格中的链接（请参见创建到详细页的链接 (ColdFusion)）不仅要打开详细页，它们还必须传递用户所选记录的 ID。详细页将使用此 ID 在数据库中查找请求的记录并显示该记录。

记录 ID 通过 URL 参数传递给详细页。有关更多信息，请参见 URL 参数。

本节介绍如何创建 URL 参数，URL 参数用于将记录 ID 传递给详细页。

若要创建 URL 参数，请执行以下操作：

  1. 在主页上，选择动态表格中的链接。

    如果打开了“动态数据”视图，请选择第一行中的链接。

  2. 在“属性”检查器的“链接”文本框中，将下面的字符串添加到 URL 的末尾：
    ?recordID=#recordsetName.fieldName#

    问号将告知服务器接下来是一个或多个 URL 参数。单词“recordID”是 URL 参数的名称（您可以指定任何名称）。记下该 URL 参数的名称，因为接下来会在详细页中用到它。

    等号后的表达式是该参数的值。在本例中，该值由 ColdFusion 表达式生成，该表达式从记录集中返回一个记录 ID。它将为动态表格中的每一行生成一个不同的 ID。在 ColdFusion 表达式中，用您的记录集的名称替换 recordsetName，用记录集中唯一标识每条记录的字段的名称替换 fieldName。大多数情况下，该字段将由一个记录 ID 号组成。在下面的示例中，该字段由唯一位置代码构成。

    locationDetail.cfm?recordID=#rsLocations.CODE#

    当该页面运行时，记录集的 CODE 字段的值将插入到动态表格中相应的行中。例如，如果澳大利亚堪培拉的租位代码为 CBR，那么下面的 URL 将用于动态表格中有堪培拉的行：

    locationDetail.cfm?recordID=CBR
  3. 保存该页面。

下一步是查找请求的记录并在详细页上显示。请参见查找请求的记录并在详细页上显示 (ColdFusion)。


查找请求的记录并在详细页上显示 (ColdFusion)

完成主页后（请参见为链接创建 URL 参数 (ColdFusion)），请切换到详细页。您必须在数据库中查找请求的记录，并将其显示在页面上。该过程由两个步骤组成：首先，定义一个记录集以存储单个记录（即主页请求的记录）；然后，将记录集列绑定到页面上。

若要查找请求的记录并在详细页上显示，请执行以下操作：

  1. 切换到详细页。

    如果您还没有详细页，请创建一个空白的 ColdFusion 页面（“文件”>“新建”）。

  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并从弹出式菜单中选择“记录集（查询）”。

    出现简单的“记录集”对话框。如果出现的是高级的“记录集”对话框，请单击“简单”切换到简单的“记录集”对话框。

  3. 命名该记录集，然后选择一个 ColdFusion 数据源和将向记录集提供数据的数据库表格。
  4. 在“列”区域中，选择要包括在记录集中的表格列。

    详细页上的记录集可以与主页上的记录集相同，也可以不同。通常，详细页记录集的列数更多，可以显示更多的详细信息。

    如果记录集不同，则请确保详细页上的记录集至少包含一个与主页上的记录集相同的列。这个公共列通常是记录 ID 列，但也可以是相关表格的连结字段。

    若要使数据集中只包括某些表列，请单击“已选定”，然后按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 列表中的列，以选择所需列。

  5. 如下所示完成“筛选”部分，以便查找和显示主页所传递的 URL 参数中指定的记录：
    • 从“筛选”区域的第一个弹出式菜单中选择记录集中的列，该列包含与主页传递的 URL 参数值相匹配的值。例如，如果 URL 参数包含一个记录 ID 号，则选择包含记录 ID 号的列。在上一节讨论的示例中，记录集列 CODE 包含与通过主页传递的 URL 参数值相匹配的值。
    • 从第一个菜单旁边的弹出式菜单中选择等号（它应该已被选定）。
    • 从第三个弹出菜单中选择 URL 参数。

      主页使用 URL 参数将信息传递到详细页。

    • 在第四个文本框中，输入由主页传递的 URL 参数的名称。例如，如果用来打开详细页的主页的 URL 包含 locationDetail.cfm?recordID=CBR 后缀，请接着输入 recordID。

    “记录集”对话框的外观应如下所示：

  6. 单击“确定”。

    记录集随即出现在“绑定”面板中。

  7. 通过下面的方法将记录集列绑定到详细页：在“绑定”面板（“窗口”>“绑定”）上选择列，然后将其拖到页面上。

    有关更多信息，请参见将文本动态化。

将主页和详细页上传到服务器后，您可以在浏览器中打开主页。单击主页上的详细链接，会打开详细页，其中显示所选记录的更多信息。


建立搜索/结果页（ColdFusion、ASP、JSP、PHP）

可以使用 Dreamweaver 建立一组页面，使用户可以搜索您的数据库。所用方法对于 ColdFusion、ASP、JSP 和 PHP 页完全相同。有关建立 ASP.NET 搜索/结果页的信息，请参见生成数据库搜索页 (ASP.NET).

本节包含以下主题：

  • 生成搜索页
  • 生成结果页
  • 创建结果页的详细页


生成搜索页

Web 上的搜索页通常包含用户在其中输入搜索参数的表单字段。搜索页至少必须具有一个带有“提交”按钮的 HTML 表单。

若要向搜索页添加 HTML 表单，请执行以下操作：

  1. 打开搜索页或一个新页面，然后选择“插入”>“表单”>“表单”。

    将在页面上创建一个空表单。您可能需要启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）来查看表单的边界，边界是由红色的细线表示的。

  2. 从“插入”菜单中选择“表单”，添加表单对象以供用户输入搜索参数。

    表单对象包括文本字段、菜单、复选框和单选按钮。可以添加任意多的表单对象以帮助用户细化搜索操作。但是请记住，搜索页上搜索参数的数目越多，SQL 语句就将越复杂。

    有关表单对象的更多信息，请参见插入 HTML 表单对象。

  3. 在表单上添加一个“提交”按钮（“插入”>“表单”>“按钮”）。
  4. 如果愿意，可以通过以下方法更改“提交”按钮的标签文字：选择该按钮，打开“属性”检查器（“窗口”>“属性”），然后在“标签”文本框中输入一个新值。

    下一步，您将告诉表单当用户单击“提交”按钮时向何处发送搜索参数。

  5. 通过在“文档”窗口底部的标签选择器中选择 <form> 标签来选择表单，如下所示：

  6. 在该表单的“属性”检查器上的“动作”文本框中，输入将执行数据库搜索的结果页的文件名。
  7. 在“方法”弹出式菜单中，选择下列方法之一确定表单如何将数据发送到服务器：
    • GET 通过将表单数据作为查询字符串附加到 URL 来发送这些数据。由于 URL 的长度限制为 8192 个字符，因此不要将 GET 方法用于较长的表单。
    • POST 在消息体中发送表单数据。
    • 默认 使用浏览器的默认方法（通常为 GET）。

搜索页就完成了。下一步将完成结果页。有关更多信息，请参见生成结果页。

相关主题

  • 关于搜索/结果页


生成结果页

用户单击表单的“搜索”按钮时，搜索参数即发送到服务器上的结果页。由服务器上的结果页（而不是浏览器上的搜索页）负责从数据库检索记录。

本节包含以下主题：

  • 只使用一个搜索参数进行搜索
  • 使用多个搜索参数进行搜索
  • 显示结果

相关主题

  • 关于搜索/结果页
  • 生成搜索页
  • 创建结果页的详细页


只使用一个搜索参数进行搜索

如果搜索页只向服务器提交一个搜索参数，那么您无需 SQL 查询和变量即可建立结果页。您可以创建一个具有过滤器的基本记录集，该过滤器能够排除不满足搜索页所提交的搜索参数的记录。

注意

如果具有多个搜索条件，则必须使用高级“记录集”对话框定义记录集（请参见使用多个搜索参数进行搜索）。

若要创建保留搜索结果的记录集，请执行以下操作：

  1. 在“文档”窗口中打开结果页。

    如果您还没有结果页，请创建一个空白的动态页（“文件”>“新建”）。

  2. 通过下列方法创建一个新记录集：打开“绑定”面板（“窗口”>“绑定”），单击加号 (+) 按钮，并从弹出式菜单中选择“记录集”。
  3. 确保出现简单“记录集”对话框。

    如果出现的是高级对话框，则通过单击“简单”按钮切换到简单对话框。

  4. 输入记录集的名称并选择一个连接。

    该连接应该连接到包含希望用户搜索的数据的数据库。

  5. 在“表格”弹出式菜单中，选择数据库中要搜索的表格。

    注意

    在单参数搜索中，可以只在一个表格中搜索记录。若要同时搜索多个表格，必须使用高级的“记录集”对话框并定义一个 SQL 查询。
  6. 若要使记录集中只包括某些表格列，请单击“已选中”，然后按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 列表中的列，以选择所需的列。

    您应该只包括含有您要在结果页显示的信息的列。

暂时使“记录集”对话框保持打开状态。下一步将使用该对话框获取搜索页发送的参数，并创建一个记录集过滤器以排除不满足参数的记录。

若要创建记录集过滤器，请执行以下操作：

  1. 在“筛选”区域中的第一个弹出式菜单中，选择要在其中搜索匹配记录的数据库表格中的一列。

    例如，如果搜索页发送的值是城市名，则在包含城市名的表中选择列。

  2. 从第一个菜单旁边的弹出菜单中，选择等号（它应该为默认值）。
  3. 从第三个弹出式菜单中，选择“表单变量”（如果搜索页上的表单使用 POST 方法），或者选择“URL 参数”（如果搜索页上的表单使用 GET 方法）。

    搜索页使用表单变量或是 URL 参数将信息传递到结果页。

  4. 在第四个文本框中，输入接受搜索页上的搜索参数的表单对象名称。

    对象名称也兼作为表单变量名称或 URL 参数。可以通过下面的方法获取此名称：切换到搜索页，单击选择表单上的表单对象，并在“属性”检查器中选择对象的名称。

    例如，假设您希望创建一个只包括到特定国家的探险旅程的记录集。假设表格中有一个名为 TRIPLOCATION 的列。另外还假设搜索页上的 HTML 表单使用 GET 方法并包含一个名为 Location 的菜单对象（它显示国家/地区列表）。您的“筛选”部分应如下所示：

  5. 如果需要，请单击“测试”，输入一个测试值，然后单击“确定”连接到数据库并创建一个记录集实例。

    测试值模拟本来应由搜索页返回的值。单击“确定”关闭测试记录集。

  6. 如果您对该记录集感到满意，请单击“确定”。

Dreamweaver 在页面中插入一个服务器端脚本，该脚本在服务器上运行，它检查数据库表格中的每条记录。如果某一记录中的指定字段满足过滤条件，则将该记录包含在记录集中。这样，脚本将生成一个只包含搜索结果的记录集。

下一步是在结果页上显示记录集。有关更多信息，请参见显示结果。


使用多个搜索参数进行搜索

如果搜索页向服务器提交多个搜索参数，则必须为结果页编写一个 SQL 查询并在 SQL 变量中使用搜索参数。

注意

如果仅有一个搜索条件，则可以使用简单“记录集”对话框来定义记录集（请参见只使用一个搜索参数进行搜索）。

使用 SQL 在数据库中查找记录：

  1. 在 Dreamweaver 中打开结果页，然后通过下面的方法创建一个新记录集：打开“绑定”面板（“窗口”>“绑定”），单击加号 (+) 按钮，然后从弹出式菜单中选择“记录集”。
  2. 确保出现高级“记录集”对话框。

    如果出现的是简单对话框，则请通过单击“高级”按钮切换到高级对话框。

  3. 输入记录集的名称并选择一个连接。

    应该连接到包含希望用户搜索的数据的数据库。

  4. 在 SQL 文本区域中输入一条 Select 语句。

    确保该语句包含一个 WHERE 子句，并且该子句带有可以用来保存搜索参数的变量。在下面的示例中，变量名为 varLastName 和 varDept：

    SELECT EMPLOYEEID, FIRSTNAME, LASTNAME, DEPARTMENT, EXTENSION
FROM EMPLOYEE WHERE LASTNAME LIKE 'varLastName' AND DEPARTMENT
LIKE 'varDept'

    若要减少键入量，可以使用高级“记录集”对话框底部的数据库项目树。有关说明，请参见通过编写 SQL 来创建高级记录集。

    有关 SQL 语法的帮助，请参见 SQL 入门。

  5. 通过单击“变量”区域中的加号 (+) 按钮并输入变量名、默认值（没有运行时值返回时变量应采用的值）和运行时值（通常是含有浏览器发送的值的服务器对象，如请求变量），将搜索参数的值赋给 SQL 变量。

    在下面的 ASP 示例中，搜索页上的 HTML 表单使用 GET 方法并包含一个名为“LastName”的文本字段和一个名为“Department”的文本字段。

    在 ColdFusion 中，运行时值将为 #LastName# 和 #Department#。在 JSP 中，运行时值将为 request.getParameter("LastName") 和 request.getParameter("Department")。

  6. 如果需要，请单击“测试”使用默认的变量值创建一个记录集实例。

    默认值模拟本来应由搜索页返回的值。单击“确定”关闭测试记录集。

  7. 如果您对该记录集感到满意，请单击“确定”。

    Dreamweaver 将 SQL 查询插入到您的页中。

下一步是在结果页上显示记录集。有关更多信息，请参见显示结果。


显示结果

创建保留搜索结果的记录集后，您必须在结果页上显示这些信息。显示记录只是将单个列从“绑定”面板拖动到结果页上。可以添加导航链接以便在记录集中向前和向后移动，或者可以创建重复区域在页面上显示多条记录。您还可以将链接添加到详细页。

本节介绍如何使用动态表格显示结果。

若要使用动态表格显示搜索结果，请执行以下操作：

  1. 将插入点放在结果页上想要显示动态表格的地方，然后选择“插入”>“应用程序对象”>“动态数据”>“动态表格”。

    随即出现“动态表格”对话框。

  2. 通过选择您所定义的用来放置搜索结果的记录集完成“动态表格”对话框。

    如果需要帮助来完成“动态表格”对话框，单击该对话框中的“帮助”按钮。

  3. 单击“确定”。

    Dreamweaver 插入一个动态表格，用于显示搜索结果。

有关在页面上显示动态内容的其它方法的更多信息，请参见显示数据库记录。


创建结果页的详细页

您的搜索/结果页集可包括一个详细页，以显示有关结果页上的特定记录的更多信息。这种情况下，结果页兼作为主/详细页集中的主页。有关更多信息，请参见下列主题：

  • 生成主/详细页 (ColdFusion)
  • 生成主/详细页（ASP 和 JSP）
  • 生成主/详细页 (PHP)

相关主题

  • 生成搜索页
  • 生成结果页


建立记录插入页（所有服务器）

您的应用程序可以包含一个允许用户向数据库中插入新记录的页。例如，下面的页在一个雇员数据库中插入一个新记录：

插入页由两个构造块组成：

  • 一个允许用户输入数据的 HTML 表单
  • 一个更新数据库的“插入记录”服务器行为

您可以使用“插入记录表单”应用程序对象通过单个操作添加这两个构造块（请参见用一次操作建立插入页），或者您可以使用 Dreamweaver 表单工具和“服务器行为”面板分别添加它们（请参见逐块生成插入页）。

注意

插入页一次只能包含一个记录编辑服务器行为。例如，您不能将“更新记录”或“删除记录”服务器行为添加到插入页。


用一次操作建立插入页

您可以使用“插入记录表单”应用程序对象通过单个操作添加插入页的基本构造块。该应用程序对象将 HTML 表单和“插入记录”服务器行为添加到页中。

您还可以使用表单工具和“服务器行为”面板分别添加这些构造块。有关更多信息，请参见逐块生成插入页。

在将构造块放置到页上之后，您可以使用 Dreamweaver 设计工具自定义表单，或使用“服务器行为”面板编辑“插入记录”服务器行为。

若要用“插入记录表单”应用程序对象建立插入页，请执行以下操作：

  1. 在“设计”视图中打开该页，然后选择“插入”>“应用程序对象”>“插入记录”>“插入记录表单向导”。

    即会出现“插入记录表单”对话框。

  2. 完成对话框。

    有关说明，请参见设置“插入记录表单”对话框选项。

  3. 单击“确定”。

Dreamweaver 将 HTML 表单和“插入记录”服务器行为添加到页面。表单对象是在一个基本表格中进行布局的，您可以使用 Dreamweaver 页面设计工具自定义该表格。（确保所有表单对象都保持在表单的边界内。）

若要编辑服务器行为，请打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“插入记录”行为。


逐块生成插入页

您可以使用表单工具和“服务器行为”面板分别添加插入页的基本构造块。

您也可以使用“插入记录表单”应用程序对象一次添加所有构造块。有关更多信息，请参见用一次操作建立插入页。

建立插入页的过程由两个步骤组成：

  • 将 HTML 表单添加到页面以允许用户输入数据
  • 添加“插入记录”服务器行为以在数据库表格中插入记录

若要将 HTML 表单添加到插入页，请执行以下操作：

  1. 创建一个新动态页（“文件”>“新建”）并使用 Dreamweaver 设计工具对您的页进行布局。
  2. 添加一个 HTML 表单，方法是：将插入点放置在希望表单出现的位置，然后选择“插入”>“表单”>“表单”。

    将在页面上创建一个空表单。您可能需要启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）来查看表单的边界，边界是由红色的细线表示的。

  3. 为 HTML 表单指定名称；方法是单击“文档”窗口底部的 <form> 标签以选中表单，打开“属性”检查器（“窗口”>“属性”），然后在“表单名称”文本框中输入一个名称。

    不需要指定表单的 action 或 method 属性来指示当用户单击“提交”按钮时向何处及如何发送记录数据。“插入记录”服务器行为会为您设置这些属性。

  4. 为要插入记录的数据库表格中的每一列添加一个表单对象，如文本字段（“插入”>“表单”>“文本字段”）。

    表单对象用于数据输入。为了实现该目的，经常会使用文本字段，但是您也可以使用菜单、复选框和单选按钮。

    有关表单对象的更多信息，请参见插入 HTML 表单对象。

  5. 在表单上添加一个“提交”按钮（“插入”>“表单”>“按钮”）。

    可以通过以下方法更改“提交”按钮的标签文字：选择该按钮，打开属性检查器（“窗口”>“属性”），并在“标签文字”文本框中输入一个新值。

若要添加服务器行为以在数据库表格中插入记录，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮并从弹出式菜单中选择“插入记录”。

    出现“插入记录”对话框。

  2. 完成对话框。

    有关说明，请参见：

    • 设置“插入记录”对话框选项（ASP 和 JSP）
    • 设置“插入记录”对话框选项 (PHP)
    • 设置“插入记录”对话框选项 (ColdFusion)
    • 设置“插入记录”对话框选项 (ASP.NET)
  3. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过单击表单上的“提交”按钮从而在数据库表格中插入记录。

若要编辑服务器行为，请打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“插入记录”行为。


建立更新记录的页面 (ColdFusion)

您的应用程序可以包含允许用户更新数据库表中现有记录的一组页。这组页通常由一个搜索页、一个结果页和一个更新页组成。用户可以使用搜索页和结果页检索记录，使用更新页修改记录。

本节介绍生成页面用于更新记录的步骤：

  • 搜索要更新的记录 (ColdFusion)
  • 创建打开更新页的链接 (ColdFusion)
  • 创建用于更新链接的 URL 参数 (ColdFusion)
  • 检索要更新的记录 (ColdFusion)
  • 在一次操作中完成更新页 (ColdFusion)
  • 逐块完成更新页 (ColdFusion)

相关主题

  • 生成主/详细页 (ColdFusion)
  • 建立记录插入页（所有服务器）
  • 建立删除记录的页面 (ColdFusion)


搜索要更新的记录 (ColdFusion)

当用户要更新某个记录时，他们必须首先在数据库中找到该记录。因此，您需要一个搜索页和一个结果页以便使用更新页。用户在搜索页中输入搜索条件，并在结果页中选择记录。当用户单击该记录时，更新页将打开并在 HTML 表单中显示该记录。

有关创建用于搜索要更新的记录的页面的指导，请参见建立搜索/结果页（ColdFusion、ASP、JSP、PHP）。

创建搜索/结果页后，下一步是在结果页上创建链接，当单击链接时将打开更新页。请参见创建打开更新页的链接 (ColdFusion)。


创建打开更新页的链接 (ColdFusion)

创建搜索/结果页后（请参见搜索要更新的记录 (ColdFusion)），您必须在结果页上创建链接，用于打开更新页，并在 HTML 表单中显示所选的记录。本节介绍如何创建此类链接。下一节介绍如何修改该链接，使之同时传递用户所选记录的 ID。更新页将使用此 ID 在数据库中查找请求的记录并显示该记录。

若要创建指向更新页的链接，请执行以下操作：

  1. 在结果页中，选择用于您要链接的重复文本或动态内容占位符。

    下面的示例选择了 {rsLocations.LOCATION_NAME} 占位符。这些链接将应用于列中的位置名称。

  2. 在“属性”检查器中，单击“链接”文本框旁边的文件夹图标。
  3. 浏览找到并选择该更新页。

    更新页的文件名出现在“链接”文本框中。

    在结果页上，动态内容的占位符显示为链接状态。如果将更新页和结果页上传到服务器并运行一个搜索，您可以看到该链接被应用到结果页上列出的每条记录。

下一步是创建一个 URL 参数，传递用户所选记录的 ID。请参见创建用于更新链接的 URL 参数 (ColdFusion)。


创建用于更新链接的 URL 参数 (ColdFusion)

结果页上的链接（请参见创建打开更新页的链接 (ColdFusion)）不仅要打开更新页，它们还必须传递用户所选记录的 ID。更新页将使用此 ID 在数据库中查找请求的记录并显示该记录。

记录 ID 通过 URL 参数传递给更新页。有关更多信息，请参见 URL 参数。

本节介绍如何创建 URL 参数，该参数将记录 ID 传递给更新页。

若要创建 URL 参数，请执行以下操作：

  1. 在结果页上选中该链接。
  2. 在“属性”检查器的“链接”文本框中，将下面的字符串添加到 URL 的末尾：
    ?recordID=#recordsetName.fieldName#

    问号将告知服务器接下来是一个或多个 URL 参数。单词“recordID”是 URL 参数的名称（您可以指定任何名称）。记下该 URL 参数的名称，因为接下来会在更新页中用到它。

    等号后的表达式是该参数的值。在本例中，该值由 ColdFusion 表达式生成，该表达式从记录集中返回一个记录 ID。它将为动态表格中的每一行生成一个不同的 ID。在 ColdFusion 表达式中，用您的记录集的名称替换 recordsetName，用记录集中唯一标识每条记录的字段的名称替换 fieldName。大多数情况下，该字段将由一个记录 ID 号组成。在下面的示例中，该字段由唯一位置代码构成。

    locationDetail.cfm?recordID=#rsLocations.CODE#

    当该页运行时，记录集的 CODE 字段的值将插入到动态表格中相应的行中。例如，如果澳大利亚堪培拉的租位代码为 CBR，那么下面的 URL 将用于动态表格中有堪培拉的行：

    locationDetail.cfm?recordID=CBR
  3. 保存该页面。

下一步将修改更新页，使之能够在数据库中查找请求的记录，并将其显示在页面上。请参见检索要更新的记录 (ColdFusion)。


检索要更新的记录 (ColdFusion)

在结果页将标识要更新的记录的 URL 参数传递到更新页之后（请参见创建用于更新链接的 URL 参数 (ColdFusion)），更新页必须读取该参数，从数据库表中检索该记录，然后将其临时存储在一个记录集中。

若要检索要更新的记录，请执行以下操作：

  1. 在 Dreamweaver 中创建新的 ColdFusion 页并保存该页。

    该页将成为您的更新页。

  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并选择“记录集”。

    如果出现高级对话框，则单击“简单”按钮打开简单对话框。

  3. 对记录集进行命名，并使用“连接”和“表格”弹出式菜单指定要更新的数据所在的位置。
  4. 单击“已选定”选项并选择一个键列（通常是记录 ID 列）和包含要更新数据的列。
  5. 配置“筛选”区域，以便键列的值等于结果页传递的相应 URL 参数的值。

    这种过滤器创建一个只包含结果页所指定记录的记录集。例如，如果您的键列称为 PRID 且包含记录 ID 信息，并且如果结果页在名为 id 的 URL 参数中传递相应的记录 ID 信息，则您的“筛选”区域的外观应该如下所示：

  6. 单击“确定”。

当用户在结果页上选择一个记录时，更新页将生成一个只包含所选记录的记录集。


在一次操作中完成更新页 (ColdFusion)

更新页具有三个构造块：

  • 一个用于从数据库表格中检索记录的过滤记录集（请参见检索要更新的记录 (ColdFusion)）
  • 一个允许用户修改记录数据的 HTML 表单
  • 一个用于更新数据库表的“更新记录”服务器行为

您可以使用“更新记录表单”应用程序对象通过单个操作添加更新页的最后两个构造块。该应用程序对象将 HTML 表单和“更新记录”服务器行为添加到页中。

在您可以使用该应用程序对象之前，您的 Web 应用程序必须能够识别要更新的记录，并且您的更新页必须能够检索它。请参见搜索要更新的记录 (ColdFusion)、创建打开更新页的链接 (ColdFusion)、创建用于更新链接的 URL 参数 (ColdFusion) 和检索要更新的记录 (ColdFusion)。

在应用程序对象将构造块放置到页上之后，您可以使用 Dreamweaver 设计工具按需要自定义表单，或使用“服务器行为”面板编辑“更新记录”服务器行为。

注意

更新页一次只能包含一个记录编辑服务器行为。例如，您不能将“插入记录”或“删除记录”服务器行为添加到更新页。

若要用“更新记录表单”应用程序对象建立更新页，请执行以下操作：

  1. 在“设计”视图中打开该页，然后选择“插入”>“应用程序对象”>“更新记录”>“更新记录表单向导”。

    即会出现“更新记录表单”对话框。

  2. 完成对话框。

    有关说明，请参见设置“更新记录表单”对话框选项。

  3. 单击“确定”。

该应用程序对象将 HTML 表单和“更新记录”服务器行为添加到您的页中。表单对象是在一个基本表格中进行布局的，您可以使用 Dreamweaver 页面设计工具自定义该表格。（确保所有表单对象都保持在表单的边界内。）

若要编辑服务器行为，请打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“更新记录”行为。

相关主题

  • 逐块完成更新页 (ColdFusion)


逐块完成更新页 (ColdFusion)

更新页具有三个构造块：

  • 一个用于从数据库表格中检索记录的过滤记录集（请参见检索要更新的记录 (ColdFusion)）
  • 一个允许用户修改记录数据的 HTML 表单
  • 一个用于更新数据库表的“更新记录”服务器行为

您可以使用表单工具和“服务器行为”面板分别添加更新页的最后两个基本构造块。

在您可以添加构造块之前，您的 Web 应用程序必须能够识别要更新的记录，并且您的更新页必须能够检索它。请参见搜索要更新的记录 (ColdFusion)、创建打开更新页的链接 (ColdFusion)、创建用于更新链接的 URL 参数 (ColdFusion) 和检索要更新的记录 (ColdFusion)。

完成更新页由以下三个任务组成：

  • 将 HTML 表单添加到页面以允许用户修改数据。
  • 将表单对象绑定到数据库表列以显示表单中的记录
  • 添加“更新记录”服务器行为以在用户修改记录后更新数据库表。

若要将 HTML 表单添加到更新页，请执行以下操作：

  1. 创建一个新 Coldfusion 页（“文件”>“新建”）。
  2. 使用 Dreamweaver 设计工具对您的页进行布局。
  3. 添加一个 HTML 表单，方法是：将插入点放置在希望表单出现的位置，然后选择“插入”>“表单”>“表单”。

    将在页面上创建一个空表单。您可能需要启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）来查看表单的边界，边界是由红色的细线表示的。

  4. 为 HTML 表单指定名称；方法是单击“文档”窗口底部的 <form> 标签以选中表单，打开“属性”检查器（“窗口”>“属性”），然后在“表单名称”文本框中输入一个名称。

    您不必为表单指定 action 或 method 属性来指示当用户单击“提交”按钮时表单向何处及如何发送记录数据。“更新记录”服务器行为会为您设置这些属性。

  5. 为数据库表中要更新的每一列添加一个表单对象，例如文本字段（“插入”>“表单”>“文本字段”）。

    表单对象用于数据输入。为了实现该目的，经常会使用文本字段，但是您也可以使用菜单、复选框和单选按钮。

    每个表单对象都应该在早先定义的记录集中具有一个对应的列。唯一的例外情况就是唯一键列，该列没有对应的表单对象。

    有关表单对象的更多信息，请参见插入 HTML 表单对象。

  6. 在表单上添加一个“提交”按钮（“插入”>“表单”>“按钮”）。

    可以通过以下方法更改“提交”按钮的标签文字：选择该按钮，打开属性检查器（“窗口”>“属性”），并在“标签文字”文本框中输入一个新值。

若要在表单中显示记录，请执行以下操作：

  1. 确保您定义了一个记录集来保存用户要更新的记录。

    有关更多信息，请参见检索要更新的记录 (ColdFusion)。

  2. 将每个表单对象绑定到记录集中的数据，如以下各节所述：
    • 在 HTML 文本域中显示动态内容
    • 动态预先选择 HTML 复选框
    • 动态预先选择 HTML 单选按钮
    • 创建动态 HTML 表单菜单
    • 使现有 HTML 表单菜单成为动态对象

若要添加服务器行为来更新数据库表，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮并从弹出菜单中选择“更新记录”。

    出现“更新记录”对话框。

  2. 完成对话框。

    有关说明，请参见设置“更新记录”对话框选项 (ColdFusion)。

  3. 单击“确定”。

Dreamweaver 在页中添加服务器行为，允许用户通过单击表单上的“提交”按钮更新数据库中的记录。

若要编辑服务器行为，请打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“更新记录”行为。

相关主题

  • 在一次操作中完成更新页 (ColdFusion)


建立删除记录的页面 (ColdFusion)

您的应用程序可以包含允许用户删除数据库中的记录的一组页。这组页通常由一个搜索页、一个结果页和一个删除页组成。用户可以使用搜索页和结果页检索记录，使用删除页删除记录。

本节介绍了建立用于删除记录的 ColdFusion 页的步骤：

  • 搜索要删除的记录 (ColdFusion)
  • 创建到确认页的链接 (ColdFusion)
  • 创建传递到确认页的 URL 参数 (ColdFusion)
  • 在确认页上显示记录 (ColdFusion)
  • 添加删除记录的逻辑 (ColdFusion)


搜索要删除的记录 (ColdFusion)

当用户要删除某个记录时，他们必须首先在数据库中找到该记录。因此，您需要一个搜索页和一个结果页以便使用删除页。用户在搜索页中输入搜索条件，并在结果页中选择记录。当用户单击该记录时，删除页将打开并在 HTML 表单中显示该记录。

有关创建用于搜索要删除记录的页面的指导，请参见建立搜索/结果页（ColdFusion、ASP、JSP、PHP）。

在创建搜索／结果页之后，下一步是创建结果页上的链接以允许用户选择要删除的记录并显示确认页。请参见创建到确认页的链接 (ColdFusion)。


创建到确认页的链接 (ColdFusion)

创建结果页后（请参见搜索要删除的记录 (ColdFusion)），您必须创建链接，用户可以单击这些链接来确认删除数据库中相关联的记录。本节介绍如何创建此类链接。下一节介绍如何修改该链接，使之同时传递用户要删除的记录的 ID。确认页使用该 ID 来查找并显示该记录。

若要创建指向确认页的链接，请执行以下操作：

  1. 在结果页上，通过以下方式在表格中创建一个新列用于显示记录：在最后一个表格列内单击，然后选择“修改”>“表格”>“插入行或列”。

    即出现“插入行或列”对话框。

  2. 选择“列”选项，然后选择“当前列之后”选项，并单击“确定”。

    Dreamweaver 在表格中添加一列。

  3. 在新创建的表格列中，在包含动态内容占位符的行中输入 Delete 字符串。确保在选项卡式的重复区域内输入该字符串。

    您还可以插入图像，上面带有指示删除的文字或符号。

    如果打开了“动态数据”视图，请在记录的第一行输入该字符串，然后单击“刷新”图标。

  4. 选择 Delete 字符串将一个链接应用于该字符串。

    如果打开了“动态数据”视图，请选择第一行记录中的该字符串。

  5. 在“属性”检查器的“链接”文本框中输入确认页。

    您可以输入任何文件名。

在“链接”文本框外单击后，表格中的 Delete 字符串将显示为已链接。如果启用“动态数据”视图（“查看”>“动态数据”），您可以看到该链接被应用于每个表格行中相同的文本。如果已经打开“动态数据”视图，请单击“刷新”图标将这些链接应用于每一行。

在创建链接后，下一步是创建这些链接的 URL 参数。请参见创建传递到确认页的 URL 参数 (ColdFusion)。


创建传递到确认页的 URL 参数 (ColdFusion)

结果页上的链接不仅要打开确认页，它们还必须传递用户要删除的记录的 ID。确认页将使用此 ID 在数据库中查找该记录并将其显示出来。

您必须使用 URL 参数将记录 ID 传递给确认页。本节介绍如何创建 URL 参数，以将记录 ID 传递给确认页。

若要创建 URL 参数，请执行以下操作：

  1. 在结果页上选择该“删除”链接。

    如果打开了“动态数据”视图，请选择第一行中的链接。

  2. 在“属性”检查器的“链接”文本框中，将下面的字符串添加到 URL 的末尾：
    ?recordID=#recordsetName.fieldName#

    问号将告知服务器接下来是一个或多个 URL 参数。单词“recordID”是 URL 参数的名称（您可以指定任何名称）。记下该 URL 参数的名称，因为接下来会在确认页中用到它。

    等号后的表达式是该参数的值。在本例中，该值由 ColdFusion 表达式生成，该表达式从记录集中返回一个记录 ID。它将为动态表格中的每一行生成一个不同的 ID。在 ColdFusion 表达式中，用您的记录集的名称替换 recordsetName，用记录集中唯一标识每条记录的字段的名称替换 fieldName。大多数情况下，该字段将由一个记录 ID 号组成。在下面的示例中，该字段由唯一位置代码构成：

    confirmDelete.cfm?recordID=#rsLocations.CODE#

    当该页面运行时，记录集的 CODE 字段的值将插入到动态表格中相应的行中。例如，如果澳大利亚堪培拉的租位代码为 CBR，那么下面的 URL 将用于动态表格中有堪培拉的行：

    confirmDelete.cfm?recordID=CBR
  3. 保存该页面。

在创建删除链接的动态 URL 参数后，下一步是在确认页上显示记录。请参见在确认页上显示记录 (ColdFusion)。


在确认页上显示记录 (ColdFusion)

完成用于列出记录的页之后（请参见创建传递到确认页的 URL 参数 (ColdFusion)），切换到确认页。确认页将显示该记录，并询问用户是否确实要删除该记录。当用户单击表单按钮以确认该操作后，Web 应用程序将从数据库中删除该记录。

建立此页分四步：创建 HTML 表单；检索要在表单中显示的记录；在表单中显示记录；添加逻辑以从数据库中删除记录。检索和显示记录分两步：定义一个用来存放单个记录（用户希望删除的记录）的记录集；将该记录集的列绑定到表单。下面详细列出了这些步骤。

若要创建用于显示记录的 HTML 表单，请执行以下操作：

  1. 创建新的 ColdFusion 页，并将它另存为您在上一节指定的确认页。

    您在上一节创建“删除”链接时已经指定了一个确认页。在第一次保存该文件时将使用该名称（如 deleteConfirm.cfm）。

  2. 在页面上插入一个 HTML 表单（“插入”>“表单”>“表单”）。
  3. 在表单中添加一个隐藏的表单字段。

    该隐藏的表单字段是存储 URL 参数传递的记录 ID 所必需的。要添加隐藏字段，请将插入点置于表单中，然后选择“插入”>“表单”>“隐藏字段”。

  4. 在表单上添加按钮。

    用户将单击该按钮以确认并删除所显示的记录。要添加按钮，请将插入点置于表单中，然后选择“插入”>“表单”>“按钮”。

  5. 您可以通过所需的任何方式增强页面的设计然后将其保存。

若要检索用户要删除的记录，请执行以下操作：

  1. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并从弹出式菜单中选择“记录集（查询）”。

    出现简单的“记录集”对话框。如果出现的是高级的“记录集”对话框，请单击“简单”切换到简单的“记录集”对话框。

  2. 命名该记录集，然后选择一个 ColdFusion 数据源和包含用户可删除的记录的数据库表格。
  3. 在“列”区域中，选择要在页面中显示的表列（记录字段）。

    若要只显示记录的某些字段，请单击“已选中”，然后按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 列表中的列，以选择所需字段。

    确保包含记录 ID 字段，即使您不打算显示该字段。

  4. 如下所示完成“筛选”部分，以便查找和显示结果页所传递的 URL 参数中指定的记录：
    • 从“筛选”区域的第一个弹出式菜单中，选择记录集中的列，该列包含的值与带有“删除”链接的页所传递的 URL 参数值相匹配。例如，如果 URL 参数包含一个记录 ID 号，则选择包含记录 ID 号的列。在上一节讨论的示例中，记录集列 CODE 包含的值与带有“删除”链接的页所传递的 URL 参数值相匹配。
    • 从第一个菜单旁边的弹出菜单中选择等号（如果尚未选定）。
    • 从第三个弹出菜单中选择 URL 参数。包含“删除”链接的页使用 URL 参数向确认页传递信息。
    • 在第四个文本框中，输入由带有“删除”链接的页传递的 URL 参数的名称。

      例如，如果用于打开确认页的 URL 包含 confirmDelete.cfm?recordID=CBR 后缀，那么请输入 recordID。

      “记录集”对话框的外观应该如下所示。

  5. 单击“确定”。

记录集随即出现在“绑定”面板中。

若要显示用户要删除的记录，请执行以下操作：

  1. 在“绑定”面板中选择记录集列并将其拖到确认页中。

    请确保您在表单边框内插入该只读动态内容。有关在页面中插入动态内容的更多信息，请参见将文本动态化。

    接着，必须将记录 ID 列绑定到隐藏的表单字段。

  2. 确保启用了“不可见元素”（“查看”>“可视化助理”>“不可见元素”），然后单击代表隐藏表单字段的黄色盾牌图标。

    已选中隐藏表单字段。

  3. 在属性检查器中，单击“值”文本框旁边的闪电图标。

    出现“动态数据”对话框。

  4. 在“动态数据”对话框中，在记录集中选择记录 ID 列。

    在下面的示例中，选择的记录 ID 列是“CODE”。

  5. 单击“确定”，保存该页。

完成后的确认页的外观应如下所示。

在确认页中显示记录后，下一步将添加用来删除记录的逻辑。请参见添加删除记录的逻辑 (ColdFusion)。


添加删除记录的逻辑 (ColdFusion)

在确认页显示出所选记录后（请参见在确认页上显示记录 (ColdFusion)，您必须向该页面添加当用户单击“确认删除”按钮时从数据库中删除该记录的逻辑。在 Dreamweaver 中，使用“删除记录”服务器行为可以快速、方便地添加此逻辑。

若要添加用于删除 HTML 表单中显示的记录的逻辑，请执行以下操作：

  1. 确保确认页在 Dreamweaver 中是打开的。
  2. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后选择“删除记录”。

    出现“删除记录”对话框。

  3. 在“先检查是否定义了变量”文本框中，确保已选中“主键值”。

    随后您将在对话框中指定主键值。

  4. 在“连接”弹出式菜单中，选择一个到该数据库的连接，这样服务器行为就可以连接到该数据库。
  5. 在“表格”弹出菜单中，选择包含要删除的记录的数据库表。
  6. 在“主键列”弹出菜单中，选择包含记录 ID 的表列。

    “删除记录”服务器行为将在此列搜索匹配值。此列与绑定到页面上的隐藏表单字段的记录集列应包含相同的记录 ID 数据。

    如果该记录 ID 是一个数字，请选择“数字”选项。

  7. 在“主键值”弹出菜单中，选择页面上包含记录 ID 的变量，该记录 ID 标识了要删除的记录。

    该变量是由隐藏表单字段创建的。其名称与隐藏字段的 name 属性相同，是一个表单参数或 URL 参数，具体取决于该表单的 method 属性。在此示例中，该变量是名为 hiddenRecID 的表单变量。

  8. 在“删除后，转到”文本框中，指定从数据库表格删除该记录之后打开的页。

    可以指定向用户显示含有简短的成功消息的页，或者指定一个页，在其中列出剩余记录，使用户可以验证该记录是否已被删除。

    完成后的“删除记录”对话框外观应如下所示。

  9. 单击“确定”，保存您的工作。

将这些页上传到 Web 服务器，打开浏览器，然后搜索要删除的记录。当单击结果页上的“删除”链接时，将显示确认页。单击“确认”按钮可从数据库中删除该记录。若要验证该记录是否已被删除，请重新打开带有“删除”链接的页。列表中将不再显示该记录。

注意

如果页上仍然显示该记录，请单击“刷新”。


使用预存过程修改数据库 (ColdFusion)

您可以使用预存过程修改数据库。预存过程是一种可以重复使用的数据库项，用于在数据库上执行某些操作。

注意

MySQL 和 Microsoft Access 数据库不支持预存过程。

在您使用预存过程修改数据库之前，确保预存过程包含以某种方式修改数据库的 SQL。若要在数据库中创建并存储一个 SQL，请查询您的数据库文档和一本好的 Transact-SQL 手册。

若要将预存过程添加到 ColdFusion 页，请执行以下操作：

  1. 在 Dreamweaver 中，打开将运行预存过程的页。
  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮，然后选择“预存过程”。

    出现“预存过程”对话框。

  3. 完成对话框。

    有关更多信息，请参见设置“ColdFusion 预存过程”对话框选项。

  4. 单击“确定”。

在关闭了“预存过程”对话框之后，Dreamweaver 在您的页中插入 ColdFusion 代码，当在服务器上运行该页时，将调用数据库中的预存过程。预存过程接着执行数据库操作，例如插入记录。

如果预存过程接受参数，则您可以创建一个页，该页通过预存过程收集参数值并将参数值提交到页。例如，您可以创建一个使用 URL 参数或 HTML 表单从用户收集参数值的页。

相关主题

  • 预存过程


生成对站点访问进行限制的页（ColdFusion、ASP、JSP、PHP）

您可以使用 Dreamweaver 建立以下对站点访问进行限制的页：

  • 要求用户在首次访问站点时进行注册的页（请参见建立注册页）
  • 让注册用户登录到站点的页（请参见建立登录页）
  • 只有授权用户才能查看的页（请参见建立只有授权用户才能访问的页）

所用方法对于 ColdFusion、ASP、JSP 和 PHP 页完全相同。Dreamweaver 没有针对 ASP.NET 页的身份验证服务器行为。

相关主题

  • 保护应用程序 (ColdFusion) 中的文件夹


建立注册页

Web 应用程序可以包含要求用户在首次访问站点时进行注册的页。

例如，以下页要求首次访问的用户进行注册：

注册页由以下构造块组成：

  • 存储有关用户的登录信息的数据库表（请参见存储有关用户的登录信息）
  • 让用户选择用户名和密码的 HTML 表单（请参见让用户选择用户名和密码）

    您也可以使用该表单来获取用户的其他个人信息。

  • 用于更新站点用户数据库表的“插入记录”服务器行为（请参见更新数据库中的用户表）
  • 用于确保用户输入的用户名没有被其他用户使用的“检查新用户名”服务器行为（请参见确保选择的用户名是唯一的）


存储有关用户的登录信息

注册页需要使用数据库表格来存储用户输入的登录信息。请确保数据库表格包含用户名和密码列。如果您希望登录的用户具有不同的访问权限，请包含一个访问权限列（请参见在用户数据库中存储访问权限）。

如果要为站点的所有用户设置一个通用的密码，请配置数据库应用程序（Microsoft Access、Microsoft SQL Server、Oracle 等），使其在默认情况下将该密码输入到每个新的用户记录中。在大多数数据库应用程序中，每当新建一个记录时，可以将一个列设置为默认值。将该默认值设置为密码。

您还可以使用数据库表格来存储有关用户的其他有用信息。

创建注册页的下一个步骤是向注册页添加一个 HTML 表单，以让用户选择用户名和密码（如果适用）。请参见让用户选择用户名和密码。

相关主题

  • 建立注册页


让用户选择用户名和密码

您可以向注册页添加一个 HTML 表单，以让用户选择用户名和密码（如果适用）。

若要让用户选择用户名和密码，请执行以下操作：

  1. 创建一个新页（“文件”>“新建”），然后使用 Dreamweaver 设计工具设计注册页的布局。
  2. 将插入点放置在您想要显示表单的位置，然后从“插入”菜单中选择“表单”，添加一个 HTML 表单。

    将在页面上创建一个空表单。您可能需要启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）来查看表单的边界，边界是由红色的细线表示的。

  3. 为 HTML 表单指定名称；方法是单击“文档”窗口底部的 <form> 标签以选中表单，打开“属性”检查器（“窗口”>“属性”），然后在“表单名称”文本框中输入一个名称。

    您不必为表单指定 action 或 method 属性来指示当用户单击“提交”按钮时表单向何处及如何发送记录数据。“插入记录”服务器行为会为您设置这些属性（请参见更新数据库中的用户表）。

  4. 添加文本字段（“插入”>“表单”>“文本字段”），以便让用户输入用户名和密码。

    该表单还可以包含更多的表单对象，以记录其他个人数据。

    您应该在每个表单对象的旁边添加标签文字（以文本或图像的形式），让用户知道它们的用途，还应该通过将表单对象放入 HTML 表格来排列这些对象。有关表单对象的更多信息，请参见插入 HTML 表单对象。

  5. 在表单上添加一个“提交”按钮（“插入”>“表单”>“按钮”）。

    可以通过以下方法更改“提交”按钮的标签文字：选择该按钮，打开属性检查器（“窗口”>“属性”），并在“标签文字”文本框中输入一个新值。

创建注册页的下一个步骤是添加“插入记录”服务器行为，以便将记录插入到数据库中的用户表格。请参见更新数据库中的用户表。

相关主题

  • 建立注册页


更新数据库中的用户表

您必须在注册页中添加“插入记录”服务器行为，以更新数据库中的用户表格。

若要更新数据库中的用户表格，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮并从弹出式菜单中选择“插入记录”。

    出现“插入记录”对话框。

  2. 完成此对话框，确保指定数据库中要插入用户数据的用户表格。

    有关说明，请参见下列主题：

    • 设置“插入记录”对话框选项 (ColdFusion)
    • 设置“插入记录”对话框选项（ASP 和 JSP）
    • 设置“插入记录”对话框选项 (PHP)
  3. 单击“确定”。

创建注册页的最后一步是确保用户名没有被其他注册用户使用。请参见确保选择的用户名是唯一的。

相关主题

  • 建立注册页


确保选择的用户名是唯一的

您可以添加一个服务器行为来确保输入的用户名没有被其他注册用户使用。

若要确保选择的用户名是唯一的，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮并从弹出式菜单中选择“用户身份验证”>“检查新用户名”。

    出现“检查新用户名”对话框。

  2. 完成对话框。

    有关说明，请参见设置“检查新用户名”对话框选项。

  3. 单击“确定”。

Dreamweaver 在注册页上添加了一个服务器行为，它将先检查访问者提交的用户名是否是唯一的，然后才将该访问者的信息添加到注册用户数据库中。

当用户单击注册页上的“提交”按钮时，该服务器行为将对用户输入的用户名和存储在注册用户数据库表格中的用户名进行比较。如果没有在数据库表格中找到匹配的用户名，该服务器行为通常会执行插入记录操作。如果找到匹配的用户名，该服务器行为将取消插入记录操作并打开一个新页（通常是提示用户该用户名已被使用的页）。

相关主题

  • 建立注册页


建立登录页

Web 应用程序可以包含让注册用户登录站点的页。

例如，以下页要求注册用户登录：

登录页由以下构造块组成：

  • 注册用户的数据库表（请参见创建注册用户的数据库表）
  • 让用户输入用户名和密码的 HTML 表单（请参见让用户登录）
  • 确保输入的用户名和密码有效的“登录用户”服务器行为（请参见检查用户名和密码）

当用户成功登录时，将为该用户创建一个包含其用户名的阶段变量。


创建注册用户的数据库表

您需要使用注册用户的数据库表格来验证在登录页中输入的用户名和密码是否有效。请使用数据库应用程序和注册页创建该表格。有关更多信息，请参见建立注册页。

建立登录页的下一个步骤是将一个 HTML 表单添加到页面，以允许用户登录。请参见让用户登录。

相关主题

  • 建立登录页


让用户登录

您可以在页上添加一个 HTML 表单，以让用户通过输入用户名和密码来进行登录。

若要让用户登录，请执行以下操作：

  1. 创建一个新页（“文件”>“新建”）并使用 Dreamweaver 设计工具设计登录页的布局。
  2. 将插入点放置在希望表单出现的位置，然后从“插入”菜单中选择“表单”，添加一个 HTML 表单。

    将在页面上创建一个空表单。您可能需要启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）来查看表单的边界，边界是由红色的细线表示的。

  3. 为 HTML 表单指定名称；方法是单击“文档”窗口底部的 <form> 标签以选中表单，打开“属性”检查器（“窗口”>“属性”），然后在“表单名称”文本框中输入一个名称。

    您不必为表单指定 action 或 method 属性来指示当用户单击“提交”按钮时表单向何处及如何发送记录数据。“登录用户”服务器行为会为您设置这些属性（请参见检查用户名和密码）。

  4. 在该表单上添加一个用户名和一个密码文本字段（“插入”>“表单”>“文本字段”）。

    在每个文本字段旁边添加标签（以文本或图像的形式），然后将这些文本字段放入 HTML 表格并将表格的 border 属性设置为 0，以排列这些文本字段。

  5. 在表单上添加一个“提交”按钮（“插入”>“表单”>“按钮”）。

    可以通过以下方法更改“提交”按钮的标签文字：选择该按钮，打开属性检查器（“窗口”>“属性”），并在“标签文字”文本框中输入一个新值。

建立登录页的下一个步骤是添加“登录用户”服务器行为，以确保输入的用户名和密码有效。请参见检查用户名和密码。

相关主题

  • 建立登录页


检查用户名和密码

您必须在登录页中添加“登录用户”服务器行为来确保用户输入的用户名和密码有效。

若要检查用户名和密码，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮并从弹出式菜单中选择“用户身份验证”>“登录用户”。

    出现“登录用户”对话框。

  2. 完成对话框。

    有关说明，请参见设置“登录用户”对话框选项。

  3. 单击“确定”。

Dreamweaver 在登录页上添加了一个服务器行为，它将确保访问者输入的用户名和密码有效。

当用户单击登录页上的“提交”按钮时，“登录用户”服务器行为将对用户输入的值和注册用户的值进行比较。如果这些值匹配，该服务器行为会打开一个页（通常是站点的起始页）。如果这些值不匹配，该服务器行为会打开另一个页（通常是提示用户登录尝试已失败的页）。

相关主题

  • 建立登录页


建立只有授权用户才能访问的页

Web 应用程序可以包含只有授权用户才能访问的受保护页。

注意

Dreamweaver 没有针对 ASP.NET 页的身份验证服务器行为。

例如，如果用户试图通过在浏览器中键入受保护页的 URL 来绕过登录页，则该用户将被重定向到另一页。同样，如果将页的授权级别设置为“管理员”，则只有具有“管理员”访问权限的用户才能查看该页。如果已登录的用户试图访问不具有正确访问权限的受保护页，则该用户将被重定向到另一页。

您也可以使用授权级别在向新注册的用户授予站点的完全访问权限之前对他们进行审查。例如，您可能需要在允许用户访问站点的成员页之前接收付款。为此，可以用“成员”授权级别保护成员页，而仅向新注册的用户授予“来宾”权限。当收到用户的付款后，可以将用户的访问权限升级为“成员”（在注册用户的数据库表格中）。

如果您不打算使用授权级别，只需在页面上添加“限制对页的访问”服务器行为即可保护站点上的任何页。该服务器行为会将尚未成功登录的任何用户重定向到另一页。有关更多信息，请参见将未授权的用户重定向到另一页。

如果您确实打算使用授权级别，则可以用以下构造块保护站点上的任意页：

  • 用于将未授权的用户重定向到另一页的“限制对页的访问”服务器行为（请参见将未授权的用户重定向到另一页）
  • 用户数据库表格中的附加列，用于存储每个用户的访问权限（请参见在用户数据库中存储访问权限）

无论您是否使用授权级别，均可以在受保护的页上添加一个链接，让用户注销并清除任何阶段变量。有关更多信息，请参见注销用户。


将未授权的用户重定向到另一页

为了防止未授权的用户访问某一页，可以在该页上添加“限制对页的访问”服务器行为。如果用户试图通过在浏览器中键入受保护页的 URL 来绕过登录页，或者如果用户已登录但试图访问不具有正确访问权限的受保护页，该服务器行为就会将用户重定向到另一页。

注意

“限制对页的访问”服务器行为只能保护 HTML 页。它不保护其他站点资源，如图像文件和音频文件。

如果要为站点上的多个页授予相同的访问权限，可以复制一个页的访问权限，然后将其粘贴到另一个页。

若要将未授权的用户重定向到另一页，请执行以下操作：

  1. 打开要保护的页。
  2. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮并从弹出式菜单中选择“用户身份验证”>“限制对页的访问”。

    出现“限制对页的访问”对话框。

  3. 完成对话框。

    有关说明，请参见设置“限制对页的访问”对话框选项。

  4. 单击“确定”。

Dreamweaver 在页上添加了一个服务器行为，它只允许授权用户查看该页。

若要复制一个页的访问权限并将其粘贴到站点的其他页上，请执行以下操作：

  1. 打开受保护的页并选择在“服务器行为”面板中列出的“限制对页的访问”服务器行为（而不是加号 (+) 弹出式菜单中的这一服务器行为）。
  2. 单击该面板右上角的箭头按钮，然后从弹出式菜单中选择“复制”。

    “限制对页的访问”服务器行为被复制到系统的剪贴板上。

  3. 按照同一方式打开另一个要保护的页。
  4. 在“服务器行为”面板（“窗口”>“服务器行为”）上，单击右上角的箭头按钮并从弹出式菜单中选择“粘贴”。
  5. 对于每个要保护的页重复第 3 步和第 4 步。

相关主题

  • 在用户数据库中存储访问权限


在用户数据库中存储访问权限

只有在需要让某些登录用户具有不同的访问权限时，该构造块才是必需的。如果您只是要求用户登录，则不需要存储访问权限。

如果您需要让某些登录用户具有不同的访问权限，请确保用户数据库表格包含一个特定的列，该列指定每个用户的访问权限（“来宾”、“用户”、“管理员”等）。每个用户的访问权限应该由站点管理员在数据库中输入。

在大多数数据库应用程序中，每当新建一个记录时，可以将一个列设置为默认值。将该默认值设置为站点上最常用的访问权限（例如“来宾”）；然后手动更改例外的情况（例如，将“来宾”更改为“管理员”）。用户现在即可访问所有管理员页。

确保数据库中的每个用户都具有单一的访问权限（例如“来宾”或“管理员”），而不是多项权限（例如“用户、管理员”）。如果要为您的页设置多项访问权限（例如，所有来宾和管理员都可以查看该页），则在页级别（而不是在数据库级别）设置这些权限。

相关主题

  • 将未授权的用户重定向到另一页


注销用户

当用户成功登录后，将创建一个包含其用户名的阶段变量。当用户退出站点时，可以使用“注销用户”服务器行为来清除该阶段变量并将用户重定向到另一页（通常是“再见”或“谢谢”页）。

当用户单击链接或者当指定页加载时，可以调用“注销用户”服务器行为。

若要添加用于让用户注销的链接，请执行以下操作：

  1. 在页上选择要用作该链接的文本或图像。
  2. 在“服务器行为”面板（“窗口”>“行为”）上，单击加号 (+) 按钮并选择“用户身份验证”>“注销用户”。

    出现“注销用户”对话框。

  3. 指定在用户单击该链接时要打开的页。

    该页通常是“再见”或“谢谢”页。

  4. 单击“确定”。

若要在特定页加载时注销用户，请执行以下操作：

  1. 打开将在 Dreamweaver 中加载的页。

    该页通常是“再见”或“谢谢”页。

  2. 在“服务器行为”面板上，单击加号 (+) 按钮并选择“用户身份验证”>“注销用户”。

    出现“注销用户”对话框。

  3. 选择“当页载入时注销”选项。
  4. 单击“确定”。

相关主题

  • 建立只有授权用户才能访问的页


保护应用程序 (ColdFusion) 中的文件夹

可以使用 Dreamweaver 对 ColdFusion 应用程序中的特定文件夹（包括应用程序的根文件夹）进行密码保护。当站点访问者请求指定的文件夹中的任何页面时，ColdFusion 都会提示该访问者输入用户名和密码。ColdFusion 将用户名和密码存储在阶段变量中，因此访问者无需在会话过程中再次输入用户名和密码。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要保护服务器上的文件夹或站点，请执行以下操作：

  1. 在 Dreamweaver 中打开 Coldfusion 文档后，选择“命令”>“ColdFusion 登录向导”。
  2. 完成 ColdFusion 登录向导。

    有关说明，请单击向导中的“帮助”按钮。

    该向导创建保护文件夹所需的文件。

  3. 将新文件上传到远端站点。

    这些文件位于本地站点文件夹中。

相关主题

  • 生成对站点访问进行限制的页（ColdFusion、ASP、JSP、PHP）


使用 ColdFusion 组件

ColdFusion 组件 (CFC) 使您可以将应用程序和商业逻辑封装成独立的、可重用的单元。CFC 还提供了一种创建 Web 服务的快速而简单的方法。

可以使用 Dreamweaver 创建和修改 CFC，也可以使用 Dreamweaver 构建使用 CFC 的网页。

注意

CFC 只能用于 Macromedia ColdFusion MX 或更高版本。ColdFusion 5 不支持 CFC。

本节包含以下主题：

  • 关于 ColdFusion 组件
  • 在 Dreamweaver 中以可视方式创建组件
  • 在 Dreamweaver 中查看 ColdFusion 组件
  • 在 Dreamweaver 中编辑 ColdFusion 组件
  • 构建使用 ColdFusion 组件的网页
  • 在 ColdFusion 组件中定义记录集
  • 将 CFC 记录集用作动态内容源


关于 ColdFusion 组件

ColdFusion 组件是用 ColdFusion 标记语言 (CFML) 编写的可重用软件单元。CFC 能够帮助您使代码可重用并易于维护。

本节介绍 CFC 的优点。后面章节介绍 Dreamweaver 如何帮助您使用 CFC。有关 CFC 标签和语法的信息，请参见 Dreamweaver 中的 ColdFusion 文档（“帮助”>“使用 ColdFusion”）。

ColdFusion 组件旨在为开发人员提供一种简单而强大的方法来封装 Web 站点的元素。通常，您应该将组件用于应用程序或商业逻辑。对表示元素（如自定义的问候、动态菜单等）使用自定义标签。

与许多其他类型的构造相比，动态站点经常能从可互换的部分受益。例如，动态站点可以重复运行同一个查询，或者计算购物车页上的总价格，并在每次添加项目时重新计算总价格。这些任务可由组件来完成。您可以在对应用程序的其他部分影响最小的情况下修复、改进、扩展甚至替换某个组件。

假设一家网上商店根据订单价格计算运费。低于 $20 的订单运费为 $4；在 $20 至 $40 之间的订单运费为 $6，等等。您可以在购物车页和结帐页中同时插入计算运费的逻辑，但那样会将 HTML 表示代码和 CFML 逻辑代码混合在一起，并且通常会使代码难以维护和重复使用。

您决定创建一个称作 Pricing 的 ColdFusion 组件，该组件中有一个称作 ShippingCharge 的函数。该函数将价格作为参数并返回运费。例如，如果参数值为 32.80，则函数返回 6。

在购物车页和结帐页中都插入一个特殊标签来调用 ShippingCharge 函数。请求其中任何一种页面时，都调用该函数并将运费返回到该页面。

如果后来商店宣布了一种特殊的促销方法：$100 以上的所有订单免费送货。您只要在一个地方 －Pricing 组件的 ShippingCharge 函数 － 更改送货费用，使用该函数的所有页面都将自动得到精确的运费。


在 Dreamweaver 中以可视方式创建组件

您可以使用 Dreamweaver 可视地定义一个 ColdFusion 组件及其函数。Dreamweaver 将创建 .cfc 文件并为您插入必要的 CFML 标签。

注意

根据组件的不同，您可能需要手动完成某些代码。

若要可视地创建 ColdFusion 组件，请执行以下操作：

  1. 在 Dreamweaver 中打开 ColdFusion 页面。
  2. 在“组件”面板（“窗口”>“组件”）中，从弹出式菜单中选择“CF 组件”。
  3. 在“组件”面板中，单击加号 (+) 按钮。

    打开“创建组件”对话框。

  4. 完成对话框设置，然后单击“确定”。

    有关更多信息，请参见设置“创建组件”对话框选项。

Dreamweaver 编写一个 .cfc 文件并将其保存在您指定的文件夹中。新组件还出现在“组件”面板中（单击“刷新”后）。

若要删除一个组件，您必须手动从服务器中删除 .cfc 文件。

相关主题

  • 关于 ColdFusion 组件
  • 在 Dreamweaver 中查看 ColdFusion 组件
  • 在 Dreamweaver 中编辑 ColdFusion 组件
  • 构建使用 ColdFusion 组件的网页


在 Dreamweaver 中查看 ColdFusion 组件

Dreamweaver 提供一种方法，以可视方式对站点文件夹中或服务器上的 ColdFusion 组件 (CFC) 进行总体检查。Dreamweaver 读取 .cfc 文件并在“组件”面板中以一种易于导航的树状视图显示有关信息。

Dreamweaver 在测试服务器中查找组件（请参见指定可在哪里处理动态页）。如果创建新的 CFC 或对现有 CFC 进行更改，请确保将 CFC 文件上传到测试服务器，以便这些文件能在“组件”面板中准确地反映出来。

如果要查看位于其他服务器的组件，请更改测试服务器的设置。

您可以查看有关 CF 组件的下列任何信息：

  • 列出服务器上定义的所有 ColdFusion 组件。
  • 如果运行的是 ColdFusion MX 7 或更高版本，则筛选该列表以便仅显示位于站点文件夹的 CFC。
  • 研究每个组件的函数和参数。
  • 检查用作 Web 服务的函数的属性。

若要在 Dreamweaver 中查看 ColdFusion 组件，请执行以下操作：

  1. 在 Dreamweaver 中打开任何一个 ColdFusion 页。
  2. 在“组件”面板（“窗口”>“组件”）中，从弹出式菜单中选择“CF 组件”。
  3. 单击面板中的“刷新”按钮以检索组件。

    Dreamweaver 显示服务器中的组件包。组件包 就是包含 CFC 文件的文件夹。

    如果现有组件包没有显示，则单击面板工具栏中的“刷新”按钮。

  4. 若要仅显示站点文件夹中的 CFC，请在“组件”面板工具栏中单击“仅显示当前站点的 CFC”按钮。

    仅当将运行 ColdFusion MX 6 或更高版本的计算机定义为 Dreamweaver 的测试服务器时，才能使用此功能。有关更多信息，请参见启用 ColdFusion 增强功能。

    注意

    如果当前站点在远端服务器上的虚拟文件夹中列出，则筛选操作无效。
  5. 单击组件包名称旁边的加号 (+) 按钮以查看包中存储的组件。
    • 若要列出某个组件的函数，请单击该组件名称旁边的加号 (+) 按钮。
    • 若要查看函数采用的参数、参数类型以及它们是必需的还是可选的，请在树状视图中打开该函数的分支。

      没有参数的函数旁边没有加号 (+) 按钮。

    • 若要快速查看参数、函数、组件或包的详细信息，请在树状视图中选择相应项，然后单击面板工具栏中的“获取详细信息”按钮。

      还可以右键单击相应项 (Windows) 或在按住 Control 键同时单击相应项 (Macintosh)，然后从弹出式菜单中选择“获取详细信息”。

      Dreamweaver 在消息框中显示有关所选项的详细信息。

相关主题

  • 关于 ColdFusion 组件
  • 在 Dreamweaver 中以可视方式创建组件
  • 在 Dreamweaver 中编辑 ColdFusion 组件
  • 构建使用 ColdFusion 组件的网页


在 Dreamweaver 中编辑 ColdFusion 组件

Dreamweaver 提供了一种简化的方法来编辑为您的站点定义的 ColdFusion 组件的代码。例如，您无须离开 Dreamweaver 即可添加、更改或删除任何组件函数。

若要使用此功能，您的开发环境必须按如下方式进行设置：

  • ColdFusion 必须在本地运行。
  • 在 Dreamweaver 的高级“站点定义”对话框中，“测试服务器”类别中指定的“访问类型”必须是“本地/网络”。
  • 在高级“站点定义”对话框中，您的本地根文件夹的路径必须与测试服务器文件夹的路径相同（例如 c:\Inetpub\wwwroot\cf_projects\myNewApp\）。您可以通过选择“站点”>“编辑站点”来检查和更改这两个路径。
  • 组件必须存储在硬盘上的本地站点文件夹或该文件夹的任何子文件夹中。

在 Dreamweaver 中打开任意 ColdFusion 页面，并在“组件”面板中显示组件。若要显示组件，请打开“组件”面板（“窗口”>“组件”），从面板的弹出式菜单中选择“CF 组件”，然后单击面板上的“刷新”按钮。

ColdFusion 是在本地运行的，因此 Dreamweaver 可显示硬盘中的组件包。有关更多信息，请参见在 Dreamweaver 中查看 ColdFusion 组件。

若要编辑组件，请执行以下操作：

  1. 在 Dreamweaver 中打开任意 ColdFusion 页面，并在“组件”面板（“窗口”>“组件”）中显示组件。
  2. 从面板的弹出式菜单中选择“CF 组件”，然后单击面板上的“刷新”按钮。

    ColdFusion 是在本地运行的，因此 Dreamweaver 可显示硬盘中的组件包。有关更多信息，请参见在 Dreamweaver 中查看 ColdFusion 组件。

  3. 若要编辑某个组件文件，通常需要打开包并在树状视图中双击该组件的名称。

    Dreamweaver 在“代码”视图中打开组件的文件。

  4. 若要编辑特定的函数、参数或属性，请在树状视图中双击相应项。
  5. 在“代码”视图中手动进行更改。
  6. 保存文件（“文件”>“保存”）。

若要查看“组件”面板中的任何新函数，请单击面板工具栏中的“刷新”按钮来刷新视图。


构建使用 ColdFusion 组件的网页

在网页中使用组件函数的一种方法是在页面中写入该页面被请求时可以调用函数的代码。您可以使用 Dreamweaver 来帮助编写此代码。

注意

有关使用组件的其他方法，请参见 Dreamweaver 中的 ColdFusion 文档（“帮助”>“使用 ColdFusion”）。

若要在网页中使用 ColdFusion 组件，请执行以下操作：

  1. 在 Dreamweaver 中，打开将使用组件函数的 ColdFusion 页面。
  2. 切换到“代码”视图（“查看”>“代码”）。
  3. 打开“组件”面板（“窗口”>“组件”），然后从面板的弹出式菜单中选择“CF 组件”。
  4. 找到需要的组件并使用下列方法之一将其插入：
    • 将一个函数从树状视图拖动到页面中。Dreamweaver 在页面中插入代码以调用函数。
    • 在面板中选择该函数并单击面板工具栏中的“插入”按钮（右边的第二个按钮）。Dreamweaver 在页面中的插入点处插入代码。
  5. 如果插入的是带参数的函数，请手动完成参数代码。

    有关更多信息，请参见 Dreamweaver 中的 ColdFusion 文档（“帮助”>“使用 ColdFusion”）。

  6. 保存页面（“文件”>“保存”）。


在 ColdFusion 组件中定义记录集

Dreamweaver 可以帮助您在 ColdFusion 组件 (CFC) 中定义记录集（也称为 ColdFusion 查询）。通过在 CFC 中定义记录集，则无需在使用该记录集的每个页面上都进行定义。在 CFC 中定义记录集一次，即可在不同页面上使用该 CFC。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要在 ColdFusion 组件中定义记录集，请执行以下操作：

  1. 在 Dreamweaver 中创建 CFC 文件或打开现有的 CFC 文件。

    有关更多信息，请参见在 Dreamweaver 中以可视方式创建组件。

  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并从弹出式菜单中选择“记录集（查询）”。

    出现“记录集”对话框。您既可使用简单“记录集”对话框，也可使用高级“记录集”对话框。

  3. 如果要使用 CFC 中的某个现有函数，请从“函数”弹出式菜单中选择该函数并跳到步骤 6。

    记录集是在函数中定义的。

  4. 如果要在 CFC 中定义新的函数，请单击“新函数”按钮，在出现的对话框中输入函数的名称，然后单击“确定”。

    名称只能包含字母、数字和下划线字符 (_)。不能使用特殊字符或空格。

  5. 使用“记录集”对话框定义函数的记录集。

    有关更多信息，请单击对话框上的“帮助”按钮。

    完成之后，Dreamweaver 将新函数插入到定义该记录集的 CFC 中。

    若要以可视方式编辑 CFC 记录集，请在“绑定”面板中双击该记录集。

相关主题

  • 将 CFC 记录集用作动态内容源


将 CFC 记录集用作动态内容源

如果某个 ColdFusion 组件 (CFC) 包含定义记录集的函数，则可以将该组件用作页面的动态内容源。有关创建此类型的 CFC 的更多信息，请参见在 ColdFusion 组件中定义记录集。

仅当您对运行 ColdFusion MX 7 或更高版本的计算机具有访问权限时，才能使用此功能。有关更多信息，请参见启用 ColdFusion 增强功能。

若要将 CFC 记录集用作动态内容源，请执行以下操作：

  1. 在 Dreamweaver 中打开 ColdFusion 页面。
  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并从弹出式菜单中选择“记录集（查询）”。

    出现“记录集”对话框。您既可使用简单“记录集”对话框，也可使用高级“记录集”对话框。

  3. 单击“CFC 查询”按钮。

    出现“CFC 查询”对话框。

  4. 完成对话框。

    有关说明，请单击对话框中的“帮助”按钮。

  5. 单击“确定”关闭“CFC 查询”对话框，然后再次单击“确定”将 CFC 记录集添加到“绑定”面板中的可用内容源列表中。
  6. 使用“绑定”面板将记录集绑定到各种页面元素。

    有关更多信息，请参见向 Web 页中添加动态内容。

相关主题

  • 在 ColdFusion 组件中定义记录集


参考资料

本节说明本章中介绍的以下对话框和面板：

  • 设置 CFForm 属性 (ColdFusion)
  • 设置 CFTextField 属性 (ColdFusion)
  • 设置 CFHiddenField 属性 (ColdFusion)
  • 设置 CFTextArea 属性 (ColdFusion)
  • 设置 CFButton 属性 (ColdFusion)
  • 设置 CFCheckBox 属性 (ColdFusion)
  • 设置 CFRadioButton 属性 (ColdFusion)
  • 设置 CFSelect 属性 (ColdFusion)
  • 设置 CFImageField 属性 (ColdFusion)
  • 设置 CFFileField 属性 (ColdFusion)
  • 设置 CFDateField 属性 (ColdFusion)
  • 设置“主详细页集”对话框选项
  • 设置“插入记录表单”对话框选项
  • 设置“表单元素属性”对话框选项
  • 设置“插入记录”对话框选项（ASP 和 JSP）
  • 设置“插入记录”对话框选项 (PHP)
  • 设置“插入记录”对话框选项 (ColdFusion)
  • 设置“插入记录”对话框选项 (ASP.NET)
  • 设置“更新记录表单”对话框选项
  • 设置“更新记录”对话框选项 (ColdFusion)
  • 设置“删除记录”对话框选项 (ColdFusion)
  • 设置“ColdFusion 预存过程”对话框选项
  • 设置“预存过程变量”对话框选项
  • 设置“检查新用户名”对话框选项
  • 设置“登录用户”对话框选项
  • 设置“限制对页的访问”对话框选项
  • 设置“定义访问级别”对话框选项
  • 设置“注销用户”对话框选项
  • 设置“ColdFusion 登录向导”选项
  • 设置“创建组件”对话框选项
  • 设置“CF 组件”面板选项
  • 设置“CFC 查询”对话框选项
  • 设置“新组件”对话框选项
  • 设置“编辑参数”对话框选项


设置 CFForm 属性 (ColdFusion)

使用此“属性”检查器设置 ColdFusion 表单的属性。

若要设置 CFForm 属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    CFForm 设置表单的名称。

    动作指定在提交表单时要处理的 ColdFusion 页面的名称。

    方法定义浏览器用来将表单数据发送给服务器的方法：

    • POST 使用 HTTP post 方法发送数据；此方法将单个消息中的数据发送给服务器。
    • GET 使用 HTTP get 方法发送数据，将表单字段内容放置在 URL 查询字符串中。

    目标用于修改 cfform 标签的目标属性的值。

    编码类型指定用来传输表单数据的编码方法。

    注意

    编码类型指的不是字符编码。此属性指定用于将表单提交给服务器的内容类型（如果方法的值为 post）。此属性的默认值为 application/x-www-form-urlencoded。

    格式确定要创建的表单的类型，如下所示：

    • HTML 生成 HTML 表单并将其发送给客户端。cfgrid 和 cftree 子控件可以使用 Flash 或 applet 格式。
    • Flash 生成 Macromedia Flash 表单并将其发送给客户端。所有控件都使用 Flash 格式。
    • XForm 生成 XForms XML 并将结果放置在具有 ColdFusion 表单名称的变量中。不向客户端发送任何内容。cfgrid 和 cftree 子控件可以使用 Flash 或 applet 格式。

    样式指定表单的样式。有关更多信息，请参见 ColdFusion 文档。

    Flash/XML 外观指定 Macromedia 光晕颜色，以便样式化输出。该主题确定用于高亮显示和所选元素的颜色。

    保留数据确定在表单发送到自身时是否用提交值覆盖初始控件值。

    • 如果为 False，则使用在控件标签属性中指定的值。
    • 如果为 True，则使用提交的值。

    脚本源文件指定 JavaScript 文件（包含标签及其子标签使用的客户端代码）相对于 Web 根目录的 URL。如果该文件不在默认位置，则此属性十分有用。在某些阻止对 /CFIDE 目录进行访问的主机环境和配置中，可能需要此属性。默认位置在“ColdFusion 管理员”中设置；默认情况下为 /CFIDE/scripts/cfform.js。

    存档为 cfgrid、cfslider 和 cftree applet 控件指定可下载 Java 类的 URL。默认位置为 /CFIDE/classes/cfapplets.jar。

    高度指定表单的高度。

    宽度指定表单的宽度。

    显示标签编辑器编辑未在“属性”检查器中列出的属性。

相关主题

  • 创建 ColdFusion 表单
  • 验证 ColdFusion 表单数据


设置 CFTextField 属性 (ColdFusion)

使用此“属性”检查器设置 ColdFusion 文本字段的属性。

若要设置 CFTextField 属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    CFtextfield 设置 <cfinput> 标签的 id 属性。

    值指定当页面在浏览器中第一次打开时要在字段中显示的文本。它既可以是静态信息，也可以是动态信息。

    若要指定动态值，请单击“值”文本框旁的闪电图标，然后在“动态数据”对话框中选择一个记录集列。在浏览器中查看表单时，该记录集列向文本字段提供一个值。

    文本模式用于在标准文本输入字段和密码输入字段之间进行切换。由此控件修改的属性为 type。

    只读将显示文本设置为只读。

    最大长度设置文本字段可以接受的最多字符数。

    掩码为所请求的文本指定掩码。此属性可用于验证用户输入。掩码格式由 A、9、X 和 ? 字符组成。

    注意

    如果是 cfinput type="password" 标签，则忽略掩码属性。

    验证为当前字段指定验证类型。

    验证于指定字段的验证时间：onSubmit、onBlur 或 onServer。

    标签为文本字段指定标签。

    模式指定 JavaScript 正则表达式模式以验证输入。省略前导斜杠和结尾斜杠。有关更多信息，请参见 ColdFusion 文档。

    高度指定控件的高度（以像素为单位）。

    宽度指定控件的宽度（以像素为单位）。

    大小指定控件的大小。

    必需指定在将表单提交给服务器前文本字段是否必须包含数据。

    显示标签编辑器编辑未在“属性”检查器中列出的属性。

相关主题

  • 插入 ColdFusion 文本字段


设置 CFHiddenField 属性 (ColdFusion)

使用此“属性”检查器设置 ColdFusion 隐藏字段的属性。

若要设置 CFHiddenField 属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    Cfhiddenfield 为隐藏字段指定唯一名称。

    值为隐藏字段指定值。它既可以是静态数据，也可以是动态数据。

    若要指定动态值，请单击“值”文本框旁的闪电图标，然后在“动态数据”对话框中选择一个记录集列。在浏览器中查看表单时，该记录集列向文本字段提供一个值。

    验证为当前字段指定验证类型。

    验证于指定字段的验证时间：onSubmit、onBlur 或 onServer。

    标签为控件指定标签。ColdFusion 服务器在运行时忽略此属性。

    模式指定 JavaScript 正则表达式模式以验证输入。省略前导斜杠和结尾斜杠。有关更多信息，请参见 ColdFusion 文档。

    高度指定控件的高度（以像素为单位）。ColdFusion 服务器在运行时忽略此属性。

    宽度指定控件的宽度（以像素为单位）。ColdFusion 服务器在运行时忽略此属性。

    大小指定控件的大小。ColdFusion 服务器在运行时忽略此属性。

    必需指定在将表单提交给服务器前隐藏字段是否必须包含数据。

    显示标签编辑器编辑未在“属性”检查器中列出的属性。

相关主题

  • 插入 ColdFusion 隐藏字段


设置 CFTextArea 属性 (ColdFusion)

使用此“属性”检查器设置 ColdFusion 文本区域的属性。

若要设置 CFTextArea 属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    Cftextarea 为控件指定唯一名称。

    字符宽度设置每行的字符数。

    行数设置文本区域显示的行数。

    换行指定用户输入文本如何换行。

    必需指定用户是（已选中）否（未选中）必须在字段中输入数据。

    初始值指定当页面最初在浏览器中打开时要在文本区域中显示的文本。

    验证为字段指定验证类型。

    验证于指定字段的验证时间：onSubmit、onBlur 或 onServer。

    标签为控件指定标签。

    样式指定控件的样式。有关更多信息，请参见 ColdFusion 文档。

    高度指定控件的高度（以像素为单位）。ColdFusion 服务器在运行时忽略此属性。

    宽度指定控件的宽度（以像素为单位）。ColdFusion 服务器在运行时忽略此属性。

    显示标签编辑器编辑未在“属性”检查器中列出的属性。

相关主题

  • 插入 ColdFusion 文本区域


设置 CFButton 属性 (ColdFusion)

使用此“属性”检查器设置 ColdFusion 按钮的属性。

若要设置 CFButton 属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    Cfbutton 为控件指定唯一名称。

    动作指定要创建的按钮的类型。

    显示标签编辑器编辑未在“属性”检查器中列出的属性。

ColdFusion 服务器在运行时忽略其他属性。

相关主题

  • 插入 ColdFusion 按钮
  • 验证 ColdFusion 表单数据


设置 CFCheckBox 属性 (ColdFusion)

使用此“属性”检查器设置 ColdFusion 复选框的属性。

若要设置 CFCheckBox 属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    Cfcheckbox 为控件指定唯一名称。

    选定值指定在用户选中复选框时由复选框返回的值。

    初始状态指定当页面在浏览器中第一次打开时是否选中复选框。

    验证为复选框指定验证类型。

    验证于指定复选框的验证时间：onSubmit、onBlur 或 onServer。

    标签为复选框指定标签。

    模式指定 JavaScript 正则表达式模式以验证输入。省略前导斜杠和结尾斜杠。有关更多信息，请参见 ColdFusion 文档。

    高度指定控件的高度（以像素为单位）。ColdFusion 服务器在运行时忽略此属性。

    宽度指定控件的宽度（以像素为单位）。ColdFusion 服务器在运行时忽略此属性。

    大小指定控件的大小。ColdFusion 服务器在运行时忽略此属性。

    必需指定在将表单提交给服务器前是否必须选中复选框。

    显示标签编辑器编辑未在“属性”检查器中列出的属性。

相关主题

  • 插入 ColdFusion 复选框
  • 验证 ColdFusion 表单数据


设置 CFRadioButton 属性 (ColdFusion)

使用此“属性”检查器设置 ColdFusion 单选按钮的属性。

若要设置 CFRadioButton 属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    Cfradiobutton 为控件指定唯一名称。

    选定值指定在用户选中单选按钮时由该单选按钮返回的值。

    初始状态指定当页面在浏览器中第一次打开时是否选中单选按钮。

    验证为单选按钮指定验证类型。

    验证于指定单选按钮的验证时间：onSubmit、onBlur 或 onServer。

    标签为单选按钮指定标签。

    模式指定 JavaScript 正则表达式模式以验证输入。省略前导斜杠和结尾斜杠。有关更多信息，请参见 ColdFusion 文档。

    高度指定控件的高度（以像素为单位）。ColdFusion 服务器在运行时忽略此属性。

    宽度指定控件的宽度（以像素为单位）。ColdFusion 服务器在运行时忽略此属性。

    大小指定控件的大小。ColdFusion 服务器在运行时忽略此属性。

    必需指定在将表单提交给服务器前是否必须选中单选按钮。

    显示标签编辑器编辑未在“属性”检查器中列出的属性。

相关主题

  • 插入 ColdFusion 单选按钮
  • 验证 ColdFusion 表单数据


设置 CFSelect 属性 (ColdFusion)

使用此“属性”检查器设置 ColdFusion 选择框的属性。

若要设置 CFSelect 属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    Cfselect 为控件指定唯一名称。

    类型用于在弹出式菜单或列表之间进行选择。如果选择列表类型，则可使用“列表高度”和“允许选择多个列表”选项。

    列表高度指定要在列表菜单中显示的行数。仅当选择列表类型时才可用。

    允许选择多个列表指定用户是否可以从列表中一次选择多个选项。仅当选择列表类型时才可用。

    编辑值打开一个对话框，使用该对话框可以添加、编辑或删除选择框中的选项。

    初始化时选定指定默认选择的选项。如果选择“允许选择多个列表”选项，则可以选择多个选项。

    记录集指定用于填充列表或菜单的 ColdFusion 查询的名称。

    显示列指定记录集列以提供每个列表元素的显示标签。用于“记录集”属性。

    值列指定记录集列以提供每个列表元素的值。用于“记录集”属性。

    Flash 标签为选择框指定标签。

    Flash 高度指定控件的高度（以像素为单位）。ColdFusion 服务器在运行时忽略此属性。

    Flash 宽度指定控件的宽度（以像素为单位）。ColdFusion 服务器在运行时忽略此属性。

    消息指定在将“必需”属性设置为“是”且用户在提交表单前未进行选择时要显示的消息。

    必需指定在将表单提交给服务器前是否必须选择一个菜单项。

    显示标签编辑器编辑未在“属性”检查器中列出的属性。

相关主题

  • 插入 ColdFusion 选择框
  • 验证 ColdFusion 表单数据


设置 CFImageField 属性 (ColdFusion)

使用此“属性”检查器设置 ColdFusion 图像字段的属性。

若要设置 CFImageField 属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    Cfimagefield 为控件指定唯一名称。

    源文件指定插入的图像的 URL。

    Alt 指定图像无法显示时的消息。

    对齐指定图片的对齐方式。

    边框指定图像边框的宽度。

    编辑图像在默认图像编辑器中打开图像。

    若要定义默认图像编辑器，请选择“编辑”>“首选参数”>“文件类型/编辑器”。否则，“编辑图像”按钮不执行任何动作。

    验证为图像字段指定验证类型。

    验证于指定字段的验证时间：onSubmit、onBlur 或 onServer。

    标签为单选按钮指定标签。

    模式指定 JavaScript 正则表达式模式以验证输入。省略前导斜杠和结尾斜杠。有关更多信息，请参见 ColdFusion 文档。

    高度指定控件的高度（以像素为单位）。

    宽度指定控件的宽度（以像素为单位）。

    大小指定控件的大小。ColdFusion 服务器在运行时忽略此属性。

    必需指定在将表单提交给服务器前控件是否必须包含数据。

    显示标签编辑器编辑未在“属性”检查器中列出的属性。

相关主题

  • 插入 ColdFusion 图像字段
  • 验证 ColdFusion 表单数据


设置 CFFileField 属性 (ColdFusion)

使用此“属性”检查器设置 ColdFusion 文件上传字段的属性。

若要设置 CFFileField 属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    Cffilefield 为控件指定唯一名称。

    最大长度指定文件路径可以包含的最多字符数。

    验证为字段指定验证类型。

    验证于指定字段的验证时间：onSubmit、onBlur 或 onServer。

    标签为字段指定标签。

    模式指定 JavaScript 正则表达式模式以验证输入。省略前导斜杠和结尾斜杠。有关更多信息，请参见 ColdFusion 文档。

    高度指定控件的高度（以像素为单位）。ColdFusion 服务器在运行时忽略此属性。

    宽度指定控件的宽度（以像素为单位）。ColdFusion 服务器在运行时忽略此属性。

    大小指定控件的大小。

    必需指定在将表单提交给服务器前文件域是否必须包含数据。

    显示标签编辑器编辑未在“属性”检查器中列出的属性。

相关主题

  • 插入 ColdFusion 文件域
  • 验证 ColdFusion 表单数据


设置 CFDateField 属性 (ColdFusion)

使用此“属性”检查器设置 ColdFusion 日期字段的属性。

若要设置 CFDateField 属性，请执行以下操作：

  • 在“属性”检查器中设置以下任一选项：

    Cfdatefield 为控件指定唯一名称。

    值指定当页面在浏览器中第一次打开时要在字段中显示的日期。它既可以是静态日期，也可以是动态日期。

    若要指定动态值，请单击“值”文本框旁的闪电图标，然后在“动态数据”对话框中选择一个记录集列。在浏览器中查看表单时，该记录集列向日期字段提供一个值。

    验证为字段指定验证类型。

    验证于指定字段的验证时间：onSubmit、onBlur 或 onServer。

    标签为字段指定标签。

    模式指定 JavaScript 正则表达式模式以验证输入。省略前导斜杠和结尾斜杠。有关更多信息，请参见 ColdFusion 文档。

    高度指定控件的高度（以像素为单位）。

    宽度指定控件的宽度（以像素为单位）。

    大小指定控件的大小。

    必需指定在将表单提交给服务器前日期字段是否必须包含值。

    显示标签编辑器编辑未在“属性”检查器中列出的属性。

相关主题

  • 插入 ColdFusion 日期字段
  • 验证 ColdFusion 表单数据


设置“主详细页集”对话框选项

此对话框用于创建主页和相应的详细页。只有在 ColdFusion、ASP、PHP 或 JSP 站点上工作时，才能使用该应用程序对象。

若要设置对话框的选项，请执行以下操作：

  1. 在“记录集”弹出式菜单中，确保已选择了包含要在主页上显示的记录的记录集。
  2. 在“主页字段”区域，选择要在主页上显示的记录集列。

    默认情况下，Dreamweaver 选择记录集中的所有列。如果记录集包含唯一键列，如 recordID，则将其选定并单击减号 (-) 按钮使之不在页面上显示。

  3. 若要更改列在主页上的显示顺序，请选择列表中的列并单击向上或向下箭头。

    在主页上，记录集列在表格中水平排列。单击向上箭头可将列向左移动；单击向下箭头可将列向右移动。

  4. 在“以此链接到详细信息”弹出式菜单中，选择记录集中的一个列，该列将显示一个值并且该值也用作到详细页的链接。

    例如，如果要使主页上的每个产品名称都有一个到详细页的链接，请选择包含产品名称的记录集列。

  5. 在“传递唯一键”弹出式菜单中，选择记录集中包含标识记录的值的列。

    通常，所选的列就是记录 ID 号。此值被传递到详细页使之能够标识用户所选的记录。

  6. 如果唯一键列不是数值，请取消选择“数值”复选框。

    注意

    默认情况下选择此选项；并非所有型号的服务器都显示该选项。
  7. 指定要在主页上显示的记录数。
  8. 在“详细页名称”文本框中，单击“浏览”并找到已创建的详细页文件，或输入一个名称让应用程序对象创建一个详细页文件。
  9. 在“详细页字段”区域，选择要在详细页上显示的列。

    默认情况下，Dreamweaver 选择主页的记录集中的所有列。如果该记录集包含唯一键列，如 recordID，则将其选定并单击减号 (-) 按钮使之不在详细页上显示。

  10. 若要更改列在详细页上的出现顺序，请选择列表中的列并单击向上或向下箭头。

    在详细页上，记录集列在表格中垂直排列。单击向上箭头可将列向上移动；单击向下箭头可将列向下移动。

  11. 单击“确定”。

    应用程序对象创建一个详细页（如果尚未创建），并且同时向主页和详细页中添加动态内容和服务器行为。

相关主题

  • 在一次操作中生成主/详细页（ColdFusion、ASP、JSP、PHP）


设置“插入记录表单”对话框选项

此对话框用于生成一个使用户可以在数据库中插入新记录的页。

若要设置对话框的选项，请执行以下操作：

  1. 在“连接”弹出菜单中，选择一个到数据库的连接。

    如果您需要定义连接，则单击“定义”按钮。

  2. 在“插入到表格”弹出式菜单中，选择应向其插入记录的数据库表格。
  3. 如果使用 ColdFusion，则输入用户名和密码。
  4. 在“插入后，转到”文本框中，输入将记录插入表格后要打开的页面，或单击“浏览”按钮浏览到该文件。
  5. 如果使用 ASP.NET，则可以指定一个成功时转到的页面和一个失败时转到的页面。您也可以选择在失败时显示调试信息。

    如果选择“失败时显示调试信息”，则 Dreamweaver 将忽略“如果失败，则转到”选项。

    提示

    在开发过程中使用“失败时显示调试信息”选项，并在页面处于活动状态时使用“如果失败，则转到”选项。
  6. 在“表单字段”区域中，指定要包括在插入页面的 HTML 表单上的表单对象，以及每个表单对象应该更新数据库表格中的哪些列。

    默认情况下，Dreamweaver 为数据库表格中的每个列创建一个表单对象。如果您的数据库为创建的每个新记录都自动生成唯一键 ID，则需删除对应于该键列的表单对象，方法是在列表中将其选中然后单击减号 (-) 按钮。这消除了表单的用户输入已存在的 ID 值的风险。

    您还可以更改 HTML 表单上表单对象的顺序，方法是在列表中选中某个表单对象然后单击对话框右侧的向上或向下箭头。

  7. 指定每个数据输入字段在 HTML 表单上的显示方式；方法是单击“表单字段”表格中的一行，然后在表格下面的框中输入以下信息：
    • 在“标签文字”框中，输入显示在数据输入字段旁边的描述性标签文字。默认情况下，Dreamweaver 在该标签中显示表列的名称。
    • 在“显示为”弹出菜单中，选择一个表单对象充当数据输入字段。您可以选择“文本字段”、“文本区域”、“菜单”、“复选框”、“单选按钮组”和“文本”。对于只读项，请选择“文本”。您还可以选择“密码字段”、“文件域”和“隐藏字段”。

      注意

      “隐藏字段”插入在表单的结尾。
    • 在“提交为”弹出式菜单中，选择您的数据库表格接受的数据格式。例如，如果表列只接受数字数据，则选择“数字”。
    • 设置表单对象的属性。根据您选择作为数据输入字段的表单对象的不同，您有不同的选项。对于文本字段、文本区域和文本，您可以输入初始值。对于菜单和单选按钮组，将打开另一个对话框来设置属性。对于复选框，选择“已选中”或“未选中”选项。
    • 如果使用 ASP.NET，则可以选择使用 Web 表单控件。
  8. 单击“确定”。

Dreamweaver 将 HTML 表单和“插入记录”服务器行为添加到页面。

相关主题

  • 用一次操作建立插入页
  • 插入动态 HTML 表单对象


设置“表单元素属性”对话框选项

此对话框用于设置页上表单元素的属性以允许用户更新数据库中的记录。

若要设置对话框的选项，请执行以下操作：

  1. 根据计划创建表单元素的方式，选择“手动”或“来自数据库”。
  2. 单击加号 (+) 按钮添加元素。
  3. 为该元素输入标签和值。
  4. 在“选取值等于”文本框中，如果要在浏览器中打开页面时或在表单中显示记录时选择特定的元素，则输入一个等于该元素值的值。

    您可以输入静态值，或者通过单击闪电图标，然后从数据源列表中选择一个动态值来指定动态值。无论在何种情况下，所指定的值都应该与元素值之一匹配。


设置“插入记录”对话框选项（ASP 和 JSP）

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表中插入记录。

在添加此服务器行为之前，页面中必须包含带有“提交”按钮的 HTML 表单。

若要设置对话框的选项，请执行以下操作：

  1. 在“连接”弹出菜单中，选择一个到数据库的连接。

    如果您需要定义连接，则单击“定义”按钮。

  2. 在“插入到表格”弹出式菜单中，选择应向其插入记录的数据库表格。
  3. 在“插入后，转到”文本框中，输入在将记录插入表格后要打开的页面或单击“浏览”浏览到该文件。
  4. 在“获取值自”弹出式菜单中，选择用于输入数据的 HTML 表单。

    Dreamweaver 自动选择页面上的第一个表单。

  5. 指定要向其中插入记录的数据库列，从“值”弹出式菜单中选择将插入记录的表单对象，然后从“提交为”弹出式菜单中为该表单对象选择数据类型。

    数据类型是数据库表中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  6. 单击“确定”。

Dreamweaver 将服务器行为添加到特定页面，该页面允许用户通过填写 HTML 表单并单击“提交”按钮在数据库表格中插入记录。

相关主题

  • 逐块生成插入页


设置“插入记录”对话框选项 (PHP)

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表中插入记录。

在添加此服务器行为之前，页面中必须包含带有“提交”按钮的 HTML 表单。

若要设置对话框的选项，请执行以下操作：

  1. 从“提交值，自”弹出菜单中选择一个表单。
  2. 在“连接”弹出菜单中，选择一个到数据库的连接。
  3. 在“插入表格”弹出式菜单中，选择要向其中插入记录的数据库表格。
  4. 指定要向其中插入记录的数据库列，从“值”弹出式菜单中选择将插入记录的表单对象，然后从“提交为”弹出式菜单中为该表单对象选择数据类型。

    数据类型是数据库表中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  5. 在“插入后，转到”文本框中，输入将记录插入表格后要打开的页面或单击“浏览”按钮浏览到该文件。
  6. 单击“确定”。

Dreamweaver 将服务器行为添加到特定页面，该页面允许用户通过填写 HTML 表单并单击“提交”按钮在数据库表格中插入记录。

相关主题

  • 逐块生成插入页


设置“插入记录”对话框选项 (ColdFusion)

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表中插入记录。

在添加此服务器行为之前，页面中必须包含带有“提交”按钮的 HTML 表单。

若要设置对话框的选项，请执行以下操作：

  1. 从“提交值，自”弹出菜单中选择一个表单。
  2. 在“数据源”弹出式菜单中，选择一个到数据库的连接。
  3. 输入您的用户名和密码。
  4. 在“插入到表格”弹出式菜单中，选择要向其中插入记录的数据库表格。
  5. 指定要向其中插入记录的数据库列，从“值”弹出式菜单中选择将插入记录的表单对象，然后从“提交为”弹出式菜单中为该表单对象选择数据类型。

    数据类型是数据库表中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  6. 在“插入后，转到”文本框中，输入将记录插入表格后要打开的页面或单击“浏览”按钮浏览到该文件。
  7. 单击“确定”。

Dreamweaver 将服务器行为添加到特定页面，该页面允许用户通过填写 HTML 表单并单击“提交”按钮在数据库表格中插入记录。

相关主题

  • 逐块生成插入页


设置“插入记录”对话框选项 (ASP.NET)

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表中插入记录。

在添加此服务器行为之前，页面中必须包含带有“提交”按钮的 HTML 表单。

若要设置对话框的选项，请执行以下操作：

  1. 从“提交值，自”弹出菜单中选择一个表单。
  2. 在“连接”弹出菜单中，选择一个到数据库的连接。

    如果您需要定义连接，则单击“定义”按钮。

  3. 在“插入到表格”弹出式菜单中，选择要向其中插入记录的数据库表格。
  4. 指定要向其中插入记录的数据库列，从“值”弹出式菜单中选择将插入记录的表单对象，然后从“提交为”弹出式菜单中为该表单对象选择数据类型。

    数据类型是数据库表中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  5. 在“如果成功，则转到”文本框中，输入服务器行为成功运行后所显示的页的位置或单击“浏览”按钮浏览到该位置。
  6. 在“如果失败，则转到”文本框中，输入如果服务器行为失败所显示的页的位置或单击“浏览”按钮浏览到该位置。
  7. 如果要在服务器行为失败时显示调试信息，则选择“失败时显示调试信息”复选框。

    如果选择了此选项，则 Dreamweaver 将忽略“如果失败，则转到”选项。

    提示

    在开发过程中使用调试选项，在站点处于活动状态时使用“如果失败，则转到”选项。
  8. 单击“确定”。

Dreamweaver 将服务器行为添加到特定页面，该页面允许用户通过填写 HTML 表单并单击“提交”按钮在数据库表格中插入记录。

相关主题

  • 逐块生成插入页


设置“更新记录表单”对话框选项

此对话框用于建立一个允许用户更新数据库中记录的页。

在开始之前，您必须完成以下任务：

  • 建立一个或多个页使用户可以查找要更新的记录。有关更多信息，请参见搜索要更新的记录 (ColdFusion)。
  • 将逻辑添加到更新页，允许它从数据库中检索用户选定的记录，准备进行更新。有关说明，请参见检索要更新的记录 (ColdFusion)。

实现了这些前提条件之后，您可以按以下步骤完成该对话框。

若要设置对话框的选项，请执行以下操作：

  1. 在“连接”弹出菜单中，选择一个到数据库的连接。

    如果您需要定义连接，则单击“定义”按钮。

  2. 在“要更新的表格”弹出式菜单中，选择包含要更新的记录的数据库表格。
  3. 在“选取记录自”弹出式菜单中，指定包含显示在 HTML 表单上的记录的记录集。
  4. 在“唯一键列”弹出菜单中，选择一个键列（通常是记录 ID 列）来标识数据库表中的记录。

    如果该值是一个数字，则选择“数字”选项。键列通常只接受数值，但有时候也接受文本值。

  5. 在“更新后，转到”文本框中，输入在表格中更新记录之后要打开的页面。
  6. 在“表单字段”区域中，指定每个表单对象应该更新数据库表格中的哪些列。

    默认情况下，Dreamweaver 为数据库表格中的每个列创建一个表单对象。如果您的数据库为创建的每个新记录都自动生成唯一键 ID，则需删除对应于该键列的表单对象，方法是在列表中将其选中然后单击减号 (-) 按钮。这消除了表单的用户输入已存在的 ID 值的风险。

    您还可以更改 HTML 表单上表单对象的顺序，方法是在列表中选中某个表单对象然后单击对话框右侧的向上或向下箭头。

  7. 指定每个数据输入字段在 HTML 表单上的显示方式；方法是单击“表单字段”表格中的一行，然后在表格下面的框中输入以下信息：
    • 在“标签文字”框中，输入显示在数据输入字段旁边的描述性标签文字。默认情况下，Dreamweaver 在该标签中显示表列的名称。
    • 在“显示为”弹出菜单中，选择一个表单对象充当数据输入字段。您可以选择“文本字段”、“文本区域”、“菜单”、“复选框”、“单选按钮组”和“文本”。对于只读项，请选择“文本”。您还可以选择“密码字段”、“文件域”和“隐藏字段”。

      注意

      “隐藏字段”插入在表单的结尾。
    • 在“提交为”弹出菜单中，选择您的数据库表需要的数据格式。例如，如果表列只接受数字数据，则选择“数字”。
    • 设置表单对象的属性。根据您选择作为数据输入字段的表单对象的不同，您有不同的选项。对于文本字段、文本区域和文本，您可以输入初始值。对于菜单和单选按钮组，将打开另一个对话框来设置属性。对于复选框，选择“已选中”或“未选中”选项。
  8. 通过选择另一个表单字段行并输入标签文字、显示为值和提交为值来设置其他表单对象的属性。

    对于菜单和单选按钮组，打开另一个对话框来设置属性。对于复选框，定义一个复选框当前记录的值和给定值之间的比较，以确定当显示记录时是否选中了该复选框。

  9. 单击“确定”。

Dreamweaver 将 HTML 表单和“更新记录”服务器行为添加到您的页中。

相关主题

  • 在一次操作中完成更新页 (ColdFusion)
  • 插入动态 HTML 表单对象


设置“更新记录”对话框选项 (ColdFusion)

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表中更新记录。

在开始之前，您必须完成以下任务：

  • 建立一个或多个页使用户可以查找要更新的记录。有关更多信息，请参见搜索要更新的记录 (ColdFusion)。
  • 将逻辑添加到更新页，允许它从数据库中检索用户选定的记录，准备进行更新。有关说明，请参见检索要更新的记录 (ColdFusion)。
  • 将 HTML 表单添加到更新页以允许用户修改数据。有关说明，请参见逐块完成更新页 (ColdFusion)。

实现了这些前提条件之后，您可以完成“更新记录”对话框。

若要设置对话框的选项，请执行以下操作：

  1. 从“提交值，自”弹出菜单中选择一个表单。
  2. 在“数据源”弹出式菜单中，选择一个到数据库的连接。
  3. 如果可行，则输入您的用户名和密码。
  4. 在“更新表格”弹出菜单中，选择包含您正在更新的记录的数据库表。
  5. 指定要更新的数据库列，从“值”弹出菜单中选择将更新该列的表单对象，从“提交为”弹出菜单中为该表单对象选择数据类型，并且如果要将此列标识为主键，还应选择“主键”。

    数据类型是数据库表中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  6. 在“更新后，转到”文本框中，输入在表格中更新记录后将要打开的页面或单击“浏览”按钮浏览到该文件。
  7. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过修改显示在 HTML 表单中的信息并单击“提交”按钮更新数据库表中的记录。

相关主题

  • 逐块完成更新页 (ColdFusion)


设置“删除记录”对话框选项 (ColdFusion)

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表中删除记录。

若要设置对话框的选项，请执行以下操作：

  1. 在“先检查是否定义了变量”弹出菜单中，选择“主键值”。

    如果您要检查一个变量（该变量不是标识要删除记录的那个变量），则选中该变量，然后输入其名称。

    Dreamweaver 检查是否定义了该变量。

  2. 在“数据源”弹出式菜单中，选择一个到数据库的连接。
  3. 输入您的用户名和密码。
  4. 在“表格”弹出菜单中，选择包含要删除的记录的数据库表。
  5. 在“主键列”弹出菜单中，选择一个键列在数据库表中标识该记录。

    如果该值是一个数字，则选择“数字”选项。键列通常只接受数值，但有时候也接受文本值。

  6. 在“主键值”弹出菜单中，选择标识要删除记录的变量，然后输入其名称。
  7. 在“删除后，转到”文本框中，输入在从数据库表格中删除记录后打开的页或单击“浏览”按钮浏览到该文件。
  8. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过单击表单上的“提交”按钮删除数据库表中的记录。


设置“ColdFusion 预存过程”对话框选项

此对话框用于将预存过程插入您的 ColdFusion 页中。

若要设置对话框的选项，请执行以下操作：

  1. 在“数据源”弹出式菜单中，选择一个到包含预存过程的数据库的连接。
  2. 输入 ColdFusion 数据源用户名和密码。
  3. 从“过程”弹出菜单中选择一个预存过程。

    Dreamweaver 自动填写任何参数。

  4. 如果需要进行更改，则选择某个参数，然后单击“编辑”按钮。

    即会出现“编辑预存过程变量”对话框。若要完成此对话框，请参见设置“预存过程变量”对话框选项。

    注意

    您必须为任何预存过程输入参数输入测试值。
  5. 如果预存过程采用参数，则单击加号 (+) 按钮添加页参数。

    即会出现“添加参数”对话框。若要完成此对话框，请参见设置“添加参数”对话框选项。

    注意

    您必须为每个预存过程参数返回值输入对应的页参数。除非有对应的返回值，否则不要添加页参数。

    如果需要，再次单击加号 (+) 按钮添加另一个页参数。

  6. 选择一个页参数，然后单击减号 (-) 按钮删除该参数（如果需要）或单击“编辑”对该参数进行更改。

    即会出现“编辑参数”对话框。若要完成此对话框，请参见设置“添加参数”对话框选项。

  7. 选择“返回具有以下名称的记录集”复选框，然后输入记录集的名称；如果预存过程返回记录集，则单击“测试”按钮查看预存过程返回的记录集。

    Dreamweaver 运行预存过程并显示记录集（如果存在）。

    注意

    如果预存过程返回记录集并采用参数，则您必须在“变量”±框的“默认值”列中输入一个值以测试该预存过程。

    提示

    您可以使用不同的测试值生成不同的记录集。如果要更改测试值，则单击“参数”的“编辑”按钮，然后更改测试值；或者单击“页参数”的“编辑”按钮，然后更改默认值。
  8. 如果预存过程返回状态代码返回值，则选择“返回具有以下名称的状态代码”复选框，然后输入状态代码的名称。
  9. 单击“确定”。

在关闭了“预存过程”对话框之后，Dreamweaver 在您的页中插入 ColdFusion 代码，当在服务器上运行该页时，将调用数据库中的预存过程。预存过程接着执行数据库操作，例如插入记录。

相关主题

  • 预存过程
  • 使用预存过程修改数据库 (ColdFusion)


设置“预存过程变量”对话框选项

此对话框用于添加或编辑预存过程参数。

若要设置对话框的选项，请执行以下操作：

  1. 正在编辑的变量名显示在“名称”文本框中。
  2. 从弹出式菜单中选择一个方向。

    预存过程可能具有输入值、输出值、或者既具有输入值又具有输出值。

  3. 从弹出式菜单中选择一个 SQL 类型。
  4. 输入返回变量。
  5. 输入运行时值。
  6. 输入测试值。

相关主题

  • 设置“ColdFusion 预存过程”对话框选项
  • 使用预存过程修改数据库 (ColdFusion)


设置“检查新用户名”对话框选项

此对话框用于在用户注册页上添加一个服务器行为，它将先验证访问者提交的用户名是唯一的，然后才将该访问者添加到注册用户数据库中。

在开始之前，您必须完成以下任务：

  • 在注册页上添加一个 HTML 表单，以便让用户选择用户名和密码。有关说明，请参见让用户选择用户名和密码。
  • 在页上添加“插入记录”服务器行为，用以更新包含注册用户登录信息的数据库。有关说明，请参见更新数据库中的用户表。

实现了这些前提条件之后，您可以按以下步骤完成该对话框。

若要设置对话框的选项，请执行以下操作：

  1. 在“用户名字段”弹出式菜单中，选择访问者用来输入用户名的表单文本字段。
  2. 在“如果已存在，则转到”文本框中，指定在数据库表格中找到匹配的用户名时所打开的页。

    所打开的页应提示用户该用户名已被使用，并且让用户重试。

  3. 单击“确定”。

当用户单击注册页上的“提交”按钮时，该服务器行为将对用户输入的用户名和存储在注册用户数据库表格中的用户名进行比较。如果没有在数据库表格中找到匹配的用户名，该服务器行为通常会执行插入记录操作。如果找到匹配的用户名，该服务器行为将取消插入记录操作并打开一个新页（通常是提示用户该用户名已被使用的页）。

相关主题

  • 确保选择的用户名是唯一的
  • 建立注册页


设置“登录用户”对话框选项

此对话框用于在登录页上添加一个服务器行为，它确保访问者输入的用户名和密码有效。

在开始之前，必须先在登录页上添加一个 HTML 表单，用以让用户输入用户名和密码。有关说明，请参见让用户登录。当具备该先决条件后，就可以按如下方式完成“登录用户”对话文本框。

若要设置对话框的选项，请执行以下操作：

  1. 指定访问者在输入用户名和密码时所使用的表单和表单对象。
  2. 如果使用 ColdFusion，则请输入您的用户名和密码（如果可行）。
  3. 指定包含所有注册用户的用户名和密码的数据库表格和列。

    该服务器行为将对访问者在登录页上输入的用户名及密码和这些列中的值进行比较。

  4. 指定在登录过程成功时所打开的页。

    所指定的页通常是站点的起始页。

  5. 指定在登录过程失败时所打开的页。

    所指定的页通常会提示用户登录过程已失败，并且让用户重试。

  6. 如果要让用户在试图访问受限页时前进到登录页，并且在登录后返回到该受限页，请选择“转到前一 URL”选项。

    如果用户未先登录就试图通过打开受限页来访问站点，则受限页可以使该用户前进到登录页。当用户成功登录后，登录页会将该用户重定向到原来使用户前进到登录页的受限页。

    当您在这些页上完成“限制对页的访问”服务器行为的对话框后，请确保在“如果访问被拒绝，则转到”文本框中指定登录页。有关更多信息，请参见设置“限制对页的访问”对话框选项。

  7. 指定是仅根据用户名和密码还是同时根据授权级别来授予对该页的访问权。

    有关更多信息，请参见建立只有授权用户才能访问的页。

  8. 单击“确定”。

当用户单击登录页上的“提交”按钮时，“登录用户”服务器行为将对用户输入的值和注册用户的值进行比较。如果这些值匹配，该服务器行为会打开一个页（通常是站点的起始页）。如果这些值不匹配，该服务器行为会打开另一个页（通常是提示用户登录过程已失败的页）。

相关主题

  • 检查用户名和密码
  • 建立登录页


设置“限制对页的访问”对话框选项

此对话框用于在页上添加一个服务器行为，它只允许授权用户查看该页。

若要设置对话框的选项，请执行以下操作：

  1. 如果您只希望让具有特定访问权限的用户查看该页，请选中“用户名、密码和访问级别”选项并指定该页的授权级别。

    例如，通过在授权级别列表中选择“管理员”，可以指定只有那些具有“管理员”权限的用户才能查看该页。

    若要在该列表中添加授权级别，请单击“定义”。在出现的“定义访问级别”列表中，输入一个新的授权级别并单击加号 (+) 按钮。Dreamweaver 会存储该级别，使您不必为每个页逐一键入该级别。确保您输入的字符串精确匹配用户数据库中的字符串。

  2. 如果要为一个页设置多个授权级别，请按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 该列表中的级别。

    例如，您可以指定任何具有“来宾”、“成员”或“管理员”权限的用户都能够查看该页。

  3. 指定在未授权用户试图打开受保护页时所打开的页。

    确保您选择的页本身并不受保护。

  4. 单击“确定”。

Dreamweaver 添加服务器行为，如果用户试图通过在浏览器中键入受保护页的 URL 来绕过注册页，或者如果用户已登录但试图访问不具有相应访问权限的受保护页，该服务器行为就会将用户重定向到另一页。

相关主题

  • 将未授权的用户重定向到另一页
  • 建立只有授权用户才能访问的页


设置“定义访问级别”对话框选项

此对话框用于在“限制对页的访问”对话框的授权级别列表中添加授权级别。

若要设置对话框的选项，请执行以下操作：

  1. 在“名称”文本框中，输入新的授权级别。

    确保该授权级别的字符串精确匹配存储在数据库中的字符串。例如，如果数据库中的授权列包含值 “Administrator”，则请在“名称”文本框中输入 Administrator（而不是 Admin）。

  2. 单击加号 (+) 按钮，将该授权级别添加到列表中。
  3. 单击“确定”返回到“限制对页的访问”对话框。

Dreamweaver 会存储新建的授权级别，以用于其他页。

相关主题

  • 设置“限制对页的访问”对话框选项
  • 将未授权的用户重定向到另一页
  • 建立只有授权用户才能访问的页


设置“注销用户”对话框选项

此对话框用于注销用户并清除在用户登录时创建的会话变量。

当用户单击链接或者当指定页加载时，可以调用“注销用户”服务器行为。

若要设置对话框的选项，请执行以下操作：

  1. 如果已选择文本或图像作为注销链接，则指定在用户单击该链接时所打开的页。

    该页通常是“再见”或“谢谢”页。

  2. 如果要在页加载时注销用户，请选择“当页载入时注销”选项。
  3. 单击“确定”。

Dreamweaver 将在页上添加该服务器行为。

相关主题

  • 注销用户


设置“ColdFusion 登录向导”选项

此对话框用于使用密码保护服务器上的文件夹或站点。

若要设置向导的选项，请执行以下操作：

  1. 指定要保护的文件夹的完整路径，然后单击“下一步”。
  2. 在下一个屏幕中，选择以下验证类型之一：
    • 简单验证用所有用户都能使用的同一用户名和密码保护应用程序。
    • Windows NT 验证使用 NT 用户名和密码保护应用程序。
    • LDAP 验证用存储在 LDAP 服务器上的用户名和密码保护应用程序。
  3. 指定希望用户使用 ColdFusion 登录页还是通过弹出提示框进行登录。
  4. 在下一个屏幕中，指定以下设置：
    • 如果选择了简单验证，则指定每个访问者必须输入的用户名和密码。
    • 如果选择了 Windows NT 验证，则指定要验证的 NT 域。
    • 如果选择了 LDAP 验证，则指定要验证的 LDAP 服务器。
  5. 单击“下一步”创建保护文件夹所需的文件。

    向导列出新文件。

  6. 将新文件上传到远端站点。

    这些文件位于本地站点文件夹中。

相关主题

  • 保护应用程序 (ColdFusion) 中的文件夹


设置“创建组件”对话框选项

此对话框用于创建新的 ColdFusion 组件。

有关该对话框中每个字段的可能值的更多信息，请参见 Dreamweaver 中的 ColdFusion 文档（“帮助”>“使用 ColdFusion”）。

若要创建新的 ColdFusion 组件，请执行以下操作：

  1. 在“组件”部分输入组件的详细信息。

    只能使用字母、数字或下划线。

    “名称”框指定 .cfc 文件名。输入名称时不要指定 .cfc 文件扩展名。

    “组件目录”框指定将要保存该组件的位置。选择 Web 应用程序的根文件夹（如 \Inetpub\wwwroot\myapp\）或它的任何子文件夹。

  2. 如果您想为该组件定义一个或多个函数，请从“部分”列表中选择“函数”，单击加号 (+) 按钮，然后输入新函数的详细信息。

    提示

    如果您从“访问”菜单中选择“远程”，则该函数可用作 Web 服务。

    请确保在“返回值类型”框中指定该函数返回的值的类型。

  3. 如果您想为函数定义一个或多个参数，请从“部分”列表中选择“参数”，从弹出式菜单中选择该函数，单击加号 (+) 按钮，然后在右边输入新参数的详细信息。
  4. 单击“确定”创建该组件。
  5. 如果使用的是远程开发服务器，请将 CFC 文件和任何相关文件（如那些用于实现函数或包含文件的文件）上传到该远程服务器。

    上传文件可以确保 Dreamweaver 的功能（如“动态数据”视图和“在浏览器中预览”）正常工作。

相关主题

  • 在 Dreamweaver 中以可视方式创建组件
  • 关于 ColdFusion 组件


设置“CF 组件”面板选项

此面板用于查看和编辑 ColdFusion 组件。您还可以使用此面板向页面添加代码以调用某个组件的函数。

注意

只有在 Dreamweaver 中查看 ColdFusion 页时，此面板才可用。

您可以使用此对话框执行以下任务：

  • 在 Dreamweaver 中查看 ColdFusion 组件
  • 在 Dreamweaver 中编辑 ColdFusion 组件
  • 构建使用 ColdFusion 组件的网页

相关主题

  • 关于 ColdFusion 组件
  • 在 Dreamweaver 中查看 ColdFusion 组件


设置“CFC 查询”对话框选项

此对话框用于使用包含记录集定义的 ColdFusion 组件在 Dreamweaver 中将记录集定义为动态内容源。

若要设置对话框的选项，请执行以下操作：

  1. 在“名称”文本框中，输入 CFC 记录集的名称。

    通常的做法是在记录集名称前添加前缀 rs，以将其与代码中的其他对象名称区分开。例如：rsPressRelease。

    记录集名称只能包含字母、数字和下划线 (_)。不能使用特殊字符或空格。

  2. 从服务器上已定义的包中选择一个包。

    如果该包未出现在弹出式菜单中，则可以通过单击弹出式菜单附近的“刷新”按钮来刷新包的列表。

    确保首先将 CFC 上传到测试服务器。只有测试服务器上的 CFC 才能被显示出来。

  3. 从当前选择的包中所定义的组件中选择一个组件。

    如果“组件”弹出式菜单不包含任何组件，或是如果没有任何您以前创建的组件出现在该菜单中，则应将 CFC 文件上传到测试服务器。

  4. 如果要创建新组件，请单击“创建新组件”按钮。

    即会出现“新组件”对话框。有关更多信息，请参见设置“新组件”对话框选项。

  5. 从“函数”弹出式菜单中，选择包含记录集定义的函数。

    “函数”弹出式菜单仅包含当前选定组件中定义的函数。如果没有任何函数出现在此弹出式菜单中，或是如果您最近的更改未反映在当前列出的函数中，请检查是否已将最近的更改保存并上传到了服务器。

    注意

    “连接”和“SQL”文本框是只读的。
  6. 通过单击“编辑”按钮来编辑每个必须作为函数参数传递的参数（类型、值和默认值）。

    即会出现“编辑参数”对话框。有关更多信息，请参见设置“编辑参数”对话框选项。

    您不能修改记录集的数据库连接和 SQL 查询。这些字段始终禁用 ó 连接和 SQL 查询仅为提供信息而显示。

  7. 单击“测试”连接到数据库并创建一个记录集实例。

    如果 SQL 语句包含页参数，则在单击“测试”前，请确保“参数”框的“默认值”列包含有效的测试值。

    如果查询执行成功，则会有一个表显示该记录集。每行包含一条记录，而每列表示该记录中的一个域。

    单击“确定”清除 CFC 查询。

  8. 单击“确定”。

相关主题

  • 将 CFC 记录集用作动态内容源


设置“新组件”对话框选项

此对话框用于创建新的 ColdFusion 组件。

若要设置对话框的选项，请执行以下操作：

  1. 在“名称”文本框中，输入新 CFC 的名称。

    仅接受字母数字字符和下划线 (_)。

  2. 在“组件目录”文本框中，输入 CFC 的放置位置。

    也可以使用“浏览”按钮更方便地定位文件夹。

    注意

    文件夹必须为站点根文件夹的相对路径。

相关主题

  • 设置“CFC 查询”对话框选项


设置“编辑参数”对话框选项

此对话框用于编辑 SQL 语句的参数。

若要设置对话框的选项，请执行以下操作：

  1. 为当前参数输入一个值，方法是从“值”弹出式菜单中选择值类型并在右侧的文本框中输入值。

    值类型可以为 URL 参数、表单变量、Cookie、阶段变量、应用程序变量或输入的值。

  2. 在“默认值”文本框中输入该参数的默认值。

    如果未返回任何运行时值，则使用该默认参数值。

  3. 单击“确定”。

相关主题

  • 设置“CFC 查询”对话框选项


快速生成 ASP.NET 应用程序

使用 Macromedia Dreamweaver 8 中的工具可以快速生成 ASP.NET Web 应用程序，只需很少甚至不需要编码。

本章包含下列章节：

生成 ASP.NET 表单

创建 ASP.NET 数据网格和数据列表 Web 控件

生成主/详细页 (ASP.NET)

生成数据库搜索页 (ASP.NET)

生成记录插入页 (ASP.NET)

生成用以更新记录的页面 (ASP.NET)

生成用以删除记录的页 (ASP.NET)

使用预存过程修改数据库 (ASP.NET)

生成对站点访问进行限制的页 (ASP.NET)

相关主题

  • 关于快速应用程序开发（所有服务器）


生成 ASP.NET 表单

您可以在 Dreamweaver 设计环境中创建 ASP.NET 表单，然后修改表单控件的属性，而不必手工编写其代码。

本节包含以下主题：

  • 将 ASP.NET 表单控件添加到页面
  • 设置 ASP.NET 表单控件的属性
  • 创建动态 ASP.NET 菜单
  • 使现有 ASP.NET 菜单成为动态对象
  • 在 ASP.NET 文本框控件中显示动态内容
  • 动态预先选择 ASP.NET 复选框控件
  • 在 ASP.NET 单选按钮列表中动态预先选择一项

相关主题

  • 创建表单
  • 插入动态 HTML 表单对象


将 ASP.NET 表单控件添加到页面

您可以在 Dreamweaver 中使用可视化设计环境将 ASP.NET 表单控件添加到您的页面中。

若要将 ASP.NET 表单控件添加到页面，请执行以下操作：

  1. 在“设计”视图（“查看”>“设计”）中打开一个 ASP.NET 页面。
  2. 将插入点放在希望表单控件在页面上出现的位置。

    必须将表单控件插入到具有 runat='server' 标签属性的表单中。如果在页面中没有表单，则当您插入第一个 ASP.NET 表单控件时，Dreamweaver 会自动创建一个标签中具有 runat='server' 属性的表单。如果页面包含 HTML 表单，则当插入第一个表单控件时，Dreamweaver 会自动将 runat='server' 属性添加到现有的表单标签中。

  3. 在“插入”栏的“ASP.NET”类别中，选择表单控件的图标。
  4. 完成控件对话框。

    有关说明，请单击对话框中的“帮助”按钮。有关每个控件的属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconaspsyntaxforwebcontrols.asp 中的文档。

完成后，Dreamweaver 在页面中插入表单控件。如果需要，可在页面上单击该控件，然后在属性检查器中更改其任一属性。

相关主题

  • 设置 ASP.NET 表单控件的属性


设置 ASP.NET 表单控件的属性

您可以在设计环境中修改 ASP.NET 表单控件的属性。

若要在设计环境中修改 ASP.NET 表单控件的属性，请执行以下操作：

  1. 在“设计”视图中，选择页面上的表单控件。

    属性检查器将显示该控件的属性。

  2. 修改属性检查器中的控件属性。

    有关每个控件的属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconaspsyntaxforwebcontrols.asp 中的文档。

  3. 若要设置更多属性，请单击“属性”检查器中“标签编辑器”按钮，然后在出现的标签编辑器中设置属性。

    在标签编辑器中，您可以设置更多属性，包括事件。


创建动态 ASP.NET 菜单

可以使用数据库项动态地填充 ASP.NET 菜单控件，如“下拉列表”或“列表框”。

在开始之前，必须为菜单定义一个数据集或其它动态内容源。有关更多信息，请参见定义记录集。

若要在 ASP.NET 页面中插入动态菜单，请执行以下操作：

  1. 打开 ASP.NET 页面，将插入点放在希望菜单出现的位置。
  2. 选择“插入”>“ASP.NET 对象”，然后选择“asp:下拉列表”或“asp:列表框”。

    随即会出现“表单控件”对话框。

  3. 完成对话框设置，然后单击“确定”。

    有关更多信息，请参见下列主题：

    • 设置“asp:下拉列表”对话框的选项
    • 设置“asp:列表框”对话框的选项

Dreamweaver 在页面的插入点处插入表单控件。如果没有插入表单，则 Dreamweaver 会插入一个包含runat=”server” 属性的表单。

相关主题

  • 设置 ASP.NET 表单控件的属性
  • 使现有 ASP.NET 菜单成为动态对象


使现有 ASP.NET 菜单成为动态对象

您可以使现有的 ASP.NET 菜单对象成为动态对象。ASP.NET 菜单对象包括“下拉列表”和“列表框”控件。

在开始之前，必须为菜单定义一个数据集或其它动态内容源。有关更多信息，请参见定义记录集。

若要使现有“下拉列表”或“列表框”对象成为动态对象，请执行以下操作：

  1. 在“设计”视图中，选择要使之为动态对象的“下拉列表”或“列表框”对象。
  2. 在属性检查器中，单击“列表项”按钮。

    出现“列表项”对话框。

  3. 选择“来自数据库”选项，然后完成该对话框。

    有关更多信息，请参见设置“列表项”对话框的选项。

相关主题

  • 创建动态 ASP.NET 菜单
  • 使现有 HTML 表单菜单成为动态对象


在 ASP.NET 文本框控件中显示动态内容

您可以在 ASP.NET 文本框表单控件中显示动态内容。

在开始之前，必须为文本框定义一个数据集或其它动态内容源。有关更多信息，请参见定义记录集。

若要使 ASP.NET 文本框成为动态对象，请执行以下操作：

  1. 在“设计”视图中，选择页面上的文本框。
  2. 在属性检查器中，单击“文本”文本框旁边的闪电图标。

    出现“动态数据”对话框。

  3. 选择为文本框对象提供值的记录集列，然后单击“确定”。

当在浏览器中查看该页面时，该文本框控件将显示动态内容。

相关主题

  • 在 HTML 文本域中显示动态内容


动态预先选择 ASP.NET 复选框控件

您可以让服务器决定当 ASP.NET 页面在浏览器中载入时是否选中特定的复选框控件。

在开始之前，必须为复选框定义一个数据集或其它动态内容源。有关更多信息，请参见定义记录集。理想情况下，该内容源应包含布尔数据，如 Yes/No 或 true/false。

若要动态预先选择 ASP.NET 复选框，请执行以下操作：

  1. 在 ASP.NET 页面中选择一个复选框表单控件。
  2. 在属性检查器中，选择“动态”选项。

    出现“动态复选框”对话框。

  3. 完成对话框设置，然后单击“确定”。

    有关说明，请单击对话框中的“帮助”按钮。

当在浏览器中载入该页面时，该复选框将显示为选中或未选中状态，这具体取决于数据。

相关主题

  • 动态预先选择 HTML 复选框


在 ASP.NET 单选按钮列表中动态预先选择一项

您可以让服务器决定当页面在浏览器中载入时是否选中单选按钮列表控件中一个单选按钮。

开始之前，您必须在页面中插入至少一个 ASP.NET 单选按钮列表控件。而且必须为该单选按钮定义数据集或其它动态内容源。有关更多信息，请参见定义记录集。理想情况下，该内容源应包含布尔数据，如 Yes/No 或 true/false。

若要在单选按钮列表中动态预先选择单选按钮，请执行以下操作：

  1. 在“设计”视图中，选择单选按钮列表控件。
  2. 在属性检查器中单击“列表”项目。

    出现“列表项”对话框。

  3. 选择“来自数据库”选项，然后完成该对话框。

    有关说明，请单击对话框中的“帮助”按钮。

相关主题

  • 动态预先选择 HTML 单选按钮


创建 ASP.NET 数据网格和数据列表 Web 控件

ASP.NET 的数据网格和数据列表控件为显示不同数据类型（尤其是数据库中的动态内容）提供了大量选项，并简化了将数据源绑定到控件的过程。对于数据网格控件和数据列表控件，Dreamweaver 都支持它们作为服务器行为。

本节包含以下主题：

  • 关于 ASP.NET 数据网格和数据列表控件
  • 将 ASP.NET 数据网格添加到页面中
  • 将 ASP.NET 数据列表添加到页面中
  • 修改数据网格或数据列表对象


关于 ASP.NET 数据网格和数据列表控件

ASP.NET 的数据网格和数据列表控件为显示不同数据类型（尤其是数据库中的动态内容）提供了大量选项，并简化了将数据源绑定到控件的过程。对于数据网格控件和数据列表控件，Dreamweaver 都支持它们作为服务器行为。这些控件提供了下列功能：

数据网格创建多列数据绑定网格。该控件允许定义各种类型的列，不仅可以编排网格的内容，还可以添加特定的功能（编辑按钮列、超级链接列等等）。

数据列表使用模板显示来自数据源的项目。通过对组成控件的不同组件的模板进行操作，可以自定义控件的外观。

相关主题

  • 将 ASP.NET 数据网格添加到页面中
  • 将 ASP.NET 数据列表添加到页面中
  • 修改数据网格或数据列表对象

ASP.NET 数据网格 Web 控件

Dreamweaver 的数据网格使您可以插入 ASP.NET 的数据网格网页控件。数据网格控件将表格呈现为多列网格，并且可以包含用于定义单元格内容布局的不同列类型（异类列）。其中包括绑定、按钮和模板列等等。另外，数据网格还支持交互功能，例如列排序、列编辑和列命令等。下表显示了数据网格中的可用列类型：

数据网格列类型 | 描述
简单数据域 | “简单数据域”列在 ASP.NET 中称为“绑定列”，它使您可以指定要显示的数据源域，以及该域在用于 .NET 格式表达式时使用的数据格式。
自由格式 | “自由格式”列类型在 ASP.NET 中称为“模板列”，它使您可以创建 HTML 文本和服务器控件的组合，为列设计自定义布局。自由格式列中的控件可以是数据绑定控件。自由格式列在定义网格内容的布局和功能方面为您提供了更大的灵活性。原因是，您可以完全控制数据的显示方式，以及用户与网格中的行交互时所发生的事情。
超级链接 | “超级链接”列显示超级链接形式的信息。它的典型用法是显示超级链接形式的数据（如客户编号或产品名称），用户单击超级链接后，可以导航到一个单独的页面，上面提供了有关该项目的详细信息。
编辑、更新、取消按钮 | “编辑、更新、取消按钮”列在 ASP.NET 中称为“编辑命令”列，它允许用户对数据网格行中的信息进行就地编辑。为此，需要创建“编辑、更新、取消”列。在运行时，该列会显示一个被标记为“编辑”的按钮。当用户单击“编辑”按钮时，在文本框这类可编辑控件中会显示行数据，并且“编辑”按钮被替换为“更新”按钮和“取消”按钮。
删除按钮 | “删除按钮”使用户可以通过单击按钮删除特定的行。

使用“数据网格”服务器行为之前，必须为数据网格定义数据集（其它文档类型称之为“记录集”）。有关更多信息，请参见了解记录集。

要了解有关 DataGrid 控件的更多信息，以及了解如何用它对动态数据设置格式，请访问 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpcondatagridwebservercontrol.asp。

相关主题

  • 关于 ASP.NET 数据网格和数据列表控件
  • 将 ASP.NET 数据网格添加到页面中
  • 将 ASP.NET 数据列表添加到页面中
  • 修改数据网格或数据列表对象


将 ASP.NET 数据网格添加到页面中

数据网格控件可让您在呈现为表格的多列网格中格式化和显示动态数据。有关数据网格及其提供的格式化控件类型的更多信息，请参见关于 ASP.NET 数据网格和数据列表控件。

注意

插入“数据网格”服务器行为之前，必须为数据网格定义数据集（其它文档类型称之为记录集）。有关更多信息，请参见了解记录集。

若要将数据网格对象添加到页面，请执行以下操作：

  1. 打开“服务器行为”面板（“窗口”>“服务器行为”），单击加号 (+) 按钮，然后选择“数据网格”。

    “数据网格”对话框随即出现。

  2. 完成“数据网格”对话框，然后单击“确定”。

    有关如何完成“数据网格”对话框的指导，请参见设置 ASP.NET 的“数据网格对象”对话框选项。

在“文档”窗口中，数据网格的周围会出现一个选项卡式的灰色轮廓。而在“动态数据”窗口（“查看”>“动态数据”）中，灰色轮廓消失，并且对象的占位符被替换为指定的数据网格。

相关主题

  • 关于 ASP.NET 数据网格和数据列表控件
  • 将 ASP.NET 数据列表添加到页面中
  • 修改数据网格或数据列表对象


将 ASP.NET 数据列表添加到页面中

Dreamweaver 的“数据列表”服务器行为允许在页面中插入 ASP.NET 数据列表控件。

注意

插入“数据列表”服务器行为之前，必须为数据列表定义数据集（其它文档类型称之为记录集）。有关更多信息，请参见了解记录集。

若要将数据列表对象添加到页面，请执行以下操作：

  1. 打开“服务器行为”面板（“窗口”>“服务器行为”），单击加号 (+) 按钮，然后选择“数据列表”。

    “数据列表”对话框随即出现。

  2. 完成“数据列表”对话框，然后单击“确定”。

    有关如何完成“数据列表”对话框的指导，请参见设置 ASP.NET“数据列表对象”对话框选项。

在“文档”窗口中，数据列表对象的周围会出现一个选项卡式的灰色轮廓。而在“动态数据”窗口（“查看”>“动态数据”）中，灰色轮廓消失，并且对象的占位符被指定的数据列表取代。

相关主题

  • 修改数据网格或数据列表对象


修改数据网格或数据列表对象

您随时可以修改数据网格和数据列表对象，使其符合页面设计需要。

若要修改数据网格和数据列表对象，请执行以下操作：

  • 在“设计”视图中，单击数据网格或数据列表左上角的图标切换到“编辑”模式，然后在所显示的任何选项卡式区域中添加或修改内容。

    注意

    还可以将动态内容源从“绑定”面板拖到选项卡式区域。
  • 在“设计”视图中，选择对象，然后使用属性检查器更改其属性。
  • 双击“服务器行为”面板中的对象，然后在打开的对话框中更改其属性。
  • 在“代码”视图中，选择页面上的数据网格或数据列表，然后使用它的标记对话框更改其属性。


生成主/详细页 (ASP.NET)

使用 Dreamweaver 可以创建以两个明细级别表示信息的页面集：主页列出记录，详细页显示有关各记录的更多详细信息。本节描述如何生成这些类型的主/详细页。

本节包含以下主题：

  • 创建主页 (ASP.NET)
  • 打开详细页并传递记录 ID (ASP.NET)
  • 查找请求的记录并在详细页上显示 (ASP.NET)

相关主题

  • 增强动态页的功能


创建主页 (ASP.NET)

本节介绍如何创建能列出数据库记录的主页。使用 ASP.NET，您可以使用数据网格在页面上列出记录。

在您开始前，请确保为站点定义了一个数据库连接。有关更多信息，请参见 ASP.NET 开发人员的数据库连接。

若要创建主页，请执行以下操作：

  1. 创建新的 ASP.NET 页。

    选择“文件”>“新建”>“动态页”，选择一种 ASP.NET 页面格式，然后单击“创建”。在 Dreamweaver 中打开一个 .aspx 空白页。

  2. 为页定义数据集。

    在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮，然后选择“数据集（查询）”并完成该对话框。有关更多信息，请单击对话框中的“帮助”按钮。如果您想编写自己的 SQL 语句，请单击“高级”按钮，打开高级“数据集”对话框。

    确保数据集包含创建主页所需的所有表列。

    数据集还必须包括一个表列，其中包含每条记录的唯一键，即记录 ID 列。

    通常，主页上的数据集提取数据库表格中的少数几列，而详细页上的数据集提取同一表格中的更多列以提供额外的详细信息。

    数据集可以在运行时由用户定义。有关更多信息，请参见生成数据库搜索页 (ASP.NET)。

  3. 在页面上创建数据网格。

    在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后选择“数据网格”，并完成“数据网格”对话框。有关更多信息，请单击对话框中的“帮助”按钮。现在，为数据网格的每一列接受“简单数据字段”的默认列类型。在下一节中，您将把列的类型更改为超级链接（请参见打开详细页并传递记录 ID (ASP.NET)）。

下面是一个“数据网格”对话框的示例，它定义了三列。

创建主/详细页的下一步是创建用于打开详细页和传递用户选定记录的 ID 的链接。请参见打开详细页并传递记录 ID (ASP.NET)。


打开详细页并传递记录 ID (ASP.NET)

向主页添加数据网格后（请参见创建主页 (ASP.NET)），必须创建用于打开详细页并传递用户选定记录的 ID 的链接。详细页将使用此 ID 在数据库中查找请求的记录并显示该记录。

记录 ID 通过 URL 参数传递给详细页。有关更多信息，请参见 URL 参数。

您可以按照本节中介绍的步骤在数据网格中创建链接，方法是把数据网格中的列转换成超级链接列并设置列的属性。

若要打开详细页并将包含用户所单击记录 ID 的 URL 参数传递给它，请执行以下操作：

  1. 打开在上一节创建的“数据网格”对话框。

    若要打开对话框，请双击“服务器行为”面板中的“数据网格”（“窗口”>“服务器行为”）。

    “数据网格”对话框打开。

  2. 在“列”框中选择要应用链接的列。

  3. 请单击“更改列类型”按钮并从弹出菜单中选择“超级链接”。

    出现“超级链接列”对话框。

  4. 在“超级链接文本”区域中，指定要在超级链接列中显示的文本。

    如果要为数据网格中的每一行创建普通链接，如详细信息，请选择“静态文本”选项然后为该链接输入文本。数据网格的每一行都将在超级链接列中显示相同的文本（例如详细信息）。

    如果要为列中显示的数据添加链接，请选择“数据字段”选项并在数据集中选择数据字段。数据字段为超级链接列中的链接提供了文本。在下面的示例中，“数据网格”的每行都将显示一个位置名称。

  5. 在“链接页”区域中，生成 URL 以应用到超级链接列超级链接列中的文本。

    URL 不仅需要打开详细页，而且必须唯一标识要在该页上显示的记录。

    若要标识在详细页上显示的记录，请选择“数据字段”选项并在数据集中选择一个唯一标识每条记录的字段。大多数情况下，该字段将由一个记录 ID 号组成。在下面的示例中，该字段由唯一位置代码构成。

  6. 在“链接页”区域的“格式字符串”文本框中，单击“浏览”按钮然后定位并选择详细页。

    Dreamweaver 将创建指向详细页的 URL，其中包含一个用于标识详细页要显示的记录的 URL 参数。记下该 URL 参数的名称，因为接下来会在详细页中用到它。

    例如，如果选择 locationDetail.aspx 作为详细页，Dreamweaver 将创建下面的 URL：

    在本例中，Dreamweaver 创建一个名为 CODE 的 URL 参数。Dreamweaver 复制数据字段的名称，但是您可以不使用该名称。可以将它改为一个更具描述性的名称，例如 recordID，如下面的示例所示。

    {0} 元素是一个与数据字段的值相对应的占位符。当页面运行时，“数据集”的 CODE 字段值将被插入到数据网格的相应行中。例如，如果澳大利亚堪培拉的租位代码为 CBR，那么下面的 URL 将用于“数据网格”中有堪培拉的行：

    locationDetail.aspx?recordID=CBR
  7. 单击“确定”关闭“超级链接”对话框，然后单击“确定”关闭“数据网格”对话框。

    Dreamweaver 更新页面上的“数据网格”。

创建主/详细页的下一步是修改详细页，使它能够在数据库中查找请求的记录，并将其显示在页面上。请参见查找请求的记录并在详细页上显示 (ASP.NET)。


查找请求的记录并在详细页上显示 (ASP.NET)

完成主页后（请参见打开详细页并传递记录 ID (ASP.NET)，必须在数据库中查找请求的记录并将其显示在详细页上。该过程由两个步骤组成：在详细页上定义一个数据集以保留单个记录（即主页请求的记录）；将数据集列绑定到页面上。

若要查找请求的记录并在详细页上显示，请执行以下操作：

  1. 切换到详细页。

    如果不存在详细页，请选择“文件”>“新建”>“动态页”，选择一种 ASP.NET 页面格式，然后单击“创建”。在 Dreamweaver 中打开一个 .aspx 空白页。

  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并从弹出菜单中选择“数据集（查询）”。

    出现简单的“数据集”对话框。如果出现的是高级的“数据集”对话框，请单击“简单”切换到简单的“数据集”对话框。

  3. 命名该数据集，然后选择一个连接以及将向数据集提供数据的数据库表。
  4. 在“列”区域中，选择要包括在数据集中的表列。

    详细页上的数据集可以与主页上的数据集相同，也可以不同。通常，详细页数据集的列数更多，可以显示更多的详细信息。

    如果数据集不同，则请确保详细页上的数据集至少包含一个与主页上的数据集相同的列。这个公共列通常是记录 ID 列，但也可以是相关表格的连结字段。

    若要使记录集中只包括某些表列，请选择“已选定”选项，然后按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 列表中的列，以选择所需列。

  5. 如下所示完成“筛选”部分，以便查找和显示主页所传递的 URL 参数中指定的记录：
    • 从“筛选”区域的第一个弹出菜单中选择数据集中的列，该列包含与主页传递的 URL 参数值相匹配的值。

      例如，如果 URL 参数包含一个记录 ID 号，则选择包含记录 ID 号的列。在上一节讨论的示例中，数据集列 CODE 包含与通过主页传递的 URL 参数值相匹配的值。

    • 从第一个菜单旁边的弹出菜单中选择等号（如果尚未选定）。
    • 从第三个弹出菜单中选择“URL 参数”。

      主页使用 URL 参数将信息传递到详细页。

    • 在第四个框中输入主页传递的 URL 参数的名称。

      例如，如果主页用来打开详细页的 URL 包含后缀 locationDetail.aspx?recordID=CBR，请接着输入 recordID。

    “数据集”对话框的外观应该如下所示：

  6. 单击“确定”。

    “数据集”即会出现在“绑定”面板中。

  7. 通过下面的方法将数据集列绑定到详细页：在“绑定”面板（“窗口”>“绑定”）上选择列，然后将其拖到页面上。

    有关更多信息，请参见将文本动态化。

ASP.NET 主/详细页的设置完成。

创建主/详细页后，可以使用“服务器行为”面板（“窗口”>“服务器行为”）来修改各种构造块。


生成数据库搜索页 (ASP.NET)

可以使用 Dreamweaver 生成用于搜索数据库并将结果显示在数据网格中的页面。

本节将介绍生成数据库搜索页的步骤：

  • 添加搜索控件 (ASP.NET)
  • 只使用一个搜索参数进行搜索 (ASP.NET)
  • 使用多个搜索参数进行搜索 (ASP.NET)
  • 在数据网格中显示结果
  • 首次加载搜索页时隐藏数据网格
  • 创建详细页 (ASP.NET)


添加搜索控件 (ASP.NET)

Web 上的搜索页通常包含用户在其中输入搜索参数的表单字段。当用户单击按钮时，将显示搜索结果。

若要添加搜索表单到页面，请执行以下操作：

  1. 打开搜索页并选择“插入”>“表单”>“表单”。

    将在页面上创建一个空表单。您可能需要启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）来查看表单的边界，边界是由红色的细线表示的。

    在表单的“属性”检查器中，应该选择 POST 作为表单的 Method 属性。不需要为表单指定 Action 属性。ASP.NET 页面将回发到自己，并且搜索结果将显示在同一页。

  2. 添加表单控件以供用户输入搜索参数（“插入”>“ASP.NET 对象”）。

    可以插入任意 ASP.NET 表单控件，包括“文本框”、“复选框”、“单选按钮”、“列表框”或者“下拉列表”控件。可以添加任意多的控件以帮助用户细化搜索操作。但是请记住，搜索页上搜索参数的数目越多，SQL 语句就将越复杂。

    请确保为每个控件指定一个 ID 属性，例如为文本框控件指定 txtCity，或者为列表框控件指定 lbxCountry。

    有关更多信息，请参见将 ASP.NET 表单控件添加到页面。

  3. 将 ASP.NET 按钮添加到表单（“插入”>“ASP.NET 对象”>“asp:按钮”）。

    确保已为该按钮指定 ID 属性，例如 btnSearch，并为该按钮标签指定文本，例如 Search。

搜索表单完成。创建搜索页面的下一步是定义用于查找和存储搜索结果的数据集。请参见只使用一个搜索参数进行搜索 (ASP.NET)。


只使用一个搜索参数进行搜索 (ASP.NET)

用户单击页面的“搜索”按钮时，搜索参数被发送到服务器。服务器处理该请求，基于该参数生成一个过滤数据集，填充数据网格并且将该页面发送回浏览器。

添加数据网格前，必须定义一个用于查找和存储满足搜索条件的所有记录的数据集。

若要创建用于保留搜索结果的数据集，请执行以下操作：

  1. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并选择“数据集”（查询）。

    如果出现高级对话框，则单击“简单”按钮打开简单对话框。

  2. 命名该数据集，然后选择一个连接和包含用户要搜索的数据的数据库表。
  3. 在“列”区域中，单击“已选定”选项并选择一个键列（通常是记录 ID 列）和包含要显示在数据网格中的数据的列。

暂时使“数据集”对话框保持打开状态。下一步将使用该对话框检索发送到服务器的搜索参数，并创建一个数据集过滤器以排除不满足参数的记录。

若要创建数据集过滤器，请执行以下操作：

  1. 从“筛选”区域中的第一个弹出菜单中，选择要与搜索页发送的搜索参数进行比较的表中的列。

    例如，如果搜索页发送的值是城市名，则在包含城市名的表中选择列。

  2. 从第一个菜单旁边的弹出菜单中，选择等号（它应该为默认值）。

    此选择声明用户只需要这样的记录：在这些记录中，选定的表列与搜索页中指定的列完全相同。可以使用限制较少的选项，例如“开始于”或“包含”。

  3. 在第三个弹出菜单中选取“表单变量”。

    表单使用 POST 方法将该参数发送到服务器。

  4. 在第四个文本框中，输入用于将搜索参数发送到服务器的表单控件的名称。

    可以通过下面的方法获取控件的名称：单击表单上的表单控件以选择该控件，然后在属性检查器中查看控件 ID。

  5. 如果需要，请单击“测试”，输入一个测试值，然后单击“确定”连接到数据库并创建一个数据集实例。

    测试值模拟本来应由搜索页返回的值。单击“确定”关闭数据集。

  6. 如果您对该数据集感到满意，请单击“确定”。

Dreamweaver 在页面中插入代码，当代码在服务器上运行时，将检查数据库表格中的每个记录。如果记录中的指定字段满足过滤条件，则将该记录包含在数据集中。有效的脚本将生成一个只包含搜索结果的记录集。

创建搜索页的下一步是在数据网格中显示搜索结果。请参见在数据网格中显示结果。


使用多个搜索参数进行搜索 (ASP.NET)

如果搜索页向服务器提交多个搜索参数，则必须编写一个 SQL 查询并在 SQL 变量中使用搜索参数。

注意

如果仅有一个搜索条件，则可以使用简单“数据集”对话框来定义数据集（请参见只使用一个搜索参数进行搜索 (ASP.NET)）。

使用 SQL 在数据库中查找记录：

  1. 在 Dreamweaver 中打开结果页，然后通过下面的方法创建一个新数据集：打开“绑定”面板（“窗口”>“绑定”），单击加号 (+) 按钮，然后从弹出菜单中选择“数据集”。
  2. 确保出现高级“数据集”对话框。

    如果出现的是简单对话框，则请通过单击“高级”按钮切换到高级对话框。

  3. 输入数据集的名称并选择一个连接。

    应该连接到包含希望用户搜索的数据的数据库。

  4. 在 SQL 文本区域中输入一条 Select 语句。

    确保该语句包含一个 WHERE 子句，并且该子句含有作为搜索参数的问号 (?) 占位符。下面的示例中包含两个占位符：

    SELECT EMPLOYEEID, FIRSTNAME, LASTNAME, DEPARTMENT, EXTENSION
FROM EMPLOYEE WHERE LASTNAME LIKE ?
AND DEPARTMENT LIKE ?

    有关 SQL 语法的帮助，请参见 SQL 入门。

  5. 单击“参数”区域的加号 (+) 按钮并输入参数的名称、类型和值，将搜索参数的值赋给占位符。

    参数列出的顺序必须与它们在 SQL 语句中出现的顺序相同。

    在“名称”文本框中，输入任意一个有效的参数名称。此名称不要包含任何空格或特殊字符。

    在“类型”弹出菜单中选择一个数据类型。例如，如果该参数将存放文本，请选择“WChar”。

    在“值”框中，输入将包含参数值的服务器变量。例如，如果搜索页上的表单控件名为“txtCity”，则将创建名为 Request.Form(ìtxtCity) 的服务器变量，并在其中存储一个值。

    您也可以输入一个更完整的表达式，使用它在服务器变量不存在的情况下指定一个默认值。例如，如果搜索 Microsoft Access 数据库，可以使用“%”作为默认值。下面的表达式检查是否存在服务器变量 Request.Form("txtCity")。如果该变量存在（即该变量不等于 nothing），则表达式返回该变量的值，如果该变量不存在，该表达式返回 % 的默认值。

    (IIf((Request.Form("txtCity") <> Nothing),
Request.Form("txtCity"), "")) + "%"

    有关更多信息，请参见 Visual Basic 或 C# 语言参考。

  6. 如果需要，请单击“测试”使用默认的变量值创建该数据集的一个实例。

    默认值模拟本来应由搜索页返回的值。单击“确定”关闭测试数据集。

  7. 如果您对该数据集感到满意，请单击“确定”。

    Dreamweaver 将 SQL 查询插入到您的页中。

下一步是在数据网格中显示搜索结果。请参见在数据网格中显示结果。


在数据网格中显示结果

在创建数据集以保留搜索结果后（请参见只使用一个搜索参数进行搜索 (ASP.NET) 或使用多个搜索参数进行搜索 (ASP.NET)），可以使用数据网格在页面上显示信息。

若要在数据网格中显示搜索结果，请执行以下操作：

  1. 在搜索页上，将插入点放在希望数据网格出现的位置。
  2. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后选择“数据网格”。

    “数据网格”对话框随即出现。

  3. 在“ID”文本框中，输入数据网格的名称，如 dgLocation。
  4. 在“数据集”弹出菜单中，选择您定义用来存放搜索结果的数据集。
  5. 根据需要完成对话框的其余部分。

    有关更多信息，请单击对话框中的“帮助”按钮。

下面是一个“数据网格”对话框示例，该对话框将创建一个三列十行的数据网格，并包含指向结果的前后页的链接。

该数据网格将在搜索页首次加载时显示，无论用户是否执行了搜索。您可以在首次加载搜索页时隐藏数据网格。请参见首次加载搜索页时隐藏数据网格。


首次加载搜索页时隐藏数据网格

首次加载搜索页时，您可以隐藏将用于显示搜索结果的数据网格。

若要在首次加载搜索页时隐藏数据网格，请执行以下操作：

  1. 在“代码”视图中打开搜索页（“查看”>“代码”）。
  2. 在页面顶部紧跟“Register”指令之后输入以下代码块（如果页面语言是 Visual Basic）：
    <script runat="server">
Sub Page_Load()
   If Not IsPostBack Then
      dgName.Visible = false
   Else
      dgName.Visible = true
   End If
End Sub
</script>

    其中 dgName 是数据网格的 ID。

    如果页面语言是 C#，请输入以下代码：

    <script runat="server">
void Page_Load() {
   if (!IsPostBack) {
      dgName.Visible = false;
   } else {
      dgName.Visible = true;
   }
}
</script>
  3. 保存该页面。


创建详细页 (ASP.NET)

搜索页可以包含一个详细页，用来显示有关数据网格中列出的特定记录的更多信息。在这种情况下，搜索页作为主/详细页集中的主页。有关更多信息，请参见生成主/详细页 (ASP.NET)。


生成记录插入页 (ASP.NET)

可以用 Dreamweaver 生成一个允许用户向数据库插入新记录的页。您所使用的方法对于所有 Dreamweaver 支持的服务器技术而言完全相同。有关说明，请参见建立记录插入页（所有服务器）。


生成用以更新记录的页面 (ASP.NET)

您的应用程序可以包含允许用户更新数据库表中现有记录的一组页。这组页通常由一个搜索页、一个结果页和一个更新页组成。用户可以使用搜索页和结果页检索记录，使用更新页修改记录。

本节介绍生成页面用于更新记录的步骤：

  • 搜索要更新的记录 (ASP.NET)
  • 打开更新页并传递记录的 ID (ASP.NET)
  • 检索要更新的记录 (ASP.NET)
  • 在一个操作中完成更新页 (ASP.NET)
  • 逐块完成更新页 (ASP.NET)

相关主题

  • 建立记录插入页（所有服务器）
  • 生成用以删除记录的页 (ASP.NET)


搜索要更新的记录 (ASP.NET)

当用户要更新某个记录时，他们必须首先在数据库中找到该记录。因此，您需要一个搜索页以便使用更新页。用户将从搜索页上生成的数据网格结果中选择要更新的记录。当用户单击该记录时，更新页将打开并在表单中显示该记录。

有关创建页面来搜索要更新的记录的说明，请参见生成数据库搜索页 (ASP.NET)。

创建搜索页后，下一步是在结果页上创建链接，当单击链接时将打开更新页。请参见打开更新页并传递记录的 ID (ASP.NET)。


打开更新页并传递记录的 ID (ASP.NET)

在创建了搜索页（请参见搜索要更新的记录 (ASP.NET)）之后，必须创建能够打开更新页并传递用户所选记录的 ID 的链接。更新页将使用此 ID 在数据库中查找请求的记录并显示该记录。

记录 ID 通过 URL 参数传递给更新页。有关更多信息，请参见 URL 参数。

本节假定您已按生成数据库搜索页 (ASP.NET) 中的说明进行了操作，您的搜索页使用数据网格来显示记录。

若要在搜索页上创建链接以打开更新页并传递记录 ID，请执行以下操作：

  1. 在 Dreamweaver 中打开搜索页。
  2. 双击“服务器行为”面板（“窗口”>“服务器行为”）中列出的数据网格对象。

    “数据网格”对话框打开。

  3. 在“列”框中选择要应用链接的列。

  4. 请单击“更改列类型”按钮并从弹出菜单中选择“超级链接”。

    出现“超级链接列”对话框。

  5. 在“超级链接文本”区域中，指定要在超级链接列中显示的文本。

    如果希望为数据网格中的每一行创建一个普通链接如“更新”，请选择“静态文本”选项并输入链接文本。数据网格中的每一行都将显示与超级链接列中相同的文本（如“更新”）。

    如果要为列中显示的数据添加链接，请选择“数据字段”选项并在数据集中选择数据字段。数据字段为超级链接列中的链接提供了文本。在下面的示例中，“数据网格”的每行都将显示一个位置名称。

  6. 在“链接页”区域中，生成 URL 以应用到超级链接列中的文本。

    URL 不仅要打开更新页，还必须唯一标识要在该页上显示的记录。

    要标识在更新页上显示的记录，请选择“数据字段”选项，并从数据集中选择一个唯一标识每条记录的字段。大多数情况下，该字段将由一个记录 ID 号组成。在下面的示例中，该字段由唯一位置代码构成。

  7. 在“链接页”区域的“格式字符串”文本框中，单击“浏览”按钮并定位和选择更新页。

    Dreamweaver 将创建指向更新页的 URL，其中包含一个用于标识更新页要显示的记录的 URL 参数。记下该 URL 参数的名称，因为接下来会在更新页中用到它。

    例如，如果选择 locationUpdate.aspx 作为更新页，Dreamweaver 会创建如下 URL 并将其显示在“格式字符串”文本框中：

    locationUpdate.aspx?CODE={0}

    在本例中，Dreamweaver 创建一个名为 CODE 的 URL 参数。Dreamweaver 复制数据字段的名称，但是您可以不使用该名称。可在“格式字符串”文本框中将它更改为更具描述性的名称（如 recordID），如下面的示例所示：

    locationUpdate.aspx?recordID={0}

    {0} 元素是一个与数据字段的值相对应的占位符。当页面运行时，“数据集”的 CODE 字段值将被插入到数据网格的相应行中。例如，如果澳大利亚堪培拉的租位代码为 CBR，那么下面的 URL 将用于“数据网格”中有堪培拉的行：

    locationUpdate.aspx?recordID=CBR
  8. 请单击“确定”关闭“超级链接”对话框，然后单击“确定”关闭“数据网格”对话框。

Dreamweaver 更新页面上的“数据网格”。

在创建了链接用以打开更新页和传递用户所选记录的 ID 后，更新页必须检索要更新的记录。请参见检索要更新的记录 (ASP.NET)。


检索要更新的记录 (ASP.NET)

在搜索页将 URL 参数传递到更新页之后（请参见打开更新页并传递记录的 ID (ASP.NET)），更新页必须读取该参数，从数据库表中检索该记录，然后将其临时存储在一个数据集中。

若要检索要更新的记录，请执行以下操作：

  1. 在 Dreamweaver 中创建新的 ASP.NET 页并保存该页。

    该页将成为您的更新页。

  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并选择“数据集”（查询）。

    如果出现高级对话框，则单击“简单”按钮打开简单对话框。

  3. 命名该数据集，然后选择一个连接和包含用户要更新的数据的数据库表。
  4. 单击“已选定”选项并选择一个键列（通常是记录 ID 列）和包含要更新数据的列。
  5. 配置“筛选”区域，以便键列的值等于搜索页传递的相应 URL 参数的值。

    这种过滤器创建只包含一条记录的数据集，即 ID 与 URL 参数值相匹配的记录。例如，如果您的键列名为 CODE 且包含记录 ID 信息，并且搜索页在名为 recordID 的 URL 参数中传递相应的记录 ID 信息，则您的“筛选”区域应如下所示：

  6. 单击“确定”。

当用户在搜索页上选择一条记录时，更新页将生成一个只包含所选记录的数据集。

修改更新页以便从数据库检索记录并将它存储到数据集中之后，您必须添加一个可以让用户修改记录数据的表单。并且还必须添加更新数据库所需的逻辑。您可以在一个操作中完成这些任务，也可以逐个地完成。请参见在一个操作中完成更新页 (ASP.NET) 或逐块完成更新页 (ASP.NET)。


在一个操作中完成更新页 (ASP.NET)

更新页具有三个构造块：

  • 一个用于从数据库表中检索记录的过滤数据集（请参见检索要更新的记录 (ASP.NET)）
  • 一个允许用户修改记录数据的 HTML 表单
  • 一个用于更新数据库表的“更新记录”服务器行为

您可以使用“更新记录表单”应用程序对象通过单个操作添加更新页的最后两个构造块。该应用程序对象将 HTML 表单和“更新记录”服务器行为添加到页中。

在您可以使用该应用程序对象之前，您的 Web 应用程序必须能够识别要更新的记录，并且您的更新页必须能够检索它。请参见搜索要更新的记录 (ASP.NET)、打开更新页并传递记录的 ID (ASP.NET) 和检索要更新的记录 (ASP.NET)。

在应用程序对象将构造块放置到页上之后，您可以使用 Dreamweaver 设计工具按需要自定义表单，或使用“服务器行为”面板编辑“更新记录”服务器行为。

注意

更新页一次只能包含一个记录编辑服务器行为。例如，您不能将“插入记录”或“删除记录”服务器行为添加到更新页。

若要用“更新记录表单”应用程序对象建立更新页，请执行以下操作：

  1. 在“设计”视图中打开该页，然后选择“插入”>“应用程序对象”>“更新记录”>“更新记录表单向导”。

    即会出现“更新记录表单”对话框。

  2. 完成对话框。

    有关说明，请参见设置“更新记录表单”对话框的选项 (ASP.NET)。

  3. 单击“确定”。

该应用程序对象将 HTML 表单和“更新记录”服务器行为添加到您的页中。表单对象是在一个基本表格中进行布局的，您可以使用 Dreamweaver 页面设计工具自定义该表格。确保所有表单对象都位于表单的边界内。

若要编辑服务器行为，请打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“更新记录”行为。

相关主题

  • 逐块完成更新页 (ASP.NET)


逐块完成更新页 (ASP.NET)

更新页具有三个构造块：

  • 一个用于从数据库表中检索记录的过滤数据集（请参见检索要更新的记录 (ASP.NET)）
  • 一个允许用户修改记录数据的 HTML 表单
  • 一个用于更新数据库表的“更新记录”服务器行为

您可以使用表单工具和“服务器行为”面板分别添加更新页的最后两个基本构造块。

在您可以添加构造块之前，您的 Web 应用程序必须能够识别要更新的记录，并且您的更新页必须能够检索它。请参见搜索要更新的记录 (ASP.NET)、打开更新页并传递记录的 ID (ASP.NET) 和检索要更新的记录 (ASP.NET)。

完成更新页由以下三个任务组成：

  • 将 HTML 表单添加到页面以允许用户修改数据。
  • 将表单对象绑定到数据库表列以显示表单中的记录
  • 添加“更新记录”服务器行为以在用户修改记录后更新数据库表。

若要将 HTML 表单添加到更新页，请执行以下操作：

  1. 创建新的 ASP.NET 页。

    该页将成为更新页。

  2. 使用 Dreamweaver 设计工具对您的页进行布局。
  3. 将插入点放置在您想要显示表单的位置，然后从“插入”菜单中选择“表单”，添加一个 HTML 表单。

    将在页面上创建一个空表单。您可能需要启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）来查看表单的边界，边界是由红色的细线表示的。

  4. 为 HTML 表单命名，方法是单击“文档”窗口底部的 <form> 标签以选中表单，打开属性检查器（“窗口”>“属性”），然后在“表单名称”框中输入一个名称。

    您不必为表单指定 action 或 method 属性来指示当用户单击“提交”按钮时表单向何处及如何发送记录数据。“更新记录”服务器行为会为您设置这些属性。

  5. 为数据库表中要更新的每一列添加一个表单对象，例如文本字段（“插入”>“表单”>“文本字段”）。

    该表单对象允许用户修改数据。为了实现该目的经常会使用文本字段，但是您也可以使用列表/菜单、复选框和单选按钮。

    每个表单对象都应该在早先定义的数据集中具有一个对应的列。唯一的例外就是唯一键列，该列没有对应的表单对象。

    有关表单对象的更多信息，请参见插入 HTML 表单对象。

  6. 在表单上添加一个“提交”按钮（“插入”>“表单”>“按钮”）。

    可以通过以下方法更改“提交”按钮的标签文字：选择该按钮，打开属性检查器（“窗口”>“属性”），并在“标签文字”文本框中输入一个新值。

若要在表单中显示记录，请执行以下操作：

  1. 确保您定义了一个数据集来保存用户要更新的记录。

    有关更多信息，请参见检索要更新的记录 (ASP.NET)。

  2. 将每个表单对象绑定到记录集中的数据。

    有关更多信息，请参见以下章节：

    • 在 HTML 文本域中显示动态内容
    • 动态预先选择 HTML 复选框
    • 动态预先选择 HTML 单选按钮
    • 创建动态 HTML 表单菜单
    • 使现有 HTML 表单菜单成为动态对象

若要添加服务器行为来更新数据库表，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮并从弹出菜单中选择“更新记录”。

    出现“更新记录”对话框。

  2. 完成对话框。

    有关说明，请参见设置“更新记录”对话框的选项 (ASP.NET)。

  3. 单击“确定”。

Dreamweaver 在页中添加服务器行为，允许用户通过单击表单上的“提交”按钮更新数据库中的记录。

若要编辑服务器行为，请打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“更新记录”行为。

相关主题

  • 在一个操作中完成更新页 (ASP.NET)


生成用以删除记录的页 (ASP.NET)

您的应用程序可以包含允许用户删除数据库中的记录的一组页。这组页通常由一个搜索页和一个删除页组成。用户可以使用搜索页检索记录，使用删除页删除记录。

本节介绍生成 ASP.NET 页面用于删除记录的步骤：

  • 搜索要删除的记录 (ASP.NET)
  • 在搜索页上创建删除链接 (ASP.NET)
  • 在确认页上显示记录 (ASP.NET)
  • 添加用来删除记录的逻辑 (ASP.NET)


搜索要删除的记录 (ASP.NET)

当用户要删除某个记录时，他们必须首先在数据库中找到该记录。因此，您需要一个搜索页以便使用删除页。用户在搜索页中输入搜索条件，并在数据网格中显示的搜索结果中选择记录。当用户单击该记录时，删除页将打开并在 HTML 表单中显示该记录。

有关创建页面来搜索要删除的记录的说明，请参见生成数据库搜索页 (ASP.NET)。

创建搜索页后，下一步要在搜索页的数据网格中添加删除按钮或超级链接。请参见在搜索页上创建删除链接 (ASP.NET)。


在搜索页上创建删除链接 (ASP.NET)

在生成带有数据网格的搜索页之后（请参见搜索要删除的记录 (ASP.NET)），必须创建能够打开删除确认页并传递用户所选记录的 ID 的链接。确认页将使用此 ID 在数据库中查找所请求的记录并将其显示出来。

记录 ID 通过 URL 参数传递给确认页。有关更多信息，请参见 URL 参数。

可通过添加超级链接列并设置其属性在数据网格中创建这些链接，如本节中所述。

若要在搜索页的数据网格中创建删除链接，请执行以下操作：

  1. 打开在上一节创建的“数据网格”对话框。

    若要打开对话框，请双击“服务器行为”面板中的“数据网格”。请确保双击在面板中所列出的数据网格，而不是当点击加号 (+) 按钮时在弹出菜单中出现的数据网格项。

    “数据网格”对话框打开。

  2. 通过单击加号 (+) 按钮并选择“超级链接”可以添加一列删除链接。
  3. 在“标题”文本框中，输入一个列标题，如“删除”。

    该标题将显示在列标题中。

  4. 选择“静态文本”选项，并输入链接文本，如删除记录。

    数据网格中的每一行都会在超级链接列中显示这一相同的文本。

    “数据网格”对话框应如下所示：

  5. 在“链接页”区域中，生成 URL 以应用到超级链接列中的文本。

    URL 不仅要打开确认页，还必须唯一标识要在该页上显示的记录。

    若要标识在确认页上显示的记录，请选择“数据字段”选项，并从数据集中选择一个唯一标识每条记录的字段。大多数情况下，该字段将由一个记录 ID 号组成。

  6. 在“链接页”区域的“格式字符串”文本框中，单击“浏览”按钮并定位和选择确认页。

    Dreamweaver 为确认页创建了一个 URL，其中包含一个用于标识确认页要显示的记录的 URL 参数。记下该 URL 参数的名称，因为接下来会在确认页中用到它。

    例如，如果选择 locationDelete.aspx 作为详细页，并选择 CODE 作为数据集中唯一标识每条记录的字段，则 Dreamweaver 将创建下面的 URL。

    在本例中，Dreamweaver 创建一个名为 CODE 的 URL 参数。Dreamweaver 复制数据字段的名称，但是您可以不使用该名称。可以将它改为一个更具描述性的名称，例如 recordID，如下面的示例所示。

    locationDelete.aspx?recordID={0}

    {0} 元素是一个与数据字段的值相对应的占位符。当页面运行时，“数据集”的 CODE 字段值将被插入到数据网格的相应行中。例如，如果澳大利亚堪培拉的租位代码为 CBR，那么下面的 URL 将用于“数据网格”中有堪培拉的行：

    locationDelete.aspx?recordID=CBR
  7. 单击“确定”关闭“超级链接”对话框，然后单击“确定”关闭“数据网格”对话框。

    Dreamweaver 更新页面上的“数据网格”。下面是在搜索以字母 c 开头的所有城市后，浏览器中显示的数据网格。

创建删除链接后，下一步是在确认页上显示该记录。请参见在确认页上显示记录 (ASP.NET)。


在确认页上显示记录 (ASP.NET)

在完成列出记录的页后（请参见在搜索页上创建删除链接 (ASP.NET)），请切换到删除确认页。确认页将显示该记录，并询问用户是否确实要删除该记录。当用户单击表单按钮以确认该操作后，Web 应用程序将从数据库中删除该记录。

生成此页由以下两个任务构成：

  • 创建带有一个按钮的 HTML 表单，单击其中的按钮将确认删除操作
  • 检索要在页面上显示的记录
  • 在页面上显示记录

检索和显示记录由两个步骤组成：定义一个用来存放单个记录（用户希望删除的记录）的数据集；将该数据集的列绑定到页面。下面详细列出了这些步骤。

若要创建用于确认删除的 HTML 表单，请执行以下操作：

  1. 创建新的 ASP.NET 页并将其另存为您在上一节中指定的确认页。

    您在上一节创建“删除”链接时已经指定了一个确认页。请在第一次保存该文件时使用此名字（如 locationDelete.aspx）。

  2. 在页面上插入一个 HTML 表单（“插入”>“表单”>“表单”）。
  3. 在表单中添加一个隐藏的表单字段。

    该隐藏的表单字段是存储 URL 参数传递的记录 ID 所必需的。要添加隐藏字段，请将插入点置于表单中，然后选择“插入”>“表单”>“隐藏字段”。

  4. 在表单上添加按钮。

    用户将单击该按钮以确认并删除所显示的记录。要添加按钮，请将插入点置于表单中，然后选择“插入”>“表单”>“按钮”。

  5. 根据需要增强页面的设计然后保存。

若要检索用户要删除的记录，请执行以下操作：

  1. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并从弹出菜单中选择“数据集”。

    出现简单的“数据集”对话框。如果出现的是高级的“数据集”对话框，请单击“简单”切换到简单的“数据集”对话框。

  2. 命名该数据集，然后选择包含可能要显示的记录的数据库表。
  3. 在“列”区域中，选择要在页面中显示的表列（记录字段）。

    若要只显示记录的某些字段，请单击“已选定”，然后按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 列表中的列，以选择所需字段。

    确保包含记录 ID 字段，即使您不打算显示该字段。

  4. 如下所示完成“筛选”部分，以便查找和显示搜索页所传递的 URL 参数中指定的记录：
    • 从“筛选”区域的第一个弹出菜单中，选择“数据集”中的列，该列包含的值与带有“删除”链接的页所传递的 URL 参数值相匹配。例如，如果 URL 参数包含一个记录 ID 号，则选择包含记录 ID 号的列。在上一节讨论的示例中，“数据集”列 CODE 包含的值与带有“删除”链接的页所传递的 URL 参数值相匹配。
    • 从第一个菜单旁边的弹出菜单中选择等号（如果尚未选定）。
    • 从第三个弹出菜单中选择 URL 参数。包含“删除”链接的页使用 URL 参数向确认页传递信息。
    • 在第四个文本框中，输入由带有“删除”链接的页传递的 URL 参数的名称。

      例如，如果用于打开确认页的 URL 中包含后缀 locationDelete.aspx?recordID=CBR，请输入“recordID”。

      “数据集”对话框的外观应该如下所示。

  5. 单击“确定”。

“数据集”即会出现在“绑定”面板中。

若要显示用户要删除的记录，请执行以下操作：

  1. 在“绑定”面板上选择“数据集”列（记录字段）并将它们拖动到确认页中。

    请确保您在表单边框内插入该只读动态内容。有关在页面中插入动态内容的更多信息，请参见将文本动态化。

    接着，必须将记录 ID 列绑定到隐藏的表单字段。

  2. 确保启用了“不可见元素”（“查看”>“可视化助理”>“不可见元素”），然后单击代表隐藏表单字段的黄色盾牌图标。

    已选中隐藏表单字段。

  3. 在属性检查器中，单击“值”文本框旁边的闪电图标。

    出现“动态数据”对话框。

  4. 在“动态数据”对话框中，在数据集中选择记录 ID 列，然后单击“确定”。

    在下面的示例中，选择的记录 ID 列是“CODE”。

  5. 保存该页面。

    完成后的确认页的外观应该如下所示。

在创建了确认页后，下一步将添加用来删除记录的逻辑。请参见添加用来删除记录的逻辑 (ASP.NET)。


添加用来删除记录的逻辑 (ASP.NET)

创建了确认页后（请参见在确认页上显示记录 (ASP.NET)），下一步是在页中添加逻辑，当用户单击“确认”按钮时该逻辑将从数据库中删除记录。在 Dreamweaver 中，使用“删除记录”服务器行为可以快速、方便地添加此逻辑。

若要添加用于删除 HTML 表单中显示的记录的逻辑，请执行以下操作：

  1. 确保确认页在 Dreamweaver 中是打开的。
  2. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后选择“删除记录”。

    出现“删除记录”对话框。

  3. 在“先检查是否定义了变量”文本框中，确保已选中“主键值”。

    随后您将在对话框中指定主键值。

  4. 在“连接”弹出菜单中，选择一个到该数据库的连接，这样页面就可以查找并连接到该数据库。
  5. 在“表格”弹出菜单中，选择包含要删除的记录的数据库表。
  6. 在“主键列”弹出菜单中，选择包含记录 ID 的表列。

    “删除记录”服务器行为将在此列搜索匹配值。此列与绑定到页面上的隐藏表单字段的“数据集”列应包含相同的记录 ID 数据。

  7. 在“提交主键为”弹出菜单中，选择主键列的数据类型。
  8. 在“主键值”弹出菜单中，选择页面上包含记录 ID 的变量，该记录 ID 标识了要删除的记录。

    该变量是由隐藏表单字段创建的。其名称与隐藏字段的 name 属性相同，是一个表单参数或 URL 参数，具体取决于该表单的 method 属性。在此示例中，该变量是名为 hiddenID 的 URL 参数。

  9. 在“如果成功，转到”文本框中，指定从数据库表删除该记录之后打开的页。

    可以指定向用户显示含有简短的成功消息的页，或者指定一个页，在其中列出剩余记录，使用户可以验证该记录是否已被删除。

  10. 如果需要，您可以选择“失败时显示调试信息”选项。

    调试信息将由服务器生成。

  11. 如果希望提供自定义的错误信息，请取消选择“失败时显示调试信息”选项，并在“如果失败，则转到”文本框中指定要打开的页。

    完成后的“删除记录”对话框外观应如下所示。

  12. 单击“确定”，保存您的工作。

将这些页上传到 Web 服务器（如果需要），打开浏览器，然后搜索要删除的记录。当单击结果页上的“删除”链接时，将显示确认页。单击表单按钮可从数据库中删除该记录。要验证记录是否已被删除，请再次搜索该记录。


使用预存过程修改数据库 (ASP.NET)

您可以使用预存过程修改数据库。预存过程是一种可以重复使用的数据库项，用于在数据库上执行某些操作。

注意

Microsoft Access 和 MySQL 数据库不支持预存过程。

在您使用预存过程修改数据库之前，确保预存过程包含以某种方式修改数据库的 SQL。若要在数据库中创建并存储一个 SQL，请查询您的数据库文档和一本好的 Transact-SQL 手册。

若要将预存过程添加到 ASP.NET 页，请执行以下操作：

  1. 在 Dreamweaver 中，打开将运行预存过程的页。
  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并选择“预存过程”。

    出现“预存过程”对话框。

  3. 完成对话框。

    有关更多信息，请参见设置“预存过程”对话框的选项 (ASP.NET)。

  4. 单击“确定”。

在关闭了该对话框之后，Dreamweaver 在您的页中插入 ASP.NET 代码，当在服务器上运行该页时，将执行数据库中的预存过程。预存过程接着执行数据库操作，例如插入记录或执行查询。

如果预存过程接受参数，则您可以创建一个页，该页通过预存过程收集参数值并将参数值提交到页。例如，您可以创建一个使用 URL 参数或 HTML 表单从用户收集参数值的页。

相关主题

  • 预存过程


生成对站点访问进行限制的页 (ASP.NET)

您可以使用 Dreamweaver 生成一组对站点访问进行限制的页。Dreamweaver 没有针对 ASP.NET 页的身份验证服务器行为。但是，由于 ASP 和 ASP.NET 页可在同一站点上运行，您可以使用 ASP 身份验证服务器行为。您用于生成这些页面的方法与 ColdFusion 的方法完全相同。有关说明，请参见生成对站点访问进行限制的页（ColdFusion、ASP、JSP、PHP）。


参考资料

本节讲述本章中介绍的以下对话框和检查器：

  • 设置“asp:按钮”对话框的选项
  • 设置“asp:复选框”对话框的选项
  • 设置“asp:图像按钮”对话框的选项
  • 设置“asp:标签”对话框的选项
  • 设置“asp:单选按钮”对话框的选项
  • 设置“asp:文本框”对话框的选项
  • 设置“asp:复选框列表”对话框的选项
  • 设置“asp:下拉列表”对话框的选项
  • 设置“asp:列表框”对话框的选项
  • 设置“asp:单选按钮列表”对话框的选项
  • 设置按钮属性 (ASP.NET)
  • 设置复选框的属性 (ASP.NET)
  • 设置图像按钮的属性 (ASP.NET)
  • 设置标签的属性 (ASP.NET)
  • 设置单选按钮的属性 (ASP.NET)
  • 设置文本框的属性 (ASP.NET)
  • 设置复选框列表的属性 (ASP.NET)
  • 设置下拉列表的属性 (ASP.NET)
  • 设置列表框的属性 (ASP.NET)
  • 设置单选按钮列表的属性 (ASP.NET)
  • 设置“列表项”对话框的选项
  • 设置 ASP.NET 的“数据网格对象”对话框选项
  • 设置“简单数据域”对话框选项
  • 设置“自由格式”对话框选项
  • 设置“超级链接列”对话框选项
  • 设置“编辑、更新、取消按钮”对话框选项
  • 设置“删除按钮”对话框选项
  • 设置 ASP.NET“数据列表对象”对话框选项
  • 设置“添加数据域”对话框选项
  • 设置 ASP.NET 数据网格“属性”检查器选项
  • 设置 ASP.NET 数据列表“属性”检查器选项
  • 设置“更新记录表单”对话框的选项 (ASP.NET)
  • 设置“更新记录”对话框的选项 (ASP.NET)
  • 设置“删除记录”对话框的选项 (ASP.NET)
  • 设置“预存过程”对话框的选项 (ASP.NET)
  • 设置“编辑预存过程变量”对话框的选项 (ASP.NET)
  • 设置“生成值”对话框的选项 (ASP.NET)


设置“asp:按钮”对话框的选项

在页面中插入该表单控件时，使用此对话框设置其属性。

有关 ASP.NET 按钮属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconbuttonwebcontrol.asp 中的文档。


设置“asp:复选框”对话框的选项

在页面中插入该表单控件时，使用此对话框设置其属性。

有关 ASP.NET 复选框属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconcheckboxwebservercontrol.asp 中的文档。


设置“asp:图像按钮”对话框的选项

在页面中插入该表单控件时，使用此对话框设置其属性。

有关 ASP.NET 图像按钮属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconimagebuttonwebcontrol.asp 中的文档。


设置“asp:标签”对话框的选项

在页面中插入该表单控件时，使用此对话框设置其属性。

有关 ASP.NET 标签属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconlabelwebservercontrol.asp 中的文档。


设置“asp:单选按钮”对话框的选项

在页面中插入该表单控件时，使用此对话框设置其属性。

有关 ASP.NET 单选按钮属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconradiobuttonwebservercontrol.asp 中的文档。


设置“asp:文本框”对话框的选项

在页面中插入该表单控件时，使用此对话框设置其属性。

有关 ASP.NET 文本框属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpcontextboxwebservercontrol.asp 中的文档。


设置“asp:复选框列表”对话框的选项

在页面中插入该表单控件时，使用此对话框设置其属性。

若要填写“asp:复选框列表”对话框，请执行以下操作：

  1. 在“ID”文本框中，输入您要为该表单控件指定的名称。

    ID 是必需的。

  2. 指定以下任意选项：

    工具提示指定在浏览器中将鼠标指针置于表单控件上方时显示的文本。

    数据集指定要用来填充此列表控件的项的数据源。如果不指定数据集，您可以在以后指定，或者通过在属性检查器中单击“列表项”按钮静态设置列表项。

    获取标签自指定选定的数据集中用于提供列表项标签的字段。

    获取值自指定选定的数据集中用于提供列表项值的字段。

    访问键创建一个用于在浏览器中快速定位到表单控件的快捷键。例如，如果您输入 K，该用户便可以通过按 Alt+K 定位到该控件。访问键只能包含一个字符。

    自动回发指定当用户更改列表选择时是否自动回发到服务器。选择该选项将允许回发。

  3. 单击“确定”。

有关 ASP.NET 复选框列表属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconcheckboxlistwebservercontrol.asp 中的文档。


设置“asp:下拉列表”对话框的选项

在页面中插入该表单控件时，使用此对话框设置其属性。

若要完成“asp:下拉列表”对话框，请执行以下操作：

  1. 在“ID”文本框中，输入您要为该表单控件指定的名称。

    ID 是必需的。

  2. 指定以下任意选项：

    数据集指定要用来填充此列表控件的项的数据源。如果不指定数据集，您可以在以后指定，或者通过在属性检查器中单击“列表项”按钮静态设置列表项。

    获取标签自指定选定的数据集中用于提供列表项标签的字段。

    获取值自指定选定的数据集中用于提供列表项值的字段。

    选取值等于指定一个值，服务器使用该值确定当下拉列表在浏览器中显示时选中哪一个列表项。服务器将每一项的值与指定值进行比较。如果值相等，将选择相匹配的项。

    访问键创建一个用于在浏览器中快速定位到表单控件的快捷键。例如，如果您输入 K，该用户便可以通过按 Alt+K 定位到该控件。访问键只能包含一个字符。

    自动回发指定当用户更改列表选择时是否自动回发到服务器。选择该选项将允许回发。

  3. 单击“确定”。

有关 ASP.NET 下拉列表属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpcondropdownlistwebservercontrol.asp 中的文档。


设置“asp:列表框”对话框的选项

在页面中插入该表单控件时，使用此对话框设置其属性。

若要完成“asp:列表框”对话框，请执行以下操作：

  1. 在“ID”文本框中，输入您要为该表单控件指定的名称。

    ID 是必需的。

  2. 指定以下任意选项：

    数据集指定要用来填充此列表控件的项的数据源。如果不指定数据集，您可以在以后指定，或者通过在属性检查器中单击“列表项”按钮静态设置列表项。

    获取标签自指定选定的数据集中用于提供列表项标签的字段。

    获取值自指定选定的数据集中用于提供列表项值的字段。

    访问键创建一个用于在浏览器中快速定位到表单控件的快捷键。例如，如果您输入 K，该用户便可以通过按 Alt+K 定位到该控件。访问键只能包含一个字符。

    自动回发指定当用户更改列表选择时是否自动回发到服务器。选择该选项将允许回发。

  3. 单击“确定”。

有关 ASP.NET 列表框属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconlistboxwebservercontrol.asp 中的文档。


设置“asp:单选按钮列表”对话框的选项

在页面中插入该表单控件时，使用此对话框设置其属性。

若要填写“asp:单选按钮列表”对话框，请执行以下操作：

  1. 在“ID”文本框中，输入您要为该表单控件指定的名称。

    ID 是必需的。

  2. 指定以下任意选项：

    工具提示指定在浏览器中将鼠标指针置于表单控件上方时显示的文本。

    数据集指定要用来填充此列表控件的项的数据源。如果不指定数据集，您可以在以后指定，或者通过在属性检查器中单击“列表项”按钮静态设置列表项。

    获取标签自指定选定的数据集中用于提供列表项标签的字段。

    获取值自指定选定的数据集中用于提供列表项值的字段。

    选取值等于指定一个值，服务器使用该值确定当单选按钮列表在浏览器中显示时选中哪一个列表项。服务器将每一项的值与指定值进行比较。如果值相等，将选择相匹配的项。

    访问键创建一个用于在浏览器中快速定位到表单控件的快捷键。例如，如果您输入 K，该用户便可以通过按 Alt+K 定位到该控件。访问键只能包含一个字符。

    自动回发指定当用户更改列表选择时是否自动回发到服务器。选择该选项将允许回发。

  3. 单击“确定”。

有关 ASP.NET 单选按钮列表属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconradiobuttonlistwebservercontrol.asp 中的文档。


设置按钮属性 (ASP.NET)

使用该“属性”检查器设置表单控件的属性。

有关 ASP.NET 按钮属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconbuttonwebcontrol.asp 中的文档。


设置复选框的属性 (ASP.NET)

使用该“属性”检查器设置表单控件的属性。

有关 ASP.NET 复选框属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconcheckboxwebservercontrol.asp 中的文档。

您可以让服务器来决定是否选中该复选框控件。在运行时，服务器将对指定的值与数据集中的值进行比较。如果两个值匹配，服务器将选中该复选框。

若要让服务器在运行时确定复选框的状态，请执行以下操作：

  1. 在属性检查器中选择“动态”选项。
  2. 完成“动态复选框”对话框。

    有关说明，请单击对话框中的“帮助”按钮。


设置图像按钮的属性 (ASP.NET)

使用该“属性”检查器设置表单控件的属性。

有关 ASP.NET 图像按钮属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconimagebuttonwebcontrol.asp 中的文档。


设置标签的属性 (ASP.NET)

使用该“属性”检查器设置表单控件的属性。

有关 ASP.NET 标签属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconlabelwebservercontrol.asp 中的文档。


设置单选按钮的属性 (ASP.NET)

使用该“属性”检查器设置表单控件的属性。

有关 ASP.NET 单选按钮属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconradiobuttonwebservercontrol.asp 中的文档。

您可以让服务器决定选中单选按钮组中的哪一个单选按钮。在运行时，服务器将对您指定的每一个选中的值与数据集中的值进行比较。如果值匹配，服务器将选中该单选按钮。

若要让服务器在运行时选中单选按钮组中的一个单选按钮，请执行以下操作：

  1. 在属性检查器中选择“动态”选项。
  2. 完成“动态单选按钮组”对话框。

    有关说明，请单击对话框中的“帮助”按钮。


设置文本框的属性 (ASP.NET)

使用该“属性”检查器设置表单控件的属性。

有关 ASP.NET 文本框属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpcontextboxwebservercontrol.asp 中的文档。


设置复选框列表的属性 (ASP.NET)

使用该“属性”检查器设置表单控件的属性。

有关 ASP.NET 复选框列表属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconcheckboxlistwebservercontrol.asp 中的文档。


设置下拉列表的属性 (ASP.NET)

使用该“属性”检查器设置表单控件的属性。

有关 ASP.NET 下拉列表属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpcondropdownlistwebservercontrol.asp 中的文档。


设置列表框的属性 (ASP.NET)

使用该“属性”检查器设置表单控件的属性。

有关 ASP.NET 列表框属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconlistboxwebservercontrol.asp 中的文档。


设置单选按钮列表的属性 (ASP.NET)

使用该“属性”检查器设置表单控件的属性。

有关 ASP.NET 单选按钮列表属性的更多信息，请参见 Microsoft Web 站点 http://msdn.microsoft.com/library/en-us/cpgenref/html/cpconradiobuttonlistwebservercontrol.asp 中的文档。


设置“列表项”对话框的选项

此对话框用于填充如下拉列表或列表框等 ASP.NET 表单控件的列表。

若要设置对话框的选项，请执行以下操作：

  1. 根据您打算填充列表的方式，选择“手动”或“来自数据库”。
  2. 如果选择“手动”，请执行以下操作：
    • 若要添加列表项，单击加号 (+) 按钮，然后在“标签”和“值”文本框中指定标签和值。
    • 若要删除列表项，请在列表中选择该项，然后单击减号 (-) 按钮。
    • 若要编辑列表项，选择该列表项，然后在“标签”和“值”文本框中指定新的标签和值。
    • 要指定首次显示列表时的默认项，请在“选取值等于”文本框中输入该项的值。
  3. 如果选择“来自数据库”，请执行以下操作：
    • 选择将要填充列表的数据集。
    • 指定将要提供列表项标签的数据集列。
    • 指定将要提供列表项值的数据集列。
    • 要指定首次显示列表时的默认项，请在“选取值等于”文本框中输入该项的值。


设置 ASP.NET 的“数据网格对象”对话框选项

“数据网格对象”对话框使您可以创建数据网格对象并将其添加到 ASP.NET 页面。

若要设置 ASP.NET 的“数据网格对象”对话框，请执行以下操作：

  1. 选择数据网格对象的 ID 属性（或标签）。

    该域中预先填充了一个值。可以更改数据网格的值；但是，如果将该域的值设置成现有的 ID 值，系统会提示您输入新的属性值。

  2. 选择与数据网格关联的数据集。

    数据网格将从这个数据集中检索信息。Dreamweaver 会用所选数据集中的所有域的绑定列填写“网格列”框。

  3. 指定要显示的记录数。
  4. 选择要实现的页面导航链接类型。
    • “到前一页和下一页的链接”项添加“下一页”和“前一页”链接。
    • “到每一页的编号链接”项添加页码链接，例如“1 2 3 4 5 n...”。
  5. 删除不想要的网格列，方法是在“网格列”框中选定它们，然后单击减号 (-) 按钮。
  6. 可以编辑剩余的网格列。方法是，在“网格列”框中选择某列，然后设置其属性。

    若要更改数据网格的列类型，请单击“编辑”按钮并从弹出菜单中选择列类型。随即出现一个特定于所选列类型的对话框。指定所选数据网格列的内容和格式。下表列出了列类型：

    数据网格列类型

    描述

    简单数据域

    “简单数据域”列在 ASP.NET 中称为“绑定列”，它使您可以指定要显示的数据源域，以及该域在用于 .NET 格式表达式时使用的数据格式。

    自由格式

    “自由格式”列在 ASP.NET 中称为“模板列”，它使您可以创建 HTML 文本和服务器控件的组合，为列设计自定义布局。自由格式列中的控件可以是数据绑定控件。自由格式列在定义网格内容的布局和功能方面为您提供了更大的灵活性。原因是，您可以完全控制数据的显示方式以及用户与网格中的行交互时所发生的事情。

    超级链接

    “超级链接列”显示超级链接形式的信息。它的典型用法是显示超级链接形式的数据（如客户编号或产品名称），用户单击超级链接后，可以导航到一个单独的页面，上面提供了有关该项目的详细信息。

    编辑、更新、取消按钮

    “编辑、更新、取消按钮”列在 ASP.NET 中称为“编辑命令”列，它允许用户对数据网格行中的信息进行就地编辑。为此，需要创建“编辑、更新、取消”列。在运行时，该列会显示一个被标记为“编辑”的按钮。当用户单击“编辑”按钮时，在文本框这类可编辑控件中会显示行数据，并且“编辑”按钮被替换为“更新”按钮和“取消”按钮。

    删除按钮

    “删除按钮”使用户可以通过单击按钮删除特定的行。
  7. 对于要更改的每一列重复上一步骤。
  8. 若要更改数据网格中的列顺序，请在“网格列”框中选择某列，然后单击向上箭头或向下箭头，使该列在数据网格中左移或右移。
  9. 单击“确定”关闭对话框并创建数据网格。

相关主题

  • 将 ASP.NET 数据网格添加到页面中


设置“简单数据域”对话框选项

“简单数据域”列（在 ASP.NET 中称为绑定列）使您可以指定要显示的数据源域，以及该域在用于 .NET 格式表达式时使用的数据格式。

若要设置“简单数据域”对话框选项，请执行以下操作：

  1. “标题”文本框使您可以将标题插入网格的标题行或脚注行中。（数据网格的标题行或脚注行的显示是由数据网格属性检查器控制的。）
  2. 从“数据域”弹出菜单中选择用来填充数据网格列的数据集列。
  3. 单击“只读”复选框以指定数据网格不允许添加、更新或删除权限。
  4. 从“提交为”弹出菜单中选择数据类型。
  5. 单击“确定”。

相关主题：

  • 将 ASP.NET 数据网格添加到页面中
  • 修改数据网格或数据列表对象
  • 设置 ASP.NET 数据网格“属性”检查器选项


设置“自由格式”对话框选项

“自由格式”选项（在 ASP.NET 中称为模板列）使您可以创建 HTML 文本和服务器控件的组合，为列设计自定义布局。自由格式列中的控件可以是数据绑定控件。自由格式列在定义网格内容的布局和功能方面为您提供了更大的灵活性。原因是，您可以完全控制数据的显示方式以及用户与网格中的行交互时所发生的事情。

若要设置“自由格式”对话框选项，请执行以下操作：

  1. “标题”文本框使您可以将标题插入网格的标题行或脚注行中。（数据网格的标题行或脚注行的显示是由数据网格属性检查器控制的。）
  2. 从“模板”弹出菜单中选择用于自由格式数据网格的模板。
  3. 单击“添加数据域”按钮，选择用来填充网格列的数据集列。

    “添加数据域”对话框随即出现。在该对话框中选择数据集列并单击“确定”后，Dreamweaver 会在“内容”文本框中添加适当的数据绑定表达式。

  4. 对自由格式列进行格式化，方法是在“内容”文本框中用 HTML 标记将绑定表达式括起来。
  5. 从“提交为”弹出菜单中选择数据类型。
  6. 单击“确定”。

相关主题

  • 将 ASP.NET 数据网格添加到页面中
  • 修改数据网格或数据列表对象
  • 设置 ASP.NET 数据网格“属性”检查器选项


设置“超级链接列”对话框选项

“超级链接列”显示超级链接形式的信息。它的典型用法是显示超级链接形式的数据（如客户编号或产品名称），用户单击超级链接后，可以导航到一个单独的页面，上面提供了有关该项目的详细信息。

若要设置“超级链接列”对话框的选项，请执行以下操作：

  1. 在“标题”文本框中输入列的名称。
  2. 从“超级链接文本”部分，选择“静态文本”或“数据域”选项。如果选择“静态文本”，请在“静态文本”文本框中输入超级链接的文本。如果选择“数据域”，请从“数据域”弹出菜单中选择提供超级链接文本的数据集列。
  3. 从“链接页”部分，选择“静态 URL”或“数据域”选项。如果选择“静态 URL”，请在“静态 URL”文本框中输入目标页面的 URL（可以使用“静态 URL”文本框右侧的浏览按钮浏览到目标页面）。如果选择“数据域”，请从“数据域”弹出菜单中选择提供 URL 的数据集列。
  4. 如果使用“数据域”选项创建超级链接，可以通过“格式字符串”文本框为超级链接文本指定格式表达式。有关格式表达式的更多信息，请参考相应的 ASP.NET 文档中的数据网格 String.Format 方法。
  5. 单击“确定”。

相关主题：

  • 将 ASP.NET 数据网格添加到页面中
  • 修改数据网格或数据列表对象
  • 设置 ASP.NET 数据网格“属性”检查器选项


设置“编辑、更新、取消按钮”对话框选项

“编辑、更新、取消按钮”列（在 ASP.NET 中称为“编辑命令列”）允许用户对数据网格行中的信息进行就地编辑。为此，需要创建“编辑、更新、取消”列。在运行时，该列会显示一个被标记为“编辑”的按钮。当用户单击“编辑”按钮时，在文本框这类可编辑控件中会显示行数据，并且“编辑”按钮被替换为“更新”按钮和“取消”按钮。

若要设置“编辑、更新、取消按钮”框选项，请执行以下操作：

  1. 在“标题”文本框中输入列的名称。
  2. 从“按钮类型”弹出菜单中选择链接按钮或普通按钮。在运行时，该列会显示一个被标记为“编辑”的按钮。链接按钮使用文本链接，而普通按钮则使用图像。
  3. 从“更新表格”弹出菜单中选择用户将修改其数据的数据库表。
  4. 从“主键”弹出菜单中选择与表关联的主键。
  5. 从“提交为”弹出菜单中选择数据类型。
  6. 单击“确定”。

相关主题

  • 将 ASP.NET 数据网格添加到页面中
  • 修改数据网格或数据列表对象
  • 设置 ASP.NET 数据网格“属性”检查器选项


设置“删除按钮”对话框选项

“删除按钮”（在 ASP.NET 中也称为按钮列）允许用户通过单击按钮删除特定的行。

若要设置“删除按钮”对话框选项，请执行以下操作：

  1. 在“标题”文本框中输入列的名称。
  2. 从“按钮类型”弹出菜单中选择链接按钮或普通按钮。在运行时，该列会显示一个带“删除”标签的按钮。链接按钮使用文本链接，而普通按钮则使用图像。
  3. 从“删除自”弹出菜单中选择用户将删除其数据的数据库表。
  4. 从“主键”弹出菜单中选择与表关联的主键。
  5. 从“提交为”弹出菜单中选择数据类型。
  6. 单击“确定”。

相关主题

  • 将 ASP.NET 数据网格添加到页面中
  • 修改数据网格或数据列表对象
  • 设置 ASP.NET 数据网格“属性”检查器选项


设置 ASP.NET“数据列表对象”对话框选项

该对话框创建 ASP.NET 数据列表对象并将其添加到页面。这种对象仅适用于 ASP.NET 文档类型。

若要设置 ASP.NET“数据列表对象”对话框选项，请执行以下操作：

  1. 如果愿意，可更改数据列表的名称。

    Dreamweaver 为数据列表提供了默认名称。

  2. 将一个数据集与该数据列表关联。

    可以选择现有的数据集或输入任意值。默认情况下选择列表中的第一个数据集。

  3. 若要组织表格中的项目，请选择“组织表格中各项”选项。

    如果使用表格，请指定表格中的列数。如果列数大于一，请指定表格单元格的填充顺序：选择“自上而下换行”选项可使数据水平换行；而选择“从左到右换行”则使数据垂直换行。

  4. 依次执行下列操作，指定要在数据列表中显示的数据：
    • 为“模板”列表选择“项目”模板。“项目”模板表示列表中除标题和脚注行之外的所有行。
    • 单击“将数据域添加到内容”按钮。“添加数据域”对话框随即出现。
    • 选择数据集列并单击“确定”关闭对话框。Dreamweaver 在“数据列表对象”对话框的“内容”框中添加适当的数据绑定表达式。
    • 在“内容”框中，用 HTML 标记将绑定表达式括起来，对要显示的数据设置格式。
  5. 根据需要，调整数据列表的布局。

    可以控制数据列表的布局。方法是，从“模板”列表中的模板进行选择，然后在“内容”文本框中添加 HTML 标签。可用的模板有：

    模板

    描述

    标题

    在列表开头呈现的文本和控件。

    项

    为数据源中的每一行呈现一次的 HTML 元素和控件。

    交替项

    类似于“项目模板”元素，但在数据列表中每隔一行呈现一次。如果使用该模板，通常会为它创建不同的外观，例如与“项目”模板具有不同的背景颜色等。

    编辑项

    编辑状态下项目的布局。该模板通常包含文本框之类的编辑控件。

    选择项

    用户在数据列表中选择某项时呈现的元素。典型的用法是以可视方式用背景颜色或字体颜色标记行。您也可以通过显示数据源中的其它域来展开该项。

    分隔符

    在各项之间呈现的元素。典型的例子可能是一条线（使用 <HR> 元素）。

    脚注

    在列表最后呈现的文本和控件。
  6. 单击“确定”关闭对话框并创建数据列表。

相关主题

  • 将 ASP.NET 数据列表添加到页面中
  • 修改数据网格或数据列表对象


设置“添加数据域”对话框选项

该对话框使您可以将数据集列与数据网格对象或数据列表对象关联。

若要设置“添加数据域”对话框选项，请执行以下操作：

  • 选择数据集列（“数据域”）并单击“确定”。

相关主题

  • 设置 ASP.NET 的“数据网格对象”对话框选项
  • 设置 ASP.NET“数据列表对象”对话框选项


设置 ASP.NET 数据网格“属性”检查器选项

数据网格“属性”检查器可让您更改数据网格的名称、调整单元格边距和单元格间距值以及显示列的标题或脚注。

若要修改数据网格，请执行以下操作：

  1. 若要修改数据网格，请更改以下任一设置：

    “数据网格”框使您可以更改数据网格的名称。

    “高级”按钮使您可以打开“数据网格对象”对话框。有关更多信息，请参见设置 ASP.NET 的“数据网格对象”对话框选项。

    “单元格边距”框使您可以调整网格单元格的单元格边距。

    “单元格间距”框使您可以调整网格单元格的单元格间距。

    “显示列标题”选项使您可以启用或禁用标题。

    “显示列脚注”选项使您可以启用或禁用脚注。

  2. 按 Enter 键 (Windows) 或 Return 键 (Macintosh) 应用您所做的更改。

相关主题

  • 将 ASP.NET 数据网格添加到页面中
  • 设置 ASP.NET 的“数据网格对象”对话框选项


设置 ASP.NET 数据列表“属性”检查器选项

该“属性”检查器使您可以修改页面上的 ASP.NET 数据列表。

若要修改数据列表，请执行以下操作：

  1. 若要修改数据列表，请更改以下任一设置：

    “数据列表”框使您可以更改数据列表的名称。

    “高级”按钮使您可以打开“数据列表对象”对话框。

    “显示列标题”选项打开和关闭标题。

    “显示列脚注”选项打开和关闭脚注。

  2. 按 Enter 键 (Windows) 或 Return 键 (Macintosh) 应用您所做的更改。

相关主题

  • 将 ASP.NET 数据列表添加到页面中


设置“更新记录表单”对话框的选项 (ASP.NET)

此对话框用于建立一个允许用户更新数据库中记录的页。

在开始之前，您必须完成以下任务：

  • 建立一个或多个页使用户可以查找要更新的记录。有关更多信息，请参见搜索要更新的记录 (ASP.NET)。
  • 将逻辑添加到更新页，允许它从数据库中检索用户选定的记录，准备进行更新。有关说明，请参见检索要更新的记录 (ASP.NET)。

实现了这些前提条件之后，您可以按以下步骤完成该对话框。

若要设置对话框的选项，请执行以下操作：

  1. 在“连接”弹出菜单中，选择一个到数据库的连接。

    如果您需要定义连接，则单击“定义”按钮。

  2. 在“表格”弹出菜单中，选择包含要更新的记录的数据库表格。
  3. 在“选取记录自”弹出菜单中，指定包含显示在 HTML 表单上的记录的数据集。
  4. 在“唯一键列”弹出菜单中，选择一个键列（通常是记录 ID 列）来标识数据库表中的记录。
  5. 在“提交唯一键为”弹出菜单中，选择一个数据类型。
  6. 在“如果成功，则转到”文本框中，输入服务器行为成功运行后所显示的页的位置或单击“浏览”按钮浏览到该位置。
  7. 在“如果失败，则转到”文本框中，输入如果服务器行为失败所显示的页的位置或单击“浏览”按钮浏览到该位置。
  8. 如果要在服务器行为失败时显示调试信息，则选择“失败时显示调试信息”复选框。

    如果选择了此选项，则 Dreamweaver 将忽略“如果失败，则转到”选项。

    提示

    在开发过程中使用调试选项，在站点处于活动状态时使用“如果失败，则转到”选项。
  9. 在“表单字段”区域中，指定每个表单对象应该更新数据库表格中的哪些列。

    默认情况下，Dreamweaver 为数据库表格中的每个列创建一个表单对象。如果您的数据库为创建的每个新记录都自动生成唯一键 ID，则需删除对应于该键列的表单对象，方法是在列表中将其选中然后单击减号 (-) 按钮。这消除了表单的用户输入已存在的 ID 值的风险。

    您还可以更改 HTML 表单上表单对象的顺序，方法是在列表中选中某个表单对象然后单击对话框右侧的向上或向下箭头。

  10. 指定每个数据输入字段在 HTML 表单上的显示方式；方法是单击“表单字段”表格中的一行，然后在表格下面的框中输入以下信息：
    • 在“标签文字”框中，输入显示在数据输入字段旁边的描述性标签文字。默认情况下，Dreamweaver 在该标签中显示表列的名称。
    • 在“显示为”弹出菜单中，选择一个表单对象充当数据输入字段。您可以选择“文本字段”、“文本区域”、“菜单”、“复选框”、“单选按钮组”和“文本”。对于只读项，请选择“文本”。您还可以选择“密码域”、“文件域”和“隐藏域”。

      注意

      “隐藏字段”插入在表单的结尾。
    • 在“提交为”弹出菜单中，选择您的数据库表需要的数据格式。例如，如果表列只接受数字数据，则选择“数字”。
    • 设置表单对象的属性。根据您选择作为数据输入字段的表单对象的不同，您有不同的选项。对于文本字段、文本区域和文本，您可以输入初始值。对于菜单和单选按钮组，将打开另一个对话框来设置属性。对于复选框，选择“已选中”或“未选中”选项。
  11. 通过选择另一个表单字段行并输入标签文字、显示为值和提交为值来设置其他表单对象的属性。

    对于菜单和单选按钮组，打开另一个对话框来设置属性。对于复选框，定义一个复选框当前记录的值和给定值之间的比较，以确定当显示记录时是否选中了该复选框。

  12. 单击“确定”。

Dreamweaver 将 HTML 表单和“更新记录”服务器行为添加到您的页中。

相关主题

  • 在一个操作中完成更新页 (ASP.NET)
  • 插入动态 HTML 表单对象


设置“更新记录”对话框的选项 (ASP.NET)

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表中更新记录。

在开始之前，您必须完成以下任务：

  • 建立一个或多个页使用户可以查找要更新的记录。有关更多信息，请参见搜索要更新的记录 (ASP.NET)。
  • 将逻辑添加到更新页，允许它从数据库中检索用户选定的记录，准备进行更新。有关说明，请参见检索要更新的记录 (ASP.NET)。
  • 将 HTML 表单添加到更新页以允许用户修改数据。有关说明，请参见逐块完成更新页 (ASP.NET)。

实现了这些前提条件之后，您可以完成“更新记录”对话框。

若要设置对话框的选项，请执行以下操作：

  1. 从“提交值，自”弹出菜单中选择一个表单。
  2. 在“连接”弹出菜单中，选择一个到数据库的连接。

    如果您需要定义连接，则单击“定义”按钮。

  3. 在“更新表格”弹出菜单中，选择包含您正在更新的记录的数据库表。
  4. 指定要更新的数据库列，从“值”弹出菜单中选择将更新该列的表单对象，从“提交为”弹出菜单中为该表单对象选择数据类型，并且如果要将此列标识为主键，还应选择“主键”。

    数据类型是数据库表中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  5. 在“如果成功，则转到”文本框中，输入服务器行为成功运行后所显示的页的位置或单击“浏览”按钮浏览到该位置。
  6. 在“如果失败，则转到”文本框中，输入如果服务器行为失败所显示的页的位置或单击“浏览”按钮浏览到该位置。
  7. 如果要在服务器行为失败时显示调试信息，则选择“失败时显示调试信息”复选框。

    如果选择了此选项，则 Dreamweaver 将忽略“如果失败，则转到”选项。

    提示

    在开发过程中使用调试选项，在站点处于活动状态时使用“如果失败，则转到”选项。
  8. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过修改显示在 HTML 表单中的信息并单击“提交”按钮更新数据库表中的记录。

相关主题

  • 逐块完成更新页 (ASP.NET)


设置“删除记录”对话框的选项 (ASP.NET)

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表中删除记录。

若要设置对话框的选项，请执行以下操作：

  1. 在“先检查是否定义了变量”弹出菜单中，选择“主键值”。

    如果您要检查一个变量（该变量不是标识要删除记录的那个变量），则选中该变量，然后输入其名称。

    Dreamweaver 检查是否定义了该变量。

  2. 在“连接”弹出菜单中，选择一个连接，这样页面就可以查找并连接到该数据库。

    如果您需要定义连接，则单击“定义”按钮。

  3. 在“表格”弹出菜单中，选择包含要删除的记录的数据库表。
  4. 在“主键列”弹出菜单中，选择一个键列在数据库表中标识该记录。
  5. 在“提交主键作为”弹出菜单中，选择一个数据类型。

    数据类型是数据库表中的列所需的数据种类（文本、数字、布尔型复选框值）。

  6. 在“主键值”弹出菜单中，选择标识要删除记录的变量，然后输入其名称。
  7. 在“如果成功，则转到”文本框中，输入如果删除成功所显示的页的位置或单击“浏览”按钮浏览到该位置。
  8. 在“如果失败，则转到”文本框中，输入如果删除失败所显示的页的位置或单击“浏览”按钮浏览到该位置。
  9. 如果要在删除失败时显示调试信息，则选择“失败时显示调试信息”复选框。

    如果选择了此选项，则 Dreamweaver 将忽略“如果失败，则转到”选项。

    提示

    在开发过程中使用调试选项，在站点处于活动状态时使用“如果失败，则转到”选项。
  10. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过单击表单上的“提交”按钮删除数据库表中的记录。


设置“预存过程”对话框的选项 (ASP.NET)

此对话框用于设置 ASP.NET 页以使用预存过程。

若要设置对话框的选项，请执行以下操作：

  1. 输入预存过程的名称。
  2. 在“连接”弹出菜单中，选择一个到包含预存过程的数据库的连接。

    如果您需要定义连接，则单击“定义”按钮。

  3. 从“过程”弹出菜单中选择一个预存过程。

    Dreamweaver 自动填写任何参数。

  4. 如果预存过程返回数据集，请选择“返回数据集”复选框，然后单击“测试”按钮查看预存过程返回的数据集。
  5. 选择一个参数，然后单击“编辑”按钮（如果您需要进行更改）或单击“删除”按钮删除该参数。

    有关更多信息，请参见设置“编辑预存过程变量”对话框的选项 (ASP.NET)。

  6. 在“如果成功，则转到”文本框中，输入预存过程成功运行后所显示的页的位置或单击“浏览”按钮浏览到该位置。
  7. 在“如果失败，则转到”文本框中，输入如果预存过程失败所显示的页的位置或单击“浏览”按钮浏览到该位置。
  8. 如果要在预存过程失败时显示调试信息，则选择“失败时显示调试信息”复选框。

    如果选择了此选项，则 Dreamweaver 将忽略“如果失败，则转到”选项。

    提示

    在开发过程中使用调试选项，而后在站点处于活动状态时使用“如果失败，则转到”选项。
  9. 单击“确定”。

在关闭了“预存过程”对话框之后，Dreamweaver 在您的页中插入 ASP.NET 代码，当在服务器上运行该页时，将调用数据库中的预存过程。预存过程接着执行数据库操作，例如插入记录。

相关主题

  • 预存过程
  • 使用预存过程修改数据库 (ASP.NET)


设置“编辑预存过程变量”对话框的选项 (ASP.NET)

此对话框用于编辑预存过程参数。您可以按需要更改值。

若要设置对话框的选项，请执行以下操作：

  1. 正在编辑的变量名显示在“名称”文本框中。
  2. 从弹出菜单中选择变量类型。
  3. 输入变量的大小。
  4. 从弹出式菜单中选择一个方向。

    预存过程可能具有输入值、输出值、或者既具有输入值又具有输出值。

  5. 输入测试值。
  6. 输入一个值。
  7. 单击“生成”按钮生成值。

    即会出现“生成值”对话框。若要完成此对话框，请参见设置“生成值”对话框的选项 (ASP.NET)。

  8. 单击“确定”。

相关主题

  • 设置“预存过程”对话框的选项 (ASP.NET)
  • 使用预存过程修改数据库 (ASP.NET)


设置“生成值”对话框的选项 (ASP.NET)

此对话框用于生成您的预存过程值。

若要设置对话框的选项，请执行以下操作：

  1. 从弹出菜单中选择一个来源。
  2. 输入默认值。
  3. 单击“确定”。

相关主题

  • 设置“编辑预存过程变量”对话框的选项 (ASP.NET)
  • 设置“预存过程”对话框的选项 (ASP.NET)
  • 使用预存过程修改数据库 (ASP.NET)


快速生成 ASP 和 JSP 应用程序

使用 Macromedia Dreamweaver 8 中的工具可以快速生成 ASP 或 JSP Web 应用程序，只需要很少甚至不需要编码。

本章包含下列章节：

生成主/详细页（ASP 和 JSP）

生成搜索/结果页（ASP 和 JSP）

生成记录插入页（ASP 和 JSP）

生成更新记录的页面（ASP 和 JSP）

生成删除记录的页面（ASP 和 JSP）

使用高级的数据操作对象来生成页面（ASP 和 JSP）

生成限制对站点的访问的页（ASP 和 JSP）

使用 JavaBeans (JSP)

相关主题

  • 关于快速应用程序开发（所有服务器）


生成主/详细页（ASP 和 JSP）

使用 Dreamweaver 可以创建以两个明细级别表示信息的页面集：主页列出记录，详细页显示有关各记录的更多详细信息。本节介绍如何生成主/详细页。

本节包含以下主题：

  • 在一个操作中生成主/详细页（ASP 和 JSP）
  • 逐块生成主/详细页（ASP 和 JSP）


在一个操作中生成主/详细页（ASP 和 JSP）

开发 ASP 或 JSP 应用程序时，使用主/详细页集应用程序对象可以快速生成主/详细页。应用程序对象可以通过完成一两个对话框来生成一组完整的动态页。

您使用的方法与 ColdFusion 的方法完全相同。有关说明，请参见在一次操作中生成主/详细页（ColdFusion、ASP、JSP、PHP）。

您还可以使用单独的服务器行为来建立主/详细页。有关更多信息，请参见逐块生成主/详细页（ASP 和 JSP）。


逐块生成主/详细页（ASP 和 JSP）

本节描述在不使用“主/详细页集”应用程序对象的情况下如何生成主/详细页集。有关使用应用程序对象的指导，请参见在一个操作中生成主/详细页（ASP 和 JSP）。

本节介绍生成一组主/详细页的步骤：

  • 创建主页并为其定义记录集（ASP 和 JSP）
  • 在主页上显示记录（ASP 和 JSP）
  • 打开详细页并将记录 ID 传递给它（ASP 和 JSP）
  • 查找请求的记录并在详细页上显示（ASP 和 JSP）


创建主页并为其定义记录集（ASP 和 JSP）

生成主/详细页的第一步是创建一个空主页并向其中添加一个记录集。

您可以在设计时定义记录集（请参见定义记录集），或者由用户在运行时定义记录集（请参见生成搜索/结果页（ASP 和 JSP））。

确保该记录集不仅包含主页所需的所有列，还包含详细页所需的所有列。

通常，主页上的记录集提取数据库表格中的少数几列，而详细页上的记录集提取同一表格中的更多列以提供额外的详细信息。

创建主/详细页的下一步是在主页上显示记录。请参见在主页上显示记录（ASP 和 JSP）。


在主页上显示记录（ASP 和 JSP）

创建一个空主页并为其定义记录集后（请参见创建主页并为其定义记录集（ASP 和 JSP）），必须在该页面上显示记录。

若要在主页上显示记录，请执行以下操作：

  1. 创建页面布局以显示多条记录，并把记录集列绑定到该页面。

    通常的做法是：先在主页上创建一个两行的 HTML 表，然后将有限数目的记录集列从“绑定”面板（“窗口”>“绑定”）上拖动到该表的第二行中。（使用第一行显示表格的列标题。）

  2. 创建重复区域以同时显示多条记录。

    重复区域通常应用于包含动态内容的表行。有关更多信息，请参见显示多个记录集结果。

创建主/详细页的下一步是打开详细页并将记录 ID 传递给它。请参见打开详细页并将记录 ID 传递给它（ASP 和 JSP）。


打开详细页并将记录 ID 传递给它（ASP 和 JSP）

创建主页并在其中显示记录后（请参见在主页上显示记录（ASP 和 JSP）），必须创建用于打开详细页并将用户所选记录的 ID 传递给详细页的链接。

若要打开详细页并将标识要显示的记录的 URL 参数传递到该页，请执行以下操作：

  1. 在主页上的重复区域中，选择要兼作链接的动态内容。
  2. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后从弹出菜单中选择“转到详细页面”。

    “转到详细页面”对话框随即出现。

  3. 完成对话框。

    有关更多信息，请单击对话框上的“帮助”按钮。

  4. 单击“确定”。

Dreamweaver 在所选文本周围放置一个特殊链接。当用户单击该链接时，“转到详细页面”服务器行为将一个包含记录 ID 的 URL 参数传递到详细页。例如，如果 URL 参数的名称为 id，详细页的名称为 customerdetail.asp，则当用户单击该链接时，URL 看起来应该像下面这样：

http://www.mysite.com/customerdetail.asp?id=43

URL 的第一部分 http://www.mysite.com/customerdetail.asp 用于打开详细页。第二部分 ?id=43 是 URL 参数。它告诉详细页要查找和显示哪个记录。术语 id 是 URL 参数的名称，43 是它的值。在本例中，URL 参数包含记录的 ID 号，即 43。

有关更多信息，请参见 URL 参数。

创建主/详细页的下一步是查找请求的记录并将其显示在详细页上。请参见查找请求的记录并在详细页上显示（ASP 和 JSP）。


查找请求的记录并在详细页上显示（ASP 和 JSP）

完成主页后（请参见打开详细页并将记录 ID 传递给它（ASP 和 JSP）），必须在数据库中查找请求的记录并将其显示在详细页上。该过程由两个步骤组成：首先，定义一个记录集以存储单个记录（即主页请求的记录）；然后，将记录集列绑定到页面上。

若要查找请求的记录并在详细页上显示，请执行以下操作：

  1. 切换到详细页，如果它尚不存在，可创建一个新的 ASP 或 JSP 页。
  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并从弹出菜单中选择“记录集”。

    出现简单的“记录集”对话框。如果出现的是高级对话框，请单击“简单”进行切换。

  3. 命名该记录集，然后选择一个连接和将向记录集提供数据的数据库表。
  4. 在“列”区域中，选择要包括在记录集中的表列。

    详细页上的记录集可以与主页上的记录集相同，也可以不同。通常，详细页记录集的列数更多，可以显示更多的详细信息。

    如果记录集不同，则详细页上的记录集至少应包含一个与主页上的记录集相同的列。这个公共列通常是记录 ID 列，但也可以是相关表格的连结字段。

    若要使记录集中只包括某些表列，请单击“已选定”，然后按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 列表中的列，以选择所需列。

  5. 如下所示完成“筛选”部分，以便查找和显示结果页所传递的 URL 参数中指定的记录：
    • 从“筛选”区域的第一个弹出菜单中选择数据库表中的列，该列包含与主页传递的 URL 参数值相匹配的值。

      例如，如果 URL 参数包含一个记录 ID 号，则选择包含记录 ID 号的列。

    • 从第一个菜单旁边的弹出式菜单中选择等号（它应该已被选定）。
    • 从第三个弹出菜单中选择 URL 参数。

      主页通过 URL 参数将标识用户所选内容的信息传递到详细页。

    • 在第四个文本框中，输入由主页传递的 URL 参数的名称。

      例如，如果主页用于打开详细页的 URL 是 www.mysite.com/customerdetail.asp?id=43，则请输入 id。

      您还可以用下面的方法获得该名称：切换到主页，打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“转到详细页面”服务器行为。检查“传递 URL 参数”的名称。

  6. 单击“确定”。

    记录集随即出现在“绑定”面板中。

  7. 通过下面的方法将记录集列绑定到详细页：在“绑定”面板（“窗口”>“绑定”）上选择列，然后将其拖到页面上。

主/详细页设置已完成。

创建主/详细页后，可以使用“服务器行为”面板（“窗口”>“服务器行为”）来修改各种服务器行为。


生成搜索/结果页（ASP 和 JSP）

可以使用 Dreamweaver 建立一组页面，使用户可以搜索您的数据库。您使用的方法与 ColdFusion 的方法完全相同。有关说明，请参见建立搜索/结果页（ColdFusion、ASP、JSP、PHP）。


生成记录插入页（ASP 和 JSP）

可以用 Dreamweaver 生成一个允许用户向数据库插入新记录的页。您所使用的方法对于所有 Dreamweaver 支持的服务器技术而言完全相同。有关说明，请参见建立记录插入页（所有服务器）。


生成更新记录的页面（ASP 和 JSP）

您的应用程序可以包含允许用户更新数据库表中现有记录的一组页。这组页通常由一个搜索页、一个结果页和一个更新页组成。用户可以使用搜索页和结果页检索记录，使用更新页修改记录。

本节介绍生成页面用于更新记录的步骤：

  • 搜索要更新的记录（ASP 和 JSP）
  • 打开更新页并传递记录的 ID（ASP 和 JSP）
  • 检索要更新的记录（ASP 和 JSP）
  • 在一个操作中完成更新页（ASP 和 JSP）
  • 逐块完成更新页（ASP 和 JSP）

相关主题

  • 建立记录插入页（所有服务器）
  • 生成删除记录的页面（ASP 和 JSP）


搜索要更新的记录（ASP 和 JSP）

当用户要更新某个记录时，他们必须首先在数据库中找到该记录。因此，您需要一个搜索页和一个结果页以便使用更新页。用户在搜索页中输入搜索条件，并在结果页中选择记录。当用户单击该记录时，更新页将打开并在 HTML 表单中显示该记录。

有关创建用于搜索要更新的记录的页面的指导，请参见建立搜索/结果页（ColdFusion、ASP、JSP、PHP）。

创建搜索/结果页后，创建记录更新页的下一步是在结果页上创建链接，当单击链接时将打开更新页。请参见打开更新页并传递记录的 ID（ASP 和 JSP）。


打开更新页并传递记录的 ID（ASP 和 JSP）

创建搜索/结果页后（请参见建立搜索/结果页（ColdFusion、ASP、JSP、PHP）），必须在结果页上创建链接，该链接用于打开更新页并传递用户所选记录的 ID。更新页将使用此 ID 在数据库中查找请求的记录并显示该记录。

记录 ID 通过 URL 参数传递给更新页。有关更多信息，请参见 URL 参数。

若要创建用于打开更新页并传递记录 ID 的链接，请执行以下操作：

  1. 在结果页中，选择用于您要链接的文本的动态内容占位符。
  2. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后从弹出菜单中选择“转到详细页面”。

    “转到详细页面”对话框随即出现。

  3. 在“详细信息页”文本框中，单击“浏览”并定位更新页。
  4. 对该 URL 参数进行命名，并指定包含要传递给更新页的记录 ID 的记录集和列。

    记下该 URL 参数的名称，因为接下来会在更新页中用到它。

  5. 单击“确定”。

Dreamweaver 将在该页面中插入一个特殊链接。当用户单击该链接时，一个包含记录 ID 的 URL 参数将被传递到更新页。

创建记录更新页的下一步是检索要更新的记录。请参见检索要更新的记录（ASP 和 JSP）。


检索要更新的记录（ASP 和 JSP）

在结果页将标识要更新的记录的 URL 参数传递到更新页之后（请参见打开更新页并传递记录的 ID（ASP 和 JSP）），更新页必须读取该参数，从数据库表中检索该记录，然后将其临时存储在一个记录集中。

若要检索要更新的记录，请执行以下操作：

  1. 在 Dreamweaver 中创建一个新的 ASP 或 JSP 页并保存。

    该页将成为您的更新页。

  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并选择“记录集”。

    如果出现高级对话框，则单击“简单”按钮打开简单对话框。

  3. 对记录集进行命名，并使用“连接”和“表格”弹出式菜单指定要更新的数据所在的位置。
  4. 单击“已选定”选项并选择一个键列（通常是记录 ID 列）和包含要更新数据的列。
  5. 配置“筛选”区域，以便键列的值等于结果页传递的相应 URL 参数的值。

    这种过滤器创建一个只包含结果页所指定记录的记录集。例如，如果您的键列称为 PRID 且包含记录 ID 信息，并且如果结果页在名为 id 的 URL 参数中传递相应的记录 ID 信息，则您的“筛选”区域的外观应该如下所示：

  6. 单击“确定”。

当用户在结果页上选择一个记录时，更新页将生成一个只包含所选记录的记录集。

修改更新页以便从数据库检索记录并将它存储到记录集中，然后您必须添加一个可以让用户修改记录数据的表单，以及更新数据库所需的逻辑。您可以在一个操作中完成这些任务，也可以逐个地完成。请参见在一个操作中完成更新页（ASP 和 JSP）或逐块完成更新页（ASP 和 JSP）。


在一个操作中完成更新页（ASP 和 JSP）

更新页具有三个构造块：

  • 一个用于从数据库表格中检索记录的过滤记录集（请参见检索要更新的记录（ASP 和 JSP））
  • 一个允许用户修改记录数据的 HTML 表单
  • 一个用于更新数据库表的“更新记录”服务器行为

您可以使用“更新记录表单”应用程序对象通过单个操作添加更新页的最后两个构造块。该应用程序对象将 HTML 表单和“更新记录”服务器行为添加到页中。

在您可以使用该应用程序对象之前，您的 Web 应用程序必须能够识别要更新的记录，并且您的更新页必须能够检索它。请参见搜索要更新的记录（ASP 和 JSP）、打开更新页并传递记录的 ID（ASP 和 JSP）和检索要更新的记录（ASP 和 JSP）。

在应用程序对象将构造块放置到页上之后，您可以使用 Dreamweaver 设计工具按需要自定义表单，或使用“服务器行为”面板编辑“更新记录”服务器行为。

注意

更新页一次只能包含一个记录编辑服务器行为。例如，您不能将“插入记录”或“删除记录”服务器行为添加到更新页。

若要用“更新记录表单”应用程序对象建立更新页，请执行以下操作：

  1. 在“设计”视图中打开更新页，然后选择“插入”>“应用程序对象”>“更新记录”>“更新记录表单向导”。

    即会出现“更新记录表单”对话框。

  2. 完成对话框。

    有关说明，请单击对话框中的“帮助”按钮。

  3. 单击“确定”。

该应用程序对象将 HTML 表单和“更新记录”服务器行为添加到您的页中。表单对象是在一个基本表格中进行布局的，您可以使用 Dreamweaver 页面设计工具自定义该表格。确保所有表单对象都位于表单的边界内。

若要编辑服务器行为，请打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“更新记录”行为。

相关主题

  • 逐块完成更新页（ASP 和 JSP）


逐块完成更新页（ASP 和 JSP）

更新页具有三个构造块：

  • 一个用于从数据库表格中检索记录的过滤记录集（请参见检索要更新的记录（ASP 和 JSP））
  • 一个允许用户修改记录数据的 HTML 表单
  • 一个用于更新数据库表的“更新记录”服务器行为

您可以使用表单工具和“服务器行为”面板分别添加更新页的最后两个基本构造块。

在您可以添加构造块之前，您的 Web 应用程序必须能够识别要更新的记录，并且您的更新页必须能够检索它。请参见搜索要更新的记录（ASP 和 JSP）、打开更新页并传递记录的 ID（ASP 和 JSP）和检索要更新的记录（ASP 和 JSP）。

完成更新页由以下三个任务组成：

  • 将 HTML 表单添加到页面以允许用户修改数据。
  • 将表单对象绑定到数据库表列以显示表单中的记录
  • 添加“更新记录”服务器行为以在用户修改记录后更新数据库表，并单击表单按钮。

若要将 HTML 表单添加到更新页，请执行以下操作：

  1. 创建一个新 ASP 或 JSP 页（“文件”>“新建”）。

    该页将成为您的更新页。

  2. 使用 Dreamweaver 设计工具对您的页进行布局。
  3. 添加一个 HTML 表单，方法是：将插入点放置在希望表单出现的位置，然后选择“插入”>“表单”>“表单”。

    将在页面上创建一个空表单。您可能需要启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）来查看表单的边界，边界是由红色的细线表示的。

  4. 为 HTML 表单命名，方法是单击“文档”窗口底部的 <form> 标签以选中表单，打开属性检查器（“窗口”>“属性”），然后在“表单名称”框中输入一个名称。

    您不必为表单指定 action 或 method 属性来指示当用户单击“提交”按钮时表单向何处及如何发送记录数据。“更新记录”服务器行为会为您设置这些属性。

  5. 为数据库表中要更新的每一列添加一个表单对象，例如文本字段（“插入”>“表单”>“文本字段”）。

    表单对象用于数据输入。为了实现该目的，经常会使用文本字段，但是您也可以使用菜单、复选框和单选按钮。

    每个表单对象都应该在早先定义的记录集中具有一个对应的列。唯一的例外情况就是唯一键列，该列没有对应的表单对象。

    有关更多信息，请参见插入 HTML 表单对象。

  6. 在表单上添加一个“提交”按钮（“插入”>“表单”>“按钮”）。

    可以通过以下方法更改“提交”按钮的标签文字：选择该按钮，打开属性检查器（“窗口”>“属性”），并在“标签文字”框中输入一个新值。

若要在表单中显示记录，请执行以下操作：

  1. 确保您定义了一个记录集来保存用户要更新的记录。

    有关更多信息，请参见检索要更新的记录（ASP 和 JSP）。

  2. 将每个表单对象绑定到记录集中的数据，如以下各节所述：
    • 在 HTML 文本域中显示动态内容
    • 动态预先选择 HTML 复选框
    • 动态预先选择 HTML 单选按钮
    • 创建动态 HTML 表单菜单
    • 使现有 HTML 表单菜单成为动态对象

若要添加服务器行为来更新数据库表，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮并从弹出菜单中选择“更新记录”。

    出现“更新记录”对话框。

  2. 完成对话框。

    有关说明，请单击对话框中的“帮助”按钮。

  3. 单击“确定”。

Dreamweaver 在页中添加服务器行为，允许用户通过单击表单上的“提交”按钮更新数据库中的记录。

若要编辑服务器行为，请打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“更新记录”行为。

相关主题

  • 在一个操作中完成更新页（ASP 和 JSP）


生成删除记录的页面（ASP 和 JSP）

您的应用程序可以包含一个允许用户删除数据库表中现有记录的页。删除页通常是一个与结果页一同工作的详细信息页。结果页允许用户选择要删除的记录，然后将选择传递到删除页。

删除页具有四个构造块：

  • 一个用于从数据库表格中检索记录的过滤记录集（请参见检索要删除的记录（ASP 和 JSP））
  • 一个要删除数据的只读显示（请参见显示要删除的数据（ASP 和 JSP）)
  • 一个将删除命令发送给服务器的“提交”按钮（请参见将删除命令发送到服务器（ASP 和 JSP））
  • 一个更新数据库表的“删除记录”服务器行为（请参见从数据库表中删除记录（ASP 和 JSP））

    注意

    删除页一次只能包含一个记录编辑服务器行为。例如，您不能将“插入记录”或“更新记录”服务器行为添加到删除页。

相关主题

  • 生成记录插入页（ASP 和 JSP）
  • 生成更新记录的页面（ASP 和 JSP）


标识要删除的记录（ASP 和 JSP）

当用户要删除某个记录时，他们必须首先在数据库中找到该记录。因此，您需要一个搜索页和一个结果页以便使用删除页。有关创建搜索页和结果页的指导，请参见生成搜索/结果页（ASP 和 JSP）。

结果页通过向删除页传递一个 URL 参数来通知删除页要删除的记录。下一步是检索要删除的记录。请参见检索要删除的记录（ASP 和 JSP）。


检索要删除的记录（ASP 和 JSP）

在结果页将标识要删除记录的 URL 参数传递到删除页之后（请参见标识要删除的记录（ASP 和 JSP）），删除页必须读取该参数，从数据库表中检索该记录，然后将该记录临时存储在一个记录集中。

若要检索要删除的记录，请执行以下操作：

  1. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并选择“记录集”。

    如果出现高级对话框，则单击“简单”按钮打开简单对话框。

  2. 对记录集进行命名，并使用“连接”和“表格”弹出菜单指定要删除的数据所在的位置。
  3. 在“列”区域中，选择“全部”选项选择数据库表中的所有列。
  4. 配置“筛选”区域，以便键列的值等于结果页传递的相应 URL 参数的值。

    这种过滤器创建一个只包含结果页所指定记录的记录集。例如，如果您的键列称为 PRID 且包含记录 ID 信息，并且如果结果页在名为 id 的 URL 参数中传递相应的记录 ID 信息，则您的“筛选”区域的外观应该如下所示：

  5. 单击“确定”。

当用户在结果页上选择一个记录时，删除页将生成一个只包含所选记录的记录集。

生成删除记录的页面的下一步是显示要删除的记录。请参见显示要删除的数据（ASP 和 JSP）。


显示要删除的数据（ASP 和 JSP）

检索要删除的记录后（请参见检索要删除的记录（ASP 和 JSP）），在用户删除记录前对其进行显示以确认用户确实要删除该记录，这是一个很好的做法。

若要添加要删除记录的只读显示，请执行以下操作：

  1. 确保您定义了一个记录集来保存用户要删除的记录。

    有关更多信息，请参见检索要删除的记录（ASP 和 JSP）。

  2. 将一个记录集列从“绑定”面板（“窗口”>“绑定”）拖到页上。

    页上即会出现动态内容。您可以将动态内容按原样放在页上，也可以将其放在一个 HTML 表格中。有关更多信息，请参见将文本动态化。

生成删除记录的页面的下一步是将删除命令发送到服务器。请参见显示要删除的数据（ASP 和 JSP）。


将删除命令发送到服务器（ASP 和 JSP）

检索并显示要删除的记录后，您必须添加一个可以由用户单击来删除记录的按钮。删除页使用表单“提交”按钮将删除命令发送到服务器。若要向您的页中添加“提交”按钮，您必须创建一个 HTML 表单。该表单只能包含“提交”按钮。

若要在删除页上添加“提交”按钮，请执行以下操作：

  1. 在“设计”视图中，将插入点放置在要“提交”按钮出现的位置，然后选择“插入”>“表单”>“表单”。

    将在页面上创建一个空表单。您可能需要启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）来查看表单的边界，边界是由红色的细线表示的。

  2. 为 HTML 表单命名，方法是单击“文档”窗口底部的 <form> 标签以选中表单，打开属性检查器（“窗口”>“属性”），然后在“表单名称”框中输入一个名称。

    您不必为表单指定 action 或 method 属性来指示当用户单击“提交”按钮时表单向何处及如何发送记录数据。“删除记录”服务器行为会为您设置这些属性。

  3. 在表单上添加一个“提交”按钮（“插入”>“表单”>“按钮”）。
  4. 如果您愿意，可以通过以下方法更改“提交”按钮的标签文字：选择该按钮，打开属性检查器（“窗口”>“属性”），并在“标签文字”框中输入一个新值。

下一步是添加“删除记录”服务器行为，在用户单击“提交”按钮之后更新数据库表。请参见将删除命令发送到服务器（ASP 和 JSP）。


从数据库表中删除记录（ASP 和 JSP）

添加了用户单击可删除记录的按钮后（请参见将删除命令发送到服务器（ASP 和 JSP），最后的步骤是添加“删除记录”服务器行为，在用户单击“提交”按钮后更新数据库表。

若要添加服务器行为以删除数据库表，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮并从弹出菜单中选择“删除记录”。

    出现“删除记录”对话框。

  2. 完成对话框。

    有关更多信息，请单击对话框上的“帮助”按钮。

  3. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过单击表单上的“提交”按钮删除数据库表中的记录。


使用高级的数据操作对象来生成页面（ASP 和 JSP）

通过 Dreamweaver 可以生成使用预存过程、ASP 命令对象和 JSP 已准备语句的页面。

本节包含以下主题：

  • 使用预存过程修改数据库（ASP 和 JSP）
  • 使用 ASP 命令修改数据库
  • 使用 JSP 已准备语句修改数据库


使用预存过程修改数据库（ASP 和 JSP）

您可以使用预存过程修改数据库。预存过程是一种可以重复使用的数据库项，用于在数据库上执行某些操作。

注意

MySQL 和 Microsoft Access 数据库不支持预存过程。

在您使用预存过程修改数据库之前，确保预存过程包含以某种方式修改数据库的 SQL。若要在数据库中创建并存储一个 SQL，请查询您的数据库文档和一本好的 Transact-SQL 手册。

使用预存过程的步骤随服务器模型的不同而有所变化。

本节包括以下服务器模型：

  • 运行预存过程 (ASP)
  • 运行预存过程 (JSP)

相关主题

  • 预存过程


运行预存过程 (ASP)

当处理 ASP 页时，您必须将命令对象添加到页以运行预存过程。有关命令对象的更多信息，请参见 ASP 命令对象。

若要将预存过程添加到 ASP 页，请执行以下操作：

  1. 在 Dreamweaver 中，打开将运行预存过程的页。
  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮，然后选择“命令（预存过程）”。

    即会出现“命令”对话框。

  3. 输入命令的名称，选择一个到包含预存过程的数据库的连接，然后从“类型”弹出菜单中选择“预存过程”。
  4. 选择您的预存过程，方法是展开“数据库项”框中的“预存过程”分支，从列表中选择预存过程，然后单击“过程”按钮。
  5. 在“变量”表格中输入任何所需的参数。

    您不需要为任何 RETURN_VALUE 变量输入任何参数。

  6. 单击“确定”。

在关闭了该对话框之后，Dreamweaver 在您的页中插入 ASP 代码，当在服务器上运行该页时，将创建在数据库中运行预存过程的命令对象。预存过程接着执行数据库操作，例如插入记录。

默认情况下，该代码将命令对象的“Prepared”属性设置为 true，这使应用程序服务器在每次运行预存过程时重复使用对象的单个编译的版本。如果您知道将多次执行该命令，则具有该对象的单个编译的版本可以提高数据库操作的效率。但是，如果该命令只执行一两次，则使用单个编译的版本实际上可能会降低 Web 应用程序的效率，因为系统必须暂停以编译该命令。若要更改设置，请切换到“代码”视图并将“Prepared”属性更改为 false。

注意

并不是所有数据库提供程序都支持已准备命令。如果您的数据库不支持，当运行此页时，您可能会得到一条错误信息。切换到“代码”视图并将“Prepared”属性更改为 false。

如果预存过程接受参数，则您可以创建一个页，该页通过预存过程收集参数值并将参数值提交到页。例如，您可以创建一个使用 URL 参数或 HTML 表单从用户收集参数值的页。


运行预存过程 (JSP)

当处理 JSP 页时，您必须将“可调用”服务器行为添加到页以运行预存过程。

若要将预存过程添加到 JSP 页，请执行以下操作：

  1. 在 Dreamweaver 中，打开将运行预存过程的页。
  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并选择“可调用（预存过程）”。

    即会出现“可调用（预存过程）”对话框。

  3. 完成对话框。

    有关说明，请单击对话框中的“帮助”按钮。

  4. 单击“确定”。

在关闭了“可调用（预存过程）”对话框之后，Dreamweaver 在您的页中插入 JSP 代码，当在服务器上运行该页时，将调用数据库中的预存过程。预存过程接着执行数据库操作，例如插入记录。

如果预存过程接受参数，则您可以创建一个页，该页通过预存过程收集参数值并将参数值提交到页。例如，您可以创建一个使用 URL 参数或 HTML 表单从用户收集参数值的页。


使用 ASP 命令修改数据库

您可以使用 Dreamweaver 创建在数据库中插入、更新或删除记录的 ASP 命令对象。命令对象是在数据库上执行某些操作的服务器对象。您可以向命令对象提供在数据库上执行操作的 SQL 语句。有关更多信息，请参见 ASP 命令对象。

您还可以向该对象提供执行操作的预存过程。有关更多信息，请参见运行预存过程 (ASP)。

若要创建使用 SQL 编辑数据库的命令对象，请执行以下操作：

  1. 在 Dreamweaver 中，打开将运行该命令的 ASP 页。
  2. 打开“服务器行为”面板（“窗口”>“服务器行为”），单击加号 (+) 按钮，然后选择“命令”。

    即会出现“命令”对话框。

  3. 为该命令输入一个名称，选择到包含要编辑记录的数据库的连接，然后选择需要该命令执行的编辑操作（插入、更新或删除）。

    Dreamweaver 根据您选择的操作类型为您启动 SQL 语句。例如，如果选择“插入”，则显示如下对话框：

  4. 完成 SQL 语句。

    有关编写修改数据库的 SQL 语句的信息，请查询 Transact-SQL 手册。

  5. 使用“变量”区域定义任何 SQL 变量。

    例如，下面是包含三个 SQL 变量的插入语句。这三个变量的值是由传递到页的 URL 参数提供的，如在“变量”区域的“运行时值”列中定义的那样。

    在关闭了该对话框之后，Dreamweaver 在您的页中插入 ASP 代码，当在服务器上运行该页时，将创建在数据库中插入、更新或删除记录的命令。

    默认情况下，该代码将命令对象的“Prepared”属性设置为 true，这使应用程序服务器在每次运行该命令时都重复使用对象的单个编译的版本。若要更改此设置，请切换到“代码”视图并将“Prepared”属性更改为 false。

在上面的示例中，下一步您可能要创建一个带有 HTML 表单的页，以便用户可以输入记录数据。HTML 表单将包含三个文本域（txtCity、txtAddress 和 txtPhone）和一个提交按钮。该表单将使用 GET 方法并将文本域值提交到包含您的命令的页。


使用 JSP 已准备语句修改数据库

您可以使用 Dreamweaver 创建在数据库中插入、更新或删除记录的 JSP 已准备语句。JSP 已准备语句是包含 SQL 语句的可重复使用的服务器对象。向已准备语句提供在数据库上执行操作的 SQL。有关更多信息，请参见 JSP 已准备语句。

若要创建编辑数据库记录的已准备语句，请执行以下操作：

  1. 在 Dreamweaver 中，打开将运行命令的 JSP 页。
  2. 打开“服务器行为”面板（“窗口”>“服务器行为”），单击加号 (+) 按钮，然后选择“已准备（插入、更新、删除）”。

    即会出现“已准备（插入、更新、删除）”对话框。

  3. 完成对话框。

    有关说明，请单击对话框中的“帮助”按钮。

  4. 单击“确定”。

在关闭了该对话框之后，Dreamweaver 在您的页中插入 JSP 代码，在服务器上运行该页时，将创建在数据库中插入、更新或删除记录的已准备语句。


生成限制对站点的访问的页（ASP 和 JSP）

您可以使用 Dreamweaver 生成一组对站点访问进行限制的页。您使用的方法与 ColdFusion 的方法完全相同。有关说明，请参见生成对站点访问进行限制的页（ColdFusion、ASP、JSP、PHP）。


使用 JavaBeans (JSP)

JavaBeans 组件是多层 JSP 应用程序的结构元素。JavaBeans 通常用作中间“商业逻辑”层（它旨在将表示逻辑和数据访问逻辑隔离）的组成部分。在这些应用程序中，由 JavaBeans（也称为“Beans”）而不是 JSP 页面包含直接访问数据库的逻辑。

在 Dreamweaver 中，JavaBeans 组件被视为 JSP 页面的动态内容源并出现在“绑定”面板中。可以在“绑定”面板中双击 JavaBeans 以查看它们的属性，然后将属性拖到页面中以创建动态数据引用。

还可以将 JavaBeans 集合（一组 JavaBeans）定义为动态内容源。不过，使用 JavaBeans 集合时，Dreamweaver 只支持重复区域和动态绑定。

Bean 类的副本（或者是包含 Bean 类的 .zip 或 .jar 文件的副本）必须驻留在下列位置：

  • 在运行 Dreamweaver 的系统中，Bean 类的副本必须驻留在 Dreamweaver 的 Configuration/classes 文件夹或系统的类路径中。（Dreamweaver 在设计时使用该类副本。
  • 在运行 JSP 应用程序服务器的系统上，Bean 类必须驻留在应用程序服务器的类路径中。（应用程序服务器在运行时使用该类副本。应用程序服务器的类路径因应用程序服务器而异，但在一般情况下，类路径指向一个带有 classes/bean 子文件夹的 WEB-INF 文件夹。

如果 Dreamweaver 和应用程序服务器都在同一个系统上运行，并且应用程序服务器使用的是系统类路径（而不是内部类路径），则 JavaBeans 类的单个副本可以驻留在计算机上的系统类路径中。应用程序服务器和 Dreamweaver 都将使用该类副本。否则，JavaBeans 类的副本必须驻留在计算机的两个路径中，如上所述。

文件夹结构必须与 JavaBeans 程序包相匹配。例如，如果 JavaBeans 程序包名为 com.ardvark.myBean，则必须将该程序包存储在类路径内的 /com/ardvark/ 中或 Dreamweaver 的 Configuration/classes 文件夹中。

若要定义用于 JSP 页面的 JavaBean，请执行以下操作：

  1. 选择“窗口”>“绑定”显示“绑定”面板。
  2. 单击加号 (+) 按钮并从弹出菜单中选择“JavaBean”。

    随即出现“JavaBean”对话框。

  3. 完成对话框设置，然后单击“确定”。

    有关说明，请单击对话框中的“帮助”按钮。

  4. 新定义的 Bean 即会出现在“绑定”面板中。

若要定义用于 JSP 页面的 JavaBean 集合，请执行以下操作：

  1. 选择“窗口”>“绑定”显示“绑定”面板。
  2. 单击加号 (+) 按钮并从弹出菜单中选择“JavaBean 集合”。

    出现“JavaBean 集合”对话框。

  3. 完成对话框设置，然后单击“确定”。

    有关说明，请单击对话框的“帮助”按钮。

  4. 新定义的 JavaBean 集合出现在“绑定”面板中。


参考资料

本节描述本章中介绍的下列对话框：

  • 设置“转到详细页面”对话框的选项（ASP 和 JSP）
  • 设置“移至特定记录”对话框的选项（ASP 和 JSP）
  • 设置“转到相关页面”对话框的选项（ASP 和 JSP）
  • 设置“更新记录”对话框的选项（ASP 和 JSP）
  • 设置“删除记录”对话框的选项（ASP 和 JSP）
  • 设置“命令（预存过程）”对话框的选项
  • 设置“可调用（预存过程）”对话框的选项
  • 设置“已准备（插入、更新、删除）”对话框的选项 (JSP)
  • 设置“JavaBean”对话框选项
  • 设置“JavaBean 集合”对话框选项


设置“转到详细页面”对话框的选项（ASP 和 JSP）

此对话框用于创建一个链接（该链接可以打开一个详细页并传递一个记录 ID），以便可以找到所需的记录并将其在详细页上显示。仅当在 ASP 或 JSP 站点上工作时，此服务器行为才可用。

若要设置对话框的选项，请执行以下操作：

  1. 在“详细信息页”框中，单击“浏览”并定位详细页。
  2. 从“记录集”和“列”弹出菜单中选择记录集和列，以指定要传递到详细页的值。

    通常，该值对于记录是唯一的，如记录的唯一键 ID。

  3. 如果需要，可选择“URL 参数”或“表单参数”选项将现有的页面参数传递到详细页。
  4. 单击“确定”。

Dreamweaver 将在该页面中插入一个特殊链接。当用户单击该链接时，一个包含记录 ID 的 URL 参数将被传递到详细页。


设置“移至特定记录”对话框的选项（ASP 和 JSP）

此对话框用于添加一个可在为详细页所定义的记录集中查找特定记录的服务器行为。仅当使用 ASP 或者 JSP 服务器模型时，服务器行为才可用。

使用此服务器行为的前提条件如下：

  • URL 参数中包含一个从另一个页面传递给当前页面的记录 ID。可以在带有 HTML 超级链接或 HTML 表单的另一个页面上创建 URL 参数。有关更多信息，请参见收集用户提交的数据。
  • 为当前页所定义的记录集。该服务器行为将从此记录集中提取记录的详细信息。有关说明，请参见定义记录集。
  • 绑定到该页面的记录集列。特定记录必须显示在该页面上。有关更多信息，请参见将文本动态化。

若要添加服务器行为，请执行以下操作：

  1. 在“移至记录”弹出菜单中，选择为详细页定义的记录集。
  2. 在“其中的列”弹出菜单中，选择包含另一个页所传递的值的列。

    例如，如果另一个页传递一个记录 ID 号，则选择包含记录 ID 号的列。

  3. 在“匹配 URL 参数”文本框中，输入另一个页所传递的 URL 参数的名称。

    例如，如果另一个页用于打开详细页的 URL 是 id=43，则在“匹配 URL 参数”文本框中输入 id。

  4. 单击“确定”。

浏览器下次请求该页面时，该服务器行为将读取另一个页所传递的 URL 参数中的记录 ID，并移动到记录集中的指定记录。


设置“转到相关页面”对话框的选项（ASP 和 JSP）

此对话框的目的是创建打开相关页并将现有参数传递到该页的链接。仅当使用 ASP 或者 JSP 服务器模型时，服务器行为才可用。

在将“转到相关页面”服务器行为添加到页面时，请确保该页从另一个页面接收表单或 URL 参数。服务器行为的工作是将这些参数传递到第三个页面。例如，可以将结果页接收的搜索参数传递到另一个页面，从而使用户不必再次输入搜索参数。

另外，可以在页面上选择用作到相关页的链接的文本或图像，或者可以将指针放在该页上而无须选择任何内容，Dreamweaver 将为您插入链接文本。

若要设置对话框的选项，请执行以下操作：

  1. 在“相关页”框中，单击“浏览”并定位相关页文件。

    如果当前页向自身提交数据，则输入当前页的文件名。

  2. 如果希望传递的参数直接从使用 GET 方法的 HTML 表单获得，或者列在该页的 URL 中，则请选择“URL 参数”选项。
  3. 如果希望传递的参数直接从使用 POST 方法的 HTML 表单获得，则请选择“表单参数”选项。
  4. 单击“确定”。

当单击新链接时，页面使用查询字符串将参数传递到相关页。

相关主题

  • 收集用户提交的数据


设置“更新记录”对话框的选项（ASP 和 JSP）

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表中更新记录。

在开始之前，您必须完成以下任务：

  • 建立一个或多个页使用户可以查找要更新的记录。有关更多信息，请参见搜索要更新的记录（ASP 和 JSP）。
  • 将逻辑添加到更新页，允许它从数据库中检索用户选定的记录，准备进行更新。有关说明，请参见检索要更新的记录（ASP 和 JSP）。
  • 将 HTML 表单添加到更新页以允许用户修改数据。有关说明，请参见逐块完成更新页（ASP 和 JSP）。

实现了这些前提条件之后，您可以完成“更新记录”对话框。

若要设置对话框的选项，请执行以下操作：

  1. 在“连接”弹出菜单中，选择一个到数据库的连接。

    如果您需要定义连接，则单击“定义”按钮。

  2. 在“要更新的表格”弹出菜单中，选择包含您正在更新的记录的数据库表。
  3. 在“选取记录自”弹出式菜单中，指定包含显示在 HTML 表单上的记录的记录集。
  4. 在“唯一键列”弹出菜单中，选择一个键列（通常是记录 ID 列）来标识数据库表中的记录。

    如果该值是一个数字，则选择“数字”选项。键列通常只接受数值，但有时候也接受文本值。

  5. 在“更新后，转到”文本框中，输入在表格中更新记录之后打开的页。
  6. 在“获取值自”弹出菜单中，选择用于编辑记录数据的 HTML 表单。

    Dreamweaver 自动选择页面上的第一个表单。

  7. 指定要更新的数据库列，从“值”弹出菜单中选择将更新该列的表单对象，然后从“提交为”弹出菜单中为该表单对象选择数据类型。

    数据类型是数据库表中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  8. 单击“确定”。

Dreamweaver 在页中添加服务器行为，允许用户通过单击表单上的“提交”按钮更新数据库表中的记录。


设置“删除记录”对话框的选项（ASP 和 JSP）

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表中删除记录。

在开始之前，您必须完成以下任务：

  • 生成一个或多个可使用户查找要删除的记录的页面。有关更多信息，请参见标识要删除的记录（ASP 和 JSP）。
  • 将逻辑添加到删除页，允许它从数据库中检索用户选定的记录准备进行删除。有关说明，请参见检索要删除的记录（ASP 和 JSP）。
  • 在页面上显示记录，这样用户可以在删除记录之前查看该记录。有关说明，请参见显示要删除的数据（ASP 和 JSP）。
  • 将带有“提交”按钮的 HTML 表单添加到删除页才能将删除命令发送到服务器。有关说明，请参见将删除命令发送到服务器（ASP 和 JSP）。

实现了这些前提条件之后，您可以完成“删除记录”对话框。

若要设置对话框的选项，请执行以下操作：

  1. 在“连接”弹出菜单中，选择一个到数据库的连接。

    如果您需要定义连接，则单击“定义”按钮。

  2. 在“从表格中删除”弹出菜单中，选择包含要删除的记录的数据库表。
  3. 在“选取记录自”弹出菜单中，指定包含要删除的记录的记录集。
  4. 在“唯一键列”弹出菜单中，选择一个键列（通常是记录 ID 列）来标识数据库表中的记录。

    如果该值是一个数字，则选择“数字”选项。键列通常只接受数值，但有时候也接受文本值。

  5. 在“提交此表单以删除”弹出菜单中，指定具有将删除命令发送到服务器的“提交”按钮的 HTML 表单。
  6. 在“删除后，转到”框中，输入在从数据库表中删除记录后打开的页或单击“浏览”按钮浏览到该文件。
  7. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过单击表单上的“提交”按钮删除数据库表中的记录。


设置“命令（预存过程）”对话框的选项

此对话框用于在您的页中插入 ASP 命令对象。

可以使用一个带有命令对象的 SQL 语句或预存过程。

  • 如果您要使用带有命令对象的 SQL 语句，请参见使用 ASP 命令修改数据库。
  • 如果您要使用带有命令对象的预存过程，请参见运行预存过程 (ASP)。

相关主题

  • ASP 命令对象
  • 预存过程


设置“可调用（预存过程）”对话框的选项

此对话框用于将预存过程插入您的 JSP 页中。

若要设置对话框的选项，请执行以下操作：

  1. 输入预存过程的名称。
  2. 在“连接”弹出菜单中，选择一个到包含该预存过程的数据库的连接。
  3. 在“数据库项”文本框中，展开“预存过程”分支，从列表中选择预存过程，然后单击“过程”按钮。

    Dreamweaver 将自动填写“可调用文本”和“变量”框。

  4. 如果预存过程返回记录集，则选择“返回具有以下名称的记录集”复选框，然后输入记录集的名称，最后单击“测试”按钮查看预存过程返回的记录集。

    Dreamweaver 运行预存过程并显示记录集（如果存在）。

    注意

    如果预存过程返回记录集并采用参数，则您必须在“变量”框的“默认值”列中输入一个值以测试该预存过程。

在关闭了“可调用（预存过程）”对话框之后，Dreamweaver 在您的页中插入 JSP 代码，当在服务器上运行该页时，将调用数据库中的预存过程。预存过程接着执行数据库操作，例如插入记录。

相关主题

  • 运行预存过程 (JSP)
  • 预存过程


设置“已准备（插入、更新、删除）”对话框的选项 (JSP)

此对话框用于创建在数据库中插入、更新或删除记录的已准备语句。

若要设置对话框的选项，请执行以下操作：

  1. 输入已准备语句的名称，选择到包含要编辑记录的数据库的连接，然后选择需要已准备语句执行的编辑操作（插入、更新或删除）。

    Dreamweaver 根据您选择的操作类型为您启动 SQL 语句。

  2. 完成 SQL 语句。

    有关编写修改数据库的 SQL 语句的信息，请查询 Transact-SQL 手册。

  3. 使用“变量”区域定义任何 SQL 变量。

    在“参数”列中，输入在 SQL 语句中使用的 SQL 参数的名称。在“运行时值”列中，输入为每个 SQL 参数提供值的表单或 URL 参数。例如，如果由名为 txtCity 的 URL 参数提供指定给 SQL 参数的值，则输入以下运行时值：

    request.getParameter(“txtCity”)

在关闭了该对话框之后，Dreamweaver 在您的页中插入 JSP 代码，在服务器上运行该页时，将创建在数据库中插入、更新或删除记录的已准备语句。

相关主题

  • 使用 JSP 已准备语句修改数据库
  • JSP 已准备语句


设置“JavaBean”对话框选项

此对话框用于将 JavaBeans 组件定义为页面的动态内容源。

若要定义 JavaBeans 组件，请执行以下操作：

  1. 输入 Bean 的名称。
  2. 选择 Bean 的范围。
  3. 选择 Bean 的类。

    若要列出 .zip 或 .jar 文件中的类，请单击“浏览”并选择该文件。

    类以下面的格式表示：

    packagename.classname
  4. 如果您想为某个 JavaBean 属性提供默认值，请从列表中选取该属性并在列表下面的“默认值”框中输入一个值。

    您还可以单击“默认值”框旁边的闪电图标，将属性的默认值设置为动态值。

  5. 单击“确定”。

    JavaBean 即会出现在“绑定”面板中。

相关主题

  • 使用 JavaBeans (JSP)


设置“JavaBean 集合”对话框选项

此对话框用于将 JavaBean 集合定义为页面的动态内容源。

若要定义 JavaBean 集合，请执行以下操作：

  1. 从“集合类”弹出菜单中选择集合的类。

    类以下面的格式表示：

    packagename.classname

    若要列出 .zip 或 .jar 文件中的类，请单击“浏览”并选择该文件。

  2. 从“索引属性”弹出菜单中选择集合的一个索引属性。
  3. Dreamweaver 在“项类”文本框中显示默认名称。如果列出的名称不正确，请输入正确的名称。
  4. 从“范围”弹出菜单中选择 Bean 的范围。
  5. 单击“确定”。

    新定义的内容源即会出现在“绑定”面板中。

相关主题

  • 使用 JavaBeans (JSP)


快速生成 PHP 应用程序

使用 Macromedia Dreamweaver 8 中的工具可以快速生成 PHP Web 应用程序，只需要很少甚至不需要编码。

本章包含下列章节：

生成主/详细页 (PHP)

生成搜索/结果页 (PHP)

生成记录插入页面 (PHP)

生成更新记录的页面 (PHP)

生成删除记录的页面 (PHP)

生成对站点访问进行限制的页 (PHP)

相关主题

  • 关于快速应用程序开发（所有服务器）


生成主/详细页 (PHP)

使用 Dreamweaver 可以创建以两个明细级别表示信息的页面集：主页列出记录，详细页显示有关各记录的更多详细信息。本节描述如何生成这些类型的主/详细页。

本节包含以下主题：

  • 在一个操作中生成主/详细页 (PHP)
  • 逐块生成主/详细页 (PHP)


在一个操作中生成主/详细页 (PHP)

开发 PHP 应用程序时，使用主/详细页集应用程序对象可以快速生成主/详细页。应用程序对象可以通过完成一两个对话框来生成一组完整的动态页。

您使用的方法与 ColdFusion 的方法完全相同。有关说明，请参见在一次操作中生成主/详细页（ColdFusion、ASP、JSP、PHP）。

您还可以使用单独的服务器行为来建立主/详细页。有关更多信息，请参见逐块生成主/详细页 (PHP)。


逐块生成主/详细页 (PHP)

您可以使用“服务器行为”面板分别添加主/详细页的基本构造块。

也可以使用主/详细页集应用程序对象一次性添加所有构造块。有关更多信息，请参见在一个操作中生成主/详细页 (PHP)。

本节介绍生成一组主/详细页的步骤：

  • 创建主页 (PHP)
  • 创建到详细页的链接 (PHP)
  • 为链接创建 URL 参数 (PHP)
  • 查找请求的记录并在详细页上显示 (PHP)


创建主页 (PHP)

本节介绍如何创建能列出数据库记录的主页。可以使用动态表在 PHP 页上列出记录。

在您开始前，请确保为站点定义了一个数据库连接。有关更多信息，请参见适用于 PHP 开发人员的数据库连接。

若要创建主页，请执行以下操作：

  1. 在 Dreamweaver 中，创建一个新的 PHP 页。

    选择“文件”>“新建”>“动态”，选择“PHP”，然后单击“创建”。

    一个 PHP 空白页将在 Dreamweaver 中打开。

  2. 为该页面定义记录集。

    在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮，然后选择“记录集（查询）”，并完成该“记录集”对话框。有关更多信息，请单击对话框中的“帮助”按钮。如果您想自己编写 SQL 语句，请单击“高级”按钮，打开“高级记录集”对话框。

    确保记录集包含创建动态表格所需的所有表格列。记录集还必须包含含有每条记录的唯一键的表格列，即记录 ID 列。在下面的示例中，CODE 列包含了唯一标识每条记录的信息。

    通常，主页上的记录集提取数据库表中的少数几列，而详细页上的记录集提取同一表格中的更多列以提供额外的详细信息。

    记录集可以在运行时由用户定义。有关更多信息，请参见生成搜索/结果页 (PHP)。

  3. 插入动态表格以将记录显示在页面中。

    将插入点放在页面上想要显示动态表格的地方，然后选择“插入”>“应用程序对象”>“动态数据”>“动态表格”。

    随即出现“动态表格”对话框。

  4. 完成“动态表格”对话框，然后单击“确定”。

    Dreamweaver 将动态表格插入到页面中。

    如果需要与完成“动态表格”对话框有关的帮助，请单击该对话框上的“帮助”按钮。

  5. 如果需要，您可以删除包含记录 ID 的动态表格列。

    如果不打算向用户显示记录 ID，可以从动态表格中删除该列。在页面上任意位置单击，将焦点移至页面。将指针移动到动态表格中该列的顶部附近直到列单元格外框为红色，然后单击选择该表格列。按 Delete 键将该列从表格中删除。

创建主/详细页的下一步是创建用于打开详细页的链接。请参见创建到详细页的链接 (PHP)。


创建到详细页的链接 (PHP)

创建动态表格后（请参见创建主页 (PHP)），必须创建打开详细页的链接。本节介绍如何创建此类链接。下一节介绍如何修改该链接，使之同时传递用户所选记录的 ID。详细页将使用此 ID 在数据库中查找请求的记录并显示该记录。

若要创建指向详细页的链接，请执行以下操作：

  1. 在动态表格中，选择用于您要链接的文本的动态内容占位符。

    下面的示例选择了 {rsLocations.LOCATION_NAME} 占位符。这些链接将应用于列中的位置名称。

  2. 在属性检查器中，单击“链接”域旁边的文件夹图标。
  3. 浏览找到并选择该详细页。

    详细页出现在“链接”域中。

    在动态表格中，动态内容的占位符显示为链接状态。如果您在服务器上运行该页面，可以看到该链接被应用到每个表格行的文本。

创建主/详细页的下一个步骤是创建 URL 参数以传递用户所选记录的 ID。请参见为链接创建 URL 参数 (PHP)。


为链接创建 URL 参数 (PHP)

主页上动态表格中的链接（请参见创建到详细页的链接 (PHP)）不仅要打开详细页，它们还必须传递用户所选记录的 ID。详细页将使用此 ID 在数据库中查找请求的记录并显示该记录。

记录 ID 通过 URL 参数传递给详细页。有关更多信息，请参见 URL 参数。

本节介绍如何创建 URL 参数，URL 参数用于将记录 ID 传递给详细页。

若要创建 URL 参数，请执行以下操作：

  1. 选择在动态表格中的链接。

    如果打开了“动态数据”，请选择第一行中的该链接。

  2. 在属性检查器的“链接”域中，将下面的字符串添加到 URL的结尾处：
    ?recordID=<?php echo $row_recordsetName['fieldName']; ?>

    问号将告知服务器接下来是一个或多个 URL 参数。单词 recordID 是 URL 参数的名称（您可以使用任何喜欢的名称）。记下该 URL 参数的名称，因为接下来会在详细页中用到它。

    等号后的表达式是该参数的值。在本例中，该值由 PHP 表达式生成，该表达式从记录集中返回一个记录 ID。它将为动态表格中的每一行生成一个不同的 ID。在 PHP 表达式中，用您的记录集的名称替换 recordsetName，用记录集中唯一标识每条记录的字段的名称来替换 fieldName。大多数情况下，该字段将由一个记录 ID 号组成。在下面的示例中，该字段由唯一位置代码构成。

    locationDetail.php?recordID=<?php echo $row_rsLocations['CODE']; ?>

    当该页运行时，记录集的 CODE 字段的值将插入到动态表格中相应的行中。例如，如果澳大利亚堪培拉的租位代码为 CBR，那么下面的 URL 将用于动态表格中有堪培拉的行：

    locationDetail.php?recordID=CBR
  3. 保存该页面。

创建主/详细页的下一步是修改详细页，使它能够在数据库中查找请求的记录，并将其显示在页面上。请参见查找请求的记录并在详细页上显示 (PHP)。


查找请求的记录并在详细页上显示 (PHP)

完成主页后（请参见为链接创建 URL 参数 (PHP)），请切换到详细页。您必须在数据库中查找请求的记录，并将其显示在页面上。该过程由两个步骤组成：首先，定义一个记录集以存储单个记录（即主页请求的记录）；然后，将记录集列绑定到页面上。

若要查找请求的记录并在详细页上显示，请执行以下操作：

  1. 切换到详细页，如果它不存在，则创建一个新的 PHP 页。
  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并从弹出式菜单中选择“记录集（查询）”。

    出现简单的“记录集”对话框。如果出现的是高级的“记录集”对话框，请单击“简单”切换到简单的“记录集”对话框。

  3. 命名该记录集，然后选择一个连接和将向记录集提供数据的数据库表。
  4. 在“列”区域中，选择要包括在记录集中的表格列。

    详细页上的记录集可以与主页上的记录集相同，也可以不同。通常，详细页记录集的列数更多，可以显示更多的详细信息。

    如果记录集不同，则请确保详细页上的记录集至少包含一个与主页上的记录集相同的列。这个公共列通常是记录 ID 列，但也可以是相关表格的连结字段。

    若要使记录集中只包括某些表列，请单击“已选定”，然后按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 列表中的列，以选择所需列。

  5. 如下所示完成“筛选”部分，以便查找和显示主页所传递的 URL 参数中指定的记录：
    • 从“筛选”区域的第一个弹出式菜单中选择记录集中的列，该列包含与主页传递的 URL 参数值相匹配的值。例如，如果 URL 参数包含一个记录 ID 号，则选择包含记录 ID 号的列。在上一节讨论的示例中，记录集列 CODE 包含与通过主页传递的 URL 参数值相匹配的值。
    • 从第一个菜单旁边的弹出菜单中选择等号（如果尚未选定）。
    • 从第三个弹出菜单中选择“URL 参数”。

      主页使用 URL 参数将信息传递到详细页。

    • 在第四个框中，输入主页传递的 URL 参数的名称。

      例如，如果主页用来打开详细页的 URL 包含 locationDetail.php?recordID=CBR 后缀，请接着输入 recordID。

    “记录集”对话框的外观应该如下所示：

  6. 单击“确定”。

    记录集随即出现在“绑定”面板中。

  7. 通过下面的方法将记录集列绑定到详细页：在“绑定”面板（“窗口”>“绑定”）上选择列，然后将其拖到页面上。

    有关更多信息，请参见将文本动态化。

PHP 主/详细页的设置完成。

创建主/详细页后，可以使用“服务器行为”面板（“窗口”>“服务器行为”）来修改各种构造块。


生成搜索/结果页 (PHP)

可以使用 Dreamweaver 建立一组页面，使用户可以搜索您的数据库。您使用的方法与 ColdFusion 的方法完全相同。有关说明，请参见建立搜索/结果页（ColdFusion、ASP、JSP、PHP）。


生成记录插入页面 (PHP)

可以用 Dreamweaver 生成一个允许用户向数据库插入新记录的页。您所使用的方法对于所有 Dreamweaver 支持的服务器技术而言完全相同。有关说明，请参见建立记录插入页（所有服务器）。


生成更新记录的页面 (PHP)

您的应用程序可以包含允许用户更新数据库表中现有记录的一组页。这组页通常由一个搜索页、一个结果页和一个更新页组成。用户可以使用搜索页和结果页检索记录，使用更新页修改记录。

本节介绍生成页面用于更新记录的步骤：

  • 搜索要更新的记录 (PHP)
  • 创建打开更新页的链接 (PHP)
  • 为链接创建 URL 参数 (PHP)
  • 检索要更新的记录 (PHP)
  • 在一个操作中完成更新页 (PHP)
  • 逐块完成更新页 (PHP)

相关主题

  • 建立记录插入页（所有服务器）
  • 生成删除记录的页面 (PHP)


搜索要更新的记录 (PHP)

当用户要更新某个记录时，他们必须首先在数据库中找到该记录。因此，您需要一个搜索页和一个结果页以便使用更新页。用户在搜索页中输入搜索条件，并在结果页中选择记录。当用户单击该记录时，更新页将打开并在 HTML 表单中显示该记录。

有关创建用于搜索要更新的记录的页面的指导，请参见生成搜索/结果页 (PHP)。

创建搜索/结果页后，下一步是在结果页上创建链接，当单击链接时将打开更新页。请参见创建打开更新页的链接 (PHP)。


创建打开更新页的链接 (PHP)

创建搜索/结果页后（请参见搜索要更新的记录 (PHP)），您必须在结果页上创建链接，用于打开更新页，并在 HTML 表单中显示所选的记录。本节介绍如何创建此类链接。下一节介绍如何修改该链接，使之同时传递用户所选记录的 ID。更新页将使用此 ID 在数据库中查找请求的记录并显示该记录。

若要创建指向更新页的链接，请执行以下操作：

  1. 在结果页中，选择用于您要链接的文本的动态内容占位符。

    下面的示例选择了 {rsLocations.LOCATION_NAME} 占位符。这些链接将应用于列中的位置名称。

  2. 在属性检查器中，单击“链接”域旁边的文件夹图标。
  3. 浏览找到并选择该更新页。

    更新页出现在“链接”域中。

    在结果页上，动态内容的占位符显示为链接状态。如果将页面上传到服务器然后运行搜索，您可以看到该链接被应用到结果页上的每条记录。

创建记录更新页的下一个步骤是创建 URL 参数以传递用户所选记录的 ID。请参见为链接创建 URL 参数 (PHP)。


为更新链接创建 URL 参数 (PHP)

结果页上的链接（请参见创建打开更新页的链接 (PHP)）不仅要打开更新页，它们还必须传递用户所选记录的 ID。更新页将使用此 ID 在数据库中查找请求的记录并显示该记录。

记录 ID 通过 URL 参数传递给更新页。有关更多信息，请参见 URL 参数。

本节介绍如何创建 URL 参数，该参数将记录 ID 传递给更新页。

若要创建 URL 参数，请执行以下操作：

  1. 在结果页上选中该链接。
  2. 在属性检查器的“链接”域中，将下面的字符串添加到 URL的结尾处：
    ?recordID=<?php echo $row_recordsetName['fieldName']; ?>

    问号将告知服务器接下来是一个或多个 URL 参数。单词“recordID”是 URL 参数的名称（您可以指定任何名称）。记下该 URL 参数的名称，因为接下来会在更新页中用到它。

    等号后的表达式是该参数的值。在本例中，该值由 PHP 表达式生成，该表达式从记录集中返回一个记录 ID。它将为动态表格中的每一行生成一个不同的 ID。在 PHP 表达式中，用您的记录集的名称替换 recordsetName，用记录集中唯一标识每条记录的字段的名称来替换 fieldName。大多数情况下，该字段将由一个记录 ID 号组成。在下面的示例中，该字段由唯一位置代码构成。

    locationDetail.php?recordID=<?php echo $row_rsLocations['CODE']; ?>

    当该页运行时，记录集的 CODE 字段的值将插入到动态表格中相应的行中。例如，如果澳大利亚堪培拉的租位代码为 CBR，那么下面的 URL 将用于动态表格中有堪培拉的行：

    locationDetail.php?recordID=CBR
  3. 保存该页面。

下一步将修改更新页，使之能够在数据库中查找请求的记录，并将其显示在页面上。请参见检索要更新的记录 (PHP)。


检索要更新的记录 (PHP)

在结果页将标识要更新的记录的 URL 参数传递到更新页之后（请参见为更新链接创建 URL 参数 (PHP)），更新页必须读取该参数，从数据库表中检索该记录，然后将其临时存储在一个记录集中。

若要检索要更新的记录，请执行以下操作：

  1. 在 Dreamweaver 中创建一个新的 PHP 页并保存该页。

    该页将成为您的更新页。

  2. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并选择“记录集”。

    如果出现高级对话框，则单击“简单”按钮打开简单对话框。

  3. 对记录集进行命名，并使用“连接”和“表格”弹出式菜单指定要更新的数据所在的位置。
  4. 单击“已选定”选项并选择一个键列（通常是记录 ID 列）和包含要更新数据的列。
  5. 配置“筛选”区域，以便键列的值等于结果页传递的相应 URL 参数的值。

    这种过滤器创建一个只包含结果页所指定记录的记录集。例如，如果您的键列称为 PRID 且包含记录 ID 信息，并且如果结果页在名为 id 的 URL 参数中传递相应的记录 ID 信息，则您的“筛选”区域的外观应该如下所示：

  6. 单击“确定”。

当用户在结果页上选择一个记录时，更新页将生成一个只包含所选记录的记录集。

修改更新页以便从数据库检索记录并将它存储到记录集中，然后您必须添加一个可以让用户修改记录数据的表单，以及更新数据库所需的逻辑。您可以在一个操作中完成这些任务，也可以逐个地完成。请参见在一个操作中完成更新页 (PHP) 或逐块完成更新页 (PHP)。


在一个操作中完成更新页 (PHP)

更新页具有三个构造块：

  • 一个用于从数据库表格中检索记录的过滤记录集（请参见检索要更新的记录 (PHP)）
  • 一个允许用户修改记录数据的 HTML 表单
  • 一个用于更新数据库表的“更新记录”服务器行为

您可以使用“更新记录表单”应用程序对象通过单个操作添加更新页的最后两个构造块。该应用程序对象将 HTML 表单和“更新记录”服务器行为添加到页中。

在您可以使用该应用程序对象之前，您的 Web 应用程序必须能够识别要更新的记录，并且您的更新页必须能够检索它。请参见搜索要更新的记录 (PHP)、创建打开更新页的链接 (PHP)、为链接创建 URL 参数 (PHP) 和检索要更新的记录 (PHP)。

在应用程序对象将构造块放置到页上之后，您可以使用 Dreamweaver 设计工具按需要自定义表单，或使用“服务器行为”面板编辑“更新记录”服务器行为。

注意

更新页一次只能包含一个记录编辑服务器行为。例如，您不能将“插入记录”或“删除记录”服务器行为添加到更新页。

若要用“更新记录表单”应用程序对象建立更新页，请执行以下操作：

  1. 在“设计”视图中打开更新页，然后选择“插入”>“应用程序对象”>“更新记录”>“更新记录表单向导”。

    即会出现“更新记录表单”对话框。

  2. 完成对话框。

    有关说明，请参见设置“插入记录表单”对话框选项。

  3. 单击“确定”。

该应用程序对象将 HTML 表单和“更新记录”服务器行为添加到您的页中。表单对象是在一个基本表格中进行布局的，您可以使用 Dreamweaver 页面设计工具自定义该表格。确保所有表单对象都位于表单的边界内。

若要编辑服务器行为，请打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“更新记录”行为。

相关主题

  • 逐块完成更新页 (PHP)


逐块完成更新页 (PHP)

更新页具有三个构造块：

  • 一个用于从数据库表格中检索记录的过滤记录集（请参见检索要更新的记录 (PHP)）
  • 一个允许用户修改记录数据的 HTML 表单
  • 一个用于更新数据库表的“更新记录”服务器行为

您可以使用表单工具和“服务器行为”面板分别添加更新页的最后两个基本构造块。

在您可以添加构造块之前，您的 Web 应用程序必须能够识别要更新的记录，并且您的更新页必须能够检索它。请参见搜索要更新的记录 (PHP)、创建打开更新页的链接 (PHP)、为链接创建 URL 参数 (PHP) 和检索要更新的记录 (PHP)。

完成更新页由以下三个任务组成：

  • 将 HTML 表单添加到页面以允许用户修改数据。
  • 将表单对象绑定到数据库表列以显示表单中的记录
  • 添加“更新记录”服务器行为以在用户修改记录后更新数据库表。

若要将 HTML 表单添加到更新页，请执行以下操作：

  1. 创建一个新的 PHP 页（“文件”>“新建”）。

    该页将成为您的更新页。

  2. 使用 Dreamweaver 设计工具对您的页进行布局。
  3. 将插入点放置在您想要显示表单的位置，然后从“插入”菜单中选择“表单”，添加一个 HTML 表单。

    将在页面上创建一个空表单。您可能需要启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）来查看表单的边界，边界是由红色的细线表示的。

  4. 为 HTML 表单命名，方法是单击“文档”窗口底部的 <form> 标签以选中表单，打开属性检查器（“窗口”>“属性”），然后在“表单名称”框中输入一个名称。

    您不必为表单指定 action 或 method 属性来指示当用户单击“提交”按钮时表单向何处及如何发送记录数据。“更新记录”服务器行为会为您设置这些属性。

  5. 为数据库表中要更新的每一列添加一个表单对象，例如文本字段（“插入”>“表单”>“文本字段”）。

    表单对象用于数据输入。为了实现该目的，经常会使用文本字段，但是您也可以使用菜单、复选框和单选按钮。

    每个表单对象都应该在早先定义的记录集中具有一个对应的列。唯一的例外情况就是唯一键列，该列没有对应的表单对象。

    有关更多信息，请参见插入 HTML 表单对象。

  6. 在表单上添加一个“提交”按钮（“插入”>“表单”>“按钮”）。

    可以通过以下方法更改“提交”按钮的标签文字：选择该按钮，打开属性检查器（“窗口”>“属性”），并在“标签文字”框中输入一个新值。

若要在表单中显示记录，请执行以下操作：

  1. 确保您定义了一个记录集来保存用户要更新的记录。

    有关更多信息，请参见检索要更新的记录 (PHP)

  2. 将每个表单对象绑定到记录集中的数据，如以下各节所述：
    • 在 HTML 文本域中显示动态内容
    • 动态预先选择 HTML 复选框
    • 动态预先选择 HTML 单选按钮
    • 创建动态 HTML 表单菜单
    • 使现有 HTML 表单菜单成为动态对象

若要添加服务器行为来更新数据库表，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮并从弹出菜单中选择“更新记录”。

    出现“更新记录”对话框。

  2. 完成对话框。

    有关说明，请参见设置“更新记录”对话框的选项 (PHP)。

  3. 单击“确定”。

    Dreamweaver 在页中添加服务器行为，允许用户通过单击表单上的“提交”按钮更新数据库中的记录。

若要编辑服务器行为，请打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“更新记录”行为。

相关主题

  • 在一个操作中完成更新页 (PHP)


生成删除记录的页面 (PHP)

您的应用程序可以包含允许用户删除数据库中的记录的一组页。这组页通常由一个搜索页、一个结果页和一个删除页组成。用户可以使用搜索页和结果页检索记录，使用删除页删除记录。

本节介绍了如何生成删除记录的 PHP 页，步骤如下：

  • 搜索要删除的记录 (PHP)
  • 创建到确认页的链接 (PHP)
  • 创建传递到确认页的 URL 参数 (PHP)
  • 在确认页上显示记录 (PHP)
  • 添加用来删除记录的逻辑 (PHP)


搜索要删除的记录 (PHP)

当用户要删除某个记录时，他们必须首先在数据库中找到该记录。因此，您需要一个搜索页和一个结果页以便使用删除页。用户在搜索页中输入搜索条件，并在结果页中选择记录。当用户单击该记录时，删除页将打开并显示该记录。

有关创建用于搜索要删除记录的页面的指导，请参见生成搜索/结果页 (PHP)。

创建搜索/结果页后，下一步是在结果页上创建链接以用于打开删除确认页。请参见创建到确认页的链接 (PHP)。


创建到确认页的链接 (PHP)

创建结果页后（请参见搜索要删除的记录 (PHP)），您必须创建链接，用户可以单击这些链接来打开一个询问用户是否确认删除的页面。本节介绍如何创建此类链接。下一节介绍如何修改该链接，使之同时传递用户要删除的记录的 ID。

若要创建指向确认页的链接，请执行以下操作：

  1. 在结果页上，通过以下方式在表格中创建一个新列用于显示记录：在最后一个表格列内单击，然后选择“修改”>“表格”>“插入行或列”。

    即出现“插入行或列”对话框。

  2. 选择“列”选项，然后选择“当前列之后”选项。

    单击“确定”后，Dreamweaver 会将一列添加到表格中。

  3. 在新创建的表格列中，在包含动态内容占位符的行中输入 Delete 字符串。确保在选项卡式的重复区域内输入该字符串。

    您还可以插入图像，上面带有指示删除的文字或符号。

    如果打开了“动态数据”，请在记录的第一行输入该字符串，然后单击“刷新”图标。

  4. 选择 Delete 字符串将一个链接应用于该字符串。

    如果打开了“动态数据”，请选择第一行记录中的该字符串。

  5. 在属性检查器的“链接”域中输入确认页。

    您可以输入任何文件名。

在“链接”域外单击后，Delete 字符串在表格中显示为链接状态。

创建链接后，创建记录删除页的下一个步骤是为这些链接创建 URL 参数。请参见创建传递到确认页的 URL 参数 (PHP)。


创建传递到确认页的 URL 参数 (PHP)

结果页上的链接（请参见创建到确认页的链接 (PHP)）不仅要打开确认页，它们还必须传递用户要删除的记录的 ID。确认页将使用此 ID 在数据库中查找该记录并将其显示出来。

您必须使用 URL 参数将记录 ID 传递给确认页。本节介绍如何创建 URL 参数，以将记录 ID 传递给确认页。

若要创建 URL 参数，请执行以下操作：

  1. 在结果页上选择删除链接。

    如果打开了“动态数据”，请选择第一行中的该链接。

  2. 在属性检查器的“链接”域中，将下面的字符串添加到 URL的结尾处：
    ?recordID=<?php echo $row_recordsetName['fieldName']; ?>

    问号将告知服务器接下来是一个或多个 URL 参数。单词“recordID”是 URL 参数的名称（您可以指定任何名称）。记下该 URL 参数的名称，因为接下来会在确认页中用到它。

    等号后的表达式是该参数的值。在本例中，该值由 PHP 表达式生成，该表达式从记录集中返回一个记录 ID。它将为动态表格中的每一行生成一个不同的 ID。在 PHP 表达式中，用您的记录集的名称替换 recordsetName，用记录集中唯一标识每条记录的字段的名称来替换 fieldName。大多数情况下，该字段将由一个记录 ID 号组成。在下面的示例中，该字段由唯一位置代码构成：

    confirmDelete.php?recordID=<?php echo $row_rsLocations['CODE']; ?>

    当该页面运行时，记录集的 CODE 字段的值将插入到动态表格中相应的行中。例如，如果澳大利亚堪培拉的租位代码为 CBR，那么下面的 URL 将用于动态表格中有堪培拉的行：

    confirmDelete.php?recordID=CBR
  3. 保存该页面。

在创建删除链接的动态 URL 参数后，下一步是在确认页上显示记录。请参见在确认页上显示记录 (PHP)。


在确认页上显示记录 (PHP)

完成列出记录的页后（请参见创建传递到确认页的 URL 参数 (PHP)），请切换到确认页。确认页将显示该记录，并询问用户是否确实要删除该记录。当用户单击表单按钮以确认该操作后，Web 应用程序将从数据库中删除该记录。

显示记录由以下三个任务构成：

  • 创建 HTML 表单
  • 检索要在表单中显示的记录
  • 在表单中显示记录

检索和显示记录分两步：定义一个用来存放单个记录（用户希望删除的记录）的记录集；将该记录集的列绑定到表单。下面详细列出了这些步骤。

若要创建用于显示记录的 HTML 表单，请执行以下操作：

  1. 创建新的 PHP 页面并将它保存为在上一节指定的确认页。

    您在上一节创建“删除”链接时已经指定了一个确认页。如果第一次保存该文件请使用此名字（如，deleteConfirm.php）。

  2. 在页面上插入一个 HTML 表单（“插入”>“表单”>“表单”）。
  3. 在表单中添加一个隐藏的表单字段。

    该隐藏的表单字段是存储 URL 参数传递的记录 ID 所必需的。要添加隐藏字段，请将插入点置于表单中，然后选择“插入”>“表单”>“隐藏字段”。

  4. 在表单上添加按钮。

    用户将单击该按钮以确认并删除所显示的记录。要添加按钮，请将插入点置于表单中，然后选择“插入”>“表单”>“按钮”。

  5. 根据需要增强页面的设计然后保存。

若要检索用户要删除的记录，请执行以下操作：

  1. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并从弹出式菜单中选择“记录集（查询）”。

    出现简单的“记录集”对话框。如果出现的是高级的“记录集”对话框，请单击“简单”切换到简单的“记录集”对话框。

  2. 命名该记录集，然后选择一个连接和包含可显示的记录的数据库表。
  3. 在“列”区域中，选择要在页面中显示的表列（记录字段）。

    若要只显示记录的某些域，请单击“已选定”，然后按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 列表中的列，以选择所需域。

    确保包含记录 ID 字段，即使您不打算显示该字段。

  4. 如下所示完成“筛选”部分，以便查找和显示结果页所传递的 URL 参数中指定的记录：
    • 从“筛选”区域的第一个弹出式菜单中，选择记录集中的列，该列包含的值与带有“删除”链接的页所传递的 URL 参数值相匹配。例如，如果 URL 参数包含一个记录 ID 号，则选择包含记录 ID 号的列。在上一节讨论的示例中，记录集列 CODE 包含的值与带有“删除”链接的页所传递的 URL 参数值相匹配。
    • 从第一个菜单旁边的弹出菜单中选择等号（如果尚未选定）。
    • 从第三个弹出菜单中选择 URL 参数。包含“删除”链接的页使用 URL 参数向确认页传递信息。
    • 在第四个文本框中，输入由带有“删除”链接的页传递的 URL 参数的名称。

      例如，如果用于打开确认页的 URL 包含 confirmDelete.php?recordID=CBR 后缀，那么请输入 recordID。

      “记录集”对话框的外观应该如下所示：

  5. 单击“确定”。

    记录集随即出现在“绑定”面板中。

若要显示用户要删除的记录，请执行以下操作：

  1. 在“绑定”面板中选择记录集列（记录域）并把它们拖动到页面上插入的表单中。

    有关更多信息，请参见将文本动态化。

    接着，必须将记录 ID 列绑定到隐藏的表单字段。

  2. 确保启用了“不可见元素”（“查看”>“可视化助理”>“不可见元素”），然后单击代表隐藏表单字段的黄色盾牌图标。

    已选中隐藏表单字段。

  3. 在属性检查器中，单击“值”文本框旁边的闪电图标。

    出现“动态数据”对话框。

  4. 在“动态数据”对话框中，在记录集中选择记录 ID 列，然后单击“确定”。

    在下面的示例中，选择的记录 ID 列是“CODE”。

  5. 保存该页面。

    完成后的确认页的外观应该如下所示：

创建确认页后，创建记录删除页的下一步是添加用来删除记录的逻辑。请参见添加用来删除记录的逻辑 (PHP)。


添加用来删除记录的逻辑 (PHP)

创建确认页后（请参见在确认页上显示记录 (PHP)），生成记录删除页的下一步是向确认页添加逻辑，用于当用户单击“确认”按钮时从数据库删除记录。在 Dreamweaver 中，使用“删除记录”服务器行为可以快速、方便地添加此逻辑。

若要添加用于删除 HTML 表单中显示的记录的逻辑，请执行以下操作：

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后选择“删除记录”。

    出现“删除记录”对话框。

  2. 在“先检查是否定义了变量”文本框中，确保已选中“主键值”。

    随后您将在对话框中指定主键值。

  3. 在“连接”弹出式菜单中，选择一个到该数据库的连接，这样服务器行为就可以连接到该数据库。
  4. 在“表格”弹出菜单中，选择包含要删除的记录的数据库表。
  5. 在“主键列”弹出菜单中，选择包含记录 ID 的表列。

    “删除记录”服务器行为将在此列搜索匹配值。此列与绑定到页面上的隐藏表单字段的记录集列应包含相同的记录 ID 数据。

    如果该记录 ID 是一个数字，请选择“数字”选项。

  6. 在“主键值”弹出菜单中，选择页面上包含记录 ID 的变量，该记录 ID 标识了要删除的记录。

    该变量是由隐藏表单字段创建的。其名称与隐藏字段的 name 属性相同，是一个表单参数或 URL 参数，具体取决于该表单的 method 属性。在此示例中，该变量是名为 hiddenRecID 的表单变量。

  7. 在“删除后，转到”文本框中，指定从数据库表格删除该记录之后打开的页。

    可以指定向用户显示含有简短的成功消息的页，或者指定一个页，在其中列出剩余记录，使用户可以验证该记录是否已被删除。

    完成后的“删除记录”对话框外观应如下所示：

  8. 单击“确定”，保存您的工作。

    将这些页上传到 Web 服务器（如果需要），打开浏览器，然后搜索要删除的记录。当单击结果页上的“删除”链接时，将显示确认页。单击“确认”按钮可从数据库中删除该记录。若要验证该记录是否已被删除，请重新打开带有“删除”链接的页。列表中不再显示该记录。

    注意

    如果页上仍然显示该记录，请单击“刷新”。


生成对站点访问进行限制的页 (PHP)

您可以使用 Dreamweaver 生成一组对站点访问进行限制的页。您使用的方法与 ColdFusion 的方法完全相同。有关说明，请参见生成对站点访问进行限制的页（ColdFusion、ASP、JSP、PHP）。


参考资料

本节描述本章中介绍的下列对话框：

  • 设置“更新记录”对话框的选项 (PHP)
  • 设置“删除记录”对话框的选项 (PHP)


设置“更新记录”对话框的选项 (PHP)

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表中更新记录。

在开始之前，您必须完成以下任务：

  • 建立一个或多个页使用户可以查找要更新的记录。有关更多信息，请参见搜索要更新的记录 (PHP)。
  • 将逻辑添加到更新页，允许它从数据库中检索用户选定的记录，准备进行更新。有关说明，请参见检索要更新的记录 (PHP)。
  • 将 HTML 表单添加到更新页以允许用户修改数据。有关说明，请参见逐块完成更新页 (PHP)。

实现了这些前提条件之后，您可以完成“更新记录”对话框。

若要设置对话框的选项，请执行以下操作：

  1. 从“提交值，自”弹出菜单中选择一个表单。
  2. 在“连接”弹出菜单中，选择一个到数据库的连接。
  3. 在“更新表格”弹出菜单中，选择包含您正在更新的记录的数据库表。
  4. 指定要更新的数据库列，从“值”弹出菜单中选择将更新该列的表单对象，从“提交为”弹出菜单中为该表单对象选择数据类型，并且如果要将此列标识为主键，还应选择“主键”。

    数据类型是数据库表中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  5. 在“更新后，转到”框中，输入在表格中更新记录后打开的页或单击“浏览”按钮浏览到该文件。
  6. 单击“确定”。

Dreamweaver 在页中添加服务器行为，允许用户通过单击表单上的“提交”按钮更新数据库表中的记录。


设置“删除记录”对话框的选项 (PHP)

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表中删除记录。

若要设置对话框的选项，请执行以下操作

  1. 在“先检查是否定义了变量”弹出菜单中，指定具有“提交”按钮（用于将删除命令发送到服务器）的 HTML 表单。
  2. 在“连接”弹出菜单中，选择一个到数据库的连接。
  3. 在“表格”弹出菜单中，选择包含要删除的记录的数据库表。
  4. 在“主键列”弹出菜单中，选择一个键列在数据库表中标识该记录。
  5. 在“主键值”弹出菜单中，指定标识要删除的记录的变量。
  6. 在“删除后，转到”文本框中，输入在从数据库表格中删除记录后打开的页或单击“浏览”按钮浏览到该文件。
  7. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过单击表单上的“提交”按钮删除数据库表中的记录。


附录

获取开发 Web 应用程序所需的更多帮助。

此部分包含以下各章：

数据库初学者指南

SQL 入门


数据库初学者指南

本附录适用于对数据库或数据库连接使用经验很少或没有使用经验的 Macromedia Dreamweaver 8 用户。本附录解释一般性概念，而非特定的操作过程。若要了解这些概念在实践中如何应用，请参阅帮助系统的其余部分。

本附录描述如何设计数据库，但不涉及如何在如 Microsoft Access 或 SQL Server 等应用程序中创建数据库。您的数据库系统所附带的印刷或联机文档介绍了该过程。

本附录包含以下章节：

关于数据库

数据库设计基础

理解数据库连接


关于数据库

数据库的基本组成单位是记录。记录是被视为单个实体的相关数据的集合。例如，一个曲棍球商用卡可以称为一条记录：该卡集中了某名运动员的姓名、照片、运动队和相关的统计信息。用数据库术语表示，上述每一条相关信息都可以称为一个字段：每条曲棍球卡“记录”都具有姓名字段、照片字段、运动队字段以及各种运动员统计信息字段。

具有相同字段的记录的集合称为表，因为此类信息可方便地以表的格式表示：每一列代表一个字段，每一行代表一条记录。实际上，“列”一词和“字段”一词是同义的，“行”一词和“记录”一词是同义的。

一个数据库可包含多个表，每个表具有唯一的名称。这些表可以是相关的，也可以是彼此独立的。

从一个或多个表中提取的数据子集称为记录集（在 ASP.NET 中称为数据集）。记录集也是一种表，因为它是具有相同列的记录的集合。例如，列有运动员姓名和司职位置的曲棍球运动队花名册可以称为记录集：它由所有可能与运动员相关的信息（如得分、助攻、罚球记录等等）的子集组成。

若要创建记录集，需要运行数据库查询。查询由搜索条件组成。例如，查询可指定记录集中仅包含特定列或仅包含特定记录。有关更多信息，请参见了解记录集。

相关主题

  • 数据库设计基础
  • 理解数据库连接


数据库设计基础

数据库设计是构建任何数据库驱动的 Web 站点的第一步。本节提供一个案例研究，来解释基本的数据库设计原则。该案例研究涉及一个由名为 Arrow Aircraft Services 的虚构公司委托开发的 Web 应用程序。该公司经营一小队私人拥有的商用喷气式飞机。

数据库设计包括一系列常规步骤。第一步，研究要在 Web 应用程序中反映的业务规则和策略。第二步，考虑用户将询问数据库的问题。第三步，定义数据库结构。最后，创建数据库。

本节包含以下主题：

  • 研究 Arrow Aircraft 的业务规则和策略
  • 研究 Arrow Aircraft 的功能要求
  • 用户将向数据库询问什么问题？
  • 选择数据库中包含的表
  • 选择每个表中的列
  • 定义表之间的关系
  • 创建数据库


研究 Arrow Aircraft 的业务规则和策略

假设根据某份合同，您受雇为 Arrow Aircraft Services 构建一个 Web 应用程序。在开始设计数据库之前，您需要确保理解了该组织的所有将影响应用程序的业务规则和策略。本节描述了 Arrow Aircraft Services（简化）的业务规则和策略。

Arrow Aircraft 经营一队五架分属不同所有者的不同大小和型号的商用喷气机。每架喷气机最多可有八位部分所有者（已购买该飞机股份的公司或个人）。不需要全年使用商用喷气机的人士比较欢迎这种安排方式。

部分所有者（或者也可称为“股份持有者”）需要向 Arrow Aircraft 支付以下费用：

  • 与所有者持有的飞机股份成比例的月管理费，用于支付飞行员、保险和停机的费用
  • 用于支付所有诸如维护、引擎备用和餐饮等直接成本的每小时“占用”费

作为交换，股份持有者告诉 Arrow Aircraft 何时需要飞往何地，Arrow Aircraft 负责其它事情，包括雇用航班和地勤人员以及为航班人员准备餐饮。Arrow Aircraft 要求至少提前 8 小时提出申请才能准备一次飞行。

Arrow Aircraft 保证每架飞机每年的“占用小时数”达到 800 小时。占用小时数是指喷气机处于飞行中而且至少搭乘一名乘客的小时数。占用小时数在乘客搭载的飞机起飞前六分钟（一个小时的十分之一）开始计算，到飞机降落后六分钟结束。

每架飞机最多可有八位所有者。例如，一个个人或公司可购买一架喷气机的 1/5 股权（或 1/5 股份）。由于 Arrow Aircraft 保证每年 800 小时的占用飞行小时数，因此持有 1/5 股份的所有者具有 160 小时的占用小时数（800 小时 / 5 = 160 小时）。


研究 Arrow Aircraft 的功能要求

Arrow Aircraft 雇用您构建具有以下功能的 Web 应用程序：

  • 允许任何飞机股份持有者请求飞机进行飞行
  • 向公司的“飞行运作部门”提供开始准备飞机飞行所需的所有信息，包括股份持有者请求的详细信息（路线、出发日期和时间、餐饮需求等）、股份持有者的剩余占用小时数以及对于建议行程可用的飞机
  • 允许“飞行运作部门”预订飞机以防止日程冲突


用户将向数据库询问什么问题？

在您熟悉了所建议的有关该 Web 应用程序的功能后，您可以与该数据库的用户们一起协商，并提出以下问题：“您将向数据库询问什么问题？”

您从一些飞机股份持有者那里了解到他们希望询问数据库以下问题：

  • 我还剩下多少占用小时数？
  • 我的飞机在特定日期或特定日期范围是否可用？

在某股份持有者请求飞机后，“飞行运作部门”的雇员将询问数据库以下问题：

  • 该股份持有者希望飞往何地？
  • 飞行路线是单程、往返还是途经多个城市？“飞行运作部门”需要这些信息以开始制定飞行计划（查看天气预报、提出飞行计划等）并估计总占用小时数。
  • 该股份持有者剩余的占用小时数是否足够用于计划的路线？
  • 该股份持有者希望何时出发？
  • 该股份持有者的飞机是什么型号？
  • 该飞机是否可用于计划的路线？
  • 该股份持有者随行乘客有多少？
  • 他们将携带多少行李 － 轻（手提行李）、普通（每位乘客一个手提箱）或重（每位乘客有多个手提箱）？
  • 该股份持有者的餐饮需求如何？
  • 该飞机的每小时占用费如何？
  • 我在何处能联系到该股份持有者以确认本次飞行和估计的费用？


选择数据库中包含的表

在了解到用户将询问数据库的问题后，可思考应如何构造数据库才能最圆满地回答他们的问题。第一步是选择数据库中的表。

在关系数据库中，所有数据都表示在表的行和列中。每个表都描述了诸如人员、对象或事件的相关实体的集合。每行都描述实体的一个匹配项，每列都描述实体的一个属性。例如，人员的姓氏、对象的颜色或事件的日期。

可为 Arrow Aircraft 数据库选择以下五个表：

  • 一个飞机表，描述由 Arrow Aircraft 经营的所有商用喷气机
  • 一个飞机预订表，列出喷气机已被预订或无法飞行的所有日期
  • 一个股份持有者表，描述拥有喷气机股份的所有公司和个人
  • 一个路线表，描述股份持有者请求的所有路线
  • 一个飞行表，描述路线的各段行程（“航程”）。


选择每个表中的列

下一步是选择每个表中的列。这些列描述了表中每个实体的属性。

选择列时的一个很好的经验规则是避免重复的数据。例如，在 Arrow Aircraft 应用程序中，您知道股份持有者姓名一定会与路线数据一起用于回答以下“飞行运作部门”问题：“股份持有者对特定路线的餐饮需求如何？”

一种方法是使股份持有者表和路线表都具有股份持有者的名字和姓氏列。但是，这不但使两个表中的姓名数据重复，而且将在路线表中若干次重复这些数据（在股份持有者每次请求新路线时，都必须在路线表中输入股份持有者的姓名）。此方法将增加数据输入的工作，带来出错的机会，并会危及数据的完整性（在数据库的一部分中进行更改，在数据库的其它部分也必须进行更改）。

一个好得多的解决方案是在一个表（股份持有者表）中仅输入一次股份持有者的名字和姓氏。当需要回答上面的“飞行运作部门”问题时，您可以使用 SQL 表达式将股份持有者表与路线表联接。

确保每个表都有一个主键列。主键列包含的值对于每一行都是唯一的。这使您能够在搜索数据库时准确地找到所需的行。大多数主键列由 ID 号组成，但也可使用自然的主键，例如政府规定的编号或飞机序列号。

经过一番思考后，为 Arrow Aircraft 数据库中的表选择了以下属性和主键：


定义表之间的关系

在定义了表中的基本列和主键后，可开始定义表之间的关系。定义了关系后，就可在 Dreamweaver 中编写 SQL 语句，以合并两个表的数据（请参见联接表）。

例如，由 Arrow Aircraft 经营的每架飞机都有若干个股份持有者。您希望在飞机表中的每架飞机与股份持有者表中的股份持有者之间建立类似于“一对多”的关系。这将使您不必在股份持有者表中输入和跟踪冗余的飞机数据。

在一对多数据库关系中，一个表中的单个行与另一个表中的多个行相关。您可通过在提供多个行的表（在上述示例中，就是股份持有者表）中包含一个外键来定义这种关系。外键是所包含的值与另一个表主键列中的值相匹配的列。飞机表的主键称为 ac_serial。因此，在股份持有者表中包含称为 ac_serial 的外键将定义一个“一架飞机对多个股份持有者”的关系。

在了解了客户的功能要求和公司的业务规则及策略后，您决定在数据库中定义以下一对多关系：

  • 每架飞机有多位股份持有者
  • 每架飞机有多次预订
  • 每架飞机有多条路线
  • 每位股份持有者有多条路线
  • 每条路线可有多段行程（或航程）

下面是添加了定义这些关系的外键后修订的表关系图：

这些关系图称为 E-R 关系图或实体关系关系图。


创建数据库

最后的设计步骤是使用诸如 Microsoft Access、SQL Server、Oracle9i 或 MySQL 的数据库系统创建数据库。有关更多信息，请参考数据库系统文档。


理解数据库连接

如果您计划将数据库与 Web 应用程序一起使用，至少需要创建一个数据库连接。如果没有数据库连接，应用程序将不知道在何处找到数据库或如何与之连接。可通过提供应用程序与数据库建立联系所需的信息或“参数”，在 Dreamweaver 中创建数据库连接。

注意

在 Dreamweaver 中，不需要为 ColdFusion 页创建数据库连接。您可以使用 ColdFusion 数据源进行连接。

本节用常规术语讨论数据库连接。有关在 Dreamweaver 中创建连接的详尽说明，请参见连接到数据库。


与数据库进行通信

存储在数据库中的数据通常有专有的格式，就像字处理器文件中的文本以专有格式存储一样。例如，数据在 Microsoft Access 中类似于此处显示的形式：

相同的数据库在“记事本”中类似于此处显示的形式：

您的 Web 应用程序与“记事本”或其它任何应用程序一样，在试图访问未知格式的数据时面临同样的问题：应用程序无法解释这些数据。这就需要在 Web 应用程序与数据库之间存在一个软件接口，以允许应用程序和数据库互相进行通信。

三种常见接口可以使应用程序与数据库进行通信。第一种称为“开放式数据库连接”（或 ODBC）；第二种称为 OLE DB（对象链接和嵌入数据库）；第三种称为“Java 数据库连接”（或 JDBC）。

这些接口的工作类似于翻译人员。例如，当在联合国进行英语演讲时，一名翻译人员为说法语的代表进行翻译，同时另一名翻译人员为说德语的代表进行翻译。与此类似，您可为“说”OLE DB 的应用程序使用一种接口，为“说”ODBC 的 Web 应用程序使用另一种接口，还可为“说”JDBC 的应用程序使用另外一种接口。ColdFusion 和 JSP 应用程序使用 JDBC、ASP 使用 ODBC（通过内置的 OLE DB/ODBC 解释器）、ASP.NET 应用程序使用 OLE DB。


使用数据库驱动程序与数据库进行通信

ODBC、OLE DB 和 JDBC 接口由数据库驱动程序（在 OLE DB 中称为“数据提供程序”）实现，这些接口仅是软件片段。当 Web 应用程序与数据库进行通信时，应用程序是通过驱动程序的中间作用实现通信的。

数据库驱动程序是特定于数据库的。例如，可以使用 Microsoft Access、SQL Server 和 dBase 驱动程序。与此类似，您可使用 OLE DB 提供程序，例如用于 SQL Server 的 OLE DB 提供程序。您的数据库决定了您的选择。

驱动程序由诸如 Microsoft 和 Oracle 等数据库供应商编写，也可由各个第三方软件供应商编写。Microsoft 为最流行的数据库软件包（如 Microsoft Access、Microsoft SQL Server 和 Oracle）提供许多 ODBC 驱动程序和 OLE DB 提供程序。ODBC 驱动程序只运行于 Windows 平台，在安装 Microsoft Office、Windows 2000 或 Windows XP Professional 时会同时自动安装这些驱动程序。它们也随 Microsoft Data Access Components (MDAC) 2.5、2.6 和 2.7 软件包安装。Microsoft Data Access Components (MDAC) 2.5、2.6 和 2.7 软件包可从 Microsoft Web 站点 http://msdn.microsoft.com/data/mdac/downloads/ 处免费下载。MDAC 2.7 可安装许多 OLE DB 提供程序。

注意

首先安装 MDAC 2.5，然后安装 MDAC 2.7。

若要了解您的 Windows 系统上安装了哪些 ODBC 驱动程序，请参见查看安装在 Windows 系统上的 ODBC 驱动程序。

一些常见 JDBC 驱动程序包括：用于 Microsoft SQL Server 数据库的 i-net JDBC 驱动程序、用于 Oracle 数据库的 Oracle Thin 驱动程序和用于 IBM DB2 数据库的 JDBC Driver for DB2。有关 JDBC 驱动程序及其供应商的更多信息，请访问 Sun Web 站点 http://developers.sun.com/product/jdbc/drivers 上 JDBC 驱动程序的可搜索数据库。

此处是用于各种类型 Web 应用程序的数据库接口及一些常见的数据库驱动程序：

Web 应用程序 | 数据库接口 | 常见驱动程序
ColdFusion JSP | JDBC | ColdFusion 本身的驱动程序 Sun JDBC-ODBC 驱动程序 Oracle Thin JDBC 驱动程序
ASP | ODBC 或 OLE DB | Microsoft Access Driver Microsoft SQL Server Provider Microsoft ODBC for Oracle
ASP.NET | OLE DB | Microsoft Jet Provider Microsoft SQL Server Provider Microsoft Oracle 提供程序
PHP | 特定于 MySQL | MySQL 驱动程序


查看安装在 Windows 系统上的 ODBC 驱动程序

如果您需要特定的 ODBC 驱动程序，并且您的 Web 服务器运行于 Windows 系统上，则可方便地知道系统上是否安装有所需的 ODBC 驱动程序。

若要查看 Windows 系统上安装的 ODBC 驱动程序，请执行以下操作：

  1. 按以下步骤打开“ODBC 数据源管理器”：
    • 在 Windows 2000 中，选择“开始”>“设置”>“控制面板”>“管理工具”>“数据源”。
    • 在 Windows XP 中，选择“开始”>“控制面板”>“管理工具”>“数据源 (ODBC)”。
  2. 单击“驱动程序”选项卡。

    将会出现系统上所安装的 ODBC 驱动程序的列表。


调用数据库驱动程序

应用程序必须调用数据库驱动程序才能建立与数据库的双向通信。Web 应用程序通过使用连接字符串来调用驱动程序。连接字符串由建立到数据库的连接所需的全部信息（或参数）组成。连接字符串可用类似于以下示例的最简单形式指定驱动程序和数据库：

Driver={Microsoft Access Driver (*.mdb)};
DBQ=C:\Inetpub\wwwroot\Scaal\scaalcoffee.mdb

ASP 连接字符串可包含指定 OLE DB 提供程序的 Provider 参数。如果省略此参数，默认情况下，ASP 为 ODBC 驱动程序使用 OLE DB 提供程序。在上面的示例中，用于 ODBC 驱动程序的 OLE DB 提供程序将与 ODBC 驱动程序 (Microsoft Access Driver) 进行通信，而 Microsoft Access Driver 又将与 Access 数据库 (scaalcoffee.mdb) 进行通信。

根据驱动程序的不同，连接字符串中的参数可能不同。下面是一个用于名为“Cases”的 SQL Server 数据库的连接字符串，“Cases”位于名为 Hoover 的服务器上：

Driver={SQL Server};Server=Hoover;Database=Cases;
UID=DanaS;PWD=Queequeg

注意

UID 表示用户 ID，PWD 表示密码。

Dreamweaver 通过向您提供可在其中输入不同连接参数的对话框，简化了向页面中插入连接字符串的过程。例如，此处显示在开发 JSP 应用程序时，定义连接的对话框的外观：

在完成对话框设置并单击“确定”后，Dreamweaver 将连接字符串插入到站点的包含文件中。


使用 DSN

可在一些连接中指定数据源名称 (DSN)。DSN 是在 Windows 中为连接字符串创建的一种快捷方式。

例如，假设有一个名为“Precinct”的 Microsoft SQL Server 数据库，该数据库位于名为“Kojak”的服务器上。为了能够访问该数据库，必须输入用户名 columbo 和密码 savalas7。在使用这些参数定义一个名为 ourcops 的 DSN 之后，可以通过在 Dreamweaver 中输入单词 ourcops 创建连接，而不必输入所有的其它参数。

如果应用程序服务器运行于 Windows 系统上，并且您在该系统中定义了 DSN，则可以使用该 DSN 定义 ASP 或 JSP 连接。

如果您不具有对服务器的物理访问权限，从而无法在其上定义 DSN，则您必须使用连接字符串来连接到该数据库。

若要在 Windows 中设置 DSN，请参见 Microsoft Web 站点上的下列文章：

  • 对于 Windows 2000 用户，请参见 Microsoft 知识库文章 300596，网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;300596
  • 对于 Windows XP 用户，请参见 Microsoft 知识库文章 305599，网址为 http://support.microsoft.com/default.aspx?scid=kb;en-us;305599

相关主题

  • ASP 开发人员的数据库连接
  • 用于 JSP 开发人员的数据库连接


SQL 入门

本附录说明如何使用“结构化查询语言”（Structured Query Language，SQL）为动态页创建记录集。SQL（发音是 sequel）是一种用来从数据库中读取数据以及将数据写入数据库中的语言。虽然该语言仅使用几个关键字和一些非常简单的语法规则，但却使您可以执行复杂的数据库操作。

本附录包含以下章节：

语法基础知识

定义记录集的列

限制记录集中的记录

对记录集中的记录进行排序

联接表

相关主题

  • 关于数据库
  • 数据库设计基础
  • 了解记录集

    注意

    Macromedia 不为第三方技术（如 SQL）提供技术支持。


语法基础知识

最常用的 SQL 语句之一是 SELECT 语句，它可从一个或多个数据库表中提取指定列，以生成一个记录集。下面是 SELECT 语句的基本语法：

SELECT ColumnName FROM TableName

可以在语句中添加换行符、制表符和其它空白，以使逻辑关系更加清晰：SQL 忽略所有空白。下面是一个有效语句的示例：

SELECT PaidDues
   FROM Members

下列关键字标识常用的 SQL 命令：

关键字 | 描述
SELECT | 从数据库中检索指定的记录
INSERT | 在数据库表中添加新记录
UPDATE | 更改指定数据库记录中的值
DELETE | 移除指定的数据库记录

下列关键字使 SQL 语句更精确：

关键字 | 描述
FROM | 为操作指定数据源
WHERE | 为操作设置一个或多个条件
ORDER BY | 按指定顺序对记录集行进行排序
GROUP BY | 按指定的选择列表项将记录集进行分组

下列运算符指定条件并执行逻辑和数字运算功能：

运算符 | 意义
= | 等于
LIKE | 类似于（支持通配符）
<> | 不等于
NOT LIKE | 不类似于（支持通配符）
< | 小于
> | 大于
<= | 小于或等于
>= | 大于或等于
AND | 两个条件都必须满足，如：上海 AND 北京
OR | 至少必须满足其中一个条件，如：老张 OR 老王
NOT | 排除后跟的条件，如：巴黎 NOT 法国

如果比较的项是文本，请将其放在单引号中，如下例中所示：

...WHERE Country = 'Germany'

如果比较的项是日期，而且使用的是 Microsoft Access 数据库，请将日期放在两个 # 符号之间：

...WHERE DateOfBirth < #01/01/1970#

其它数据库可能有其自己的日期约定。请查阅数据库系统的文档。

一些数据库系统可能在其产品中使用非标准的 SQL 语法。请查阅数据库系统的文档。


定义记录集的列

可使用 SQL 为页面定义记录集。记录集是从数据库中提取的记录子集。有关更多信息，请参见关于数据库。

下面是用来定义记录集的列的基本 SQL 语法：

SELECT ColumnName1, ColumnName2, ColumnNameX FROM TableName

如果要在记录集中包含某个表的所有列，可以使用通配符 *，如下所示：

SELECT * FROM TableName

例如，假设有一个名为 Customers 的表。若要提取所有列，可键入下面的 SELECT 语句：

SELECT * FROM Customers

假设只需要 Customers 表内以下两列中包含的数据：YearBorn 列和 DateLastPurchase 列。若要创建只包含这两列中数据的记录集，请键入下面的 SELECT 语句：

SELECT YearBorn, DateLastPurchase
FROM Customers


限制记录集中的记录

使用 WHERE 子句限制记录集中的记录数。例如，可能只希望包含年薪高于 50,000 美元的那些客户。假设表中有名为 Earnings 的列，该列列出了每位客户的收入。所使用的 SELECT 语句应如下所示：

SELECT YearBorn, DateLastPurchase FROM Customers
WHERE Earnings > 50000

可以在 WHERE 子句中指定一个或多个条件，以筛选出数据库中的记录。以下章节描述使用 WHERE 子句筛选记录的方法：

  • 根据两个值是否相等筛选记录
  • 根据两个值之间的相似性筛选记录
  • 根据值的范围筛选记录
  • 根据组合搜索条件筛选记录

根据两个值是否相等筛选记录

可以根据参数的值与记录列的值是否相等来筛选数据库中的记录。

假设决定让用户按部门搜索数据库。则必须满足下列逻辑关系才能生成搜索结果记录集：

  • 检查数据库表中的一个记录。
  • 如果该记录 department 列中的值等于用户提交的部门名称，则在搜索结果记录集中包含该记录。
  • 检查表中的下一条记录。

可以使用下面的 WHERE 子句表示这种逻辑：

WHERE ColumnName = ParameterValue

ParameterValue 是包含搜索参数的 SQL 变量。在 Web 应用程序中，用户通常使用 HTML 表单提供此参数。

可以完全用 SQL 表达这种数据库查询，如下所示：

SELECT FIRSTNAME, LASTNAME, DEPARTMENT, EMAIL
FROM EMPLOYEES
WHERE DEPARTMENT = 'varDept'

此 SQL 语句在雇员表中查找 DEPARTMENT 值等于 varDept 变量中所包含值的所有记录。例如，如果用户指定 Operations 作为部门名称，则该 SQL 语句可能生成下列记录集：

根据两个值之间的相似性筛选记录

可以根据参数值与记录列的值的相似性，对数据库中的记录进行筛选。

在指定搜索参数的值时，使用相似性而不是相等性，可以给予用户更大的灵活性。例如，搜索字不需要区分大小写。如果用户输入 ohio，而表列中包含值 Ohio，则产生匹配。

而且，相似性允许使用通配符，以便用户可以搜索字母或搜索单词中的一部分。例如，如果用户输入 m，而且表列中包含值 Morgan、Macy 和 Michelson，则可在 SQL 语句中使用通配符，从而与所有这三个项匹配。

标准通配符是百分号 (%)：

...WHERE LastName LIKE 'Mc%'

假设决定让用户按姓氏搜索数据库。则必须满足下列逻辑关系才能生成搜索结果记录集：

  • 检查数据库表中的一个记录。
  • 如果该记录 Last name 列中的值包含类似于用户提交的值，则在结果记录集中包含该记录。
  • 检查表中的下一条记录。

可以使用下面的 WHERE 子句表示这种逻辑：

WHERE ColumnName LIKE ParameterValue

ParameterValue 是包含搜索参数的 SQL 变量。在 Web 应用程序中，用户通常使用 HTML 表单提供此参数。

可以完全用 SQL 表达这种数据库查询，如下所示：

SELECT FIRSTNAME, LASTNAME, DEPARTMENT, EMAIL
FROM EMPLOYEES
WHERE DEPARTMENT LIKE 'varLastName'

如果要使用户能够搜索部分单词，可组合使用变量和通配符。这种情况下使用的 SQL 通配符是百分号 (%)。这里提供了一个示例：

...WHERE LASTNAME LIKE 'varLastName%'

例如，如果用户键入 s 作为搜索参数，则姓氏以字母 s 开头的所有记录都包含在记录集中，如下面的示例所示：

如果用户指定 sm 作为搜索参数，则只有姓氏以字母 sm 开头的那些记录包含在记录集中：

根据值的范围筛选记录

可以根据记录列的值是否在两个参数值的范围之间来筛选数据库中的记录。

假设决定让用户按日期范围来搜索数据库。则必须满足下列逻辑关系才能生成搜索结果记录集：

  • 检查数据库表中的一个记录。
  • 如果该记录 date 列中的值在用户提交的两个日期值之间，则在结果记录集中包含该记录。
  • 检查表中的下一条记录。

可以使用下面的 WHERE 子句表示这种逻辑：

WHERE ColumnName BETWEEN ParameterValue1 AND ParameterValue2

ParameterValue1 和 ParameterValue2 是包含搜索参数的 SQL 变量。在 Web 应用程序中，用户通常使用 HTML 表单提供这些参数。

以下示例说明如何用 SQL 表达这种数据库查询：

SELECT FIRSTNAME, LASTNAME, DEPARTMENT, STARTDATE
FROM EMPLOYEES
WHERE STARTDATE BETWEEN #varStartRange# AND #varEndRange#

例如，如果用户输入 7/1/99 和 12/31/99 作为范围参数，则 1999 年下半年加盟的所有雇员都将包含在记录集中，如下面的示例中所示：

根据组合搜索条件筛选记录

本节描述如何根据组合搜索条件在搜索结果记录集中包含记录。在 SQL 中可以使用 AND、OR 和 NOT 逻辑运算符组合搜索条件。

如果希望所有条件都为“真”时，记录才能包含在记录集中，请使用 AND 运算符，如下所示：

...WHERE LASTNAME LIKE 'varLastName' AND DEPARTMENT LIKE 'varDept'

如果希望只要其中任何一个条件为“真”时，记录就可以包含在记录集中，请使用 OR 运算符，如下所示：

...WHERE LASTNAME LIKE 'varLastName' OR DEPARTMENT LIKE 'varDept'

如果希望其中一个条件为“真”，而另一个条件不为“真”，请使用 NOT 运算符，如下所示：

...WHERE DEPARTMENT LIKE 'varDept' AND NOT COUNTRY LIKE 'varCountry'

可以使用括号组合搜索条件：

...WHERE (DEPARTMENT LIKE 'varDept' AND STARTDATE < #varStart#)
OR STARTDATE BETWEEN #varStartRange# AND #varEndRange#


对记录集中的记录进行排序

使用 ORDER BY 子句对记录集中的记录进行排序。例如，假设希望按客户收入从最低到最高对记录集中的记录进行排序。在 SQL 中，按如下所示对记录进行排序：

SELECT LastName, FirstName, Earnings FROM Customers
ORDER BY Earnings

默认情况下，ORDER BY 子句按升序（1、2、3... 或 A、B、C...）对记录进行排序。如果希望按降序对记录进行排序，从最高收入到最低收入，请使用 DESC 关键字，如下所示：

ORDER BY Earnings DESC


联接表

可以使用一个 SELECT 语句从数据库的多个表中检索数据。该语句联接表，并返回一个包含每个表中所选数据的记录集。

例如，公司数据库可能包含两个表，一个表是有关雇员的个人数据，另一个表是有关公司部门的数据。如果要生成一个显示雇员姓名、电话号码和部门的雇员名录，则必须同时从两个表中检索信息。

为此，请创建一个联接，指定要包含的所有表以及表彼此之间如何关联。这里提供了一个示例：

SELECT FIRSTNAME, LASTNAME, PHONE, DEPTNAME
FROM EMPLOYEES, DEPARTMENTS
WHERE EMPLOYEES.DEPT_ID = DEPARTMENTS.DEPT_ID

注意

使用点标记可以更精确地标识列。例如，EMPLOYEES.DEPT_ID 指 EMPLOYEES 表中的 DEPT_ID 列。

第一行指定要检索的列。前三列 － FIRSTNAME、LASTNAME 和 PHONE － 存在于 EMPLOYEES 表中，而第四列 － DEPTNAME － 存在于 DEPARTMENTS 表中。

第二行指定要从中检索数据的两个表：EMPLOYEES 和 DEPARTMENTS。

最后一行指定要在两个表中进行联接和检索的记录。每个表中都有一个名为 DEPT_ID 的列。（在 DEPARTMENTS 表中，该列为主键。有关更多信息，请参见定义表之间的关系。）WHERE 子句将一个表中 DEPT_ID 的值与另一个表中 DEPT_ID 的值进行比较。如果找到匹配项，则将 EMPLOYEES 表中该记录的所有字段与 DEPARTMENTS 表中该记录的所有字段相联接。然后，对合并数据进行筛选，以创建由 FIRSTNAME、LASTNAME、PHONE 和 DEPTNAME 列组成的新记录。最后，将新记录添加到记录集中。

在一些数据库系统中使用稍有不同的联接语法可能会更好。例如，下列 SQL 语句使用 SQL 关键字 INNER JOIN...ON 来获得与上例相同的结果：

SELECT FIRSTNAME, LASTNAME, PHONE, DEPTNAME
FROM EMPLOYEES INNER JOIN DEPARTMENTS
ON EMPLOYEES.DEPT_ID = DEPARTMENTS.DEPT_ID

请查阅数据库系统的文档来确定应使用的联接语法。

上一页


商标 和 鸣谢

商标

1 Step RoboPDF、ActiveEdit、ActiveTest、Authorware、Blue Sky Software、Blue Sky、Breeze、Breezo、Captivate、Central、ColdFusion、Contribute、Database Explorer、Director、Dreamweaver、Fireworks、Flash、FlashCast、FlashHelp、Flash Lite、FlashPaper、Flex、Flex Builder、Fontographer、FreeHand、Generator、HomeSite、Jrun、MacRecorder、Macromedia、MXML、RoboEngine、RoboHelp、RoboInfo、RoboPDF、Roundtrip、Roundtrip HTML、Shockwave、SoundEdit、Studio MX、UltraDev 和 WebHelp 是 Macromedia, Inc. 的注册商标或商标，并且可能已在美国或其它司法管辖区域（包括国际法管辖区域）内注册。本出版物涉及的其它产品名称、徽标、图案、标题、文字或短语可能是 Macromedia, Inc. 或其它实体的商标、服务标志或商品名称，并且可能已在某些司法管辖区域（包括国际法管辖区域）内注册。

第三方信息

本指南包含指向第三方 Web 站点的链接，这些站点不受 Macromedia 的控制，并且 Macromedia 不对所链接的任何站点上的内容负责。如果要访问本指南中提到的第三方 Web 站点，风险自负。Macromedia 提供这些链接仅仅是为了方便，并不意味着 Macromedia 认可或接受对这些第三方站点上的内容负有任何责任。

Copyright © 2005 Macromedia, Inc. 保留所有权利。未经 Macromedia, Inc. 事先书面许可，不得将本手册的全部或部分拷贝、影印、复制、翻译或转换为任何电子形式或可用机器读取的形式。除了上述事项外，随本手册提供的软件的有效副本的所有者或授权用户可以从本手册的电子版本打印一份副本，但仅限于供此类所有者或授权用户学习此软件时使用，不得打印、复制、分发、再销售或传输本手册的任何部分以用于其它用途，包括但不限于商业用途，如销售此文档的副本或提供有偿支持服务。

鸣谢

管理：Charles Nadeau

撰稿：Jon Michael Varese

其他编写人员：Jennifer Rowe、Paul Gubbay、Charles Nadeau

编辑：Rosana Francescato、Lisa Stanziano、Anne Szabla、Evelyn Eldridge、Mary Ferguson、Mark Nigara

本地化管理：Melissa Baerwald

本地化质量保证：Cindy Shen

制作管理：Patrice O’Neill

媒体设计和制作：John Francis、Adam Barnett、Mario Reynoso、Aaron Begley、Arena Reed、Paul Rangel

特别感谢：Sheila McGinn、Paul Gubbay、Vic Mitnick、Jim Doubek、Joaquin Blas、Wenlan Du、Ken Karleskint、Jennifer Taylor、Jorge Taylor、Nick Halbakken、Scott Richards、Sami Kaied、Jung Choi、John Skidgel、Jennifer Rowe、Jay Armstrong、Sally Sadosky、测试版测试人员以及 Dreamweaver 工程小组和 QA 小组的全体人员。

第一版：2005 年 9 月

Macromedia, Inc.
601 Townsend St.
San Francisco, CA 94103


Dreamweaver 8 帮助

版权所有 © 2005
Macromedia, Inc.
保留所有权利。
商标和鸣谢


使用 Dreamweaver

本指南基于各项任务全面介绍了 Dreamweaver 的所有功能。

本指南包含以下各部分：

Dreamweaver 基础

使用 Dreamweaver 站点

对页进行布局

向页面添加内容

使用页代码

准备建立动态站点

生成动态页

迅速开发应用程序

附录