前言

DOS之家 葛明阳

“DOS之家”自从2000年建站以来，得到了许多网友的关注和帮助，尤其是第二版的DOS之家出炉后，访问量与日俱增，一个冷门话题的个人网站发展到今天（5000多注册用户，600IP/每日），可以说实数不易，在这里，我要感谢几年来支持本站的网友们，是你们给了我办好这个站的信心和勇气，谢谢大家了。

2002年某日，一位特殊的网友光临本站，那就是“高兴”大姐（《电脑爱好者》杂志社编辑），她对本站颇感兴趣，并通过EMAIL向我约稿，要求写与DOS有关的话题，如果能写好，将准备在她负责的《特别话题》栏目中发表，我听了非常高兴，因为俗话说：“千里马常有，伯乐难寻”...终于有人发现我了！！！（谁在申舌头？天气不热啊！）

我连夜把10000字的稿子写了出来。别看字数不太多，但颇花了些心思，虽然网友都称我为电脑高手，但也免不了有不会的的时候，怎么办？只有上网“搜索，搜索，再搜索”，这样，一个月下来，上网费多了许多。

后来，当“高兴”大姐正要排版时，突然杀出个“李红警”（当时《系统应用》栏目的责编），硬是把稿子从“高兴”手里“抢”走了，说是要他的栏目中连载，并且还多了一些要求。我的天啊，又来个伯乐！我可有点受宠若惊了！

于是又开始了日夜兼程...14期，终于看到我的文章了！15期、16期，到了17期的时候，《系统应用》栏目换了责编，就是现在的“木头”，后几篇文章都是他帮助修改的。在此，我真心地向3个编辑同志说声：谢谢。

其实，这10篇文章不仅集中了3位编辑和我的努力，还有Wengier等网友的帮助，在此一并表示感谢。

文章发表于2002年《电脑爱好者》杂志第14-23期，整理时略有改动。

联系方式：
主页：DOS之家 http://doshome.126.com
EMAIL：gmy@0451.com
OICQ：53617565
论坛: http://doshome.com/bbs/dispbbs.asp?boardID=5&ID=3


DOS系统的安装

作者：DOS之家 葛明阳

一、DOS的历史

DOS是Diskette Operating System的缩写，意思是磁盘操作系统，主要有MS-DOS，PC-DOS，Novell-DOS等几种版本，但以微软公司的MS-DOS流行最广，影响最大。它与Windows最大的不同在于它是字符式操作系统，所有操作通过命令行来执行。MS-DOS发展，从早期1981年不支持硬盘分层目录的DOS1.0，到当时广泛流行的DOS3.3，再到非常成熟支持CD-ROM的DOS6.22，以及后来隐藏到Windows9X下的DOS7.X，前前后后一共经历了20年，至今仍然活跃在PC舞台上，扮演着重要的角色。

二、DOS系统的安装

1.如果安装了Windows9X，无需再安装DOS了，可采用Windows9X自带的DOS7.X
2.如果安装了WindowsMe，不能开机进入DOS实模式，解决办法是安装WindowsMe的DOS实模式补丁
 3.如果只安装过Windows2000/XP，一般认为不能再装DOS了，实际上是有办法的（以下是 http://chinados.126.com的Wengier提供材料，我没试过），以Win2000为例，如果分区格式是FAT32，可以安装Windows97/98自带的DOS7.X，方法是:
(1)复制DOS启动文件:在Win2000环境中把Win98启动盘的IO.SYS，MSDOS.SYS，COMMAND.COM等文件复制到C:\下。注意:如果在DOS下复制不要使用SYS命令，否则Win2000无法启动。
(2)创建C:\Bootsect.dos:该文件是DOS启动所需的MBR主引导记录文件，如果在Win2000安装前安装过DOS/Win9X，该文件会自动生成不用创建;但是本例是Win2000安装前未安装过DOS，所以要手动创建了，创建方法有很多，这里推荐使用一个不到3KB 的小程序Bfhf，它可以备份/恢复MBR，MPBR和CMOS，生成方法是:把Bfhf.exe复制到C:\中，进入DOS，输入Bfhf回车，输入03（备份MBR）回车，输入Bootsect.dos回车，输入00（退出回车）
(3)修改C:\BOOT.INI文件:去掉其所有属性编辑该文件在[operating systems] 下添加一行:C:\="MS-DOS"，好了，重启电脑看看MS-DOS是不是可以与Win2000共存了？（WINXP的方法类似）
DOS安装好之后,下期我们开始通过实例学习使用DOS命令.

本期小提示 ：
如果你的系统是WindowsNT/2000/XP，而且是NTFS格式的，请安装Virtual PC（虚拟PC），选择WINDOWS98就可以得到DOS了，当然你必须有WIN98的安装光盘。

本文发表于2002年《电脑爱好者》第14期


恢复误删文件--DOS命令应用实例（一）

作者：DOS之家 葛明阳

上期我们讲述了DOS 的安装，从本期开始我向大家介绍几个经久不衰的DOS命令，我不会写成DOS命令语法详解，而是结合具体实例，希望对大家有所帮助。

故障现象:
 开机蓝屏无法进入Windows98。
定性分析:
开机按F8，选择Safe Mode（安全模式），同样蓝屏无法进入，再次重启按F8，选择Step-By-Step Confirmation（一步一步配置），逐个确定，到达某一步时，出现“The folowing file is missing or corrupted:c:\windows\ifshlp.sys”，什么意思？（E文不好，只好查英汉词典，大概意思是:ifshlp.sys文件丢失或被破坏，经过回忆，上次关机之前曾经删除过c:\windows下的一些无用文件，如txt文件等，看来ifshlp.sys文件在这次轰炸行动中被误击了。
不能进入Windows系统，只能在DOS环境下恢复了，按照已往的经验具体问题具体分析:

第一种情况:回收站误删，并且未被清空。
在DOS下进入回收站目录进行恢复。主要DOS命令:cd、type、copy （本例属于这种情况。）
恢复步骤:
1.开机按F8，选择Command Prompt Only（命令行方式，即DOS实模式）回车
2.输入CD Recycled回车，如图：
恢复误删文件（回收站）
3.输入Type info2回车，查看回收站删除记录文件，发现ifshlp.sys和它改名后的文件名dc2.sys，太棒了！果真还再！
4.copy dc2.sys c:\windows\ifshlp.sys回车，复制被删文件dc2.com到原始位置c:\windows，并改成原名ifshlp.sys，至此恢复成功。

第二种情况:del命令误删，并且知道文件名。
在DOS下进入被删文件所在目录进行恢复。主要DOS命令:undelete （DOS6.22里的一个外部命令）。
恢复步骤:
1.开机按F8，选择Command Prompt Only回车，进入DOS实模式
2.输入cd windows回车，进入Windows目录
3.输入lock回车，是一个内部命令，目的是解除Windows98里硬盘目录区不让修改的限制，为下一步使用undelete做准备，如果不用lock，Undelete就无法运行，如图:

4.输入Undelete回车，恢复当前文件夹里的所有可以恢复的被删除文件，这时出现第一个被删文件显示bc.txt，很明显这不是我们要恢复的文件英文，显示是否恢复(y/n?)按n，接着出现
？fshlp.sys(y/n?)，哇！找到了！当然按y了，又显示一行英文，意思是说文件名的第一个字符是什么，因为第一个字符是i，当然按i了，dir/a，ifshlp.sys回来了，成功！

第三种情况:回收站误删，并且被清空，或者被deletree误删，并且文件数目不多。
用Win98启动盘启动电脑进行恢复。主要DOS命令:ext和extract
恢复步骤:
1.用Win98启动盘启动电脑
2.输入ext回车，如图:

出现两行英文不要管它，输入c:\mybak\pwin98\win98（Windows98的安装目录，按实际情况输入），回车，输入ifshlp.sys回车，输入c:\windows回车，最后输入y，回车。下面就是耐心的等待了，直到又出现a:\>，拿出软盘重启，大功告成。

第四种情况:与第三种情况类似，但被删文件数目很多，且都是Windows系统文件。
只能用专业文件恢复软件或重装Win98等方法恢复了，因不属于DOS命令范畴，故不做讨论。

本文发表于2002年《电脑爱好者》第15期


合并VCD片断、快速删除文件夹--DOS命令应用实例（二）

作者：DOS之家 葛明阳

一、合并VCD片断--copy的完美解决方案

问题:
最近下载了许多MPG（VCD）电影，但一个600MB的电影被分割成6个100MB的文件，观看起来很不方便，也不过瘾，于是想把它们合并成一个文件观看。
定性:
对于简单的合并一般人用Windows软件如VCDCutter，但它对合并的文件大小有限制，且合并速度也慢，其实用DOS命令copy最合适，正所谓“杀鸡焉用宰牛刀”。
分析:
copy的二进制文件合并功能的参数是/B。
解决:
例如想把c:\down里面的3个mpg文件:1.mpg，2.mpg，3.mpg合并成一个mpg文件并取名为4.mpg，步骤是:
（一）在Win98中打开MS-DOS方式窗口
（二）如图：

二，快速删除文件夹--deltree小试身手

问题:
为增加硬盘空间，打算卸载一个大游戏（安装在c:\moto里），因为是D盘的游戏（直接复制就能玩的那一种，没有卸载程序），只好直接在Windows下删除c:\moto，发现速度奇慢，竟然用了3分多钟，难道没有快一点的方法吗？
定性:
经过分析，这是由于被删目录（C:\moto）里的文件太多，而且Windows的本身的删除机制过于死板造成速度慢。
分析:
经过反复试验，在MS-DOS下用Deltree删除目录树最快。
解决:
如图：
（一）打开MS-DOS 方式窗口
（二）输入deletree c:\moto回车，用不到1分钟就删完了，好快呀。

本文小提示:
不要在“DOS实模式”下删除，一定要在“MS-DOS窗口”下删除，否则比Windows下删除速度还要慢。

本文发表于2002年《电脑爱好者》第16期


低格、分区、高格的应对--DOS命令应用实例（三）

作者：DOS之家 葛明阳

低格、分区、高格是硬盘安装系统之前的三道工序，经常用于出现故障的硬盘。

一、低格--LFORMAT，低格是低級格式化的简称，它是一个较为复杂的针对硬盘表面的物理过程，原本不需要用户操心（硬盘出厂前就已经低格好了），但由于种种原因（硬盘使用不当、质量问题）硬盘有时会出现坏道（坏道的测试方法：在DOS下用输入命令SCANDISK /ALL回车，磁盘扫瞄时，如果出现一个或若干个黑底红字的“B”,就证明硬盘有了坏道），出现坏道的后果是：轻者硬盘吱吱作响，重者硬盘根本无法使用。怎么解决？这时就需要请出“低格软件”,一般可以让硬盘起死回生。
低格软件有很多，如DM、SmartFdisk、QAPLUS等都有低格功能，但笔者体会，低格专门工具LFORMAT更好用些。 例如，一块1.2G硬盘，测试有坏道，用LFORMAT修复，步骤如下：
1、用带有LFORMAT.EXE文件的启动盘引导电脑；
2、出现A:\>输入LFORMAT回车；
如图：

3、出现警告信息（提示是否继续?），按Y继续；
4、出现“Select Device（选择硬盘）”，直接按回车；
5、出现“Which device...？(选择哪个硬盘）”,按数字0（应根据CMOS中硬盘的实际位置选择0、1、2或3)
6、出现所选硬盘参数和“Low level...（低格所选硬盘）”，如果参数相符，按回车；
7、出现“Do you want...?（采用LBA模式吗？）”，如果硬盘大于540M，按Y，如果硬盘小于540MB，按N，本例应该选Y；
8、出现警告信息（提示是否继续?），按Y继续；
9、等待一段时间后，低格完毕。RESET重启，进入A盘，运行SCANDISK /ALL看看，坏道是不是没有了？

二、分区--FDISK，就是把一块硬盘划成一个或多个独立的区域。在多分区的硬盘里，“主分区”一般理解成C盘；“扩展分区”是D-Z盘的总称；“逻辑分区”D-Z盘每个盘的单独称谓。
举例：一块6.4G硬盘（原有C，D，E三个分区），因为原来的C盘太小，想增加C盘容量，需要重新划分硬盘（目标是两个相等的分区，我不建议使用PQ等调整分区，因为兼容不好，易丢数据，最好用FDISK，事先把有用的文件备份)，步骤如下：

（一）删除分区
1、用WIN98启动盘（自带FDISK命令）引导电脑；
2、出现A:\>后，输入FDISK回车；
3、出现提示“Do you wish...”，如果想采用FAT32格式，按Y回车，如果想采用FAT16格式（每个分区必须小于2G），按N回车，本例选Y；
4、出现主菜单，按3回车（“Delete...删除分区”）；
5、出现4个选项，请务必按照4、3、2、1的先后顺序进行选择（即：先后删除“非DOS分区”、“逻辑分区”、“扩展分区”、“主分区”），首先按4回车（“Delete Non-DOS...删除非DOS分区”），出现“No Non-DOS...没有非DOS分区”，按ESC继续；
6、同“步骤3”，再按3回车（“Delete Logical...删除逻辑分区”）
7、出现D盘和E盘的分区情况和提示（“WARNING...输入你要删除哪个分区？）按D回车（删除D盘）
8、出现提示“Enter...输入该盘的卷标”，（“卷标”在上方的分区情况表里有提示）如果有就输入，没有就直接回车跳过；
9、出现“Are...真的删除吗?”，按Y；
10、参看“步骤6-8”删除E盘；
11、参看“步骤4、5”删除扩展分区和主分区。

（二）建立分区
12、出现主菜单，按1（“Create...建立分区）；
13、出现三个选项，请务必按照1、2、3顺序进行选择（即分别先后建立“主分区”、“扩展分区”、“逻辑分区”），首先按1回车（“Create...建立主DOS分区”）；
14、出现提示“Do...是否将硬盘的全部容量划分为基本分区?（即让硬盘只有C盘这一个分区）”，如果是按Y，如果不是（想划分两个或两个以上的分区）按N，本例选N； 15、出现提示“Enter...[6400]”，根据你的需要输入C盘容量或占百分比，本例输入“3200”(当然输入50%效果是一样的）回车，出现C盘的分区情况，按ESC返回主菜单；
16、参看“步骤11-14”建立扩展分区、逻辑分区。

（三）激活分区
17、出现主菜单，按2回车（“Set...激活分区”）；
18、按1回车（激活C盘） 19、ESC退出FDISK，重新电脑，准备格式化。

好了，怎么样，会了吗？...什么？还不会，没关系，以下两个软件可能对你点帮助：
“FDISK汉化版”和
“FDISK完全模拟程序”（下载地址: http://www.skycn.com/soft/8658.html ）

三、高格--FORMAT，高级格式化的简称，是紧跟分区后的一道工序。
举例：一块硬盘已经分区，需要格式化C盘，并让C盘成为可引导盘：
1、用WIN98启动盘（自带FDISK命令）引导电脑；
2、出现A:\>后，输入FORMAT C:/Q/U/S回车（/Q：快速，/U：彻底，/S：复制系统文件，注意FORMAT后要输入空格）；
3、出现警告信息（提示是否继续?）按Y回车；
4、等待...，完成后，提示输入卷标，回车跳过即可。
5、拿出软盘，重启电脑，出现C:\>后，输入DIR回车，如果屏幕显示有COMMAND.COM这个文件，即获成功。

本文小提示：
 1、低格、分区、高格都是危险操作，初学者不宜使用。
2、不建议使用微软以外的分区格式化工具（如PQ、DM、EZ等），因为它们并不完全兼容较新版本的WINDOWS。另外，PQ的动态分区调整功能，极易引起硬盘数据的意外丢失。
3、对于60G以上的大硬盘，WIN98的FDISK是无法识别的（不信可以试一试），解决方法是：(1)如果是老主板应首先升级BIOS；(2)使用WINME的FDISK和FORMAT，可以支持60G以上的大硬盘。

本文发表于2002年《电脑爱好者》第17期


清除CMOS密码--DOS命令应用实例（四）

问题：
CMOS密码忘记了怎么办？
定性：
破解的方法有很多，如万能密码破解工具，CMOS放电等，都可以达到目的，但是如果你遇到：万能法对个别主板不管用，破解软件一时找不到，放电又太麻烦的时候，debug 命令反而更好用。
分析:
1.在DOS实模式或窗口中运行DUBUG都可以
2.原理是：利用o语句输入端口把垃圾字节10H覆盖原有CMOS数据，致使CMOS读取错误而自动重置成没有密码的初始状态，而达到破解目的。
解决:
1.打开MS-DOS窗口
2.如下图所示输入就可以了：

本文发表于2002年《电脑爱好者》第18期


一劳永逸--批处理命令（一）

一、基本概念：

顾名思义，所谓“批处理”就是“成批处理”，指用一个命令执行多个命令，其中的一个命令就是指批处理文件扩展名为bat的文件，最常见的批处理文件就是Autoexec.bat，电脑启动时会自动查找这个批处理命令，如果找到就会自动运行；多个命令是指普通的DOS命令或程序如copy（复制），md（创建一个文件夹），del（删除文件）等，另外也可以指批处理专用的命令，我们称之为批处理命令，如if（如果）for（条件）goto（转到）等。

二、如何制作批处理命令？

这是初学者经常提到的问题，下面以一个Windows98的Autoexec.bat为例，讲述如何制作一个批处理文件，为了使原来的C:\Autoexec.bat不受影响，请事先将该文件备。
（一）DOS下的制作方法:
在DOS下制作批处理需要使用纯文本编辑命令:Edit.exe。下面是详细的制作步骤:
1 进入DOS
2 输入edit c:\autoexec.bat回车，出现一个蓝色界面，输入以下内容，如图：

@echo off echo off表示不显示以下命令行，@表示不显示本行path=c:\windows;c:\windows\command 设置Windows 自身安装的DOS 外部命令存放位置，以便于直接使用外部命令。
set temp=c:\windows\temp 设置Windows临时文件存放位置
c:\windows\command\mscdex /d:mscd000 让DOS能识别光驱
lh doskey 把命令存储命令放入高端内存，在DOS状态下Doskey命令可以让你使用上下光标键翻阅选择原来输入过的命令，就如同Windows浏览器里面的历史记录一样。
cls 清除屏幕显示

3 按Alt+F组合键激活文件菜单，选Exit，回车，出现一个对话框按Y键或者直接回车即可保存退出

（二）Windows下的制作方法: 使用记事本编辑步骤是:
1 点击开始--程序--附件--记事本
2 输入如图里面所表示的内容

3 用鼠标单击文件下拉菜单选择“退出”，单击“保存”，如图2，至此完成制作，大功告成。 好了一个批处理文件就这样制作，完成了是不是很简单。

本文发表于2002年《电脑爱好者》第19期


让CIH永不发作--批处理命令（二）

小知识：

1998年的4月26日，是CIH病毒的生日，这个病毒首先在台湾被发现，是由24岁的陈盈豪Chen Ing-Halu编制的，由于其名字第一个字母分别为C、I、H，因此这可能是计算机病毒名称的由来。
如同潘多拉的盒子被打开，从此，这个病毒象幽灵一样在网络中游荡，一年后的4月26日，中国的30余万台电脑的用户经历了一个令人心悸的梦魇：当从初春的风中走入办公室打开电脑的时候，屏幕却没有任何显示，只有死一般的沉寂，单是可以统计的经济损失就可以以亿为单位计算，从此中国电脑用户明白了：病毒很厉害，病毒在身边。
破坏性：CIH是迄今为止发现的最阴险的病毒之一属恶性病，毒当其发作条件成熟时可从硬盘主引导区开始依次往硬盘中写入垃圾数据，直到硬盘数据被全部破坏为止，最坏的情况下硬盘所有数据(含全部逻辑盘数据)均被破坏。另外，某些主板上的Flash Rom中的BIOS信息将被清除。
CIH有3个版本，1.2版（最流行）4月26日发作，1.3版6月26日发作，1.4版每月26日发作（最厉害）。另外，最近又有一个CIH的变种每年的12月25日发作，俗称“圣诞CIH”，据说比CIH的更隐蔽，破坏性更强。

解决方案：

虽然预防CIH 的软件很多，如各大杀毒软件的实时监测功能，但难免有疏漏之时。
原理：
根据病毒的两个弱点进行编程：
1，只在特定日期发作
2，只在进入Windows之后发作
因此我们可以在Autoexec.bat中设置一段小程序，在进入Windows之前提醒用户更改日期。 详细步骤：
（一）用记事本打开或新建Autoexec.bat，输入以下内容:
rem *****CIH&25CIH***** 此行为注释不被执行
type nul>c:\today.is 建立一个0 字节空的临时文件todoy.is
cls 清除屏幕显示
dir c:\today.is|find "-26-" 查找开机时间是否为26日
if not errorlevel 1 goto CIH 如果没有错误是26日就执行
:CIH 子程序
goto noCIH 否则不是26日则转到:noCIH子程序
:CIH :是子程序的标志，CIH是子程序名称
echo Today is CIH day!Please change clock to 27th in the CMOS! 是26日就在屏幕上显示英文“今天是CIH 日请在CMOS中更改日期为27日”
pause 暂停程序运行，并显示英文“Press any key countinue”（按任意键继续）
del c:\today.is>nul 删除today.is（nul为不显示删除过程中的提示）
restart.com 执行restart.com，此文件可以到Win98启动盘中的Ebd.cab 中提取，提取后把它放到C:\下面
:noCIH 不是26日时执行该子程序.以下预防圣诞CIH的方法与上面的类似不再说明
cls
dir c:\today.is|find "12-25-"
if not errorlevel 1 goto 25vir
goto novir
:25vir
echo Today is CIH day!Please change clock to 27th in the CMOS!
pause
del c:\today.is>nul
restart.com
:novir
del c:\today.is>nul
rem *****CIH&25CIH*****
cls
使用:
当你在每月的26日或12月25日打开电脑时，屏幕就会出现英文提示“Today is CIH day!Please change clock to 27th in the CMOS!”如图:

按任意键将重启电脑，然后按Delete键进入CMOS，将日期更改为为27日即可，不要忘了到第二天再将日期改回正常日期哦。

本文发表于2002年《电脑爱好者》第20期


巧设开机密码等--批处理命令（三）

一、巧设开机密码

背景:
不想让别人打开或进入自己的电脑方法有很多方法，但用得多了破解也变得容易了（破解文章的作用），本例也有破解方法，但旨在提供思路，可能会有出奇制胜的效果
原理：
障眼法，利用Choice命令等待输入一个字符，Echo命令显示错误信息达到加密目的。
编程:
用记事本打开或EDIT新建Autoexec.bat，输入以下内容:
@echo off
echo non-system disk or disk error
choice /c:#/n
使用:
开机时显示non-system disk or disk error，造成“死机”的假象，别人看了会吓一跳，如果是你自己开的机，可以从容地输入#（相当于开机密码，也可以换成其它字符），即可让电脑继续运行直至进入桌面。

二、吓退非法来客

背景：
如果认为上面例子的威力不够，可以用这个程序试试。
原理:用Echo命令显示每行80个_（80个下划线），再用Goto命令设置一个死循环程序，以达到屏幕花屏的效果（是不是更唬人呢？）
编程:
打开记事本新建C:\Windows\Winstart.bat，输入以下内容:
@echo off
abc echo _ _是英文下划线，为了节省篇幅，这里只输入1个，在实际中请输入80个_才能达到效果
goto abc
使用:
当别人打开你的电脑时会以为显示器坏了或有病毒了，以达到吓退非法来客的目的，如果是你开机，暂时中止的方法:按Ctrl+Break组合键，再按Y键。彻底解除的方法：开机按F8进入DOS，把C:\Windows\Winstart.bat文件删除即可恢复。
注意:禁止用于吓唬胆小的女生:)

三、屏蔽危险命令

背景：
近来网页病毒十分猖獗，只要浏览就会发作，轻则删除文件，重则格式化硬盘，无所不为，其实其作案工具非常简陋，就是DOS命令中的Deltree和Format，以前一般采用删除这两个命令或用超级兔子魔法设置屏蔽，这两种方法都有缺点。其实编个批处理文件就可以完全解决。
原理：
Ren（改名命令）与3个自动批处理文件Autoexec.bat，Winstart.bat，Dosstart.bat巧妙配合编程:
1 在Winstart.bat中加入两行内容:
ren c:\windows\command\deltree.exe deltree.ex_
ren c:\windows\command\format.com format.co_
2 分别在Autoexec.bat和Dosstart.bat也加入两行内容:
ren c:\windows\command\ deltree.ex_ deltree.exe
ren c:\windows\command\ format.co_ format.com
使用:
在Windows下无法使用这两个命令，以达到预防网页病毒的目的，但是在DOS实模式下可以正常使用。

本文小提示：
Autoexec.bat：开机后自动运行的批处理文件
Winstart.bat：选择进入Windows时会运行的批处理文件
Dosstart.bat：在Windows中选择关机重新启动计算机到MS-DOS方式后运行的批处理文件
以上3个文件的共同点是：都叫自动批处理文件；不同点是：执行的时间段不同

本文发表于2002年《电脑爱好者》第21期


DOS经典软件

在连载中的第一期我们就说过DOS最具魅力的地方是系统维护，而在系统维护软件里又以磁盘工具软件最为经典。

软盘工具HD-COPY

简介:
HD-COPY的功能太多了：软盘对拷，扩充容量，恢复数据，解压IMG文件，清洁软盘，可以说：软盘之事几乎无所不能，版本有多种，建议使用2.0a汉化版，下面介绍其中的两个重要功能：

1.恢复数据
软盘被划伤,重要数据件无法打开,也无法复制到硬盘上,怎么办？只要有HD-COPY和一张好软盘，一般可以解决，当然要看划伤程度了。

恢复的步骤是: 在DOS下运行天汇TWay3.2，再运行HD-COPY，即会出现主界面，把坏软盘放到软驱内直接回车（执行“读取”），软驱慢慢读起来，经过重复读取，显示字符R的表示好扇区，显示字符E表示该扇区已坏，但坏扇区并不影响好扇区的备份这也正是文件可以恢复的关键所在。弹出坏软盘，换上好软盘（事先去掉写保护），将光标下移到“写入”处，回车按Y键确认，最后在我的电脑里打开软盘，看看能不能打开文件或复制文件了？祝你好运。

2.扩充容量
可将1.44MB软盘扩充到1.764MB大小。

步骤是:在DOS下运行天汇TWay3.2，再运行HD-COPY，即会出现主界面，插入软盘，选择格式化目标盘，回车，如图，选择“磁道数80-84”后，按4次回车，默认的80磁道就会变成了84磁道，选择最后选择最后一行的 1.764MB，回车按Y确认，开始格式化。等待格式化完毕按两次Esc键，再按Y键确认，即可退出HD-COPY。

磁盘医生NDD

 简介：
Ndd.exe，是Norton Utilities 2002急救盘中的一个DOS工具，主要功能:修复硬盘引导记录MBR，主系统分区引导记录MPBR，文件分配表FAT等，支持FAT32和长文件名。
操作:
硬盘不能启动了怎么办？用本软件试试。步骤是:
把Ndd.exe复制到Windows98启动盘里，用该盘启机，如果软盘放不下可以删除一些无用文件，输入ndd c:后回车显示主菜单，默认选择第一项（按回车键即可自动修复），在自动修复过程中可能会出现提示，一般情况请选其中的Skip Undo即可，修复完成后拿出软盘重启，看看电脑是不是能启动了？如图：

擦除信息Wipeinfo

简介:
Wipeinfo.exe，是NU8.0中文版里一个DOS工具，主要功能是:清零磁盘。
操作：
文件经常丢失，用DOS命令Scandisk /all测出硬盘有坏扇区（标有字符B的扇区），怎么办？首先要考虑可能是逻辑坏扇区（用本软件解决），如果不能解决再用低格软件Lformat（不建议首选，因为会影响硬盘的使用寿命），Wipeinfo的使用步骤是:
把Wipeinfo.exe和China16.fnt两个文件复制到Win98启动盘里，用该盘启动，输入wipeinfo回车，出现主菜单，选择驱动器，回车，选择硬盘，回车，即可清除。如图：

低格硬盘Lformat
（见“低格分区高格”中的低格部分）

本文发表于2002年《电脑爱好者》第22期


DOS经典游戏

清纯、简洁、明快、激情，这就是DOS游戏，它伴随了几代人的成长。

美少女梦工厂Ⅱ

 简介：
养成类，繁体中文界面，女生男生都喜欢玩的游戏。如图：

情节是：
在一个被魔鬼控制的王国，你（小女孩的父亲）担负起了培养一个有希望拯救王国的小女孩的重任，游戏从小女孩10岁开始你每月安排她的活动，有上课学习，打工挣钱，武者修行，休息和其他社会活动，总之，按你的意图使之成长，日子一天天如此过去，直到小女孩长到18岁，这时电脑会根据你的实际操作显示结局，大概有70多种不同结局，如:结婚，当兵，当老师等等，所以游戏很具有耐玩性。
操作:
在DOS实模式下进入游戏所在目录输入play回车，进入游戏后点击确定，出现“重新开始”和“时光倒转”两个选项，点击一个即可进入。常用控制键: X取消，F3键加速游戏，F1键或Ctrl+Alt+Del是返回到DOS。
攻略:
1.要想多赚钱就要多安排“武者修行”（冒险），因为打败怪物可以赚钱，有时运气好的话还能捡到钱，提醒一句:遇到怪物时可有不同选项，如果自已的MP值不多最好不要打，当然打败了也不要紧还有管家救驾呢
2.每年举行一次收获节，如果你的女儿有一技之长就可以参加，有比武大赛，烹饪大赛，舞蹈大赛等，如果获得名次还可得到高额奖金或奖品，但得到的奖品千万不要卖掉啊，否则会被警方抓走的噢。
秘笈:
1.只要同时按Q+R+N+F12后再同时放开，然后再按住F10并单击“上街图标”即可进入“神秘商店”和“职业介绍”，前者可以让你的金钱无限，后者可以观看各种结局等
2.在Pm2.cnf中加入CAMERA=1，只按一次F5就会存储当前进度至全部8个档案位置中。

三国志Ⅱ

简介:
格斗类（有个与它同名的是策略类的），日文界面，又叫“吞噬天地之赤壁之战”，九十年代大型游戏厅里随处可见，可同时支持4人共同作战。如图:

操作:
进入游戏所在目录输入play开始游戏，如果只是你一个人玩，就按F1和F3开始，如果两个人玩，另外一个人按F2和F4开始，默认的控制键是：Ctrl拳或武器，Alt跳，当然你可以自定义控制键（空格--鼠标选择Input--Keboard）
秘笈:
大招必杀技（适用于关羽）:按住Ctrl键不放再按一下Alt是“旋风拳”，前后都有敌人时使用最佳。另外，按住Alt键不放再按一下Ctrl，是“组合拳”，只在一个方向有敌人时使用最佳。
坦克大战

简介:
射击类，英文界面，家庭游戏机任天堂红白机之经典，在九十年代初风靡一时，基本玩法是:两个坦克保卫自己的总部，可以吃许多加强的武器，可以自己画地图。如图：

操作:输入play后按回车，再按回车，用下方向键找到Tank.nes文件按回车键即可进入游戏，Insert键选择，Home键开始/暂停，F4键全屏/窗口，F6键从头开始，F8退出游戏，Delete/End选局，End开炮

毁灭战士

简介:
迷宫类（第一人称射击类，CS的祖宗）英文界面，俗称DOOM与后来的DOOM2相比有更完整的故事性和更适当的难度，可说是经典中的经典。如图：

操作:
进入游戏所在目录，输入play开始游戏，进入游戏后再按4次回车就可以玩了，常用键:Ctrl开火，空格开门，数字键换武器，F1帮助，F2存盘，F3载入，F4调整音量，F5低/高分辩切换，F10退出游戏，F11调整亮度，加减号增大/缩小窗口。
秘笈:在游戏进行时输入iddqd无敌，idkfa全武器，idspispopd穿墙

本文发表于2002年《电脑爱好者》第23期