《高手之路,DOS起步》
制作：老树　　 　　欢迎光临！！


DOS使用常识

__________laoshu.8ok.net_____________________ ______

DOS使用常识

DOS的概况
DOS（Disk Operating System）是一个使用得十分广泛的磁盘操作系统，就连眼下流行的Windows9x/ME系统都是以它为基础。

常见的DOS有两种：IBM公司的PC-DOS和微软公司的MS-DOS，它们的功能、命令用途格式都相同，我们常用的是MS-DOS。

自从DOS在1981年问世以来，版本就不断更新，从最初的DOS1.0升级到了最新的DOS8.0（Windows ME系统），纯DOS 的最高版本为DOS6.22，这以后的新版本DOS都是由Windows系统所提供的，并不单独存在。下面的讲解所使用的DOS为Windows98 4.10.2222A的DOS7.0系统。

DOS的基础知识

1）DOS的组成
DOS分为核心启动程序和命令程序两个部分。

DOS的核心启动程序有Boot系统引导程序、IO.SYS、MSDOS.SYS和COMMAND.COM。它们是构成DOS系统最基础的几个部分，有了它们系统就可以启动。

但光有启动程序还不行，DOS作为一个字符型的操作系统，一般的操作都是通过命令来完成。DOS命令分为内部命令和外部命令。内部命令是一些常用而所占空间不大的命令程序，如dir、cd等，它们存在于COMMAND.COM文件中，会在系统启动时加载到内存中，以方便调用。而其它的一些外部命令则以单独的可执行文件存在，在使用时才被调入内存。
（小知识：可执行的程序文件有*.COM和*.EXE两种，一般来讲，*.EXE文件为软件执行程序，而*.COM文件则为命令程序）

2）DOS的启动
如果你安装了WIN98，在电脑启动时按住Ctrl不放，出现启动选择菜单，选择5"Command Prompt Only"即可进入DOS方式。

目前我们常用的操作系统有windows 9x/Me,NT,2000等，都是可视化的界面。在这些系统之前的人们使用的操作系统是DOS系统。DOS系统目前已经没有什么人使用了，但是dos命令却依然存在于我们使用的windows系统之中。大部分的DOS命令都已经在Windows里变成了可视化的界面，但是有一些高级的DOS命令还是要在DOS环境下来执行。所以学习命令行对于我们熟练操作Windows系统是很有必要的。

不同的操作系统要用不同的命令进入命令行界面。
在Win9x/Me的开始菜单中的运行程序中键入"command"命令，可进入命令行界面。
在Win2000/NT的开始菜单中的运行程序中键�"cmd"命令，可进入命令行界面。
下面我用讲到的DOS命令都可以在Windows Me操作系统中执行。

那么，我们如何进入命令行窗口？
开始——〉运行——〉键入command命令——〉回车
进入了命令行操作界面（DOS窗口），在DOS窗口中只能用键盘来操作。

在DOS中通过输入英文命令加回车键这种方式来执行程序。

3）DOS的系统提示符
DOS启动后，会显示"C:>"以及一个闪动的光标，这及是DOS的系统提示符，它表示了当前所在的盘符和目录，我们可以输入"[盘符] :"来进行转换，如"A:"、"E:"。这里要注意输入的盘符一定要是存在的。
（小知识：盘符从A到Z，通常A、B盘为软驱，硬盘的盘符从C开始，而光驱的盘符为最后一个）

4）文件及目录
电脑中的数据主要都是以文件形式存储的，也可以说DOS以文件的形式来管理数据。
文件是相关数据的集合，若干数据聚集在一起组成一个文件。每个文件都有文件名，文件名由主文件名和后缀名两部分组成，中间有小圆点隔开。DOS6.22及其以前版本最多仅支持8个字符的主文件名和3个字符的后缀名，而从Windows 95的DOS7.0开始就可支持128个字符的主文件名和后缀名。字母、汉字、数字和一些特殊符号如"!、@、#"都可以作为文件名，但不能有"/、\、|、:、?"等符号。

通常我们可以通过文件的后缀名看出该文件的类型，比如：

后缀名 | 文件类型
EXE | 可执行程序文件
COM | 可执行命令文件
BAT | 可执行批处理文件
TXT | 文本文件
DAT | 数据文件
BAK | 备份文件

为了方便用户进行操作，DOS还允许使用通配符。所谓通配符，就是"？"与"*"这两个符号，它们可以用来代替文件名中的某些字符。"？"代表一个合法的字符或空字符，比如"AB?D.EXE"文件就可以表示"ABCD.EXE"、"ABDD.EXE"、"ABZD.EXE"等。

而"*"则代表若干个字符，如"*.BAT"就代表当前目录下所有后缀名为"BAT"的文件。
DOS以目录树的形式管理磁盘，这里的目录就相当于Windows中的文件夹。和文件夹一样，目录也是一层一层的，构成一个树的形式。在一个盘符中最底层的目录为根目录，根目录下的目录都称为它的子目录，根目录用"\"表示，一个目录的上一层目录用".."表示。我们可以通过路径来查找某一个文件或目录，路径就如同地址一样，可以使用户方便、准确地进行查找。比如"C:\Windows\Command\deltree.exe"就是一个文件的路径。

在同一个目录下，不允许存在相同名称的文件或目录。


DOS的内部命令

DOS的内部命令

DOS的内部命令是进行操作的基础，完成了对它们的学习你就跨进了DOS系统的大门。

1）DIR--显示指定路径上所有文件或目录的信息
它的格式为"DIR [盘符：][路径][文件名] [参数]"，比如"DIR E:\FF.M3U"。输入后回车则会显示出相关信息（如图1）。另外它还有几个参数：

/W：宽屏显示，一排显示5个文件名，而不会显示修改时间，文件大小等信息；
/P：分页显示，当屏幕无法将信息完成显示时，可使用其进行分页显示；
/A：显示具有特殊属性的文件，这里的属性有"H"隐藏、"R"只读等，我们可以输入"DIR *.* /AH"来显示当前目录下所有具有隐藏属性的文件；
/S：显示当前目录及其子目录下所有的文件，通过这个参数，我们可以进行某个文件或目录的查找，比如我们可以在"C:>"后输入"DIR *.DAT /S"来查找C盘中所有后缀名为DAT的文件。

几种参数可以同时使用，例如"DIR *.COM /W /P /S"。

图1

2）MD--建立目录
它的格式为"MD [盘符][路径]"，例如"MD TEMP"。
注意：该命令一次只能建立一个目录。

3）RD--删除目录
格式为"RD [盘符][路径]"。
注意：该命令只能删除空目录，并且不能删除当前目录。

4）CD--进入指定目录
格式为" CD [路径]"，例如"CD HAPPY"。
注意：只能进入当前盘符中的目录。其中"CD\"为回到根目录，"CD.."为回到上一层目录。

5）COPY--拷贝文件
格式为"COPY [源目录或文件] [目的目录或文件]"，比如"COPY C:\*.COM D:\"，我们也可以输入"COPY C:\Command.COM D:\Command.BAK"来进行文件拷贝并改名。
注意：使用该命令进行文件拷贝时，目的目录一定要存在。

6）DEL--删除文件
格式为"DEL [盘符][路径][文件名] [参数]"，比如"DEL C:\DATA\*.BAK"。它有一个参数："/P"，可以使用户在删除多个文件时对每个文件都显示删除询问（如图2）。

图2

7）REN--改名
格式为"REN [原名] [现名]"，7.0以后版本的DOS都支持对文件名和目录名的修改，而以前的DOS只能修改文件名。

8）TYPE--显示文本文件
格式为"TYPE [文件名]"，能对文本文件进行查看。

9）discopy--磁盘复制

[功能] 复制出一个和原来磁盘内容一模一样的磁盘

[格式] diskcopy　源驱动器名　目的驱动器名

[说明] 它的主要用途就是用来备份。比如我们的电脑在刚买来时，会随机附带一些设备驱动程序磁盘，这些驱动程序在以后都有可能用到，为防止这些磁盘的损坏，一定要将它们都备份一套，这时，使用diskcopy命令是比较快捷和方便的。

10) deltree--删除目录树

[格式] [C:][path]DELTREE [C1:][path1] [[C2:][path2] […]]

[说明] 这个命令将整个指定目录树全部消灭，而不管它是否是只读、隐藏与否。使用应特别小心。它是一个危险命令。

11) mem--查看你的计算机内存有多少，以及内存的使用情况。

[格式] 直接键入mem命令

12) chkdsk--检查你的磁盘的使用情况。

[格式] chkdsk　磁盘名

[说明] 例如要检查A盘使用情况，就输入chkdsk　A: ，检查c盘使用情况，就输入chkdsk　C: ，如果直接输入chkdsk，就检查当前磁盘的使用情况。

13) sys--传递系统文件命令。将DOS的两个隐含的系统IO.SYS和MSDOS.SYS传送到目标磁盘的特定位置上，并将COMMAND.COM文件复制过去。完成后，目标盘成为DOS的启动盘。

[格式] [C:][path]SYS [C1:][path] d2:

[说明] 由于这几个文件需要复制到特定位置上，所以用COPY命令完成的复制未必能够启动机器。能过SYS命令，DOS可以将目标盘已占据特定位置的文件移动，并将系统文件复制到相应位置上。参数C1:path用来指明系统文件所在目录。如不指明，则缺省为当前盘的当前目录。所以这个命令一般要在源盘的根目录进行。

14) pass--设定DOS寻找.COM、.EXE、.BAT文件的所在目录

[格式] path=[[drive:]path[;…]]或path

[说明] 只打path没有参数时，只显示环境变量内容。有参数时，重新设置path变量。在没有指定path环境变量时，用户发出的命令，DOS首先判断其是否为内部命令，再查找当前目录中是否有主文件名是该命令的可执行文件，如果均不是，则显示信息“Bad command or filename”。如果发出了指定路径的命令，则在指定径中依次查找，仍找不到则出现上述提示。

15) cls--清除显示器屏幕上的内容，使DOS提示符到屏幕左上角。

[格式] cls

16) time--显示和设置DOS的系统时间

[格式] time [hh[:mm[:ss[.cc]]]

17) date--显示和设置DOS的系统日期

[格式] date [MM-DD-YY]

18) ver--显示正在运行的DOS系统版本号

[格式] ver


DOS的外部命令

DOS的外部命令

DOS的外部命令就是一些应用程序，能够使用户的操作更加方便和深入。这些外部命令都是以文件的形式存在，Windows系统的DOS外部命令保存在Windwos主目录下的"Command"目录中。下面就让我们来看看常用的一些DOS外部命令。

1）FORMAT（Format.COM）--格式化命令
众所周知，新买的磁盘都必须经过格式化后方能使用，FORMAT命令可以完成对软盘和硬盘的格式化操作，格式为"FORMAT [盘符] [参数]"，例如："FORMAT A: /S"。它有两个常见的参数：

/Q：进行快速格式化；
/S：完成格式化，并将系统引导文件拷贝到该磁盘。

注意：该命令会清除目的磁盘上的所有数据，一定要小心使用。如果进行了普通的格式化，那磁盘上的数据还有可能恢复，但如果加上了"/Q"，那要恢复就比蹬天还难了。

2）EDIT（Edit.COM）--编辑命令
其实它就是一个文本编辑软件（如图3），使用它可以在DOS下方便地对文本文件进行编辑，格式为"EDIT [文件名] [参数]"，它的参数不是特别实用，我在此就不多讲。

图3

3）SYS（Sys.COM）--系统引导文件传输命令
它能够将IO.SYS等几个文件传输到目的磁盘，使其可以引导、启动。格式为"SYS [盘符]"

4）ATTRIB（Attrib.EXE）--文件属性设置命令
通过该命令，我们可以对文件进行属性的查看和更改。格式为"ATTRIB [路径][文件名] [参数]"，如果不加参数则为显示文件属性。它的参数有"+？"和"-？"两种，"？"代表属性代号，这些代号有："H"隐藏；"S"系统；"R"只读，"+"表示赋予，"-"表示去除。

5）XCOPY（Xcopy.EXE）--拷贝命令
该命令在"COPY"的基础上进行了加强，能够对多个子目录进行拷贝。它的参数比较多，但是最常用的是"/S"，它可以对一个目录下属的多个子目录进行拷贝，另外"/E"可以拷贝空目录。格式为"XCOPY [源路径][源目录/文件名] [目的目录/文件名] [参数]"。

6）SCANDISK（Scandisk.EXE）--磁盘扫描程序
这个命令在实际的操作中有很大的用处，它能对磁盘进行扫描并修复，能够解决大部分的磁盘文件损坏问题。格式为"SCANDISK [盘符：] [参数]"下面是它的几个参数：

/fragment ［驱动器名:\路径\文件名］：使用这个参数可以显示文件是否包含有间断的块，我们可以通过运行磁盘整理程序来解决这个问题；
/all：检查并修复所有的本地驱动器；
/autofix：自动修复错误，即在修复时不会出现提示；
/checkonly：仅仅检查磁盘，并不修复错误；
/custom：根据Scandisk.ini文件的内容来运行Scandisk，Scandisk.ini是一个文本文件，它包含了对Scandisk程序的设置，其中的［custom］块是在加上"/custom"参数后才执行的，用户可以根据自己的不同情况来进行不同的设置；
/nosave：在检查出有丢失簇后直接删除，并不转化为文件；
/nosummary：不显示检查概要，完成检查后将直接退出程序；
/surface：在完成初步检查后进行磁盘表面扫描；
/mono：以单色形式运行Scandisk。

我们可以根据不同的情况来加上不同的参数。我们可以执行"scandisk /all /checkonly /nosave /nosummary"来完成对磁盘的检查并且自动退出，另外还可以编辑scandisk.ini文件中设置，再运行"scandisk /custom"。如果被损坏的文件比较多，我们可以使用"/autofix"来进行自动修复，不然会忙死你的。

7）CHKDSK（Chkdsk.EXE）--磁盘检查命令
它会检查磁盘，并会显示一个磁盘状态报告。格式为"CHKDSK [盘符：] [参数]"，最常用的参数是"/F"，可以对文件错误进行修复。

8）MOVE（Move.EXE）--文件移动命令
使用它可以对文件进行移动。格式为"MOVE [源文件] [目的路径]"。同时也可以使用通配符。

9）DELTREE（Deltree.EXE）--删除命令
这可是DEL命令的超级加强版，它不仅可以删除文件，并且会将指定目录和其下的所有文件和子目录一并删掉。使用它，我们可以很方便的对目录进行彻底的删除。格式"DELTREE [文件/路径] [参数]"，参数有一个"/Y"，使用时系统会对每个文件进行询问，回答"Y"后才删除。

10）FDISK（Fdisk.EXE）--分区命令
我们可以使用它对硬盘进行分区操作，我在下一部分会进行具体讲解。

以上就是常用的一些DOS外部命令，使用它们可以使你的操作更方便，同时也是进行系统修复所必不可少的。请大家好好地掌握每一个命令及其用处。

更多的DOS命令

命令 | 功能 | 命令 | 功能
ctty | 改变控制设备 | attrib | 设置文件属性
emm386 | 扩展内存管理 | defrag | 磁盘碎片整理
fdisk | 硬盘分区 | doskey | 调用和建立DOS宏命令
lh/loadhigh | 将程序装入高端内存 | debug | 程序调试命令
move | 移动文件，改目录名 | fc | 文件比较
prompt | 设置提示符 | more | 分屏显示
smartdrv | 设置磁盘加速器 | set | 设置环境变量
subst | 路径替换 | setver | 设置版本
xcopy | 拷贝目录和文件 | vol | 显示指定的磁盘卷标号
大家如果感兴趣的话，不妨自己在DOS窗口中打打这些命令试试看。:)


FDISK使用介绍

FDISK使用介绍

对硬盘进行分区、格式化，是每个硬盘都必须经过的步骤。在这里我就来具体讲解一下怎样使用FDISK进行硬盘分区。

FDISK程序是DOS和Windows系统自带的分区软件，虽然其功能比不上有些软件，但用它分区是十分安全的。一下就是具体的操作步骤：

1）进入DOS方式。在系统引导、出现"Starting Windows....."的时候按下"F8"键，然后再选择"Command Prompt Only"即可进入DOS方式。

2）键入"FDISK"后回车即可进入。

3）这时软件会问你是否支持FAT32，回答"Y"就可以建立FAT32分区，回答"N"则会使用FAT16，决定以后按回车。

4）出现FDISK的主菜单，要建立分区请选择"1"再回车。

5）建立主分区（Primary Partition)，选择"1"后回车。

6）这时系统会询问你是否使用最大的可用空间作为主分区，如果回答"Y"，那么软件就会将所有的磁盘空间划分成一个分区，回答"N"则可以划分多个分区，对于现在的硬盘来说，一般都比较大，如果划分成一个分区就不太好管理，因此可以选择输入"N"来分成多个分区。

7）软件会提示你输入主分区的大小，输入后回车。

8）完成后按ESC键回到主菜单。

9）对于一个硬盘，必须设置一个活动分区后才可以引导操作系统，所以我们需要进入"2"项。

10）这是会提示用户输入活动分区的号码，由于只有一个分区，就输入"1"。 完后会在状态栏中显示一个"A"，表示此分区为活动分区。

11）一个硬盘只能有一个主分区，因此如果现在要划分剩下的硬盘空间就必须建立扩展分区，回到主菜单后选择"2"。

12）程序会提示用户输入扩展分区的大小。

13）扩展分区建立完成后，会显示主分区和扩展分区的相关资料，按ESC键。

14）这时会提示没有逻辑盘的信息，你可以将整个扩展分区划分成一个逻辑盘，或者分成几个逻辑盘。现在可以输入第一个逻辑盘的大小，然后回车。

15）这时会显示第一个逻辑盘的相关信息，并且要求你输入第2个逻辑盘的大小。

16）完成后即可按ESC键退回到主菜单。

17）这时在按ESC退出FDISK再重新启动，就可以对分区进行格式化了。

如果是对已经分好区的硬盘进行重新分区，那么在主菜单时就必须先进入第三项将分区删除后才能进行。


用FDISK进行硬盘分区

用FDISK进行硬盘分区

分区从实质上说就是对硬盘的一种格式化。当我们创建分区时，就已经设置好了硬盘的各项物理参数，指定了硬盘主引导记录(即MasterBootRecord，一般简称为MBR)和引导记录备份的存放位置。而对于文件系统以及其他操作系统管理硬盘所需要的信息则是通过之后的高级格式化，即Format命令来实现。用一个形象的比喻，分区就好比在一张白纸上画一个大方框。而格式化好比在方框里打上格子。安装各种软件就好比在格子里写上字。（见图8）可以看得出来，分区和格式化就相当于为安装软件打基础，实际上它们为电脑在硬盘上存储数据起到标记定位的作用。进行硬盘分区，我们最常用的软件是FDISK.com。下面，我们就FDISK的一些功能和使用做一番比较详尽地介绍：

图8 点击看大图

图9 点击看大图

图10 点击看大图

我们以Win 95为例（Win 98和95大致上基本一致），用启动盘启动计算机，在A盘根目录下输入"Format"；屏幕上出现信息问你是否要启用FAT32支持（见图9），回答"Y"会建立FAT32分区，回答"N"则会使用FAT16,决定以后按Enter键。大家要记住一点，早期的WIN95及DOS并不能识别FAT32结构。如果你想要安装此类系统的话，还是选择FAT16为好。但选择FAT16后，每个分区不能大于2GB。在这里，我们选择FAT16。

这时候，屏幕上将会显示以下4个选项（如图10所示）
1. 建立DOS分区或逻辑分区
2. 设置活动分区
3. 删除分区或逻辑分区
4. 显示分区信息
5. 如果你安装有不止一块硬盘，系统还会出现有第5项（Change current fixed disk drive）。

图11 点击看大图

图12 点击看大图

图13 点击看大图

建立主分区
这里，缺省的选项是"1"。如果你的硬盘还没有建立过分区的话，直接按ENTER键即可。然后，在图11所示对话框中选择"建立主分区（Primary Partition）"，选择"1"再按下Enter键。这时，系统会询问你是否使用最大的可用空间作为主分区，缺省的回答是"Y"，你只要直接按下Enter键即可。当然，当程序问你是否要使用最大的可用空间作为主分区时，你也可以回答"N"然后按Enter键。这时，系统会要求你输入主分区的大小，输入以后按Enter键。这时，系统将会自动为主分区分配逻辑盘符"C"。然后屏幕将提示主分区已建立并显示主分区容量和所占硬盘全部容量的比例，此后按"Esc"返回FDISK主菜单。

建立扩展分区
在FDISK主菜单中继续选择"1"进入 "建立分区菜单" 后再选择"2"建立扩展分区，屏幕将提示当前硬盘可建为扩展分区的全部容量。此时我们如果不需要为其它操作系统（如NT、LINUX等）预留分区，那么建议使用系统给出的全部硬盘空间，此时可以直接回车建立扩展分区，然后屏幕将显示已经建立的扩展分区容量。

设置逻辑盘数量和容量
扩展分区建立后，系统提示用户还没有建立逻辑驱动器，此时按"Esc"键开始设置逻辑盘，提示用户可以建为逻辑盘的全部硬盘空间，用户可以根据硬盘容量和自己的需要来设定逻辑盘数量和各逻辑盘容量。设置完成后，此时屏幕将会显示用户所建立的逻辑盘数量和容量，然后返回FDISK主菜单。

图14 点击看大图

图15 点击看大图

图16 点击看大图

激活硬盘主分区
在硬盘上同时建有主分区和扩展分区时，必须进行主分区激活，否则以后硬盘无法引导系统。在FDISK主菜单上选择"2"（Set active partition），此时屏幕将显示主硬盘上所有分区供用户进行选择（见图12），我们的主盘上只有主分区"1"和扩展分区"2"，当然我们选择主分区"1"进行激活，然后退回FDISK主菜单。

一切结束以后，退出FDISK程序。继续按"Esc"键退出至屏幕提示用户必须重新启动系统，必须重新启动系统，然后才能继续对所建立的所有逻辑盘进行格式化（Format）操作。

图17 点击看大图

图18 点击看大图

图19 点击看大图

注意事项：在建立分区时，以下几点是值得您注意：

1.主分区和逻辑分区
主分区的特性是在任何时刻只能有一个是活动的，当一个主分区被激活以后，同一硬盘上的其他主分区就不能再被访问。所以一个主分区中的操作系统不能再访问同一物理硬盘上其他主分区上的文件。而逻辑分区并不属于某个操作系统，只要它的文件系统与启动的操作系统兼容，则该操作系统就能访问它。（如图13所示）

图20 点击看大图

图21 点击看大图

图22 点击看大图

主分区和逻辑分区的一个重要区别是：每个逻辑分区分配唯一的驱动器名（盘符），而在同一硬盘上的所有主分区共享同一个驱动器名，因为某一时刻只能有一个主分区是活动的。这就意味着某一时刻只能用共享驱动器名访问活动的那个主分区。系统支持多达24个逻辑分区，这样，可能有许多人都会有这样一个错误的认识，那就是在对硬盘进行分区时最好多创建几个逻辑分区，这样可以避免出现问题的分区影响到保存在其他分区中的数据。但是事实往往并非如此，一个被损坏的分区往往会导致整个硬盘无法正常使用。我们已经在前面提到过主分区和扩展分区的信息都是被保存在MBR中，如果由于某种原因使MBR受到破坏，硬盘主分区将无法使用，进而使包含操作系统的启动盘也无法使用。

是也许有人会认为逻辑分区的信息并不保存在MBR中，因此逻辑分区并不会受到任何影响。其实我们忽略了这样一个事实，那就是虽然逻辑分区的信息保存在扩展分区内，但是扩展分区的信息却是被保存在MBR中。这样，通过相互之间的作用，使逻辑分区最终也不能免受影响。不过一般情况下，一个分区受到损坏而其他分区仍然可以正常工作。例如，如果一个逻辑分区出现问题，很多时候其他的逻辑分区以及主分区和扩展分区都不会受到任何影响。但是话又说回来，出现问题的分区往往就是那些使用最频繁的分区，也就是MBR。

图23 点击看大图

图24 点击看大图

图25 点击看大图

2.驱动器名的分配
    启动系统时，活动分区上的操作系统将执行一个称为驱动器映像的过程，它给主分区和逻辑分区分配驱动器名。所有的主分区首先被映像，而逻辑分区用后续的字母指定。一般来说，主分区将被定义为C，然后，系统会根据逻辑分区的多少依次给出D，E。。。。直到Z。当然，如果你有不两块硬盘的话，情况又会发生一些变化。我们举例说明，我们将每块硬盘都分为两个区，第一个硬盘的第一分区为主分区（盘符C），则第二个硬盘的第一分区为D，第一个硬盘的第二分区为E，第二个硬盘的第二分区为F。

3.容量的分配
要分割成几个分区以及第一个分区所占有的容量，取决于使用者自己的想法，有些人喜欢将整个硬盘规划单一分区，有些人则认为分割成几个分区比较利于管理。例如，分割成两个分区，一个储存操作系统文件，另一个储存应用程序文件;或者一个储存操作系统和应用程序档案，另一个储存个人和备份的资料。至于分区所使用的文件系统，则取决于你要安装的操作系统。一般来说，主分区由于经常会进行数据 的交换，因此容量不宜太小。其他的分区的大小分配则完全取决于个人喜好了。

图26 点击看大图

图27 点击看大图

图28 点击看大图

分区建立完了，接下去，我们应该查看一下具体的分区内容，做到心中有数。在FDISK主界面上，按"4"，回车。 如图14所示A区显示了当前的分区情况，B区显示了硬盘的总容量，C区则进一步询问你是否要显示详细的逻辑分区情况。

我们一部分一部分的来分析。如图15所示，在分区信息中：
①第一行是当前的硬盘号，因为只有一个硬盘，所以硬盘号为1。下面几行是分区信息。
②第一栏是当前分区，有1，2两部分，分别表示基本分区和扩展分区。
③第二栏是状态。A表示是活动分区。
④第三栏是分区类型，C为PRI DOS，即基本分区，下面这个是EXT DOS 即扩展分区。
⑤第四栏是硬盘卷标，它就好像我们给每个分区起的名字。
⑥第五栏是分区的大小，用多少兆字节(Mbytes)来表示。
⑦第六栏是系统文件分配表类型，显示FAT16。
⑧最后一栏是基本和扩展分区占总容量的比例。

接下来我们再来看B区中的硬盘的容量，图16中表示"硬盘的总容量为4126M"，即通常我们所说的4.3G的硬盘。

这时候，系统会询问是否查看扩展DOS分区的信息，（见图17）选"Y"则进入下一项。

因为只有一个扩展分区，所以只有D、E盘的信息显示出来，虽然现在扩展分区分成了两个逻辑分区，但我们只能将逻辑分区叫做D、E盘，而不能称这个扩展分区为D、E盘。这里显示按ESC键继续。（如图18）

至此，分区的建立算是完成了。如果你对现行的分区不满意，你可以将分区删除后重新来。在建立分区时，我们遵循的步骤是： 建立基本分区-> 建立扩展分区à 分成一个或几个逻辑分区；而我们在删除分区时则需要遵循以下原则： 删除逻辑分区-> 删除扩展分区-> 删除基本分区

图29

分区的删除
删除逻辑分区，进入FDISK主界面（如图19所示）。选择3，回车。选择了删除分区选择后，又出现下一级子菜单，包括如下内容：（见图20）
1、删除主DOS分区。
2、删除扩展DOS分区。
3、删除扩展分区中的逻辑分区。
4、删除非DOS分区。

关于删除分区的顺序，我们在上文中已经提到过，这里就不再重复了。需要补充的是，如果你的硬盘上有非DOS的分区，则应先将它删除，再删除逻辑分区。 这里，我们直接从删除逻辑分区开始。选择"3"按下回车。下面就开始删除了！系统会用一个不断闪动的"WARNING!"提出警告，同时提示你输入要删除的逻辑分区号。输入E，再回车。（见图21）

这时候，系统提示输入E分区的卷标号（见图22），按屏幕上方的显示输入卷标。
如果没有，就直接回车跳过。系统会再提示确认，输入Y回车，E分区就被删除了。　　同样我们删除D分区，接着系统提示扩展分区中所有逻辑区均被删除。 (见图23)

删除完了逻辑分区，我们再回到主界面，删除完逻辑分区后就要删除扩展分区了，这时还要选择3； （如图24）这时进入删除界面。然后选2，"删除扩展DOS分区"。（见图25）

按提示输入"Y"，回车。扩展分区就被删除了。（如图26）删除后如图27所示。
删除完扩展分区后就要删除基本DOS分区了，按ESC返回。选第1项"删除基本DOS分区"。
（见图28）

与其他分区的操作步骤一样，还要输入卷标、输入"Y"确认后回车，基本分区就被删除了。到这里，删除分区的工作就完成了。 （见图29）

删除完成后，我们再次查看分区的情况，屏幕会显示当前硬盘还没有分区（如图30）。

图30

现在，硬盘又恢复到初始的状态下了。如果你对上次的硬盘分区不满意，现在又可以重新开始了，不过，还应该多思考思考，成熟了再动手呦：）


DOS解决问题实战

DOS解决问题实战

    看了前面的文章，相信大家对DOS的基础操作以有了一个较深的印象了吧。但光掌握以上的这些内容是远远不够的，解决电脑问题，最主要的还是能够将学到的死知识转化为自己可以熟练使用的兵器。当然，这也不是一朝一夕就可以达到的，同时也要靠经验的积累。下面就请大家随我一道来看几个实例，从中找出解决问题的关键和主要的思路。

故障事例：
某电脑在使用时突然停电，来电后开启电脑，但Windows系统无法正常启动，死机频繁。

故障分析：
从这个原因，我们可以大致推断：停电造成电脑非法关机而损伤磁盘文件，从而导致Windows系统受到损坏，无法正常运行。

大致操作：
从解决文件损坏这个角度出发，需要修复损坏的文件，如果损坏严重，也可以考虑重装Windows。

具体操作：
1、进入DOS。由于Windows受损，只有在DOS下进行操作。在系统引导、出现"Starting Windows....."的时候按下"F8"键，然后再选择"Command Prompt Only"即可进入DOS方式。为了使修复速度更快，我们可以运行Windows目录下的"SMARTDRV.EXE"程序，这是一个加速磁盘读取速度的缓存程序。

2、运行SCANDISK程序，必要时可以加上"/autofix"参数，这样在第一次选择后就可让程序自动修复。

3、运行CHKDSK程序，查看是否还存在着问题，并可以使用"/F"进行修复。

4、运行Windows，看系统是否恢复正常。如果在启动时提示注册表出错，可以重新进入DOS，在Windows目录下运行"SCANREG /RESTORE"，然后在列表中选择一个好的注册表文件就行了。

5、如果文件系统受损严重，就需要重新安装Windows。

如果无法正常进入Windows，那需要重新安装Windows的任务又只得在DOS下进行了。对于广大初学者，在DOS下安装Windows还有一定的困难，下面我就具体讲解一下在DOS下的安装。这里的安装使用光盘启动，若使用软盘启动其操作大致相同。

1、在开机进行自检时按下"DEL"键从而进入BIOS设置，在"BIOS FEATURES SETUP"的"Boot Sequence"将"CDROM"一项设置在最前面；按"ESC"键退到主画面，按"F10"键，并输入"Y"，即可存盘退出。

2、在开机前将系统启动盘放入光驱。

3、在启动后的启动菜单中选择"启动并使用光驱（With CDROM）"，大家也可以选择启动后自动运行Windows98的安装程序，但那样并不和我意，安装过程将十分漫长，所以在安装前我们需要运行"SMARTDRV.EXE"。

4、进入DOS后就转到光驱盘符，使用"DIR"命令查看目录，然后进入Windows的安装目录（目录名大都可以见名知意，一般为"Win98"、"Win"、"Windows"等）。

5、运行"SMARTDRV.EXE"。

6、运行"SETUP.EXE"，回车后会进入磁盘扫描，完成后即可进入安装，其操作就和在Windows中安装一样了。

    看完了这两个最常见的问题，你是否有所收获？主要大家将基础的东西掌握后，面对问题不慌不乱，仔细思考分析，能从其它的故障中不断总结经验，你也很快会成为一个电脑高手。另外，多帮助他人解决问题也能使你获得更多的锻炼机会，增加自己的知识面，从而可以积累更多、更好的资本。


DOS下应用程序的使用方法

DOS下应用程序的使用方法

一、arj 压缩命令的使用
    arj a a:pp c:*.dbf 普遍方法 使用arj x a:pp解压
    arj a -r -va a:pp c:*.dbf
    arj x -r -va a:pp -va参数自动测试a盘的剩余容量,
    -r参数自动压缩子目录下的文件.
    arj a -je a:pp c:*.dbf 解压时直接运行pp.exe 即可.
    -je 参数自动生成可以自动解压的文件.
    arj a -r -va -g? a:pp c:*.dbf 生成带有口令的文件
    arj x -r -va -g? a:pp 解压时需要输入正确的口令.
    arj a -r -vva a:pp c:*.dbf 更换磁盘时响铃提示.
    -jt 压缩时作效验工作,确保数据完好.
    e 解开时自动创建子目录,不需要提示
    l 显示压缩文件中包含的文件目录.
    -o:980818 98年8月18日后的所有文件全部压缩(含这天)
    -ob:980818 98年8月18日前的所有文件全部压缩(不含这天)
  各种提示符:
    Quit 中止退出
    Always 对当前的提问永远作"Yes"回答(当解开压缩时,?需要覆盖原来存在的文件时,就需要"A"回答.
    Skip 对当前的提问作一个肯定回答.
    Yes 仅对当前提问作一个肯定回答
    No 仅对当前提问作一个否定回答
    Global对当前盘作肯定回答,换盘后需要另行回答.
    Command 提示输入一个可执行dos命令.

二、chkdsk 与 compress 命令
    用chkdsk c:/f可以对C盘自动修复丢失的簇,一般对根目录产生的file???.chk等文件予以删除,在使用compress 之前先做chkdsk 命令
  compress 参数如下:
    /cu 不重新链接文件 /cf全面压缩
    /cc 全面压缩,并清除扫描剩余的簇 /cs优化剩余的空间
    /cd 优化各子目录 /nm禁止镜象工作(压缩之后)
    /video 屏显命令行 /os标准方式排序
    /of指定文件优先 /oo子目录优先
    /od子目录在文件之后 /sf按照文件名排序
    /se按照扩展名 /st按照时间排序
    /ss按照文件大小 /sa升序
    sd按照降序
    最常见的方法: compress c:/cc/sf
  注意:1)不能对win95增容处理过的硬盘压缩
      2)对于win95下的长文件名格式不支持
      3)对于一些加密软件安装时产生的文件,压缩后应重新进行安装.
    标记为"X"的为坏道,"D"为根目录 "F"为文件分配表 "B"为引导扇区

三、img工具的使用
    主要作用是在内存中开辟一块地方,?建立虚拟的软盘驱动器,并将所有对于该软驱的操作映射到该内存区域.具体操作步骤如下:
    1)启动img文件
    2)按下ctrl+alt+s+d+x即可激活该软件
    3)在filename区输入要安装的文件完整的文件名,如:c:\dos\1.img
    4)移动到drive区后可以选择"A B O"三个要建立的虚拟盘符
    5)?format区可以选择hdcopya-b以及diskdupe格式中的一个,如果不知道以前使用的格式,可以通过多次试验来取得.
    6)?移动到read区敲回车,若显示message "file c:\dos\1.img error"则是文件不存在或者是format区文件格式不对,可以重新到format 区选择.
    7)正确读入后,使用dir a(b 或o):,就可以查看虚拟盘中的文件
    8)按下Esc键退出,转到虚拟盘,允许安装程序或进行其它操作.
    9)若有多张盘需要安装,在收到须插入第二盘的提示时,重复2)的操作,重新读取数据,继续安装工作,直到完成.
  注意:
    1)?有时可能存在文件格式上的错误,导致不能读取数据,这时可先退出,重新激活img工具,换一种格式再读.
    2)输入映象文件时需要输入完整的文件名(包括路径)
    3)安装完成后,为了消除虚拟盘带来的影响,可以重新启动.
    4)使用这种方法,只能完成一些dos下的程序的安装.

四、hdcopy的使用
    主要完成软盘间的快速复制以及将软盘的内容建立映象保存到硬盘,还可以将硬盘的映象内容重新读取到软盘上,?还有将软盘格式化为不同的容量的功能,如果结合img的使用,则更加方便.
  1)在options menu中进行设置的改变
    soure(destination) drive 改变源(目标)盘盘符(仅对于有2个驱动器)
    auto verify:on/off 在进行读写操作及格式化时是否自动效验数据.
    fat selection:on/off 拷贝时是否仅对有数据区域进行读操作, 为on时读全盘.
    format destinatin:auto/on/off 写盘时(自动/是/不)对目标盘进行格式化.
    password protected:on/off 对于保存到硬盘的映象文件是否加口令保护.
    verbose mode:on/off是否开启在出现错误时进行多次效验的功能.
    head settle time:on/off 是否等待磁头的调整
    user mode:safe/prof/expert 读数据时使用安全/保护/冒险模式。冒险模式时,计算机自动检测驱动器,并进行读写操作,要求熟练掌握操作.冒险模式等同于专家模式.
  注意:1)若A B 两驱动器容量不同时,要求源盘容量大于目标盘.
    2)使用put to file 功能可以将读在内存中文件保存到硬盘中.对于有加密点的磁盘,它也可以读出来,并长期保存或复制.
    3)使用get from file 功能可将硬盘中保存的文件读到内存中,再写到软盘.
    4)格式化磁盘时,使用不同的格式时应注意在另外的驱动器读取可能有困难.可以将坏盘格式化成低容量,以便修复诸如零道损坏等问题.
    5)对于1.7@ 1.7m及2.0版,虽然界面有所不同,但基本内容一致,2.0版中的"+"相当于on,"-"相当于"off","*"相当于自动方式.

五、diskfix 工具
    用作修复文件分配表,引导扇区及目录扇区发生错误的软盘或硬盘.命令行参数:
    /test 只作测试,不作修复工作
    /scan 完成测试并进行修复工作
    /ro:filename 完成测试工作,并报告于filename文件中(覆盖该文件)
    /ra:filename 同上,只是追加到文件尾.
    /hcache 或hcard 如有硬盘卡,则选该项
    注意:作diskfix工作之前,应将驻留内存的程序退出.
    repaire disk选项 修复由于文件分配表,?引导扇区及目录区错误等而引起的磁盘异常,进入后会让你对驱动器进行选择,它会自动完成以上各项的检测工作,并自动进行修复. comparion(对比) description(描述) destructor(结构)surface scan选项 自动进行表面媒体测试,检测不安全隐患,并将数据移动到安全区域,?它会有一个测试次数的选项,可进行 多达80次的测试,这一过程需要很长时间. preventive(防止) maintenance(维护) read write only 模拟media (媒体) defect(欠缺,不安全) perform (执行) destructive(有害的)revitabize(复兴)选项 除完成surface scan 以外,在不对磁盘数据进行破坏的前提下,完成一边格式化,并尽可能修复损坏的数据. optimum(适宜的)undo a diskfix repair 选项 在进行磁盘repaire时,可以保存一些信息,以便由于diskfix工作而造成了问题,可以使用该选项进行复原工作.
  configure 配置
    1)test paration table 测试分区信息.
    2)check boot sector for virus 测试根扇区中是否有病毒
    3)look for mirror 寻找映象文件
    4)use bios surface scan 使用bios 进行表面测试
    5)use custom error message 使用当前的错误提示信息

六、diskfix的应用
  1)对于由于分区表,引导扇区错误而造成的损坏,表现为:
    主分区盘不能启动,显示"cann't load file "或"Invalid drive specition"
    其他分区"D"显示"Invalid drive spection "或"Not ready drive D:Abort,Retry,Fail"
    方法:首先使用软盘启动
    (1)?使用输入diskfix c:,选择其中的repair a disk ,然后对于其它的所有问题均回答"Y",修复时,diskfix会自动修复损坏的硬盘.
    (2)可以使用norton工具包中的磁盘医生"NDD"来修复,启动NDD后进入选项中,对"修理设定"项选择"自动修理",然后选择"诊断磁盘"一项,对"C"进行操作即可.
    (3)若软盘启动后,不能进入"C:",应首选"diskfix c:"硬盘不能启动有多方面的原因,?对于由于系统文件损坏而造成的启动困难,可以软盘启动后,用"sys c:"来传送系统文件就可以了.但对于"win95",则应使用win95应急盘启动,传递成功后,应查看根目录下是否存在"io.dos msdos.dos command.dos"三个文件,若不存在,则应使用dos启动盘,拷贝一份到根目录区,否则以前的dos版本将启动困难.须注意的是,制作启动盘应与机器原来的系统文件版本号相同.
  2)对于由于误删除而造成的问题
    (1)dos下可以使用undelete 命令恢复,或者使用pctool工具恢复删除.
    (2)win95删除的文件,可先在"回收站"中查找,若"回收站"属性设置为直接清空,还可以到被删除文件所在的目录下运行undelete命令恢复.

七、norton 工具的使用
    优化磁盘读写,提高磁盘速度的工具,calibrate(校准)
    (1)优化磁盘速度
    (2)移动危险区数据到安全区
    (3)在磁盘数据损坏以前进行检测和纠正来保护磁盘
  测试项目:
    (1)完整性测试,包括系统参数,硬盘编码技术及交叉因子的设置.
    (2)系统内存,内存控制器的,软(硬)盘控制器的诊断

八、磁盘编辑器 diskedit的使用
    它可以挽救因为磁盘0道损坏而造成的文件的读写困难.
    方法:将一块好的磁盘插入驱动器,启动diskedit,来读盘的内容,然后取出好盘换上受损盘,继续读操作,由于仅仅0道损坏,而其它磁道内容完好,因而可以读出数据,记下相应的起止扇区号,利用工具中的写对象命令,将相应的扇区号写入硬盘中去,退出编辑,调用相应的文件即可.(若出现读错误,可以kip,igrone)
这种方法对于根目录损坏的磁盘,恢复的可能性狠小.同时可以通过查找特定的字符,可以快速判断要找的文件的位置.

九、diskmon 它可以监视磁盘的任何动作,防止意外发生.
    1)?磁盘保护,它可以通过对系统区域,文件区,或者全部磁盘区实行写保护,对于个别类型文件,?也可以单独设置,如让某种类型文件受到特殊保护,通过设置,就不能存取某种类型的文件.
    2)磁盘读写灯设置,设置它可以识别网络磁盘,在发生存取盘的操作时,屏显磁盘
号.
    3)磁盘挂起,相当于dos中的park 命令,将磁头放置安全区域.

十、filefind/ts
    可以在整个磁盘区域,当前目录,当前目录及子目录下,查找某类或某个文件,还可以查找某几个字符,以达到匹配的目的.它能够在同一文件中多次查找并显示匹配的字串,这在查找多个文件时有用.由于其中有多中设置,?它可以在某个时间段,某大小甚至可以在网络驱动器上进行工作,还具有对某类型文件查找的功能.查找时可以输入汉字.如果加上/ts命令则速度更快,它具有1)查找字串 2)查找相应文件功能

十一、filefix 可以对某种文件进行修复.
    文件由于各种原因,造成损坏,可以使用它来进行最大限度的恢复.

十二、unerase 可以通过子目录以及对驱动器的选择来恢复被删除文件.
    它可以将所有被删除文件例表,?来显示所有可恢复的文件的详细资料,同时提供选择的权力,?可以有针对性的恢复.可以将恢复的文件直接存盘到另外的子目录 乃至另外的驱动器中.注意:
    1)它提供对网络上删除的文件进行浏览功能,但不能进行恢复.网络上删除的文件可以用salvage中提供的功能恢复.
    2)?在预测栏中sub_dir为子目录,"好""困难""平均"标记了几种要恢复文件的难易程度.利用它可以恢复子目录.
    3)对于使用rd 及deletree删除的子目录,只要保证没有往盘中追加数据,都可以完全恢复文件.
    4)?使用时,可以使用空格或"+"号,来选择要恢复的文件,直接将光标移动到要恢复的文件上,按"U"键进行恢复,然后输入一个字母,作为文件名的首字母,要确保不存在相同的文件名.
    5)对于删除的子目录,可以直接进入,继续进行文件的恢复工作.相比之下,unerase比pctool及undelete操作简单,功能强大.在文件信息一栏中,显示文件编辑的最后日期,字节数,文件属性以及是否能正确恢复,?有时提示"将不包括正确数�",但经过测试,对大多数标记为"好"的文件,均可以正常恢复,还可通过选择进行批量恢复.

十四、wipeinfo 快速擦写,使用它擦写后的文件无法恢复.
    使用undelete,unerase及pctools工具,对于它也无济于事,它可以对整个驱动器,某个子目录,子目录中的每个文件进行操作,操作前有警告,须慎用.

十五、norton工具中的unformat 将恢复因意外格式化而造成数据丢失的软/硬盘,也可修复受其它原因破坏的磁盘.对于由于引导信息丢失,分区表损坏而无法进入的磁盘无效(应使用diskfix,diskedit等修复).
    对于刚使用format格式过的磁盘,如:format a:/q时,可使用dos下的unformat可以恢复.
    使用norton中的unformat命令,则更加直观,它扫描磁盘中的每个扇区,并对每块可用数据进行标记,经过大约5分钟(对软盘),可以对全盘的可恢复文件有全面的标志.
    在相应的子目录dir0,??dir1之下,??可以找到一些较完整的文件,???比dos下的unformat要准确可靠.
    可直接用unformat a:,对于子目录下存在的子目录中的文件,不能确保全部恢复.
    如果使用了format a:命令不加参数,则不能恢复.
    实验表明:?在对使用format a:/q不加/u参数的盘反格式化时,dos下unformat的性能优于norton下的unformat,但若用作过norton中的image则另当别论.在对使用format a:/q/u格式化过的盘进行反格式时,dos下的unformat与norton基本一样.
    在无任何参数下格式化的磁盘,dos下的unformat也能恢复.
    评论:dos下的unformat 速度较快,但必须有完整的影象文件,当磁盘中要恢复的
    文件很多时,norton中的unformat性能要优于dos下的unformat.

十六、speeddisk的工作
    功能:1)优化磁盘的可利用空间,并移动到磁盘尾部
    2)合并文件的存放碎片,并加以消除.
    运行时不能中途掉电,但可以通过esc来终止,不能有内存驻留程序的活动.
  可供选择的策略:
    1)除目录和文件分配表外全部优化
    2)全部优化,包括目录,目录优于文件,
    3)全部优化,并将文件排序.
    4)取消文件碎片.
    5)取消各种空间碎片,有利于进行大文件安装.


目录

《高手之路,DOS起步》目录

    你想成为电脑高手吗？你是否面对着种种电脑故障却无从下手，是否羡慕他人熟练地解决各种问题？如果你的回答为"是"，那么问问你自己"你会DOS操作吗？"
微软产品向下兼容的特点决定了Windows需要构建在DOS的基础上，同时由于Windows系统存在着种种不稳定的因素，哪怕是微软宣称极其稳定的Windows NT/2000也经常出现一些其自身难以修复的故障，这时就不得不使用DOS来解决这些问题。因此，要想成为高手，必须懂得DOS………

    DOS小巧且灵活，使用一张软盘就能启动。刷新主板、显卡的BIOS大部分都必须在DOS下进行，不会DOS能行吗？

    学习DOS不仅可以使你解决一些常见的故障，并且可以提高你对事物的探索能力，同时也为学习Linux、UNIX等操作系统打下了一定的基础。随着Windows系统的普及，书店书架上的DOS书籍渐渐地被Windows书籍所替代，使得人们对DOS的了解越来越少，普通的电脑用户对于DOS简直是一窍不通，电脑出了问题后又只得求救于他人。

    学DOS也不仅仅是为了操作，在学习的同时也可以掌握一些基础的概念，使以后的操作更有正确的依据。我发现大多数电脑初学者由于对概念的模糊，使得其操作时往往张冠李戴。为了帮助广大电脑用户成为电脑高手，我们现在一起来踏上DOS之路。

一、DOS使用常识
DOS（Disk Operating System）是一个使用得十分广泛的磁盘操作系统，就连眼下流行的Windows9x/ME系统都是以它为基础。

常见的DOS有两种：IBM公司的PC-DOS和微软公司的MS-DOS，它们的功能、命令用途格式都相同，我们常用的是MS-DOS………

  • DOS使用常识

二、DOS的内部命令
DOS的内部命令是进行操作的基础，完成了对它们的学习你就跨进了DOS系统的大门。内部命令，是指在DOS启动之后，自动通过command.com文件导入内存的命令。在执行这些命令的时候，直接从内存进行调用………

  • DOS的内部命令

三、DOS的外部命令
DOS的外部命令就是一些应用程序，能够使用户的操作更加方便和深入。这些外部命令都是以文件的形式存在，Windows系统的DOS外部命令保存在Windwos主目录下的"Command"目录中………

  • DOS的外部命令

四、FDISK使用介绍
对硬盘进行分区、格式化，是每个硬盘都必须经过的步骤。在这里我就来具体讲解一下怎样使用FDISK进行硬盘分区。FDISK程序是DOS和Windows系统自带的分区软件，虽然其功能比不上有些软件，但用它分区是十分安全的………

  • FDISK使用介绍
  • 用FDISK进行硬盘分区

五、DOS解决问题实战
看了前面的文章，相信大家对DOS的基础操作以有了一个较深的印象了吧。但光掌握以上的这些内容是远远不够的，解决电脑问题，最主要的还是能够将学到的死知识转化为自己可以熟练使用的兵器。下面就请大家随我一道来看几个实例，从中找出解决问题的关键和主要的思路………

  • DOS解决问题