电脑故障维修判断指导大全

前 言：

    本《电脑故障维修判断指导大全》中所有编辑文章版权归原作者和本站所有。一切商业媒体如要引用本教程内容请与本站联系!网上非盈利媒体引用本教程时请注明作者及出处!本教程纯属学习研究性质，对于您使用本教程中技术所导致的一切后果本站不负任何责任！

***********本电子书由“我要[dfcg]”网上收集编辑，特别感谢原文作者的好文章。***********

   DFCG大本营-经天纬地是穷人的软件乐园、免费提供注册机、破解下载，希望大家喜欢...

发行网站：DFCG大本营－经天纬地
主要成员：我要、北极熊、飞叶流枫等
本站域名：http://www.cn12.com
本站论坛：http://www.jxlb.com/cgi-bin/leoboard.cgi
发布时间:2003年3月18日

Copyright © 2002 DFCG破解 All Rights Reserved
整理编辑：我要[DFCG]


QuickCHM

第一部分 总则
第一章 电脑维修的基本原则和方法
第二章 电脑维修步骤与维修操作注意事项

第二部分 常见故障判断
第一章 加电类故障
第二章 启动与关闭类故障
第三章 磁盘类故障
第四章 显示类故障
第五章 安装类故障
第六章 操作与应用类故障
第七章 局域网类故障
第八章 Internet类故障
第九章 端口与外设故障
第十章 音视频类故障
第十一章 兼容类故障

第三部分 附录
硬盘基本知识
挽救硬盘的几个方法
硬盘逻辑锁巧解
WINDOWS蓝色当机画面解读
win2k注册表终极修改
下载影片修复合成全供略
IE5.X@6.0选项控制大全
实用的端口大全(中文版)


第一章 电脑维修的基本原则和方法
这里所述原则、方法等是第二部分分类判断的基础，需要认真遵守执行。

§1.1 进行电脑维修应遵循的基本原则：
一、 进行维修判断须从最简单的事情做起
简单的事情，一方面指观察，另一方面是指简捷的环境。
简单的事情就是观察，它包括：
1、 电脑周围的环境情况——位置、电源、连接、其它设备、温度与湿度等；
2、 电脑所表现的现象、显示的内容，及它们与正常情况下的异同；
3、 电脑内部的环境情况——灰尘、连接、器件的颜色、部件的形状、指示灯的状态等；
4、 电脑的软硬件配置——安装了何种硬件，资源的使用情况；使用的是使种操作系统，其上又安装了何种应用软件；硬件的设置驱动程序版本等。
简捷的环境包括：
1、 后续将提到的最小系统；
2、 在判断的环境中，仅包括基本的运行部件/软件，和被怀疑有故障的部件/软件；
3、 在一个干净的系统中，添加用户的应用（硬件、软件）来进行分析判断
从简单的事情做起，有利于精力的集中，有利于进行故障的判断与定位。一定要注意，必须通过认真的观察后，才可进行判断与维修。
二、 根据观察到的现象，要“先想后做”
先想后做，包括以下几个方面：
首先是，先想好怎样做、从何处入手，再实际动手。也可以说是先分析判断，再进行维修。
其次是，对于所观察到的现象，尽可能地先查阅相关的资料，看有无相应的技术要求、使用特点等，然后根据查阅到的资料，结合下面要谈到的内容，再着手维修。
最后是，在分析判断的过程中，要根据自身已有的知识、经验来进行判断，对于自己不太了解或根本不了解的，一定要先向有经验的同事或你的技术支持工程师咨询，寻求帮助。
三、 在大多数的电脑维修判断中，必须“先软后硬：
即从整个维修判断的过程看，总是先判断是否为软件故障，先检查软件问题，当可判软件环境是正常时，如果故障不能消失，再从硬件方面着手检查。
四、 在维修过程中要分清主次，即“抓主要矛盾“
在复现故障现象时，有时可能会看到一台故障机不止有一个故障现象，而是有两个或两个以上的故障现象（如：启动过程中无显，但机器也在启动，同时启动完后，有死机的现象等），为时，应该先判断、维修主要的故障现象，当修复后，再维修次要故障现象，有时可能次要故障现象已不需要维修了。

§1.2 电脑维修的基本方法
一、观察法
观察，是维修判断过程中第一要法，它贯穿于整个维修过程中。观察不仅要认真，而且要全面。要观察的内容包括：
1、 周围的环境；
2、 硬件环境。包括接插头、座和槽等；
3、 软件环境；
4、 用户操作的习惯、过程
二、最小系统法
最小系统是指，从维修判断的角度能使电脑开机或运行的最基本的硬件和软件环境。最小系统有两种形式：
硬件最小系统：由电源、主板和CPU组成。在这个系统中，没有任何信号线的连接，只有电源到主板的电源连接。在判断过程中是通过声音来判断这一核心组成部分是否可正常工作；
软件最小系统：由电源、主板、CPU、内存、显示卡/显示器、键盘和硬盘组成。这个最小系统主要用来判断系统是否可完成正常的启动与运行。
对于软件最小环境，就“软件”有以下几点要说明：
1、 硬盘中的软件环境，保留着原先的软件环境，只是在分析判断时，根据需要进行隔离如卸载、屏蔽等）。保留原有的软件环境，主要是用来分析判断应用软件方面的问题
2、 硬盘中的软件环境，只有一个基本的操作系统环境（可能是卸载掉所有应用，或是重新安装一个干净的操作系统），然后根据分析判断的需要，加载需要的应用。需要使用一个干净的操作系统环境，是要判断系统问题、软件冲突或软、硬件间的冲突问题。
3、 在软件最小系统下，可根据需要添加或更改适当的硬件。如：在判断启动故障时，由于硬盘不能启动，想检查一下能否从其它驱动器启动。这时，可在软件最小系统下加入一个软驱或干脆用软驱替换硬盘，来检查。又如：在判断音视频方面的故障时，应需要在软件最小系统中加入声卡；在判断网络问题时，就应在软件最小系统中加入网卡等。
最小系统法，主要是要先判断在最基本的软、硬件环境中，系统是否可正常工作。如果不能正常工作，即可判定最基本的软、硬件部件有故障，从而起到故障隔离的作用。
最小系统法与逐步添加法结合，能较快速地定位发生在其它板软件的故障，提高维修效率。
三、逐步添加/去除法
逐步添加法，以最小系统为基础，每次只向系统添加一个部件/设备或软件，来检查故障现象是否消失或发生变化，以此来判断并定位故障部位。
逐步去除法，正好与逐步添加法的操作相反。
逐步添加/去除法一般要与替换法配合，才能较为准确地定位故障部位。
四、隔离法
是将可能防碍故障判断的硬件或软件屏蔽起来的一种判断方法。它也可用来将怀疑相互冲突的硬件、软件隔离开以判断故障是否发生变化的一种方法。
上提到的软硬件屏蔽，对于软件来说，即是停止其运行，或者是卸载；对于硬件来说，是在设备管理器中，禁用、卸载其驱动，或干脆将硬件从系统中去除。
五、替换法
替换法是用好的部件去代替可能有故障的部件，以判断故障现象是否消失的一种维修方法。好的部件可以是同型号的，也可能是不同型号的。替换的顺序一般为：
1、 根据故障的现象或第二部分中的故障类别，来考虑需要进行替换的部件或设备；
2、 按先简单后复杂的顺序进行替换。如：先内存、CPU，后主板，又如要判断打印故障时，可先考虑打印驱动是否有问题，再考虑打印电缆是否有故障，最后考虑打印机或并口是否有故障等；
3、 最先考查与怀疑有故障的部件相连接的连接线、信号线等，之后是替换怀疑有故障的部件，再后是替换供电部件，最后是与之相关的其它部件。
4、 从部件的故障率高低来考虑最先替换的部件。故障率高的部件先进行替换。
六、比较法
比较法与替换法类似，即用好的部件与怀疑有故障的部件进行外观、配置、运行现象等方面的比较，也可在两台电脑间进行比较，以判断故障电脑在环境设置，硬件配置方面的不同，从而找出故障部位。
七、升降温法
在上门服务过程中，升降温法由于工具的限制，其使用与维修间是不同的。在上门服务中的升温法，可在用户同意的情况下，设法降低电脑的通风能力，靠电脑自身的发热来升温；降温的方法有：1）一般选择环境温度较低的时段，如一清早或较晚的时间；2）使电脑停机12~24小时以上等方法实现；3）用电风扇对着故障机吹，以加快降温速度。
八、敲打法
敲打法一般用在怀疑电脑中的某部件有接触不良的故障时，通过振动、适当的扭曲，甚或用橡胶锤敲打部件或设备的特定部件来使故障复现，从而判断故障部件的一种维修方法。
九、对电脑产品进行清洁的建议
有些电脑故障，往往是由于机器内灰尘较多引起的，这就要求我们在维修过程中，注意观察故障机内、外部是否有较多的灰尘，如果是，应该先进行除尘，再进行后续的判断维修。在进行除尘操作中，以下几个方面要特别注意：
1、 注意风道的清洁
2、 注意风扇的清洁
风扇的清洁过程中，最好在清除其灰尘后，能在风扇轴处，点一点儿钟表油，加强润滑。
3、 注意接插头、座、槽、板卡金手指部分的清洁
金手指的清洁，可以用橡皮擦拭金手指部分，或用酒精棉擦拭也可以。
插头、座、槽的金属引脚上的氧化现象的去除： 一是用酒精擦拭，一是用金属片（如小一字改锥）在金属引脚上轻轻刮擦。
4、 注意大规模集成电路、元器件等引脚处的清洁
清洁时，应用小毛刷或吸尘器等除掉灰尘，同时要观察引脚有无虚焊和潮湿的现象，元器件是否有变形、变色或漏液现象。
5、 注意使用的清洁工具
清洁用的工具，首先是防静电的。如清洁用的小毛刷，应使用天然材料制成的毛刷，禁用塑料毛刷。其次是如使用金属工具进行清洁时，必须切断电源，且对金属工具进行泄放静电的处理。
用于清洁的工具包括：小毛刷、皮老虎、吸尘器、抹布、酒精（不可用来擦拭机箱、显示器等的塑料外壳）。
6、 对于比较潮湿的情况，应想办法使其干燥后再使用。可用的工具如电风扇、电吹风等，也可让其自然风干。
十、软件调试的几个方法和建议
1、 操作系统方面。
主要的调整内容是操作系统的启动文件、系统配置参数、组件文件、病毒等。
修复操作系统启动文件。
1) 对于Windows 9x系统，可用SYS命令来修复（要保证MSDOS.SYS的大小在1KB以上），但要求，在修复之前应保证分区参数是正确的。这可使用诸如DiskMap之类的软件实现；
2) 对于Windows 2000/XP系统，有两种方法——修复启动文件，使用fixboot命令；修复主引导记录，使用fixmbr命令。
调整操作系统配置文件。
A. 对于Windows 9x系统，可用的工具很多，如：Msconfig命令、系统文件检查器、注册表备份和恢复命令（scanreg.exe，它要求在DOS环境下运行。另外如果要用scanreg.exe恢复注册表，最好使用所列出的恢复菜单中的第二个备份文件）等；
B. 对于Windows 2000系统，可用的工具与Windows 9x相比比较少，但某些调试命令可用Win98中的一些命令（如win98下的Msconfig命令，就可用在windows 2000下）；
C. 对于Windows XP系统，可用的工具主要是Msconfig命令；
D. 调整电源管理和有关的服务，可以使用的命令是，要“运行”文本框中输入gpedit.msc来进行；
E. 所有操作系统的调试，都可通过控制面板、设备管理器、计算机管理器（Windows 9x系统无）来进行系统的调试。
组件文件（包括.DLL、.VXD等）的修复
A. 通过添加删除程序来重新安装；
B. 通过从.CAB文件中提取安装；
C. 可用系统文件检查器（sfc.exe命令）来修复有错误的文件；
D. 从好的机器上拷贝覆盖。
检查系统中的病毒。
建议使用命令行方式下的病毒查杀软件，并能直接访问诸如NTFS分区。
2、 设备驱动安装与配置方面。
主要调整设备驱动程序是否与设备匹配、版本是否合适、相应的设备在驱动程序的作用下能否正常响应。
A. 最好先由操作系统自动识别（特别要求的除外，如一些有特别要求的显示卡驱动、声卡驱动、非即插即用设备的驱动等），而后考虑强行安装。这样有利于判断设备的好坏；
B. 如果有操作系统自带的驱动，则先使用，仍不能正常或不能满足应用需要，则使用设备自带的驱动；
C. 更换设备，应先卸载驱动再更换。卸载驱动，可从设备管理器中卸载；再从安全模式下卸载；进而在INF目录中删除；最后通过注册表卸载；
D. 更新驱动时，如直接升级有问题，须先卸载再更新。
3、 磁盘状况方面。
检查磁盘上的分区是否能访问、介质是否有损坏、保存在其上的文件是否完整等。
可用的调整工具：
A. DiskMap，方便地找回正确的分区；
B. Fdisk及Fdisk /MDR，检查分区是否正确及使主引导记录恢复到原始状态；
C. 当硬盘容量大于64GB时，如果要重新分区或查看分区，要求使用随机附带的磁盘分区软盘中的Fdisk命令。这个命令可用windows Me下的Fdisk命令来代替；
D. Format、Scandisk、厂商提供的磁盘检测程序，检查磁盘介质是否有坏道；
E. 文件不完整时，要求对不完整的文件先进行改名，再用在“操作系统方面”中所述的方法重建。
4、 应用软件方面。
如应用软件是否与操作系统或其它应用有兼容性的问题、使用与配置是否与说明手册中所述的相符、应用软件的相关程序、数据等是否完整等；
5、 BIOS设置方面。
1) 在必要时应先恢复到最优状态。建议：在维修时先把BIOS恢复到最优状态（一般是出厂时的状态），然后根据应用的需要，逐步设置到合适值。
2) BIOS刷新不一定要刷新到最新版，有时应考虑降低版本。
6、 重建系统。
在硬件配置正确，并得到用户许可时，可通过重建系统的方法来判断操作系统之类软件故障，在用户不同意的情况下，建议使用自带的硬盘，来进行重建系统的操作。在这种情况下，最好重建系统后，逐步复原到用户原硬盘的状态，以便判断故障点。
1) 重建系统，须以一键恢复为主，其次是恢复安装，最后是完全重新安装。恢复安装的方法：
对于Windows 9x系统，直接从光盘安装，或执行tools\sysrec\pcrestor.bat，即可实现恢复安装。在进行恢复安装时，可能由于win.com的存在而影响安装过程的正常进行，这时，可在Windows目录下，删除win.com后，再重新安装。
另一种恢复安装，是将根目录下的System.1st改名为System.dat后覆盖掉Windows目录下的同名文件，之后重启即可。但这种方法，不是真正意义上的重新安装，而类似于完全重新安装。
对于Windows XP或Windows2000系统，直接使用其安装光盘启动，在安装界面中选择修复安装，选择R时会出现两个选项：一是快速修复，对于简单问题用此选择；另一是故障修复台，只要选择正确的安装目录就可启用故障修复台。故障修复台界面类似于DOS界面。
2) 为保证系统干净，在安装前，执行Fdisk /MBR命令（也可用Clear.com）。必要时，在此之后执行Format <驱动器盘符> /u [/s]命令。
3) 一定要使用随机版的或正版的操作系统安装介质进行安装。


第二章 电脑维修步骤与维修操作注意事项
§2.1 电脑维修步骤
对电脑进行维修，应遵循如下步骤：
一、了解情况
即在服务前，与用户沟通，了解故障发生前后的情况，进行初步的判断。如果能了解到故障发生前后尽可能详细的情况，将使现场维修效率及判断的准确性得到提高。了解用户的故障与技术标准是否有冲突。
向用户了解情况，应借助第二部分中相关的分析判断方法，与用户交流。这样不仅能初步判断故障部位，也对准备相应的维修备件有帮助。
二、复现故障
即在与用户充分沟通的情况下，确认：
1. 用户所报修故障现象是否存在，并对所见现象进行初步的判断，确定下一步的操作；
2. 是否还有其它故障存在。
三、判断、维修
即对所见的故障现象进行判断、定位，找出产生故障的原因，并进行修复的过程。在进行判断维修的过程中，应遵循下面一节“维修判断”中所述的原则、方法、注意事项，及第二、三部分所述内容进行操作。
四、检验
1. 维修后必须进行检验，确认所复现或发现的故障现象解决，且用户的电脑不存在其它可见的故障。电脑整机正常的标准，参见《联想台式电脑整机检验规范》；
2. 必须按照《XX维修检验确认单》所列内容，进行整机验机，尽可能消除用户未发现的故障，并及时排除之。

§2.2 电脑维修操作
在维修过程中，下列各条款应引起切实的关注和注意。
一、在进行故障现象复现、维修判断的过程中，应避免故障范围扩大；
二、在维修时，须查验、核对装箱单及配置；
三、必须充分地与用户沟通。了解用户的操作过程、出故障时所进行过的操作、用户使用电脑的水平等。
四、维修中第一要注意的就是观察——观察、观察、再观察！！！
1. 周围环境：电源环境、其它高功率电器、电、磁场状况、机器的布局、网络硬件环境、温湿度、环境的洁净程度；安放电脑的台面是否稳固。周边设备是否存在变形、变色、异味等异常现象；
2. 硬件环境：机箱内的清洁度、温湿度，部件上的跳接线设置、颜色、形状、气味等，部件或设备间的连接是否正确；有无错误或错接、缺针/断针等现象；用户加装的与机器相连的其它设备等一切可能与机器运行有关的其它硬件设施；
3. 软件环境：
A. 系统中加载了何种软件、它们与其它软、硬件间是否有冲突或不匹配的地方；
B. 除标配软件及设置外，要观察设备、主板及系统等的驱动、补丁是否安装、是否合适；要处理的故障是否为业内公认的BUG或兼容问题；用户加装的其它应用与配置是否合适；
4. 加电过程中的观察：元器件的温度、异味、是否冒烟等；系统时间是否正确；
5. 拆装部件时的观察：要有记录部件原始安装状态的好习惯，且要认真观察部件上元器件的形状、颜色、原始的安装状态等情况；
6. 观察用户的操作过程和习惯，及是否符合要求等。
五、在维修前，如果灰尘较多，或怀疑是灰尘引起的，应先除尘
六、对于自己不熟悉的应用或设备，应在认真阅读用户使用手册或其它相关文档后，才可动手操作。
七、平时要多注意通过《技术直通车》、《技术工程信息通报》等下发的技术资料及其他工程师们的经验来积累自己的经验和提高维修水平。
八、禁止维修工程师为用户安装地线。如用户要安装地线，请用户联系正式电工为其安装。
九、如果要通过比较法、替换法进行故障判断的话，应先征得用户的同意。
十、在进行维修判断的过程中，如有可能影响到用户所存储的数据，一定要在做好备份、或保护措施、并征得用户同意后，才可继续进行。
十一、当出现大批量的相似故障（不仅是可能判断为批量的故障）时，一定要对周围的环境、连接的设备，以及与故障部件相关的其它部件或设备进行认真的检查和记录，以找出引起故障的根本原因。
十二、随机性故障的处理思路。随机性故障是指：随机性死机、随机性报错、随机性出现不稳定现象。对于这类故障的处理思路应该是：
1. 慎换硬件，特别是上门服务时。一定要在充分的软件调试和观察后，在一定的分析基础上进行硬件更换。如果没有把握，最好在维修站内进行硬件更换操作。
2. 以软件调整为主。调整的内容有：
1） 设置BIOS为出厂状态（注意BIOS开关位置）
2） 查杀病毒
3） 调整电源管理
4） 调整系统运行环境
5） 必要时做磁盘整理，包括磁盘碎片整理、无用文件的清理及介质检查（注意，应在检查磁盘分区正常及分区中空余空间足够的情况下进行）。
6） 确认有无用户自加装的软硬件，如果有，确认其性能的完好性/兼容性。
7） 与无故障的机器比较、对比。这种对比的一种方法是，在一台配置与故障机相同的无故障机器上，逐个插入故障机中的部件（包括软件），查看无故障机的变化，当在插入某部件后，无故障机出现了与故障机类似的现象，可判该部件有故障。注意这种方式的对比，应做得彻底，以防漏掉可能有两种部件引起同一故障的情况。
十三、应努力学习相关技术知识、掌握操作系统的安装、使用方法及配置工具的使用等；理解各配置参数的意义与适用的范围。
十四、请求支持需要关注的内容
1. 硬件及配置信息（尽可能详尽）
2. 软件及配置信息（尽可能详尽）
3. 周围环境
4. 完整的故障现象描述。即用户第一次报修时的故障现象，经过维修操作后故障现象的变化情况。（清晰的描述）
5. 做过的维修操作（要详尽）

§2.3 电脑维修的基本思路
为帮助维修工程师，顺利找到第二部分中的相关内容，在这里列出基本的判断思路，供参考使用。


第二部分 常见故障判断

本部分将计算机从开机一直到关机期间的故障进行分类。每一类的判断、定位过程都是第一部分中“维修判断”一节的有机组成部分，即不论使用什么方法或不论去判断什么内容，这两部分总是相互结合使用的。
以下各故障类型中所列的故障现象只是众多故障现象中的一部分，对于未列出的故障现象，有的可归类到其中，有的无法归类。因此，本手册只针对已列出的及可归类其中的故障现象提供相应的判断的方法和思路，并提供基本的排除的方法。而对不能归类其中的其它故障现象来说，我们会在今后的工作中不断的收集、整理总结，然后对本《台式电脑维修指导手册》进行丰富。

第一章 加电类故障
一、定义举例
从上电（或复位）到自检完成这一段过程中电脑所发生的故障。
二、可能的故障现象
1、 主机不能加电（如：电源风扇不转或转一下即停等）、有时不能加电、开机掉闸、机箱金属部分带电等；
2、 开机无显，开机报警；
3、 自检报错或死机、自检过程中所显示的配置与实际不符等；
4、 反复重启；
5、 不能进入BIOS、刷新BIOS后死机或报错；CMOS掉电、时钟不准；
6、 机器噪音大、自动（定时）开机、电源设备问题等其它故障。
三、可能涉及的部件
市电环境；电源、主板、CPU、内存、显示卡、其它可能的板卡；BIOS中的设置（可通过放电来回复到出厂状态）；开关及开关线、复位按钮及复位线本身的故障。
四、判断要点/顺序。
以下的文字叙述部分是对维修判断流程的补充和说明，要结合流程图来阅读。另外，本章只分析加电类的故障，如果在判断中涉及其它类故障，可转入相应故障的判断过程。以下各类同。
1、 维修前的准备
1) POST卡；
2) 万用表；
3) 试电笔；
4) CPU负载。
2、 环境检查
1) 检查电脑设备：
A. 周边及电脑设备内外是否有变形、变色、异味等现象；
B. 环境的温、湿度情况；
C. 加电后，注意部件、元器件及其它设备是否变形、变色、异味、温度异常等现象发生。
2) 检查市电情况：
A. 检查市电电压是否在220V±10%范围内，是否稳定（即是否有经常停电、瞬间停电等现象）；
B. 市电的接线定义是否正确（即，左零右火、不允许用零线作地线用（现象是零地短接）、零线不应有悬空或虚接现象）；
C. 供电线路上是否接有漏电保护器（且必须接地火线上），是否有地线等；
D. 主机电源线一端是否牢靠地插在市电插座中，不应有过松或插不到位的现象，另一端是否可靠在接在主机电源上，不应有过松或插不到位的情况。
3) 检查电脑内部连接：
A. 电源开关可否正常的通断，声音清晰，无连键、接触不良现象；
B. 其它各按钮、开关通断是否正常；
C. 连接到外部的信号线是否有断路、短路等现象；
D. 主机电源是否已正确地连接在各主要部件，特别是主板的相应插座中；
E. 板卡，特别是主板上的跳接线设置是否正确。
4) 检查部件安装：
A. 检查机箱内是否有异物造成短路；
B. 或零部件安装上是否造成短路（如P4CPU风扇在主板背面的支架安装错位造成的短路等）；
C. 通过重新插拔部件（包括CPU、内存），检查故障是否消失（重新插拔前，应该先做除尘和清洁金手指工作，包括插槽）。如果总是通过重新插拔来解决，应检查部件安装时，是否过松、后档板尺寸是否不合适、插座太紧，以致插不到位或被挤出；
D. 检查内存的安装，要求内存的安装总是从第一个插槽开始顺序安装。如果不是这样，请重新插好。
5) 检查加电后的现象：
A. 按下电源开关或复位按钮时，观察各指示灯是否正常闪亮；
B. 风扇（电源的和CPU的等）的工作情况，不应有不动作或只动作一下即停止的现象；
C. 注意倾听风扇、驱动器等的电机是否有正常的运转声音或声音是否过大；
D. 主机能加电，但无显示，应倾听主机能否正常自检（即有自检完成的鸣叫声，且硬盘灯能不断闪烁）若有，先检查显示系统是否有故障，否则检查主机问题；
E. 对于开机噪音大的问题，应分辨清噪音大的部位，一般情况下，噪音大的部件有风扇、硬盘、光驱和软驱动机械部件。对于风扇，应通过除尘来检查，如果噪音减小，可在风扇轴处滴一些钟表油，以加强润滑。
3、 故障判断要点
1) 检查主机电源：
A. 主机电源在不接负载时，将电源到主板的插头中绿线与黑线直接短接，看能否加电，并用万用表检查是否有电压输出；
B. 用万用表检查输出的各路电压值是否在规格允许的范围内；
C. 在接有负载的情况下，用万用表检查输出电源的波动范围是否在超出允许范围；
D. 对于电源一加电，只动作一下即停止工作的情况，应首先判断电源空载或接在其它机器上是否能正常工作（即检查上面提到的三点）；
E. 如果电脑的供电不是直接从市电来，而是通过稳压设备获得，要注意用户所用的稳压设备是否完好、或是否与我们的产品的电源兼容。
2) 在开机无显时，用POST卡检查硬件最小系统中的部件是否正常
A. 查看POST显示的代码是否为正常值（参见《维修工具使用手册》中的代码定义）；
B. 对于POST卡所显示的代码，应检查与之相关的所有部件。如显示的代码与内存有关，就应检查主板和内存；
C. 倾听在硬件最小系统下，有无报警声音，若无检查的重点应在最小系统中的部件上；
D. 检查中还应注意的是，当硬件最小系统有报警声时，要求插入无故障的内存和显示卡（集成显示卡除外），若此时没有报警音，且有显示或自检完成的声音，证明硬件最小系统中的部件基本无故障，否则，应主要检查主板；
E. 在准备更换CPU来检查时，应先使用CPU负载，检查主板的供电电压是否在允许范围内，在电压正常的情况下才可进行CPU更换操作。如果超出范围，直接更换主板。CPU电压允许值参见《维修工具使用手册》；
3) 部件的检查：
A. 如果硬件最小系统中的部件经POST卡检查正常后，要逐步加入其它的板卡及设备，以检查其中哪个部件或设备有问题；
B. 对于总是通过重新插拔来解决加电故障的部件，应检查部件的后档板尺寸是否不太合适，这可通过去掉后档板检查。
4) BIOS设置检查：
A. 通过清CMOS检查故障是否消失；
B. BIOS中的设置是否与实际的配置不相符（如：磁盘参数、内存类型、CPU参数、显示类型、温度设置等）；
C. 根据需要更新BIOS检查故障是否消失。
5) 其它方面的检查：
A. 在接有漏电保护器的环境中，一定要先检查市电插座上的接线是否正确（即按左零右火，上地的连接方法；零地线不可短接；零线不能悬空），再检查漏电保护器是否正确地接在火线上、容量是否过小，接着检查在一路市电线路上所接的设备的数量（特别是电脑的数量——在漏电保护器的动作电流为30mA时，应可接16~20台电脑），最后检查整机设备中有无漏电或漏电流过大的现象；
B. 检查用户环境中有无地线。在无地线的环境中，触摸主机的金属部分，会有麻手的感觉。这时，如果接地后，机器可正常运行，且麻手现象消失，则属正常现象，不是故障；
C. 对于不能进BIOS，或不能刷新BIOS的情况，可先考虑主板的故障；
D. 对于反复重启或关机的情况，除注意市电的环境（如插头是否插好等）外，要注意电源或主板是否有故障；
E. 系统中是否加载有第三方的开关机控制软件，有应予以卸载。
五、本类故障的判断流程
见附录一之（一）。
六、案例
案例一：
问题描述：双子恒星6C/766的机器，主板是精英P6SEP-ME V2.2D，当内存不插在DIMM1时，开机无显示，但机器不报警。
解决方案：经测试，当DIMM1上不插内存时，即使DIMM2、DIMM3都插上内存，开机也是无显。当DIMM1插上内存时，不管DIMM2、DIMM3上是否插有内存，开机正常。
查询早期的周报得知，此问题是由于此机型集成的显卡使用的显存是共享物理内存的，而显存所要求的物理内存是要从插在DIMM1上内存中取得，当DIMM1上没有插内存时，集成显卡无法从物理内存中取得显存，故用户开机时无显。

案例二：
问题描述：每次计算机开机自检时，系统总会在显示512K Cache的地方停止运行了，是什么原因？
解决方案：首先既然在显示缓存处死机，必然是该处或其后的部分有问题。记得平常开机，此项显示完后就轮到硬盘启动操作系统了。因此，可以断定不是高速缓存的问题，就是硬盘的故障。取下硬盘安装到别的电脑上，证实硬盘是好的。这是检查计算机故障最常用的办法——替换排除法。
现在我们把注意力集中到高速缓存上，进入CMOS设置，禁止L2 Cache，存盘退出，重启机器，电脑就可以正常工作了，可以断定是L2 Cache的问题。
触摸主板上的高速缓存芯片，发现有些芯片很热，估计就是这儿的问题。再次确认问题所在没错。
触类旁通：若发现机器总死机，可运行一会后，用手触摸主板上的高速缓存芯片，发现烫手，就可在Cmos中关闭二级缓存，发现是否死机，最后定义故障所在。

案例三：
问题描述：用户使用T启天2600 P4 1.6G 12840DSF(特5409)计算机，开机无显示，用户现在咨询如何解决？
解决方案：检查用户的环境，发现用户机随机附带两块显卡——主板集成一个显卡另外还有一块单独的TNT2 M64 32M显卡，有些客户在刚刚购买电脑时由于对电脑不太熟悉，将显示器信号线接到了主板集成的显卡接头上，这样会导致开机无显，但是此时主机工作正常。
遇到用户报修开机无显或显示器故障，请提示客户检查环境，若有不正确，提示更正后，问题即可解决。


第二章 启动与关闭类故障
一、定义举例
与启动、关闭过程有关的故障。启动是指从自检完毕到进入操作系统应用界面这一过程中发生的问题；关闭系统是指从点击关闭按扭后到电源断开之间的所有过程。
二、可能的故障现象
1、 启动过程中死机、报错、黑屏、反复重启等；
2、 启动过程中报某个文件错误；
3、 启动过程中，总是执行一些不应该的操作（如总是磁盘扫描、启动一个不正常的应用程序等）；
4、 只能以安全模式或命令行模式启动；
5、 登录时失败、报错或死机；
6、 关闭操作系统时死机或报错。
三、可能涉及的部件
BIOS设置、启动文件、设备驱动程序、操作系统/应用程序配置文件；电源、磁盘及磁盘驱动器、主板、信号线、CPU、内存、可能的其它板卡。
四、判断要点/顺序
1、 维修前的准备
1) 磁盘数据线；
2) 万用表；
3) 查毒软件。
2、 环境检查
1) 机器周边及外观检查：
A. 市电连接是否牢靠，不应有过松或插不到位的现象；
B. 主机硬盘指示灯是否正确闪亮，不应有不亮或常亮的现象；
C. 观察系统是否有异味，元器件的温度是否偏高；
D. 观察CPU风扇的转速是否不够，或是否过慢或不稳定；
E. 倾听驱动器工作时是否有异响。
2) 驱动器连接检查：
A. 驱动器的电源连接是否正确、牢靠。驱动器上的电源连接插座是否有虚接的现象；
B. 驱动器上的跳线设置是否与驱动器连接在电缆上的位置相符；
C. 驱动器数据电缆是否接错或漏接，规格是否与驱动器的技术规格相符（如：支持DMA66的驱动器，必须使用80芯数据电缆）；
D. 驱动器数据电缆是否有故障（如露出芯线、有死弯或硬痕等），除可通过观察来判断外，也可通过更换一根数据电缆来检查；
E. 驱动器是否通过其它板卡连接到系统上，或通过其它板卡（如硬盘保护卡，双网隔离卡等）来控制。
3) 检查其它部件的安装：
A. 通过重新插拔部件（包括CPU、内存），检查故障是否消失（重新插拔前，应该先做除尘和清洁金手指工作，包括插槽）。如果总是通过重新插拔来解决，应检查部件安装时，是否过松、后档板尺寸是否不合适、插座太紧，以致插不到位或被挤出；
B. 检查CPU风扇与CPU是否接触良好。最好重新安装一次。
4) 显示的内容的观察：要注意屏幕报错的内容、死机的位置，以确定故障可能发生的部位。
3、 故障判断要点
1) 充分地与用户沟通，了解出现不能启动的过程及用户的操作；
2) BIOS设置检查：
A. 是否为刚更换完不同型号的硬件。如果主板BIOS支持BOOTEasy功能或BIOS防写开关打开，则建议将其关闭，待完成一次完整启动后，再开启；
B. 是否添加了新硬件。这时应先去除添加的硬件，看故障是否消失，若是，检查添加的硬件是否有故障，或系统中的设置是否正确（通过对比新硬件的使用手册检查）；
C. 检查BIOS中的设置，如：启动顺序、启动磁盘的设备参数等。建议通过清CMOS来恢复；
D. 检查是否由于BIOS问题（包括设置及功能）引起操作系统不能正常启动或关闭，可偿试将Windows目录下的BIOS.vxd（或VPBIOSD.vxd）改名为BIOS.old，然后重启，或关闭，若故障消失，则通过修改BIOS设备或更新BIOS来解决，否则与BIOS无关。注意测试完成以后，一定要将其改回原来的名字（注：除Windows 98外，其它操作系统无此文件）；
E. 在某些特殊情况下，应考虑升级BIOS来检查。如：对于在第一次开机启动后，某些应用或设备不能工作的情况，除检查设备本身的问题外，就可考虑更新BIOS来解决。
以下检查应在软件最小系统下进行。
3) 磁盘逻辑检查：
A. 根据启动过程中的错误提示，相应地检查磁盘上的分区是否正确、分区是否激活、是否格式化；
B. 直接检查硬盘是否已分区、格式化；
C. 加入一个其它无故障的驱动器（如软驱或光驱）来检查能否从其它驱动器中启动（若使用软驱，最好使用希捷的检测软盘启动）。若能，进行第3）、4）步的检查，否则进行第5）步的检查；接着、分区是否激活、有无坏道等；
D. 硬盘上的启动分区是否已激活，其上是否有启动时所用的启动文件或命令；
E. 检查硬盘驱动器上的启动分区是否可访问，若不能，用相应厂商的磁盘检测程序检查硬盘是否有故障。有故障，更换硬盘；在无故障的情况下，通过初始化硬盘来检测，若故障依然存在，更换硬盘；
F. 在用其它驱动器也不能启动时，先将硬盘驱动器去除，看是否可启动，若仍不能，应对软件最小系统中的部件进行逐一检查，包括硬盘驱动器和磁盘传输的公共部件——磁盘接口、电源、内存等。若可启动了，最好对硬盘进行一次初始化操作，若故障不消失，则再更换硬盘；
G. 如果要对硬盘进行初始化操作，但用户存有有用数据，建议用户找数据修复公司解决。
4) 操作系统配置检查：
A. 对于出现文件错误的提示，应按照在第一部分中提到的相应软件调试方法来修复文件；
B. 在不能启动的情况，建议进行一次“选择上一次启动”或用scanreg.exe恢复注册表到前期备份的注册表的方法检查故障是否能够消除；
C. 检查系统中有无第三方程序在运行，或系统中不当的设置或设备驱动引起启动不正常。在这里特别要注意Autoexec.bat和Config.sys文件，应屏蔽这两个文件，检查启动故障是否消失；
D. 检查启动设置、启动组中的项、注册表中的键值等，是否加载了不必要的程序；
E. 检查是否存在病毒。要求在一个系统中，只能安装一个防病毒软件；
F. 必要时，通过一键恢复、恢复安装等方法，检查启动方面的故障；
G. 当启动中显示不正常时（如黑屏、花屏等），应按显示类故障的判断方法进行检查，但首先要注意显示设备的驱动程序是否正常、显示设置是否正确，最好将显示改变到标准的VGA方式检查。
5) 硬件部件检查：
A. 如果启动的驱动器是通过另外的控制卡连接的，请将驱动器直接连接在缺省的驱动器接口（主板上的）；
B. 当在软件最小系统下启动正常后，应逐步回复到原始配置状态，来定位引起不能正常启动的部件；
C. 要注意检查电源的供电能力，即输出电压是否在允许的范围内，波动范围是否超出允许的范围（参见《维修工具使用手册》）；
D. 驱动器的检查，可参考磁盘类故障的判断方法进行；
E. 硬件方面的考虑，应从内存开始考虑：使用内存检测程序进行判断内存部分是否有故障，内存安装的位置，应从第一个内存槽开始安装，对于安装的多条内存检查内存规格是否一致、兼容等。有关内存规格请参阅附录二的相关部分。
6) 对于不能正常关机的现象，应从下列几个方面检查：
A. 在命令提示符下查看BOOTLOG.TXT文件（在根目录下）。此文件是开机注册文件，它里面记录了系统工作时失败的记录，保存一份系统正常工作时的记录，与出问题后的记录相比较，找出有问题的驱动程序，在WIN.INI SYSTEM.INI 中找到该驱动对应的选项，或在注册表中找到相关联的对应键值，更改或升级该驱动程序，有可能将问题解决；
B. 升级BIOS到最新版本，注意CMOS的设置（特别是APM、USB、IRQ等）；
C. 检查是否有一些系统的文件损坏或未安装（参阅附录二之（三）的相关内容）
D. 应用程序引起的问题，关闭启动组中的应用程序，检查关机时的声音程序是否损坏；
E. 检查是否有某个设备引起无法正常关机，比如网卡、声卡，可通过更新驱动或更换硬件来检查；
F. 通过安装补丁程序或升级操作系统进行检查；
G. 对于Windows 98SE系统的关机问题，请参阅附录二之（三）。其中的一引起论述对于其它Windows系统也有帮助。
五、本类故障的判断流程
见附录一之（二）。
六、案例
案例一：
问题描述：客户计算机安装WIN 2000 PROFESSIONAL操作系统，每次启动均蓝屏，报MEMORY ERROR。
解决方案：到达客户处，故障复现，向客户了解情况，客户反映发生故障前曾经安装过一根内存条，之后发生此类故障。关机后拔下内存条，重新开机，仍旧蓝屏，但是不再报MEMORY ERROR。考虑到WIN 2000对硬件要求较高，而且故障是在加装内存后出现的故障，基本可以断定机器的原配硬件和软件系统没有问题。再次重新启动计算机，开机时按下F8键，选择进入“VGA模式”，此次计算机能够正常启动，并且登陆正常。在进行了一次正常登陆后，重新启动到标准模式，计算机启动正常，至此，故障排除。

案例二：
问题描述：客户机器被运行一段恶意程序，导致每次启动后均出现一个对话框，且该对话框无法关闭，只能强制结束，客户机器有重要程序，不愿意重新安装操作系统。
解决方案：首先怀疑是否是病毒，运行常用杀毒软件均不能查杀。在“开始”――“运行”中输入“MSCONFIG”，但是在“启动”组中仍然不能找到该程序。运行“SCANREG”，将注册表恢复到最老的版本故障依旧。最后只好手工编辑注册表，运行“REGEDIT”，在“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\RUN下，找到对应的程序文件名，删除对应的键值后，重新启动，故障排除。（注：建议在更改注册表前，使用注册表编辑器的“导出”功能进行注册表备份。）


第三章 磁盘类故障

一、定义举例
这里所指的磁盘类故障表示两个方面：一是硬盘、光驱、软驱及其介质等引起的故障；另一是影响对硬盘、光驱、软驱访问的部件（如主板、内存等）引起的故障。
二、可能的故障现象
1、 硬盘驱动器
1) 硬盘有异常声响，噪音较大；
2) BIOS中不能正确地识别硬盘、硬盘指示灯常亮或不亮、硬盘干扰其它驱动器的工作等；
3) 不能分区或格式化、硬盘容量不正确、硬盘有坏道、数据损失等；
4) 逻辑驱动器盘符丢失或被更改、访问硬盘时报错；
5) 硬盘数据的保护故障；
6) 第三方软件造成硬盘故障；
7) 硬盘保护卡引起的故障。
2、 软盘驱动器
1) 软驱指示灯不亮或常亮、软驱读盘声音大；
2) 软驱划盘、软盘不能弹出或插入等；
3) 软盘不能被格式化、软驱不读盘、软驱干扰其它驱动器或设备或应用的正常工作等；
4) 在一个软驱中写的文件不能在另一个软驱中读出；
5) 软驱盘符丢失或被更改、访问软驱时报错；
6) 软驱安装不到位。
3、 光盘驱动器
1) 光驱噪音较大、光驱划盘、光驱托盘不能弹出或关闭、光驱读盘能力差等；
2) 光驱盘符丢失或被更改、系统检测不到光驱等；
3) 访问光驱时死机或报错等；
4) 光盘介质造成光驱不能正常工作。
三、可能涉及的部件
硬盘、光驱、软驱及其它们的设置，主板上的磁盘接口、电源、信号线。
四、判断要点/顺序
1、 维修前的准备
1) 磁盘数据线；
2) 相应的磁盘检测软件；
3) 查毒软件等。
2、 硬盘驱动器
1) 环境检查
A. 检查硬盘连接：
a) 硬盘上的ID跳线是否正确，它应与连接在线缆上的位置匹配；
b) 连接硬盘的数据线是否接错或接反；
c) 硬盘连接线是否有破损或硬折痕。可通过更换连接线检查；
d) 硬盘连接线类型是否与硬盘的技术规格要求相符；
e) 硬盘电源是否已正确连接，不应有过松或插不到位的现象。
B. 硬盘外观检查：
a) 硬盘电路板上的元器件是否有变形、变色，及断裂缺损等现象；
b) 硬盘电源插座之接针是否有虚焊或脱焊现象；
c) 加电后，硬盘自检时指示灯是否不亮或常亮；工作时指示灯是否能正常闪亮；
d) 加电后，要倾听硬盘驱动器的运转声音是否正常，不应有异常的声响及过大的噪音。
C. 硬盘的供电检查：
a) 供电电压是否在允许范围内，波动范围是否在允许的范围内等。
2) 故障判断要点
A. 建议在软件最小系统下进行检查，并判断故障现象是否消失。这样做可排除由于其它驱动器或部件对硬盘访问的影响。
B. 参数与设置检查：
a) 硬盘能否被系统正确识别，识别到的硬盘参数是否正确；BIOS中对IDE通道的传输模式设置是否正确（最好设为“自动”）；
b) 显示的硬盘容量是否与实际相符、格式化容量是否与实际相符（注意，一般标称容量是按1000为单位标注的，而BIOS中及格式化后的容量是按1024为单位显示的，二者之间有3%~5%的差距。另格式化后的容量一般会小于BIOS中显示的容量）。硬盘的容量根据系统所提供的功能（如带有一键恢复），应比实际容量小很多，缩小的值请参看用户手册中的相关说明；
c) 检查当前主板的技术规格是否支持所用硬盘的技术规格，如：对于大于8GB硬盘的支持、对高传输速率的支持等；
C. 硬盘逻辑结构检查：参考启动类故障判断要点中的相关部分。
a) 检查磁盘上的分区是否正常、分区是否激活、是否格式化、系统文件是否存在或完整；
b) 对于不能分区、格式化操作的硬盘，在无病毒的情况下，应更换硬盘。更换仍无效的，应检查软件最小系统下的硬件部件是否有故障；
c) 必要时进行修复或初始化操作，或完全重新安装操作系统；
D. 系统环境与设置检查：参考启动类故障判断要点中的相关部分。
a) 注意检查系统中是否存在病毒，特别是引导型病毒（如用查KV3000 /K命令，或用MEM.EXE命令等进行检查）；
b) 认真检查在操作系统中有无第三方磁盘管理软件在运行；设备管理器中对IDE通道的设置是否恰当；
c) 是否开启了不恰当的服务。在这里要注意的是，ATA驱动在有些应用下可能会出现异常，建议将其卸载后查看异常现象是否消失；
E. 硬盘性能检查：
a) 当加电后，如果硬盘声音异常、根本不工作或工作不正常时，应检查一下电源是否有问题、数据线是否有故障、BIOS设置是否正确等，然后再考虑硬盘本身是否有故障；
b) 应使用相应硬盘厂商提供的硬盘检测程序检查硬盘是否有坏道或其它可能的故障；
F. 对于关于硬盘保护卡所引起的问题，应从以下几方面考虑：
a) 安装硬盘保护卡，应注意将CMOS中的病毒警告关闭、将CMOS中的映射地址设为不使用（disable）、将CMOS中的第一启动设备为设为LAN；光驱和硬盘应接在不同的IDE数据线上。
b) 如果忘记的硬盘保护卡的管理员密码，对于1.0版ALT+133，ALT+144，ALT+155，弹出10组数（必须用小键盘），对于3.0版，在管理员密码处输入ENPQ，得到一组数据，然后拨打800，来得到密码；
c) 装有硬盘保护卡的机器，开机出现红屏现象，应使用专用的工具程序解决。方法请参阅相关的《技术工程信息通报》；
d) 对于在某个引导盘下，看不到某些数据盘的情况，要检查：这些数据盘是否为该引导盘专属的数据盘；分区类型是否为引导盘的操作系统所识别；在大于8GB的硬盘上，在8GB之后是否建立了属于该引导盘的FAT16分区（当然引导盘支持FAT16文件系统）；该引导盘的专属分区是否多于3 个；
e) 硬盘保护卡不起保护功能，要检查用户是否关闭了硬盘保护功能，要启用硬盘保护功能，可在进入系统前按一下F4来启用（事先应已安装过），如果不行，可重新插拔一下硬盘保护卡。在Windows下，则应检查其驱动软件是否已安装；
f) 当启有了硬盘保护功能后，硬盘上原来的系统不被保留，应询部用户原系统是否是用第三方软件进行的分区。目前硬盘保护卡只能保护用操作系统自带的FDISK进行分区的系统；
g) 在硬盘保护模式为每次还原，如果由于未正常关机，而出现多次提示进行磁盘扫描，应在管理员模式下，在Msdos.sys文件中加入autoscan=0的项；
h) 对于在使用者模式下，出现乱码的现象，需在管理员模式下运行升级盘中的SETUP.EXE；
3、 软盘驱动器
1) 环境检查
A. 软驱的在一定情况下，类似于硬盘的检查方法。
B. 检查软驱的连接：
a) 连接电缆安装是否正确，不应有插错或插反的现象；
b) 软驱连接的位置，应与BIOS中设置的值相符；
c) 软驱的电源连接是否正确。
C. 软驱外观检查
a) 软驱中是否有异物；
b) 电路板上及其元器件是否有变形、变色、异味等现象。
D. 所使用的软盘介质的质量是否太差；
2) 故障判断要点
A. 软驱的检查，应在软件最小系统中加入软驱，或去掉硬盘后进行检查判断。且在必要时，移出机箱外检查；
B. 类似硬盘驱动器的检查。但要注意：BIOS中对软驱是否可读写的设置是否为允许或禁止；
C. 检查软驱的读、写能力，一方面是自身读写能力的检查，另一方面是软盘的互换读写能力的检查，即在可能有故障的软驱中写过的软盘能否在另一正常的软驱中读出。如果不能，更换软驱；
D. 软盘是最易感染病毒的介质，因此的检查中，一定要注意对病毒的检查。
4、 光盘驱动器
1) 环境检查
A. 检查光驱连接：
a) 光驱上的ID跳线是否正确，它应与连接在线缆上的位置匹配；
b) 连接光驱的数据线是否接错或接反；
c) 光驱连接线是否有破损或硬折痕。可通过更换连接线检查；
d) 光驱连接线类型是否与光驱的技术规格要求相符；
e) 光驱电源是否已正确连接，不应有过松或插不到位的现象。
B. 光驱外观检查：
b) 光驱电路板上的元器件是否有变形、变色，及断裂缺损等现象；
c) 光驱电源插座之接针是否有虚焊或脱焊现象；
d) 加电后，光驱自检时指示灯是否不亮或常亮；工作时指示灯是否能正常闪亮；
e) 加电后，要倾听光驱驱动器的运转声音是否正常，不应有异常的声响及过大的噪音。
2) 故障判断要点
A. 光驱的检查，应用光驱替换软件最小系统中的硬盘进行检查判断。且在必要时，移出机箱外检查。检查时，用一可启动的光盘来启动，以初步检查光驱的故障。如不能正常读取，则在软件最小系统中检查。最先考察的是光驱；
B. 类似硬盘驱动器的检查方法；
C. 光驱性能检查：
a) 对于读盘能力差的故障，先考虑防病毒软件的影响，然后用随机光盘进行检测，如故障复现，更换维修，否则根据用户的需要及所见的故障进行相应的处理；
b) 必要时，通过刷新光驱的formware检查不驱的故障现象是否消失（如由于光驱中放入了一张CD光盘，导致系统第一次启动时，光驱工作不正常，就可偿试此方法）；
D. 操作系统中配置检查：
a) 在操作系统下的应用软件能否支持当前所用光驱的技术规格；
b) 设备管理器中的设置是否正确，IDE通道的设置是否正确。必要时卸载光驱驱动重启，以便让操作系统重新识别。
五、本类故障的判断流程
见附录一之（三）。
六、案例
案例一:
问题描述：小王是一家公司的计算机维护人员，办公用机为联想的奔月2000机型，13G硬盘，由于长时间电脑中系统和数据未进行维护，系统启动和运行都比较慢，将C盘上的重要数据复制到D盘，之后运行联想的系统恢复软件，将隐藏分区里的Windows98SE系统复制到C盘上。10分钟不到恢复完毕，再次重新启动，正常进入Windows98系统。但是进入系统后，发现原来用PM划分的扩展分区不见了大量的数据资料都在扩展分区中，如何是好？小王陷入尴尬的境地……
解决方案：首先查看联想机器随机资料，说明书上写着“可能对PM等的分区格式不支持，分区时请用Fdisk……”，可能是进行系统恢复时破坏了原来的硬盘分区表，有没有什么办法解决呢？开机进入MSDos或者进入PM，出了一个主分区和一个扩展分区没有其他的分区信息，这时想到软件Diskman，进入MSDos，运行Diskman，首先警告说分区表有误，Diskman虽然仍然把硬盘识别成两个分区，但它还有重新检测分区表的功能。重新检测分区表有全自动和交互两种方式，选择后者，Diskman就开始逐柱面检测硬盘上原已存在的分区表。过了很长的时间，原有的三个分区包括联想系统恢复软件隐藏的备份分区都被检测了出来，保持分区格式，一切正常。
点评：用户应用中或是在用户对硬盘分区时断电都会导致硬盘分区表的错误，遇到此种问题时不要着急，要分析问题的原因，查看相关的资料，如相关软件和计算机附带的资料，借助相关的软件或工具解决，若是对硬盘的工作原理、相关软件或工具的应用不是很了解，一定要查找相关资料或是向人询问。
注：Diskman硬盘分区表维护软件，运行于MSDOS环境，采用全中文图形界面，无须任何汉字系统支持。以图表的形式揭示了分区表的详细结构，支持鼠标操作，支持8G以上的大硬盘和UNIX、NTFS等多种分区格式等。

案例二：
问题描述：一用户天禧二5311机型，用户反映用随机的软件NTI CD-Maker Plus中的FileCD工具格式化可擦写光盘的时候(明基CD-RW)，进度很快到100％，但是没有格式化完毕的提示，强行关闭对话框也无法关闭。最后等了只得结束任务。用NTI CD-Maker Plus刻录硬盘，刻录过程中显示刻录进度，并提示刻录完毕后，将刻录好的光盘放入光驱，提示无法识别光盘。
解决方案：首先考虑是NTI CD-Maker中的插件FileCD的软件问题，升级NTI CD-Maker软件到V5.08，V5.13,都没能解决，升级到V5.15现象依旧，再看FileCD的版本和用户原机的FileCD的版本一样，为2.0.10后续的版本并未在擦写光盘的功能上有所改进。考虑选用另外的刻录软件，用NERO来进行测试（版本为V5.5.9.0），用该软件执行快速擦写后再对光盘进行刻录，依旧发生上述的现象。但是用SONY的CD-RW光盘则无此问题。
点评：擦写光盘时和刻录软件及刻录机都有很大的关系，请工程师在解决问题时可以从多个角度考虑问题。

案例三：
问题描述：一用户光驱过保，用户自行购买光驱，据用户称在市场上购买光驱时进行测试，光驱没有任何问题，测试的数据盘和VCD等光盘都可以正常读出，但是回到家加装光驱后，开机进入系统，所有放入光驱中的碟片在驱动器的盘符上都只显示CD样的标记。用户回到购买处将光驱安装到测试机器上，问题复现。
解决方案：经过检查发现，光驱的数据接口上一根数据线弯，导致驱动器中数据无法正常识别。


第四章 显示类故障

一、定义举例
这类故障不仅包含由于显示设备或部件所引起的故障，还包含有由于其它部件不良所引起的在显示方面不正常的现象。也就是说，显示方面的故障不一定就是由于显示设备引起的，应全面进行观察和判断。
二、可能的故障现象
1、 开机无显、显示器有时或经常不能加电；
2、 显示偏色、抖动或滚动、显示发虚、花屏等；
3、 在某种应用或配置下花屏、发暗（甚至黑屏）、重影、死机等；
4、 屏幕参数不能设置或修改；
5、 亮度或对比度不可调或可调范围小、屏幕大小或位置不能调节或范围较小；
6、 休眠唤醒后显示异常；
7、 显示器异味或有声音。
三、可能涉及的部件
显示器、显示卡及其它们的设置；主板、内存、电源，及其它相关部件。特别要注意计算机周边其它设备及地磁对计算机的干扰。
四、判断要点/顺序
1、 维修前的准备
相应显示卡的最新版驱动程序
2、 环境检查
1) 市电检查：
A. 市电电压是否在220V±10%、50Hz或60Hz；市电是否稳定；
B. 其余参考加电类故障中有关市电检查部分。
2) 连接检查：
A. 显示器与主机的连接牢靠、正确（特别注意，当有两个显示端口时，是否连接到正确的显示端口上）；电缆接头的针脚是否有变形、折断等现象，应注意检查显示电缆的质量是否完好；
B. 显示器是否正确连接上市电，其电源指示是否正确（是否亮及颜色）；
C. 显示设备的异常，是否与未接地线有关。特别注意：不允许电脑维修工程师为用户安装地线，应请用户通过正式电工来安装；
3) 周边及主机环境检查：
A. 检查环境温、湿度是否与使用手册相符（如钻石珑管，要求的使用温度为18~40C）；
B. 显示器加电后是否有异味、冒烟或异常声响（如爆裂声等）；
C. 显示卡上的元器件是否有变形、变色，或温升过快的现象；
D. 显示卡是否插好，可以通过重插、用橡皮或酒精擦拭显示卡（包括其它板卡）的金手指部分来检查；主机内的灰尘是否较多，进行清除；
E. 周围环境中是否有干扰物存在（这些干扰物包括：日光灯、UPS、音箱、电吹风机、相靠过近（50厘米以内）的其它显示器，及其它大功率电磁设备、线缆等）。注意显示器的摆放方向也可能由于地磁的的影响而对显示设备产生干扰；
F. 对于偏色、抖动等故障现象，可通过改变显示器的方向和位置，检查故障现象能否消失。
4) 其它检查及注意事项：
A. 主机加电后，是否有正常的自检与运行的动作（如有自检完成的鸣叫声、硬盘指示灯不停闪烁等），如有，则重点检查显示器或显示卡；
B. 禁止带电搬动显示器及显示器方向，在断电后的一段时间内（2~3分钟）也最好不要搬动显示器。
3、 故障判断要点
1) 调整显示器与显示卡：
A. 通过调节显示器的OSD选项，最好是回复到RECALL（出厂状态）状态来检查故障是否消失。对于液晶显示器，需按一下auto config按钮；
B. 显示器的参数是否调得过高或过低（如H/V-MOIRE，这是不能通过RECALL来恢复的）；
C. 显示器各按钮可否调整，调整范围是否偏移显示器的规格要求；
D. 显示器的异常声响或异常气味，是否超出了显示器技术规格的要求（如新显示器刚用之时，会有异常的气味；刚加电时由于消磁的原因而引起的响声、屏幕抖动等，但这些都属正常现象）。有关显示器的规格，请见附录二之（二）；
E. 显示卡的技术规格是否可用在主机中（如AGP 2.0卡是否可用在主机的AGP插槽中等）。
2) BIOS配置调整：
A. BIOS中的设置是否与当前使用的显示卡类型或显示器连接的位置匹配（即是用板载显示卡、还是外接显示卡；是AGP显示卡还是PCI显示卡）；
B. 对于不支持自动分配显示内存的板载显示卡，需检查BIOS中显示内存的大小是否符合应用的需要；
以下的检查应在软件最小系统下进行。
3) 检查显示器/卡的驱动：
A. 显示器/卡的驱动程序是否与显示设备匹配、版本是否恰当；
B. 显示器的驱动是否正确，如果有厂家提供的驱动程序，最好使用厂家的驱动；
C. 是否加载了合适的Direct X驱动（包括主板驱动）；
D. 如果系统中装有Direct X驱动，可用其提供的Dxdiag.exe命令检查显示系统是否有故障。该程序还可用来对声卡设备进行检查。
4) 显示属性、资源的检查：
A. 在设备管理器中检查是否有其它设备与显示卡有资源冲突的情况，如有，先去除这些冲突的设备；
B. 显示属性的设置是否恰当（如：不正确的监示器类型、刷新速率、分辨率和颜色深度等，会引起重影、模糊、花屏、抖动、甚至黑屏的现象）；
5) 操作系统配置与应用检查：
A. 系统中的一些配置文件（如：System.ini文件）中的设置是否恰当；
B. 显示卡的技术规格或显示驱动的功能是否支持应用的需要；
C. 是否存在其它软、硬件冲突。
6) 硬件检查：
A. 当显示调整正常后，应逐个添加其它部件，以检查是何部件引起显示不正常；
B. 通过更换不同型号的显示卡或显示器，检查是否存在它们之间的匹配问题；
C. 通过更换相应的硬件检查是否由于硬件故障引起显示不正常（建议的更换顺序为：显示卡、内存、主板）。
五、本类故障的判断流程
见附录一之（四）。
六、案例
案例一：
问题描述：碰到过这样的一台机器，现象比较怪，机型为奔月2000 PIII/800，故障为经常性的开机无显，有时能显示进入系统，但使用1-2小时会出现死机，重启又无显示，只有过很长时间再开机，才可以显示。
解决方案：碰到此问题，首先断定应为硬件问题，打开机箱，查看各板卡并无松动（注：显卡与主板插槽上的联想贴条，粘得很紧），换件试吧，先后更换过内存、CPU、电源，均不能解决问题，再换主板吧，拆撕显卡与主板插槽的联想贴条时，感觉到显卡没插到位，向下按，还能再进去一点，遂怀疑是不是显卡与主板接触不良所致，于是又把机器的原部件全都还原，试机，一切正常。
后记：此案例就是因为显卡的接触不良，而造成的奇怪故障，在维修中因为检测时的疏漏（只查看显卡是否插紧，而未实际动手检查一下），造成了维修过程的繁琐。

案例二：
问题描述：一台奔月机器，用户称每次启动都无法进入WIN98，光标停留在屏幕左上角闪动，死机；但安全模式可以进入。
解决方案：怀疑为显卡或监视器设置不当所致，进入安全模式把显示分辨率设为640*480，颜色设为16色，重启，能以正常模式进入，但只要改动一下分辨率或颜色，则机器就不能正常启动；察看机器内部，除用户自加一块网卡外，别无其它配置，难道是网卡与显卡发生了冲突？拔掉网卡，能正常启动WIN98，给网卡换个插槽，开机检测到新硬件，加载完驱动，启动，一切正常。
后记：由于显卡与其它部件不兼容或冲突造成的死机，完全可以先采用最小系统化的方法来测试（最小系统化法即只保留主板、CPU、显卡、电源等主要部件），先排除主要的部件，再逐一检测其它扩展卡。

案例三：
问题描述：三角洲部队-大地勇士，在810（e）系列主板的机器上运行（同禧、逐日系列），如用随机带的显卡驱动程序安装（而用随机盘进 行驱动的安装又是我们一贯的作风），在进入游戏画面时，必然会导致死机。
解决方案：解决方法就是从网上下载新版本的驱动，进行升级。
后记：如果在实际维修中遇到玩3D游戏死机的故障，估计可能是显卡故障，而又无备件替换时（这在我们上门维修中，是经常遇到的），不妨从网上下载一个Direct control软件，通过它屏蔽掉AGP支持。再玩3D游戏，如不出现死机，说明问题很可能出在别处（如主板、内存）。如死机，则在很大程度上说明，这块显卡是有故障的了。

案例四：
故障描述: 开天2200 P4/1.7G （为QDI P7LI-AL主板），在运行华光超恩组版软件时（带一ISA加密卡），如进行放大显示，则左边界线无法显示。
解决方案: 用户新购机器，代理商在为用户安装超恩组版软件时，出现问题。换一新机，故障依旧，代理判断为华光ISA卡与此机型不兼容，让维修站上门解决。到用户处，复现故障，插一PCI显卡则显示正常，估计不为机器故障。在系统属性—性能—图形中，把硬件加速调低两格，问题解决。


第五章 安装类故障

一、定义举例
这类故障主要是反映在安装操作系统或应用软件时出现的故障
二、可能的故障现象
1、 安装操作系统时，在进行文件复制过程中死机或报错；在进行系统配置时死机或报错；
2、 安装应用软件时报错、重启、死机等（包括复制和配置过程）；
3、 硬件设备安装后系统异常（如黑屏、不启动等）；
4、 应用软件卸载后安装不上，或卸载不了等。
三、可能涉及的部件
磁盘驱动器、主板、CPU、内存，及其它可能的部件、软件。
四、判断要点/顺序
1、 维修前的准备
1) 注意携带磁盘数据线；
2) 相适应的最新版设备驱动程序。
2、 环境检查
1) 软件安装
A. 检查硬件设备的连接与外观：
a) 检查与主机连接的其他设备工作是否正常；
b) 设备间的连接线是否接错或漏接。连接插头、座的接针是否有变形、缺失、短路等现象；
c) 仔细检查报错信息，判断可能造成故障的部位；
d) 观察系统是否有异味，元器件的温度；
e) CPU风扇的转速是否过慢或不稳定；
f) 驱动器工作时是否有不正常的声响。
B. 其它方面检查：
a) 认真对照软件的使用手册，确认机器的软、硬件配置符合该手册的要求；
b) 仔细观察安装介质是否完好。
2) 设备安装
A. 检查设备的连接与外观：
a) 要安装的设备、部件是否连接正确，连接电缆是否完好、接针是否有缺针、断针、或短接的现象；
b) 要安装的设备、部件的制作工艺是否优良；
c) 余类似上述软件安装。
B. 驱动程序介质检查：用于安装设备的驱动程序介质是否完好。
3、 故障判断要点
1) 操作系统安装：
A. 检查CMOS中的设置：
a) 如果需要，请先恢复到出厂设置；
b) 关闭BootEasy功能、关闭防病毒功能，及关闭BIOS防写开关；
c) 特别注意硬盘的参数、CPU的温度等。注意观察自检时显示出来的信息是否与实际的硬件配置相符。
B. 安装介质与目标介质检查：
a) 检查是否有病毒；
b) 检查分区表是否正确、分区是否激活。使用Fdisk /mbr命令来确保主引导记录是正确的（注意使用此命令后，如果机器不能启动，可证明原系统中存在病毒或有错误。硬盘应做初始化操作）；
c) 检查系统中是否有第三方内存驻留程序。
以下过程，建议在软件最小系统下检查（注：在最小系统下，需要添加与安装有关的其它驱动器）。
C. 安装过程检查：
a) 如果在复制文件时，报CAB等文件错，可偿试将原文件复制到另一介质（如硬盘）上再行安装。如果正常通过，则原安装介质有问题，可去检查介质及相应的驱动器是否有故障；若仍然不能复制，应检查相应的磁盘驱动器、数据线、内存等部件；
b) 如果是采用覆盖安装而出现上述问题，建议如果更换安装介质后仍不能排除故障，应先对硬盘进行初始化操作，再重新安装（初始化操作时，最好将硬盘分区彻底清除后进行）。如果仍不能解决，再考虑硬件；
c) 安装过程中，在检测硬件时出现错误提示、蓝屏或死机等，一是通过多重新启动几次（应该是关机重启），看能否通过；另一是在软件最小系统下检查是否能通过。如果不能通过，应该依次检查软件最小系统中的内存、磁盘、CPU（包括风扇）、电源等部件；如果能正常安装，则是软件最小系统之外的部件的故障或配置问题，这可通过在安装完成后，逐步添加那些部件，并判断是否有故障或配置不当；
D. 硬件及其它应注意的问题：
a) 如果安装系统时重启或掉电，要求在软件最小系统下进行测试。如果故障消失，在安装好系统以后，将软件最小系统之外的设备逐一接上，检查故障是由哪个部件引起，并用替换法解决；如果故障不能消失，应检查软件最小系统中的电源、主板和内存，甚至磁盘驱动器；
b) 在IDE设备上安装诸如UNIX操作系统时，或要安装多个操作系统时，要注意：一是8.4GB 限制（UNIX的开始部分必须在8.4GB之内）——这一条在SCSI设备上无这一要求；另一是多操作系统间的安装顺序及配合关系；
E. 对于LEOS的安装应注意以下几点：
a) 确保主板BIOS支持LEOS，建议在为用户更换主板后首先就要刷新支持LEOS的BIOS；
b) 如果为用户更换硬盘，也要注意备件硬盘是否正确支持DMA66。否则在安装LEOS时也会出现问题；
c) LEOS最好是在一块全新未被分区的硬盘上进行安装。具体顺序可以参考如下方案：新硬盘-〉安装LEOS->分区（Fdisk）->安装操作系统（Windows XP）-〉制作一键恢复。如果原硬盘存在分区，可以使用Clear.com程序清楚后再安装LEOS。
2) 应用软件安装：
A. 检查安装应用软件问题时应注意的问题：
a) 应用软件的安装问题，部分可参考上述的操作系统安装的检查方法；
b) 在进行安装前，要求先备份注册表，再进行安装；
B. 软件间、软硬件间的冲突检查：
a) 可采用两种软件问题隔离的方法。一是在软件最小系统下，关闭正在运行的应用程序，然后安装需要的应用软件；另一是在原系统下直接关闭正在运行的应用程序，然后安装需要的应用软件。关闭已有的应用的方法是：使用msconfig禁用启动组、autoexec.bat、config.sys、win.ini、system.ini中在启动时调用的程序；
b) 使用任务管理器，检查系统中有无不正常的进程，并给予杀除；
c) 对于基本满足软件技术手册要求但安装不上的情况，看能否通过设置调整来解决。如果不能解决，则视为不兼容；
d) 利用其它机器（最好是不同配置的），检查是否存在软、硬件方面的兼容问题；
e) 检查系统中是否已经安装过该软件，如果已经安装过应先将其卸载后再安装，如果无法正常卸载，可以手动卸载或通过恢复注册表来卸载（对于Windows XP可使用系统还原功能来卸载）；
f) 必要时，可从网络上查阅相关资料，之后再与软件厂商联系，看是否有其他的注意事项。
C. 硬件检查：
在以上的步骤都不奏效时可考虑硬件问题，应检查光驱、安装介质、硬盘线等配件。
3) 硬件设备安装：
A. 冲突检查：
a) 所安装的设备、部件是否在系统启动前的自检过程中识别到，或能由操作系统识别到（非即插即用识备除外）。如果不能识别，应检查BIOS设置及设备本身，包括跳线及相应的插槽或端口；
b) 检查新安装的设备与原系统中的设备是否有冲突；通过改变驱动的安装顺序、去除原系统中的相应部件或设备、更换插槽，看故障是否消除。如果不能消除，则为不兼容；
c) 加装的设备是否与现有系统的技术规格或物理规格匹配；
d) 检查当前系统中的一些设置（主要是.ini文件中的设置）是否与所安装的部件或设备驱动有不匹配的地方；
B. 驱动程序检查：所安装的设备驱动是否为合适的版本（即，不一定是最新的）；
C. 硬件检查：
a) 所安装的部件或设备是否本身就有故障；
b) 检查原系统中的部件是否有不良的现象（如插槽损坏、供电能力不足等）。
五、本类故障的判断流程
见附录一之（五）。

六、案例
案例一：
问题描述：用户报修天禧6620机器，在安装98过程中，提示剩余三分钟时。Hwinfo报错，无法正常安装。
解决方案：工程师上门后，经过检测，确实存在用户反应的问题。然后尝试将安装文件拷贝到硬盘上安装和换一张安装盘安装，故障依旧。接着检查BIOS发现，系统日期是2075年。将日期改回后，故障排除。问题虽小，影响却大。在此，提醒各位同仁，做事要细心，不要忽略每个细节。

案例二：
问题描述：逐日2000机器，一次突然死机，不能启动，重装系统能成功，但在设备管理里有很多问号，如打印口，COM口等都没有驱动。
解决方案：在站内又重装系统，驱动主板不能解决问题，看来只有更换主机才行了。打开机箱，发现有很多灰尘，取出主板，进行大扫除，抱着试一试的心里，重装一切OK。

案例三：
问题描述：一用户奔月4000机器/PIII 1G，他是单位技术员，说此机不能重装系统，每次重装都死机，要求上门维修。
解决方案：到达用户处，发现重装到检测硬件时无反应，打开机器进行检查时，发现CPU风扇不是联想。客户说这是刚从市场上拿来的，新的，应没有问题。依次替代硬盘与内存没有用，经用户同意带回站内烤机，再换下主板与CPU还是不行，后经多次重试发现每次死时间越来越短，怀疑还是CPU风扇有问题。换其它联想机器上的风扇竟解决问题。引起故障原因是客户的CPU风扇转速不够，引起温度过高死机。


第六章 操作与应用类故障

一、定义举例
这类故障主要是指启动完毕后到关机前所发生的应用方面及系统方面的故障。
二、可能的故障现象
1、 休眠后无法正常唤醒；
2、 系统运行中出现蓝屏、死机、非法操作等故障现象；
3、 系统运行速度慢；
4、 运行某应用程序，导致硬件功能失效；
5、 游戏无法正常运行；
6、 应用程序不能正常使用。
三、可能涉及的部件
主板、CPU、内存、电源、磁盘、键盘、接插的板卡等
四、判断要点/顺序
1、 维修前的准备
1) 干净的可用硬盘；
2) 杀毒软件；
3) 尽可能新的驱动程序、若干版本的BIOS；
4) 磁盘连接的数据线等。
2、 环境检查
1) 市电及连接检查：
A. 检查市电是否正常，连接是否牵靠；是否有接地；
B. 设备间的连接线是否接错或漏接。
2) 周边及外观检查：
A. 检查与主机连接的其他外设工作是否正常；
B. 驱动器工作时是否有异响，CPU风扇的转速是否过慢或不稳定；
C. 观察机箱内灰尘是否太多，而导致各插接件间接触不良。先除尘后可用橡皮等擦拭金手指，去除氧化层或灰尘。然后重新插上；
D. 观察系统是否有异味，元器件的温升是否过高或过快。
3) 显示与设置检查：
A. 详细记录报错信息，判断可能造成故障的部位；
B. 注意CMOS中对于硬盘、系统时间、CPU温度的设置，注意在自检时显示的硬件信息和机器配置是否相符；
C. 仔细阅读软件的使用指南，注意软件运行的环境要求。
4) 充分与用户沟通：
A. 了解用户的使用情况；
B. 出故障前的现象；
C. 做过什么操作才出现目前的故障。
根据以上了解的情况，来初步判断可能的故障原因。
3、 故障判断要点
1） 检查是否由于用户误操作引起
A. 机器出现死机、蓝屏或无故重启时，首先要考虑到用户的操作是否符合操作规范和要求，要仔细询问、观察用户的操作方法是否符合常理，并由工程师用正确的方法操作、应用用户的机器，查看是否出现用户所报修的故障。若不出现，则可认为是用户操作不当引起的，由工程师向用户解释并演示正确的操作方法。
B. 若经过上述操作故障依然存在，可用系统文件检查器检查用户的机器系统是否有丢失的DLL文件，并尝试恢复。
C. 注意观察用户的机器在死机、蓝屏或无故重启时有没有规律，并找出可能引起机器故障的原因（如机器在运行某一程序时或机器开机在一定时间内死机）。
D. 通过与另一台软硬件相同且无故障的机器进行比较，查看故障机的文件大小是否相同或相差不大，主程序的版本是否一致。
2） 检查是否由于病毒或防病毒程序引起故障
A. 检查用户的机器是否被病毒感染，使用杀毒软件杀毒；
B. 检查用户是否安装了两个或两个以上的防毒软件，建议用户使用其中一个，并卸载其他的防毒软件；
C. 检查是否有木马程序，用最新版的杀毒程序可以查出木马程序。可以通过安装补丁来弥补程序中的安全漏洞，或者安装防火墙。
3） 检查是否由于操作系统问题引起故障
A. 检查硬盘是否有足够的剩余空间，并检查临时文件是否太多。整理硬盘空间，删除不需要的文件；
B. 对于系统文件损坏或丢失，可以使用系统文件检查器进行检查和修复；
C. 检查操作系统是否安装了合适的系统补丁（对于Winnt可在启动时观察service pack的版本，推荐使用SP6；Win2k和Winxp可以在系统属性中查看，Win2k推荐使用SP3，Winxp推荐使用SP1。）；
D. 检查DirectX驱动是否正常，升级DirectX的版本；
E. 检查是否正确安装了设备的驱动程序，并且驱动的版本是否合适。检查驱动安装的顺序是否正确（例如：首先安装主板驱动）。
4） 检查是否由软件冲突、兼容引起故障
A. 检查用户应用软件的运行环境是否与现有的操作系统（NT/98/2K/XP）相兼容，可通过查看软件说明书或到应用软件网页上查找相关资料，并查看网页上有没有对于此软件的升级程序或补丁可安装。
B. 可用任务管理器观察故障机器的后台是否有不正常的程序在运行，并尝试关闭程序只保留最基本的后台程序。
C. 注意查看故障机内是否有共用的DLL文件，可通过改变安装顺序或安装目录来解决问题。
5） 检查硬件设置是否不正确
A. 首先，检查CMOS设置是否正确，可恢复默认值；
B. 在设备管理器中检查硬件是否正常，中断是否有冲突，如有冲突，调整系统资源（对于某些硬件，要阅读说明书，按照说明正确设置硬件）；
C. 在设备管理器中将硬件驱动删除，重新安装驱动程序（最好安装版本正确的驱动程序），查看硬件驱动是否恢复正常；
D. 运行硬件检测程序，如AMI等检测硬件是否有故障；
E. 在软件最小系统情况下， 重新更新硬件驱动，观察故障是否消失。
6） 检查是否为兼容问题
A. 遇到兼容性问题时，应检查硬件的规格和标准（如同时使用多条内存时检查内存是否为同一厂家、同一规格、同一容量、内存颗粒同一批次），是否允许在一起使用。
B. 阅读说明书或到网页上查找相关资料，检查用户的硬件正常使用所需的软件要求，现在的软件环境是否符合要求，软硬件之间是否相互支持。
C. 在设备管理器中检查用户的系统资源是否有冲突，如有冲突，手动调整系统源。
D. 在设备管理器中检查用户机器的硬件的驱动是否安装正确，更新合适版本的设备驱动（如某些显卡用WIN2000或WINXP自带的公版驱动，会造成某些大型3D游戏无法运行）；
E. 检查维修BOM，去除非联想的硬件，检查系统是否可正常工作，如可正常工作，建议用户更换自行添加的硬件或查找硬件相关资料进行解决。
7） 检查是否由于网络故障引起
A. 碰到机器连接在网络上，出现死机、运行慢、蓝屏等故障时，应首先关闭网络，与网络环境隔离，观察故障是否消失，如故障消失，则为网络问题引起故障。
B. 确为网络问题引起的故障，其判断与解决步骤参考网络部分。
8） 检查是否由于硬件性能不佳或损坏引起
A. 使用相应的硬件检测程序，检查硬件是否有故障，如果有，利用替换法排除相应的硬件；
B. 用替换法检查检测程序无法判断的硬件故障。


第七章 局域网类故障

一、定义举例
这类故障主要涉及局域网宽带网等网络环境中的故障。
二、可能的故障现象
1、 网卡不工作，指示灯状态不正确；
2、 网络连不通或只有几台机器不能上网、能Ping通但不能连网、网络传输速度慢；
3、 数据传输错误、网络应用出错或死机等；
4、 网络工作正常，但某一应用下不能使用网络；
5、 只能看见自己或个别计算机；
6、 无盘站不能上网或启动报错；
7、 网络设备安装异常。
8、 网络时通时不通。
三、可能涉及的部件
网卡、交换机（包括HUB、路由器等）、网线、主板、硬盘、电源等相关部件。
四、判断要点/顺序
1. 维修前的准备
1) 可用的网线（直连线和普通网线，线序符合国际标准）；
2) 如有条件，带上网线连接检查器。
2. 环境检查
1) 电源连接检查：
A. 市电的接线定义是否正确；
B. 是否有地线；
C. 网络上的各设备（如：HUB、交换机等）是否均已上电工作。
2) 网线连接检查：
A. 网线连接线序是否与网络连接的要求匹配（如直连和普通网线）；
B. 网线的连通性是否正常，要查看网线有无破损、过度扭曲；
C. 网线长度是否过长（如5类双绞线长度超过技术规格要求的100米）；
D. 网线接头——水晶头是否完好、是否氧化；
E. 网卡接口是否完好。重新插拨网线检查网线与网卡连接是否松动；
F. 根据电缆要求是否有终结器，终结器是否正常。
3) 网络设备外观及周边检查：
A. 加电启动后，网卡指示灯是否亮等；
B. HUB等设备的网线接口，在与终端或服务器连接后，如果终端或服务器启动及配置正常，其指示灯会亮（注意指示灯颜色是否正常，参考设备说明书），如果指示灯不亮，说明设备有故障；
C. 网卡部件是否接插到位无翘起，网卡上金手指是否氧化；
D. 网线或交换机等设备周围是否有干扰。
4) 主机外观检查：
A. 检查机箱内是否有异物造成短路；
B. 机箱内的灰尘是否过多，如果是，应清理灰尘；
C. 主板与网卡上元器件是否有变形、变色现象；
D. 加电后，注意部件、元器件及其它设备是否有异味、温度异常等现象发生。
5) 其它方面：
A. 在UNIX下，要分清是终端死机还是服务器死机
3. 故障判断要点
1) 寻求用户网管的配合。
首先应尽可能与网管联系，以得到网管合作。
2) 网络环境检查：
A. 对于掉线、丢包等故障，要注意检查网卡与交换机间的兼容性；
B. 网络连接正常，但不能进行域登录，要从以下几点检查：
a) 指明的域名是否存在或已工作；
b) 是否已按服务器、操作系统的要求（如在服务器端启用了WINS解析服务、DNS服务等，WINXP HOME版不能登录到域中。），设置终端允许登录到域中，计算机名是否已注册到域中；
c) 检查使用的协议是否正确；
C. 检查是否安装了防火墙，是否被授权访问；
D. 在必要时，使用直连线只连接两台机器在对等网环境下检查是否可连网（这样做可排除网络上诸环境因素的影响）。
3) 网络适配器驱动与属性检查：
A. 驱动程序是否正确、合适。网卡设备建议由系统自动识别，并尽可能使用与操作系统匹配和更新的驱动程序（只有老型号的ISA网卡才可使用手动安装的方法进行驱动的安装）。在安装驱动程序时，如有必要，可将启动中加载的和正在运行的程序关掉，再行安装；
B. 网卡在某一网络环境下工作不正常，可调整网速，如对于10/100Mbps的网卡，如果工作在10Mbps的网络环境下，网络工作不正常，应特别指定网卡工作在10Mbps的速度上；
C. 检查网络通信方式，如是否为全双工等。
4) 网络协议检查：
A. 检查网络中的协议等项设置是否正确（不管用哪种协议，必须保证网内的机器使用的协议一致）。网络中是否有重名的计算机名；
B. 如果不能看到自己或其它计算机，先通过按F5多刷新几次来检查，然后检查是否安装并启用了文件和打印共享服务、是否添加了NETBEUI协议（如果网络环境中有WINS服务器，则不需添加，如没有则要添加）；
C. 如能ping通网络，但不能在网上邻居中访问其它终端或服务器，可用ipconfig /all（在命令行方式）、netstat等命令查看具体信息，检查网络属性的设置，如域、工作组等，并进行相应的更改；
D. TCP/IP协议的实用程序ping命令，可用来检查网络的工作情况。这需要维修人员了解TCP/IP协议的相关知识（顺序：PING 127.0.0.1，本机IP、本网段IP、网关、DNS等）；
E. 如果PING不通，可尝试在网络属性中把所有的适配器和协议删除，重启后重新安装；
F. 通过执行tracert <目标IP地址>命令,检查IP包在哪个网段出错；
5) 系统设置与应用检查：
A. 检查机器自检完成后，所列的资源清单中网卡是否被列其中（非PNP网卡除外），其所用资源与其它设备有无共享；
B. 检查系统中是否有与网卡所用资源相冲突的其它设备，如有，可通过更换设备间的安装位置，或手动操作更改冲突的资源。对于ISA总线的网卡，可能需要在CMOS中关掉其所占中断的PnP属性，且其所用资源一般不宜与其它设备共享。较老的PCI设备也不宜与其它设备共享资源；
C. 检查系统中是否存在病毒；
D. 如果某一特定的应用在使用网络时工作不正常，检查CMOS设置是否正确，重点检查网卡的驱动程序是否与其匹配，必要时，关闭其它正在运行的应用程序，及启动中加载的程序，看是否能正常工作，或与能够正常运行该应用的机器进行比较，检查在配置方面有何不同；
E. 通过重新安装系统，检查是否由于系统原因而导致网络工作不正常。
6) 硬件检查：
A. 用网卡自带程序和网卡短路环检测网卡是否完好；
B. 如更换网卡后仍不正常，可更换主板，更换主板仍不能解决时，可考虑更换其它型号网卡；
7) 对于无盘站，注意检查以下几点：
A. BIOS中是否允许了从网络启动，BIOS中最好禁用软驱，将"Report No FDD For Win 95"，由Yes更改为No（或反之。这与软驱的设置有关）
B. 对于ISA网卡，其BIOS的设置，应使BOOT ROM默认的起始地址为D800H 或C800H，I/O为300H（如有些网卡的默认设置为C800H容易与AGP显卡等部件占用的地址资源冲突导致安装失败）。；
C. 在以上操作无效时，对有些主板，屏蔽板载声卡，再根据需要进行相应的修改。
D. 工作站的协议必须与服务器协议一致；
E. 有多台服务器时，必须指定第一响应服务器。
8) 对于无线网络，特别要注意：
A. 检查两台终端间的有效距离是否过大，中间是否有隔离物；
B. 对等网络下，所使用的频率通道是否一致；
C. 在用AP的环境下，终端的网络ESSID必须与AP一致；
D. 检查网卡和AP的密钥的密钥是否相符。
五、本类故障的判断流程
见附录一之（七）。
六、案例
案例一：
问题描述：网卡不工作，指示灯状态不正确；
解决方案：首先观察系统设备管理器中有没有网卡这个设备，若没有则更换网卡或重新插拔网卡测试，并看金手指部分有没有锈迹，若有，则用橡皮擦干净测试。

案例二：
问题描述：局域网内，只有几台机器能连网，大部分不能互访。网卡灯亮，HUB灯闪
解决方案：见到这种情况，要从软硬两个方面来分析，首先：
a、软件方面，使用最新版本的KV3000进行了查、杀病毒工作，没有发现任何病毒，从而排除了病毒干扰的可能性。网络方面，安装了NetBEUI、IPX/SPX和TCP/IP协议，网卡的驱动也正确安装，在设备管理中没有发现任何冲突，并进行了协议绑定。设置了文件、打印机共享，也设定了工作组名称和计算机名称。应该说从网络协议到共享资源设置等均没有问题，可以排除软件方面的错误。
b、从硬件方面分析，大致有四种可能：其一是网线断路，无法形成信号回路；其二是网线的线序是否正确；其三是在集线器与计算机间连接用的网线过长，超过100米；其四集线器端口有问题。针对这四种可能性，逐个进行排除。使用测线工具或万用表测量网线，发现网线连接状况很好，没有断路。通过目测，连接用的网线长度不可能超过100米。将几台网络已连通的计算机接在集线器上的插口换到怀疑损坏的集线器端口上，这几台计算机仍然互通，说明集线器端口没有损坏。
c、通过对网线线序的检查，发现用户的制作的线序是1、2、3、4，问题就出在这儿，因为RJ45插头正确的连接应该是使用1、2、3、6，其中1、2是一对线，3、6是一对线，其余四根线没有定义。查出了问题，只需为用户重新做网线头，插入后网络正常。

案例三：
问题描述：脑在“网上邻居”中只能看到自己，而看不到其他电脑，从而无法使用其他电脑上的共享资源和共享打印机
解决方案：使用ping命令，ping本地的IP地址或主机名，检查网卡和IP网络协议是否安装完好。如果能ping通，说明该电脑的网卡和网络协议设置都没有问题。问题出在电脑与网络的连接上。因此，应当检查网线和Hub及Hub的接口状态，如果无法ping通，只能说明TCP/IP协议有问题。重新设置网络协议，对于10台以下的机器且不上Internet的机器可考虑用NetBEUI协议，若上Intrnet则用TCP/IP协议，不管用哪种协议，必须保证网内的机器使用的协议一样。

案例四：
问题描述：无盘站不能上网或启动报错；
解决方案：
NOVELL无盘工作站不能正常登录服务器有以下几种情况：
    a．工作站屏幕上出现“Error opening boot disk image file ”OR“Unable to open image file”
    这可能是连到了一个没有包含远程启动映像文件的服务器。把启动映像文件拷到这个服务器的Login目录下；如果使用的是多远程启动映像文件，检查Bootconf.sys中对工作站是否进行了正确设置，应确保网络地址和节点地址的正确，如果以上都正确，那么可能是远程启动映像文件有问题，可以测试生成启动映像文件的软盘能否正常启动有盘工作站。若还不行，可以运行一下RPLFIX实用程序。
    b．工作站屏幕上出现“Error finding server”
    在确保硬件线路连接没问题的前提下，检查服务器上是否安装了“Ethernet_802.3”帧类型，远程启动映像文件的net.cfg 中是否包含Ethernet_802.3，这种就是前面所说的旧型的IPX芯片，它不支持Ethernet－802.2帧。按照相应的帧类型重新制作启动映像文件。
    c．工作站在从远程启动映像文件装入网卡驱动时挂起，屏幕并显示下面类似信息：Ethernet card is improperly install or net connected the network.
    这就是由于前面所说的旧式IPX芯片在Netware 4.X以上使用时，在远程启动映像文件中没有RPLODI.com或远程启动映像文件的批处理文件中ISL.com下行没有RPLODI.com行。
    d．工作站显示“Loading MS－DOS”并挂起
    这是由于远程启动映像文件使用了DOS 5．0或以上版本，对远程启动映像的文件运行RPLFIX实用程序。
    e．屏幕上出现“batch file missing”
    出现这个消息是由于autoexec.bat或其它批处理文件（对多个远程启动映像所使用的批处理）没有同时存在于LOGIN目录和用户登录目录。


第八章 Internet类故障

一、定义举例
主要是与浏览Internet有关的软、硬件故障。如：不能拨号、不能浏览网页等。
二、可能的故障现象
1、 不能拨号、无拨号音、拨号有杂音、上网掉线；
2、 上网速度慢、个别网页不能浏览；
3、 上网时死机、蓝屏报错等；
4、 能收邮件但不能发邮件；
5、 网络设备安装异常；
6、 与调制解调器相连的其它通信设备损坏、或反之。
三、可能涉及的部件
调制解调器、电话机、电话线、局端。余类同 “局域网类故障”。
四、判断要点/顺序
1、 环境检查
1) 周边及外观检查：
A. 市电的接线定义是否正确，是否有地线；
B. 外置MODEM附近是否有变压器等设备或其它可造成干扰的电器设备；
C. 电话是否有防盗打功能，是否安装了IP电话拨号器、传真机等外部设备。这些外部设备连接是否正确，工作是否正常（单独工作和连机情况下）；
D. 检查机箱内灰尘是否较多，是否有异物造成短路，插接部件是否接插到位，无翘起；
E. 主板、MODEM或宽带上网网卡上元器件是否有变形、变色等现象；
F. 网卡接口接触是否良好；
G. 加电后注意部件、元器件及其它设备是否有异味、温度异常等现象发生。
2) 信号线连接：
A. 电话线是否正确连接，连接的电话线是否正常，用户的电话是否为分机，是否有来电提醒；
B. 拨打的电话号码是否有限制；
C. 宽带上网其网线定义是否正确，能否连通，有条件的话将机器更换环境（如：到邻居家中或回站）后再进行测试，以验证是否为连线问题；
2、 故障判断要点
1) MODEM配置检查：
A. 检查CMOS中的设置是否正确。MODEM设备是否被系统认到；
B. 软件最小系统加MODEM，检查故障现象是否消失。如消失。则是硬件之间的不兼容或资源冲突造成的故障；
C. 在设备管理器中检查MODEM驱动是否正确，是否有资源冲突。MODEM支持的协议是否与局端不兼容。在驱动不正确时，可能会造成上网掉线、上网速度慢等现象。将原MODEM驱动删除（最好在控制面板——调制解调器中将MODEM删除），安装主板驱动后重新安装MODEM驱动程序；
D. MODEM设备属性设置是否正确（如使用的连接速度等）。
2) 拨号器/拨号过程检查：
A. 检查用户所用的拨号程序，是否为第三方的软件，建议用一新建的拨号连接，拨号上网（最好能不用用户的账号），检查是否能拨号，是否报错；
B. 注意察看报错信息，初步判断故障原因（如：报680错误，是没有拨号音，678错误，是远程服务器没响应等）；
C. 用户是否有权访问Internet网络。
3) 网络属性及协议检查：
A. 如果是通过服务提供商来拨号上网的，除一定要安装IP协议外，不应对IP地址等参数进行设定。其它上网方式，应按要求进行相关的设定；
B. 使用的拨号协议是否与服务商要求的一致（如使用PPP协议等）。
4) IE检查：
A. 对于Windows 98系统，如果IE有故障，建议升级IE到5.5版本，或打补丁；
B. 检查IE属性设置是否正确，检查IE是否因上某一网站而被修改。如果临时文件过多，可造成上网后无法浏览网页（可在IE属性中删除临时文件等。关于删除的方法，见本章之后）。是否因为没有安装某些网站所必须的插件，而造成不能浏览网页。检查IE中的安全级别设置，和分级检查设置，恢复成默认值；
C. 检查是否因上某些网站，造成系统被修改（如注册表被禁用等）；
D. 检查用户的软件环境，是否由于防病毒、防火墙之类的软件，或其设置不正确，造成浏览困难。
5) 系统检查：
A. 检查系统中是否有病毒；
B. 在MSCONFIG中关掉所有启动时加载的程序，关掉所有正在运行的程序。防止软件冲突造成的无法上网；
C. 必要时重新安装操作系统进行测试。
6) 硬件检查：
A. 更换MODEM所在的插槽，重新检测MODEM并安装驱动，如果无法上网，更换MODEM测试；
B. 如果是在雷雨后出现不能拨号等现象，除检查电缆线及其上的其它设备是否损坏外，应查MODEM是否已损坏；
C. 如还不能上网，注意检查其它硬件；
7) 宽带上网如出现故障，还需检查：
A. 检查网卡驱动是否安装正确；
B. 用闭环测试网卡是否正常；
C. 根据当地实际情况将拨号属性设置正确，根据宽带上网说明重新安装拨号软件，设置各项设置；
D. 更换不同型号网卡进行测试，排除不兼容现象；
E. 联系电信局或小区网管检查网络环境或连接设备；
F. 对于自动上网的，代理服务器不要进行设置，对于早期的宽带网，需要设置IP。
五、本类故障的判断流程
见附录一之（八）。
六、案例
案例一：
问题描述：
一客户机器采用98操作系统，在拨号上网时发现网页无法打开，但右下脚确实有链接的图标，发现无网络流量，但多拨几次后问题解决，此问题复现无规律，客户需要解释原因并证明不是机器的问题。
解决方案：客户要求给予一个合理的解释，因为机器并非无法上网，了解到这一点就应该从软件方面来考虑，不能一上来就换硬件，给客户感觉不好。
机器可以正常拨号说明机器的Modem硬件和驱动没有问题，但仔细观察后发现网络流量为0，说明机器并没有在网上，右下脚的链接符号可能是一种假相，使用ipconfig/all命令发现机器没有获得IP地址，为什么会有这种现象呢？可能会和电信接入端有关，反复测试几次拨号上网，发现只要拨号后如果获得IP地址就一定可以上网，如果没有获得IP地址，就一定无法打开网页，客户看到这种现象后基本认可我的说法，并希望通过重新安装操作系统来看是否可以解决，通过重新安装98操作系统后问题依旧，客户已认为机器没有问题，在新的98下我为客户用另外一种方式进行测试，即用98里边的超级终端来拨号，原因是超级终端在拨号时可以看到拨号的全过程，是否可以得到IP地址，在使用超级终端拨号5－6次后发现有一次没有得到IP地址，至此客户完全信服了，正真的原因在于电信的局端，而不是在于机器本身。

案例二：
问题描述：客户机器所装的操作系统为98，除安装Modem外，还加了一块网卡，客户机器平时使用网卡上局域网的，网卡获得IP是采用DHCP方式，但在拨号时无法拨号上网，可是有拨号音，客户要求彻底解决。
解决方案： 客户以前曾经用过Modem拨号上网，现在无法使用，情绪较激动，除了解决外还需要充分的沟通，因此处理的过程很重要。
我在测试时发现故障复现，经过和客户沟通，发现客户以前确实可以拨号上网，最近由于安装了一块网卡，局域网可以上，拨号是用不成了，从和客户的沟通后，我认为不是机器本身的问题，还是和设置及操作系统本身有关，因为在2000下别的机器上是没有此问题的。首先我将网卡屏蔽掉，然后测试拨号上网，发现故障消失，难道和网卡有关，将网卡打开，发现可以拨号上网，问题解决！怎么回事，重新启动后发现局域网上去后拨号再次出现异常，故障复现，使用超级终端拨号发现无法获得IP地址，OK，问题找到，但是什么原因造成无法获得IP地址呢？看来和操作系统有关，因为2000下并无此问题，应该在98下和网卡有关，由于此局域网是采用DHCP方式，我用winipcfg将网卡IP Realse，再次拨号故障解决，总算找出了问题的所在，反复启动并释放网卡IP后拨号正常，后经和微软工程师沟通，确定95和98确实有这种问题，但2000下已经解决了此问题，至此问题圆满解决，客户表示非常认可。

案例三：
问题描述：客户自己买了一个Modem，用此Modem可以拨号163/169上网，但其却无法拨到公司的局域网上收发邮件，客户希望协助解决，虽然客户的Modem不是标配的。
解决方案：客户自己对电脑还是比较熟悉的，因此只是要求我们协助处理，查出真正的原因，所以在处理这个问题时尽量不要打开机箱，做换主板之类的操作，重点要来考虑兼容性。
因为可以拨到163上，无法拨到公司网上，所以我重点要看客户Modem的型号及协议，客户的Modem是国产同维的产品，支持V.90协议，客户公司的Modem是美国3COM的产品，也支持V.90协议，首先用超级终端拨号到公司，发现出现拨号音后2秒后自动断调，没有到获得IP地址的那一步，这就说明这两个Modem出现了兼容性问题，在握手阶段出现了问题，向客户解释清楚后，客户向其单位借了一个3COM Modem，首先用拨号网络测试一切正常，再用超级终端测试发现一切正常，客户非常认可，认为我们的测试方式很有说服力。

附：在IE中删除临时文件可用以下几种办法：
1、 打开IE浏览器，在工具—internet选项中删除临时文件，清空历史记录。（对于IE无法打开的可在这项里的设置中选“每次启动Internet Explorer”，或将Internet临时文件夹使用的磁盘空间加大；
2、 在开始—设置—任务栏和开始菜单—开始菜单程序中选清除；
3、 在c:\windows\history目录中将历史记录删除；
4、 在c:\windowsTemporary Internet Files中删除所有文件；
5、 使用网络实铭等第三方软件进行清除。


第九章 端口与外设故障

一、定义举例
这类故障主要涉及串并口、USB端口、键盘、鼠标等设备的故障。
二、可能的故障现象
1、 键盘工作不正常、功能键不起作用；
2、 鼠标工作不正常；
3、 不能打印或在某种操作系统下不能打印；
4、 外部设备工作不正常；
5、 串口通信错误（如：传输数据报错、丢数据、串口设备识别不到等）；
6、 使用USB设备不正常（如USB硬盘带不动，不能接多个USB设备等）；
三、可能涉及的部件
装有相应端口的部件（如主板）、电源、连接电缆、BIOS中的设置。
四、判断要点/顺序
1、 维修前的准备
1) 准备相应端口的短路环测试制具；
2) 准备测试程序QA、AMI等——这些程序要求在DOS下运行；
3) 根据站内的资源，准备相应端口使用的电缆线，如并口、打印机线、串口线、USB线等。
2、 环境检查
1) 连接及外观检查：
A. 设备数据电缆接口是否与主机连接良好、针脚是否有弯曲、缺失、短接等现象；
B. 对于一些品牌的USB硬盘，应向用户说明最好使用外接电源以使其更好的工作；
C. 连接端口及相关控制电路是否有变形、变色现象；
D. 连接用的电缆是否与所要连接的设备匹配（如：两台机器通过串口相连，就应使用空调制解调器连接线而不能使用MODEM线等）。
2) 外设检查：
A. 外接设备的电源适配器是否与设备匹配；
B. 检查外接设备是否可加电（包括自带电源，和从主机信号端口取电）；
C. 检测其在纯DOS下是否可正常工作。如不能工作，应先检查线缆或更换外设及主板；
D. 如果外接设备有自检等功能，可先行检验其是否为完好；也可将外接设备接至其它联想机器检测。
3、 故障判断要点
1) 尽可能简化系统，无关的外设先去掉；
2) 端口设置检查（BIOS和操作系统两方面）：
A. 检查主板BIOS设置是否正确，端口是否打开，工作模式是否正确；
B. 通过更新BIOS、更换不同品牌或不同芯片组主板，测试是否存在兼容问题；
C. 检查系统中相应端口是否有资源冲突。接在端口上的外设驱动是否已安装，其设备属性是否与外接设备相适应。在设置正确的情况下，检测相应的硬件——主板等；
D. 检查端口是否可在DOS环境下使用，可通过接一外设或用下面介绍的端口检测工具检查；
E. 对于串、并口等端口，须使用相应端口的专用短路环，配以相应的检测程序（推荐使用AMI）进行检查。如果检测出有错误，则应更换相应的硬件；
F. 检查在一些应用软件中是否有不当的设置，导致一些外设在此应用下工作不正常。如：在一些应用下，设置了不当的热键组合，使某些键不能正常工作。
3) 设备及驱动程序检查：
A. 驱动重新安装时优先使用设备驱动自带的卸载程序,如Z32打印机；
B. 检查设备软件设置是否与实际使用的端口相对应，如USB打印机要设置USB端口输出；
C. USB设备、驱动、应用软件的安装顺序要严格按照使用说明操作；
D. 外设的驱动程序，最好使用较新的版本，并可到厂商的网站上去升级。


第十章 音视频类故障

一、定义举例
与多媒体播放、制作有关的软硬件故障。
二、可能的故障现象
1、 播放CD、VCD或DVD等报错、死机；
2、 播放多媒体软件时，有图像无声或无图像有声音；
3、 播放声音时有杂音，声音异常、无声；
4、 声音过小或过大，且不能调节；
5、 不能录音、播放的录音杂音很大或声音较小；
6、 设备安装异常。
三、可能涉及的部件
音、视频板卡或设备、主板、内存、光驱、磁盘介质、机箱等。
四、判断要点/顺序
1、 维修前的准备
1) 除必备的维修工具外，应准备最新的设备驱动、补丁程序、主板BIOS、最新的DirectX，标准格式的音频文件（CD、WAV文件）、视频文件（VCD、DVD）；
2) 熟悉多媒体应用软件的各项设置，如WINDOWS下声音属性的设置、声卡/显卡附带应用软件的设置、视频盒/卡应用软件的设置等；
3) 有针对性的了解用户的信息，主要了解：出现故障前是否安装过新硬件、软件、重装过系统（包括一键恢复）。
2、 环境检查
1) 检查市电的电压是否在允许的范围内（220V±10%）；
2) 检查设备电源、数据线连接是否正确，插头是否完全插好，如音箱、视频盒的音/视频连线等；开关是否开启；音箱的音量是否调整到适当大小；
3) 观察用户的操作方法是否正确；
4) 检查周围使用环境，有无大功率干扰设备，如：空调、背投、大屏幕彩电、冰箱等大功率电器。如果有应与其保持相当的距离（50厘米以上）；
5) 检查主板BIOS设置是否被调整，应先将设置恢复出厂状态，特别检查CPU、内存是否被超频。
3、 故障判断要点
1) 对声音类故障（无声、噪音、单声道等），首先确认音箱是否有故障，方法：可以将音箱连接到其他音源（如录音机、随身听）上检测，声音输出是否正常，此时可以判定音箱是否有故障；
2) 检查是否由于未安装相应的插件或补丁，造成多媒体功能工作不正常；
3) 对多媒体播放、制作类故障，如果故障是在不同的播放器下、播放不同的多媒体文件均复现，则应检查相关的系统设置（如声音设置、光驱属性设置、声卡驱动及设置）。乃至检查相关的硬件是否有故障；
4) 如果是在特定的播放器下才有故障，在其他播放器下正常，应从有问题的播放器软件着手，检查软件设置是否正确，是否能支持被播放文件的格式。可以重新安装或升级软件后，看故障是否排除；
5) 如果故障是在重装系统、更换板卡、用系统恢复盘恢复系统、或使用一键恢复等情况下出现，应首先从板卡驱动安装入手检查，如驱动是否与相应设备匹配等；
6) 对于视频输入、输出相关的故障应首先检查视频应用软件采用信号制式设定是否正确，即应该与信号源（如有线电视信号）、信号终端（电视等）采用相同的制式。中国地区普遍为PAL制式；
7) 进行视频导入时，应注意视频导入软件和声卡的音频输入设置是否相符，如：软件中音频输入为MIC，则音频线接声卡的MIC口，且声卡的音频输入设置为MIC；
8) 当仅从光驱读取多媒体文件时出现故障，如：播放DVD/VCD速度慢、不连贯等，先检查光驱的传输模式，应设为“DMA”方式；
9) 检查有无第三方的软件，干扰系统的音视频功能的正常使用。另外，杀毒软件会引起播放DVD/VCD速度慢、不连贯等（如瑞星等，应关闭）；
10) 软件检查
A. 检查系统中是否有病毒；
B. 声音/音频属性设置：音量的设定，是否使用数字音频等；
C. 视频设置：视频属性中分辨率和色彩深度；
D. 检查DirectX的版本，安装最新的DirectX。同时使用其提供的Dxdiag.exe程序，对声卡设备进行检查
E. 设备驱动检查：在WINDOWS下“系统—设备管理”中，检查多媒体相关的设备（显卡、声卡、视频卡等）是否正常，即不应存在有“？”或“！”等标识，设备驱动文件应完整。必要时，可通过卸载驱动再重新安装或进行驱动升级。对于说明书中注明必须手动安装的声卡设备，应按要求删除或直接覆盖安装（此时，不应让系统自动搜索，而是手动在设备列表中选取）；
F. 如用户曾重装过系统，可能在装驱动时没有按正确步骤操作（如重启动等），导致系统显示设备正常，但实际驱动并没有正确工作。此时应为用户重装驱动。方法可同上；
G. 用系统恢复盘恢复系统、或使用一键恢复后有时会出现系统识别的设备不是用户实际使用的设备，而且在WINDOWS下“系统—设备管理”中不报错，这时必须仔细核对设备名称是否与实际的设备一致，不一致则重装驱动（如：更换过可替换的主板后声卡芯片与原来的不一致）；
H. 重装驱动仍不能排除故障，应考虑是否有更新的驱动版本，应进行驱动升级、或安装补丁程序。
11) 硬件检查
A. 用内存检测程序检测内存部分是否有故障。考虑的硬件有主板和内存；
B. 首先采用替换法检查与故障直接关联的板卡、设备。声音类的问题：声卡、音箱、主板上的音频接口跳线；显示类问题：显卡；视频输入、输出类问题：视频盒/卡；
C. 当仅从光驱读取多媒体文件时出现故障，在软件设置无效时，用替换法确定光驱是否有故障；
D. 对于有噪音问题，检查光驱的音频连线是否正确安装，音箱自身是否有问题，音箱电源适配器是否有故障，及其他匹配问题等；
E. 用磁盘类故障判断方法，检测硬盘是否有故障；
F. 采用替换法确定CPU是否有故障；
G. 采用替换法确定主板是否有故障。
五、本类故障的判断流程
见附录一之（十）。
六、案例
案例一：
问题描述：用户报修同禧E5000电脑，安装的WINDOWS XP系统。用户在播放音视频文件，如VCD、CD、MP3等时，音箱里“滋滋”的噪音很明显。
解决方案：
一般看到此类问题，总是会先想到是音箱的问题，或者主板的声卡有问题。但是工程师先后更换音箱、主板都是故障依旧。此时维修陷入困境。
其实只要仔细观察并思考一下，本着先软后硬的思路去观察，问题应该能很快解决的。此案例中，由于机器本身出厂是DOS系统，WINDOWS XP是用户自己安装的，声卡驱动也是WINDOWS XP自己认的，而恰恰是XP自带的驱动出了问题，造成用户报修的问题现象。只要安装随机驱动光盘里的相应的驱动程序，问题就迎刃而解了。

案例二：
问题描述：用户购买的未来先锋722机器，自己按装了 WINDOWS 98，发现播放CD时无声音。在声音控制里已经打开了CD的控制，并且把音量调节到最大了。
解决方案：首先我们要知道这点，联想出厂预装WINDOWS XP的机器，已经不再配置光驱和声卡之间的音频线了，播放CD时都采用XP本身提供的数字音频功能直接播放。而WINDOWS 98不具备数字音频的功能。明白了这一点，用户的问题的答案也就明朗了。
告诉用户机器标配中利用WINDOWS XP的数字音频功能播放CD，所以机器没有配置光驱音频线。而WINDOWS 98不支持数字音频功能，所以会产生这样的问题。建议用户还是使用WINDOWS XP操作系统，或者自己添加一根音频线。
从这个案例不难看出，对产品配置、技术规范的了解和掌握对于我们解决用户问题是很重要的保证。


第十一章 兼容或配合性故障

一、定义举例
这类故障主要是由于用户追加第三方软、硬件设备而引起的软、硬件故障。
这类故障，在前面的几类故障中已部分提及，因此有些故障现象可能与前面所介绍的故障判断类似，可参考。
二、可能的故障现象
1、 加装用户的设备或应用后，系统运行不稳定，如：死机或重启等；
2、 用户所加装的设备不能正常工作；
3、 用户开发的应用不能正常工作；
4、 用户需要的配置在联想机上不能满足（如需要加装大容量内存、需要多个串口等）。
三、可能涉及的部件
所有可能的部件或软件。但影响第三方应用最多的部件应该是：主板、CPU、内存、显示卡，及新型接口的外设。
四、判断要点/顺序
1、 环境检查
1) 检查外加设备板卡等的制作工艺，对于工艺粗糙的板卡或设备，很易引起黑屏、电源不工作、运行不稳定的现象；
2) 检查追加的内存条是否与原内存条是同一型号。不同的型号一是会引起兼容问题，造成运行不稳定、死机等现象；另一是要注意修改BIOS中的设置；
3) 更新或追加的部件，如CPU、硬盘等的技术规格是否能与其余的部件兼容。过于新的部件或规格较旧的部件，都会与原有配置不兼容。如：较旧的部件不支持电源管理，从而使系统运行时，使用这样的部件就会工作不正常，或是使整个系统也不能正常工作。
2、 故障判断要点
1) 开机后应首先检查新更新的或追加的部件，在系统启动前出现的配置列表中能否出现。如果不能，应检查其安装及其技术规格；
2) 如果造成无显、运行不稳定或死机等现象，应先去除更新或追加的部件或设备，看系统是否恢复到正常的工作状态，并认真研读新设备、部件的技术手册，了解安装与配置方法；
3) 外加的设备如不能正常安装，应查看其技术手册了解正确的安装方法、技术要求等，并尽可能使用最新版本的驱动程序。如果不能解决，应检查外加设备的质量及原系统的工作情况；
4) 检查新追加或更新部件与原有部件间是否存在不能共享资源的现象，即调开相应部件的资源检查故障是否消失，在不能调开时，可设法更换安装的插槽位置，或在BIOS中更改资源的分配方式；
5) 检查是否由于BIOS的原因造成了兼容性问题，这可通过更新BIOS来检查（注不一定是最新版或更高版本，可以降低版本检查）；
6) 查看追加的部件上的跳线设置是否恰当，并进行必要的设置修改；
7) 对于使用较旧的板卡或软件，应注意是否由于速度上的不匹配而引起工作不正常；
8) 通过更改系统中的设置或服务，来检查故障是否消失。如电源管理服务、设备参数修改等；
9) 检查原有的软硬件是否存在性能不佳的情况，即通过更换硬件或屏蔽原有软件来检查。


每个用户的硬盘中都存放着大量的有用数据，而硬盘又是一个易出毛病的部件。为了有效的保存硬盘中的数据，除了有效的保存硬盘中的数据，备份工作以外，还要学会在硬盘出现故障时如何救活硬盘，或者提取其中的有用数据，把损失降到最小程度。

1、系统不承认硬盘
此类故障比较常见，即从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法发现硬盘的存在。这种故障大都出现在连接电缆或IDE口端口上，硬盘本身的故障率很少，可通过重新插拔硬盘电缆或者改换IDE口及电缆等进行替换试验，可很快发现故障的所在。如果新接上的硬盘不承认，还有一个常见的原因就是硬盘上的主从条线，如果硬盘接在IDE的主盘位置，则硬盘必须跳为主盘状，跳线错误一般无法检测到硬盘。

2、CMOS引起的故障
CMOS的正确与否直接影响硬盘的正常使用，这里主要指其中的硬盘类型。好在现在的机器都支持"IDEautodetect"的功能，可自动检测硬盘的类型。当连接新的硬盘或者更换新的硬盘后都要通过此功能重新进行设置类型。当然，现在有的类型的主板可自动识别硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用Normal、LBA、Large等。如果在一般的模式下安装了数据，而又在CMOS中改为其他的模式，则会发生硬盘的读写错误故障，因为其物理地质的映射关系已经改变，将无法读取原来的正确硬盘位置。

3、主引导程序引起的启动故障
硬盘的主引导扇区是硬盘中的最为敏感的一个部件，其中的主引导程序是它的一部分，此段程序主要用于检测硬盘分区的正确性，并确定活动分区，负责把引导权移交给活动分区的DOS或其他操作系统。此段程序损坏将无法从硬盘引导，但从软区或光区之后可对硬盘进行读写。修复此故障的方法较为简单，使用高版本DOS的fdisk最为方便，当带参数/mbr运行时，将直接更换(重写)硬盘的主引导程序。实际上硬盘的主引导扇区正是此程序建立的，fdisk.exe之中包含有完整的硬盘主引导程序。虽然DOS版本不断更新，但硬盘的主引导程序一直没有变化，从DOS3.x到目前有winDOS95的DOS，所以只要找到一种DOS引导盘启动系统并运行此程序即可修复。

4、分区表错误引导的启动故障
分区表错误是硬盘的严重错误，不同错误的程度会造成不同的损失。如果是没有活动分区标志，则计算机无法启动。但从软驱或光驱引导系统后可对硬盘读写，可通过fdisk重置活动分区进行修复。如果是某一分区类型错误，可造成某一分区的丢失。分区表的第四个字节为分区类型值，正常的可引导的大于32mb的基本DOS分区值为06，而扩展的DOS分区值是05。如果把基本DOS分区类型改为05则无法启动系统，并且不能读写其中的数据。如果把06改为DOS不识别的类型如efh，则DOS认为改分区不是DOS分区，当然无法读写。很多人利用此类型值实现单个分区的加密技术，恢复原来的正确类型值即可使该分区恢复正常。分区表中还有其他数据用于纪录分区的起始或终止地址。这些数据的损坏将造成该分区的混乱或丢失，一般无法进行手工恢复，唯一的方法是用备份的分区表数据重新写回，或者从其他的相同类型的并且分区状况相同的硬盘上获取分区表数据，否则将导致其他的数据永久的丢失。在对主引导扇区进行操作时，可采用nu等工具软件，操作非常的方便，可直接对硬盘主引导扇区进行读写或编辑。当然也可采用debug进行操作，但操作繁琐并且具有一定的风险。

5、分区有效标志错误引起的硬盘故障
在硬盘主引导扇区中还存在一个重要的部分，那就是其最后的两个字节:55aah，此字为扇区的有效标志。当从硬盘，软盘或光区启动时，将检测这两个字节，如果存在则认为有硬盘存在，否则将不承认硬盘。此标志时从硬盘启动将转入rombasic或提示放入软盘。从软盘启动时无法转入硬盘。此处可用于整个硬盘的加密技术。可采用debug方法进行恢复处理。另外，DOS引导扇区仍有这样的标志存在，当DOS引导扇区无引导标志时，系统启动将显示为:"missingoperatingsystem"。其修复的方法可采用的主引导扇区修复方法，只是地址不同，更方便的方法是使用下面的DOS系统通用的修复方法。

6、DOS引导系统引起的启动故障
DOS引导系统主要由DOS引导扇区和DOS系统文件组成。系统文件主要包括io.sys、msdos.sys、command.com，其中command.com是DOS的外壳文件，可用其他的同类文件替换，但缺省状态下是DOS启动的必备文件。在Windows95携带的DOS系统中，msdos.sys是一个文本文件，是启动windows必须的文件。但只启动DOS时可不用此文件。但DOS引导出错时，可从软盘或光盘引导系统，之后使用sysc:传送系统即可修复故障，包括引导扇区及系统文件都可自动修复到正常状态。

7、fat表引起的读写故障
fat表纪录着硬盘数据的存储地址，每一个文件都有一组连接的fat链指定其存放的簇地址。fat表的损坏意味着文件内容的丢失。庆幸的是DOS系统本身提供了两个fat表，如果目前使用的fat表损坏，可用第二个进行覆盖修复。但由于不同规格的磁盘其fat表的长度及第二个fat表的地址也是不固定的，所以修复时必须正确查找其正确位置，由一些工具软件如nu等本身具有这样的修复功能，使用也非常的方便。采用debug也可实现这种操作，即采用其m命令把第二个fat表移到第一个表处即可。如果第二个fat表也损坏了，则也无法把硬盘恢复到原来的状态，但文件的数据仍然存放在硬盘的数据区中，可采用chkdsk或scandisk命令进行修复，最终得到*.chk文件，这便是丢失fat链的扇区数据。如果是文本文件则可从中提取并可合并完整的文件，如果是二进制的数据文件，则很难恢复出完整的文件。

8、目录表损坏引起的引导故障
目录表纪录着硬盘中文件的文件名等数据，其中最重要的一项是该文件的起始簇号，目录表由于没有自动备份功能，所以如果目录损坏将丢失大量的文件。一种减少损失的方法也是采用上面的chkdsk或scandisk程序的方法，从硬盘中搜索出chk文件，由目录表损坏时是首簇号丢失，在fat为损坏的情况下所形成的chk文件一般都比较完整的文件数据，每一个chk文件即是一个完整的文件，把其改为原来的名字可恢复大多数文件。

9、误删除分区时数据的恢复
当用fdisk删除了硬盘分区之后，表面现象是硬盘中的数据已经完全消失，在未格式化时进入硬盘会显示无效驱动器。如果了解fdisk的工作原理，就会知道，fdisk只是重新改写了硬盘的主引导扇区(0面0道1扇区)中的内容。具体说就是删除了硬盘分区表信息，而硬盘中的任何分区的数据均没有改变，可仿造上述的分区表错误的修复方法，即想办法恢复分区表数据即可恢复原来的分区即数据，但这只限于除分区或重建分区之后。如果已经对分区用format格式化，在先恢复分区后，在按下面的方法恢复分区数据。

10、误格式化硬盘数据的恢复
在DOS高版本状态下，格式化操作format在缺省状态下都建立了用于恢复格式化的磁盘信息，实际上是把磁盘的DOS引导扇区，fat分区表及目录表的所有内容复制到了磁盘的最后几个扇区中(因为后面的扇区很少使用)，而数据区中的内容根本没有改变。这样通过运行"unformatc:"即可恢复原来的文件分配表及目录表，从而完成硬盘信息的恢复。另外DOS还提供了一个miror命令用于纪录当前的磁盘的信息，供格式化或删除之后的恢复使用，此方法也比较有效。


硬盘的DOS管理结构
1.磁道，扇区，柱面和磁头数
    硬盘最基本的组成部分是由坚硬金属材料制成的涂以磁性介质的盘片，不同容量硬盘的盘片数不等。每个盘片有两面，都可
记录信息。盘片被分成许多扇形的区域，每个区域叫一个扇区，每个扇区可存储128×2的N次方（N＝0.1.2.3）字节信息。在DOS
中每扇区是128×2的2次方＝512字节，盘片表面上以盘片中心为圆心，不同半径的同心圆称为磁道。硬盘中，不同盘片相同半径
的磁道所组成的圆柱称为柱面。磁道与柱面都是表示不同半径的圆，在许多场合，磁道和柱面可以互换使用，我们知道，每个磁
盘有两个面，每个面都有一个磁头，习惯用磁头号来区分。扇区，磁道（或柱面）和磁头数构成了硬盘结构的基本参数，帮这些
参数可以得到硬盘的容量，基计算公式为：
存储容量＝磁头数×磁道（柱面）数×每道扇区数×每扇区字节数
要点：（1）硬盘有数个盘片，每盘片两个面，每个面一个磁头
      （2）盘片被划分为多个扇形区域即扇区
      （3）同一盘片不同半径的同心圆为磁道
      （4）不同盘片相同半径构成的圆柱面即柱面
      （5）公式：　存储容量＝磁头数×磁道（柱面）数×每道扇区数×每扇区字节数
      （6）信息记录可表示为：××磁道（柱面），××磁头，××扇区
2.簇
    “簇”是DOS进行分配的最小单位。当创建一个很小的文件时，如是一个字节，则它在磁盘上并不是只占一个字节的空间，
而是占有整个一簇。DOS视不同的存储介质（如软盘，硬盘），不同容量的硬盘，簇的大小也不一样。簇的大小可在称为磁盘
参数块（BPB）中获取。簇的概念仅适用于数据区。
本点：（1）“簇”是DOS进行分配的最小单位。
      （2）不同的存储介质，不同容量的硬盘，不同的DOS版本，簇的大小也不一样。
      （3）簇的概念仅适用于数据区。
3.扇区编号定义：绝对扇区与DOS扇区
    由前面介绍可知，我们可以用柱面/磁头/扇区来唯一定位磁盘上每一个区域，或是说柱面/磁头/扇区与磁盘上每一个扇区有
一一对应关系，通常DOS将“柱面/磁头/扇区”这样表示法称为“绝对扇区”表示法。但DOS不能直接使用绝对扇区进行磁盘上的
信息管理，而是用所谓“相对扇区”或“DOS扇区”。“相对扇区”只是一个数字，如柱面140，磁头3，扇区4对应的相对扇区号
为2757。该数字与绝对扇区“柱面/磁头/扇区”具有一一对应关系。当使用相对扇区编号时，DOS是从柱面0，磁头1，扇区1开始
（注：柱面0，磁头0，扇区1没有DOS扇区编号，DOS下不能访问，只能调用BIOS访问），第一个DOS扇区编号为0，该磁道上剩余
的扇区编号为1到16（设每磁道17个扇区），然后是磁头号为2，柱面为0的17个扇区，形成的DOS扇区号从17到33。直到该柱面的
所有磁头。然后再移到柱面1，磁头1，扇区1继续进行DOS扇区的编号，即按扇区号，磁头号，柱面号（磁道号）增长的顺序连续
地分配DOS扇区号。
公式：记DH－－第一个DOS扇区的磁头号
        DC－－第一个DOS扇区的柱面号
        DS－－第一个DOS扇区的扇区号
        NS－－每磁道扇区数
        NH－－磁盘总的磁头数
      则某扇区（柱面C，磁头H，扇区S）的相对扇区号RS为：
RS＝NH×NS×（C－DC）＋NS×（H－DH）＋（S－DS）
      若已知RS，DC，DH，DS，NS和NH则
S＝（RS　MOD　NS）＋DS
H＝（（RS　DIV　NS）MOD　NH）＋DH
C＝（（RS　DIV　NS）DIV　NH）＋DC
要点：（1）以柱面/磁头/扇区表示的为绝对扇区又称物理磁盘地址
      （2）单一数字表示的为相对扇区或DOS扇区，又称逻辑扇区号
      （3）相对扇区与绝对扇区的转换公式
4.DOS磁盘区域的划分
    格式化好的硬盘，整个磁盘按所记录数据的作用不同可分为主引导记录（MBR:Main Boot Record），Dos引导记录（DBR:Dos
Boot Record），文件分配表（FAT:File Assign Table），根目录（BD:Boot Directory）和数据区。前5个重要信息在磁盘的外
磁道上，原因是外圈周长总大于内圈周长，也即外圈存储密度要小些，可靠性高些。
要点：（1）整个硬盘可分为MBR，DBR，FAT，BD和数据区。
      （2）MBR，DBR，FAT，和BD位于磁盘外道。
5.MBR
    MBR位于硬盘第一个物理扇区（绝对扇区）柱面0，磁头0，扇区1处。由于DOS是由柱面0，磁头1，扇区1开始，故MBR不属于
DOS扇区，DOS不能直接访问。MBR中包含硬盘的主引导程序和硬盘分区表。分区表有4个分区记录区。记录区就是记录有关分区信
息的一张表。它从主引导记录偏移地址01BEH处连续存放，每个分区记录区占16个字节。
分区表的格式
分区表项的偏移 意义 　　占用字节数
      00 引导指示符 1B
      01 分区引导记录的磁头号 1B
      02 分区引导记录的扇区和柱面号 2B
      04 系统指示符 1B
      05 分区结束磁头号 1B
      06 分区结束扇区和柱面号 2B
      08 分区前面的扇区数 4B
      0C 分区中总的扇区数 4B
4个分区中只能有1个活跃分区，即C盘。标志符是80H在分区表的第一个字节处。若是00H则表示非活跃分区。例如：
80　01　01　00　0B FE 3F 81 3F 00 00 00 C3 DD 1F 00
00 00 01 82 05 FE BF 0C 02 DE 1F 00 0E 90 61 00
00　00　00　00　00　00　00　00　00　00　00　00　00　00　00　00
00　00　00　00　00　00　00　00　00　00　00　00　00　00　00　00
要点：（1）MBR位于硬盘第一个物理扇区柱面0，磁头0，扇区1处。不属于DOS扇区，
      （2）主引导记录分为硬盘的主引导程序和硬盘分区表。
6.DBR
    DBR位于柱面0，磁头1，扇区1，即逻辑扇区0。DBR分为两部分：DOS引导程序和BPB（BIOS参数块）。其中DOS引导程序完成
DOS系统文件（IO.SYS，MSDOS.SYS）的定位与装载，而BPB用来描述本DOS分区的磁盘信息，BPB位于DBR偏移0BH处，共13字节。
它包含逻辑格式化时使用的参数，可供DOS计算磁盘上的文件分配表，目录区和数据区的起始地址，BPB之后三个字提供物理格
式化（低格）时采用的一些参数。引导程序或设备驱动程序根据这些信息将磁盘逻辑地址（DOS扇区号）转换成物理地址（绝对
扇区号）。BPB格式
序号 偏移地址 意义
1 03H－0AH OEM号
2 0BH－0CH 每扇区字节数
3 0DH 每簇扇区数
4 0EH－0FH 保留扇区数
5 10H FAT备份数
6 11H－12H 根目录项数
7 13H－14H 磁盘总扇区数
8 15H 描述介质
9 16H－17H 每FAT扇区数
10 18H－19H 每磁道扇区数
11 1AH－1BH 磁头数
12 1CH－1FH 特殊隐含扇区数
13 20H－23H 总扇区数
14 24H－25H 物理驱动器数
15 26H 扩展引导签证
16 27H－2AH 卷系列号
17 2BH－35H 卷标号
18 36H－3DH 文件系统号
DOS引导记录公式：
文件分配表≡保留扇区数
根目录≡保留扇区数＋FAT的个数×每个FAT的扇区数
数据区≡根目录逻辑扇区号＋（32×根目录中目录项数＋（每扇区字节数－1））DIV每扇区字节数
绝对扇区号≡逻辑扇区号＋隐含扇区数
扇区号≡（绝对扇区号MOD每磁道扇区数）＋1
磁头号≡（绝对扇区号DIV每磁道扇区数）MOD磁头数
磁道号≡（绝对扇区号DIV每磁道扇区数）DIV磁头数
要点：（1）DBR位于柱面0，磁头1，扇区1，其逻辑扇区号为0
      （2）DBR包含DOS引导程序和BPB。
      （3）BPB十分重要，由此可算出逻辑地址与物理地址。
7.文件分配表
    文件分配表是DOS文件组织结构的主要组成部分。我们知道DOS进行分配的最基本单位是簇。文件分配表是反映硬盘上所
有簇的使用情况，通过查文件分配表可以得知任一簇的使用情况。DOS在给一个文件分配空间时总先扫描FAT，找到第一个可
用簇，将该空间分配给文件，并将该簇的簇号填到目录的相应段内。即形成了“簇号链”。FAT就是记录文件簇号的一张表。
FAT的头两个域为保留域，对FAT12来说是3个字节，FAT来说是4个字节。其中头一个字节是用来描述介质的，其余字节为FFH
。介质格式与BPB相同。
第一个字节的8位意义：
7　6　5　4　3　２　１ ０
└─────-┘ │ │ │┌0非双面
置1 │ │ └┤
│ │ └1双面
│ │┌0不是8扇区
│ └┤
│ └1是8扇区
│┌0不是可换的
└┤
└1是可换的
FAT结构含义
FAT12 FAT16 意义
000H 0000H 可用
FF0H－FF6H FFF0H－FFF6H 保留
FF7H FFF7H 坏
FF8H－FFFH FFF8H－FFFFH 文件最后一个簇
×××H ××××H 文件下一个簇
对于FAT16，簇号×2作偏移地址，从FAT中取出一字即为FAT中的域。
逻辑扇区号＝数据区起始逻辑扇区号＋（簇号－2）×每簇扇区数
簇号＝（逻辑扇区号－数据区起始逻辑扇区号）DIV每簇扇区数＋2
要点：（1）FAT反映硬盘上所有簇的使用情况，它记录了文件在硬盘中具体位置（簇）。
      （2）文件第一个簇号（在目录表中）和FAT的该文件的簇号串起来形成文件的“簇号链”，恢复被破坏的文件就是根
据这条链。
      （3）由簇号可算逻辑扇区号，反之，由逻辑扇区号也可以算出簇号，公式如上。
      （4）FAT位于DBR之后，其DOS扇区号从1开始。
8.文件目录
    文件目录是DOS文件组织结构的又一重要组成部分。文件目录分为两类：根目录，子目录。根目录有一个，子目录可以有
多个。子目录下还可以有子目录，从而形成“树状”的文件目录结构。子目录其实是一种特殊的文件，DOS为目录项分配32字
节。目录项分为三类：文件，子目录（其内容是许多目录项），卷标（只能在根目录，只有一个。目录项中有文件（或子目
录，或卷标）的名字，扩展名，属性，生成或最后修改日期，时间，开始簇号，及文件大小。
目录项的格式
字节偏移 意义 占字节数
00H 文件名 8B
08H 扩展名 3B
0BH 文件属性 1B
0CH 保留 10B
16H 时间 2B
18H 日期 2B
1AH 开始簇号 2B
1CH 文件长度 4B
目录项文件名区域中第一个字节还有特殊的意义：00H代表未使用
05H代表实际名为E5H
EBH代表此文件已被删除
目录项属性区域的这个字节各个位的意义如下： ７　６　５　４　３　２　１　０
                                           未　修　修　子　卷　系　隐　只
                                           用　改　改　目　标　统　藏　读
                                               标　标　录　　　属　属　属
                                               志　志　　　　　性　性　性
注意：WINDOWS的长文件名使用了上表中所说的“保留”这片区域。
要点：（1）文件目录是记录所有文件，子目录名，扩展名属性，建立或删除最后修改日期。文件开始簇号及文件长度的一张
           登记表.
      （2）DOS中DIR列出的内容训是根据文件目录表得到的。
      （3）文件起始簇号填在文件目录中，其余簇都填在FAT中上一簇的位置上。
9.物理驱动器与逻辑驱动器
    物理驱动器指实际安装的驱动器。
    逻辑驱动器是对物理驱动器格式化后产生的。
要点：同上。


硬盘逻辑锁巧解

在谈论具体的解决方法前，先讲述一下被"逻辑锁"锁住的硬盘为什么不能用普通办法启 动的原因：

计算机在引导DOS系统时将会搜索所有逻辑盘的顺序，当DOS被引导时，首先要去找主引 导扇区的分区表信息，位于硬盘的零头零柱面的第一个扇区的OBEH地址开始的地方，当 分区信息开始的地方为80H时表示是主引导分区，其他的为扩展分区，主引导分区被定义 为逻辑盘C盘，然后查找扩展分区的逻辑盘，被定义为D盘，以此类推找到E，F，G..... "逻辑锁"就是在此下手，修改了正常的主引导分区记录将扩展分区的第一个逻辑盘指向 自己，DOS在启动时查找到第一个逻辑盘后，查找下个逻辑盘总是找到是自己，这样一来 就形成了死循环，这就是使用软驱,光驱，双硬盘都不能正常启动的原因。实际上这"逻辑锁"只是利用了DOS在启动时的一个小小缺陷，便令不少高手都束手无策。知道了"逻辑 锁"的"上锁"原理，要解锁也就比较容易了。以前我看到有位朋友采用"热拔插"硬盘电源的方法来处理：就是在当系统启动时，先不给被锁的硬盘插上电源线，等待启动完成后再给硬盘"热插"上电源线，这时如果硬盘没有烧坏的话，系统就可以控制硬盘了。当然这是一种非常危险的方法，大家不要轻易尝试，下面介绍两种比较简单和安全的处理方法。

方法一：修改DOS启动文件
首先准备一张DOS6.22的系统盘，带上debug、pctools5.0、fdisk等工具。然后在一台正常的机器上，使用你熟悉的二进制编辑工具（debug、pctools5.0，或者windows下的ultraedit都行）修改软盘上的IO.SYS文件（修改前记住改该文件的属性为正常），具体是在这个文件里面搜索第一个"55aa"字符串，找到以后修改为任何其他数值即可。用这张修改过的系统软盘你就可以顺利地带着被锁的硬盘启动了。不过这时由于该硬盘正常的分区表已经被黑客程序给恶意修改了，你无法用FDISK来删除和修改分区，而且仍无法用正常的启动盘启动系统，这时你可以用DEBUG来手工恢复。使用DEBUG手工修复硬盘步骤如下：

a:\>debug
-a
-xxxx:100 mov ax,0201 读一个扇区的内容
-xxxx:103 mov bx,500 设置一个缓存地址
-xxxx:106 mov cx,0001 设置第一个硬盘的硬盘指针
-xxxx:109 mov dx,0080 读零磁头
-xxxx:10c int 13 硬盘中断
-xxxx:10e int 20
-xxxx:0110 退出程序返回到指示符
-g 运行
-d500 查看运行后500地址的内容

这时候会发现地址6be开始的内容是硬盘分区的信息，发现此硬盘的扩展分区指向自己，这就使DOS或WINDOWS启动时查找硬盘逻辑盘进去死循环，在DEBUG指示符下用E命令修改内存数据 具体如下：

E6BE
xx.0 xx.0 xx.0...............
.............................
.......................55 AA
55 AA表示硬盘有效的标记，不要修改，xx0表示把以前的数据"xx"改成0

再用硬盘中断13把修改好的数据写入硬盘就可以了，具体如下：

A:\>debug
a 100 表示修改100地址的汇编指令
-xxxx:100 mov ax,0301 写硬盘一个扇区
-xxxx: 这里直接按回车
-g 运行
-q 退出

然后运行 FDISK/MBR（重置硬盘引导扇区的引导程序)，再重新启动电脑就行了。 怎么样？用这种方法处理够简单的吧？而且这种方法还有一个好处就是可以保住盘上的 数据！如果你不需要保数据的话，还有更加简单的处理方法：
方法二：巧设BIOS，用DM解锁大家知道DM软件是不依赖于主板BIOS的硬盘识别安装软件，（所以在不能识别大硬盘的老主板上也可用DM来安装使用大容量硬盘）。就算在BIOS中将硬盘设为"NONE"，DM也可识别并处理硬盘。

首先你要找到和硬盘配套的DM软件（找JS要或去网上荡），然后把DM拷到一张系统盘上。接上被锁硬盘，开机，按住DEL键，进CMOS设置，将所有IDE硬盘设为NONE（这是关键所在!），保存设置，重启动，这时系统即可 "带锁"启动。启动后运行DM，你会发现DM可以绕过BIOS，识别出硬盘，选中该硬盘，分区格式化，就OK了。这么简单？不过这种 方法的弱点是硬盘上的数据将全部丢失。


数 值 叙 述
0 0x0000 作业完成。
1 0x0001 不正确的函数。
2 0x0002 系统找不到指定的档案。
3 0x0003 系统找不到指定的路径。
4 0x0004 系统无法开启档案。
5 0x0005 拒绝存取。
6 0x0006 无效的代码。
7 0x0007 储存体控制区块已毁。
8 0x0008 储存体空间不足，无法处理这个指令。
9 0x0009 储存体控制区块位址无效。
10 0x000A 环境不正确。
11 0x000B 尝试载入一个格式错误的程式。
12 0x000C 存取码错误。
13 0x000D 资料错误。
14 0x000E 储存体空间不够，无法完成这项作业。
15 0x000F 系统找不到指定的磁碟机。
16 0x0010 无法移除目录。
17 0x0011 系统无法将档案移到 其他的磁碟机。
18 0x0012 没有任何档案。
19 0x0013 储存媒体为防写状态。
20 0x0014 系统找不到指定的装置。
21 0x0015 装置尚未就绪。
22 0x0016 装置无法识别指令。
23 0x0017 资料错误 (cyclic redundancy check) 24 0x0018 程式发出一个长 度错误的指令。
25 0x0019 磁碟机在磁碟找不到 持定的磁区或磁轨。
26 0x001A 指定的磁碟或磁片无法存取。
27 0x001B 磁碟机找不到要求的磁区。
28 0x001C 印表机没有纸。
29 0x001D 系统无法将资料写入指定的磁碟机。
30 0x001E 系统无法读取指定的装置。
31 0x001F 连接到系统的某个装置没有作用。
32 0x0020 The process cannot access the file because it is being used by
another process.
33 0x0021 档案的一部份被锁定， 现在无法存取。
34 0x0022 磁碟机的磁片不正确。 请将 %2 (Volume Serial Number: %3) 插入磁碟
机%1。
36 0x0024 开启的分享档案数量太多。
38 0x0026 到达档案结尾。
39 0x0027 磁碟已满。
50 0x0032 不支援这种网路要求。
51 0x0033 远端电脑无法使用。
52 0x0034 网路名称重复。
53 0x0035 网路路径找不到。
54 0x0036 网路忙碌中。
55 0x0037 The specified network resource or device is no longer available.
56 0x0038 The network BIOS command limit has been reached. 57 0x0039 网路配接卡发生问题。
58 0x003A 指定的伺服器无法执行要求的作业。
59 0x003B 网路发生意外错误。
60 0x003C 远端配接卡不相容。
61 0x003D 印表机伫列已满。
62 0x003E 伺服器的空间无法储存等候列印的档案。
63 0x003F 等候列印的档案已经删除。
64 0x0040 指定的网路名称无法使用。
65 0x0041 拒绝存取网路。
66 0x0042 网路资源类型错误。
67 0x0043 网路名称找不到。
68 0x0044 超过区域电脑网路配接卡的名称限制。
69 0x0045 超过网路 BIOS 作业阶段的限制。
70 0x0046 远端伺服器已经暂停或者正在起始中。
71 0x0047 由於连线数目已达上限，此时无法再连线到这台远端电脑。
72 0x0048 指定的印表机或磁碟装置已经暂停作用。
80 0x0050 档案已经存在。
82 0x0052 无法建立目录或档案。
83 0x0053 INT 24失败
84 0x0054 处理这项要求的储存体无法使用。
85 0x0055 近端装置名称已经在使用中。
86 0x0056 指定的网路密码错误。
87 0x0057 参数错误。
88 0x0058 网路发生资料写入错误。
89 0x0059 此时系统无法执行其他行程。
100 0x0064 无法建立其他的系统 semaphore。 101 0x0065 属於其他行程专用的 semaphore 。
102 0x0066 semaphore 已经设定，而且无法关闭。
103 0x0067 无法指定 semaphore 。
104 0x0068 在岔断时间无法要求专用的 semaphore 。
105 0x0069 此 semaphore 先前的拥有权已经结束。
106 0x006A 请将磁片插入 %1。
107 0x006B 因为代用的磁片尚未插入，所以程式已经停止。
108 0x006C 磁碟正在使用中或被锁定。
109 0x006D Pipe 已经中止。
110 0x006E 系统无法开启指定的 装置或档案。
111 0x006F 档名太长。
112 0x0070 磁碟空间不足。
113 0x0071 没有可用的内部档案识别字。
114 0x0072 目标内部档案识别字不正确。
117 0x0075 由应用程式所执行的 IOCTL 呼叫 不正确。
118 0x0076 写入验证参数值不正确。
119 0x0077 系统不支援所要求的指令。
120 0x0078 此项功能仅在 Win32 模式有效。
121 0x0079 semaphore 超过逾时期间。
122 0x007A 传到系统呼叫的资料区域 太小。
123 0x007B 档名、目录名称或储存体标签语法错误。
124 0x007C 系统呼叫层次不正确。
125 0x007D 磁碟没有设定标签。
126 0x007E 找不到指定的模组。
127 0x007F 找不到指定的程序。
128 0x0080 没有子行程可供等待。
129 0x0081 %1 这个应用程式无法在 Win32 模式下执行。
130 0x0082 Attempt to use a file handle to an open disk partition for an
operation other than raw disk I/O.
131 0x0083 尝试将档案指标移至档案开头之前。
132 0x0084 无法在指定的装置或档案，设定档案指标。
133 0x0085 JOIN 或 SUBST 指令 无法用於 内含事先结合过的磁碟机。
134 0x0086 尝试在已经结合的磁碟机，使用 JOIN 或 SUBST 指令。
135 0x0087 尝试在已经替换的磁碟机，使 用 JOIN 或 SUBST 指令。
136 0x0088 系统尝试删除 未连结过的磁碟机的连结关系。
137 0x0089 系统尝试删除 未替换过的磁碟机的替换关系。
138 0x008A 系统尝试将磁碟机结合到已经结合过之磁碟机的目录。
139 0x008B 系统尝试将磁碟机替换成已经替换过之磁碟机的目录。
140 0x008C 系统尝试将磁碟机替换成已经替换过之磁碟机的目录。
141 0x008d系统尝试将磁碟机 SUBST 成已结合的磁碟机 目录。
142 0x008E 系统此刻无法执行 JOIN 或 SUBST。
143 0x008F 系统无法将磁碟机结合或替换同一磁碟机下目录。
144 0x0090 这个目录不是根目录的子目录。
145 0x0091 目录仍有资料。
146 0x0092 指定的路径已经被替换过。
147 0x0093 资源不足，无法处理这项 指令。
148 0x0094 指定的路径这时候无法使用。
149 0x0095 尝试要结合或替换的磁碟机目录，是已经替换过的的目标。
150 0x0096 CONFIG.SYS 档未指定系统追踪资讯，或是追踪功能被取消。
151 0x0097 指定的 semaphore事件 DosMuxSemWait 数目不正确。
152 0x0098 DosMuxSemWait 没有执行；设定太多的 semaphore。 153 0x0099 DosMuxSemWait 清单不正确。
154 0x009A 您所输入的储存媒体标 元长度限制。
155 0x009B 无法建立其他的执行绪。
156 0x009C 接收行程拒绝接受信号。
157 0x009D 区段已经被舍弃，无法被锁定。
158 0x009E 区段已经解除锁定。
159 0x009F 执行绪识别码的位址不正确。
160 0x00A0 传到 DosExecPgm 的引数字串不正确。
161 0x00A1 指定的路径不正确。
162 0x00A2 信号等候处理。
164 0x00A4 系统无法建立执行绪。
167 0x00A7 无法锁定档案的部份范围。
170 0x00AA 所要求的资源正在使用中。
173 0x00AD 取消范围的锁定要求不明显。
174 0x00AE 档案系统不支援自动变更锁定类型。
180 0x00B4 系统发现不正确的区段号码。
182 0x00B6 作业系统无法执行 %1。
183 0x00B7 档案已存在，无法建立同一档案。
186 0x00BA 传送的旗号错误。
187 0x00BB 指定的系统旗号找不到。
188 0x00BC 作业系统无法执行 %1。
189 0x00BD 作业系统无法执行 %1。
190 0x00BE 作业系统无法执行 %1。
191 0x00BF 无法在 Win32 模式下执行 %1。
192 0x00C0 作业系统无法执行 %1。
193 0x00C1 %1 不是正确的 Win32 应用程式。
194 0x00C2 作业系统无法执行 %1。
195 0x00C3 作业系统无法执行 %1。
196 0x00C4 作业系统无法执行 这个应用程式。
197 0x00C5 作业系统目前无法执行 这个应用程式。
198 0x00C6 作业系统无法执行 %1。
199 0x00C7 作业系统无法执行 这个应用程式。
200 0x00C8 程式码的区段不可以大於或等於 64KB。
201 0x00C9 作业系统无法执行 %1。
202 0x00CA 作业系统无法执行 %1。
203 0x00CB 系统找不到输入的环境选项。 \r
205 0x00CD 在指令子目录下，没有任何行程有信号副处理程式。
206 0x00CE 档案名称或副档名太长。
207 0x00CF ring 2 堆叠使用中。
208 0x00D0 输入的通用档名字元 * 或 ? 不正确， 或指定太多的通用档名字元。
209 0x00D1 所传送的信号不正确。
210 0x00D2 无法设定信号处理程式。
212 0x00D4 区段被锁定，而且无法重新配置。
214 0x00D6 附加到此程式或动态连结模组的动态连结模组太多。
215 0x00D7 Can`t nest calls to LoadModule.
230 0x00E6 The pipe state is invalid.
231 0x00E7 所有的 pipe instances 都在忙碌中。
232 0x00E8 The pipe is being closed.
233 0x00E9 No process is on the other end of the pipe.
234 0x00EA 有更多可用的资料。
240 0x00F0 作业阶段被取消。
254 0x00FE 指定的延伸属性名称无效。
255 0x00FF 延伸的属性不一致。
259 0x0103 没有可用的资料。
266 0x010A 无法使用 Copy API。
267 0x010B 目录名称错误。
275 0x0113 延伸属性不适用於缓冲区。
276 0x0114 在外挂的档案系统上的延伸属性档案已经毁损。
277 0x0115 延伸属性表格档满。
278 0x0116 指定的延伸属性代码无效。
282 0x011A 外挂的这个档案系统不支援延伸属性。
288 0x0120 意图释放不属於叫用者的 mutex。
298 0x012A semaphore 传送次数过多。
299 0x012B 只完成 Read/WriteProcessMemory 的部份要求。
317 0x013D 系统找不到位於讯息档 %2 中编号为 0x%1 的讯息。
487 0x01E7 尝试存取无效的位址。
534 0x0216 运算结果超过 32 位元。
535 0x0217 通道的另一端有一个行程在接送资料。
536 0x0218 等候行程来开启通道的另一端。
994 0x03E2 存取延伸的属性被拒。
995 0x03E3 由於执行绪结束或应用程式要求，而异常终止 I/O 作业。
996 0x03E4 重叠的 I/O 事件不是设定成通知状态。
997 0x03E5 正在处理重叠的 I/O 作业。
998 0x03E6 对记忆体位置的无效存取。
999 0x03E7 执行 inpage 作业发生错误。
1001 0x03E9 递回太深，堆叠满溢。
1002 0x03EA 视窗无法用来传送讯息。
1003 0x03EB 无法完成这项功能。
1004 0x03EC 旗号无效。
1005 0x03ED 储存媒体未含任何可辨识的档案系统。 请确定以载入所需的系统驱动
程式，而且该储存媒体并未毁损。
1006 0x03EE 储存该档案的外部媒体发出警告， 表示该已开启档案已经无效。
1007 0x03EF 所要求的作业无法在全萤幕模式下执行。
1008 0x03F0 An attempt was made to reference a token that does not exist.
1009 0x03F1 组态系统登录资料库毁损。
1010 0x03F2 组态系统登录机码无效。
1011 0x03F3 无法开启组态系统登录机码。
1012 0x03F4 无法读取组态系统登录机码。
1013 0x03F5 无法写入组态系统登录机码。
1014 0x03F6 系统登录资料库中的一个档案必须使用记录或其他备份还原。 已经还
原成功。
1015 0x03F7 系统登录毁损。其中某个档案毁损、或者该档案的 系统映对记忆体 内
容毁损、会是档案无法复原。
1016 0x03F8 系统登录起始的 I/O 作业发生无法复原的错误。 系统登录无法读入、
写出或更新，其中的一个档案 内含系统登录在记忆体中的内容。
1017 0x03F9 系统尝试将档案载入系统登录或将档案还原到系统登录中， 但是，指
定档案的格式不是系统登录档的格式。
1018 0x03FA 尝试在标示为删除的系统登录机码，执行不合法的操作。
1019 0x03FB 系统无法配置系统登录记录所需的空间。
1020 0x03FC 无法在已经有子机码或数值的系统登录机码建立符号连结。
1021 0x03FD 无法在临时机码下建立永久的子机码。
1022 0x03FE 变更要求的通知完成，但资讯 并未透过呼叫者的缓冲区传回。呼叫者
现在 需要自行列举档案，找出变更的地方。
1051 0x041B 停止控制已经传送给其他服务 所依峙的一个服务。
1052 0x041C 要求的控制对此服务无效
1053 0x041D The service did not respond to the start or control request in
a timely fashion. 1054 0x041E 无法建立服务的执行绪。
1055 0x041F 服务资料库被锁定。
1056 0x0420 这种服务已经在执行。
1057 0x0421 帐户名称错误或者不存在。
1058 0x0422 指定的服务暂停作用，无法启动。
1059 0x0423 指定循环服务从属关系。
1060 0x0424 指定的服务不是安装进来的服务。
1061 0x0425 该服务项目此时无法接收控制讯息。
1062 0x0426 服务尚未启动。
1063 0x0427 无法连线到服务控制程式。
1064 0x0428 处理控制要求时，发生意外状况。
1065 0x0429 指定的资料库不存在。
1066 0x042A 服务传回专属於服务的错误码。
1067 0x042B The process terminated unexpectedly.
1068 0x042C 从属服务或群组无法启动。
1069 0x042D 因为登入失败，所以没有启动服务。
1070 0x042E 在启动之後，服务在启动状态时当机。
1071 0x042F 指定服务资料库锁定无效。
1072 0x0430 指定的服务已经标示为删除。
1073 0x0431 指定的服务已经存在。
1074 0x0432 系统目前正以上一次执行成功的组态执行。
1075 0x0433 从属服务不存在，或已经标示为删除。
1076 0x0434 目前的启动已经接受上一次执行成功的 控制设定。
1077 0x0435 上一次启动之後，就没有再启动服务。
1078 0x0436 指定的名称已经用於服务名称或服务显示 名称。
1100 0x044C 已经到了磁带的最後。
1101 0x044D 到了档案标示。
1102 0x044E 遇到磁带的开头或分割区。
1103 0x044F 到了档案组的结尾。
1104 0x0450 磁带没有任何资料。
1105 0x0451 磁带无法制作分割区。
1106 0x0452 存取多重容体的新磁带时，发现目前 区块大小错误。
1107 0x0453 载入磁带时，找不到磁带分割区资讯。
1108 0x0454 无法锁住储存媒体退带功能。
1109 0x0455 无法解除载入储存媒体。
1110 0x0456 磁碟机中的储存媒体已经变更。
1111 0x0457 已经重设 I/O 汇流排。
1112 0x0458 磁碟机没有任何储存媒体。
1113 0x0459 目标 multi-byte code page，没有对应 Unicode 字元。
1114 0x045A 动态连结程式库 (DLL) 起始常式失败。
1115 0x045B 系统正在关机。
1116 0x045C 无法中止系统关机，因为没有关机的动作在进行中。
1117 0x045D 因为 I/O 装置发生错误，所以无法执行要求。
1118 0x045E 序列装置起始失败，会取消载入序列驱动程式。
1119 0x045F 无法开启装置。这个装置与其他装置共用岔断要求 (IRQ)。 至少已经
有一个使用同一IRQ 的其他装置已经开启。
1120 0x0460 A serial I/O operation was completed by another write to the serial port. (The IOCTL_SERIAL_XOFF_COUNTER reached zero.)
1121 0x0461 因为已经过了逾时时间，所以序列 I/O 作业完成。
(IOCTL_SERIAL_XOFF_COUNTER 不是零。)
1122 0x0462 在磁片找不到任何的 ID 位址标示。
1123 0x0463 磁片磁区 ID 栏位与磁片控制卡追踪位址 不符。
1124 0x0464 软式磁碟机控制卡回报了一个软式磁碟机驱动程式无法识别 的错误。
1125 0x0465 软式磁碟机控制卡传回与暂存器中不一致的结果。
1126 0x0466 存取硬碟失败，重试後也无法作业。
1127 0x0467 存取硬碟失败，重试後也无法作业。
1128 0x0468 存取硬碟时，必须重设磁碟控制卡，但是 连重设的动作也失败。
1129 0x0469 到了磁带的最後。
1130 0x046A 可用伺服器储存空间不足，无法处理这项指令。
1131 0x046B 发现潜在的锁死条件。
1132 0x046C 指定的基本位址或档案位移没有适当 对齐。
1140 0x0474 尝试变更系统电源状态，但其他的应用程式或驱动程式拒绝。
1141 0x0475 系统 BIOS 无法变更系统电源状态。
1150 0x047E 指定的程式需要新的 Windows 版本。
1151 0x047F 指定的程式不是 Windows 或 MS-DOS 程式。
1152 0x0480 指定的程式已经启动，无法再启动一次。
1153 0x0481 指定的程式是为旧版的 Windows 所写的。
1154 0x0482 执行此应用程式所需的程式库档案之一毁损。
1155 0x0483 没有应用程式与此项作业的指定档案建立关联。
1156 0x0484 传送指令到应用程式发生错误。
1157 0x0485 找不到执行此应用程式所需的程式库档案。
1200 0x04B0 指定的装置名称无效。
1201 0x04B1 装置现在虽然未连线，但是它是一个记忆连线。
1202 0x04B2 尝试记忆已经记住的装置。
1203 0x04B3 提供的网路路径找不到任何网路提供程式。
1204 0x04B4 指定的网路提供程式名称错误。
1205 0x04B5 无法开启网路连线设定档。
1206 0x04B6 网路连线设定档坏掉。
1207 0x04B7 无法列举非容器。
1208 0x04B8 发生延伸的错误。
1209 0x04B9 指定的群组名称错误。
1210 0x04BA 指定的电脑名称错误。
1211 0x04BB 指定的事件名称错误。
1212 0x04BC 指定的网路名称错误。
1213 0x04BD 指定的服务名称错误。
1214 0x04BE 指定的网路名称错误。
1215 0x04BF 指定的资源分享名称错误。
1216 0x04C0 指定的密码错误。
1217 0x04C1 指定的讯息名称错误。
1218 0x04C2 指定的讯息目的地错误。
1219 0x04C3 所提供的条件与现有的条件组发生冲突。
1220 0x04C4 尝试与网路伺服器连线，但是 与该伺服器的连线已经太多。
1221 0x04C5 其他网路电脑已经在使用这个工作群组或网域名称。
1222 0x04C6 网路没有显示出来或者没有启动。
1223 0x04C7 使用者已经取消作业。
1224 0x04C8 要求的作业无法在已经开启使用者对应区段的档案执行。
1225 0x04C9 远端系统拒绝网路连线。
1226 0x04CA 关闭网路连线。
1227 0x04CB 网路传输端点已经有相关连的位址。
1228 0x04CC 位址尚未有相关的网路端点。
1229 0x04CD 尝试在不存在的网路连线作业。
1230 0x04CE 在作用中的网路连线上执行无效的作业。
1231 0x04CF 无法传输到远端网路。
1232 0x04D0 无法连线到远端系统。
1233 0x04D1 远端系统不支援传输通讯协定。
1234 0x04D2 远端系统的目的地网路端点没有作何执行中的服务。
1235 0x04D3 要求已经中止。
1236 0x04D4 进端系统已经中断网路连线。
1237 0x04D5 无法完成作业，请重试。
1238 0x04D6 无法与伺服器连线，原因是这个帐户已经到达同时连线数目 的上限。
1239 0x04D7 尝试在这个帐户未授权的时间登入网路。
1240 0x04D8 这个帐户无法从这个地方登入网路。
1241 0x04D9 网路位址无法用於这个要求的作业。
1242 0x04DA 服务已经登记。
1243 0x04DB 指定的服务不存在。
1244 0x04DC 作业无法执行，原因是使用者尚未授权使用。
1245 0x04DD 要求的作业无法执行，原因是使用者尚未登入网路。 指定的服务不存
在。
1246 0x04DE 传回要求呼叫者继续工作的讯息。
1247 0x04DF 在完成起始作业之後，尝试再执行起始作业。
1248 0x04E0 没有其他的近端装置。
1300 0x0514 并未指定所有的参照权限给呼叫者。
1301 0x0515 帐户名称与安全识别码之间尚有未执行完成的连线。
1302 0x0516 此帐户并未设定特别的系统配额限制。
1303 0x0517 没有可用的加密机码。传回一个已知的加密机码。
1304 0x0518 NT 密码太复杂，无法转换成 LAN Manager 密码。传回的LAN Manager
密码是一个空字串。
1305 0x0519 修正层次不详。
1306 0x051A 表示两个修订阶层不相容。
1307 0x051B 此安全识别码无法指定为这个物件的拥有者。
1308 0x051C 此安全识别码无法指定为主要的物件群组。
1309 0x051D An attempt has been made to operate on an impersonation token
by a thread that is not currently impersonating a client.
1310 0x051E 不可以关闭群组。
1311 0x051F 目前没有可登入的伺服器，所以无法处理登入要求。
1312 0x0520 指定登入作业阶段不存在。该作业阶段可能已经 结束。
1313 0x0521 指定的权限不存在。
1314 0x0522 用户端未列出要求的权限。
1315 0x0523 所提供的名称格式与帐户名称不符。
1316 0x0524 指定的使用者已经存在。
1317 0x0525 指定的使用者不存在。
1318 0x0526 指定的群组已经存在。
1319 0x0527 指定的群组不存存。
1320 0x0528 指定的使用者帐户已经是指定群组的成员，或 指定的群组因为内含成
员而无法删除。
1321 0x0529 指定的使用者帐户不是指定的群组帐户成员。
1322 0x052A 上一次留下来的管理帐户无法关闭或 删除。
1323 0x052B 无法更新密码。所输入的密码不正确。
1324 0x052C 无法更新密码。所输入的新密码内含不符合 密码规定。
1325 0x052D 因为违反密码更新规则，所以无法更新密码。
1326 0x052E 登入失败: 无法辨识的使用者名称或密码错误。
1327 0x052F 登入失败: 使用者帐户限制。
1328 0x0530 登入失败: 违反帐户登入时间限制。
1329 0x0531 登入失败: 使用者不可登入这部电脑。
1330 0x0532 登入失败: 指定的帐户密码过期。
1331 0x0533 登入失败: 帐户目前无效。
1332 0x0534 帐户名称与帐户识别码不符。
1333 0x0535 一次要求太多的近端使用者识别码 (local user identifiers， LUIDs)。 1334 0x0536 没有可用的近端使用者识别码 (local user identifiers ，LUIDs)。
1335 0x0537 安全识别码的转授权部份对这个特殊用法无效。
1336 0x0538 无效的存取控制清单结构。
1337 0x0539 安全识别码结构无效。
1338 0x053A 安全叙述子结构无效。
1340 0x053C 无法建立继承的存取控制清单或存取控制项目。
1341 0x053D 伺服器目前无效。
1342 0x053E 伺服器目前可以使用。
1343 0x053F 所提供的值是无效的识别码授权值。
1344 0x0540 没有可供安全资讯更新使用的记忆体。
1345 0x0541 指定的属性无效，或指定的属性与整个群组的 属性不相容。
1346 0x0542 Either a required impersonation level was not provided, or the provided impersonation level is invalid.
1347 0x0543 Cannot open an anonymous level security token.
1348 0x0544 所要求的认可资讯类别无效。
1349 0x0545 The type of the token is inappropriate for its attempted use.
1350 0x0546 无法在没有相关连安全性的物件执行 安全
1351 0x0547 指示无法连到 Windows NT 伺服器，或网域中的物件 受到保护，所以
无法撷取所需的物件。
1352 0x0548 安全帐户管理程式或区域安全授权伺服器状态 不正确，所以无法执行
安全作业。
1353 0x0549 网域状态错误，所以无法执行安全作业。
1354 0x054A 只有网域的主网域控制器才能使用这项作业。
1355 0x054B 指定的网域不存在。
1356 0x054C 指定的网域已经存在。
1357 0x054D 尝试超过每个伺服器的网域数目限制。
1358 0x054E 因为磁碟上发生严重的储存媒体错误或是资料结构毁损， 所以无法完
成所要求的作业。
1359 0x054F 安全帐户资料库内有内部不一致的状况。
1360 0x0550 通用的存取类型包含在某一存取遮罩中， 这个遮罩已经对应到非通用
的类型。
1361 0x0551 安全叙述子的格式不正确 (absolute or self-relative)。 1362 0x0552 所要求的动作只能给登入使用。 而目前呼叫该动作的处理并未登录为
登入。
1363 0x0553 无法利用已经在使用的识别码来启动新的作业阶段。
1364 0x0554 无法识别指定的确认包装。
1365 0x0555 登入作业阶段不是在与要求的作业一致的 状态。
1366 0x0556 登入作业阶段识别码已经在使用中。
1367 0x0557 登入要求包含无效的登入类型值。
1368 0x0558 Unable to impersonate via a named pipe until data has been
read from that pipe.
1369 0x0559 The transaction state of a Registry subtree is incompatible
with the requested operation.
1370 0x055A 内部安全资料库毁损。
1371 0x055B 无法在内建帐户执行这项作业。
1372 0x055C 无法在这个内建的特殊群组执行这项操作。
1373 0x055D 无法在这个内建的特殊使用者执行这项作业。
1374 0x055E 因为群组目前是使用者的主要群组，所以不能 从群组移除使用者。
1375 0x055F The token is already in use as a primary token.
1376 0x0560 指定的区域群组不存在。
1377 0x0561 指定的帐户名称不是区域群组的成员。
1378 0x0562 指定的帐户名称已经是区域群组的成员。
1379 0x0563 指定的区域群组已经存在。
1380 0x0564 登入失败: 使用者无权在这部电脑以要求的 登入类型登入。
1381 0x0565 The maximum number of secrets that may be stored in a single
system has been exceeded.
1382 0x0566 The length of a secret exceeds the maximum length allowed.
1383 0x0567 本区安全性授权资料库内含的资料不一致。
1384 0x0568 在登入时，使用者的安全内容累积太多的 安全识别码。
1385 0x0569 登入失败: 使用者尚未被许可在这个台脑使用要求的登入类型。
1386 0x056A 交叉加密的密码需要变更使用者的密码。
1387 0x056B 因为成员不存在，所以无法将新的成员新增到 区域群组。
1388 0x056C 因为成员的帐号类型不正确，所以无法新增到区域群组。
1389 0x056D 指定的安全 ID 太多。
1390 0x056E 需要用到交互加密的密码才能变更这个使用者的密码。
1391 0x056F 表示存取控制清单没有可继承的元件
1392 0x0570 档案或目录已毁，无法读取资料。
1393 0x0571 磁碟结构已毁无法读取。
1394 0x0572 没有指定之登入作业阶段的使用者作业阶段机码。
1395 0x0573 正在存取的服务仅授权特定数目的连线。 而目前连线数目已达上限，
所以无法再建立服务连线。
1400 0x0578 视窗代码无效。
1401 0x0579 功能表识别码无效。
1402 0x057A 游标控制码无效。
1403 0x057B 加速键表格控制码无效。
1404 0x057C Invalid hook handle. 1405 0x057D 无效的多重视窗位置结构控制。
1406 0x057E 无法建立最上层的子视窗。
1407 0x057F 找不到 window class。
1408 0x0580 无效的视窗，属於其他的执行绪。
1409 0x0581 快速键已经登记。
1410 0x0582 Class 已经存在。
1411 0x0583 Class 不存在。
1412 0x0584 Class 仍然有开启的视窗。
1413 0x0585 无效的索引。
1414 0x0586 图示控制码无效。
1415 0x0587 使用专用的 DIALOG 视窗文字。
1416 0x0588 清单方块识别码找不到。
1417 0x0589 找不到任何通配字元。
1418 0x058A 执行绪 (thread) 没有开启剪贴簿。
1419 0x058B 快速键没有登记。
1420 0x058C 不是有效的对话视窗。
1421 0x058d Control ID 找不到。
1422 0x058E 清单方块的讯息无效，因为没有任何的编辑控制码。
1423 0x058F 视窗不是一个清单方块。
1424 0x0590 高度必须小於 256。
1425 0x0591 装置范围 (DC) 控制码无效。
1426 0x0592 锁定程序类型无效。
1427 0x0593 锁定程序无效。
1428 0x0594 没有模组控制码就不能设定非本区的锁定。
1429 0x0595 This hook procedure can only be set globally.
1430 0x0596 The journal hook procedure is already installed.
1431 0x0597 The hook procedure is not installed.
1432 0x0598 无效的单一选择清单方块讯息。
1433 0x0599 LB_SETCOUNT 传送到 non-lazy 清单方块。
1434 0x059A 这个清单方块不支援跳格停驻。
1435 0x059B 不可毁损由其他执行绪所建立的物件。
1436 0x059C 子视窗不能有功能表。
1437 0x059D 视窗没有系统功能表。
1438 0x059E 无效的讯息方块样式。
1439 0x059F 无效的 system-wide (SPI_*) 参数。
1440 0x05A0 萤幕已经锁定。
1441 0x05A1 All handles to windows in a multiple-window position structure
must have the same parent.
1442 0x05A2 视窗不是子视窗。
1443 0x05A3 GW_* 指令无效。
1444 0x05A4 执行绪识别码无效。
1445 0x05A5 无法处理多重文件介面视窗的讯息。
1446 0x05A6 即现式功能表已在作用中。
1447 0x05A7 视窗没有卷轴。
1448 0x05A8 卷轴范围不可以大於 0x7FFF。 1449 0x05A9 无法以指定的方式显示或移除视窗。
1450 0x05AA 系统资源不足，无法完成所要求的服务。
1451 0x05AB 系统资源不足，无法完成所要求的服务。
1452 0x05AC 系统资源不足，无法完成所要求的服务。
1453 0x05AD 配额不足，无法完成所要求的服务。
1454 0x05AE 配额不足，无法完成所要求的服务。
1455 0x05AF 这项作业的 paging 档太小，无法完成作业。
1456 0x05B0 找不到功能表项目。
1500 0x05DC 事件记录档坏掉。
1501 0x05DD 无法开启事件记录档，因此事件记录服务没有启动。
1502 0x05DE 事件记录档已满。
1503 0x05DF 事件记录档已经变更。
1700 0x06A4 字串连结错误。
1701 0x06A5 连结控制码 (binding handle) 的类型错误。
1702 0x06A6 连结控制码 (binding handle) 无效。
1703 0x06A7 不支援 RPC 通讯协定顺序。
1704 0x06A8 RPC 通讯协定顺序无效。
1705 0x06A9 字串 universal unique identifier (UUID) 无效。
1706 0x06AA 端点格式错误。
1707 0x06AB 网路位址无效。
1708 0x06AC 找不到端点。
1709 0x06AD 逾时数值无效。
1710 0x06AE 找不到物件的 universal unique identifier (UUID)。
1711 0x06AF 物件的 universal unique identifier (UUID) 已经登记。
1712 0x06B0 类型的 universal unique identifier (UUID) 已经登记。
1713 0x06B1 RPC 伺服器已经在听候。
1714 0x06B2 没有登记通讯协定顺序。
1715 0x06B3 RPC 伺服器没有听候指令。
1716 0x06B4 管理员类型不详。
1717 0x06B5 介面不详。
1718 0x06B6 没有连线。
1719 0x06B7 没有通讯协定顺序。
1720 0x06B8 无法建立端点。
1721 0x06B9 资源不足，无法完成作业。
1722 0x06BA RPC 伺服器无法使用。
1723 0x06BB RPC 伺服器太忙，无法完成这项作业。
1724 0x06BC 网路选项无效。
1725 0x06BD 这个执行绪 (thread) 没有任何执行的远端程序呼叫。
1726 0x06BE 远端程序呼叫失败。
1727 0x06BF 远端程序呼叫失败，所以没有执行。
1728 0x06C0 远端程序呼叫 (remote procedure call，RPC) 通讯协定发生错误。
1730 0x06C2 RPC 伺服器不支援转送语法。
1732 0x06C4 不支援 universal unique identifier (UUID) 的类型。
1733 0x06C5 封签 (tag) 无效。
1734 0x06C6 阵列无效。
1735 0x06C7 连结中没有项目名称。
1736 0x06C8 名称语法无效。
1737 0x06C9 名称语法不被支援。
1739 0x06CB 没有任何网路位址可以用来建立全球唯一的识别码 (UUID)。
1740 0x06CC 端点重复。
1741 0x06CD 授权类型不详。
1742 0x06CE 呼叫次数的上限太小。
1743 0x06CF 字串太长。
1744 0x06D0 找不到 RPC 通讯协定顺序。
1745 0x06D1 程序号码超出范围。
1746 0x06D2 连结中没有包含任何确认资讯。
1747 0x06D3 确认服务不详。
1748 0x06D4 确认层次不详。
1749 0x06D5 安全内容无效。
1750 0x06D6 确认服务不详。
1751 0x06D7 项目无效。
1752 0x06D8 伺服器端点无法执行这个作业。
1753 0x06D9 端点对应程式没有其他的端点。
1754 0x06DA 没有汇出任何的介面。
1755 0x06DB 项目名称不完整。
1756 0x06DC 版本选项无效。
1757 0x06DD 没有其他的成员。
1758 0x06DE 没有任何资料可以取消汇出。
1759 0x06DF 介面找不到。
1760 0x06E0 项目已经存在。
1761 0x06E1 项目找不到。
1762 0x06E2 名称服务无法使用。
1763 0x06E3 网路位址系列无效。
1764 0x06E4 要求的作业不受支援。
1765 0x06E5 没有可用来模拟的安全内容。
1766 0x06E6 远端程序呼叫 (RPC) 发生内部错误。
1767 0x06E7 RPC 伺服器尝试用整数除以 0。
1768 0x06E8 RPC 伺服器发生位址设定错误。
1769 0x06E9 RPC 伺服器的浮点作业导致除以 0 的运算。
1770 0x06EA RPC 伺服器发生浮点 underflow。 1771 0x06EB RPC 伺服器发生浮点 overflow。 1772 0x06EC 清单中可供连结自动代码 的 RPC 伺服器已经用完。
1773 0x06ED 无法开启字元转换表档案。
1774 0x06EE 包含字元转换表的档案少於 512 位元组。
1775 0x06EF 在远端程序呼叫时，将空的 context 代码从 用户端传送到主电脑。
1777 0x06F1 在远端程序呼叫时内容处理改变。
1778 0x06F2 传送给远端程序呼叫的连结代码不符。
1779 0x06F3 The stub is unable to get the remote procedure call handle. 1780 0x06F4 A null reference pointer was passed to the stub.
1781 0x06F5 The enumeration value is out of range.
1782 0x06F6 位元组计数太小。
1783 0x06F7 The stub received bad data.
1784 0x06F8 所提供的使用者缓冲区对要求的作业无效。
1785 0x06F9 无法辨识磁碟储存媒体。磁碟储存媒体可能还没有制作格式。
1786 0x06FA The workstation does not have a trust secret.
1787 0x06FB The SAM database on the Windows NT Server does not have a
computer account for this workstation trust relationship. 1788 0x06FC The trust relationship between the primary domain and the trusted domain failed. 1789 0x06FD The trust relationship between this workstation and the primary domain failed. 1790 0x06FE 网路登入失败。
1791 0x06FF 远端程序呼叫已经在这个执行绪进行中。
1792 0x0700 尝试登入，但网路登入服务尚未启动。
1793 0x0701 使用者的帐户已经过期。
1794 0x0702 The redirector is in use and cannot be unloaded.
1795 0x0703 指定的印表机驱动程式已经安装。
1796 0x0704 指定的连接埠无法识别。
1797 0x0705 印表机驱动程式无法识别。
1798 0x0706 列印处理器不详。
1799 0x0707 指定的分隔档无效。
1800 0x0708 指定的优先顺序无效。
1801 0x0709 印表机名称无效。
1802 0x070A 印表机已经存在。
1803 0x070B 印表机指令无效。
1804 0x070C 指定的资料类型无效。
1805 0x070D 指定的 Environment 无效。
1806 0x070E 没有其他的连结。
1807 0x070F 这是一个跨网域的信任帐户。请用您的全域性使用者帐户或区域性使用
者帐户来存取伺服器。
1808 0x0710 这是一个电脑帐户。请使用您的全域性使用者帐户或区域性使用者帐户
来存取这个伺服器。
1809 0x0711 这是一个伺服端信任帐户。请用您的全域性使用者帐户或区域性使用者
帐户来存取伺服器。
1810 0x0712 指定的网域名称或安全识别码与网域信用资讯 不符。
1811 0x0713 伺服器正在使用中，无法卸载。
1812 0x0714 指定的影像档案没有有包含资源区段。
1813 0x0715 在影像档找不到指定的资源类型。
1814 0x0716 在影像档找不到指定的资源名称。
1815 0x0717 在影像档找不到指定的资源语系识别码。
1816 0x0718 可用的配额不足，无法处理这项指令。
1817 0x0719 登录任何介面。
1818 0x071A 处理这项呼叫的时候，伺服器发生变更。
1819 0x071B 连结代码没有包含所有必须的资讯。
1820 0x071C 通讯失败。
1821 0x071D 要求的认证层次不被支援。
1822 0x071E 没有登记任何主要的名称。
1823 0x071F 指定的错误不是有效的 Windows RPC 错误码。
1824 0x0720 A UUID that is valid only on this computer has been allocated.
1825 0x0721 发生安全包装指定错误。
1826 0x0722 没有取消执行绪 (THREAD) 1827 0x0723 针对编码/解码的代码进行无效的作业。
1828 0x0724 Incompatible version of the serializing package.
1829 0x0725 不相容的 RPC stub 版本。
1898 0x076A 找不到群组成员。
1899 0x076B 无法建立 endpoint mapper 资料库。
1900 0x076C The object universal unique identifier (UUID) is the nil UUID.
1901 0x076D 指定的项目无效。
1902 0x076E 指定表单名称错误。
1903 0x076F 指定的表单大小错误。
1904 0x0770 指定的印表机控制码已经在等候。
1905 0x0771 指定的印表机已经删除
1906 0x0772 印表机的状态错误。
1907 0x0773 使用者在第一次登入之前，必须先变更它的密码。
1908 0x0774 找不到这个网域的网域控制器。
1909 0x0775 参照的帐户目前被锁定，无法登入。
2000 0x07D0 像素格式无效。
2001 0x07D1 指定的驱动程式无效。
2002 0x07D2 视窗样式或 class 属性对这项作业无效。
2003 0x07D3 不支援所要求的中继档作业。
2004 0x07D4 不支援要求的传输作业。
2005 0x07D5 不支援要求的剪辑作业。
2202 0x089A 指定的使用者名称无效。
2250 0x08CA 网路连线不存在。
2401 0x0961 这个网路连线已经开启档案或者要求暂停。
2402 0x0962 现行的连线仍然存在。
2404 0x0964 装置正在使用中，无法中断连线。
3000 0x0BB8 指定的印表机监视器不详。
3001 0x0BB9 指定的印表机驱动程式正在使用中。
3002 0x0BBA 找不到排存档。
3003 0x0BBB 没有发出 StartDocPrinter 呼叫。
3004 0x0BBC 没有发出 AddJob 呼叫。
3005 0x0BBD 指定的列印处理器已经安装。
3006 0x0BBE 指定列印监控程式已经安装。
4000 0x0FA0 在处理指令时，WINS 发生错误。
4001 0x0FA1 无法删除区域的 WINS。
4002 0x0FA2 The importation from the file failed. 4003 0x0FA3 制作备份失败。以前执行过完整的备份吗 ?
4004 0x0FA4 无法制作备份，请检查目录。
4005 0x0FA5 名称不在 WINS 资料库中。
4006 0x0FA6 不可用未设定的印表机来取代。
6118 0x17E6 这个工作群组的服务清单目前无法使用。


Microsoft Windows 2000 是一个强大的操作系统，为我们提供了以往Windows 9x从未有过的安全性能，可是你是否感觉某些地方的设置还不够呢，这里就对Windows 2000 的注册表进行一些修改来达到我们的目的。

一、修改开始菜单和任务栏
由于以往不少文章对 Windows 9x 下的修改方法介绍了不少，所以有一些常见的我这里就不再赘述了：）
另外请注意，此次更改的注册表项目是在HKEY_CURRENT_USER下的，如果只想针对某一用户则只需要修改HKEY_USERS\用户代码（比如S-1-5-21-448539723-113007714-842925246-1000） 下的相应键值就可以了。

1.禁止开始菜单上的上下拖动
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoChangeStartMenu的DWORD，然后将它赋值为：1 (0x1)即可

2.禁止更改任务栏和开始菜单设置
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoSetTaskbar的DWORD，然后将它赋值为 1 (0x1)即可

3.不保留最近打开文档的纪录
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoRecentDocsHistory的DWORD，然后将它赋值为 1 (0x1)即可

4.禁用个性化菜单
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为Intellimenus的DWORD，然后将它赋值为 1 (0x1)即可

5.禁用用户追踪功能
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoInstrumentation的DWORD，然后将它赋值为 1 (0x1)即可
PS:用户追踪功能是系统跟踪用户使用的程序、用户导航的路径和用户打开的文档的一种功能。系统用这个信息来自定义 Windows 功能，如个性化菜单等。

6.在“运行”中添加“在单独的内存空间中运行”的选项
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个MemCheckBoxInRunDlg的DWORD，然后将它赋值为 1 (0x1)即可
PS:在默认情况下，所有十六位程序都在单一共享的 VDM 进程中作为线程运行。在这种情况下，这些程序共享分配给 VDM（虚拟DOS机器） 进程的内存空间，因此不能同时运行。我们的设置就是允许用户在专用的(不是共享的)VDM进程中运行十六位程序。另外复选框只有在用户在“运行”对话框中输入十六位程序时才被启用。

7.防止系统通过进行一个综合目标驱动器的寻找解析一个快捷键。（仅限于NTFS格式硬盘）
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoResolveSearch的DWORD，然后将它赋值为 1 (0x1)即可
PS：在默认的情况下，当系统无法为快捷键(.lnk)找到目标文件，它寻找所有与快捷键有关的路径。如目标文件位于 NTFS 分区，系统会使用目标文件的 ID 去寻找路径。我们这样设置可以防止系统通过进行一个综合目标驱动器的寻找解析一个快捷键。

8.防止系统使用 NTFS 跟踪功能解析一个快捷键。（仅限于NTFS格式硬盘）
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoResolveTrack的DWORD，然后将它赋值为 1 (0x1)即可

9.用灰色文字显示安装不完全的程序的「开始」菜单快捷方式
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为GreyMSIAds的DWORD，然后将它赋值为 1 (0x1)即可
PS:使用该功能后，打开「开始」菜单的速度就会变慢。

二、修改桌面设置

1.隐藏桌面的所有图标
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoDesktop的DWORD，然后将它赋值为 1 (0x1)即可

2.从桌面上删除“我的文档”
在HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为NonEnum的项，然后再其下面新建一个名为{450D8FBA-AD25-11D0-98A8-0800361B1103}的DWORD，然后将它赋值为 1 (0x1)即可
PS:该功能并不是真正的删除了“我的文档”文件夹

3.在桌面上删除“网上邻居”
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoNetHood的DWORD，然后将它赋值为 1 (0x1)即可

4.从桌面及任务栏上的“快速启动”上删除 Internet Explorer 图标
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoInternetIcon的DWORD，然后将它赋值为 1 (0x1)即可

5.不将最新打开的文档共享添加到“网上邻居”上
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoRecentDocsNetHood的DWORD，然后将它赋值为 1 (0x1)即可

6.禁止用户更改“我的文档”文件夹的路径
在HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为DisablePersonalDirChange的DWORD，然后将它赋值为 1 (0x1)即可

7.防止用户改动桌面工具栏
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoCloseDragDropBands的DWORD，然后将它赋值为 1 (0x1)即可

8.防止用户调整桌面工具栏的长度,并且用户不能再锁定的工具栏上重新放置项目或工具栏
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoMovingBands的DWORD，然后将它赋值为 1 (0x1)即可

9.退出时不保存设置
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoSaveSettings的DWORD，然后将它赋值为 1 (0x1)即可
10.禁用活动桌面
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoActiveDesktop的DWORD，然后将它赋值为 1 (0x1)即可

11.启用活动桌面
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为ForceActiveDesktopOn的DWORD，然后将它赋值为 1 (0x1)即可

12.禁用活动桌面的项目，但可以使用活动桌面
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为ActiveDesktop的项，然后在它下面新建一个名为NoComponents的DWORD，然后将它赋值为 1 (0x1)即可

13.禁止更改活动桌面配置
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoActiveDesktopChanges的DWORD，然后将它赋值为 1 (0x1)即可

14.防止用户将 Web 内容添加到“活动桌面”
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为ActiveDesktop的项，然后在它下面新建一个名为NoAddingComponents的DWORD，然后将它赋值为 1 (0x1)即可

15.只允许使用位图作为墙纸
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为ActiveDesktop的项，然后在它的下面新建一个名为NoHTMLWallPaper的DWORD，然后将它赋值为 1 (0x1)即可

16.禁止更换桌面墙纸
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为ActiveDesktop的项，然后在它的下面新建一个名为NoChangingWallPaper的DWORD,然后将它赋值为 1 (0x1)即可

17.隐藏“外观”
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为System的项，然后在它的下面新建一个名为NoDispAppearancePage的DWORD,然后将它赋值为 1 (0x1)即可

18.禁止控制面版中的“显示”
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为System的项，然后在它的下面新建一个名为NoDispCPL的DWORD,然后将它赋值为 1 (0x1)即可

19.禁止“屏幕保护”选项
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为System的项，然后在它的下面新建一个名为NoDispScrSavPage的DWORD,然后将它赋值为 1 (0x1)即可

20.隐藏“设置”选项
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为System的项，然后在它的下面新建一个名为NoDispSettingsPage的DWORD,然后将它赋值为 1 (0x1)即可

21.隐藏“背景”
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为System的项，然后在它的下面新建一个名为NoDispBackgroundPage的DWORD,然后将它赋值为 1 (0x1)即可

22.禁用“屏幕保护”
在 HKEY_CURRENT_USER\Software\Policies\Microsoft下建立一个名为Windows的项，然后在它的下面建立一个名为Control Panel的项，然后在它的下面建立一个名为Desktop的项，最后在该项的下面建立一个名为ScreenSaveActive的String，然后将它赋值为 "0"即可

23.为所有的屏幕保护都加上密码
在 HKEY_CURRENT_USER\Software\Policies\Microsoft下建立一个名为Windows的项，然后在它的下面建立一个名为Control Panel的项，然后在它的下面建立一个名为Desktop的项，最后在该项的下面建立一个名为ScreenSaverIsSecure的String然后将它赋值为 "1"即可。

24.设定屏幕保护的延迟时间（单位为秒，数值应介于1-86400之间）
在 HKEY_CURRENT_USER\Software\Policies\Microsoft下建立一个名为Windows的项，然后在它的下面建立一个名为Control Panel的项，然后在它的下面建立一个名为Desktop的项，最后在该项的下面建立一个名为ScreenSaveTimeOut的String，然后将它赋值为你需要的时间即可

25.只允许用户使用特定的屏幕保护
在 HKEY_CURRENT_USER\Software\Policies\Microsoft下建立一个名为Windows的项，然后在它的下面建立一个名为Control Panel的项，然后在它的下面建立一个名为Desktop的项，最后在该项的下面建立一个名为SCRNSAVE.EXE的 String，然后将它赋值为你所需要的屏幕保护名称（*.scr）即可
PS:如果目标屏幕保护程序不在%systemroot%\System32里，要输入完整的路径才行

26.指定为响应浏览或搜索 Active Directory 系统显示的的最大数量（这里设置为1000，默认为10000）
在 HKEY_CURRENT_USER\Software\Policies\Microsoft下新建一个名为Windows的项，然后在它下面新建一个名为Directory UI的项，然后在它的下面建立一个名为QueryLimit的DWORD，然后将它赋值为 1000 (0x3e8)即可

27.在 Active Directory 搜索上显示筛选器栏
在 HKEY_CURRENT_USER\Software\Policies\Microsoft下新建一个名为Windows的项，然后在它下面新建一个名为Directory UI的项，然后在它的下面建立一个名为EnableFilter的DWORD，然后将它赋值为 1 (0x1)即可

28.隐藏 Active Directory 文件夹
在 HKEY_CURRENT_USER\Software\Policies下新建一个名为Windows的项，然后在它下面新建一个名为Directory UI的项，然后在它的下面建立一个名为HideDirectoryFolder的DWORD，然后将它赋值为 1 (0x1)
三、修改控制面板

1.禁用“控制面板”包括 Control.exe
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoControlPanel的DWORD赋值为 1 (0x1)即可
PS:同时也禁止了Control.exe的运行

2.禁用某些控制面板文件
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为DisallowCpl的DWORD赋值为 1 (0x1)，然后在
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为DisallowCpl的项，然后在它下面新建一个名为1的String，将你想禁用的控制面板文件赋值给它即可。
PS:如果想同时禁用多个文件，需要在HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下建立相应个数的String，命名方式以阿拉伯数字的形式向下延伸，键值为想要禁用的控制面板文件。

3.只使用特定的控制面板文件
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为RestrictCpl的DWORD赋值为 1 (0x1)，然后在
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为RestrictCpl的项，然后在它的下面新建一个名为1的String，将你所想运行的控制面板文件赋值给它既可。
PS:可以同时启用多个文件，方法同上一条。

“添加/删除程序”相关修改

1.禁用“添加删除程序”（不防止利用别的方法安装、删除程序）
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为Uninstall的项，然后在它的下面新建一个名为NoAddRemovePrograms的DWORD赋值为 1 (0x1)即可。

2.隐藏“更改或删除程序”
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为Uninstall的项，然后在它的下面新建一个名为NoRemovePage的DWORD赋值为 1 (0x1)即可

3.隐藏“添加新程序”
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为Uninstall的项，然后在它的下面新建一个名为NoAddPage的DWORD赋值为 1 (0x1)即可。

4.隐藏“从CD-ROM或软盘添加程序”
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为Uninstall的项，然后在它的下面新建一个名为NoAddFromCDorFloppy的DWORD赋值为 1 (0x1)即可。

__________________
EPOX 4BDA (Intel 845D chipset)
Northwood P4 2.13 (133x16)
HY 512M DDR266*_*
Acer 78G-_-
ATi Radeon 8500
ATi Tv-Wonder PCI
Sound Blaster Live！5.1
Sony 16X DVD-Rom
LITEON CD-RW 16x10x40
2x40G ST340016A
Logitech HID-compliant Wheel Mouse
Acer ERGO Keyboard
BenQ 3300U scanner
:0
PlayStation2
3DMark 2001 SE Benchmark

2002-04-03 03:26

可爱小闪电
看什么看~~

注册日期: Feb 2002
来自: 暗黑天空
发帖数量: 8483
5.隐藏“从Microsoft添加程序”
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为Uninstall的项，然后在它的下面新建一个名为NoAddFromInternet的DWORD赋值为 1 (0x1)即可。

6.隐藏“从网络中添加程序”
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为Uninstall的项，然后在它的下面新建一个名为NoAddFromNetwork的DWORD赋值为 1 (0x1)即可。

7.隐藏“添加/删除组件”
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为Uninstall的项，然后在它的下面新建一个名为NoWindowsSetupPage的DWORD赋值为 1 (0x1)即可。

8.禁用“支持信息”
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为Uninstall的项，然后在它的下面新建一个名为NoSupportInfo的DWORD赋值为 1 (0x1)即可。

9.指定当用户打开 "添加新程序" 页时出现的程序分类。（必须在添加/删除定义中有这种类别）
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies下新建一个名为Uninstall的项，然后在它的下面新建一个名为DefaultCategory的String，然后将你说想要类别赋值给它就行了。

“打印机”相关修改

1.禁止用户安装打印机（包括网络打印机）
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoAddPrinter的DWORD赋值为 1 (0x1)即可。

2.禁止用户删除打印机（包括网络打印机）
在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoDeletePrinter的DWORD赋值为 1 (0x1)即可。

3.让用户使用“添加打印机向导”在网络上寻找共享打印机
在 HKEY_CURRENT_USER\Software\Policies\Microsoft下新建一个名为Windows NT的项，然后在它下面新建一个名为Printers的项，然后在它的下面新建一个名为Wizard的项，最后在它的下面新建一个名为Downlevel Browse的DWORD赋值为 1 (0x1)即可。
4.指定搜索打印机的初始 Active Directory 位置
在HKEY_CURRENT_USER\Software\Policies\Microsoft下新建一个名为Windows NT的项，然后在它下面新建一个名为Printers的项，然后在它的下面新建一个名为Wizard的项，最后在它的下面新建一个名为Default Search Scope的 String，然后将Active Directory的位置赋值给它即可。
PS:如果要在domain.hopeclan.com中搜索，该路径名应该为LDAP://DC=Domain,DC=Hopeclan,DC=com

5.让用户可以使用web打印机（服务器必须支持Internet打印）
HKEY_CURRENT_USER\Software\Policies\Microsoft下新建一个名为Windows NT的项，然后在它下面新建一个名为Printers的项，然后在它的下面新建一个名为Wizard的项，最后在它的下面新建一个名为Printers Page URL的String，然后将搜索的位置赋值给它既可。如："http://www.hopeclan.com/printer"

6.启用Internet打印功能
在 HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft新建一个名为Windows NT的项，然后在它下面新建一个名为Printers的项，然后在它的下面新建一个名为DisableWebPrinting的DWORD赋值为 0 (0)即可。

7.允许剪除（从Active Directory删除）已公布的打印机
在 HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft新建一个名为Windows NT的项，然后在它下面新建一个名为Printers的项，然后在它的下面新建一个名为Immortal的DWORD赋值为 0 (0)即可。

8.允许在Active Directory上公布打印机
在 HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\新建一个名为Windows NT的项，然后在它下面新建一个名为Printers的项，然后在它的下面新建一个名为PublishPrinters的DWORD赋值为 1 (0x1)即可。

9.向域的打印浏览主服务器公布共享打印机
在 HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft新建一个名为Windows NT的项，然后在它下面新建一个名为Printers的项，然后在它的下面新建一个名为ServerThread的DWORD赋值为 1 (0x1)即可。

10.自动在Active Directory上公布新的打印机
在 HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft下新建一个名为Windows NT的项，然后在它下面新建一个名为Printers的项，然后在它的下面新建一个名为Wizard的项，最后在它的下面新建一个名为Auto Publishing的DWORD赋值为 1 (0x1)即可。

11.在打印机文件夹的左边提供支持链接
在 HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft下新建一个名为Windows NT的项，然后在它下面新建一个名为Printers的项，然后在它的下面新建一个名为SupportLink的String，用你的支持链接赋值给它即可。在同一位置再创建名为SupportLinkName的String，用链接的名称赋值给它即可。

“计划任务”相关修改

1.禁止浏览计划任务
在 HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft下新建一个名叫Windows的项，然后在它的下面新建一个名叫Task Scheduler5.0的项，最后在它的下面建立一个叫做Allow Browse的DWORD赋值为 1 (0x1)即可。

2.禁止计划任务的“高级”菜单
在 HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft下新建一个名叫Windows的项，然后在它的下面新建一个名叫Task Scheduler5.0的项，最后在它的下面建立一个叫做Disable Advanced的DWORD赋值为 1 (0x1)即可。

3.禁止用户在计划任务文件夹中通过移动或复制程序添加或删除任务
在 HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft下新建一个名叫Windows的项，然后在它的下面新建一个名叫Task Scheduler5.0的项，最后在它的下面建立一个叫做DragAndDrop的DWORD赋值为 1 (0x1)即可。

4.禁止用户手动启动和停止任务
在 HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft下新建一个名叫Windows的项，然后在它的下面新建一个名叫Task Scheduler5.0的项，最后在它的下面建立一个叫做Execution的DWORD 1 (0x1)即可。

5.防止用户查看和更改一个现存任务的属性
在 HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft下新建一个名叫Windows的项，然后在它的下面新建一个名叫Task Scheduler5.0的项，最后在它的下面建立一个叫做Property Pages的DWORD赋值为 1 (0x1)即可。

6.禁用“创建新任务”
在 HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft下新建一个名叫Windows的项，然后在它的下面新建一个名叫Task Scheduler5.0的项，最后在它的下面建立一个叫做Task Creation的DWORD赋值为 1 (0x1)即可。

7.禁止“删除任务”
在 HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft下新建一个名叫Windows的项，然后在它的下面新建一个名叫Task Scheduler5.0的项，最后在它的下面建立一个叫做Task Deletion的DWORD赋值为 1 (0x1)即可。

“区域选项”设置

1.禁止用户选择Windwos 2000的菜单和对话语言的选择（以禁止“日文”为例）
在 HKEY_CURRENT_USER\Software\Policies\Microsoft下新建一个名为Control Panel的项，然后在它下面新建一个名为Desktop的项，最后在它的下面建立一个名为MultiUILanguageID的String赋值为 "00000411"即可。
Internet Explorer 完全设置 IE属性部分 禁用常规页 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为GeneralTab的DWORD，然后赋值为: 1 (0x1)即可。 禁用更改主页设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为HomePage的DWORD，然后赋值为: 1 (0x1)即可 禁用更改辅助功能设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Accessibility的DWORD，然后赋值为: 1 (0x1)即可 禁用更改临时文件的设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Cache的DWORD，然后赋值为: 1 (0x1)即可 禁用更改颜色设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Colors的DWORD，然后赋值为: 1 (0x1)即可 禁用更改字体设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Fonts的DWORD，然后赋值为: 1 (0x1)即可 禁用更改语言设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Languages的DWORD，然后赋值为: 1 (0x1)即可 禁用更改链接颜色 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为links的DWORD，然后赋值为: 1 (0x1)即可 禁用更改历史纪录设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为History的DWORD，然后赋值为: 1 (0x1)即可 禁用安全项 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为SecurityTab的DWORD，然后赋值为: 1 (0x1)即可 禁用内容项 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为ContentTab的DWORD，然后赋值为: 1 (0x1)即可 禁用更改分级设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Ratings的DWORD，然后赋值为: 1 (0x1)即可 禁用更改证书设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Certificates的DWORD，然后赋值为: 1 (0x1)即可 禁用表单的自动完成功能 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为FORMSuggest的DWORD，然后赋值为: 1 (0x1)即可 禁用自动完成保存密码 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为FORMSuggest Passwords的DWORD，然后赋值为: 1 (0x1)即可 禁止更改配置文件助理设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Profiles的DWORD，然后赋值为: 1 (0x1)即可 禁用连接项 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为ConnectionsTab的DWORD，然后赋值为: 1 (0x1)即可 对拨号连接实行“自动检测” 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings下新建一个名为DialupAutodetect的DWORD，然后赋值为: 1 (0x1)即可 禁用缓存自动代理脚本 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings下新建一个名为EnableAutoProxyResultCache的DWORD，然后赋值为: 0 (0)即可 禁用更改连接设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Connection Settings的DWORD，然后赋值为: 1 (0x1)即可 禁用Internet连接向导 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Connwiz Admin Lock的DWORD，然后赋值为: 1 (0x1)即可 禁用更改代理服务器设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Proxy的DWORD，然后赋值为: 1 (0x1)即可 显示有关代理脚本下载失败的出错信息 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings下新建一个名为DisplayScriptDownloadFailureUI的DWORD，然后赋值为: 1 (0x1)即可 禁用程序项 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为ProgramsTab的DWORD，然后赋值为: 1 (0x1)即可 禁用更改默认浏览器检查 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Check_If_Default的DWORD，然后赋值为: 1 (0x1)即可 禁用更改日历和联系人的设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为CalendarContact的DWORD，然后赋值为: 1 (0x1)即可 禁止更改邮件设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Messaging的DWORD，然后赋值为: 1 (0x1)即可 禁用“重置Web设置”功能 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为ResetWebSettings的DWORD，然后赋值为: 1 (0x1)即可 禁用高级项 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为AdvancedTab的DWORD，然后赋值为: 1 (0x1)即可 禁用更改高级页设置 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为Advanced的DWORD，然后赋值为 (0x1)即可 禁止用户使用标示 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Windows\CurrentVersion\Identities下新建一个名为Locked Down的DWORD，然后赋值为: 1 (0x1)即可 设置Internet Explorer的菜单 “文件”菜单 禁用“另存为……” 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoBrowserSaveAs的DWORD，然后赋值为: 1 (0x1)即可 禁用另存为“Web页，全部” 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions下新建一个名为NoBrowserSaveWebComplete的DWORD，然后赋值为: 1 (0x1)即可 禁用关闭浏览器 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoBrowserClose的DWORD，然后赋值为: 1 (0x1)即可 禁用“新建” 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoFileNew的DWORD，然后赋值为: 1 (0x1)即可 禁用“打开” 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoFileOpen的DWORD，然后赋值为: 1 (0x1)即可
“查看”菜单 禁用“全屏” 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoTheaterMode的DWORD，然后赋值为: 1 (0x1)即可 禁用“源文件” 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoViewSource的DWORD，然后赋值为: 1 (0x1)即可 禁用自定义工具栏的按钮 在HKEY_LOCAL_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoBandCustomize的DWORD，然后赋值为: 1 (0x1)即可 禁用自定义工具栏 在HKEY_LOCAL_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下新建一个名为NoToolbarCustomize的DWORD，然后赋值为: 1 (0x1)即可 “收藏”菜单 禁用“收藏”菜单 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoFavorites的DWORD，然后赋值为: 1 (0x1)即可 禁用添加频道 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions下新建一个名为NoAddingChannels的DWORD，然后赋值为: 1 (0x1)即可 禁用添加脱机页计划 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions下新建一个名为NoAddingSubscriptions的DWORD，然后赋值为: 1 (0x1)即可 禁用脱机页记数 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions下新建一个名为NoChannelLogging的DWORD，然后赋值为: 1 (0x1)即可 禁用频道界面 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions下新建一个名为NoChannelUI的DWORD，然后赋值为: 1 (0x1)即可 禁用编辑和创建计划组 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions下新建一个名为NoEditingScheduleGroups的DWORD，然后赋值为: 1 (0x1)即可 禁用编辑脱机页计划 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Infodeliver\Restrictions下新建一个名为NoEditingSubscriptions的DWORD，然后赋值为: 1 (0x1)即可 禁用删除频道 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions下新建一个名为NoRemovingChannels的DWORD，然后赋值为: 1 (0x1)即可 禁用删除脱机页计划 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Infodeliver\Restrictions下新建一个名为NoRemovingSubscriptions的DWORD，然后赋值为: 1 (0x1)即可 禁用所有已计划的脱机页 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Infodeliver\Restrictions下新建一个名为NoScheduledUpdates的DWORD，然后赋值为: 1 (0x1)即可 禁用下载站点预定内容 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\InfodeliveryRestrictions下新建一个名为NoSubscriptionContent的DWORD，然后赋值为: 1 (0x1)即可 “工具”菜单 禁用“Internet选项” 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoBrowserOptions的DWORD，然后赋值为: 1 (0x1)即可 “帮助”菜单 禁用“Netscape用户”菜单 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoHelpItemNetscapeHelp的DWORD，然后赋值为: 1 (0x1)即可 禁用“每日提示” 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoHelpItemTipOfTheDay的DWORD，然后赋值为: 1 (0x1)即可 禁用“教程” 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoHelpItemTutorial的DWORD，然后赋值为: 1 (0x1)即可 禁用“发送反馈意见” 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoHelpItemSendFeedback的DWORD，然后赋值为: 1 (0x1)即可 其它 禁用鼠标右键 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoBrowserContextMenu的DWORD，然后赋值为: 1 (0x1)即可 禁用“在新窗口打开” 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoOpeninNewWnd的DWORD，然后赋值为: 1 (0x1)即可 禁用“将该程序保存到磁盘” 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoSelectDownloadDir的DWORD，然后赋值为: 1 (0x1)即可 禁用自定义搜索 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery Restrictions下新建一个名为NoSearchCustomization的DWORD，然后赋值为: 1 (0x1)即可 禁用IE的外部商标 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoExternalBranding的DWORD，然后赋值为: 1 (0x1)即可 禁用F3的查找功能 在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions下新建一个名为NoFindFiles的DWORD，然后赋值为: 1 (0x1)即可 禁用IE组件自动安装 在HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Infodelivery下新建一个名为Restrictions\NoJITSetup的DWORD，然后赋值为: 1 (0x1)即可 禁用显示初始屏幕 在HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions下新建一个名为NoSplash的DWORD，然后赋值为: 1 (0x1)即可 禁用检查IE更新 在HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions下新建一个名为NoUpdateCheck的DWORD，然后赋值为: 1 (0x1)即可


IE5.X@6.0选项控制大全

近来，很多网友在各大BBS提出一个相同的问题----IE选项全部或其中某几个不能使用，怎么办？本来有关IE的选项的问题Solon已经发表过相关的文章，但是还是有很多不是很了解注册表的朋友看不懂，在这种情况下，我只好重新解释一下相关的Dword值的用途，希望大家能够理解。如果还是不能够理解的话，就到这里下载一个还原文件吧。

特别注意：有些系统没有以下的键值，需要手工添加：

HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\GeneralTab Internet Explorer选项中的常规
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\SecurityTab Internet Explorer选项中的安全
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\ContentTab Internet Explorer选项中的内容
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\ConnectionsTab Internet Explorer选项中的连接
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\ProgramsTab Internet Explorer选项中的程序
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\AdvancedTab Internet Explorer选项中的高级
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\PrivacyTab Internet Explorer选项中的隐私 (IE6中才有)

以上是几个大项，小项的解释在下面：
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Colors 颜色
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Links 链接
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Fonts 字体
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Languages 语言
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Connection Settings 连接
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Proxy 代理
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: HomePage 主页
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: History 历史
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Messaging 程序--电子邮件、新闻组、Internet呼叫
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Ratings 分级审查
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Certificates 证书+发行商
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: CertifPers 证书
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: CertifSite 证书
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: CertifPub 发行商
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Cache IE临时文件大小设置控制
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: AutoConfig 局域网自动配置
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Accessibility 辅助功能
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: SecChangeSettings 安全自定义
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: SecAddSites IE中安全--站点增加控制
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Profiles 内容--个人信息--配置文件
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: formSuggest 内容--个人信息--自动完成--表单
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: formSuggest Passwords 内容--个人信息--自动完成--表单上的用户名和密码
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Connwiz Admin Lock 连接--建立连接
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: CalendarContact 程序--日历、联系人列表
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Advanced 高级
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Settings Internet临时文件
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: ResetWebSettings 程序--重置WEB设置
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Check_If_Default 检查IE是不是默认浏览器

以上就是注册表中IE选项控制键值。
使用方法：假设要屏蔽主页选项，就可以在HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\下建立一个Dwoed值，并修改为1，这样就可以直接取消IE中有关主页的选项。还原方法：将Dword=1修改为Dword=0即可。经过测试，这种方法在98/2000/XP下均有效。

由于本贴所述的IE 与操作系统紧密结合，所以也发贴在操作系统Forum

附件是：IE控制选项恢复注册表文件，使用本文件可以解开被锁定的IE控制选项。


下载影片修复合成全供略
一、mpg文件：
1.51xz推荐：copy/b file.mpg [注：这种方法适用于相同码率的mpg文件合并，但不同码率的mpg文件合并后会出现文件大小合并了，但只能看到第一个文件的内容，所以合并后要仔细检查］
2.用超级解霸的工具集中unitempeg：点击后会出现一个界面，在输入项按顺序选择待合并的文件名，再在输出栏输入输出文件名点开始即可。［注：原理同上，但不同码率的mpg文件它会拒绝合并，对一般使用者较适合］
3.jonny兄推荐：M1-edit Pro 效果最好 ifilm 1.45 简单易用［注：无论mpg文件的码率是否相同都能合并，适合不同码率的mpg文件合并剪裁］
二。001。002。等分割文件：
1。hj-split 2.x-split 执行后都会出现一个split(分割)和一个join(合并)菜单，需要分割时选择文件再输入分割文件大小，系统自动开始分割，从001开始，需要合并时点合并键，系统会让你选择或输入待合并的第一个即<.001>文件，只要你选择正确，系统会自动将选择目录下的所有文件合并！

［注：合并的时候一定要把所有要合并的文件放在同一目录下面］

三。rm文件：

目前只看到一种，斑竹和老解决提供的realproducer,英文版，很有效，文件大小6324K，有些名相同但里面内容不同，安装时得有序列号：212-09483-1266（最早由jonny兄提供），先选择第一个文件后，再点file菜单中的append(版本不对没有这项功能）添加第二个文件，合并完后再继续第三个第四个等，最后保存文件。

［注：要用realproducer plus而不是realproducer basic］

下载地址及序列号（仅供参考）
http://newhua.infosail.com/down/Rea...r_8.5_Setup.exe ;
RealProducer Plus 8.5正式版 由Real公司所出的Real格式文件制作工具。sn:212-08976-3639

四。asf文件的合并：

老解决提供两种办法：1。windows me中的movie maker，但我没用过 2。ppj-asfcuter(名字我记不太清了），文件大小4755K，安装后在所安装的目录中看不到，实际上执行文件安装到windows目录中，文件名ppjasf ,文件大小100K，执行时需转到dos状态，命令： ppjasf <输出文件名> <文件1> <文件2> <文件3>。

注：1. movie maker是重新编码合并的，时间比较长，一般的简单合并不推荐使用。适合不同码率的asf文件合并
2. ppjasf我使用过几次，经常都会出现错误而不成功（不知道是否因为什么原因，和别人交流过他们也有同样的现象），因此不建议使用。（但别急于把它删除，因为后面的wmv它我倒立是有用）
3. 呵呵，说了这么多都是为了介绍这个。推荐使用ASFCut 2.0 beta 1（注意要这个版本才可以，切记）和ASFCutGUI 1.0（ASFCut 的图形*作界面接口程序）吧，在搜新网上有

下载地址 : http://cool.sj.net.cn/~souxin/software/asfcutgui.zip ;
http://cool.sj.net.cn/~souxin/softw...ut_20_beta1.zip ;
］
五。avi文件的合并：virtuaii_d.exe ,用法：选文件，点附加，最后保存。

六。还有一个wmv（记不清了）的文件，老解决也提供有，但刚才找半天没找到，回头由他解答吧！

［注：1. 我用ppjasf合并的wmv能成功（我在windows 2000下*作合并后每次都产生错误日志，不影响别管它），但是看是没问题，就是不能拖动进度条。如果不介意这点就用它吧，速度快！
2. 如果要完美的合并，就还是用windows me中的movie maker吧，毕竟是微软定立的标准嘛。哈哈］

4。如何解决 Midia Player不能放avi文件的问题?

1.下载Divx放炮件
2.我的经验供你参考：我也不太清楚mpeg4是做什么用的，但机器重装后不能放有些文件时装上它就能放了！
［注：mpeg4是一种能将影片压缩成近乎DVD质量的压缩方式］

五。关于jetcar和flashget中多填加多任务的办法

在上述两个软件的任务栏中都有两项：新增下载任务（单个文件下载）和添加成批任务两项，而添加成批文件时有一个前提：要下载的多个文件必须在同一地址，否则只能采用新增下载任务下载！成批文件下载主要用于分割文件的下载！下面以下http://201.10.1.5/ggwsss.mpg.001~201为例说明用法。
先将上面地址复制，然后选择成批文件下载后会出现一个窗口，需填写四项：url、通配符开起序号、终止序号、通配符长度。点击右键选择粘贴将复制的地址复制到url栏，然后将后面的001~201改为(*),在开始序号中填入1，在终止序号中填入201，将通配符设为3位，最后点确定结束，这样地下载任务栏就会出现201个任务。
最后再提醒一点：近段出现不同的文件分割方式，分割时不像x-split和hj-split那样分割为后缀等位的文件，如分割成xxx.1,xxx.2,......xxx.10,xxx.11,....xxx.100,xxx999,......等，这时就得根据文件个数将所有文件分成几个成批文件下载，即后缀1-9为一批，10-99为一批100-999为一批，相应地通配符设为1，2，3.....

［注：jetcar和flashget是同一个软件，开始叫jetcar，后来改名为flashget。

作点补充： 如果网页已经列出了全部的地址,你可以用复制Url的功能:你选择好网页列出了的全部地址,接着复制(Ctrl+C),那样flashget就会列出一个Url的列表（有时候flashget没有列出，你只要打开flashget后按粘贴(Ctrl+V)就会弹出）,在每个地址左方有个选择框,你把要下的就打勾,然后按确定,哈哈,它就开始批量下载了］

六。RM修复软件(老解决) ：你一定有这样的经历：下的rm文件虽然可以播放，但进度条不能拖动。这说明你下的文件不完整。怎么办？这个软件可以帮你忙！

下载地址

http://gk2.gau.hu/~black/rmfix/rmfix.exe ;

使用说明：

要点：rmfix可能会对rm文件造成永久性损坏，所以在使用rmfix之前把要修复的rm文件做备份。

第一种情况：一个完整的rm文件，但只能播放一部分

1：把rm文件拖拽到rmfix程序图标上(注：也可以命令行方式，例如："rmfix c: movie a.rm"
2：这时候rmfix会以dos模式运行并显示出一个菜单，按"A"键切换到自动修复模式。
3：按"2"开始检查所有的数据块，rmfix开始扫描整个文件(需要扫描几分钟时间)
4：当rmfix扫描到一个损坏的数据块的时候，扫描会暂停，按"Y"修复这个块。
5：当数据块扫描全部结束时(按回车键回到主菜单)，按"5"开始重建索引数据(注：播放rm文件无法拖拽时间条就是因为索引数据出错)

现在这个rm文件就能够正常播放了。

第二种情况：修复一个不完整的rm文件(例如一个没有下载完全的rm文件)

1：把rm文件拖拽到rmfix程序图标上(注：也可以命令行方式，例如："rmfix c: movie a.rm"
2：按"C"开始数据块扫描。
3：当rmfix扫描到一个损坏的数据块的时候，扫描会暂停，按"Y"修复这个块。
4：数据块扫描完成的时候rmfix程序结束，这时再次把rm文件拖拽到rmfix程序图标上。
5：按"R"重建索引数据(有索引数据的rm文件在播放的时候才允许使用快进、重放、时间条拖放等控制功能)

(问)：你老哥好运，我下的rmfix.exe一运行就进“dos”还提示说要命令符。真是见脆了。你能将使用的这东西给我一份吗。
(wru1228答)：兄弟你没下错啊，就是这个。用法是：先进入dos状态下，后进入rmfix的目录下运行 rmfix　*: **** ****.rm 第一个星号代表的是盘符，也就是你rm文件所在的盘，后边的一排星号代表的是所在目录和文件名。运行后就按R键，更简单的方法是在windows下把要修复的图标直接拖放到rmfix的图标上然后在弹出的命令框里面按R，就可以等它自己运行了

七。asf转avi方法：由于格式的原因,ASF文件要比同样内容的AVI文件"虚胖"很多,而且可以编辑ASF文件的工具也很少,因此有必要把ASF文件转换为AVI文件.

1. 下? VirtualDub 并安?
http://w1.463.telia.com/~u46307158/...are/vdub13c.zip ;
2.File > Open vedio file > 你要?換的.asf 檔。
3.Vedio > Direct Stream Copy
4.Audio > Full Processing Mode
5. File > Save AVI... > 新avi 名字和路徑
6. ?換完成!

注意:在转换比较大的ASF文件的时候,一定要保证系统有足够的内存或交换文件,否则会导致Virtual-Dub崩溃.http://www.souxin.com有关于Virtual-Dub的更多详细说明.

八。如何一次观看多个rm 文件？

打开资源管理器，进入rm歌曲所在的目录，用鼠标选中了其中几首，敲下回车键，结果只有第一首歌被打开了，播放列表里仍然没有东西。我又想能不能直接用鼠标把所选歌曲一起拖到realplay的肚子里去呢？于是我先启动realplay（8.0版），然后再一次选中那几首歌，此时realplay已经最小化到任务栏上，我按住鼠标不放，拖动那几首歌到任务栏的realplay窗口图标上，稍候，realplay窗口自动被激活（最大化），我继续按着鼠标不放，移动到realplay的界面上，只见鼠标指针右下部立刻出现了一个加号，好兆头！我一松手――奇迹发生了，realplay的播放列表栏被激活，点击播放列表下拉菜单，可以看到我所选的歌目都排列在里面，而realplay已经开始依次播放它们了！怎么样，整个过程要不了５秒钟。（不过还没完，最后让我们到windows的temp文件夹里去看一下，你会发现这里多出来一个ram文件，用记事本打开它，就会发现里面依次排列着我们选中歌曲的路径。其实这个ram文件就是我们梦寐以求的那个realplay播放列表文件。你可以把它保存起来以便下次使用。

九。　如何把ASF格式转换为MPG格式

    首先我想先说明一下，除了本文介绍的方法外，你也可以用其它方法把 ASF 文件先转换为 AVI 格式的文件后，再用相应的软件把 AVI 转换成 MPG 格式。并不是说现在这个方法就是唯一的，请注意灵活变通！

    由于 ASF 视频格式的先天限制，所以它的图象质量总是比不上好的 VCD ，所以你在考虑到底转不转换成 MPG 格式前应该认真考虑清楚到底有没有这个必要。

    如何制作：

    首先你必须要有： DVMpeg 5.0+， VirtualDub 和 Windows Media Tools 这三个软件。

    请先安装 Windows Media Tools 和 DVMPEG，运行 VirtualDub 选择 File->Open 然后打开你想转换的 ASF 文件。

    注意：如果你不是把转换出来的 MPG 文件用来做 VCD 的话，请跳过接着下面的 resize （重新调整大小）这步 。

    选择 File->File Information 来检查 ASF 文件的分辨率尺寸大小，如果显示出来的这个视频文件的分辨率是 320x240 25 fps 的话就要选择 Video->filter 来把分辨率转换到 352x288 。还有就是如果这个视频文件是 29.97/30 fps 的话，也请将它的分辨率调整为 352x240 。如果你确实要调整视频的分辨率的话，请在 Filter mode 这里选择 Precise bicubic 来确保生成作品的质量是最好的。

    选择 Audio->Compression 后选择 DVMpeg 的 DVMpeg Stereo Audio format 立体声格式。

    选择 Audio->Conversion 后选中里面的 44100 Hz, 16 bit and Stereo.

    选择 Audio->Full Processing.

    选择 Video->Full Processing.

    选择 Video->Compression. 选中 DVMPEG 然后按 Configure.

    在 Stream Type 里面选择 Video CD 和 PAL 25 （如果这个 ASF 视频文件是 25fps 或者是 NTSC 格式的 29.97/30fps 的话），最后按下 OK 按钮。

    现在请选择 Select File->Save AVI 把你的AVI文件保存到任何一个文件夹，然后 DVMpeg 就会自动把它转换成 MPG 文件。
十。再谈rm视频文件的制作

    rm格式的视频文件因其体积小巧而十分流行，关于如何制作rm格式的视频文件，已有不少的文章进行过介绍。但就其内容而言均是大同小异，其过程基本都是先用超级解霸等工具将vcd的dat文件转换或抓取成avi格式的视频文件，再用real encoder或real producer将avi文件转换为我们需要的rm文件。但这样做至少有如下缺点：

    1.制作过程耗时太长，将一部90分钟的电影制作成rm格式一般需要4～5个小时。实在让人难以忍受。

    2.硬盘空间耗用巨大，2～3GB的空间占用是常有的事。不少朋友为了在自己有限的硬盘空间里制作rm文件,要么忍痛降低图像分辨率，要么提高avi文件的压缩程度，这对今后的播放效果影响是很大的，特别是全屏播放时，有的干脆把电影分成几段来制作,给播放带来不必要的麻烦。

    有没有更好的方法呢？答案是肯定的。这种方法是先将dat文件转换成mpeg文件，进而得到rm视频文件。具体*作如下：

    首先，利用工具软件mpegtool v1.04将dat文件转成mpeg文件。该软件很容易在网上找到，而且是**软件。该软件的主要作用有两个：一个是把dat格式的文件转换成mpeg格式，另一个是可用来分割mpeg文件。Mpegtool的使用方法十分简单，在“来源”找到要转换的dat文件，在“目的”中添上rm文件的文件名便可进行下一步了。

    如果需要，我们可以利用mpegtool对电影进行剪裁，方法也很简单，输入起始帧和结束帧或直接拖动刻度即可设定。

    还要注意，有些dat文件在转换后有无法播放的现象，可以点选special format选项来解决。

    设定好后，点击“next”转换就开始了，一张VCD碟片只需几分钟。Mpeg文件大小与dat文件差不多，也就是几百兆字节。怎么样很酷吧！！！

    接下来，就要用real producer来压缩了。有些朋友可能会问：“real producer不可以用mpeg文件呀？”其实，这已经是历史了。试试real producer plus 8.0(version 8.0.0.45)吧！它可以很好的利用mpeg文件。过程和其他类型的文件一样，这里就不再赘述。需要注意的问题是：

    1.real producer的版本问题：早期的real producer是不支持mpeg的。还有一些共享的real producer版本只能支持每秒15帧，播放时画面不连贯。

    1.压缩设置问题：如果是在局域网中使用，可选择较高速率并将画面质量设置为最高。对于双语的影碟，音频一定要按双声道模式来处理。

    使用该方法制作rm文件使用时是原来的一半，硬盘空间有700～800M也就足够了。更重要的是可以在不将影片分成若干段的情况下获得质量很高的rm视频文件，播放效果和VCD十分接近。

十一。RealPlayer的使用技巧

.....

5、优化播放质量

    RealPlayer为了能争取更多的用户，在播放器对系统资源的利用率上做了限制。随着电脑配件价格的不断降低，大家的电脑硬件配置越来越高，建议电脑内存在64MB以上的用户可以对RealPlayer进行优化设置：选中“Play(播放)”菜单的“Perfect Play（完美播放）”选项，你会发现RealPlayer的播放质量有所有提高，画面更加清晰流畅！

    6、禁用StartCenter

    在你完成RealPlayer的安装后，在系统的工具兰终会自动出现一个RealPlayer的图标，这就是帮助你在网上接收视频节目的StartCenter，它的作用是在线时使RealPlayer保持能及时收到各种相关的信息。由于StartCenter在启动RealPlayer时会自动随机运行，但在离线使用RealPlayer却又毫无作用，所以不如禁用它，降低系统资源占用率。建议你选择RealPlayer的“View（浏览）”菜单中的“Preferences”（性能）选项，再点击“General（常规）”设置中“StartCenter”栏的“Settings”按钮，然后选中禁用StartCenter的选项。
十二。RealPlayer应用常见问题解答

注：此贴中所指RealPlayer软件为RealPlayer Plus 8.0中文完整版，如果你还没有的话，可去这儿下载：

http://www.wenchuan.com/htm/RealPlayer.htm ;

1.Windows启动后，RealPlayer就自动运行，我用msconfig程序把它禁掉也不成功，请问怎样取消它的自动运行？
答：在RealPlayer中设置一下就行了。视图-->首选项，在“常规”选项卡中点击StartCenter的“设置”按钮，在弹出的窗口中取消“启用StartCenter”选项。

2.安装RealPlayer后，双击MP3文件它就自动跳出来播放，可我更喜欢使用Winamp/超级解霸来播放，请问如何改回去？
答：运行RealPlayer，视图-->首选项，找到“升级”选项卡，点击媒体类型的“自动恢复设置”按钮，在弹出的窗口中将最后两项Mpeg Audio和MP3 PlayLists取消，按两次“确定”按钮存储设置后关闭RealPlayer。然后运行Winamp，Options-->Preferences，在File types中选择想与Winamp关联的文件类型，建议选中Register types on Winamp start项，这样即使别的软件修改了选定文件的关联类型，Winamp也能自动更正回来。如果使用超级解霸，最方便的办法就是卸载重装，或者只能手动修改文件关联了。

3.我在播放rm影碟时，常碰到声音在放，但画面却静止不动的情况，请问如何解决？
答：Real格式本来是为了在网上实时播放用的，压缩率非常高，如果在制作时出了错就没办法解决了。如果碟片文件本身没有问题，可以在RealPlayer中作一点简单设置改善效果：视图-->首选项，找到“连接”选项卡，设置缓冲播放为“至少缓冲30秒才播放”，再找到“性能”选项卡，设置“剪辑高速缓存”，可以设置得大一些，比如我设为50M。

4.我买了张周星弛的经典全集，可它是张双语碟，国/粤语同时播放使我听不清楚影片的对白，请问在RealPlayer中如何*作关掉一个声道？
答：如果rm影碟在制作时未将音频格式设置为立体声音乐，那除非将一个音箱拔掉，没有别的办法。而如果是立体声音频，可以用软件调节，RealPlayer自身不具备调节左右声道的功能，可以使用Windows的自带功能：双击系统栏的小喇叭图标，将音量控制的均衡滑动条向左或向右拉即可。

5.我在用RealPlayer播放影碟时只能一个一个打开文件，非常麻烦，请问它有没有类似Winamp的列表播放功能？
答：RealPlayer未提供生成文件列表的菜单项，如果你不怕麻烦，可以这样做：用记事本新建一个文本文件，在其中键入类似以下内容：

file:f: 01.rm file:f: 02.rm file:f: 03.rm

即格式为：file:[路径][文件名]，并存成以ram为扩展名的文件即可。相信大多数人（包括我在内）都不喜欢这个方法，另外还有一个方法：同时打开RealPlayer和资源管理器，在资源管理器中选择要播放的rm文件拖到RealPlayer的播放窗口即可，如果你要保存这个播放列表，在WindowsTemp下找一下，会找到一个以tmp开头的ram文件，就是临时生成的播放列表，把它复制一份即可。

6.听说Winamp在加放炮件后也能播放rm影碟，请问在哪里下载？
答：《电脑报》上曾刊文说有一个叫Innover的Winamp放炮件可以，但我试了一下不行，后来在Winamp的主页上找到一个叫Tara的放炮件可以用。因为Winamp本身支持播放列表和左右声道的调节，所以安装这个放炮件后播放rm影碟确实很方便，但这个放炮件有个很大的Bug：不能使用全屏播放，否则就不能回到窗口播放了，除非关闭Winamp，另外它需要调用RealPlayer，所以RealPlayer不可不装。去这个网页下载Tara Audio Video for Winamphttp://www.winamp.com/customize/detail.jhtml?componentId=22143另外，由汉化人水手制作的可独立使用的Winamp 2.72全功能增强汉化程序也已内置了此放炮件的汉化版，下载地址http://newhua.infosail.com/down/PWinamp272_PlusAll_SS.zip ;

7.请问如何将ra文件及rm文件中的音频转换为MP3文件格式？
答 ：曾听说有个叫Streambox Ripper的程序可以做到，就当下来试了一下，发现它已去除此功能，只能另想办法了。又在一些论坛上看到有网友说ra2wav软件可以，可是在网上没找到，后来在一个比较0然的机会发现了这个软件：Total Recorder。这是一个录音软件，它有一个非常独特的功能：将别的软件通过声卡发出的声音录制下来，由于它的原理是使用了一个虚拟的声音设备，将别的软件输出的声音经此设备截取再传输到物理声卡上，所以实现了数码录音，无任何失真。

根据软件附带的帮助，它可以：
a.录制来自Internet的声音，包括流式音频（比如rm就是）；
b.录制来自游戏程序的声音；
c.录制用IP电话对话的声音。

Total Recorder 3.0版支持Windows 95/98/Me/NT/2000，并可直接将录制的音频存为MP3文件格式。这个功能是调用外部程序来实现的，在使用前要先设置一下：Options-Settings，找到MP3 encoding选项卡，在Select program for encoding to MP3下拉列表中选取要使用的压缩程序，如果你和我一样安装了JetAudio，只需选MPEG Layer-3 Codec (professional)即可。在设置好后，先按下该软件的录音按钮，再播放rm影碟，Total Recorder就会将声音录制下来。这个软件是共享软件，不注册的话最次只能录制40秒钟的声音。

下载Total Recorder 3.01http://www.highcriteria.com/download/totre301.exe ;

下载Total Recorder 3.0注册码生成器：（3.01版仍可以用http://202.103.100.253/hambo/othergroup19/dm_tre30.zip ;

8.请问如何截取rm影碟中的图像？
答：使用HyperSnap-DX软件，象截取DirectX游戏图像一样用法，先做一点设置：Capture-->Enable Special Capture，选中以DirectX字样开头的两个选项，然后在播放rm影碟时按下Scroll Lock键即可，不管在RealPlayer中如何缩放，所截的图都是原始大小的。

9.我在网上看到一些在线播放的rm文件很不错，可用FlashGet下载的是一些很小的ram文件，并不是影片本身，请问该如何下载这些文件？
答；用记事本打开这些ram文件，你会看到一些以rstp开头的链接，这才是真实的影片所在地址，但用FlashGet等工具是无法下载的。在搜新网上曾见到一款叫Streambox VCR的软件，可把rm、ra、wma、asf等流文件下载到本地再播放，但因为要注册才能用，我还没试过，哪位朋友有兴趣可自行测试。另外还有一个比较“狠”的办法（因为比较“狠”所以也没试过），就是在影片播放完后立即按Reset重启电脑，再运行磁盘扫描程序将找到的内容存为文件就是影片了。下载Streambox VCR 1.0 Beta 3.1http://run.i151.com/software/StreamBox_VCR10B31.zip ;

10.我觉得rm影碟很节省空间，便于收藏，想把VCD转换为这种格式，请问需要什么软件？
答：使用RealProducer制作，它可将wav、mov、avi、au、mpeg文件压制成Real影音文件(ra、rm、ram...)，如果要压缩VCD文件，则应先转换为mpg格式，可使用超级解霸、VCDCutter及**的VCDGear来完成。

RealProducer Plus 8.5及其汉化版下载页面：

http://www.wenchuan.com/htm/RealProducer.htm ;

下载VCDCutter 4.03：

http://dl1.51soft.com/soft/97/vcdcutter403.zip ;

下载VCDGear 1.6d：

http://www.soft999.com/download2/vcdgear16d_win32.zip ;

VCDGear只能以DOS命令行方式调用，比如“VCDGear -dat2mpg 1.dat 1.mpg”即为将1.dat文件转换为1.mpg文件。

RealProducer的具体使用方法可参看这里：

http://www.cpcw.com/2000/03/00030907.htm ;

11.我想保存rm影碟中的某一片断，该如何实现？
答：用RealProducer软件就可以做到，File-->Edit RealMedia File，在弹出的窗口中打开rm文件按屏幕显示进行*作即可。

12.除RealPlayer和Winamp外，还有别的软件可以播放rm影碟吗？你觉得用哪个软件播放的效果最好？
答：据我所知，还有这些软件可以播放rm影碟：Media Jukebox、Cowon Jet-Audio、UltraPlayer以及实达铭泰的东方影都立体版。
Media Jukebox可播放各种多媒体格式的文件，功能强大，但它的播放列表功能使用困难，不推荐使用。
Cowon JetAudio 4.71版开始内置了RealPlayer G2播放引擎，这个软件有非常漂亮的界面和强大易用的专辑管理，并可对声音进行一些特殊处理，是一款极棒的软件，但它不能实现rm影碟的全屏播放，而且播放一些较新格式的rm影碟时还得调用RealPlayer 8的播放功能才行。

UltraPlayer可以播放流行的多媒体格式文件而且音质不错，它有一个独特的功能：设定在一段时间内播放音乐并逐渐减小或增大音量，可以用来播放催眠曲或提醒起床的音乐（外国人不关电脑吗？呵呵），它有简单易用的播放列表，可调节音量的左右均衡，但播放rm影碟画面只能在小窗口和全屏幕间切换，这个软件是**的。

我没用过东方影都立体版，从一些电脑杂志和网上的文章来看，播放rm影碟的效果还不错，而且可以很方便的抓图。

说到效果，我觉得还是用RealPlayer播放比较好，在解决了播放列表和左右声道调节问题并做一些设置后，感觉还是用它更方便，而且别的软件大多数是调用它来播放rm影碟的，还不如就直接用它了


实用的端口大全(中文版)

1　tcpmux　TCP Port Service Multiplexer　　传输控制协议端口服务多路开关选择器
2　compressnet　Management Utility　　　　 compressnet 管理实用程序
3　compressnet　Compression Process　　　　压缩进程
5　rje　Remote Job Entry　　　　　　　　　 远程作业登录
7　echo　Echo　　　　　　　　　　　　　　　回显
9　discard　Discard　　　　　　　　　　　　丢弃
11　systat　Active Users　　　　　　　　　 在线用户
13　daytime　Daytime　　　　　　　　　　　 时间
17　qotd　Quote of the Day　　　　　　　　 每日引用
18　msp　Message Send Protocol　　　　　　 消息发送协议
19　chargen　Character Generator　　　　　 字符发生器
20　ftp-data　File Transfer [Default Data]　文件传输协议(默认数据口)
21　ftp　File Transfer [Control]　　　　　　文件传输协议(控制)
22　ssh　SSH Remote Login Protocol　　　　 SSH远程登录协议
23　telnet　Telnet　　　　　　　　　　　　 终端仿真协议
24　?　any private mail system　　　　　　 预留给个人用邮件系统
25　smtp　Simple Mail Transfer　　　　　　 简单邮件发送协议
27　nsw-fe　NSW User System FE　　　　　　 NSW 用户系统现场工程师
29　msg-icp　MSG ICP　　　　　　　　　　　 MSG　ICP
31　msg-auth　MSG Authentication　　　　　 MSG验证
33　dsp　Display Support Protocol　　　　　显示支持协议
35　?　any private printer server　　　　　预留给个人打印机服务
37　time　Time　　　　　　　　　　　　　　 时间
38　rap　Route Access Protocol　　　　　　 路由访问协议
39　rlp　Resource Location Protocol　　　　资源定位协议
41　graphics　Graphics　　　　　　　　　　 图形
42　nameserver　WINS Host Name Server　　　WINS 主机名服务
43　nicname　Who Is　　　　　　　　　　　　"绰号" who is服务
44　mpm-flags　MPM FLAGS Protocol　　　　　MPM(消息处理模块)标志协议
45　mpm　Message Processing Module [recv]　消息处理模块
46　mpm-snd　MPM [default send]　　　　　　消息处理模块(默认发送口)
47　ni-ftp　NI FTP　　　　　　　　　　　　 NI FTP
48　auditd　Digital Audit Daemon　　　　　 数码音频后台服务
49　tacacs　Login Host Protocol (TACACS)　 TACACS登录主机协议
50　re-mail-ck　Remote Mail Checking Protocol　远程邮件检查协议
51　la-maint　IMP Logical Address Maintenance　IMP(接口信息处理机)逻辑地址维护
52　xns-time　XNS Time Protocol　　　　　　施乐网络服务系统时间协议
53　domain　Domain Name Server　　　　　　 域名服务器
54　xns-ch　XNS Clearinghouse　　　　　　　施乐网络服务系统票据交换
55　isi-gl　ISI Graphics Language　　　　　ISI图形语言
56　xns-auth　XNS Authentication　　　　　 施乐网络服务系统验证
57　?　any private terminal access　　　　 预留个人用终端访问
58　xns-mail　XNS Mail　　　　　　　　　　 施乐网络服务系统邮件
59　?　any private file service　　　　　　预留个人文件服务
60　?　Unassigned　　　　　　　　　　　　　未定义
61　ni-mail　NI MAIL　　　　　　　　　　　 NI邮件?
62　acas　ACA Services　　　　　　　　　　 异步通讯适配器服务
63　whois+ whois+　　　　　　　　　　　　　 WHOIS+
64　covia　Communications Integrator (CI)　通讯接口
65　tacacs-ds　TACACS-Database Service　　 TACACS数据库服务
66　sql*net　Oracle SQL*NET　　　　　　　　Oracle SQL*NET
67　bootps　Bootstrap Protocol Server　　　引导程序协议服务端
68　bootpc　Bootstrap Protocol Client　　　引导程序协议客户端
69　tftp　Trivial File Transfer　　　　　　小型文件传输协议
70　gopher　Gopher　　　　　　　　　　　　 信息检索协议
71　netrjs-1　Remote Job Service　　　　　 远程作业服务
72　netrjs-2　Remote Job Service　　　　　 远程作业服务
73　netrjs-3　Remote Job Service　　　　　 远程作业服务
74　netrjs-4　Remote Job Service　　　　　 远程作业服务
75　?　any private dial out service　　　　预留给个人拨出服务
76　deos　Distributed External Object Store 分布式外部对象存储
77　?　any private RJE service　　　　　　预留给个人远程作业输入服务
78　vettcp　vettcp　　　　　　　　　　　　 修正TCP?
79　finger　Finger　　　　　　　　　　　　 FINGER(查询远程主机在线用户等信息)
80　http　World Wide Web HTTP　　　　　　　全球信息网超文本传输协议
81　hosts2-ns　HOSTS2 Name Server　　　　　HOST2名称服务
82　xfer　XFER Utility　　　　　　　　　　 传输实用程序
83　mit-ml-dev　MIT ML Device　　　　　　　模块化智能终端ML设备
84　ctf　Common Trace Facility　　　　　　 公用追踪设备
85　mit-ml-dev　MIT ML Device　　　　　　　模块化智能终端ML设备
86　mfcobol　Micro Focus Cobol　　　　　　 Micro Focus Cobol编程语言
87　?　any private terminal link　　　　　 预留给个人终端连接
88　kerberos　Kerberos　　　　　　　　　　 Kerberros安全认证系统
89　su-mit-tg　SU/MIT Telnet Gateway　　　 SU/MIT终端仿真网关
90　dnsix　DNSIX Securit Attribute Token Map　DNSIX 安全属性标记图
91　mit-dov　MIT Dover Spooler　　　　　　 MIT Dover假脱机
92　npp　Network Printing Protocol　　　　 网络打印协议
93　dcp　Device Control Protocol　　　　　 设备控制协议
94　objcall　Tivoli Object Dispatcher　　　Tivoli对象调度
95　supdup　SUPDUP
96　dixie　DIXIE Protocol Specification　　DIXIE协议规范
97　swift-rvf　Swift Remote Virtural File Protocol　快速远程虚拟文件协议
98　tacnews　TAC News　　　　　　　　　　　TAC(东京大学自动计算机?)新闻协议
99　metagram　Metagram Relay
100　newacct　[unauthorized use]