DHTMLET ®

网页制作论坛
rainer@dhtmlet.com
rainer@mail.hf.ah.cn
︱ 样式表中文手册 ︱ 在线资源 ︱ 关于 ︱ 论坛 ︱ 信箱


DHTMLET® 属性清单 | 相关内容：
Introduction To CSS2样式表简介

说明：
本手册针对的是已有一定网页设计制作经验的读者。其目的是提供最新最全的样式表内容的快速索引及注释。所以对于样式表的基础知识，在此仅简单介绍，恕不赘述。
本手册的升级信息与版权声明请参阅关于本书页面。本手册中专用词汇请参阅中英文词汇对照表。
限于篇幅，对于一些过于繁杂的相关内容，如动态样式属性（Dynamic Properties），滤镜（Filters），行为（Behaviors）请参阅我的其它相关著作。
本书中涉及到的所有HTML对象（Object，Element），HTML特性（Attributes）和属性（Properties）请参阅我的相关著作。

什么是样式表
CSS是Cascading Style Sheet 的缩写。译作「层叠样式表单」。是用于（增强）控制网页样式并允许将样式信息与网页内容分离的一种标记性语言。
如何将样式表加入您的网页
你可以用以下三种方式将样式表加入您的网页。而最接近目标的样式定义优先权越高。高优先权样式将继承低优先权样式的未重叠定义但覆盖重叠的定义。例外请参阅!important声明。
链入外部样式表文件 (Linking to a Style Sheet)
你可以先建立外部样式表文件（.css），然后使用HTML的link对象。示例如下：
<head>
<title>title of article</title>
<link rel=stylesheet href="http://www.dhtmlet.com/rainer.css" type="text/css">
</head>
而在XML中，你应该如下例所示在声明区中加入：
<? xml-stylesheet type="text/css" href="http://www.dhtmlet.com/rainer.css" ?>>
定义内部样式块对象 (Embedding a Style Block)
你可以在你的HTML文档的<HTML>和<BODY>标记之间插入一个<STYLE>...</STYLE>块对象。 定义方式请参阅样式表语法。示例如下：
<html>
<style type="text/css">
<!--
body {font: 10pt "Arial"}
h1 {font: 15pt/17pt "Arial"; font-weight: bold; color: maroon}
h2 {font: 13pt/15pt "Arial"; font-weight: bold; color: blue}
p {font: 10pt/12pt "Arial"; color: black}
-->
</style>
<body>
请注意，这里将style对象的type属性设置为"text/css"，是允许不支持这类型的浏览器忽略样式表单。
内联定义 (Inline Styles)
内联定义即是在对象的标记内使用对象的style属性定义适用其的样式表属性。示例如下：
<p style="margin-left: 0.5in; margin-right:0.5in">这一行被增加了左右的外补丁<p>
样式表语法 (CSS Syntax)
Selector { property: value }
参数说明：
Selector -- 选择符
property : value -- 样式表定义。属性和属性值之间用冒号(:)隔开。定义之间用分号(;)隔开
继承的值 (The ' Inherit ' Value)
每个属性都有一个指定的值：Inherit。它的意思是：将父对象的值等同为计算机值得到。这个值通常仅仅是备用的。显式的声明它可用来强调。
苏沈小雨制作·保留所有权利
©2001 rain1977.comer . All rights reserved . Terms of Use .


DHTMLET ®

网页制作论坛
rainer@dhtmlet.com
rainer@mail.hf.ah.cn
︱ 样式表中文手册 ︱ 在线资源 ︱ 关于 ︱ 论坛 ︱ 信箱

About this handbook

版权声明(COPYRIGHT)
本手册由苏沈小雨整理，翻译，编写。版权所有者为苏沈小雨。
您可以免费的使用、分发本手册。但未经苏沈小雨的授权许可不得擅自进行篡改、反编译，及将其全部或部分用于商业用途。
本手册受著作权法和国际公约的保护，作者保留对本手册及本声明的最终修改权。
本手册的部分内容参考了Mainsoft(R)及World Wide Web Consortium (W3C)公开的网络文档。
本手册使用Mainsoft(R)的HTML Help格式制作。
rain1977.comer是苏沈小雨使用的个人标识。dhtmlet是苏沈小雨的个人网站使用的标识。

版本更新(UPDATE)
本手册当前版本时间为2001年4月29日。手册中的内容在此日期后发生的变动或更新将在本手册的更新版本中出现。
您可以随时访问我的网站www.dhtmlet.com检查并获取更新版本。
您也可以给我写电子邮件咨询及洽谈商业合作。关于我的介绍您可以在关于苏沈小雨页面获得。


DHTMLET ®

网页制作论坛
rainer@dhtmlet.com
rainer@mail.hf.ah.cn
︱ 样式表中文手册 ︱ 在线资源 ︱ 关于 ︱ 论坛 ︱ 信箱

About rain1977

简历(Vita)
1996 - 1999 中国航空油料安徽分公司(CAOSC) - 油品化验员
1999 - 2000 北京清华园中文在线网络技术有限公司(www.chineseall.com) - 频道经理
2000 -- 上海榕树下计算机有限公司(www.rongshu.com) - 网页设计兼前台工程师
自述(Intro)
精通脚本(JScripts)、样式表(CSS)、DHTML(包括HTML4.0，HTC，HTA，Scriptlet，CHM等)等技术。
对于网页制作，有专业的编写优化代码，网页设计、图片处理、网站策划的能力。
对于上述工作，有丰富的实际操作经验。熟悉团队项目流程。
能够熟练使用或很快上手任何常见的和网页制作有关的代码编辑、图片处理等工具软件。
出生于文人世家，有较高的中文水平。
希望寻求网页设计制作，商业项目合作，教材编写等工作机会。有意者请与我联系。
主要作品
她比烟花寂寞(1998)
著名网络女作家安妮宝贝的第一个网上主页。也是最知名的。是我的第一个网页作品。
印象无限(2000)
榕树下精品电子刊物。设计、技术、内容皆走前卫路线。使用Microsoft(R) HTML Help格式发行。有三个月便达到六万订户的骄人成绩。由我最初策划制作。
榕树下个人文集(2001)
自助个人主页项目。是前后台协作的完美实例。由宁财神设计，我负责所有网页制作和前台技术。
联络方式
主页： www.dhtmlet.com、www.rain1977.com
信箱： rainer@dhtmlet.com、rainer@mail.hf.ah.cn
电话： 13916616163（上海）
邮寄地址：上海市北京西路1399号建京大厦12楼E3 榕树下 苏昱(小雨)收
邮政编码：200040


CSS Properties Reference 样式表属性

字体 Font
font color font-family font-size font-size-adjust font-stretch font-style font-weight text-decoration text-underline-position text-shadow font-variant text-transform line-height letter-spacing word-spacing
文本 Text
text-indent text-overflow vertical-align text-align layout-flow writing-mode direction unicode-bidi word-break line-break white-space word-wrap text-autospace text-kashida-space text-justify ruby-align ruby-position ruby-overhang ime-mode layout-grid layout-grid-char layout-grid-char-spacing layout-grid-line layout-grid-mode layout-grid-type
背景 Background
background background-attachment background-color background-image background-position background-positionX background-positionY background-repeat layer-background-color layer-background-image
定位 Positioning
position z-index top right bottom left
尺寸 Dimensions
height max-height min-height width max-width min-width
布局 Layout
clear float clip overflow overflow-x overflow-y display visibility
外补丁 Margins
margin margin-top margin-right margin-bottom margin-left
轮廓 Outlines
outline outline-color outline-style outline-width
边框 Borders
border border-color border-style border-width border-top border-top-color border-top-style border-top-width border-right border-right-color border-right-style border-right-width border-bottom border-bottom-color border-bottom-style border-bottom-width border-left border-left-color border-left-style border-left-width
内容 Generated Content
include-source quotes content counter-increment counter-reset
内补丁 Paddings
padding padding-top padding-right padding-bottom padding-left
列表项目 Lists
list-style list-style-image list-style-position list-style-type marker-offset
表格 Table
border-collapse border-spacing caption-side empty-cells table-layout speak-header
滚动条 Scrollbars
scrollbar-3d-light-color scrollbar-highlight-color scrollbar-face-color scrollbar-arrow-color scrollbar-shadow-color scrollbar-dark-shadow-color scrollbar-base-color
打印 Printing
page page-break-after page-break-before page-break-inside marks orphans size widows
声音 Aural
voice-family volume elevation azimuth stress richness speech-rate cue cue-after cue-before pause pause-after pause-before pitch pitch-range play-during speak speak-numeral speak-punctuation
其它属性 Classification
behavior zoom cursor filter

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


CSS Font Properties 字体属性

Font Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
font | CSS1/CSS2 | IE4+ , NS4+ | 有 | 复合属性。设置或检索对象中的文本特性
color | CSS1 | IE4+ , NS4+ | 有 | 检索或设置对象的文本颜色
font-family | CSS1 | IE4+ , NS4+ | 有 | 设置或检索用于对象中文本的字体名称序列
font-size | CSS1 | IE4+ , NS4+ | 有 | 设置或检索对象中的字体尺寸
font-size-adjust | CSS2 | NONE | 有 | 设置或检索用于对象中文本的字体名称序列是否强制使用同一尺寸
font-stretch | CSS2 | NONE | 有 | 设置或检索用于对象中文本的文字是否横向的拉伸变形
font-style | CSS1 | IE4+ , NS4+ | 有 | 设置或检索对象中的字体样式
font-weight | CSS1 | IE4+ , NS4+ | 有 | 设置或检索对象中的文本字体的粗细
text-decoration | CSS1 | IE4+ , NS4+ | 无 | 检索或设置对象中的文本的装饰，如下划线 、闪烁等
text-underline-position | IE专有属性 | IE5.5+ | 有 | 设置或检索text-decoration属性定义的下划线的位置
text-shadow | CSS2 | NONE | 无 | 设置或检索对象中文本的文字是否有阴影及模糊效果
font-variant | CSS1 | IE4+ , NS6+ | 有 | 设置或检索对象中的文本是否为小型的大写字母
text-transform | CSS1 | IE4+ , NS4+ | 有 | 检索或设置对象中的文本的大小写
line-height | CSS1 | IE4+ , NS4+ | 有 | 检索或设置对象的行高。即字体最底端与字体内部顶端之间的距离
letter-spacing | CSS1 | IE4+ , NS6+ | 有 | 检索或设置对象中的文字之间的间隔
word-spacing | CSS1 | IE4+ , NS6+ | 有 | 检索或设置对象中的单词之间插入的空格数。对于IE4+而言仅在MAC平台上可用

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


font版本：CSS1/CSS2　 兼容性：IE4+ NS4+　继承性：有

语法：

font : font-style || font-variant || font-weight || font-size || line-height || font-family
font : caption | icon | menu | message-box | small-caption | status-bar

参数：

该属性是复合属性。第一种声明方式请参阅各参数对应的属性。
第二种声明方式中的参数属于CSS2。
caption : 使用有标题的系统控件的文本字体（如按钮，菜单等）
icon : 使用图标标签的字体
menu : 使用菜单的字体
message-box : 使用信息对话框的文本字体
small-caption : 使用小控件的字体
status-bar : 使用窗口状态栏的字体

说明：

设置或检索对象中的文本特性。该属性是复合属性。
第一种声明方式参数必须按照如上的排列顺序。每个参数仅允许有一个值。忽略的将使用其参数对应的独立属性的默认值。
对于如何使用用户端系统可能没有的字体，可以参阅@font-face规则。
对应的脚本特性为font。请参阅我编写的其他书目。

示例：

p { font: italic small-caps 600 12pts/18pts 宋体; }
p { font: italic small-caps 600 12pts/150% Courier; }
p { font: italic small-caps 600 12pts/1.5 Courier; }
p { font: italic small-caps 600 12pts/18pts Courier; }
p { font: /18pts serif; }
p { font: oblique 100 24pts; }
H1 { font: 15pt/17pt bold "Arial" normal }


color版本：CSS1　 兼容性：IE4+ NS4+　继承性：有

语法：

color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

检索或设置对象的文本颜色。无默认值。
注意，用颜色名称指定color不被一些浏览器接受。
对应的脚本特性为color。请参阅我编写的其他书目。

示例：

div {color: #345456; }
div { color: rgb(100,14,200); }
div {color: menu; }
div {color: red; }


font-family版本：CSS1　 兼容性：IE4+ NS4+　继承性：有

语法：

font-family : name
font-family : cursive | fantasy | monospace | serif | sans-serif

参数：

name : 字体名称。按优先顺序排列。以逗号隔开。如果字体名称包含空格，则应使用引号括起
第二种声明方式使用所列出的字体序列名称。如果使用fantasy序列，将提供默认字体序列

说明：

设置或检索用于对象中文本的字体名称序列。
默认值由浏览器确定。
序列可包含嵌入字体字体。请参阅@font-face规则。
对应的脚本特性为fontFamily。请参阅我编写的其他书目。

示例：

div.fixedwidth { font-family: Courier, "Courier New", monospace }


font-size版本：CSS1　 兼容性：IE4+ NS4+　继承性：有

语法：

font-size : absolute-size | relative-size | length

参数：

absolute-size : 根据对象字体进行调节。xx-small | x-small | small | medium | large | x-large | xx-large
relative-size : 相对于父对像中字体尺寸进行相对调节。使用成比例的em单位计算。larger | smaller
length : 百分数 | 由浮点数字和单位标识符组成的长度值，不可为负值。其百分比取值是基于父对象中字体的尺寸。请参阅长度单位

说明：

设置或检索对象中的字体尺寸。
默认值为absolute-size的medium值。
对应的脚本特性为fontSize。请参阅我编写的其他书目。

示例：

p { font-style: normal; }
p { font-size: 12px; }
p { font-size: 20%; }


font-size-adjust版本：CSS2　 兼容性：NONE　继承性：有

语法：

font-size-adjust : none | number

参数：

none : 允许字体序列中每一字体遵守它的自己的尺寸
number : 为字体序列中所有字体强迫指定同一尺寸

说明：

设置或检索用于对象中文本的字体名称序列是否强制使用同一尺寸。
目前IE5.5尚不支持此属性。
对应的脚本特性为fontSizeAdjust。请参阅我编写的其他书目。

示例：

p { font-family: arial, courier; font-size-adjust: none; }
p { font-family: verdana, courier; font-size-adjust: .56; }


font-stretch版本：CSS2　 兼容性：NONE　继承性：有

语法：

font-stretch : normal | narrower | wider | ultra-condensed | extra-condensed | condensed | semi-condensed | semi-expanded | expanded | extra-expanded | ultra-expanded

参数：

normal : 不应用拉伸变形
narrower : 使用比当前设置的值导致字体宽度更小的值
wider : 使用比当前设置的值导致字体宽度更大的值

说明：

设置或检索用于对象中文本的文字是否横向的拉伸变形。
改变是相对于浏览器显示的字体的正常宽度的。
目前IE5.5尚不支持此属性。
对应的脚本特性为fontStretch。请参阅我编写的其他书目。

示例：

p { font-stretch: wider; }
p { font-stretch: ultra-expanded; }


font-style版本：CSS1　 兼容性：IE4+ NS4+　继承性：有

语法：

font-style : normal | italic | oblique

参数：

normal : 正常的字体
italic : 斜体。对于没有斜体变量的特殊字体，将应用oblique
oblique : 倾斜的字体

说明：

设置或检索对象中的字体样式。
对应的脚本特性为fontStyle。请参阅我编写的其他书目。

示例：

p { font-style: normal; }
p { font-style: italic; }
p { font-style: oblique; }

请您用下面的按钮选择这段文字的font-style属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


font-weight版本：CSS1　 兼容性：IE4+ NS4+　继承性：有

语法：

font-weight : normal | bold | bolder | lighter | number

参数：

normal : 正常的字体。相当于number为400。声明此值将取消之前任何设置
bold : 粗体。相当于number为700。也相当于b对象的作用
bolder : IE5+　特粗体
lighter : IE5+　细体
number : IE5+　100 | 200 | 300 | 400 | 500 | 600 | 700 | 800 | 900

说明：

设置或检索对象中的文本字体的粗细。
作用由用户端系统安装的字体的特定字体变量映射决定。系统选择最近的匹配。也就是说，用户可能看不到不同值之间的差异。
对应的脚本特性为fontWeight。请参阅我编写的其他书目。

示例：

span { font-weight:800; }

请您用下面的按钮选择这段文字的font-weight属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


text-decoration版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

text-decoration : none || underline || blink || overline || line-through

参数：

none : 　无装饰
blink : 　闪烁
underline : 　下划线
line-through : 　贯穿线
overline : 　上划线

说明：

检索或设置对象中的文本的装饰。
有href特性的a，以及u，ins对象默认值为underline 。
对象strike，s，del，默认值是line-through。
没有文本的对象此属性不会作用。
对应的脚本特性为textDecoration。请参阅我编写的其他书目。

示例：

div { text-decoration : underline; }
div { text-decoration : underline overline; }

请您用下面的按钮选择这段文字的text-decoration属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


text-underline-position版本：IE5.5+专有属性　继承性：有

语法：

text-underline-position : below | above

参数：

below : 　在文本下面
above : 　在文本上面

说明：

设置或检索text-decoration属性定义的下划线的位置。
对应的脚本特性为textUnderlinePosition。请参阅我编写的其他书目。

示例：

p { text-underline-position: above; text-decoration: underline; }

请您用下面的按钮选择这段文字的text-underline-position属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


text-shadow版本：CSS2　 兼容性：NONE　继承性：无

语法：

text-shadow : color || length || lenth|| opacity

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表
length : 　由浮点数字和单位标识符组成的长度值。可为负值。第一个length指定阴影的水平延伸距离。第二个length指定阴影的垂直延伸距离。请参阅长度单位
opacity : 　由浮点数字和单位标识符组成的长度值。不可为负值。指定模糊效果的作用距离。如果你仅仅需要模糊效果，将前两个length全部设定为0。请参阅长度单位

说明：

设置或检索对象中文本的文字是否有阴影及模糊效果。
可以设定多组效果，方式是用逗号隔开。
可以被用于伪类:first-letter和 :first-line。
目前IE5.5尚不支持此属性。
对应的脚本特性为textShadow。请参阅我编写的其他书目。

示例：

p { text-shadow: 0px 0px 20px yellow, 0px 0px 10px orange, red 5px -5px; }
p:first-letter { font-size: 36px; color: red; text-shadow: red 0px 0px 5px;}


font-variant版本：CSS1　 兼容性：IE4+ NS6+　继承性：有

语法：

font-variant : normal | small-caps

参数：

normal : 正常的字体
small-caps : 小型的大写字母字体

说明：

设置或检索对象中的文本是否为小型的大写字母。
对应的脚本特性为fontVariant。请参阅我编写的其他书目。

示例：

span { font-variant: small-caps; }

请您用下面的按钮选择这段文字的font-variant属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


text-transform版本：CSS1　 兼容性：IE4+ NS4+　继承性：有

语法：

text-transform : none | capitalize | uppercase | lowercase

参数：

none : 　无转换发生
capitalize : 　将每个单词的第一个字母转换成大写，其余无转换发生
uppercase : 　转换成大写
lowercase : 　转换成小写

说明：

检索或设置对象中的文本的大小写。
对应的脚本特性为textTransform。请参阅我编写的其他书目。

示例：

div { text-transform : uppercase; }

请您用下面的按钮选择这段文字的text-transform属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


line-height版本：CSS1　 兼容性：IE4+ NS4+　继承性：有

语法：

line-height : normal | length

参数：

normal : 　默认行高
length : 　百分比数字 | 由浮点数字和单位标识符组成的长度值，允许为负值。其百分比取值是基于字体的高度尺寸。请参阅长度单位

说明：

检索或设置对象的行高。即字体最底端与字体内部顶端之间的距离。
如行内包含多个对象，则应用最大行高。此时行高不可为负值。
对应的脚本特性为lineHeight。请参阅我编写的其他书目。

示例：

div {line-height:6px; }
div {line-height:10.5; }

请您用下面的按钮加减这段文字的line-height属性的值（单位是px）。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


letter-spacing版本：CSS1　 兼容性：IE4+ NS6+　继承性：有

语法：

letter-spacing : normal | length

参数：

normal : 　默认间隔
length : 　由浮点数字和单位标识符组成的长度值，允许为负值。请参阅长度单位

说明：

检索或设置对象中的文字之间的间隔。
该属性将指定的间隔添加到每个文字之后，但最后一个字将被排除在外。
对应的脚本特性为letterSpacing。请参阅我编写的其他书目。

示例：

div {letter-spacing:6px; }
div {letter-spacing:0.5pt; }

请您用下面的按钮加减这段文字的letter-spacing属性的值（单位是px）。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


word-spacing版本：CSS1　 兼容性：IE4+ NS6+　继承性：有

语法：

word-spacing : normal | length

参数：

normal : 　默认间距
length : 　由浮点数字和单位标识符组成的长度值，允许为负值。请参阅长度单位

说明：

检索或设置对象中的单词之间插入的空格数。对于IE4+而言仅在MAC平台上可用。
对应的脚本特性为wordSpacing。请参阅我编写的其他书目。

示例：

div { word-spacing : 10; }
div { word-spacing : 10px; }


CSS Text Properties 文本属性

Text Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
text-indent | CSS1 | IE4+ , NS4+ | 有 | 检索或设置对象中的文本的缩进
text-overflow | IE专有属性 | IE6+ | 无 | 设置或检索是否使用一个省略标记（...）标示对象内文本的溢出
vertical-align | CSS1/CSS2 | IE4+ , NS4+ | 无 | 设置或检索对象内容的垂直对其方式
text-align | CSS1 | IE4+ , NS4+ | 有 | 设置或检索对象中文本的对齐方式
layout-flow | IE专有属性 | IE5.5+ | 有 | 设置或检索对象内文本的流动和方向
writing-mode | IE专有属性 | IE5.5+ | 有 | 设置或检索对象的内容块固有的书写方向
direction | CSS2 | IE5+ | 无 | 用于设置文本流的方向
unicode-bidi | CSS2 | IE5+ | 无 | 用于同一个页面里存在从不同方向读进的文本显示。与direction属性一起使用
word-break | IE专有属性 | IE5+ | 无 | 设置或检索对象内文本的字内换行行为。尤其在出现多种语言时
line-break | IE专有属性 | IE5+ | 无 | 设置或检索用于日文文本的换行规则
white-space | CSS1 | IE5.5+ , NS4+ | 有 | 设置或检索对象内空格的处理方式
word-wrap | IE专有属性 | IE5.5+ | 有 | 设置或检索当当前行超过指定容器的边界时是否断开转行
text-autospace | IE专有属性 | IE5+ | 无 | 设置或检索对象文本的自动空格和紧缩空格宽度调整的方式
text-kashida-space | IE专有属性 | IE5.5+ | 有 | 设置或检索如何拉伸字符来调节文本行排列
text-justify | IE专有属性 | IE5+ | 无 | 设置或检索对象内文本的对齐方式
ruby-align | IE专有属性 | IE5+ | 无 | 设置或检索通过rt对象指定的注释文本或发音指南（参考ruby对象）的对齐位置
ruby-position | IE专有属性 | IE5+ | 无 | 设置或检索通过rt对象指定的注释文本或发音指南（参考ruby对象）的位置
ruby-overhang | IE专有属性 | IE5+ | 无 | 设置或检索通过rt对象指定的注释文本或发音指南（参考ruby对象）的位置
ime-mode | IE专有属性 | IE5+ | 无 | 设置或检索是否允许用户激活输入中文，韩文，日文等的输入法（IME）状态
layout-grid | IE专有属性 | IE5+ | 有 | 复合属性。设置或检索复合文档中指定文本字符版式的网格特性
layout-grid-char | IE专有属性 | IE5+ | 有 | 设置或检索应用于对象文本的字符网格值
layout-grid-char-spacing | IE专有属性 | IE5+ | 有 | 设置或检索字符间隔
layout-grid-line | IE专有属性 | IE5+ | 有 | 设置或检索应用于对象文本的行网格值
layout-grid-mode | IE专有属性 | IE5+ | 有 | 设置或检索文本网格版式是否使用二维
layout-grid-type | IE专有属性 | IE5+ | 有 | 设置或检索应用于对象文本的网格类型

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


text-indent版本：CSS1　 兼容性：IE4+ NS4+　继承性：有

语法：

text-indent : length

参数：

length : 　百分比数字|由浮点数字和单位标识符组成的长度值，允许为负值。请参阅长度单位

说明：

检索或设置对象中的文本的缩进。
在被另一个对象（如）断开的对象内不能应用本属性。
对应的脚本特性为textIndent。请参阅我编写的其他书目。

示例：

div { text-indent : -5px; }
div { text-indent : underline 10%; }

请您用下面的按钮加减这段文字的text-indent属性的值（单位是px）。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


text-overflow版本：IE6+专有属性　继承性：无

语法：

text-overflow : clip | ellipsis

参数：

clip : 　不显示省略标记（...），而是简单的裁切
ellipsis : 　当对象内文本溢出时显示省略标记（...）

说明：

设置或检索是否使用一个省略标记（...）标示对象内文本的溢出。
对应的脚本特性为textOverflow。请参阅我编写的其他书目。

示例：

div { text-overflow : clip; }


vertical-align版本：CSS1/CSS2　 兼容性：IE4+ NS4+　继承性：无

语法：

vertical-align : baseline |sub | super |top |text-top |middle |bottom |text-bottom |length

参数：

baseline : 　将支持valign特性的对象的内容与基线对齐
sub : 　垂直对齐文本的下标
super : 　垂直对齐文本的上标
top : 　将支持valign特性的对象的内容与对象顶端对齐
text-top : 　将支持valign特性的对象的文本与对象顶端对齐
middle : 　将支持valign特性的对象的内容与对象中部对齐
bottom : 　将支持valign特性的对象的文本与对象底端对齐
text-bottom : 　将支持valign特性的对象的文本与对象顶端对齐
length : 　CSS2　由浮点数字和单位标识符组成的长度值 | 或者百分数。可为负数。定义由基线算起的偏移量。基线对于数值来说为0，对于百分数来说就是0%。目前IE5尚不支持。请参阅长度单位

说明：

设置或检索对象内容的垂直对其方式。
对应的脚本特性为verticalAlign。请参阅我编写的其他书目。

示例：

td { vertical-align : center; }


text-align版本：CSS1　 兼容性：IE4+ NS4+　继承性：有

语法：

text-align : left | right | center | justify

参数：

left : 　左对齐
right : 　右对齐
center : 　居中
justify : 　两端对齐

说明：

设置或检索对象中文本的对齐方式。
对应的脚本特性为textAlign。请参阅我编写的其他书目。

示例：

div { text-align : center; }

请您用下面的按钮选择这段文字的text-align属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


layout-flow版本：IE5.5+专有属性　继承性：有

语法：

layout-flow : horizontal | vertical-ideographic

参数：

horizontal : 　对象中的内容自左边流入。下一行在前一行下面。这个值适于拉丁语系
vertical-ideographic : 　对象中的内容自上而下流入，下一行在前一行左面。这个值适于亚洲语系

说明：

设置或检索对象内文本的流动和方向。
当此属性值发生变化时，text-align属性与vertical-align属性的作用也将发生变化。
对应的脚本特性为layoutFlow。请参阅我编写的其他书目。

示例：

div { layout-flow : horizontal; }

请您用下面的按钮选择这段文字的layout-flow属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


writing-mode版本：IE5.5+专有属性　继承性：有

语法：

writing-mode : lr-tb | tb-rl

参数：

lr-tb : 左-右，上-下
tb-rl : 上-下，右-左

说明：

设置或检索对象的内容块固有的书写方向。西方语言确省的是左-右，上-下的书写方式。但是亚洲语言常有上-下，右-左的书写方式。
当此属性值发生变化时，text-align属性与vertical-align属性的作用也将发生变化。
对应的脚本特性为writingMode。请参阅我编写的其他书目。

示例：

div { writing-mode: tb-rl; }

请您用下面的按钮选择这段文字的writing-mode属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


direction版本：CSS2　 兼容性：IE5+　继承性：无

语法：

direction : ltr | rtl | inherit

参数：

ltr : 　文本流从左到右
rtl : 　文本流从右到左
inherit : 　文本流的值不可继承

说明：

用于设置文本流的方向。
假如您想应用direction属性于内联文本，您必须设定unicode-bidi属性为embed或bidi-override。
对应的脚本特性为direction。请参阅我编写的其他书目。

示例：

div { direction: rtl; unicode-bidi: bidi-override; }

请您用下面的按钮选择这段文字的direction和unicode-bidi属性的值。看一看会发生什么，然后您就会明白他们的意义。Enjoy my works . many thanks .


unicode-bidi版本：CSS2　 兼容性：IE5+　继承性：无

语法：

unicode-bidi : normal | bidi-override | embed

参数：

normal : 　对象不打开附加的嵌入层，对于内联要素，隐式重排序跨对象边界进行工作
embed : 　对象打开附加的嵌入层，direction属性的值指定嵌入层，在对象内部进行隐式重排序
bidi-override : 　严格按照direction属性的值重排序。忽略隐式双向运算规则

说明：

用于同一个页面里存在从不同方向读进的文本显示。与direction属性一起使用。
假如您想应用direction属性于内联文本，您必须设定unicode-bidi属性为embed或bidi-override。
对应的脚本特性为unicodeBidi。请参阅我编写的其他书目。

示例：

div { direction: rtl; unicode-bidi: bidi-override; }

请您用下面的按钮选择这段文字的direction和unicode-bidi属性的值。看一看会发生什么，然后您就会明白他们的意义。Enjoy my works . many thanks .


word-break版本：IE5+专有属性　继承性：无

语法：

word-break : normal | break-all | keep-all

参数：

normal : 　依照亚洲语言和非亚洲语言的文本规则，允许在字内换行
break-all : 　该行为与亚洲语言的normal相同。也允许非亚洲语言文本行的任意字内断开。该值适合包含一些非亚洲文本的亚洲文本
keep-all : 　与所有非亚洲语言的normal相同。对于中文，韩文，日文，不允许字断开。适合包含少量亚洲文本的非亚洲文本

说明：

设置或检索对象内文本的字内换行行为。尤其在出现多种语言时。
对于中文，应该使用break-all 。
对应的脚本特性为wordBreak。请参阅我编写的其他书目。

示例：

div {word-break : break-all; }

请您用下面的按钮选择这段文字的word-break属性的值。看一看会发生什么，然后您就会明白这个属性的意义。Enjoy my works . many thanks .


line-break版本：IE5+专有属性　继承性：无

语法：

line-break : normal | strict

参数：

normal : 　应用日文文本的默认换行规则
strict : 　强制日文文本换行规则的严谨性

说明：

设置或检索用于日文文本的换行规则。
对应的脚本特性为lineBreak。请参阅我编写的其他书目。

示例：

div { line-break : strict; }


white-space版本：CSS1　 兼容性：IE5.5+ NS4+　继承性：有

语法：

white-space : normal | pre | nowrap

参数：

normal : 　默认处理方式
pre : 　用等宽字体显示预先格式化的文本。不合并字间的空白距离和进行两端对齐。参阅pre对象
nowrap : 　强制在同一行内显示所有文本，直到文本结束或者遭遇br对象。参阅td，div等对象的nowrap属性（特性）

说明：

设置或检索对象内空格的处理方式。
对应的脚本特性为whiteSpace。请参阅我编写的其他书目。

示例：

p { white-space: nowrap; }

请您从下方的选择框内选择white-space属性的不同的值，看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


word-wrap版本：IE5.5+专有属性　继承性：有

语法：

word-wrap : normal | break-word

参数：

normal : 　允许内容顶开指定的容器边界
break-word : 　内容将在边界内换行。如果需要，词内换行（word-break）也行发生

说明：

设置或检索当当前行超过指定容器的边界时是否断开转行。
对应的脚本特性为wordWrap。请参阅我编写的其他书目。

示例：

div { word-wrap: break-word; }


text-autospace版本：IE5+专有属性　继承性：无

语法：

text-autospace : none | ideograph-alpha | ideograph-numeric | ideograph-parenthesis | ideograph-space

参数：

none : 无调整发生
ideograph-alpha : 表意字和非表意字（如Latin-based，Greek，Cyrillic，Arabic，Hebrew文本）之间创建额外空格
ideograph-numeric : 在表意字和数字字符之间创建额外空格
ideograph-parenthesis : 在常规（非宽度）插入语和表意字之间创建额外空格
ideograph-space : 当空格相邻表意字符时，扩展空格的宽度

说明：

设置或检索对象文本的自动空格和紧缩空格宽度调整的方式。
表意字是东亚编写系统中的字符，表示一个概念或方法，但不是一个特定的字或词。
对应的脚本特性为textAutospace。请参阅我编写的其他书目。


text-kashida-space版本：IE5.5+专有属性　继承性：有

语法：

text-kashida-space : length

参数：

length : 　百分数。标示kashida膨胀与空格膨胀的比例。为100%，仅有kashida膨胀。为0%，仅有空格膨胀。缺省值为0%

说明：

设置或检索如何拉伸字符来调节文本行排列。它可以和text-justify属性一起使用。
对应的脚本特性为textKashidaSpace。请参阅我编写的其他书目。

示例：

div { text-kashida-space : 50%; }


text-justify版本：IE5+专有属性　继承性：无

语法：

text-justify : auto |inter-word | newspaper | distribute | distribute-all-lines | inter-ideograph

参数：

auto : 　允许浏览器用户代理确定使用的两端对齐法则
inter-word : 　通过增加字之间的空格对齐文本。该行为是对齐所有文本行最快的方法。它的两端对齐行为对段落的最后一行无效
newspaper : 　通过增加或减少字或字母之间的空格对齐文本。是用于拉丁文字母表两端对齐的最精确格式
distribute : 　处理空格很像newspaper，适用于东亚文档。尤其是泰国
distribute-all-lines : 　两端对齐行的方式与distribute相同，也同样不包含两段对齐段落的最后一行。适用于表意字文档
inter-ideograph : 　为表意字文本提供完全两端对齐。他增加或减少表意字和词间的空格

说明：

设置或检索对象内文本的对齐方式。
对应的脚本特性为textJustify。请参阅我编写的其他书目。

示例：

div {text-justify : auto; }

请您用下面的按钮选择这段文字的text-justify属性的值。看一看会发生什么，然后您就会明白这个属性的意义。然后您就会明白这个属性的意义。希望您喜欢这本电子书。


ruby-align版本：IE5+专有属性　继承性：无

语法：

ruby-align : auto | left | center | right | distribute-letter | distribute-space | line-edge

参数：

auto : 　由浏览器确定对齐方式。对于ideographic（东亚文本）以distribute-space值对齐。对于Latin文本以center值对齐
left : 　根据基本宽度左对齐
center : 　根据基本宽度居中对齐。如果基本宽度小于ruby文本的宽度，那么在ruby文本的宽度中居中基本宽度
right : 　根据基本宽度右对齐
distribute-letter : 　如果ruby文本的宽度小于基本宽度，则ruby文本在基本宽度中均匀分布。如果ruby文本的宽度大于或等于基本宽度，，居中对齐
distribute-space : 　如果ruby文本的宽度小于基本宽度，则ruby文本在基本宽度中均匀分布。在ruby文本中，在第一个字符的前面后最后字符的后面有半个字距的空白区域。如果ruby文本的宽度大于或等于基本宽度，居中对齐
line-edge : 　如果ruby文本不相邻行边缘，则其被居中。否则ruby文本行在基本文本边的上方

说明：

设置或检索通过rt对象指定的注释文本或发音指南（参考ruby对象）的对齐位置。
ruby对象及rt对象请参阅我的其他著作。
对应的脚本特性为rubyAlign。请参阅我编写的其他书目。

示例：

ruby { ruby-align: right; }

请您用下面的按钮选择这段文字的ruby-align属性的值。看一看上面的ruby文本会发生什么，然后您就会明白这个属性意义。Enjoy my works . many thanks .


ruby-overhang版本：IE5+专有属性　继承性：无

语法：

ruby-overhang : auto | whitespace | none

参数：

auto : 　ruby文本突出相邻基本文本的任何其他文本
whitespace : 　ruby文本只突出空白区域的字符
none : 　ruby文本只突出相邻基本文本的任何其他文本

说明：

设置或检索通过rt对象指定的注释文本或发音指南（参考ruby对象）的位置。
ruby对象及rt对象请参阅我的其他著作。
对应的脚本特性为rubyOverhang。请参阅我编写的其他书目。

示例：

ruby { ruby-overhang: auto; }

请您用下面的按钮选择这段文字的ruby-overhang属性的值。看一看上面的ruby文本会发生什么，然后您就会明白这个属性意义。Enjoy my works . many thanks .


ruby-position版本：IE5+专有属性　继承性：无

语法：

ruby-position : above | inline

参数：

above : 　在基本文本上方定位ruby文本
inline : 　ruby文本与基本文本内联

说明：

设置或检索通过rt对象指定的注释文本或发音指南（参考ruby对象）的位置。
ruby对象及rt对象请参阅我的其他著作。
对应的脚本特性为rubyPosition。请参阅我编写的其他书目。

示例：

ruby { ruby-position: above; }

请您用下面的按钮选择这段文字的ruby-position属性的值。看一看上面的ruby文本会发生什么，然后您就会明白这个属性意义。Enjoy my works . many thanks .


ime-mode版本：IE5+专有属性　继承性：无

语法：

ime-mode : auto | active | inactive | disabled

参数：

auto : 不影响IME的状态。与不指定ime-mode属性时相同
active : 指定所有使用IME输入的字符。即激活本地语言输入法。用户仍可以撤销激活IME
inactive : 指定所有不使用IME输入的字符。即激活非本地语言。用户仍可以撤销激活IME
disabled : 完全禁用IME。对于有焦点的控件（如输入框），用户不可以激活IME

说明：

设置或检索是否允许用户激活输入中文，韩文，日文等的输入法（IME）状态。
对应的脚本特性为imeMode。请参阅我编写的其他书目。

示例：

<input type=text style="ime-mode: auto; ">


layout-grid版本：IE5+专有属性　继承性：有

语法：

layout-grid : layout-grid-mode || layout-grid-type || layout-grid-line || layout-grid-char || layout-grid-char-spacing

参数：

该属性是复合属性。请参阅各参数对应的属性。

说明：

设置或检索复合文档中指定文本字符版式的网格特性。
以东亚语言（如中文，日文）编写的文档通常根据一维或二维网格使用字符的页面版式。
对应的脚本特性为layoutGrid。请参阅我编写的其他书目。

示例：

div { layout-grid:char line 12px 12px 5px; }


layout-grid-char版本：IE5+专有属性　继承性：有

语法：

layout-grid-char : none | auto | length

参数：

none : 　不指定行网格值
auto : 　在对象文本中按最大字符确定网格
length : 　百分数 | 由浮点数字和单位标识符组成的长度值，其百分比取值是基于父对象尺寸。请参阅长度单位

说明：

设置或检索应用于对象文本的字符网格值。
要实现此属性，layout-grid-mode必须设置为char或both。
其视觉效果类似于line-height属性。只应用于块对象（如div）。
以东亚语言（如中文，日文）编写的文档通常根据一维或二维网格使用字符的页面版式。
对应的脚本特性为layoutGridChar。请参阅我编写的其他书目。

示例：

div { layout-grid-char: auto; }


layout-grid-char-spacing 版本：IE5+专有属性　继承性：有

语法：

layout-grid-char-spacing : auto | length

参数：

auto : 　在对象文本中按最大字符确定网格
length : 　百分数 | 由浮点数字和单位标识符组成的长度值，其百分比取值是基于父对象尺寸。请参阅长度单位

说明：

设置或检索字符间隔。
要实现此属性，layout-grid-mode必须设置为char或both。layout-grid-type必须设置为loose。
其视觉效果类似于line-height属性。只应用于块对象（如div）。
以东亚语言（如中文，日文）编写的文档通常根据一维或二维网格使用字符的页面版式。
对应的脚本特性为layoutGridCharSpacing。请参阅我编写的其他书目。

示例：

div { layout-grid-char-spacing: auto; }


layout-grid-line版本：IE5+专有属性　继承性：有

语法：

layout-grid-line : none | auto | length

参数：

none : 　不指定行网格值
auto : 　在对象文本中按最大字符确定网格
length : 　百分数 | 由浮点数字和单位标识符组成的长度值，其百分比取值是基于父对象尺寸。请参阅长度单位

说明：

设置或检索应用于对象文本的行网格值。
要实现此属性，layout-grid-mode必须设置为line或both。
其视觉效果类似于line-height属性。只应用于块对象（如div）。
以东亚语言（如中文，日文）编写的文档通常根据一维或二维网格使用字符的页面版式。
对应的脚本特性为layoutGridLine。请参阅我编写的其他书目。

示例：

div { layout-grid-line: auto; }


layout-grid-mode版本：IE5+专有属性　继承性：有

语法：

layout-grid-mode : both | line | char | none

参数：

both : 　指定char和line都被启用。要在一个对象上完全启用网格版式，此值是必须的
line : 　指定只使用行网格。建议与内联对象（如span）一起使用
char : 　指定只使用字符网格。建议和块对象（如div）一起使用
none : 　不使用网格

说明：

设置或检索文本网格版式是否使用二维。
以东亚语言（如中文，日文）编写的文档通常根据一维或二维网格使用字符的页面版式。
对应的脚本特性为layoutGridMode。请参阅我编写的其他书目。

示例：

div { layout-grid-mode: char; }


layout-grid-type版本：IE5+专有属性　继承性：有

语法：

layout-grid-type : loose | strict | fixed

参数：

loose : 　指定在中文或韩文中使用网格的文本，只有象形文字，假名，宽字符域网格对齐。其余的和通常一样，尽管包含这些字符的文本范围的layout-grid-mode被设置为none或line。该模式还禁用通常用于对象文本的特殊文本对齐和字符宽度调整。最后，如果不能再换行边界的文本中找到一个换行机会，那么文本将被推至下一行，并且上一行的最后留出空白
strict : 　指定在日文中使用网格。规则为：如果没有其他的宽度调整效果，则增加宽字符以获取精确的网格填充。窄字符（除了草书字体）按照应用于宽字符的一半增量增加
fixed : 　指定使用于等宽版式网格。规则为：所有非草书符号视为等宽。默认情况下，每个字符在单一网格中居中。禁止对齐或任何其他改变字符宽度的行为

说明：

设置或检索应用于对象文本的网格类型。
只应用于块对象（如div）。
以东亚语言（如中文，日文）编写的文档通常根据一维或二维网格使用字符的页面版式。
对应的脚本特性为layoutGridType。请参阅我编写的其他书目。

示例：

div { layout-grid-type: strict; }


CSS Background Properties 背景属性

Background Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
background | CSS1 | IE4+ , NS4+ | 无 | 复合属性。设置或检索对象的背景特性
background-attachment | CSS1 | IE4+ , NS6+ | 无 | 设置或检索背景图像是随对象内容滚动还是固定的
background-color | CSS1 | IE4+ , NS4+ | 无 | 设置或检索对象的背景颜色
background-image | CSS1 | IE4+ , NS4+ | 无 | 设置或检索对象的背景图像
background-position | CSS1 | IE4+ , NS6+ | 无 | 设置或检索对象的背景图像位置
background-positionX | IE专有属性 | IE5.5+ | 无 | 设置或检索对象的背景图像横坐标位置
background-positionY | IE专有属性 | IE5.5+ | 无 | 设置或检索对象的背景图像纵坐标位置
background-repeat | CSS1 | IE4+ , NS4+ | 无 | 设置或检索对象的背景图像是否及如何铺排
layer-background-color | NS专有属性 | NS4+ | 无 | 设置或检索对象整个区域的背景颜色
layer-background-image | NS专有属性 | NS4+ | 无 | 设置或检索对象整个区域的背景图像

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


background版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

background : background-color || background-image || background-repeat || background-attachment || background-position

参数：

该属性是复合属性。请参阅各参数对应的属性。

说明：

如使用该复合属性定义其单个参数，则其他参数的默认值将无条件覆盖各自对应的单个属性设置。
默认值为：transparent none repeat scroll 0% 0%。
尽管该属性不可继承，但如果未指定，其父对象的背景颜色和背景图将在对象下面显示。
对应的脚本特性为background。请参阅我编写的其他书目。

示例：

div { background: red no-repeat scroll 5% 60%; }
body { background: url("images/aardvark.gif") repeat-y; }
pre { background: url("images/aardvark.gif") top; }
caption { background: fuchsia; }


background-attachment版本：CSS1　 兼容性：IE4+ NS6+　继承性：无

语法：

background-attachment : scroll | fixed

参数：

scroll : 　背景图像是随对象内容滚动
fixed : 　背景图像固定

说明：

设置或检索背景图像是随对象内容滚动还是固定的。
对应的脚本特性为backgroundAttachment。请参阅我编写的其他书目。

示例：

html { background-image: url("anasazi.tif"); background-attachment: fixed; }


background-color版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

background-color : transparent | color

参数：

transparent : 　背景色透明
color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

设置或检索对象的背景颜色。
对应的脚本特性为backgroundColor。请参阅我编写的其他书目。

示例：

p { background-color: silver }
div { background-color: rgb(223,71,177) }
body { background-color: #98AB6F }
pre { background-color: transparent; }


background-image版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

background-image : none | url (url)

参数：

none : 　无背景图
url : 　使用绝对或相对地址指定背景图像

说明：

设置或检索对象的背景图像。
对应的脚本特性为backgroundImage。请参阅我编写的其他书目。

示例：

code { background-image: url("comet.jpg"); }
blockquote { background-image: url("c:\InetPub\MyPixs\comet.jpg"); }
br { background-image: url(http://Fred.com/ImageFile/Q.gif); }
body { background-image: none; }


background-position版本：CSS1　 兼容性：IE4+ NS6+　继承性：无

语法：

background-position : length || length
background-position : position || position

参数：

length : 　百分数 | 由浮点数字和单位标识符组成的长度值。请参阅长度单位
position : 　top | center | bottom | left | center | right

说明：

设置或检索对象的背景图像位置。必须先指定background-image属性。默认值为：(0% 0%)。
如果只指定了一个值，该值将用于横坐标。纵坐标将默认为50%。第二个值将用于纵坐标。
该属性定位不受对象的补丁属性(padding)设置影响。
对应的脚本特性为backgroundPosition。请参阅我编写的其他书目。

示例：

div { background: url("images/aardvark.gif"); background-position: 35% 80%; }
menu { background: url("images/aardvark.gif"); background-position: 35% 2.5cm; }
a { background: url("images/aardvark.gif"); background-position: 3.25in; }
body { background: url("images/aardvark.gif"); background-position: top right; }


background-positionX版本：IE5.5+专有属性　继承性：无

语法：

background-positionX : length | left | center | right

参数：

length : 　百分数 | 由浮点数字和单位标识符组成的长度值。请参阅长度单位
left : 　居左
center : 　居中
right : 　居右

说明：

设置或检索对象的背景图像横坐标位置。必须先指定background-image属性。默认值为：0%。
该属性定位不受对象的补丁属性(padding)设置影响。
对应的脚本特性为backgroundPositionX。请参阅我编写的其他书目。

示例：

p { background-image: url("images/aardvark.gif"); background-positionX: 35%; background-repeat:no-repeat; }


background-positionY版本：IE5.5+专有属性　继承性：无

语法：

background-positionY : length | top | center | bottom

参数：

length : 　百分数 | 由浮点数字和单位标识符组成的长度值。请参阅长度单位
top : 　居顶
center : 　居中
bottom : 　居底

说明：

设置或检索对象的背景图像纵坐标位置。必须先指定background-image属性。默认值为：0%。
该属性定位不受对象的补丁属性(padding)设置影响。
对应的脚本特性为backgroundPositionY。请参阅我编写的其他书目。

示例：

p { background-image: url("images/aardvark.gif"); background-positionY: 35%; background-repeat:no-repeat; }


background-repeat版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

background-repeat : repeat | no-repeat | repeat-x | repeat-y

参数：

repeat : 　背景图像在纵向和横向上平铺
no-repeat : 　背景图像不平铺
repeat-x : 　背景图像在横向上平铺
repeat-y : 　背景图像在纵向平铺

说明：

设置或检索对象的背景图像是否及如何铺排。必须先指定对象的背景图像。
对应的脚本特性为backgroundRepeat。请参阅我编写的其他书目。

示例：

menu { background: url("images/aardvark.gif"); background-repeat: repeat-y; }
p { background: url("images/aardvark.gif"); background-repeat: no-repeat; }


layer-background-color版本：NS4+专有属性　继承性：无

语法：

layer-background-color : transparent | color

参数：

transparent : 　背景色透明
color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

设置或检索对象整个区域的背景颜色。

示例：

div { layer-background-color: transparent; }


layer-background-image 版本：NS4+专有属性　继承性：无

语法：

layer-background-image : none | url (url)

参数：

none : 　无背景图
url : 　使用绝对或相对地址指定背景图像

说明：

设置或检索对象整个区域的背景图像。

示例：

code { position: absolute; top: 100px; left: 300px; width: 200px; border: thin solid black; background-image: url("comet.jpg"); layer-background-image: url("bb_comet.jpg"); }


CSS Positioning Properties 定位属性

Positioning Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
position | CSS2 | IE4+ , NS4+ | 无 | 检索对象的定位方式
z-index | CSS2 | IE4+ , NS6+ | 无 | 检索或设置对象的层叠顺序
top | CSS2 | IE4+ , NS4+ | 无 | 检索或设置对象与其最近一个定位的父对象顶部相关的位置
right | CSS2 | IE5+ | 无 | 检索或设置对象与其最近一个定位的父对象右边相关的位置
bottom | CSS2 | IE5+ | 无 | 检索或设置对象与其最近一个定位的父对象底边相关的位置
left | CSS2 | IE4+ , NS4+ | 无 | 检索或设置对象与其最近一个定位的父对象左边相关的位置

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


position版本：CSS2　 兼容性：IE4+ NS4+　继承性：无

语法：

position : static | absolute | fixed | relative

参数：

static : 　无特殊定位，对象遵循HTML定位规则
absolute : 　将对象从文档流中拖出，使用left，right，top，bottom等属性进行绝对定位。而其层叠通过z-index属性定义。此时对象不具有边距，但仍有补白和边框
relative : 　对象不可层叠，但将依据left，right，top，bottom等属性在正常文档流中偏移位置
fixed : 　IE5.5及NS6尚不支持此属性

说明：

检索对象的定位方式。
对应的脚本特性为position。请参阅我编写的其他书目。

示例：

div { position: absolute; bottom: 1in; left: 1in; right: 1in; top: 1in; }
div { position:relative; top:-3px; left:6px; }

小 强 bottom : -20px
  小强的属性：


z-index版本：CSS2　 兼容性：IE4+ NS6+　继承性：无

语法：

z-index : auto | number

参数：

auto : 　遵从其父对象的定位
number : 　无单位的整数值。可为负数

说明：

检索或设置对象的层叠顺序。
如两个绝对定位对象的此属性具有同样的值，那么将依据它们在HTML文档中声明的顺序层叠
对应的脚本特性为zIndex。请参阅我编写的其他书目。

示例：

div { position:absolute; z-index:3; width:6px; }


top版本：CSS2　 兼容性：IE4+ NS4+　继承性：无

语法：

top : auto | length

参数：

auto : 　无特殊定位，根据HTML定位规则载文档流中分配
length : 　由浮点数字和单位标识符组成的长度值，或者百分数。必须定义position属性值为absolute或者relative此取值方可生效。请参阅长度单位

说明：

检索或设置对象与其最近一个定位的父对象顶部相关的位置。
对应的脚本特性为top。其值为一字符串，所以不可用于脚本(Scripts)中的计算。请使用style对象的posTop，pixelTop，以及对象的offsetTop等特性。请参阅我编写的其他书目。

示例：

div { position: absolute; top: 1in; }
div { position:relative; top:-3px; left:6px; }


right版本：CSS2　 兼容性：IE5+　继承性：无

语法：

right : auto | length

参数：

auto : 　无特殊定位，根据HTML定位规则载文档流中分配
length : 　由浮点数字和单位标识符组成的长度值 | 或者百分数。必须定义position属性值为absolute或者relative此取值方可生效。请参阅长度单位

说明：

检索或设置对象与其最近一个定位的父对象右边相关的位置。
对应的脚本特性为right。其值为一字符串，所以不可用于脚本(Scripts)中的计算。请使用style对象的posRight，pixelRight等特性。请参阅我编写的其他书目。

示例：

div { position: absolute; right: 1in; }
div { position:relative; top:-3px; right:6px; }


bottom版本：CSS2　 兼容性：IE5+　继承性：无

语法：

bottom : auto | length

参数：

auto : 　无特殊定位，根据HTML定位规则载文档流中分配
length : 　由浮点数字和单位标识符组成的长度值 | 百分数。必须定义position属性值为absolute或者relative此取值方可生效。请参阅长度单位

说明：

检索或设置对象与其最近一个定位的父对象底边相关的位置。
对应的脚本特性为bottom。其值为一字符串，所以不可用于脚本(Scripts)中的计算。请使用style对象的posBottom，pixelBottom等运行时特性。请参阅我编写的其他书目。

示例：

div { position: absolute; bottom: 1in; }
div { position:relative; bottom:6px; }


left版本：CSS2　 兼容性：IE4+ NS4+　继承性：无

语法：

left : auto | length

参数：

auto : 　无特殊定位，根据HTML定位规则载文档流中分配
length : 　由浮点数字和单位标识符组成的长度值 | 百分数。必须定义position属性值为absolute或者relative此取值方可生效。请参阅长度单位

说明：

检索或设置对象与其最近一个定位的父对象左边相关的位置。
对应的脚本特性为left。其值为一字符串，所以不可用于脚本(Scripts)中的计算。请使用style对象的posLeft，pixelLeft，以及对象的offsetLeft等特性。请参阅我编写的其他书目。

示例：

div { position: absolute; left: 1in; }
div { position:relative; top:-3px; left:6px; }


CSS Dimensions Properties 尺寸属性

Dimensions Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
height | CSS1 | IE4+ , NS6+ | 无 | 检索或设置对象的高度
max-height | CSS2 | NONE | 无 | 设置或检索对象的最大高度
min-height | CSS2 | IE6+ | 无 | 设置或检索对象的最小高度
width | CSS1 | IE4+ , NS6+ | 无 | 检索或设置对象的宽度
max-width | CSS2 | NONE | 无 | 设置或检索对象的最大宽度
min-width | CSS2 | NONE | 无 | 设置或检索对象的最小宽度

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


height版本：CSS1　 兼容性：IE4+ NS6+　继承性：无

语法：

height : auto | length

参数：

auto : 　无特殊定位，根据HTML定位规则载文档流中分配
length : 　由浮点数字和单位标识符组成的长度值 | 百分数。百分数是基于父对象的高度。不可为负数。请参阅长度单位

说明：

检索或设置对象的高度。
对于img对象来说，仅指定此属性，其width值将根据图片源尺寸等比例缩放。
对应的脚本特性为height。其值为一字符串，所以不可用于脚本(Scripts)中的计算。请使用style对象的posHeight，pixelHeight，以及对象的offsetHeight等特性。请参阅我编写的其他书目。
按照样式表的规则，对象的实际高度为其下列属性值之和：
margin-top + border-top + padding-top + height + padding-bottom + border-bottom + margin-bottom
而在IE6以前的版本，对象的实际高度却等于：
margin-top + height + margin-bottom
在IE6中，已经提供了针对此问题的解决方案。而上述属性的相互关系，请参看图例。

示例：

div { height: 1in; }
div { position:absolute; top:-3px; height:6px; }


max-height版本：CSS2　 兼容性：NONE　继承性：无

语法：

max-height : none | length

参数：

none : 　无最大高度限制
length : 　由浮点数字和单位标识符组成的长度值 | 或者百分数。不可为负数。请参阅长度单位

说明：

设置或检索对象的最大高度。
如果max-height属性的值小于min-height属性的值，将会被自动转设为min-height属性的值。
目前IE5.5尚不支持此属性。
对应的脚本特性为maxHeight。请参阅我编写的其他书目。

示例：

p { max-height: 200%; }


min-height版本：CSS2　 兼容性：IE6+　继承性：无

语法：

min-height : none | length

参数：

none : 　无最小高度限制
length : 　由浮点数字和单位标识符组成的长度值 | 或者百分数。不可为负数。请参阅长度单位

说明：

设置或检索对象的最小高度。
如果min-height属性的值大于max-height属性的值，将会被自动转设为max-height属性的值。
目前IE5.5尚不支持此属性。
对应的脚本特性为minHeight。请参阅我编写的其他书目。

示例：

p { min-height: 200px; }


width版本：CSS1　 兼容性：IE4+ NS6+　继承性：无

语法：

width : auto | length

参数：

auto : 　无特殊定位，根据HTML定位规则载文档流中分配
length : 　由浮点数字和单位标识符组成的长度值，或者百分数。百分数是基于父对象的宽度。不可为负数。请参阅长度单位

说明：

检索或设置对象的宽度。
对于img对象来说，仅指定此属性，其height值将根据图片源尺寸等比例缩放。
对应的脚本特性为width。其值为一字符串，所以不可用于脚本(Scripts)中的计算。请使用style对象的posWidth，pixelWidth，以及对象的offsetWidth等特性。请参阅我编写的其他书目。
按照样式表的规则，对象的实际宽度为其下列属性值之和：
margin-left + border-left + padding-left + width + padding-right + border-right + margin-right
而在IE6以前的版本，对象的实际宽度却等于：
margin-left + width + margin-right
在IE6中，已经提供了针对此问题的解决方案。而上述属性的相互关系，请参看图例。

示例：

div { width: 1in; }
div { position:absolute; top:-3px; width:6px; }


max-width版本：CSS2　 兼容性：NONE　继承性：无

语法：

max-width : none | length

参数：

none : 　无最大宽度限制
length : 　由浮点数字和单位标识符组成的长度值 | 或者百分数。不可为负数。请参阅长度单位

说明：

设置或检索对象的最大宽度。
如果max-width属性的值小于min-width属性的值，将会被自动转设为min-width属性的值。
目前IE5.5尚不支持此属性。
对应的脚本特性为maxWidth。请参阅我编写的其他书目。

示例：

p { max-width: 200%; }


min-width版本：CSS2　 兼容性：NONE　继承性：无

语法：

min-width : none | length

参数：

none : 　无最小宽度限制
length : 　由浮点数字和单位标识符组成的长度值，或者百分数。不可为负数。请参阅长度单位

说明：

设置或检索对象的最小宽度。
如果min-width属性的值大于max-width属性的值，将会被自动转设为max-width属性的值。
目前IE5.5尚不支持此属性。
对应的脚本特性为minWidth。请参阅我编写的其他书目。

示例：

p { min-width: 200px; }


CSS Layout Properties 布局属性

Layout Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
clear | CSS1 | IE4+ , NS4+ | 无 | 该属性的值指出了不允许有浮动对象的边。请参阅float属性
float | CSS1 | IE4+ , NS4+ | 无 | 该属性的值指出了对象是否及如何浮动。请参阅clear属性
clip | CSS2 | IE4+ , NS6+ | 无 | 检索或设置对象的可视区域。区域外的部分是透明的
overflow | CSS2 | IE4+ , NS6+ | 无 | 检索或设置当对象的内容超过其指定高度及宽度时如何管理内容
overflow-x | IE专有属性 | IE4+ | 无 | 检索或设置当对象的内容超过其指定宽度时如何管理内容
overflow-y | IE专有属性 | IE4+ | 无 | 检索或设置当对象的内容超过其指定高度时如何管理内容
display | CSS1/CSS2 | IE4+ , NS4+ | 无 | 设置或检索对象是否及如何显示
visibility | CSS2 | IE4+ , NS6+ | 无 | 设置或检索是否显示对象。与display属性不同，此属性为隐藏的对象保留其占据的物理空间

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


clear版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

clear : none | left |right | both

参数：

none : 　允许两边都可以有浮动对象
both : 　不允许有浮动对象
left : 　不允许左边有浮动对象
right : 　不允许右边有浮动对象

说明：

该属性的值指出了不允许有浮动对象的边。请参阅float属性。
对应的脚本特性为clear。请参阅我编写的其他书目。

示例：

div { clear : left }
img { float: right }

您所看到的文字块的名字是小强，图片的名字是旺财，请您从下方的选择框内选择文字块和图片不同的属性值，看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。
  小强的属性：
  旺财的属性：


float版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

float : none | left |right

参数：

none : 　对象不浮动
left : 　对象浮在左边
right : 　对象浮在右边

说明：

该属性的值指出了对象是否及如何浮动。请参阅clear属性。
当该属性不等于none引起对象浮动时，对象将被视作块对象(block-level)，即display属性等于block。也就是说，浮动对象的display特性将被忽略。
对应的脚本特性为styleFloat。请参阅我编写的其他书目。

示例：

div { clear : left }
img { float: right }

您所看到的文字块的名字是小强，图片的名字是旺财，请您从下方的选择框内选择文字块和图片不同的属性值，看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。
  小强的属性：
  旺财的属性：


clip版本：CSS2　 兼容性：IE4+ NS6+　继承性：无

语法：

clip : auto | rect ( number number number number )

参数：

auto : 　对象无剪切
rect ( number number number number ) : 　依据上-右-下-左的顺序提供自对象左上角为(0,0)坐标计算的四个偏移数值，其中任一数值都可用auto替换，即此边不剪切

说明：

检索或设置对象的可视区域。区域外的部分是透明的。
必须将position的值设为absolute，此属性方可使用。
自IE5开始，此属性在MAC平台上可用。
对应的脚本特性为clip。请参阅我编写的其他书目。

示例：

div { position:absolute; width:60px; height:60px; clip:rect(0 20 50 10); }
div { position:absolute; width:60px; height:60px; clip:rect(1cm auto 50px 10cm); }


overflow 版本：CSS2　 兼容性：IE4+ NS6+　继承性：无

语法：

overflow : visible | auto | hidden | scroll

参数：

visible : 　不剪切内容也不添加滚动条。假如显式声明此默认值，对象将被剪切为包含对象的window或frame的大小。并且clip属性设置将失效
auto : 　此为body对象和textarea的默认值。在需要时剪切内容并添加滚动条
hidden : 　不显示超过对象尺寸的内容
scroll : 　总是显示滚动条

说明：

检索或设置当对象的内容超过其指定高度及宽度时如何管理内容。
设置textarea对象为hidden值将隐藏其滚动条。
对于table来说，假如table-layout属性设置为fixed，则td对象支持带有默认值为hidden的overflow属性。如果设为hidden，scroll或者auto，那么超出td尺寸的内容将被剪切。如果设为visible，将导致额外的文本溢出到右边或左边（视direction属性设置而定）的单元格。
自IE5开始，此属性在MAC平台上可用。
对应的脚本特性为overflow。请参阅我编写的其他书目。

示例：

body { overflow: hidden; }
div { overflow: scroll; height: 100px; width: 100px; }

请您用下面的按钮选择这段文字的overflow属性的值。看一看会发生什么，然后您就会明白这个属性的意义。然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


overflow-x版本：IE4+专有属性　继承性：无

语法：

overflow-x : visible | auto | hidden | scroll

参数：

visible : 　不剪切内容也不添加滚动条。假如显式声明此默认值，对象将被剪切为包含对象的window或frame的宽度。并且clip属性设置将失效
auto : 　此为body对象和textarea的默认值。在需要时剪切内容并添加滚动条
hidden : 　不显示超过对象宽度的内容
scroll : 　总是显示横向滚动条

说明：

检索或设置当对象的内容超过其指定宽度时如何管理内容。
参阅overflow属性。
对应的脚本特性为overflowX。请参阅我编写的其他书目。

示例：

body { overflow-x: hidden; }
div { overflow-x: scroll; height: 100px; width: 100px; }

请您用下面的按钮选择这段文字的overflow-x属性的值。看一看会发生什么，然后您就会明白这个属性的意义。然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


overflow-y版本：IE4+专有属性　继承性：无

语法：

overflow-y : visible | auto | hidden | scroll

参数：

visible : 　不剪切内容也不添加滚动条。假如显式声明此默认值，对象将被剪切为包含对象的window或frame的高度。并且clip属性设置将失效
auto : 　此为body对象和textarea的默认值。在需要时剪切内容并添加滚动条
hidden : 　不显示超过对象高度的内容
scroll : 　总是显示纵向滚动条

说明：

检索或设置当对象的内容超过其指定高度时如何管理内容。
参阅overflow属性。
对应的脚本特性为overflowY。请参阅我编写的其他书目。

示例：

body { overflow-y: hidden; }
div { overflow-y: scroll; height: 100px; width: 100px; }

请您用下面的按钮选择这段文字的overflow-y属性的值。看一看会发生什么，然后您就会明白这个属性的意义。然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


display版本：CSS1/CSS2　 兼容性：IE4+ NS4+　继承性：无

语法：

display : block | none | inline | compact | marker | inline-table | list-item | run-in | table |table-caption | table-cell | table-column | table-column-group | table-footer-group | table-header-group | table-row | table-row-group

参数：

block : 　CSS1　块对象的默认值。用该值为对象之后添加新行
none : 　CSS1　隐藏对象。与visibility属性的hidden值不同，其不为被隐藏的对象保留其物理空间
inline : 　CSS1　内联对象的默认值。用该值将从对象中删除行
compact : 　CSS2　分配对象为块对象或基于内容之上的内联对象
marker : 　CSS2　指定内容在容器对象之前或之后。要使用此参数，对象必须和:after及:before 伪元素一起使用
inline-table : 　CSS2　将表格显示为无前后换行的内联对象或内联容器
list-item : 　CSS1　将块对象指定为列表项目。并可以添加可选项目标志
run-in : 　CSS2　分配对象为块对象或基于内容之上的内联对象
table : 　CSS2　将对象作为块元素级的表格显示
table-caption : 　CSS2　将对象作为表格标题显示
table-cell : 　CSS2　将对象作为表格单元格显示
table-column : 　CSS2　将对象作为表格列显示
table-column-group : 　CSS2　将对象作为表格列组显示
table-header-group : 　CSS2　将对象作为表格标题组显示
table-footer-group : 　CSS2　将对象作为表格脚注组显示
table-row : 　CSS2　将对象作为表格行显示
table-row-group : 　CSS2　将对象作为表格行组显示

说明：

设置或检索对象是否及如何显示。
目前 IE5.5仅支持以上CSS1的参数。
对应的脚本特性为display。请参阅我编写的其他书目。

示例：

img { disply: block; float: right; }

您所看到的文字块的名字是小强，图片的名字是旺财，请您从下方的选择框内选择旺财的display属性的不同的值，看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。
  旺财的属性：


visibility版本：CSS2　 兼容性：IE4+ NS6+　继承性：无

语法：

visibility : inherit | visible | collapse | hidden

参数：

inherit : 　继承上一个父对象的可见性
visible : 　对象可视
hidden : 　对象隐藏
collapse : 　主要用来隐藏表格的行或列。隐藏的行或列能够被其他内容使用。对于表格外的其他对象，其作用等同于hidden。IE5.5尚不支持此属性。

说明：

设置或检索是否显示对象。与display属性不同，此属性为隐藏的对象保留其占据的物理空间。
如果希望对象为可视，其父对象也必须是可视的。
对应的脚本特性为visibility。请参阅我编写的其他书目。

示例：

img { visibility: inherit; float: right; }

您所看到的文字块的名字是小强，图片的名字是旺财，请您从下方的选择框内选择旺财的visibility属性的不同的值，看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。
  旺财的属性：


CSS Margins Properties 外补丁属性

Margins Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
margin | CSS1 | IE4+ , NS4+ | 无 | 检索或设置对象四边的外延边距
margin-top | CSS1 | IE4+ , NS4+ | 无 | 检索或设置对象顶边的外延边距
margin-right | CSS1 | IE4+ , NS4+ | 无 | 检索或设置对象右边的外延边距
margin-bottom | CSS1 | IE4+ , NS4+ | 无 | 检索或设置对象底边的外延边距
margin-left | CSS1 | IE4+ , NS4+ | 无 | 检索或设置对象左边的外延边距

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


margin版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

margin : auto | length

参数：

auto : 　值被设置为相对边的值
length : 　由浮点数字和单位标识符组成的长度值 | 百分数。百分数是基于父对象的高度。对于内联对象来说，左右外延边距可以是负数值。请参阅长度单位

说明：

检索或设置对象四边的外延边距。
如果提供全部四个参数值，将按上－右－下－左的顺序作用于四边。
如果只提供一个，将用于全部的四边。
如果提供两个，第一个用于上－下，第二个用于左－右。
如果提供三个，第一个用于上，第二个用于左－右，第三个用于下。
内联对象要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
在IE4+，margin属性不可用于td和tr对象。
外延边距始终透明。
对应的脚本特性为margin。请参阅我编写的其他书目。
关于对象的尺寸与边框，内外补丁等样式表属性的关系，请参看图例以及height和width属性。

示例：

body { margin: 36pt 24pt 36pt; }
body { margin: 11.5%; }
body { margin: 10% 10% 10% 10%; }


margin-top版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

margin-top : auto | length

参数：

auto : 　值被设置为相对边的值
length : 　由浮点数字和单位标识符组成的长度值 | 或者百分数。百分数是基于父对象的高度。请参阅长度单位

说明：

检索或设置对象顶边的外延边距。
内联对象要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
在IE4+，margin属性不可用于td和tr对象。
外延边距始终透明。
对应的脚本特性为marginTop。请参阅我编写的其他书目。

示例：

body { margin-top: 11.5%; }

请您用下面的按钮加减这段文字的margin-top属性的值（单位是px）。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


margin-right版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

margin-right : auto | length

参数：

auto : 　值被设置为相对边的值
length : 　由浮点数字和单位标识符组成的长度值 | 或者百分数。百分数是基于父对象的高度。请参阅长度单位

说明：

检索或设置对象右边的外延边距。
内联对象要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
在IE4+，margin属性不可用于td和tr对象。
外延边距始终透明。
对应的脚本特性为marginRight。请参阅我编写的其他书目。

示例：

body { margin-right: 11.5%; }

请您用下面的按钮加减这段文字的margin-right属性的值（单位是px）。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


margin-bottom版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

margin-bottom : auto | length

参数：

auto : 　值被设置为相对边的值
length : 　由浮点数字和单位标识符组成的长度值 | 百分数。百分数是基于父对象的高度。请参阅长度单位

说明：

检索或设置对象底边的外延边距。
内联对象要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
在IE4+，margin属性不可用于td和tr对象。
外延边距始终透明。
对应的脚本特性为marginBottom。请参阅我编写的其他书目。

示例：

body { margin-bottom: 11.5%; }

请您用下面的按钮加减这段文字的margin-bottom属性的值（单位是px）。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


margin-left版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

margin-left : auto | length

参数：

auto : 　值被设置为相对边的值
length : 　由浮点数字和单位标识符组成的长度值 | 或者百分数。百分数是基于父对象的高度。请参阅长度单位

说明：

检索或设置对象左边的外延边距。
内联对象要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
在IE4+，margin属性不可用于td和tr对象。
外延边距始终透明。
对应的脚本特性为marginLeft。请参阅我编写的其他书目。

示例：

body { margin-left: 11.5%; }

请您用下面的按钮加减这段文字的margin-left属性的值（单位是px）。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


CSS Outlines Properties 轮廓属性

Outlines Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
outline | CSS2 | NONE | 无 | 复合属性。设置或检索对象外的线条轮廓
outline-color | CSS2 | NONE | 无 | 设置或检索对象外的线条轮廓的颜色
outline-style | CSS2 | NONE | 无 | 设置或检索对象外的线条轮廓的样式
outline-width | CSS2 | NONE | 无 | 设置或检索对象外的线条轮廓的宽度

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


outline版本：CSS2　 兼容性：NONE　继承性：无

语法：

outline : outline-color ||outline-style || outline-width

参数：

该属性是复合属性。请参阅各参数对应的属性。

说明：

设置或检索对象外的线条轮廓。outline画在border外面，并且不一定是矩形。
目前IE5.5尚不支持此属性。
对应的脚本特性为outline。请参阅我编写的其他书目。

示例：

img { outline: red }
p { outline: double 5px }
button { outline: #E9E9E9 double thin }


outline-color版本：CSS2　 兼容性：NONE　继承性：无

语法：

outline-color : color |invert

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表
invert : 　使用背景色的反色

说明：

设置或检索对象外的线条轮廓的颜色。参见outline属性。
目前IE5.5尚不支持此属性。
对应的脚本特性为outlineColor。请参阅我编写的其他书目。

示例：

img { outline-color: red }
p { outline-color: #E9E9E9 }


outline-style版本：CSS2　 兼容性：NONE　继承性：无

语法：

outline-style : none |dotted |dashed |solid |double |groove |ridge |inset |outset

参数：

none : 　无边框。与任何指定的outline-width值无关
dotted : 　点线边框
dashed : 　虚线边框
solid : 　实线边框
double : 　双线边框。两条单线与其间隔的和等于指定的oueline-width值
groove : 　根据outline-color的值画3D凹槽
ridge : 　根据outline-color的值画菱形边框
inset : 　根据outline-color的值画3D凹边
outset : 　根据outline-color的值画3D凸边

说明：

设置或检索对象外的线条轮廓的样式。参见outline属性。
目前IE5.5尚不支持此属性。
对应的脚本特性为outlineStyle。请参阅我编写的其他书目。

示例：

img { outline-color: orange; outline-style: solid ; outline-width: medium ; }


outline-width版本：CSS2　 兼容性：NONE　继承性：无

语法：

outline-width : medium | thin | thick | length

参数：

medium : 　默认宽度
thin : 　小于默认宽度
thick : 　大于默认宽度
length : 　由浮点数字和单位标识符组成的长度值。不可为负值。请参阅长度单位

说明：

设置或检索对象外的线条轮廓的宽度。参见outline属性。
目前IE5.5尚不支持此属性。
对应的脚本特性为outlineWidth。请参阅我编写的其他书目。

示例：

img { outline-color: orange; outline-style: solid ; outline-width: medium ; }


CSS Borders Properties 边框属性

Borders Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
border | CSS1 | IE4+ , NS4+ | 无 | 复合属性。设置对象边框的特性
border-color | CSS1 | IE4+ , NS6+ | 无 | 设置或检索对象边框颜色
border-style | CSS1 | IE4+ , NS4+ | 无 | 设置或检索对象边框样式
border-width | CSS1 | IE4+ , NS4+ | 无 | 设置或检索对象边框宽度
border-top | CSS1 | IE4+ , NS6+ | 无 | 复合属性。设置对象顶边的特性
border-top-color | CSS2 | IE4+ , NS6+ | 无 | 设置或检索对象顶边颜色
border-top-style | CSS2 | IE4+ , NS6+ | 无 | 设置或检索对象顶边样式
border-top-width | CSS1 | IE4+ , NS4+ | 无 | 设置或检索对象顶边宽度
border-right | CSS1 | IE4+ , NS6+ | 无 | 复合属性。设置对象右边的特性
border-right-color | CSS2 | IE4+ , NS6+ | 无 | 设置或检索对象右边颜色
border-right-style | CSS2 | IE4+ , NS6+ | 无 | 设置或检索对象右边样式
border-right-width | CSS1 | IE4+ , NS4+ | 无 | 设置或检索对象右边宽度
border-bottom | CSS1 | IE4+ , NS6+ | 无 | 复合属性。设置对象底边的特性
border-bottom-color | CSS2 | IE4+ , NS6+ | 无 | 设置或检索对象底边颜色
border-bottom-style | CSS2 | IE4+ , NS6+ | 无 | 设置或检索对象底边样式
border-bottom-width | CSS1 | IE4+ , NS4+ | 无 | 设置或检索对象底边宽度
border-left | CSS1 | IE4+ , NS6+ | 无 | 复合属性。设置对象左边的特性
border-left-color | CSS2 | IE4+ , NS6+ | 无 | 设置或检索对象左边颜色
border-left-style | CSS2 | IE4+ , NS6+ | 无 | 设置或检索对象左边样式
border-left-width | CSS1 | IE4+ , NS4+ | 无 | 设置或检索对象左边宽度

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


border版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

border : border-width || border-style || border-color

参数：

该属性是复合属性。请参阅各参数对应的属性。

说明：

如使用该复合属性定义其单个参数，则其他参数的默认值将无条件覆盖各自对应的单个属性设置。
默认值为：medium none。border-color的默认值将采用文本颜色。
要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
对应的脚本特性为border。请参阅我编写的其他书目。
关于对象的尺寸与边框，内外补丁等样式表属性的关系，请参看图例以及height和width属性。

示例：

p { border: thick double yellow; }
blockquote { border: dotted gray; }
p { border: 25px; }


border-color版本：CSS1　 兼容性：IE4+ NS6+　继承性：无

语法：

border-color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

如果提供全部四个参数值，将按上－右－下－左的顺序作用于四个边框。
如果只提供一个，将用于全部的四条边。
如果提供两个，第一个用于上－下，第二个用于左－右。
如果提供三个，第一个用于上，第二个用于左－右，第三个用于下。
要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-width等于0或border-style设置为none，本属性将失去作用。
对应的脚本特性为borderColor。请参阅我编写的其他书目。

示例：

ody { border-color: silver ;red; }
body { border-color: silver red RGB(223, 94, 77); }
body { border-color: silver red RGB(223, 94, 77) black; }


border-style版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

border-style : none | hidden | dotted | dashed | solid | double | groove | ridge | inset | outset

参数：

none : 　无边框。与任何指定的border-width值无关
hidden : 　隐藏边框。IE不支持
dotted : 　在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为点线。否则为实线
dashed : 　在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为虚线。否则为实线
solid : 　实线边框
double : 　双线边框。两条单线与其间隔的和等于指定的border-width值
groove : 　根据border-color的值画3D凹槽
ridge : 　根据border-color的值画菱形边框
inset : 　根据border-color的值画3D凹边
outset : 　根据border-color的值画3D凸边

说明：

如果提供全部四个参数值，将按上－右－下－左的顺序作用于四个边框。
如果只提供一个，将用于全部的四条边。
如果提供两个，第一个用于上－下，第二个用于左－右。
如果提供三个，第一个用于上，第二个用于左－右，第三个用于下。
要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-width不大于0，本属性将失去作用。
对应的脚本特性为borderStyle。请参阅我编写的其他书目。

示例：

body { border-style: double groove; }
body { border-style: double groove dashed; }

none hidden dotted dashed

solid double groove

ridge inset outset


border-width版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

border-width : medium | thin | thick | length

参数：

medium : 　默认宽度
thin : 　小于默认宽度
thick : 　大于默认宽度
length : 　由浮点数字和单位标识符组成的长度值。不可为负值。请参阅长度单位

说明：

如果提供全部四个参数值，将按上－右－下－左的顺序作用于四个边框。
如果只提供一个，将用于全部的四条边。
如果提供两个，第一个用于上－下，第二个用于左－右。
如果提供三个，第一个用于上，第二个用于左－右，第三个用于下。
要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-style设置为none，本属性将失去作用。
对应的脚本特性为borderWidth。请参阅我编写的其他书目。

示例：

span { border-style: solid; border-width: thin; }
span { border-style: solid; border-width: 1px thin; }

thin midium thick


border-top版本：CSS1　 兼容性：IE4+ NS6+　继承性：无

语法：

border-top : border-width || border-style || border-color

参数：

该属性是复合属性。请参阅各参数对应的属性。

说明：

请参阅border属性。
对应的脚本特性为borderTop。请参阅我编写的其他书目。

示例：

div { border-bottom: 25px solid red; border-left: 25px solid yellow; border-right: 25px solid blue; border-top: 25px solid green; }


border-top-color版本：CSS2　 兼容性：IE4+ NS6+　继承性：无

语法：

border-top-color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-width等于0或border-style设置为none，本属性将失去作用。
对应的脚本特性为borderTopColor。请参阅我编写的其他书目。

示例：

div { border-top-color: red; border-bottom-color: RGB(223, 94, 77); border-right-color: red; border-left-color: black;}


border-top-style版本：CSS2　 兼容性：IE4+ NS6+　继承性：无

语法：

border-top-style : none | hidden | dotted | dashed | solid | double | groove | ridge | inset | outset

参数：

none : 　无边框。与任何指定的border-width值无关
hidden : 　隐藏边框。IE不支持
dotted : 　在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为点线。否则为实线
dashed : 　在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为虚线。否则为实线
solid : 　实线边框
double : 　双线边框。两条单线与其间隔的和等于指定的border-width值
groove : 　根据border-color的值画3D凹槽
ridge : 　根据border-color的值画菱形边框
inset : 　根据border-color的值画3D凹边
outset : 　根据border-color的值画3D凸边

说明：

要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-width不大于0，本属性将失去作用。
对应的脚本特性为borderTopStyle。请参阅我编写的其他书目。

示例：

body { border-top-style: double; border-bottom-style: groove; border-left-style: dashed; border-right-style: dotted; }


border-top-width版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

border-top-width : medium | thin | thick | length

参数：

medium : 　默认宽度
thin : 　小于默认宽度
thick : 　大于默认宽度
length : 　由浮点数字和单位标识符组成的长度值。不可为负值。请参阅长度单位

说明：

要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-style设置为none，本属性将失去作用。
对应的脚本特性为borderTopWidth。请参阅我编写的其他书目。

示例：

span { border-top-width: thin; border-top-style: solid; }
span { border-bottom-width: thin; border-bottom-style: solid; }
span { border-left-width: thin; border-left-style: solid; }
span { border-right-width: thin; border-right-style: solid; }


border-right版本：CSS1　 兼容性：IE4+ NS6+　继承性：无

语法：

border-right : border-width || border-style || border-color

参数：

该属性是复合属性。请参阅各参数对应的属性。

说明：

请参阅border属性。
对应的脚本特性为borderRight。请参阅我编写的其他书目。

示例：

div { border-bottom: 25px solid red; border-left: 25px solid yellow; border-right: 25px solid blue; border-top: 25px solid green; }


border-right-color版本：CSS2　 兼容性：IE4+ NS6　继承性：无

语法：

border-right-color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-width等于0或border-style设置为none，本属性将失去作用。
对应的脚本特性为borderRightColor。请参阅我编写的其他书目。

示例：

div { border-top-color: red; border-bottom-color: RGB(223, 94, 77); border-right-color: red; border-left-color: black;}


border-right-style版本：CSS2　 兼容性：IE4+ NS6+　继承性：无

语法：

border-right-style : none | hidden | dotted | dashed | solid | double | groove | ridge | inset | outset

参数：

none : 　无边框。与任何指定的border-width值无关
hidden : 　隐藏边框。IE不支持
dotted : 　在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为点线。否则为实线
dashed : 　在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为虚线。否则为实线
solid : 　实线边框
double : 　双线边框。两条单线与其间隔的和等于指定的border-width值
groove : 　根据border-color的值画3D凹槽
ridge : 　根据border-color的值画菱形边框
inset : 　根据border-color的值画3D凹边
outset : 　根据border-color的值画3D凸边

说明：

要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-width不大于0，本属性将失去作用。
对应的脚本特性为borderRightStyle。请参阅我编写的其他书目。

示例：

body { border-top-style: double; border-bottom-style: groove; border-left-style: dashed; border-right-style: dotted; }


border-right-width版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

border-right-width : medium | thin | thick | length

参数：

medium : 　默认宽度
thin : 　小于默认宽度
thick : 　大于默认宽度
length : 　由浮点数字和单位标识符组成的长度值。不可为负值。请参阅长度单位

说明：

要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-style设置为none，本属性将失去作用。
对应的脚本特性为borderRightWidth。请参阅我编写的其他书目。

示例：

span { border-top-width: thin; border-top-style: solid; }
span { border-bottom-width: thin; border-bottom-style: solid; }
span { border-left-width: thin; border-left-style: solid; }
span { border-right-width: thin; border-right-style: solid; }


border-bottom版本：CSS1　 兼容性：IE4+ NS6+　继承性：无

语法：

border-bottom : border-width || border-style || border-color

参数：

该属性是复合属性。请参阅各参数对应的属性。

说明：

请参阅border属性。
对应的脚本特性为borderBottom。请参阅我编写的其他书目。

示例：

div { border-bottom: 25px solid red; border-left: 25px solid yellow; border-right: 25px solid blue; border-top: 25px solid green; }


border-bottom-color版本：CSS2　 兼容性：IE4+ NS6　继承性：无

语法：

border-bottom-color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-width等于0或border-style设置为none，本属性将失去作用。

示例：

div { border-top-color: red; border-bottom-color: RGB(223, 94, 77); border-right-color: red; border-left-color: black;}


border-bottom-style版本：CSS2　 兼容性：IE4+ NS6+　继承性：无

语法：

border-bottom-style : none | hidden | dotted | dashed | solid | double | groove | ridge | inset | outset

参数：

none : 　无边框。与任何指定的border-width值无关
hidden : 　隐藏边框。IE不支持
dotted : 　在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为点线。否则为实线
dashed : 　在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为虚线。否则为实线
solid : 　实线边框
double : 　双线边框。两条单线与其间隔的和等于指定的border-width值
groove : 　根据border-color的值画3D凹槽
ridge : 　根据border-color的值画菱形边框
inset : 　根据border-color的值画3D凹边
outset : 　根据border-color的值画3D凸边

说明：

要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-width不大于0，本属性将失去作用。
对应的脚本特性为borderBottomStyle。请参阅我编写的其他书目。

示例：

body { border-top-style: double; border-bottom-style: groove; border-left-style: dashed; border-right-style: dotted; }


border-bottom-width版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

border-bottom-width : medium | thin | thick | length

参数：

medium : 　默认宽度
thin : 　小于默认宽度
thick : 　大于默认宽度
length : 　由浮点数字和单位标识符组成的长度值。不可为负值。请参阅长度单位

说明：

要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-style设置为none，本属性将失去作用。
对应的脚本特性为borderBottomWidth。请参阅我编写的其他书目。

示例：

span { border-top-width: thin; border-top-style: solid; }
span { border-bottom-width: thin; border-bottom-style: solid; }
span { border-left-width: thin; border-left-style: solid; }
span { border-right-width: thin; border-right-style: solid; }


border-left版本：CSS1　 兼容性：IE4+ NS6+　继承性：无

语法：

border-left : border-width || border-style || border-color

参数：

该属性是复合属性。请参阅各参数对应的属性。

说明：

请参阅border属性。
对应的脚本特性为borderLeft。请参阅我编写的其他书目。

示例：

div { border-bottom: 25px solid red; border-left: 25px solid yellow; border-right: 25px solid blue; border-top: 25px solid green; }


border-left-color版本：CSS2　 兼容性：IE4+ NS6　继承性：无

语法：

border-left-color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-width等于0或border-style设置为none，本属性将失去作用。
对应的脚本特性为borderLeftColor。请参阅我编写的其他书目。

示例：

div { border-top-color: red; border-bottom-color: RGB(223, 94, 77); border-right-color: red; border-left-color: black;}


border-left-style版本：CSS2　 兼容性：IE4+ NS6+　继承性：无

语法：

border-left-style : none | hidden | dotted | dashed | solid | double | groove | ridge | inset | outset

参数：

none : 　无边框。与任何指定的border-width值无关
hidden : 　隐藏边框。IE不支持
dotted : 　在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为点线。否则为实线
dashed : 　在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为虚线。否则为实线
solid : 　实线边框
double : 　双线边框。两条单线与其间隔的和等于指定的border-width值
groove : 　根据border-color的值画3D凹槽
ridge : 　根据border-color的值画菱形边框
inset : 　根据border-color的值画3D凹边
outset : 　根据border-color的值画3D凸边

说明：

要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-width不大于0，本属性将失去作用。
对应的脚本特性为borderLeftStyle。请参阅我编写的其他书目。

示例：

body { border-top-style: double; border-bottom-style: groove; border-left-style: dashed; border-right-style: dotted; }


border-left-width版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

border-left-width : medium | thin | thick | length

参数：

medium : 　默认宽度
thin : 　小于默认宽度
thick : 　大于默认宽度
length : 　由浮点数字和单位标识符组成的长度值。不可为负值。请参阅长度单位

说明：

要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
如果border-style设置为none，本属性将失去作用。
对应的脚本特性为borderLeftWidth。请参阅我编写的其他书目。

示例：

span { border-top-width: thin; border-top-style: solid; }
span { border-bottom-width: thin; border-bottom-style: solid; }
span { border-left-width: thin; border-left-style: solid; }
span { border-right-width: thin; border-right-style: solid; }


CSS Generated Content Properties 内容属性

Content Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
include-source | CSS2 | NONE | 无 | 这个属性插入另一个文档到当前文档，取代当前对象的内容
quotes | CSS2 | NONE | 无 | 设置或检索对象内使用的嵌套标记
content | CSS2 | NONE | 无 | 用来和:after及:before 伪元素一起使用，在对象前或后显示内容
counter-increment | CSS2 | NONE | 无 | 设定当一个selector发生时计数器增加的值
counter-reset | CSS2 | NONE | 无 | 将指定selector的计数器复位

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


include-source版本：CSS2　 兼容性：NONE　继承性：无

语法：

include-source : url (url)

参数：

url : 　使用绝对或相对地址指定插入文档。假如该文档不存在，当前对象的内容将被显示

说明：

这个属性插入另一个文档到当前文档，取代当前对象的内容。插入文档的样式属性从当前对象继承。
目前IE5.5尚不支持此属性。
对应的脚本特性为includeSource。请参阅我编写的其他书目。

示例：

div { position: absolute; top: 100px; left: 300px; width: 200px; height: 200px; border: thin solid black; include-source: url("http://www.example.com/testpage.htm"); }


quotes版本：CSS2　 兼容性：NONE　继承性：无

语法：

quotes : none | string

参数：

none : 　content属性的open-quote和close-quote值将不会生成任何嵌套标记
string : 　用引号括起的嵌套标记定义。两个为一组。第一个string定义前标记（例："<"），第二个string定义后标记（例：">"）。组之间用空格格开。嵌套标记的应用深度按定义顺序内推

说明：

设置或检索对象内使用的嵌套标记。
目前IE5.5尚不支持此属性。
对应的脚本特性为quotes。请参阅我编写的其他书目。

示例：

blockquote[lang-=fr] { quotes: "\201C" "\201D" }
blockquote[lang-=en] { quotes: "\00AB" "\00BB" }
blockquote:before { content: open-quote }
blockquote:after { content: close-quote }

q { quotes: """ """ "'" "'"; }

<q>This is an <q>emedded</q> quote.</q>

显示结果如下：

"This is an 'embedded' quote."


content版本：CSS2　 兼容性：NONE　继承性：无

语法：

content : attr(alt) | counter(name) | counter(name, list-style-type) | counters(name, string) | counters(name, string, list-style-type) | no-close-quote | no-open-quote | close-quote | open-quote | string | url (url)

参数：

attr(alt) : 　使用alt特性的文字
counter(name) : 　使用已命名的计数器
counter(name, list-style-type) : 　使用已命名的计数器并遵从指定的list-style-type属性
counters(name, string) : 　使用所有已命名的计数器
counters(name, string, list-style-type) : 　使用所有已命名的计数器并遵从指定的list-style-type属性
no-close-quote : 　并不插入quotes属性的后标记。但增加其嵌套级别
no-open-quote : 　并不插入quotes属性的前标记。但减少其嵌套级别
close-quote : 　插入quotes属性的后标记
open-quote : 　插入quotes属性的前标记
string : 　使用用引号括起的字符串
url : 　使用指定的绝对或相对地址

说明：

用来和:after及:before 伪元素一起使用，在对象前或后显示内容。
目前IE5.5尚不支持此属性。
对应的脚本特性为content。请参阅我编写的其他书目。

示例：

p:after { content: url("http:www.devguru.com"); text-decoration: none; }
p:before { content: url("beep.wav") }


counter-increment版本：CSS2　 兼容性：NONE　继承性：无

语法：

counter-increment : none | identifier number

参数：

none : 　阻止计数器增加
identifier number : 　identifier定义一个将被增加selector，id，或者class。number定义增加的数值。可以为负值。默认值是1

说明：

设定当一个selector发生时计数器增加的值。
目前IE5.5尚不支持此属性。
对应的脚本特性为counterIncrement。请参阅我编写的其他书目。

示例：

p:before { content: "paragraph" counter(paragraph); counter-increment: paragraph; }


counter-reset版本：CSS2　 兼容性：NONE　继承性：无

语法：

counter-reset : none | identifier number

参数：

none : 　阻止计数器复位
identifier number : 　指定一个或多个复位的计数器

说明：

将指定selector的计数器复位。默认值是0。
目前IE5.5尚不支持此属性。
对应的脚本特性为counterReset。请参阅我编写的其他书目。

示例：

h1:before { counter-increment: main-heading; counter-reset: sub-heading; content: "Section " counter(main-heading) ":" }


CSS Paddings Properties 内补丁属性

Paddings Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
padding | CSS1 | IE4+ , NS4+ | 无 | 检索或设置对象四边的补丁边距
padding-top | CSS1 | IE4+ , NS4+ | 无 | 检索或设置对象顶边的补丁边距
padding-right | CSS1 | IE4+ , NS4+ | 无 | 检索或设置对象右边的补丁边距
padding-bottom | CSS1 | IE4+ , NS4+ | 无 | 检索或设置对象底边的补丁边距
padding-left | CSS1 | IE4+ , NS4+ | 无 | 检索或设置对象左边的补丁边距

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


padding版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

padding : length

参数：

length : 　由浮点数字和单位标识符组成的长度值 | 或者百分数。百分数是基于父对象的宽度。请参阅长度单位

说明：

检索或设置对象四边的补丁边距。
如果提供全部四个参数值，将按上－右－下－左的顺序作用于四边。
如果只提供一个，将用于全部的四条边。
如果提供两个，第一个用于上－下，第二个用于左－右。
如果提供三个，第一个用于上，第二个用于左－右，第三个用于下。
内联对象要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
不允许负值。
对应的脚本特性为padding。请参阅我编写的其他书目。
关于对象的尺寸与边框，内外补丁等样式表属性的关系，请参看图例以及height和width属性。

示例：

body { padding: 36pt 24pt 36pt; }
body { padding: 11.5%; }
body { padding: 10% 10% 10% 10%; }


padding-top版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

padding-top : length

参数：

length : 　由浮点数字和单位标识符组成的长度值 | 或者百分数。百分数是基于父对象的宽度。请参阅长度单位

说明：

检索或设置对象顶边的补丁边距。
内联对象要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
不允许负值。
对应的脚本特性为paddingTop。请参阅我编写的其他书目。

示例：

body { padding-top: 36pt; }

请您用下面的按钮加减这段文字的padding-top属性的值（单位是px）。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


padding-right版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

padding-right : length

参数：

length : 　由浮点数字和单位标识符组成的长度值 | 或者百分数。百分数是基于父对象的宽度。请参阅长度单位

说明：

检索或设置对象右边的补丁边距。
内联对象要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
不允许负值。
对应的脚本特性为paddingRight。请参阅我编写的其他书目。

示例：

body { padding-right: 36pt; }

请您用下面的按钮加减这段文字的padding-right属性的值（单位是px）。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


padding-bottom版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

padding-bottom : length

参数：

length : 　由浮点数字和单位标识符组成的长度值 | 或者百分数。百分数是基于父对象的宽度。请参阅长度单位

说明：

检索或设置对象底边的补丁边距。
内联对象要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
不允许负值。
对应的脚本特性为paddingBottom。请参阅我编写的其他书目。

示例：

body { padding-bottom: 36pt; }

请您用下面的按钮加减这段文字的padding-bottom属性的值（单位是px）。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


padding-left版本：CSS1　 兼容性：IE4+ NS4+　继承性：无

语法：

padding-left : length

参数：

length : 　由浮点数字和单位标识符组成的长度值 | 或者百分数。百分数是基于父对象的宽度。请参阅长度单位

说明：

检索或设置对象左边的补丁边距。
内联对象要使用该属性，必须先设定对象的height或width属性，或者设定position属性为absolute。
不允许负值。
对应的脚本特性为paddingLeft。请参阅我编写的其他书目。

示例：

body { padding-left: 36pt; }

请您用下面的按钮加减这段文字的padding-left属性的值（单位是px）。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


CSS Lists Properties 列表项目属性

Lists Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
list-style | CSS1 | IE4+ , NS4+ | 有 | 复合属性。设置列表项目相关内容
list-style-image | CSS1 | IE4+ , NS6+ | 有 | 设置或检索作为对象的列表项标记的图像
list-style-position | CSS1 | IE4+ , NS6+ | 有 | 设置或检索作为对象的列表项标记如何根据文本排列
list-style-type | CSS1/CSS2 | IE4+ , NS4+ | 有 | 设置或检索对象的列表项所使用的预设标记
marker-offset | CSS2 | NONE | 无 | 设置或检索标记容器和主容器之间水平补白。即两个容器靠近的一边的间距

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


list-style版本：CSS1　 兼容性：IE4+ NS4+　继承性：有

语法：

list-style : list-style-image || list-style-position || list-style-type

参数：

该属性是复合属性。请参阅各参数对应的属性。

说明：

设置列表项目相关内容。
对应的脚本特性为listStyle。请参阅我编写的其他书目。

示例：

li { list-style: url("http://www.dhtmlet.com/devgurupix.gif"), inside, circle; }
ul { list-style: outside, upper-roman; }
ol { list-style: square; }


list-style-image版本：CSS1　 兼容性：IE4+ NS6+　继承性：有

语法：

list-style-image : none | url (url)

参数：

none : 　不指定图像
url : 　使用绝对或相对地址指定背景图像

说明：

设置或检索作为对象的列表项标记的图像。
若list-style-image属性为none或指定图像不可用时，list-style-type属性将发生作用。
对应的脚本特性为listStyleImage。请参阅我编写的其他书目。

示例：

ul.out { list-style-position: outside; list-style-image: url("images/ie.gif"); }


list-style-position版本：CSS1　 兼容性：IE4+ NS6+　继承性：有

语法：

list-style-position : outside | inside

参数：

outside : 　列表项目标记放置在文本以外，且环绕文本不根据标记对齐
inside : 　列表项目标记放置在文本以内，且环绕文本根据标记对齐

说明：

设置或检索作为对象的列表项标记如何根据文本排列。
仅作用于具有display值等于list-item的对象（如li对象）。
注意：ol对象和ul对象的type特性为其后的所有列表项目（如li对象）指明列表属性。请参阅我的其他著作。
对应的脚本特性为listStylePosition。请参阅我编写的其他书目。

示例：

ul.in { display: list-item; list-style-position: inside; }

  • 这是一个名字叫小强的列表项目。他难道不是很可爱吗？
  • 这是一个名字叫小强的列表项目。他难道不是很可爱吗？
  • 这是一个名字叫小强的列表项目。他难道不是很可爱吗？


list-style-type版本：CSS1/CSS2　 兼容性：IE4+ NS4+　继承性：有

语法：

list-style-type : disc | circle | square | decimal | lower-roman | upper-roman | lower-alpha | upper-alpha | none | armenian | cjk-ideographic | georgian | lower-greek | hebrew | hiragana | hiragana-iroha | katakana | katakana-iroha | lower-latin | upper-latin

参数：

disc : 　CSS1　实心圆
circle : 　CSS1　空心圆
square : 　CSS1　实心方块
decimal : 　CSS1　阿拉伯数字
lower-roman : 　CSS1　小写罗马数字
upper-roman : 　CSS1　大写罗马数字
lower-alpha : 　CSS1　小写英文字母
upper-alpha : 　CSS1　大写英文字母
none : 　CSS1　不使用项目符号
armenian : 　CSS2　传统的亚美尼亚数字
cjk-ideographic : 　CSS2　浅白的表意数字
georgian : 　CSS2　传统的乔治数字
lower-greek : 　CSS2　基本的希腊小写字母
hebrew : 　CSS2　传统的希伯莱数字
hiragana : 　CSS2　日文平假名字符
hiragana-iroha : 　CSS2　日文平假名序号
katakana : 　CSS2　日文片假名字符
katakana-iroha : 　CSS2　日文片假名序号
lower-latin : 　CSS2　小写拉丁字母
upper-latin : 　CSS2　大写拉丁字母

说明：

设置或检索对象的列表项所使用的预设标记。
若list-style-image属性为none或指定图像不可用时，list-style-type属性将发生作用。
仅作用于具有display值等于list-item的对象（如li对象）。
注意：ol对象和ul对象的type特性为其后的所有列表项目（如li对象）指明列表属性。请参阅我的其他著作。
IE5.5尚不支持所有CSS2的值。
对应的脚本特性为listStyleType。请参阅我编写的其他书目。

示例：

li { list-style-type: square }

  • 这是一个名字叫小强的列表项目。他难道不是很可爱吗？
  • 这是一个名字叫小强的列表项目。他难道不是很可爱吗？
  • 这是一个名字叫小强的列表项目。他难道不是很可爱吗？


marker-offset版本：CSS2　 兼容性：NONE　继承性：无

语法：

marker-offset : auto | length

参数：

auto : 　浏览器自动设置间距
length : 　由浮点数字和单位标识符组成的长度值。可为负值。请参阅长度单位

说明：

设置或检索标记容器和主容器之间水平补白。即两个容器靠近的一边的间距。
目前IE5.5尚不支持此属性。
对应的脚本特性为markerOffset。请参阅我编写的其他书目。

示例：

li:before { display: marker; marker-offset: 5px; }


CSS Table Properties 表格属性

Table Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
border-collapse | CSS2 | IE5+ | 有 | 设置或检索表格的行和单元格的边是合并在一起还是按照标准的HTML样式分开
border-spacing | CSS2 | NONE | 有 | 设置或检索当表格边框独立时，行和单元格的边框在横向和纵向上的间距
caption-side | CSS2 | NONE | 有 | 设置或检索表格的caption对象是在表格的那一边
empty-cells | CSS2 | NONE | 有 | 设置或检索当表格的单元格无内容时，是否显示该单元格的边框
table-layout | CSS2 | IE5+ | 有 | 设置或检索表格的布局算法
speak-header | CSS2 | NONE | 有 | 设置或检索表格头与其后的一系列单元格发生多少次关系

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


border-collapse版本：CSS2　 兼容性：IE5+　继承性：有

语法：

border-collapse : separate | collapse

参数：

separate : 　边框独立（标准HTML）
rtl : 　相邻边被合并

说明：

设置或检索表格的行和单元格的边是合并在一起还是按照标准的HTML样式分开。
对应的脚本特性为borderCollapse。请参阅我编写的其他书目。

示例：

table { border-collapse: separate; }

请您用下面的按钮选择这段文字 | 的direction和unicode-bidi属性的值。看一看
会发生什么，然后您就会明白他们 | 的意义。


border-spacing版本：CSS2　 兼容性：NONE　继承性：有

语法：

border-spacing : length || length

参数：

length : 　由浮点数字和单位标识符组成的长度值。不可为负值。请参阅长度单位

说明：

设置或检索当表格边框独立（例如当border-collapse属性等于separate时），行和单元格的边框在横向和纵向上的间距。
当只指定一个length值时，这个值将作用于横向和纵向上的间距。当指定了全部两个length值时，第一个作用于横向间距，第二个作用于纵向间距。
目前IE5.5尚不支持此属性。
对应的脚本特性为borderSpacing。请参阅我编写的其他书目。

示例：

table { border-collapse: separate; border-spacing: 10px; }


caption-side版本：CSS2　 兼容性：NONE　继承性：有

语法：

caption-side : bottom | left |right | top

参数：

bottom : 　下面
left : 　左边
right : 　右边
top : 　下面

说明：

设置或检索表格的caption对象是在表格的那一边。它是和caption对象一起使用的属性。
目前IE5.5尚不支持此属性。
对应的脚本特性为captionSide。请参阅我编写的其他书目。

示例：

table caption { caption-side: top; width: auto; text-align: left; }


empty-cells版本：CSS2　 兼容性：NONE　继承性：有

语法：

empty-cells : hide | show

参数：

hide : 　隐藏
show : 　显示

说明：

设置或检索当表格的单元格无内容时，是否显示该单元格的边框。
只有当表格边框独立（例如当border-collapse属性等于separate时）此属性才起作用。
目前IE5.5尚不支持此属性。
对应的脚本特性为emptyCells。请参阅我编写的其他书目。

示例：

table { caption-side: top; width: auto; border-collapse: separate; empty-cells: hide; }


table-layout版本：CSS2　 兼容性：IE5+　继承性：有

语法：

table-layout : auto | fixed

参数：

auto : 　默认的自动算法。布局将基于各单元格的内容。表格在每一单元格读取计算之后才会显示出来。速度很慢
fixed : 　固定布局的算法。在这算法中，水平布局是仅仅基于表格的宽度，表格边框的宽度，单元格间距，列的宽度，而和表格内容无关。也就是说，内容可能被裁切

说明：

设置或检索表格的布局算法。
对应的脚本特性为tableLayout。请参阅我编写的其他书目。

示例：

table { table-layout: auto; }


speak-header版本：CSS2　 兼容性：NONE　继承性：有

语法：

speak-header : once | always

参数：

once : 　所有的单元格只有一个表格头
fixed : 　每一组单元格对应一个表头

说明：

设置或检索表格头与其后的一系列单元格发生多少次关系。
目前IE5.5尚不支持此属性。
对应的脚本特性为speakHeader。请参阅我编写的其他书目。

示例：

table { speak-header: once }


CSS Scrollbar Properties 滚动条属性

Scrollbar Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
scrollbar-3dlight-color | IE专有属性 | IE5.5+ | 有 | 设置或检索滚动条亮边框颜色
scrollbar-highlight-color | IE专有属性 | IE5.5+ | 有 | 设置或检索滚动条3D界面的亮边（ThreedHighlight）颜色
scrollbar-face-color | IE专有属性 | IE5.5+ | 有 | 设置或检索滚动条3D表面（ThreedFace）的颜色
scrollbar-arrow-color | IE专有属性 | IE5.5+ | 有 | 设置或检索滚动条方向箭头的颜色
scrollbar-shadow-color | IE专有属性 | IE5.5+ | 有 | 设置或检索滚动条3D界面的暗边（ThreedShadow）颜色
scrollbar-darkshadow-color | IE专有属性 | IE5.5+ | 有 | 设置或检索滚动条暗边框（ThreedDarkShadow）颜色
scrollbar-base-color | IE专有属性 | IE5.5+ | 有 | 设置或检索滚动条基准颜色。其它界面颜色将据此自动调整
scrollbar-track-color | IE专有属性 | IE5.5+ | 有 | 设置或检索滚动条的拖动区域（TrackBar）颜色

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


scrollbar-3dlight-color版本：IE5.5+专有属性　继承性：有

语法：

scrollbar-3dlight-color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

设置或检索滚动条亮边框颜色。
请参阅overflow属性 。
对应的脚本特性为scrollbar3dLightColor。请参阅我编写的其他书目。

示例：

div {scrollbar-3dlight-color :threedhighlight; }

请您用下面的按钮选择这段文字的scrollbar-3dlight-color属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


scrollbar-highlight-color版本：IE5.5+专有属性　继承性：有

语法：

scrollbar-highlight-color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

设置或检索滚动条3D界面的亮边（ThreedHighlight）颜色。
请参阅overflow属性 。
对应的脚本特性为scrollbarHighlightColor。请参阅我编写的其他书目。

示例：

div {scrollbar-highlight-color :threedhighlight; }

请您用下面的按钮选择这段文字的scrollbar-highlight-color属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


scrollbar-face-color版本：IE5.5+专有属性　继承性：有

语法：

scrollbar-face-color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

设置或检索滚动条3D表面（ThreedFace）的颜色。
请参阅overflow属性 。
对应的脚本特性为scrollbarFaceColor。请参阅我编写的其他书目。

示例：

div {scrollbar-face-color : threedface; }

请您用下面的按钮选择这段文字的scrollbar-face-color属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


scrollbar-arrow-color版本：IE5.5+专有属性　继承性：有

语法：

scrollbar-arrow-color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

设置或检索滚动条方向箭头的颜色。当滚动条出现但不可用时，此属性失效。
请参阅overflow属性 。
对应的脚本特性为scrollbarArrowColor。请参阅我编写的其他书目。

示例：

div {scrollbar-arrow-color : buttontext; }

请您用下面的按钮选择这段文字的scrollbar-arrow-color属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


scrollbar-shadow-color版本：IE5.5+专有属性　继承性：有

语法：

scrollbar-shadow-color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

设置或检索滚动条3D界面的暗边（ThreedShadow）颜色。
请参阅overflow属性 。
对应的脚本特性为scrollbarShadowColor。请参阅我编写的其他书目。

示例：

div {scrollbar-shadow-color :ThreedDarkShadow; }

请您用下面的按钮选择这段文字的scrollbar-shadow-color属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


scrollbar-darkshadow-color 版本：IE5.5+专有属性　继承性：有

语法：

scrollbar-darkshadow-color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

设置或检索滚动条暗边框（ThreedDarkShadow）颜色。
请参阅overflow属性 。
对应的脚本特性为scrollbarDarkShadowColor。请参阅我编写的其他书目。

示例：

div {scrollbar-darkshadow-color :threeddarkshadow; }

请您用下面的按钮选择这段文字的scrollbar-darkshadow-color属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


scrollbar-base-color版本：IE5.5+专有属性　继承性：有

语法：

scrollbar-base-color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

设置或检索滚动条基准颜色。其它界面颜色将据此自动调整。
请参阅overflow属性 。
对应的脚本特性为scrollbarBaseColor。请参阅我编写的其他书目。

示例：

div {scrollbar-base-color : buttonface; }

请您用下面的按钮选择这段文字的scrollbar-base-color属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


scrollbar-track-color版本：IE5.5+专有属性　继承性：有

语法：

scrollbar-track-color : color

参数：

color : 　指定颜色。请参阅颜色单位和附录：颜色表

说明：

设置或检索滚动条的拖动区域（TrackBar）颜色。
请参阅overflow属性 。
对应的脚本特性为scrollbarTrackColor。请参阅我编写的其他书目。

示例：

div {scrollbar-track-color :ThreedDarkShadow; }

请您用下面的按钮选择这段文字的scrollbar-track-color属性的值。看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


CSS Printing Properties 打印属性

Printing Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
page | CSS2 | IE5.5+ | 有 | 检索或指定显示对象容器时使用的页面类型（pagetype）。参阅@page规则
page-break-after | CSS2 | IE4+ | 无 | 检索或设置对象后出现的页分割符
page-break-before | CSS2 | IE4+ | 无 | 检索或设置对象前出现的页分割符
page-break-inside | CSS2 | NONE | 有 | 检索或设置对象容器中出现的页分割符
marks | CSS2 | NONE | 无 | 设置或检索什么样的标志是应该在页容器外边被给予
orphans | CSS2 | NONE | 有 | 设置或检索对象内容内一定要留在一页范围底端以内的行的最少数量
size | CSS2 | NONE | 有 | 检索或指定页面规格的调整
widows | CSS2 | NONE | 有 | 检索或指定一定要留在页面顶部的行数

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


page版本：CSS2　 兼容性：IE5.5+　继承性：有

语法：

page : auto | pagetype

参数：

auto : 　参照当前的默认页面
pagetype : 　指定@page规则里的一个页面类型（pagetype）定义

说明：

检索或指定显示对象容器时使用的页面类型（pagetype）。参阅@page规则。
对应的脚本特性为page。请参阅我编写的其他书目。

示例：

@page doublepage { size: 8.5in 11in; page-break-after: left }
body { page: doublepage; page-break-after: right }


page-break-after版本：CSS2　 兼容性：IE4+　继承性：无

语法：

page-break-after : auto | always | avoid | left | right | null

参数：

auto : 　假如需要在对象之后插入页分割符
always : 　始终在对象之后插入页分割符
avoid : 　避免在对象后面插入页分割符
left : 　在对象后面插入页分割符直到它到达一个空白的左页边
right : 　在对象后面插入页分割符直到它到达一个空白的右页边
null : 　空值。IE5用来取消页分割符设置

说明：

检索或设置对象后出现的页分割符。
IE5仅支持always值和空白值（null）。
在IE4中此属性不作用于br对象，但是IE5作用。
对应的脚本特性为pageBreakAfter。请参阅我编写的其他书目。

示例：

p { page-break-after: always;}


page-break-before版本：CSS2　 兼容性：IE4+　继承性：无

语法：

page-break-before : auto | always | avoid | left | right | null

参数：

auto : 　假如需要在对象之前插入页分割符
always : 　始终在对象之前插入页分割符
avoid : 　避免在对象前面插入页分割符
left : 　在对象前面插入页分割符直到它到达一个空白的左页边
right : 　在对象前面插入页分割符直到它到达一个空白的右页边
null : 　空值。IE5用来取消页分割符设置

说明：

检索或设置对象前出现的页分割符。
IE5仅支持always值和空白值（null）。
在IE4中此属性不作用于br对象，但是IE5作用。
对应的脚本特性为pageBreakBefore。请参阅我编写的其他书目。

示例：

p { page-break-after: always;}


page-break-inside版本：CSS2　 兼容性：NONE　继承性：有

语法：

page-break-inside : auto | avoid

参数：

auto : 　假如需要在对象容器中插入页分割符
avoid : 　使当前对象容器中禁止插入页分割符

说明：

检索或设置对象容器中出现的页分割符。
目前IE5.5尚不支持此属性。
对应的脚本特性为pageBreakInside。请参阅我编写的其他书目。

示例：

p { page-break-inside: auto }


marks版本：CSS2　 兼容性：NONE　继承性：无

语法：

marks : none | crop || cross

参数：

none : 　无页标记出现
crop : 　在页面将会被裁切处指定切割标记
cross : 　指定交叉线标记用来供页面对齐

说明：

印刷业的印刷文档通常在页面内容区域外带有一些标记，用来校正和调整所有的页面。此属性用来设置或检索什么样的标志是应该在页容器外边被给予。
目前IE5.5尚不支持此属性。
对应的脚本特性为marks。请参阅我编写的其他书目。

示例：

body { marks: crop cross }


orphans版本：CSS2　 兼容性：NONE　继承性：有

语法：

orphans : number

参数：

number : 　整数

说明：

设置或检索对象内容内一定要留在一页范围底端以内的行的最少数量。
目前IE5.5尚不支持此属性。
对应的脚本特性为orphans。请参阅我编写的其他书目。

示例：

p { orphans: 4; }


size版本：CSS2　 兼容性：NONE　继承性：无

语法：

size : auto | portrait | landscape | length

参数：

auto : 　指定为适应目标纸张尺寸和方向的relative页面容器
portrait : 　指定为适应目标纸张尺寸和方向的relative页面容器，不理会目标页的当前缺省的内容方向，使用文档流从左到右短距离跨越，向下长距离跨越的典型范例（纵向方式）
landscape : 　指定为适应目标纸张尺寸和方向的relative页面容器，不理会目标页的当前缺省的内容方向，使用横向方式
length : 　由浮点数字和单位标识符组成的长度值。指定为固定尺寸和方向的absolute页面容器。只有一个参数，则指定高度和宽度。用空格分开的两个，第一个指定高度，第二个指定宽度。请参阅长度单位

说明：

检索或指定页面规格的调整。它把页面容器归类为absolute和relative两种。absolute页面有固定的尺寸。relative页面容器将会调整适应目标纸张的尺寸。
目前IE5.5尚不支持此属性。
对应的脚本特性为size。请参阅我编写的其他书目。

示例：

body { size: 8.5in 11in }


widows版本：CSS2　 兼容性：NONE　继承性：有

语法：

widows : number

参数：

number : 　无单位整数。不可为负值

说明：

检索或指定一定要留在页面顶部的行数。
目前IE5.5尚不支持此属性。
对应的脚本特性为widows。请参阅我编写的其他书目。

示例：

p { widows: 1 }


CSS Aural Properties 声音属性

Aural Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
voice-family | CSS2 | NONE | 有 | 设置或检索当前声音类型
volume | CSS2 | NONE | 有 | 设置或检索音量
elevation | CSS2 | NONE | 有 | 设置或检索当前声音的音源仰角
azimuth | CSS2 | NONE | 有 | 设置或检索当前声音的音场角度
stress | CSS2 | NONE | 有 | 和pitch-range相似。设置或检索当前声音波形的最高峰值
richness | CSS2 | NONE | 有 | 设置或检索当前声音的音色
speech-rate | CSS2 | NONE | 有 | 设置或检索发音速度
cue | CSS2 | NONE | 无 | 设置在对象前后播放的声音
cue-after | CSS2 | NONE | 无 | 设置在对象后播放的声音
cue-before | CSS2 | NONE | 无 | 设置在对象前播放的声音
pause | CSS2 | NONE | 无 | 设置对象前后的声音暂停
pause-after | CSS2 | NONE | 无 | 定义对象内容被发音后的暂停
pause-before | CSS2 | NONE | 无 | 定义对象内容发音前的暂停
pitch | CSS2 | NONE | 有 | 设置或检索音高
pitch-range | CSS2 | NONE | 有 | 设置或检索声音的平滑程度
play-during | CSS2 | NONE | 无 | 设置或检索背景音乐的播放
speak | CSS2 | NONE | 有 | 设置或检索声音是否给出
speak-numeral | CSS2 | NONE | 有 | 设置或检索数字如何发音
speak-punctuation | CSS2 | NONE | 有 | 设置或检索标点符号如何发音

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


voice-family版本：CSS2　 兼容性：NONE　继承性：有

语法：

voice-family : child | female | male || name

参数：

child : 　童声
female : 　女声
male : 　男声
name : 　声音名称。按优先顺序排列。以逗号隔开。如果声音名称包含空格，则应使用引号括起

说明：

设置或检索当前声音类型。
目前IE5.5尚不支持此属性。
对应的脚本特性为voiceFamily。请参阅我编写的其他书目。

示例：

strong { voice-family: "Bob Barker", "Monty Hall", male }


volume版本：CSS2　 兼容性：NONE　继承性：有

语法：

volume : silent | x-soft | soft | medium | loud | x-loud | number

参数：

silent : 　不同于speak的none值，当前声音仍将占用时间，但是没有声音发出
x-soft : 　相当于number的值为0
soft : 　相当于number的值为25
medium : 　相当于number的值为50
loud : 　相当于number的值为75
x-loud : 　相当于number的值为100
number : 　整数 | 百分数。整数值取值范围为0-100。百分数值是相对于此属性继承而的值

说明：

设置或检索音量。
目前IE5.5尚不支持此属性。
对应的脚本特性为volume。请参阅我编写的其他书目。

示例：

body { volume: soft }


elevation版本：CSS2　 兼容性：NONE　继承性：有

语法：

elevation : below | level | above | lower | higher | angle

参数：

below : 　-90deg
level : 　0deg
above : 　90deg
lower : 　相对于继承值或绝对参考角度减（逆时针）10deg
higher : 　相对于继承值或绝对参考角度加（顺时针）10deg
angle : 　角度值。整数值取值范围为-90deg到90deg。单位为deg。请参阅角度单位

说明：

设置或检索当前声音的音源仰角。
目前IE5.5尚不支持此属性。
对应的脚本特性为elevation。请参阅我编写的其他书目。

示例：

body { elevation: 75deg }


azimuth版本：CSS2　 兼容性：NONE　继承性：有

语法：

azimuth : left-side | far-left | left | center-left | center | center-right | right |far-right | right-side | leftwards | rightwards | angle

参数：

left-side : 　270deg | 90deg
far-left : 　300deg | -60deg
left : 　320deg | -40deg
center-left : 　340deg | -20deg
center : 　0deg
center-right : 　20deg | -340deg
right : 　40deg | -320deg
far-right : 　60deg | -300deg
right-side 　90deg | -270deg
leftwards : 　相对于继承值或绝对参考角度减（逆时针）20deg
rightwards : 　相对于继承值或绝对参考角度加（顺时针）20deg
angle : 　角度值。整数值取值范围为-360deg到360deg。单位为deg。请参阅角度单位

说明：

设置或检索当前声音的音场角度。
目前IE5.5尚不支持此属性。
对应的脚本特性为azimuth。请参阅我编写的其他书目。

示例：

body { azimuth: 75deg }


stress版本：CSS2　 兼容性：NONE　继承性：有

语法：

stress : number

参数：

number : 　整数。整数值取值范围为0-100。默认值为50

说明：

和pitch-range相似。设置或检索当前声音波形的最高峰值。
目前IE5.5尚不支持此属性。
对应的脚本特性为stress。请参阅我编写的其他书目。

示例：

body { stress: 75 }


richness版本：CSS2　 兼容性：NONE　继承性：有

语法：

richness : number

参数：

number : 　整数。整数值取值范围为0-100。默认值为50

说明：

设置或检索当前声音的音色。
目前IE5.5尚不支持此属性。
对应的脚本特性为richness。请参阅我编写的其他书目。

示例：

body { richness: 75 }


speech-rate版本：CSS2　 兼容性：NONE　继承性：有

语法：

speech-rate : x-slow | slow | medium | fast | x-fast | slower | faster | number

参数：

x-slow : 　80字/分钟
slow : 　120字/分钟
medium : 　180-200字/分钟
fast : 　300字/分钟
x-fast : 　500字/分钟
slower : 　根据当前的速度每分钟减少40个字
faster : 　根据当前的速度每分钟增加40个字
number : 　整数。指定每分钟发音字数

说明：

设置或检索发音速度。
目前IE5.5尚不支持此属性。
对应的脚本特性为speechRate。请参阅我编写的其他书目。

示例：

strong { speech-rate: fast }


cue版本：CSS2　 兼容性：NONE　继承性：无

语法：

cue : cue-before || cue-after

参数：

该属性是复合属性。请参阅各参数对应的属性。

说明：

设置在对象前后播放的声音。
假如只给出了一个值，它将用于cue-before属性和cue-after属性。假如给出了两个值，则第一个用于cue-before属性，第二个用于cue-after属性。
目前IE5.5尚不支持此属性。
对应的脚本特性为cue。请参阅我编写的其他书目。

示例：

div { cue: url(orchestralsneeze.wav) none }
div { cue: url(orchestralsneeze.wav) ; }


cue-after版本：CSS2　 兼容性：NONE　继承性：无

语法：

cue-after : none | url (url)

参数：

none : 　无声音播放
url : 　使用绝对或相对地址指定音乐文件

说明：

设置在对象后播放的声音。
目前IE5.5尚不支持此属性。
对应的脚本特性为cueAfter。请参阅我编写的其他书目。

示例：

div { cue-after: url(orchestralsneeze.wav) ; }


cue-before版本：CSS2　 兼容性：NONE　继承性：无

语法：

cue-before : none | url (url)

参数：

none : 　无声音播放
url : 　使用绝对或相对地址指定音乐文件

说明：

设置在对象前播放的声音。
目前IE5.5尚不支持此属性。
对应的脚本特性为cueBefore。请参阅我编写的其他书目。

示例：

div { cue-before: url(orchestralsneeze.wav) ; }


pause版本：CSS2　 兼容性：NONE　继承性：无

语法：

pause : pause-before || pause-after

参数：

该属性是复合属性。请参阅各参数对应的属性。

说明：

设置对象前后的声音暂停。
假如只给出了一个值，它将用于pause-before属性和pause-after属性。假如给出了两个值，则第一个用于pause-before属性，第二个用于pause-after属性。
目前IE5.5尚不支持此属性。
对应的脚本特性为pause。请参阅我编写的其他书目。

示例：

div { pause: 2s 3s }
div { pause: 2s; }


pause-after版本：CSS2　 兼容性：NONE　继承性：无

语法：

pause-after : time

参数：

time : 　由浮点数字与时间单位组成的时间值|百分数。百分数值是相对于speech-rate属性的值。对于值为60字/分钟的speech-rate属性来说，值为100%的pause-after属性即相当于暂停1秒。请参阅时间单位

说明：

定义对象内容被发音后的暂停。
目前IE5.5尚不支持此属性。
对应的脚本特性为pauseAfter。请参阅我编写的其他书目。

示例：

div { pause-after: 2s; }


pause-before版本：CSS2　 兼容性：NONE　继承性：无

语法：

pause-before : time

参数：

time : 　由浮点数字与时间单位组成的时间值|百分数。百分数值是相对于speech-rate属性的值。对于值为60字/分钟的speech-rate属性来说，值为100%的pause-before属性即相当于暂停1秒。请参阅时间单位

说明：

定义对象内容发音前的暂停。
目前IE5.5尚不支持此属性。
对应的脚本特性为pauseBefore。请参阅我编写的其他书目。

示例：

div { pause-before: 2s; }


pitch版本：CSS2　 兼容性：NONE　继承性：有

语法：

pitch : x-low | low | medium | high | x-high | number

参数：

number 数字。指定赫兹（HZ）值。其他参数取决于voice-family属性指定的声音种类。请参阅频率单位

说明：

设置或检索音高。
目前IE5.5尚不支持此属性。
对应的脚本特性为pitch。请参阅我编写的其他书目。

示例：

strong { pitch: x-high }
strong { pitch: 75hz }


pitch-range版本：CSS2　 兼容性：NONE　继承性：有

语法：

pitch-range : number

参数：

number 数字。取值范围为0-100。默认值为50，表示普通发音。小于50趋向于平缓，大于50趋向于颤抖。

说明：

设置或检索声音的平滑程度。
目前IE5.5尚不支持此属性。
对应的脚本特性为pitchRange。请参阅我编写的其他书目。

示例：

strong { pitch-range: 80 }


play-during版本：CSS2　 兼容性：NONE　继承性：无

语法：

play-during : url (url) |mix | repeat | auto | none

参数：

mix : 　在播放对象的背景音乐的同时并不停止父对象的背景音乐
repeat : 　循环播放对象的背景音乐
auto : 　仅仅再一次执行父对象的play-during属性值
none : 　无背景音乐。甚至取消父对象的play-during属性值的作用
url : 　使用绝对或相对地址指定背景音乐

说明：

设置或检索背景音乐的播放。
目前IE5.5尚不支持此属性。
对应的脚本特性为playDuring。请参阅我编写的其他书目。

示例：

q { play-during: url(accordian.wav) mix }


speak版本：CSS2　 兼容性：NONE　继承性：有

语法：

speak : normal | none | spell-out

参数：

normal : 　使用当前语言的正常发音尺度
none : 　取消发音。不同于volume的silent值，未发出的声音不占用时间。这个值不会被子对象继承
spell-out : 　一次一字的拼写内容

说明：

设置或检索声音是否给出。
目前IE5.5尚不支持此属性。
对应的脚本特性为speak。请参阅我编写的其他书目。

示例：

acronym { speak: spell-out }


speak-numeral版本：CSS2　 兼容性：NONE　继承性：有

语法：

speak-numeral : continuous | digits

参数：

continuous : 　根据默认语言对数字的词语描述阅读
digits : 　逐位阅读数字

说明：

设置或检索数字如何发音。
目前IE5.5尚不支持此属性。
对应的脚本特性为speakNumeral。请参阅我编写的其他书目。

示例：

.telephone { speak-numeral: digits }


speak-punctuation版本：CSS2　 兼容性：NONE　继承性：有

语法：

speak-punctuation : none | code

参数：

none : 　取消标点符号发音。替代为停顿
code : 　标点符号被发音

说明：

设置或检索标点符号如何发音。
目前IE5.5尚不支持此属性。
对应的脚本特性为speakPunctuation。请参阅我编写的其他书目。

示例：

.telephone { speak-punctuation: code; speak-numeral: digits }


CSS Classification Properties 其它属性

Classification Properties 属性 | CSS Version 版本 | Compatibility 兼容性 | Inherit From Parent 继承性 | Description 简介
cursor | CSS2 | IE4+ | 无 | 设置或检索在对象上移动的鼠标指针采用何种系统预定义的光标形状
filter | IE专有属性 | IE4+ | 无 | 设置或检索对象所应用的滤镜效果
behavior | IE专有属性 | IE5+ | 无 | 设置或检索对象的DHTML行为
zoom | IE4+ , NS6+ | IE5.5+ | 无 | 设置或检索对象的缩放比例

说明：这种颜色是CSS2标准属性。这种颜色是IE建议样式表属性。这种颜色是NS私有属性。这种颜色是目前尚无浏览器支持的属性。


cursor版本：CSS2　 兼容性：IE4+ NS6+　继承性：无

语法：

cursor : auto | crosshair | default | hand | move | help | wait | text | w-resize |s-resize | n-resize |e-resize | ne-resize |sw-resize | se-resize | nw-resize |pointer | url (url)

参数：
crosshair | default | hand | pointer
move | help | wait | text
w-resize | s-resize | n-resize | e-resize
ne-resize | sw-resize | se-resize | nw-resize
auto | url(img/1001.gif)

您将鼠标在上方的表格内移动，就能看到本属性在您当前的软件环境下可以使用的样式。
以这种颜色为背景色的是IE5.5尚不支持的值。

说明：

设置或检索在对象上移动的鼠标指针采用何种系统预定义的光标形状。
对应的脚本特性为cursor。请参阅我编写的其他书目。

示例：

p { cursor: text; }
a { cursor: pointer; }
body { cursor: url("mycursor.gif"), url("images/cursors/footcursor.jpg"), default; }


behavior版本：IE5+专有属性　继承性：无

语法：

behavior : url (url) | url (#objID ) | url (#default#behaviorName)

参数：

url (url) : 使用绝对或相对地址指定DHTML行为组件（.htc）
url (#objID ) : 用二进制实现DHTML行为，#objID为object对象指定的id特性
url (#default#behaviorName) : IE的默认行为。由behaviorName指定

说明：

设置或检索对象的DHTML行为。
多个行为之间用空格隔开。
关于DHTML行为，请参阅我所编写的其他教程。
对应的脚本特性为behavior。请参阅我编写的其他书目。

示例：

div { behavior: url(fly.htc) url(shy.htc); }


filter版本：IE4+专有属性　继承性：无

语法：

filter : filter

参数：

filter : 　要使用的滤镜效果。多个滤镜之间用空格隔开。具体请参阅我的相关著作

说明：

设置或检索对象所应用的滤镜效果。
要使用该属性，对象必须具有height，width，position三个属性中的一个。
滤镜的机制是可扩展的。可以开发和使用第三方滤镜。
该属性在MAC平台上不可用。
对应的脚本特性为filter。请参阅我编写的其他书目。

示例：

div { width:200px; filter:blur(strength=50) flipv() ; }
img { filter: invert(); }


zoom版本：IE5.5+专有属性　继承性：无

语法：

zoom : normal | number

参数：

normal : 　使用对象的实际尺寸
number : 　百分数|无符号浮点实数。浮点实数值为1.0或百分数为100%时相当于此属性的normal值

说明：

设置或检索对象的缩放比例。
对应的脚本特性为zoom。请参阅我编写的其他书目。

示例：

div {zoom : 0.75; }

您所看到的文字块的名字是小强，图片的名字是旺财，请您从下方的选择框内加减选择旺财和小强的zoom值，看一看会发生什么，然后您就会明白这个属性的意义。希望您喜欢这本电子书。谢谢。


Selectors 选择符

Selectors 选择符 | CSS Version 版本 | Compatibility 兼容性 | Syntax Samples 语法 | Description 简介
类型选择符(Type Selectors) | CSS1 | IE4+ , NS4+ | E1 | 以文档语言对象类型作为选择符
通配选择符(Universal Selector) | CSS2 | NONE | * | 选定文档目录树（DOM）中的所有类型的单一对象
包含选择符(Descendant Selectors) | CSS1 | IE4+ , NS4+ | E1 E2 | 选择所有被E1包含的E2。即E1.contains(E2)==true
子对象选择符(Child Selectors) | CSS2 | NONE | E1 > E2 | 选择所有作为E1子对象的E2
相邻选择符(Adjacent Sibling Selectors) | CSS2 | NONE | E1 + E2 | 选择紧贴在对象E1之后的所有E2对象
属性选择符(Attribute Selectors) | CSS2 | NONE | E1[attr] | 选择具有attr属性的E1
属性选择符(Attribute Selectors) | CSS2 | NONE | E1[attr=value] | 选择具有attr属性且属性值等于value的E1
属性选择符(Attribute Selectors) | CSS2 | NONE | E1[attr~=value] | 选择具有attr属性且属性值为一用空格分隔的字词列表，其中一个等于value的E1
属性选择符(Attribute Selectors) | CSS2 | NONE | E1[attr|=value] | 选择具有attr属性且属性值为一用连字符分隔的字词列表，由value开始的E1
ID选择符(ID Selectors) | CSS1 | IE4+ , NS4+ | #sID | 以文档目录树（DOM）中作为对象的唯一标识符的ID作为选择
类选择符(Class Selectors) | CSS1 | IE4+ , NS4+ | E1.className | 在HTML中可以使用此种选择符。其效果等同于E1[class~=className]
选择符分组(Grouping) | CSS1 | IE4+ , NS4+ | E1,E2,E3 | 将同样的定义应用于多个选择符，可以将选择符以逗号分隔的方式并为组

说明：这种颜色是CSS2标准选择符。这种颜色是IE建议样式表选择符。这种颜色是NS私有选择符。这种颜色是目前尚无浏览器支持的选择符。


DHTMLET® 选择符清单 | 相关内容：
Universal Selector 通配选择符

语法：

*

说明：

选定文档目录树（DOM）中的所有类型的单一对象。
假如通配选择符不是单一选择符中的唯一组成，“*”可以省略。
目前IE5.5+尚不支持此种选择符。

示例：

*[lang=fr] { font-size:14px; width:120px; }
*.div { text-decoration:none; }


DHTMLET® 选择符清单 | 相关内容：
Type Selectors 类型选择符

语法：

E1

说明：

以文档语言对象类型作为选择符。

示例：

td { font-size:14px; width:120px; }
a { text-decoration:none; }


DHTMLET® 选择符清单 | 相关内容：
Attribute Selectors 属性选择符

语法：

1. E1[attr]
2. E1[attr=value]
3. E1[attr~=value]
4. E1[attr|=value]

说明：

1. 选择具有attr属性的E1
2. 选择具有attr属性且属性值等于value的E1
3. 选择具有attr属性且属性值为一用空格分隔的字词列表，其中一个等于value的E1。这里的value不能包含空格
4. 选择具有attr属性且属性值为一用连字符分隔的字词列表，由value开始的E1
目前IE5.5+尚不支持此种选择符。

示例：

h[title] { color: blue; }
/* 所有具有title属性的h对象 */

span[class=demo] { color: red; }

div[speed="fast"][dorun="no"] { color: red; }

a[rel~="copyright"] { color:black; }


DHTMLET® 选择符清单 | 相关内容：
Descendant Selectors 包含选择符

语法：

E1 E2

说明：

选择所有被E1包含的E2。即E1.contains(E2)==true。

示例：

table td { font-size:14px; }

div.sub a { font-size:14px; }


DHTMLET® 选择符清单 | 相关内容：
Child Selectors 子对象选择符

语法：

E1 > E2

说明：

选择所有作为E1子对象的E2。
目前IE5.5+尚不支持此种选择符。

示例：

body > p { font-size:14px; }
/* 所有作为body的子对象的p对象字体尺寸为14px */

div ul>li p { font-size:14px; }


DHTMLET® 选择符清单 | 相关内容：
ID Selectors ID选择符

语法：

#sID

说明：

以文档目录树（DOM）中作为对象的唯一标识符的ID作为选择符。

示例：

#note { font-size:14px; width:120px;}


DHTMLET® 选择符清单 | 相关内容：
Class Selectors 类选择符

语法：

E1.className

说明：

在HTML中可以使用此种选择符。其效果等同于E1[class~=className]。请参阅属性选择符( Attribute Selectors)。
在IE5+，可以为对象的class属性（特性）指定多于一个值(className)，其方法是指定用空格隔开的一组样式表的类名。

示例：

div.note { font-size:14px; }
/* 所有class属性值等于（包含）"note"的div对象字体尺寸为14px */

.dream { font-size:14px; }
/* 所有class属性值等于（包含）"note"的对象字体尺寸为14px */


DHTMLET® 选择符清单 | 相关内容：
Grouping 选择符分组

语法：

E1,E2,E3

说明：

将同样的定义应用于多个选择符，可以将选择符以逗号分隔的方式并为组。

示例：

.td1,div a,body { font-size:14px; }


CSS Pseudo-Classes Reference 伪类

Pseudo-Classes 伪类 | CSS Version 版本 | Compatibility 兼容性 | Description 简介
:link | CSS1 | IE4+ , NS4+ | 设置a对象在未被访问前的样式表属性
:hover | CSS1/CSS2 | IE4+ , NS4+ | 设置对象在其鼠标悬停时的样式表属性
:active | CSS1/CSS2 | IE4+ | 设置对象在被用户激活（在鼠标点击与释放之间发生的事件）时的样式表属性
:visited | CSS1 | IE4+ , NS4+ | 设置a对象在其链接地址已被访问过时的样式表属性
:focus | CSS2 | NONE | 设置对象在成为输入焦点（该对象的onfocus事件发生）时的样式表属性
:first-child | CSS2 | NONE | 设置对象（Selector1）的第一个子对象（Selector2）的样式表属性
:first | CSS2 | IE4+ | 设置页面容器第一页使用的样式表属性。仅用于@page规则
:left | CSS2 | IE4+ | 设置页面容器位于装订线左边的所有页面使用的样式表属性。仅用于@page规则
:right | CSS2 | IE4+ | 设置页面容器位于装订线右边的所有页面使用的样式表属性。仅用于@page规则
:lang | CSS2 | NONE | 设置对象使用特殊语言的内容样式表属性

说明：这种颜色是CSS2标准伪类。这种颜色是IE建议样式表伪类。这种颜色是NS私有伪类。这种颜色是目前尚无浏览器支持的伪类。


DHTMLET® 伪类清单 | 相关内容：
:link版本：CSS1　 兼容性：IE4+ NS4+

语法：

Selector : link { sRules }

说明：

设置a对象在未被访问前的样式表属性。
IE3将:link伪类的样式表属性作用于visited伪类。
默认值由浏览器决定。
对于无href属性（特性）的a对象，此伪类不发生作用。
请参阅body对象的link属性（特性）和document对象的linkColor特性。详见我编写的其他书目。

示例：

a:link { font-size: 14pt; text-decoration: underline; color: blue; }

请您将鼠标移到这个a对象上，点击，看看会发生什么。然后您就会明白这个伪类的意义。希望您喜欢这本电子书。谢谢。


DHTMLET® 伪类清单 | 相关内容：
:hover版本：CSS1/CSS2　 兼容性：IE4+ NS4+

语法：

Selector : hover { sRules }

说明：

设置对象在其鼠标悬停时的样式表属性。
在CSS1中此伪类仅可用于a对象。且对于无href属性（特性）的a对象，此伪类不发生作用。在CSS2中此伪类可以应用于任何对象。
目前IE5.5+仅支持CSS1中的:hover。

示例：

a:hover { font-size: 14pt; text-decoration: underline; color: blue; }
a:hover span{ color:red; }

请您将鼠标移到这个a对象上，点击，看看会发生什么。然后您就会明白这个伪类的意义。希望您喜欢这本电子书。谢谢。


DHTMLET® 伪类清单 | 相关内容：
:active版本：CSS1/CSS2　 兼容性：IE4+

语法：

Selector : active { sRules }

说明：

设置对象在被用户激活（在鼠标点击与释放之间发生的事件）时的样式表属性。
在CSS1中此伪类仅可用于a对象。且对于无href属性（特性）的a对象，此伪类不发生作用。在CSS2中此伪类可以应用于任何对象。并且:active状态可以和:link以及:visited状态同时发生。
目前IE5.5+仅支持CSS1中的:active。

示例：

a:active { font-size: 14pt; text-decoration: underline; color: blue; }

请您将鼠标移到这个a对象上，点击，看看会发生什么。然后您就会明白这个伪类的意义。希望您喜欢这本电子书。谢谢。


DHTMLET® 伪类清单 | 相关内容：
:visited版本：CSS1　 兼容性：IE4+ NS4+

语法：

Selector : visited { sRules }

说明：

设置a对象在其链接地址已被访问过时的样式表属性。
IE3将:link伪类的样式表属性作用于visited伪类。
默认值由浏览器决定。定义网页过期时间或用户清空历史记录将影响此伪类的作用。
对于无href属性（特性）的a对象，此伪类不发生作用。
请参阅body对象的vlink属性（特性）和document对象的vlinkColor特性。详见我编写的其他书目。

示例：

a:visited { font-size: 14pt; text-decoration: underline; color: blue; }

请您将鼠标移到这个a对象上，点击，看看会发生什么。然后您就会明白这个伪类的意义。希望您喜欢这本电子书。谢谢。


DHTMLET® 伪类清单 | 相关内容：
:focus版本：CSS2　 兼容性：NONE

语法：

Selector : focus { sRules }

说明：

设置对象在成为输入焦点（该对象的onfocus事件发生）时的样式表属性。
目前IE5.5尚不支持此属性。

示例：

a:focus { font-size: 14pt; text-decoration: underline; color: blue; }
a:focus img { border: thin solid green }


DHTMLET® 伪对象清单 | 相关内容：
:first-letter版本：CSS2　 兼容性：IE5.5+

语法：

Selector : first-letter { sRules }

说明：

设置对象内的第一个字符的样式表属性。
此伪对象仅作用于块对象。内联对象要使用该伪对象，必须先设定对象的height或width属性，或者设定position属性为absolute，或者设定display属性为block。
在此伪类中配合使用font-size属性和float属性可以制作首字下沉效果。

示例：

p a:first-letter { color: green }
div:first-letter { color:red;font-size:16px;float:left; }

请您看看这段文字的首字。您就会明白这个伪类的意义。希望您喜欢这本电子书。谢谢。


DHTMLET® 伪对象清单 | 相关内容：
:first-line版本：CSS2　 兼容性：IE5.5+

语法：

Selector : first-line { sRules }

说明：

设置对象内的第一行的样式表属性。
此伪对象仅作用于块对象。内联对象要使用该伪对象，必须先设定对象的height或width属性，或者设定position属性为absolute，或者设定display属性为block。
如果未强制指定对象的width属性， 首行的内容长度可能不是固定的。

示例：

p a:first-line { color: green }
div:first-line { color:red;font-size:16px; }

请您看看这段文字的首字。您就会明白这个伪类的意义。希望您喜欢这本电子书。谢谢。


DHTMLET® 伪类清单 | 相关内容：
:first-child版本：CSS2　 兼容性：NONE

语法：

Selector1 Selector2 : first-child { sRules }

说明：

设置对象（Selector1）的第一个子对象（Selector2）的样式表属性。
目前IE5.5尚不支持此伪类。

示例：

p a:first-child { color: green }
table td:first-child { width:200px; }


DHTMLET® 伪类清单 | 相关内容：
:first版本：CSS2　 兼容性：IE4+

语法：

Selector : first { sRules }

说明：

设置页面容器第一页使用的样式表属性。仅用于@page规则。

示例：

@page :first { margin: 4cm }


DHTMLET® 伪类清单 | 相关内容：
:left版本：CSS2　 兼容性：IE4+

语法：

Selector : left { sRules }

说明：

设置页面容器位于装订线左边的所有页面使用的样式表属性。仅用于@page规则。

示例：

@page :left { margin: 4cm }


DHTMLET® 伪类清单 | 相关内容：
:right版本：CSS2　 兼容性：IE4+

语法：

Selector : right { sRules }

说明：

设置页面容器位于装订线右边的所有页面使用的样式表属性。仅用于@page规则。

示例：

@page :right { margin: 4cm }


DHTMLET® 伪类清单 | 相关内容：
:lang版本：CSS2　 兼容性：NONE

语法：

Selector : lang { sRules }

说明：

设置对象使用特殊语言的内容样式表属性。
目前IE5.5尚不支持此属性。

示例：

blockquote:lang(fr) { quotes: '?' ' ?' }
//使用法语显示由quotes属性指定的法语的嵌套标记


CSS Pseudo-Elements Reference 伪对象

Pseudo-Elements 伪对象 | CSS Version 版本 | Compatibility 兼容性 | Description 简介
:first-letter | CSS2 | IE5.5+ | 设置对象内的第一个字符的样式表属性
:first-line | CSS2 | IE5.5+ | 设置对象内的第一行的样式表属性
:before | CSS2 | NONE | 用来和content属性一起使用，设置在对象前（依据对象树的逻辑结构）发生的内容
:after | CSS2 | NONE | 用来和content属性一起使用，设置在对象后（依据对象树的逻辑结构）发生的内容

说明：这种颜色是CSS2标准伪对象。这种颜色是IE建议样式表伪对象。这种颜色是NS私有伪对象。这种颜色是目前尚无浏览器支持的伪对象。


DHTMLET® 伪对象清单 | 相关内容：
:before版本：CSS2　 兼容性：NONE

语法：

Selector : before { sRules }

说明：

用来和content属性一起使用，设置在对象前（依据对象树的逻辑结构）发生的内容。
目前IE5.5尚不支持此伪对象。

示例：

em:before { content: url("ding.wav") }


DHTMLET® 伪对象清单 | 相关内容：
:after版本：CSS2　 兼容性：NONE

语法：

Selector : after { sRules }

说明：

用来和content属性一起使用，设置在对象后（依据对象树的逻辑结构）发生的内容。
目前IE5.5尚不支持此伪对象。

示例：

table:after { content: END OF TABLE }


CSS At-Rules Reference 样式表规则

At-Rules 样式表规则 | CSS Version 版本 | Compatibility 兼容性 | Description 简介
@import | CSS1 | IE4+ | 指定导入的外部样式表及目标媒体。该规则必须在样式表头部最先声明
@charset | CSS2 | IE4+ | 在外部样式表文件内使用。指定该样式表使用的字符集。请参阅附录：字符集
@font-face | CSS2 | IE4+ | 设置嵌入HTML文档的OpenType字体
@fontdef | NS专有规则 | NS4+ | 设置嵌入HTML文档的字体
@media | CSS2 | IE5+ | 指定样式表规则用于指定的媒体类型
@page | CSS2 | IE5.5+ | 设置页面容器的版式，方向，边空等

说明：这种颜色是CSS2标准规则。这种颜色是IE建议样式表规则。这种颜色是NS私有规则。这种颜色是目前尚无浏览器支持的规则。


DHTMLET® 规则清单 | 相关内容：
@import版本：CSS1/CSS2　 兼容性：IE4+

语法：

@import url (url) sMedia ;

说明：

url : 　使用绝对或相对地址指定导入的外部样式表文件。请参阅link对象
sMedia : 　指定设备类型。请参阅附录：设备类型。目前IE5.5尚不支持此属性

指定导入的外部样式表及目标设备类型。
该规则必须在样式表头部最先声明。并且其后的分号是必需的，如果省略了此分号，外部样式表将无法正确导入，并会生成错误信息。
用此规则导入的样式表，其owningElement特性是一个link对象或style对象。请参阅我的其他著作。
导入的外部样式表中的定义将被文当中的同名定义覆盖。

示例：

@import url("foo.css") screen, print;
@import "print.css"


DHTMLET® 规则清单 | 相关内容：
@charset版本：CSS2　 兼容性：IE4+

语法：

@charset sCharacterSet

说明：

sCharacterSet : 　字符集名称

在外部样式表文件内使用。指定该样式表使用的字符集。请参阅附录：字符集。
在外部样式表文件内，此规则只允许发生一次。且必须在样式表的最前面。
对于内部样式表来说，其字符集由HTML文档的字符集指定。请参阅meta对象的content属性（特性）。

示例：

@charset "Shift-JIS";


DHTMLET® 规则清单 | 相关内容：
@font-face版本：CSS2　 兼容性：IE4+

语法：

@font-face { font-family : name ; src : url( url ) ; sRules }

说明：

name : 　字体名称
url : 　使用绝对或相对地址指定OpenType字体
sRules : 　样式表定义

设置嵌入HTML文档的字体。
嵌入HTML文档的字体是指将OpenType字体（压缩的TrueType字体）文件映射到客户端系统，用来提供HTML文档使用该字体，或取代客户端系统已有的同名字体。

示例：

@font-face { font-family: dreamy; font-weight: bold; src: url(http://www.example.com/font.eot); }


DHTMLET® 规则清单 | 相关内容：
@fontdef版本：NS4+专有规则　 兼容性：NS4+

语法：

@fontdef { url( url ) }

说明：
url : 　使用绝对或相对地址指定嵌入HTML文档的字体定义文件

设置嵌入HTML文档的字体。

示例：

@fontdef url("http://www.example.com/sample.pfr");


DHTMLET® 规则清单 | 相关内容：
@page版本：CSS2　 兼容性：IE5.5+

语法：

@page label pseudo-class { sRules }

说明：

label : 　页标
pseudo-class : 　伪类。:first | :left | :right
sRules : 　样式表定义

设置页面容器的版式，方向，边空等。
页面容器包括页面内容区域和内容区域外围的边空补白区域。

示例：

@page thin:first { size: 3in 8in }


DHTMLET® 规则清单 | 相关内容：
@media版本：CSS2　 兼容性：IE5+

语法：

@media sMedia { sRules }

说明：

sMedia : 　指定设备名称。请参阅附录：设备类型
sRules : 　样式表定义

指定样式表规则用于指定的设备类型。请参阅link对象的media属性（特性）。

示例：

// 设置显示器用字体尺寸
@media screen {
BODY {font-size:12pt; }
}

// 设置打印机用字体尺寸
@media print {
@import "print.css"
BODY {font-size:8pt;}
}


CSS Declaration Reference 样式表声明

Declaration 样式表声明 | CSS Version 版本 | Compatibility 兼容性 | Description 简介
!important | CSS1 | IE4+ | 提升指定样式条目的应用优先权

说明：这种颜色是CSS2标准声明。这种颜色是IE建议样式表声明。这种颜色是NS私有声明。这种颜色是目前尚无浏览器支持的声明。


DHTMLET® 声明清单 | 相关内容：
!important版本：CSS1　 兼容性：IE4+

语法：

sRule!important

说明：
sRules : 　样式表条目

提升指定样式规则的应用优先权。

示例：

div { color:red!important }


CSS Units样式表单位

时间单位 Time Units
s ms
长度单位 Length Units
em ex px pt pc in cm mm
频率单位 Frequency Units
kHz Hz
颜色单位 Color Units
#RRGGBB rgb ( R,G,B ) Color Name
角度单位 Angle Units
deg grad rad

说明：这种颜色是CSS2标准单位。这种颜色是IE建议样式表单位。这种颜色是NS私有单位。这种颜色是目前尚无浏览器支持的单位。


CSS Length Units Reference 长度单位

Length Units 长度单位 | CSS Version 版本 | Compatibility 兼容性 | Description 简介
相对长度单位 Relative Length Units
em | CSS1 | IE4+ , NS4+ | 相对于当前对象内文本的字体尺寸
ex | CSS1 | IE4+ , NS4+ | 相对于字符 “ x ” 的高度。通常为字体高度的一半
px | CSS1 | IE3+ , NS4+ | 像素（Pixel）
绝对长度单位 Absolute Length Units
pt | CSS1 | IE3+ , NS4+ | 点（Point）
pc | CSS1 | IE3+ , NS4+ | 派卡（Pica）。相当于我国新四号铅字的尺寸
in | CSS1 | IE3+ , NS4+ | 英寸（Inch）
cm | CSS1 | IE3+ , NS4+ | 厘米（Centimeter）
mm | CSS1 | IE3+ , NS4+ | 毫米（Millimeter）

单位换算：1in = 2.54cm = 25.4 mm = 72pt = 6pc

说明：这种颜色是CSS2标准单位。这种颜色是IE建议样式表单位。这种颜色是NS私有单位。这种颜色是目前尚无浏览器支持的单位。


DHTMLET® 长度单位清单 | 相关内容：
px版本：CSS1　 兼容性：IE3+ NS4+

说明：

像素（Pixel）。相对长度单位。
像素是相对于显示器屏幕分辨率而言的。譬如，WONDOWS的用户所使用的分辨率一般是96像素/英寸。而MAC的用户所使用的分辨率一般是72像素/英寸。

示例：

div { font-size : 12px; }

请您用下面的按钮设定这段文字的尺寸值（单位为px）。看一看会发生什么。


DHTMLET® 长度单位清单 | 相关内容：
em版本：CSS1　 兼容性：IE4+ NS4+

说明：

相对长度单位。相对于当前对象内文本的字体尺寸。
如当前对行内文本的字体尺寸未被人为设置，则相对于浏览器的默认字体尺寸。

示例：

div { font-size : 1.2em; }

请您用下面的按钮设定这段文字的尺寸值（单位为em）。看一看会发生什么。


DHTMLET® 长度单位清单 | 相关内容：
ex版本：CSS1　 兼容性：IE4+ NS4+

说明：

相对长度单位。相对于字符“x”的高度。此高度通常为字体尺寸的一半。
如当前对行内文本的字体尺寸未被人为设置，则相对于浏览器的默认字体尺寸。

示例：

div { font-size : 1.2ex; }

请您用下面的按钮设定这段文字的尺寸值（单位为ex）。看一看会发生什么。


DHTMLET® 长度单位清单 | 相关内容：
pt版本：CSS1　 兼容性：IE3+ NS4+

说明：

点（Point）。绝对长度单位。
1in = 2.54cm = 25.4 mm = 72pt = 6pc

示例：

div { font-size : 12pt; }

请您用下面的按钮设定这段文字的尺寸值（单位为pt）。看一看会发生什么。


DHTMLET® 长度单位清单 | 相关内容：
pc版本：CSS1　 兼容性：IE3+ NS4+

说明：

派卡（Pica）。绝对长度单位。相当于我国新四号铅字的尺寸。
1in = 2.54cm = 25.4 mm = 72pt = 6pc

示例：

div { font-size : 0.75pc; }

请您用下面的按钮设定这段文字的尺寸值（单位为pc）。看一看会发生什么。


DHTMLET® 长度单位清单 | 相关内容：
in版本：CSS1　 兼容性：IE3+ NS4+

说明：

英寸（Inch）。绝对长度单位。
1in = 2.54cm = 25.4 mm = 72pt = 6pc

示例：

div { font-size : 0.13in; }

请您用下面的按钮设定这段文字的尺寸值（单位为in）。看一看会发生什么。


DHTMLET® 长度单位清单 | 相关内容：
mm版本：CSS1　 兼容性：IE3+ NS4+

说明：

毫米（Millimeter）。绝对长度单位。
1in = 2.54cm = 25.4 mm = 72pt = 6pc

示例：

div { font-size : 3.3mm; }

请您用下面的按钮设定这段文字的尺寸值（单位为mm）。看一看会发生什么。


DHTMLET® 长度单位清单 | 相关内容：
cm版本：CSS1　 兼容性：IE3+ NS4+

说明：

厘米（Centimeter）。绝对长度单位。
1in = 2.54cm = 25.4 mm = 72pt = 6pc

示例：

div { font-size : 0.33cm; }

请您用下面的按钮设定这段文字的尺寸值（单位为cm）。看一看会发生什么。


CSS Color Units Reference 颜色单位

Color Units 颜色单位 | CSS Version 版本 | Compatibility 兼容性 | Description 简介
#RRGGBB | CSS1 | IE4+ , NS4+ | 三个两位十六进制正整数。取值范围为：00 - FF
rgb ( R,G,B ) | CSS1 | IE4+ , NS4+ | 表示红，绿，蓝的正整数或百分数数值
Color Name | CSS1 | IE4+ , NS4+ | 颜色名称。不同的浏览器会有不同的预定义颜色名称。请查看附录：颜色表

说明：这种颜色是CSS2标准单位。这种颜色是IE建议样式表单位。这种颜色是NS私有单位。这种颜色是目前尚无浏览器支持的单位。


DHTMLET® 颜色单位清单 | 相关内容：
rgb(R,G,B)版本：CSS1　 兼容性：IE4+ NS4+

参数：

R : 　红色值。正整数 | 百分数
G : 　绿色值。正整数 | 百分数
B : 　蓝色值。正整数 | 百分数

说明：

以上三个参数，正整数值的取值范围为：0 - 255。百分数值的取值范围为：0.0% - 100.0%。超出范围的数值将被截至其最接近的取值极限。
并非所有浏览器都支持使用百分数值。
请参阅附录：颜色表。

示例：

div { color: rgb(132,20,180); }
div { color: rgb(12%,200,50%); }


DHTMLET® 颜色单位清单 | 相关内容：
#RRGGBB版本：CSS1　 兼容性：IE4+ NS4+

参数：

RR : 　红色值。十六进制正整数
GG : 　绿色值。十六进制正整数
BB : 　蓝色值。十六进制正整数

说明：

以上三个参数，取值范围为：00 - FF。
参数必须是两位数。对于只有一位的，应在前面补零。
如果每个参数各自在两位上的数字都相同，那么本单位也可缩写为 #RGB 的方式。例如：#FF8800 可以缩写为 #F80。
请参阅附录：颜色表。

示例：

div { color: #FF0000; }
div { color: #F00; }


DHTMLET® 颜色单位清单 | 相关内容：
Color Name版本：CSS1　 兼容性：IE4+ NS4+

说明：

颜色名称。不同的浏览器会有不同的预定义颜色名称。请查看附录：颜色表。

示例：

div {color: red; }


CSS Angle Units Reference 角度单位

Angle Units 角度单位 | CSS Version 版本 | Compatibility 兼容性 | Description 简介
deg | CSS2 | NONE | 度。一个圆圈的360等分之一
grad | CSS2 | NONE | 梯度。一个直角的100等分之一。一个圆圈相当于400grad
rad | CSS2 | NONE | 弧度。把一个圆圈分成2*PI单位

说明：这种颜色是CSS2标准单位。这种颜色是IE建议样式表单位。这种颜色是NS私有单位。这种颜色是目前尚无浏览器支持的单位。


DHTMLET® 角度单位清单 | 相关内容：
deg版本：CSS2　 兼容性：NONE

说明：

度。一个圆圈的360等分之一。

示例：

body { azimuth: 75deg }
body { elevation: 75deg }


DHTMLET® 角度单位清单 | 相关内容：
grad版本：CSS2　 兼容性：NONE

说明：

梯度。一个直角的100等分之一。一个圆圈相当于400grad。

示例：

body { azimuth: 75grad }
body { elevation: 75grad }


DHTMLET® 角度单位清单 | 相关内容：
rad版本：CSS2　 兼容性：NONE

说明：

弧度。把一个圆圈分成2*PI单位。

示例：

body { azimuth: 3rad }
body { elevation: 5rad }


CSS Time Units Reference 时间单位

Time Units 时间单位 | CSS Version 版本 | Compatibility 兼容性 | Description 简介
s | CSS2 | NONE | 秒。时间的国际主单位
ms | CSS2 | NONE | 微秒

单位换算：1s = 1000ms

说明：这种颜色是CSS2标准单位。这种颜色是IE建议样式表单位。这种颜色是NS私有单位。这种颜色是目前尚无浏览器支持的单位。


DHTMLET® 时间单位清单 | 相关内容：
s版本：CSS2　 兼容性：NONE

说明：

秒。时间的国际主单位。
1s = 1000 ms

示例：

div { pause-after: 2s; }
div { pause-before: 2s; }


DHTMLET® 时间单位清单 | 相关内容：
ms版本：CSS2　 兼容性：NONE

说明：

微秒。
1s = 1000 ms

示例：

div { pause-after: 2s; }
div { pause-before: 2s; }


CSS Frequency Units Reference 频率单位

Frequency Units 频率单位 | CSS Version 版本 | Compatibility 兼容性 | Description 简介
kHz | CSS2 | NONE | 千赫
Hz | CSS2 | NONE | 赫兹。声波的基本单位

单位换算：1kHz = 1000 Hz

说明：这种颜色是CSS2标准单位。这种颜色是IE建议样式表单位。这种颜色是NS私有单位。这种颜色是目前尚无浏览器支持的单位。


DHTMLET® 频率单位清单 | 相关内容：
Hz版本：CSS2　 兼容性：NONE

说明：

赫兹。声波的基本单位。
1kHz = 1000 Hz

示例：

strong { pitch: 75hz }


DHTMLET® 频率单位清单 | 相关内容：
kHz版本：CSS2　 兼容性：NONE

说明：

千赫。
1kHz = 1000 Hz

示例：

strong { pitch: 75hz }


Appendix附 录

  • Color Table 颜色表
  • Media Types 设备类型
  • Character Set Recognition 字符集识别
  • ISO Latin-1 Character Set ISO Latin-1字符集
  • Additional Named Entities for HTML HTML附加命名实体
  • Character Entities for Special Symbols and BIDI Text 特殊文本和BIDI文本的字符实体


W3C- 十六色色盘 颜色名称： 色值：

安全色色盘 颜色名称： 色值：

IE4+预命名颜色 颜色名称： 色值：

WIN- 用户系统色盘 颜色名称：

windowtextwindowframewindowthreedshadowbuttonshadowthreedlightshadowthreedhighlightthreedfacethreeddarkshadowscrollbarmenutextmenuinfotextinfobackgroundinactivecaptiontextinactivecaptioninactiveborderhighlighttexthighlightgraytextcaptiontextbuttontextbuttonhighlightbuttonfacebackgroundappworkspaceactivecaptionactiveborder


Media Types 设备类型

Media Type 设备类型 | CSS Version 版本 | Compatibility 兼容性 | Description 简介
all | CSS2 | IE4+ | 用于所有设备类型
aural | CSS2 | NONE | 用于语音和音乐合成器
braille | CSS2 | NONE | 用于触觉反馈设备
embossed | CSS2 | NONE | 用于凸点字符（盲文）印刷设备
handheld | CSS2 | NONE | 用于小型或手提设备
print | CSS2 | IE4+ | 用于打印机
projection | CSS2 | NONE | 用于投影图像，如幻灯片
screen | CSS2 | IE4+ | 用于计算机显示器
tty | CSS2 | NONE | 用于使用固定间距字符格的设备。如电传打字机和终端
tv | CSS2 | NONE | 用于电视类设备


Character Set Recognition 字符集识别

CharsetFriendlyName 显示名称 | Preferred Charset Label 首选字符集标示 | Aliases 附加别名 | IE Ver 浏览器版本 | Min OS 操作系统 | CodePage 代码页 | FamilyCodePage 内部代码页
Arabic (ASMO 708) | ASMO-708 |  | IE5 | Win95 | 708 | 1256
Arabic (DOS) | DOS-720 |  | IE5 | Win95 | 720 | 1256
Arabic (ISO) | iso-8859-6 | arabiccsISOLatinArabicECMA-114ISO_8859-6ISO_8859-6:1987iso-ir-127 | IE5,IE4 | Win95 | 28596 | 1256
Arabic (Mac) | x-mac-arabic |  | IE5 | Win2000 | 10004 | 1256
Arabic (Windows) | windows-1256 | cp1256 | IE5 | Win95 | 1256 | 1256
Baltic (DOS) | ibm775 | CP500 | IE5 | Win2000 | 775 | 1257
Baltic (ISO) | iso-8859-4 | csISOLatin4ISO_8859-4ISO_8859-4:1988iso-ir-110l4latin4 | IE5 | Win95 | 28594 | 1257
Baltic (Windows) | windows-1257 |  | IE5 | Win95 | 1257 | 1257
Central European (DOS) | ibm852 | cp852 | IE5,IE4 | Win95 | 852 | 1250
Central European (ISO) | iso-8859-2 | csISOLatin2iso_8859-2iso_8859-2:1987iso8859-2iso-ir-101l2latin2 | IE5,IE4 | Win95 | 28592 | 1250
Central European (Mac) | x-mac-ce |  | IE5 | Win2000 | 10029 | 1250
Central European (Windows) | windows-1250 | x-cp1250 | IE5 | Win95 | 1250 | 1250
Chinese Simplified (EUC) | EUC-CN | x-euc-cn | IE5 | Win2000 | 51936 | 936
Chinese Simplified (GB2312) | gb2312 | chineseCN-GBcsGB2312csGB231280csISO58GB231280GB_2312-80GB231280GB2312-80GBKiso-ir-58 | IE5,IE4 | Win95 | 936 | 936
Chinese Simplified (HZ) | hz-gb-2312 |  | IE5,IE4 | Win95 | 52936 | 936
Chinese Simplified (Mac) | x-mac-chinesesimp |  | IE5 | Win2000 | 10008 | 936
Chinese Traditional (Big5) | big5 | cn-big5csbig5x-x-big5 | IE5,IE4 | Win95 | 950 | 950
Chinese Traditional (CNS) | x-Chinese-CNS |  | IE5 | Win2000 | 20000 | 950
Chinese Traditional (Eten) | x-Chinese-Eten |  | IE5 | Win2000 | 20002 | 950
Chinese Traditional (Mac) | x-mac-chinesetrad |  | IE5 | Win2000 | 10002 | 950
Cyrillic (DOS) | cp866 | ibm866 | IE5,IE4 | Win95 | 866 | 1251
Cyrillic (ISO) | iso-8859-5 | csISOLatin5csISOLatinCyrilliccyrillicISO_8859-5ISO_8859-5:1988iso-ir-144l5 | IE5,IE4 | Win95 | 28595 | 1251
Cyrillic (KOI8-R) | koi8-r | csKOI8Rkoikoi8koi8r | IE5,IE4 | Win95 | 20866 | 1251
Cyrillic (KOI8-U) | koi8-u | koi8-ru | IE5 | Win95 | 21866 | 1251
Cyrillic (Mac) | x-mac-cyrillic |  | IE5 | Win2000 | 10007 | 1251
Cyrillic (Windows) | windows-1251 | x-cp1251 | IE5 | Win95 | 1251 | 1251
Europa | x-Europa |  | IE5 | n.a. | 29001 | 1252
German (IA5) | x-IA5-German |  | IE5 | Win2000 | 20106 | 1252
Greek (DOS) | ibm737 |  | IE5 | Win2000 | 737 | 1253
Greek (ISO) | iso-8859-7 | csISOLatinGreekECMA-118ELOT_928greekgreek8ISO_8859-7ISO_8859-7:1987iso-ir-126 | IE5,IE4 | Win95 | 28597 | 1253
Greek (Mac) | x-mac-greek |  | IE5 | Win2000 | 10006 | 1253
Greek (Windows) | windows-1253 |  | IE5 | Win95 | 1253 | 1253
Greek, Modern (DOS) | ibm869 |  | IE5 | Win2000 | 869 | 1253
Hebrew (DOS) | DOS-862 |  | IE5 | Win95 | 862 | 1255
Hebrew (ISO-Logical) | iso-8859-8-i | logical | IE5,IE4 | Win95 | 38598 | 1255
Hebrew (ISO-Visual) | iso-8859-8 | csISOLatinHebrewhebrewISO_8859-8ISO_8859-8:1988ISO-8859-8iso-ir-138visual | IE5,IE4 | Win95 | 28598 | 1255
Hebrew (Mac) | x-mac-hebrew |  | IE5 | Win2000 | 10005 | 1255
Hebrew (Windows) | windows-1255 | ISO_8859-8-IISO-8859-8visual | IE5 | Win95 | 1255 | 1255
IBM EBCDIC (Arabic) | x-EBCDIC-Arabic |  | IE5 | Win2000 | 20420 | 1256
IBM EBCDIC (Cyrillic Russian) | x-EBCDIC-CyrillicRussian |  | IE5 | Win2000 | 20880 | 1251
IBM EBCDIC (Cyrillic Serbian-Bulgarian) | x-EBCDIC-CyrillicSerbianBulgarian |  | IE5 | Win2000 | 21025 | 1251
IBM EBCDIC (Denmark-Norway) | x-EBCDIC-DenmarkNorway |  | IE5 | Win2000 | 20277 | 1252
IBM EBCDIC (Denmark-Norway-Euro) | x-ebcdic-denmarknorway-euro |  | IE5 | Win2000 | 1142 | 1252
IBM EBCDIC (Finland-Sweden) | x-EBCDIC-FinlandSweden |  | IE5 | Win2000 | 20278 | 1252
IBM EBCDIC (Finland-Sweden-Euro) | x-ebcdic-finlandsweden-euro |  | IE5 | Win2000 | 1143 | 1252
IBM EBCDIC (Finland-Sweden-Euro) | x-ebcdic-finlandsweden-euro | X-EBCDIC-France | IE5 | Win2000 | 1143 | 1252
IBM EBCDIC (France-Euro) | x-ebcdic-france-euro |  | IE5 | Win2000 | 1147 | 1252
IBM EBCDIC (Germany) | x-EBCDIC-Germany |  | IE5 | Win2000 | 20273 | 1252
IBM EBCDIC (Germany-Euro) | x-ebcdic-germany-euro |  | IE5 | Win2000 | 1141 | 1252
IBM EBCDIC (Greek Modern) | x-EBCDIC-GreekModern |  | IE5 | Win2000 | 875 | 1253
IBM EBCDIC (Greek) | x-EBCDIC-Greek |  | IE5 | Win2000 | 20423 | 1253
IBM EBCDIC (Hebrew) | x-EBCDIC-Hebrew |  | IE5 | Win2000 | 20424 | 1255
IBM EBCDIC (Icelandic) | x-EBCDIC-Icelandic |  | IE5 | Win2000 | 20871 | 1252
IBM EBCDIC (Icelandic-Euro) | x-ebcdic-icelandic-euro |  | IE5 | Win2000 | 1149 | 1252
IBM EBCDIC (International-Euro) | x-ebcdic-international-euro |  | IE5 | Win2000 | 1148 | 1252
IBM EBCDIC (Italy) | x-EBCDIC-Italy |  | IE5 | Win2000 | 20280 | 1252
IBM EBCDIC (Italy-Euro) | x-ebcdic-italy-euro |  | IE5 | Win2000 | 1144 | 1252
IBM EBCDIC (Japanese and Japanese Katakana) | x-EBCDIC-JapaneseAndKana |  | IE5 | Win2000 | 50930 | 932
IBM EBCDIC (Japanese and Japanese-Latin) | x-EBCDIC-JapaneseAndJapaneseLatin |  | IE5 | Win2000 | 50939 | 932
IBM EBCDIC (Japanese and US-Canada) | x-EBCDIC-JapaneseAndUSCanada |  | IE5 | Win2000 | 50931 | 932
IBM EBCDIC (Japanese katakana) | x-EBCDIC-JapaneseKatakana |  | IE5 | Win2000 | 20290 | 932
IBM EBCDIC (Korean and Korean Extended) | x-EBCDIC-KoreanAndKoreanExtended |  | IE5 | Win2000 | 50933 | 949
IBM EBCDIC (Korean Extended) | x-EBCDIC-KoreanExtended |  | IE5 | Win2000 | 20833 | 949
IBM EBCDIC (Multilingual Latin-2) | CP870 |  | IE5 | Win2000 | 870 | 1250
IBM EBCDIC (Simplified Chinese) | x-EBCDIC-SimplifiedChinese |  | IE5 | Win2000 | 50935 | 936
IBM EBCDIC (Spain) | X-EBCDIC-Spain |  | IE5 | Win2000 | 20284 | 1252
IBM EBCDIC (Spain-Euro) | x-ebcdic-spain-euro |  | IE5 | Win2000 | 1145 | 1252
IBM EBCDIC (Thai) | x-EBCDIC-Thai |  | IE5 | Win2000 | 20838 | 874
IBM EBCDIC (Traditional Chinese) | x-EBCDIC-TraditionalChinese |  | IE5 | Win2000 | 50937 | 950
IBM EBCDIC (Turkish Latin-5) | CP1026 |  | IE5 | Win2000 | 1026 | 1254
IBM EBCDIC (Turkish) | x-EBCDIC-Turkish |  | IE5 | Win2000 | 20905 | 1254
IBM EBCDIC (UK) | x-EBCDIC-UK |  | IE5 | Win2000 | 20285 | 1252
IBM EBCDIC (UK-Euro) | x-ebcdic-uk-euro |  | IE5 | Win2000 | 1146 | 1252
IBM EBCDIC (US-Canada) | ebcdic-cp-us |  | IE5 | Win2000 | 37 | 1252
IBM EBCDIC (US-Canada-Euro) | x-ebcdic-cp-us-euro |  | IE5 | Win2000 | 1140 | 1252
Icelandic (DOS) | ibm861 |  | IE5 | Win2000 | 861 | 1252
Icelandic (Mac) | x-mac-icelandic |  | IE5 | Win2000 | 10079 | 1252
ISCII Assamese | x-iscii-as |  | IE5 | Win2000 | 57006 | 57006
ISCII Bengali | x-iscii-be |  | IE5 | Win2000 | 57003 | 57003
ISCII Devanagari | x-iscii-de |  | IE5 | Win2000 | 57002 | 57002
ISCII Gujarathi | x-iscii-gu |  | IE5 | Win2000 | 57010 | 57010
ISCII Kannada | x-iscii-ka |  | IE5 | Win2000 | 57008 | 57008
ISCII Malayalam | x-iscii-ma |  | IE5 | Win2000 | 57009 | 57009
ISCII Oriya | x-iscii-or |  | IE5 | Win2000 | 57007 | 57007
ISCII Panjabi | x-iscii-pa |  | IE5 | Win2000 | 57011 | 57011
ISCII Tamil | x-iscii-ta |  | IE5 | Win2000 | 57004 | 57004
ISCII Telugu | x-iscii-te |  | IE5 | Win2000 | 57005 | 57005
Japanese (EUC) | euc-jp | csEUCPkdFmtJapaneseExtended_UNIX_Code_Packed_牋牋Format_for_Japanesex-eucx-euc-jp | IE5,IE4 | Win95 | 51932 | 932
Japanese (JIS) | iso-2022-jp |  | IE5,IE4 | Win95 | 50220 | 932
Japanese (JIS-Allow 1 byte Kana - SO/SI) | iso-2022-jp | _iso-2022-jp$SIO | IE5 | Win95 | 50222 | 932
Japanese (JIS-Allow 1 byte Kana) | csISO2022JP | _iso-2022-jp$ESC | IE5 | Win95 | 50221 | 932
Japanese (Mac) | x-mac-japanese |  | IE5 | Win2000 | 10001 | 932
Japanese (Shift-JIS) | shift_jis | csShiftJIScsWindows31Jms_Kanjishift-jisx-ms-cp932x-sjis | IE5,IE4 | Win95 | 932 | 932
Korean | ks_c_5601-1987 | csKSC56011987euc-kriso-ir-149koreanks_c_5601ks_c_5601_1987ks_c_5601-1989KSC_5601KSC5601 | IE5 | Win95 | 949 | 949
Korean (EUC) | euc-kr | csEUCKR | IE5 | Win95 | 51949 | 949
Korean (ISO) | iso-2022-kr | csISO2022KR | IE5 | Win95 | 50225 | 949
Korean (Johab) | Johab |  | IE5 | Win2000 | 1361 | 1361
Korean (Mac) | x-mac-korean |  | IE5 | Win2000 | 10003 | 949
Latin 3 (ISO) | iso-8859-3 | csISOLatin3ISO_8859-3ISO_8859-3:1988iso-ir-109l3latin3 | IE5,IE4 | Win95 | 28593 | 1254
Latin 9 (ISO) | iso-8859-15 | csISOLatin9ISO_8859-15l9latin9 | IE5 | Win95 | 28605 | 1252
Norwegian (IA5) | x-IA5-Norwegian |  | IE5 | Win2000 | 20108 | 1252
OEM United States | IBM437 | 437cp437csPC8CodePage437 | IE5 | Win2000 | 437 | 1252
Swedish (IA5) | x-IA5-Swedish |  | IE5 | Win2000 | 20107 | 1252
Thai (Windows) | windows-874 | DOS-874iso-8859-11TIS-620 | IE5,IE4 | Win95 | 874 | 874
Turkish (DOS) | ibm857 |  | IE5 | Win2000 | 857 | 1254
Turkish (ISO) | iso-8859-9 | csISOLatin5ISO_8859-9ISO_8859-9:1989iso-ir-148l5latin5 | IE5 | Win95 | 28599 | 1254
Turkish (Mac) | x-mac-turkish |  | IE5 | Win2000 | 10081 | 1254
Turkish (Windows) | windows-1254 | ISO_8859-9ISO_8859-9:1989iso-8859-9iso-ir-148latin5 | IE5 | Win95 | 1254 | 1254
Unicode | unicode | utf-16 | IE5,IE4 | Win95 | 1200 | 1200
Unicode (Big-Endian) | unicodeFFFE |  | IE5,IE4 | Win95 | 1201 | 1200
Unicode (UTF-7) | utf-7 | csUnicode11UTF7unicode-1-1-utf-7x-unicode-2-0-utf-7 | IE5,IE4 | Win95 | 65000 | 1200
Unicode (UTF-8) | utf-8 | unicode-1-1-utf-8unicode-2-0-utf-8x-unicode-2-0-utf-8 | IE5,IE4 | Win95 | 65001 | 1200
US-ASCII | us-ascii | ANSI_X3.4-1968ANSI_X3.4-1986asciicp367csASCIIIBM367ISO_646.irv:1991ISO646-USiso-ir-6us | IE5 | Win95 | 20127 | 1252
Vietnamese (Windows) | windows-1258 |  | IE5,IE4 | Win95 | 1258 | 1258
Western European (DOS) | ibm850 |  | IE5 | Win2000 | 850 | 1252
Western European (IA5) | x-IA5 |  | IE5 | Win2000 | 20105 | 1252
Western European (ISO) | iso-8859-1 | cp819csISOLatin1ibm819iso_8859-1iso_8859-1:1987iso8859-1iso-ir-100l1latin1 | IE5 | Win95 | 28591 | 1252
Western European (Mac) | macintosh |  | IE5 | Win2000 | 10000 | 1252
Western European (Windows) | Windows-1252 | ANSI_X3.4-1968ANSI_X3.4-1986asciicp367cp819csASCIIIBM367ibm819ISO_646.irv:1991iso_8859-1iso_8859-1:1987ISO646-USiso8859-1iso-8859-1iso-ir-100iso-ir-6latin1usus-asciix-ansi | IE5 | Win95 | 1252 | 1252


ISO Latin-1 Character Set ISO Latin-1字符集

Character 字符 | Decimal code 十进制编码 | Named entity 已命名实体 | Character 字符 | Decimal code 十进制编码 | Named entity 已命名实体
--- | &#00; | --- | --- | &#01; | ---
--- | &#02; | --- | --- | &#03; | ---
--- | &#04; | --- | --- | &#05; | ---
--- | &#06; | --- | --- | &#07; | ---
--- | &#08; | --- | --- | &#09; | ---
--- | &#10; | --- | --- | &#11; | ---
--- | &#12; | --- | --- | &#13; | ---
--- | &#14; | --- | --- | &#15; | ---
--- | &#16; | --- | --- | &#17; | ---
--- | &#18; | --- | --- | &#19; | ---
--- | &#20; | --- | --- | &#21; | ---
--- | &#22; | --- | --- | &#23; | ---
--- | &#24; | --- | --- | &#25; | ---
--- | &#26; | --- | --- | &#27; | ---
--- | &#28; | --- | --- | &#29; | ---
--- | &#30; | --- | --- | &#31; | ---
 | &#32; | --- | ! | &#33; | ---
" | &#34; | &quot; | # | &#35; | ---
$ | &#36; | --- | % | &#37; | ---
& | &#38; | &amp; | ' | &#39; | ---
( | &#40; | --- | ) | &#41; | ---
* | &#42; | --- | + | &#43; | ---
, | &#44; | --- | - | &#45; | ---
. | &#46; | --- | / | &#47; | ---
0 | &#48; | --- | 1 | &#49; | ---
2 | &#50; | --- | 3 | &#51; | ---
4 | &#52; | --- | 5 | &#53; | ---
6 | &#54; | --- | 7 | &#55; | ---
8 | &#56; | --- | 9 | &#57; | ---
: | &#58; | --- | ; | &#59; | ---
< | &#60; | &lt; | = | &#61; | ---
> | &#62; | &gt; | ? | &#63; | ---
@ | &#64; | --- | A | &#65; | ---
B | &#66; | --- | C | &#67; | ---
D | &#68; | --- | E | &#69; | ---
F | &#70; | --- | G | &#71; | ---
H | &#72; | --- | I | &#73; | ---
J | &#74; | --- | K | &#75; | ---
L | &#76; | --- | M | &#77; | ---
N | &#78; | --- | O | &#79; | ---
P | &#80; | --- | Q | &#81; | ---
R | &#82; | --- | S | &#83; | ---
T | &#84; | --- | U | &#85; | ---
V | &#86; | --- | W | &#87; | ---
X | &#88; | --- | Y | &#89; | ---
Z | &#90; | --- | [ | &#91; | ---
\ | &#92; | --- | ] | &#93; | ---
^ | &#94; | --- | _ | &#95; | ---
` | &#96; | --- | a | &#97; | ---
b | &#98; | --- | c | &#99; | ---
d | &#100; | --- | e | &#101; | ---
f | &#102; | --- | g | &#103; | ---
h | &#104; | --- | i | &#105; | ---
j | &#106; | --- | k | &#107; | ---
l | &#108; | --- | m | &#109; | ---
n | &#110; | --- | o | &#111; | ---
p | &#112; | --- | q | &#113; | ---
r | &#114; | --- | s | &#115; | ---
t | &#116; | --- | u | &#117; | ---
v | &#118; | --- | w | &#119; | ---
x | &#120; | --- | y | &#121; | ---
z | &#122; | --- | { | &#123; | ---
| | &#124; | --- | } | &#125; | ---
~ | &#126; | --- | --- | &#127; | ---
 | &#160; | &nbsp; | ¡ | &#161; | &iexcl;
¢ | &#162; | &cent; | £ | &#163; | &pound;
¤ | &#164; | &curren; | ¥ | &#165; | &yen;
¦ | &#166; | &brvbar; or &brkbar; | § | &#167; | &sect;
¨ | &#168; | &uml; or &die; | © | &#169; | &copy;
ª | &#170; | &ordf; | « | &#171; | &laquo;
¬ | &#172; | &not |  | &#173; | &shy;
® | &#174; | &reg; | ¯ | &#175; | &macr; or &hibar;
° | &#176; | &deg; | ± | &#177; | &plusmn;
² | &#178; | &sup2; | ³ | &#179; | &sup3;
´ | &#180; | &acute; | µ | &#181; | &micro;
¶ | &#182; | &para; | · | &#183; | &middot;
¸ | &#184; | &cedil; | ¹ | &#185; | &sup1;
º | &#186; | &ordm; | » | &#187; | &raquo;
¼ | &#188; | &frac14; | ½ | &#189; | &frac12;
¾ | &#190; | &frac34; | ¿ | &#191; | &iquest;
À | &#192; | &Agrave; | Á | &#193; | &Aacute;
Â | &#194; | &Acirc; | Ã | &#195; | &Atilde;
Ä | &#196; | &Auml; | Å | &#197; | &Aring;
Æ | &#198; | &AElig; | Ç | &#199; | &Ccedil;
È | &#200; | &Egrave; | É | &#201; | &Eacute;
Ê | &#202; | &Ecirc; | Ë | &#203; | &Euml;
Ì | &#204; | &Igrave; | Í | &#205; | &Iacute;
Î | &#206; | &Icirc; | Ï | &#207; | &Iuml;
Ð | &#208; | &ETH; | Ñ | &#209; | &Ntilde;
Ò | &#210; | &Ograve; | Ó | &#211; | &Oacute;
Ô | &#212; | &Ocirc; | Õ | &#213; | &Otilde;
Ö | &#214; | &Ouml; | × | &#215; | &times;
Ø | &#216; | &Oslash; | Ù | &#217; | &Ugrave;
Ú | &#218; | &Uacute; | Û | &#219; | &Ucirc;
Ü | &#220; | &Uuml; | Ý | &#221; | &Yacute;
Þ | &#222; | &THORN; | ß | &#223; | &szlig;
à | &#224; | &agrave; | á | &#225; | &aacute;
â | &#226; | &acirc; | ã | &#227; | &atilde;
ä | &#228; | &auml; | å | &#229; | &aring;
æ | &#230; | &aelig; | ç | &#231; | &ccedil;
è | &#232; | &egrave; | é | &#233; | &eacute;
ê | &#234; | &ecirc; | ë | &#235; | &euml;
ì | &#236; | &igrave; | í | &#237; | &iacute;
î | &#238; | &icirc; | ï | &#239; | &iuml;
ð | &#240; | &eth; | ñ | &#241; | &ntilde;
ò | &#242; | &ograve; | ó | &#243; | &oacute;
ô | &#244; | &ocirc; | õ | &#245; | &otilde;
ö | &#246; | &ouml; | ÷ | &#247; | &divide;
ø | &#248; | &oslash; | ù | &#249; | &ugrave;
ú | &#250; | &uacute; | û | &#251; | &ucirc;
ü | &#252; | &uuml; | ý | &#253; | &yacute;
þ | &#254; | &thorn; | ÿ | &#255; | &yuml;

上表包含全部的ISO Latin-1字符集，对应于IE4+中Unicode字符指令表的前256个条目。该表提供了每个字符及字符的十进制编码，HTML已命名实体。


Additional Named Entities for HTML HTML附加命名实体

Character 字符 | Named entity 已命名实体 | Numeric character reference 十进制编码 | Description 简介
扩展拉丁字符 Latin Extended-B
ƒ | &fnof; | &#402; | Latin small f with hook, =function, =florin, U0192 ISOtech
希腊字符 Greek
Α | &Alpha; | &#913; | Greek capital letter alpha, U0391
Β | &Beta; | &#914; | Greek capital letter beta, U0392
Γ | &Gamma; | &#915; | Greek capital letter gamma, U0393 ISOgrk3
Δ | &Delta; | &#916; | Greek capital letter delta, U0394 ISOgrk3
Ε | &Epsilon; | &#917; | Greek capital letter epsilon, U0395
Ζ | &Zeta; | &#918; | Greek capital letter zeta, U0396
Η | &Eta; | &#919; | Greek capital letter eta, U0397
Θ | &Theta; | &#920; | Greek capital letter theta, U0398 ISOgrk3
Ι | &Iota; | &#921; | Greek capital letter iota, U0399
Κ | &Kappa; | &#922; | Greek capital letter kappa, U039A
Λ | &Lambda; | &#923; | Greek capital letter lambda, U039B ISOgrk3
Μ | &Mu; | &#924; | Greek capital letter mu, U039C
Ν | &Nu; | &#925; | Greek capital letter nu, U039D
Ξ | &Xi; | &#926; | Greek capital letter xi, U039E ISOgrk3
Ο | &Omicron; | &#927; | Greek capital letter omicron, U039F
Π | &Pi; | &#928; | Greek capital letter pi, U03A0 ISOgrk3
Ρ | &Rho; | &#929; | Greek capital letter rho, U03A1
Σ | &Sigma; | &#931; | Greek capital letter sigma, U03A3 ISOgrk3
Τ | &Tau; | &#932; | Greek capital letter tau, U03A4
Υ | &Upsilon; | &#933; | Greek capital letter upsilon, U03A5 ISOgrk3
Φ | &Phi; | &#934; | Greek capital letter phi, U03A6 ISOgrk3
Χ | &Chi; | &#935; | Greek capital letter chi, U03A7
Ψ | &Psi; | &#936; | Greek capital letter psi, U03A8 ISOgrk3
Ω | &Omega; | &#937; | Greek capital letter omega, U03A9 ISOgrk3
α | &alpha; | &#945; | Greek small letter alpha, U03B1 ISOgrk3
β | &beta; | &#946; | Greek small letter beta, U03B2 ISOgrk3
γ | &gamma; | &#947; | Greek small letter gamma, U03B3 ISOgrk3
δ | &delta; | &#948; | Greek small letter delta, U03B4 ISOgrk3
ε | &epsilon; | &#949; | Greek small letter epsilon, U03B5 ISOgrk3
ζ | &zeta; | &#950; | Greek small letter zeta, U03B6 ISOgrk3
η | &eta; | &#951; | Greek small letter eta, U03B7 ISOgrk3
θ | &theta; | &#952; | Greek small letter theta, U03B8 ISOgrk3
ι | &iota; | &#953; | Greek small letter iota, U03B9 ISOgrk3
κ | &kappa; | &#954; | Greek small letter kappa, U03BA ISOgrk3
λ | &lambda; | &#955; | Greek small letter lambda, U03BB ISOgrk3
μ | &mu; | &#956; | Greek small letter mu, U03BC ISOgrk3
ν | &nu; | &#957; | Greek small letter nu, U03BD ISOgrk3
ξ | &xi; | &#958; | Greek small letter xi, U03BE ISOgrk3
ο | &omicron; | &#959; | Greek small letter omicron, U03BF NEW
π | &pi; | &#960; | Greek small letter pi, U03C0 ISOgrk3
ρ | &rho; | &#961; | Greek small letter rho, U03C1 ISOgrk3
ς | &sigmaf; | &#962; | Greek small letter final sigma, U03C2 ISOgrk3
σ | &sigma; | &#963; | Greek small letter sigma, U03C3 ISOgrk3
τ | &tau; | &#964; | Greek small letter tau, U03C4 ISOgrk3
υ | &upsilon; | &#965; | Greek small letter upsilon, U03C5 ISOgrk3
φ | &phi; | &#966; | Greek small letter phi, U03C6 ISOgrk3
χ | &chi; | &#967; | Greek small letter chi, U03C7 ISOgrk3
ψ | &psi; | &#968; | Greek small letter psi, U03C8 ISOgrk3
ω | &omega; | &#969; | Greek small letter omega, U03C9 ISOgrk3
ϑ | &thetasym; | &#977; | Greek small letter theta symbol, U03D1 NEW
ϒ | &upsih; | &#978; | Greek upsilon with hook symbol, U03D2 NEW
ϖ | &piv; | &#982; | Greek pi symbol, U03D6 ISOgrk3
通用标点符号 General Punctuation
• | &bull; | &#8226; | bullet, =black small circle, U2022 ISOpub
… | &hellip; | &#8230; | horizontal ellipsis, =three dot leader, U2026 ISOpub
′ | &prime; | &#8242; | prime, =minutes, =feet, U2032 ISOtech
″ | &Prime; | &#8243; | double prime, =seconds, =inches, U2033 ISOtech
‾ | &oline; | &#8254; | overline, =spacing overscore, U203E NEW
⁄ | &frasl; | &#8260; | fraction slash, U2044 NEW
字符标记 Letterlike Symbols
℘ | &weierp; | &#8472; | script capital P, =power set, =Weierstrass p, U2118 ISOamso
ℑ | &image; | &#8465; | blackletter capital I, =imaginary part, U2111 ISOamso
ℜ | &real; | &#8476; | blackletter capital R, =real part symbol, U211C ISOamso
™ | &trade; | &#8482; | trade mark sign, U2122 ISOnum
ℵ | &alefsym; | &#8501; | alef symbol, =first transfinite cardinal, U2135 NEW
箭头 Arrows
← | &larr; | &#8592; | leftward arrow, U2190 ISOnum
↑ | &uarr; | &#8593; | upward arrow, U2191 ISOnum
→ | &rarr; | &#8594; | rightward arrow, U2192 ISOnum
↓ | &darr; | &#8595; | downward arrow, U2193 ISOnum
↔ | &harr; | &#8596; | left right arrow, U2194 ISOamsa
↵ | &crarr; | &#8629; | downward arrow with corner leftward, =carriage return, U21B5 NEW
⇐ | &lArr; | &#8656; | leftward double arrow, U21D0 ISOtech
⇑ | &uArr; | &#8657; | upward double arrow, U21D1 ISOamsa
⇒ | &rArr; | &#8658; | rightward double arrow, U21D2 ISOtech
⇓ | &dArr; | &#8659; | downward double arrow, U21D3 ISOamsa
⇔ | &hArr; | &#8660; | left right double arrow, U21D4 ISOamsa
数学符号 Mathematical Operators
∀ | &forall; | &#8704; | for all, U2200 ISOtech
∂ | &part; | &#8706; | partial differential, U2202 ISOtech
∃ | &exist; | &#8707; | there exists, U2203 ISOtech
∅ | &empty; | &#8709; | empty set, =null set, =diameter, U2205 ISOamso
∇ | &nabla; | &#8711; | nabla, =backward difference, U2207 ISOtech
∈ | &isin; | &#8712; | element of, U2208 ISOtech
∉ | &notin; | &#8713; | not an element of, U2209 ISOtech
∋ | &ni; | &#8715; | contains as member, U220B ISOtech
∏ | &prod; | &#8719; | n-ary product, =product sign, U220F ISOamsb
− | &sum; | &#8722; | n-ary sumation, U2211 ISOamsb
− | &minus; | &#8722; | minus sign, U2212 ISOtech
∗ | &lowast; | &#8727; | asterisk operator, U2217 ISOtech
√ | &radic; | &#8730; | square root, =radical sign, U221A ISOtech
∝ | &prop; | &#8733; | proportional to, U221D ISOtech
∞ | &infin; | &#8734; | infinity, U221E ISOtech
∠ | &ang; | &#8736; | angle, U2220 ISOamso
⊥ | &and; | &#8869; | logical and, =wedge, U2227 ISOtech
⊦ | &or; | &#8870; | logical or, =vee, U2228 ISOtech
∩ | &cap; | &#8745; | intersection, =cap, U2229 ISOtech
∪ | &cup; | &#8746; | union, =cup, U222A ISOtech
∫ | &int; | &#8747; | integral, U222B ISOtech
∴ | &there4; | &#8756; | therefore, U2234 ISOtech
∼ | &sim; | &#8764; | tilde operator, =varies with, =similar to, U223C ISOtech
≅ | &cong; | &#8773; | approximately equal to, U2245 ISOtech
≅ | &asymp; | &#8773; | almost equal to, =asymptotic to, U2248 ISOamsr
≠ | &ne; | &#8800; | not equal to, U2260 ISOtech
≡ | &equiv; | &#8801; | identical to, U2261 ISOtech
≤ | &le; | &#8804; | less-than or equal to, U2264 ISOtech
≥ | &ge; | &#8805; | greater-than or equal to, U2265 ISOtech
⊂ | &sub; | &#8834; | subset of, U2282 ISOtech
⊃ | &sup; | &#8835; | superset of, U2283 ISOtech
⊄ | &nsub; | &#8836; | not a subset of, U2284 ISOamsn
⊆ | &sube; | &#8838; | subset of or equal to, U2286 ISOtech
⊇ | &supe; | &#8839; | superset of or equal to, U2287 ISOtech
⊕ | &oplus; | &#8853; | circled plus, =direct sum, U2295 ISOamsb
⊗ | &otimes; | &#8855; | circled times, =vector product, U2297 ISOamsb
⊥ | &perp; | &#8869; | up tack, =orthogonal to, =perpendicular, U22A5 ISOtech
⋅ | &sdot; | &#8901; | dot operator, U22C5 ISOamsb
其他技术符号 Miscellaneous Technical
⌈ | &lceil; | &#8968; | left ceiling, =apl upstile, U2308, ISOamsc
⌉ | &rceil; | &#8969; | right ceiling, U2309, ISOamsc
⌊ | &lfloor; | &#8970; | left floor, =apl downstile, U230A, ISOamsc
⌋ | &rfloor; | &#8971; | right floor, U230B, ISOamsc
〈 | &lang; | &#9001; | left-pointing angle bracket, =bra, U2329 ISOtech
〉 | &rang; | &#9002; | right-pointing angle bracket, =ket, U232A ISOtech
几何图形 Geometric Shapes
◊ | &loz; | &#9674; | lozenge, U25CA ISOpub
其他标记 Miscellaneous Symbols
♠ | &spades; | &#9824; | black spade suit, U2660 ISOpub
♣ | &clubs; | &#9827; | black club suit, =shamrock, U2663 ISOpub
♥ | &hearts; | &#9829; | black heart suit, =valentine, U2665 ISOpub
♦ | &diams; | &#9830; | black diamond suit, U2666 ISOpub

以上命名实体使用Lucida sans Unicode给出。


DHTMLET® 选择符清单 | 相关内容：
Adjacent Sibling Selectors 相邻选择符

语法：

E1 + E2

说明：

选择紧贴在对象E1之后的所有E2对象。E2和E1对象在文档目录结构树（DOM）中有共同的父对象。
目前IE5.5+尚不支持此种选择符。

示例：

div + p { font-size:14px; }
/* 所有紧贴在div对象之后的p对象的字体尺寸为14px */

div.fly + p { font-size:14px; }