Easy CHM - http://www.eTextWizard.com

您现在使用的CHM文件由Easy CHM的未注册版本制作而成。
注册版本不会在CHM里自动添加此页面。

制作时使用的Easy CHM程序版本号：v3.92
制作日期：2013/07/29

Easy CHM 软件 软件出品: 国华软件 中国北京 |  | 截屏图片
免费下载最新的试用版 | 文件大小: 2989k - 2.84MB | 软件类型: 共享软件 购买注册: 这里

关键词: make chm, create chm, chm制作工具, chm电子书制作工具,chm帮助文件制作工具

描述:

Easy CHM是国华软件推出的一款强大的CHM电子书或CHM帮助文件的快速制作工具。

使用EasyCHM只需要三个步骤就可以完成CHM的制作：
1、用户指定一个目录，EasyCHM会自动导入全部目录及文件;
2、设置CHM编译选项;
3、开始制作。

EasyCHM非常适合个人和单位制作高压缩比的带有全文检索及高亮显示搜索结果的网页集锦、CHM帮助文件、产品说明、公司介绍、CHM电子书等等。

主要功能：

  • 全自动的目录及文件导入（可以包括子目录）;
  • EasyCHM支持导入任意的文件类型;
  • EasyCHM操作速度快，性能稳定，EasyCHM因为上手容易深得广大用户好评;
  • EasyCHM自动生成CHM的目录列表并自动生成所有目录项;
  • 为CHM的目录列表自动添加多级编号;
  • 在编辑目录项、索引项时用到的移动、拖拽、替换等操作中Easy CHM完全支持多选及拖拽操作，避免了一项一项地操作，极大的减少用户手工 － 非常适合企业维护大型CHM帮助文档;
  • 支持批量查找替换多级目录各项的标题文字内容;
  • 允许用户指定从文本文件的第N行自动截取标题;
  • 易用的目录/索引编辑器;
  • 丰富实用的CHM制作选项帮助用户制作更加个性化的专业CHM电子书或CHM帮助文件;
  • EasyCHM自动生成输出Alias和Map头文件;
  • EasyCHM自动生成上下文相关的帮助文件（ContextID），适合于软件公司制作专业的支持Help Context ID的专业帮助文件;
  • EasyCHM可以保存工程文件，方便企业用户编辑维护文档。
  • 批量更换CHM目录各项的图标;
  • 内嵌CHM反编译工具
  • 更多功能

EasyCHM未注册版本的主要限制：

  1. EasyCHM的未注册版本可以制作带任意层级目录的CHM，但是每个CHM的工具栏上都会自动添加一个ABOUT按钮，以提醒用户注册。
    注册版本不会添加ABOUT按钮。
  2. EasyCHM的未注册版本无法保存CHM的通用工程文件，如*.HHP、*.HHC、*.HHK等。
    未注册版本的EasyCHM会自动删除*.HHP、*.HHC、*.HHK这几个文件。
  3. 未注册版本制作的CHM标题上会有Made by UNREGISTERED version of Easy CHM这样的提示您试用的是未注册版本的文字。

注册版本无任何限制，也不会再显示ABOUT按钮或者提示注册的文字。
如果EasyCHM可以为您的工作和学习提供帮助，请注册购买，感谢您给予软件作者的支持。
联系方式:
国华软件站点一: http://www.etextwizard.com
国华软件站点二: http://www.zipghost.com
技术支持信箱: webmaster@etextwizard.com
购买方式:
在线购买:（可提供发票，支持很多种支付方式，包括在线支付、银行电汇、邮政汇款等）
通过“共享软件注册中心”购买单用户企业版

通过“共享软件注册中心”购买单用户家庭版
直接向国华软件注册购买（共3种方式）：
1、招商银行划款:
开户行： 招商银行北京分行双榆树支行
帐 号： 001015570093
户 名： 冯国华
2、中国农业银行金穗卡转帐（注意是卡号）：
金穗卡卡号： 95599 8001 42061 34216
收 款 人： 冯国华
3、中国工商银行牡丹灵通卡转帐：

开户城市：北京
牡丹灵通卡卡号：9558 8202 0000 3186295 （注意是卡号9558820200003186295）
收 款 人： 冯国华

注意事项：
直接向作者注册的用户请在汇出足额的注册费后以EMAIL形式通知作者，同时请尽量提供

  • 汇款日期

  • 汇出城市

  • 您汇到哪个银行帐号？

  • 汇款人姓名

  • 用于接收注册码的信箱（请确保可以接收邮件，最好多提供）

  • 您希望使用的注册用户名（程序将授权给这个用户）

  • 要注册的软件名称及套数

您提供的资料详细些会比较方便确认。
作者在确认支付已完成后将会马上发出注册码。
用户在收到注册信后请尽量给软件作者发个类似“已收到注册码”的确认信 - 感谢您的配合！
免费下载最新的试用版:
http://www.etextwizard.com/cn/download/ecdown.html

系统需求: Win98, WinME, WinXP, Win2000,WinVista, Win7
安装支持: 支持安装及卸载


com.adobe.utils - Away3D Documentation

Package com.adobe.utils

Classes
AGALMiniAssembler


com.adobe.utils Summary

Away3D Documentation | All Packages | All Classes | Index | Frames No Frames | Adobe Logo
com.adobe.utils | Classes

Classes
Class | Description
AGALMiniAssembler |

Thu Nov 15 2012, 12:09 PM Z


com.adobe.utils.AGALMiniAssembler

AGALMiniAssembler | Properties | Methods | Constants
Package | com.adobe.utils
Class | public class AGALMiniAssembler
Inheritance | AGALMiniAssembler Inheritance Object

Public Properties
Property |  | Defined By
 | agalcode : ByteArray [read-only] | AGALMiniAssembler
 | error : String [read-only] | AGALMiniAssembler
 | verbose : Boolean = false | AGALMiniAssembler
Public Methods
Method |  | Defined By
 | AGALMiniAssembler(debugging:Boolean = false) | AGALMiniAssembler
 | assemble(mode:String, source:String):ByteArray | AGALMiniAssembler
Protected Constants
Constant |  | Defined By
 | REGEXP_OUTER_SPACES : RegExp [static] | AGALMiniAssembler
 | USE_NEW_SYNTAX : Boolean = false [static] | AGALMiniAssembler
Property Detail
agalcode property
agalcode:ByteArray [read-only]

Implementation
    public function get agalcode():ByteArray
error property
error:String [read-only]

Implementation
    public function get error():String
verbose property
public var verbose:Boolean = false

Constructor Detail
AGALMiniAssembler () Constructor
public function AGALMiniAssembler(debugging:Boolean = false)

Parameters
debugging:Boolean (default = false)
Method Detail
assemble () method
public function assemble(mode:String, source:String):ByteArray

Parameters

mode:String
source:String

Returns
ByteArray
Constant Detail
REGEXP_OUTER_SPACES Constant
protected static const REGEXP_OUTER_SPACES:RegExp

USE_NEW_SYNTAX Constant
protected static const USE_NEW_SYNTAX:Boolean = false

Thu Nov 15 2012, 12:08 PM Z


away3d - Away3D Documentation

Package away3d

Classes
Away3D


away3d Summary

away3d | Classes

Classes
Class | Description
Away3D | Helper class to track a few important library constants.

Thu Nov 15 2012, 12:09 PM Z


away3d.Away3D

Away3D | Constants
Package | away3d
Class | public class Away3D
Inheritance | Away3D Inheritance Object

Helper class to track a few important library constants.

Public Constants
Constant |  | Defined By
 | MAJOR_VERSION : uint = 4 [static] | Away3D
 | MINOR_VERSION : uint = 1 [static] | Away3D
 | REVISION : uint = 0 [static] | Away3D
 | WEBSITE_URL : String = http://www.away3d.com [static] | Away3D
Constant Detail
MAJOR_VERSION Constant
public static const MAJOR_VERSION:uint = 4

MINOR_VERSION Constant
public static const MINOR_VERSION:uint = 1

REVISION Constant
public static const REVISION:uint = 0

WEBSITE_URL Constant
public static const WEBSITE_URL:String = http://www.away3d.com


away3d.animators - Away3D Documentation

Package away3d.animators

Interfaces
IAnimationSet
IAnimator
Classes
AnimationSetBase
AnimatorBase
ParticleAnimationSet
ParticleAnimator
PathAnimator
SkeletonAnimationSet
SkeletonAnimator
UVAnimationSet
UVAnimator
VertexAnimationSet
VertexAnimator


away3d.animators Summary

away3d.animators | Interfaces | Classes

Interfaces
Interface | Description
IAnimationSet | Provides an interface for data set classes that hold animation data for use in animator classes.
IAnimator | Provides an interface for animator classes that control animation output from a data set subtype of AnimationSetBase.
Classes
Class | Description
AnimationSetBase | Provides an abstract base class for data set classes that hold animation data for use in animator classes.
AnimatorBase | Provides an abstract base class for animator classes that control animation output from a data set subtype of AnimationSetBase.
ParticleAnimationSet | The animation data set used by particle-based animators, containing particle animation data.
ParticleAnimator | Provides an interface for assigning paricle-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.
PathAnimator |
SkeletonAnimationSet | The animation data set used by skeleton-based animators, containing skeleton animation data.
SkeletonAnimator | Provides an interface for assigning skeleton-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.
UVAnimationSet | The animation data set used by uv-based animators, containing uv animation state data.
UVAnimator | Provides an interface for assigning uv-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.
VertexAnimationSet | The animation data set used by vertex-based animators, containing vertex animation state data.
VertexAnimator | Provides an interface for assigning vertex-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.

Thu Nov 15 2012, 12:09 PM Z


away3d.animators.AnimationSetBase

AnimationSetBase | Properties | Methods | Constants
Package | away3d.animators
Class | public class AnimationSetBase
Inheritance | AnimationSetBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IAsset
Subclasses | ParticleAnimationSet, SkeletonAnimationSet, UVAnimationSet, VertexAnimationSet

Provides an abstract base class for data set classes that hold animation data for use in animator classes.

See also

away3d.animators.AnimatorBase

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | animationNames : Vector.<String> [read-only] Returns a vector of animation state objects that make up the contents of the animation data set. | AnimationSetBase
 | animations : Vector.<AnimationNodeBase> [read-only] Returns a vector of animation state objects that make up the contents of the animation data set. | AnimationSetBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
 | assetType : String [read-only] | AnimationSetBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | usesCPU : Boolean [read-only] Indicates whether the properties of the animation data contained within the set combined with the vertex registers aslready in use on shading materials allows the animation data to utilise GPU calls. | AnimationSetBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | addAnimation(node:AnimationNodeBase):void Adds an animation state object to the aniamtion data set under the given name. | AnimationSetBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | cancelGPUCompatibility():void | AnimationSetBase
 | dispose():void Cleans up any resources used by the current object. | AnimationSetBase
 | getAnimation(name:String):AnimationNodeBase Retrieves the animation state object registered in the animation data set under the given name. | AnimationSetBase
 | hasAnimation(name:String):Boolean Check to determine whether a state is registered in the animation set under the given name. | AnimationSetBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Method |  | Defined By
 | findTempReg(exclude:Vector.<String>, excludeAnother:String = null):String Retrieves a temporary GPU register that's still free. | AnimationSetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
animationNames property
animationNames:Vector.<String> [read-only]

Returns a vector of animation state objects that make up the contents of the animation data set.

Implementation
    public function get animationNames():Vector.<String>
animations property
animations:Vector.<AnimationNodeBase> [read-only]

Returns a vector of animation state objects that make up the contents of the animation data set.

Implementation
    public function get animations():Vector.<AnimationNodeBase>
assetType property
assetType:String [read-only]

Implementation
    public function get assetType():String
usesCPU property
usesCPU:Boolean [read-only]

Indicates whether the properties of the animation data contained within the set combined with the vertex registers aslready in use on shading materials allows the animation data to utilise GPU calls.

Implementation
    public function get usesCPU():Boolean
Method Detail
addAnimation () method
public function addAnimation(node:AnimationNodeBase):void

Adds an animation state object to the aniamtion data set under the given name.

Parameters

node:AnimationNodeBase — The name under which the animation state object will be stored.

cancelGPUCompatibility () method
public function cancelGPUCompatibility():void

dispose () method
public function dispose():void

Cleans up any resources used by the current object.

findTempReg () method
protected function findTempReg(exclude:Vector.<String>, excludeAnother:String = null):String

Retrieves a temporary GPU register that's still free.

Parameters

exclude:Vector.<String> — An array of non-free temporary registers.
excludeAnother:String (default = null) — An additional register that's not free.

Returns
String — A temporary register that can be used.
getAnimation () method
public function getAnimation(name:String):AnimationNodeBase

Retrieves the animation state object registered in the animation data set under the given name.

Parameters

name:String — The name of the animation state object to be retrieved.

Returns
AnimationNodeBase
hasAnimation () method
public function hasAnimation(name:String):Boolean

Check to determine whether a state is registered in the animation set under the given name.

Parameters

name:String — The name of the animation state object to be checked.

Returns
Boolean


away3d.animators.AnimatorBase

AnimatorBase | Properties | Methods | Events
Package | away3d.animators
Class | public class AnimatorBase
Inheritance | AnimatorBase Inheritance flash.events.EventDispatcher
Subclasses | ParticleAnimator, SkeletonAnimator, UVAnimator, VertexAnimator

Provides an abstract base class for animator classes that control animation output from a data set subtype of AnimationSetBase.

See also

away3d.animators.AnimationSetBase

Public Properties
Property |  | Defined By
 | absoluteTime : Number [read-only] Returns the internal absolute time of the animator, calculated by the current time and the playback speed. | AnimatorBase
 | activeAnimation : AnimationNodeBase [read-only] Returns the current active animation node. | AnimatorBase
 | activeAnimationName : String [read-only] Returns the current active animation node. | AnimatorBase
 | activeState : IAnimationState [read-only] Returns the current active animation state. | AnimatorBase
 | animationSet : IAnimationSet [read-only] Returns the animation data set in use by the animator. | AnimatorBase
 | autoUpdate : Boolean Determines whether the animators internal update mechanisms are active. | AnimatorBase
 | playbackSpeed : Number The amount by which passed time should be scaled. | AnimatorBase
 | time : int Gets and sets the internal time clock of the animator. | AnimatorBase
 | updatePosition : Boolean = true Enables translation of the animated mesh from data returned per frame via the positionDelta property of the active animation node. | AnimatorBase
Protected Properties
Property |  | Defined By
 | _absoluteTime : Number = 0 | AnimatorBase
 | _activeNode : AnimationNodeBase | AnimatorBase
 | _activeState : IAnimationState | AnimatorBase
 | _animationSet : IAnimationSet | AnimatorBase
 | _name : String | AnimatorBase
 | _owners : Vector.<Mesh> | AnimatorBase
Public Methods
Method |  | Defined By
 | AnimatorBase(animationSet:IAnimationSet) Creates a new AnimatorBase object. | AnimatorBase
 | getAnimationState(node:AnimationNodeBase):AnimationStateBase | AnimatorBase
 | getAnimationStateByName(name:String):AnimationStateBase | AnimatorBase
 | phase(value:Number):void Sets the animation phase of the current active state's animation clip(s). | AnimatorBase
 | reset(name:String, offset:Number = 0):void | AnimatorBase
 | start():void Resumes the automatic playback clock controling the active state of the animator. | AnimatorBase
 | stop():void Pauses the automatic playback clock of the animator, in case manual updates are required via the time property or update() method. | AnimatorBase
 | update(time:int):void Provides a way to manually update the active state of the animator when automatic updates are disabled. | AnimatorBase
Events
Event |  | Summary | Defined By
 | start | Dispatched when playback of an animation inside the animator object starts. | AnimatorBase
 | stop | Dispatched when playback of an animation inside the animator object stops. | AnimatorBase
Property Detail
_absoluteTime property
protected var _absoluteTime:Number = 0

_activeNode property
protected var _activeNode:AnimationNodeBase

_activeState property
protected var _activeState:IAnimationState

_animationSet property
protected var _animationSet:IAnimationSet

_name property
protected var _name:String

_owners property
protected var _owners:Vector.<Mesh>

absoluteTime property
absoluteTime:Number [read-only]

Returns the internal absolute time of the animator, calculated by the current time and the playback speed.

Implementation
    public function get absoluteTime():Number

See also

time
playbackSpeed
activeAnimation property
activeAnimation:AnimationNodeBase [read-only]

Returns the current active animation node.

Implementation
    public function get activeAnimation():AnimationNodeBase
activeAnimationName property
activeAnimationName:String [read-only]

Returns the current active animation node.

Implementation
    public function get activeAnimationName():String
activeState property
activeState:IAnimationState [read-only]

Returns the current active animation state.

Implementation
    public function get activeState():IAnimationState
animationSet property
animationSet:IAnimationSet [read-only]

Returns the animation data set in use by the animator.

Implementation
    public function get animationSet():IAnimationSet
autoUpdate property
autoUpdate:Boolean

Determines whether the animators internal update mechanisms are active. Used in cases where manual updates are required either via the time property or update() method. Defaults to true.

Implementation
    public function get autoUpdate():Boolean
    public function set autoUpdate(value:Boolean):void

See also

time
update()
playbackSpeed property
playbackSpeed:Number

The amount by which passed time should be scaled. Used to slow down or speed up animations. Defaults to 1.

Implementation
    public function get playbackSpeed():Number
    public function set playbackSpeed(value:Number):void
time property
time:int

Gets and sets the internal time clock of the animator.

Implementation
    public function get time():int
    public function set time(value:int):void
updatePosition property
public var updatePosition:Boolean = true

Enables translation of the animated mesh from data returned per frame via the positionDelta property of the active animation node. Defaults to true.

See also

away3d.animators.states.IAnimationState.positionDelta
Constructor Detail
AnimatorBase () Constructor
public function AnimatorBase(animationSet:IAnimationSet)

Creates a new AnimatorBase object.

Parameters
animationSet:IAnimationSet — The animation data set to be used by the animator object.
Method Detail
getAnimationState () method
public function getAnimationState(node:AnimationNodeBase):AnimationStateBase

Parameters

node:AnimationNodeBase

Returns
AnimationStateBase
getAnimationStateByName () method
public function getAnimationStateByName(name:String):AnimationStateBase

Parameters

name:String

Returns
AnimationStateBase
phase () method
public function phase(value:Number):void

Sets the animation phase of the current active state's animation clip(s).

Parameters

value:Number — The phase value to use. 0 represents the beginning of an animation clip, 1 represents the end.

reset () method
public function reset(name:String, offset:Number = 0):void

Parameters

name:String
offset:Number (default = 0)

start () method
public function start():void

Resumes the automatic playback clock controling the active state of the animator.

stop () method
public function stop():void

Pauses the automatic playback clock of the animator, in case manual updates are required via the time property or update() method.

See also

time
update()
update () method
public function update(time:int):void

Provides a way to manually update the active state of the animator when automatic updates are disabled.

Parameters

time:int

See also

stop()
autoUpdate
Event Detail
start Event
Event Object Type: away3d.events.AnimatorEvent
AnimatorEvent.type property = away3d.events.AnimatorEvent

Dispatched when playback of an animation inside the animator object starts.

stop Event
Event Object Type: away3d.events.AnimatorEvent
AnimatorEvent.type property = away3d.events.AnimatorEvent

Dispatched when playback of an animation inside the animator object stops.


away3d.animators.IAnimationSet

IAnimationSet | Properties | Methods
Package | away3d.animators
Interface | public interface IAnimationSet
Implementors | ParticleAnimationSet, SkeletonAnimationSet, UVAnimationSet, VertexAnimationSet

Provides an interface for data set classes that hold animation data for use in animator classes.

See also

away3d.animators.IAnimator

Public Properties
Property |  | Defined By
 | usesCPU : Boolean [read-only] Indicates whether the properties of the animation data contained within the set combined with the vertex registers aslready in use on shading materials allows the animation data to utilise GPU calls. | IAnimationSet
Public Methods
Method |  | Defined By
 | getAnimation(name:String):AnimationNodeBase Retrieves the animation state object registered in the animation data set under the given name. | IAnimationSet
 | hasAnimation(name:String):Boolean Check to determine whether a state is registered in the animation set under the given name. | IAnimationSet
Property Detail
usesCPU property
usesCPU:Boolean [read-only]

Indicates whether the properties of the animation data contained within the set combined with the vertex registers aslready in use on shading materials allows the animation data to utilise GPU calls.

Implementation
    public function get usesCPU():Boolean
Method Detail
getAnimation () method
public function getAnimation(name:String):AnimationNodeBase

Retrieves the animation state object registered in the animation data set under the given name.

Parameters

name:String — The name of the animation state object to be retrieved.

Returns
AnimationNodeBase
hasAnimation () method
public function hasAnimation(name:String):Boolean

Check to determine whether a state is registered in the animation set under the given name.

Parameters

name:String — The name of the animation state object to be checked.

Returns
Boolean


away3d.animators.IAnimator

IAnimator | Properties | Methods
Package | away3d.animators
Interface | public interface IAnimator
Implementors | ParticleAnimator, SkeletonAnimator, UVAnimator, VertexAnimator

Provides an interface for animator classes that control animation output from a data set subtype of AnimationSetBase.

See also

away3d.animators.IAnimationSet

Public Properties
Property |  | Defined By
 | animationSet : IAnimationSet [read-only] Returns the animation data set in use by the animator. | IAnimator
Public Methods
Method |  | Defined By
 | getAnimationState(node:AnimationNodeBase):AnimationStateBase | IAnimator
 | getAnimationStateByName(name:String):AnimationStateBase | IAnimator
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:Camera3D):void Sets the GPU render state required by the animation that is dependent of the rendered object. | IAnimator
 | testGPUCompatibility(pass:MaterialPassBase):void Verifies if the animation will be used on cpu. | IAnimator
Property Detail
animationSet property
animationSet:IAnimationSet [read-only]

Returns the animation data set in use by the animator.

Implementation
    public function get animationSet():IAnimationSet
Method Detail
getAnimationState () method
public function getAnimationState(node:AnimationNodeBase):AnimationStateBase

Parameters

node:AnimationNodeBase

Returns
AnimationStateBase
getAnimationStateByName () method
public function getAnimationStateByName(name:String):AnimationStateBase

Parameters

name:String

Returns
AnimationStateBase
setRenderState () method
public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:Camera3D):void

Sets the GPU render state required by the animation that is dependent of the rendered object.

Parameters

stage3DProxy:Stage3DProxy — The Stage3DProxy object which is currently being used for rendering.
renderable:IRenderable — The object currently being rendered.
vertexConstantOffset:int — The first available vertex register to write data to if running on the gpu.
vertexStreamOffset:int — The first available vertex stream to write vertex data to if running on the gpu.
camera:Camera3D

testGPUCompatibility () method
public function testGPUCompatibility(pass:MaterialPassBase):void

Verifies if the animation will be used on cpu. Needs to be true for all passes for a material to be able to use it on gpu. Needs to be called if gpu code is potentially required.

Parameters

pass:MaterialPassBase


away3d.animators.ParticleAnimationSet

ParticleAnimationSet | Properties | Methods | Constants
Package | away3d.animators
Class | public class ParticleAnimationSet
Inheritance | ParticleAnimationSet Inheritance AnimationSetBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IAnimationSet

The animation data set used by particle-based animators, containing particle animation data.

See also

away3d.animators.ParticleAnimator

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animationNames : Vector.<String> [read-only] Returns a vector of animation state objects that make up the contents of the animation data set. | AnimationSetBase
Inherited | animations : Vector.<AnimationNodeBase> [read-only] Returns a vector of animation state objects that make up the contents of the animation data set. | AnimationSetBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationSetBase
 | hasBillboard : Boolean | ParticleAnimationSet
 | hasColorNode : Boolean | ParticleAnimationSet
 | hasUVNode : Boolean | ParticleAnimationSet
 | initParticleFunc : Function Initialiser function for static particle properties. | ParticleAnimationSet
Inherited | name : String | NamedAssetBase
 | needVelocity : Boolean | ParticleAnimationSet
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | particleNodes : Vector.<ParticleNodeBase> [read-only] Returns a vector of the particle animation nodes contained within the set. | ParticleAnimationSet
 | usesCPU : Boolean [override] [read-only] Indicates whether the properties of the animation data contained within the set combined with the vertex registers aslready in use on shading materials allows the animation data to utilise GPU calls. | ParticleAnimationSet
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleAnimationSet(usesDuration:Boolean = false, usesLooping:Boolean = false, usesDelay:Boolean = false) Creates a new ParticleAnimationSet | ParticleAnimationSet
 | activate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void | ParticleAnimationSet
 | addAnimation(node:AnimationNodeBase):void [override] Adds an animation state object to the aniamtion data set under the given name. | ParticleAnimationSet
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | cancelGPUCompatibility():void [override] | ParticleAnimationSet
 | deactivate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void | ParticleAnimationSet
Inherited | dispose():void Cleans up any resources used by the current object. | AnimationSetBase
 | doneAGALCode(pass:MaterialPassBase):void | ParticleAnimationSet
 | getAGALFragmentCode(pass:MaterialPassBase, shadedTarget:String):String | ParticleAnimationSet
 | getAGALUVCode(pass:MaterialPassBase, UVSource:String, UVTarget:String):String | ParticleAnimationSet
 | getAGALVertexCode(pass:MaterialPassBase, sourceRegisters:Vector.<String>, targetRegisters:Vector.<String>):String | ParticleAnimationSet
Inherited | getAnimation(name:String):AnimationNodeBase Retrieves the animation state object registered in the animation data set under the given name. | AnimationSetBase
Inherited | hasAnimation(name:String):Boolean Check to determine whether a state is registered in the animation set under the given name. | AnimationSetBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | findTempReg(exclude:Vector.<String>, excludeAnother:String = null):String Retrieves a temporary GPU register that's still free. | AnimationSetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
 | POST_PRIORITY : int = 9 [static] Property used by particle nodes that require compilation at the end of the shader | ParticleAnimationSet
Property Detail
hasBillboard property
public var hasBillboard:Boolean

hasColorNode property
public var hasColorNode:Boolean

hasUVNode property
public var hasUVNode:Boolean

initParticleFunc property
public var initParticleFunc:Function

Initialiser function for static particle properties. Needs to reference a function with teh following format function initParticleFunc(prop:ParticleProperties):void { //code for settings local properties } Aside from setting any properties required in particle animation nodes using local static properties, the initParticleFunc function is required to time node requirements as they may be needed. These properties on the ParticleProperties object can include startTime, duration and delay. The use of these properties is determined by the setting arguments passed in the constructor of the particle animation set. By default, only the startTime property is required.

needVelocity property
public var needVelocity:Boolean

particleNodes property
particleNodes:Vector.<ParticleNodeBase> [read-only]

Returns a vector of the particle animation nodes contained within the set.

Implementation
    public function get particleNodes():Vector.<ParticleNodeBase>
usesCPU property
usesCPU:Boolean [read-only] [override]

Indicates whether the properties of the animation data contained within the set combined with the vertex registers aslready in use on shading materials allows the animation data to utilise GPU calls.

Implementation
    public function get usesCPU():Boolean
Constructor Detail
ParticleAnimationSet () Constructor
public function ParticleAnimationSet(usesDuration:Boolean = false, usesLooping:Boolean = false, usesDelay:Boolean = false)

Creates a new ParticleAnimationSet

Parameters
usesDuration:Boolean (default = false) — usesDuration Defines whether the animation set uses the duration data in its static properties function to determine how long a particle is visible for. Defaults to false.
usesLooping:Boolean (default = false) — usesLooping Defines whether the animation set uses a looping timeframe for each particle determined by the startTime, duration and delay data in its static properties function. Defaults to false. Requires usesDuration to be true.
usesDelay:Boolean (default = false) — usesDelay Defines whether the animation set uses the delay data in its static properties function to determine how long a particle is hidden for. Defaults to false. Requires usesLooping to be true.
Method Detail
activate () method
public function activate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void

Parameters

stage3DProxy:Stage3DProxy
pass:MaterialPassBase

addAnimation () method
override public function addAnimation(node:AnimationNodeBase):void

Adds an animation state object to the aniamtion data set under the given name.

Parameters

node:AnimationNodeBase — The name under which the animation state object will be stored.

cancelGPUCompatibility () method
override public function cancelGPUCompatibility():void

deactivate () method
public function deactivate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void

Parameters

stage3DProxy:Stage3DProxy
pass:MaterialPassBase

doneAGALCode () method
public function doneAGALCode(pass:MaterialPassBase):void

Parameters

pass:MaterialPassBase

getAGALFragmentCode () method
public function getAGALFragmentCode(pass:MaterialPassBase, shadedTarget:String):String

Parameters

pass:MaterialPassBase
shadedTarget:String

Returns
String
getAGALUVCode () method
public function getAGALUVCode(pass:MaterialPassBase, UVSource:String, UVTarget:String):String

Parameters

pass:MaterialPassBase
UVSource:String
UVTarget:String

Returns
String
getAGALVertexCode () method
public function getAGALVertexCode(pass:MaterialPassBase, sourceRegisters:Vector.<String>, targetRegisters:Vector.<String>):String

Parameters

pass:MaterialPassBase
sourceRegisters:Vector.<String>
targetRegisters:Vector.<String>

Returns
String
Constant Detail
POST_PRIORITY Constant
public static const POST_PRIORITY:int = 9

Property used by particle nodes that require compilation at the end of the shader


away3d.animators.ParticleAnimator

ParticleAnimator | Properties | Methods | Events
Package | away3d.animators
Class | public class ParticleAnimator
Inheritance | ParticleAnimator Inheritance AnimatorBase Inheritance flash.events.EventDispatcher
Implements | IAnimator

Provides an interface for assigning paricle-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered. Requires that the containing geometry of the parent mesh is particle geometry

See also

away3d.core.base.ParticleGeometry

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | absoluteTime : Number [read-only] Returns the internal absolute time of the animator, calculated by the current time and the playback speed. | AnimatorBase
Inherited | activeAnimation : AnimationNodeBase [read-only] Returns the current active animation node. | AnimatorBase
Inherited | activeAnimationName : String [read-only] Returns the current active animation node. | AnimatorBase
Inherited | activeState : IAnimationState [read-only] Returns the current active animation state. | AnimatorBase
Inherited | animationSet : IAnimationSet [read-only] Returns the animation data set in use by the animator. | AnimatorBase
Inherited | autoUpdate : Boolean Determines whether the animators internal update mechanisms are active. | AnimatorBase
Inherited | playbackSpeed : Number The amount by which passed time should be scaled. | AnimatorBase
Inherited | time : int Gets and sets the internal time clock of the animator. | AnimatorBase
Inherited | updatePosition : Boolean = true Enables translation of the animated mesh from data returned per frame via the positionDelta property of the active animation node. | AnimatorBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _absoluteTime : Number = 0 | AnimatorBase
Inherited | _activeNode : AnimationNodeBase | AnimatorBase
Inherited | _activeState : IAnimationState | AnimatorBase
Inherited | _animationSet : IAnimationSet | AnimatorBase
Inherited | _name : String | AnimatorBase
Inherited | _owners : Vector.<Mesh> | AnimatorBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleAnimator(particleAnimationSet:ParticleAnimationSet) Creates a new ParticleAnimator object. | ParticleAnimator
Inherited | getAnimationState(node:AnimationNodeBase):AnimationStateBase | AnimatorBase
Inherited | getAnimationStateByName(name:String):AnimationStateBase | AnimatorBase
Inherited | phase(value:Number):void Sets the animation phase of the current active state's animation clip(s). | AnimatorBase
Inherited | reset(name:String, offset:Number = 0):void | AnimatorBase
 | resetTime(offset:int = 0):void | ParticleAnimator
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:Camera3D):void Sets the GPU render state required by the animation that is dependent of the rendered object. | ParticleAnimator
 | start():void [override] Resumes the automatic playback clock controling the active state of the animator. | ParticleAnimator
Inherited | stop():void Pauses the automatic playback clock of the animator, in case manual updates are required via the time property or update() method. | AnimatorBase
 | testGPUCompatibility(pass:MaterialPassBase):void Verifies if the animation will be used on cpu. | ParticleAnimator
Inherited | update(time:int):void Provides a way to manually update the active state of the animator when automatic updates are disabled. | AnimatorBase
Protected Methods
Method |  | Defined By
 | updateDeltaTime(dt:Number):void [override] | ParticleAnimator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | start | Dispatched when playback of an animation inside the animator object starts. | AnimatorBase
Inherited | stop | Dispatched when playback of an animation inside the animator object stops. | AnimatorBase
Constructor Detail
ParticleAnimator () Constructor
public function ParticleAnimator(particleAnimationSet:ParticleAnimationSet)

Creates a new ParticleAnimator object.

Parameters
particleAnimationSet:ParticleAnimationSet — The animation data set containing the particle animations used by the animator.
Method Detail
resetTime () method
public function resetTime(offset:int = 0):void

Parameters

offset:int (default = 0)

setRenderState () method
public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:Camera3D):void

Sets the GPU render state required by the animation that is dependent of the rendered object.

Parameters

stage3DProxy:Stage3DProxy — The Stage3DProxy object which is currently being used for rendering.
renderable:IRenderable — The object currently being rendered.
vertexConstantOffset:int — The first available vertex register to write data to if running on the gpu.
vertexStreamOffset:int — The first available vertex stream to write vertex data to if running on the gpu.
camera:Camera3D

start () method
override public function start():void

Resumes the automatic playback clock controling the active state of the animator.

testGPUCompatibility () method
public function testGPUCompatibility(pass:MaterialPassBase):void

Verifies if the animation will be used on cpu. Needs to be true for all passes for a material to be able to use it on gpu. Needs to be called if gpu code is potentially required.

Parameters

pass:MaterialPassBase

updateDeltaTime () method
override protected function updateDeltaTime(dt:Number):void

Parameters

dt:Number


away3d.animators.PathAnimator

PathAnimator | Properties | Methods
Package | away3d.animators
Class | public class PathAnimator
Inheritance | PathAnimator Inheritance flash.events.EventDispatcher
Deprecated: Deprecated

Public Properties
Property |  | Defined By
 | alignToPath : Boolean defines if the object animated along the path must be aligned to the path. | PathAnimator
 | index : uint Set the pointer to a given segment along the path | PathAnimator
 | lookAtObject : Object3D sets the object that the animated object will be looking at along the path | PathAnimator
 | orientation : Vector3D [read-only] returns the actual interpolated rotation along the path. | PathAnimator
 | path : IPath defines the path to follow | PathAnimator
 | position : Vector3D [read-only] returns the current interpolated position on the path with no optional offset applied | PathAnimator
 | progress : Number Represents the progress of the animation playhead from the start (0) to the end (1) of the animation. | PathAnimator
 | rotations : Vector.<Vector3D> [write-only] sets an optional Vector.<Vector3D> of rotations. | PathAnimator
 | target : Object3D sets the object to be animated along the path. | PathAnimator
 | upAxis : Vector3D | PathAnimator
Public Methods
Method |  | Defined By
 | PathAnimator(path:IPath = null, target:Object3D = null, offset:Vector3D = null, alignToPath:Boolean = true, lookAtTarget:Object3D = null, rotations:Vector.<Vector3D> = null) Creates a new PathAnimator | PathAnimator
 | addOnChangeSegment(listener:Function):void Default method for adding a segmentchange event listener. | PathAnimator
 | addOnCycle(listener:Function):void Default method for adding a cycle event listener. | PathAnimator
 | addOnRange(listener:Function, from:Number = 0, to:Number = 0):void Default method for adding a range event listener. | PathAnimator
 | getPositionOnPath(t:Number, out:Vector3D):Vector3D Updates a position Vector3D on the path at a given time. | PathAnimator
 | getPositionOnPathMS(ms:Number, duration:Number, out:Vector3D):Vector3D Returns a position on the path according to duration/elapsed time. | PathAnimator
 | getTimeSegment(t:Number):Number returns the segment index that is used at a given time; | PathAnimator
 | removeOnChangeSegment(listener:Function):void Default method for removing a range event listener | PathAnimator
 | removeOnCycle(listener:Function):void Default method for removing a cycle event listener | PathAnimator
 | removeOnRange(listener:Function):void Default method for removing a range event listener | PathAnimator
 | setOffset(x:Number = 0, y:Number = 0, z:Number = 0):void sets an optional offset to the position on the path, ideal for cameras or reusing the same Path object for parallel animations | PathAnimator
 | updateProgress(t:Number):void Calculates the new position and set the object on the path accordingly | PathAnimator
Property Detail
alignToPath property
alignToPath:Boolean

defines if the object animated along the path must be aligned to the path.

Implementation
    public function get alignToPath():Boolean
    public function set alignToPath(value:Boolean):void
index property
index:uint

Set the pointer to a given segment along the path

Implementation
    public function get index():uint
    public function set index(value:uint):void
lookAtObject property
lookAtObject:Object3D

sets the object that the animated object will be looking at along the path

Implementation
    public function get lookAtObject():Object3D
    public function set lookAtObject(value:Object3D):void
orientation property
orientation:Vector3D [read-only]

returns the actual interpolated rotation along the path.

Implementation
    public function get orientation():Vector3D
path property
path:IPath

defines the path to follow

Implementation
    public function get path():IPath
    public function set path(value:IPath):void

See also

Path
position property
position:Vector3D [read-only]

returns the current interpolated position on the path with no optional offset applied

Implementation
    public function get position():Vector3D
progress property
progress:Number

Represents the progress of the animation playhead from the start (0) to the end (1) of the animation.

Implementation
    public function get progress():Number
    public function set progress(value:Number):void
rotations property
rotations:Vector.<Vector3D> [write-only]

sets an optional Vector.<Vector3D> of rotations. if the object3d is animated along a PathExtrude object, use the very same vector to follow the "curves".

Implementation
    public function set rotations(value:Vector.<Vector3D>):void
target property
target:Object3D

sets the object to be animated along the path.

Implementation
    public function get target():Object3D
    public function set target(value:Object3D):void
upAxis property
upAxis:Vector3D

Implementation
    public function get upAxis():Vector3D
    public function set upAxis(value:Vector3D):void
Constructor Detail
PathAnimator () Constructor
public function PathAnimator(path:IPath = null, target:Object3D = null, offset:Vector3D = null, alignToPath:Boolean = true, lookAtTarget:Object3D = null, rotations:Vector.<Vector3D> = null)

Creates a new PathAnimator

Parameters
path:IPath (default = null) — path The QuadraticPath to animate onto.
target:Object3D (default = null) — target An Object3D, the object to animate along the path. It can be Mesh, Camera, ObjectContainer3D...
offset:Vector3D (default = null) — offset A Vector3D to define the target offset to its location on the path.
alignToPath:Boolean (default = true) — alignToPath Defines if the object animated along the path is orientated to the path. Default is true.
lookAtTarget:Object3D (default = null) — lookAtTarget An Object3D that the target will constantly look at during animation.
rotations:Vector.<Vector3D> (default = null) — rotations A Vector.<Vector3D> to define rotations per pathsegments. If PathExtrude is used to simulate the "road", use the very same rotations vector.
Method Detail
addOnChangeSegment () method
public function addOnChangeSegment(listener:Function):void

Default method for adding a segmentchange event listener. Event fired when the time pointer enters another PathSegment.

Parameters

listener:Function — The listener function

addOnCycle () method
public function addOnCycle(listener:Function):void

Default method for adding a cycle event listener. Event fired when the time reaches 1.

Parameters

listener:Function — The listener function

addOnRange () method
public function addOnRange(listener:Function, from:Number = 0, to:Number = 0):void

Default method for adding a range event listener. Event fired when the time is >= from and <= to variables.

Parameters

listener:Function — The listener function
from:Number (default = 0)
to:Number (default = 0)

getPositionOnPath () method
public function getPositionOnPath(t:Number, out:Vector3D):Vector3D

Updates a position Vector3D on the path at a given time. Do not use this handler to animate, it's in there to add dummy's or place camera before or after the animated object. Use the update() or the automatic tweened animateOnPath() handlers instead.

Parameters

t:Number — Number. A Number from 0 to 1
out:Vector3D — Vector3D. The Vector3D to update according to the "t" time parameter.

Returns
Vector3D
getPositionOnPathMS () method
public function getPositionOnPathMS(ms:Number, duration:Number, out:Vector3D):Vector3D

Returns a position on the path according to duration/elapsed time. Duration variable must be set.

Parameters

ms:Number — Number. A number representing milliseconds.
duration:Number — Number. The total duration in milliseconds.
out:Vector3D — [optional] Vector3D. A Vector3D that will be used to return the position. If none provided, method returns a new Vector3D with this data. An example of use of this handler would be cases where a given "lap" must be done in a given amount of time and you would want to retrieve the "ideal" time based on elapsed time since start of the race. By comparing actual progress to ideal time, you could extract their classement, calculate distance/time between competitors, abort the race if goal is impossible to be reached in time etc... returns Vector3D The position at a given elapsed time, compared to total duration.

Returns
Vector3D
getTimeSegment () method
public function getTimeSegment(t:Number):Number

returns the segment index that is used at a given time;

Parameters

t:Number (default = NaN) — [Number]. A Number between 0 and 1. If no params, actual pathanimator time segment index is returned.

Returns
Number
removeOnChangeSegment () method
public function removeOnChangeSegment(listener:Function):void

Default method for removing a range event listener

Parameters

listener:Function — The listener function

removeOnCycle () method
public function removeOnCycle(listener:Function):void

Default method for removing a cycle event listener

Parameters

listener:Function — The listener function

removeOnRange () method
public function removeOnRange(listener:Function):void

Default method for removing a range event listener

Parameters

listener:Function — The listener function

setOffset () method
public function setOffset(x:Number = 0, y:Number = 0, z:Number = 0):void

sets an optional offset to the position on the path, ideal for cameras or reusing the same Path object for parallel animations

Parameters

x:Number (default = 0)
y:Number (default = 0)
z:Number (default = 0)

updateProgress () method
public function updateProgress(t:Number):void

Calculates the new position and set the object on the path accordingly

Parameters

t:Number — A Number from 0 to 1 (less than one to allow alignToPath)


away3d.animators.SkeletonAnimationSet

SkeletonAnimationSet | Properties | Methods | Constants
Package | away3d.animators
Class | public class SkeletonAnimationSet
Inheritance | SkeletonAnimationSet Inheritance AnimationSetBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IAnimationSet

The animation data set used by skeleton-based animators, containing skeleton animation data.

See also

away3d.animators.SkeletonAnimator

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animationNames : Vector.<String> [read-only] Returns a vector of animation state objects that make up the contents of the animation data set. | AnimationSetBase
Inherited | animations : Vector.<AnimationNodeBase> [read-only] Returns a vector of animation state objects that make up the contents of the animation data set. | AnimationSetBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationSetBase
 | jointsPerVertex : uint [read-only] Returns the amount of skeleton joints that can be linked to a single vertex via skinned weight values. | SkeletonAnimationSet
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | usesCPU : Boolean [read-only] Indicates whether the properties of the animation data contained within the set combined with the vertex registers aslready in use on shading materials allows the animation data to utilise GPU calls. | AnimationSetBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkeletonAnimationSet(jointsPerVertex:uint = 4) Creates a new SkeletonAnimationSet object. | SkeletonAnimationSet
 | activate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void | SkeletonAnimationSet
Inherited | addAnimation(node:AnimationNodeBase):void Adds an animation state object to the aniamtion data set under the given name. | AnimationSetBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | cancelGPUCompatibility():void | AnimationSetBase
 | deactivate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void | SkeletonAnimationSet
Inherited | dispose():void Cleans up any resources used by the current object. | AnimationSetBase
 | doneAGALCode(pass:MaterialPassBase):void | SkeletonAnimationSet
 | getAGALFragmentCode(pass:MaterialPassBase, shadedTarget:String):String | SkeletonAnimationSet
 | getAGALUVCode(pass:MaterialPassBase, UVSource:String, UVTarget:String):String | SkeletonAnimationSet
 | getAGALVertexCode(pass:MaterialPassBase, sourceRegisters:Vector.<String>, targetRegisters:Vector.<String>):String | SkeletonAnimationSet
Inherited | getAnimation(name:String):AnimationNodeBase Retrieves the animation state object registered in the animation data set under the given name. | AnimationSetBase
Inherited | hasAnimation(name:String):Boolean Check to determine whether a state is registered in the animation set under the given name. | AnimationSetBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | findTempReg(exclude:Vector.<String>, excludeAnother:String = null):String Retrieves a temporary GPU register that's still free. | AnimationSetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
jointsPerVertex property
jointsPerVertex:uint [read-only]

Returns the amount of skeleton joints that can be linked to a single vertex via skinned weight values. For GPU-base animation, the maximum allowed value is 4.

Implementation
    public function get jointsPerVertex():uint
Constructor Detail
SkeletonAnimationSet () Constructor
public function SkeletonAnimationSet(jointsPerVertex:uint = 4)

Creates a new SkeletonAnimationSet object.

Parameters
jointsPerVertex:uint (default = 4) — Sets the amount of skeleton joints that can be linked to a single vertex via skinned weight values. For GPU-base animation, the maximum allowed value is 4. Defaults to 4.
Method Detail
activate () method
public function activate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void

Parameters

stage3DProxy:Stage3DProxy
pass:MaterialPassBase

deactivate () method
public function deactivate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void

Parameters

stage3DProxy:Stage3DProxy
pass:MaterialPassBase

doneAGALCode () method
public function doneAGALCode(pass:MaterialPassBase):void

Parameters

pass:MaterialPassBase

getAGALFragmentCode () method
public function getAGALFragmentCode(pass:MaterialPassBase, shadedTarget:String):String

Parameters

pass:MaterialPassBase
shadedTarget:String

Returns
String
getAGALUVCode () method
public function getAGALUVCode(pass:MaterialPassBase, UVSource:String, UVTarget:String):String

Parameters

pass:MaterialPassBase
UVSource:String
UVTarget:String

Returns
String
getAGALVertexCode () method
public function getAGALVertexCode(pass:MaterialPassBase, sourceRegisters:Vector.<String>, targetRegisters:Vector.<String>):String

Parameters

pass:MaterialPassBase
sourceRegisters:Vector.<String>
targetRegisters:Vector.<String>

Returns
String


away3d.animators.SkeletonAnimator

SkeletonAnimator | Properties | Methods | Events
Package | away3d.animators
Class | public class SkeletonAnimator
Inheritance | SkeletonAnimator Inheritance AnimatorBase Inheritance flash.events.EventDispatcher
Implements | IAnimator

Provides an interface for assigning skeleton-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | absoluteTime : Number [read-only] Returns the internal absolute time of the animator, calculated by the current time and the playback speed. | AnimatorBase
Inherited | activeAnimation : AnimationNodeBase [read-only] Returns the current active animation node. | AnimatorBase
Inherited | activeAnimationName : String [read-only] Returns the current active animation node. | AnimatorBase
Inherited | activeState : IAnimationState [read-only] Returns the current active animation state. | AnimatorBase
Inherited | animationSet : IAnimationSet [read-only] Returns the animation data set in use by the animator. | AnimatorBase
Inherited | autoUpdate : Boolean Determines whether the animators internal update mechanisms are active. | AnimatorBase
 | forceCPU : Boolean [read-only] Indicates whether the skeleton animator is disabled by default for GPU rendering, something that allows the animator to perform calculation on the GPU. | SkeletonAnimator
 | globalMatrices : Vector.<Number> [read-only] returns the calculated global matrices of the current skeleton pose. | SkeletonAnimator
 | globalPose : SkeletonPose [read-only] returns the current skeleton pose output from the animator. | SkeletonAnimator
Inherited | playbackSpeed : Number The amount by which passed time should be scaled. | AnimatorBase
 | skeleton : Skeleton [read-only] Returns the skeleton object in use by the animator - this defines the number and heirarchy of joints used by the skinned geoemtry to which skeleon animator is applied. | SkeletonAnimator
Inherited | time : int Gets and sets the internal time clock of the animator. | AnimatorBase
Inherited | updatePosition : Boolean = true Enables translation of the animated mesh from data returned per frame via the positionDelta property of the active animation node. | AnimatorBase
 | useCondensedIndices : Boolean Offers the option of enabling GPU accelerated animation on skeletons larger than 32 joints by condensing the number of joint index values required per mesh. | SkeletonAnimator
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _absoluteTime : Number = 0 | AnimatorBase
Inherited | _activeNode : AnimationNodeBase | AnimatorBase
Inherited | _activeState : IAnimationState | AnimatorBase
Inherited | _animationSet : IAnimationSet | AnimatorBase
Inherited | _name : String | AnimatorBase
Inherited | _owners : Vector.<Mesh> | AnimatorBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkeletonAnimator(animationSet:SkeletonAnimationSet, skeleton:Skeleton, forceCPU:Boolean = false) Creates a new SkeletonAnimator object. | SkeletonAnimator
Inherited | getAnimationState(node:AnimationNodeBase):AnimationStateBase | AnimatorBase
Inherited | getAnimationStateByName(name:String):AnimationStateBase | AnimatorBase
Inherited | phase(value:Number):void Sets the animation phase of the current active state's animation clip(s). | AnimatorBase
 | play(name:String, transition:IAnimationTransition = null, offset:Number):void Plays an animation state registered with the given name in the animation data set. | SkeletonAnimator
Inherited | reset(name:String, offset:Number = 0):void | AnimatorBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:Camera3D):void Sets the GPU render state required by the animation that is dependent of the rendered object. | SkeletonAnimator
Inherited | start():void Resumes the automatic playback clock controling the active state of the animator. | AnimatorBase
Inherited | stop():void Pauses the automatic playback clock of the animator, in case manual updates are required via the time property or update() method. | AnimatorBase
 | testGPUCompatibility(pass:MaterialPassBase):void Verifies if the animation will be used on cpu. | SkeletonAnimator
Inherited | update(time:int):void Provides a way to manually update the active state of the animator when automatic updates are disabled. | AnimatorBase
Protected Methods
Method |  | Defined By
 | updateDeltaTime(dt:Number):void [override] Applies the calculated time delta to the active animation state node or state transition object. | SkeletonAnimator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | start | Dispatched when playback of an animation inside the animator object starts. | AnimatorBase
Inherited | stop | Dispatched when playback of an animation inside the animator object stops. | AnimatorBase
Property Detail
forceCPU property
forceCPU:Boolean [read-only]

Indicates whether the skeleton animator is disabled by default for GPU rendering, something that allows the animator to perform calculation on the GPU. Defaults to false.

Implementation
    public function get forceCPU():Boolean
globalMatrices property
globalMatrices:Vector.<Number> [read-only]

returns the calculated global matrices of the current skeleton pose.

Implementation
    public function get globalMatrices():Vector.<Number>

See also

globalPose
globalPose property
globalPose:SkeletonPose [read-only]

returns the current skeleton pose output from the animator.

Implementation
    public function get globalPose():SkeletonPose

See also

away3d.animators.data.SkeletonPose
skeleton property
skeleton:Skeleton [read-only]

Returns the skeleton object in use by the animator - this defines the number and heirarchy of joints used by the skinned geoemtry to which skeleon animator is applied.

Implementation
    public function get skeleton():Skeleton
useCondensedIndices property
useCondensedIndices:Boolean

Offers the option of enabling GPU accelerated animation on skeletons larger than 32 joints by condensing the number of joint index values required per mesh. Only applicable to skeleton animations that utilise more than one mesh object. Defaults to false.

Implementation
    public function get useCondensedIndices():Boolean
    public function set useCondensedIndices(value:Boolean):void
Constructor Detail
SkeletonAnimator () Constructor
public function SkeletonAnimator(animationSet:SkeletonAnimationSet, skeleton:Skeleton, forceCPU:Boolean = false)

Creates a new SkeletonAnimator object.

Parameters
animationSet:SkeletonAnimationSet — The animation data set containing the skeleton animations used by the animator.
skeleton:Skeleton — The skeleton object used for calculating the resulting global matrices for transforming skinned mesh data.
forceCPU:Boolean (default = false) — Optional value that only allows the animator to perform calculation on the CPU. Defaults to false.
Method Detail
play () method
public function play(name:String, transition:IAnimationTransition = null, offset:Number):void

Plays an animation state registered with the given name in the animation data set.

Parameters

name:String — The data set name of the animation state to be played.
transition:IAnimationTransition (default = null) — An optional transition object that determines how the animator will transition from the currently active animation state.
offset:Number (default = NaN)

setRenderState () method
public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:Camera3D):void

Sets the GPU render state required by the animation that is dependent of the rendered object.

Parameters

stage3DProxy:Stage3DProxy — The Stage3DProxy object which is currently being used for rendering.
renderable:IRenderable — The object currently being rendered.
vertexConstantOffset:int — The first available vertex register to write data to if running on the gpu.
vertexStreamOffset:int — The first available vertex stream to write vertex data to if running on the gpu.
camera:Camera3D

testGPUCompatibility () method
public function testGPUCompatibility(pass:MaterialPassBase):void

Verifies if the animation will be used on cpu. Needs to be true for all passes for a material to be able to use it on gpu. Needs to be called if gpu code is potentially required.

Parameters

pass:MaterialPassBase

updateDeltaTime () method
override protected function updateDeltaTime(dt:Number):void

Applies the calculated time delta to the active animation state node or state transition object.

Parameters

dt:Number


away3d.animators.UVAnimationSet

UVAnimationSet | Properties | Methods | Constants
Package | away3d.animators
Class | public class UVAnimationSet
Inheritance | UVAnimationSet Inheritance AnimationSetBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IAnimationSet

The animation data set used by uv-based animators, containing uv animation state data.

See also

away3d.animators.UVAnimator
away3d.animators.UVAnimationState

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animationNames : Vector.<String> [read-only] Returns a vector of animation state objects that make up the contents of the animation data set. | AnimationSetBase
Inherited | animations : Vector.<AnimationNodeBase> [read-only] Returns a vector of animation state objects that make up the contents of the animation data set. | AnimationSetBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationSetBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | usesCPU : Boolean [read-only] Indicates whether the properties of the animation data contained within the set combined with the vertex registers aslready in use on shading materials allows the animation data to utilise GPU calls. | AnimationSetBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | activate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void | UVAnimationSet
Inherited | addAnimation(node:AnimationNodeBase):void Adds an animation state object to the aniamtion data set under the given name. | AnimationSetBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | cancelGPUCompatibility():void | AnimationSetBase
 | deactivate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void | UVAnimationSet
Inherited | dispose():void Cleans up any resources used by the current object. | AnimationSetBase
 | doneAGALCode(pass:MaterialPassBase):void | UVAnimationSet
 | getAGALFragmentCode(pass:MaterialPassBase, shadedTarget:String):String | UVAnimationSet
 | getAGALUVCode(pass:MaterialPassBase, UVSource:String, UVTarget:String):String | UVAnimationSet
 | getAGALVertexCode(pass:MaterialPassBase, sourceRegisters:Vector.<String>, targetRegisters:Vector.<String>):String | UVAnimationSet
Inherited | getAnimation(name:String):AnimationNodeBase Retrieves the animation state object registered in the animation data set under the given name. | AnimationSetBase
Inherited | hasAnimation(name:String):Boolean Check to determine whether a state is registered in the animation set under the given name. | AnimationSetBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | findTempReg(exclude:Vector.<String>, excludeAnother:String = null):String Retrieves a temporary GPU register that's still free. | AnimationSetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Method Detail
activate () method
public function activate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void

Parameters

stage3DProxy:Stage3DProxy
pass:MaterialPassBase

deactivate () method
public function deactivate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void

Parameters

stage3DProxy:Stage3DProxy
pass:MaterialPassBase

doneAGALCode () method
public function doneAGALCode(pass:MaterialPassBase):void

Parameters

pass:MaterialPassBase

getAGALFragmentCode () method
public function getAGALFragmentCode(pass:MaterialPassBase, shadedTarget:String):String

Parameters

pass:MaterialPassBase
shadedTarget:String

Returns
String
getAGALUVCode () method
public function getAGALUVCode(pass:MaterialPassBase, UVSource:String, UVTarget:String):String

Parameters

pass:MaterialPassBase
UVSource:String
UVTarget:String

Returns
String
getAGALVertexCode () method
public function getAGALVertexCode(pass:MaterialPassBase, sourceRegisters:Vector.<String>, targetRegisters:Vector.<String>):String

Parameters

pass:MaterialPassBase
sourceRegisters:Vector.<String>
targetRegisters:Vector.<String>

Returns
String


away3d.animators.UVAnimator

UVAnimator | Properties | Methods | Events
Package | away3d.animators
Class | public class UVAnimator
Inheritance | UVAnimator Inheritance AnimatorBase Inheritance flash.events.EventDispatcher
Implements | IAnimator

Provides an interface for assigning uv-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | absoluteTime : Number [read-only] Returns the internal absolute time of the animator, calculated by the current time and the playback speed. | AnimatorBase
Inherited | activeAnimation : AnimationNodeBase [read-only] Returns the current active animation node. | AnimatorBase
Inherited | activeAnimationName : String [read-only] Returns the current active animation node. | AnimatorBase
Inherited | activeState : IAnimationState [read-only] Returns the current active animation state. | AnimatorBase
Inherited | animationSet : IAnimationSet [read-only] Returns the animation data set in use by the animator. | AnimatorBase
Inherited | autoUpdate : Boolean Determines whether the animators internal update mechanisms are active. | AnimatorBase
Inherited | playbackSpeed : Number The amount by which passed time should be scaled. | AnimatorBase
Inherited | time : int Gets and sets the internal time clock of the animator. | AnimatorBase
Inherited | updatePosition : Boolean = true Enables translation of the animated mesh from data returned per frame via the positionDelta property of the active animation node. | AnimatorBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _absoluteTime : Number = 0 | AnimatorBase
Inherited | _activeNode : AnimationNodeBase | AnimatorBase
Inherited | _activeState : IAnimationState | AnimatorBase
Inherited | _animationSet : IAnimationSet | AnimatorBase
Inherited | _name : String | AnimatorBase
Inherited | _owners : Vector.<Mesh> | AnimatorBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | UVAnimator(uvAnimationSet:UVAnimationSet) Creates a new UVAnimator object. | UVAnimator
Inherited | getAnimationState(node:AnimationNodeBase):AnimationStateBase | AnimatorBase
Inherited | getAnimationStateByName(name:String):AnimationStateBase | AnimatorBase
Inherited | phase(value:Number):void Sets the animation phase of the current active state's animation clip(s). | AnimatorBase
 | play(name:String, transition:IAnimationTransition = null, offset:Number):void | UVAnimator
Inherited | reset(name:String, offset:Number = 0):void | AnimatorBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:Camera3D):void Sets the GPU render state required by the animation that is dependent of the rendered object. | UVAnimator
Inherited | start():void Resumes the automatic playback clock controling the active state of the animator. | AnimatorBase
Inherited | stop():void Pauses the automatic playback clock of the animator, in case manual updates are required via the time property or update() method. | AnimatorBase
 | testGPUCompatibility(pass:MaterialPassBase):void Verifies if the animation will be used on cpu. | UVAnimator
Inherited | update(time:int):void Provides a way to manually update the active state of the animator when automatic updates are disabled. | AnimatorBase
Protected Methods
Method |  | Defined By
 | updateDeltaTime(dt:Number):void [override] Applies the calculated time delta to the active animation state node. | UVAnimator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | start | Dispatched when playback of an animation inside the animator object starts. | AnimatorBase
Inherited | stop | Dispatched when playback of an animation inside the animator object stops. | AnimatorBase
Constructor Detail
UVAnimator () Constructor
public function UVAnimator(uvAnimationSet:UVAnimationSet)

Creates a new UVAnimator object.

Parameters
uvAnimationSet:UVAnimationSet — The animation data set containing the uv animations used by the animator.
Method Detail
play () method
public function play(name:String, transition:IAnimationTransition = null, offset:Number):void

Parameters

name:String
transition:IAnimationTransition (default = null)
offset:Number (default = NaN)

setRenderState () method
public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:Camera3D):void

Sets the GPU render state required by the animation that is dependent of the rendered object.

Parameters

stage3DProxy:Stage3DProxy — The Stage3DProxy object which is currently being used for rendering.
renderable:IRenderable — The object currently being rendered.
vertexConstantOffset:int — The first available vertex register to write data to if running on the gpu.
vertexStreamOffset:int — The first available vertex stream to write vertex data to if running on the gpu.
camera:Camera3D

testGPUCompatibility () method
public function testGPUCompatibility(pass:MaterialPassBase):void

Verifies if the animation will be used on cpu. Needs to be true for all passes for a material to be able to use it on gpu. Needs to be called if gpu code is potentially required.

Parameters

pass:MaterialPassBase

updateDeltaTime () method
override protected function updateDeltaTime(dt:Number):void

Applies the calculated time delta to the active animation state node.

Parameters

dt:Number


away3d.animators.VertexAnimationSet

VertexAnimationSet | Properties | Methods | Constants
Package | away3d.animators
Class | public class VertexAnimationSet
Inheritance | VertexAnimationSet Inheritance AnimationSetBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IAnimationSet

The animation data set used by vertex-based animators, containing vertex animation state data.

See also

away3d.animators.VertexAnimator

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animationNames : Vector.<String> [read-only] Returns a vector of animation state objects that make up the contents of the animation data set. | AnimationSetBase
Inherited | animations : Vector.<AnimationNodeBase> [read-only] Returns a vector of animation state objects that make up the contents of the animation data set. | AnimationSetBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationSetBase
 | blendMode : String [read-only] Returns the active blend mode of the vertex animator object. | VertexAnimationSet
Inherited | name : String | NamedAssetBase
 | numPoses : uint [read-only] Returns the number of poses made available at once to the GPU animation code. | VertexAnimationSet
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | useNormals : Boolean [read-only] Returns whether or not normal data is used in last set GPU pass of the vertex shader. | VertexAnimationSet
Inherited | usesCPU : Boolean [read-only] Indicates whether the properties of the animation data contained within the set combined with the vertex registers aslready in use on shading materials allows the animation data to utilise GPU calls. | AnimationSetBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | VertexAnimationSet(numPoses:uint = 2, blendMode:String = absolute) Creates a new VertexAnimationSet object. | VertexAnimationSet
 | activate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void | VertexAnimationSet
Inherited | addAnimation(node:AnimationNodeBase):void Adds an animation state object to the aniamtion data set under the given name. | AnimationSetBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | cancelGPUCompatibility():void | AnimationSetBase
 | deactivate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void | VertexAnimationSet
Inherited | dispose():void Cleans up any resources used by the current object. | AnimationSetBase
 | doneAGALCode(pass:MaterialPassBase):void | VertexAnimationSet
 | getAGALFragmentCode(pass:MaterialPassBase, shadedTarget:String):String | VertexAnimationSet
 | getAGALUVCode(pass:MaterialPassBase, UVSource:String, UVTarget:String):String | VertexAnimationSet
 | getAGALVertexCode(pass:MaterialPassBase, sourceRegisters:Vector.<String>, targetRegisters:Vector.<String>):String | VertexAnimationSet
Inherited | getAnimation(name:String):AnimationNodeBase Retrieves the animation state object registered in the animation data set under the given name. | AnimationSetBase
Inherited | hasAnimation(name:String):Boolean Check to determine whether a state is registered in the animation set under the given name. | AnimationSetBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | findTempReg(exclude:Vector.<String>, excludeAnother:String = null):String Retrieves a temporary GPU register that's still free. | AnimationSetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
blendMode property
blendMode:String [read-only]

Returns the active blend mode of the vertex animator object.

Implementation
    public function get blendMode():String
numPoses property
numPoses:uint [read-only]

Returns the number of poses made available at once to the GPU animation code.

Implementation
    public function get numPoses():uint
useNormals property
useNormals:Boolean [read-only]

Returns whether or not normal data is used in last set GPU pass of the vertex shader.

Implementation
    public function get useNormals():Boolean
Constructor Detail
VertexAnimationSet () Constructor
public function VertexAnimationSet(numPoses:uint = 2, blendMode:String = absolute)

Creates a new VertexAnimationSet object.

Parameters
numPoses:uint (default = 2) — The number of poses made available at once to the GPU animation code.
blendMode:String (default = absolute) — Optional value for setting the animation mode of the vertex animator object.

See also

away3d.animators.data.VertexAnimationMode
Method Detail
activate () method
public function activate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void

Parameters

stage3DProxy:Stage3DProxy
pass:MaterialPassBase

deactivate () method
public function deactivate(stage3DProxy:Stage3DProxy, pass:MaterialPassBase):void

Parameters

stage3DProxy:Stage3DProxy
pass:MaterialPassBase

doneAGALCode () method
public function doneAGALCode(pass:MaterialPassBase):void

Parameters

pass:MaterialPassBase

getAGALFragmentCode () method
public function getAGALFragmentCode(pass:MaterialPassBase, shadedTarget:String):String

Parameters

pass:MaterialPassBase
shadedTarget:String

Returns
String
getAGALUVCode () method
public function getAGALUVCode(pass:MaterialPassBase, UVSource:String, UVTarget:String):String

Parameters

pass:MaterialPassBase
UVSource:String
UVTarget:String

Returns
String
getAGALVertexCode () method
public function getAGALVertexCode(pass:MaterialPassBase, sourceRegisters:Vector.<String>, targetRegisters:Vector.<String>):String

Parameters

pass:MaterialPassBase
sourceRegisters:Vector.<String>
targetRegisters:Vector.<String>

Returns
String


away3d.animators.VertexAnimator

VertexAnimator | Properties | Methods | Events
Package | away3d.animators
Class | public class VertexAnimator
Inheritance | VertexAnimator Inheritance AnimatorBase Inheritance flash.events.EventDispatcher
Implements | IAnimator

Provides an interface for assigning vertex-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | absoluteTime : Number [read-only] Returns the internal absolute time of the animator, calculated by the current time and the playback speed. | AnimatorBase
Inherited | activeAnimation : AnimationNodeBase [read-only] Returns the current active animation node. | AnimatorBase
Inherited | activeAnimationName : String [read-only] Returns the current active animation node. | AnimatorBase
Inherited | activeState : IAnimationState [read-only] Returns the current active animation state. | AnimatorBase
Inherited | animationSet : IAnimationSet [read-only] Returns the animation data set in use by the animator. | AnimatorBase
Inherited | autoUpdate : Boolean Determines whether the animators internal update mechanisms are active. | AnimatorBase
Inherited | playbackSpeed : Number The amount by which passed time should be scaled. | AnimatorBase
Inherited | time : int Gets and sets the internal time clock of the animator. | AnimatorBase
Inherited | updatePosition : Boolean = true Enables translation of the animated mesh from data returned per frame via the positionDelta property of the active animation node. | AnimatorBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _absoluteTime : Number = 0 | AnimatorBase
Inherited | _activeNode : AnimationNodeBase | AnimatorBase
Inherited | _activeState : IAnimationState | AnimatorBase
Inherited | _animationSet : IAnimationSet | AnimatorBase
Inherited | _name : String | AnimatorBase
Inherited | _owners : Vector.<Mesh> | AnimatorBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | VertexAnimator(vertexAnimationSet:VertexAnimationSet) Creates a new VertexAnimator object. | VertexAnimator
Inherited | getAnimationState(node:AnimationNodeBase):AnimationStateBase | AnimatorBase
Inherited | getAnimationStateByName(name:String):AnimationStateBase | AnimatorBase
Inherited | phase(value:Number):void Sets the animation phase of the current active state's animation clip(s). | AnimatorBase
 | play(name:String, transition:IAnimationTransition = null, offset:Number):void Plays a sequence with a given name. | VertexAnimator
Inherited | reset(name:String, offset:Number = 0):void | AnimatorBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:Camera3D):void Sets the GPU render state required by the animation that is dependent of the rendered object. | VertexAnimator
Inherited | start():void Resumes the automatic playback clock controling the active state of the animator. | AnimatorBase
Inherited | stop():void Pauses the automatic playback clock of the animator, in case manual updates are required via the time property or update() method. | AnimatorBase
 | testGPUCompatibility(pass:MaterialPassBase):void Verifies if the animation will be used on cpu. | VertexAnimator
Inherited | update(time:int):void Provides a way to manually update the active state of the animator when automatic updates are disabled. | AnimatorBase
Protected Methods
Method |  | Defined By
 | updateDeltaTime(dt:Number):void [override] | VertexAnimator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | start | Dispatched when playback of an animation inside the animator object starts. | AnimatorBase
Inherited | stop | Dispatched when playback of an animation inside the animator object stops. | AnimatorBase
Constructor Detail
VertexAnimator () Constructor
public function VertexAnimator(vertexAnimationSet:VertexAnimationSet)

Creates a new VertexAnimator object.

Parameters
vertexAnimationSet:VertexAnimationSet — The animation data set containing the vertex animations used by the animator.
Method Detail
play () method
public function play(name:String, transition:IAnimationTransition = null, offset:Number):void

Plays a sequence with a given name. If the sequence is not found, it may not be loaded yet, and it will retry every frame.

Parameters

name:String — The name of the clip to be played.
transition:IAnimationTransition (default = null)
offset:Number (default = NaN)

setRenderState () method
public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:Camera3D):void

Sets the GPU render state required by the animation that is dependent of the rendered object.

Parameters

stage3DProxy:Stage3DProxy — The Stage3DProxy object which is currently being used for rendering.
renderable:IRenderable — The object currently being rendered.
vertexConstantOffset:int — The first available vertex register to write data to if running on the gpu.
vertexStreamOffset:int — The first available vertex stream to write vertex data to if running on the gpu.
camera:Camera3D

testGPUCompatibility () method
public function testGPUCompatibility(pass:MaterialPassBase):void

Verifies if the animation will be used on cpu. Needs to be true for all passes for a material to be able to use it on gpu. Needs to be called if gpu code is potentially required.

Parameters

pass:MaterialPassBase

updateDeltaTime () method
override protected function updateDeltaTime(dt:Number):void

Parameters

dt:Number


away3d.animators.data - Away3D Documentation

Package away3d.animators.data

Classes
AnimationRegisterCache
AnimationSubGeometry
JointPose
ParticleAnimationData
ParticleProperties
ParticlePropertiesMode
Skeleton
SkeletonJoint
SkeletonPose
UVAnimationFrame
VertexAnimationMode


away3d.animators.data Summary

away3d.animators.data | Classes

Classes
Class | Description
AnimationRegisterCache | ...
AnimationSubGeometry | ...
JointPose | Contains transformation data for a skeleton joint, used for skeleton animation.
ParticleAnimationData | ...
ParticleProperties | Dynamic class for holding the local properties of a particle, used for processing the static properties of particles in the particle animation set before beginning upload to the GPU.
ParticlePropertiesMode | Options for setting the properties mode of a particle animation node.
Skeleton | A Skeleton object is a hierarchical grouping of joint objects that can be used for skeletal animation.
SkeletonJoint | A value obect representing a single joint in a skeleton object.
SkeletonPose | A collection of pose objects, determining the pose for an entire skeleton.
UVAnimationFrame | A value object for a single frame of animation in a UVClipNode object.
VertexAnimationMode | Options for setting the animation mode of a vertex animator object.

Thu Nov 15 2012, 12:09 PM Z


away3d.animators.data.AnimationRegisterCache

AnimationRegisterCache | Properties | Methods
Package | away3d.animators.data
Class | public class AnimationRegisterCache
Inheritance | AnimationRegisterCache Inheritance ShaderRegisterCache Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | colorTarget : ShaderRegisterElement | AnimationRegisterCache
 | fragmentConstantData : Vector.<Number> | AnimationRegisterCache
Inherited | fragmentConstantOffset : uint | ShaderRegisterCache
 | fragmentLife : ShaderRegisterElement | AnimationRegisterCache
 | fragmentOneConst : ShaderRegisterElement | AnimationRegisterCache
Inherited | fragmentOutputRegister : ShaderRegisterElement [read-only] The fragment output register. | ShaderRegisterCache
 | fragmentTime : ShaderRegisterElement | AnimationRegisterCache
 | fragmentZeroConst : ShaderRegisterElement | AnimationRegisterCache
 | hasBillboard : Boolean | AnimationRegisterCache
 | hasColorNode : Boolean | AnimationRegisterCache
 | hasUVNode : Boolean | AnimationRegisterCache
 | needFragmentAnimation : Boolean | AnimationRegisterCache
 | needUVAnimation : Boolean | AnimationRegisterCache
 | needVelocity : Boolean | AnimationRegisterCache
 | numFragmentConstant : int [read-only] | AnimationRegisterCache
Inherited | numUsedFragmentConstants : uint [read-only] The amount of used fragment constant registers. | ShaderRegisterCache
Inherited | numUsedStreams : uint [read-only] The amount of used vertex streams. | ShaderRegisterCache
Inherited | numUsedTextures : uint [read-only] | ShaderRegisterCache
Inherited | numUsedVaryings : uint [read-only] | ShaderRegisterCache
Inherited | numUsedVertexConstants : uint [read-only] The amount of used vertex constant registers. | ShaderRegisterCache
 | numVertexConstant : int [read-only] | AnimationRegisterCache
 | positionAttribute : ShaderRegisterElement | AnimationRegisterCache
 | positionTarget : ShaderRegisterElement | AnimationRegisterCache
 | rotationRegisters : Vector.<ShaderRegisterElement> | AnimationRegisterCache
 | scaleAndRotateTarget : ShaderRegisterElement | AnimationRegisterCache
 | sourceRegisters : Vector.<String> | AnimationRegisterCache
 | targetRegisters : Vector.<String> | AnimationRegisterCache
 | uvAttribute : ShaderRegisterElement | AnimationRegisterCache
 | uvTarget : ShaderRegisterElement | AnimationRegisterCache
 | uvVar : ShaderRegisterElement | AnimationRegisterCache
Inherited | varyingsOffset : uint | ShaderRegisterCache
 | varyTime : ShaderRegisterElement | AnimationRegisterCache
 | velocityTarget : ShaderRegisterElement | AnimationRegisterCache
Inherited | vertexAttributesOffset : uint Indicates the start index from which to retrieve vertex attributes. | ShaderRegisterCache
 | vertexConstantData : Vector.<Number> | AnimationRegisterCache
Inherited | vertexConstantOffset : uint Indicates the start index from which to retrieve vertex constants. | ShaderRegisterCache
 | vertexLife : ShaderRegisterElement | AnimationRegisterCache
 | vertexOneConst : ShaderRegisterElement | AnimationRegisterCache
 | vertexTime : ShaderRegisterElement | AnimationRegisterCache
 | vertexTwoConst : ShaderRegisterElement | AnimationRegisterCache
 | vertexZeroConst : ShaderRegisterElement | AnimationRegisterCache
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _fragmentConstantOffset : uint | ShaderRegisterCache
Inherited | _numUsedFragmentConstants : uint | ShaderRegisterCache
Inherited | _numUsedVertexConstants : uint | ShaderRegisterCache
Inherited | _vertexConstantOffset : uint | ShaderRegisterCache
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | AnimationRegisterCache() | AnimationRegisterCache
Inherited | addFragmentTempUsages(register:ShaderRegisterElement, usageCount:uint):void Marks a fragment temporary register as used, so it cannot be retrieved. | ShaderRegisterCache
Inherited | addVertexTempUsages(register:ShaderRegisterElement, usageCount:uint):void Marks a vertex temporary register as used, so it cannot be retrieved. | ShaderRegisterCache
Inherited | dispose():void | ShaderRegisterCache
 | getCombinationCode():String | AnimationRegisterCache
Inherited | getFreeFragmentConstant():ShaderRegisterElement Retrieve an available fragment constant register | ShaderRegisterCache
Inherited | getFreeFragmentSingleTemp():ShaderRegisterElement Retrieve a single component from a fragment temporary register that's still available. | ShaderRegisterCache
Inherited | getFreeFragmentVectorTemp():ShaderRegisterElement Retrieve an entire fragment temporary register that's still available. | ShaderRegisterCache
Inherited | getFreeTextureReg():ShaderRegisterElement Retrieve an available texture register | ShaderRegisterCache
Inherited | getFreeVarying():ShaderRegisterElement Retrieve an available varying register | ShaderRegisterCache
Inherited | getFreeVertexAttribute():ShaderRegisterElement Retrieve an available vertex attribute register | ShaderRegisterCache
Inherited | getFreeVertexConstant():ShaderRegisterElement Retrieve an available vertex constant register | ShaderRegisterCache
Inherited | getFreeVertexSingleTemp():ShaderRegisterElement Retrieve a single component from a vertex temporary register that's still available. | ShaderRegisterCache
Inherited | getFreeVertexVectorTemp():ShaderRegisterElement Retrieve an entire vertex temporary register that's still available. | ShaderRegisterCache
 | getInitCode():String | AnimationRegisterCache
 | getRegisterIndex(node:AnimationNodeBase, parameterIndex:int):int | AnimationRegisterCache
Inherited | removeFragmentTempUsage(register:ShaderRegisterElement):void Removes a usage from a fragment temporary register. | ShaderRegisterCache
Inherited | removeVertexTempUsage(register:ShaderRegisterElement):void Removes a usage from a vertex temporary register. | ShaderRegisterCache
 | reset():void [override] | AnimationRegisterCache
 | setDataLength():void | AnimationRegisterCache
 | setFragmentConst(index:int, x:Number = 0, y:Number = 0, z:Number = 0, w:Number = 0):void | AnimationRegisterCache
 | setRegisterIndex(node:AnimationNodeBase, parameterIndex:int, registerIndex:int):void | AnimationRegisterCache
 | setShadedTarget(shadedTarget:String):void | AnimationRegisterCache
 | setUVSourceAndTarget(UVAttribute:String, UVVaring:String):void | AnimationRegisterCache
 | setVertexConst(index:int, x:Number = 0, y:Number = 0, z:Number = 0, w:Number = 0):void | AnimationRegisterCache
 | setVertexConstFromMatrix(index:int, matrix:Matrix3D):void | AnimationRegisterCache
Property Detail
colorTarget property
public var colorTarget:ShaderRegisterElement

fragmentConstantData property
public var fragmentConstantData:Vector.<Number>

fragmentLife property
public var fragmentLife:ShaderRegisterElement

fragmentOneConst property
public var fragmentOneConst:ShaderRegisterElement

fragmentTime property
public var fragmentTime:ShaderRegisterElement

fragmentZeroConst property
public var fragmentZeroConst:ShaderRegisterElement

hasBillboard property
public var hasBillboard:Boolean

hasColorNode property
public var hasColorNode:Boolean

hasUVNode property
public var hasUVNode:Boolean

needFragmentAnimation property
public var needFragmentAnimation:Boolean

needUVAnimation property
public var needUVAnimation:Boolean

needVelocity property
public var needVelocity:Boolean

numFragmentConstant property
numFragmentConstant:int [read-only]

Implementation
    public function get numFragmentConstant():int
numVertexConstant property
numVertexConstant:int [read-only]

Implementation
    public function get numVertexConstant():int
positionAttribute property
public var positionAttribute:ShaderRegisterElement

positionTarget property
public var positionTarget:ShaderRegisterElement

rotationRegisters property
public var rotationRegisters:Vector.<ShaderRegisterElement>

scaleAndRotateTarget property
public var scaleAndRotateTarget:ShaderRegisterElement

sourceRegisters property
public var sourceRegisters:Vector.<String>

targetRegisters property
public var targetRegisters:Vector.<String>

uvAttribute property
public var uvAttribute:ShaderRegisterElement

uvTarget property
public var uvTarget:ShaderRegisterElement

uvVar property
public var uvVar:ShaderRegisterElement

varyTime property
public var varyTime:ShaderRegisterElement

velocityTarget property
public var velocityTarget:ShaderRegisterElement

vertexConstantData property
public var vertexConstantData:Vector.<Number>

vertexLife property
public var vertexLife:ShaderRegisterElement

vertexOneConst property
public var vertexOneConst:ShaderRegisterElement

vertexTime property
public var vertexTime:ShaderRegisterElement

vertexTwoConst property
public var vertexTwoConst:ShaderRegisterElement

vertexZeroConst property
public var vertexZeroConst:ShaderRegisterElement

Constructor Detail
AnimationRegisterCache () Constructor
public function AnimationRegisterCache()

Method Detail
getCombinationCode () method
public function getCombinationCode():String

Returns
String
getInitCode () method
public function getInitCode():String

Returns
String
getRegisterIndex () method
public function getRegisterIndex(node:AnimationNodeBase, parameterIndex:int):int

Parameters

node:AnimationNodeBase
parameterIndex:int

Returns
int
reset () method
override public function reset():void

setDataLength () method
public function setDataLength():void

setFragmentConst () method
public function setFragmentConst(index:int, x:Number = 0, y:Number = 0, z:Number = 0, w:Number = 0):void

Parameters

index:int
x:Number (default = 0)
y:Number (default = 0)
z:Number (default = 0)
w:Number (default = 0)

setRegisterIndex () method
public function setRegisterIndex(node:AnimationNodeBase, parameterIndex:int, registerIndex:int):void

Parameters

node:AnimationNodeBase
parameterIndex:int
registerIndex:int

setShadedTarget () method
public function setShadedTarget(shadedTarget:String):void

Parameters

shadedTarget:String

setUVSourceAndTarget () method
public function setUVSourceAndTarget(UVAttribute:String, UVVaring:String):void

Parameters

UVAttribute:String
UVVaring:String

setVertexConst () method
public function setVertexConst(index:int, x:Number = 0, y:Number = 0, z:Number = 0, w:Number = 0):void

Parameters

index:int
x:Number (default = 0)
y:Number (default = 0)
z:Number (default = 0)
w:Number (default = 0)

setVertexConstFromMatrix () method
public function setVertexConstFromMatrix(index:int, matrix:Matrix3D):void

Parameters

index:int
matrix:Matrix3D


away3d.animators.data.AnimationSubGeometry

AnimationSubGeometry | Properties | Methods
Package | away3d.animators.data
Class | public class AnimationSubGeometry
Inheritance | AnimationSubGeometry Inheritance Object

...

Public Properties
Property |  | Defined By
 | animationParticles : Vector.<ParticleAnimationData> | AnimationSubGeometry
 | numProcessedVertices : int = 0 | AnimationSubGeometry
 | numVertices : uint [read-only] | AnimationSubGeometry
 | previousTime : Number = 0 | AnimationSubGeometry
 | totalLenOfOneVertex : uint [read-only] | AnimationSubGeometry
 | vertexData : Vector.<Number> [read-only] | AnimationSubGeometry
Protected Properties
Property |  | Defined By
 | _bufferContext : Vector.<Context3D> | AnimationSubGeometry
 | _bufferDirty : Vector.<Boolean> | AnimationSubGeometry
 | _vertexBuffer : Vector.<VertexBuffer3D> | AnimationSubGeometry
 | _vertexData : Vector.<Number> | AnimationSubGeometry
Public Methods
Method |  | Defined By
 | AnimationSubGeometry() | AnimationSubGeometry
 | activateVertexBuffer(index:int, bufferOffset:int, stage3DProxy:Stage3DProxy, format:String):void | AnimationSubGeometry
 | createVertexData(numVertices:uint, totalLenOfOneVertex:uint):void | AnimationSubGeometry
 | invalidateBuffer():void | AnimationSubGeometry
Property Detail
_bufferContext property
protected var _bufferContext:Vector.<Context3D>

_bufferDirty property
protected var _bufferDirty:Vector.<Boolean>

_vertexBuffer property
protected var _vertexBuffer:Vector.<VertexBuffer3D>

_vertexData property
protected var _vertexData:Vector.<Number>

animationParticles property
public var animationParticles:Vector.<ParticleAnimationData>

numProcessedVertices property
public var numProcessedVertices:int = 0

numVertices property
numVertices:uint [read-only]

Implementation
    public function get numVertices():uint
previousTime property
public var previousTime:Number = 0

totalLenOfOneVertex property
totalLenOfOneVertex:uint [read-only]

Implementation
    public function get totalLenOfOneVertex():uint
vertexData property
vertexData:Vector.<Number> [read-only]

Implementation
    public function get vertexData():Vector.<Number>
Constructor Detail
AnimationSubGeometry () Constructor
public function AnimationSubGeometry()

Method Detail
activateVertexBuffer () method
public function activateVertexBuffer(index:int, bufferOffset:int, stage3DProxy:Stage3DProxy, format:String):void

Parameters

index:int
bufferOffset:int
stage3DProxy:Stage3DProxy
format:String

createVertexData () method
public function createVertexData(numVertices:uint, totalLenOfOneVertex:uint):void

Parameters

numVertices:uint
totalLenOfOneVertex:uint

invalidateBuffer () method
public function invalidateBuffer():void


away3d.animators.data.JointPose

JointPose | Properties | Methods
Package | away3d.animators.data
Class | public class JointPose
Inheritance | JointPose Inheritance Object

Contains transformation data for a skeleton joint, used for skeleton animation.

See also

away3d.animation.data.Skeleton
todo: support (uniform) scale

Public Properties
Property |  | Defined By
 | name : String The name of the joint to which the pose is associated | JointPose
 | orientation : Quaternion The rotation of the pose stored as a quaternion | JointPose
 | translation : Vector3D The translation of the pose | JointPose
Public Methods
Method |  | Defined By
 | copyFrom(pose:JointPose):void Copies the transformation data from a source pose object into the existing pose object. | JointPose
 | toMatrix3D(target:Matrix3D = null):Matrix3D Converts the transformation to a Matrix3D representation. | JointPose
Property Detail
name property
public var name:String

The name of the joint to which the pose is associated

orientation property
public var orientation:Quaternion

The rotation of the pose stored as a quaternion

translation property
public var translation:Vector3D

The translation of the pose

Method Detail
copyFrom () method
public function copyFrom(pose:JointPose):void

Copies the transformation data from a source pose object into the existing pose object.

Parameters

pose:JointPose — The source pose to copy from.

toMatrix3D () method
public function toMatrix3D(target:Matrix3D = null):Matrix3D

Converts the transformation to a Matrix3D representation.

Parameters

target:Matrix3D (default = null) — An optional target matrix to store the transformation. If not provided, it will create a new instance.

Returns
Matrix3D — The transformation matrix of the pose.


away3d.animators.data.ParticleAnimationData

ParticleAnimationData | Properties | Methods
Package | away3d.animators.data
Class | public class ParticleAnimationData
Inheritance | ParticleAnimationData Inheritance Object

...

Public Properties
Property |  | Defined By
 | delay : Number | ParticleAnimationData
 | duration : Number | ParticleAnimationData
 | index : uint | ParticleAnimationData
 | numVertices : uint | ParticleAnimationData
 | startTime : Number | ParticleAnimationData
 | startVertexIndex : uint | ParticleAnimationData
 | totalTime : Number | ParticleAnimationData
Public Methods
Method |  | Defined By
 | ParticleAnimationData(index:uint, startTime:Number, duration:Number, delay:Number, particle:ParticleData) | ParticleAnimationData
Property Detail
delay property
public var delay:Number

duration property
public var duration:Number

index property
public var index:uint

numVertices property
public var numVertices:uint

startTime property
public var startTime:Number

startVertexIndex property
public var startVertexIndex:uint

totalTime property
public var totalTime:Number

Constructor Detail
ParticleAnimationData () Constructor
public function ParticleAnimationData(index:uint, startTime:Number, duration:Number, delay:Number, particle:ParticleData)

Parameters
index:uint
startTime:Number
duration:Number
delay:Number
particle:ParticleData


away3d.animators.data.ParticleProperties

ParticleProperties | Properties
Package | away3d.animators.data
Class | public dynamic class ParticleProperties
Inheritance | ParticleProperties Inheritance Object

Dynamic class for holding the local properties of a particle, used for processing the static properties of particles in the particle animation set before beginning upload to the GPU.

Public Properties
Property |  | Defined By
 | delay : Number The delay between cycles of the particle, an optional value used when the particle aniamtion set settings for useLooping and useDelay are enabled in the constructor. | ParticleProperties
 | duration : Number The duration of the particle, an optional value used when the particle aniamtion set settings for useDuration are enabled in the constructor. | ParticleProperties
 | index : uint The index of the current particle being set. | ParticleProperties
 | startTime : Number The start time of the particle. | ParticleProperties
 | total : uint The total number of particles being processed by the particle animation set. | ParticleProperties
Property Detail
delay property
public var delay:Number

The delay between cycles of the particle, an optional value used when the particle aniamtion set settings for useLooping and useDelay are enabled in the constructor.

See also

away3d.animators.ParticleAnimationSet
duration property
public var duration:Number

The duration of the particle, an optional value used when the particle aniamtion set settings for useDuration are enabled in the constructor.

See also

away3d.animators.ParticleAnimationSet
index property
public var index:uint

The index of the current particle being set.

startTime property
public var startTime:Number

The start time of the particle.

total property
public var total:uint

The total number of particles being processed by the particle animation set.


away3d.animators.data.ParticlePropertiesMode

ParticlePropertiesMode | Constants
Package | away3d.animators.data
Class | public class ParticlePropertiesMode
Inheritance | ParticlePropertiesMode Inheritance Object

Options for setting the properties mode of a particle animation node.

Public Constants
Constant |  | Defined By
 | GLOBAL : uint = 0 [static] Mode that defines the particle node as acting on global properties (ie. | ParticlePropertiesMode
 | LOCAL_DYNAMIC : uint = 2 [static] Mode that defines the particle node as acting on local dynamic properties (ie. | ParticlePropertiesMode
 | LOCAL_STATIC : uint = 1 [static] Mode that defines the particle node as acting on local static properties (ie. | ParticlePropertiesMode
Constant Detail
GLOBAL Constant
public static const GLOBAL:uint = 0

Mode that defines the particle node as acting on global properties (ie. the properties set in the node constructor or the corresponding animation state).

LOCAL_DYNAMIC Constant
public static const LOCAL_DYNAMIC:uint = 2

Mode that defines the particle node as acting on local dynamic properties (ie. the properties of the particles set in the corresponding animation state).

LOCAL_STATIC Constant
public static const LOCAL_STATIC:uint = 1

Mode that defines the particle node as acting on local static properties (ie. the properties of particles set in the initialising function on the animation set).


away3d.animators.data.Skeleton

Skeleton | Properties | Methods | Constants
Package | away3d.animators.data
Class | public class Skeleton
Inheritance | Skeleton Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IAsset

A Skeleton object is a hierarchical grouping of joint objects that can be used for skeletal animation.

See also

away3d.animators.data.SkeletonJoint

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
 | assetType : String [read-only] | Skeleton
 | joints : Vector.<SkeletonJoint> A flat list of joint objects that comprise the skeleton. | Skeleton
Inherited | name : String | NamedAssetBase
 | numJoints : uint [read-only] The total number of joints in the skeleton. | Skeleton
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Skeleton() Creates a new Skeleton object | Skeleton
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | dispose():void Cleans up resources used by this asset. | Skeleton
 | jointFromName(jointName:String):SkeletonJoint Returns the joint object in the skeleton with the given name, otherwise returns a null object. | Skeleton
 | jointIndexFromName(jointName:String):int Returns the joint index, given the joint name. | Skeleton
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
assetType property
assetType:String [read-only]

Implementation
    public function get assetType():String
joints property
public var joints:Vector.<SkeletonJoint>

A flat list of joint objects that comprise the skeleton. Every joint except for the root has a parentIndex property that is an index into this list. A child joint should always have a higher index than its parent.

numJoints property
numJoints:uint [read-only]

The total number of joints in the skeleton.

Implementation
    public function get numJoints():uint
Constructor Detail
Skeleton () Constructor
public function Skeleton()

Creates a new Skeleton object

Method Detail
dispose () method
public function dispose():void

Cleans up resources used by this asset.

jointFromName () method
public function jointFromName(jointName:String):SkeletonJoint

Returns the joint object in the skeleton with the given name, otherwise returns a null object.

Parameters

jointName:String — The name of the joint object to be found.

Returns
SkeletonJoint — The joint object with the given name.

See also

joints
jointIndexFromName () method
public function jointIndexFromName(jointName:String):int

Returns the joint index, given the joint name. -1 is returned if the joint name is not found.

Parameters

jointName:String — The name of the joint object to be found.

Returns
int — The index of the joint object in the joints vector.

See also

joints


away3d.animators.data.SkeletonJoint

SkeletonJoint | Properties | Methods
Package | away3d.animators.data
Class | public class SkeletonJoint
Inheritance | SkeletonJoint Inheritance Object

A value obect representing a single joint in a skeleton object.

See also

away3d.animators.data.Skeleton

Public Properties
Property |  | Defined By
 | inverseBindPose : Vector.<Number> The inverse bind pose matrix, as raw data, used to transform vertices to bind joint space in preparation for transformation using the joint matrix. | SkeletonJoint
 | name : String The name of the joint | SkeletonJoint
 | parentIndex : int = -1 The index of the parent joint in the skeleton's joints vector. | SkeletonJoint
Public Methods
Method |  | Defined By
 | SkeletonJoint() Creates a new SkeletonJoint object | SkeletonJoint
Property Detail
inverseBindPose property
public var inverseBindPose:Vector.<Number>

The inverse bind pose matrix, as raw data, used to transform vertices to bind joint space in preparation for transformation using the joint matrix.

name property
public var name:String

The name of the joint

parentIndex property
public var parentIndex:int = -1

The index of the parent joint in the skeleton's joints vector.

See also

away3d.animators.data.Skeleton.joints
Constructor Detail
SkeletonJoint () Constructor
public function SkeletonJoint()

Creates a new SkeletonJoint object


away3d.animators.data.SkeletonPose

SkeletonPose | Properties | Methods | Constants
Package | away3d.animators.data
Class | public class SkeletonPose
Inheritance | SkeletonPose Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IAsset

A collection of pose objects, determining the pose for an entire skeleton. The jointPoses vector object corresponds to a skeleton's joints vector object, however, there is no reference to a skeleton's instance, since several skeletons can be influenced by the same pose (eg: animation clips are added to any animator with a valid skeleton)

See also

away3d.animators.data.Skeleton
away3d.animators.data.JointPose

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
 | assetType : String [read-only] | SkeletonPose
 | jointPoses : Vector.<JointPose> A flat list of pose objects that comprise the skeleton pose. | SkeletonPose
Inherited | name : String | NamedAssetBase
 | numJointPoses : uint [read-only] The total number of joint poses in the skeleton pose. | SkeletonPose
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkeletonPose() Creates a new SkeletonPose object. | SkeletonPose
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | clone():SkeletonPose Creates a copy of the SkeletonPose object, with a dulpicate of its component joint poses. | SkeletonPose
 | dispose():void Cleans up resources used by this asset. | SkeletonPose
 | jointPoseFromName(jointName:String):JointPose Returns the joint pose object with the given joint name, otherwise returns a null object. | SkeletonPose
 | jointPoseIndexFromName(jointName:String):int Returns the pose index, given the joint name. | SkeletonPose
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
assetType property
assetType:String [read-only]

Implementation
    public function get assetType():String
jointPoses property
public var jointPoses:Vector.<JointPose>

A flat list of pose objects that comprise the skeleton pose. The pose indices correspond to the target skeleton's joint indices.

See also

away3d.animators.data.Skeleton.joints
numJointPoses property
numJointPoses:uint [read-only]

The total number of joint poses in the skeleton pose.

Implementation
    public function get numJointPoses():uint
Constructor Detail
SkeletonPose () Constructor
public function SkeletonPose()

Creates a new SkeletonPose object.

Method Detail
clone () method
public function clone():SkeletonPose

Creates a copy of the SkeletonPose object, with a dulpicate of its component joint poses.

Returns
SkeletonPose — SkeletonPose
dispose () method
public function dispose():void

Cleans up resources used by this asset.

jointPoseFromName () method
public function jointPoseFromName(jointName:String):JointPose

Returns the joint pose object with the given joint name, otherwise returns a null object.

Parameters

jointName:String — The name of the joint object whose pose is to be found.

Returns
JointPose — The pose object with the given joint name.
jointPoseIndexFromName () method
public function jointPoseIndexFromName(jointName:String):int

Returns the pose index, given the joint name. -1 is returned if the joint name is not found in the pose.

Parameters

jointName:String — name of the joint object whose pose is to be found.

Returns
int — The index of the pose object in the jointPoses vector.

See also

jointPoses


away3d.animators.data.UVAnimationFrame

UVAnimationFrame | Properties | Methods
Package | away3d.animators.data
Class | public class UVAnimationFrame
Inheritance | UVAnimationFrame Inheritance Object

A value object for a single frame of animation in a UVClipNode object.

See also

away3d.animators.nodes.UVClipNode

Public Properties
Property |  | Defined By
 | offsetU : Number The u-component offset of the UV animation frame. | UVAnimationFrame
 | offsetV : Number The v-component offset of the UV animation frame. | UVAnimationFrame
 | rotation : Number The rotation value (in degrees) of the UV animation frame. | UVAnimationFrame
 | scaleU : Number The u-component scale of the UV animation frame. | UVAnimationFrame
 | scaleV : Number The v-component scale of the UV animation frame. | UVAnimationFrame
Public Methods
Method |  | Defined By
 | UVAnimationFrame(offsetU:Number = 0, offsetV:Number = 0, scaleU:Number = 1, scaleV:Number = 1, rotation:Number = 0) Creates a new UVAnimationFrame object. | UVAnimationFrame
Property Detail
offsetU property
public var offsetU:Number

The u-component offset of the UV animation frame.

offsetV property
public var offsetV:Number

The v-component offset of the UV animation frame.

rotation property
public var rotation:Number

The rotation value (in degrees) of the UV animation frame.

scaleU property
public var scaleU:Number

The u-component scale of the UV animation frame.

scaleV property
public var scaleV:Number

The v-component scale of the UV animation frame.

Constructor Detail
UVAnimationFrame () Constructor
public function UVAnimationFrame(offsetU:Number = 0, offsetV:Number = 0, scaleU:Number = 1, scaleV:Number = 1, rotation:Number = 0)

Creates a new UVAnimationFrame object.

Parameters
offsetU:Number (default = 0) — The u-component offset of the UV animation frame.
offsetV:Number (default = 0) — The v-component offset of the UV animation frame.
scaleU:Number (default = 1) — The u-component scale of the UV animation frame.
scaleV:Number (default = 1) — The v-component scale of the UV animation frame.
rotation:Number (default = 0) — The rotation value (in degrees) of the UV animation frame.


away3d.animators.data.VertexAnimationMode

VertexAnimationMode | Constants
Package | away3d.animators.data
Class | public class VertexAnimationMode
Inheritance | VertexAnimationMode Inheritance Object

Options for setting the animation mode of a vertex animator object.

See also

away3d.animators.VertexAnimator

Public Constants
Constant |  | Defined By
 | ABSOLUTE : String = absolute [static] Animation mode that picks the output from a single vertex animation state to form the current vertex animation pose. | VertexAnimationMode
 | ADDITIVE : String = additive [static] Animation mode that adds all outputs from active vertex animation state to form the current vertex animation pose. | VertexAnimationMode
Constant Detail
ABSOLUTE Constant
public static const ABSOLUTE:String = absolute

Animation mode that picks the output from a single vertex animation state to form the current vertex animation pose.

ADDITIVE Constant
public static const ADDITIVE:String = additive

Animation mode that adds all outputs from active vertex animation state to form the current vertex animation pose.


away3d.animators.nodes - Away3D Documentation

Package away3d.animators.nodes

Classes
AnimationClipNodeBase
AnimationNodeBase
ParticleAccelerationNode
ParticleBezierCurveNode
ParticleBillboardNode
ParticleColorNode
ParticleFollowNode
ParticleNodeBase
ParticleOrbitNode
ParticleOscillatorNode
ParticlePositionNode
ParticleRotateToHeadingNode
ParticleRotationalVelocityNode
ParticleScaleNode
ParticleSpriteSheetNode
ParticleTimeNode
ParticleUVNode
ParticleVelocityNode
SkeletonBinaryLERPNode
SkeletonClipNode
SkeletonDifferenceNode
SkeletonDirectionalNode
SkeletonNaryLERPNode
UVClipNode
VertexClipNode


away3d.animators.nodes Summary

away3d.animators.nodes | Classes

Classes
Class | Description
AnimationClipNodeBase | Provides an abstract base class for nodes with time-based animation data in an animation blend tree.
AnimationNodeBase | Provides an abstract base class for nodes in an animation blend tree.
ParticleAccelerationNode | A particle animation node used to apply a constant acceleration vector to the motion of a particle.
ParticleBezierCurveNode | A particle animation node used to control the position of a particle over time along a bezier curve.
ParticleBillboardNode | A particle animation node that controls the rotation of a particle to always face the camera.
ParticleColorNode | A particle animation node used to control the color variation of a particle over time.
ParticleFollowNode | A particle animation node used to create a follow behaviour on a particle system.
ParticleNodeBase | Provides an abstract base class for particle animation nodes.
ParticleOrbitNode | A particle animation node used to control the position of a particle over time around a circular orbit.
ParticleOscillatorNode | A particle animation node used to control the position of a particle over time using simple harmonic motion.
ParticlePositionNode | A particle animation node used to set the starting position of a particle.
ParticleRotateToHeadingNode | A particle animation node used to control the rotation of a particle to match its heading vector.
ParticleRotationalVelocityNode | A particle animation node used to set the starting rotational velocity of a particle.
ParticleScaleNode | A particle animation node used to control the scale variation of a particle over time.
ParticleSpriteSheetNode | A particle animation node used when a spritesheet texture is required to animate the particle.
ParticleTimeNode | A particle animation node used as the base node for timekeeping inside a particle.
ParticleUVNode | A particle animation node used to control the UV offset and scale of a particle over time.
ParticleVelocityNode | A particle animation node used to set the starting velocity of a particle.
SkeletonBinaryLERPNode | A skeleton animation node that uses two animation node inputs to blend a lineraly interpolated output of a skeleton pose.
SkeletonClipNode | A skeleton animation node containing time-based animation data as individual skeleton poses.
SkeletonDifferenceNode | A skeleton animation node that uses a difference input pose with a base input pose to blend a linearly interpolated output of a skeleton pose.
SkeletonDirectionalNode | A skeleton animation node that uses four directional input poses with an input direction to blend a linearly interpolated output of a skeleton pose.
SkeletonNaryLERPNode | A skeleton animation node that uses an n-dimensional array of animation node inputs to blend a lineraly interpolated output of a skeleton pose.
UVClipNode | A uv animation node containing time-based animation data as individual uv animation frames.
VertexClipNode | A vertex animation node containing time-based animation data as individual geometry obejcts.

Thu Nov 15 2012, 12:09 PM Z


away3d.animators.nodes.AnimationClipNodeBase

AnimationClipNodeBase | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class AnimationClipNodeBase
Inheritance | AnimationClipNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | SkeletonClipNode, UVClipNode, VertexClipNode

Provides an abstract base class for nodes with time-based animation data in an animation blend tree.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
 | durations : Vector.<uint> [read-only] Returns a vector of time values representing the duration (in milliseconds) of each animation frame in the clip. | AnimationClipNodeBase
 | fixedFrameRate : Boolean = true | AnimationClipNodeBase
 | lastFrame : uint [read-only] | AnimationClipNodeBase
 | looping : Boolean Determines whether the contents of the animation node have looping characteristics enabled. | AnimationClipNodeBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
 | stitchFinalFrame : Boolean Defines if looping content blends the final frame of animation data with the first (true) or works on the assumption that both first and last frames are identical (false). | AnimationClipNodeBase
 | totalDelta : Vector3D [read-only] | AnimationClipNodeBase
 | totalDuration : uint [read-only] | AnimationClipNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
 | _durations : Vector.<uint> | AnimationClipNodeBase
 | _lastFrame : uint | AnimationClipNodeBase
 | _looping : Boolean = true | AnimationClipNodeBase
 | _numFrames : uint = 0 | AnimationClipNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
 | _stitchDirty : Boolean = true | AnimationClipNodeBase
 | _stitchFinalFrame : Boolean = false | AnimationClipNodeBase
 | _totalDelta : Vector3D | AnimationClipNodeBase
 | _totalDuration : uint = 0 | AnimationClipNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | AnimationClipNodeBase() Creates a new AnimationClipNodeBase object. | AnimationClipNodeBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Method |  | Defined By
 | updateStitch():void Updates the node's final frame stitch state. | AnimationClipNodeBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_durations property
protected var _durations:Vector.<uint>

_lastFrame property
protected var _lastFrame:uint

_looping property
protected var _looping:Boolean = true

_numFrames property
protected var _numFrames:uint = 0

_stitchDirty property
protected var _stitchDirty:Boolean = true

_stitchFinalFrame property
protected var _stitchFinalFrame:Boolean = false

_totalDelta property
protected var _totalDelta:Vector3D

_totalDuration property
protected var _totalDuration:uint = 0

durations property
durations:Vector.<uint> [read-only]

Returns a vector of time values representing the duration (in milliseconds) of each animation frame in the clip.

Implementation
    public function get durations():Vector.<uint>
fixedFrameRate property
public var fixedFrameRate:Boolean = true

lastFrame property
lastFrame:uint [read-only]

Implementation
    public function get lastFrame():uint
looping property
looping:Boolean

Determines whether the contents of the animation node have looping characteristics enabled.

Implementation
    public function get looping():Boolean
    public function set looping(value:Boolean):void
stitchFinalFrame property
stitchFinalFrame:Boolean

Defines if looping content blends the final frame of animation data with the first (true) or works on the assumption that both first and last frames are identical (false). Defaults to false.

Implementation
    public function get stitchFinalFrame():Boolean
    public function set stitchFinalFrame(value:Boolean):void
totalDelta property
totalDelta:Vector3D [read-only]

Implementation
    public function get totalDelta():Vector3D
totalDuration property
totalDuration:uint [read-only]

Implementation
    public function get totalDuration():uint
Constructor Detail
AnimationClipNodeBase () Constructor
public function AnimationClipNodeBase()

Creates a new AnimationClipNodeBase object.

Method Detail
updateStitch () method
protected function updateStitch():void

Updates the node's final frame stitch state.

See also

stitchFinalFrame


away3d.animators.nodes.AnimationNodeBase

AnimationNodeBase | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class AnimationNodeBase
Inheritance | AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IAsset
Subclasses | AnimationClipNodeBase, ParticleNodeBase, SkeletonBinaryLERPNode, SkeletonDifferenceNode, SkeletonDirectionalNode, SkeletonNaryLERPNode

Provides an abstract base class for nodes in an animation blend tree.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
 | assetType : String [read-only] | AnimationNodeBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Property |  | Defined By
 | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | AnimationNodeBase() Creates a new AnimationNodeBase object. | AnimationNodeBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_stateClass property
protected var _stateClass:Class

assetType property
assetType:String [read-only]

Implementation
    public function get assetType():String
stateClass property
stateClass:Class [read-only]

Implementation
    public function get stateClass():Class
Constructor Detail
AnimationNodeBase () Constructor
public function AnimationNodeBase()

Creates a new AnimationNodeBase object.

Method Detail
dispose () method
public function dispose():void

Cleans up resources used by this asset.


away3d.animators.nodes.ParticleAccelerationNode

ParticleAccelerationNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleAccelerationNode
Inheritance | ParticleAccelerationNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used to apply a constant acceleration vector to the motion of a particle.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleAccelerationNode(mode:uint, acceleration:Vector3D = null) Creates a new ParticleAccelerationNode | ParticleAccelerationNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
Inherited | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleAccelerationNode
 | getAnimationState(animator:IAnimator):ParticleAccelerationState | ParticleAccelerationNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
 | ACCELERATION_VECTOR3D : String = AccelerationVector3D [static] Reference for acceleration node properties on a single particle (when in local property mode). | ParticleAccelerationNode
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
ParticleAccelerationNode () Constructor
public function ParticleAccelerationNode(mode:uint, acceleration:Vector3D = null)

Creates a new ParticleAccelerationNode

Parameters
mode:uint — Defines whether the mode of operation acts on local properties of a particle or global properties of the node.
acceleration:Vector3D (default = null) — acceleration Defines the default acceleration vector of the node, used when in global mode.
Method Detail
generatePropertyOfOneParticle () method
override arcane function generatePropertyOfOneParticle(param:ParticleProperties):void

Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.

Parameters

param:ParticleProperties

getAGALVertexCode () method
override public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleAccelerationState

Parameters

animator:IAnimator

Returns
ParticleAccelerationState
Constant Detail
ACCELERATION_VECTOR3D Constant
public static const ACCELERATION_VECTOR3D:String = AccelerationVector3D

Reference for acceleration node properties on a single particle (when in local property mode). Expects a Vector3D object representing the direction of acceleration on the particle.


away3d.animators.nodes.ParticleBezierCurveNode

ParticleBezierCurveNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleBezierCurveNode
Inheritance | ParticleBezierCurveNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used to control the position of a particle over time along a bezier curve.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleBezierCurveNode(mode:uint, controlPoint:Vector3D = null, endPoint:Vector3D = null) Creates a new ParticleBezierCurveNode | ParticleBezierCurveNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
Inherited | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleBezierCurveNode
 | getAnimationState(animator:IAnimator):ParticleBezierCurveState | ParticleBezierCurveNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
 | BEZIER_CONTROL_VECTOR3D : String = BezierControlVector3D [static] Reference for bezier curve node properties on a single particle (when in local property mode). | ParticleBezierCurveNode
 | BEZIER_END_VECTOR3D : String = BezierEndVector3D [static] Reference for bezier curve node properties on a single particle (when in local property mode). | ParticleBezierCurveNode
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
ParticleBezierCurveNode () Constructor
public function ParticleBezierCurveNode(mode:uint, controlPoint:Vector3D = null, endPoint:Vector3D = null)

Creates a new ParticleBezierCurveNode

Parameters
mode:uint — Defines whether the mode of operation acts on local properties of a particle or global properties of the node.
controlPoint:Vector3D (default = null) — controlPoint Defines the default control point of the node, used when in global mode.
endPoint:Vector3D (default = null) — endPoint Defines the default end point of the node, used when in global mode.
Method Detail
generatePropertyOfOneParticle () method
override arcane function generatePropertyOfOneParticle(param:ParticleProperties):void

Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.

Parameters

param:ParticleProperties

getAGALVertexCode () method
override public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleBezierCurveState

Parameters

animator:IAnimator

Returns
ParticleBezierCurveState
Constant Detail
BEZIER_CONTROL_VECTOR3D Constant
public static const BEZIER_CONTROL_VECTOR3D:String = BezierControlVector3D

Reference for bezier curve node properties on a single particle (when in local property mode). Expects a Vector3D object representing the control point position (0, 1, 2) of the curve.

BEZIER_END_VECTOR3D Constant
public static const BEZIER_END_VECTOR3D:String = BezierEndVector3D

Reference for bezier curve node properties on a single particle (when in local property mode). Expects a Vector3D object representing the end point position (0, 1, 2) of the curve.


away3d.animators.nodes.ParticleBillboardNode

ParticleBillboardNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleBillboardNode
Inheritance | ParticleBillboardNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node that controls the rotation of a particle to always face the camera.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleBillboardNode() Creates a new ParticleBillboardNode | ParticleBillboardNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
Inherited | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleBillboardNode
 | getAnimationState(animator:IAnimator):ParticleBillboardState | ParticleBillboardNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
ParticleBillboardNode () Constructor
public function ParticleBillboardNode()

Creates a new ParticleBillboardNode

Method Detail
getAGALVertexCode () method
override public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleBillboardState

Parameters

animator:IAnimator

Returns
ParticleBillboardState
processAnimationSetting () method
override arcane function processAnimationSetting(particleAnimationSet:ParticleAnimationSet):void

Called internally by the particle animation set when determining the requirements of the particle animation node AGAL.

Parameters

particleAnimationSet:ParticleAnimationSet


away3d.animators.nodes.ParticleColorNode

ParticleColorNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleColorNode
Inheritance | ParticleColorNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used to control the color variation of a particle over time.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleColorNode(mode:uint, usesMultiplier:Boolean = true, usesOffset:Boolean = true, usesCycle:Boolean = false, usesPhase:Boolean = false, startColor:ColorTransform = null, endColor:ColorTransform = null, cycleDuration:Number = 1, cyclePhase:Number = 0) Creates a new ParticleColorNode | ParticleColorNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
 | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleColorNode
Inherited | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleColorNode
 | getAnimationState(animator:IAnimator):ParticleColorState | ParticleColorNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
 | COLOR_END_COLORTRANSFORM : String = ColorEndColorTransform [static] Reference for color node properties on a single particle (when in local property mode). | ParticleColorNode
 | COLOR_START_COLORTRANSFORM : String = ColorStartColorTransform [static] Reference for color node properties on a single particle (when in local property mode). | ParticleColorNode
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
ParticleColorNode () Constructor
public function ParticleColorNode(mode:uint, usesMultiplier:Boolean = true, usesOffset:Boolean = true, usesCycle:Boolean = false, usesPhase:Boolean = false, startColor:ColorTransform = null, endColor:ColorTransform = null, cycleDuration:Number = 1, cyclePhase:Number = 0)

Creates a new ParticleColorNode

Parameters
mode:uint — Defines whether the mode of operation acts on local properties of a particle or global properties of the node.
usesMultiplier:Boolean (default = true) — usesMultiplier Defines whether the node uses multiplier data in the shader for its color transformations. Defaults to true.
usesOffset:Boolean (default = true) — usesOffset Defines whether the node uses offset data in the shader for its color transformations. Defaults to true.
usesCycle:Boolean (default = false) — usesCycle Defines whether the node uses the cycleDuration property in the shader to calculate the period of the animation independent of particle duration. Defaults to false.
usesPhase:Boolean (default = false) — usesPhase Defines whether the node uses the cyclePhase property in the shader to calculate a starting offset to the cycle rotation of the particle. Defaults to false.
startColor:ColorTransform (default = null) — startColor Defines the default start color transform of the node, when in global mode.
endColor:ColorTransform (default = null) — endColor Defines the default end color transform of the node, when in global mode.
cycleDuration:Number (default = 1) — cycleDuration Defines the duration of the animation in seconds, used as a period independent of particle duration when in global mode. Defaults to 1.
cyclePhase:Number (default = 0) — cyclePhase Defines the phase of the cycle in degrees, used as the starting offset of the cycle when in global mode. Defaults to 0.
Method Detail
generatePropertyOfOneParticle () method
override arcane function generatePropertyOfOneParticle(param:ParticleProperties):void

Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.

Parameters

param:ParticleProperties

getAGALFragmentCode () method
override public function getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the fragment shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAGALVertexCode () method
override public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleColorState

Parameters

animator:IAnimator

Returns
ParticleColorState
processAnimationSetting () method
override arcane function processAnimationSetting(particleAnimationSet:ParticleAnimationSet):void

Called internally by the particle animation set when determining the requirements of the particle animation node AGAL.

Parameters

particleAnimationSet:ParticleAnimationSet

Constant Detail
COLOR_END_COLORTRANSFORM Constant
public static const COLOR_END_COLORTRANSFORM:String = ColorEndColorTransform

Reference for color node properties on a single particle (when in local property mode). Expects a ColorTransform object representing the end color transform applied to the particle.

COLOR_START_COLORTRANSFORM Constant
public static const COLOR_START_COLORTRANSFORM:String = ColorStartColorTransform

Reference for color node properties on a single particle (when in local property mode). Expects a ColorTransform object representing the start color transform applied to the particle.


away3d.animators.nodes.ParticleFollowNode

ParticleFollowNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleFollowNode
Inheritance | ParticleFollowNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used to create a follow behaviour on a particle system.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleFollowNode(usesPosition:Boolean = true, usesRotation:Boolean = true) Creates a new ParticleFollowNode | ParticleFollowNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
Inherited | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleFollowNode
 | getAnimationState(animator:IAnimator):ParticleFollowState | ParticleFollowNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
ParticleFollowNode () Constructor
public function ParticleFollowNode(usesPosition:Boolean = true, usesRotation:Boolean = true)

Creates a new ParticleFollowNode

Parameters
usesPosition:Boolean (default = true) — usesPosition Defines wehether the individual particle reacts to the position of the target.
usesRotation:Boolean (default = true) — usesRotation Defines wehether the individual particle reacts to the rotation of the target.
Method Detail
getAGALVertexCode () method
override public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleFollowState

Parameters

animator:IAnimator

Returns
ParticleFollowState


away3d.animators.nodes.ParticleNodeBase

ParticleNodeBase | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleNodeBase
Inheritance | ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | ParticleAccelerationNode, ParticleBezierCurveNode, ParticleBillboardNode, ParticleColorNode, ParticleFollowNode, ParticleOrbitNode, ParticleOscillatorNode, ParticlePositionNode, ParticleRotateToHeadingNode, ParticleRotationalVelocityNode, ParticleScaleNode, ParticleSpriteSheetNode, ParticleTimeNode, ParticleUVNode, ParticleVelocityNode

Provides an abstract base class for particle animation nodes.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
 | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
 | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
 | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
 | _dataLength : uint = 3 | ParticleNodeBase
 | _mode : uint | ParticleNodeBase
 | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleNodeBase(name:String, mode:uint, dataLength:uint, priority:int = 1) Creates a new ParticleNodeBase object. | ParticleNodeBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
 | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
 | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleNodeBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_dataLength property
protected var _dataLength:uint = 3

_mode property
protected var _mode:uint

_oneData property
protected var _oneData:Vector.<Number>

dataLength property
dataLength:int [read-only]

Returns the length of the data used by the node when in LOCAL_STATIC mode. Used to generate the local static data of the particle animation set.

Implementation
    public function get dataLength():int

See also

away3d.animators.ParticleAnimationSet
getAGALVertexCode
dataOffset property
arcane var dataOffset:uint

mode property
mode:uint [read-only]

Returns the property mode of the particle animation node. Typically set in the node constructor

Implementation
    public function get mode():uint

See also

away3d.animators.data.ParticlePropertiesMode
oneData property
oneData:Vector.<Number> [read-only]

Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set.

Implementation
    public function get oneData():Vector.<Number>

See also

away3d.animators.ParticleAnimationSet
generatePropertyOfOneParticle
priority property
priority:int [read-only]

Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. Set automatically on instantiation.

Implementation
    public function get priority():int

See also

away3d.animators.ParticleAnimationSet
getAGALVertexCode
Constructor Detail
ParticleNodeBase () Constructor
public function ParticleNodeBase(name:String, mode:uint, dataLength:uint, priority:int = 1)

Creates a new ParticleNodeBase object.

Parameters
name:String — Defines the generic name of the particle animation node.
mode:uint — Defines whether the mode of operation acts on local properties of a particle or global properties of the node.
dataLength:uint — Defines the length of the data used by the node when in LOCAL_STATIC mode.
priority:int (default = 1) — priority the priority of the particle animation node, used to order the agal generated in a particle animation set. Defaults to 1.
Method Detail
generatePropertyOfOneParticle () method
arcane function generatePropertyOfOneParticle(param:ParticleProperties):void

Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.

Parameters

param:ParticleProperties

See also

away3d.animators.ParticleAnimationSet.initParticleFunc
getAGALFragmentCode () method
public function getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the fragment shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAGALUVCode () method
public function getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAGALVertexCode () method
public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
processAnimationSetting () method
arcane function processAnimationSetting(particleAnimationSet:ParticleAnimationSet):void

Called internally by the particle animation set when determining the requirements of the particle animation node AGAL.

Parameters

particleAnimationSet:ParticleAnimationSet


away3d.animators.nodes.ParticleOrbitNode

ParticleOrbitNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleOrbitNode
Inheritance | ParticleOrbitNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used to control the position of a particle over time around a circular orbit.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleOrbitNode(mode:uint, usesEulers:Boolean = true, usesCycle:Boolean = false, usesPhase:Boolean = false, radius:Number = 100, cycleDuration:Number = 1, cyclePhase:Number = 0, eulers:Vector3D = null) Creates a new ParticleOrbitNode object. | ParticleOrbitNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
Inherited | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleOrbitNode
 | getAnimationState(animator:IAnimator):ParticleOrbitState | ParticleOrbitNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
 | ORBIT_VECTOR3D : String = OrbitVector3D [static] Reference for orbit node properties on a single particle (when in local property mode). | ParticleOrbitNode
Constructor Detail
ParticleOrbitNode () Constructor
public function ParticleOrbitNode(mode:uint, usesEulers:Boolean = true, usesCycle:Boolean = false, usesPhase:Boolean = false, radius:Number = 100, cycleDuration:Number = 1, cyclePhase:Number = 0, eulers:Vector3D = null)

Creates a new ParticleOrbitNode object.

Parameters
mode:uint — Defines whether the mode of operation acts on local properties of a particle or global properties of the node.
usesEulers:Boolean (default = true) — usesEulers Defines whether the node uses the eulers property in the shader to calculate a rotation on the orbit. Defaults to true.
usesCycle:Boolean (default = false) — usesCycle Defines whether the node uses the cycleDuration property in the shader to calculate the period of the orbit independent of particle duration. Defaults to false.
usesPhase:Boolean (default = false) — usesPhase Defines whether the node uses the cyclePhase property in the shader to calculate a starting offset to the cycle rotation of the particle. Defaults to false.
radius:Number (default = 100) — radius Defines the radius of the orbit when in global mode. Defaults to 100.
cycleDuration:Number (default = 1) — cycleDuration Defines the duration of the orbit in seconds, used as a period independent of particle duration when in global mode. Defaults to 1.
cyclePhase:Number (default = 0) — cyclePhase Defines the phase of the orbit in degrees, used as the starting offset of the cycle when in global mode. Defaults to 0.
eulers:Vector3D (default = null) — eulers Defines the euler rotation in degrees, applied to the orientation of the orbit when in global mode.
Method Detail
generatePropertyOfOneParticle () method
override arcane function generatePropertyOfOneParticle(param:ParticleProperties):void

Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.

Parameters

param:ParticleProperties

getAGALVertexCode () method
override public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleOrbitState

Parameters

animator:IAnimator

Returns
ParticleOrbitState
Constant Detail
ORBIT_VECTOR3D Constant
public static const ORBIT_VECTOR3D:String = OrbitVector3D

Reference for orbit node properties on a single particle (when in local property mode). Expects a Vector3D object representing the radius (x), cycle speed (y) and cycle phase (z) of the motion on the particle.


away3d.animators.nodes.ParticleOscillatorNode

ParticleOscillatorNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleOscillatorNode
Inheritance | ParticleOscillatorNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used to control the position of a particle over time using simple harmonic motion.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleOscillatorNode(mode:uint, oscillator:Vector3D = null) Creates a new ParticleOscillatorNode | ParticleOscillatorNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
Inherited | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleOscillatorNode
 | getAnimationState(animator:IAnimator):ParticleOscillatorState | ParticleOscillatorNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
 | OSCILLATOR_VECTOR3D : String = OscillatorVector3D [static] Reference for ocsillator node properties on a single particle (when in local property mode). | ParticleOscillatorNode
Constructor Detail
ParticleOscillatorNode () Constructor
public function ParticleOscillatorNode(mode:uint, oscillator:Vector3D = null)

Creates a new ParticleOscillatorNode

Parameters
mode:uint — Defines whether the mode of operation acts on local properties of a particle or global properties of the node.
oscillator:Vector3D (default = null) — oscillator Defines the default oscillator axis (x, y, z) and cycleDuration (w) of the node, used when in global mode.
Method Detail
generatePropertyOfOneParticle () method
override arcane function generatePropertyOfOneParticle(param:ParticleProperties):void

Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.

Parameters

param:ParticleProperties

getAGALVertexCode () method
override public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleOscillatorState

Parameters

animator:IAnimator

Returns
ParticleOscillatorState
Constant Detail
OSCILLATOR_VECTOR3D Constant
public static const OSCILLATOR_VECTOR3D:String = OscillatorVector3D

Reference for ocsillator node properties on a single particle (when in local property mode). Expects a Vector3D object representing the axis (x,y,z) and cycle speed (w) of the motion on the particle.


away3d.animators.nodes.ParticlePositionNode

ParticlePositionNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticlePositionNode
Inheritance | ParticlePositionNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used to set the starting position of a particle.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticlePositionNode(mode:uint, position:Vector3D = null) Creates a new ParticlePositionNode | ParticlePositionNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
Inherited | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticlePositionNode
 | getAnimationState(animator:IAnimator):ParticlePositionState | ParticlePositionNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
 | POSITION_VECTOR3D : String = PositionVector3D [static] Reference for position node properties on a single particle (when in local property mode). | ParticlePositionNode
Constructor Detail
ParticlePositionNode () Constructor
public function ParticlePositionNode(mode:uint, position:Vector3D = null)

Creates a new ParticlePositionNode

Parameters
mode:uint — Defines whether the mode of operation acts on local properties of a particle or global properties of the node.
position:Vector3D (default = null) — position Defines the default position of the particle when in global mode. Defaults to 0,0,0.
Method Detail
generatePropertyOfOneParticle () method
override arcane function generatePropertyOfOneParticle(param:ParticleProperties):void

Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.

Parameters

param:ParticleProperties

getAGALVertexCode () method
override public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticlePositionState

Parameters

animator:IAnimator

Returns
ParticlePositionState
Constant Detail
POSITION_VECTOR3D Constant
public static const POSITION_VECTOR3D:String = PositionVector3D

Reference for position node properties on a single particle (when in local property mode). Expects a Vector3D object representing position of the particle.


away3d.animators.nodes.ParticleRotateToHeadingNode

ParticleRotateToHeadingNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleRotateToHeadingNode
Inheritance | ParticleRotateToHeadingNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used to control the rotation of a particle to match its heading vector.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleRotateToHeadingNode() Creates a new ParticleBillboardNode | ParticleRotateToHeadingNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
Inherited | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleRotateToHeadingNode
 | getAnimationState(animator:IAnimator):ParticleRotateToHeadingState | ParticleRotateToHeadingNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
ParticleRotateToHeadingNode () Constructor
public function ParticleRotateToHeadingNode()

Creates a new ParticleBillboardNode

Method Detail
getAGALVertexCode () method
override public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleRotateToHeadingState

Parameters

animator:IAnimator

Returns
ParticleRotateToHeadingState
processAnimationSetting () method
override arcane function processAnimationSetting(particleAnimationSet:ParticleAnimationSet):void

Called internally by the particle animation set when determining the requirements of the particle animation node AGAL.

Parameters

particleAnimationSet:ParticleAnimationSet


away3d.animators.nodes.ParticleRotationalVelocityNode

ParticleRotationalVelocityNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleRotationalVelocityNode
Inheritance | ParticleRotationalVelocityNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used to set the starting rotational velocity of a particle.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleRotationalVelocityNode(mode:uint, rotationalVelocity:Vector3D = null) Creates a new ParticleRotationalVelocityNode | ParticleRotationalVelocityNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
Inherited | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleRotationalVelocityNode
 | getAnimationState(animator:IAnimator):ParticleRotationalVelocityState | ParticleRotationalVelocityNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
 | ROTATIONALVELOCITY_VECTOR3D : String = RotationalVelocityVector3D [static] Reference for rotational velocity node properties on a single particle (when in local property mode). | ParticleRotationalVelocityNode
Constructor Detail
ParticleRotationalVelocityNode () Constructor
public function ParticleRotationalVelocityNode(mode:uint, rotationalVelocity:Vector3D = null)

Creates a new ParticleRotationalVelocityNode

Parameters
mode:uint — Defines whether the mode of operation acts on local properties of a particle or global properties of the node.
rotationalVelocity:Vector3D (default = null)
Method Detail
generatePropertyOfOneParticle () method
override arcane function generatePropertyOfOneParticle(param:ParticleProperties):void

Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.

Parameters

param:ParticleProperties

getAGALVertexCode () method
override public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleRotationalVelocityState

Parameters

animator:IAnimator

Returns
ParticleRotationalVelocityState
Constant Detail
ROTATIONALVELOCITY_VECTOR3D Constant
public static const ROTATIONALVELOCITY_VECTOR3D:String = RotationalVelocityVector3D

Reference for rotational velocity node properties on a single particle (when in local property mode). Expects a Vector3D object representing the rotational velocity around an axis of the particle.


away3d.animators.nodes.ParticleScaleNode

ParticleScaleNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleScaleNode
Inheritance | ParticleScaleNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used to control the scale variation of a particle over time.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleScaleNode(mode:uint, usesCycle:Boolean, usesPhase:Boolean, minScale:Number = 1, maxScale:Number = 1, cycleDuration:Number = 1, cyclePhase:Number = 0) Creates a new ParticleScaleNode | ParticleScaleNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
Inherited | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleScaleNode
 | getAnimationState(animator:IAnimator):ParticleScaleState | ParticleScaleNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
 | SCALE_VECTOR3D : String = ScaleVector3D [static] Reference for scale node properties on a single particle (when in local property mode). | ParticleScaleNode
Constructor Detail
ParticleScaleNode () Constructor
public function ParticleScaleNode(mode:uint, usesCycle:Boolean, usesPhase:Boolean, minScale:Number = 1, maxScale:Number = 1, cycleDuration:Number = 1, cyclePhase:Number = 0)

Creates a new ParticleScaleNode

Parameters
mode:uint — Defines whether the mode of operation acts on local properties of a particle or global properties of the node.
usesCycle:Boolean — usesCycle Defines whether the node uses the cycleDuration property in the shader to calculate the period of animation independent of particle duration. Defaults to false.
usesPhase:Boolean — usesPhase Defines whether the node uses the cyclePhase property in the shader to calculate a starting offset to the animation cycle. Defaults to false.
minScale:Number (default = 1) — minScale Defines the default min scale transform of the node, when in global mode. Defaults to 1.
maxScale:Number (default = 1) — maxScale Defines the default max color transform of the node, when in global mode. Defaults to 1.
cycleDuration:Number (default = 1) — cycleDuration Defines the default duration of the animation in seconds, used as a period independent of particle duration when in global mode. Defaults to 1.
cyclePhase:Number (default = 0) — cyclePhase Defines the default phase of the cycle in degrees, used as the starting offset of the cycle when in global mode. Defaults to 0.
Method Detail
generatePropertyOfOneParticle () method
override arcane function generatePropertyOfOneParticle(param:ParticleProperties):void

Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.

Parameters

param:ParticleProperties

getAGALVertexCode () method
override public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleScaleState

Parameters

animator:IAnimator

Returns
ParticleScaleState
Constant Detail
SCALE_VECTOR3D Constant
public static const SCALE_VECTOR3D:String = ScaleVector3D

Reference for scale node properties on a single particle (when in local property mode). Expects a Vector3D representing the min scale (x), max scale(y), optional cycle speed (z) and phase offset (w) applied to the particle.


away3d.animators.nodes.ParticleSpriteSheetNode

ParticleSpriteSheetNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleSpriteSheetNode
Inheritance | ParticleSpriteSheetNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used when a spritesheet texture is required to animate the particle. NB: to enable use of this node, the repeat property on the material has to be set to true.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
 | numColumns : Number [read-only] Defines the number of columns in the spritesheet, when in global mode. | ParticleSpriteSheetNode
 | numRows : Number [read-only] Defines the number of rows in the spritesheet, when in global mode. | ParticleSpriteSheetNode
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
 | totalFrames : Number [read-only] Defines the total number of frames used by the spritesheet, when in global mode. | ParticleSpriteSheetNode
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleSpriteSheetNode(mode:uint, usesCycle:Boolean, usesPhase:Boolean, numColumns:int = 1, numRows:uint = 1, cycleDuration:Number = 1, cyclePhase:Number = 0, totalFrames:uint) Creates a new ParticleSpriteSheetNode | ParticleSpriteSheetNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
 | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleSpriteSheetNode
Inherited | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleNodeBase
 | getAnimationState(animator:IAnimator):ParticleSpriteSheetState | ParticleSpriteSheetNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
 | UV_VECTOR3D : String = UVVector3D [static] Reference for spritesheet node properties on a single particle (when in local property mode). | ParticleSpriteSheetNode
Property Detail
numColumns property
numColumns:Number [read-only]

Defines the number of columns in the spritesheet, when in global mode. Defaults to 1. Read only.

Implementation
    public function get numColumns():Number
numRows property
numRows:Number [read-only]

Defines the number of rows in the spritesheet, when in global mode. Defaults to 1. Read only.

Implementation
    public function get numRows():Number
totalFrames property
totalFrames:Number [read-only]

Defines the total number of frames used by the spritesheet, when in global mode. Defaults to the number defined by numColumns and numRows. Read only.

Implementation
    public function get totalFrames():Number
Constructor Detail
ParticleSpriteSheetNode () Constructor
public function ParticleSpriteSheetNode(mode:uint, usesCycle:Boolean, usesPhase:Boolean, numColumns:int = 1, numRows:uint = 1, cycleDuration:Number = 1, cyclePhase:Number = 0, totalFrames:uint)

Creates a new ParticleSpriteSheetNode

Parameters
mode:uint — Defines whether the mode of operation acts on local properties of a particle or global properties of the node.
usesCycle:Boolean — numColumns Defines the number of columns in the spritesheet, when in global mode. Defaults to 1.
usesPhase:Boolean — numRows Defines the number of rows in the spritesheet, when in global mode. Defaults to 1.
numColumns:int (default = 1) — cycleDuration Defines the default cycle duration in seconds, when in global mode. Defaults to 1.
numRows:uint (default = 1) — cyclePhase Defines the default cycle phase, when in global mode. Defaults to 0.
cycleDuration:Number (default = 1) — totalFrames Defines the total number of frames used by the spritesheet, when in global mode. Defaults to the number defined by numColumns and numRows.
cyclePhase:Number (default = 0) — looping Defines whether the spritesheet animation is set to loop indefinitely. Defaults to true.
totalFrames:uint (default = NaN)
Method Detail
generatePropertyOfOneParticle () method
override arcane function generatePropertyOfOneParticle(param:ParticleProperties):void

Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.

Parameters

param:ParticleProperties

getAGALUVCode () method
override public function getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleSpriteSheetState

Parameters

animator:IAnimator

Returns
ParticleSpriteSheetState
processAnimationSetting () method
override arcane function processAnimationSetting(particleAnimationSet:ParticleAnimationSet):void

Called internally by the particle animation set when determining the requirements of the particle animation node AGAL.

Parameters

particleAnimationSet:ParticleAnimationSet

Constant Detail
UV_VECTOR3D Constant
public static const UV_VECTOR3D:String = UVVector3D

Reference for spritesheet node properties on a single particle (when in local property mode). Expects a Vector3D representing the cycleDuration (x), optional phaseTime (y).


away3d.animators.nodes.ParticleTimeNode

ParticleTimeNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleTimeNode
Inheritance | ParticleTimeNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used as the base node for timekeeping inside a particle. Automatically added to a particle animation set on instatiation.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleTimeNode(usesDuration:Boolean = false, usesLooping:Boolean = false, usesDelay:Boolean = false) Creates a new ParticleTimeNode | ParticleTimeNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
Inherited | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleTimeNode
 | getAnimationState(animator:IAnimator):ParticleTimeState | ParticleTimeNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
ParticleTimeNode () Constructor
public function ParticleTimeNode(usesDuration:Boolean = false, usesLooping:Boolean = false, usesDelay:Boolean = false)

Creates a new ParticleTimeNode

Parameters
usesDuration:Boolean (default = false) — usesDuration Defines whether the node uses the duration data in the static properties function to determine how long a particle is visible for. Defaults to false.
usesLooping:Boolean (default = false) — usesDelay Defines whether the node uses the delay data in the static properties function to determine how long a particle is hidden for. Defaults to false. Requires usesDuration to be true.
usesDelay:Boolean (default = false) — usesLooping Defines whether the node creates a looping timeframe for each particle determined by the startTime, duration and delay data in the static properties function. Defaults to false. Requires usesLooping to be true.
Method Detail
generatePropertyOfOneParticle () method
override arcane function generatePropertyOfOneParticle(param:ParticleProperties):void

Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.

Parameters

param:ParticleProperties

getAGALVertexCode () method
override public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleTimeState

Parameters

animator:IAnimator

Returns
ParticleTimeState


away3d.animators.nodes.ParticleUVNode

ParticleUVNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleUVNode
Inheritance | ParticleUVNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used to control the UV offset and scale of a particle over time.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
 | axis : String | ParticleUVNode
 | cycle : Number | ParticleUVNode
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
 | scale : Number | ParticleUVNode
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleUVNode(mode:uint, cycle:Number = 1, scale:Number = 1, axis:String = x) Creates a new ParticleTimeNode | ParticleUVNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
 | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleUVNode
Inherited | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleNodeBase
 | getAnimationState(animator:IAnimator):ParticleUVState | ParticleUVNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
 | GLOBAL : uint = 1 [static] Used to set the time node into global property mode. | ParticleUVNode
 | U_AXIS : String = x [static] | ParticleUVNode
 | V_AXIS : String = y [static] | ParticleUVNode
Property Detail
axis property
axis:String

Implementation
    public function get axis():String
    public function set axis(value:String):void
cycle property
cycle:Number

Implementation
    public function get cycle():Number
    public function set cycle(value:Number):void
scale property
scale:Number

Implementation
    public function get scale():Number
    public function set scale(value:Number):void
Constructor Detail
ParticleUVNode () Constructor
public function ParticleUVNode(mode:uint, cycle:Number = 1, scale:Number = 1, axis:String = x)

Creates a new ParticleTimeNode

Parameters
mode:uint — Defines whether the mode of operation acts on local properties of a particle or global properties of the node.
cycle:Number (default = 1) — cycle Defines whether the time track is in loop mode. Defaults to false.
scale:Number (default = 1) — scale Defines whether the time track is in loop mode. Defaults to false.
axis:String (default = x) — axis Defines whether the time track is in loop mode. Defaults to false.
Method Detail
getAGALUVCode () method
override public function getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleUVState

Parameters

animator:IAnimator

Returns
ParticleUVState
processAnimationSetting () method
override arcane function processAnimationSetting(particleAnimationSet:ParticleAnimationSet):void

Called internally by the particle animation set when determining the requirements of the particle animation node AGAL.

Parameters

particleAnimationSet:ParticleAnimationSet

Constant Detail
GLOBAL Constant
public static const GLOBAL:uint = 1

Used to set the time node into global property mode.

U_AXIS Constant
public static const U_AXIS:String = x

V_AXIS Constant
public static const V_AXIS:String = y


away3d.animators.nodes.ParticleVelocityNode

ParticleVelocityNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class ParticleVelocityNode
Inheritance | ParticleVelocityNode Inheritance ParticleNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A particle animation node used to set the starting velocity of a particle.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | dataLength : int [read-only] Returns the length of the data used by the node when in LOCAL_STATIC mode. | ParticleNodeBase
Inherited | mode : uint [read-only] Returns the property mode of the particle animation node. | ParticleNodeBase
Inherited | name : String | NamedAssetBase
Inherited | oneData : Vector.<Number> [read-only] Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set. | ParticleNodeBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | priority : int [read-only] Returns the priority of the particle animation node, used to order the agal generated in a particle animation set. | ParticleNodeBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dataLength : uint = 3 | ParticleNodeBase
Inherited | _mode : uint | ParticleNodeBase
Inherited | _oneData : Vector.<Number> | ParticleNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleVelocityNode(mode:uint, velocity:Vector3D = null) Creates a new ParticleVelocityNode | ParticleVelocityNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAGALFragmentCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader. | ParticleNodeBase
Inherited | getAGALUVCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required. | ParticleNodeBase
 | getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String [override] Returns the AGAL code of the particle animation node for use in the vertex shader. | ParticleVelocityNode
 | getAnimationState(animator:IAnimator):ParticleVelocityState | ParticleVelocityNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
 | VELOCITY_VECTOR3D : String = VelocityVector3D [static] Reference for velocity node properties on a single particle (when in local property mode). | ParticleVelocityNode
Constructor Detail
ParticleVelocityNode () Constructor
public function ParticleVelocityNode(mode:uint, velocity:Vector3D = null)

Creates a new ParticleVelocityNode

Parameters
mode:uint — Defines whether the mode of operation acts on local properties of a particle or global properties of the node.
velocity:Vector3D (default = null) — velocity Defines the default velocity vector of the node, used when in global mode.
Method Detail
generatePropertyOfOneParticle () method
override arcane function generatePropertyOfOneParticle(param:ParticleProperties):void

Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.

Parameters

param:ParticleProperties

getAGALVertexCode () method
override public function getAGALVertexCode(pass:MaterialPassBase, animationRegisterCache:AnimationRegisterCache):String

Returns the AGAL code of the particle animation node for use in the vertex shader.

Parameters

pass:MaterialPassBase
animationRegisterCache:AnimationRegisterCache

Returns
String
getAnimationState () method
public function getAnimationState(animator:IAnimator):ParticleVelocityState

Parameters

animator:IAnimator

Returns
ParticleVelocityState
Constant Detail
VELOCITY_VECTOR3D Constant
public static const VELOCITY_VECTOR3D:String = VelocityVector3D

Reference for velocity node properties on a single particle (when in local property mode). Expects a Vector3D object representing the direction of movement on the particle.


away3d.animators.nodes.SkeletonBinaryLERPNode

SkeletonBinaryLERPNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class SkeletonBinaryLERPNode
Inheritance | SkeletonBinaryLERPNode Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | CrossfadeTransitionNode

A skeleton animation node that uses two animation node inputs to blend a lineraly interpolated output of a skeleton pose.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
 | inputA : AnimationNodeBase Defines input node A to use for the blended output. | SkeletonBinaryLERPNode
 | inputB : AnimationNodeBase Defines input node B to use for the blended output. | SkeletonBinaryLERPNode
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkeletonBinaryLERPNode() Creates a new SkeletonBinaryLERPNode object. | SkeletonBinaryLERPNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
 | getAnimationState(animator:IAnimator):SkeletonBinaryLERPState | SkeletonBinaryLERPNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
inputA property
public var inputA:AnimationNodeBase

Defines input node A to use for the blended output.

inputB property
public var inputB:AnimationNodeBase

Defines input node B to use for the blended output.

Constructor Detail
SkeletonBinaryLERPNode () Constructor
public function SkeletonBinaryLERPNode()

Creates a new SkeletonBinaryLERPNode object.

Method Detail
getAnimationState () method
public function getAnimationState(animator:IAnimator):SkeletonBinaryLERPState

Parameters

animator:IAnimator

Returns
SkeletonBinaryLERPState


away3d.animators.nodes.SkeletonClipNode

SkeletonClipNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class SkeletonClipNode
Inheritance | SkeletonClipNode Inheritance AnimationClipNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A skeleton animation node containing time-based animation data as individual skeleton poses.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | durations : Vector.<uint> [read-only] Returns a vector of time values representing the duration (in milliseconds) of each animation frame in the clip. | AnimationClipNodeBase
Inherited | fixedFrameRate : Boolean = true | AnimationClipNodeBase
 | frames : Vector.<SkeletonPose> [read-only] Returns a vector of skeleton poses representing the pose of each animation frame in the clip. | SkeletonClipNode
 | highQuality : Boolean = false Determines whether to use SLERP equations (true) or LERP equations (false) in the calculation of the output skeleton pose. | SkeletonClipNode
Inherited | lastFrame : uint [read-only] | AnimationClipNodeBase
Inherited | looping : Boolean Determines whether the contents of the animation node have looping characteristics enabled. | AnimationClipNodeBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Inherited | stitchFinalFrame : Boolean Defines if looping content blends the final frame of animation data with the first (true) or works on the assumption that both first and last frames are identical (false). | AnimationClipNodeBase
Inherited | totalDelta : Vector3D [read-only] | AnimationClipNodeBase
Inherited | totalDuration : uint [read-only] | AnimationClipNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _durations : Vector.<uint> | AnimationClipNodeBase
Inherited | _lastFrame : uint | AnimationClipNodeBase
Inherited | _looping : Boolean = true | AnimationClipNodeBase
Inherited | _numFrames : uint = 0 | AnimationClipNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Inherited | _stitchDirty : Boolean = true | AnimationClipNodeBase
Inherited | _stitchFinalFrame : Boolean = false | AnimationClipNodeBase
Inherited | _totalDelta : Vector3D | AnimationClipNodeBase
Inherited | _totalDuration : uint = 0 | AnimationClipNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkeletonClipNode() Creates a new SkeletonClipNode object. | SkeletonClipNode
 | addFrame(skeletonPose:SkeletonPose, duration:uint):void Adds a skeleton pose frame to the internal timeline of the animation node. | SkeletonClipNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
 | getAnimationState(animator:IAnimator):SkeletonClipState | SkeletonClipNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Method |  | Defined By
 | updateStitch():void [override] Updates the node's final frame stitch state. | SkeletonClipNode
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
frames property
frames:Vector.<SkeletonPose> [read-only]

Returns a vector of skeleton poses representing the pose of each animation frame in the clip.

Implementation
    public function get frames():Vector.<SkeletonPose>
highQuality property
public var highQuality:Boolean = false

Determines whether to use SLERP equations (true) or LERP equations (false) in the calculation of the output skeleton pose. Defaults to false.

Constructor Detail
SkeletonClipNode () Constructor
public function SkeletonClipNode()

Creates a new SkeletonClipNode object.

Method Detail
addFrame () method
public function addFrame(skeletonPose:SkeletonPose, duration:uint):void

Adds a skeleton pose frame to the internal timeline of the animation node.

Parameters

skeletonPose:SkeletonPose — The skeleton pose object to add to the timeline of the node.
duration:uint — The specified duration of the frame in milliseconds.

getAnimationState () method
public function getAnimationState(animator:IAnimator):SkeletonClipState

Parameters

animator:IAnimator

Returns
SkeletonClipState
updateStitch () method
override protected function updateStitch():void

Updates the node's final frame stitch state.


away3d.animators.nodes.SkeletonDifferenceNode

SkeletonDifferenceNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class SkeletonDifferenceNode
Inheritance | SkeletonDifferenceNode Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A skeleton animation node that uses a difference input pose with a base input pose to blend a linearly interpolated output of a skeleton pose.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
 | baseInput : AnimationNodeBase Defines a base input node to use for the blended output. | SkeletonDifferenceNode
 | differenceInput : AnimationNodeBase Defines a difference input node to use for the blended output. | SkeletonDifferenceNode
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkeletonDifferenceNode() Creates a new SkeletonAdditiveNode object. | SkeletonDifferenceNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
 | getAnimationState(animator:IAnimator):SkeletonDifferenceState | SkeletonDifferenceNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
baseInput property
public var baseInput:AnimationNodeBase

Defines a base input node to use for the blended output.

differenceInput property
public var differenceInput:AnimationNodeBase

Defines a difference input node to use for the blended output.

Constructor Detail
SkeletonDifferenceNode () Constructor
public function SkeletonDifferenceNode()

Creates a new SkeletonAdditiveNode object.

Method Detail
getAnimationState () method
public function getAnimationState(animator:IAnimator):SkeletonDifferenceState

Parameters

animator:IAnimator

Returns
SkeletonDifferenceState


away3d.animators.nodes.SkeletonDirectionalNode

SkeletonDirectionalNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class SkeletonDirectionalNode
Inheritance | SkeletonDirectionalNode Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A skeleton animation node that uses four directional input poses with an input direction to blend a linearly interpolated output of a skeleton pose.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
 | backward : AnimationNodeBase Defines the backwards configured input node to use for the blended output. | SkeletonDirectionalNode
 | forward : AnimationNodeBase Defines the forward configured input node to use for the blended output. | SkeletonDirectionalNode
 | left : AnimationNodeBase Defines the left configured input node to use for the blended output. | SkeletonDirectionalNode
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | right : AnimationNodeBase Defines the right configured input node to use for the blended output. | SkeletonDirectionalNode
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkeletonDirectionalNode() | SkeletonDirectionalNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
 | getAnimationState(animator:IAnimator):SkeletonDirectionalState | SkeletonDirectionalNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
backward property
public var backward:AnimationNodeBase

Defines the backwards configured input node to use for the blended output.

forward property
public var forward:AnimationNodeBase

Defines the forward configured input node to use for the blended output.

left property
public var left:AnimationNodeBase

Defines the left configured input node to use for the blended output.

right property
public var right:AnimationNodeBase

Defines the right configured input node to use for the blended output.

Constructor Detail
SkeletonDirectionalNode () Constructor
public function SkeletonDirectionalNode()

Method Detail
getAnimationState () method
public function getAnimationState(animator:IAnimator):SkeletonDirectionalState

Parameters

animator:IAnimator

Returns
SkeletonDirectionalState


away3d.animators.nodes.SkeletonNaryLERPNode

SkeletonNaryLERPNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class SkeletonNaryLERPNode
Inheritance | SkeletonNaryLERPNode Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A skeleton animation node that uses an n-dimensional array of animation node inputs to blend a lineraly interpolated output of a skeleton pose.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | name : String | NamedAssetBase
 | numInputs : uint [read-only] | SkeletonNaryLERPNode
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkeletonNaryLERPNode() Creates a new SkeletonNaryLERPNode object. | SkeletonNaryLERPNode
 | addInput(input:AnimationNodeBase):void Adds a new skeleton animation node input to the animation node. | SkeletonNaryLERPNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
 | getAnimationState(animator:IAnimator):SkeletonNaryLERPState | SkeletonNaryLERPNode
 | getInputAt(index:uint):AnimationNodeBase Returns the skeleton animation node object that resides at the given input index. | SkeletonNaryLERPNode
 | getInputIndex(input:AnimationNodeBase):int Returns an integer representing the input index of the given skeleton animation node. | SkeletonNaryLERPNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_inputs property
arcane var _inputs:Vector.<AnimationNodeBase>

numInputs property
numInputs:uint [read-only]

Implementation
    public function get numInputs():uint
Constructor Detail
SkeletonNaryLERPNode () Constructor
public function SkeletonNaryLERPNode()

Creates a new SkeletonNaryLERPNode object.

Method Detail
addInput () method
public function addInput(input:AnimationNodeBase):void

Adds a new skeleton animation node input to the animation node.

Parameters

input:AnimationNodeBase

getAnimationState () method
public function getAnimationState(animator:IAnimator):SkeletonNaryLERPState

Parameters

animator:IAnimator

Returns
SkeletonNaryLERPState
getInputAt () method
public function getInputAt(index:uint):AnimationNodeBase

Returns the skeleton animation node object that resides at the given input index.

Parameters

index:uint — The input index for which the skeleton animation node is requested.

Returns
AnimationNodeBase
getInputIndex () method
public function getInputIndex(input:AnimationNodeBase):int

Returns an integer representing the input index of the given skeleton animation node.

Parameters

input:AnimationNodeBase — The skeleton animation node for with the input index is requested.

Returns
int


away3d.animators.nodes.UVClipNode

UVClipNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class UVClipNode
Inheritance | UVClipNode Inheritance AnimationClipNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A uv animation node containing time-based animation data as individual uv animation frames.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | durations : Vector.<uint> [read-only] Returns a vector of time values representing the duration (in milliseconds) of each animation frame in the clip. | AnimationClipNodeBase
Inherited | fixedFrameRate : Boolean = true | AnimationClipNodeBase
 | frames : Vector.<UVAnimationFrame> [read-only] Returns a vector of UV frames representing the uv values of each animation frame in the clip. | UVClipNode
Inherited | lastFrame : uint [read-only] | AnimationClipNodeBase
Inherited | looping : Boolean Determines whether the contents of the animation node have looping characteristics enabled. | AnimationClipNodeBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Inherited | stitchFinalFrame : Boolean Defines if looping content blends the final frame of animation data with the first (true) or works on the assumption that both first and last frames are identical (false). | AnimationClipNodeBase
Inherited | totalDelta : Vector3D [read-only] | AnimationClipNodeBase
Inherited | totalDuration : uint [read-only] | AnimationClipNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _durations : Vector.<uint> | AnimationClipNodeBase
Inherited | _lastFrame : uint | AnimationClipNodeBase
Inherited | _looping : Boolean = true | AnimationClipNodeBase
Inherited | _numFrames : uint = 0 | AnimationClipNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Inherited | _stitchDirty : Boolean = true | AnimationClipNodeBase
Inherited | _stitchFinalFrame : Boolean = false | AnimationClipNodeBase
Inherited | _totalDelta : Vector3D | AnimationClipNodeBase
Inherited | _totalDuration : uint = 0 | AnimationClipNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | UVClipNode() Creates a new UVClipNode object. | UVClipNode
 | addFrame(uvFrame:UVAnimationFrame, duration:uint):void Adds a UV frame object to the internal timeline of the animation node. | UVClipNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Method |  | Defined By
 | updateStitch():void [override] Updates the node's final frame stitch state. | UVClipNode
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
frames property
frames:Vector.<UVAnimationFrame> [read-only]

Returns a vector of UV frames representing the uv values of each animation frame in the clip.

Implementation
    public function get frames():Vector.<UVAnimationFrame>
Constructor Detail
UVClipNode () Constructor
public function UVClipNode()

Creates a new UVClipNode object.

Method Detail
addFrame () method
public function addFrame(uvFrame:UVAnimationFrame, duration:uint):void

Adds a UV frame object to the internal timeline of the animation node.

Parameters

uvFrame:UVAnimationFrame — The uv frame object to add to the timeline of the node.
duration:uint — The specified duration of the frame in milliseconds.

updateStitch () method
override protected function updateStitch():void

Updates the node's final frame stitch state.


away3d.animators.nodes.VertexClipNode

VertexClipNode | Properties | Methods | Constants
Package | away3d.animators.nodes
Class | public class VertexClipNode
Inheritance | VertexClipNode Inheritance AnimationClipNodeBase Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A vertex animation node containing time-based animation data as individual geometry obejcts.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
Inherited | durations : Vector.<uint> [read-only] Returns a vector of time values representing the duration (in milliseconds) of each animation frame in the clip. | AnimationClipNodeBase
Inherited | fixedFrameRate : Boolean = true | AnimationClipNodeBase
 | frames : Vector.<Geometry> [read-only] Returns a vector of geometry frames representing the vertex values of each animation frame in the clip. | VertexClipNode
Inherited | lastFrame : uint [read-only] | AnimationClipNodeBase
Inherited | looping : Boolean Determines whether the contents of the animation node have looping characteristics enabled. | AnimationClipNodeBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Inherited | stitchFinalFrame : Boolean Defines if looping content blends the final frame of animation data with the first (true) or works on the assumption that both first and last frames are identical (false). | AnimationClipNodeBase
Inherited | totalDelta : Vector3D [read-only] | AnimationClipNodeBase
Inherited | totalDuration : uint [read-only] | AnimationClipNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _durations : Vector.<uint> | AnimationClipNodeBase
Inherited | _lastFrame : uint | AnimationClipNodeBase
Inherited | _looping : Boolean = true | AnimationClipNodeBase
Inherited | _numFrames : uint = 0 | AnimationClipNodeBase
Inherited | _stateClass : Class | AnimationNodeBase
Inherited | _stitchDirty : Boolean = true | AnimationClipNodeBase
Inherited | _stitchFinalFrame : Boolean = false | AnimationClipNodeBase
Inherited | _totalDelta : Vector3D | AnimationClipNodeBase
Inherited | _totalDuration : uint = 0 | AnimationClipNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | VertexClipNode() Creates a new VertexClipNode object. | VertexClipNode
 | addFrame(geometry:Geometry, duration:uint, translation:Vector3D = null):void Adds a geometry object to the internal timeline of the animation node. | VertexClipNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Method |  | Defined By
 | updateStitch():void [override] Updates the node's final frame stitch state. | VertexClipNode
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
frames property
frames:Vector.<Geometry> [read-only]

Returns a vector of geometry frames representing the vertex values of each animation frame in the clip.

Implementation
    public function get frames():Vector.<Geometry>
Constructor Detail
VertexClipNode () Constructor
public function VertexClipNode()

Creates a new VertexClipNode object.

Method Detail
addFrame () method
public function addFrame(geometry:Geometry, duration:uint, translation:Vector3D = null):void

Adds a geometry object to the internal timeline of the animation node.

Parameters

geometry:Geometry — The geometry object to add to the timeline of the node.
duration:uint — The specified duration of the frame in milliseconds.
translation:Vector3D (default = null) — The absolute translation of the frame, used in root delta calculations for mesh movement.

updateStitch () method
override protected function updateStitch():void

Updates the node's final frame stitch state.


away3d.animators.states - Away3D Documentation

Package away3d.animators.states

Interfaces
IAnimationState
ISkeletonAnimationState
IUVAnimationState
IVertexAnimationState
Classes
AnimationClipState
AnimationStateBase
ParticleAccelerationState
ParticleBezierCurveState
ParticleBillboardState
ParticleColorState
ParticleFollowState
ParticleOrbitState
ParticleOscillatorState
ParticlePositionState
ParticleRotateToHeadingState
ParticleRotationalVelocityState
ParticleScaleState
ParticleSpriteSheetState
ParticleStateBase
ParticleTimeState
ParticleUVState
ParticleVelocityState
SkeletonBinaryLERPState
SkeletonClipState
SkeletonDifferenceState
SkeletonDirectionalState
SkeletonNaryLERPState
UVClipState
VertexClipState


away3d.animators.states Summary

away3d.animators.states | Interfaces | Classes

Interfaces
Interface | Description
IAnimationState |
ISkeletonAnimationState |
IUVAnimationState | Provides an interface for animation node classes that hold animation data for use in the UV animator class.
IVertexAnimationState | Provides an interface for animation node classes that hold animation data for use in the Vertex animator class.
Classes
Class | Description
AnimationClipState |
AnimationStateBase |
ParticleAccelerationState | ...
ParticleBezierCurveState | ...
ParticleBillboardState | ...
ParticleColorState | ...
ParticleFollowState | ...
ParticleOrbitState | ...
ParticleOscillatorState | ...
ParticlePositionState | ...
ParticleRotateToHeadingState | ...
ParticleRotationalVelocityState | ...
ParticleScaleState | ...
ParticleSpriteSheetState | ...
ParticleStateBase | ...
ParticleTimeState | ...
ParticleUVState | ...
ParticleVelocityState | ...
SkeletonBinaryLERPState |
SkeletonClipState |
SkeletonDifferenceState |
SkeletonDirectionalState |
SkeletonNaryLERPState |
UVClipState |
VertexClipState |

Thu Nov 15 2012, 12:09 PM Z


away3d.animators.states.AnimationClipState

AnimationClipState | Properties | Methods
Package | away3d.animators.states
Class | public class AnimationClipState
Inheritance | AnimationClipState Inheritance AnimationStateBase Inheritance Object
Subclasses | SkeletonClipState, UVClipState, VertexClipState

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | blendWeight : Number [read-only] Returns a fractional value between 0 and 1 representing the blending ratio of the current playhead position between the current frame (0) and next frame (1) of the animation. | AnimationClipState
 | currentFrame : uint [read-only] Returns the current frame of animation in the clip based on the internal playhead position. | AnimationClipState
 | nextFrame : uint [read-only] Returns the next frame of animation in the clip based on the internal playhead position. | AnimationClipState
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
 | _blendWeight : Number | AnimationClipState
 | _currentFrame : uint | AnimationClipState
 | _framesDirty : Boolean = true | AnimationClipState
 | _nextFrame : uint | AnimationClipState
 | _oldFrame : uint | AnimationClipState
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
 | _timeDir : int | AnimationClipState
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | AnimationClipState(animator:IAnimator, animationClipNode:AnimationClipNodeBase) | AnimationClipState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
 | phase(value:Number):void [override] Sets the animation phase of the node. | AnimationClipState
 | update(time:int):void [override] Updates the configuration of the node to its current state. | AnimationClipState
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | updateFrames():void Updates the nodes internal playhead to determine the current and next animation frame, and the blendWeight between the two. | AnimationClipState
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
 | updateTime(time:int):void [override] Updates the node's internal playhead position. | AnimationClipState
Property Detail
_blendWeight property
protected var _blendWeight:Number

_currentFrame property
protected var _currentFrame:uint

_framesDirty property
protected var _framesDirty:Boolean = true

_nextFrame property
protected var _nextFrame:uint

_oldFrame property
protected var _oldFrame:uint

_timeDir property
protected var _timeDir:int

blendWeight property
blendWeight:Number [read-only]

Returns a fractional value between 0 and 1 representing the blending ratio of the current playhead position between the current frame (0) and next frame (1) of the animation.

Implementation
    public function get blendWeight():Number

See also

currentFrame
nextFrame
currentFrame property
currentFrame:uint [read-only]

Returns the current frame of animation in the clip based on the internal playhead position.

Implementation
    public function get currentFrame():uint
nextFrame property
nextFrame:uint [read-only]

Returns the next frame of animation in the clip based on the internal playhead position.

Implementation
    public function get nextFrame():uint
Constructor Detail
AnimationClipState () Constructor
public function AnimationClipState(animator:IAnimator, animationClipNode:AnimationClipNodeBase)

Parameters
animator:IAnimator
animationClipNode:AnimationClipNodeBase
Method Detail
phase () method
override public function phase(value:Number):void

Sets the animation phase of the node.

Parameters

value:Number — The phase value to use. 0 represents the beginning of an animation clip, 1 represents the end.

update () method
override public function update(time:int):void

Updates the configuration of the node to its current state.

Parameters

time:int — The absolute time (in milliseconds) of the animator's play head position.

updateFrames () method
protected function updateFrames():void

Updates the nodes internal playhead to determine the current and next animation frame, and the blendWeight between the two.

See also

currentFrame
nextFrame
blendWeight
updateTime () method
override protected function updateTime(time:int):void

Updates the node's internal playhead position.

Parameters

time:int — The local time (in milliseconds) of the node's playhead position.


away3d.animators.states.AnimationStateBase

AnimationStateBase | Properties | Methods
Package | away3d.animators.states
Class | public class AnimationStateBase
Inheritance | AnimationStateBase Inheritance Object
Implements | IAnimationState
Subclasses | AnimationClipState, ParticleStateBase, SkeletonBinaryLERPState, SkeletonDifferenceState, SkeletonDirectionalState, SkeletonNaryLERPState

Public Properties
Property |  | Defined By
 | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Property |  | Defined By
 | _animationNode : AnimationNodeBase | AnimationStateBase
 | _animator : IAnimator | AnimationStateBase
 | _positionDeltaDirty : Boolean = true | AnimationStateBase
 | _rootDelta : Vector3D | AnimationStateBase
 | _startTime : int | AnimationStateBase
 | _time : int | AnimationStateBase
Public Methods
Method |  | Defined By
 | AnimationStateBase(animator:IAnimator, animationNode:AnimationNodeBase) | AnimationStateBase
 | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
 | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Method |  | Defined By
 | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
 | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Property Detail
_animationNode property
protected var _animationNode:AnimationNodeBase

_animator property
protected var _animator:IAnimator

_positionDeltaDirty property
protected var _positionDeltaDirty:Boolean = true

_rootDelta property
protected var _rootDelta:Vector3D

_startTime property
protected var _startTime:int

_time property
protected var _time:int

positionDelta property
positionDelta:Vector3D [read-only]

Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation

Implementation
    public function get positionDelta():Vector3D
Constructor Detail
AnimationStateBase () Constructor
public function AnimationStateBase(animator:IAnimator, animationNode:AnimationNodeBase)

Parameters
animator:IAnimator
animationNode:AnimationNodeBase
Method Detail
offset () method
public function offset(startTime:int):void

Resets the start time of the node to a new value.

Parameters

startTime:int — The absolute start time (in milliseconds) of the node's starting time.

phase () method
public function phase(value:Number):void

Sets the animation phase of the node.

Parameters

value:Number — The phase value to use. 0 represents the beginning of an animation clip, 1 represents the end.

update () method
public function update(time:int):void

Updates the configuration of the node to its current state.

Parameters

time:int — The absolute time (in milliseconds) of the animator's play head position.

See also

away3d.animators.AnimatorBase.update()
updatePositionDelta () method
protected function updatePositionDelta():void

Updates the node's root delta position

updateTime () method
protected function updateTime(time:int):void

Updates the node's internal playhead position.

Parameters

time:int — The local time (in milliseconds) of the node's playhead position.


away3d.animators.states.IAnimationState

IAnimationState | Properties | Methods
Package | away3d.animators.states
Interface | public interface IAnimationState
Implementors | AnimationStateBase

Public Properties
Property |  | Defined By
 | positionDelta : Vector3D [read-only] | IAnimationState
Public Methods
Method |  | Defined By
 | offset(startTime:int):void | IAnimationState
 | phase(value:Number):void Sets the animation phase of the node. | IAnimationState
 | update(time:int):void | IAnimationState
Property Detail
positionDelta property
positionDelta:Vector3D [read-only]

Implementation
    public function get positionDelta():Vector3D
Method Detail
offset () method
public function offset(startTime:int):void

Parameters

startTime:int

phase () method
public function phase(value:Number):void

Sets the animation phase of the node.

Parameters

value:Number — The phase value to use. 0 represents the beginning of an animation clip, 1 represents the end.

update () method
public function update(time:int):void

Parameters

time:int


away3d.animators.states.ISkeletonAnimationState

ISkeletonAnimationState | Methods
Package | away3d.animators.states
Interface | public interface ISkeletonAnimationState extends IAnimationState
Implementors | SkeletonBinaryLERPState, SkeletonClipState, SkeletonDifferenceState, SkeletonDirectionalState, SkeletonNaryLERPState

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | positionDelta : Vector3D [read-only] | IAnimationState
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | getSkeletonPose(skeleton:Skeleton):SkeletonPose Returns the output skeleton pose of the animation node. | ISkeletonAnimationState
Inherited | offset(startTime:int):void | IAnimationState
Inherited | phase(value:Number):void Sets the animation phase of the node. | IAnimationState
Inherited | update(time:int):void | IAnimationState
Method Detail
getSkeletonPose () method
public function getSkeletonPose(skeleton:Skeleton):SkeletonPose

Returns the output skeleton pose of the animation node.

Parameters

skeleton:Skeleton

Returns
SkeletonPose


away3d.animators.states.IUVAnimationState

IUVAnimationState | Properties
Package | away3d.animators.states
Interface | public interface IUVAnimationState extends IAnimationState
Implementors | UVClipState

Provides an interface for animation node classes that hold animation data for use in the UV animator class.

See also

away3d.animators.UVAnimator

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | blendWeight : Number [read-only] Returns a fractional value between 0 and 1 representing the blending ratio of the current playhead position between the current uv frame (0) and next uv frame (1) of the animation. | IUVAnimationState
 | currentUVFrame : UVAnimationFrame [read-only] Returns the current UV frame of animation in the clip based on the internal playhead position. | IUVAnimationState
 | nextUVFrame : UVAnimationFrame [read-only] Returns the next UV frame of animation in the clip based on the internal playhead position. | IUVAnimationState
Inherited | positionDelta : Vector3D [read-only] | IAnimationState
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
Inherited | offset(startTime:int):void | IAnimationState
Inherited | phase(value:Number):void Sets the animation phase of the node. | IAnimationState
Inherited | update(time:int):void | IAnimationState
Property Detail
blendWeight property
blendWeight:Number [read-only]

Returns a fractional value between 0 and 1 representing the blending ratio of the current playhead position between the current uv frame (0) and next uv frame (1) of the animation.

Implementation
    public function get blendWeight():Number
currentUVFrame property
currentUVFrame:UVAnimationFrame [read-only]

Returns the current UV frame of animation in the clip based on the internal playhead position.

Implementation
    public function get currentUVFrame():UVAnimationFrame
nextUVFrame property
nextUVFrame:UVAnimationFrame [read-only]

Returns the next UV frame of animation in the clip based on the internal playhead position.

Implementation
    public function get nextUVFrame():UVAnimationFrame


away3d.animators.states.IVertexAnimationState

IVertexAnimationState | Properties
Package | away3d.animators.states
Interface | public interface IVertexAnimationState extends IAnimationState
Implementors | VertexClipState

Provides an interface for animation node classes that hold animation data for use in the Vertex animator class.

See also

away3d.animators.VertexAnimator

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | blendWeight : Number [read-only] Returns a fractional value between 0 and 1 representing the blending ratio of the current playhead position between the current geometry frame (0) and next geometry frame (1) of the animation. | IVertexAnimationState
 | currentGeometry : Geometry [read-only] Returns the current geometry frame of animation in the clip based on the internal playhead position. | IVertexAnimationState
 | nextGeometry : Geometry [read-only] Returns the current geometry frame of animation in the clip based on the internal playhead position. | IVertexAnimationState
Inherited | positionDelta : Vector3D [read-only] | IAnimationState
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
Inherited | offset(startTime:int):void | IAnimationState
Inherited | phase(value:Number):void Sets the animation phase of the node. | IAnimationState
Inherited | update(time:int):void | IAnimationState
Property Detail
blendWeight property
blendWeight:Number [read-only]

Returns a fractional value between 0 and 1 representing the blending ratio of the current playhead position between the current geometry frame (0) and next geometry frame (1) of the animation.

Implementation
    public function get blendWeight():Number
currentGeometry property
currentGeometry:Geometry [read-only]

Returns the current geometry frame of animation in the clip based on the internal playhead position.

Implementation
    public function get currentGeometry():Geometry
nextGeometry property
nextGeometry:Geometry [read-only]

Returns the current geometry frame of animation in the clip based on the internal playhead position.

Implementation
    public function get nextGeometry():Geometry


away3d.animators.states.ParticleAccelerationState

ParticleAccelerationState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleAccelerationState
Inheritance | ParticleAccelerationState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | acceleration : Vector3D Defines the acceleration vector of the state, used when in global mode. | ParticleAccelerationState
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleAccelerationState(animator:ParticleAnimator, particleAccelerationNode:ParticleAccelerationNode) | ParticleAccelerationState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleAccelerationState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Property Detail
acceleration property
acceleration:Vector3D

Defines the acceleration vector of the state, used when in global mode.

Implementation
    public function get acceleration():Vector3D
    public function set acceleration(value:Vector3D):void
Constructor Detail
ParticleAccelerationState () Constructor
public function ParticleAccelerationState(animator:ParticleAnimator, particleAccelerationNode:ParticleAccelerationNode)

Parameters
animator:ParticleAnimator
particleAccelerationNode:ParticleAccelerationNode
Method Detail
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D


away3d.animators.states.ParticleBezierCurveState

ParticleBezierCurveState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleBezierCurveState
Inheritance | ParticleBezierCurveState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | controlPoint : Vector3D Defines the default control point of the node, used when in global mode. | ParticleBezierCurveState
 | endPoint : Vector3D Defines the default end point of the node, used when in global mode. | ParticleBezierCurveState
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleBezierCurveState(animator:ParticleAnimator, particleBezierCurveNode:ParticleBezierCurveNode) | ParticleBezierCurveState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleBezierCurveState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Property Detail
controlPoint property
controlPoint:Vector3D

Defines the default control point of the node, used when in global mode.

Implementation
    public function get controlPoint():Vector3D
    public function set controlPoint(value:Vector3D):void
endPoint property
endPoint:Vector3D

Defines the default end point of the node, used when in global mode.

Implementation
    public function get endPoint():Vector3D
    public function set endPoint(value:Vector3D):void
Constructor Detail
ParticleBezierCurveState () Constructor
public function ParticleBezierCurveState(animator:ParticleAnimator, particleBezierCurveNode:ParticleBezierCurveNode)

Parameters
animator:ParticleAnimator
particleBezierCurveNode:ParticleBezierCurveNode
Method Detail
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D


away3d.animators.states.ParticleBillboardState

ParticleBillboardState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleBillboardState
Inheritance | ParticleBillboardState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleBillboardState(animator:ParticleAnimator, particleNode:ParticleNodeBase) | ParticleBillboardState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleBillboardState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Constructor Detail
ParticleBillboardState () Constructor
public function ParticleBillboardState(animator:ParticleAnimator, particleNode:ParticleNodeBase)

Parameters
animator:ParticleAnimator
particleNode:ParticleNodeBase
Method Detail
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D


away3d.animators.states.ParticleColorState

ParticleColorState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleColorState
Inheritance | ParticleColorState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | cycleDuration : Number Defines the duration of the animation in seconds, used as a period independent of particle duration when in global mode. | ParticleColorState
 | cyclePhase : Number Defines the phase of the cycle in degrees, used as the starting offset of the cycle when in global mode. | ParticleColorState
 | endColor : ColorTransform Defines the end color transform of the state, when in global mode. | ParticleColorState
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
 | startColor : ColorTransform Defines the start color transform of the state, when in global mode. | ParticleColorState
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleColorState(animator:ParticleAnimator, particleColorNode:ParticleColorNode) | ParticleColorState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleColorState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Property Detail
cycleDuration property
cycleDuration:Number

Defines the duration of the animation in seconds, used as a period independent of particle duration when in global mode. Defaults to 1.

Implementation
    public function get cycleDuration():Number
    public function set cycleDuration(value:Number):void
cyclePhase property
cyclePhase:Number

Defines the phase of the cycle in degrees, used as the starting offset of the cycle when in global mode. Defaults to 0.

Implementation
    public function get cyclePhase():Number
    public function set cyclePhase(value:Number):void
endColor property
endColor:ColorTransform

Defines the end color transform of the state, when in global mode.

Implementation
    public function get endColor():ColorTransform
    public function set endColor(value:ColorTransform):void
startColor property
startColor:ColorTransform

Defines the start color transform of the state, when in global mode.

Implementation
    public function get startColor():ColorTransform
    public function set startColor(value:ColorTransform):void
Constructor Detail
ParticleColorState () Constructor
public function ParticleColorState(animator:ParticleAnimator, particleColorNode:ParticleColorNode)

Parameters
animator:ParticleAnimator
particleColorNode:ParticleColorNode
Method Detail
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D


away3d.animators.states.ParticleFollowState

ParticleFollowState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleFollowState
Inheritance | ParticleFollowState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | followTarget : Object3D | ParticleFollowState
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleFollowState(animator:ParticleAnimator, particleFollowNode:ParticleFollowNode) | ParticleFollowState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleFollowState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Property Detail
followTarget property
followTarget:Object3D

Implementation
    public function get followTarget():Object3D
    public function set followTarget(value:Object3D):void
Constructor Detail
ParticleFollowState () Constructor
public function ParticleFollowState(animator:ParticleAnimator, particleFollowNode:ParticleFollowNode)

Parameters
animator:ParticleAnimator
particleFollowNode:ParticleFollowNode
Method Detail
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D


away3d.animators.states.ParticleOrbitState

ParticleOrbitState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleOrbitState
Inheritance | ParticleOrbitState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | cycleDuration : Number Defines the duration of the orbit in seconds, used as a period independent of particle duration when in global mode. | ParticleOrbitState
 | cyclePhase : Number Defines the phase of the orbit in degrees, used as the starting offset of the cycle when in global mode. | ParticleOrbitState
 | eulers : Vector3D Defines the euler rotation in degrees, applied to the orientation of the orbit when in global mode. | ParticleOrbitState
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
 | radius : Number Defines the radius of the orbit when in global mode. | ParticleOrbitState
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleOrbitState(animator:ParticleAnimator, particleOrbitNode:ParticleOrbitNode) | ParticleOrbitState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleOrbitState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Property Detail
cycleDuration property
cycleDuration:Number

Defines the duration of the orbit in seconds, used as a period independent of particle duration when in global mode. Defaults to 1.

Implementation
    public function get cycleDuration():Number
    public function set cycleDuration(value:Number):void
cyclePhase property
cyclePhase:Number

Defines the phase of the orbit in degrees, used as the starting offset of the cycle when in global mode. Defaults to 0.

Implementation
    public function get cyclePhase():Number
    public function set cyclePhase(value:Number):void
eulers property
eulers:Vector3D

Defines the euler rotation in degrees, applied to the orientation of the orbit when in global mode.

Implementation
    public function get eulers():Vector3D
    public function set eulers(value:Vector3D):void
radius property
radius:Number

Defines the radius of the orbit when in global mode. Defaults to 100.

Implementation
    public function get radius():Number
    public function set radius(value:Number):void
Constructor Detail
ParticleOrbitState () Constructor
public function ParticleOrbitState(animator:ParticleAnimator, particleOrbitNode:ParticleOrbitNode)

Parameters
animator:ParticleAnimator
particleOrbitNode:ParticleOrbitNode
Method Detail
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D


away3d.animators.states.ParticleOscillatorState

ParticleOscillatorState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleOscillatorState
Inheritance | ParticleOscillatorState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
 | oscillator : Vector3D Defines the default oscillator axis (x, y, z) and cycleDuration (w) of the state, used when in global mode. | ParticleOscillatorState
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleOscillatorState(animator:ParticleAnimator, particleOscillatorNode:ParticleOscillatorNode) | ParticleOscillatorState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleOscillatorState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Property Detail
oscillator property
oscillator:Vector3D

Defines the default oscillator axis (x, y, z) and cycleDuration (w) of the state, used when in global mode.

Implementation
    public function get oscillator():Vector3D
    public function set oscillator(value:Vector3D):void
Constructor Detail
ParticleOscillatorState () Constructor
public function ParticleOscillatorState(animator:ParticleAnimator, particleOscillatorNode:ParticleOscillatorNode)

Parameters
animator:ParticleAnimator
particleOscillatorNode:ParticleOscillatorNode
Method Detail
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D


away3d.animators.states.ParticlePositionState

ParticlePositionState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticlePositionState
Inheritance | ParticlePositionState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
 | position : Vector3D Defines the position of the particle when in global mode. | ParticlePositionState
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticlePositionState(animator:ParticleAnimator, particlePositionNode:ParticlePositionNode) | ParticlePositionState
 | getPositions():Vector.<Vector3D> | ParticlePositionState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setPositions(value:Vector.<Vector3D>):void | ParticlePositionState
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticlePositionState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Property Detail
position property
position:Vector3D

Defines the position of the particle when in global mode. Defaults to 0,0,0.

Implementation
    public function get position():Vector3D
    public function set position(value:Vector3D):void
Constructor Detail
ParticlePositionState () Constructor
public function ParticlePositionState(animator:ParticleAnimator, particlePositionNode:ParticlePositionNode)

Parameters
animator:ParticleAnimator
particlePositionNode:ParticlePositionNode
Method Detail
getPositions () method
public function getPositions():Vector.<Vector3D>

Returns
Vector.<Vector3D>
setPositions () method
public function setPositions(value:Vector.<Vector3D>):void

Parameters

value:Vector.<Vector3D>

setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D


away3d.animators.states.ParticleRotateToHeadingState

ParticleRotateToHeadingState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleRotateToHeadingState
Inheritance | ParticleRotateToHeadingState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleRotateToHeadingState(animator:ParticleAnimator, particleNode:ParticleNodeBase) | ParticleRotateToHeadingState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleRotateToHeadingState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Constructor Detail
ParticleRotateToHeadingState () Constructor
public function ParticleRotateToHeadingState(animator:ParticleAnimator, particleNode:ParticleNodeBase)

Parameters
animator:ParticleAnimator
particleNode:ParticleNodeBase
Method Detail
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D


away3d.animators.states.ParticleRotationalVelocityState

ParticleRotationalVelocityState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleRotationalVelocityState
Inheritance | ParticleRotationalVelocityState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
 | rotationalVelocity : Vector3D Defines the default rotationalVelocity of the state, used when in global mode. | ParticleRotationalVelocityState
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleRotationalVelocityState(animator:ParticleAnimator, particleRotationNode:ParticleRotationalVelocityNode) | ParticleRotationalVelocityState
 | getRotationalVelocities():Vector.<Vector3D> | ParticleRotationalVelocityState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleRotationalVelocityState
 | setRotationalVelocities(value:Vector.<Vector3D>):void | ParticleRotationalVelocityState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Property Detail
rotationalVelocity property
rotationalVelocity:Vector3D

Defines the default rotationalVelocity of the state, used when in global mode.

Implementation
    public function get rotationalVelocity():Vector3D
    public function set rotationalVelocity(value:Vector3D):void
Constructor Detail
ParticleRotationalVelocityState () Constructor
public function ParticleRotationalVelocityState(animator:ParticleAnimator, particleRotationNode:ParticleRotationalVelocityNode)

Parameters
animator:ParticleAnimator
particleRotationNode:ParticleRotationalVelocityNode
Method Detail
getRotationalVelocities () method
public function getRotationalVelocities():Vector.<Vector3D>

Returns
Vector.<Vector3D>
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D

setRotationalVelocities () method
public function setRotationalVelocities(value:Vector.<Vector3D>):void

Parameters

value:Vector.<Vector3D>


away3d.animators.states.ParticleScaleState

ParticleScaleState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleScaleState
Inheritance | ParticleScaleState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | cycleDuration : Number Defines the duration of the animation in seconds, used as a period independent of particle duration when in global mode. | ParticleScaleState
 | cyclePhase : Number Defines the phase of the cycle in degrees, used as the starting offset of the cycle when in global mode. | ParticleScaleState
 | maxScale : Number Defines the end scale of the state, when in global mode. | ParticleScaleState
 | minScale : Number Defines the end scale of the state, when in global mode. | ParticleScaleState
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleScaleState(animator:ParticleAnimator, particleScaleNode:ParticleScaleNode) | ParticleScaleState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleScaleState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Property Detail
cycleDuration property
cycleDuration:Number

Defines the duration of the animation in seconds, used as a period independent of particle duration when in global mode. Defaults to 1.

Implementation
    public function get cycleDuration():Number
    public function set cycleDuration(value:Number):void
cyclePhase property
cyclePhase:Number

Defines the phase of the cycle in degrees, used as the starting offset of the cycle when in global mode. Defaults to 0.

Implementation
    public function get cyclePhase():Number
    public function set cyclePhase(value:Number):void
maxScale property
maxScale:Number

Defines the end scale of the state, when in global mode. Defaults to 1.

Implementation
    public function get maxScale():Number
    public function set maxScale(value:Number):void
minScale property
minScale:Number

Defines the end scale of the state, when in global mode. Defaults to 1.

Implementation
    public function get minScale():Number
    public function set minScale(value:Number):void
Constructor Detail
ParticleScaleState () Constructor
public function ParticleScaleState(animator:ParticleAnimator, particleScaleNode:ParticleScaleNode)

Parameters
animator:ParticleAnimator
particleScaleNode:ParticleScaleNode
Method Detail
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D


away3d.animators.states.ParticleSpriteSheetState

ParticleSpriteSheetState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleSpriteSheetState
Inheritance | ParticleSpriteSheetState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | cycleDuration : Number Defines the cycle duration in seconds, when in global mode. | ParticleSpriteSheetState
 | cyclePhase : Number Defines the cycle phase, when in global mode. | ParticleSpriteSheetState
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleSpriteSheetState(animator:ParticleAnimator, particleSpriteSheetNode:ParticleSpriteSheetNode) | ParticleSpriteSheetState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleSpriteSheetState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Property Detail
cycleDuration property
cycleDuration:Number

Defines the cycle duration in seconds, when in global mode. Defaults to 1.

Implementation
    public function get cycleDuration():Number
    public function set cycleDuration(value:Number):void
cyclePhase property
cyclePhase:Number

Defines the cycle phase, when in global mode. Defaults to zero.

Implementation
    public function get cyclePhase():Number
    public function set cyclePhase(value:Number):void
Constructor Detail
ParticleSpriteSheetState () Constructor
public function ParticleSpriteSheetState(animator:ParticleAnimator, particleSpriteSheetNode:ParticleSpriteSheetNode)

Parameters
animator:ParticleAnimator
particleSpriteSheetNode:ParticleSpriteSheetNode
Method Detail
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D


away3d.animators.states.ParticleStateBase

ParticleStateBase | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleStateBase
Inheritance | ParticleStateBase Inheritance AnimationStateBase Inheritance Object
Subclasses | ParticleAccelerationState, ParticleBezierCurveState, ParticleBillboardState, ParticleColorState, ParticleFollowState, ParticleOrbitState, ParticleOscillatorState, ParticlePositionState, ParticleRotateToHeadingState, ParticleRotationalVelocityState, ParticleScaleState, ParticleSpriteSheetState, ParticleTimeState, ParticleUVState, ParticleVelocityState

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
 | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
 | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
 | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleStateBase(animator:ParticleAnimator, particleNode:ParticleNodeBase, needUpdateTime:Boolean = false) | ParticleStateBase
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void | ParticleStateBase
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Property Detail
_dynamicProperties property
protected var _dynamicProperties:Vector.<Vector3D>

_dynamicPropertiesDirty property
protected var _dynamicPropertiesDirty:Dictionary

_needUpdateTime property
protected var _needUpdateTime:Boolean

needUpdateTime property
needUpdateTime:Boolean [read-only]

Implementation
    public function get needUpdateTime():Boolean
Constructor Detail
ParticleStateBase () Constructor
public function ParticleStateBase(animator:ParticleAnimator, particleNode:ParticleNodeBase, needUpdateTime:Boolean = false)

Parameters
animator:ParticleAnimator
particleNode:ParticleNodeBase
needUpdateTime:Boolean (default = false)
Method Detail
setRenderState () method
public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D

updateDynamicProperties () method
protected function updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void

Parameters

animationSubGeometry:AnimationSubGeometry


away3d.animators.states.ParticleTimeState

ParticleTimeState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleTimeState
Inheritance | ParticleTimeState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleTimeState(animator:ParticleAnimator, particleTimeNode:ParticleTimeNode) | ParticleTimeState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleTimeState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Constructor Detail
ParticleTimeState () Constructor
public function ParticleTimeState(animator:ParticleAnimator, particleTimeNode:ParticleTimeNode)

Parameters
animator:ParticleAnimator
particleTimeNode:ParticleTimeNode
Method Detail
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D


away3d.animators.states.ParticleUVState

ParticleUVState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleUVState
Inheritance | ParticleUVState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleUVState(animator:ParticleAnimator, particleUVNode:ParticleUVNode) | ParticleUVState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleUVState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Constructor Detail
ParticleUVState () Constructor
public function ParticleUVState(animator:ParticleAnimator, particleUVNode:ParticleUVNode)

Parameters
animator:ParticleAnimator
particleUVNode:ParticleUVNode
Method Detail
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D


away3d.animators.states.ParticleVelocityState

ParticleVelocityState | Properties | Methods
Package | away3d.animators.states
Class | public class ParticleVelocityState
Inheritance | ParticleVelocityState Inheritance ParticleStateBase Inheritance AnimationStateBase Inheritance Object

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | needUpdateTime : Boolean [read-only] | ParticleStateBase
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
 | velocity : Vector3D Defines the default velocity vector of the state, used when in global mode. | ParticleVelocityState
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _dynamicProperties : Vector.<Vector3D> | ParticleStateBase
Inherited | _dynamicPropertiesDirty : Dictionary | ParticleStateBase
Inherited | _needUpdateTime : Boolean | ParticleStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleVelocityState(animator:ParticleAnimator, particleVelocityNode:ParticleVelocityNode) | ParticleVelocityState
 | getVelocities():Vector.<Vector3D> | ParticleVelocityState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void Sets the animation phase of the node. | AnimationStateBase
 | setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void [override] | ParticleVelocityState
 | setVelocities(value:Vector.<Vector3D>):void | ParticleVelocityState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateDynamicProperties(animationSubGeometry:AnimationSubGeometry):void | ParticleStateBase
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void Updates the node's internal playhead position. | AnimationStateBase
Property Detail
velocity property
velocity:Vector3D

Defines the default velocity vector of the state, used when in global mode.

Implementation
    public function get velocity():Vector3D
    public function set velocity(value:Vector3D):void
Constructor Detail
ParticleVelocityState () Constructor
public function ParticleVelocityState(animator:ParticleAnimator, particleVelocityNode:ParticleVelocityNode)

Parameters
animator:ParticleAnimator
particleVelocityNode:ParticleVelocityNode
Method Detail
getVelocities () method
public function getVelocities():Vector.<Vector3D>

Returns
Vector.<Vector3D>
setRenderState () method
override public function setRenderState(stage3DProxy:Stage3DProxy, renderable:IRenderable, animationSubGeometry:AnimationSubGeometry, animationRegisterCache:AnimationRegisterCache, camera:Camera3D):void

Parameters

stage3DProxy:Stage3DProxy
renderable:IRenderable
animationSubGeometry:AnimationSubGeometry
animationRegisterCache:AnimationRegisterCache
camera:Camera3D

setVelocities () method
public function setVelocities(value:Vector.<Vector3D>):void

Parameters

value:Vector.<Vector3D>


away3d.animators.states.SkeletonBinaryLERPState

SkeletonBinaryLERPState | Properties | Methods
Package | away3d.animators.states
Class | public class SkeletonBinaryLERPState
Inheritance | SkeletonBinaryLERPState Inheritance AnimationStateBase Inheritance Object
Implements | ISkeletonAnimationState
Subclasses | CrossfadeTransitionState

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | blendWeight : Number Defines a fractional value between 0 and 1 representing the blending ratio between inputA (0) and inputB (1), used to produce the skeleton pose output. | SkeletonBinaryLERPState
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkeletonBinaryLERPState(animator:IAnimator, skeletonAnimationNode:SkeletonBinaryLERPNode) | SkeletonBinaryLERPState
 | getSkeletonPose(skeleton:Skeleton):SkeletonPose Returns the current skeleton pose of the animation in the clip based on the internal playhead position. | SkeletonBinaryLERPState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
 | phase(value:Number):void [override] Sets the animation phase of the node. | SkeletonBinaryLERPState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Method |  | Defined By
 | updatePositionDelta():void [override] Updates the node's root delta position | SkeletonBinaryLERPState
 | updateTime(time:int):void [override] Updates the node's internal playhead position. | SkeletonBinaryLERPState
Property Detail
blendWeight property
blendWeight:Number

Defines a fractional value between 0 and 1 representing the blending ratio between inputA (0) and inputB (1), used to produce the skeleton pose output.

Implementation
    public function get blendWeight():Number
    public function set blendWeight(value:Number):void

See also

inputA
inputB
Constructor Detail
SkeletonBinaryLERPState () Constructor
public function SkeletonBinaryLERPState(animator:IAnimator, skeletonAnimationNode:SkeletonBinaryLERPNode)

Parameters
animator:IAnimator
skeletonAnimationNode:SkeletonBinaryLERPNode
Method Detail
getSkeletonPose () method
public function getSkeletonPose(skeleton:Skeleton):SkeletonPose

Returns the current skeleton pose of the animation in the clip based on the internal playhead position.

Parameters

skeleton:Skeleton

Returns
SkeletonPose
phase () method
override public function phase(value:Number):void

Sets the animation phase of the node.

Parameters

value:Number — The phase value to use. 0 represents the beginning of an animation clip, 1 represents the end.

updatePositionDelta () method
override protected function updatePositionDelta():void

Updates the node's root delta position

updateTime () method
override protected function updateTime(time:int):void

Updates the node's internal playhead position.

Parameters

time:int — The local time (in milliseconds) of the node's playhead position.


away3d.animators.states.SkeletonClipState

SkeletonClipState | Properties | Methods
Package | away3d.animators.states
Class | public class SkeletonClipState
Inheritance | SkeletonClipState Inheritance AnimationClipState Inheritance AnimationStateBase Inheritance Object
Implements | ISkeletonAnimationState

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | blendWeight : Number [read-only] Returns a fractional value between 0 and 1 representing the blending ratio of the current playhead position between the current frame (0) and next frame (1) of the animation. | AnimationClipState
Inherited | currentFrame : uint [read-only] Returns the current frame of animation in the clip based on the internal playhead position. | AnimationClipState
 | currentPose : SkeletonPose [read-only] Returns the current skeleton pose frame of animation in the clip based on the internal playhead position. | SkeletonClipState
Inherited | nextFrame : uint [read-only] Returns the next frame of animation in the clip based on the internal playhead position. | AnimationClipState
 | nextPose : SkeletonPose [read-only] Returns the next skeleton pose frame of animation in the clip based on the internal playhead position. | SkeletonClipState
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _blendWeight : Number | AnimationClipState
Inherited | _currentFrame : uint | AnimationClipState
Inherited | _framesDirty : Boolean = true | AnimationClipState
Inherited | _nextFrame : uint | AnimationClipState
Inherited | _oldFrame : uint | AnimationClipState
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Inherited | _timeDir : int | AnimationClipState
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkeletonClipState(animator:IAnimator, skeletonClipNode:SkeletonClipNode) | SkeletonClipState
 | getSkeletonPose(skeleton:Skeleton):SkeletonPose Returns the current skeleton pose of the animation in the clip based on the internal playhead position. | SkeletonClipState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void [override] Sets the animation phase of the node. | AnimationClipState
Inherited | update(time:int):void [override] Updates the configuration of the node to its current state. | AnimationClipState
Protected Methods
Method |  | Defined By
 | updateFrames():void [override] Updates the nodes internal playhead to determine the current and next animation frame, and the blendWeight between the two. | SkeletonClipState
 | updatePositionDelta():void [override] Updates the node's root delta position | SkeletonClipState
 | updateTime(time:int):void [override] Updates the node's internal playhead position. | SkeletonClipState
Property Detail
currentPose property
currentPose:SkeletonPose [read-only]

Returns the current skeleton pose frame of animation in the clip based on the internal playhead position.

Implementation
    public function get currentPose():SkeletonPose
nextPose property
nextPose:SkeletonPose [read-only]

Returns the next skeleton pose frame of animation in the clip based on the internal playhead position.

Implementation
    public function get nextPose():SkeletonPose
Constructor Detail
SkeletonClipState () Constructor
public function SkeletonClipState(animator:IAnimator, skeletonClipNode:SkeletonClipNode)

Parameters
animator:IAnimator
skeletonClipNode:SkeletonClipNode
Method Detail
getSkeletonPose () method
public function getSkeletonPose(skeleton:Skeleton):SkeletonPose

Returns the current skeleton pose of the animation in the clip based on the internal playhead position.

Parameters

skeleton:Skeleton

Returns
SkeletonPose
updateFrames () method
override protected function updateFrames():void

Updates the nodes internal playhead to determine the current and next animation frame, and the blendWeight between the two.

updatePositionDelta () method
override protected function updatePositionDelta():void

Updates the node's root delta position

updateTime () method
override protected function updateTime(time:int):void

Updates the node's internal playhead position.

Parameters

time:int — The local time (in milliseconds) of the node's playhead position.


away3d.animators.states.SkeletonDifferenceState

SkeletonDifferenceState | Properties | Methods
Package | away3d.animators.states
Class | public class SkeletonDifferenceState
Inheritance | SkeletonDifferenceState Inheritance AnimationStateBase Inheritance Object
Implements | ISkeletonAnimationState

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | blendWeight : Number Defines a fractional value between 0 and 1 representing the blending ratio between the base input (0) and difference input (1), used to produce the skeleton pose output. | SkeletonDifferenceState
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkeletonDifferenceState(animator:IAnimator, skeletonAnimationNode:SkeletonDifferenceNode) | SkeletonDifferenceState
 | getSkeletonPose(skeleton:Skeleton):SkeletonPose Returns the current skeleton pose of the animation in the clip based on the internal playhead position. | SkeletonDifferenceState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
 | phase(value:Number):void [override] Sets the animation phase of the node. | SkeletonDifferenceState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Method |  | Defined By
 | updatePositionDelta():void [override] Updates the node's root delta position | SkeletonDifferenceState
 | updateTime(time:int):void [override] Updates the node's internal playhead position. | SkeletonDifferenceState
Property Detail
blendWeight property
blendWeight:Number

Defines a fractional value between 0 and 1 representing the blending ratio between the base input (0) and difference input (1), used to produce the skeleton pose output.

Implementation
    public function get blendWeight():Number
    public function set blendWeight(value:Number):void

See also

baseInput
differenceInput
Constructor Detail
SkeletonDifferenceState () Constructor
public function SkeletonDifferenceState(animator:IAnimator, skeletonAnimationNode:SkeletonDifferenceNode)

Parameters
animator:IAnimator
skeletonAnimationNode:SkeletonDifferenceNode
Method Detail
getSkeletonPose () method
public function getSkeletonPose(skeleton:Skeleton):SkeletonPose

Returns the current skeleton pose of the animation in the clip based on the internal playhead position.

Parameters

skeleton:Skeleton

Returns
SkeletonPose
phase () method
override public function phase(value:Number):void

Sets the animation phase of the node.

Parameters

value:Number — The phase value to use. 0 represents the beginning of an animation clip, 1 represents the end.

updatePositionDelta () method
override protected function updatePositionDelta():void

Updates the node's root delta position

updateTime () method
override protected function updateTime(time:int):void

Updates the node's internal playhead position.

Parameters

time:int — The local time (in milliseconds) of the node's playhead position.


away3d.animators.states.SkeletonDirectionalState

SkeletonDirectionalState | Properties | Methods
Package | away3d.animators.states
Class | public class SkeletonDirectionalState
Inheritance | SkeletonDirectionalState Inheritance AnimationStateBase Inheritance Object
Implements | ISkeletonAnimationState

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | direction : Number Defines the direction in degrees of the aniamtion between the forwards (0), right(90) backwards (180) and left(270) input nodes, used to produce the skeleton pose output. | SkeletonDirectionalState
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkeletonDirectionalState(animator:IAnimator, skeletonAnimationNode:SkeletonDirectionalNode) | SkeletonDirectionalState
 | getSkeletonPose(skeleton:Skeleton):SkeletonPose Returns the current skeleton pose of the animation in the clip based on the internal playhead position. | SkeletonDirectionalState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
 | phase(value:Number):void [override] Sets the animation phase of the node. | SkeletonDirectionalState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Method |  | Defined By
 | updatePositionDelta():void [override] Updates the node's root delta position | SkeletonDirectionalState
 | updateTime(time:int):void [override] Updates the node's internal playhead position. | SkeletonDirectionalState
Property Detail
direction property
direction:Number

Defines the direction in degrees of the aniamtion between the forwards (0), right(90) backwards (180) and left(270) input nodes, used to produce the skeleton pose output.

Implementation
    public function get direction():Number
    public function set direction(value:Number):void
Constructor Detail
SkeletonDirectionalState () Constructor
public function SkeletonDirectionalState(animator:IAnimator, skeletonAnimationNode:SkeletonDirectionalNode)

Parameters
animator:IAnimator
skeletonAnimationNode:SkeletonDirectionalNode
Method Detail
getSkeletonPose () method
public function getSkeletonPose(skeleton:Skeleton):SkeletonPose

Returns the current skeleton pose of the animation in the clip based on the internal playhead position.

Parameters

skeleton:Skeleton

Returns
SkeletonPose
phase () method
override public function phase(value:Number):void

Sets the animation phase of the node.

Parameters

value:Number — The phase value to use. 0 represents the beginning of an animation clip, 1 represents the end.

updatePositionDelta () method
override protected function updatePositionDelta():void

Updates the node's root delta position

updateTime () method
override protected function updateTime(time:int):void

Updates the node's internal playhead position.

Parameters

time:int — The local time (in milliseconds) of the node's playhead position.


away3d.animators.states.SkeletonNaryLERPState

SkeletonNaryLERPState | Properties | Methods
Package | away3d.animators.states
Class | public class SkeletonNaryLERPState
Inheritance | SkeletonNaryLERPState Inheritance AnimationStateBase Inheritance Object
Implements | ISkeletonAnimationState

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkeletonNaryLERPState(animator:IAnimator, skeletonAnimationNode:SkeletonNaryLERPNode) | SkeletonNaryLERPState
 | getBlendWeightAt(index:uint):Number Returns the blend weight of the skeleton aniamtion node that resides at the given input index. | SkeletonNaryLERPState
 | getSkeletonPose(skeleton:Skeleton):SkeletonPose Returns the current skeleton pose of the animation in the clip based on the internal playhead position. | SkeletonNaryLERPState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
 | phase(value:Number):void [override] Sets the animation phase of the node. | SkeletonNaryLERPState
 | setBlendWeightAt(index:uint, blendWeight:Number):void Sets the blend weight of the skeleton aniamtion node that resides at the given input index. | SkeletonNaryLERPState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Method |  | Defined By
 | updatePositionDelta():void [override] Updates the node's root delta position | SkeletonNaryLERPState
 | updateTime(time:int):void [override] Updates the node's internal playhead position. | SkeletonNaryLERPState
Constructor Detail
SkeletonNaryLERPState () Constructor
public function SkeletonNaryLERPState(animator:IAnimator, skeletonAnimationNode:SkeletonNaryLERPNode)

Parameters
animator:IAnimator
skeletonAnimationNode:SkeletonNaryLERPNode
Method Detail
getBlendWeightAt () method
public function getBlendWeightAt(index:uint):Number

Returns the blend weight of the skeleton aniamtion node that resides at the given input index.

Parameters

index:uint — The input index for which the skeleton animation node blend weight is requested.

Returns
Number
getSkeletonPose () method
public function getSkeletonPose(skeleton:Skeleton):SkeletonPose

Returns the current skeleton pose of the animation in the clip based on the internal playhead position.

Parameters

skeleton:Skeleton

Returns
SkeletonPose
phase () method
override public function phase(value:Number):void

Sets the animation phase of the node.

Parameters

value:Number — The phase value to use. 0 represents the beginning of an animation clip, 1 represents the end.

setBlendWeightAt () method
public function setBlendWeightAt(index:uint, blendWeight:Number):void

Sets the blend weight of the skeleton aniamtion node that resides at the given input index.

Parameters

index:uint — The input index on which the skeleton animation node blend weight is to be set.
blendWeight:Number — The blend weight value to use for the given skeleton animation node index.

updatePositionDelta () method
override protected function updatePositionDelta():void

Updates the node's root delta position

updateTime () method
override protected function updateTime(time:int):void

Updates the node's internal playhead position.

Parameters

time:int — The local time (in milliseconds) of the node's playhead position.


away3d.animators.states.UVClipState

UVClipState | Properties | Methods
Package | away3d.animators.states
Class | public class UVClipState
Inheritance | UVClipState Inheritance AnimationClipState Inheritance AnimationStateBase Inheritance Object
Implements | IUVAnimationState

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | blendWeight : Number [read-only] Returns a fractional value between 0 and 1 representing the blending ratio of the current playhead position between the current frame (0) and next frame (1) of the animation. | AnimationClipState
Inherited | currentFrame : uint [read-only] Returns the current frame of animation in the clip based on the internal playhead position. | AnimationClipState
 | currentUVFrame : UVAnimationFrame [read-only] Returns the current UV frame of animation in the clip based on the internal playhead position. | UVClipState
Inherited | nextFrame : uint [read-only] Returns the next frame of animation in the clip based on the internal playhead position. | AnimationClipState
 | nextUVFrame : UVAnimationFrame [read-only] Returns the next UV frame of animation in the clip based on the internal playhead position. | UVClipState
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _blendWeight : Number | AnimationClipState
Inherited | _currentFrame : uint | AnimationClipState
Inherited | _framesDirty : Boolean = true | AnimationClipState
Inherited | _nextFrame : uint | AnimationClipState
Inherited | _oldFrame : uint | AnimationClipState
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Inherited | _timeDir : int | AnimationClipState
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | UVClipState(animator:IAnimator, uvClipNode:UVClipNode) | UVClipState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void [override] Sets the animation phase of the node. | AnimationClipState
Inherited | update(time:int):void [override] Updates the configuration of the node to its current state. | AnimationClipState
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | updateFrames():void [override] Updates the nodes internal playhead to determine the current and next animation frame, and the blendWeight between the two. | UVClipState
Inherited | updatePositionDelta():void Updates the node's root delta position | AnimationStateBase
Inherited | updateTime(time:int):void [override] Updates the node's internal playhead position. | AnimationClipState
Property Detail
currentUVFrame property
currentUVFrame:UVAnimationFrame [read-only]

Returns the current UV frame of animation in the clip based on the internal playhead position.

Implementation
    public function get currentUVFrame():UVAnimationFrame
nextUVFrame property
nextUVFrame:UVAnimationFrame [read-only]

Returns the next UV frame of animation in the clip based on the internal playhead position.

Implementation
    public function get nextUVFrame():UVAnimationFrame
Constructor Detail
UVClipState () Constructor
public function UVClipState(animator:IAnimator, uvClipNode:UVClipNode)

Parameters
animator:IAnimator
uvClipNode:UVClipNode
Method Detail
updateFrames () method
override protected function updateFrames():void

Updates the nodes internal playhead to determine the current and next animation frame, and the blendWeight between the two.


away3d.animators.states.VertexClipState

VertexClipState | Properties | Methods
Package | away3d.animators.states
Class | public class VertexClipState
Inheritance | VertexClipState Inheritance AnimationClipState Inheritance AnimationStateBase Inheritance Object
Implements | IVertexAnimationState

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | blendWeight : Number [read-only] Returns a fractional value between 0 and 1 representing the blending ratio of the current playhead position between the current frame (0) and next frame (1) of the animation. | AnimationClipState
Inherited | currentFrame : uint [read-only] Returns the current frame of animation in the clip based on the internal playhead position. | AnimationClipState
 | currentGeometry : Geometry [read-only] Returns the current geometry frame of animation in the clip based on the internal playhead position. | VertexClipState
Inherited | nextFrame : uint [read-only] Returns the next frame of animation in the clip based on the internal playhead position. | AnimationClipState
 | nextGeometry : Geometry [read-only] Returns the current geometry frame of animation in the clip based on the internal playhead position. | VertexClipState
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _blendWeight : Number | AnimationClipState
Inherited | _currentFrame : uint | AnimationClipState
Inherited | _framesDirty : Boolean = true | AnimationClipState
Inherited | _nextFrame : uint | AnimationClipState
Inherited | _oldFrame : uint | AnimationClipState
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Inherited | _timeDir : int | AnimationClipState
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | VertexClipState(animator:IAnimator, vertexClipNode:VertexClipNode) | VertexClipState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void [override] Sets the animation phase of the node. | AnimationClipState
Inherited | update(time:int):void [override] Updates the configuration of the node to its current state. | AnimationClipState
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | updateFrames():void [override] Updates the nodes internal playhead to determine the current and next animation frame, and the blendWeight between the two. | VertexClipState
 | updatePositionDelta():void [override] Updates the node's root delta position | VertexClipState
Inherited | updateTime(time:int):void [override] Updates the node's internal playhead position. | AnimationClipState
Property Detail
currentGeometry property
currentGeometry:Geometry [read-only]

Returns the current geometry frame of animation in the clip based on the internal playhead position.

Implementation
    public function get currentGeometry():Geometry
nextGeometry property
nextGeometry:Geometry [read-only]

Returns the current geometry frame of animation in the clip based on the internal playhead position.

Implementation
    public function get nextGeometry():Geometry
Constructor Detail
VertexClipState () Constructor
public function VertexClipState(animator:IAnimator, vertexClipNode:VertexClipNode)

Parameters
animator:IAnimator
vertexClipNode:VertexClipNode
Method Detail
updateFrames () method
override protected function updateFrames():void

Updates the nodes internal playhead to determine the current and next animation frame, and the blendWeight between the two.

updatePositionDelta () method
override protected function updatePositionDelta():void

Updates the node's root delta position


away3d.animators.transitions - Away3D Documentation

Package away3d.animators.transitions

Interfaces
IAnimationTransition
Classes
CrossfadeTransition
CrossfadeTransitionNode
CrossfadeTransitionState


away3d.animators.transitions Summary

away3d.animators.transitions | Interfaces | Classes

Interfaces
Interface | Description
IAnimationTransition |
Classes
Class | Description
CrossfadeTransition |
CrossfadeTransitionNode | A skeleton animation node that uses two animation node inputs to blend a lineraly interpolated output of a skeleton pose.
CrossfadeTransitionState |

Thu Nov 15 2012, 12:09 PM Z


away3d.animators.transitions.CrossfadeTransition

CrossfadeTransition | Properties | Methods
Package | away3d.animators.transitions
Class | public class CrossfadeTransition
Inheritance | CrossfadeTransition Inheritance Object
Implements | IAnimationTransition

Public Properties
Property |  | Defined By
 | blendSpeed : Number = 0.5 | CrossfadeTransition
Public Methods
Method |  | Defined By
 | CrossfadeTransition(blendSpeed:Number) | CrossfadeTransition
 | getAnimationNode(animator:IAnimator, startNode:AnimationNodeBase, endNode:AnimationNodeBase, startBlend:int):AnimationNodeBase | CrossfadeTransition
Property Detail
blendSpeed property
public var blendSpeed:Number = 0.5

Constructor Detail
CrossfadeTransition () Constructor
public function CrossfadeTransition(blendSpeed:Number)

Parameters
blendSpeed:Number
Method Detail
getAnimationNode () method
public function getAnimationNode(animator:IAnimator, startNode:AnimationNodeBase, endNode:AnimationNodeBase, startBlend:int):AnimationNodeBase

Parameters

animator:IAnimator
startNode:AnimationNodeBase
endNode:AnimationNodeBase
startBlend:int

Returns
AnimationNodeBase


away3d.animators.transitions.CrossfadeTransitionNode

CrossfadeTransitionNode | Properties | Methods | Constants
Package | away3d.animators.transitions
Class | public class CrossfadeTransitionNode
Inheritance | CrossfadeTransitionNode Inheritance SkeletonBinaryLERPNode Inheritance AnimationNodeBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A skeleton animation node that uses two animation node inputs to blend a lineraly interpolated output of a skeleton pose.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | AnimationNodeBase
 | blendSpeed : Number | CrossfadeTransitionNode
Inherited | inputA : AnimationNodeBase Defines input node A to use for the blended output. | SkeletonBinaryLERPNode
Inherited | inputB : AnimationNodeBase Defines input node B to use for the blended output. | SkeletonBinaryLERPNode
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | startBlend : int | CrossfadeTransitionNode
Inherited | stateClass : Class [read-only] | AnimationNodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _stateClass : Class | AnimationNodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CrossfadeTransitionNode() Creates a new CrossfadeTransitionNode object. | CrossfadeTransitionNode
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | AnimationNodeBase
Inherited | getAnimationState(animator:IAnimator):SkeletonBinaryLERPState | SkeletonBinaryLERPNode
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
blendSpeed property
public var blendSpeed:Number

startBlend property
public var startBlend:int

Constructor Detail
CrossfadeTransitionNode () Constructor
public function CrossfadeTransitionNode()

Creates a new CrossfadeTransitionNode object.


away3d.animators.transitions.CrossfadeTransitionState

CrossfadeTransitionState | Properties | Methods
Package | away3d.animators.transitions
Class | public class CrossfadeTransitionState
Inheritance | CrossfadeTransitionState Inheritance SkeletonBinaryLERPState Inheritance AnimationStateBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | blendWeight : Number Defines a fractional value between 0 and 1 representing the blending ratio between inputA (0) and inputB (1), used to produce the skeleton pose output. | SkeletonBinaryLERPState
Inherited | positionDelta : Vector3D [read-only] Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation | AnimationStateBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _animationNode : AnimationNodeBase | AnimationStateBase
Inherited | _animator : IAnimator | AnimationStateBase
Inherited | _positionDeltaDirty : Boolean = true | AnimationStateBase
Inherited | _rootDelta : Vector3D | AnimationStateBase
Inherited | _startTime : int | AnimationStateBase
Inherited | _time : int | AnimationStateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CrossfadeTransitionState(animator:IAnimator, skeletonAnimationNode:CrossfadeTransitionNode) | CrossfadeTransitionState
Inherited | getSkeletonPose(skeleton:Skeleton):SkeletonPose Returns the current skeleton pose of the animation in the clip based on the internal playhead position. | SkeletonBinaryLERPState
Inherited | offset(startTime:int):void Resets the start time of the node to a new value. | AnimationStateBase
Inherited | phase(value:Number):void [override] Sets the animation phase of the node. | SkeletonBinaryLERPState
Inherited | update(time:int):void Updates the configuration of the node to its current state. | AnimationStateBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updatePositionDelta():void [override] Updates the node's root delta position | SkeletonBinaryLERPState
 | updateTime(time:int):void [override] Updates the node's internal playhead position. | CrossfadeTransitionState
Constructor Detail
CrossfadeTransitionState () Constructor
public function CrossfadeTransitionState(animator:IAnimator, skeletonAnimationNode:CrossfadeTransitionNode)

Parameters
animator:IAnimator
skeletonAnimationNode:CrossfadeTransitionNode
Method Detail
updateTime () method
override protected function updateTime(time:int):void

Updates the node's internal playhead position.

Parameters

time:int — The local time (in milliseconds) of the node's playhead position.


away3d.animators.transitions.IAnimationTransition

IAnimationTransition | Methods
Package | away3d.animators.transitions
Interface | public interface IAnimationTransition
Implementors | CrossfadeTransition

Public Methods
Method |  | Defined By
 | getAnimationNode(animator:IAnimator, startNode:AnimationNodeBase, endNode:AnimationNodeBase, startTime:int):AnimationNodeBase | IAnimationTransition
Method Detail
getAnimationNode () method
public function getAnimationNode(animator:IAnimator, startNode:AnimationNodeBase, endNode:AnimationNodeBase, startTime:int):AnimationNodeBase

Parameters

animator:IAnimator
startNode:AnimationNodeBase
endNode:AnimationNodeBase
startTime:int

Returns
AnimationNodeBase


away3d.animators.utils - Away3D Documentation

Package away3d.animators.utils

Classes
SkeletonUtils


away3d.animators.utils Summary

away3d.animators.utils | Classes

Classes
Class | Description
SkeletonUtils |

Thu Nov 15 2012, 12:09 PM Z


away3d.animators.utils.SkeletonUtils

SkeletonUtils | Methods
Package | away3d.animators.utils
Class | public class SkeletonUtils
Inheritance | SkeletonUtils Inheritance Object

Public Methods
Method |  | Defined By
 | generateDifferenceClip(source:SkeletonClipNode, referencePose:SkeletonPose):SkeletonClipNode [static] | SkeletonUtils
 | generateDifferencePose(source:SkeletonPose, reference:SkeletonPose):SkeletonPose [static] | SkeletonUtils
Method Detail
generateDifferenceClip () method
public static function generateDifferenceClip(source:SkeletonClipNode, referencePose:SkeletonPose):SkeletonClipNode

Parameters

source:SkeletonClipNode
referencePose:SkeletonPose

Returns
SkeletonClipNode
generateDifferencePose () method
public static function generateDifferencePose(source:SkeletonPose, reference:SkeletonPose):SkeletonPose

Parameters

source:SkeletonPose
reference:SkeletonPose

Returns
SkeletonPose


away3d.audio - Away3D Documentation

Package away3d.audio

Classes
Sound3D
SoundTransform3D


away3d.audio Summary

away3d.audio | Classes

Classes
Class | Description
Sound3D | A sound source/emitter object that can be positioned in 3D space, and from which all audio playback will be transformed to simulate orientation. The Sound3D object works much in the same fashion as primitives, lights and cameras, in that it can be added to a scene and positioned therein.
SoundTransform3D | SoundTransform3D is a convinience class that helps adjust a Soundtransform's volume and pan according position and distance of a listener and emitter object.

Thu Nov 15 2012, 12:09 PM Z


away3d.audio.Sound3D

Sound3D | Properties | Methods | Events | Constants
Package | away3d.audio
Class | public class Sound3D
Inheritance | Sound3D Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A sound source/emitter object that can be positioned in 3D space, and from which all audio playback will be transformed to simulate orientation.

The Sound3D object works much in the same fashion as primitives, lights and cameras, in that it can be added to a scene and positioned therein. It is the main object, in the 3D sound API, which the programmer will interact with.

Actual sound transformation is performed by a driver object, which is defined at the time of creation by the driver ini variable, the default being a simple pan/volume driver.

See also

SimplePanVolumeDriver

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | ObjectContainer3D
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean Does not apply any transformations to this object. | ObjectContainer3D
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | maxX : Number [read-only] The maximum extremum of the object along the X-axis. | ObjectContainer3D
Inherited | maxY : Number [read-only] The maximum extremum of the object along the Y-axis. | ObjectContainer3D
Inherited | maxZ : Number [read-only] The maximum extremum of the object along the Z-axis. | ObjectContainer3D
Inherited | minX : Number [read-only] The minimum extremum of the object along the X-axis. | ObjectContainer3D
Inherited | minY : Number [read-only] The minimum extremum of the object along the Y-axis. | ObjectContainer3D
Inherited | minZ : Number [read-only] The minimum extremum of the object along the Z-axis. | ObjectContainer3D
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
 | paused : Boolean [read-only] Returns a boolean indicating whether or not playback is currently paused. | Sound3D
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
 | playing : Boolean [read-only] Returns a boolean indicating whether or not the sound is currently playing. | Sound3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | scaleDistance : Number Defines a scale value used by the driver when adjusting sound intensity to simulate distance. | Sound3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D A reference to the Scene3D object to which this object belongs. | ObjectContainer3D
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
 | volume : Number Defines the overall (master) volume of the 3D sound, after any positional adjustments to volume have been applied. | Sound3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Sound3D(sound:Sound, reference:ObjectContainer3D, driver:ISound3DDriver = null, volume:Number = 1, scale:Number = 1000) Create a Sound3D object, representing the sound source used for playback of a flash Sound object. | Sound3D
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | ObjectContainer3D
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
 | pause():void Pause playback. | Sound3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
 | play():void Start (or resume, if paused) playback. | Sound3D
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
 | stop():void Stop and rewind sound file. | Sound3D
 | togglePlayPause():void Alternate between pausing and resuming playback of this sound. | Sound3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | invalidateSceneTransform():void Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | ObjectContainer3D
Inherited | updateMouseChildren():void | ObjectContainer3D
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
 | soundComplete | Dispatched when end of sound stream is reached (bubbled from the internal sound object). | Sound3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
paused property
paused:Boolean [read-only]

Returns a boolean indicating whether or not playback is currently paused.

Implementation
    public function get paused():Boolean
playing property
playing:Boolean [read-only]

Returns a boolean indicating whether or not the sound is currently playing.

Implementation
    public function get playing():Boolean
scaleDistance property
scaleDistance:Number

Defines a scale value used by the driver when adjusting sound intensity to simulate distance. The default number of 1000 means that sound volume will near the hearing threshold as the distance between listener and sound source approaches 1000 Away3D units.

Implementation
    public function get scaleDistance():Number
    public function set scaleDistance(value:Number):void

See also

ISound3DDriver.scale
volume property
volume:Number

Defines the overall (master) volume of the 3D sound, after any positional adjustments to volume have been applied. This value can equally well be cotrolled by modifying the volume property on the driver used by this Sound3D instance.

Implementation
    public function get volume():Number
    public function set volume(value:Number):void

See also

ISound3DDriver.volume
Constructor Detail
Sound3D () Constructor
public function Sound3D(sound:Sound, reference:ObjectContainer3D, driver:ISound3DDriver = null, volume:Number = 1, scale:Number = 1000)

Create a Sound3D object, representing the sound source used for playback of a flash Sound object.

Parameters
sound:Sound — The flash Sound object that is played back from this Sound3D object's position. For realistic results, this should be a mono (single-channel, non-stereo) sound stream.
reference:ObjectContainer3D — The reference, or "listener" object, typically a camera.
driver:ISound3DDriver (default = null) — Sound3D driver to use when applying simulation effects. Defaults to SimplePanVolumeDriver.
volume:Number (default = 1) — [optional] An initialisation object for specifying default instance properties.
scale:Number (default = 1000)
Method Detail
pause () method
public function pause():void

Pause playback. Resume using play().

play () method
public function play():void

Start (or resume, if paused) playback.

stop () method
public function stop():void

Stop and rewind sound file. Replay (from the beginning) using play(). To temporarily pause playback, allowing you to resume from the same point, use pause() instead.

See also

pause()
togglePlayPause () method
public function togglePlayPause():void

Alternate between pausing and resuming playback of this sound. If called while sound is paused (or stopped), this will resume playback. When called during playback, it will pause it.

Event Detail
soundComplete Event
Event Object Type: flash.events.Event

Dispatched when end of sound stream is reached (bubbled from the internal sound object).


away3d.audio.SoundTransform3D

SoundTransform3D | Properties | Methods
Package | away3d.audio
Class | public class SoundTransform3D
Inheritance | SoundTransform3D Inheritance Object

SoundTransform3D is a convinience class that helps adjust a Soundtransform's volume and pan according position and distance of a listener and emitter object. See SimplePanVolumeDriver for the limitations of this method.

Public Properties
Property |  | Defined By
 | emitter : ObjectContainer3D | SoundTransform3D
 | listener : ObjectContainer3D | SoundTransform3D
 | scale : Number | SoundTransform3D
 | soundTransform : SoundTransform | SoundTransform3D
 | volume : Number | SoundTransform3D
Public Methods
Method |  | Defined By
 | SoundTransform3D(emitter:ObjectContainer3D = null, listener:ObjectContainer3D = null, volume:Number = 1, scale:Number = 1000) Creates a new SoundTransform3D. | SoundTransform3D
 | update():void updates the SoundTransform based on the emitter and listener. | SoundTransform3D
 | updateFromVector3D(v:Vector3D):void udpates the SoundTransform based on the vector representing the distance and angle between the emitter and listener. | SoundTransform3D
Property Detail
emitter property
emitter:ObjectContainer3D

Implementation
    public function get emitter():ObjectContainer3D
    public function set emitter(value:ObjectContainer3D):void
listener property
listener:ObjectContainer3D

Implementation
    public function get listener():ObjectContainer3D
    public function set listener(value:ObjectContainer3D):void
scale property
scale:Number

Implementation
    public function get scale():Number
    public function set scale(value:Number):void
soundTransform property
soundTransform:SoundTransform

Implementation
    public function get soundTransform():SoundTransform
    public function set soundTransform(value:SoundTransform):void
volume property
volume:Number

Implementation
    public function get volume():Number
    public function set volume(value:Number):void
Constructor Detail
SoundTransform3D () Constructor
public function SoundTransform3D(emitter:ObjectContainer3D = null, listener:ObjectContainer3D = null, volume:Number = 1, scale:Number = 1000)

Creates a new SoundTransform3D.

Parameters
emitter:ObjectContainer3D (default = null) — the ObjectContainer3D from which the sound originates.
listener:ObjectContainer3D (default = null) — the ObjectContainer3D considered to be to position of the listener (usually, the camera)
volume:Number (default = 1) — the maximum volume used.
scale:Number (default = 1000) — the distance that the sound covers.
Method Detail
update () method
public function update():void

updates the SoundTransform based on the emitter and listener.

updateFromVector3D () method
public function updateFromVector3D(v:Vector3D):void

udpates the SoundTransform based on the vector representing the distance and angle between the emitter and listener.

Parameters

v:Vector3D — Vector3D


away3d.audio.drivers - Away3D Documentation

Package away3d.audio.drivers

Interfaces
ISound3DDriver
Classes
AbstractSound3DDriver
SimplePanVolumeDriver


away3d.audio.drivers Summary

away3d.audio.drivers | Interfaces | Classes

Interfaces
Interface | Description
ISound3DDriver |
Classes
Class | Description
AbstractSound3DDriver |
SimplePanVolumeDriver | The Simple pan/volume Sound3D driver will alter the pan and volume properties on the sound transform object of a regular flash.media.Sound3D representation of the sound.

Thu Nov 15 2012, 12:09 PM Z


away3d.audio.drivers.AbstractSound3DDriver

AbstractSound3DDriver | Properties | Methods
Package | away3d.audio.drivers
Class | public class AbstractSound3DDriver
Inheritance | AbstractSound3DDriver Inheritance flash.events.EventDispatcher
Subclasses | SimplePanVolumeDriver

Public Properties
Property |  | Defined By
 | mute : Boolean | AbstractSound3DDriver
 | scale : Number | AbstractSound3DDriver
 | sourceSound : Sound | AbstractSound3DDriver
 | volume : Number | AbstractSound3DDriver
Protected Properties
Property |  | Defined By
 | _mute : Boolean | AbstractSound3DDriver
 | _paused : Boolean | AbstractSound3DDriver
 | _playing : Boolean | AbstractSound3DDriver
 | _ref_v : Vector3D | AbstractSound3DDriver
 | _scale : Number | AbstractSound3DDriver
 | _src : Sound | AbstractSound3DDriver
 | _volume : Number | AbstractSound3DDriver
Public Methods
Method |  | Defined By
 | AbstractSound3DDriver() | AbstractSound3DDriver
 | updateReferenceVector(v:Vector3D):void | AbstractSound3DDriver
Property Detail
_mute property
protected var _mute:Boolean

_paused property
protected var _paused:Boolean

_playing property
protected var _playing:Boolean

_ref_v property
protected var _ref_v:Vector3D

_scale property
protected var _scale:Number

_src property
protected var _src:Sound

_volume property
protected var _volume:Number

mute property
mute:Boolean

Implementation
    public function get mute():Boolean
    public function set mute(value:Boolean):void
scale property
scale:Number

Implementation
    public function get scale():Number
    public function set scale(value:Number):void
sourceSound property
sourceSound:Sound

Implementation
    public function get sourceSound():Sound
    public function set sourceSound(value:Sound):void
volume property
volume:Number

Implementation
    public function get volume():Number
    public function set volume(value:Number):void
Constructor Detail
AbstractSound3DDriver () Constructor
public function AbstractSound3DDriver()

Method Detail
updateReferenceVector () method
public function updateReferenceVector(v:Vector3D):void

Parameters

v:Vector3D


away3d.audio.drivers.ISound3DDriver

ISound3DDriver | Properties | Methods
Package | away3d.audio.drivers
Interface | public interface ISound3DDriver extends flash.events.IEventDispatcher
Implementors | SimplePanVolumeDriver

Public Properties
Property |  | Defined By
 | mute : Boolean Mutes/unmutes the driver completely, which is typically only done (internally by Sound3D) whenever the sound source is removed from the scene. | ISound3DDriver
 | scale : Number Arbitrary value by which all distances are divided. | ISound3DDriver
 | sourceSound : Sound The sound object (flash.media.Sound) to play at the point of the sound source. | ISound3DDriver
 | volume : Number Master volume/gain after 3D modifications to pan/volume have been applied. | ISound3DDriver
Public Methods
Method |  | Defined By
 | pause():void Temporarily pause playback. | ISound3DDriver
 | play():void Start playing (or resume if paused) the audio. | ISound3DDriver
 | stop():void Stop playback and reset playhead. | ISound3DDriver
 | updateReferenceVector(v:Vector3D):void Change the position of the sound source relative to the listener, known as the reference vector. | ISound3DDriver
Property Detail
mute property
mute:Boolean

Mutes/unmutes the driver completely, which is typically only done (internally by Sound3D) whenever the sound source is removed from the scene. When true, any values set to the volume property will be ignored.

Implementation
    public function get mute():Boolean
    public function set mute(value:Boolean):void
scale property
scale:Number

Arbitrary value by which all distances are divided. The default value of 1000 is usually suitable for scenes with a scale that roughly matches the standard Away3D scale, i.e. that look good from the default camera position.

Implementation
    public function get scale():Number
    public function set scale(value:Number):void
sourceSound property
sourceSound:Sound

The sound object (flash.media.Sound) to play at the point of the sound source. The output of this sound is modified by the driver before actual sound output.

Implementation
    public function get sourceSound():Sound
    public function set sourceSound(value:Sound):void
volume property
volume:Number

Master volume/gain after 3D modifications to pan/volume have been applied. Modify this to raise or lower the overall volume regardless of where the sound source is located.

Implementation
    public function get volume():Number
    public function set volume(value:Number):void
Method Detail
pause () method
public function pause():void

Temporarily pause playback. Resume using play().

play () method
public function play():void

Start playing (or resume if paused) the audio. This is NOT The same thing as invoking play() on the flash.media.Sound object used as the source sound for the driver.

stop () method
public function stop():void

Stop playback and reset playhead. Subsequent play() calls will restart the playback from the beginning of the sound file.

updateReferenceVector () method
public function updateReferenceVector(v:Vector3D):void

Change the position of the sound source relative to the listener, known as the reference vector. This is invoked by the Sound3D object when it's position changes, and should typically not be called by any other code.

Parameters

v:Vector3D — Sound source position vector relative to the listener.


away3d.audio.drivers.SimplePanVolumeDriver

SimplePanVolumeDriver | Properties | Methods
Package | away3d.audio.drivers
Class | public class SimplePanVolumeDriver
Inheritance | SimplePanVolumeDriver Inheritance AbstractSound3DDriver Inheritance flash.events.EventDispatcher
Implements | ISound3DDriver

The Simple pan/volume Sound3D driver will alter the pan and volume properties on the sound transform object of a regular flash.media.Sound3D representation of the sound. This is very efficient, but has the drawback that it can only reflect azimuth and distance, and will disregard elevation. You'll be able to hear whether a

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | mute : Boolean | AbstractSound3DDriver
 | scale : Number [override] | SimplePanVolumeDriver
Inherited | sourceSound : Sound | AbstractSound3DDriver
 | volume : Number [override] | SimplePanVolumeDriver
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _mute : Boolean | AbstractSound3DDriver
Inherited | _paused : Boolean | AbstractSound3DDriver
Inherited | _playing : Boolean | AbstractSound3DDriver
Inherited | _ref_v : Vector3D | AbstractSound3DDriver
Inherited | _scale : Number | AbstractSound3DDriver
Inherited | _src : Sound | AbstractSound3DDriver
Inherited | _volume : Number | AbstractSound3DDriver
Public Methods
Method |  | Defined By
 | SimplePanVolumeDriver() | SimplePanVolumeDriver
 | pause():void | SimplePanVolumeDriver
 | play():void | SimplePanVolumeDriver
 | stop():void | SimplePanVolumeDriver
 | updateReferenceVector(v:Vector3D):void [override] | SimplePanVolumeDriver
Property Detail
scale property
scale:Number[override]

Implementation
    public function get scale():Number
    public function set scale(value:Number):void
volume property
volume:Number[override]

Implementation
    public function get volume():Number
    public function set volume(value:Number):void
Constructor Detail
SimplePanVolumeDriver () Constructor
public function SimplePanVolumeDriver()

Method Detail
pause () method
public function pause():void

play () method
public function play():void

stop () method
public function stop():void

updateReferenceVector () method
override public function updateReferenceVector(v:Vector3D):void

Parameters

v:Vector3D


away3d.bounds - Away3D Documentation

Package away3d.bounds

Classes
AxisAlignedBoundingBox
BoundingSphere
BoundingVolumeBase
NullBounds


away3d.bounds Summary

away3d.bounds | Classes

Classes
Class | Description
AxisAlignedBoundingBox | AxisAlignedBoundingBox represents a bounding box volume that has its planes aligned to the local coordinate axes of the bounded object.
BoundingSphere | BoundingSphere represents a spherical bounding volume defined by a center point and a radius.
BoundingVolumeBase | An abstract base class for all bounding volume classes.
NullBounds | NullBounds represents a debug bounding "volume" that is either considered always in, or always out of the frustum.

Thu Nov 15 2012, 12:09 PM Z


away3d.bounds.AxisAlignedBoundingBox

AxisAlignedBoundingBox | Properties | Methods
Package | away3d.bounds
Class | public class AxisAlignedBoundingBox
Inheritance | AxisAlignedBoundingBox Inheritance BoundingVolumeBase Inheritance Object

AxisAlignedBoundingBox represents a bounding box volume that has its planes aligned to the local coordinate axes of the bounded object. This is useful for most meshes.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | aabbPoints : Vector.<Number> [read-only] Returns a vector of values representing the concatenated cartesian triplet of the 8 axial extremities of the bounding volume. | BoundingVolumeBase
Inherited | boundingRenderable : WireframePrimitiveBase [read-only] Returns the bounding renderable object for the bounding volume, in cases where the showBounds property of the entity is set to true. | BoundingVolumeBase
 | halfExtentsX : Number [read-only] | AxisAlignedBoundingBox
 | halfExtentsY : Number [read-only] | AxisAlignedBoundingBox
 | halfExtentsZ : Number [read-only] | AxisAlignedBoundingBox
Inherited | max : Vector3D [read-only] The maximum extreme of the bounds | BoundingVolumeBase
Inherited | min : Vector3D [read-only] The minimum extreme of the bounds | BoundingVolumeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _aabbPoints : Vector.<Number> | BoundingVolumeBase
Inherited | _aabbPointsDirty : Boolean = true | BoundingVolumeBase
Inherited | _boundingRenderable : WireframePrimitiveBase | BoundingVolumeBase
Inherited | _max : Vector3D | BoundingVolumeBase
Inherited | _min : Vector3D | BoundingVolumeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | AxisAlignedBoundingBox() Creates a new AxisAlignedBoundingBox object. | AxisAlignedBoundingBox
 | classifyToPlane(plane:Plane3D):int [override] | AxisAlignedBoundingBox
 | clone():BoundingVolumeBase [override] Clones the current BoundingVolume object | AxisAlignedBoundingBox
 | closestPointToPoint(point:Vector3D, target:Vector3D = null):Vector3D Finds the closest point on the bounding volume to another given point. | AxisAlignedBoundingBox
 | containsPoint(position:Vector3D):Boolean [override] Method for calculating whether the given position is contained within the bounding volume. | AxisAlignedBoundingBox
Inherited | disposeRenderable():void Disposes of the bounds renderable object. | BoundingVolumeBase
 | fromExtremes(minX:Number, minY:Number, minZ:Number, maxX:Number, maxY:Number, maxZ:Number):void [override] Sets the bounds to the given extrema. | AxisAlignedBoundingBox
Inherited | fromGeometry(geometry:Geometry):void Updates the bounds to fit a Geometry object. | BoundingVolumeBase
Inherited | fromSphere(center:Vector3D, radius:Number):void Sets the bound to fit a given sphere. | BoundingVolumeBase
Inherited | fromVertices(vertices:Vector.<Number>):void Updates the bounds to fit a list of vertices | BoundingVolumeBase
 | isInFrustum(mvpMatrix:Matrix3D):Boolean [override] Tests if the bounds are in the camera frustum. | AxisAlignedBoundingBox
 | nullify():void [override] Sets the bounds to zero size. | AxisAlignedBoundingBox
 | rayIntersection(position:Vector3D, direction:Vector3D, targetNormal:Vector3D):Number [override] | AxisAlignedBoundingBox
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createBoundingRenderable():WireframePrimitiveBase [override] | AxisAlignedBoundingBox
Inherited | updateAABBPoints():void | BoundingVolumeBase
 | updateBoundingRenderable():void [override] | AxisAlignedBoundingBox
Property Detail
halfExtentsX property
halfExtentsX:Number [read-only]

Implementation
    public function get halfExtentsX():Number
halfExtentsY property
halfExtentsY:Number [read-only]

Implementation
    public function get halfExtentsY():Number
halfExtentsZ property
halfExtentsZ:Number [read-only]

Implementation
    public function get halfExtentsZ():Number
Constructor Detail
AxisAlignedBoundingBox () Constructor
public function AxisAlignedBoundingBox()

Creates a new AxisAlignedBoundingBox object.

Method Detail
classifyToPlane () method
override public function classifyToPlane(plane:Plane3D):int

Parameters

plane:Plane3D

Returns
int
clone () method
override public function clone():BoundingVolumeBase

Clones the current BoundingVolume object

Returns
BoundingVolumeBase — An exact duplicate of this object
closestPointToPoint () method
public function closestPointToPoint(point:Vector3D, target:Vector3D = null):Vector3D

Finds the closest point on the bounding volume to another given point. This can be used for maximum error calculations for content within a given bound.

Parameters

point:Vector3D — The point for which to find the closest point on the bounding volume
target:Vector3D (default = null) — An optional Vector3D to store the result to prevent creating a new object.

Returns
Vector3D —
containsPoint () method
override public function containsPoint(position:Vector3D):Boolean

Method for calculating whether the given position is contained within the bounding volume.

Parameters

position:Vector3D — The position in local coordinates to be checked.

Returns
Boolean — A Boolean value representing the detection of a contained position.
createBoundingRenderable () method
override protected function createBoundingRenderable():WireframePrimitiveBase

Returns
WireframePrimitiveBase
fromExtremes () method
override public function fromExtremes(minX:Number, minY:Number, minZ:Number, maxX:Number, maxY:Number, maxZ:Number):void

Sets the bounds to the given extrema.

Parameters

minX:Number — The minimum x value of the bounds
minY:Number — The minimum y value of the bounds
minZ:Number — The minimum z value of the bounds
maxX:Number — The maximum x value of the bounds
maxY:Number — The maximum y value of the bounds
maxZ:Number — The maximum z value of the bounds

isInFrustum () method
override public function isInFrustum(mvpMatrix:Matrix3D):Boolean

Tests if the bounds are in the camera frustum.

Parameters

mvpMatrix:Matrix3D — The model view projection matrix for the object to which this bounding box belongs.

Returns
Boolean — True if the bounding box is at least partially inside the frustum
nullify () method
override public function nullify():void

Sets the bounds to zero size.

rayIntersection () method
override public function rayIntersection(position:Vector3D, direction:Vector3D, targetNormal:Vector3D):Number

Parameters

position:Vector3D
direction:Vector3D
targetNormal:Vector3D

Returns
Number
updateBoundingRenderable () method
override protected function updateBoundingRenderable():void


away3d.bounds.BoundingSphere

BoundingSphere | Properties | Methods
Package | away3d.bounds
Class | public class BoundingSphere
Inheritance | BoundingSphere Inheritance BoundingVolumeBase Inheritance Object

BoundingSphere represents a spherical bounding volume defined by a center point and a radius. This bounding volume is useful for point lights.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | aabbPoints : Vector.<Number> [read-only] Returns a vector of values representing the concatenated cartesian triplet of the 8 axial extremities of the bounding volume. | BoundingVolumeBase
Inherited | boundingRenderable : WireframePrimitiveBase [read-only] Returns the bounding renderable object for the bounding volume, in cases where the showBounds property of the entity is set to true. | BoundingVolumeBase
Inherited | max : Vector3D [read-only] The maximum extreme of the bounds | BoundingVolumeBase
Inherited | min : Vector3D [read-only] The minimum extreme of the bounds | BoundingVolumeBase
 | radius : Number [read-only] The radius of the bounding sphere, calculated from the contents of the entity. | BoundingSphere
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _aabbPoints : Vector.<Number> | BoundingVolumeBase
Inherited | _aabbPointsDirty : Boolean = true | BoundingVolumeBase
Inherited | _boundingRenderable : WireframePrimitiveBase | BoundingVolumeBase
Inherited | _max : Vector3D | BoundingVolumeBase
Inherited | _min : Vector3D | BoundingVolumeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | BoundingSphere() Creates a new BoundingSphere object | BoundingSphere
 | classifyToPlane(plane:Plane3D):int [override] | BoundingSphere
 | clone():BoundingVolumeBase [override] Clones the current BoundingVolume object | BoundingSphere
 | containsPoint(position:Vector3D):Boolean [override] Method for calculating whether the given position is contained within the bounding volume. | BoundingSphere
Inherited | disposeRenderable():void Disposes of the bounds renderable object. | BoundingVolumeBase
 | fromExtremes(minX:Number, minY:Number, minZ:Number, maxX:Number, maxY:Number, maxZ:Number):void [override] Sets the bounds to the given extrema. | BoundingSphere
Inherited | fromGeometry(geometry:Geometry):void Updates the bounds to fit a Geometry object. | BoundingVolumeBase
 | fromSphere(center:Vector3D, radius:Number):void [override] Sets the bound to fit a given sphere. | BoundingSphere
Inherited | fromVertices(vertices:Vector.<Number>):void Updates the bounds to fit a list of vertices | BoundingVolumeBase
 | isInFrustum(mvpMatrix:Matrix3D):Boolean [override] todo: pass planes? Tests if the bounds are in the camera frustum. | BoundingSphere
 | nullify():void [override] Sets the bounds to zero size. | BoundingSphere
 | rayIntersection(position:Vector3D, direction:Vector3D, targetNormal:Vector3D):Number [override] | BoundingSphere
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createBoundingRenderable():WireframePrimitiveBase [override] | BoundingSphere
Inherited | updateAABBPoints():void | BoundingVolumeBase
 | updateBoundingRenderable():void [override] | BoundingSphere
Property Detail
radius property
radius:Number [read-only]

The radius of the bounding sphere, calculated from the contents of the entity.

Implementation
    public function get radius():Number
Constructor Detail
BoundingSphere () Constructor
public function BoundingSphere()

Creates a new BoundingSphere object

Method Detail
classifyToPlane () method
override public function classifyToPlane(plane:Plane3D):int

Parameters

plane:Plane3D

Returns
int
clone () method
override public function clone():BoundingVolumeBase

Clones the current BoundingVolume object

Returns
BoundingVolumeBase — An exact duplicate of this object
containsPoint () method
override public function containsPoint(position:Vector3D):Boolean

Method for calculating whether the given position is contained within the bounding volume.

Parameters

position:Vector3D — The position in local coordinates to be checked.

Returns
Boolean — A Boolean value representing the detection of a contained position.
createBoundingRenderable () method
override protected function createBoundingRenderable():WireframePrimitiveBase

Returns
WireframePrimitiveBase
fromExtremes () method
override public function fromExtremes(minX:Number, minY:Number, minZ:Number, maxX:Number, maxY:Number, maxZ:Number):void

Sets the bounds to the given extrema.

Parameters

minX:Number — The minimum x value of the bounds
minY:Number — The minimum y value of the bounds
minZ:Number — The minimum z value of the bounds
maxX:Number — The maximum x value of the bounds
maxY:Number — The maximum y value of the bounds
maxZ:Number — The maximum z value of the bounds

fromSphere () method
override public function fromSphere(center:Vector3D, radius:Number):void

Sets the bound to fit a given sphere.

Parameters

center:Vector3D — The center of the sphere to be bounded
radius:Number — The radius of the sphere to be bounded

isInFrustum () method
override public function isInFrustum(mvpMatrix:Matrix3D):Boolean

todo: pass planes? Tests if the bounds are in the camera frustum.

Parameters

mvpMatrix:Matrix3D — The model view projection matrix for the object to which this bounding box belongs.

Returns
Boolean — True if the bounding box is at least partially inside the frustum
nullify () method
override public function nullify():void

Sets the bounds to zero size.

rayIntersection () method
override public function rayIntersection(position:Vector3D, direction:Vector3D, targetNormal:Vector3D):Number

Parameters

position:Vector3D
direction:Vector3D
targetNormal:Vector3D

Returns
Number
updateBoundingRenderable () method
override protected function updateBoundingRenderable():void


away3d.bounds.BoundingVolumeBase

BoundingVolumeBase | Properties | Methods
Package | away3d.bounds
Class | public class BoundingVolumeBase
Inheritance | BoundingVolumeBase Inheritance Object
Subclasses | AxisAlignedBoundingBox, BoundingSphere, NullBounds

An abstract base class for all bounding volume classes. It should not be instantiated directly.

Public Properties
Property |  | Defined By
 | aabbPoints : Vector.<Number> [read-only] Returns a vector of values representing the concatenated cartesian triplet of the 8 axial extremities of the bounding volume. | BoundingVolumeBase
 | boundingRenderable : WireframePrimitiveBase [read-only] Returns the bounding renderable object for the bounding volume, in cases where the showBounds property of the entity is set to true. | BoundingVolumeBase
 | max : Vector3D [read-only] The maximum extreme of the bounds | BoundingVolumeBase
 | min : Vector3D [read-only] The minimum extreme of the bounds | BoundingVolumeBase
Protected Properties
Property |  | Defined By
 | _aabbPoints : Vector.<Number> | BoundingVolumeBase
 | _aabbPointsDirty : Boolean = true | BoundingVolumeBase
 | _boundingRenderable : WireframePrimitiveBase | BoundingVolumeBase
 | _max : Vector3D | BoundingVolumeBase
 | _min : Vector3D | BoundingVolumeBase
Public Methods
Method |  | Defined By
 | BoundingVolumeBase() Creates a new BoundingVolumeBase object | BoundingVolumeBase
 | classifyToPlane(plane:Plane3D):int | BoundingVolumeBase
 | clone():BoundingVolumeBase Clones the current BoundingVolume object | BoundingVolumeBase
 | containsPoint(position:Vector3D):Boolean Method for calculating whether the given position is contained within the bounding volume. | BoundingVolumeBase
 | disposeRenderable():void Disposes of the bounds renderable object. | BoundingVolumeBase
 | fromExtremes(minX:Number, minY:Number, minZ:Number, maxX:Number, maxY:Number, maxZ:Number):void Sets the bounds to the given extrema. | BoundingVolumeBase
 | fromGeometry(geometry:Geometry):void Updates the bounds to fit a Geometry object. | BoundingVolumeBase
 | fromSphere(center:Vector3D, radius:Number):void Sets the bound to fit a given sphere. | BoundingVolumeBase
 | fromVertices(vertices:Vector.<Number>):void Updates the bounds to fit a list of vertices | BoundingVolumeBase
 | isInFrustum(mvpMatrix:Matrix3D):Boolean Tests if the bounds are in the camera frustum. | BoundingVolumeBase
 | nullify():void Sets the bounds to zero size. | BoundingVolumeBase
 | rayIntersection(position:Vector3D, direction:Vector3D, targetNormal:Vector3D):Number Method for calculating whether an intersection of the given ray occurs with the bounding volume. | BoundingVolumeBase
Protected Methods
Method |  | Defined By
 | createBoundingRenderable():WireframePrimitiveBase | BoundingVolumeBase
 | updateAABBPoints():void | BoundingVolumeBase
 | updateBoundingRenderable():void | BoundingVolumeBase
Property Detail
_aabbPoints property
protected var _aabbPoints:Vector.<Number>

_aabbPointsDirty property
protected var _aabbPointsDirty:Boolean = true

_boundingRenderable property
protected var _boundingRenderable:WireframePrimitiveBase

_max property
protected var _max:Vector3D

_min property
protected var _min:Vector3D

aabbPoints property
aabbPoints:Vector.<Number> [read-only]

Returns a vector of values representing the concatenated cartesian triplet of the 8 axial extremities of the bounding volume.

Implementation
    public function get aabbPoints():Vector.<Number>
boundingRenderable property
boundingRenderable:WireframePrimitiveBase [read-only]

Returns the bounding renderable object for the bounding volume, in cases where the showBounds property of the entity is set to true.

Implementation
    public function get boundingRenderable():WireframePrimitiveBase

See also

away3d.entities.Entity.showBounds
max property
max:Vector3D [read-only]

The maximum extreme of the bounds

Implementation
    public function get max():Vector3D
min property
min:Vector3D [read-only]

The minimum extreme of the bounds

Implementation
    public function get min():Vector3D
Constructor Detail
BoundingVolumeBase () Constructor
public function BoundingVolumeBase()

Creates a new BoundingVolumeBase object

Method Detail
classifyToPlane () method
public function classifyToPlane(plane:Plane3D):int

Parameters

plane:Plane3D

Returns
int
clone () method
public function clone():BoundingVolumeBase

Clones the current BoundingVolume object

Returns
BoundingVolumeBase — An exact duplicate of this object
containsPoint () method
public function containsPoint(position:Vector3D):Boolean

Method for calculating whether the given position is contained within the bounding volume.

Parameters

position:Vector3D — The position in local coordinates to be checked.

Returns
Boolean — A Boolean value representing the detection of a contained position.
createBoundingRenderable () method
protected function createBoundingRenderable():WireframePrimitiveBase

Returns
WireframePrimitiveBase
disposeRenderable () method
public function disposeRenderable():void

Disposes of the bounds renderable object. Used to clear memory after a bounds rendeable is no longer required.

fromExtremes () method
public function fromExtremes(minX:Number, minY:Number, minZ:Number, maxX:Number, maxY:Number, maxZ:Number):void

Sets the bounds to the given extrema.

Parameters

minX:Number — The minimum x value of the bounds
minY:Number — The minimum y value of the bounds
minZ:Number — The minimum z value of the bounds
maxX:Number — The maximum x value of the bounds
maxY:Number — The maximum y value of the bounds
maxZ:Number — The maximum z value of the bounds

fromGeometry () method
public function fromGeometry(geometry:Geometry):void

Updates the bounds to fit a Geometry object.

Parameters

geometry:Geometry — The Geometry object to be bounded.

fromSphere () method
public function fromSphere(center:Vector3D, radius:Number):void

Sets the bound to fit a given sphere.

Parameters

center:Vector3D — The center of the sphere to be bounded
radius:Number — The radius of the sphere to be bounded

fromVertices () method
public function fromVertices(vertices:Vector.<Number>):void

Updates the bounds to fit a list of vertices

Parameters

vertices:Vector.<Number> — A Vector.<Number> of vertex data to be bounded.

isInFrustum () method
public function isInFrustum(mvpMatrix:Matrix3D):Boolean

Tests if the bounds are in the camera frustum.

Parameters

mvpMatrix:Matrix3D — The model view projection matrix for the object to which this bounding box belongs.

Returns
Boolean — True if the bounding box is at least partially inside the frustum
nullify () method
public function nullify():void

Sets the bounds to zero size.

rayIntersection () method
public function rayIntersection(position:Vector3D, direction:Vector3D, targetNormal:Vector3D):Number

Method for calculating whether an intersection of the given ray occurs with the bounding volume.

Parameters

position:Vector3D — The starting position of the casting ray in local coordinates.
direction:Vector3D — A unit vector representing the direction of the casting ray in local coordinates.
targetNormal:Vector3D — The vector to store the bounds' normal at the point of collision

Returns
Number — A Boolean value representing the detection of an intersection.
updateAABBPoints () method
protected function updateAABBPoints():void

updateBoundingRenderable () method
protected function updateBoundingRenderable():void


away3d.bounds.NullBounds

NullBounds | Properties | Methods
Package | away3d.bounds
Class | public class NullBounds
Inheritance | NullBounds Inheritance BoundingVolumeBase Inheritance Object

NullBounds represents a debug bounding "volume" that is either considered always in, or always out of the frustum. NullBounds is useful for entities that are always considered in the frustum, such as directional lights or skyboxes.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | aabbPoints : Vector.<Number> [read-only] Returns a vector of values representing the concatenated cartesian triplet of the 8 axial extremities of the bounding volume. | BoundingVolumeBase
Inherited | boundingRenderable : WireframePrimitiveBase [read-only] Returns the bounding renderable object for the bounding volume, in cases where the showBounds property of the entity is set to true. | BoundingVolumeBase
Inherited | max : Vector3D [read-only] The maximum extreme of the bounds | BoundingVolumeBase
Inherited | min : Vector3D [read-only] The minimum extreme of the bounds | BoundingVolumeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _aabbPoints : Vector.<Number> | BoundingVolumeBase
Inherited | _aabbPointsDirty : Boolean = true | BoundingVolumeBase
Inherited | _boundingRenderable : WireframePrimitiveBase | BoundingVolumeBase
Inherited | _max : Vector3D | BoundingVolumeBase
Inherited | _min : Vector3D | BoundingVolumeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | NullBounds(alwaysIn:Boolean = true, renderable:WireframePrimitiveBase = null) | NullBounds
 | classifyToPlane(plane:Plane3D):int [override] | NullBounds
Inherited | clone():BoundingVolumeBase Clones the current BoundingVolume object | BoundingVolumeBase
Inherited | containsPoint(position:Vector3D):Boolean Method for calculating whether the given position is contained within the bounding volume. | BoundingVolumeBase
Inherited | disposeRenderable():void Disposes of the bounds renderable object. | BoundingVolumeBase
 | fromExtremes(minX:Number, minY:Number, minZ:Number, maxX:Number, maxY:Number, maxZ:Number):void [override] Sets the bounds to the given extrema. | NullBounds
 | fromGeometry(geometry:Geometry):void [override] Updates the bounds to fit a Geometry object. | NullBounds
 | fromSphere(center:Vector3D, radius:Number):void [override] Sets the bound to fit a given sphere. | NullBounds
Inherited | fromVertices(vertices:Vector.<Number>):void Updates the bounds to fit a list of vertices | BoundingVolumeBase
 | isInFrustum(mvpMatrix:Matrix3D):Boolean [override] Tests if the bounds are in the camera frustum. | NullBounds
Inherited | nullify():void Sets the bounds to zero size. | BoundingVolumeBase
Inherited | rayIntersection(position:Vector3D, direction:Vector3D, targetNormal:Vector3D):Number Method for calculating whether an intersection of the given ray occurs with the bounding volume. | BoundingVolumeBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createBoundingRenderable():WireframePrimitiveBase [override] | NullBounds
Inherited | updateAABBPoints():void | BoundingVolumeBase
Inherited | updateBoundingRenderable():void | BoundingVolumeBase
Constructor Detail
NullBounds () Constructor
public function NullBounds(alwaysIn:Boolean = true, renderable:WireframePrimitiveBase = null)

Parameters
alwaysIn:Boolean (default = true)
renderable:WireframePrimitiveBase (default = null)
Method Detail
classifyToPlane () method
override public function classifyToPlane(plane:Plane3D):int

Parameters

plane:Plane3D

Returns
int
createBoundingRenderable () method
override protected function createBoundingRenderable():WireframePrimitiveBase

Returns
WireframePrimitiveBase
fromExtremes () method
override public function fromExtremes(minX:Number, minY:Number, minZ:Number, maxX:Number, maxY:Number, maxZ:Number):void

Sets the bounds to the given extrema.

Parameters

minX:Number — The minimum x value of the bounds
minY:Number — The minimum y value of the bounds
minZ:Number — The minimum z value of the bounds
maxX:Number — The maximum x value of the bounds
maxY:Number — The maximum y value of the bounds
maxZ:Number — The maximum z value of the bounds

fromGeometry () method
override public function fromGeometry(geometry:Geometry):void

Updates the bounds to fit a Geometry object.

Parameters

geometry:Geometry — The Geometry object to be bounded.

fromSphere () method
override public function fromSphere(center:Vector3D, radius:Number):void

Sets the bound to fit a given sphere.

Parameters

center:Vector3D — The center of the sphere to be bounded
radius:Number — The radius of the sphere to be bounded

isInFrustum () method
override public function isInFrustum(mvpMatrix:Matrix3D):Boolean

Tests if the bounds are in the camera frustum.

Parameters

mvpMatrix:Matrix3D — The model view projection matrix for the object to which this bounding box belongs.

Returns
Boolean — True if the bounding box is at least partially inside the frustum


away3d.cameras - Away3D Documentation

Package away3d.cameras

Classes
Camera3D


away3d.cameras Summary

away3d.cameras | Classes

Classes
Class | Description
Camera3D | A Camera3D object represents a virtual camera through which we view the scene.

Thu Nov 15 2012, 12:09 PM Z


away3d.cameras.Camera3D

Camera3D | Properties | Methods | Events | Constants
Package | away3d.cameras
Class | public class Camera3D
Inheritance | Camera3D Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | StereoCamera3D

A Camera3D object represents a virtual camera through which we view the scene.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Entity
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
 | frustumPlanes : Vector.<Plane3D> [read-only] | Camera3D
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
 | lens : LensBase The lens used by the camera to perform the projection; | Camera3D
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
 | viewProjection : Matrix3D [read-only] The view projection matrix of the camera. | Camera3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Camera3D(lens:LensBase = null) Creates a new Camera3D object | Camera3D
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | ObjectContainer3D
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
 | getRay(mX:Number, mY:Number, mZ:Number = 0):Vector3D Returns the ray in scene space from the camera to the point on the screen in normalized coordinates. | Camera3D
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
 | project(point3d:Vector3D):Vector3D | Camera3D
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
 | unproject(mX:Number, mY:Number, mZ:Number = 0):Vector3D Calculates the scene position of the given normalized coordinates. | Camera3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createEntityPartitionNode():EntityNode [override] Factory method that returns the current partition node. | Camera3D
Inherited | getDefaultBoundingVolume():BoundingVolumeBase Creates the default bounding box to be used by this type of Entity. | Entity
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
 | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Camera3D
 | updateBounds():void [override] Updates the bounding volume for the object. | Camera3D
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
frustumPlanes property
frustumPlanes:Vector.<Plane3D> [read-only]

Implementation
    public function get frustumPlanes():Vector.<Plane3D>
lens property
lens:LensBase

The lens used by the camera to perform the projection;

Implementation
    public function get lens():LensBase
    public function set lens(value:LensBase):void
viewProjection property
viewProjection:Matrix3D [read-only]

The view projection matrix of the camera.

Implementation
    public function get viewProjection():Matrix3D
Constructor Detail
Camera3D () Constructor
public function Camera3D(lens:LensBase = null)

Creates a new Camera3D object

Parameters
lens:LensBase (default = null) — An optional lens object that will perform the projection. Defaults to PerspectiveLens.

See also

away3d.cameras.lenses.PerspectiveLens
Method Detail
createEntityPartitionNode () method
override protected function createEntityPartitionNode():EntityNode

Factory method that returns the current partition node. Needs to be overridden by concrete subclasses such as Mesh to return the correct concrete subtype of EntityPartition3DNode (for Mesh = MeshPartition3DNode, most IRenderables (particles fe) would return RenderablePartition3DNode, I suppose)

Returns
EntityNode
getRay () method
public function getRay(mX:Number, mY:Number, mZ:Number = 0):Vector3D

Returns the ray in scene space from the camera to the point on the screen in normalized coordinates.

Parameters

mX:Number — The x coordinate relative to the View3D. -1 corresponds to the utter left side of the viewport, 1 to the right.
mY:Number — The y coordinate relative to the View3D. -1 corresponds to the top side of the viewport, 1 to the bottom.
mZ:Number (default = 0)

Returns
Vector3D — The ray from the camera to the scene space position of a point on the projection plane.
invalidateSceneTransform () method
override protected function invalidateSceneTransform():void

Invalidates the scene transformation matrix, causing it to be updated the next time it's requested.

project () method
public function project(point3d:Vector3D):Vector3D

Parameters

point3d:Vector3D

Returns
Vector3D
unproject () method
public function unproject(mX:Number, mY:Number, mZ:Number = 0):Vector3D

Calculates the scene position of the given normalized coordinates.

Parameters

mX:Number — The x coordinate relative to the View3D. -1 corresponds to the utter left side of the viewport, 1 to the right.
mY:Number — The y coordinate relative to the View3D. -1 corresponds to the top side of the viewport, 1 to the bottom.
mZ:Number (default = 0)

Returns
Vector3D — The scene position of the given screen coordinates.
updateBounds () method
override protected function updateBounds():void

Updates the bounding volume for the object. Overriding methods need to set invalid flag to false!


away3d.cameras.lenses - Away3D Documentation

Package away3d.cameras.lenses

Classes
FreeMatrixLens
LensBase
ObliqueNearPlaneLens
OrthographicLens
OrthographicOffCenterLens
PerspectiveLens


away3d.cameras.lenses Summary

away3d.cameras.lenses | Classes

Classes
Class | Description
FreeMatrixLens | FreeMatrixLens provides a projection lens that exposes a full projection matrix, rather than provide one through more user-friendly settings.
LensBase | An abstract base class for all lens classes.
ObliqueNearPlaneLens |
OrthographicLens | The PerspectiveLens object provides a projection matrix that projects 3D geometry isometrically.
OrthographicOffCenterLens | The PerspectiveLens object provides a projection matrix that projects 3D geometry isometrically.
PerspectiveLens | The PerspectiveLens object provides a projection matrix that projects 3D geometry with perspective distortion.

Thu Nov 15 2012, 12:09 PM Z


away3d.cameras.lenses.FreeMatrixLens

FreeMatrixLens | Properties | Methods
Package | away3d.cameras.lenses
Class | public class FreeMatrixLens
Inheritance | FreeMatrixLens Inheritance LensBase Inheritance flash.events.EventDispatcher

FreeMatrixLens provides a projection lens that exposes a full projection matrix, rather than provide one through more user-friendly settings. Whenever the matrix is updated, it needs to be reset in order to trigger an update.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | far : Number [override] | FreeMatrixLens
Inherited | frustumCorners : Vector.<Number> Retrieves the corner points of the lens frustum. | LensBase
Inherited | matrix : Matrix3D The projection matrix that transforms 3D geometry to normalized homogeneous coordinates. | LensBase
 | near : Number [override] | FreeMatrixLens
Inherited | unprojectionMatrix : Matrix3D [read-only] | LensBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _aspectRatio : Number = 1 | LensBase
Inherited | _far : Number = 3000 | LensBase
Inherited | _frustumCorners : Vector.<Number> | LensBase
Inherited | _matrix : Matrix3D | LensBase
Inherited | _matrixInvalid : Boolean = true | LensBase
Inherited | _near : Number = 20 | LensBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | FreeMatrixLens() Creates a new FreeMatrixLens object. | FreeMatrixLens
 | clone():LensBase [override] | FreeMatrixLens
Inherited | project(point3d:Vector3D):Vector3D | LensBase
Inherited | unproject(mX:Number, mY:Number, mZ:Number):Vector3D Calculates the position of the given normalized coordinates relative to the camera. | LensBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | invalidateMatrix():void Invalidates the projection matrix, which will cause it to be updated on the next request. | LensBase
 | updateMatrix():void [override] | FreeMatrixLens
Property Detail
aspectRatio property
aspectRatio:Number[override]

Implementation
    arcane function get aspectRatio():Number
    arcane function set aspectRatio(value:Number):void
far property
far:Number[override]

Implementation
    public function get far():Number
    public function set far(value:Number):void
near property
near:Number[override]

Implementation
    public function get near():Number
    public function set near(value:Number):void
Constructor Detail
FreeMatrixLens () Constructor
public function FreeMatrixLens()

Creates a new FreeMatrixLens object.

Method Detail
clone () method
override public function clone():LensBase

Returns
LensBase
updateMatrix () method
override protected function updateMatrix():void


away3d.cameras.lenses.LensBase

LensBase | Properties | Methods
Package | away3d.cameras.lenses
Class | public class LensBase
Inheritance | LensBase Inheritance flash.events.EventDispatcher
Subclasses | FreeMatrixLens, ObliqueNearPlaneLens, OrthographicLens, OrthographicOffCenterLens, PerspectiveLens

An abstract base class for all lens classes. Lens objects provides a projection matrix that transforms 3D geometry to normalized homogeneous coordinates.

Public Properties
Property |  | Defined By
 | far : Number The distance to the far plane of the frustum. | LensBase
 | frustumCorners : Vector.<Number> Retrieves the corner points of the lens frustum. | LensBase
 | matrix : Matrix3D The projection matrix that transforms 3D geometry to normalized homogeneous coordinates. | LensBase
 | near : Number The distance to the near plane of the frustum. | LensBase
 | unprojectionMatrix : Matrix3D [read-only] | LensBase
Protected Properties
Property |  | Defined By
 | _aspectRatio : Number = 1 | LensBase
 | _far : Number = 3000 | LensBase
 | _frustumCorners : Vector.<Number> | LensBase
 | _matrix : Matrix3D | LensBase
 | _matrixInvalid : Boolean = true | LensBase
 | _near : Number = 20 | LensBase
Public Methods
Method |  | Defined By
 | LensBase() Creates a new LensBase object. | LensBase
 | clone():LensBase Creates an exact duplicate of the lens | LensBase
 | project(point3d:Vector3D):Vector3D | LensBase
 | unproject(mX:Number, mY:Number, mZ:Number):Vector3D Calculates the position of the given normalized coordinates relative to the camera. | LensBase
Protected Methods
Method |  | Defined By
 | invalidateMatrix():void Invalidates the projection matrix, which will cause it to be updated on the next request. | LensBase
 | updateMatrix():void Updates the matrix | LensBase
Property Detail
_aspectRatio property
protected var _aspectRatio:Number = 1

_far property
protected var _far:Number = 3000

_frustumCorners property
protected var _frustumCorners:Vector.<Number>

_matrix property
protected var _matrix:Matrix3D

_matrixInvalid property
protected var _matrixInvalid:Boolean = true

_near property
protected var _near:Number = 20

aspectRatio property
aspectRatio:Number

Implementation
    arcane function get aspectRatio():Number
    arcane function set aspectRatio(value:Number):void
far property
far:Number

The distance to the far plane of the frustum. Anything beyond the far plane will not be rendered.

Implementation
    public function get far():Number
    public function set far(value:Number):void
frustumCorners property
frustumCorners:Vector.<Number>

Retrieves the corner points of the lens frustum.

Implementation
    public function get frustumCorners():Vector.<Number>
    public function set frustumCorners(value:Vector.<Number>):void
matrix property
matrix:Matrix3D

The projection matrix that transforms 3D geometry to normalized homogeneous coordinates.

Implementation
    public function get matrix():Matrix3D
    public function set matrix(value:Matrix3D):void
near property
near:Number

The distance to the near plane of the frustum. Anything behind near plane will not be rendered.

Implementation
    public function get near():Number
    public function set near(value:Number):void
unprojectionMatrix property
unprojectionMatrix:Matrix3D [read-only]

Implementation
    public function get unprojectionMatrix():Matrix3D
Constructor Detail
LensBase () Constructor
public function LensBase()

Creates a new LensBase object.

Method Detail
clone () method
public function clone():LensBase

Creates an exact duplicate of the lens

Returns
LensBase
invalidateMatrix () method
protected function invalidateMatrix():void

Invalidates the projection matrix, which will cause it to be updated on the next request.

project () method
public function project(point3d:Vector3D):Vector3D

Parameters

point3d:Vector3D

Returns
Vector3D
unproject () method
public function unproject(mX:Number, mY:Number, mZ:Number):Vector3D

Calculates the position of the given normalized coordinates relative to the camera.

Parameters

mX:Number — The x coordinate relative to the View3D. -1 corresponds to the utter left side of the viewport, 1 to the right.
mY:Number — The y coordinate relative to the View3D. -1 corresponds to the top side of the viewport, 1 to the bottom.
mZ:Number — The distance from the projection plane.

Returns
Vector3D — The scene position of the given screen coordinates.
updateMatrix () method
protected function updateMatrix():void

Updates the matrix


away3d.cameras.lenses.ObliqueNearPlaneLens

ObliqueNearPlaneLens | Properties | Methods
Package | away3d.cameras.lenses
Class | public class ObliqueNearPlaneLens
Inheritance | ObliqueNearPlaneLens Inheritance LensBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | baseLens : LensBase [write-only] | ObliqueNearPlaneLens
 | far : Number [override] | ObliqueNearPlaneLens
 | frustumCorners : Vector.<Number> [override] | ObliqueNearPlaneLens
Inherited | matrix : Matrix3D The projection matrix that transforms 3D geometry to normalized homogeneous coordinates. | LensBase
 | near : Number [override] | ObliqueNearPlaneLens
 | plane : Plane3D | ObliqueNearPlaneLens
Inherited | unprojectionMatrix : Matrix3D [read-only] | LensBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _aspectRatio : Number = 1 | LensBase
Inherited | _far : Number = 3000 | LensBase
Inherited | _frustumCorners : Vector.<Number> | LensBase
Inherited | _matrix : Matrix3D | LensBase
Inherited | _matrixInvalid : Boolean = true | LensBase
Inherited | _near : Number = 20 | LensBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ObliqueNearPlaneLens(baseLens:LensBase, plane:Plane3D) | ObliqueNearPlaneLens
Inherited | clone():LensBase Creates an exact duplicate of the lens | LensBase
Inherited | project(point3d:Vector3D):Vector3D | LensBase
Inherited | unproject(mX:Number, mY:Number, mZ:Number):Vector3D Calculates the position of the given normalized coordinates relative to the camera. | LensBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | invalidateMatrix():void Invalidates the projection matrix, which will cause it to be updated on the next request. | LensBase
 | updateMatrix():void [override] | ObliqueNearPlaneLens
Property Detail
aspectRatio property
aspectRatio:Number[override]

Implementation
    arcane function get aspectRatio():Number
    arcane function set aspectRatio(value:Number):void
baseLens property
baseLens:LensBase [write-only]

Implementation
    public function set baseLens(value:LensBase):void
far property
far:Number[override]

Implementation
    public function get far():Number
    public function set far(value:Number):void
frustumCorners property
frustumCorners:Vector.<Number>[override]

Implementation
    public function get frustumCorners():Vector.<Number>
    public function set frustumCorners(value:Vector.<Number>):void
near property
near:Number[override]

Implementation
    public function get near():Number
    public function set near(value:Number):void
plane property
plane:Plane3D

Implementation
    public function get plane():Plane3D
    public function set plane(value:Plane3D):void
Constructor Detail
ObliqueNearPlaneLens () Constructor
public function ObliqueNearPlaneLens(baseLens:LensBase, plane:Plane3D)

Parameters
baseLens:LensBase
plane:Plane3D
Method Detail
updateMatrix () method
override protected function updateMatrix():void


away3d.cameras.lenses.OrthographicLens

OrthographicLens | Properties | Methods
Package | away3d.cameras.lenses
Class | public class OrthographicLens
Inheritance | OrthographicLens Inheritance LensBase Inheritance flash.events.EventDispatcher

The PerspectiveLens object provides a projection matrix that projects 3D geometry isometrically. This entails there is no perspective distortion, and lines that are parallel in the scene will remain parallel on the screen.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | far : Number The distance to the far plane of the frustum. | LensBase
Inherited | frustumCorners : Vector.<Number> Retrieves the corner points of the lens frustum. | LensBase
Inherited | matrix : Matrix3D The projection matrix that transforms 3D geometry to normalized homogeneous coordinates. | LensBase
Inherited | near : Number The distance to the near plane of the frustum. | LensBase
 | projectionHeight : Number The vertical field of view of the projection. | OrthographicLens
Inherited | unprojectionMatrix : Matrix3D [read-only] | LensBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _aspectRatio : Number = 1 | LensBase
Inherited | _far : Number = 3000 | LensBase
Inherited | _frustumCorners : Vector.<Number> | LensBase
Inherited | _matrix : Matrix3D | LensBase
Inherited | _matrixInvalid : Boolean = true | LensBase
Inherited | _near : Number = 20 | LensBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | OrthographicLens(projectionHeight:Number = 500) Creates a new OrthogonalLens object. | OrthographicLens
 | clone():LensBase [override] | OrthographicLens
Inherited | project(point3d:Vector3D):Vector3D | LensBase
Inherited | unproject(mX:Number, mY:Number, mZ:Number):Vector3D Calculates the position of the given normalized coordinates relative to the camera. | LensBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | invalidateMatrix():void Invalidates the projection matrix, which will cause it to be updated on the next request. | LensBase
 | updateMatrix():void [override] Updates the matrix | OrthographicLens
Property Detail
projectionHeight property
projectionHeight:Number

The vertical field of view of the projection.

Implementation
    public function get projectionHeight():Number
    public function set projectionHeight(value:Number):void
Constructor Detail
OrthographicLens () Constructor
public function OrthographicLens(projectionHeight:Number = 500)

Creates a new OrthogonalLens object.

Parameters
projectionHeight:Number (default = 500)
Method Detail
clone () method
override public function clone():LensBase

Returns
LensBase
updateMatrix () method
override protected function updateMatrix():void

Updates the matrix


away3d.cameras.lenses.OrthographicOffCenterLens

OrthographicOffCenterLens | Properties | Methods
Package | away3d.cameras.lenses
Class | public class OrthographicOffCenterLens
Inheritance | OrthographicOffCenterLens Inheritance LensBase Inheritance flash.events.EventDispatcher

The PerspectiveLens object provides a projection matrix that projects 3D geometry isometrically. This entails there is no perspective distortion, and lines that are parallel in the scene will remain parallel on the screen.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | far : Number The distance to the far plane of the frustum. | LensBase
Inherited | frustumCorners : Vector.<Number> Retrieves the corner points of the lens frustum. | LensBase
Inherited | matrix : Matrix3D The projection matrix that transforms 3D geometry to normalized homogeneous coordinates. | LensBase
 | maxX : Number | OrthographicOffCenterLens
 | maxY : Number | OrthographicOffCenterLens
 | minX : Number | OrthographicOffCenterLens
 | minY : Number | OrthographicOffCenterLens
Inherited | near : Number The distance to the near plane of the frustum. | LensBase
Inherited | unprojectionMatrix : Matrix3D [read-only] | LensBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _aspectRatio : Number = 1 | LensBase
Inherited | _far : Number = 3000 | LensBase
Inherited | _frustumCorners : Vector.<Number> | LensBase
Inherited | _matrix : Matrix3D | LensBase
Inherited | _matrixInvalid : Boolean = true | LensBase
Inherited | _near : Number = 20 | LensBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | OrthographicOffCenterLens(minX:Number, maxX:Number, minY:Number, maxY:Number) Creates a new OrthogonalLens object. | OrthographicOffCenterLens
 | clone():LensBase [override] | OrthographicOffCenterLens
Inherited | project(point3d:Vector3D):Vector3D | LensBase
Inherited | unproject(mX:Number, mY:Number, mZ:Number):Vector3D Calculates the position of the given normalized coordinates relative to the camera. | LensBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | invalidateMatrix():void Invalidates the projection matrix, which will cause it to be updated on the next request. | LensBase
 | updateMatrix():void [override] Updates the matrix | OrthographicOffCenterLens
Property Detail
maxX property
maxX:Number

Implementation
    public function get maxX():Number
    public function set maxX(value:Number):void
maxY property
maxY:Number

Implementation
    public function get maxY():Number
    public function set maxY(value:Number):void
minX property
minX:Number

Implementation
    public function get minX():Number
    public function set minX(value:Number):void
minY property
minY:Number

Implementation
    public function get minY():Number
    public function set minY(value:Number):void
Constructor Detail
OrthographicOffCenterLens () Constructor
public function OrthographicOffCenterLens(minX:Number, maxX:Number, minY:Number, maxY:Number)

Creates a new OrthogonalLens object.

Parameters
minX:Number — The vertical field of view of the projection.
maxX:Number
minY:Number
maxY:Number
Method Detail
clone () method
override public function clone():LensBase

Returns
LensBase
updateMatrix () method
override protected function updateMatrix():void

Updates the matrix


away3d.cameras.lenses.PerspectiveLens

PerspectiveLens | Properties | Methods
Package | away3d.cameras.lenses
Class | public class PerspectiveLens
Inheritance | PerspectiveLens Inheritance LensBase Inheritance flash.events.EventDispatcher

The PerspectiveLens object provides a projection matrix that projects 3D geometry with perspective distortion.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | far : Number The distance to the far plane of the frustum. | LensBase
 | fieldOfView : Number The vertical field of view of the projection. | PerspectiveLens
Inherited | frustumCorners : Vector.<Number> Retrieves the corner points of the lens frustum. | LensBase
Inherited | matrix : Matrix3D The projection matrix that transforms 3D geometry to normalized homogeneous coordinates. | LensBase
Inherited | near : Number The distance to the near plane of the frustum. | LensBase
Inherited | unprojectionMatrix : Matrix3D [read-only] | LensBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _aspectRatio : Number = 1 | LensBase
Inherited | _far : Number = 3000 | LensBase
Inherited | _frustumCorners : Vector.<Number> | LensBase
Inherited | _matrix : Matrix3D | LensBase
Inherited | _matrixInvalid : Boolean = true | LensBase
Inherited | _near : Number = 20 | LensBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | PerspectiveLens(fieldOfView:Number = 60) Creates a new PerspectiveLens object. | PerspectiveLens
 | clone():LensBase [override] | PerspectiveLens
Inherited | project(point3d:Vector3D):Vector3D | LensBase
Inherited | unproject(mX:Number, mY:Number, mZ:Number):Vector3D Calculates the position of the given normalized coordinates relative to the camera. | LensBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | invalidateMatrix():void Invalidates the projection matrix, which will cause it to be updated on the next request. | LensBase
 | updateMatrix():void [override] Updates the matrix | PerspectiveLens
Property Detail
fieldOfView property
fieldOfView:Number

The vertical field of view of the projection.

Implementation
    public function get fieldOfView():Number
    public function set fieldOfView(value:Number):void
Constructor Detail
PerspectiveLens () Constructor
public function PerspectiveLens(fieldOfView:Number = 60)

Creates a new PerspectiveLens object.

Parameters
fieldOfView:Number (default = 60) — The vertical field of view of the projection.
Method Detail
clone () method
override public function clone():LensBase

Returns
LensBase
updateMatrix () method
override protected function updateMatrix():void

Updates the matrix


away3d.containers - Away3D Documentation

Package away3d.containers

Classes
ObjectContainer3D
Scene3D
View3D


away3d.containers Summary

away3d.containers | Classes

Classes
Class | Description
ObjectContainer3D | ObjectContainer3D is the most basic scene graph node.
Scene3D | The Scene3D class represents an independent 3D scene in which 3D objects can be created and manipulated.
View3D |

Thu Nov 15 2012, 12:09 PM Z


away3d.containers.ObjectContainer3D

ObjectContainer3D | Properties | Methods | Events | Constants
Package | away3d.containers
Class | public class ObjectContainer3D
Inheritance | ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IAsset
Subclasses | Entity, Loader3D, Sound3D, TextureProjector

ObjectContainer3D is the most basic scene graph node. It can contain other ObjectContainer3Ds. ObjectContainer3D can have its own scene partition assigned. However, when assigned to a different scene, it will loose any partition information, since partitions are tied to a scene.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
 | assetType : String [read-only] | ObjectContainer3D
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
 | ignoreTransform : Boolean Does not apply any transformations to this object. | ObjectContainer3D
 | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
 | maxX : Number [read-only] The maximum extremum of the object along the X-axis. | ObjectContainer3D
 | maxY : Number [read-only] The maximum extremum of the object along the Y-axis. | ObjectContainer3D
 | maxZ : Number [read-only] The maximum extremum of the object along the Z-axis. | ObjectContainer3D
 | minX : Number [read-only] The minimum extremum of the object along the X-axis. | ObjectContainer3D
 | minY : Number [read-only] The minimum extremum of the object along the Y-axis. | ObjectContainer3D
 | minZ : Number [read-only] The minimum extremum of the object along the Z-axis. | ObjectContainer3D
 | mouseChildren : Boolean | ObjectContainer3D
 | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
 | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
 | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
 | scene : Scene3D A reference to the Scene3D object to which this object belongs. | ObjectContainer3D
 | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
 | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
 | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
 | _explicitPartition : Partition3D | ObjectContainer3D
 | _ignoreTransform : Boolean = false | ObjectContainer3D
 | _implicitPartition : Partition3D | ObjectContainer3D
 | _mouseEnabled : Boolean | ObjectContainer3D
 | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
 | _scene : Scene3D | ObjectContainer3D
 | _sceneTransform : Matrix3D | ObjectContainer3D
 | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ObjectContainer3D() Creates a new ObjectContainer3D object. | ObjectContainer3D
 | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
 | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
 | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
 | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
 | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
 | dispose():void [override] Cleans up resources used by this asset. | ObjectContainer3D
Inherited | disposeAsset():void | Object3D
 | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
 | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
 | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
 | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
 | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
 | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
 | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | invalidateSceneTransform():void Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | ObjectContainer3D
 | updateMouseChildren():void | ObjectContainer3D
 | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
 | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
 | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
 | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
 | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
 | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
 | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
 | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_explicitPartition property
protected var _explicitPartition:Partition3D

_ignoreTransform property
protected var _ignoreTransform:Boolean = false

_implicitPartition property
protected var _implicitPartition:Partition3D

_isRoot property
arcane var _isRoot:Boolean

_mouseEnabled property
protected var _mouseEnabled:Boolean

_parent property
protected var _parent:ObjectContainer3D

_scene property
protected var _scene:Scene3D

_sceneTransform property
protected var _sceneTransform:Matrix3D

_sceneTransformDirty property
protected var _sceneTransformDirty:Boolean = true

assetType property
assetType:String [read-only]

Implementation
    public function get assetType():String
ignoreTransform property
ignoreTransform:Boolean

Does not apply any transformations to this object. Allows static objects to be described in world coordinates without any matrix calculations.

Implementation
    public function get ignoreTransform():Boolean
    public function set ignoreTransform(value:Boolean):void
implicitPartition property
implicitPartition:Partition3D

Implementation
    arcane function get implicitPartition():Partition3D
    arcane function set implicitPartition(value:Partition3D):void
inverseSceneTransform property
inverseSceneTransform:Matrix3D [read-only]

The inverse scene transform object that transforms from world to model space.

Implementation
    public function get inverseSceneTransform():Matrix3D
maxX property
maxX:Number [read-only]

The maximum extremum of the object along the X-axis.

Implementation
    public function get maxX():Number
maxY property
maxY:Number [read-only]

The maximum extremum of the object along the Y-axis.

Implementation
    public function get maxY():Number
maxZ property
maxZ:Number [read-only]

The maximum extremum of the object along the Z-axis.

Implementation
    public function get maxZ():Number
minX property
minX:Number [read-only]

The minimum extremum of the object along the X-axis.

Implementation
    public function get minX():Number
minY property
minY:Number [read-only]

The minimum extremum of the object along the Y-axis.

Implementation
    public function get minY():Number
minZ property
minZ:Number [read-only]

The minimum extremum of the object along the Z-axis.

Implementation
    public function get minZ():Number
mouseChildren property
mouseChildren:Boolean

Implementation
    public function get mouseChildren():Boolean
    public function set mouseChildren(value:Boolean):void
mouseEnabled property
mouseEnabled:Boolean

Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing.

Implementation
    public function get mouseEnabled():Boolean
    public function set mouseEnabled(value:Boolean):void
numChildren property
numChildren:uint [read-only]

The amount of child objects of the ObjectContainer3D.

Implementation
    public function get numChildren():uint
parent property
parent:ObjectContainer3D [read-only]

The parent ObjectContainer3D to which this object's transformation is relative.

Implementation
    public function get parent():ObjectContainer3D
partition property
partition:Partition3D

The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned.

Implementation
    public function get partition():Partition3D
    public function set partition(value:Partition3D):void
scene property
scene:Scene3D

A reference to the Scene3D object to which this object belongs.

Implementation
    public function get scene():Scene3D
    public function set scene(value:Scene3D):void
scenePosition property
scenePosition:Vector3D [read-only]

The global position of the ObjectContainer3D in the scene.

Implementation
    public function get scenePosition():Vector3D
sceneTransform property
sceneTransform:Matrix3D [read-only]

The transformation matrix that transforms from model to world space.

Implementation
    public function get sceneTransform():Matrix3D
visible property
visible:Boolean

Implementation
    public function get visible():Boolean
    public function set visible(value:Boolean):void
Constructor Detail
ObjectContainer3D () Constructor
public function ObjectContainer3D()

Creates a new ObjectContainer3D object.

Method Detail
addChild () method
public function addChild(child:ObjectContainer3D):ObjectContainer3D

Adds a child ObjectContainer3D to the current object. The child's transformation will become relative to the current object's transformation.

Parameters

child:ObjectContainer3D — The object to be added as a child.

Returns
ObjectContainer3D — A reference to the added child object.
addChildren () method
public function addChildren(... childarray):void

Adds an array of 3d objects to the scene as children of the container

Parameters

... childarray — An array of 3d objects to be added

addEventListener () method
override public function addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void

Parameters

type:String
listener:Function
useCapture:Boolean (default = false)
priority:int (default = 0)
useWeakReference:Boolean (default = false)

clone () method
override public function clone():Object3D

Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.)

Returns
Object3D
contains () method
public function contains(child:ObjectContainer3D):Boolean

Parameters

child:ObjectContainer3D

Returns
Boolean
dispatchEvent () method
override public function dispatchEvent(event:Event):Boolean

Parameters

event:Event

Returns
Boolean
dispose () method
override public function dispose():void

Cleans up resources used by this asset.

getChildAt () method
public function getChildAt(index:uint):ObjectContainer3D

Retrieves the child object at the given index.

Parameters

index:uint — The index of the object to be retrieved.

Returns
ObjectContainer3D — The child object at the given index.
invalidateSceneTransform () method
protected function invalidateSceneTransform():void

Invalidates the scene transformation matrix, causing it to be updated the next time it's requested.

invalidateTransform () method
override arcane function invalidateTransform():void

Invalidates the transformation matrix, causing it to be updated upon the next request

lookAt () method
override public function lookAt(target:Vector3D, upAxis:Vector3D = null):void

Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D.

Parameters

target:Vector3D — The vector defining the point to be looked at
upAxis:Vector3D (default = null) — An optional vector used to define the desired up orientation of the 3d object after rotation has occurred

removeChild () method
public function removeChild(child:ObjectContainer3D):void

Removes a 3d object from the child array of the container

Parameters

child:ObjectContainer3D — The 3d object to be removed

Throws
Error ObjectContainer3D:removeChild(null)
removeEventListener () method
override public function removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void

Parameters

type:String
listener:Function
useCapture:Boolean (default = false)

rotate () method
override public function rotate(axis:Vector3D, angle:Number):void

Parameters

axis:Vector3D
angle:Number

translateLocal () method
override public function translateLocal(axis:Vector3D, distance:Number):void

Parameters

axis:Vector3D
distance:Number

updateImplicitVisibility () method
public function updateImplicitVisibility():void

updateMouseChildren () method
protected function updateMouseChildren():void

updateSceneTransform () method
protected function updateSceneTransform():void

Updates the scene transformation matrix.

Event Detail
mouseDown3d Event
Event Object Type: away3d.events.MouseEvent3D
MouseEvent3D.type property = away3d.events.MouseEvent3D

Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object.

mouseMove3d Event
Event Object Type: away3d.events.MouseEvent3D
MouseEvent3D.type property = away3d.events.MouseEvent3D

Dispatched when a user moves the cursor while it is over the 3d object.

mouseOut3d Event
Event Object Type: away3d.events.MouseEvent3D
MouseEvent3D.type property = away3d.events.MouseEvent3D

Dispatched when a user moves the cursor away from the 3d object.

mouseOver3d Event
Event Object Type: away3d.events.MouseEvent3D
MouseEvent3D.type property = away3d.events.MouseEvent3D

Dispatched when a user moves the cursor over the 3d object.

mouseUp3d Event
Event Object Type: away3d.events.MouseEvent3D
MouseEvent3D.type property = away3d.events.MouseEvent3D

Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object.

sceneChanged Event
Event Object Type: away3d.events.Object3DEvent
Object3DEvent.type property = away3d.events.Object3DEvent

Dispatched when the parent scene of the 3d object changes.

See also

scene
scenetransformChanged Event
Event Object Type: away3d.events.Object3DEvent
Object3DEvent.type property = away3d.events.Object3DEvent

Dispatched when the scene transform matrix of the 3d object changes.

See also

sceneTransform


away3d.containers.Scene3D

Scene3D | Properties | Methods
Package | away3d.containers
Class | public class Scene3D
Inheritance | Scene3D Inheritance flash.events.EventDispatcher

The Scene3D class represents an independent 3D scene in which 3D objects can be created and manipulated. Multiple Scene3D instances can be created in the same SWF file. Scene management happens through the scene graph, which is exposed using addChild and removeChild methods. Internally, the Scene3D object also manages any space partition objects that have been assigned to objects in the scene graph, of which there is at least 1.

Public Properties
Property |  | Defined By
 | numChildren : uint [read-only] The amount of children directly contained by the scene. | Scene3D
 | partition : Partition3D The root partition to be used by the Scene3D. | Scene3D
Public Methods
Method |  | Defined By
 | Scene3D() Creates a new Scene3D object. | Scene3D
 | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child to the scene's root. | Scene3D
 | contains(child:ObjectContainer3D):Boolean | Scene3D
 | getChildAt(index:uint):ObjectContainer3D Retrieves the child with the given index | Scene3D
 | removeChild(child:ObjectContainer3D):void Removes a child from the scene's root. | Scene3D
 | traversePartitions(traverser:PartitionTraverser):void Sends a PartitionTraverser object down the scene partitions | Scene3D
Protected Methods
Method |  | Defined By
 | addPartitionUnique(partition:Partition3D):void Add a partition if it's not in the list | Scene3D
Property Detail
_sceneGraphRoot property
arcane var _sceneGraphRoot:ObjectContainer3D

numChildren property
numChildren:uint [read-only]

The amount of children directly contained by the scene.

Implementation
    public function get numChildren():uint
partition property
partition:Partition3D

The root partition to be used by the Scene3D.

Implementation
    public function get partition():Partition3D
    public function set partition(value:Partition3D):void
Constructor Detail
Scene3D () Constructor
public function Scene3D()

Creates a new Scene3D object.

Method Detail
addChild () method
public function addChild(child:ObjectContainer3D):ObjectContainer3D

Adds a child to the scene's root.

Parameters

child:ObjectContainer3D — The child to be added to the scene

Returns
ObjectContainer3D — A reference to the added child.
addPartitionUnique () method
protected function addPartitionUnique(partition:Partition3D):void

Add a partition if it's not in the list

Parameters

partition:Partition3D

contains () method
public function contains(child:ObjectContainer3D):Boolean

Parameters

child:ObjectContainer3D

Returns
Boolean
getChildAt () method
public function getChildAt(index:uint):ObjectContainer3D

Retrieves the child with the given index

Parameters

index:uint — The index for the child to be retrieved.

Returns
ObjectContainer3D — The child with the given index
invalidateEntityBounds () method
arcane function invalidateEntityBounds(entity:Entity):void

When an entity has moved or changed size, update its position in its partition tree.

Parameters

entity:Entity

registerPartition () method
arcane function registerPartition(entity:Entity):void

When a partition is assigned to an object somewhere in the scene graph, add the partition to the list if it isn't in there yet

Parameters

entity:Entity

removeChild () method
public function removeChild(child:ObjectContainer3D):void

Removes a child from the scene's root.

Parameters

child:ObjectContainer3D — The child to be removed from the scene.

traversePartitions () method
public function traversePartitions(traverser:PartitionTraverser):void

Sends a PartitionTraverser object down the scene partitions

Parameters

traverser:PartitionTraverser — The traverser which will pass through the partitions.

See also

away3d.core.traverse.PartitionTraverser
away3d.core.traverse.EntityCollector
unregisterPartition () method
arcane function unregisterPartition(entity:Entity):void

When a partition is removed from an object somewhere in the scene graph, remove the partition from the list

Parameters

entity:Entity


away3d.containers.View3D

View3D | Properties | Methods
Package | away3d.containers
Class | public class View3D
Inheritance | View3D Inheritance flash.display.Sprite
Subclasses | StereoView3D

Public Properties
Property |  | Defined By
 | antiAlias : uint The amount of anti-aliasing to be used. | View3D
 | background : Texture2DBase | View3D
 | backgroundAlpha : Number | View3D
 | backgroundColor : uint The background color of the screen. | View3D
 | camera : Camera3D The camera that's used to render the scene for this viewport | View3D
 | deltaTime : uint [read-only] The amount of milliseconds the last render call took | View3D
 | depthPrepass : Boolean | View3D
 | filters : Array [override] Not supported. | View3D
 | filters3d : Array | View3D
 | forceMouseMove : Boolean Forces mouse-move related events even when the mouse hasn't moved. | View3D
 | height : Number [override] The height of the viewport. | View3D
 | mousePicker : IPicker | View3D
 | renderedFacesCount : uint [read-only] The amount of faces that were pushed through the render pipeline on the last frame render. | View3D
 | renderer : RendererBase The renderer used to draw the scene. | View3D
 | rightClickMenuEnabled : Boolean | View3D
 | rotation : Number [override] [write-only] | View3D
 | rotationX : Number [override] [write-only] | View3D
 | rotationY : Number [override] [write-only] | View3D
 | rotationZ : Number [override] [write-only] | View3D
 | scaleX : Number [override] [write-only] | View3D
 | scaleY : Number [override] [write-only] | View3D
 | scaleZ : Number [override] [write-only] | View3D
 | scene : Scene3D The scene that's used to render for this viewport | View3D
 | shareContext : Boolean Defers control of Context3D clear() and present() calls to Stage3DProxy, enabling multiple Stage3D frameworks to share the same Context3D object. | View3D
 | stage3DProxy : Stage3DProxy | View3D
 | transform : Transform [override] [write-only] | View3D
 | visible : Boolean [override] [write-only] | View3D
 | width : Number [override] The width of the viewport. | View3D
 | x : Number [override] [write-only] | View3D
 | y : Number [override] [write-only] | View3D
 | z : Number [override] [write-only] | View3D
Protected Properties
Property |  | Defined By
 | _aspectRatio : Number | View3D
 | _backBufferInvalid : Boolean = true | View3D
 | _camera : Camera3D | View3D
 | _depthRender : Texture | View3D
 | _entityCollector : EntityCollector | View3D
 | _filter3DRenderer : Filter3DRenderer | View3D
 | _mouse3DManager : Mouse3DManager | View3D
 | _parentIsStage : Boolean | View3D
 | _renderer : RendererBase | View3D
 | _requireDepthRender : Boolean | View3D
 | _rttBufferManager : RTTBufferManager | View3D
 | _scene : Scene3D | View3D
 | _shareContext : Boolean = false | View3D
 | _stage3DProxy : Stage3DProxy | View3D
 | _viewScissorRect : Rectangle | View3D
Public Methods
Method |  | Defined By
 | View3D(scene:Scene3D = null, camera:Camera3D = null, renderer:RendererBase = null, forceSoftware:Boolean = false) | View3D
 | addSourceURL(url:String):void Defines a source url string that can be accessed though a View Source option in the right-click menu. | View3D
 | dispose():void Disposes all memory occupied by the view. | View3D
 | getRay(mX:Number, mY:Number, mZ:Number = 0):Vector3D Returns the ray in scene space from the camera to the point on the screen. | View3D
 | project(point3d:Vector3D):Vector3D | View3D
 | render():void Renders the view. | View3D
 | unproject(mX:Number, mY:Number, mZ:Number = 0):Vector3D Calculates the scene position of the given screen coordinates. | View3D
Protected Methods
Method |  | Defined By
 | renderDepthPrepass(entityCollector:EntityCollector):void | View3D
 | renderSceneDepthToTexture(entityCollector:EntityCollector):void | View3D
 | updateBackBuffer():void Updates the backbuffer dimensions. | View3D
 | updateGlobalPos():void | View3D
 | updateTime():void | View3D
 | updateViewSizeData():void | View3D
Property Detail
_aspectRatio property
protected var _aspectRatio:Number

_backBufferInvalid property
protected var _backBufferInvalid:Boolean = true

_camera property
protected var _camera:Camera3D

_depthRender property
protected var _depthRender:Texture

_entityCollector property
protected var _entityCollector:EntityCollector

_filter3DRenderer property
protected var _filter3DRenderer:Filter3DRenderer

_mouse3DManager property
protected var _mouse3DManager:Mouse3DManager

_parentIsStage property
protected var _parentIsStage:Boolean

_renderer property
protected var _renderer:RendererBase

_requireDepthRender property
protected var _requireDepthRender:Boolean

_rttBufferManager property
protected var _rttBufferManager:RTTBufferManager

_scene property
protected var _scene:Scene3D

_shareContext property
protected var _shareContext:Boolean = false

_stage3DProxy property
protected var _stage3DProxy:Stage3DProxy

_viewScissorRect property
protected var _viewScissorRect:Rectangle

antiAlias property
antiAlias:uint

The amount of anti-aliasing to be used.

Implementation
    public function get antiAlias():uint
    public function set antiAlias(value:uint):void
background property
background:Texture2DBase

Implementation
    public function get background():Texture2DBase
    public function set background(value:Texture2DBase):void
backgroundAlpha property
backgroundAlpha:Number

Implementation
    public function get backgroundAlpha():Number
    public function set backgroundAlpha(value:Number):void
backgroundColor property
backgroundColor:uint

The background color of the screen. This value is only used when clearAll is set to true.

Implementation
    public function get backgroundColor():uint
    public function set backgroundColor(value:uint):void
camera property
camera:Camera3D

The camera that's used to render the scene for this viewport

Implementation
    public function get camera():Camera3D
    public function set camera(value:Camera3D):void
deltaTime property
deltaTime:uint [read-only]

The amount of milliseconds the last render call took

Implementation
    public function get deltaTime():uint
depthPrepass property
depthPrepass:Boolean

Implementation
    public function get depthPrepass():Boolean
    public function set depthPrepass(value:Boolean):void
filters property
filters:Array[override]

Not supported. Use filters3d instead.

Implementation
    public function get filters():Array
    public function set filters(value:Array):void
filters3d property
filters3d:Array

Implementation
    public function get filters3d():Array
    public function set filters3d(value:Array):void
forceMouseMove property
forceMouseMove:Boolean

Forces mouse-move related events even when the mouse hasn't moved. This allows mouseOver and mouseOut events etc to be triggered due to changes in the scene graph. Defaults to false.

Implementation
    public function get forceMouseMove():Boolean
    public function set forceMouseMove(value:Boolean):void
height property
height:Number[override]

The height of the viewport. When software rendering is used, this is limited by the platform to 2048 pixels.

Implementation
    public function get height():Number
    public function set height(value:Number):void
mousePicker property
mousePicker:IPicker

Implementation
    public function get mousePicker():IPicker
    public function set mousePicker(value:IPicker):void
renderedFacesCount property
renderedFacesCount:uint [read-only]

The amount of faces that were pushed through the render pipeline on the last frame render.

Implementation
    public function get renderedFacesCount():uint
renderer property
renderer:RendererBase

The renderer used to draw the scene.

Implementation
    public function get renderer():RendererBase
    public function set renderer(value:RendererBase):void
rightClickMenuEnabled property
rightClickMenuEnabled:Boolean

Implementation
    public function get rightClickMenuEnabled():Boolean
    public function set rightClickMenuEnabled(value:Boolean):void
rotation property
rotation:Number [write-only] [override]

Implementation
    public function set rotation(value:Number):void
rotationX property
rotationX:Number [write-only] [override]

Implementation
    public function set rotationX(value:Number):void
rotationY property
rotationY:Number [write-only] [override]

Implementation
    public function set rotationY(value:Number):void
rotationZ property
rotationZ:Number [write-only] [override]

Implementation
    public function set rotationZ(value:Number):void
scaleX property
scaleX:Number [write-only] [override]

Implementation
    public function set scaleX(value:Number):void
scaleY property
scaleY:Number [write-only] [override]

Implementation
    public function set scaleY(value:Number):void
scaleZ property
scaleZ:Number [write-only] [override]

Implementation
    public function set scaleZ(value:Number):void
scene property
scene:Scene3D

The scene that's used to render for this viewport

Implementation
    public function get scene():Scene3D
    public function set scene(value:Scene3D):void
shareContext property
shareContext:Boolean

Defers control of Context3D clear() and present() calls to Stage3DProxy, enabling multiple Stage3D frameworks to share the same Context3D object.

Implementation
    public function get shareContext():Boolean
    public function set shareContext(value:Boolean):void
stage3DProxy property
stage3DProxy:Stage3DProxy

Implementation
    public function get stage3DProxy():Stage3DProxy
    public function set stage3DProxy(value:Stage3DProxy):void
transform property
transform:Transform [write-only] [override]

Implementation
    public function set transform(value:Transform):void
visible property
visible:Boolean [write-only] [override]

Implementation
    public function set visible(value:Boolean):void
width property
width:Number[override]

The width of the viewport. When software rendering is used, this is limited by the platform to 2048 pixels.

Implementation
    public function get width():Number
    public function set width(value:Number):void
x property
x:Number [write-only] [override]

Implementation
    public function set x(value:Number):void
y property
y:Number [write-only] [override]

Implementation
    public function set y(value:Number):void
z property
z:Number [write-only] [override]

Implementation
    public function set z(value:Number):void
Constructor Detail
View3D () Constructor
public function View3D(scene:Scene3D = null, camera:Camera3D = null, renderer:RendererBase = null, forceSoftware:Boolean = false)

Parameters
scene:Scene3D (default = null)
camera:Camera3D (default = null)
renderer:RendererBase (default = null)
forceSoftware:Boolean (default = false)
Method Detail
addSourceURL () method
public function addSourceURL(url:String):void

Defines a source url string that can be accessed though a View Source option in the right-click menu. Requires the stats panel to be enabled.

Parameters

url:String — The url to the source files.

dispose () method
public function dispose():void

Disposes all memory occupied by the view. This will also dispose the renderer.

getRay () method
public function getRay(mX:Number, mY:Number, mZ:Number = 0):Vector3D

Returns the ray in scene space from the camera to the point on the screen.

Parameters

mX:Number — The x coordinate relative to the View3D.
mY:Number — The y coordinate relative to the View3D.
mZ:Number (default = 0) — The z coordinate relative to the View3D.

Returns
Vector3D — The ray from the camera to the scene space position of a point on the projection plane.
project () method
public function project(point3d:Vector3D):Vector3D

Parameters

point3d:Vector3D

Returns
Vector3D
render () method
public function render():void

Renders the view.

renderDepthPrepass () method
protected function renderDepthPrepass(entityCollector:EntityCollector):void

Parameters

entityCollector:EntityCollector

renderSceneDepthToTexture () method
protected function renderSceneDepthToTexture(entityCollector:EntityCollector):void

Parameters

entityCollector:EntityCollector

unproject () method
public function unproject(mX:Number, mY:Number, mZ:Number = 0):Vector3D

Calculates the scene position of the given screen coordinates.

Parameters

mX:Number — The x coordinate relative to the View3D.
mY:Number — The y coordinate relative to the View3D.
mZ:Number (default = 0) — The z coordinate relative to the View3D.

Returns
Vector3D — The scene position of the given screen coordinates. The returned point corresponds to a point on the projection plane.
updateBackBuffer () method
protected function updateBackBuffer():void

Updates the backbuffer dimensions.

updateGlobalPos () method
protected function updateGlobalPos():void

updateTime () method
protected function updateTime():void

updateViewSizeData () method
protected function updateViewSizeData():void


away3d.controllers - Away3D Documentation

Package away3d.controllers

Classes
ControllerBase
FirstPersonController
FollowController
HoverController
LookAtController
SpringController


away3d.controllers Summary

away3d.controllers | Classes

Classes
Class | Description
ControllerBase |
FirstPersonController | Extended camera used to hover round a specified target object.
FollowController | Controller used to follow behind an object on the XZ plane, with an optional elevation (tiltAngle).
HoverController | Extended camera used to hover round a specified target object.
LookAtController | Extended camera used to automatically look at a specified target object.
SpringController | Uses spring physics to animate the target object towards a position that is defined as the lookAtTarget object's position plus the vector defined by the positionOffset property.

Thu Nov 15 2012, 12:09 PM Z


away3d.controllers.ControllerBase

ControllerBase | Properties | Methods
Package | away3d.controllers
Class | public class ControllerBase
Inheritance | ControllerBase Inheritance Object
Subclasses | FirstPersonController, LookAtController

Public Properties
Property |  | Defined By
 | autoUpdate : Boolean Determines whether the controller applies updates automatically. | ControllerBase
 | targetObject : Entity Target object on which the controller acts. | ControllerBase
Protected Properties
Property |  | Defined By
 | _autoUpdate : Boolean = true | ControllerBase
 | _targetObject : Entity | ControllerBase
Public Methods
Method |  | Defined By
 | ControllerBase(targetObject:Entity = null) Base controller class for dynamically adjusting the propeties of a 3D object. | ControllerBase
 | update():void Manually applies updates to the target 3D object. | ControllerBase
Protected Methods
Method |  | Defined By
 | notifyUpdate():void | ControllerBase
Property Detail
_autoUpdate property
protected var _autoUpdate:Boolean = true

_targetObject property
protected var _targetObject:Entity

autoUpdate property
autoUpdate:Boolean

Determines whether the controller applies updates automatically. Defaults to true

Implementation
    public function get autoUpdate():Boolean
    public function set autoUpdate(value:Boolean):void
targetObject property
targetObject:Entity

Target object on which the controller acts. Defaults to null.

Implementation
    public function get targetObject():Entity
    public function set targetObject(value:Entity):void
Constructor Detail
ControllerBase () Constructor
public function ControllerBase(targetObject:Entity = null)

Base controller class for dynamically adjusting the propeties of a 3D object.

Parameters
targetObject:Entity (default = null) — The 3D object on which to act.
Method Detail
notifyUpdate () method
protected function notifyUpdate():void

update () method
public function update():void

Manually applies updates to the target 3D object.


away3d.controllers.FirstPersonController

FirstPersonController | Properties | Methods
Package | away3d.controllers
Class | public class FirstPersonController
Inheritance | FirstPersonController Inheritance ControllerBase Inheritance Object

Extended camera used to hover round a specified target object.

See also

away3d.containers.View3D

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | autoUpdate : Boolean Determines whether the controller applies updates automatically. | ControllerBase
 | fly : Boolean = false | FirstPersonController
 | maxTiltAngle : Number Maximum bounds for the tiltAngle. | FirstPersonController
 | minTiltAngle : Number Minimum bounds for the tiltAngle. | FirstPersonController
 | panAngle : Number Rotation of the camera in degrees around the y axis. | FirstPersonController
 | steps : uint Fractional step taken each time the hover() method is called. | FirstPersonController
Inherited | targetObject : Entity Target object on which the controller acts. | ControllerBase
 | tiltAngle : Number Elevation angle of the camera in degrees. | FirstPersonController
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _autoUpdate : Boolean = true | ControllerBase
Inherited | _targetObject : Entity | ControllerBase
Public Methods
Method |  | Defined By
 | FirstPersonController(targetObject:Entity = null, panAngle:Number = 0, tiltAngle:Number = 90, minTiltAngle:Number = -90, maxTiltAngle:Number = 90, steps:uint = 8) Creates a new HoverController object. | FirstPersonController
 | incrementStrafe(val:Number):void | FirstPersonController
 | incrementWalk(val:Number):void | FirstPersonController
 | update():void [override] Updates the current tilt angle and pan angle values. | FirstPersonController
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | notifyUpdate():void | ControllerBase
Property Detail
_currentPanAngle property
arcane var _currentPanAngle:Number = 0

_currentTiltAngle property
arcane var _currentTiltAngle:Number = 90

fly property
public var fly:Boolean = false

maxTiltAngle property
maxTiltAngle:Number

Maximum bounds for the tiltAngle. Defaults to 90.

Implementation
    public function get maxTiltAngle():Number
    public function set maxTiltAngle(value:Number):void

See also

tiltAngle
minTiltAngle property
minTiltAngle:Number

Minimum bounds for the tiltAngle. Defaults to -90.

Implementation
    public function get minTiltAngle():Number
    public function set minTiltAngle(value:Number):void

See also

tiltAngle
panAngle property
panAngle:Number

Rotation of the camera in degrees around the y axis. Defaults to 0.

Implementation
    public function get panAngle():Number
    public function set panAngle(value:Number):void
steps property
steps:uint

Fractional step taken each time the hover() method is called. Defaults to 8. Affects the speed at which the tiltAngle and panAngle resolve to their targets.

Implementation
    public function get steps():uint
    public function set steps(value:uint):void

See also

tiltAngle
panAngle
tiltAngle property
tiltAngle:Number

Elevation angle of the camera in degrees. Defaults to 90.

Implementation
    public function get tiltAngle():Number
    public function set tiltAngle(value:Number):void
Constructor Detail
FirstPersonController () Constructor
public function FirstPersonController(targetObject:Entity = null, panAngle:Number = 0, tiltAngle:Number = 90, minTiltAngle:Number = -90, maxTiltAngle:Number = 90, steps:uint = 8)

Creates a new HoverController object.

Parameters
targetObject:Entity (default = null)
panAngle:Number (default = 0)
tiltAngle:Number (default = 90)
minTiltAngle:Number (default = -90)
maxTiltAngle:Number (default = 90)
steps:uint (default = 8)
Method Detail
incrementStrafe () method
public function incrementStrafe(val:Number):void

Parameters

val:Number

incrementWalk () method
public function incrementWalk(val:Number):void

Parameters

val:Number

update () method
override public function update():void

Updates the current tilt angle and pan angle values. Values are calculated using the defined tiltAngle, panAngle and steps variables.

See also


away3d.controllers.FollowController

FollowController | Properties | Methods
Package | away3d.controllers
Class | public class FollowController
Inheritance | FollowController Inheritance HoverController Inheritance LookAtController Inheritance ControllerBase Inheritance Object

Controller used to follow behind an object on the XZ plane, with an optional elevation (tiltAngle).

See also

away3d.containers.View3D

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | autoUpdate : Boolean Determines whether the controller applies updates automatically. | ControllerBase
Inherited | distance : Number Distance between the camera and the specified target. | HoverController
Inherited | lookAtObject : ObjectContainer3D The 3d object that the target looks at. | LookAtController
Inherited | lookAtPosition : Vector3D The Vector3D object that the target looks at. | LookAtController
Inherited | maxPanAngle : Number Maximum bounds for the panAngle. | HoverController
Inherited | maxTiltAngle : Number Maximum bounds for the tiltAngle. | HoverController
Inherited | minPanAngle : Number Minimum bounds for the panAngle. | HoverController
Inherited | minTiltAngle : Number Minimum bounds for the tiltAngle. | HoverController
Inherited | panAngle : Number Rotation of the camera in degrees around the y axis. | HoverController
Inherited | steps : uint Fractional step taken each time the hover() method is called. | HoverController
Inherited | targetObject : Entity Target object on which the controller acts. | ControllerBase
Inherited | tiltAngle : Number Elevation angle of the camera in degrees. | HoverController
Inherited | wrapPanAngle : Boolean Defines whether the value of the pan angle wraps when over 360 degrees or under 0 degrees. | HoverController
Inherited | yFactor : Number Fractional difference in distance between the horizontal camera orientation and vertical camera orientation. | HoverController
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _autoUpdate : Boolean = true | ControllerBase
Inherited | _lookAtObject : ObjectContainer3D | LookAtController
Inherited | _lookAtPosition : Vector3D | LookAtController
Inherited | _origin : Vector3D | LookAtController
Inherited | _targetObject : Entity | ControllerBase
Public Methods
Method |  | Defined By
 | FollowController(targetObject:Entity = null, lookAtObject:ObjectContainer3D = null, tiltAngle:Number = 45, distance:Number = 700) | FollowController
 | update():void [override] | FollowController
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | notifyUpdate():void | ControllerBase
Constructor Detail
FollowController () Constructor
public function FollowController(targetObject:Entity = null, lookAtObject:ObjectContainer3D = null, tiltAngle:Number = 45, distance:Number = 700)

Parameters
targetObject:Entity (default = null)
lookAtObject:ObjectContainer3D (default = null)
tiltAngle:Number (default = 45)
distance:Number (default = 700)
Method Detail
update () method
override public function update():void


away3d.controllers.HoverController

HoverController | Properties | Methods
Package | away3d.controllers
Class | public class HoverController
Inheritance | HoverController Inheritance LookAtController Inheritance ControllerBase Inheritance Object
Subclasses | FollowController

Extended camera used to hover round a specified target object.

See also

away3d.containers.View3D

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | autoUpdate : Boolean Determines whether the controller applies updates automatically. | ControllerBase
 | distance : Number Distance between the camera and the specified target. | HoverController
Inherited | lookAtObject : ObjectContainer3D The 3d object that the target looks at. | LookAtController
Inherited | lookAtPosition : Vector3D The Vector3D object that the target looks at. | LookAtController
 | maxPanAngle : Number Maximum bounds for the panAngle. | HoverController
 | maxTiltAngle : Number Maximum bounds for the tiltAngle. | HoverController
 | minPanAngle : Number Minimum bounds for the panAngle. | HoverController
 | minTiltAngle : Number Minimum bounds for the tiltAngle. | HoverController
 | panAngle : Number Rotation of the camera in degrees around the y axis. | HoverController
 | steps : uint Fractional step taken each time the hover() method is called. | HoverController
Inherited | targetObject : Entity Target object on which the controller acts. | ControllerBase
 | tiltAngle : Number Elevation angle of the camera in degrees. | HoverController
 | wrapPanAngle : Boolean Defines whether the value of the pan angle wraps when over 360 degrees or under 0 degrees. | HoverController
 | yFactor : Number Fractional difference in distance between the horizontal camera orientation and vertical camera orientation. | HoverController
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _autoUpdate : Boolean = true | ControllerBase
Inherited | _lookAtObject : ObjectContainer3D | LookAtController
Inherited | _lookAtPosition : Vector3D | LookAtController
Inherited | _origin : Vector3D | LookAtController
Inherited | _targetObject : Entity | ControllerBase
Public Methods
Method |  | Defined By
 | HoverController(targetObject:Entity = null, lookAtObject:ObjectContainer3D = null, panAngle:Number = 0, tiltAngle:Number = 90, distance:Number = 1000, minTiltAngle:Number = -90, maxTiltAngle:Number = 90, minPanAngle:Number, maxPanAngle:Number, steps:uint = 8, yFactor:Number = 2, wrapPanAngle:Boolean = false) Creates a new HoverController object. | HoverController
 | update():void [override] Updates the current tilt angle and pan angle values. | HoverController
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | notifyUpdate():void | ControllerBase
Property Detail
_currentPanAngle property
arcane var _currentPanAngle:Number = 0

_currentTiltAngle property
arcane var _currentTiltAngle:Number = 90

distance property
distance:Number

Distance between the camera and the specified target. Defaults to 1000.

Implementation
    public function get distance():Number
    public function set distance(value:Number):void
maxPanAngle property
maxPanAngle:Number

Maximum bounds for the panAngle. Defaults to Infinity.

Implementation
    public function get maxPanAngle():Number
    public function set maxPanAngle(value:Number):void

See also

panAngle
maxTiltAngle property
maxTiltAngle:Number

Maximum bounds for the tiltAngle. Defaults to 90.

Implementation
    public function get maxTiltAngle():Number
    public function set maxTiltAngle(value:Number):void

See also

tiltAngle
minPanAngle property
minPanAngle:Number

Minimum bounds for the panAngle. Defaults to -Infinity.

Implementation
    public function get minPanAngle():Number
    public function set minPanAngle(value:Number):void

See also

panAngle
minTiltAngle property
minTiltAngle:Number

Minimum bounds for the tiltAngle. Defaults to -90.

Implementation
    public function get minTiltAngle():Number
    public function set minTiltAngle(value:Number):void

See also

tiltAngle
panAngle property
panAngle:Number

Rotation of the camera in degrees around the y axis. Defaults to 0.

Implementation
    public function get panAngle():Number
    public function set panAngle(value:Number):void
steps property
steps:uint

Fractional step taken each time the hover() method is called. Defaults to 8. Affects the speed at which the tiltAngle and panAngle resolve to their targets.

Implementation
    public function get steps():uint
    public function set steps(value:uint):void

See also

tiltAngle
panAngle
tiltAngle property
tiltAngle:Number

Elevation angle of the camera in degrees. Defaults to 90.

Implementation
    public function get tiltAngle():Number
    public function set tiltAngle(value:Number):void
wrapPanAngle property
wrapPanAngle:Boolean

Defines whether the value of the pan angle wraps when over 360 degrees or under 0 degrees. Defaults to false.

Implementation
    public function get wrapPanAngle():Boolean
    public function set wrapPanAngle(value:Boolean):void
yFactor property
yFactor:Number

Fractional difference in distance between the horizontal camera orientation and vertical camera orientation. Defaults to 2.

Implementation
    public function get yFactor():Number
    public function set yFactor(value:Number):void

See also

distance
Constructor Detail
HoverController () Constructor
public function HoverController(targetObject:Entity = null, lookAtObject:ObjectContainer3D = null, panAngle:Number = 0, tiltAngle:Number = 90, distance:Number = 1000, minTiltAngle:Number = -90, maxTiltAngle:Number = 90, minPanAngle:Number, maxPanAngle:Number, steps:uint = 8, yFactor:Number = 2, wrapPanAngle:Boolean = false)

Creates a new HoverController object.

Parameters
targetObject:Entity (default = null)
lookAtObject:ObjectContainer3D (default = null)
panAngle:Number (default = 0)
tiltAngle:Number (default = 90)
distance:Number (default = 1000)
minTiltAngle:Number (default = -90)
maxTiltAngle:Number (default = 90)
minPanAngle:Number (default = NaN)
maxPanAngle:Number (default = NaN)
steps:uint (default = 8)
yFactor:Number (default = 2)
wrapPanAngle:Boolean (default = false)
Method Detail
update () method
override public function update():void

Updates the current tilt angle and pan angle values. Values are calculated using the defined tiltAngle, panAngle and steps variables.

See also


away3d.controllers.LookAtController

LookAtController | Properties | Methods
Package | away3d.controllers
Class | public class LookAtController
Inheritance | LookAtController Inheritance ControllerBase Inheritance Object
Subclasses | HoverController, SpringController

Extended camera used to automatically look at a specified target object.

See also

away3d.containers.View3D

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | autoUpdate : Boolean Determines whether the controller applies updates automatically. | ControllerBase
 | lookAtObject : ObjectContainer3D The 3d object that the target looks at. | LookAtController
 | lookAtPosition : Vector3D The Vector3D object that the target looks at. | LookAtController
Inherited | targetObject : Entity Target object on which the controller acts. | ControllerBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _autoUpdate : Boolean = true | ControllerBase
 | _lookAtObject : ObjectContainer3D | LookAtController
 | _lookAtPosition : Vector3D | LookAtController
 | _origin : Vector3D | LookAtController
Inherited | _targetObject : Entity | ControllerBase
Public Methods
Method |  | Defined By
 | LookAtController(targetObject:Entity = null, lookAtObject:ObjectContainer3D = null) Creates a new LookAtController object. | LookAtController
 | update():void [override] Manually applies updates to the target 3D object. | LookAtController
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | notifyUpdate():void | ControllerBase
Property Detail
_lookAtObject property
protected var _lookAtObject:ObjectContainer3D

_lookAtPosition property
protected var _lookAtPosition:Vector3D

_origin property
protected var _origin:Vector3D

lookAtObject property
lookAtObject:ObjectContainer3D

The 3d object that the target looks at.

Implementation
    public function get lookAtObject():ObjectContainer3D
    public function set lookAtObject(value:ObjectContainer3D):void
lookAtPosition property
lookAtPosition:Vector3D

The Vector3D object that the target looks at.

Implementation
    public function get lookAtPosition():Vector3D
    public function set lookAtPosition(value:Vector3D):void
Constructor Detail
LookAtController () Constructor
public function LookAtController(targetObject:Entity = null, lookAtObject:ObjectContainer3D = null)

Creates a new LookAtController object.

Parameters
targetObject:Entity (default = null)
lookAtObject:ObjectContainer3D (default = null)
Method Detail
update () method
override public function update():void

Manually applies updates to the target 3D object.


away3d.controllers.SpringController

SpringController | Properties | Methods
Package | away3d.controllers
Class | public class SpringController
Inheritance | SpringController Inheritance LookAtController Inheritance ControllerBase Inheritance Object

Uses spring physics to animate the target object towards a position that is defined as the lookAtTarget object's position plus the vector defined by the positionOffset property.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | autoUpdate : Boolean Determines whether the controller applies updates automatically. | ControllerBase
 | damping : Number Damping is the spring internal friction, or how much it resists the "boinggggg" effect. | SpringController
Inherited | lookAtObject : ObjectContainer3D The 3d object that the target looks at. | LookAtController
Inherited | lookAtPosition : Vector3D The Vector3D object that the target looks at. | LookAtController
 | mass : Number Mass of the camera, if over 120 and it'll be very heavy to move. | SpringController
 | positionOffset : Vector3D Offset of spring center from target in target object space, ie: Where the camera should ideally be in the target object space. | SpringController
 | stiffness : Number Stiffness of the spring, how hard is it to extend. | SpringController
Inherited | targetObject : Entity Target object on which the controller acts. | ControllerBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _autoUpdate : Boolean = true | ControllerBase
Inherited | _lookAtObject : ObjectContainer3D | LookAtController
Inherited | _lookAtPosition : Vector3D | LookAtController
Inherited | _origin : Vector3D | LookAtController
Inherited | _targetObject : Entity | ControllerBase
Public Methods
Method |  | Defined By
 | SpringController(targetObject:Entity = null, lookAtObject:ObjectContainer3D = null, stiffness:Number = 1, mass:Number = 40, damping:Number = 4) | SpringController
 | update():void [override] | SpringController
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | notifyUpdate():void | ControllerBase
Property Detail
damping property
public var damping:Number

Damping is the spring internal friction, or how much it resists the "boinggggg" effect. Too high and you'll lose it! A number between 1 and 20 is recommended.

mass property
public var mass:Number

Mass of the camera, if over 120 and it'll be very heavy to move.

positionOffset property
public var positionOffset:Vector3D

Offset of spring center from target in target object space, ie: Where the camera should ideally be in the target object space.

stiffness property
public var stiffness:Number

Stiffness of the spring, how hard is it to extend. The higher it is, the more "fixed" the cam will be. A number between 1 and 20 is recommended.

Constructor Detail
SpringController () Constructor
public function SpringController(targetObject:Entity = null, lookAtObject:ObjectContainer3D = null, stiffness:Number = 1, mass:Number = 40, damping:Number = 4)

Parameters
targetObject:Entity (default = null)
lookAtObject:ObjectContainer3D (default = null)
stiffness:Number (default = 1)
mass:Number (default = 40)
damping:Number (default = 4)
Method Detail
update () method
override public function update():void


away3d.core.base - Away3D Documentation

Package away3d.core.base

Interfaces
IMaterialOwner
IRenderable
ISubGeometry
Classes
CompactSubGeometry
Geometry
Object3D
ParticleGeometry
SkinnedSubGeometry
SubGeometry
SubGeometryBase
SubMesh


away3d.core.base Summary

away3d.core.base | Interfaces | Classes

Interfaces
Interface | Description
IMaterialOwner | IMaterialOwner provides an interface for objects that can use materials.
IRenderable | IRenderable provides an interface for objects that can be rendered in the rendering pipeline.
ISubGeometry |
Classes
Class | Description
CompactSubGeometry |
Geometry | Geometry is a collection of SubGeometries, each of which contain the actual geometrical data such as vertices, normals, uvs, etc.
Object3D | Object3D provides a base class for any 3D object that has a (local) transformation. Standard Transform: The standard order for transformation is [parent transform] (Translate+Pivot) (Rotate) (-Pivot) (Scale) [child transform] This is the order of matrix multiplications, left-to-right.
ParticleGeometry | ...
SkinnedSubGeometry | SkinnedSubGeometry provides a SubGeometry extension that contains data needed to skin vertices.
SubGeometry | The SubGeometry class is a collections of geometric data that describes a triangle mesh.
SubGeometryBase |
SubMesh | SubMesh wraps a SubGeometry as a scene graph instantiation.

Thu Nov 15 2012, 12:09 PM Z


away3d.core.base.CompactSubGeometry

CompactSubGeometry | Properties | Methods
Package | away3d.core.base
Class | public class CompactSubGeometry
Inheritance | CompactSubGeometry Inheritance SubGeometryBase Inheritance Object
Implements | ISubGeometry
Subclasses | SkinnedSubGeometry

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | autoDeriveVertexNormals : Boolean True if the vertex normals should be derived from the geometry, false if the vertex normals are set explicitly. | SubGeometryBase
Inherited | autoDeriveVertexTangents : Boolean True if the vertex tangents should be derived from the geometry, false if the vertex normals are set explicitly. | SubGeometryBase
Inherited | autoGenerateDummyUVs : Boolean Defines whether a UV buffer should be automatically generated to contain dummy UV coordinates. | SubGeometryBase
Inherited | numTriangles : uint [read-only] The total amount of triangles in the SubGeometry. | SubGeometryBase
 | numVertices : uint [read-only] | CompactSubGeometry
Inherited | parentGeometry : Geometry | SubGeometryBase
Inherited | scaleU : Number [read-only] Scales the uv coordinates | SubGeometryBase
Inherited | scaleV : Number [read-only] | SubGeometryBase
 | secondaryUVOffset : int [read-only] | CompactSubGeometry
 | secondaryUVStride : uint [read-only] | CompactSubGeometry
Inherited | useFaceWeights : Boolean Indicates whether or not to take the size of faces into account when auto-deriving vertex normals and tangents. | SubGeometryBase
 | UVData : Vector.<Number> [override] [read-only] | CompactSubGeometry
 | UVOffset : int [override] [read-only] | CompactSubGeometry
 | UVStride : uint [override] [read-only] | CompactSubGeometry
 | vertexData : Vector.<Number> [override] [read-only] | CompactSubGeometry
 | vertexNormalData : Vector.<Number> [override] [read-only] | CompactSubGeometry
 | vertexNormalOffset : int [override] [read-only] | CompactSubGeometry
 | vertexNormalStride : uint [override] [read-only] | CompactSubGeometry
 | vertexOffset : int [override] [read-only] | CompactSubGeometry
 | vertexStride : uint [override] [read-only] | CompactSubGeometry
 | vertexTangentData : Vector.<Number> [override] [read-only] | CompactSubGeometry
 | vertexTangentOffset : int [override] [read-only] | CompactSubGeometry
 | vertexTangentStride : uint [override] [read-only] | CompactSubGeometry
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
 | _activeBuffer : VertexBuffer3D | CompactSubGeometry
 | _activeContext : Context3D | CompactSubGeometry
 | _activeDataInvalid : Boolean | CompactSubGeometry
Inherited | _autoDeriveVertexNormals : Boolean = true | SubGeometryBase
Inherited | _autoDeriveVertexTangents : Boolean = true | SubGeometryBase
Inherited | _autoGenerateUVs : Boolean = false | SubGeometryBase
 | _bufferContext : Vector.<Context3D> | CompactSubGeometry
 | _contextIndex : int | CompactSubGeometry
Inherited | _faceNormals : Vector.<Number> | SubGeometryBase
Inherited | _faceNormalsDirty : Boolean = true | SubGeometryBase
Inherited | _faceTangents : Vector.<Number> | SubGeometryBase
Inherited | _faceTangentsDirty : Boolean = true | SubGeometryBase
Inherited | _faceWeights : Vector.<Number> | SubGeometryBase
Inherited | _indexBuffer : Vector.<IndexBuffer3D> | SubGeometryBase
Inherited | _indexBufferContext : Vector.<Context3D> | SubGeometryBase
Inherited | _indices : Vector.<uint> | SubGeometryBase
Inherited | _indicesInvalid : Vector.<Boolean> | SubGeometryBase
Inherited | _numIndices : uint | SubGeometryBase
Inherited | _numTriangles : uint | SubGeometryBase
 | _numVertices : uint | CompactSubGeometry
Inherited | _uvsDirty : Boolean = true | SubGeometryBase
 | _vertexBuffer : Vector.<VertexBuffer3D> | CompactSubGeometry
Inherited | _vertexData : Vector.<Number> | SubGeometryBase
 | _vertexDataInvalid : Vector.<Boolean> | CompactSubGeometry
Inherited | _vertexNormalsDirty : Boolean = true | SubGeometryBase
Inherited | _vertexTangentsDirty : Boolean = true | SubGeometryBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CompactSubGeometry() | CompactSubGeometry
 | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | CompactSubGeometry
 | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | CompactSubGeometry
 | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void | CompactSubGeometry
 | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void | CompactSubGeometry
 | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void | CompactSubGeometry
 | applyTransformation(transform:Matrix3D):void [override] | CompactSubGeometry
 | clone():ISubGeometry | CompactSubGeometry
 | cloneWithSeperateBuffers():SubGeometry | CompactSubGeometry
 | dispose():void [override] | CompactSubGeometry
 | fromVectors(verts:Vector.<Number>, uvs:Vector.<Number>, normals:Vector.<Number>, tangents:Vector.<Number>):void | CompactSubGeometry
Inherited | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D Retrieves the VertexBuffer3D object that contains triangle indices. | SubGeometryBase
 | scale(scale:Number):void [override] | CompactSubGeometry
 | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void [override] | CompactSubGeometry
 | updateData(data:Vector.<Number>):void Updates the vertex data. | CompactSubGeometry
Inherited | updateIndexData(indices:Vector.<uint>):void Updates the face indices of the SubGeometry. | SubGeometryBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createBuffer(contextIndex:int, context:Context3D):void | CompactSubGeometry
Inherited | disposeIndexBuffers(buffers:Vector.<IndexBuffer3D>):void Disposes all buffers in a given vector. | SubGeometryBase
 | disposeVertexBuffers(buffers:Vector.<VertexBuffer3D>):void [override] | CompactSubGeometry
Inherited | invalidateBounds():void | SubGeometryBase
 | invalidateBuffers(invalid:Vector.<Boolean>):void [override] | CompactSubGeometry
 | stripBuffer(offset:int, numEntries:int):Vector.<Number> | CompactSubGeometry
 | updateActiveBuffer(contextIndex:int):void | CompactSubGeometry
Inherited | updateDummyUVs(target:Vector.<Number>):Vector.<Number> | SubGeometryBase
Inherited | updateFaceTangents():void Updates the tangents for each face. | SubGeometryBase
 | updateVertexNormals(target:Vector.<Number>):Vector.<Number> [override] | CompactSubGeometry
 | updateVertexTangents(target:Vector.<Number>):Vector.<Number> [override] | CompactSubGeometry
 | uploadData(contextIndex:int):void | CompactSubGeometry
Property Detail
_activeBuffer property
protected var _activeBuffer:VertexBuffer3D

_activeContext property
protected var _activeContext:Context3D

_activeDataInvalid property
protected var _activeDataInvalid:Boolean

_bufferContext property
protected var _bufferContext:Vector.<Context3D>

_contextIndex property
protected var _contextIndex:int

_numVertices property
protected var _numVertices:uint

_vertexBuffer property
protected var _vertexBuffer:Vector.<VertexBuffer3D>

_vertexDataInvalid property
protected var _vertexDataInvalid:Vector.<Boolean>

numVertices property
numVertices:uint [read-only]

Implementation
    public function get numVertices():uint
secondaryUVOffset property
secondaryUVOffset:int [read-only]

Implementation
    public function get secondaryUVOffset():int
secondaryUVStride property
secondaryUVStride:uint [read-only]

Implementation
    public function get secondaryUVStride():uint
UVData property
UVData:Vector.<Number> [read-only] [override]

Implementation
    public function get UVData():Vector.<Number>
UVOffset property
UVOffset:int [read-only] [override]

Implementation
    public function get UVOffset():int
UVStride property
UVStride:uint [read-only] [override]

Implementation
    public function get UVStride():uint
vertexData property
vertexData:Vector.<Number> [read-only] [override]

Implementation
    public function get vertexData():Vector.<Number>
vertexNormalData property
vertexNormalData:Vector.<Number> [read-only] [override]

Implementation
    public function get vertexNormalData():Vector.<Number>
vertexNormalOffset property
vertexNormalOffset:int [read-only] [override]

Implementation
    public function get vertexNormalOffset():int
vertexNormalStride property
vertexNormalStride:uint [read-only] [override]

Implementation
    public function get vertexNormalStride():uint
vertexOffset property
vertexOffset:int [read-only] [override]

Implementation
    public function get vertexOffset():int
vertexStride property
vertexStride:uint [read-only] [override]

Implementation
    public function get vertexStride():uint
vertexTangentData property
vertexTangentData:Vector.<Number> [read-only] [override]

Implementation
    public function get vertexTangentData():Vector.<Number>
vertexTangentOffset property
vertexTangentOffset:int [read-only] [override]

Implementation
    public function get vertexTangentOffset():int
vertexTangentStride property
vertexTangentStride:uint [read-only] [override]

Implementation
    public function get vertexTangentStride():uint
Constructor Detail
CompactSubGeometry () Constructor
public function CompactSubGeometry()

Method Detail
activateSecondaryUVBuffer () method
public function activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateUVBuffer () method
public function activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateVertexBuffer () method
public function activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateVertexNormalBuffer () method
public function activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateVertexTangentBuffer () method
public function activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

applyTransformation () method
override public function applyTransformation(transform:Matrix3D):void

Parameters

transform:Matrix3D

clone () method
public function clone():ISubGeometry

Returns
ISubGeometry
cloneWithSeperateBuffers () method
public function cloneWithSeperateBuffers():SubGeometry

Returns
SubGeometry
createBuffer () method
protected function createBuffer(contextIndex:int, context:Context3D):void

Parameters

contextIndex:int
context:Context3D

dispose () method
override public function dispose():void

disposeVertexBuffers () method
override protected function disposeVertexBuffers(buffers:Vector.<VertexBuffer3D>):void

Parameters

buffers:Vector.<VertexBuffer3D>

fromVectors () method
public function fromVectors(verts:Vector.<Number>, uvs:Vector.<Number>, normals:Vector.<Number>, tangents:Vector.<Number>):void

Parameters

verts:Vector.<Number>
uvs:Vector.<Number>
normals:Vector.<Number>
tangents:Vector.<Number>

invalidateBuffers () method
override protected function invalidateBuffers(invalid:Vector.<Boolean>):void

Parameters

invalid:Vector.<Boolean>

scale () method
override public function scale(scale:Number):void

Parameters

scale:Number

scaleUV () method
override public function scaleUV(scaleU:Number = 1, scaleV:Number = 1):void

Parameters

scaleU:Number (default = 1)
scaleV:Number (default = 1)

stripBuffer () method
protected function stripBuffer(offset:int, numEntries:int):Vector.<Number>

Parameters

offset:int
numEntries:int

Returns
Vector.<Number>
updateActiveBuffer () method
protected function updateActiveBuffer(contextIndex:int):void

Parameters

contextIndex:int

updateData () method
public function updateData(data:Vector.<Number>):void

Updates the vertex data. All vertex properties are contained in a single Vector, and the order is as follows: 0 - 2: vertex position X, Y, Z 3 - 5: normal X, Y, Z 6 - 8: tangent X, Y, Z 9 - 10: U V 11 - 12: Secondary U V

Parameters

data:Vector.<Number>

updateVertexNormals () method
override protected function updateVertexNormals(target:Vector.<Number>):Vector.<Number>

Parameters

target:Vector.<Number>

Returns
Vector.<Number>
updateVertexTangents () method
override protected function updateVertexTangents(target:Vector.<Number>):Vector.<Number>

Parameters

target:Vector.<Number>

Returns
Vector.<Number>
uploadData () method
protected function uploadData(contextIndex:int):void

Parameters

contextIndex:int


away3d.core.base.Geometry

Geometry | Properties | Methods | Constants
Package | away3d.core.base
Class | public class Geometry
Inheritance | Geometry Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IAsset
Subclasses | ParticleGeometry, PrimitiveBase

Geometry is a collection of SubGeometries, each of which contain the actual geometrical data such as vertices, normals, uvs, etc. It also contains a reference to an animation class, which defines how the geometry moves. A Geometry object is assigned to a Mesh, a scene graph occurence of the geometry, which in turn assigns the SubGeometries to its respective SubMesh objects.

See also

away3d.core.base.SubGeometry
away3d.scenegraph.Mesh

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
 | assetType : String [read-only] | Geometry
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | subGeometries : Vector.<ISubGeometry> [read-only] A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc. | Geometry
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Geometry() Creates a new Geometry object. | Geometry
 | addSubGeometry(subGeometry:ISubGeometry):void Adds a new SubGeometry object to the list. | Geometry
 | applyTransformation(transform:Matrix3D):void | Geometry
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | clone():Geometry Clones the geometry. | Geometry
 | convertToSeparateBuffers():void Updates the SubGeometries so all vertex data is represented in different buffers. | Geometry
 | dispose():void Clears all resources used by the Geometry object, including SubGeometries. | Geometry
 | removeSubGeometry(subGeometry:ISubGeometry):void Removes a new SubGeometry object from the list. | Geometry
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
 | scale(scale:Number):void Scales the geometry. | Geometry
 | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void Scales the uv coordinates (tiling) | Geometry
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
assetType property
assetType:String [read-only]

Implementation
    public function get assetType():String
subGeometries property
subGeometries:Vector.<ISubGeometry> [read-only]

A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc.

Implementation
    public function get subGeometries():Vector.<ISubGeometry>
Constructor Detail
Geometry () Constructor
public function Geometry()

Creates a new Geometry object.

Method Detail
addSubGeometry () method
public function addSubGeometry(subGeometry:ISubGeometry):void

Adds a new SubGeometry object to the list.

Parameters

subGeometry:ISubGeometry — The SubGeometry object to be added.

applyTransformation () method
public function applyTransformation(transform:Matrix3D):void

Parameters

transform:Matrix3D

clone () method
public function clone():Geometry

Clones the geometry.

Returns
Geometry — An exact duplicate of the current Geometry object.
convertToSeparateBuffers () method
public function convertToSeparateBuffers():void

Updates the SubGeometries so all vertex data is represented in different buffers. Use this for compatibility with Pixel Bender and PBPickingCollider

dispose () method
public function dispose():void

Clears all resources used by the Geometry object, including SubGeometries.

invalidateBounds () method
arcane function invalidateBounds(subGeom:ISubGeometry):void

Parameters

subGeom:ISubGeometry

removeSubGeometry () method
public function removeSubGeometry(subGeometry:ISubGeometry):void

Removes a new SubGeometry object from the list.

Parameters

subGeometry:ISubGeometry — The SubGeometry object to be removed.

scale () method
public function scale(scale:Number):void

Scales the geometry.

Parameters

scale:Number — The amount by which to scale.

scaleUV () method
public function scaleUV(scaleU:Number = 1, scaleV:Number = 1):void

Scales the uv coordinates (tiling)

Parameters

scaleU:Number (default = 1) — The amount by which to scale on the u axis. Default is 1;
scaleV:Number (default = 1) — The amount by which to scale on the v axis. Default is 1;

validate () method
arcane function validate():void


away3d.core.base.IMaterialOwner

IMaterialOwner | Properties
Package | away3d.core.base
Interface | public interface IMaterialOwner
Implementors | Mesh

IMaterialOwner provides an interface for objects that can use materials.

Public Properties
Property |  | Defined By
 | animator : IAnimator [read-only] The animation used by the material to assemble the vertex code. | IMaterialOwner
 | material : MaterialBase The material with which to render the object. | IMaterialOwner
Property Detail
animator property
animator:IAnimator [read-only]

The animation used by the material to assemble the vertex code.

Implementation
    public function get animator():IAnimator
material property
material:MaterialBase

The material with which to render the object.

Implementation
    public function get material():MaterialBase
    public function set material(value:MaterialBase):void


away3d.core.base.IRenderable

IRenderable | Properties | Methods
Package | away3d.core.base
Interface | public interface IRenderable extends IMaterialOwner
Implementors | SegmentSet, SkyBox, Sprite3D, SubMesh

IRenderable provides an interface for objects that can be rendered in the rendering pipeline.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator [read-only] The animation used by the material to assemble the vertex code. | IMaterialOwner
 | castsShadows : Boolean [read-only] Indicates whether the renderable can cast shadows | IRenderable
 | indexData : Vector.<uint> [read-only] Retrieves the object's indices as a uint array. | IRenderable
 | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | IRenderable
Inherited | material : MaterialBase The material with which to render the object. | IMaterialOwner
 | modelViewProjection : Matrix3D [read-only] The model-view-projection (MVP) matrix used to transform from model to homogeneous projection space. | IRenderable
 | mouseEnabled : Boolean [read-only] Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | IRenderable
 | numTriangles : uint [read-only] The amount of triangles that comprise the IRenderable geometry. | IRenderable
 | numVertices : uint [read-only] The total amount of vertices in the SubGeometry. | IRenderable
 | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | IRenderable
 | shaderPickingDetails : Boolean [read-only] | IRenderable
 | sourceEntity : Entity [read-only] The entity that that initially provided the IRenderable to the render pipeline. | IRenderable
 | UVData : Vector.<Number> [read-only] Retrieves the object's uvs as a Number array. | IRenderable
 | uvTransform : Matrix [read-only] | IRenderable
 | vertexData : Vector.<Number> [read-only] Retrieves the object's vertices as a Number array. | IRenderable
 | vertexNormalData : Vector.<Number> [read-only] Retrieves the object's normals as a Number array. | IRenderable
 | vertexStride : uint [read-only] The number of data elements in the buffers per vertex. | IRenderable
 | vertexTangentData : Vector.<Number> [read-only] Retrieves the object's tangents as a Number array. | IRenderable
 | zIndex : Number [read-only] The distance of the IRenderable object to the view, used to sort per object. | IRenderable
Public Methods
Method |  | Defined By
 | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for a secondary set of UV coordinates | IRenderable
 | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for UV coordinates | IRenderable
 | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for vertex positions. | IRenderable
 | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for vertex normals | IRenderable
 | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for vertex tangents | IRenderable
 | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D Retrieves the IndexBuffer3D object that contains triangle indices. | IRenderable
Property Detail
castsShadows property
castsShadows:Boolean [read-only]

Indicates whether the renderable can cast shadows

Implementation
    public function get castsShadows():Boolean
indexData property
indexData:Vector.<uint> [read-only]

Retrieves the object's indices as a uint array.

Implementation
    public function get indexData():Vector.<uint>
inverseSceneTransform property
inverseSceneTransform:Matrix3D [read-only]

The inverse scene transform object that transforms from world to model space.

Implementation
    public function get inverseSceneTransform():Matrix3D
modelViewProjection property
modelViewProjection:Matrix3D [read-only]

The model-view-projection (MVP) matrix used to transform from model to homogeneous projection space.

Implementation
    public function get modelViewProjection():Matrix3D
mouseEnabled property
mouseEnabled:Boolean [read-only]

Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing.

Implementation
    public function get mouseEnabled():Boolean
numTriangles property
numTriangles:uint [read-only]

The amount of triangles that comprise the IRenderable geometry.

Implementation
    public function get numTriangles():uint
numVertices property
numVertices:uint [read-only]

The total amount of vertices in the SubGeometry.

Implementation
    public function get numVertices():uint
sceneTransform property
sceneTransform:Matrix3D [read-only]

The transformation matrix that transforms from model to world space.

Implementation
    public function get sceneTransform():Matrix3D
shaderPickingDetails property
shaderPickingDetails:Boolean [read-only]

Implementation
    public function get shaderPickingDetails():Boolean
sourceEntity property
sourceEntity:Entity [read-only]

The entity that that initially provided the IRenderable to the render pipeline.

Implementation
    public function get sourceEntity():Entity
UVData property
UVData:Vector.<Number> [read-only]

Retrieves the object's uvs as a Number array.

Implementation
    public function get UVData():Vector.<Number>
uvTransform property
uvTransform:Matrix [read-only]

Implementation
    public function get uvTransform():Matrix
vertexData property
vertexData:Vector.<Number> [read-only]

Retrieves the object's vertices as a Number array.

Implementation
    public function get vertexData():Vector.<Number>
vertexNormalData property
vertexNormalData:Vector.<Number> [read-only]

Retrieves the object's normals as a Number array.

Implementation
    public function get vertexNormalData():Vector.<Number>
vertexStride property
vertexStride:uint [read-only]

The number of data elements in the buffers per vertex. This always applies to vertices, normals and tangents.

Implementation
    public function get vertexStride():uint
vertexTangentData property
vertexTangentData:Vector.<Number> [read-only]

Retrieves the object's tangents as a Number array.

Implementation
    public function get vertexTangentData():Vector.<Number>
zIndex property
zIndex:Number [read-only]

The distance of the IRenderable object to the view, used to sort per object.

Implementation
    public function get zIndex():Number
Method Detail
activateSecondaryUVBuffer () method
public function activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for a secondary set of UV coordinates

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateUVBuffer () method
public function activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for UV coordinates

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexBuffer () method
public function activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for vertex positions.

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexNormalBuffer () method
public function activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for vertex normals

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexTangentBuffer () method
public function activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for vertex tangents

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

getIndexBuffer () method
public function getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D

Retrieves the IndexBuffer3D object that contains triangle indices.

Parameters

stage3DProxy:Stage3DProxy — The Context3D for which we request the buffer

Returns
IndexBuffer3D — The VertexBuffer3D object that contains triangle indices.


away3d.core.base.ISubGeometry

ISubGeometry | Properties | Methods
Package | away3d.core.base
Interface | public interface ISubGeometry
Implementors | CompactSubGeometry, SubGeometry

Public Properties
Property |  | Defined By
 | autoDeriveVertexNormals : Boolean | ISubGeometry
 | autoDeriveVertexTangents : Boolean | ISubGeometry
 | faceNormals : Vector.<Number> [read-only] | ISubGeometry
 | indexData : Vector.<uint> [read-only] Retrieves the object's indices as a uint array. | ISubGeometry
 | numTriangles : uint [read-only] The amount of triangles that comprise the IRenderable geometry. | ISubGeometry
 | numVertices : uint [read-only] The total amount of vertices in the SubGeometry. | ISubGeometry
 | parentGeometry : Geometry | ISubGeometry
 | scaleU : Number [read-only] | ISubGeometry
 | scaleV : Number [read-only] | ISubGeometry
 | secondaryUVOffset : int [read-only] The offset into SecondaryUVData vector where the UVs are placed | ISubGeometry
 | secondaryUVStride : uint [read-only] The distance between two secondary UV elements | ISubGeometry
 | UVData : Vector.<Number> [read-only] Retrieves the object's uvs as a Number array. | ISubGeometry
 | UVOffset : int [read-only] The offset into UVData vector where the UVs are placed | ISubGeometry
 | UVStride : uint [read-only] The distance between two consecutive UV elements | ISubGeometry
 | vertexData : Vector.<Number> [read-only] Retrieves the object's vertices as a Number array. | ISubGeometry
 | vertexNormalData : Vector.<Number> [read-only] Retrieves the object's normals as a Number array. | ISubGeometry
 | vertexNormalOffset : int [read-only] The offset into vertexNormalData where the normals are placed | ISubGeometry
 | vertexNormalStride : uint [read-only] The distance between two consecutive normal elements This always applies to vertices, normals and tangents. | ISubGeometry
 | vertexOffset : int [read-only] The offset into vertexData where the vertices are placed | ISubGeometry
 | vertexStride : uint [read-only] The distance between two consecutive vertex, normal or tangent elements This always applies to vertices, normals and tangents. | ISubGeometry
 | vertexTangentData : Vector.<Number> [read-only] Retrieves the object's tangents as a Number array. | ISubGeometry
 | vertexTangentOffset : int [read-only] The offset into vertexTangentData where the tangents are placed | ISubGeometry
 | vertexTangentStride : uint [read-only] The distance between two consecutive tangent elements This always applies to vertices, normals and tangents. | ISubGeometry
Public Methods
Method |  | Defined By
 | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for a secondary set of UV coordinates | ISubGeometry
 | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for UV coordinates | ISubGeometry
 | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for vertex positions. | ISubGeometry
 | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for vertex normals | ISubGeometry
 | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for vertex tangents | ISubGeometry
 | applyTransformation(transform:Matrix3D):void | ISubGeometry
 | clone():ISubGeometry | ISubGeometry
 | cloneWithSeperateBuffers():SubGeometry | ISubGeometry
 | dispose():void | ISubGeometry
 | fromVectors(vertices:Vector.<Number>, uvs:Vector.<Number>, normals:Vector.<Number>, tangents:Vector.<Number>):void | ISubGeometry
 | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D Retrieves the IndexBuffer3D object that contains triangle indices. | ISubGeometry
 | scale(scale:Number):void | ISubGeometry
 | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void | ISubGeometry
Property Detail
autoDeriveVertexNormals property
autoDeriveVertexNormals:Boolean

Implementation
    public function get autoDeriveVertexNormals():Boolean
    public function set autoDeriveVertexNormals(value:Boolean):void
autoDeriveVertexTangents property
autoDeriveVertexTangents:Boolean

Implementation
    public function get autoDeriveVertexTangents():Boolean
    public function set autoDeriveVertexTangents(value:Boolean):void
faceNormals property
faceNormals:Vector.<Number> [read-only]

Implementation
    public function get faceNormals():Vector.<Number>
indexData property
indexData:Vector.<uint> [read-only]

Retrieves the object's indices as a uint array.

Implementation
    public function get indexData():Vector.<uint>
numTriangles property
numTriangles:uint [read-only]

The amount of triangles that comprise the IRenderable geometry.

Implementation
    public function get numTriangles():uint
numVertices property
numVertices:uint [read-only]

The total amount of vertices in the SubGeometry.

Implementation
    public function get numVertices():uint
parentGeometry property
parentGeometry:Geometry

Implementation
    public function get parentGeometry():Geometry
    public function set parentGeometry(value:Geometry):void
scaleU property
scaleU:Number [read-only]

Implementation
    public function get scaleU():Number
scaleV property
scaleV:Number [read-only]

Implementation
    public function get scaleV():Number
secondaryUVOffset property
secondaryUVOffset:int [read-only]

The offset into SecondaryUVData vector where the UVs are placed

Implementation
    public function get secondaryUVOffset():int
secondaryUVStride property
secondaryUVStride:uint [read-only]

The distance between two secondary UV elements

Implementation
    public function get secondaryUVStride():uint
UVData property
UVData:Vector.<Number> [read-only]

Retrieves the object's uvs as a Number array.

Implementation
    public function get UVData():Vector.<Number>
UVOffset property
UVOffset:int [read-only]

The offset into UVData vector where the UVs are placed

Implementation
    public function get UVOffset():int
UVStride property
UVStride:uint [read-only]

The distance between two consecutive UV elements

Implementation
    public function get UVStride():uint
vertexData property
vertexData:Vector.<Number> [read-only]

Retrieves the object's vertices as a Number array.

Implementation
    public function get vertexData():Vector.<Number>
vertexNormalData property
vertexNormalData:Vector.<Number> [read-only]

Retrieves the object's normals as a Number array.

Implementation
    public function get vertexNormalData():Vector.<Number>
vertexNormalOffset property
vertexNormalOffset:int [read-only]

The offset into vertexNormalData where the normals are placed

Implementation
    public function get vertexNormalOffset():int
vertexNormalStride property
vertexNormalStride:uint [read-only]

The distance between two consecutive normal elements This always applies to vertices, normals and tangents.

Implementation
    public function get vertexNormalStride():uint
vertexOffset property
vertexOffset:int [read-only]

The offset into vertexData where the vertices are placed

Implementation
    public function get vertexOffset():int
vertexStride property
vertexStride:uint [read-only]

The distance between two consecutive vertex, normal or tangent elements This always applies to vertices, normals and tangents.

Implementation
    public function get vertexStride():uint
vertexTangentData property
vertexTangentData:Vector.<Number> [read-only]

Retrieves the object's tangents as a Number array.

Implementation
    public function get vertexTangentData():Vector.<Number>
vertexTangentOffset property
vertexTangentOffset:int [read-only]

The offset into vertexTangentData where the tangents are placed

Implementation
    public function get vertexTangentOffset():int
vertexTangentStride property
vertexTangentStride:uint [read-only]

The distance between two consecutive tangent elements This always applies to vertices, normals and tangents.

Implementation
    public function get vertexTangentStride():uint
Method Detail
activateSecondaryUVBuffer () method
public function activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for a secondary set of UV coordinates

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateUVBuffer () method
public function activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for UV coordinates

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexBuffer () method
public function activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for vertex positions.

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexNormalBuffer () method
public function activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for vertex normals

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexTangentBuffer () method
public function activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for vertex tangents

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

applyTransformation () method
public function applyTransformation(transform:Matrix3D):void

Parameters

transform:Matrix3D

clone () method
public function clone():ISubGeometry

Returns
ISubGeometry
cloneWithSeperateBuffers () method
public function cloneWithSeperateBuffers():SubGeometry

Returns
SubGeometry
dispose () method
public function dispose():void

fromVectors () method
public function fromVectors(vertices:Vector.<Number>, uvs:Vector.<Number>, normals:Vector.<Number>, tangents:Vector.<Number>):void

Parameters

vertices:Vector.<Number>
uvs:Vector.<Number>
normals:Vector.<Number>
tangents:Vector.<Number>

getIndexBuffer () method
public function getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D

Retrieves the IndexBuffer3D object that contains triangle indices.

Parameters

stage3DProxy:Stage3DProxy — The Context3D for which we request the buffer

Returns
IndexBuffer3D — The VertexBuffer3D object that contains triangle indices.
scale () method
public function scale(scale:Number):void

Parameters

scale:Number

scaleUV () method
public function scaleUV(scaleU:Number = 1, scaleV:Number = 1):void

Parameters

scaleU:Number (default = 1)
scaleV:Number (default = 1)


away3d.core.base.Object3D

Object3D | Properties | Methods | Events | Constants
Package | away3d.core.base
Class | public class Object3D
Inheritance | Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | ObjectContainer3D

Object3D provides a base class for any 3D object that has a (local) transformation. Standard Transform:
  • The standard order for transformation is [parent transform] (Translate+Pivot) (Rotate) (-Pivot) (Scale) [child transform]
  • This is the order of matrix multiplications, left-to-right.
  • The order of transformation is right-to-left, however! (Scale) happens before (-Pivot) happens before (Rotate) happens before (Translate+Pivot) with no pivot, the above transform works out to [parent transform] Translate Rotate Scale [child transform] (Scale) happens before (Rotate) happens before (Translate)
  • This is based on code in updateTransform and ObjectContainer3D.updateSceneTransform().
  • Matrix3D prepend = operator on rhs - e.g. transform' = transform rhs;
  • Matrix3D append = operator on lhr - e.g. transform' = lhs transform;
To affect Scale:
  • set scaleX/Y/Z directly, or call scale(delta)
To affect Pivot:
  • set pivotPoint directly, or call movePivot()
To affect Rotate:
  • set rotationX/Y/Z individually (using degrees), set eulers [all 3 angles] (using radians), or call rotateTo()
  • call pitch()/yaw()/roll()/rotate() to add an additional rotation eforethe current transform. rotationX/Y/Z will be reset based on these operations.
To affect Translate (post-rotate translate):
  • set x/y/z/position or call moveTo().
  • call translate(), which modifies x/y/z based on a delta vector.
  • call moveForward()/moveBackward()/moveLeft()/moveRight()/moveUp()/moveDown()/translateLocal() to add an additional translate eforethe current transform. x/y/z will be reset based on these operations.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
 | backVector : Vector3D [read-only] | Object3D
 | downVector : Vector3D [read-only] | Object3D
 | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
 | extra : Object An object that can contain any extra data. | Object3D
 | forwardVector : Vector3D [read-only] | Object3D
 | leftVector : Vector3D [read-only] | Object3D
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
 | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | rightVector : Vector3D [read-only] | Object3D
 | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
 | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
 | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
 | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | upVector : Vector3D [read-only] | Object3D
 | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Property |  | Defined By
 | _pivotPoint : Vector3D | Object3D
 | _pivotZero : Boolean = true | Object3D
 | _pos : Vector3D | Object3D
 | _rot : Vector3D | Object3D
 | _sca : Vector3D | Object3D
 | _scaleX : Number = 1 | Object3D
 | _scaleY : Number = 1 | Object3D
 | _scaleZ : Number = 1 | Object3D
 | _transform : Matrix3D | Object3D
 | _transformComponents : Vector.<Vector3D> | Object3D
 | _x : Number = 0 | Object3D
 | _y : Number = 0 | Object3D
 | _z : Number = 0 | Object3D
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Object3D() Creates an Object3D object. | Object3D
 | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | Object3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | clone():Object3D | Object3D
 | dispose():void Cleans up any resources used by the current object. | Object3D
 | disposeAsset():void | Object3D
 | lookAt(target:Vector3D, upAxis:Vector3D = null):void Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
 | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
 | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
 | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
 | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
 | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
 | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
 | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
 | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
 | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | Object3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
 | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
 | rotate(axis:Vector3D, angle:Number):void Rotates the 3d object around an axis by a defined angle | Object3D
 | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
 | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
 | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
 | translateLocal(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
 | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Method |  | Defined By
 | updateTransform():void | Object3D
Events
Event |  | Summary | Defined By
 | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
 | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
 | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_pivotPoint property
protected var _pivotPoint:Vector3D

_pivotZero property
protected var _pivotZero:Boolean = true

_pos property
protected var _pos:Vector3D

_rot property
protected var _rot:Vector3D

_sca property
protected var _sca:Vector3D

_scaleX property
protected var _scaleX:Number = 1

_scaleY property
protected var _scaleY:Number = 1

_scaleZ property
protected var _scaleZ:Number = 1

_transform property
protected var _transform:Matrix3D

_transformComponents property
protected var _transformComponents:Vector.<Vector3D>

_x property
protected var _x:Number = 0

_y property
protected var _y:Number = 0

_z property
protected var _z:Number = 0

backVector property
backVector:Vector3D [read-only]

Implementation
    public function get backVector():Vector3D
downVector property
downVector:Vector3D [read-only]

Implementation
    public function get downVector():Vector3D
eulers property
eulers:Vector3D

Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis.

Implementation
    public function get eulers():Vector3D
    public function set eulers(value:Vector3D):void
extra property
public var extra:Object

An object that can contain any extra data.

forwardVector property
forwardVector:Vector3D [read-only]

Implementation
    public function get forwardVector():Vector3D
leftVector property
leftVector:Vector3D [read-only]

Implementation
    public function get leftVector():Vector3D
pivotPoint property
pivotPoint:Vector3D

Defines the local point around which the object rotates.

Implementation
    public function get pivotPoint():Vector3D
    public function set pivotPoint(value:Vector3D):void
position property
position:Vector3D

Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D.

Implementation
    public function get position():Vector3D
    public function set position(value:Vector3D):void
rightVector property
rightVector:Vector3D [read-only]

Implementation
    public function get rightVector():Vector3D
rotationX property
rotationX:Number

Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D.

Implementation
    public function get rotationX():Number
    public function set rotationX(value:Number):void
rotationY property
rotationY:Number

Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D.

Implementation
    public function get rotationY():Number
    public function set rotationY(value:Number):void
rotationZ property
rotationZ:Number

Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D.

Implementation
    public function get rotationZ():Number
    public function set rotationZ(value:Number):void
scaleX property
scaleX:Number

Defines the scale of the 3d object along the x-axis, relative to local coordinates.

Implementation
    public function get scaleX():Number
    public function set scaleX(value:Number):void
scaleY property
scaleY:Number

Defines the scale of the 3d object along the y-axis, relative to local coordinates.

Implementation
    public function get scaleY():Number
    public function set scaleY(value:Number):void
scaleZ property
scaleZ:Number

Defines the scale of the 3d object along the z-axis, relative to local coordinates.

Implementation
    public function get scaleZ():Number
    public function set scaleZ(value:Number):void
transform property
transform:Matrix3D

The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D.

Implementation
    public function get transform():Matrix3D
    public function set transform(value:Matrix3D):void
upVector property
upVector:Vector3D [read-only]

Implementation
    public function get upVector():Vector3D
x property
x:Number

Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D.

Implementation
    public function get x():Number
    public function set x(value:Number):void
y property
y:Number

Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D.

Implementation
    public function get y():Number
    public function set y(value:Number):void
z property
z:Number

Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D.

Implementation
    public function get z():Number
    public function set z(value:Number):void
Constructor Detail
Object3D () Constructor
public function Object3D()

Creates an Object3D object.

Method Detail
addEventListener () method
override public function addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void

Parameters

type:String
listener:Function
useCapture:Boolean (default = false)
priority:int (default = 0)
useWeakReference:Boolean (default = false)

clone () method
public function clone():Object3D

Returns
Object3D
dispose () method
public function dispose():void

Cleans up any resources used by the current object.

disposeAsset () method
public function disposeAsset():void

invalidateTransform () method
arcane function invalidateTransform():void

Invalidates the transformation matrix, causing it to be updated upon the next request

lookAt () method
public function lookAt(target:Vector3D, upAxis:Vector3D = null):void

Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D.

Parameters

target:Vector3D — The vector defining the point to be looked at
upAxis:Vector3D (default = null) — An optional vector used to define the desired up orientation of the 3d object after rotation has occurred

moveBackward () method
public function moveBackward(distance:Number):void

Moves the 3d object backwards along it's local z axis

Parameters

distance:Number — The length of the movement

moveDown () method
public function moveDown(distance:Number):void

Moves the 3d object backwards along it's local y axis

Parameters

distance:Number — The length of the movement

moveForward () method
public function moveForward(distance:Number):void

Moves the 3d object forwards along it's local z axis

Parameters

distance:Number — The length of the movement

moveLeft () method
public function moveLeft(distance:Number):void

Moves the 3d object backwards along it's local x axis

Parameters

distance:Number — The length of the movement

movePivot () method
public function movePivot(dx:Number, dy:Number, dz:Number):void

Moves the local point around which the object rotates.

Parameters

dx:Number — The amount of movement along the local x axis.
dy:Number — The amount of movement along the local y axis.
dz:Number — The amount of movement along the local z axis.

moveRight () method
public function moveRight(distance:Number):void

Moves the 3d object forwards along it's local x axis

Parameters

distance:Number — The length of the movement

moveTo () method
public function moveTo(dx:Number, dy:Number, dz:Number):void

Moves the 3d object directly to a point in space

Parameters

dx:Number — The amount of movement along the local x axis.
dy:Number — The amount of movement along the local y axis.
dz:Number — The amount of movement along the local z axis.

moveUp () method
public function moveUp(distance:Number):void

Moves the 3d object forwards along it's local y axis

Parameters

distance:Number — The length of the movement

pitch () method
public function pitch(angle:Number):void

Rotates the 3d object around it's local x-axis

Parameters

angle:Number — The amount of rotation in degrees

removeEventListener () method
override public function removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void

Parameters

type:String
listener:Function
useCapture:Boolean (default = false)

roll () method
public function roll(angle:Number):void

Rotates the 3d object around it's local z-axis

Parameters

angle:Number — The amount of rotation in degrees

rotate () method
public function rotate(axis:Vector3D, angle:Number):void

Rotates the 3d object around an axis by a defined angle

Parameters

axis:Vector3D — The vector defining the axis of rotation
angle:Number — The amount of rotation in degrees

rotateTo () method
public function rotateTo(ax:Number, ay:Number, az:Number):void

Rotates the 3d object directly to a euler angle

Parameters

ax:Number — The angle in degrees of the rotation around the x axis.
ay:Number — The angle in degrees of the rotation around the y axis.
az:Number — The angle in degrees of the rotation around the z axis.

scale () method
public function scale(value:Number):void

Appends a uniform scale to the current transformation.

Parameters

value:Number — The amount by which to scale.

translate () method
public function translate(axis:Vector3D, distance:Number):void

Moves the 3d object along a vector by a defined length

Parameters

axis:Vector3D — The vector defining the axis of movement
distance:Number — The length of the movement

translateLocal () method
public function translateLocal(axis:Vector3D, distance:Number):void

Moves the 3d object along a vector by a defined length

Parameters

axis:Vector3D — The vector defining the axis of movement
distance:Number — The length of the movement

updateTransform () method
protected function updateTransform():void

yaw () method
public function yaw(angle:Number):void

Rotates the 3d object around it's local y-axis

Parameters

angle:Number — The amount of rotation in degrees

Event Detail
positionChanged Event
Event Object Type: away3d.events.Object3DEvent
Object3DEvent.type property = away3d.events.Object3DEvent

Dispatched when the position of the 3d object changes.

rotationChanged Event
Event Object Type: away3d.events.Object3DEvent
Object3DEvent.type property = away3d.events.Object3DEvent

Dispatched when the rotation of the 3d object changes.

scaleChanged Event
Event Object Type: away3d.events.Object3DEvent
Object3DEvent.type property = away3d.events.Object3DEvent

Dispatched when the scale of the 3d object changes.


away3d.core.base.ParticleGeometry

ParticleGeometry | Properties | Methods | Constants
Package | away3d.core.base
Class | public class ParticleGeometry
Inheritance | ParticleGeometry Inheritance Geometry Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | Geometry
Inherited | name : String | NamedAssetBase
 | numParticles : uint | ParticleGeometry
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | particles : Vector.<ParticleData> | ParticleGeometry
Inherited | subGeometries : Vector.<ISubGeometry> [read-only] A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc. | Geometry
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ParticleGeometry() | ParticleGeometry
Inherited | addSubGeometry(subGeometry:ISubGeometry):void Adds a new SubGeometry object to the list. | Geometry
Inherited | applyTransformation(transform:Matrix3D):void | Geometry
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Geometry Clones the geometry. | Geometry
Inherited | convertToSeparateBuffers():void Updates the SubGeometries so all vertex data is represented in different buffers. | Geometry
Inherited | dispose():void Clears all resources used by the Geometry object, including SubGeometries. | Geometry
Inherited | removeSubGeometry(subGeometry:ISubGeometry):void Removes a new SubGeometry object from the list. | Geometry
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | scale(scale:Number):void Scales the geometry. | Geometry
Inherited | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void Scales the uv coordinates (tiling) | Geometry
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
numParticles property
public var numParticles:uint

particles property
public var particles:Vector.<ParticleData>

Constructor Detail
ParticleGeometry () Constructor
public function ParticleGeometry()


away3d.core.base.SkinnedSubGeometry

SkinnedSubGeometry | Properties | Methods
Package | away3d.core.base
Class | public class SkinnedSubGeometry
Inheritance | SkinnedSubGeometry Inheritance CompactSubGeometry Inheritance SubGeometryBase Inheritance Object

SkinnedSubGeometry provides a SubGeometry extension that contains data needed to skin vertices. In particular, it provides joint indices and weights. Important! Joint indices need to be pre-multiplied by 3, since they index the matrix array (and each matrix has 3 float4 elements)

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | animatedData : Vector.<Number> [read-only] The animated vertex positions when set explicitly if the skinning transformations couldn't be performed on GPU. | SkinnedSubGeometry
Inherited | autoDeriveVertexNormals : Boolean True if the vertex normals should be derived from the geometry, false if the vertex normals are set explicitly. | SubGeometryBase
Inherited | autoDeriveVertexTangents : Boolean True if the vertex tangents should be derived from the geometry, false if the vertex normals are set explicitly. | SubGeometryBase
Inherited | autoGenerateDummyUVs : Boolean Defines whether a UV buffer should be automatically generated to contain dummy UV coordinates. | SubGeometryBase
 | condensedIndexLookUp : Vector.<uint> [read-only] If indices have been condensed, this will contain the original index for each condensed index. | SkinnedSubGeometry
 | numCondensedJoints : uint [read-only] The amount of joints used when joint indices have been condensed. | SkinnedSubGeometry
Inherited | numTriangles : uint [read-only] The total amount of triangles in the SubGeometry. | SubGeometryBase
Inherited | numVertices : uint [read-only] | CompactSubGeometry
Inherited | parentGeometry : Geometry | SubGeometryBase
Inherited | scaleU : Number [read-only] Scales the uv coordinates | SubGeometryBase
Inherited | scaleV : Number [read-only] | SubGeometryBase
Inherited | secondaryUVOffset : int [read-only] | CompactSubGeometry
Inherited | secondaryUVStride : uint [read-only] | CompactSubGeometry
Inherited | useFaceWeights : Boolean Indicates whether or not to take the size of faces into account when auto-deriving vertex normals and tangents. | SubGeometryBase
Inherited | UVData : Vector.<Number> [override] [read-only] | CompactSubGeometry
Inherited | UVOffset : int [override] [read-only] | CompactSubGeometry
Inherited | UVStride : uint [override] [read-only] | CompactSubGeometry
Inherited | vertexData : Vector.<Number> [override] [read-only] | CompactSubGeometry
Inherited | vertexNormalData : Vector.<Number> [override] [read-only] | CompactSubGeometry
Inherited | vertexNormalOffset : int [override] [read-only] | CompactSubGeometry
Inherited | vertexNormalStride : uint [override] [read-only] | CompactSubGeometry
Inherited | vertexOffset : int [override] [read-only] | CompactSubGeometry
Inherited | vertexStride : uint [override] [read-only] | CompactSubGeometry
Inherited | vertexTangentData : Vector.<Number> [override] [read-only] | CompactSubGeometry
Inherited | vertexTangentOffset : int [override] [read-only] | CompactSubGeometry
Inherited | vertexTangentStride : uint [override] [read-only] | CompactSubGeometry
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _activeBuffer : VertexBuffer3D | CompactSubGeometry
Inherited | _activeContext : Context3D | CompactSubGeometry
Inherited | _activeDataInvalid : Boolean | CompactSubGeometry
Inherited | _autoDeriveVertexNormals : Boolean = true | SubGeometryBase
Inherited | _autoDeriveVertexTangents : Boolean = true | SubGeometryBase
Inherited | _autoGenerateUVs : Boolean = false | SubGeometryBase
Inherited | _bufferContext : Vector.<Context3D> | CompactSubGeometry
Inherited | _contextIndex : int | CompactSubGeometry
Inherited | _faceNormals : Vector.<Number> | SubGeometryBase
Inherited | _faceNormalsDirty : Boolean = true | SubGeometryBase
Inherited | _faceTangents : Vector.<Number> | SubGeometryBase
Inherited | _faceTangentsDirty : Boolean = true | SubGeometryBase
Inherited | _faceWeights : Vector.<Number> | SubGeometryBase
Inherited | _indexBuffer : Vector.<IndexBuffer3D> | SubGeometryBase
Inherited | _indexBufferContext : Vector.<Context3D> | SubGeometryBase
Inherited | _indices : Vector.<uint> | SubGeometryBase
Inherited | _indicesInvalid : Vector.<Boolean> | SubGeometryBase
Inherited | _numIndices : uint | SubGeometryBase
Inherited | _numTriangles : uint | SubGeometryBase
Inherited | _numVertices : uint | CompactSubGeometry
Inherited | _uvsDirty : Boolean = true | SubGeometryBase
Inherited | _vertexBuffer : Vector.<VertexBuffer3D> | CompactSubGeometry
Inherited | _vertexData : Vector.<Number> | SubGeometryBase
Inherited | _vertexDataInvalid : Vector.<Boolean> | CompactSubGeometry
Inherited | _vertexNormalsDirty : Boolean = true | SubGeometryBase
Inherited | _vertexTangentsDirty : Boolean = true | SubGeometryBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkinnedSubGeometry(jointsPerVertex:int) Creates a new SkinnedSubGeometry object. | SkinnedSubGeometry
 | activateJointIndexBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for joint indices | SkinnedSubGeometry
 | activateJointWeightsBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for joint weights | SkinnedSubGeometry
Inherited | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | CompactSubGeometry
Inherited | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | CompactSubGeometry
Inherited | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void | CompactSubGeometry
Inherited | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void | CompactSubGeometry
Inherited | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void | CompactSubGeometry
Inherited | applyTransformation(transform:Matrix3D):void [override] | CompactSubGeometry
 | clone():ISubGeometry [override] Clones the current object. | SkinnedSubGeometry
Inherited | cloneWithSeperateBuffers():SubGeometry | CompactSubGeometry
 | dispose():void [override] Cleans up any resources used by this object. | SkinnedSubGeometry
Inherited | fromVectors(verts:Vector.<Number>, uvs:Vector.<Number>, normals:Vector.<Number>, tangents:Vector.<Number>):void | CompactSubGeometry
Inherited | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D Retrieves the VertexBuffer3D object that contains triangle indices. | SubGeometryBase
Inherited | scale(scale:Number):void [override] | CompactSubGeometry
Inherited | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void [override] | CompactSubGeometry
 | updateAnimatedData(value:Vector.<Number>):void | SkinnedSubGeometry
Inherited | updateData(data:Vector.<Number>):void Updates the vertex data. | CompactSubGeometry
Inherited | updateIndexData(indices:Vector.<uint>):void Updates the face indices of the SubGeometry. | SubGeometryBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createBuffer(contextIndex:int, context:Context3D):void | CompactSubGeometry
Inherited | disposeIndexBuffers(buffers:Vector.<IndexBuffer3D>):void Disposes all buffers in a given vector. | SubGeometryBase
Inherited | disposeVertexBuffers(buffers:Vector.<VertexBuffer3D>):void [override] | CompactSubGeometry
Inherited | invalidateBounds():void | SubGeometryBase
Inherited | invalidateBuffers(invalid:Vector.<Boolean>):void [override] | CompactSubGeometry
Inherited | stripBuffer(offset:int, numEntries:int):Vector.<Number> | CompactSubGeometry
Inherited | updateActiveBuffer(contextIndex:int):void | CompactSubGeometry
Inherited | updateDummyUVs(target:Vector.<Number>):Vector.<Number> | SubGeometryBase
Inherited | updateFaceTangents():void Updates the tangents for each face. | SubGeometryBase
Inherited | updateVertexNormals(target:Vector.<Number>):Vector.<Number> [override] | CompactSubGeometry
Inherited | updateVertexTangents(target:Vector.<Number>):Vector.<Number> [override] | CompactSubGeometry
 | uploadData(contextIndex:int):void [override] | SkinnedSubGeometry
Property Detail
animatedData property
animatedData:Vector.<Number> [read-only]

The animated vertex positions when set explicitly if the skinning transformations couldn't be performed on GPU.

Implementation
    public function get animatedData():Vector.<Number>
condensedIndexLookUp property
condensedIndexLookUp:Vector.<uint> [read-only]

If indices have been condensed, this will contain the original index for each condensed index.

Implementation
    public function get condensedIndexLookUp():Vector.<uint>
jointIndexData property
jointIndexData:Vector.<Number> [read-only]

The raw joint index data.

Implementation
    arcane function get jointIndexData():Vector.<Number>
jointWeightsData property
jointWeightsData:Vector.<Number> [read-only]

The raw joint weights data.

Implementation
    arcane function get jointWeightsData():Vector.<Number>
numCondensedJoints property
numCondensedJoints:uint [read-only]

The amount of joints used when joint indices have been condensed.

Implementation
    public function get numCondensedJoints():uint
Constructor Detail
SkinnedSubGeometry () Constructor
public function SkinnedSubGeometry(jointsPerVertex:int)

Creates a new SkinnedSubGeometry object.

Parameters
jointsPerVertex:int — The amount of joints that can be assigned per vertex.
Method Detail
activateJointIndexBuffer () method
public function activateJointIndexBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for joint indices

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateJointWeightsBuffer () method
public function activateJointWeightsBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for joint weights

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

clone () method
override public function clone():ISubGeometry

Clones the current object.

Returns
ISubGeometry — An exact duplicate of the current object.
condenseIndexData () method
arcane function condenseIndexData():void

dispose () method
override public function dispose():void

Cleans up any resources used by this object.

updateAnimatedData () method
public function updateAnimatedData(value:Vector.<Number>):void

Parameters

value:Vector.<Number>

updateJointIndexData () method
arcane function updateJointIndexData(value:Vector.<Number>):void

Parameters

value:Vector.<Number>

updateJointWeightsData () method
arcane function updateJointWeightsData(value:Vector.<Number>):void

Parameters

value:Vector.<Number>

uploadData () method
override protected function uploadData(contextIndex:int):void

Parameters

contextIndex:int


away3d.core.base.SubGeometry

SubGeometry | Properties | Methods
Package | away3d.core.base
Class | public class SubGeometry
Inheritance | SubGeometry Inheritance SubGeometryBase Inheritance Object
Implements | ISubGeometry

The SubGeometry class is a collections of geometric data that describes a triangle mesh. It is owned by a Geometry instance, and wrapped by a SubMesh in the scene graph. Several SubGeometries are grouped so they can be rendered with different materials, but still represent a single object.

See also

away3d.core.base.Geometry
away3d.core.base.SubMesh

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | autoDeriveVertexNormals : Boolean True if the vertex normals should be derived from the geometry, false if the vertex normals are set explicitly. | SubGeometryBase
Inherited | autoDeriveVertexTangents : Boolean True if the vertex tangents should be derived from the geometry, false if the vertex normals are set explicitly. | SubGeometryBase
Inherited | autoGenerateDummyUVs : Boolean Defines whether a UV buffer should be automatically generated to contain dummy UV coordinates. | SubGeometryBase
Inherited | numTriangles : uint [read-only] The total amount of triangles in the SubGeometry. | SubGeometryBase
 | numVertices : uint [read-only] The total amount of vertices in the SubGeometry. | SubGeometry
Inherited | parentGeometry : Geometry | SubGeometryBase
Inherited | scaleU : Number [read-only] Scales the uv coordinates | SubGeometryBase
Inherited | scaleV : Number [read-only] | SubGeometryBase
 | secondaryUVData : Vector.<Number> [read-only] | SubGeometry
 | secondaryUVOffset : int [read-only] | SubGeometry
 | secondaryUVStride : uint [read-only] | SubGeometry
Inherited | useFaceWeights : Boolean Indicates whether or not to take the size of faces into account when auto-deriving vertex normals and tangents. | SubGeometryBase
 | UVData : Vector.<Number> [override] [read-only] The raw texture coordinate data. | SubGeometry
 | UVOffset : int [override] [read-only] | SubGeometry
 | UVStride : uint [override] [read-only] | SubGeometry
 | vertexData : Vector.<Number> [override] [read-only] The raw vertex position data. | SubGeometry
 | vertexNormalData : Vector.<Number> [override] [read-only] The raw vertex normal data. | SubGeometry
 | vertexNormalOffset : int [override] [read-only] | SubGeometry
 | vertexNormalStride : uint [override] [read-only] | SubGeometry
 | vertexOffset : int [override] [read-only] | SubGeometry
 | vertexStride : uint [override] [read-only] | SubGeometry
Inherited | vertexTangentData : Vector.<Number> [read-only] | SubGeometryBase
 | vertexTangentOffset : int [override] [read-only] | SubGeometry
 | vertexTangentStride : uint [override] [read-only] | SubGeometry
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _autoDeriveVertexNormals : Boolean = true | SubGeometryBase
Inherited | _autoDeriveVertexTangents : Boolean = true | SubGeometryBase
Inherited | _autoGenerateUVs : Boolean = false | SubGeometryBase
Inherited | _faceNormals : Vector.<Number> | SubGeometryBase
Inherited | _faceNormalsDirty : Boolean = true | SubGeometryBase
Inherited | _faceTangents : Vector.<Number> | SubGeometryBase
Inherited | _faceTangentsDirty : Boolean = true | SubGeometryBase
Inherited | _faceWeights : Vector.<Number> | SubGeometryBase
Inherited | _indexBuffer : Vector.<IndexBuffer3D> | SubGeometryBase
Inherited | _indexBufferContext : Vector.<Context3D> | SubGeometryBase
Inherited | _indices : Vector.<uint> | SubGeometryBase
Inherited | _indicesInvalid : Vector.<Boolean> | SubGeometryBase
 | _normalsInvalid : Vector.<Boolean> | SubGeometry
Inherited | _numIndices : uint | SubGeometryBase
Inherited | _numTriangles : uint | SubGeometryBase
 | _numVertices : uint | SubGeometry
 | _secondaryUvBuffer : Vector.<VertexBuffer3D> | SubGeometry
 | _secondaryUvBufferContext : Vector.<Context3D> | SubGeometry
 | _secondaryUvs : Vector.<Number> | SubGeometry
 | _secondaryUvsInvalid : Vector.<Boolean> | SubGeometry
 | _tangentsInvalid : Vector.<Boolean> | SubGeometry
 | _uvBuffer : Vector.<VertexBuffer3D> | SubGeometry
 | _uvBufferContext : Vector.<Context3D> | SubGeometry
 | _uvs : Vector.<Number> | SubGeometry
Inherited | _uvsDirty : Boolean = true | SubGeometryBase
 | _uvsInvalid : Vector.<Boolean> | SubGeometry
 | _vertexBuffer : Vector.<VertexBuffer3D> | SubGeometry
 | _vertexBufferContext : Vector.<Context3D> | SubGeometry
Inherited | _vertexData : Vector.<Number> | SubGeometryBase
 | _vertexNormalBuffer : Vector.<VertexBuffer3D> | SubGeometry
 | _vertexNormalBufferContext : Vector.<Context3D> | SubGeometry
 | _vertexNormals : Vector.<Number> | SubGeometry
Inherited | _vertexNormalsDirty : Boolean = true | SubGeometryBase
 | _vertexTangentBuffer : Vector.<VertexBuffer3D> | SubGeometry
 | _vertexTangentBufferContext : Vector.<Context3D> | SubGeometry
 | _vertexTangents : Vector.<Number> | SubGeometry
Inherited | _vertexTangentsDirty : Boolean = true | SubGeometryBase
 | _verticesInvalid : Vector.<Boolean> | SubGeometry
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SubGeometry() Creates a new SubGeometry object. | SubGeometry
 | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for a secondary set of UV coordinates | SubGeometry
 | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for UV coordinates | SubGeometry
 | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for vertex positions. | SubGeometry
 | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void Retrieves the VertexBuffer3D object that contains vertex normals. | SubGeometry
 | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void Retrieves the VertexBuffer3D object that contains vertex tangents. | SubGeometry
 | applyTransformation(transform:Matrix3D):void [override] | SubGeometry
 | clone():ISubGeometry Clones the current object | SubGeometry
 | cloneWithSeperateBuffers():SubGeometry | SubGeometry
 | dispose():void [override] Clears all resources used by the SubGeometry object. | SubGeometry
 | fromVectors(vertices:Vector.<Number>, uvs:Vector.<Number>, normals:Vector.<Number>, tangents:Vector.<Number>):void | SubGeometry
Inherited | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D Retrieves the VertexBuffer3D object that contains triangle indices. | SubGeometryBase
 | scale(scale:Number):void [override] | SubGeometry
 | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void [override] | SubGeometry
Inherited | updateIndexData(indices:Vector.<uint>):void Updates the face indices of the SubGeometry. | SubGeometryBase
 | updateSecondaryUVData(uvs:Vector.<Number>):void | SubGeometry
 | updateUVData(uvs:Vector.<Number>):void Updates the uv coordinates of the SubGeometry. | SubGeometry
 | updateVertexData(vertices:Vector.<Number>):void Updates the vertex data of the SubGeometry. | SubGeometry
 | updateVertexNormalData(vertexNormals:Vector.<Number>):void Updates the vertex normals of the SubGeometry. | SubGeometry
 | updateVertexTangentData(vertexTangents:Vector.<Number>):void Updates the vertex tangents of the SubGeometry. | SubGeometry
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | disposeAllVertexBuffers():void | SubGeometry
 | disposeForStage3D(stage3DProxy:Stage3DProxy):void | SubGeometry
Inherited | disposeIndexBuffers(buffers:Vector.<IndexBuffer3D>):void Disposes all buffers in a given vector. | SubGeometryBase
Inherited | disposeVertexBuffers(buffers:Vector.<VertexBuffer3D>):void Disposes all buffers in a given vector. | SubGeometryBase
Inherited | invalidateBounds():void | SubGeometryBase
Inherited | invalidateBuffers(invalid:Vector.<Boolean>):void Invalidates all buffers in a vector, causing them the update when they are first requested. | SubGeometryBase
 | updateDummyUVs(target:Vector.<Number>):Vector.<Number> [override] | SubGeometry
Inherited | updateFaceTangents():void Updates the tangents for each face. | SubGeometryBase
 | updateVertexNormals(target:Vector.<Number>):Vector.<Number> [override] | SubGeometry
 | updateVertexTangents(target:Vector.<Number>):Vector.<Number> [override] | SubGeometry
Property Detail
_normalsInvalid property
protected var _normalsInvalid:Vector.<Boolean>

_numVertices property
protected var _numVertices:uint

_secondaryUvBuffer property
protected var _secondaryUvBuffer:Vector.<VertexBuffer3D>

_secondaryUvBufferContext property
protected var _secondaryUvBufferContext:Vector.<Context3D>

_secondaryUvs property
protected var _secondaryUvs:Vector.<Number>

_secondaryUvsInvalid property
protected var _secondaryUvsInvalid:Vector.<Boolean>

_tangentsInvalid property
protected var _tangentsInvalid:Vector.<Boolean>

_uvBuffer property
protected var _uvBuffer:Vector.<VertexBuffer3D>

_uvBufferContext property
protected var _uvBufferContext:Vector.<Context3D>

_uvs property
protected var _uvs:Vector.<Number>

_uvsInvalid property
protected var _uvsInvalid:Vector.<Boolean>

_vertexBuffer property
protected var _vertexBuffer:Vector.<VertexBuffer3D>

_vertexBufferContext property
protected var _vertexBufferContext:Vector.<Context3D>

_vertexNormalBuffer property
protected var _vertexNormalBuffer:Vector.<VertexBuffer3D>

_vertexNormalBufferContext property
protected var _vertexNormalBufferContext:Vector.<Context3D>

_vertexNormals property
protected var _vertexNormals:Vector.<Number>

_vertexTangentBuffer property
protected var _vertexTangentBuffer:Vector.<VertexBuffer3D>

_vertexTangentBufferContext property
protected var _vertexTangentBufferContext:Vector.<Context3D>

_vertexTangents property
protected var _vertexTangents:Vector.<Number>

_verticesInvalid property
protected var _verticesInvalid:Vector.<Boolean>

numVertices property
numVertices:uint [read-only]

The total amount of vertices in the SubGeometry.

Implementation
    public function get numVertices():uint
secondaryUVData property
secondaryUVData:Vector.<Number> [read-only]

Implementation
    public function get secondaryUVData():Vector.<Number>
secondaryUVOffset property
secondaryUVOffset:int [read-only]

Implementation
    public function get secondaryUVOffset():int
secondaryUVStride property
secondaryUVStride:uint [read-only]

Implementation
    public function get secondaryUVStride():uint
UVData property
UVData:Vector.<Number> [read-only] [override]

The raw texture coordinate data.

Implementation
    public function get UVData():Vector.<Number>
UVOffset property
UVOffset:int [read-only] [override]

Implementation
    public function get UVOffset():int
UVStride property
UVStride:uint [read-only] [override]

Implementation
    public function get UVStride():uint
vertexData property
vertexData:Vector.<Number> [read-only] [override]

The raw vertex position data.

Implementation
    public function get vertexData():Vector.<Number>
vertexNormalData property
vertexNormalData:Vector.<Number> [read-only] [override]

The raw vertex normal data.

Implementation
    public function get vertexNormalData():Vector.<Number>
vertexNormalOffset property
vertexNormalOffset:int [read-only] [override]

Implementation
    public function get vertexNormalOffset():int
vertexNormalStride property
vertexNormalStride:uint [read-only] [override]

Implementation
    public function get vertexNormalStride():uint
vertexOffset property
vertexOffset:int [read-only] [override]

Implementation
    public function get vertexOffset():int
vertexStride property
vertexStride:uint [read-only] [override]

Implementation
    public function get vertexStride():uint
vertexTangentOffset property
vertexTangentOffset:int [read-only] [override]

Implementation
    public function get vertexTangentOffset():int
vertexTangentStride property
vertexTangentStride:uint [read-only] [override]

Implementation
    public function get vertexTangentStride():uint
Constructor Detail
SubGeometry () Constructor
public function SubGeometry()

Creates a new SubGeometry object.

Method Detail
activateSecondaryUVBuffer () method
public function activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for a secondary set of UV coordinates

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateUVBuffer () method
public function activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for UV coordinates

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexBuffer () method
public function activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for vertex positions.

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexNormalBuffer () method
public function activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void

Retrieves the VertexBuffer3D object that contains vertex normals.

Parameters

index:int — The Context3D for which we request the buffer
stage3DProxy:Stage3DProxy

activateVertexTangentBuffer () method
public function activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void

Retrieves the VertexBuffer3D object that contains vertex tangents.

Parameters

index:int — The Context3D for which we request the buffer
stage3DProxy:Stage3DProxy

applyTransformation () method
override public function applyTransformation(transform:Matrix3D):void

Parameters

transform:Matrix3D

clone () method
public function clone():ISubGeometry

Clones the current object

Returns
ISubGeometry — An exact duplicate of the current object.
cloneWithSeperateBuffers () method
public function cloneWithSeperateBuffers():SubGeometry

Returns
SubGeometry
dispose () method
override public function dispose():void

Clears all resources used by the SubGeometry object.

disposeAllVertexBuffers () method
protected function disposeAllVertexBuffers():void

disposeForStage3D () method
protected function disposeForStage3D(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

fromVectors () method
public function fromVectors(vertices:Vector.<Number>, uvs:Vector.<Number>, normals:Vector.<Number>, tangents:Vector.<Number>):void

Parameters

vertices:Vector.<Number>
uvs:Vector.<Number>
normals:Vector.<Number>
tangents:Vector.<Number>

scale () method
override public function scale(scale:Number):void

Parameters

scale:Number

scaleUV () method
override public function scaleUV(scaleU:Number = 1, scaleV:Number = 1):void

Parameters

scaleU:Number (default = 1)
scaleV:Number (default = 1)

updateDummyUVs () method
override protected function updateDummyUVs(target:Vector.<Number>):Vector.<Number>

Parameters

target:Vector.<Number>

Returns
Vector.<Number>
updateSecondaryUVData () method
public function updateSecondaryUVData(uvs:Vector.<Number>):void

Parameters

uvs:Vector.<Number>

updateUVData () method
public function updateUVData(uvs:Vector.<Number>):void

Updates the uv coordinates of the SubGeometry.

Parameters

uvs:Vector.<Number> — The uv coordinates to upload.

updateVertexData () method
public function updateVertexData(vertices:Vector.<Number>):void

Updates the vertex data of the SubGeometry.

Parameters

vertices:Vector.<Number> — The new vertex data to upload.

updateVertexNormalData () method
public function updateVertexNormalData(vertexNormals:Vector.<Number>):void

Updates the vertex normals of the SubGeometry. When updating the vertex normals like this, autoDeriveVertexNormals will be set to false and vertex normals will no longer be calculated automatically.

Parameters

vertexNormals:Vector.<Number> — The vertex normals to upload.

updateVertexNormals () method
override protected function updateVertexNormals(target:Vector.<Number>):Vector.<Number>

Parameters

target:Vector.<Number>

Returns
Vector.<Number>
updateVertexTangentData () method
public function updateVertexTangentData(vertexTangents:Vector.<Number>):void

Updates the vertex tangents of the SubGeometry. When updating the vertex tangents like this, autoDeriveVertexTangents will be set to false and vertex tangents will no longer be calculated automatically.

Parameters

vertexTangents:Vector.<Number> — The vertex tangents to upload.

updateVertexTangents () method
override protected function updateVertexTangents(target:Vector.<Number>):Vector.<Number>

Parameters

target:Vector.<Number>

Returns
Vector.<Number>


away3d.core.base.SubGeometryBase

SubGeometryBase | Properties | Methods
Package | away3d.core.base
Class | public class SubGeometryBase
Inheritance | SubGeometryBase Inheritance Object
Subclasses | CompactSubGeometry, SubGeometry

Public Properties
Property |  | Defined By
 | autoDeriveVertexNormals : Boolean True if the vertex normals should be derived from the geometry, false if the vertex normals are set explicitly. | SubGeometryBase
 | autoDeriveVertexTangents : Boolean True if the vertex tangents should be derived from the geometry, false if the vertex normals are set explicitly. | SubGeometryBase
 | autoGenerateDummyUVs : Boolean Defines whether a UV buffer should be automatically generated to contain dummy UV coordinates. | SubGeometryBase
 | numTriangles : uint [read-only] The total amount of triangles in the SubGeometry. | SubGeometryBase
 | parentGeometry : Geometry | SubGeometryBase
 | scaleU : Number [read-only] Scales the uv coordinates | SubGeometryBase
 | scaleV : Number [read-only] | SubGeometryBase
 | useFaceWeights : Boolean Indicates whether or not to take the size of faces into account when auto-deriving vertex normals and tangents. | SubGeometryBase
 | UVData : Vector.<Number> [read-only] | SubGeometryBase
 | UVOffset : int [read-only] | SubGeometryBase
 | UVStride : uint [read-only] | SubGeometryBase
 | vertexData : Vector.<Number> [read-only] | SubGeometryBase
 | vertexNormalData : Vector.<Number> [read-only] | SubGeometryBase
 | vertexNormalOffset : int [read-only] | SubGeometryBase
 | vertexNormalStride : uint [read-only] | SubGeometryBase
 | vertexOffset : int [read-only] | SubGeometryBase
 | vertexStride : uint [read-only] | SubGeometryBase
 | vertexTangentData : Vector.<Number> [read-only] | SubGeometryBase
 | vertexTangentOffset : int [read-only] | SubGeometryBase
 | vertexTangentStride : uint [read-only] | SubGeometryBase
Protected Properties
Property |  | Defined By
 | _autoDeriveVertexNormals : Boolean = true | SubGeometryBase
 | _autoDeriveVertexTangents : Boolean = true | SubGeometryBase
 | _autoGenerateUVs : Boolean = false | SubGeometryBase
 | _faceNormals : Vector.<Number> | SubGeometryBase
 | _faceNormalsDirty : Boolean = true | SubGeometryBase
 | _faceTangents : Vector.<Number> | SubGeometryBase
 | _faceTangentsDirty : Boolean = true | SubGeometryBase
 | _faceWeights : Vector.<Number> | SubGeometryBase
 | _indexBuffer : Vector.<IndexBuffer3D> | SubGeometryBase
 | _indexBufferContext : Vector.<Context3D> | SubGeometryBase
 | _indices : Vector.<uint> | SubGeometryBase
 | _indicesInvalid : Vector.<Boolean> | SubGeometryBase
 | _numIndices : uint | SubGeometryBase
 | _numTriangles : uint | SubGeometryBase
 | _uvsDirty : Boolean = true | SubGeometryBase
 | _vertexData : Vector.<Number> | SubGeometryBase
 | _vertexNormalsDirty : Boolean = true | SubGeometryBase
 | _vertexTangentsDirty : Boolean = true | SubGeometryBase
Public Methods
Method |  | Defined By
 | SubGeometryBase() | SubGeometryBase
 | applyTransformation(transform:Matrix3D):void | SubGeometryBase
 | dispose():void | SubGeometryBase
 | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D Retrieves the VertexBuffer3D object that contains triangle indices. | SubGeometryBase
 | scale(scale:Number):void Scales the geometry. | SubGeometryBase
 | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void | SubGeometryBase
 | updateIndexData(indices:Vector.<uint>):void Updates the face indices of the SubGeometry. | SubGeometryBase
Protected Methods
Method |  | Defined By
 | disposeIndexBuffers(buffers:Vector.<IndexBuffer3D>):void Disposes all buffers in a given vector. | SubGeometryBase
 | disposeVertexBuffers(buffers:Vector.<VertexBuffer3D>):void Disposes all buffers in a given vector. | SubGeometryBase
 | invalidateBounds():void | SubGeometryBase
 | invalidateBuffers(invalid:Vector.<Boolean>):void Invalidates all buffers in a vector, causing them the update when they are first requested. | SubGeometryBase
 | updateDummyUVs(target:Vector.<Number>):Vector.<Number> | SubGeometryBase
 | updateFaceTangents():void Updates the tangents for each face. | SubGeometryBase
 | updateVertexNormals(target:Vector.<Number>):Vector.<Number> Updates the vertex normals based on the geometry. | SubGeometryBase
 | updateVertexTangents(target:Vector.<Number>):Vector.<Number> Updates the vertex tangents based on the geometry. | SubGeometryBase
Property Detail
_autoDeriveVertexNormals property
protected var _autoDeriveVertexNormals:Boolean = true

_autoDeriveVertexTangents property
protected var _autoDeriveVertexTangents:Boolean = true

_autoGenerateUVs property
protected var _autoGenerateUVs:Boolean = false

_faceNormals property
protected var _faceNormals:Vector.<Number>

_faceNormalsDirty property
protected var _faceNormalsDirty:Boolean = true

_faceTangents property
protected var _faceTangents:Vector.<Number>

_faceTangentsDirty property
protected var _faceTangentsDirty:Boolean = true

_faceWeights property
protected var _faceWeights:Vector.<Number>

_indexBuffer property
protected var _indexBuffer:Vector.<IndexBuffer3D>

_indexBufferContext property
protected var _indexBufferContext:Vector.<Context3D>

_indices property
protected var _indices:Vector.<uint>

_indicesInvalid property
protected var _indicesInvalid:Vector.<Boolean>

_numIndices property
protected var _numIndices:uint

_numTriangles property
protected var _numTriangles:uint

_uvsDirty property
protected var _uvsDirty:Boolean = true

_vertexData property
protected var _vertexData:Vector.<Number>

_vertexNormalsDirty property
protected var _vertexNormalsDirty:Boolean = true

_vertexTangentsDirty property
protected var _vertexTangentsDirty:Boolean = true

autoDeriveVertexNormals property
autoDeriveVertexNormals:Boolean

True if the vertex normals should be derived from the geometry, false if the vertex normals are set explicitly.

Implementation
    public function get autoDeriveVertexNormals():Boolean
    public function set autoDeriveVertexNormals(value:Boolean):void
autoDeriveVertexTangents property
autoDeriveVertexTangents:Boolean

True if the vertex tangents should be derived from the geometry, false if the vertex normals are set explicitly.

Implementation
    public function get autoDeriveVertexTangents():Boolean
    public function set autoDeriveVertexTangents(value:Boolean):void
autoGenerateDummyUVs property
autoGenerateDummyUVs:Boolean

Defines whether a UV buffer should be automatically generated to contain dummy UV coordinates. Set to true if a geometry lacks UV data but uses a material that requires it, or leave as false in cases where UV data is explicitly defined or the material does not require UV data.

Implementation
    public function get autoGenerateDummyUVs():Boolean
    public function set autoGenerateDummyUVs(value:Boolean):void
numTriangles property
numTriangles:uint [read-only]

The total amount of triangles in the SubGeometry.

Implementation
    public function get numTriangles():uint
parentGeometry property
parentGeometry:Geometry

Implementation
    public function get parentGeometry():Geometry
    public function set parentGeometry(value:Geometry):void
scaleU property
scaleU:Number [read-only]

Scales the uv coordinates

Implementation
    public function get scaleU():Number
scaleV property
scaleV:Number [read-only]

Implementation
    public function get scaleV():Number
useFaceWeights property
useFaceWeights:Boolean

Indicates whether or not to take the size of faces into account when auto-deriving vertex normals and tangents.

Implementation
    public function get useFaceWeights():Boolean
    public function set useFaceWeights(value:Boolean):void
UVData property
UVData:Vector.<Number> [read-only]

Implementation
    public function get UVData():Vector.<Number>
UVOffset property
UVOffset:int [read-only]

Implementation
    public function get UVOffset():int
UVStride property
UVStride:uint [read-only]

Implementation
    public function get UVStride():uint
vertexData property
vertexData:Vector.<Number> [read-only]

Implementation
    public function get vertexData():Vector.<Number>
vertexNormalData property
vertexNormalData:Vector.<Number> [read-only]

Implementation
    public function get vertexNormalData():Vector.<Number>
vertexNormalOffset property
vertexNormalOffset:int [read-only]

Implementation
    public function get vertexNormalOffset():int
vertexNormalStride property
vertexNormalStride:uint [read-only]

Implementation
    public function get vertexNormalStride():uint
vertexOffset property
vertexOffset:int [read-only]

Implementation
    public function get vertexOffset():int
vertexStride property
vertexStride:uint [read-only]

Implementation
    public function get vertexStride():uint
vertexTangentData property
vertexTangentData:Vector.<Number> [read-only]

Implementation
    public function get vertexTangentData():Vector.<Number>
vertexTangentOffset property
vertexTangentOffset:int [read-only]

Implementation
    public function get vertexTangentOffset():int
vertexTangentStride property
vertexTangentStride:uint [read-only]

Implementation
    public function get vertexTangentStride():uint
Constructor Detail
SubGeometryBase () Constructor
public function SubGeometryBase()

Method Detail
applyTransformation () method
public function applyTransformation(transform:Matrix3D):void

Parameters

transform:Matrix3D

dispose () method
public function dispose():void

disposeIndexBuffers () method
protected function disposeIndexBuffers(buffers:Vector.<IndexBuffer3D>):void

Disposes all buffers in a given vector.

Parameters

buffers:Vector.<IndexBuffer3D> — The vector of buffers to dispose.

disposeVertexBuffers () method
protected function disposeVertexBuffers(buffers:Vector.<VertexBuffer3D>):void

Disposes all buffers in a given vector.

Parameters

buffers:Vector.<VertexBuffer3D> — The vector of buffers to dispose.

getIndexBuffer () method
public function getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D

Retrieves the VertexBuffer3D object that contains triangle indices.

Parameters

stage3DProxy:Stage3DProxy — The Context3D for which we request the buffer

Returns
IndexBuffer3D — The VertexBuffer3D object that contains triangle indices.
invalidateBounds () method
protected function invalidateBounds():void

invalidateBuffers () method
protected function invalidateBuffers(invalid:Vector.<Boolean>):void

Invalidates all buffers in a vector, causing them the update when they are first requested.

Parameters

invalid:Vector.<Boolean> — The vector of buffers to invalidate.

scale () method
public function scale(scale:Number):void

Scales the geometry.

Parameters

scale:Number — The amount by which to scale.

scaleUV () method
public function scaleUV(scaleU:Number = 1, scaleV:Number = 1):void

Parameters

scaleU:Number (default = 1)
scaleV:Number (default = 1)

updateDummyUVs () method
protected function updateDummyUVs(target:Vector.<Number>):Vector.<Number>

Parameters

target:Vector.<Number>

Returns
Vector.<Number>
updateFaceTangents () method
protected function updateFaceTangents():void

Updates the tangents for each face.

updateIndexData () method
public function updateIndexData(indices:Vector.<uint>):void

Updates the face indices of the SubGeometry.

Parameters

indices:Vector.<uint> — The face indices to upload.

updateVertexNormals () method
protected function updateVertexNormals(target:Vector.<Number>):Vector.<Number>

Updates the vertex normals based on the geometry.

Parameters

target:Vector.<Number>

Returns
Vector.<Number>
updateVertexTangents () method
protected function updateVertexTangents(target:Vector.<Number>):Vector.<Number>

Updates the vertex tangents based on the geometry.

Parameters

target:Vector.<Number>

Returns
Vector.<Number>


away3d.core.base.SubMesh

SubMesh | Properties | Methods
Package | away3d.core.base
Class | public class SubMesh
Inheritance | SubMesh Inheritance Object
Implements | IRenderable

SubMesh wraps a SubGeometry as a scene graph instantiation. A SubMesh is owned by a Mesh object.

See also

away3d.core.base.SubGeometry
away3d.scenegraph.Mesh

Public Properties
Property |  | Defined By
 | animationSubGeometry : AnimationSubGeometry | SubMesh
 | animator : IAnimator [read-only] The animator object that provides the state for the SubMesh's animation. | SubMesh
 | animatorSubGeometry : AnimationSubGeometry | SubMesh
 | bounds : BoundingVolumeBase [read-only] | SubMesh
 | castsShadows : Boolean [read-only] | SubMesh
 | indexData : Vector.<uint> [read-only] | SubMesh
 | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | SubMesh
 | material : MaterialBase The material used to render the current SubMesh. | SubMesh
 | modelViewProjection : Matrix3D [read-only] The model-view-projection (MVP) matrix used to transform from model to homogeneous projection space. | SubMesh
 | mouseEnabled : Boolean [read-only] Indicates whether the SubMesh should trigger mouse events, and hence should be rendered for hit testing. | SubMesh
 | numTriangles : uint [read-only] The amount of triangles that make up this SubMesh. | SubMesh
 | numVertices : uint [read-only] | SubMesh
 | offsetU : Number | SubMesh
 | offsetV : Number | SubMesh
 | scaleU : Number | SubMesh
 | scaleV : Number | SubMesh
 | sceneTransform : Matrix3D [read-only] The scene transform object that transforms from model to world space. | SubMesh
 | shaderPickingDetails : Boolean [read-only] | SubMesh
 | sourceEntity : Entity [read-only] The entity that that initially provided the IRenderable to the render pipeline (ie: the owning Mesh object). | SubMesh
 | subGeometry : ISubGeometry The SubGeometry object which provides the geometry data for this SubMesh. | SubMesh
 | UVData : Vector.<Number> [read-only] | SubMesh
 | UVOffset : uint [read-only] | SubMesh
 | uvRotation : Number | SubMesh
 | UVStride : uint [read-only] | SubMesh
 | uvTransform : Matrix [read-only] | SubMesh
 | vertexData : Vector.<Number> [read-only] | SubMesh
 | vertexNormalData : Vector.<Number> [read-only] | SubMesh
 | vertexNormalOffset : uint [read-only] | SubMesh
 | vertexOffset : uint [read-only] | SubMesh
 | vertexStride : uint [read-only] | SubMesh
 | vertexTangentData : Vector.<Number> [read-only] | SubMesh
 | vertexTangentOffset : uint [read-only] | SubMesh
 | visible : Boolean [read-only] | SubMesh
 | zIndex : Number [read-only] The distance of the SubMesh object to the view, used to sort per object. | SubMesh
Public Methods
Method |  | Defined By
 | SubMesh(subGeometry:ISubGeometry, parentMesh:Mesh, material:MaterialBase = null) Creates a new SubMesh object | SubMesh
 | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for a secondary set of UV coordinates | SubMesh
 | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for UV coordinates | SubMesh
 | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for vertex positions. | SubMesh
 | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for vertex normals | SubMesh
 | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for vertex tangents | SubMesh
 | dispose():void | SubMesh
 | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D Retrieves the IndexBuffer3D object that contains triangle indices. | SubMesh
Property Detail
_index property
arcane var _index:uint

_material property
arcane var _material:MaterialBase

animationSubGeometry property
public var animationSubGeometry:AnimationSubGeometry

animator property
animator:IAnimator [read-only]

The animator object that provides the state for the SubMesh's animation.

Implementation
    public function get animator():IAnimator
animatorSubGeometry property
public var animatorSubGeometry:AnimationSubGeometry

bounds property
bounds:BoundingVolumeBase [read-only]

Implementation
    public function get bounds():BoundingVolumeBase
castsShadows property
castsShadows:Boolean [read-only]

Implementation
    public function get castsShadows():Boolean
indexData property
indexData:Vector.<uint> [read-only]

Implementation
    public function get indexData():Vector.<uint>
inverseSceneTransform property
inverseSceneTransform:Matrix3D [read-only]

The inverse scene transform object that transforms from world to model space.

Implementation
    public function get inverseSceneTransform():Matrix3D
material property
material:MaterialBase

The material used to render the current SubMesh. If set to null, its parent Mesh's material will be used instead.

Implementation
    public function get material():MaterialBase
    public function set material(value:MaterialBase):void
modelViewProjection property
modelViewProjection:Matrix3D [read-only]

The model-view-projection (MVP) matrix used to transform from model to homogeneous projection space.

Implementation
    public function get modelViewProjection():Matrix3D
mouseEnabled property
mouseEnabled:Boolean [read-only]

Indicates whether the SubMesh should trigger mouse events, and hence should be rendered for hit testing.

Implementation
    public function get mouseEnabled():Boolean
numTriangles property
numTriangles:uint [read-only]

The amount of triangles that make up this SubMesh.

Implementation
    public function get numTriangles():uint
numVertices property
numVertices:uint [read-only]

Implementation
    public function get numVertices():uint
offsetU property
offsetU:Number

Implementation
    public function get offsetU():Number
    public function set offsetU(value:Number):void
offsetV property
offsetV:Number

Implementation
    public function get offsetV():Number
    public function set offsetV(value:Number):void
parentMesh property
parentMesh:Mesh

Implementation
    arcane function get parentMesh():Mesh
    arcane function set parentMesh(value:Mesh):void
scaleU property
scaleU:Number

Implementation
    public function get scaleU():Number
    public function set scaleU(value:Number):void
scaleV property
scaleV:Number

Implementation
    public function get scaleV():Number
    public function set scaleV(value:Number):void
sceneTransform property
sceneTransform:Matrix3D [read-only]

The scene transform object that transforms from model to world space.

Implementation
    public function get sceneTransform():Matrix3D
shaderPickingDetails property
shaderPickingDetails:Boolean [read-only]

Implementation
    public function get shaderPickingDetails():Boolean
sourceEntity property
sourceEntity:Entity [read-only]

The entity that that initially provided the IRenderable to the render pipeline (ie: the owning Mesh object).

Implementation
    public function get sourceEntity():Entity
subGeometry property
subGeometry:ISubGeometry

The SubGeometry object which provides the geometry data for this SubMesh.

Implementation
    public function get subGeometry():ISubGeometry
    public function set subGeometry(value:ISubGeometry):void
UVData property
UVData:Vector.<Number> [read-only]

Implementation
    public function get UVData():Vector.<Number>
UVOffset property
UVOffset:uint [read-only]

Implementation
    public function get UVOffset():uint
uvRotation property
uvRotation:Number

Implementation
    public function get uvRotation():Number
    public function set uvRotation(value:Number):void
UVStride property
UVStride:uint [read-only]

Implementation
    public function get UVStride():uint
uvTransform property
uvTransform:Matrix [read-only]

Implementation
    public function get uvTransform():Matrix
vertexData property
vertexData:Vector.<Number> [read-only]

Implementation
    public function get vertexData():Vector.<Number>
vertexNormalData property
vertexNormalData:Vector.<Number> [read-only]

Implementation
    public function get vertexNormalData():Vector.<Number>
vertexNormalOffset property
vertexNormalOffset:uint [read-only]

Implementation
    public function get vertexNormalOffset():uint
vertexOffset property
vertexOffset:uint [read-only]

Implementation
    public function get vertexOffset():uint
vertexStride property
vertexStride:uint [read-only]

Implementation
    public function get vertexStride():uint
vertexTangentData property
vertexTangentData:Vector.<Number> [read-only]

Implementation
    public function get vertexTangentData():Vector.<Number>
vertexTangentOffset property
vertexTangentOffset:uint [read-only]

Implementation
    public function get vertexTangentOffset():uint
visible property
visible:Boolean [read-only]

Implementation
    public function get visible():Boolean
zIndex property
zIndex:Number [read-only]

The distance of the SubMesh object to the view, used to sort per object.

Implementation
    public function get zIndex():Number
Constructor Detail
SubMesh () Constructor
public function SubMesh(subGeometry:ISubGeometry, parentMesh:Mesh, material:MaterialBase = null)

Creates a new SubMesh object

Parameters
subGeometry:ISubGeometry — The SubGeometry object which provides the geometry data for this SubMesh.
parentMesh:Mesh — The Mesh object to which this SubMesh belongs.
material:MaterialBase (default = null) — An optional material used to render this SubMesh.
Method Detail
activateSecondaryUVBuffer () method
public function activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for a secondary set of UV coordinates

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateUVBuffer () method
public function activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for UV coordinates

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexBuffer () method
public function activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for vertex positions.

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexNormalBuffer () method
public function activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for vertex normals

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexTangentBuffer () method
public function activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for vertex tangents

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

dispose () method
public function dispose():void

getIndexBuffer () method
public function getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D

Retrieves the IndexBuffer3D object that contains triangle indices.

Parameters

stage3DProxy:Stage3DProxy — The Context3D for which we request the buffer

Returns
IndexBuffer3D — The VertexBuffer3D object that contains triangle indices.


away3d.core.base.data - Away3D Documentation

Package away3d.core.base.data

Classes
Face
ParticleData
UV
Vertex


away3d.core.base.data Summary

away3d.core.base.data | Classes

Classes
Class | Description
Face | Face value object.
ParticleData |
UV | Texture coordinates value object.
Vertex | Vertex value object.

Thu Nov 15 2012, 12:09 PM Z


away3d.core.base.data.Face

Face | Properties | Methods
Package | away3d.core.base.data
Class | public class Face
Inheritance | Face Inheritance Object

Face value object.

Public Properties
Property |  | Defined By
 | faceIndex : uint To store a temp index of a face during a loop | Face
 | uv0Index : uint the index set for uv0 in this Face value object | Face
 | uv0u : Number [read-only] | Face
 | uv0v : Number [read-only] | Face
 | uv1Index : uint the index set for uv1 in this Face value object | Face
 | uv1u : Number [read-only] | Face
 | uv1v : Number [read-only] | Face
 | uv2Index : uint the index set for uv2 in this Face value object | Face
 | uv2u : Number [read-only] | Face
 | uv2v : Number [read-only] | Face
 | v0 : Vector.<Number> [read-only] | Face
 | v0Index : uint set the index value for v0 | Face
 | v0x : Number [read-only] | Face
 | v0y : Number [read-only] | Face
 | v0z : Number [read-only] | Face
 | v1 : Vector.<Number> [read-only] | Face
 | v1Index : uint set the index value for v1 | Face
 | v1x : Number [read-only] | Face
 | v1y : Number [read-only] | Face
 | v1z : Number [read-only] | Face
 | v2 : Vector.<Number> [read-only] | Face
 | v2Index : uint set the index value for v2 | Face
 | v2x : Number [read-only] | Face
 | v2y : Number [read-only] | Face
 | v2z : Number [read-only] | Face
Public Methods
Method |  | Defined By
 | Face(vertices:Vector.<Number> = null, uvs:Vector.<Number> = null) Creates a new Face value object. | Face
 | clone():Face returns a new Face value Object | Face
 | containsPoint(point:Vector3D, maxDistanceToPlane:Number = .007):Boolean Tests whether a given point is inside the triangle | Face
 | getBarycentricCoords(point:Vector3D, target:Point = null):Point Returns the first two barycentric coordinates for a point on (or outside) the triangle. | Face
 | getUVAtPoint(point:Vector3D, target:UV = null):UV Returns the target coordinates for a point on a triangle | Face
 | setUv0Value(u:Number, v:Number):void uv0 u and v values | Face
 | setUv1Value(u:Number, v:Number):void uv1 u and v values | Face
 | setUv2Value(u:Number, v:Number):void uv2 u and v values | Face
 | setUVat(index:uint, u:Number, v:Number):void To set uv values for either uv0, uv1 or uv2. | Face
 | setVertexAt(index:uint, x:Number, y:Number, z:Number):void To set uv values for either v0, v1 or v2. | Face
Property Detail
faceIndex property
faceIndex:uint

To store a temp index of a face during a loop

Implementation
    public function get faceIndex():uint
    public function set faceIndex(value:uint):void
uv0Index property
uv0Index:uint

the index set for uv0 in this Face value object

Implementation
    public function get uv0Index():uint
    public function set uv0Index(value:uint):void
uv0u property
uv0u:Number [read-only]

Implementation
    public function get uv0u():Number
uv0v property
uv0v:Number [read-only]

Implementation
    public function get uv0v():Number
uv1Index property
uv1Index:uint

the index set for uv1 in this Face value object

Implementation
    public function get uv1Index():uint
    public function set uv1Index(value:uint):void
uv1u property
uv1u:Number [read-only]

Implementation
    public function get uv1u():Number
uv1v property
uv1v:Number [read-only]

Implementation
    public function get uv1v():Number
uv2Index property
uv2Index:uint

the index set for uv2 in this Face value object

Implementation
    public function get uv2Index():uint
    public function set uv2Index(value:uint):void
uv2u property
uv2u:Number [read-only]

Implementation
    public function get uv2u():Number
uv2v property
uv2v:Number [read-only]

Implementation
    public function get uv2v():Number
v0 property
v0:Vector.<Number> [read-only]

Implementation
    public function get v0():Vector.<Number>
v0Index property
v0Index:uint

set the index value for v0

Implementation
    public function get v0Index():uint
    public function set v0Index(value:uint):void
v0x property
v0x:Number [read-only]

Implementation
    public function get v0x():Number
v0y property
v0y:Number [read-only]

Implementation
    public function get v0y():Number
v0z property
v0z:Number [read-only]

Implementation
    public function get v0z():Number
v1 property
v1:Vector.<Number> [read-only]

Implementation
    public function get v1():Vector.<Number>
v1Index property
v1Index:uint

set the index value for v1

Implementation
    public function get v1Index():uint
    public function set v1Index(value:uint):void
v1x property
v1x:Number [read-only]

Implementation
    public function get v1x():Number
v1y property
v1y:Number [read-only]

Implementation
    public function get v1y():Number
v1z property
v1z:Number [read-only]

Implementation
    public function get v1z():Number
v2 property
v2:Vector.<Number> [read-only]

Implementation
    public function get v2():Vector.<Number>
v2Index property
v2Index:uint

set the index value for v2

Implementation
    public function get v2Index():uint
    public function set v2Index(value:uint):void
v2x property
v2x:Number [read-only]

Implementation
    public function get v2x():Number
v2y property
v2y:Number [read-only]

Implementation
    public function get v2y():Number
v2z property
v2z:Number [read-only]

Implementation
    public function get v2z():Number
Constructor Detail
Face () Constructor
public function Face(vertices:Vector.<Number> = null, uvs:Vector.<Number> = null)

Creates a new Face value object.

Parameters
vertices:Vector.<Number> (default = null) — [optional] 9 entries long Vector.<Number> representing the x, y and z of v0, v1, and v2 of a face
uvs:Vector.<Number> (default = null) — [optional] 6 entries long Vector.<Number> representing the u and v of uv0, uv1, and uv2 of a face
Method Detail
clone () method
public function clone():Face

returns a new Face value Object

Returns
Face
containsPoint () method
public function containsPoint(point:Vector3D, maxDistanceToPlane:Number = .007):Boolean

Tests whether a given point is inside the triangle

Parameters

point:Vector3D — The point to test against
maxDistanceToPlane:Number (default = .007) — The minimum distance to the plane for the point to be considered on the triangle. This is usually used to allow for rounding error, but can also be used to perform a volumetric test.

Returns
Boolean
getBarycentricCoords () method
public function getBarycentricCoords(point:Vector3D, target:Point = null):Point

Returns the first two barycentric coordinates for a point on (or outside) the triangle. The third coordinate is 1 - x - y

Parameters

point:Vector3D — The point for which to calculate the new target
target:Point (default = null) — An optional Point object to store the calculation in order to prevent creation of a new object

Returns
Point
getUVAtPoint () method
public function getUVAtPoint(point:Vector3D, target:UV = null):UV

Returns the target coordinates for a point on a triangle

Parameters

point:Vector3D — The triangle's first vertex
target:UV (default = null) — The triangle's second vertex

Returns
UV
setUv0Value () method
public function setUv0Value(u:Number, v:Number):void

uv0 u and v values

Parameters

u:Number — The u value
v:Number — The v value

setUv1Value () method
public function setUv1Value(u:Number, v:Number):void

uv1 u and v values

Parameters

u:Number — The u value
v:Number — The v value

setUv2Value () method
public function setUv2Value(u:Number, v:Number):void

uv2 u and v values

Parameters

u:Number — The u value
v:Number — The v value

setUVat () method
public function setUVat(index:uint, u:Number, v:Number):void

To set uv values for either uv0, uv1 or uv2.

Parameters

index:uint — The id of the uv (0, 1 or 2)
u:Number — The horizontal coordinate of the texture value.
v:Number — The vertical coordinate of the texture value.

setVertexAt () method
public function setVertexAt(index:uint, x:Number, y:Number, z:Number):void

To set uv values for either v0, v1 or v2.

Parameters

index:uint — The id of the uv (0, 1 or 2)
x:Number — The x value of the vertex.
y:Number — The y value of the vertex.
z:Number — The z value of the vertex.


away3d.core.base.data.ParticleData

ParticleData | Properties
Package | away3d.core.base.data
Class | public class ParticleData
Inheritance | ParticleData Inheritance Object

Public Properties
Property |  | Defined By
 | numVertices : uint | ParticleData
 | particleIndex : uint | ParticleData
 | startVertexIndex : uint | ParticleData
 | subGeometry : CompactSubGeometry | ParticleData
Property Detail
numVertices property
public var numVertices:uint

particleIndex property
public var particleIndex:uint

startVertexIndex property
public var startVertexIndex:uint

subGeometry property
public var subGeometry:CompactSubGeometry


away3d.core.base.data.UV

UV | Properties | Methods
Package | away3d.core.base.data
Class | public class UV
Inheritance | UV Inheritance Object

Texture coordinates value object.

Public Properties
Property |  | Defined By
 | u : Number Defines the horizontal coordinate of the texture value. | UV
 | v : Number Defines the vertical coordinate of the texture value. | UV
Public Methods
Method |  | Defined By
 | UV(u:Number = 0, v:Number = 0) Creates a new UV object. | UV
 | clone():UV returns a new UV value Object | UV
 | toString():String returns the value object as a string for trace/debug purpose | UV
Property Detail
u property
u:Number

Defines the horizontal coordinate of the texture value.

Implementation
    public function get u():Number
    public function set u(value:Number):void
v property
v:Number

Defines the vertical coordinate of the texture value.

Implementation
    public function get v():Number
    public function set v(value:Number):void
Constructor Detail
UV () Constructor
public function UV(u:Number = 0, v:Number = 0)

Creates a new UV object.

Parameters
u:Number (default = 0) — [optional] The horizontal coordinate of the texture value. Defaults to 0.
v:Number (default = 0) — [optional] The vertical coordinate of the texture value. Defaults to 0.
Method Detail
clone () method
public function clone():UV

returns a new UV value Object

Returns
UV
toString () method
public function toString():String

returns the value object as a string for trace/debug purpose

Returns
String


away3d.core.base.data.Vertex

Vertex | Properties | Methods
Package | away3d.core.base.data
Class | public class Vertex
Inheritance | Vertex Inheritance Object
Subclasses | NURBSVertex

Vertex value object.

Public Properties
Property |  | Defined By
 | index : uint To define/store the index of value object | Vertex
 | x : Number To define/store the x value of the value object | Vertex
 | y : Number To define/store the y value of the value object | Vertex
 | z : Number To define/store the z value of the value object | Vertex
Public Methods
Method |  | Defined By
 | Vertex(x:Number = 0, y:Number = 0, z:Number = 0, index:uint) Creates a new Vertex value object. | Vertex
 | clone():Vertex returns a new Vertex value Object | Vertex
 | toString():String returns the value object as a string for trace/debug purpose | Vertex
Property Detail
index property
index:uint

To define/store the index of value object

Implementation
    public function get index():uint
    public function set index(value:uint):void
x property
x:Number

To define/store the x value of the value object

Implementation
    public function get x():Number
    public function set x(value:Number):void
y property
y:Number

To define/store the y value of the value object

Implementation
    public function get y():Number
    public function set y(value:Number):void
z property
z:Number

To define/store the z value of the value object

Implementation
    public function get z():Number
    public function set z(value:Number):void
Constructor Detail
Vertex () Constructor
public function Vertex(x:Number = 0, y:Number = 0, z:Number = 0, index:uint)

Creates a new Vertex value object.

Parameters
x:Number (default = 0) — [optional] The x value. Defaults to 0.
y:Number (default = 0) — [optional] The y value. Defaults to 0.
z:Number (default = 0) — [optional] The z value. Defaults to 0.
index:uint (default = NaN) — [optional] The index value. Defaults is NaN.
Method Detail
clone () method
public function clone():Vertex

returns a new Vertex value Object

Returns
Vertex
toString () method
public function toString():String

returns the value object as a string for trace/debug purpose

Returns
String


away3d.core.data - Away3D Documentation

Package away3d.core.data

Classes
EntityListItem
EntityListItemPool
RenderableListItem
RenderableListItemPool


away3d.core.data Summary

away3d.core.data | Classes

Classes
Class | Description
EntityListItem |
EntityListItemPool |
RenderableListItem |
RenderableListItemPool |

Thu Nov 15 2012, 12:09 PM Z


away3d.core.data.EntityListItem

EntityListItem | Properties
Package | away3d.core.data
Class | public class EntityListItem
Inheritance | EntityListItem Inheritance Object

Public Properties
Property |  | Defined By
 | entity : Entity | EntityListItem
 | next : EntityListItem | EntityListItem
Property Detail
entity property
public var entity:Entity

next property
public var next:EntityListItem


away3d.core.data.EntityListItemPool

EntityListItemPool | Methods
Package | away3d.core.data
Class | public class EntityListItemPool
Inheritance | EntityListItemPool Inheritance Object

Public Methods
Method |  | Defined By
 | EntityListItemPool() | EntityListItemPool
 | dispose():void | EntityListItemPool
 | freeAll():void | EntityListItemPool
 | getItem():EntityListItem | EntityListItemPool
Constructor Detail
EntityListItemPool () Constructor
public function EntityListItemPool()

Method Detail
dispose () method
public function dispose():void

freeAll () method
public function freeAll():void

getItem () method
public function getItem():EntityListItem

Returns
EntityListItem


away3d.core.data.RenderableListItem

RenderableListItem | Properties
Package | away3d.core.data
Class | public final class RenderableListItem
Inheritance | RenderableListItem Inheritance Object

Public Properties
Property |  | Defined By
 | materialId : int | RenderableListItem
 | next : RenderableListItem | RenderableListItem
 | renderable : IRenderable | RenderableListItem
 | renderOrderId : int | RenderableListItem
 | zIndex : Number | RenderableListItem
Property Detail
materialId property
public var materialId:int

next property
public var next:RenderableListItem

renderable property
public var renderable:IRenderable

renderOrderId property
public var renderOrderId:int

zIndex property
public var zIndex:Number


away3d.core.data.RenderableListItemPool

RenderableListItemPool | Methods
Package | away3d.core.data
Class | public class RenderableListItemPool
Inheritance | RenderableListItemPool Inheritance Object

Public Methods
Method |  | Defined By
 | RenderableListItemPool() | RenderableListItemPool
 | dispose():void | RenderableListItemPool
 | freeAll():void | RenderableListItemPool
 | getItem():RenderableListItem | RenderableListItemPool
Constructor Detail
RenderableListItemPool () Constructor
public function RenderableListItemPool()

Method Detail
dispose () method
public function dispose():void

freeAll () method
public function freeAll():void

getItem () method
public function getItem():RenderableListItem

Returns
RenderableListItem


away3d.core.managers - Away3D Documentation

Package away3d.core.managers

Classes
AGALProgram3DCache
Mouse3DManager
RTTBufferManager
Stage3DManager
Stage3DProxy


away3d.core.managers Summary

away3d.core.managers | Classes

Classes
Class | Description
AGALProgram3DCache |
Mouse3DManager | Mouse3DManager enforces a singleton pattern and is not intended to be instanced.
RTTBufferManager |
Stage3DManager | The Stage3DManager class provides a multiton object that handles management for Stage3D objects.
Stage3DProxy | Stage3DProxy provides a proxy class to manage a single Stage3D instance as well as handling the creation and attachment of the Context3D (and in turn the back buffer) is uses.

Thu Nov 15 2012, 12:09 PM Z


away3d.core.managers.AGALProgram3DCache

AGALProgram3DCache | Methods
Package | away3d.core.managers
Class | public class AGALProgram3DCache
Inheritance | AGALProgram3DCache Inheritance Object

Public Methods
Method |  | Defined By
 | AGALProgram3DCache(stage3DProxy:Stage3DProxy, AGALProgram3DCacheSingletonEnforcer:AGALProgram3DCacheSingletonEnforcer) | AGALProgram3DCache
 | dispose():void | AGALProgram3DCache
 | freeProgram3D(programId:int):void | AGALProgram3DCache
 | getInstance(stage3DProxy:Stage3DProxy):AGALProgram3DCache [static] | AGALProgram3DCache
 | getInstanceFromIndex(index:int):AGALProgram3DCache [static] | AGALProgram3DCache
 | setProgram3D(pass:MaterialPassBase, vertexCode:String, fragmentCode:String):void | AGALProgram3DCache
Constructor Detail
AGALProgram3DCache () Constructor
public function AGALProgram3DCache(stage3DProxy:Stage3DProxy, AGALProgram3DCacheSingletonEnforcer:AGALProgram3DCacheSingletonEnforcer)

Parameters
stage3DProxy:Stage3DProxy
AGALProgram3DCacheSingletonEnforcer:AGALProgram3DCacheSingletonEnforcer
Method Detail
dispose () method
public function dispose():void

freeProgram3D () method
public function freeProgram3D(programId:int):void

Parameters

programId:int

getInstance () method
public static function getInstance(stage3DProxy:Stage3DProxy):AGALProgram3DCache

Parameters

stage3DProxy:Stage3DProxy

Returns
AGALProgram3DCache
getInstanceFromIndex () method
public static function getInstanceFromIndex(index:int):AGALProgram3DCache

Parameters

index:int

Returns
AGALProgram3DCache
setProgram3D () method
public function setProgram3D(pass:MaterialPassBase, vertexCode:String, fragmentCode:String):void

Parameters

pass:MaterialPassBase
vertexCode:String
fragmentCode:String


away3d.core.managers.Mouse3DManager

Mouse3DManager | Properties | Methods
Package | away3d.core.managers
Class | public class Mouse3DManager
Inheritance | Mouse3DManager Inheritance Object

Mouse3DManager enforces a singleton pattern and is not intended to be instanced. it provides a manager class for detecting 3D mouse hits on View3D objects and sending out 3D mouse events.

Public Properties
Property |  | Defined By
 | forceMouseMove : Boolean | Mouse3DManager
 | mousePicker : IPicker | Mouse3DManager
Protected Properties
Property |  | Defined By
 | _collidingObject : PickingCollisionVO | Mouse3DManager
Public Methods
Method |  | Defined By
 | Mouse3DManager() Creates a new Mouse3DManager object. | Mouse3DManager
 | disableMouseListeners(view:View3D):void | Mouse3DManager
 | enableMouseListeners(view:View3D):void | Mouse3DManager
 | fireMouseEvents():void | Mouse3DManager
 | updateCollider(view:View3D):void | Mouse3DManager
Property Detail
_collidingObject property
protected var _collidingObject:PickingCollisionVO

forceMouseMove property
forceMouseMove:Boolean

Implementation
    public function get forceMouseMove():Boolean
    public function set forceMouseMove(value:Boolean):void
mousePicker property
mousePicker:IPicker

Implementation
    public function get mousePicker():IPicker
    public function set mousePicker(value:IPicker):void
Constructor Detail
Mouse3DManager () Constructor
public function Mouse3DManager()

Creates a new Mouse3DManager object.

Method Detail
disableMouseListeners () method
public function disableMouseListeners(view:View3D):void

Parameters

view:View3D

enableMouseListeners () method
public function enableMouseListeners(view:View3D):void

Parameters

view:View3D

fireMouseEvents () method
public function fireMouseEvents():void

updateCollider () method
public function updateCollider(view:View3D):void

Parameters

view:View3D


away3d.core.managers.RTTBufferManager

RTTBufferManager | Properties | Methods
Package | away3d.core.managers
Class | public class RTTBufferManager
Inheritance | RTTBufferManager Inheritance flash.events.EventDispatcher

Public Properties
Property |  | Defined By
 | indexBuffer : IndexBuffer3D [read-only] | RTTBufferManager
 | renderToScreenVertexBuffer : VertexBuffer3D [read-only] | RTTBufferManager
 | renderToTextureRect : Rectangle [read-only] | RTTBufferManager
 | renderToTextureVertexBuffer : VertexBuffer3D [read-only] | RTTBufferManager
 | textureHeight : int [read-only] | RTTBufferManager
 | textureRatioX : Number [read-only] | RTTBufferManager
 | textureRatioY : Number [read-only] | RTTBufferManager
 | textureWidth : int [read-only] | RTTBufferManager
 | viewHeight : int | RTTBufferManager
 | viewWidth : int | RTTBufferManager
Public Methods
Method |  | Defined By
 | RTTBufferManager(se:SingletonEnforcer, stage3DProxy:Stage3DProxy) | RTTBufferManager
 | dispose():void | RTTBufferManager
 | getInstance(stage3DProxy:Stage3DProxy):RTTBufferManager [static] | RTTBufferManager
Property Detail
indexBuffer property
indexBuffer:IndexBuffer3D [read-only]

Implementation
    public function get indexBuffer():IndexBuffer3D
renderToScreenVertexBuffer property
renderToScreenVertexBuffer:VertexBuffer3D [read-only]

Implementation
    public function get renderToScreenVertexBuffer():VertexBuffer3D
renderToTextureRect property
renderToTextureRect:Rectangle [read-only]

Implementation
    public function get renderToTextureRect():Rectangle
renderToTextureVertexBuffer property
renderToTextureVertexBuffer:VertexBuffer3D [read-only]

Implementation
    public function get renderToTextureVertexBuffer():VertexBuffer3D
textureHeight property
textureHeight:int [read-only]

Implementation
    public function get textureHeight():int
textureRatioX property
textureRatioX:Number [read-only]

Implementation
    public function get textureRatioX():Number
textureRatioY property
textureRatioY:Number [read-only]

Implementation
    public function get textureRatioY():Number
textureWidth property
textureWidth:int [read-only]

Implementation
    public function get textureWidth():int
viewHeight property
viewHeight:int

Implementation
    public function get viewHeight():int
    public function set viewHeight(value:int):void
viewWidth property
viewWidth:int

Implementation
    public function get viewWidth():int
    public function set viewWidth(value:int):void
Constructor Detail
RTTBufferManager () Constructor
public function RTTBufferManager(se:SingletonEnforcer, stage3DProxy:Stage3DProxy)

Parameters
se:SingletonEnforcer
stage3DProxy:Stage3DProxy
Method Detail
dispose () method
public function dispose():void

getInstance () method
public static function getInstance(stage3DProxy:Stage3DProxy):RTTBufferManager

Parameters

stage3DProxy:Stage3DProxy

Returns
RTTBufferManager


away3d.core.managers.Stage3DManager

Stage3DManager | Properties | Methods
Package | away3d.core.managers
Class | public class Stage3DManager
Inheritance | Stage3DManager Inheritance Object

The Stage3DManager class provides a multiton object that handles management for Stage3D objects. Stage3D objects should not be requested directly, but are exposed by a Stage3DProxy.

See also

away3d.core.managers.Stage3DProxy

Public Properties
Property |  | Defined By
 | hasFreeStage3DProxy : Boolean [read-only] Checks if a new stage3DProxy can be created and managed by the class. | Stage3DManager
 | numProxySlotsFree : uint [read-only] Returns the amount of stage3DProxy objects that can be created and managed by the class | Stage3DManager
 | numProxySlotsTotal : uint [read-only] Returns the maximum amount of Stage3DProxy objects that can be managed by the class | Stage3DManager
 | numProxySlotsUsed : uint [read-only] Returns the amount of Stage3DProxy objects currently managed by the class. | Stage3DManager
Public Methods
Method |  | Defined By
 | getFreeStage3DProxy(forceSoftware:Boolean = false):Stage3DProxy Get the next available stage3DProxy. | Stage3DManager
 | getInstance(stage:Stage):Stage3DManager [static] Gets a Stage3DManager instance for the given Stage object. | Stage3DManager
 | getStage3DProxy(index:uint, forceSoftware:Boolean = false):Stage3DProxy Requests the Stage3DProxy for the given index. | Stage3DManager
Property Detail
hasFreeStage3DProxy property
hasFreeStage3DProxy:Boolean [read-only]

Checks if a new stage3DProxy can be created and managed by the class.

Implementation
    public function get hasFreeStage3DProxy():Boolean
numProxySlotsFree property
numProxySlotsFree:uint [read-only]

Returns the amount of stage3DProxy objects that can be created and managed by the class

Implementation
    public function get numProxySlotsFree():uint
numProxySlotsTotal property
numProxySlotsTotal:uint [read-only]

Returns the maximum amount of Stage3DProxy objects that can be managed by the class

Implementation
    public function get numProxySlotsTotal():uint
numProxySlotsUsed property
numProxySlotsUsed:uint [read-only]

Returns the amount of Stage3DProxy objects currently managed by the class.

Implementation
    public function get numProxySlotsUsed():uint
Method Detail
getFreeStage3DProxy () method
public function getFreeStage3DProxy(forceSoftware:Boolean = false):Stage3DProxy

Get the next available stage3DProxy. An error is thrown if there are no Stage3DProxies available

Parameters

forceSoftware:Boolean (default = false) — Whether to force software mode even if hardware acceleration is available.

Returns
Stage3DProxy — The allocated stage3DProxy
getInstance () method
public static function getInstance(stage:Stage):Stage3DManager

Gets a Stage3DManager instance for the given Stage object.

Parameters

stage:Stage — The Stage object that contains the Stage3D objects to be managed.

Returns
Stage3DManager — The Stage3DManager instance for the given Stage object.
getStage3DProxy () method
public function getStage3DProxy(index:uint, forceSoftware:Boolean = false):Stage3DProxy

Requests the Stage3DProxy for the given index.

Parameters

index:uint — The index of the requested Stage3D.
forceSoftware:Boolean (default = false) — Whether to force software mode even if hardware acceleration is available.

Returns
Stage3DProxy — The Stage3DProxy for the given index.


away3d.core.managers.Stage3DProxy

Stage3DProxy | Properties | Methods | Events
Package | away3d.core.managers
Class | public class Stage3DProxy
Inheritance | Stage3DProxy Inheritance flash.events.EventDispatcher

Stage3DProxy provides a proxy class to manage a single Stage3D instance as well as handling the creation and attachment of the Context3D (and in turn the back buffer) is uses. Stage3DProxy should never be created directly, but requested through Stage3DManager.

See also

todo: consider moving all creation methods (createVertexBuffer etc) in here, so that disposal can occur here along with the context, instead of scattered throughout the framework

Public Properties
Property |  | Defined By
 | antiAlias : int The antiAliasing of the Stage3D. | Stage3DProxy
 | color : uint The background color of the Stage3D. | Stage3DProxy
 | context3D : Context3D [read-only] The Context3D object associated with the given Stage3D object. | Stage3DProxy
 | driverInfo : String [read-only] The driver information as reported by the Context3D object (if any) | Stage3DProxy
 | enableDepthAndStencil : Boolean | Stage3DProxy
 | height : int The height of the Stage3D. | Stage3DProxy
 | renderSurfaceSelector : int [read-only] | Stage3DProxy
 | renderTarget : TextureBase [read-only] | Stage3DProxy
 | scissorRect : Rectangle | Stage3DProxy
 | stage3D : Stage3D [read-only] The base Stage3D object associated with this proxy. | Stage3DProxy
 | stage3DIndex : int [read-only] The index of the Stage3D which is managed by this instance of Stage3DProxy. | Stage3DProxy
 | usesSoftwareRendering : Boolean [read-only] Indicates whether the Stage3D managed by this proxy is running in software mode. | Stage3DProxy
 | viewPort : Rectangle [read-only] A viewPort rectangle equivalent of the Stage3D size and position. | Stage3DProxy
 | visible : Boolean The visibility of the Stage3D. | Stage3DProxy
 | width : int The width of the Stage3D. | Stage3DProxy
 | x : Number The x position of the Stage3D. | Stage3DProxy
 | y : Number The y position of the Stage3D. | Stage3DProxy
Public Methods
Method Defined By
Stage3DProxy(stage3DIndex:int, stage3D:Stage3D, stage3DManager:Stage3DManager, forceSoftware:Boolean = false)
Creates a Stage3DProxy object.
Stage3DProxy
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
[override] Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
Stage3DProxy
clear():void
Stage3DProxy
configureBackBuffer(backBufferWidth:int, backBufferHeight:int, antiAlias:int, enableDepthAndStencil:Boolean):void
Configures the back buffer associated with the Stage3D object.
Stage3DProxy
dispose():void
Disposes the Stage3DProxy object, freeing the Context3D attached to the Stage3D.
Stage3DProxy
present():void
Stage3DProxy
recoverFromDisposal():Boolean
Stage3DProxy
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
[override] Removes a listener from the EventDispatcher object.
Stage3DProxy
setProgram(program3D:Program3D):void
Set the shader program for the subsequent rendering calls.
Stage3DProxy
setRenderTarget(target:TextureBase, enableDepthAndStencil:Boolean = false, surfaceSelector:int = 0):void
Stage3DProxy
setTextureAt(index:int, texture:TextureBase):void
Assign the texture in the Context3D ready for use in the shader.
Stage3DProxy
Events
Event |  | Summary | Defined By
 | enterFrame |  | Stage3DProxy
 | exitFrame |  | Stage3DProxy
Property Detail
_context3D property
arcane var _context3D:Context3D

_stage3DIndex property
arcane var _stage3DIndex:int = -1

antiAlias property
antiAlias:int

The antiAliasing of the Stage3D.

Implementation
    public function get antiAlias():int
    public function set antiAlias(value:int):void
color property
color:uint

The background color of the Stage3D.

Implementation
    public function get color():uint
    public function set color(value:uint):void
context3D property
context3D:Context3D [read-only]

The Context3D object associated with the given Stage3D object.

Implementation
    public function get context3D():Context3D
driverInfo property
driverInfo:String [read-only]

The driver information as reported by the Context3D object (if any)

Implementation
    public function get driverInfo():String
enableDepthAndStencil property
enableDepthAndStencil:Boolean

Implementation
    public function get enableDepthAndStencil():Boolean
    public function set enableDepthAndStencil(value:Boolean):void
height property
height:int

The height of the Stage3D.

Implementation
    public function get height():int
    public function set height(value:int):void
renderSurfaceSelector property
renderSurfaceSelector:int [read-only]

Implementation
    public function get renderSurfaceSelector():int
renderTarget property
renderTarget:TextureBase [read-only]

Implementation
    public function get renderTarget():TextureBase
scissorRect property
scissorRect:Rectangle

Implementation
    public function get scissorRect():Rectangle
    public function set scissorRect(value:Rectangle):void
stage3D property
stage3D:Stage3D [read-only]

The base Stage3D object associated with this proxy.

Implementation
    public function get stage3D():Stage3D
stage3DIndex property
stage3DIndex:int [read-only]

The index of the Stage3D which is managed by this instance of Stage3DProxy.

Implementation
    public function get stage3DIndex():int
usesSoftwareRendering property
usesSoftwareRendering:Boolean [read-only]

Indicates whether the Stage3D managed by this proxy is running in software mode. Remember to wait for the CONTEXT3D_CREATED event before checking this property, as only then will it be guaranteed to be accurate.

Implementation
    public function get usesSoftwareRendering():Boolean
viewPort property
viewPort:Rectangle [read-only]

A viewPort rectangle equivalent of the Stage3D size and position.

Implementation
    public function get viewPort():Rectangle
visible property
visible:Boolean

The visibility of the Stage3D.

Implementation
    public function get visible():Boolean
    public function set visible(value:Boolean):void
width property
width:int

The width of the Stage3D.

Implementation
    public function get width():int
    public function set width(value:int):void
x property
x:Number

The x position of the Stage3D.

Implementation
    public function get x():Number
    public function set x(value:Number):void
y property
y:Number

The y position of the Stage3D.

Implementation
    public function get y():Number
    public function set y(value:Number):void
Constructor Detail
Stage3DProxy () Constructor
public function Stage3DProxy(stage3DIndex:int, stage3D:Stage3D, stage3DManager:Stage3DManager, forceSoftware:Boolean = false)

Creates a Stage3DProxy object. This method should not be called directly. Creation of Stage3DProxy objects should be handled by Stage3DManager.

Parameters
stage3DIndex:int — The index of the Stage3D to be proxied.
stage3D:Stage3D — The Stage3D to be proxied.
stage3DManager:Stage3DManager
forceSoftware:Boolean (default = false) — Whether to force software mode even if hardware acceleration is available.
Method Detail
addEventListener () method
override public function addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void

Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event. Special case for enterframe and exitframe events - will switch Stage3DProxy into automatic render mode. You can register event listeners on all nodes in the display list for a specific type of event, phase, and priority.

Parameters

type:String — The type of event.
listener:Function — The listener function that processes the event.
useCapture:Boolean (default = false) — Determines whether the listener works in the capture phase or the target and bubbling phases. If useCapture is set to true, the listener processes the event only during the capture phase and not in the target or bubbling phase. If useCapture is false, the listener processes the event only during the target or bubbling phase. To listen for the event in all three phases, call addEventListener twice, once with useCapture set to true, then again with useCapture set to false.
priority:int (default = 0) — The priority level of the event listener. The priority is designated by a signed 32-bit integer. The higher the number, the higher the priority. All listeners with priority n are processed before listeners of priority n-1. If two or more listeners share the same priority, they are processed in the order in which they were added. The default priority is 0.
useWeakReference:Boolean (default = false) — Determines whether the reference to the listener is strong or weak. A strong reference (the default) prevents your listener from being garbage-collected. A weak reference does not.

clear () method
public function clear():void

configureBackBuffer () method
public function configureBackBuffer(backBufferWidth:int, backBufferHeight:int, antiAlias:int, enableDepthAndStencil:Boolean):void

Configures the back buffer associated with the Stage3D object.

Parameters

backBufferWidth:int — The width of the backbuffer.
backBufferHeight:int — The height of the backbuffer.
antiAlias:int — The amount of anti-aliasing to use.
enableDepthAndStencil:Boolean — Indicates whether the back buffer contains a depth and stencil buffer.

dispose () method
public function dispose():void

Disposes the Stage3DProxy object, freeing the Context3D attached to the Stage3D.

present () method
public function present():void

recoverFromDisposal () method
public function recoverFromDisposal():Boolean

Returns
Boolean
removeEventListener () method
override public function removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void

Removes a listener from the EventDispatcher object. Special case for enterframe and exitframe events - will switch Stage3DProxy out of automatic render mode. If there is no matching listener registered with the EventDispatcher object, a call to this method has no effect.

Parameters

type:String — The type of event.
listener:Function — The listener object to remove.
useCapture:Boolean (default = false) — Specifies whether the listener was registered for the capture phase or the target and bubbling phases. If the listener was registered for both the capture phase and the target and bubbling phases, two calls to removeEventListener() are required to remove both, one call with useCapture() set to true, and another call with useCapture() set to false.

setProgram () method
public function setProgram(program3D:Program3D):void

Set the shader program for the subsequent rendering calls.

Parameters

program3D:Program3D — The program to be used in the shader

setRenderTarget () method
public function setRenderTarget(target:TextureBase, enableDepthAndStencil:Boolean = false, surfaceSelector:int = 0):void

Parameters

target:TextureBase
enableDepthAndStencil:Boolean (default = false)
surfaceSelector:int (default = 0)

setTextureAt () method
public function setTextureAt(index:int, texture:TextureBase):void

Assign the texture in the Context3D ready for use in the shader.

Parameters

index:int — The index where the texture is set
texture:TextureBase — The texture to set

Event Detail
enterFrame Event
Event Object Type: flash.events.Event

exitFrame Event
Event Object Type: flash.events.Event


away3d.core.math - Away3D Documentation

Package away3d.core.math

Classes
MathConsts
Matrix3DUtils
Plane3D
PlaneClassification
Quaternion
Vector3DUtils


away3d.core.math Summary

away3d.core.math | Classes

Classes
Class | Description
MathConsts | MathConsts provides some commonly used mathematical constants
Matrix3DUtils | Matrix3DUtils provides additional Matrix3D math functions.
Plane3D |
PlaneClassification |
Quaternion | A Quaternion object which can be used to represent rotations.
Vector3DUtils | Vector3DUtils provides additional Vector3D math functions.

Thu Nov 15 2012, 12:09 PM Z


away3d.core.math.MathConsts

MathConsts | Constants
Package | away3d.core.math
Class | public class MathConsts
Inheritance | MathConsts Inheritance Object

MathConsts provides some commonly used mathematical constants

Public Constants
Constant |  | Defined By
 | DEGREES_TO_RADIANS : Number = 0.017453292519943295 [static] The amount to multiply with when converting degrees to radians. | MathConsts
 | RADIANS_TO_DEGREES : Number = 57.29577951308232 [static] The amount to multiply with when converting radians to degrees. | MathConsts
Constant Detail
DEGREES_TO_RADIANS Constant
public static const DEGREES_TO_RADIANS:Number = 0.017453292519943295

The amount to multiply with when converting degrees to radians.

RADIANS_TO_DEGREES Constant
public static const RADIANS_TO_DEGREES:Number = 57.29577951308232

The amount to multiply with when converting radians to degrees.


away3d.core.math.Matrix3DUtils

Matrix3DUtils | Methods | Constants
Package | away3d.core.math
Class | public class Matrix3DUtils
Inheritance | Matrix3DUtils Inheritance Object

Matrix3DUtils provides additional Matrix3D math functions.

Public Methods
Method |  | Defined By
 | compare(m1:Matrix3D, m2:Matrix3D):Boolean [static] Returns a boolean value representing whether there is any significant difference between the two given 3d matrices. | Matrix3DUtils
 | getForward(m:Matrix3D, v:Vector3D = null):Vector3D [static] Returns a normalised Vector3D object representing the forward vector of the given matrix. | Matrix3DUtils
 | getRight(m:Matrix3D, v:Vector3D = null):Vector3D [static] Returns a normalised Vector3D object representing the right vector of the given matrix. | Matrix3DUtils
 | getUp(m:Matrix3D, v:Vector3D = null):Vector3D [static] Returns a normalised Vector3D object representing the up vector of the given matrix. | Matrix3DUtils
 | lookAt(matrix:Matrix3D, pos:Vector3D, dir:Vector3D, up:Vector3D):void [static] | Matrix3DUtils
 | quaternion2matrix(quarternion:Quaternion, m:Matrix3D = null):Matrix3D [static] Fills the 3d matrix object with values representing the transformation made by the given quaternion. | Matrix3DUtils
 | reflection(plane:Plane3D, target:Matrix3D = null):Matrix3D [static] | Matrix3DUtils
Public Constants
Constant |  | Defined By
 | RAW_DATA_CONTAINER : Vector.<Number> [static] A reference to a Vector to be used as a temporary raw data container, to prevent object creation. | Matrix3DUtils
Method Detail
compare () method
public static function compare(m1:Matrix3D, m2:Matrix3D):Boolean

Returns a boolean value representing whether there is any significant difference between the two given 3d matrices.

Parameters

m1:Matrix3D
m2:Matrix3D

Returns
Boolean
getForward () method
public static function getForward(m:Matrix3D, v:Vector3D = null):Vector3D

Returns a normalised Vector3D object representing the forward vector of the given matrix.

Parameters

m:Matrix3D — The Matrix3D object to use to get the forward vector
v:Vector3D (default = null) — [optional] A vector holder to prevent make new Vector3D instance if already exists. Default is null.

Returns
Vector3D — The forward vector
getRight () method
public static function getRight(m:Matrix3D, v:Vector3D = null):Vector3D

Returns a normalised Vector3D object representing the right vector of the given matrix.

Parameters

m:Matrix3D — The Matrix3D object to use to get the right vector
v:Vector3D (default = null) — [optional] A vector holder to prevent make new Vector3D instance if already exists. Default is null.

Returns
Vector3D — The right vector
getUp () method
public static function getUp(m:Matrix3D, v:Vector3D = null):Vector3D

Returns a normalised Vector3D object representing the up vector of the given matrix.

Parameters

m:Matrix3D — The Matrix3D object to use to get the up vector
v:Vector3D (default = null) — [optional] A vector holder to prevent make new Vector3D instance if already exists. Default is null.

Returns
Vector3D — The up vector
lookAt () method
public static function lookAt(matrix:Matrix3D, pos:Vector3D, dir:Vector3D, up:Vector3D):void

Parameters

matrix:Matrix3D
pos:Vector3D
dir:Vector3D
up:Vector3D

quaternion2matrix () method
public static function quaternion2matrix(quarternion:Quaternion, m:Matrix3D = null):Matrix3D

Fills the 3d matrix object with values representing the transformation made by the given quaternion.

Parameters

quarternion:Quaternion — The quarterion object to convert.
m:Matrix3D (default = null)

Returns
Matrix3D
reflection () method
public static function reflection(plane:Plane3D, target:Matrix3D = null):Matrix3D

Parameters

plane:Plane3D
target:Matrix3D (default = null)

Returns
Matrix3D
Constant Detail
RAW_DATA_CONTAINER Constant
public static const RAW_DATA_CONTAINER:Vector.<Number>

A reference to a Vector to be used as a temporary raw data container, to prevent object creation.


away3d.core.math.Plane3D

Plane3D | Properties | Methods | Constants
Package | away3d.core.math
Class | public class Plane3D
Inheritance | Plane3D Inheritance Object

Public Properties
Property |  | Defined By
 | a : Number The A coefficient of this plane. | Plane3D
 | b : Number The B coefficient of this plane. | Plane3D
 | c : Number The C coefficient of this plane. | Plane3D
 | d : Number The D coefficient of this plane. | Plane3D
Public Methods
Method |  | Defined By
 | Plane3D(a:Number = 0, b:Number = 0, c:Number = 0, d:Number = 0) Create a Plane3D with ABCD coefficients | Plane3D
 | classifyPoint(p:Vector3D, epsilon:Number = 0.01):int Classify a point against this Plane3D. | Plane3D
 | distance(p:Vector3D):Number Returns the signed distance between this Plane3D and the point p. | Plane3D
 | fromNormalAndPoint(normal:Vector3D, point:Vector3D):void Fills this Plane3D with the coefficients from the plane's normal and a point in 3d space. | Plane3D
 | fromPoints(p0:Vector3D, p1:Vector3D, p2:Vector3D):void Fills this Plane3D with the coefficients from 3 points in 3d space. | Plane3D
 | normalize():Plane3D Normalize this Plane3D | Plane3D
 | toString():String | Plane3D
Public Constants
Constant |  | Defined By
 | ALIGN_ANY : int = 0 [static] | Plane3D
 | ALIGN_XY_AXIS : int = 1 [static] | Plane3D
 | ALIGN_XZ_AXIS : int = 3 [static] | Plane3D
 | ALIGN_YZ_AXIS : int = 2 [static] | Plane3D
Property Detail
_alignment property
arcane var _alignment:int

a property
public var a:Number

The A coefficient of this plane. (Also the x dimension of the plane normal)

b property
public var b:Number

The B coefficient of this plane. (Also the y dimension of the plane normal)

c property
public var c:Number

The C coefficient of this plane. (Also the z dimension of the plane normal)

d property
public var d:Number

The D coefficient of this plane. (Also the inverse dot product between normal and point)

Constructor Detail
Plane3D () Constructor
public function Plane3D(a:Number = 0, b:Number = 0, c:Number = 0, d:Number = 0)

Create a Plane3D with ABCD coefficients

Parameters
a:Number (default = 0)
b:Number (default = 0)
c:Number (default = 0)
d:Number (default = 0)
Method Detail
classifyPoint () method
public function classifyPoint(p:Vector3D, epsilon:Number = 0.01):int

Classify a point against this Plane3D. (in front, back or intersecting)

Parameters

p:Vector3D — Vector3D
epsilon:Number (default = 0.01)

Returns
int — int Plane3.FRONT or Plane3D.BACK or Plane3D.INTERSECT
distance () method
public function distance(p:Vector3D):Number

Returns the signed distance between this Plane3D and the point p.

Parameters

p:Vector3D — Vector3D

Returns
Number
fromNormalAndPoint () method
public function fromNormalAndPoint(normal:Vector3D, point:Vector3D):void

Fills this Plane3D with the coefficients from the plane's normal and a point in 3d space.

Parameters

normal:Vector3D — Vector3D
point:Vector3D — Vector3D

fromPoints () method
public function fromPoints(p0:Vector3D, p1:Vector3D, p2:Vector3D):void

Fills this Plane3D with the coefficients from 3 points in 3d space.

Parameters

p0:Vector3D — Vector3D
p1:Vector3D — Vector3D
p2:Vector3D — Vector3D

normalize () method
public function normalize():Plane3D

Normalize this Plane3D

Returns
Plane3D — Plane3D This Plane3D.
toString () method
public function toString():String

Returns
String
Constant Detail
ALIGN_ANY Constant
public static const ALIGN_ANY:int = 0

ALIGN_XY_AXIS Constant
public static const ALIGN_XY_AXIS:int = 1

ALIGN_XZ_AXIS Constant
public static const ALIGN_XZ_AXIS:int = 3

ALIGN_YZ_AXIS Constant
public static const ALIGN_YZ_AXIS:int = 2


away3d.core.math.PlaneClassification

PlaneClassification | Constants
Package | away3d.core.math
Class | public class PlaneClassification
Inheritance | PlaneClassification Inheritance Object

Public Constants
Constant |  | Defined By
 | BACK : int = 0 [static] | PlaneClassification
 | FRONT : int = 1 [static] | PlaneClassification
 | IN : int = 0 [static] | PlaneClassification
 | INTERSECT : int = 2 [static] | PlaneClassification
 | OUT : int = 1 [static] | PlaneClassification
Constant Detail
BACK Constant
public static const BACK:int = 0

FRONT Constant
public static const FRONT:int = 1

IN Constant
public static const IN:int = 0

INTERSECT Constant
public static const INTERSECT:int = 2

OUT Constant
public static const OUT:int = 1


away3d.core.math.Quaternion

Quaternion | Properties | Methods
Package | away3d.core.math
Class | public final class Quaternion
Inheritance | Quaternion Inheritance Object

A Quaternion object which can be used to represent rotations.

Public Properties
Property |  | Defined By
 | magnitude : Number [read-only] Returns the magnitude of the quaternion object. | Quaternion
 | w : Number = 1 The w value of the quaternion. | Quaternion
 | x : Number = 0 The x value of the quaternion. | Quaternion
 | y : Number = 0 The y value of the quaternion. | Quaternion
 | z : Number = 0 The z value of the quaternion. | Quaternion
Public Methods
Method |  | Defined By
 | Quaternion(x:Number = 0, y:Number = 0, z:Number = 0, w:Number = 1) Creates a new Quaternion object. | Quaternion
 | clone():Quaternion Clones the quaternion. | Quaternion
 | copyFrom(q:Quaternion):void Copies the data from a quaternion into this instance. | Quaternion
 | fromAxisAngle(axis:Vector3D, angle:Number):void Fills the quaternion object with values representing the given rotation around a vector. | Quaternion
 | fromEulerAngles(ax:Number, ay:Number, az:Number):void Fills the quaternion object with values representing the given euler rotation. | Quaternion
 | fromMatrix(matrix:Matrix3D):void Extracts a quaternion rotation matrix out of a given Matrix3D object. | Quaternion
 | lerp(qa:Quaternion, qb:Quaternion, t:Number):void Linearly interpolates between two quaternions. | Quaternion
 | multiply(qa:Quaternion, qb:Quaternion):void Fills the quaternion object with the result from a multiplication of two quaternion objects. | Quaternion
 | multiplyVector(vector:Vector3D, target:Quaternion = null):Quaternion | Quaternion
 | normalize(val:Number = 1):void Normalises the quaternion object. | Quaternion
 | rotatePoint(vector:Vector3D, target:Vector3D = null):Vector3D Rotates a point. | Quaternion
 | slerp(qa:Quaternion, qb:Quaternion, t:Number):void Spherically interpolates between two quaternions, providing an interpolation between rotations with constant angle change rate. | Quaternion
 | toEulerAngles(target:Vector3D = null):Vector3D Fills a target Vector3D object with the Euler angles that form the rotation represented by this quaternion. | Quaternion
 | toMatrix3D(target:Matrix3D = null):Matrix3D Converts the quaternion to a Matrix3D object representing an equivalent rotation. | Quaternion
 | toRawData(target:Vector.<Number>, exclude4thRow:Boolean = false):void Converts the quaternion to a Vector.<Number> matrix representation of a rotation equivalent to this quaternion. | Quaternion
 | toString():String Used to trace the values of a quaternion. | Quaternion
Property Detail
magnitude property
magnitude:Number [read-only]

Returns the magnitude of the quaternion object.

Implementation
    public function get magnitude():Number
w property
public var w:Number = 1

The w value of the quaternion.

x property
public var x:Number = 0

The x value of the quaternion.

y property
public var y:Number = 0

The y value of the quaternion.

z property
public var z:Number = 0

The z value of the quaternion.

Constructor Detail
Quaternion () Constructor
public function Quaternion(x:Number = 0, y:Number = 0, z:Number = 0, w:Number = 1)

Creates a new Quaternion object.

Parameters
x:Number (default = 0) — The x value of the quaternion.
y:Number (default = 0) — The y value of the quaternion.
z:Number (default = 0) — The z value of the quaternion.
w:Number (default = 1) — The w value of the quaternion.
Method Detail
clone () method
public function clone():Quaternion

Clones the quaternion.

Returns
Quaternion — An exact duplicate of the current Quaternion.
copyFrom () method
public function copyFrom(q:Quaternion):void

Copies the data from a quaternion into this instance.

Parameters

q:Quaternion — The quaternion to copy from.

fromAxisAngle () method
public function fromAxisAngle(axis:Vector3D, angle:Number):void

Fills the quaternion object with values representing the given rotation around a vector.

Parameters

axis:Vector3D — The axis around which to rotate
angle:Number — The angle in radians of the rotation.

fromEulerAngles () method
public function fromEulerAngles(ax:Number, ay:Number, az:Number):void

Fills the quaternion object with values representing the given euler rotation.

Parameters

ax:Number — The angle in radians of the rotation around the ax axis.
ay:Number — The angle in radians of the rotation around the ay axis.
az:Number — The angle in radians of the rotation around the az axis.

fromMatrix () method
public function fromMatrix(matrix:Matrix3D):void

Extracts a quaternion rotation matrix out of a given Matrix3D object.

Parameters

matrix:Matrix3D — The Matrix3D out of which the rotation will be extracted.

lerp () method
public function lerp(qa:Quaternion, qb:Quaternion, t:Number):void

Linearly interpolates between two quaternions.

Parameters

qa:Quaternion — The first quaternion to interpolate.
qb:Quaternion — The second quaternion to interpolate.
t:Number — The interpolation weight, a value between 0 and 1.

multiply () method
public function multiply(qa:Quaternion, qb:Quaternion):void

Fills the quaternion object with the result from a multiplication of two quaternion objects.

Parameters

qa:Quaternion — The first quaternion in the multiplication.
qb:Quaternion — The second quaternion in the multiplication.

multiplyVector () method
public function multiplyVector(vector:Vector3D, target:Quaternion = null):Quaternion

Parameters

vector:Vector3D
target:Quaternion (default = null)

Returns
Quaternion
normalize () method
public function normalize(val:Number = 1):void

Normalises the quaternion object.

Parameters

val:Number (default = 1)

rotatePoint () method
public function rotatePoint(vector:Vector3D, target:Vector3D = null):Vector3D

Rotates a point.

Parameters

vector:Vector3D — The Vector3D object to be rotated.
target:Vector3D (default = null) — An optional Vector3D object that will contain the rotated coordinates. If not provided, a new object will be created.

Returns
Vector3D — A Vector3D object containing the rotated point.
slerp () method
public function slerp(qa:Quaternion, qb:Quaternion, t:Number):void

Spherically interpolates between two quaternions, providing an interpolation between rotations with constant angle change rate.

Parameters

qa:Quaternion — The first quaternion to interpolate.
qb:Quaternion — The second quaternion to interpolate.
t:Number — The interpolation weight, a value between 0 and 1.

toEulerAngles () method
public function toEulerAngles(target:Vector3D = null):Vector3D

Fills a target Vector3D object with the Euler angles that form the rotation represented by this quaternion.

Parameters

target:Vector3D (default = null) — An optional Vector3D object to contain the Euler angles. If not provided, a new object is created.

Returns
Vector3D — The Vector3D containing the Euler angles.
toMatrix3D () method
public function toMatrix3D(target:Matrix3D = null):Matrix3D

Converts the quaternion to a Matrix3D object representing an equivalent rotation.

Parameters

target:Matrix3D (default = null) — An optional Matrix3D container to store the transformation in. If not provided, a new object is created.

Returns
Matrix3D — A Matrix3D object representing an equivalent rotation.
toRawData () method
public function toRawData(target:Vector.<Number>, exclude4thRow:Boolean = false):void

Converts the quaternion to a Vector.<Number> matrix representation of a rotation equivalent to this quaternion.

Parameters

target:Vector.<Number> — The Vector.<Number> to contain the raw matrix data.
exclude4thRow:Boolean (default = false) — If true, the last row will be omitted, and a 4x3 matrix will be generated instead of a 4x4.

toString () method
public function toString():String

Used to trace the values of a quaternion.

Returns
String — A string representation of the quaternion object.


away3d.core.math.Vector3DUtils

Vector3DUtils | Methods
Package | away3d.core.math
Class | public class Vector3DUtils
Inheritance | Vector3DUtils Inheritance Object

Vector3DUtils provides additional Vector3D math functions.

Public Methods
Method |  | Defined By
 | getAngle(w:Vector3D, q:Vector3D):Number [static] Returns the angle in radians made between the 3d number obejct and the given Vector3D object. | Vector3DUtils
 | matrix2euler(m1:Matrix3D):Vector3D [static] Returns a Vector3D object with the euler angles represented by the 3x3 matrix rotation of the given Matrix3D object. | Vector3DUtils
 | matrix2scale(m:Matrix3D):Vector3D [static] Returns a Vector3D object containing the scale values represented by the given Matrix3D object. | Vector3DUtils
 | quaternion2euler(quarternion:Quaternion):Vector3D [static] Returns a Vector3D object containing the euler angles represented by the given Quaternion object. | Vector3DUtils
 | rotatePoint(aPoint:Vector3D, rotation:Vector3D):Vector3D [static] | Vector3DUtils
 | subdivide(startVal:Vector3D, endVal:Vector3D, numSegments:int):Vector.<Vector3D> [static] | Vector3DUtils
Method Detail
getAngle () method
public static function getAngle(w:Vector3D, q:Vector3D):Number

Returns the angle in radians made between the 3d number obejct and the given Vector3D object.

Parameters

w:Vector3D — The first 3d number object to use in the calculation.
q:Vector3D — The first 3d number object to use in the calculation.

Returns
Number — An angle in radians representing the angle between the two Vector3D objects.
matrix2euler () method
public static function matrix2euler(m1:Matrix3D):Vector3D

Returns a Vector3D object with the euler angles represented by the 3x3 matrix rotation of the given Matrix3D object.

Parameters

m1:Matrix3D — The 3d matrix object to use in the calculation.

Returns
Vector3D — A 3d vector representing the euler angles extracted from the 3d matrix.
matrix2scale () method
public static function matrix2scale(m:Matrix3D):Vector3D

Returns a Vector3D object containing the scale values represented by the given Matrix3D object.

Parameters

m:Matrix3D — The 3d matrix object to use in the calculation.

Returns
Vector3D — A 3d vector representing the axis scale values extracted from the 3d matrix.
quaternion2euler () method
public static function quaternion2euler(quarternion:Quaternion):Vector3D

Returns a Vector3D object containing the euler angles represented by the given Quaternion object.

Parameters

quarternion:Quaternion — The quaternion object to use in the calculation.

Returns
Vector3D — A 3d vector representing the euler angles extracted from the quaternion.
rotatePoint () method
public static function rotatePoint(aPoint:Vector3D, rotation:Vector3D):Vector3D

Parameters

aPoint:Vector3D
rotation:Vector3D

Returns
Vector3D
subdivide () method
public static function subdivide(startVal:Vector3D, endVal:Vector3D, numSegments:int):Vector.<Vector3D>

Parameters

startVal:Vector3D
endVal:Vector3D
numSegments:int

Returns
Vector.<Vector3D>


away3d.core.partition - Away3D Documentation

Package away3d.core.partition

Classes
CameraNode
DirectionalLightNode
DynamicGrid
EntityNode
InvertedOctreeNode
LightNode
LightProbeNode
MeshNode
NodeBase
NullNode
Octree
OctreeNode
Partition3D
PointLightNode
QuadTree
QuadTreeNode
RenderableNode
SkyBoxNode
ViewVolume
ViewVolumePartition
ViewVolumeRootNode


away3d.core.partition Summary

away3d.core.partition | Classes

Classes
Class | Description
CameraNode | CameraNode is a space partitioning leaf node that contains a Camera3D object.
DirectionalLightNode | LightNode is a space partitioning leaf node that contains a LightBase object.
DynamicGrid | DynamicGrid is used by certain partitioning systems that require vislists for regions of dynamic data.
EntityNode | The EntityNode class provides an abstract base class for leaf nodes in a partition tree, containing entities to be fed to the EntityCollector traverser.
InvertedOctreeNode | InvertedOctreeNode is an octree data structure not used hierarchically for culling, but for fast dynamic insertion.
LightNode | LightNode is a space partitioning leaf node that contains a LightBase object.
LightProbeNode | LightNode is a space partitioning leaf node that contains a LightBase object.
MeshNode | MeshNode is a space partitioning leaf node that contains a Mesh object.
NodeBase | The NodeBase class is an abstract base class for any type of space partition tree node.
NullNode | NullNode is a node that performs no space partitioning, but simply stores all objects in a list of leaf nodes.
Octree |
OctreeNode |
Partition3D | Partition3D is the core of a space partition system.
PointLightNode | LightNode is a space partitioning leaf node that contains a LightBase object.
QuadTree |
QuadTreeNode |
RenderableNode | RenderableNode is a space partitioning leaf node that contains any Entity that is itself a IRenderable object.
SkyBoxNode | SkyBoxNode is a space partitioning leaf node that contains a SkyBox object.
ViewVolume |
ViewVolumePartition |
ViewVolumeRootNode |

Thu Nov 15 2012, 12:09 PM Z


away3d.core.partition.CameraNode

CameraNode | Properties | Methods
Package | away3d.core.partition
Class | public class CameraNode
Inheritance | CameraNode Inheritance EntityNode Inheritance NodeBase Inheritance Object

CameraNode is a space partitioning leaf node that contains a Camera3D object.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | entity : Entity [read-only] The entity contained in this leaf node. | EntityNode
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CameraNode(camera:Camera3D) Creates a new CameraNode object. | CameraNode
 | acceptTraverser(traverser:PartitionTraverser):void [override] Allows the traverser to visit the current node. | CameraNode
Inherited | findPartitionForEntity(entity:Entity):NodeBase Finds the partition that contains (or should contain) the given entity. | NodeBase
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
Inherited | removeFromParent():void Detaches the node from its parent. | EntityNode
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createDebugBounds():WireframePrimitiveBase | NodeBase
Inherited | isInFrustumImpl(camera:Camera3D):Boolean [override] | EntityNode
Inherited | updateNumEntities(value:int):void | NodeBase
Constructor Detail
CameraNode () Constructor
public function CameraNode(camera:Camera3D)

Creates a new CameraNode object.

Parameters
camera:Camera3D — The camera to be contained in the node.
Method Detail
acceptTraverser () method
override public function acceptTraverser(traverser:PartitionTraverser):void

Allows the traverser to visit the current node. If the traverser's enterNode method returns true, the traverser will be sent down the child nodes of the tree. This method should be overridden if the order of traversal is important (such as for BSP trees) - or if static child nodes are not added using addNode, but are linked to separately.

Parameters

traverser:PartitionTraverser — The traverser visiting the node.


away3d.core.partition.DirectionalLightNode

DirectionalLightNode | Properties | Methods
Package | away3d.core.partition
Class | public class DirectionalLightNode
Inheritance | DirectionalLightNode Inheritance EntityNode Inheritance NodeBase Inheritance Object

LightNode is a space partitioning leaf node that contains a LightBase object.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | entity : Entity [read-only] The entity contained in this leaf node. | EntityNode
 | light : DirectionalLight [read-only] The light object contained in this node. | DirectionalLightNode
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DirectionalLightNode(light:DirectionalLight) Creates a new LightNode object. | DirectionalLightNode
 | acceptTraverser(traverser:PartitionTraverser):void [override] Allows the traverser to visit the current node. | DirectionalLightNode
Inherited | findPartitionForEntity(entity:Entity):NodeBase Finds the partition that contains (or should contain) the given entity. | NodeBase
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
Inherited | removeFromParent():void Detaches the node from its parent. | EntityNode
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createDebugBounds():WireframePrimitiveBase | NodeBase
Inherited | isInFrustumImpl(camera:Camera3D):Boolean [override] | EntityNode
Inherited | updateNumEntities(value:int):void | NodeBase
Property Detail
light property
light:DirectionalLight [read-only]

The light object contained in this node.

Implementation
    public function get light():DirectionalLight
Constructor Detail
DirectionalLightNode () Constructor
public function DirectionalLightNode(light:DirectionalLight)

Creates a new LightNode object.

Parameters
light:DirectionalLight — The light to be contained in the node.
Method Detail
acceptTraverser () method
override public function acceptTraverser(traverser:PartitionTraverser):void

Allows the traverser to visit the current node. If the traverser's enterNode method returns true, the traverser will be sent down the child nodes of the tree. This method should be overridden if the order of traversal is important (such as for BSP trees) - or if static child nodes are not added using addNode, but are linked to separately.

Parameters

traverser:PartitionTraverser — The traverser visiting the node.


away3d.core.partition.DynamicGrid

DynamicGrid | Properties | Methods
Package | away3d.core.partition
Class | public class DynamicGrid
Inheritance | DynamicGrid Inheritance Object

DynamicGrid is used by certain partitioning systems that require vislists for regions of dynamic data.

Public Properties
Property |  | Defined By
 | numCellsX : uint [read-only] | DynamicGrid
 | numCellsY : uint [read-only] | DynamicGrid
 | numCellsZ : uint [read-only] | DynamicGrid
 | showDebugBounds : Boolean | DynamicGrid
Public Methods
Method |  | Defined By
 | DynamicGrid(minBounds:Vector3D, maxBounds:Vector3D, numCellsX:uint, numCellsY:uint, numCellsZ:uint) | DynamicGrid
 | findPartitionForEntity(entity:Entity):NodeBase | DynamicGrid
 | getCellAt(x:uint, y:uint, z:uint):InvertedOctreeNode | DynamicGrid
 | getCellsIntersecting(minBounds:Vector3D, maxBounds:Vector3D):Vector.<InvertedOctreeNode> | DynamicGrid
Property Detail
numCellsX property
numCellsX:uint [read-only]

Implementation
    public function get numCellsX():uint
numCellsY property
numCellsY:uint [read-only]

Implementation
    public function get numCellsY():uint
numCellsZ property
numCellsZ:uint [read-only]

Implementation
    public function get numCellsZ():uint
showDebugBounds property
showDebugBounds:Boolean

Implementation
    public function get showDebugBounds():Boolean
    public function set showDebugBounds(value:Boolean):void
Constructor Detail
DynamicGrid () Constructor
public function DynamicGrid(minBounds:Vector3D, maxBounds:Vector3D, numCellsX:uint, numCellsY:uint, numCellsZ:uint)

Parameters
minBounds:Vector3D
maxBounds:Vector3D
numCellsX:uint
numCellsY:uint
numCellsZ:uint
Method Detail
findPartitionForEntity () method
public function findPartitionForEntity(entity:Entity):NodeBase

Parameters

entity:Entity

Returns
NodeBase
getCellAt () method
public function getCellAt(x:uint, y:uint, z:uint):InvertedOctreeNode

Parameters

x:uint
y:uint
z:uint

Returns
InvertedOctreeNode
getCellsIntersecting () method
public function getCellsIntersecting(minBounds:Vector3D, maxBounds:Vector3D):Vector.<InvertedOctreeNode>

Parameters

minBounds:Vector3D
maxBounds:Vector3D

Returns
Vector.<InvertedOctreeNode>


away3d.core.partition.EntityNode

EntityNode | Properties | Methods
Package | away3d.core.partition
Class | public class EntityNode
Inheritance | EntityNode Inheritance NodeBase Inheritance Object
Subclasses | CameraNode, DirectionalLightNode, LightNode, LightProbeNode, MeshNode, PointLightNode, RenderableNode, SkyBoxNode

The EntityNode class provides an abstract base class for leaf nodes in a partition tree, containing entities to be fed to the EntityCollector traverser. The concrete subtype of Entity is responsible for creating a matching subtype of EntityNode.

See also

away3d.scenegraph.Entity
away3d.core.traverse.EntityCollector

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | entity : Entity [read-only] The entity contained in this leaf node. | EntityNode
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | EntityNode(entity:Entity) Creates a new EntityNode object. | EntityNode
 | acceptTraverser(traverser:PartitionTraverser):void [override] Allows the traverser to visit the current node. | EntityNode
Inherited | findPartitionForEntity(entity:Entity):NodeBase Finds the partition that contains (or should contain) the given entity. | NodeBase
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
 | removeFromParent():void Detaches the node from its parent. | EntityNode
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createDebugBounds():WireframePrimitiveBase | NodeBase
 | isInFrustumImpl(camera:Camera3D):Boolean [override] | EntityNode
Inherited | updateNumEntities(value:int):void | NodeBase
Property Detail
entity property
entity:Entity [read-only]

The entity contained in this leaf node.

Implementation
    public function get entity():Entity
Constructor Detail
EntityNode () Constructor
public function EntityNode(entity:Entity)

Creates a new EntityNode object.

Parameters
entity:Entity — The Entity to be contained in this leaf node.
Method Detail
acceptTraverser () method
override public function acceptTraverser(traverser:PartitionTraverser):void

Allows the traverser to visit the current node. If the traverser's enterNode method returns true, the traverser will be sent down the child nodes of the tree. This method should be overridden if the order of traversal is important (such as for BSP trees) - or if static child nodes are not added using addNode, but are linked to separately.

Parameters

traverser:PartitionTraverser — The traverser visiting the node.

isInFrustumImpl () method
override protected function isInFrustumImpl(camera:Camera3D):Boolean

Parameters

camera:Camera3D

Returns
Boolean
removeFromParent () method
public function removeFromParent():void

Detaches the node from its parent.


away3d.core.partition.InvertedOctreeNode

InvertedOctreeNode | Properties | Methods
Package | away3d.core.partition
Class | public class InvertedOctreeNode
Inheritance | InvertedOctreeNode Inheritance NodeBase Inheritance Object

InvertedOctreeNode is an octree data structure not used hierarchically for culling, but for fast dynamic insertion. The data structure is essentially a grid, but "overarching" parent container nodes for entities striding across nodes. If this is visible, so is the parent. Traversal happens invertedly too.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | InvertedOctreeNode(minBounds:Vector3D, maxBounds:Vector3D) | InvertedOctreeNode
 | acceptTraverser(traverser:PartitionTraverser):void [override] | InvertedOctreeNode
Inherited | findPartitionForEntity(entity:Entity):NodeBase Finds the partition that contains (or should contain) the given entity. | NodeBase
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createDebugBounds():WireframePrimitiveBase [override] | InvertedOctreeNode
 | isInFrustumImpl(camera:Camera3D):Boolean [override] | InvertedOctreeNode
Inherited | updateNumEntities(value:int):void | NodeBase
Constructor Detail
InvertedOctreeNode () Constructor
public function InvertedOctreeNode(minBounds:Vector3D, maxBounds:Vector3D)

Parameters
minBounds:Vector3D
maxBounds:Vector3D
Method Detail
acceptTraverser () method
override public function acceptTraverser(traverser:PartitionTraverser):void

Parameters

traverser:PartitionTraverser

createDebugBounds () method
override protected function createDebugBounds():WireframePrimitiveBase

Returns
WireframePrimitiveBase
isInFrustumImpl () method
override protected function isInFrustumImpl(camera:Camera3D):Boolean

Parameters

camera:Camera3D

Returns
Boolean
setParent () method
arcane function setParent(value:InvertedOctreeNode):void

Parameters

value:InvertedOctreeNode


away3d.core.partition.LightNode

LightNode | Properties | Methods
Package | away3d.core.partition
Class | public class LightNode
Inheritance | LightNode Inheritance EntityNode Inheritance NodeBase Inheritance Object

LightNode is a space partitioning leaf node that contains a LightBase object. Used for lights that are not of default supported type.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | entity : Entity [read-only] The entity contained in this leaf node. | EntityNode
 | light : LightBase [read-only] The light object contained in this node. | LightNode
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | LightNode(light:LightBase) Creates a new LightNode object. | LightNode
 | acceptTraverser(traverser:PartitionTraverser):void [override] Allows the traverser to visit the current node. | LightNode
Inherited | findPartitionForEntity(entity:Entity):NodeBase Finds the partition that contains (or should contain) the given entity. | NodeBase
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
Inherited | removeFromParent():void Detaches the node from its parent. | EntityNode
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createDebugBounds():WireframePrimitiveBase | NodeBase
Inherited | isInFrustumImpl(camera:Camera3D):Boolean [override] | EntityNode
Inherited | updateNumEntities(value:int):void | NodeBase
Property Detail
light property
light:LightBase [read-only]

The light object contained in this node.

Implementation
    public function get light():LightBase
Constructor Detail
LightNode () Constructor
public function LightNode(light:LightBase)

Creates a new LightNode object.

Parameters
light:LightBase — The light to be contained in the node.
Method Detail
acceptTraverser () method
override public function acceptTraverser(traverser:PartitionTraverser):void

Allows the traverser to visit the current node. If the traverser's enterNode method returns true, the traverser will be sent down the child nodes of the tree. This method should be overridden if the order of traversal is important (such as for BSP trees) - or if static child nodes are not added using addNode, but are linked to separately.

Parameters

traverser:PartitionTraverser — The traverser visiting the node.


away3d.core.partition.LightProbeNode

LightProbeNode | Properties | Methods
Package | away3d.core.partition
Class | public class LightProbeNode
Inheritance | LightProbeNode Inheritance EntityNode Inheritance NodeBase Inheritance Object

LightNode is a space partitioning leaf node that contains a LightBase object.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | entity : Entity [read-only] The entity contained in this leaf node. | EntityNode
 | light : LightProbe [read-only] The light object contained in this node. | LightProbeNode
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | LightProbeNode(light:LightProbe) Creates a new LightNode object. | LightProbeNode
 | acceptTraverser(traverser:PartitionTraverser):void [override] Allows the traverser to visit the current node. | LightProbeNode
Inherited | findPartitionForEntity(entity:Entity):NodeBase Finds the partition that contains (or should contain) the given entity. | NodeBase
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
Inherited | removeFromParent():void Detaches the node from its parent. | EntityNode
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createDebugBounds():WireframePrimitiveBase | NodeBase
Inherited | isInFrustumImpl(camera:Camera3D):Boolean [override] | EntityNode
Inherited | updateNumEntities(value:int):void | NodeBase
Property Detail
light property
light:LightProbe [read-only]

The light object contained in this node.

Implementation
    public function get light():LightProbe
Constructor Detail
LightProbeNode () Constructor
public function LightProbeNode(light:LightProbe)

Creates a new LightNode object.

Parameters
light:LightProbe — The light to be contained in the node.
Method Detail
acceptTraverser () method
override public function acceptTraverser(traverser:PartitionTraverser):void

Allows the traverser to visit the current node. If the traverser's enterNode method returns true, the traverser will be sent down the child nodes of the tree. This method should be overridden if the order of traversal is important (such as for BSP trees) - or if static child nodes are not added using addNode, but are linked to separately.

Parameters

traverser:PartitionTraverser — The traverser visiting the node.


away3d.core.partition.MeshNode

MeshNode | Properties | Methods
Package | away3d.core.partition
Class | public class MeshNode
Inheritance | MeshNode Inheritance EntityNode Inheritance NodeBase Inheritance Object

MeshNode is a space partitioning leaf node that contains a Mesh object.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | entity : Entity [read-only] The entity contained in this leaf node. | EntityNode
 | mesh : Mesh [read-only] The mesh object contained in the partition node. | MeshNode
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | MeshNode(mesh:Mesh) Creates a new MeshNode object. | MeshNode
 | acceptTraverser(traverser:PartitionTraverser):void [override] Allows the traverser to visit the current node. | MeshNode
Inherited | findPartitionForEntity(entity:Entity):NodeBase Finds the partition that contains (or should contain) the given entity. | NodeBase
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
Inherited | removeFromParent():void Detaches the node from its parent. | EntityNode
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createDebugBounds():WireframePrimitiveBase | NodeBase
Inherited | isInFrustumImpl(camera:Camera3D):Boolean [override] | EntityNode
Inherited | updateNumEntities(value:int):void | NodeBase
Property Detail
mesh property
mesh:Mesh [read-only]

The mesh object contained in the partition node.

Implementation
    public function get mesh():Mesh
Constructor Detail
MeshNode () Constructor
public function MeshNode(mesh:Mesh)

Creates a new MeshNode object.

Parameters
mesh:Mesh — The mesh to be contained in the node.
Method Detail
acceptTraverser () method
override public function acceptTraverser(traverser:PartitionTraverser):void

Allows the traverser to visit the current node. If the traverser's enterNode method returns true, the traverser will be sent down the child nodes of the tree. This method should be overridden if the order of traversal is important (such as for BSP trees) - or if static child nodes are not added using addNode, but are linked to separately.

Parameters

traverser:PartitionTraverser — The traverser visiting the node.


away3d.core.partition.NodeBase

NodeBase | Properties | Methods
Package | away3d.core.partition
Class | public class NodeBase
Inheritance | NodeBase Inheritance Object
Subclasses | EntityNode, InvertedOctreeNode, NullNode, OctreeNode, QuadTreeNode, ViewVolume, ViewVolumeRootNode

The NodeBase class is an abstract base class for any type of space partition tree node. The concrete subtype will control the creation of its child nodes, which are necessarily of the same type. The exception is the creation of leaf entity nodes, which is handled by the Partition3D class.

See also

away3d.partition.EntityNode
away3d.partition.Partition3D
away3d.containers.Scene3D

Public Properties
Property |  | Defined By
 | parent : NodeBase [read-only] The parent node. | NodeBase
 | showDebugBounds : Boolean | NodeBase
Protected Properties
Property |  | Defined By
 | _childNodes : Vector.<NodeBase> | NodeBase
 | _debugPrimitive : WireframePrimitiveBase | NodeBase
 | _numChildNodes : uint | NodeBase
 | numEntities : int [read-only] | NodeBase
Public Methods
Method |  | Defined By
 | NodeBase() Creates a new NodeBase object. | NodeBase
 | acceptTraverser(traverser:PartitionTraverser):void Allows the traverser to visit the current node. | NodeBase
 | findPartitionForEntity(entity:Entity):NodeBase Finds the partition that contains (or should contain) the given entity. | NodeBase
 | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
Protected Methods
Method |  | Defined By
 | createDebugBounds():WireframePrimitiveBase | NodeBase
 | isInFrustumImpl(camera:Camera3D):Boolean | NodeBase
 | updateNumEntities(value:int):void | NodeBase
Property Detail
_childNodes property
protected var _childNodes:Vector.<NodeBase>

_collectionMark property
arcane var _collectionMark:uint

_debugPrimitive property
protected var _debugPrimitive:WireframePrimitiveBase

_numChildNodes property
protected var _numChildNodes:uint

_numEntities property
arcane var _numEntities:int

_parent property
arcane var _parent:NodeBase

numEntities property
numEntities:int [read-only]

Implementation
    protected function get numEntities():int
parent property
parent:NodeBase [read-only]

The parent node. Null if this node is the root.

Implementation
    public function get parent():NodeBase
showDebugBounds property
showDebugBounds:Boolean

Implementation
    public function get showDebugBounds():Boolean
    public function set showDebugBounds(value:Boolean):void
Constructor Detail
NodeBase () Constructor
public function NodeBase()

Creates a new NodeBase object.

Method Detail
acceptTraverser () method
public function acceptTraverser(traverser:PartitionTraverser):void

Allows the traverser to visit the current node. If the traverser's enterNode method returns true, the traverser will be sent down the child nodes of the tree. This method should be overridden if the order of traversal is important (such as for BSP trees) - or if static child nodes are not added using addNode, but are linked to separately.

Parameters

traverser:PartitionTraverser — The traverser visiting the node.

See also

away3d.core.traverse.PartitionTraverser
addNode () method
arcane function addNode(node:NodeBase):void

Adds a node to the tree. By default, this is used for both static as dynamic nodes, but for some data structures such as BSP trees, it can be more efficient to only use this for dynamic nodes, and add the static child nodes using custom links.

Parameters

node:NodeBase — The node to be added as a child of the current node.

createDebugBounds () method
protected function createDebugBounds():WireframePrimitiveBase

Returns
WireframePrimitiveBase
findPartitionForEntity () method
public function findPartitionForEntity(entity:Entity):NodeBase

Finds the partition that contains (or should contain) the given entity.

Parameters

entity:Entity

Returns
NodeBase
isInFrustum () method
public function isInFrustum(camera:Camera3D):Boolean

Tests if the current node is at least partly inside the frustum.

Parameters

camera:Camera3D — The raw data of the view projection matrix

Returns
Boolean — Whether or not the node is at least partly inside the view frustum.
isInFrustumImpl () method
protected function isInFrustumImpl(camera:Camera3D):Boolean

Parameters

camera:Camera3D

Returns
Boolean
removeNode () method
arcane function removeNode(node:NodeBase):void

Removes a child node from the tree.

Parameters

node:NodeBase — The child node to be removed.

updateNumEntities () method
protected function updateNumEntities(value:int):void

Parameters

value:int


away3d.core.partition.NullNode

NullNode | Properties | Methods
Package | away3d.core.partition
Class | public class NullNode
Inheritance | NullNode Inheritance NodeBase Inheritance Object

NullNode is a node that performs no space partitioning, but simply stores all objects in a list of leaf nodes. This partitioning system is most useful for simple content, or content that is always in the screen, such as a 3d user interface.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | NullNode() Creates a new NullNode object. | NullNode
Inherited | acceptTraverser(traverser:PartitionTraverser):void Allows the traverser to visit the current node. | NodeBase
Inherited | findPartitionForEntity(entity:Entity):NodeBase Finds the partition that contains (or should contain) the given entity. | NodeBase
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createDebugBounds():WireframePrimitiveBase | NodeBase
Inherited | isInFrustumImpl(camera:Camera3D):Boolean | NodeBase
Inherited | updateNumEntities(value:int):void | NodeBase
Constructor Detail
NullNode () Constructor
public function NullNode()

Creates a new NullNode object.


away3d.core.partition.Octree

Octree | Properties | Methods
Package | away3d.core.partition
Class | public class Octree
Inheritance | Octree Inheritance Partition3D Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | showDebugBounds : Boolean | Partition3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _rootNode : NodeBase | Partition3D
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Octree(maxDepth:int, size:Number) | Octree
Inherited | traverse(traverser:PartitionTraverser):void Sends a traverser through the partition tree. | Partition3D
Constructor Detail
Octree () Constructor
public function Octree(maxDepth:int, size:Number)

Parameters
maxDepth:int
size:Number


away3d.core.partition.OctreeNode

OctreeNode | Properties | Methods
Package | away3d.core.partition
Class | public class OctreeNode
Inheritance | OctreeNode Inheritance NodeBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | OctreeNode(maxDepth:int = 5, size:Number = 10000, centerX:Number = 0, centerY:Number = 0, centerZ:Number = 0, depth:int = 0) | OctreeNode
Inherited | acceptTraverser(traverser:PartitionTraverser):void Allows the traverser to visit the current node. | NodeBase
 | findPartitionForEntity(entity:Entity):NodeBase [override] | OctreeNode
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createDebugBounds():WireframePrimitiveBase [override] | OctreeNode
 | isInFrustumImpl(camera:Camera3D):Boolean [override] | OctreeNode
Inherited | updateNumEntities(value:int):void | NodeBase
Constructor Detail
OctreeNode () Constructor
public function OctreeNode(maxDepth:int = 5, size:Number = 10000, centerX:Number = 0, centerY:Number = 0, centerZ:Number = 0, depth:int = 0)

Parameters
maxDepth:int (default = 5)
size:Number (default = 10000)
centerX:Number (default = 0)
centerY:Number (default = 0)
centerZ:Number (default = 0)
depth:int (default = 0)
Method Detail
createDebugBounds () method
override protected function createDebugBounds():WireframePrimitiveBase

Returns
WireframePrimitiveBase
findPartitionForEntity () method
override public function findPartitionForEntity(entity:Entity):NodeBase

Parameters

entity:Entity

Returns
NodeBase
isInFrustumImpl () method
override protected function isInFrustumImpl(camera:Camera3D):Boolean

Parameters

camera:Camera3D

Returns
Boolean


away3d.core.partition.Partition3D

Partition3D | Properties | Methods
Package | away3d.core.partition
Class | public class Partition3D
Inheritance | Partition3D Inheritance Object
Subclasses | Octree, QuadTree, ViewVolumePartition

Partition3D is the core of a space partition system. The space partition system typically subdivides the 3D scene hierarchically into a number of non-overlapping subspaces, forming a tree data structure. This is used to more efficiently perform frustum culling, potential visibility determination and collision detection.

Public Properties
Property |  | Defined By
 | showDebugBounds : Boolean | Partition3D
Protected Properties
Property |  | Defined By
 | _rootNode : NodeBase | Partition3D
Public Methods
Method |  | Defined By
 | Partition3D(rootNode:NodeBase) Creates a new Partition3D object. | Partition3D
 | traverse(traverser:PartitionTraverser):void Sends a traverser through the partition tree. | Partition3D
Property Detail
_rootNode property
protected var _rootNode:NodeBase

showDebugBounds property
showDebugBounds:Boolean

Implementation
    public function get showDebugBounds():Boolean
    public function set showDebugBounds(value:Boolean):void
Constructor Detail
Partition3D () Constructor
public function Partition3D(rootNode:NodeBase)

Creates a new Partition3D object.

Parameters
rootNode:NodeBase — The root node of the space partition system. This will indicate which type of data structure will be used.
Method Detail
markForUpdate () method
arcane function markForUpdate(entity:Entity):void

Mark a scene graph entity for updating. This will trigger a reassignment within the tree, based on the object's bounding box, upon the next traversal.

Parameters

entity:Entity — The entity to be updated in the tree.

removeEntity () method
arcane function removeEntity(entity:Entity):void

Removes an entity from the partition tree.

Parameters

entity:Entity — The entity to be removed.

traverse () method
public function traverse(traverser:PartitionTraverser):void

Sends a traverser through the partition tree.

Parameters

traverser:PartitionTraverser

See also

away3d.core.traverse.PartitionTraverser


away3d.core.partition.PointLightNode

PointLightNode | Properties | Methods
Package | away3d.core.partition
Class | public class PointLightNode
Inheritance | PointLightNode Inheritance EntityNode Inheritance NodeBase Inheritance Object

LightNode is a space partitioning leaf node that contains a LightBase object.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | entity : Entity [read-only] The entity contained in this leaf node. | EntityNode
 | light : PointLight [read-only] The light object contained in this node. | PointLightNode
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | PointLightNode(light:PointLight) Creates a new LightNode object. | PointLightNode
 | acceptTraverser(traverser:PartitionTraverser):void [override] Allows the traverser to visit the current node. | PointLightNode
Inherited | findPartitionForEntity(entity:Entity):NodeBase Finds the partition that contains (or should contain) the given entity. | NodeBase
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
Inherited | removeFromParent():void Detaches the node from its parent. | EntityNode
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createDebugBounds():WireframePrimitiveBase | NodeBase
Inherited | isInFrustumImpl(camera:Camera3D):Boolean [override] | EntityNode
Inherited | updateNumEntities(value:int):void | NodeBase
Property Detail
light property
light:PointLight [read-only]

The light object contained in this node.

Implementation
    public function get light():PointLight
Constructor Detail
PointLightNode () Constructor
public function PointLightNode(light:PointLight)

Creates a new LightNode object.

Parameters
light:PointLight — The light to be contained in the node.
Method Detail
acceptTraverser () method
override public function acceptTraverser(traverser:PartitionTraverser):void

Allows the traverser to visit the current node. If the traverser's enterNode method returns true, the traverser will be sent down the child nodes of the tree. This method should be overridden if the order of traversal is important (such as for BSP trees) - or if static child nodes are not added using addNode, but are linked to separately.

Parameters

traverser:PartitionTraverser — The traverser visiting the node.


away3d.core.partition.QuadTree

QuadTree | Properties | Methods
Package | away3d.core.partition
Class | public class QuadTree
Inheritance | QuadTree Inheritance Partition3D Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | showDebugBounds : Boolean | Partition3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _rootNode : NodeBase | Partition3D
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | QuadTree(maxDepth:int, size:Number, height:Number = 1000000) | QuadTree
Inherited | traverse(traverser:PartitionTraverser):void Sends a traverser through the partition tree. | Partition3D
Constructor Detail
QuadTree () Constructor
public function QuadTree(maxDepth:int, size:Number, height:Number = 1000000)

Parameters
maxDepth:int
size:Number
height:Number (default = 1000000)


away3d.core.partition.QuadTreeNode

QuadTreeNode | Properties | Methods
Package | away3d.core.partition
Class | public class QuadTreeNode
Inheritance | QuadTreeNode Inheritance NodeBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | QuadTreeNode(maxDepth:int = 5, size:Number = 10000, height:Number = 1000000, centerX:Number = 0, centerZ:Number = 0, depth:int = 0) | QuadTreeNode
Inherited | acceptTraverser(traverser:PartitionTraverser):void Allows the traverser to visit the current node. | NodeBase
 | findPartitionForEntity(entity:Entity):NodeBase [override] | QuadTreeNode
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createDebugBounds():WireframePrimitiveBase | NodeBase
 | isInFrustumImpl(camera:Camera3D):Boolean [override] | QuadTreeNode
Inherited | updateNumEntities(value:int):void | NodeBase
Constructor Detail
QuadTreeNode () Constructor
public function QuadTreeNode(maxDepth:int = 5, size:Number = 10000, height:Number = 1000000, centerX:Number = 0, centerZ:Number = 0, depth:int = 0)

Parameters
maxDepth:int (default = 5)
size:Number (default = 10000)
height:Number (default = 1000000)
centerX:Number (default = 0)
centerZ:Number (default = 0)
depth:int (default = 0)
Method Detail
findPartitionForEntity () method
override public function findPartitionForEntity(entity:Entity):NodeBase

Parameters

entity:Entity

Returns
NodeBase
isInFrustumImpl () method
override protected function isInFrustumImpl(camera:Camera3D):Boolean

Parameters

camera:Camera3D

Returns
Boolean


away3d.core.partition.RenderableNode

RenderableNode | Properties | Methods
Package | away3d.core.partition
Class | public class RenderableNode
Inheritance | RenderableNode Inheritance EntityNode Inheritance NodeBase Inheritance Object

RenderableNode is a space partitioning leaf node that contains any Entity that is itself a IRenderable object. This excludes Mesh (since the renderable objects are its SubMesh children).

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | entity : Entity [read-only] The entity contained in this leaf node. | EntityNode
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | RenderableNode(renderable:IRenderable) Creates a new RenderableNode object. | RenderableNode
 | acceptTraverser(traverser:PartitionTraverser):void [override] Allows the traverser to visit the current node. | RenderableNode
Inherited | findPartitionForEntity(entity:Entity):NodeBase Finds the partition that contains (or should contain) the given entity. | NodeBase
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
Inherited | removeFromParent():void Detaches the node from its parent. | EntityNode
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createDebugBounds():WireframePrimitiveBase | NodeBase
Inherited | isInFrustumImpl(camera:Camera3D):Boolean [override] | EntityNode
Inherited | updateNumEntities(value:int):void | NodeBase
Constructor Detail
RenderableNode () Constructor
public function RenderableNode(renderable:IRenderable)

Creates a new RenderableNode object.

Parameters
renderable:IRenderable — The mesh to be contained in the node.
Method Detail
acceptTraverser () method
override public function acceptTraverser(traverser:PartitionTraverser):void

Allows the traverser to visit the current node. If the traverser's enterNode method returns true, the traverser will be sent down the child nodes of the tree. This method should be overridden if the order of traversal is important (such as for BSP trees) - or if static child nodes are not added using addNode, but are linked to separately.

Parameters

traverser:PartitionTraverser — The traverser visiting the node.


away3d.core.partition.SkyBoxNode

SkyBoxNode | Properties | Methods
Package | away3d.core.partition
Class | public class SkyBoxNode
Inheritance | SkyBoxNode Inheritance EntityNode Inheritance NodeBase Inheritance Object

SkyBoxNode is a space partitioning leaf node that contains a SkyBox object.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | entity : Entity [read-only] The entity contained in this leaf node. | EntityNode
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkyBoxNode(skyBox:SkyBox) Creates a new SkyBoxNode object. | SkyBoxNode
 | acceptTraverser(traverser:PartitionTraverser):void [override] Allows the traverser to visit the current node. | SkyBoxNode
Inherited | findPartitionForEntity(entity:Entity):NodeBase Finds the partition that contains (or should contain) the given entity. | NodeBase
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
Inherited | removeFromParent():void Detaches the node from its parent. | EntityNode
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createDebugBounds():WireframePrimitiveBase | NodeBase
 | isInFrustumImpl(camera:Camera3D):Boolean [override] | SkyBoxNode
Inherited | updateNumEntities(value:int):void | NodeBase
Constructor Detail
SkyBoxNode () Constructor
public function SkyBoxNode(skyBox:SkyBox)

Creates a new SkyBoxNode object.

Parameters
skyBox:SkyBox — The SkyBox to be contained in the node.
Method Detail
acceptTraverser () method
override public function acceptTraverser(traverser:PartitionTraverser):void

Allows the traverser to visit the current node. If the traverser's enterNode method returns true, the traverser will be sent down the child nodes of the tree. This method should be overridden if the order of traversal is important (such as for BSP trees) - or if static child nodes are not added using addNode, but are linked to separately.

Parameters

traverser:PartitionTraverser — The traverser visiting the node.

isInFrustumImpl () method
override protected function isInFrustumImpl(camera:Camera3D):Boolean

Parameters

camera:Camera3D

Returns
Boolean


away3d.core.partition.ViewVolume

ViewVolume | Properties | Methods
Package | away3d.core.partition
Class | public class ViewVolume
Inheritance | ViewVolume Inheritance NodeBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | depth : Number [read-only] | ViewVolume
 | height : Number [read-only] | ViewVolume
 | maxBound : Vector3D [read-only] | ViewVolume
 | maxX : Number [read-only] | ViewVolume
 | maxY : Number [read-only] | ViewVolume
 | maxZ : Number [read-only] | ViewVolume
 | minBound : Vector3D [read-only] | ViewVolume
 | minX : Number [read-only] | ViewVolume
 | minY : Number [read-only] | ViewVolume
 | minZ : Number [read-only] | ViewVolume
 | numCellsX : uint [read-only] | ViewVolume
 | numCellsY : uint [read-only] | ViewVolume
 | numCellsZ : uint [read-only] | ViewVolume
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
Inherited | showDebugBounds : Boolean | NodeBase
 | width : Number [read-only] | ViewVolume
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined By
ViewVolume(minBound:Vector3D, maxBound:Vector3D, cellSize:Number = -1)
Creates a new ViewVolume with given dimensions.
ViewVolume
acceptTraverser(traverser:PartitionTraverser):void
[override]
ViewVolume
addVisibleDynamicCell(cell:InvertedOctreeNode, indexX:uint = 0, indexY:uint = 0, indexZ:uint = 0):void
ViewVolume
addVisibleRegion(minBounds:Vector3D, maxBounds:Vector3D, scene:Scene3D, dynamicGrid:DynamicGrid = null, indexX:uint = 0, indexY:uint = 0, indexZ:uint = 0):void
Adds all static geometry in a scene that intersects a given region, as well as the dynamic grid if provided.
ViewVolume
addVisibleStatic(entity:Entity, indexX:uint = 0, indexY:uint = 0, indexZ:uint = 0):void
ViewVolume
addVisibleViewVolume(viewVolume:ViewVolume, scene:Scene3D, dynamicGrid:DynamicGrid = null):void
A shortcut method for addVisibleRegion, that adds static geometry in a scene that intersects a given viewvolume, as well as the dynamic grid if provided.
ViewVolume
contains(entryPoint:Vector3D):Boolean
ViewVolume
Inherited
findPartitionForEntity(entity:Entity):NodeBase
Finds the partition that contains (or should contain) the given entity.
NodeBase
Inherited
isInFrustum(camera:Camera3D):Boolean
Tests if the current node is at least partly inside the frustum.
NodeBase
markCellAccessible(indexX:uint, indexY:uint, indexZ:uint):void
Enable the use of a cell.
ViewVolume
markCellInaccessible(indexX:uint, indexY:uint, indexZ:uint):void
Disables the use of a cell.
ViewVolume
removeVisibleDynamicCell(cell:InvertedOctreeNode, indexX:uint = 0, indexY:uint = 0, indexZ:uint = 0):void
ViewVolume
removeVisibleStatic(entity:Entity, indexX:uint = 0, indexY:uint = 0, indexZ:uint = 0):void
ViewVolume
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createDebugBounds():WireframePrimitiveBase [override] | ViewVolume
Inherited | isInFrustumImpl(camera:Camera3D):Boolean | NodeBase
Inherited | updateNumEntities(value:int):void | NodeBase
Property Detail
_active property
arcane var _active:Boolean

depth property
depth:Number [read-only]

Implementation
    public function get depth():Number
height property
height:Number [read-only]

Implementation
    public function get height():Number
maxBound property
maxBound:Vector3D [read-only]

Implementation
    public function get maxBound():Vector3D
maxX property
maxX:Number [read-only]

Implementation
    public function get maxX():Number
maxY property
maxY:Number [read-only]

Implementation
    public function get maxY():Number
maxZ property
maxZ:Number [read-only]

Implementation
    public function get maxZ():Number
minBound property
minBound:Vector3D [read-only]

Implementation
    public function get minBound():Vector3D
minX property
minX:Number [read-only]

Implementation
    public function get minX():Number
minY property
minY:Number [read-only]

Implementation
    public function get minY():Number
minZ property
minZ:Number [read-only]

Implementation
    public function get minZ():Number
numCellsX property
numCellsX:uint [read-only]

Implementation
    public function get numCellsX():uint
numCellsY property
numCellsY:uint [read-only]

Implementation
    public function get numCellsY():uint
numCellsZ property
numCellsZ:uint [read-only]

Implementation
    public function get numCellsZ():uint
width property
width:Number [read-only]

Implementation
    public function get width():Number
Constructor Detail
ViewVolume () Constructor
public function ViewVolume(minBound:Vector3D, maxBound:Vector3D, cellSize:Number = -1)

Creates a new ViewVolume with given dimensions. A ViewVolume is a region where the camera or a shadow casting light could reside in.

Parameters
minBound:Vector3D — The minimum boundaries of the view volume (the bottom-left-near corner)
maxBound:Vector3D — The maximum boundaries of the view volume (the top-right-far corner)
cellSize:Number (default = -1) — The size of cell subdivisions for the view volume. The default value is -1, meaning the view volume will not be subdivided. This is the value that should usually be used when setting visibility info manually.
Method Detail
acceptTraverser () method
override public function acceptTraverser(traverser:PartitionTraverser):void

Parameters

traverser:PartitionTraverser

addVisibleDynamicCell () method
public function addVisibleDynamicCell(cell:InvertedOctreeNode, indexX:uint = 0, indexY:uint = 0, indexZ:uint = 0):void

Parameters

cell:InvertedOctreeNode
indexX:uint (default = 0)
indexY:uint (default = 0)
indexZ:uint (default = 0)

addVisibleRegion () method
public function addVisibleRegion(minBounds:Vector3D, maxBounds:Vector3D, scene:Scene3D, dynamicGrid:DynamicGrid = null, indexX:uint = 0, indexY:uint = 0, indexZ:uint = 0):void

Adds all static geometry in a scene that intersects a given region, as well as the dynamic grid if provided.

Parameters

minBounds:Vector3D — The minimum bounds of the region to be considered visible
maxBounds:Vector3D — The maximum bounds of the region to be considered visible
scene:Scene3D — The Scene3D object containing the static objects to be added.
dynamicGrid:DynamicGrid (default = null) — The DynamicGrid belonging to the partition this will be used with
indexX:uint (default = 0) — An optional index for the cell within ViewVolume. If created with gridSize -1, this is typically avoided.
indexY:uint (default = 0) — An optional index for the cell within ViewVolume. If created with gridSize -1, this is typically avoided.
indexZ:uint (default = 0) — An optional index for the cell within ViewVolume. If created with gridSize -1, this is typically avoided.

addVisibleStatic () method
public function addVisibleStatic(entity:Entity, indexX:uint = 0, indexY:uint = 0, indexZ:uint = 0):void

Parameters

entity:Entity
indexX:uint (default = 0)
indexY:uint (default = 0)
indexZ:uint (default = 0)

addVisibleViewVolume () method
public function addVisibleViewVolume(viewVolume:ViewVolume, scene:Scene3D, dynamicGrid:DynamicGrid = null):void

A shortcut method for addVisibleRegion, that adds static geometry in a scene that intersects a given viewvolume, as well as the dynamic grid if provided.

Parameters

viewVolume:ViewVolume — The viewVolume providing the region
scene:Scene3D — The Scene3D object containing the static objects to be added.
dynamicGrid:DynamicGrid (default = null) — The DynamicGrid belonging to the partition this will be used with

contains () method
public function contains(entryPoint:Vector3D):Boolean

Parameters

entryPoint:Vector3D

Returns
Boolean
createDebugBounds () method
override protected function createDebugBounds():WireframePrimitiveBase

Returns
WireframePrimitiveBase
markCellAccessible () method
public function markCellAccessible(indexX:uint, indexY:uint, indexZ:uint):void

Enable the use of a cell. Do this if the camera or casting light can potentially be in this cell. If the ViewVolume was constructed with gridSize -1, it does not need to be called

Parameters

indexX:uint — The x-index of the cell
indexY:uint — The y-index of the cell
indexZ:uint — The z-index of the cell

markCellInaccessible () method
public function markCellInaccessible(indexX:uint, indexY:uint, indexZ:uint):void

Disables the use of a cell. Do this only if the camera or casting light can never be in this cell.

Parameters

indexX:uint — The x-index of the cell
indexY:uint — The y-index of the cell
indexZ:uint — The z-index of the cell

removeVisibleDynamicCell () method
public function removeVisibleDynamicCell(cell:InvertedOctreeNode, indexX:uint = 0, indexY:uint = 0, indexZ:uint = 0):void

Parameters

cell:InvertedOctreeNode
indexX:uint (default = 0)
indexY:uint (default = 0)
indexZ:uint (default = 0)

removeVisibleStatic () method
public function removeVisibleStatic(entity:Entity, indexX:uint = 0, indexY:uint = 0, indexZ:uint = 0):void

Parameters

entity:Entity
indexX:uint (default = 0)
indexY:uint (default = 0)
indexZ:uint (default = 0)


away3d.core.partition.ViewVolumePartition

ViewVolumePartition | Properties | Methods
Package | away3d.core.partition
Class | public class ViewVolumePartition
Inheritance | ViewVolumePartition Inheritance Partition3D Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | dynamicGrid : DynamicGrid A dynamic grid to be able to determine visibility of dynamic objects. | ViewVolumePartition
Inherited | showDebugBounds : Boolean | Partition3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _rootNode : NodeBase | Partition3D
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ViewVolumePartition() | ViewVolumePartition
 | addViewVolume(viewVolume:ViewVolume):void Adds a view volume to provide visibility info for a given region. | ViewVolumePartition
 | removeViewVolume(viewVolume:ViewVolume):void | ViewVolumePartition
Inherited | traverse(traverser:PartitionTraverser):void Sends a traverser through the partition tree. | Partition3D
Property Detail
dynamicGrid property
dynamicGrid:DynamicGrid

A dynamic grid to be able to determine visibility of dynamic objects. If none is provided, dynamic objects are only frustum-culled. If provided, ViewVolumes need to have visible grid cells assigned from the same DynamicGrid instance.

Implementation
    public function get dynamicGrid():DynamicGrid
    public function set dynamicGrid(value:DynamicGrid):void
Constructor Detail
ViewVolumePartition () Constructor
public function ViewVolumePartition()

Method Detail
addViewVolume () method
public function addViewVolume(viewVolume:ViewVolume):void

Adds a view volume to provide visibility info for a given region.

Parameters

viewVolume:ViewVolume

markForUpdate () method
override arcane function markForUpdate(entity:Entity):void

Parameters

entity:Entity

removeViewVolume () method
public function removeViewVolume(viewVolume:ViewVolume):void

Parameters

viewVolume:ViewVolume


away3d.core.partition.ViewVolumeRootNode

ViewVolumeRootNode | Properties | Methods
Package | away3d.core.partition
Class | public class ViewVolumeRootNode
Inheritance | ViewVolumeRootNode Inheritance NodeBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | dynamicGrid : DynamicGrid | ViewVolumeRootNode
Inherited | parent : NodeBase [read-only] The parent node. | NodeBase
 | showDebugBounds : Boolean [override] | ViewVolumeRootNode
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _childNodes : Vector.<NodeBase> | NodeBase
Inherited | _debugPrimitive : WireframePrimitiveBase | NodeBase
Inherited | _numChildNodes : uint | NodeBase
Inherited | numEntities : int [read-only] | NodeBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ViewVolumeRootNode() | ViewVolumeRootNode
 | acceptTraverser(traverser:PartitionTraverser):void [override] | ViewVolumeRootNode
 | addViewVolume(viewVolume:ViewVolume):void | ViewVolumeRootNode
 | findPartitionForEntity(entity:Entity):NodeBase [override] | ViewVolumeRootNode
Inherited | isInFrustum(camera:Camera3D):Boolean Tests if the current node is at least partly inside the frustum. | NodeBase
 | removeViewVolume(viewVolume:ViewVolume):void | ViewVolumeRootNode
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createDebugBounds():WireframePrimitiveBase | NodeBase
Inherited | isInFrustumImpl(camera:Camera3D):Boolean | NodeBase
Inherited | updateNumEntities(value:int):void | NodeBase
Property Detail
dynamicGrid property
dynamicGrid:DynamicGrid

Implementation
    public function get dynamicGrid():DynamicGrid
    public function set dynamicGrid(value:DynamicGrid):void
showDebugBounds property
showDebugBounds:Boolean[override]

Implementation
    public function get showDebugBounds():Boolean
    public function set showDebugBounds(value:Boolean):void
Constructor Detail
ViewVolumeRootNode () Constructor
public function ViewVolumeRootNode()

Method Detail
acceptTraverser () method
override public function acceptTraverser(traverser:PartitionTraverser):void

Parameters

traverser:PartitionTraverser

addViewVolume () method
public function addViewVolume(viewVolume:ViewVolume):void

Parameters

viewVolume:ViewVolume

findPartitionForEntity () method
override public function findPartitionForEntity(entity:Entity):NodeBase

Parameters

entity:Entity

Returns
NodeBase
removeViewVolume () method
public function removeViewVolume(viewVolume:ViewVolume):void

Parameters

viewVolume:ViewVolume


away3d.core.pick - Away3D Documentation

Package away3d.core.pick

Interfaces
IPicker
IPickingCollider
Classes
AS3PickingCollider
AutoPickingCollider
PBPickingCollider
PickingColliderBase
PickingColliderType
PickingCollisionVO
PickingType
RaycastPicker
ShaderPicker


away3d.core.pick Summary

away3d.core.pick | Interfaces | Classes

Interfaces
Interface | Description
IPicker | Provides an interface for picking objects that can pick 3d objects from a view or scene.
IPickingCollider | Provides an interface for picking colliders that can be assigned to individual entities in a scene for specific picking behaviour.
Classes
Class | Description
AS3PickingCollider | Pure AS3 picking collider for entity objects.
AutoPickingCollider | Auto-selecting picking collider for entity objects.
PBPickingCollider | PixelBender-based picking collider for entity objects.
PickingColliderBase | An abstract base class for all picking collider classes.
PickingColliderType | Options for setting a picking collider for entity objects.
PickingCollisionVO | Value object for a picking collision returned by a picking collider.
PickingType | Options for the different 3D object picking approaches available in Away3D.
RaycastPicker | Picks a 3d object from a view or scene by 3D raycast calculations.
ShaderPicker | Picks a 3d object from a view or scene by performing a separate render pass on the scene around the area being picked using key color values, then reading back the color value of the pixel in the render representing the picking ray.

Thu Nov 15 2012, 12:09 PM Z


away3d.core.pick.AS3PickingCollider

AS3PickingCollider | Methods
Package | away3d.core.pick
Class | public class AS3PickingCollider
Inheritance | AS3PickingCollider Inheritance PickingColliderBase Inheritance Object
Implements | IPickingCollider

Pure AS3 picking collider for entity objects. Used with the RaycastPicker picking object.

See also

away3d.entities.Entity.pickingCollider
away3d.core.pick.RaycastPicker

Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | rayDirection : Vector3D | PickingColliderBase
Inherited | rayPosition : Vector3D | PickingColliderBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | AS3PickingCollider(findClosestCollision:Boolean = false) Creates a new AS3PickingCollider object. | AS3PickingCollider
Inherited | setLocalRay(localPosition:Vector3D, localDirection:Vector3D):void | PickingColliderBase
 | testSubMeshCollision(subMesh:SubMesh, pickingCollisionVO:PickingCollisionVO, shortestCollisionDistance:Number, ignoreFacesLookingAway:Boolean):Boolean Tests a SubMesh object for a collision with the picking ray. | AS3PickingCollider
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | getCollisionNormal(indexData:Vector.<uint>, vertexData:Vector.<Number>, triangleIndex:uint):Vector3D | PickingColliderBase
Inherited | getCollisionUV(indexData:Vector.<uint>, uvData:Vector.<Number>, triangleIndex:uint, v:Number, w:Number, u:Number, uvOffset:uint, uvStride:uint):Point | PickingColliderBase
Constructor Detail
AS3PickingCollider () Constructor
public function AS3PickingCollider(findClosestCollision:Boolean = false)

Creates a new AS3PickingCollider object.

Parameters
findClosestCollision:Boolean (default = false) — Determines whether the picking collider searches for the closest collision along the ray. Defaults to false.
Method Detail
testSubMeshCollision () method
public function testSubMeshCollision(subMesh:SubMesh, pickingCollisionVO:PickingCollisionVO, shortestCollisionDistance:Number, ignoreFacesLookingAway:Boolean):Boolean

Tests a SubMesh object for a collision with the picking ray.

Parameters

subMesh:SubMesh — The SubMesh instance to be tested.
pickingCollisionVO:PickingCollisionVO — The collision object used to store the collision results
shortestCollisionDistance:Number — The current value of the shortest distance to a detected collision along the ray.
ignoreFacesLookingAway:Boolean

Returns
Boolean


away3d.core.pick.AutoPickingCollider

AutoPickingCollider | Properties | Methods
Package | away3d.core.pick
Class | public class AutoPickingCollider
Inheritance | AutoPickingCollider Inheritance Object
Implements | IPickingCollider

Auto-selecting picking collider for entity objects. Used with the RaycastPicker picking object. Chooses between pure AS3 picking and PixelBender picking based on a threshold property representing the number of triangles encountered in a SubMesh object over which PixelBender is used.

See also

away3d.entities.Entity.pickingCollider
away3d.core.pick.RaycastPicker

Public Properties
Property |  | Defined By
 | triangleThreshold : uint = 1024 Represents the number of triangles encountered in a SubMesh object over which PixelBender is used. | AutoPickingCollider
Public Methods
Method |  | Defined By
 | AutoPickingCollider(findClosestCollision:Boolean = false) Creates a new AutoPickingCollider object. | AutoPickingCollider
 | setLocalRay(localPosition:Vector3D, localDirection:Vector3D):void Sets the position and direction of a picking ray in local coordinates to the entity. | AutoPickingCollider
 | testSubMeshCollision(subMesh:SubMesh, pickingCollisionVO:PickingCollisionVO, shortestCollisionDistance:Number, ignoreFacesLookingAway:Boolean):Boolean Tests a SubMesh object for a collision with the picking ray. | AutoPickingCollider
Property Detail
triangleThreshold property
public var triangleThreshold:uint = 1024

Represents the number of triangles encountered in a SubMesh object over which PixelBender is used.

Constructor Detail
AutoPickingCollider () Constructor
public function AutoPickingCollider(findClosestCollision:Boolean = false)

Creates a new AutoPickingCollider object.

Parameters
findClosestCollision:Boolean (default = false) — Determines whether the picking collider searches for the closest collision along the ray. Defaults to false.
Method Detail
setLocalRay () method
public function setLocalRay(localPosition:Vector3D, localDirection:Vector3D):void

Sets the position and direction of a picking ray in local coordinates to the entity.

Parameters

localPosition:Vector3D — The position vector in local coordinates
localDirection:Vector3D — The direction vector in local coordinates

testSubMeshCollision () method
public function testSubMeshCollision(subMesh:SubMesh, pickingCollisionVO:PickingCollisionVO, shortestCollisionDistance:Number, ignoreFacesLookingAway:Boolean):Boolean

Tests a SubMesh object for a collision with the picking ray.

Parameters

subMesh:SubMesh — The SubMesh instance to be tested.
pickingCollisionVO:PickingCollisionVO — The collision object used to store the collision results
shortestCollisionDistance:Number — The current value of the shortest distance to a detected collision along the ray.
ignoreFacesLookingAway:Boolean

Returns
Boolean


away3d.core.pick.IPicker

IPicker | Methods
Package | away3d.core.pick
Interface | public interface IPicker
Implementors | RaycastPicker, ShaderPicker

Provides an interface for picking objects that can pick 3d objects from a view or scene.

Public Methods
Method |  | Defined By
 | getSceneCollision(position:Vector3D, direction:Vector3D, scene:Scene3D):PickingCollisionVO Gets the collision object from the scene position and direction of the picking ray. | IPicker
 | getViewCollision(x:Number, y:Number, view:View3D):PickingCollisionVO Gets the collision object from the screen coordinates of the picking ray. | IPicker
Method Detail
getSceneCollision () method
public function getSceneCollision(position:Vector3D, direction:Vector3D, scene:Scene3D):PickingCollisionVO

Gets the collision object from the scene position and direction of the picking ray.

Parameters

position:Vector3D — The position of the picking ray in scene-space.
direction:Vector3D — The direction of the picking ray in scene-space.
scene:Scene3D — The scene on which the picking object acts.

Returns
PickingCollisionVO
getViewCollision () method
public function getViewCollision(x:Number, y:Number, view:View3D):PickingCollisionVO

Gets the collision object from the screen coordinates of the picking ray.

Parameters

x:Number — The x coordinate of the picking ray in screen-space.
y:Number — The y coordinate of the picking ray in screen-space.
view:View3D — The view on which the picking object acts.

Returns
PickingCollisionVO


away3d.core.pick.IPickingCollider

IPickingCollider | Methods
Package | away3d.core.pick
Interface | public interface IPickingCollider
Implementors | AS3PickingCollider, AutoPickingCollider, PBPickingCollider

Provides an interface for picking colliders that can be assigned to individual entities in a scene for specific picking behaviour. Used with the RaycastPicker picking object.

See also

away3d.entities.Entity.pickingCollider
away3d.core.pick.RaycastPicker

Public Methods
Method |  | Defined By
 | setLocalRay(localPosition:Vector3D, localDirection:Vector3D):void Sets the position and direction of a picking ray in local coordinates to the entity. | IPickingCollider
 | testSubMeshCollision(subMesh:SubMesh, pickingCollisionVO:PickingCollisionVO, shortestCollisionDistance:Number, ignoreFacesLookingAway:Boolean):Boolean Tests a SubMesh object for a collision with the picking ray. | IPickingCollider
Method Detail
setLocalRay () method
public function setLocalRay(localPosition:Vector3D, localDirection:Vector3D):void

Sets the position and direction of a picking ray in local coordinates to the entity.

Parameters

localPosition:Vector3D — The position vector in local coordinates
localDirection:Vector3D — The direction vector in local coordinates

testSubMeshCollision () method
public function testSubMeshCollision(subMesh:SubMesh, pickingCollisionVO:PickingCollisionVO, shortestCollisionDistance:Number, ignoreFacesLookingAway:Boolean):Boolean

Tests a SubMesh object for a collision with the picking ray.

Parameters

subMesh:SubMesh — The SubMesh instance to be tested.
pickingCollisionVO:PickingCollisionVO — The collision object used to store the collision results
shortestCollisionDistance:Number — The current value of the shortest distance to a detected collision along the ray.
ignoreFacesLookingAway:Boolean

Returns
Boolean


away3d.core.pick.PBPickingCollider

PBPickingCollider | Methods
Package | away3d.core.pick
Class | public class PBPickingCollider
Inheritance | PBPickingCollider Inheritance PickingColliderBase Inheritance Object
Implements | IPickingCollider

PixelBender-based picking collider for entity objects. Used with the RaycastPicker picking object.

See also

away3d.entities.Entity.pickingCollider
away3d.core.pick.RaycastPicker

Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | rayDirection : Vector3D | PickingColliderBase
Inherited | rayPosition : Vector3D | PickingColliderBase
Public Methods
Method |  | Defined By
 | PBPickingCollider(findClosestCollision:Boolean = false) Creates a new PBPickingCollider object. | PBPickingCollider
 | setLocalRay(localPosition:Vector3D, localDirection:Vector3D):void [override] Sets the position and direction of a picking ray in local coordinates to the entity. | PBPickingCollider
 | testSubMeshCollision(subMesh:SubMesh, pickingCollisionVO:PickingCollisionVO, shortestCollisionDistance:Number, ignoreFacesLookingAway:Boolean):Boolean Tests a SubMesh object for a collision with the picking ray. | PBPickingCollider
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | getCollisionNormal(indexData:Vector.<uint>, vertexData:Vector.<Number>, triangleIndex:uint):Vector3D | PickingColliderBase
Inherited | getCollisionUV(indexData:Vector.<uint>, uvData:Vector.<Number>, triangleIndex:uint, v:Number, w:Number, u:Number, uvOffset:uint, uvStride:uint):Point | PickingColliderBase
Constructor Detail
PBPickingCollider () Constructor
public function PBPickingCollider(findClosestCollision:Boolean = false)

Creates a new PBPickingCollider object.

Parameters
findClosestCollision:Boolean (default = false) — Determines whether the picking collider searches for the closest collision along the ray. Defaults to false.
Method Detail
setLocalRay () method
override public function setLocalRay(localPosition:Vector3D, localDirection:Vector3D):void

Sets the position and direction of a picking ray in local coordinates to the entity.

Parameters

localPosition:Vector3D — The position vector in local coordinates
localDirection:Vector3D — The direction vector in local coordinates

testSubMeshCollision () method
public function testSubMeshCollision(subMesh:SubMesh, pickingCollisionVO:PickingCollisionVO, shortestCollisionDistance:Number, ignoreFacesLookingAway:Boolean):Boolean

Tests a SubMesh object for a collision with the picking ray.

Parameters

subMesh:SubMesh — The SubMesh instance to be tested.
pickingCollisionVO:PickingCollisionVO — The collision object used to store the collision results
shortestCollisionDistance:Number — The current value of the shortest distance to a detected collision along the ray.
ignoreFacesLookingAway:Boolean

Returns
Boolean


away3d.core.pick.PickingColliderBase

PickingColliderBase | Properties | Methods
Package | away3d.core.pick
Class | public class PickingColliderBase
Inheritance | PickingColliderBase Inheritance Object
Subclasses | AS3PickingCollider, PBPickingCollider

An abstract base class for all picking collider classes. It should not be instantiated directly.

Protected Properties
Property |  | Defined By
 | rayDirection : Vector3D | PickingColliderBase
 | rayPosition : Vector3D | PickingColliderBase
Public Methods
Method |  | Defined By
 | setLocalRay(localPosition:Vector3D, localDirection:Vector3D):void | PickingColliderBase
Protected Methods
Method |  | Defined By
 | getCollisionNormal(indexData:Vector.<uint>, vertexData:Vector.<Number>, triangleIndex:uint):Vector3D | PickingColliderBase
 | getCollisionUV(indexData:Vector.<uint>, uvData:Vector.<Number>, triangleIndex:uint, v:Number, w:Number, u:Number, uvOffset:uint, uvStride:uint):Point | PickingColliderBase
Property Detail
rayDirection property
protected var rayDirection:Vector3D

rayPosition property
protected var rayPosition:Vector3D

Method Detail
getCollisionNormal () method
protected function getCollisionNormal(indexData:Vector.<uint>, vertexData:Vector.<Number>, triangleIndex:uint):Vector3D

Parameters

indexData:Vector.<uint>
vertexData:Vector.<Number>
triangleIndex:uint

Returns
Vector3D
getCollisionUV () method
protected function getCollisionUV(indexData:Vector.<uint>, uvData:Vector.<Number>, triangleIndex:uint, v:Number, w:Number, u:Number, uvOffset:uint, uvStride:uint):Point

Parameters

indexData:Vector.<uint>
uvData:Vector.<Number>
triangleIndex:uint
v:Number
w:Number
u:Number
uvOffset:uint
uvStride:uint

Returns
Point
setLocalRay () method
public function setLocalRay(localPosition:Vector3D, localDirection:Vector3D):void

Parameters

localPosition:Vector3D
localDirection:Vector3D


away3d.core.pick.PickingColliderType

PickingColliderType | Constants
Package | away3d.core.pick
Class | public class PickingColliderType
Inheritance | PickingColliderType Inheritance Object

Options for setting a picking collider for entity objects. Used with the RaycastPicker picking object.

See also

away3d.entities.Entity.pickingCollider
away3d.core.pick.RaycastPicker

Public Constants
Constant |  | Defined By
 | AS3_BEST_HIT : IPickingCollider [static] Pure AS3 picking collider that returns the best (closest) hit on an Entity. | PickingColliderType
 | AS3_FIRST_ENCOUNTERED : IPickingCollider [static] Pure AS3 picking collider that returns the first encountered hit on an Entity. | PickingColliderType
 | AUTO_BEST_HIT : IPickingCollider [static] Auto-selecting picking collider that returns the best (closest) hit on an Entity Chooses between pure AS3 picking and PixelBender picking based on a threshold property representing the number of triangles encountered in a SubMesh object over which PixelBender is used. | PickingColliderType
 | AUTO_FIRST_ENCOUNTERED : IPickingCollider [static] Auto-selecting picking collider that returns the first encountered hit on an Entity. | PickingColliderType
 | BOUNDS_ONLY : IPickingCollider = null [static] Default null collider that forces picker to only use entity bounds for hit calculations on an Entity | PickingColliderType
 | PB_BEST_HIT : IPickingCollider [static] PixelBender-based picking collider that returns the best (closest) hit on an Entity. | PickingColliderType
 | PB_FIRST_ENCOUNTERED : IPickingCollider [static] PixelBender-based picking collider that returns the first encountered hit on an Entity. | PickingColliderType
Constant Detail
AS3_BEST_HIT Constant
public static const AS3_BEST_HIT:IPickingCollider

Pure AS3 picking collider that returns the best (closest) hit on an Entity. Useful for low poly meshes and applying to many mesh instances.

See also

away3d.core.pick.AS3PickingCollider
AS3_FIRST_ENCOUNTERED Constant
public static const AS3_FIRST_ENCOUNTERED:IPickingCollider

Pure AS3 picking collider that returns the first encountered hit on an Entity. Useful for low poly meshes and applying to many mesh instances.

See also

away3d.core.pick.AS3PickingCollider
AUTO_BEST_HIT Constant
public static const AUTO_BEST_HIT:IPickingCollider

Auto-selecting picking collider that returns the best (closest) hit on an Entity Chooses between pure AS3 picking and PixelBender picking based on a threshold property representing the number of triangles encountered in a SubMesh object over which PixelBender is used. Useful for picking meshes with a mixture of polycounts.

See also

away3d.core.pick.AutoPickingCollider
away3d.core.pick.AutoPickingCollider.triangleThreshold
AUTO_FIRST_ENCOUNTERED Constant
public static const AUTO_FIRST_ENCOUNTERED:IPickingCollider

Auto-selecting picking collider that returns the first encountered hit on an Entity. Chooses between pure AS3 picking and PixelBender picking based on a threshold property representing the number of triangles encountered in a SubMesh object over which PixelBender is used. Useful for picking meshes with a mixture of polycounts.

See also

away3d.core.pick.AutoPickingCollider
away3d.core.pick.AutoPickingCollider.triangleThreshold
BOUNDS_ONLY Constant
public static const BOUNDS_ONLY:IPickingCollider = null

Default null collider that forces picker to only use entity bounds for hit calculations on an Entity

PB_BEST_HIT Constant
public static const PB_BEST_HIT:IPickingCollider

PixelBender-based picking collider that returns the best (closest) hit on an Entity. Useful for fast picking high poly meshes on desktop devices. To use this, the SubGeometry must have its vertex data in separate buffers: use Geometry::convertToSeparateBuffers() to ensure this.

See also

away3d.core.pick.PBPickingCollider
PB_FIRST_ENCOUNTERED Constant
public static const PB_FIRST_ENCOUNTERED:IPickingCollider

PixelBender-based picking collider that returns the first encountered hit on an Entity. Useful for fast picking high poly meshes on desktop devices. To use this, the SubGeometry must have its vertex data in separate buffers: use Geometry::convertToSeparateBuffers() to ensure this.

See also

away3d.core.pick.PBPickingCollider


away3d.core.pick.PickingCollisionVO

PickingCollisionVO | Properties | Methods
Package | away3d.core.pick
Class | public class PickingCollisionVO
Inheritance | PickingCollisionVO Inheritance Object

Value object for a picking collision returned by a picking collider. Created as unique objects on entities

See also

away3d.entities.Entity.pickingCollisionVO
away3d.core.pick.IPickingCollider

Public Properties
Property |  | Defined By
 | entity : Entity The entity to which this collision object belongs. | PickingCollisionVO
 | localNormal : Vector3D The local normal vector at the position of the collision. | PickingCollisionVO
 | localPosition : Vector3D The local position of the collision on the entity's surface. | PickingCollisionVO
 | localRayDirection : Vector3D The direction of the colliding ray in local coordinates. | PickingCollisionVO
 | localRayPosition : Vector3D The starting position of the colliding ray in local coordinates. | PickingCollisionVO
 | rayEntryDistance : Number The distance along the ray from the starting position to the calculated intersection entry point with the entity. | PickingCollisionVO
 | rayOriginIsInsideBounds : Boolean Determines if the ray position is contained within the entity bounds. | PickingCollisionVO
 | renderable : IRenderable The IRenderable associated with a collision. | PickingCollisionVO
 | uv : Point The uv coordinate at the position of the collision. | PickingCollisionVO
Public Methods
Method |  | Defined By
 | PickingCollisionVO(entity:Entity) Creates a new PickingCollisionVO object. | PickingCollisionVO
Property Detail
entity property
public var entity:Entity

The entity to which this collision object belongs.

localNormal property
public var localNormal:Vector3D

The local normal vector at the position of the collision.

localPosition property
public var localPosition:Vector3D

The local position of the collision on the entity's surface.

localRayDirection property
public var localRayDirection:Vector3D

The direction of the colliding ray in local coordinates.

localRayPosition property
public var localRayPosition:Vector3D

The starting position of the colliding ray in local coordinates.

rayEntryDistance property
public var rayEntryDistance:Number

The distance along the ray from the starting position to the calculated intersection entry point with the entity.

rayOriginIsInsideBounds property
public var rayOriginIsInsideBounds:Boolean

Determines if the ray position is contained within the entity bounds.

See also

away3d.entities.Entity.bounds
renderable property
public var renderable:IRenderable

The IRenderable associated with a collision.

uv property
public var uv:Point

The uv coordinate at the position of the collision.

Constructor Detail
PickingCollisionVO () Constructor
public function PickingCollisionVO(entity:Entity)

Creates a new PickingCollisionVO object.

Parameters
entity:Entity — The entity to which this collision object belongs.


away3d.core.pick.PickingType

PickingType | Constants
Package | away3d.core.pick
Class | public class PickingType
Inheritance | PickingType Inheritance Object

Options for the different 3D object picking approaches available in Away3D. Can be used for automatic mouse picking on the view.

See also

away3d.containers.View3D.mousePicker

Public Constants
Constant |  | Defined By
 | RAYCAST_BEST_HIT : IPicker [static] Uses AS3 and Pixel Bender to pick objects based on ray intersection. | PickingType
 | RAYCAST_FIRST_ENCOUNTERED : IPicker [static] Uses AS3 and Pixel Bender to pick objects based on ray intersection. | PickingType
 | SHADER : IPicker [static] Uses a render pass to pick objects based on a key color that is read back into the engine. | PickingType
Constant Detail
RAYCAST_BEST_HIT Constant
public static const RAYCAST_BEST_HIT:IPicker

Uses AS3 and Pixel Bender to pick objects based on ray intersection. Returns the best (closest) hit on an Entity.

RAYCAST_FIRST_ENCOUNTERED Constant
public static const RAYCAST_FIRST_ENCOUNTERED:IPicker

Uses AS3 and Pixel Bender to pick objects based on ray intersection. Returns the hit on the first encountered Entity.

SHADER Constant
public static const SHADER:IPicker

Uses a render pass to pick objects based on a key color that is read back into the engine. Performance can be variable on some GPUs.


away3d.core.pick.RaycastPicker

RaycastPicker | Properties | Methods
Package | away3d.core.pick
Class | public class RaycastPicker
Inheritance | RaycastPicker Inheritance Object
Implements | IPicker

Picks a 3d object from a view or scene by 3D raycast calculations. Performs an initial coarse boundary calculation to return a subset of entities whose bounding volumes intersect with the specified ray, then triggers an optional picking collider on individual entity objects to further determine the precise values of the picking ray collision.

Protected Properties
Property |  | Defined By
 | _entities : Vector.<Entity> | RaycastPicker
 | _hasCollisions : Boolean | RaycastPicker
 | _numEntities : uint | RaycastPicker
Public Methods
Method |  | Defined By
 | RaycastPicker(findClosestCollision:Boolean) Creates a new RaycastPicker object. | RaycastPicker
 | getSceneCollision(position:Vector3D, direction:Vector3D, scene:Scene3D):PickingCollisionVO Gets the collision object from the scene position and direction of the picking ray. | RaycastPicker
 | getViewCollision(x:Number, y:Number, view:View3D):PickingCollisionVO Gets the collision object from the screen coordinates of the picking ray. | RaycastPicker
Property Detail
_entities property
protected var _entities:Vector.<Entity>

_hasCollisions property
protected var _hasCollisions:Boolean

_numEntities property
protected var _numEntities:uint

Constructor Detail
RaycastPicker () Constructor
public function RaycastPicker(findClosestCollision:Boolean)

Creates a new RaycastPicker object.

Parameters
findClosestCollision:Boolean — Determines whether the picker searches for the closest bounds collision along the ray, or simply returns the first collision encountered Defaults to false.
Method Detail
getSceneCollision () method
public function getSceneCollision(position:Vector3D, direction:Vector3D, scene:Scene3D):PickingCollisionVO

Gets the collision object from the scene position and direction of the picking ray.

Parameters

position:Vector3D — The position of the picking ray in scene-space.
direction:Vector3D — The direction of the picking ray in scene-space.
scene:Scene3D — The scene on which the picking object acts.

Returns
PickingCollisionVO
getViewCollision () method
public function getViewCollision(x:Number, y:Number, view:View3D):PickingCollisionVO

Gets the collision object from the screen coordinates of the picking ray.

Parameters

x:Number — The x coordinate of the picking ray in screen-space.
y:Number — The y coordinate of the picking ray in screen-space.
view:View3D — The view on which the picking object acts.

Returns
PickingCollisionVO


away3d.core.pick.ShaderPicker

ShaderPicker | Methods
Package | away3d.core.pick
Class | public class ShaderPicker
Inheritance | ShaderPicker Inheritance Object
Implements | IPicker

Picks a 3d object from a view or scene by performing a separate render pass on the scene around the area being picked using key color values, then reading back the color value of the pixel in the render representing the picking ray. Requires multiple passes and readbacks for retriving details on an entity that has its shaderPickingDetails property set to true. A read-back operation from any GPU is not a very efficient process, and the amount of processing used can vary significantly between different hardware.

See also

away3d.entities.Entity.shaderPickingDetails

Public Methods
Method |  | Defined By
 | ShaderPicker() Creates a new ShaderPicker object. | ShaderPicker
 | getSceneCollision(position:Vector3D, direction:Vector3D, scene:Scene3D):PickingCollisionVO Gets the collision object from the scene position and direction of the picking ray. | ShaderPicker
 | getViewCollision(x:Number, y:Number, view:View3D):PickingCollisionVO Gets the collision object from the screen coordinates of the picking ray. | ShaderPicker
Protected Methods
Method |  | Defined By
 | draw(entityCollector:EntityCollector, target:TextureBase):void | ShaderPicker
Constructor Detail
ShaderPicker () Constructor
public function ShaderPicker()

Creates a new ShaderPicker object.

Method Detail
draw () method
protected function draw(entityCollector:EntityCollector, target:TextureBase):void

Parameters

entityCollector:EntityCollector
target:TextureBase

getSceneCollision () method
public function getSceneCollision(position:Vector3D, direction:Vector3D, scene:Scene3D):PickingCollisionVO

Gets the collision object from the scene position and direction of the picking ray.

Parameters

position:Vector3D — The position of the picking ray in scene-space.
direction:Vector3D — The direction of the picking ray in scene-space.
scene:Scene3D — The scene on which the picking object acts.

Returns
PickingCollisionVO
getViewCollision () method
public function getViewCollision(x:Number, y:Number, view:View3D):PickingCollisionVO

Gets the collision object from the screen coordinates of the picking ray.

Parameters

x:Number — The x coordinate of the picking ray in screen-space.
y:Number — The y coordinate of the picking ray in screen-space.
view:View3D — The view on which the picking object acts.

Returns
PickingCollisionVO


away3d.core.render - Away3D Documentation

Package away3d.core.render

Classes
BackgroundImageRenderer
DefaultRenderer
DepthRenderer
Filter3DRenderer
PositionRenderer
RendererBase


away3d.core.render Summary

away3d.core.render | Classes

Classes
Class | Description
BackgroundImageRenderer |
DefaultRenderer | The DefaultRenderer class provides the default rendering method.
DepthRenderer | The DepthRenderer class renders 32-bit depth information encoded as RGBA
Filter3DRenderer |
PositionRenderer | The PositionRenderer renders normalized position coordinates.
RendererBase | RendererBase forms an abstract base class for classes that are used in the rendering pipeline to render geometry to the back buffer or a texture.

Thu Nov 15 2012, 12:09 PM Z


away3d.core.render.BackgroundImageRenderer

BackgroundImageRenderer | Properties | Methods
Package | away3d.core.render
Class | public class BackgroundImageRenderer
Inheritance | BackgroundImageRenderer Inheritance Object

Public Properties
Property |  | Defined By
 | stage3DProxy : Stage3DProxy | BackgroundImageRenderer
 | texture : Texture2DBase | BackgroundImageRenderer
Public Methods
Method |  | Defined By
 | BackgroundImageRenderer(stage3DProxy:Stage3DProxy) | BackgroundImageRenderer
 | dispose():void | BackgroundImageRenderer
 | render():void | BackgroundImageRenderer
Property Detail
stage3DProxy property
stage3DProxy:Stage3DProxy

Implementation
    public function get stage3DProxy():Stage3DProxy
    public function set stage3DProxy(value:Stage3DProxy):void
texture property
texture:Texture2DBase

Implementation
    public function get texture():Texture2DBase
    public function set texture(value:Texture2DBase):void
Constructor Detail
BackgroundImageRenderer () Constructor
public function BackgroundImageRenderer(stage3DProxy:Stage3DProxy)

Parameters
stage3DProxy:Stage3DProxy
Method Detail
dispose () method
public function dispose():void

render () method
public function render():void


away3d.core.render.DefaultRenderer

DefaultRenderer | Properties | Methods
Package | away3d.core.render
Class | public class DefaultRenderer
Inheritance | DefaultRenderer Inheritance RendererBase Inheritance Object

The DefaultRenderer class provides the default rendering method. It renders the scene graph objects using the materials assigned to them.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | antiAlias : uint | RendererBase
Inherited | backgroundImageRenderer : BackgroundImageRenderer [read-only] | RendererBase
Inherited | renderableSorter : IEntitySorter | RendererBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _antiAlias : uint | RendererBase
Inherited | _backgroundAlpha : Number = 1 | RendererBase
Inherited | _backgroundB : Number = 0 | RendererBase
Inherited | _backgroundG : Number = 0 | RendererBase
Inherited | _backgroundR : Number = 0 | RendererBase
Inherited | _context : Context3D | RendererBase
Inherited | _renderableSorter : IEntitySorter | RendererBase
Inherited | _renderTarget : TextureBase | RendererBase
Inherited | _renderTargetSurface : int | RendererBase
Inherited | _renderToTexture : Boolean | RendererBase
Inherited | _shareContext : Boolean = false | RendererBase
Inherited | _stage3DProxy : Stage3DProxy | RendererBase
Inherited | _textureRatioX : Number = 1 | RendererBase
Inherited | _textureRatioY : Number = 1 | RendererBase
Inherited | _viewHeight : Number | RendererBase
Inherited | _viewWidth : Number | RendererBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DefaultRenderer() Creates a new DefaultRenderer object. | DefaultRenderer
Inherited | queueSnapshot(bmd:BitmapData):void | RendererBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | draw(entityCollector:EntityCollector, target:TextureBase):void [override] Performs the actual drawing of geometry to the target. | DefaultRenderer
 | executeRender(entityCollector:EntityCollector, target:TextureBase = null, scissorRect:Rectangle = null, surfaceSelector:int = 0):void [override] | DefaultRenderer
Inherited | executeRenderToTexturePass(entityCollector:EntityCollector):void | RendererBase
Property Detail
stage3DProxy property
stage3DProxy:Stage3DProxy[override]

Implementation
    arcane function get stage3DProxy():Stage3DProxy
    arcane function set stage3DProxy(value:Stage3DProxy):void
Constructor Detail
DefaultRenderer () Constructor
public function DefaultRenderer()

Creates a new DefaultRenderer object.

Method Detail
dispose () method
override arcane function dispose():void

draw () method
override protected function draw(entityCollector:EntityCollector, target:TextureBase):void

Performs the actual drawing of geometry to the target.

Parameters

entityCollector:EntityCollector — The EntityCollector object containing the potentially visible geometry.
target:TextureBase

executeRender () method
override protected function executeRender(entityCollector:EntityCollector, target:TextureBase = null, scissorRect:Rectangle = null, surfaceSelector:int = 0):void

Parameters

entityCollector:EntityCollector
target:TextureBase (default = null)
scissorRect:Rectangle (default = null)
surfaceSelector:int (default = 0)


away3d.core.render.DepthRenderer

DepthRenderer | Properties | Methods
Package | away3d.core.render
Class | public class DepthRenderer
Inheritance | DepthRenderer Inheritance RendererBase Inheritance Object

The DepthRenderer class renders 32-bit depth information encoded as RGBA

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | antiAlias : uint | RendererBase
Inherited | backgroundImageRenderer : BackgroundImageRenderer [read-only] | RendererBase
 | disableColor : Boolean | DepthRenderer
Inherited | renderableSorter : IEntitySorter | RendererBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _antiAlias : uint | RendererBase
Inherited | _backgroundAlpha : Number = 1 | RendererBase
Inherited | _backgroundB : Number = 0 | RendererBase
Inherited | _backgroundG : Number = 0 | RendererBase
Inherited | _backgroundR : Number = 0 | RendererBase
Inherited | _context : Context3D | RendererBase
Inherited | _renderableSorter : IEntitySorter | RendererBase
Inherited | _renderTarget : TextureBase | RendererBase
Inherited | _renderTargetSurface : int | RendererBase
Inherited | _renderToTexture : Boolean | RendererBase
Inherited | _shareContext : Boolean = false | RendererBase
Inherited | _stage3DProxy : Stage3DProxy | RendererBase
Inherited | _textureRatioX : Number = 1 | RendererBase
Inherited | _textureRatioY : Number = 1 | RendererBase
Inherited | _viewHeight : Number | RendererBase
Inherited | _viewWidth : Number | RendererBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DepthRenderer(renderBlended:Boolean = false, distanceBased:Boolean = false) Creates a new DepthRenderer object. | DepthRenderer
Inherited | queueSnapshot(bmd:BitmapData):void | RendererBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | draw(entityCollector:EntityCollector, target:TextureBase):void [override] Performs the actual drawing of geometry to the target. | DepthRenderer
Inherited | executeRender(entityCollector:EntityCollector, target:TextureBase = null, scissorRect:Rectangle = null, surfaceSelector:int = 0):void Renders the potentially visible geometry to the back buffer or texture. | RendererBase
Inherited | executeRenderToTexturePass(entityCollector:EntityCollector):void | RendererBase
Property Detail
backgroundB property
backgroundB:Number[override]

Implementation
    arcane function get backgroundB():Number
    arcane function set backgroundB(value:Number):void
backgroundG property
backgroundG:Number[override]

Implementation
    arcane function get backgroundG():Number
    arcane function set backgroundG(value:Number):void
backgroundR property
backgroundR:Number[override]

Implementation
    arcane function get backgroundR():Number
    arcane function set backgroundR(value:Number):void
disableColor property
disableColor:Boolean

Implementation
    public function get disableColor():Boolean
    public function set disableColor(value:Boolean):void
Constructor Detail
DepthRenderer () Constructor
public function DepthRenderer(renderBlended:Boolean = false, distanceBased:Boolean = false)

Creates a new DepthRenderer object.

Parameters
renderBlended:Boolean (default = false) — Indicates whether semi-transparent objects should be rendered.
distanceBased:Boolean (default = false) — The amount of anti-aliasing to be used.
Method Detail
draw () method
override protected function draw(entityCollector:EntityCollector, target:TextureBase):void

Performs the actual drawing of geometry to the target.

Parameters

entityCollector:EntityCollector — The EntityCollector object containing the potentially visible geometry.
target:TextureBase

renderCascades () method
arcane function renderCascades(entityCollector:EntityCollector, target:TextureBase, numCascades:uint, scissorRects:Vector.<Rectangle>, splitPlanes:Vector.<Plane3D>, cameras:Vector.<Camera3D>):void

Parameters

entityCollector:EntityCollector
target:TextureBase
numCascades:uint
scissorRects:Vector.<Rectangle>
splitPlanes:Vector.<Plane3D>
cameras:Vector.<Camera3D>


away3d.core.render.Filter3DRenderer

Filter3DRenderer | Properties | Methods
Package | away3d.core.render
Class | public class Filter3DRenderer
Inheritance | Filter3DRenderer Inheritance Object

Public Properties
Property |  | Defined By
 | filters : Array | Filter3DRenderer
 | requireDepthRender : Boolean [read-only] | Filter3DRenderer
Public Methods
Method |  | Defined By
 | Filter3DRenderer(stage3DProxy:Stage3DProxy) | Filter3DRenderer
 | dispose():void | Filter3DRenderer
 | getMainInputTexture(stage3DProxy:Stage3DProxy):Texture | Filter3DRenderer
 | render(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void | Filter3DRenderer
Property Detail
filters property
filters:Array

Implementation
    public function get filters():Array
    public function set filters(value:Array):void
requireDepthRender property
requireDepthRender:Boolean [read-only]

Implementation
    public function get requireDepthRender():Boolean
Constructor Detail
Filter3DRenderer () Constructor
public function Filter3DRenderer(stage3DProxy:Stage3DProxy)

Parameters
stage3DProxy:Stage3DProxy
Method Detail
dispose () method
public function dispose():void

getMainInputTexture () method
public function getMainInputTexture(stage3DProxy:Stage3DProxy):Texture

Parameters

stage3DProxy:Stage3DProxy

Returns
Texture
render () method
public function render(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void

Parameters

stage3DProxy:Stage3DProxy
camera3D:Camera3D
depthTexture:Texture


away3d.core.render.PositionRenderer

PositionRenderer | Properties | Methods
Package | away3d.core.render
Class | public class PositionRenderer
Inheritance | PositionRenderer Inheritance RendererBase Inheritance Object

The PositionRenderer renders normalized position coordinates.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | antiAlias : uint | RendererBase
Inherited | backgroundImageRenderer : BackgroundImageRenderer [read-only] | RendererBase
Inherited | renderableSorter : IEntitySorter | RendererBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _antiAlias : uint | RendererBase
Inherited | _backgroundAlpha : Number = 1 | RendererBase
Inherited | _backgroundB : Number = 0 | RendererBase
Inherited | _backgroundG : Number = 0 | RendererBase
Inherited | _backgroundR : Number = 0 | RendererBase
Inherited | _context : Context3D | RendererBase
Inherited | _renderableSorter : IEntitySorter | RendererBase
Inherited | _renderTarget : TextureBase | RendererBase
Inherited | _renderTargetSurface : int | RendererBase
Inherited | _renderToTexture : Boolean | RendererBase
Inherited | _shareContext : Boolean = false | RendererBase
Inherited | _stage3DProxy : Stage3DProxy | RendererBase
Inherited | _textureRatioX : Number = 1 | RendererBase
Inherited | _textureRatioY : Number = 1 | RendererBase
Inherited | _viewHeight : Number | RendererBase
Inherited | _viewWidth : Number | RendererBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | PositionRenderer(renderBlended:Boolean = false) Creates a PositionRenderer object. | PositionRenderer
Inherited | queueSnapshot(bmd:BitmapData):void | RendererBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | draw(entityCollector:EntityCollector, target:TextureBase):void [override] Performs the actual drawing of geometry to the target. | PositionRenderer
Inherited | executeRender(entityCollector:EntityCollector, target:TextureBase = null, scissorRect:Rectangle = null, surfaceSelector:int = 0):void Renders the potentially visible geometry to the back buffer or texture. | RendererBase
Inherited | executeRenderToTexturePass(entityCollector:EntityCollector):void | RendererBase
Constructor Detail
PositionRenderer () Constructor
public function PositionRenderer(renderBlended:Boolean = false)

Creates a PositionRenderer object.

Parameters
renderBlended:Boolean (default = false) — Indicates whether semi-transparent objects should be rendered.
Method Detail
draw () method
override protected function draw(entityCollector:EntityCollector, target:TextureBase):void

Performs the actual drawing of geometry to the target.

Parameters

entityCollector:EntityCollector — The EntityCollector object containing the potentially visible geometry.
target:TextureBase


away3d.core.render.RendererBase

RendererBase | Properties | Methods
Package | away3d.core.render
Class | public class RendererBase
Inheritance | RendererBase Inheritance Object
Subclasses | DefaultRenderer, DepthRenderer, PositionRenderer

RendererBase forms an abstract base class for classes that are used in the rendering pipeline to render geometry to the back buffer or a texture.

Public Properties
Property |  | Defined By
 | antiAlias : uint | RendererBase
 | backgroundImageRenderer : BackgroundImageRenderer [read-only] | RendererBase
 | renderableSorter : IEntitySorter | RendererBase
Protected Properties
Property |  | Defined By
 | _antiAlias : uint | RendererBase
 | _backgroundAlpha : Number = 1 | RendererBase
 | _backgroundB : Number = 0 | RendererBase
 | _backgroundG : Number = 0 | RendererBase
 | _backgroundR : Number = 0 | RendererBase
 | _context : Context3D | RendererBase
 | _renderableSorter : IEntitySorter | RendererBase
 | _renderTarget : TextureBase | RendererBase
 | _renderTargetSurface : int | RendererBase
 | _renderToTexture : Boolean | RendererBase
 | _shareContext : Boolean = false | RendererBase
 | _stage3DProxy : Stage3DProxy | RendererBase
 | _textureRatioX : Number = 1 | RendererBase
 | _textureRatioY : Number = 1 | RendererBase
 | _viewHeight : Number | RendererBase
 | _viewWidth : Number | RendererBase
Public Methods
Method |  | Defined By
 | RendererBase(renderToTexture:Boolean = false) Creates a new RendererBase object. | RendererBase
 | queueSnapshot(bmd:BitmapData):void | RendererBase
Protected Methods
Method |  | Defined By
 | draw(entityCollector:EntityCollector, target:TextureBase):void Performs the actual drawing of geometry to the target. | RendererBase
 | executeRender(entityCollector:EntityCollector, target:TextureBase = null, scissorRect:Rectangle = null, surfaceSelector:int = 0):void Renders the potentially visible geometry to the back buffer or texture. | RendererBase
 | executeRenderToTexturePass(entityCollector:EntityCollector):void | RendererBase
Property Detail
_antiAlias property
protected var _antiAlias:uint

_backgroundAlpha property
protected var _backgroundAlpha:Number = 1

_backgroundB property
protected var _backgroundB:Number = 0

_backgroundG property
protected var _backgroundG:Number = 0

_backgroundR property
protected var _backgroundR:Number = 0

_context property
protected var _context:Context3D

_renderableSorter property
protected var _renderableSorter:IEntitySorter

_renderTarget property
protected var _renderTarget:TextureBase

_renderTargetSurface property
protected var _renderTargetSurface:int

_renderToTexture property
protected var _renderToTexture:Boolean

_shareContext property
protected var _shareContext:Boolean = false

_stage3DProxy property
protected var _stage3DProxy:Stage3DProxy

_textureRatioX property
protected var _textureRatioX:Number = 1

_textureRatioY property
protected var _textureRatioY:Number = 1

_viewHeight property
protected var _viewHeight:Number

_viewWidth property
protected var _viewWidth:Number

antiAlias property
antiAlias:uint

Implementation
    public function get antiAlias():uint
    public function set antiAlias(value:uint):void
background property
background:Texture2DBase

Implementation
    arcane function get background():Texture2DBase
    arcane function set background(value:Texture2DBase):void
backgroundAlpha property
backgroundAlpha:Number

Implementation
    arcane function get backgroundAlpha():Number
    arcane function set backgroundAlpha(value:Number):void
backgroundB property
backgroundB:Number

Implementation
    arcane function get backgroundB():Number
    arcane function set backgroundB(value:Number):void
backgroundG property
backgroundG:Number

Implementation
    arcane function get backgroundG():Number
    arcane function set backgroundG(value:Number):void
backgroundImageRenderer property
backgroundImageRenderer:BackgroundImageRenderer [read-only]

Implementation
    public function get backgroundImageRenderer():BackgroundImageRenderer
backgroundR property
backgroundR:Number

Implementation
    arcane function get backgroundR():Number
    arcane function set backgroundR(value:Number):void
clearOnRender property
clearOnRender:Boolean

Implementation
    arcane function get clearOnRender():Boolean
    arcane function set clearOnRender(value:Boolean):void
renderableSorter property
renderableSorter:IEntitySorter

Implementation
    public function get renderableSorter():IEntitySorter
    public function set renderableSorter(value:IEntitySorter):void
renderToTexture property
renderToTexture:Boolean [read-only]

Implementation
    arcane function get renderToTexture():Boolean
shareContext property
shareContext:Boolean

Implementation
    arcane function get shareContext():Boolean
    arcane function set shareContext(value:Boolean):void
stage3DProxy property
stage3DProxy:Stage3DProxy

Implementation
    arcane function get stage3DProxy():Stage3DProxy
    arcane function set stage3DProxy(value:Stage3DProxy):void
textureRatioX property
textureRatioX:Number

Implementation
    arcane function get textureRatioX():Number
    arcane function set textureRatioX(value:Number):void
textureRatioY property
textureRatioY:Number

Implementation
    arcane function get textureRatioY():Number
    arcane function set textureRatioY(value:Number):void
viewHeight property
viewHeight:Number

Implementation
    arcane function get viewHeight():Number
    arcane function set viewHeight(value:Number):void
viewWidth property
viewWidth:Number

Implementation
    arcane function get viewWidth():Number
    arcane function set viewWidth(value:Number):void
Constructor Detail
RendererBase () Constructor
public function RendererBase(renderToTexture:Boolean = false)

Creates a new RendererBase object.

Parameters
renderToTexture:Boolean (default = false)
Method Detail
createEntityCollector () method
arcane function createEntityCollector():EntityCollector

Returns
EntityCollector
draw () method
protected function draw(entityCollector:EntityCollector, target:TextureBase):void

Performs the actual drawing of geometry to the target.

Parameters

entityCollector:EntityCollector — The EntityCollector object containing the potentially visible geometry.
target:TextureBase

executeRender () method
protected function executeRender(entityCollector:EntityCollector, target:TextureBase = null, scissorRect:Rectangle = null, surfaceSelector:int = 0):void

Renders the potentially visible geometry to the back buffer or texture. Only executed if everything is set up.

Parameters

entityCollector:EntityCollector — The EntityCollector object containing the potentially visible geometry.
target:TextureBase (default = null) — An option target texture to render to.
scissorRect:Rectangle (default = null) — The index of a CubeTexture's face to render to.
surfaceSelector:int (default = 0) — Additional clear mask information, in case extra clear channels are to be omitted.

executeRenderToTexturePass () method
protected function executeRenderToTexturePass(entityCollector:EntityCollector):void

Parameters

entityCollector:EntityCollector

queueSnapshot () method
public function queueSnapshot(bmd:BitmapData):void

Parameters

bmd:BitmapData

render () method
arcane function render(entityCollector:EntityCollector, target:TextureBase = null, scissorRect:Rectangle = null, surfaceSelector:int = 0):void

Renders the potentially visible geometry to the back buffer or texture.

Parameters

entityCollector:EntityCollector — The EntityCollector object containing the potentially visible geometry.
target:TextureBase (default = null) — An option target texture to render to.
scissorRect:Rectangle (default = null) — The index of a CubeTexture's face to render to.
surfaceSelector:int (default = 0) — Additional clear mask information, in case extra clear channels are to be omitted.


away3d.core.sort - Away3D Documentation

Package away3d.core.sort

Interfaces
IEntitySorter
Classes
RenderableMergeSort


away3d.core.sort Summary

away3d.core.sort | Interfaces | Classes

Interfaces
Interface | Description
IEntitySorter | EntitySorterBase provides an abstract base class to sort geometry information in an EntityCollector object for rendering.
Classes
Class | Description
RenderableMergeSort | RenderableSorter sorts the potentially visible IRenderable objects collected by EntityCollector for optimal rendering performance.

Thu Nov 15 2012, 12:09 PM Z


away3d.core.sort.IEntitySorter

IEntitySorter | Methods
Package | away3d.core.sort
Interface | public interface IEntitySorter
Implementors | RenderableMergeSort

EntitySorterBase provides an abstract base class to sort geometry information in an EntityCollector object for rendering.

Public Methods
Method |  | Defined By
 | sort(collector:EntityCollector):void Sort the potentially visible data in an EntityCollector for rendering. | IEntitySorter
Method Detail
sort () method
public function sort(collector:EntityCollector):void

Sort the potentially visible data in an EntityCollector for rendering.

Parameters

collector:EntityCollector — The EntityCollector object containing the potentially visible data.


away3d.core.sort.RenderableMergeSort

RenderableMergeSort | Methods
Package | away3d.core.sort
Class | public class RenderableMergeSort
Inheritance | RenderableMergeSort Inheritance Object
Implements | IEntitySorter

RenderableSorter sorts the potentially visible IRenderable objects collected by EntityCollector for optimal rendering performance. Objects are sorted first by material, then by distance to the camera. Opaque objects are sorted front to back, while objects that require blending are sorted back to front, to ensure correct blending.

Public Methods
Method |  | Defined By
 | RenderableMergeSort() Creates a RenderableSorter objects | RenderableMergeSort
 | sort(collector:EntityCollector):void Sort the potentially visible data in an EntityCollector for rendering. | RenderableMergeSort
Constructor Detail
RenderableMergeSort () Constructor
public function RenderableMergeSort()

Creates a RenderableSorter objects

Method Detail
sort () method
public function sort(collector:EntityCollector):void

Sort the potentially visible data in an EntityCollector for rendering.

Parameters

collector:EntityCollector — The EntityCollector object containing the potentially visible data.


away3d.core.traverse - Away3D Documentation

Package away3d.core.traverse

Classes
EntityCollector
PartitionTraverser
SceneIterator
ShadowCasterCollector


away3d.core.traverse Summary

away3d.core.traverse | Classes

Classes
Class | Description
EntityCollector | The EntityCollector class is a traverser for scene partitions that collects all scene graph entities that are considered potientially visible.
PartitionTraverser | IPartitionTraverser is a hierarchical visitor pattern that traverses through a Partition3D data structure.
SceneIterator |
ShadowCasterCollector | The EntityCollector class is a traverser for scene partitions that collects all scene graph entities that are considered potientially visible.

Thu Nov 15 2012, 12:09 PM Z


away3d.core.traverse.EntityCollector

EntityCollector | Properties | Methods
Package | away3d.core.traverse
Class | public class EntityCollector
Inheritance | EntityCollector Inheritance PartitionTraverser Inheritance Object
Subclasses | ShadowCasterCollector

The EntityCollector class is a traverser for scene partitions that collects all scene graph entities that are considered potientially visible.

See also

away3d.partition.Partition3D
away3d.partition.Entity

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | blendedRenderableHead : RenderableListItem The list of IRenderable objects that require blending and are considered potentially visible. | EntityCollector
 | camera : Camera3D The camera that provides the visible frustum. | EntityCollector
 | directionalLights : Vector.<DirectionalLight> [read-only] | EntityCollector
 | entityHead : EntityListItem [read-only] | EntityCollector
Inherited | entryPoint : Vector3D [read-only] The entry point for scene graph traversal, ie the point that will be used for traversing the graph position-dependently. | PartitionTraverser
 | lightProbes : Vector.<LightProbe> [read-only] | EntityCollector
 | lights : Vector.<LightBase> [read-only] The lights of which the affecting area intersects the camera's frustum. | EntityCollector
 | numMouseEnableds : uint [read-only] The amount of IRenderable objects that are mouse-enabled. | EntityCollector
 | numTriangles : uint [read-only] The total number of triangles collected, and which will be pushed to the render engine. | EntityCollector
 | opaqueRenderableHead : RenderableListItem The list of opaque IRenderable objects that are considered potentially visible. | EntityCollector
 | pointLights : Vector.<PointLight> [read-only] | EntityCollector
Inherited | scene : Scene3D The scene being traversed. | PartitionTraverser
 | skyBox : IRenderable [read-only] The sky box object if encountered. | EntityCollector
Protected Properties
Property |  | Defined By
 | _blendedRenderableHead : RenderableListItem | EntityCollector
 | _camera : Camera3D | EntityCollector
 | _entityListItemPool : EntityListItemPool | EntityCollector
 | _lights : Vector.<LightBase> | EntityCollector
 | _numEntities : uint | EntityCollector
 | _numLights : uint | EntityCollector
 | _numMouseEnableds : uint | EntityCollector
 | _numTriangles : uint | EntityCollector
 | _opaqueRenderableHead : RenderableListItem | EntityCollector
 | _renderableListItemPool : RenderableListItemPool | EntityCollector
 | _skyBox : IRenderable | EntityCollector
Public Methods
Method |  | Defined By
 | EntityCollector() Creates a new EntityCollector object. | EntityCollector
 | applyDirectionalLight(light:DirectionalLight):void [override] | EntityCollector
 | applyEntity(entity:Entity):void [override] Registers an entity for use. | EntityCollector
 | applyLightProbe(light:LightProbe):void [override] | EntityCollector
 | applyPointLight(light:PointLight):void [override] | EntityCollector
 | applyRenderable(renderable:IRenderable):void [override] Adds an IRenderable object to the potentially visible objects. | EntityCollector
 | applySkyBox(renderable:IRenderable):void [override] Adds a skybox to the potentially visible objects. | EntityCollector
 | applyUnknownLight(light:LightBase):void [override] Adds a light to the potentially visible objects. | EntityCollector
 | cleanUp():void Cleans up any data at the end of a frame. | EntityCollector
 | clear():void Clears all objects in the entity collector. | EntityCollector
 | enterNode(node:NodeBase):Boolean [override] Returns true if the current node is at least partly in the frustum. | EntityCollector
Property Detail
_blendedRenderableHead property
protected var _blendedRenderableHead:RenderableListItem

_camera property
protected var _camera:Camera3D

_entityListItemPool property
protected var _entityListItemPool:EntityListItemPool

_lights property
protected var _lights:Vector.<LightBase>

_numEntities property
protected var _numEntities:uint

_numLights property
protected var _numLights:uint

_numMouseEnableds property
protected var _numMouseEnableds:uint

_numTriangles property
protected var _numTriangles:uint

_opaqueRenderableHead property
protected var _opaqueRenderableHead:RenderableListItem

_renderableListItemPool property
protected var _renderableListItemPool:RenderableListItemPool

_skyBox property
protected var _skyBox:IRenderable

blendedRenderableHead property
blendedRenderableHead:RenderableListItem

The list of IRenderable objects that require blending and are considered potentially visible.

Implementation
    public function get blendedRenderableHead():RenderableListItem
    public function set blendedRenderableHead(value:RenderableListItem):void
camera property
camera:Camera3D

The camera that provides the visible frustum.

Implementation
    public function get camera():Camera3D
    public function set camera(value:Camera3D):void
directionalLights property
directionalLights:Vector.<DirectionalLight> [read-only]

Implementation
    public function get directionalLights():Vector.<DirectionalLight>
entityHead property
entityHead:EntityListItem [read-only]

Implementation
    public function get entityHead():EntityListItem
lightProbes property
lightProbes:Vector.<LightProbe> [read-only]

Implementation
    public function get lightProbes():Vector.<LightProbe>
lights property
lights:Vector.<LightBase> [read-only]

The lights of which the affecting area intersects the camera's frustum.

Implementation
    public function get lights():Vector.<LightBase>
numMouseEnableds property
numMouseEnableds:uint [read-only]

The amount of IRenderable objects that are mouse-enabled.

Implementation
    public function get numMouseEnableds():uint
numTriangles property
numTriangles:uint [read-only]

The total number of triangles collected, and which will be pushed to the render engine.

Implementation
    public function get numTriangles():uint
opaqueRenderableHead property
opaqueRenderableHead:RenderableListItem

The list of opaque IRenderable objects that are considered potentially visible.

Implementation
    public function get opaqueRenderableHead():RenderableListItem
    public function set opaqueRenderableHead(value:RenderableListItem):void
pointLights property
pointLights:Vector.<PointLight> [read-only]

Implementation
    public function get pointLights():Vector.<PointLight>
skyBox property
skyBox:IRenderable [read-only]

The sky box object if encountered.

Implementation
    public function get skyBox():IRenderable
Constructor Detail
EntityCollector () Constructor
public function EntityCollector()

Creates a new EntityCollector object.

Method Detail
applyDirectionalLight () method
override public function applyDirectionalLight(light:DirectionalLight):void

Parameters

light:DirectionalLight

applyEntity () method
override public function applyEntity(entity:Entity):void

Registers an entity for use.

Parameters

entity:Entity

applyLightProbe () method
override public function applyLightProbe(light:LightProbe):void

Parameters

light:LightProbe

applyPointLight () method
override public function applyPointLight(light:PointLight):void

Parameters

light:PointLight

applyRenderable () method
override public function applyRenderable(renderable:IRenderable):void

Adds an IRenderable object to the potentially visible objects.

Parameters

renderable:IRenderable — The IRenderable object to add.

applySkyBox () method
override public function applySkyBox(renderable:IRenderable):void

Adds a skybox to the potentially visible objects.

Parameters

renderable:IRenderable — The skybox to add.

applyUnknownLight () method
override public function applyUnknownLight(light:LightBase):void

Adds a light to the potentially visible objects.

Parameters

light:LightBase — The light to add.

cleanUp () method
public function cleanUp():void

Cleans up any data at the end of a frame.

clear () method
public function clear():void

Clears all objects in the entity collector.

enterNode () method
override public function enterNode(node:NodeBase):Boolean

Returns true if the current node is at least partly in the frustum. If so, the partition node knows to pass on the traverser to its children.

Parameters

node:NodeBase — The Partition3DNode object to frustum-test.

Returns
Boolean


away3d.core.traverse.PartitionTraverser

PartitionTraverser | Properties | Methods
Package | away3d.core.traverse
Class | public class PartitionTraverser
Inheritance | PartitionTraverser Inheritance Object
Subclasses | EntityCollector

IPartitionTraverser is a hierarchical visitor pattern that traverses through a Partition3D data structure.

See also

away3d.partition.Partition3D

Public Properties
Property |  | Defined By
 | entryPoint : Vector3D [read-only] The entry point for scene graph traversal, ie the point that will be used for traversing the graph position-dependently. | PartitionTraverser
 | scene : Scene3D The scene being traversed. | PartitionTraverser
Public Methods
Method |  | Defined By
 | applyDirectionalLight(light:DirectionalLight):void | PartitionTraverser
 | applyEntity(entity:Entity):void Registers an entity for use. | PartitionTraverser
 | applyLightProbe(light:LightProbe):void | PartitionTraverser
 | applyPointLight(light:PointLight):void | PartitionTraverser
 | applyRenderable(renderable:IRenderable):void Passes an IRenderable object to be processed by the traverser. | PartitionTraverser
 | applySkyBox(renderable:IRenderable):void Passes a skybox to be processed by the traverser. | PartitionTraverser
 | applyUnknownLight(light:LightBase):void Passes a light to be processed by the traverser. | PartitionTraverser
 | enterNode(node:NodeBase):Boolean Called when the traversers enters a node. | PartitionTraverser
Property Detail
_collectionMark property
arcane static var _collectionMark:uint

A property that can be used to avoid processing a partition more than once.

_entryPoint property
arcane var _entryPoint:Vector3D

entryPoint property
entryPoint:Vector3D [read-only]

The entry point for scene graph traversal, ie the point that will be used for traversing the graph position-dependently. For example: BSP visibility determination or collision detection. For the EntityCollector, this is the camera's scene position for example.

Implementation
    public function get entryPoint():Vector3D
scene property
public var scene:Scene3D

The scene being traversed.

Method Detail
applyDirectionalLight () method
public function applyDirectionalLight(light:DirectionalLight):void

Parameters

light:DirectionalLight

applyEntity () method
public function applyEntity(entity:Entity):void

Registers an entity for use.

Parameters

entity:Entity

applyLightProbe () method
public function applyLightProbe(light:LightProbe):void

Parameters

light:LightProbe

applyPointLight () method
public function applyPointLight(light:PointLight):void

Parameters

light:PointLight

applyRenderable () method
public function applyRenderable(renderable:IRenderable):void

Passes an IRenderable object to be processed by the traverser.

Parameters

renderable:IRenderable

applySkyBox () method
public function applySkyBox(renderable:IRenderable):void

Passes a skybox to be processed by the traverser.

Parameters

renderable:IRenderable

applyUnknownLight () method
public function applyUnknownLight(light:LightBase):void

Passes a light to be processed by the traverser.

Parameters

light:LightBase

enterNode () method
public function enterNode(node:NodeBase):Boolean

Called when the traversers enters a node. At minimum, it notifies the currently visited Partition3DNode whether or not further recursion is necessary.

Parameters

node:NodeBase — The currently entered node.

Returns
Boolean — true if further recursion down children is necessary, false if not.


away3d.core.traverse.SceneIterator

SceneIterator | Methods
Package | away3d.core.traverse
Class | public class SceneIterator
Inheritance | SceneIterator Inheritance Object

Public Methods
Method |  | Defined By
 | SceneIterator(scene:Scene3D) | SceneIterator
 | next():ObjectContainer3D | SceneIterator
 | reset():void | SceneIterator
Constructor Detail
SceneIterator () Constructor
public function SceneIterator(scene:Scene3D)

Parameters
scene:Scene3D
Method Detail
next () method
public function next():ObjectContainer3D

Returns
ObjectContainer3D
reset () method
public function reset():void


away3d.core.traverse.ShadowCasterCollector

ShadowCasterCollector | Properties | Methods
Package | away3d.core.traverse
Class | public class ShadowCasterCollector
Inheritance | ShadowCasterCollector Inheritance EntityCollector Inheritance PartitionTraverser Inheritance Object

The EntityCollector class is a traverser for scene partitions that collects all scene graph entities that are considered potientially visible.

See also

away3d.partition.Partition3D
away3d.partition.Entity

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | blendedRenderableHead : RenderableListItem The list of IRenderable objects that require blending and are considered potentially visible. | EntityCollector
Inherited | camera : Camera3D The camera that provides the visible frustum. | EntityCollector
Inherited | directionalLights : Vector.<DirectionalLight> [read-only] | EntityCollector
Inherited | entityHead : EntityListItem [read-only] | EntityCollector
Inherited | entryPoint : Vector3D [read-only] The entry point for scene graph traversal, ie the point that will be used for traversing the graph position-dependently. | PartitionTraverser
Inherited | lightProbes : Vector.<LightProbe> [read-only] | EntityCollector
Inherited | lights : Vector.<LightBase> [read-only] The lights of which the affecting area intersects the camera's frustum. | EntityCollector
Inherited | numMouseEnableds : uint [read-only] The amount of IRenderable objects that are mouse-enabled. | EntityCollector
Inherited | numTriangles : uint [read-only] The total number of triangles collected, and which will be pushed to the render engine. | EntityCollector
Inherited | opaqueRenderableHead : RenderableListItem The list of opaque IRenderable objects that are considered potentially visible. | EntityCollector
Inherited | pointLights : Vector.<PointLight> [read-only] | EntityCollector
Inherited | scene : Scene3D The scene being traversed. | PartitionTraverser
Inherited | skyBox : IRenderable [read-only] The sky box object if encountered. | EntityCollector
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _blendedRenderableHead : RenderableListItem | EntityCollector
Inherited | _camera : Camera3D | EntityCollector
Inherited | _entityListItemPool : EntityListItemPool | EntityCollector
Inherited | _lights : Vector.<LightBase> | EntityCollector
Inherited | _numEntities : uint | EntityCollector
Inherited | _numLights : uint | EntityCollector
Inherited | _numMouseEnableds : uint | EntityCollector
Inherited | _numTriangles : uint | EntityCollector
Inherited | _opaqueRenderableHead : RenderableListItem | EntityCollector
Inherited | _renderableListItemPool : RenderableListItemPool | EntityCollector
Inherited | _skyBox : IRenderable | EntityCollector
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ShadowCasterCollector() Creates a new EntityCollector object. | ShadowCasterCollector
 | applyDirectionalLight(light:DirectionalLight):void [override] | ShadowCasterCollector
Inherited | applyEntity(entity:Entity):void [override] Registers an entity for use. | EntityCollector
 | applyLightProbe(light:LightProbe):void [override] | ShadowCasterCollector
 | applyPointLight(light:PointLight):void [override] | ShadowCasterCollector
 | applyRenderable(renderable:IRenderable):void [override] Adds an IRenderable object to the potentially visible objects. | ShadowCasterCollector
 | applySkyBox(renderable:IRenderable):void [override] | ShadowCasterCollector
 | applyUnknownLight(light:LightBase):void [override] | ShadowCasterCollector
Inherited | cleanUp():void Cleans up any data at the end of a frame. | EntityCollector
Inherited | clear():void Clears all objects in the entity collector. | EntityCollector
Inherited | enterNode(node:NodeBase):Boolean [override] Returns true if the current node is at least partly in the frustum. | EntityCollector
Constructor Detail
ShadowCasterCollector () Constructor
public function ShadowCasterCollector()

Creates a new EntityCollector object.

Method Detail
applyDirectionalLight () method
override public function applyDirectionalLight(light:DirectionalLight):void

Parameters

light:DirectionalLight

applyLightProbe () method
override public function applyLightProbe(light:LightProbe):void

Parameters

light:LightProbe

applyPointLight () method
override public function applyPointLight(light:PointLight):void

Parameters

light:PointLight

applyRenderable () method
override public function applyRenderable(renderable:IRenderable):void

Adds an IRenderable object to the potentially visible objects.

Parameters

renderable:IRenderable — The IRenderable object to add.

applySkyBox () method
override public function applySkyBox(renderable:IRenderable):void

Parameters

renderable:IRenderable

applyUnknownLight () method
override public function applyUnknownLight(light:LightBase):void

Parameters

light:LightBase


away3d.debug - Away3D Documentation

Package away3d.debug

Classes
AwayStats
Debug
Trident
WireframeAxesGrid


away3d.debug Summary

away3d.debug | Classes

Classes
Class | Description
AwayStats | Stats monitor for Away3D or general use in any project.
Debug | Class for emmiting debuging messages, warnings and errors
Trident | Creates a new Trident object.
WireframeAxesGrid | Class WireframeAxesGrid generates a grid of lines on a given planeWireframeAxesGrid

Thu Nov 15 2012, 12:09 PM Z


away3d.debug.AwayStats

AwayStats | Properties | Methods
Package | away3d.debug
Class | public class AwayStats
Inheritance | AwayStats Inheritance flash.display.Sprite

Stats monitor for Away3D or general use in any project. The widget was designed to display all the necessary data in ways that are easily readable, while maintaining a tiny size.

The following data is displayed by the widget, either graphically, through text, or both.

  • Current frame rate in FPS (white in graph/bar)
  • SWF frame rate (Stage.frameRate)
  • Average FPS (blue in graph/bar)
  • Min/Max FPS (only on frame rate bar in minimized mode)
  • Current RAM usage (pink in graph)
  • Maximum RAM usage
  • Number of polygons in scene
  • Number of polygons last rendered (yellow in graph)

There are two display modes; standard and minimized, which are alternated by clicking the button in the upper right corner, at runtime. The widget can also be configured to start in minimized mode by setting the relevant constructor parameter.

All data can be reset at any time, by clicking the lower part of the widget (where the RAM and POLY counters are located. The average FPS can be reset separately by clicking it's ²displayed value. Furthermore, the stage frame rate can be increased or decreased by clicking the upper and lower parts of the graph, respectively. Clicking close to the center will increment in small values, and further away will increase the steps. The graph itself is only visible in standard (as opposed to minimized) display mode.

The average FPS is calculated using one of two methods, configurable via constructor parameters. By setting the meanDataLength to a non-zero value, the number of recorded frame rate values on which the average is based can be configured. This has a tiny impact on CPU usage, which is the reason why the default number is zero, denoting that the average is calculated from a running sum since the widget was last reset.

Public Properties
Property |  | Defined By
 | avg_fps : Number [read-only] | AwayStats
 | fps : int [read-only] | AwayStats
 | instance : AwayStats [static] [read-only] Holds a reference to the stats widget (or if several have been created during session, the one that was last instantiated.) Allows you to set properties and register views from anywhere in your code. | AwayStats
 | max_fps : uint [read-only] | AwayStats
 | max_ram : Number [read-only] | AwayStats
 | ram : Number [read-only] | AwayStats
Public Methods
Method |  | Defined By
 | AwayStats(view3d:View3D = null, minimized:Boolean = false, transparent:Boolean = false, meanDataLength:uint = 0, enableClickToReset:Boolean = true, enableModifyFrameRate:Boolean = true) Create an Away3D stats widget. | AwayStats
 | registerView(view3d:View3D):void Add a view to the list of those that are taken into account when calculating on-screen and total poly counts. | AwayStats
 | reset():void | AwayStats
 | unregisterView(view3d:View3D):void Remove a view from the list of those that are taken into account when calculating on-screen and total poly counts. | AwayStats
Property Detail
avg_fps property
avg_fps:Number [read-only]

Implementation
    public function get avg_fps():Number
fps property
fps:int [read-only]

Implementation
    public function get fps():int
instance property
instance:AwayStats [read-only]

Holds a reference to the stats widget (or if several have been created during session, the one that was last instantiated.) Allows you to set properties and register views from anywhere in your code.

Implementation
    public static function get instance():AwayStats
max_fps property
max_fps:uint [read-only]

Implementation
    public function get max_fps():uint
max_ram property
max_ram:Number [read-only]

Implementation
    public function get max_ram():Number
ram property
ram:Number [read-only]

Implementation
    public function get ram():Number
Constructor Detail
AwayStats () Constructor
public function AwayStats(view3d:View3D = null, minimized:Boolean = false, transparent:Boolean = false, meanDataLength:uint = 0, enableClickToReset:Boolean = true, enableModifyFrameRate:Boolean = true)

Create an Away3D stats widget. The widget can be added to the stage and positioned like any other display object. Once on the stage, you can drag the widget to re-position it at runtime.

If you pass a View3D instance, the widget will be able to display the total number of faces in your scene, and the amount of faces that were rendered during the last render() call. Views can also be registered after construction using the registerView() method. Omit the view constructor parameter to disable this feature altogether.

Parameters
view3d:View3D (default = null) — A reference to your Away3D view. This is required if you want the stats widget to display polycounts.
minimized:Boolean (default = false) — Defines whether the widget should start up in minimized mode. By default, it is shown in full-size mode on launch.
transparent:Boolean (default = false) — Defines whether to omit the background plate and print statistics directly on top of the underlying stage.
meanDataLength:uint (default = 0) — The number of frames on which to base the average frame rate calculation. The default value of zero indicates that all frames since the last reset will be used.
enableClickToReset:Boolean (default = true) — Enables interaction allowing you to reset all counters by clicking the bottom bar of the widget. When activated, you can also click the average frame rate trace-out to reset just that one value.
enableModifyFrameRate:Boolean (default = true) — When enabled, allows you to click the upper and lower parts of the graph area to increase and decrease SWF frame rate respectively.
Method Detail
registerView () method
public function registerView(view3d:View3D):void

Add a view to the list of those that are taken into account when calculating on-screen and total poly counts. Use this method when the stats widget is not instantiated in the same place as where you create your view, or when using several views, or when views are created and destroyed dynamically at runtime.

Parameters

view3d:View3D

reset () method
public function reset():void

unregisterView () method
public function unregisterView(view3d:View3D):void

Remove a view from the list of those that are taken into account when calculating on-screen and total poly counts. If the supplied view is the only one known to the stats widget, calling this will leave the list empty, disabling poly count statistics altogether.

Parameters

view3d:View3D


away3d.debug.Debug

Debug | Properties | Methods
Package | away3d.debug
Class | public class Debug
Inheritance | Debug Inheritance Object

Class for emmiting debuging messages, warnings and errors

Public Properties
Property |  | Defined By
 | active : Boolean = false [static] | Debug
 | warningsAsErrors : Boolean = false [static] | Debug
Public Methods
Method |  | Defined By
 | clear():void [static] | Debug
 | delimiter():void [static] | Debug
 | error(message:Object):void [static] | Debug
 | trace(message:Object):void [static] | Debug
 | warning(message:Object):void [static] | Debug
Property Detail
active property
public static var active:Boolean = false

warningsAsErrors property
public static var warningsAsErrors:Boolean = false

Method Detail
clear () method
public static function clear():void

delimiter () method
public static function delimiter():void

error () method
public static function error(message:Object):void

Parameters

message:Object

trace () method
public static function trace(message:Object):void

Parameters

message:Object

warning () method
public static function warning(message:Object):void

Parameters

message:Object


away3d.debug.Trident

Trident | Properties | Methods | Events | Constants
Package | away3d.debug
Class | public class Trident
Inheritance | Trident Inheritance Mesh Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Creates a new Trident object.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator Defines the animator of the mesh. | Mesh
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Mesh
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
Inherited | castsShadows : Boolean Indicates whether or not the Mesh can cast shadows | Mesh
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | geometry : Geometry The geometry used by the mesh that provides it with its shape. | Mesh
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase The material with which to render the Mesh. | Mesh
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | subMeshes : Vector.<SubMesh> [read-only] The SubMeshes out of which the Mesh consists. | Mesh
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _geometry : Geometry | Mesh
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Trident(length:Number = 1000, showLetters:Boolean = true) | Trident
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | bakeTransformations():void | Mesh
Inherited | clone():Object3D [override] Clones this Mesh instance along with all it's children, while re-using the same material and geometry instance. | Mesh
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | Mesh
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getSubMeshForSubGeometry(subGeometry:SubGeometry):SubMesh | Mesh
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createEntityPartitionNode():EntityNode [override] Factory method that returns the current partition node. | Mesh
Inherited | getDefaultBoundingVolume():BoundingVolumeBase Creates the default bounding box to be used by this type of Entity. | Entity
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] Updates the bounding volume for the object. | Mesh
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
Trident () Constructor
public function Trident(length:Number = 1000, showLetters:Boolean = true)

Parameters
length:Number (default = 1000)
showLetters:Boolean (default = true)


away3d.debug.WireframeAxesGrid

WireframeAxesGrid | Properties | Methods | Events | Constants
Package | away3d.debug
Class | public class WireframeAxesGrid
Inheritance | WireframeAxesGrid Inheritance SegmentSet Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Class WireframeAxesGrid generates a grid of lines on a given planeWireframeAxesGrid

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator [read-only] | SegmentSet
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | SegmentSet
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
Inherited | castsShadows : Boolean [read-only] | SegmentSet
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | indexData : Vector.<uint> [read-only] | SegmentSet
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase | SegmentSet
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean [override] | SegmentSet
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | numTriangles : uint [read-only] | SegmentSet
Inherited | numVertices : uint [read-only] | SegmentSet
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | sourceEntity : Entity [read-only] | SegmentSet
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | UVData : Vector.<Number> [read-only] | SegmentSet
Inherited | uvTransform : Matrix [read-only] | SegmentSet
Inherited | vertexData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalOffset : int [read-only] | SegmentSet
Inherited | vertexOffset : int [read-only] | SegmentSet
Inherited | vertexStride : uint [read-only] | SegmentSet
Inherited | vertexTangentData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexTangentOffset : int [read-only] | SegmentSet
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _segments : Vector.<Segment> | SegmentSet
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | WireframeAxesGrid(subDivision:uint = 10, gridSize:uint = 100, thickness:Number = 1, colorXY:uint = 0x0000FF, colorZY:uint = 0xFF0000, colorXZ:uint = 0x00FF00) | WireframeAxesGrid
Inherited | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | addSegment(segment:Segment):void | SegmentSet
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] | SegmentSet
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D | SegmentSet
Inherited | getSegment(index:uint):Segment | SegmentSet
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeAllSegments():void | SegmentSet
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | removeSegment(segment:Segment):void | SegmentSet
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createEntityPartitionNode():EntityNode [override] | SegmentSet
Inherited | getDefaultBoundingVolume():BoundingVolumeBase [override] | SegmentSet
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] | SegmentSet
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
WireframeAxesGrid () Constructor
public function WireframeAxesGrid(subDivision:uint = 10, gridSize:uint = 100, thickness:Number = 1, colorXY:uint = 0x0000FF, colorZY:uint = 0xFF0000, colorXZ:uint = 0x00FF00)

Parameters
subDivision:uint (default = 10)
gridSize:uint (default = 100)
thickness:Number (default = 1)
colorXY:uint (default = 0x0000FF)
colorZY:uint (default = 0xFF0000)
colorXZ:uint (default = 0x00FF00)


away3d.debug.data - Away3D Documentation

Package away3d.debug.data

Classes
TridentLines


away3d.debug.data Summary

away3d.debug.data | Classes

Classes
Class | Description
TridentLines |

Thu Nov 15 2012, 12:09 PM Z


away3d.debug.data.TridentLines

TridentLines | Properties | Methods | Events | Constants
Package | away3d.debug.data
Class | public class TridentLines
Inheritance | TridentLines Inheritance SegmentSet Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator [read-only] | SegmentSet
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | SegmentSet
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
Inherited | castsShadows : Boolean [read-only] | SegmentSet
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | indexData : Vector.<uint> [read-only] | SegmentSet
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase | SegmentSet
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean [override] | SegmentSet
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | numTriangles : uint [read-only] | SegmentSet
Inherited | numVertices : uint [read-only] | SegmentSet
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | sourceEntity : Entity [read-only] | SegmentSet
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | UVData : Vector.<Number> [read-only] | SegmentSet
Inherited | uvTransform : Matrix [read-only] | SegmentSet
Inherited | vertexData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalOffset : int [read-only] | SegmentSet
Inherited | vertexOffset : int [read-only] | SegmentSet
Inherited | vertexStride : uint [read-only] | SegmentSet
Inherited | vertexTangentData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexTangentOffset : int [read-only] | SegmentSet
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _segments : Vector.<Segment> | SegmentSet
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | TridentLines(vectors:Vector.<Vector3D>, colors:Vector.<uint>) | TridentLines
Inherited | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | addSegment(segment:Segment):void | SegmentSet
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] | SegmentSet
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D | SegmentSet
Inherited | getSegment(index:uint):Segment | SegmentSet
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeAllSegments():void | SegmentSet
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | removeSegment(segment:Segment):void | SegmentSet
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createEntityPartitionNode():EntityNode [override] | SegmentSet
Inherited | getDefaultBoundingVolume():BoundingVolumeBase [override] | SegmentSet
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] | SegmentSet
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
TridentLines () Constructor
public function TridentLines(vectors:Vector.<Vector3D>, colors:Vector.<uint>)

Parameters
vectors:Vector.<Vector3D>
colors:Vector.<uint>


away3d.entities - Away3D Documentation

Package away3d.entities

Classes
Entity
Mesh
SegmentSet
Sprite3D
TextureProjector


away3d.entities Summary

away3d.entities | Classes

Classes
Class | Description
Entity | The Entity class provides an abstract base class for all scene graph objects that are considered having a "presence" in the scene, in the sense that it can be considered an actual object with a position and a size (even if infinite or idealised), rather than a grouping.
Mesh | Mesh is an instance of a Geometry, augmenting it with a presence in the scene graph, a material, and an animation state.
SegmentSet |
Sprite3D | Sprite3D is a 3D billboard, a renderable rectangular area that is always aligned with the projection plane.
TextureProjector | TextureProjector is an object in the scene that can be used to project textures onto geometry.

Thu Nov 15 2012, 12:09 PM Z


away3d.entities.Entity

Entity | Properties | Methods | Events | Constants
Package | away3d.entities
Class | public class Entity
Inheritance | Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | Camera3D, LightBase, Mesh, SegmentSet, SkyBox, Sprite3D

The Entity class provides an abstract base class for all scene graph objects that are considered having a "presence" in the scene, in the sense that it can be considered an actual object with a position and a size (even if infinite or idealised), rather than a grouping. Entities can be partitioned in a space partitioning system and in turn collected by an EntityCollector.

See also

away3d.partition.Partition3D
away3d.core.traverse.EntityCollector

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
 | assetType : String [override] [read-only] | Entity
Inherited | backVector : Vector3D [read-only] | Object3D
 | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
 | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
 | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
 | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
 | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
 | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
 | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
 | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
 | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
 | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
 | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
 | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
 | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
 | showBounds : Boolean | Entity
 | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
 | _bounds : BoundingVolumeBase | Entity
 | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
 | _mvpIndex : int = -1 | Entity
 | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
 | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
 | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Entity() Creates a new Entity object. | Entity
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | ObjectContainer3D
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
 | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
 | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
 | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createEntityPartitionNode():EntityNode Factory method that returns the current partition node. | Entity
 | getDefaultBoundingVolume():BoundingVolumeBase Creates the default bounding box to be used by this type of Entity. | Entity
 | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
 | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
 | updateBounds():void Updates the bounding volume for the object. | Entity
 | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_bounds property
protected var _bounds:BoundingVolumeBase

_boundsInvalid property
protected var _boundsInvalid:Boolean = true

_mvpIndex property
protected var _mvpIndex:int = -1

_mvpTransformStack property
protected var _mvpTransformStack:Vector.<Matrix3D>

_pickingCollider property
arcane var _pickingCollider:IPickingCollider

_pickingCollisionVO property
arcane var _pickingCollisionVO:PickingCollisionVO

_stackLen property
protected var _stackLen:uint

_staticNode property
arcane var _staticNode:Boolean

_zIndices property
protected var _zIndices:Vector.<Number>

assetType property
assetType:String [read-only] [override]

Implementation
    public function get assetType():String
bounds property
bounds:BoundingVolumeBase

The bounding volume approximating the volume occupied by the Entity.

Implementation
    public function get bounds():BoundingVolumeBase
    public function set bounds(value:BoundingVolumeBase):void
ignoreTransform property
ignoreTransform:Boolean[override]

Implementation
    public function get ignoreTransform():Boolean
    public function set ignoreTransform(value:Boolean):void
implicitPartition property
implicitPartition:Partition3D[override]

Implementation
    arcane function get implicitPartition():Partition3D
    arcane function set implicitPartition(value:Partition3D):void
maxX property
maxX:Number [read-only] [override]

The maximum extremum of the object along the X-axis.

Implementation
    public function get maxX():Number
maxY property
maxY:Number [read-only] [override]

The maximum extremum of the object along the Y-axis.

Implementation
    public function get maxY():Number
maxZ property
maxZ:Number [read-only] [override]

The maximum extremum of the object along the Z-axis.

Implementation
    public function get maxZ():Number
minX property
minX:Number [read-only] [override]

The minimum extremum of the object along the X-axis.

Implementation
    public function get minX():Number
minY property
minY:Number [read-only] [override]

The minimum extremum of the object along the Y-axis.

Implementation
    public function get minY():Number
minZ property
minZ:Number [read-only] [override]

The minimum extremum of the object along the Z-axis.

Implementation
    public function get minZ():Number
modelViewProjection property
modelViewProjection:Matrix3D [read-only]

The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space.

Implementation
    public function get modelViewProjection():Matrix3D
pickingCollider property
pickingCollider:IPickingCollider

Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. Defaults to null.

Implementation
    public function get pickingCollider():IPickingCollider
    public function set pickingCollider(value:IPickingCollider):void

See also

away3d.core.pick.RaycastPicker
pickingCollisionVO property
pickingCollisionVO:PickingCollisionVO [read-only]

Returns a unique picking collision value object for the entity.

Implementation
    public function get pickingCollisionVO():PickingCollisionVO
scene property
scene:Scene3D[override]

A reference to the Scene3D object to which this object belongs.

Implementation
    public function get scene():Scene3D
    public function set scene(value:Scene3D):void
shaderPickingDetails property
shaderPickingDetails:Boolean

Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. Defaults to false.

Implementation
    public function get shaderPickingDetails():Boolean
    public function set shaderPickingDetails(value:Boolean):void

See also

away3d.core.pick.ShaderPicker
showBounds property
showBounds:Boolean

Implementation
    public function get showBounds():Boolean
    public function set showBounds(value:Boolean):void
staticNode property
staticNode:Boolean

Defines whether or not the object will be moved or animated at runtime. This property is used by some partitioning systems to improve performance. Warning: if set to true, they may not be processed by certain partition systems using static visibility lists, unless they're specifically assigned to the visibility list.

Implementation
    public function get staticNode():Boolean
    public function set staticNode(value:Boolean):void
Constructor Detail
Entity () Constructor
public function Entity()

Creates a new Entity object.

Method Detail
collidesBefore () method
arcane function collidesBefore(shortestCollisionDistance:Number, findClosest:Boolean):Boolean

Tests if a collision occurs before shortestCollisionDistance, using the data stored in PickingCollisionVO.

Parameters

shortestCollisionDistance:Number
findClosest:Boolean

Returns
Boolean —
createEntityPartitionNode () method
protected function createEntityPartitionNode():EntityNode

Factory method that returns the current partition node. Needs to be overridden by concrete subclasses such as Mesh to return the correct concrete subtype of EntityPartition3DNode (for Mesh = MeshPartition3DNode, most IRenderables (particles fe) would return RenderablePartition3DNode, I suppose)

Returns
EntityNode
getDefaultBoundingVolume () method
protected function getDefaultBoundingVolume():BoundingVolumeBase

Creates the default bounding box to be used by this type of Entity.

Returns
BoundingVolumeBase —
getEntityPartitionNode () method
public function getEntityPartitionNode():EntityNode

Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance

Returns
EntityNode
internalUpdate () method
arcane function internalUpdate():void

invalidateBounds () method
protected function invalidateBounds():void

Invalidates the bounding volume, causing to be updated when requested.

invalidateSceneTransform () method
override protected function invalidateSceneTransform():void

Invalidates the scene transformation matrix, causing it to be updated the next time it's requested.

popModelViewProjection () method
public function popModelViewProjection():void

Removes a model view projection matrix from the stack, used when leaving a render.

pushModelViewProjection () method
public function pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void

Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. The stack allows nested rendering while keeping the MVP intact.

Parameters

camera:Camera3D — The camera which will perform the view transformation and projection.
updateZIndex:Boolean (default = true)

updateBounds () method
protected function updateBounds():void

Updates the bounding volume for the object. Overriding methods need to set invalid flag to false!

updateMouseChildren () method
override protected function updateMouseChildren():void


away3d.entities.Mesh

Mesh | Properties | Methods | Events | Constants
Package | away3d.entities
Class | public class Mesh
Inheritance | Mesh Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IMaterialOwner, IAsset
Subclasses | DelaunayMesh, Elevation, LatheExtrude, LinearExtrude, PathExtrude, SkinExtrude, Trident

Mesh is an instance of a Geometry, augmenting it with a presence in the scene graph, a material, and an animation state. It consists out of SubMeshes, which in turn correspond to SubGeometries. SubMeshes allow different parts of the geometry to be assigned different materials.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | animator : IAnimator Defines the animator of the mesh. | Mesh
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
 | assetType : String [override] [read-only] | Mesh
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
 | castsShadows : Boolean Indicates whether or not the Mesh can cast shadows | Mesh
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
 | geometry : Geometry The geometry used by the mesh that provides it with its shape. | Mesh
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
 | material : MaterialBase The material with which to render the Mesh. | Mesh
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
 | subMeshes : Vector.<SubMesh> [read-only] The SubMeshes out of which the Mesh consists. | Mesh
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
 | _geometry : Geometry | Mesh
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Mesh(geometry:Geometry, material:MaterialBase = null) Create a new Mesh object. | Mesh
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | bakeTransformations():void | Mesh
 | clone():Object3D [override] Clones this Mesh instance along with all it's children, while re-using the same material and geometry instance. | Mesh
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
 | dispose():void [override] Cleans up resources used by this asset. | Mesh
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
 | getSubMeshForSubGeometry(subGeometry:SubGeometry):SubMesh | Mesh
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createEntityPartitionNode():EntityNode [override] Factory method that returns the current partition node. | Mesh
Inherited | getDefaultBoundingVolume():BoundingVolumeBase Creates the default bounding box to be used by this type of Entity. | Entity
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
 | updateBounds():void [override] Updates the bounding volume for the object. | Mesh
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_geometry property
protected var _geometry:Geometry

animator property
animator:IAnimator

Defines the animator of the mesh. Act on the mesh's geometry. Defaults to null

Implementation
    public function get animator():IAnimator
    public function set animator(value:IAnimator):void
assetType property
assetType:String [read-only] [override]

Implementation
    public function get assetType():String
castsShadows property
castsShadows:Boolean

Indicates whether or not the Mesh can cast shadows

Implementation
    public function get castsShadows():Boolean
    public function set castsShadows(value:Boolean):void
geometry property
geometry:Geometry

The geometry used by the mesh that provides it with its shape.

Implementation
    public function get geometry():Geometry
    public function set geometry(value:Geometry):void
material property
material:MaterialBase

The material with which to render the Mesh.

Implementation
    public function get material():MaterialBase
    public function set material(value:MaterialBase):void
subMeshes property
subMeshes:Vector.<SubMesh> [read-only]

The SubMeshes out of which the Mesh consists. Every SubMesh can be assigned a material to override the Mesh's material.

Implementation
    public function get subMeshes():Vector.<SubMesh>
Constructor Detail
Mesh () Constructor
public function Mesh(geometry:Geometry, material:MaterialBase = null)

Create a new Mesh object.

Parameters
geometry:Geometry — The material with which to render the Mesh.
material:MaterialBase (default = null) — The geometry used by the mesh that provides it with its shape.
Method Detail
bakeTransformations () method
public function bakeTransformations():void

clone () method
override public function clone():Object3D

Clones this Mesh instance along with all it's children, while re-using the same material and geometry instance. The returned result will be a copy of this mesh, containing copies of all of it's children. Properties that are re-used (i.e. not cloned) by the new copy include name, geometry, and material. Properties that are cloned or created anew for the copy include subMeshes, animation and animationState and the children of the mesh. If you want to copy just the mesh, reusing it's geometry and material while not cloning it's children, the simplest way is to create a new mesh manually: var clone : Mesh = new Mesh(original.geometry, original.material);

Returns
Object3D
collidesBefore () method
override arcane function collidesBefore(shortestCollisionDistance:Number, findClosest:Boolean):Boolean

Parameters

shortestCollisionDistance:Number
findClosest:Boolean

Returns
Boolean
createEntityPartitionNode () method
override protected function createEntityPartitionNode():EntityNode

Factory method that returns the current partition node. Needs to be overridden by concrete subclasses such as Mesh to return the correct concrete subtype of EntityPartition3DNode (for Mesh = MeshPartition3DNode, most IRenderables (particles fe) would return RenderablePartition3DNode, I suppose)

Returns
EntityNode
dispose () method
override public function dispose():void

Cleans up resources used by this asset.

getSubMeshForSubGeometry () method
public function getSubMeshForSubGeometry(subGeometry:SubGeometry):SubMesh

Parameters

subGeometry:SubGeometry

Returns
SubMesh
updateBounds () method
override protected function updateBounds():void

Updates the bounding volume for the object. Overriding methods need to set invalid flag to false!


away3d.entities.SegmentSet

SegmentSet | Properties | Methods | Events | Constants
Package | away3d.entities
Class | public class SegmentSet
Inheritance | SegmentSet Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IRenderable
Subclasses | MeshDebug, TridentLines, WireframeAxesGrid, WireframePrimitiveBase

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | animator : IAnimator [read-only] | SegmentSet
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
 | assetType : String [override] [read-only] | SegmentSet
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
 | castsShadows : Boolean [read-only] | SegmentSet
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean [override] | Entity
 | indexData : Vector.<uint> [read-only] | SegmentSet
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
 | material : MaterialBase | SegmentSet
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
 | mouseEnabled : Boolean [override] | SegmentSet
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
 | numTriangles : uint [read-only] | SegmentSet
 | numVertices : uint [read-only] | SegmentSet
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
 | sourceEntity : Entity [read-only] | SegmentSet
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
 | UVData : Vector.<Number> [read-only] | SegmentSet
 | uvTransform : Matrix [read-only] | SegmentSet
 | vertexData : Vector.<Number> [read-only] | SegmentSet
 | vertexNormalData : Vector.<Number> [read-only] | SegmentSet
 | vertexNormalOffset : int [read-only] | SegmentSet
 | vertexOffset : int [read-only] | SegmentSet
 | vertexStride : uint [read-only] | SegmentSet
 | vertexTangentData : Vector.<Number> [read-only] | SegmentSet
 | vertexTangentOffset : int [read-only] | SegmentSet
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
 | _segments : Vector.<Segment> | SegmentSet
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SegmentSet() | SegmentSet
 | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
 | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
 | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
 | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
 | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
 | addSegment(segment:Segment):void | SegmentSet
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
 | dispose():void [override] | SegmentSet
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
 | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D | SegmentSet
 | getSegment(index:uint):Segment | SegmentSet
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
 | removeAllSegments():void | SegmentSet
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
 | removeSegment(segment:Segment):void | SegmentSet
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createEntityPartitionNode():EntityNode [override] | SegmentSet
 | getDefaultBoundingVolume():BoundingVolumeBase [override] | SegmentSet
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
 | updateBounds():void [override] | SegmentSet
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_segments property
protected var _segments:Vector.<Segment>

animator property
animator:IAnimator [read-only]

Implementation
    public function get animator():IAnimator
assetType property
assetType:String [read-only] [override]

Implementation
    public function get assetType():String
castsShadows property
castsShadows:Boolean [read-only]

Implementation
    public function get castsShadows():Boolean
indexData property
indexData:Vector.<uint> [read-only]

Implementation
    public function get indexData():Vector.<uint>
material property
material:MaterialBase

Implementation
    public function get material():MaterialBase
    public function set material(value:MaterialBase):void
mouseEnabled property
mouseEnabled:Boolean[override]

Implementation
    public function get mouseEnabled():Boolean
    public function set mouseEnabled(value:Boolean):void
numTriangles property
numTriangles:uint [read-only]

Implementation
    public function get numTriangles():uint
numVertices property
numVertices:uint [read-only]

Implementation
    public function get numVertices():uint
sourceEntity property
sourceEntity:Entity [read-only]

Implementation
    public function get sourceEntity():Entity
UVData property
UVData:Vector.<Number> [read-only]

Implementation
    public function get UVData():Vector.<Number>
uvTransform property
uvTransform:Matrix [read-only]

Implementation
    public function get uvTransform():Matrix
vertexData property
vertexData:Vector.<Number> [read-only]

Implementation
    public function get vertexData():Vector.<Number>
vertexNormalData property
vertexNormalData:Vector.<Number> [read-only]

Implementation
    public function get vertexNormalData():Vector.<Number>
vertexNormalOffset property
vertexNormalOffset:int [read-only]

Implementation
    public function get vertexNormalOffset():int
vertexOffset property
vertexOffset:int [read-only]

Implementation
    public function get vertexOffset():int
vertexStride property
vertexStride:uint [read-only]

Implementation
    public function get vertexStride():uint
vertexTangentData property
vertexTangentData:Vector.<Number> [read-only]

Implementation
    public function get vertexTangentData():Vector.<Number>
vertexTangentOffset property
vertexTangentOffset:int [read-only]

Implementation
    public function get vertexTangentOffset():int
Constructor Detail
SegmentSet () Constructor
public function SegmentSet()

Method Detail
activateSecondaryUVBuffer () method
public function activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateUVBuffer () method
public function activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateVertexBuffer () method
public function activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateVertexNormalBuffer () method
public function activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateVertexTangentBuffer () method
public function activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

addSegment () method
public function addSegment(segment:Segment):void

Parameters

segment:Segment

createEntityPartitionNode () method
override protected function createEntityPartitionNode():EntityNode

Returns
EntityNode
dispose () method
override public function dispose():void

getDefaultBoundingVolume () method
override protected function getDefaultBoundingVolume():BoundingVolumeBase

Returns
BoundingVolumeBase
getIndexBuffer () method
public function getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D

Parameters

stage3DProxy:Stage3DProxy

Returns
IndexBuffer3D
getSegment () method
public function getSegment(index:uint):Segment

Parameters

index:uint

Returns
Segment
removeAllSegments () method
public function removeAllSegments():void

removeSegment () method
public function removeSegment(segment:Segment):void

Parameters

segment:Segment

updateBounds () method
override protected function updateBounds():void

updateSegment () method
arcane function updateSegment(segment:Segment):void

Parameters

segment:Segment


away3d.entities.Sprite3D

Sprite3D | Properties | Methods | Events | Constants
Package | away3d.entities
Class | public class Sprite3D
Inheritance | Sprite3D Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IRenderable

Sprite3D is a 3D billboard, a renderable rectangular area that is always aligned with the projection plane. As a result, no perspective transformation occurs on a Sprite3D object. todo: mvp generation or vertex shader code can be optimized

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | animator : IAnimator [read-only] Defines the animator of the mesh. | Sprite3D
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Entity
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
 | castsShadows : Boolean [read-only] | Sprite3D
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
 | height : Number | Sprite3D
Inherited | ignoreTransform : Boolean [override] | Entity
 | indexData : Vector.<uint> [read-only] | Sprite3D
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
 | material : MaterialBase | Sprite3D
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
 | numTriangles : uint [read-only] | Sprite3D
 | numVertices : uint [read-only] | Sprite3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
 | sourceEntity : Entity [read-only] | Sprite3D
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
 | UVData : Vector.<Number> [read-only] | Sprite3D
 | uvTransform : Matrix [read-only] | Sprite3D
 | vertexData : Vector.<Number> [read-only] | Sprite3D
 | vertexNormalData : Vector.<Number> [read-only] | Sprite3D
 | vertexNormalOffset : int [read-only] | Sprite3D
 | vertexOffset : int [read-only] | Sprite3D
 | vertexStride : uint [read-only] | Sprite3D
 | vertexTangentData : Vector.<Number> [read-only] | Sprite3D
 | vertexTangentOffset : int [read-only] | Sprite3D
Inherited | visible : Boolean | ObjectContainer3D
 | width : Number | Sprite3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Sprite3D(material:MaterialBase, width:Number, height:Number) | Sprite3D
 | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | Sprite3D
 | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | Sprite3D
 | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void | Sprite3D
 | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void | Sprite3D
 | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void | Sprite3D
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | ObjectContainer3D
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
 | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D | Sprite3D
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
 | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void [override] | Sprite3D
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createEntityPartitionNode():EntityNode [override] | Sprite3D
 | getDefaultBoundingVolume():BoundingVolumeBase [override] | Sprite3D
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
 | updateBounds():void [override] | Sprite3D
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
 | updateTransform():void [override] | Sprite3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
animator property
animator:IAnimator [read-only]

Defines the animator of the mesh. Act on the mesh's geometry. Defaults to null

Implementation
    public function get animator():IAnimator
castsShadows property
castsShadows:Boolean [read-only]

Implementation
    public function get castsShadows():Boolean
height property
height:Number

Implementation
    public function get height():Number
    public function set height(value:Number):void
indexData property
indexData:Vector.<uint> [read-only]

Implementation
    public function get indexData():Vector.<uint>
material property
material:MaterialBase

Implementation
    public function get material():MaterialBase
    public function set material(value:MaterialBase):void
numTriangles property
numTriangles:uint [read-only]

Implementation
    public function get numTriangles():uint
numVertices property
numVertices:uint [read-only]

Implementation
    public function get numVertices():uint
sourceEntity property
sourceEntity:Entity [read-only]

Implementation
    public function get sourceEntity():Entity
UVData property
UVData:Vector.<Number> [read-only]

Implementation
    public function get UVData():Vector.<Number>
uvTransform property
uvTransform:Matrix [read-only]

Implementation
    public function get uvTransform():Matrix
vertexData property
vertexData:Vector.<Number> [read-only]

Implementation
    public function get vertexData():Vector.<Number>
vertexNormalData property
vertexNormalData:Vector.<Number> [read-only]

Implementation
    public function get vertexNormalData():Vector.<Number>
vertexNormalOffset property
vertexNormalOffset:int [read-only]

Implementation
    public function get vertexNormalOffset():int
vertexOffset property
vertexOffset:int [read-only]

Implementation
    public function get vertexOffset():int
vertexStride property
vertexStride:uint [read-only]

Implementation
    public function get vertexStride():uint
vertexTangentData property
vertexTangentData:Vector.<Number> [read-only]

Implementation
    public function get vertexTangentData():Vector.<Number>
vertexTangentOffset property
vertexTangentOffset:int [read-only]

Implementation
    public function get vertexTangentOffset():int
width property
width:Number

Implementation
    public function get width():Number
    public function set width(value:Number):void
Constructor Detail
Sprite3D () Constructor
public function Sprite3D(material:MaterialBase, width:Number, height:Number)

Parameters
material:MaterialBase
width:Number
height:Number
Method Detail
activateSecondaryUVBuffer () method
public function activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateUVBuffer () method
public function activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateVertexBuffer () method
public function activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateVertexNormalBuffer () method
public function activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateVertexTangentBuffer () method
public function activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

createEntityPartitionNode () method
override protected function createEntityPartitionNode():EntityNode

Returns
EntityNode
getDefaultBoundingVolume () method
override protected function getDefaultBoundingVolume():BoundingVolumeBase

Returns
BoundingVolumeBase
getIndexBuffer () method
public function getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D

Parameters

stage3DProxy:Stage3DProxy

Returns
IndexBuffer3D
pushModelViewProjection () method
override public function pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void

Parameters

camera:Camera3D
updateZIndex:Boolean (default = true)

updateBounds () method
override protected function updateBounds():void

updateTransform () method
override protected function updateTransform():void


away3d.entities.TextureProjector

TextureProjector | Properties | Methods | Events | Constants
Package | away3d.entities
Class | public class TextureProjector
Inheritance | TextureProjector Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

TextureProjector is an object in the scene that can be used to project textures onto geometry. To do so, the object's material must have a ProjectiveTextureMethod method added to it with a TextureProjector object passed in the constructor. This can be used for various effects apart from acting like a normal projector, such as projecting fake shadows unto a surface, the impact of light coming through a stained glass window, ...

See also

away3d.materials.methods.ProjectiveTextureMethod

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | aspectRatio : Number The aspect ratio of the texture or projection. | TextureProjector
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | ObjectContainer3D
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
 | fieldOfView : Number The vertical field of view of the projection, or the angle of the cone. | TextureProjector
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean Does not apply any transformations to this object. | ObjectContainer3D
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | maxX : Number [read-only] The maximum extremum of the object along the X-axis. | ObjectContainer3D
Inherited | maxY : Number [read-only] The maximum extremum of the object along the Y-axis. | ObjectContainer3D
Inherited | maxZ : Number [read-only] The maximum extremum of the object along the Z-axis. | ObjectContainer3D
Inherited | minX : Number [read-only] The minimum extremum of the object along the X-axis. | ObjectContainer3D
Inherited | minY : Number [read-only] The minimum extremum of the object along the Y-axis. | ObjectContainer3D
Inherited | minZ : Number [read-only] The minimum extremum of the object along the Z-axis. | ObjectContainer3D
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D A reference to the Scene3D object to which this object belongs. | ObjectContainer3D
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
 | texture : Texture2DBase The texture to be projected on the geometry. | TextureProjector
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
 | viewProjection : Matrix3D [read-only] The matrix that projects a point in scene space into the texture coordinates. | TextureProjector
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | TextureProjector(texture:Texture2DBase) Creates a new TextureProjector object. | TextureProjector
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | ObjectContainer3D
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | TextureProjector
Inherited | updateMouseChildren():void | ObjectContainer3D
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
aspectRatio property
aspectRatio:Number

The aspect ratio of the texture or projection. By default this is the same aspect ratio of the texture (width/height)

Implementation
    public function get aspectRatio():Number
    public function set aspectRatio(value:Number):void
fieldOfView property
fieldOfView:Number

The vertical field of view of the projection, or the angle of the cone.

Implementation
    public function get fieldOfView():Number
    public function set fieldOfView(value:Number):void
texture property
texture:Texture2DBase

The texture to be projected on the geometry. IMPORTANT: Since any point that is projected out of the range of the projector's cone is clamped to the texture's edges, the edges should be entirely neutral. Depending on the blend mode, the neutral color is: White for MULTIPLY, Black for ADD, Transparent for MIX

Implementation
    public function get texture():Texture2DBase
    public function set texture(value:Texture2DBase):void
viewProjection property
viewProjection:Matrix3D [read-only]

The matrix that projects a point in scene space into the texture coordinates.

Implementation
    public function get viewProjection():Matrix3D
Constructor Detail
TextureProjector () Constructor
public function TextureProjector(texture:Texture2DBase)

Creates a new TextureProjector object.

Parameters
texture:Texture2DBase — The texture to be projected on the geometry. Since any point that is projected out of the range of the projector's cone is clamped to the texture's edges, the edges should be entirely neutral.
Method Detail
invalidateSceneTransform () method
override protected function invalidateSceneTransform():void

Invalidates the scene transformation matrix, causing it to be updated the next time it's requested.


away3d.errors - Away3D Documentation

Package away3d.errors

Classes
AbstractMethodError
AnimationSetError
CastError
DeprecationError
InvalidTextureError


away3d.errors Summary

away3d.errors | Classes

Classes
Class | Description
AbstractMethodError | AbstractMethodError is thrown when an abstract method is called.
AnimationSetError |
CastError |
DeprecationError |
InvalidTextureError | TextureError is thrown when an invalid texture is used regarding Stage3D limitations.

Thu Nov 15 2012, 12:09 PM Z


away3d.errors.AbstractMethodError

AbstractMethodError | Methods
Package | away3d.errors
Class | public class AbstractMethodError
Inheritance | AbstractMethodError Inheritance Error

AbstractMethodError is thrown when an abstract method is called. The method in question should be overridden by a concrete subclass.

Public Methods
Method |  | Defined By
 | AbstractMethodError(message:String = null, id:int = 0) Create a new AbstractMethodError. | AbstractMethodError
Constructor Detail
AbstractMethodError () Constructor
public function AbstractMethodError(message:String = null, id:int = 0)

Create a new AbstractMethodError.

Parameters
message:String (default = null) — An optional message to override the default error message.
id:int (default = 0) — The id of the error.


away3d.errors.AnimationSetError

AnimationSetError | Methods
Package | away3d.errors
Class | public class AnimationSetError
Inheritance | AnimationSetError Inheritance Error

Public Methods
Method |  | Defined By
 | AnimationSetError(message:String) | AnimationSetError
Constructor Detail
AnimationSetError () Constructor
public function AnimationSetError(message:String)

Parameters
message:String


away3d.errors.CastError

CastError | Methods
Package | away3d.errors
Class | public class CastError
Inheritance | CastError Inheritance Error

Public Methods
Method |  | Defined By
 | CastError(message:String) | CastError
Constructor Detail
CastError () Constructor
public function CastError(message:String)

Parameters
message:String


away3d.errors.DeprecationError

DeprecationError | Properties | Methods
Package | away3d.errors
Class | public class DeprecationError
Inheritance | DeprecationError Inheritance Error

Public Properties
Property |  | Defined By
 | info : String [read-only] | DeprecationError
 | since : String [read-only] | DeprecationError
 | source : String [read-only] | DeprecationError
Public Methods
Method |  | Defined By
 | DeprecationError(source:String, since:String, info:String) | DeprecationError
Property Detail
info property
info:String [read-only]

Implementation
    public function get info():String
since property
since:String [read-only]

Implementation
    public function get since():String
source property
source:String [read-only]

Implementation
    public function get source():String
Constructor Detail
DeprecationError () Constructor
public function DeprecationError(source:String, since:String, info:String)

Parameters
source:String
since:String
info:String


away3d.errors.InvalidTextureError

InvalidTextureError | Methods
Package | away3d.errors
Class | public class InvalidTextureError
Inheritance | InvalidTextureError Inheritance Error

TextureError is thrown when an invalid texture is used regarding Stage3D limitations.

Public Methods
Method |  | Defined By
 | InvalidTextureError(message:String = null, id:int = 0) Create a new TextureError. | InvalidTextureError
Constructor Detail
InvalidTextureError () Constructor
public function InvalidTextureError(message:String = null, id:int = 0)

Create a new TextureError.

Parameters
message:String (default = null) — An optional message to override the default error message.
id:int (default = 0) — The id of the error.


away3d.events - Away3D Documentation

Package away3d.events

Classes
AnimationStateEvent
AnimatorEvent
AssetEvent
GeometryEvent
LensEvent
LightEvent
LoaderEvent
MouseEvent3D
Object3DEvent
ParserEvent
PathEvent
Scene3DEvent
ShadingMethodEvent
Stage3DEvent


away3d.events Summary

away3d.events | Classes

Classes
Class | Description
AnimationStateEvent | Dispatched to notify changes in an animation state's state.
AnimatorEvent | Dispatched to notify changes in an animator's state.
AssetEvent |
GeometryEvent | Dispatched to notify changes in a geometry object's state.
LensEvent |
LightEvent |
LoaderEvent | LoaderEvent is an Event dispatched to notify changes in loading state.
MouseEvent3D | A MouseEvent3D is dispatched when a mouse event occurs over a mouseEnabled object in View3D.
Object3DEvent | Passed as a parameter when a 3d object event occurs
ParserEvent |
PathEvent |
Scene3DEvent |
ShadingMethodEvent |
Stage3DEvent |

Thu Nov 15 2012, 12:09 PM Z


away3d.events.AnimationStateEvent

AnimationStateEvent | Properties | Methods | Constants
Package | away3d.events
Class | public class AnimationStateEvent
Inheritance | AnimationStateEvent Inheritance flash.events.Event

Dispatched to notify changes in an animation state's state.

Public Properties
Property |  | Defined By
 | animationNode : AnimationNodeBase [read-only] The animation node inside the animation state from which the event originated. | AnimationStateEvent
 | animationState : IAnimationState [read-only] The animation state object that is the subject of this event. | AnimationStateEvent
 | animator : IAnimator [read-only] The animator object that is the subject of this event. | AnimationStateEvent
Public Methods
Method |  | Defined By
 | AnimationStateEvent(type:String, animator:IAnimator, animationState:IAnimationState, animationNode:AnimationNodeBase) Create a new AnimatonStateEvent | AnimationStateEvent
 | clone():Event [override] Clones the event. | AnimationStateEvent
Public Constants
Constant |  | Defined By
 | PLAYBACK_COMPLETE : String = playbackComplete [static] Dispatched when a non-looping clip node inside an animation state reaches the end of its timeline. | AnimationStateEvent
 | TRANSITION_COMPLETE : String = transitionComplete [static] | AnimationStateEvent
Property Detail
animationNode property
animationNode:AnimationNodeBase [read-only]

The animation node inside the animation state from which the event originated.

Implementation
    public function get animationNode():AnimationNodeBase
animationState property
animationState:IAnimationState [read-only]

The animation state object that is the subject of this event.

Implementation
    public function get animationState():IAnimationState
animator property
animator:IAnimator [read-only]

The animator object that is the subject of this event.

Implementation
    public function get animator():IAnimator
Constructor Detail
AnimationStateEvent () Constructor
public function AnimationStateEvent(type:String, animator:IAnimator, animationState:IAnimationState, animationNode:AnimationNodeBase)

Create a new AnimatonStateEvent

Parameters
type:String — The event type.
animator:IAnimator — The animation state object that is the subject of this event.
animationState:IAnimationState — The animation node inside the animation state from which the event originated.
animationNode:AnimationNodeBase
Method Detail
clone () method
override public function clone():Event

Clones the event.

Returns
Event — An exact duplicate of the current object.
Constant Detail
PLAYBACK_COMPLETE Constant
public static const PLAYBACK_COMPLETE:String = playbackComplete

Dispatched when a non-looping clip node inside an animation state reaches the end of its timeline.

TRANSITION_COMPLETE Constant
public static const TRANSITION_COMPLETE:String = transitionComplete


away3d.events.AnimatorEvent

AnimatorEvent | Properties | Methods | Constants
Package | away3d.events
Class | public class AnimatorEvent
Inheritance | AnimatorEvent Inheritance flash.events.Event

Dispatched to notify changes in an animator's state.

Public Properties
Property |  | Defined By
 | animator : AnimatorBase [read-only] | AnimatorEvent
Public Methods
Method |  | Defined By
 | AnimatorEvent(type:String, animator:AnimatorBase) Create a new AnimatorEvent object. | AnimatorEvent
 | clone():Event [override] Clones the event. | AnimatorEvent
Public Constants
Constant |  | Defined By
 | START : String = start [static] Defines the value of the type property of a start event object. | AnimatorEvent
 | STOP : String = stop [static] Defines the value of the type property of a stop event object. | AnimatorEvent
Property Detail
animator property
animator:AnimatorBase [read-only]

Implementation
    public function get animator():AnimatorBase
Constructor Detail
AnimatorEvent () Constructor
public function AnimatorEvent(type:String, animator:AnimatorBase)

Create a new AnimatorEvent object.

Parameters
type:String — The event type.
animator:AnimatorBase — The animator object that is the subject of this event.
Method Detail
clone () method
override public function clone():Event

Clones the event.

Returns
Event — An exact duplicate of the current event object.
Constant Detail
START Constant
public static const START:String = start

Defines the value of the type property of a start event object.

STOP Constant
public static const STOP:String = stop

Defines the value of the type property of a stop event object.


away3d.events.AssetEvent

AssetEvent | Properties | Methods | Constants
Package | away3d.events
Class | public class AssetEvent
Inheritance | AssetEvent Inheritance flash.events.Event

Public Properties
Property |  | Defined By
 | asset : IAsset [read-only] | AssetEvent
 | assetPrevName : String [read-only] | AssetEvent
Public Methods
Method |  | Defined By
 | AssetEvent(type:String, asset:IAsset = null, prevName:String = null) | AssetEvent
 | clone():Event [override] | AssetEvent
Public Constants
Constant |  | Defined By
 | ANIMATION_NODE_COMPLETE : String = animationNodeComplete [static] | AssetEvent
 | ANIMATION_SET_COMPLETE : String = animationSetComplete [static] | AssetEvent
 | ANIMATION_STATE_COMPLETE : String = animationStateComplete [static] | AssetEvent
 | ASSET_COMPLETE : String = assetComplete [static] | AssetEvent
 | ASSET_CONFLICT_RESOLVED : String = assetConflictResolved [static] | AssetEvent
 | ASSET_RENAME : String = assetRename [static] | AssetEvent
 | CONTAINER_COMPLETE : String = containerComplete [static] | AssetEvent
 | ENTITY_COMPLETE : String = entityComplete [static] | AssetEvent
 | GEOMETRY_COMPLETE : String = geometryComplete [static] | AssetEvent
 | MATERIAL_COMPLETE : String = materialComplete [static] | AssetEvent
 | MESH_COMPLETE : String = meshComplete [static] | AssetEvent
 | SEGMENT_SET_COMPLETE : String = segmentSetComplete [static] | AssetEvent
 | SKELETON_COMPLETE : String = skeletonComplete [static] | AssetEvent
 | SKELETON_POSE_COMPLETE : String = skeletonPoseComplete [static] | AssetEvent
 | STATE_TRANSITION_COMPLETE : String = stateTransitionComplete [static] | AssetEvent
 | TEXTURE_COMPLETE : String = textureComplete [static] | AssetEvent
Property Detail
asset property
asset:IAsset [read-only]

Implementation
    public function get asset():IAsset
assetPrevName property
assetPrevName:String [read-only]

Implementation
    public function get assetPrevName():String
Constructor Detail
AssetEvent () Constructor
public function AssetEvent(type:String, asset:IAsset = null, prevName:String = null)

Parameters
type:String
asset:IAsset (default = null)
prevName:String (default = null)
Method Detail
clone () method
override public function clone():Event

Returns
Event
Constant Detail
ANIMATION_NODE_COMPLETE Constant
public static const ANIMATION_NODE_COMPLETE:String = animationNodeComplete

ANIMATION_SET_COMPLETE Constant
public static const ANIMATION_SET_COMPLETE:String = animationSetComplete

ANIMATION_STATE_COMPLETE Constant
public static const ANIMATION_STATE_COMPLETE:String = animationStateComplete

ASSET_COMPLETE Constant
public static const ASSET_COMPLETE:String = assetComplete

ASSET_CONFLICT_RESOLVED Constant
public static const ASSET_CONFLICT_RESOLVED:String = assetConflictResolved

ASSET_RENAME Constant
public static const ASSET_RENAME:String = assetRename

CONTAINER_COMPLETE Constant
public static const CONTAINER_COMPLETE:String = containerComplete

ENTITY_COMPLETE Constant
public static const ENTITY_COMPLETE:String = entityComplete

GEOMETRY_COMPLETE Constant
public static const GEOMETRY_COMPLETE:String = geometryComplete

MATERIAL_COMPLETE Constant
public static const MATERIAL_COMPLETE:String = materialComplete

MESH_COMPLETE Constant
public static const MESH_COMPLETE:String = meshComplete

SEGMENT_SET_COMPLETE Constant
public static const SEGMENT_SET_COMPLETE:String = segmentSetComplete

SKELETON_COMPLETE Constant
public static const SKELETON_COMPLETE:String = skeletonComplete

SKELETON_POSE_COMPLETE Constant
public static const SKELETON_POSE_COMPLETE:String = skeletonPoseComplete

STATE_TRANSITION_COMPLETE Constant
public static const STATE_TRANSITION_COMPLETE:String = stateTransitionComplete

TEXTURE_COMPLETE Constant
public static const TEXTURE_COMPLETE:String = textureComplete


away3d.events.GeometryEvent

GeometryEvent | Properties | Methods | Constants
Package | away3d.events
Class | public class GeometryEvent
Inheritance | GeometryEvent Inheritance flash.events.Event

Dispatched to notify changes in a geometry object's state.

See also

away3d.core.base.Geometry

Public Properties
Property |  | Defined By
 | subGeometry : ISubGeometry [read-only] The SubGeometry object that is the subject of this event, if appropriate. | GeometryEvent
Public Methods
Method |  | Defined By
 | GeometryEvent(type:String, subGeometry:ISubGeometry = null) Create a new GeometryEvent | GeometryEvent
 | clone():Event [override] Clones the event. | GeometryEvent
Public Constants
Constant |  | Defined By
 | BOUNDS_INVALID : String = BoundsInvalid [static] | GeometryEvent
 | SUB_GEOMETRY_ADDED : String = SubGeometryAdded [static] Dispatched when a SubGeometry was added from the dispatching Geometry. | GeometryEvent
 | SUB_GEOMETRY_REMOVED : String = SubGeometryRemoved [static] Dispatched when a SubGeometry was removed from the dispatching Geometry. | GeometryEvent
Property Detail
subGeometry property
subGeometry:ISubGeometry [read-only]

The SubGeometry object that is the subject of this event, if appropriate.

Implementation
    public function get subGeometry():ISubGeometry
Constructor Detail
GeometryEvent () Constructor
public function GeometryEvent(type:String, subGeometry:ISubGeometry = null)

Create a new GeometryEvent

Parameters
type:String — The event type.
subGeometry:ISubGeometry (default = null) — An optional SubGeometry object that is the subject of this event.
Method Detail
clone () method
override public function clone():Event

Clones the event.

Returns
Event — An exact duplicate of the current object.
Constant Detail
BOUNDS_INVALID Constant
public static const BOUNDS_INVALID:String = BoundsInvalid

SUB_GEOMETRY_ADDED Constant
public static const SUB_GEOMETRY_ADDED:String = SubGeometryAdded

Dispatched when a SubGeometry was added from the dispatching Geometry.

SUB_GEOMETRY_REMOVED Constant
public static const SUB_GEOMETRY_REMOVED:String = SubGeometryRemoved

Dispatched when a SubGeometry was removed from the dispatching Geometry.


away3d.events.LensEvent

LensEvent | Properties | Methods | Constants
Package | away3d.events
Class | public class LensEvent
Inheritance | LensEvent Inheritance flash.events.Event

Public Properties
Property |  | Defined By
 | lens : LensBase [read-only] | LensEvent
Public Methods
Method |  | Defined By
 | LensEvent(type:String, lens:LensBase, bubbles:Boolean = false, cancelable:Boolean = false) | LensEvent
 | clone():Event [override] | LensEvent
Public Constants
Constant |  | Defined By
 | MATRIX_CHANGED : String = matrixChanged [static] | LensEvent
Property Detail
lens property
lens:LensBase [read-only]

Implementation
    public function get lens():LensBase
Constructor Detail
LensEvent () Constructor
public function LensEvent(type:String, lens:LensBase, bubbles:Boolean = false, cancelable:Boolean = false)

Parameters
type:String
lens:LensBase
bubbles:Boolean (default = false)
cancelable:Boolean (default = false)
Method Detail
clone () method
override public function clone():Event

Returns
Event
Constant Detail
MATRIX_CHANGED Constant
public static const MATRIX_CHANGED:String = matrixChanged


away3d.events.LightEvent

LightEvent | Methods | Constants
Package | away3d.events
Class | public class LightEvent
Inheritance | LightEvent Inheritance flash.events.Event

Public Methods
Method |  | Defined By
 | LightEvent(type:String) | LightEvent
 | clone():Event [override] | LightEvent
Public Constants
Constant |  | Defined By
 | CASTS_SHADOW_CHANGE : String = castsShadowChange [static] | LightEvent
Constructor Detail
LightEvent () Constructor
public function LightEvent(type:String)

Parameters
type:String
Method Detail
clone () method
override public function clone():Event

Returns
Event
Constant Detail
CASTS_SHADOW_CHANGE Constant
public static const CASTS_SHADOW_CHANGE:String = castsShadowChange


away3d.events.LoaderEvent

LoaderEvent | Properties | Methods | Constants
Package | away3d.events
Class | public class LoaderEvent
Inheritance | LoaderEvent Inheritance flash.events.Event

LoaderEvent is an Event dispatched to notify changes in loading state.

Public Properties
Property |  | Defined By
 | isDependency : Boolean [read-only] Indicates whether the event occurred while loading a dependency, as opposed to the base file. | LoaderEvent
 | message : String [read-only] The error string on loadError. | LoaderEvent
 | url : String [read-only] The url of the loaded resource. | LoaderEvent
Public Methods
Method |  | Defined By
 | LoaderEvent(type:String, url:String = null, isDependency:Boolean = false, errmsg:String = null) Create a new LoaderEvent object. | LoaderEvent
 | clone():Event [override] Clones the current event. | LoaderEvent
 | isDefaultPrevented():Boolean [override] | LoaderEvent
 | preventDefault():void [override] | LoaderEvent
Public Constants
Constant |  | Defined By
 | DEPENDENCY_COMPLETE : String = dependencyComplete [static] Dispatched when a resource's dependency is retrieved and resolved. | LoaderEvent
 | LOAD_ERROR : String = loadError [static] Dispatched when loading of a asset failed. | LoaderEvent
 | RESOURCE_COMPLETE : String = resourceComplete [static] Dispatched when a resource and all of its dependencies is retrieved. | LoaderEvent
Property Detail
isDependency property
isDependency:Boolean [read-only]

Indicates whether the event occurred while loading a dependency, as opposed to the base file. Dependencies can be textures or other files that are referenced by the base file.

Implementation
    public function get isDependency():Boolean
message property
message:String [read-only]

The error string on loadError.

Implementation
    public function get message():String
url property
url:String [read-only]

The url of the loaded resource.

Implementation
    public function get url():String
Constructor Detail
LoaderEvent () Constructor
public function LoaderEvent(type:String, url:String = null, isDependency:Boolean = false, errmsg:String = null)

Create a new LoaderEvent object.

Parameters
type:String — The event type.
url:String (default = null) — The loaded or parsed resource.
isDependency:Boolean (default = false) — The url of the loaded resource.
errmsg:String (default = null)
Method Detail
clone () method
override public function clone():Event

Clones the current event.

Returns
Event — An exact duplicate of the current event.
isDefaultPrevented () method
override public function isDefaultPrevented():Boolean

Returns
Boolean
preventDefault () method
override public function preventDefault():void

Constant Detail
DEPENDENCY_COMPLETE Constant
public static const DEPENDENCY_COMPLETE:String = dependencyComplete

Dispatched when a resource's dependency is retrieved and resolved.

LOAD_ERROR Constant
public static const LOAD_ERROR:String = loadError

Dispatched when loading of a asset failed. Such as wrong parser type, unsupported extensions, parsing errors, malformated or unsupported 3d file etc..

RESOURCE_COMPLETE Constant
public static const RESOURCE_COMPLETE:String = resourceComplete

Dispatched when a resource and all of its dependencies is retrieved.


away3d.events.MouseEvent3D

MouseEvent3D | Properties | Methods | Constants
Package | away3d.events
Class | public class MouseEvent3D
Inheritance | MouseEvent3D Inheritance flash.events.Event

A MouseEvent3D is dispatched when a mouse event occurs over a mouseEnabled object in View3D. todo: we don't have screenZ data, nor global coords, tho this should be easy to implement

Public Properties
Property |  | Defined By
 | altKey : Boolean Indicates whether the Alt key is active (true) or inactive (false). | MouseEvent3D
 | bubbles : Boolean [override] [read-only] | MouseEvent3D
 | ctrlKey : Boolean Indicates whether the Control key is active (true) or inactive (false). | MouseEvent3D
 | delta : int Indicates how many lines should be scrolled for each unit the user rotates the mouse wheel. | MouseEvent3D
 | localNormal : Vector3D The normal in object space where the event took place | MouseEvent3D
 | localPosition : Vector3D The position in object space where the event took place | MouseEvent3D
 | material : MaterialBase The material of the 3d element inside which the event took place. | MouseEvent3D
 | object : ObjectContainer3D The 3d object inside which the event took place. | MouseEvent3D
 | renderable : IRenderable The renderable inside which the event took place. | MouseEvent3D
 | sceneNormal : Vector3D [read-only] The normal in scene space where the event took place | MouseEvent3D
 | scenePosition : Vector3D [read-only] The position in scene space where the event took place | MouseEvent3D
 | screenX : Number The horizontal coordinate at which the event occurred in view coordinates. | MouseEvent3D
 | screenY : Number The vertical coordinate at which the event occurred in view coordinates. | MouseEvent3D
 | shiftKey : Boolean Indicates whether the Shift key is active (true) or inactive (false). | MouseEvent3D
 | uv : Point The uv coordinate inside the draw primitive where the event took place. | MouseEvent3D
 | view : View3D The view object inside which the event took place. | MouseEvent3D
Public Methods
Method |  | Defined By
 | MouseEvent3D(type:String) Create a new MouseEvent3D object. | MouseEvent3D
 | clone():Event [override] Creates a copy of the MouseEvent3D object and sets the value of each property to match that of the original. | MouseEvent3D
 | stopImmediatePropagation():void [override] | MouseEvent3D
 | stopPropagation():void [override] | MouseEvent3D
Public Constants
Constant |  | Defined By
 | CLICK : String = click3d [static] Defines the value of the type property of a click3d event object. | MouseEvent3D
 | DOUBLE_CLICK : String = doubleClick3d [static] Defines the value of the type property of a doubleClick3d event object. | MouseEvent3D
 | MOUSE_DOWN : String = mouseDown3d [static] Defines the value of the type property of a mouseDown3d event object. | MouseEvent3D
 | MOUSE_MOVE : String = mouseMove3d [static] Defines the value of the type property of a mouseMove3d event object. | MouseEvent3D
 | MOUSE_OUT : String = mouseOut3d [static] Defines the value of the type property of a mouseOut3d event object. | MouseEvent3D
 | MOUSE_OVER : String = mouseOver3d [static] Defines the value of the type property of a mouseOver3d event object. | MouseEvent3D
 | MOUSE_UP : String = mouseUp3d [static] Defines the value of the type property of a mouseUp3d event object. | MouseEvent3D
 | MOUSE_WHEEL : String = mouseWheel3d [static] Defines the value of the type property of a mouseWheel3d event object. | MouseEvent3D
Property Detail
altKey property
public var altKey:Boolean

Indicates whether the Alt key is active (true) or inactive (false).

bubbles property
bubbles:Boolean [read-only] [override]

Implementation
    public function get bubbles():Boolean
ctrlKey property
public var ctrlKey:Boolean

Indicates whether the Control key is active (true) or inactive (false).

delta property
public var delta:int

Indicates how many lines should be scrolled for each unit the user rotates the mouse wheel.

localNormal property
public var localNormal:Vector3D

The normal in object space where the event took place

localPosition property
public var localPosition:Vector3D

The position in object space where the event took place

material property
public var material:MaterialBase

The material of the 3d element inside which the event took place.

object property
public var object:ObjectContainer3D

The 3d object inside which the event took place.

renderable property
public var renderable:IRenderable

The renderable inside which the event took place.

sceneNormal property
sceneNormal:Vector3D [read-only]

The normal in scene space where the event took place

Implementation
    public function get sceneNormal():Vector3D
scenePosition property
scenePosition:Vector3D [read-only]

The position in scene space where the event took place

Implementation
    public function get scenePosition():Vector3D
screenX property
public var screenX:Number

The horizontal coordinate at which the event occurred in view coordinates.

screenY property
public var screenY:Number

The vertical coordinate at which the event occurred in view coordinates.

shiftKey property
public var shiftKey:Boolean

Indicates whether the Shift key is active (true) or inactive (false).

uv property
public var uv:Point

The uv coordinate inside the draw primitive where the event took place.

view property
public var view:View3D

The view object inside which the event took place.

Constructor Detail
MouseEvent3D () Constructor
public function MouseEvent3D(type:String)

Create a new MouseEvent3D object.

Parameters
type:String — The type of the MouseEvent3D.
Method Detail
clone () method
override public function clone():Event

Creates a copy of the MouseEvent3D object and sets the value of each property to match that of the original.

Returns
Event
stopImmediatePropagation () method
override public function stopImmediatePropagation():void

stopPropagation () method
override public function stopPropagation():void

Constant Detail
CLICK Constant
public static const CLICK:String = click3d

Defines the value of the type property of a click3d event object.

DOUBLE_CLICK Constant
public static const DOUBLE_CLICK:String = doubleClick3d

Defines the value of the type property of a doubleClick3d event object.

MOUSE_DOWN Constant
public static const MOUSE_DOWN:String = mouseDown3d

Defines the value of the type property of a mouseDown3d event object.

MOUSE_MOVE Constant
public static const MOUSE_MOVE:String = mouseMove3d

Defines the value of the type property of a mouseMove3d event object.

MOUSE_OUT Constant
public static const MOUSE_OUT:String = mouseOut3d

Defines the value of the type property of a mouseOut3d event object.

MOUSE_OVER Constant
public static const MOUSE_OVER:String = mouseOver3d

Defines the value of the type property of a mouseOver3d event object.

MOUSE_UP Constant
public static const MOUSE_UP:String = mouseUp3d

Defines the value of the type property of a mouseUp3d event object.

MOUSE_WHEEL Constant
public static const MOUSE_WHEEL:String = mouseWheel3d

Defines the value of the type property of a mouseWheel3d event object.


away3d.events.Object3DEvent

Object3DEvent | Properties | Methods | Constants
Package | away3d.events
Class | public class Object3DEvent
Inheritance | Object3DEvent Inheritance flash.events.Event

Passed as a parameter when a 3d object event occurs

Public Properties
Property |  | Defined By
 | object : Object3D A reference to the 3d object that is relevant to the event. | Object3DEvent
Public Methods
Method |  | Defined By
 | Object3DEvent(type:String, object:Object3D) Creates a new MaterialEvent object. | Object3DEvent
 | clone():Event [override] Creates a copy of the Object3DEvent object and sets the value of each property to match that of the original. | Object3DEvent
Public Constants
Constant |  | Defined By
 | POSITION_CHANGED : String = positionChanged [static] Defines the value of the type property of a positionChanged event object. | Object3DEvent
 | ROTATION_CHANGED : String = rotationChanged [static] Defines the value of the type property of a rotationChanged event object. | Object3DEvent
 | SCALE_CHANGED : String = scaleChanged [static] Defines the value of the type property of a scaleChanged event object. | Object3DEvent
 | SCENE_CHANGED : String = sceneChanged [static] Defines the value of the type property of a sceneChanged event object. | Object3DEvent
 | SCENETRANSFORM_CHANGED : String = scenetransformChanged [static] Defines the value of the type property of a scenetransformChanged event object. | Object3DEvent
 | VISIBLITY_UPDATED : String = visiblityUpdated [static] Defines the value of the type property of a visiblityUpdated event object. | Object3DEvent
Property Detail
object property
public var object:Object3D

A reference to the 3d object that is relevant to the event.

Constructor Detail
Object3DEvent () Constructor
public function Object3DEvent(type:String, object:Object3D)

Creates a new MaterialEvent object.

Parameters
type:String — The type of the event. Possible values are: Object3DEvent.TRANSFORM_CHANGED, Object3DEvent.SCENETRANSFORM_CHANGED, Object3DEvent.SCENE_CHANGED, Object3DEvent.RADIUS_CHANGED and Object3DEvent.DIMENSIONS_CHANGED.
object:Object3D — A reference to the 3d object that is relevant to the event.
Method Detail
clone () method
override public function clone():Event

Creates a copy of the Object3DEvent object and sets the value of each property to match that of the original.

Returns
Event
Constant Detail
POSITION_CHANGED Constant
public static const POSITION_CHANGED:String = positionChanged

Defines the value of the type property of a positionChanged event object.

ROTATION_CHANGED Constant
public static const ROTATION_CHANGED:String = rotationChanged

Defines the value of the type property of a rotationChanged event object.

SCALE_CHANGED Constant
public static const SCALE_CHANGED:String = scaleChanged

Defines the value of the type property of a scaleChanged event object.

SCENE_CHANGED Constant
public static const SCENE_CHANGED:String = sceneChanged

Defines the value of the type property of a sceneChanged event object.

SCENETRANSFORM_CHANGED Constant
public static const SCENETRANSFORM_CHANGED:String = scenetransformChanged

Defines the value of the type property of a scenetransformChanged event object.

VISIBLITY_UPDATED Constant
public static const VISIBLITY_UPDATED:String = visiblityUpdated

Defines the value of the type property of a visiblityUpdated event object.


away3d.events.ParserEvent

ParserEvent | Properties | Methods | Constants
Package | away3d.events
Class | public class ParserEvent
Inheritance | ParserEvent Inheritance flash.events.Event

Public Properties
Property |  | Defined By
 | message : String [read-only] Additional human-readable message. | ParserEvent
Public Methods
Method |  | Defined By
 | ParserEvent(type:String, message:String) | ParserEvent
 | clone():Event [override] | ParserEvent
Public Constants
Constant |  | Defined By
 | PARSE_COMPLETE : String = parseComplete [static] Dispatched when parsing of an asset completed. | ParserEvent
 | PARSE_ERROR : String = parseError [static] Dispatched when an error occurs while parsing the data (e.g. | ParserEvent
 | READY_FOR_DEPENDENCIES : String = readyForDependencies [static] Dispatched when a parser is ready to have dependencies retrieved and resolved. | ParserEvent
Property Detail
message property
message:String [read-only]

Additional human-readable message. Usually supplied for PARSE_ERROR events.

Implementation
    public function get message():String
Constructor Detail
ParserEvent () Constructor
public function ParserEvent(type:String, message:String)

Parameters
type:String
message:String
Method Detail
clone () method
override public function clone():Event

Returns
Event
Constant Detail
PARSE_COMPLETE Constant
public static const PARSE_COMPLETE:String = parseComplete

Dispatched when parsing of an asset completed.

PARSE_ERROR Constant
public static const PARSE_ERROR:String = parseError

Dispatched when an error occurs while parsing the data (e.g. because it's incorrectly formatted.)

READY_FOR_DEPENDENCIES Constant
public static const READY_FOR_DEPENDENCIES:String = readyForDependencies

Dispatched when a parser is ready to have dependencies retrieved and resolved. This is an internal event that should rarely (if ever) be listened for by external classes.


away3d.events.PathEvent

PathEvent | Methods | Constants
Package | away3d.events
Class | public class PathEvent
Inheritance | PathEvent Inheritance flash.events.Event

Public Methods
Method |  | Defined By
 | PathEvent(type:String) | PathEvent
Public Constants
Constant |  | Defined By
 | CHANGE_SEGMENT : String = change_segment [static] Dispatched when the time pointer enters a new PathSegment | PathEvent
 | CYCLE : String = cycle [static] Dispatched when the time pointer enter a new cycle at time 0, after last time was greater than 0.99 | PathEvent
 | RANGE : String = range [static] Dispatched when the time pointer is included a given from/to time region on a path | PathEvent
Constructor Detail
PathEvent () Constructor
public function PathEvent(type:String)

Parameters
type:String
Constant Detail
CHANGE_SEGMENT Constant
public static const CHANGE_SEGMENT:String = change_segment

Dispatched when the time pointer enters a new PathSegment

CYCLE Constant
public static const CYCLE:String = cycle

Dispatched when the time pointer enter a new cycle at time 0, after last time was greater than 0.99

RANGE Constant
public static const RANGE:String = range

Dispatched when the time pointer is included a given from/to time region on a path


away3d.events.Scene3DEvent

Scene3DEvent | Properties | Methods | Constants
Package | away3d.events
Class | public class Scene3DEvent
Inheritance | Scene3DEvent Inheritance flash.events.Event

Public Properties
Property |  | Defined By
 | objectContainer3D : ObjectContainer3D | Scene3DEvent
 | target : Object [override] [read-only] | Scene3DEvent
Public Methods
Method |  | Defined By
 | Scene3DEvent(type:String, objectContainer:ObjectContainer3D) | Scene3DEvent
 | clone():Event [override] | Scene3DEvent
Public Constants
Constant |  | Defined By
 | ADDED_TO_SCENE : String = addedToScene [static] | Scene3DEvent
 | REMOVED_FROM_SCENE : String = removedFromScene [static] | Scene3DEvent
Property Detail
objectContainer3D property
public var objectContainer3D:ObjectContainer3D

target property
target:Object [read-only] [override]

Implementation
    public function get target():Object
Constructor Detail
Scene3DEvent () Constructor
public function Scene3DEvent(type:String, objectContainer:ObjectContainer3D)

Parameters
type:String
objectContainer:ObjectContainer3D
Method Detail
clone () method
override public function clone():Event

Returns
Event
Constant Detail
ADDED_TO_SCENE Constant
public static const ADDED_TO_SCENE:String = addedToScene

REMOVED_FROM_SCENE Constant
public static const REMOVED_FROM_SCENE:String = removedFromScene


away3d.events.ShadingMethodEvent

ShadingMethodEvent | Methods | Constants
Package | away3d.events
Class | public class ShadingMethodEvent
Inheritance | ShadingMethodEvent Inheritance flash.events.Event

Public Methods
Method |  | Defined By
 | ShadingMethodEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false) | ShadingMethodEvent
Public Constants
Constant |  | Defined By
 | SHADER_INVALIDATED : String = ShaderInvalidated [static] | ShadingMethodEvent
Constructor Detail
ShadingMethodEvent () Constructor
public function ShadingMethodEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false)

Parameters
type:String
bubbles:Boolean (default = false)
cancelable:Boolean (default = false)
Constant Detail
SHADER_INVALIDATED Constant
public static const SHADER_INVALIDATED:String = ShaderInvalidated


away3d.events.Stage3DEvent

Stage3DEvent | Methods | Constants
Package | away3d.events
Class | public class Stage3DEvent
Inheritance | Stage3DEvent Inheritance flash.events.Event

Public Methods
Method |  | Defined By
 | Stage3DEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false) | Stage3DEvent
Public Constants
Constant |  | Defined By
 | CONTEXT3D_CREATED : String = Context3DCreated [static] | Stage3DEvent
 | CONTEXT3D_DISPOSED : String = Context3DDisposed [static] | Stage3DEvent
 | CONTEXT3D_RECREATED : String = Context3DRecreated [static] | Stage3DEvent
Constructor Detail
Stage3DEvent () Constructor
public function Stage3DEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false)

Parameters
type:String
bubbles:Boolean (default = false)
cancelable:Boolean (default = false)
Constant Detail
CONTEXT3D_CREATED Constant
public static const CONTEXT3D_CREATED:String = Context3DCreated

CONTEXT3D_DISPOSED Constant
public static const CONTEXT3D_DISPOSED:String = Context3DDisposed

CONTEXT3D_RECREATED Constant
public static const CONTEXT3D_RECREATED:String = Context3DRecreated


away3d.extrusions - Away3D Documentation

Package away3d.extrusions

Classes
DelaunayMesh
Elevation
LatheExtrude
LinearExtrude
PathDuplicator
PathExtrude
SkinExtrude


away3d.extrusions Summary

away3d.extrusions | Classes

Classes
Class | Description
DelaunayMesh |
Elevation |
LatheExtrude | Class for generating meshes with axial symmetry such as donuts, pipes, vases etc.
LinearExtrude |
PathDuplicator |
PathExtrude |
SkinExtrude |

Thu Nov 15 2012, 12:09 PM Z


away3d.extrusions.DelaunayMesh

DelaunayMesh | Properties | Methods | Events | Constants
Package | away3d.extrusions
Class | public class DelaunayMesh
Inheritance | DelaunayMesh Inheritance Mesh Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator Defines the animator of the mesh. | Mesh
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Mesh
Inherited | backVector : Vector3D [read-only] | Object3D
 | bounds : BoundingVolumeBase [override] The bounding volume approximating the volume occupied by the Entity. | DelaunayMesh
Inherited | castsShadows : Boolean Indicates whether or not the Mesh can cast shadows | Mesh
 | centerMesh : Boolean Defines whether the mesh is recentered of not after generation | DelaunayMesh
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
 | flip : Boolean Defines if the face orientation needs to be inverted | DelaunayMesh
Inherited | forwardVector : Vector3D [read-only] | Object3D
 | geometry : Geometry [override] The geometry used by the mesh that provides it with its shape. | DelaunayMesh
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase The material with which to render the Mesh. | Mesh
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
 | plane : String Defines the projection plane for the class. | DelaunayMesh
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
 | smoothSurface : Boolean Defines if the surface of the mesh must be smoothed or not. | DelaunayMesh
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
 | subMeshes : Vector.<SubMesh> [override] [read-only] The SubMeshes out of which the Mesh consists. | DelaunayMesh
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
 | vectors : Vector.<Vector3D> The "cloud" of vector3d's to compose the mesh | DelaunayMesh
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _geometry : Geometry | Mesh
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DelaunayMesh(material:MaterialBase, vectors:Vector.<Vector3D>, plane:String, centerMesh:Boolean = false, flip:Boolean = false, smoothSurface:Boolean = true) | DelaunayMesh
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | bakeTransformations():void | Mesh
Inherited | clone():Object3D [override] Clones this Mesh instance along with all it's children, while re-using the same material and geometry instance. | Mesh
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | Mesh
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getSubMeshForSubGeometry(subGeometry:SubGeometry):SubMesh | Mesh
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createEntityPartitionNode():EntityNode [override] Factory method that returns the current partition node. | Mesh
Inherited | getDefaultBoundingVolume():BoundingVolumeBase Creates the default bounding box to be used by this type of Entity. | Entity
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] Updates the bounding volume for the object. | Mesh
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
 | PLANE_XY : String = xy [static] | DelaunayMesh
 | PLANE_XZ : String = xz [static] | DelaunayMesh
 | PLANE_ZY : String = zy [static] | DelaunayMesh
Property Detail
bounds property
bounds:BoundingVolumeBase[override]

The bounding volume approximating the volume occupied by the Entity.

Implementation
    public function get bounds():BoundingVolumeBase
    public function set bounds(value:BoundingVolumeBase):void
centerMesh property
centerMesh:Boolean

Defines whether the mesh is recentered of not after generation

Implementation
    public function get centerMesh():Boolean
    public function set centerMesh(value:Boolean):void
flip property
flip:Boolean

Defines if the face orientation needs to be inverted

Implementation
    public function get flip():Boolean
    public function set flip(value:Boolean):void
geometry property
geometry:Geometry[override]

The geometry used by the mesh that provides it with its shape.

Implementation
    public function get geometry():Geometry
    public function set geometry(value:Geometry):void
plane property
plane:String

Defines the projection plane for the class. Default is xz.

Implementation
    public function get plane():String
    public function set plane(value:String):void
smoothSurface property
smoothSurface:Boolean

Defines if the surface of the mesh must be smoothed or not. Default value is true.

Implementation
    public function get smoothSurface():Boolean
    public function set smoothSurface(value:Boolean):void
subMeshes property
subMeshes:Vector.<SubMesh> [read-only] [override]

The SubMeshes out of which the Mesh consists. Every SubMesh can be assigned a material to override the Mesh's material.

Implementation
    public function get subMeshes():Vector.<SubMesh>
vectors property
vectors:Vector.<Vector3D>

The "cloud" of vector3d's to compose the mesh

Implementation
    public function get vectors():Vector.<Vector3D>
    public function set vectors(value:Vector.<Vector3D>):void
Constructor Detail
DelaunayMesh () Constructor
public function DelaunayMesh(material:MaterialBase, vectors:Vector.<Vector3D>, plane:String, centerMesh:Boolean = false, flip:Boolean = false, smoothSurface:Boolean = true)

Parameters
material:MaterialBase
vectors:Vector.<Vector3D>
plane:String (default = NaN)
centerMesh:Boolean (default = false)
flip:Boolean (default = false)
smoothSurface:Boolean (default = true)
Constant Detail
PLANE_XY Constant
public static const PLANE_XY:String = xy

PLANE_XZ Constant
public static const PLANE_XZ:String = xz

PLANE_ZY Constant
public static const PLANE_ZY:String = zy


away3d.extrusions.Elevation

Elevation | Properties | Methods | Events | Constants
Package | away3d.extrusions
Class | public class Elevation
Inheritance | Elevation Inheritance Mesh Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator Defines the animator of the mesh. | Mesh
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Mesh
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
Inherited | castsShadows : Boolean Indicates whether or not the Mesh can cast shadows | Mesh
 | depth : Number The depth of the terrain plane. | Elevation
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | geometry : Geometry The geometry used by the mesh that provides it with its shape. | Mesh
 | height : Number | Elevation
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase The material with which to render the Mesh. | Mesh
 | maxElevation : uint Locks elevation factor above this color reading level. | Elevation
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
 | minElevation : uint Locks elevation factor beneath this color reading level. | Elevation
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
 | segmentsH : uint The number of segments that make up the plane along the Y or Z-axis, depending on whether yUp is true or false, respectively. | Elevation
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
 | smoothedHeightMap : BitmapData [read-only] | Elevation
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | subMeshes : Vector.<SubMesh> [read-only] The SubMeshes out of which the Mesh consists. | Mesh
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
 | width : Number The width of the terrain plane. | Elevation
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
 | _geomDirty : Boolean = true | Elevation
Inherited | _geometry : Geometry | Mesh
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
 | _uvDirty : Boolean = true | Elevation
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Elevation(material:MaterialBase, heightMap:BitmapData, width:Number = 1000, height:Number = 100, depth:Number = 1000, segmentsW:uint = 30, segmentsH:uint = 30, maxElevation:uint = 255, minElevation:uint = 0, smoothMap:Boolean = false) Class Elevation generates (and becomes) a mesh from an heightmap. | Elevation
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | bakeTransformations():void | Mesh
Inherited | clone():Object3D [override] Clones this Mesh instance along with all it's children, while re-using the same material and geometry instance. | Mesh
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | Mesh
Inherited | disposeAsset():void | Object3D
 | generateSmoothedHeightMap():BitmapData Generates a smoother representation of the geometry using the original heightmap and subdivision settings. | Elevation
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
 | getHeightAt(x:Number, z:Number):Number Reading the terrain height from a given x z position for surface tracking purposes | Elevation
Inherited | getSubMeshForSubGeometry(subGeometry:SubGeometry):SubMesh | Mesh
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createEntityPartitionNode():EntityNode [override] Factory method that returns the current partition node. | Mesh
Inherited | getDefaultBoundingVolume():BoundingVolumeBase Creates the default bounding box to be used by this type of Entity. | Entity
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
 | invalidateGeometry():void Invalidates the primitive's geometry, causing it to be updated when requested. | Elevation
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
 | invalidateUVs():void Invalidates the primitive's uv coordinates, causing them to be updated when requested. | Elevation
Inherited | updateBounds():void [override] Updates the bounding volume for the object. | Mesh
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_geomDirty property
protected var _geomDirty:Boolean = true

_uvDirty property
protected var _uvDirty:Boolean = true

depth property
depth:Number

The depth of the terrain plane.

Implementation
    public function get depth():Number
    public function set depth(value:Number):void
height property
height:Number

Implementation
    public function get height():Number
    public function set height(value:Number):void
maxElevation property
maxElevation:uint

Locks elevation factor above this color reading level. Default is 255; Allows to build "canyon" like landscapes with no additional work on heightmap source.

Implementation
    public function get maxElevation():uint
    public function set maxElevation(value:uint):void
minElevation property
minElevation:uint

Locks elevation factor beneath this color reading level. Default is 0;

Implementation
    public function get minElevation():uint
    public function set minElevation(value:uint):void
segmentsH property
segmentsH:uint

The number of segments that make up the plane along the Y or Z-axis, depending on whether yUp is true or false, respectively. Defaults to 1.

Implementation
    public function get segmentsH():uint
    public function set segmentsH(value:uint):void
smoothedHeightMap property
smoothedHeightMap:BitmapData [read-only]

Implementation
    public function get smoothedHeightMap():BitmapData
width property
width:Number

The width of the terrain plane.

Implementation
    public function get width():Number
    public function set width(value:Number):void
Constructor Detail
Elevation () Constructor
public function Elevation(material:MaterialBase, heightMap:BitmapData, width:Number = 1000, height:Number = 100, depth:Number = 1000, segmentsW:uint = 30, segmentsH:uint = 30, maxElevation:uint = 255, minElevation:uint = 0, smoothMap:Boolean = false)

Class Elevation generates (and becomes) a mesh from an heightmap. Elevation

Parameters
material:MaterialBase — MaterialBase. The Mesh (Elevation) material
heightMap:BitmapData — BitmapData. The heightmap to generate the mesh from
width:Number (default = 1000) — [optional] Number. The width of the mesh. Default is 1000.
height:Number (default = 100) — [optional] Number. The height of the mesh. Default is 100.
depth:Number (default = 1000) — [optional] Number. The depth of the mesh. Default is 1000.
segmentsW:uint (default = 30) — [optional] uint. The subdivision of the mesh along the x axis. Default is 30.
segmentsH:uint (default = 30) — [optional] uint. The subdivision of the mesh along the y axis. Default is 30.
maxElevation:uint (default = 255) — [optional] uint. The maximum color value to be used. Allows canyon like elevations instead of mountainious. Default is 255.
minElevation:uint (default = 0) — [optional] uint. The minimum color value to be used. Default is 0.
smoothMap:Boolean (default = false) — [optional] Boolean. If surface tracking is used, an internal smoothed version of the map is generated, prevents irregular height readings if original map is blowed up or is having noise. Default is false.
Method Detail
generateSmoothedHeightMap () method
public function generateSmoothedHeightMap():BitmapData

Generates a smoother representation of the geometry using the original heightmap and subdivision settings. Allows smoother readings for surface tracking if original heightmap has noise, causing choppy camera movement.

Returns
BitmapData

See also

away3d.extrusions.Elevation.getHeightAt
getHeightAt () method
public function getHeightAt(x:Number, z:Number):Number

Reading the terrain height from a given x z position for surface tracking purposes

Parameters

x:Number
z:Number

Returns
Number

See also

away3d.extrusions.Elevation.smoothHeightMap
invalidateGeometry () method
protected function invalidateGeometry():void

Invalidates the primitive's geometry, causing it to be updated when requested.

invalidateUVs () method
protected function invalidateUVs():void

Invalidates the primitive's uv coordinates, causing them to be updated when requested.


away3d.extrusions.LatheExtrude

LatheExtrude | Properties | Methods | Events | Constants
Package | away3d.extrusions
Class | public class LatheExtrude
Inheritance | LatheExtrude Inheritance Mesh Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Class for generating meshes with axial symmetry such as donuts, pipes, vases etc.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator Defines the animator of the mesh. | Mesh
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Mesh
 | axis : String Defines the axis used for the lathe rotation. | LatheExtrude
Inherited | backVector : Vector3D [read-only] | Object3D
 | bounds : BoundingVolumeBase [override] The bounding volume approximating the volume occupied by the Entity. | LatheExtrude
Inherited | castsShadows : Boolean Indicates whether or not the Mesh can cast shadows | Mesh
 | centerMesh : Boolean Defines whether the mesh is recentered of not after generation | LatheExtrude
 | coverAll : Boolean Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments. | LatheExtrude
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
 | flip : Boolean Defines if the generated faces should be inversed. | LatheExtrude
Inherited | forwardVector : Vector3D [read-only] | Object3D
 | geometry : Geometry [override] The geometry used by the mesh that provides it with its shape. | LatheExtrude
 | ignoreSides : String Defines if the top, bottom, left, right, front or back of the the extrusion is left open. | LatheExtrude
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
 | keepLastProfile : Boolean Defines if the last transformed profile values are saved or not. | LatheExtrude
 | lastProfile : Vector.<Vector3D> [read-only] returns the last rotated profile values, if keepLastProfile was true | LatheExtrude
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase The material with which to render the Mesh. | Mesh
 | materials : MultipleMaterials An optional object that defines left, right, front, back, top and bottom materials to be set on the resulting lathe extrusion. | LatheExtrude
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
 | offsetRadius : Number Defines an offset radius applied to the profile. | LatheExtrude
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | preciseThickness : Boolean Defines if thickness is greater than 0 if the thickness is equally distributed along the volume. | LatheExtrude
 | profile : Vector.<Vector3D> | LatheExtrude
 | revolutions : Number Defines the number of revolutions performed by the lathe extrusion. | LatheExtrude
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
 | smoothSurface : Boolean Defines if the surface of the mesh must be smoothed or not. | LatheExtrude
 | startRotationOffset : Number | LatheExtrude
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
 | subdivision : uint Defines the subdivisions created in the mesh for the total number of revolutions. | LatheExtrude
 | subMeshes : Vector.<SubMesh> [override] [read-only] The SubMeshes out of which the Mesh consists. | LatheExtrude
 | thickness : Number Defines the thickness of the resulting lathed geometry. | LatheExtrude
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | tweek : Object Allows the building of shapes such as springs. | LatheExtrude
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _geometry : Geometry | Mesh
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | LatheExtrude(material:MaterialBase = null, profile:Vector.<Vector3D> = null, axis:String, revolutions:Number = 1, subdivision:uint = 10, coverall:Boolean = true, centerMesh:Boolean = false, flip:Boolean = false, thickness:Number = 0, preciseThickness:Boolean = true, offsetRadius:Number = 0, materials:MultipleMaterials = null, ignoreSides:String, tweek:Object = null, smoothSurface:Boolean = true) Class LatheExtrude generates circular meshes such as donuts, pipes, pyramids etc.. | LatheExtrude
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | bakeTransformations():void | Mesh
Inherited | clone():Object3D [override] Clones this Mesh instance along with all it's children, while re-using the same material and geometry instance. | Mesh
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | Mesh
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getSubMeshForSubGeometry(subGeometry:SubGeometry):SubMesh | Mesh
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createEntityPartitionNode():EntityNode [override] Factory method that returns the current partition node. | Mesh
Inherited | getDefaultBoundingVolume():BoundingVolumeBase Creates the default bounding box to be used by this type of Entity. | Entity
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] Updates the bounding volume for the object. | Mesh
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
 | X_AXIS : String = x [static] | LatheExtrude
 | Y_AXIS : String = y [static] | LatheExtrude
 | Z_AXIS : String = z [static] | LatheExtrude
Property Detail
axis property
axis:String

Defines the axis used for the lathe rotation. Defaults to "y".

Implementation
    public function get axis():String
    public function set axis(value:String):void
bounds property
bounds:BoundingVolumeBase[override]

The bounding volume approximating the volume occupied by the Entity.

Implementation
    public function get bounds():BoundingVolumeBase
    public function set bounds(value:BoundingVolumeBase):void
centerMesh property
centerMesh:Boolean

Defines whether the mesh is recentered of not after generation

Implementation
    public function get centerMesh():Boolean
    public function set centerMesh(value:Boolean):void
coverAll property
coverAll:Boolean

Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments. Defaults to true.

Implementation
    public function get coverAll():Boolean
    public function set coverAll(value:Boolean):void
flip property
flip:Boolean

Defines if the generated faces should be inversed. Default false.

Implementation
    public function get flip():Boolean
    public function set flip(value:Boolean):void
geometry property
geometry:Geometry[override]

The geometry used by the mesh that provides it with its shape.

Implementation
    public function get geometry():Geometry
    public function set geometry(value:Geometry):void
ignoreSides property
ignoreSides:String

Defines if the top, bottom, left, right, front or back of the the extrusion is left open.

Implementation
    public function get ignoreSides():String
    public function set ignoreSides(value:String):void
keepLastProfile property
keepLastProfile:Boolean

Defines if the last transformed profile values are saved or not. Useful in combo with rotations less than 1, to ease combinations with other extrusions classes such as SkinExtrude.

Implementation
    public function get keepLastProfile():Boolean
    public function set keepLastProfile(value:Boolean):void
lastProfile property
lastProfile:Vector.<Vector3D> [read-only]

returns the last rotated profile values, if keepLastProfile was true

Implementation
    public function get lastProfile():Vector.<Vector3D>
materials property
materials:MultipleMaterials

An optional object that defines left, right, front, back, top and bottom materials to be set on the resulting lathe extrusion.

Implementation
    public function get materials():MultipleMaterials
    public function set materials(value:MultipleMaterials):void
offsetRadius property
offsetRadius:Number

Defines an offset radius applied to the profile. Defaults to 0.

Implementation
    public function get offsetRadius():Number
    public function set offsetRadius(value:Number):void
preciseThickness property
preciseThickness:Boolean

Defines if thickness is greater than 0 if the thickness is equally distributed along the volume. Default is false.

Implementation
    public function get preciseThickness():Boolean
    public function set preciseThickness(value:Boolean):void
profile property
profile:Vector.<Vector3D>

Implementation
    public function get profile():Vector.<Vector3D>
    public function set profile(value:Vector.<Vector3D>):void
revolutions property
revolutions:Number

Defines the number of revolutions performed by the lathe extrusion. Defaults to 1.

Implementation
    public function get revolutions():Number
    public function set revolutions(value:Number):void
smoothSurface property
smoothSurface:Boolean

Defines if the surface of the mesh must be smoothed or not.

Implementation
    public function get smoothSurface():Boolean
    public function set smoothSurface(value:Boolean):void
startRotationOffset property
startRotationOffset:Number

Implementation
    public function get startRotationOffset():Number
    public function set startRotationOffset(value:Number):void
subdivision property
subdivision:uint

Defines the subdivisions created in the mesh for the total number of revolutions. Defaults to 2, minimum 2.

Implementation
    public function get subdivision():uint
    public function set subdivision(value:uint):void

See also

revolutions
subMeshes property
subMeshes:Vector.<SubMesh> [read-only] [override]

The SubMeshes out of which the Mesh consists. Every SubMesh can be assigned a material to override the Mesh's material.

Implementation
    public function get subMeshes():Vector.<SubMesh>
thickness property
thickness:Number

Defines the thickness of the resulting lathed geometry. Defaults to 0 (single face).

Implementation
    public function get thickness():Number
    public function set thickness(value:Number):void
tweek property
tweek:Object

Allows the building of shapes such as springs. Rotation must be higher than 1 to have significant effect. Properties of the objects are x,y,z,radius and rotation

Implementation
    public function get tweek():Object
    public function set tweek(value:Object):void
Constructor Detail
LatheExtrude () Constructor
public function LatheExtrude(material:MaterialBase = null, profile:Vector.<Vector3D> = null, axis:String, revolutions:Number = 1, subdivision:uint = 10, coverall:Boolean = true, centerMesh:Boolean = false, flip:Boolean = false, thickness:Number = 0, preciseThickness:Boolean = true, offsetRadius:Number = 0, materials:MultipleMaterials = null, ignoreSides:String, tweek:Object = null, smoothSurface:Boolean = true)

Class LatheExtrude generates circular meshes such as donuts, pipes, pyramids etc.. from a series of Vector3D's param material [optional] MaterialBase. The LatheExtrude (Mesh) material. Optional in constructor, material must be set before LatheExtrude object is render.

Parameters
material:MaterialBase (default = null) — [optional] Vector.<Vector3D>. A series of Vector3D's representing the profile information to be repeated/rotated around a given axis.
profile:Vector.<Vector3D> (default = null) — [optional] String. The axis to rotate around: X_AXIS, Y_AXIS or Z_AXIS. Default is LatheExtrude.Y_AXIS.
axis:String (default = NaN) — [optional] Number. The LatheExtrude object can have less than one revolution, like 0.6 for a piechart or greater than 1 if a tweek object is passed. Minimum is 0.01. Default is 1.
revolutions:Number (default = 1) — [optional] uint. Howmany segments will compose the mesh in its rotational construction. Minimum is 3. Default is 10.
subdivision:uint (default = 10) — [optional] Boolean. The way the uv mapping is spreaded across the shape. True covers an entire side of the geometry while false covers per segments. Default is true.
coverall:Boolean (default = true) — [optional] Boolean. If the faces must be reversed depending on Vector3D's orientation. Default is false.
centerMesh:Boolean (default = false) — [optional] Number. If the shape must simulate a thickness. Default is 0.
flip:Boolean (default = false) — [optional] Boolean. If the thickness must be repected along the entire volume profile. Default is true.
thickness:Number (default = 0) — [optional] Boolean. If the geometry needs to be recentered in its own object space. If the position after generation is set to 0,0,0, the object would be centered in worldspace. Default is false.
preciseThickness:Boolean (default = true) — [optional] Number. An offset radius if the profile data is not to be updated but the radius expected to be different. Default is 0.
offsetRadius:Number (default = 0) — [optional] MultipleMaterials. Allows multiple material support when thickness is set higher to 1. Default is null. properties as MaterialBase are: bottom, top, left, right, front and back.
materials:MultipleMaterials (default = null) — [optional] String. To prevent the generation of sides if thickness is set higher than 0. To avoid the bottom ignoreSides = "bottom", avoiding both top and bottom: ignoreSides = "bottom, top". Strings options: bottom, top, left, right, front and back. Default is "".
ignoreSides:String — [optional] Object. To build springs like shapes, rotation must be higher than 1. Properties of the tweek object are x,y,z, radius and rotation. Default is null.
tweek:Object (default = null) — [optional] An optional Boolean. Defines if the surface of the mesh must be smoothed or not.
smoothSurface:Boolean (default = true)
Constant Detail
X_AXIS Constant
public static const X_AXIS:String = x

Y_AXIS Constant
public static const Y_AXIS:String = y

Z_AXIS Constant
public static const Z_AXIS:String = z


away3d.extrusions.LinearExtrude

LinearExtrude | Properties | Methods | Events | Constants
Package | away3d.extrusions
Class | public class LinearExtrude
Inheritance | LinearExtrude Inheritance Mesh Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator Defines the animator of the mesh. | Mesh
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Mesh
 | axis : String Defines the axis used for the extrusion. | LinearExtrude
Inherited | backVector : Vector3D [read-only] | Object3D
 | bounds : BoundingVolumeBase [override] The bounding volume approximating the volume occupied by the Entity. | LinearExtrude
Inherited | castsShadows : Boolean Indicates whether or not the Mesh can cast shadows | Mesh
 | centerMesh : Boolean Defines whether the mesh is recentered of not after generation | LinearExtrude
 | coverAll : Boolean Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments. | LinearExtrude
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
 | flip : Boolean Defines if the generated faces should be inversed. | LinearExtrude
Inherited | forwardVector : Vector3D [read-only] | Object3D
 | geometry : Geometry [override] The geometry used by the mesh that provides it with its shape. | LinearExtrude
 | ignoreSides : String Defines if the top, bottom, left, right, front or back of the the extrusion is left open. | LinearExtrude
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase The material with which to render the Mesh. | Mesh
 | materials : MultipleMaterials An optional MultipleMaterials object that defines left, right, front, back, top and bottom materials to be set on the resulting lathe extrusion. | LinearExtrude
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
 | subdivision : uint Defines the subdivisions created in the mesh for the total number of revolutions. | LinearExtrude
 | subMeshes : Vector.<SubMesh> [override] [read-only] The SubMeshes out of which the Mesh consists. | LinearExtrude
 | thickness : Number Defines the _thickness of the resulting lathed geometry. | LinearExtrude
 | thicknessSubdivision : uint Defines the subdivision for the top, bottom, right and left if thickness is set higher to 0. | LinearExtrude
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _geometry : Geometry | Mesh
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined By
LinearExtrude(material:MaterialBase = null, vectors:Vector.<Vector3D> = null, axis:String, offset:Number = 10, subdivision:uint = 3, coverAll:Boolean = false, thickness:Number = 0, thicknessSubdivision:uint = 3, materials:MultipleMaterials = null, centerMesh:Boolean = false, closePath:Boolean = false, ignoreSides:String, flip:Boolean = false)
Class LinearExtrusion generates walls like meshes with or without thickness from a series of Vector3D's param material [optional] MaterialBase.
LinearExtrude
Inherited
addChild(child:ObjectContainer3D):ObjectContainer3D
Adds a child ObjectContainer3D to the current object.
ObjectContainer3D
Inherited
addChildren(... childarray):void
Adds an array of 3d objects to the scene as children of the container
ObjectContainer3D
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
[override]
ObjectContainer3D
Inherited
assetPathEquals(name:String, ns:String):Boolean
NamedAssetBase
Inherited
bakeTransformations():void
Mesh
Inherited
clone():Object3D
[override] Clones this Mesh instance along with all it's children, while re-using the same material and geometry instance.
Mesh
Inherited
contains(child:ObjectContainer3D):Boolean
ObjectContainer3D
Inherited
dispatchEvent(event:Event):Boolean
[override]
ObjectContainer3D
Inherited
dispose():void
[override] Cleans up resources used by this asset.
Mesh
Inherited
disposeAsset():void
Object3D
Inherited
getChildAt(index:uint):ObjectContainer3D
Retrieves the child object at the given index.
ObjectContainer3D
Inherited
getEntityPartitionNode():EntityNode
Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance
Entity
Inherited
getSubMeshForSubGeometry(subGeometry:SubGeometry):SubMesh
Mesh
Inherited
lookAt(target:Vector3D, upAxis:Vector3D = null):void
[override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D.
ObjectContainer3D
Inherited
moveBackward(distance:Number):void
Moves the 3d object backwards along it's local z axis
Object3D
Inherited
moveDown(distance:Number):void
Moves the 3d object backwards along it's local y axis
Object3D
Inherited
moveForward(distance:Number):void
Moves the 3d object forwards along it's local z axis
Object3D
Inherited
moveLeft(distance:Number):void
Moves the 3d object backwards along it's local x axis
Object3D
Inherited
movePivot(dx:Number, dy:Number, dz:Number):void
Moves the local point around which the object rotates.
Object3D
Inherited
moveRight(distance:Number):void
Moves the 3d object forwards along it's local x axis
Object3D
Inherited
moveTo(dx:Number, dy:Number, dz:Number):void
Moves the 3d object directly to a point in space
Object3D
Inherited
moveUp(distance:Number):void
Moves the 3d object forwards along it's local y axis
Object3D
Inherited
pitch(angle:Number):void
Rotates the 3d object around it's local x-axis
Object3D
Inherited
popModelViewProjection():void
Removes a model view projection matrix from the stack, used when leaving a render.
Entity
Inherited
pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void
Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack.
Entity
Inherited
removeChild(child:ObjectContainer3D):void
Removes a 3d object from the child array of the container
ObjectContainer3D
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
[override]
ObjectContainer3D
Inherited
resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void
NamedAssetBase
Inherited
roll(angle:Number):void
Rotates the 3d object around it's local z-axis
Object3D
Inherited
rotate(axis:Vector3D, angle:Number):void
[override]
ObjectContainer3D
Inherited
rotateTo(ax:Number, ay:Number, az:Number):void
Rotates the 3d object directly to a euler angle
Object3D
Inherited
scale(value:Number):void
Appends a uniform scale to the current transformation.
Object3D
Inherited
translate(axis:Vector3D, distance:Number):void
Moves the 3d object along a vector by a defined length
Object3D
Inherited
translateLocal(axis:Vector3D, distance:Number):void
[override]
ObjectContainer3D
Inherited
updateImplicitVisibility():void
ObjectContainer3D
Inherited
yaw(angle:Number):void
Rotates the 3d object around it's local y-axis
Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createEntityPartitionNode():EntityNode [override] Factory method that returns the current partition node. | Mesh
Inherited | getDefaultBoundingVolume():BoundingVolumeBase Creates the default bounding box to be used by this type of Entity. | Entity
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] Updates the bounding volume for the object. | Mesh
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
 | X_AXIS : String = x [static] | LinearExtrude
 | Y_AXIS : String = y [static] | LinearExtrude
 | Z_AXIS : String = z [static] | LinearExtrude
Property Detail
axis property
axis:String

Defines the axis used for the extrusion. Defaults to "y".

Implementation
    public function get axis():String
    public function set axis(value:String):void
bounds property
bounds:BoundingVolumeBase[override]

The bounding volume approximating the volume occupied by the Entity.

Implementation
    public function get bounds():BoundingVolumeBase
    public function set bounds(value:BoundingVolumeBase):void
centerMesh property
centerMesh:Boolean

Defines whether the mesh is recentered of not after generation

Implementation
    public function get centerMesh():Boolean
    public function set centerMesh(value:Boolean):void
coverAll property
coverAll:Boolean

Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments. Defaults to true.

Implementation
    public function get coverAll():Boolean
    public function set coverAll(value:Boolean):void
flip property
flip:Boolean

Defines if the generated faces should be inversed. Default false.

Implementation
    public function get flip():Boolean
    public function set flip(value:Boolean):void
geometry property
geometry:Geometry[override]

The geometry used by the mesh that provides it with its shape.

Implementation
    public function get geometry():Geometry
    public function set geometry(value:Geometry):void
ignoreSides property
ignoreSides:String

Defines if the top, bottom, left, right, front or back of the the extrusion is left open.

Implementation
    public function get ignoreSides():String
    public function set ignoreSides(value:String):void
materials property
materials:MultipleMaterials

An optional MultipleMaterials object that defines left, right, front, back, top and bottom materials to be set on the resulting lathe extrusion.

Implementation
    public function get materials():MultipleMaterials
    public function set materials(value:MultipleMaterials):void
subdivision property
subdivision:uint

Defines the subdivisions created in the mesh for the total number of revolutions. Defaults to 2, minimum 2.

Implementation
    public function get subdivision():uint
    public function set subdivision(value:uint):void
subMeshes property
subMeshes:Vector.<SubMesh> [read-only] [override]

The SubMeshes out of which the Mesh consists. Every SubMesh can be assigned a material to override the Mesh's material.

Implementation
    public function get subMeshes():Vector.<SubMesh>
thickness property
thickness:Number

Defines the _thickness of the resulting lathed geometry. Defaults to 0 (single face).

Implementation
    public function get thickness():Number
    public function set thickness(value:Number):void
thicknessSubdivision property
thicknessSubdivision:uint

Defines the subdivision for the top, bottom, right and left if thickness is set higher to 0. Defaults to 1.

Implementation
    public function get thicknessSubdivision():uint
    public function set thicknessSubdivision(value:uint):void
Constructor Detail
LinearExtrude () Constructor
public function LinearExtrude(material:MaterialBase = null, vectors:Vector.<Vector3D> = null, axis:String, offset:Number = 10, subdivision:uint = 3, coverAll:Boolean = false, thickness:Number = 0, thicknessSubdivision:uint = 3, materials:MultipleMaterials = null, centerMesh:Boolean = false, closePath:Boolean = false, ignoreSides:String, flip:Boolean = false)

Class LinearExtrusion generates walls like meshes with or without thickness from a series of Vector3D's param material [optional] MaterialBase. The LatheExtrude (Mesh) material. Optional in constructor, material must be set before LatheExtrude object is render.

Parameters
material:MaterialBase (default = null) — [optional] Vector.<Vector3D>. A series of Vector3D's representing the profile information to be repeated/rotated around a given axis.
vectors:Vector.<Vector3D> (default = null) — [optional] String. The axis to elevate along: X_AXIS, Y_AXIS or Z_AXIS. Default is LinearExtrusion.Y_AXIS.
axis:String (default = NaN) — [optional] Number. The elevation offset along the defined axis.
offset:Number (default = 10) — [optional] uint. The subdivision of the geometry between 2 vector3D. Default is 32.
subdivision:uint (default = 3) — [optional] Boolean. The way the uv mapping is spreaded across the shape. True covers an entire side of the geometry while false covers per segments. Default is false.
coverAll:Boolean (default = false) — [optional] Number. If the shape must simulate a thickness. Default is 0.
thickness:Number (default = 0) — [optional] uint. If thickness is higher than 0. Defines the subdivision of the thickness (top, left, right, bottom). Default is 3;
thicknessSubdivision:uint (default = 3) — [optional] MultipleMaterials. Allows multiple material support when thickness is set higher to 1. Default is null. properties as MaterialBase are: bottom, top, left, right, front and back.
materials:MultipleMaterials (default = null) — [optional] Boolean. If the geometry needs to be recentered in its own object space. If the position after generation is set to 0,0,0, the object would be centered in worldspace. Default is false.
centerMesh:Boolean (default = false) — [optional] Boolean. Defines if the last entered vector needs to be linked with the first one to form a closed shape. Default is false.
closePath:Boolean (default = false) — [optional] String. To prevent the generation of sides if thickness is set higher than 0. To avoid the bottom ignoreSides = "bottom", avoiding both top and bottom: ignoreSides = "bottom, top". Strings options: bottom, top, left, right, front and back. Default is "".
ignoreSides:String — [optional] Boolean. If the faces must be reversed depending on Vector3D's orientation. Default is false.
flip:Boolean (default = false)
Constant Detail
X_AXIS Constant
public static const X_AXIS:String = x

Y_AXIS Constant
public static const Y_AXIS:String = y

Z_AXIS Constant
public static const Z_AXIS:String = z


away3d.extrusions.PathDuplicator

PathDuplicator | Properties | Methods
Package | away3d.extrusions
Class | public class PathDuplicator
Inheritance | PathDuplicator Inheritance Object
Deprecated: Deprecated

Public Properties
Property |  | Defined By
 | alignToPath : Boolean Defines if the profile point array should be orientated on path or not. | PathDuplicator
 | clones : Vector.<Mesh> [read-only] returns a vector with all meshes cloned since last time build method was called. | PathDuplicator
 | container : ObjectContainer3D If a container is provided, the meshes are addChilded to it instead of directly into the scene. | PathDuplicator
 | meshes : Vector.<Mesh> Defines an optional Vector.<Mesh>. | PathDuplicator
 | path : IPath Sets and defines the Path object. | PathDuplicator
 | randomRotationY : Boolean Defines if a clone gets a random rotationY to break visual repetitions, usefull in case of vegetation for instance. | PathDuplicator
 | repeat : uint Defines the resolution between each PathSegments. | PathDuplicator
 | segmentSpread : Boolean defines if the meshes[index] is repeated per segments or duplicated after each others. | PathDuplicator
 | upAxis : Vector3D The up axis to which duplicated objects' Y axis will be oriented. | PathDuplicator
Public Methods
Method |  | Defined By
 | PathDuplicator(path:IPath = null, meshes:Vector.<Mesh> = null, scene:Scene3D = null, repeat:uint = 1, alignToPath:Boolean = true, segmentSpread:Boolean = true, container:ObjectContainer3D = null, randomRotationY:Boolean = false) Creates a new PathDuplicator Class replicates and distribute one or more mesh(es) along a path. | PathDuplicator
 | build():void Triggers the generation | PathDuplicator
 | clearData(destroyCachedMeshes:Boolean):void | PathDuplicator
Property Detail
alignToPath property
alignToPath:Boolean

Defines if the profile point array should be orientated on path or not. Default true.

Implementation
    public function get alignToPath():Boolean
    public function set alignToPath(value:Boolean):void
clones property
clones:Vector.<Mesh> [read-only]

returns a vector with all meshes cloned since last time build method was called. Returns null if build hasn't be called yet. Another option to retreive the generated meshes is to pass an ObjectContainer3D to the class

Implementation
    public function get clones():Vector.<Mesh>
container property
container:ObjectContainer3D

If a container is provided, the meshes are addChilded to it instead of directly into the scene. The container is NOT addChilded to the scene.

Implementation
    public function get container():ObjectContainer3D
    public function set container(value:ObjectContainer3D):void
meshes property
meshes:Vector.<Mesh>

Defines an optional Vector.<Mesh>. One or more meshes to repeat along the path. When the last in the vector is reached, the first in the array will be used, this process go on and on until the last segment.

Implementation
    public function get meshes():Vector.<Mesh>
    public function set meshes(value:Vector.<Mesh>):void
path property
path:IPath

Sets and defines the Path object. See extrusions.utils package. Required for this class.

Implementation
    public function get path():IPath
    public function set path(value:IPath):void
randomRotationY property
randomRotationY:Boolean

Defines if a clone gets a random rotationY to break visual repetitions, usefull in case of vegetation for instance.

Implementation
    public function get randomRotationY():Boolean
    public function set randomRotationY(value:Boolean):void
repeat property
repeat:uint

Defines the resolution between each PathSegments. Default 1, is also minimum.

Implementation
    public function get repeat():uint
    public function set repeat(value:uint):void
segmentSpread property
segmentSpread:Boolean

defines if the meshes[index] is repeated per segments or duplicated after each others. default = false.

Implementation
    public function get segmentSpread():Boolean
    public function set segmentSpread(value:Boolean):void
upAxis property
upAxis:Vector3D

The up axis to which duplicated objects' Y axis will be oriented.

Implementation
    public function get upAxis():Vector3D
    public function set upAxis(value:Vector3D):void
Constructor Detail
PathDuplicator () Constructor
public function PathDuplicator(path:IPath = null, meshes:Vector.<Mesh> = null, scene:Scene3D = null, repeat:uint = 1, alignToPath:Boolean = true, segmentSpread:Boolean = true, container:ObjectContainer3D = null, randomRotationY:Boolean = false)

Creates a new PathDuplicator Class replicates and distribute one or more mesh(es) along a path. The offsets are defined by the position of the object. 0,0,0 would place the center of the mesh exactly on Path.

Parameters
path:IPath (default = null) — [optional] A Path object. The _path definition. either Cubic or Quadratic path
meshes:Vector.<Mesh> (default = null) — [optional] Vector.<Mesh>. One or more meshes to repeat along the path.
scene:Scene3D (default = null) — [optional] Scene3D. The scene where to addchild the meshes if no ObjectContainer3D is provided.
repeat:uint (default = 1) — [optional] uint. How many times a mesh is cloned per PathSegment. Default is 1.
alignToPath:Boolean (default = true) — [optional] Boolean. If the alignment of the clones must follow the path. Default is true.
segmentSpread:Boolean (default = true) — [optional] Boolean. If more than one Mesh is passed, it defines if the clones alternate themselves per PathSegment or each repeat. Default is false.
container:ObjectContainer3D (default = null) — [optional] ObjectContainer3D. If an ObjectContainer3D is provided, the meshes are addChilded to it instead of directly into the scene. The container is NOT addChilded to the scene by default.
randomRotationY:Boolean (default = false) — [optional] Boolean. If the clones must have a random rotationY added to them.
Method Detail
build () method
public function build():void

Triggers the generation

clearData () method
public function clearData(destroyCachedMeshes:Boolean):void

Parameters

destroyCachedMeshes:Boolean


away3d.extrusions.PathExtrude

PathExtrude | Properties | Methods | Events | Constants
Package | away3d.extrusions
Class | public class PathExtrude
Inheritance | PathExtrude Inheritance Mesh Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Deprecated: Deprecated

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | aligntoPath : Boolean [read-only] Defines if the array of profile points should be orientated on path or not. | PathExtrude
 | alignToPath : Boolean [write-only] | PathExtrude
Inherited | animator : IAnimator Defines the animator of the mesh. | Mesh
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Mesh
Inherited | backVector : Vector3D [read-only] | Object3D
 | bounds : BoundingVolumeBase [override] The bounding volume approximating the volume occupied by the Entity. | PathExtrude
Inherited | castsShadows : Boolean Indicates whether or not the Mesh can cast shadows | Mesh
 | centerMesh : Boolean Defines whether the mesh is recentered of not after generation | PathExtrude
 | closePath : Boolean Defines if the last PathSegment should join the first one and close the loop. | PathExtrude
 | coverAll : Boolean Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments. | PathExtrude
 | coverSegment : Boolean Defines if the texture(s) should applied per segment. | PathExtrude
 | distribute : Boolean Defines if the mesh subdivision is spread evenly over the entire geometry. | PathExtrude
 | distributeU : Boolean Defines the uv's u values are spreaded procentually over the entire surface to prevent the maps to be stretched. | PathExtrude
Inherited | downVector : Vector3D [read-only] | Object3D
 | endProfile : Vector.<Vector3D> [read-only] returns a vector of vector3d's representing the transformed profile coordinates at the end of the extrude shape null if "keepExtremes" is false or if the extrusion has not been builded yet. | PathExtrude
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
 | flip : Boolean Defines if the generated faces should be inversed. | PathExtrude
Inherited | forwardVector : Vector3D [read-only] | Object3D
 | geometry : Geometry [override] The geometry used by the mesh that provides it with its shape. | PathExtrude
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
 | keepExtremes : Boolean Defines if the first and last transformed vector3d's of the profile are kept. | PathExtrude
Inherited | leftVector : Vector3D [read-only] | Object3D
 | mapFit : Boolean Defines if the texture(s) should be projected on the geometry evenly spreaded over the source bitmapdata or using distance/percent. | PathExtrude
Inherited | material : MaterialBase The material with which to render the Mesh. | Mesh
 | materials : Vector.<MaterialBase> An optional Vector.<MaterialBase>. | PathExtrude
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
 | path : IPath Defines the Path object representing path to extrude along. | PathExtrude
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | profile : Vector.<Vector3D> Defines a Vector.<Vector3D> of Vector3D objects representing the profile information to be projected along the Path object. | PathExtrude
Inherited | rightVector : Vector3D [read-only] | Object3D
 | rotations : Vector.<Vector3D> An optional Vector.<Vector3D> of Vector3D objects that defines a series of rotations to be set on each PathSegment. | PathExtrude
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | scales : Vector.<Vector3D> An optional Vector.<Vector3D> of Vector3D objects that defines a series of scales to be set on each PathSegment. | PathExtrude
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
 | smoothScale : Boolean Defines if a scaling of a PathSegment defined from the scales array of Vector3D objects should affect the whole PathSegment evenly or be smoothly interpolated from previous PathSegment scale. | PathExtrude
 | smoothSurface : Boolean Defines if the surface of the mesh must be smoothed or not. | PathExtrude
 | startProfile : Vector.<Vector3D> [read-only] returns a vector of vector3d's representing the transformed profile coordinates at the start of the extrude shape null if "keepExtremes" is false or if the extrusion has not been builded yet. | PathExtrude
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
 | subdivision : int Defines the subdivisions created in the mesh for each PathSegment. | PathExtrude
 | subMeshes : Vector.<SubMesh> [override] [read-only] The SubMeshes out of which the Mesh consists. | PathExtrude
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | upAxis : Vector3D | PathExtrude
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _geometry : Geometry | Mesh
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | PathExtrude(material:MaterialBase = null, path:IPath = null, profile:Vector.<Vector3D> = null, subdivision:uint = 2, coverAll:Boolean = true, coverSegment:Boolean = false, alignToPath:Boolean = true, centerMesh:Boolean = false, mapFit:Boolean = false, flip:Boolean = false, closePath:Boolean = false, materials:Vector.<MaterialBase> = null, scales:Vector.<Vector3D> = null, smoothScale:Boolean = true, rotations:Vector.<Vector3D> = null, smoothSurface:Boolean = true, distribute:Boolean = false, distributeU:Boolean = true, keepExtremes:Boolean = false) Creates a new PathExtrude | PathExtrude
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | bakeTransformations():void | Mesh
Inherited | clone():Object3D [override] Clones this Mesh instance along with all it's children, while re-using the same material and geometry instance. | Mesh
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | Mesh
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getSubMeshForSubGeometry(subGeometry:SubGeometry):SubMesh | Mesh
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createEntityPartitionNode():EntityNode [override] Factory method that returns the current partition node. | Mesh
Inherited | getDefaultBoundingVolume():BoundingVolumeBase Creates the default bounding box to be used by this type of Entity. | Entity
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] Updates the bounding volume for the object. | Mesh
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
aligntoPath property
aligntoPath:Boolean [read-only]

Defines if the array of profile points should be orientated on path or not. Default true. Note that Path object's worldaxis property might need to be changed. default = 0,1,0.

Implementation
    public function get aligntoPath():Boolean

See also

profile
alignToPath property
alignToPath:Boolean [write-only]

Implementation
    public function set alignToPath(value:Boolean):void
bounds property
bounds:BoundingVolumeBase[override]

The bounding volume approximating the volume occupied by the Entity.

Implementation
    public function get bounds():BoundingVolumeBase
    public function set bounds(value:BoundingVolumeBase):void
centerMesh property
centerMesh:Boolean

Defines whether the mesh is recentered of not after generation

Implementation
    public function get centerMesh():Boolean
    public function set centerMesh(value:Boolean):void
closePath property
closePath:Boolean

Defines if the last PathSegment should join the first one and close the loop. Defaults to false.

Implementation
    public function get closePath():Boolean
    public function set closePath(value:Boolean):void
coverAll property
coverAll:Boolean

Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments. Defaults to true.

Implementation
    public function get coverAll():Boolean
    public function set coverAll(value:Boolean):void
coverSegment property
coverSegment:Boolean

Defines if the texture(s) should applied per segment. Default false.

Implementation
    public function get coverSegment():Boolean
    public function set coverSegment(value:Boolean):void
distribute property
distribute:Boolean

Defines if the mesh subdivision is spread evenly over the entire geometry. Possibly resulting in uneven subdivision per segments. Uv mapping is less distorted on complex shapes once applied. Depending on Path length, extra construct time might be significant. Defaults to false.

Implementation
    public function get distribute():Boolean
    public function set distribute(value:Boolean):void
distributeU property
distributeU:Boolean

Defines the uv's u values are spreaded procentually over the entire surface to prevent the maps to be stretched.

Implementation
    public function get distributeU():Boolean
    public function set distributeU(value:Boolean):void
endProfile property
endProfile:Vector.<Vector3D> [read-only]

returns a vector of vector3d's representing the transformed profile coordinates at the end of the extrude shape null if "keepExtremes" is false or if the extrusion has not been builded yet.

Implementation
    public function get endProfile():Vector.<Vector3D>
flip property
flip:Boolean

Defines if the generated faces should be inversed. Default false.

Implementation
    public function get flip():Boolean
    public function set flip(value:Boolean):void
geometry property
geometry:Geometry[override]

The geometry used by the mesh that provides it with its shape.

Implementation
    public function get geometry():Geometry
    public function set geometry(value:Geometry):void
keepExtremes property
keepExtremes:Boolean

Defines if the first and last transformed vector3d's of the profile are kept. For instance to be able to pass these coordinates to DelaunayMesh class, to close the extrude, if it was a tube.

Implementation
    public function get keepExtremes():Boolean
    public function set keepExtremes(value:Boolean):void

See also

getStartProfile
getEndProfile
mapFit property
mapFit:Boolean

Defines if the texture(s) should be projected on the geometry evenly spreaded over the source bitmapdata or using distance/percent. Default is false. The mapping considers first and last profile points are the most distant from each other. Most left and most right on the map. Note that it is NOT suitable for most cases. It is helpfull for roads definition, usually seen from above with simple profile. It prevents then distorts and eases map designs.

Implementation
    public function get mapFit():Boolean
    public function set mapFit(value:Boolean):void
materials property
materials:Vector.<MaterialBase>

An optional Vector.<MaterialBase>. It defines a series of materials to be set on each PathSegment if coverAll is set to false.

Implementation
    public function get materials():Vector.<MaterialBase>
    public function set materials(value:Vector.<MaterialBase>):void
path property
path:IPath

Defines the Path object representing path to extrude along. Required.

Implementation
    public function get path():IPath
    public function set path(value:IPath):void
profile property
profile:Vector.<Vector3D>

Defines a Vector.<Vector3D> of Vector3D objects representing the profile information to be projected along the Path object. Required.

Implementation
    public function get profile():Vector.<Vector3D>
    public function set profile(value:Vector.<Vector3D>):void
rotations property
rotations:Vector.<Vector3D>

An optional Vector.<Vector3D> of Vector3D objects that defines a series of rotations to be set on each PathSegment.

Implementation
    public function get rotations():Vector.<Vector3D>
    public function set rotations(value:Vector.<Vector3D>):void
scales property
scales:Vector.<Vector3D>

An optional Vector.<Vector3D> of Vector3D objects that defines a series of scales to be set on each PathSegment.

Implementation
    public function get scales():Vector.<Vector3D>
    public function set scales(value:Vector.<Vector3D>):void
smoothScale property
smoothScale:Boolean

Defines if a scaling of a PathSegment defined from the scales array of Vector3D objects should affect the whole PathSegment evenly or be smoothly interpolated from previous PathSegment scale. Defaults to true.

Implementation
    public function get smoothScale():Boolean
    public function set smoothScale(value:Boolean):void
smoothSurface property
smoothSurface:Boolean

Defines if the surface of the mesh must be smoothed or not.

Implementation
    public function get smoothSurface():Boolean
    public function set smoothSurface(value:Boolean):void
startProfile property
startProfile:Vector.<Vector3D> [read-only]

returns a vector of vector3d's representing the transformed profile coordinates at the start of the extrude shape null if "keepExtremes" is false or if the extrusion has not been builded yet.

Implementation
    public function get startProfile():Vector.<Vector3D>
subdivision property
subdivision:int

Defines the subdivisions created in the mesh for each PathSegment. Defaults to 2, minimum 2.

Implementation
    public function get subdivision():int
    public function set subdivision(value:int):void
subMeshes property
subMeshes:Vector.<SubMesh> [read-only] [override]

The SubMeshes out of which the Mesh consists. Every SubMesh can be assigned a material to override the Mesh's material.

Implementation
    public function get subMeshes():Vector.<SubMesh>
upAxis property
upAxis:Vector3D

Implementation
    public function get upAxis():Vector3D
    public function set upAxis(value:Vector3D):void
Constructor Detail
PathExtrude () Constructor
public function PathExtrude(material:MaterialBase = null, path:IPath = null, profile:Vector.<Vector3D> = null, subdivision:uint = 2, coverAll:Boolean = true, coverSegment:Boolean = false, alignToPath:Boolean = true, centerMesh:Boolean = false, mapFit:Boolean = false, flip:Boolean = false, closePath:Boolean = false, materials:Vector.<MaterialBase> = null, scales:Vector.<Vector3D> = null, smoothScale:Boolean = true, rotations:Vector.<Vector3D> = null, smoothSurface:Boolean = true, distribute:Boolean = false, distributeU:Boolean = true, keepExtremes:Boolean = false)

Creates a new PathExtrude

Parameters
material:MaterialBase (default = null) — [optional] MaterialBase. The PathExtrude (Mesh) material. Optional in constructor, material must be set before PathExtrude object is rendered. Required for the class to work.
path:IPath (default = null) — [optional] Path. Defines the Path object representing path to extrude along. Required for the class to work.
profile:Vector.<Vector3D> (default = null) — [optional] Vector.<Vector3D>. Defines an Vector.<Vector3D> of Vector3D objects representing the profile information to be projected along the Path object. Required for the class to work.
subdivision:uint (default = 2) — [optional] uint. Howmany steps between each PathSegment. If the path holds curves, the higher this value, the higher the curve fidelity. Default and minimum is 2;
coverAll:Boolean (default = true) — [optional] Boolean. Defines the uv mapping, when true a unique material is stretched along the entire path/shape. Default is true.
coverSegment:Boolean (default = false) — [optional] Boolean. Defines the uv mapping, when true and coverall is false a unique material is stretched along one PathSegment. Default is false.
alignToPath:Boolean (default = true) — [optional] Boolean. If the profile must follow the path or keep its original orientation.
centerMesh:Boolean (default = false) — [optional] Boolean. If the geometry needs to be recentered in its own object space. If the position after generation is set to 0,0,0, the object would be centered in worldspace. Default is false.
mapFit:Boolean (default = false) — [optional] Boolean. The UV mapping is percentually spreaded over the width of the path, making texture looking nicer and edits for applications such as a race track, road, more easy. Affects the uv's u values and set distributeU to false. Default is false.
flip:Boolean (default = false) — [optional] Boolean. If the faces must be reversed depending on Vector3D's orientation. Default is false.
closePath:Boolean (default = false) — [optional] Boolean. If the last PathSegment entered must be welded back to first one. Executed in a straight manner, its recommanded to pass the first entry to the Path again, as last entry if curves are involved.
materials:Vector.<MaterialBase> (default = null) — [optional] Vector.<MaterialBase>. An optional Vector.<MaterialBase> of different materials that can be alternated along the path if coverAll is false.
scales:Vector.<Vector3D> (default = null) — [optional] An optional Vector.<Vector3D> of Vector3D objects that defines a series of scales to be set on each PathSegment.
smoothScale:Boolean (default = true) — [optional] Boolean. Defines if the scale must be interpolated between values or keep their full aspect on each PathSegment.
rotations:Vector.<Vector3D> (default = null) — [optional] An optional Vector.<Vector3D> of Vector3D objects that defines a series of rotations to be set on each PathSegment.
smoothSurface:Boolean (default = true) — [optional] An optional Boolean. Defines if the surface of the mesh must be smoothed or not. Default is true.
distribute:Boolean (default = false) — [optional] Boolean. If the mesh subdivision is evenly spreaded over the entire mesh. Depending on path definition, segments are possibly not having the same amount of subdivision.
distributeU:Boolean (default = true) — [optional] Boolean. If the mesh uv' u value is procentually spreaded over the entire mesh surface. Prevents the source map to be stretched. Default is true.
keepExtremes:Boolean (default = false) — [optional] Boolean. If the the first and last profile coordinates must be kept accessible, in order to feed classes such as DelaunayMesh. Default is false;


away3d.extrusions.SkinExtrude

SkinExtrude | Properties | Methods | Events | Constants
Package | away3d.extrusions
Class | public class SkinExtrude
Inheritance | SkinExtrude Inheritance Mesh Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator Defines the animator of the mesh. | Mesh
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Mesh
Inherited | backVector : Vector3D [read-only] | Object3D
 | bounds : BoundingVolumeBase [override] The bounding volume approximating the volume occupied by the Entity. | SkinExtrude
Inherited | castsShadows : Boolean Indicates whether or not the Mesh can cast shadows | Mesh
 | centerMesh : Boolean Defines whether the mesh is _centerMeshed of not after generation | SkinExtrude
 | closeShape : Boolean Defines if the last vector of Vector3D are joined to the first one, closing the shape. | SkinExtrude
 | coverAll : Boolean Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments. | SkinExtrude
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
 | flip : Boolean Defines if the face orientatio needs to be inverted | SkinExtrude
Inherited | forwardVector : Vector3D [read-only] | Object3D
 | geometry : Geometry [override] The geometry used by the mesh that provides it with its shape. | SkinExtrude
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase The material with which to render the Mesh. | Mesh
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | profiles : Vector.<Vector3D> Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments. | SkinExtrude
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
 | subdivision : Number | SkinExtrude
 | subMeshes : Vector.<SubMesh> [override] [read-only] The SubMeshes out of which the Mesh consists. | SkinExtrude
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _geometry : Geometry | Mesh
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkinExtrude(material:MaterialBase, profiles:Vector.<Vector3D>, subdivision:uint = 1, centerMesh:Boolean = false, closeShape:Boolean = false, coverAll:Boolean = false, flip:Boolean = false) | SkinExtrude
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | bakeTransformations():void | Mesh
Inherited | clone():Object3D [override] Clones this Mesh instance along with all it's children, while re-using the same material and geometry instance. | Mesh
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | Mesh
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getSubMeshForSubGeometry(subGeometry:SubGeometry):SubMesh | Mesh
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createEntityPartitionNode():EntityNode [override] Factory method that returns the current partition node. | Mesh
Inherited | getDefaultBoundingVolume():BoundingVolumeBase Creates the default bounding box to be used by this type of Entity. | Entity
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] Updates the bounding volume for the object. | Mesh
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
bounds property
bounds:BoundingVolumeBase[override]

The bounding volume approximating the volume occupied by the Entity.

Implementation
    public function get bounds():BoundingVolumeBase
    public function set bounds(value:BoundingVolumeBase):void
centerMesh property
centerMesh:Boolean

Defines whether the mesh is _centerMeshed of not after generation

Implementation
    public function get centerMesh():Boolean
    public function set centerMesh(value:Boolean):void
closeShape property
closeShape:Boolean

Defines if the last vector of Vector3D are joined to the first one, closing the shape. works from 3 vector.<Vector3D> entered.

Implementation
    public function get closeShape():Boolean
    public function set closeShape(value:Boolean):void
coverAll property
coverAll:Boolean

Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments. Defaults to false.

Implementation
    public function get coverAll():Boolean
    public function set coverAll(value:Boolean):void
flip property
flip:Boolean

Defines if the face orientatio needs to be inverted

Implementation
    public function get flip():Boolean
    public function set flip(value:Boolean):void
geometry property
geometry:Geometry[override]

The geometry used by the mesh that provides it with its shape.

Implementation
    public function get geometry():Geometry
    public function set geometry(value:Geometry):void
profiles property
profiles:Vector.<Vector3D>

Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments. Defaults to false.

Implementation
    public function get profiles():Vector.<Vector3D>
    public function set profiles(value:Vector.<Vector3D>):void
subdivision property
subdivision:Number

Implementation
    public function get subdivision():Number
    public function set subdivision(value:Number):void
subMeshes property
subMeshes:Vector.<SubMesh> [read-only] [override]

The SubMeshes out of which the Mesh consists. Every SubMesh can be assigned a material to override the Mesh's material.

Implementation
    public function get subMeshes():Vector.<SubMesh>
Constructor Detail
SkinExtrude () Constructor
public function SkinExtrude(material:MaterialBase, profiles:Vector.<Vector3D>, subdivision:uint = 1, centerMesh:Boolean = false, closeShape:Boolean = false, coverAll:Boolean = false, flip:Boolean = false)

Parameters
material:MaterialBase
profiles:Vector.<Vector3D>
subdivision:uint (default = 1)
centerMesh:Boolean (default = false)
closeShape:Boolean (default = false)
coverAll:Boolean (default = false)
flip:Boolean (default = false)


away3d.filters - Away3D Documentation

Package away3d.filters

Classes
BloomFilter3D
BlurFilter3D
DepthOfFieldFilter3D
Filter3DBase
HBlurFilter3D
HDepthOfFieldFilter3D
HueSaturationFilter3D
MotionBlurFilter3D
RadialBlurFilter3D
VBlurFilter3D
VDepthOfFieldFilter3D


away3d.filters Summary

away3d.filters | Classes

Classes
Class | Description
BloomFilter3D |
BlurFilter3D |
DepthOfFieldFilter3D |
Filter3DBase |
HBlurFilter3D |
HDepthOfFieldFilter3D |
HueSaturationFilter3D |
MotionBlurFilter3D |
RadialBlurFilter3D |
VBlurFilter3D |
VDepthOfFieldFilter3D |

Thu Nov 15 2012, 12:09 PM Z


away3d.filters.BloomFilter3D

BloomFilter3D | Properties | Methods
Package | away3d.filters
Class | public class BloomFilter3D
Inheritance | BloomFilter3D Inheritance Filter3DBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | blurX : uint | BloomFilter3D
 | blurY : uint | BloomFilter3D
 | exposure : Number | BloomFilter3D
Inherited | requireDepthRender : Boolean [read-only] | Filter3DBase
Inherited | tasks : Vector.<Filter3DTaskBase> [read-only] | Filter3DBase
Inherited | textureHeight : int | Filter3DBase
Inherited | textureWidth : int | Filter3DBase
 | threshold : Number | BloomFilter3D
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | BloomFilter3D(blurX:uint = 15, blurY:uint = 15, threshold:Number = .75, exposure:Number = 3, quality:int = 3) | BloomFilter3D
Inherited | dispose():void | Filter3DBase
Inherited | getMainInputTexture(stage3DProxy:Stage3DProxy):Texture | Filter3DBase
 | setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void [override] | BloomFilter3D
Inherited | update(stage:Stage3DProxy, camera:Camera3D):void | Filter3DBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addTask(filter:Filter3DTaskBase):void | Filter3DBase
Property Detail
blurX property
blurX:uint

Implementation
    public function get blurX():uint
    public function set blurX(value:uint):void
blurY property
blurY:uint

Implementation
    public function get blurY():uint
    public function set blurY(value:uint):void
exposure property
exposure:Number

Implementation
    public function get exposure():Number
    public function set exposure(value:Number):void
threshold property
threshold:Number

Implementation
    public function get threshold():Number
    public function set threshold(value:Number):void
Constructor Detail
BloomFilter3D () Constructor
public function BloomFilter3D(blurX:uint = 15, blurY:uint = 15, threshold:Number = .75, exposure:Number = 3, quality:int = 3)

Parameters
blurX:uint (default = 15)
blurY:uint (default = 15)
threshold:Number (default = .75)
exposure:Number (default = 3)
quality:int (default = 3)
Method Detail
setRenderTargets () method
override public function setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void

Parameters

mainTarget:Texture
stage3DProxy:Stage3DProxy


away3d.filters.BlurFilter3D

BlurFilter3D | Properties | Methods
Package | away3d.filters
Class | public class BlurFilter3D
Inheritance | BlurFilter3D Inheritance Filter3DBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | blurX : uint | BlurFilter3D
 | blurY : uint | BlurFilter3D
Inherited | requireDepthRender : Boolean [read-only] | Filter3DBase
 | stepSize : int The distance between two blur samples. | BlurFilter3D
Inherited | tasks : Vector.<Filter3DTaskBase> [read-only] | Filter3DBase
Inherited | textureHeight : int | Filter3DBase
Inherited | textureWidth : int | Filter3DBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | BlurFilter3D(blurX:uint = 3, blurY:uint = 3, stepSize:int = -1) Creates a new BlurFilter3D object | BlurFilter3D
Inherited | dispose():void | Filter3DBase
Inherited | getMainInputTexture(stage3DProxy:Stage3DProxy):Texture | Filter3DBase
 | setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void [override] | BlurFilter3D
Inherited | update(stage:Stage3DProxy, camera:Camera3D):void | Filter3DBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addTask(filter:Filter3DTaskBase):void | Filter3DBase
Property Detail
blurX property
blurX:uint

Implementation
    public function get blurX():uint
    public function set blurX(value:uint):void
blurY property
blurY:uint

Implementation
    public function get blurY():uint
    public function set blurY(value:uint):void
stepSize property
stepSize:int

The distance between two blur samples. Set to -1 to autodetect with acceptable quality (default value). Higher values provide better performance at the cost of reduces quality.

Implementation
    public function get stepSize():int
    public function set stepSize(value:int):void
Constructor Detail
BlurFilter3D () Constructor
public function BlurFilter3D(blurX:uint = 3, blurY:uint = 3, stepSize:int = -1)

Creates a new BlurFilter3D object

Parameters
blurX:uint (default = 3) — The amount of horizontal blur to apply
blurY:uint (default = 3) — The amount of vertical blur to apply
stepSize:int (default = -1) — The distance between samples. Set to -1 to autodetect with acceptable quality.
Method Detail
setRenderTargets () method
override public function setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void

Parameters

mainTarget:Texture
stage3DProxy:Stage3DProxy


away3d.filters.DepthOfFieldFilter3D

DepthOfFieldFilter3D | Properties | Methods
Package | away3d.filters
Class | public class DepthOfFieldFilter3D
Inheritance | DepthOfFieldFilter3D Inheritance Filter3DBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | focusDistance : Number The distance from the camera to the point that is in focus. | DepthOfFieldFilter3D
 | focusTarget : ObjectContainer3D An optional target ObjectContainer3D that will be used to auto-focus on. | DepthOfFieldFilter3D
 | maxBlurX : uint The maximum amount of horizontal blur. | DepthOfFieldFilter3D
 | maxBlurY : uint The maximum amount of vertical blur. | DepthOfFieldFilter3D
 | range : Number The distance between the focus point and the maximum amount of blur. | DepthOfFieldFilter3D
Inherited | requireDepthRender : Boolean [read-only] | Filter3DBase
 | stepSize : int The amount of pixels between each sample. | DepthOfFieldFilter3D
Inherited | tasks : Vector.<Filter3DTaskBase> [read-only] | Filter3DBase
Inherited | textureHeight : int | Filter3DBase
Inherited | textureWidth : int | Filter3DBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DepthOfFieldFilter3D(maxBlurX:uint = 3, maxBlurY:uint = 3, stepSize:int = -1) Creates a new DepthOfFieldFilter3D object. | DepthOfFieldFilter3D
Inherited | dispose():void | Filter3DBase
Inherited | getMainInputTexture(stage3DProxy:Stage3DProxy):Texture | Filter3DBase
 | setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void [override] | DepthOfFieldFilter3D
 | update(stage:Stage3DProxy, camera:Camera3D):void [override] | DepthOfFieldFilter3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addTask(filter:Filter3DTaskBase):void | Filter3DBase
Property Detail
focusDistance property
focusDistance:Number

The distance from the camera to the point that is in focus.

Implementation
    public function get focusDistance():Number
    public function set focusDistance(value:Number):void
focusTarget property
focusTarget:ObjectContainer3D

An optional target ObjectContainer3D that will be used to auto-focus on.

Implementation
    public function get focusTarget():ObjectContainer3D
    public function set focusTarget(value:ObjectContainer3D):void
maxBlurX property
maxBlurX:uint

The maximum amount of horizontal blur.

Implementation
    public function get maxBlurX():uint
    public function set maxBlurX(value:uint):void
maxBlurY property
maxBlurY:uint

The maximum amount of vertical blur.

Implementation
    public function get maxBlurY():uint
    public function set maxBlurY(value:uint):void
range property
range:Number

The distance between the focus point and the maximum amount of blur.

Implementation
    public function get range():Number
    public function set range(value:Number):void
stepSize property
stepSize:int

The amount of pixels between each sample.

Implementation
    public function get stepSize():int
    public function set stepSize(value:int):void
Constructor Detail
DepthOfFieldFilter3D () Constructor
public function DepthOfFieldFilter3D(maxBlurX:uint = 3, maxBlurY:uint = 3, stepSize:int = -1)

Creates a new DepthOfFieldFilter3D object.

Parameters
maxBlurX:uint (default = 3) — The maximum amount of horizontal blur to apply
maxBlurY:uint (default = 3) — The maximum amount of vertical blur to apply
stepSize:int (default = -1) — The distance between samples. Set to -1 to auto-detect with acceptable quality.
Method Detail
setRenderTargets () method
override public function setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void

Parameters

mainTarget:Texture
stage3DProxy:Stage3DProxy

update () method
override public function update(stage:Stage3DProxy, camera:Camera3D):void

Parameters

stage:Stage3DProxy
camera:Camera3D


away3d.filters.Filter3DBase

Filter3DBase | Properties | Methods
Package | away3d.filters
Class | public class Filter3DBase
Inheritance | Filter3DBase Inheritance Object
Subclasses | BloomFilter3D, BlurFilter3D, DepthOfFieldFilter3D, HBlurFilter3D, HDepthOfFieldFilter3D, HueSaturationFilter3D, MotionBlurFilter3D, RadialBlurFilter3D, VBlurFilter3D, VDepthOfFieldFilter3D

Public Properties
Property |  | Defined By
 | requireDepthRender : Boolean [read-only] | Filter3DBase
 | tasks : Vector.<Filter3DTaskBase> [read-only] | Filter3DBase
 | textureHeight : int | Filter3DBase
 | textureWidth : int | Filter3DBase
Public Methods
Method |  | Defined By
 | Filter3DBase() | Filter3DBase
 | dispose():void | Filter3DBase
 | getMainInputTexture(stage3DProxy:Stage3DProxy):Texture | Filter3DBase
 | setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void | Filter3DBase
 | update(stage:Stage3DProxy, camera:Camera3D):void | Filter3DBase
Protected Methods
Method |  | Defined By
 | addTask(filter:Filter3DTaskBase):void | Filter3DBase
Property Detail
requireDepthRender property
requireDepthRender:Boolean [read-only]

Implementation
    public function get requireDepthRender():Boolean
tasks property
tasks:Vector.<Filter3DTaskBase> [read-only]

Implementation
    public function get tasks():Vector.<Filter3DTaskBase>
textureHeight property
textureHeight:int

Implementation
    public function get textureHeight():int
    public function set textureHeight(value:int):void
textureWidth property
textureWidth:int

Implementation
    public function get textureWidth():int
    public function set textureWidth(value:int):void
Constructor Detail
Filter3DBase () Constructor
public function Filter3DBase()

Method Detail
addTask () method
protected function addTask(filter:Filter3DTaskBase):void

Parameters

filter:Filter3DTaskBase

dispose () method
public function dispose():void

getMainInputTexture () method
public function getMainInputTexture(stage3DProxy:Stage3DProxy):Texture

Parameters

stage3DProxy:Stage3DProxy

Returns
Texture
setRenderTargets () method
public function setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void

Parameters

mainTarget:Texture
stage3DProxy:Stage3DProxy

update () method
public function update(stage:Stage3DProxy, camera:Camera3D):void

Parameters

stage:Stage3DProxy
camera:Camera3D


away3d.filters.HBlurFilter3D

HBlurFilter3D | Properties | Methods
Package | away3d.filters
Class | public class HBlurFilter3D
Inheritance | HBlurFilter3D Inheritance Filter3DBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | amount : uint | HBlurFilter3D
Inherited | requireDepthRender : Boolean [read-only] | Filter3DBase
 | stepSize : int The distance between two blur samples. | HBlurFilter3D
Inherited | tasks : Vector.<Filter3DTaskBase> [read-only] | Filter3DBase
Inherited | textureHeight : int | Filter3DBase
Inherited | textureWidth : int | Filter3DBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | HBlurFilter3D(amount:uint, stepSize:int = -1) Creates a new HBlurFilter3D object | HBlurFilter3D
Inherited | dispose():void | Filter3DBase
Inherited | getMainInputTexture(stage3DProxy:Stage3DProxy):Texture | Filter3DBase
Inherited | setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void | Filter3DBase
Inherited | update(stage:Stage3DProxy, camera:Camera3D):void | Filter3DBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addTask(filter:Filter3DTaskBase):void | Filter3DBase
Property Detail
amount property
amount:uint

Implementation
    public function get amount():uint
    public function set amount(value:uint):void
stepSize property
stepSize:int

The distance between two blur samples. Set to -1 to autodetect with acceptable quality (default value). Higher values provide better performance at the cost of reduces quality.

Implementation
    public function get stepSize():int
    public function set stepSize(value:int):void
Constructor Detail
HBlurFilter3D () Constructor
public function HBlurFilter3D(amount:uint, stepSize:int = -1)

Creates a new HBlurFilter3D object

Parameters
amount:uint — The amount of blur in pixels
stepSize:int (default = -1) — The distance between two blur samples. Set to -1 to autodetect with acceptable quality (default value).


away3d.filters.HDepthOfFieldFilter3D

HDepthOfFieldFilter3D | Properties | Methods
Package | away3d.filters
Class | public class HDepthOfFieldFilter3D
Inheritance | HDepthOfFieldFilter3D Inheritance Filter3DBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | focusDistance : Number | HDepthOfFieldFilter3D
 | focusTarget : ObjectContainer3D | HDepthOfFieldFilter3D
 | maxBlur : uint | HDepthOfFieldFilter3D
 | range : Number | HDepthOfFieldFilter3D
Inherited | requireDepthRender : Boolean [read-only] | Filter3DBase
Inherited | tasks : Vector.<Filter3DTaskBase> [read-only] | Filter3DBase
Inherited | textureHeight : int | Filter3DBase
Inherited | textureWidth : int | Filter3DBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | HDepthOfFieldFilter3D(maxBlur:uint = 3, stepSize:int = -1) Creates a new HDepthOfFieldFilter3D object | HDepthOfFieldFilter3D
Inherited | dispose():void | Filter3DBase
Inherited | getMainInputTexture(stage3DProxy:Stage3DProxy):Texture | Filter3DBase
Inherited | setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void | Filter3DBase
 | update(stage:Stage3DProxy, camera:Camera3D):void [override] | HDepthOfFieldFilter3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addTask(filter:Filter3DTaskBase):void | Filter3DBase
Property Detail
focusDistance property
focusDistance:Number

Implementation
    public function get focusDistance():Number
    public function set focusDistance(value:Number):void
focusTarget property
focusTarget:ObjectContainer3D

Implementation
    public function get focusTarget():ObjectContainer3D
    public function set focusTarget(value:ObjectContainer3D):void
maxBlur property
maxBlur:uint

Implementation
    public function get maxBlur():uint
    public function set maxBlur(value:uint):void
range property
range:Number

Implementation
    public function get range():Number
    public function set range(value:Number):void
Constructor Detail
HDepthOfFieldFilter3D () Constructor
public function HDepthOfFieldFilter3D(maxBlur:uint = 3, stepSize:int = -1)

Creates a new HDepthOfFieldFilter3D object

Parameters
maxBlur:uint (default = 3) — The amount of blur to apply in pixels
stepSize:int (default = -1) — The distance between samples. Set to -1 to autodetect with acceptable quality.
Method Detail
update () method
override public function update(stage:Stage3DProxy, camera:Camera3D):void

Parameters

stage:Stage3DProxy
camera:Camera3D


away3d.filters.HueSaturationFilter3D

HueSaturationFilter3D | Properties | Methods
Package | away3d.filters
Class | public class HueSaturationFilter3D
Inheritance | HueSaturationFilter3D Inheritance Filter3DBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | b : Number | HueSaturationFilter3D
 | g : Number | HueSaturationFilter3D
 | r : Number | HueSaturationFilter3D
Inherited | requireDepthRender : Boolean [read-only] | Filter3DBase
 | saturation : Number | HueSaturationFilter3D
Inherited | tasks : Vector.<Filter3DTaskBase> [read-only] | Filter3DBase
Inherited | textureHeight : int | Filter3DBase
Inherited | textureWidth : int | Filter3DBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | HueSaturationFilter3D(saturation:Number = 1, r:Number = 1, g:Number = 1, b:Number = 1) | HueSaturationFilter3D
Inherited | dispose():void | Filter3DBase
Inherited | getMainInputTexture(stage3DProxy:Stage3DProxy):Texture | Filter3DBase
Inherited | setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void | Filter3DBase
Inherited | update(stage:Stage3DProxy, camera:Camera3D):void | Filter3DBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addTask(filter:Filter3DTaskBase):void | Filter3DBase
Property Detail
b property
b:Number

Implementation
    public function get b():Number
    public function set b(value:Number):void
g property
g:Number

Implementation
    public function get g():Number
    public function set g(value:Number):void
r property
r:Number

Implementation
    public function get r():Number
    public function set r(value:Number):void
saturation property
saturation:Number

Implementation
    public function get saturation():Number
    public function set saturation(value:Number):void
Constructor Detail
HueSaturationFilter3D () Constructor
public function HueSaturationFilter3D(saturation:Number = 1, r:Number = 1, g:Number = 1, b:Number = 1)

Parameters
saturation:Number (default = 1)
r:Number (default = 1)
g:Number (default = 1)
b:Number (default = 1)


away3d.filters.MotionBlurFilter3D

MotionBlurFilter3D | Properties | Methods
Package | away3d.filters
Class | public class MotionBlurFilter3D
Inheritance | MotionBlurFilter3D Inheritance Filter3DBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | requireDepthRender : Boolean [read-only] | Filter3DBase
 | strength : Number | MotionBlurFilter3D
Inherited | tasks : Vector.<Filter3DTaskBase> [read-only] | Filter3DBase
Inherited | textureHeight : int | Filter3DBase
Inherited | textureWidth : int | Filter3DBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | MotionBlurFilter3D(strength:Number = .65) | MotionBlurFilter3D
Inherited | dispose():void | Filter3DBase
Inherited | getMainInputTexture(stage3DProxy:Stage3DProxy):Texture | Filter3DBase
Inherited | setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void | Filter3DBase
 | update(stage:Stage3DProxy, camera:Camera3D):void [override] | MotionBlurFilter3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addTask(filter:Filter3DTaskBase):void | Filter3DBase
Property Detail
strength property
strength:Number

Implementation
    public function get strength():Number
    public function set strength(value:Number):void
Constructor Detail
MotionBlurFilter3D () Constructor
public function MotionBlurFilter3D(strength:Number = .65)

Parameters
strength:Number (default = .65)
Method Detail
update () method
override public function update(stage:Stage3DProxy, camera:Camera3D):void

Parameters

stage:Stage3DProxy
camera:Camera3D


away3d.filters.RadialBlurFilter3D

RadialBlurFilter3D | Properties | Methods
Package | away3d.filters
Class | public class RadialBlurFilter3D
Inheritance | RadialBlurFilter3D Inheritance Filter3DBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | blurStart : Number | RadialBlurFilter3D
 | blurWidth : Number | RadialBlurFilter3D
 | cx : Number | RadialBlurFilter3D
 | cy : Number | RadialBlurFilter3D
 | glowGamma : Number | RadialBlurFilter3D
 | intensity : Number | RadialBlurFilter3D
Inherited | requireDepthRender : Boolean [read-only] | Filter3DBase
Inherited | tasks : Vector.<Filter3DTaskBase> [read-only] | Filter3DBase
Inherited | textureHeight : int | Filter3DBase
Inherited | textureWidth : int | Filter3DBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | RadialBlurFilter3D(intensity:Number = 8.0, glowGamma:Number = 1.6, blurStart:Number = 1.0, blurWidth:Number = -0.3, cx:Number = 0.5, cy:Number = 0.5) | RadialBlurFilter3D
Inherited | dispose():void | Filter3DBase
Inherited | getMainInputTexture(stage3DProxy:Stage3DProxy):Texture | Filter3DBase
Inherited | setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void | Filter3DBase
Inherited | update(stage:Stage3DProxy, camera:Camera3D):void | Filter3DBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addTask(filter:Filter3DTaskBase):void | Filter3DBase
Property Detail
blurStart property
blurStart:Number

Implementation
    public function get blurStart():Number
    public function set blurStart(value:Number):void
blurWidth property
blurWidth:Number

Implementation
    public function get blurWidth():Number
    public function set blurWidth(value:Number):void
cx property
cx:Number

Implementation
    public function get cx():Number
    public function set cx(value:Number):void
cy property
cy:Number

Implementation
    public function get cy():Number
    public function set cy(value:Number):void
glowGamma property
glowGamma:Number

Implementation
    public function get glowGamma():Number
    public function set glowGamma(value:Number):void
intensity property
intensity:Number

Implementation
    public function get intensity():Number
    public function set intensity(value:Number):void
Constructor Detail
RadialBlurFilter3D () Constructor
public function RadialBlurFilter3D(intensity:Number = 8.0, glowGamma:Number = 1.6, blurStart:Number = 1.0, blurWidth:Number = -0.3, cx:Number = 0.5, cy:Number = 0.5)

Parameters
intensity:Number (default = 8.0)
glowGamma:Number (default = 1.6)
blurStart:Number (default = 1.0)
blurWidth:Number (default = -0.3)
cx:Number (default = 0.5)
cy:Number (default = 0.5)


away3d.filters.VBlurFilter3D

VBlurFilter3D | Properties | Methods
Package | away3d.filters
Class | public class VBlurFilter3D
Inheritance | VBlurFilter3D Inheritance Filter3DBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | amount : uint | VBlurFilter3D
Inherited | requireDepthRender : Boolean [read-only] | Filter3DBase
 | stepSize : int The distance between two blur samples. | VBlurFilter3D
Inherited | tasks : Vector.<Filter3DTaskBase> [read-only] | Filter3DBase
Inherited | textureHeight : int | Filter3DBase
Inherited | textureWidth : int | Filter3DBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | VBlurFilter3D(amount:uint, stepSize:int = -1) Creates a new VBlurFilter3D object | VBlurFilter3D
Inherited | dispose():void | Filter3DBase
Inherited | getMainInputTexture(stage3DProxy:Stage3DProxy):Texture | Filter3DBase
Inherited | setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void | Filter3DBase
Inherited | update(stage:Stage3DProxy, camera:Camera3D):void | Filter3DBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addTask(filter:Filter3DTaskBase):void | Filter3DBase
Property Detail
amount property
amount:uint

Implementation
    public function get amount():uint
    public function set amount(value:uint):void
stepSize property
stepSize:int

The distance between two blur samples. Set to -1 to autodetect with acceptable quality (default value). Higher values provide better performance at the cost of reduces quality.

Implementation
    public function get stepSize():int
    public function set stepSize(value:int):void
Constructor Detail
VBlurFilter3D () Constructor
public function VBlurFilter3D(amount:uint, stepSize:int = -1)

Creates a new VBlurFilter3D object

Parameters
amount:uint — The amount of blur in pixels
stepSize:int (default = -1) — The distance between two blur samples. Set to -1 to autodetect with acceptable quality (default value).


away3d.filters.VDepthOfFieldFilter3D

VDepthOfFieldFilter3D | Properties | Methods
Package | away3d.filters
Class | public class VDepthOfFieldFilter3D
Inheritance | VDepthOfFieldFilter3D Inheritance Filter3DBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | focusDistance : Number | VDepthOfFieldFilter3D
 | focusTarget : ObjectContainer3D | VDepthOfFieldFilter3D
 | maxBlur : uint | VDepthOfFieldFilter3D
 | range : Number | VDepthOfFieldFilter3D
Inherited | requireDepthRender : Boolean [read-only] | Filter3DBase
Inherited | tasks : Vector.<Filter3DTaskBase> [read-only] | Filter3DBase
Inherited | textureHeight : int | Filter3DBase
Inherited | textureWidth : int | Filter3DBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | VDepthOfFieldFilter3D(maxBlur:uint = 3, stepSize:int = -1) Creates a new VDepthOfFieldFilter3D object | VDepthOfFieldFilter3D
Inherited | dispose():void | Filter3DBase
Inherited | getMainInputTexture(stage3DProxy:Stage3DProxy):Texture | Filter3DBase
Inherited | setRenderTargets(mainTarget:Texture, stage3DProxy:Stage3DProxy):void | Filter3DBase
 | update(stage:Stage3DProxy, camera:Camera3D):void [override] | VDepthOfFieldFilter3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addTask(filter:Filter3DTaskBase):void | Filter3DBase
Property Detail
focusDistance property
focusDistance:Number

Implementation
    public function get focusDistance():Number
    public function set focusDistance(value:Number):void
focusTarget property
focusTarget:ObjectContainer3D

Implementation
    public function get focusTarget():ObjectContainer3D
    public function set focusTarget(value:ObjectContainer3D):void
maxBlur property
maxBlur:uint

Implementation
    public function get maxBlur():uint
    public function set maxBlur(value:uint):void
range property
range:Number

Implementation
    public function get range():Number
    public function set range(value:Number):void
Constructor Detail
VDepthOfFieldFilter3D () Constructor
public function VDepthOfFieldFilter3D(maxBlur:uint = 3, stepSize:int = -1)

Creates a new VDepthOfFieldFilter3D object

Parameters
maxBlur:uint (default = 3) — The amount of blur to apply in pixels
stepSize:int (default = -1) — The distance between samples. Set to -1 to autodetect with acceptable quality.
Method Detail
update () method
override public function update(stage:Stage3DProxy, camera:Camera3D):void

Parameters

stage:Stage3DProxy
camera:Camera3D


away3d.filters.tasks - Away3D Documentation

Package away3d.filters.tasks

Classes
Filter3DBrightPassTask
Filter3DCompositeTask
Filter3DDoubleBufferCopyTask
Filter3DHBlurTask
Filter3DHDepthOfFFieldTask
Filter3DHueSaturationTask
Filter3DRadialBlurTask
Filter3DTaskBase
Filter3DVBlurTask
Filter3DVDepthOfFFieldTask
Filter3DXFadeCompositeTask


away3d.filters.tasks Summary

away3d.filters.tasks | Classes

Classes
Class | Description
Filter3DBrightPassTask |
Filter3DCompositeTask |
Filter3DDoubleBufferCopyTask |
Filter3DHBlurTask |
Filter3DHDepthOfFFieldTask |
Filter3DHueSaturationTask |
Filter3DRadialBlurTask |
Filter3DTaskBase |
Filter3DVBlurTask |
Filter3DVDepthOfFFieldTask |
Filter3DXFadeCompositeTask |

Thu Nov 15 2012, 12:09 PM Z


away3d.filters.tasks.Filter3DBrightPassTask

Filter3DBrightPassTask | Properties | Methods
Package | away3d.filters.tasks
Class | public class Filter3DBrightPassTask
Inheritance | Filter3DBrightPassTask Inheritance Filter3DTaskBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | requireDepthRender : Boolean [read-only] | Filter3DTaskBase
Inherited | target : Texture | Filter3DTaskBase
Inherited | textureHeight : int | Filter3DTaskBase
Inherited | textureScale : int The texture scale for the input of this texture. | Filter3DTaskBase
Inherited | textureWidth : int | Filter3DTaskBase
 | threshold : Number | Filter3DBrightPassTask
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _mainInputTexture : Texture | Filter3DTaskBase
Inherited | _scaledTextureHeight : int = -1 | Filter3DTaskBase
Inherited | _scaledTextureWidth : int = -1 | Filter3DTaskBase
Inherited | _textureHeight : int = -1 | Filter3DTaskBase
Inherited | _textureScale : int = 0 | Filter3DTaskBase
Inherited | _textureWidth : int = -1 | Filter3DTaskBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Filter3DBrightPassTask(threshold:Number = .75) | Filter3DBrightPassTask
 | activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void [override] | Filter3DBrightPassTask
Inherited | deactivate(stage3DProxy:Stage3DProxy):void | Filter3DTaskBase
Inherited | dispose():void | Filter3DTaskBase
Inherited | getMainInputTexture(stage:Stage3DProxy):Texture | Filter3DTaskBase
Inherited | getProgram3D(stage3DProxy:Stage3DProxy):Program3D | Filter3DTaskBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | getFragmentCode():String [override] | Filter3DBrightPassTask
Inherited | getVertexCode():String | Filter3DTaskBase
Inherited | invalidateProgram3D():void | Filter3DTaskBase
Inherited | updateProgram3D(stage:Stage3DProxy):void | Filter3DTaskBase
Inherited | updateTextures(stage:Stage3DProxy):void | Filter3DTaskBase
Property Detail
threshold property
threshold:Number

Implementation
    public function get threshold():Number
    public function set threshold(value:Number):void
Constructor Detail
Filter3DBrightPassTask () Constructor
public function Filter3DBrightPassTask(threshold:Number = .75)

Parameters
threshold:Number (default = .75)
Method Detail
activate () method
override public function activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void

Parameters

stage3DProxy:Stage3DProxy
camera3D:Camera3D
depthTexture:Texture

getFragmentCode () method
override protected function getFragmentCode():String

Returns
String


away3d.filters.tasks.Filter3DCompositeTask

Filter3DCompositeTask | Properties | Methods
Package | away3d.filters.tasks
Class | public class Filter3DCompositeTask
Inheritance | Filter3DCompositeTask Inheritance Filter3DTaskBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | exposure : Number | Filter3DCompositeTask
 | overlayTexture : TextureBase | Filter3DCompositeTask
Inherited | requireDepthRender : Boolean [read-only] | Filter3DTaskBase
Inherited | target : Texture | Filter3DTaskBase
Inherited | textureHeight : int | Filter3DTaskBase
Inherited | textureScale : int The texture scale for the input of this texture. | Filter3DTaskBase
Inherited | textureWidth : int | Filter3DTaskBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _mainInputTexture : Texture | Filter3DTaskBase
Inherited | _scaledTextureHeight : int = -1 | Filter3DTaskBase
Inherited | _scaledTextureWidth : int = -1 | Filter3DTaskBase
Inherited | _textureHeight : int = -1 | Filter3DTaskBase
Inherited | _textureScale : int = 0 | Filter3DTaskBase
Inherited | _textureWidth : int = -1 | Filter3DTaskBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Filter3DCompositeTask(blendMode:String, exposure:Number = 1) | Filter3DCompositeTask
 | activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void [override] | Filter3DCompositeTask
 | deactivate(stage3DProxy:Stage3DProxy):void [override] | Filter3DCompositeTask
Inherited | dispose():void | Filter3DTaskBase
Inherited | getMainInputTexture(stage:Stage3DProxy):Texture | Filter3DTaskBase
Inherited | getProgram3D(stage3DProxy:Stage3DProxy):Program3D | Filter3DTaskBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | getFragmentCode():String [override] | Filter3DCompositeTask
Inherited | getVertexCode():String | Filter3DTaskBase
Inherited | invalidateProgram3D():void | Filter3DTaskBase
Inherited | updateProgram3D(stage:Stage3DProxy):void | Filter3DTaskBase
Inherited | updateTextures(stage:Stage3DProxy):void | Filter3DTaskBase
Property Detail
exposure property
exposure:Number

Implementation
    public function get exposure():Number
    public function set exposure(value:Number):void
overlayTexture property
overlayTexture:TextureBase

Implementation
    public function get overlayTexture():TextureBase
    public function set overlayTexture(value:TextureBase):void
Constructor Detail
Filter3DCompositeTask () Constructor
public function Filter3DCompositeTask(blendMode:String, exposure:Number = 1)

Parameters
blendMode:String
exposure:Number (default = 1)
Method Detail
activate () method
override public function activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void

Parameters

stage3DProxy:Stage3DProxy
camera3D:Camera3D
depthTexture:Texture

deactivate () method
override public function deactivate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

getFragmentCode () method
override protected function getFragmentCode():String

Returns
String


away3d.filters.tasks.Filter3DDoubleBufferCopyTask

Filter3DDoubleBufferCopyTask | Properties | Methods
Package | away3d.filters.tasks
Class | public class Filter3DDoubleBufferCopyTask
Inheritance | Filter3DDoubleBufferCopyTask Inheritance Filter3DTaskBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | requireDepthRender : Boolean [read-only] | Filter3DTaskBase
 | secondaryInputTexture : Texture [read-only] | Filter3DDoubleBufferCopyTask
Inherited | target : Texture | Filter3DTaskBase
Inherited | textureHeight : int | Filter3DTaskBase
Inherited | textureScale : int The texture scale for the input of this texture. | Filter3DTaskBase
Inherited | textureWidth : int | Filter3DTaskBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _mainInputTexture : Texture | Filter3DTaskBase
Inherited | _scaledTextureHeight : int = -1 | Filter3DTaskBase
Inherited | _scaledTextureWidth : int = -1 | Filter3DTaskBase
Inherited | _textureHeight : int = -1 | Filter3DTaskBase
Inherited | _textureScale : int = 0 | Filter3DTaskBase
Inherited | _textureWidth : int = -1 | Filter3DTaskBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Filter3DDoubleBufferCopyTask() | Filter3DDoubleBufferCopyTask
 | activate(stage3DProxy:Stage3DProxy, camera:Camera3D, depthTexture:Texture):void [override] | Filter3DDoubleBufferCopyTask
Inherited | deactivate(stage3DProxy:Stage3DProxy):void | Filter3DTaskBase
Inherited | dispose():void | Filter3DTaskBase
Inherited | getMainInputTexture(stage:Stage3DProxy):Texture | Filter3DTaskBase
Inherited | getProgram3D(stage3DProxy:Stage3DProxy):Program3D | Filter3DTaskBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | getFragmentCode():String [override] | Filter3DDoubleBufferCopyTask
Inherited | getVertexCode():String | Filter3DTaskBase
Inherited | invalidateProgram3D():void | Filter3DTaskBase
Inherited | updateProgram3D(stage:Stage3DProxy):void | Filter3DTaskBase
 | updateTextures(stage:Stage3DProxy):void [override] | Filter3DDoubleBufferCopyTask
Property Detail
secondaryInputTexture property
secondaryInputTexture:Texture [read-only]

Implementation
    public function get secondaryInputTexture():Texture
Constructor Detail
Filter3DDoubleBufferCopyTask () Constructor
public function Filter3DDoubleBufferCopyTask()

Method Detail
activate () method
override public function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, depthTexture:Texture):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
depthTexture:Texture

getFragmentCode () method
override protected function getFragmentCode():String

Returns
String
updateTextures () method
override protected function updateTextures(stage:Stage3DProxy):void

Parameters

stage:Stage3DProxy


away3d.filters.tasks.Filter3DHBlurTask

Filter3DHBlurTask | Properties | Methods
Package | away3d.filters.tasks
Class | public class Filter3DHBlurTask
Inheritance | Filter3DHBlurTask Inheritance Filter3DTaskBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | amount : uint | Filter3DHBlurTask
Inherited | requireDepthRender : Boolean [read-only] | Filter3DTaskBase
 | stepSize : int | Filter3DHBlurTask
Inherited | target : Texture | Filter3DTaskBase
Inherited | textureHeight : int | Filter3DTaskBase
Inherited | textureScale : int The texture scale for the input of this texture. | Filter3DTaskBase
Inherited | textureWidth : int | Filter3DTaskBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _mainInputTexture : Texture | Filter3DTaskBase
Inherited | _scaledTextureHeight : int = -1 | Filter3DTaskBase
Inherited | _scaledTextureWidth : int = -1 | Filter3DTaskBase
Inherited | _textureHeight : int = -1 | Filter3DTaskBase
Inherited | _textureScale : int = 0 | Filter3DTaskBase
Inherited | _textureWidth : int = -1 | Filter3DTaskBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Filter3DHBlurTask(amount:uint, stepSize:int = -1) Creates a new Filter3DHDepthOfFFieldTask | Filter3DHBlurTask
 | activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void [override] | Filter3DHBlurTask
Inherited | deactivate(stage3DProxy:Stage3DProxy):void | Filter3DTaskBase
Inherited | dispose():void | Filter3DTaskBase
Inherited | getMainInputTexture(stage:Stage3DProxy):Texture | Filter3DTaskBase
Inherited | getProgram3D(stage3DProxy:Stage3DProxy):Program3D | Filter3DTaskBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | getFragmentCode():String [override] | Filter3DHBlurTask
Inherited | getVertexCode():String | Filter3DTaskBase
Inherited | invalidateProgram3D():void | Filter3DTaskBase
Inherited | updateProgram3D(stage:Stage3DProxy):void | Filter3DTaskBase
 | updateTextures(stage:Stage3DProxy):void [override] | Filter3DHBlurTask
Property Detail
amount property
amount:uint

Implementation
    public function get amount():uint
    public function set amount(value:uint):void
stepSize property
stepSize:int

Implementation
    public function get stepSize():int
    public function set stepSize(value:int):void
Constructor Detail
Filter3DHBlurTask () Constructor
public function Filter3DHBlurTask(amount:uint, stepSize:int = -1)

Creates a new Filter3DHDepthOfFFieldTask

Parameters
amount:uint — The maximum amount of blur to apply in pixels at the most out-of-focus areas
stepSize:int (default = -1) — The distance between samples. Set to -1 to autodetect with acceptable quality.
Method Detail
activate () method
override public function activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void

Parameters

stage3DProxy:Stage3DProxy
camera3D:Camera3D
depthTexture:Texture

getFragmentCode () method
override protected function getFragmentCode():String

Returns
String
updateTextures () method
override protected function updateTextures(stage:Stage3DProxy):void

Parameters

stage:Stage3DProxy


away3d.filters.tasks.Filter3DHDepthOfFFieldTask

Filter3DHDepthOfFFieldTask | Properties | Methods
Package | away3d.filters.tasks
Class | public class Filter3DHDepthOfFFieldTask
Inheritance | Filter3DHDepthOfFFieldTask Inheritance Filter3DTaskBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | focusDistance : Number | Filter3DHDepthOfFFieldTask
 | maxBlur : uint | Filter3DHDepthOfFFieldTask
 | range : Number | Filter3DHDepthOfFFieldTask
Inherited | requireDepthRender : Boolean [read-only] | Filter3DTaskBase
 | stepSize : int | Filter3DHDepthOfFFieldTask
Inherited | target : Texture | Filter3DTaskBase
Inherited | textureHeight : int | Filter3DTaskBase
Inherited | textureScale : int The texture scale for the input of this texture. | Filter3DTaskBase
Inherited | textureWidth : int | Filter3DTaskBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _mainInputTexture : Texture | Filter3DTaskBase
Inherited | _scaledTextureHeight : int = -1 | Filter3DTaskBase
Inherited | _scaledTextureWidth : int = -1 | Filter3DTaskBase
Inherited | _textureHeight : int = -1 | Filter3DTaskBase
Inherited | _textureScale : int = 0 | Filter3DTaskBase
Inherited | _textureWidth : int = -1 | Filter3DTaskBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Filter3DHDepthOfFFieldTask(maxBlur:uint, stepSize:int = -1) Creates a new Filter3DHDepthOfFFieldTask | Filter3DHDepthOfFFieldTask
 | activate(stage3DProxy:Stage3DProxy, camera:Camera3D, depthTexture:Texture):void [override] | Filter3DHDepthOfFFieldTask
 | deactivate(stage3DProxy:Stage3DProxy):void [override] | Filter3DHDepthOfFFieldTask
Inherited | dispose():void | Filter3DTaskBase
Inherited | getMainInputTexture(stage:Stage3DProxy):Texture | Filter3DTaskBase
Inherited | getProgram3D(stage3DProxy:Stage3DProxy):Program3D | Filter3DTaskBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | getFragmentCode():String [override] | Filter3DHDepthOfFFieldTask
Inherited | getVertexCode():String | Filter3DTaskBase
Inherited | invalidateProgram3D():void | Filter3DTaskBase
Inherited | updateProgram3D(stage:Stage3DProxy):void | Filter3DTaskBase
 | updateTextures(stage:Stage3DProxy):void [override] | Filter3DHDepthOfFFieldTask
Property Detail
focusDistance property
focusDistance:Number

Implementation
    public function get focusDistance():Number
    public function set focusDistance(value:Number):void
maxBlur property
maxBlur:uint

Implementation
    public function get maxBlur():uint
    public function set maxBlur(value:uint):void
range property
range:Number

Implementation
    public function get range():Number
    public function set range(value:Number):void
stepSize property
stepSize:int

Implementation
    public function get stepSize():int
    public function set stepSize(value:int):void
Constructor Detail
Filter3DHDepthOfFFieldTask () Constructor
public function Filter3DHDepthOfFFieldTask(maxBlur:uint, stepSize:int = -1)

Creates a new Filter3DHDepthOfFFieldTask

Parameters
maxBlur:uint — The maximum amount of blur to apply in pixels at the most out-of-focus areas
stepSize:int (default = -1) — The distance between samples. Set to -1 to autodetect with acceptable quality.
Method Detail
activate () method
override public function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, depthTexture:Texture):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
depthTexture:Texture

deactivate () method
override public function deactivate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

getFragmentCode () method
override protected function getFragmentCode():String

Returns
String
updateTextures () method
override protected function updateTextures(stage:Stage3DProxy):void

Parameters

stage:Stage3DProxy


away3d.filters.tasks.Filter3DHueSaturationTask

Filter3DHueSaturationTask | Properties | Methods
Package | away3d.filters.tasks
Class | public class Filter3DHueSaturationTask
Inheritance | Filter3DHueSaturationTask Inheritance Filter3DTaskBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | b : Number | Filter3DHueSaturationTask
 | g : Number | Filter3DHueSaturationTask
 | r : Number | Filter3DHueSaturationTask
Inherited | requireDepthRender : Boolean [read-only] | Filter3DTaskBase
 | saturation : Number | Filter3DHueSaturationTask
Inherited | target : Texture | Filter3DTaskBase
Inherited | textureHeight : int | Filter3DTaskBase
Inherited | textureScale : int The texture scale for the input of this texture. | Filter3DTaskBase
Inherited | textureWidth : int | Filter3DTaskBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _mainInputTexture : Texture | Filter3DTaskBase
Inherited | _scaledTextureHeight : int = -1 | Filter3DTaskBase
Inherited | _scaledTextureWidth : int = -1 | Filter3DTaskBase
Inherited | _textureHeight : int = -1 | Filter3DTaskBase
Inherited | _textureScale : int = 0 | Filter3DTaskBase
Inherited | _textureWidth : int = -1 | Filter3DTaskBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Filter3DHueSaturationTask() | Filter3DHueSaturationTask
 | activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void [override] | Filter3DHueSaturationTask
Inherited | deactivate(stage3DProxy:Stage3DProxy):void | Filter3DTaskBase
Inherited | dispose():void | Filter3DTaskBase
Inherited | getMainInputTexture(stage:Stage3DProxy):Texture | Filter3DTaskBase
Inherited | getProgram3D(stage3DProxy:Stage3DProxy):Program3D | Filter3DTaskBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | getFragmentCode():String [override] | Filter3DHueSaturationTask
Inherited | getVertexCode():String | Filter3DTaskBase
Inherited | invalidateProgram3D():void | Filter3DTaskBase
 | updateConstants():void | Filter3DHueSaturationTask
Inherited | updateProgram3D(stage:Stage3DProxy):void | Filter3DTaskBase
Inherited | updateTextures(stage:Stage3DProxy):void | Filter3DTaskBase
Property Detail
b property
b:Number

Implementation
    public function get b():Number
    public function set b(value:Number):void
g property
g:Number

Implementation
    public function get g():Number
    public function set g(value:Number):void
r property
r:Number

Implementation
    public function get r():Number
    public function set r(value:Number):void
saturation property
saturation:Number

Implementation
    public function get saturation():Number
    public function set saturation(value:Number):void
Constructor Detail
Filter3DHueSaturationTask () Constructor
public function Filter3DHueSaturationTask()

Method Detail
activate () method
override public function activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void

Parameters

stage3DProxy:Stage3DProxy
camera3D:Camera3D
depthTexture:Texture

getFragmentCode () method
override protected function getFragmentCode():String

Returns
String
updateConstants () method
protected function updateConstants():void


away3d.filters.tasks.Filter3DRadialBlurTask

Filter3DRadialBlurTask | Properties | Methods
Package | away3d.filters.tasks
Class | public class Filter3DRadialBlurTask
Inheritance | Filter3DRadialBlurTask Inheritance Filter3DTaskBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | blurStart : Number | Filter3DRadialBlurTask
 | blurWidth : Number | Filter3DRadialBlurTask
 | cx : Number | Filter3DRadialBlurTask
 | cy : Number | Filter3DRadialBlurTask
 | glowGamma : Number | Filter3DRadialBlurTask
 | intensity : Number | Filter3DRadialBlurTask
Inherited | requireDepthRender : Boolean [read-only] | Filter3DTaskBase
Inherited | target : Texture | Filter3DTaskBase
Inherited | textureHeight : int | Filter3DTaskBase
Inherited | textureScale : int The texture scale for the input of this texture. | Filter3DTaskBase
Inherited | textureWidth : int | Filter3DTaskBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _mainInputTexture : Texture | Filter3DTaskBase
Inherited | _scaledTextureHeight : int = -1 | Filter3DTaskBase
Inherited | _scaledTextureWidth : int = -1 | Filter3DTaskBase
Inherited | _textureHeight : int = -1 | Filter3DTaskBase
Inherited | _textureScale : int = 0 | Filter3DTaskBase
Inherited | _textureWidth : int = -1 | Filter3DTaskBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Filter3DRadialBlurTask(intensity:Number = 1.0, glowGamma:Number = 1.0, blurStart:Number = 1.0, blurWidth:Number = -0.3, cx:Number = 0.5, cy:Number = 0.5) | Filter3DRadialBlurTask
 | activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void [override] | Filter3DRadialBlurTask
Inherited | deactivate(stage3DProxy:Stage3DProxy):void | Filter3DTaskBase
Inherited | dispose():void | Filter3DTaskBase
Inherited | getMainInputTexture(stage:Stage3DProxy):Texture | Filter3DTaskBase
Inherited | getProgram3D(stage3DProxy:Stage3DProxy):Program3D | Filter3DTaskBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | getFragmentCode():String [override] | Filter3DRadialBlurTask
 | getVertexCode():String [override] | Filter3DRadialBlurTask
Inherited | invalidateProgram3D():void | Filter3DTaskBase
Inherited | updateProgram3D(stage:Stage3DProxy):void | Filter3DTaskBase
Inherited | updateTextures(stage:Stage3DProxy):void | Filter3DTaskBase
Property Detail
blurStart property
blurStart:Number

Implementation
    public function get blurStart():Number
    public function set blurStart(value:Number):void
blurWidth property
blurWidth:Number

Implementation
    public function get blurWidth():Number
    public function set blurWidth(value:Number):void
cx property
cx:Number

Implementation
    public function get cx():Number
    public function set cx(value:Number):void
cy property
cy:Number

Implementation
    public function get cy():Number
    public function set cy(value:Number):void
glowGamma property
glowGamma:Number

Implementation
    public function get glowGamma():Number
    public function set glowGamma(value:Number):void
intensity property
intensity:Number

Implementation
    public function get intensity():Number
    public function set intensity(value:Number):void
Constructor Detail
Filter3DRadialBlurTask () Constructor
public function Filter3DRadialBlurTask(intensity:Number = 1.0, glowGamma:Number = 1.0, blurStart:Number = 1.0, blurWidth:Number = -0.3, cx:Number = 0.5, cy:Number = 0.5)

Parameters
intensity:Number (default = 1.0)
glowGamma:Number (default = 1.0)
blurStart:Number (default = 1.0)
blurWidth:Number (default = -0.3)
cx:Number (default = 0.5)
cy:Number (default = 0.5)
Method Detail
activate () method
override public function activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void

Parameters

stage3DProxy:Stage3DProxy
camera3D:Camera3D
depthTexture:Texture

getFragmentCode () method
override protected function getFragmentCode():String

Returns
String
getVertexCode () method
override protected function getVertexCode():String

Returns
String


away3d.filters.tasks.Filter3DTaskBase

Filter3DTaskBase | Properties | Methods
Package | away3d.filters.tasks
Class | public class Filter3DTaskBase
Inheritance | Filter3DTaskBase Inheritance Object
Subclasses | Filter3DBrightPassTask, Filter3DCompositeTask, Filter3DDoubleBufferCopyTask, Filter3DHBlurTask, Filter3DHDepthOfFFieldTask, Filter3DHueSaturationTask, Filter3DRadialBlurTask, Filter3DVBlurTask, Filter3DVDepthOfFFieldTask, Filter3DXFadeCompositeTask

Public Properties
Property |  | Defined By
 | requireDepthRender : Boolean [read-only] | Filter3DTaskBase
 | target : Texture | Filter3DTaskBase
 | textureHeight : int | Filter3DTaskBase
 | textureScale : int The texture scale for the input of this texture. | Filter3DTaskBase
 | textureWidth : int | Filter3DTaskBase
Protected Properties
Property |  | Defined By
 | _mainInputTexture : Texture | Filter3DTaskBase
 | _scaledTextureHeight : int = -1 | Filter3DTaskBase
 | _scaledTextureWidth : int = -1 | Filter3DTaskBase
 | _textureHeight : int = -1 | Filter3DTaskBase
 | _textureScale : int = 0 | Filter3DTaskBase
 | _textureWidth : int = -1 | Filter3DTaskBase
Public Methods
Method |  | Defined By
 | Filter3DTaskBase(requireDepthRender:Boolean = false) | Filter3DTaskBase
 | activate(stage3DProxy:Stage3DProxy, camera:Camera3D, depthTexture:Texture):void | Filter3DTaskBase
 | deactivate(stage3DProxy:Stage3DProxy):void | Filter3DTaskBase
 | dispose():void | Filter3DTaskBase
 | getMainInputTexture(stage:Stage3DProxy):Texture | Filter3DTaskBase
 | getProgram3D(stage3DProxy:Stage3DProxy):Program3D | Filter3DTaskBase
Protected Methods
Method |  | Defined By
 | getFragmentCode():String | Filter3DTaskBase
 | getVertexCode():String | Filter3DTaskBase
 | invalidateProgram3D():void | Filter3DTaskBase
 | updateProgram3D(stage:Stage3DProxy):void | Filter3DTaskBase
 | updateTextures(stage:Stage3DProxy):void | Filter3DTaskBase
Property Detail
_mainInputTexture property
protected var _mainInputTexture:Texture

_scaledTextureHeight property
protected var _scaledTextureHeight:int = -1

_scaledTextureWidth property
protected var _scaledTextureWidth:int = -1

_textureHeight property
protected var _textureHeight:int = -1

_textureScale property
protected var _textureScale:int = 0

_textureWidth property
protected var _textureWidth:int = -1

requireDepthRender property
requireDepthRender:Boolean [read-only]

Implementation
    public function get requireDepthRender():Boolean
target property
target:Texture

Implementation
    public function get target():Texture
    public function set target(value:Texture):void
textureHeight property
textureHeight:int

Implementation
    public function get textureHeight():int
    public function set textureHeight(value:int):void
textureScale property
textureScale:int

The texture scale for the input of this texture. This will define the output of the previous entry in the chain

Implementation
    public function get textureScale():int
    public function set textureScale(value:int):void
textureWidth property
textureWidth:int

Implementation
    public function get textureWidth():int
    public function set textureWidth(value:int):void
Constructor Detail
Filter3DTaskBase () Constructor
public function Filter3DTaskBase(requireDepthRender:Boolean = false)

Parameters
requireDepthRender:Boolean (default = false)
Method Detail
activate () method
public function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, depthTexture:Texture):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
depthTexture:Texture

deactivate () method
public function deactivate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

dispose () method
public function dispose():void

getFragmentCode () method
protected function getFragmentCode():String

Returns
String
getMainInputTexture () method
public function getMainInputTexture(stage:Stage3DProxy):Texture

Parameters

stage:Stage3DProxy

Returns
Texture
getProgram3D () method
public function getProgram3D(stage3DProxy:Stage3DProxy):Program3D

Parameters

stage3DProxy:Stage3DProxy

Returns
Program3D
getVertexCode () method
protected function getVertexCode():String

Returns
String
invalidateProgram3D () method
protected function invalidateProgram3D():void

updateProgram3D () method
protected function updateProgram3D(stage:Stage3DProxy):void

Parameters

stage:Stage3DProxy

updateTextures () method
protected function updateTextures(stage:Stage3DProxy):void

Parameters

stage:Stage3DProxy


away3d.filters.tasks.Filter3DVBlurTask

Filter3DVBlurTask | Properties | Methods
Package | away3d.filters.tasks
Class | public class Filter3DVBlurTask
Inheritance | Filter3DVBlurTask Inheritance Filter3DTaskBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | amount : uint | Filter3DVBlurTask
Inherited | requireDepthRender : Boolean [read-only] | Filter3DTaskBase
 | stepSize : int | Filter3DVBlurTask
Inherited | target : Texture | Filter3DTaskBase
Inherited | textureHeight : int | Filter3DTaskBase
Inherited | textureScale : int The texture scale for the input of this texture. | Filter3DTaskBase
Inherited | textureWidth : int | Filter3DTaskBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _mainInputTexture : Texture | Filter3DTaskBase
Inherited | _scaledTextureHeight : int = -1 | Filter3DTaskBase
Inherited | _scaledTextureWidth : int = -1 | Filter3DTaskBase
Inherited | _textureHeight : int = -1 | Filter3DTaskBase
Inherited | _textureScale : int = 0 | Filter3DTaskBase
Inherited | _textureWidth : int = -1 | Filter3DTaskBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Filter3DVBlurTask(amount:uint, stepSize:int = -1) | Filter3DVBlurTask
 | activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void [override] | Filter3DVBlurTask
Inherited | deactivate(stage3DProxy:Stage3DProxy):void | Filter3DTaskBase
Inherited | dispose():void | Filter3DTaskBase
Inherited | getMainInputTexture(stage:Stage3DProxy):Texture | Filter3DTaskBase
Inherited | getProgram3D(stage3DProxy:Stage3DProxy):Program3D | Filter3DTaskBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | getFragmentCode():String [override] | Filter3DVBlurTask
Inherited | getVertexCode():String | Filter3DTaskBase
Inherited | invalidateProgram3D():void | Filter3DTaskBase
Inherited | updateProgram3D(stage:Stage3DProxy):void | Filter3DTaskBase
 | updateTextures(stage:Stage3DProxy):void [override] | Filter3DVBlurTask
Property Detail
amount property
amount:uint

Implementation
    public function get amount():uint
    public function set amount(value:uint):void
stepSize property
stepSize:int

Implementation
    public function get stepSize():int
    public function set stepSize(value:int):void
Constructor Detail
Filter3DVBlurTask () Constructor
public function Filter3DVBlurTask(amount:uint, stepSize:int = -1)

Parameters
amount:uint
stepSize:int (default = -1) — The distance between samples. Set to -1 to autodetect with acceptable quality.
Method Detail
activate () method
override public function activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void

Parameters

stage3DProxy:Stage3DProxy
camera3D:Camera3D
depthTexture:Texture

getFragmentCode () method
override protected function getFragmentCode():String

Returns
String
updateTextures () method
override protected function updateTextures(stage:Stage3DProxy):void

Parameters

stage:Stage3DProxy


away3d.filters.tasks.Filter3DVDepthOfFFieldTask

Filter3DVDepthOfFFieldTask | Properties | Methods
Package | away3d.filters.tasks
Class | public class Filter3DVDepthOfFFieldTask
Inheritance | Filter3DVDepthOfFFieldTask Inheritance Filter3DTaskBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | focusDistance : Number | Filter3DVDepthOfFFieldTask
 | maxBlur : uint | Filter3DVDepthOfFFieldTask
 | range : Number | Filter3DVDepthOfFFieldTask
Inherited | requireDepthRender : Boolean [read-only] | Filter3DTaskBase
 | stepSize : int | Filter3DVDepthOfFFieldTask
Inherited | target : Texture | Filter3DTaskBase
Inherited | textureHeight : int | Filter3DTaskBase
Inherited | textureScale : int The texture scale for the input of this texture. | Filter3DTaskBase
Inherited | textureWidth : int | Filter3DTaskBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _mainInputTexture : Texture | Filter3DTaskBase
Inherited | _scaledTextureHeight : int = -1 | Filter3DTaskBase
Inherited | _scaledTextureWidth : int = -1 | Filter3DTaskBase
Inherited | _textureHeight : int = -1 | Filter3DTaskBase
Inherited | _textureScale : int = 0 | Filter3DTaskBase
Inherited | _textureWidth : int = -1 | Filter3DTaskBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Filter3DVDepthOfFFieldTask(maxBlur:uint, stepSize:int = -1) Creates a new Filter3DHDepthOfFFieldTask | Filter3DVDepthOfFFieldTask
 | activate(stage3DProxy:Stage3DProxy, camera:Camera3D, depthTexture:Texture):void [override] | Filter3DVDepthOfFFieldTask
 | deactivate(stage3DProxy:Stage3DProxy):void [override] | Filter3DVDepthOfFFieldTask
Inherited | dispose():void | Filter3DTaskBase
Inherited | getMainInputTexture(stage:Stage3DProxy):Texture | Filter3DTaskBase
Inherited | getProgram3D(stage3DProxy:Stage3DProxy):Program3D | Filter3DTaskBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | getFragmentCode():String [override] | Filter3DVDepthOfFFieldTask
Inherited | getVertexCode():String | Filter3DTaskBase
Inherited | invalidateProgram3D():void | Filter3DTaskBase
Inherited | updateProgram3D(stage:Stage3DProxy):void | Filter3DTaskBase
 | updateTextures(stage:Stage3DProxy):void [override] | Filter3DVDepthOfFFieldTask
Property Detail
focusDistance property
focusDistance:Number

Implementation
    public function get focusDistance():Number
    public function set focusDistance(value:Number):void
maxBlur property
maxBlur:uint

Implementation
    public function get maxBlur():uint
    public function set maxBlur(value:uint):void
range property
range:Number

Implementation
    public function get range():Number
    public function set range(value:Number):void
stepSize property
stepSize:int

Implementation
    public function get stepSize():int
    public function set stepSize(value:int):void
Constructor Detail
Filter3DVDepthOfFFieldTask () Constructor
public function Filter3DVDepthOfFFieldTask(maxBlur:uint, stepSize:int = -1)

Creates a new Filter3DHDepthOfFFieldTask

Parameters
maxBlur:uint — The maximum amount of blur to apply in pixels at the most out-of-focus areas
stepSize:int (default = -1) — The distance between samples. Set to -1 to autodetect with acceptable quality.
Method Detail
activate () method
override public function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, depthTexture:Texture):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
depthTexture:Texture

deactivate () method
override public function deactivate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

getFragmentCode () method
override protected function getFragmentCode():String

Returns
String
updateTextures () method
override protected function updateTextures(stage:Stage3DProxy):void

Parameters

stage:Stage3DProxy


away3d.filters.tasks.Filter3DXFadeCompositeTask

Filter3DXFadeCompositeTask | Properties | Methods
Package | away3d.filters.tasks
Class | public class Filter3DXFadeCompositeTask
Inheritance | Filter3DXFadeCompositeTask Inheritance Filter3DTaskBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | amount : Number | Filter3DXFadeCompositeTask
 | overlayTexture : TextureBase | Filter3DXFadeCompositeTask
Inherited | requireDepthRender : Boolean [read-only] | Filter3DTaskBase
Inherited | target : Texture | Filter3DTaskBase
Inherited | textureHeight : int | Filter3DTaskBase
Inherited | textureScale : int The texture scale for the input of this texture. | Filter3DTaskBase
Inherited | textureWidth : int | Filter3DTaskBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _mainInputTexture : Texture | Filter3DTaskBase
Inherited | _scaledTextureHeight : int = -1 | Filter3DTaskBase
Inherited | _scaledTextureWidth : int = -1 | Filter3DTaskBase
Inherited | _textureHeight : int = -1 | Filter3DTaskBase
Inherited | _textureScale : int = 0 | Filter3DTaskBase
Inherited | _textureWidth : int = -1 | Filter3DTaskBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Filter3DXFadeCompositeTask(amount:Number) | Filter3DXFadeCompositeTask
 | activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void [override] | Filter3DXFadeCompositeTask
 | deactivate(stage3DProxy:Stage3DProxy):void [override] | Filter3DXFadeCompositeTask
Inherited | dispose():void | Filter3DTaskBase
Inherited | getMainInputTexture(stage:Stage3DProxy):Texture | Filter3DTaskBase
Inherited | getProgram3D(stage3DProxy:Stage3DProxy):Program3D | Filter3DTaskBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | getFragmentCode():String [override] | Filter3DXFadeCompositeTask
Inherited | getVertexCode():String | Filter3DTaskBase
Inherited | invalidateProgram3D():void | Filter3DTaskBase
Inherited | updateProgram3D(stage:Stage3DProxy):void | Filter3DTaskBase
Inherited | updateTextures(stage:Stage3DProxy):void | Filter3DTaskBase
Property Detail
amount property
amount:Number

Implementation
    public function get amount():Number
    public function set amount(value:Number):void
overlayTexture property
overlayTexture:TextureBase

Implementation
    public function get overlayTexture():TextureBase
    public function set overlayTexture(value:TextureBase):void
Constructor Detail
Filter3DXFadeCompositeTask () Constructor
public function Filter3DXFadeCompositeTask(amount:Number)

Parameters
amount:Number
Method Detail
activate () method
override public function activate(stage3DProxy:Stage3DProxy, camera3D:Camera3D, depthTexture:Texture):void

Parameters

stage3DProxy:Stage3DProxy
camera3D:Camera3D
depthTexture:Texture

deactivate () method
override public function deactivate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

getFragmentCode () method
override protected function getFragmentCode():String

Returns
String


away3d.library - Away3D Documentation

Package away3d.library

Classes
AssetLibrary
AssetLibraryBundle


away3d.library Summary

away3d.library | Classes

Classes
Class | Description
AssetLibrary | AssetLibrary enforces a singleton pattern and is not intended to be instanced.
AssetLibraryBundle | AssetLibraryBundle enforces a multiton pattern and is not intended to be instanced directly.

Thu Nov 15 2012, 12:09 PM Z


away3d.library.AssetLibrary

AssetLibrary | Properties | Methods
Package | away3d.library
Class | public class AssetLibrary
Inheritance | AssetLibrary Inheritance Object

AssetLibrary enforces a singleton pattern and is not intended to be instanced. It's purpose is to allow access to the default library bundle through a set of static shortcut methods. If you are interested in creating multiple library bundles, please use the getBundle() method.

Public Properties
Property |  | Defined By
 | conflictPrecedence : String [static] Short-hand for conflictPrecedence property on default asset library bundle. | AssetLibrary
 | conflictStrategy : ConflictStrategyBase [static] Short-hand for conflictStrategy property on default asset library bundle. | AssetLibrary
Public Methods
Method |  | Defined By
 | AssetLibrary(se:AssetLibrarySingletonEnforcer) Creates a new AssetLibrary object. | AssetLibrary
 | addAsset(asset:IAsset):void [static] Short-hand for addAsset() method on default asset library bundle. | AssetLibrary
 | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [static] Short-hand for addEventListener() method on default asset library bundle. | AssetLibrary
 | createIterator(assetTypeFilter:String = null, namespaceFilter:String = null, filterFunc:Function = null):AssetLibraryIterator [static] Short-hand for createIterator() method on default asset library bundle. | AssetLibrary
 | enableParser(parserClass:Class):void [static] | AssetLibrary
 | enableParsers(parserClasses:Vector.<Class>):void [static] | AssetLibrary
 | getAsset(name:String, ns:String = null):IAsset [static] Short-hand for getAsset() method on default asset library bundle. | AssetLibrary
 | getBundle(key:String = default):AssetLibraryBundle [static] Returns an AssetLibrary bundle instance. | AssetLibrary
 | hasEventListener(type:String):Boolean [static] Short-hand for hasEventListener() method on default asset library bundle. | AssetLibrary
 | load(req:URLRequest, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken [static] Short-hand for load() method on default asset library bundle. | AssetLibrary
 | loadData(data:*, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken [static] Short-hand for loadData() method on default asset library bundle. | AssetLibrary
 | removeAllAssets(dispose:Boolean = true):void [static] Short-hand for removeAllAssets() method on default asset library bundle. | AssetLibrary
 | removeAsset(asset:IAsset, dispose:Boolean = true):void [static] Short-hand for removeAsset() method on default asset library bundle. | AssetLibrary
 | removeAssetByName(name:String, ns:String = null, dispose:Boolean = true):IAsset [static] Short-hand for removeAssetByName() method on default asset library bundle. | AssetLibrary
 | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [static] Short-hand for removeEventListener() method on default asset library bundle. | AssetLibrary
 | removeNamespaceAssets(ns:String = null, dispose:Boolean = true):void [static] Short-hand for removeNamespaceAssets() method on default asset library bundle. | AssetLibrary
 | willTrigger(type:String):Boolean [static] | AssetLibrary
Property Detail
_instances property
arcane static var _instances:Object

conflictPrecedence property
conflictPrecedence:String

Short-hand for conflictPrecedence property on default asset library bundle.

Implementation
    public static function get conflictPrecedence():String
    public static function set conflictPrecedence(value:String):void

See also

away3d.library.AssetLibraryBundle.conflictPrecedence
conflictStrategy property
conflictStrategy:ConflictStrategyBase

Short-hand for conflictStrategy property on default asset library bundle.

Implementation
    public static function get conflictStrategy():ConflictStrategyBase
    public static function set conflictStrategy(value:ConflictStrategyBase):void

See also

away3d.library.AssetLibraryBundle.conflictStrategy
Constructor Detail
AssetLibrary () Constructor
public function AssetLibrary(se:AssetLibrarySingletonEnforcer)

Creates a new AssetLibrary object.

Parameters
se:AssetLibrarySingletonEnforcer — A singleton enforcer for the AssetLibrary ensuring it cannnot be instanced.
Method Detail
addAsset () method
public static function addAsset(asset:IAsset):void

Short-hand for addAsset() method on default asset library bundle.

Parameters

asset:IAsset

See also

away3d.library.AssetLibraryBundle.addAsset()
addEventListener () method
public static function addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void

Short-hand for addEventListener() method on default asset library bundle.

Parameters

type:String
listener:Function
useCapture:Boolean (default = false)
priority:int (default = 0)
useWeakReference:Boolean (default = false)

createIterator () method
public static function createIterator(assetTypeFilter:String = null, namespaceFilter:String = null, filterFunc:Function = null):AssetLibraryIterator

Short-hand for createIterator() method on default asset library bundle.

Parameters

assetTypeFilter:String (default = null)
namespaceFilter:String (default = null)
filterFunc:Function (default = null)

Returns
AssetLibraryIterator

See also

away3d.library.AssetLibraryBundle.createIterator()
enableParser () method
public static function enableParser(parserClass:Class):void

Parameters

parserClass:Class

enableParsers () method
public static function enableParsers(parserClasses:Vector.<Class>):void

Parameters

parserClasses:Vector.<Class>

getAsset () method
public static function getAsset(name:String, ns:String = null):IAsset

Short-hand for getAsset() method on default asset library bundle.

Parameters

name:String
ns:String (default = null)

Returns
IAsset

See also

away3d.library.AssetLibraryBundle.getAsset()
getBundle () method
public static function getBundle(key:String = default):AssetLibraryBundle

Returns an AssetLibrary bundle instance. If no key is given, returns the default bundle (which is similar to using the AssetLibraryBundle as a singleton). To keep several separated library bundles, pass a string key to this method to define which bundle should be returned. This is referred to as using the AssetLibraryBundle as a multiton.

Parameters

key:String (default = default) — Defines which multiton instance should be returned.

Returns
AssetLibraryBundle — An instance of the asset library
hasEventListener () method
public static function hasEventListener(type:String):Boolean

Short-hand for hasEventListener() method on default asset library bundle.

Parameters

type:String

Returns
Boolean
load () method
public static function load(req:URLRequest, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken

Short-hand for load() method on default asset library bundle.

Parameters

req:URLRequest
context:AssetLoaderContext (default = null)
ns:String (default = null)
parser:ParserBase (default = null)

Returns
AssetLoaderToken

See also

away3d.library.AssetLibraryBundle.load()
loadData () method
public static function loadData(data:*, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken

Short-hand for loadData() method on default asset library bundle.

Parameters

data:*
context:AssetLoaderContext (default = null)
ns:String (default = null)
parser:ParserBase (default = null)

Returns
AssetLoaderToken

See also

away3d.library.AssetLibraryBundle.loadData()
removeAllAssets () method
public static function removeAllAssets(dispose:Boolean = true):void

Short-hand for removeAllAssets() method on default asset library bundle.

Parameters

dispose:Boolean (default = true) — Defines whether the assets should also be disposed.

See also

away3d.library.AssetLibraryBundle.removeAllAssets()
removeAsset () method
public static function removeAsset(asset:IAsset, dispose:Boolean = true):void

Short-hand for removeAsset() method on default asset library bundle.

Parameters

asset:IAsset — The asset which should be removed from the library.
dispose:Boolean (default = true) — Defines whether the assets should also be disposed.

See also

away3d.library.AssetLibraryBundle.removeAsset()
removeAssetByName () method
public static function removeAssetByName(name:String, ns:String = null, dispose:Boolean = true):IAsset

Short-hand for removeAssetByName() method on default asset library bundle.

Parameters

name:String — The name of the asset to be removed.
ns:String (default = null) — The namespace to which the desired asset belongs.
dispose:Boolean (default = true) — Defines whether the assets should also be disposed.

Returns
IAsset

See also

away3d.library.AssetLibraryBundle.removeAssetByName()
removeEventListener () method
public static function removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void

Short-hand for removeEventListener() method on default asset library bundle.

Parameters

type:String
listener:Function
useCapture:Boolean (default = false)

removeNamespaceAssets () method
public static function removeNamespaceAssets(ns:String = null, dispose:Boolean = true):void

Short-hand for removeNamespaceAssets() method on default asset library bundle.

Parameters

ns:String (default = null)
dispose:Boolean (default = true)

See also

away3d.library.AssetLibraryBundle.removeNamespaceAssets()
willTrigger () method
public static function willTrigger(type:String):Boolean

Parameters

type:String

Returns
Boolean


away3d.library.AssetLibraryBundle

AssetLibraryBundle | Properties | Methods | Events
Package | away3d.library
Class | public class AssetLibraryBundle
Inheritance | AssetLibraryBundle Inheritance flash.events.EventDispatcher

AssetLibraryBundle enforces a multiton pattern and is not intended to be instanced directly. Its purpose is to create a container for 3D data management, both before and after parsing. If you are interested in creating multiple library bundles, please use the getInstance() method.

Public Properties
Property |  | Defined By
 | conflictPrecedence : String Defines which asset should have precedence when resolving a naming conflict between two assets of which one has just been renamed by the user or by a parser. | AssetLibraryBundle
 | conflictStrategy : ConflictStrategyBase Defines which strategy should be used for resolving naming conflicts, when two library assets are given the same name. | AssetLibraryBundle
Public Methods
Method Defined By
AssetLibraryBundle(me:AssetLibraryBundleSingletonEnforcer)
Creates a new AssetLibraryBundle object.
AssetLibraryBundle
addAsset(asset:IAsset):void
Adds an asset to the asset library, first making sure that it's name is unique using the method defined by the conflictStrategy and conflictPrecedence properties.
AssetLibraryBundle
createIterator(assetTypeFilter:String = null, namespaceFilter:String = null, filterFunc:Function = null):AssetLibraryIterator
Create an AssetLibraryIterator instance that can be used to iterate over the assets in this asset library instance.
AssetLibraryBundle
enableParser(parserClass:Class):void
AssetLibraryBundle
enableParsers(parserClasses:Vector.<Class>):void
AssetLibraryBundle
getAsset(name:String, ns:String = null):IAsset
AssetLibraryBundle
getInstance(key:String = default):AssetLibraryBundle
[static] Returns an AssetLibraryBundle instance.
AssetLibraryBundle
load(req:URLRequest, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken
Loads a file and (optionally) all of its dependencies.
AssetLibraryBundle
loadData(data:*, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken
Loads a resource from existing data in memory.
AssetLibraryBundle
removeAllAssets(dispose:Boolean = true):void
Removes all assets from the asset library, optionally disposing them as they are removed.
AssetLibraryBundle
removeAsset(asset:IAsset, dispose:Boolean = true):void
Removes an asset from the library, and optionally disposes that asset by calling it's disposeAsset() method (which for most assets is implemented as a default version of that type's dispose() method.
AssetLibraryBundle
removeAssetByName(name:String, ns:String = null, dispose:Boolean = true):IAsset
Removes an asset which is specified using name and namespace.
AssetLibraryBundle
removeNamespaceAssets(ns:String = null, dispose:Boolean = true):void
Removes all assets belonging to a particular namespace (null for default) from the asset library, and optionall disposes them by calling their disposeAsset() method.
AssetLibraryBundle
Events
Event |  | Summary | Defined By
 | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | AssetLibraryBundle
 | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | AssetLibraryBundle
 | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | AssetLibraryBundle
 | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | AssetLibraryBundle
 | assetComplete | Dispatched when any asset finishes parsing. | AssetLibraryBundle
 | containerComplete | Dispatched when a container asset has been constructed from a resource. | AssetLibraryBundle
 | dependencyComplete | Dispatched when a single dependency (which may be the main file of a resource) finishes loading. | AssetLibraryBundle
 | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | AssetLibraryBundle
 | loadError | Dispatched when an error occurs during loading. | AssetLibraryBundle
 | materialComplete | Dispatched when a material asset has been constructed from a resource. | AssetLibraryBundle
 | resourceComplete | Dispatched when a full resource (including dependencies) finishes loading. | AssetLibraryBundle
 | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | AssetLibraryBundle
 | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | AssetLibraryBundle
 | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | AssetLibraryBundle
 | textureComplete | Dispatched when a texture asset has been constructed from a resource. | AssetLibraryBundle
Property Detail
conflictPrecedence property
conflictPrecedence:String

Defines which asset should have precedence when resolving a naming conflict between two assets of which one has just been renamed by the user or by a parser. By default ConflictPrecedence.FAVOR_NEW is used, meaning that the newly renamed asset will keep it's new name while the older asset gets renamed to not conflict. This property is ignored for conflict strategies that do not actually rename an asset automatically, such as ConflictStrategy.IGNORE and ConflictStrategy.THROW_ERROR.

Implementation
    public function get conflictPrecedence():String
    public function set conflictPrecedence(value:String):void

See also

away3d.library.naming.ConflictPrecedence
away3d.library.naming.ConflictStrategy
conflictStrategy property
conflictStrategy:ConflictStrategyBase

Defines which strategy should be used for resolving naming conflicts, when two library assets are given the same name. By default, ConflictStrategy.APPEND_NUM_SUFFIX is used which means that a numeric suffix is appended to one of the assets. The conflictPrecedence property defines which of the two conflicting assets will be renamed.

Implementation
    public function get conflictStrategy():ConflictStrategyBase
    public function set conflictStrategy(value:ConflictStrategyBase):void

See also

away3d.library.naming.ConflictStrategy
away3d.library.AssetLibrary.conflictPrecedence
Constructor Detail
AssetLibraryBundle () Constructor
public function AssetLibraryBundle(me:AssetLibraryBundleSingletonEnforcer)

Creates a new AssetLibraryBundle object.

Parameters
me:AssetLibraryBundleSingletonEnforcer — A multiton enforcer for the AssetLibraryBundle ensuring it cannnot be instanced.
Method Detail
addAsset () method
public function addAsset(asset:IAsset):void

Adds an asset to the asset library, first making sure that it's name is unique using the method defined by the conflictStrategy and conflictPrecedence properties.

Parameters

asset:IAsset

createIterator () method
public function createIterator(assetTypeFilter:String = null, namespaceFilter:String = null, filterFunc:Function = null):AssetLibraryIterator

Create an AssetLibraryIterator instance that can be used to iterate over the assets in this asset library instance. The iterator can filter assets on asset type and/or namespace. A "null" filter value means no filter of that type is used.

Parameters

assetTypeFilter:String (default = null) — Asset type to filter on (from the AssetType enum class.) Use null to not filter on asset type.
namespaceFilter:String (default = null) — Namespace to filter on. Use null to not filter on namespace.
filterFunc:Function (default = null) — Callback function to use when deciding whether an asset should be included in the iteration or not. This needs to be a function that takes a single parameter of type IAsset and returns a boolean where true means it should be included.

Returns
AssetLibraryIterator

See also

away3d.library.assets.AssetType
enableParser () method
public function enableParser(parserClass:Class):void

Parameters

parserClass:Class

enableParsers () method
public function enableParsers(parserClasses:Vector.<Class>):void

Parameters

parserClasses:Vector.<Class>

getAsset () method
public function getAsset(name:String, ns:String = null):IAsset

Parameters

name:String
ns:String (default = null)

Returns
IAsset
getInstance () method
public static function getInstance(key:String = default):AssetLibraryBundle

Returns an AssetLibraryBundle instance. If no key is given, returns the default bundle instance (which is similar to using the AssetLibraryBundle as a singleton.) To keep several separated library bundles, pass a string key to this method to define which bundle should be returned. This is referred to as using the AssetLibrary as a multiton.

Parameters

key:String (default = default) — Defines which multiton instance should be returned.

Returns
AssetLibraryBundle — An instance of the asset library
load () method
public function load(req:URLRequest, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken

Loads a file and (optionally) all of its dependencies.

Parameters

req:URLRequest — The URLRequest object containing the URL of the file to be loaded.
context:AssetLoaderContext (default = null) — An optional context object providing additional parameters for loading
ns:String (default = null) — An optional namespace string under which the file is to be loaded, allowing the differentiation of two resources with identical assets
parser:ParserBase (default = null) — An optional parser object for translating the loaded data into a usable resource. If not provided, AssetLoader will attempt to auto-detect the file type.

Returns
AssetLoaderToken
loadData () method
public function loadData(data:*, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken

Loads a resource from existing data in memory.

Parameters

data:* — The data object containing all resource information.
context:AssetLoaderContext (default = null) — An optional context object providing additional parameters for loading
ns:String (default = null) — An optional namespace string under which the file is to be loaded, allowing the differentiation of two resources with identical assets
parser:ParserBase (default = null) — An optional parser object for translating the loaded data into a usable resource. If not provided, AssetLoader will attempt to auto-detect the file type.

Returns
AssetLoaderToken
removeAllAssets () method
public function removeAllAssets(dispose:Boolean = true):void

Removes all assets from the asset library, optionally disposing them as they are removed.

Parameters

dispose:Boolean (default = true) — Defines whether the assets should also be disposed.

removeAsset () method
public function removeAsset(asset:IAsset, dispose:Boolean = true):void

Removes an asset from the library, and optionally disposes that asset by calling it's disposeAsset() method (which for most assets is implemented as a default version of that type's dispose() method.

Parameters

asset:IAsset — The asset which should be removed from this library.
dispose:Boolean (default = true) — Defines whether the assets should also be disposed.

removeAssetByName () method
public function removeAssetByName(name:String, ns:String = null, dispose:Boolean = true):IAsset

Removes an asset which is specified using name and namespace.

Parameters

name:String — The name of the asset to be removed.
ns:String (default = null) — The namespace to which the desired asset belongs.
dispose:Boolean (default = true) — Defines whether the assets should also be disposed.

Returns
IAsset

See also

away3d.library.AssetLibrary.removeAsset()
removeNamespaceAssets () method
public function removeNamespaceAssets(ns:String = null, dispose:Boolean = true):void

Removes all assets belonging to a particular namespace (null for default) from the asset library, and optionall disposes them by calling their disposeAsset() method.

Parameters

ns:String (default = null) — The namespace from which all assets should be removed.
dispose:Boolean (default = true) — Defines whether the assets should also be disposed.

See also

away3d.library.AssetLibrary.removeAsset()
Event Detail
animationNodeComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation node has been constructed from a resource.

animationSetComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation set has been constructed from a group of animation state resources.

animationStateComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation state has been constructed from a group of animation node resources.

animatorComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a animator asset has been constructed from a resource.

assetComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when any asset finishes parsing. Also see specific events for each individual asset type (meshes, materials et c.)

containerComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a container asset has been constructed from a resource.

dependencyComplete Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when a single dependency (which may be the main file of a resource) finishes loading.

geometryComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a geometry asset has been constructed from a resource.

loadError Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when an error occurs during loading.

materialComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a material asset has been constructed from a resource.

resourceComplete Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when a full resource (including dependencies) finishes loading.

skeletonComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a skeleton asset has been constructed from a resource.

skeletonPoseComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a skeleton pose asset has been constructed from a resource.

stateTransitionComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation state transition has been constructed from a group of animation node resources.

textureComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a texture asset has been constructed from a resource.


away3d.library.assets - Away3D Documentation

Package away3d.library.assets

Interfaces
IAsset
Classes
AssetType
BitmapDataAsset
NamedAssetBase


away3d.library.assets Summary

away3d.library.assets | Interfaces | Classes

Interfaces
Interface | Description
IAsset |
Classes
Class | Description
AssetType |
BitmapDataAsset | BitmapDataResource is a wrapper for loaded BitmapData, allowing it to be used uniformly as a resource when loading, parsing, and listing/resolving dependencies.
NamedAssetBase |

Thu Nov 15 2012, 12:09 PM Z


away3d.library.assets.AssetType

AssetType | Constants
Package | away3d.library.assets
Class | public class AssetType
Inheritance | AssetType Inheritance Object

Public Constants
Constant |  | Defined By
 | ANIMATION_NODE : String = animationNode [static] | AssetType
 | ANIMATION_SET : String = animationSet [static] | AssetType
 | ANIMATION_STATE : String = animationState [static] | AssetType
 | CONTAINER : String = container [static] | AssetType
 | ENTITY : String = entity [static] | AssetType
 | GEOMETRY : String = geometry [static] | AssetType
 | MATERIAL : String = material [static] | AssetType
 | MESH : String = mesh [static] | AssetType
 | SEGMENT_SET : String = segmentSet [static] | AssetType
 | SKELETON : String = skeleton [static] | AssetType
 | SKELETON_POSE : String = skeletonPose [static] | AssetType
 | STATE_TRANSITION : String = stateTransition [static] | AssetType
 | TEXTURE : String = texture [static] | AssetType
Constant Detail
ANIMATION_NODE Constant
public static const ANIMATION_NODE:String = animationNode

ANIMATION_SET Constant
public static const ANIMATION_SET:String = animationSet

ANIMATION_STATE Constant
public static const ANIMATION_STATE:String = animationState

CONTAINER Constant
public static const CONTAINER:String = container

ENTITY Constant
public static const ENTITY:String = entity

GEOMETRY Constant
public static const GEOMETRY:String = geometry

MATERIAL Constant
public static const MATERIAL:String = material

MESH Constant
public static const MESH:String = mesh

SEGMENT_SET Constant
public static const SEGMENT_SET:String = segmentSet

SKELETON Constant
public static const SKELETON:String = skeleton

SKELETON_POSE Constant
public static const SKELETON_POSE:String = skeletonPose

STATE_TRANSITION Constant
public static const STATE_TRANSITION:String = stateTransition

TEXTURE Constant
public static const TEXTURE:String = texture


away3d.library.assets.BitmapDataAsset

BitmapDataAsset | Properties | Methods | Constants
Package | away3d.library.assets
Class | public class BitmapDataAsset
Inheritance | BitmapDataAsset Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IAsset

BitmapDataResource is a wrapper for loaded BitmapData, allowing it to be used uniformly as a resource when loading, parsing, and listing/resolving dependencies.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
 | assetType : String [read-only] | BitmapDataAsset
 | bitmapData : BitmapData The bitmapData to be treated as a resource. | BitmapDataAsset
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | BitmapDataAsset(bitmapData:BitmapData = null) Creates a new BitmapDataResource object. | BitmapDataAsset
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | dispose():void Cleans up any resources used by the current object. | BitmapDataAsset
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
assetType property
assetType:String [read-only]

Implementation
    public function get assetType():String
bitmapData property
bitmapData:BitmapData

The bitmapData to be treated as a resource.

Implementation
    public function get bitmapData():BitmapData
    public function set bitmapData(value:BitmapData):void
Constructor Detail
BitmapDataAsset () Constructor
public function BitmapDataAsset(bitmapData:BitmapData = null)

Creates a new BitmapDataResource object.

Parameters
bitmapData:BitmapData (default = null) — An optional BitmapData object to use as the resource data.
Method Detail
dispose () method
public function dispose():void

Cleans up any resources used by the current object.


away3d.library.assets.IAsset

IAsset | Properties | Methods
Package | away3d.library.assets
Interface | public interface IAsset extends flash.events.IEventDispatcher
Implementors | AnimationNodeBase, AnimationSetBase, BitmapDataAsset, Geometry, MaterialBase, Mesh, ObjectContainer3D, Skeleton, SkeletonPose, TextureProxyBase

Public Properties
Property |  | Defined By
 | assetFullPath : Array [read-only] | IAsset
 | assetNamespace : String [read-only] | IAsset
 | assetType : String [read-only] | IAsset
 | name : String | IAsset
Public Methods
Method |  | Defined By
 | assetPathEquals(name:String, ns:String):Boolean | IAsset
 | dispose():void Cleans up resources used by this asset. | IAsset
 | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | IAsset
Property Detail
assetFullPath property
assetFullPath:Array [read-only]

Implementation
    public function get assetFullPath():Array
assetNamespace property
assetNamespace:String [read-only]

Implementation
    public function get assetNamespace():String
assetType property
assetType:String [read-only]

Implementation
    public function get assetType():String
name property
name:String

Implementation
    public function get name():String
    public function set name(value:String):void
Method Detail
assetPathEquals () method
public function assetPathEquals(name:String, ns:String):Boolean

Parameters

name:String
ns:String

Returns
Boolean
dispose () method
public function dispose():void

Cleans up resources used by this asset.

resetAssetPath () method
public function resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void

Parameters

name:String
ns:String (default = null)
overrideOriginal:Boolean (default = true)


away3d.library.assets.NamedAssetBase

NamedAssetBase | Properties | Methods | Constants
Package | away3d.library.assets
Class | public class NamedAssetBase
Inheritance | NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | AnimationNodeBase, AnimationSetBase, BitmapDataAsset, Geometry, MaterialBase, Object3D, Skeleton, SkeletonPose, TextureProxyBase

Public Properties
Property |  | Defined By
 | assetFullPath : Array [read-only] | NamedAssetBase
 | assetNamespace : String [read-only] | NamedAssetBase
 | name : String | NamedAssetBase
 | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Public Methods
Method |  | Defined By
 | NamedAssetBase(name:String = null) | NamedAssetBase
 | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Public Constants
Constant |  | Defined By
 | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
assetFullPath property
assetFullPath:Array [read-only]

Implementation
    public function get assetFullPath():Array
assetNamespace property
assetNamespace:String [read-only]

Implementation
    public function get assetNamespace():String
name property
name:String

Implementation
    public function get name():String
    public function set name(value:String):void
originalName property
originalName:String [read-only]

The original name used for this asset in the resource (e.g. file) in which it was found. This may not be the same as name, which may have changed due to of a name conflict.

Implementation
    public function get originalName():String
Constructor Detail
NamedAssetBase () Constructor
public function NamedAssetBase(name:String = null)

Parameters
name:String (default = null)
Method Detail
assetPathEquals () method
public function assetPathEquals(name:String, ns:String):Boolean

Parameters

name:String
ns:String

Returns
Boolean
resetAssetPath () method
public function resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void

Parameters

name:String
ns:String (default = null)
overrideOriginal:Boolean (default = true)

Constant Detail
DEFAULT_NAMESPACE Constant
public static const DEFAULT_NAMESPACE:String = default


away3d.library.naming - Away3D Documentation

Package away3d.library.naming

Classes
ConflictPrecedence
ConflictStrategy
ConflictStrategyBase
ErrorConflictStrategy
IgnoreConflictStrategy
NumSuffixConflictStrategy


away3d.library.naming Summary

away3d.library.naming | Classes

Classes
Class | Description
ConflictPrecedence | Enumaration class for precedence when resolving naming conflicts in the library.
ConflictStrategy | Enumeration class for bundled conflict strategies.
ConflictStrategyBase | Abstract base class for naming conflict resolution classes.
ErrorConflictStrategy |
IgnoreConflictStrategy |
NumSuffixConflictStrategy |

Thu Nov 15 2012, 12:09 PM Z


away3d.library.naming.ConflictPrecedence

ConflictPrecedence | Constants
Package | away3d.library.naming
Class | public class ConflictPrecedence
Inheritance | ConflictPrecedence Inheritance Object

Enumaration class for precedence when resolving naming conflicts in the library.

See also

away3d.library.AssetLibrary.conflictPrecedence
away3d.library.AssetLibrary.conflictStrategy
away3d.library.naming.ConflictStrategy

Public Constants
Constant |  | Defined By
 | FAVOR_NEW : String = favorNew [static] Signales that in a conflict, the newly renamed asset is favored (and keeps it's newly defined name) and that the previous owner of that name gets renamed to a non-conflicting name. | ConflictPrecedence
 | FAVOR_OLD : String = favorOld [static] Signals that in a conflict, the previous owner of the conflicting name should be favored (and keep it's name) and that the newly renamed asset is reverted to a non-conflicting name. | ConflictPrecedence
Constant Detail
FAVOR_NEW Constant
public static const FAVOR_NEW:String = favorNew

Signales that in a conflict, the newly renamed asset is favored (and keeps it's newly defined name) and that the previous owner of that name gets renamed to a non-conflicting name.

FAVOR_OLD Constant
public static const FAVOR_OLD:String = favorOld

Signals that in a conflict, the previous owner of the conflicting name should be favored (and keep it's name) and that the newly renamed asset is reverted to a non-conflicting name.


away3d.library.naming.ConflictStrategy

ConflictStrategy | Constants
Package | away3d.library.naming
Class | public class ConflictStrategy
Inheritance | ConflictStrategy Inheritance Object

Enumeration class for bundled conflict strategies. Set one of these values (or an instance of a self-defined sub-class of ConflictStrategyBase) to the conflictStrategy property on an AssetLibrary to define how that library resolves naming conflicts. The value of the AssetLibrary.conflictPrecedence property defines which of the conflicting assets will get to keep it's name, and which is renamed (if any.)

See also

away3d.library.AssetLibrary.conflictStrategy
away3d.library.naming.ConflictStrategyBase

Public Constants
Constant |  | Defined By
 | APPEND_NUM_SUFFIX : ConflictStrategyBase [static] Specifies that in case of a naming conflict, one of the assets will be renamed and a numeric suffix appended to the base name. | ConflictStrategy
 | IGNORE : ConflictStrategyBase [static] Specifies that naming conflicts should be ignored. | ConflictStrategy
 | THROW_ERROR : ConflictStrategyBase [static] Specifies that an error should be thrown if a naming conflict is discovered. | ConflictStrategy
Constant Detail
APPEND_NUM_SUFFIX Constant
public static const APPEND_NUM_SUFFIX:ConflictStrategyBase

Specifies that in case of a naming conflict, one of the assets will be renamed and a numeric suffix appended to the base name.

IGNORE Constant
public static const IGNORE:ConflictStrategyBase

Specifies that naming conflicts should be ignored. This is not recommended in most cases, unless it can be 100% guaranteed that the application does not cause naming conflicts in the library (i.e. when an app-level system is in place to prevent this.)

THROW_ERROR Constant
public static const THROW_ERROR:ConflictStrategyBase

Specifies that an error should be thrown if a naming conflict is discovered. Use this to be 100% sure that naming conflicts never occur unnoticed, and when it's undesirable to have the library automatically rename assets to avoid such conflicts.


away3d.library.naming.ConflictStrategyBase

ConflictStrategyBase | Methods
Package | away3d.library.naming
Class | public class ConflictStrategyBase
Inheritance | ConflictStrategyBase Inheritance Object
Subclasses | ErrorConflictStrategy, IgnoreConflictStrategy, NumSuffixConflictStrategy

Abstract base class for naming conflict resolution classes. Extend this to create a strategy class which the asset library can use to resolve asset naming conflicts, or use one of the bundled concrete strategy classes:
  • IgnoreConflictStrategy (ConflictStrategy.IGNORE)
  • ErrorConflictStrategy (ConflictStrategy.THROW_ERROR)
  • NumSuffixConflictStrategy (ConflictStrategy.APPEND_NUM_SUFFIX)

See also

away3d.library.AssetLibrary.conflictStrategy
away3d.library.naming.ConflictStrategy
away3d.library.naming.IgnoreConflictStrategy
away3d.library.naming.ErrorConflictStrategy
away3d.library.naming.NumSuffixConflictStrategy

Public Methods
Method |  | Defined By
 | ConflictStrategyBase() | ConflictStrategyBase
 | create():ConflictStrategyBase Create instance of this conflict strategy. | ConflictStrategyBase
 | resolveConflict(changedAsset:IAsset, oldAsset:IAsset, assetsDictionary:Object, precedence:String):void Resolve a naming conflict between two assets. | ConflictStrategyBase
Protected Methods
Method Defined By
updateNames(ns:String, nonConflictingName:String, oldAsset:IAsset, newAsset:IAsset, assetsDictionary:Object, precedence:String):void
Provided as a convenience method for all conflict strategy classes, as a way to finalize the conflict resolution by applying the new names and dispatching the correct events.
ConflictStrategyBase
Constructor Detail
ConflictStrategyBase () Constructor
public function ConflictStrategyBase()

Method Detail
create () method
public function create():ConflictStrategyBase

Create instance of this conflict strategy. Used internally by the AssetLibrary to make sure the same strategy instance is not used in all AssetLibrary instances, which would break any state caching that happens inside the strategy class.

Returns
ConflictStrategyBase
resolveConflict () method
public function resolveConflict(changedAsset:IAsset, oldAsset:IAsset, assetsDictionary:Object, precedence:String):void

Resolve a naming conflict between two assets. Must be implemented by concrete strategy classes.

Parameters

changedAsset:IAsset
oldAsset:IAsset
assetsDictionary:Object
precedence:String

updateNames () method
protected function updateNames(ns:String, nonConflictingName:String, oldAsset:IAsset, newAsset:IAsset, assetsDictionary:Object, precedence:String):void

Provided as a convenience method for all conflict strategy classes, as a way to finalize the conflict resolution by applying the new names and dispatching the correct events.

Parameters

ns:String
nonConflictingName:String
oldAsset:IAsset
newAsset:IAsset
assetsDictionary:Object
precedence:String


away3d.library.naming.ErrorConflictStrategy

ErrorConflictStrategy | Methods
Package | away3d.library.naming
Class | public class ErrorConflictStrategy
Inheritance | ErrorConflictStrategy Inheritance ConflictStrategyBase Inheritance Object

Public Methods
Method |  | Defined By
 | ErrorConflictStrategy() | ErrorConflictStrategy
 | create():ConflictStrategyBase [override] | ErrorConflictStrategy
 | resolveConflict(changedAsset:IAsset, oldAsset:IAsset, assetsDictionary:Object, precedence:String):void [override] | ErrorConflictStrategy
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
updateNames(ns:String, nonConflictingName:String, oldAsset:IAsset, newAsset:IAsset, assetsDictionary:Object, precedence:String):void
Provided as a convenience method for all conflict strategy classes, as a way to finalize the conflict resolution by applying the new names and dispatching the correct events.
ConflictStrategyBase
Constructor Detail
ErrorConflictStrategy () Constructor
public function ErrorConflictStrategy()

Method Detail
create () method
override public function create():ConflictStrategyBase

Returns
ConflictStrategyBase
resolveConflict () method
override public function resolveConflict(changedAsset:IAsset, oldAsset:IAsset, assetsDictionary:Object, precedence:String):void

Parameters

changedAsset:IAsset
oldAsset:IAsset
assetsDictionary:Object
precedence:String


away3d.library.naming.IgnoreConflictStrategy

IgnoreConflictStrategy | Methods
Package | away3d.library.naming
Class | public class IgnoreConflictStrategy
Inheritance | IgnoreConflictStrategy Inheritance ConflictStrategyBase Inheritance Object

Public Methods
Method |  | Defined By
 | IgnoreConflictStrategy() | IgnoreConflictStrategy
 | create():ConflictStrategyBase [override] | IgnoreConflictStrategy
 | resolveConflict(changedAsset:IAsset, oldAsset:IAsset, assetsDictionary:Object, precedence:String):void [override] | IgnoreConflictStrategy
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
updateNames(ns:String, nonConflictingName:String, oldAsset:IAsset, newAsset:IAsset, assetsDictionary:Object, precedence:String):void
Provided as a convenience method for all conflict strategy classes, as a way to finalize the conflict resolution by applying the new names and dispatching the correct events.
ConflictStrategyBase
Constructor Detail
IgnoreConflictStrategy () Constructor
public function IgnoreConflictStrategy()

Method Detail
create () method
override public function create():ConflictStrategyBase

Returns
ConflictStrategyBase
resolveConflict () method
override public function resolveConflict(changedAsset:IAsset, oldAsset:IAsset, assetsDictionary:Object, precedence:String):void

Parameters

changedAsset:IAsset
oldAsset:IAsset
assetsDictionary:Object
precedence:String


away3d.library.naming.NumSuffixConflictStrategy

NumSuffixConflictStrategy | Methods
Package | away3d.library.naming
Class | public class NumSuffixConflictStrategy
Inheritance | NumSuffixConflictStrategy Inheritance ConflictStrategyBase Inheritance Object

Public Methods
Method |  | Defined By
 | NumSuffixConflictStrategy(separator:String = .) | NumSuffixConflictStrategy
 | create():ConflictStrategyBase [override] | NumSuffixConflictStrategy
 | resolveConflict(changedAsset:IAsset, oldAsset:IAsset, assetsDictionary:Object, precedence:String):void [override] | NumSuffixConflictStrategy
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
updateNames(ns:String, nonConflictingName:String, oldAsset:IAsset, newAsset:IAsset, assetsDictionary:Object, precedence:String):void
Provided as a convenience method for all conflict strategy classes, as a way to finalize the conflict resolution by applying the new names and dispatching the correct events.
ConflictStrategyBase
Constructor Detail
NumSuffixConflictStrategy () Constructor
public function NumSuffixConflictStrategy(separator:String = .)

Parameters
separator:String (default = .)
Method Detail
create () method
override public function create():ConflictStrategyBase

Returns
ConflictStrategyBase
resolveConflict () method
override public function resolveConflict(changedAsset:IAsset, oldAsset:IAsset, assetsDictionary:Object, precedence:String):void

Parameters

changedAsset:IAsset
oldAsset:IAsset
assetsDictionary:Object
precedence:String


away3d.library.utils - Away3D Documentation

Package away3d.library.utils

Classes
AssetLibraryIterator


away3d.library.utils Summary

away3d.library.utils | Classes

Classes
Class | Description
AssetLibraryIterator |

Thu Nov 15 2012, 12:09 PM Z


away3d.library.utils.AssetLibraryIterator

AssetLibraryIterator | Properties | Methods
Package | away3d.library.utils
Class | public class AssetLibraryIterator
Inheritance | AssetLibraryIterator Inheritance Object

Public Properties
Property |  | Defined By
 | currentAsset : IAsset [read-only] | AssetLibraryIterator
 | numAssets : uint [read-only] | AssetLibraryIterator
Public Methods
Method |  | Defined By
 | AssetLibraryIterator(assets:Vector.<IAsset>, assetTypeFilter:String, namespaceFilter:String, filterFunc:Function) | AssetLibraryIterator
 | next():IAsset | AssetLibraryIterator
 | reset():void | AssetLibraryIterator
 | setIndex(index:uint):void | AssetLibraryIterator
Property Detail
currentAsset property
currentAsset:IAsset [read-only]

Implementation
    public function get currentAsset():IAsset
numAssets property
numAssets:uint [read-only]

Implementation
    public function get numAssets():uint
Constructor Detail
AssetLibraryIterator () Constructor
public function AssetLibraryIterator(assets:Vector.<IAsset>, assetTypeFilter:String, namespaceFilter:String, filterFunc:Function)

Parameters
assets:Vector.<IAsset>
assetTypeFilter:String
namespaceFilter:String
filterFunc:Function
Method Detail
next () method
public function next():IAsset

Returns
IAsset
reset () method
public function reset():void

setIndex () method
public function setIndex(index:uint):void

Parameters

index:uint


away3d.lights - Away3D Documentation

Package away3d.lights

Classes
DirectionalLight
LightBase
LightProbe
PointLight


away3d.lights Summary

away3d.lights | Classes

Classes
Class | Description
DirectionalLight | DirectionalLight represents an idealized light "at infinity", to be used for distant light sources such as the sun.
LightBase | LightBase provides an abstract base class for subtypes representing lights.
LightProbe |
PointLight | PointLight represents an omni-directional light.

Thu Nov 15 2012, 12:09 PM Z


away3d.lights.DirectionalLight

DirectionalLight | Properties | Methods | Events | Constants
Package | away3d.lights
Class | public class DirectionalLight
Inheritance | DirectionalLight Inheritance LightBase Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

DirectionalLight represents an idealized light "at infinity", to be used for distant light sources such as the sun. In any position in the scene, the light raytracing will always be parallel. Although the position of the light does not impact its effect, it can be used along with lookAt to intuitively create day cycles by orbiting the position around a center point and using lookAt at that position.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | ambient : Number The ambient emission strength of the light. | LightBase
Inherited | ambientColor : uint | LightBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Entity
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
Inherited | castsShadows : Boolean | LightBase
Inherited | color : uint The color of the light. | LightBase
Inherited | diffuse : Number The diffuse emission strength of the light. | LightBase
 | direction : Vector3D The direction of the light. | DirectionalLight
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
 | sceneDirection : Vector3D [read-only] The direction of the light in scene coordinates. | DirectionalLight
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | shadowMapper : ShadowMapperBase | LightBase
Inherited | showBounds : Boolean | Entity
Inherited | specular : Number The specular emission strength of the light. | LightBase
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DirectionalLight(xDir:Number = 0, yDir:Number = -1, zDir:Number = 1) Creates a new DirectionalLight object. | DirectionalLight
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | ObjectContainer3D
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createEntityPartitionNode():EntityNode [override] | DirectionalLight
 | createShadowMapper():ShadowMapperBase [override] | DirectionalLight
 | getDefaultBoundingVolume():BoundingVolumeBase [override] Creates the default bounding box to be used by this type of Entity. | DirectionalLight
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
 | updateBounds():void [override] Updates the bounding volume for the object. | DirectionalLight
Inherited | updateMouseChildren():void [override] | Entity
 | updateSceneTransform():void [override] Updates the scene transformation matrix. | DirectionalLight
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
direction property
direction:Vector3D

The direction of the light.

Implementation
    public function get direction():Vector3D
    public function set direction(value:Vector3D):void
sceneDirection property
sceneDirection:Vector3D [read-only]

The direction of the light in scene coordinates.

Implementation
    public function get sceneDirection():Vector3D
Constructor Detail
DirectionalLight () Constructor
public function DirectionalLight(xDir:Number = 0, yDir:Number = -1, zDir:Number = 1)

Creates a new DirectionalLight object.

Parameters
xDir:Number (default = 0) — The x-component of the light's directional vector.
yDir:Number (default = -1) — The y-component of the light's directional vector.
zDir:Number (default = 1) — The z-component of the light's directional vector.
Method Detail
createEntityPartitionNode () method
override protected function createEntityPartitionNode():EntityNode

Returns
EntityNode
createShadowMapper () method
override protected function createShadowMapper():ShadowMapperBase

Returns
ShadowMapperBase
getDefaultBoundingVolume () method
override protected function getDefaultBoundingVolume():BoundingVolumeBase

Creates the default bounding box to be used by this type of Entity.

Returns
BoundingVolumeBase —
getObjectProjectionMatrix () method
override arcane function getObjectProjectionMatrix(renderable:IRenderable, target:Matrix3D = null):Matrix3D

Gets the optimal projection matrix to render a light-based depth map for a single object.

Parameters

renderable:IRenderable — The IRenderable object to render to a depth map.
target:Matrix3D (default = null) — An optional target Matrix3D object. If not provided, an instance will be created.

Returns
Matrix3D — A Matrix3D object containing the projection transformation.
updateBounds () method
override protected function updateBounds():void

Updates the bounding volume for the object. Overriding methods need to set invalid flag to false!

updateSceneTransform () method
override protected function updateSceneTransform():void

Updates the scene transformation matrix.


away3d.lights.LightBase

LightBase | Properties | Methods | Events | Constants
Package | away3d.lights
Class | public class LightBase
Inheritance | LightBase Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | DirectionalLight, LightProbe, PointLight

LightBase provides an abstract base class for subtypes representing lights.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | ambient : Number The ambient emission strength of the light. | LightBase
 | ambientColor : uint | LightBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Entity
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
 | castsShadows : Boolean | LightBase
 | color : uint The color of the light. | LightBase
 | diffuse : Number The diffuse emission strength of the light. | LightBase
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
 | shadowMapper : ShadowMapperBase | LightBase
Inherited | showBounds : Boolean | Entity
 | specular : Number The specular emission strength of the light. | LightBase
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | LightBase() Create a new LightBase object. | LightBase
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | ObjectContainer3D
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createEntityPartitionNode():EntityNode [override] Factory method that returns the current partition node. | LightBase
 | createShadowMapper():ShadowMapperBase | LightBase
Inherited | getDefaultBoundingVolume():BoundingVolumeBase Creates the default bounding box to be used by this type of Entity. | Entity
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void Updates the bounding volume for the object. | Entity
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_ambientB property
arcane var _ambientB:Number = 0

_ambientG property
arcane var _ambientG:Number = 0

_ambientR property
arcane var _ambientR:Number = 0

_diffuseB property
arcane var _diffuseB:Number = 1

_diffuseG property
arcane var _diffuseG:Number = 1

_diffuseR property
arcane var _diffuseR:Number = 1

_specularB property
arcane var _specularB:Number = 1

_specularG property
arcane var _specularG:Number = 1

_specularR property
arcane var _specularR:Number = 1

ambient property
ambient:Number

The ambient emission strength of the light.

Implementation
    public function get ambient():Number
    public function set ambient(value:Number):void
ambientColor property
ambientColor:uint

Implementation
    public function get ambientColor():uint
    public function set ambientColor(value:uint):void
castsShadows property
castsShadows:Boolean

Implementation
    public function get castsShadows():Boolean
    public function set castsShadows(value:Boolean):void
color property
color:uint

The color of the light.

Implementation
    public function get color():uint
    public function set color(value:uint):void
diffuse property
diffuse:Number

The diffuse emission strength of the light.

Implementation
    public function get diffuse():Number
    public function set diffuse(value:Number):void
shadowMapper property
shadowMapper:ShadowMapperBase

Implementation
    public function get shadowMapper():ShadowMapperBase
    public function set shadowMapper(value:ShadowMapperBase):void
specular property
specular:Number

The specular emission strength of the light.

Implementation
    public function get specular():Number
    public function set specular(value:Number):void
Constructor Detail
LightBase () Constructor
public function LightBase()

Create a new LightBase object.

Method Detail
createEntityPartitionNode () method
override protected function createEntityPartitionNode():EntityNode

Factory method that returns the current partition node. Needs to be overridden by concrete subclasses such as Mesh to return the correct concrete subtype of EntityPartition3DNode (for Mesh = MeshPartition3DNode, most IRenderables (particles fe) would return RenderablePartition3DNode, I suppose)

Returns
EntityNode
createShadowMapper () method
protected function createShadowMapper():ShadowMapperBase

Returns
ShadowMapperBase
getObjectProjectionMatrix () method
arcane function getObjectProjectionMatrix(renderable:IRenderable, target:Matrix3D = null):Matrix3D

Gets the optimal projection matrix to render a light-based depth map for a single object.

Parameters

renderable:IRenderable — The IRenderable object to render to a depth map.
target:Matrix3D (default = null) — An optional target Matrix3D object. If not provided, an instance will be created.

Returns
Matrix3D — A Matrix3D object containing the projection transformation.


away3d.lights.LightProbe

LightProbe | Properties | Methods | Events | Constants
Package | away3d.lights
Class | public class LightProbe
Inheritance | LightProbe Inheritance LightBase Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | ambient : Number The ambient emission strength of the light. | LightBase
Inherited | ambientColor : uint | LightBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Entity
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
Inherited | castsShadows : Boolean | LightBase
Inherited | color : uint The color of the light. | LightBase
Inherited | diffuse : Number The diffuse emission strength of the light. | LightBase
 | diffuseMap : CubeTextureBase | LightProbe
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | shadowMapper : ShadowMapperBase | LightBase
Inherited | showBounds : Boolean | Entity
Inherited | specular : Number The specular emission strength of the light. | LightBase
 | specularMap : CubeTextureBase | LightProbe
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | LightProbe(diffuseMap:CubeTextureBase, specularMap:CubeTextureBase = null) Creates a new LightProbe object. | LightProbe
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | ObjectContainer3D
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createEntityPartitionNode():EntityNode [override] | LightProbe
Inherited | createShadowMapper():ShadowMapperBase | LightBase
 | getDefaultBoundingVolume():BoundingVolumeBase [override] Creates the default bounding box to be used by this type of Entity. | LightProbe
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
 | updateBounds():void [override] Updates the bounding volume for the object. | LightProbe
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
diffuseMap property
diffuseMap:CubeTextureBase

Implementation
    public function get diffuseMap():CubeTextureBase
    public function set diffuseMap(value:CubeTextureBase):void
specularMap property
specularMap:CubeTextureBase

Implementation
    public function get specularMap():CubeTextureBase
    public function set specularMap(value:CubeTextureBase):void
Constructor Detail
LightProbe () Constructor
public function LightProbe(diffuseMap:CubeTextureBase, specularMap:CubeTextureBase = null)

Creates a new LightProbe object.

Parameters
diffuseMap:CubeTextureBase
specularMap:CubeTextureBase (default = null)
Method Detail
createEntityPartitionNode () method
override protected function createEntityPartitionNode():EntityNode

Returns
EntityNode
getDefaultBoundingVolume () method
override protected function getDefaultBoundingVolume():BoundingVolumeBase

Creates the default bounding box to be used by this type of Entity.

Returns
BoundingVolumeBase —
getObjectProjectionMatrix () method
override arcane function getObjectProjectionMatrix(renderable:IRenderable, target:Matrix3D = null):Matrix3D

Gets the optimal projection matrix to render a light-based depth map for a single object.

Parameters

renderable:IRenderable — The IRenderable object to render to a depth map.
target:Matrix3D (default = null) — An optional target Matrix3D object. If not provided, an instance will be created.

Returns
Matrix3D — A Matrix3D object containing the projection transformation.
updateBounds () method
override protected function updateBounds():void

Updates the bounding volume for the object. Overriding methods need to set invalid flag to false!


away3d.lights.PointLight

PointLight | Properties | Methods | Events | Constants
Package | away3d.lights
Class | public class PointLight
Inheritance | PointLight Inheritance LightBase Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

PointLight represents an omni-directional light. The light is emitted from a given position in the scene.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | ambient : Number The ambient emission strength of the light. | LightBase
Inherited | ambientColor : uint | LightBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Entity
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
Inherited | castsShadows : Boolean | LightBase
Inherited | color : uint The color of the light. | LightBase
Inherited | diffuse : Number The diffuse emission strength of the light. | LightBase
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
 | fallOff : Number The maximum distance of the light's reach | PointLight
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | radius : Number The minimum distance of the light's reach. | PointLight
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | shadowMapper : ShadowMapperBase | LightBase
Inherited | showBounds : Boolean | Entity
Inherited | specular : Number The specular emission strength of the light. | LightBase
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | PointLight() Creates a new PointLight object. | PointLight
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | ObjectContainer3D
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createEntityPartitionNode():EntityNode [override] | PointLight
 | createShadowMapper():ShadowMapperBase [override] | PointLight
 | getDefaultBoundingVolume():BoundingVolumeBase [override] Creates the default bounding box to be used by this type of Entity. | PointLight
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
 | updateBounds():void [override] Updates the bounding volume for the object. | PointLight
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_fallOff property
arcane var _fallOff:Number = 1.7976931348623157E308

_fallOffFactor property
arcane var _fallOffFactor:Number

_radius property
arcane var _radius:Number = 1.7976931348623157E308

fallOff property
fallOff:Number

The maximum distance of the light's reach

Implementation
    public function get fallOff():Number
    public function set fallOff(value:Number):void
radius property
radius:Number

The minimum distance of the light's reach.

Implementation
    public function get radius():Number
    public function set radius(value:Number):void
Constructor Detail
PointLight () Constructor
public function PointLight()

Creates a new PointLight object.

Method Detail
createEntityPartitionNode () method
override protected function createEntityPartitionNode():EntityNode

Returns
EntityNode
createShadowMapper () method
override protected function createShadowMapper():ShadowMapperBase

Returns
ShadowMapperBase
fallOffFactor () method
arcane function fallOffFactor():Number

Returns
Number
getDefaultBoundingVolume () method
override protected function getDefaultBoundingVolume():BoundingVolumeBase

Creates the default bounding box to be used by this type of Entity.

Returns
BoundingVolumeBase —
getObjectProjectionMatrix () method
override arcane function getObjectProjectionMatrix(renderable:IRenderable, target:Matrix3D = null):Matrix3D

Gets the optimal projection matrix to render a light-based depth map for a single object.

Parameters

renderable:IRenderable — The IRenderable object to render to a depth map.
target:Matrix3D (default = null) — An optional target Matrix3D object. If not provided, an instance will be created.

Returns
Matrix3D — A Matrix3D object containing the projection transformation.
updateBounds () method
override protected function updateBounds():void

Updates the bounding volume for the object. Overriding methods need to set invalid flag to false!


away3d.lights.shadowmaps - Away3D Documentation

Package away3d.lights.shadowmaps

Classes
CascadeShadowMapper
CubeMapShadowMapper
DirectionalShadowMapper
NearDirectionalShadowMapper
ShadowMapperBase


away3d.lights.shadowmaps Summary

away3d.lights.shadowmaps | Classes

Classes
Class | Description
CascadeShadowMapper |
CubeMapShadowMapper |
DirectionalShadowMapper |
NearDirectionalShadowMapper |
ShadowMapperBase |

Thu Nov 15 2012, 12:09 PM Z


away3d.lights.shadowmaps.CascadeShadowMapper

CascadeShadowMapper | Properties | Methods
Package | away3d.lights.shadowmaps
Class | public class CascadeShadowMapper
Inheritance | CascadeShadowMapper Inheritance ShadowMapperBase Inheritance Object
Implements | flash.events.IEventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | autoUpdateShadows : Boolean | ShadowMapperBase
Inherited | depthMap : TextureProxyBase [read-only] | ShadowMapperBase
 | depthMapSize : uint [override] | CascadeShadowMapper
Inherited | light : LightBase | ShadowMapperBase
 | lightOffset : Number | CascadeShadowMapper
 | numCascades : int | CascadeShadowMapper
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _casterCollector : ShadowCasterCollector | ShadowMapperBase
Inherited | _depthMapSize : uint = 2048 | ShadowMapperBase
Inherited | _light : LightBase | ShadowMapperBase
 | _scissorRects : Vector.<Rectangle> | CascadeShadowMapper
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CascadeShadowMapper(numCascades:uint = 3) | CascadeShadowMapper
 | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void | CascadeShadowMapper
 | dispatchEvent(event:Event):Boolean | CascadeShadowMapper
Inherited | dispose():void | ShadowMapperBase
 | getDepthProjections(partition:uint):Matrix3D | CascadeShadowMapper
 | getSplitRatio(index:uint):Number | CascadeShadowMapper
 | hasEventListener(type:String):Boolean | CascadeShadowMapper
 | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void | CascadeShadowMapper
 | setSplitRatio(index:uint, value:Number):void | CascadeShadowMapper
Inherited | updateShadows():void | ShadowMapperBase
 | willTrigger(type:String):Boolean | CascadeShadowMapper
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createCasterCollector():ShadowCasterCollector | ShadowMapperBase
Inherited | createDepthTexture():TextureProxyBase | ShadowMapperBase
 | drawDepthMap(target:TextureBase, scene:Scene3D, renderer:DepthRenderer):void [override] | CascadeShadowMapper
 | updateDepthProjection(viewCamera:Camera3D):void [override] | CascadeShadowMapper
Property Detail
_scissorRects property
protected var _scissorRects:Vector.<Rectangle>

depthMapSize property
depthMapSize:uint[override]

Implementation
    public function get depthMapSize():uint
    public function set depthMapSize(value:uint):void
lightOffset property
lightOffset:Number

Implementation
    public function get lightOffset():Number
    public function set lightOffset(value:Number):void
nearPlaneDistances property
nearPlaneDistances:Vector.<Number> [read-only]

Implementation
    arcane function get nearPlaneDistances():Vector.<Number>
numCascades property
numCascades:int

Implementation
    public function get numCascades():int
    public function set numCascades(value:int):void
Constructor Detail
CascadeShadowMapper () Constructor
public function CascadeShadowMapper(numCascades:uint = 3)

Parameters
numCascades:uint (default = 3)
Method Detail
addEventListener () method
public function addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void

Parameters

type:String
listener:Function
useCapture:Boolean (default = false)
priority:int (default = 0)
useWeakReference:Boolean (default = false)

dispatchEvent () method
public function dispatchEvent(event:Event):Boolean

Parameters

event:Event

Returns
Boolean
drawDepthMap () method
override protected function drawDepthMap(target:TextureBase, scene:Scene3D, renderer:DepthRenderer):void

Parameters

target:TextureBase
scene:Scene3D
renderer:DepthRenderer

getDepthProjections () method
public function getDepthProjections(partition:uint):Matrix3D

Parameters

partition:uint

Returns
Matrix3D
getSplitRatio () method
public function getSplitRatio(index:uint):Number

Parameters

index:uint

Returns
Number
hasEventListener () method
public function hasEventListener(type:String):Boolean

Parameters

type:String

Returns
Boolean
removeEventListener () method
public function removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void

Parameters

type:String
listener:Function
useCapture:Boolean (default = false)

setSplitRatio () method
public function setSplitRatio(index:uint, value:Number):void

Parameters

index:uint
value:Number

updateDepthProjection () method
override protected function updateDepthProjection(viewCamera:Camera3D):void

Parameters

viewCamera:Camera3D

willTrigger () method
public function willTrigger(type:String):Boolean

Parameters

type:String

Returns
Boolean


away3d.lights.shadowmaps.CubeMapShadowMapper

CubeMapShadowMapper | Properties | Methods
Package | away3d.lights.shadowmaps
Class | public class CubeMapShadowMapper
Inheritance | CubeMapShadowMapper Inheritance ShadowMapperBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | autoUpdateShadows : Boolean | ShadowMapperBase
Inherited | depthMap : TextureProxyBase [read-only] | ShadowMapperBase
Inherited | depthMapSize : uint | ShadowMapperBase
Inherited | light : LightBase | ShadowMapperBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _casterCollector : ShadowCasterCollector | ShadowMapperBase
Inherited | _depthMapSize : uint = 2048 | ShadowMapperBase
Inherited | _light : LightBase | ShadowMapperBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CubeMapShadowMapper() | CubeMapShadowMapper
Inherited | dispose():void | ShadowMapperBase
Inherited | updateShadows():void | ShadowMapperBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createCasterCollector():ShadowCasterCollector | ShadowMapperBase
 | createDepthTexture():TextureProxyBase [override] | CubeMapShadowMapper
 | drawDepthMap(target:TextureBase, scene:Scene3D, renderer:DepthRenderer):void [override] | CubeMapShadowMapper
 | updateDepthProjection(viewCamera:Camera3D):void [override] | CubeMapShadowMapper
Constructor Detail
CubeMapShadowMapper () Constructor
public function CubeMapShadowMapper()

Method Detail
createDepthTexture () method
override protected function createDepthTexture():TextureProxyBase

Returns
TextureProxyBase
drawDepthMap () method
override protected function drawDepthMap(target:TextureBase, scene:Scene3D, renderer:DepthRenderer):void

Parameters

target:TextureBase
scene:Scene3D
renderer:DepthRenderer

updateDepthProjection () method
override protected function updateDepthProjection(viewCamera:Camera3D):void

Parameters

viewCamera:Camera3D


away3d.lights.shadowmaps.DirectionalShadowMapper

DirectionalShadowMapper | Properties | Methods
Package | away3d.lights.shadowmaps
Class | public class DirectionalShadowMapper
Inheritance | DirectionalShadowMapper Inheritance ShadowMapperBase Inheritance Object
Subclasses | NearDirectionalShadowMapper

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | autoUpdateShadows : Boolean | ShadowMapperBase
Inherited | depthMap : TextureProxyBase [read-only] | ShadowMapperBase
Inherited | depthMapSize : uint | ShadowMapperBase
Inherited | light : LightBase | ShadowMapperBase
 | lightOffset : Number | DirectionalShadowMapper
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _casterCollector : ShadowCasterCollector | ShadowMapperBase
 | _depthCamera : Camera3D | DirectionalShadowMapper
 | _depthLens : FreeMatrixLens | DirectionalShadowMapper
Inherited | _depthMapSize : uint = 2048 | ShadowMapperBase
Inherited | _light : LightBase | ShadowMapperBase
 | _lightOffset : Number = 10000 | DirectionalShadowMapper
 | _localFrustum : Vector.<Number> | DirectionalShadowMapper
 | _matrix : Matrix3D | DirectionalShadowMapper
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DirectionalShadowMapper() | DirectionalShadowMapper
Inherited | dispose():void | ShadowMapperBase
Inherited | updateShadows():void | ShadowMapperBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createCasterCollector():ShadowCasterCollector | ShadowMapperBase
Inherited | createDepthTexture():TextureProxyBase | ShadowMapperBase
 | drawDepthMap(target:TextureBase, scene:Scene3D, renderer:DepthRenderer):void [override] | DirectionalShadowMapper
 | updateDepthProjection(viewCamera:Camera3D):void [override] | DirectionalShadowMapper
 | updateProjectionFromFrustumCorners(viewCamera:Camera3D, corners:Vector.<Number>, matrix:Matrix3D):void | DirectionalShadowMapper
Property Detail
_depthCamera property
protected var _depthCamera:Camera3D

_depthLens property
protected var _depthLens:FreeMatrixLens

_lightOffset property
protected var _lightOffset:Number = 10000

_localFrustum property
protected var _localFrustum:Vector.<Number>

_matrix property
protected var _matrix:Matrix3D

depthProjection property
depthProjection:Matrix3D [read-only]

Depth projection matrix that projects from scene space to depth map.

Implementation
    arcane function get depthProjection():Matrix3D
lightOffset property
lightOffset:Number

Implementation
    public function get lightOffset():Number
    public function set lightOffset(value:Number):void
Constructor Detail
DirectionalShadowMapper () Constructor
public function DirectionalShadowMapper()

Method Detail
drawDepthMap () method
override protected function drawDepthMap(target:TextureBase, scene:Scene3D, renderer:DepthRenderer):void

Parameters

target:TextureBase
scene:Scene3D
renderer:DepthRenderer

updateDepthProjection () method
override protected function updateDepthProjection(viewCamera:Camera3D):void

Parameters

viewCamera:Camera3D

updateProjectionFromFrustumCorners () method
protected function updateProjectionFromFrustumCorners(viewCamera:Camera3D, corners:Vector.<Number>, matrix:Matrix3D):void

Parameters

viewCamera:Camera3D
corners:Vector.<Number>
matrix:Matrix3D


away3d.lights.shadowmaps.NearDirectionalShadowMapper

NearDirectionalShadowMapper | Properties | Methods
Package | away3d.lights.shadowmaps
Class | public class NearDirectionalShadowMapper
Inheritance | NearDirectionalShadowMapper Inheritance DirectionalShadowMapper Inheritance ShadowMapperBase Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | autoUpdateShadows : Boolean | ShadowMapperBase
 | coverageRatio : Number A value between 0 and 1 to indicate the ratio of the view frustum that needs to be covered by the shadow map. | NearDirectionalShadowMapper
Inherited | depthMap : TextureProxyBase [read-only] | ShadowMapperBase
Inherited | depthMapSize : uint | ShadowMapperBase
Inherited | light : LightBase | ShadowMapperBase
Inherited | lightOffset : Number | DirectionalShadowMapper
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _casterCollector : ShadowCasterCollector | ShadowMapperBase
Inherited | _depthCamera : Camera3D | DirectionalShadowMapper
Inherited | _depthLens : FreeMatrixLens | DirectionalShadowMapper
Inherited | _depthMapSize : uint = 2048 | ShadowMapperBase
Inherited | _light : LightBase | ShadowMapperBase
Inherited | _lightOffset : Number = 10000 | DirectionalShadowMapper
Inherited | _localFrustum : Vector.<Number> | DirectionalShadowMapper
Inherited | _matrix : Matrix3D | DirectionalShadowMapper
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | NearDirectionalShadowMapper(coverageRatio:Number = .5) | NearDirectionalShadowMapper
Inherited | dispose():void | ShadowMapperBase
Inherited | updateShadows():void | ShadowMapperBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createCasterCollector():ShadowCasterCollector | ShadowMapperBase
Inherited | createDepthTexture():TextureProxyBase | ShadowMapperBase
Inherited | drawDepthMap(target:TextureBase, scene:Scene3D, renderer:DepthRenderer):void [override] | DirectionalShadowMapper
 | updateDepthProjection(viewCamera:Camera3D):void [override] | NearDirectionalShadowMapper
Inherited | updateProjectionFromFrustumCorners(viewCamera:Camera3D, corners:Vector.<Number>, matrix:Matrix3D):void | DirectionalShadowMapper
Property Detail
coverageRatio property
coverageRatio:Number

A value between 0 and 1 to indicate the ratio of the view frustum that needs to be covered by the shadow map.

Implementation
    public function get coverageRatio():Number
    public function set coverageRatio(value:Number):void
Constructor Detail
NearDirectionalShadowMapper () Constructor
public function NearDirectionalShadowMapper(coverageRatio:Number = .5)

Parameters
coverageRatio:Number (default = .5)
Method Detail
updateDepthProjection () method
override protected function updateDepthProjection(viewCamera:Camera3D):void

Parameters

viewCamera:Camera3D


away3d.lights.shadowmaps.ShadowMapperBase

ShadowMapperBase | Properties | Methods
Package | away3d.lights.shadowmaps
Class | public class ShadowMapperBase
Inheritance | ShadowMapperBase Inheritance Object
Subclasses | CascadeShadowMapper, CubeMapShadowMapper, DirectionalShadowMapper

Public Properties
Property |  | Defined By
 | autoUpdateShadows : Boolean | ShadowMapperBase
 | depthMap : TextureProxyBase [read-only] | ShadowMapperBase
 | depthMapSize : uint | ShadowMapperBase
 | light : LightBase | ShadowMapperBase
Protected Properties
Property |  | Defined By
 | _casterCollector : ShadowCasterCollector | ShadowMapperBase
 | _depthMapSize : uint = 2048 | ShadowMapperBase
 | _light : LightBase | ShadowMapperBase
Public Methods
Method |  | Defined By
 | ShadowMapperBase() | ShadowMapperBase
 | dispose():void | ShadowMapperBase
 | updateShadows():void | ShadowMapperBase
Protected Methods
Method |  | Defined By
 | createCasterCollector():ShadowCasterCollector | ShadowMapperBase
 | createDepthTexture():TextureProxyBase | ShadowMapperBase
 | drawDepthMap(target:TextureBase, scene:Scene3D, renderer:DepthRenderer):void | ShadowMapperBase
 | updateDepthProjection(viewCamera:Camera3D):void | ShadowMapperBase
Property Detail
_casterCollector property
protected var _casterCollector:ShadowCasterCollector

_depthMapSize property
protected var _depthMapSize:uint = 2048

_light property
protected var _light:LightBase

_shadowsInvalid property
arcane var _shadowsInvalid:Boolean

autoUpdateShadows property
autoUpdateShadows:Boolean

Implementation
    public function get autoUpdateShadows():Boolean
    public function set autoUpdateShadows(value:Boolean):void
depthMap property
depthMap:TextureProxyBase [read-only]

Implementation
    public function get depthMap():TextureProxyBase
depthMapSize property
depthMapSize:uint

Implementation
    public function get depthMapSize():uint
    public function set depthMapSize(value:uint):void
light property
light:LightBase

Implementation
    public function get light():LightBase
    public function set light(value:LightBase):void
Constructor Detail
ShadowMapperBase () Constructor
public function ShadowMapperBase()

Method Detail
createCasterCollector () method
protected function createCasterCollector():ShadowCasterCollector

Returns
ShadowCasterCollector
createDepthTexture () method
protected function createDepthTexture():TextureProxyBase

Returns
TextureProxyBase
dispose () method
public function dispose():void

drawDepthMap () method
protected function drawDepthMap(target:TextureBase, scene:Scene3D, renderer:DepthRenderer):void

Parameters

target:TextureBase
scene:Scene3D
renderer:DepthRenderer

renderDepthMap () method
arcane function renderDepthMap(stage3DProxy:Stage3DProxy, entityCollector:EntityCollector, renderer:DepthRenderer):void

Renders the depth map for this light.

Parameters

stage3DProxy:Stage3DProxy — The EntityCollector that contains the original scene data.
entityCollector:EntityCollector — The DepthRenderer to render the depth map.
renderer:DepthRenderer

setDepthMap () method
arcane function setDepthMap(depthMap:TextureProxyBase):void

This is used by renderers that can support depth maps to be shared across instances

Parameters

depthMap:TextureProxyBase

updateDepthProjection () method
protected function updateDepthProjection(viewCamera:Camera3D):void

Parameters

viewCamera:Camera3D

updateShadows () method
public function updateShadows():void


away3d.loaders - Away3D Documentation

Package away3d.loaders

Classes
AssetLoader
Loader3D


away3d.loaders Summary

away3d.loaders | Classes

Classes
Class | Description
AssetLoader | AssetLoader can load any file format that Away3D supports (or for which a third-party parser has been plugged in) and it's dependencies.
Loader3D | Loader3D can load any file format that Away3D supports (or for which a third-party parser has been plugged in) and be added directly to the scene.

Thu Nov 15 2012, 12:09 PM Z


away3d.loaders.AssetLoader

AssetLoader | Methods | Events
Package | away3d.loaders
Class | public class AssetLoader
Inheritance | AssetLoader Inheritance flash.events.EventDispatcher

AssetLoader can load any file format that Away3D supports (or for which a third-party parser has been plugged in) and it's dependencies. Events are dispatched when assets are encountered and for when the resource (or it's dependencies) have been loaded. The AssetLoader will not make assets available in any other way than through the dispatched events. To store assets and make them available at any point from any module in an application, use the AssetLibrary to load and manage assets.

See also

away3d.loading.Loader3D
away3d.loading.AssetLibrary

Public Methods
Method |  | Defined By
 | AssetLoader() Create a new ResourceLoadSession object. | AssetLoader
 | enableParser(parserClass:Class):void [static] | AssetLoader
 | enableParsers(parserClasses:Vector.<Class>):void [static] | AssetLoader
 | load(req:URLRequest, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken Loads a file and (optionally) all of its dependencies. | AssetLoader
 | loadData(data:*, id:String, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken Loads a resource from already loaded data. | AssetLoader
Events
Event |  | Summary | Defined By
 | animationNodeComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | AssetLoader
 | animationSetComplete | Dispatched when an animation node has been constructed from a resource. | AssetLoader
 | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | AssetLoader
 | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | AssetLoader
 | assetComplete | Dispatched when any asset finishes parsing. | AssetLoader
 | containerComplete | Dispatched when a container asset has been constructed from a resource. | AssetLoader
 | dependencyComplete | Dispatched when a single dependency (which may be the main file of a resource) finishes loading. | AssetLoader
 | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | AssetLoader
 | loadError | Dispatched when an error occurs during loading. | AssetLoader
 | materialComplete | Dispatched when a material asset has been constructed from a resource. | AssetLoader
 | resourceComplete | Dispatched when a full resource (including dependencies) finishes loading. | AssetLoader
 | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | AssetLoader
 | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | AssetLoader
 | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | AssetLoader
 | textureComplete | Dispatched when a texture asset has been constructed from a resource. | AssetLoader
Constructor Detail
AssetLoader () Constructor
public function AssetLoader()

Create a new ResourceLoadSession object.

Method Detail
enableParser () method
public static function enableParser(parserClass:Class):void

Parameters

parserClass:Class

enableParsers () method
public static function enableParsers(parserClasses:Vector.<Class>):void

Parameters

parserClasses:Vector.<Class>

load () method
public function load(req:URLRequest, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken

Loads a file and (optionally) all of its dependencies.

Parameters

req:URLRequest — The URLRequest object containing the URL of the file to be loaded.
context:AssetLoaderContext (default = null) — An optional context object providing additional parameters for loading
ns:String (default = null) — An optional namespace string under which the file is to be loaded, allowing the differentiation of two resources with identical assets
parser:ParserBase (default = null) — An optional parser object for translating the loaded data into a usable resource. If not provided, AssetLoader will attempt to auto-detect the file type.

Returns
AssetLoaderToken
loadData () method
public function loadData(data:*, id:String, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken

Loads a resource from already loaded data.

Parameters

data:* — The data object containing all resource information.
id:String — An optional context object providing additional parameters for loading
context:AssetLoaderContext (default = null) — An optional namespace string under which the file is to be loaded, allowing the differentiation of two resources with identical assets
ns:String (default = null) — An optional parser object for translating the loaded data into a usable resource. If not provided, AssetLoader will attempt to auto-detect the file type.
parser:ParserBase (default = null)

Returns
AssetLoaderToken
Event Detail
animationNodeComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation set has been constructed from a group of animation state resources.

animationSetComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation node has been constructed from a resource.

animationStateComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation state has been constructed from a group of animation node resources.

animatorComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a animator asset has been constructed from a resource.

assetComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when any asset finishes parsing. Also see specific events for each individual asset type (meshes, materials et c.)

containerComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a container asset has been constructed from a resource.

dependencyComplete Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when a single dependency (which may be the main file of a resource) finishes loading.

geometryComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a geometry asset has been constructed from a resource.

loadError Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when an error occurs during loading.

materialComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a material asset has been constructed from a resource.

resourceComplete Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when a full resource (including dependencies) finishes loading.

skeletonComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a skeleton asset has been constructed from a resource.

skeletonPoseComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a skeleton pose asset has been constructed from a resource.

stateTransitionComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation state transition has been constructed from a group of animation node resources.

textureComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a texture asset has been constructed from a resource.


away3d.loaders.Loader3D

Loader3D | Properties | Methods | Events | Constants
Package | away3d.loaders
Class | public class Loader3D
Inheritance | Loader3D Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Loader3D can load any file format that Away3D supports (or for which a third-party parser has been plugged in) and be added directly to the scene. As assets are encountered they are added to the Loader3D container. Assets that can not be displayed in the scene graph (e.g. unused bitmaps/materials, skeletons et c) will be ignored. This provides a fast and easy way to load models (no need for event listeners) but is not very versatile since many types of assets are ignored. Loader3D by default uses the AssetLibrary to load all assets, which means that they also ends up in the library. To circumvent this, Loader3D can be configured to not use the AssetLibrary in which case it will use the AssetLoader directly.

See also

away3d.loading.AssetLoader
away3d.loading.AssetLibrary

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | ObjectContainer3D
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean Does not apply any transformations to this object. | ObjectContainer3D
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | maxX : Number [read-only] The maximum extremum of the object along the X-axis. | ObjectContainer3D
Inherited | maxY : Number [read-only] The maximum extremum of the object along the Y-axis. | ObjectContainer3D
Inherited | maxZ : Number [read-only] The maximum extremum of the object along the Z-axis. | ObjectContainer3D
Inherited | minX : Number [read-only] The minimum extremum of the object along the X-axis. | ObjectContainer3D
Inherited | minY : Number [read-only] The minimum extremum of the object along the Y-axis. | ObjectContainer3D
Inherited | minZ : Number [read-only] The minimum extremum of the object along the Z-axis. | ObjectContainer3D
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D A reference to the Scene3D object to which this object belongs. | ObjectContainer3D
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Loader3D(useAssetLibrary:Boolean = true, assetLibraryId:String = null) | Loader3D
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | ObjectContainer3D
Inherited | disposeAsset():void | Object3D
 | enableParser(parserClass:Class):void [static] | Loader3D
 | enableParsers(parserClasses:Vector.<Class>):void [static] | Loader3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
 | load(req:URLRequest, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken Loads a file and (optionally) all of its dependencies. | Loader3D
 | loadData(data:*, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken Loads a resource from already loaded data. | Loader3D
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | invalidateSceneTransform():void Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | ObjectContainer3D
Inherited | updateMouseChildren():void | ObjectContainer3D
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
 | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | Loader3D
 | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | Loader3D
 | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | Loader3D
 | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | Loader3D
 | assetComplete | Dispatched when any asset finishes parsing. | Loader3D
 | containerComplete | Dispatched when a container asset has been constructed from a resource. | Loader3D
 | dependencyComplete | Dispatched when a single dependency (which may be the main file of a resource) finishes loading. | Loader3D
 | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | Loader3D
 | loadError | Dispatched when an error occurs during loading. | Loader3D
 | materialComplete | Dispatched when a material asset has been constructed from a resource. | Loader3D
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
 | resourceComplete | Dispatched when a full resource (including dependencies) finishes loading. | Loader3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
 | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | Loader3D
 | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | Loader3D
 | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | Loader3D
 | textureComplete | Dispatched when a texture asset has been constructed from a resource. | Loader3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
Loader3D () Constructor
public function Loader3D(useAssetLibrary:Boolean = true, assetLibraryId:String = null)

Parameters
useAssetLibrary:Boolean (default = true)
assetLibraryId:String (default = null)
Method Detail
enableParser () method
public static function enableParser(parserClass:Class):void

Parameters

parserClass:Class

enableParsers () method
public static function enableParsers(parserClasses:Vector.<Class>):void

Parameters

parserClasses:Vector.<Class>

load () method
public function load(req:URLRequest, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken

Loads a file and (optionally) all of its dependencies.

Parameters

req:URLRequest — The URLRequest object containing the URL of the file to be loaded.
context:AssetLoaderContext (default = null) — An optional context object providing additional parameters for loading
ns:String (default = null) — An optional namespace string under which the file is to be loaded, allowing the differentiation of two resources with identical assets
parser:ParserBase (default = null) — An optional parser object for translating the loaded data into a usable resource. If not provided, AssetLoader will attempt to auto-detect the file type.

Returns
AssetLoaderToken
loadData () method
public function loadData(data:*, context:AssetLoaderContext = null, ns:String = null, parser:ParserBase = null):AssetLoaderToken

Loads a resource from already loaded data.

Parameters

data:* — The data object containing all resource information.
context:AssetLoaderContext (default = null) — An optional context object providing additional parameters for loading
ns:String (default = null) — An optional namespace string under which the file is to be loaded, allowing the differentiation of two resources with identical assets
parser:ParserBase (default = null) — An optional parser object for translating the loaded data into a usable resource. If not provided, AssetLoader will attempt to auto-detect the file type.

Returns
AssetLoaderToken
Event Detail
animationNodeComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation node has been constructed from a resource.

animationSetComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation set has been constructed from a group of animation state resources.

animationStateComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation state has been constructed from a group of animation node resources.

animatorComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a animator asset has been constructed from a resource.

assetComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when any asset finishes parsing. Also see specific events for each individual asset type (meshes, materials et c.)

containerComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a container asset has been constructed from a resource.

dependencyComplete Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when a single dependency (which may be the main file of a resource) finishes loading.

geometryComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a geometry asset has been constructed from a resource.

loadError Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when an error occurs during loading.

materialComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a material asset has been constructed from a resource.

resourceComplete Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when a full resource (including dependencies) finishes loading.

skeletonComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a skeleton asset has been constructed from a resource.

skeletonPoseComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a skeleton pose asset has been constructed from a resource.

stateTransitionComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation state transition has been constructed from a group of animation node resources.

textureComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a texture asset has been constructed from a resource.


away3d.loaders.misc - Away3D Documentation

Package away3d.loaders.misc

Classes
AssetLoaderContext
AssetLoaderToken
ResourceDependency
SingleFileLoader


away3d.loaders.misc Summary

away3d.loaders.misc | Classes

Classes
Class | Description
AssetLoaderContext |
AssetLoaderToken | Instances of this class are returned as tokens by loading operations to provide an object on which events can be listened for in cases where the actual asset loader is not directly available (e.g.
ResourceDependency | ResourceDependency represents the data required to load, parse and resolve additional files ("dependencies") required by a parser, used by ResourceLoadSession.
SingleFileLoader | The SingleFileLoader is used to load a single file, as part of a resource.

Thu Nov 15 2012, 12:09 PM Z


away3d.loaders.misc.AssetLoaderContext

AssetLoaderContext | Properties | Methods
Package | away3d.loaders.misc
Class | public class AssetLoaderContext
Inheritance | AssetLoaderContext Inheritance Object

Public Properties
Property |  | Defined By
 | dependencyBaseUrl : String A base URL that will be prepended to all relative dependency URLs found in a loaded resource. | AssetLoaderContext
 | includeDependencies : Boolean Defines whether dependencies (all files except the one at the URL given to the load() or parseData() operations) should be automatically loaded. | AssetLoaderContext
 | overrideAbsolutePaths : Boolean Defines whether absolute paths (defined as paths that begin with a "/") should be overridden with the dependencyBaseUrl defined in this context. | AssetLoaderContext
 | overrideFullURLs : Boolean Defines whether "full" URLs (defined as a URL that includes a scheme, e.g. | AssetLoaderContext
Public Methods
Method |  | Defined By
 | AssetLoaderContext(includeDependencies:Boolean = true, dependencyBaseUrl:String = null) AssetLoaderContext provides configuration for the AssetLoader load() and parse() operations. | AssetLoaderContext
 | mapUrl(originalUrl:String, newUrl:String):void Map a URL to another URL, so that files that are referred to by the original URL will instead be loaded from the new URL. | AssetLoaderContext
 | mapUrlToData(originalUrl:String, data:*):void Map a URL to embedded data, so that instead of trying to load a dependency from the URL at which it's referenced, the dependency data will be retrieved straight from the memory instead. | AssetLoaderContext
Property Detail
dependencyBaseUrl property
dependencyBaseUrl:String

A base URL that will be prepended to all relative dependency URLs found in a loaded resource. Absolute paths will not be affected by the value of this property.

Implementation
    public function get dependencyBaseUrl():String
    public function set dependencyBaseUrl(value:String):void
includeDependencies property
includeDependencies:Boolean

Defines whether dependencies (all files except the one at the URL given to the load() or parseData() operations) should be automatically loaded. Defaults to true.

Implementation
    public function get includeDependencies():Boolean
    public function set includeDependencies(value:Boolean):void
overrideAbsolutePaths property
overrideAbsolutePaths:Boolean

Defines whether absolute paths (defined as paths that begin with a "/") should be overridden with the dependencyBaseUrl defined in this context. If this is true, and the base path is "base", /path/to/asset.jpg will be resolved as base/path/to/asset.jpg.

Implementation
    public function get overrideAbsolutePaths():Boolean
    public function set overrideAbsolutePaths(value:Boolean):void
overrideFullURLs property
overrideFullURLs:Boolean

Defines whether "full" URLs (defined as a URL that includes a scheme, e.g. http://) should be overridden with the dependencyBaseUrl defined in this context. If this is true, and the base path is "base", http://example.com/path/to/asset.jpg will be resolved as base/path/to/asset.jpg.

Implementation
    public function get overrideFullURLs():Boolean
    public function set overrideFullURLs(value:Boolean):void
Constructor Detail
AssetLoaderContext () Constructor
public function AssetLoaderContext(includeDependencies:Boolean = true, dependencyBaseUrl:String = null)

AssetLoaderContext provides configuration for the AssetLoader load() and parse() operations. Use it to configure how (and if) dependencies are loaded, or to map dependency URLs to embedded data.

Parameters
includeDependencies:Boolean (default = true)
dependencyBaseUrl:String (default = null)

See also

away3d.loading.AssetLoader
Method Detail
mapUrl () method
public function mapUrl(originalUrl:String, newUrl:String):void

Map a URL to another URL, so that files that are referred to by the original URL will instead be loaded from the new URL. Use this when your file structure does not match the one that is expected by the loaded file.

Parameters

originalUrl:String — The original URL which is referenced in the loaded resource.
newUrl:String — The URL from which Away3D should load the resource instead.

See also

mapUrlToData()
mapUrlToData () method
public function mapUrlToData(originalUrl:String, data:*):void

Map a URL to embedded data, so that instead of trying to load a dependency from the URL at which it's referenced, the dependency data will be retrieved straight from the memory instead.

Parameters

originalUrl:String — The original URL which is referenced in the loaded resource.
data:* — The embedded data. Can be ByteArray or a class which can be used to create a bytearray.


away3d.loaders.misc.AssetLoaderToken

AssetLoaderToken | Properties | Methods | Events
Package | away3d.loaders.misc
Class | public class AssetLoaderToken
Inheritance | AssetLoaderToken Inheritance flash.events.EventDispatcher

Instances of this class are returned as tokens by loading operations to provide an object on which events can be listened for in cases where the actual asset loader is not directly available (e.g. when using the AssetLibrary to perform the load.) By listening for events on this class instead of directly on the AssetLibrary, one can distinguish different loads from each other. The token will dispatch all events that the original AssetLoader dispatches, while not providing an interface to obstruct the load and is as such a safer return value for loader wrappers than the loader itself.

Public Methods
Method |  | Defined By
 | AssetLoaderToken(loader:AssetLoader) | AssetLoaderToken
 | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | AssetLoaderToken
 | hasEventListener(type:String):Boolean [override] | AssetLoaderToken
 | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | AssetLoaderToken
 | willTrigger(type:String):Boolean [override] | AssetLoaderToken
Events
Event |  | Summary | Defined By
 | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | AssetLoaderToken
 | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | AssetLoaderToken
 | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | AssetLoaderToken
 | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | AssetLoaderToken
 | assetComplete | Dispatched when any asset finishes parsing. | AssetLoaderToken
 | containerComplete | Dispatched when a container asset has been constructed from a resource. | AssetLoaderToken
 | dependencyComplete | Dispatched when a single dependency (which may be the main file of a resource) finishes loading. | AssetLoaderToken
 | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | AssetLoaderToken
 | loadError | Dispatched when an error occurs during loading. | AssetLoaderToken
 | materialComplete | Dispatched when a material asset has been constructed from a resource. | AssetLoaderToken
 | resourceComplete | Dispatched when a full resource (including dependencies) finishes loading. | AssetLoaderToken
 | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | AssetLoaderToken
 | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | AssetLoaderToken
 | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | AssetLoaderToken
 | textureComplete | Dispatched when a texture asset has been constructed from a resource. | AssetLoaderToken
Property Detail
_loader property
arcane var _loader:AssetLoader

Constructor Detail
AssetLoaderToken () Constructor
public function AssetLoaderToken(loader:AssetLoader)

Parameters
loader:AssetLoader
Method Detail
addEventListener () method
override public function addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void

Parameters

type:String
listener:Function
useCapture:Boolean (default = false)
priority:int (default = 0)
useWeakReference:Boolean (default = false)

hasEventListener () method
override public function hasEventListener(type:String):Boolean

Parameters

type:String

Returns
Boolean
removeEventListener () method
override public function removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void

Parameters

type:String
listener:Function
useCapture:Boolean (default = false)

willTrigger () method
override public function willTrigger(type:String):Boolean

Parameters

type:String

Returns
Boolean
Event Detail
animationNodeComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation node has been constructed from a resource.

animationSetComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation set has been constructed from a group of animation state resources.

animationStateComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation state has been constructed from a group of animation node resources.

animatorComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a animator asset has been constructed from a resource.

assetComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when any asset finishes parsing. Also see specific events for each individual asset type (meshes, materials et c.)

containerComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a container asset has been constructed from a resource.

dependencyComplete Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when a single dependency (which may be the main file of a resource) finishes loading.

geometryComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a geometry asset has been constructed from a resource.

loadError Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when an error occurs during loading.

materialComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a material asset has been constructed from a resource.

resourceComplete Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when a full resource (including dependencies) finishes loading.

skeletonComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a skeleton asset has been constructed from a resource.

skeletonPoseComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a skeleton pose asset has been constructed from a resource.

stateTransitionComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation state transition has been constructed from a group of animation node resources.

textureComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a texture asset has been constructed from a resource.


away3d.loaders.misc.ResourceDependency

ResourceDependency | Properties | Methods
Package | away3d.loaders.misc
Class | public class ResourceDependency
Inheritance | ResourceDependency Inheritance Object

ResourceDependency represents the data required to load, parse and resolve additional files ("dependencies") required by a parser, used by ResourceLoadSession.

Public Properties
Property |  | Defined By
 | assets : Vector.<IAsset> [read-only] | ResourceDependency
 | data : * [read-only] The data containing the dependency to be parsed, if the resource was already loaded. | ResourceDependency
 | dependencies : Vector.<ResourceDependency> [read-only] | ResourceDependency
 | id : String [read-only] | ResourceDependency
 | parentParser : ParserBase [read-only] The parser which is dependent on this ResourceDependency object. | ResourceDependency
 | request : URLRequest [read-only] | ResourceDependency
 | retrieveAsRawData : Boolean [read-only] | ResourceDependency
 | suppresAssetEvents : Boolean [read-only] | ResourceDependency
Public Methods
Method |  | Defined By
 | ResourceDependency(id:String, req:URLRequest, data:*, parentParser:ParserBase, retrieveAsRawData:Boolean = false, suppressAssetEvents:Boolean = false) | ResourceDependency
 | resolve():void Resolve the dependency when it's loaded with the parent parser. | ResourceDependency
 | resolveFailure():void Resolve a dependency failure. | ResourceDependency
Property Detail
assets property
assets:Vector.<IAsset> [read-only]

Implementation
    public function get assets():Vector.<IAsset>
data property
data:* [read-only]

The data containing the dependency to be parsed, if the resource was already loaded.

Implementation
    public function get data():*
dependencies property
dependencies:Vector.<ResourceDependency> [read-only]

Implementation
    public function get dependencies():Vector.<ResourceDependency>
id property
id:String [read-only]

Implementation
    public function get id():String
loader property
arcane var loader:SingleFileLoader

parentParser property
parentParser:ParserBase [read-only]

The parser which is dependent on this ResourceDependency object.

Implementation
    public function get parentParser():ParserBase
request property
request:URLRequest [read-only]

Implementation
    public function get request():URLRequest
retrieveAsRawData property
retrieveAsRawData:Boolean [read-only]

Implementation
    public function get retrieveAsRawData():Boolean
success property
arcane var success:Boolean

suppresAssetEvents property
suppresAssetEvents:Boolean [read-only]

Implementation
    public function get suppresAssetEvents():Boolean
Constructor Detail
ResourceDependency () Constructor
public function ResourceDependency(id:String, req:URLRequest, data:*, parentParser:ParserBase, retrieveAsRawData:Boolean = false, suppressAssetEvents:Boolean = false)

Parameters
id:String
req:URLRequest
data:*
parentParser:ParserBase
retrieveAsRawData:Boolean (default = false)
suppressAssetEvents:Boolean (default = false)
Method Detail
resolve () method
public function resolve():void

Resolve the dependency when it's loaded with the parent parser. For example, a dependency containing an ImageResource would be assigned to a Mesh instance as a BitmapMaterial, a scene graph object would be added to its intended parent. The dependency should be a member of the dependencies property.

resolveFailure () method
public function resolveFailure():void

Resolve a dependency failure. For example, map loading failure from a 3d file


away3d.loaders.misc.SingleFileLoader

SingleFileLoader | Properties | Methods | Events
Package | away3d.loaders.misc
Class | public class SingleFileLoader
Inheritance | SingleFileLoader Inheritance flash.events.EventDispatcher

The SingleFileLoader is used to load a single file, as part of a resource. While SingleFileLoader can be used directly, e.g. to create a third-party asset management system, it's recommended to use any of the classes Loader3D, AssetLoader and AssetLibrary instead in most cases.

See also

away3d.loading.Loader3D
away3d.loading.AssetLoader
away3d.loading.AssetLibrary

Public Properties
Property |  | Defined By
 | data : * [read-only] | SingleFileLoader
 | dependencies : Vector.<ResourceDependency> [read-only] A list of dependencies that need to be loaded and resolved for the loaded object. | SingleFileLoader
 | loadAsRawData : Boolean [read-only] | SingleFileLoader
 | parser : ParserBase [read-only] A reference to the parser that will translate the loaded data into a usable resource. | SingleFileLoader
 | url : String [read-only] | SingleFileLoader
Public Methods
Method |  | Defined By
 | SingleFileLoader() Creates a new SingleFileLoader object. | SingleFileLoader
 | enableParser(parser:Class):void [static] | SingleFileLoader
 | enableParsers(parsers:Vector.<Class>):void [static] | SingleFileLoader
 | load(urlRequest:URLRequest, parser:ParserBase = null, loadAsRawData:Boolean = false):void Load a resource from a file. | SingleFileLoader
 | parseData(data:*, parser:ParserBase = null, req:URLRequest = null):void Loads a resource from already loaded data. | SingleFileLoader
Events
Event |  | Summary | Defined By
 | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | SingleFileLoader
 | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | SingleFileLoader
 | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | SingleFileLoader
 | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | SingleFileLoader
 | assetComplete | Dispatched when any asset finishes parsing. | SingleFileLoader
 | containerComplete | Dispatched when a container asset has been constructed from a resource. | SingleFileLoader
 | dependencyComplete | Dispatched when the dependency that this single-file loader was loading complets. | SingleFileLoader
 | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | SingleFileLoader
 | loadError | Dispatched when an error occurs during loading. | SingleFileLoader
 | materialComplete | Dispatched when a material asset has been constructed from a resource. | SingleFileLoader
 | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | SingleFileLoader
 | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | SingleFileLoader
 | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | SingleFileLoader
 | textureComplete | Dispatched when a texture asset has been constructed from a resource. | SingleFileLoader
Property Detail
data property
data:* [read-only]

Implementation
    public function get data():*
dependencies property
dependencies:Vector.<ResourceDependency> [read-only]

A list of dependencies that need to be loaded and resolved for the loaded object.

Implementation
    public function get dependencies():Vector.<ResourceDependency>
loadAsRawData property
loadAsRawData:Boolean [read-only]

Implementation
    public function get loadAsRawData():Boolean
parser property
parser:ParserBase [read-only]

A reference to the parser that will translate the loaded data into a usable resource.

Implementation
    public function get parser():ParserBase
url property
url:String [read-only]

Implementation
    public function get url():String
Constructor Detail
SingleFileLoader () Constructor
public function SingleFileLoader()

Creates a new SingleFileLoader object.

Method Detail
enableParser () method
public static function enableParser(parser:Class):void

Parameters

parser:Class

enableParsers () method
public static function enableParsers(parsers:Vector.<Class>):void

Parameters

parsers:Vector.<Class>

load () method
public function load(urlRequest:URLRequest, parser:ParserBase = null, loadAsRawData:Boolean = false):void

Load a resource from a file.

Parameters

urlRequest:URLRequest — The URLRequest object containing the URL of the object to be loaded.
parser:ParserBase (default = null) — An optional parser object that will translate the loaded data into a usable resource. If not provided, AssetLoader will attempt to auto-detect the file type.
loadAsRawData:Boolean (default = false)

parseData () method
public function parseData(data:*, parser:ParserBase = null, req:URLRequest = null):void

Loads a resource from already loaded data.

Parameters

data:* — The data to be parsed. Depending on the parser type, this can be a ByteArray, String or XML.
parser:ParserBase (default = null) — The identifier (url or id) of the object to be loaded, mainly used for resource management.
req:URLRequest (default = null) — An optional parser object that will translate the data into a usable resource. If not provided, AssetLoader will attempt to auto-detect the file type.

Event Detail
animationNodeComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation node has been constructed from a resource.

animationSetComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation set has been constructed from a group of animation state resources.

animationStateComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation state has been constructed from a group of animation node resources.

animatorComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a animator asset has been constructed from a resource.

assetComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when any asset finishes parsing. Also see specific events for each individual asset type (meshes, materials et c.)

containerComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a container asset has been constructed from a resource.

dependencyComplete Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when the dependency that this single-file loader was loading complets.

geometryComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a geometry asset has been constructed from a resource.

loadError Event
Event Object Type: away3d.events.LoaderEvent
LoaderEvent.type property = away3d.events.LoaderEvent

Dispatched when an error occurs during loading.

materialComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a material asset has been constructed from a resource.

skeletonComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a skeleton asset has been constructed from a resource.

skeletonPoseComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a skeleton pose asset has been constructed from a resource.

stateTransitionComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation state transition has been constructed from a group of animation node resources.

textureComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a texture asset has been constructed from a resource.


away3d.loaders.parsers - Away3D Documentation

Package away3d.loaders.parsers

Classes
AC3DParser
AWD1Parser
AWD2Parser
AWDParser
DAEParser
DXFParser
ImageParser
Max3DSParser
MD2Parser
MD5AnimParser
MD5MeshParser
OBJParser
ParserBase
ParserDataFormat
Parsers


away3d.loaders.parsers Summary

away3d.loaders.parsers | Classes

Classes
Class | Description
AC3DParser | AC3DParser provides a parser for the AC3D data type.
AWD1Parser | AWD1Parser provides a parser for the AWD data type.
AWD2Parser | AWDParser provides a parser for the AWD data type.
AWDParser | The AWDParser class is a wrapper for both AWD1Parser and AWD2Parser, and will find the right concrete parser for an AWD file.
DAEParser | DAEParser provides a parser for the DAE data type.
DXFParser | DXFParser provides a parser for the dxf 3D renderable data.
ImageParser | ImageParser provides a "parser" for natively supported image types (jpg, png).
Max3DSParser |
MD2Parser | MD2Parser provides a parser for the MD2 data type.
MD5AnimParser | AWDParser provides a parser for the AWD data type, providing an animation sequence for the md5 format.
MD5MeshParser | AWDParser provides a parser for the md5mesh data type, providing the geometry of the md5 format.
OBJParser | OBJParser provides a parser for the OBJ data type.
ParserBase | ParserBase provides an abstract base class for objects that convert blocks of data to data structures supported by Away3D.
ParserDataFormat | An enumeration providing values to describe the data format of parsed data.
Parsers |

Thu Nov 15 2012, 12:09 PM Z


away3d.loaders.parsers.AC3DParser

AC3DParser | Properties | Methods | Events
Package | away3d.loaders.parsers
Class | public class AC3DParser
Inheritance | AC3DParser Inheritance ParserBase Inheritance flash.events.EventDispatcher

AC3DParser provides a parser for the AC3D data type. unsupported tags: "numsurf","crease","texrep","refs lines of","url","data" and "numvert lines of":

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | dataFormat : String [read-only] The data format of the file data to be parsed. | ParserBase
Inherited | dependencies : Vector.<ResourceDependency> [read-only] A list of dependencies that need to be loaded and resolved for the object being parsed. | ParserBase
Inherited | parsingComplete : Boolean [read-only] | ParserBase
Inherited | parsingFailure : Boolean | ParserBase
Inherited | parsingPaused : Boolean [read-only] | ParserBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _data : * | ParserBase
Inherited | _dataFormat : String | ParserBase
Inherited | _frameLimit : Number | ParserBase
Inherited | _lastFrameTime : Number | ParserBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | AC3DParser() Creates a new AC3DParser object. | AC3DParser
Inherited | isBitmapDataValid(bitmapData:BitmapData):Boolean Validates a bitmapData loaded before assigning to a default BitmapMaterial | ParserBase
Inherited | parseAsync(data:*, frameLimit:Number = 30):void Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame. | ParserBase
 | supportsData(data:*):Boolean [static] Tests whether a data block can be parsed by the parser. | AC3DParser
 | supportsType(extension:String):Boolean [static] Indicates whether or not a given file extension is supported by the parser. | AC3DParser
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void | ParserBase
Inherited | dieWithError(message:String = Unknown parsing error):void | ParserBase
Inherited | finalizeAsset(asset:IAsset, name:String = null):void | ParserBase
Inherited | finishParsing():void Finish parsing the data. | ParserBase
Inherited | getByteData():ByteArray | ParserBase
Inherited | getTextData():String | ParserBase
Inherited | hasTime():Boolean Tests whether or not there is still time left for parsing within the maximum allowed time frame per session. | ParserBase
Inherited | onInterval(event:TimerEvent = null):void Called when the parsing pause interval has passed and parsing can proceed. | ParserBase
Inherited | pauseAndRetrieveDependencies():void | ParserBase
 | proceedParsing():Boolean [override] Parse the next block of data. | AC3DParser
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | ParserBase
Inherited | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | ParserBase
Inherited | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | ParserBase
Inherited | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | ParserBase
Inherited | assetComplete | Dispatched when any asset finishes parsing. | ParserBase
Inherited | containerComplete | Dispatched when a container asset has been constructed from a resource. | ParserBase
Inherited | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | ParserBase
Inherited | materialComplete | Dispatched when a material asset has been constructed from a resource. | ParserBase
Inherited | parseComplete | Dispatched when the parsing finishes. | ParserBase
Inherited | parseError | Dispatched if an error was caught during parsing. | ParserBase
Inherited | readyForDependencies | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace. | ParserBase
Inherited | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | ParserBase
Inherited | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | ParserBase
Inherited | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | ParserBase
Inherited | textureComplete | Dispatched when a texture asset has been constructed from a resource. | ParserBase
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | MORE_TO_PARSE : Boolean = false [static] Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing. | ParserBase
Inherited | PARSING_DONE : Boolean = true [static] Returned by proceedParsing to indicate no more parsing is needed. | ParserBase
Constructor Detail
AC3DParser () Constructor
public function AC3DParser()

Creates a new AC3DParser object.

Method Detail
proceedParsing () method
override protected function proceedParsing():Boolean

Parse the next block of data.

Returns
Boolean — Whether or not more data needs to be parsed. Can be ParserBase.PARSING_DONE or ParserBase.MORE_TO_PARSE.
resolveDependency () method
override arcane function resolveDependency(resourceDependency:ResourceDependency):void

Resolve a dependency when it's loaded. For example, a dependency containing an ImageResource would be assigned to a Mesh instance as a BitmapMaterial, a scene graph object would be added to its intended parent. The dependency should be a member of the dependencies property.

Parameters

resourceDependency:ResourceDependency — The dependency to be resolved.

resolveDependencyFailure () method
override arcane function resolveDependencyFailure(resourceDependency:ResourceDependency):void

Parameters

resourceDependency:ResourceDependency

supportsData () method
public static function supportsData(data:*):Boolean

Tests whether a data block can be parsed by the parser.

Parameters

data:* — The data block to potentially be parsed.

Returns
Boolean — Whether or not the given data is supported.
supportsType () method
public static function supportsType(extension:String):Boolean

Indicates whether or not a given file extension is supported by the parser.

Parameters

extension:String — The file extension of a potential file to be parsed.

Returns
Boolean — Whether or not the given file type is supported.


away3d.loaders.parsers.AWD1Parser

AWD1Parser | Properties | Methods | Events
Package | away3d.loaders.parsers
Class | public class AWD1Parser
Inheritance | AWD1Parser Inheritance ParserBase Inheritance flash.events.EventDispatcher

AWD1Parser provides a parser for the AWD data type. The version 1.0 in ascii. Usually generated by Prefab3D 1.x and Away3D engine exporters.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | dataFormat : String [read-only] The data format of the file data to be parsed. | ParserBase
Inherited | dependencies : Vector.<ResourceDependency> [read-only] A list of dependencies that need to be loaded and resolved for the object being parsed. | ParserBase
Inherited | parsingComplete : Boolean [read-only] | ParserBase
Inherited | parsingFailure : Boolean | ParserBase
Inherited | parsingPaused : Boolean [read-only] | ParserBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _data : * | ParserBase
Inherited | _dataFormat : String | ParserBase
Inherited | _frameLimit : Number | ParserBase
Inherited | _lastFrameTime : Number | ParserBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | AWD1Parser() Creates a new AWD1Parser object. | AWD1Parser
Inherited | isBitmapDataValid(bitmapData:BitmapData):Boolean Validates a bitmapData loaded before assigning to a default BitmapMaterial | ParserBase
Inherited | parseAsync(data:*, frameLimit:Number = 30):void Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame. | ParserBase
 | supportsData(data:*):Boolean [static] Tests whether a data block can be parsed by the parser. | AWD1Parser
 | supportsType(extension:String):Boolean [static] Indicates whether or not a given file extension is supported by the parser. | AWD1Parser
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void | ParserBase
Inherited | dieWithError(message:String = Unknown parsing error):void | ParserBase
Inherited | finalizeAsset(asset:IAsset, name:String = null):void | ParserBase
Inherited | finishParsing():void Finish parsing the data. | ParserBase
Inherited | getByteData():ByteArray | ParserBase
Inherited | getTextData():String | ParserBase
Inherited | hasTime():Boolean Tests whether or not there is still time left for parsing within the maximum allowed time frame per session. | ParserBase
Inherited | onInterval(event:TimerEvent = null):void Called when the parsing pause interval has passed and parsing can proceed. | ParserBase
Inherited | pauseAndRetrieveDependencies():void | ParserBase
 | proceedParsing():Boolean [override] Parse the next block of data. | AWD1Parser
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | ParserBase
Inherited | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | ParserBase
Inherited | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | ParserBase
Inherited | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | ParserBase
Inherited | assetComplete | Dispatched when any asset finishes parsing. | ParserBase
Inherited | containerComplete | Dispatched when a container asset has been constructed from a resource. | ParserBase
Inherited | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | ParserBase
Inherited | materialComplete | Dispatched when a material asset has been constructed from a resource. | ParserBase
Inherited | parseComplete | Dispatched when the parsing finishes. | ParserBase
Inherited | parseError | Dispatched if an error was caught during parsing. | ParserBase
Inherited | readyForDependencies | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace. | ParserBase
Inherited | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | ParserBase
Inherited | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | ParserBase
Inherited | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | ParserBase
Inherited | textureComplete | Dispatched when a texture asset has been constructed from a resource. | ParserBase
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | MORE_TO_PARSE : Boolean = false [static] Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing. | ParserBase
Inherited | PARSING_DONE : Boolean = true [static] Returned by proceedParsing to indicate no more parsing is needed. | ParserBase
Constructor Detail
AWD1Parser () Constructor
public function AWD1Parser()

Creates a new AWD1Parser object.

Method Detail
proceedParsing () method
override protected function proceedParsing():Boolean

Parse the next block of data.

Returns
Boolean — Whether or not more data needs to be parsed. Can be ParserBase.PARSING_DONE or ParserBase.MORE_TO_PARSE.
resolveDependency () method
override arcane function resolveDependency(resourceDependency:ResourceDependency):void

Resolve a dependency when it's loaded. For example, a dependency containing an ImageResource would be assigned to a Mesh instance as a BitmapMaterial, a scene graph object would be added to its intended parent. The dependency should be a member of the dependencies property.

Parameters

resourceDependency:ResourceDependency — The dependency to be resolved.

resolveDependencyFailure () method
override arcane function resolveDependencyFailure(resourceDependency:ResourceDependency):void

Resolve a dependency loading failure. Used by parser to eventually provide a default map

Parameters

resourceDependency:ResourceDependency — The dependency to be resolved.

supportsData () method
public static function supportsData(data:*):Boolean

Tests whether a data block can be parsed by the parser.

Parameters

data:* — The data block to potentially be parsed.

Returns
Boolean — Whether or not the given data is supported.
supportsType () method
public static function supportsType(extension:String):Boolean

Indicates whether or not a given file extension is supported by the parser.

Parameters

extension:String — The file extension of a potential file to be parsed.

Returns
Boolean — Whether or not the given file type is supported.


away3d.loaders.parsers.AWD2Parser

AWD2Parser | Properties | Methods | Events | Constants
Package | away3d.loaders.parsers
Class | public class AWD2Parser
Inheritance | AWD2Parser Inheritance ParserBase Inheritance flash.events.EventDispatcher

AWDParser provides a parser for the AWD data type.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | dataFormat : String [read-only] The data format of the file data to be parsed. | ParserBase
Inherited | dependencies : Vector.<ResourceDependency> [read-only] A list of dependencies that need to be loaded and resolved for the object being parsed. | ParserBase
Inherited | parsingComplete : Boolean [read-only] | ParserBase
Inherited | parsingFailure : Boolean | ParserBase
Inherited | parsingPaused : Boolean [read-only] | ParserBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _data : * | ParserBase
Inherited | _dataFormat : String | ParserBase
Inherited | _frameLimit : Number | ParserBase
Inherited | _lastFrameTime : Number | ParserBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | AWD2Parser() Creates a new AWDParser object. | AWD2Parser
Inherited | isBitmapDataValid(bitmapData:BitmapData):Boolean Validates a bitmapData loaded before assigning to a default BitmapMaterial | ParserBase
Inherited | parseAsync(data:*, frameLimit:Number = 30):void Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame. | ParserBase
 | supportsData(data:*):Boolean [static] Tests whether a data block can be parsed by the parser. | AWD2Parser
 | supportsType(extension:String):Boolean [static] Indicates whether or not a given file extension is supported by the parser. | AWD2Parser
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void | ParserBase
Inherited | dieWithError(message:String = Unknown parsing error):void | ParserBase
Inherited | finalizeAsset(asset:IAsset, name:String = null):void | ParserBase
Inherited | finishParsing():void Finish parsing the data. | ParserBase
Inherited | getByteData():ByteArray | ParserBase
Inherited | getTextData():String | ParserBase
Inherited | hasTime():Boolean Tests whether or not there is still time left for parsing within the maximum allowed time frame per session. | ParserBase
Inherited | onInterval(event:TimerEvent = null):void Called when the parsing pause interval has passed and parsing can proceed. | ParserBase
Inherited | pauseAndRetrieveDependencies():void | ParserBase
 | proceedParsing():Boolean [override] Parse the next block of data. | AWD2Parser
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | ParserBase
Inherited | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | ParserBase
Inherited | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | ParserBase
Inherited | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | ParserBase
Inherited | assetComplete | Dispatched when any asset finishes parsing. | ParserBase
Inherited | containerComplete | Dispatched when a container asset has been constructed from a resource. | ParserBase
Inherited | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | ParserBase
Inherited | materialComplete | Dispatched when a material asset has been constructed from a resource. | ParserBase
Inherited | parseComplete | Dispatched when the parsing finishes. | ParserBase
Inherited | parseError | Dispatched if an error was caught during parsing. | ParserBase
Inherited | readyForDependencies | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace. | ParserBase
Inherited | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | ParserBase
Inherited | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | ParserBase
Inherited | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | ParserBase
Inherited | textureComplete | Dispatched when a texture asset has been constructed from a resource. | ParserBase
Public Constants
Constant |  | Defined By
 | AWD_FIELD_BADDR : uint = 23 [static] | AWD2Parser
 | AWD_FIELD_BOOL : uint = 21 [static] | AWD2Parser
 | AWD_FIELD_BYTEARRAY : uint = 32 [static] | AWD2Parser
 | AWD_FIELD_COLOR : uint = 22 [static] | AWD2Parser
 | AWD_FIELD_FLOAT32 : uint = 7 [static] | AWD2Parser
 | AWD_FIELD_FLOAT64 : uint = 8 [static] | AWD2Parser
 | AWD_FIELD_INT16 : uint = 2 [static] | AWD2Parser
 | AWD_FIELD_INT32 : uint = 3 [static] | AWD2Parser
 | AWD_FIELD_INT8 : uint = 1 [static] | AWD2Parser
 | AWD_FIELD_MTX3x2 : uint = 44 [static] | AWD2Parser
 | AWD_FIELD_MTX3x3 : uint = 45 [static] | AWD2Parser
 | AWD_FIELD_MTX4x3 : uint = 46 [static] | AWD2Parser
 | AWD_FIELD_MTX4x4 : uint = 47 [static] | AWD2Parser
 | AWD_FIELD_STRING : uint = 31 [static] | AWD2Parser
 | AWD_FIELD_UINT16 : uint = 5 [static] | AWD2Parser
 | AWD_FIELD_UINT32 : uint = 6 [static] | AWD2Parser
 | AWD_FIELD_UINT8 : uint = 4 [static] | AWD2Parser
 | AWD_FIELD_VECTOR2x1 : uint = 41 [static] | AWD2Parser
 | AWD_FIELD_VECTOR3x1 : uint = 42 [static] | AWD2Parser
 | AWD_FIELD_VECTOR4x1 : uint = 43 [static] | AWD2Parser
 | DEFLATE : uint = 1 [static] | AWD2Parser
 | LZMA : uint = 2 [static] | AWD2Parser
 | UNCOMPRESSED : uint = 0 [static] | AWD2Parser
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | MORE_TO_PARSE : Boolean = false [static] Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing. | ParserBase
Inherited | PARSING_DONE : Boolean = true [static] Returned by proceedParsing to indicate no more parsing is needed. | ParserBase
Constructor Detail
AWD2Parser () Constructor
public function AWD2Parser()

Creates a new AWDParser object.

Method Detail
proceedParsing () method
override protected function proceedParsing():Boolean

Parse the next block of data.

Returns
Boolean — Whether or not more data needs to be parsed. Can be ParserBase.PARSING_DONE or ParserBase.MORE_TO_PARSE.
resolveDependency () method
override arcane function resolveDependency(resourceDependency:ResourceDependency):void

Resolve a dependency when it's loaded. For example, a dependency containing an ImageResource would be assigned to a Mesh instance as a BitmapMaterial, a scene graph object would be added to its intended parent. The dependency should be a member of the dependencies property.

Parameters

resourceDependency:ResourceDependency — The dependency to be resolved.

resolveDependencyFailure () method
override arcane function resolveDependencyFailure(resourceDependency:ResourceDependency):void

Resolve a dependency loading failure. Used by parser to eventually provide a default map

Parameters

resourceDependency:ResourceDependency — The dependency to be resolved.

supportsData () method
public static function supportsData(data:*):Boolean

Tests whether a data block can be parsed by the parser.

Parameters

data:* — The data block to potentially be parsed.

Returns
Boolean — Whether or not the given data is supported.
supportsType () method
public static function supportsType(extension:String):Boolean

Indicates whether or not a given file extension is supported by the parser.

Parameters

extension:String — The file extension of a potential file to be parsed.

Returns
Boolean — Whether or not the given file type is supported.
Constant Detail
AWD_FIELD_BADDR Constant
public static const AWD_FIELD_BADDR:uint = 23

AWD_FIELD_BOOL Constant
public static const AWD_FIELD_BOOL:uint = 21

AWD_FIELD_BYTEARRAY Constant
public static const AWD_FIELD_BYTEARRAY:uint = 32

AWD_FIELD_COLOR Constant
public static const AWD_FIELD_COLOR:uint = 22

AWD_FIELD_FLOAT32 Constant
public static const AWD_FIELD_FLOAT32:uint = 7

AWD_FIELD_FLOAT64 Constant
public static const AWD_FIELD_FLOAT64:uint = 8

AWD_FIELD_INT16 Constant
public static const AWD_FIELD_INT16:uint = 2

AWD_FIELD_INT32 Constant
public static const AWD_FIELD_INT32:uint = 3

AWD_FIELD_INT8 Constant
public static const AWD_FIELD_INT8:uint = 1

AWD_FIELD_MTX3x2 Constant
public static const AWD_FIELD_MTX3x2:uint = 44

AWD_FIELD_MTX3x3 Constant
public static const AWD_FIELD_MTX3x3:uint = 45

AWD_FIELD_MTX4x3 Constant
public static const AWD_FIELD_MTX4x3:uint = 46

AWD_FIELD_MTX4x4 Constant
public static const AWD_FIELD_MTX4x4:uint = 47

AWD_FIELD_STRING Constant
public static const AWD_FIELD_STRING:uint = 31

AWD_FIELD_UINT16 Constant
public static const AWD_FIELD_UINT16:uint = 5

AWD_FIELD_UINT32 Constant
public static const AWD_FIELD_UINT32:uint = 6

AWD_FIELD_UINT8 Constant
public static const AWD_FIELD_UINT8:uint = 4

AWD_FIELD_VECTOR2x1 Constant
public static const AWD_FIELD_VECTOR2x1:uint = 41

AWD_FIELD_VECTOR3x1 Constant
public static const AWD_FIELD_VECTOR3x1:uint = 42

AWD_FIELD_VECTOR4x1 Constant
public static const AWD_FIELD_VECTOR4x1:uint = 43

DEFLATE Constant
public static const DEFLATE:uint = 1

LZMA Constant
public static const LZMA:uint = 2

UNCOMPRESSED Constant
public static const UNCOMPRESSED:uint = 0


away3d.loaders.parsers.AWDParser

AWDParser | Properties | Methods | Events
Package | away3d.loaders.parsers
Class | public class AWDParser
Inheritance | AWDParser Inheritance ParserBase Inheritance flash.events.EventDispatcher

The AWDParser class is a wrapper for both AWD1Parser and AWD2Parser, and will find the right concrete parser for an AWD file.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | dataFormat : String [read-only] The data format of the file data to be parsed. | ParserBase
 | dependencies : Vector.<ResourceDependency> [override] [read-only] A list of dependencies that need to be loaded and resolved for the object being parsed. | AWDParser
 | parsingComplete : Boolean [override] [read-only] | AWDParser
Inherited | parsingFailure : Boolean | ParserBase
 | parsingPaused : Boolean [override] [read-only] | AWDParser
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _data : * | ParserBase
Inherited | _dataFormat : String | ParserBase
Inherited | _frameLimit : Number | ParserBase
Inherited | _lastFrameTime : Number | ParserBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | AWDParser() | AWDParser
Inherited | isBitmapDataValid(bitmapData:BitmapData):Boolean Validates a bitmapData loaded before assigning to a default BitmapMaterial | ParserBase
Inherited | parseAsync(data:*, frameLimit:Number = 30):void Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame. | ParserBase
 | supportsData(data:*):Boolean [static] | AWDParser
 | supportsType(suffix:String):Boolean [static] | AWDParser
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void | ParserBase
Inherited | dieWithError(message:String = Unknown parsing error):void | ParserBase
Inherited | finalizeAsset(asset:IAsset, name:String = null):void | ParserBase
Inherited | finishParsing():void Finish parsing the data. | ParserBase
Inherited | getByteData():ByteArray | ParserBase
Inherited | getTextData():String | ParserBase
Inherited | hasTime():Boolean Tests whether or not there is still time left for parsing within the maximum allowed time frame per session. | ParserBase
Inherited | onInterval(event:TimerEvent = null):void Called when the parsing pause interval has passed and parsing can proceed. | ParserBase
Inherited | pauseAndRetrieveDependencies():void | ParserBase
 | proceedParsing():Boolean [override] Find the right conrete parser (AWD1Parser or AWD2Parser) and delegate actual parsing to it. | AWDParser
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | ParserBase
Inherited | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | ParserBase
Inherited | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | ParserBase
Inherited | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | ParserBase
Inherited | assetComplete | Dispatched when any asset finishes parsing. | ParserBase
Inherited | containerComplete | Dispatched when a container asset has been constructed from a resource. | ParserBase
Inherited | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | ParserBase
Inherited | materialComplete | Dispatched when a material asset has been constructed from a resource. | ParserBase
Inherited | parseComplete | Dispatched when the parsing finishes. | ParserBase
Inherited | parseError | Dispatched if an error was caught during parsing. | ParserBase
Inherited | readyForDependencies | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace. | ParserBase
Inherited | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | ParserBase
Inherited | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | ParserBase
Inherited | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | ParserBase
Inherited | textureComplete | Dispatched when a texture asset has been constructed from a resource. | ParserBase
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | MORE_TO_PARSE : Boolean = false [static] Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing. | ParserBase
Inherited | PARSING_DONE : Boolean = true [static] Returned by proceedParsing to indicate no more parsing is needed. | ParserBase
Property Detail
dependencies property
dependencies:Vector.<ResourceDependency> [read-only] [override]

A list of dependencies that need to be loaded and resolved for the object being parsed.

Implementation
    public function get dependencies():Vector.<ResourceDependency>
parsingComplete property
parsingComplete:Boolean [read-only] [override]

Implementation
    public function get parsingComplete():Boolean
parsingPaused property
parsingPaused:Boolean [read-only] [override]

Implementation
    public function get parsingPaused():Boolean
Constructor Detail
AWDParser () Constructor
public function AWDParser()

Method Detail
proceedParsing () method
override protected function proceedParsing():Boolean

Find the right conrete parser (AWD1Parser or AWD2Parser) and delegate actual parsing to it.

Returns
Boolean
resumeParsingAfterDependencies () method
override arcane function resumeParsingAfterDependencies():void

supportsData () method
public static function supportsData(data:*):Boolean

Parameters

data:*

Returns
Boolean
supportsType () method
public static function supportsType(suffix:String):Boolean

Parameters

suffix:String

Returns
Boolean


away3d.loaders.parsers.DAEParser

DAEParser | Properties | Methods | Events | Constants
Package | away3d.loaders.parsers
Class | public class DAEParser
Inheritance | DAEParser Inheritance ParserBase Inheritance flash.events.EventDispatcher

DAEParser provides a parser for the DAE data type.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | dataFormat : String [read-only] The data format of the file data to be parsed. | ParserBase
Inherited | dependencies : Vector.<ResourceDependency> [read-only] A list of dependencies that need to be loaded and resolved for the object being parsed. | ParserBase
 | effects : Object [read-only] | DAEParser
 | geometries : Vector.<Geometry> [read-only] | DAEParser
 | images : Object [read-only] | DAEParser
 | isAnimated : Boolean [read-only] | DAEParser
 | materials : Object [read-only] | DAEParser
Inherited | parsingComplete : Boolean [read-only] | ParserBase
Inherited | parsingFailure : Boolean | ParserBase
Inherited | parsingPaused : Boolean [read-only] | ParserBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _data : * | ParserBase
Inherited | _dataFormat : String | ParserBase
Inherited | _frameLimit : Number | ParserBase
Inherited | _lastFrameTime : Number | ParserBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DAEParser(configFlags:uint = 0) | DAEParser
 | getGeometryByName(name:String, clone:Boolean = false):Geometry | DAEParser
Inherited | isBitmapDataValid(bitmapData:BitmapData):Boolean Validates a bitmapData loaded before assigning to a default BitmapMaterial | ParserBase
Inherited | parseAsync(data:*, frameLimit:Number = 30):void Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame. | ParserBase
 | supportsData(data:*):Boolean [static] Tests whether a data block can be parsed by the parser. | DAEParser
 | supportsType(extension:String):Boolean [static] Indicates whether or not a given file extension is supported by the parser. | DAEParser
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void | ParserBase
Inherited | dieWithError(message:String = Unknown parsing error):void | ParserBase
Inherited | finalizeAsset(asset:IAsset, name:String = null):void | ParserBase
Inherited | finishParsing():void Finish parsing the data. | ParserBase
Inherited | getByteData():ByteArray | ParserBase
Inherited | getTextData():String | ParserBase
Inherited | hasTime():Boolean Tests whether or not there is still time left for parsing within the maximum allowed time frame per session. | ParserBase
Inherited | onInterval(event:TimerEvent = null):void Called when the parsing pause interval has passed and parsing can proceed. | ParserBase
Inherited | pauseAndRetrieveDependencies():void | ParserBase
 | proceedParsing():Boolean [override] | DAEParser
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | ParserBase
Inherited | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | ParserBase
Inherited | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | ParserBase
Inherited | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | ParserBase
Inherited | assetComplete | Dispatched when any asset finishes parsing. | ParserBase
Inherited | containerComplete | Dispatched when a container asset has been constructed from a resource. | ParserBase
Inherited | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | ParserBase
Inherited | materialComplete | Dispatched when a material asset has been constructed from a resource. | ParserBase
Inherited | parseComplete | Dispatched when the parsing finishes. | ParserBase
Inherited | parseError | Dispatched if an error was caught during parsing. | ParserBase
Inherited | readyForDependencies | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace. | ParserBase
Inherited | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | ParserBase
Inherited | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | ParserBase
Inherited | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | ParserBase
Inherited | textureComplete | Dispatched when a texture asset has been constructed from a resource. | ParserBase
Public Constants
Constant |  | Defined By
 | CONFIG_DEFAULT : uint = 1 [static] | DAEParser
 | CONFIG_USE_GPU : uint = 1 [static] | DAEParser
 | PARSE_DEFAULT : uint [static] | DAEParser
 | PARSE_GEOMETRIES : uint = 1 [static] | DAEParser
 | PARSE_IMAGES : uint = 2 [static] | DAEParser
 | PARSE_MATERIALS : uint = 4 [static] | DAEParser
 | PARSE_VISUAL_SCENES : uint = 8 [static] | DAEParser
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | MORE_TO_PARSE : Boolean = false [static] Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing. | ParserBase
Inherited | PARSING_DONE : Boolean = true [static] Returned by proceedParsing to indicate no more parsing is needed. | ParserBase
Property Detail
effects property
effects:Object [read-only]

Implementation
    public function get effects():Object
geometries property
geometries:Vector.<Geometry> [read-only]

Implementation
    public function get geometries():Vector.<Geometry>
images property
images:Object [read-only]

Implementation
    public function get images():Object
isAnimated property
isAnimated:Boolean [read-only]

Implementation
    public function get isAnimated():Boolean
materials property
materials:Object [read-only]

Implementation
    public function get materials():Object
Constructor Detail
DAEParser () Constructor
public function DAEParser(configFlags:uint = 0)

Parameters
configFlags:uint (default = 0) — Bitfield to configure the parser.

See also

etc.
Method Detail
getGeometryByName () method
public function getGeometryByName(name:String, clone:Boolean = false):Geometry

Parameters

name:String
clone:Boolean (default = false)

Returns
Geometry
proceedParsing () method
override protected function proceedParsing():Boolean

Returns
Boolean
resolveDependency () method
override arcane function resolveDependency(resourceDependency:ResourceDependency):void

Parameters

resourceDependency:ResourceDependency

resolveDependencyFailure () method
override arcane function resolveDependencyFailure(resourceDependency:ResourceDependency):void

Parameters

resourceDependency:ResourceDependency

supportsData () method
public static function supportsData(data:*):Boolean

Tests whether a data block can be parsed by the parser.

Parameters

data:* — The data block to potentially be parsed.

Returns
Boolean — Whether or not the given data is supported.
supportsType () method
public static function supportsType(extension:String):Boolean

Indicates whether or not a given file extension is supported by the parser.

Parameters

extension:String — The file extension of a potential file to be parsed.

Returns
Boolean — Whether or not the given file type is supported.
Constant Detail
CONFIG_DEFAULT Constant
public static const CONFIG_DEFAULT:uint = 1

CONFIG_USE_GPU Constant
public static const CONFIG_USE_GPU:uint = 1

PARSE_DEFAULT Constant
public static const PARSE_DEFAULT:uint

PARSE_GEOMETRIES Constant
public static const PARSE_GEOMETRIES:uint = 1

PARSE_IMAGES Constant
public static const PARSE_IMAGES:uint = 2

PARSE_MATERIALS Constant
public static const PARSE_MATERIALS:uint = 4

PARSE_VISUAL_SCENES Constant
public static const PARSE_VISUAL_SCENES:uint = 8


away3d.loaders.parsers.DXFParser

DXFParser | Properties | Methods | Events
Package | away3d.loaders.parsers
Class | public class DXFParser
Inheritance | DXFParser Inheritance ParserBase Inheritance flash.events.EventDispatcher

DXFParser provides a parser for the dxf 3D renderable data. supported blocks type: FACEDATA, LINE. Color from dxf color table is set where index is encountered POLYLINE(64 polyface mesh) and VERTEX.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | dataFormat : String [read-only] The data format of the file data to be parsed. | ParserBase
Inherited | dependencies : Vector.<ResourceDependency> [read-only] A list of dependencies that need to be loaded and resolved for the object being parsed. | ParserBase
Inherited | parsingComplete : Boolean [read-only] | ParserBase
Inherited | parsingFailure : Boolean | ParserBase
Inherited | parsingPaused : Boolean [read-only] | ParserBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _data : * | ParserBase
Inherited | _dataFormat : String | ParserBase
Inherited | _frameLimit : Number | ParserBase
Inherited | _lastFrameTime : Number | ParserBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DXFParser() Creates a new DXFParser object. | DXFParser
Inherited | isBitmapDataValid(bitmapData:BitmapData):Boolean Validates a bitmapData loaded before assigning to a default BitmapMaterial | ParserBase
Inherited | parseAsync(data:*, frameLimit:Number = 30):void Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame. | ParserBase
 | supportsData(data:*):Boolean [static] Tests whether a data block can be parsed by the parser. | DXFParser
 | supportsType(extension:String):Boolean [static] Indicates whether or not a given file extension is supported by the parser. | DXFParser
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void | ParserBase
Inherited | dieWithError(message:String = Unknown parsing error):void | ParserBase
Inherited | finalizeAsset(asset:IAsset, name:String = null):void | ParserBase
Inherited | finishParsing():void Finish parsing the data. | ParserBase
Inherited | getByteData():ByteArray | ParserBase
Inherited | getTextData():String | ParserBase
Inherited | hasTime():Boolean Tests whether or not there is still time left for parsing within the maximum allowed time frame per session. | ParserBase
Inherited | onInterval(event:TimerEvent = null):void Called when the parsing pause interval has passed and parsing can proceed. | ParserBase
Inherited | pauseAndRetrieveDependencies():void | ParserBase
 | proceedParsing():Boolean [override] Parse the next block of data. | DXFParser
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | ParserBase
Inherited | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | ParserBase
Inherited | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | ParserBase
Inherited | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | ParserBase
Inherited | assetComplete | Dispatched when any asset finishes parsing. | ParserBase
Inherited | containerComplete | Dispatched when a container asset has been constructed from a resource. | ParserBase
Inherited | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | ParserBase
Inherited | materialComplete | Dispatched when a material asset has been constructed from a resource. | ParserBase
Inherited | parseComplete | Dispatched when the parsing finishes. | ParserBase
Inherited | parseError | Dispatched if an error was caught during parsing. | ParserBase
Inherited | readyForDependencies | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace. | ParserBase
Inherited | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | ParserBase
Inherited | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | ParserBase
Inherited | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | ParserBase
Inherited | textureComplete | Dispatched when a texture asset has been constructed from a resource. | ParserBase
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | MORE_TO_PARSE : Boolean = false [static] Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing. | ParserBase
Inherited | PARSING_DONE : Boolean = true [static] Returned by proceedParsing to indicate no more parsing is needed. | ParserBase
Constructor Detail
DXFParser () Constructor
public function DXFParser()

Creates a new DXFParser object.

Method Detail
proceedParsing () method
override protected function proceedParsing():Boolean

Parse the next block of data.

Returns
Boolean — Whether or not more data needs to be parsed. Can be ParserBase.PARSING_DONE or ParserBase.MORE_TO_PARSE.
supportsData () method
public static function supportsData(data:*):Boolean

Tests whether a data block can be parsed by the parser.

Parameters

data:* — The data block to potentially be parsed.

Returns
Boolean — Whether or not the given data is supported.
supportsType () method
public static function supportsType(extension:String):Boolean

Indicates whether or not a given file extension is supported by the parser.

Parameters

extension:String — The file extension of a potential file to be parsed.

Returns
Boolean — Whether or not the given file type is supported.


away3d.loaders.parsers.ImageParser

ImageParser | Properties | Methods | Events
Package | away3d.loaders.parsers
Class | public class ImageParser
Inheritance | ImageParser Inheritance ParserBase Inheritance flash.events.EventDispatcher

ImageParser provides a "parser" for natively supported image types (jpg, png). While it simply loads bytes into a loader object, it wraps it in a BitmapDataResource so resource management can happen consistently without exception cases.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | dataFormat : String [read-only] The data format of the file data to be parsed. | ParserBase
Inherited | dependencies : Vector.<ResourceDependency> [read-only] A list of dependencies that need to be loaded and resolved for the object being parsed. | ParserBase
Inherited | parsingComplete : Boolean [read-only] | ParserBase
Inherited | parsingFailure : Boolean | ParserBase
Inherited | parsingPaused : Boolean [read-only] | ParserBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _data : * | ParserBase
Inherited | _dataFormat : String | ParserBase
Inherited | _frameLimit : Number | ParserBase
Inherited | _lastFrameTime : Number | ParserBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ImageParser() Creates a new ImageParser object. | ImageParser
Inherited | isBitmapDataValid(bitmapData:BitmapData):Boolean Validates a bitmapData loaded before assigning to a default BitmapMaterial | ParserBase
Inherited | parseAsync(data:*, frameLimit:Number = 30):void Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame. | ParserBase
 | supportsData(data:*):Boolean [static] Tests whether a data block can be parsed by the parser. | ImageParser
 | supportsType(extension:String):Boolean [static] Indicates whether or not a given file extension is supported by the parser. | ImageParser
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void | ParserBase
Inherited | dieWithError(message:String = Unknown parsing error):void | ParserBase
Inherited | finalizeAsset(asset:IAsset, name:String = null):void | ParserBase
Inherited | finishParsing():void Finish parsing the data. | ParserBase
Inherited | getByteData():ByteArray | ParserBase
Inherited | getTextData():String | ParserBase
Inherited | hasTime():Boolean Tests whether or not there is still time left for parsing within the maximum allowed time frame per session. | ParserBase
Inherited | onInterval(event:TimerEvent = null):void Called when the parsing pause interval has passed and parsing can proceed. | ParserBase
Inherited | pauseAndRetrieveDependencies():void | ParserBase
 | proceedParsing():Boolean [override] Parse the next block of data. | ImageParser
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | ParserBase
Inherited | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | ParserBase
Inherited | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | ParserBase
Inherited | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | ParserBase
Inherited | assetComplete | Dispatched when any asset finishes parsing. | ParserBase
Inherited | containerComplete | Dispatched when a container asset has been constructed from a resource. | ParserBase
Inherited | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | ParserBase
Inherited | materialComplete | Dispatched when a material asset has been constructed from a resource. | ParserBase
Inherited | parseComplete | Dispatched when the parsing finishes. | ParserBase
Inherited | parseError | Dispatched if an error was caught during parsing. | ParserBase
Inherited | readyForDependencies | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace. | ParserBase
Inherited | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | ParserBase
Inherited | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | ParserBase
Inherited | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | ParserBase
Inherited | textureComplete | Dispatched when a texture asset has been constructed from a resource. | ParserBase
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | MORE_TO_PARSE : Boolean = false [static] Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing. | ParserBase
Inherited | PARSING_DONE : Boolean = true [static] Returned by proceedParsing to indicate no more parsing is needed. | ParserBase
Constructor Detail
ImageParser () Constructor
public function ImageParser()

Creates a new ImageParser object.

Method Detail
proceedParsing () method
override protected function proceedParsing():Boolean

Parse the next block of data.

Returns
Boolean — Whether or not more data needs to be parsed. Can be ParserBase.PARSING_DONE or ParserBase.MORE_TO_PARSE.
supportsData () method
public static function supportsData(data:*):Boolean

Tests whether a data block can be parsed by the parser.

Parameters

data:* — The data block to potentially be parsed.

Returns
Boolean — Whether or not the given data is supported.
supportsType () method
public static function supportsType(extension:String):Boolean

Indicates whether or not a given file extension is supported by the parser.

Parameters

extension:String — The file extension of a potential file to be parsed.

Returns
Boolean — Whether or not the given file type is supported.


away3d.loaders.parsers.Max3DSParser

Max3DSParser | Properties | Methods | Events
Package | away3d.loaders.parsers
Class | public class Max3DSParser
Inheritance | Max3DSParser Inheritance ParserBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | dataFormat : String [read-only] The data format of the file data to be parsed. | ParserBase
Inherited | dependencies : Vector.<ResourceDependency> [read-only] A list of dependencies that need to be loaded and resolved for the object being parsed. | ParserBase
Inherited | parsingComplete : Boolean [read-only] | ParserBase
Inherited | parsingFailure : Boolean | ParserBase
Inherited | parsingPaused : Boolean [read-only] | ParserBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _data : * | ParserBase
Inherited | _dataFormat : String | ParserBase
Inherited | _frameLimit : Number | ParserBase
Inherited | _lastFrameTime : Number | ParserBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Max3DSParser() | Max3DSParser
Inherited | isBitmapDataValid(bitmapData:BitmapData):Boolean Validates a bitmapData loaded before assigning to a default BitmapMaterial | ParserBase
Inherited | parseAsync(data:*, frameLimit:Number = 30):void Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame. | ParserBase
 | supportsData(data:*):Boolean [static] | Max3DSParser
 | supportsType(extension:String):Boolean [static] | Max3DSParser
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void | ParserBase
Inherited | dieWithError(message:String = Unknown parsing error):void | ParserBase
Inherited | finalizeAsset(asset:IAsset, name:String = null):void | ParserBase
Inherited | finishParsing():void Finish parsing the data. | ParserBase
Inherited | getByteData():ByteArray | ParserBase
Inherited | getTextData():String | ParserBase
Inherited | hasTime():Boolean Tests whether or not there is still time left for parsing within the maximum allowed time frame per session. | ParserBase
Inherited | onInterval(event:TimerEvent = null):void Called when the parsing pause interval has passed and parsing can proceed. | ParserBase
Inherited | pauseAndRetrieveDependencies():void | ParserBase
 | proceedParsing():Boolean [override] | Max3DSParser
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | ParserBase
Inherited | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | ParserBase
Inherited | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | ParserBase
Inherited | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | ParserBase
Inherited | assetComplete | Dispatched when any asset finishes parsing. | ParserBase
Inherited | containerComplete | Dispatched when a container asset has been constructed from a resource. | ParserBase
Inherited | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | ParserBase
Inherited | materialComplete | Dispatched when a material asset has been constructed from a resource. | ParserBase
Inherited | parseComplete | Dispatched when the parsing finishes. | ParserBase
Inherited | parseError | Dispatched if an error was caught during parsing. | ParserBase
Inherited | readyForDependencies | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace. | ParserBase
Inherited | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | ParserBase
Inherited | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | ParserBase
Inherited | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | ParserBase
Inherited | textureComplete | Dispatched when a texture asset has been constructed from a resource. | ParserBase
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | MORE_TO_PARSE : Boolean = false [static] Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing. | ParserBase
Inherited | PARSING_DONE : Boolean = true [static] Returned by proceedParsing to indicate no more parsing is needed. | ParserBase
Constructor Detail
Max3DSParser () Constructor
public function Max3DSParser()

Method Detail
proceedParsing () method
override protected function proceedParsing():Boolean

Returns
Boolean
resolveDependency () method
override arcane function resolveDependency(resourceDependency:ResourceDependency):void

Parameters

resourceDependency:ResourceDependency

resolveDependencyFailure () method
override arcane function resolveDependencyFailure(resourceDependency:ResourceDependency):void

Parameters

resourceDependency:ResourceDependency

supportsData () method
public static function supportsData(data:*):Boolean

Parameters

data:*

Returns
Boolean
supportsType () method
public static function supportsType(extension:String):Boolean

Parameters

extension:String

Returns
Boolean


away3d.loaders.parsers.MD2Parser

MD2Parser | Properties | Methods | Events
Package | away3d.loaders.parsers
Class | public class MD2Parser
Inheritance | MD2Parser Inheritance ParserBase Inheritance flash.events.EventDispatcher

MD2Parser provides a parser for the MD2 data type.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | dataFormat : String [read-only] The data format of the file data to be parsed. | ParserBase
Inherited | dependencies : Vector.<ResourceDependency> [read-only] A list of dependencies that need to be loaded and resolved for the object being parsed. | ParserBase
 | FPS : int = 6 [static] | MD2Parser
Inherited | parsingComplete : Boolean [read-only] | ParserBase
Inherited | parsingFailure : Boolean | ParserBase
Inherited | parsingPaused : Boolean [read-only] | ParserBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _data : * | ParserBase
Inherited | _dataFormat : String | ParserBase
Inherited | _frameLimit : Number | ParserBase
Inherited | _lastFrameTime : Number | ParserBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | MD2Parser(textureType:String = jpg, ignoreTexturePath:Boolean = true) Creates a new MD2Parser object. | MD2Parser
Inherited | isBitmapDataValid(bitmapData:BitmapData):Boolean Validates a bitmapData loaded before assigning to a default BitmapMaterial | ParserBase
Inherited | parseAsync(data:*, frameLimit:Number = 30):void Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame. | ParserBase
 | supportsData(data:*):Boolean [static] Tests whether a data block can be parsed by the parser. | MD2Parser
 | supportsType(extension:String):Boolean [static] Indicates whether or not a given file extension is supported by the parser. | MD2Parser
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void | ParserBase
Inherited | dieWithError(message:String = Unknown parsing error):void | ParserBase
Inherited | finalizeAsset(asset:IAsset, name:String = null):void | ParserBase
Inherited | finishParsing():void Finish parsing the data. | ParserBase
Inherited | getByteData():ByteArray | ParserBase
Inherited | getTextData():String | ParserBase
Inherited | hasTime():Boolean Tests whether or not there is still time left for parsing within the maximum allowed time frame per session. | ParserBase
Inherited | onInterval(event:TimerEvent = null):void Called when the parsing pause interval has passed and parsing can proceed. | ParserBase
Inherited | pauseAndRetrieveDependencies():void | ParserBase
 | proceedParsing():Boolean [override] Parse the next block of data. | MD2Parser
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | ParserBase
Inherited | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | ParserBase
Inherited | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | ParserBase
Inherited | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | ParserBase
Inherited | assetComplete | Dispatched when any asset finishes parsing. | ParserBase
Inherited | containerComplete | Dispatched when a container asset has been constructed from a resource. | ParserBase
Inherited | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | ParserBase
Inherited | materialComplete | Dispatched when a material asset has been constructed from a resource. | ParserBase
Inherited | parseComplete | Dispatched when the parsing finishes. | ParserBase
Inherited | parseError | Dispatched if an error was caught during parsing. | ParserBase
Inherited | readyForDependencies | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace. | ParserBase
Inherited | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | ParserBase
Inherited | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | ParserBase
Inherited | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | ParserBase
Inherited | textureComplete | Dispatched when a texture asset has been constructed from a resource. | ParserBase
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | MORE_TO_PARSE : Boolean = false [static] Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing. | ParserBase
Inherited | PARSING_DONE : Boolean = true [static] Returned by proceedParsing to indicate no more parsing is needed. | ParserBase
Property Detail
FPS property
public static var FPS:int = 6

Constructor Detail
MD2Parser () Constructor
public function MD2Parser(textureType:String = jpg, ignoreTexturePath:Boolean = true)

Creates a new MD2Parser object.

Parameters
textureType:String (default = jpg) — The url or id of the data or file to be parsed.
ignoreTexturePath:Boolean (default = true) — The holder for extra contextual data that the parser might need.
Method Detail
proceedParsing () method
override protected function proceedParsing():Boolean

Parse the next block of data.

Returns
Boolean — Whether or not more data needs to be parsed. Can be ParserBase.PARSING_DONE or ParserBase.MORE_TO_PARSE.
resolveDependency () method
override arcane function resolveDependency(resourceDependency:ResourceDependency):void

Resolve a dependency when it's loaded. For example, a dependency containing an ImageResource would be assigned to a Mesh instance as a BitmapMaterial, a scene graph object would be added to its intended parent. The dependency should be a member of the dependencies property.

Parameters

resourceDependency:ResourceDependency — The dependency to be resolved.

resolveDependencyFailure () method
override arcane function resolveDependencyFailure(resourceDependency:ResourceDependency):void

Resolve a dependency loading failure. Used by parser to eventually provide a default map

Parameters

resourceDependency:ResourceDependency — The dependency to be resolved.

supportsData () method
public static function supportsData(data:*):Boolean

Tests whether a data block can be parsed by the parser.

Parameters

data:* — The data block to potentially be parsed.

Returns
Boolean — Whether or not the given data is supported.
supportsType () method
public static function supportsType(extension:String):Boolean

Indicates whether or not a given file extension is supported by the parser.

Parameters

extension:String — The file extension of a potential file to be parsed.

Returns
Boolean — Whether or not the given file type is supported.


away3d.loaders.parsers.MD5AnimParser

MD5AnimParser | Properties | Methods | Events
Package | away3d.loaders.parsers
Class | public class MD5AnimParser
Inheritance | MD5AnimParser Inheritance ParserBase Inheritance flash.events.EventDispatcher

AWDParser provides a parser for the AWD data type, providing an animation sequence for the md5 format. todo: optimize

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | dataFormat : String [read-only] The data format of the file data to be parsed. | ParserBase
Inherited | dependencies : Vector.<ResourceDependency> [read-only] A list of dependencies that need to be loaded and resolved for the object being parsed. | ParserBase
Inherited | parsingComplete : Boolean [read-only] | ParserBase
Inherited | parsingFailure : Boolean | ParserBase
Inherited | parsingPaused : Boolean [read-only] | ParserBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _data : * | ParserBase
Inherited | _dataFormat : String | ParserBase
Inherited | _frameLimit : Number | ParserBase
Inherited | _lastFrameTime : Number | ParserBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | MD5AnimParser(additionalRotationAxis:Vector3D = null, additionalRotationRadians:Number = 0) Creates a new MD5AnimParser object. | MD5AnimParser
Inherited | isBitmapDataValid(bitmapData:BitmapData):Boolean Validates a bitmapData loaded before assigning to a default BitmapMaterial | ParserBase
Inherited | parseAsync(data:*, frameLimit:Number = 30):void Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame. | ParserBase
 | supportsData(data:*):Boolean [static] Tests whether a data block can be parsed by the parser. | MD5AnimParser
 | supportsType(extension:String):Boolean [static] Indicates whether or not a given file extension is supported by the parser. | MD5AnimParser
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void | ParserBase
Inherited | dieWithError(message:String = Unknown parsing error):void | ParserBase
Inherited | finalizeAsset(asset:IAsset, name:String = null):void | ParserBase
Inherited | finishParsing():void Finish parsing the data. | ParserBase
Inherited | getByteData():ByteArray | ParserBase
Inherited | getTextData():String | ParserBase
Inherited | hasTime():Boolean Tests whether or not there is still time left for parsing within the maximum allowed time frame per session. | ParserBase
Inherited | onInterval(event:TimerEvent = null):void Called when the parsing pause interval has passed and parsing can proceed. | ParserBase
Inherited | pauseAndRetrieveDependencies():void | ParserBase
 | proceedParsing():Boolean [override] Parse the next block of data. | MD5AnimParser
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | ParserBase
Inherited | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | ParserBase
Inherited | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | ParserBase
Inherited | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | ParserBase
Inherited | assetComplete | Dispatched when any asset finishes parsing. | ParserBase
Inherited | containerComplete | Dispatched when a container asset has been constructed from a resource. | ParserBase
Inherited | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | ParserBase
Inherited | materialComplete | Dispatched when a material asset has been constructed from a resource. | ParserBase
Inherited | parseComplete | Dispatched when the parsing finishes. | ParserBase
Inherited | parseError | Dispatched if an error was caught during parsing. | ParserBase
Inherited | readyForDependencies | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace. | ParserBase
Inherited | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | ParserBase
Inherited | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | ParserBase
Inherited | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | ParserBase
Inherited | textureComplete | Dispatched when a texture asset has been constructed from a resource. | ParserBase
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | MORE_TO_PARSE : Boolean = false [static] Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing. | ParserBase
Inherited | PARSING_DONE : Boolean = true [static] Returned by proceedParsing to indicate no more parsing is needed. | ParserBase
Constructor Detail
MD5AnimParser () Constructor
public function MD5AnimParser(additionalRotationAxis:Vector3D = null, additionalRotationRadians:Number = 0)

Creates a new MD5AnimParser object.

Parameters
additionalRotationAxis:Vector3D (default = null) — The url or id of the data or file to be parsed.
additionalRotationRadians:Number (default = 0) — The holder for extra contextual data that the parser might need.
Method Detail
proceedParsing () method
override protected function proceedParsing():Boolean

Parse the next block of data.

Returns
Boolean — Whether or not more data needs to be parsed. Can be ParserBase.PARSING_DONE or ParserBase.MORE_TO_PARSE.
supportsData () method
public static function supportsData(data:*):Boolean

Tests whether a data block can be parsed by the parser.

Parameters

data:* — The data block to potentially be parsed.

Returns
Boolean — Whether or not the given data is supported.
supportsType () method
public static function supportsType(extension:String):Boolean

Indicates whether or not a given file extension is supported by the parser.

Parameters

extension:String — The file extension of a potential file to be parsed.

Returns
Boolean — Whether or not the given file type is supported.


away3d.loaders.parsers.MD5MeshParser

MD5MeshParser | Properties | Methods | Events
Package | away3d.loaders.parsers
Class | public class MD5MeshParser
Inheritance | MD5MeshParser Inheritance ParserBase Inheritance flash.events.EventDispatcher

AWDParser provides a parser for the md5mesh data type, providing the geometry of the md5 format. todo: optimize

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | dataFormat : String [read-only] The data format of the file data to be parsed. | ParserBase
Inherited | dependencies : Vector.<ResourceDependency> [read-only] A list of dependencies that need to be loaded and resolved for the object being parsed. | ParserBase
Inherited | parsingComplete : Boolean [read-only] | ParserBase
Inherited | parsingFailure : Boolean | ParserBase
Inherited | parsingPaused : Boolean [read-only] | ParserBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _data : * | ParserBase
Inherited | _dataFormat : String | ParserBase
Inherited | _frameLimit : Number | ParserBase
Inherited | _lastFrameTime : Number | ParserBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | MD5MeshParser(additionalRotationAxis:Vector3D = null, additionalRotationRadians:Number = 0) Creates a new MD5MeshParser object. | MD5MeshParser
Inherited | isBitmapDataValid(bitmapData:BitmapData):Boolean Validates a bitmapData loaded before assigning to a default BitmapMaterial | ParserBase
Inherited | parseAsync(data:*, frameLimit:Number = 30):void Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame. | ParserBase
 | supportsData(data:*):Boolean [static] Tests whether a data block can be parsed by the parser. | MD5MeshParser
 | supportsType(extension:String):Boolean [static] Indicates whether or not a given file extension is supported by the parser. | MD5MeshParser
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void | ParserBase
Inherited | dieWithError(message:String = Unknown parsing error):void | ParserBase
Inherited | finalizeAsset(asset:IAsset, name:String = null):void | ParserBase
Inherited | finishParsing():void Finish parsing the data. | ParserBase
Inherited | getByteData():ByteArray | ParserBase
Inherited | getTextData():String | ParserBase
Inherited | hasTime():Boolean Tests whether or not there is still time left for parsing within the maximum allowed time frame per session. | ParserBase
Inherited | onInterval(event:TimerEvent = null):void Called when the parsing pause interval has passed and parsing can proceed. | ParserBase
Inherited | pauseAndRetrieveDependencies():void | ParserBase
 | proceedParsing():Boolean [override] Parse the next block of data. | MD5MeshParser
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | ParserBase
Inherited | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | ParserBase
Inherited | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | ParserBase
Inherited | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | ParserBase
Inherited | assetComplete | Dispatched when any asset finishes parsing. | ParserBase
Inherited | containerComplete | Dispatched when a container asset has been constructed from a resource. | ParserBase
Inherited | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | ParserBase
Inherited | materialComplete | Dispatched when a material asset has been constructed from a resource. | ParserBase
Inherited | parseComplete | Dispatched when the parsing finishes. | ParserBase
Inherited | parseError | Dispatched if an error was caught during parsing. | ParserBase
Inherited | readyForDependencies | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace. | ParserBase
Inherited | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | ParserBase
Inherited | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | ParserBase
Inherited | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | ParserBase
Inherited | textureComplete | Dispatched when a texture asset has been constructed from a resource. | ParserBase
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | MORE_TO_PARSE : Boolean = false [static] Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing. | ParserBase
Inherited | PARSING_DONE : Boolean = true [static] Returned by proceedParsing to indicate no more parsing is needed. | ParserBase
Constructor Detail
MD5MeshParser () Constructor
public function MD5MeshParser(additionalRotationAxis:Vector3D = null, additionalRotationRadians:Number = 0)

Creates a new MD5MeshParser object.

Parameters
additionalRotationAxis:Vector3D (default = null)
additionalRotationRadians:Number (default = 0)
Method Detail
proceedParsing () method
override protected function proceedParsing():Boolean

Parse the next block of data.

Returns
Boolean — Whether or not more data needs to be parsed. Can be ParserBase.PARSING_DONE or ParserBase.MORE_TO_PARSE.
supportsData () method
public static function supportsData(data:*):Boolean

Tests whether a data block can be parsed by the parser.

Parameters

data:* — The data block to potentially be parsed.

Returns
Boolean — Whether or not the given data is supported.
supportsType () method
public static function supportsType(extension:String):Boolean

Indicates whether or not a given file extension is supported by the parser.

Parameters

extension:String — The file extension of a potential file to be parsed.

Returns
Boolean — Whether or not the given file type is supported.


away3d.loaders.parsers.OBJParser

OBJParser | Properties | Methods | Events
Package | away3d.loaders.parsers
Class | public class OBJParser
Inheritance | OBJParser Inheritance ParserBase Inheritance flash.events.EventDispatcher

OBJParser provides a parser for the OBJ data type.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | dataFormat : String [read-only] The data format of the file data to be parsed. | ParserBase
Inherited | dependencies : Vector.<ResourceDependency> [read-only] A list of dependencies that need to be loaded and resolved for the object being parsed. | ParserBase
Inherited | parsingComplete : Boolean [read-only] | ParserBase
Inherited | parsingFailure : Boolean | ParserBase
Inherited | parsingPaused : Boolean [read-only] | ParserBase
 | scale : Number [write-only] Scaling factor applied directly to vertices data | OBJParser
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _data : * | ParserBase
Inherited | _dataFormat : String | ParserBase
Inherited | _frameLimit : Number | ParserBase
Inherited | _lastFrameTime : Number | ParserBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | OBJParser(scale:Number = 1) Creates a new OBJParser object. | OBJParser
Inherited | isBitmapDataValid(bitmapData:BitmapData):Boolean Validates a bitmapData loaded before assigning to a default BitmapMaterial | ParserBase
Inherited | parseAsync(data:*, frameLimit:Number = 30):void Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame. | ParserBase
 | supportsData(data:*):Boolean [static] Tests whether a data block can be parsed by the parser. | OBJParser
 | supportsType(extension:String):Boolean [static] Indicates whether or not a given file extension is supported by the parser. | OBJParser
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void | ParserBase
Inherited | dieWithError(message:String = Unknown parsing error):void | ParserBase
Inherited | finalizeAsset(asset:IAsset, name:String = null):void | ParserBase
Inherited | finishParsing():void Finish parsing the data. | ParserBase
Inherited | getByteData():ByteArray | ParserBase
Inherited | getTextData():String | ParserBase
Inherited | hasTime():Boolean Tests whether or not there is still time left for parsing within the maximum allowed time frame per session. | ParserBase
Inherited | onInterval(event:TimerEvent = null):void Called when the parsing pause interval has passed and parsing can proceed. | ParserBase
Inherited | pauseAndRetrieveDependencies():void | ParserBase
 | proceedParsing():Boolean [override] Parse the next block of data. | OBJParser
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | ParserBase
Inherited | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | ParserBase
Inherited | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | ParserBase
Inherited | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | ParserBase
Inherited | assetComplete | Dispatched when any asset finishes parsing. | ParserBase
Inherited | containerComplete | Dispatched when a container asset has been constructed from a resource. | ParserBase
Inherited | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | ParserBase
Inherited | materialComplete | Dispatched when a material asset has been constructed from a resource. | ParserBase
Inherited | parseComplete | Dispatched when the parsing finishes. | ParserBase
Inherited | parseError | Dispatched if an error was caught during parsing. | ParserBase
Inherited | readyForDependencies | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace. | ParserBase
Inherited | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | ParserBase
Inherited | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | ParserBase
Inherited | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | ParserBase
Inherited | textureComplete | Dispatched when a texture asset has been constructed from a resource. | ParserBase
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | MORE_TO_PARSE : Boolean = false [static] Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing. | ParserBase
Inherited | PARSING_DONE : Boolean = true [static] Returned by proceedParsing to indicate no more parsing is needed. | ParserBase
Property Detail
scale property
scale:Number [write-only]

Scaling factor applied directly to vertices data

Implementation
    public function set scale(value:Number):void
Constructor Detail
OBJParser () Constructor
public function OBJParser(scale:Number = 1)

Creates a new OBJParser object.

Parameters
scale:Number (default = 1) — The url or id of the data or file to be parsed.
Method Detail
proceedParsing () method
override protected function proceedParsing():Boolean

Parse the next block of data.

Returns
Boolean — Whether or not more data needs to be parsed. Can be ParserBase.PARSING_DONE or ParserBase.MORE_TO_PARSE.
resolveDependency () method
override arcane function resolveDependency(resourceDependency:ResourceDependency):void

Resolve a dependency when it's loaded. For example, a dependency containing an ImageResource would be assigned to a Mesh instance as a BitmapMaterial, a scene graph object would be added to its intended parent. The dependency should be a member of the dependencies property.

Parameters

resourceDependency:ResourceDependency — The dependency to be resolved.

resolveDependencyFailure () method
override arcane function resolveDependencyFailure(resourceDependency:ResourceDependency):void

Resolve a dependency loading failure. Used by parser to eventually provide a default map

Parameters

resourceDependency:ResourceDependency — The dependency to be resolved.

supportsData () method
public static function supportsData(data:*):Boolean

Tests whether a data block can be parsed by the parser.

Parameters

data:* — The data block to potentially be parsed.

Returns
Boolean — Whether or not the given data is supported.
supportsType () method
public static function supportsType(extension:String):Boolean

Indicates whether or not a given file extension is supported by the parser.

Parameters

extension:String — The file extension of a potential file to be parsed.

Returns
Boolean — Whether or not the given file type is supported.


away3d.loaders.parsers.ParserBase

ParserBase | Properties | Methods | Events | Constants
Package | away3d.loaders.parsers
Class | public class ParserBase
Inheritance | ParserBase Inheritance flash.events.EventDispatcher
Subclasses | AC3DParser, AWD1Parser, AWD2Parser, AWDParser, DAEParser, DXFParser, ImageParser, Max3DSParser, MD2Parser, MD5AnimParser, MD5MeshParser, OBJParser

ParserBase provides an abstract base class for objects that convert blocks of data to data structures supported by Away3D. If used by AssetLoader to automatically determine the parser type, two static public methods should be implemented, with the following signatures: public static function supportsType(extension : String) : Boolean Indicates whether or not a given file extension is supported by the parser. public static function supportsData(data : : Boolean Tests whether a data block can be parsed by the parser. Furthermore, for any concrete subtype, the method initHandle should be overridden to immediately create the object that will contain the parsed data. This allows ResourceManager to return an object handle regardless of whether the object was loaded or not.

See also

away3d.loading.parsers.AssetLoader
away3d.loading.ResourceManager

Public Properties
Property |  | Defined By
 | dataFormat : String [read-only] The data format of the file data to be parsed. | ParserBase
 | dependencies : Vector.<ResourceDependency> [read-only] A list of dependencies that need to be loaded and resolved for the object being parsed. | ParserBase
 | parsingComplete : Boolean [read-only] | ParserBase
 | parsingFailure : Boolean | ParserBase
 | parsingPaused : Boolean [read-only] | ParserBase
Protected Properties
Property |  | Defined By
 | _data : * | ParserBase
 | _dataFormat : String | ParserBase
 | _frameLimit : Number | ParserBase
 | _lastFrameTime : Number | ParserBase
Public Methods
Method |  | Defined By
 | ParserBase(format:String) Creates a new ParserBase object | ParserBase
 | isBitmapDataValid(bitmapData:BitmapData):Boolean Validates a bitmapData loaded before assigning to a default BitmapMaterial | ParserBase
 | parseAsync(data:*, frameLimit:Number = 30):void Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame. | ParserBase
Protected Methods
Method |  | Defined By
 | addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void | ParserBase
 | dieWithError(message:String = Unknown parsing error):void | ParserBase
 | finalizeAsset(asset:IAsset, name:String = null):void | ParserBase
 | finishParsing():void Finish parsing the data. | ParserBase
 | getByteData():ByteArray | ParserBase
 | getTextData():String | ParserBase
 | hasTime():Boolean Tests whether or not there is still time left for parsing within the maximum allowed time frame per session. | ParserBase
 | onInterval(event:TimerEvent = null):void Called when the parsing pause interval has passed and parsing can proceed. | ParserBase
 | pauseAndRetrieveDependencies():void | ParserBase
 | proceedParsing():Boolean Parse the next block of data. | ParserBase
Events
Event |  | Summary | Defined By
 | animationNodeComplete | Dispatched when an animation node has been constructed from a resource. | ParserBase
 | animationSetComplete | Dispatched when an animation set has been constructed from a group of animation state resources. | ParserBase
 | animationStateComplete | Dispatched when an animation state has been constructed from a group of animation node resources. | ParserBase
 | animatorComplete | Dispatched when a animator asset has been constructed from a resource. | ParserBase
 | assetComplete | Dispatched when any asset finishes parsing. | ParserBase
 | containerComplete | Dispatched when a container asset has been constructed from a resource. | ParserBase
 | geometryComplete | Dispatched when a geometry asset has been constructed from a resource. | ParserBase
 | materialComplete | Dispatched when a material asset has been constructed from a resource. | ParserBase
 | parseComplete | Dispatched when the parsing finishes. | ParserBase
 | parseError | Dispatched if an error was caught during parsing. | ParserBase
 | readyForDependencies | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace. | ParserBase
 | skeletonComplete | Dispatched when a skeleton asset has been constructed from a resource. | ParserBase
 | skeletonPoseComplete | Dispatched when a skeleton pose asset has been constructed from a resource. | ParserBase
 | stateTransitionComplete | Dispatched when an animation state transition has been constructed from a group of animation node resources. | ParserBase
 | textureComplete | Dispatched when a texture asset has been constructed from a resource. | ParserBase
Protected Constants
Constant |  | Defined By
 | MORE_TO_PARSE : Boolean = false [static] Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing. | ParserBase
 | PARSING_DONE : Boolean = true [static] Returned by proceedParsing to indicate no more parsing is needed. | ParserBase
Property Detail
_data property
protected var _data:*

_dataFormat property
protected var _dataFormat:String

_fileName property
arcane var _fileName:String

_frameLimit property
protected var _frameLimit:Number

_lastFrameTime property
protected var _lastFrameTime:Number

dataFormat property
dataFormat:String [read-only]

The data format of the file data to be parsed. Can be either ParserDataFormat.BINARY or ParserDataFormat.PLAIN_TEXT.

Implementation
    public function get dataFormat():String
dependencies property
dependencies:Vector.<ResourceDependency> [read-only]

A list of dependencies that need to be loaded and resolved for the object being parsed.

Implementation
    public function get dependencies():Vector.<ResourceDependency>
parsingComplete property
parsingComplete:Boolean [read-only]

Implementation
    public function get parsingComplete():Boolean
parsingFailure property
parsingFailure:Boolean

Implementation
    public function get parsingFailure():Boolean
    public function set parsingFailure(value:Boolean):void
parsingPaused property
parsingPaused:Boolean [read-only]

Implementation
    public function get parsingPaused():Boolean
Constructor Detail
ParserBase () Constructor
public function ParserBase(format:String)

Creates a new ParserBase object

Parameters
format:String — The data format of the file data to be parsed. Can be either ParserDataFormat.BINARY or ParserDataFormat.PLAIN_TEXT, and should be provided by the concrete subtype.

See also

away3d.loading.parsers.ParserDataFormat
Method Detail
addDependency () method
protected function addDependency(id:String, req:URLRequest, retrieveAsRawData:Boolean = false, data:* = null, suppressErrorEvents:Boolean = false):void

Parameters

id:String
req:URLRequest
retrieveAsRawData:Boolean (default = false)
data:* (default = null)
suppressErrorEvents:Boolean (default = false)

dieWithError () method
protected function dieWithError(message:String = Unknown parsing error):void

Parameters

message:String (default = Unknown parsing error)

finalizeAsset () method
protected function finalizeAsset(asset:IAsset, name:String = null):void

Parameters

asset:IAsset
name:String (default = null)

finishParsing () method
protected function finishParsing():void

Finish parsing the data.

getByteData () method
protected function getByteData():ByteArray

Returns
ByteArray
getTextData () method
protected function getTextData():String

Returns
String
hasTime () method
protected function hasTime():Boolean

Tests whether or not there is still time left for parsing within the maximum allowed time frame per session.

Returns
Boolean — True if there is still time left, false if the maximum allotted time was exceeded and parsing should be interrupted.
isBitmapDataValid () method
public function isBitmapDataValid(bitmapData:BitmapData):Boolean

Validates a bitmapData loaded before assigning to a default BitmapMaterial

Parameters

bitmapData:BitmapData

Returns
Boolean
onInterval () method
protected function onInterval(event:TimerEvent = null):void

Called when the parsing pause interval has passed and parsing can proceed.

Parameters

event:TimerEvent (default = null)

parseAsync () method
public function parseAsync(data:*, frameLimit:Number = 30):void

Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame.

Parameters

data:* — The untyped data object in which the loaded data resides.
frameLimit:Number (default = 30) — number of milliseconds of parsing allowed per frame. The actual time spent on a frame can exceed this number since time-checks can only be performed between logical sections of the parsing procedure.

pauseAndRetrieveDependencies () method
protected function pauseAndRetrieveDependencies():void

proceedParsing () method
protected function proceedParsing():Boolean

Parse the next block of data.

Returns
Boolean — Whether or not more data needs to be parsed. Can be ParserBase.PARSING_DONE or ParserBase.MORE_TO_PARSE.
resolveDependency () method
arcane function resolveDependency(resourceDependency:ResourceDependency):void

Resolve a dependency when it's loaded. For example, a dependency containing an ImageResource would be assigned to a Mesh instance as a BitmapMaterial, a scene graph object would be added to its intended parent. The dependency should be a member of the dependencies property.

Parameters

resourceDependency:ResourceDependency — The dependency to be resolved.

resolveDependencyFailure () method
arcane function resolveDependencyFailure(resourceDependency:ResourceDependency):void

Resolve a dependency loading failure. Used by parser to eventually provide a default map

Parameters

resourceDependency:ResourceDependency — The dependency to be resolved.

resumeParsingAfterDependencies () method
arcane function resumeParsingAfterDependencies():void

Event Detail
animationNodeComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation node has been constructed from a resource.

animationSetComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation set has been constructed from a group of animation state resources.

animationStateComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation state has been constructed from a group of animation node resources.

animatorComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a animator asset has been constructed from a resource.

assetComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when any asset finishes parsing. Also see specific events for each individual asset type (meshes, materials et c.)

containerComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a container asset has been constructed from a resource.

geometryComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a geometry asset has been constructed from a resource.

materialComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a material asset has been constructed from a resource.

parseComplete Event
Event Object Type: away3d.events.ParserEvent
ParserEvent.type property = away3d.events.ParserEvent

Dispatched when the parsing finishes.

parseError Event
Event Object Type: away3d.events.ParserEvent
ParserEvent.type property = away3d.events.ParserEvent

Dispatched if an error was caught during parsing.

readyForDependencies Event
Event Object Type: away3d.events.ParserEvent
ParserEvent.type property = away3d.events.ParserEvent

Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace.

skeletonComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a skeleton asset has been constructed from a resource.

skeletonPoseComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a skeleton pose asset has been constructed from a resource.

stateTransitionComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when an animation state transition has been constructed from a group of animation node resources.

textureComplete Event
Event Object Type: away3d.events.AssetEvent
AssetEvent.type property = away3d.events.AssetEvent

Dispatched when a texture asset has been constructed from a resource.

Constant Detail
MORE_TO_PARSE Constant
protected static const MORE_TO_PARSE:Boolean = false

Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing.

PARSING_DONE Constant
protected static const PARSING_DONE:Boolean = true

Returned by proceedParsing to indicate no more parsing is needed.


away3d.loaders.parsers.ParserDataFormat

ParserDataFormat | Constants
Package | away3d.loaders.parsers
Class | public class ParserDataFormat
Inheritance | ParserDataFormat Inheritance Object

An enumeration providing values to describe the data format of parsed data.

Public Constants
Constant |  | Defined By
 | BINARY : String = binary [static] Describes the format of a binary file. | ParserDataFormat
 | PLAIN_TEXT : String = plainText [static] Describes the format of a plain text file. | ParserDataFormat
Constant Detail
BINARY Constant
public static const BINARY:String = binary

Describes the format of a binary file.

PLAIN_TEXT Constant
public static const PLAIN_TEXT:String = plainText

Describes the format of a plain text file.


away3d.loaders.parsers.Parsers

Parsers | Methods | Constants
Package | away3d.loaders.parsers
Class | public class Parsers
Inheritance | Parsers Inheritance Object

Public Methods
Method |  | Defined By
 | enableAllBundled():void [static] Short-hand function to enable all bundled parsers for auto-detection. | Parsers
Public Constants
Constant |  | Defined By
 | ALL_BUNDLED : Vector.<Class> [static] A list of all parsers that come bundled with Away3D. | Parsers
Method Detail
enableAllBundled () method
public static function enableAllBundled():void

Short-hand function to enable all bundled parsers for auto-detection. In practice, this is the same as invoking enableParsers(Parsers.ALL_BUNDLED) on any of the loader classes SingleFileLoader, AssetLoader, AssetLibrary or Loader3D. See notes about file size in the documentation for the ALL_BUNDLED constant.

See also

away3d.loaders.parsers.Parsers.ALL_BUNDLED
Constant Detail
ALL_BUNDLED Constant
public static const ALL_BUNDLED:Vector.<Class>

A list of all parsers that come bundled with Away3D. Use this to quickly enable support for all bundled parsers to the file format auto-detection feature, using any of the enableParsers() methods on loaders, e.g.: AssetLibrary.enableParsers(Parsers.ALL_BUNDLED); Beware however that this requires all parser classes to be included in the SWF file, which will add 50-100 kb to the file. When only a limited set of file formats are used, SWF file size can be saved by adding the parsers individually using AssetLibrary.enableParser() A third way is to specify a parser for each loaded file, thereby bypassing the auto-detection mechanisms altogether, while at the same time allowing any properties that are unique to that parser to be set for that load. The bundled parsers are:

  • Away Data version 1 ASCII and version 2 binary (.awd). AWD1 BSP unsupported
  • AC3D (.ac)
  • Collada (.dae)
  • Quake 2 MD2 models (.md2)
  • Doom 3 MD5 meshes (.md5mesh)
  • Doom 3 MD5 animation clips (.md5anim)
  • Wavefront OBJ (.obj)
  • 3DMax (.3ds)
  • DXF (.dxf)
  • Images (.jpg, .png)

See also

away3d.loading.AssetLibrary.enableParser


away3d.loaders.parsers.utils - Away3D Documentation

Package away3d.loaders.parsers.utils

Classes
ParserUtil


away3d.loaders.parsers.utils Summary

away3d.loaders.parsers.utils | Classes

Classes
Class | Description
ParserUtil |

Thu Nov 15 2012, 12:09 PM Z


away3d.loaders.parsers.utils.ParserUtil

ParserUtil | Methods
Package | away3d.loaders.parsers.utils
Class | public class ParserUtil
Inheritance | ParserUtil Inheritance Object

Public Methods
Method |  | Defined By
 | toByteArray(data:*):ByteArray [static] | ParserUtil
 | toString(data:*, length:uint = 0):String [static] | ParserUtil
Method Detail
toByteArray () method
public static function toByteArray(data:*):ByteArray

Parameters

data:*

Returns
ByteArray
toString () method
public static function toString(data:*, length:uint = 0):String

Parameters

data:*
length:uint (default = 0)

Returns
String


away3d.materials - Away3D Documentation

Package away3d.materials

Classes
ColorMaterial
ColorMultiPassMaterial
LightSources
MaterialBase
MultiPassMaterialBase
SegmentMaterial
SinglePassMaterialBase
SkyBoxMaterial
TextureMaterial
TextureMultiPassMaterial


away3d.materials Summary

away3d.materials | Classes

Classes
Class | Description
ColorMaterial | ColorMaterial is a material that uses a flat colour as the surfaces diffuse.
ColorMultiPassMaterial | ColorMaterial is a material that uses a flat colour as the surfaces diffuse.
LightSources | Enumeration class for defining which lighting types affects the specific material lighting component (diffuse and specular).
MaterialBase | MaterialBase forms an abstract base class for any material.
MultiPassMaterialBase | DefaultMaterialBase forms an abstract base class for the default materials provided by Away3D and use methods to define their appearance.
SegmentMaterial | SegmentMaterial is a material exclusively used to render wireframe object
SinglePassMaterialBase | DefaultMaterialBase forms an abstract base class for the default materials provided by Away3D and use methods to define their appearance.
SkyBoxMaterial | SkyBoxMaterial is a material exclusively used to render skyboxes
TextureMaterial | TextureMaterial is a material that uses a texture as the surface's diffuse colour.
TextureMultiPassMaterial |

Thu Nov 15 2012, 12:09 PM Z


away3d.materials.ColorMaterial

ColorMaterial | Properties | Methods | Constants
Package | away3d.materials
Class | public class ColorMaterial
Inheritance | ColorMaterial Inheritance SinglePassMaterialBase Inheritance MaterialBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

ColorMaterial is a material that uses a flat colour as the surfaces diffuse.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alpha : Number The alpha of the surface. | ColorMaterial
Inherited | alphaBlending : Boolean Indicate whether or not the material has transparency. | SinglePassMaterialBase
Inherited | alphaPremultiplied : Boolean Indicates whether visible textures (or other pixels) used by this material have already been premultiplied. | MaterialBase
Inherited | alphaThreshold : Number The minimum alpha value for which pixels should be drawn. | SinglePassMaterialBase
Inherited | ambient : Number The strength of the ambient reflection. | SinglePassMaterialBase
Inherited | ambientColor : uint The colour of the ambient reflection. | SinglePassMaterialBase
Inherited | ambientMethod : BasicAmbientMethod The method to perform ambient shading. | SinglePassMaterialBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | MaterialBase
Inherited | blendMode : String [override] | SinglePassMaterialBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialBase
 | color : uint The diffuse color of the surface. | ColorMaterial
Inherited | colorTransform : ColorTransform The ColorTransform object to transform the colour of the material with. | SinglePassMaterialBase
Inherited | depthCompareMode : String [override] | SinglePassMaterialBase
Inherited | diffuseLightSources : uint | SinglePassMaterialBase
Inherited | diffuseMethod : BasicDiffuseMethod The method to perform diffuse shading. | SinglePassMaterialBase
Inherited | extra : Object An object to contain any extra data | MaterialBase
Inherited | gloss : Number The sharpness of the specular highlight. | SinglePassMaterialBase
Inherited | lightPicker : LightPickerBase [override] | SinglePassMaterialBase
Inherited | mipmap : Boolean [override] Indicates whether or not any used textures should use mipmapping. | SinglePassMaterialBase
Inherited | name : String [override] | MaterialBase
Inherited | normalMap : Texture2DBase The tangent space normal map to influence the direction of the surface for each texel. | SinglePassMaterialBase
Inherited | normalMethod : BasicNormalMethod The method to generate the (tangent-space) normal. | SinglePassMaterialBase
Inherited | numMethods : int [read-only] | SinglePassMaterialBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | repeat : Boolean Indicates whether or not any used textures should be tiled. | MaterialBase
 | requiresBlending : Boolean [override] [read-only] Indicates whether or not the material requires alpha blending during rendering. | ColorMaterial
Inherited | shadowMethod : ShadowMapMethodBase The method to render shadows cast on this surface. | SinglePassMaterialBase
Inherited | smooth : Boolean Indicates whether or not any used textures should use smoothing. | MaterialBase
Inherited | specular : Number The overall strength of the specular reflection. | SinglePassMaterialBase
Inherited | specularColor : uint The colour of the specular reflection. | SinglePassMaterialBase
Inherited | specularLightSources : uint | SinglePassMaterialBase
Inherited | specularMap : Texture2DBase A specular map that defines the strength of specular reflections for each texel in the red channel, and the gloss factor in the green channel. | SinglePassMaterialBase
Inherited | specularMethod : BasicSpecularMethod The method to perform specular shading. | SinglePassMaterialBase
Inherited | uniqueId : uint [read-only] The unique id assigned to the material by the MaterialLibrary. | MaterialBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _depthPass : DepthMapPass | MaterialBase
Inherited | _distancePass : DistanceMapPass | MaterialBase
Inherited | _lightPicker : LightPickerBase | MaterialBase
Inherited | _mipmap : Boolean = true | MaterialBase
Inherited | _numPasses : uint | MaterialBase
Inherited | _passes : Vector.<MaterialPassBase> | MaterialBase
Inherited | _repeat : Boolean | MaterialBase
Inherited | _screenPass : SuperShaderPass | SinglePassMaterialBase
Inherited | _smooth : Boolean = true | MaterialBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ColorMaterial(color:uint = 0xcccccc, alpha:Number = 1) Creates a new ColorMaterial object. | ColorMaterial
Inherited | addMethod(method:EffectMethodBase):void Adds a shading method to the end of the shader. | SinglePassMaterialBase
Inherited | addMethodAt(method:EffectMethodBase, index:int):void Adds a shading method to the end of a shader, at the specified index amongst the methods in that section of the shader. | SinglePassMaterialBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up any resources used by the current object. | MaterialBase
Inherited | getMethodAt(index:int):EffectMethodBase | SinglePassMaterialBase
Inherited | hasMethod(method:EffectMethodBase):Boolean | SinglePassMaterialBase
Inherited | removeMethod(method:EffectMethodBase):void | SinglePassMaterialBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addPass(pass:MaterialPassBase):void Adds a pass to the material | MaterialBase
Inherited | clearPasses():void Clears all passes in the material. | MaterialBase
Inherited | removePass(pass:MaterialPassBase):void | MaterialBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
alpha property
alpha:Number

The alpha of the surface.

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
color property
color:uint

The diffuse color of the surface.

Implementation
    public function get color():uint
    public function set color(value:uint):void
requiresBlending property
requiresBlending:Boolean [read-only] [override]

Indicates whether or not the material requires alpha blending during rendering.

Implementation
    public function get requiresBlending():Boolean
Constructor Detail
ColorMaterial () Constructor
public function ColorMaterial(color:uint = 0xcccccc, alpha:Number = 1)

Creates a new ColorMaterial object.

Parameters
color:uint (default = 0xcccccc) — The material's diffuse surface color.
alpha:Number (default = 1) — The material's surface alpha.


away3d.materials.ColorMultiPassMaterial

ColorMultiPassMaterial | Properties | Methods | Constants
Package | away3d.materials
Class | public class ColorMultiPassMaterial
Inheritance | ColorMultiPassMaterial Inheritance MultiPassMaterialBase Inheritance MaterialBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

ColorMaterial is a material that uses a flat colour as the surfaces diffuse.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean Indicates whether visible textures (or other pixels) used by this material have already been premultiplied. | MaterialBase
Inherited | alphaThreshold : Number The minimum alpha value for which pixels should be drawn. | MultiPassMaterialBase
Inherited | ambient : Number The strength of the ambient reflection. | MultiPassMaterialBase
Inherited | ambientColor : uint The colour of the ambient reflection. | MultiPassMaterialBase
Inherited | ambientMethod : BasicAmbientMethod The method to perform ambient shading. | MultiPassMaterialBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | MaterialBase
Inherited | blendMode : String [override] | MultiPassMaterialBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialBase
 | color : uint The diffuse color of the surface. | ColorMultiPassMaterial
Inherited | depthCompareMode : String [override] | MultiPassMaterialBase
Inherited | diffuseLightSources : uint | MultiPassMaterialBase
Inherited | diffuseMethod : BasicDiffuseMethod The method to perform diffuse shading. | MultiPassMaterialBase
Inherited | extra : Object An object to contain any extra data | MaterialBase
Inherited | gloss : Number The sharpness of the specular highlight. | MultiPassMaterialBase
Inherited | lightPicker : LightPickerBase [override] | MultiPassMaterialBase
Inherited | mipmap : Boolean [override] Indicates whether or not any used textures should use mipmapping. | MultiPassMaterialBase
Inherited | name : String [override] | MaterialBase
Inherited | normalMap : Texture2DBase The tangent space normal map to influence the direction of the surface for each texel. | MultiPassMaterialBase
Inherited | normalMethod : BasicNormalMethod The method to generate the (tangent-space) normal. | MultiPassMaterialBase
Inherited | numMethods : int [read-only] | MultiPassMaterialBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | repeat : Boolean Indicates whether or not any used textures should be tiled. | MaterialBase
Inherited | requiresBlending : Boolean [override] [read-only] Indicates whether or not the material requires alpha blending during rendering. | MultiPassMaterialBase
Inherited | shadowMethod : ShadowMapMethodBase The method to render shadows cast on this surface. | MultiPassMaterialBase
Inherited | smooth : Boolean Indicates whether or not any used textures should use smoothing. | MaterialBase
Inherited | specular : Number The overall strength of the specular reflection. | MultiPassMaterialBase
Inherited | specularColor : uint The colour of the specular reflection. | MultiPassMaterialBase
Inherited | specularLightSources : uint | MultiPassMaterialBase
Inherited | specularMap : Texture2DBase A specular map that defines the strength of specular reflections for each texel in the red channel, and the gloss factor in the green channel. | MultiPassMaterialBase
Inherited | specularMethod : BasicSpecularMethod The method to perform specular shading. | MultiPassMaterialBase
Inherited | uniqueId : uint [read-only] The unique id assigned to the material by the MaterialLibrary. | MaterialBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _casterLightPass : ShadowCasterPass | MultiPassMaterialBase
Inherited | _depthPass : DepthMapPass | MaterialBase
Inherited | _distancePass : DistanceMapPass | MaterialBase
Inherited | _effectsPass : SuperShaderPass | MultiPassMaterialBase
Inherited | _lightPicker : LightPickerBase | MaterialBase
Inherited | _mipmap : Boolean = true | MaterialBase
Inherited | _nonCasterLightPasses : Vector.<LightingPass> | MultiPassMaterialBase
Inherited | _numPasses : uint | MaterialBase
Inherited | _passes : Vector.<MaterialPassBase> | MaterialBase
Inherited | _repeat : Boolean | MaterialBase
Inherited | _smooth : Boolean = true | MaterialBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ColorMultiPassMaterial(color:uint = 0xcccccc) Creates a new ColorMaterial object. | ColorMultiPassMaterial
Inherited | addMethod(method:EffectMethodBase):void Adds a shading method to the end of the shader. | MultiPassMaterialBase
Inherited | addMethodAt(method:EffectMethodBase, index:int):void Adds a shading method to the end of a shader, at the specified index amongst the methods in that section of the shader. | MultiPassMaterialBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up any resources used by the current object. | MaterialBase
Inherited | getMethodAt(index:int):EffectMethodBase | MultiPassMaterialBase
Inherited | hasMethod(method:EffectMethodBase):Boolean | MultiPassMaterialBase
Inherited | removeMethod(method:EffectMethodBase):void | MultiPassMaterialBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addPass(pass:MaterialPassBase):void Adds a pass to the material | MaterialBase
Inherited | clearPasses():void Clears all passes in the material. | MaterialBase
Inherited | invalidateScreenPasses():void | MultiPassMaterialBase
Inherited | removePass(pass:MaterialPassBase):void | MaterialBase
Inherited | updateScreenPasses():void | MultiPassMaterialBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
color property
color:uint

The diffuse color of the surface.

Implementation
    public function get color():uint
    public function set color(value:uint):void
Constructor Detail
ColorMultiPassMaterial () Constructor
public function ColorMultiPassMaterial(color:uint = 0xcccccc)

Creates a new ColorMaterial object.

Parameters
color:uint (default = 0xcccccc) — The material's diffuse surface color.


away3d.materials.LightSources

LightSources | Constants
Package | away3d.materials
Class | public class LightSources
Inheritance | LightSources Inheritance Object

Enumeration class for defining which lighting types affects the specific material lighting component (diffuse and specular). This can be useful if, for example, you want to use light probes for diffuse global lighting, but want specular lights from traditional light sources without those affecting the diffuse light.

See also

away3d.materials.ColorMaterial.diffuseLightSources
away3d.materials.ColorMaterial.specularLightSources
away3d.materials.TextureMaterial.diffuseLightSources
away3d.materials.TextureMaterial.specularLightSources

Public Constants
Constant |  | Defined By
 | ALL : uint = 0x03 [static] Defines that both normal and global lighting probes are to be used as the source for the lighting component. | LightSources
 | LIGHTS : uint = 0x01 [static] Defines normal lights are to be used as the source for the lighting component. | LightSources
 | PROBES : uint = 0x02 [static] Defines that global lighting probes are to be used as the source for the lighting component. | LightSources
Constant Detail
ALL Constant
public static const ALL:uint = 0x03

Defines that both normal and global lighting probes are to be used as the source for the lighting component.

LIGHTS Constant
public static const LIGHTS:uint = 0x01

Defines normal lights are to be used as the source for the lighting component.

PROBES Constant
public static const PROBES:uint = 0x02

Defines that global lighting probes are to be used as the source for the lighting component.


away3d.materials.MaterialBase

MaterialBase | Properties | Methods | Constants
Package | away3d.materials
Class | public class MaterialBase
Inheritance | MaterialBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IAsset
Subclasses | MultiPassMaterialBase, SegmentMaterial, SinglePassMaterialBase, SkyBoxMaterial

MaterialBase forms an abstract base class for any material.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alphaPremultiplied : Boolean Indicates whether visible textures (or other pixels) used by this material have already been premultiplied. | MaterialBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
 | assetType : String [read-only] | MaterialBase
 | blendMode : String The blend mode to use when drawing this renderable. | MaterialBase
 | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialBase
 | depthCompareMode : String | MaterialBase
 | extra : Object An object to contain any extra data | MaterialBase
 | lightPicker : LightPickerBase | MaterialBase
 | mipmap : Boolean Indicates whether or not any used textures should use mipmapping. | MaterialBase
 | name : String [override] | MaterialBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | repeat : Boolean Indicates whether or not any used textures should be tiled. | MaterialBase
 | requiresBlending : Boolean [read-only] Indicates whether or not the material requires alpha blending during rendering. | MaterialBase
 | smooth : Boolean Indicates whether or not any used textures should use smoothing. | MaterialBase
 | uniqueId : uint [read-only] The unique id assigned to the material by the MaterialLibrary. | MaterialBase
Protected Properties
Property |  | Defined By
 | _depthPass : DepthMapPass | MaterialBase
 | _distancePass : DistanceMapPass | MaterialBase
 | _lightPicker : LightPickerBase | MaterialBase
 | _mipmap : Boolean = true | MaterialBase
 | _numPasses : uint | MaterialBase
 | _passes : Vector.<MaterialPassBase> | MaterialBase
 | _repeat : Boolean | MaterialBase
 | _smooth : Boolean = true | MaterialBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | MaterialBase() Creates a new MaterialBase object. | MaterialBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | dispose():void Cleans up any resources used by the current object. | MaterialBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Method |  | Defined By
 | addPass(pass:MaterialPassBase):void Adds a pass to the material | MaterialBase
 | clearPasses():void Clears all passes in the material. | MaterialBase
 | removePass(pass:MaterialPassBase):void | MaterialBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_classification property
arcane var _classification:String

_depthPass property
protected var _depthPass:DepthMapPass

_depthPassId property
arcane var _depthPassId:int

_distancePass property
protected var _distancePass:DistanceMapPass

_lightPicker property
protected var _lightPicker:LightPickerBase

_mipmap property
protected var _mipmap:Boolean = true

_name property
arcane var _name:String = material

_numPasses property
protected var _numPasses:uint

_passes property
protected var _passes:Vector.<MaterialPassBase>

_renderOrderId property
arcane var _renderOrderId:int

_repeat property
protected var _repeat:Boolean

_smooth property
protected var _smooth:Boolean = true

_uniqueId property
arcane var _uniqueId:uint

alphaPremultiplied property
alphaPremultiplied:Boolean

Indicates whether visible textures (or other pixels) used by this material have already been premultiplied. Toggle this if you are seeing black halos around your blended alpha edges.

Implementation
    public function get alphaPremultiplied():Boolean
    public function set alphaPremultiplied(value:Boolean):void
assetType property
assetType:String [read-only]

Implementation
    public function get assetType():String
blendMode property
blendMode:String

The blend mode to use when drawing this renderable. The following blend modes are supported:

  • BlendMode.NORMAL
  • BlendMode.MULTIPLY
  • BlendMode.ADD
  • BlendMode.ALPHA

Implementation
    public function get blendMode():String
    public function set blendMode(value:String):void
bothSides property
bothSides:Boolean

Defines whether or not the material should perform backface culling.

Implementation
    public function get bothSides():Boolean
    public function set bothSides(value:Boolean):void
depthCompareMode property
depthCompareMode:String

Implementation
    public function get depthCompareMode():String
    public function set depthCompareMode(value:String):void
extra property
public var extra:Object

An object to contain any extra data

lightPicker property
lightPicker:LightPickerBase

Implementation
    public function get lightPicker():LightPickerBase
    public function set lightPicker(value:LightPickerBase):void
mipmap property
mipmap:Boolean

Indicates whether or not any used textures should use mipmapping.

Implementation
    public function get mipmap():Boolean
    public function set mipmap(value:Boolean):void
name property
name:String[override]

Implementation
    public function get name():String
    public function set name(value:String):void
repeat property
repeat:Boolean

Indicates whether or not any used textures should be tiled.

Implementation
    public function get repeat():Boolean
    public function set repeat(value:Boolean):void
requiresBlending property
requiresBlending:Boolean [read-only]

Indicates whether or not the material requires alpha blending during rendering.

Implementation
    public function get requiresBlending():Boolean
smooth property
smooth:Boolean

Indicates whether or not any used textures should use smoothing.

Implementation
    public function get smooth():Boolean
    public function set smooth(value:Boolean):void
uniqueId property
uniqueId:uint [read-only]

The unique id assigned to the material by the MaterialLibrary.

Implementation
    public function get uniqueId():uint
Constructor Detail
MaterialBase () Constructor
public function MaterialBase()

Creates a new MaterialBase object.

Method Detail
activateForDepth () method
arcane function activateForDepth(stage3DProxy:Stage3DProxy, camera:Camera3D, distanceBased:Boolean = false, textureRatioX:Number = 1, textureRatioY:Number = 1):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
distanceBased:Boolean (default = false)
textureRatioX:Number (default = 1)
textureRatioY:Number (default = 1)

addPass () method
protected function addPass(pass:MaterialPassBase):void

Adds a pass to the material

Parameters

pass:MaterialPassBase

clearPasses () method
protected function clearPasses():void

Clears all passes in the material.

deactivateForDepth () method
arcane function deactivateForDepth(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

dispose () method
public function dispose():void

Cleans up any resources used by the current object.

hasDepthAlphaThreshold () method
arcane function hasDepthAlphaThreshold():Boolean

Returns
Boolean
invalidatePasses () method
arcane function invalidatePasses(triggerPass:MaterialPassBase):void

Marks the depth shader programs as invalid, so it will be recompiled before the next render.

Parameters

triggerPass:MaterialPassBase — The pass triggering the invalidation, if any, so no infinite loop will occur.

passRendersToTexture () method
arcane function passRendersToTexture(index:uint):Boolean

Parameters

index:uint

Returns
Boolean
removePass () method
protected function removePass(pass:MaterialPassBase):void

Parameters

pass:MaterialPassBase

renderDepth () method
arcane function renderDepth(renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D


away3d.materials.MultiPassMaterialBase

MultiPassMaterialBase | Properties | Methods | Constants
Package | away3d.materials
Class | public class MultiPassMaterialBase
Inheritance | MultiPassMaterialBase Inheritance MaterialBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | ColorMultiPassMaterial, TextureMultiPassMaterial

DefaultMaterialBase forms an abstract base class for the default materials provided by Away3D and use methods to define their appearance.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean Indicates whether visible textures (or other pixels) used by this material have already been premultiplied. | MaterialBase
 | alphaThreshold : Number The minimum alpha value for which pixels should be drawn. | MultiPassMaterialBase
 | ambient : Number The strength of the ambient reflection. | MultiPassMaterialBase
 | ambientColor : uint The colour of the ambient reflection. | MultiPassMaterialBase
 | ambientMethod : BasicAmbientMethod The method to perform ambient shading. | MultiPassMaterialBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | MaterialBase
 | blendMode : String [override] | MultiPassMaterialBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialBase
 | depthCompareMode : String [override] | MultiPassMaterialBase
 | diffuseLightSources : uint | MultiPassMaterialBase
 | diffuseMethod : BasicDiffuseMethod The method to perform diffuse shading. | MultiPassMaterialBase
Inherited | extra : Object An object to contain any extra data | MaterialBase
 | gloss : Number The sharpness of the specular highlight. | MultiPassMaterialBase
 | lightPicker : LightPickerBase [override] | MultiPassMaterialBase
 | mipmap : Boolean [override] Indicates whether or not any used textures should use mipmapping. | MultiPassMaterialBase
Inherited | name : String [override] | MaterialBase
 | normalMap : Texture2DBase The tangent space normal map to influence the direction of the surface for each texel. | MultiPassMaterialBase
 | normalMethod : BasicNormalMethod The method to generate the (tangent-space) normal. | MultiPassMaterialBase
 | numMethods : int [read-only] | MultiPassMaterialBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | repeat : Boolean Indicates whether or not any used textures should be tiled. | MaterialBase
 | requiresBlending : Boolean [override] [read-only] Indicates whether or not the material requires alpha blending during rendering. | MultiPassMaterialBase
 | shadowMethod : ShadowMapMethodBase The method to render shadows cast on this surface. | MultiPassMaterialBase
Inherited | smooth : Boolean Indicates whether or not any used textures should use smoothing. | MaterialBase
 | specular : Number The overall strength of the specular reflection. | MultiPassMaterialBase
 | specularColor : uint The colour of the specular reflection. | MultiPassMaterialBase
 | specularLightSources : uint | MultiPassMaterialBase
 | specularMap : Texture2DBase A specular map that defines the strength of specular reflections for each texel in the red channel, and the gloss factor in the green channel. | MultiPassMaterialBase
 | specularMethod : BasicSpecularMethod The method to perform specular shading. | MultiPassMaterialBase
Inherited | uniqueId : uint [read-only] The unique id assigned to the material by the MaterialLibrary. | MaterialBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
 | _casterLightPass : ShadowCasterPass | MultiPassMaterialBase
Inherited | _depthPass : DepthMapPass | MaterialBase
Inherited | _distancePass : DistanceMapPass | MaterialBase
 | _effectsPass : SuperShaderPass | MultiPassMaterialBase
Inherited | _lightPicker : LightPickerBase | MaterialBase
Inherited | _mipmap : Boolean = true | MaterialBase
 | _nonCasterLightPasses : Vector.<LightingPass> | MultiPassMaterialBase
Inherited | _numPasses : uint | MaterialBase
Inherited | _passes : Vector.<MaterialPassBase> | MaterialBase
Inherited | _repeat : Boolean | MaterialBase
Inherited | _smooth : Boolean = true | MaterialBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | MultiPassMaterialBase() Creates a new DefaultMaterialBase object. | MultiPassMaterialBase
 | addMethod(method:EffectMethodBase):void Adds a shading method to the end of the shader. | MultiPassMaterialBase
 | addMethodAt(method:EffectMethodBase, index:int):void Adds a shading method to the end of a shader, at the specified index amongst the methods in that section of the shader. | MultiPassMaterialBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up any resources used by the current object. | MaterialBase
 | getMethodAt(index:int):EffectMethodBase | MultiPassMaterialBase
 | hasMethod(method:EffectMethodBase):Boolean | MultiPassMaterialBase
 | removeMethod(method:EffectMethodBase):void | MultiPassMaterialBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addPass(pass:MaterialPassBase):void Adds a pass to the material | MaterialBase
Inherited | clearPasses():void Clears all passes in the material. | MaterialBase
 | invalidateScreenPasses():void | MultiPassMaterialBase
Inherited | removePass(pass:MaterialPassBase):void | MaterialBase
 | updateScreenPasses():void | MultiPassMaterialBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_casterLightPass property
protected var _casterLightPass:ShadowCasterPass

_effectsPass property
protected var _effectsPass:SuperShaderPass

_nonCasterLightPasses property
protected var _nonCasterLightPasses:Vector.<LightingPass>

alphaThreshold property
alphaThreshold:Number

The minimum alpha value for which pixels should be drawn. This is used for transparency that is either invisible or entirely opaque, often used with textures for foliage, etc. Recommended values are 0 to disable alpha, or 0.5 to create smooth edges. Default value is 0 (disabled).

Implementation
    public function get alphaThreshold():Number
    public function set alphaThreshold(value:Number):void
ambient property
ambient:Number

The strength of the ambient reflection.

Implementation
    public function get ambient():Number
    public function set ambient(value:Number):void
ambientColor property
ambientColor:uint

The colour of the ambient reflection.

Implementation
    public function get ambientColor():uint
    public function set ambientColor(value:uint):void
ambientMethod property
ambientMethod:BasicAmbientMethod

The method to perform ambient shading. Note that shading methods cannot be reused across materials.

Implementation
    public function get ambientMethod():BasicAmbientMethod
    public function set ambientMethod(value:BasicAmbientMethod):void
blendMode property
blendMode:String[override]

Implementation
    public function get blendMode():String
    public function set blendMode(value:String):void
depthCompareMode property
depthCompareMode:String[override]

Implementation
    public function get depthCompareMode():String
    public function set depthCompareMode(value:String):void
diffuseLightSources property
diffuseLightSources:uint

Implementation
    public function get diffuseLightSources():uint
    public function set diffuseLightSources(value:uint):void
diffuseMethod property
diffuseMethod:BasicDiffuseMethod

The method to perform diffuse shading. Note that shading methods can not be reused across materials.

Implementation
    public function get diffuseMethod():BasicDiffuseMethod
    public function set diffuseMethod(value:BasicDiffuseMethod):void
gloss property
gloss:Number

The sharpness of the specular highlight.

Implementation
    public function get gloss():Number
    public function set gloss(value:Number):void
lightPicker property
lightPicker:LightPickerBase[override]

Implementation
    public function get lightPicker():LightPickerBase
    public function set lightPicker(value:LightPickerBase):void
mipmap property
mipmap:Boolean[override]

Indicates whether or not any used textures should use mipmapping.

Implementation
    public function get mipmap():Boolean
    public function set mipmap(value:Boolean):void
normalMap property
normalMap:Texture2DBase

The tangent space normal map to influence the direction of the surface for each texel.

Implementation
    public function get normalMap():Texture2DBase
    public function set normalMap(value:Texture2DBase):void
normalMethod property
normalMethod:BasicNormalMethod

The method to generate the (tangent-space) normal. Note that shading methods can not be reused across materials.

Implementation
    public function get normalMethod():BasicNormalMethod
    public function set normalMethod(value:BasicNormalMethod):void
numMethods property
numMethods:int [read-only]

Implementation
    public function get numMethods():int
requiresBlending property
requiresBlending:Boolean [read-only] [override]

Indicates whether or not the material requires alpha blending during rendering.

Implementation
    public function get requiresBlending():Boolean
shadowMethod property
shadowMethod:ShadowMapMethodBase

The method to render shadows cast on this surface. Note that shading methods can not be reused across materials.

Implementation
    public function get shadowMethod():ShadowMapMethodBase
    public function set shadowMethod(value:ShadowMapMethodBase):void
specular property
specular:Number

The overall strength of the specular reflection.

Implementation
    public function get specular():Number
    public function set specular(value:Number):void
specularColor property
specularColor:uint

The colour of the specular reflection.

Implementation
    public function get specularColor():uint
    public function set specularColor(value:uint):void
specularLightSources property
specularLightSources:uint

Implementation
    public function get specularLightSources():uint
    public function set specularLightSources(value:uint):void
specularMap property
specularMap:Texture2DBase

A specular map that defines the strength of specular reflections for each texel in the red channel, and the gloss factor in the green channel. You can use SpecularBitmapTexture if you want to easily set specular and gloss maps from greyscale images, but prepared images are preffered.

Implementation
    public function get specularMap():Texture2DBase
    public function set specularMap(value:Texture2DBase):void
specularMethod property
specularMethod:BasicSpecularMethod

The method to perform specular shading. Note that shading methods can not be reused across materials.

Implementation
    public function get specularMethod():BasicSpecularMethod
    public function set specularMethod(value:BasicSpecularMethod):void
Constructor Detail
MultiPassMaterialBase () Constructor
public function MultiPassMaterialBase()

Creates a new DefaultMaterialBase object.

Method Detail
activateForDepth () method
override arcane function activateForDepth(stage3DProxy:Stage3DProxy, camera:Camera3D, distanceBased:Boolean = false, textureRatioX:Number = 1, textureRatioY:Number = 1):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
distanceBased:Boolean (default = false)
textureRatioX:Number (default = 1)
textureRatioY:Number (default = 1)

activatePass () method
override arcane function activatePass(index:uint, stage3DProxy:Stage3DProxy, camera:Camera3D, textureRatioX:Number, textureRatioY:Number):void

Parameters

index:uint
stage3DProxy:Stage3DProxy
camera:Camera3D
textureRatioX:Number
textureRatioY:Number

addMethod () method
public function addMethod(method:EffectMethodBase):void

Adds a shading method to the end of the shader. Note that shading methods can not be reused across materials.

Parameters

method:EffectMethodBase

addMethodAt () method
public function addMethodAt(method:EffectMethodBase, index:int):void

Adds a shading method to the end of a shader, at the specified index amongst the methods in that section of the shader. Note that shading methods can not be reused across materials.

Parameters

method:EffectMethodBase
index:int

deactivate () method
override arcane function deactivate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

getMethodAt () method
public function getMethodAt(index:int):EffectMethodBase

Parameters

index:int

Returns
EffectMethodBase
hasMethod () method
public function hasMethod(method:EffectMethodBase):Boolean

Parameters

method:EffectMethodBase

Returns
Boolean
invalidateScreenPasses () method
protected function invalidateScreenPasses():void

removeMethod () method
public function removeMethod(method:EffectMethodBase):void

Parameters

method:EffectMethodBase

updateMaterial () method
override arcane function updateMaterial(context:Context3D):void

Parameters

context:Context3D

updateScreenPasses () method
protected function updateScreenPasses():void


away3d.materials.SegmentMaterial

SegmentMaterial | Properties | Methods | Constants
Package | away3d.materials
Class | public class SegmentMaterial
Inheritance | SegmentMaterial Inheritance MaterialBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

SegmentMaterial is a material exclusively used to render wireframe object

See also

away3d.entities.Lines

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean Indicates whether visible textures (or other pixels) used by this material have already been premultiplied. | MaterialBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | MaterialBase
Inherited | blendMode : String The blend mode to use when drawing this renderable. | MaterialBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialBase
Inherited | depthCompareMode : String | MaterialBase
Inherited | extra : Object An object to contain any extra data | MaterialBase
Inherited | lightPicker : LightPickerBase | MaterialBase
Inherited | mipmap : Boolean Indicates whether or not any used textures should use mipmapping. | MaterialBase
Inherited | name : String [override] | MaterialBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | repeat : Boolean Indicates whether or not any used textures should be tiled. | MaterialBase
Inherited | requiresBlending : Boolean [read-only] Indicates whether or not the material requires alpha blending during rendering. | MaterialBase
Inherited | smooth : Boolean Indicates whether or not any used textures should use smoothing. | MaterialBase
Inherited | uniqueId : uint [read-only] The unique id assigned to the material by the MaterialLibrary. | MaterialBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _depthPass : DepthMapPass | MaterialBase
Inherited | _distancePass : DistanceMapPass | MaterialBase
Inherited | _lightPicker : LightPickerBase | MaterialBase
Inherited | _mipmap : Boolean = true | MaterialBase
Inherited | _numPasses : uint | MaterialBase
Inherited | _passes : Vector.<MaterialPassBase> | MaterialBase
Inherited | _repeat : Boolean | MaterialBase
Inherited | _smooth : Boolean = true | MaterialBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SegmentMaterial(thickness:Number = 1.25) Creates a new WireframeMaterial object. | SegmentMaterial
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up any resources used by the current object. | MaterialBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addPass(pass:MaterialPassBase):void Adds a pass to the material | MaterialBase
Inherited | clearPasses():void Clears all passes in the material. | MaterialBase
Inherited | removePass(pass:MaterialPassBase):void | MaterialBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
SegmentMaterial () Constructor
public function SegmentMaterial(thickness:Number = 1.25)

Creates a new WireframeMaterial object.

Parameters
thickness:Number (default = 1.25)


away3d.materials.SinglePassMaterialBase

SinglePassMaterialBase | Properties | Methods | Constants
Package | away3d.materials
Class | public class SinglePassMaterialBase
Inheritance | SinglePassMaterialBase Inheritance MaterialBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | ColorMaterial, TextureMaterial

DefaultMaterialBase forms an abstract base class for the default materials provided by Away3D and use methods to define their appearance.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alphaBlending : Boolean Indicate whether or not the material has transparency. | SinglePassMaterialBase
Inherited | alphaPremultiplied : Boolean Indicates whether visible textures (or other pixels) used by this material have already been premultiplied. | MaterialBase
 | alphaThreshold : Number The minimum alpha value for which pixels should be drawn. | SinglePassMaterialBase
 | ambient : Number The strength of the ambient reflection. | SinglePassMaterialBase
 | ambientColor : uint The colour of the ambient reflection. | SinglePassMaterialBase
 | ambientMethod : BasicAmbientMethod The method to perform ambient shading. | SinglePassMaterialBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | MaterialBase
 | blendMode : String [override] | SinglePassMaterialBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialBase
 | colorTransform : ColorTransform The ColorTransform object to transform the colour of the material with. | SinglePassMaterialBase
 | depthCompareMode : String [override] | SinglePassMaterialBase
 | diffuseLightSources : uint | SinglePassMaterialBase
 | diffuseMethod : BasicDiffuseMethod The method to perform diffuse shading. | SinglePassMaterialBase
Inherited | extra : Object An object to contain any extra data | MaterialBase
 | gloss : Number The sharpness of the specular highlight. | SinglePassMaterialBase
 | lightPicker : LightPickerBase [override] | SinglePassMaterialBase
 | mipmap : Boolean [override] Indicates whether or not any used textures should use mipmapping. | SinglePassMaterialBase
Inherited | name : String [override] | MaterialBase
 | normalMap : Texture2DBase The tangent space normal map to influence the direction of the surface for each texel. | SinglePassMaterialBase
 | normalMethod : BasicNormalMethod The method to generate the (tangent-space) normal. | SinglePassMaterialBase
 | numMethods : int [read-only] | SinglePassMaterialBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | repeat : Boolean Indicates whether or not any used textures should be tiled. | MaterialBase
 | requiresBlending : Boolean [override] [read-only] Indicates whether or not the material requires alpha blending during rendering. | SinglePassMaterialBase
 | shadowMethod : ShadowMapMethodBase The method to render shadows cast on this surface. | SinglePassMaterialBase
Inherited | smooth : Boolean Indicates whether or not any used textures should use smoothing. | MaterialBase
 | specular : Number The overall strength of the specular reflection. | SinglePassMaterialBase
 | specularColor : uint The colour of the specular reflection. | SinglePassMaterialBase
 | specularLightSources : uint | SinglePassMaterialBase
 | specularMap : Texture2DBase A specular map that defines the strength of specular reflections for each texel in the red channel, and the gloss factor in the green channel. | SinglePassMaterialBase
 | specularMethod : BasicSpecularMethod The method to perform specular shading. | SinglePassMaterialBase
Inherited | uniqueId : uint [read-only] The unique id assigned to the material by the MaterialLibrary. | MaterialBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _depthPass : DepthMapPass | MaterialBase
Inherited | _distancePass : DistanceMapPass | MaterialBase
Inherited | _lightPicker : LightPickerBase | MaterialBase
Inherited | _mipmap : Boolean = true | MaterialBase
Inherited | _numPasses : uint | MaterialBase
Inherited | _passes : Vector.<MaterialPassBase> | MaterialBase
Inherited | _repeat : Boolean | MaterialBase
 | _screenPass : SuperShaderPass | SinglePassMaterialBase
Inherited | _smooth : Boolean = true | MaterialBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SinglePassMaterialBase() Creates a new DefaultMaterialBase object. | SinglePassMaterialBase
 | addMethod(method:EffectMethodBase):void Adds a shading method to the end of the shader. | SinglePassMaterialBase
 | addMethodAt(method:EffectMethodBase, index:int):void Adds a shading method to the end of a shader, at the specified index amongst the methods in that section of the shader. | SinglePassMaterialBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up any resources used by the current object. | MaterialBase
 | getMethodAt(index:int):EffectMethodBase | SinglePassMaterialBase
 | hasMethod(method:EffectMethodBase):Boolean | SinglePassMaterialBase
 | removeMethod(method:EffectMethodBase):void | SinglePassMaterialBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addPass(pass:MaterialPassBase):void Adds a pass to the material | MaterialBase
Inherited | clearPasses():void Clears all passes in the material. | MaterialBase
Inherited | removePass(pass:MaterialPassBase):void | MaterialBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_screenPass property
protected var _screenPass:SuperShaderPass

alphaBlending property
alphaBlending:Boolean

Indicate whether or not the material has transparency. If binary transparency is sufficient, for example when using textures of foliage, consider using alphaThreshold instead.

Implementation
    public function get alphaBlending():Boolean
    public function set alphaBlending(value:Boolean):void
alphaThreshold property
alphaThreshold:Number

The minimum alpha value for which pixels should be drawn. This is used for transparency that is either invisible or entirely opaque, often used with textures for foliage, etc. Recommended values are 0 to disable alpha, or 0.5 to create smooth edges. Default value is 0 (disabled).

Implementation
    public function get alphaThreshold():Number
    public function set alphaThreshold(value:Number):void
ambient property
ambient:Number

The strength of the ambient reflection.

Implementation
    public function get ambient():Number
    public function set ambient(value:Number):void
ambientColor property
ambientColor:uint

The colour of the ambient reflection.

Implementation
    public function get ambientColor():uint
    public function set ambientColor(value:uint):void
ambientMethod property
ambientMethod:BasicAmbientMethod

The method to perform ambient shading. Note that shading methods cannot be reused across materials.

Implementation
    public function get ambientMethod():BasicAmbientMethod
    public function set ambientMethod(value:BasicAmbientMethod):void
blendMode property
blendMode:String[override]

Implementation
    public function get blendMode():String
    public function set blendMode(value:String):void
colorTransform property
colorTransform:ColorTransform

The ColorTransform object to transform the colour of the material with.

Implementation
    public function get colorTransform():ColorTransform
    public function set colorTransform(value:ColorTransform):void
depthCompareMode property
depthCompareMode:String[override]

Implementation
    public function get depthCompareMode():String
    public function set depthCompareMode(value:String):void
diffuseLightSources property
diffuseLightSources:uint

Implementation
    public function get diffuseLightSources():uint
    public function set diffuseLightSources(value:uint):void
diffuseMethod property
diffuseMethod:BasicDiffuseMethod

The method to perform diffuse shading. Note that shading methods can not be reused across materials.

Implementation
    public function get diffuseMethod():BasicDiffuseMethod
    public function set diffuseMethod(value:BasicDiffuseMethod):void
gloss property
gloss:Number

The sharpness of the specular highlight.

Implementation
    public function get gloss():Number
    public function set gloss(value:Number):void
lightPicker property
lightPicker:LightPickerBase[override]

Implementation
    public function get lightPicker():LightPickerBase
    public function set lightPicker(value:LightPickerBase):void
mipmap property
mipmap:Boolean[override]

Indicates whether or not any used textures should use mipmapping.

Implementation
    public function get mipmap():Boolean
    public function set mipmap(value:Boolean):void
normalMap property
normalMap:Texture2DBase

The tangent space normal map to influence the direction of the surface for each texel.

Implementation
    public function get normalMap():Texture2DBase
    public function set normalMap(value:Texture2DBase):void
normalMethod property
normalMethod:BasicNormalMethod

The method to generate the (tangent-space) normal. Note that shading methods can not be reused across materials.

Implementation
    public function get normalMethod():BasicNormalMethod
    public function set normalMethod(value:BasicNormalMethod):void
numMethods property
numMethods:int [read-only]

Implementation
    public function get numMethods():int
requiresBlending property
requiresBlending:Boolean [read-only] [override]

Indicates whether or not the material requires alpha blending during rendering.

Implementation
    public function get requiresBlending():Boolean
shadowMethod property
shadowMethod:ShadowMapMethodBase

The method to render shadows cast on this surface. Note that shading methods can not be reused across materials.

Implementation
    public function get shadowMethod():ShadowMapMethodBase
    public function set shadowMethod(value:ShadowMapMethodBase):void
specular property
specular:Number

The overall strength of the specular reflection.

Implementation
    public function get specular():Number
    public function set specular(value:Number):void
specularColor property
specularColor:uint

The colour of the specular reflection.

Implementation
    public function get specularColor():uint
    public function set specularColor(value:uint):void
specularLightSources property
specularLightSources:uint

Implementation
    public function get specularLightSources():uint
    public function set specularLightSources(value:uint):void
specularMap property
specularMap:Texture2DBase

A specular map that defines the strength of specular reflections for each texel in the red channel, and the gloss factor in the green channel. You can use SpecularBitmapTexture if you want to easily set specular and gloss maps from greyscale images, but prepared images are preffered.

Implementation
    public function get specularMap():Texture2DBase
    public function set specularMap(value:Texture2DBase):void
specularMethod property
specularMethod:BasicSpecularMethod

The method to perform specular shading. Note that shading methods can not be reused across materials.

Implementation
    public function get specularMethod():BasicSpecularMethod
    public function set specularMethod(value:BasicSpecularMethod):void
Constructor Detail
SinglePassMaterialBase () Constructor
public function SinglePassMaterialBase()

Creates a new DefaultMaterialBase object.

Method Detail
activateForDepth () method
override arcane function activateForDepth(stage3DProxy:Stage3DProxy, camera:Camera3D, distanceBased:Boolean = false, textureRatioX:Number = 1, textureRatioY:Number = 1):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
distanceBased:Boolean (default = false)
textureRatioX:Number (default = 1)
textureRatioY:Number (default = 1)

addMethod () method
public function addMethod(method:EffectMethodBase):void

Adds a shading method to the end of the shader. Note that shading methods can not be reused across materials.

Parameters

method:EffectMethodBase

addMethodAt () method
public function addMethodAt(method:EffectMethodBase, index:int):void

Adds a shading method to the end of a shader, at the specified index amongst the methods in that section of the shader. Note that shading methods can not be reused across materials.

Parameters

method:EffectMethodBase
index:int

getMethodAt () method
public function getMethodAt(index:int):EffectMethodBase

Parameters

index:int

Returns
EffectMethodBase
hasMethod () method
public function hasMethod(method:EffectMethodBase):Boolean

Parameters

method:EffectMethodBase

Returns
Boolean
removeMethod () method
public function removeMethod(method:EffectMethodBase):void

Parameters

method:EffectMethodBase

updateMaterial () method
override arcane function updateMaterial(context:Context3D):void

Parameters

context:Context3D


away3d.materials.SkyBoxMaterial

SkyBoxMaterial | Properties | Methods | Constants
Package | away3d.materials
Class | public class SkyBoxMaterial
Inheritance | SkyBoxMaterial Inheritance MaterialBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

SkyBoxMaterial is a material exclusively used to render skyboxes

See also

away3d.primitives.SkyBox

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean Indicates whether visible textures (or other pixels) used by this material have already been premultiplied. | MaterialBase
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | MaterialBase
Inherited | blendMode : String The blend mode to use when drawing this renderable. | MaterialBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialBase
 | cubeMap : CubeTextureBase The CubeMap to use as the skybox. | SkyBoxMaterial
Inherited | depthCompareMode : String | MaterialBase
Inherited | extra : Object An object to contain any extra data | MaterialBase
Inherited | lightPicker : LightPickerBase | MaterialBase
Inherited | mipmap : Boolean Indicates whether or not any used textures should use mipmapping. | MaterialBase
Inherited | name : String [override] | MaterialBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | repeat : Boolean Indicates whether or not any used textures should be tiled. | MaterialBase
Inherited | requiresBlending : Boolean [read-only] Indicates whether or not the material requires alpha blending during rendering. | MaterialBase
Inherited | smooth : Boolean Indicates whether or not any used textures should use smoothing. | MaterialBase
Inherited | uniqueId : uint [read-only] The unique id assigned to the material by the MaterialLibrary. | MaterialBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _depthPass : DepthMapPass | MaterialBase
Inherited | _distancePass : DistanceMapPass | MaterialBase
Inherited | _lightPicker : LightPickerBase | MaterialBase
Inherited | _mipmap : Boolean = true | MaterialBase
Inherited | _numPasses : uint | MaterialBase
Inherited | _passes : Vector.<MaterialPassBase> | MaterialBase
Inherited | _repeat : Boolean | MaterialBase
Inherited | _smooth : Boolean = true | MaterialBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkyBoxMaterial(cubeMap:CubeTextureBase) Creates a new SkyBoxMaterial object. | SkyBoxMaterial
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up any resources used by the current object. | MaterialBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addPass(pass:MaterialPassBase):void Adds a pass to the material | MaterialBase
Inherited | clearPasses():void Clears all passes in the material. | MaterialBase
Inherited | removePass(pass:MaterialPassBase):void | MaterialBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
cubeMap property
cubeMap:CubeTextureBase

The CubeMap to use as the skybox.

Implementation
    public function get cubeMap():CubeTextureBase
    public function set cubeMap(value:CubeTextureBase):void
Constructor Detail
SkyBoxMaterial () Constructor
public function SkyBoxMaterial(cubeMap:CubeTextureBase)

Creates a new SkyBoxMaterial object.

Parameters
cubeMap:CubeTextureBase — The CubeMap to use as the skybox.


away3d.materials.TextureMaterial

TextureMaterial | Properties | Methods | Constants
Package | away3d.materials
Class | public class TextureMaterial
Inheritance | TextureMaterial Inheritance SinglePassMaterialBase Inheritance MaterialBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

TextureMaterial is a material that uses a texture as the surface's diffuse colour.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alpha : Number The alpha of the surface. | TextureMaterial
Inherited | alphaBlending : Boolean Indicate whether or not the material has transparency. | SinglePassMaterialBase
Inherited | alphaPremultiplied : Boolean Indicates whether visible textures (or other pixels) used by this material have already been premultiplied. | MaterialBase
Inherited | alphaThreshold : Number The minimum alpha value for which pixels should be drawn. | SinglePassMaterialBase
Inherited | ambient : Number The strength of the ambient reflection. | SinglePassMaterialBase
Inherited | ambientColor : uint The colour of the ambient reflection. | SinglePassMaterialBase
Inherited | ambientMethod : BasicAmbientMethod The method to perform ambient shading. | SinglePassMaterialBase
 | ambientTexture : Texture2DBase The texture object to use for the ambient colour. | TextureMaterial
 | animateUVs : Boolean | TextureMaterial
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | MaterialBase
Inherited | blendMode : String [override] | SinglePassMaterialBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialBase
Inherited | colorTransform : ColorTransform The ColorTransform object to transform the colour of the material with. | SinglePassMaterialBase
Inherited | depthCompareMode : String [override] | SinglePassMaterialBase
Inherited | diffuseLightSources : uint | SinglePassMaterialBase
Inherited | diffuseMethod : BasicDiffuseMethod The method to perform diffuse shading. | SinglePassMaterialBase
Inherited | extra : Object An object to contain any extra data | MaterialBase
Inherited | gloss : Number The sharpness of the specular highlight. | SinglePassMaterialBase
Inherited | lightPicker : LightPickerBase [override] | SinglePassMaterialBase
Inherited | mipmap : Boolean [override] Indicates whether or not any used textures should use mipmapping. | SinglePassMaterialBase
Inherited | name : String [override] | MaterialBase
Inherited | normalMap : Texture2DBase The tangent space normal map to influence the direction of the surface for each texel. | SinglePassMaterialBase
Inherited | normalMethod : BasicNormalMethod The method to generate the (tangent-space) normal. | SinglePassMaterialBase
Inherited | numMethods : int [read-only] | SinglePassMaterialBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | repeat : Boolean Indicates whether or not any used textures should be tiled. | MaterialBase
Inherited | requiresBlending : Boolean [override] [read-only] Indicates whether or not the material requires alpha blending during rendering. | SinglePassMaterialBase
Inherited | shadowMethod : ShadowMapMethodBase The method to render shadows cast on this surface. | SinglePassMaterialBase
Inherited | smooth : Boolean Indicates whether or not any used textures should use smoothing. | MaterialBase
Inherited | specular : Number The overall strength of the specular reflection. | SinglePassMaterialBase
Inherited | specularColor : uint The colour of the specular reflection. | SinglePassMaterialBase
Inherited | specularLightSources : uint | SinglePassMaterialBase
Inherited | specularMap : Texture2DBase A specular map that defines the strength of specular reflections for each texel in the red channel, and the gloss factor in the green channel. | SinglePassMaterialBase
Inherited | specularMethod : BasicSpecularMethod The method to perform specular shading. | SinglePassMaterialBase
 | texture : Texture2DBase The texture object to use for the albedo colour. | TextureMaterial
Inherited | uniqueId : uint [read-only] The unique id assigned to the material by the MaterialLibrary. | MaterialBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _depthPass : DepthMapPass | MaterialBase
Inherited | _distancePass : DistanceMapPass | MaterialBase
Inherited | _lightPicker : LightPickerBase | MaterialBase
Inherited | _mipmap : Boolean = true | MaterialBase
Inherited | _numPasses : uint | MaterialBase
Inherited | _passes : Vector.<MaterialPassBase> | MaterialBase
Inherited | _repeat : Boolean | MaterialBase
Inherited | _screenPass : SuperShaderPass | SinglePassMaterialBase
Inherited | _smooth : Boolean = true | MaterialBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | TextureMaterial(texture:Texture2DBase = null, smooth:Boolean = true, repeat:Boolean = false, mipmap:Boolean = true) Creates a new TextureMaterial. | TextureMaterial
Inherited | addMethod(method:EffectMethodBase):void Adds a shading method to the end of the shader. | SinglePassMaterialBase
Inherited | addMethodAt(method:EffectMethodBase, index:int):void Adds a shading method to the end of a shader, at the specified index amongst the methods in that section of the shader. | SinglePassMaterialBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up any resources used by the current object. | MaterialBase
Inherited | getMethodAt(index:int):EffectMethodBase | SinglePassMaterialBase
Inherited | hasMethod(method:EffectMethodBase):Boolean | SinglePassMaterialBase
Inherited | removeMethod(method:EffectMethodBase):void | SinglePassMaterialBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addPass(pass:MaterialPassBase):void Adds a pass to the material | MaterialBase
Inherited | clearPasses():void Clears all passes in the material. | MaterialBase
Inherited | removePass(pass:MaterialPassBase):void | MaterialBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
alpha property
alpha:Number

The alpha of the surface.

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
ambientTexture property
ambientTexture:Texture2DBase

The texture object to use for the ambient colour.

Implementation
    public function get ambientTexture():Texture2DBase
    public function set ambientTexture(value:Texture2DBase):void
animateUVs property
animateUVs:Boolean

Implementation
    public function get animateUVs():Boolean
    public function set animateUVs(value:Boolean):void
texture property
texture:Texture2DBase

The texture object to use for the albedo colour.

Implementation
    public function get texture():Texture2DBase
    public function set texture(value:Texture2DBase):void
Constructor Detail
TextureMaterial () Constructor
public function TextureMaterial(texture:Texture2DBase = null, smooth:Boolean = true, repeat:Boolean = false, mipmap:Boolean = true)

Creates a new TextureMaterial.

Parameters
texture:Texture2DBase (default = null)
smooth:Boolean (default = true)
repeat:Boolean (default = false)
mipmap:Boolean (default = true)


away3d.materials.TextureMultiPassMaterial

TextureMultiPassMaterial | Properties | Methods | Constants
Package | away3d.materials
Class | public class TextureMultiPassMaterial
Inheritance | TextureMultiPassMaterial Inheritance MultiPassMaterialBase Inheritance MaterialBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean Indicates whether visible textures (or other pixels) used by this material have already been premultiplied. | MaterialBase
Inherited | alphaThreshold : Number The minimum alpha value for which pixels should be drawn. | MultiPassMaterialBase
Inherited | ambient : Number The strength of the ambient reflection. | MultiPassMaterialBase
Inherited | ambientColor : uint The colour of the ambient reflection. | MultiPassMaterialBase
Inherited | ambientMethod : BasicAmbientMethod The method to perform ambient shading. | MultiPassMaterialBase
 | ambientTexture : Texture2DBase The texture object to use for the ambient colour. | TextureMultiPassMaterial
 | animateUVs : Boolean | TextureMultiPassMaterial
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | MaterialBase
Inherited | blendMode : String [override] | MultiPassMaterialBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialBase
Inherited | depthCompareMode : String [override] | MultiPassMaterialBase
Inherited | diffuseLightSources : uint | MultiPassMaterialBase
Inherited | diffuseMethod : BasicDiffuseMethod The method to perform diffuse shading. | MultiPassMaterialBase
Inherited | extra : Object An object to contain any extra data | MaterialBase
Inherited | gloss : Number The sharpness of the specular highlight. | MultiPassMaterialBase
Inherited | lightPicker : LightPickerBase [override] | MultiPassMaterialBase
Inherited | mipmap : Boolean [override] Indicates whether or not any used textures should use mipmapping. | MultiPassMaterialBase
Inherited | name : String [override] | MaterialBase
Inherited | normalMap : Texture2DBase The tangent space normal map to influence the direction of the surface for each texel. | MultiPassMaterialBase
Inherited | normalMethod : BasicNormalMethod The method to generate the (tangent-space) normal. | MultiPassMaterialBase
Inherited | numMethods : int [read-only] | MultiPassMaterialBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | repeat : Boolean Indicates whether or not any used textures should be tiled. | MaterialBase
Inherited | requiresBlending : Boolean [override] [read-only] Indicates whether or not the material requires alpha blending during rendering. | MultiPassMaterialBase
Inherited | shadowMethod : ShadowMapMethodBase The method to render shadows cast on this surface. | MultiPassMaterialBase
Inherited | smooth : Boolean Indicates whether or not any used textures should use smoothing. | MaterialBase
Inherited | specular : Number The overall strength of the specular reflection. | MultiPassMaterialBase
Inherited | specularColor : uint The colour of the specular reflection. | MultiPassMaterialBase
Inherited | specularLightSources : uint | MultiPassMaterialBase
Inherited | specularMap : Texture2DBase A specular map that defines the strength of specular reflections for each texel in the red channel, and the gloss factor in the green channel. | MultiPassMaterialBase
Inherited | specularMethod : BasicSpecularMethod The method to perform specular shading. | MultiPassMaterialBase
 | texture : Texture2DBase The texture object to use for the albedo colour. | TextureMultiPassMaterial
Inherited | uniqueId : uint [read-only] The unique id assigned to the material by the MaterialLibrary. | MaterialBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _casterLightPass : ShadowCasterPass | MultiPassMaterialBase
Inherited | _depthPass : DepthMapPass | MaterialBase
Inherited | _distancePass : DistanceMapPass | MaterialBase
Inherited | _effectsPass : SuperShaderPass | MultiPassMaterialBase
Inherited | _lightPicker : LightPickerBase | MaterialBase
Inherited | _mipmap : Boolean = true | MaterialBase
Inherited | _nonCasterLightPasses : Vector.<LightingPass> | MultiPassMaterialBase
Inherited | _numPasses : uint | MaterialBase
Inherited | _passes : Vector.<MaterialPassBase> | MaterialBase
Inherited | _repeat : Boolean | MaterialBase
Inherited | _smooth : Boolean = true | MaterialBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | TextureMultiPassMaterial(texture:Texture2DBase = null, smooth:Boolean = true, repeat:Boolean = false, mipmap:Boolean = true) | TextureMultiPassMaterial
Inherited | addMethod(method:EffectMethodBase):void Adds a shading method to the end of the shader. | MultiPassMaterialBase
Inherited | addMethodAt(method:EffectMethodBase, index:int):void Adds a shading method to the end of a shader, at the specified index amongst the methods in that section of the shader. | MultiPassMaterialBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up any resources used by the current object. | MaterialBase
Inherited | getMethodAt(index:int):EffectMethodBase | MultiPassMaterialBase
Inherited | hasMethod(method:EffectMethodBase):Boolean | MultiPassMaterialBase
Inherited | removeMethod(method:EffectMethodBase):void | MultiPassMaterialBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addPass(pass:MaterialPassBase):void Adds a pass to the material | MaterialBase
Inherited | clearPasses():void Clears all passes in the material. | MaterialBase
Inherited | invalidateScreenPasses():void | MultiPassMaterialBase
Inherited | removePass(pass:MaterialPassBase):void | MaterialBase
 | updateScreenPasses():void [override] | TextureMultiPassMaterial
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
ambientTexture property
ambientTexture:Texture2DBase

The texture object to use for the ambient colour.

Implementation
    public function get ambientTexture():Texture2DBase
    public function set ambientTexture(value:Texture2DBase):void
animateUVs property
animateUVs:Boolean

Implementation
    public function get animateUVs():Boolean
    public function set animateUVs(value:Boolean):void
texture property
texture:Texture2DBase

The texture object to use for the albedo colour.

Implementation
    public function get texture():Texture2DBase
    public function set texture(value:Texture2DBase):void
Constructor Detail
TextureMultiPassMaterial () Constructor
public function TextureMultiPassMaterial(texture:Texture2DBase = null, smooth:Boolean = true, repeat:Boolean = false, mipmap:Boolean = true)

Parameters
texture:Texture2DBase (default = null)
smooth:Boolean (default = true)
repeat:Boolean (default = false)
mipmap:Boolean (default = true)
Method Detail
updateScreenPasses () method
override protected function updateScreenPasses():void


away3d.materials.compilation - Away3D Documentation

Package away3d.materials.compilation

Classes
LightingShaderCompiler
MethodDependencyCounter
ShaderCompiler
ShaderRegisterCache
ShaderRegisterData
ShaderRegisterElement
SuperShaderCompiler


away3d.materials.compilation Summary

away3d.materials.compilation | Classes

Classes
Class | Description
LightingShaderCompiler |
MethodDependencyCounter |
ShaderCompiler |
ShaderRegisterCache | ShaderRegister Cache provides the usage management system for all registers during shading compilation.
ShaderRegisterData |
ShaderRegisterElement | A single register element (an entire register or a single register's component) used by the RegisterPool.
SuperShaderCompiler |

Thu Nov 15 2012, 12:09 PM Z


away3d.materials.compilation.LightingShaderCompiler

LightingShaderCompiler | Properties | Methods
Package | away3d.materials.compilation
Class | public class LightingShaderCompiler
Inheritance | LightingShaderCompiler Inheritance ShaderCompiler Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean | ShaderCompiler
Inherited | animatableAttributes : Vector.<String> [read-only] | ShaderCompiler
Inherited | animateUVs : Boolean | ShaderCompiler
Inherited | animationTargetRegisters : Vector.<String> [read-only] | ShaderCompiler
Inherited | cameraPositionIndex : int [read-only] | ShaderCompiler
Inherited | commonsDataIndex : int [read-only] | ShaderCompiler
Inherited | diffuseLightSources : uint | ShaderCompiler
 | _dirLightFragmentConstants : Vector.<ShaderRegisterElement> | LightingShaderCompiler
 | _dirLightVertexConstants : Vector.<ShaderRegisterElement> | LightingShaderCompiler
Inherited | fragmentCode : String [read-only] | ShaderCompiler
Inherited | fragmentLightCode : String [read-only] | ShaderCompiler
Inherited | framentPostLightCode : String [read-only] | ShaderCompiler
Inherited | lightFragmentConstantIndex : int [read-only] | ShaderCompiler
Inherited | lightProbeDiffuseIndices : Vector.<uint> [read-only] | ShaderCompiler
Inherited | lightProbeSpecularIndices : Vector.<uint> [read-only] | ShaderCompiler
 | lightVertexConstantIndex : int [read-only] | LightingShaderCompiler
Inherited | methodSetup : ShaderMethodSetup | ShaderCompiler
Inherited | needUVAnimation : Boolean [read-only] | ShaderCompiler
Inherited | normalBufferIndex : int [read-only] | ShaderCompiler
Inherited | numDirectionalLights : uint | ShaderCompiler
Inherited | numLightProbes : uint | ShaderCompiler
Inherited | numPointLights : uint | ShaderCompiler
Inherited | numUsedFragmentConstants : uint [read-only] | ShaderCompiler
Inherited | numUsedStreams : uint [read-only] | ShaderCompiler
Inherited | numUsedTextures : uint [read-only] | ShaderCompiler
Inherited | numUsedVaryings : uint [read-only] | ShaderCompiler
Inherited | numUsedVertexConstants : uint [read-only] | ShaderCompiler
 | _pointLightFragmentConstants : Vector.<ShaderRegisterElement> | LightingShaderCompiler
 | _pointLightVertexConstants : Vector.<ShaderRegisterElement> | LightingShaderCompiler
Inherited | preserveAlpha : Boolean | ShaderCompiler
Inherited | probeWeightsIndex : int [read-only] | ShaderCompiler
Inherited | sceneMatrixIndex : int [read-only] | ShaderCompiler
Inherited | sceneNormalMatrixIndex : int [read-only] | ShaderCompiler
Inherited | secondaryUVBufferIndex : int [read-only] | ShaderCompiler
Inherited | shadedTarget : String [read-only] | ShaderCompiler
Inherited | specularLightSources : uint | ShaderCompiler
Inherited | tangentBufferIndex : int [read-only] | ShaderCompiler
 | tangentSpace : Boolean [read-only] | LightingShaderCompiler
Inherited | usesNormals : Boolean [read-only] | ShaderCompiler
Inherited | usingSpecularMethod : Boolean [read-only] | ShaderCompiler
Inherited | uvBufferIndex : int [read-only] | ShaderCompiler
Inherited | UVSource : String [read-only] | ShaderCompiler
Inherited | UVTarget : String [read-only] | ShaderCompiler
Inherited | uvTransformIndex : int [read-only] | ShaderCompiler
Inherited | vertexCode : String [read-only] | ShaderCompiler
Inherited | vertexConstantsOffset : uint [read-only] | ShaderCompiler
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaPremultiplied : Boolean | ShaderCompiler
Inherited | _animatableAttributes : Vector.<String> | ShaderCompiler
Inherited | _animateUVs : Boolean | ShaderCompiler
Inherited | _animationTargetRegisters : Vector.<String> | ShaderCompiler
Inherited | _cameraPositionIndex : int = -1 | ShaderCompiler
Inherited | _combinedLightSources : uint | ShaderCompiler
Inherited | _dependencyCounter : MethodDependencyCounter | ShaderCompiler
Inherited | _diffuseLightSources : uint | ShaderCompiler
Inherited | _fragmentCode : String | ShaderCompiler
Inherited | _fragmentConstantData : Vector.<Number> | ShaderCompiler
Inherited | _fragmentLightCode : String | ShaderCompiler
Inherited | _framentPostLightCode : String | ShaderCompiler
Inherited | _lightFragmentConstantIndex : int = -1 | ShaderCompiler
Inherited | _lightProbeDiffuseIndices : Vector.<uint> | ShaderCompiler
Inherited | _lightProbeSpecularIndices : Vector.<uint> | ShaderCompiler
Inherited | _methodSetup : ShaderMethodSetup | ShaderCompiler
Inherited | _mipmap : Boolean | ShaderCompiler
Inherited | _needUVAnimation : Boolean | ShaderCompiler
Inherited | _normalBufferIndex : int = -1 | ShaderCompiler
Inherited | _numDirectionalLights : uint | ShaderCompiler
Inherited | _numLightProbes : uint | ShaderCompiler
Inherited | _numLights : int | ShaderCompiler
Inherited | _numPointLights : uint | ShaderCompiler
Inherited | _numProbeRegisters : Number | ShaderCompiler
Inherited | _preserveAlpha : Boolean = true | ShaderCompiler
Inherited | _probeWeightsIndex : int = -1 | ShaderCompiler
Inherited | _registerCache : ShaderRegisterCache | ShaderCompiler
Inherited | _repeat : Boolean | ShaderCompiler
Inherited | _sceneMatrixIndex : int = -1 | ShaderCompiler
Inherited | _sceneNormalMatrixIndex : int = -1 | ShaderCompiler
Inherited | _secondaryUVBufferIndex : int = -1 | ShaderCompiler
Inherited | _sharedRegisters : ShaderRegisterData | ShaderCompiler
Inherited | _smooth : Boolean | ShaderCompiler
Inherited | _specularLightSources : uint | ShaderCompiler
Inherited | _tangentBufferIndex : int = -1 | ShaderCompiler
Inherited | _usingSpecularMethod : Boolean | ShaderCompiler
Inherited | _uvBufferIndex : int = -1 | ShaderCompiler
Inherited | _UVSource : String | ShaderCompiler
Inherited | _UVTarget : String | ShaderCompiler
Inherited | _uvTransformIndex : int = -1 | ShaderCompiler
Inherited | _vertexCode : String | ShaderCompiler
Inherited | _vertexConstantData : Vector.<Number> | ShaderCompiler
Inherited | _vertexConstantsOffset : uint | ShaderCompiler
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | LightingShaderCompiler() | LightingShaderCompiler
Inherited | compile():void | ShaderCompiler
Inherited | dispose():void | ShaderCompiler
Inherited | setConstantDataBuffers(vertexConstantData:Vector.<Number>, fragmentConstantData:Vector.<Number>):void | ShaderCompiler
Inherited | setTextureSampling(smooth:Boolean, repeat:Boolean, mipmap:Boolean):void | ShaderCompiler
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | calculateDependencies():void [override] Calculates register dependencies for commonly used data. | LightingShaderCompiler
Inherited | compileGlobalPositionCode():void | ShaderCompiler
 | compileLightingCode():void [override] | LightingShaderCompiler
Inherited | compileMethods():void | ShaderCompiler
 | compileMethodsCode():void [override] | LightingShaderCompiler
 | compileNormalCode():void [override] | LightingShaderCompiler
 | compileViewDirCode():void [override] | LightingShaderCompiler
 | createNormalRegisters():void | LightingShaderCompiler
 | initLightData():void [override] | LightingShaderCompiler
 | initRegisterIndices():void [override] | LightingShaderCompiler
Inherited | usesLights():Boolean | ShaderCompiler
Inherited | usesLightsForDiffuse():Boolean | ShaderCompiler
Inherited | usesLightsForSpecular():Boolean | ShaderCompiler
Inherited | usesProbes():Boolean | ShaderCompiler
Inherited | usesProbesForDiffuse():Boolean | ShaderCompiler
Inherited | usesProbesForSpecular():Boolean | ShaderCompiler
Property Detail
_dirLightFragmentConstants property
public var _dirLightFragmentConstants:Vector.<ShaderRegisterElement>

_dirLightVertexConstants property
public var _dirLightVertexConstants:Vector.<ShaderRegisterElement>

_pointLightFragmentConstants property
public var _pointLightFragmentConstants:Vector.<ShaderRegisterElement>

_pointLightVertexConstants property
public var _pointLightVertexConstants:Vector.<ShaderRegisterElement>

lightVertexConstantIndex property
lightVertexConstantIndex:int [read-only]

Implementation
    public function get lightVertexConstantIndex():int
tangentSpace property
tangentSpace:Boolean [read-only]

Implementation
    public function get tangentSpace():Boolean
Constructor Detail
LightingShaderCompiler () Constructor
public function LightingShaderCompiler()

Method Detail
calculateDependencies () method
override protected function calculateDependencies():void

Calculates register dependencies for commonly used data.

compileLightingCode () method
override protected function compileLightingCode():void

compileMethodsCode () method
override protected function compileMethodsCode():void

compileNormalCode () method
override protected function compileNormalCode():void

compileViewDirCode () method
override protected function compileViewDirCode():void

createNormalRegisters () method
protected function createNormalRegisters():void

initLightData () method
override protected function initLightData():void

initRegisterIndices () method
override protected function initRegisterIndices():void


away3d.materials.compilation.MethodDependencyCounter

MethodDependencyCounter | Properties | Methods
Package | away3d.materials.compilation
Class | public class MethodDependencyCounter
Inheritance | MethodDependencyCounter Inheritance Object

Public Properties
Property |  | Defined By
 | globalPosDependencies : uint [read-only] | MethodDependencyCounter
 | normalDependencies : uint [read-only] | MethodDependencyCounter
 | projectionDependencies : uint [read-only] | MethodDependencyCounter
 | secondaryUVDependencies : uint [read-only] | MethodDependencyCounter
 | tangentDependencies : uint [read-only] | MethodDependencyCounter
 | usesGlobalPosFragment : Boolean [read-only] | MethodDependencyCounter
 | uvDependencies : uint [read-only] | MethodDependencyCounter
 | viewDirDependencies : uint [read-only] | MethodDependencyCounter
Public Methods
Method |  | Defined By
 | MethodDependencyCounter() | MethodDependencyCounter
 | addWorldSpaceDependencies(fragmentLights:Boolean):void | MethodDependencyCounter
 | includeMethodVO(methodVO:MethodVO):void | MethodDependencyCounter
 | reset():void | MethodDependencyCounter
 | setPositionedLights(numPointLights:uint, lightSourceMask:uint):void | MethodDependencyCounter
Property Detail
globalPosDependencies property
globalPosDependencies:uint [read-only]

Implementation
    public function get globalPosDependencies():uint
normalDependencies property
normalDependencies:uint [read-only]

Implementation
    public function get normalDependencies():uint
projectionDependencies property
projectionDependencies:uint [read-only]

Implementation
    public function get projectionDependencies():uint
secondaryUVDependencies property
secondaryUVDependencies:uint [read-only]

Implementation
    public function get secondaryUVDependencies():uint
tangentDependencies property
tangentDependencies:uint [read-only]

Implementation
    public function get tangentDependencies():uint
usesGlobalPosFragment property
usesGlobalPosFragment:Boolean [read-only]

Implementation
    public function get usesGlobalPosFragment():Boolean
uvDependencies property
uvDependencies:uint [read-only]

Implementation
    public function get uvDependencies():uint
viewDirDependencies property
viewDirDependencies:uint [read-only]

Implementation
    public function get viewDirDependencies():uint
Constructor Detail
MethodDependencyCounter () Constructor
public function MethodDependencyCounter()

Method Detail
addWorldSpaceDependencies () method
public function addWorldSpaceDependencies(fragmentLights:Boolean):void

Parameters

fragmentLights:Boolean

includeMethodVO () method
public function includeMethodVO(methodVO:MethodVO):void

Parameters

methodVO:MethodVO

reset () method
public function reset():void

setPositionedLights () method
public function setPositionedLights(numPointLights:uint, lightSourceMask:uint):void

Parameters

numPointLights:uint
lightSourceMask:uint


away3d.materials.compilation.ShaderCompiler

ShaderCompiler | Properties | Methods
Package | away3d.materials.compilation
Class | public class ShaderCompiler
Inheritance | ShaderCompiler Inheritance Object
Subclasses | LightingShaderCompiler, SuperShaderCompiler

Public Properties
Property |  | Defined By
 | alphaPremultiplied : Boolean | ShaderCompiler
 | animatableAttributes : Vector.<String> [read-only] | ShaderCompiler
 | animateUVs : Boolean | ShaderCompiler
 | animationTargetRegisters : Vector.<String> [read-only] | ShaderCompiler
 | cameraPositionIndex : int [read-only] | ShaderCompiler
 | commonsDataIndex : int [read-only] | ShaderCompiler
 | diffuseLightSources : uint | ShaderCompiler
 | fragmentCode : String [read-only] | ShaderCompiler
 | fragmentLightCode : String [read-only] | ShaderCompiler
 | framentPostLightCode : String [read-only] | ShaderCompiler
 | lightFragmentConstantIndex : int [read-only] | ShaderCompiler
 | lightProbeDiffuseIndices : Vector.<uint> [read-only] | ShaderCompiler
 | lightProbeSpecularIndices : Vector.<uint> [read-only] | ShaderCompiler
 | methodSetup : ShaderMethodSetup | ShaderCompiler
 | needUVAnimation : Boolean [read-only] | ShaderCompiler
 | normalBufferIndex : int [read-only] | ShaderCompiler
 | numDirectionalLights : uint | ShaderCompiler
 | numLightProbes : uint | ShaderCompiler
 | numPointLights : uint | ShaderCompiler
 | numUsedFragmentConstants : uint [read-only] | ShaderCompiler
 | numUsedStreams : uint [read-only] | ShaderCompiler
 | numUsedTextures : uint [read-only] | ShaderCompiler
 | numUsedVaryings : uint [read-only] | ShaderCompiler
 | numUsedVertexConstants : uint [read-only] | ShaderCompiler
 | preserveAlpha : Boolean | ShaderCompiler
 | probeWeightsIndex : int [read-only] | ShaderCompiler
 | sceneMatrixIndex : int [read-only] | ShaderCompiler
 | sceneNormalMatrixIndex : int [read-only] | ShaderCompiler
 | secondaryUVBufferIndex : int [read-only] | ShaderCompiler
 | shadedTarget : String [read-only] | ShaderCompiler
 | specularLightSources : uint | ShaderCompiler
 | tangentBufferIndex : int [read-only] | ShaderCompiler
 | usesNormals : Boolean [read-only] | ShaderCompiler
 | usingSpecularMethod : Boolean [read-only] | ShaderCompiler
 | uvBufferIndex : int [read-only] | ShaderCompiler
 | UVSource : String [read-only] | ShaderCompiler
 | UVTarget : String [read-only] | ShaderCompiler
 | uvTransformIndex : int [read-only] | ShaderCompiler
 | vertexCode : String [read-only] | ShaderCompiler
 | vertexConstantsOffset : uint [read-only] | ShaderCompiler
Protected Properties
Property |  | Defined By
 | _alphaPremultiplied : Boolean | ShaderCompiler
 | _animatableAttributes : Vector.<String> | ShaderCompiler
 | _animateUVs : Boolean | ShaderCompiler
 | _animationTargetRegisters : Vector.<String> | ShaderCompiler
 | _cameraPositionIndex : int = -1 | ShaderCompiler
 | _combinedLightSources : uint | ShaderCompiler
 | _dependencyCounter : MethodDependencyCounter | ShaderCompiler
 | _diffuseLightSources : uint | ShaderCompiler
 | _fragmentCode : String | ShaderCompiler
 | _fragmentConstantData : Vector.<Number> | ShaderCompiler
 | _fragmentLightCode : String | ShaderCompiler
 | _framentPostLightCode : String | ShaderCompiler
 | _lightFragmentConstantIndex : int = -1 | ShaderCompiler
 | _lightProbeDiffuseIndices : Vector.<uint> | ShaderCompiler
 | _lightProbeSpecularIndices : Vector.<uint> | ShaderCompiler
 | _methodSetup : ShaderMethodSetup | ShaderCompiler
 | _mipmap : Boolean | ShaderCompiler
 | _needUVAnimation : Boolean | ShaderCompiler
 | _normalBufferIndex : int = -1 | ShaderCompiler
 | _numDirectionalLights : uint | ShaderCompiler
 | _numLightProbes : uint | ShaderCompiler
 | _numLights : int | ShaderCompiler
 | _numPointLights : uint | ShaderCompiler
 | _numProbeRegisters : Number | ShaderCompiler
 | _preserveAlpha : Boolean = true | ShaderCompiler
 | _probeWeightsIndex : int = -1 | ShaderCompiler
 | _registerCache : ShaderRegisterCache | ShaderCompiler
 | _repeat : Boolean | ShaderCompiler
 | _sceneMatrixIndex : int = -1 | ShaderCompiler
 | _sceneNormalMatrixIndex : int = -1 | ShaderCompiler
 | _secondaryUVBufferIndex : int = -1 | ShaderCompiler
 | _sharedRegisters : ShaderRegisterData | ShaderCompiler
 | _smooth : Boolean | ShaderCompiler
 | _specularLightSources : uint | ShaderCompiler
 | _tangentBufferIndex : int = -1 | ShaderCompiler
 | _usingSpecularMethod : Boolean | ShaderCompiler
 | _uvBufferIndex : int = -1 | ShaderCompiler
 | _UVSource : String | ShaderCompiler
 | _UVTarget : String | ShaderCompiler
 | _uvTransformIndex : int = -1 | ShaderCompiler
 | _vertexCode : String | ShaderCompiler
 | _vertexConstantData : Vector.<Number> | ShaderCompiler
 | _vertexConstantsOffset : uint | ShaderCompiler
Public Methods
Method |  | Defined By
 | ShaderCompiler() | ShaderCompiler
 | compile():void | ShaderCompiler
 | dispose():void | ShaderCompiler
 | setConstantDataBuffers(vertexConstantData:Vector.<Number>, fragmentConstantData:Vector.<Number>):void | ShaderCompiler
 | setTextureSampling(smooth:Boolean, repeat:Boolean, mipmap:Boolean):void | ShaderCompiler
Protected Methods
Method |  | Defined By
 | calculateDependencies():void | ShaderCompiler
 | compileGlobalPositionCode():void | ShaderCompiler
 | compileLightingCode():void | ShaderCompiler
 | compileMethods():void | ShaderCompiler
 | compileMethodsCode():void | ShaderCompiler
 | compileNormalCode():void | ShaderCompiler
 | compileViewDirCode():void | ShaderCompiler
 | initLightData():void | ShaderCompiler
 | initRegisterIndices():void | ShaderCompiler
 | usesLights():Boolean | ShaderCompiler
 | usesLightsForDiffuse():Boolean | ShaderCompiler
 | usesLightsForSpecular():Boolean | ShaderCompiler
 | usesProbes():Boolean | ShaderCompiler
 | usesProbesForDiffuse():Boolean | ShaderCompiler
 | usesProbesForSpecular():Boolean | ShaderCompiler
Property Detail
_alphaPremultiplied property
protected var _alphaPremultiplied:Boolean

_animatableAttributes property
protected var _animatableAttributes:Vector.<String>

_animateUVs property
protected var _animateUVs:Boolean

_animationTargetRegisters property
protected var _animationTargetRegisters:Vector.<String>

_cameraPositionIndex property
protected var _cameraPositionIndex:int = -1

_combinedLightSources property
protected var _combinedLightSources:uint

_dependencyCounter property
protected var _dependencyCounter:MethodDependencyCounter

_diffuseLightSources property
protected var _diffuseLightSources:uint

_fragmentCode property
protected var _fragmentCode:String

_fragmentConstantData property
protected var _fragmentConstantData:Vector.<Number>

_fragmentLightCode property
protected var _fragmentLightCode:String

_framentPostLightCode property
protected var _framentPostLightCode:String

_lightFragmentConstantIndex property
protected var _lightFragmentConstantIndex:int = -1

_lightProbeDiffuseIndices property
protected var _lightProbeDiffuseIndices:Vector.<uint>

_lightProbeSpecularIndices property
protected var _lightProbeSpecularIndices:Vector.<uint>

_methodSetup property
protected var _methodSetup:ShaderMethodSetup

_mipmap property
protected var _mipmap:Boolean

_needUVAnimation property
protected var _needUVAnimation:Boolean

_normalBufferIndex property
protected var _normalBufferIndex:int = -1

_numDirectionalLights property
protected var _numDirectionalLights:uint

_numLightProbes property
protected var _numLightProbes:uint

_numLights property
protected var _numLights:int

_numPointLights property
protected var _numPointLights:uint

_numProbeRegisters property
protected var _numProbeRegisters:Number

_preserveAlpha property
protected var _preserveAlpha:Boolean = true

_probeWeightsIndex property
protected var _probeWeightsIndex:int = -1

_registerCache property
protected var _registerCache:ShaderRegisterCache

_repeat property
protected var _repeat:Boolean

_sceneMatrixIndex property
protected var _sceneMatrixIndex:int = -1

_sceneNormalMatrixIndex property
protected var _sceneNormalMatrixIndex:int = -1

_secondaryUVBufferIndex property
protected var _secondaryUVBufferIndex:int = -1

_sharedRegisters property
protected var _sharedRegisters:ShaderRegisterData

_smooth property
protected var _smooth:Boolean

_specularLightSources property
protected var _specularLightSources:uint

_tangentBufferIndex property
protected var _tangentBufferIndex:int = -1

_usingSpecularMethod property
protected var _usingSpecularMethod:Boolean

_uvBufferIndex property
protected var _uvBufferIndex:int = -1

_UVSource property
protected var _UVSource:String

_UVTarget property
protected var _UVTarget:String

_uvTransformIndex property
protected var _uvTransformIndex:int = -1

_vertexCode property
protected var _vertexCode:String

_vertexConstantData property
protected var _vertexConstantData:Vector.<Number>

_vertexConstantsOffset property
protected var _vertexConstantsOffset:uint

alphaPremultiplied property
alphaPremultiplied:Boolean

Implementation
    public function get alphaPremultiplied():Boolean
    public function set alphaPremultiplied(value:Boolean):void
animatableAttributes property
animatableAttributes:Vector.<String> [read-only]

Implementation
    public function get animatableAttributes():Vector.<String>
animateUVs property
animateUVs:Boolean

Implementation
    public function get animateUVs():Boolean
    public function set animateUVs(value:Boolean):void
animationTargetRegisters property
animationTargetRegisters:Vector.<String> [read-only]

Implementation
    public function get animationTargetRegisters():Vector.<String>
cameraPositionIndex property
cameraPositionIndex:int [read-only]

Implementation
    public function get cameraPositionIndex():int
commonsDataIndex property
commonsDataIndex:int [read-only]

Implementation
    public function get commonsDataIndex():int
diffuseLightSources property
diffuseLightSources:uint

Implementation
    public function get diffuseLightSources():uint
    public function set diffuseLightSources(value:uint):void
fragmentCode property
fragmentCode:String [read-only]

Implementation
    public function get fragmentCode():String
fragmentLightCode property
fragmentLightCode:String [read-only]

Implementation
    public function get fragmentLightCode():String
framentPostLightCode property
framentPostLightCode:String [read-only]

Implementation
    public function get framentPostLightCode():String
lightFragmentConstantIndex property
lightFragmentConstantIndex:int [read-only]

Implementation
    public function get lightFragmentConstantIndex():int
lightProbeDiffuseIndices property
lightProbeDiffuseIndices:Vector.<uint> [read-only]

Implementation
    public function get lightProbeDiffuseIndices():Vector.<uint>
lightProbeSpecularIndices property
lightProbeSpecularIndices:Vector.<uint> [read-only]

Implementation
    public function get lightProbeSpecularIndices():Vector.<uint>
methodSetup property
methodSetup:ShaderMethodSetup

Implementation
    public function get methodSetup():ShaderMethodSetup
    public function set methodSetup(value:ShaderMethodSetup):void
needUVAnimation property
needUVAnimation:Boolean [read-only]

Implementation
    public function get needUVAnimation():Boolean
normalBufferIndex property
normalBufferIndex:int [read-only]

Implementation
    public function get normalBufferIndex():int
numDirectionalLights property
numDirectionalLights:uint

Implementation
    public function get numDirectionalLights():uint
    public function set numDirectionalLights(value:uint):void
numLightProbes property
numLightProbes:uint

Implementation
    public function get numLightProbes():uint
    public function set numLightProbes(value:uint):void
numPointLights property
numPointLights:uint

Implementation
    public function get numPointLights():uint
    public function set numPointLights(value:uint):void
numUsedFragmentConstants property
numUsedFragmentConstants:uint [read-only]

Implementation
    public function get numUsedFragmentConstants():uint
numUsedStreams property
numUsedStreams:uint [read-only]

Implementation
    public function get numUsedStreams():uint
numUsedTextures property
numUsedTextures:uint [read-only]

Implementation
    public function get numUsedTextures():uint
numUsedVaryings property
numUsedVaryings:uint [read-only]

Implementation
    public function get numUsedVaryings():uint
numUsedVertexConstants property
numUsedVertexConstants:uint [read-only]

Implementation
    public function get numUsedVertexConstants():uint
preserveAlpha property
preserveAlpha:Boolean

Implementation
    public function get preserveAlpha():Boolean
    public function set preserveAlpha(value:Boolean):void
probeWeightsIndex property
probeWeightsIndex:int [read-only]

Implementation
    public function get probeWeightsIndex():int
sceneMatrixIndex property
sceneMatrixIndex:int [read-only]

Implementation
    public function get sceneMatrixIndex():int
sceneNormalMatrixIndex property
sceneNormalMatrixIndex:int [read-only]

Implementation
    public function get sceneNormalMatrixIndex():int
secondaryUVBufferIndex property
secondaryUVBufferIndex:int [read-only]

Implementation
    public function get secondaryUVBufferIndex():int
shadedTarget property
shadedTarget:String [read-only]

Implementation
    public function get shadedTarget():String
specularLightSources property
specularLightSources:uint

Implementation
    public function get specularLightSources():uint
    public function set specularLightSources(value:uint):void
tangentBufferIndex property
tangentBufferIndex:int [read-only]

Implementation
    public function get tangentBufferIndex():int
usesNormals property
usesNormals:Boolean [read-only]

Implementation
    public function get usesNormals():Boolean
usingSpecularMethod property
usingSpecularMethod:Boolean [read-only]

Implementation
    public function get usingSpecularMethod():Boolean
uvBufferIndex property
uvBufferIndex:int [read-only]

Implementation
    public function get uvBufferIndex():int
UVSource property
UVSource:String [read-only]

Implementation
    public function get UVSource():String
UVTarget property
UVTarget:String [read-only]

Implementation
    public function get UVTarget():String
uvTransformIndex property
uvTransformIndex:int [read-only]

Implementation
    public function get uvTransformIndex():int
vertexCode property
vertexCode:String [read-only]

Implementation
    public function get vertexCode():String
vertexConstantsOffset property
vertexConstantsOffset:uint [read-only]

Implementation
    public function get vertexConstantsOffset():uint
Constructor Detail
ShaderCompiler () Constructor
public function ShaderCompiler()

Method Detail
calculateDependencies () method
protected function calculateDependencies():void

compile () method
public function compile():void

compileGlobalPositionCode () method
protected function compileGlobalPositionCode():void

compileLightingCode () method
protected function compileLightingCode():void

compileMethods () method
protected function compileMethods():void

compileMethodsCode () method
protected function compileMethodsCode():void

compileNormalCode () method
protected function compileNormalCode():void

compileViewDirCode () method
protected function compileViewDirCode():void

dispose () method
public function dispose():void

initLightData () method
protected function initLightData():void

initRegisterIndices () method
protected function initRegisterIndices():void

setConstantDataBuffers () method
public function setConstantDataBuffers(vertexConstantData:Vector.<Number>, fragmentConstantData:Vector.<Number>):void

Parameters

vertexConstantData:Vector.<Number>
fragmentConstantData:Vector.<Number>

setTextureSampling () method
public function setTextureSampling(smooth:Boolean, repeat:Boolean, mipmap:Boolean):void

Parameters

smooth:Boolean
repeat:Boolean
mipmap:Boolean

usesLights () method
protected function usesLights():Boolean

Returns
Boolean
usesLightsForDiffuse () method
protected function usesLightsForDiffuse():Boolean

Returns
Boolean
usesLightsForSpecular () method
protected function usesLightsForSpecular():Boolean

Returns
Boolean
usesProbes () method
protected function usesProbes():Boolean

Returns
Boolean
usesProbesForDiffuse () method
protected function usesProbesForDiffuse():Boolean

Returns
Boolean
usesProbesForSpecular () method
protected function usesProbesForSpecular():Boolean

Returns
Boolean


away3d.materials.compilation.ShaderRegisterCache

ShaderRegisterCache | Properties | Methods
Package | away3d.materials.compilation
Class | public class ShaderRegisterCache
Inheritance | ShaderRegisterCache Inheritance Object
Subclasses | AnimationRegisterCache

ShaderRegister Cache provides the usage management system for all registers during shading compilation.

Public Properties
Property |  | Defined By
 | fragmentConstantOffset : uint | ShaderRegisterCache
 | fragmentOutputRegister : ShaderRegisterElement [read-only] The fragment output register. | ShaderRegisterCache
 | numUsedFragmentConstants : uint [read-only] The amount of used fragment constant registers. | ShaderRegisterCache
 | numUsedStreams : uint [read-only] The amount of used vertex streams. | ShaderRegisterCache
 | numUsedTextures : uint [read-only] | ShaderRegisterCache
 | numUsedVaryings : uint [read-only] | ShaderRegisterCache
 | numUsedVertexConstants : uint [read-only] The amount of used vertex constant registers. | ShaderRegisterCache
 | varyingsOffset : uint | ShaderRegisterCache
 | vertexAttributesOffset : uint Indicates the start index from which to retrieve vertex attributes. | ShaderRegisterCache
 | vertexConstantOffset : uint Indicates the start index from which to retrieve vertex constants. | ShaderRegisterCache
Protected Properties
Property |  | Defined By
 | _fragmentConstantOffset : uint | ShaderRegisterCache
 | _numUsedFragmentConstants : uint | ShaderRegisterCache
 | _numUsedVertexConstants : uint | ShaderRegisterCache
 | _vertexConstantOffset : uint | ShaderRegisterCache
Public Methods
Method |  | Defined By
 | ShaderRegisterCache() Create a new ShaderRegisterCache object. | ShaderRegisterCache
 | addFragmentTempUsages(register:ShaderRegisterElement, usageCount:uint):void Marks a fragment temporary register as used, so it cannot be retrieved. | ShaderRegisterCache
 | addVertexTempUsages(register:ShaderRegisterElement, usageCount:uint):void Marks a vertex temporary register as used, so it cannot be retrieved. | ShaderRegisterCache
 | dispose():void | ShaderRegisterCache
 | getFreeFragmentConstant():ShaderRegisterElement Retrieve an available fragment constant register | ShaderRegisterCache
 | getFreeFragmentSingleTemp():ShaderRegisterElement Retrieve a single component from a fragment temporary register that's still available. | ShaderRegisterCache
 | getFreeFragmentVectorTemp():ShaderRegisterElement Retrieve an entire fragment temporary register that's still available. | ShaderRegisterCache
 | getFreeTextureReg():ShaderRegisterElement Retrieve an available texture register | ShaderRegisterCache
 | getFreeVarying():ShaderRegisterElement Retrieve an available varying register | ShaderRegisterCache
 | getFreeVertexAttribute():ShaderRegisterElement Retrieve an available vertex attribute register | ShaderRegisterCache
 | getFreeVertexConstant():ShaderRegisterElement Retrieve an available vertex constant register | ShaderRegisterCache
 | getFreeVertexSingleTemp():ShaderRegisterElement Retrieve a single component from a vertex temporary register that's still available. | ShaderRegisterCache
 | getFreeVertexVectorTemp():ShaderRegisterElement Retrieve an entire vertex temporary register that's still available. | ShaderRegisterCache
 | removeFragmentTempUsage(register:ShaderRegisterElement):void Removes a usage from a fragment temporary register. | ShaderRegisterCache
 | removeVertexTempUsage(register:ShaderRegisterElement):void Removes a usage from a vertex temporary register. | ShaderRegisterCache
 | reset():void Resets all registers. | ShaderRegisterCache
Property Detail
_fragmentConstantOffset property
protected var _fragmentConstantOffset:uint

_numUsedFragmentConstants property
protected var _numUsedFragmentConstants:uint

_numUsedVertexConstants property
protected var _numUsedVertexConstants:uint

_vertexConstantOffset property
protected var _vertexConstantOffset:uint

fragmentConstantOffset property
fragmentConstantOffset:uint

Implementation
    public function get fragmentConstantOffset():uint
    public function set fragmentConstantOffset(value:uint):void
fragmentOutputRegister property
fragmentOutputRegister:ShaderRegisterElement [read-only]

The fragment output register.

Implementation
    public function get fragmentOutputRegister():ShaderRegisterElement
numUsedFragmentConstants property
numUsedFragmentConstants:uint [read-only]

The amount of used fragment constant registers.

Implementation
    public function get numUsedFragmentConstants():uint
numUsedStreams property
numUsedStreams:uint [read-only]

The amount of used vertex streams.

Implementation
    public function get numUsedStreams():uint
numUsedTextures property
numUsedTextures:uint [read-only]

Implementation
    public function get numUsedTextures():uint
numUsedVaryings property
numUsedVaryings:uint [read-only]

Implementation
    public function get numUsedVaryings():uint
numUsedVertexConstants property
numUsedVertexConstants:uint [read-only]

The amount of used vertex constant registers.

Implementation
    public function get numUsedVertexConstants():uint
varyingsOffset property
varyingsOffset:uint

Implementation
    public function get varyingsOffset():uint
    public function set varyingsOffset(value:uint):void
vertexAttributesOffset property
vertexAttributesOffset:uint

Indicates the start index from which to retrieve vertex attributes.

Implementation
    public function get vertexAttributesOffset():uint
    public function set vertexAttributesOffset(value:uint):void
vertexConstantOffset property
vertexConstantOffset:uint

Indicates the start index from which to retrieve vertex constants.

Implementation
    public function get vertexConstantOffset():uint
    public function set vertexConstantOffset(value:uint):void
Constructor Detail
ShaderRegisterCache () Constructor
public function ShaderRegisterCache()

Create a new ShaderRegisterCache object.

Method Detail
addFragmentTempUsages () method
public function addFragmentTempUsages(register:ShaderRegisterElement, usageCount:uint):void

Marks a fragment temporary register as used, so it cannot be retrieved.

Parameters

register:ShaderRegisterElement — The register to mark as used.
usageCount:uint — The amount of usages to add.

addVertexTempUsages () method
public function addVertexTempUsages(register:ShaderRegisterElement, usageCount:uint):void

Marks a vertex temporary register as used, so it cannot be retrieved.

Parameters

register:ShaderRegisterElement — The register to mark as used.
usageCount:uint — The amount of usages to add.

dispose () method
public function dispose():void

getFreeFragmentConstant () method
public function getFreeFragmentConstant():ShaderRegisterElement

Retrieve an available fragment constant register

Returns
ShaderRegisterElement
getFreeFragmentSingleTemp () method
public function getFreeFragmentSingleTemp():ShaderRegisterElement

Retrieve a single component from a fragment temporary register that's still available.

Returns
ShaderRegisterElement
getFreeFragmentVectorTemp () method
public function getFreeFragmentVectorTemp():ShaderRegisterElement

Retrieve an entire fragment temporary register that's still available.

Returns
ShaderRegisterElement
getFreeTextureReg () method
public function getFreeTextureReg():ShaderRegisterElement

Retrieve an available texture register

Returns
ShaderRegisterElement
getFreeVarying () method
public function getFreeVarying():ShaderRegisterElement

Retrieve an available varying register

Returns
ShaderRegisterElement
getFreeVertexAttribute () method
public function getFreeVertexAttribute():ShaderRegisterElement

Retrieve an available vertex attribute register

Returns
ShaderRegisterElement
getFreeVertexConstant () method
public function getFreeVertexConstant():ShaderRegisterElement

Retrieve an available vertex constant register

Returns
ShaderRegisterElement
getFreeVertexSingleTemp () method
public function getFreeVertexSingleTemp():ShaderRegisterElement

Retrieve a single component from a vertex temporary register that's still available.

Returns
ShaderRegisterElement
getFreeVertexVectorTemp () method
public function getFreeVertexVectorTemp():ShaderRegisterElement

Retrieve an entire vertex temporary register that's still available.

Returns
ShaderRegisterElement
removeFragmentTempUsage () method
public function removeFragmentTempUsage(register:ShaderRegisterElement):void

Removes a usage from a fragment temporary register. When usages reach 0, the register is freed again.

Parameters

register:ShaderRegisterElement — The register for which to remove a usage.

removeVertexTempUsage () method
public function removeVertexTempUsage(register:ShaderRegisterElement):void

Removes a usage from a vertex temporary register. When usages reach 0, the register is freed again.

Parameters

register:ShaderRegisterElement — The register for which to remove a usage.

reset () method
public function reset():void

Resets all registers.


away3d.materials.compilation.ShaderRegisterData

ShaderRegisterData | Properties
Package | away3d.materials.compilation
Class | public class ShaderRegisterData
Inheritance | ShaderRegisterData Inheritance Object

Public Properties
Property |  | Defined By
 | animatedNormal : ShaderRegisterElement | ShaderRegisterData
 | animatedTangent : ShaderRegisterElement | ShaderRegisterData
 | bitangent : ShaderRegisterElement | ShaderRegisterData
 | bitangentVarying : ShaderRegisterElement | ShaderRegisterData
 | commons : ShaderRegisterElement | ShaderRegisterData
 | globalPositionVarying : ShaderRegisterElement | ShaderRegisterData
 | globalPositionVertex : ShaderRegisterElement | ShaderRegisterData
 | localPosition : ShaderRegisterElement | ShaderRegisterData
 | normalFragment : ShaderRegisterElement | ShaderRegisterData
 | normalInput : ShaderRegisterElement | ShaderRegisterData
 | normalVarying : ShaderRegisterElement | ShaderRegisterData
 | projectedTarget : ShaderRegisterElement | ShaderRegisterData
 | projectionFragment : ShaderRegisterElement | ShaderRegisterData
 | secondaryUVVarying : ShaderRegisterElement | ShaderRegisterData
 | shadedTarget : ShaderRegisterElement | ShaderRegisterData
 | tangentInput : ShaderRegisterElement | ShaderRegisterData
 | tangentVarying : ShaderRegisterElement | ShaderRegisterData
 | uvVarying : ShaderRegisterElement | ShaderRegisterData
 | viewDirFragment : ShaderRegisterElement | ShaderRegisterData
 | viewDirVarying : ShaderRegisterElement | ShaderRegisterData
Property Detail
animatedNormal property
public var animatedNormal:ShaderRegisterElement

animatedTangent property
public var animatedTangent:ShaderRegisterElement

bitangent property
public var bitangent:ShaderRegisterElement

bitangentVarying property
public var bitangentVarying:ShaderRegisterElement

commons property
public var commons:ShaderRegisterElement

globalPositionVarying property
public var globalPositionVarying:ShaderRegisterElement

globalPositionVertex property
public var globalPositionVertex:ShaderRegisterElement

localPosition property
public var localPosition:ShaderRegisterElement

normalFragment property
public var normalFragment:ShaderRegisterElement

normalInput property
public var normalInput:ShaderRegisterElement

normalVarying property
public var normalVarying:ShaderRegisterElement

projectedTarget property
public var projectedTarget:ShaderRegisterElement

projectionFragment property
public var projectionFragment:ShaderRegisterElement

secondaryUVVarying property
public var secondaryUVVarying:ShaderRegisterElement

shadedTarget property
public var shadedTarget:ShaderRegisterElement

tangentInput property
public var tangentInput:ShaderRegisterElement

tangentVarying property
public var tangentVarying:ShaderRegisterElement

uvVarying property
public var uvVarying:ShaderRegisterElement

viewDirFragment property
public var viewDirFragment:ShaderRegisterElement

viewDirVarying property
public var viewDirVarying:ShaderRegisterElement


away3d.materials.compilation.ShaderRegisterElement

ShaderRegisterElement | Properties | Methods
Package | away3d.materials.compilation
Class | public class ShaderRegisterElement
Inheritance | ShaderRegisterElement Inheritance Object

A single register element (an entire register or a single register's component) used by the RegisterPool.

Public Properties
Property |  | Defined By
 | component : String [read-only] The register's component, if not the entire register is represented. | ShaderRegisterElement
 | index : int [read-only] The register's index. | ShaderRegisterElement
 | regName : String [read-only] The register's name. | ShaderRegisterElement
Public Methods
Method |  | Defined By
 | ShaderRegisterElement(regName:String, index:int, component:String = null) Creates a new ShaderRegisterElement object. | ShaderRegisterElement
 | toString():String Converts the register or the components AGAL string representation. | ShaderRegisterElement
Property Detail
component property
component:String [read-only]

The register's component, if not the entire register is represented.

Implementation
    public function get component():String
index property
index:int [read-only]

The register's index.

Implementation
    public function get index():int
regName property
regName:String [read-only]

The register's name.

Implementation
    public function get regName():String
Constructor Detail
ShaderRegisterElement () Constructor
public function ShaderRegisterElement(regName:String, index:int, component:String = null)

Creates a new ShaderRegisterElement object.

Parameters
regName:String — The name of the register.
index:int — The index of the register.
component:String (default = null) — The register's component, if not the entire register is represented.
Method Detail
toString () method
public function toString():String

Converts the register or the components AGAL string representation.

Returns
String


away3d.materials.compilation.SuperShaderCompiler

SuperShaderCompiler | Properties | Methods
Package | away3d.materials.compilation
Class | public class SuperShaderCompiler
Inheritance | SuperShaderCompiler Inheritance ShaderCompiler Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean | ShaderCompiler
Inherited | animatableAttributes : Vector.<String> [read-only] | ShaderCompiler
Inherited | animateUVs : Boolean | ShaderCompiler
Inherited | animationTargetRegisters : Vector.<String> [read-only] | ShaderCompiler
Inherited | cameraPositionIndex : int [read-only] | ShaderCompiler
Inherited | commonsDataIndex : int [read-only] | ShaderCompiler
Inherited | diffuseLightSources : uint | ShaderCompiler
 | _dirLightRegisters : Vector.<ShaderRegisterElement> | SuperShaderCompiler
Inherited | fragmentCode : String [read-only] | ShaderCompiler
Inherited | fragmentLightCode : String [read-only] | ShaderCompiler
Inherited | framentPostLightCode : String [read-only] | ShaderCompiler
Inherited | lightFragmentConstantIndex : int [read-only] | ShaderCompiler
Inherited | lightProbeDiffuseIndices : Vector.<uint> [read-only] | ShaderCompiler
Inherited | lightProbeSpecularIndices : Vector.<uint> [read-only] | ShaderCompiler
Inherited | methodSetup : ShaderMethodSetup | ShaderCompiler
Inherited | needUVAnimation : Boolean [read-only] | ShaderCompiler
Inherited | normalBufferIndex : int [read-only] | ShaderCompiler
Inherited | numDirectionalLights : uint | ShaderCompiler
Inherited | numLightProbes : uint | ShaderCompiler
Inherited | numPointLights : uint | ShaderCompiler
Inherited | numUsedFragmentConstants : uint [read-only] | ShaderCompiler
Inherited | numUsedStreams : uint [read-only] | ShaderCompiler
Inherited | numUsedTextures : uint [read-only] | ShaderCompiler
Inherited | numUsedVaryings : uint [read-only] | ShaderCompiler
Inherited | numUsedVertexConstants : uint [read-only] | ShaderCompiler
 | _pointLightRegisters : Vector.<ShaderRegisterElement> | SuperShaderCompiler
Inherited | preserveAlpha : Boolean | ShaderCompiler
Inherited | probeWeightsIndex : int [read-only] | ShaderCompiler
Inherited | sceneMatrixIndex : int [read-only] | ShaderCompiler
Inherited | sceneNormalMatrixIndex : int [read-only] | ShaderCompiler
Inherited | secondaryUVBufferIndex : int [read-only] | ShaderCompiler
Inherited | shadedTarget : String [read-only] | ShaderCompiler
Inherited | specularLightSources : uint | ShaderCompiler
Inherited | tangentBufferIndex : int [read-only] | ShaderCompiler
Inherited | usesNormals : Boolean [read-only] | ShaderCompiler
Inherited | usingSpecularMethod : Boolean [read-only] | ShaderCompiler
Inherited | uvBufferIndex : int [read-only] | ShaderCompiler
Inherited | UVSource : String [read-only] | ShaderCompiler
Inherited | UVTarget : String [read-only] | ShaderCompiler
Inherited | uvTransformIndex : int [read-only] | ShaderCompiler
Inherited | vertexCode : String [read-only] | ShaderCompiler
Inherited | vertexConstantsOffset : uint [read-only] | ShaderCompiler
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaPremultiplied : Boolean | ShaderCompiler
Inherited | _animatableAttributes : Vector.<String> | ShaderCompiler
Inherited | _animateUVs : Boolean | ShaderCompiler
Inherited | _animationTargetRegisters : Vector.<String> | ShaderCompiler
Inherited | _cameraPositionIndex : int = -1 | ShaderCompiler
Inherited | _combinedLightSources : uint | ShaderCompiler
Inherited | _dependencyCounter : MethodDependencyCounter | ShaderCompiler
Inherited | _diffuseLightSources : uint | ShaderCompiler
Inherited | _fragmentCode : String | ShaderCompiler
Inherited | _fragmentConstantData : Vector.<Number> | ShaderCompiler
Inherited | _fragmentLightCode : String | ShaderCompiler
Inherited | _framentPostLightCode : String | ShaderCompiler
Inherited | _lightFragmentConstantIndex : int = -1 | ShaderCompiler
Inherited | _lightProbeDiffuseIndices : Vector.<uint> | ShaderCompiler
Inherited | _lightProbeSpecularIndices : Vector.<uint> | ShaderCompiler
Inherited | _methodSetup : ShaderMethodSetup | ShaderCompiler
Inherited | _mipmap : Boolean | ShaderCompiler
Inherited | _needUVAnimation : Boolean | ShaderCompiler
Inherited | _normalBufferIndex : int = -1 | ShaderCompiler
Inherited | _numDirectionalLights : uint | ShaderCompiler
Inherited | _numLightProbes : uint | ShaderCompiler
Inherited | _numLights : int | ShaderCompiler
Inherited | _numPointLights : uint | ShaderCompiler
Inherited | _numProbeRegisters : Number | ShaderCompiler
Inherited | _preserveAlpha : Boolean = true | ShaderCompiler
Inherited | _probeWeightsIndex : int = -1 | ShaderCompiler
Inherited | _registerCache : ShaderRegisterCache | ShaderCompiler
Inherited | _repeat : Boolean | ShaderCompiler
Inherited | _sceneMatrixIndex : int = -1 | ShaderCompiler
Inherited | _sceneNormalMatrixIndex : int = -1 | ShaderCompiler
Inherited | _secondaryUVBufferIndex : int = -1 | ShaderCompiler
Inherited | _sharedRegisters : ShaderRegisterData | ShaderCompiler
Inherited | _smooth : Boolean | ShaderCompiler
Inherited | _specularLightSources : uint | ShaderCompiler
Inherited | _tangentBufferIndex : int = -1 | ShaderCompiler
Inherited | _usingSpecularMethod : Boolean | ShaderCompiler
Inherited | _uvBufferIndex : int = -1 | ShaderCompiler
Inherited | _UVSource : String | ShaderCompiler
Inherited | _UVTarget : String | ShaderCompiler
Inherited | _uvTransformIndex : int = -1 | ShaderCompiler
Inherited | _vertexCode : String | ShaderCompiler
Inherited | _vertexConstantData : Vector.<Number> | ShaderCompiler
Inherited | _vertexConstantsOffset : uint | ShaderCompiler
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SuperShaderCompiler() | SuperShaderCompiler
Inherited | compile():void | ShaderCompiler
Inherited | dispose():void | ShaderCompiler
Inherited | setConstantDataBuffers(vertexConstantData:Vector.<Number>, fragmentConstantData:Vector.<Number>):void | ShaderCompiler
Inherited | setTextureSampling(smooth:Boolean, repeat:Boolean, mipmap:Boolean):void | ShaderCompiler
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | calculateDependencies():void [override] Calculates register dependencies for commonly used data. | SuperShaderCompiler
Inherited | compileGlobalPositionCode():void | ShaderCompiler
 | compileLightingCode():void [override] | SuperShaderCompiler
Inherited | compileMethods():void | ShaderCompiler
Inherited | compileMethodsCode():void | ShaderCompiler
 | compileNormalCode():void [override] | SuperShaderCompiler
 | compileViewDirCode():void [override] | SuperShaderCompiler
 | initLightData():void [override] | SuperShaderCompiler
Inherited | initRegisterIndices():void | ShaderCompiler
Inherited | usesLights():Boolean | ShaderCompiler
Inherited | usesLightsForDiffuse():Boolean | ShaderCompiler
Inherited | usesLightsForSpecular():Boolean | ShaderCompiler
Inherited | usesProbes():Boolean | ShaderCompiler
Inherited | usesProbesForDiffuse():Boolean | ShaderCompiler
Inherited | usesProbesForSpecular():Boolean | ShaderCompiler
Property Detail
_dirLightRegisters property
public var _dirLightRegisters:Vector.<ShaderRegisterElement>

_pointLightRegisters property
public var _pointLightRegisters:Vector.<ShaderRegisterElement>

Constructor Detail
SuperShaderCompiler () Constructor
public function SuperShaderCompiler()

Method Detail
calculateDependencies () method
override protected function calculateDependencies():void

Calculates register dependencies for commonly used data.

compileLightingCode () method
override protected function compileLightingCode():void

compileNormalCode () method
override protected function compileNormalCode():void

compileViewDirCode () method
override protected function compileViewDirCode():void

initLightData () method
override protected function initLightData():void


away3d.materials.lightpickers - Away3D Documentation

Package away3d.materials.lightpickers

Classes
LightPickerBase
StaticLightPicker


away3d.materials.lightpickers Summary

away3d.materials.lightpickers | Classes

Classes
Class | Description
LightPickerBase |
StaticLightPicker |

Thu Nov 15 2012, 12:09 PM Z


away3d.materials.lightpickers.LightPickerBase

LightPickerBase | Properties | Methods
Package | away3d.materials.lightpickers
Class | public class LightPickerBase
Inheritance | LightPickerBase Inheritance flash.events.EventDispatcher
Subclasses | StaticLightPicker

Public Properties
Property |  | Defined By
 | allPickedLights : Vector.<LightBase> [read-only] | LightPickerBase
 | castingDirectionalLights : Vector.<DirectionalLight> [read-only] | LightPickerBase
 | castingPointLights : Vector.<PointLight> [read-only] | LightPickerBase
 | directionalLights : Vector.<DirectionalLight> [read-only] | LightPickerBase
 | lightProbes : Vector.<LightProbe> [read-only] | LightPickerBase
 | lightProbeWeights : Vector.<Number> [read-only] | LightPickerBase
 | name : String | LightPickerBase
 | numCastingDirectionalLights : uint [read-only] The maximum amount of directional lights that cast shadows | LightPickerBase
 | numCastingPointLights : uint [read-only] The amount of point lights that cast shadows | LightPickerBase
 | numDirectionalLights : uint [read-only] The maximum amount of directional lights that will be provided | LightPickerBase
 | numLightProbes : uint [read-only] The maximum amount of light probes that will be provided | LightPickerBase
 | numPointLights : uint [read-only] The maximum amount of point lights that will be provided | LightPickerBase
 | pointLights : Vector.<PointLight> [read-only] | LightPickerBase
Protected Properties
Property |  | Defined By
 | _allPickedLights : Vector.<LightBase> | LightPickerBase
 | _castingDirectionalLights : Vector.<DirectionalLight> | LightPickerBase
 | _castingPointLights : Vector.<PointLight> | LightPickerBase
 | _directionalLights : Vector.<DirectionalLight> | LightPickerBase
 | _lightProbes : Vector.<LightProbe> | LightPickerBase
 | _lightProbeWeights : Vector.<Number> | LightPickerBase
 | _numCastingDirectionalLights : uint | LightPickerBase
 | _numCastingPointLights : uint | LightPickerBase
 | _numDirectionalLights : uint | LightPickerBase
 | _numLightProbes : uint | LightPickerBase
 | _numPointLights : uint | LightPickerBase
 | _pointLights : Vector.<PointLight> | LightPickerBase
Public Methods
Method |  | Defined By
 | collectLights(renderable:IRenderable, entityCollector:EntityCollector):void Updates set of lights for a given renderable and EntityCollector. | LightPickerBase
Property Detail
_allPickedLights property
protected var _allPickedLights:Vector.<LightBase>

_castingDirectionalLights property
protected var _castingDirectionalLights:Vector.<DirectionalLight>

_castingPointLights property
protected var _castingPointLights:Vector.<PointLight>

_directionalLights property
protected var _directionalLights:Vector.<DirectionalLight>

_lightProbes property
protected var _lightProbes:Vector.<LightProbe>

_lightProbeWeights property
protected var _lightProbeWeights:Vector.<Number>

_numCastingDirectionalLights property
protected var _numCastingDirectionalLights:uint

_numCastingPointLights property
protected var _numCastingPointLights:uint

_numDirectionalLights property
protected var _numDirectionalLights:uint

_numLightProbes property
protected var _numLightProbes:uint

_numPointLights property
protected var _numPointLights:uint

_pointLights property
protected var _pointLights:Vector.<PointLight>

allPickedLights property
allPickedLights:Vector.<LightBase> [read-only]

Implementation
    public function get allPickedLights():Vector.<LightBase>
castingDirectionalLights property
castingDirectionalLights:Vector.<DirectionalLight> [read-only]

Implementation
    public function get castingDirectionalLights():Vector.<DirectionalLight>
castingPointLights property
castingPointLights:Vector.<PointLight> [read-only]

Implementation
    public function get castingPointLights():Vector.<PointLight>
directionalLights property
directionalLights:Vector.<DirectionalLight> [read-only]

Implementation
    public function get directionalLights():Vector.<DirectionalLight>
lightProbes property
lightProbes:Vector.<LightProbe> [read-only]

Implementation
    public function get lightProbes():Vector.<LightProbe>
lightProbeWeights property
lightProbeWeights:Vector.<Number> [read-only]

Implementation
    public function get lightProbeWeights():Vector.<Number>
name property
public var name:String

numCastingDirectionalLights property
numCastingDirectionalLights:uint [read-only]

The maximum amount of directional lights that cast shadows

Implementation
    public function get numCastingDirectionalLights():uint
numCastingPointLights property
numCastingPointLights:uint [read-only]

The amount of point lights that cast shadows

Implementation
    public function get numCastingPointLights():uint
numDirectionalLights property
numDirectionalLights:uint [read-only]

The maximum amount of directional lights that will be provided

Implementation
    public function get numDirectionalLights():uint
numLightProbes property
numLightProbes:uint [read-only]

The maximum amount of light probes that will be provided

Implementation
    public function get numLightProbes():uint
numPointLights property
numPointLights:uint [read-only]

The maximum amount of point lights that will be provided

Implementation
    public function get numPointLights():uint
pointLights property
pointLights:Vector.<PointLight> [read-only]

Implementation
    public function get pointLights():Vector.<PointLight>
Method Detail
collectLights () method
public function collectLights(renderable:IRenderable, entityCollector:EntityCollector):void

Updates set of lights for a given renderable and EntityCollector. Always call super.collectLights() after custom overridden code.

Parameters

renderable:IRenderable
entityCollector:EntityCollector


away3d.materials.lightpickers.StaticLightPicker

StaticLightPicker | Properties | Methods
Package | away3d.materials.lightpickers
Class | public class StaticLightPicker
Inheritance | StaticLightPicker Inheritance LightPickerBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | allPickedLights : Vector.<LightBase> [read-only] | LightPickerBase
Inherited | castingDirectionalLights : Vector.<DirectionalLight> [read-only] | LightPickerBase
Inherited | castingPointLights : Vector.<PointLight> [read-only] | LightPickerBase
Inherited | directionalLights : Vector.<DirectionalLight> [read-only] | LightPickerBase
Inherited | lightProbes : Vector.<LightProbe> [read-only] | LightPickerBase
Inherited | lightProbeWeights : Vector.<Number> [read-only] | LightPickerBase
 | lights : Array | StaticLightPicker
Inherited | name : String | LightPickerBase
Inherited | numCastingDirectionalLights : uint [read-only] The maximum amount of directional lights that cast shadows | LightPickerBase
Inherited | numCastingPointLights : uint [read-only] The amount of point lights that cast shadows | LightPickerBase
Inherited | numDirectionalLights : uint [read-only] The maximum amount of directional lights that will be provided | LightPickerBase
Inherited | numLightProbes : uint [read-only] The maximum amount of light probes that will be provided | LightPickerBase
Inherited | numPointLights : uint [read-only] The maximum amount of point lights that will be provided | LightPickerBase
Inherited | pointLights : Vector.<PointLight> [read-only] | LightPickerBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _allPickedLights : Vector.<LightBase> | LightPickerBase
Inherited | _castingDirectionalLights : Vector.<DirectionalLight> | LightPickerBase
Inherited | _castingPointLights : Vector.<PointLight> | LightPickerBase
Inherited | _directionalLights : Vector.<DirectionalLight> | LightPickerBase
Inherited | _lightProbes : Vector.<LightProbe> | LightPickerBase
Inherited | _lightProbeWeights : Vector.<Number> | LightPickerBase
Inherited | _numCastingDirectionalLights : uint | LightPickerBase
Inherited | _numCastingPointLights : uint | LightPickerBase
Inherited | _numDirectionalLights : uint | LightPickerBase
Inherited | _numLightProbes : uint | LightPickerBase
Inherited | _numPointLights : uint | LightPickerBase
Inherited | _pointLights : Vector.<PointLight> | LightPickerBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | StaticLightPicker(lights:Array) | StaticLightPicker
Inherited | collectLights(renderable:IRenderable, entityCollector:EntityCollector):void Updates set of lights for a given renderable and EntityCollector. | LightPickerBase
Property Detail
lights property
lights:Array

Implementation
    public function get lights():Array
    public function set lights(value:Array):void
Constructor Detail
StaticLightPicker () Constructor
public function StaticLightPicker(lights:Array)

Parameters
lights:Array


away3d.materials.methods - Away3D Documentation

Package away3d.materials.methods

Classes
AlphaMaskMethod
AnisotropicSpecularMethod
BasicAmbientMethod
BasicDiffuseMethod
BasicNormalMethod
BasicSpecularMethod
CascadeShadowMapMethod
CelDiffuseMethod
CelSpecularMethod
ColorMatrixMethod
ColorTransformMethod
CompositeDiffuseMethod
CompositeSpecularMethod
DepthDiffuseMethod
DitheredShadowMapMethod
EffectMethodBase
EnvMapAmbientMethod
EnvMapMethod
FilteredShadowMapMethod
FogMethod
FresnelEnvMapMethod
FresnelPlanarReflectionMethod
FresnelSpecularMethod
HardShadowMapMethod
HeightMapNormalMethod
LightingMethodBase
LightMapDiffuseMethod
LightMapMethod
MethodVO
MethodVOSet
NearShadowMapMethod
OutlineMethod
PlanarReflectionMethod
ProjectiveTextureMethod
RefractionEnvMapMethod
RimLightMethod
ShaderMethodSetup
ShadingMethodBase
ShadowMapMethodBase
SimpleShadowMapMethodBase
SimpleWaterNormalMethod
SoftShadowMapMethod
SpecularShadingModel
SubsurfaceScatteringDiffuseMethod
TerrainDiffuseMethod
TripleFilteredShadowMapMethod
WrapDiffuseMethod


away3d.materials.methods Summary

away3d.materials.methods | Classes

Classes
Class | Description
AlphaMaskMethod | Allows the use of an additional texture to specify the alpha value of the material.
AnisotropicSpecularMethod |
BasicAmbientMethod | BasicAmbientMethod provides the default shading method for uniform ambient lighting.
BasicDiffuseMethod | BasicDiffuseMethod provides the default shading method for Lambert (dot3) diffuse lighting.
BasicNormalMethod |
BasicSpecularMethod | BasicSpecularMethod provides the default shading method for Blinn-Phong specular highlights.
CascadeShadowMapMethod |
CelDiffuseMethod | CelDiffuseMethod provides a shading method to add specular cel (cartoon) shading.
CelSpecularMethod | CelSpecularMethod provides a shading method to add diffuse cel (cartoon) shading.
ColorMatrixMethod | ColorMatrixMethod provides a shading method that changes the colour of a material according to a ColorMatrixFilter object.
ColorTransformMethod | ColorTransformMethod provides a shading method that changes the colour of a material according to a ColorTransform object.
CompositeDiffuseMethod | CompositeDiffuseMethod provides a base class for diffuse methods that wrap a diffuse method to alter the strength of its calculated strength.
CompositeSpecularMethod | CompositeSpecularMethod provides a base class for specular methods that wrap a specular method to alter the strength of its calculated strength.
DepthDiffuseMethod | DepthDiffuseMethod provides a debug method to visualise depth maps
DitheredShadowMapMethod | DitheredShadowMapMethod provides a soft shadowing technique by randomly distributing sample points.
EffectMethodBase | EffectMethodBase forms an abstract base class for shader methods that are not dependent on light sources, and are in essence post-process effects on the materials.
EnvMapAmbientMethod | EnvMapDiffuseMethod provides a diffuse shading method that uses a diffuse irradiance environment map to approximate global lighting rather than lights.
EnvMapMethod |
FilteredShadowMapMethod |
FogMethod |
FresnelEnvMapMethod |
FresnelPlanarReflectionMethod | Allows the use of an additional texture to specify the alpha value of the material.
FresnelSpecularMethod | FresnelSpecularMethod provides a specular shading method that is stronger on shallow view angles.
HardShadowMapMethod |
HeightMapNormalMethod |
LightingMethodBase | LightingMethodBase provides an abstract base method for shading methods that uses lights.
LightMapDiffuseMethod |
LightMapMethod |
MethodVO |
MethodVOSet |
NearShadowMapMethod |
OutlineMethod |
PlanarReflectionMethod | PlanarReflectionMethod is a material method that adds reflections from a PlanarReflectionTexture object.
ProjectiveTextureMethod | ProjectiveTextureMethod is a material method used to project a texture unto the surface of an object.
RefractionEnvMapMethod |
RimLightMethod |
ShaderMethodSetup |
ShadingMethodBase | ShadingMethodBase provides an abstract base method for shading methods, used by DefaultScreenPass to compile the final shading program.
ShadowMapMethodBase |
SimpleShadowMapMethodBase |
SimpleWaterNormalMethod |
SoftShadowMapMethod |
SpecularShadingModel |
SubsurfaceScatteringDiffuseMethod | SubsurfaceScatteringDiffuseMethod provides a depth map-based diffuse shading method that mimics the scattering of light inside translucent surfaces.
TerrainDiffuseMethod |
TripleFilteredShadowMapMethod |
WrapDiffuseMethod | WrapDiffuseMethod is an alternative to BasicDiffuseMethod in which the light is allowed to be "wrapped around" the normally dark area, to some extent.

Thu Nov 15 2012, 12:09 PM Z


away3d.materials.methods.AlphaMaskMethod

AlphaMaskMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class AlphaMaskMethod
Inheritance | AlphaMaskMethod Inheritance EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Allows the use of an additional texture to specify the alpha value of the material. When used with the secondary uv set, it allows for a tiled main texture with independently varying alpha (useful for water etc).

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | texture : Texture2DBase | AlphaMaskMethod
 | useSecondaryUV : Boolean | AlphaMaskMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | AlphaMaskMethod(texture:Texture2DBase, useSecondaryUV:Boolean = false) | AlphaMaskMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
texture property
texture:Texture2DBase

Implementation
    public function get texture():Texture2DBase
    public function set texture(value:Texture2DBase):void
useSecondaryUV property
useSecondaryUV:Boolean

Implementation
    public function get useSecondaryUV():Boolean
    public function set useSecondaryUV(value:Boolean):void
Constructor Detail
AlphaMaskMethod () Constructor
public function AlphaMaskMethod(texture:Texture2DBase, useSecondaryUV:Boolean = false)

Parameters
texture:Texture2DBase
useSecondaryUV:Boolean (default = false)
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.AnisotropicSpecularMethod

AnisotropicSpecularMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class AnisotropicSpecularMethod
Inheritance | AnisotropicSpecularMethod Inheritance BasicSpecularMethod Inheritance LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | gloss : Number The sharpness of the specular highlight. | BasicSpecularMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Inherited | shadingModel : String The model used by the specular shader | BasicSpecularMethod
Inherited | specular : Number The overall strength of the specular highlights. | BasicSpecularMethod
Inherited | specularColor : uint The colour of the specular reflection of the surface. | BasicSpecularMethod
Inherited | texture : Texture2DBase The bitmapData that encodes the specular highlight strength per texel in the red channel, and the sharpness in the green channel. | BasicSpecularMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _isFirstLight : Boolean | BasicSpecularMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _specularDataRegister : ShaderRegisterElement | BasicSpecularMethod
Inherited | _specularTexData : ShaderRegisterElement | BasicSpecularMethod
Inherited | _specularTextureRegister : ShaderRegisterElement | BasicSpecularMethod
Inherited | _totalLightColorReg : ShaderRegisterElement | BasicSpecularMethod
Inherited | _useTexture : Boolean | BasicSpecularMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | AnisotropicSpecularMethod() | AnisotropicSpecularMethod
Inherited | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicSpecularMethod object into the current object. | BasicSpecularMethod
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Constructor Detail
AnisotropicSpecularMethod () Constructor
public function AnisotropicSpecularMethod()

Method Detail
getFragmentCodePerLight () method
override arcane function getFragmentCodePerLight(vo:MethodVO, lightDirReg:ShaderRegisterElement, lightColReg:ShaderRegisterElement, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
lightDirReg:ShaderRegisterElement
lightColReg:ShaderRegisterElement
regCache:ShaderRegisterCache

Returns
String
getFragmentPreLightingCode () method
override arcane function getFragmentPreLightingCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.BasicAmbientMethod

BasicAmbientMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class BasicAmbientMethod
Inheritance | BasicAmbientMethod Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher
Subclasses | EnvMapAmbientMethod

BasicAmbientMethod provides the default shading method for uniform ambient lighting.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | ambient : Number The strength of the ambient reflection of the surface. | BasicAmbientMethod
 | ambientColor : uint The colour of the ambient reflection of the surface. | BasicAmbientMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | texture : Texture2DBase The bitmapData to use to define the diffuse reflection color per texel. | BasicAmbientMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
 | _ambientInputRegister : ShaderRegisterElement | BasicAmbientMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
 | _useTexture : Boolean | BasicAmbientMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | BasicAmbientMethod() Creates a new BasicAmbientMethod object. | BasicAmbientMethod
 | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicAmbientMethod object into the current object. | BasicAmbientMethod
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
_ambientInputRegister property
protected var _ambientInputRegister:ShaderRegisterElement

_lightAmbientB property
arcane var _lightAmbientB:Number = 0

_lightAmbientG property
arcane var _lightAmbientG:Number = 0

_lightAmbientR property
arcane var _lightAmbientR:Number = 0

_useTexture property
protected var _useTexture:Boolean

ambient property
ambient:Number

The strength of the ambient reflection of the surface.

Implementation
    public function get ambient():Number
    public function set ambient(value:Number):void
ambientColor property
ambientColor:uint

The colour of the ambient reflection of the surface.

Implementation
    public function get ambientColor():uint
    public function set ambientColor(value:uint):void
texture property
texture:Texture2DBase

The bitmapData to use to define the diffuse reflection color per texel.

Implementation
    public function get texture():Texture2DBase
    public function set texture(value:Texture2DBase):void
Constructor Detail
BasicAmbientMethod () Constructor
public function BasicAmbientMethod()

Creates a new BasicAmbientMethod object.

Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

copyFrom () method
override public function copyFrom(method:ShadingMethodBase):void

Copies the state from a BasicAmbientMethod object into the current object.

Parameters

method:ShadingMethodBase

getFragmentCode () method
arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.BasicDiffuseMethod

BasicDiffuseMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class BasicDiffuseMethod
Inheritance | BasicDiffuseMethod Inheritance LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher
Subclasses | CompositeDiffuseMethod, DepthDiffuseMethod, TerrainDiffuseMethod, WrapDiffuseMethod

BasicDiffuseMethod provides the default shading method for Lambert (dot3) diffuse lighting.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alphaThreshold : Number The minimum alpha value for which pixels should be drawn. | BasicDiffuseMethod
 | diffuseAlpha : Number The alpha component of the diffuse reflection. | BasicDiffuseMethod
 | diffuseColor : uint The color of the diffuse reflection when not using a texture. | BasicDiffuseMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | texture : Texture2DBase The bitmapData to use to define the diffuse reflection color per texel. | BasicDiffuseMethod
 | _totalLightColorReg : ShaderRegisterElement | BasicDiffuseMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
 | _alphaThreshold : Number = 0 | BasicDiffuseMethod
 | _diffuseInputRegister : ShaderRegisterElement | BasicDiffuseMethod
 | _isFirstLight : Boolean | BasicDiffuseMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
 | _shadowRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
 | _useTexture : Boolean | BasicDiffuseMethod
Public Methods
Method |  | Defined By
 | BasicDiffuseMethod() Creates a new BasicDiffuseMethod object. | BasicDiffuseMethod
 | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicDiffuseMethod object into the current object. | BasicDiffuseMethod
 | dispose():void [override] Cleans up any resources used by the current object. | BasicDiffuseMethod
 | generateMip(stage3DProxy:Stage3DProxy):void | BasicDiffuseMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
_alphaThreshold property
protected var _alphaThreshold:Number = 0

_diffuseInputRegister property
protected var _diffuseInputRegister:ShaderRegisterElement

_isFirstLight property
protected var _isFirstLight:Boolean

_shadowRegister property
protected var _shadowRegister:ShaderRegisterElement

_totalLightColorReg property
public var _totalLightColorReg:ShaderRegisterElement

_useDiffuseTexture property
arcane var _useDiffuseTexture:Boolean

_useTexture property
protected var _useTexture:Boolean

alphaThreshold property
alphaThreshold:Number

The minimum alpha value for which pixels should be drawn. This is used for transparency that is either invisible or entirely opaque, often used with textures for foliage, etc. Recommended values are 0 to disable alpha, or 0.5 to create smooth edges. Default value is 0 (disabled).

Implementation
    public function get alphaThreshold():Number
    public function set alphaThreshold(value:Number):void
diffuseAlpha property
diffuseAlpha:Number

The alpha component of the diffuse reflection.

Implementation
    public function get diffuseAlpha():Number
    public function set diffuseAlpha(value:Number):void
diffuseColor property
diffuseColor:uint

The color of the diffuse reflection when not using a texture.

Implementation
    public function get diffuseColor():uint
    public function set diffuseColor(value:uint):void
shadowRegister property
shadowRegister:ShaderRegisterElement [write-only]

Implementation
    arcane function set shadowRegister(value:ShaderRegisterElement):void
texture property
texture:Texture2DBase

The bitmapData to use to define the diffuse reflection color per texel.

Implementation
    public function get texture():Texture2DBase
    public function set texture(value:Texture2DBase):void
Constructor Detail
BasicDiffuseMethod () Constructor
public function BasicDiffuseMethod()

Creates a new BasicDiffuseMethod object.

Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

copyFrom () method
override public function copyFrom(method:ShadingMethodBase):void

Copies the state from a BasicDiffuseMethod object into the current object.

Parameters

method:ShadingMethodBase

dispose () method
override public function dispose():void

Cleans up any resources used by the current object.

generateMip () method
public function generateMip(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

getFragmentCodePerLight () method
override arcane function getFragmentCodePerLight(vo:MethodVO, lightDirReg:ShaderRegisterElement, lightColReg:ShaderRegisterElement, regCache:ShaderRegisterCache):String

Get the fragment shader code that will generate the code relevant to a single light.

Parameters

vo:MethodVO
lightDirReg:ShaderRegisterElement
lightColReg:ShaderRegisterElement
regCache:ShaderRegisterCache

Returns
String
getFragmentCodePerProbe () method
override arcane function getFragmentCodePerProbe(vo:MethodVO, cubeMapReg:ShaderRegisterElement, weightRegister:String, regCache:ShaderRegisterCache):String

Get the fragment shader code that will generate the code relevant to a single light probe object.

Parameters

vo:MethodVO — The register containing the cube map for the current probe
cubeMapReg:ShaderRegisterElement — A string representation of the register + component containing the current weight
weightRegister:String — The register cache providing any necessary registers to the shader
regCache:ShaderRegisterCache

Returns
String
getFragmentPostLightingCode () method
override arcane function getFragmentPostLightingCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
getFragmentPreLightingCode () method
override arcane function getFragmentPreLightingCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.BasicNormalMethod

BasicNormalMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class BasicNormalMethod
Inheritance | BasicNormalMethod Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher
Subclasses | HeightMapNormalMethod, SimpleWaterNormalMethod

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | normalMap : Texture2DBase | BasicNormalMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
 | _normalTextureRegister : ShaderRegisterElement | BasicNormalMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Method |  | Defined By
 | BasicNormalMethod() | BasicNormalMethod
 | copyFrom(method:ShadingMethodBase):void [override] | BasicNormalMethod
 | dispose():void [override] | BasicNormalMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
_normalTextureRegister property
protected var _normalTextureRegister:ShaderRegisterElement

hasOutput property
hasOutput:Boolean [read-only]

Override this is normal method output is not based on a texture (if not, it will usually always return true)

Implementation
    arcane function get hasOutput():Boolean
normalMap property
normalMap:Texture2DBase

Implementation
    public function get normalMap():Texture2DBase
    public function set normalMap(value:Texture2DBase):void
tangentSpace property
tangentSpace:Boolean [read-only]

Implementation
    arcane function get tangentSpace():Boolean
Constructor Detail
BasicNormalMethod () Constructor
public function BasicNormalMethod()

Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

copyFrom () method
override public function copyFrom(method:ShadingMethodBase):void

Parameters

method:ShadingMethodBase

dispose () method
override public function dispose():void

getFragmentCode () method
arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.BasicSpecularMethod

BasicSpecularMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class BasicSpecularMethod
Inheritance | BasicSpecularMethod Inheritance LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher
Subclasses | AnisotropicSpecularMethod, CompositeSpecularMethod

BasicSpecularMethod provides the default shading method for Blinn-Phong specular highlights.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | gloss : Number The sharpness of the specular highlight. | BasicSpecularMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | shadingModel : String The model used by the specular shader | BasicSpecularMethod
 | specular : Number The overall strength of the specular highlights. | BasicSpecularMethod
 | specularColor : uint The colour of the specular reflection of the surface. | BasicSpecularMethod
 | texture : Texture2DBase The bitmapData that encodes the specular highlight strength per texel in the red channel, and the sharpness in the green channel. | BasicSpecularMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
 | _isFirstLight : Boolean | BasicSpecularMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
 | _specularDataRegister : ShaderRegisterElement | BasicSpecularMethod
 | _specularTexData : ShaderRegisterElement | BasicSpecularMethod
 | _specularTextureRegister : ShaderRegisterElement | BasicSpecularMethod
 | _totalLightColorReg : ShaderRegisterElement | BasicSpecularMethod
 | _useTexture : Boolean | BasicSpecularMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | BasicSpecularMethod() Creates a new BasicSpecularMethod object. | BasicSpecularMethod
 | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicSpecularMethod object into the current object. | BasicSpecularMethod
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
_isFirstLight property
protected var _isFirstLight:Boolean

_specularDataRegister property
protected var _specularDataRegister:ShaderRegisterElement

_specularR property
arcane var _specularR:Number = 1

_specularTexData property
protected var _specularTexData:ShaderRegisterElement

_specularTextureRegister property
protected var _specularTextureRegister:ShaderRegisterElement

_totalLightColorReg property
protected var _totalLightColorReg:ShaderRegisterElement

_useTexture property
protected var _useTexture:Boolean

gloss property
gloss:Number

The sharpness of the specular highlight.

Implementation
    public function get gloss():Number
    public function set gloss(value:Number):void
shadingModel property
shadingModel:String

The model used by the specular shader

Implementation
    public function get shadingModel():String
    public function set shadingModel(value:String):void

See also

away3d.materials.methods.SpecularShadingModel
shadowRegister property
shadowRegister:ShaderRegisterElement [write-only]

Implementation
    arcane function set shadowRegister(value:ShaderRegisterElement):void
specular property
specular:Number

The overall strength of the specular highlights.

Implementation
    public function get specular():Number
    public function set specular(value:Number):void
specularColor property
specularColor:uint

The colour of the specular reflection of the surface.

Implementation
    public function get specularColor():uint
    public function set specularColor(value:uint):void
texture property
texture:Texture2DBase

The bitmapData that encodes the specular highlight strength per texel in the red channel, and the sharpness in the green channel. You can use SpecularBitmapTexture if you want to easily set specular and gloss maps from greyscale images, but prepared images are preffered.

Implementation
    public function get texture():Texture2DBase
    public function set texture(value:Texture2DBase):void
Constructor Detail
BasicSpecularMethod () Constructor
public function BasicSpecularMethod()

Creates a new BasicSpecularMethod object.

Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

copyFrom () method
override public function copyFrom(method:ShadingMethodBase):void

Copies the state from a BasicSpecularMethod object into the current object.

Parameters

method:ShadingMethodBase

getFragmentCodePerLight () method
override arcane function getFragmentCodePerLight(vo:MethodVO, lightDirReg:ShaderRegisterElement, lightColReg:ShaderRegisterElement, regCache:ShaderRegisterCache):String

Get the fragment shader code that will generate the code relevant to a single light.

Parameters

vo:MethodVO
lightDirReg:ShaderRegisterElement
lightColReg:ShaderRegisterElement
regCache:ShaderRegisterCache

Returns
String
getFragmentCodePerProbe () method
override arcane function getFragmentCodePerProbe(vo:MethodVO, cubeMapReg:ShaderRegisterElement, weightRegister:String, regCache:ShaderRegisterCache):String

Get the fragment shader code that will generate the code relevant to a single light probe object.

Parameters

vo:MethodVO — The register containing the cube map for the current probe
cubeMapReg:ShaderRegisterElement — A string representation of the register + component containing the current weight
weightRegister:String — The register cache providing any necessary registers to the shader
regCache:ShaderRegisterCache

Returns
String
getFragmentPostLightingCode () method
override arcane function getFragmentPostLightingCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
getFragmentPreLightingCode () method
override arcane function getFragmentPreLightingCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.CascadeShadowMapMethod

CascadeShadowMapMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class CascadeShadowMapMethod
Inheritance | CascadeShadowMapMethod Inheritance ShadowMapMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number | ShadowMapMethodBase
 | baseMethod : SimpleShadowMapMethodBase | CascadeShadowMapMethod
Inherited | castingLight : LightBase [read-only] | ShadowMapMethodBase
Inherited | epsilon : Number | ShadowMapMethodBase
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alpha : Number = 1 | ShadowMapMethodBase
Inherited | _castingLight : LightBase | ShadowMapMethodBase
Inherited | _epsilon : Number = .002 | ShadowMapMethodBase
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowMapper : ShadowMapperBase | ShadowMapMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CascadeShadowMapMethod(shadowMethodBase:SimpleShadowMapMethodBase) Creates a new CascadeShadowMapMethod object. | CascadeShadowMapMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
baseMethod property
baseMethod:SimpleShadowMapMethodBase

Implementation
    public function get baseMethod():SimpleShadowMapMethodBase
    public function set baseMethod(value:SimpleShadowMapMethodBase):void
sharedRegisters property
sharedRegisters:ShaderRegisterData[override]

Implementation
    arcane function get sharedRegisters():ShaderRegisterData
    arcane function set sharedRegisters(value:ShaderRegisterData):void
Constructor Detail
CascadeShadowMapMethod () Constructor
public function CascadeShadowMapMethod(shadowMethodBase:SimpleShadowMapMethodBase)

Creates a new CascadeShadowMapMethod object.

Parameters
shadowMethodBase:SimpleShadowMapMethodBase
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
getVertexCode () method
override arcane function getVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO

setRenderState () method
override arcane function setRenderState(vo:MethodVO, renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

vo:MethodVO
renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D


away3d.materials.methods.CelDiffuseMethod

CelDiffuseMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class CelDiffuseMethod
Inheritance | CelDiffuseMethod Inheritance CompositeDiffuseMethod Inheritance BasicDiffuseMethod Inheritance LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

CelDiffuseMethod provides a shading method to add specular cel (cartoon) shading.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaThreshold : Number [override] | CompositeDiffuseMethod
Inherited | diffuseAlpha : Number [override] The alpha component of the diffuse reflection. | CompositeDiffuseMethod
Inherited | diffuseColor : uint [override] The color of the diffuse reflection when not using a texture. | CompositeDiffuseMethod
 | levels : uint | CelDiffuseMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | smoothness : Number The smoothness of the edge between 2 shading levels. | CelDiffuseMethod
Inherited | texture : Texture2DBase [override] The bitmapData to use to define the diffuse reflection color per texel. | CompositeDiffuseMethod
Inherited | _totalLightColorReg : ShaderRegisterElement | BasicDiffuseMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaThreshold : Number = 0 | BasicDiffuseMethod
Inherited | _baseDiffuseMethod : BasicDiffuseMethod | CompositeDiffuseMethod
Inherited | _diffuseInputRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _isFirstLight : Boolean | BasicDiffuseMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _useTexture : Boolean | BasicDiffuseMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CelDiffuseMethod(levels:uint = 3, baseDiffuseMethod:BasicDiffuseMethod = null) Creates a new CelDiffuseMethod object. | CelDiffuseMethod
Inherited | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicDiffuseMethod object into the current object. | BasicDiffuseMethod
Inherited | dispose():void [override] Cleans up any resources used by the current object. | CompositeDiffuseMethod
Inherited | generateMip(stage3DProxy:Stage3DProxy):void | BasicDiffuseMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
levels property
levels:uint

Implementation
    public function get levels():uint
    public function set levels(value:uint):void
smoothness property
smoothness:Number

The smoothness of the edge between 2 shading levels.

Implementation
    public function get smoothness():Number
    public function set smoothness(value:Number):void
Constructor Detail
CelDiffuseMethod () Constructor
public function CelDiffuseMethod(levels:uint = 3, baseDiffuseMethod:BasicDiffuseMethod = null)

Creates a new CelDiffuseMethod object.

Parameters
levels:uint (default = 3) — The amount of shadow gradations.
baseDiffuseMethod:BasicDiffuseMethod (default = null) — An optional diffuse method on which the cartoon shading is based. If ommitted, BasicDiffuseMethod is used.
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

getFragmentPreLightingCode () method
override arcane function getFragmentPreLightingCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.CelSpecularMethod

CelSpecularMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class CelSpecularMethod
Inheritance | CelSpecularMethod Inheritance CompositeSpecularMethod Inheritance BasicSpecularMethod Inheritance LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

CelSpecularMethod provides a shading method to add diffuse cel (cartoon) shading.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | gloss : Number [override] The sharpness of the specular highlight. | CompositeSpecularMethod
Inherited | passes : Vector.<MaterialPassBase> [override] [read-only] Any passes required that render to a texture used by this method. | CompositeSpecularMethod
Inherited | shadingModel : String [override] The model used by the specular shader | CompositeSpecularMethod
 | smoothness : Number The smoothness of the highlight edge. | CelSpecularMethod
Inherited | specular : Number [override] The overall strength of the specular highlights. | CompositeSpecularMethod
Inherited | specularColor : uint The colour of the specular reflection of the surface. | BasicSpecularMethod
 | specularCutOff : Number The threshold at which the specular highlight should be shown. | CelSpecularMethod
Inherited | texture : Texture2DBase [override] The bitmapData that encodes the specular highlight strength per texel in the red channel, and the sharpness in the green channel. | CompositeSpecularMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _isFirstLight : Boolean | BasicSpecularMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _specularDataRegister : ShaderRegisterElement | BasicSpecularMethod
Inherited | _specularTexData : ShaderRegisterElement | BasicSpecularMethod
Inherited | _specularTextureRegister : ShaderRegisterElement | BasicSpecularMethod
Inherited | _totalLightColorReg : ShaderRegisterElement | BasicSpecularMethod
Inherited | _useTexture : Boolean | BasicSpecularMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CelSpecularMethod(specularCutOff:Number = .5, baseSpecularMethod:BasicSpecularMethod = null) Creates a new CelSpecularMethod object. | CelSpecularMethod
Inherited | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicSpecularMethod object into the current object. | BasicSpecularMethod
Inherited | dispose():void [override] Cleans up any resources used by the current object. | CompositeSpecularMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
smoothness property
smoothness:Number

The smoothness of the highlight edge.

Implementation
    public function get smoothness():Number
    public function set smoothness(value:Number):void
specularCutOff property
specularCutOff:Number

The threshold at which the specular highlight should be shown.

Implementation
    public function get specularCutOff():Number
    public function set specularCutOff(value:Number):void
Constructor Detail
CelSpecularMethod () Constructor
public function CelSpecularMethod(specularCutOff:Number = .5, baseSpecularMethod:BasicSpecularMethod = null)

Creates a new CelSpecularMethod object.

Parameters
specularCutOff:Number (default = .5) — The threshold at which the specular highlight should be shown.
baseSpecularMethod:BasicSpecularMethod (default = null) — An optional specular method on which the cartoon shading is based. If ommitted, BasicSpecularMethod is used.
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

getFragmentPreLightingCode () method
override arcane function getFragmentPreLightingCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String


away3d.materials.methods.ColorMatrixMethod

ColorMatrixMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class ColorMatrixMethod
Inheritance | ColorMatrixMethod Inheritance EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

ColorMatrixMethod provides a shading method that changes the colour of a material according to a ColorMatrixFilter object.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | colorMatrix : Array The ColorMatrixFilter object to transform the color of the material. | ColorMatrixMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ColorMatrixMethod(matrix:Array) Creates a new ColorTransformMethod. | ColorMatrixMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
colorMatrix property
colorMatrix:Array

The ColorMatrixFilter object to transform the color of the material.

Implementation
    public function get colorMatrix():Array
    public function set colorMatrix(value:Array):void
Constructor Detail
ColorMatrixMethod () Constructor
public function ColorMatrixMethod(matrix:Array)

Creates a new ColorTransformMethod.

Parameters
matrix:Array
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String


away3d.materials.methods.ColorTransformMethod

ColorTransformMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class ColorTransformMethod
Inheritance | ColorTransformMethod Inheritance EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

ColorTransformMethod provides a shading method that changes the colour of a material according to a ColorTransform object.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | colorTransform : ColorTransform The ColorTransform object to transform the colour of the material with. | ColorTransformMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ColorTransformMethod() Creates a new ColorTransformMethod. | ColorTransformMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
colorTransform property
colorTransform:ColorTransform

The ColorTransform object to transform the colour of the material with.

Implementation
    public function get colorTransform():ColorTransform
    public function set colorTransform(value:ColorTransform):void
Constructor Detail
ColorTransformMethod () Constructor
public function ColorTransformMethod()

Creates a new ColorTransformMethod.

Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String


away3d.materials.methods.CompositeDiffuseMethod

CompositeDiffuseMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class CompositeDiffuseMethod
Inheritance | CompositeDiffuseMethod Inheritance BasicDiffuseMethod Inheritance LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher
Subclasses | CelDiffuseMethod, LightMapDiffuseMethod, SubsurfaceScatteringDiffuseMethod

CompositeDiffuseMethod provides a base class for diffuse methods that wrap a diffuse method to alter the strength of its calculated strength.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alphaThreshold : Number [override] | CompositeDiffuseMethod
 | diffuseAlpha : Number [override] The alpha component of the diffuse reflection. | CompositeDiffuseMethod
 | diffuseColor : uint [override] The color of the diffuse reflection when not using a texture. | CompositeDiffuseMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | texture : Texture2DBase [override] The bitmapData to use to define the diffuse reflection color per texel. | CompositeDiffuseMethod
Inherited | _totalLightColorReg : ShaderRegisterElement | BasicDiffuseMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaThreshold : Number = 0 | BasicDiffuseMethod
 | _baseDiffuseMethod : BasicDiffuseMethod | CompositeDiffuseMethod
Inherited | _diffuseInputRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _isFirstLight : Boolean | BasicDiffuseMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _useTexture : Boolean | BasicDiffuseMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CompositeDiffuseMethod(modulateMethod:Function = null, baseDiffuseMethod:BasicDiffuseMethod = null) Creates a new WrapDiffuseMethod object. | CompositeDiffuseMethod
Inherited | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicDiffuseMethod object into the current object. | BasicDiffuseMethod
 | dispose():void [override] Cleans up any resources used by the current object. | CompositeDiffuseMethod
Inherited | generateMip(stage3DProxy:Stage3DProxy):void | BasicDiffuseMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
_baseDiffuseMethod property
protected var _baseDiffuseMethod:BasicDiffuseMethod

alphaThreshold property
alphaThreshold:Number[override]

Implementation
    public function get alphaThreshold():Number
    public function set alphaThreshold(value:Number):void
diffuseAlpha property
diffuseAlpha:Number[override]

The alpha component of the diffuse reflection.

Implementation
    public function get diffuseAlpha():Number
    public function set diffuseAlpha(value:Number):void
diffuseColor property
diffuseColor:uint[override]

The color of the diffuse reflection when not using a texture.

Implementation
    public function get diffuseColor():uint
    public function set diffuseColor(value:uint):void
shadowRegister property
shadowRegister:ShaderRegisterElement [write-only] [override]

Implementation
    arcane function set shadowRegister(value:ShaderRegisterElement):void
sharedRegisters property
sharedRegisters:ShaderRegisterData[override]

Implementation
    arcane function get sharedRegisters():ShaderRegisterData
    arcane function set sharedRegisters(value:ShaderRegisterData):void
texture property
texture:Texture2DBase[override]

The bitmapData to use to define the diffuse reflection color per texel.

Implementation
    public function get texture():Texture2DBase
    public function set texture(value:Texture2DBase):void
Constructor Detail
CompositeDiffuseMethod () Constructor
public function CompositeDiffuseMethod(modulateMethod:Function = null, baseDiffuseMethod:BasicDiffuseMethod = null)

Creates a new WrapDiffuseMethod object.

Parameters
modulateMethod:Function (default = null) — The method which will add the code to alter the base method's strength. It needs to have the signature clampDiffuse(t : ShaderRegisterElement, regCache : ShaderRegisterCache) : String, in which t.w will contain the diffuse strength.
baseDiffuseMethod:BasicDiffuseMethod (default = null) — The base diffuse method on which this method's shading is based.
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

deactivate () method
override arcane function deactivate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

dispose () method
override public function dispose():void

Cleans up any resources used by the current object.

getFragmentCodePerLight () method
override arcane function getFragmentCodePerLight(vo:MethodVO, lightDirReg:ShaderRegisterElement, lightColReg:ShaderRegisterElement, regCache:ShaderRegisterCache):String

Get the fragment shader code that will generate the code relevant to a single light.

Parameters

vo:MethodVO
lightDirReg:ShaderRegisterElement
lightColReg:ShaderRegisterElement
regCache:ShaderRegisterCache

Returns
String
getFragmentCodePerProbe () method
override arcane function getFragmentCodePerProbe(vo:MethodVO, cubeMapReg:ShaderRegisterElement, weightRegister:String, regCache:ShaderRegisterCache):String

Get the fragment shader code that will generate the code relevant to a single light probe object.

Parameters

vo:MethodVO — The register containing the cube map for the current probe
cubeMapReg:ShaderRegisterElement — A string representation of the register + component containing the current weight
weightRegister:String — The register cache providing any necessary registers to the shader
regCache:ShaderRegisterCache

Returns
String
getFragmentPostLightingCode () method
override arcane function getFragmentPostLightingCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
getFragmentPreLightingCode () method
override arcane function getFragmentPreLightingCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
getVertexCode () method
override arcane function getVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO

reset () method
override arcane function reset():void


away3d.materials.methods.CompositeSpecularMethod

CompositeSpecularMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class CompositeSpecularMethod
Inheritance | CompositeSpecularMethod Inheritance BasicSpecularMethod Inheritance LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher
Subclasses | CelSpecularMethod, FresnelSpecularMethod

CompositeSpecularMethod provides a base class for specular methods that wrap a specular method to alter the strength of its calculated strength.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | gloss : Number [override] The sharpness of the specular highlight. | CompositeSpecularMethod
 | passes : Vector.<MaterialPassBase> [override] [read-only] Any passes required that render to a texture used by this method. | CompositeSpecularMethod
 | shadingModel : String [override] The model used by the specular shader | CompositeSpecularMethod
 | specular : Number [override] The overall strength of the specular highlights. | CompositeSpecularMethod
Inherited | specularColor : uint The colour of the specular reflection of the surface. | BasicSpecularMethod
 | texture : Texture2DBase [override] The bitmapData that encodes the specular highlight strength per texel in the red channel, and the sharpness in the green channel. | CompositeSpecularMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _isFirstLight : Boolean | BasicSpecularMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _specularDataRegister : ShaderRegisterElement | BasicSpecularMethod
Inherited | _specularTexData : ShaderRegisterElement | BasicSpecularMethod
Inherited | _specularTextureRegister : ShaderRegisterElement | BasicSpecularMethod
Inherited | _totalLightColorReg : ShaderRegisterElement | BasicSpecularMethod
Inherited | _useTexture : Boolean | BasicSpecularMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CompositeSpecularMethod(modulateMethod:Function, baseSpecularMethod:BasicSpecularMethod = null) Creates a new WrapSpecularMethod object. | CompositeSpecularMethod
Inherited | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicSpecularMethod object into the current object. | BasicSpecularMethod
 | dispose():void [override] Cleans up any resources used by the current object. | CompositeSpecularMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
gloss property
gloss:Number[override]

The sharpness of the specular highlight.

Implementation
    public function get gloss():Number
    public function set gloss(value:Number):void
passes property
passes:Vector.<MaterialPassBase> [read-only] [override]

Any passes required that render to a texture used by this method.

Implementation
    public function get passes():Vector.<MaterialPassBase>
shadingModel property
shadingModel:String[override]

The model used by the specular shader

Implementation
    public function get shadingModel():String
    public function set shadingModel(value:String):void
shadowRegister property
shadowRegister:ShaderRegisterElement [write-only] [override]

Implementation
    arcane function set shadowRegister(value:ShaderRegisterElement):void
sharedRegisters property
sharedRegisters:ShaderRegisterData[override]

Implementation
    arcane function get sharedRegisters():ShaderRegisterData
    arcane function set sharedRegisters(value:ShaderRegisterData):void
specular property
specular:Number[override]

The overall strength of the specular highlights.

Implementation
    public function get specular():Number
    public function set specular(value:Number):void
texture property
texture:Texture2DBase[override]

The bitmapData that encodes the specular highlight strength per texel in the red channel, and the sharpness in the green channel. You can use SpecularBitmapTexture if you want to easily set specular and gloss maps from greyscale images, but prepared images are preffered.

Implementation
    public function get texture():Texture2DBase
    public function set texture(value:Texture2DBase):void
Constructor Detail
CompositeSpecularMethod () Constructor
public function CompositeSpecularMethod(modulateMethod:Function, baseSpecularMethod:BasicSpecularMethod = null)

Creates a new WrapSpecularMethod object.

Parameters
modulateMethod:Function — The method which will add the code to alter the base method's strength. It needs to have the signature modSpecular(t : ShaderRegisterElement, regCache : ShaderRegisterCache) : String, in which t.w will contain the specular strength and t.xyz will contain the half-vector or the reflection vector.
baseSpecularMethod:BasicSpecularMethod (default = null) — The base specular method on which this method's shading is based.
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

deactivate () method
override arcane function deactivate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

dispose () method
override public function dispose():void

Cleans up any resources used by the current object.

getFragmentCodePerLight () method
override arcane function getFragmentCodePerLight(vo:MethodVO, lightDirReg:ShaderRegisterElement, lightColReg:ShaderRegisterElement, regCache:ShaderRegisterCache):String

Get the fragment shader code that will generate the code relevant to a single light.

Parameters

vo:MethodVO
lightDirReg:ShaderRegisterElement
lightColReg:ShaderRegisterElement
regCache:ShaderRegisterCache

Returns
String
getFragmentCodePerProbe () method
override arcane function getFragmentCodePerProbe(vo:MethodVO, cubeMapReg:ShaderRegisterElement, weightRegister:String, regCache:ShaderRegisterCache):String

Get the fragment shader code that will generate the code relevant to a single light probe object.

Parameters

vo:MethodVO — The register containing the cube map for the current probe
cubeMapReg:ShaderRegisterElement — A string representation of the register + component containing the current weight
weightRegister:String — The register cache providing any necessary registers to the shader
regCache:ShaderRegisterCache

Returns
String —
getFragmentPostLightingCode () method
override arcane function getFragmentPostLightingCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
getFragmentPreLightingCode () method
override arcane function getFragmentPreLightingCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
getVertexCode () method
override arcane function getVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO

reset () method
override arcane function reset():void


away3d.materials.methods.DepthDiffuseMethod

DepthDiffuseMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class DepthDiffuseMethod
Inheritance | DepthDiffuseMethod Inheritance BasicDiffuseMethod Inheritance LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

DepthDiffuseMethod provides a debug method to visualise depth maps

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaThreshold : Number The minimum alpha value for which pixels should be drawn. | BasicDiffuseMethod
Inherited | diffuseAlpha : Number The alpha component of the diffuse reflection. | BasicDiffuseMethod
Inherited | diffuseColor : uint The color of the diffuse reflection when not using a texture. | BasicDiffuseMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Inherited | texture : Texture2DBase The bitmapData to use to define the diffuse reflection color per texel. | BasicDiffuseMethod
Inherited | _totalLightColorReg : ShaderRegisterElement | BasicDiffuseMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaThreshold : Number = 0 | BasicDiffuseMethod
Inherited | _diffuseInputRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _isFirstLight : Boolean | BasicDiffuseMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _useTexture : Boolean | BasicDiffuseMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DepthDiffuseMethod() Creates a new BasicDiffuseMethod object. | DepthDiffuseMethod
Inherited | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicDiffuseMethod object into the current object. | BasicDiffuseMethod
Inherited | dispose():void [override] Cleans up any resources used by the current object. | BasicDiffuseMethod
Inherited | generateMip(stage3DProxy:Stage3DProxy):void | BasicDiffuseMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Constructor Detail
DepthDiffuseMethod () Constructor
public function DepthDiffuseMethod()

Creates a new BasicDiffuseMethod object.

Method Detail
getFragmentPostLightingCode () method
override arcane function getFragmentPostLightingCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.DitheredShadowMapMethod

DitheredShadowMapMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class DitheredShadowMapMethod
Inheritance | DitheredShadowMapMethod Inheritance SimpleShadowMapMethodBase Inheritance ShadowMapMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

DitheredShadowMapMethod provides a soft shadowing technique by randomly distributing sample points.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number | ShadowMapMethodBase
Inherited | castingLight : LightBase [read-only] | ShadowMapMethodBase
Inherited | epsilon : Number | ShadowMapMethodBase
 | numSamples : int | DitheredShadowMapMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | range : Number | DitheredShadowMapMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alpha : Number = 1 | ShadowMapMethodBase
Inherited | _castingLight : LightBase | ShadowMapMethodBase
Inherited | _depthMapCoordReg : ShaderRegisterElement | SimpleShadowMapMethodBase
Inherited | _epsilon : Number = .002 | ShadowMapMethodBase
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowMapper : ShadowMapperBase | ShadowMapMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _usePoint : Boolean | SimpleShadowMapMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DitheredShadowMapMethod(castingLight:DirectionalLight, numSamples:int = 4) Creates a new DitheredShadowMapMethod object. | DitheredShadowMapMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
 | dispose():void [override] | DitheredShadowMapMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
getPlanarFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
[override]
DitheredShadowMapMethod
Inherited
getPlanarVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
Inherited
getPointFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
SimpleShadowMapMethodBase
Inherited
getPointVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
numSamples property
numSamples:int

Implementation
    public function get numSamples():int
    public function set numSamples(value:int):void
range property
range:Number

Implementation
    public function get range():Number
    public function set range(value:Number):void
Constructor Detail
DitheredShadowMapMethod () Constructor
public function DitheredShadowMapMethod(castingLight:DirectionalLight, numSamples:int = 4)

Creates a new DitheredShadowMapMethod object.

Parameters
castingLight:DirectionalLight — The light casting the shadows
numSamples:int (default = 4) — The amount of samples to take for dithering. Minimum 1, maximum 8.
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

activateForCascade () method
override arcane function activateForCascade(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

dispose () method
override public function dispose():void

getCascadeFragmentCode () method
override arcane function getCascadeFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, decodeRegister:ShaderRegisterElement, depthTexture:ShaderRegisterElement, depthProjection:ShaderRegisterElement, targetRegister:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
decodeRegister:ShaderRegisterElement
depthTexture:ShaderRegisterElement
depthProjection:ShaderRegisterElement
targetRegister:ShaderRegisterElement

Returns
String
getPlanarFragmentCode () method
override protected function getPlanarFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.EffectMethodBase

EffectMethodBase | Properties | Methods
Package | away3d.materials.methods
Class | public class EffectMethodBase
Inheritance | EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher
Subclasses | AlphaMaskMethod, ColorMatrixMethod, ColorTransformMethod, EnvMapMethod, FogMethod, FresnelEnvMapMethod, FresnelPlanarReflectionMethod, LightMapMethod, OutlineMethod, PlanarReflectionMethod, ProjectiveTextureMethod, RefractionEnvMapMethod, RimLightMethod

EffectMethodBase forms an abstract base class for shader methods that are not dependent on light sources, and are in essence post-process effects on the materials.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | EffectMethodBase() | EffectMethodBase
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Constructor Detail
EffectMethodBase () Constructor
public function EffectMethodBase()


away3d.materials.methods.EnvMapAmbientMethod

EnvMapAmbientMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class EnvMapAmbientMethod
Inheritance | EnvMapAmbientMethod Inheritance BasicAmbientMethod Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

EnvMapDiffuseMethod provides a diffuse shading method that uses a diffuse irradiance environment map to approximate global lighting rather than lights.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | ambient : Number The strength of the ambient reflection of the surface. | BasicAmbientMethod
Inherited | ambientColor : uint The colour of the ambient reflection of the surface. | BasicAmbientMethod
 | envMap : CubeTextureBase The cube environment map to use for the diffuse lighting. | EnvMapAmbientMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Inherited | texture : Texture2DBase The bitmapData to use to define the diffuse reflection color per texel. | BasicAmbientMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _ambientInputRegister : ShaderRegisterElement | BasicAmbientMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _useTexture : Boolean | BasicAmbientMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | EnvMapAmbientMethod(envMap:CubeTextureBase) Creates a new EnvMapDiffuseMethod object. | EnvMapAmbientMethod
Inherited | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicAmbientMethod object into the current object. | BasicAmbientMethod
 | dispose():void [override] Cleans up any resources used by the current object. | EnvMapAmbientMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
envMap property
envMap:CubeTextureBase

The cube environment map to use for the diffuse lighting.

Implementation
    public function get envMap():CubeTextureBase
    public function set envMap(value:CubeTextureBase):void
Constructor Detail
EnvMapAmbientMethod () Constructor
public function EnvMapAmbientMethod(envMap:CubeTextureBase)

Creates a new EnvMapDiffuseMethod object.

Parameters
envMap:CubeTextureBase — The cube environment map to use for the diffuse lighting.
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

dispose () method
override public function dispose():void

Cleans up any resources used by the current object.

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.EnvMapMethod

EnvMapMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class EnvMapMethod
Inheritance | EnvMapMethod Inheritance EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alpha : Number The reflectiveness of the surface | EnvMapMethod
 | envMap : CubeTextureBase The cube environment map to use for the diffuse lighting. | EnvMapMethod
 | mask : Texture2DBase | EnvMapMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | EnvMapMethod(envMap:CubeTextureBase, alpha:Number = 1) | EnvMapMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
 | dispose():void [override] Cleans up any resources used by the current object. | EnvMapMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
alpha property
alpha:Number

The reflectiveness of the surface

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
envMap property
envMap:CubeTextureBase

The cube environment map to use for the diffuse lighting.

Implementation
    public function get envMap():CubeTextureBase
    public function set envMap(value:CubeTextureBase):void
mask property
mask:Texture2DBase

Implementation
    public function get mask():Texture2DBase
    public function set mask(value:Texture2DBase):void
Constructor Detail
EnvMapMethod () Constructor
public function EnvMapMethod(envMap:CubeTextureBase, alpha:Number = 1)

Parameters
envMap:CubeTextureBase
alpha:Number (default = 1)
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

dispose () method
override public function dispose():void

Cleans up any resources used by the current object.

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.FilteredShadowMapMethod

FilteredShadowMapMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class FilteredShadowMapMethod
Inheritance | FilteredShadowMapMethod Inheritance SimpleShadowMapMethodBase Inheritance ShadowMapMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number | ShadowMapMethodBase
Inherited | castingLight : LightBase [read-only] | ShadowMapMethodBase
Inherited | epsilon : Number | ShadowMapMethodBase
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alpha : Number = 1 | ShadowMapMethodBase
Inherited | _castingLight : LightBase | ShadowMapMethodBase
Inherited | _depthMapCoordReg : ShaderRegisterElement | SimpleShadowMapMethodBase
Inherited | _epsilon : Number = .002 | ShadowMapMethodBase
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowMapper : ShadowMapperBase | ShadowMapMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _usePoint : Boolean | SimpleShadowMapMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | FilteredShadowMapMethod(castingLight:DirectionalLight) Creates a new BasicDiffuseMethod object. | FilteredShadowMapMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
getPlanarFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
[override]
FilteredShadowMapMethod
Inherited
getPlanarVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
Inherited
getPointFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
SimpleShadowMapMethodBase
Inherited
getPointVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Constructor Detail
FilteredShadowMapMethod () Constructor
public function FilteredShadowMapMethod(castingLight:DirectionalLight)

Creates a new BasicDiffuseMethod object.

Parameters
castingLight:DirectionalLight — The light casting the shadow
Method Detail
activateForCascade () method
override arcane function activateForCascade(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getCascadeFragmentCode () method
override arcane function getCascadeFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, decodeRegister:ShaderRegisterElement, depthTexture:ShaderRegisterElement, depthProjection:ShaderRegisterElement, targetRegister:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
decodeRegister:ShaderRegisterElement
depthTexture:ShaderRegisterElement
depthProjection:ShaderRegisterElement
targetRegister:ShaderRegisterElement

Returns
String
getPlanarFragmentCode () method
override protected function getPlanarFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.FogMethod

FogMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class FogMethod
Inheritance | FogMethod Inheritance EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | fogColor : uint | FogMethod
 | maxDistance : Number | FogMethod
 | minDistance : Number | FogMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | FogMethod(minDistance:Number, maxDistance:Number, fogColor:uint = 0x808080) | FogMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
fogColor property
fogColor:uint

Implementation
    public function get fogColor():uint
    public function set fogColor(value:uint):void
maxDistance property
maxDistance:Number

Implementation
    public function get maxDistance():Number
    public function set maxDistance(value:Number):void
minDistance property
minDistance:Number

Implementation
    public function get minDistance():Number
    public function set minDistance(value:Number):void
Constructor Detail
FogMethod () Constructor
public function FogMethod(minDistance:Number, maxDistance:Number, fogColor:uint = 0x808080)

Parameters
minDistance:Number
maxDistance:Number
fogColor:uint (default = 0x808080)
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.FresnelEnvMapMethod

FresnelEnvMapMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class FresnelEnvMapMethod
Inheritance | FresnelEnvMapMethod Inheritance EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alpha : Number | FresnelEnvMapMethod
 | envMap : CubeTextureBase The cube environment map to use for the diffuse lighting. | FresnelEnvMapMethod
 | fresnelPower : Number | FresnelEnvMapMethod
 | mask : Texture2DBase | FresnelEnvMapMethod
 | normalReflectance : Number The minimum amount of reflectance, ie the reflectance when the view direction is normal to the surface or light direction. | FresnelEnvMapMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | FresnelEnvMapMethod(envMap:CubeTextureBase, alpha:Number = 1) | FresnelEnvMapMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
 | dispose():void [override] Cleans up any resources used by the current object. | FresnelEnvMapMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
alpha property
alpha:Number

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
envMap property
envMap:CubeTextureBase

The cube environment map to use for the diffuse lighting.

Implementation
    public function get envMap():CubeTextureBase
    public function set envMap(value:CubeTextureBase):void
fresnelPower property
fresnelPower:Number

Implementation
    public function get fresnelPower():Number
    public function set fresnelPower(value:Number):void
mask property
mask:Texture2DBase

Implementation
    public function get mask():Texture2DBase
    public function set mask(value:Texture2DBase):void
normalReflectance property
normalReflectance:Number

The minimum amount of reflectance, ie the reflectance when the view direction is normal to the surface or light direction.

Implementation
    public function get normalReflectance():Number
    public function set normalReflectance(value:Number):void
Constructor Detail
FresnelEnvMapMethod () Constructor
public function FresnelEnvMapMethod(envMap:CubeTextureBase, alpha:Number = 1)

Parameters
envMap:CubeTextureBase
alpha:Number (default = 1)
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

dispose () method
override public function dispose():void

Cleans up any resources used by the current object.

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.FresnelPlanarReflectionMethod

FresnelPlanarReflectionMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class FresnelPlanarReflectionMethod
Inheritance | FresnelPlanarReflectionMethod Inheritance EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Allows the use of an additional texture to specify the alpha value of the material. When used with the secondary uv set, it allows for a tiled main texture with independently varying alpha (useful for water etc).

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alpha : Number | FresnelPlanarReflectionMethod
 | fresnelPower : Number | FresnelPlanarReflectionMethod
 | normalDisplacement : Number | FresnelPlanarReflectionMethod
 | normalReflectance : Number The minimum amount of reflectance, ie the reflectance when the view direction is normal to the surface or light direction. | FresnelPlanarReflectionMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | texture : PlanarReflectionTexture | FresnelPlanarReflectionMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | FresnelPlanarReflectionMethod(texture:PlanarReflectionTexture, alpha:Number = 1) | FresnelPlanarReflectionMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
alpha property
alpha:Number

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
fresnelPower property
fresnelPower:Number

Implementation
    public function get fresnelPower():Number
    public function set fresnelPower(value:Number):void
normalDisplacement property
normalDisplacement:Number

Implementation
    public function get normalDisplacement():Number
    public function set normalDisplacement(value:Number):void
normalReflectance property
normalReflectance:Number

The minimum amount of reflectance, ie the reflectance when the view direction is normal to the surface or light direction.

Implementation
    public function get normalReflectance():Number
    public function set normalReflectance(value:Number):void
texture property
texture:PlanarReflectionTexture

Implementation
    public function get texture():PlanarReflectionTexture
    public function set texture(value:PlanarReflectionTexture):void
Constructor Detail
FresnelPlanarReflectionMethod () Constructor
public function FresnelPlanarReflectionMethod(texture:PlanarReflectionTexture, alpha:Number = 1)

Parameters
texture:PlanarReflectionTexture
alpha:Number (default = 1)
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.FresnelSpecularMethod

FresnelSpecularMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class FresnelSpecularMethod
Inheritance | FresnelSpecularMethod Inheritance CompositeSpecularMethod Inheritance BasicSpecularMethod Inheritance LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

FresnelSpecularMethod provides a specular shading method that is stronger on shallow view angles.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | fresnelPower : Number | FresnelSpecularMethod
Inherited | gloss : Number [override] The sharpness of the specular highlight. | CompositeSpecularMethod
 | normalReflectance : Number The minimum amount of reflectance, ie the reflectance when the view direction is normal to the surface or light direction. | FresnelSpecularMethod
Inherited | passes : Vector.<MaterialPassBase> [override] [read-only] Any passes required that render to a texture used by this method. | CompositeSpecularMethod
Inherited | shadingModel : String [override] The model used by the specular shader | CompositeSpecularMethod
Inherited | specular : Number [override] The overall strength of the specular highlights. | CompositeSpecularMethod
Inherited | specularColor : uint The colour of the specular reflection of the surface. | BasicSpecularMethod
Inherited | texture : Texture2DBase [override] The bitmapData that encodes the specular highlight strength per texel in the red channel, and the sharpness in the green channel. | CompositeSpecularMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _isFirstLight : Boolean | BasicSpecularMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _specularDataRegister : ShaderRegisterElement | BasicSpecularMethod
Inherited | _specularTexData : ShaderRegisterElement | BasicSpecularMethod
Inherited | _specularTextureRegister : ShaderRegisterElement | BasicSpecularMethod
Inherited | _totalLightColorReg : ShaderRegisterElement | BasicSpecularMethod
Inherited | _useTexture : Boolean | BasicSpecularMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | FresnelSpecularMethod(basedOnSurface:Boolean = true, baseSpecularMethod:BasicSpecularMethod = null) Creates a new FresnelSpecularMethod object. | FresnelSpecularMethod
Inherited | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicSpecularMethod object into the current object. | BasicSpecularMethod
Inherited | dispose():void [override] Cleans up any resources used by the current object. | CompositeSpecularMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
fresnelPower property
fresnelPower:Number

Implementation
    public function get fresnelPower():Number
    public function set fresnelPower(value:Number):void
normalReflectance property
normalReflectance:Number

The minimum amount of reflectance, ie the reflectance when the view direction is normal to the surface or light direction.

Implementation
    public function get normalReflectance():Number
    public function set normalReflectance(value:Number):void
Constructor Detail
FresnelSpecularMethod () Constructor
public function FresnelSpecularMethod(basedOnSurface:Boolean = true, baseSpecularMethod:BasicSpecularMethod = null)

Creates a new FresnelSpecularMethod object.

Parameters
basedOnSurface:Boolean (default = true) — Defines whether the fresnel effect should be based on the view angle on the surface (if true), or on the angle between the light and the view.
baseSpecularMethod:BasicSpecularMethod (default = null)
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

getFragmentPreLightingCode () method
override arcane function getFragmentPreLightingCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.HardShadowMapMethod

HardShadowMapMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class HardShadowMapMethod
Inheritance | HardShadowMapMethod Inheritance SimpleShadowMapMethodBase Inheritance ShadowMapMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number | ShadowMapMethodBase
Inherited | castingLight : LightBase [read-only] | ShadowMapMethodBase
Inherited | epsilon : Number | ShadowMapMethodBase
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alpha : Number = 1 | ShadowMapMethodBase
Inherited | _castingLight : LightBase | ShadowMapMethodBase
Inherited | _depthMapCoordReg : ShaderRegisterElement | SimpleShadowMapMethodBase
Inherited | _epsilon : Number = .002 | ShadowMapMethodBase
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowMapper : ShadowMapperBase | ShadowMapMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _usePoint : Boolean | SimpleShadowMapMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | HardShadowMapMethod(castingLight:LightBase) Creates a new HardShadowMapMethod object. | HardShadowMapMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
getPlanarFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
[override]
HardShadowMapMethod
Inherited
getPlanarVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
getPointFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
[override]
HardShadowMapMethod
Inherited
getPointVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Constructor Detail
HardShadowMapMethod () Constructor
public function HardShadowMapMethod(castingLight:LightBase)

Creates a new HardShadowMapMethod object.

Parameters
castingLight:LightBase
Method Detail
activateForCascade () method
override arcane function activateForCascade(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getCascadeFragmentCode () method
override arcane function getCascadeFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, decodeRegister:ShaderRegisterElement, depthTexture:ShaderRegisterElement, depthProjection:ShaderRegisterElement, targetRegister:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
decodeRegister:ShaderRegisterElement
depthTexture:ShaderRegisterElement
depthProjection:ShaderRegisterElement
targetRegister:ShaderRegisterElement

Returns
String
getPlanarFragmentCode () method
override protected function getPlanarFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
getPointFragmentCode () method
override protected function getPointFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String


away3d.materials.methods.HeightMapNormalMethod

HeightMapNormalMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class HeightMapNormalMethod
Inheritance | HeightMapNormalMethod Inheritance BasicNormalMethod Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | normalMap : Texture2DBase | BasicNormalMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _normalTextureRegister : ShaderRegisterElement | BasicNormalMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | HeightMapNormalMethod(heightMap:Texture2DBase, worldWidth:Number, worldHeight:Number, worldDepth:Number) | HeightMapNormalMethod
 | copyFrom(method:ShadingMethodBase):void [override] | HeightMapNormalMethod
Inherited | dispose():void [override] | BasicNormalMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
tangentSpace property
tangentSpace:Boolean [read-only] [override]

Implementation
    arcane function get tangentSpace():Boolean
Constructor Detail
HeightMapNormalMethod () Constructor
public function HeightMapNormalMethod(heightMap:Texture2DBase, worldWidth:Number, worldHeight:Number, worldDepth:Number)

Parameters
heightMap:Texture2DBase
worldWidth:Number
worldHeight:Number
worldDepth:Number
Method Detail
copyFrom () method
override public function copyFrom(method:ShadingMethodBase):void

Parameters

method:ShadingMethodBase

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.LightingMethodBase

LightingMethodBase | Properties | Methods
Package | away3d.materials.methods
Class | public class LightingMethodBase
Inheritance | LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher
Subclasses | BasicDiffuseMethod, BasicSpecularMethod

LightingMethodBase provides an abstract base method for shading methods that uses lights. Used for diffuse and specular shaders only.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | LightingMethodBase() | LightingMethodBase
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
_modulateMethod property
arcane var _modulateMethod:Function

A method that is exposed to wrappers in case the strength needs to be controlled

Constructor Detail
LightingMethodBase () Constructor
public function LightingMethodBase()

Method Detail
getFragmentCodePerLight () method
arcane function getFragmentCodePerLight(vo:MethodVO, lightDirReg:ShaderRegisterElement, lightColReg:ShaderRegisterElement, regCache:ShaderRegisterCache):String

Get the fragment shader code that will generate the code relevant to a single light.

Parameters

vo:MethodVO
lightDirReg:ShaderRegisterElement
lightColReg:ShaderRegisterElement
regCache:ShaderRegisterCache

Returns
String
getFragmentCodePerProbe () method
arcane function getFragmentCodePerProbe(vo:MethodVO, cubeMapReg:ShaderRegisterElement, weightRegister:String, regCache:ShaderRegisterCache):String

Get the fragment shader code that will generate the code relevant to a single light probe object.

Parameters

vo:MethodVO — The register containing the cube map for the current probe
cubeMapReg:ShaderRegisterElement — A string representation of the register + component containing the current weight
weightRegister:String — The register cache providing any necessary registers to the shader
regCache:ShaderRegisterCache

Returns
String


away3d.materials.methods.LightMapDiffuseMethod

LightMapDiffuseMethod | Properties | Methods | Constants
Package | away3d.materials.methods
Class | public class LightMapDiffuseMethod
Inheritance | LightMapDiffuseMethod Inheritance CompositeDiffuseMethod Inheritance BasicDiffuseMethod Inheritance LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaThreshold : Number [override] | CompositeDiffuseMethod
 | blendMode : String | LightMapDiffuseMethod
Inherited | diffuseAlpha : Number [override] The alpha component of the diffuse reflection. | CompositeDiffuseMethod
Inherited | diffuseColor : uint [override] The color of the diffuse reflection when not using a texture. | CompositeDiffuseMethod
 | lightMapTexture : Texture2DBase | LightMapDiffuseMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Inherited | texture : Texture2DBase [override] The bitmapData to use to define the diffuse reflection color per texel. | CompositeDiffuseMethod
Inherited | _totalLightColorReg : ShaderRegisterElement | BasicDiffuseMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaThreshold : Number = 0 | BasicDiffuseMethod
Inherited | _baseDiffuseMethod : BasicDiffuseMethod | CompositeDiffuseMethod
Inherited | _diffuseInputRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _isFirstLight : Boolean | BasicDiffuseMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _useTexture : Boolean | BasicDiffuseMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | LightMapDiffuseMethod(lightMap:Texture2DBase, blendMode:String = multiply, useSecondaryUV:Boolean = false, baseMethod:BasicDiffuseMethod = null) | LightMapDiffuseMethod
Inherited | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicDiffuseMethod object into the current object. | BasicDiffuseMethod
Inherited | dispose():void [override] Cleans up any resources used by the current object. | CompositeDiffuseMethod
Inherited | generateMip(stage3DProxy:Stage3DProxy):void | BasicDiffuseMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Public Constants
Constant |  | Defined By
 | ADD : String = add [static] | LightMapDiffuseMethod
 | MULTIPLY : String = multiply [static] | LightMapDiffuseMethod
Property Detail
blendMode property
blendMode:String

Implementation
    public function get blendMode():String
    public function set blendMode(value:String):void
lightMapTexture property
lightMapTexture:Texture2DBase

Implementation
    public function get lightMapTexture():Texture2DBase
    public function set lightMapTexture(value:Texture2DBase):void
Constructor Detail
LightMapDiffuseMethod () Constructor
public function LightMapDiffuseMethod(lightMap:Texture2DBase, blendMode:String = multiply, useSecondaryUV:Boolean = false, baseMethod:BasicDiffuseMethod = null)

Parameters
lightMap:Texture2DBase
blendMode:String (default = multiply)
useSecondaryUV:Boolean (default = false)
baseMethod:BasicDiffuseMethod (default = null)
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getFragmentPostLightingCode () method
override arcane function getFragmentPostLightingCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO

Constant Detail
ADD Constant
public static const ADD:String = add

MULTIPLY Constant
public static const MULTIPLY:String = multiply


away3d.materials.methods.LightMapMethod

LightMapMethod | Properties | Methods | Constants
Package | away3d.materials.methods
Class | public class LightMapMethod
Inheritance | LightMapMethod Inheritance EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | blendMode : String | LightMapMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | texture : Texture2DBase | LightMapMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | LightMapMethod(texture:Texture2DBase, blendMode:String = multiply, useSecondaryUV:Boolean = false) | LightMapMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Public Constants
Constant |  | Defined By
 | ADD : String = add [static] | LightMapMethod
 | MULTIPLY : String = multiply [static] | LightMapMethod
Property Detail
blendMode property
blendMode:String

Implementation
    public function get blendMode():String
    public function set blendMode(value:String):void
texture property
texture:Texture2DBase

Implementation
    public function get texture():Texture2DBase
    public function set texture(value:Texture2DBase):void
Constructor Detail
LightMapMethod () Constructor
public function LightMapMethod(texture:Texture2DBase, blendMode:String = multiply, useSecondaryUV:Boolean = false)

Parameters
texture:Texture2DBase
blendMode:String (default = multiply)
useSecondaryUV:Boolean (default = false)
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO

Constant Detail
ADD Constant
public static const ADD:String = add

MULTIPLY Constant
public static const MULTIPLY:String = multiply


away3d.materials.methods.MethodVO

MethodVO | Properties | Methods
Package | away3d.materials.methods
Class | public class MethodVO
Inheritance | MethodVO Inheritance Object

Public Properties
Property |  | Defined By
 | fragmentConstantsIndex : int | MethodVO
 | fragmentData : Vector.<Number> | MethodVO
 | needsGlobalFragmentPos : Boolean | MethodVO
 | needsGlobalVertexPos : Boolean | MethodVO
 | needsNormals : Boolean | MethodVO
 | needsProjection : Boolean | MethodVO
 | needsSecondaryUV : Boolean | MethodVO
 | needsTangents : Boolean | MethodVO
 | needsUV : Boolean | MethodVO
 | needsView : Boolean | MethodVO
 | numLights : int | MethodVO
 | repeatTextures : Boolean | MethodVO
 | secondaryFragmentConstantsIndex : int | MethodVO
 | secondaryTexturesIndex : int | MethodVO
 | secondaryVertexConstantsIndex : int | MethodVO
 | texturesIndex : int | MethodVO
 | useMipmapping : Boolean | MethodVO
 | useSmoothTextures : Boolean | MethodVO
 | vertexConstantsIndex : int | MethodVO
 | vertexConstantsOffset : int | MethodVO
 | vertexData : Vector.<Number> | MethodVO
Public Methods
Method |  | Defined By
 | reset():void | MethodVO
Property Detail
fragmentConstantsIndex property
public var fragmentConstantsIndex:int

fragmentData property
public var fragmentData:Vector.<Number>

needsGlobalFragmentPos property
public var needsGlobalFragmentPos:Boolean

needsGlobalVertexPos property
public var needsGlobalVertexPos:Boolean

needsNormals property
public var needsNormals:Boolean

needsProjection property
public var needsProjection:Boolean

needsSecondaryUV property
public var needsSecondaryUV:Boolean

needsTangents property
public var needsTangents:Boolean

needsUV property
public var needsUV:Boolean

needsView property
public var needsView:Boolean

numLights property
public var numLights:int

repeatTextures property
public var repeatTextures:Boolean

secondaryFragmentConstantsIndex property
public var secondaryFragmentConstantsIndex:int

secondaryTexturesIndex property
public var secondaryTexturesIndex:int

secondaryVertexConstantsIndex property
public var secondaryVertexConstantsIndex:int

texturesIndex property
public var texturesIndex:int

useMipmapping property
public var useMipmapping:Boolean

useSmoothTextures property
public var useSmoothTextures:Boolean

vertexConstantsIndex property
public var vertexConstantsIndex:int

vertexConstantsOffset property
public var vertexConstantsOffset:int

vertexData property
public var vertexData:Vector.<Number>

Method Detail
reset () method
public function reset():void


away3d.materials.methods.MethodVOSet

MethodVOSet | Properties | Methods
Package | away3d.materials.methods
Class | public class MethodVOSet
Inheritance | MethodVOSet Inheritance Object

Public Properties
Property |  | Defined By
 | data : MethodVO | MethodVOSet
 | method : EffectMethodBase | MethodVOSet
Public Methods
Method |  | Defined By
 | MethodVOSet(method:EffectMethodBase) | MethodVOSet
Property Detail
data property
public var data:MethodVO

method property
public var method:EffectMethodBase

Constructor Detail
MethodVOSet () Constructor
public function MethodVOSet(method:EffectMethodBase)

Parameters
method:EffectMethodBase


away3d.materials.methods.NearShadowMapMethod

NearShadowMapMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class NearShadowMapMethod
Inheritance | NearShadowMapMethod Inheritance SimpleShadowMapMethodBase Inheritance ShadowMapMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alpha : Number [override] | NearShadowMapMethod
Inherited | castingLight : LightBase [read-only] | ShadowMapMethodBase
 | epsilon : Number [override] | NearShadowMapMethod
 | fadeRatio : Number | NearShadowMapMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alpha : Number = 1 | ShadowMapMethodBase
Inherited | _castingLight : LightBase | ShadowMapMethodBase
Inherited | _depthMapCoordReg : ShaderRegisterElement | SimpleShadowMapMethodBase
Inherited | _epsilon : Number = .002 | ShadowMapMethodBase
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowMapper : ShadowMapperBase | ShadowMapMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _usePoint : Boolean | SimpleShadowMapMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | NearShadowMapMethod(baseMethod:SimpleShadowMapMethodBase, fadeRatio:Number = .1) | NearShadowMapMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
 | dispose():void [override] | NearShadowMapMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getPlanarFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
SimpleShadowMapMethodBase
Inherited
getPlanarVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
Inherited
getPointFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
SimpleShadowMapMethodBase
Inherited
getPointVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
alpha property
alpha:Number[override]

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
epsilon property
epsilon:Number[override]

Implementation
    public function get epsilon():Number
    public function set epsilon(value:Number):void
fadeRatio property
fadeRatio:Number

Implementation
    public function get fadeRatio():Number
    public function set fadeRatio(value:Number):void
sharedRegisters property
sharedRegisters:ShaderRegisterData[override]

Implementation
    arcane function get sharedRegisters():ShaderRegisterData
    arcane function set sharedRegisters(value:ShaderRegisterData):void
Constructor Detail
NearShadowMapMethod () Constructor
public function NearShadowMapMethod(baseMethod:SimpleShadowMapMethodBase, fadeRatio:Number = .1)

Parameters
baseMethod:SimpleShadowMapMethodBase
fadeRatio:Number (default = .1)
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

deactivate () method
override arcane function deactivate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

dispose () method
override public function dispose():void

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
getVertexCode () method
override arcane function getVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO

reset () method
override arcane function reset():void

setRenderState () method
override arcane function setRenderState(vo:MethodVO, renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

vo:MethodVO
renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D


away3d.materials.methods.OutlineMethod

OutlineMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class OutlineMethod
Inheritance | OutlineMethod Inheritance EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | outlineColor : uint | OutlineMethod
 | outlineSize : Number | OutlineMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | showInnerLines : Boolean | OutlineMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | OutlineMethod(outlineColor:uint = 0x000000, outlineSize:Number = 1, showInnerLines:Boolean = true, dedicatedMeshes:Boolean = false) | OutlineMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
outlineColor property
outlineColor:uint

Implementation
    public function get outlineColor():uint
    public function set outlineColor(value:uint):void
outlineSize property
outlineSize:Number

Implementation
    public function get outlineSize():Number
    public function set outlineSize(value:Number):void
showInnerLines property
showInnerLines:Boolean

Implementation
    public function get showInnerLines():Boolean
    public function set showInnerLines(value:Boolean):void
Constructor Detail
OutlineMethod () Constructor
public function OutlineMethod(outlineColor:uint = 0x000000, outlineSize:Number = 1, showInnerLines:Boolean = true, dedicatedMeshes:Boolean = false)

Parameters
outlineColor:uint (default = 0x000000)
outlineSize:Number (default = 1)
showInnerLines:Boolean (default = true)
dedicatedMeshes:Boolean (default = false)
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO

reset () method
override arcane function reset():void


away3d.materials.methods.PlanarReflectionMethod

PlanarReflectionMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class PlanarReflectionMethod
Inheritance | PlanarReflectionMethod Inheritance EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

PlanarReflectionMethod is a material method that adds reflections from a PlanarReflectionTexture object.

See also

away3d.textures.PlanarReflectionTexture

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alpha : Number The reflectiveness of the surface. | PlanarReflectionMethod
 | normalDisplacement : Number The amount of displacement on the surface, for use with water waves. | PlanarReflectionMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | texture : PlanarReflectionTexture The PlanarReflectionTexture used to render the reflected view. | PlanarReflectionMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | PlanarReflectionMethod(texture:PlanarReflectionTexture, alpha:Number = 1) Creates a new PlanarReflectionMethod | PlanarReflectionMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
alpha property
alpha:Number

The reflectiveness of the surface.

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
normalDisplacement property
normalDisplacement:Number

The amount of displacement on the surface, for use with water waves.

Implementation
    public function get normalDisplacement():Number
    public function set normalDisplacement(value:Number):void
texture property
texture:PlanarReflectionTexture

The PlanarReflectionTexture used to render the reflected view.

Implementation
    public function get texture():PlanarReflectionTexture
    public function set texture(value:PlanarReflectionTexture):void
Constructor Detail
PlanarReflectionMethod () Constructor
public function PlanarReflectionMethod(texture:PlanarReflectionTexture, alpha:Number = 1)

Creates a new PlanarReflectionMethod

Parameters
texture:PlanarReflectionTexture — The PlanarReflectionTexture used to render the reflected view.
alpha:Number (default = 1) — The reflectiveness of the surface.
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.ProjectiveTextureMethod

ProjectiveTextureMethod | Properties | Methods | Constants
Package | away3d.materials.methods
Class | public class ProjectiveTextureMethod
Inheritance | ProjectiveTextureMethod Inheritance EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

ProjectiveTextureMethod is a material method used to project a texture unto the surface of an object. This can be used for various effects apart from acting like a normal projector, such as projecting fake shadows unto a surface, the impact of light coming through a stained glass window, ...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | mode : String The blend mode with which the texture is blended unto the object. | ProjectiveTextureMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | projector : TextureProjector The TextureProjector object that defines the projection properties as well as the texture. | ProjectiveTextureMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ProjectiveTextureMethod(projector:TextureProjector, mode:String = multiply) Creates a new ProjectiveTextureMethod object. | ProjectiveTextureMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Public Constants
Constant |  | Defined By
 | ADD : String = add [static] | ProjectiveTextureMethod
 | MIX : String = mix [static] | ProjectiveTextureMethod
 | MULTIPLY : String = multiply [static] | ProjectiveTextureMethod
Property Detail
mode property
mode:String

The blend mode with which the texture is blended unto the object. ProjectiveTextureMethod.MULTIPLY can be used to project shadows. To prevent clamping, the texture's alpha should be white! ProjectiveTextureMethod.ADD can be used to project light, such as a slide projector or light coming through stained glass. To prevent clamping, the texture's alpha should be black! ProjectiveTextureMethod.MIX provides normal alpha blending. To prevent clamping, the texture's alpha should be transparent!

Implementation
    public function get mode():String
    public function set mode(value:String):void
projector property
projector:TextureProjector

The TextureProjector object that defines the projection properties as well as the texture.

Implementation
    public function get projector():TextureProjector
    public function set projector(value:TextureProjector):void

See also

away3d.entities.TextureProjector
Constructor Detail
ProjectiveTextureMethod () Constructor
public function ProjectiveTextureMethod(projector:TextureProjector, mode:String = multiply)

Creates a new ProjectiveTextureMethod object.

Parameters
projector:TextureProjector — The TextureProjector object that defines the projection properties as well as the texture.
mode:String (default = multiply) — The blend mode with which the texture is blended unto the surface.

See also

away3d.entities.TextureProjector
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
getVertexCode () method
override arcane function getVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

setRenderState () method
override arcane function setRenderState(vo:MethodVO, renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

vo:MethodVO
renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D

Constant Detail
ADD Constant
public static const ADD:String = add

MIX Constant
public static const MIX:String = mix

MULTIPLY Constant
public static const MULTIPLY:String = multiply


away3d.materials.methods.RefractionEnvMapMethod

RefractionEnvMapMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class RefractionEnvMapMethod
Inheritance | RefractionEnvMapMethod Inheritance EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alpha : Number | RefractionEnvMapMethod
 | dispersionB : Number | RefractionEnvMapMethod
 | dispersionG : Number | RefractionEnvMapMethod
 | dispersionR : Number | RefractionEnvMapMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | refractionIndex : Number | RefractionEnvMapMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | RefractionEnvMapMethod(envMap:CubeTextureBase, refractionIndex:Number = .1, dispersionR:Number = 0, dispersionG:Number = 0, dispersionB:Number = 0) | RefractionEnvMapMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
alpha property
alpha:Number

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
dispersionB property
dispersionB:Number

Implementation
    public function get dispersionB():Number
    public function set dispersionB(value:Number):void
dispersionG property
dispersionG:Number

Implementation
    public function get dispersionG():Number
    public function set dispersionG(value:Number):void
dispersionR property
dispersionR:Number

Implementation
    public function get dispersionR():Number
    public function set dispersionR(value:Number):void
refractionIndex property
refractionIndex:Number

Implementation
    public function get refractionIndex():Number
    public function set refractionIndex(value:Number):void
Constructor Detail
RefractionEnvMapMethod () Constructor
public function RefractionEnvMapMethod(envMap:CubeTextureBase, refractionIndex:Number = .1, dispersionR:Number = 0, dispersionG:Number = 0, dispersionB:Number = 0)

Parameters
envMap:CubeTextureBase
refractionIndex:Number (default = .1)
dispersionR:Number (default = 0)
dispersionG:Number (default = 0)
dispersionB:Number (default = 0)
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.RimLightMethod

RimLightMethod | Properties | Methods | Constants
Package | away3d.materials.methods
Class | public class RimLightMethod
Inheritance | RimLightMethod Inheritance EffectMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | color : uint | RimLightMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | power : Number | RimLightMethod
 | strength : Number | RimLightMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | RimLightMethod(color:uint = 0xffffff, strength:Number = .4, power:Number = 2, blend:String = mix) | RimLightMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Public Constants
Constant |  | Defined By
 | ADD : String = add [static] | RimLightMethod
 | MIX : String = mix [static] | RimLightMethod
 | MULTIPLY : String = multiply [static] | RimLightMethod
Property Detail
color property
color:uint

Implementation
    public function get color():uint
    public function set color(value:uint):void
power property
power:Number

Implementation
    public function get power():Number
    public function set power(value:Number):void
strength property
strength:Number

Implementation
    public function get strength():Number
    public function set strength(value:Number):void
Constructor Detail
RimLightMethod () Constructor
public function RimLightMethod(color:uint = 0xffffff, strength:Number = .4, power:Number = 2, blend:String = mix)

Parameters
color:uint (default = 0xffffff)
strength:Number (default = .4)
power:Number (default = 2)
blend:String (default = mix)
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO

Constant Detail
ADD Constant
public static const ADD:String = add

MIX Constant
public static const MIX:String = mix

MULTIPLY Constant
public static const MULTIPLY:String = multiply


away3d.materials.methods.ShaderMethodSetup

ShaderMethodSetup | Properties | Methods
Package | away3d.materials.methods
Class | public class ShaderMethodSetup
Inheritance | ShaderMethodSetup Inheritance flash.events.EventDispatcher

Public Properties
Property |  | Defined By
 | ambientMethod : BasicAmbientMethod | ShaderMethodSetup
 | diffuseMethod : BasicDiffuseMethod The method to perform diffuse shading. | ShaderMethodSetup
 | normalMethod : BasicNormalMethod | ShaderMethodSetup
 | numMethods : int [read-only] | ShaderMethodSetup
 | shadowMethod : ShadowMapMethodBase | ShaderMethodSetup
 | specularMethod : BasicSpecularMethod The method to perform specular shading. | ShaderMethodSetup
Public Methods
Method |  | Defined By
 | ShaderMethodSetup() | ShaderMethodSetup
 | addMethod(method:EffectMethodBase):void Adds a method to change the material after all lighting is performed. | ShaderMethodSetup
 | addMethodAt(method:EffectMethodBase, index:int):void Inserts a method to change the material after all lighting is performed at the given index. | ShaderMethodSetup
 | dispose():void | ShaderMethodSetup
 | getMethodAt(index:int):EffectMethodBase | ShaderMethodSetup
 | hasMethod(method:EffectMethodBase):Boolean | ShaderMethodSetup
 | removeMethod(method:EffectMethodBase):void Removes a method from the pass. | ShaderMethodSetup
Property Detail
_ambientMethod property
arcane var _ambientMethod:BasicAmbientMethod

_ambientMethodVO property
arcane var _ambientMethodVO:MethodVO

_colorTransformMethod property
arcane var _colorTransformMethod:ColorTransformMethod

_colorTransformMethodVO property
arcane var _colorTransformMethodVO:MethodVO

_diffuseMethod property
arcane var _diffuseMethod:BasicDiffuseMethod

_diffuseMethodVO property
arcane var _diffuseMethodVO:MethodVO

_methods property
arcane var _methods:Vector.<MethodVOSet>

_normalMethod property
arcane var _normalMethod:BasicNormalMethod

_normalMethodVO property
arcane var _normalMethodVO:MethodVO

_shadowMethod property
arcane var _shadowMethod:ShadowMapMethodBase

_shadowMethodVO property
arcane var _shadowMethodVO:MethodVO

_specularMethod property
arcane var _specularMethod:BasicSpecularMethod

_specularMethodVO property
arcane var _specularMethodVO:MethodVO

ambientMethod property
ambientMethod:BasicAmbientMethod

Implementation
    public function get ambientMethod():BasicAmbientMethod
    public function set ambientMethod(value:BasicAmbientMethod):void
colorTransformMethod property
colorTransformMethod:ColorTransformMethod

Implementation
    arcane function get colorTransformMethod():ColorTransformMethod
    arcane function set colorTransformMethod(value:ColorTransformMethod):void
diffuseMethod property
diffuseMethod:BasicDiffuseMethod

The method to perform diffuse shading.

Implementation
    public function get diffuseMethod():BasicDiffuseMethod
    public function set diffuseMethod(value:BasicDiffuseMethod):void
normalMethod property
normalMethod:BasicNormalMethod

Implementation
    public function get normalMethod():BasicNormalMethod
    public function set normalMethod(value:BasicNormalMethod):void
numMethods property
numMethods:int [read-only]

Implementation
    public function get numMethods():int
shadowMethod property
shadowMethod:ShadowMapMethodBase

Implementation
    public function get shadowMethod():ShadowMapMethodBase
    public function set shadowMethod(value:ShadowMapMethodBase):void
specularMethod property
specularMethod:BasicSpecularMethod

The method to perform specular shading.

Implementation
    public function get specularMethod():BasicSpecularMethod
    public function set specularMethod(value:BasicSpecularMethod):void
Constructor Detail
ShaderMethodSetup () Constructor
public function ShaderMethodSetup()

Method Detail
addMethod () method
public function addMethod(method:EffectMethodBase):void

Adds a method to change the material after all lighting is performed.

Parameters

method:EffectMethodBase — The method to be added.

addMethodAt () method
public function addMethodAt(method:EffectMethodBase, index:int):void

Inserts a method to change the material after all lighting is performed at the given index.

Parameters

method:EffectMethodBase — The method to be added.
index:int — The index of the method's occurrence

dispose () method
public function dispose():void

getMethodAt () method
public function getMethodAt(index:int):EffectMethodBase

Parameters

index:int

Returns
EffectMethodBase
hasMethod () method
public function hasMethod(method:EffectMethodBase):Boolean

Parameters

method:EffectMethodBase

Returns
Boolean
removeMethod () method
public function removeMethod(method:EffectMethodBase):void

Removes a method from the pass.

Parameters

method:EffectMethodBase — The method to be removed.


away3d.materials.methods.ShadingMethodBase

ShadingMethodBase | Properties | Methods
Package | away3d.materials.methods
Class | public class ShadingMethodBase
Inheritance | ShadingMethodBase Inheritance flash.events.EventDispatcher
Subclasses | BasicAmbientMethod, BasicNormalMethod, EffectMethodBase, LightingMethodBase, ShadowMapMethodBase

ShadingMethodBase provides an abstract base method for shading methods, used by DefaultScreenPass to compile the final shading program.

Public Properties
Property |  | Defined By
 | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Property |  | Defined By
 | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
 | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Method |  | Defined By
 | ShadingMethodBase() Create a new ShadingMethodBase object. | ShadingMethodBase
 | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
 | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Method Defined By
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
_passes property
protected var _passes:Vector.<MaterialPassBase>

_sharedRegisters property
protected var _sharedRegisters:ShaderRegisterData

passes property
passes:Vector.<MaterialPassBase> [read-only]

Any passes required that render to a texture used by this method.

Implementation
    public function get passes():Vector.<MaterialPassBase>
sharedRegisters property
sharedRegisters:ShaderRegisterData

Implementation
    arcane function get sharedRegisters():ShaderRegisterData
    arcane function set sharedRegisters(value:ShaderRegisterData):void
Constructor Detail
ShadingMethodBase () Constructor
public function ShadingMethodBase()

Create a new ShadingMethodBase object.

Method Detail
copyFrom () method
public function copyFrom(method:ShadingMethodBase):void

Copies the state from a ShadingMethodBase object into the current object.

Parameters

method:ShadingMethodBase

createMethodVO () method
arcane function createMethodVO():MethodVO

Creates a data container that contains material-dependent data. Provided as a factory method so a custom subtype can be overridden when needed.

Returns
MethodVO
dispose () method
public function dispose():void

Cleans up any resources used by the current object.

getTex2DSampleCode () method
protected function getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String

A helper method that generates standard code for sampling from a texture using the normal uv coordinates.

Parameters

vo:MethodVO — The register in which to store the sampled colour.
targetReg:ShaderRegisterElement — The texture stream register.
inputReg:ShaderRegisterElement
texture:TextureProxyBase
uvReg:ShaderRegisterElement (default = null)
forceWrap:String (default = null)

Returns
String — The fragment code that performs the sampling.
getTexCubeSampleCode () method
protected function getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
targetReg:ShaderRegisterElement
inputReg:ShaderRegisterElement
texture:TextureProxyBase
uvReg:ShaderRegisterElement

Returns
String
initConstants () method
arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

initVO () method
arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO

invalidateShaderProgram () method
protected function invalidateShaderProgram():void

Marks the shader program as invalid, so it will be recompiled before the next render.

reset () method
arcane function reset():void

setRenderState () method
arcane function setRenderState(vo:MethodVO, renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Sets the render state for a single renderable.

Parameters

vo:MethodVO
renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D


away3d.materials.methods.ShadowMapMethodBase

ShadowMapMethodBase | Properties | Methods
Package | away3d.materials.methods
Class | public class ShadowMapMethodBase
Inheritance | ShadowMapMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher
Subclasses | CascadeShadowMapMethod, SimpleShadowMapMethodBase

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alpha : Number | ShadowMapMethodBase
 | castingLight : LightBase [read-only] | ShadowMapMethodBase
 | epsilon : Number | ShadowMapMethodBase
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
 | _alpha : Number = 1 | ShadowMapMethodBase
 | _castingLight : LightBase | ShadowMapMethodBase
 | _epsilon : Number = .002 | ShadowMapMethodBase
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
 | _shadowMapper : ShadowMapperBase | ShadowMapMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ShadowMapMethodBase(castingLight:LightBase) | ShadowMapMethodBase
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
_alpha property
protected var _alpha:Number = 1

_castingLight property
protected var _castingLight:LightBase

_epsilon property
protected var _epsilon:Number = .002

_shadowMapper property
protected var _shadowMapper:ShadowMapperBase

alpha property
alpha:Number

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
castingLight property
castingLight:LightBase [read-only]

Implementation
    public function get castingLight():LightBase
epsilon property
epsilon:Number

Implementation
    public function get epsilon():Number
    public function set epsilon(value:Number):void
Constructor Detail
ShadowMapMethodBase () Constructor
public function ShadowMapMethodBase(castingLight:LightBase)

Parameters
castingLight:LightBase
Method Detail
getFragmentCode () method
arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String


away3d.materials.methods.SimpleShadowMapMethodBase

SimpleShadowMapMethodBase | Properties | Methods
Package | away3d.materials.methods
Class | public class SimpleShadowMapMethodBase
Inheritance | SimpleShadowMapMethodBase Inheritance ShadowMapMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher
Subclasses | DitheredShadowMapMethod, FilteredShadowMapMethod, HardShadowMapMethod, NearShadowMapMethod, SoftShadowMapMethod, TripleFilteredShadowMapMethod

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number | ShadowMapMethodBase
Inherited | castingLight : LightBase [read-only] | ShadowMapMethodBase
Inherited | epsilon : Number | ShadowMapMethodBase
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alpha : Number = 1 | ShadowMapMethodBase
Inherited | _castingLight : LightBase | ShadowMapMethodBase
 | _depthMapCoordReg : ShaderRegisterElement | SimpleShadowMapMethodBase
Inherited | _epsilon : Number = .002 | ShadowMapMethodBase
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowMapper : ShadowMapperBase | ShadowMapMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
 | _usePoint : Boolean | SimpleShadowMapMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SimpleShadowMapMethodBase(castingLight:LightBase) | SimpleShadowMapMethodBase
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
getPlanarFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
SimpleShadowMapMethodBase
getPlanarVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
getPointFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
SimpleShadowMapMethodBase
getPointVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
_depthMapCoordReg property
protected var _depthMapCoordReg:ShaderRegisterElement

_usePoint property
protected var _usePoint:Boolean

depthMapCoordReg property
depthMapCoordReg:ShaderRegisterElement

Wrappers that override the vertex shader need to set this explicitly

Implementation
    arcane function get depthMapCoordReg():ShaderRegisterElement
    arcane function set depthMapCoordReg(value:ShaderRegisterElement):void
Constructor Detail
SimpleShadowMapMethodBase () Constructor
public function SimpleShadowMapMethodBase(castingLight:LightBase)

Parameters
castingLight:LightBase
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

activateForCascade () method
arcane function activateForCascade(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

getCascadeFragmentCode () method
arcane function getCascadeFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, decodeRegister:ShaderRegisterElement, depthTexture:ShaderRegisterElement, depthProjection:ShaderRegisterElement, targetRegister:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
decodeRegister:ShaderRegisterElement
depthTexture:ShaderRegisterElement
depthProjection:ShaderRegisterElement
targetRegister:ShaderRegisterElement

Returns
String
getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
getPlanarFragmentCode () method
protected function getPlanarFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
getPlanarVertexCode () method
protected function getPlanarVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
getPointFragmentCode () method
protected function getPointFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
getPointVertexCode () method
protected function getPointVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
getVertexCode () method
override arcane function getVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO

setRenderState () method
override arcane function setRenderState(vo:MethodVO, renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

vo:MethodVO
renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D


away3d.materials.methods.SimpleWaterNormalMethod

SimpleWaterNormalMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class SimpleWaterNormalMethod
Inheritance | SimpleWaterNormalMethod Inheritance BasicNormalMethod Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | normalMap : Texture2DBase [override] | SimpleWaterNormalMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | secondaryNormalMap : Texture2DBase | SimpleWaterNormalMethod
 | water1OffsetX : Number | SimpleWaterNormalMethod
 | water1OffsetY : Number | SimpleWaterNormalMethod
 | water2OffsetX : Number | SimpleWaterNormalMethod
 | water2OffsetY : Number | SimpleWaterNormalMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _normalTextureRegister : ShaderRegisterElement | BasicNormalMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SimpleWaterNormalMethod(waveMap1:Texture2DBase, waveMap2:Texture2DBase) | SimpleWaterNormalMethod
Inherited | copyFrom(method:ShadingMethodBase):void [override] | BasicNormalMethod
 | dispose():void [override] | SimpleWaterNormalMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
normalMap property
normalMap:Texture2DBase[override]

Implementation
    public function get normalMap():Texture2DBase
    public function set normalMap(value:Texture2DBase):void
secondaryNormalMap property
secondaryNormalMap:Texture2DBase

Implementation
    public function get secondaryNormalMap():Texture2DBase
    public function set secondaryNormalMap(value:Texture2DBase):void
water1OffsetX property
water1OffsetX:Number

Implementation
    public function get water1OffsetX():Number
    public function set water1OffsetX(value:Number):void
water1OffsetY property
water1OffsetY:Number

Implementation
    public function get water1OffsetY():Number
    public function set water1OffsetY(value:Number):void
water2OffsetX property
water2OffsetX:Number

Implementation
    public function get water2OffsetX():Number
    public function set water2OffsetX(value:Number):void
water2OffsetY property
water2OffsetY:Number

Implementation
    public function get water2OffsetY():Number
    public function set water2OffsetY(value:Number):void
Constructor Detail
SimpleWaterNormalMethod () Constructor
public function SimpleWaterNormalMethod(waveMap1:Texture2DBase, waveMap2:Texture2DBase)

Parameters
waveMap1:Texture2DBase
waveMap2:Texture2DBase
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

dispose () method
override public function dispose():void

getFragmentCode () method
override arcane function getFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

initVO () method
override arcane function initVO(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.SoftShadowMapMethod

SoftShadowMapMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class SoftShadowMapMethod
Inheritance | SoftShadowMapMethod Inheritance SimpleShadowMapMethodBase Inheritance ShadowMapMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number | ShadowMapMethodBase
Inherited | castingLight : LightBase [read-only] | ShadowMapMethodBase
Inherited | epsilon : Number | ShadowMapMethodBase
 | numSamples : int | SoftShadowMapMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | range : Number | SoftShadowMapMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alpha : Number = 1 | ShadowMapMethodBase
Inherited | _castingLight : LightBase | ShadowMapMethodBase
Inherited | _depthMapCoordReg : ShaderRegisterElement | SimpleShadowMapMethodBase
Inherited | _epsilon : Number = .002 | ShadowMapMethodBase
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowMapper : ShadowMapperBase | ShadowMapMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _usePoint : Boolean | SimpleShadowMapMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SoftShadowMapMethod(castingLight:DirectionalLight, numSamples:int = 5) Creates a new BasicDiffuseMethod object. | SoftShadowMapMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
getPlanarFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
[override]
SoftShadowMapMethod
Inherited
getPlanarVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
Inherited
getPointFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
SimpleShadowMapMethodBase
Inherited
getPointVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
numSamples property
numSamples:int

Implementation
    public function get numSamples():int
    public function set numSamples(value:int):void
range property
range:Number

Implementation
    public function get range():Number
    public function set range(value:Number):void
Constructor Detail
SoftShadowMapMethod () Constructor
public function SoftShadowMapMethod(castingLight:DirectionalLight, numSamples:int = 5)

Creates a new BasicDiffuseMethod object.

Parameters
castingLight:DirectionalLight
numSamples:int (default = 5)
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

activateForCascade () method
override arcane function activateForCascade(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getCascadeFragmentCode () method
override arcane function getCascadeFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, decodeRegister:ShaderRegisterElement, depthTexture:ShaderRegisterElement, depthProjection:ShaderRegisterElement, targetRegister:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
decodeRegister:ShaderRegisterElement
depthTexture:ShaderRegisterElement
depthProjection:ShaderRegisterElement
targetRegister:ShaderRegisterElement

Returns
String
getPlanarFragmentCode () method
override protected function getPlanarFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.SpecularShadingModel

SpecularShadingModel | Constants
Package | away3d.materials.methods
Class | public class SpecularShadingModel
Inheritance | SpecularShadingModel Inheritance Object

Public Constants
Constant |  | Defined By
 | BLINN_PHONG : String = blinnPhong [static] | SpecularShadingModel
 | PHONG : String = phong [static] | SpecularShadingModel
Constant Detail
BLINN_PHONG Constant
public static const BLINN_PHONG:String = blinnPhong

PHONG Constant
public static const PHONG:String = phong


away3d.materials.methods.SubsurfaceScatteringDiffuseMethod

SubsurfaceScatteringDiffuseMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class SubsurfaceScatteringDiffuseMethod
Inheritance | SubsurfaceScatteringDiffuseMethod Inheritance CompositeDiffuseMethod Inheritance BasicDiffuseMethod Inheritance LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

SubsurfaceScatteringDiffuseMethod provides a depth map-based diffuse shading method that mimics the scattering of light inside translucent surfaces. It allows light to shine through an object and to soften the diffuse shading. It can be used for candle wax, ice, skin, ...

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaThreshold : Number [override] | CompositeDiffuseMethod
Inherited | diffuseAlpha : Number [override] The alpha component of the diffuse reflection. | CompositeDiffuseMethod
Inherited | diffuseColor : uint [override] The color of the diffuse reflection when not using a texture. | CompositeDiffuseMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | scatterColor : uint The colour the light becomes inside the object. | SubsurfaceScatteringDiffuseMethod
 | scattering : Number The amount by which the light scatters. | SubsurfaceScatteringDiffuseMethod
Inherited | texture : Texture2DBase [override] The bitmapData to use to define the diffuse reflection color per texel. | CompositeDiffuseMethod
Inherited | _totalLightColorReg : ShaderRegisterElement | BasicDiffuseMethod
 | translucency : Number The translucency of the object. | SubsurfaceScatteringDiffuseMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaThreshold : Number = 0 | BasicDiffuseMethod
Inherited | _baseDiffuseMethod : BasicDiffuseMethod | CompositeDiffuseMethod
Inherited | _diffuseInputRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _isFirstLight : Boolean | BasicDiffuseMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _useTexture : Boolean | BasicDiffuseMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SubsurfaceScatteringDiffuseMethod(depthMapSize:int = 512, depthMapOffset:Number = 15) Creates a new SubsurfaceScatteringDiffuseMethod object. | SubsurfaceScatteringDiffuseMethod
Inherited | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicDiffuseMethod object into the current object. | BasicDiffuseMethod
Inherited | dispose():void [override] Cleans up any resources used by the current object. | CompositeDiffuseMethod
Inherited | generateMip(stage3DProxy:Stage3DProxy):void | BasicDiffuseMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
scatterColor property
scatterColor:uint

The colour the light becomes inside the object.

Implementation
    public function get scatterColor():uint
    public function set scatterColor(value:uint):void
scattering property
scattering:Number

The amount by which the light scatters. It can be used to set the translucent surface's thickness. Use low values for skin.

Implementation
    public function get scattering():Number
    public function set scattering(value:Number):void
translucency property
translucency:Number

The translucency of the object.

Implementation
    public function get translucency():Number
    public function set translucency(value:Number):void
Constructor Detail
SubsurfaceScatteringDiffuseMethod () Constructor
public function SubsurfaceScatteringDiffuseMethod(depthMapSize:int = 512, depthMapOffset:Number = 15)

Creates a new SubsurfaceScatteringDiffuseMethod object.

Parameters
depthMapSize:int (default = 512) — The size of the depth map used.
depthMapOffset:Number (default = 15) — The amount by which the rendered object will be inflated, to prevent depth map rounding errors.
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

getFragmentCodePerLight () method
override arcane function getFragmentCodePerLight(vo:MethodVO, lightDirReg:ShaderRegisterElement, lightColReg:ShaderRegisterElement, regCache:ShaderRegisterCache):String

Get the fragment shader code that will generate the code relevant to a single light.

Parameters

vo:MethodVO
lightDirReg:ShaderRegisterElement
lightColReg:ShaderRegisterElement
regCache:ShaderRegisterCache

Returns
String
getFragmentPostLightingCode () method
override arcane function getFragmentPostLightingCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
getFragmentPreLightingCode () method
override arcane function getFragmentPreLightingCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
getVertexCode () method
override arcane function getVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO

setRenderState () method
override arcane function setRenderState(vo:MethodVO, renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

vo:MethodVO
renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D


away3d.materials.methods.TerrainDiffuseMethod

TerrainDiffuseMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class TerrainDiffuseMethod
Inheritance | TerrainDiffuseMethod Inheritance BasicDiffuseMethod Inheritance LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alphaThreshold : Number [override] | TerrainDiffuseMethod
Inherited | diffuseAlpha : Number The alpha component of the diffuse reflection. | BasicDiffuseMethod
Inherited | diffuseColor : uint The color of the diffuse reflection when not using a texture. | BasicDiffuseMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Inherited | texture : Texture2DBase The bitmapData to use to define the diffuse reflection color per texel. | BasicDiffuseMethod
Inherited | _totalLightColorReg : ShaderRegisterElement | BasicDiffuseMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaThreshold : Number = 0 | BasicDiffuseMethod
Inherited | _diffuseInputRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _isFirstLight : Boolean | BasicDiffuseMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _useTexture : Boolean | BasicDiffuseMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | TerrainDiffuseMethod(splatTextures:Array, blendingTexture:Texture2DBase, tileData:Array) | TerrainDiffuseMethod
Inherited | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicDiffuseMethod object into the current object. | BasicDiffuseMethod
Inherited | dispose():void [override] Cleans up any resources used by the current object. | BasicDiffuseMethod
Inherited | generateMip(stage3DProxy:Stage3DProxy):void | BasicDiffuseMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
getSplatSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null):String
TerrainDiffuseMethod
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
alphaThreshold property
alphaThreshold:Number[override]

Implementation
    public function get alphaThreshold():Number
    public function set alphaThreshold(value:Number):void
Constructor Detail
TerrainDiffuseMethod () Constructor
public function TerrainDiffuseMethod(splatTextures:Array, blendingTexture:Texture2DBase, tileData:Array)

Parameters
splatTextures:Array — An array of Texture2DProxyBase containing the detailed textures to be tiled.
blendingTexture:Texture2DBase — The texture containing the blending data. The red, green, and blue channels contain the blending values for each of the textures in splatTextures, respectively.
tileData:Array — The amount of times each splat texture needs to be tiled. The first entry in the array applies to the base texture, the others to the splats. If omitted, the default value of 50 is assumed for each.
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

getFragmentPostLightingCode () method
override arcane function getFragmentPostLightingCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
getSplatSampleCode () method
protected function getSplatSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null):String

Parameters

vo:MethodVO
targetReg:ShaderRegisterElement
inputReg:ShaderRegisterElement
texture:TextureProxyBase
uvReg:ShaderRegisterElement (default = null)

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.TripleFilteredShadowMapMethod

TripleFilteredShadowMapMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class TripleFilteredShadowMapMethod
Inheritance | TripleFilteredShadowMapMethod Inheritance SimpleShadowMapMethodBase Inheritance ShadowMapMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher
Deprecated: Please consider any of the superior shadow map methods: SoftShadowMapMethod or DitheredShadowMapMethod

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number | ShadowMapMethodBase
Inherited | castingLight : LightBase [read-only] | ShadowMapMethodBase
Inherited | epsilon : Number | ShadowMapMethodBase
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alpha : Number = 1 | ShadowMapMethodBase
Inherited | _castingLight : LightBase | ShadowMapMethodBase
Inherited | _depthMapCoordReg : ShaderRegisterElement | SimpleShadowMapMethodBase
Inherited | _epsilon : Number = .002 | ShadowMapMethodBase
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowMapper : ShadowMapperBase | ShadowMapMethodBase
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _usePoint : Boolean | SimpleShadowMapMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | TripleFilteredShadowMapMethod(castingLight:DirectionalLight) Creates a new BasicDiffuseMethod object. | TripleFilteredShadowMapMethod
Inherited | copyFrom(method:ShadingMethodBase):void Copies the state from a ShadingMethodBase object into the current object. | ShadingMethodBase
Inherited | dispose():void Cleans up any resources used by the current object. | ShadingMethodBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
getPlanarFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
[override]
TripleFilteredShadowMapMethod
Inherited
getPlanarVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
Inherited
getPointFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String
SimpleShadowMapMethodBase
Inherited
getPointVertexCode(vo:MethodVO, regCache:ShaderRegisterCache):String
SimpleShadowMapMethodBase
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Constructor Detail
TripleFilteredShadowMapMethod () Constructor
public function TripleFilteredShadowMapMethod(castingLight:DirectionalLight)

Creates a new BasicDiffuseMethod object.

Parameters
castingLight:DirectionalLight — The light casting the shadow
Method Detail
getPlanarFragmentCode () method
override protected function getPlanarFragmentCode(vo:MethodVO, regCache:ShaderRegisterCache, targetReg:ShaderRegisterElement):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache
targetReg:ShaderRegisterElement

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.methods.WrapDiffuseMethod

WrapDiffuseMethod | Properties | Methods
Package | away3d.materials.methods
Class | public class WrapDiffuseMethod
Inheritance | WrapDiffuseMethod Inheritance BasicDiffuseMethod Inheritance LightingMethodBase Inheritance ShadingMethodBase Inheritance flash.events.EventDispatcher

WrapDiffuseMethod is an alternative to BasicDiffuseMethod in which the light is allowed to be "wrapped around" the normally dark area, to some extent. It can be used as a crude approximation to Oren-Nayar or subsurface scattering.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaThreshold : Number The minimum alpha value for which pixels should be drawn. | BasicDiffuseMethod
Inherited | diffuseAlpha : Number The alpha component of the diffuse reflection. | BasicDiffuseMethod
Inherited | diffuseColor : uint The color of the diffuse reflection when not using a texture. | BasicDiffuseMethod
Inherited | passes : Vector.<MaterialPassBase> [read-only] Any passes required that render to a texture used by this method. | ShadingMethodBase
 | scatterTexture : Texture2DBase | WrapDiffuseMethod
Inherited | texture : Texture2DBase The bitmapData to use to define the diffuse reflection color per texel. | BasicDiffuseMethod
Inherited | _totalLightColorReg : ShaderRegisterElement | BasicDiffuseMethod
 | wrapFactor : Number | WrapDiffuseMethod
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaThreshold : Number = 0 | BasicDiffuseMethod
Inherited | _diffuseInputRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _isFirstLight : Boolean | BasicDiffuseMethod
Inherited | _passes : Vector.<MaterialPassBase> | ShadingMethodBase
Inherited | _shadowRegister : ShaderRegisterElement | BasicDiffuseMethod
Inherited | _sharedRegisters : ShaderRegisterData | ShadingMethodBase
Inherited | _useTexture : Boolean | BasicDiffuseMethod
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | WrapDiffuseMethod(wrapFactor:Number = .5, scatterTexture:Texture2DBase = null) Creates a new WrapDiffuseMethod object. | WrapDiffuseMethod
Inherited | copyFrom(method:ShadingMethodBase):void [override] Copies the state from a BasicDiffuseMethod object into the current object. | BasicDiffuseMethod
Inherited | dispose():void [override] Cleans up any resources used by the current object. | BasicDiffuseMethod
Inherited | generateMip(stage3DProxy:Stage3DProxy):void | BasicDiffuseMethod
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method Defined By
Inherited
getTex2DSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement = null, forceWrap:String = null):String
A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
ShadingMethodBase
Inherited
getTexCubeSampleCode(vo:MethodVO, targetReg:ShaderRegisterElement, inputReg:ShaderRegisterElement, texture:TextureProxyBase, uvReg:ShaderRegisterElement):String
ShadingMethodBase
Inherited
invalidateShaderProgram():void
Marks the shader program as invalid, so it will be recompiled before the next render.
ShadingMethodBase
Property Detail
scatterTexture property
scatterTexture:Texture2DBase

Implementation
    public function get scatterTexture():Texture2DBase
    public function set scatterTexture(value:Texture2DBase):void
wrapFactor property
wrapFactor:Number

Implementation
    public function get wrapFactor():Number
    public function set wrapFactor(value:Number):void
Constructor Detail
WrapDiffuseMethod () Constructor
public function WrapDiffuseMethod(wrapFactor:Number = .5, scatterTexture:Texture2DBase = null)

Creates a new WrapDiffuseMethod object.

Parameters
wrapFactor:Number (default = .5) — A factor to indicate the amount by which the light is allowed to wrap
scatterTexture:Texture2DBase (default = null) — A texture that contains the light colour based on the angle. This can be used to change the light colour due to subsurface scattering when dot < 0
Method Detail
activate () method
override arcane function activate(vo:MethodVO, stage3DProxy:Stage3DProxy):void

Parameters

vo:MethodVO
stage3DProxy:Stage3DProxy

cleanCompilationData () method
override arcane function cleanCompilationData():void

getFragmentCodePerLight () method
override arcane function getFragmentCodePerLight(vo:MethodVO, lightDirReg:ShaderRegisterElement, lightColReg:ShaderRegisterElement, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
lightDirReg:ShaderRegisterElement
lightColReg:ShaderRegisterElement
regCache:ShaderRegisterCache

Returns
String
getFragmentPreLightingCode () method
override arcane function getFragmentPreLightingCode(vo:MethodVO, regCache:ShaderRegisterCache):String

Parameters

vo:MethodVO
regCache:ShaderRegisterCache

Returns
String
initConstants () method
override arcane function initConstants(vo:MethodVO):void

Parameters

vo:MethodVO


away3d.materials.passes - Away3D Documentation

Package away3d.materials.passes

Classes
CompiledPass
DepthMapPass
DistanceMapPass
LightingPass
MaterialPassBase
OutlinePass
SegmentPass
ShadowCasterPass
SingleObjectDepthPass
SkyBoxPass
SuperShaderPass


away3d.materials.passes Summary

away3d.materials.passes | Classes

Classes
Class | Description
CompiledPass |
DepthMapPass |
DistanceMapPass |
LightingPass | DefaultScreenPass is a shader pass that uses shader methods to compile a complete program.
MaterialPassBase | MaterialPassBase provides an abstract base class for material shader passes.
OutlinePass |
SegmentPass |
ShadowCasterPass | DefaultScreenPass is a shader pass that uses shader methods to compile a complete program.
SingleObjectDepthPass | The SingleObjectDepthPass provides a material pass that renders a single object to a depth map from the point of view from a light.
SkyBoxPass | SkyBoxPass provides a material pass exclusively used to render sky boxes from a cube texture.
SuperShaderPass | DefaultScreenPass is a shader pass that uses shader methods to compile a complete program.

Thu Nov 15 2012, 12:09 PM Z


away3d.materials.passes.CompiledPass

CompiledPass | Properties | Methods
Package | away3d.materials.passes
Class | public class CompiledPass
Inheritance | CompiledPass Inheritance MaterialPassBase Inheritance flash.events.EventDispatcher
Subclasses | LightingPass, ShadowCasterPass, SuperShaderPass

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean | MaterialPassBase
 | ambientMethod : BasicAmbientMethod | CompiledPass
 | animateUVs : Boolean | CompiledPass
Inherited | animationRegisterCache : AnimationRegisterCache | MaterialPassBase
Inherited | animationSet : IAnimationSet The animation used to add vertex code to the shader code. | MaterialPassBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialPassBase
Inherited | depthCompareMode : String | MaterialPassBase
 | diffuseLightSources : uint | CompiledPass
 | diffuseMethod : BasicDiffuseMethod | CompiledPass
Inherited | material : MaterialBase The material to which this pass belongs. | MaterialPassBase
 | mipmap : Boolean [override] Defines whether any used textures should use mipmapping. | CompiledPass
Inherited | needFragmentAnimation : Boolean [read-only] | MaterialPassBase
Inherited | needUVAnimation : Boolean [read-only] | MaterialPassBase
 | normalMap : Texture2DBase The tangent space normal map to influence the direction of the surface for each texel. | CompiledPass
 | normalMethod : BasicNormalMethod | CompiledPass
Inherited | numUsedFragmentConstants : uint [read-only] | MaterialPassBase
Inherited | numUsedStreams : uint [read-only] The amount of used vertex streams in the vertex code. | MaterialPassBase
Inherited | numUsedVaryings : uint [read-only] | MaterialPassBase
Inherited | numUsedVertexConstants : uint [read-only] The amount of used vertex constants in the vertex code. | MaterialPassBase
 | preserveAlpha : Boolean | CompiledPass
Inherited | renderToTexture : Boolean [read-only] Specifies whether this pass renders to texture | MaterialPassBase
Inherited | repeat : Boolean Defines whether textures should be tiled. | MaterialPassBase
 | shadowMethod : ShadowMapMethodBase | CompiledPass
Inherited | smooth : Boolean Defines whether smoothing should be applied to any used textures. | MaterialPassBase
 | specularLightSources : uint | CompiledPass
 | specularMethod : BasicSpecularMethod | CompiledPass
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaPremultiplied : Boolean | MaterialPassBase
 | _ambientLightB : Number | CompiledPass
 | _ambientLightG : Number | CompiledPass
 | _ambientLightR : Number | CompiledPass
Inherited | _animatableAttributes : Vector.<String> | MaterialPassBase
 | _animateUVs : Boolean | CompiledPass
Inherited | _animationSet : IAnimationSet | MaterialPassBase
Inherited | _animationTargetRegisters : Vector.<String> | MaterialPassBase
 | _cameraPositionIndex : int | CompiledPass
 | _commonsDataIndex : int | CompiledPass
 | _compiler : ShaderCompiler | CompiledPass
Inherited | _defaultCulling : String = back | MaterialPassBase
Inherited | _depthCompareMode : String = lessEqual | MaterialPassBase
 | _diffuseLightSources : uint = 0x03 | CompiledPass
 | _fragmentAnimationCode : String | CompiledPass
 | _fragmentConstantData : Vector.<Number> | CompiledPass
 | _fragmentLightCode : String | CompiledPass
 | _framentPostLightCode : String | CompiledPass
 | _lightFragmentConstantIndex : int | CompiledPass
Inherited | _lightPicker : LightPickerBase | MaterialPassBase
 | _lightProbeDiffuseIndices : Vector.<uint> | CompiledPass
 | _lightProbeSpecularIndices : Vector.<uint> | CompiledPass
Inherited | _material : MaterialBase | MaterialPassBase
 | _methodSetup : ShaderMethodSetup | CompiledPass
Inherited | _mipmap : Boolean = true | MaterialPassBase
Inherited | _needFragmentAnimation : Boolean | MaterialPassBase
Inherited | _needUVAnimation : Boolean | MaterialPassBase
 | _normalBufferIndex : int | CompiledPass
 | _numDirectionalLights : uint | CompiledPass
 | _numLightProbes : uint | CompiledPass
 | _numPointLights : uint | CompiledPass
Inherited | _numUsedFragmentConstants : uint | MaterialPassBase
Inherited | _numUsedStreams : uint | MaterialPassBase
Inherited | _numUsedTextures : uint | MaterialPassBase
Inherited | _numUsedVaryings : uint | MaterialPassBase
Inherited | _numUsedVertexConstants : uint | MaterialPassBase
 | _preserveAlpha : Boolean = true | CompiledPass
 | _probeWeightsIndex : int | CompiledPass
Inherited | _repeat : Boolean = false | MaterialPassBase
 | _sceneMatrixIndex : int | CompiledPass
 | _sceneNormalMatrixIndex : int | CompiledPass
 | _secondaryUVBufferIndex : int | CompiledPass
Inherited | _shadedTarget : String = ft0 | MaterialPassBase
Inherited | _smooth : Boolean = true | MaterialPassBase
 | _specularLightSources : uint = 0x01 | CompiledPass
 | _tangentBufferIndex : int | CompiledPass
 | _usesNormals : Boolean | CompiledPass
 | _usingSpecularMethod : Boolean | CompiledPass
 | _uvBufferIndex : int | CompiledPass
Inherited | _UVSource : String | MaterialPassBase
Inherited | _UVTarget : String | MaterialPassBase
 | _uvTransformIndex : int | CompiledPass
 | _vertexCode : String | CompiledPass
 | _vertexConstantData : Vector.<Number> | CompiledPass
 | _vertexConstantsOffset : uint | CompiledPass
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CompiledPass(material:MaterialBase) | CompiledPass
 | dispose():void [override] Cleans up any resources used by the current object. | CompiledPass
Inherited | setBlendMode(value:String, force:Boolean = false):void | MaterialPassBase
Protected Methods
Method |  | Defined By
 | addPasses(passes:Vector.<MaterialPassBase>):void Adds passes to the list. | CompiledPass
 | addPassesFromMethods():void | CompiledPass
 | cleanUp():void | CompiledPass
 | createCompiler():ShaderCompiler | CompiledPass
 | initCommonsData():void | CompiledPass
 | initCompiler():void | CompiledPass
 | initUVTransformData():void | CompiledPass
 | updateLightConstants():void | CompiledPass
 | updateLights():void [override] | CompiledPass
 | updateMethodConstants():void | CompiledPass
 | updateProbes(stage3DProxy:Stage3DProxy):void | CompiledPass
 | updateRegisterIndices():void | CompiledPass
 | updateShaderProperties():void | CompiledPass
 | usesLights():Boolean | CompiledPass
 | usesProbes():Boolean | CompiledPass
Property Detail
_ambientLightB property
protected var _ambientLightB:Number

_ambientLightG property
protected var _ambientLightG:Number

_ambientLightR property
protected var _ambientLightR:Number

_animateUVs property
protected var _animateUVs:Boolean

_cameraPositionIndex property
protected var _cameraPositionIndex:int

_commonsDataIndex property
protected var _commonsDataIndex:int

_compiler property
protected var _compiler:ShaderCompiler

_diffuseLightSources property
protected var _diffuseLightSources:uint = 0x03

_fragmentAnimationCode property
protected var _fragmentAnimationCode:String

_fragmentConstantData property
protected var _fragmentConstantData:Vector.<Number>

_fragmentLightCode property
protected var _fragmentLightCode:String

_framentPostLightCode property
protected var _framentPostLightCode:String

_lightFragmentConstantIndex property
protected var _lightFragmentConstantIndex:int

_lightProbeDiffuseIndices property
protected var _lightProbeDiffuseIndices:Vector.<uint>

_lightProbeSpecularIndices property
protected var _lightProbeSpecularIndices:Vector.<uint>

_methodSetup property
protected var _methodSetup:ShaderMethodSetup

_normalBufferIndex property
protected var _normalBufferIndex:int

_numDirectionalLights property
protected var _numDirectionalLights:uint

_numLightProbes property
protected var _numLightProbes:uint

_numPointLights property
protected var _numPointLights:uint

_passes property
arcane var _passes:Vector.<MaterialPassBase>

_passesDirty property
arcane var _passesDirty:Boolean

_preserveAlpha property
protected var _preserveAlpha:Boolean = true

_probeWeightsIndex property
protected var _probeWeightsIndex:int

_sceneMatrixIndex property
protected var _sceneMatrixIndex:int

_sceneNormalMatrixIndex property
protected var _sceneNormalMatrixIndex:int

_secondaryUVBufferIndex property
protected var _secondaryUVBufferIndex:int

_specularLightSources property
protected var _specularLightSources:uint = 0x01

_tangentBufferIndex property
protected var _tangentBufferIndex:int

_usesNormals property
protected var _usesNormals:Boolean

_usingSpecularMethod property
protected var _usingSpecularMethod:Boolean

_uvBufferIndex property
protected var _uvBufferIndex:int

_uvTransformIndex property
protected var _uvTransformIndex:int

_vertexCode property
protected var _vertexCode:String

_vertexConstantData property
protected var _vertexConstantData:Vector.<Number>

_vertexConstantsOffset property
protected var _vertexConstantsOffset:uint

ambientMethod property
ambientMethod:BasicAmbientMethod

Implementation
    public function get ambientMethod():BasicAmbientMethod
    public function set ambientMethod(value:BasicAmbientMethod):void
animateUVs property
animateUVs:Boolean

Implementation
    public function get animateUVs():Boolean
    public function set animateUVs(value:Boolean):void
diffuseLightSources property
diffuseLightSources:uint

Implementation
    public function get diffuseLightSources():uint
    public function set diffuseLightSources(value:uint):void
diffuseMethod property
diffuseMethod:BasicDiffuseMethod

Implementation
    public function get diffuseMethod():BasicDiffuseMethod
    public function set diffuseMethod(value:BasicDiffuseMethod):void
mipmap property
mipmap:Boolean[override]

Defines whether any used textures should use mipmapping.

Implementation
    public function get mipmap():Boolean
    public function set mipmap(value:Boolean):void
normalMap property
normalMap:Texture2DBase

The tangent space normal map to influence the direction of the surface for each texel.

Implementation
    public function get normalMap():Texture2DBase
    public function set normalMap(value:Texture2DBase):void
normalMethod property
normalMethod:BasicNormalMethod

Implementation
    public function get normalMethod():BasicNormalMethod
    public function set normalMethod(value:BasicNormalMethod):void
numDirectionalLights property
numDirectionalLights:uint [read-only]

Implementation
    arcane function get numDirectionalLights():uint
numLightProbes property
numLightProbes:uint [read-only]

Implementation
    arcane function get numLightProbes():uint
numPointLights property
numPointLights:uint [read-only]

Implementation
    arcane function get numPointLights():uint
preserveAlpha property
preserveAlpha:Boolean

Implementation
    public function get preserveAlpha():Boolean
    public function set preserveAlpha(value:Boolean):void
shadowMethod property
shadowMethod:ShadowMapMethodBase

Implementation
    public function get shadowMethod():ShadowMapMethodBase
    public function set shadowMethod(value:ShadowMapMethodBase):void
specularLightSources property
specularLightSources:uint

Implementation
    public function get specularLightSources():uint
    public function set specularLightSources(value:uint):void
specularMethod property
specularMethod:BasicSpecularMethod

Implementation
    public function get specularMethod():BasicSpecularMethod
    public function set specularMethod(value:BasicSpecularMethod):void
Constructor Detail
CompiledPass () Constructor
public function CompiledPass(material:MaterialBase)

Parameters
material:MaterialBase
Method Detail
activate () method
override arcane function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, textureRatioX:Number, textureRatioY:Number):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
textureRatioX:Number
textureRatioY:Number

addPasses () method
protected function addPasses(passes:Vector.<MaterialPassBase>):void

Adds passes to the list.

Parameters

passes:Vector.<MaterialPassBase>

addPassesFromMethods () method
protected function addPassesFromMethods():void

cleanUp () method
protected function cleanUp():void

createCompiler () method
protected function createCompiler():ShaderCompiler

Returns
ShaderCompiler
deactivate () method
override arcane function deactivate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

dispose () method
override public function dispose():void

Cleans up any resources used by the current object.

getFragmentCode () method
override arcane function getFragmentCode(animatorCode:String):String

Parameters

animatorCode:String

Returns
String
getVertexCode () method
override arcane function getVertexCode():String

Returns
String
initCommonsData () method
protected function initCommonsData():void

initCompiler () method
protected function initCompiler():void

initUVTransformData () method
protected function initUVTransformData():void

invalidateShaderProgram () method
override arcane function invalidateShaderProgram(updateMaterial:Boolean = true):void

Marks the shader program as invalid, so it will be recompiled before the next render.

Parameters

updateMaterial:Boolean (default = true)

render () method
override arcane function render(renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D

updateLightConstants () method
protected function updateLightConstants():void

updateLights () method
override protected function updateLights():void

updateMethodConstants () method
protected function updateMethodConstants():void

updateProbes () method
protected function updateProbes(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

updateProgram () method
override arcane function updateProgram(stage3DProxy:Stage3DProxy):void

Compiles the shader program.

Parameters

stage3DProxy:Stage3DProxy — An optional register that contains an amount by which to inflate the model (used in single object depth map rendering).

updateRegisterIndices () method
protected function updateRegisterIndices():void

updateShaderProperties () method
protected function updateShaderProperties():void

usesLights () method
protected function usesLights():Boolean

Returns
Boolean
usesProbes () method
protected function usesProbes():Boolean

Returns
Boolean


away3d.materials.passes.DepthMapPass

DepthMapPass | Properties | Methods
Package | away3d.materials.passes
Class | public class DepthMapPass
Inheritance | DepthMapPass Inheritance MaterialPassBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alphaMask : Texture2DBase | DepthMapPass
Inherited | alphaPremultiplied : Boolean | MaterialPassBase
 | alphaThreshold : Number The minimum alpha value for which pixels should be drawn. | DepthMapPass
Inherited | animationRegisterCache : AnimationRegisterCache | MaterialPassBase
Inherited | animationSet : IAnimationSet The animation used to add vertex code to the shader code. | MaterialPassBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialPassBase
Inherited | depthCompareMode : String | MaterialPassBase
Inherited | material : MaterialBase The material to which this pass belongs. | MaterialPassBase
Inherited | mipmap : Boolean Defines whether any used textures should use mipmapping. | MaterialPassBase
Inherited | needFragmentAnimation : Boolean [read-only] | MaterialPassBase
Inherited | needUVAnimation : Boolean [read-only] | MaterialPassBase
Inherited | numUsedFragmentConstants : uint [read-only] | MaterialPassBase
Inherited | numUsedStreams : uint [read-only] The amount of used vertex streams in the vertex code. | MaterialPassBase
Inherited | numUsedVaryings : uint [read-only] | MaterialPassBase
Inherited | numUsedVertexConstants : uint [read-only] The amount of used vertex constants in the vertex code. | MaterialPassBase
Inherited | renderToTexture : Boolean [read-only] Specifies whether this pass renders to texture | MaterialPassBase
Inherited | repeat : Boolean Defines whether textures should be tiled. | MaterialPassBase
Inherited | smooth : Boolean Defines whether smoothing should be applied to any used textures. | MaterialPassBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaPremultiplied : Boolean | MaterialPassBase
Inherited | _animatableAttributes : Vector.<String> | MaterialPassBase
Inherited | _animationSet : IAnimationSet | MaterialPassBase
Inherited | _animationTargetRegisters : Vector.<String> | MaterialPassBase
Inherited | _defaultCulling : String = back | MaterialPassBase
Inherited | _depthCompareMode : String = lessEqual | MaterialPassBase
Inherited | _lightPicker : LightPickerBase | MaterialPassBase
Inherited | _material : MaterialBase | MaterialPassBase
Inherited | _mipmap : Boolean = true | MaterialPassBase
Inherited | _needFragmentAnimation : Boolean | MaterialPassBase
Inherited | _needUVAnimation : Boolean | MaterialPassBase
Inherited | _numUsedFragmentConstants : uint | MaterialPassBase
Inherited | _numUsedStreams : uint | MaterialPassBase
Inherited | _numUsedTextures : uint | MaterialPassBase
Inherited | _numUsedVaryings : uint | MaterialPassBase
Inherited | _numUsedVertexConstants : uint | MaterialPassBase
Inherited | _repeat : Boolean = false | MaterialPassBase
Inherited | _shadedTarget : String = ft0 | MaterialPassBase
Inherited | _smooth : Boolean = true | MaterialPassBase
Inherited | _UVSource : String | MaterialPassBase
Inherited | _UVTarget : String | MaterialPassBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DepthMapPass() | DepthMapPass
Inherited | dispose():void Cleans up any resources used by the current object. | MaterialPassBase
Inherited | setBlendMode(value:String, force:Boolean = false):void | MaterialPassBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateLights():void | MaterialPassBase
Property Detail
alphaMask property
alphaMask:Texture2DBase

Implementation
    public function get alphaMask():Texture2DBase
    public function set alphaMask(value:Texture2DBase):void
alphaThreshold property
alphaThreshold:Number

The minimum alpha value for which pixels should be drawn. This is used for transparency that is either invisible or entirely opaque, often used with textures for foliage, etc. Recommended values are 0 to disable alpha, or 0.5 to create smooth edges. Default value is 0 (disabled).

Implementation
    public function get alphaThreshold():Number
    public function set alphaThreshold(value:Number):void
Constructor Detail
DepthMapPass () Constructor
public function DepthMapPass()

Method Detail
activate () method
override arcane function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, textureRatioX:Number, textureRatioY:Number):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
textureRatioX:Number
textureRatioY:Number

getFragmentCode () method
override arcane function getFragmentCode(code:String):String

Parameters

code:String

Returns
String
getVertexCode () method
override arcane function getVertexCode():String

Returns
String
render () method
override arcane function render(renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D


away3d.materials.passes.DistanceMapPass

DistanceMapPass | Properties | Methods
Package | away3d.materials.passes
Class | public class DistanceMapPass
Inheritance | DistanceMapPass Inheritance MaterialPassBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alphaMask : Texture2DBase | DistanceMapPass
Inherited | alphaPremultiplied : Boolean | MaterialPassBase
 | alphaThreshold : Number The minimum alpha value for which pixels should be drawn. | DistanceMapPass
Inherited | animationRegisterCache : AnimationRegisterCache | MaterialPassBase
Inherited | animationSet : IAnimationSet The animation used to add vertex code to the shader code. | MaterialPassBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialPassBase
Inherited | depthCompareMode : String | MaterialPassBase
Inherited | material : MaterialBase The material to which this pass belongs. | MaterialPassBase
Inherited | mipmap : Boolean Defines whether any used textures should use mipmapping. | MaterialPassBase
Inherited | needFragmentAnimation : Boolean [read-only] | MaterialPassBase
Inherited | needUVAnimation : Boolean [read-only] | MaterialPassBase
Inherited | numUsedFragmentConstants : uint [read-only] | MaterialPassBase
Inherited | numUsedStreams : uint [read-only] The amount of used vertex streams in the vertex code. | MaterialPassBase
Inherited | numUsedVaryings : uint [read-only] | MaterialPassBase
Inherited | numUsedVertexConstants : uint [read-only] The amount of used vertex constants in the vertex code. | MaterialPassBase
Inherited | renderToTexture : Boolean [read-only] Specifies whether this pass renders to texture | MaterialPassBase
Inherited | repeat : Boolean Defines whether textures should be tiled. | MaterialPassBase
Inherited | smooth : Boolean Defines whether smoothing should be applied to any used textures. | MaterialPassBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaPremultiplied : Boolean | MaterialPassBase
Inherited | _animatableAttributes : Vector.<String> | MaterialPassBase
Inherited | _animationSet : IAnimationSet | MaterialPassBase
Inherited | _animationTargetRegisters : Vector.<String> | MaterialPassBase
Inherited | _defaultCulling : String = back | MaterialPassBase
Inherited | _depthCompareMode : String = lessEqual | MaterialPassBase
Inherited | _lightPicker : LightPickerBase | MaterialPassBase
Inherited | _material : MaterialBase | MaterialPassBase
Inherited | _mipmap : Boolean = true | MaterialPassBase
Inherited | _needFragmentAnimation : Boolean | MaterialPassBase
Inherited | _needUVAnimation : Boolean | MaterialPassBase
Inherited | _numUsedFragmentConstants : uint | MaterialPassBase
Inherited | _numUsedStreams : uint | MaterialPassBase
Inherited | _numUsedTextures : uint | MaterialPassBase
Inherited | _numUsedVaryings : uint | MaterialPassBase
Inherited | _numUsedVertexConstants : uint | MaterialPassBase
Inherited | _repeat : Boolean = false | MaterialPassBase
Inherited | _shadedTarget : String = ft0 | MaterialPassBase
Inherited | _smooth : Boolean = true | MaterialPassBase
Inherited | _UVSource : String | MaterialPassBase
Inherited | _UVTarget : String | MaterialPassBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DistanceMapPass() | DistanceMapPass
Inherited | dispose():void Cleans up any resources used by the current object. | MaterialPassBase
Inherited | setBlendMode(value:String, force:Boolean = false):void | MaterialPassBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateLights():void | MaterialPassBase
Property Detail
alphaMask property
alphaMask:Texture2DBase

Implementation
    public function get alphaMask():Texture2DBase
    public function set alphaMask(value:Texture2DBase):void
alphaThreshold property
alphaThreshold:Number

The minimum alpha value for which pixels should be drawn. This is used for transparency that is either invisible or entirely opaque, often used with textures for foliage, etc. Recommended values are 0 to disable alpha, or 0.5 to create smooth edges. Default value is 0 (disabled).

Implementation
    public function get alphaThreshold():Number
    public function set alphaThreshold(value:Number):void
Constructor Detail
DistanceMapPass () Constructor
public function DistanceMapPass()

Method Detail
activate () method
override arcane function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, textureRatioX:Number, textureRatioY:Number):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
textureRatioX:Number
textureRatioY:Number

getFragmentCode () method
override arcane function getFragmentCode(animationCode:String):String

Parameters

animationCode:String

Returns
String
getVertexCode () method
override arcane function getVertexCode():String

Returns
String
render () method
override arcane function render(renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D


away3d.materials.passes.LightingPass

LightingPass | Properties | Methods
Package | away3d.materials.passes
Class | public class LightingPass
Inheritance | LightingPass Inheritance CompiledPass Inheritance MaterialPassBase Inheritance flash.events.EventDispatcher

DefaultScreenPass is a shader pass that uses shader methods to compile a complete program.

See also

away3d.materials.methods.ShadingMethodBase

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean | MaterialPassBase
Inherited | ambientMethod : BasicAmbientMethod | CompiledPass
Inherited | animateUVs : Boolean | CompiledPass
Inherited | animationRegisterCache : AnimationRegisterCache | MaterialPassBase
Inherited | animationSet : IAnimationSet The animation used to add vertex code to the shader code. | MaterialPassBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialPassBase
Inherited | depthCompareMode : String | MaterialPassBase
Inherited | diffuseLightSources : uint | CompiledPass
Inherited | diffuseMethod : BasicDiffuseMethod | CompiledPass
 | directionalLightsOffset : uint | LightingPass
 | includeCasters : Boolean | LightingPass
 | lightProbesOffset : uint | LightingPass
Inherited | material : MaterialBase The material to which this pass belongs. | MaterialPassBase
Inherited | mipmap : Boolean [override] Defines whether any used textures should use mipmapping. | CompiledPass
Inherited | needFragmentAnimation : Boolean [read-only] | MaterialPassBase
Inherited | needUVAnimation : Boolean [read-only] | MaterialPassBase
Inherited | normalMap : Texture2DBase The tangent space normal map to influence the direction of the surface for each texel. | CompiledPass
Inherited | normalMethod : BasicNormalMethod | CompiledPass
Inherited | numUsedFragmentConstants : uint [read-only] | MaterialPassBase
Inherited | numUsedStreams : uint [read-only] The amount of used vertex streams in the vertex code. | MaterialPassBase
Inherited | numUsedVaryings : uint [read-only] | MaterialPassBase
Inherited | numUsedVertexConstants : uint [read-only] The amount of used vertex constants in the vertex code. | MaterialPassBase
 | pointLightsOffset : uint | LightingPass
Inherited | preserveAlpha : Boolean | CompiledPass
Inherited | renderToTexture : Boolean [read-only] Specifies whether this pass renders to texture | MaterialPassBase
Inherited | repeat : Boolean Defines whether textures should be tiled. | MaterialPassBase
Inherited | shadowMethod : ShadowMapMethodBase | CompiledPass
Inherited | smooth : Boolean Defines whether smoothing should be applied to any used textures. | MaterialPassBase
Inherited | specularLightSources : uint | CompiledPass
Inherited | specularMethod : BasicSpecularMethod | CompiledPass
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaPremultiplied : Boolean | MaterialPassBase
Inherited | _ambientLightB : Number | CompiledPass
Inherited | _ambientLightG : Number | CompiledPass
Inherited | _ambientLightR : Number | CompiledPass
Inherited | _animatableAttributes : Vector.<String> | MaterialPassBase
Inherited | _animateUVs : Boolean | CompiledPass
Inherited | _animationSet : IAnimationSet | MaterialPassBase
Inherited | _animationTargetRegisters : Vector.<String> | MaterialPassBase
Inherited | _cameraPositionIndex : int | CompiledPass
Inherited | _commonsDataIndex : int | CompiledPass
Inherited | _compiler : ShaderCompiler | CompiledPass
Inherited | _defaultCulling : String = back | MaterialPassBase
Inherited | _depthCompareMode : String = lessEqual | MaterialPassBase
Inherited | _diffuseLightSources : uint = 0x03 | CompiledPass
Inherited | _fragmentAnimationCode : String | CompiledPass
Inherited | _fragmentConstantData : Vector.<Number> | CompiledPass
Inherited | _fragmentLightCode : String | CompiledPass
Inherited | _framentPostLightCode : String | CompiledPass
Inherited | _lightFragmentConstantIndex : int | CompiledPass
Inherited | _lightPicker : LightPickerBase | MaterialPassBase
Inherited | _lightProbeDiffuseIndices : Vector.<uint> | CompiledPass
Inherited | _lightProbeSpecularIndices : Vector.<uint> | CompiledPass
Inherited | _material : MaterialBase | MaterialPassBase
Inherited | _methodSetup : ShaderMethodSetup | CompiledPass
Inherited | _mipmap : Boolean = true | MaterialPassBase
Inherited | _needFragmentAnimation : Boolean | MaterialPassBase
Inherited | _needUVAnimation : Boolean | MaterialPassBase
Inherited | _normalBufferIndex : int | CompiledPass
Inherited | _numDirectionalLights : uint | CompiledPass
Inherited | _numLightProbes : uint | CompiledPass
Inherited | _numPointLights : uint | CompiledPass
Inherited | _numUsedFragmentConstants : uint | MaterialPassBase
Inherited | _numUsedStreams : uint | MaterialPassBase
Inherited | _numUsedTextures : uint | MaterialPassBase
Inherited | _numUsedVaryings : uint | MaterialPassBase
Inherited | _numUsedVertexConstants : uint | MaterialPassBase
Inherited | _preserveAlpha : Boolean = true | CompiledPass
Inherited | _probeWeightsIndex : int | CompiledPass
Inherited | _repeat : Boolean = false | MaterialPassBase
Inherited | _sceneMatrixIndex : int | CompiledPass
Inherited | _sceneNormalMatrixIndex : int | CompiledPass
Inherited | _secondaryUVBufferIndex : int | CompiledPass
Inherited | _shadedTarget : String = ft0 | MaterialPassBase
Inherited | _smooth : Boolean = true | MaterialPassBase
Inherited | _specularLightSources : uint = 0x01 | CompiledPass
Inherited | _tangentBufferIndex : int | CompiledPass
Inherited | _usesNormals : Boolean | CompiledPass
Inherited | _usingSpecularMethod : Boolean | CompiledPass
Inherited | _uvBufferIndex : int | CompiledPass
Inherited | _UVSource : String | MaterialPassBase
Inherited | _UVTarget : String | MaterialPassBase
Inherited | _uvTransformIndex : int | CompiledPass
Inherited | _vertexCode : String | CompiledPass
Inherited | _vertexConstantData : Vector.<Number> | CompiledPass
Inherited | _vertexConstantsOffset : uint | CompiledPass
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | LightingPass(material:MaterialBase) Creates a new DefaultScreenPass objects. | LightingPass
Inherited | dispose():void [override] Cleans up any resources used by the current object. | CompiledPass
Inherited | setBlendMode(value:String, force:Boolean = false):void | MaterialPassBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addPasses(passes:Vector.<MaterialPassBase>):void Adds passes to the list. | CompiledPass
Inherited | addPassesFromMethods():void | CompiledPass
Inherited | cleanUp():void | CompiledPass
 | createCompiler():ShaderCompiler [override] | LightingPass
Inherited | initCommonsData():void | CompiledPass
Inherited | initCompiler():void | CompiledPass
Inherited | initUVTransformData():void | CompiledPass
 | updateLightConstants():void [override] | LightingPass
 | updateLights():void [override] | LightingPass
Inherited | updateMethodConstants():void | CompiledPass
 | updateProbes(stage3DProxy:Stage3DProxy):void [override] | LightingPass
 | updateRegisterIndices():void [override] | LightingPass
 | updateShaderProperties():void [override] | LightingPass
Inherited | usesLights():Boolean | CompiledPass
Inherited | usesProbes():Boolean | CompiledPass
Property Detail
directionalLightsOffset property
directionalLightsOffset:uint

Implementation
    public function get directionalLightsOffset():uint
    public function set directionalLightsOffset(value:uint):void
includeCasters property
includeCasters:Boolean

Implementation
    public function get includeCasters():Boolean
    public function set includeCasters(value:Boolean):void
lightProbesOffset property
lightProbesOffset:uint

Implementation
    public function get lightProbesOffset():uint
    public function set lightProbesOffset(value:uint):void
pointLightsOffset property
pointLightsOffset:uint

Implementation
    public function get pointLightsOffset():uint
    public function set pointLightsOffset(value:uint):void
Constructor Detail
LightingPass () Constructor
public function LightingPass(material:MaterialBase)

Creates a new DefaultScreenPass objects.

Parameters
material:MaterialBase
Method Detail
activate () method
override arcane function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, textureRatioX:Number, textureRatioY:Number):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
textureRatioX:Number
textureRatioY:Number

createCompiler () method
override protected function createCompiler():ShaderCompiler

Returns
ShaderCompiler
render () method
override arcane function render(renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D

updateLightConstants () method
override protected function updateLightConstants():void

updateLights () method
override protected function updateLights():void

updateProbes () method
override protected function updateProbes(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

updateRegisterIndices () method
override protected function updateRegisterIndices():void

updateShaderProperties () method
override protected function updateShaderProperties():void


away3d.materials.passes.MaterialPassBase

MaterialPassBase | Properties | Methods
Package | away3d.materials.passes
Class | public class MaterialPassBase
Inheritance | MaterialPassBase Inheritance flash.events.EventDispatcher
Subclasses | CompiledPass, DepthMapPass, DistanceMapPass, OutlinePass, SegmentPass, SingleObjectDepthPass, SkyBoxPass

MaterialPassBase provides an abstract base class for material shader passes. Vertex stream index 0 is reserved for vertex positions. Vertex shader constants index 0-3 are reserved for projections, constant 4 for viewport positioning Vertex shader constant index 4 is reserved for render-to-texture scaling

Public Properties
Property |  | Defined By
 | alphaPremultiplied : Boolean | MaterialPassBase
 | animationRegisterCache : AnimationRegisterCache | MaterialPassBase
 | animationSet : IAnimationSet The animation used to add vertex code to the shader code. | MaterialPassBase
 | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialPassBase
 | depthCompareMode : String | MaterialPassBase
 | material : MaterialBase The material to which this pass belongs. | MaterialPassBase
 | mipmap : Boolean Defines whether any used textures should use mipmapping. | MaterialPassBase
 | needFragmentAnimation : Boolean [read-only] | MaterialPassBase
 | needUVAnimation : Boolean [read-only] | MaterialPassBase
 | numUsedFragmentConstants : uint [read-only] | MaterialPassBase
 | numUsedStreams : uint [read-only] The amount of used vertex streams in the vertex code. | MaterialPassBase
 | numUsedVaryings : uint [read-only] | MaterialPassBase
 | numUsedVertexConstants : uint [read-only] The amount of used vertex constants in the vertex code. | MaterialPassBase
 | renderToTexture : Boolean [read-only] Specifies whether this pass renders to texture | MaterialPassBase
 | repeat : Boolean Defines whether textures should be tiled. | MaterialPassBase
 | smooth : Boolean Defines whether smoothing should be applied to any used textures. | MaterialPassBase
Protected Properties
Property |  | Defined By
 | _alphaPremultiplied : Boolean | MaterialPassBase
 | _animatableAttributes : Vector.<String> | MaterialPassBase
 | _animationSet : IAnimationSet | MaterialPassBase
 | _animationTargetRegisters : Vector.<String> | MaterialPassBase
 | _defaultCulling : String = back | MaterialPassBase
 | _depthCompareMode : String = lessEqual | MaterialPassBase
 | _lightPicker : LightPickerBase | MaterialPassBase
 | _material : MaterialBase | MaterialPassBase
 | _mipmap : Boolean = true | MaterialPassBase
 | _needFragmentAnimation : Boolean | MaterialPassBase
 | _needUVAnimation : Boolean | MaterialPassBase
 | _numUsedFragmentConstants : uint | MaterialPassBase
 | _numUsedStreams : uint | MaterialPassBase
 | _numUsedTextures : uint | MaterialPassBase
 | _numUsedVaryings : uint | MaterialPassBase
 | _numUsedVertexConstants : uint | MaterialPassBase
 | _repeat : Boolean = false | MaterialPassBase
 | _shadedTarget : String = ft0 | MaterialPassBase
 | _smooth : Boolean = true | MaterialPassBase
 | _UVSource : String | MaterialPassBase
 | _UVTarget : String | MaterialPassBase
Public Methods
Method |  | Defined By
 | MaterialPassBase(renderToTexture:Boolean = false) Creates a new MaterialPassBase object. | MaterialPassBase
 | dispose():void Cleans up any resources used by the current object. | MaterialPassBase
 | setBlendMode(value:String, force:Boolean = false):void | MaterialPassBase
Protected Methods
Method |  | Defined By
 | updateLights():void | MaterialPassBase
Property Detail
_alphaPremultiplied property
protected var _alphaPremultiplied:Boolean

_animatableAttributes property
protected var _animatableAttributes:Vector.<String>

_animationSet property
protected var _animationSet:IAnimationSet

_animationTargetRegisters property
protected var _animationTargetRegisters:Vector.<String>

_defaultCulling property
protected var _defaultCulling:String = back

_depthCompareMode property
protected var _depthCompareMode:String = lessEqual

_lightPicker property
protected var _lightPicker:LightPickerBase

_material property
protected var _material:MaterialBase

_mipmap property
protected var _mipmap:Boolean = true

_needFragmentAnimation property
protected var _needFragmentAnimation:Boolean

_needUVAnimation property
protected var _needUVAnimation:Boolean

_numUsedFragmentConstants property
protected var _numUsedFragmentConstants:uint

_numUsedStreams property
protected var _numUsedStreams:uint

_numUsedTextures property
protected var _numUsedTextures:uint

_numUsedVaryings property
protected var _numUsedVaryings:uint

_numUsedVertexConstants property
protected var _numUsedVertexConstants:uint

_program3Dids property
arcane var _program3Dids:Vector.<int>

_program3Ds property
arcane var _program3Ds:Vector.<Program3D>

_repeat property
protected var _repeat:Boolean = false

_shadedTarget property
protected var _shadedTarget:String = ft0

_smooth property
protected var _smooth:Boolean = true

_UVSource property
protected var _UVSource:String

_UVTarget property
protected var _UVTarget:String

alphaPremultiplied property
alphaPremultiplied:Boolean

Implementation
    public function get alphaPremultiplied():Boolean
    public function set alphaPremultiplied(value:Boolean):void
animationRegisterCache property
public var animationRegisterCache:AnimationRegisterCache

animationSet property
animationSet:IAnimationSet

The animation used to add vertex code to the shader code.

Implementation
    public function get animationSet():IAnimationSet
    public function set animationSet(value:IAnimationSet):void
bothSides property
bothSides:Boolean

Defines whether or not the material should perform backface culling.

Implementation
    public function get bothSides():Boolean
    public function set bothSides(value:Boolean):void
depthCompareMode property
depthCompareMode:String

Implementation
    public function get depthCompareMode():String
    public function set depthCompareMode(value:String):void
lightPicker property
lightPicker:LightPickerBase

Implementation
    arcane function get lightPicker():LightPickerBase
    arcane function set lightPicker(value:LightPickerBase):void
material property
material:MaterialBase

The material to which this pass belongs.

Implementation
    public function get material():MaterialBase
    public function set material(value:MaterialBase):void
mipmap property
mipmap:Boolean

Defines whether any used textures should use mipmapping.

Implementation
    public function get mipmap():Boolean
    public function set mipmap(value:Boolean):void
needFragmentAnimation property
needFragmentAnimation:Boolean [read-only]

Implementation
    public function get needFragmentAnimation():Boolean
needUVAnimation property
needUVAnimation:Boolean [read-only]

Implementation
    public function get needUVAnimation():Boolean
numUsedFragmentConstants property
numUsedFragmentConstants:uint [read-only]

Implementation
    public function get numUsedFragmentConstants():uint
numUsedStreams property
numUsedStreams:uint [read-only]

The amount of used vertex streams in the vertex code. Used by the animation code generation to know from which index on streams are available.

Implementation
    public function get numUsedStreams():uint
numUsedVaryings property
numUsedVaryings:uint [read-only]

Implementation
    public function get numUsedVaryings():uint
numUsedVertexConstants property
numUsedVertexConstants:uint [read-only]

The amount of used vertex constants in the vertex code. Used by the animation code generation to know from which index on registers are available.

Implementation
    public function get numUsedVertexConstants():uint
renderToTexture property
renderToTexture:Boolean [read-only]

Specifies whether this pass renders to texture

Implementation
    public function get renderToTexture():Boolean
repeat property
repeat:Boolean

Defines whether textures should be tiled.

Implementation
    public function get repeat():Boolean
    public function set repeat(value:Boolean):void
smooth property
smooth:Boolean

Defines whether smoothing should be applied to any used textures.

Implementation
    public function get smooth():Boolean
    public function set smooth(value:Boolean):void
Constructor Detail
MaterialPassBase () Constructor
public function MaterialPassBase(renderToTexture:Boolean = false)

Creates a new MaterialPassBase object.

Parameters
renderToTexture:Boolean (default = false)
Method Detail
activate () method
arcane function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, textureRatioX:Number, textureRatioY:Number):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
textureRatioX:Number
textureRatioY:Number

dispose () method
public function dispose():void

Cleans up any resources used by the current object.

getFragmentCode () method
arcane function getFragmentCode(code:String):String

Parameters

code:String

Returns
String
getVertexCode () method
arcane function getVertexCode():String

Returns
String
invalidateShaderProgram () method
arcane function invalidateShaderProgram(updateMaterial:Boolean = true):void

Marks the shader program as invalid, so it will be recompiled before the next render.

Parameters

updateMaterial:Boolean (default = true) — Indicates whether the invalidation should be performed on the entire material. Should always pass "true" unless it's called from the material itself.

setBlendMode () method
public function setBlendMode(value:String, force:Boolean = false):void

Parameters

value:String
force:Boolean (default = false)

updateLights () method
protected function updateLights():void

updateProgram () method
arcane function updateProgram(stage3DProxy:Stage3DProxy):void

Compiles the shader program.

Parameters

stage3DProxy:Stage3DProxy — An optional register that contains an amount by which to inflate the model (used in single object depth map rendering).


away3d.materials.passes.OutlinePass

OutlinePass | Properties | Methods
Package | away3d.materials.passes
Class | public class OutlinePass
Inheritance | OutlinePass Inheritance MaterialPassBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean | MaterialPassBase
Inherited | animationRegisterCache : AnimationRegisterCache | MaterialPassBase
Inherited | animationSet : IAnimationSet The animation used to add vertex code to the shader code. | MaterialPassBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialPassBase
Inherited | depthCompareMode : String | MaterialPassBase
Inherited | material : MaterialBase The material to which this pass belongs. | MaterialPassBase
Inherited | mipmap : Boolean Defines whether any used textures should use mipmapping. | MaterialPassBase
Inherited | needFragmentAnimation : Boolean [read-only] | MaterialPassBase
Inherited | needUVAnimation : Boolean [read-only] | MaterialPassBase
Inherited | numUsedFragmentConstants : uint [read-only] | MaterialPassBase
Inherited | numUsedStreams : uint [read-only] The amount of used vertex streams in the vertex code. | MaterialPassBase
Inherited | numUsedVaryings : uint [read-only] | MaterialPassBase
Inherited | numUsedVertexConstants : uint [read-only] The amount of used vertex constants in the vertex code. | MaterialPassBase
 | outlineColor : uint | OutlinePass
 | outlineSize : Number | OutlinePass
Inherited | renderToTexture : Boolean [read-only] Specifies whether this pass renders to texture | MaterialPassBase
Inherited | repeat : Boolean Defines whether textures should be tiled. | MaterialPassBase
 | showInnerLines : Boolean | OutlinePass
Inherited | smooth : Boolean Defines whether smoothing should be applied to any used textures. | MaterialPassBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaPremultiplied : Boolean | MaterialPassBase
Inherited | _animatableAttributes : Vector.<String> | MaterialPassBase
Inherited | _animationSet : IAnimationSet | MaterialPassBase
Inherited | _animationTargetRegisters : Vector.<String> | MaterialPassBase
Inherited | _defaultCulling : String = back | MaterialPassBase
Inherited | _depthCompareMode : String = lessEqual | MaterialPassBase
Inherited | _lightPicker : LightPickerBase | MaterialPassBase
Inherited | _material : MaterialBase | MaterialPassBase
Inherited | _mipmap : Boolean = true | MaterialPassBase
Inherited | _needFragmentAnimation : Boolean | MaterialPassBase
Inherited | _needUVAnimation : Boolean | MaterialPassBase
Inherited | _numUsedFragmentConstants : uint | MaterialPassBase
Inherited | _numUsedStreams : uint | MaterialPassBase
Inherited | _numUsedTextures : uint | MaterialPassBase
Inherited | _numUsedVaryings : uint | MaterialPassBase
Inherited | _numUsedVertexConstants : uint | MaterialPassBase
Inherited | _repeat : Boolean = false | MaterialPassBase
Inherited | _shadedTarget : String = ft0 | MaterialPassBase
Inherited | _smooth : Boolean = true | MaterialPassBase
Inherited | _UVSource : String | MaterialPassBase
Inherited | _UVTarget : String | MaterialPassBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | OutlinePass(outlineColor:uint = 0x000000, outlineSize:Number = 20, showInnerLines:Boolean = true, dedicatedMeshes:Boolean = false) | OutlinePass
 | clearDedicatedMesh(mesh:Mesh):void Clears mesh. | OutlinePass
 | dispose():void [override] | OutlinePass
Inherited | setBlendMode(value:String, force:Boolean = false):void | MaterialPassBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateLights():void | MaterialPassBase
Property Detail
outlineColor property
outlineColor:uint

Implementation
    public function get outlineColor():uint
    public function set outlineColor(value:uint):void
outlineSize property
outlineSize:Number

Implementation
    public function get outlineSize():Number
    public function set outlineSize(value:Number):void
showInnerLines property
showInnerLines:Boolean

Implementation
    public function get showInnerLines():Boolean
    public function set showInnerLines(value:Boolean):void
Constructor Detail
OutlinePass () Constructor
public function OutlinePass(outlineColor:uint = 0x000000, outlineSize:Number = 20, showInnerLines:Boolean = true, dedicatedMeshes:Boolean = false)

Parameters
outlineColor:uint (default = 0x000000)
outlineSize:Number (default = 20)
showInnerLines:Boolean (default = true)
dedicatedMeshes:Boolean (default = false) — Create a Mesh specifically for the outlines. This is only useful if the outlines of the existing mesh appear fragmented due to discontinuities in the normals.
Method Detail
activate () method
override arcane function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, textureRatioX:Number, textureRatioY:Number):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
textureRatioX:Number
textureRatioY:Number

clearDedicatedMesh () method
public function clearDedicatedMesh(mesh:Mesh):void

Clears mesh. TODO: have Object3D broadcast dispose event, so this can be handled automatically?

Parameters

mesh:Mesh

deactivate () method
override arcane function deactivate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

dispose () method
override public function dispose():void

getFragmentCode () method
override arcane function getFragmentCode(animationCode:String):String

Parameters

animationCode:String

Returns
String
getVertexCode () method
override arcane function getVertexCode():String

Returns
String
render () method
override arcane function render(renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D


away3d.materials.passes.SegmentPass

SegmentPass | Properties | Methods | Constants
Package | away3d.materials.passes
Class | public class SegmentPass
Inheritance | SegmentPass Inheritance MaterialPassBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean | MaterialPassBase
Inherited | animationRegisterCache : AnimationRegisterCache | MaterialPassBase
Inherited | animationSet : IAnimationSet The animation used to add vertex code to the shader code. | MaterialPassBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialPassBase
Inherited | depthCompareMode : String | MaterialPassBase
Inherited | material : MaterialBase The material to which this pass belongs. | MaterialPassBase
Inherited | mipmap : Boolean Defines whether any used textures should use mipmapping. | MaterialPassBase
Inherited | needFragmentAnimation : Boolean [read-only] | MaterialPassBase
Inherited | needUVAnimation : Boolean [read-only] | MaterialPassBase
Inherited | numUsedFragmentConstants : uint [read-only] | MaterialPassBase
Inherited | numUsedStreams : uint [read-only] The amount of used vertex streams in the vertex code. | MaterialPassBase
Inherited | numUsedVaryings : uint [read-only] | MaterialPassBase
Inherited | numUsedVertexConstants : uint [read-only] The amount of used vertex constants in the vertex code. | MaterialPassBase
Inherited | renderToTexture : Boolean [read-only] Specifies whether this pass renders to texture | MaterialPassBase
Inherited | repeat : Boolean Defines whether textures should be tiled. | MaterialPassBase
Inherited | smooth : Boolean Defines whether smoothing should be applied to any used textures. | MaterialPassBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaPremultiplied : Boolean | MaterialPassBase
Inherited | _animatableAttributes : Vector.<String> | MaterialPassBase
Inherited | _animationSet : IAnimationSet | MaterialPassBase
Inherited | _animationTargetRegisters : Vector.<String> | MaterialPassBase
Inherited | _defaultCulling : String = back | MaterialPassBase
Inherited | _depthCompareMode : String = lessEqual | MaterialPassBase
Inherited | _lightPicker : LightPickerBase | MaterialPassBase
Inherited | _material : MaterialBase | MaterialPassBase
Inherited | _mipmap : Boolean = true | MaterialPassBase
Inherited | _needFragmentAnimation : Boolean | MaterialPassBase
Inherited | _needUVAnimation : Boolean | MaterialPassBase
Inherited | _numUsedFragmentConstants : uint | MaterialPassBase
Inherited | _numUsedStreams : uint | MaterialPassBase
Inherited | _numUsedTextures : uint | MaterialPassBase
Inherited | _numUsedVaryings : uint | MaterialPassBase
Inherited | _numUsedVertexConstants : uint | MaterialPassBase
Inherited | _repeat : Boolean = false | MaterialPassBase
Inherited | _shadedTarget : String = ft0 | MaterialPassBase
Inherited | _smooth : Boolean = true | MaterialPassBase
Inherited | _UVSource : String | MaterialPassBase
Inherited | _UVTarget : String | MaterialPassBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SegmentPass(thickness:Number) Creates a new WireframePass object. | SegmentPass
Inherited | dispose():void Cleans up any resources used by the current object. | MaterialPassBase
Inherited | setBlendMode(value:String, force:Boolean = false):void | MaterialPassBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateLights():void | MaterialPassBase
Protected Constants
Constant |  | Defined By
 | FRONT_VECTOR : Vector.<Number> [static] | SegmentPass
 | ONE_VECTOR : Vector.<Number> [static] | SegmentPass
Constructor Detail
SegmentPass () Constructor
public function SegmentPass(thickness:Number)

Creates a new WireframePass object.

Parameters
thickness:Number
Method Detail
activate () method
override arcane function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, textureRatioX:Number, textureRatioY:Number):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
textureRatioX:Number
textureRatioY:Number

deactivate () method
override arcane function deactivate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

getFragmentCode () method
override arcane function getFragmentCode(animationCode:String):String

Parameters

animationCode:String

Returns
String
getVertexCode () method
override arcane function getVertexCode():String

Returns
String
render () method
override arcane function render(renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D

Constant Detail
FRONT_VECTOR Constant
protected static const FRONT_VECTOR:Vector.<Number>

ONE_VECTOR Constant
protected static const ONE_VECTOR:Vector.<Number>


away3d.materials.passes.ShadowCasterPass

ShadowCasterPass | Properties | Methods
Package | away3d.materials.passes
Class | public class ShadowCasterPass
Inheritance | ShadowCasterPass Inheritance CompiledPass Inheritance MaterialPassBase Inheritance flash.events.EventDispatcher

DefaultScreenPass is a shader pass that uses shader methods to compile a complete program.

See also

away3d.materials.methods.ShadingMethodBase

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean | MaterialPassBase
Inherited | ambientMethod : BasicAmbientMethod | CompiledPass
Inherited | animateUVs : Boolean | CompiledPass
Inherited | animationRegisterCache : AnimationRegisterCache | MaterialPassBase
Inherited | animationSet : IAnimationSet The animation used to add vertex code to the shader code. | MaterialPassBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialPassBase
Inherited | depthCompareMode : String | MaterialPassBase
Inherited | diffuseLightSources : uint | CompiledPass
Inherited | diffuseMethod : BasicDiffuseMethod | CompiledPass
Inherited | material : MaterialBase The material to which this pass belongs. | MaterialPassBase
Inherited | mipmap : Boolean [override] Defines whether any used textures should use mipmapping. | CompiledPass
Inherited | needFragmentAnimation : Boolean [read-only] | MaterialPassBase
Inherited | needUVAnimation : Boolean [read-only] | MaterialPassBase
Inherited | normalMap : Texture2DBase The tangent space normal map to influence the direction of the surface for each texel. | CompiledPass
Inherited | normalMethod : BasicNormalMethod | CompiledPass
Inherited | numUsedFragmentConstants : uint [read-only] | MaterialPassBase
Inherited | numUsedStreams : uint [read-only] The amount of used vertex streams in the vertex code. | MaterialPassBase
Inherited | numUsedVaryings : uint [read-only] | MaterialPassBase
Inherited | numUsedVertexConstants : uint [read-only] The amount of used vertex constants in the vertex code. | MaterialPassBase
Inherited | preserveAlpha : Boolean | CompiledPass
Inherited | renderToTexture : Boolean [read-only] Specifies whether this pass renders to texture | MaterialPassBase
Inherited | repeat : Boolean Defines whether textures should be tiled. | MaterialPassBase
Inherited | shadowMethod : ShadowMapMethodBase | CompiledPass
Inherited | smooth : Boolean Defines whether smoothing should be applied to any used textures. | MaterialPassBase
Inherited | specularLightSources : uint | CompiledPass
Inherited | specularMethod : BasicSpecularMethod | CompiledPass
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaPremultiplied : Boolean | MaterialPassBase
Inherited | _ambientLightB : Number | CompiledPass
Inherited | _ambientLightG : Number | CompiledPass
Inherited | _ambientLightR : Number | CompiledPass
Inherited | _animatableAttributes : Vector.<String> | MaterialPassBase
Inherited | _animateUVs : Boolean | CompiledPass
Inherited | _animationSet : IAnimationSet | MaterialPassBase
Inherited | _animationTargetRegisters : Vector.<String> | MaterialPassBase
Inherited | _cameraPositionIndex : int | CompiledPass
Inherited | _commonsDataIndex : int | CompiledPass
Inherited | _compiler : ShaderCompiler | CompiledPass
Inherited | _defaultCulling : String = back | MaterialPassBase
Inherited | _depthCompareMode : String = lessEqual | MaterialPassBase
Inherited | _diffuseLightSources : uint = 0x03 | CompiledPass
Inherited | _fragmentAnimationCode : String | CompiledPass
Inherited | _fragmentConstantData : Vector.<Number> | CompiledPass
Inherited | _fragmentLightCode : String | CompiledPass
Inherited | _framentPostLightCode : String | CompiledPass
Inherited | _lightFragmentConstantIndex : int | CompiledPass
Inherited | _lightPicker : LightPickerBase | MaterialPassBase
Inherited | _lightProbeDiffuseIndices : Vector.<uint> | CompiledPass
Inherited | _lightProbeSpecularIndices : Vector.<uint> | CompiledPass
Inherited | _material : MaterialBase | MaterialPassBase
Inherited | _methodSetup : ShaderMethodSetup | CompiledPass
Inherited | _mipmap : Boolean = true | MaterialPassBase
Inherited | _needFragmentAnimation : Boolean | MaterialPassBase
Inherited | _needUVAnimation : Boolean | MaterialPassBase
Inherited | _normalBufferIndex : int | CompiledPass
Inherited | _numDirectionalLights : uint | CompiledPass
Inherited | _numLightProbes : uint | CompiledPass
Inherited | _numPointLights : uint | CompiledPass
Inherited | _numUsedFragmentConstants : uint | MaterialPassBase
Inherited | _numUsedStreams : uint | MaterialPassBase
Inherited | _numUsedTextures : uint | MaterialPassBase
Inherited | _numUsedVaryings : uint | MaterialPassBase
Inherited | _numUsedVertexConstants : uint | MaterialPassBase
Inherited | _preserveAlpha : Boolean = true | CompiledPass
Inherited | _probeWeightsIndex : int | CompiledPass
Inherited | _repeat : Boolean = false | MaterialPassBase
Inherited | _sceneMatrixIndex : int | CompiledPass
Inherited | _sceneNormalMatrixIndex : int | CompiledPass
Inherited | _secondaryUVBufferIndex : int | CompiledPass
Inherited | _shadedTarget : String = ft0 | MaterialPassBase
Inherited | _smooth : Boolean = true | MaterialPassBase
Inherited | _specularLightSources : uint = 0x01 | CompiledPass
Inherited | _tangentBufferIndex : int | CompiledPass
Inherited | _usesNormals : Boolean | CompiledPass
Inherited | _usingSpecularMethod : Boolean | CompiledPass
Inherited | _uvBufferIndex : int | CompiledPass
Inherited | _UVSource : String | MaterialPassBase
Inherited | _UVTarget : String | MaterialPassBase
Inherited | _uvTransformIndex : int | CompiledPass
Inherited | _vertexCode : String | CompiledPass
Inherited | _vertexConstantData : Vector.<Number> | CompiledPass
Inherited | _vertexConstantsOffset : uint | CompiledPass
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ShadowCasterPass(material:MaterialBase) Creates a new DefaultScreenPass objects. | ShadowCasterPass
Inherited | dispose():void [override] Cleans up any resources used by the current object. | CompiledPass
Inherited | setBlendMode(value:String, force:Boolean = false):void | MaterialPassBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addPasses(passes:Vector.<MaterialPassBase>):void Adds passes to the list. | CompiledPass
Inherited | addPassesFromMethods():void | CompiledPass
Inherited | cleanUp():void | CompiledPass
 | createCompiler():ShaderCompiler [override] | ShadowCasterPass
Inherited | initCommonsData():void | CompiledPass
Inherited | initCompiler():void | CompiledPass
Inherited | initUVTransformData():void | CompiledPass
 | updateLightConstants():void [override] Updates the lights data for the render state. | ShadowCasterPass
 | updateLights():void [override] | ShadowCasterPass
Inherited | updateMethodConstants():void | CompiledPass
 | updateProbes(stage3DProxy:Stage3DProxy):void [override] | ShadowCasterPass
 | updateRegisterIndices():void [override] | ShadowCasterPass
 | updateShaderProperties():void [override] | ShadowCasterPass
 | usesLights():Boolean [override] | ShadowCasterPass
 | usesProbes():Boolean [override] | ShadowCasterPass
Constructor Detail
ShadowCasterPass () Constructor
public function ShadowCasterPass(material:MaterialBase)

Creates a new DefaultScreenPass objects.

Parameters
material:MaterialBase
Method Detail
activate () method
override arcane function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, textureRatioX:Number, textureRatioY:Number):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
textureRatioX:Number
textureRatioY:Number

createCompiler () method
override protected function createCompiler():ShaderCompiler

Returns
ShaderCompiler
render () method
override arcane function render(renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D

updateLightConstants () method
override protected function updateLightConstants():void

Updates the lights data for the render state.

updateLights () method
override protected function updateLights():void

updateProbes () method
override protected function updateProbes(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

updateRegisterIndices () method
override protected function updateRegisterIndices():void

updateShaderProperties () method
override protected function updateShaderProperties():void

usesLights () method
override protected function usesLights():Boolean

Returns
Boolean
usesProbes () method
override protected function usesProbes():Boolean

Returns
Boolean


away3d.materials.passes.SingleObjectDepthPass

SingleObjectDepthPass | Properties | Methods
Package | away3d.materials.passes
Class | public class SingleObjectDepthPass
Inheritance | SingleObjectDepthPass Inheritance MaterialPassBase Inheritance flash.events.EventDispatcher

The SingleObjectDepthPass provides a material pass that renders a single object to a depth map from the point of view from a light.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean | MaterialPassBase
Inherited | animationRegisterCache : AnimationRegisterCache | MaterialPassBase
Inherited | animationSet : IAnimationSet The animation used to add vertex code to the shader code. | MaterialPassBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialPassBase
Inherited | depthCompareMode : String | MaterialPassBase
Inherited | material : MaterialBase The material to which this pass belongs. | MaterialPassBase
Inherited | mipmap : Boolean Defines whether any used textures should use mipmapping. | MaterialPassBase
Inherited | needFragmentAnimation : Boolean [read-only] | MaterialPassBase
Inherited | needUVAnimation : Boolean [read-only] | MaterialPassBase
Inherited | numUsedFragmentConstants : uint [read-only] | MaterialPassBase
Inherited | numUsedStreams : uint [read-only] The amount of used vertex streams in the vertex code. | MaterialPassBase
Inherited | numUsedVaryings : uint [read-only] | MaterialPassBase
Inherited | numUsedVertexConstants : uint [read-only] The amount of used vertex constants in the vertex code. | MaterialPassBase
Inherited | renderToTexture : Boolean [read-only] Specifies whether this pass renders to texture | MaterialPassBase
Inherited | repeat : Boolean Defines whether textures should be tiled. | MaterialPassBase
Inherited | smooth : Boolean Defines whether smoothing should be applied to any used textures. | MaterialPassBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaPremultiplied : Boolean | MaterialPassBase
Inherited | _animatableAttributes : Vector.<String> | MaterialPassBase
Inherited | _animationSet : IAnimationSet | MaterialPassBase
Inherited | _animationTargetRegisters : Vector.<String> | MaterialPassBase
Inherited | _defaultCulling : String = back | MaterialPassBase
Inherited | _depthCompareMode : String = lessEqual | MaterialPassBase
Inherited | _lightPicker : LightPickerBase | MaterialPassBase
Inherited | _material : MaterialBase | MaterialPassBase
Inherited | _mipmap : Boolean = true | MaterialPassBase
Inherited | _needFragmentAnimation : Boolean | MaterialPassBase
Inherited | _needUVAnimation : Boolean | MaterialPassBase
Inherited | _numUsedFragmentConstants : uint | MaterialPassBase
Inherited | _numUsedStreams : uint | MaterialPassBase
Inherited | _numUsedTextures : uint | MaterialPassBase
Inherited | _numUsedVaryings : uint | MaterialPassBase
Inherited | _numUsedVertexConstants : uint | MaterialPassBase
Inherited | _repeat : Boolean = false | MaterialPassBase
Inherited | _shadedTarget : String = ft0 | MaterialPassBase
Inherited | _smooth : Boolean = true | MaterialPassBase
Inherited | _UVSource : String | MaterialPassBase
Inherited | _UVTarget : String | MaterialPassBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SingleObjectDepthPass(textureSize:uint = 512, polyOffset:Number = 15) Creates a new SingleObjectDepthPass object. | SingleObjectDepthPass
 | dispose():void [override] Cleans up any resources used by the current object. | SingleObjectDepthPass
Inherited | setBlendMode(value:String, force:Boolean = false):void | MaterialPassBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateLights():void | MaterialPassBase
Constructor Detail
SingleObjectDepthPass () Constructor
public function SingleObjectDepthPass(textureSize:uint = 512, polyOffset:Number = 15)

Creates a new SingleObjectDepthPass object.

Parameters
textureSize:uint (default = 512) — The size of the depth map texture to render to.
polyOffset:Number (default = 15) — The amount by which the rendered object will be inflated, to prevent depth map rounding errors. todo: provide custom vertex code to assembler
Method Detail
activate () method
override arcane function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, textureRatioX:Number, textureRatioY:Number):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
textureRatioX:Number
textureRatioY:Number

dispose () method
override public function dispose():void

Cleans up any resources used by the current object.

getDepthMap () method
arcane function getDepthMap(renderable:IRenderable, stage3DProxy:Stage3DProxy):Texture

Gets the depth maps rendered for this object from all lights.

Parameters

renderable:IRenderable — The renderable for which to retrieve the depth maps
stage3DProxy:Stage3DProxy

Returns
Texture — A list of depth map textures for all supported lights.
getFragmentCode () method
override arcane function getFragmentCode(animationCode:String):String

Parameters

animationCode:String

Returns
String
getProjection () method
arcane function getProjection(renderable:IRenderable):Matrix3D

Retrieves the depth map projection maps for all lights.

Parameters

renderable:IRenderable — The renderable for which to retrieve the projection maps.

Returns
Matrix3D — A list of projection maps for all supported lights.
getVertexCode () method
override arcane function getVertexCode():String

Returns
String
render () method
override arcane function render(renderable:IRenderable, stage3DProxy:Stage3DProxy, camera:Camera3D):void

Parameters

renderable:IRenderable
stage3DProxy:Stage3DProxy
camera:Camera3D


away3d.materials.passes.SkyBoxPass

SkyBoxPass | Properties | Methods
Package | away3d.materials.passes
Class | public class SkyBoxPass
Inheritance | SkyBoxPass Inheritance MaterialPassBase Inheritance flash.events.EventDispatcher

SkyBoxPass provides a material pass exclusively used to render sky boxes from a cube texture.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean | MaterialPassBase
Inherited | animationRegisterCache : AnimationRegisterCache | MaterialPassBase
Inherited | animationSet : IAnimationSet The animation used to add vertex code to the shader code. | MaterialPassBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialPassBase
 | cubeTexture : CubeTextureBase The cube texture to use as the skybox. | SkyBoxPass
Inherited | depthCompareMode : String | MaterialPassBase
Inherited | material : MaterialBase The material to which this pass belongs. | MaterialPassBase
Inherited | mipmap : Boolean Defines whether any used textures should use mipmapping. | MaterialPassBase
Inherited | needFragmentAnimation : Boolean [read-only] | MaterialPassBase
Inherited | needUVAnimation : Boolean [read-only] | MaterialPassBase
Inherited | numUsedFragmentConstants : uint [read-only] | MaterialPassBase
Inherited | numUsedStreams : uint [read-only] The amount of used vertex streams in the vertex code. | MaterialPassBase
Inherited | numUsedVaryings : uint [read-only] | MaterialPassBase
Inherited | numUsedVertexConstants : uint [read-only] The amount of used vertex constants in the vertex code. | MaterialPassBase
Inherited | renderToTexture : Boolean [read-only] Specifies whether this pass renders to texture | MaterialPassBase
Inherited | repeat : Boolean Defines whether textures should be tiled. | MaterialPassBase
Inherited | smooth : Boolean Defines whether smoothing should be applied to any used textures. | MaterialPassBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaPremultiplied : Boolean | MaterialPassBase
Inherited | _animatableAttributes : Vector.<String> | MaterialPassBase
Inherited | _animationSet : IAnimationSet | MaterialPassBase
Inherited | _animationTargetRegisters : Vector.<String> | MaterialPassBase
Inherited | _defaultCulling : String = back | MaterialPassBase
Inherited | _depthCompareMode : String = lessEqual | MaterialPassBase
Inherited | _lightPicker : LightPickerBase | MaterialPassBase
Inherited | _material : MaterialBase | MaterialPassBase
Inherited | _mipmap : Boolean = true | MaterialPassBase
Inherited | _needFragmentAnimation : Boolean | MaterialPassBase
Inherited | _needUVAnimation : Boolean | MaterialPassBase
Inherited | _numUsedFragmentConstants : uint | MaterialPassBase
Inherited | _numUsedStreams : uint | MaterialPassBase
Inherited | _numUsedTextures : uint | MaterialPassBase
Inherited | _numUsedVaryings : uint | MaterialPassBase
Inherited | _numUsedVertexConstants : uint | MaterialPassBase
Inherited | _repeat : Boolean = false | MaterialPassBase
Inherited | _shadedTarget : String = ft0 | MaterialPassBase
Inherited | _smooth : Boolean = true | MaterialPassBase
Inherited | _UVSource : String | MaterialPassBase
Inherited | _UVTarget : String | MaterialPassBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkyBoxPass() Creates a new SkyBoxPass object. | SkyBoxPass
Inherited | dispose():void Cleans up any resources used by the current object. | MaterialPassBase
Inherited | setBlendMode(value:String, force:Boolean = false):void | MaterialPassBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | updateLights():void | MaterialPassBase
Property Detail
cubeTexture property
cubeTexture:CubeTextureBase

The cube texture to use as the skybox.

Implementation
    public function get cubeTexture():CubeTextureBase
    public function set cubeTexture(value:CubeTextureBase):void
Constructor Detail
SkyBoxPass () Constructor
public function SkyBoxPass()

Creates a new SkyBoxPass object.

Method Detail
activate () method
override arcane function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, textureRatioX:Number, textureRatioY:Number):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
textureRatioX:Number
textureRatioY:Number

getFragmentCode () method
override arcane function getFragmentCode(animationCode:String):String

Parameters

animationCode:String

Returns
String
getVertexCode () method
override arcane function getVertexCode():String

Returns
String


away3d.materials.passes.SuperShaderPass

SuperShaderPass | Properties | Methods
Package | away3d.materials.passes
Class | public class SuperShaderPass
Inheritance | SuperShaderPass Inheritance CompiledPass Inheritance MaterialPassBase Inheritance flash.events.EventDispatcher

DefaultScreenPass is a shader pass that uses shader methods to compile a complete program.

See also

away3d.materials.methods.ShadingMethodBase

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alphaPremultiplied : Boolean | MaterialPassBase
Inherited | ambientMethod : BasicAmbientMethod | CompiledPass
Inherited | animateUVs : Boolean | CompiledPass
Inherited | animationRegisterCache : AnimationRegisterCache | MaterialPassBase
Inherited | animationSet : IAnimationSet The animation used to add vertex code to the shader code. | MaterialPassBase
Inherited | bothSides : Boolean Defines whether or not the material should perform backface culling. | MaterialPassBase
 | colorTransform : ColorTransform The ColorTransform object to transform the colour of the material with. | SuperShaderPass
 | colorTransformMethod : ColorTransformMethod | SuperShaderPass
Inherited | depthCompareMode : String | MaterialPassBase
Inherited | diffuseLightSources : uint | CompiledPass
Inherited | diffuseMethod : BasicDiffuseMethod | CompiledPass
 | includeCasters : Boolean | SuperShaderPass
Inherited | material : MaterialBase The material to which this pass belongs. | MaterialPassBase
Inherited | mipmap : Boolean [override] Defines whether any used textures should use mipmapping. | CompiledPass
Inherited | needFragmentAnimation : Boolean [read-only] | MaterialPassBase
Inherited | needUVAnimation : Boolean [read-only] | MaterialPassBase
Inherited | normalMap : Texture2DBase The tangent space normal map to influence the direction of the surface for each texel. | CompiledPass
Inherited | normalMethod : BasicNormalMethod | CompiledPass
 | numMethods : int [read-only] | SuperShaderPass
Inherited | numUsedFragmentConstants : uint [read-only] | MaterialPassBase
Inherited | numUsedStreams : uint [read-only] The amount of used vertex streams in the vertex code. | MaterialPassBase
Inherited | numUsedVaryings : uint [read-only] | MaterialPassBase
Inherited | numUsedVertexConstants : uint [read-only] The amount of used vertex constants in the vertex code. | MaterialPassBase
Inherited | preserveAlpha : Boolean | CompiledPass
Inherited | renderToTexture : Boolean [read-only] Specifies whether this pass renders to texture | MaterialPassBase
Inherited | repeat : Boolean Defines whether textures should be tiled. | MaterialPassBase
Inherited | shadowMethod : ShadowMapMethodBase | CompiledPass
Inherited | smooth : Boolean Defines whether smoothing should be applied to any used textures. | MaterialPassBase
Inherited | specularLightSources : uint | CompiledPass
Inherited | specularMethod : BasicSpecularMethod | CompiledPass
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _alphaPremultiplied : Boolean | MaterialPassBase
Inherited | _ambientLightB : Number | CompiledPass
Inherited | _ambientLightG : Number | CompiledPass
Inherited | _ambientLightR : Number | CompiledPass
Inherited | _animatableAttributes : Vector.<String> | MaterialPassBase
Inherited | _animateUVs : Boolean | CompiledPass
Inherited | _animationSet : IAnimationSet | MaterialPassBase
Inherited | _animationTargetRegisters : Vector.<String> | MaterialPassBase
Inherited | _cameraPositionIndex : int | CompiledPass
Inherited | _commonsDataIndex : int | CompiledPass
Inherited | _compiler : ShaderCompiler | CompiledPass
Inherited | _defaultCulling : String = back | MaterialPassBase
Inherited | _depthCompareMode : String = lessEqual | MaterialPassBase
Inherited | _diffuseLightSources : uint = 0x03 | CompiledPass
Inherited | _fragmentAnimationCode : String | CompiledPass
Inherited | _fragmentConstantData : Vector.<Number> | CompiledPass
Inherited | _fragmentLightCode : String | CompiledPass
Inherited | _framentPostLightCode : String | CompiledPass
Inherited | _lightFragmentConstantIndex : int | CompiledPass
Inherited | _lightPicker : LightPickerBase | MaterialPassBase
Inherited | _lightProbeDiffuseIndices : Vector.<uint> | CompiledPass
Inherited | _lightProbeSpecularIndices : Vector.<uint> | CompiledPass
Inherited | _material : MaterialBase | MaterialPassBase
Inherited | _methodSetup : ShaderMethodSetup | CompiledPass
Inherited | _mipmap : Boolean = true | MaterialPassBase
Inherited | _needFragmentAnimation : Boolean | MaterialPassBase
Inherited | _needUVAnimation : Boolean | MaterialPassBase
Inherited | _normalBufferIndex : int | CompiledPass
Inherited | _numDirectionalLights : uint | CompiledPass
Inherited | _numLightProbes : uint | CompiledPass
Inherited | _numPointLights : uint | CompiledPass
Inherited | _numUsedFragmentConstants : uint | MaterialPassBase
Inherited | _numUsedStreams : uint | MaterialPassBase
Inherited | _numUsedTextures : uint | MaterialPassBase
Inherited | _numUsedVaryings : uint | MaterialPassBase
Inherited | _numUsedVertexConstants : uint | MaterialPassBase
Inherited | _preserveAlpha : Boolean = true | CompiledPass
Inherited | _probeWeightsIndex : int | CompiledPass
Inherited | _repeat : Boolean = false | MaterialPassBase
Inherited | _sceneMatrixIndex : int | CompiledPass
Inherited | _sceneNormalMatrixIndex : int | CompiledPass
Inherited | _secondaryUVBufferIndex : int | CompiledPass
Inherited | _shadedTarget : String = ft0 | MaterialPassBase
Inherited | _smooth : Boolean = true | MaterialPassBase
Inherited | _specularLightSources : uint = 0x01 | CompiledPass
Inherited | _tangentBufferIndex : int | CompiledPass
Inherited | _usesNormals : Boolean | CompiledPass
Inherited | _usingSpecularMethod : Boolean | CompiledPass
Inherited | _uvBufferIndex : int | CompiledPass
Inherited | _UVSource : String | MaterialPassBase
Inherited | _UVTarget : String | MaterialPassBase
Inherited | _uvTransformIndex : int | CompiledPass
Inherited | _vertexCode : String | CompiledPass
Inherited | _vertexConstantData : Vector.<Number> | CompiledPass
Inherited | _vertexConstantsOffset : uint | CompiledPass
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SuperShaderPass(material:MaterialBase) Creates a new DefaultScreenPass objects. | SuperShaderPass
 | addMethod(method:EffectMethodBase):void Adds a shading method to the end of the shader. | SuperShaderPass
 | addMethodAt(method:EffectMethodBase, index:int):void Adds a shading method to the end of a shader, at the specified index amongst the methods in that section of the shader. | SuperShaderPass
Inherited | dispose():void [override] Cleans up any resources used by the current object. | CompiledPass
 | getMethodAt(index:int):EffectMethodBase | SuperShaderPass
 | hasMethod(method:EffectMethodBase):Boolean | SuperShaderPass
 | removeMethod(method:EffectMethodBase):void | SuperShaderPass
Inherited | setBlendMode(value:String, force:Boolean = false):void | MaterialPassBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | addPasses(passes:Vector.<MaterialPassBase>):void Adds passes to the list. | CompiledPass
 | addPassesFromMethods():void [override] | SuperShaderPass
Inherited | cleanUp():void | CompiledPass
 | createCompiler():ShaderCompiler [override] | SuperShaderPass
Inherited | initCommonsData():void | CompiledPass
Inherited | initCompiler():void | CompiledPass
Inherited | initUVTransformData():void | CompiledPass
 | updateLightConstants():void [override] Updates the lights data for the render state. | SuperShaderPass
 | updateLights():void [override] | SuperShaderPass
 | updateMethodConstants():void [override] | SuperShaderPass
 | updateProbes(stage3DProxy:Stage3DProxy):void [override] | SuperShaderPass
Inherited | updateRegisterIndices():void | CompiledPass
Inherited | updateShaderProperties():void | CompiledPass
Inherited | usesLights():Boolean | CompiledPass
Inherited | usesProbes():Boolean | CompiledPass
Property Detail
colorTransform property
colorTransform:ColorTransform

The ColorTransform object to transform the colour of the material with.

Implementation
    public function get colorTransform():ColorTransform
    public function set colorTransform(value:ColorTransform):void
colorTransformMethod property
colorTransformMethod:ColorTransformMethod

Implementation
    public function get colorTransformMethod():ColorTransformMethod
    public function set colorTransformMethod(value:ColorTransformMethod):void
includeCasters property
includeCasters:Boolean

Implementation
    public function get includeCasters():Boolean
    public function set includeCasters(value:Boolean):void
numMethods property
numMethods:int [read-only]

Implementation
    public function get numMethods():int
Constructor Detail
SuperShaderPass () Constructor
public function SuperShaderPass(material:MaterialBase)

Creates a new DefaultScreenPass objects.

Parameters
material:MaterialBase
Method Detail
activate () method
override arcane function activate(stage3DProxy:Stage3DProxy, camera:Camera3D, textureRatioX:Number, textureRatioY:Number):void

Parameters

stage3DProxy:Stage3DProxy
camera:Camera3D
textureRatioX:Number
textureRatioY:Number

addMethod () method
public function addMethod(method:EffectMethodBase):void

Adds a shading method to the end of the shader. Note that shading methods can not be reused across materials.

Parameters

method:EffectMethodBase

addMethodAt () method
public function addMethodAt(method:EffectMethodBase, index:int):void

Adds a shading method to the end of a shader, at the specified index amongst the methods in that section of the shader. Note that shading methods can not be reused across materials.

Parameters

method:EffectMethodBase
index:int

addPassesFromMethods () method
override protected function addPassesFromMethods():void

createCompiler () method
override protected function createCompiler():ShaderCompiler

Returns
ShaderCompiler
deactivate () method
override arcane function deactivate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

getMethodAt () method
public function getMethodAt(index:int):EffectMethodBase

Parameters

index:int

Returns
EffectMethodBase
hasMethod () method
public function hasMethod(method:EffectMethodBase):Boolean

Parameters

method:EffectMethodBase

Returns
Boolean
removeMethod () method
public function removeMethod(method:EffectMethodBase):void

Parameters

method:EffectMethodBase

updateLightConstants () method
override protected function updateLightConstants():void

Updates the lights data for the render state.

updateLights () method
override protected function updateLights():void

updateMethodConstants () method
override protected function updateMethodConstants():void

updateProbes () method
override protected function updateProbes(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy


away3d.materials.utils - Away3D Documentation

Package away3d.materials.utils

Interfaces
IVideoPlayer
Classes
DefaultMaterialManager
MipmapGenerator
MultipleMaterials
SimpleVideoPlayer
WireframeMapGenerator


away3d.materials.utils Summary

away3d.materials.utils | Interfaces | Classes

Interfaces
Interface | Description
IVideoPlayer |
Classes
Class | Description
DefaultMaterialManager |
MipmapGenerator | MipmapGenerator is a helper class that uploads BitmapData to a Texture including mipmap levels.
MultipleMaterials |
SimpleVideoPlayer |
WireframeMapGenerator | WireframeMapGenerator is a utility class to generate a wireframe texture for uniquely mapped meshes.

Thu Nov 15 2012, 12:09 PM Z


away3d.materials.utils.DefaultMaterialManager

DefaultMaterialManager | Methods
Package | away3d.materials.utils
Class | public class DefaultMaterialManager
Inheritance | DefaultMaterialManager Inheritance Object

Public Methods
Method |  | Defined By
 | getDefaultMaterial(renderable:IMaterialOwner = null):TextureMaterial [static] | DefaultMaterialManager
 | getDefaultTexture(renderable:IMaterialOwner = null):BitmapTexture [static] | DefaultMaterialManager
Method Detail
getDefaultMaterial () method
public static function getDefaultMaterial(renderable:IMaterialOwner = null):TextureMaterial

Parameters

renderable:IMaterialOwner (default = null)

Returns
TextureMaterial
getDefaultTexture () method
public static function getDefaultTexture(renderable:IMaterialOwner = null):BitmapTexture

Parameters

renderable:IMaterialOwner (default = null)

Returns
BitmapTexture


away3d.materials.utils.IVideoPlayer

IVideoPlayer | Properties | Methods
Package | away3d.materials.utils
Interface | public interface IVideoPlayer
Implementors | SimpleVideoPlayer

Public Properties
Property |  | Defined By
 | container : Sprite [read-only] Provides access to the Video Object | IVideoPlayer
 | height : int Get/Set access to the height of the video object | IVideoPlayer
 | loop : Boolean Indicates whether the player should loop when video finishes | IVideoPlayer
 | mute : Boolean Mutes/unmutes the video's audio. | IVideoPlayer
 | pan : Number Panning | IVideoPlayer
 | paused : Boolean [read-only] Indicates whether the video is paused | IVideoPlayer
 | playing : Boolean [read-only] Indicates whether the video is playing | IVideoPlayer
 | soundTransform : SoundTransform Provides access to the SoundTransform of the video stream | IVideoPlayer
 | source : String The source, url, to the video file | IVideoPlayer
 | time : Number [read-only] Returns the actual time of the netStream | IVideoPlayer
 | volume : Number Master volume/gain | IVideoPlayer
 | width : int Get/Set access to the with of the video object | IVideoPlayer
Public Methods
Method |  | Defined By
 | dispose():void Called if the player is no longer needed | IVideoPlayer
 | pause():void Temporarily pause playback. | IVideoPlayer
 | play():void Start playing (or resume if paused) the video. | IVideoPlayer
 | seek(val:Number):void Seeks to a given time in the video, specified in seconds, with a precision of three decimal places (milliseconds). | IVideoPlayer
 | stop():void Stop playback and reset playhead. | IVideoPlayer
Property Detail
container property
container:Sprite [read-only]

Provides access to the Video Object

Implementation
    public function get container():Sprite
height property
height:int

Get/Set access to the height of the video object

Implementation
    public function get height():int
    public function set height(value:int):void
loop property
loop:Boolean

Indicates whether the player should loop when video finishes

Implementation
    public function get loop():Boolean
    public function set loop(value:Boolean):void
mute property
mute:Boolean

Mutes/unmutes the video's audio.

Implementation
    public function get mute():Boolean
    public function set mute(value:Boolean):void
pan property
pan:Number

Panning

Implementation
    public function get pan():Number
    public function set pan(value:Number):void
paused property
paused:Boolean [read-only]

Indicates whether the video is paused

Implementation
    public function get paused():Boolean
playing property
playing:Boolean [read-only]

Indicates whether the video is playing

Implementation
    public function get playing():Boolean
soundTransform property
soundTransform:SoundTransform

Provides access to the SoundTransform of the video stream

Implementation
    public function get soundTransform():SoundTransform
    public function set soundTransform(value:SoundTransform):void
source property
source:String

The source, url, to the video file

Implementation
    public function get source():String
    public function set source(value:String):void
time property
time:Number [read-only]

Returns the actual time of the netStream

Implementation
    public function get time():Number
volume property
volume:Number

Master volume/gain

Implementation
    public function get volume():Number
    public function set volume(value:Number):void
width property
width:int

Get/Set access to the with of the video object

Implementation
    public function get width():int
    public function set width(value:int):void
Method Detail
dispose () method
public function dispose():void

Called if the player is no longer needed

pause () method
public function pause():void

Temporarily pause playback. Resume using play().

play () method
public function play():void

Start playing (or resume if paused) the video.

seek () method
public function seek(val:Number):void

Seeks to a given time in the video, specified in seconds, with a precision of three decimal places (milliseconds).

Parameters

val:Number

stop () method
public function stop():void

Stop playback and reset playhead.


away3d.materials.utils.MipmapGenerator

MipmapGenerator | Methods
Package | away3d.materials.utils
Class | public class MipmapGenerator
Inheritance | MipmapGenerator Inheritance Object

MipmapGenerator is a helper class that uploads BitmapData to a Texture including mipmap levels.

Public Methods
Method |  | Defined By
 | generateMipMaps(source:BitmapData, target:TextureBase, mipmap:BitmapData = null, alpha:Boolean = false, side:int = -1):void [static] Uploads a BitmapData with mip maps to a target Texture object. | MipmapGenerator
Method Detail
generateMipMaps () method
public static function generateMipMaps(source:BitmapData, target:TextureBase, mipmap:BitmapData = null, alpha:Boolean = false, side:int = -1):void

Uploads a BitmapData with mip maps to a target Texture object.

Parameters

source:BitmapData — The source BitmapData to upload.
target:TextureBase — The target Texture to upload to.
mipmap:BitmapData (default = null) — An optional mip map holder to avoids creating new instances for fe animated materials.
alpha:Boolean (default = false) — Indicate whether or not the uploaded bitmapData is transparent.
side:int (default = -1)


away3d.materials.utils.MultipleMaterials

MultipleMaterials | Properties | Methods
Package | away3d.materials.utils
Class | public class MultipleMaterials
Inheritance | MultipleMaterials Inheritance Object

Public Properties
Property |  | Defined By
 | back : MaterialBase Defines the material applied to the back side of the cube. | MultipleMaterials
 | bottom : MaterialBase Defines the material applied to the bottom side of the cube. | MultipleMaterials
 | front : MaterialBase Defines the material applied to the front side of the cube. | MultipleMaterials
 | left : MaterialBase Defines the material applied to the left side of the cube. | MultipleMaterials
 | right : MaterialBase Defines the material applied to the right side of the cube. | MultipleMaterials
 | top : MaterialBase Defines the material applied to the top side of the cube. | MultipleMaterials
Public Methods
Method |  | Defined By
 | MultipleMaterials(front:MaterialBase = null, back:MaterialBase = null, left:MaterialBase = null, right:MaterialBase = null, top:MaterialBase = null) Creates a new MultipleMaterials object. | MultipleMaterials
Property Detail
back property
back:MaterialBase

Defines the material applied to the back side of the cube.

Implementation
    public function get back():MaterialBase
    public function set back(value:MaterialBase):void
bottom property
bottom:MaterialBase

Defines the material applied to the bottom side of the cube.

Implementation
    public function get bottom():MaterialBase
    public function set bottom(value:MaterialBase):void
front property
front:MaterialBase

Defines the material applied to the front side of the cube.

Implementation
    public function get front():MaterialBase
    public function set front(value:MaterialBase):void
left property
left:MaterialBase

Defines the material applied to the left side of the cube.

Implementation
    public function get left():MaterialBase
    public function set left(value:MaterialBase):void
right property
right:MaterialBase

Defines the material applied to the right side of the cube.

Implementation
    public function get right():MaterialBase
    public function set right(value:MaterialBase):void
top property
top:MaterialBase

Defines the material applied to the top side of the cube.

Implementation
    public function get top():MaterialBase
    public function set top(value:MaterialBase):void
Constructor Detail
MultipleMaterials () Constructor
public function MultipleMaterials(front:MaterialBase = null, back:MaterialBase = null, left:MaterialBase = null, right:MaterialBase = null, top:MaterialBase = null)

Creates a new MultipleMaterials object. Class can hold up to 6 materials. Class is designed to work as typed object for materials setters in a multitude of classes such as Cube, LatheExtrude (with thickness) etc...

Parameters
front:MaterialBase (default = null) — [optional] The front material.
back:MaterialBase (default = null) — [optional] The back material.
left:MaterialBase (default = null) — [optional] The left material.
right:MaterialBase (default = null) — [optional] The right material.
top:MaterialBase (default = null) — [optional] The top material.


away3d.materials.utils.SimpleVideoPlayer

SimpleVideoPlayer | Properties | Methods
Package | away3d.materials.utils
Class | public class SimpleVideoPlayer
Inheritance | SimpleVideoPlayer Inheritance Object
Implements | IVideoPlayer

Public Properties
Property |  | Defined By
 | container : Sprite [read-only] | SimpleVideoPlayer
 | height : int | SimpleVideoPlayer
 | loop : Boolean | SimpleVideoPlayer
 | mute : Boolean | SimpleVideoPlayer
 | pan : Number | SimpleVideoPlayer
 | paused : Boolean [read-only] | SimpleVideoPlayer
 | playing : Boolean [read-only] | SimpleVideoPlayer
 | soundTransform : SoundTransform | SimpleVideoPlayer
 | source : String | SimpleVideoPlayer
 | time : Number [read-only] | SimpleVideoPlayer
 | volume : Number | SimpleVideoPlayer
 | width : int | SimpleVideoPlayer
Public Methods
Method |  | Defined By
 | SimpleVideoPlayer() | SimpleVideoPlayer
 | dispose():void | SimpleVideoPlayer
 | pause():void | SimpleVideoPlayer
 | play():void | SimpleVideoPlayer
 | seek(val:Number):void | SimpleVideoPlayer
 | stop():void | SimpleVideoPlayer
Property Detail
container property
container:Sprite [read-only]

Implementation
    public function get container():Sprite
height property
height:int

Implementation
    public function get height():int
    public function set height(value:int):void
loop property
loop:Boolean

Implementation
    public function get loop():Boolean
    public function set loop(value:Boolean):void
mute property
mute:Boolean

Implementation
    public function get mute():Boolean
    public function set mute(value:Boolean):void
pan property
pan:Number

Implementation
    public function get pan():Number
    public function set pan(value:Number):void
paused property
paused:Boolean [read-only]

Implementation
    public function get paused():Boolean
playing property
playing:Boolean [read-only]

Implementation
    public function get playing():Boolean
soundTransform property
soundTransform:SoundTransform

Implementation
    public function get soundTransform():SoundTransform
    public function set soundTransform(value:SoundTransform):void
source property
source:String

Implementation
    public function get source():String
    public function set source(value:String):void
time property
time:Number [read-only]

Implementation
    public function get time():Number
volume property
volume:Number

Implementation
    public function get volume():Number
    public function set volume(value:Number):void
width property
width:int

Implementation
    public function get width():int
    public function set width(value:int):void
Constructor Detail
SimpleVideoPlayer () Constructor
public function SimpleVideoPlayer()

Method Detail
dispose () method
public function dispose():void

pause () method
public function pause():void

play () method
public function play():void

seek () method
public function seek(val:Number):void

Parameters

val:Number

stop () method
public function stop():void


away3d.materials.utils.WireframeMapGenerator

WireframeMapGenerator | Methods
Package | away3d.materials.utils
Class | public class WireframeMapGenerator
Inheritance | WireframeMapGenerator Inheritance Object

WireframeMapGenerator is a utility class to generate a wireframe texture for uniquely mapped meshes.

Public Methods
Method |  | Defined By
 | generateSolidMap(mesh:Mesh, lineColor:uint = 0xffffff, lineThickness:Number = 2, fillColor:uint = 0, fillAlpha:Number = 0, width:uint = 512, height:uint = 512):BitmapData [static] Create a wireframe map with a solid colour fill. | WireframeMapGenerator
 | generateTexturedMap(mesh:Mesh, bitmapData:BitmapData, lineColor:uint = 0xffffff, lineThickness:Number = 2):BitmapData [static] Create a wireframe map with a texture fill. | WireframeMapGenerator
Method Detail
generateSolidMap () method
public static function generateSolidMap(mesh:Mesh, lineColor:uint = 0xffffff, lineThickness:Number = 2, fillColor:uint = 0, fillAlpha:Number = 0, width:uint = 512, height:uint = 512):BitmapData

Create a wireframe map with a solid colour fill.

Parameters

mesh:Mesh — The Mesh object for which to create the wireframe texture.
lineColor:uint (default = 0xffffff) — The wireframe's line colour.
lineThickness:Number (default = 2) — The wireframe's line thickness.
fillColor:uint (default = 0) — The colour of the wireframe fill.
fillAlpha:Number (default = 0) — The alpha of the wireframe fill.
width:uint (default = 512) — The texture's width.
height:uint (default = 512) — The texture's height.

Returns
BitmapData — A BitmapData containing the texture underneath the wireframe.
generateTexturedMap () method
public static function generateTexturedMap(mesh:Mesh, bitmapData:BitmapData, lineColor:uint = 0xffffff, lineThickness:Number = 2):BitmapData

Create a wireframe map with a texture fill.

Parameters

mesh:Mesh — The Mesh object for which to create the wireframe texture.
bitmapData:BitmapData — The BitmapData to use as the fill texture.
lineColor:uint (default = 0xffffff) — The wireframe's line colour.
lineThickness:Number (default = 2) — The wireframe's line thickness.

Returns
BitmapData


away3d.paths - Away3D Documentation

Package away3d.paths

Interfaces
IPath
IPathSegment
Classes
CubicPath
CubicPathSegment
QuadraticPath
QuadraticPathSegment
SegmentedPathBase


away3d.paths Summary

away3d.paths | Interfaces | Classes

Interfaces
Interface | Description
IPath |
IPathSegment |
Classes
Class | Description
CubicPath | Defines a cubic path.
CubicPathSegment | Defines a single segment of a cubic path
QuadraticPath | Holds information about a single Path definition.
QuadraticPathSegment | Creates a curved line segment definition required for the Path class.
SegmentedPathBase |

Thu Nov 15 2012, 12:09 PM Z


away3d.paths.CubicPath

CubicPath | Properties | Methods
Package | away3d.paths
Class | public class CubicPath
Inheritance | CubicPath Inheritance SegmentedPathBase Inheritance Object
Implements | IPath

Defines a cubic path. Each segment of the path has two control points as opposed to CubicPathSegment which being quadratic, has one control point.

See also

away3d.animators.CubicPathAnimator
away3d.paths.CubicPathSegment

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | numSegments : uint [read-only] The number of segments in the Path | SegmentedPathBase
Inherited | pointData : Vector.<Vector3D> [write-only] | SegmentedPathBase
Inherited | segments : Vector.<IPathSegment> [read-only] returns the Vector.<PathSegment> holding the elements (PathSegment) of the path | SegmentedPathBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _segments : Vector.<IPathSegment> | SegmentedPathBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CubicPath(data:Vector.<Vector3D> = null) Creates a new CubicPath instance. | CubicPath
Inherited | addSegment(segment:IPathSegment):void | SegmentedPathBase
Inherited | dispose():void | SegmentedPathBase
Inherited | getPointOnCurve(t:Number, target:Vector3D = null):Vector3D | SegmentedPathBase
Inherited | getPointsOnCurvePerSegment(subdivision:uint):Vector.<Vector3D> | SegmentedPathBase
Inherited | getSegmentAt(index:uint):IPathSegment returns a given PathSegment from the path (PathSegment holds 3 Vector3D's) | SegmentedPathBase
Inherited | removeSegment(index:uint, join:Boolean = false):void removes a segment in the path according to id. | SegmentedPathBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createSegmentFromArrayEntry(data:Vector.<Vector3D>, offset:uint):IPathSegment [override] | CubicPath
Inherited | getSegmentPoints(segment:IPathSegment, n:uint, last:Boolean):Vector.<Vector3D> | SegmentedPathBase
 | stitchSegment(start:IPathSegment, middle:IPathSegment, end:IPathSegment):void [override] | CubicPath
Constructor Detail
CubicPath () Constructor
public function CubicPath(data:Vector.<Vector3D> = null)

Creates a new CubicPath instance.

Parameters
data:Vector.<Vector3D> (default = null) — See pointData
Method Detail
createSegmentFromArrayEntry () method
override protected function createSegmentFromArrayEntry(data:Vector.<Vector3D>, offset:uint):IPathSegment

Parameters

data:Vector.<Vector3D>
offset:uint

Returns
IPathSegment
stitchSegment () method
override protected function stitchSegment(start:IPathSegment, middle:IPathSegment, end:IPathSegment):void

Parameters

start:IPathSegment
middle:IPathSegment
end:IPathSegment


away3d.paths.CubicPathSegment

CubicPathSegment | Properties | Methods
Package | away3d.paths
Class | public class CubicPathSegment
Inheritance | CubicPathSegment Inheritance Object
Implements | IPathSegment

Defines a single segment of a cubic path

See also

away3d.paths.CubicPath

Public Properties
Property |  | Defined By
 | control1 : Vector3D The first control point. | CubicPathSegment
 | control2 : Vector3D The second control point. | CubicPathSegment
 | end : Vector3D The last anchor point. | CubicPathSegment
 | start : Vector3D The first anchor point. | CubicPathSegment
Public Methods
Method |  | Defined By
 | CubicPathSegment(start:Vector3D, control1:Vector3D, control2:Vector3D, end:Vector3D) | CubicPathSegment
 | dispose():void | CubicPathSegment
 | getPointOnSegment(phase:Number, target:Vector3D = null):Vector3D | CubicPathSegment
 | toString():String | CubicPathSegment
Property Detail
control1 property
public var control1:Vector3D

The first control point.

control2 property
public var control2:Vector3D

The second control point.

end property
public var end:Vector3D

The last anchor point.

start property
public var start:Vector3D

The first anchor point.

Constructor Detail
CubicPathSegment () Constructor
public function CubicPathSegment(start:Vector3D, control1:Vector3D, control2:Vector3D, end:Vector3D)

Parameters
start:Vector3D — The first anchor point.
control1:Vector3D — The first control point.
control2:Vector3D — The second control point.
end:Vector3D — The last anchor point.
Method Detail
dispose () method
public function dispose():void

getPointOnSegment () method
public function getPointOnSegment(phase:Number, target:Vector3D = null):Vector3D

Parameters

phase:Number
target:Vector3D (default = null)

Returns
Vector3D
toString () method
public function toString():String

Returns
String


away3d.paths.IPath

IPath | Properties | Methods
Package | away3d.paths
Interface | public interface IPath
Implementors | CubicPath, QuadraticPath, SegmentedPathBase

Public Properties
Property |  | Defined By
 | numSegments : uint Deprecated: Deprecated [read-only] The number of CubicPathSegment instances in the path. | IPath
 | segments : Vector.<IPathSegment> Deprecated: Deprecated [read-only] The IPathSegment instances which make up this path. | IPath
Public Methods
Method |  | Defined By
 | addSegment(segment:IPathSegment):void Deprecated: Deprecated Adds a CubicPathSegment to the end of the path | IPath
 | dispose():void Disposes the path and all the segments | IPath
 | getPointOnCurve(t:Number, target:Vector3D = null):Vector3D Gets a point on the curve | IPath
 | getPointsOnCurvePerSegment(numSegments:uint):Vector.<Vector3D> Deprecated: Deprecated Discretizes the segment into a set of sample points. | IPath
 | getSegmentAt(index:uint):IPathSegment Deprecated: Deprecated Returns the CubicPathSegment at the specified index | IPath
 | removeSegment(index:uint, join:Boolean = false):void Deprecated: Deprecated Removes a segment from the path | IPath
Property Detail
numSegments property
numSegments:uint [read-only]
Deprecated: Deprecated

The number of CubicPathSegment instances in the path.

Implementation
    public function get numSegments():uint
segments property
segments:Vector.<IPathSegment> [read-only]
Deprecated: Deprecated

The IPathSegment instances which make up this path.

Implementation
    public function get segments():Vector.<IPathSegment>
Method Detail
addSegment () method
public function addSegment(segment:IPathSegment):void
Deprecated: Deprecated

Adds a CubicPathSegment to the end of the path

Parameters

segment:IPathSegment

dispose () method
public function dispose():void

Disposes the path and all the segments

getPointOnCurve () method
public function getPointOnCurve(t:Number, target:Vector3D = null):Vector3D

Gets a point on the curve

Parameters

t:Number — The phase for which to get the point. A number between 0 and 1.
target:Vector3D (default = null) — An optional parameter to store the calculation, to avoid creating a new Vector3D object

Returns
Vector3D — The point on the curve for the given phase
getPointsOnCurvePerSegment () method
public function getPointsOnCurvePerSegment(numSegments:uint):Vector.<Vector3D>
Deprecated: Deprecated

Discretizes the segment into a set of sample points.

Parameters

numSegments:uint — The amount of segments to split the sampling in. The amount of points returned is numSegments + 1 TODO: is this really even necessary? We should be able to simply call getPointOnCurve(t) instead, oblivious of segments

Returns
Vector.<Vector3D>
getSegmentAt () method
public function getSegmentAt(index:uint):IPathSegment
Deprecated: Deprecated

Returns the CubicPathSegment at the specified index

Parameters

index:uint — The index of the segment

Returns
IPathSegment — A CubicPathSegment instance
removeSegment () method
public function removeSegment(index:uint, join:Boolean = false):void
Deprecated: Deprecated

Removes a segment from the path

Parameters

index:uint — The index of the CubicPathSegment to be removed
join:Boolean (default = false) — Determines if the segments on either side of the removed segment should be adjusted so there is no gap.


away3d.paths.IPathSegment

IPathSegment | Methods
Package | away3d.paths
Interface | public interface IPathSegment
Implementors | CubicPathSegment, QuadraticPathSegment

Public Methods
Method |  | Defined By
 | dispose():void Destroys the segment | IPathSegment
 | getPointOnSegment(phase:Number, target:Vector3D = null):Vector3D Calculates the position of the curve on this segment. | IPathSegment
Method Detail
dispose () method
public function dispose():void

Destroys the segment

getPointOnSegment () method
public function getPointOnSegment(phase:Number, target:Vector3D = null):Vector3D

Calculates the position of the curve on this segment.

Parameters

phase:Number — The ratio between the start and end point.
target:Vector3D (default = null) — An optional target to store the calculation, to prevent creating a new Vector3D object.

Returns
Vector3D —


away3d.paths.QuadraticPath

QuadraticPath | Properties | Methods
Package | away3d.paths
Class | public class QuadraticPath
Inheritance | QuadraticPath Inheritance SegmentedPathBase Inheritance Object
Implements | IPath

Holds information about a single Path definition. DEBUG OPTION OUT AT THIS TIME OF DEV

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | averaged : Boolean [read-only] returns true if the averagePath handler is being used. | QuadraticPath
Inherited | numSegments : uint [read-only] The number of segments in the Path | SegmentedPathBase
Inherited | pointData : Vector.<Vector3D> [write-only] | SegmentedPathBase
Inherited | segments : Vector.<IPathSegment> [read-only] returns the Vector.<PathSegment> holding the elements (PathSegment) of the path | SegmentedPathBase
 | smoothed : Boolean [read-only] returns true if the smoothPath handler is being used. | QuadraticPath
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _segments : Vector.<IPathSegment> | SegmentedPathBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | QuadraticPath(data:Vector.<Vector3D> = null) Creates a new Path object. | QuadraticPath
Inherited | addSegment(segment:IPathSegment):void | SegmentedPathBase
 | averagePath():void handler will average the path using averages of the PathSegments note that this is not dynamic, the path values are overwrited | QuadraticPath
 | continuousCurve(points:Vector.<Vector3D>, closed:Boolean = false):void | QuadraticPath
Inherited | dispose():void | SegmentedPathBase
Inherited | getPointOnCurve(t:Number, target:Vector3D = null):Vector3D | SegmentedPathBase
Inherited | getPointsOnCurvePerSegment(subdivision:uint):Vector.<Vector3D> | SegmentedPathBase
Inherited | getSegmentAt(index:uint):IPathSegment returns a given PathSegment from the path (PathSegment holds 3 Vector3D's) | SegmentedPathBase
Inherited | removeSegment(index:uint, join:Boolean = false):void removes a segment in the path according to id. | SegmentedPathBase
 | smoothPath():void handler will smooth the path using anchors as control vector of the PathSegments note that this is not dynamic, the PathSegments values are overwrited | QuadraticPath
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createSegmentFromArrayEntry(data:Vector.<Vector3D>, offset:uint):IPathSegment [override] | QuadraticPath
Inherited | getSegmentPoints(segment:IPathSegment, n:uint, last:Boolean):Vector.<Vector3D> | SegmentedPathBase
 | stitchSegment(start:IPathSegment, middle:IPathSegment, end:IPathSegment):void [override] | QuadraticPath
Property Detail
averaged property
averaged:Boolean [read-only]

returns true if the averagePath handler is being used.

Implementation
    public function get averaged():Boolean
smoothed property
smoothed:Boolean [read-only]

returns true if the smoothPath handler is being used.

Implementation
    public function get smoothed():Boolean
Constructor Detail
QuadraticPath () Constructor
public function QuadraticPath(data:Vector.<Vector3D> = null)

Creates a new Path object.

Parameters
data:Vector.<Vector3D> (default = null) — [optional] An array of a series of Vector3D's organized in the following fashion. [a,b,c,a,b,c etc...] a = pEnd, b=pControl (control point), c = v2
Method Detail
averagePath () method
public function averagePath():void

handler will average the path using averages of the PathSegments note that this is not dynamic, the path values are overwrited

continuousCurve () method
public function continuousCurve(points:Vector.<Vector3D>, closed:Boolean = false):void

Parameters

points:Vector.<Vector3D>
closed:Boolean (default = false)

createSegmentFromArrayEntry () method
override protected function createSegmentFromArrayEntry(data:Vector.<Vector3D>, offset:uint):IPathSegment

Parameters

data:Vector.<Vector3D>
offset:uint

Returns
IPathSegment
smoothPath () method
public function smoothPath():void

handler will smooth the path using anchors as control vector of the PathSegments note that this is not dynamic, the PathSegments values are overwrited

stitchSegment () method
override protected function stitchSegment(start:IPathSegment, middle:IPathSegment, end:IPathSegment):void

Parameters

start:IPathSegment
middle:IPathSegment
end:IPathSegment


away3d.paths.QuadraticPathSegment

QuadraticPathSegment | Properties | Methods
Package | away3d.paths
Class | public class QuadraticPathSegment
Inheritance | QuadraticPathSegment Inheritance Object
Implements | IPathSegment

Creates a curved line segment definition required for the Path class.

Public Properties
Property |  | Defined By
 | control : Vector3D Defines the control vector of the PathSegment | QuadraticPathSegment
 | end : Vector3D Defines the control vector of the PathSegment | QuadraticPathSegment
 | start : Vector3D Defines the first vector of the PathSegment | QuadraticPathSegment
Public Methods
Method |  | Defined By
 | QuadraticPathSegment(pStart:Vector3D, pControl:Vector3D, pEnd:Vector3D) | QuadraticPathSegment
 | dispose():void nulls the 3 vectors | QuadraticPathSegment
 | getPointOnSegment(t:Number, target:Vector3D = null):Vector3D | QuadraticPathSegment
 | toString():String | QuadraticPathSegment
Property Detail
control property
public var control:Vector3D

Defines the control vector of the PathSegment

end property
public var end:Vector3D

Defines the control vector of the PathSegment

start property
public var start:Vector3D

Defines the first vector of the PathSegment

Constructor Detail
QuadraticPathSegment () Constructor
public function QuadraticPathSegment(pStart:Vector3D, pControl:Vector3D, pEnd:Vector3D)

Parameters
pStart:Vector3D
pControl:Vector3D
pEnd:Vector3D
Method Detail
dispose () method
public function dispose():void

nulls the 3 vectors

getPointOnSegment () method
public function getPointOnSegment(t:Number, target:Vector3D = null):Vector3D

Parameters

t:Number
target:Vector3D (default = null)

Returns
Vector3D
toString () method
public function toString():String

Returns
String


away3d.paths.SegmentedPathBase

SegmentedPathBase | Properties | Methods
Package | away3d.paths
Class | public class SegmentedPathBase
Inheritance | SegmentedPathBase Inheritance Object
Implements | IPath
Subclasses | CubicPath, QuadraticPath

Public Properties
Property |  | Defined By
 | numSegments : uint [read-only] The number of segments in the Path | SegmentedPathBase
 | pointData : Vector.<Vector3D> [write-only] | SegmentedPathBase
 | segments : Vector.<IPathSegment> [read-only] returns the Vector.<PathSegment> holding the elements (PathSegment) of the path | SegmentedPathBase
Protected Properties
Property |  | Defined By
 | _segments : Vector.<IPathSegment> | SegmentedPathBase
Public Methods
Method |  | Defined By
 | SegmentedPathBase(pointsPerSegment:uint, data:Vector.<Vector3D> = null) | SegmentedPathBase
 | addSegment(segment:IPathSegment):void | SegmentedPathBase
 | dispose():void | SegmentedPathBase
 | getPointOnCurve(t:Number, target:Vector3D = null):Vector3D | SegmentedPathBase
 | getPointsOnCurvePerSegment(subdivision:uint):Vector.<Vector3D> | SegmentedPathBase
 | getSegmentAt(index:uint):IPathSegment returns a given PathSegment from the path (PathSegment holds 3 Vector3D's) | SegmentedPathBase
 | removeSegment(index:uint, join:Boolean = false):void removes a segment in the path according to id. | SegmentedPathBase
Protected Methods
Method |  | Defined By
 | createSegmentFromArrayEntry(data:Vector.<Vector3D>, offset:uint):IPathSegment | SegmentedPathBase
 | getSegmentPoints(segment:IPathSegment, n:uint, last:Boolean):Vector.<Vector3D> | SegmentedPathBase
 | stitchSegment(start:IPathSegment, middle:IPathSegment, end:IPathSegment):void Stitches two segments together based on a segment between them. | SegmentedPathBase
Property Detail
_segments property
protected var _segments:Vector.<IPathSegment>

numSegments property
numSegments:uint [read-only]

The number of segments in the Path

Implementation
    public function get numSegments():uint
pointData property
pointData:Vector.<Vector3D> [write-only]

Implementation
    public function set pointData(value:Vector.<Vector3D>):void
segments property
segments:Vector.<IPathSegment> [read-only]

returns the Vector.<PathSegment> holding the elements (PathSegment) of the path

Implementation
    public function get segments():Vector.<IPathSegment>
Constructor Detail
SegmentedPathBase () Constructor
public function SegmentedPathBase(pointsPerSegment:uint, data:Vector.<Vector3D> = null)

Parameters
pointsPerSegment:uint
data:Vector.<Vector3D> (default = null)
Method Detail
addSegment () method
public function addSegment(segment:IPathSegment):void

Parameters

segment:IPathSegment

createSegmentFromArrayEntry () method
protected function createSegmentFromArrayEntry(data:Vector.<Vector3D>, offset:uint):IPathSegment

Parameters

data:Vector.<Vector3D>
offset:uint

Returns
IPathSegment
dispose () method
public function dispose():void

getPointOnCurve () method
public function getPointOnCurve(t:Number, target:Vector3D = null):Vector3D

Parameters

t:Number
target:Vector3D (default = null)

Returns
Vector3D
getPointsOnCurvePerSegment () method
public function getPointsOnCurvePerSegment(subdivision:uint):Vector.<Vector3D>

Parameters

subdivision:uint

Returns
Vector.<Vector3D>
getSegmentAt () method
public function getSegmentAt(index:uint):IPathSegment

returns a given PathSegment from the path (PathSegment holds 3 Vector3D's)

Parameters

index:uint — uint. the indice of a given PathSegment

Returns
IPathSegment — given PathSegment from the path
getSegmentPoints () method
protected function getSegmentPoints(segment:IPathSegment, n:uint, last:Boolean):Vector.<Vector3D>

Parameters

segment:IPathSegment
n:uint
last:Boolean

Returns
Vector.<Vector3D>
removeSegment () method
public function removeSegment(index:uint, join:Boolean = false):void

removes a segment in the path according to id.

Parameters

index:uint — int. The index in path of the to be removed curvesegment
join:Boolean (default = false) — Boolean. If true previous and next segments coordinates are reconnected

stitchSegment () method
protected function stitchSegment(start:IPathSegment, middle:IPathSegment, end:IPathSegment):void

Stitches two segments together based on a segment between them. This is an abstract method used by the template method removeSegment and must be overridden by concrete subclasses!

Parameters

start:IPathSegment — The section of which the end points must be connected with "end"
middle:IPathSegment — The section that was removed and forms the position hint
end:IPathSegment — The section of which the start points must be connected with "start"


away3d.primitives - Away3D Documentation

Package away3d.primitives

Classes
CapsuleGeometry
ConeGeometry
CubeGeometry
CylinderGeometry
LineSegment
NURBSGeometry
PlaneGeometry
PrimitiveBase
RegularPolygonGeometry
SkyBox
SphereGeometry
TorusGeometry
WireframeCube
WireframeCylinder
WireframePlane
WireframePrimitiveBase
WireframeSphere


away3d.primitives Summary

away3d.primitives | Classes

Classes
Class | Description
CapsuleGeometry | A UV Capsule primitive mesh.
ConeGeometry | A UV Cone primitive mesh.
CubeGeometry | A Cube primitive mesh.
CylinderGeometry | A UV Cylinder primitive mesh.
LineSegment | A Line Segment primitive.
NURBSGeometry | A NURBS primitive geometry.
PlaneGeometry | A Plane primitive mesh.
PrimitiveBase | PrimitiveBase is an abstract base class for mesh primitives, which are prebuilt simple meshes.
RegularPolygonGeometry | A UV RegularPolygon primitive mesh.
SkyBox | A SkyBox class is used to render a sky in the scene.
SphereGeometry | A UV Sphere primitive mesh.
TorusGeometry | A UV Cylinder primitive mesh.
WireframeCube | A WirefameCube primitive mesh.
WireframeCylinder | Generates a wireframd cylinder primitive.
WireframePlane | A WireframePlane primitive mesh.
WireframePrimitiveBase |
WireframeSphere | A WireframeSphere primitive mesh

Thu Nov 15 2012, 12:09 PM Z


away3d.primitives.CapsuleGeometry

CapsuleGeometry | Properties | Methods | Constants
Package | away3d.primitives
Class | public class CapsuleGeometry
Inheritance | CapsuleGeometry Inheritance PrimitiveBase Inheritance Geometry Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A UV Capsule primitive mesh.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | Geometry
 | height : Number The height of the capsule. | CapsuleGeometry
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | radius : Number The radius of the capsule. | CapsuleGeometry
 | segmentsH : uint Defines the number of vertical segments that make up the capsule. | CapsuleGeometry
 | segmentsW : uint Defines the number of horizontal segments that make up the capsule. | CapsuleGeometry
Inherited | subGeometries : Vector.<ISubGeometry> [override] [read-only] A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc. | PrimitiveBase
 | yUp : Boolean Defines whether the capsule poles should lay on the Y-axis (true) or on the Z-axis (false). | CapsuleGeometry
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _geomDirty : Boolean = true | PrimitiveBase
Inherited | _uvDirty : Boolean = true | PrimitiveBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CapsuleGeometry(radius:Number = 50, height:Number = 100, segmentsW:uint = 16, segmentsH:uint = 12, yUp:Boolean = true) Creates a new Capsule object. | CapsuleGeometry
Inherited | addSubGeometry(subGeometry:ISubGeometry):void Adds a new SubGeometry object to the list. | Geometry
Inherited | applyTransformation(transform:Matrix3D):void [override] | PrimitiveBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Geometry [override] Clones the geometry. | PrimitiveBase
Inherited | convertToSeparateBuffers():void Updates the SubGeometries so all vertex data is represented in different buffers. | Geometry
Inherited | dispose():void Clears all resources used by the Geometry object, including SubGeometries. | Geometry
Inherited | removeSubGeometry(subGeometry:ISubGeometry):void Removes a new SubGeometry object from the list. | Geometry
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | scale(scale:Number):void [override] Scales the geometry. | PrimitiveBase
Inherited | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void [override] Scales the uv coordinates (tiling) | PrimitiveBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | buildGeometry(target:CompactSubGeometry):void [override] Builds the primitive's geometry when invalid. | CapsuleGeometry
 | buildUVs(target:CompactSubGeometry):void [override] Builds the primitive's uv coordinates when invalid. | CapsuleGeometry
Inherited | invalidateGeometry():void Invalidates the primitive's geometry, causing it to be updated when requested. | PrimitiveBase
Inherited | invalidateUVs():void Invalidates the primitive's uv coordinates, causing them to be updated when requested. | PrimitiveBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
height property
height:Number

The height of the capsule.

Implementation
    public function get height():Number
    public function set height(value:Number):void
radius property
radius:Number

The radius of the capsule.

Implementation
    public function get radius():Number
    public function set radius(value:Number):void
segmentsH property
segmentsH:uint

Defines the number of vertical segments that make up the capsule. Defaults to 12.

Implementation
    public function get segmentsH():uint
    public function set segmentsH(value:uint):void
segmentsW property
segmentsW:uint

Defines the number of horizontal segments that make up the capsule. Defaults to 16.

Implementation
    public function get segmentsW():uint
    public function set segmentsW(value:uint):void
yUp property
yUp:Boolean

Defines whether the capsule poles should lay on the Y-axis (true) or on the Z-axis (false).

Implementation
    public function get yUp():Boolean
    public function set yUp(value:Boolean):void
Constructor Detail
CapsuleGeometry () Constructor
public function CapsuleGeometry(radius:Number = 50, height:Number = 100, segmentsW:uint = 16, segmentsH:uint = 12, yUp:Boolean = true)

Creates a new Capsule object.

Parameters
radius:Number (default = 50) — The radius of the capsule.
height:Number (default = 100) — The height of the capsule.
segmentsW:uint (default = 16) — Defines the number of horizontal segments that make up the capsule. Defaults to 16.
segmentsH:uint (default = 12) — Defines the number of vertical segments that make up the capsule. Defaults to 12.
yUp:Boolean (default = true) — Defines whether the capsule poles should lay on the Y-axis (true) or on the Z-axis (false).
Method Detail
buildGeometry () method
override protected function buildGeometry(target:CompactSubGeometry):void

Builds the primitive's geometry when invalid. This method should not be called directly. The calling should be triggered by the invalidateGeometry method (and in turn by updateGeometry).

Parameters

target:CompactSubGeometry

buildUVs () method
override protected function buildUVs(target:CompactSubGeometry):void

Builds the primitive's uv coordinates when invalid. This method should not be called directly. The calling should be triggered by the invalidateUVs method (and in turn by updateUVs).

Parameters

target:CompactSubGeometry


away3d.primitives.ConeGeometry

ConeGeometry | Properties | Methods | Constants
Package | away3d.primitives
Class | public class ConeGeometry
Inheritance | ConeGeometry Inheritance CylinderGeometry Inheritance PrimitiveBase Inheritance Geometry Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A UV Cone primitive mesh.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | Geometry
Inherited | bottomClosed : Boolean Defines whether the bottom end of the cylinder is closed (true) or open. | CylinderGeometry
Inherited | bottomRadius : Number The radius of the bottom end of the cylinder. | CylinderGeometry
Inherited | height : Number The radius of the top end of the cylinder. | CylinderGeometry
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | radius : Number The radius of the bottom end of the cone. | ConeGeometry
Inherited | segmentsH : uint Defines the number of vertical segments that make up the cylinder. | CylinderGeometry
Inherited | segmentsW : uint Defines the number of horizontal segments that make up the cylinder. | CylinderGeometry
Inherited | subGeometries : Vector.<ISubGeometry> [override] [read-only] A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc. | PrimitiveBase
Inherited | topClosed : Boolean Defines whether the top end of the cylinder is closed (true) or open. | CylinderGeometry
Inherited | topRadius : Number The radius of the top end of the cylinder. | CylinderGeometry
Inherited | yUp : Boolean Defines whether the cylinder poles should lay on the Y-axis (true) or on the Z-axis (false). | CylinderGeometry
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bottomClosed : Boolean | CylinderGeometry
Inherited | _bottomRadius : Number | CylinderGeometry
Inherited | _geomDirty : Boolean = true | PrimitiveBase
Inherited | _height : Number | CylinderGeometry
Inherited | _segmentsH : uint | CylinderGeometry
Inherited | _segmentsW : uint | CylinderGeometry
Inherited | _surfaceClosed : Boolean | CylinderGeometry
Inherited | _topClosed : Boolean | CylinderGeometry
Inherited | _topRadius : Number | CylinderGeometry
Inherited | _uvDirty : Boolean = true | PrimitiveBase
Inherited | _yUp : Boolean | CylinderGeometry
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ConeGeometry(radius:Number = 50, height:Number = 100, segmentsW:uint = 16, segmentsH:uint = 1, closed:Boolean = true, yUp:Boolean = true) Creates a new Cone object. | ConeGeometry
Inherited | addSubGeometry(subGeometry:ISubGeometry):void Adds a new SubGeometry object to the list. | Geometry
Inherited | applyTransformation(transform:Matrix3D):void [override] | PrimitiveBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Geometry [override] Clones the geometry. | PrimitiveBase
Inherited | convertToSeparateBuffers():void Updates the SubGeometries so all vertex data is represented in different buffers. | Geometry
Inherited | dispose():void Clears all resources used by the Geometry object, including SubGeometries. | Geometry
Inherited | removeSubGeometry(subGeometry:ISubGeometry):void Removes a new SubGeometry object from the list. | Geometry
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | scale(scale:Number):void [override] Scales the geometry. | PrimitiveBase
Inherited | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void [override] Scales the uv coordinates (tiling) | PrimitiveBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | buildGeometry(target:CompactSubGeometry):void [override] Builds the primitive's geometry when invalid. | CylinderGeometry
Inherited | buildUVs(target:CompactSubGeometry):void [override] Builds the primitive's uv coordinates when invalid. | CylinderGeometry
Inherited | invalidateGeometry():void Invalidates the primitive's geometry, causing it to be updated when requested. | PrimitiveBase
Inherited | invalidateUVs():void Invalidates the primitive's uv coordinates, causing them to be updated when requested. | PrimitiveBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
radius property
radius:Number

The radius of the bottom end of the cone.

Implementation
    public function get radius():Number
    public function set radius(value:Number):void
Constructor Detail
ConeGeometry () Constructor
public function ConeGeometry(radius:Number = 50, height:Number = 100, segmentsW:uint = 16, segmentsH:uint = 1, closed:Boolean = true, yUp:Boolean = true)

Creates a new Cone object.

Parameters
radius:Number (default = 50) — The radius of the bottom end of the cone
height:Number (default = 100) — The height of the cone
segmentsW:uint (default = 16) — Defines the number of horizontal segments that make up the cone. Defaults to 16.
segmentsH:uint (default = 1) — Defines the number of vertical segments that make up the cone. Defaults to 1.
closed:Boolean (default = true) — Defines whether the cone poles should lay on the Y-axis (true) or on the Z-axis (false).
yUp:Boolean (default = true)


away3d.primitives.CubeGeometry

CubeGeometry | Properties | Methods | Constants
Package | away3d.primitives
Class | public class CubeGeometry
Inheritance | CubeGeometry Inheritance PrimitiveBase Inheritance Geometry Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A Cube primitive mesh.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | Geometry
 | depth : Number The size of the cube along its Z-axis. | CubeGeometry
 | height : Number The size of the cube along its Y-axis. | CubeGeometry
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | segmentsD : Number The number of segments that make up the cube along the Z-axis. | CubeGeometry
 | segmentsH : Number The number of segments that make up the cube along the Y-axis. | CubeGeometry
 | segmentsW : Number The number of segments that make up the cube along the X-axis. | CubeGeometry
Inherited | subGeometries : Vector.<ISubGeometry> [override] [read-only] A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc. | PrimitiveBase
 | tile6 : Boolean The type of uv mapping to use. | CubeGeometry
 | width : Number The size of the cube along its X-axis. | CubeGeometry
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _geomDirty : Boolean = true | PrimitiveBase
Inherited | _uvDirty : Boolean = true | PrimitiveBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CubeGeometry(width:Number = 100, height:Number = 100, depth:Number = 100, segmentsW:uint = 1, segmentsH:uint = 1, segmentsD:uint = 1, tile6:Boolean = true) Creates a new Cube object. | CubeGeometry
Inherited | addSubGeometry(subGeometry:ISubGeometry):void Adds a new SubGeometry object to the list. | Geometry
Inherited | applyTransformation(transform:Matrix3D):void [override] | PrimitiveBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Geometry [override] Clones the geometry. | PrimitiveBase
Inherited | convertToSeparateBuffers():void Updates the SubGeometries so all vertex data is represented in different buffers. | Geometry
Inherited | dispose():void Clears all resources used by the Geometry object, including SubGeometries. | Geometry
Inherited | removeSubGeometry(subGeometry:ISubGeometry):void Removes a new SubGeometry object from the list. | Geometry
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | scale(scale:Number):void [override] Scales the geometry. | PrimitiveBase
Inherited | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void [override] Scales the uv coordinates (tiling) | PrimitiveBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | buildGeometry(target:CompactSubGeometry):void [override] Builds the primitive's geometry when invalid. | CubeGeometry
 | buildUVs(target:CompactSubGeometry):void [override] Builds the primitive's uv coordinates when invalid. | CubeGeometry
Inherited | invalidateGeometry():void Invalidates the primitive's geometry, causing it to be updated when requested. | PrimitiveBase
Inherited | invalidateUVs():void Invalidates the primitive's uv coordinates, causing them to be updated when requested. | PrimitiveBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
depth property
depth:Number

The size of the cube along its Z-axis.

Implementation
    public function get depth():Number
    public function set depth(value:Number):void
height property
height:Number

The size of the cube along its Y-axis.

Implementation
    public function get height():Number
    public function set height(value:Number):void
segmentsD property
segmentsD:Number

The number of segments that make up the cube along the Z-axis. Defaults to 1.

Implementation
    public function get segmentsD():Number
    public function set segmentsD(value:Number):void
segmentsH property
segmentsH:Number

The number of segments that make up the cube along the Y-axis. Defaults to 1.

Implementation
    public function get segmentsH():Number
    public function set segmentsH(value:Number):void
segmentsW property
segmentsW:Number

The number of segments that make up the cube along the X-axis. Defaults to 1.

Implementation
    public function get segmentsW():Number
    public function set segmentsW(value:Number):void
tile6 property
tile6:Boolean

The type of uv mapping to use. When false, the entire image is mapped on each face. When true, a texture will be subdivided in a 3x2 grid, each used for a single face. Reading the tiles from left to right, top to bottom they represent the faces of the cube in the following order: bottom, top, back, left, front, right. This creates several shared edges (between the top, front, left and right faces) which simplifies texture painting.

Implementation
    public function get tile6():Boolean
    public function set tile6(value:Boolean):void
width property
width:Number

The size of the cube along its X-axis.

Implementation
    public function get width():Number
    public function set width(value:Number):void
Constructor Detail
CubeGeometry () Constructor
public function CubeGeometry(width:Number = 100, height:Number = 100, depth:Number = 100, segmentsW:uint = 1, segmentsH:uint = 1, segmentsD:uint = 1, tile6:Boolean = true)

Creates a new Cube object.

Parameters
width:Number (default = 100) — The size of the cube along its X-axis.
height:Number (default = 100) — The size of the cube along its Y-axis.
depth:Number (default = 100) — The size of the cube along its Z-axis.
segmentsW:uint (default = 1) — The number of segments that make up the cube along the X-axis.
segmentsH:uint (default = 1) — The number of segments that make up the cube along the Y-axis.
segmentsD:uint (default = 1) — The number of segments that make up the cube along the Z-axis.
tile6:Boolean (default = true) — The type of uv mapping to use. When true, a texture will be subdivided in a 2x3 grid, each used for a single face. When false, the entire image is mapped on each face.
Method Detail
buildGeometry () method
override protected function buildGeometry(target:CompactSubGeometry):void

Builds the primitive's geometry when invalid. This method should not be called directly. The calling should be triggered by the invalidateGeometry method (and in turn by updateGeometry).

Parameters

target:CompactSubGeometry

buildUVs () method
override protected function buildUVs(target:CompactSubGeometry):void

Builds the primitive's uv coordinates when invalid. This method should not be called directly. The calling should be triggered by the invalidateUVs method (and in turn by updateUVs).

Parameters

target:CompactSubGeometry


away3d.primitives.CylinderGeometry

CylinderGeometry | Properties | Methods | Constants
Package | away3d.primitives
Class | public class CylinderGeometry
Inheritance | CylinderGeometry Inheritance PrimitiveBase Inheritance Geometry Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | ConeGeometry, RegularPolygonGeometry

A UV Cylinder primitive mesh.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | Geometry
 | bottomClosed : Boolean Defines whether the bottom end of the cylinder is closed (true) or open. | CylinderGeometry
 | bottomRadius : Number The radius of the bottom end of the cylinder. | CylinderGeometry
 | height : Number The radius of the top end of the cylinder. | CylinderGeometry
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | segmentsH : uint Defines the number of vertical segments that make up the cylinder. | CylinderGeometry
 | segmentsW : uint Defines the number of horizontal segments that make up the cylinder. | CylinderGeometry
Inherited | subGeometries : Vector.<ISubGeometry> [override] [read-only] A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc. | PrimitiveBase
 | topClosed : Boolean Defines whether the top end of the cylinder is closed (true) or open. | CylinderGeometry
 | topRadius : Number The radius of the top end of the cylinder. | CylinderGeometry
 | yUp : Boolean Defines whether the cylinder poles should lay on the Y-axis (true) or on the Z-axis (false). | CylinderGeometry
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
 | _bottomClosed : Boolean | CylinderGeometry
 | _bottomRadius : Number | CylinderGeometry
Inherited | _geomDirty : Boolean = true | PrimitiveBase
 | _height : Number | CylinderGeometry
 | _segmentsH : uint | CylinderGeometry
 | _segmentsW : uint | CylinderGeometry
 | _surfaceClosed : Boolean | CylinderGeometry
 | _topClosed : Boolean | CylinderGeometry
 | _topRadius : Number | CylinderGeometry
Inherited | _uvDirty : Boolean = true | PrimitiveBase
 | _yUp : Boolean | CylinderGeometry
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CylinderGeometry(topRadius:Number = 50, bottomRadius:Number = 50, height:Number = 100, segmentsW:uint = 16, segmentsH:uint = 1, topClosed:Boolean = true, bottomClosed:Boolean = true, surfaceClosed:Boolean = true, yUp:Boolean = true) Creates a new Cylinder object. | CylinderGeometry
Inherited | addSubGeometry(subGeometry:ISubGeometry):void Adds a new SubGeometry object to the list. | Geometry
Inherited | applyTransformation(transform:Matrix3D):void [override] | PrimitiveBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Geometry [override] Clones the geometry. | PrimitiveBase
Inherited | convertToSeparateBuffers():void Updates the SubGeometries so all vertex data is represented in different buffers. | Geometry
Inherited | dispose():void Clears all resources used by the Geometry object, including SubGeometries. | Geometry
Inherited | removeSubGeometry(subGeometry:ISubGeometry):void Removes a new SubGeometry object from the list. | Geometry
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | scale(scale:Number):void [override] Scales the geometry. | PrimitiveBase
Inherited | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void [override] Scales the uv coordinates (tiling) | PrimitiveBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | buildGeometry(target:CompactSubGeometry):void [override] Builds the primitive's geometry when invalid. | CylinderGeometry
 | buildUVs(target:CompactSubGeometry):void [override] Builds the primitive's uv coordinates when invalid. | CylinderGeometry
Inherited | invalidateGeometry():void Invalidates the primitive's geometry, causing it to be updated when requested. | PrimitiveBase
Inherited | invalidateUVs():void Invalidates the primitive's uv coordinates, causing them to be updated when requested. | PrimitiveBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_bottomClosed property
protected var _bottomClosed:Boolean

_bottomRadius property
protected var _bottomRadius:Number

_height property
protected var _height:Number

_segmentsH property
protected var _segmentsH:uint

_segmentsW property
protected var _segmentsW:uint

_surfaceClosed property
protected var _surfaceClosed:Boolean

_topClosed property
protected var _topClosed:Boolean

_topRadius property
protected var _topRadius:Number

_yUp property
protected var _yUp:Boolean

bottomClosed property
bottomClosed:Boolean

Defines whether the bottom end of the cylinder is closed (true) or open.

Implementation
    public function get bottomClosed():Boolean
    public function set bottomClosed(value:Boolean):void
bottomRadius property
bottomRadius:Number

The radius of the bottom end of the cylinder.

Implementation
    public function get bottomRadius():Number
    public function set bottomRadius(value:Number):void
height property
height:Number

The radius of the top end of the cylinder.

Implementation
    public function get height():Number
    public function set height(value:Number):void
segmentsH property
segmentsH:uint

Defines the number of vertical segments that make up the cylinder. Defaults to 1.

Implementation
    public function get segmentsH():uint
    public function set segmentsH(value:uint):void
segmentsW property
segmentsW:uint

Defines the number of horizontal segments that make up the cylinder. Defaults to 16.

Implementation
    public function get segmentsW():uint
    public function set segmentsW(value:uint):void
topClosed property
topClosed:Boolean

Defines whether the top end of the cylinder is closed (true) or open.

Implementation
    public function get topClosed():Boolean
    public function set topClosed(value:Boolean):void
topRadius property
topRadius:Number

The radius of the top end of the cylinder.

Implementation
    public function get topRadius():Number
    public function set topRadius(value:Number):void
yUp property
yUp:Boolean

Defines whether the cylinder poles should lay on the Y-axis (true) or on the Z-axis (false).

Implementation
    public function get yUp():Boolean
    public function set yUp(value:Boolean):void
Constructor Detail
CylinderGeometry () Constructor
public function CylinderGeometry(topRadius:Number = 50, bottomRadius:Number = 50, height:Number = 100, segmentsW:uint = 16, segmentsH:uint = 1, topClosed:Boolean = true, bottomClosed:Boolean = true, surfaceClosed:Boolean = true, yUp:Boolean = true)

Creates a new Cylinder object.

Parameters
topRadius:Number (default = 50) — The radius of the top end of the cylinder.
bottomRadius:Number (default = 50) — The radius of the bottom end of the cylinder
height:Number (default = 100) — The radius of the bottom end of the cylinder
segmentsW:uint (default = 16) — Defines the number of horizontal segments that make up the cylinder. Defaults to 16.
segmentsH:uint (default = 1) — Defines the number of vertical segments that make up the cylinder. Defaults to 1.
topClosed:Boolean (default = true) — Defines whether the top end of the cylinder is closed (true) or open.
bottomClosed:Boolean (default = true) — Defines whether the bottom end of the cylinder is closed (true) or open.
surfaceClosed:Boolean (default = true) — Defines whether the cone poles should lay on the Y-axis (true) or on the Z-axis (false).
yUp:Boolean (default = true)
Method Detail
buildGeometry () method
override protected function buildGeometry(target:CompactSubGeometry):void

Builds the primitive's geometry when invalid. This method should not be called directly. The calling should be triggered by the invalidateGeometry method (and in turn by updateGeometry).

Parameters

target:CompactSubGeometry

buildUVs () method
override protected function buildUVs(target:CompactSubGeometry):void

Builds the primitive's uv coordinates when invalid. This method should not be called directly. The calling should be triggered by the invalidateUVs method (and in turn by updateUVs).

Parameters

target:CompactSubGeometry


away3d.primitives.LineSegment

LineSegment | Properties | Methods | Constants
Package | away3d.primitives
Class | public class LineSegment
Inheritance | LineSegment Inheritance Segment Inheritance Object

A Line Segment primitive.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | end : Vector3D Defines the ending vertex. | Segment
Inherited | endColor : uint Defines the endColor | Segment
Inherited | start : Vector3D Defines the starting vertex. | Segment
Inherited | startColor : uint Defines the startColor | Segment
Inherited | thickness : Number Defines the ending vertex. | Segment
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | LineSegment(v0:Vector3D, v1:Vector3D, color0:uint = 0x333333, color1:uint = 0x333333, thickness:Number = 1) Create a line segment | LineSegment
Inherited | updateSegment(start:Vector3D, end:Vector3D, anchor:Vector3D, colorStart:uint = 0x333333, colorEnd:uint = 0x333333, thickness:Number = 1):void | Segment
Public Constants
Constant |  | Defined By
 | TYPE : String = line | LineSegment
Constructor Detail
LineSegment () Constructor
public function LineSegment(v0:Vector3D, v1:Vector3D, color0:uint = 0x333333, color1:uint = 0x333333, thickness:Number = 1)

Create a line segment

Parameters
v0:Vector3D — Start position of the line segment
v1:Vector3D — Ending position of the line segment
color0:uint (default = 0x333333) — Starting color of the line segment
color1:uint (default = 0x333333) — Ending colour of the line segment
thickness:Number (default = 1) — Thickness of the line
Constant Detail
TYPE Constant
public const TYPE:String = line


away3d.primitives.NURBSGeometry

NURBSGeometry | Properties | Methods | Constants
Package | away3d.primitives
Class | public class NURBSGeometry
Inheritance | NURBSGeometry Inheritance PrimitiveBase Inheritance Geometry Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A NURBS primitive geometry.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | Geometry
 | controlNet : Vector.<NURBSVertex> Defines the control point net to describe the NURBS surface | NURBSGeometry
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | subGeometries : Vector.<ISubGeometry> [override] [read-only] A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc. | PrimitiveBase
 | uControlPoints : int Defines the number of control points along the U splines | NURBSGeometry
 | uKnot : Vector.<Number> Defines the knot sequence in the U direction that determines where and how the control points affect the NURBS curve. | NURBSGeometry
 | uOrder : int Defines the number of control points along the U splines that influence any given point on the curve | NURBSGeometry
 | uSegments : int Defines the number segments (triangle pair) the final curve will be divided into in the U direction | NURBSGeometry
 | vControlPoints : int Defines the number of control points along the V splines | NURBSGeometry
 | vKnot : Vector.<Number> Defines the knot sequence in the V direction that determines where and how the control points affect the NURBS curve. | NURBSGeometry
 | vOrder : int Defines the number of control points along the V splines that influence any given point on the curve | NURBSGeometry
 | vSegments : int Defines the number segments (triangle pair) the final curve will be divided into in the V direction | NURBSGeometry
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _geomDirty : Boolean = true | PrimitiveBase
Inherited | _uvDirty : Boolean = true | PrimitiveBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined By
NURBSGeometry(cNet:Vector.<NURBSVertex>, uCtrlPnts:int, vCtrlPnts:int, uOrder:int = 4, vOrder:int = 4, uSegments:int = 10, vSegments:int = 10, uKnot:Vector.<Number> = null, vKnot:Vector.<Number> = null)
NURBS primitive generates a segmented mesh that fits the curved surface defined by the specified control points based on weighting, order influence and knot sequence
NURBSGeometry
Inherited
addSubGeometry(subGeometry:ISubGeometry):void
Adds a new SubGeometry object to the list.
Geometry
Inherited
applyTransformation(transform:Matrix3D):void
[override]
PrimitiveBase
Inherited
assetPathEquals(name:String, ns:String):Boolean
NamedAssetBase
Inherited
clone():Geometry
[override] Clones the geometry.
PrimitiveBase
Inherited
convertToSeparateBuffers():void
Updates the SubGeometries so all vertex data is represented in different buffers.
Geometry
Inherited
dispose():void
Clears all resources used by the Geometry object, including SubGeometries.
Geometry
getSurfacePoint(uS:Number, vS:Number, vecOffset:Number = 0, scale:Number = 1, uTol:Number = 0.01, vTol:Number = 0.01):Vector3D
Return a 3d point representing the surface point at the required U(0-1) and V(0-1) across the NURBS curved surface.
NURBSGeometry
refreshNURBS():void
Refresh the mesh without reconstructing all the supporting data.
NURBSGeometry
Inherited
removeSubGeometry(subGeometry:ISubGeometry):void
Removes a new SubGeometry object from the list.
Geometry
Inherited
resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void
NamedAssetBase
Inherited
scale(scale:Number):void
[override] Scales the geometry.
PrimitiveBase
Inherited
scaleUV(scaleU:Number = 1, scaleV:Number = 1):void
[override] Scales the uv coordinates (tiling)
PrimitiveBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | buildGeometry(target:CompactSubGeometry):void [override] Rebuild the mesh as there is significant change to the structural parameters | NURBSGeometry
 | buildUVs(target:CompactSubGeometry):void [override] Rebuild the UV coordinates as there is significant change to the structural parameters | NURBSGeometry
Inherited | invalidateGeometry():void Invalidates the primitive's geometry, causing it to be updated when requested. | PrimitiveBase
Inherited | invalidateUVs():void Invalidates the primitive's uv coordinates, causing them to be updated when requested. | PrimitiveBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
controlNet property
controlNet:Vector.<NURBSVertex>

Defines the control point net to describe the NURBS surface

Implementation
    public function get controlNet():Vector.<NURBSVertex>
    public function set controlNet(value:Vector.<NURBSVertex>):void
uControlPoints property
uControlPoints:int

Defines the number of control points along the U splines

Implementation
    public function get uControlPoints():int
    public function set uControlPoints(value:int):void
uKnot property
uKnot:Vector.<Number>

Defines the knot sequence in the U direction that determines where and how the control points affect the NURBS curve.

Implementation
    public function get uKnot():Vector.<Number>
    public function set uKnot(value:Vector.<Number>):void
uOrder property
uOrder:int

Defines the number of control points along the U splines that influence any given point on the curve

Implementation
    public function get uOrder():int
    public function set uOrder(value:int):void
uSegments property
uSegments:int

Defines the number segments (triangle pair) the final curve will be divided into in the U direction

Implementation
    public function get uSegments():int
    public function set uSegments(value:int):void
vControlPoints property
vControlPoints:int

Defines the number of control points along the V splines

Implementation
    public function get vControlPoints():int
    public function set vControlPoints(value:int):void
vKnot property
vKnot:Vector.<Number>

Defines the knot sequence in the V direction that determines where and how the control points affect the NURBS curve.

Implementation
    public function get vKnot():Vector.<Number>
    public function set vKnot(value:Vector.<Number>):void
vOrder property
vOrder:int

Defines the number of control points along the V splines that influence any given point on the curve

Implementation
    public function get vOrder():int
    public function set vOrder(value:int):void
vSegments property
vSegments:int

Defines the number segments (triangle pair) the final curve will be divided into in the V direction

Implementation
    public function get vSegments():int
    public function set vSegments(value:int):void
Constructor Detail
NURBSGeometry () Constructor
public function NURBSGeometry(cNet:Vector.<NURBSVertex>, uCtrlPnts:int, vCtrlPnts:int, uOrder:int = 4, vOrder:int = 4, uSegments:int = 10, vSegments:int = 10, uKnot:Vector.<Number> = null, vKnot:Vector.<Number> = null)

NURBS primitive generates a segmented mesh that fits the curved surface defined by the specified control points based on weighting, order influence and knot sequence

Parameters
cNet:Vector.<NURBSVertex> — Array of control points (WeightedVertex array)
uCtrlPnts:int — Number of control points in the U direction
vCtrlPnts:int — Number of control points in the V direction
uOrder:int (default = 4) — Init object for the mesh
vOrder:int (default = 4)
uSegments:int (default = 10)
vSegments:int (default = 10)
uKnot:Vector.<Number> (default = null)
vKnot:Vector.<Number> (default = null)
Method Detail
buildGeometry () method
override protected function buildGeometry(target:CompactSubGeometry):void

Rebuild the mesh as there is significant change to the structural parameters

Parameters

target:CompactSubGeometry

buildUVs () method
override protected function buildUVs(target:CompactSubGeometry):void

Rebuild the UV coordinates as there is significant change to the structural parameters

Parameters

target:CompactSubGeometry

getSurfacePoint () method
public function getSurfacePoint(uS:Number, vS:Number, vecOffset:Number = 0, scale:Number = 1, uTol:Number = 0.01, vTol:Number = 0.01):Vector3D

Return a 3d point representing the surface point at the required U(0-1) and V(0-1) across the NURBS curved surface.

Parameters

uS:Number — U position on the surface
vS:Number — V position on the surface
vecOffset:Number (default = 0) — Offset the point on the surface by this vector
scale:Number (default = 1) — Scale of the surface point - should match the Mesh scaling
uTol:Number (default = 0.01) — U tolerance for adjacent surface sample to calculate normal
vTol:Number (default = 0.01) — V tolerance for adjacent surface sample to calculate normal

Returns
Vector3D — The offset surface point being returned
refreshNURBS () method
public function refreshNURBS():void

Refresh the mesh without reconstructing all the supporting data. This should be used only when the control point positions change.


away3d.primitives.PlaneGeometry

PlaneGeometry | Properties | Methods | Constants
Package | away3d.primitives
Class | public class PlaneGeometry
Inheritance | PlaneGeometry Inheritance PrimitiveBase Inheritance Geometry Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A Plane primitive mesh.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | Geometry
 | doubleSided : Boolean Defines whether the plane will be visible from both sides, with correct vertex normals (as opposed to bothSides on Material). | PlaneGeometry
 | height : Number The height of the plane. | PlaneGeometry
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | segmentsH : uint The number of segments that make up the plane along the Y or Z-axis, depending on whether yUp is true or false, respectively. | PlaneGeometry
 | segmentsW : uint The number of segments that make up the plane along the X-axis. | PlaneGeometry
Inherited | subGeometries : Vector.<ISubGeometry> [override] [read-only] A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc. | PrimitiveBase
 | width : Number The width of the plane. | PlaneGeometry
 | yUp : Boolean Defines whether the normal vector of the plane should point along the Y-axis (true) or Z-axis (false). | PlaneGeometry
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _geomDirty : Boolean = true | PrimitiveBase
Inherited | _uvDirty : Boolean = true | PrimitiveBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | PlaneGeometry(width:Number = 100, height:Number = 100, segmentsW:uint = 1, segmentsH:uint = 1, yUp:Boolean = true, doubleSided:Boolean = false) Creates a new Plane object. | PlaneGeometry
Inherited | addSubGeometry(subGeometry:ISubGeometry):void Adds a new SubGeometry object to the list. | Geometry
Inherited | applyTransformation(transform:Matrix3D):void [override] | PrimitiveBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Geometry [override] Clones the geometry. | PrimitiveBase
Inherited | convertToSeparateBuffers():void Updates the SubGeometries so all vertex data is represented in different buffers. | Geometry
Inherited | dispose():void Clears all resources used by the Geometry object, including SubGeometries. | Geometry
Inherited | removeSubGeometry(subGeometry:ISubGeometry):void Removes a new SubGeometry object from the list. | Geometry
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | scale(scale:Number):void [override] Scales the geometry. | PrimitiveBase
Inherited | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void [override] Scales the uv coordinates (tiling) | PrimitiveBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | buildGeometry(target:CompactSubGeometry):void [override] Builds the primitive's geometry when invalid. | PlaneGeometry
 | buildUVs(target:CompactSubGeometry):void [override] Builds the primitive's uv coordinates when invalid. | PlaneGeometry
Inherited | invalidateGeometry():void Invalidates the primitive's geometry, causing it to be updated when requested. | PrimitiveBase
Inherited | invalidateUVs():void Invalidates the primitive's uv coordinates, causing them to be updated when requested. | PrimitiveBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
doubleSided property
doubleSided:Boolean

Defines whether the plane will be visible from both sides, with correct vertex normals (as opposed to bothSides on Material). Defaults to false.

Implementation
    public function get doubleSided():Boolean
    public function set doubleSided(value:Boolean):void
height property
height:Number

The height of the plane.

Implementation
    public function get height():Number
    public function set height(value:Number):void
segmentsH property
segmentsH:uint

The number of segments that make up the plane along the Y or Z-axis, depending on whether yUp is true or false, respectively. Defaults to 1.

Implementation
    public function get segmentsH():uint
    public function set segmentsH(value:uint):void
segmentsW property
segmentsW:uint

The number of segments that make up the plane along the X-axis. Defaults to 1.

Implementation
    public function get segmentsW():uint
    public function set segmentsW(value:uint):void
width property
width:Number

The width of the plane.

Implementation
    public function get width():Number
    public function set width(value:Number):void
yUp property
yUp:Boolean

Defines whether the normal vector of the plane should point along the Y-axis (true) or Z-axis (false). Defaults to true.

Implementation
    public function get yUp():Boolean
    public function set yUp(value:Boolean):void
Constructor Detail
PlaneGeometry () Constructor
public function PlaneGeometry(width:Number = 100, height:Number = 100, segmentsW:uint = 1, segmentsH:uint = 1, yUp:Boolean = true, doubleSided:Boolean = false)

Creates a new Plane object.

Parameters
width:Number (default = 100) — The width of the plane.
height:Number (default = 100) — The height of the plane.
segmentsW:uint (default = 1) — The number of segments that make up the plane along the X-axis.
segmentsH:uint (default = 1) — The number of segments that make up the plane along the Y or Z-axis.
yUp:Boolean (default = true) — Defines whether the normal vector of the plane should point along the Y-axis (true) or Z-axis (false).
doubleSided:Boolean (default = false) — Defines whether the plane will be visible from both sides, with correct vertex normals.
Method Detail
buildGeometry () method
override protected function buildGeometry(target:CompactSubGeometry):void

Builds the primitive's geometry when invalid. This method should not be called directly. The calling should be triggered by the invalidateGeometry method (and in turn by updateGeometry).

Parameters

target:CompactSubGeometry

buildUVs () method
override protected function buildUVs(target:CompactSubGeometry):void

Builds the primitive's uv coordinates when invalid. This method should not be called directly. The calling should be triggered by the invalidateUVs method (and in turn by updateUVs).

Parameters

target:CompactSubGeometry


away3d.primitives.PrimitiveBase

PrimitiveBase | Properties | Methods | Constants
Package | away3d.primitives
Class | public class PrimitiveBase
Inheritance | PrimitiveBase Inheritance Geometry Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | CapsuleGeometry, CubeGeometry, CylinderGeometry, NURBSGeometry, PlaneGeometry, SphereGeometry, TorusGeometry

PrimitiveBase is an abstract base class for mesh primitives, which are prebuilt simple meshes.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | Geometry
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | subGeometries : Vector.<ISubGeometry> [override] [read-only] A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc. | PrimitiveBase
Protected Properties
Property |  | Defined By
 | _geomDirty : Boolean = true | PrimitiveBase
 | _uvDirty : Boolean = true | PrimitiveBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | PrimitiveBase() Creates a new PrimitiveBase object. | PrimitiveBase
Inherited | addSubGeometry(subGeometry:ISubGeometry):void Adds a new SubGeometry object to the list. | Geometry
 | applyTransformation(transform:Matrix3D):void [override] | PrimitiveBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | clone():Geometry [override] Clones the geometry. | PrimitiveBase
Inherited | convertToSeparateBuffers():void Updates the SubGeometries so all vertex data is represented in different buffers. | Geometry
Inherited | dispose():void Clears all resources used by the Geometry object, including SubGeometries. | Geometry
Inherited | removeSubGeometry(subGeometry:ISubGeometry):void Removes a new SubGeometry object from the list. | Geometry
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
 | scale(scale:Number):void [override] Scales the geometry. | PrimitiveBase
 | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void [override] Scales the uv coordinates (tiling) | PrimitiveBase
Protected Methods
Method |  | Defined By
 | buildGeometry(target:CompactSubGeometry):void Builds the primitive's geometry when invalid. | PrimitiveBase
 | buildUVs(target:CompactSubGeometry):void Builds the primitive's uv coordinates when invalid. | PrimitiveBase
 | invalidateGeometry():void Invalidates the primitive's geometry, causing it to be updated when requested. | PrimitiveBase
 | invalidateUVs():void Invalidates the primitive's uv coordinates, causing them to be updated when requested. | PrimitiveBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_geomDirty property
protected var _geomDirty:Boolean = true

_uvDirty property
protected var _uvDirty:Boolean = true

subGeometries property
subGeometries:Vector.<ISubGeometry> [read-only] [override]

A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc.

Implementation
    public function get subGeometries():Vector.<ISubGeometry>
Constructor Detail
PrimitiveBase () Constructor
public function PrimitiveBase()

Creates a new PrimitiveBase object.

Method Detail
applyTransformation () method
override public function applyTransformation(transform:Matrix3D):void

Parameters

transform:Matrix3D

buildGeometry () method
protected function buildGeometry(target:CompactSubGeometry):void

Builds the primitive's geometry when invalid. This method should not be called directly. The calling should be triggered by the invalidateGeometry method (and in turn by updateGeometry).

Parameters

target:CompactSubGeometry

buildUVs () method
protected function buildUVs(target:CompactSubGeometry):void

Builds the primitive's uv coordinates when invalid. This method should not be called directly. The calling should be triggered by the invalidateUVs method (and in turn by updateUVs).

Parameters

target:CompactSubGeometry

clone () method
override public function clone():Geometry

Clones the geometry.

Returns
Geometry — An exact duplicate of the current Geometry object.
invalidateGeometry () method
protected function invalidateGeometry():void

Invalidates the primitive's geometry, causing it to be updated when requested.

invalidateUVs () method
protected function invalidateUVs():void

Invalidates the primitive's uv coordinates, causing them to be updated when requested.

scale () method
override public function scale(scale:Number):void

Scales the geometry.

Parameters

scale:Number — The amount by which to scale.

scaleUV () method
override public function scaleUV(scaleU:Number = 1, scaleV:Number = 1):void

Scales the uv coordinates (tiling)

Parameters

scaleU:Number (default = 1) — The amount by which to scale on the u axis. Default is 1;
scaleV:Number (default = 1) — The amount by which to scale on the v axis. Default is 1;

validate () method
override arcane function validate():void


away3d.primitives.RegularPolygonGeometry

RegularPolygonGeometry | Properties | Methods | Constants
Package | away3d.primitives
Class | public class RegularPolygonGeometry
Inheritance | RegularPolygonGeometry Inheritance CylinderGeometry Inheritance PrimitiveBase Inheritance Geometry Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A UV RegularPolygon primitive mesh.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | Geometry
Inherited | bottomClosed : Boolean Defines whether the bottom end of the cylinder is closed (true) or open. | CylinderGeometry
Inherited | bottomRadius : Number The radius of the bottom end of the cylinder. | CylinderGeometry
Inherited | height : Number The radius of the top end of the cylinder. | CylinderGeometry
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | radius : Number The radius of the regular polygon. | RegularPolygonGeometry
Inherited | segmentsH : uint Defines the number of vertical segments that make up the cylinder. | CylinderGeometry
Inherited | segmentsW : uint Defines the number of horizontal segments that make up the cylinder. | CylinderGeometry
 | sides : uint The number of sides of the regular polygon. | RegularPolygonGeometry
 | subdivisions : uint The number of subdivisions from the edge to the center of the regular polygon. | RegularPolygonGeometry
Inherited | subGeometries : Vector.<ISubGeometry> [override] [read-only] A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc. | PrimitiveBase
Inherited | topClosed : Boolean Defines whether the top end of the cylinder is closed (true) or open. | CylinderGeometry
Inherited | topRadius : Number The radius of the top end of the cylinder. | CylinderGeometry
Inherited | yUp : Boolean Defines whether the cylinder poles should lay on the Y-axis (true) or on the Z-axis (false). | CylinderGeometry
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bottomClosed : Boolean | CylinderGeometry
Inherited | _bottomRadius : Number | CylinderGeometry
Inherited | _geomDirty : Boolean = true | PrimitiveBase
Inherited | _height : Number | CylinderGeometry
Inherited | _segmentsH : uint | CylinderGeometry
Inherited | _segmentsW : uint | CylinderGeometry
Inherited | _surfaceClosed : Boolean | CylinderGeometry
Inherited | _topClosed : Boolean | CylinderGeometry
Inherited | _topRadius : Number | CylinderGeometry
Inherited | _uvDirty : Boolean = true | PrimitiveBase
Inherited | _yUp : Boolean | CylinderGeometry
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | RegularPolygonGeometry(radius:Number = 100, sides:uint = 16, yUp:Boolean = true) Creates a new RegularPolygon disc object. | RegularPolygonGeometry
Inherited | addSubGeometry(subGeometry:ISubGeometry):void Adds a new SubGeometry object to the list. | Geometry
Inherited | applyTransformation(transform:Matrix3D):void [override] | PrimitiveBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Geometry [override] Clones the geometry. | PrimitiveBase
Inherited | convertToSeparateBuffers():void Updates the SubGeometries so all vertex data is represented in different buffers. | Geometry
Inherited | dispose():void Clears all resources used by the Geometry object, including SubGeometries. | Geometry
Inherited | removeSubGeometry(subGeometry:ISubGeometry):void Removes a new SubGeometry object from the list. | Geometry
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | scale(scale:Number):void [override] Scales the geometry. | PrimitiveBase
Inherited | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void [override] Scales the uv coordinates (tiling) | PrimitiveBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | buildGeometry(target:CompactSubGeometry):void [override] Builds the primitive's geometry when invalid. | CylinderGeometry
Inherited | buildUVs(target:CompactSubGeometry):void [override] Builds the primitive's uv coordinates when invalid. | CylinderGeometry
Inherited | invalidateGeometry():void Invalidates the primitive's geometry, causing it to be updated when requested. | PrimitiveBase
Inherited | invalidateUVs():void Invalidates the primitive's uv coordinates, causing them to be updated when requested. | PrimitiveBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
radius property
radius:Number

The radius of the regular polygon.

Implementation
    public function get radius():Number
    public function set radius(value:Number):void
sides property
sides:uint

The number of sides of the regular polygon.

Implementation
    public function get sides():uint
    public function set sides(value:uint):void
subdivisions property
subdivisions:uint

The number of subdivisions from the edge to the center of the regular polygon.

Implementation
    public function get subdivisions():uint
    public function set subdivisions(value:uint):void
Constructor Detail
RegularPolygonGeometry () Constructor
public function RegularPolygonGeometry(radius:Number = 100, sides:uint = 16, yUp:Boolean = true)

Creates a new RegularPolygon disc object.

Parameters
radius:Number (default = 100) — The radius of the regular polygon
sides:uint (default = 16) — Defines the number of sides of the regular polygon.
yUp:Boolean (default = true) — Defines whether the regular polygon should lay on the Y-axis (true) or on the Z-axis (false).


away3d.primitives.SkyBox

SkyBox | Properties | Methods | Events | Constants
Package | away3d.primitives
Class | public class SkyBox
Inheritance | SkyBox Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IRenderable

A SkyBox class is used to render a sky in the scene. It's always considered static and 'at infinity', and as such it's always centered at the camera's position and sized to exactly fit within the camera's frustum, ensuring the sky box is always as large as possible without being clipped.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | animator : IAnimator [read-only] | SkyBox
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Entity
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
 | castsShadows : Boolean [read-only] | SkyBox
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean [override] | Entity
 | indexData : Vector.<uint> [read-only] | SkyBox
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
 | material : MaterialBase The material with which to render the object. | SkyBox
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
 | numTriangles : uint [read-only] The amount of triangles that comprise the SkyBox geometry. | SkyBox
 | numVertices : uint [read-only] | SkyBox
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
 | sourceEntity : Entity [read-only] The entity that that initially provided the IRenderable to the render pipeline. | SkyBox
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
 | UVData : Vector.<Number> [read-only] | SkyBox
 | uvTransform : Matrix [read-only] | SkyBox
 | vertexData : Vector.<Number> [read-only] | SkyBox
 | vertexNormalData : Vector.<Number> [read-only] | SkyBox
 | vertexNormalOffset : int [read-only] | SkyBox
 | vertexOffset : int [read-only] | SkyBox
 | vertexStride : uint [read-only] | SkyBox
 | vertexTangentData : Vector.<Number> [read-only] | SkyBox
 | vertexTangentOffset : int [read-only] | SkyBox
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | zIndex : Number [override] [read-only] The distance of the IRenderable object to the view, used to sort per object. | SkyBox
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SkyBox(cubeMap:CubeTextureBase) Create a new SkyBox object. | SkyBox
 | activateCustomBuffer(index:int, stage3DProxy:Stage3DProxy):void | SkyBox
 | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SkyBox
 | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for UV coordinates | SkyBox
 | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for vertex positions. | SkyBox
 | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for vertex normals | SkyBox
 | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void Assigns the attribute stream for vertex tangents | SkyBox
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | ObjectContainer3D
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
 | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D Retrieves the IndexBuffer3D object that contains triangle indices. | SkyBox
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
 | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void [override] Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | SkyBox
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createEntityPartitionNode():EntityNode [override] Factory method that returns the current partition node. | SkyBox
Inherited | getDefaultBoundingVolume():BoundingVolumeBase Creates the default bounding box to be used by this type of Entity. | Entity
 | invalidateBounds():void [override] Invalidates the bounding volume, causing to be updated when requested. | SkyBox
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
 | updateBounds():void [override] Updates the bounding volume for the object. | SkyBox
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
animator property
animator:IAnimator [read-only]

Implementation
    public function get animator():IAnimator
castsShadows property
castsShadows:Boolean [read-only]

Implementation
    public function get castsShadows():Boolean
indexData property
indexData:Vector.<uint> [read-only]

Implementation
    public function get indexData():Vector.<uint>
material property
material:MaterialBase

The material with which to render the object.

Implementation
    public function get material():MaterialBase
    public function set material(value:MaterialBase):void
numTriangles property
numTriangles:uint [read-only]

The amount of triangles that comprise the SkyBox geometry.

Implementation
    public function get numTriangles():uint
numVertices property
numVertices:uint [read-only]

Implementation
    public function get numVertices():uint
sourceEntity property
sourceEntity:Entity [read-only]

The entity that that initially provided the IRenderable to the render pipeline.

Implementation
    public function get sourceEntity():Entity
UVData property
UVData:Vector.<Number> [read-only]

Implementation
    public function get UVData():Vector.<Number>
uvTransform property
uvTransform:Matrix [read-only]

Implementation
    public function get uvTransform():Matrix
vertexData property
vertexData:Vector.<Number> [read-only]

Implementation
    public function get vertexData():Vector.<Number>
vertexNormalData property
vertexNormalData:Vector.<Number> [read-only]

Implementation
    public function get vertexNormalData():Vector.<Number>
vertexNormalOffset property
vertexNormalOffset:int [read-only]

Implementation
    public function get vertexNormalOffset():int
vertexOffset property
vertexOffset:int [read-only]

Implementation
    public function get vertexOffset():int
vertexStride property
vertexStride:uint [read-only]

Implementation
    public function get vertexStride():uint
vertexTangentData property
vertexTangentData:Vector.<Number> [read-only]

Implementation
    public function get vertexTangentData():Vector.<Number>
vertexTangentOffset property
vertexTangentOffset:int [read-only]

Implementation
    public function get vertexTangentOffset():int
zIndex property
zIndex:Number [read-only] [override]

The distance of the IRenderable object to the view, used to sort per object.

Implementation
    public function get zIndex():Number
Constructor Detail
SkyBox () Constructor
public function SkyBox(cubeMap:CubeTextureBase)

Create a new SkyBox object.

Parameters
cubeMap:CubeTextureBase — The CubeMap to use for the sky box's texture.
Method Detail
activateCustomBuffer () method
public function activateCustomBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateSecondaryUVBuffer () method
public function activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Parameters

index:int
stage3DProxy:Stage3DProxy

activateUVBuffer () method
public function activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for UV coordinates

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexBuffer () method
public function activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for vertex positions.

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexNormalBuffer () method
public function activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for vertex normals

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

activateVertexTangentBuffer () method
public function activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void

Assigns the attribute stream for vertex tangents

Parameters

index:int — The attribute stream index for the vertex shader
stage3DProxy:Stage3DProxy — The Stage3DProxy to assign the stream to

createEntityPartitionNode () method
override protected function createEntityPartitionNode():EntityNode

Factory method that returns the current partition node. Needs to be overridden by concrete subclasses such as Mesh to return the correct concrete subtype of EntityPartition3DNode (for Mesh = MeshPartition3DNode, most IRenderables (particles fe) would return RenderablePartition3DNode, I suppose)

Returns
EntityNode
getIndexBuffer () method
public function getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D

Retrieves the IndexBuffer3D object that contains triangle indices.

Parameters

stage3DProxy:Stage3DProxy — The Context3D for which we request the buffer

Returns
IndexBuffer3D — The VertexBuffer3D object that contains triangle indices.
invalidateBounds () method
override protected function invalidateBounds():void

Invalidates the bounding volume, causing to be updated when requested.

pushModelViewProjection () method
override public function pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void

Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. The stack allows nested rendering while keeping the MVP intact.

Parameters

camera:Camera3D — The camera which will perform the view transformation and projection.
updateZIndex:Boolean (default = true)

updateBounds () method
override protected function updateBounds():void

Updates the bounding volume for the object. Overriding methods need to set invalid flag to false!


away3d.primitives.SphereGeometry

SphereGeometry | Properties | Methods | Constants
Package | away3d.primitives
Class | public class SphereGeometry
Inheritance | SphereGeometry Inheritance PrimitiveBase Inheritance Geometry Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A UV Sphere primitive mesh.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | Geometry
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | radius : Number The radius of the sphere. | SphereGeometry
 | segmentsH : uint Defines the number of vertical segments that make up the sphere. | SphereGeometry
 | segmentsW : uint Defines the number of horizontal segments that make up the sphere. | SphereGeometry
Inherited | subGeometries : Vector.<ISubGeometry> [override] [read-only] A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc. | PrimitiveBase
 | yUp : Boolean Defines whether the sphere poles should lay on the Y-axis (true) or on the Z-axis (false). | SphereGeometry
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _geomDirty : Boolean = true | PrimitiveBase
Inherited | _uvDirty : Boolean = true | PrimitiveBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SphereGeometry(radius:Number = 50, segmentsW:uint = 16, segmentsH:uint = 12, yUp:Boolean = true) Creates a new Sphere object. | SphereGeometry
Inherited | addSubGeometry(subGeometry:ISubGeometry):void Adds a new SubGeometry object to the list. | Geometry
Inherited | applyTransformation(transform:Matrix3D):void [override] | PrimitiveBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Geometry [override] Clones the geometry. | PrimitiveBase
Inherited | convertToSeparateBuffers():void Updates the SubGeometries so all vertex data is represented in different buffers. | Geometry
Inherited | dispose():void Clears all resources used by the Geometry object, including SubGeometries. | Geometry
Inherited | removeSubGeometry(subGeometry:ISubGeometry):void Removes a new SubGeometry object from the list. | Geometry
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | scale(scale:Number):void [override] Scales the geometry. | PrimitiveBase
Inherited | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void [override] Scales the uv coordinates (tiling) | PrimitiveBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | buildGeometry(target:CompactSubGeometry):void [override] Builds the primitive's geometry when invalid. | SphereGeometry
 | buildUVs(target:CompactSubGeometry):void [override] Builds the primitive's uv coordinates when invalid. | SphereGeometry
Inherited | invalidateGeometry():void Invalidates the primitive's geometry, causing it to be updated when requested. | PrimitiveBase
Inherited | invalidateUVs():void Invalidates the primitive's uv coordinates, causing them to be updated when requested. | PrimitiveBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
radius property
radius:Number

The radius of the sphere.

Implementation
    public function get radius():Number
    public function set radius(value:Number):void
segmentsH property
segmentsH:uint

Defines the number of vertical segments that make up the sphere. Defaults to 12.

Implementation
    public function get segmentsH():uint
    public function set segmentsH(value:uint):void
segmentsW property
segmentsW:uint

Defines the number of horizontal segments that make up the sphere. Defaults to 16.

Implementation
    public function get segmentsW():uint
    public function set segmentsW(value:uint):void
yUp property
yUp:Boolean

Defines whether the sphere poles should lay on the Y-axis (true) or on the Z-axis (false).

Implementation
    public function get yUp():Boolean
    public function set yUp(value:Boolean):void
Constructor Detail
SphereGeometry () Constructor
public function SphereGeometry(radius:Number = 50, segmentsW:uint = 16, segmentsH:uint = 12, yUp:Boolean = true)

Creates a new Sphere object.

Parameters
radius:Number (default = 50) — The radius of the sphere.
segmentsW:uint (default = 16) — Defines the number of horizontal segments that make up the sphere.
segmentsH:uint (default = 12) — Defines the number of vertical segments that make up the sphere.
yUp:Boolean (default = true) — Defines whether the sphere poles should lay on the Y-axis (true) or on the Z-axis (false).
Method Detail
buildGeometry () method
override protected function buildGeometry(target:CompactSubGeometry):void

Builds the primitive's geometry when invalid. This method should not be called directly. The calling should be triggered by the invalidateGeometry method (and in turn by updateGeometry).

Parameters

target:CompactSubGeometry

buildUVs () method
override protected function buildUVs(target:CompactSubGeometry):void

Builds the primitive's uv coordinates when invalid. This method should not be called directly. The calling should be triggered by the invalidateUVs method (and in turn by updateUVs).

Parameters

target:CompactSubGeometry


away3d.primitives.TorusGeometry

TorusGeometry | Properties | Methods | Constants
Package | away3d.primitives
Class | public class TorusGeometry
Inheritance | TorusGeometry Inheritance PrimitiveBase Inheritance Geometry Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A UV Cylinder primitive mesh.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | Geometry
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | radius : Number The radius of the torus. | TorusGeometry
 | segmentsR : uint Defines the number of horizontal segments that make up the torus. | TorusGeometry
 | segmentsT : uint Defines the number of vertical segments that make up the torus. | TorusGeometry
Inherited | subGeometries : Vector.<ISubGeometry> [override] [read-only] A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc. | PrimitiveBase
 | tubeRadius : Number The radius of the inner tube of the torus. | TorusGeometry
 | yUp : Boolean Defines whether the torus poles should lay on the Y-axis (true) or on the Z-axis (false). | TorusGeometry
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _geomDirty : Boolean = true | PrimitiveBase
 | _radius : Number | TorusGeometry
 | _segmentsR : uint | TorusGeometry
 | _segmentsT : uint | TorusGeometry
 | _tubeRadius : Number | TorusGeometry
Inherited | _uvDirty : Boolean = true | PrimitiveBase
 | _yUp : Boolean | TorusGeometry
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | TorusGeometry(radius:Number = 50, tubeRadius:Number = 50, segmentsR:uint = 16, segmentsT:uint = 8, yUp:Boolean = true) Creates a new Torus object. | TorusGeometry
Inherited | addSubGeometry(subGeometry:ISubGeometry):void Adds a new SubGeometry object to the list. | Geometry
Inherited | applyTransformation(transform:Matrix3D):void [override] | PrimitiveBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Geometry [override] Clones the geometry. | PrimitiveBase
Inherited | convertToSeparateBuffers():void Updates the SubGeometries so all vertex data is represented in different buffers. | Geometry
Inherited | dispose():void Clears all resources used by the Geometry object, including SubGeometries. | Geometry
Inherited | removeSubGeometry(subGeometry:ISubGeometry):void Removes a new SubGeometry object from the list. | Geometry
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | scale(scale:Number):void [override] Scales the geometry. | PrimitiveBase
Inherited | scaleUV(scaleU:Number = 1, scaleV:Number = 1):void [override] Scales the uv coordinates (tiling) | PrimitiveBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | buildGeometry(target:CompactSubGeometry):void [override] Builds the primitive's geometry when invalid. | TorusGeometry
 | buildUVs(target:CompactSubGeometry):void [override] Builds the primitive's uv coordinates when invalid. | TorusGeometry
Inherited | invalidateGeometry():void Invalidates the primitive's geometry, causing it to be updated when requested. | PrimitiveBase
Inherited | invalidateUVs():void Invalidates the primitive's uv coordinates, causing them to be updated when requested. | PrimitiveBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_radius property
protected var _radius:Number

_segmentsR property
protected var _segmentsR:uint

_segmentsT property
protected var _segmentsT:uint

_tubeRadius property
protected var _tubeRadius:Number

_yUp property
protected var _yUp:Boolean

radius property
radius:Number

The radius of the torus.

Implementation
    public function get radius():Number
    public function set radius(value:Number):void
segmentsR property
segmentsR:uint

Defines the number of horizontal segments that make up the torus. Defaults to 16.

Implementation
    public function get segmentsR():uint
    public function set segmentsR(value:uint):void
segmentsT property
segmentsT:uint

Defines the number of vertical segments that make up the torus. Defaults to 8.

Implementation
    public function get segmentsT():uint
    public function set segmentsT(value:uint):void
tubeRadius property
tubeRadius:Number

The radius of the inner tube of the torus.

Implementation
    public function get tubeRadius():Number
    public function set tubeRadius(value:Number):void
yUp property
yUp:Boolean

Defines whether the torus poles should lay on the Y-axis (true) or on the Z-axis (false).

Implementation
    public function get yUp():Boolean
    public function set yUp(value:Boolean):void
Constructor Detail
TorusGeometry () Constructor
public function TorusGeometry(radius:Number = 50, tubeRadius:Number = 50, segmentsR:uint = 16, segmentsT:uint = 8, yUp:Boolean = true)

Creates a new Torus object.

Parameters
radius:Number (default = 50) — The radius of the torus.
tubeRadius:Number (default = 50) — The radius of the inner tube of the torus.
segmentsR:uint (default = 16) — Defines the number of horizontal segments that make up the torus.
segmentsT:uint (default = 8) — Defines the number of vertical segments that make up the torus.
yUp:Boolean (default = true) — Defines whether the torus poles should lay on the Y-axis (true) or on the Z-axis (false).
Method Detail
buildGeometry () method
override protected function buildGeometry(target:CompactSubGeometry):void

Builds the primitive's geometry when invalid. This method should not be called directly. The calling should be triggered by the invalidateGeometry method (and in turn by updateGeometry).

Parameters

target:CompactSubGeometry

buildUVs () method
override protected function buildUVs(target:CompactSubGeometry):void

Builds the primitive's uv coordinates when invalid. This method should not be called directly. The calling should be triggered by the invalidateUVs method (and in turn by updateUVs).

Parameters

target:CompactSubGeometry


away3d.primitives.WireframeCube

WireframeCube | Properties | Methods | Events | Constants
Package | away3d.primitives
Class | public class WireframeCube
Inheritance | WireframeCube Inheritance WireframePrimitiveBase Inheritance SegmentSet Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A WirefameCube primitive mesh.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator [read-only] | SegmentSet
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | SegmentSet
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase [override] | WireframePrimitiveBase
Inherited | castsShadows : Boolean [read-only] | SegmentSet
Inherited | color : uint | WireframePrimitiveBase
 | depth : Number The size of the cube along its Z-axis. | WireframeCube
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
 | height : Number The size of the cube along its Y-axis. | WireframeCube
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | indexData : Vector.<uint> [read-only] | SegmentSet
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase | SegmentSet
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean [override] | SegmentSet
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | numTriangles : uint [read-only] | SegmentSet
Inherited | numVertices : uint [read-only] | SegmentSet
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | sourceEntity : Entity [read-only] | SegmentSet
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | thickness : Number | WireframePrimitiveBase
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | UVData : Vector.<Number> [read-only] | SegmentSet
Inherited | uvTransform : Matrix [read-only] | SegmentSet
Inherited | vertexData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalOffset : int [read-only] | SegmentSet
Inherited | vertexOffset : int [read-only] | SegmentSet
Inherited | vertexStride : uint [read-only] | SegmentSet
Inherited | vertexTangentData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexTangentOffset : int [read-only] | SegmentSet
Inherited | visible : Boolean | ObjectContainer3D
 | width : Number The size of the cube along its X-axis. | WireframeCube
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _segments : Vector.<Segment> | SegmentSet
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | WireframeCube(width:Number = 100, height:Number = 100, depth:Number = 100, color:uint = 0xFFFFFF, thickness:Number = 1) Creates a new WireframeCube object. | WireframeCube
Inherited | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | addSegment(segment:Segment):void | SegmentSet
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] | SegmentSet
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D | SegmentSet
Inherited | getSegment(index:uint):Segment | SegmentSet
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void [override] | WireframePrimitiveBase
Inherited | removeAllSegments():void [override] | WireframePrimitiveBase
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | removeSegment(segment:Segment):void | SegmentSet
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | buildGeometry():void [override] | WireframeCube
Inherited | createEntityPartitionNode():EntityNode [override] | SegmentSet
Inherited | getDefaultBoundingVolume():BoundingVolumeBase [override] | SegmentSet
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateGeometry():void | WireframePrimitiveBase
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] | SegmentSet
Inherited | updateMouseChildren():void [override] | WireframePrimitiveBase
Inherited | updateOrAddSegment(index:uint, v0:Vector3D, v1:Vector3D):void | WireframePrimitiveBase
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
depth property
depth:Number

The size of the cube along its Z-axis.

Implementation
    public function get depth():Number
    public function set depth(value:Number):void
height property
height:Number

The size of the cube along its Y-axis.

Implementation
    public function get height():Number
    public function set height(value:Number):void
width property
width:Number

The size of the cube along its X-axis.

Implementation
    public function get width():Number
    public function set width(value:Number):void
Constructor Detail
WireframeCube () Constructor
public function WireframeCube(width:Number = 100, height:Number = 100, depth:Number = 100, color:uint = 0xFFFFFF, thickness:Number = 1)

Creates a new WireframeCube object.

Parameters
width:Number (default = 100) — The size of the cube along its X-axis.
height:Number (default = 100) — The size of the cube along its Y-axis.
depth:Number (default = 100) — The size of the cube along its Z-axis.
color:uint (default = 0xFFFFFF) — The colour of the wireframe lines
thickness:Number (default = 1) — The thickness of the wireframe lines
Method Detail
buildGeometry () method
override protected function buildGeometry():void


away3d.primitives.WireframeCylinder

WireframeCylinder | Properties | Methods | Events | Constants
Package | away3d.primitives
Class | public class WireframeCylinder
Inheritance | WireframeCylinder Inheritance WireframePrimitiveBase Inheritance SegmentSet Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Generates a wireframd cylinder primitive.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator [read-only] | SegmentSet
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | SegmentSet
Inherited | backVector : Vector3D [read-only] | Object3D
 | bottomRadius : Number Bottom radius of the cylinder | WireframeCylinder
Inherited | bounds : BoundingVolumeBase [override] | WireframePrimitiveBase
Inherited | castsShadows : Boolean [read-only] | SegmentSet
Inherited | color : uint | WireframePrimitiveBase
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
 | height : Number The height of the cylinder | WireframeCylinder
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | indexData : Vector.<uint> [read-only] | SegmentSet
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase | SegmentSet
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean [override] | SegmentSet
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | numTriangles : uint [read-only] | SegmentSet
Inherited | numVertices : uint [read-only] | SegmentSet
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | sourceEntity : Entity [read-only] | SegmentSet
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | thickness : Number | WireframePrimitiveBase
 | topRadius : Number Top radius of the cylinder | WireframeCylinder
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | UVData : Vector.<Number> [read-only] | SegmentSet
Inherited | uvTransform : Matrix [read-only] | SegmentSet
Inherited | vertexData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalOffset : int [read-only] | SegmentSet
Inherited | vertexOffset : int [read-only] | SegmentSet
Inherited | vertexStride : uint [read-only] | SegmentSet
Inherited | vertexTangentData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexTangentOffset : int [read-only] | SegmentSet
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _segments : Vector.<Segment> | SegmentSet
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | WireframeCylinder(topRadius:Number = 50, bottomRadius:Number = 50, height:Number = 100, segmentsW:uint = 16, segmentsH:uint = 1, color:uint = 0xFFFFFF, thickness:Number = 1) Creates a new WireframeCylinder instance | WireframeCylinder
Inherited | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | addSegment(segment:Segment):void | SegmentSet
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] | SegmentSet
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D | SegmentSet
Inherited | getSegment(index:uint):Segment | SegmentSet
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void [override] | WireframePrimitiveBase
Inherited | removeAllSegments():void [override] | WireframePrimitiveBase
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | removeSegment(segment:Segment):void | SegmentSet
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | buildGeometry():void [override] | WireframeCylinder
Inherited | createEntityPartitionNode():EntityNode [override] | SegmentSet
Inherited | getDefaultBoundingVolume():BoundingVolumeBase [override] | SegmentSet
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateGeometry():void | WireframePrimitiveBase
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] | SegmentSet
Inherited | updateMouseChildren():void [override] | WireframePrimitiveBase
Inherited | updateOrAddSegment(index:uint, v0:Vector3D, v1:Vector3D):void | WireframePrimitiveBase
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
bottomRadius property
bottomRadius:Number

Bottom radius of the cylinder

Implementation
    public function get bottomRadius():Number
    public function set bottomRadius(value:Number):void
height property
height:Number

The height of the cylinder

Implementation
    public function get height():Number
    public function set height(value:Number):void
topRadius property
topRadius:Number

Top radius of the cylinder

Implementation
    public function get topRadius():Number
    public function set topRadius(value:Number):void
Constructor Detail
WireframeCylinder () Constructor
public function WireframeCylinder(topRadius:Number = 50, bottomRadius:Number = 50, height:Number = 100, segmentsW:uint = 16, segmentsH:uint = 1, color:uint = 0xFFFFFF, thickness:Number = 1)

Creates a new WireframeCylinder instance

Parameters
topRadius:Number (default = 50) — Top radius of the cylinder
bottomRadius:Number (default = 50) — Bottom radius of the cylinder
height:Number (default = 100) — The height of the cylinder
segmentsW:uint (default = 16) — Number of radial segments
segmentsH:uint (default = 1) — Number of vertical segments
color:uint (default = 0xFFFFFF) — The color of the wireframe lines
thickness:Number (default = 1) — The thickness of the wireframe lines
Method Detail
buildGeometry () method
override protected function buildGeometry():void


away3d.primitives.WireframePlane

WireframePlane | Properties | Methods | Events | Constants
Package | away3d.primitives
Class | public class WireframePlane
Inheritance | WireframePlane Inheritance WireframePrimitiveBase Inheritance SegmentSet Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A WireframePlane primitive mesh.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator [read-only] | SegmentSet
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | SegmentSet
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase [override] | WireframePrimitiveBase
Inherited | castsShadows : Boolean [read-only] | SegmentSet
Inherited | color : uint | WireframePrimitiveBase
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
 | height : Number The size of the cube along its Y-axis. | WireframePlane
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | indexData : Vector.<uint> [read-only] | SegmentSet
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase | SegmentSet
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean [override] | SegmentSet
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | numTriangles : uint [read-only] | SegmentSet
Inherited | numVertices : uint [read-only] | SegmentSet
 | orientation : String The orientaion in which the plane lies. | WireframePlane
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
 | segmentsH : int The number of segments that make up the plane along the Y-axis. | WireframePlane
 | segmentsW : int The number of segments that make up the plane along the X-axis. | WireframePlane
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | sourceEntity : Entity [read-only] | SegmentSet
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | thickness : Number | WireframePrimitiveBase
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | UVData : Vector.<Number> [read-only] | SegmentSet
Inherited | uvTransform : Matrix [read-only] | SegmentSet
Inherited | vertexData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalOffset : int [read-only] | SegmentSet
Inherited | vertexOffset : int [read-only] | SegmentSet
Inherited | vertexStride : uint [read-only] | SegmentSet
Inherited | vertexTangentData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexTangentOffset : int [read-only] | SegmentSet
Inherited | visible : Boolean | ObjectContainer3D
 | width : Number The size of the cube along its X-axis. | WireframePlane
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _segments : Vector.<Segment> | SegmentSet
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | WireframePlane(width:Number, height:Number, segmentsW:int = 10, segmentsH:int = 10, color:uint = 0xFFFFFF, thickness:Number = 1, orientation:String = yz) Creates a new WireframePlane object. | WireframePlane
Inherited | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | addSegment(segment:Segment):void | SegmentSet
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] | SegmentSet
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D | SegmentSet
Inherited | getSegment(index:uint):Segment | SegmentSet
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void [override] | WireframePrimitiveBase
Inherited | removeAllSegments():void [override] | WireframePrimitiveBase
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | removeSegment(segment:Segment):void | SegmentSet
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | buildGeometry():void [override] | WireframePlane
Inherited | createEntityPartitionNode():EntityNode [override] | SegmentSet
Inherited | getDefaultBoundingVolume():BoundingVolumeBase [override] | SegmentSet
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateGeometry():void | WireframePrimitiveBase
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] | SegmentSet
Inherited | updateMouseChildren():void [override] | WireframePrimitiveBase
Inherited | updateOrAddSegment(index:uint, v0:Vector3D, v1:Vector3D):void | WireframePrimitiveBase
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
 | ORIENTATION_XY : String = xy [static] | WireframePlane
 | ORIENTATION_XZ : String = xz [static] | WireframePlane
 | ORIENTATION_YZ : String = yz [static] | WireframePlane
Property Detail
height property
height:Number

The size of the cube along its Y-axis.

Implementation
    public function get height():Number
    public function set height(value:Number):void
orientation property
orientation:String

The orientaion in which the plane lies.

Implementation
    public function get orientation():String
    public function set orientation(value:String):void
segmentsH property
segmentsH:int

The number of segments that make up the plane along the Y-axis.

Implementation
    public function get segmentsH():int
    public function set segmentsH(value:int):void
segmentsW property
segmentsW:int

The number of segments that make up the plane along the X-axis.

Implementation
    public function get segmentsW():int
    public function set segmentsW(value:int):void
width property
width:Number

The size of the cube along its X-axis.

Implementation
    public function get width():Number
    public function set width(value:Number):void
Constructor Detail
WireframePlane () Constructor
public function WireframePlane(width:Number, height:Number, segmentsW:int = 10, segmentsH:int = 10, color:uint = 0xFFFFFF, thickness:Number = 1, orientation:String = yz)

Creates a new WireframePlane object.

Parameters
width:Number — The size of the cube along its X-axis.
height:Number — The size of the cube along its Y-axis.
segmentsW:int (default = 10) — The number of segments that make up the cube along the X-axis.
segmentsH:int (default = 10) — The number of segments that make up the cube along the Y-axis.
color:uint (default = 0xFFFFFF) — The colour of the wireframe lines
thickness:Number (default = 1) — The thickness of the wireframe lines
orientation:String (default = yz) — The orientaion in which the plane lies.
Method Detail
buildGeometry () method
override protected function buildGeometry():void

Constant Detail
ORIENTATION_XY Constant
public static const ORIENTATION_XY:String = xy

ORIENTATION_XZ Constant
public static const ORIENTATION_XZ:String = xz

ORIENTATION_YZ Constant
public static const ORIENTATION_YZ:String = yz


away3d.primitives.WireframePrimitiveBase

WireframePrimitiveBase | Properties | Methods | Events | Constants
Package | away3d.primitives
Class | public class WireframePrimitiveBase
Inheritance | WireframePrimitiveBase Inheritance SegmentSet Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | WireframeCube, WireframeCylinder, WireframePlane, WireframeSphere

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator [read-only] | SegmentSet
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | SegmentSet
Inherited | backVector : Vector3D [read-only] | Object3D
 | bounds : BoundingVolumeBase [override] | WireframePrimitiveBase
Inherited | castsShadows : Boolean [read-only] | SegmentSet
 | color : uint | WireframePrimitiveBase
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | indexData : Vector.<uint> [read-only] | SegmentSet
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase | SegmentSet
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean [override] | SegmentSet
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | numTriangles : uint [read-only] | SegmentSet
Inherited | numVertices : uint [read-only] | SegmentSet
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | sourceEntity : Entity [read-only] | SegmentSet
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
 | thickness : Number | WireframePrimitiveBase
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | UVData : Vector.<Number> [read-only] | SegmentSet
Inherited | uvTransform : Matrix [read-only] | SegmentSet
Inherited | vertexData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalOffset : int [read-only] | SegmentSet
Inherited | vertexOffset : int [read-only] | SegmentSet
Inherited | vertexStride : uint [read-only] | SegmentSet
Inherited | vertexTangentData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexTangentOffset : int [read-only] | SegmentSet
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _segments : Vector.<Segment> | SegmentSet
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | WireframePrimitiveBase(color:uint = 0xffffff, thickness:Number = 1) | WireframePrimitiveBase
Inherited | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | addSegment(segment:Segment):void | SegmentSet
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] | SegmentSet
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D | SegmentSet
Inherited | getSegment(index:uint):Segment | SegmentSet
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
 | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void [override] | WireframePrimitiveBase
 | removeAllSegments():void [override] | WireframePrimitiveBase
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | removeSegment(segment:Segment):void | SegmentSet
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | buildGeometry():void | WireframePrimitiveBase
Inherited | createEntityPartitionNode():EntityNode [override] | SegmentSet
Inherited | getDefaultBoundingVolume():BoundingVolumeBase [override] | SegmentSet
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
 | invalidateGeometry():void | WireframePrimitiveBase
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] | SegmentSet
 | updateMouseChildren():void [override] | WireframePrimitiveBase
 | updateOrAddSegment(index:uint, v0:Vector3D, v1:Vector3D):void | WireframePrimitiveBase
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
bounds property
bounds:BoundingVolumeBase[override]

Implementation
    public function get bounds():BoundingVolumeBase
    public function set bounds(value:BoundingVolumeBase):void
color property
color:uint

Implementation
    public function get color():uint
    public function set color(value:uint):void
thickness property
thickness:Number

Implementation
    public function get thickness():Number
    public function set thickness(value:Number):void
Constructor Detail
WireframePrimitiveBase () Constructor
public function WireframePrimitiveBase(color:uint = 0xffffff, thickness:Number = 1)

Parameters
color:uint (default = 0xffffff)
thickness:Number (default = 1)
Method Detail
buildGeometry () method
protected function buildGeometry():void

invalidateGeometry () method
protected function invalidateGeometry():void

pushModelViewProjection () method
override public function pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void

Parameters

camera:Camera3D
updateZIndex:Boolean (default = true)

removeAllSegments () method
override public function removeAllSegments():void

updateMouseChildren () method
override protected function updateMouseChildren():void

updateOrAddSegment () method
protected function updateOrAddSegment(index:uint, v0:Vector3D, v1:Vector3D):void

Parameters

index:uint
v0:Vector3D
v1:Vector3D


away3d.primitives.WireframeSphere

WireframeSphere | Properties | Methods | Events | Constants
Package | away3d.primitives
Class | public class WireframeSphere
Inheritance | WireframeSphere Inheritance WireframePrimitiveBase Inheritance SegmentSet Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A WireframeSphere primitive mesh

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator [read-only] | SegmentSet
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | SegmentSet
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase [override] | WireframePrimitiveBase
Inherited | castsShadows : Boolean [read-only] | SegmentSet
Inherited | color : uint | WireframePrimitiveBase
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | indexData : Vector.<uint> [read-only] | SegmentSet
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase | SegmentSet
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean [override] | SegmentSet
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | numTriangles : uint [read-only] | SegmentSet
Inherited | numVertices : uint [read-only] | SegmentSet
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | sourceEntity : Entity [read-only] | SegmentSet
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | thickness : Number | WireframePrimitiveBase
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | UVData : Vector.<Number> [read-only] | SegmentSet
Inherited | uvTransform : Matrix [read-only] | SegmentSet
Inherited | vertexData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalOffset : int [read-only] | SegmentSet
Inherited | vertexOffset : int [read-only] | SegmentSet
Inherited | vertexStride : uint [read-only] | SegmentSet
Inherited | vertexTangentData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexTangentOffset : int [read-only] | SegmentSet
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _segments : Vector.<Segment> | SegmentSet
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | WireframeSphere(radius:Number = 50, segmentsW:uint = 16, segmentsH:uint = 12, color:uint = 0xFFFFFF, thickness:Number = 1) Creates a new WireframeSphere object. | WireframeSphere
Inherited | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | addSegment(segment:Segment):void | SegmentSet
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] | SegmentSet
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D | SegmentSet
Inherited | getSegment(index:uint):Segment | SegmentSet
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void [override] | WireframePrimitiveBase
Inherited | removeAllSegments():void [override] | WireframePrimitiveBase
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | removeSegment(segment:Segment):void | SegmentSet
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | buildGeometry():void [override] | WireframeSphere
Inherited | createEntityPartitionNode():EntityNode [override] | SegmentSet
Inherited | getDefaultBoundingVolume():BoundingVolumeBase [override] | SegmentSet
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateGeometry():void | WireframePrimitiveBase
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] | SegmentSet
Inherited | updateMouseChildren():void [override] | WireframePrimitiveBase
Inherited | updateOrAddSegment(index:uint, v0:Vector3D, v1:Vector3D):void | WireframePrimitiveBase
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
WireframeSphere () Constructor
public function WireframeSphere(radius:Number = 50, segmentsW:uint = 16, segmentsH:uint = 12, color:uint = 0xFFFFFF, thickness:Number = 1)

Creates a new WireframeSphere object.

Parameters
radius:Number (default = 50) — The radius of the sphere.
segmentsW:uint (default = 16) — Defines the number of horizontal segments that make up the sphere.
segmentsH:uint (default = 12) — Defines the number of vertical segments that make up the sphere.
color:uint (default = 0xFFFFFF) — The colour of the wireframe lines
thickness:Number (default = 1) — The thickness of the wireframe lines
Method Detail
buildGeometry () method
override protected function buildGeometry():void


away3d.primitives.data - Away3D Documentation

Package away3d.primitives.data

Classes
NURBSVertex
Segment


away3d.primitives.data Summary

away3d.primitives.data | Classes

Classes
Class | Description
NURBSVertex | A nurbvertex that simply extends vertex with a w weight property.
Segment |

Thu Nov 15 2012, 12:09 PM Z


away3d.primitives.data.NURBSVertex

NURBSVertex | Properties | Methods
Package | away3d.primitives.data
Class | public class NURBSVertex
Inheritance | NURBSVertex Inheritance Vertex Inheritance Object

A nurbvertex that simply extends vertex with a w weight property. Properties x, y, z and w represent a 3d point in space with nurb weighting.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | index : uint To define/store the index of value object | Vertex
 | w : Number | NURBSVertex
Inherited | x : Number To define/store the x value of the value object | Vertex
Inherited | y : Number To define/store the y value of the value object | Vertex
Inherited | z : Number To define/store the z value of the value object | Vertex
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | NURBSVertex(x:Number = 0, y:Number = 0, z:Number = 0, w:Number = 1) Creates a new Vertex object. | NURBSVertex
Inherited | clone():Vertex returns a new Vertex value Object | Vertex
Inherited | toString():String returns the value object as a string for trace/debug purpose | Vertex
Property Detail
w property
w:Number

Implementation
    public function get w():Number
    public function set w(value:Number):void
Constructor Detail
NURBSVertex () Constructor
public function NURBSVertex(x:Number = 0, y:Number = 0, z:Number = 0, w:Number = 1)

Creates a new Vertex object.

Parameters
x:Number (default = 0) — [optional] The local x position of the vertex. Defaults to 0.
y:Number (default = 0) — [optional] The local y position of the vertex. Defaults to 0.
z:Number (default = 0) — [optional] The local z position of the vertex. Defaults to 0.
w:Number (default = 1) — [optional] The local w weight of the vertex. Defaults to 1.


away3d.primitives.data.Segment

Segment | Properties | Methods
Package | away3d.primitives.data
Class | public class Segment
Inheritance | Segment Inheritance Object
Subclasses | LineSegment

Public Properties
Property |  | Defined By
 | end : Vector3D Defines the ending vertex. | Segment
 | endColor : uint Defines the endColor | Segment
 | start : Vector3D Defines the starting vertex. | Segment
 | startColor : uint Defines the startColor | Segment
 | thickness : Number Defines the ending vertex. | Segment
Public Methods
Method |  | Defined By
 | Segment(start:Vector3D, end:Vector3D, anchor:Vector3D, colorStart:uint = 0x333333, colorEnd:uint = 0x333333, thickness:Number = 1) | Segment
 | updateSegment(start:Vector3D, end:Vector3D, anchor:Vector3D, colorStart:uint = 0x333333, colorEnd:uint = 0x333333, thickness:Number = 1):void | Segment
Property Detail
_end property
arcane var _end:Vector3D

_endB property
arcane var _endB:Number

_endG property
arcane var _endG:Number

_endR property
arcane var _endR:Number

_segmentsBase property
arcane var _segmentsBase:SegmentSet

_start property
arcane var _start:Vector3D

_startB property
arcane var _startB:Number

_startG property
arcane var _startG:Number

_startR property
arcane var _startR:Number

_thickness property
arcane var _thickness:Number

end property
end:Vector3D

Defines the ending vertex.

Implementation
    public function get end():Vector3D
    public function set end(value:Vector3D):void
endColor property
endColor:uint

Defines the endColor

Implementation
    public function get endColor():uint
    public function set endColor(value:uint):void
index property
index:uint

Implementation
    arcane function get index():uint
    arcane function set index(value:uint):void
segmentsBase property
segmentsBase:SegmentSet [write-only]

Implementation
    arcane function set segmentsBase(value:SegmentSet):void
start property
start:Vector3D

Defines the starting vertex.

Implementation
    public function get start():Vector3D
    public function set start(value:Vector3D):void
startColor property
startColor:uint

Defines the startColor

Implementation
    public function get startColor():uint
    public function set startColor(value:uint):void
thickness property
thickness:Number

Defines the ending vertex.

Implementation
    public function get thickness():Number
    public function set thickness(value:Number):void
Constructor Detail
Segment () Constructor
public function Segment(start:Vector3D, end:Vector3D, anchor:Vector3D, colorStart:uint = 0x333333, colorEnd:uint = 0x333333, thickness:Number = 1)

Parameters
start:Vector3D
end:Vector3D
anchor:Vector3D
colorStart:uint (default = 0x333333)
colorEnd:uint (default = 0x333333)
thickness:Number (default = 1)
Method Detail
updateSegment () method
public function updateSegment(start:Vector3D, end:Vector3D, anchor:Vector3D, colorStart:uint = 0x333333, colorEnd:uint = 0x333333, thickness:Number = 1):void

Parameters

start:Vector3D
end:Vector3D
anchor:Vector3D
colorStart:uint (default = 0x333333)
colorEnd:uint (default = 0x333333)
thickness:Number (default = 1)


away3d.stereo - Away3D Documentation

Package away3d.stereo

Classes
StereoCamera3D
StereoRenderer
StereoView3D


away3d.stereo Summary

away3d.stereo | Classes

Classes
Class | Description
StereoCamera3D |
StereoRenderer |
StereoView3D |

Thu Nov 15 2012, 12:09 PM Z


away3d.stereo.StereoCamera3D

StereoCamera3D | Properties | Methods | Events | Constants
Package | away3d.stereo
Class | public class StereoCamera3D
Inheritance | StereoCamera3D Inheritance Camera3D Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | Entity
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | frustumPlanes : Vector.<Plane3D> [read-only] | Camera3D
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
 | leftCamera : Camera3D [read-only] | StereoCamera3D
Inherited | leftVector : Vector3D [read-only] | Object3D
 | lens : LensBase [override] | StereoCamera3D
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing. | ObjectContainer3D
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
 | rightCamera : Camera3D [read-only] | StereoCamera3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
 | stereoFocus : Number | StereoCamera3D
 | stereoOffset : Number | StereoCamera3D
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | viewProjection : Matrix3D [read-only] The view projection matrix of the camera. | Camera3D
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | StereoCamera3D(lens:LensBase = null) | StereoCamera3D
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
Inherited | dispose():void [override] Cleans up resources used by this asset. | ObjectContainer3D
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getRay(mX:Number, mY:Number, mZ:Number = 0):Vector3D Returns the ray in scene space from the camera to the point on the screen in normalized coordinates. | Camera3D
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | project(point3d:Vector3D):Vector3D | Camera3D
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | unproject(mX:Number, mY:Number, mZ:Number = 0):Vector3D Calculates the scene position of the given normalized coordinates. | Camera3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createEntityPartitionNode():EntityNode [override] Factory method that returns the current partition node. | Camera3D
Inherited | getDefaultBoundingVolume():BoundingVolumeBase Creates the default bounding box to be used by this type of Entity. | Entity
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Camera3D
Inherited | updateBounds():void [override] Updates the bounding volume for the object. | Camera3D
 | updateFocusPoint():void | StereoCamera3D
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
leftCamera property
leftCamera:Camera3D [read-only]

Implementation
    public function get leftCamera():Camera3D
lens property
lens:LensBase[override]

Implementation
    public function get lens():LensBase
    public function set lens(value:LensBase):void
rightCamera property
rightCamera:Camera3D [read-only]

Implementation
    public function get rightCamera():Camera3D
stereoFocus property
stereoFocus:Number

Implementation
    public function get stereoFocus():Number
    public function set stereoFocus(value:Number):void
stereoOffset property
stereoOffset:Number

Implementation
    public function get stereoOffset():Number
    public function set stereoOffset(value:Number):void
Constructor Detail
StereoCamera3D () Constructor
public function StereoCamera3D(lens:LensBase = null)

Parameters
lens:LensBase (default = null)
Method Detail
invalidateStereoCams () method
arcane function invalidateStereoCams():void

invalidateTransform () method
override arcane function invalidateTransform():void

updateFocusPoint () method
protected function updateFocusPoint():void


away3d.stereo.StereoRenderer

StereoRenderer | Properties | Methods
Package | away3d.stereo
Class | public class StereoRenderer
Inheritance | StereoRenderer Inheritance Object

Public Properties
Property |  | Defined By
 | renderMethod : StereoRenderMethodBase | StereoRenderer
Public Methods
Method |  | Defined By
 | StereoRenderer(renderMethod:StereoRenderMethodBase = null) | StereoRenderer
 | getLeftInputTexture(stage3DProxy:Stage3DProxy):Texture | StereoRenderer
 | getRightInputTexture(stage3DProxy:Stage3DProxy):Texture | StereoRenderer
 | render(stage3DProxy:Stage3DProxy):void | StereoRenderer
Property Detail
renderMethod property
renderMethod:StereoRenderMethodBase

Implementation
    public function get renderMethod():StereoRenderMethodBase
    public function set renderMethod(value:StereoRenderMethodBase):void
Constructor Detail
StereoRenderer () Constructor
public function StereoRenderer(renderMethod:StereoRenderMethodBase = null)

Parameters
renderMethod:StereoRenderMethodBase (default = null)
Method Detail
getLeftInputTexture () method
public function getLeftInputTexture(stage3DProxy:Stage3DProxy):Texture

Parameters

stage3DProxy:Stage3DProxy

Returns
Texture
getRightInputTexture () method
public function getRightInputTexture(stage3DProxy:Stage3DProxy):Texture

Parameters

stage3DProxy:Stage3DProxy

Returns
Texture
render () method
public function render(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy


away3d.stereo.StereoView3D

StereoView3D | Properties | Methods
Package | away3d.stereo
Class | public class StereoView3D
Inheritance | StereoView3D Inheritance View3D Inheritance flash.display.Sprite

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | antiAlias : uint The amount of anti-aliasing to be used. | View3D
Inherited | background : Texture2DBase | View3D
Inherited | backgroundAlpha : Number | View3D
Inherited | backgroundColor : uint The background color of the screen. | View3D
 | camera : Camera3D [override] | StereoView3D
Inherited | deltaTime : uint [read-only] The amount of milliseconds the last render call took | View3D
Inherited | depthPrepass : Boolean | View3D
Inherited | filters : Array [override] Not supported. | View3D
Inherited | filters3d : Array | View3D
Inherited | forceMouseMove : Boolean Forces mouse-move related events even when the mouse hasn't moved. | View3D
Inherited | height : Number [override] The height of the viewport. | View3D
Inherited | mousePicker : IPicker | View3D
Inherited | renderedFacesCount : uint [read-only] The amount of faces that were pushed through the render pipeline on the last frame render. | View3D
Inherited | renderer : RendererBase The renderer used to draw the scene. | View3D
Inherited | rightClickMenuEnabled : Boolean | View3D
Inherited | rotation : Number [override] [write-only] | View3D
Inherited | rotationX : Number [override] [write-only] | View3D
Inherited | rotationY : Number [override] [write-only] | View3D
Inherited | rotationZ : Number [override] [write-only] | View3D
Inherited | scaleX : Number [override] [write-only] | View3D
Inherited | scaleY : Number [override] [write-only] | View3D
Inherited | scaleZ : Number [override] [write-only] | View3D
Inherited | scene : Scene3D The scene that's used to render for this viewport | View3D
Inherited | shareContext : Boolean Defers control of Context3D clear() and present() calls to Stage3DProxy, enabling multiple Stage3D frameworks to share the same Context3D object. | View3D
Inherited | stage3DProxy : Stage3DProxy | View3D
 | stereoEnabled : Boolean | StereoView3D
 | stereoRenderMethod : StereoRenderMethodBase | StereoView3D
Inherited | transform : Transform [override] [write-only] | View3D
Inherited | visible : Boolean [override] [write-only] | View3D
Inherited | width : Number [override] The width of the viewport. | View3D
Inherited | x : Number [override] [write-only] | View3D
Inherited | y : Number [override] [write-only] | View3D
Inherited | z : Number [override] [write-only] | View3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _aspectRatio : Number | View3D
Inherited | _backBufferInvalid : Boolean = true | View3D
Inherited | _camera : Camera3D | View3D
Inherited | _depthRender : Texture | View3D
Inherited | _entityCollector : EntityCollector | View3D
Inherited | _filter3DRenderer : Filter3DRenderer | View3D
Inherited | _mouse3DManager : Mouse3DManager | View3D
Inherited | _parentIsStage : Boolean | View3D
Inherited | _renderer : RendererBase | View3D
Inherited | _requireDepthRender : Boolean | View3D
Inherited | _rttBufferManager : RTTBufferManager | View3D
Inherited | _scene : Scene3D | View3D
Inherited | _shareContext : Boolean = false | View3D
Inherited | _stage3DProxy : Stage3DProxy | View3D
Inherited | _viewScissorRect : Rectangle | View3D
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | StereoView3D(scene:Scene3D = null, camera:Camera3D = null, renderer:RendererBase = null, stereoRenderMethod:StereoRenderMethodBase = null) | StereoView3D
Inherited | addSourceURL(url:String):void Defines a source url string that can be accessed though a View Source option in the right-click menu. | View3D
Inherited | dispose():void Disposes all memory occupied by the view. | View3D
Inherited | getRay(mX:Number, mY:Number, mZ:Number = 0):Vector3D Returns the ray in scene space from the camera to the point on the screen. | View3D
Inherited | project(point3d:Vector3D):Vector3D | View3D
 | render():void [override] | StereoView3D
Inherited | unproject(mX:Number, mY:Number, mZ:Number = 0):Vector3D Calculates the scene position of the given screen coordinates. | View3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | renderDepthPrepass(entityCollector:EntityCollector):void | View3D
Inherited | renderSceneDepthToTexture(entityCollector:EntityCollector):void | View3D
Inherited | updateBackBuffer():void Updates the backbuffer dimensions. | View3D
Inherited | updateGlobalPos():void | View3D
Inherited | updateTime():void | View3D
Inherited | updateViewSizeData():void | View3D
Property Detail
camera property
camera:Camera3D[override]

Implementation
    public function get camera():Camera3D
    public function set camera(value:Camera3D):void
stereoEnabled property
stereoEnabled:Boolean

Implementation
    public function get stereoEnabled():Boolean
    public function set stereoEnabled(value:Boolean):void
stereoRenderMethod property
stereoRenderMethod:StereoRenderMethodBase

Implementation
    public function get stereoRenderMethod():StereoRenderMethodBase
    public function set stereoRenderMethod(value:StereoRenderMethodBase):void
Constructor Detail
StereoView3D () Constructor
public function StereoView3D(scene:Scene3D = null, camera:Camera3D = null, renderer:RendererBase = null, stereoRenderMethod:StereoRenderMethodBase = null)

Parameters
scene:Scene3D (default = null)
camera:Camera3D (default = null)
renderer:RendererBase (default = null)
stereoRenderMethod:StereoRenderMethodBase (default = null)
Method Detail
render () method
override public function render():void


away3d.stereo.methods - Away3D Documentation

Package away3d.stereo.methods

Classes
AnaglyphStereoRenderMethod
InterleavedStereoRenderMethod
StereoRenderMethodBase


away3d.stereo.methods Summary

away3d.stereo.methods | Classes

Classes
Class | Description
AnaglyphStereoRenderMethod |
InterleavedStereoRenderMethod |
StereoRenderMethodBase |

Thu Nov 15 2012, 12:09 PM Z


away3d.stereo.methods.AnaglyphStereoRenderMethod

AnaglyphStereoRenderMethod | Methods
Package | away3d.stereo.methods
Class | public class AnaglyphStereoRenderMethod
Inheritance | AnaglyphStereoRenderMethod Inheritance StereoRenderMethodBase Inheritance Object

Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _textureSizeInvalid : Boolean = true | StereoRenderMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | AnaglyphStereoRenderMethod() | AnaglyphStereoRenderMethod
 | activate(stage3DProxy:Stage3DProxy):void [override] | AnaglyphStereoRenderMethod
Inherited | deactivate(stage3DProxy:Stage3DProxy):void | StereoRenderMethodBase
 | getFragmentCode():String [override] | AnaglyphStereoRenderMethod
Inherited | invalidateTextureSize():void | StereoRenderMethodBase
Constructor Detail
AnaglyphStereoRenderMethod () Constructor
public function AnaglyphStereoRenderMethod()

Method Detail
activate () method
override public function activate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

getFragmentCode () method
override public function getFragmentCode():String

Returns
String


away3d.stereo.methods.InterleavedStereoRenderMethod

InterleavedStereoRenderMethod | Methods
Package | away3d.stereo.methods
Class | public class InterleavedStereoRenderMethod
Inheritance | InterleavedStereoRenderMethod Inheritance StereoRenderMethodBase Inheritance Object

Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _textureSizeInvalid : Boolean = true | StereoRenderMethodBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | InterleavedStereoRenderMethod() | InterleavedStereoRenderMethod
 | activate(stage3DProxy:Stage3DProxy):void [override] | InterleavedStereoRenderMethod
 | deactivate(stage3DProxy:Stage3DProxy):void [override] | InterleavedStereoRenderMethod
 | getFragmentCode():String [override] | InterleavedStereoRenderMethod
Inherited | invalidateTextureSize():void | StereoRenderMethodBase
Constructor Detail
InterleavedStereoRenderMethod () Constructor
public function InterleavedStereoRenderMethod()

Method Detail
activate () method
override public function activate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

deactivate () method
override public function deactivate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

getFragmentCode () method
override public function getFragmentCode():String

Returns
String


away3d.stereo.methods.StereoRenderMethodBase

StereoRenderMethodBase | Properties | Methods
Package | away3d.stereo.methods
Class | public class StereoRenderMethodBase
Inheritance | StereoRenderMethodBase Inheritance Object
Subclasses | AnaglyphStereoRenderMethod, InterleavedStereoRenderMethod

Protected Properties
Property |  | Defined By
 | _textureSizeInvalid : Boolean = true | StereoRenderMethodBase
Public Methods
Method |  | Defined By
 | StereoRenderMethodBase() | StereoRenderMethodBase
 | activate(stage3DProxy:Stage3DProxy):void | StereoRenderMethodBase
 | deactivate(stage3DProxy:Stage3DProxy):void | StereoRenderMethodBase
 | getFragmentCode():String | StereoRenderMethodBase
 | invalidateTextureSize():void | StereoRenderMethodBase
Property Detail
_textureSizeInvalid property
protected var _textureSizeInvalid:Boolean = true

Constructor Detail
StereoRenderMethodBase () Constructor
public function StereoRenderMethodBase()

Method Detail
activate () method
public function activate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

deactivate () method
public function deactivate(stage3DProxy:Stage3DProxy):void

Parameters

stage3DProxy:Stage3DProxy

getFragmentCode () method
public function getFragmentCode():String

Returns
String
invalidateTextureSize () method
public function invalidateTextureSize():void


away3d.textures - Away3D Documentation

Package away3d.textures

Classes
ATFCubeTexture
ATFData
ATFTexture
BitmapCubeTexture
BitmapTexture
BitmapTextureCache
CubeReflectionTexture
CubeTextureBase
PlanarReflectionTexture
RenderCubeTexture
RenderTexture
SpecularBitmapTexture
SplatBlendBitmapTexture
Texture2DBase
TextureProxyBase
VideoTexture
WebcamTexture


away3d.textures Summary

away3d.textures | Classes

Classes
Class | Description
ATFCubeTexture |
ATFData |
ATFTexture |
BitmapCubeTexture |
BitmapTexture |
BitmapTextureCache | DEPRECRATED along with BitmapMaterial.
CubeReflectionTexture | CubeReflectionTexture provides a cube map texture for real-time reflections, used for any method that uses environment maps, such as EnvMapMethod.
CubeTextureBase |
PlanarReflectionTexture | PlanarReflectionTexture is a Texture that can be used for material-based planar reflections, as provided by PlanarReflectionMethod, FresnelPlanarReflectionMethod.
RenderCubeTexture |
RenderTexture |
SpecularBitmapTexture | A convenience texture that encodes a specular map in the red channel, and the gloss map in the green channel, as expected by BasicSpecularMapMethod
SplatBlendBitmapTexture |
Texture2DBase |
TextureProxyBase |
VideoTexture |
WebcamTexture |

Thu Nov 15 2012, 12:09 PM Z


away3d.textures.ATFCubeTexture

ATFCubeTexture | Properties | Methods | Constants
Package | away3d.textures
Class | public class ATFCubeTexture
Inheritance | ATFCubeTexture Inheritance CubeTextureBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
 | atfData : ATFData | ATFCubeTexture
Inherited | format : String [read-only] | TextureProxyBase
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
Inherited | height : int [read-only] | TextureProxyBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | size : int [read-only] | CubeTextureBase
Inherited | width : int [read-only] | TextureProxyBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ATFCubeTexture(byteArray:ByteArray) | ATFCubeTexture
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | TextureProxyBase
Inherited | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase | TextureProxyBase
Inherited | invalidateContent():void | TextureProxyBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createTexture(context:Context3D):TextureBase [override] | ATFCubeTexture
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
 | uploadContent(texture:TextureBase):void [override] | ATFCubeTexture
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
atfData property
atfData:ATFData

Implementation
    public function get atfData():ATFData
    public function set atfData(value:ATFData):void
Constructor Detail
ATFCubeTexture () Constructor
public function ATFCubeTexture(byteArray:ByteArray)

Parameters
byteArray:ByteArray
Method Detail
createTexture () method
override protected function createTexture(context:Context3D):TextureBase

Parameters

context:Context3D

Returns
TextureBase
uploadContent () method
override protected function uploadContent(texture:TextureBase):void

Parameters

texture:TextureBase


away3d.textures.ATFData

ATFData | Properties | Methods | Constants
Package | away3d.textures
Class | public class ATFData
Inheritance | ATFData Inheritance Object

Public Properties
Property |  | Defined By
 | data : ByteArray | ATFData
 | format : String | ATFData
 | height : int | ATFData
 | numTextures : int | ATFData
 | totalBytes : int | ATFData
 | type : int | ATFData
 | width : int | ATFData
Public Methods
Method |  | Defined By
 | ATFData(data:ByteArray) Create a new instance by parsing the given byte array. | ATFData
Public Constants
Constant |  | Defined By
 | TYPE_CUBE : int = 0x1 [static] | ATFData
 | TYPE_NORMAL : int = 0x0 [static] | ATFData
Property Detail
data property
public var data:ByteArray

format property
public var format:String

height property
public var height:int

numTextures property
public var numTextures:int

totalBytes property
public var totalBytes:int

type property
public var type:int

width property
public var width:int

Constructor Detail
ATFData () Constructor
public function ATFData(data:ByteArray)

Create a new instance by parsing the given byte array.

Parameters
data:ByteArray
Constant Detail
TYPE_CUBE Constant
public static const TYPE_CUBE:int = 0x1

TYPE_NORMAL Constant
public static const TYPE_NORMAL:int = 0x0


away3d.textures.ATFTexture

ATFTexture | Properties | Methods | Constants
Package | away3d.textures
Class | public class ATFTexture
Inheritance | ATFTexture Inheritance Texture2DBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
 | atfData : ATFData | ATFTexture
Inherited | format : String [read-only] | TextureProxyBase
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
Inherited | height : int [read-only] | TextureProxyBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | width : int [read-only] | TextureProxyBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ATFTexture(byteArray:ByteArray) | ATFTexture
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | TextureProxyBase
Inherited | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase | TextureProxyBase
Inherited | invalidateContent():void | TextureProxyBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createTexture(context:Context3D):TextureBase [override] | ATFTexture
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
 | uploadContent(texture:TextureBase):void [override] | ATFTexture
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
atfData property
atfData:ATFData

Implementation
    public function get atfData():ATFData
    public function set atfData(value:ATFData):void
Constructor Detail
ATFTexture () Constructor
public function ATFTexture(byteArray:ByteArray)

Parameters
byteArray:ByteArray
Method Detail
createTexture () method
override protected function createTexture(context:Context3D):TextureBase

Parameters

context:Context3D

Returns
TextureBase
uploadContent () method
override protected function uploadContent(texture:TextureBase):void

Parameters

texture:TextureBase


away3d.textures.BitmapCubeTexture

BitmapCubeTexture | Properties | Methods | Constants
Package | away3d.textures
Class | public class BitmapCubeTexture
Inheritance | BitmapCubeTexture Inheritance CubeTextureBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
Inherited | format : String [read-only] | TextureProxyBase
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
Inherited | height : int [read-only] | TextureProxyBase
Inherited | name : String | NamedAssetBase
 | negativeX : BitmapData The texture on the cube's left face. | BitmapCubeTexture
 | negativeY : BitmapData The texture on the cube's bottom face. | BitmapCubeTexture
 | negativeZ : BitmapData The texture on the cube's near face. | BitmapCubeTexture
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | positiveX : BitmapData The texture on the cube's right face. | BitmapCubeTexture
 | positiveY : BitmapData The texture on the cube's top face. | BitmapCubeTexture
 | positiveZ : BitmapData The texture on the cube's far face. | BitmapCubeTexture
Inherited | size : int [read-only] | CubeTextureBase
Inherited | width : int [read-only] | TextureProxyBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | BitmapCubeTexture(posX:BitmapData, negX:BitmapData, posY:BitmapData, negY:BitmapData, posZ:BitmapData, negZ:BitmapData) | BitmapCubeTexture
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | TextureProxyBase
Inherited | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase | TextureProxyBase
Inherited | invalidateContent():void | TextureProxyBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createTexture(context:Context3D):TextureBase [override] | CubeTextureBase
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
 | uploadContent(texture:TextureBase):void [override] | BitmapCubeTexture
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
negativeX property
negativeX:BitmapData

The texture on the cube's left face.

Implementation
    public function get negativeX():BitmapData
    public function set negativeX(value:BitmapData):void
negativeY property
negativeY:BitmapData

The texture on the cube's bottom face.

Implementation
    public function get negativeY():BitmapData
    public function set negativeY(value:BitmapData):void
negativeZ property
negativeZ:BitmapData

The texture on the cube's near face.

Implementation
    public function get negativeZ():BitmapData
    public function set negativeZ(value:BitmapData):void
positiveX property
positiveX:BitmapData

The texture on the cube's right face.

Implementation
    public function get positiveX():BitmapData
    public function set positiveX(value:BitmapData):void
positiveY property
positiveY:BitmapData

The texture on the cube's top face.

Implementation
    public function get positiveY():BitmapData
    public function set positiveY(value:BitmapData):void
positiveZ property
positiveZ:BitmapData

The texture on the cube's far face.

Implementation
    public function get positiveZ():BitmapData
    public function set positiveZ(value:BitmapData):void
Constructor Detail
BitmapCubeTexture () Constructor
public function BitmapCubeTexture(posX:BitmapData, negX:BitmapData, posY:BitmapData, negY:BitmapData, posZ:BitmapData, negZ:BitmapData)

Parameters
posX:BitmapData
negX:BitmapData
posY:BitmapData
negY:BitmapData
posZ:BitmapData
negZ:BitmapData
Method Detail
uploadContent () method
override protected function uploadContent(texture:TextureBase):void

Parameters

texture:TextureBase


away3d.textures.BitmapTexture

BitmapTexture | Properties | Methods | Constants
Package | away3d.textures
Class | public class BitmapTexture
Inheritance | BitmapTexture Inheritance Texture2DBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | SpecularBitmapTexture, SplatBlendBitmapTexture, VideoTexture, WebcamTexture

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
 | bitmapData : BitmapData | BitmapTexture
Inherited | format : String [read-only] | TextureProxyBase
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
Inherited | height : int [read-only] | TextureProxyBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | width : int [read-only] | TextureProxyBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | BitmapTexture(bitmapData:BitmapData) | BitmapTexture
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | TextureProxyBase
Inherited | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase | TextureProxyBase
Inherited | invalidateContent():void | TextureProxyBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createTexture(context:Context3D):TextureBase [override] | Texture2DBase
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
 | uploadContent(texture:TextureBase):void [override] | BitmapTexture
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
bitmapData property
bitmapData:BitmapData

Implementation
    public function get bitmapData():BitmapData
    public function set bitmapData(value:BitmapData):void
Constructor Detail
BitmapTexture () Constructor
public function BitmapTexture(bitmapData:BitmapData)

Parameters
bitmapData:BitmapData
Method Detail
uploadContent () method
override protected function uploadContent(texture:TextureBase):void

Parameters

texture:TextureBase


away3d.textures.BitmapTextureCache

BitmapTextureCache | Methods
Package | away3d.textures
Class | public class BitmapTextureCache
Inheritance | BitmapTextureCache Inheritance Object

DEPRECRATED along with BitmapMaterial. Will be removed along with BitmapMaterial

Public Methods
Method |  | Defined By
 | BitmapTextureCache(singletonEnforcer:SingletonEnforcer) | BitmapTextureCache
 | freeTexture(texture:BitmapTexture):void | BitmapTextureCache
 | getInstance():BitmapTextureCache [static] | BitmapTextureCache
 | getTexture(bitmapData:BitmapData):BitmapTexture | BitmapTextureCache
Constructor Detail
BitmapTextureCache () Constructor
public function BitmapTextureCache(singletonEnforcer:SingletonEnforcer)

Parameters
singletonEnforcer:SingletonEnforcer
Method Detail
freeTexture () method
public function freeTexture(texture:BitmapTexture):void

Parameters

texture:BitmapTexture

getInstance () method
public static function getInstance():BitmapTextureCache

Returns
BitmapTextureCache
getTexture () method
public function getTexture(bitmapData:BitmapData):BitmapTexture

Parameters

bitmapData:BitmapData

Returns
BitmapTexture


away3d.textures.CubeReflectionTexture

CubeReflectionTexture | Properties | Methods | Constants
Package | away3d.textures
Class | public class CubeReflectionTexture
Inheritance | CubeReflectionTexture Inheritance RenderCubeTexture Inheritance CubeTextureBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

CubeReflectionTexture provides a cube map texture for real-time reflections, used for any method that uses environment maps, such as EnvMapMethod.

See also

away3d.materials.methods.EnvMapMethod

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
 | farPlaneDistance : Number The far plane of the camera lens. | CubeReflectionTexture
Inherited | format : String [read-only] | TextureProxyBase
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
Inherited | height : int [read-only] | TextureProxyBase
Inherited | name : String | NamedAssetBase
 | nearPlaneDistance : Number The near plane used by the camera lens. | CubeReflectionTexture
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | position : Vector3D The origin where the environment map will be rendered. | CubeReflectionTexture
 | renderer : RendererBase The renderer to use. | CubeReflectionTexture
Inherited | size : int | RenderCubeTexture
Inherited | width : int [read-only] | TextureProxyBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CubeReflectionTexture(size:int) Creates a new CubeReflectionTexture object | CubeReflectionTexture
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | dispose():void [override] Cleans up resources used by this asset. | CubeReflectionTexture
 | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase [override] | CubeReflectionTexture
Inherited | invalidateContent():void | TextureProxyBase
 | render(view:View3D):void Renders the scene in the given view for reflections. | CubeReflectionTexture
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createTexture(context:Context3D):TextureBase [override] | RenderCubeTexture
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
Inherited | uploadContent(texture:TextureBase):void [override] | RenderCubeTexture
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
farPlaneDistance property
farPlaneDistance:Number

The far plane of the camera lens. Can be used to cut off objects that are too far to be of interest in reflections

Implementation
    public function get farPlaneDistance():Number
    public function set farPlaneDistance(value:Number):void
nearPlaneDistance property
nearPlaneDistance:Number

The near plane used by the camera lens.

Implementation
    public function get nearPlaneDistance():Number
    public function set nearPlaneDistance(value:Number):void
position property
position:Vector3D

The origin where the environment map will be rendered. This is usually in the centre of the reflective object.

Implementation
    public function get position():Vector3D
    public function set position(value:Vector3D):void
renderer property
renderer:RendererBase

The renderer to use.

Implementation
    public function get renderer():RendererBase
    public function set renderer(value:RendererBase):void
Constructor Detail
CubeReflectionTexture () Constructor
public function CubeReflectionTexture(size:int)

Creates a new CubeReflectionTexture object

Parameters
size:int — The size of the cube texture
Method Detail
dispose () method
override public function dispose():void

Cleans up resources used by this asset.

getTextureForStage3D () method
override public function getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase

Parameters

stage3DProxy:Stage3DProxy

Returns
TextureBase
render () method
public function render(view:View3D):void

Renders the scene in the given view for reflections.

Parameters

view:View3D — The view containing the scene to render.


away3d.textures.CubeTextureBase

CubeTextureBase | Properties | Methods | Constants
Package | away3d.textures
Class | public class CubeTextureBase
Inheritance | CubeTextureBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | ATFCubeTexture, BitmapCubeTexture, RenderCubeTexture

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
Inherited | format : String [read-only] | TextureProxyBase
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
Inherited | height : int [read-only] | TextureProxyBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | size : int [read-only] | CubeTextureBase
Inherited | width : int [read-only] | TextureProxyBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | CubeTextureBase() | CubeTextureBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | TextureProxyBase
Inherited | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase | TextureProxyBase
Inherited | invalidateContent():void | TextureProxyBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createTexture(context:Context3D):TextureBase [override] | CubeTextureBase
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
Inherited | uploadContent(texture:TextureBase):void | TextureProxyBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
size property
size:int [read-only]

Implementation
    public function get size():int
Constructor Detail
CubeTextureBase () Constructor
public function CubeTextureBase()

Method Detail
createTexture () method
override protected function createTexture(context:Context3D):TextureBase

Parameters

context:Context3D

Returns
TextureBase


away3d.textures.PlanarReflectionTexture

PlanarReflectionTexture | Properties | Methods | Constants
Package | away3d.textures
Class | public class PlanarReflectionTexture
Inheritance | PlanarReflectionTexture Inheritance RenderTexture Inheritance Texture2DBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

PlanarReflectionTexture is a Texture that can be used for material-based planar reflections, as provided by PlanarReflectionMethod, FresnelPlanarReflectionMethod.

See also

away3d.materials.methods.PlanarReflectionMethod

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
Inherited | format : String [read-only] | TextureProxyBase
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
Inherited | height : int | RenderTexture
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | plane : Plane3D The plane to reflect with. | PlanarReflectionTexture
 | renderer : RendererBase The renderer to use. | PlanarReflectionTexture
 | scale : Number A scale factor to reduce the quality of the reflection. | PlanarReflectionTexture
Inherited | width : int | RenderTexture
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | PlanarReflectionTexture() Creates a new PlanarReflectionTexture object. | PlanarReflectionTexture
 | applyTransform(matrix:Matrix3D):void Sets the plane to match a given matrix. | PlanarReflectionTexture
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | dispose():void [override] | PlanarReflectionTexture
 | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase [override] | PlanarReflectionTexture
Inherited | invalidateContent():void | TextureProxyBase
 | render(view:View3D):void Renders the scene in the given view for reflections. | PlanarReflectionTexture
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createTexture(context:Context3D):TextureBase [override] | RenderTexture
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
 | uploadContent(texture:TextureBase):void [override] | PlanarReflectionTexture
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
plane property
plane:Plane3D

The plane to reflect with.

Implementation
    public function get plane():Plane3D
    public function set plane(value:Plane3D):void
renderer property
renderer:RendererBase

The renderer to use.

Implementation
    public function get renderer():RendererBase
    public function set renderer(value:RendererBase):void
scale property
scale:Number

A scale factor to reduce the quality of the reflection. Default value is 1 (same quality as the View)

Implementation
    public function get scale():Number
    public function set scale(value:Number):void
textureRatioX property
textureRatioX:Number [read-only]

Implementation
    arcane function get textureRatioX():Number
textureRatioY property
textureRatioY:Number [read-only]

Implementation
    arcane function get textureRatioY():Number
Constructor Detail
PlanarReflectionTexture () Constructor
public function PlanarReflectionTexture()

Creates a new PlanarReflectionTexture object.

Method Detail
applyTransform () method
public function applyTransform(matrix:Matrix3D):void

Sets the plane to match a given matrix. This is used to easily match a Mesh using a PlaneGeometry and yUp = false.

Parameters

matrix:Matrix3D — The transformation matrix to rotate the plane with.

dispose () method
override public function dispose():void

getTextureForStage3D () method
override public function getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase

Parameters

stage3DProxy:Stage3DProxy

Returns
TextureBase
render () method
public function render(view:View3D):void

Renders the scene in the given view for reflections.

Parameters

view:View3D — The view containing the Scene to render.

uploadContent () method
override protected function uploadContent(texture:TextureBase):void

Parameters

texture:TextureBase


away3d.textures.RenderCubeTexture

RenderCubeTexture | Properties | Methods | Constants
Package | away3d.textures
Class | public class RenderCubeTexture
Inheritance | RenderCubeTexture Inheritance CubeTextureBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | CubeReflectionTexture

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
Inherited | format : String [read-only] | TextureProxyBase
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
Inherited | height : int [read-only] | TextureProxyBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | size : int | RenderCubeTexture
Inherited | width : int [read-only] | TextureProxyBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | RenderCubeTexture(size:Number) | RenderCubeTexture
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | TextureProxyBase
Inherited | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase | TextureProxyBase
Inherited | invalidateContent():void | TextureProxyBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createTexture(context:Context3D):TextureBase [override] | RenderCubeTexture
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
 | uploadContent(texture:TextureBase):void [override] | RenderCubeTexture
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
size property
size:int

Implementation
    public function get size():int
    public function set size(value:int):void
Constructor Detail
RenderCubeTexture () Constructor
public function RenderCubeTexture(size:Number)

Parameters
size:Number
Method Detail
createTexture () method
override protected function createTexture(context:Context3D):TextureBase

Parameters

context:Context3D

Returns
TextureBase
uploadContent () method
override protected function uploadContent(texture:TextureBase):void

Parameters

texture:TextureBase


away3d.textures.RenderTexture

RenderTexture | Properties | Methods | Constants
Package | away3d.textures
Class | public class RenderTexture
Inheritance | RenderTexture Inheritance Texture2DBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | PlanarReflectionTexture

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
Inherited | format : String [read-only] | TextureProxyBase
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
 | height : int | RenderTexture
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | width : int | RenderTexture
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | RenderTexture(width:Number, height:Number) | RenderTexture
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | TextureProxyBase
Inherited | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase | TextureProxyBase
Inherited | invalidateContent():void | TextureProxyBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createTexture(context:Context3D):TextureBase [override] | RenderTexture
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
 | uploadContent(texture:TextureBase):void [override] | RenderTexture
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
height property
height:int

Implementation
    public function get height():int
    public function set height(value:int):void
width property
width:int

Implementation
    public function get width():int
    public function set width(value:int):void
Constructor Detail
RenderTexture () Constructor
public function RenderTexture(width:Number, height:Number)

Parameters
width:Number
height:Number
Method Detail
createTexture () method
override protected function createTexture(context:Context3D):TextureBase

Parameters

context:Context3D

Returns
TextureBase
uploadContent () method
override protected function uploadContent(texture:TextureBase):void

Parameters

texture:TextureBase


away3d.textures.SpecularBitmapTexture

SpecularBitmapTexture | Properties | Methods | Constants
Package | away3d.textures
Class | public class SpecularBitmapTexture
Inheritance | SpecularBitmapTexture Inheritance BitmapTexture Inheritance Texture2DBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

A convenience texture that encodes a specular map in the red channel, and the gloss map in the green channel, as expected by BasicSpecularMapMethod

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
Inherited | bitmapData : BitmapData | BitmapTexture
Inherited | format : String [read-only] | TextureProxyBase
 | glossMap : BitmapData | SpecularBitmapTexture
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
Inherited | height : int [read-only] | TextureProxyBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | specularMap : BitmapData | SpecularBitmapTexture
Inherited | width : int [read-only] | TextureProxyBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SpecularBitmapTexture(specularMap:BitmapData = null, glossMap:BitmapData = null) | SpecularBitmapTexture
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | dispose():void [override] | SpecularBitmapTexture
Inherited | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase | TextureProxyBase
Inherited | invalidateContent():void | TextureProxyBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createTexture(context:Context3D):TextureBase [override] | Texture2DBase
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
 | uploadContent(texture:TextureBase):void [override] | SpecularBitmapTexture
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
glossMap property
glossMap:BitmapData

Implementation
    public function get glossMap():BitmapData
    public function set glossMap(value:BitmapData):void
specularMap property
specularMap:BitmapData

Implementation
    public function get specularMap():BitmapData
    public function set specularMap(value:BitmapData):void
Constructor Detail
SpecularBitmapTexture () Constructor
public function SpecularBitmapTexture(specularMap:BitmapData = null, glossMap:BitmapData = null)

Parameters
specularMap:BitmapData (default = null)
glossMap:BitmapData (default = null)
Method Detail
dispose () method
override public function dispose():void

uploadContent () method
override protected function uploadContent(texture:TextureBase):void

Parameters

texture:TextureBase


away3d.textures.SplatBlendBitmapTexture

SplatBlendBitmapTexture | Properties | Methods | Constants
Package | away3d.textures
Class | public class SplatBlendBitmapTexture
Inheritance | SplatBlendBitmapTexture Inheritance BitmapTexture Inheritance Texture2DBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
Inherited | bitmapData : BitmapData | BitmapTexture
Inherited | format : String [read-only] | TextureProxyBase
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
Inherited | height : int [read-only] | TextureProxyBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | width : int [read-only] | TextureProxyBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | SplatBlendBitmapTexture(blendingData:Array, normalize:Boolean = false) | SplatBlendBitmapTexture
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | dispose():void [override] | SplatBlendBitmapTexture
Inherited | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase | TextureProxyBase
Inherited | invalidateContent():void | TextureProxyBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createTexture(context:Context3D):TextureBase [override] | Texture2DBase
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
Inherited | uploadContent(texture:TextureBase):void [override] | BitmapTexture
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
SplatBlendBitmapTexture () Constructor
public function SplatBlendBitmapTexture(blendingData:Array, normalize:Boolean = false)

Parameters
blendingData:Array — An array of BitmapData objects to be used for the blend data, as required by TerrainDiffuseMethod.
normalize:Boolean (default = false)
Method Detail
dispose () method
override public function dispose():void


away3d.textures.Texture2DBase

Texture2DBase | Properties | Methods | Constants
Package | away3d.textures
Class | public class Texture2DBase
Inheritance | Texture2DBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Subclasses | ATFTexture, BitmapTexture, RenderTexture

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
Inherited | format : String [read-only] | TextureProxyBase
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
Inherited | height : int [read-only] | TextureProxyBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | width : int [read-only] | TextureProxyBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Texture2DBase() | Texture2DBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
Inherited | dispose():void Cleans up resources used by this asset. | TextureProxyBase
Inherited | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase | TextureProxyBase
Inherited | invalidateContent():void | TextureProxyBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
 | createTexture(context:Context3D):TextureBase [override] | Texture2DBase
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
Inherited | uploadContent(texture:TextureBase):void | TextureProxyBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Constructor Detail
Texture2DBase () Constructor
public function Texture2DBase()

Method Detail
createTexture () method
override protected function createTexture(context:Context3D):TextureBase

Parameters

context:Context3D

Returns
TextureBase


away3d.textures.TextureProxyBase

TextureProxyBase | Properties | Methods | Constants
Package | away3d.textures
Class | public class TextureProxyBase
Inheritance | TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher
Implements | IAsset
Subclasses | CubeTextureBase, Texture2DBase

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
 | assetType : String [read-only] | TextureProxyBase
 | format : String [read-only] | TextureProxyBase
 | hasMipMaps : Boolean [read-only] | TextureProxyBase
 | height : int [read-only] | TextureProxyBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | width : int [read-only] | TextureProxyBase
Protected Properties
Property |  | Defined By
 | _dirty : Vector.<Context3D> | TextureProxyBase
 | _format : String = bgra | TextureProxyBase
 | _hasMipmaps : Boolean = true | TextureProxyBase
 | _height : int | TextureProxyBase
 | _textures : Vector.<TextureBase> | TextureProxyBase
 | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | TextureProxyBase() | TextureProxyBase
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | dispose():void Cleans up resources used by this asset. | TextureProxyBase
 | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase | TextureProxyBase
 | invalidateContent():void | TextureProxyBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Protected Methods
Method |  | Defined By
 | createTexture(context:Context3D):TextureBase | TextureProxyBase
 | invalidateSize():void | TextureProxyBase
 | setSize(width:int, height:int):void | TextureProxyBase
 | uploadContent(texture:TextureBase):void | TextureProxyBase
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
_dirty property
protected var _dirty:Vector.<Context3D>

_format property
protected var _format:String = bgra

_hasMipmaps property
protected var _hasMipmaps:Boolean = true

_height property
protected var _height:int

_textures property
protected var _textures:Vector.<TextureBase>

_width property
protected var _width:int

assetType property
assetType:String [read-only]

Implementation
    public function get assetType():String
format property
format:String [read-only]

Implementation
    public function get format():String
hasMipMaps property
hasMipMaps:Boolean [read-only]

Implementation
    public function get hasMipMaps():Boolean
height property
height:int [read-only]

Implementation
    public function get height():int
width property
width:int [read-only]

Implementation
    public function get width():int
Constructor Detail
TextureProxyBase () Constructor
public function TextureProxyBase()

Method Detail
createTexture () method
protected function createTexture(context:Context3D):TextureBase

Parameters

context:Context3D

Returns
TextureBase
dispose () method
public function dispose():void

Cleans up resources used by this asset.

getTextureForStage3D () method
public function getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase

Parameters

stage3DProxy:Stage3DProxy

Returns
TextureBase
invalidateContent () method
public function invalidateContent():void

invalidateSize () method
protected function invalidateSize():void

setSize () method
protected function setSize(width:int, height:int):void

Parameters

width:int
height:int

uploadContent () method
protected function uploadContent(texture:TextureBase):void

Parameters

texture:TextureBase


away3d.textures.VideoTexture

VideoTexture | Properties | Methods | Constants
Package | away3d.textures
Class | public class VideoTexture
Inheritance | VideoTexture Inheritance BitmapTexture Inheritance Texture2DBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
 | autoPlay : Boolean Indicates whether the video will start playing on initialisation. | VideoTexture
 | autoUpdate : Boolean Indicates whether the material will redraw onEnterFrame | VideoTexture
Inherited | bitmapData : BitmapData | BitmapTexture
Inherited | format : String [read-only] | TextureProxyBase
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
Inherited | height : int [read-only] | TextureProxyBase
 | materialHeight : uint | VideoTexture
 | materialWidth : uint | VideoTexture
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | player : IVideoPlayer [read-only] | VideoTexture
Inherited | width : int [read-only] | TextureProxyBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | VideoTexture(source:String, materialWidth:uint = 256, materialHeight:uint = 256, loop:Boolean = true, autoPlay:Boolean = false, player:IVideoPlayer = null) | VideoTexture
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | dispose():void [override] | VideoTexture
Inherited | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase | TextureProxyBase
Inherited | invalidateContent():void | TextureProxyBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
 | update():void Draws the video and updates the bitmap texture If autoUpdate is false and this function is not called the bitmap texture will not update! | VideoTexture
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createTexture(context:Context3D):TextureBase [override] | Texture2DBase
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
Inherited | uploadContent(texture:TextureBase):void [override] | BitmapTexture
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
autoPlay property
autoPlay:Boolean

Indicates whether the video will start playing on initialisation. If false, only the first frame is displayed.

Implementation
    public function get autoPlay():Boolean
    public function set autoPlay(value:Boolean):void
autoUpdate property
autoUpdate:Boolean

Indicates whether the material will redraw onEnterFrame

Implementation
    public function get autoUpdate():Boolean
    public function set autoUpdate(value:Boolean):void
materialHeight property
materialHeight:uint

Implementation
    public function get materialHeight():uint
    public function set materialHeight(value:uint):void
materialWidth property
materialWidth:uint

Implementation
    public function get materialWidth():uint
    public function set materialWidth(value:uint):void
player property
player:IVideoPlayer [read-only]

Implementation
    public function get player():IVideoPlayer
Constructor Detail
VideoTexture () Constructor
public function VideoTexture(source:String, materialWidth:uint = 256, materialHeight:uint = 256, loop:Boolean = true, autoPlay:Boolean = false, player:IVideoPlayer = null)

Parameters
source:String
materialWidth:uint (default = 256)
materialHeight:uint (default = 256)
loop:Boolean (default = true)
autoPlay:Boolean (default = false)
player:IVideoPlayer (default = null)
Method Detail
dispose () method
override public function dispose():void

update () method
public function update():void

Draws the video and updates the bitmap texture If autoUpdate is false and this function is not called the bitmap texture will not update!


away3d.textures.WebcamTexture

WebcamTexture | Properties | Methods | Constants
Package | away3d.textures
Class | public class WebcamTexture
Inheritance | WebcamTexture Inheritance BitmapTexture Inheritance Texture2DBase Inheritance TextureProxyBase Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [read-only] | TextureProxyBase
 | autoUpdate : Boolean Defines whether the texture should automatically update while camera stream is playing. | WebcamTexture
Inherited | bitmapData : BitmapData | BitmapTexture
 | camera : Camera [read-only] The Camera instance (webcam) used by this texture. | WebcamTexture
Inherited | format : String [read-only] | TextureProxyBase
Inherited | hasMipMaps : Boolean [read-only] | TextureProxyBase
Inherited | height : int [read-only] | TextureProxyBase
Inherited | name : String | NamedAssetBase
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
 | smoothing : Boolean Toggles smoothing on the texture as it's drawn (and potentially scaled) from the video stream to a BitmapData object. | WebcamTexture
Inherited | width : int [read-only] | TextureProxyBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _dirty : Vector.<Context3D> | TextureProxyBase
Inherited | _format : String = bgra | TextureProxyBase
Inherited | _hasMipmaps : Boolean = true | TextureProxyBase
Inherited | _height : int | TextureProxyBase
Inherited | _textures : Vector.<TextureBase> | TextureProxyBase
Inherited | _width : int | TextureProxyBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | WebcamTexture(cameraWidth:uint = 320, cameraHeight:uint = 240, materialSize:uint = 256, autoStart:Boolean = true, camera:Camera = null, smoothing:Boolean = true) | WebcamTexture
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | dispose():void [override] Clean up used resources. | WebcamTexture
 | flipHorizontal():void Flips the image from the webcam horizontally | WebcamTexture
 | flipVertical():void Flips the image from the webcam vertically | WebcamTexture
Inherited | getTextureForStage3D(stage3DProxy:Stage3DProxy):TextureBase | TextureProxyBase
Inherited | invalidateContent():void | TextureProxyBase
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
 | start():void Start subscribing to camera stream. | WebcamTexture
 | stop():void Detaches from the camera stream. | WebcamTexture
 | update():void Draws the video and updates the bitmap texture If autoUpdate is false and this function is not called the bitmap texture will not update! | WebcamTexture
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createTexture(context:Context3D):TextureBase [override] | Texture2DBase
Inherited | invalidateSize():void | TextureProxyBase
Inherited | setSize(width:int, height:int):void | TextureProxyBase
 | uploadContent(texture:TextureBase):void [override] | WebcamTexture
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Property Detail
autoUpdate property
autoUpdate:Boolean

Defines whether the texture should automatically update while camera stream is playing. If false, the update() method must be invoked for the texture to redraw.

Implementation
    public function get autoUpdate():Boolean
    public function set autoUpdate(value:Boolean):void
camera property
camera:Camera [read-only]

The Camera instance (webcam) used by this texture.

Implementation
    public function get camera():Camera
smoothing property
smoothing:Boolean

Toggles smoothing on the texture as it's drawn (and potentially scaled) from the video stream to a BitmapData object.

Implementation
    public function get smoothing():Boolean
    public function set smoothing(value:Boolean):void
Constructor Detail
WebcamTexture () Constructor
public function WebcamTexture(cameraWidth:uint = 320, cameraHeight:uint = 240, materialSize:uint = 256, autoStart:Boolean = true, camera:Camera = null, smoothing:Boolean = true)

Parameters
cameraWidth:uint (default = 320)
cameraHeight:uint (default = 240)
materialSize:uint (default = 256)
autoStart:Boolean (default = true)
camera:Camera (default = null)
smoothing:Boolean (default = true)
Method Detail
dispose () method
override public function dispose():void

Clean up used resources.

flipHorizontal () method
public function flipHorizontal():void

Flips the image from the webcam horizontally

flipVertical () method
public function flipVertical():void

Flips the image from the webcam vertically

start () method
public function start():void

Start subscribing to camera stream. For the texture to update the update() method must be repeatedly invoked, or autoUpdate set to true.

stop () method
public function stop():void

Detaches from the camera stream.

update () method
public function update():void

Draws the video and updates the bitmap texture If autoUpdate is false and this function is not called the bitmap texture will not update!

uploadContent () method
override protected function uploadContent(texture:TextureBase):void

Parameters

texture:TextureBase


away3d.tools.commands - Away3D Documentation

Package away3d.tools.commands

Classes
Align
Explode
Merge
Mirror
Weld


away3d.tools.commands Summary

away3d.tools.commands | Classes

Classes
Class | Description
Align | Class Aligns an arrays of Object3Ds, Vector3D's or Vertexes compaired to each other.Align
Explode | Class Explode make all vertices and uv's of a mesh unicExplode
Merge | Class Merge merges two or more static meshes into one.Merge
Mirror |
Weld | Class Weld removes the vertices that can be shared from one or more meshes (smoothes the mesh surface when lighted).

Thu Nov 15 2012, 12:09 PM Z


away3d.tools.commands.Align

Align | Methods | Constants
Package | away3d.tools.commands
Class | public class Align
Inheritance | Align Inheritance Object

Class Aligns an arrays of Object3Ds, Vector3D's or Vertexes compaired to each other.Align

Public Methods
Method |  | Defined By
 | align(aObjs:Array, axis:String, condition:String):void [static] Applies to array elements the alignment according to axis, x, y or z and a condition. | Align
 | alignMeshes(meshes:Vector.<Mesh>, axis:String, condition:String):void [static] Aligns a series of meshes to their bounds along a given axis. | Align
 | alignToFloor(meshes:Vector.<Mesh>):void [static] Place one or more meshes at y 0 using their min bounds | Align
 | distribute(aObjs:Array, axis:String):void [static] Applies to array elements a distributed alignment according to axis, x,y or z. | Align
Public Constants
Constant |  | Defined By
 | AVERAGE : String = av [static] | Align
 | NEGATIVE : String = - [static] | Align
 | POSITIVE : String = + [static] | Align
 | X_AXIS : String = x [static] | Align
 | Y_AXIS : String = y [static] | Align
 | Z_AXIS : String = z [static] | Align
Method Detail
align () method
public static function align(aObjs:Array, axis:String, condition:String):void

Applies to array elements the alignment according to axis, x, y or z and a condition. each element must have public x,y and z properties. In case elements are meshes only their positions is affected. Method doesn't take in account their respective bounds String condition: "+" align to highest value on a given axis "-" align to lowest value on a given axis "" align to a given axis on 0; This is the default. "av" align to average of all values on a given axis

Parameters

aObjs:Array — Array. An array with elements with x,y and z public properties such as Mesh, Object3D, ObjectContainer3D,Vector3D or Vertex
axis:String — String. Represent the axis to align on.
condition:String — [optional]. String. Can be '+", "-", "av" or "", Default is "", aligns to given axis at 0.

alignMeshes () method
public static function alignMeshes(meshes:Vector.<Mesh>, axis:String, condition:String):void

Aligns a series of meshes to their bounds along a given axis.

Parameters

meshes:Vector.<Mesh> — A Vector of Mesh objects
axis:String — Represent the axis to align on.
condition:String (default = NaN) — Can be POSITIVE ('+') or NEGATIVE ('-'), Default is POSITIVE ('+')

alignToFloor () method
public static function alignToFloor(meshes:Vector.<Mesh>):void

Place one or more meshes at y 0 using their min bounds

Parameters

meshes:Vector.<Mesh>

distribute () method
public static function distribute(aObjs:Array, axis:String):void

Applies to array elements a distributed alignment according to axis, x,y or z. In case elements are meshes only their positions is affected. Method doesn't take in account their respective bounds each element must have public x,y and z properties

Parameters

aObjs:Array — Array. An array with elements with x,y and z public properties such as Mesh, Object3D, ObjectContainer3D,Vector3D or Vertex
axis:String — String. Represent the axis to align on.

Constant Detail
AVERAGE Constant
public static const AVERAGE:String = av

NEGATIVE Constant
public static const NEGATIVE:String = -

POSITIVE Constant
public static const POSITIVE:String = +

X_AXIS Constant
public static const X_AXIS:String = x

Y_AXIS Constant
public static const Y_AXIS:String = y

Z_AXIS Constant
public static const Z_AXIS:String = z


away3d.tools.commands.Explode

Explode | Methods
Package | away3d.tools.commands
Class | public class Explode
Inheritance | Explode Inheritance Object

Class Explode make all vertices and uv's of a mesh unicExplode

Public Methods
Method |  | Defined By
 | Explode() | Explode
 | apply(geom:Geometry, keepNormals:Boolean = true):void | Explode
 | applyToContainer(ctr:ObjectContainer3D, keepNormals:Boolean = true):void Apply the explode code to a given ObjectContainer3D. | Explode
Constructor Detail
Explode () Constructor
public function Explode()

Method Detail
apply () method
public function apply(geom:Geometry, keepNormals:Boolean = true):void

Parameters

geom:Geometry
keepNormals:Boolean (default = true)

applyToContainer () method
public function applyToContainer(ctr:ObjectContainer3D, keepNormals:Boolean = true):void

Apply the explode code to a given ObjectContainer3D.

Parameters

ctr:ObjectContainer3D — ObjectContainer3D. The target Object3d object.
keepNormals:Boolean (default = true) — Boolean. If the vertexNormals of the object are preserved. Default is true.


away3d.tools.commands.Merge

Merge | Properties | Methods
Package | away3d.tools.commands
Class | public class Merge
Inheritance | Merge Inheritance Object

Class Merge merges two or more static meshes into one.Merge

Public Properties
Property |  | Defined By
 | disposeSources : Boolean Defines if the mesh(es) sources used for the merging are kept or disposed. | Merge
 | keepMaterial : Boolean Defines if mesh2 will be merged using its own material information. | Merge
 | objectSpace : Boolean Defines if mesh2 is merged using its objectSpace. | Merge
Public Methods
Method |  | Defined By
 | Merge(keepMaterial:Boolean = false, disposeSources:Boolean = false, objectSpace:Boolean = false) | Merge
 | apply(mesh1:Mesh, mesh2:Mesh):void Merge 2 meshes into one. | Merge
 | applyToContainer(object:ObjectContainer3D, name:String):Mesh Merges all the children of a container as one single Mesh. | Merge
 | applyToMeshes(receiver:Mesh, meshes:Vector.<Mesh>):Mesh Merges all the meshes found into the Vector.<Mesh> parameter with the receiver Mesh. | Merge
Property Detail
disposeSources property
disposeSources:Boolean

Defines if the mesh(es) sources used for the merging are kept or disposed.

Implementation
    public function get disposeSources():Boolean
    public function set disposeSources(value:Boolean):void
keepMaterial property
keepMaterial:Boolean

Defines if mesh2 will be merged using its own material information.

Implementation
    public function get keepMaterial():Boolean
    public function set keepMaterial(value:Boolean):void
objectSpace property
objectSpace:Boolean

Defines if mesh2 is merged using its objectSpace.

Implementation
    public function get objectSpace():Boolean
    public function set objectSpace(value:Boolean):void
Constructor Detail
Merge () Constructor
public function Merge(keepMaterial:Boolean = false, disposeSources:Boolean = false, objectSpace:Boolean = false)

Parameters
keepMaterial:Boolean (default = false) — [optional] Boolean. Defines if the merged object uses the mesh1 material information or keeps its material(s). Default is false. If set to false and receiver object has multiple materials, the last material found in mesh1 submeshes is applied to mesh2 submeshes.
disposeSources:Boolean (default = false) — [optional] Boolean. Defines if mesh2 (or sources meshes in case applyToContainer is used) are kept untouched or disposed. Default is false. If keepMaterial is true, only geometry and eventual ObjectContainers3D are cleared from memory.
objectSpace:Boolean (default = false) — [optional] Boolean. Defines if mesh2 is merge using its objectSpace or worldspace. Default is false.
Method Detail
apply () method
public function apply(mesh1:Mesh, mesh2:Mesh):void

Merge 2 meshes into one. It is recommand to use apply when 2 meshes are to be merged. If more need to be merged, use either applyToMeshes or applyToContainer methods.

Parameters

mesh1:Mesh — Mesh. The receiver object that will hold both meshes information.
mesh2:Mesh — Mesh. The Mesh object to be merge with mesh1.

applyToContainer () method
public function applyToContainer(object:ObjectContainer3D, name:String):Mesh

Merges all the children of a container as one single Mesh. The first Mesh child encountered becomes the receiver. This is mesh that is returned. If no Mesh object is found, class returns null.

Parameters

object:ObjectContainer3D — The ObjectContainer3D holding meshes to merge as one mesh.
name:String — [optional] As the class picks the first mesh it finds, the name is applied to the merged mesh.

Returns
Mesh — The merged Mesh instance renamed to the name parameter if one was provided.
applyToMeshes () method
public function applyToMeshes(receiver:Mesh, meshes:Vector.<Mesh>):Mesh

Merges all the meshes found into the Vector.<Mesh> parameter with the receiver Mesh.

Parameters

receiver:Mesh — Mesh. The Mesh receiver.
meshes:Vector.<Mesh> — Vector.<Mesh>. A series of Meshes to be merged with the reciever mesh.

Returns
Mesh — The merged receiver Mesh instance.


away3d.tools.commands.Mirror

Mirror | Methods | Constants
Package | away3d.tools.commands
Class | public class Mirror
Inheritance | Mirror Inheritance Object

Public Methods
Method |  | Defined By
 | Mirror(recenter:Boolean = false, duplicate:Boolean = true) | Mirror
 | apply(mesh:Mesh, axis:int, offset:String):void | Mirror
 | applyToContainer(ctr:ObjectContainer3D, axis:int, offset:String):void | Mirror
Public Constants
Constant |  | Defined By
 | CENTER : String = center [static] | Mirror
 | MAX_BOUND : String = max [static] | Mirror
 | MIN_BOUND : String = min [static] | Mirror
 | X_AXIS : int = 1 [static] | Mirror
 | Y_AXIS : int = 2 [static] | Mirror
 | Z_AXIS : int = 4 [static] | Mirror
Constructor Detail
Mirror () Constructor
public function Mirror(recenter:Boolean = false, duplicate:Boolean = true)

Parameters
recenter:Boolean (default = false)
duplicate:Boolean (default = true)
Method Detail
apply () method
public function apply(mesh:Mesh, axis:int, offset:String):void

Parameters

mesh:Mesh
axis:int
offset:String (default = NaN)

applyToContainer () method
public function applyToContainer(ctr:ObjectContainer3D, axis:int, offset:String):void

Parameters

ctr:ObjectContainer3D
axis:int
offset:String (default = NaN)

Constant Detail
CENTER Constant
public static const CENTER:String = center

MAX_BOUND Constant
public static const MAX_BOUND:String = max

MIN_BOUND Constant
public static const MIN_BOUND:String = min

X_AXIS Constant
public static const X_AXIS:int = 1

Y_AXIS Constant
public static const Y_AXIS:int = 2

Z_AXIS Constant
public static const Z_AXIS:int = 4


away3d.tools.commands.Weld

Weld | Methods
Package | away3d.tools.commands
Class | public class Weld
Inheritance | Weld Inheritance Object

Class Weld removes the vertices that can be shared from one or more meshes (smoothes the mesh surface when lighted).

Public Methods
Method |  | Defined By
 | Weld() | Weld
 | apply(geom:Geometry, keepUvs:Boolean = true, normalAngleThresholdRadians:Number = 0):void | Weld
 | applyToContainer(obj:ObjectContainer3D, keepUVs:Boolean = true, normalThreshold:Number = 0):void | Weld
Constructor Detail
Weld () Constructor
public function Weld()

Method Detail
apply () method
public function apply(geom:Geometry, keepUvs:Boolean = true, normalAngleThresholdRadians:Number = 0):void

Parameters

geom:Geometry
keepUvs:Boolean (default = true)
normalAngleThresholdRadians:Number (default = 0)

applyToContainer () method
public function applyToContainer(obj:ObjectContainer3D, keepUVs:Boolean = true, normalThreshold:Number = 0):void

Parameters

obj:ObjectContainer3D
keepUVs:Boolean (default = true)
normalThreshold:Number (default = 0)


away3d.tools.helpers - Away3D Documentation

Package away3d.tools.helpers

Classes
FaceHelper
LightsHelper
MeshDebugger
MeshHelper
ParticleGeometryHelper


away3d.tools.helpers Summary

away3d.tools.helpers | Classes

Classes
Class | Description
FaceHelper | Helper Class for face manipulationFaceHelper
LightsHelper | Helper Class for the LightBase objects LightsHelper A series of methods to ease work with LightBase objects
MeshDebugger | Helper Class for Mesh objects MeshDebugger Displays the normals, tangents and vertexNormals of a given mesh.
MeshHelper | Helper Class for the Mesh object MeshHelper A series of methods usually usefull for mesh manipulations
ParticleGeometryHelper | ...

Thu Nov 15 2012, 12:09 PM Z


away3d.tools.helpers.FaceHelper

FaceHelper | Methods
Package | away3d.tools.helpers
Class | public class FaceHelper
Inheritance | FaceHelper Inheritance Object

Helper Class for face manipulationFaceHelper

Public Methods
Method |  | Defined By
 | addFace(mesh:Mesh, v0:Vertex, v1:Vertex, v2:Vertex, uv0:UV, uv1:UV, uv2:UV, subGeomIndice:uint):void [static] | FaceHelper
 | addFaces(mesh:Mesh, v0s:Vector.<Vertex>, v1s:Vector.<Vertex>, v2s:Vector.<Vertex>, uv0s:Vector.<UV>, uv1s:Vector.<UV>, uv2s:Vector.<UV>, subGeomIndices:Vector.<uint>):void [static] Adds a series of faces from a mesh. | FaceHelper
 | quarterFace(mesh:Mesh, indice:uint, subGeomIndice:uint):void [static] Divides a face into 4 faces. | FaceHelper
 | quarterFaces(mesh:Mesh):void [static] Divides all the faces of a mesh in 4 faces. | FaceHelper
 | removeFace(mesh:Mesh, index:uint, subGeomIndice:uint):void [static] Remove a face from a mesh | FaceHelper
 | removeFaces(mesh:Mesh, indices:Vector.<uint>, subGeomIndices:Vector.<uint>):void [static] Remove a series of faces from a mesh. | FaceHelper
 | splitFace(mesh:Mesh, indice:uint, subGeomIndice:uint, side:uint = 0):void [static] Divides a face into 2 faces. | FaceHelper
 | splitFaces(mesh:Mesh):void [static] Divides all the faces of a mesh in 2 faces. | FaceHelper
 | triFace(mesh:Mesh, indice:uint, subGeomIndice:uint):void [static] Divides a face into 3 faces. | FaceHelper
 | triFaces(mesh:Mesh):void [static] Divides all the faces of a mesh in 3 faces. | FaceHelper
Method Detail
addFace () method
public static function addFace(mesh:Mesh, v0:Vertex, v1:Vertex, v2:Vertex, uv0:UV, uv1:UV, uv2:UV, subGeomIndice:uint):void

Parameters

mesh:Mesh
v0:Vertex
v1:Vertex
v2:Vertex
uv0:UV
uv1:UV
uv2:UV
subGeomIndice:uint

addFaces () method
public static function addFaces(mesh:Mesh, v0s:Vector.<Vertex>, v1s:Vector.<Vertex>, v2s:Vector.<Vertex>, uv0s:Vector.<UV>, uv1s:Vector.<UV>, uv2s:Vector.<UV>, subGeomIndices:Vector.<uint>):void

Adds a series of faces from a mesh. All vectors must have the same length.

Parameters

mesh:Mesh — Mesh. The mesh to remove a face from
v0s:Vector.<Vertex> — A vector with a series of Vertex Objects representing the v0 of a face.
v1s:Vector.<Vertex> — A vector with a series of Vertex Objects representing the v1 of a face.
v2s:Vector.<Vertex> — A vector with a series of Vertex Objects representing the v2 of a face.
uv0s:Vector.<UV> — A vector with a series of UV Objects representing the uv0 of a face.
uv1s:Vector.<UV> — A vector with a series of UV Objects representing the uv1 of a face.
uv2s:Vector.<UV> — A vector with a series of UV Objects representing the uv2 of a face.
subGeomIndices:Vector.<uint>

quarterFace () method
public static function quarterFace(mesh:Mesh, indice:uint, subGeomIndice:uint):void

Divides a face into 4 faces.

Parameters

mesh:Mesh — The mesh holding the face to split in 4.
indice:uint — The face index. The value represents the position in indices vector divided by 3. For instance, to edit face [1], the parameter indice will be 1. The x value of the v0 at position 9 in vertices vector is then extracted from vertices[indices[indice]]
subGeomIndice:uint — The index of the subgeometry holder this face.

quarterFaces () method
public static function quarterFaces(mesh:Mesh):void

Divides all the faces of a mesh in 4 faces.

Parameters

mesh:Mesh — The mesh holding the faces to split in 4 At this time of dev, quarterFaces method will abort if a subgeometry reaches max buffer limit of 65k

removeFace () method
public static function removeFace(mesh:Mesh, index:uint, subGeomIndice:uint):void

Remove a face from a mesh

Parameters

mesh:Mesh — Mesh. The mesh to remove a face from
index:uint — uint. Index of the face in vertices. The value represents the position in indices vector divided by 3. For instance, to edit face [1], the parameter indice will be 1. The x value of the v0 at position 3 in vertice vector is then extracted from vertices[indices[indice]]
subGeomIndice:uint — uint. Index of vertex 1 of the face

removeFaces () method
public static function removeFaces(mesh:Mesh, indices:Vector.<uint>, subGeomIndices:Vector.<uint>):void

Remove a series of faces from a mesh. Indices and geomIndices must have the same length. Meshes with less that 20k faces and single material, will generally only have one single subgeometry. The geomIndices vector will then contain only zeros. IMPORTANT: the code considers the indices as location in the mesh subgemeometry indices vector, not the value at the pointer location.

Parameters

mesh:Mesh — Mesh. The mesh to remove a face from
indices:Vector.<uint> — A vector with a series of uints indices: the indices of the faces to be removed.
subGeomIndices:Vector.<uint> — A vector with a series of uints indices representing the subgeometries of the faces to be removed.

splitFace () method
public static function splitFace(mesh:Mesh, indice:uint, subGeomIndice:uint, side:uint = 0):void

Divides a face into 2 faces.

Parameters

mesh:Mesh — The mesh holding the face to split in 2
indice:uint — The face index. The value represents the position in indices vector divided by 3. For instance, to edit face [1], the parameter indice will be 1. The x value of the v0 at position 9 in vertices vector is then extracted from vertices[indices[indice]]
subGeomIndice:uint — The index of the subgeometry holder this face.
side:uint (default = 0) — [optional] The side of the face to split in two. 0 , 1 or 2. (clockwize).

splitFaces () method
public static function splitFaces(mesh:Mesh):void

Divides all the faces of a mesh in 2 faces.

Parameters

mesh:Mesh — The mesh holding the faces to split in 2

triFace () method
public static function triFace(mesh:Mesh, indice:uint, subGeomIndice:uint):void

Divides a face into 3 faces.

Parameters

mesh:Mesh — The mesh holding the face to split in 3.
indice:uint — The face index. The value represents the position in indices vector divided by 3. For instance, to edit face [1], the parameter indice will be 1. The x value of the v0 at position 9 in vertices vector is then extracted from vertices[indices[indice]]
subGeomIndice:uint — The index of the subgeometry holder this face.

triFaces () method
public static function triFaces(mesh:Mesh):void

Divides all the faces of a mesh in 3 faces.

Parameters

mesh:Mesh — The mesh holding the faces to split in 3 At this time of dev, triFaces method will abort if a subgeometry reaches max buffer limit of 65k


away3d.tools.helpers.LightsHelper

LightsHelper | Methods
Package | away3d.tools.helpers
Class | public class LightsHelper
Inheritance | LightsHelper Inheritance Object

Helper Class for the LightBase objects LightsHelper A series of methods to ease work with LightBase objects

Public Methods
Method |  | Defined By
 | addStaticLightsToMaterials(objectContainer3D:ObjectContainer3D, lights:Vector.<LightBase>):void [static] Applys a series of lights to all materials found into an objectcontainer and its children. | LightsHelper
 | addStaticLightToMaterials(objectContainer3D:ObjectContainer3D, light:LightBase):void [static] Adds one light to all materials found into an objectcontainer and its children. | LightsHelper
 | removeStaticLightFromMaterials(objectContainer3D:ObjectContainer3D, light:LightBase):void [static] Removes a given light from all materials found into an objectcontainer and its children. | LightsHelper
Method Detail
addStaticLightsToMaterials () method
public static function addStaticLightsToMaterials(objectContainer3D:ObjectContainer3D, lights:Vector.<LightBase>):void

Applys a series of lights to all materials found into an objectcontainer and its children. The lights eventually set previously are replaced by the new ones.

Parameters

objectContainer3D:ObjectContainer3D — ObjectContainer3D. The target ObjectContainer3D object to be inspected.
lights:Vector.<LightBase> — Vector.<LightBase>. A series of lights to be set to all materials found during parsing of the target ObjectContainer3D.

addStaticLightToMaterials () method
public static function addStaticLightToMaterials(objectContainer3D:ObjectContainer3D, light:LightBase):void

Adds one light to all materials found into an objectcontainer and its children. The lights eventually set previously on a material are kept unchanged. The new light is added to the lights array of the materials found during parsing.

Parameters

objectContainer3D:ObjectContainer3D — ObjectContainer3D. The target ObjectContainer3D object to be inspected.
light:LightBase — LightBase. The light to add to all materials found during the parsing of the target ObjectContainer3D.

removeStaticLightFromMaterials () method
public static function removeStaticLightFromMaterials(objectContainer3D:ObjectContainer3D, light:LightBase):void

Removes a given light from all materials found into an objectcontainer and its children.

Parameters

objectContainer3D:ObjectContainer3D — ObjectContainer3D. The target ObjectContainer3D object to be inspected.
light:LightBase — LightBase. The light to be removed from all materials found during the parsing of the target ObjectContainer3D.


away3d.tools.helpers.MeshDebugger

MeshDebugger | Properties | Methods
Package | away3d.tools.helpers
Class | public class MeshDebugger
Inheritance | MeshDebugger Inheritance Object

Helper Class for Mesh objects MeshDebugger Displays the normals, tangents and vertexNormals of a given mesh.

Public Properties
Property |  | Defined By
 | colorNormals : uint | MeshDebugger
 | colorTangents : uint | MeshDebugger
 | colorVertexNormals : uint | MeshDebugger
 | lengthNormals : Number | MeshDebugger
 | lengthTangents : Number | MeshDebugger
 | lengthVertexNormals : Number | MeshDebugger
Public Methods
Method |  | Defined By
 | debug(mesh:Mesh, scene:Scene3D, displayNormals:Boolean = true, displayVertexNormals:Boolean = false, displayTangents:Boolean = false):MeshDebugData | MeshDebugger
 | debugContainer(object:ObjectContainer3D, scene:Scene3D, displayNormals:Boolean = true, displayVertexNormals:Boolean = false, displayTangents:Boolean = false):void | MeshDebugger
 | hasDebug(mesh:Mesh):Boolean | MeshDebugger
 | hideDebug(mesh:Mesh):void | MeshDebugger
 | removeDebug(mesh:Mesh):void | MeshDebugger
 | showDebug(mesh:Mesh):void | MeshDebugger
 | update():void | MeshDebugger
Property Detail
colorNormals property
colorNormals:uint

Implementation
    public function get colorNormals():uint
    public function set colorNormals(value:uint):void
colorTangents property
colorTangents:uint

Implementation
    public function get colorTangents():uint
    public function set colorTangents(value:uint):void
colorVertexNormals property
colorVertexNormals:uint

Implementation
    public function get colorVertexNormals():uint
    public function set colorVertexNormals(value:uint):void
lengthNormals property
lengthNormals:Number

Implementation
    public function get lengthNormals():Number
    public function set lengthNormals(value:Number):void
lengthTangents property
lengthTangents:Number

Implementation
    public function get lengthTangents():Number
    public function set lengthTangents(value:Number):void
lengthVertexNormals property
lengthVertexNormals:Number

Implementation
    public function get lengthVertexNormals():Number
    public function set lengthVertexNormals(value:Number):void
Method Detail
debug () method
public function debug(mesh:Mesh, scene:Scene3D, displayNormals:Boolean = true, displayVertexNormals:Boolean = false, displayTangents:Boolean = false):MeshDebugData

Parameters

mesh:Mesh
scene:Scene3D
displayNormals:Boolean (default = true)
displayVertexNormals:Boolean (default = false)
displayTangents:Boolean (default = false)

Returns
MeshDebugData
debugContainer () method
public function debugContainer(object:ObjectContainer3D, scene:Scene3D, displayNormals:Boolean = true, displayVertexNormals:Boolean = false, displayTangents:Boolean = false):void

Parameters

object:ObjectContainer3D
scene:Scene3D
displayNormals:Boolean (default = true)
displayVertexNormals:Boolean (default = false)
displayTangents:Boolean (default = false)

hasDebug () method
public function hasDebug(mesh:Mesh):Boolean

Parameters

mesh:Mesh

Returns
Boolean
hideDebug () method
public function hideDebug(mesh:Mesh):void

Parameters

mesh:Mesh

removeDebug () method
public function removeDebug(mesh:Mesh):void

Parameters

mesh:Mesh

showDebug () method
public function showDebug(mesh:Mesh):void

Parameters

mesh:Mesh

update () method
public function update():void


away3d.tools.helpers.MeshHelper

MeshHelper | Methods
Package | away3d.tools.helpers
Class | public class MeshHelper
Inheritance | MeshHelper Inheritance Object

Helper Class for the Mesh object MeshHelper A series of methods usually usefull for mesh manipulations

Public Methods
Method |  | Defined By
 | applyPosition(mesh:Mesh, dx:Number, dy:Number, dz:Number):void [static] Applys an offset to a mesh at vertices level | MeshHelper
 | applyRotations(mesh:Mesh):void [static] Applys the rotation values of a mesh in object space and resets rotations to zero. | MeshHelper
 | applyRotationsContainer(obj:ObjectContainer3D):void [static] Applys the rotation values of each mesh found into an ObjectContainer3D | MeshHelper
 | applyScales(mesh:Mesh, scaleX:Number, scaleY:Number, scaleZ:Number, parent:ObjectContainer3D = null):void [static] Applys the scaleX, scaleY and scaleZ scale factors to the mesh vertices. | MeshHelper
 | applyScalesContainer(obj:ObjectContainer3D, scaleX:Number, scaleY:Number, scaleZ:Number, parent:ObjectContainer3D = null):void [static] Applys the scale properties values of each mesh found into an ObjectContainer3D | MeshHelper
 | boundingRadius(mesh:Mesh):Number [static] Returns the boundingRadius of an Entity of a Mesh. | MeshHelper
 | boundingRadiusContainer(container:ObjectContainer3D):Number [static] Returns the boundingRadius of a ObjectContainer3D | MeshHelper
 | build(vertices:Vector.<Number>, indices:Vector.<uint>, uvs:Vector.<Number> = null, name:String, material:MaterialBase = null, shareVertices:Boolean = true, useDefaultMap:Boolean = true):Mesh [static] Build a Mesh from Vectors | MeshHelper
 | clone(mesh:Mesh, newName:String):Mesh [static] Clones a Mesh | MeshHelper
 | invertFaces(mesh:Mesh, invertU:Boolean = false):void [static] Inverts the faces of a Mesh | MeshHelper
 | invertFacesInContainer(obj:ObjectContainer3D):void [static] Inverts the faces of all the Meshes into an ObjectContainer3D | MeshHelper
 | recenter(mesh:Mesh, keepPosition:Boolean = true):void [static] Recenter geometry | MeshHelper
 | recenterContainer(obj:ObjectContainer3D, keepPosition:Boolean = true):void [static] Recenter geometry of all meshes found into container | MeshHelper
 | splitMesh(mesh:Mesh, disposeSource:Boolean = false):Vector.<Mesh> [static] Splits the subgeometries of a given mesh in a series of new meshes | MeshHelper
Method Detail
applyPosition () method
public static function applyPosition(mesh:Mesh, dx:Number, dy:Number, dz:Number):void

Applys an offset to a mesh at vertices level

Parameters

mesh:Mesh — Mesh. The Mesh to offset
dx:Number — Number. The offset along the x axis
dy:Number — Number. The offset along the y axis
dz:Number — Number. The offset along the z axis

applyRotations () method
public static function applyRotations(mesh:Mesh):void

Applys the rotation values of a mesh in object space and resets rotations to zero.

Parameters

mesh:Mesh — Mesh. The Mesh to alter

applyRotationsContainer () method
public static function applyRotationsContainer(obj:ObjectContainer3D):void

Applys the rotation values of each mesh found into an ObjectContainer3D

Parameters

obj:ObjectContainer3D — ObjectContainer3D. The ObjectContainer3D to alter

applyScales () method
public static function applyScales(mesh:Mesh, scaleX:Number, scaleY:Number, scaleZ:Number, parent:ObjectContainer3D = null):void

Applys the scaleX, scaleY and scaleZ scale factors to the mesh vertices. Resets the mesh scaleX, scaleY and scaleZ properties to 1;

Parameters

mesh:Mesh — Mesh. The Mesh to rescale
scaleX:Number — Number. The scale factor to apply on all vertices x values.
scaleY:Number — Number. The scale factor to apply on all vertices y values.
scaleZ:Number — Number. The scale factor to apply on all vertices z values.
parent:ObjectContainer3D (default = null) — ObjectContainer3D. If a parent is set, the position of children is also scaled

applyScalesContainer () method
public static function applyScalesContainer(obj:ObjectContainer3D, scaleX:Number, scaleY:Number, scaleZ:Number, parent:ObjectContainer3D = null):void

Applys the scale properties values of each mesh found into an ObjectContainer3D

Parameters

obj:ObjectContainer3D — ObjectContainer3D. The ObjectContainer3D to alter
scaleX:Number — Number. The scale factor to apply on all vertices x values.
scaleY:Number — Number. The scale factor to apply on all vertices y values.
scaleZ:Number — Number. The scale factor to apply on all vertices z values.
parent:ObjectContainer3D (default = null)

boundingRadius () method
public static function boundingRadius(mesh:Mesh):Number

Returns the boundingRadius of an Entity of a Mesh.

Parameters

mesh:Mesh — Mesh. The mesh to get the boundingRadius from.

Returns
Number
boundingRadiusContainer () method
public static function boundingRadiusContainer(container:ObjectContainer3D):Number

Returns the boundingRadius of a ObjectContainer3D

Parameters

container:ObjectContainer3D — ObjectContainer3D. The ObjectContainer3D and its children to get the boundingRadius from.

Returns
Number
build () method
public static function build(vertices:Vector.<Number>, indices:Vector.<uint>, uvs:Vector.<Number> = null, name:String, material:MaterialBase = null, shareVertices:Boolean = true, useDefaultMap:Boolean = true):Mesh

Build a Mesh from Vectors

Parameters

vertices:Vector.<Number> — Vector.<Number>. The vertices Vector.<Number>, must hold a multiple of 3 numbers.
indices:Vector.<uint> — Vector.<uint>. The indices Vector.<uint>, holding the face order
uvs:Vector.<Number> (default = null) — [optional] Vector.<Number>. The uvs Vector, must hold a series of numbers of (vertices.length/3 2) entries. If none is set, default uv's are applied if no uv's are defined, default uv mapping is set.
name:String — [optional] String. new name for the generated mesh. Default = "";
material:MaterialBase (default = null) — [optional] MaterialBase. new name for the duplicated mesh. Default = null;
shareVertices:Boolean (default = true) — [optional] Boolean. Defines if the vertices are shared or not. When true surface gets a smoother appearance when exposed to light. Default = true;
useDefaultMap:Boolean (default = true) — [optional] Boolean. Defines if the mesh receives the default engine map if no material is passes. Default = true;

Returns
Mesh
clone () method
public static function clone(mesh:Mesh, newName:String):Mesh

Clones a Mesh

Parameters

mesh:Mesh — Mesh. The mesh to clone
newName:String — [optional] String. new name for the duplicated mesh. Default = "";

Returns
Mesh
invertFaces () method
public static function invertFaces(mesh:Mesh, invertU:Boolean = false):void

Inverts the faces of a Mesh

Parameters

mesh:Mesh — Mesh. The Mesh to invert.
invertU:Boolean (default = false) — Boolean. If the uvs are inverted too. Default is false;

invertFacesInContainer () method
public static function invertFacesInContainer(obj:ObjectContainer3D):void

Inverts the faces of all the Meshes into an ObjectContainer3D

Parameters

obj:ObjectContainer3D — ObjectContainer3D. The ObjectContainer3D to invert.

recenter () method
public static function recenter(mesh:Mesh, keepPosition:Boolean = true):void

Recenter geometry

Parameters

mesh:Mesh — Mesh. The Mesh to recenter in its own objectspace
keepPosition:Boolean (default = true) — Boolean. KeepPosition applys the offset to the object position. Object is "visually" at same position.

recenterContainer () method
public static function recenterContainer(obj:ObjectContainer3D, keepPosition:Boolean = true):void

Recenter geometry of all meshes found into container

Parameters

obj:ObjectContainer3D — Mesh. The Mesh to recenter in its own objectspace
keepPosition:Boolean (default = true) — Boolean. KeepPosition applys the offset to the object position. Object is "visually" at same position.

splitMesh () method
public static function splitMesh(mesh:Mesh, disposeSource:Boolean = false):Vector.<Mesh>

Splits the subgeometries of a given mesh in a series of new meshes

Parameters

mesh:Mesh — Mesh. The mesh to split in a series of independant meshes from its subgeometries.
disposeSource:Boolean (default = false) — Boolean. If the mesh source must be destroyed after the split. Default is false;

Returns
Vector.<Mesh>


away3d.tools.helpers.ParticleGeometryHelper

ParticleGeometryHelper | Methods | Constants
Package | away3d.tools.helpers
Class | public class ParticleGeometryHelper
Inheritance | ParticleGeometryHelper Inheritance Object

...

Public Methods
Method |  | Defined By
 | generateGeometry(geometries:Vector.<Geometry>, transforms:Vector.<ParticleGeometryTransform> = null):ParticleGeometry [static] | ParticleGeometryHelper
Public Constants
Constant |  | Defined By
 | MAX_VERTEX : int = 65535 [static] | ParticleGeometryHelper
Method Detail
generateGeometry () method
public static function generateGeometry(geometries:Vector.<Geometry>, transforms:Vector.<ParticleGeometryTransform> = null):ParticleGeometry

Parameters

geometries:Vector.<Geometry>
transforms:Vector.<ParticleGeometryTransform> (default = null)

Returns
ParticleGeometry
Constant Detail
MAX_VERTEX Constant
public static const MAX_VERTEX:int = 65535


away3d.tools.helpers.data - Away3D Documentation

Package away3d.tools.helpers.data

Classes
MeshDebug
ParticleGeometryTransform


away3d.tools.helpers.data Summary

away3d.tools.helpers.data | Classes

Classes
Class | Description
MeshDebug | MeshDebug, holds the data for the MeshDebugger class
ParticleGeometryTransform | ...

Thu Nov 15 2012, 12:09 PM Z


away3d.tools.helpers.data.MeshDebug

MeshDebug | Properties | Methods | Events | Constants
Package | away3d.tools.helpers.data
Class | public class MeshDebug
Inheritance | MeshDebug Inheritance SegmentSet Inheritance Entity Inheritance ObjectContainer3D Inheritance Object3D Inheritance NamedAssetBase Inheritance flash.events.EventDispatcher

MeshDebug, holds the data for the MeshDebugger class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | animator : IAnimator [read-only] | SegmentSet
Inherited | assetFullPath : Array [read-only] | NamedAssetBase
Inherited | assetNamespace : String [read-only] | NamedAssetBase
Inherited | assetType : String [override] [read-only] | SegmentSet
Inherited | backVector : Vector3D [read-only] | Object3D
Inherited | bounds : BoundingVolumeBase The bounding volume approximating the volume occupied by the Entity. | Entity
Inherited | castsShadows : Boolean [read-only] | SegmentSet
Inherited | downVector : Vector3D [read-only] | Object3D
Inherited | eulers : Vector3D Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis. | Object3D
Inherited | extra : Object An object that can contain any extra data. | Object3D
Inherited | forwardVector : Vector3D [read-only] | Object3D
Inherited | ignoreTransform : Boolean [override] | Entity
Inherited | indexData : Vector.<uint> [read-only] | SegmentSet
Inherited | inverseSceneTransform : Matrix3D [read-only] The inverse scene transform object that transforms from world to model space. | ObjectContainer3D
Inherited | leftVector : Vector3D [read-only] | Object3D
Inherited | material : MaterialBase | SegmentSet
Inherited | maxX : Number [override] [read-only] The maximum extremum of the object along the X-axis. | Entity
Inherited | maxY : Number [override] [read-only] The maximum extremum of the object along the Y-axis. | Entity
Inherited | maxZ : Number [override] [read-only] The maximum extremum of the object along the Z-axis. | Entity
Inherited | minX : Number [override] [read-only] The minimum extremum of the object along the X-axis. | Entity
Inherited | minY : Number [override] [read-only] The minimum extremum of the object along the Y-axis. | Entity
Inherited | minZ : Number [override] [read-only] The minimum extremum of the object along the Z-axis. | Entity
Inherited | modelViewProjection : Matrix3D [read-only] The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space. | Entity
Inherited | mouseChildren : Boolean | ObjectContainer3D
Inherited | mouseEnabled : Boolean [override] | SegmentSet
Inherited | name : String | NamedAssetBase
Inherited | numChildren : uint [read-only] The amount of child objects of the ObjectContainer3D. | ObjectContainer3D
Inherited | numTriangles : uint [read-only] | SegmentSet
Inherited | numVertices : uint [read-only] | SegmentSet
Inherited | originalName : String [read-only] The original name used for this asset in the resource (e.g. | NamedAssetBase
Inherited | parent : ObjectContainer3D [read-only] The parent ObjectContainer3D to which this object's transformation is relative. | ObjectContainer3D
Inherited | partition : Partition3D The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned. | ObjectContainer3D
Inherited | pickingCollider : IPickingCollider Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | pickingCollisionVO : PickingCollisionVO [read-only] Returns a unique picking collision value object for the entity. | Entity
Inherited | pivotPoint : Vector3D Defines the local point around which the object rotates. | Object3D
Inherited | position : Vector3D Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rightVector : Vector3D [read-only] | Object3D
Inherited | rotationX : Number Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationY : Number Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | rotationZ : Number Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | scaleX : Number Defines the scale of the 3d object along the x-axis, relative to local coordinates. | Object3D
Inherited | scaleY : Number Defines the scale of the 3d object along the y-axis, relative to local coordinates. | Object3D
Inherited | scaleZ : Number Defines the scale of the 3d object along the z-axis, relative to local coordinates. | Object3D
Inherited | scene : Scene3D [override] A reference to the Scene3D object to which this object belongs. | Entity
Inherited | scenePosition : Vector3D [read-only] The global position of the ObjectContainer3D in the scene. | ObjectContainer3D
Inherited | sceneTransform : Matrix3D [read-only] The transformation matrix that transforms from model to world space. | ObjectContainer3D
Inherited | shaderPickingDetails : Boolean Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value. | Entity
Inherited | showBounds : Boolean | Entity
Inherited | sourceEntity : Entity [read-only] | SegmentSet
Inherited | staticNode : Boolean Defines whether or not the object will be moved or animated at runtime. | Entity
Inherited | transform : Matrix3D The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | upVector : Vector3D [read-only] | Object3D
Inherited | UVData : Vector.<Number> [read-only] | SegmentSet
Inherited | uvTransform : Matrix [read-only] | SegmentSet
Inherited | vertexData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexNormalOffset : int [read-only] | SegmentSet
Inherited | vertexOffset : int [read-only] | SegmentSet
Inherited | vertexStride : uint [read-only] | SegmentSet
Inherited | vertexTangentData : Vector.<Number> [read-only] | SegmentSet
Inherited | vertexTangentOffset : int [read-only] | SegmentSet
Inherited | visible : Boolean | ObjectContainer3D
Inherited | x : Number Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | y : Number Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Inherited | z : Number Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D. | Object3D
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | _bounds : BoundingVolumeBase | Entity
Inherited | _boundsInvalid : Boolean = true | Entity
Inherited | _explicitPartition : Partition3D | ObjectContainer3D
Inherited | _ignoreTransform : Boolean = false | ObjectContainer3D
Inherited | _implicitPartition : Partition3D | ObjectContainer3D
Inherited | _mouseEnabled : Boolean | ObjectContainer3D
Inherited | _mvpIndex : int = -1 | Entity
Inherited | _mvpTransformStack : Vector.<Matrix3D> | Entity
Inherited | _parent : ObjectContainer3D | ObjectContainer3D
Inherited | _pivotPoint : Vector3D | Object3D
Inherited | _pivotZero : Boolean = true | Object3D
Inherited | _pos : Vector3D | Object3D
Inherited | _rot : Vector3D | Object3D
Inherited | _sca : Vector3D | Object3D
Inherited | _scaleX : Number = 1 | Object3D
Inherited | _scaleY : Number = 1 | Object3D
Inherited | _scaleZ : Number = 1 | Object3D
Inherited | _scene : Scene3D | ObjectContainer3D
Inherited | _sceneTransform : Matrix3D | ObjectContainer3D
Inherited | _sceneTransformDirty : Boolean = true | ObjectContainer3D
Inherited | _segments : Vector.<Segment> | SegmentSet
Inherited | _stackLen : uint | Entity
Inherited | _transform : Matrix3D | Object3D
Inherited | _transformComponents : Vector.<Vector3D> | Object3D
Inherited | _x : Number = 0 | Object3D
Inherited | _y : Number = 0 | Object3D
Inherited | _z : Number = 0 | Object3D
Inherited | _zIndices : Vector.<Number> | Entity
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
Inherited | activateSecondaryUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateUVBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexNormalBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | activateVertexTangentBuffer(index:int, stage3DProxy:Stage3DProxy):void | SegmentSet
Inherited | addChild(child:ObjectContainer3D):ObjectContainer3D Adds a child ObjectContainer3D to the current object. | ObjectContainer3D
Inherited | addChildren(... childarray):void Adds an array of 3d objects to the scene as children of the container | ObjectContainer3D
Inherited | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void [override] | ObjectContainer3D
Inherited | addSegment(segment:Segment):void | SegmentSet
Inherited | assetPathEquals(name:String, ns:String):Boolean | NamedAssetBase
 | clearAll():void | MeshDebug
Inherited | clone():Object3D [override] Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.) | ObjectContainer3D
Inherited | contains(child:ObjectContainer3D):Boolean | ObjectContainer3D
Inherited | dispatchEvent(event:Event):Boolean [override] | ObjectContainer3D
 | displayNormals(mesh:Mesh, color:uint = 0xFF3399, length:Number = 30):void | MeshDebug
 | displayTangents(mesh:Mesh, color:uint = 0xFFCC00, length:Number = 30):void | MeshDebug
 | displayVertexNormals(mesh:Mesh, color:uint = 0x66CCFF, length:Number = 30):void | MeshDebug
Inherited | dispose():void [override] | SegmentSet
Inherited | disposeAsset():void | Object3D
Inherited | getChildAt(index:uint):ObjectContainer3D Retrieves the child object at the given index. | ObjectContainer3D
Inherited | getEntityPartitionNode():EntityNode Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance | Entity
Inherited | getIndexBuffer(stage3DProxy:Stage3DProxy):IndexBuffer3D | SegmentSet
Inherited | getSegment(index:uint):Segment | SegmentSet
Inherited | lookAt(target:Vector3D, upAxis:Vector3D = null):void [override] Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D. | ObjectContainer3D
Inherited | moveBackward(distance:Number):void Moves the 3d object backwards along it's local z axis | Object3D
Inherited | moveDown(distance:Number):void Moves the 3d object backwards along it's local y axis | Object3D
Inherited | moveForward(distance:Number):void Moves the 3d object forwards along it's local z axis | Object3D
Inherited | moveLeft(distance:Number):void Moves the 3d object backwards along it's local x axis | Object3D
Inherited | movePivot(dx:Number, dy:Number, dz:Number):void Moves the local point around which the object rotates. | Object3D
Inherited | moveRight(distance:Number):void Moves the 3d object forwards along it's local x axis | Object3D
Inherited | moveTo(dx:Number, dy:Number, dz:Number):void Moves the 3d object directly to a point in space | Object3D
Inherited | moveUp(distance:Number):void Moves the 3d object forwards along it's local y axis | Object3D
Inherited | pitch(angle:Number):void Rotates the 3d object around it's local x-axis | Object3D
Inherited | popModelViewProjection():void Removes a model view projection matrix from the stack, used when leaving a render. | Entity
Inherited | pushModelViewProjection(camera:Camera3D, updateZIndex:Boolean = true):void Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack. | Entity
Inherited | removeAllSegments():void | SegmentSet
Inherited | removeChild(child:ObjectContainer3D):void Removes a 3d object from the child array of the container | ObjectContainer3D
Inherited | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void [override] | ObjectContainer3D
Inherited | removeSegment(segment:Segment):void | SegmentSet
Inherited | resetAssetPath(name:String, ns:String = null, overrideOriginal:Boolean = true):void | NamedAssetBase
Inherited | roll(angle:Number):void Rotates the 3d object around it's local z-axis | Object3D
Inherited | rotate(axis:Vector3D, angle:Number):void [override] | ObjectContainer3D
Inherited | rotateTo(ax:Number, ay:Number, az:Number):void Rotates the 3d object directly to a euler angle | Object3D
Inherited | scale(value:Number):void Appends a uniform scale to the current transformation. | Object3D
Inherited | translate(axis:Vector3D, distance:Number):void Moves the 3d object along a vector by a defined length | Object3D
Inherited | translateLocal(axis:Vector3D, distance:Number):void [override] | ObjectContainer3D
Inherited | updateImplicitVisibility():void | ObjectContainer3D
Inherited | yaw(angle:Number):void Rotates the 3d object around it's local y-axis | Object3D
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | createEntityPartitionNode():EntityNode [override] | SegmentSet
Inherited | getDefaultBoundingVolume():BoundingVolumeBase [override] | SegmentSet
Inherited | invalidateBounds():void Invalidates the bounding volume, causing to be updated when requested. | Entity
Inherited | invalidateSceneTransform():void [override] Invalidates the scene transformation matrix, causing it to be updated the next time it's requested. | Entity
Inherited | updateBounds():void [override] | SegmentSet
Inherited | updateMouseChildren():void [override] | Entity
Inherited | updateSceneTransform():void Updates the scene transformation matrix. | ObjectContainer3D
Inherited | updateTransform():void | Object3D
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | mouseDown3d | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | mouseMove3d | Dispatched when a user moves the cursor while it is over the 3d object. | ObjectContainer3D
Inherited | mouseOut3d | Dispatched when a user moves the cursor away from the 3d object. | ObjectContainer3D
Inherited | mouseOver3d | Dispatched when a user moves the cursor over the 3d object. | ObjectContainer3D
Inherited | mouseUp3d | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object. | ObjectContainer3D
Inherited | positionChanged | Dispatched when the position of the 3d object changes. | Object3D
Inherited | rotationChanged | Dispatched when the rotation of the 3d object changes. | Object3D
Inherited | scaleChanged | Dispatched when the scale of the 3d object changes. | Object3D
Inherited | sceneChanged | Dispatched when the parent scene of the 3d object changes. | ObjectContainer3D
Inherited | scenetransformChanged | Dispatched when the scene transform matrix of the 3d object changes. | ObjectContainer3D
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | DEFAULT_NAMESPACE : String = default [static] | NamedAssetBase
Method Detail
clearAll () method
public function clearAll():void

displayNormals () method
public function displayNormals(mesh:Mesh, color:uint = 0xFF3399, length:Number = 30):void

Parameters

mesh:Mesh
color:uint (default = 0xFF3399)
length:Number (default = 30)

displayTangents () method
public function displayTangents(mesh:Mesh, color:uint = 0xFFCC00, length:Number = 30):void

Parameters

mesh:Mesh
color:uint (default = 0xFFCC00)
length:Number (default = 30)

displayVertexNormals () method
public function displayVertexNormals(mesh:Mesh, color:uint = 0x66CCFF, length:Number = 30):void

Parameters

mesh:Mesh
color:uint (default = 0x66CCFF)
length:Number (default = 30)


away3d.tools.helpers.data.ParticleGeometryTransform

ParticleGeometryTransform | Properties
Package | away3d.tools.helpers.data
Class | public class ParticleGeometryTransform
Inheritance | ParticleGeometryTransform Inheritance Object

...

Public Properties
Property |  | Defined By
 | invVertexTransform : Matrix3D [read-only] | ParticleGeometryTransform
 | UVTransform : Matrix | ParticleGeometryTransform
 | vertexTransform : Matrix3D | ParticleGeometryTransform
Property Detail
invVertexTransform property
invVertexTransform:Matrix3D [read-only]

Implementation
    public function get invVertexTransform():Matrix3D
UVTransform property
UVTransform:Matrix

Implementation
    public function get UVTransform():Matrix
    public function set UVTransform(value:Matrix):void
vertexTransform property
vertexTransform:Matrix3D

Implementation
    public function get vertexTransform():Matrix3D
    public function set vertexTransform(value:Matrix3D):void


away3d.tools.serialize - Away3D Documentation

Package away3d.tools.serialize

Classes
Serialize
SerializerBase
TraceSerializer


away3d.tools.serialize Summary

away3d.tools.serialize | Classes

Classes
Class | Description
Serialize |
SerializerBase | SerializerBase is the abstract class for all Serializers.
TraceSerializer | TraceSerializer is a concrete Serializer that will output its results to trace().

Thu Nov 15 2012, 12:09 PM Z


away3d.tools.serialize.Serialize

Serialize | Properties | Methods
Package | away3d.tools.serialize
Class | public class Serialize
Inheritance | Serialize Inheritance Object

Public Properties
Property |  | Defined By
 | tabSize : uint = 2 [static] | Serialize
Public Methods
Method |  | Defined By
 | Serialize() | Serialize
 | serializeAnimationState(animator:IAnimator, serializer:SerializerBase):void [static] | Serialize
 | serializeAnimator(animator:IAnimator, serializer:SerializerBase):void [static] | Serialize
 | serializeJointPose(jointPose:JointPose, serializer:SerializerBase):void [static] | Serialize
 | serializeMaterial(material:MaterialBase, serializer:SerializerBase):void [static] | Serialize
 | serializeMesh(mesh:Mesh, serializer:SerializerBase):void [static] | Serialize
 | serializeObjectContainer(objectContainer3D:ObjectContainer3D, serializer:SerializerBase):void [static] | Serialize
 | serializeScene(scene:Scene3D, serializer:SerializerBase):void [static] | Serialize
 | serializeSkeleton(skeleton:Skeleton, serializer:SerializerBase):void [static] | Serialize
 | serializeSkeletonJoint(skeletonJoint:SkeletonJoint, serializer:SerializerBase):void [static] | Serialize
 | serializeSkeletonPose(skeletonPose:SkeletonPose, serializer:SerializerBase):void [static] | Serialize
 | serializeSubGeometry(subGeometry:ISubGeometry, serializer:SerializerBase):void [static] | Serialize
 | serializeSubMesh(subMesh:SubMesh, serializer:SerializerBase):void [static] | Serialize
Property Detail
tabSize property
public static var tabSize:uint = 2

Constructor Detail
Serialize () Constructor
public function Serialize()

Method Detail
serializeAnimationState () method
public static function serializeAnimationState(animator:IAnimator, serializer:SerializerBase):void

Parameters

animator:IAnimator
serializer:SerializerBase

serializeAnimator () method
public static function serializeAnimator(animator:IAnimator, serializer:SerializerBase):void

Parameters

animator:IAnimator
serializer:SerializerBase

serializeJointPose () method
public static function serializeJointPose(jointPose:JointPose, serializer:SerializerBase):void

Parameters

jointPose:JointPose
serializer:SerializerBase

serializeMaterial () method
public static function serializeMaterial(material:MaterialBase, serializer:SerializerBase):void

Parameters

material:MaterialBase
serializer:SerializerBase

serializeMesh () method
public static function serializeMesh(mesh:Mesh, serializer:SerializerBase):void

Parameters

mesh:Mesh
serializer:SerializerBase

serializeObjectContainer () method
public static function serializeObjectContainer(objectContainer3D:ObjectContainer3D, serializer:SerializerBase):void

Parameters

objectContainer3D:ObjectContainer3D
serializer:SerializerBase

serializeScene () method
public static function serializeScene(scene:Scene3D, serializer:SerializerBase):void

Parameters

scene:Scene3D
serializer:SerializerBase

serializeSkeleton () method
public static function serializeSkeleton(skeleton:Skeleton, serializer:SerializerBase):void

Parameters

skeleton:Skeleton
serializer:SerializerBase

serializeSkeletonJoint () method
public static function serializeSkeletonJoint(skeletonJoint:SkeletonJoint, serializer:SerializerBase):void

Parameters

skeletonJoint:SkeletonJoint
serializer:SerializerBase

serializeSkeletonPose () method
public static function serializeSkeletonPose(skeletonPose:SkeletonPose, serializer:SerializerBase):void

Parameters

skeletonPose:SkeletonPose
serializer:SerializerBase

serializeSubGeometry () method
public static function serializeSubGeometry(subGeometry:ISubGeometry, serializer:SerializerBase):void

Parameters

subGeometry:ISubGeometry
serializer:SerializerBase

serializeSubMesh () method
public static function serializeSubMesh(subMesh:SubMesh, serializer:SerializerBase):void

Parameters

subMesh:SubMesh
serializer:SerializerBase


away3d.tools.serialize.SerializerBase

SerializerBase | Methods
Package | away3d.tools.serialize
Class | public class SerializerBase
Inheritance | SerializerBase Inheritance Object
Subclasses | TraceSerializer

SerializerBase is the abstract class for all Serializers. It provides an interface for basic data type writing. It is not intended for reading.

See also

away3d.tools.serialize.Serialize

Public Methods
Method |  | Defined By
 | SerializerBase() Creates a new SerializerBase object. | SerializerBase
 | beginObject(className:String, instanceName:String):void Begin object serialization. | SerializerBase
 | endObject():void End object serialization | SerializerBase
 | writeBoolean(name:String, value:Boolean):void Serialize Boolean | SerializerBase
 | writeInt(name:String, value:int):void Serialize int | SerializerBase
 | writeQuaternion(name:String, value:Quaternion):void Serialize Quaternion | SerializerBase
 | writeString(name:String, value:String):void Serialize String | SerializerBase
 | writeTransform(name:String, value:Vector.<Number>):void Serialize Transform, in the form of Vector.<Number> | SerializerBase
 | writeUint(name:String, value:uint):void Serialize uint | SerializerBase
 | writeVector3D(name:String, value:Vector3D):void Serialize Vector3D | SerializerBase
Constructor Detail
SerializerBase () Constructor
public function SerializerBase()

Creates a new SerializerBase object.

Method Detail
beginObject () method
public function beginObject(className:String, instanceName:String):void

Begin object serialization. Output className and instanceName.

Parameters

className:String — name of class being serialized
instanceName:String — name of instance being serialized

endObject () method
public function endObject():void

End object serialization

writeBoolean () method
public function writeBoolean(name:String, value:Boolean):void

Serialize Boolean

Parameters

name:String — name of value being serialized
value:Boolean — value being serialized

writeInt () method
public function writeInt(name:String, value:int):void

Serialize int

Parameters

name:String — name of value being serialized
value:int — value being serialized

writeQuaternion () method
public function writeQuaternion(name:String, value:Quaternion):void

Serialize Quaternion

Parameters

name:String — name of value being serialized
value:Quaternion — value being serialized

writeString () method
public function writeString(name:String, value:String):void

Serialize String

Parameters

name:String — name of value being serialized
value:String — value being serialized

writeTransform () method
public function writeTransform(name:String, value:Vector.<Number>):void

Serialize Transform, in the form of Vector.<Number>

Parameters

name:String — name of value being serialized
value:Vector.<Number> — value being serialized

writeUint () method
public function writeUint(name:String, value:uint):void

Serialize uint

Parameters

name:String — name of value being serialized
value:uint — value being serialized

writeVector3D () method
public function writeVector3D(name:String, value:Vector3D):void

Serialize Vector3D

Parameters

name:String — name of value being serialized
value:Vector3D — value being serialized


away3d.tools.serialize.TraceSerializer

TraceSerializer | Properties | Methods
Package | away3d.tools.serialize
Class | public class TraceSerializer
Inheritance | TraceSerializer Inheritance SerializerBase Inheritance Object

TraceSerializer is a concrete Serializer that will output its results to trace(). It has user settable tabSize and separator vars.

See also

away3d.tools.serialize.Serialize

Public Properties
Property |  | Defined By
 | separator : String = : | TraceSerializer
 | tabSize : uint = 2 | TraceSerializer
Public Methods
Method |  | Defined By
 | TraceSerializer() Creates a new TraceSerializer object. | TraceSerializer
 | beginObject(className:String, instanceName:String):void [override] Begin object serialization. | TraceSerializer
 | endObject():void [override] End object serialization | TraceSerializer
 | writeBoolean(name:String, value:Boolean):void [override] Serialize Boolean | TraceSerializer
 | writeInt(name:String, value:int):void [override] Serialize int | TraceSerializer
 | writeQuaternion(name:String, value:Quaternion):void [override] Serialize Quaternion | TraceSerializer
 | writeString(name:String, value:String):void [override] Serialize String | TraceSerializer
 | writeTransform(name:String, value:Vector.<Number>):void [override] Serialize Transform, in the form of Vector.<Number> | TraceSerializer
 | writeUint(name:String, value:uint):void [override] Serialize uint | TraceSerializer
 | writeVector3D(name:String, value:Vector3D):void [override] Serialize Vector3D | TraceSerializer
Property Detail
separator property
public var separator:String = :

tabSize property
public var tabSize:uint = 2

Constructor Detail
TraceSerializer () Constructor
public function TraceSerializer()

Creates a new TraceSerializer object.

Method Detail
beginObject () method
override public function beginObject(className:String, instanceName:String):void

Begin object serialization. Output className and instanceName.

Parameters

className:String — name of class being serialized
instanceName:String — name of instance being serialized

endObject () method
override public function endObject():void

End object serialization

writeBoolean () method
override public function writeBoolean(name:String, value:Boolean):void

Serialize Boolean

Parameters

name:String — name of value being serialized
value:Boolean — value being serialized

writeInt () method
override public function writeInt(name:String, value:int):void

Serialize int

Parameters

name:String — name of value being serialized
value:int — value being serialized

writeQuaternion () method
override public function writeQuaternion(name:String, value:Quaternion):void

Serialize Quaternion

Parameters

name:String — name of value being serialized
value:Quaternion — value being serialized

writeString () method
override public function writeString(name:String, value:String):void

Serialize String

Parameters

name:String — name of value being serialized
value:String — value being serialized

writeTransform () method
override public function writeTransform(name:String, value:Vector.<Number>):void

Serialize Transform, in the form of Vector.<Number>

Parameters

name:String — name of value being serialized
value:Vector.<Number> — value being serialized

writeUint () method
override public function writeUint(name:String, value:uint):void

Serialize uint

Parameters

name:String — name of value being serialized
value:uint — value being serialized

writeVector3D () method
override public function writeVector3D(name:String, value:Vector3D):void

Serialize Vector3D

Parameters

name:String — name of value being serialized
value:Vector3D — value being serialized


away3d.tools.utils - Away3D Documentation

Package away3d.tools.utils

Classes
Bounds
ColorHitMap
Drag3D
GeomUtil
Grid
Projector
Ray
TextureUtils


away3d.tools.utils Summary

away3d.tools.utils | Classes

Classes
Class | Description
Bounds | Helper Class to retrieve objects bounds Bounds
ColorHitMap |
Drag3D | Class Drag3D allows free dragging of an ObjectContainer3D onto a given plane.
GeomUtil |
Grid | Class Grid snaps vertexes or meshes according to a given grid unit.Grid
Projector |
Ray |
TextureUtils |

Thu Nov 15 2012, 12:09 PM Z


away3d.tools.utils.Bounds

Bounds | Properties | Methods
Package | away3d.tools.utils
Class | public class Bounds
Inheritance | Bounds Inheritance Object

Helper Class to retrieve objects bounds Bounds

Public Properties
Property |  | Defined By
 | depth : Number [static] [read-only] | Bounds
 | height : Number [static] [read-only] | Bounds
 | maxX : Number [static] [read-only] | Bounds
 | maxY : Number [static] [read-only] | Bounds
 | maxZ : Number [static] [read-only] | Bounds
 | minX : Number [static] [read-only] | Bounds
 | minY : Number [static] [read-only] | Bounds
 | minZ : Number [static] [read-only] | Bounds
 | width : Number [static] [read-only] | Bounds
Public Methods
Method |  | Defined By
 | getMeshBounds(mesh:Mesh):void [static] Calculate the bounds of a Mesh object | Bounds
 | getObjectContainerBounds(container:ObjectContainer3D):void [static] Calculate the bounds of an ObjectContainer3D object | Bounds
 | getVerticesVectorBounds(vertices:Vector.<Number>):void [static] Calculate the bounds from a vector of number representing the vertices. | Bounds
Property Detail
depth property
depth:Number [read-only]

Implementation
    public static function get depth():Number
height property
height:Number [read-only]

Implementation
    public static function get height():Number
maxX property
maxX:Number [read-only]

Implementation
    public static function get maxX():Number
maxY property
maxY:Number [read-only]

Implementation
    public static function get maxY():Number
maxZ property
maxZ:Number [read-only]

Implementation
    public static function get maxZ():Number
minX property
minX:Number [read-only]

Implementation
    public static function get minX():Number
minY property
minY:Number [read-only]

Implementation
    public static function get minY():Number
minZ property
minZ:Number [read-only]

Implementation
    public static function get minZ():Number
width property
width:Number [read-only]

Implementation
    public static function get width():Number
Method Detail
getMeshBounds () method
public static function getMeshBounds(mesh:Mesh):void

Calculate the bounds of a Mesh object

Parameters

mesh:Mesh — Mesh. The Mesh to get the bounds from. Use the getters of this class to retrieve the results

getObjectContainerBounds () method
public static function getObjectContainerBounds(container:ObjectContainer3D):void

Calculate the bounds of an ObjectContainer3D object

Parameters

container:ObjectContainer3D — ObjectContainer3D. The ObjectContainer3D to get the bounds from. Use the getters of this class to retrieve the results

getVerticesVectorBounds () method
public static function getVerticesVectorBounds(vertices:Vector.<Number>):void

Calculate the bounds from a vector of number representing the vertices. <x,y,z,x,y,z.....>

Parameters

vertices:Vector.<Number> — Vector.<Number>. The vertices to get the bounds from. Use the getters of this class to retrieve the results


away3d.tools.utils.ColorHitMap

ColorHitMap | Properties | Methods
Package | away3d.tools.utils
Class | public class ColorHitMap
Inheritance | ColorHitMap Inheritance flash.events.EventDispatcher

Public Properties
Property |  | Defined By
 | bitmapData : BitmapData The source bitmapdata uses for colour readings | ColorHitMap
 | offsetX : Number The offsetX, offsetY by default offsetX and offsetY represent the center of the map. | ColorHitMap
 | offsetY : Number | ColorHitMap
 | scaleX : Number defines the scaleX and scaleY. | ColorHitMap
 | scaleY : Number | ColorHitMap
Public Methods
Method |  | Defined By
 | ColorHitMap(bitmapData:BitmapData, scaleX:Number = 1, scaleY:Number = 1) Creates a new ColorHitMap | ColorHitMap
 | addColorEvent(color:Number, eventID:String, listener:Function):void Defines a color event for this class. | ColorHitMap
 | getColorAt(x:Number, y:Number):uint returns the color at x,y coordinates. | ColorHitMap
 | plotAt(x:Number, y:Number, color:uint = 0xFF0000):void Another method for debug, if you addChild your bitmapdata on screen, this method will colour a pixel at the coordinates helping you to visualize if your scale factors or entered coordinates are correct. | ColorHitMap
 | read(x:Number, y:Number):void If at the given coordinates a color is found that matches a defined color event, the color event will be triggered. | ColorHitMap
 | removeColorEvent(eventID:String):void removes a color event by its id | ColorHitMap
Property Detail
bitmapData property
bitmapData:BitmapData

The source bitmapdata uses for colour readings

Implementation
    public function get bitmapData():BitmapData
    public function set bitmapData(value:BitmapData):void
offsetX property
offsetX:Number

The offsetX, offsetY by default offsetX and offsetY represent the center of the map.

Implementation
    public function get offsetX():Number
    public function set offsetX(value:Number):void
offsetY property
offsetY:Number

Implementation
    public function get offsetY():Number
    public function set offsetY(value:Number):void
scaleX property
scaleX:Number

defines the scaleX and scaleY. Defines the ratio map to the 3d world

Implementation
    public function get scaleX():Number
    public function set scaleX(value:Number):void
scaleY property
scaleY:Number

Implementation
    public function get scaleY():Number
    public function set scaleY(value:Number):void
Constructor Detail
ColorHitMap () Constructor
public function ColorHitMap(bitmapData:BitmapData, scaleX:Number = 1, scaleY:Number = 1)

Creates a new ColorHitMap

Parameters
bitmapData:BitmapData — The bitmapdata with color regions to act as trigger.
scaleX:Number (default = 1) — [optional] A factor scale along the X axis. Default is 1.
scaleY:Number (default = 1) — [optional] A factor scale along the Y axis. Default is 1. Note that by default the class is considered as centered, like a plane at 0,0,0. Also by default coordinates offset are set. If a map of 256x256 is set, and no custom offsets are set. The read method using the camera position -128 x and -128 z would return the color value found at 0,0 on the map.
Method Detail
addColorEvent () method
public function addColorEvent(color:Number, eventID:String, listener:Function):void

Defines a color event for this class. If read method is called, and the target pixel color has the same value as a previously set listener, an event is triggered.

Parameters

color:Number — A color Number
eventID:String — A string to identify that event
listener:Function — The function that must be triggered

getColorAt () method
public function getColorAt(x:Number, y:Number):uint

returns the color at x,y coordinates. This method is made to test if the color is indeed the expected one, (the one you set for an event), as due to compression for instance using the Flash IDE library, compression might have altered the color values.

Parameters

x:Number — X coordinate on the source bitmapData
y:Number — Y coordinate on the source bitmapData

Returns
uint — A uint, the color value at coordinates x, y

See also

plotAt
plotAt () method
public function plotAt(x:Number, y:Number, color:uint = 0xFF0000):void

Another method for debug, if you addChild your bitmapdata on screen, this method will colour a pixel at the coordinates helping you to visualize if your scale factors or entered coordinates are correct.

Parameters

x:Number — X coordinate on the source bitmapData
y:Number — Y coordinate on the source bitmapData
color:uint (default = 0xFF0000)

read () method
public function read(x:Number, y:Number):void

If at the given coordinates a color is found that matches a defined color event, the color event will be triggered.

Parameters

x:Number — X coordinate on the source bmd
y:Number — Y coordinate on the source bmd

removeColorEvent () method
public function removeColorEvent(eventID:String):void

removes a color event by its id

Parameters

eventID:String — The Event id


away3d.tools.utils.Drag3D

Drag3D | Properties | Methods | Constants
Package | away3d.tools.utils
Class | public class Drag3D
Inheritance | Drag3D Inheritance Object

Class Drag3D allows free dragging of an ObjectContainer3D onto a given plane. locks on world planes locks on ObjectContainer3D planes locks on ObjectContainer3D rotations planes

Public Properties
Property |  | Defined By
 | debug : Boolean Displays the planes for debug/visual aid purposes | Drag3D
 | object3d : ObjectContainer3D Sets the target ObjectContainer3D to the class. | Drag3D
 | offsetCenter : Boolean Defines an offset for the drag from center mesh to mouse position. | Drag3D
 | offsetMouseCenter : Vector3D [read-only] getIntersect method returns the 3d point in space (Vector3D) where mouse hits the given plane. | Drag3D
 | plane : String [write-only] Changes the plane the object will be considered on. | Drag3D
 | planeObject3d : ObjectContainer3D [write-only] Defines planes as the position of a given ObjectContainer3D | Drag3D
 | planePosition : Vector3D [write-only] Defines planes position by a postion Vector3D | Drag3D
 | useRotations : Boolean Defines if the target object3d plane will be aligned to object rotations or not | Drag3D
Public Methods
Method |  | Defined By
 | Drag3D(view:View3D, object3d:ObjectContainer3D = null, plane:String) Class Drag3D allows to drag 3d objects with the mouse.Drag3D | Drag3D
 | getIntersect(x:Number, y:Number):Vector3D Returns the Vector3D where mouse to scene ray hits the plane set for the class. | Drag3D
 | updateDrag():void if an ObjectContainer3D is set this handler will calculate the mouse intersection on given plane and will update position and rotations of the ObjectContainer3D set accordingly | Drag3D
Public Constants
Constant |  | Defined By
 | PLANE_XY : String = xy [static] | Drag3D
 | PLANE_XZ : String = xz [static] | Drag3D
 | PLANE_ZY : String = zy [static] | Drag3D
Property Detail
debug property
debug:Boolean

Displays the planes for debug/visual aid purposes

Implementation
    public function get debug():Boolean
    public function set debug(value:Boolean):void
object3d property
object3d:ObjectContainer3D

Sets the target ObjectContainer3D to the class. The ObjectContainer3D that will be dragged

Implementation
    public function get object3d():ObjectContainer3D
    public function set object3d(value:ObjectContainer3D):void
offsetCenter property
offsetCenter:Boolean

Defines an offset for the drag from center mesh to mouse position. object3d must have been set previously for this setter. if not an error is triggered Since the offset is set from center to mouse projection, its usually a good practice to set it during firt mouse down prior to drag.

Implementation
    public function get offsetCenter():Boolean
    public function set offsetCenter(value:Boolean):void
offsetMouseCenter property
offsetMouseCenter:Vector3D [read-only]

getIntersect method returns the 3d point in space (Vector3D) where mouse hits the given plane. return Vector3D the difference mouse mouse hit to object center

Implementation
    public function get offsetMouseCenter():Vector3D
plane property
plane:String [write-only]

Changes the plane the object will be considered on. If class debug is set to true. It display the selected plane for debug/visual aid purposes with a brighter color.

Implementation
    public function set plane(value:String):void
planeObject3d property
planeObject3d:ObjectContainer3D [write-only]

Defines planes as the position of a given ObjectContainer3D

Implementation
    public function set planeObject3d(value:ObjectContainer3D):void
planePosition property
planePosition:Vector3D [write-only]

Defines planes position by a postion Vector3D

Implementation
    public function set planePosition(value:Vector3D):void
useRotations property
useRotations:Boolean

Defines if the target object3d plane will be aligned to object rotations or not

Implementation
    public function get useRotations():Boolean
    public function set useRotations(value:Boolean):void
Constructor Detail
Drag3D () Constructor
public function Drag3D(view:View3D, object3d:ObjectContainer3D = null, plane:String)

Class Drag3D allows to drag 3d objects with the mouse.Drag3D

Parameters
view:View3D — View3D. The view3d where the object to drag is or will be addChilded.
object3d:ObjectContainer3D (default = null) — [optional] ObjectContainer3D. The object3D to drag.
plane:String (default = NaN) — [optional] String. The plane to drag on.
Method Detail
getIntersect () method
public function getIntersect(x:Number, y:Number):Vector3D

Returns the Vector3D where mouse to scene ray hits the plane set for the class.

Parameters

x:Number (default = NaN) — [optional] Number. x coordinate.
y:Number (default = NaN) — [optional] Number. y coordinate.

Returns
Vector3D — Vector3D The intersection Vector3D If both x and y params are NaN, the class will return the hit from mouse coordinates
updateDrag () method
public function updateDrag():void

if an ObjectContainer3D is set this handler will calculate the mouse intersection on given plane and will update position and rotations of the ObjectContainer3D set accordingly

Constant Detail
PLANE_XY Constant
public static const PLANE_XY:String = xy

PLANE_XZ Constant
public static const PLANE_XZ:String = xz

PLANE_ZY Constant
public static const PLANE_ZY:String = zy


away3d.tools.utils.GeomUtil

GeomUtil | Methods
Package | away3d.tools.utils
Class | public class GeomUtil
Inheritance | GeomUtil Inheritance Object

Public Methods
Method Defined By
constructSubGeometry(verts:Vector.<Number>, indices:Vector.<uint>, uvs:Vector.<Number>, normals:Vector.<Number>, tangents:Vector.<Number>, weights:Vector.<Number>, jointIndices:Vector.<Number>):CompactSubGeometry
[static] Build a sub-geometry from data vectors.
GeomUtil
fromVectors(verts:Vector.<Number>, indices:Vector.<uint>, uvs:Vector.<Number>, normals:Vector.<Number>, tangents:Vector.<Number>, weights:Vector.<Number>, jointIndices:Vector.<Number>):Vector.<ISubGeometry>
[static] Build a list of sub-geometries from raw data vectors, splitting them up in such a way that they won't exceed buffer length limits.
GeomUtil
Method Detail
constructSubGeometry () method
public static function constructSubGeometry(verts:Vector.<Number>, indices:Vector.<uint>, uvs:Vector.<Number>, normals:Vector.<Number>, tangents:Vector.<Number>, weights:Vector.<Number>, jointIndices:Vector.<Number>):CompactSubGeometry

Build a sub-geometry from data vectors.

Parameters

verts:Vector.<Number>
indices:Vector.<uint>
uvs:Vector.<Number>
normals:Vector.<Number>
tangents:Vector.<Number>
weights:Vector.<Number>
jointIndices:Vector.<Number>

Returns
CompactSubGeometry
fromVectors () method
public static function fromVectors(verts:Vector.<Number>, indices:Vector.<uint>, uvs:Vector.<Number>, normals:Vector.<Number>, tangents:Vector.<Number>, weights:Vector.<Number>, jointIndices:Vector.<Number>):Vector.<ISubGeometry>

Build a list of sub-geometries from raw data vectors, splitting them up in such a way that they won't exceed buffer length limits.

Parameters

verts:Vector.<Number>
indices:Vector.<uint>
uvs:Vector.<Number>
normals:Vector.<Number>
tangents:Vector.<Number>
weights:Vector.<Number>
jointIndices:Vector.<Number>

Returns
Vector.<ISubGeometry>


away3d.tools.utils.Grid

Grid | Properties | Methods
Package | away3d.tools.utils
Class | public class Grid
Inheritance | Grid Inheritance Object

Class Grid snaps vertexes or meshes according to a given grid unit.Grid

Public Properties
Property |  | Defined By
 | objectSpace : Boolean Defines if the grid unit is applied in objectspace or worldspace. | Grid
 | unit : Number Defines if the grid unit. | Grid
Public Methods
Method |  | Defined By
 | Grid(unit:Number = 1, objectSpace:Boolean = false) Grid snaps vertexes according to a given grid unit | Grid
 | snapMesh(mesh:Mesh):void Apply the grid code to a single mesh | Grid
 | snapObject(object3d:ObjectContainer3D, dovert:Boolean = false):void Apply the grid code to a given object3D. | Grid
 | snapVertices(vertices:Vector.<Number>):Vector.<Number> Snaps to grid a given Vector.<Number> of vertices | Grid
Property Detail
objectSpace property
objectSpace:Boolean

Defines if the grid unit is applied in objectspace or worldspace. In worldspace, objects positions are affected.

Implementation
    public function get objectSpace():Boolean
    public function set objectSpace(value:Boolean):void
unit property
unit:Number

Defines if the grid unit.

Implementation
    public function get unit():Number
    public function set unit(value:Number):void
Constructor Detail
Grid () Constructor
public function Grid(unit:Number = 1, objectSpace:Boolean = false)

Grid snaps vertexes according to a given grid unit

Parameters
unit:Number (default = 1) — [optional] Number. The grid unit. Default is 1.
objectSpace:Boolean (default = false) — [optional] Boolean. Apply only to vertexes in geometry objectspace when Object3D are considered. Default is false.
Method Detail
snapMesh () method
public function snapMesh(mesh:Mesh):void

Apply the grid code to a single mesh

Parameters

mesh:Mesh — Mesh. The mesh to snap to grid. Vertices are affected by default. Mesh position is snapped if grid.objectSpace is true;

snapObject () method
public function snapObject(object3d:ObjectContainer3D, dovert:Boolean = false):void

Apply the grid code to a given object3D. If type ObjectContainer3D, all children Mesh vertices will be affected.

Parameters

object3d:ObjectContainer3D — Object3D. The Object3d to snap to grid.
dovert:Boolean (default = false) — [optional]. If the vertices must be handled or not. When false only object position is snapped to grid. Default is false.

snapVertices () method
public function snapVertices(vertices:Vector.<Number>):Vector.<Number>

Snaps to grid a given Vector.<Number> of vertices

Parameters

vertices:Vector.<Number> — Vector.<Number>. The vertices vector

Returns
Vector.<Number>


away3d.tools.utils.Projector

Projector | Methods | Constants
Package | away3d.tools.utils
Class | public class Projector
Inheritance | Projector Inheritance Object

Public Methods
Method |  | Defined By
 | project(orientation:String, obj:ObjectContainer3D):void [static] Class remaps the uv data of a mesh | Projector
Public Constants
Constant |  | Defined By
 | BACK : String = back [static] | Projector
 | BOTTOM : String = bottom [static] | Projector
 | CYLINDRICAL_X : String = cylindricalx [static] | Projector
 | CYLINDRICAL_Y : String = cylindricaly [static] | Projector
 | CYLINDRICAL_Z : String = cylindricalz [static] | Projector
 | FRONT : String = front [static] | Projector
 | LEFT : String = left [static] | Projector
 | RIGHT : String = right [static] | Projector
 | SPHERICAL : String = spherical [static] | Projector
 | TOP : String = top [static] | Projector
Method Detail
project () method
public static function project(orientation:String, obj:ObjectContainer3D):void

Class remaps the uv data of a mesh

Parameters

orientation:String — String. Defines the projection direction and methods. Note: As we use triangles, cylindrical and spherical projections might require correction, as some faces, may have vertices pointing at other side of the map, causing some faces to be rendered as a whole reverted map.
obj:ObjectContainer3D — ObjectContainer3D. The ObjectContainer3D to remap.

Constant Detail
BACK Constant
public static const BACK:String = back

BOTTOM Constant
public static const BOTTOM:String = bottom

CYLINDRICAL_X Constant
public static const CYLINDRICAL_X:String = cylindricalx

CYLINDRICAL_Y Constant
public static const CYLINDRICAL_Y:String = cylindricaly

CYLINDRICAL_Z Constant
public static const CYLINDRICAL_Z:String = cylindricalz

FRONT Constant
public static const FRONT:String = front

LEFT Constant
public static const LEFT:String = left

RIGHT Constant
public static const RIGHT:String = right

SPHERICAL Constant
public static const SPHERICAL:String = spherical

TOP Constant
public static const TOP:String = top


away3d.tools.utils.Ray

Ray | Properties | Methods
Package | away3d.tools.utils
Class | public class Ray
Inheritance | Ray Inheritance Object

Public Properties
Property |  | Defined By
 | dir : Vector3D Defines the directional vector of the Ray object | Ray
 | orig : Vector3D Defines the origin point of the Ray object | Ray
 | planeNormal : Vector3D [read-only] Defines the directional normal of the Ray object | Ray
Public Methods
Method Defined By
Ray()
Ray
getRayToSphereIntersection(pOrig:Vector3D, dir:Vector3D, sPos:Vector3D, radius:Number, bNearest:Boolean = true, bNormal:Boolean = false, outVector3D:Vector3D = null):Vector3D
Returns a Vector3D where the ray intersects a sphere.
Ray
getRayToTriangleIntersection(p0:Vector3D, p1:Vector3D, v0:Vector3D, v1:Vector3D, v2:Vector3D, outVector3D:Vector3D = null):Vector3D
Returns a Vector3D where the ray intersects a plane inside a triangle Returns null if no hit is found.
Ray
intersectsSphere(pOrig:Vector3D, dir:Vector3D, sPos:Vector3D, radius:Number):Boolean
Checks if a ray intersects a sphere.
Ray
Property Detail
dir property
dir:Vector3D

Defines the directional vector of the Ray object

Implementation
    public function get dir():Vector3D
    public function set dir(value:Vector3D):void
orig property
orig:Vector3D

Defines the origin point of the Ray object

Implementation
    public function get orig():Vector3D
    public function set orig(value:Vector3D):void
planeNormal property
planeNormal:Vector3D [read-only]

Defines the directional normal of the Ray object

Implementation
    public function get planeNormal():Vector3D
Constructor Detail
Ray () Constructor
public function Ray()

Method Detail
getRayToSphereIntersection () method
public function getRayToSphereIntersection(pOrig:Vector3D, dir:Vector3D, sPos:Vector3D, radius:Number, bNearest:Boolean = true, bNormal:Boolean = false, outVector3D:Vector3D = null):Vector3D

Returns a Vector3D where the ray intersects a sphere. Return null if the ray misses the sphere param pOrig Vector3D. The origin of the ray. param dir Vector3D. The direction of the ray. param sPos Vector3D. The position of the sphere. param radius Number. The radius of the sphere. param bNearest [optional] Boolean. If the ray traverses the sphere and if true the returned hit is the nearest to ray origin. Default is true. param bNormal [optional] Boolean. If the returned vector is the normal of the hitpoint. Default is false.

Parameters

pOrig:Vector3D
dir:Vector3D
sPos:Vector3D
radius:Number
bNearest:Boolean (default = true)
bNormal:Boolean (default = false)
outVector3D:Vector3D (default = null)

Returns
Vector3D — Vector3D The intersection vector3D or the normal vector3D of the hitpoint. Default is false. example of a ray triggered from mouse var pMouse:Vector3D = _view.unproject(_view.mouseX, _view.mouseY); var cam:Vector3D = _view.camera.position; var dir:Vector3D = new Vector3D( pMouse.x-cam.x, pMouse.y-cam.y, pMouse.z-cam.z); dir.normalize(); var spherePosition:Vector3D = new Vector3D(200, 200, 200); //hittest trace("Ray intersects sphere :"+ _ray.intersectsSphere(pMouse, dir, spherePosition, 500) ); var sintersect:Vector3D = _ray.getRayToSphereIntersection(pMouse, dir, spherePosition, 500, true, false); if sintersect == null no hit, else sintersect = intersection vector3d or the normal of the intersection
getRayToTriangleIntersection () method
public function getRayToTriangleIntersection(p0:Vector3D, p1:Vector3D, v0:Vector3D, v1:Vector3D, v2:Vector3D, outVector3D:Vector3D = null):Vector3D

Returns a Vector3D where the ray intersects a plane inside a triangle Returns null if no hit is found. param p0 Vector3D. The origin of the ray. param p1 Vector3D. The end of the ray. param v0 Vector3D. The first scenespace vertex of the face. param v1 Vector3D. The second scenespace vertex of the face. param v2 Vector3D. The third scenespace vertex of the face. param outVector3D Vector3D. Optional user defined Vector3D returned with result values example: fire a ray from camera position to 0,0,0 and test if it hits the triangle. view.camera.x = 100; view.camera.y = 100; view.camera.z = 500; var v0:Vector3D = new Vector3D(-200, 100, 60); var v1:Vector3D = new Vector3D(200, 100, 60); var v2:Vector3D = new Vector3D(0, -200, 60); var dest: Vector3D = new Vector3D(0, 0, 0); var intersect:Vector3D = _ray.getRayToTriangleIntersection(_view.camera.position, dest, v0, v1, v2 ); trace("intersect ray: "+intersect);

Parameters

p0:Vector3D
p1:Vector3D
v0:Vector3D
v1:Vector3D
v2:Vector3D
outVector3D:Vector3D (default = null)

Returns
Vector3D — Vector3D The intersection point
intersectsSphere () method
public function intersectsSphere(pOrig:Vector3D, dir:Vector3D, sPos:Vector3D, radius:Number):Boolean

Checks if a ray intersects a sphere. param pOrig Vector3D. The origin vector of the ray. param dir Vector3D. The normalized direction vector of the ray. param sPos Vector3D. The position of the sphere. param radius Number. The radius of the sphere.

Parameters

pOrig:Vector3D
dir:Vector3D
sPos:Vector3D
radius:Number

Returns
Boolean — Boolean If the ray intersects the sphere


away3d.tools.utils.TextureUtils

TextureUtils | Methods
Package | away3d.tools.utils
Class | public class TextureUtils
Inheritance | TextureUtils Inheritance Object

Public Methods
Method |  | Defined By
 | getBestPowerOf2(value:uint):Number [static] | TextureUtils
 | isBitmapDataValid(bitmapData:BitmapData):Boolean [static] | TextureUtils
 | isDimensionValid(d:uint):Boolean [static] | TextureUtils
 | isPowerOfTwo(value:int):Boolean [static] | TextureUtils
Method Detail
getBestPowerOf2 () method
public static function getBestPowerOf2(value:uint):Number

Parameters

value:uint

Returns
Number
isBitmapDataValid () method
public static function isBitmapDataValid(bitmapData:BitmapData):Boolean

Parameters

bitmapData:BitmapData

Returns
Boolean
isDimensionValid () method
public static function isDimensionValid(d:uint):Boolean

Parameters

d:uint

Returns
Boolean
isPowerOfTwo () method
public static function isPowerOfTwo(value:int):Boolean

Parameters

value:int

Returns
Boolean


away3d.utils - Away3D Documentation

Package away3d.utils

Classes
Cast
GeometryUtil


away3d.utils Summary

away3d.utils | Classes

Classes
Class | Description
Cast | Helper class for casting assets to usable objects
GeometryUtil |

Thu Nov 15 2012, 12:09 PM Z


away3d.utils.Cast

Cast | Methods
Package | away3d.utils
Class | public class Cast
Inheritance | Cast Inheritance Object

Helper class for casting assets to usable objects

Public Methods
Method |  | Defined By
 | bitmapData(data:*):BitmapData [static] | Cast
 | bitmapTexture(data:*):BitmapTexture [static] | Cast
 | byteArray(data:*):ByteArray [static] | Cast
 | color(data:*):uint [static] | Cast
 | string(data:*):String [static] | Cast
 | tryClass(name:String):Object [static] | Cast
 | tryColor(data:*):uint [static] | Cast
 | xml(data:*):XML [static] | Cast
Method Detail
bitmapData () method
public static function bitmapData(data:*):BitmapData

Parameters

data:*

Returns
BitmapData
bitmapTexture () method
public static function bitmapTexture(data:*):BitmapTexture

Parameters

data:*

Returns
BitmapTexture
byteArray () method
public static function byteArray(data:*):ByteArray

Parameters

data:*

Returns
ByteArray
color () method
public static function color(data:*):uint

Parameters

data:*

Returns
uint
string () method
public static function string(data:*):String

Parameters

data:*

Returns
String
tryClass () method
public static function tryClass(name:String):Object

Parameters

name:String

Returns
Object
tryColor () method
public static function tryColor(data:*):uint

Parameters

data:*

Returns
uint
xml () method
public static function xml(data:*):XML

Parameters

data:*

Returns
XML


away3d.utils.GeometryUtil

GeometryUtil | Methods
Package | away3d.utils
Class | public class GeometryUtil
Inheritance | GeometryUtil Inheritance Object

Public Methods
Method |  | Defined By
 | interleaveBuffers(numVertices:uint, vertices:Vector.<Number> = null, normals:Vector.<Number> = null, tangents:Vector.<Number> = null, uvs:Vector.<Number> = null, suvs:Vector.<Number> = null):Vector.<Number> [static] | GeometryUtil
Method Detail
interleaveBuffers () method
public static function interleaveBuffers(numVertices:uint, vertices:Vector.<Number> = null, normals:Vector.<Number> = null, tangents:Vector.<Number> = null, uvs:Vector.<Number> = null, suvs:Vector.<Number> = null):Vector.<Number>

Parameters

numVertices:uint
vertices:Vector.<Number> (default = null)
normals:Vector.<Number> (default = null)
tangents:Vector.<Number> (default = null)
uvs:Vector.<Number> (default = null)
suvs:Vector.<Number> (default = null)

Returns
Vector.<Number>


A

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
A Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
a — Property, class away3d.core.math.Plane3D
 | The A coefficient of this plane.
_aabbPoints — Property, class away3d.bounds.BoundingVolumeBase
aabbPoints — Property, class away3d.bounds.BoundingVolumeBase
 | Returns a vector of values representing the concatenated cartesian triplet of the 8 axial extremities of the bounding volume.
_aabbPointsDirty — Property, class away3d.bounds.BoundingVolumeBase
ABSOLUTE — Constant Static Property, class away3d.animators.data.VertexAnimationMode
 | Animation mode that picks the output from a single vertex animation state to form the current vertex animation pose.
_absoluteTime — Property, class away3d.animators.AnimatorBase
absoluteTime — Property, class away3d.animators.AnimatorBase
 | Returns the internal absolute time of the animator, calculated by the current time and the playback speed.
AbstractMethodError — class, package away3d.errors
 | AbstractMethodError is thrown when an abstract method is called.
AbstractMethodError(message:String, id:int) — Constructor, class away3d.errors.AbstractMethodError
 | Create a new AbstractMethodError.
AbstractSound3DDriver — class, package away3d.audio.drivers
AbstractSound3DDriver() — Constructor, class away3d.audio.drivers.AbstractSound3DDriver
AC3DParser — class, package away3d.loaders.parsers
 | AC3DParser provides a parser for the AC3D data type.
AC3DParser() — Constructor, class away3d.loaders.parsers.AC3DParser
 | Creates a new AC3DParser object.
acceleration — Property, class away3d.animators.states.ParticleAccelerationState
 | Defines the acceleration vector of the state, used when in global mode.
ACCELERATION_VECTOR3D — Constant Static Property, class away3d.animators.nodes.ParticleAccelerationNode
 | Reference for acceleration node properties on a single particle (when in local property mode).
acceptTraverser(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.CameraNode
 | Allows the traverser to visit the current node.
acceptTraverser(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.DirectionalLightNode
 | Allows the traverser to visit the current node.
acceptTraverser(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.EntityNode
 | Allows the traverser to visit the current node.
acceptTraverser(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.InvertedOctreeNode
acceptTraverser(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.LightNode
 | Allows the traverser to visit the current node.
acceptTraverser(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.LightProbeNode
 | Allows the traverser to visit the current node.
acceptTraverser(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.MeshNode
 | Allows the traverser to visit the current node.
acceptTraverser(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.NodeBase
 | Allows the traverser to visit the current node.
acceptTraverser(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.PointLightNode
 | Allows the traverser to visit the current node.
acceptTraverser(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.RenderableNode
 | Allows the traverser to visit the current node.
acceptTraverser(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.SkyBoxNode
 | Allows the traverser to visit the current node.
acceptTraverser(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.ViewVolume
acceptTraverser(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.ViewVolumeRootNode
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.ParticleAnimationSet
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.SkeletonAnimationSet
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.UVAnimationSet
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.VertexAnimationSet
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera3D:away3d.cameras:Camera3D, depthTexture:flash.display3D.textures:Texture) — method, class away3d.filters.tasks.Filter3DBrightPassTask
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera3D:away3d.cameras:Camera3D, depthTexture:flash.display3D.textures:Texture) — method, class away3d.filters.tasks.Filter3DCompositeTask
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, depthTexture:flash.display3D.textures:Texture) — method, class away3d.filters.tasks.Filter3DDoubleBufferCopyTask
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera3D:away3d.cameras:Camera3D, depthTexture:flash.display3D.textures:Texture) — method, class away3d.filters.tasks.Filter3DHBlurTask
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, depthTexture:flash.display3D.textures:Texture) — method, class away3d.filters.tasks.Filter3DHDepthOfFFieldTask
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera3D:away3d.cameras:Camera3D, depthTexture:flash.display3D.textures:Texture) — method, class away3d.filters.tasks.Filter3DHueSaturationTask
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera3D:away3d.cameras:Camera3D, depthTexture:flash.display3D.textures:Texture) — method, class away3d.filters.tasks.Filter3DRadialBlurTask
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, depthTexture:flash.display3D.textures:Texture) — method, class away3d.filters.tasks.Filter3DTaskBase
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera3D:away3d.cameras:Camera3D, depthTexture:flash.display3D.textures:Texture) — method, class away3d.filters.tasks.Filter3DVBlurTask
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, depthTexture:flash.display3D.textures:Texture) — method, class away3d.filters.tasks.Filter3DVDepthOfFFieldTask
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera3D:away3d.cameras:Camera3D, depthTexture:flash.display3D.textures:Texture) — method, class away3d.filters.tasks.Filter3DXFadeCompositeTask
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.AlphaMaskMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.BasicAmbientMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.BasicDiffuseMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.BasicNormalMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.BasicSpecularMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.CascadeShadowMapMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.CelDiffuseMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.CelSpecularMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.ColorMatrixMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.ColorTransformMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.CompositeDiffuseMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.CompositeSpecularMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.DitheredShadowMapMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.EnvMapAmbientMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.EnvMapMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.FogMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.FresnelEnvMapMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.FresnelPlanarReflectionMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.FresnelSpecularMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.LightMapDiffuseMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.LightMapMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.NearShadowMapMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.OutlineMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.PlanarReflectionMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.ProjectiveTextureMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.RefractionEnvMapMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.RimLightMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.SimpleShadowMapMethodBase
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.SimpleWaterNormalMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.SoftShadowMapMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.SubsurfaceScatteringDiffuseMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.TerrainDiffuseMethod
activate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.WrapDiffuseMethod
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.passes.CompiledPass
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.passes.DepthMapPass
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.passes.DistanceMapPass
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.passes.LightingPass
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.passes.MaterialPassBase
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.passes.OutlinePass
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.passes.SegmentPass
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.passes.ShadowCasterPass
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.passes.SingleObjectDepthPass
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.passes.SkyBoxPass
activate(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.passes.SuperShaderPass
activate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.stereo.methods.AnaglyphStereoRenderMethod
activate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.stereo.methods.InterleavedStereoRenderMethod
activate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.stereo.methods.StereoRenderMethodBase
activateCustomBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.primitives.SkyBox
activateForCascade(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.DitheredShadowMapMethod
activateForCascade(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.FilteredShadowMapMethod
activateForCascade(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.HardShadowMapMethod
activateForCascade(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.SimpleShadowMapMethodBase
activateForCascade(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.SoftShadowMapMethod
activateForDepth(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, distanceBased:Boolean, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.MaterialBase
activateForDepth(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, distanceBased:Boolean, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.MultiPassMaterialBase
activateForDepth(stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, distanceBased:Boolean, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.SinglePassMaterialBase
activateJointIndexBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SkinnedSubGeometry
 | Assigns the attribute stream for joint indices
activateJointWeightsBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SkinnedSubGeometry
 | Assigns the attribute stream for joint weights
activatePass(index:uint, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D, textureRatioX:Number, textureRatioY:Number) — method, class away3d.materials.MultiPassMaterialBase
activateSecondaryUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.CompactSubGeometry
activateSecondaryUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, interface away3d.core.base.IRenderable
 | Assigns the attribute stream for a secondary set of UV coordinates
activateSecondaryUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, interface away3d.core.base.ISubGeometry
 | Assigns the attribute stream for a secondary set of UV coordinates
activateSecondaryUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SubGeometry
 | Assigns the attribute stream for a secondary set of UV coordinates
activateSecondaryUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SubMesh
 | Assigns the attribute stream for a secondary set of UV coordinates
activateSecondaryUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.entities.SegmentSet
activateSecondaryUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.entities.Sprite3D
activateSecondaryUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.primitives.SkyBox
activateUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.CompactSubGeometry
activateUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, interface away3d.core.base.IRenderable
 | Assigns the attribute stream for UV coordinates
activateUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, interface away3d.core.base.ISubGeometry
 | Assigns the attribute stream for UV coordinates
activateUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SubGeometry
 | Assigns the attribute stream for UV coordinates
activateUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SubMesh
 | Assigns the attribute stream for UV coordinates
activateUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.entities.SegmentSet
activateUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.entities.Sprite3D
activateUVBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.primitives.SkyBox
 | Assigns the attribute stream for UV coordinates
activateVertexBuffer(index:int, bufferOffset:int, stage3DProxy:away3d.core.managers:Stage3DProxy, format:String) — method, class away3d.animators.data.AnimationSubGeometry
activateVertexBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.CompactSubGeometry
activateVertexBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, interface away3d.core.base.IRenderable
 | Assigns the attribute stream for vertex positions.
activateVertexBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, interface away3d.core.base.ISubGeometry
 | Assigns the attribute stream for vertex positions.
activateVertexBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SubGeometry
 | Assigns the attribute stream for vertex positions.
activateVertexBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SubMesh
 | Assigns the attribute stream for vertex positions.
activateVertexBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.entities.SegmentSet
activateVertexBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.entities.Sprite3D
activateVertexBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.primitives.SkyBox
 | Assigns the attribute stream for vertex positions.
activateVertexNormalBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.CompactSubGeometry
activateVertexNormalBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, interface away3d.core.base.IRenderable
 | Assigns the attribute stream for vertex normals
activateVertexNormalBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, interface away3d.core.base.ISubGeometry
 | Assigns the attribute stream for vertex normals
activateVertexNormalBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SubGeometry
 | Retrieves the VertexBuffer3D object that contains vertex normals.
activateVertexNormalBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SubMesh
 | Assigns the attribute stream for vertex normals
activateVertexNormalBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.entities.SegmentSet
activateVertexNormalBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.entities.Sprite3D
activateVertexNormalBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.primitives.SkyBox
 | Assigns the attribute stream for vertex normals
activateVertexTangentBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.CompactSubGeometry
activateVertexTangentBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, interface away3d.core.base.IRenderable
 | Assigns the attribute stream for vertex tangents
activateVertexTangentBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, interface away3d.core.base.ISubGeometry
 | Assigns the attribute stream for vertex tangents
activateVertexTangentBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SubGeometry
 | Retrieves the VertexBuffer3D object that contains vertex tangents.
activateVertexTangentBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SubMesh
 | Assigns the attribute stream for vertex tangents
activateVertexTangentBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.entities.SegmentSet
activateVertexTangentBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.entities.Sprite3D
activateVertexTangentBuffer(index:int, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.primitives.SkyBox
 | Assigns the attribute stream for vertex tangents
_active — Property, class away3d.core.partition.ViewVolume
active — Static Property, class away3d.debug.Debug
activeAnimation — Property, class away3d.animators.AnimatorBase
 | Returns the current active animation node.
activeAnimationName — Property, class away3d.animators.AnimatorBase
 | Returns the current active animation node.
_activeBuffer — Property, class away3d.core.base.CompactSubGeometry
_activeContext — Property, class away3d.core.base.CompactSubGeometry
_activeDataInvalid — Property, class away3d.core.base.CompactSubGeometry
_activeNode — Property, class away3d.animators.AnimatorBase
_activeState — Property, class away3d.animators.AnimatorBase
activeState — Property, class away3d.animators.AnimatorBase
 | Returns the current active animation state.
ADD — Constant Static Property, class away3d.materials.methods.LightMapDiffuseMethod
ADD — Constant Static Property, class away3d.materials.methods.LightMapMethod
ADD — Constant Static Property, class away3d.materials.methods.ProjectiveTextureMethod
ADD — Constant Static Property, class away3d.materials.methods.RimLightMethod
addAnimation(node:away3d.animators.nodes:AnimationNodeBase) — method, class away3d.animators.AnimationSetBase
 | Adds an animation state object to the aniamtion data set under the given name.
addAnimation(node:away3d.animators.nodes:AnimationNodeBase) — method, class away3d.animators.ParticleAnimationSet
 | Adds an animation state object to the aniamtion data set under the given name.
addAsset(asset:away3d.library.assets:IAsset) — Static Method , class away3d.library.AssetLibrary
 | Short-hand for addAsset() method on default asset library bundle.
addAsset(asset:away3d.library.assets:IAsset) — method, class away3d.library.AssetLibraryBundle
 | Adds an asset to the asset library, first making sure that it's name is unique using the method defined by the conflictStrategy and conflictPrecedence properties.
addChild(child:away3d.containers:ObjectContainer3D) — method, class away3d.containers.ObjectContainer3D
 | Adds a child ObjectContainer3D to the current object.
addChild(child:away3d.containers:ObjectContainer3D) — method, class away3d.containers.Scene3D
 | Adds a child to the scene's root.
addChildren(... rest) — method, class away3d.containers.ObjectContainer3D
 | Adds an array of 3d objects to the scene as children of the container
addColorEvent(color:Number, eventID:String, listener:Function) — method, class away3d.tools.utils.ColorHitMap
 | Defines a color event for this class.
addDependency(id:String, req:flash.net:URLRequest, retrieveAsRawData:Boolean, data:any, suppressErrorEvents:Boolean) — method, class away3d.loaders.parsers.ParserBase
ADDED_TO_SCENE — Constant Static Property, class away3d.events.Scene3DEvent
addEventListener(type:String, listener:Function, useCapture:Boolean, priority:int, useWeakReference:Boolean) — method, class away3d.containers.ObjectContainer3D
addEventListener(type:String, listener:Function, useCapture:Boolean, priority:int, useWeakReference:Boolean) — method, class away3d.core.base.Object3D
addEventListener(type:String, listener:Function, useCapture:Boolean, priority:int, useWeakReference:Boolean) — method, class away3d.core.managers.Stage3DProxy
 | Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
addEventListener(type:String, listener:Function, useCapture:Boolean, priority:int, useWeakReference:Boolean) — Static Method , class away3d.library.AssetLibrary
 | Short-hand for addEventListener() method on default asset library bundle.
addEventListener(type:String, listener:Function, useCapture:Boolean, priority:int, useWeakReference:Boolean) — method, class away3d.lights.shadowmaps.CascadeShadowMapper
addEventListener(type:String, listener:Function, useCapture:Boolean, priority:int, useWeakReference:Boolean) — method, class away3d.loaders.misc.AssetLoaderToken
addFace(mesh:away3d.entities:Mesh, v0:away3d.core.base.data:Vertex, v1:away3d.core.base.data:Vertex, v2:away3d.core.base.data:Vertex, uv0:away3d.core.base.data:UV, uv1:away3d.core.base.data:UV, uv2:away3d.core.base.data:UV, subGeomIndice:uint) — Static Method , class away3d.tools.helpers.FaceHelper
addFaces(mesh:away3d.entities:Mesh, v0s:Vector$away3d.core.base.data:Vertex, v1s:Vector$away3d.core.base.data:Vertex, v2s:Vector$away3d.core.base.data:Vertex, uv0s:Vector$away3d.core.base.data:UV, uv1s:Vector$away3d.core.base.data:UV, uv2s:Vector$away3d.core.base.data:UV, subGeomIndices:Vector$uint) — Static Method , class away3d.tools.helpers.FaceHelper
 | Adds a series of faces from a mesh.
addFragmentTempUsages(register:away3d.materials.compilation:ShaderRegisterElement, usageCount:uint) — method, class away3d.materials.compilation.ShaderRegisterCache
 | Marks a fragment temporary register as used, so it cannot be retrieved.
addFrame(skeletonPose:away3d.animators.data:SkeletonPose, duration:uint) — method, class away3d.animators.nodes.SkeletonClipNode
 | Adds a skeleton pose frame to the internal timeline of the animation node.
addFrame(uvFrame:away3d.animators.data:UVAnimationFrame, duration:uint) — method, class away3d.animators.nodes.UVClipNode
 | Adds a UV frame object to the internal timeline of the animation node.
addFrame(geometry:away3d.core.base:Geometry, duration:uint, translation:flash.geom:Vector3D) — method, class away3d.animators.nodes.VertexClipNode
 | Adds a geometry object to the internal timeline of the animation node.
addInput(input:away3d.animators.nodes:AnimationNodeBase) — method, class away3d.animators.nodes.SkeletonNaryLERPNode
 | Adds a new skeleton animation node input to the animation node.
ADDITIVE — Constant Static Property, class away3d.animators.data.VertexAnimationMode
 | Animation mode that adds all outputs from active vertex animation state to form the current vertex animation pose.
addMethod(method:away3d.materials.methods:EffectMethodBase) — method, class away3d.materials.MultiPassMaterialBase
 | Adds a shading method to the end of the shader.
addMethod(method:away3d.materials.methods:EffectMethodBase) — method, class away3d.materials.SinglePassMaterialBase
 | Adds a shading method to the end of the shader.
addMethod(method:away3d.materials.methods:EffectMethodBase) — method, class away3d.materials.methods.ShaderMethodSetup
 | Adds a method to change the material after all lighting is performed.
addMethod(method:away3d.materials.methods:EffectMethodBase) — method, class away3d.materials.passes.SuperShaderPass
 | Adds a shading method to the end of the shader.
addMethodAt(method:away3d.materials.methods:EffectMethodBase, index:int) — method, class away3d.materials.MultiPassMaterialBase
 | Adds a shading method to the end of a shader, at the specified index amongst the methods in that section of the shader.
addMethodAt(method:away3d.materials.methods:EffectMethodBase, index:int) — method, class away3d.materials.SinglePassMaterialBase
 | Adds a shading method to the end of a shader, at the specified index amongst the methods in that section of the shader.
addMethodAt(method:away3d.materials.methods:EffectMethodBase, index:int) — method, class away3d.materials.methods.ShaderMethodSetup
 | Inserts a method to change the material after all lighting is performed at the given index.
addMethodAt(method:away3d.materials.methods:EffectMethodBase, index:int) — method, class away3d.materials.passes.SuperShaderPass
 | Adds a shading method to the end of a shader, at the specified index amongst the methods in that section of the shader.
addNode(node:away3d.core.partition:NodeBase) — method, class away3d.core.partition.NodeBase
 | Adds a node to the tree.
addOnChangeSegment(listener:Function) — method, class away3d.animators.PathAnimator
 | Default method for adding a segmentchange event listener.
addOnCycle(listener:Function) — method, class away3d.animators.PathAnimator
 | Default method for adding a cycle event listener.
addOnRange(listener:Function, from:Number, to:Number) — method, class away3d.animators.PathAnimator
 | Default method for adding a range event listener.
addPartitionUnique(partition:away3d.core.partition:Partition3D) — method, class away3d.containers.Scene3D
 | Add a partition if it's not in the list
addPass(pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.materials.MaterialBase
 | Adds a pass to the material
addPasses(passes:Vector$away3d.materials.passes:MaterialPassBase) — method, class away3d.materials.passes.CompiledPass
 | Adds passes to the list.
addPassesFromMethods() — method, class away3d.materials.passes.CompiledPass
addPassesFromMethods() — method, class away3d.materials.passes.SuperShaderPass
addSegment(segment:away3d.primitives.data:Segment) — method, class away3d.entities.SegmentSet
addSegment(segment:away3d.paths:IPathSegment) — method, interface away3d.paths.IPath
 | Adds a CubicPathSegment to the end of the path
addSegment(segment:away3d.paths:IPathSegment) — method, class away3d.paths.SegmentedPathBase
addSourceURL(url:String) — method, class away3d.containers.View3D
 | Defines a source url string that can be accessed though a View Source option in the right-click menu.
addStaticLightsToMaterials(objectContainer3D:away3d.containers:ObjectContainer3D, lights:Vector$away3d.lights:LightBase) — Static Method , class away3d.tools.helpers.LightsHelper
 | Applys a series of lights to all materials found into an objectcontainer and its children.
addStaticLightToMaterials(objectContainer3D:away3d.containers:ObjectContainer3D, light:away3d.lights:LightBase) — Static Method , class away3d.tools.helpers.LightsHelper
 | Adds one light to all materials found into an objectcontainer and its children.
addSubGeometry(subGeometry:away3d.core.base:ISubGeometry) — method, class away3d.core.base.Geometry
 | Adds a new SubGeometry object to the list.
addTask(filter:away3d.filters.tasks:Filter3DTaskBase) — method, class away3d.filters.Filter3DBase
addVertexTempUsages(register:away3d.materials.compilation:ShaderRegisterElement, usageCount:uint) — method, class away3d.materials.compilation.ShaderRegisterCache
 | Marks a vertex temporary register as used, so it cannot be retrieved.
addViewVolume(viewVolume:away3d.core.partition:ViewVolume) — method, class away3d.core.partition.ViewVolumePartition
 | Adds a view volume to provide visibility info for a given region.
addViewVolume(viewVolume:away3d.core.partition:ViewVolume) — method, class away3d.core.partition.ViewVolumeRootNode
addVisibleDynamicCell(cell:away3d.core.partition:InvertedOctreeNode, indexX:uint, indexY:uint, indexZ:uint) — method, class away3d.core.partition.ViewVolume
addVisibleRegion(minBounds:flash.geom:Vector3D, maxBounds:flash.geom:Vector3D, scene:away3d.containers:Scene3D, dynamicGrid:away3d.core.partition:DynamicGrid, indexX:uint, indexY:uint, indexZ:uint) — method, class away3d.core.partition.ViewVolume
 | Adds all static geometry in a scene that intersects a given region, as well as the dynamic grid if provided.
addVisibleStatic(entity:away3d.entities:Entity, indexX:uint, indexY:uint, indexZ:uint) — method, class away3d.core.partition.ViewVolume
addVisibleViewVolume(viewVolume:away3d.core.partition:ViewVolume, scene:away3d.containers:Scene3D, dynamicGrid:away3d.core.partition:DynamicGrid) — method, class away3d.core.partition.ViewVolume
 | A shortcut method for addVisibleRegion, that adds static geometry in a scene that intersects a given viewvolume, as well as the dynamic grid if provided.
addWorldSpaceDependencies(fragmentLights:Boolean) — method, class away3d.materials.compilation.MethodDependencyCounter
agalcode — Property, class com.adobe.utils.AGALMiniAssembler
AGALMiniAssembler — class, package com.adobe.utils
AGALMiniAssembler(debugging:Boolean) — Constructor, class com.adobe.utils.AGALMiniAssembler
AGALProgram3DCache — class, package away3d.core.managers
AGALProgram3DCache(stage3DProxy:away3d.core.managers:Stage3DProxy, AGALProgram3DCacheSingletonEnforcer:AGALProgram3DCache.as$8:AGALProgram3DCacheSingletonEnforcer) — Constructor, class away3d.core.managers.AGALProgram3DCache
align(aObjs:Array, axis:String, condition:String) — Static Method , class away3d.tools.commands.Align
 | Applies to array elements the alignment according to axis, x, y or z and a condition.
Align — class, package away3d.tools.commands
 | Class Aligns an arrays of Object3Ds, Vector3D's or Vertexes compaired to each other.Align
ALIGN_ANY — Constant Static Property, class away3d.core.math.Plane3D
_alignment — Property, class away3d.core.math.Plane3D
alignMeshes(meshes:Vector$away3d.entities:Mesh, axis:String, condition:String) — Static Method , class away3d.tools.commands.Align
 | Aligns a series of meshes to their bounds along a given axis.
alignToFloor(meshes:Vector$away3d.entities:Mesh) — Static Method , class away3d.tools.commands.Align
 | Place one or more meshes at y 0 using their min bounds
aligntoPath — Property, class away3d.extrusions.PathExtrude
 | Defines if the array of profile points should be orientated on path or not.
alignToPath — Property, class away3d.animators.PathAnimator
 | defines if the object animated along the path must be aligned to the path.
alignToPath — Property, class away3d.extrusions.PathDuplicator
 | Defines if the profile point array should be orientated on path or not.
alignToPath — Property, class away3d.extrusions.PathExtrude
ALIGN_XY_AXIS — Constant Static Property, class away3d.core.math.Plane3D
ALIGN_XZ_AXIS — Constant Static Property, class away3d.core.math.Plane3D
ALIGN_YZ_AXIS — Constant Static Property, class away3d.core.math.Plane3D
ALL — Constant Static Property, class away3d.materials.LightSources
 | Defines that both normal and global lighting probes are to be used as the source for the lighting component.
ALL_BUNDLED — Constant Static Property, class away3d.loaders.parsers.Parsers
 | A list of all parsers that come bundled with Away3D.
_allPickedLights — Property, class away3d.materials.lightpickers.LightPickerBase
allPickedLights — Property, class away3d.materials.lightpickers.LightPickerBase
alpha — Property, class away3d.materials.ColorMaterial
 | The alpha of the surface.
alpha — Property, class away3d.materials.TextureMaterial
 | The alpha of the surface.
alpha — Property, class away3d.materials.methods.EnvMapMethod
 | The reflectiveness of the surface
alpha — Property, class away3d.materials.methods.FresnelEnvMapMethod
alpha — Property, class away3d.materials.methods.FresnelPlanarReflectionMethod
alpha — Property, class away3d.materials.methods.NearShadowMapMethod
alpha — Property, class away3d.materials.methods.PlanarReflectionMethod
 | The reflectiveness of the surface.
alpha — Property, class away3d.materials.methods.RefractionEnvMapMethod
_alpha — Property, class away3d.materials.methods.ShadowMapMethodBase
alpha — Property, class away3d.materials.methods.ShadowMapMethodBase
alphaBlending — Property, class away3d.materials.SinglePassMaterialBase
 | Indicate whether or not the material has transparency.
alphaMask — Property, class away3d.materials.passes.DepthMapPass
alphaMask — Property, class away3d.materials.passes.DistanceMapPass
AlphaMaskMethod — class, package away3d.materials.methods
 | Allows the use of an additional texture to specify the alpha value of the material.
AlphaMaskMethod(texture:away3d.textures:Texture2DBase, useSecondaryUV:Boolean) — Constructor, class away3d.materials.methods.AlphaMaskMethod
alphaPremultiplied — Property, class away3d.materials.MaterialBase
 | Indicates whether visible textures (or other pixels) used by this material have already been premultiplied.
_alphaPremultiplied — Property, class away3d.materials.compilation.ShaderCompiler
alphaPremultiplied — Property, class away3d.materials.compilation.ShaderCompiler
_alphaPremultiplied — Property, class away3d.materials.passes.MaterialPassBase
alphaPremultiplied — Property, class away3d.materials.passes.MaterialPassBase
alphaThreshold — Property, class away3d.materials.MultiPassMaterialBase
 | The minimum alpha value for which pixels should be drawn.
alphaThreshold — Property, class away3d.materials.SinglePassMaterialBase
 | The minimum alpha value for which pixels should be drawn.
_alphaThreshold — Property, class away3d.materials.methods.BasicDiffuseMethod
alphaThreshold — Property, class away3d.materials.methods.BasicDiffuseMethod
 | The minimum alpha value for which pixels should be drawn.
alphaThreshold — Property, class away3d.materials.methods.CompositeDiffuseMethod
alphaThreshold — Property, class away3d.materials.methods.TerrainDiffuseMethod
alphaThreshold — Property, class away3d.materials.passes.DepthMapPass
 | The minimum alpha value for which pixels should be drawn.
alphaThreshold — Property, class away3d.materials.passes.DistanceMapPass
 | The minimum alpha value for which pixels should be drawn.
altKey — Property, class away3d.events.MouseEvent3D
 | Indicates whether the Alt key is active (true) or inactive (false).
ambient — Property, class away3d.lights.LightBase
 | The ambient emission strength of the light.
ambient — Property, class away3d.materials.MultiPassMaterialBase
 | The strength of the ambient reflection.
ambient — Property, class away3d.materials.SinglePassMaterialBase
 | The strength of the ambient reflection.
ambient — Property, class away3d.materials.methods.BasicAmbientMethod
 | The strength of the ambient reflection of the surface.
_ambientB — Property, class away3d.lights.LightBase
ambientColor — Property, class away3d.lights.LightBase
ambientColor — Property, class away3d.materials.MultiPassMaterialBase
 | The colour of the ambient reflection.
ambientColor — Property, class away3d.materials.SinglePassMaterialBase
 | The colour of the ambient reflection.
ambientColor — Property, class away3d.materials.methods.BasicAmbientMethod
 | The colour of the ambient reflection of the surface.
_ambientG — Property, class away3d.lights.LightBase
_ambientInputRegister — Property, class away3d.materials.methods.BasicAmbientMethod
_ambientLightB — Property, class away3d.materials.passes.CompiledPass
_ambientLightG — Property, class away3d.materials.passes.CompiledPass
_ambientLightR — Property, class away3d.materials.passes.CompiledPass
ambientMethod — Property, class away3d.materials.MultiPassMaterialBase
 | The method to perform ambient shading.
ambientMethod — Property, class away3d.materials.SinglePassMaterialBase
 | The method to perform ambient shading.
_ambientMethod — Property, class away3d.materials.methods.ShaderMethodSetup
ambientMethod — Property, class away3d.materials.methods.ShaderMethodSetup
ambientMethod — Property, class away3d.materials.passes.CompiledPass
_ambientMethodVO — Property, class away3d.materials.methods.ShaderMethodSetup
_ambientR — Property, class away3d.lights.LightBase
ambientTexture — Property, class away3d.materials.TextureMaterial
 | The texture object to use for the ambient colour.
ambientTexture — Property, class away3d.materials.TextureMultiPassMaterial
 | The texture object to use for the ambient colour.
amount — Property, class away3d.filters.HBlurFilter3D
amount — Property, class away3d.filters.VBlurFilter3D
amount — Property, class away3d.filters.tasks.Filter3DHBlurTask
amount — Property, class away3d.filters.tasks.Filter3DVBlurTask
amount — Property, class away3d.filters.tasks.Filter3DXFadeCompositeTask
AnaglyphStereoRenderMethod — class, package away3d.stereo.methods
AnaglyphStereoRenderMethod() — Constructor, class away3d.stereo.methods.AnaglyphStereoRenderMethod
_animatableAttributes — Property, class away3d.materials.compilation.ShaderCompiler
animatableAttributes — Property, class away3d.materials.compilation.ShaderCompiler
_animatableAttributes — Property, class away3d.materials.passes.MaterialPassBase
animatedData — Property, class away3d.core.base.SkinnedSubGeometry
 | The animated vertex positions when set explicitly if the skinning transformations couldn't be performed on GPU.
animatedNormal — Property, class away3d.materials.compilation.ShaderRegisterData
animatedTangent — Property, class away3d.materials.compilation.ShaderRegisterData
animateUVs — Property, class away3d.materials.TextureMaterial
animateUVs — Property, class away3d.materials.TextureMultiPassMaterial
_animateUVs — Property, class away3d.materials.compilation.ShaderCompiler
animateUVs — Property, class away3d.materials.compilation.ShaderCompiler
_animateUVs — Property, class away3d.materials.passes.CompiledPass
animateUVs — Property, class away3d.materials.passes.CompiledPass
AnimationClipNodeBase — class, package away3d.animators.nodes
 | Provides an abstract base class for nodes with time-based animation data in an animation blend tree.
AnimationClipNodeBase() — Constructor, class away3d.animators.nodes.AnimationClipNodeBase
 | Creates a new AnimationClipNodeBase object.
AnimationClipState — class, package away3d.animators.states
AnimationClipState(animator:away3d.animators:IAnimator, animationClipNode:away3d.animators.nodes:AnimationClipNodeBase) — Constructor, class away3d.animators.states.AnimationClipState
animationNames — Property, class away3d.animators.AnimationSetBase
 | Returns a vector of animation state objects that make up the contents of the animation data set.
_animationNode — Property, class away3d.animators.states.AnimationStateBase
animationNode — Property, class away3d.events.AnimationStateEvent
 | The animation node inside the animation state from which the event originated.
ANIMATION_NODE — Constant Static Property, class away3d.library.assets.AssetType
AnimationNodeBase — class, package away3d.animators.nodes
 | Provides an abstract base class for nodes in an animation blend tree.
AnimationNodeBase() — Constructor, class away3d.animators.nodes.AnimationNodeBase
 | Creates a new AnimationNodeBase object.
animationNodeComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when an animation node has been constructed from a resource.
animationNodeComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when an animation set has been constructed from a group of animation state resources.
animationNodeComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when an animation node has been constructed from a resource.
animationNodeComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when an animation node has been constructed from a resource.
animationNodeComplete — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when an animation node has been constructed from a resource.
animationNodeComplete — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when an animation node has been constructed from a resource.
ANIMATION_NODE_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
animationParticles — Property, class away3d.animators.data.AnimationSubGeometry
animationRegisterCache — Property, class away3d.materials.passes.MaterialPassBase
AnimationRegisterCache — class, package away3d.animators.data
 | ...
AnimationRegisterCache() — Constructor, class away3d.animators.data.AnimationRegisterCache
animations — Property, class away3d.animators.AnimationSetBase
 | Returns a vector of animation state objects that make up the contents of the animation data set.
_animationSet — Property, class away3d.animators.AnimatorBase
animationSet — Property, class away3d.animators.AnimatorBase
 | Returns the animation data set in use by the animator.
animationSet — Property, interface away3d.animators.IAnimator
 | Returns the animation data set in use by the animator.
_animationSet — Property, class away3d.materials.passes.MaterialPassBase
animationSet — Property, class away3d.materials.passes.MaterialPassBase
 | The animation used to add vertex code to the shader code.
ANIMATION_SET — Constant Static Property, class away3d.library.assets.AssetType
AnimationSetBase — class, package away3d.animators
 | Provides an abstract base class for data set classes that hold animation data for use in animator classes.
animationSetComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when an animation set has been constructed from a group of animation state resources.
animationSetComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when an animation node has been constructed from a resource.
animationSetComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when an animation set has been constructed from a group of animation state resources.
animationSetComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when an animation set has been constructed from a group of animation state resources.
animationSetComplete — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when an animation set has been constructed from a group of animation state resources.
animationSetComplete — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when an animation set has been constructed from a group of animation state resources.
ANIMATION_SET_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
AnimationSetError — class, package away3d.errors
AnimationSetError(message:String) — Constructor, class away3d.errors.AnimationSetError
animationState — Property, class away3d.events.AnimationStateEvent
 | The animation state object that is the subject of this event.
ANIMATION_STATE — Constant Static Property, class away3d.library.assets.AssetType
AnimationStateBase — class, package away3d.animators.states
AnimationStateBase(animator:away3d.animators:IAnimator, animationNode:away3d.animators.nodes:AnimationNodeBase) — Constructor, class away3d.animators.states.AnimationStateBase
animationStateComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when an animation state has been constructed from a group of animation node resources.
animationStateComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when an animation state has been constructed from a group of animation node resources.
animationStateComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when an animation state has been constructed from a group of animation node resources.
animationStateComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when an animation state has been constructed from a group of animation node resources.
animationStateComplete — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when an animation state has been constructed from a group of animation node resources.
animationStateComplete — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when an animation state has been constructed from a group of animation node resources.
ANIMATION_STATE_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
AnimationStateEvent — class, package away3d.events
 | Dispatched to notify changes in an animation state's state.
AnimationStateEvent(type:String, animator:away3d.animators:IAnimator, animationState:away3d.animators.states:IAnimationState, animationNode:away3d.animators.nodes:AnimationNodeBase) — Constructor, class away3d.events.AnimationStateEvent
 | Create a new AnimatonStateEvent
animationSubGeometry — Property, class away3d.core.base.SubMesh
AnimationSubGeometry — class, package away3d.animators.data
 | ...
AnimationSubGeometry() — Constructor, class away3d.animators.data.AnimationSubGeometry
_animationTargetRegisters — Property, class away3d.materials.compilation.ShaderCompiler
animationTargetRegisters — Property, class away3d.materials.compilation.ShaderCompiler
_animationTargetRegisters — Property, class away3d.materials.passes.MaterialPassBase
_animator — Property, class away3d.animators.states.AnimationStateBase
animator — Property, interface away3d.core.base.IMaterialOwner
 | The animation used by the material to assemble the vertex code.
animator — Property, class away3d.core.base.SubMesh
 | The animator object that provides the state for the SubMesh's animation.
animator — Property, class away3d.entities.Mesh
 | Defines the animator of the mesh.
animator — Property, class away3d.entities.SegmentSet
animator — Property, class away3d.entities.Sprite3D
 | Defines the animator of the mesh.
animator — Property, class away3d.events.AnimationStateEvent
 | The animator object that is the subject of this event.
animator — Property, class away3d.events.AnimatorEvent
animator — Property, class away3d.primitives.SkyBox
AnimatorBase — class, package away3d.animators
 | Provides an abstract base class for animator classes that control animation output from a data set subtype of AnimationSetBase.
AnimatorBase(animationSet:away3d.animators:IAnimationSet) — Constructor, class away3d.animators.AnimatorBase
 | Creates a new AnimatorBase object.
animatorComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when a animator asset has been constructed from a resource.
animatorComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when a animator asset has been constructed from a resource.
animatorComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when a animator asset has been constructed from a resource.
animatorComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when a animator asset has been constructed from a resource.
animatorComplete — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when a animator asset has been constructed from a resource.
animatorComplete — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when a animator asset has been constructed from a resource.
AnimatorEvent — class, package away3d.events
 | Dispatched to notify changes in an animator's state.
AnimatorEvent(type:String, animator:away3d.animators:AnimatorBase) — Constructor, class away3d.events.AnimatorEvent
 | Create a new AnimatorEvent object.
animatorSubGeometry — Property, class away3d.core.base.SubMesh
AnisotropicSpecularMethod — class, package away3d.materials.methods
AnisotropicSpecularMethod() — Constructor, class away3d.materials.methods.AnisotropicSpecularMethod
antiAlias — Property, class away3d.containers.View3D
 | The amount of anti-aliasing to be used.
antiAlias — Property, class away3d.core.managers.Stage3DProxy
 | The antiAliasing of the Stage3D.
_antiAlias — Property, class away3d.core.render.RendererBase
antiAlias — Property, class away3d.core.render.RendererBase
APPEND_NUM_SUFFIX — Constant Static Property, class away3d.library.naming.ConflictStrategy
 | Specifies that in case of a naming conflict, one of the assets will be renamed and a numeric suffix appended to the base name.
apply(geom:away3d.core.base:Geometry, keepNormals:Boolean) — method, class away3d.tools.commands.Explode
apply(mesh1:away3d.entities:Mesh, mesh2:away3d.entities:Mesh) — method, class away3d.tools.commands.Merge
 | Merge 2 meshes into one.
apply(mesh:away3d.entities:Mesh, axis:int, offset:String) — method, class away3d.tools.commands.Mirror
apply(geom:away3d.core.base:Geometry, keepUvs:Boolean, normalAngleThresholdRadians:Number) — method, class away3d.tools.commands.Weld
applyDirectionalLight(light:away3d.lights:DirectionalLight) — method, class away3d.core.traverse.EntityCollector
applyDirectionalLight(light:away3d.lights:DirectionalLight) — method, class away3d.core.traverse.PartitionTraverser
applyDirectionalLight(light:away3d.lights:DirectionalLight) — method, class away3d.core.traverse.ShadowCasterCollector
applyEntity(entity:away3d.entities:Entity) — method, class away3d.core.traverse.EntityCollector
 | Registers an entity for use.
applyEntity(entity:away3d.entities:Entity) — method, class away3d.core.traverse.PartitionTraverser
 | Registers an entity for use.
applyLightProbe(light:away3d.lights:LightProbe) — method, class away3d.core.traverse.EntityCollector
applyLightProbe(light:away3d.lights:LightProbe) — method, class away3d.core.traverse.PartitionTraverser
applyLightProbe(light:away3d.lights:LightProbe) — method, class away3d.core.traverse.ShadowCasterCollector
applyPointLight(light:away3d.lights:PointLight) — method, class away3d.core.traverse.EntityCollector
applyPointLight(light:away3d.lights:PointLight) — method, class away3d.core.traverse.PartitionTraverser
applyPointLight(light:away3d.lights:PointLight) — method, class away3d.core.traverse.ShadowCasterCollector
applyPosition(mesh:away3d.entities:Mesh, dx:Number, dy:Number, dz:Number) — Static Method , class away3d.tools.helpers.MeshHelper
 | Applys an offset to a mesh at vertices level
applyRenderable(renderable:away3d.core.base:IRenderable) — method, class away3d.core.traverse.EntityCollector
 | Adds an IRenderable object to the potentially visible objects.
applyRenderable(renderable:away3d.core.base:IRenderable) — method, class away3d.core.traverse.PartitionTraverser
 | Passes an IRenderable object to be processed by the traverser.
applyRenderable(renderable:away3d.core.base:IRenderable) — method, class away3d.core.traverse.ShadowCasterCollector
 | Adds an IRenderable object to the potentially visible objects.
applyRotations(mesh:away3d.entities:Mesh) — Static Method , class away3d.tools.helpers.MeshHelper
 | Applys the rotation values of a mesh in object space and resets rotations to zero.
applyRotationsContainer(obj:away3d.containers:ObjectContainer3D) — Static Method , class away3d.tools.helpers.MeshHelper
 | Applys the rotation values of each mesh found into an ObjectContainer3D
applyScales(mesh:away3d.entities:Mesh, scaleX:Number, scaleY:Number, scaleZ:Number, parent:away3d.containers:ObjectContainer3D) — Static Method , class away3d.tools.helpers.MeshHelper
 | Applys the scaleX, scaleY and scaleZ scale factors to the mesh vertices.
applyScalesContainer(obj:away3d.containers:ObjectContainer3D, scaleX:Number, scaleY:Number, scaleZ:Number, parent:away3d.containers:ObjectContainer3D) — Static Method , class away3d.tools.helpers.MeshHelper
 | Applys the scale properties values of each mesh found into an ObjectContainer3D
applySkyBox(renderable:away3d.core.base:IRenderable) — method, class away3d.core.traverse.EntityCollector
 | Adds a skybox to the potentially visible objects.
applySkyBox(renderable:away3d.core.base:IRenderable) — method, class away3d.core.traverse.PartitionTraverser
 | Passes a skybox to be processed by the traverser.
applySkyBox(renderable:away3d.core.base:IRenderable) — method, class away3d.core.traverse.ShadowCasterCollector
applyToContainer(ctr:away3d.containers:ObjectContainer3D, keepNormals:Boolean) — method, class away3d.tools.commands.Explode
 | Apply the explode code to a given ObjectContainer3D.
applyToContainer(object:away3d.containers:ObjectContainer3D, name:String) — method, class away3d.tools.commands.Merge
 | Merges all the children of a container as one single Mesh.
applyToContainer(ctr:away3d.containers:ObjectContainer3D, axis:int, offset:String) — method, class away3d.tools.commands.Mirror
applyToContainer(obj:away3d.containers:ObjectContainer3D, keepUVs:Boolean, normalThreshold:Number) — method, class away3d.tools.commands.Weld
applyToMeshes(receiver:away3d.entities:Mesh, meshes:Vector$away3d.entities:Mesh) — method, class away3d.tools.commands.Merge
 | Merges all the meshes found into the Vector.<Mesh> parameter with the receiver Mesh.
applyTransform(matrix:flash.geom:Matrix3D) — method, class away3d.textures.PlanarReflectionTexture
 | Sets the plane to match a given matrix.
applyTransformation(transform:flash.geom:Matrix3D) — method, class away3d.core.base.CompactSubGeometry
applyTransformation(transform:flash.geom:Matrix3D) — method, class away3d.core.base.Geometry
applyTransformation(transform:flash.geom:Matrix3D) — method, interface away3d.core.base.ISubGeometry
applyTransformation(transform:flash.geom:Matrix3D) — method, class away3d.core.base.SubGeometry
applyTransformation(transform:flash.geom:Matrix3D) — method, class away3d.core.base.SubGeometryBase
applyTransformation(transform:flash.geom:Matrix3D) — method, class away3d.primitives.PrimitiveBase
applyUnknownLight(light:away3d.lights:LightBase) — method, class away3d.core.traverse.EntityCollector
 | Adds a light to the potentially visible objects.
applyUnknownLight(light:away3d.lights:LightBase) — method, class away3d.core.traverse.PartitionTraverser
 | Passes a light to be processed by the traverser.
applyUnknownLight(light:away3d.lights:LightBase) — method, class away3d.core.traverse.ShadowCasterCollector
AS3_BEST_HIT — Constant Static Property, class away3d.core.pick.PickingColliderType
 | Pure AS3 picking collider that returns the best (closest) hit on an Entity.
AS3_FIRST_ENCOUNTERED — Constant Static Property, class away3d.core.pick.PickingColliderType
 | Pure AS3 picking collider that returns the first encountered hit on an Entity.
AS3PickingCollider — class, package away3d.core.pick
 | Pure AS3 picking collider for entity objects.
AS3PickingCollider(findClosestCollision:Boolean) — Constructor, class away3d.core.pick.AS3PickingCollider
 | Creates a new AS3PickingCollider object.
aspectRatio — Property, class away3d.cameras.lenses.FreeMatrixLens
_aspectRatio — Property, class away3d.cameras.lenses.LensBase
aspectRatio — Property, class away3d.cameras.lenses.LensBase
aspectRatio — Property, class away3d.cameras.lenses.ObliqueNearPlaneLens
_aspectRatio — Property, class away3d.containers.View3D
aspectRatio — Property, class away3d.entities.TextureProjector
 | The aspect ratio of the texture or projection.
assemble(mode:String, source:String) — method, class com.adobe.utils.AGALMiniAssembler
asset — Property, class away3d.events.AssetEvent
assetComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when any asset finishes parsing.
assetComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when any asset finishes parsing.
assetComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when any asset finishes parsing.
assetComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when any asset finishes parsing.
assetComplete — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when any asset finishes parsing.
assetComplete — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when any asset finishes parsing.
ASSET_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
ASSET_CONFLICT_RESOLVED — Constant Static Property, class away3d.events.AssetEvent
AssetEvent — class, package away3d.events
AssetEvent(type:String, asset:away3d.library.assets:IAsset, prevName:String) — Constructor, class away3d.events.AssetEvent
assetFullPath — Property, interface away3d.library.assets.IAsset
assetFullPath — Property, class away3d.library.assets.NamedAssetBase
AssetLibrary — class, package away3d.library
 | AssetLibrary enforces a singleton pattern and is not intended to be instanced.
AssetLibrary(se:AssetLibrary.as$336:AssetLibrarySingletonEnforcer) — Constructor, class away3d.library.AssetLibrary
 | Creates a new AssetLibrary object.
AssetLibraryBundle — class, package away3d.library
 | AssetLibraryBundle enforces a multiton pattern and is not intended to be instanced directly.
AssetLibraryBundle(me:AssetLibraryBundle.as$61:AssetLibraryBundleSingletonEnforcer) — Constructor, class away3d.library.AssetLibraryBundle
 | Creates a new AssetLibraryBundle object.
AssetLibraryIterator — class, package away3d.library.utils
AssetLibraryIterator(assets:Vector$away3d.library.assets:IAsset, assetTypeFilter:String, namespaceFilter:String, filterFunc:Function) — Constructor, class away3d.library.utils.AssetLibraryIterator
AssetLoader — class, package away3d.loaders
 | AssetLoader can load any file format that Away3D supports (or for which a third-party parser has been plugged in) and it's dependencies.
AssetLoader() — Constructor, class away3d.loaders.AssetLoader
 | Create a new ResourceLoadSession object.
AssetLoaderContext — class, package away3d.loaders.misc
AssetLoaderContext(includeDependencies:Boolean, dependencyBaseUrl:String) — Constructor, class away3d.loaders.misc.AssetLoaderContext
 | AssetLoaderContext provides configuration for the AssetLoader load() and parse() operations.
AssetLoaderToken — class, package away3d.loaders.misc
 | Instances of this class are returned as tokens by loading operations to provide an object on which events can be listened for in cases where the actual asset loader is not directly available (e.g.
AssetLoaderToken(loader:away3d.loaders:AssetLoader) — Constructor, class away3d.loaders.misc.AssetLoaderToken
assetNamespace — Property, interface away3d.library.assets.IAsset
assetNamespace — Property, class away3d.library.assets.NamedAssetBase
assetPathEquals(name:String, ns:String) — method, interface away3d.library.assets.IAsset
assetPathEquals(name:String, ns:String) — method, class away3d.library.assets.NamedAssetBase
assetPrevName — Property, class away3d.events.AssetEvent
ASSET_RENAME — Constant Static Property, class away3d.events.AssetEvent
assets — Property, class away3d.loaders.misc.ResourceDependency
assetType — Property, class away3d.animators.AnimationSetBase
assetType — Property, class away3d.animators.data.Skeleton
assetType — Property, class away3d.animators.data.SkeletonPose
assetType — Property, class away3d.animators.nodes.AnimationNodeBase
assetType — Property, class away3d.containers.ObjectContainer3D
assetType — Property, class away3d.core.base.Geometry
assetType — Property, class away3d.entities.Entity
assetType — Property, class away3d.entities.Mesh
assetType — Property, class away3d.entities.SegmentSet
assetType — Property, class away3d.library.assets.BitmapDataAsset
assetType — Property, interface away3d.library.assets.IAsset
assetType — Property, class away3d.materials.MaterialBase
assetType — Property, class away3d.textures.TextureProxyBase
AssetType — class, package away3d.library.assets
ATFCubeTexture — class, package away3d.textures
ATFCubeTexture(byteArray:flash.utils:ByteArray) — Constructor, class away3d.textures.ATFCubeTexture
atfData — Property, class away3d.textures.ATFCubeTexture
atfData — Property, class away3d.textures.ATFTexture
ATFData — class, package away3d.textures
ATFData(data:flash.utils:ByteArray) — Constructor, class away3d.textures.ATFData
 | Create a new instance by parsing the given byte array.
ATFTexture — class, package away3d.textures
ATFTexture(byteArray:flash.utils:ByteArray) — Constructor, class away3d.textures.ATFTexture
AUTO_BEST_HIT — Constant Static Property, class away3d.core.pick.PickingColliderType
 | Auto-selecting picking collider that returns the best (closest) hit on an Entity Chooses between pure AS3 picking and PixelBender picking based on a threshold property representing the number of triangles encountered in a SubMesh object over which PixelBender is used.
autoDeriveVertexNormals — Property, interface away3d.core.base.ISubGeometry
_autoDeriveVertexNormals — Property, class away3d.core.base.SubGeometryBase
autoDeriveVertexNormals — Property, class away3d.core.base.SubGeometryBase
 | True if the vertex normals should be derived from the geometry, false if the vertex normals are set explicitly.
autoDeriveVertexTangents — Property, interface away3d.core.base.ISubGeometry
_autoDeriveVertexTangents — Property, class away3d.core.base.SubGeometryBase
autoDeriveVertexTangents — Property, class away3d.core.base.SubGeometryBase
 | True if the vertex tangents should be derived from the geometry, false if the vertex normals are set explicitly.
AUTO_FIRST_ENCOUNTERED — Constant Static Property, class away3d.core.pick.PickingColliderType
 | Auto-selecting picking collider that returns the first encountered hit on an Entity.
autoGenerateDummyUVs — Property, class away3d.core.base.SubGeometryBase
 | Defines whether a UV buffer should be automatically generated to contain dummy UV coordinates.
_autoGenerateUVs — Property, class away3d.core.base.SubGeometryBase
AutoPickingCollider — class, package away3d.core.pick
 | Auto-selecting picking collider for entity objects.
AutoPickingCollider(findClosestCollision:Boolean) — Constructor, class away3d.core.pick.AutoPickingCollider
 | Creates a new AutoPickingCollider object.
autoPlay — Property, class away3d.textures.VideoTexture
 | Indicates whether the video will start playing on initialisation.
autoUpdate — Property, class away3d.animators.AnimatorBase
 | Determines whether the animators internal update mechanisms are active.
_autoUpdate — Property, class away3d.controllers.ControllerBase
autoUpdate — Property, class away3d.controllers.ControllerBase
 | Determines whether the controller applies updates automatically.
autoUpdate — Property, class away3d.textures.VideoTexture
 | Indicates whether the material will redraw onEnterFrame
autoUpdate — Property, class away3d.textures.WebcamTexture
 | Defines whether the texture should automatically update while camera stream is playing.
autoUpdateShadows — Property, class away3d.lights.shadowmaps.ShadowMapperBase
AVERAGE — Constant Static Property, class away3d.tools.commands.Align
averaged — Property, class away3d.paths.QuadraticPath
 | returns true if the averagePath handler is being used.
averagePath() — method, class away3d.paths.QuadraticPath
 | handler will average the path using averages of the PathSegments note that this is not dynamic, the path values are overwrited
avg_fps — Property, class away3d.debug.AwayStats
away3d — package
Away3D — class, package away3d
 | Helper class to track a few important library constants.
away3d.animators — package
away3d.animators.data — package
away3d.animators.nodes — package
away3d.animators.states — package
away3d.animators.transitions — package
away3d.animators.utils — package
away3d.audio — package
away3d.audio.drivers — package
away3d.bounds — package
away3d.cameras — package
away3d.cameras.lenses — package
away3d.containers — package
away3d.controllers — package
away3d.core.base — package
away3d.core.base.data — package
away3d.core.data — package
away3d.core.managers — package
away3d.core.math — package
away3d.core.partition — package
away3d.core.pick — package
away3d.core.render — package
away3d.core.sort — package
away3d.core.traverse — package
away3d.debug — package
away3d.debug.data — package
away3d.entities — package
away3d.errors — package
away3d.events — package
away3d.extrusions — package
away3d.filters — package
away3d.filters.tasks — package
away3d.library — package
away3d.library.assets — package
away3d.library.naming — package
away3d.library.utils — package
away3d.lights — package
away3d.lights.shadowmaps — package
away3d.loaders — package
away3d.loaders.misc — package
away3d.loaders.parsers — package
away3d.loaders.parsers.utils — package
away3d.materials — package
away3d.materials.compilation — package
away3d.materials.lightpickers — package
away3d.materials.methods — package
away3d.materials.passes — package
away3d.materials.utils — package
away3d.paths — package
away3d.primitives — package
away3d.primitives.data — package
away3d.stereo — package
away3d.stereo.methods — package
away3d.textures — package
away3d.tools.commands — package
away3d.tools.helpers — package
away3d.tools.helpers.data — package
away3d.tools.serialize — package
away3d.tools.utils — package
away3d.utils — package
AwayStats — class, package away3d.debug
 | Stats monitor for Away3D or general use in any project.
AwayStats(view3d:away3d.containers:View3D, minimized:Boolean, transparent:Boolean, meanDataLength:uint, enableClickToReset:Boolean, enableModifyFrameRate:Boolean) — Constructor, class away3d.debug.AwayStats
 | Create an Away3D stats widget.
AWD1Parser — class, package away3d.loaders.parsers
 | AWD1Parser provides a parser for the AWD data type.
AWD1Parser() — Constructor, class away3d.loaders.parsers.AWD1Parser
 | Creates a new AWD1Parser object.
AWD2Parser — class, package away3d.loaders.parsers
 | AWDParser provides a parser for the AWD data type.
AWD2Parser() — Constructor, class away3d.loaders.parsers.AWD2Parser
 | Creates a new AWDParser object.
AWD_FIELD_BADDR — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_BOOL — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_BYTEARRAY — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_COLOR — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_FLOAT32 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_FLOAT64 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_INT16 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_INT32 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_INT8 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_MTX3x2 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_MTX3x3 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_MTX4x3 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_MTX4x4 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_STRING — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_UINT16 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_UINT32 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_UINT8 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_VECTOR2x1 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_VECTOR3x1 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWD_FIELD_VECTOR4x1 — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
AWDParser — class, package away3d.loaders.parsers
 | The AWDParser class is a wrapper for both AWD1Parser and AWD2Parser, and will find the right concrete parser for an AWD file.
AWDParser() — Constructor, class away3d.loaders.parsers.AWDParser
axis — Property, class away3d.animators.nodes.ParticleUVNode
axis — Property, class away3d.extrusions.LatheExtrude
 | Defines the axis used for the lathe rotation.
axis — Property, class away3d.extrusions.LinearExtrude
 | Defines the axis used for the extrusion.
AxisAlignedBoundingBox — class, package away3d.bounds
 | AxisAlignedBoundingBox represents a bounding box volume that has its planes aligned to the local coordinate axes of the bounded object.
AxisAlignedBoundingBox() — Constructor, class away3d.bounds.AxisAlignedBoundingBox
 | Creates a new AxisAlignedBoundingBox object.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


All Classes

Away3D Documentation | All Packages | Index | Frames No Frames | Adobe Logo
All Classes |

Documentation for classes includes syntax, usage information, and code samples for methods, properties, and event handlers and listeners for those APIs that belong to a specific class in ActionScript. The classes are listed alphabetically. If you are not sure to which class a certain method or property belongs, you can look it up in the Index.

Class | Package | Description
AbstractMethodError | away3d.errors | AbstractMethodError is thrown when an abstract method is called.
AbstractSound3DDriver | away3d.audio.drivers |
AC3DParser | away3d.loaders.parsers | AC3DParser provides a parser for the AC3D data type.
AGALMiniAssembler | com.adobe.utils |
AGALProgram3DCache | away3d.core.managers |
Align | away3d.tools.commands | Class Aligns an arrays of Object3Ds, Vector3D's or Vertexes compaired to each other.Align
AlphaMaskMethod | away3d.materials.methods | Allows the use of an additional texture to specify the alpha value of the material.
AnaglyphStereoRenderMethod | away3d.stereo.methods |
AnimationClipNodeBase | away3d.animators.nodes | Provides an abstract base class for nodes with time-based animation data in an animation blend tree.
AnimationClipState | away3d.animators.states |
AnimationNodeBase | away3d.animators.nodes | Provides an abstract base class for nodes in an animation blend tree.
AnimationRegisterCache | away3d.animators.data | ...
AnimationSetBase | away3d.animators | Provides an abstract base class for data set classes that hold animation data for use in animator classes.
AnimationSetError | away3d.errors |
AnimationStateBase | away3d.animators.states |
AnimationStateEvent | away3d.events | Dispatched to notify changes in an animation state's state.
AnimationSubGeometry | away3d.animators.data | ...
AnimatorBase | away3d.animators | Provides an abstract base class for animator classes that control animation output from a data set subtype of AnimationSetBase.
AnimatorEvent | away3d.events | Dispatched to notify changes in an animator's state.
AnisotropicSpecularMethod | away3d.materials.methods |
AS3PickingCollider | away3d.core.pick | Pure AS3 picking collider for entity objects.
AssetEvent | away3d.events |
AssetLibrary | away3d.library | AssetLibrary enforces a singleton pattern and is not intended to be instanced.
AssetLibraryBundle | away3d.library | AssetLibraryBundle enforces a multiton pattern and is not intended to be instanced directly.
AssetLibraryIterator | away3d.library.utils |
AssetLoader | away3d.loaders | AssetLoader can load any file format that Away3D supports (or for which a third-party parser has been plugged in) and it's dependencies.
AssetLoaderContext | away3d.loaders.misc |
AssetLoaderToken | away3d.loaders.misc | Instances of this class are returned as tokens by loading operations to provide an object on which events can be listened for in cases where the actual asset loader is not directly available (e.g.
AssetType | away3d.library.assets |
ATFCubeTexture | away3d.textures |
ATFData | away3d.textures |
ATFTexture | away3d.textures |
AutoPickingCollider | away3d.core.pick | Auto-selecting picking collider for entity objects.
Away3D | away3d | Helper class to track a few important library constants.
AwayStats | away3d.debug | Stats monitor for Away3D or general use in any project.
AWD1Parser | away3d.loaders.parsers | AWD1Parser provides a parser for the AWD data type.
AWD2Parser | away3d.loaders.parsers | AWDParser provides a parser for the AWD data type.
AWDParser | away3d.loaders.parsers | The AWDParser class is a wrapper for both AWD1Parser and AWD2Parser, and will find the right concrete parser for an AWD file.
AxisAlignedBoundingBox | away3d.bounds | AxisAlignedBoundingBox represents a bounding box volume that has its planes aligned to the local coordinate axes of the bounded object.
BackgroundImageRenderer | away3d.core.render |
BasicAmbientMethod | away3d.materials.methods | BasicAmbientMethod provides the default shading method for uniform ambient lighting.
BasicDiffuseMethod | away3d.materials.methods | BasicDiffuseMethod provides the default shading method for Lambert (dot3) diffuse lighting.
BasicNormalMethod | away3d.materials.methods |
BasicSpecularMethod | away3d.materials.methods | BasicSpecularMethod provides the default shading method for Blinn-Phong specular highlights.
BitmapCubeTexture | away3d.textures |
BitmapDataAsset | away3d.library.assets | BitmapDataResource is a wrapper for loaded BitmapData, allowing it to be used uniformly as a resource when loading, parsing, and listing/resolving dependencies.
BitmapTexture | away3d.textures |
BitmapTextureCache | away3d.textures | DEPRECRATED along with BitmapMaterial.
BloomFilter3D | away3d.filters |
BlurFilter3D | away3d.filters |
BoundingSphere | away3d.bounds | BoundingSphere represents a spherical bounding volume defined by a center point and a radius.
BoundingVolumeBase | away3d.bounds | An abstract base class for all bounding volume classes.
Bounds | away3d.tools.utils | Helper Class to retrieve objects bounds Bounds
Camera3D | away3d.cameras | A Camera3D object represents a virtual camera through which we view the scene.
CameraNode | away3d.core.partition | CameraNode is a space partitioning leaf node that contains a Camera3D object.
CapsuleGeometry | away3d.primitives | A UV Capsule primitive mesh.
CascadeShadowMapMethod | away3d.materials.methods |
CascadeShadowMapper | away3d.lights.shadowmaps |
Cast | away3d.utils | Helper class for casting assets to usable objects
CastError | away3d.errors |
CelDiffuseMethod | away3d.materials.methods | CelDiffuseMethod provides a shading method to add specular cel (cartoon) shading.
CelSpecularMethod | away3d.materials.methods | CelSpecularMethod provides a shading method to add diffuse cel (cartoon) shading.
ColorHitMap | away3d.tools.utils |
ColorMaterial | away3d.materials | ColorMaterial is a material that uses a flat colour as the surfaces diffuse.
ColorMatrixMethod | away3d.materials.methods | ColorMatrixMethod provides a shading method that changes the colour of a material according to a ColorMatrixFilter object.
ColorMultiPassMaterial | away3d.materials | ColorMaterial is a material that uses a flat colour as the surfaces diffuse.
ColorTransformMethod | away3d.materials.methods | ColorTransformMethod provides a shading method that changes the colour of a material according to a ColorTransform object.
CompactSubGeometry | away3d.core.base |
CompiledPass | away3d.materials.passes |
CompositeDiffuseMethod | away3d.materials.methods | CompositeDiffuseMethod provides a base class for diffuse methods that wrap a diffuse method to alter the strength of its calculated strength.
CompositeSpecularMethod | away3d.materials.methods | CompositeSpecularMethod provides a base class for specular methods that wrap a specular method to alter the strength of its calculated strength.
ConeGeometry | away3d.primitives | A UV Cone primitive mesh.
ConflictPrecedence | away3d.library.naming | Enumaration class for precedence when resolving naming conflicts in the library.
ConflictStrategy | away3d.library.naming | Enumeration class for bundled conflict strategies.
ConflictStrategyBase | away3d.library.naming | Abstract base class for naming conflict resolution classes.
ControllerBase | away3d.controllers |
CrossfadeTransition | away3d.animators.transitions |
CrossfadeTransitionNode | away3d.animators.transitions | A skeleton animation node that uses two animation node inputs to blend a lineraly interpolated output of a skeleton pose.
CrossfadeTransitionState | away3d.animators.transitions |
CubeGeometry | away3d.primitives | A Cube primitive mesh.
CubeMapShadowMapper | away3d.lights.shadowmaps |
CubeReflectionTexture | away3d.textures | CubeReflectionTexture provides a cube map texture for real-time reflections, used for any method that uses environment maps, such as EnvMapMethod.
CubeTextureBase | away3d.textures |
CubicPath | away3d.paths | Defines a cubic path.
CubicPathSegment | away3d.paths | Defines a single segment of a cubic path
CylinderGeometry | away3d.primitives | A UV Cylinder primitive mesh.
DAEParser | away3d.loaders.parsers | DAEParser provides a parser for the DAE data type.
Debug | away3d.debug | Class for emmiting debuging messages, warnings and errors
DefaultMaterialManager | away3d.materials.utils |
DefaultRenderer | away3d.core.render | The DefaultRenderer class provides the default rendering method.
DelaunayMesh | away3d.extrusions |
DeprecationError | away3d.errors |
DepthDiffuseMethod | away3d.materials.methods | DepthDiffuseMethod provides a debug method to visualise depth maps
DepthMapPass | away3d.materials.passes |
DepthOfFieldFilter3D | away3d.filters |
DepthRenderer | away3d.core.render | The DepthRenderer class renders 32-bit depth information encoded as RGBA
DirectionalLight | away3d.lights | DirectionalLight represents an idealized light "at infinity", to be used for distant light sources such as the sun.
DirectionalLightNode | away3d.core.partition | LightNode is a space partitioning leaf node that contains a LightBase object.
DirectionalShadowMapper | away3d.lights.shadowmaps |
DistanceMapPass | away3d.materials.passes |
DitheredShadowMapMethod | away3d.materials.methods | DitheredShadowMapMethod provides a soft shadowing technique by randomly distributing sample points.
Drag3D | away3d.tools.utils | Class Drag3D allows free dragging of an ObjectContainer3D onto a given plane.
DXFParser | away3d.loaders.parsers | DXFParser provides a parser for the dxf 3D renderable data.
DynamicGrid | away3d.core.partition | DynamicGrid is used by certain partitioning systems that require vislists for regions of dynamic data.
EffectMethodBase | away3d.materials.methods | EffectMethodBase forms an abstract base class for shader methods that are not dependent on light sources, and are in essence post-process effects on the materials.
Elevation | away3d.extrusions |
Entity | away3d.entities | The Entity class provides an abstract base class for all scene graph objects that are considered having a "presence" in the scene, in the sense that it can be considered an actual object with a position and a size (even if infinite or idealised), rather than a grouping.
EntityCollector | away3d.core.traverse | The EntityCollector class is a traverser for scene partitions that collects all scene graph entities that are considered potientially visible.
EntityListItem | away3d.core.data |
EntityListItemPool | away3d.core.data |
EntityNode | away3d.core.partition | The EntityNode class provides an abstract base class for leaf nodes in a partition tree, containing entities to be fed to the EntityCollector traverser.
EnvMapAmbientMethod | away3d.materials.methods | EnvMapDiffuseMethod provides a diffuse shading method that uses a diffuse irradiance environment map to approximate global lighting rather than lights.
EnvMapMethod | away3d.materials.methods |
ErrorConflictStrategy | away3d.library.naming |
Explode | away3d.tools.commands | Class Explode make all vertices and uv's of a mesh unicExplode
Face | away3d.core.base.data | Face value object.
FaceHelper | away3d.tools.helpers | Helper Class for face manipulationFaceHelper
Filter3DBase | away3d.filters |
Filter3DBrightPassTask | away3d.filters.tasks |
Filter3DCompositeTask | away3d.filters.tasks |
Filter3DDoubleBufferCopyTask | away3d.filters.tasks |
Filter3DHBlurTask | away3d.filters.tasks |
Filter3DHDepthOfFFieldTask | away3d.filters.tasks |
Filter3DHueSaturationTask | away3d.filters.tasks |
Filter3DRadialBlurTask | away3d.filters.tasks |
Filter3DRenderer | away3d.core.render |
Filter3DTaskBase | away3d.filters.tasks |
Filter3DVBlurTask | away3d.filters.tasks |
Filter3DVDepthOfFFieldTask | away3d.filters.tasks |
Filter3DXFadeCompositeTask | away3d.filters.tasks |
FilteredShadowMapMethod | away3d.materials.methods |
FirstPersonController | away3d.controllers | Extended camera used to hover round a specified target object.
FogMethod | away3d.materials.methods |
FollowController | away3d.controllers | Controller used to follow behind an object on the XZ plane, with an optional elevation (tiltAngle).
FreeMatrixLens | away3d.cameras.lenses | FreeMatrixLens provides a projection lens that exposes a full projection matrix, rather than provide one through more user-friendly settings.
FresnelEnvMapMethod | away3d.materials.methods |
FresnelPlanarReflectionMethod | away3d.materials.methods | Allows the use of an additional texture to specify the alpha value of the material.
FresnelSpecularMethod | away3d.materials.methods | FresnelSpecularMethod provides a specular shading method that is stronger on shallow view angles.
Geometry | away3d.core.base | Geometry is a collection of SubGeometries, each of which contain the actual geometrical data such as vertices, normals, uvs, etc.
GeometryEvent | away3d.events | Dispatched to notify changes in a geometry object's state.
GeometryUtil | away3d.utils |
GeomUtil | away3d.tools.utils |
Grid | away3d.tools.utils | Class Grid snaps vertexes or meshes according to a given grid unit.Grid
HardShadowMapMethod | away3d.materials.methods |
HBlurFilter3D | away3d.filters |
HDepthOfFieldFilter3D | away3d.filters |
HeightMapNormalMethod | away3d.materials.methods |
HoverController | away3d.controllers | Extended camera used to hover round a specified target object.
HueSaturationFilter3D | away3d.filters |
IAnimationSet | away3d.animators | Provides an interface for data set classes that hold animation data for use in animator classes.
IAnimationState | away3d.animators.states |
IAnimationTransition | away3d.animators.transitions |
IAnimator | away3d.animators | Provides an interface for animator classes that control animation output from a data set subtype of AnimationSetBase.
IAsset | away3d.library.assets |
IEntitySorter | away3d.core.sort | EntitySorterBase provides an abstract base class to sort geometry information in an EntityCollector object for rendering.
IgnoreConflictStrategy | away3d.library.naming |
ImageParser | away3d.loaders.parsers | ImageParser provides a "parser" for natively supported image types (jpg, png).
IMaterialOwner | away3d.core.base | IMaterialOwner provides an interface for objects that can use materials.
InterleavedStereoRenderMethod | away3d.stereo.methods |
InvalidTextureError | away3d.errors | TextureError is thrown when an invalid texture is used regarding Stage3D limitations.
InvertedOctreeNode | away3d.core.partition | InvertedOctreeNode is an octree data structure not used hierarchically for culling, but for fast dynamic insertion.
IPath | away3d.paths |
IPathSegment | away3d.paths |
IPicker | away3d.core.pick | Provides an interface for picking objects that can pick 3d objects from a view or scene.
IPickingCollider | away3d.core.pick | Provides an interface for picking colliders that can be assigned to individual entities in a scene for specific picking behaviour.
IRenderable | away3d.core.base | IRenderable provides an interface for objects that can be rendered in the rendering pipeline.
ISkeletonAnimationState | away3d.animators.states |
ISound3DDriver | away3d.audio.drivers |
ISubGeometry | away3d.core.base |
IUVAnimationState | away3d.animators.states | Provides an interface for animation node classes that hold animation data for use in the UV animator class.
IVertexAnimationState | away3d.animators.states | Provides an interface for animation node classes that hold animation data for use in the Vertex animator class.
IVideoPlayer | away3d.materials.utils |
JointPose | away3d.animators.data | Contains transformation data for a skeleton joint, used for skeleton animation.
LatheExtrude | away3d.extrusions | Class for generating meshes with axial symmetry such as donuts, pipes, vases etc.
LensBase | away3d.cameras.lenses | An abstract base class for all lens classes.
LensEvent | away3d.events |
LightBase | away3d.lights | LightBase provides an abstract base class for subtypes representing lights.
LightEvent | away3d.events |
LightingMethodBase | away3d.materials.methods | LightingMethodBase provides an abstract base method for shading methods that uses lights.
LightingPass | away3d.materials.passes | DefaultScreenPass is a shader pass that uses shader methods to compile a complete program.
LightingShaderCompiler | away3d.materials.compilation |
LightMapDiffuseMethod | away3d.materials.methods |
LightMapMethod | away3d.materials.methods |
LightNode | away3d.core.partition | LightNode is a space partitioning leaf node that contains a LightBase object.
LightPickerBase | away3d.materials.lightpickers |
LightProbe | away3d.lights |
LightProbeNode | away3d.core.partition | LightNode is a space partitioning leaf node that contains a LightBase object.
LightsHelper | away3d.tools.helpers | Helper Class for the LightBase objects LightsHelper A series of methods to ease work with LightBase objects
LightSources | away3d.materials | Enumeration class for defining which lighting types affects the specific material lighting component (diffuse and specular).
LinearExtrude | away3d.extrusions |
LineSegment | away3d.primitives | A Line Segment primitive.
Loader3D | away3d.loaders | Loader3D can load any file format that Away3D supports (or for which a third-party parser has been plugged in) and be added directly to the scene.
LoaderEvent | away3d.events | LoaderEvent is an Event dispatched to notify changes in loading state.
LookAtController | away3d.controllers | Extended camera used to automatically look at a specified target object.
MaterialBase | away3d.materials | MaterialBase forms an abstract base class for any material.
MaterialPassBase | away3d.materials.passes | MaterialPassBase provides an abstract base class for material shader passes.
MathConsts | away3d.core.math | MathConsts provides some commonly used mathematical constants
Matrix3DUtils | away3d.core.math | Matrix3DUtils provides additional Matrix3D math functions.
Max3DSParser | away3d.loaders.parsers |
MD2Parser | away3d.loaders.parsers | MD2Parser provides a parser for the MD2 data type.
MD5AnimParser | away3d.loaders.parsers | AWDParser provides a parser for the AWD data type, providing an animation sequence for the md5 format.
MD5MeshParser | away3d.loaders.parsers | AWDParser provides a parser for the md5mesh data type, providing the geometry of the md5 format.
Merge | away3d.tools.commands | Class Merge merges two or more static meshes into one.Merge
Mesh | away3d.entities | Mesh is an instance of a Geometry, augmenting it with a presence in the scene graph, a material, and an animation state.
MeshDebug | away3d.tools.helpers.data | MeshDebug, holds the data for the MeshDebugger class
MeshDebugger | away3d.tools.helpers | Helper Class for Mesh objects MeshDebugger Displays the normals, tangents and vertexNormals of a given mesh.
MeshHelper | away3d.tools.helpers | Helper Class for the Mesh object MeshHelper A series of methods usually usefull for mesh manipulations
MeshNode | away3d.core.partition | MeshNode is a space partitioning leaf node that contains a Mesh object.
MethodDependencyCounter | away3d.materials.compilation |
MethodVO | away3d.materials.methods |
MethodVOSet | away3d.materials.methods |
MipmapGenerator | away3d.materials.utils | MipmapGenerator is a helper class that uploads BitmapData to a Texture including mipmap levels.
Mirror | away3d.tools.commands |
MotionBlurFilter3D | away3d.filters |
Mouse3DManager | away3d.core.managers | Mouse3DManager enforces a singleton pattern and is not intended to be instanced.
MouseEvent3D | away3d.events | A MouseEvent3D is dispatched when a mouse event occurs over a mouseEnabled object in View3D.
MultiPassMaterialBase | away3d.materials | DefaultMaterialBase forms an abstract base class for the default materials provided by Away3D and use methods to define their appearance.
MultipleMaterials | away3d.materials.utils |
NamedAssetBase | away3d.library.assets |
NearDirectionalShadowMapper | away3d.lights.shadowmaps |
NearShadowMapMethod | away3d.materials.methods |
NodeBase | away3d.core.partition | The NodeBase class is an abstract base class for any type of space partition tree node.
NullBounds | away3d.bounds | NullBounds represents a debug bounding "volume" that is either considered always in, or always out of the frustum.
NullNode | away3d.core.partition | NullNode is a node that performs no space partitioning, but simply stores all objects in a list of leaf nodes.
NumSuffixConflictStrategy | away3d.library.naming |
NURBSGeometry | away3d.primitives | A NURBS primitive geometry.
NURBSVertex | away3d.primitives.data | A nurbvertex that simply extends vertex with a w weight property.
Object3D | away3d.core.base | Object3D provides a base class for any 3D object that has a (local) transformation. Standard Transform: The standard order for transformation is [parent transform] (Translate+Pivot) (Rotate) (-Pivot) (Scale) [child transform] This is the order of matrix multiplications, left-to-right.
Object3DEvent | away3d.events | Passed as a parameter when a 3d object event occurs
ObjectContainer3D | away3d.containers | ObjectContainer3D is the most basic scene graph node.
OBJParser | away3d.loaders.parsers | OBJParser provides a parser for the OBJ data type.
ObliqueNearPlaneLens | away3d.cameras.lenses |
Octree | away3d.core.partition |
OctreeNode | away3d.core.partition |
OrthographicLens | away3d.cameras.lenses | The PerspectiveLens object provides a projection matrix that projects 3D geometry isometrically.
OrthographicOffCenterLens | away3d.cameras.lenses | The PerspectiveLens object provides a projection matrix that projects 3D geometry isometrically.
OutlineMethod | away3d.materials.methods |
OutlinePass | away3d.materials.passes |
ParserBase | away3d.loaders.parsers | ParserBase provides an abstract base class for objects that convert blocks of data to data structures supported by Away3D.
ParserDataFormat | away3d.loaders.parsers | An enumeration providing values to describe the data format of parsed data.
ParserEvent | away3d.events |
Parsers | away3d.loaders.parsers |
ParserUtil | away3d.loaders.parsers.utils |
ParticleAccelerationNode | away3d.animators.nodes | A particle animation node used to apply a constant acceleration vector to the motion of a particle.
ParticleAccelerationState | away3d.animators.states | ...
ParticleAnimationData | away3d.animators.data | ...
ParticleAnimationSet | away3d.animators | The animation data set used by particle-based animators, containing particle animation data.
ParticleAnimator | away3d.animators | Provides an interface for assigning paricle-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.
ParticleBezierCurveNode | away3d.animators.nodes | A particle animation node used to control the position of a particle over time along a bezier curve.
ParticleBezierCurveState | away3d.animators.states | ...
ParticleBillboardNode | away3d.animators.nodes | A particle animation node that controls the rotation of a particle to always face the camera.
ParticleBillboardState | away3d.animators.states | ...
ParticleColorNode | away3d.animators.nodes | A particle animation node used to control the color variation of a particle over time.
ParticleColorState | away3d.animators.states | ...
ParticleData | away3d.core.base.data |
ParticleFollowNode | away3d.animators.nodes | A particle animation node used to create a follow behaviour on a particle system.
ParticleFollowState | away3d.animators.states | ...
ParticleGeometry | away3d.core.base | ...
ParticleGeometryHelper | away3d.tools.helpers | ...
ParticleGeometryTransform | away3d.tools.helpers.data | ...
ParticleNodeBase | away3d.animators.nodes | Provides an abstract base class for particle animation nodes.
ParticleOrbitNode | away3d.animators.nodes | A particle animation node used to control the position of a particle over time around a circular orbit.
ParticleOrbitState | away3d.animators.states | ...
ParticleOscillatorNode | away3d.animators.nodes | A particle animation node used to control the position of a particle over time using simple harmonic motion.
ParticleOscillatorState | away3d.animators.states | ...
ParticlePositionNode | away3d.animators.nodes | A particle animation node used to set the starting position of a particle.
ParticlePositionState | away3d.animators.states | ...
ParticleProperties | away3d.animators.data | Dynamic class for holding the local properties of a particle, used for processing the static properties of particles in the particle animation set before beginning upload to the GPU.
ParticlePropertiesMode | away3d.animators.data | Options for setting the properties mode of a particle animation node.
ParticleRotateToHeadingNode | away3d.animators.nodes | A particle animation node used to control the rotation of a particle to match its heading vector.
ParticleRotateToHeadingState | away3d.animators.states | ...
ParticleRotationalVelocityNode | away3d.animators.nodes | A particle animation node used to set the starting rotational velocity of a particle.
ParticleRotationalVelocityState | away3d.animators.states | ...
ParticleScaleNode | away3d.animators.nodes | A particle animation node used to control the scale variation of a particle over time.
ParticleScaleState | away3d.animators.states | ...
ParticleSpriteSheetNode | away3d.animators.nodes | A particle animation node used when a spritesheet texture is required to animate the particle.
ParticleSpriteSheetState | away3d.animators.states | ...
ParticleStateBase | away3d.animators.states | ...
ParticleTimeNode | away3d.animators.nodes | A particle animation node used as the base node for timekeeping inside a particle.
ParticleTimeState | away3d.animators.states | ...
ParticleUVNode | away3d.animators.nodes | A particle animation node used to control the UV offset and scale of a particle over time.
ParticleUVState | away3d.animators.states | ...
ParticleVelocityNode | away3d.animators.nodes | A particle animation node used to set the starting velocity of a particle.
ParticleVelocityState | away3d.animators.states | ...
Partition3D | away3d.core.partition | Partition3D is the core of a space partition system.
PartitionTraverser | away3d.core.traverse | IPartitionTraverser is a hierarchical visitor pattern that traverses through a Partition3D data structure.
PathAnimator | away3d.animators |
PathDuplicator | away3d.extrusions |
PathEvent | away3d.events |
PathExtrude | away3d.extrusions |
PBPickingCollider | away3d.core.pick | PixelBender-based picking collider for entity objects.
PerspectiveLens | away3d.cameras.lenses | The PerspectiveLens object provides a projection matrix that projects 3D geometry with perspective distortion.
PickingColliderBase | away3d.core.pick | An abstract base class for all picking collider classes.
PickingColliderType | away3d.core.pick | Options for setting a picking collider for entity objects.
PickingCollisionVO | away3d.core.pick | Value object for a picking collision returned by a picking collider.
PickingType | away3d.core.pick | Options for the different 3D object picking approaches available in Away3D.
PlanarReflectionMethod | away3d.materials.methods | PlanarReflectionMethod is a material method that adds reflections from a PlanarReflectionTexture object.
PlanarReflectionTexture | away3d.textures | PlanarReflectionTexture is a Texture that can be used for material-based planar reflections, as provided by PlanarReflectionMethod, FresnelPlanarReflectionMethod.
Plane3D | away3d.core.math |
PlaneClassification | away3d.core.math |
PlaneGeometry | away3d.primitives | A Plane primitive mesh.
PointLight | away3d.lights | PointLight represents an omni-directional light.
PointLightNode | away3d.core.partition | LightNode is a space partitioning leaf node that contains a LightBase object.
PositionRenderer | away3d.core.render | The PositionRenderer renders normalized position coordinates.
PrimitiveBase | away3d.primitives | PrimitiveBase is an abstract base class for mesh primitives, which are prebuilt simple meshes.
ProjectiveTextureMethod | away3d.materials.methods | ProjectiveTextureMethod is a material method used to project a texture unto the surface of an object.
Projector | away3d.tools.utils |
QuadraticPath | away3d.paths | Holds information about a single Path definition.
QuadraticPathSegment | away3d.paths | Creates a curved line segment definition required for the Path class.
QuadTree | away3d.core.partition |
QuadTreeNode | away3d.core.partition |
Quaternion | away3d.core.math | A Quaternion object which can be used to represent rotations.
RadialBlurFilter3D | away3d.filters |
Ray | away3d.tools.utils |
RaycastPicker | away3d.core.pick | Picks a 3d object from a view or scene by 3D raycast calculations.
RefractionEnvMapMethod | away3d.materials.methods |
RegularPolygonGeometry | away3d.primitives | A UV RegularPolygon primitive mesh.
RenderableListItem | away3d.core.data |
RenderableListItemPool | away3d.core.data |
RenderableMergeSort | away3d.core.sort | RenderableSorter sorts the potentially visible IRenderable objects collected by EntityCollector for optimal rendering performance.
RenderableNode | away3d.core.partition | RenderableNode is a space partitioning leaf node that contains any Entity that is itself a IRenderable object.
RenderCubeTexture | away3d.textures |
RendererBase | away3d.core.render | RendererBase forms an abstract base class for classes that are used in the rendering pipeline to render geometry to the back buffer or a texture.
RenderTexture | away3d.textures |
ResourceDependency | away3d.loaders.misc | ResourceDependency represents the data required to load, parse and resolve additional files ("dependencies") required by a parser, used by ResourceLoadSession.
RimLightMethod | away3d.materials.methods |
RTTBufferManager | away3d.core.managers |
Scene3D | away3d.containers | The Scene3D class represents an independent 3D scene in which 3D objects can be created and manipulated.
Scene3DEvent | away3d.events |
SceneIterator | away3d.core.traverse |
Segment | away3d.primitives.data |
SegmentedPathBase | away3d.paths |
SegmentMaterial | away3d.materials | SegmentMaterial is a material exclusively used to render wireframe object
SegmentPass | away3d.materials.passes |
SegmentSet | away3d.entities |
Serialize | away3d.tools.serialize |
SerializerBase | away3d.tools.serialize | SerializerBase is the abstract class for all Serializers.
ShaderCompiler | away3d.materials.compilation |
ShaderMethodSetup | away3d.materials.methods |
ShaderPicker | away3d.core.pick | Picks a 3d object from a view or scene by performing a separate render pass on the scene around the area being picked using key color values, then reading back the color value of the pixel in the render representing the picking ray.
ShaderRegisterCache | away3d.materials.compilation | ShaderRegister Cache provides the usage management system for all registers during shading compilation.
ShaderRegisterData | away3d.materials.compilation |
ShaderRegisterElement | away3d.materials.compilation | A single register element (an entire register or a single register's component) used by the RegisterPool.
ShadingMethodBase | away3d.materials.methods | ShadingMethodBase provides an abstract base method for shading methods, used by DefaultScreenPass to compile the final shading program.
ShadingMethodEvent | away3d.events |
ShadowCasterCollector | away3d.core.traverse | The EntityCollector class is a traverser for scene partitions that collects all scene graph entities that are considered potientially visible.
ShadowCasterPass | away3d.materials.passes | DefaultScreenPass is a shader pass that uses shader methods to compile a complete program.
ShadowMapMethodBase | away3d.materials.methods |
ShadowMapperBase | away3d.lights.shadowmaps |
SimplePanVolumeDriver | away3d.audio.drivers | The Simple pan/volume Sound3D driver will alter the pan and volume properties on the sound transform object of a regular flash.media.Sound3D representation of the sound.
SimpleShadowMapMethodBase | away3d.materials.methods |
SimpleVideoPlayer | away3d.materials.utils |
SimpleWaterNormalMethod | away3d.materials.methods |
SingleFileLoader | away3d.loaders.misc | The SingleFileLoader is used to load a single file, as part of a resource.
SingleObjectDepthPass | away3d.materials.passes | The SingleObjectDepthPass provides a material pass that renders a single object to a depth map from the point of view from a light.
SinglePassMaterialBase | away3d.materials | DefaultMaterialBase forms an abstract base class for the default materials provided by Away3D and use methods to define their appearance.
Skeleton | away3d.animators.data | A Skeleton object is a hierarchical grouping of joint objects that can be used for skeletal animation.
SkeletonAnimationSet | away3d.animators | The animation data set used by skeleton-based animators, containing skeleton animation data.
SkeletonAnimator | away3d.animators | Provides an interface for assigning skeleton-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.
SkeletonBinaryLERPNode | away3d.animators.nodes | A skeleton animation node that uses two animation node inputs to blend a lineraly interpolated output of a skeleton pose.
SkeletonBinaryLERPState | away3d.animators.states |
SkeletonClipNode | away3d.animators.nodes | A skeleton animation node containing time-based animation data as individual skeleton poses.
SkeletonClipState | away3d.animators.states |
SkeletonDifferenceNode | away3d.animators.nodes | A skeleton animation node that uses a difference input pose with a base input pose to blend a linearly interpolated output of a skeleton pose.
SkeletonDifferenceState | away3d.animators.states |
SkeletonDirectionalNode | away3d.animators.nodes | A skeleton animation node that uses four directional input poses with an input direction to blend a linearly interpolated output of a skeleton pose.
SkeletonDirectionalState | away3d.animators.states |
SkeletonJoint | away3d.animators.data | A value obect representing a single joint in a skeleton object.
SkeletonNaryLERPNode | away3d.animators.nodes | A skeleton animation node that uses an n-dimensional array of animation node inputs to blend a lineraly interpolated output of a skeleton pose.
SkeletonNaryLERPState | away3d.animators.states |
SkeletonPose | away3d.animators.data | A collection of pose objects, determining the pose for an entire skeleton.
SkeletonUtils | away3d.animators.utils |
SkinExtrude | away3d.extrusions |
SkinnedSubGeometry | away3d.core.base | SkinnedSubGeometry provides a SubGeometry extension that contains data needed to skin vertices.
SkyBox | away3d.primitives | A SkyBox class is used to render a sky in the scene.
SkyBoxMaterial | away3d.materials | SkyBoxMaterial is a material exclusively used to render skyboxes
SkyBoxNode | away3d.core.partition | SkyBoxNode is a space partitioning leaf node that contains a SkyBox object.
SkyBoxPass | away3d.materials.passes | SkyBoxPass provides a material pass exclusively used to render sky boxes from a cube texture.
SoftShadowMapMethod | away3d.materials.methods |
Sound3D | away3d.audio | A sound source/emitter object that can be positioned in 3D space, and from which all audio playback will be transformed to simulate orientation. The Sound3D object works much in the same fashion as primitives, lights and cameras, in that it can be added to a scene and positioned therein.
SoundTransform3D | away3d.audio | SoundTransform3D is a convinience class that helps adjust a Soundtransform's volume and pan according position and distance of a listener and emitter object.
SpecularBitmapTexture | away3d.textures | A convenience texture that encodes a specular map in the red channel, and the gloss map in the green channel, as expected by BasicSpecularMapMethod
SpecularShadingModel | away3d.materials.methods |
SphereGeometry | away3d.primitives | A UV Sphere primitive mesh.
SplatBlendBitmapTexture | away3d.textures |
SpringController | away3d.controllers | Uses spring physics to animate the target object towards a position that is defined as the lookAtTarget object's position plus the vector defined by the positionOffset property.
Sprite3D | away3d.entities | Sprite3D is a 3D billboard, a renderable rectangular area that is always aligned with the projection plane.
Stage3DEvent | away3d.events |
Stage3DManager | away3d.core.managers | The Stage3DManager class provides a multiton object that handles management for Stage3D objects.
Stage3DProxy | away3d.core.managers | Stage3DProxy provides a proxy class to manage a single Stage3D instance as well as handling the creation and attachment of the Context3D (and in turn the back buffer) is uses.
StaticLightPicker | away3d.materials.lightpickers |
StereoCamera3D | away3d.stereo |
StereoRenderer | away3d.stereo |
StereoRenderMethodBase | away3d.stereo.methods |
StereoView3D | away3d.stereo |
SubGeometry | away3d.core.base | The SubGeometry class is a collections of geometric data that describes a triangle mesh.
SubGeometryBase | away3d.core.base |
SubMesh | away3d.core.base | SubMesh wraps a SubGeometry as a scene graph instantiation.
SubsurfaceScatteringDiffuseMethod | away3d.materials.methods | SubsurfaceScatteringDiffuseMethod provides a depth map-based diffuse shading method that mimics the scattering of light inside translucent surfaces.
SuperShaderCompiler | away3d.materials.compilation |
SuperShaderPass | away3d.materials.passes | DefaultScreenPass is a shader pass that uses shader methods to compile a complete program.
TerrainDiffuseMethod | away3d.materials.methods |
Texture2DBase | away3d.textures |
TextureMaterial | away3d.materials | TextureMaterial is a material that uses a texture as the surface's diffuse colour.
TextureMultiPassMaterial | away3d.materials |
TextureProjector | away3d.entities | TextureProjector is an object in the scene that can be used to project textures onto geometry.
TextureProxyBase | away3d.textures |
TextureUtils | away3d.tools.utils |
TorusGeometry | away3d.primitives | A UV Cylinder primitive mesh.
TraceSerializer | away3d.tools.serialize | TraceSerializer is a concrete Serializer that will output its results to trace().
Trident | away3d.debug | Creates a new Trident object.
TridentLines | away3d.debug.data |
TripleFilteredShadowMapMethod | away3d.materials.methods |
UV | away3d.core.base.data | Texture coordinates value object.
UVAnimationFrame | away3d.animators.data | A value object for a single frame of animation in a UVClipNode object.
UVAnimationSet | away3d.animators | The animation data set used by uv-based animators, containing uv animation state data.
UVAnimator | away3d.animators | Provides an interface for assigning uv-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.
UVClipNode | away3d.animators.nodes | A uv animation node containing time-based animation data as individual uv animation frames.
UVClipState | away3d.animators.states |
VBlurFilter3D | away3d.filters |
VDepthOfFieldFilter3D | away3d.filters |
Vector3DUtils | away3d.core.math | Vector3DUtils provides additional Vector3D math functions.
Vertex | away3d.core.base.data | Vertex value object.
VertexAnimationMode | away3d.animators.data | Options for setting the animation mode of a vertex animator object.
VertexAnimationSet | away3d.animators | The animation data set used by vertex-based animators, containing vertex animation state data.
VertexAnimator | away3d.animators | Provides an interface for assigning vertex-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.
VertexClipNode | away3d.animators.nodes | A vertex animation node containing time-based animation data as individual geometry obejcts.
VertexClipState | away3d.animators.states |
VideoTexture | away3d.textures |
View3D | away3d.containers |
ViewVolume | away3d.core.partition |
ViewVolumePartition | away3d.core.partition |
ViewVolumeRootNode | away3d.core.partition |
WebcamTexture | away3d.textures |
Weld | away3d.tools.commands | Class Weld removes the vertices that can be shared from one or more meshes (smoothes the mesh surface when lighted).
WireframeAxesGrid | away3d.debug | Class WireframeAxesGrid generates a grid of lines on a given planeWireframeAxesGrid
WireframeCube | away3d.primitives | A WirefameCube primitive mesh.
WireframeCylinder | away3d.primitives | Generates a wireframd cylinder primitive.
WireframeMapGenerator | away3d.materials.utils | WireframeMapGenerator is a utility class to generate a wireframe texture for uniquely mapped meshes.
WireframePlane | away3d.primitives | A WireframePlane primitive mesh.
WireframePrimitiveBase | away3d.primitives |
WireframeSphere | away3d.primitives | A WireframeSphere primitive mesh
WrapDiffuseMethod | away3d.materials.methods | WrapDiffuseMethod is an alternative to BasicDiffuseMethod in which the light is allowed to be "wrapped around" the normally dark area, to some extent.

Thu Nov 15 2012, 12:09 PM Z


All Classes - Away3D Documentation

All Classes

AbstractMethodError
AbstractSound3DDriver
AC3DParser
AGALMiniAssembler
AGALProgram3DCache
Align
AlphaMaskMethod
AnaglyphStereoRenderMethod
AnimationClipNodeBase
AnimationClipState
AnimationNodeBase
AnimationRegisterCache
AnimationSetBase
AnimationSetError
AnimationStateBase
AnimationStateEvent
AnimationSubGeometry
AnimatorBase
AnimatorEvent
AnisotropicSpecularMethod
AS3PickingCollider
AssetEvent
AssetLibrary
AssetLibraryBundle
AssetLibraryIterator
AssetLoader
AssetLoaderContext
AssetLoaderToken
AssetType
ATFCubeTexture
ATFData
ATFTexture
AutoPickingCollider
Away3D
AwayStats
AWD1Parser
AWD2Parser
AWDParser
AxisAlignedBoundingBox
BackgroundImageRenderer
BasicAmbientMethod
BasicDiffuseMethod
BasicNormalMethod
BasicSpecularMethod
BitmapCubeTexture
BitmapDataAsset
BitmapTexture
BitmapTextureCache
BloomFilter3D
BlurFilter3D
BoundingSphere
BoundingVolumeBase
Bounds
Camera3D
CameraNode
CapsuleGeometry
CascadeShadowMapMethod
CascadeShadowMapper
Cast
CastError
CelDiffuseMethod
CelSpecularMethod
ColorHitMap
ColorMaterial
ColorMatrixMethod
ColorMultiPassMaterial
ColorTransformMethod
CompactSubGeometry
CompiledPass
CompositeDiffuseMethod
CompositeSpecularMethod
ConeGeometry
ConflictPrecedence
ConflictStrategy
ConflictStrategyBase
ControllerBase
CrossfadeTransition
CrossfadeTransitionNode
CrossfadeTransitionState
CubeGeometry
CubeMapShadowMapper
CubeReflectionTexture
CubeTextureBase
CubicPath
CubicPathSegment
CylinderGeometry
DAEParser
Debug
DefaultMaterialManager
DefaultRenderer
DelaunayMesh
DeprecationError
DepthDiffuseMethod
DepthMapPass
DepthOfFieldFilter3D
DepthRenderer
DirectionalLight
DirectionalLightNode
DirectionalShadowMapper
DistanceMapPass
DitheredShadowMapMethod
Drag3D
DXFParser
DynamicGrid
EffectMethodBase
Elevation
Entity
EntityCollector
EntityListItem
EntityListItemPool
EntityNode
EnvMapAmbientMethod
EnvMapMethod
ErrorConflictStrategy
Explode
Face
FaceHelper
Filter3DBase
Filter3DBrightPassTask
Filter3DCompositeTask
Filter3DDoubleBufferCopyTask
Filter3DHBlurTask
Filter3DHDepthOfFFieldTask
Filter3DHueSaturationTask
Filter3DRadialBlurTask
Filter3DRenderer
Filter3DTaskBase
Filter3DVBlurTask
Filter3DVDepthOfFFieldTask
Filter3DXFadeCompositeTask
FilteredShadowMapMethod
FirstPersonController
FogMethod
FollowController
FreeMatrixLens
FresnelEnvMapMethod
FresnelPlanarReflectionMethod
FresnelSpecularMethod
Geometry
GeometryEvent
GeometryUtil
GeomUtil
Grid
HardShadowMapMethod
HBlurFilter3D
HDepthOfFieldFilter3D
HeightMapNormalMethod
HoverController
HueSaturationFilter3D
IAnimationSet
IAnimationState
IAnimationTransition
IAnimator
IAsset
IEntitySorter
IgnoreConflictStrategy
ImageParser
IMaterialOwner
InterleavedStereoRenderMethod
InvalidTextureError
InvertedOctreeNode
IPath
IPathSegment
IPicker
IPickingCollider
IRenderable
ISkeletonAnimationState
ISound3DDriver
ISubGeometry
IUVAnimationState
IVertexAnimationState
IVideoPlayer
JointPose
LatheExtrude
LensBase
LensEvent
LightBase
LightEvent
LightingMethodBase
LightingPass
LightingShaderCompiler
LightMapDiffuseMethod
LightMapMethod
LightNode
LightPickerBase
LightProbe
LightProbeNode
LightsHelper
LightSources
LinearExtrude
LineSegment
Loader3D
LoaderEvent
LookAtController
MaterialBase
MaterialPassBase
MathConsts
Matrix3DUtils
Max3DSParser
MD2Parser
MD5AnimParser
MD5MeshParser
Merge
Mesh
MeshDebug
MeshDebugger
MeshHelper
MeshNode
MethodDependencyCounter
MethodVO
MethodVOSet
MipmapGenerator
Mirror
MotionBlurFilter3D
Mouse3DManager
MouseEvent3D
MultiPassMaterialBase
MultipleMaterials
NamedAssetBase
NearDirectionalShadowMapper
NearShadowMapMethod
NodeBase
NullBounds
NullNode
NumSuffixConflictStrategy
NURBSGeometry
NURBSVertex
Object3D
Object3DEvent
ObjectContainer3D
OBJParser
ObliqueNearPlaneLens
Octree
OctreeNode
OrthographicLens
OrthographicOffCenterLens
OutlineMethod
OutlinePass
ParserBase
ParserDataFormat
ParserEvent
Parsers
ParserUtil
ParticleAccelerationNode
ParticleAccelerationState
ParticleAnimationData
ParticleAnimationSet
ParticleAnimator
ParticleBezierCurveNode
ParticleBezierCurveState
ParticleBillboardNode
ParticleBillboardState
ParticleColorNode
ParticleColorState
ParticleData
ParticleFollowNode
ParticleFollowState
ParticleGeometry
ParticleGeometryHelper
ParticleGeometryTransform
ParticleNodeBase
ParticleOrbitNode
ParticleOrbitState
ParticleOscillatorNode
ParticleOscillatorState
ParticlePositionNode
ParticlePositionState
ParticleProperties
ParticlePropertiesMode
ParticleRotateToHeadingNode
ParticleRotateToHeadingState
ParticleRotationalVelocityNode
ParticleRotationalVelocityState
ParticleScaleNode
ParticleScaleState
ParticleSpriteSheetNode
ParticleSpriteSheetState
ParticleStateBase
ParticleTimeNode
ParticleTimeState
ParticleUVNode
ParticleUVState
ParticleVelocityNode
ParticleVelocityState
Partition3D
PartitionTraverser
PathAnimator
PathDuplicator
PathEvent
PathExtrude
PBPickingCollider
PerspectiveLens
PickingColliderBase
PickingColliderType
PickingCollisionVO
PickingType
PlanarReflectionMethod
PlanarReflectionTexture
Plane3D
PlaneClassification
PlaneGeometry
PointLight
PointLightNode
PositionRenderer
PrimitiveBase
ProjectiveTextureMethod
Projector
QuadraticPath
QuadraticPathSegment
QuadTree
QuadTreeNode
Quaternion
RadialBlurFilter3D
Ray
RaycastPicker
RefractionEnvMapMethod
RegularPolygonGeometry
RenderableListItem
RenderableListItemPool
RenderableMergeSort
RenderableNode
RenderCubeTexture
RendererBase
RenderTexture
ResourceDependency
RimLightMethod
RTTBufferManager
Scene3D
Scene3DEvent
SceneIterator
Segment
SegmentedPathBase
SegmentMaterial
SegmentPass
SegmentSet
Serialize
SerializerBase
ShaderCompiler
ShaderMethodSetup
ShaderPicker
ShaderRegisterCache
ShaderRegisterData
ShaderRegisterElement
ShadingMethodBase
ShadingMethodEvent
ShadowCasterCollector
ShadowCasterPass
ShadowMapMethodBase
ShadowMapperBase
SimplePanVolumeDriver
SimpleShadowMapMethodBase
SimpleVideoPlayer
SimpleWaterNormalMethod
SingleFileLoader
SingleObjectDepthPass
SinglePassMaterialBase
Skeleton
SkeletonAnimationSet
SkeletonAnimator
SkeletonBinaryLERPNode
SkeletonBinaryLERPState
SkeletonClipNode
SkeletonClipState
SkeletonDifferenceNode
SkeletonDifferenceState
SkeletonDirectionalNode
SkeletonDirectionalState
SkeletonJoint
SkeletonNaryLERPNode
SkeletonNaryLERPState
SkeletonPose
SkeletonUtils
SkinExtrude
SkinnedSubGeometry
SkyBox
SkyBoxMaterial
SkyBoxNode
SkyBoxPass
SoftShadowMapMethod
Sound3D
SoundTransform3D
SpecularBitmapTexture
SpecularShadingModel
SphereGeometry
SplatBlendBitmapTexture
SpringController
Sprite3D
Stage3DEvent
Stage3DManager
Stage3DProxy
StaticLightPicker
StereoCamera3D
StereoRenderer
StereoRenderMethodBase
StereoView3D
SubGeometry
SubGeometryBase
SubMesh
SubsurfaceScatteringDiffuseMethod
SuperShaderCompiler
SuperShaderPass
TerrainDiffuseMethod
Texture2DBase
TextureMaterial
TextureMultiPassMaterial
TextureProjector
TextureProxyBase
TextureUtils
TorusGeometry
TraceSerializer
Trident
TridentLines
TripleFilteredShadowMapMethod
UV
UVAnimationFrame
UVAnimationSet
UVAnimator
UVClipNode
UVClipState
VBlurFilter3D
VDepthOfFieldFilter3D
Vector3DUtils
Vertex
VertexAnimationMode
VertexAnimationSet
VertexAnimator
VertexClipNode
VertexClipState
VideoTexture
View3D
ViewVolume
ViewVolumePartition
ViewVolumeRootNode
WebcamTexture
Weld
WireframeAxesGrid
WireframeCube
WireframeCylinder
WireframeMapGenerator
WireframePlane
WireframePrimitiveBase
WireframeSphere
WrapDiffuseMethod


All Packages

Away3D Documentation | All Classes | Index | Frames No Frames | Adobe Logo
All Packages |

package | Description
away3d |
away3d.animators |
away3d.animators.data |
away3d.animators.nodes |
away3d.animators.states |
away3d.animators.transitions |
away3d.animators.utils |
away3d.audio |
away3d.audio.drivers |
away3d.bounds |
away3d.cameras |
away3d.cameras.lenses |
away3d.containers |
away3d.controllers |
away3d.core.base |
away3d.core.base.data |
away3d.core.data |
away3d.core.managers |
away3d.core.math |
away3d.core.partition |
away3d.core.pick |
away3d.core.render |
away3d.core.sort |
away3d.core.traverse |
away3d.debug |
away3d.debug.data |
away3d.entities |
away3d.errors |
away3d.events |
away3d.extrusions |
away3d.filters |
away3d.filters.tasks |
away3d.library |
away3d.library.assets |
away3d.library.naming |
away3d.library.utils |
away3d.lights |
away3d.lights.shadowmaps |
away3d.loaders |
away3d.loaders.misc |
away3d.loaders.parsers |
away3d.loaders.parsers.utils |
away3d.materials |
away3d.materials.compilation |
away3d.materials.lightpickers |
away3d.materials.methods |
away3d.materials.passes |
away3d.materials.utils |
away3d.paths |
away3d.primitives |
away3d.primitives.data |
away3d.stereo |
away3d.stereo.methods |
away3d.textures |
away3d.tools.commands |
away3d.tools.helpers |
away3d.tools.helpers.data |
away3d.tools.serialize |
away3d.tools.utils |
away3d.utils |
com.adobe.utils |

Thu Nov 15 2012, 12:09 PM Z


Away3D Documentation

Index

A | N
B | O
C | P
D | Q
E | R
F | S
G | T
H | U
I | V
J | W
K | X
L | Y
M | Z


Away3D Documentation

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link to Non-frame version.


Away3D Documentation

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Away3D Documentation

Away3D Documentation All Packages | All Classes | Index | No Frames
Adobe Logo
Properties | Properties | Constructor | Methods | Functions | Events | Styles | Skin Parts | Skin States | Effects | Constants | Constants | Interfaces | Classes | Use | Examples


B

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
B Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
b — Property, class away3d.core.math.Plane3D
 | The B coefficient of this plane.
b — Property, class away3d.filters.HueSaturationFilter3D
b — Property, class away3d.filters.tasks.Filter3DHueSaturationTask
back — Property, class away3d.materials.utils.MultipleMaterials
 | Defines the material applied to the back side of the cube.
BACK — Constant Static Property, class away3d.core.math.PlaneClassification
BACK — Constant Static Property, class away3d.tools.utils.Projector
_backBufferInvalid — Property, class away3d.containers.View3D
background — Property, class away3d.containers.View3D
background — Property, class away3d.core.render.RendererBase
backgroundAlpha — Property, class away3d.containers.View3D
_backgroundAlpha — Property, class away3d.core.render.RendererBase
backgroundAlpha — Property, class away3d.core.render.RendererBase
backgroundB — Property, class away3d.core.render.DepthRenderer
_backgroundB — Property, class away3d.core.render.RendererBase
backgroundB — Property, class away3d.core.render.RendererBase
backgroundColor — Property, class away3d.containers.View3D
 | The background color of the screen.
backgroundG — Property, class away3d.core.render.DepthRenderer
_backgroundG — Property, class away3d.core.render.RendererBase
backgroundG — Property, class away3d.core.render.RendererBase
backgroundImageRenderer — Property, class away3d.core.render.RendererBase
BackgroundImageRenderer — class, package away3d.core.render
BackgroundImageRenderer(stage3DProxy:away3d.core.managers:Stage3DProxy) — Constructor, class away3d.core.render.BackgroundImageRenderer
backgroundR — Property, class away3d.core.render.DepthRenderer
_backgroundR — Property, class away3d.core.render.RendererBase
backgroundR — Property, class away3d.core.render.RendererBase
backVector — Property, class away3d.core.base.Object3D
backward — Property, class away3d.animators.nodes.SkeletonDirectionalNode
 | Defines the backwards configured input node to use for the blended output.
bakeTransformations() — method, class away3d.entities.Mesh
_baseDiffuseMethod — Property, class away3d.materials.methods.CompositeDiffuseMethod
baseInput — Property, class away3d.animators.nodes.SkeletonDifferenceNode
 | Defines a base input node to use for the blended output.
baseLens — Property, class away3d.cameras.lenses.ObliqueNearPlaneLens
baseMethod — Property, class away3d.materials.methods.CascadeShadowMapMethod
BasicAmbientMethod — class, package away3d.materials.methods
 | BasicAmbientMethod provides the default shading method for uniform ambient lighting.
BasicAmbientMethod() — Constructor, class away3d.materials.methods.BasicAmbientMethod
 | Creates a new BasicAmbientMethod object.
BasicDiffuseMethod — class, package away3d.materials.methods
 | BasicDiffuseMethod provides the default shading method for Lambert (dot3) diffuse lighting.
BasicDiffuseMethod() — Constructor, class away3d.materials.methods.BasicDiffuseMethod
 | Creates a new BasicDiffuseMethod object.
BasicNormalMethod — class, package away3d.materials.methods
BasicNormalMethod() — Constructor, class away3d.materials.methods.BasicNormalMethod
BasicSpecularMethod — class, package away3d.materials.methods
 | BasicSpecularMethod provides the default shading method for Blinn-Phong specular highlights.
BasicSpecularMethod() — Constructor, class away3d.materials.methods.BasicSpecularMethod
 | Creates a new BasicSpecularMethod object.
beginObject(className:String, instanceName:String) — method, class away3d.tools.serialize.SerializerBase
 | Begin object serialization.
beginObject(className:String, instanceName:String) — method, class away3d.tools.serialize.TraceSerializer
 | Begin object serialization.
BEZIER_CONTROL_VECTOR3D — Constant Static Property, class away3d.animators.nodes.ParticleBezierCurveNode
 | Reference for bezier curve node properties on a single particle (when in local property mode).
BEZIER_END_VECTOR3D — Constant Static Property, class away3d.animators.nodes.ParticleBezierCurveNode
 | Reference for bezier curve node properties on a single particle (when in local property mode).
BINARY — Constant Static Property, class away3d.loaders.parsers.ParserDataFormat
 | Describes the format of a binary file.
bitangent — Property, class away3d.materials.compilation.ShaderRegisterData
bitangentVarying — Property, class away3d.materials.compilation.ShaderRegisterData
BitmapCubeTexture — class, package away3d.textures
BitmapCubeTexture(posX:flash.display:BitmapData, negX:flash.display:BitmapData, posY:flash.display:BitmapData, negY:flash.display:BitmapData, posZ:flash.display:BitmapData, negZ:flash.display:BitmapData) — Constructor, class away3d.textures.BitmapCubeTexture
bitmapData — Property, class away3d.library.assets.BitmapDataAsset
 | The bitmapData to be treated as a resource.
bitmapData — Property, class away3d.textures.BitmapTexture
bitmapData — Property, class away3d.tools.utils.ColorHitMap
 | The source bitmapdata uses for colour readings
bitmapData(data:any) — Static Method , class away3d.utils.Cast
BitmapDataAsset — class, package away3d.library.assets
 | BitmapDataResource is a wrapper for loaded BitmapData, allowing it to be used uniformly as a resource when loading, parsing, and listing/resolving dependencies.
BitmapDataAsset(bitmapData:flash.display:BitmapData) — Constructor, class away3d.library.assets.BitmapDataAsset
 | Creates a new BitmapDataResource object.
bitmapTexture(data:any) — Static Method , class away3d.utils.Cast
BitmapTexture — class, package away3d.textures
BitmapTexture(bitmapData:flash.display:BitmapData) — Constructor, class away3d.textures.BitmapTexture
BitmapTextureCache — class, package away3d.textures
 | DEPRECRATED along with BitmapMaterial.
BitmapTextureCache(singletonEnforcer:BitmapTextureCache.as$478:SingletonEnforcer) — Constructor, class away3d.textures.BitmapTextureCache
_blendedRenderableHead — Property, class away3d.core.traverse.EntityCollector
blendedRenderableHead — Property, class away3d.core.traverse.EntityCollector
 | The list of IRenderable objects that require blending and are considered potentially visible.
blendMode — Property, class away3d.animators.VertexAnimationSet
 | Returns the active blend mode of the vertex animator object.
blendMode — Property, class away3d.materials.MaterialBase
 | The blend mode to use when drawing this renderable.
blendMode — Property, class away3d.materials.MultiPassMaterialBase
blendMode — Property, class away3d.materials.SinglePassMaterialBase
blendMode — Property, class away3d.materials.methods.LightMapDiffuseMethod
blendMode — Property, class away3d.materials.methods.LightMapMethod
blendSpeed — Property, class away3d.animators.transitions.CrossfadeTransition
blendSpeed — Property, class away3d.animators.transitions.CrossfadeTransitionNode
_blendWeight — Property, class away3d.animators.states.AnimationClipState
blendWeight — Property, class away3d.animators.states.AnimationClipState
 | Returns a fractional value between 0 and 1 representing the blending ratio of the current playhead position between the current frame (0) and next frame (1) of the animation.
blendWeight — Property, interface away3d.animators.states.IUVAnimationState
 | Returns a fractional value between 0 and 1 representing the blending ratio of the current playhead position between the current uv frame (0) and next uv frame (1) of the animation.
blendWeight — Property, interface away3d.animators.states.IVertexAnimationState
 | Returns a fractional value between 0 and 1 representing the blending ratio of the current playhead position between the current geometry frame (0) and next geometry frame (1) of the animation.
blendWeight — Property, class away3d.animators.states.SkeletonBinaryLERPState
 | Defines a fractional value between 0 and 1 representing the blending ratio between inputA (0) and inputB (1), used to produce the skeleton pose output.
blendWeight — Property, class away3d.animators.states.SkeletonDifferenceState
 | Defines a fractional value between 0 and 1 representing the blending ratio between the base input (0) and difference input (1), used to produce the skeleton pose output.
BLINN_PHONG — Constant Static Property, class away3d.materials.methods.SpecularShadingModel
BloomFilter3D — class, package away3d.filters
BloomFilter3D(blurX:uint, blurY:uint, threshold:Number, exposure:Number, quality:int) — Constructor, class away3d.filters.BloomFilter3D
BlurFilter3D — class, package away3d.filters
BlurFilter3D(blurX:uint, blurY:uint, stepSize:int) — Constructor, class away3d.filters.BlurFilter3D
 | Creates a new BlurFilter3D object
blurStart — Property, class away3d.filters.RadialBlurFilter3D
blurStart — Property, class away3d.filters.tasks.Filter3DRadialBlurTask
blurWidth — Property, class away3d.filters.RadialBlurFilter3D
blurWidth — Property, class away3d.filters.tasks.Filter3DRadialBlurTask
blurX — Property, class away3d.filters.BloomFilter3D
blurX — Property, class away3d.filters.BlurFilter3D
blurY — Property, class away3d.filters.BloomFilter3D
blurY — Property, class away3d.filters.BlurFilter3D
bothSides — Property, class away3d.materials.MaterialBase
 | Defines whether or not the material should perform backface culling.
bothSides — Property, class away3d.materials.passes.MaterialPassBase
 | Defines whether or not the material should perform backface culling.
bottom — Property, class away3d.materials.utils.MultipleMaterials
 | Defines the material applied to the bottom side of the cube.
BOTTOM — Constant Static Property, class away3d.tools.utils.Projector
_bottomClosed — Property, class away3d.primitives.CylinderGeometry
bottomClosed — Property, class away3d.primitives.CylinderGeometry
 | Defines whether the bottom end of the cylinder is closed (true) or open.
_bottomRadius — Property, class away3d.primitives.CylinderGeometry
bottomRadius — Property, class away3d.primitives.CylinderGeometry
 | The radius of the bottom end of the cylinder.
bottomRadius — Property, class away3d.primitives.WireframeCylinder
 | Bottom radius of the cylinder
boundingRadius(mesh:away3d.entities:Mesh) — Static Method , class away3d.tools.helpers.MeshHelper
 | Returns the boundingRadius of an Entity of a Mesh.
boundingRadiusContainer(container:away3d.containers:ObjectContainer3D) — Static Method , class away3d.tools.helpers.MeshHelper
 | Returns the boundingRadius of a ObjectContainer3D
_boundingRenderable — Property, class away3d.bounds.BoundingVolumeBase
boundingRenderable — Property, class away3d.bounds.BoundingVolumeBase
 | Returns the bounding renderable object for the bounding volume, in cases where the showBounds property of the entity is set to true.
BoundingSphere — class, package away3d.bounds
 | BoundingSphere represents a spherical bounding volume defined by a center point and a radius.
BoundingSphere() — Constructor, class away3d.bounds.BoundingSphere
 | Creates a new BoundingSphere object
BoundingVolumeBase — class, package away3d.bounds
 | An abstract base class for all bounding volume classes.
BoundingVolumeBase() — Constructor, class away3d.bounds.BoundingVolumeBase
 | Creates a new BoundingVolumeBase object
bounds — Property, class away3d.core.base.SubMesh
_bounds — Property, class away3d.entities.Entity
bounds — Property, class away3d.entities.Entity
 | The bounding volume approximating the volume occupied by the Entity.
bounds — Property, class away3d.extrusions.DelaunayMesh
 | The bounding volume approximating the volume occupied by the Entity.
bounds — Property, class away3d.extrusions.LatheExtrude
 | The bounding volume approximating the volume occupied by the Entity.
bounds — Property, class away3d.extrusions.LinearExtrude
 | The bounding volume approximating the volume occupied by the Entity.
bounds — Property, class away3d.extrusions.PathExtrude
 | The bounding volume approximating the volume occupied by the Entity.
bounds — Property, class away3d.extrusions.SkinExtrude
 | The bounding volume approximating the volume occupied by the Entity.
bounds — Property, class away3d.primitives.WireframePrimitiveBase
Bounds — class, package away3d.tools.utils
 | Helper Class to retrieve objects bounds Bounds
_boundsInvalid — Property, class away3d.entities.Entity
BOUNDS_INVALID — Constant Static Property, class away3d.events.GeometryEvent
BOUNDS_ONLY — Constant Static Property, class away3d.core.pick.PickingColliderType
 | Default null collider that forces picker to only use entity bounds for hit calculations on an Entity
bubbles — Property, class away3d.events.MouseEvent3D
_bufferContext — Property, class away3d.animators.data.AnimationSubGeometry
_bufferContext — Property, class away3d.core.base.CompactSubGeometry
_bufferDirty — Property, class away3d.animators.data.AnimationSubGeometry
build() — method, class away3d.extrusions.PathDuplicator
 | Triggers the generation
build(vertices:Vector$Number, indices:Vector$uint, uvs:Vector$Number, name:String, material:away3d.materials:MaterialBase, shareVertices:Boolean, useDefaultMap:Boolean) — Static Method , class away3d.tools.helpers.MeshHelper
 | Build a Mesh from Vectors
buildGeometry(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.CapsuleGeometry
 | Builds the primitive's geometry when invalid.
buildGeometry(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.CubeGeometry
 | Builds the primitive's geometry when invalid.
buildGeometry(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.CylinderGeometry
 | Builds the primitive's geometry when invalid.
buildGeometry(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.NURBSGeometry
 | Rebuild the mesh as there is significant change to the structural parameters
buildGeometry(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.PlaneGeometry
 | Builds the primitive's geometry when invalid.
buildGeometry(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.PrimitiveBase
 | Builds the primitive's geometry when invalid.
buildGeometry(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.SphereGeometry
 | Builds the primitive's geometry when invalid.
buildGeometry(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.TorusGeometry
 | Builds the primitive's geometry when invalid.
buildGeometry() — method, class away3d.primitives.WireframeCube
buildGeometry() — method, class away3d.primitives.WireframeCylinder
buildGeometry() — method, class away3d.primitives.WireframePlane
buildGeometry() — method, class away3d.primitives.WireframePrimitiveBase
buildGeometry() — method, class away3d.primitives.WireframeSphere
buildUVs(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.CapsuleGeometry
 | Builds the primitive's uv coordinates when invalid.
buildUVs(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.CubeGeometry
 | Builds the primitive's uv coordinates when invalid.
buildUVs(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.CylinderGeometry
 | Builds the primitive's uv coordinates when invalid.
buildUVs(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.NURBSGeometry
 | Rebuild the UV coordinates as there is significant change to the structural parameters
buildUVs(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.PlaneGeometry
 | Builds the primitive's uv coordinates when invalid.
buildUVs(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.PrimitiveBase
 | Builds the primitive's uv coordinates when invalid.
buildUVs(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.SphereGeometry
 | Builds the primitive's uv coordinates when invalid.
buildUVs(target:away3d.core.base:CompactSubGeometry) — method, class away3d.primitives.TorusGeometry
 | Builds the primitive's uv coordinates when invalid.
byteArray(data:any) — Static Method , class away3d.utils.Cast
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


C

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
C Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
c — Property, class away3d.core.math.Plane3D
 | The C coefficient of this plane.
calculateDependencies() — method, class away3d.materials.compilation.LightingShaderCompiler
 | Calculates register dependencies for commonly used data.
calculateDependencies() — method, class away3d.materials.compilation.ShaderCompiler
calculateDependencies() — method, class away3d.materials.compilation.SuperShaderCompiler
 | Calculates register dependencies for commonly used data.
_camera — Property, class away3d.containers.View3D
camera — Property, class away3d.containers.View3D
 | The camera that's used to render the scene for this viewport
_camera — Property, class away3d.core.traverse.EntityCollector
camera — Property, class away3d.core.traverse.EntityCollector
 | The camera that provides the visible frustum.
camera — Property, class away3d.stereo.StereoView3D
camera — Property, class away3d.textures.WebcamTexture
 | The Camera instance (webcam) used by this texture.
Camera3D — class, package away3d.cameras
 | A Camera3D object represents a virtual camera through which we view the scene.
Camera3D(lens:away3d.cameras.lenses:LensBase) — Constructor, class away3d.cameras.Camera3D
 | Creates a new Camera3D object
CameraNode — class, package away3d.core.partition
 | CameraNode is a space partitioning leaf node that contains a Camera3D object.
CameraNode(camera:away3d.cameras:Camera3D) — Constructor, class away3d.core.partition.CameraNode
 | Creates a new CameraNode object.
_cameraPositionIndex — Property, class away3d.materials.compilation.ShaderCompiler
cameraPositionIndex — Property, class away3d.materials.compilation.ShaderCompiler
_cameraPositionIndex — Property, class away3d.materials.passes.CompiledPass
cancelGPUCompatibility() — method, class away3d.animators.AnimationSetBase
cancelGPUCompatibility() — method, class away3d.animators.ParticleAnimationSet
CapsuleGeometry — class, package away3d.primitives
 | A UV Capsule primitive mesh.
CapsuleGeometry(radius:Number, height:Number, segmentsW:uint, segmentsH:uint, yUp:Boolean) — Constructor, class away3d.primitives.CapsuleGeometry
 | Creates a new Capsule object.
CascadeShadowMapMethod — class, package away3d.materials.methods
CascadeShadowMapMethod(shadowMethodBase:away3d.materials.methods:SimpleShadowMapMethodBase) — Constructor, class away3d.materials.methods.CascadeShadowMapMethod
 | Creates a new CascadeShadowMapMethod object.
CascadeShadowMapper — class, package away3d.lights.shadowmaps
CascadeShadowMapper(numCascades:uint) — Constructor, class away3d.lights.shadowmaps.CascadeShadowMapper
Cast — class, package away3d.utils
 | Helper class for casting assets to usable objects
_casterCollector — Property, class away3d.lights.shadowmaps.ShadowMapperBase
_casterLightPass — Property, class away3d.materials.MultiPassMaterialBase
CastError — class, package away3d.errors
CastError(message:String) — Constructor, class away3d.errors.CastError
_castingDirectionalLights — Property, class away3d.materials.lightpickers.LightPickerBase
castingDirectionalLights — Property, class away3d.materials.lightpickers.LightPickerBase
_castingLight — Property, class away3d.materials.methods.ShadowMapMethodBase
castingLight — Property, class away3d.materials.methods.ShadowMapMethodBase
_castingPointLights — Property, class away3d.materials.lightpickers.LightPickerBase
castingPointLights — Property, class away3d.materials.lightpickers.LightPickerBase
CASTS_SHADOW_CHANGE — Constant Static Property, class away3d.events.LightEvent
castsShadows — Property, interface away3d.core.base.IRenderable
 | Indicates whether the renderable can cast shadows
castsShadows — Property, class away3d.core.base.SubMesh
castsShadows — Property, class away3d.entities.Mesh
 | Indicates whether or not the Mesh can cast shadows
castsShadows — Property, class away3d.entities.SegmentSet
castsShadows — Property, class away3d.entities.Sprite3D
castsShadows — Property, class away3d.lights.LightBase
castsShadows — Property, class away3d.primitives.SkyBox
CelDiffuseMethod — class, package away3d.materials.methods
 | CelDiffuseMethod provides a shading method to add specular cel (cartoon) shading.
CelDiffuseMethod(levels:uint, baseDiffuseMethod:away3d.materials.methods:BasicDiffuseMethod) — Constructor, class away3d.materials.methods.CelDiffuseMethod
 | Creates a new CelDiffuseMethod object.
CelSpecularMethod — class, package away3d.materials.methods
 | CelSpecularMethod provides a shading method to add diffuse cel (cartoon) shading.
CelSpecularMethod(specularCutOff:Number, baseSpecularMethod:away3d.materials.methods:BasicSpecularMethod) — Constructor, class away3d.materials.methods.CelSpecularMethod
 | Creates a new CelSpecularMethod object.
CENTER — Constant Static Property, class away3d.tools.commands.Mirror
centerMesh — Property, class away3d.extrusions.DelaunayMesh
 | Defines whether the mesh is recentered of not after generation
centerMesh — Property, class away3d.extrusions.LatheExtrude
 | Defines whether the mesh is recentered of not after generation
centerMesh — Property, class away3d.extrusions.LinearExtrude
 | Defines whether the mesh is recentered of not after generation
centerMesh — Property, class away3d.extrusions.PathExtrude
 | Defines whether the mesh is recentered of not after generation
centerMesh — Property, class away3d.extrusions.SkinExtrude
 | Defines whether the mesh is _centerMeshed of not after generation
CHANGE_SEGMENT — Constant Static Property, class away3d.events.PathEvent
 | Dispatched when the time pointer enters a new PathSegment
_childNodes — Property, class away3d.core.partition.NodeBase
_classification — Property, class away3d.materials.MaterialBase
classifyPoint(p:flash.geom:Vector3D, epsilon:Number) — method, class away3d.core.math.Plane3D
 | Classify a point against this Plane3D.
classifyToPlane(plane:away3d.core.math:Plane3D) — method, class away3d.bounds.AxisAlignedBoundingBox
classifyToPlane(plane:away3d.core.math:Plane3D) — method, class away3d.bounds.BoundingSphere
classifyToPlane(plane:away3d.core.math:Plane3D) — method, class away3d.bounds.BoundingVolumeBase
classifyToPlane(plane:away3d.core.math:Plane3D) — method, class away3d.bounds.NullBounds
cleanCompilationData() — method, class away3d.materials.methods.BasicAmbientMethod
cleanCompilationData() — method, class away3d.materials.methods.BasicDiffuseMethod
cleanCompilationData() — method, class away3d.materials.methods.BasicNormalMethod
cleanCompilationData() — method, class away3d.materials.methods.BasicSpecularMethod
cleanCompilationData() — method, class away3d.materials.methods.CascadeShadowMapMethod
cleanCompilationData() — method, class away3d.materials.methods.CelDiffuseMethod
cleanCompilationData() — method, class away3d.materials.methods.CelSpecularMethod
cleanCompilationData() — method, class away3d.materials.methods.CompositeDiffuseMethod
cleanCompilationData() — method, class away3d.materials.methods.CompositeSpecularMethod
cleanCompilationData() — method, class away3d.materials.methods.FresnelSpecularMethod
cleanCompilationData() — method, class away3d.materials.methods.NearShadowMapMethod
cleanCompilationData() — method, class away3d.materials.methods.ProjectiveTextureMethod
cleanCompilationData() — method, class away3d.materials.methods.SimpleShadowMapMethodBase
cleanCompilationData() — method, class away3d.materials.methods.SimpleWaterNormalMethod
cleanCompilationData() — method, class away3d.materials.methods.SubsurfaceScatteringDiffuseMethod
cleanCompilationData() — method, class away3d.materials.methods.WrapDiffuseMethod
cleanUp() — method, class away3d.core.traverse.EntityCollector
 | Cleans up any data at the end of a frame.
cleanUp() — method, class away3d.materials.passes.CompiledPass
clear() — method, class away3d.core.managers.Stage3DProxy
clear() — method, class away3d.core.traverse.EntityCollector
 | Clears all objects in the entity collector.
clear() — Static Method , class away3d.debug.Debug
clearAll() — method, class away3d.tools.helpers.data.MeshDebug
clearData(destroyCachedMeshes:Boolean) — method, class away3d.extrusions.PathDuplicator
clearDedicatedMesh(mesh:away3d.entities:Mesh) — method, class away3d.materials.passes.OutlinePass
 | Clears mesh.
clearOnRender — Property, class away3d.core.render.RendererBase
clearPasses() — method, class away3d.materials.MaterialBase
 | Clears all passes in the material.
CLICK — Constant Static Property, class away3d.events.MouseEvent3D
 | Defines the value of the type property of a click3d event object.
clone() — method, class away3d.animators.data.SkeletonPose
 | Creates a copy of the SkeletonPose object, with a dulpicate of its component joint poses.
clone() — method, class away3d.bounds.AxisAlignedBoundingBox
 | Clones the current BoundingVolume object
clone() — method, class away3d.bounds.BoundingSphere
 | Clones the current BoundingVolume object
clone() — method, class away3d.bounds.BoundingVolumeBase
 | Clones the current BoundingVolume object
clone() — method, class away3d.cameras.lenses.FreeMatrixLens
clone() — method, class away3d.cameras.lenses.LensBase
 | Creates an exact duplicate of the lens
clone() — method, class away3d.cameras.lenses.OrthographicLens
clone() — method, class away3d.cameras.lenses.OrthographicOffCenterLens
clone() — method, class away3d.cameras.lenses.PerspectiveLens
clone() — method, class away3d.containers.ObjectContainer3D
 | Clones this ObjectContainer3D instance along with all it's children, and returns the result (which will be a copy of this container, containing copies of all it's children.)
clone() — method, class away3d.core.base.CompactSubGeometry
clone() — method, class away3d.core.base.Geometry
 | Clones the geometry.
clone() — method, interface away3d.core.base.ISubGeometry
clone() — method, class away3d.core.base.Object3D
clone() — method, class away3d.core.base.SkinnedSubGeometry
 | Clones the current object.
clone() — method, class away3d.core.base.SubGeometry
 | Clones the current object
clone() — method, class away3d.core.base.data.Face
 | returns a new Face value Object
clone() — method, class away3d.core.base.data.UV
 | returns a new UV value Object
clone() — method, class away3d.core.base.data.Vertex
 | returns a new Vertex value Object
clone() — method, class away3d.core.math.Quaternion
 | Clones the quaternion.
clone() — method, class away3d.entities.Mesh
 | Clones this Mesh instance along with all it's children, while re-using the same material and geometry instance.
clone() — method, class away3d.events.AnimationStateEvent
 | Clones the event.
clone() — method, class away3d.events.AnimatorEvent
 | Clones the event.
clone() — method, class away3d.events.AssetEvent
clone() — method, class away3d.events.GeometryEvent
 | Clones the event.
clone() — method, class away3d.events.LensEvent
clone() — method, class away3d.events.LightEvent
clone() — method, class away3d.events.LoaderEvent
 | Clones the current event.
clone() — method, class away3d.events.MouseEvent3D
 | Creates a copy of the MouseEvent3D object and sets the value of each property to match that of the original.
clone() — method, class away3d.events.Object3DEvent
 | Creates a copy of the Object3DEvent object and sets the value of each property to match that of the original.
clone() — method, class away3d.events.ParserEvent
clone() — method, class away3d.events.Scene3DEvent
clone() — method, class away3d.primitives.PrimitiveBase
 | Clones the geometry.
clone(mesh:away3d.entities:Mesh, newName:String) — Static Method , class away3d.tools.helpers.MeshHelper
 | Clones a Mesh
clones — Property, class away3d.extrusions.PathDuplicator
 | returns a vector with all meshes cloned since last time build method was called.
cloneWithSeperateBuffers() — method, class away3d.core.base.CompactSubGeometry
cloneWithSeperateBuffers() — method, interface away3d.core.base.ISubGeometry
cloneWithSeperateBuffers() — method, class away3d.core.base.SubGeometry
closePath — Property, class away3d.extrusions.PathExtrude
 | Defines if the last PathSegment should join the first one and close the loop.
closeShape — Property, class away3d.extrusions.SkinExtrude
 | Defines if the last vector of Vector3D are joined to the first one, closing the shape.
closestPointToPoint(point:flash.geom:Vector3D, target:flash.geom:Vector3D) — method, class away3d.bounds.AxisAlignedBoundingBox
 | Finds the closest point on the bounding volume to another given point.
_collectionMark — Property, class away3d.core.partition.NodeBase
_collectionMark — Static Property, class away3d.core.traverse.PartitionTraverser
 | A property that can be used to avoid processing a partition more than once.
collectLights(renderable:away3d.core.base:IRenderable, entityCollector:away3d.core.traverse:EntityCollector) — method, class away3d.materials.lightpickers.LightPickerBase
 | Updates set of lights for a given renderable and EntityCollector.
collidesBefore(shortestCollisionDistance:Number, findClosest:Boolean) — method, class away3d.entities.Entity
 | Tests if a collision occurs before shortestCollisionDistance, using the data stored in PickingCollisionVO.
collidesBefore(shortestCollisionDistance:Number, findClosest:Boolean) — method, class away3d.entities.Mesh
_collidingObject — Property, class away3d.core.managers.Mouse3DManager
color — Property, class away3d.core.managers.Stage3DProxy
 | The background color of the Stage3D.
color — Property, class away3d.lights.LightBase
 | The color of the light.
color — Property, class away3d.materials.ColorMaterial
 | The diffuse color of the surface.
color — Property, class away3d.materials.ColorMultiPassMaterial
 | The diffuse color of the surface.
color — Property, class away3d.materials.methods.RimLightMethod
color — Property, class away3d.primitives.WireframePrimitiveBase
color(data:any) — Static Method , class away3d.utils.Cast
COLOR_END_COLORTRANSFORM — Constant Static Property, class away3d.animators.nodes.ParticleColorNode
 | Reference for color node properties on a single particle (when in local property mode).
ColorHitMap — class, package away3d.tools.utils
ColorHitMap(bitmapData:flash.display:BitmapData, scaleX:Number, scaleY:Number) — Constructor, class away3d.tools.utils.ColorHitMap
 | Creates a new ColorHitMap
ColorMaterial — class, package away3d.materials
 | ColorMaterial is a material that uses a flat colour as the surfaces diffuse.
ColorMaterial(color:uint, alpha:Number) — Constructor, class away3d.materials.ColorMaterial
 | Creates a new ColorMaterial object.
colorMatrix — Property, class away3d.materials.methods.ColorMatrixMethod
 | The ColorMatrixFilter object to transform the color of the material.
ColorMatrixMethod — class, package away3d.materials.methods
 | ColorMatrixMethod provides a shading method that changes the colour of a material according to a ColorMatrixFilter object.
ColorMatrixMethod(matrix:Array) — Constructor, class away3d.materials.methods.ColorMatrixMethod
 | Creates a new ColorTransformMethod.
ColorMultiPassMaterial — class, package away3d.materials
 | ColorMaterial is a material that uses a flat colour as the surfaces diffuse.
ColorMultiPassMaterial(color:uint) — Constructor, class away3d.materials.ColorMultiPassMaterial
 | Creates a new ColorMaterial object.
colorNormals — Property, class away3d.tools.helpers.MeshDebugger
COLOR_START_COLORTRANSFORM — Constant Static Property, class away3d.animators.nodes.ParticleColorNode
 | Reference for color node properties on a single particle (when in local property mode).
colorTangents — Property, class away3d.tools.helpers.MeshDebugger
colorTarget — Property, class away3d.animators.data.AnimationRegisterCache
colorTransform — Property, class away3d.materials.SinglePassMaterialBase
 | The ColorTransform object to transform the colour of the material with.
colorTransform — Property, class away3d.materials.methods.ColorTransformMethod
 | The ColorTransform object to transform the colour of the material with.
colorTransform — Property, class away3d.materials.passes.SuperShaderPass
 | The ColorTransform object to transform the colour of the material with.
_colorTransformMethod — Property, class away3d.materials.methods.ShaderMethodSetup
colorTransformMethod — Property, class away3d.materials.methods.ShaderMethodSetup
colorTransformMethod — Property, class away3d.materials.passes.SuperShaderPass
ColorTransformMethod — class, package away3d.materials.methods
 | ColorTransformMethod provides a shading method that changes the colour of a material according to a ColorTransform object.
ColorTransformMethod() — Constructor, class away3d.materials.methods.ColorTransformMethod
 | Creates a new ColorTransformMethod.
_colorTransformMethodVO — Property, class away3d.materials.methods.ShaderMethodSetup
colorVertexNormals — Property, class away3d.tools.helpers.MeshDebugger
com.adobe.utils — package
_combinedLightSources — Property, class away3d.materials.compilation.ShaderCompiler
commons — Property, class away3d.materials.compilation.ShaderRegisterData
commonsDataIndex — Property, class away3d.materials.compilation.ShaderCompiler
_commonsDataIndex — Property, class away3d.materials.passes.CompiledPass
CompactSubGeometry — class, package away3d.core.base
CompactSubGeometry() — Constructor, class away3d.core.base.CompactSubGeometry
compare(m1:flash.geom:Matrix3D, m2:flash.geom:Matrix3D) — Static Method , class away3d.core.math.Matrix3DUtils
 | Returns a boolean value representing whether there is any significant difference between the two given 3d matrices.
compile() — method, class away3d.materials.compilation.ShaderCompiler
CompiledPass — class, package away3d.materials.passes
CompiledPass(material:away3d.materials:MaterialBase) — Constructor, class away3d.materials.passes.CompiledPass
compileGlobalPositionCode() — method, class away3d.materials.compilation.ShaderCompiler
compileLightingCode() — method, class away3d.materials.compilation.LightingShaderCompiler
compileLightingCode() — method, class away3d.materials.compilation.ShaderCompiler
compileLightingCode() — method, class away3d.materials.compilation.SuperShaderCompiler
compileMethods() — method, class away3d.materials.compilation.ShaderCompiler
compileMethodsCode() — method, class away3d.materials.compilation.LightingShaderCompiler
compileMethodsCode() — method, class away3d.materials.compilation.ShaderCompiler
compileNormalCode() — method, class away3d.materials.compilation.LightingShaderCompiler
compileNormalCode() — method, class away3d.materials.compilation.ShaderCompiler
compileNormalCode() — method, class away3d.materials.compilation.SuperShaderCompiler
_compiler — Property, class away3d.materials.passes.CompiledPass
compileViewDirCode() — method, class away3d.materials.compilation.LightingShaderCompiler
compileViewDirCode() — method, class away3d.materials.compilation.ShaderCompiler
compileViewDirCode() — method, class away3d.materials.compilation.SuperShaderCompiler
component — Property, class away3d.materials.compilation.ShaderRegisterElement
 | The register's component, if not the entire register is represented.
CompositeDiffuseMethod — class, package away3d.materials.methods
 | CompositeDiffuseMethod provides a base class for diffuse methods that wrap a diffuse method to alter the strength of its calculated strength.
CompositeDiffuseMethod(modulateMethod:Function, baseDiffuseMethod:away3d.materials.methods:BasicDiffuseMethod) — Constructor, class away3d.materials.methods.CompositeDiffuseMethod
 | Creates a new WrapDiffuseMethod object.
CompositeSpecularMethod — class, package away3d.materials.methods
 | CompositeSpecularMethod provides a base class for specular methods that wrap a specular method to alter the strength of its calculated strength.
CompositeSpecularMethod(modulateMethod:Function, baseSpecularMethod:away3d.materials.methods:BasicSpecularMethod) — Constructor, class away3d.materials.methods.CompositeSpecularMethod
 | Creates a new WrapSpecularMethod object.
condensedIndexLookUp — Property, class away3d.core.base.SkinnedSubGeometry
 | If indices have been condensed, this will contain the original index for each condensed index.
condenseIndexData() — method, class away3d.core.base.SkinnedSubGeometry
ConeGeometry — class, package away3d.primitives
 | A UV Cone primitive mesh.
ConeGeometry(radius:Number, height:Number, segmentsW:uint, segmentsH:uint, closed:Boolean, yUp:Boolean) — Constructor, class away3d.primitives.ConeGeometry
 | Creates a new Cone object.
CONFIG_DEFAULT — Constant Static Property, class away3d.loaders.parsers.DAEParser
configureBackBuffer(backBufferWidth:int, backBufferHeight:int, antiAlias:int, enableDepthAndStencil:Boolean) — method, class away3d.core.managers.Stage3DProxy
 | Configures the back buffer associated with the Stage3D object.
CONFIG_USE_GPU — Constant Static Property, class away3d.loaders.parsers.DAEParser
conflictPrecedence — Static Property, class away3d.library.AssetLibrary
 | Short-hand for conflictPrecedence property on default asset library bundle.
conflictPrecedence — Property, class away3d.library.AssetLibraryBundle
 | Defines which asset should have precedence when resolving a naming conflict between two assets of which one has just been renamed by the user or by a parser.
ConflictPrecedence — class, package away3d.library.naming
 | Enumaration class for precedence when resolving naming conflicts in the library.
conflictStrategy — Static Property, class away3d.library.AssetLibrary
 | Short-hand for conflictStrategy property on default asset library bundle.
conflictStrategy — Property, class away3d.library.AssetLibraryBundle
 | Defines which strategy should be used for resolving naming conflicts, when two library assets are given the same name.
ConflictStrategy — class, package away3d.library.naming
 | Enumeration class for bundled conflict strategies.
ConflictStrategyBase — class, package away3d.library.naming
 | Abstract base class for naming conflict resolution classes.
ConflictStrategyBase() — Constructor, class away3d.library.naming.ConflictStrategyBase
constructSubGeometry(verts:Vector$Number, indices:Vector$uint, uvs:Vector$Number, normals:Vector$Number, tangents:Vector$Number, weights:Vector$Number, jointIndices:Vector$Number) — Static Method , class away3d.tools.utils.GeomUtil
 | Build a sub-geometry from data vectors.
container — Property, class away3d.extrusions.PathDuplicator
 | If a container is provided, the meshes are addChilded to it instead of directly into the scene.
container — Property, interface away3d.materials.utils.IVideoPlayer
 | Provides access to the Video Object
container — Property, class away3d.materials.utils.SimpleVideoPlayer
CONTAINER — Constant Static Property, class away3d.library.assets.AssetType
containerComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when a container asset has been constructed from a resource.
containerComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when a container asset has been constructed from a resource.
containerComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when a container asset has been constructed from a resource.
containerComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when a container asset has been constructed from a resource.
containerComplete — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when a container asset has been constructed from a resource.
containerComplete — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when a container asset has been constructed from a resource.
CONTAINER_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
contains(child:away3d.containers:ObjectContainer3D) — method, class away3d.containers.ObjectContainer3D
contains(child:away3d.containers:ObjectContainer3D) — method, class away3d.containers.Scene3D
contains(entryPoint:flash.geom:Vector3D) — method, class away3d.core.partition.ViewVolume
containsPoint(position:flash.geom:Vector3D) — method, class away3d.bounds.AxisAlignedBoundingBox
 | Method for calculating whether the given position is contained within the bounding volume.
containsPoint(position:flash.geom:Vector3D) — method, class away3d.bounds.BoundingSphere
 | Method for calculating whether the given position is contained within the bounding volume.
containsPoint(position:flash.geom:Vector3D) — method, class away3d.bounds.BoundingVolumeBase
 | Method for calculating whether the given position is contained within the bounding volume.
containsPoint(point:flash.geom:Vector3D, maxDistanceToPlane:Number) — method, class away3d.core.base.data.Face
 | Tests whether a given point is inside the triangle
_context — Property, class away3d.core.render.RendererBase
_context3D — Property, class away3d.core.managers.Stage3DProxy
context3D — Property, class away3d.core.managers.Stage3DProxy
 | The Context3D object associated with the given Stage3D object.
CONTEXT3D_CREATED — Constant Static Property, class away3d.events.Stage3DEvent
CONTEXT3D_DISPOSED — Constant Static Property, class away3d.events.Stage3DEvent
CONTEXT3D_RECREATED — Constant Static Property, class away3d.events.Stage3DEvent
_contextIndex — Property, class away3d.core.base.CompactSubGeometry
continuousCurve(points:Vector$flash.geom:Vector3D, closed:Boolean) — method, class away3d.paths.QuadraticPath
control — Property, class away3d.paths.QuadraticPathSegment
 | Defines the control vector of the PathSegment
control1 — Property, class away3d.paths.CubicPathSegment
 | The first control point.
control2 — Property, class away3d.paths.CubicPathSegment
 | The second control point.
ControllerBase — class, package away3d.controllers
ControllerBase(targetObject:away3d.entities:Entity) — Constructor, class away3d.controllers.ControllerBase
 | Base controller class for dynamically adjusting the propeties of a 3D object.
controlNet — Property, class away3d.primitives.NURBSGeometry
 | Defines the control point net to describe the NURBS surface
controlPoint — Property, class away3d.animators.states.ParticleBezierCurveState
 | Defines the default control point of the node, used when in global mode.
convertToSeparateBuffers() — method, class away3d.core.base.Geometry
 | Updates the SubGeometries so all vertex data is represented in different buffers.
copyFrom(pose:away3d.animators.data:JointPose) — method, class away3d.animators.data.JointPose
 | Copies the transformation data from a source pose object into the existing pose object.
copyFrom(q:away3d.core.math:Quaternion) — method, class away3d.core.math.Quaternion
 | Copies the data from a quaternion into this instance.
copyFrom(method:away3d.materials.methods:ShadingMethodBase) — method, class away3d.materials.methods.BasicAmbientMethod
 | Copies the state from a BasicAmbientMethod object into the current object.
copyFrom(method:away3d.materials.methods:ShadingMethodBase) — method, class away3d.materials.methods.BasicDiffuseMethod
 | Copies the state from a BasicDiffuseMethod object into the current object.
copyFrom(method:away3d.materials.methods:ShadingMethodBase) — method, class away3d.materials.methods.BasicNormalMethod
copyFrom(method:away3d.materials.methods:ShadingMethodBase) — method, class away3d.materials.methods.BasicSpecularMethod
 | Copies the state from a BasicSpecularMethod object into the current object.
copyFrom(method:away3d.materials.methods:ShadingMethodBase) — method, class away3d.materials.methods.HeightMapNormalMethod
copyFrom(method:away3d.materials.methods:ShadingMethodBase) — method, class away3d.materials.methods.ShadingMethodBase
 | Copies the state from a ShadingMethodBase object into the current object.
coverageRatio — Property, class away3d.lights.shadowmaps.NearDirectionalShadowMapper
 | A value between 0 and 1 to indicate the ratio of the view frustum that needs to be covered by the shadow map.
coverAll — Property, class away3d.extrusions.LatheExtrude
 | Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments.
coverAll — Property, class away3d.extrusions.LinearExtrude
 | Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments.
coverAll — Property, class away3d.extrusions.PathExtrude
 | Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments.
coverAll — Property, class away3d.extrusions.SkinExtrude
 | Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments.
coverSegment — Property, class away3d.extrusions.PathExtrude
 | Defines if the texture(s) should applied per segment.
create() — method, class away3d.library.naming.ConflictStrategyBase
 | Create instance of this conflict strategy.
create() — method, class away3d.library.naming.ErrorConflictStrategy
create() — method, class away3d.library.naming.IgnoreConflictStrategy
create() — method, class away3d.library.naming.NumSuffixConflictStrategy
createBoundingRenderable() — method, class away3d.bounds.AxisAlignedBoundingBox
createBoundingRenderable() — method, class away3d.bounds.BoundingSphere
createBoundingRenderable() — method, class away3d.bounds.BoundingVolumeBase
createBoundingRenderable() — method, class away3d.bounds.NullBounds
createBuffer(contextIndex:int, context:flash.display3D:Context3D) — method, class away3d.core.base.CompactSubGeometry
createCasterCollector() — method, class away3d.lights.shadowmaps.ShadowMapperBase
createCompiler() — method, class away3d.materials.passes.CompiledPass
createCompiler() — method, class away3d.materials.passes.LightingPass
createCompiler() — method, class away3d.materials.passes.ShadowCasterPass
createCompiler() — method, class away3d.materials.passes.SuperShaderPass
createDebugBounds() — method, class away3d.core.partition.InvertedOctreeNode
createDebugBounds() — method, class away3d.core.partition.NodeBase
createDebugBounds() — method, class away3d.core.partition.OctreeNode
createDebugBounds() — method, class away3d.core.partition.ViewVolume
createDepthTexture() — method, class away3d.lights.shadowmaps.CubeMapShadowMapper
createDepthTexture() — method, class away3d.lights.shadowmaps.ShadowMapperBase
createEntityCollector() — method, class away3d.core.render.RendererBase
createEntityPartitionNode() — method, class away3d.cameras.Camera3D
 | Factory method that returns the current partition node.
createEntityPartitionNode() — method, class away3d.entities.Entity
 | Factory method that returns the current partition node.
createEntityPartitionNode() — method, class away3d.entities.Mesh
 | Factory method that returns the current partition node.
createEntityPartitionNode() — method, class away3d.entities.SegmentSet
createEntityPartitionNode() — method, class away3d.entities.Sprite3D
createEntityPartitionNode() — method, class away3d.lights.DirectionalLight
createEntityPartitionNode() — method, class away3d.lights.LightBase
 | Factory method that returns the current partition node.
createEntityPartitionNode() — method, class away3d.lights.LightProbe
createEntityPartitionNode() — method, class away3d.lights.PointLight
createEntityPartitionNode() — method, class away3d.primitives.SkyBox
 | Factory method that returns the current partition node.
createIterator(assetTypeFilter:String, namespaceFilter:String, filterFunc:Function) — Static Method , class away3d.library.AssetLibrary
 | Short-hand for createIterator() method on default asset library bundle.
createIterator(assetTypeFilter:String, namespaceFilter:String, filterFunc:Function) — method, class away3d.library.AssetLibraryBundle
 | Create an AssetLibraryIterator instance that can be used to iterate over the assets in this asset library instance.
createMethodVO() — method, class away3d.materials.methods.ShadingMethodBase
 | Creates a data container that contains material-dependent data.
createNormalRegisters() — method, class away3d.materials.compilation.LightingShaderCompiler
createSegmentFromArrayEntry(data:Vector$flash.geom:Vector3D, offset:uint) — method, class away3d.paths.CubicPath
createSegmentFromArrayEntry(data:Vector$flash.geom:Vector3D, offset:uint) — method, class away3d.paths.QuadraticPath
createSegmentFromArrayEntry(data:Vector$flash.geom:Vector3D, offset:uint) — method, class away3d.paths.SegmentedPathBase
createShadowMapper() — method, class away3d.lights.DirectionalLight
createShadowMapper() — method, class away3d.lights.LightBase
createShadowMapper() — method, class away3d.lights.PointLight
createTexture(context:flash.display3D:Context3D) — method, class away3d.textures.ATFCubeTexture
createTexture(context:flash.display3D:Context3D) — method, class away3d.textures.ATFTexture
createTexture(context:flash.display3D:Context3D) — method, class away3d.textures.CubeTextureBase
createTexture(context:flash.display3D:Context3D) — method, class away3d.textures.RenderCubeTexture
createTexture(context:flash.display3D:Context3D) — method, class away3d.textures.RenderTexture
createTexture(context:flash.display3D:Context3D) — method, class away3d.textures.Texture2DBase
createTexture(context:flash.display3D:Context3D) — method, class away3d.textures.TextureProxyBase
createVertexData(numVertices:uint, totalLenOfOneVertex:uint) — method, class away3d.animators.data.AnimationSubGeometry
CrossfadeTransition — class, package away3d.animators.transitions
CrossfadeTransition(blendSpeed:Number) — Constructor, class away3d.animators.transitions.CrossfadeTransition
CrossfadeTransitionNode — class, package away3d.animators.transitions
 | A skeleton animation node that uses two animation node inputs to blend a lineraly interpolated output of a skeleton pose.
CrossfadeTransitionNode() — Constructor, class away3d.animators.transitions.CrossfadeTransitionNode
 | Creates a new CrossfadeTransitionNode object.
CrossfadeTransitionState — class, package away3d.animators.transitions
CrossfadeTransitionState(animator:away3d.animators:IAnimator, skeletonAnimationNode:away3d.animators.transitions:CrossfadeTransitionNode) — Constructor, class away3d.animators.transitions.CrossfadeTransitionState
ctrlKey — Property, class away3d.events.MouseEvent3D
 | Indicates whether the Control key is active (true) or inactive (false).
CubeGeometry — class, package away3d.primitives
 | A Cube primitive mesh.
CubeGeometry(width:Number, height:Number, depth:Number, segmentsW:uint, segmentsH:uint, segmentsD:uint, tile6:Boolean) — Constructor, class away3d.primitives.CubeGeometry
 | Creates a new Cube object.
cubeMap — Property, class away3d.materials.SkyBoxMaterial
 | The CubeMap to use as the skybox.
CubeMapShadowMapper — class, package away3d.lights.shadowmaps
CubeMapShadowMapper() — Constructor, class away3d.lights.shadowmaps.CubeMapShadowMapper
CubeReflectionTexture — class, package away3d.textures
 | CubeReflectionTexture provides a cube map texture for real-time reflections, used for any method that uses environment maps, such as EnvMapMethod.
CubeReflectionTexture(size:int) — Constructor, class away3d.textures.CubeReflectionTexture
 | Creates a new CubeReflectionTexture object
cubeTexture — Property, class away3d.materials.passes.SkyBoxPass
 | The cube texture to use as the skybox.
CubeTextureBase — class, package away3d.textures
CubeTextureBase() — Constructor, class away3d.textures.CubeTextureBase
CubicPath — class, package away3d.paths
 | Defines a cubic path.
CubicPath(data:Vector$flash.geom:Vector3D) — Constructor, class away3d.paths.CubicPath
 | Creates a new CubicPath instance.
CubicPathSegment — class, package away3d.paths
 | Defines a single segment of a cubic path
CubicPathSegment(start:flash.geom:Vector3D, control1:flash.geom:Vector3D, control2:flash.geom:Vector3D, end:flash.geom:Vector3D) — Constructor, class away3d.paths.CubicPathSegment
currentAsset — Property, class away3d.library.utils.AssetLibraryIterator
_currentFrame — Property, class away3d.animators.states.AnimationClipState
currentFrame — Property, class away3d.animators.states.AnimationClipState
 | Returns the current frame of animation in the clip based on the internal playhead position.
currentGeometry — Property, interface away3d.animators.states.IVertexAnimationState
 | Returns the current geometry frame of animation in the clip based on the internal playhead position.
currentGeometry — Property, class away3d.animators.states.VertexClipState
 | Returns the current geometry frame of animation in the clip based on the internal playhead position.
_currentPanAngle — Property, class away3d.controllers.FirstPersonController
_currentPanAngle — Property, class away3d.controllers.HoverController
currentPose — Property, class away3d.animators.states.SkeletonClipState
 | Returns the current skeleton pose frame of animation in the clip based on the internal playhead position.
_currentTiltAngle — Property, class away3d.controllers.FirstPersonController
_currentTiltAngle — Property, class away3d.controllers.HoverController
currentUVFrame — Property, interface away3d.animators.states.IUVAnimationState
 | Returns the current UV frame of animation in the clip based on the internal playhead position.
currentUVFrame — Property, class away3d.animators.states.UVClipState
 | Returns the current UV frame of animation in the clip based on the internal playhead position.
cx — Property, class away3d.filters.RadialBlurFilter3D
cx — Property, class away3d.filters.tasks.Filter3DRadialBlurTask
cy — Property, class away3d.filters.RadialBlurFilter3D
cy — Property, class away3d.filters.tasks.Filter3DRadialBlurTask
cycle — Property, class away3d.animators.nodes.ParticleUVNode
CYCLE — Constant Static Property, class away3d.events.PathEvent
 | Dispatched when the time pointer enter a new cycle at time 0, after last time was greater than 0.99
cycleDuration — Property, class away3d.animators.states.ParticleColorState
 | Defines the duration of the animation in seconds, used as a period independent of particle duration when in global mode.
cycleDuration — Property, class away3d.animators.states.ParticleOrbitState
 | Defines the duration of the orbit in seconds, used as a period independent of particle duration when in global mode.
cycleDuration — Property, class away3d.animators.states.ParticleScaleState
 | Defines the duration of the animation in seconds, used as a period independent of particle duration when in global mode.
cycleDuration — Property, class away3d.animators.states.ParticleSpriteSheetState
 | Defines the cycle duration in seconds, when in global mode.
cyclePhase — Property, class away3d.animators.states.ParticleColorState
 | Defines the phase of the cycle in degrees, used as the starting offset of the cycle when in global mode.
cyclePhase — Property, class away3d.animators.states.ParticleOrbitState
 | Defines the phase of the orbit in degrees, used as the starting offset of the cycle when in global mode.
cyclePhase — Property, class away3d.animators.states.ParticleScaleState
 | Defines the phase of the cycle in degrees, used as the starting offset of the cycle when in global mode.
cyclePhase — Property, class away3d.animators.states.ParticleSpriteSheetState
 | Defines the cycle phase, when in global mode.
CylinderGeometry — class, package away3d.primitives
 | A UV Cylinder primitive mesh.
CylinderGeometry(topRadius:Number, bottomRadius:Number, height:Number, segmentsW:uint, segmentsH:uint, topClosed:Boolean, bottomClosed:Boolean, surfaceClosed:Boolean, yUp:Boolean) — Constructor, class away3d.primitives.CylinderGeometry
 | Creates a new Cylinder object.
CYLINDRICAL_X — Constant Static Property, class away3d.tools.utils.Projector
CYLINDRICAL_Y — Constant Static Property, class away3d.tools.utils.Projector
CYLINDRICAL_Z — Constant Static Property, class away3d.tools.utils.Projector
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


D

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
D Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
d — Property, class away3d.core.math.Plane3D
 | The D coefficient of this plane.
DAEParser — class, package away3d.loaders.parsers
 | DAEParser provides a parser for the DAE data type.
DAEParser(configFlags:uint) — Constructor, class away3d.loaders.parsers.DAEParser
damping — Property, class away3d.controllers.SpringController
 | Damping is the spring internal friction, or how much it resists the "boinggggg" effect.
data — Property, class away3d.loaders.misc.ResourceDependency
 | The data containing the dependency to be parsed, if the resource was already loaded.
data — Property, class away3d.loaders.misc.SingleFileLoader
_data — Property, class away3d.loaders.parsers.ParserBase
data — Property, class away3d.materials.methods.MethodVOSet
data — Property, class away3d.textures.ATFData
_dataFormat — Property, class away3d.loaders.parsers.ParserBase
dataFormat — Property, class away3d.loaders.parsers.ParserBase
 | The data format of the file data to be parsed.
_dataLength — Property, class away3d.animators.nodes.ParticleNodeBase
dataLength — Property, class away3d.animators.nodes.ParticleNodeBase
 | Returns the length of the data used by the node when in LOCAL_STATIC mode.
dataOffset — Property, class away3d.animators.nodes.ParticleNodeBase
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy, pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.ParticleAnimationSet
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy, pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.SkeletonAnimationSet
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy, pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.UVAnimationSet
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy, pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.VertexAnimationSet
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DCompositeTask
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DHDepthOfFFieldTask
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DTaskBase
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DVDepthOfFFieldTask
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DXFadeCompositeTask
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.MultiPassMaterialBase
deactivate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.CompositeDiffuseMethod
deactivate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.CompositeSpecularMethod
deactivate(vo:away3d.materials.methods:MethodVO, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.NearShadowMapMethod
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.passes.CompiledPass
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.passes.OutlinePass
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.passes.SegmentPass
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.passes.SuperShaderPass
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.stereo.methods.InterleavedStereoRenderMethod
deactivate(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.stereo.methods.StereoRenderMethodBase
deactivateForDepth(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.MaterialBase
debug(mesh:away3d.entities:Mesh, scene:away3d.containers:Scene3D, displayNormals:Boolean, displayVertexNormals:Boolean, displayTangents:Boolean) — method, class away3d.tools.helpers.MeshDebugger
debug — Property, class away3d.tools.utils.Drag3D
 | Displays the planes for debug/visual aid purposes
Debug — class, package away3d.debug
 | Class for emmiting debuging messages, warnings and errors
debugContainer(object:away3d.containers:ObjectContainer3D, scene:away3d.containers:Scene3D, displayNormals:Boolean, displayVertexNormals:Boolean, displayTangents:Boolean) — method, class away3d.tools.helpers.MeshDebugger
_debugPrimitive — Property, class away3d.core.partition.NodeBase
_defaultCulling — Property, class away3d.materials.passes.MaterialPassBase
DefaultMaterialManager — class, package away3d.materials.utils
DEFAULT_NAMESPACE — Constant Static Property, class away3d.library.assets.NamedAssetBase
DefaultRenderer — class, package away3d.core.render
 | The DefaultRenderer class provides the default rendering method.
DefaultRenderer() — Constructor, class away3d.core.render.DefaultRenderer
 | Creates a new DefaultRenderer object.
DEFLATE — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
DEGREES_TO_RADIANS — Constant Static Property, class away3d.core.math.MathConsts
 | The amount to multiply with when converting degrees to radians.
DelaunayMesh — class, package away3d.extrusions
DelaunayMesh(material:away3d.materials:MaterialBase, vectors:Vector$flash.geom:Vector3D, plane:String, centerMesh:Boolean, flip:Boolean, smoothSurface:Boolean) — Constructor, class away3d.extrusions.DelaunayMesh
delay — Property, class away3d.animators.data.ParticleAnimationData
delay — Property, class away3d.animators.data.ParticleProperties
 | The delay between cycles of the particle, an optional value used when the particle aniamtion set settings for useLooping and useDelay are enabled in the constructor.
delimiter() — Static Method , class away3d.debug.Debug
delta — Property, class away3d.events.MouseEvent3D
 | Indicates how many lines should be scrolled for each unit the user rotates the mouse wheel.
deltaTime — Property, class away3d.containers.View3D
 | The amount of milliseconds the last render call took
dependencies — Property, class away3d.loaders.misc.ResourceDependency
dependencies — Property, class away3d.loaders.misc.SingleFileLoader
 | A list of dependencies that need to be loaded and resolved for the loaded object.
dependencies — Property, class away3d.loaders.parsers.AWDParser
 | A list of dependencies that need to be loaded and resolved for the object being parsed.
dependencies — Property, class away3d.loaders.parsers.ParserBase
 | A list of dependencies that need to be loaded and resolved for the object being parsed.
dependencyBaseUrl — Property, class away3d.loaders.misc.AssetLoaderContext
 | A base URL that will be prepended to all relative dependency URLs found in a loaded resource.
dependencyComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when a single dependency (which may be the main file of a resource) finishes loading.
dependencyComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when a single dependency (which may be the main file of a resource) finishes loading.
dependencyComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when a single dependency (which may be the main file of a resource) finishes loading.
dependencyComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when a single dependency (which may be the main file of a resource) finishes loading.
dependencyComplete — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when the dependency that this single-file loader was loading complets.
DEPENDENCY_COMPLETE — Constant Static Property, class away3d.events.LoaderEvent
 | Dispatched when a resource's dependency is retrieved and resolved.
_dependencyCounter — Property, class away3d.materials.compilation.ShaderCompiler
DeprecationError — class, package away3d.errors
DeprecationError(source:String, since:String, info:String) — Constructor, class away3d.errors.DeprecationError
depth — Property, class away3d.core.partition.ViewVolume
depth — Property, class away3d.extrusions.Elevation
 | The depth of the terrain plane.
depth — Property, class away3d.primitives.CubeGeometry
 | The size of the cube along its Z-axis.
depth — Property, class away3d.primitives.WireframeCube
 | The size of the cube along its Z-axis.
depth — Static Property, class away3d.tools.utils.Bounds
_depthCamera — Property, class away3d.lights.shadowmaps.DirectionalShadowMapper
depthCompareMode — Property, class away3d.materials.MaterialBase
depthCompareMode — Property, class away3d.materials.MultiPassMaterialBase
depthCompareMode — Property, class away3d.materials.SinglePassMaterialBase
_depthCompareMode — Property, class away3d.materials.passes.MaterialPassBase
depthCompareMode — Property, class away3d.materials.passes.MaterialPassBase
DepthDiffuseMethod — class, package away3d.materials.methods
 | DepthDiffuseMethod provides a debug method to visualise depth maps
DepthDiffuseMethod() — Constructor, class away3d.materials.methods.DepthDiffuseMethod
 | Creates a new BasicDiffuseMethod object.
_depthLens — Property, class away3d.lights.shadowmaps.DirectionalShadowMapper
depthMap — Property, class away3d.lights.shadowmaps.ShadowMapperBase
_depthMapCoordReg — Property, class away3d.materials.methods.SimpleShadowMapMethodBase
depthMapCoordReg — Property, class away3d.materials.methods.SimpleShadowMapMethodBase
 | Wrappers that override the vertex shader need to set this explicitly
DepthMapPass — class, package away3d.materials.passes
DepthMapPass() — Constructor, class away3d.materials.passes.DepthMapPass
depthMapSize — Property, class away3d.lights.shadowmaps.CascadeShadowMapper
_depthMapSize — Property, class away3d.lights.shadowmaps.ShadowMapperBase
depthMapSize — Property, class away3d.lights.shadowmaps.ShadowMapperBase
DepthOfFieldFilter3D — class, package away3d.filters
DepthOfFieldFilter3D(maxBlurX:uint, maxBlurY:uint, stepSize:int) — Constructor, class away3d.filters.DepthOfFieldFilter3D
 | Creates a new DepthOfFieldFilter3D object.
_depthPass — Property, class away3d.materials.MaterialBase
_depthPassId — Property, class away3d.materials.MaterialBase
depthPrepass — Property, class away3d.containers.View3D
depthProjection — Property, class away3d.lights.shadowmaps.DirectionalShadowMapper
 | Depth projection matrix that projects from scene space to depth map.
_depthRender — Property, class away3d.containers.View3D
DepthRenderer — class, package away3d.core.render
 | The DepthRenderer class renders 32-bit depth information encoded as RGBA
DepthRenderer(renderBlended:Boolean, distanceBased:Boolean) — Constructor, class away3d.core.render.DepthRenderer
 | Creates a new DepthRenderer object.
dieWithError(message:String) — method, class away3d.loaders.parsers.ParserBase
differenceInput — Property, class away3d.animators.nodes.SkeletonDifferenceNode
 | Defines a difference input node to use for the blended output.
diffuse — Property, class away3d.lights.LightBase
 | The diffuse emission strength of the light.
diffuseAlpha — Property, class away3d.materials.methods.BasicDiffuseMethod
 | The alpha component of the diffuse reflection.
diffuseAlpha — Property, class away3d.materials.methods.CompositeDiffuseMethod
 | The alpha component of the diffuse reflection.
_diffuseB — Property, class away3d.lights.LightBase
diffuseColor — Property, class away3d.materials.methods.BasicDiffuseMethod
 | The color of the diffuse reflection when not using a texture.
diffuseColor — Property, class away3d.materials.methods.CompositeDiffuseMethod
 | The color of the diffuse reflection when not using a texture.
_diffuseG — Property, class away3d.lights.LightBase
_diffuseInputRegister — Property, class away3d.materials.methods.BasicDiffuseMethod
diffuseLightSources — Property, class away3d.materials.MultiPassMaterialBase
diffuseLightSources — Property, class away3d.materials.SinglePassMaterialBase
_diffuseLightSources — Property, class away3d.materials.compilation.ShaderCompiler
diffuseLightSources — Property, class away3d.materials.compilation.ShaderCompiler
_diffuseLightSources — Property, class away3d.materials.passes.CompiledPass
diffuseLightSources — Property, class away3d.materials.passes.CompiledPass
diffuseMap — Property, class away3d.lights.LightProbe
diffuseMethod — Property, class away3d.materials.MultiPassMaterialBase
 | The method to perform diffuse shading.
diffuseMethod — Property, class away3d.materials.SinglePassMaterialBase
 | The method to perform diffuse shading.
_diffuseMethod — Property, class away3d.materials.methods.ShaderMethodSetup
diffuseMethod — Property, class away3d.materials.methods.ShaderMethodSetup
 | The method to perform diffuse shading.
diffuseMethod — Property, class away3d.materials.passes.CompiledPass
_diffuseMethodVO — Property, class away3d.materials.methods.ShaderMethodSetup
_diffuseR — Property, class away3d.lights.LightBase
dir — Property, class away3d.tools.utils.Ray
 | Defines the directional vector of the Ray object
direction — Property, class away3d.animators.states.SkeletonDirectionalState
 | Defines the direction in degrees of the aniamtion between the forwards (0), right(90) backwards (180) and left(270) input nodes, used to produce the skeleton pose output.
direction — Property, class away3d.lights.DirectionalLight
 | The direction of the light.
DirectionalLight — class, package away3d.lights
 | DirectionalLight represents an idealized light "at infinity", to be used for distant light sources such as the sun.
DirectionalLight(xDir:Number, yDir:Number, zDir:Number) — Constructor, class away3d.lights.DirectionalLight
 | Creates a new DirectionalLight object.
DirectionalLightNode — class, package away3d.core.partition
 | LightNode is a space partitioning leaf node that contains a LightBase object.
DirectionalLightNode(light:away3d.lights:DirectionalLight) — Constructor, class away3d.core.partition.DirectionalLightNode
 | Creates a new LightNode object.
directionalLights — Property, class away3d.core.traverse.EntityCollector
_directionalLights — Property, class away3d.materials.lightpickers.LightPickerBase
directionalLights — Property, class away3d.materials.lightpickers.LightPickerBase
directionalLightsOffset — Property, class away3d.materials.passes.LightingPass
DirectionalShadowMapper — class, package away3d.lights.shadowmaps
DirectionalShadowMapper() — Constructor, class away3d.lights.shadowmaps.DirectionalShadowMapper
_dirLightFragmentConstants — Property, class away3d.materials.compilation.LightingShaderCompiler
_dirLightRegisters — Property, class away3d.materials.compilation.SuperShaderCompiler
_dirLightVertexConstants — Property, class away3d.materials.compilation.LightingShaderCompiler
_dirty — Property, class away3d.textures.TextureProxyBase
disableColor — Property, class away3d.core.render.DepthRenderer
disableMouseListeners(view:away3d.containers:View3D) — method, class away3d.core.managers.Mouse3DManager
dispatchEvent(event:flash.events:Event) — method, class away3d.containers.ObjectContainer3D
dispatchEvent(event:flash.events:Event) — method, class away3d.lights.shadowmaps.CascadeShadowMapper
dispersionB — Property, class away3d.materials.methods.RefractionEnvMapMethod
dispersionG — Property, class away3d.materials.methods.RefractionEnvMapMethod
dispersionR — Property, class away3d.materials.methods.RefractionEnvMapMethod
displayNormals(mesh:away3d.entities:Mesh, color:uint, length:Number) — method, class away3d.tools.helpers.data.MeshDebug
displayTangents(mesh:away3d.entities:Mesh, color:uint, length:Number) — method, class away3d.tools.helpers.data.MeshDebug
displayVertexNormals(mesh:away3d.entities:Mesh, color:uint, length:Number) — method, class away3d.tools.helpers.data.MeshDebug
dispose() — method, class away3d.animators.AnimationSetBase
 | Cleans up any resources used by the current object.
dispose() — method, class away3d.animators.data.Skeleton
 | Cleans up resources used by this asset.
dispose() — method, class away3d.animators.data.SkeletonPose
 | Cleans up resources used by this asset.
dispose() — method, class away3d.animators.nodes.AnimationNodeBase
 | Cleans up resources used by this asset.
dispose() — method, class away3d.containers.ObjectContainer3D
 | Cleans up resources used by this asset.
dispose() — method, class away3d.containers.View3D
 | Disposes all memory occupied by the view.
dispose() — method, class away3d.core.base.CompactSubGeometry
dispose() — method, class away3d.core.base.Geometry
 | Clears all resources used by the Geometry object, including SubGeometries.
dispose() — method, interface away3d.core.base.ISubGeometry
dispose() — method, class away3d.core.base.Object3D
 | Cleans up any resources used by the current object.
dispose() — method, class away3d.core.base.SkinnedSubGeometry
 | Cleans up any resources used by this object.
dispose() — method, class away3d.core.base.SubGeometry
 | Clears all resources used by the SubGeometry object.
dispose() — method, class away3d.core.base.SubGeometryBase
dispose() — method, class away3d.core.base.SubMesh
dispose() — method, class away3d.core.data.EntityListItemPool
dispose() — method, class away3d.core.data.RenderableListItemPool
dispose() — method, class away3d.core.managers.AGALProgram3DCache
dispose() — method, class away3d.core.managers.RTTBufferManager
dispose() — method, class away3d.core.managers.Stage3DProxy
 | Disposes the Stage3DProxy object, freeing the Context3D attached to the Stage3D.
dispose() — method, class away3d.core.render.BackgroundImageRenderer
dispose() — method, class away3d.core.render.DefaultRenderer
dispose() — method, class away3d.core.render.Filter3DRenderer
dispose() — method, class away3d.entities.Mesh
 | Cleans up resources used by this asset.
dispose() — method, class away3d.entities.SegmentSet
dispose() — method, class away3d.filters.Filter3DBase
dispose() — method, class away3d.filters.tasks.Filter3DTaskBase
dispose() — method, class away3d.library.assets.BitmapDataAsset
 | Cleans up any resources used by the current object.
dispose() — method, interface away3d.library.assets.IAsset
 | Cleans up resources used by this asset.
dispose() — method, class away3d.lights.shadowmaps.ShadowMapperBase
dispose() — method, class away3d.materials.MaterialBase
 | Cleans up any resources used by the current object.
dispose() — method, class away3d.materials.compilation.ShaderCompiler
dispose() — method, class away3d.materials.compilation.ShaderRegisterCache
dispose() — method, class away3d.materials.methods.BasicDiffuseMethod
 | Cleans up any resources used by the current object.
dispose() — method, class away3d.materials.methods.BasicNormalMethod
dispose() — method, class away3d.materials.methods.CompositeDiffuseMethod
 | Cleans up any resources used by the current object.
dispose() — method, class away3d.materials.methods.CompositeSpecularMethod
 | Cleans up any resources used by the current object.
dispose() — method, class away3d.materials.methods.DitheredShadowMapMethod
dispose() — method, class away3d.materials.methods.EnvMapAmbientMethod
 | Cleans up any resources used by the current object.
dispose() — method, class away3d.materials.methods.EnvMapMethod
 | Cleans up any resources used by the current object.
dispose() — method, class away3d.materials.methods.FresnelEnvMapMethod
 | Cleans up any resources used by the current object.
dispose() — method, class away3d.materials.methods.NearShadowMapMethod
dispose() — method, class away3d.materials.methods.ShaderMethodSetup
dispose() — method, class away3d.materials.methods.ShadingMethodBase
 | Cleans up any resources used by the current object.
dispose() — method, class away3d.materials.methods.SimpleWaterNormalMethod
dispose() — method, class away3d.materials.passes.CompiledPass
 | Cleans up any resources used by the current object.
dispose() — method, class away3d.materials.passes.MaterialPassBase
 | Cleans up any resources used by the current object.
dispose() — method, class away3d.materials.passes.OutlinePass
dispose() — method, class away3d.materials.passes.SingleObjectDepthPass
 | Cleans up any resources used by the current object.
dispose() — method, interface away3d.materials.utils.IVideoPlayer
 | Called if the player is no longer needed
dispose() — method, class away3d.materials.utils.SimpleVideoPlayer
dispose() — method, class away3d.paths.CubicPathSegment
dispose() — method, interface away3d.paths.IPath
 | Disposes the path and all the segments
dispose() — method, interface away3d.paths.IPathSegment
 | Destroys the segment
dispose() — method, class away3d.paths.QuadraticPathSegment
 | nulls the 3 vectors
dispose() — method, class away3d.paths.SegmentedPathBase
dispose() — method, class away3d.textures.CubeReflectionTexture
 | Cleans up resources used by this asset.
dispose() — method, class away3d.textures.PlanarReflectionTexture
dispose() — method, class away3d.textures.SpecularBitmapTexture
dispose() — method, class away3d.textures.SplatBlendBitmapTexture
dispose() — method, class away3d.textures.TextureProxyBase
 | Cleans up resources used by this asset.
dispose() — method, class away3d.textures.VideoTexture
dispose() — method, class away3d.textures.WebcamTexture
 | Clean up used resources.
disposeAllVertexBuffers() — method, class away3d.core.base.SubGeometry
disposeAsset() — method, class away3d.core.base.Object3D
disposeForStage3D(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SubGeometry
disposeIndexBuffers(buffers:Vector$flash.display3D:IndexBuffer3D) — method, class away3d.core.base.SubGeometryBase
 | Disposes all buffers in a given vector.
disposeRenderable() — method, class away3d.bounds.BoundingVolumeBase
 | Disposes of the bounds renderable object.
disposeSources — Property, class away3d.tools.commands.Merge
 | Defines if the mesh(es) sources used for the merging are kept or disposed.
disposeVertexBuffers(buffers:Vector$flash.display3D:VertexBuffer3D) — method, class away3d.core.base.CompactSubGeometry
disposeVertexBuffers(buffers:Vector$flash.display3D:VertexBuffer3D) — method, class away3d.core.base.SubGeometryBase
 | Disposes all buffers in a given vector.
distance — Property, class away3d.controllers.HoverController
 | Distance between the camera and the specified target.
distance(p:flash.geom:Vector3D) — method, class away3d.core.math.Plane3D
 | Returns the signed distance between this Plane3D and the point p.
DistanceMapPass — class, package away3d.materials.passes
DistanceMapPass() — Constructor, class away3d.materials.passes.DistanceMapPass
_distancePass — Property, class away3d.materials.MaterialBase
distribute — Property, class away3d.extrusions.PathExtrude
 | Defines if the mesh subdivision is spread evenly over the entire geometry.
distribute(aObjs:Array, axis:String) — Static Method , class away3d.tools.commands.Align
 | Applies to array elements a distributed alignment according to axis, x,y or z.
distributeU — Property, class away3d.extrusions.PathExtrude
 | Defines the uv's u values are spreaded procentually over the entire surface to prevent the maps to be stretched.
DitheredShadowMapMethod — class, package away3d.materials.methods
 | DitheredShadowMapMethod provides a soft shadowing technique by randomly distributing sample points.
DitheredShadowMapMethod(castingLight:away3d.lights:DirectionalLight, numSamples:int) — Constructor, class away3d.materials.methods.DitheredShadowMapMethod
 | Creates a new DitheredShadowMapMethod object.
doneAGALCode(pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.ParticleAnimationSet
doneAGALCode(pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.SkeletonAnimationSet
doneAGALCode(pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.UVAnimationSet
doneAGALCode(pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.VertexAnimationSet
DOUBLE_CLICK — Constant Static Property, class away3d.events.MouseEvent3D
 | Defines the value of the type property of a doubleClick3d event object.
doubleSided — Property, class away3d.primitives.PlaneGeometry
 | Defines whether the plane will be visible from both sides, with correct vertex normals (as opposed to bothSides on Material).
downVector — Property, class away3d.core.base.Object3D
Drag3D — class, package away3d.tools.utils
 | Class Drag3D allows free dragging of an ObjectContainer3D onto a given plane.
Drag3D(view:away3d.containers:View3D, object3d:away3d.containers:ObjectContainer3D, plane:String) — Constructor, class away3d.tools.utils.Drag3D
 | Class Drag3D allows to drag 3d objects with the mouse.Drag3D
draw(entityCollector:away3d.core.traverse:EntityCollector, target:flash.display3D.textures:TextureBase) — method, class away3d.core.pick.ShaderPicker
draw(entityCollector:away3d.core.traverse:EntityCollector, target:flash.display3D.textures:TextureBase) — method, class away3d.core.render.DefaultRenderer
 | Performs the actual drawing of geometry to the target.
draw(entityCollector:away3d.core.traverse:EntityCollector, target:flash.display3D.textures:TextureBase) — method, class away3d.core.render.DepthRenderer
 | Performs the actual drawing of geometry to the target.
draw(entityCollector:away3d.core.traverse:EntityCollector, target:flash.display3D.textures:TextureBase) — method, class away3d.core.render.PositionRenderer
 | Performs the actual drawing of geometry to the target.
draw(entityCollector:away3d.core.traverse:EntityCollector, target:flash.display3D.textures:TextureBase) — method, class away3d.core.render.RendererBase
 | Performs the actual drawing of geometry to the target.
drawDepthMap(target:flash.display3D.textures:TextureBase, scene:away3d.containers:Scene3D, renderer:away3d.core.render:DepthRenderer) — method, class away3d.lights.shadowmaps.CascadeShadowMapper
drawDepthMap(target:flash.display3D.textures:TextureBase, scene:away3d.containers:Scene3D, renderer:away3d.core.render:DepthRenderer) — method, class away3d.lights.shadowmaps.CubeMapShadowMapper
drawDepthMap(target:flash.display3D.textures:TextureBase, scene:away3d.containers:Scene3D, renderer:away3d.core.render:DepthRenderer) — method, class away3d.lights.shadowmaps.DirectionalShadowMapper
drawDepthMap(target:flash.display3D.textures:TextureBase, scene:away3d.containers:Scene3D, renderer:away3d.core.render:DepthRenderer) — method, class away3d.lights.shadowmaps.ShadowMapperBase
driverInfo — Property, class away3d.core.managers.Stage3DProxy
 | The driver information as reported by the Context3D object (if any)
duration — Property, class away3d.animators.data.ParticleAnimationData
duration — Property, class away3d.animators.data.ParticleProperties
 | The duration of the particle, an optional value used when the particle aniamtion set settings for useDuration are enabled in the constructor.
_durations — Property, class away3d.animators.nodes.AnimationClipNodeBase
durations — Property, class away3d.animators.nodes.AnimationClipNodeBase
 | Returns a vector of time values representing the duration (in milliseconds) of each animation frame in the clip.
DXFParser — class, package away3d.loaders.parsers
 | DXFParser provides a parser for the dxf 3D renderable data.
DXFParser() — Constructor, class away3d.loaders.parsers.DXFParser
 | Creates a new DXFParser object.
dynamicGrid — Property, class away3d.core.partition.ViewVolumePartition
 | A dynamic grid to be able to determine visibility of dynamic objects.
dynamicGrid — Property, class away3d.core.partition.ViewVolumeRootNode
DynamicGrid — class, package away3d.core.partition
 | DynamicGrid is used by certain partitioning systems that require vislists for regions of dynamic data.
DynamicGrid(minBounds:flash.geom:Vector3D, maxBounds:flash.geom:Vector3D, numCellsX:uint, numCellsY:uint, numCellsZ:uint) — Constructor, class away3d.core.partition.DynamicGrid
_dynamicProperties — Property, class away3d.animators.states.ParticleStateBase
_dynamicPropertiesDirty — Property, class away3d.animators.states.ParticleStateBase
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


E

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
E Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
EffectMethodBase — class, package away3d.materials.methods
 | EffectMethodBase forms an abstract base class for shader methods that are not dependent on light sources, and are in essence post-process effects on the materials.
EffectMethodBase() — Constructor, class away3d.materials.methods.EffectMethodBase
effects — Property, class away3d.loaders.parsers.DAEParser
_effectsPass — Property, class away3d.materials.MultiPassMaterialBase
Elevation — class, package away3d.extrusions
Elevation(material:away3d.materials:MaterialBase, heightMap:flash.display:BitmapData, width:Number, height:Number, depth:Number, segmentsW:uint, segmentsH:uint, maxElevation:uint, minElevation:uint, smoothMap:Boolean) — Constructor, class away3d.extrusions.Elevation
 | Class Elevation generates (and becomes) a mesh from an heightmap.
emitter — Property, class away3d.audio.SoundTransform3D
enableAllBundled() — Static Method , class away3d.loaders.parsers.Parsers
 | Short-hand function to enable all bundled parsers for auto-detection.
enableDepthAndStencil — Property, class away3d.core.managers.Stage3DProxy
enableMouseListeners(view:away3d.containers:View3D) — method, class away3d.core.managers.Mouse3DManager
enableParser(parserClass:Class) — Static Method , class away3d.library.AssetLibrary
enableParser(parserClass:Class) — method, class away3d.library.AssetLibraryBundle
enableParser(parserClass:Class) — Static Method , class away3d.loaders.AssetLoader
enableParser(parserClass:Class) — Static Method , class away3d.loaders.Loader3D
enableParser(parser:Class) — Static Method , class away3d.loaders.misc.SingleFileLoader
enableParsers(parserClasses:Vector$Class) — Static Method , class away3d.library.AssetLibrary
enableParsers(parserClasses:Vector$Class) — method, class away3d.library.AssetLibraryBundle
enableParsers(parserClasses:Vector$Class) — Static Method , class away3d.loaders.AssetLoader
enableParsers(parserClasses:Vector$Class) — Static Method , class away3d.loaders.Loader3D
enableParsers(parsers:Vector$Class) — Static Method , class away3d.loaders.misc.SingleFileLoader
end — Property, class away3d.paths.CubicPathSegment
 | The last anchor point.
end — Property, class away3d.paths.QuadraticPathSegment
 | Defines the control vector of the PathSegment
_end — Property, class away3d.primitives.data.Segment
end — Property, class away3d.primitives.data.Segment
 | Defines the ending vertex.
_endB — Property, class away3d.primitives.data.Segment
endColor — Property, class away3d.animators.states.ParticleColorState
 | Defines the end color transform of the state, when in global mode.
endColor — Property, class away3d.primitives.data.Segment
 | Defines the endColor
_endG — Property, class away3d.primitives.data.Segment
endObject() — method, class away3d.tools.serialize.SerializerBase
 | End object serialization
endObject() — method, class away3d.tools.serialize.TraceSerializer
 | End object serialization
endPoint — Property, class away3d.animators.states.ParticleBezierCurveState
 | Defines the default end point of the node, used when in global mode.
endProfile — Property, class away3d.extrusions.PathExtrude
 | returns a vector of vector3d's representing the transformed profile coordinates at the end of the extrude shape null if "keepExtremes" is false or if the extrusion has not been builded yet.
_endR — Property, class away3d.primitives.data.Segment
enterFrame — Event, class away3d.core.managers.Stage3DProxy
enterNode(node:away3d.core.partition:NodeBase) — method, class away3d.core.traverse.EntityCollector
 | Returns true if the current node is at least partly in the frustum.
enterNode(node:away3d.core.partition:NodeBase) — method, class away3d.core.traverse.PartitionTraverser
 | Called when the traversers enters a node.
_entities — Property, class away3d.core.pick.RaycastPicker
entity — Property, class away3d.core.data.EntityListItem
entity — Property, class away3d.core.partition.EntityNode
 | The entity contained in this leaf node.
entity — Property, class away3d.core.pick.PickingCollisionVO
 | The entity to which this collision object belongs.
Entity — class, package away3d.entities
 | The Entity class provides an abstract base class for all scene graph objects that are considered having a "presence" in the scene, in the sense that it can be considered an actual object with a position and a size (even if infinite or idealised), rather than a grouping.
Entity() — Constructor, class away3d.entities.Entity
 | Creates a new Entity object.
ENTITY — Constant Static Property, class away3d.library.assets.AssetType
_entityCollector — Property, class away3d.containers.View3D
EntityCollector — class, package away3d.core.traverse
 | The EntityCollector class is a traverser for scene partitions that collects all scene graph entities that are considered potientially visible.
EntityCollector() — Constructor, class away3d.core.traverse.EntityCollector
 | Creates a new EntityCollector object.
ENTITY_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
entityHead — Property, class away3d.core.traverse.EntityCollector
EntityListItem — class, package away3d.core.data
_entityListItemPool — Property, class away3d.core.traverse.EntityCollector
EntityListItemPool — class, package away3d.core.data
EntityListItemPool() — Constructor, class away3d.core.data.EntityListItemPool
EntityNode — class, package away3d.core.partition
 | The EntityNode class provides an abstract base class for leaf nodes in a partition tree, containing entities to be fed to the EntityCollector traverser.
EntityNode(entity:away3d.entities:Entity) — Constructor, class away3d.core.partition.EntityNode
 | Creates a new EntityNode object.
_entryPoint — Property, class away3d.core.traverse.PartitionTraverser
entryPoint — Property, class away3d.core.traverse.PartitionTraverser
 | The entry point for scene graph traversal, ie the point that will be used for traversing the graph position-dependently.
envMap — Property, class away3d.materials.methods.EnvMapAmbientMethod
 | The cube environment map to use for the diffuse lighting.
envMap — Property, class away3d.materials.methods.EnvMapMethod
 | The cube environment map to use for the diffuse lighting.
envMap — Property, class away3d.materials.methods.FresnelEnvMapMethod
 | The cube environment map to use for the diffuse lighting.
EnvMapAmbientMethod — class, package away3d.materials.methods
 | EnvMapDiffuseMethod provides a diffuse shading method that uses a diffuse irradiance environment map to approximate global lighting rather than lights.
EnvMapAmbientMethod(envMap:away3d.textures:CubeTextureBase) — Constructor, class away3d.materials.methods.EnvMapAmbientMethod
 | Creates a new EnvMapDiffuseMethod object.
EnvMapMethod — class, package away3d.materials.methods
EnvMapMethod(envMap:away3d.textures:CubeTextureBase, alpha:Number) — Constructor, class away3d.materials.methods.EnvMapMethod
epsilon — Property, class away3d.materials.methods.NearShadowMapMethod
_epsilon — Property, class away3d.materials.methods.ShadowMapMethodBase
epsilon — Property, class away3d.materials.methods.ShadowMapMethodBase
error(message:Object) — Static Method , class away3d.debug.Debug
error — Property, class com.adobe.utils.AGALMiniAssembler
ErrorConflictStrategy — class, package away3d.library.naming
ErrorConflictStrategy() — Constructor, class away3d.library.naming.ErrorConflictStrategy
eulers — Property, class away3d.animators.states.ParticleOrbitState
 | Defines the euler rotation in degrees, applied to the orientation of the orbit when in global mode.
eulers — Property, class away3d.core.base.Object3D
 | Defines the rotation of the 3d object as a Vector3D object containing euler angles for rotation around x, y and z axis.
executeRender(entityCollector:away3d.core.traverse:EntityCollector, target:flash.display3D.textures:TextureBase, scissorRect:flash.geom:Rectangle, surfaceSelector:int) — method, class away3d.core.render.DefaultRenderer
executeRender(entityCollector:away3d.core.traverse:EntityCollector, target:flash.display3D.textures:TextureBase, scissorRect:flash.geom:Rectangle, surfaceSelector:int) — method, class away3d.core.render.RendererBase
 | Renders the potentially visible geometry to the back buffer or texture.
executeRenderToTexturePass(entityCollector:away3d.core.traverse:EntityCollector) — method, class away3d.core.render.RendererBase
exitFrame — Event, class away3d.core.managers.Stage3DProxy
_explicitPartition — Property, class away3d.containers.ObjectContainer3D
Explode — class, package away3d.tools.commands
 | Class Explode make all vertices and uv's of a mesh unicExplode
Explode() — Constructor, class away3d.tools.commands.Explode
exposure — Property, class away3d.filters.BloomFilter3D
exposure — Property, class away3d.filters.tasks.Filter3DCompositeTask
extra — Property, class away3d.core.base.Object3D
 | An object that can contain any extra data.
extra — Property, class away3d.materials.MaterialBase
 | An object to contain any extra data
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


F

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
F Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Face — class, package away3d.core.base.data
 | Face value object.
Face(vertices:Vector$Number, uvs:Vector$Number) — Constructor, class away3d.core.base.data.Face
 | Creates a new Face value object.
FaceHelper — class, package away3d.tools.helpers
 | Helper Class for face manipulationFaceHelper
faceIndex — Property, class away3d.core.base.data.Face
 | To store a temp index of a face during a loop
faceNormals — Property, interface away3d.core.base.ISubGeometry
_faceNormals — Property, class away3d.core.base.SubGeometryBase
_faceNormalsDirty — Property, class away3d.core.base.SubGeometryBase
_faceTangents — Property, class away3d.core.base.SubGeometryBase
_faceTangentsDirty — Property, class away3d.core.base.SubGeometryBase
_faceWeights — Property, class away3d.core.base.SubGeometryBase
fadeRatio — Property, class away3d.materials.methods.NearShadowMapMethod
_fallOff — Property, class away3d.lights.PointLight
fallOff — Property, class away3d.lights.PointLight
 | The maximum distance of the light's reach
fallOffFactor() — method, class away3d.lights.PointLight
_fallOffFactor — Property, class away3d.lights.PointLight
far — Property, class away3d.cameras.lenses.FreeMatrixLens
_far — Property, class away3d.cameras.lenses.LensBase
far — Property, class away3d.cameras.lenses.LensBase
 | The distance to the far plane of the frustum.
far — Property, class away3d.cameras.lenses.ObliqueNearPlaneLens
farPlaneDistance — Property, class away3d.textures.CubeReflectionTexture
 | The far plane of the camera lens.
FAVOR_NEW — Constant Static Property, class away3d.library.naming.ConflictPrecedence
 | Signales that in a conflict, the newly renamed asset is favored (and keeps it's newly defined name) and that the previous owner of that name gets renamed to a non-conflicting name.
FAVOR_OLD — Constant Static Property, class away3d.library.naming.ConflictPrecedence
 | Signals that in a conflict, the previous owner of the conflicting name should be favored (and keep it's name) and that the newly renamed asset is reverted to a non-conflicting name.
fieldOfView — Property, class away3d.cameras.lenses.PerspectiveLens
 | The vertical field of view of the projection.
fieldOfView — Property, class away3d.entities.TextureProjector
 | The vertical field of view of the projection, or the angle of the cone.
_fileName — Property, class away3d.loaders.parsers.ParserBase
Filter3DBase — class, package away3d.filters
Filter3DBase() — Constructor, class away3d.filters.Filter3DBase
Filter3DBrightPassTask — class, package away3d.filters.tasks
Filter3DBrightPassTask(threshold:Number) — Constructor, class away3d.filters.tasks.Filter3DBrightPassTask
Filter3DCompositeTask — class, package away3d.filters.tasks
Filter3DCompositeTask(blendMode:String, exposure:Number) — Constructor, class away3d.filters.tasks.Filter3DCompositeTask
Filter3DDoubleBufferCopyTask — class, package away3d.filters.tasks
Filter3DDoubleBufferCopyTask() — Constructor, class away3d.filters.tasks.Filter3DDoubleBufferCopyTask
Filter3DHBlurTask — class, package away3d.filters.tasks
Filter3DHBlurTask(amount:uint, stepSize:int) — Constructor, class away3d.filters.tasks.Filter3DHBlurTask
 | Creates a new Filter3DHDepthOfFFieldTask
Filter3DHDepthOfFFieldTask — class, package away3d.filters.tasks
Filter3DHDepthOfFFieldTask(maxBlur:uint, stepSize:int) — Constructor, class away3d.filters.tasks.Filter3DHDepthOfFFieldTask
 | Creates a new Filter3DHDepthOfFFieldTask
Filter3DHueSaturationTask — class, package away3d.filters.tasks
Filter3DHueSaturationTask() — Constructor, class away3d.filters.tasks.Filter3DHueSaturationTask
Filter3DRadialBlurTask — class, package away3d.filters.tasks
Filter3DRadialBlurTask(intensity:Number, glowGamma:Number, blurStart:Number, blurWidth:Number, cx:Number, cy:Number) — Constructor, class away3d.filters.tasks.Filter3DRadialBlurTask
_filter3DRenderer — Property, class away3d.containers.View3D
Filter3DRenderer — class, package away3d.core.render
Filter3DRenderer(stage3DProxy:away3d.core.managers:Stage3DProxy) — Constructor, class away3d.core.render.Filter3DRenderer
Filter3DTaskBase — class, package away3d.filters.tasks
Filter3DTaskBase(requireDepthRender:Boolean) — Constructor, class away3d.filters.tasks.Filter3DTaskBase
Filter3DVBlurTask — class, package away3d.filters.tasks
Filter3DVBlurTask(amount:uint, stepSize:int) — Constructor, class away3d.filters.tasks.Filter3DVBlurTask
Filter3DVDepthOfFFieldTask — class, package away3d.filters.tasks
Filter3DVDepthOfFFieldTask(maxBlur:uint, stepSize:int) — Constructor, class away3d.filters.tasks.Filter3DVDepthOfFFieldTask
 | Creates a new Filter3DHDepthOfFFieldTask
Filter3DXFadeCompositeTask — class, package away3d.filters.tasks
Filter3DXFadeCompositeTask(amount:Number) — Constructor, class away3d.filters.tasks.Filter3DXFadeCompositeTask
FilteredShadowMapMethod — class, package away3d.materials.methods
FilteredShadowMapMethod(castingLight:away3d.lights:DirectionalLight) — Constructor, class away3d.materials.methods.FilteredShadowMapMethod
 | Creates a new BasicDiffuseMethod object.
filters — Property, class away3d.containers.View3D
 | Not supported.
filters — Property, class away3d.core.render.Filter3DRenderer
filters3d — Property, class away3d.containers.View3D
finalizeAsset(asset:away3d.library.assets:IAsset, name:String) — method, class away3d.loaders.parsers.ParserBase
findPartitionForEntity(entity:away3d.entities:Entity) — method, class away3d.core.partition.DynamicGrid
findPartitionForEntity(entity:away3d.entities:Entity) — method, class away3d.core.partition.NodeBase
 | Finds the partition that contains (or should contain) the given entity.
findPartitionForEntity(entity:away3d.entities:Entity) — method, class away3d.core.partition.OctreeNode
findPartitionForEntity(entity:away3d.entities:Entity) — method, class away3d.core.partition.QuadTreeNode
findPartitionForEntity(entity:away3d.entities:Entity) — method, class away3d.core.partition.ViewVolumeRootNode
findTempReg(exclude:Vector$String, excludeAnother:String) — method, class away3d.animators.AnimationSetBase
 | Retrieves a temporary GPU register that's still free.
finishParsing() — method, class away3d.loaders.parsers.ParserBase
 | Finish parsing the data.
fireMouseEvents() — method, class away3d.core.managers.Mouse3DManager
FirstPersonController — class, package away3d.controllers
 | Extended camera used to hover round a specified target object.
FirstPersonController(targetObject:away3d.entities:Entity, panAngle:Number, tiltAngle:Number, minTiltAngle:Number, maxTiltAngle:Number, steps:uint) — Constructor, class away3d.controllers.FirstPersonController
 | Creates a new HoverController object.
fixedFrameRate — Property, class away3d.animators.nodes.AnimationClipNodeBase
flip — Property, class away3d.extrusions.DelaunayMesh
 | Defines if the face orientation needs to be inverted
flip — Property, class away3d.extrusions.LatheExtrude
 | Defines if the generated faces should be inversed.
flip — Property, class away3d.extrusions.LinearExtrude
 | Defines if the generated faces should be inversed.
flip — Property, class away3d.extrusions.PathExtrude
 | Defines if the generated faces should be inversed.
flip — Property, class away3d.extrusions.SkinExtrude
 | Defines if the face orientatio needs to be inverted
flipHorizontal() — method, class away3d.textures.WebcamTexture
 | Flips the image from the webcam horizontally
flipVertical() — method, class away3d.textures.WebcamTexture
 | Flips the image from the webcam vertically
fly — Property, class away3d.controllers.FirstPersonController
focusDistance — Property, class away3d.filters.DepthOfFieldFilter3D
 | The distance from the camera to the point that is in focus.
focusDistance — Property, class away3d.filters.HDepthOfFieldFilter3D
focusDistance — Property, class away3d.filters.VDepthOfFieldFilter3D
focusDistance — Property, class away3d.filters.tasks.Filter3DHDepthOfFFieldTask
focusDistance — Property, class away3d.filters.tasks.Filter3DVDepthOfFFieldTask
focusTarget — Property, class away3d.filters.DepthOfFieldFilter3D
 | An optional target ObjectContainer3D that will be used to auto-focus on.
focusTarget — Property, class away3d.filters.HDepthOfFieldFilter3D
focusTarget — Property, class away3d.filters.VDepthOfFieldFilter3D
fogColor — Property, class away3d.materials.methods.FogMethod
FogMethod — class, package away3d.materials.methods
FogMethod(minDistance:Number, maxDistance:Number, fogColor:uint) — Constructor, class away3d.materials.methods.FogMethod
FollowController — class, package away3d.controllers
 | Controller used to follow behind an object on the XZ plane, with an optional elevation (tiltAngle).
FollowController(targetObject:away3d.entities:Entity, lookAtObject:away3d.containers:ObjectContainer3D, tiltAngle:Number, distance:Number) — Constructor, class away3d.controllers.FollowController
followTarget — Property, class away3d.animators.states.ParticleFollowState
forceCPU — Property, class away3d.animators.SkeletonAnimator
 | Indicates whether the skeleton animator is disabled by default for GPU rendering, something that allows the animator to perform calculation on the GPU.
forceMouseMove — Property, class away3d.containers.View3D
 | Forces mouse-move related events even when the mouse hasn't moved.
forceMouseMove — Property, class away3d.core.managers.Mouse3DManager
format — Property, class away3d.textures.ATFData
_format — Property, class away3d.textures.TextureProxyBase
format — Property, class away3d.textures.TextureProxyBase
forward — Property, class away3d.animators.nodes.SkeletonDirectionalNode
 | Defines the forward configured input node to use for the blended output.
forwardVector — Property, class away3d.core.base.Object3D
fps — Property, class away3d.debug.AwayStats
FPS — Static Property, class away3d.loaders.parsers.MD2Parser
_fragmentAnimationCode — Property, class away3d.materials.passes.CompiledPass
_fragmentCode — Property, class away3d.materials.compilation.ShaderCompiler
fragmentCode — Property, class away3d.materials.compilation.ShaderCompiler
fragmentConstantData — Property, class away3d.animators.data.AnimationRegisterCache
_fragmentConstantData — Property, class away3d.materials.compilation.ShaderCompiler
_fragmentConstantData — Property, class away3d.materials.passes.CompiledPass
_fragmentConstantOffset — Property, class away3d.materials.compilation.ShaderRegisterCache
fragmentConstantOffset — Property, class away3d.materials.compilation.ShaderRegisterCache
fragmentConstantsIndex — Property, class away3d.materials.methods.MethodVO
fragmentData — Property, class away3d.materials.methods.MethodVO
fragmentLife — Property, class away3d.animators.data.AnimationRegisterCache
_fragmentLightCode — Property, class away3d.materials.compilation.ShaderCompiler
fragmentLightCode — Property, class away3d.materials.compilation.ShaderCompiler
_fragmentLightCode — Property, class away3d.materials.passes.CompiledPass
fragmentOneConst — Property, class away3d.animators.data.AnimationRegisterCache
fragmentOutputRegister — Property, class away3d.materials.compilation.ShaderRegisterCache
 | The fragment output register.
fragmentTime — Property, class away3d.animators.data.AnimationRegisterCache
fragmentZeroConst — Property, class away3d.animators.data.AnimationRegisterCache
_frameLimit — Property, class away3d.loaders.parsers.ParserBase
_framentPostLightCode — Property, class away3d.materials.compilation.ShaderCompiler
framentPostLightCode — Property, class away3d.materials.compilation.ShaderCompiler
_framentPostLightCode — Property, class away3d.materials.passes.CompiledPass
frames — Property, class away3d.animators.nodes.SkeletonClipNode
 | Returns a vector of skeleton poses representing the pose of each animation frame in the clip.
frames — Property, class away3d.animators.nodes.UVClipNode
 | Returns a vector of UV frames representing the uv values of each animation frame in the clip.
frames — Property, class away3d.animators.nodes.VertexClipNode
 | Returns a vector of geometry frames representing the vertex values of each animation frame in the clip.
_framesDirty — Property, class away3d.animators.states.AnimationClipState
freeAll() — method, class away3d.core.data.EntityListItemPool
freeAll() — method, class away3d.core.data.RenderableListItemPool
FreeMatrixLens — class, package away3d.cameras.lenses
 | FreeMatrixLens provides a projection lens that exposes a full projection matrix, rather than provide one through more user-friendly settings.
FreeMatrixLens() — Constructor, class away3d.cameras.lenses.FreeMatrixLens
 | Creates a new FreeMatrixLens object.
freeProgram3D(programId:int) — method, class away3d.core.managers.AGALProgram3DCache
freeTexture(texture:away3d.textures:BitmapTexture) — method, class away3d.textures.BitmapTextureCache
FresnelEnvMapMethod — class, package away3d.materials.methods
FresnelEnvMapMethod(envMap:away3d.textures:CubeTextureBase, alpha:Number) — Constructor, class away3d.materials.methods.FresnelEnvMapMethod
FresnelPlanarReflectionMethod — class, package away3d.materials.methods
 | Allows the use of an additional texture to specify the alpha value of the material.
FresnelPlanarReflectionMethod(texture:away3d.textures:PlanarReflectionTexture, alpha:Number) — Constructor, class away3d.materials.methods.FresnelPlanarReflectionMethod
fresnelPower — Property, class away3d.materials.methods.FresnelEnvMapMethod
fresnelPower — Property, class away3d.materials.methods.FresnelPlanarReflectionMethod
fresnelPower — Property, class away3d.materials.methods.FresnelSpecularMethod
FresnelSpecularMethod — class, package away3d.materials.methods
 | FresnelSpecularMethod provides a specular shading method that is stronger on shallow view angles.
FresnelSpecularMethod(basedOnSurface:Boolean, baseSpecularMethod:away3d.materials.methods:BasicSpecularMethod) — Constructor, class away3d.materials.methods.FresnelSpecularMethod
 | Creates a new FresnelSpecularMethod object.
fromAxisAngle(axis:flash.geom:Vector3D, angle:Number) — method, class away3d.core.math.Quaternion
 | Fills the quaternion object with values representing the given rotation around a vector.
fromEulerAngles(ax:Number, ay:Number, az:Number) — method, class away3d.core.math.Quaternion
 | Fills the quaternion object with values representing the given euler rotation.
fromExtremes(minX:Number, minY:Number, minZ:Number, maxX:Number, maxY:Number, maxZ:Number) — method, class away3d.bounds.AxisAlignedBoundingBox
 | Sets the bounds to the given extrema.
fromExtremes(minX:Number, minY:Number, minZ:Number, maxX:Number, maxY:Number, maxZ:Number) — method, class away3d.bounds.BoundingSphere
 | Sets the bounds to the given extrema.
fromExtremes(minX:Number, minY:Number, minZ:Number, maxX:Number, maxY:Number, maxZ:Number) — method, class away3d.bounds.BoundingVolumeBase
 | Sets the bounds to the given extrema.
fromExtremes(minX:Number, minY:Number, minZ:Number, maxX:Number, maxY:Number, maxZ:Number) — method, class away3d.bounds.NullBounds
 | Sets the bounds to the given extrema.
fromGeometry(geometry:away3d.core.base:Geometry) — method, class away3d.bounds.BoundingVolumeBase
 | Updates the bounds to fit a Geometry object.
fromGeometry(geometry:away3d.core.base:Geometry) — method, class away3d.bounds.NullBounds
 | Updates the bounds to fit a Geometry object.
fromMatrix(matrix:flash.geom:Matrix3D) — method, class away3d.core.math.Quaternion
 | Extracts a quaternion rotation matrix out of a given Matrix3D object.
fromNormalAndPoint(normal:flash.geom:Vector3D, point:flash.geom:Vector3D) — method, class away3d.core.math.Plane3D
 | Fills this Plane3D with the coefficients from the plane's normal and a point in 3d space.
fromPoints(p0:flash.geom:Vector3D, p1:flash.geom:Vector3D, p2:flash.geom:Vector3D) — method, class away3d.core.math.Plane3D
 | Fills this Plane3D with the coefficients from 3 points in 3d space.
fromSphere(center:flash.geom:Vector3D, radius:Number) — method, class away3d.bounds.BoundingSphere
 | Sets the bound to fit a given sphere.
fromSphere(center:flash.geom:Vector3D, radius:Number) — method, class away3d.bounds.BoundingVolumeBase
 | Sets the bound to fit a given sphere.
fromSphere(center:flash.geom:Vector3D, radius:Number) — method, class away3d.bounds.NullBounds
 | Sets the bound to fit a given sphere.
fromVectors(verts:Vector$Number, uvs:Vector$Number, normals:Vector$Number, tangents:Vector$Number) — method, class away3d.core.base.CompactSubGeometry
fromVectors(vertices:Vector$Number, uvs:Vector$Number, normals:Vector$Number, tangents:Vector$Number) — method, interface away3d.core.base.ISubGeometry
fromVectors(vertices:Vector$Number, uvs:Vector$Number, normals:Vector$Number, tangents:Vector$Number) — method, class away3d.core.base.SubGeometry
fromVectors(verts:Vector$Number, indices:Vector$uint, uvs:Vector$Number, normals:Vector$Number, tangents:Vector$Number, weights:Vector$Number, jointIndices:Vector$Number) — Static Method , class away3d.tools.utils.GeomUtil
 | Build a list of sub-geometries from raw data vectors, splitting them up in such a way that they won't exceed buffer length limits.
fromVertices(vertices:Vector$Number) — method, class away3d.bounds.BoundingVolumeBase
 | Updates the bounds to fit a list of vertices
front — Property, class away3d.materials.utils.MultipleMaterials
 | Defines the material applied to the front side of the cube.
FRONT — Constant Static Property, class away3d.core.math.PlaneClassification
FRONT — Constant Static Property, class away3d.tools.utils.Projector
FRONT_VECTOR — Constant Static Property, class away3d.materials.passes.SegmentPass
_frustumCorners — Property, class away3d.cameras.lenses.LensBase
frustumCorners — Property, class away3d.cameras.lenses.LensBase
 | Retrieves the corner points of the lens frustum.
frustumCorners — Property, class away3d.cameras.lenses.ObliqueNearPlaneLens
frustumPlanes — Property, class away3d.cameras.Camera3D
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


G

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
G Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
g — Property, class away3d.filters.HueSaturationFilter3D
g — Property, class away3d.filters.tasks.Filter3DHueSaturationTask
generateDifferenceClip(source:away3d.animators.nodes:SkeletonClipNode, referencePose:away3d.animators.data:SkeletonPose) — Static Method , class away3d.animators.utils.SkeletonUtils
generateDifferencePose(source:away3d.animators.data:SkeletonPose, reference:away3d.animators.data:SkeletonPose) — Static Method , class away3d.animators.utils.SkeletonUtils
generateGeometry(geometries:Vector$away3d.core.base:Geometry, transforms:Vector$away3d.tools.helpers.data:ParticleGeometryTransform) — Static Method , class away3d.tools.helpers.ParticleGeometryHelper
generateMip(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.methods.BasicDiffuseMethod
generateMipMaps(source:flash.display:BitmapData, target:flash.display3D.textures:TextureBase, mipmap:flash.display:BitmapData, alpha:Boolean, side:int) — Static Method , class away3d.materials.utils.MipmapGenerator
 | Uploads a BitmapData with mip maps to a target Texture object.
generatePropertyOfOneParticle(param:away3d.animators.data:ParticleProperties) — method, class away3d.animators.nodes.ParticleAccelerationNode
 | Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.
generatePropertyOfOneParticle(param:away3d.animators.data:ParticleProperties) — method, class away3d.animators.nodes.ParticleBezierCurveNode
 | Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.
generatePropertyOfOneParticle(param:away3d.animators.data:ParticleProperties) — method, class away3d.animators.nodes.ParticleColorNode
 | Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.
generatePropertyOfOneParticle(param:away3d.animators.data:ParticleProperties) — method, class away3d.animators.nodes.ParticleNodeBase
 | Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.
generatePropertyOfOneParticle(param:away3d.animators.data:ParticleProperties) — method, class away3d.animators.nodes.ParticleOrbitNode
 | Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.
generatePropertyOfOneParticle(param:away3d.animators.data:ParticleProperties) — method, class away3d.animators.nodes.ParticleOscillatorNode
 | Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.
generatePropertyOfOneParticle(param:away3d.animators.data:ParticleProperties) — method, class away3d.animators.nodes.ParticlePositionNode
 | Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.
generatePropertyOfOneParticle(param:away3d.animators.data:ParticleProperties) — method, class away3d.animators.nodes.ParticleRotationalVelocityNode
 | Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.
generatePropertyOfOneParticle(param:away3d.animators.data:ParticleProperties) — method, class away3d.animators.nodes.ParticleScaleNode
 | Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.
generatePropertyOfOneParticle(param:away3d.animators.data:ParticleProperties) — method, class away3d.animators.nodes.ParticleSpriteSheetNode
 | Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.
generatePropertyOfOneParticle(param:away3d.animators.data:ParticleProperties) — method, class away3d.animators.nodes.ParticleTimeNode
 | Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.
generatePropertyOfOneParticle(param:away3d.animators.data:ParticleProperties) — method, class away3d.animators.nodes.ParticleVelocityNode
 | Called internally by the particle animation set when assigning the set of static properties originally defined by the initParticleFunc of the set.
generateSmoothedHeightMap() — method, class away3d.extrusions.Elevation
 | Generates a smoother representation of the geometry using the original heightmap and subdivision settings.
generateSolidMap(mesh:away3d.entities:Mesh, lineColor:uint, lineThickness:Number, fillColor:uint, fillAlpha:Number, width:uint, height:uint) — Static Method , class away3d.materials.utils.WireframeMapGenerator
 | Create a wireframe map with a solid colour fill.
generateTexturedMap(mesh:away3d.entities:Mesh, bitmapData:flash.display:BitmapData, lineColor:uint, lineThickness:Number) — Static Method , class away3d.materials.utils.WireframeMapGenerator
 | Create a wireframe map with a texture fill.
_geomDirty — Property, class away3d.extrusions.Elevation
_geomDirty — Property, class away3d.primitives.PrimitiveBase
geometries — Property, class away3d.loaders.parsers.DAEParser
_geometry — Property, class away3d.entities.Mesh
geometry — Property, class away3d.entities.Mesh
 | The geometry used by the mesh that provides it with its shape.
geometry — Property, class away3d.extrusions.DelaunayMesh
 | The geometry used by the mesh that provides it with its shape.
geometry — Property, class away3d.extrusions.LatheExtrude
 | The geometry used by the mesh that provides it with its shape.
geometry — Property, class away3d.extrusions.LinearExtrude
 | The geometry used by the mesh that provides it with its shape.
geometry — Property, class away3d.extrusions.PathExtrude
 | The geometry used by the mesh that provides it with its shape.
geometry — Property, class away3d.extrusions.SkinExtrude
 | The geometry used by the mesh that provides it with its shape.
Geometry — class, package away3d.core.base
 | Geometry is a collection of SubGeometries, each of which contain the actual geometrical data such as vertices, normals, uvs, etc.
Geometry() — Constructor, class away3d.core.base.Geometry
 | Creates a new Geometry object.
GEOMETRY — Constant Static Property, class away3d.library.assets.AssetType
geometryComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when a geometry asset has been constructed from a resource.
geometryComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when a geometry asset has been constructed from a resource.
geometryComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when a geometry asset has been constructed from a resource.
geometryComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when a geometry asset has been constructed from a resource.
geometryComplete — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when a geometry asset has been constructed from a resource.
geometryComplete — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when a geometry asset has been constructed from a resource.
GEOMETRY_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
GeometryEvent — class, package away3d.events
 | Dispatched to notify changes in a geometry object's state.
GeometryEvent(type:String, subGeometry:away3d.core.base:ISubGeometry) — Constructor, class away3d.events.GeometryEvent
 | Create a new GeometryEvent
GeometryUtil — class, package away3d.utils
GeomUtil — class, package away3d.tools.utils
getAGALFragmentCode(pass:away3d.materials.passes:MaterialPassBase, shadedTarget:String) — method, class away3d.animators.ParticleAnimationSet
getAGALFragmentCode(pass:away3d.materials.passes:MaterialPassBase, shadedTarget:String) — method, class away3d.animators.SkeletonAnimationSet
getAGALFragmentCode(pass:away3d.materials.passes:MaterialPassBase, shadedTarget:String) — method, class away3d.animators.UVAnimationSet
getAGALFragmentCode(pass:away3d.materials.passes:MaterialPassBase, shadedTarget:String) — method, class away3d.animators.VertexAnimationSet
getAGALFragmentCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleColorNode
 | Returns the AGAL code of the particle animation node for use in the fragment shader.
getAGALFragmentCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleNodeBase
 | Returns the AGAL code of the particle animation node for use in the fragment shader.
getAGALUVCode(pass:away3d.materials.passes:MaterialPassBase, UVSource:String, UVTarget:String) — method, class away3d.animators.ParticleAnimationSet
getAGALUVCode(pass:away3d.materials.passes:MaterialPassBase, UVSource:String, UVTarget:String) — method, class away3d.animators.SkeletonAnimationSet
getAGALUVCode(pass:away3d.materials.passes:MaterialPassBase, UVSource:String, UVTarget:String) — method, class away3d.animators.UVAnimationSet
getAGALUVCode(pass:away3d.materials.passes:MaterialPassBase, UVSource:String, UVTarget:String) — method, class away3d.animators.VertexAnimationSet
getAGALUVCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleNodeBase
 | Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required.
getAGALUVCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleSpriteSheetNode
 | Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required.
getAGALUVCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleUVNode
 | Returns the AGAL code of the particle animation node for use in the fragment shader when UV coordinates are required.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, sourceRegisters:Vector$String, targetRegisters:Vector$String) — method, class away3d.animators.ParticleAnimationSet
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, sourceRegisters:Vector$String, targetRegisters:Vector$String) — method, class away3d.animators.SkeletonAnimationSet
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, sourceRegisters:Vector$String, targetRegisters:Vector$String) — method, class away3d.animators.UVAnimationSet
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, sourceRegisters:Vector$String, targetRegisters:Vector$String) — method, class away3d.animators.VertexAnimationSet
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleAccelerationNode
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleBezierCurveNode
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleBillboardNode
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleColorNode
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleFollowNode
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleNodeBase
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleOrbitNode
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleOscillatorNode
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticlePositionNode
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleRotateToHeadingNode
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleRotationalVelocityNode
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleScaleNode
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleTimeNode
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAGALVertexCode(pass:away3d.materials.passes:MaterialPassBase, animationRegisterCache:away3d.animators.data:AnimationRegisterCache) — method, class away3d.animators.nodes.ParticleVelocityNode
 | Returns the AGAL code of the particle animation node for use in the vertex shader.
getAngle(w:flash.geom:Vector3D, q:flash.geom:Vector3D) — Static Method , class away3d.core.math.Vector3DUtils
 | Returns the angle in radians made between the 3d number obejct and the given Vector3D object.
getAnimation(name:String) — method, class away3d.animators.AnimationSetBase
 | Retrieves the animation state object registered in the animation data set under the given name.
getAnimation(name:String) — method, interface away3d.animators.IAnimationSet
 | Retrieves the animation state object registered in the animation data set under the given name.
getAnimationNode(animator:away3d.animators:IAnimator, startNode:away3d.animators.nodes:AnimationNodeBase, endNode:away3d.animators.nodes:AnimationNodeBase, startBlend:int) — method, class away3d.animators.transitions.CrossfadeTransition
getAnimationNode(animator:away3d.animators:IAnimator, startNode:away3d.animators.nodes:AnimationNodeBase, endNode:away3d.animators.nodes:AnimationNodeBase, startTime:int) — method, interface away3d.animators.transitions.IAnimationTransition
getAnimationState(node:away3d.animators.nodes:AnimationNodeBase) — method, class away3d.animators.AnimatorBase
getAnimationState(node:away3d.animators.nodes:AnimationNodeBase) — method, interface away3d.animators.IAnimator
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleAccelerationNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleBezierCurveNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleBillboardNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleColorNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleFollowNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleOrbitNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleOscillatorNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticlePositionNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleRotateToHeadingNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleRotationalVelocityNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleScaleNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleSpriteSheetNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleTimeNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleUVNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.ParticleVelocityNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.SkeletonBinaryLERPNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.SkeletonClipNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.SkeletonDifferenceNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.SkeletonDirectionalNode
getAnimationState(animator:away3d.animators:IAnimator) — method, class away3d.animators.nodes.SkeletonNaryLERPNode
getAnimationStateByName(name:String) — method, class away3d.animators.AnimatorBase
getAnimationStateByName(name:String) — method, interface away3d.animators.IAnimator
getAsset(name:String, ns:String) — Static Method , class away3d.library.AssetLibrary
 | Short-hand for getAsset() method on default asset library bundle.
getAsset(name:String, ns:String) — method, class away3d.library.AssetLibraryBundle
getBarycentricCoords(point:flash.geom:Vector3D, target:flash.geom:Point) — method, class away3d.core.base.data.Face
 | Returns the first two barycentric coordinates for a point on (or outside) the triangle.
getBestPowerOf2(value:uint) — Static Method , class away3d.tools.utils.TextureUtils
getBlendWeightAt(index:uint) — method, class away3d.animators.states.SkeletonNaryLERPState
 | Returns the blend weight of the skeleton aniamtion node that resides at the given input index.
getBundle(key:String) — Static Method , class away3d.library.AssetLibrary
 | Returns an AssetLibrary bundle instance.
getByteData() — method, class away3d.loaders.parsers.ParserBase
getCascadeFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, decodeRegister:away3d.materials.compilation:ShaderRegisterElement, depthTexture:away3d.materials.compilation:ShaderRegisterElement, depthProjection:away3d.materials.compilation:ShaderRegisterElement, targetRegister:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.DitheredShadowMapMethod
getCascadeFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, decodeRegister:away3d.materials.compilation:ShaderRegisterElement, depthTexture:away3d.materials.compilation:ShaderRegisterElement, depthProjection:away3d.materials.compilation:ShaderRegisterElement, targetRegister:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.FilteredShadowMapMethod
getCascadeFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, decodeRegister:away3d.materials.compilation:ShaderRegisterElement, depthTexture:away3d.materials.compilation:ShaderRegisterElement, depthProjection:away3d.materials.compilation:ShaderRegisterElement, targetRegister:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.HardShadowMapMethod
getCascadeFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, decodeRegister:away3d.materials.compilation:ShaderRegisterElement, depthTexture:away3d.materials.compilation:ShaderRegisterElement, depthProjection:away3d.materials.compilation:ShaderRegisterElement, targetRegister:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.SimpleShadowMapMethodBase
getCascadeFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, decodeRegister:away3d.materials.compilation:ShaderRegisterElement, depthTexture:away3d.materials.compilation:ShaderRegisterElement, depthProjection:away3d.materials.compilation:ShaderRegisterElement, targetRegister:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.SoftShadowMapMethod
getCellAt(x:uint, y:uint, z:uint) — method, class away3d.core.partition.DynamicGrid
getCellsIntersecting(minBounds:flash.geom:Vector3D, maxBounds:flash.geom:Vector3D) — method, class away3d.core.partition.DynamicGrid
getChildAt(index:uint) — method, class away3d.containers.ObjectContainer3D
 | Retrieves the child object at the given index.
getChildAt(index:uint) — method, class away3d.containers.Scene3D
 | Retrieves the child with the given index
getCollisionNormal(indexData:Vector$uint, vertexData:Vector$Number, triangleIndex:uint) — method, class away3d.core.pick.PickingColliderBase
getCollisionUV(indexData:Vector$uint, uvData:Vector$Number, triangleIndex:uint, v:Number, w:Number, u:Number, uvOffset:uint, uvStride:uint) — method, class away3d.core.pick.PickingColliderBase
getColorAt(x:Number, y:Number) — method, class away3d.tools.utils.ColorHitMap
 | returns the color at x,y coordinates.
getCombinationCode() — method, class away3d.animators.data.AnimationRegisterCache
getDefaultBoundingVolume() — method, class away3d.entities.Entity
 | Creates the default bounding box to be used by this type of Entity.
getDefaultBoundingVolume() — method, class away3d.entities.SegmentSet
getDefaultBoundingVolume() — method, class away3d.entities.Sprite3D
getDefaultBoundingVolume() — method, class away3d.lights.DirectionalLight
 | Creates the default bounding box to be used by this type of Entity.
getDefaultBoundingVolume() — method, class away3d.lights.LightProbe
 | Creates the default bounding box to be used by this type of Entity.
getDefaultBoundingVolume() — method, class away3d.lights.PointLight
 | Creates the default bounding box to be used by this type of Entity.
getDefaultMaterial(renderable:away3d.core.base:IMaterialOwner) — Static Method , class away3d.materials.utils.DefaultMaterialManager
getDefaultTexture(renderable:away3d.core.base:IMaterialOwner) — Static Method , class away3d.materials.utils.DefaultMaterialManager
getDepthMap(renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.passes.SingleObjectDepthPass
 | Gets the depth maps rendered for this object from all lights.
getDepthProjections(partition:uint) — method, class away3d.lights.shadowmaps.CascadeShadowMapper
getEntityPartitionNode() — method, class away3d.entities.Entity
 | Gets a concrete EntityPartition3DNode subclass that is associated with this Entity instance
getForward(m:flash.geom:Matrix3D, v:flash.geom:Vector3D) — Static Method , class away3d.core.math.Matrix3DUtils
 | Returns a normalised Vector3D object representing the forward vector of the given matrix.
getFragmentCode() — method, class away3d.filters.tasks.Filter3DBrightPassTask
getFragmentCode() — method, class away3d.filters.tasks.Filter3DCompositeTask
getFragmentCode() — method, class away3d.filters.tasks.Filter3DDoubleBufferCopyTask
getFragmentCode() — method, class away3d.filters.tasks.Filter3DHBlurTask
getFragmentCode() — method, class away3d.filters.tasks.Filter3DHDepthOfFFieldTask
getFragmentCode() — method, class away3d.filters.tasks.Filter3DHueSaturationTask
getFragmentCode() — method, class away3d.filters.tasks.Filter3DRadialBlurTask
getFragmentCode() — method, class away3d.filters.tasks.Filter3DTaskBase
getFragmentCode() — method, class away3d.filters.tasks.Filter3DVBlurTask
getFragmentCode() — method, class away3d.filters.tasks.Filter3DVDepthOfFFieldTask
getFragmentCode() — method, class away3d.filters.tasks.Filter3DXFadeCompositeTask
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.AlphaMaskMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.BasicAmbientMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.BasicNormalMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.CascadeShadowMapMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.ColorMatrixMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.ColorTransformMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.EnvMapAmbientMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.EnvMapMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.FogMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.FresnelEnvMapMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.FresnelPlanarReflectionMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.HeightMapNormalMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.LightMapMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.NearShadowMapMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.OutlineMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.PlanarReflectionMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.ProjectiveTextureMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.RefractionEnvMapMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.RimLightMethod
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.ShadowMapMethodBase
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.SimpleShadowMapMethodBase
getFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.SimpleWaterNormalMethod
getFragmentCode(animatorCode:String) — method, class away3d.materials.passes.CompiledPass
getFragmentCode(code:String) — method, class away3d.materials.passes.DepthMapPass
getFragmentCode(animationCode:String) — method, class away3d.materials.passes.DistanceMapPass
getFragmentCode(code:String) — method, class away3d.materials.passes.MaterialPassBase
getFragmentCode(animationCode:String) — method, class away3d.materials.passes.OutlinePass
getFragmentCode(animationCode:String) — method, class away3d.materials.passes.SegmentPass
getFragmentCode(animationCode:String) — method, class away3d.materials.passes.SingleObjectDepthPass
getFragmentCode(animationCode:String) — method, class away3d.materials.passes.SkyBoxPass
getFragmentCode() — method, class away3d.stereo.methods.AnaglyphStereoRenderMethod
getFragmentCode() — method, class away3d.stereo.methods.InterleavedStereoRenderMethod
getFragmentCode() — method, class away3d.stereo.methods.StereoRenderMethodBase
getFragmentCodePerLight(vo:away3d.materials.methods:MethodVO, lightDirReg:away3d.materials.compilation:ShaderRegisterElement, lightColReg:away3d.materials.compilation:ShaderRegisterElement, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.AnisotropicSpecularMethod
getFragmentCodePerLight(vo:away3d.materials.methods:MethodVO, lightDirReg:away3d.materials.compilation:ShaderRegisterElement, lightColReg:away3d.materials.compilation:ShaderRegisterElement, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.BasicDiffuseMethod
 | Get the fragment shader code that will generate the code relevant to a single light.
getFragmentCodePerLight(vo:away3d.materials.methods:MethodVO, lightDirReg:away3d.materials.compilation:ShaderRegisterElement, lightColReg:away3d.materials.compilation:ShaderRegisterElement, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.BasicSpecularMethod
 | Get the fragment shader code that will generate the code relevant to a single light.
getFragmentCodePerLight(vo:away3d.materials.methods:MethodVO, lightDirReg:away3d.materials.compilation:ShaderRegisterElement, lightColReg:away3d.materials.compilation:ShaderRegisterElement, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.CompositeDiffuseMethod
 | Get the fragment shader code that will generate the code relevant to a single light.
getFragmentCodePerLight(vo:away3d.materials.methods:MethodVO, lightDirReg:away3d.materials.compilation:ShaderRegisterElement, lightColReg:away3d.materials.compilation:ShaderRegisterElement, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.CompositeSpecularMethod
 | Get the fragment shader code that will generate the code relevant to a single light.
getFragmentCodePerLight(vo:away3d.materials.methods:MethodVO, lightDirReg:away3d.materials.compilation:ShaderRegisterElement, lightColReg:away3d.materials.compilation:ShaderRegisterElement, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.LightingMethodBase
 | Get the fragment shader code that will generate the code relevant to a single light.
getFragmentCodePerLight(vo:away3d.materials.methods:MethodVO, lightDirReg:away3d.materials.compilation:ShaderRegisterElement, lightColReg:away3d.materials.compilation:ShaderRegisterElement, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.SubsurfaceScatteringDiffuseMethod
 | Get the fragment shader code that will generate the code relevant to a single light.
getFragmentCodePerLight(vo:away3d.materials.methods:MethodVO, lightDirReg:away3d.materials.compilation:ShaderRegisterElement, lightColReg:away3d.materials.compilation:ShaderRegisterElement, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.WrapDiffuseMethod
getFragmentCodePerProbe(vo:away3d.materials.methods:MethodVO, cubeMapReg:away3d.materials.compilation:ShaderRegisterElement, weightRegister:String, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.BasicDiffuseMethod
 | Get the fragment shader code that will generate the code relevant to a single light probe object.
getFragmentCodePerProbe(vo:away3d.materials.methods:MethodVO, cubeMapReg:away3d.materials.compilation:ShaderRegisterElement, weightRegister:String, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.BasicSpecularMethod
 | Get the fragment shader code that will generate the code relevant to a single light probe object.
getFragmentCodePerProbe(vo:away3d.materials.methods:MethodVO, cubeMapReg:away3d.materials.compilation:ShaderRegisterElement, weightRegister:String, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.CompositeDiffuseMethod
 | Get the fragment shader code that will generate the code relevant to a single light probe object.
getFragmentCodePerProbe(vo:away3d.materials.methods:MethodVO, cubeMapReg:away3d.materials.compilation:ShaderRegisterElement, weightRegister:String, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.CompositeSpecularMethod
 | Get the fragment shader code that will generate the code relevant to a single light probe object.
getFragmentCodePerProbe(vo:away3d.materials.methods:MethodVO, cubeMapReg:away3d.materials.compilation:ShaderRegisterElement, weightRegister:String, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.LightingMethodBase
 | Get the fragment shader code that will generate the code relevant to a single light probe object.
getFragmentPostLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.BasicDiffuseMethod
getFragmentPostLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.BasicSpecularMethod
getFragmentPostLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.CompositeDiffuseMethod
getFragmentPostLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.CompositeSpecularMethod
getFragmentPostLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.DepthDiffuseMethod
getFragmentPostLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.LightMapDiffuseMethod
getFragmentPostLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.SubsurfaceScatteringDiffuseMethod
getFragmentPostLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.TerrainDiffuseMethod
getFragmentPreLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.AnisotropicSpecularMethod
getFragmentPreLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.BasicDiffuseMethod
getFragmentPreLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.BasicSpecularMethod
getFragmentPreLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.CelDiffuseMethod
getFragmentPreLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.CelSpecularMethod
getFragmentPreLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.CompositeDiffuseMethod
getFragmentPreLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.CompositeSpecularMethod
getFragmentPreLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.FresnelSpecularMethod
getFragmentPreLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.SubsurfaceScatteringDiffuseMethod
getFragmentPreLightingCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.WrapDiffuseMethod
getFreeFragmentConstant() — method, class away3d.materials.compilation.ShaderRegisterCache
 | Retrieve an available fragment constant register
getFreeFragmentSingleTemp() — method, class away3d.materials.compilation.ShaderRegisterCache
 | Retrieve a single component from a fragment temporary register that's still available.
getFreeFragmentVectorTemp() — method, class away3d.materials.compilation.ShaderRegisterCache
 | Retrieve an entire fragment temporary register that's still available.
getFreeStage3DProxy(forceSoftware:Boolean) — method, class away3d.core.managers.Stage3DManager
 | Get the next available stage3DProxy.
getFreeTextureReg() — method, class away3d.materials.compilation.ShaderRegisterCache
 | Retrieve an available texture register
getFreeVarying() — method, class away3d.materials.compilation.ShaderRegisterCache
 | Retrieve an available varying register
getFreeVertexAttribute() — method, class away3d.materials.compilation.ShaderRegisterCache
 | Retrieve an available vertex attribute register
getFreeVertexConstant() — method, class away3d.materials.compilation.ShaderRegisterCache
 | Retrieve an available vertex constant register
getFreeVertexSingleTemp() — method, class away3d.materials.compilation.ShaderRegisterCache
 | Retrieve a single component from a vertex temporary register that's still available.
getFreeVertexVectorTemp() — method, class away3d.materials.compilation.ShaderRegisterCache
 | Retrieve an entire vertex temporary register that's still available.
getGeometryByName(name:String, clone:Boolean) — method, class away3d.loaders.parsers.DAEParser
getHeightAt(x:Number, z:Number) — method, class away3d.extrusions.Elevation
 | Reading the terrain height from a given x z position for surface tracking purposes
getIndexBuffer(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, interface away3d.core.base.IRenderable
 | Retrieves the IndexBuffer3D object that contains triangle indices.
getIndexBuffer(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, interface away3d.core.base.ISubGeometry
 | Retrieves the IndexBuffer3D object that contains triangle indices.
getIndexBuffer(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SubGeometryBase
 | Retrieves the VertexBuffer3D object that contains triangle indices.
getIndexBuffer(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.base.SubMesh
 | Retrieves the IndexBuffer3D object that contains triangle indices.
getIndexBuffer(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.entities.SegmentSet
getIndexBuffer(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.entities.Sprite3D
getIndexBuffer(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.primitives.SkyBox
 | Retrieves the IndexBuffer3D object that contains triangle indices.
getInitCode() — method, class away3d.animators.data.AnimationRegisterCache
getInputAt(index:uint) — method, class away3d.animators.nodes.SkeletonNaryLERPNode
 | Returns the skeleton animation node object that resides at the given input index.
getInputIndex(input:away3d.animators.nodes:AnimationNodeBase) — method, class away3d.animators.nodes.SkeletonNaryLERPNode
 | Returns an integer representing the input index of the given skeleton animation node.
getInstance(stage3DProxy:away3d.core.managers:Stage3DProxy) — Static Method , class away3d.core.managers.AGALProgram3DCache
getInstance(stage3DProxy:away3d.core.managers:Stage3DProxy) — Static Method , class away3d.core.managers.RTTBufferManager
getInstance(stage:flash.display:Stage) — Static Method , class away3d.core.managers.Stage3DManager
 | Gets a Stage3DManager instance for the given Stage object.
getInstance(key:String) — Static Method , class away3d.library.AssetLibraryBundle
 | Returns an AssetLibraryBundle instance.
getInstance() — Static Method , class away3d.textures.BitmapTextureCache
getInstanceFromIndex(index:int) — Static Method , class away3d.core.managers.AGALProgram3DCache
getIntersect(x:Number, y:Number) — method, class away3d.tools.utils.Drag3D
 | Returns the Vector3D where mouse to scene ray hits the plane set for the class.
getItem() — method, class away3d.core.data.EntityListItemPool
getItem() — method, class away3d.core.data.RenderableListItemPool
getLeftInputTexture(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.stereo.StereoRenderer
getMainInputTexture(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.core.render.Filter3DRenderer
getMainInputTexture(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.Filter3DBase
getMainInputTexture(stage:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DTaskBase
getMeshBounds(mesh:away3d.entities:Mesh) — Static Method , class away3d.tools.utils.Bounds
 | Calculate the bounds of a Mesh object
getMethodAt(index:int) — method, class away3d.materials.MultiPassMaterialBase
getMethodAt(index:int) — method, class away3d.materials.SinglePassMaterialBase
getMethodAt(index:int) — method, class away3d.materials.methods.ShaderMethodSetup
getMethodAt(index:int) — method, class away3d.materials.passes.SuperShaderPass
getObjectContainerBounds(container:away3d.containers:ObjectContainer3D) — Static Method , class away3d.tools.utils.Bounds
 | Calculate the bounds of an ObjectContainer3D object
getObjectProjectionMatrix(renderable:away3d.core.base:IRenderable, target:flash.geom:Matrix3D) — method, class away3d.lights.DirectionalLight
 | Gets the optimal projection matrix to render a light-based depth map for a single object.
getObjectProjectionMatrix(renderable:away3d.core.base:IRenderable, target:flash.geom:Matrix3D) — method, class away3d.lights.LightBase
 | Gets the optimal projection matrix to render a light-based depth map for a single object.
getObjectProjectionMatrix(renderable:away3d.core.base:IRenderable, target:flash.geom:Matrix3D) — method, class away3d.lights.LightProbe
 | Gets the optimal projection matrix to render a light-based depth map for a single object.
getObjectProjectionMatrix(renderable:away3d.core.base:IRenderable, target:flash.geom:Matrix3D) — method, class away3d.lights.PointLight
 | Gets the optimal projection matrix to render a light-based depth map for a single object.
getPlanarFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.DitheredShadowMapMethod
getPlanarFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.FilteredShadowMapMethod
getPlanarFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.HardShadowMapMethod
getPlanarFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.SimpleShadowMapMethodBase
getPlanarFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.SoftShadowMapMethod
getPlanarFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.TripleFilteredShadowMapMethod
getPlanarVertexCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.SimpleShadowMapMethodBase
getPointFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.HardShadowMapMethod
getPointFragmentCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache, targetReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.SimpleShadowMapMethodBase
getPointOnCurve(t:Number, target:flash.geom:Vector3D) — method, interface away3d.paths.IPath
 | Gets a point on the curve
getPointOnCurve(t:Number, target:flash.geom:Vector3D) — method, class away3d.paths.SegmentedPathBase
getPointOnSegment(phase:Number, target:flash.geom:Vector3D) — method, class away3d.paths.CubicPathSegment
getPointOnSegment(phase:Number, target:flash.geom:Vector3D) — method, interface away3d.paths.IPathSegment
 | Calculates the position of the curve on this segment.
getPointOnSegment(t:Number, target:flash.geom:Vector3D) — method, class away3d.paths.QuadraticPathSegment
getPointsOnCurvePerSegment(numSegments:uint) — method, interface away3d.paths.IPath
 | Discretizes the segment into a set of sample points.
getPointsOnCurvePerSegment(subdivision:uint) — method, class away3d.paths.SegmentedPathBase
getPointVertexCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.SimpleShadowMapMethodBase
getPositionOnPath(t:Number, out:flash.geom:Vector3D) — method, class away3d.animators.PathAnimator
 | Updates a position Vector3D on the path at a given time.
getPositionOnPathMS(ms:Number, duration:Number, out:flash.geom:Vector3D) — method, class away3d.animators.PathAnimator
 | Returns a position on the path according to duration/elapsed time.
getPositions() — method, class away3d.animators.states.ParticlePositionState
getProgram3D(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DTaskBase
getProjection(renderable:away3d.core.base:IRenderable) — method, class away3d.materials.passes.SingleObjectDepthPass
 | Retrieves the depth map projection maps for all lights.
getRay(mX:Number, mY:Number, mZ:Number) — method, class away3d.cameras.Camera3D
 | Returns the ray in scene space from the camera to the point on the screen in normalized coordinates.
getRay(mX:Number, mY:Number, mZ:Number) — method, class away3d.containers.View3D
 | Returns the ray in scene space from the camera to the point on the screen.
getRayToSphereIntersection(pOrig:flash.geom:Vector3D, dir:flash.geom:Vector3D, sPos:flash.geom:Vector3D, radius:Number, bNearest:Boolean, bNormal:Boolean, outVector3D:flash.geom:Vector3D) — method, class away3d.tools.utils.Ray
 | Returns a Vector3D where the ray intersects a sphere.
getRayToTriangleIntersection(p0:flash.geom:Vector3D, p1:flash.geom:Vector3D, v0:flash.geom:Vector3D, v1:flash.geom:Vector3D, v2:flash.geom:Vector3D, outVector3D:flash.geom:Vector3D) — method, class away3d.tools.utils.Ray
 | Returns a Vector3D where the ray intersects a plane inside a triangle Returns null if no hit is found.
getRegisterIndex(node:away3d.animators.nodes:AnimationNodeBase, parameterIndex:int) — method, class away3d.animators.data.AnimationRegisterCache
getRight(m:flash.geom:Matrix3D, v:flash.geom:Vector3D) — Static Method , class away3d.core.math.Matrix3DUtils
 | Returns a normalised Vector3D object representing the right vector of the given matrix.
getRightInputTexture(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.stereo.StereoRenderer
getRotationalVelocities() — method, class away3d.animators.states.ParticleRotationalVelocityState
getSceneCollision(position:flash.geom:Vector3D, direction:flash.geom:Vector3D, scene:away3d.containers:Scene3D) — method, interface away3d.core.pick.IPicker
 | Gets the collision object from the scene position and direction of the picking ray.
getSceneCollision(position:flash.geom:Vector3D, direction:flash.geom:Vector3D, scene:away3d.containers:Scene3D) — method, class away3d.core.pick.RaycastPicker
 | Gets the collision object from the scene position and direction of the picking ray.
getSceneCollision(position:flash.geom:Vector3D, direction:flash.geom:Vector3D, scene:away3d.containers:Scene3D) — method, class away3d.core.pick.ShaderPicker
 | Gets the collision object from the scene position and direction of the picking ray.
getSegment(index:uint) — method, class away3d.entities.SegmentSet
getSegmentAt(index:uint) — method, interface away3d.paths.IPath
 | Returns the CubicPathSegment at the specified index
getSegmentAt(index:uint) — method, class away3d.paths.SegmentedPathBase
 | returns a given PathSegment from the path (PathSegment holds 3 Vector3D's)
getSegmentPoints(segment:away3d.paths:IPathSegment, n:uint, last:Boolean) — method, class away3d.paths.SegmentedPathBase
getSkeletonPose(skeleton:away3d.animators.data:Skeleton) — method, interface away3d.animators.states.ISkeletonAnimationState
 | Returns the output skeleton pose of the animation node.
getSkeletonPose(skeleton:away3d.animators.data:Skeleton) — method, class away3d.animators.states.SkeletonBinaryLERPState
 | Returns the current skeleton pose of the animation in the clip based on the internal playhead position.
getSkeletonPose(skeleton:away3d.animators.data:Skeleton) — method, class away3d.animators.states.SkeletonClipState
 | Returns the current skeleton pose of the animation in the clip based on the internal playhead position.
getSkeletonPose(skeleton:away3d.animators.data:Skeleton) — method, class away3d.animators.states.SkeletonDifferenceState
 | Returns the current skeleton pose of the animation in the clip based on the internal playhead position.
getSkeletonPose(skeleton:away3d.animators.data:Skeleton) — method, class away3d.animators.states.SkeletonDirectionalState
 | Returns the current skeleton pose of the animation in the clip based on the internal playhead position.
getSkeletonPose(skeleton:away3d.animators.data:Skeleton) — method, class away3d.animators.states.SkeletonNaryLERPState
 | Returns the current skeleton pose of the animation in the clip based on the internal playhead position.
getSplatSampleCode(vo:away3d.materials.methods:MethodVO, targetReg:away3d.materials.compilation:ShaderRegisterElement, inputReg:away3d.materials.compilation:ShaderRegisterElement, texture:away3d.textures:TextureProxyBase, uvReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.TerrainDiffuseMethod
getSplitRatio(index:uint) — method, class away3d.lights.shadowmaps.CascadeShadowMapper
getStage3DProxy(index:uint, forceSoftware:Boolean) — method, class away3d.core.managers.Stage3DManager
 | Requests the Stage3DProxy for the given index.
getSubMeshForSubGeometry(subGeometry:away3d.core.base:SubGeometry) — method, class away3d.entities.Mesh
getSurfacePoint(uS:Number, vS:Number, vecOffset:Number, scale:Number, uTol:Number, vTol:Number) — method, class away3d.primitives.NURBSGeometry
 | Return a 3d point representing the surface point at the required U(0-1) and V(0-1) across the NURBS curved surface.
getTex2DSampleCode(vo:away3d.materials.methods:MethodVO, targetReg:away3d.materials.compilation:ShaderRegisterElement, inputReg:away3d.materials.compilation:ShaderRegisterElement, texture:away3d.textures:TextureProxyBase, uvReg:away3d.materials.compilation:ShaderRegisterElement, forceWrap:String) — method, class away3d.materials.methods.ShadingMethodBase
 | A helper method that generates standard code for sampling from a texture using the normal uv coordinates.
getTexCubeSampleCode(vo:away3d.materials.methods:MethodVO, targetReg:away3d.materials.compilation:ShaderRegisterElement, inputReg:away3d.materials.compilation:ShaderRegisterElement, texture:away3d.textures:TextureProxyBase, uvReg:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.methods.ShadingMethodBase
getTextData() — method, class away3d.loaders.parsers.ParserBase
getTexture(bitmapData:flash.display:BitmapData) — method, class away3d.textures.BitmapTextureCache
getTextureForStage3D(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.textures.CubeReflectionTexture
getTextureForStage3D(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.textures.PlanarReflectionTexture
getTextureForStage3D(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.textures.TextureProxyBase
getTimeSegment(t:Number) — method, class away3d.animators.PathAnimator
 | returns the segment index that is used at a given time;
getUp(m:flash.geom:Matrix3D, v:flash.geom:Vector3D) — Static Method , class away3d.core.math.Matrix3DUtils
 | Returns a normalised Vector3D object representing the up vector of the given matrix.
getUVAtPoint(point:flash.geom:Vector3D, target:away3d.core.base.data:UV) — method, class away3d.core.base.data.Face
 | Returns the target coordinates for a point on a triangle
getVelocities() — method, class away3d.animators.states.ParticleVelocityState
getVertexCode() — method, class away3d.filters.tasks.Filter3DRadialBlurTask
getVertexCode() — method, class away3d.filters.tasks.Filter3DTaskBase
getVertexCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.CascadeShadowMapMethod
getVertexCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.CompositeDiffuseMethod
getVertexCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.CompositeSpecularMethod
getVertexCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.NearShadowMapMethod
getVertexCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.ProjectiveTextureMethod
getVertexCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.SimpleShadowMapMethodBase
getVertexCode(vo:away3d.materials.methods:MethodVO, regCache:away3d.materials.compilation:ShaderRegisterCache) — method, class away3d.materials.methods.SubsurfaceScatteringDiffuseMethod
getVertexCode() — method, class away3d.materials.passes.CompiledPass
getVertexCode() — method, class away3d.materials.passes.DepthMapPass
getVertexCode() — method, class away3d.materials.passes.DistanceMapPass
getVertexCode() — method, class away3d.materials.passes.MaterialPassBase
getVertexCode() — method, class away3d.materials.passes.OutlinePass
getVertexCode() — method, class away3d.materials.passes.SegmentPass
getVertexCode() — method, class away3d.materials.passes.SingleObjectDepthPass
getVertexCode() — method, class away3d.materials.passes.SkyBoxPass
getVerticesVectorBounds(vertices:Vector$Number) — Static Method , class away3d.tools.utils.Bounds
 | Calculate the bounds from a vector of number representing the vertices.
getViewCollision(x:Number, y:Number, view:away3d.containers:View3D) — method, interface away3d.core.pick.IPicker
 | Gets the collision object from the screen coordinates of the picking ray.
getViewCollision(x:Number, y:Number, view:away3d.containers:View3D) — method, class away3d.core.pick.RaycastPicker
 | Gets the collision object from the screen coordinates of the picking ray.
getViewCollision(x:Number, y:Number, view:away3d.containers:View3D) — method, class away3d.core.pick.ShaderPicker
 | Gets the collision object from the screen coordinates of the picking ray.
GLOBAL — Constant Static Property, class away3d.animators.data.ParticlePropertiesMode
 | Mode that defines the particle node as acting on global properties (ie.
GLOBAL — Constant Static Property, class away3d.animators.nodes.ParticleUVNode
 | Used to set the time node into global property mode.
globalMatrices — Property, class away3d.animators.SkeletonAnimator
 | returns the calculated global matrices of the current skeleton pose.
globalPosDependencies — Property, class away3d.materials.compilation.MethodDependencyCounter
globalPose — Property, class away3d.animators.SkeletonAnimator
 | returns the current skeleton pose output from the animator.
globalPositionVarying — Property, class away3d.materials.compilation.ShaderRegisterData
globalPositionVertex — Property, class away3d.materials.compilation.ShaderRegisterData
gloss — Property, class away3d.materials.MultiPassMaterialBase
 | The sharpness of the specular highlight.
gloss — Property, class away3d.materials.SinglePassMaterialBase
 | The sharpness of the specular highlight.
gloss — Property, class away3d.materials.methods.BasicSpecularMethod
 | The sharpness of the specular highlight.
gloss — Property, class away3d.materials.methods.CompositeSpecularMethod
 | The sharpness of the specular highlight.
glossMap — Property, class away3d.textures.SpecularBitmapTexture
glowGamma — Property, class away3d.filters.RadialBlurFilter3D
glowGamma — Property, class away3d.filters.tasks.Filter3DRadialBlurTask
Grid — class, package away3d.tools.utils
 | Class Grid snaps vertexes or meshes according to a given grid unit.Grid
Grid(unit:Number, objectSpace:Boolean) — Constructor, class away3d.tools.utils.Grid
 | Grid snaps vertexes according to a given grid unit
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


H

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
H Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
halfExtentsX — Property, class away3d.bounds.AxisAlignedBoundingBox
halfExtentsY — Property, class away3d.bounds.AxisAlignedBoundingBox
halfExtentsZ — Property, class away3d.bounds.AxisAlignedBoundingBox
HardShadowMapMethod — class, package away3d.materials.methods
HardShadowMapMethod(castingLight:away3d.lights:LightBase) — Constructor, class away3d.materials.methods.HardShadowMapMethod
 | Creates a new HardShadowMapMethod object.
hasAnimation(name:String) — method, class away3d.animators.AnimationSetBase
 | Check to determine whether a state is registered in the animation set under the given name.
hasAnimation(name:String) — method, interface away3d.animators.IAnimationSet
 | Check to determine whether a state is registered in the animation set under the given name.
hasBillboard — Property, class away3d.animators.ParticleAnimationSet
hasBillboard — Property, class away3d.animators.data.AnimationRegisterCache
_hasCollisions — Property, class away3d.core.pick.RaycastPicker
hasColorNode — Property, class away3d.animators.ParticleAnimationSet
hasColorNode — Property, class away3d.animators.data.AnimationRegisterCache
hasDebug(mesh:away3d.entities:Mesh) — method, class away3d.tools.helpers.MeshDebugger
hasDepthAlphaThreshold() — method, class away3d.materials.MaterialBase
hasEventListener(type:String) — Static Method , class away3d.library.AssetLibrary
 | Short-hand for hasEventListener() method on default asset library bundle.
hasEventListener(type:String) — method, class away3d.lights.shadowmaps.CascadeShadowMapper
hasEventListener(type:String) — method, class away3d.loaders.misc.AssetLoaderToken
hasFreeStage3DProxy — Property, class away3d.core.managers.Stage3DManager
 | Checks if a new stage3DProxy can be created and managed by the class.
hasMethod(method:away3d.materials.methods:EffectMethodBase) — method, class away3d.materials.MultiPassMaterialBase
hasMethod(method:away3d.materials.methods:EffectMethodBase) — method, class away3d.materials.SinglePassMaterialBase
hasMethod(method:away3d.materials.methods:EffectMethodBase) — method, class away3d.materials.methods.ShaderMethodSetup
hasMethod(method:away3d.materials.methods:EffectMethodBase) — method, class away3d.materials.passes.SuperShaderPass
_hasMipmaps — Property, class away3d.textures.TextureProxyBase
hasMipMaps — Property, class away3d.textures.TextureProxyBase
hasOutput — Property, class away3d.materials.methods.BasicNormalMethod
 | Override this is normal method output is not based on a texture (if not, it will usually always return true)
hasTime() — method, class away3d.loaders.parsers.ParserBase
 | Tests whether or not there is still time left for parsing within the maximum allowed time frame per session.
hasUVNode — Property, class away3d.animators.ParticleAnimationSet
hasUVNode — Property, class away3d.animators.data.AnimationRegisterCache
HBlurFilter3D — class, package away3d.filters
HBlurFilter3D(amount:uint, stepSize:int) — Constructor, class away3d.filters.HBlurFilter3D
 | Creates a new HBlurFilter3D object
HDepthOfFieldFilter3D — class, package away3d.filters
HDepthOfFieldFilter3D(maxBlur:uint, stepSize:int) — Constructor, class away3d.filters.HDepthOfFieldFilter3D
 | Creates a new HDepthOfFieldFilter3D object
height — Property, class away3d.containers.View3D
 | The height of the viewport.
height — Property, class away3d.core.managers.Stage3DProxy
 | The height of the Stage3D.
height — Property, class away3d.core.partition.ViewVolume
height — Property, class away3d.entities.Sprite3D
height — Property, class away3d.extrusions.Elevation
height — Property, interface away3d.materials.utils.IVideoPlayer
 | Get/Set access to the height of the video object
height — Property, class away3d.materials.utils.SimpleVideoPlayer
height — Property, class away3d.primitives.CapsuleGeometry
 | The height of the capsule.
height — Property, class away3d.primitives.CubeGeometry
 | The size of the cube along its Y-axis.
_height — Property, class away3d.primitives.CylinderGeometry
height — Property, class away3d.primitives.CylinderGeometry
 | The radius of the top end of the cylinder.
height — Property, class away3d.primitives.PlaneGeometry
 | The height of the plane.
height — Property, class away3d.primitives.WireframeCube
 | The size of the cube along its Y-axis.
height — Property, class away3d.primitives.WireframeCylinder
 | The height of the cylinder
height — Property, class away3d.primitives.WireframePlane
 | The size of the cube along its Y-axis.
height — Property, class away3d.textures.ATFData
height — Property, class away3d.textures.RenderTexture
_height — Property, class away3d.textures.TextureProxyBase
height — Property, class away3d.textures.TextureProxyBase
height — Static Property, class away3d.tools.utils.Bounds
HeightMapNormalMethod — class, package away3d.materials.methods
HeightMapNormalMethod(heightMap:away3d.textures:Texture2DBase, worldWidth:Number, worldHeight:Number, worldDepth:Number) — Constructor, class away3d.materials.methods.HeightMapNormalMethod
hideDebug(mesh:away3d.entities:Mesh) — method, class away3d.tools.helpers.MeshDebugger
highQuality — Property, class away3d.animators.nodes.SkeletonClipNode
 | Determines whether to use SLERP equations (true) or LERP equations (false) in the calculation of the output skeleton pose.
HoverController — class, package away3d.controllers
 | Extended camera used to hover round a specified target object.
HoverController(targetObject:away3d.entities:Entity, lookAtObject:away3d.containers:ObjectContainer3D, panAngle:Number, tiltAngle:Number, distance:Number, minTiltAngle:Number, maxTiltAngle:Number, minPanAngle:Number, maxPanAngle:Number, steps:uint, yFactor:Number, wrapPanAngle:Boolean) — Constructor, class away3d.controllers.HoverController
 | Creates a new HoverController object.
HueSaturationFilter3D — class, package away3d.filters
HueSaturationFilter3D(saturation:Number, r:Number, g:Number, b:Number) — Constructor, class away3d.filters.HueSaturationFilter3D
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


I

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
I Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
IAnimationSet — Interface, package away3d.animators
 | Provides an interface for data set classes that hold animation data for use in animator classes.
IAnimationState — Interface, package away3d.animators.states
IAnimationTransition — Interface, package away3d.animators.transitions
IAnimator — Interface, package away3d.animators
 | Provides an interface for animator classes that control animation output from a data set subtype of AnimationSetBase.
IAsset — Interface, package away3d.library.assets
id — Property, class away3d.loaders.misc.ResourceDependency
IEntitySorter — Interface, package away3d.core.sort
 | EntitySorterBase provides an abstract base class to sort geometry information in an EntityCollector object for rendering.
IGNORE — Constant Static Property, class away3d.library.naming.ConflictStrategy
 | Specifies that naming conflicts should be ignored.
IgnoreConflictStrategy — class, package away3d.library.naming
IgnoreConflictStrategy() — Constructor, class away3d.library.naming.IgnoreConflictStrategy
ignoreSides — Property, class away3d.extrusions.LatheExtrude
 | Defines if the top, bottom, left, right, front or back of the the extrusion is left open.
ignoreSides — Property, class away3d.extrusions.LinearExtrude
 | Defines if the top, bottom, left, right, front or back of the the extrusion is left open.
_ignoreTransform — Property, class away3d.containers.ObjectContainer3D
ignoreTransform — Property, class away3d.containers.ObjectContainer3D
 | Does not apply any transformations to this object.
ignoreTransform — Property, class away3d.entities.Entity
ImageParser — class, package away3d.loaders.parsers
 | ImageParser provides a "parser" for natively supported image types (jpg, png).
ImageParser() — Constructor, class away3d.loaders.parsers.ImageParser
 | Creates a new ImageParser object.
images — Property, class away3d.loaders.parsers.DAEParser
IMaterialOwner — Interface, package away3d.core.base
 | IMaterialOwner provides an interface for objects that can use materials.
_implicitPartition — Property, class away3d.containers.ObjectContainer3D
implicitPartition — Property, class away3d.containers.ObjectContainer3D
implicitPartition — Property, class away3d.entities.Entity
IN — Constant Static Property, class away3d.core.math.PlaneClassification
includeCasters — Property, class away3d.materials.passes.LightingPass
includeCasters — Property, class away3d.materials.passes.SuperShaderPass
includeDependencies — Property, class away3d.loaders.misc.AssetLoaderContext
 | Defines whether dependencies (all files except the one at the URL given to the load() or parseData() operations) should be automatically loaded.
includeMethodVO(methodVO:away3d.materials.methods:MethodVO) — method, class away3d.materials.compilation.MethodDependencyCounter
incrementStrafe(val:Number) — method, class away3d.controllers.FirstPersonController
incrementWalk(val:Number) — method, class away3d.controllers.FirstPersonController
index — Property, class away3d.animators.PathAnimator
 | Set the pointer to a given segment along the path
index — Property, class away3d.animators.data.ParticleAnimationData
index — Property, class away3d.animators.data.ParticleProperties
 | The index of the current particle being set.
_index — Property, class away3d.core.base.SubMesh
index — Property, class away3d.core.base.data.Vertex
 | To define/store the index of value object
index — Property, class away3d.materials.compilation.ShaderRegisterElement
 | The register's index.
index — Property, class away3d.primitives.data.Segment
_indexBuffer — Property, class away3d.core.base.SubGeometryBase
indexBuffer — Property, class away3d.core.managers.RTTBufferManager
_indexBufferContext — Property, class away3d.core.base.SubGeometryBase
indexData — Property, interface away3d.core.base.IRenderable
 | Retrieves the object's indices as a uint array.
indexData — Property, interface away3d.core.base.ISubGeometry
 | Retrieves the object's indices as a uint array.
indexData — Property, class away3d.core.base.SubMesh
indexData — Property, class away3d.entities.SegmentSet
indexData — Property, class away3d.entities.Sprite3D
indexData — Property, class away3d.primitives.SkyBox
_indices — Property, class away3d.core.base.SubGeometryBase
_indicesInvalid — Property, class away3d.core.base.SubGeometryBase
info — Property, class away3d.errors.DeprecationError
initCommonsData() — method, class away3d.materials.passes.CompiledPass
initCompiler() — method, class away3d.materials.passes.CompiledPass
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.BasicAmbientMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.CascadeShadowMapMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.CelDiffuseMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.CompositeDiffuseMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.CompositeSpecularMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.DepthDiffuseMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.DitheredShadowMapMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.FilteredShadowMapMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.FogMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.FresnelEnvMapMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.FresnelSpecularMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.HeightMapNormalMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.NearShadowMapMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.ProjectiveTextureMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.RefractionEnvMapMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.RimLightMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.ShadingMethodBase
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.SimpleShadowMapMethodBase
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.SimpleWaterNormalMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.SoftShadowMapMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.SubsurfaceScatteringDiffuseMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.TerrainDiffuseMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.TripleFilteredShadowMapMethod
initConstants(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.WrapDiffuseMethod
initLightData() — method, class away3d.materials.compilation.LightingShaderCompiler
initLightData() — method, class away3d.materials.compilation.ShaderCompiler
initLightData() — method, class away3d.materials.compilation.SuperShaderCompiler
initParticleFunc — Property, class away3d.animators.ParticleAnimationSet
 | Initialiser function for static particle properties.
initRegisterIndices() — method, class away3d.materials.compilation.LightingShaderCompiler
initRegisterIndices() — method, class away3d.materials.compilation.ShaderCompiler
initUVTransformData() — method, class away3d.materials.passes.CompiledPass
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.AlphaMaskMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.AnisotropicSpecularMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.BasicAmbientMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.BasicDiffuseMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.BasicNormalMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.BasicSpecularMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.CascadeShadowMapMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.CompositeDiffuseMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.CompositeSpecularMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.DitheredShadowMapMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.EnvMapAmbientMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.EnvMapMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.FogMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.FresnelEnvMapMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.FresnelPlanarReflectionMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.LightMapDiffuseMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.LightMapMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.NearShadowMapMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.OutlineMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.PlanarReflectionMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.RefractionEnvMapMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.RimLightMethod
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.ShadingMethodBase
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.SimpleShadowMapMethodBase
initVO(vo:away3d.materials.methods:MethodVO) — method, class away3d.materials.methods.SimpleWaterNormalMethod
inputA — Property, class away3d.animators.nodes.SkeletonBinaryLERPNode
 | Defines input node A to use for the blended output.
inputB — Property, class away3d.animators.nodes.SkeletonBinaryLERPNode
 | Defines input node B to use for the blended output.
_inputs — Property, class away3d.animators.nodes.SkeletonNaryLERPNode
instance — Static Property, class away3d.debug.AwayStats
 | Holds a reference to the stats widget (or if several have been created during session, the one that was last instantiated.) Allows you to set properties and register views from anywhere in your code.
_instances — Static Property, class away3d.library.AssetLibrary
intensity — Property, class away3d.filters.RadialBlurFilter3D
intensity — Property, class away3d.filters.tasks.Filter3DRadialBlurTask
interleaveBuffers(numVertices:uint, vertices:Vector$Number, normals:Vector$Number, tangents:Vector$Number, uvs:Vector$Number, suvs:Vector$Number) — Static Method , class away3d.utils.GeometryUtil
InterleavedStereoRenderMethod — class, package away3d.stereo.methods
InterleavedStereoRenderMethod() — Constructor, class away3d.stereo.methods.InterleavedStereoRenderMethod
internalUpdate() — method, class away3d.entities.Entity
INTERSECT — Constant Static Property, class away3d.core.math.PlaneClassification
intersectsSphere(pOrig:flash.geom:Vector3D, dir:flash.geom:Vector3D, sPos:flash.geom:Vector3D, radius:Number) — method, class away3d.tools.utils.Ray
 | Checks if a ray intersects a sphere.
invalidateBounds(subGeom:away3d.core.base:ISubGeometry) — method, class away3d.core.base.Geometry
invalidateBounds() — method, class away3d.core.base.SubGeometryBase
invalidateBounds() — method, class away3d.entities.Entity
 | Invalidates the bounding volume, causing to be updated when requested.
invalidateBounds() — method, class away3d.primitives.SkyBox
 | Invalidates the bounding volume, causing to be updated when requested.
invalidateBuffer() — method, class away3d.animators.data.AnimationSubGeometry
invalidateBuffers(invalid:Vector$Boolean) — method, class away3d.core.base.CompactSubGeometry
invalidateBuffers(invalid:Vector$Boolean) — method, class away3d.core.base.SubGeometryBase
 | Invalidates all buffers in a vector, causing them the update when they are first requested.
invalidateContent() — method, class away3d.textures.TextureProxyBase
invalidateEntityBounds(entity:away3d.entities:Entity) — method, class away3d.containers.Scene3D
 | When an entity has moved or changed size, update its position in its partition tree.
invalidateGeometry() — method, class away3d.extrusions.Elevation
 | Invalidates the primitive's geometry, causing it to be updated when requested.
invalidateGeometry() — method, class away3d.primitives.PrimitiveBase
 | Invalidates the primitive's geometry, causing it to be updated when requested.
invalidateGeometry() — method, class away3d.primitives.WireframePrimitiveBase
invalidateMatrix() — method, class away3d.cameras.lenses.LensBase
 | Invalidates the projection matrix, which will cause it to be updated on the next request.
invalidatePasses(triggerPass:away3d.materials.passes:MaterialPassBase) — method, class away3d.materials.MaterialBase
 | Marks the depth shader programs as invalid, so it will be recompiled before the next render.
invalidateProgram3D() — method, class away3d.filters.tasks.Filter3DTaskBase
invalidateSceneTransform() — method, class away3d.cameras.Camera3D
 | Invalidates the scene transformation matrix, causing it to be updated the next time it's requested.
invalidateSceneTransform() — method, class away3d.containers.ObjectContainer3D
 | Invalidates the scene transformation matrix, causing it to be updated the next time it's requested.
invalidateSceneTransform() — method, class away3d.entities.Entity
 | Invalidates the scene transformation matrix, causing it to be updated the next time it's requested.
invalidateSceneTransform() — method, class away3d.entities.TextureProjector
 | Invalidates the scene transformation matrix, causing it to be updated the next time it's requested.
invalidateScreenPasses() — method, class away3d.materials.MultiPassMaterialBase
invalidateShaderProgram() — method, class away3d.materials.methods.ShadingMethodBase
 | Marks the shader program as invalid, so it will be recompiled before the next render.
invalidateShaderProgram(updateMaterial:Boolean) — method, class away3d.materials.passes.CompiledPass
 | Marks the shader program as invalid, so it will be recompiled before the next render.
invalidateShaderProgram(updateMaterial:Boolean) — method, class away3d.materials.passes.MaterialPassBase
 | Marks the shader program as invalid, so it will be recompiled before the next render.
invalidateSize() — method, class away3d.textures.TextureProxyBase
invalidateStereoCams() — method, class away3d.stereo.StereoCamera3D
invalidateTextureSize() — method, class away3d.stereo.methods.StereoRenderMethodBase
invalidateTransform() — method, class away3d.containers.ObjectContainer3D
 | Invalidates the transformation matrix, causing it to be updated upon the next request
invalidateTransform() — method, class away3d.core.base.Object3D
 | Invalidates the transformation matrix, causing it to be updated upon the next request
invalidateTransform() — method, class away3d.stereo.StereoCamera3D
invalidateUVs() — method, class away3d.extrusions.Elevation
 | Invalidates the primitive's uv coordinates, causing them to be updated when requested.
invalidateUVs() — method, class away3d.primitives.PrimitiveBase
 | Invalidates the primitive's uv coordinates, causing them to be updated when requested.
InvalidTextureError — class, package away3d.errors
 | TextureError is thrown when an invalid texture is used regarding Stage3D limitations.
InvalidTextureError(message:String, id:int) — Constructor, class away3d.errors.InvalidTextureError
 | Create a new TextureError.
inverseBindPose — Property, class away3d.animators.data.SkeletonJoint
 | The inverse bind pose matrix, as raw data, used to transform vertices to bind joint space in preparation for transformation using the joint matrix.
inverseSceneTransform — Property, class away3d.containers.ObjectContainer3D
 | The inverse scene transform object that transforms from world to model space.
inverseSceneTransform — Property, interface away3d.core.base.IRenderable
 | The inverse scene transform object that transforms from world to model space.
inverseSceneTransform — Property, class away3d.core.base.SubMesh
 | The inverse scene transform object that transforms from world to model space.
InvertedOctreeNode — class, package away3d.core.partition
 | InvertedOctreeNode is an octree data structure not used hierarchically for culling, but for fast dynamic insertion.
InvertedOctreeNode(minBounds:flash.geom:Vector3D, maxBounds:flash.geom:Vector3D) — Constructor, class away3d.core.partition.InvertedOctreeNode
invertFaces(mesh:away3d.entities:Mesh, invertU:Boolean) — Static Method , class away3d.tools.helpers.MeshHelper
 | Inverts the faces of a Mesh
invertFacesInContainer(obj:away3d.containers:ObjectContainer3D) — Static Method , class away3d.tools.helpers.MeshHelper
 | Inverts the faces of all the Meshes into an ObjectContainer3D
invVertexTransform — Property, class away3d.tools.helpers.data.ParticleGeometryTransform
IPath — Interface, package away3d.paths
IPathSegment — Interface, package away3d.paths
IPicker — Interface, package away3d.core.pick
 | Provides an interface for picking objects that can pick 3d objects from a view or scene.
IPickingCollider — Interface, package away3d.core.pick
 | Provides an interface for picking colliders that can be assigned to individual entities in a scene for specific picking behaviour.
IRenderable — Interface, package away3d.core.base
 | IRenderable provides an interface for objects that can be rendered in the rendering pipeline.
isAnimated — Property, class away3d.loaders.parsers.DAEParser
isBitmapDataValid(bitmapData:flash.display:BitmapData) — method, class away3d.loaders.parsers.ParserBase
 | Validates a bitmapData loaded before assigning to a default BitmapMaterial
isBitmapDataValid(bitmapData:flash.display:BitmapData) — Static Method , class away3d.tools.utils.TextureUtils
isDefaultPrevented() — method, class away3d.events.LoaderEvent
isDependency — Property, class away3d.events.LoaderEvent
 | Indicates whether the event occurred while loading a dependency, as opposed to the base file.
isDimensionValid(d:uint) — Static Method , class away3d.tools.utils.TextureUtils
_isFirstLight — Property, class away3d.materials.methods.BasicDiffuseMethod
_isFirstLight — Property, class away3d.materials.methods.BasicSpecularMethod
isInFrustum(mvpMatrix:flash.geom:Matrix3D) — method, class away3d.bounds.AxisAlignedBoundingBox
 | Tests if the bounds are in the camera frustum.
isInFrustum(mvpMatrix:flash.geom:Matrix3D) — method, class away3d.bounds.BoundingSphere
 | todo: pass planes? Tests if the bounds are in the camera frustum.
isInFrustum(mvpMatrix:flash.geom:Matrix3D) — method, class away3d.bounds.BoundingVolumeBase
 | Tests if the bounds are in the camera frustum.
isInFrustum(mvpMatrix:flash.geom:Matrix3D) — method, class away3d.bounds.NullBounds
 | Tests if the bounds are in the camera frustum.
isInFrustum(camera:away3d.cameras:Camera3D) — method, class away3d.core.partition.NodeBase
 | Tests if the current node is at least partly inside the frustum.
isInFrustumImpl(camera:away3d.cameras:Camera3D) — method, class away3d.core.partition.EntityNode
isInFrustumImpl(camera:away3d.cameras:Camera3D) — method, class away3d.core.partition.InvertedOctreeNode
isInFrustumImpl(camera:away3d.cameras:Camera3D) — method, class away3d.core.partition.NodeBase
isInFrustumImpl(camera:away3d.cameras:Camera3D) — method, class away3d.core.partition.OctreeNode
isInFrustumImpl(camera:away3d.cameras:Camera3D) — method, class away3d.core.partition.QuadTreeNode
isInFrustumImpl(camera:away3d.cameras:Camera3D) — method, class away3d.core.partition.SkyBoxNode
ISkeletonAnimationState — Interface, package away3d.animators.states
ISound3DDriver — Interface, package away3d.audio.drivers
isPowerOfTwo(value:int) — Static Method , class away3d.tools.utils.TextureUtils
_isRoot — Property, class away3d.containers.ObjectContainer3D
ISubGeometry — Interface, package away3d.core.base
IUVAnimationState — Interface, package away3d.animators.states
 | Provides an interface for animation node classes that hold animation data for use in the UV animator class.
IVertexAnimationState — Interface, package away3d.animators.states
 | Provides an interface for animation node classes that hold animation data for use in the Vertex animator class.
IVideoPlayer — Interface, package away3d.materials.utils
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


J

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
J Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
jointFromName(jointName:String) — method, class away3d.animators.data.Skeleton
 | Returns the joint object in the skeleton with the given name, otherwise returns a null object.
jointIndexData — Property, class away3d.core.base.SkinnedSubGeometry
 | The raw joint index data.
jointIndexFromName(jointName:String) — method, class away3d.animators.data.Skeleton
 | Returns the joint index, given the joint name.
JointPose — class, package away3d.animators.data
 | Contains transformation data for a skeleton joint, used for skeleton animation.
jointPoseFromName(jointName:String) — method, class away3d.animators.data.SkeletonPose
 | Returns the joint pose object with the given joint name, otherwise returns a null object.
jointPoseIndexFromName(jointName:String) — method, class away3d.animators.data.SkeletonPose
 | Returns the pose index, given the joint name.
jointPoses — Property, class away3d.animators.data.SkeletonPose
 | A flat list of pose objects that comprise the skeleton pose.
joints — Property, class away3d.animators.data.Skeleton
 | A flat list of joint objects that comprise the skeleton.
jointsPerVertex — Property, class away3d.animators.SkeletonAnimationSet
 | Returns the amount of skeleton joints that can be linked to a single vertex via skinned weight values.
jointWeightsData — Property, class away3d.core.base.SkinnedSubGeometry
 | The raw joint weights data.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


K

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
K Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
keepExtremes — Property, class away3d.extrusions.PathExtrude
 | Defines if the first and last transformed vector3d's of the profile are kept.
keepLastProfile — Property, class away3d.extrusions.LatheExtrude
 | Defines if the last transformed profile values are saved or not.
keepMaterial — Property, class away3d.tools.commands.Merge
 | Defines if mesh2 will be merged using its own material information.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


L

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
L Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
_lastFrame — Property, class away3d.animators.nodes.AnimationClipNodeBase
lastFrame — Property, class away3d.animators.nodes.AnimationClipNodeBase
_lastFrameTime — Property, class away3d.loaders.parsers.ParserBase
lastProfile — Property, class away3d.extrusions.LatheExtrude
 | returns the last rotated profile values, if keepLastProfile was true
LatheExtrude — class, package away3d.extrusions
 | Class for generating meshes with axial symmetry such as donuts, pipes, vases etc.
LatheExtrude(material:away3d.materials:MaterialBase, profile:Vector$flash.geom:Vector3D, axis:String, revolutions:Number, subdivision:uint, coverall:Boolean, centerMesh:Boolean, flip:Boolean, thickness:Number, preciseThickness:Boolean, offsetRadius:Number, materials:away3d.materials.utils:MultipleMaterials, ignoreSides:String, tweek:Object, smoothSurface:Boolean) — Constructor, class away3d.extrusions.LatheExtrude
 | Class LatheExtrude generates circular meshes such as donuts, pipes, pyramids etc..
left — Property, class away3d.animators.nodes.SkeletonDirectionalNode
 | Defines the left configured input node to use for the blended output.
left — Property, class away3d.materials.utils.MultipleMaterials
 | Defines the material applied to the left side of the cube.
LEFT — Constant Static Property, class away3d.tools.utils.Projector
leftCamera — Property, class away3d.stereo.StereoCamera3D
leftVector — Property, class away3d.core.base.Object3D
lengthNormals — Property, class away3d.tools.helpers.MeshDebugger
lengthTangents — Property, class away3d.tools.helpers.MeshDebugger
lengthVertexNormals — Property, class away3d.tools.helpers.MeshDebugger
lens — Property, class away3d.cameras.Camera3D
 | The lens used by the camera to perform the projection;
lens — Property, class away3d.events.LensEvent
lens — Property, class away3d.stereo.StereoCamera3D
LensBase — class, package away3d.cameras.lenses
 | An abstract base class for all lens classes.
LensBase() — Constructor, class away3d.cameras.lenses.LensBase
 | Creates a new LensBase object.
LensEvent — class, package away3d.events
LensEvent(type:String, lens:away3d.cameras.lenses:LensBase, bubbles:Boolean, cancelable:Boolean) — Constructor, class away3d.events.LensEvent
lerp(qa:away3d.core.math:Quaternion, qb:away3d.core.math:Quaternion, t:Number) — method, class away3d.core.math.Quaternion
 | Linearly interpolates between two quaternions.
levels — Property, class away3d.materials.methods.CelDiffuseMethod
light — Property, class away3d.core.partition.DirectionalLightNode
 | The light object contained in this node.
light — Property, class away3d.core.partition.LightNode
 | The light object contained in this node.
light — Property, class away3d.core.partition.LightProbeNode
 | The light object contained in this node.
light — Property, class away3d.core.partition.PointLightNode
 | The light object contained in this node.
_light — Property, class away3d.lights.shadowmaps.ShadowMapperBase
light — Property, class away3d.lights.shadowmaps.ShadowMapperBase
_lightAmbientB — Property, class away3d.materials.methods.BasicAmbientMethod
_lightAmbientG — Property, class away3d.materials.methods.BasicAmbientMethod
_lightAmbientR — Property, class away3d.materials.methods.BasicAmbientMethod
LightBase — class, package away3d.lights
 | LightBase provides an abstract base class for subtypes representing lights.
LightBase() — Constructor, class away3d.lights.LightBase
 | Create a new LightBase object.
LightEvent — class, package away3d.events
LightEvent(type:String) — Constructor, class away3d.events.LightEvent
_lightFragmentConstantIndex — Property, class away3d.materials.compilation.ShaderCompiler
lightFragmentConstantIndex — Property, class away3d.materials.compilation.ShaderCompiler
_lightFragmentConstantIndex — Property, class away3d.materials.passes.CompiledPass
LightingMethodBase — class, package away3d.materials.methods
 | LightingMethodBase provides an abstract base method for shading methods that uses lights.
LightingMethodBase() — Constructor, class away3d.materials.methods.LightingMethodBase
LightingPass — class, package away3d.materials.passes
 | DefaultScreenPass is a shader pass that uses shader methods to compile a complete program.
LightingPass(material:away3d.materials:MaterialBase) — Constructor, class away3d.materials.passes.LightingPass
 | Creates a new DefaultScreenPass objects.
LightingShaderCompiler — class, package away3d.materials.compilation
LightingShaderCompiler() — Constructor, class away3d.materials.compilation.LightingShaderCompiler
LightMapDiffuseMethod — class, package away3d.materials.methods
LightMapDiffuseMethod(lightMap:away3d.textures:Texture2DBase, blendMode:String, useSecondaryUV:Boolean, baseMethod:away3d.materials.methods:BasicDiffuseMethod) — Constructor, class away3d.materials.methods.LightMapDiffuseMethod
LightMapMethod — class, package away3d.materials.methods
LightMapMethod(texture:away3d.textures:Texture2DBase, blendMode:String, useSecondaryUV:Boolean) — Constructor, class away3d.materials.methods.LightMapMethod
lightMapTexture — Property, class away3d.materials.methods.LightMapDiffuseMethod
LightNode — class, package away3d.core.partition
 | LightNode is a space partitioning leaf node that contains a LightBase object.
LightNode(light:away3d.lights:LightBase) — Constructor, class away3d.core.partition.LightNode
 | Creates a new LightNode object.
lightOffset — Property, class away3d.lights.shadowmaps.CascadeShadowMapper
_lightOffset — Property, class away3d.lights.shadowmaps.DirectionalShadowMapper
lightOffset — Property, class away3d.lights.shadowmaps.DirectionalShadowMapper
_lightPicker — Property, class away3d.materials.MaterialBase
lightPicker — Property, class away3d.materials.MaterialBase
lightPicker — Property, class away3d.materials.MultiPassMaterialBase
lightPicker — Property, class away3d.materials.SinglePassMaterialBase
_lightPicker — Property, class away3d.materials.passes.MaterialPassBase
lightPicker — Property, class away3d.materials.passes.MaterialPassBase
LightPickerBase — class, package away3d.materials.lightpickers
LightProbe — class, package away3d.lights
LightProbe(diffuseMap:away3d.textures:CubeTextureBase, specularMap:away3d.textures:CubeTextureBase) — Constructor, class away3d.lights.LightProbe
 | Creates a new LightProbe object.
_lightProbeDiffuseIndices — Property, class away3d.materials.compilation.ShaderCompiler
lightProbeDiffuseIndices — Property, class away3d.materials.compilation.ShaderCompiler
_lightProbeDiffuseIndices — Property, class away3d.materials.passes.CompiledPass
LightProbeNode — class, package away3d.core.partition
 | LightNode is a space partitioning leaf node that contains a LightBase object.
LightProbeNode(light:away3d.lights:LightProbe) — Constructor, class away3d.core.partition.LightProbeNode
 | Creates a new LightNode object.
lightProbes — Property, class away3d.core.traverse.EntityCollector
_lightProbes — Property, class away3d.materials.lightpickers.LightPickerBase
lightProbes — Property, class away3d.materials.lightpickers.LightPickerBase
lightProbesOffset — Property, class away3d.materials.passes.LightingPass
_lightProbeSpecularIndices — Property, class away3d.materials.compilation.ShaderCompiler
lightProbeSpecularIndices — Property, class away3d.materials.compilation.ShaderCompiler
_lightProbeSpecularIndices — Property, class away3d.materials.passes.CompiledPass
_lightProbeWeights — Property, class away3d.materials.lightpickers.LightPickerBase
lightProbeWeights — Property, class away3d.materials.lightpickers.LightPickerBase
_lights — Property, class away3d.core.traverse.EntityCollector
lights — Property, class away3d.core.traverse.EntityCollector
 | The lights of which the affecting area intersects the camera's frustum.
lights — Property, class away3d.materials.lightpickers.StaticLightPicker
LIGHTS — Constant Static Property, class away3d.materials.LightSources
 | Defines normal lights are to be used as the source for the lighting component.
LightsHelper — class, package away3d.tools.helpers
 | Helper Class for the LightBase objects LightsHelper A series of methods to ease work with LightBase objects
LightSources — class, package away3d.materials
 | Enumeration class for defining which lighting types affects the specific material lighting component (diffuse and specular).
lightVertexConstantIndex — Property, class away3d.materials.compilation.LightingShaderCompiler
LinearExtrude — class, package away3d.extrusions
LinearExtrude(material:away3d.materials:MaterialBase, vectors:Vector$flash.geom:Vector3D, axis:String, offset:Number, subdivision:uint, coverAll:Boolean, thickness:Number, thicknessSubdivision:uint, materials:away3d.materials.utils:MultipleMaterials, centerMesh:Boolean, closePath:Boolean, ignoreSides:String, flip:Boolean) — Constructor, class away3d.extrusions.LinearExtrude
 | Class LinearExtrusion generates walls like meshes with or without thickness from a series of Vector3D's param material [optional] MaterialBase.
LineSegment — class, package away3d.primitives
 | A Line Segment primitive.
LineSegment(v0:flash.geom:Vector3D, v1:flash.geom:Vector3D, color0:uint, color1:uint, thickness:Number) — Constructor, class away3d.primitives.LineSegment
 | Create a line segment
listener — Property, class away3d.audio.SoundTransform3D
load(req:flash.net:URLRequest, context:away3d.loaders.misc:AssetLoaderContext, ns:String, parser:away3d.loaders.parsers:ParserBase) — Static Method , class away3d.library.AssetLibrary
 | Short-hand for load() method on default asset library bundle.
load(req:flash.net:URLRequest, context:away3d.loaders.misc:AssetLoaderContext, ns:String, parser:away3d.loaders.parsers:ParserBase) — method, class away3d.library.AssetLibraryBundle
 | Loads a file and (optionally) all of its dependencies.
load(req:flash.net:URLRequest, context:away3d.loaders.misc:AssetLoaderContext, ns:String, parser:away3d.loaders.parsers:ParserBase) — method, class away3d.loaders.AssetLoader
 | Loads a file and (optionally) all of its dependencies.
load(req:flash.net:URLRequest, context:away3d.loaders.misc:AssetLoaderContext, ns:String, parser:away3d.loaders.parsers:ParserBase) — method, class away3d.loaders.Loader3D
 | Loads a file and (optionally) all of its dependencies.
load(urlRequest:flash.net:URLRequest, parser:away3d.loaders.parsers:ParserBase, loadAsRawData:Boolean) — method, class away3d.loaders.misc.SingleFileLoader
 | Load a resource from a file.
loadAsRawData — Property, class away3d.loaders.misc.SingleFileLoader
loadData(data:any, context:away3d.loaders.misc:AssetLoaderContext, ns:String, parser:away3d.loaders.parsers:ParserBase) — Static Method , class away3d.library.AssetLibrary
 | Short-hand for loadData() method on default asset library bundle.
loadData(data:any, context:away3d.loaders.misc:AssetLoaderContext, ns:String, parser:away3d.loaders.parsers:ParserBase) — method, class away3d.library.AssetLibraryBundle
 | Loads a resource from existing data in memory.
loadData(data:any, id:String, context:away3d.loaders.misc:AssetLoaderContext, ns:String, parser:away3d.loaders.parsers:ParserBase) — method, class away3d.loaders.AssetLoader
 | Loads a resource from already loaded data.
loadData(data:any, context:away3d.loaders.misc:AssetLoaderContext, ns:String, parser:away3d.loaders.parsers:ParserBase) — method, class away3d.loaders.Loader3D
 | Loads a resource from already loaded data.
_loader — Property, class away3d.loaders.misc.AssetLoaderToken
loader — Property, class away3d.loaders.misc.ResourceDependency
Loader3D — class, package away3d.loaders
 | Loader3D can load any file format that Away3D supports (or for which a third-party parser has been plugged in) and be added directly to the scene.
Loader3D(useAssetLibrary:Boolean, assetLibraryId:String) — Constructor, class away3d.loaders.Loader3D
LoaderEvent — class, package away3d.events
 | LoaderEvent is an Event dispatched to notify changes in loading state.
LoaderEvent(type:String, url:String, isDependency:Boolean, errmsg:String) — Constructor, class away3d.events.LoaderEvent
 | Create a new LoaderEvent object.
loadError — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when an error occurs during loading.
loadError — Event, class away3d.loaders.AssetLoader
 | Dispatched when an error occurs during loading.
loadError — Event, class away3d.loaders.Loader3D
 | Dispatched when an error occurs during loading.
loadError — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when an error occurs during loading.
loadError — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when an error occurs during loading.
LOAD_ERROR — Constant Static Property, class away3d.events.LoaderEvent
 | Dispatched when loading of a asset failed.
LOCAL_DYNAMIC — Constant Static Property, class away3d.animators.data.ParticlePropertiesMode
 | Mode that defines the particle node as acting on local dynamic properties (ie.
_localFrustum — Property, class away3d.lights.shadowmaps.DirectionalShadowMapper
localNormal — Property, class away3d.core.pick.PickingCollisionVO
 | The local normal vector at the position of the collision.
localNormal — Property, class away3d.events.MouseEvent3D
 | The normal in object space where the event took place
localPosition — Property, class away3d.core.pick.PickingCollisionVO
 | The local position of the collision on the entity's surface.
localPosition — Property, class away3d.events.MouseEvent3D
 | The position in object space where the event took place
localPosition — Property, class away3d.materials.compilation.ShaderRegisterData
localRayDirection — Property, class away3d.core.pick.PickingCollisionVO
 | The direction of the colliding ray in local coordinates.
localRayPosition — Property, class away3d.core.pick.PickingCollisionVO
 | The starting position of the colliding ray in local coordinates.
LOCAL_STATIC — Constant Static Property, class away3d.animators.data.ParticlePropertiesMode
 | Mode that defines the particle node as acting on local static properties (ie.
lookAt(target:flash.geom:Vector3D, upAxis:flash.geom:Vector3D) — method, class away3d.containers.ObjectContainer3D
 | Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D.
lookAt(target:flash.geom:Vector3D, upAxis:flash.geom:Vector3D) — method, class away3d.core.base.Object3D
 | Rotates the 3d object around to face a point defined relative to the local coordinates of the parent ObjectContainer3D.
lookAt(matrix:flash.geom:Matrix3D, pos:flash.geom:Vector3D, dir:flash.geom:Vector3D, up:flash.geom:Vector3D) — Static Method , class away3d.core.math.Matrix3DUtils
LookAtController — class, package away3d.controllers
 | Extended camera used to automatically look at a specified target object.
LookAtController(targetObject:away3d.entities:Entity, lookAtObject:away3d.containers:ObjectContainer3D) — Constructor, class away3d.controllers.LookAtController
 | Creates a new LookAtController object.
lookAtObject — Property, class away3d.animators.PathAnimator
 | sets the object that the animated object will be looking at along the path
_lookAtObject — Property, class away3d.controllers.LookAtController
lookAtObject — Property, class away3d.controllers.LookAtController
 | The 3d object that the target looks at.
_lookAtPosition — Property, class away3d.controllers.LookAtController
lookAtPosition — Property, class away3d.controllers.LookAtController
 | The Vector3D object that the target looks at.
loop — Property, interface away3d.materials.utils.IVideoPlayer
 | Indicates whether the player should loop when video finishes
loop — Property, class away3d.materials.utils.SimpleVideoPlayer
_looping — Property, class away3d.animators.nodes.AnimationClipNodeBase
looping — Property, class away3d.animators.nodes.AnimationClipNodeBase
 | Determines whether the contents of the animation node have looping characteristics enabled.
LZMA — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


M

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
M Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
magnitude — Property, class away3d.core.math.Quaternion
 | Returns the magnitude of the quaternion object.
_mainInputTexture — Property, class away3d.filters.tasks.Filter3DTaskBase
MAJOR_VERSION — Constant Static Property, class away3d.Away3D
mapFit — Property, class away3d.extrusions.PathExtrude
 | Defines if the texture(s) should be projected on the geometry evenly spreaded over the source bitmapdata or using distance/percent.
mapUrl(originalUrl:String, newUrl:String) — method, class away3d.loaders.misc.AssetLoaderContext
 | Map a URL to another URL, so that files that are referred to by the original URL will instead be loaded from the new URL.
mapUrlToData(originalUrl:String, data:any) — method, class away3d.loaders.misc.AssetLoaderContext
 | Map a URL to embedded data, so that instead of trying to load a dependency from the URL at which it's referenced, the dependency data will be retrieved straight from the memory instead.
markCellAccessible(indexX:uint, indexY:uint, indexZ:uint) — method, class away3d.core.partition.ViewVolume
 | Enable the use of a cell.
markCellInaccessible(indexX:uint, indexY:uint, indexZ:uint) — method, class away3d.core.partition.ViewVolume
 | Disables the use of a cell.
markForUpdate(entity:away3d.entities:Entity) — method, class away3d.core.partition.Partition3D
 | Mark a scene graph entity for updating.
markForUpdate(entity:away3d.entities:Entity) — method, class away3d.core.partition.ViewVolumePartition
mask — Property, class away3d.materials.methods.EnvMapMethod
mask — Property, class away3d.materials.methods.FresnelEnvMapMethod
mass — Property, class away3d.controllers.SpringController
 | Mass of the camera, if over 120 and it'll be very heavy to move.
material — Property, interface away3d.core.base.IMaterialOwner
 | The material with which to render the object.
_material — Property, class away3d.core.base.SubMesh
material — Property, class away3d.core.base.SubMesh
 | The material used to render the current SubMesh.
material — Property, class away3d.entities.Mesh
 | The material with which to render the Mesh.
material — Property, class away3d.entities.SegmentSet
material — Property, class away3d.entities.Sprite3D
material — Property, class away3d.events.MouseEvent3D
 | The material of the 3d element inside which the event took place.
_material — Property, class away3d.materials.passes.MaterialPassBase
material — Property, class away3d.materials.passes.MaterialPassBase
 | The material to which this pass belongs.
material — Property, class away3d.primitives.SkyBox
 | The material with which to render the object.
MATERIAL — Constant Static Property, class away3d.library.assets.AssetType
MaterialBase — class, package away3d.materials
 | MaterialBase forms an abstract base class for any material.
MaterialBase() — Constructor, class away3d.materials.MaterialBase
 | Creates a new MaterialBase object.
materialComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when a material asset has been constructed from a resource.
materialComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when a material asset has been constructed from a resource.
materialComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when a material asset has been constructed from a resource.
materialComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when a material asset has been constructed from a resource.
materialComplete — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when a material asset has been constructed from a resource.
materialComplete — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when a material asset has been constructed from a resource.
MATERIAL_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
materialHeight — Property, class away3d.textures.VideoTexture
materialId — Property, class away3d.core.data.RenderableListItem
MaterialPassBase — class, package away3d.materials.passes
 | MaterialPassBase provides an abstract base class for material shader passes.
MaterialPassBase(renderToTexture:Boolean) — Constructor, class away3d.materials.passes.MaterialPassBase
 | Creates a new MaterialPassBase object.
materials — Property, class away3d.extrusions.LatheExtrude
 | An optional object that defines left, right, front, back, top and bottom materials to be set on the resulting lathe extrusion.
materials — Property, class away3d.extrusions.LinearExtrude
 | An optional MultipleMaterials object that defines left, right, front, back, top and bottom materials to be set on the resulting lathe extrusion.
materials — Property, class away3d.extrusions.PathExtrude
 | An optional Vector.<MaterialBase>.
materials — Property, class away3d.loaders.parsers.DAEParser
materialWidth — Property, class away3d.textures.VideoTexture
MathConsts — class, package away3d.core.math
 | MathConsts provides some commonly used mathematical constants
_matrix — Property, class away3d.cameras.lenses.LensBase
matrix — Property, class away3d.cameras.lenses.LensBase
 | The projection matrix that transforms 3D geometry to normalized homogeneous coordinates.
_matrix — Property, class away3d.lights.shadowmaps.DirectionalShadowMapper
matrix2euler(m1:flash.geom:Matrix3D) — Static Method , class away3d.core.math.Vector3DUtils
 | Returns a Vector3D object with the euler angles represented by the 3x3 matrix rotation of the given Matrix3D object.
matrix2scale(m:flash.geom:Matrix3D) — Static Method , class away3d.core.math.Vector3DUtils
 | Returns a Vector3D object containing the scale values represented by the given Matrix3D object.
Matrix3DUtils — class, package away3d.core.math
 | Matrix3DUtils provides additional Matrix3D math functions.
MATRIX_CHANGED — Constant Static Property, class away3d.events.LensEvent
_matrixInvalid — Property, class away3d.cameras.lenses.LensBase
_max — Property, class away3d.bounds.BoundingVolumeBase
max — Property, class away3d.bounds.BoundingVolumeBase
 | The maximum extreme of the bounds
Max3DSParser — class, package away3d.loaders.parsers
Max3DSParser() — Constructor, class away3d.loaders.parsers.Max3DSParser
maxBlur — Property, class away3d.filters.HDepthOfFieldFilter3D
maxBlur — Property, class away3d.filters.VDepthOfFieldFilter3D
maxBlur — Property, class away3d.filters.tasks.Filter3DHDepthOfFFieldTask
maxBlur — Property, class away3d.filters.tasks.Filter3DVDepthOfFFieldTask
maxBlurX — Property, class away3d.filters.DepthOfFieldFilter3D
 | The maximum amount of horizontal blur.
maxBlurY — Property, class away3d.filters.DepthOfFieldFilter3D
 | The maximum amount of vertical blur.
maxBound — Property, class away3d.core.partition.ViewVolume
MAX_BOUND — Constant Static Property, class away3d.tools.commands.Mirror
maxDistance — Property, class away3d.materials.methods.FogMethod
maxElevation — Property, class away3d.extrusions.Elevation
 | Locks elevation factor above this color reading level.
max_fps — Property, class away3d.debug.AwayStats
maxPanAngle — Property, class away3d.controllers.HoverController
 | Maximum bounds for the panAngle.
max_ram — Property, class away3d.debug.AwayStats
maxScale — Property, class away3d.animators.states.ParticleScaleState
 | Defines the end scale of the state, when in global mode.
maxTiltAngle — Property, class away3d.controllers.FirstPersonController
 | Maximum bounds for the tiltAngle.
maxTiltAngle — Property, class away3d.controllers.HoverController
 | Maximum bounds for the tiltAngle.
MAX_VERTEX — Constant Static Property, class away3d.tools.helpers.ParticleGeometryHelper
maxX — Property, class away3d.cameras.lenses.OrthographicOffCenterLens
maxX — Property, class away3d.containers.ObjectContainer3D
 | The maximum extremum of the object along the X-axis.
maxX — Property, class away3d.core.partition.ViewVolume
maxX — Property, class away3d.entities.Entity
 | The maximum extremum of the object along the X-axis.
maxX — Static Property, class away3d.tools.utils.Bounds
maxY — Property, class away3d.cameras.lenses.OrthographicOffCenterLens
maxY — Property, class away3d.containers.ObjectContainer3D
 | The maximum extremum of the object along the Y-axis.
maxY — Property, class away3d.core.partition.ViewVolume
maxY — Property, class away3d.entities.Entity
 | The maximum extremum of the object along the Y-axis.
maxY — Static Property, class away3d.tools.utils.Bounds
maxZ — Property, class away3d.containers.ObjectContainer3D
 | The maximum extremum of the object along the Z-axis.
maxZ — Property, class away3d.core.partition.ViewVolume
maxZ — Property, class away3d.entities.Entity
 | The maximum extremum of the object along the Z-axis.
maxZ — Static Property, class away3d.tools.utils.Bounds
MD2Parser — class, package away3d.loaders.parsers
 | MD2Parser provides a parser for the MD2 data type.
MD2Parser(textureType:String, ignoreTexturePath:Boolean) — Constructor, class away3d.loaders.parsers.MD2Parser
 | Creates a new MD2Parser object.
MD5AnimParser — class, package away3d.loaders.parsers
 | AWDParser provides a parser for the AWD data type, providing an animation sequence for the md5 format.
MD5AnimParser(additionalRotationAxis:flash.geom:Vector3D, additionalRotationRadians:Number) — Constructor, class away3d.loaders.parsers.MD5AnimParser
 | Creates a new MD5AnimParser object.
MD5MeshParser — class, package away3d.loaders.parsers
 | AWDParser provides a parser for the md5mesh data type, providing the geometry of the md5 format.
MD5MeshParser(additionalRotationAxis:flash.geom:Vector3D, additionalRotationRadians:Number) — Constructor, class away3d.loaders.parsers.MD5MeshParser
 | Creates a new MD5MeshParser object.
Merge — class, package away3d.tools.commands
 | Class Merge merges two or more static meshes into one.Merge
Merge(keepMaterial:Boolean, disposeSources:Boolean, objectSpace:Boolean) — Constructor, class away3d.tools.commands.Merge
mesh — Property, class away3d.core.partition.MeshNode
 | The mesh object contained in the partition node.
Mesh — class, package away3d.entities
 | Mesh is an instance of a Geometry, augmenting it with a presence in the scene graph, a material, and an animation state.
Mesh(geometry:away3d.core.base:Geometry, material:away3d.materials:MaterialBase) — Constructor, class away3d.entities.Mesh
 | Create a new Mesh object.
MESH — Constant Static Property, class away3d.library.assets.AssetType
MESH_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
MeshDebug — class, package away3d.tools.helpers.data
 | MeshDebug, holds the data for the MeshDebugger class
MeshDebugger — class, package away3d.tools.helpers
 | Helper Class for Mesh objects MeshDebugger Displays the normals, tangents and vertexNormals of a given mesh.
meshes — Property, class away3d.extrusions.PathDuplicator
 | Defines an optional Vector.<Mesh>.
MeshHelper — class, package away3d.tools.helpers
 | Helper Class for the Mesh object MeshHelper A series of methods usually usefull for mesh manipulations
MeshNode — class, package away3d.core.partition
 | MeshNode is a space partitioning leaf node that contains a Mesh object.
MeshNode(mesh:away3d.entities:Mesh) — Constructor, class away3d.core.partition.MeshNode
 | Creates a new MeshNode object.
message — Property, class away3d.events.LoaderEvent
 | The error string on loadError.
message — Property, class away3d.events.ParserEvent
 | Additional human-readable message.
method — Property, class away3d.materials.methods.MethodVOSet
MethodDependencyCounter — class, package away3d.materials.compilation
MethodDependencyCounter() — Constructor, class away3d.materials.compilation.MethodDependencyCounter
_methods — Property, class away3d.materials.methods.ShaderMethodSetup
_methodSetup — Property, class away3d.materials.compilation.ShaderCompiler
methodSetup — Property, class away3d.materials.compilation.ShaderCompiler
_methodSetup — Property, class away3d.materials.passes.CompiledPass
MethodVO — class, package away3d.materials.methods
MethodVOSet — class, package away3d.materials.methods
MethodVOSet(method:away3d.materials.methods:EffectMethodBase) — Constructor, class away3d.materials.methods.MethodVOSet
_min — Property, class away3d.bounds.BoundingVolumeBase
min — Property, class away3d.bounds.BoundingVolumeBase
 | The minimum extreme of the bounds
minBound — Property, class away3d.core.partition.ViewVolume
MIN_BOUND — Constant Static Property, class away3d.tools.commands.Mirror
minDistance — Property, class away3d.materials.methods.FogMethod
minElevation — Property, class away3d.extrusions.Elevation
 | Locks elevation factor beneath this color reading level.
MINOR_VERSION — Constant Static Property, class away3d.Away3D
minPanAngle — Property, class away3d.controllers.HoverController
 | Minimum bounds for the panAngle.
minScale — Property, class away3d.animators.states.ParticleScaleState
 | Defines the end scale of the state, when in global mode.
minTiltAngle — Property, class away3d.controllers.FirstPersonController
 | Minimum bounds for the tiltAngle.
minTiltAngle — Property, class away3d.controllers.HoverController
 | Minimum bounds for the tiltAngle.
minX — Property, class away3d.cameras.lenses.OrthographicOffCenterLens
minX — Property, class away3d.containers.ObjectContainer3D
 | The minimum extremum of the object along the X-axis.
minX — Property, class away3d.core.partition.ViewVolume
minX — Property, class away3d.entities.Entity
 | The minimum extremum of the object along the X-axis.
minX — Static Property, class away3d.tools.utils.Bounds
minY — Property, class away3d.cameras.lenses.OrthographicOffCenterLens
minY — Property, class away3d.containers.ObjectContainer3D
 | The minimum extremum of the object along the Y-axis.
minY — Property, class away3d.core.partition.ViewVolume
minY — Property, class away3d.entities.Entity
 | The minimum extremum of the object along the Y-axis.
minY — Static Property, class away3d.tools.utils.Bounds
minZ — Property, class away3d.containers.ObjectContainer3D
 | The minimum extremum of the object along the Z-axis.
minZ — Property, class away3d.core.partition.ViewVolume
minZ — Property, class away3d.entities.Entity
 | The minimum extremum of the object along the Z-axis.
minZ — Static Property, class away3d.tools.utils.Bounds
_mipmap — Property, class away3d.materials.MaterialBase
mipmap — Property, class away3d.materials.MaterialBase
 | Indicates whether or not any used textures should use mipmapping.
mipmap — Property, class away3d.materials.MultiPassMaterialBase
 | Indicates whether or not any used textures should use mipmapping.
mipmap — Property, class away3d.materials.SinglePassMaterialBase
 | Indicates whether or not any used textures should use mipmapping.
_mipmap — Property, class away3d.materials.compilation.ShaderCompiler
mipmap — Property, class away3d.materials.passes.CompiledPass
 | Defines whether any used textures should use mipmapping.
_mipmap — Property, class away3d.materials.passes.MaterialPassBase
mipmap — Property, class away3d.materials.passes.MaterialPassBase
 | Defines whether any used textures should use mipmapping.
MipmapGenerator — class, package away3d.materials.utils
 | MipmapGenerator is a helper class that uploads BitmapData to a Texture including mipmap levels.
Mirror — class, package away3d.tools.commands
Mirror(recenter:Boolean, duplicate:Boolean) — Constructor, class away3d.tools.commands.Mirror
MIX — Constant Static Property, class away3d.materials.methods.ProjectiveTextureMethod
MIX — Constant Static Property, class away3d.materials.methods.RimLightMethod
_mode — Property, class away3d.animators.nodes.ParticleNodeBase
mode — Property, class away3d.animators.nodes.ParticleNodeBase
 | Returns the property mode of the particle animation node.
mode — Property, class away3d.materials.methods.ProjectiveTextureMethod
 | The blend mode with which the texture is blended unto the object.
modelViewProjection — Property, interface away3d.core.base.IRenderable
 | The model-view-projection (MVP) matrix used to transform from model to homogeneous projection space.
modelViewProjection — Property, class away3d.core.base.SubMesh
 | The model-view-projection (MVP) matrix used to transform from model to homogeneous projection space.
modelViewProjection — Property, class away3d.entities.Entity
 | The current model-view-projection (MVP) matrix - the one on the top of the stack - used to transform from model to homogeneous projection space.
_modulateMethod — Property, class away3d.materials.methods.LightingMethodBase
 | A method that is exposed to wrappers in case the strength needs to be controlled
MORE_TO_PARSE — Constant Static Property, class away3d.loaders.parsers.ParserBase
 | Returned by proceedParsing to indicate more parsing is needed, allowing asynchronous parsing.
MotionBlurFilter3D — class, package away3d.filters
MotionBlurFilter3D(strength:Number) — Constructor, class away3d.filters.MotionBlurFilter3D
_mouse3DManager — Property, class away3d.containers.View3D
Mouse3DManager — class, package away3d.core.managers
 | Mouse3DManager enforces a singleton pattern and is not intended to be instanced.
Mouse3DManager() — Constructor, class away3d.core.managers.Mouse3DManager
 | Creates a new Mouse3DManager object.
mouseChildren — Property, class away3d.containers.ObjectContainer3D
MOUSE_DOWN — Constant Static Property, class away3d.events.MouseEvent3D
 | Defines the value of the type property of a mouseDown3d event object.
mouseDown3d — Event, class away3d.containers.ObjectContainer3D
 | Dispatched when a user presses the left hand mouse button while the cursor is over the 3d object.
_mouseEnabled — Property, class away3d.containers.ObjectContainer3D
mouseEnabled — Property, class away3d.containers.ObjectContainer3D
 | Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing.
mouseEnabled — Property, interface away3d.core.base.IRenderable
 | Indicates whether the IRenderable should trigger mouse events, and hence should be rendered for hit testing.
mouseEnabled — Property, class away3d.core.base.SubMesh
 | Indicates whether the SubMesh should trigger mouse events, and hence should be rendered for hit testing.
mouseEnabled — Property, class away3d.entities.SegmentSet
MouseEvent3D — class, package away3d.events
 | A MouseEvent3D is dispatched when a mouse event occurs over a mouseEnabled object in View3D.
MouseEvent3D(type:String) — Constructor, class away3d.events.MouseEvent3D
 | Create a new MouseEvent3D object.
MOUSE_MOVE — Constant Static Property, class away3d.events.MouseEvent3D
 | Defines the value of the type property of a mouseMove3d event object.
mouseMove3d — Event, class away3d.containers.ObjectContainer3D
 | Dispatched when a user moves the cursor while it is over the 3d object.
MOUSE_OUT — Constant Static Property, class away3d.events.MouseEvent3D
 | Defines the value of the type property of a mouseOut3d event object.
mouseOut3d — Event, class away3d.containers.ObjectContainer3D
 | Dispatched when a user moves the cursor away from the 3d object.
MOUSE_OVER — Constant Static Property, class away3d.events.MouseEvent3D
 | Defines the value of the type property of a mouseOver3d event object.
mouseOver3d — Event, class away3d.containers.ObjectContainer3D
 | Dispatched when a user moves the cursor over the 3d object.
mousePicker — Property, class away3d.containers.View3D
mousePicker — Property, class away3d.core.managers.Mouse3DManager
MOUSE_UP — Constant Static Property, class away3d.events.MouseEvent3D
 | Defines the value of the type property of a mouseUp3d event object.
mouseUp3d — Event, class away3d.containers.ObjectContainer3D
 | Dispatched when a user releases the left hand mouse button while the cursor is over the 3d object.
MOUSE_WHEEL — Constant Static Property, class away3d.events.MouseEvent3D
 | Defines the value of the type property of a mouseWheel3d event object.
moveBackward(distance:Number) — method, class away3d.core.base.Object3D
 | Moves the 3d object backwards along it's local z axis
moveDown(distance:Number) — method, class away3d.core.base.Object3D
 | Moves the 3d object backwards along it's local y axis
moveForward(distance:Number) — method, class away3d.core.base.Object3D
 | Moves the 3d object forwards along it's local z axis
moveLeft(distance:Number) — method, class away3d.core.base.Object3D
 | Moves the 3d object backwards along it's local x axis
movePivot(dx:Number, dy:Number, dz:Number) — method, class away3d.core.base.Object3D
 | Moves the local point around which the object rotates.
moveRight(distance:Number) — method, class away3d.core.base.Object3D
 | Moves the 3d object forwards along it's local x axis
moveTo(dx:Number, dy:Number, dz:Number) — method, class away3d.core.base.Object3D
 | Moves the 3d object directly to a point in space
moveUp(distance:Number) — method, class away3d.core.base.Object3D
 | Moves the 3d object forwards along it's local y axis
MultiPassMaterialBase — class, package away3d.materials
 | DefaultMaterialBase forms an abstract base class for the default materials provided by Away3D and use methods to define their appearance.
MultiPassMaterialBase() — Constructor, class away3d.materials.MultiPassMaterialBase
 | Creates a new DefaultMaterialBase object.
MultipleMaterials — class, package away3d.materials.utils
MultipleMaterials(front:away3d.materials:MaterialBase, back:away3d.materials:MaterialBase, left:away3d.materials:MaterialBase, right:away3d.materials:MaterialBase, top:away3d.materials:MaterialBase) — Constructor, class away3d.materials.utils.MultipleMaterials
 | Creates a new MultipleMaterials object.
multiply(qa:away3d.core.math:Quaternion, qb:away3d.core.math:Quaternion) — method, class away3d.core.math.Quaternion
 | Fills the quaternion object with the result from a multiplication of two quaternion objects.
MULTIPLY — Constant Static Property, class away3d.materials.methods.LightMapDiffuseMethod
MULTIPLY — Constant Static Property, class away3d.materials.methods.LightMapMethod
MULTIPLY — Constant Static Property, class away3d.materials.methods.ProjectiveTextureMethod
MULTIPLY — Constant Static Property, class away3d.materials.methods.RimLightMethod
multiplyVector(vector:flash.geom:Vector3D, target:away3d.core.math:Quaternion) — method, class away3d.core.math.Quaternion
_mute — Property, class away3d.audio.drivers.AbstractSound3DDriver
mute — Property, class away3d.audio.drivers.AbstractSound3DDriver
mute — Property, interface away3d.audio.drivers.ISound3DDriver
 | Mutes/unmutes the driver completely, which is typically only done (internally by Sound3D) whenever the sound source is removed from the scene.
mute — Property, interface away3d.materials.utils.IVideoPlayer
 | Mutes/unmutes the video's audio.
mute — Property, class away3d.materials.utils.SimpleVideoPlayer
_mvpIndex — Property, class away3d.entities.Entity
_mvpTransformStack — Property, class away3d.entities.Entity
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


N

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
N Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
_name — Property, class away3d.animators.AnimatorBase
name — Property, class away3d.animators.data.JointPose
 | The name of the joint to which the pose is associated
name — Property, class away3d.animators.data.SkeletonJoint
 | The name of the joint
name — Property, interface away3d.library.assets.IAsset
name — Property, class away3d.library.assets.NamedAssetBase
_name — Property, class away3d.materials.MaterialBase
name — Property, class away3d.materials.MaterialBase
name — Property, class away3d.materials.lightpickers.LightPickerBase
NamedAssetBase — class, package away3d.library.assets
NamedAssetBase(name:String) — Constructor, class away3d.library.assets.NamedAssetBase
near — Property, class away3d.cameras.lenses.FreeMatrixLens
_near — Property, class away3d.cameras.lenses.LensBase
near — Property, class away3d.cameras.lenses.LensBase
 | The distance to the near plane of the frustum.
near — Property, class away3d.cameras.lenses.ObliqueNearPlaneLens
NearDirectionalShadowMapper — class, package away3d.lights.shadowmaps
NearDirectionalShadowMapper(coverageRatio:Number) — Constructor, class away3d.lights.shadowmaps.NearDirectionalShadowMapper
nearPlaneDistance — Property, class away3d.textures.CubeReflectionTexture
 | The near plane used by the camera lens.
nearPlaneDistances — Property, class away3d.lights.shadowmaps.CascadeShadowMapper
NearShadowMapMethod — class, package away3d.materials.methods
NearShadowMapMethod(baseMethod:away3d.materials.methods:SimpleShadowMapMethodBase, fadeRatio:Number) — Constructor, class away3d.materials.methods.NearShadowMapMethod
needFragmentAnimation — Property, class away3d.animators.data.AnimationRegisterCache
_needFragmentAnimation — Property, class away3d.materials.passes.MaterialPassBase
needFragmentAnimation — Property, class away3d.materials.passes.MaterialPassBase
needsGlobalFragmentPos — Property, class away3d.materials.methods.MethodVO
needsGlobalVertexPos — Property, class away3d.materials.methods.MethodVO
needsNormals — Property, class away3d.materials.methods.MethodVO
needsProjection — Property, class away3d.materials.methods.MethodVO
needsSecondaryUV — Property, class away3d.materials.methods.MethodVO
needsTangents — Property, class away3d.materials.methods.MethodVO
needsUV — Property, class away3d.materials.methods.MethodVO
needsView — Property, class away3d.materials.methods.MethodVO
_needUpdateTime — Property, class away3d.animators.states.ParticleStateBase
needUpdateTime — Property, class away3d.animators.states.ParticleStateBase
needUVAnimation — Property, class away3d.animators.data.AnimationRegisterCache
_needUVAnimation — Property, class away3d.materials.compilation.ShaderCompiler
needUVAnimation — Property, class away3d.materials.compilation.ShaderCompiler
_needUVAnimation — Property, class away3d.materials.passes.MaterialPassBase
needUVAnimation — Property, class away3d.materials.passes.MaterialPassBase
needVelocity — Property, class away3d.animators.ParticleAnimationSet
needVelocity — Property, class away3d.animators.data.AnimationRegisterCache
NEGATIVE — Constant Static Property, class away3d.tools.commands.Align
negativeX — Property, class away3d.textures.BitmapCubeTexture
 | The texture on the cube's left face.
negativeY — Property, class away3d.textures.BitmapCubeTexture
 | The texture on the cube's bottom face.
negativeZ — Property, class away3d.textures.BitmapCubeTexture
 | The texture on the cube's near face.
next — Property, class away3d.core.data.EntityListItem
next — Property, class away3d.core.data.RenderableListItem
next() — method, class away3d.core.traverse.SceneIterator
next() — method, class away3d.library.utils.AssetLibraryIterator
_nextFrame — Property, class away3d.animators.states.AnimationClipState
nextFrame — Property, class away3d.animators.states.AnimationClipState
 | Returns the next frame of animation in the clip based on the internal playhead position.
nextGeometry — Property, interface away3d.animators.states.IVertexAnimationState
 | Returns the current geometry frame of animation in the clip based on the internal playhead position.
nextGeometry — Property, class away3d.animators.states.VertexClipState
 | Returns the current geometry frame of animation in the clip based on the internal playhead position.
nextPose — Property, class away3d.animators.states.SkeletonClipState
 | Returns the next skeleton pose frame of animation in the clip based on the internal playhead position.
nextUVFrame — Property, interface away3d.animators.states.IUVAnimationState
 | Returns the next UV frame of animation in the clip based on the internal playhead position.
nextUVFrame — Property, class away3d.animators.states.UVClipState
 | Returns the next UV frame of animation in the clip based on the internal playhead position.
NodeBase — class, package away3d.core.partition
 | The NodeBase class is an abstract base class for any type of space partition tree node.
NodeBase() — Constructor, class away3d.core.partition.NodeBase
 | Creates a new NodeBase object.
_nonCasterLightPasses — Property, class away3d.materials.MultiPassMaterialBase
_normalBufferIndex — Property, class away3d.materials.compilation.ShaderCompiler
normalBufferIndex — Property, class away3d.materials.compilation.ShaderCompiler
_normalBufferIndex — Property, class away3d.materials.passes.CompiledPass
normalDependencies — Property, class away3d.materials.compilation.MethodDependencyCounter
normalDisplacement — Property, class away3d.materials.methods.FresnelPlanarReflectionMethod
normalDisplacement — Property, class away3d.materials.methods.PlanarReflectionMethod
 | The amount of displacement on the surface, for use with water waves.
normalFragment — Property, class away3d.materials.compilation.ShaderRegisterData
normalInput — Property, class away3d.materials.compilation.ShaderRegisterData
normalize() — method, class away3d.core.math.Plane3D
 | Normalize this Plane3D
normalize(val:Number) — method, class away3d.core.math.Quaternion
 | Normalises the quaternion object.
normalMap — Property, class away3d.materials.MultiPassMaterialBase
 | The tangent space normal map to influence the direction of the surface for each texel.
normalMap — Property, class away3d.materials.SinglePassMaterialBase
 | The tangent space normal map to influence the direction of the surface for each texel.
normalMap — Property, class away3d.materials.methods.BasicNormalMethod
normalMap — Property, class away3d.materials.methods.SimpleWaterNormalMethod
normalMap — Property, class away3d.materials.passes.CompiledPass
 | The tangent space normal map to influence the direction of the surface for each texel.
normalMethod — Property, class away3d.materials.MultiPassMaterialBase
 | The method to generate the (tangent-space) normal.
normalMethod — Property, class away3d.materials.SinglePassMaterialBase
 | The method to generate the (tangent-space) normal.
_normalMethod — Property, class away3d.materials.methods.ShaderMethodSetup
normalMethod — Property, class away3d.materials.methods.ShaderMethodSetup
normalMethod — Property, class away3d.materials.passes.CompiledPass
_normalMethodVO — Property, class away3d.materials.methods.ShaderMethodSetup
normalReflectance — Property, class away3d.materials.methods.FresnelEnvMapMethod
 | The minimum amount of reflectance, ie the reflectance when the view direction is normal to the surface or light direction.
normalReflectance — Property, class away3d.materials.methods.FresnelPlanarReflectionMethod
 | The minimum amount of reflectance, ie the reflectance when the view direction is normal to the surface or light direction.
normalReflectance — Property, class away3d.materials.methods.FresnelSpecularMethod
 | The minimum amount of reflectance, ie the reflectance when the view direction is normal to the surface or light direction.
_normalsInvalid — Property, class away3d.core.base.SubGeometry
_normalTextureRegister — Property, class away3d.materials.methods.BasicNormalMethod
normalVarying — Property, class away3d.materials.compilation.ShaderRegisterData
notifyUpdate() — method, class away3d.controllers.ControllerBase
NullBounds — class, package away3d.bounds
 | NullBounds represents a debug bounding "volume" that is either considered always in, or always out of the frustum.
NullBounds(alwaysIn:Boolean, renderable:away3d.primitives:WireframePrimitiveBase) — Constructor, class away3d.bounds.NullBounds
nullify() — method, class away3d.bounds.AxisAlignedBoundingBox
 | Sets the bounds to zero size.
nullify() — method, class away3d.bounds.BoundingSphere
 | Sets the bounds to zero size.
nullify() — method, class away3d.bounds.BoundingVolumeBase
 | Sets the bounds to zero size.
NullNode — class, package away3d.core.partition
 | NullNode is a node that performs no space partitioning, but simply stores all objects in a list of leaf nodes.
NullNode() — Constructor, class away3d.core.partition.NullNode
 | Creates a new NullNode object.
numAssets — Property, class away3d.library.utils.AssetLibraryIterator
numCascades — Property, class away3d.lights.shadowmaps.CascadeShadowMapper
_numCastingDirectionalLights — Property, class away3d.materials.lightpickers.LightPickerBase
numCastingDirectionalLights — Property, class away3d.materials.lightpickers.LightPickerBase
 | The maximum amount of directional lights that cast shadows
_numCastingPointLights — Property, class away3d.materials.lightpickers.LightPickerBase
numCastingPointLights — Property, class away3d.materials.lightpickers.LightPickerBase
 | The amount of point lights that cast shadows
numCellsX — Property, class away3d.core.partition.DynamicGrid
numCellsX — Property, class away3d.core.partition.ViewVolume
numCellsY — Property, class away3d.core.partition.DynamicGrid
numCellsY — Property, class away3d.core.partition.ViewVolume
numCellsZ — Property, class away3d.core.partition.DynamicGrid
numCellsZ — Property, class away3d.core.partition.ViewVolume
_numChildNodes — Property, class away3d.core.partition.NodeBase
numChildren — Property, class away3d.containers.ObjectContainer3D
 | The amount of child objects of the ObjectContainer3D.
numChildren — Property, class away3d.containers.Scene3D
 | The amount of children directly contained by the scene.
numColumns — Property, class away3d.animators.nodes.ParticleSpriteSheetNode
 | Defines the number of columns in the spritesheet, when in global mode.
numCondensedJoints — Property, class away3d.core.base.SkinnedSubGeometry
 | The amount of joints used when joint indices have been condensed.
_numDirectionalLights — Property, class away3d.materials.compilation.ShaderCompiler
numDirectionalLights — Property, class away3d.materials.compilation.ShaderCompiler
_numDirectionalLights — Property, class away3d.materials.lightpickers.LightPickerBase
numDirectionalLights — Property, class away3d.materials.lightpickers.LightPickerBase
 | The maximum amount of directional lights that will be provided
_numDirectionalLights — Property, class away3d.materials.passes.CompiledPass
numDirectionalLights — Property, class away3d.materials.passes.CompiledPass
_numEntities — Property, class away3d.core.partition.NodeBase
numEntities — Property, class away3d.core.partition.NodeBase
_numEntities — Property, class away3d.core.pick.RaycastPicker
_numEntities — Property, class away3d.core.traverse.EntityCollector
numFragmentConstant — Property, class away3d.animators.data.AnimationRegisterCache
_numFrames — Property, class away3d.animators.nodes.AnimationClipNodeBase
_numIndices — Property, class away3d.core.base.SubGeometryBase
numInputs — Property, class away3d.animators.nodes.SkeletonNaryLERPNode
numJointPoses — Property, class away3d.animators.data.SkeletonPose
 | The total number of joint poses in the skeleton pose.
numJoints — Property, class away3d.animators.data.Skeleton
 | The total number of joints in the skeleton.
_numLightProbes — Property, class away3d.materials.compilation.ShaderCompiler
numLightProbes — Property, class away3d.materials.compilation.ShaderCompiler
_numLightProbes — Property, class away3d.materials.lightpickers.LightPickerBase
numLightProbes — Property, class away3d.materials.lightpickers.LightPickerBase
 | The maximum amount of light probes that will be provided
_numLightProbes — Property, class away3d.materials.passes.CompiledPass
numLightProbes — Property, class away3d.materials.passes.CompiledPass
_numLights — Property, class away3d.core.traverse.EntityCollector
_numLights — Property, class away3d.materials.compilation.ShaderCompiler
numLights — Property, class away3d.materials.methods.MethodVO
numMethods — Property, class away3d.materials.MultiPassMaterialBase
numMethods — Property, class away3d.materials.SinglePassMaterialBase
numMethods — Property, class away3d.materials.methods.ShaderMethodSetup
numMethods — Property, class away3d.materials.passes.SuperShaderPass
_numMouseEnableds — Property, class away3d.core.traverse.EntityCollector
numMouseEnableds — Property, class away3d.core.traverse.EntityCollector
 | The amount of IRenderable objects that are mouse-enabled.
numParticles — Property, class away3d.core.base.ParticleGeometry
_numPasses — Property, class away3d.materials.MaterialBase
_numPointLights — Property, class away3d.materials.compilation.ShaderCompiler
numPointLights — Property, class away3d.materials.compilation.ShaderCompiler
_numPointLights — Property, class away3d.materials.lightpickers.LightPickerBase
numPointLights — Property, class away3d.materials.lightpickers.LightPickerBase
 | The maximum amount of point lights that will be provided
_numPointLights — Property, class away3d.materials.passes.CompiledPass
numPointLights — Property, class away3d.materials.passes.CompiledPass
numPoses — Property, class away3d.animators.VertexAnimationSet
 | Returns the number of poses made available at once to the GPU animation code.
_numProbeRegisters — Property, class away3d.materials.compilation.ShaderCompiler
numProcessedVertices — Property, class away3d.animators.data.AnimationSubGeometry
numProxySlotsFree — Property, class away3d.core.managers.Stage3DManager
 | Returns the amount of stage3DProxy objects that can be created and managed by the class
numProxySlotsTotal — Property, class away3d.core.managers.Stage3DManager
 | Returns the maximum amount of Stage3DProxy objects that can be managed by the class
numProxySlotsUsed — Property, class away3d.core.managers.Stage3DManager
 | Returns the amount of Stage3DProxy objects currently managed by the class.
numRows — Property, class away3d.animators.nodes.ParticleSpriteSheetNode
 | Defines the number of rows in the spritesheet, when in global mode.
numSamples — Property, class away3d.materials.methods.DitheredShadowMapMethod
numSamples — Property, class away3d.materials.methods.SoftShadowMapMethod
numSegments — Property, interface away3d.paths.IPath
 | The number of CubicPathSegment instances in the path.
numSegments — Property, class away3d.paths.SegmentedPathBase
 | The number of segments in the Path
NumSuffixConflictStrategy — class, package away3d.library.naming
NumSuffixConflictStrategy(separator:String) — Constructor, class away3d.library.naming.NumSuffixConflictStrategy
numTextures — Property, class away3d.textures.ATFData
numTriangles — Property, interface away3d.core.base.IRenderable
 | The amount of triangles that comprise the IRenderable geometry.
numTriangles — Property, interface away3d.core.base.ISubGeometry
 | The amount of triangles that comprise the IRenderable geometry.
_numTriangles — Property, class away3d.core.base.SubGeometryBase
numTriangles — Property, class away3d.core.base.SubGeometryBase
 | The total amount of triangles in the SubGeometry.
numTriangles — Property, class away3d.core.base.SubMesh
 | The amount of triangles that make up this SubMesh.
_numTriangles — Property, class away3d.core.traverse.EntityCollector
numTriangles — Property, class away3d.core.traverse.EntityCollector
 | The total number of triangles collected, and which will be pushed to the render engine.
numTriangles — Property, class away3d.entities.SegmentSet
numTriangles — Property, class away3d.entities.Sprite3D
numTriangles — Property, class away3d.primitives.SkyBox
 | The amount of triangles that comprise the SkyBox geometry.
numUsedFragmentConstants — Property, class away3d.materials.compilation.ShaderCompiler
_numUsedFragmentConstants — Property, class away3d.materials.compilation.ShaderRegisterCache
numUsedFragmentConstants — Property, class away3d.materials.compilation.ShaderRegisterCache
 | The amount of used fragment constant registers.
_numUsedFragmentConstants — Property, class away3d.materials.passes.MaterialPassBase
numUsedFragmentConstants — Property, class away3d.materials.passes.MaterialPassBase
numUsedStreams — Property, class away3d.materials.compilation.ShaderCompiler
numUsedStreams — Property, class away3d.materials.compilation.ShaderRegisterCache
 | The amount of used vertex streams.
_numUsedStreams — Property, class away3d.materials.passes.MaterialPassBase
numUsedStreams — Property, class away3d.materials.passes.MaterialPassBase
 | The amount of used vertex streams in the vertex code.
numUsedTextures — Property, class away3d.materials.compilation.ShaderCompiler
numUsedTextures — Property, class away3d.materials.compilation.ShaderRegisterCache
_numUsedTextures — Property, class away3d.materials.passes.MaterialPassBase
numUsedVaryings — Property, class away3d.materials.compilation.ShaderCompiler
numUsedVaryings — Property, class away3d.materials.compilation.ShaderRegisterCache
_numUsedVaryings — Property, class away3d.materials.passes.MaterialPassBase
numUsedVaryings — Property, class away3d.materials.passes.MaterialPassBase
numUsedVertexConstants — Property, class away3d.materials.compilation.ShaderCompiler
_numUsedVertexConstants — Property, class away3d.materials.compilation.ShaderRegisterCache
numUsedVertexConstants — Property, class away3d.materials.compilation.ShaderRegisterCache
 | The amount of used vertex constant registers.
_numUsedVertexConstants — Property, class away3d.materials.passes.MaterialPassBase
numUsedVertexConstants — Property, class away3d.materials.passes.MaterialPassBase
 | The amount of used vertex constants in the vertex code.
numVertexConstant — Property, class away3d.animators.data.AnimationRegisterCache
numVertices — Property, class away3d.animators.data.AnimationSubGeometry
numVertices — Property, class away3d.animators.data.ParticleAnimationData
_numVertices — Property, class away3d.core.base.CompactSubGeometry
numVertices — Property, class away3d.core.base.CompactSubGeometry
numVertices — Property, interface away3d.core.base.IRenderable
 | The total amount of vertices in the SubGeometry.
numVertices — Property, interface away3d.core.base.ISubGeometry
 | The total amount of vertices in the SubGeometry.
_numVertices — Property, class away3d.core.base.SubGeometry
numVertices — Property, class away3d.core.base.SubGeometry
 | The total amount of vertices in the SubGeometry.
numVertices — Property, class away3d.core.base.SubMesh
numVertices — Property, class away3d.core.base.data.ParticleData
numVertices — Property, class away3d.entities.SegmentSet
numVertices — Property, class away3d.entities.Sprite3D
numVertices — Property, class away3d.primitives.SkyBox
NURBSGeometry — class, package away3d.primitives
 | A NURBS primitive geometry.
NURBSGeometry(cNet:Vector$away3d.primitives.data:NURBSVertex, uCtrlPnts:int, vCtrlPnts:int, uOrder:int, vOrder:int, uSegments:int, vSegments:int, uKnot:Vector$Number, vKnot:Vector$Number) — Constructor, class away3d.primitives.NURBSGeometry
 | NURBS primitive generates a segmented mesh that fits the curved surface defined by the specified control points based on weighting, order influence and knot sequence
NURBSVertex — class, package away3d.primitives.data
 | A nurbvertex that simply extends vertex with a w weight property.
NURBSVertex(x:Number, y:Number, z:Number, w:Number) — Constructor, class away3d.primitives.data.NURBSVertex
 | Creates a new Vertex object.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


O

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
O Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
object — Property, class away3d.events.MouseEvent3D
 | The 3d object inside which the event took place.
object — Property, class away3d.events.Object3DEvent
 | A reference to the 3d object that is relevant to the event.
object3d — Property, class away3d.tools.utils.Drag3D
 | Sets the target ObjectContainer3D to the class.
Object3D — class, package away3d.core.base
 | Object3D provides a base class for any 3D object that has a (local) transformation. Standard Transform: The standard order for transformation is [parent transform] (Translate+Pivot) (Rotate) (-Pivot) (Scale) [child transform] This is the order of matrix multiplications, left-to-right.
Object3D() — Constructor, class away3d.core.base.Object3D
 | Creates an Object3D object.
Object3DEvent — class, package away3d.events
 | Passed as a parameter when a 3d object event occurs
Object3DEvent(type:String, object:away3d.core.base:Object3D) — Constructor, class away3d.events.Object3DEvent
 | Creates a new MaterialEvent object.
objectContainer3D — Property, class away3d.events.Scene3DEvent
ObjectContainer3D — class, package away3d.containers
 | ObjectContainer3D is the most basic scene graph node.
ObjectContainer3D() — Constructor, class away3d.containers.ObjectContainer3D
 | Creates a new ObjectContainer3D object.
objectSpace — Property, class away3d.tools.commands.Merge
 | Defines if mesh2 is merged using its objectSpace.
objectSpace — Property, class away3d.tools.utils.Grid
 | Defines if the grid unit is applied in objectspace or worldspace.
OBJParser — class, package away3d.loaders.parsers
 | OBJParser provides a parser for the OBJ data type.
OBJParser(scale:Number) — Constructor, class away3d.loaders.parsers.OBJParser
 | Creates a new OBJParser object.
ObliqueNearPlaneLens — class, package away3d.cameras.lenses
ObliqueNearPlaneLens(baseLens:away3d.cameras.lenses:LensBase, plane:away3d.core.math:Plane3D) — Constructor, class away3d.cameras.lenses.ObliqueNearPlaneLens
Octree — class, package away3d.core.partition
Octree(maxDepth:int, size:Number) — Constructor, class away3d.core.partition.Octree
OctreeNode — class, package away3d.core.partition
OctreeNode(maxDepth:int, size:Number, centerX:Number, centerY:Number, centerZ:Number, depth:int) — Constructor, class away3d.core.partition.OctreeNode
offset(startTime:int) — method, class away3d.animators.states.AnimationStateBase
 | Resets the start time of the node to a new value.
offset(startTime:int) — method, interface away3d.animators.states.IAnimationState
offsetCenter — Property, class away3d.tools.utils.Drag3D
 | Defines an offset for the drag from center mesh to mouse position.
offsetMouseCenter — Property, class away3d.tools.utils.Drag3D
 | getIntersect method returns the 3d point in space (Vector3D) where mouse hits the given plane.
offsetRadius — Property, class away3d.extrusions.LatheExtrude
 | Defines an offset radius applied to the profile.
offsetU — Property, class away3d.animators.data.UVAnimationFrame
 | The u-component offset of the UV animation frame.
offsetU — Property, class away3d.core.base.SubMesh
offsetV — Property, class away3d.animators.data.UVAnimationFrame
 | The v-component offset of the UV animation frame.
offsetV — Property, class away3d.core.base.SubMesh
offsetX — Property, class away3d.tools.utils.ColorHitMap
 | The offsetX, offsetY by default offsetX and offsetY represent the center of the map.
offsetY — Property, class away3d.tools.utils.ColorHitMap
_oldFrame — Property, class away3d.animators.states.AnimationClipState
_oneData — Property, class away3d.animators.nodes.ParticleNodeBase
oneData — Property, class away3d.animators.nodes.ParticleNodeBase
 | Returns the generated data vector of the node after one particle pass during the generation of all local static data of the particle animation set.
ONE_VECTOR — Constant Static Property, class away3d.materials.passes.SegmentPass
onInterval(event:flash.events:TimerEvent) — method, class away3d.loaders.parsers.ParserBase
 | Called when the parsing pause interval has passed and parsing can proceed.
_opaqueRenderableHead — Property, class away3d.core.traverse.EntityCollector
opaqueRenderableHead — Property, class away3d.core.traverse.EntityCollector
 | The list of opaque IRenderable objects that are considered potentially visible.
ORBIT_VECTOR3D — Constant Static Property, class away3d.animators.nodes.ParticleOrbitNode
 | Reference for orbit node properties on a single particle (when in local property mode).
orientation — Property, class away3d.animators.PathAnimator
 | returns the actual interpolated rotation along the path.
orientation — Property, class away3d.animators.data.JointPose
 | The rotation of the pose stored as a quaternion
orientation — Property, class away3d.primitives.WireframePlane
 | The orientaion in which the plane lies.
ORIENTATION_XY — Constant Static Property, class away3d.primitives.WireframePlane
ORIENTATION_XZ — Constant Static Property, class away3d.primitives.WireframePlane
ORIENTATION_YZ — Constant Static Property, class away3d.primitives.WireframePlane
orig — Property, class away3d.tools.utils.Ray
 | Defines the origin point of the Ray object
_origin — Property, class away3d.controllers.LookAtController
originalName — Property, class away3d.library.assets.NamedAssetBase
 | The original name used for this asset in the resource (e.g.
OrthographicLens — class, package away3d.cameras.lenses
 | The PerspectiveLens object provides a projection matrix that projects 3D geometry isometrically.
OrthographicLens(projectionHeight:Number) — Constructor, class away3d.cameras.lenses.OrthographicLens
 | Creates a new OrthogonalLens object.
OrthographicOffCenterLens — class, package away3d.cameras.lenses
 | The PerspectiveLens object provides a projection matrix that projects 3D geometry isometrically.
OrthographicOffCenterLens(minX:Number, maxX:Number, minY:Number, maxY:Number) — Constructor, class away3d.cameras.lenses.OrthographicOffCenterLens
 | Creates a new OrthogonalLens object.
oscillator — Property, class away3d.animators.states.ParticleOscillatorState
 | Defines the default oscillator axis (x, y, z) and cycleDuration (w) of the state, used when in global mode.
OSCILLATOR_VECTOR3D — Constant Static Property, class away3d.animators.nodes.ParticleOscillatorNode
 | Reference for ocsillator node properties on a single particle (when in local property mode).
OUT — Constant Static Property, class away3d.core.math.PlaneClassification
outlineColor — Property, class away3d.materials.methods.OutlineMethod
outlineColor — Property, class away3d.materials.passes.OutlinePass
OutlineMethod — class, package away3d.materials.methods
OutlineMethod(outlineColor:uint, outlineSize:Number, showInnerLines:Boolean, dedicatedMeshes:Boolean) — Constructor, class away3d.materials.methods.OutlineMethod
OutlinePass — class, package away3d.materials.passes
OutlinePass(outlineColor:uint, outlineSize:Number, showInnerLines:Boolean, dedicatedMeshes:Boolean) — Constructor, class away3d.materials.passes.OutlinePass
outlineSize — Property, class away3d.materials.methods.OutlineMethod
outlineSize — Property, class away3d.materials.passes.OutlinePass
overlayTexture — Property, class away3d.filters.tasks.Filter3DCompositeTask
overlayTexture — Property, class away3d.filters.tasks.Filter3DXFadeCompositeTask
overrideAbsolutePaths — Property, class away3d.loaders.misc.AssetLoaderContext
 | Defines whether absolute paths (defined as paths that begin with a "/") should be overridden with the dependencyBaseUrl defined in this context.
overrideFullURLs — Property, class away3d.loaders.misc.AssetLoaderContext
 | Defines whether "full" URLs (defined as a URL that includes a scheme, e.g.
_owners — Property, class away3d.animators.AnimatorBase
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


P

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
P Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
pan — Property, interface away3d.materials.utils.IVideoPlayer
 | Panning
pan — Property, class away3d.materials.utils.SimpleVideoPlayer
panAngle — Property, class away3d.controllers.FirstPersonController
 | Rotation of the camera in degrees around the y axis.
panAngle — Property, class away3d.controllers.HoverController
 | Rotation of the camera in degrees around the y axis.
_parent — Property, class away3d.containers.ObjectContainer3D
parent — Property, class away3d.containers.ObjectContainer3D
 | The parent ObjectContainer3D to which this object's transformation is relative.
_parent — Property, class away3d.core.partition.NodeBase
parent — Property, class away3d.core.partition.NodeBase
 | The parent node.
parentGeometry — Property, interface away3d.core.base.ISubGeometry
parentGeometry — Property, class away3d.core.base.SubGeometryBase
parentIndex — Property, class away3d.animators.data.SkeletonJoint
 | The index of the parent joint in the skeleton's joints vector.
_parentIsStage — Property, class away3d.containers.View3D
parentMesh — Property, class away3d.core.base.SubMesh
parentParser — Property, class away3d.loaders.misc.ResourceDependency
 | The parser which is dependent on this ResourceDependency object.
parseAsync(data:any, frameLimit:Number) — method, class away3d.loaders.parsers.ParserBase
 | Parse data (possibly containing bytearry, plain text or BitmapAsset) asynchronously, meaning that the parser will periodically stop parsing so that the AVM may proceed to the next frame.
parseComplete — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when the parsing finishes.
PARSE_COMPLETE — Constant Static Property, class away3d.events.ParserEvent
 | Dispatched when parsing of an asset completed.
parseData(data:any, parser:away3d.loaders.parsers:ParserBase, req:flash.net:URLRequest) — method, class away3d.loaders.misc.SingleFileLoader
 | Loads a resource from already loaded data.
PARSE_DEFAULT — Constant Static Property, class away3d.loaders.parsers.DAEParser
parseError — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched if an error was caught during parsing.
PARSE_ERROR — Constant Static Property, class away3d.events.ParserEvent
 | Dispatched when an error occurs while parsing the data (e.g.
PARSE_GEOMETRIES — Constant Static Property, class away3d.loaders.parsers.DAEParser
PARSE_IMAGES — Constant Static Property, class away3d.loaders.parsers.DAEParser
PARSE_MATERIALS — Constant Static Property, class away3d.loaders.parsers.DAEParser
parser — Property, class away3d.loaders.misc.SingleFileLoader
 | A reference to the parser that will translate the loaded data into a usable resource.
ParserBase — class, package away3d.loaders.parsers
 | ParserBase provides an abstract base class for objects that convert blocks of data to data structures supported by Away3D.
ParserBase(format:String) — Constructor, class away3d.loaders.parsers.ParserBase
 | Creates a new ParserBase object
ParserDataFormat — class, package away3d.loaders.parsers
 | An enumeration providing values to describe the data format of parsed data.
ParserEvent — class, package away3d.events
ParserEvent(type:String, message:String) — Constructor, class away3d.events.ParserEvent
Parsers — class, package away3d.loaders.parsers
ParserUtil — class, package away3d.loaders.parsers.utils
PARSE_VISUAL_SCENES — Constant Static Property, class away3d.loaders.parsers.DAEParser
parsingComplete — Property, class away3d.loaders.parsers.AWDParser
parsingComplete — Property, class away3d.loaders.parsers.ParserBase
PARSING_DONE — Constant Static Property, class away3d.loaders.parsers.ParserBase
 | Returned by proceedParsing to indicate no more parsing is needed.
parsingFailure — Property, class away3d.loaders.parsers.ParserBase
parsingPaused — Property, class away3d.loaders.parsers.AWDParser
parsingPaused — Property, class away3d.loaders.parsers.ParserBase
ParticleAccelerationNode — class, package away3d.animators.nodes
 | A particle animation node used to apply a constant acceleration vector to the motion of a particle.
ParticleAccelerationNode(mode:uint, acceleration:flash.geom:Vector3D) — Constructor, class away3d.animators.nodes.ParticleAccelerationNode
 | Creates a new ParticleAccelerationNode
ParticleAccelerationState — class, package away3d.animators.states
 | ...
ParticleAccelerationState(animator:away3d.animators:ParticleAnimator, particleAccelerationNode:away3d.animators.nodes:ParticleAccelerationNode) — Constructor, class away3d.animators.states.ParticleAccelerationState
ParticleAnimationData — class, package away3d.animators.data
 | ...
ParticleAnimationData(index:uint, startTime:Number, duration:Number, delay:Number, particle:away3d.core.base.data:ParticleData) — Constructor, class away3d.animators.data.ParticleAnimationData
ParticleAnimationSet — class, package away3d.animators
 | The animation data set used by particle-based animators, containing particle animation data.
ParticleAnimationSet(usesDuration:Boolean, usesLooping:Boolean, usesDelay:Boolean) — Constructor, class away3d.animators.ParticleAnimationSet
 | Creates a new ParticleAnimationSet
ParticleAnimator — class, package away3d.animators
 | Provides an interface for assigning paricle-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.
ParticleAnimator(particleAnimationSet:away3d.animators:ParticleAnimationSet) — Constructor, class away3d.animators.ParticleAnimator
 | Creates a new ParticleAnimator object.
ParticleBezierCurveNode — class, package away3d.animators.nodes
 | A particle animation node used to control the position of a particle over time along a bezier curve.
ParticleBezierCurveNode(mode:uint, controlPoint:flash.geom:Vector3D, endPoint:flash.geom:Vector3D) — Constructor, class away3d.animators.nodes.ParticleBezierCurveNode
 | Creates a new ParticleBezierCurveNode
ParticleBezierCurveState — class, package away3d.animators.states
 | ...
ParticleBezierCurveState(animator:away3d.animators:ParticleAnimator, particleBezierCurveNode:away3d.animators.nodes:ParticleBezierCurveNode) — Constructor, class away3d.animators.states.ParticleBezierCurveState
ParticleBillboardNode — class, package away3d.animators.nodes
 | A particle animation node that controls the rotation of a particle to always face the camera.
ParticleBillboardNode() — Constructor, class away3d.animators.nodes.ParticleBillboardNode
 | Creates a new ParticleBillboardNode
ParticleBillboardState — class, package away3d.animators.states
 | ...
ParticleBillboardState(animator:away3d.animators:ParticleAnimator, particleNode:away3d.animators.nodes:ParticleNodeBase) — Constructor, class away3d.animators.states.ParticleBillboardState
ParticleColorNode — class, package away3d.animators.nodes
 | A particle animation node used to control the color variation of a particle over time.
ParticleColorNode(mode:uint, usesMultiplier:Boolean, usesOffset:Boolean, usesCycle:Boolean, usesPhase:Boolean, startColor:flash.geom:ColorTransform, endColor:flash.geom:ColorTransform, cycleDuration:Number, cyclePhase:Number) — Constructor, class away3d.animators.nodes.ParticleColorNode
 | Creates a new ParticleColorNode
ParticleColorState — class, package away3d.animators.states
 | ...
ParticleColorState(animator:away3d.animators:ParticleAnimator, particleColorNode:away3d.animators.nodes:ParticleColorNode) — Constructor, class away3d.animators.states.ParticleColorState
ParticleData — class, package away3d.core.base.data
ParticleFollowNode — class, package away3d.animators.nodes
 | A particle animation node used to create a follow behaviour on a particle system.
ParticleFollowNode(usesPosition:Boolean, usesRotation:Boolean) — Constructor, class away3d.animators.nodes.ParticleFollowNode
 | Creates a new ParticleFollowNode
ParticleFollowState — class, package away3d.animators.states
 | ...
ParticleFollowState(animator:away3d.animators:ParticleAnimator, particleFollowNode:away3d.animators.nodes:ParticleFollowNode) — Constructor, class away3d.animators.states.ParticleFollowState
ParticleGeometry — class, package away3d.core.base
 | ...
ParticleGeometry() — Constructor, class away3d.core.base.ParticleGeometry
ParticleGeometryHelper — class, package away3d.tools.helpers
 | ...
ParticleGeometryTransform — class, package away3d.tools.helpers.data
 | ...
particleIndex — Property, class away3d.core.base.data.ParticleData
ParticleNodeBase — class, package away3d.animators.nodes
 | Provides an abstract base class for particle animation nodes.
ParticleNodeBase(name:String, mode:uint, dataLength:uint, priority:int) — Constructor, class away3d.animators.nodes.ParticleNodeBase
 | Creates a new ParticleNodeBase object.
particleNodes — Property, class away3d.animators.ParticleAnimationSet
 | Returns a vector of the particle animation nodes contained within the set.
ParticleOrbitNode — class, package away3d.animators.nodes
 | A particle animation node used to control the position of a particle over time around a circular orbit.
ParticleOrbitNode(mode:uint, usesEulers:Boolean, usesCycle:Boolean, usesPhase:Boolean, radius:Number, cycleDuration:Number, cyclePhase:Number, eulers:flash.geom:Vector3D) — Constructor, class away3d.animators.nodes.ParticleOrbitNode
 | Creates a new ParticleOrbitNode object.
ParticleOrbitState — class, package away3d.animators.states
 | ...
ParticleOrbitState(animator:away3d.animators:ParticleAnimator, particleOrbitNode:away3d.animators.nodes:ParticleOrbitNode) — Constructor, class away3d.animators.states.ParticleOrbitState
ParticleOscillatorNode — class, package away3d.animators.nodes
 | A particle animation node used to control the position of a particle over time using simple harmonic motion.
ParticleOscillatorNode(mode:uint, oscillator:flash.geom:Vector3D) — Constructor, class away3d.animators.nodes.ParticleOscillatorNode
 | Creates a new ParticleOscillatorNode
ParticleOscillatorState — class, package away3d.animators.states
 | ...
ParticleOscillatorState(animator:away3d.animators:ParticleAnimator, particleOscillatorNode:away3d.animators.nodes:ParticleOscillatorNode) — Constructor, class away3d.animators.states.ParticleOscillatorState
ParticlePositionNode — class, package away3d.animators.nodes
 | A particle animation node used to set the starting position of a particle.
ParticlePositionNode(mode:uint, position:flash.geom:Vector3D) — Constructor, class away3d.animators.nodes.ParticlePositionNode
 | Creates a new ParticlePositionNode
ParticlePositionState — class, package away3d.animators.states
 | ...
ParticlePositionState(animator:away3d.animators:ParticleAnimator, particlePositionNode:away3d.animators.nodes:ParticlePositionNode) — Constructor, class away3d.animators.states.ParticlePositionState
ParticleProperties — Dynamic Class, package away3d.animators.data
 | Dynamic class for holding the local properties of a particle, used for processing the static properties of particles in the particle animation set before beginning upload to the GPU.
ParticlePropertiesMode — class, package away3d.animators.data
 | Options for setting the properties mode of a particle animation node.
ParticleRotateToHeadingNode — class, package away3d.animators.nodes
 | A particle animation node used to control the rotation of a particle to match its heading vector.
ParticleRotateToHeadingNode() — Constructor, class away3d.animators.nodes.ParticleRotateToHeadingNode
 | Creates a new ParticleBillboardNode
ParticleRotateToHeadingState — class, package away3d.animators.states
 | ...
ParticleRotateToHeadingState(animator:away3d.animators:ParticleAnimator, particleNode:away3d.animators.nodes:ParticleNodeBase) — Constructor, class away3d.animators.states.ParticleRotateToHeadingState
ParticleRotationalVelocityNode — class, package away3d.animators.nodes
 | A particle animation node used to set the starting rotational velocity of a particle.
ParticleRotationalVelocityNode(mode:uint, rotationalVelocity:flash.geom:Vector3D) — Constructor, class away3d.animators.nodes.ParticleRotationalVelocityNode
 | Creates a new ParticleRotationalVelocityNode
ParticleRotationalVelocityState — class, package away3d.animators.states
 | ...
ParticleRotationalVelocityState(animator:away3d.animators:ParticleAnimator, particleRotationNode:away3d.animators.nodes:ParticleRotationalVelocityNode) — Constructor, class away3d.animators.states.ParticleRotationalVelocityState
particles — Property, class away3d.core.base.ParticleGeometry
ParticleScaleNode — class, package away3d.animators.nodes
 | A particle animation node used to control the scale variation of a particle over time.
ParticleScaleNode(mode:uint, usesCycle:Boolean, usesPhase:Boolean, minScale:Number, maxScale:Number, cycleDuration:Number, cyclePhase:Number) — Constructor, class away3d.animators.nodes.ParticleScaleNode
 | Creates a new ParticleScaleNode
ParticleScaleState — class, package away3d.animators.states
 | ...
ParticleScaleState(animator:away3d.animators:ParticleAnimator, particleScaleNode:away3d.animators.nodes:ParticleScaleNode) — Constructor, class away3d.animators.states.ParticleScaleState
ParticleSpriteSheetNode — class, package away3d.animators.nodes
 | A particle animation node used when a spritesheet texture is required to animate the particle.
ParticleSpriteSheetNode(mode:uint, usesCycle:Boolean, usesPhase:Boolean, numColumns:int, numRows:uint, cycleDuration:Number, cyclePhase:Number, totalFrames:uint) — Constructor, class away3d.animators.nodes.ParticleSpriteSheetNode
 | Creates a new ParticleSpriteSheetNode
ParticleSpriteSheetState — class, package away3d.animators.states
 | ...
ParticleSpriteSheetState(animator:away3d.animators:ParticleAnimator, particleSpriteSheetNode:away3d.animators.nodes:ParticleSpriteSheetNode) — Constructor, class away3d.animators.states.ParticleSpriteSheetState
ParticleStateBase — class, package away3d.animators.states
 | ...
ParticleStateBase(animator:away3d.animators:ParticleAnimator, particleNode:away3d.animators.nodes:ParticleNodeBase, needUpdateTime:Boolean) — Constructor, class away3d.animators.states.ParticleStateBase
ParticleTimeNode — class, package away3d.animators.nodes
 | A particle animation node used as the base node for timekeeping inside a particle.
ParticleTimeNode(usesDuration:Boolean, usesLooping:Boolean, usesDelay:Boolean) — Constructor, class away3d.animators.nodes.ParticleTimeNode
 | Creates a new ParticleTimeNode
ParticleTimeState — class, package away3d.animators.states
 | ...
ParticleTimeState(animator:away3d.animators:ParticleAnimator, particleTimeNode:away3d.animators.nodes:ParticleTimeNode) — Constructor, class away3d.animators.states.ParticleTimeState
ParticleUVNode — class, package away3d.animators.nodes
 | A particle animation node used to control the UV offset and scale of a particle over time.
ParticleUVNode(mode:uint, cycle:Number, scale:Number, axis:String) — Constructor, class away3d.animators.nodes.ParticleUVNode
 | Creates a new ParticleTimeNode
ParticleUVState — class, package away3d.animators.states
 | ...
ParticleUVState(animator:away3d.animators:ParticleAnimator, particleUVNode:away3d.animators.nodes:ParticleUVNode) — Constructor, class away3d.animators.states.ParticleUVState
ParticleVelocityNode — class, package away3d.animators.nodes
 | A particle animation node used to set the starting velocity of a particle.
ParticleVelocityNode(mode:uint, velocity:flash.geom:Vector3D) — Constructor, class away3d.animators.nodes.ParticleVelocityNode
 | Creates a new ParticleVelocityNode
ParticleVelocityState — class, package away3d.animators.states
 | ...
ParticleVelocityState(animator:away3d.animators:ParticleAnimator, particleVelocityNode:away3d.animators.nodes:ParticleVelocityNode) — Constructor, class away3d.animators.states.ParticleVelocityState
partition — Property, class away3d.containers.ObjectContainer3D
 | The space partition to be used by the object container and all its recursive children, unless it has its own space partition assigned.
partition — Property, class away3d.containers.Scene3D
 | The root partition to be used by the Scene3D.
Partition3D — class, package away3d.core.partition
 | Partition3D is the core of a space partition system.
Partition3D(rootNode:away3d.core.partition:NodeBase) — Constructor, class away3d.core.partition.Partition3D
 | Creates a new Partition3D object.
PartitionTraverser — class, package away3d.core.traverse
 | IPartitionTraverser is a hierarchical visitor pattern that traverses through a Partition3D data structure.
_passes — Property, class away3d.materials.MaterialBase
passes — Property, class away3d.materials.methods.CompositeSpecularMethod
 | Any passes required that render to a texture used by this method.
_passes — Property, class away3d.materials.methods.ShadingMethodBase
passes — Property, class away3d.materials.methods.ShadingMethodBase
 | Any passes required that render to a texture used by this method.
_passes — Property, class away3d.materials.passes.CompiledPass
_passesDirty — Property, class away3d.materials.passes.CompiledPass
passRendersToTexture(index:uint) — method, class away3d.materials.MaterialBase
path — Property, class away3d.animators.PathAnimator
 | defines the path to follow
path — Property, class away3d.extrusions.PathDuplicator
 | Sets and defines the Path object.
path — Property, class away3d.extrusions.PathExtrude
 | Defines the Path object representing path to extrude along.
PathAnimator — class, package away3d.animators
PathAnimator(path:away3d.paths:IPath, target:away3d.core.base:Object3D, offset:flash.geom:Vector3D, alignToPath:Boolean, lookAtTarget:away3d.core.base:Object3D, rotations:Vector$flash.geom:Vector3D) — Constructor, class away3d.animators.PathAnimator
 | Creates a new PathAnimator
PathDuplicator — class, package away3d.extrusions
PathDuplicator(path:away3d.paths:IPath, meshes:Vector$away3d.entities:Mesh, scene:away3d.containers:Scene3D, repeat:uint, alignToPath:Boolean, segmentSpread:Boolean, container:away3d.containers:ObjectContainer3D, randomRotationY:Boolean) — Constructor, class away3d.extrusions.PathDuplicator
 | Creates a new PathDuplicator Class replicates and distribute one or more mesh(es) along a path.
PathEvent — class, package away3d.events
PathEvent(type:String) — Constructor, class away3d.events.PathEvent
PathExtrude — class, package away3d.extrusions
PathExtrude(material:away3d.materials:MaterialBase, path:away3d.paths:IPath, profile:Vector$flash.geom:Vector3D, subdivision:uint, coverAll:Boolean, coverSegment:Boolean, alignToPath:Boolean, centerMesh:Boolean, mapFit:Boolean, flip:Boolean, closePath:Boolean, materials:Vector$away3d.materials:MaterialBase, scales:Vector$flash.geom:Vector3D, smoothScale:Boolean, rotations:Vector$flash.geom:Vector3D, smoothSurface:Boolean, distribute:Boolean, distributeU:Boolean, keepExtremes:Boolean) — Constructor, class away3d.extrusions.PathExtrude
 | Creates a new PathExtrude
pause() — method, class away3d.audio.Sound3D
 | Pause playback.
pause() — method, interface away3d.audio.drivers.ISound3DDriver
 | Temporarily pause playback.
pause() — method, class away3d.audio.drivers.SimplePanVolumeDriver
pause() — method, interface away3d.materials.utils.IVideoPlayer
 | Temporarily pause playback.
pause() — method, class away3d.materials.utils.SimpleVideoPlayer
pauseAndRetrieveDependencies() — method, class away3d.loaders.parsers.ParserBase
paused — Property, class away3d.audio.Sound3D
 | Returns a boolean indicating whether or not playback is currently paused.
_paused — Property, class away3d.audio.drivers.AbstractSound3DDriver
paused — Property, interface away3d.materials.utils.IVideoPlayer
 | Indicates whether the video is paused
paused — Property, class away3d.materials.utils.SimpleVideoPlayer
PB_BEST_HIT — Constant Static Property, class away3d.core.pick.PickingColliderType
 | PixelBender-based picking collider that returns the best (closest) hit on an Entity.
PB_FIRST_ENCOUNTERED — Constant Static Property, class away3d.core.pick.PickingColliderType
 | PixelBender-based picking collider that returns the first encountered hit on an Entity.
PBPickingCollider — class, package away3d.core.pick
 | PixelBender-based picking collider for entity objects.
PBPickingCollider(findClosestCollision:Boolean) — Constructor, class away3d.core.pick.PBPickingCollider
 | Creates a new PBPickingCollider object.
PerspectiveLens — class, package away3d.cameras.lenses
 | The PerspectiveLens object provides a projection matrix that projects 3D geometry with perspective distortion.
PerspectiveLens(fieldOfView:Number) — Constructor, class away3d.cameras.lenses.PerspectiveLens
 | Creates a new PerspectiveLens object.
phase(value:Number) — method, class away3d.animators.AnimatorBase
 | Sets the animation phase of the current active state's animation clip(s).
phase(value:Number) — method, class away3d.animators.states.AnimationClipState
 | Sets the animation phase of the node.
phase(value:Number) — method, class away3d.animators.states.AnimationStateBase
 | Sets the animation phase of the node.
phase(value:Number) — method, interface away3d.animators.states.IAnimationState
 | Sets the animation phase of the node.
phase(value:Number) — method, class away3d.animators.states.SkeletonBinaryLERPState
 | Sets the animation phase of the node.
phase(value:Number) — method, class away3d.animators.states.SkeletonDifferenceState
 | Sets the animation phase of the node.
phase(value:Number) — method, class away3d.animators.states.SkeletonDirectionalState
 | Sets the animation phase of the node.
phase(value:Number) — method, class away3d.animators.states.SkeletonNaryLERPState
 | Sets the animation phase of the node.
PHONG — Constant Static Property, class away3d.materials.methods.SpecularShadingModel
_pickingCollider — Property, class away3d.entities.Entity
pickingCollider — Property, class away3d.entities.Entity
 | Used by the raycast-based picking system to determine how the geometric contents of an entity are processed in order to offer more details for the picking collision object, including local position, normal vector and uv value.
PickingColliderBase — class, package away3d.core.pick
 | An abstract base class for all picking collider classes.
PickingColliderType — class, package away3d.core.pick
 | Options for setting a picking collider for entity objects.
_pickingCollisionVO — Property, class away3d.entities.Entity
pickingCollisionVO — Property, class away3d.entities.Entity
 | Returns a unique picking collision value object for the entity.
PickingCollisionVO — class, package away3d.core.pick
 | Value object for a picking collision returned by a picking collider.
PickingCollisionVO(entity:away3d.entities:Entity) — Constructor, class away3d.core.pick.PickingCollisionVO
 | Creates a new PickingCollisionVO object.
PickingType — class, package away3d.core.pick
 | Options for the different 3D object picking approaches available in Away3D.
pitch(angle:Number) — method, class away3d.core.base.Object3D
 | Rotates the 3d object around it's local x-axis
_pivotPoint — Property, class away3d.core.base.Object3D
pivotPoint — Property, class away3d.core.base.Object3D
 | Defines the local point around which the object rotates.
_pivotZero — Property, class away3d.core.base.Object3D
PLAIN_TEXT — Constant Static Property, class away3d.loaders.parsers.ParserDataFormat
 | Describes the format of a plain text file.
PlanarReflectionMethod — class, package away3d.materials.methods
 | PlanarReflectionMethod is a material method that adds reflections from a PlanarReflectionTexture object.
PlanarReflectionMethod(texture:away3d.textures:PlanarReflectionTexture, alpha:Number) — Constructor, class away3d.materials.methods.PlanarReflectionMethod
 | Creates a new PlanarReflectionMethod
PlanarReflectionTexture — class, package away3d.textures
 | PlanarReflectionTexture is a Texture that can be used for material-based planar reflections, as provided by PlanarReflectionMethod, FresnelPlanarReflectionMethod.
PlanarReflectionTexture() — Constructor, class away3d.textures.PlanarReflectionTexture
 | Creates a new PlanarReflectionTexture object.
plane — Property, class away3d.cameras.lenses.ObliqueNearPlaneLens
plane — Property, class away3d.extrusions.DelaunayMesh
 | Defines the projection plane for the class.
plane — Property, class away3d.textures.PlanarReflectionTexture
 | The plane to reflect with.
plane — Property, class away3d.tools.utils.Drag3D
 | Changes the plane the object will be considered on.
Plane3D — class, package away3d.core.math
Plane3D(a:Number, b:Number, c:Number, d:Number) — Constructor, class away3d.core.math.Plane3D
 | Create a Plane3D with ABCD coefficients
PlaneClassification — class, package away3d.core.math
PlaneGeometry — class, package away3d.primitives
 | A Plane primitive mesh.
PlaneGeometry(width:Number, height:Number, segmentsW:uint, segmentsH:uint, yUp:Boolean, doubleSided:Boolean) — Constructor, class away3d.primitives.PlaneGeometry
 | Creates a new Plane object.
planeNormal — Property, class away3d.tools.utils.Ray
 | Defines the directional normal of the Ray object
planeObject3d — Property, class away3d.tools.utils.Drag3D
 | Defines planes as the position of a given ObjectContainer3D
planePosition — Property, class away3d.tools.utils.Drag3D
 | Defines planes position by a postion Vector3D
PLANE_XY — Constant Static Property, class away3d.extrusions.DelaunayMesh
PLANE_XY — Constant Static Property, class away3d.tools.utils.Drag3D
PLANE_XZ — Constant Static Property, class away3d.extrusions.DelaunayMesh
PLANE_XZ — Constant Static Property, class away3d.tools.utils.Drag3D
PLANE_ZY — Constant Static Property, class away3d.extrusions.DelaunayMesh
PLANE_ZY — Constant Static Property, class away3d.tools.utils.Drag3D
play(name:String, transition:away3d.animators.transitions:IAnimationTransition, offset:Number) — method, class away3d.animators.SkeletonAnimator
 | Plays an animation state registered with the given name in the animation data set.
play(name:String, transition:away3d.animators.transitions:IAnimationTransition, offset:Number) — method, class away3d.animators.UVAnimator
play(name:String, transition:away3d.animators.transitions:IAnimationTransition, offset:Number) — method, class away3d.animators.VertexAnimator
 | Plays a sequence with a given name.
play() — method, class away3d.audio.Sound3D
 | Start (or resume, if paused) playback.
play() — method, interface away3d.audio.drivers.ISound3DDriver
 | Start playing (or resume if paused) the audio.
play() — method, class away3d.audio.drivers.SimplePanVolumeDriver
play() — method, interface away3d.materials.utils.IVideoPlayer
 | Start playing (or resume if paused) the video.
play() — method, class away3d.materials.utils.SimpleVideoPlayer
PLAYBACK_COMPLETE — Constant Static Property, class away3d.events.AnimationStateEvent
 | Dispatched when a non-looping clip node inside an animation state reaches the end of its timeline.
playbackSpeed — Property, class away3d.animators.AnimatorBase
 | The amount by which passed time should be scaled.
player — Property, class away3d.textures.VideoTexture
playing — Property, class away3d.audio.Sound3D
 | Returns a boolean indicating whether or not the sound is currently playing.
_playing — Property, class away3d.audio.drivers.AbstractSound3DDriver
playing — Property, interface away3d.materials.utils.IVideoPlayer
 | Indicates whether the video is playing
playing — Property, class away3d.materials.utils.SimpleVideoPlayer
plotAt(x:Number, y:Number, color:uint) — method, class away3d.tools.utils.ColorHitMap
 | Another method for debug, if you addChild your bitmapdata on screen, this method will colour a pixel at the coordinates helping you to visualize if your scale factors or entered coordinates are correct.
pointData — Property, class away3d.paths.SegmentedPathBase
PointLight — class, package away3d.lights
 | PointLight represents an omni-directional light.
PointLight() — Constructor, class away3d.lights.PointLight
 | Creates a new PointLight object.
_pointLightFragmentConstants — Property, class away3d.materials.compilation.LightingShaderCompiler
PointLightNode — class, package away3d.core.partition
 | LightNode is a space partitioning leaf node that contains a LightBase object.
PointLightNode(light:away3d.lights:PointLight) — Constructor, class away3d.core.partition.PointLightNode
 | Creates a new LightNode object.
_pointLightRegisters — Property, class away3d.materials.compilation.SuperShaderCompiler
pointLights — Property, class away3d.core.traverse.EntityCollector
_pointLights — Property, class away3d.materials.lightpickers.LightPickerBase
pointLights — Property, class away3d.materials.lightpickers.LightPickerBase
pointLightsOffset — Property, class away3d.materials.passes.LightingPass
_pointLightVertexConstants — Property, class away3d.materials.compilation.LightingShaderCompiler
popModelViewProjection() — method, class away3d.entities.Entity
 | Removes a model view projection matrix from the stack, used when leaving a render.
_pos — Property, class away3d.core.base.Object3D
position — Property, class away3d.animators.PathAnimator
 | returns the current interpolated position on the path with no optional offset applied
position — Property, class away3d.animators.states.ParticlePositionState
 | Defines the position of the particle when in global mode.
position — Property, class away3d.core.base.Object3D
 | Defines the position of the 3d object, relative to the local coordinates of the parent ObjectContainer3D.
position — Property, class away3d.textures.CubeReflectionTexture
 | The origin where the environment map will be rendered.
positionAttribute — Property, class away3d.animators.data.AnimationRegisterCache
positionChanged — Event, class away3d.core.base.Object3D
 | Dispatched when the position of the 3d object changes.
POSITION_CHANGED — Constant Static Property, class away3d.events.Object3DEvent
 | Defines the value of the type property of a positionChanged event object.
positionDelta — Property, class away3d.animators.states.AnimationStateBase
 | Returns a 3d vector representing the translation delta of the animating entity for the current timestep of animation
positionDelta — Property, interface away3d.animators.states.IAnimationState
_positionDeltaDirty — Property, class away3d.animators.states.AnimationStateBase
positionOffset — Property, class away3d.controllers.SpringController
 | Offset of spring center from target in target object space, ie: Where the camera should ideally be in the target object space.
PositionRenderer — class, package away3d.core.render
 | The PositionRenderer renders normalized position coordinates.
PositionRenderer(renderBlended:Boolean) — Constructor, class away3d.core.render.PositionRenderer
 | Creates a PositionRenderer object.
positionTarget — Property, class away3d.animators.data.AnimationRegisterCache
POSITION_VECTOR3D — Constant Static Property, class away3d.animators.nodes.ParticlePositionNode
 | Reference for position node properties on a single particle (when in local property mode).
POSITIVE — Constant Static Property, class away3d.tools.commands.Align
positiveX — Property, class away3d.textures.BitmapCubeTexture
 | The texture on the cube's right face.
positiveY — Property, class away3d.textures.BitmapCubeTexture
 | The texture on the cube's top face.
positiveZ — Property, class away3d.textures.BitmapCubeTexture
 | The texture on the cube's far face.
POST_PRIORITY — Constant Static Property, class away3d.animators.ParticleAnimationSet
 | Property used by particle nodes that require compilation at the end of the shader
power — Property, class away3d.materials.methods.RimLightMethod
preciseThickness — Property, class away3d.extrusions.LatheExtrude
 | Defines if thickness is greater than 0 if the thickness is equally distributed along the volume.
present() — method, class away3d.core.managers.Stage3DProxy
_preserveAlpha — Property, class away3d.materials.compilation.ShaderCompiler
preserveAlpha — Property, class away3d.materials.compilation.ShaderCompiler
_preserveAlpha — Property, class away3d.materials.passes.CompiledPass
preserveAlpha — Property, class away3d.materials.passes.CompiledPass
preventDefault() — method, class away3d.events.LoaderEvent
previousTime — Property, class away3d.animators.data.AnimationSubGeometry
PrimitiveBase — class, package away3d.primitives
 | PrimitiveBase is an abstract base class for mesh primitives, which are prebuilt simple meshes.
PrimitiveBase() — Constructor, class away3d.primitives.PrimitiveBase
 | Creates a new PrimitiveBase object.
priority — Property, class away3d.animators.nodes.ParticleNodeBase
 | Returns the priority of the particle animation node, used to order the agal generated in a particle animation set.
PROBES — Constant Static Property, class away3d.materials.LightSources
 | Defines that global lighting probes are to be used as the source for the lighting component.
_probeWeightsIndex — Property, class away3d.materials.compilation.ShaderCompiler
probeWeightsIndex — Property, class away3d.materials.compilation.ShaderCompiler
_probeWeightsIndex — Property, class away3d.materials.passes.CompiledPass
proceedParsing() — method, class away3d.loaders.parsers.AC3DParser
 | Parse the next block of data.
proceedParsing() — method, class away3d.loaders.parsers.AWD1Parser
 | Parse the next block of data.
proceedParsing() — method, class away3d.loaders.parsers.AWD2Parser
 | Parse the next block of data.
proceedParsing() — method, class away3d.loaders.parsers.AWDParser
 | Find the right conrete parser (AWD1Parser or AWD2Parser) and delegate actual parsing to it.
proceedParsing() — method, class away3d.loaders.parsers.DAEParser
proceedParsing() — method, class away3d.loaders.parsers.DXFParser
 | Parse the next block of data.
proceedParsing() — method, class away3d.loaders.parsers.ImageParser
 | Parse the next block of data.
proceedParsing() — method, class away3d.loaders.parsers.MD2Parser
 | Parse the next block of data.
proceedParsing() — method, class away3d.loaders.parsers.MD5AnimParser
 | Parse the next block of data.
proceedParsing() — method, class away3d.loaders.parsers.MD5MeshParser
 | Parse the next block of data.
proceedParsing() — method, class away3d.loaders.parsers.Max3DSParser
proceedParsing() — method, class away3d.loaders.parsers.OBJParser
 | Parse the next block of data.
proceedParsing() — method, class away3d.loaders.parsers.ParserBase
 | Parse the next block of data.
processAnimationSetting(particleAnimationSet:away3d.animators:ParticleAnimationSet) — method, class away3d.animators.nodes.ParticleBillboardNode
 | Called internally by the particle animation set when determining the requirements of the particle animation node AGAL.
processAnimationSetting(particleAnimationSet:away3d.animators:ParticleAnimationSet) — method, class away3d.animators.nodes.ParticleColorNode
 | Called internally by the particle animation set when determining the requirements of the particle animation node AGAL.
processAnimationSetting(particleAnimationSet:away3d.animators:ParticleAnimationSet) — method, class away3d.animators.nodes.ParticleNodeBase
 | Called internally by the particle animation set when determining the requirements of the particle animation node AGAL.
processAnimationSetting(particleAnimationSet:away3d.animators:ParticleAnimationSet) — method, class away3d.animators.nodes.ParticleRotateToHeadingNode
 | Called internally by the particle animation set when determining the requirements of the particle animation node AGAL.
processAnimationSetting(particleAnimationSet:away3d.animators:ParticleAnimationSet) — method, class away3d.animators.nodes.ParticleSpriteSheetNode
 | Called internally by the particle animation set when determining the requirements of the particle animation node AGAL.
processAnimationSetting(particleAnimationSet:away3d.animators:ParticleAnimationSet) — method, class away3d.animators.nodes.ParticleUVNode
 | Called internally by the particle animation set when determining the requirements of the particle animation node AGAL.
profile — Property, class away3d.extrusions.LatheExtrude
profile — Property, class away3d.extrusions.PathExtrude
 | Defines a Vector.<Vector3D> of Vector3D objects representing the profile information to be projected along the Path object.
profiles — Property, class away3d.extrusions.SkinExtrude
 | Defines if the texture(s) should be stretched to cover the entire mesh or per step between segments.
_program3Dids — Property, class away3d.materials.passes.MaterialPassBase
_program3Ds — Property, class away3d.materials.passes.MaterialPassBase
progress — Property, class away3d.animators.PathAnimator
 | Represents the progress of the animation playhead from the start (0) to the end (1) of the animation.
project(point3d:flash.geom:Vector3D) — method, class away3d.cameras.Camera3D
project(point3d:flash.geom:Vector3D) — method, class away3d.cameras.lenses.LensBase
project(point3d:flash.geom:Vector3D) — method, class away3d.containers.View3D
project(orientation:String, obj:away3d.containers:ObjectContainer3D) — Static Method , class away3d.tools.utils.Projector
 | Class remaps the uv data of a mesh
projectedTarget — Property, class away3d.materials.compilation.ShaderRegisterData
projectionDependencies — Property, class away3d.materials.compilation.MethodDependencyCounter
projectionFragment — Property, class away3d.materials.compilation.ShaderRegisterData
projectionHeight — Property, class away3d.cameras.lenses.OrthographicLens
 | The vertical field of view of the projection.
ProjectiveTextureMethod — class, package away3d.materials.methods
 | ProjectiveTextureMethod is a material method used to project a texture unto the surface of an object.
ProjectiveTextureMethod(projector:away3d.entities:TextureProjector, mode:String) — Constructor, class away3d.materials.methods.ProjectiveTextureMethod
 | Creates a new ProjectiveTextureMethod object.
projector — Property, class away3d.materials.methods.ProjectiveTextureMethod
 | The TextureProjector object that defines the projection properties as well as the texture.
Projector — class, package away3d.tools.utils
pushModelViewProjection(camera:away3d.cameras:Camera3D, updateZIndex:Boolean) — method, class away3d.entities.Entity
 | Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack.
pushModelViewProjection(camera:away3d.cameras:Camera3D, updateZIndex:Boolean) — method, class away3d.entities.Sprite3D
pushModelViewProjection(camera:away3d.cameras:Camera3D, updateZIndex:Boolean) — method, class away3d.primitives.SkyBox
 | Updates the model-view-projection (MVP) matrix used to transform from model to homogeneous projection space and places it on the stack.
pushModelViewProjection(camera:away3d.cameras:Camera3D, updateZIndex:Boolean) — method, class away3d.primitives.WireframePrimitiveBase
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


Package List - Away3D Documentation

Packages

away3d
away3d.animators
away3d.animators.data
away3d.animators.nodes
away3d.animators.states
away3d.animators.transitions
away3d.animators.utils
away3d.audio
away3d.audio.drivers
away3d.bounds
away3d.cameras
away3d.cameras.lenses
away3d.containers
away3d.controllers
away3d.core.base
away3d.core.base.data
away3d.core.data
away3d.core.managers
away3d.core.math
away3d.core.partition
away3d.core.pick
away3d.core.render
away3d.core.sort
away3d.core.traverse
away3d.debug
away3d.debug.data
away3d.entities
away3d.errors
away3d.events
away3d.extrusions
away3d.filters
away3d.filters.tasks
away3d.library
away3d.library.assets
away3d.library.naming
away3d.library.utils
away3d.lights
away3d.lights.shadowmaps
away3d.loaders
away3d.loaders.misc
away3d.loaders.parsers
away3d.loaders.parsers.utils
away3d.materials
away3d.materials.compilation
away3d.materials.lightpickers
away3d.materials.methods
away3d.materials.passes
away3d.materials.utils
away3d.paths
away3d.primitives
away3d.primitives.data
away3d.stereo
away3d.stereo.methods
away3d.textures
away3d.tools.commands
away3d.tools.helpers
away3d.tools.helpers.data
away3d.tools.serialize
away3d.tools.utils
away3d.utils
com.adobe.utils


Q

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
Q Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
QuadraticPath — class, package away3d.paths
 | Holds information about a single Path definition.
QuadraticPath(data:Vector$flash.geom:Vector3D) — Constructor, class away3d.paths.QuadraticPath
 | Creates a new Path object.
QuadraticPathSegment — class, package away3d.paths
 | Creates a curved line segment definition required for the Path class.
QuadraticPathSegment(pStart:flash.geom:Vector3D, pControl:flash.geom:Vector3D, pEnd:flash.geom:Vector3D) — Constructor, class away3d.paths.QuadraticPathSegment
QuadTree — class, package away3d.core.partition
QuadTree(maxDepth:int, size:Number, height:Number) — Constructor, class away3d.core.partition.QuadTree
QuadTreeNode — class, package away3d.core.partition
QuadTreeNode(maxDepth:int, size:Number, height:Number, centerX:Number, centerZ:Number, depth:int) — Constructor, class away3d.core.partition.QuadTreeNode
quarterFace(mesh:away3d.entities:Mesh, indice:uint, subGeomIndice:uint) — Static Method , class away3d.tools.helpers.FaceHelper
 | Divides a face into 4 faces.
quarterFaces(mesh:away3d.entities:Mesh) — Static Method , class away3d.tools.helpers.FaceHelper
 | Divides all the faces of a mesh in 4 faces.
Quaternion — final class, package away3d.core.math
 | A Quaternion object which can be used to represent rotations.
Quaternion(x:Number, y:Number, z:Number, w:Number) — Constructor, class away3d.core.math.Quaternion
 | Creates a new Quaternion object.
quaternion2euler(quarternion:away3d.core.math:Quaternion) — Static Method , class away3d.core.math.Vector3DUtils
 | Returns a Vector3D object containing the euler angles represented by the given Quaternion object.
quaternion2matrix(quarternion:away3d.core.math:Quaternion, m:flash.geom:Matrix3D) — Static Method , class away3d.core.math.Matrix3DUtils
 | Fills the 3d matrix object with values representing the transformation made by the given quaternion.
queueSnapshot(bmd:flash.display:BitmapData) — method, class away3d.core.render.RendererBase
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


R

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
R Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
r — Property, class away3d.filters.HueSaturationFilter3D
r — Property, class away3d.filters.tasks.Filter3DHueSaturationTask
RadialBlurFilter3D — class, package away3d.filters
RadialBlurFilter3D(intensity:Number, glowGamma:Number, blurStart:Number, blurWidth:Number, cx:Number, cy:Number) — Constructor, class away3d.filters.RadialBlurFilter3D
RADIANS_TO_DEGREES — Constant Static Property, class away3d.core.math.MathConsts
 | The amount to multiply with when converting radians to degrees.
radius — Property, class away3d.animators.states.ParticleOrbitState
 | Defines the radius of the orbit when in global mode.
radius — Property, class away3d.bounds.BoundingSphere
 | The radius of the bounding sphere, calculated from the contents of the entity.
_radius — Property, class away3d.lights.PointLight
radius — Property, class away3d.lights.PointLight
 | The minimum distance of the light's reach.
radius — Property, class away3d.primitives.CapsuleGeometry
 | The radius of the capsule.
radius — Property, class away3d.primitives.ConeGeometry
 | The radius of the bottom end of the cone.
radius — Property, class away3d.primitives.RegularPolygonGeometry
 | The radius of the regular polygon.
radius — Property, class away3d.primitives.SphereGeometry
 | The radius of the sphere.
_radius — Property, class away3d.primitives.TorusGeometry
radius — Property, class away3d.primitives.TorusGeometry
 | The radius of the torus.
ram — Property, class away3d.debug.AwayStats
randomRotationY — Property, class away3d.extrusions.PathDuplicator
 | Defines if a clone gets a random rotationY to break visual repetitions, usefull in case of vegetation for instance.
range — Property, class away3d.filters.DepthOfFieldFilter3D
 | The distance between the focus point and the maximum amount of blur.
range — Property, class away3d.filters.HDepthOfFieldFilter3D
range — Property, class away3d.filters.VDepthOfFieldFilter3D
range — Property, class away3d.filters.tasks.Filter3DHDepthOfFFieldTask
range — Property, class away3d.filters.tasks.Filter3DVDepthOfFFieldTask
range — Property, class away3d.materials.methods.DitheredShadowMapMethod
range — Property, class away3d.materials.methods.SoftShadowMapMethod
RANGE — Constant Static Property, class away3d.events.PathEvent
 | Dispatched when the time pointer is included a given from/to time region on a path
RAW_DATA_CONTAINER — Constant Static Property, class away3d.core.math.Matrix3DUtils
 | A reference to a Vector to be used as a temporary raw data container, to prevent object creation.
Ray — class, package away3d.tools.utils
Ray() — Constructor, class away3d.tools.utils.Ray
RAYCAST_BEST_HIT — Constant Static Property, class away3d.core.pick.PickingType
 | Uses AS3 and Pixel Bender to pick objects based on ray intersection.
RAYCAST_FIRST_ENCOUNTERED — Constant Static Property, class away3d.core.pick.PickingType
 | Uses AS3 and Pixel Bender to pick objects based on ray intersection.
RaycastPicker — class, package away3d.core.pick
 | Picks a 3d object from a view or scene by 3D raycast calculations.
RaycastPicker(findClosestCollision:Boolean) — Constructor, class away3d.core.pick.RaycastPicker
 | Creates a new RaycastPicker object.
rayDirection — Property, class away3d.core.pick.PickingColliderBase
rayEntryDistance — Property, class away3d.core.pick.PickingCollisionVO
 | The distance along the ray from the starting position to the calculated intersection entry point with the entity.
rayIntersection(position:flash.geom:Vector3D, direction:flash.geom:Vector3D, targetNormal:flash.geom:Vector3D) — method, class away3d.bounds.AxisAlignedBoundingBox
rayIntersection(position:flash.geom:Vector3D, direction:flash.geom:Vector3D, targetNormal:flash.geom:Vector3D) — method, class away3d.bounds.BoundingSphere
rayIntersection(position:flash.geom:Vector3D, direction:flash.geom:Vector3D, targetNormal:flash.geom:Vector3D) — method, class away3d.bounds.BoundingVolumeBase
 | Method for calculating whether an intersection of the given ray occurs with the bounding volume.
rayOriginIsInsideBounds — Property, class away3d.core.pick.PickingCollisionVO
 | Determines if the ray position is contained within the entity bounds.
rayPosition — Property, class away3d.core.pick.PickingColliderBase
read(x:Number, y:Number) — method, class away3d.tools.utils.ColorHitMap
 | If at the given coordinates a color is found that matches a defined color event, the color event will be triggered.
readyForDependencies — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when parser pauses to wait for dependencies, used internally to trigger loading of dependencies which are then returned to the parser through it's interface in the arcane namespace.
READY_FOR_DEPENDENCIES — Constant Static Property, class away3d.events.ParserEvent
 | Dispatched when a parser is ready to have dependencies retrieved and resolved.
recenter(mesh:away3d.entities:Mesh, keepPosition:Boolean) — Static Method , class away3d.tools.helpers.MeshHelper
 | Recenter geometry
recenterContainer(obj:away3d.containers:ObjectContainer3D, keepPosition:Boolean) — Static Method , class away3d.tools.helpers.MeshHelper
 | Recenter geometry of all meshes found into container
recoverFromDisposal() — method, class away3d.core.managers.Stage3DProxy
reflection(plane:away3d.core.math:Plane3D, target:flash.geom:Matrix3D) — Static Method , class away3d.core.math.Matrix3DUtils
RefractionEnvMapMethod — class, package away3d.materials.methods
RefractionEnvMapMethod(envMap:away3d.textures:CubeTextureBase, refractionIndex:Number, dispersionR:Number, dispersionG:Number, dispersionB:Number) — Constructor, class away3d.materials.methods.RefractionEnvMapMethod
refractionIndex — Property, class away3d.materials.methods.RefractionEnvMapMethod
refreshNURBS() — method, class away3d.primitives.NURBSGeometry
 | Refresh the mesh without reconstructing all the supporting data.
_ref_v — Property, class away3d.audio.drivers.AbstractSound3DDriver
REGEXP_OUTER_SPACES — Constant Static Property, class com.adobe.utils.AGALMiniAssembler
_registerCache — Property, class away3d.materials.compilation.ShaderCompiler
registerPartition(entity:away3d.entities:Entity) — method, class away3d.containers.Scene3D
 | When a partition is assigned to an object somewhere in the scene graph, add the partition to the list if it isn't in there yet
registerView(view3d:away3d.containers:View3D) — method, class away3d.debug.AwayStats
 | Add a view to the list of those that are taken into account when calculating on-screen and total poly counts.
regName — Property, class away3d.materials.compilation.ShaderRegisterElement
 | The register's name.
RegularPolygonGeometry — class, package away3d.primitives
 | A UV RegularPolygon primitive mesh.
RegularPolygonGeometry(radius:Number, sides:uint, yUp:Boolean) — Constructor, class away3d.primitives.RegularPolygonGeometry
 | Creates a new RegularPolygon disc object.
removeAllAssets(dispose:Boolean) — Static Method , class away3d.library.AssetLibrary
 | Short-hand for removeAllAssets() method on default asset library bundle.
removeAllAssets(dispose:Boolean) — method, class away3d.library.AssetLibraryBundle
 | Removes all assets from the asset library, optionally disposing them as they are removed.
removeAllSegments() — method, class away3d.entities.SegmentSet
removeAllSegments() — method, class away3d.primitives.WireframePrimitiveBase
removeAsset(asset:away3d.library.assets:IAsset, dispose:Boolean) — Static Method , class away3d.library.AssetLibrary
 | Short-hand for removeAsset() method on default asset library bundle.
removeAsset(asset:away3d.library.assets:IAsset, dispose:Boolean) — method, class away3d.library.AssetLibraryBundle
 | Removes an asset from the library, and optionally disposes that asset by calling it's disposeAsset() method (which for most assets is implemented as a default version of that type's dispose() method.
removeAssetByName(name:String, ns:String, dispose:Boolean) — Static Method , class away3d.library.AssetLibrary
 | Short-hand for removeAssetByName() method on default asset library bundle.
removeAssetByName(name:String, ns:String, dispose:Boolean) — method, class away3d.library.AssetLibraryBundle
 | Removes an asset which is specified using name and namespace.
removeChild(child:away3d.containers:ObjectContainer3D) — method, class away3d.containers.ObjectContainer3D
 | Removes a 3d object from the child array of the container
removeChild(child:away3d.containers:ObjectContainer3D) — method, class away3d.containers.Scene3D
 | Removes a child from the scene's root.
removeColorEvent(eventID:String) — method, class away3d.tools.utils.ColorHitMap
 | removes a color event by its id
removeDebug(mesh:away3d.entities:Mesh) — method, class away3d.tools.helpers.MeshDebugger
REMOVED_FROM_SCENE — Constant Static Property, class away3d.events.Scene3DEvent
removeEntity(entity:away3d.entities:Entity) — method, class away3d.core.partition.Partition3D
 | Removes an entity from the partition tree.
removeEventListener(type:String, listener:Function, useCapture:Boolean) — method, class away3d.containers.ObjectContainer3D
removeEventListener(type:String, listener:Function, useCapture:Boolean) — method, class away3d.core.base.Object3D
removeEventListener(type:String, listener:Function, useCapture:Boolean) — method, class away3d.core.managers.Stage3DProxy
 | Removes a listener from the EventDispatcher object.
removeEventListener(type:String, listener:Function, useCapture:Boolean) — Static Method , class away3d.library.AssetLibrary
 | Short-hand for removeEventListener() method on default asset library bundle.
removeEventListener(type:String, listener:Function, useCapture:Boolean) — method, class away3d.lights.shadowmaps.CascadeShadowMapper
removeEventListener(type:String, listener:Function, useCapture:Boolean) — method, class away3d.loaders.misc.AssetLoaderToken
removeFace(mesh:away3d.entities:Mesh, index:uint, subGeomIndice:uint) — Static Method , class away3d.tools.helpers.FaceHelper
 | Remove a face from a mesh
removeFaces(mesh:away3d.entities:Mesh, indices:Vector$uint, subGeomIndices:Vector$uint) — Static Method , class away3d.tools.helpers.FaceHelper
 | Remove a series of faces from a mesh.
removeFragmentTempUsage(register:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.compilation.ShaderRegisterCache
 | Removes a usage from a fragment temporary register.
removeFromParent() — method, class away3d.core.partition.EntityNode
 | Detaches the node from its parent.
removeMethod(method:away3d.materials.methods:EffectMethodBase) — method, class away3d.materials.MultiPassMaterialBase
removeMethod(method:away3d.materials.methods:EffectMethodBase) — method, class away3d.materials.SinglePassMaterialBase
removeMethod(method:away3d.materials.methods:EffectMethodBase) — method, class away3d.materials.methods.ShaderMethodSetup
 | Removes a method from the pass.
removeMethod(method:away3d.materials.methods:EffectMethodBase) — method, class away3d.materials.passes.SuperShaderPass
removeNamespaceAssets(ns:String, dispose:Boolean) — Static Method , class away3d.library.AssetLibrary
 | Short-hand for removeNamespaceAssets() method on default asset library bundle.
removeNamespaceAssets(ns:String, dispose:Boolean) — method, class away3d.library.AssetLibraryBundle
 | Removes all assets belonging to a particular namespace (null for default) from the asset library, and optionall disposes them by calling their disposeAsset() method.
removeNode(node:away3d.core.partition:NodeBase) — method, class away3d.core.partition.NodeBase
 | Removes a child node from the tree.
removeOnChangeSegment(listener:Function) — method, class away3d.animators.PathAnimator
 | Default method for removing a range event listener
removeOnCycle(listener:Function) — method, class away3d.animators.PathAnimator
 | Default method for removing a cycle event listener
removeOnRange(listener:Function) — method, class away3d.animators.PathAnimator
 | Default method for removing a range event listener
removePass(pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.materials.MaterialBase
removeSegment(segment:away3d.primitives.data:Segment) — method, class away3d.entities.SegmentSet
removeSegment(index:uint, join:Boolean) — method, interface away3d.paths.IPath
 | Removes a segment from the path
removeSegment(index:uint, join:Boolean) — method, class away3d.paths.SegmentedPathBase
 | removes a segment in the path according to id.
removeStaticLightFromMaterials(objectContainer3D:away3d.containers:ObjectContainer3D, light:away3d.lights:LightBase) — Static Method , class away3d.tools.helpers.LightsHelper
 | Removes a given light from all materials found into an objectcontainer and its children.
removeSubGeometry(subGeometry:away3d.core.base:ISubGeometry) — method, class away3d.core.base.Geometry
 | Removes a new SubGeometry object from the list.
removeVertexTempUsage(register:away3d.materials.compilation:ShaderRegisterElement) — method, class away3d.materials.compilation.ShaderRegisterCache
 | Removes a usage from a vertex temporary register.
removeViewVolume(viewVolume:away3d.core.partition:ViewVolume) — method, class away3d.core.partition.ViewVolumePartition
removeViewVolume(viewVolume:away3d.core.partition:ViewVolume) — method, class away3d.core.partition.ViewVolumeRootNode
removeVisibleDynamicCell(cell:away3d.core.partition:InvertedOctreeNode, indexX:uint, indexY:uint, indexZ:uint) — method, class away3d.core.partition.ViewVolume
removeVisibleStatic(entity:away3d.entities:Entity, indexX:uint, indexY:uint, indexZ:uint) — method, class away3d.core.partition.ViewVolume
render() — method, class away3d.containers.View3D
 | Renders the view.
render() — method, class away3d.core.render.BackgroundImageRenderer
render(stage3DProxy:away3d.core.managers:Stage3DProxy, camera3D:away3d.cameras:Camera3D, depthTexture:flash.display3D.textures:Texture) — method, class away3d.core.render.Filter3DRenderer
render(entityCollector:away3d.core.traverse:EntityCollector, target:flash.display3D.textures:TextureBase, scissorRect:flash.geom:Rectangle, surfaceSelector:int) — method, class away3d.core.render.RendererBase
 | Renders the potentially visible geometry to the back buffer or texture.
render(renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.passes.CompiledPass
render(renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.passes.DepthMapPass
render(renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.passes.DistanceMapPass
render(renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.passes.LightingPass
render(renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.passes.OutlinePass
render(renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.passes.SegmentPass
render(renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.passes.ShadowCasterPass
render(renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.passes.SingleObjectDepthPass
render(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.stereo.StereoRenderer
render() — method, class away3d.stereo.StereoView3D
render(view:away3d.containers:View3D) — method, class away3d.textures.CubeReflectionTexture
 | Renders the scene in the given view for reflections.
render(view:away3d.containers:View3D) — method, class away3d.textures.PlanarReflectionTexture
 | Renders the scene in the given view for reflections.
renderable — Property, class away3d.core.data.RenderableListItem
renderable — Property, class away3d.core.pick.PickingCollisionVO
 | The IRenderable associated with a collision.
renderable — Property, class away3d.events.MouseEvent3D
 | The renderable inside which the event took place.
RenderableListItem — final class, package away3d.core.data
_renderableListItemPool — Property, class away3d.core.traverse.EntityCollector
RenderableListItemPool — class, package away3d.core.data
RenderableListItemPool() — Constructor, class away3d.core.data.RenderableListItemPool
RenderableMergeSort — class, package away3d.core.sort
 | RenderableSorter sorts the potentially visible IRenderable objects collected by EntityCollector for optimal rendering performance.
RenderableMergeSort() — Constructor, class away3d.core.sort.RenderableMergeSort
 | Creates a RenderableSorter objects
RenderableNode — class, package away3d.core.partition
 | RenderableNode is a space partitioning leaf node that contains any Entity that is itself a IRenderable object.
RenderableNode(renderable:away3d.core.base:IRenderable) — Constructor, class away3d.core.partition.RenderableNode
 | Creates a new RenderableNode object.
_renderableSorter — Property, class away3d.core.render.RendererBase
renderableSorter — Property, class away3d.core.render.RendererBase
renderCascades(entityCollector:away3d.core.traverse:EntityCollector, target:flash.display3D.textures:TextureBase, numCascades:uint, scissorRects:Vector$flash.geom:Rectangle, splitPlanes:Vector$away3d.core.math:Plane3D, cameras:Vector$away3d.cameras:Camera3D) — method, class away3d.core.render.DepthRenderer
RenderCubeTexture — class, package away3d.textures
RenderCubeTexture(size:Number) — Constructor, class away3d.textures.RenderCubeTexture
renderDepth(renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.MaterialBase
renderDepthMap(stage3DProxy:away3d.core.managers:Stage3DProxy, entityCollector:away3d.core.traverse:EntityCollector, renderer:away3d.core.render:DepthRenderer) — method, class away3d.lights.shadowmaps.ShadowMapperBase
 | Renders the depth map for this light.
renderDepthPrepass(entityCollector:away3d.core.traverse:EntityCollector) — method, class away3d.containers.View3D
renderedFacesCount — Property, class away3d.containers.View3D
 | The amount of faces that were pushed through the render pipeline on the last frame render.
_renderer — Property, class away3d.containers.View3D
renderer — Property, class away3d.containers.View3D
 | The renderer used to draw the scene.
renderer — Property, class away3d.textures.CubeReflectionTexture
 | The renderer to use.
renderer — Property, class away3d.textures.PlanarReflectionTexture
 | The renderer to use.
RendererBase — class, package away3d.core.render
 | RendererBase forms an abstract base class for classes that are used in the rendering pipeline to render geometry to the back buffer or a texture.
RendererBase(renderToTexture:Boolean) — Constructor, class away3d.core.render.RendererBase
 | Creates a new RendererBase object.
renderMethod — Property, class away3d.stereo.StereoRenderer
renderOrderId — Property, class away3d.core.data.RenderableListItem
_renderOrderId — Property, class away3d.materials.MaterialBase
renderSceneDepthToTexture(entityCollector:away3d.core.traverse:EntityCollector) — method, class away3d.containers.View3D
renderSurfaceSelector — Property, class away3d.core.managers.Stage3DProxy
renderTarget — Property, class away3d.core.managers.Stage3DProxy
_renderTarget — Property, class away3d.core.render.RendererBase
_renderTargetSurface — Property, class away3d.core.render.RendererBase
RenderTexture — class, package away3d.textures
RenderTexture(width:Number, height:Number) — Constructor, class away3d.textures.RenderTexture
renderToScreenVertexBuffer — Property, class away3d.core.managers.RTTBufferManager
_renderToTexture — Property, class away3d.core.render.RendererBase
renderToTexture — Property, class away3d.core.render.RendererBase
renderToTexture — Property, class away3d.materials.passes.MaterialPassBase
 | Specifies whether this pass renders to texture
renderToTextureRect — Property, class away3d.core.managers.RTTBufferManager
renderToTextureVertexBuffer — Property, class away3d.core.managers.RTTBufferManager
repeat — Property, class away3d.extrusions.PathDuplicator
 | Defines the resolution between each PathSegments.
_repeat — Property, class away3d.materials.MaterialBase
repeat — Property, class away3d.materials.MaterialBase
 | Indicates whether or not any used textures should be tiled.
_repeat — Property, class away3d.materials.compilation.ShaderCompiler
_repeat — Property, class away3d.materials.passes.MaterialPassBase
repeat — Property, class away3d.materials.passes.MaterialPassBase
 | Defines whether textures should be tiled.
repeatTextures — Property, class away3d.materials.methods.MethodVO
request — Property, class away3d.loaders.misc.ResourceDependency
_requireDepthRender — Property, class away3d.containers.View3D
requireDepthRender — Property, class away3d.core.render.Filter3DRenderer
requireDepthRender — Property, class away3d.filters.Filter3DBase
requireDepthRender — Property, class away3d.filters.tasks.Filter3DTaskBase
requiresBlending — Property, class away3d.materials.ColorMaterial
 | Indicates whether or not the material requires alpha blending during rendering.
requiresBlending — Property, class away3d.materials.MaterialBase
 | Indicates whether or not the material requires alpha blending during rendering.
requiresBlending — Property, class away3d.materials.MultiPassMaterialBase
 | Indicates whether or not the material requires alpha blending during rendering.
requiresBlending — Property, class away3d.materials.SinglePassMaterialBase
 | Indicates whether or not the material requires alpha blending during rendering.
reset(name:String, offset:Number) — method, class away3d.animators.AnimatorBase
reset() — method, class away3d.animators.data.AnimationRegisterCache
reset() — method, class away3d.core.traverse.SceneIterator
reset() — method, class away3d.debug.AwayStats
reset() — method, class away3d.library.utils.AssetLibraryIterator
reset() — method, class away3d.materials.compilation.MethodDependencyCounter
reset() — method, class away3d.materials.compilation.ShaderRegisterCache
 | Resets all registers.
reset() — method, class away3d.materials.methods.CompositeDiffuseMethod
reset() — method, class away3d.materials.methods.CompositeSpecularMethod
reset() — method, class away3d.materials.methods.MethodVO
reset() — method, class away3d.materials.methods.NearShadowMapMethod
reset() — method, class away3d.materials.methods.OutlineMethod
reset() — method, class away3d.materials.methods.ShadingMethodBase
resetAssetPath(name:String, ns:String, overrideOriginal:Boolean) — method, interface away3d.library.assets.IAsset
resetAssetPath(name:String, ns:String, overrideOriginal:Boolean) — method, class away3d.library.assets.NamedAssetBase
resetTime(offset:int) — method, class away3d.animators.ParticleAnimator
resolve() — method, class away3d.loaders.misc.ResourceDependency
 | Resolve the dependency when it's loaded with the parent parser.
resolveConflict(changedAsset:away3d.library.assets:IAsset, oldAsset:away3d.library.assets:IAsset, assetsDictionary:Object, precedence:String) — method, class away3d.library.naming.ConflictStrategyBase
 | Resolve a naming conflict between two assets.
resolveConflict(changedAsset:away3d.library.assets:IAsset, oldAsset:away3d.library.assets:IAsset, assetsDictionary:Object, precedence:String) — method, class away3d.library.naming.ErrorConflictStrategy
resolveConflict(changedAsset:away3d.library.assets:IAsset, oldAsset:away3d.library.assets:IAsset, assetsDictionary:Object, precedence:String) — method, class away3d.library.naming.IgnoreConflictStrategy
resolveConflict(changedAsset:away3d.library.assets:IAsset, oldAsset:away3d.library.assets:IAsset, assetsDictionary:Object, precedence:String) — method, class away3d.library.naming.NumSuffixConflictStrategy
resolveDependency(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.AC3DParser
 | Resolve a dependency when it's loaded.
resolveDependency(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.AWD1Parser
 | Resolve a dependency when it's loaded.
resolveDependency(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.AWD2Parser
 | Resolve a dependency when it's loaded.
resolveDependency(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.DAEParser
resolveDependency(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.MD2Parser
 | Resolve a dependency when it's loaded.
resolveDependency(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.Max3DSParser
resolveDependency(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.OBJParser
 | Resolve a dependency when it's loaded.
resolveDependency(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.ParserBase
 | Resolve a dependency when it's loaded.
resolveDependencyFailure(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.AC3DParser
resolveDependencyFailure(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.AWD1Parser
 | Resolve a dependency loading failure.
resolveDependencyFailure(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.AWD2Parser
 | Resolve a dependency loading failure.
resolveDependencyFailure(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.DAEParser
resolveDependencyFailure(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.MD2Parser
 | Resolve a dependency loading failure.
resolveDependencyFailure(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.Max3DSParser
resolveDependencyFailure(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.OBJParser
 | Resolve a dependency loading failure.
resolveDependencyFailure(resourceDependency:away3d.loaders.misc:ResourceDependency) — method, class away3d.loaders.parsers.ParserBase
 | Resolve a dependency loading failure.
resolveFailure() — method, class away3d.loaders.misc.ResourceDependency
 | Resolve a dependency failure.
resourceComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when a full resource (including dependencies) finishes loading.
resourceComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when a full resource (including dependencies) finishes loading.
resourceComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when a full resource (including dependencies) finishes loading.
resourceComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when a full resource (including dependencies) finishes loading.
RESOURCE_COMPLETE — Constant Static Property, class away3d.events.LoaderEvent
 | Dispatched when a resource and all of its dependencies is retrieved.
ResourceDependency — class, package away3d.loaders.misc
 | ResourceDependency represents the data required to load, parse and resolve additional files ("dependencies") required by a parser, used by ResourceLoadSession.
ResourceDependency(id:String, req:flash.net:URLRequest, data:any, parentParser:away3d.loaders.parsers:ParserBase, retrieveAsRawData:Boolean, suppressAssetEvents:Boolean) — Constructor, class away3d.loaders.misc.ResourceDependency
resumeParsingAfterDependencies() — method, class away3d.loaders.parsers.AWDParser
resumeParsingAfterDependencies() — method, class away3d.loaders.parsers.ParserBase
retrieveAsRawData — Property, class away3d.loaders.misc.ResourceDependency
REVISION — Constant Static Property, class away3d.Away3D
revolutions — Property, class away3d.extrusions.LatheExtrude
 | Defines the number of revolutions performed by the lathe extrusion.
right — Property, class away3d.animators.nodes.SkeletonDirectionalNode
 | Defines the right configured input node to use for the blended output.
right — Property, class away3d.materials.utils.MultipleMaterials
 | Defines the material applied to the right side of the cube.
RIGHT — Constant Static Property, class away3d.tools.utils.Projector
rightCamera — Property, class away3d.stereo.StereoCamera3D
rightClickMenuEnabled — Property, class away3d.containers.View3D
rightVector — Property, class away3d.core.base.Object3D
RimLightMethod — class, package away3d.materials.methods
RimLightMethod(color:uint, strength:Number, power:Number, blend:String) — Constructor, class away3d.materials.methods.RimLightMethod
roll(angle:Number) — method, class away3d.core.base.Object3D
 | Rotates the 3d object around it's local z-axis
_rootDelta — Property, class away3d.animators.states.AnimationStateBase
_rootNode — Property, class away3d.core.partition.Partition3D
_rot — Property, class away3d.core.base.Object3D
rotate(axis:flash.geom:Vector3D, angle:Number) — method, class away3d.containers.ObjectContainer3D
rotate(axis:flash.geom:Vector3D, angle:Number) — method, class away3d.core.base.Object3D
 | Rotates the 3d object around an axis by a defined angle
rotatePoint(vector:flash.geom:Vector3D, target:flash.geom:Vector3D) — method, class away3d.core.math.Quaternion
 | Rotates a point.
rotatePoint(aPoint:flash.geom:Vector3D, rotation:flash.geom:Vector3D) — Static Method , class away3d.core.math.Vector3DUtils
rotateTo(ax:Number, ay:Number, az:Number) — method, class away3d.core.base.Object3D
 | Rotates the 3d object directly to a euler angle
rotation — Property, class away3d.animators.data.UVAnimationFrame
 | The rotation value (in degrees) of the UV animation frame.
rotation — Property, class away3d.containers.View3D
rotationalVelocity — Property, class away3d.animators.states.ParticleRotationalVelocityState
 | Defines the default rotationalVelocity of the state, used when in global mode.
ROTATIONALVELOCITY_VECTOR3D — Constant Static Property, class away3d.animators.nodes.ParticleRotationalVelocityNode
 | Reference for rotational velocity node properties on a single particle (when in local property mode).
rotationChanged — Event, class away3d.core.base.Object3D
 | Dispatched when the rotation of the 3d object changes.
ROTATION_CHANGED — Constant Static Property, class away3d.events.Object3DEvent
 | Defines the value of the type property of a rotationChanged event object.
rotationRegisters — Property, class away3d.animators.data.AnimationRegisterCache
rotations — Property, class away3d.animators.PathAnimator
 | sets an optional Vector.<Vector3D> of rotations.
rotations — Property, class away3d.extrusions.PathExtrude
 | An optional Vector.<Vector3D> of Vector3D objects that defines a series of rotations to be set on each PathSegment.
rotationX — Property, class away3d.containers.View3D
rotationX — Property, class away3d.core.base.Object3D
 | Defines the euler angle of rotation of the 3d object around the x-axis, relative to the local coordinates of the parent ObjectContainer3D.
rotationY — Property, class away3d.containers.View3D
rotationY — Property, class away3d.core.base.Object3D
 | Defines the euler angle of rotation of the 3d object around the y-axis, relative to the local coordinates of the parent ObjectContainer3D.
rotationZ — Property, class away3d.containers.View3D
rotationZ — Property, class away3d.core.base.Object3D
 | Defines the euler angle of rotation of the 3d object around the z-axis, relative to the local coordinates of the parent ObjectContainer3D.
_rttBufferManager — Property, class away3d.containers.View3D
RTTBufferManager — class, package away3d.core.managers
RTTBufferManager(se:RTTBufferManager.as$131:SingletonEnforcer, stage3DProxy:away3d.core.managers:Stage3DProxy) — Constructor, class away3d.core.managers.RTTBufferManager
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


S

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
S Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
saturation — Property, class away3d.filters.HueSaturationFilter3D
saturation — Property, class away3d.filters.tasks.Filter3DHueSaturationTask
_sca — Property, class away3d.core.base.Object3D
scale — Property, class away3d.animators.nodes.ParticleUVNode
scale — Property, class away3d.audio.SoundTransform3D
_scale — Property, class away3d.audio.drivers.AbstractSound3DDriver
scale — Property, class away3d.audio.drivers.AbstractSound3DDriver
scale — Property, interface away3d.audio.drivers.ISound3DDriver
 | Arbitrary value by which all distances are divided.
scale — Property, class away3d.audio.drivers.SimplePanVolumeDriver
scale(scale:Number) — method, class away3d.core.base.CompactSubGeometry
scale(scale:Number) — method, class away3d.core.base.Geometry
 | Scales the geometry.
scale(scale:Number) — method, interface away3d.core.base.ISubGeometry
scale(value:Number) — method, class away3d.core.base.Object3D
 | Appends a uniform scale to the current transformation.
scale(scale:Number) — method, class away3d.core.base.SubGeometry
scale(scale:Number) — method, class away3d.core.base.SubGeometryBase
 | Scales the geometry.
scale — Property, class away3d.loaders.parsers.OBJParser
 | Scaling factor applied directly to vertices data
scale(scale:Number) — method, class away3d.primitives.PrimitiveBase
 | Scales the geometry.
scale — Property, class away3d.textures.PlanarReflectionTexture
 | A scale factor to reduce the quality of the reflection.
scaleAndRotateTarget — Property, class away3d.animators.data.AnimationRegisterCache
scaleChanged — Event, class away3d.core.base.Object3D
 | Dispatched when the scale of the 3d object changes.
SCALE_CHANGED — Constant Static Property, class away3d.events.Object3DEvent
 | Defines the value of the type property of a scaleChanged event object.
scaleDistance — Property, class away3d.audio.Sound3D
 | Defines a scale value used by the driver when adjusting sound intensity to simulate distance.
_scaledTextureHeight — Property, class away3d.filters.tasks.Filter3DTaskBase
_scaledTextureWidth — Property, class away3d.filters.tasks.Filter3DTaskBase
scales — Property, class away3d.extrusions.PathExtrude
 | An optional Vector.<Vector3D> of Vector3D objects that defines a series of scales to be set on each PathSegment.
scaleU — Property, class away3d.animators.data.UVAnimationFrame
 | The u-component scale of the UV animation frame.
scaleU — Property, interface away3d.core.base.ISubGeometry
scaleU — Property, class away3d.core.base.SubGeometryBase
 | Scales the uv coordinates
scaleU — Property, class away3d.core.base.SubMesh
scaleUV(scaleU:Number, scaleV:Number) — method, class away3d.core.base.CompactSubGeometry
scaleUV(scaleU:Number, scaleV:Number) — method, class away3d.core.base.Geometry
 | Scales the uv coordinates (tiling)
scaleUV(scaleU:Number, scaleV:Number) — method, interface away3d.core.base.ISubGeometry
scaleUV(scaleU:Number, scaleV:Number) — method, class away3d.core.base.SubGeometry
scaleUV(scaleU:Number, scaleV:Number) — method, class away3d.core.base.SubGeometryBase
scaleUV(scaleU:Number, scaleV:Number) — method, class away3d.primitives.PrimitiveBase
 | Scales the uv coordinates (tiling)
scaleV — Property, class away3d.animators.data.UVAnimationFrame
 | The v-component scale of the UV animation frame.
scaleV — Property, interface away3d.core.base.ISubGeometry
scaleV — Property, class away3d.core.base.SubGeometryBase
scaleV — Property, class away3d.core.base.SubMesh
SCALE_VECTOR3D — Constant Static Property, class away3d.animators.nodes.ParticleScaleNode
 | Reference for scale node properties on a single particle (when in local property mode).
scaleX — Property, class away3d.containers.View3D
_scaleX — Property, class away3d.core.base.Object3D
scaleX — Property, class away3d.core.base.Object3D
 | Defines the scale of the 3d object along the x-axis, relative to local coordinates.
scaleX — Property, class away3d.tools.utils.ColorHitMap
 | defines the scaleX and scaleY.
scaleY — Property, class away3d.containers.View3D
_scaleY — Property, class away3d.core.base.Object3D
scaleY — Property, class away3d.core.base.Object3D
 | Defines the scale of the 3d object along the y-axis, relative to local coordinates.
scaleY — Property, class away3d.tools.utils.ColorHitMap
scaleZ — Property, class away3d.containers.View3D
_scaleZ — Property, class away3d.core.base.Object3D
scaleZ — Property, class away3d.core.base.Object3D
 | Defines the scale of the 3d object along the z-axis, relative to local coordinates.
scatterColor — Property, class away3d.materials.methods.SubsurfaceScatteringDiffuseMethod
 | The colour the light becomes inside the object.
scattering — Property, class away3d.materials.methods.SubsurfaceScatteringDiffuseMethod
 | The amount by which the light scatters.
scatterTexture — Property, class away3d.materials.methods.WrapDiffuseMethod
_scene — Property, class away3d.containers.ObjectContainer3D
scene — Property, class away3d.containers.ObjectContainer3D
 | A reference to the Scene3D object to which this object belongs.
_scene — Property, class away3d.containers.View3D
scene — Property, class away3d.containers.View3D
 | The scene that's used to render for this viewport
scene — Property, class away3d.core.traverse.PartitionTraverser
 | The scene being traversed.
scene — Property, class away3d.entities.Entity
 | A reference to the Scene3D object to which this object belongs.
Scene3D — class, package away3d.containers
 | The Scene3D class represents an independent 3D scene in which 3D objects can be created and manipulated.
Scene3D() — Constructor, class away3d.containers.Scene3D
 | Creates a new Scene3D object.
Scene3DEvent — class, package away3d.events
Scene3DEvent(type:String, objectContainer:away3d.containers:ObjectContainer3D) — Constructor, class away3d.events.Scene3DEvent
sceneChanged — Event, class away3d.containers.ObjectContainer3D
 | Dispatched when the parent scene of the 3d object changes.
SCENE_CHANGED — Constant Static Property, class away3d.events.Object3DEvent
 | Defines the value of the type property of a sceneChanged event object.
sceneDirection — Property, class away3d.lights.DirectionalLight
 | The direction of the light in scene coordinates.
_sceneGraphRoot — Property, class away3d.containers.Scene3D
SceneIterator — class, package away3d.core.traverse
SceneIterator(scene:away3d.containers:Scene3D) — Constructor, class away3d.core.traverse.SceneIterator
_sceneMatrixIndex — Property, class away3d.materials.compilation.ShaderCompiler
sceneMatrixIndex — Property, class away3d.materials.compilation.ShaderCompiler
_sceneMatrixIndex — Property, class away3d.materials.passes.CompiledPass
sceneNormal — Property, class away3d.events.MouseEvent3D
 | The normal in scene space where the event took place
_sceneNormalMatrixIndex — Property, class away3d.materials.compilation.ShaderCompiler
sceneNormalMatrixIndex — Property, class away3d.materials.compilation.ShaderCompiler
_sceneNormalMatrixIndex — Property, class away3d.materials.passes.CompiledPass
scenePosition — Property, class away3d.containers.ObjectContainer3D
 | The global position of the ObjectContainer3D in the scene.
scenePosition — Property, class away3d.events.MouseEvent3D
 | The position in scene space where the event took place
_sceneTransform — Property, class away3d.containers.ObjectContainer3D
sceneTransform — Property, class away3d.containers.ObjectContainer3D
 | The transformation matrix that transforms from model to world space.
sceneTransform — Property, interface away3d.core.base.IRenderable
 | The transformation matrix that transforms from model to world space.
sceneTransform — Property, class away3d.core.base.SubMesh
 | The scene transform object that transforms from model to world space.
scenetransformChanged — Event, class away3d.containers.ObjectContainer3D
 | Dispatched when the scene transform matrix of the 3d object changes.
SCENETRANSFORM_CHANGED — Constant Static Property, class away3d.events.Object3DEvent
 | Defines the value of the type property of a scenetransformChanged event object.
_sceneTransformDirty — Property, class away3d.containers.ObjectContainer3D
scissorRect — Property, class away3d.core.managers.Stage3DProxy
_scissorRects — Property, class away3d.lights.shadowmaps.CascadeShadowMapper
_screenPass — Property, class away3d.materials.SinglePassMaterialBase
screenX — Property, class away3d.events.MouseEvent3D
 | The horizontal coordinate at which the event occurred in view coordinates.
screenY — Property, class away3d.events.MouseEvent3D
 | The vertical coordinate at which the event occurred in view coordinates.
secondaryFragmentConstantsIndex — Property, class away3d.materials.methods.MethodVO
secondaryInputTexture — Property, class away3d.filters.tasks.Filter3DDoubleBufferCopyTask
secondaryNormalMap — Property, class away3d.materials.methods.SimpleWaterNormalMethod
secondaryTexturesIndex — Property, class away3d.materials.methods.MethodVO
_secondaryUvBuffer — Property, class away3d.core.base.SubGeometry
_secondaryUvBufferContext — Property, class away3d.core.base.SubGeometry
_secondaryUVBufferIndex — Property, class away3d.materials.compilation.ShaderCompiler
secondaryUVBufferIndex — Property, class away3d.materials.compilation.ShaderCompiler
_secondaryUVBufferIndex — Property, class away3d.materials.passes.CompiledPass
secondaryUVData — Property, class away3d.core.base.SubGeometry
secondaryUVDependencies — Property, class away3d.materials.compilation.MethodDependencyCounter
secondaryUVOffset — Property, class away3d.core.base.CompactSubGeometry
secondaryUVOffset — Property, interface away3d.core.base.ISubGeometry
 | The offset into SecondaryUVData vector where the UVs are placed
secondaryUVOffset — Property, class away3d.core.base.SubGeometry
_secondaryUvs — Property, class away3d.core.base.SubGeometry
_secondaryUvsInvalid — Property, class away3d.core.base.SubGeometry
secondaryUVStride — Property, class away3d.core.base.CompactSubGeometry
secondaryUVStride — Property, interface away3d.core.base.ISubGeometry
 | The distance between two secondary UV elements
secondaryUVStride — Property, class away3d.core.base.SubGeometry
secondaryUVVarying — Property, class away3d.materials.compilation.ShaderRegisterData
secondaryVertexConstantsIndex — Property, class away3d.materials.methods.MethodVO
seek(val:Number) — method, interface away3d.materials.utils.IVideoPlayer
 | Seeks to a given time in the video, specified in seconds, with a precision of three decimal places (milliseconds).
seek(val:Number) — method, class away3d.materials.utils.SimpleVideoPlayer
Segment — class, package away3d.primitives.data
Segment(start:flash.geom:Vector3D, end:flash.geom:Vector3D, anchor:flash.geom:Vector3D, colorStart:uint, colorEnd:uint, thickness:Number) — Constructor, class away3d.primitives.data.Segment
SegmentedPathBase — class, package away3d.paths
SegmentedPathBase(pointsPerSegment:uint, data:Vector$flash.geom:Vector3D) — Constructor, class away3d.paths.SegmentedPathBase
SegmentMaterial — class, package away3d.materials
 | SegmentMaterial is a material exclusively used to render wireframe object
SegmentMaterial(thickness:Number) — Constructor, class away3d.materials.SegmentMaterial
 | Creates a new WireframeMaterial object.
SegmentPass — class, package away3d.materials.passes
SegmentPass(thickness:Number) — Constructor, class away3d.materials.passes.SegmentPass
 | Creates a new WireframePass object.
_segments — Property, class away3d.entities.SegmentSet
segments — Property, interface away3d.paths.IPath
 | The IPathSegment instances which make up this path.
_segments — Property, class away3d.paths.SegmentedPathBase
segments — Property, class away3d.paths.SegmentedPathBase
 | returns the Vector.<PathSegment> holding the elements (PathSegment) of the path
_segmentsBase — Property, class away3d.primitives.data.Segment
segmentsBase — Property, class away3d.primitives.data.Segment
segmentsD — Property, class away3d.primitives.CubeGeometry
 | The number of segments that make up the cube along the Z-axis.
SegmentSet — class, package away3d.entities
SegmentSet() — Constructor, class away3d.entities.SegmentSet
SEGMENT_SET — Constant Static Property, class away3d.library.assets.AssetType
SEGMENT_SET_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
segmentsH — Property, class away3d.extrusions.Elevation
 | The number of segments that make up the plane along the Y or Z-axis, depending on whether yUp is true or false, respectively.
segmentsH — Property, class away3d.primitives.CapsuleGeometry
 | Defines the number of vertical segments that make up the capsule.
segmentsH — Property, class away3d.primitives.CubeGeometry
 | The number of segments that make up the cube along the Y-axis.
_segmentsH — Property, class away3d.primitives.CylinderGeometry
segmentsH — Property, class away3d.primitives.CylinderGeometry
 | Defines the number of vertical segments that make up the cylinder.
segmentsH — Property, class away3d.primitives.PlaneGeometry
 | The number of segments that make up the plane along the Y or Z-axis, depending on whether yUp is true or false, respectively.
segmentsH — Property, class away3d.primitives.SphereGeometry
 | Defines the number of vertical segments that make up the sphere.
segmentsH — Property, class away3d.primitives.WireframePlane
 | The number of segments that make up the plane along the Y-axis.
segmentSpread — Property, class away3d.extrusions.PathDuplicator
 | defines if the meshes[index] is repeated per segments or duplicated after each others.
_segmentsR — Property, class away3d.primitives.TorusGeometry
segmentsR — Property, class away3d.primitives.TorusGeometry
 | Defines the number of horizontal segments that make up the torus.
_segmentsT — Property, class away3d.primitives.TorusGeometry
segmentsT — Property, class away3d.primitives.TorusGeometry
 | Defines the number of vertical segments that make up the torus.
segmentsW — Property, class away3d.primitives.CapsuleGeometry
 | Defines the number of horizontal segments that make up the capsule.
segmentsW — Property, class away3d.primitives.CubeGeometry
 | The number of segments that make up the cube along the X-axis.
_segmentsW — Property, class away3d.primitives.CylinderGeometry
segmentsW — Property, class away3d.primitives.CylinderGeometry
 | Defines the number of horizontal segments that make up the cylinder.
segmentsW — Property, class away3d.primitives.PlaneGeometry
 | The number of segments that make up the plane along the X-axis.
segmentsW — Property, class away3d.primitives.SphereGeometry
 | Defines the number of horizontal segments that make up the sphere.
segmentsW — Property, class away3d.primitives.WireframePlane
 | The number of segments that make up the plane along the X-axis.
separator — Property, class away3d.tools.serialize.TraceSerializer
Serialize — class, package away3d.tools.serialize
Serialize() — Constructor, class away3d.tools.serialize.Serialize
serializeAnimationState(animator:away3d.animators:IAnimator, serializer:away3d.tools.serialize:SerializerBase) — Static Method , class away3d.tools.serialize.Serialize
serializeAnimator(animator:away3d.animators:IAnimator, serializer:away3d.tools.serialize:SerializerBase) — Static Method , class away3d.tools.serialize.Serialize
serializeJointPose(jointPose:away3d.animators.data:JointPose, serializer:away3d.tools.serialize:SerializerBase) — Static Method , class away3d.tools.serialize.Serialize
serializeMaterial(material:away3d.materials:MaterialBase, serializer:away3d.tools.serialize:SerializerBase) — Static Method , class away3d.tools.serialize.Serialize
serializeMesh(mesh:away3d.entities:Mesh, serializer:away3d.tools.serialize:SerializerBase) — Static Method , class away3d.tools.serialize.Serialize
serializeObjectContainer(objectContainer3D:away3d.containers:ObjectContainer3D, serializer:away3d.tools.serialize:SerializerBase) — Static Method , class away3d.tools.serialize.Serialize
SerializerBase — class, package away3d.tools.serialize
 | SerializerBase is the abstract class for all Serializers.
SerializerBase() — Constructor, class away3d.tools.serialize.SerializerBase
 | Creates a new SerializerBase object.
serializeScene(scene:away3d.containers:Scene3D, serializer:away3d.tools.serialize:SerializerBase) — Static Method , class away3d.tools.serialize.Serialize
serializeSkeleton(skeleton:away3d.animators.data:Skeleton, serializer:away3d.tools.serialize:SerializerBase) — Static Method , class away3d.tools.serialize.Serialize
serializeSkeletonJoint(skeletonJoint:away3d.animators.data:SkeletonJoint, serializer:away3d.tools.serialize:SerializerBase) — Static Method , class away3d.tools.serialize.Serialize
serializeSkeletonPose(skeletonPose:away3d.animators.data:SkeletonPose, serializer:away3d.tools.serialize:SerializerBase) — Static Method , class away3d.tools.serialize.Serialize
serializeSubGeometry(subGeometry:away3d.core.base:ISubGeometry, serializer:away3d.tools.serialize:SerializerBase) — Static Method , class away3d.tools.serialize.Serialize
serializeSubMesh(subMesh:away3d.core.base:SubMesh, serializer:away3d.tools.serialize:SerializerBase) — Static Method , class away3d.tools.serialize.Serialize
setBlendMode(value:String, force:Boolean) — method, class away3d.materials.passes.MaterialPassBase
setBlendWeightAt(index:uint, blendWeight:Number) — method, class away3d.animators.states.SkeletonNaryLERPState
 | Sets the blend weight of the skeleton aniamtion node that resides at the given input index.
setConstantDataBuffers(vertexConstantData:Vector$Number, fragmentConstantData:Vector$Number) — method, class away3d.materials.compilation.ShaderCompiler
setDataLength() — method, class away3d.animators.data.AnimationRegisterCache
setDepthMap(depthMap:away3d.textures:TextureProxyBase) — method, class away3d.lights.shadowmaps.ShadowMapperBase
 | This is used by renderers that can support depth maps to be shared across instances
setFragmentConst(index:int, x:Number, y:Number, z:Number, w:Number) — method, class away3d.animators.data.AnimationRegisterCache
setIndex(index:uint) — method, class away3d.library.utils.AssetLibraryIterator
setLocalRay(localPosition:flash.geom:Vector3D, localDirection:flash.geom:Vector3D) — method, class away3d.core.pick.AutoPickingCollider
 | Sets the position and direction of a picking ray in local coordinates to the entity.
setLocalRay(localPosition:flash.geom:Vector3D, localDirection:flash.geom:Vector3D) — method, interface away3d.core.pick.IPickingCollider
 | Sets the position and direction of a picking ray in local coordinates to the entity.
setLocalRay(localPosition:flash.geom:Vector3D, localDirection:flash.geom:Vector3D) — method, class away3d.core.pick.PBPickingCollider
 | Sets the position and direction of a picking ray in local coordinates to the entity.
setLocalRay(localPosition:flash.geom:Vector3D, localDirection:flash.geom:Vector3D) — method, class away3d.core.pick.PickingColliderBase
setOffset(x:Number, y:Number, z:Number) — method, class away3d.animators.PathAnimator
 | sets an optional offset to the position on the path, ideal for cameras or reusing the same Path object for parallel animations
setParent(value:away3d.core.partition:InvertedOctreeNode) — method, class away3d.core.partition.InvertedOctreeNode
setPositionedLights(numPointLights:uint, lightSourceMask:uint) — method, class away3d.materials.compilation.MethodDependencyCounter
setPositions(value:Vector$flash.geom:Vector3D) — method, class away3d.animators.states.ParticlePositionState
setProgram(program3D:flash.display3D:Program3D) — method, class away3d.core.managers.Stage3DProxy
 | Set the shader program for the subsequent rendering calls.
setProgram3D(pass:away3d.materials.passes:MaterialPassBase, vertexCode:String, fragmentCode:String) — method, class away3d.core.managers.AGALProgram3DCache
setRegisterIndex(node:away3d.animators.nodes:AnimationNodeBase, parameterIndex:int, registerIndex:int) — method, class away3d.animators.data.AnimationRegisterCache
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:away3d.cameras:Camera3D) — method, interface away3d.animators.IAnimator
 | Sets the GPU render state required by the animation that is dependent of the rendered object.
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:away3d.cameras:Camera3D) — method, class away3d.animators.ParticleAnimator
 | Sets the GPU render state required by the animation that is dependent of the rendered object.
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:away3d.cameras:Camera3D) — method, class away3d.animators.SkeletonAnimator
 | Sets the GPU render state required by the animation that is dependent of the rendered object.
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:away3d.cameras:Camera3D) — method, class away3d.animators.UVAnimator
 | Sets the GPU render state required by the animation that is dependent of the rendered object.
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, vertexConstantOffset:int, vertexStreamOffset:int, camera:away3d.cameras:Camera3D) — method, class away3d.animators.VertexAnimator
 | Sets the GPU render state required by the animation that is dependent of the rendered object.
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleAccelerationState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleBezierCurveState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleBillboardState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleColorState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleFollowState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleOrbitState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleOscillatorState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticlePositionState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleRotateToHeadingState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleRotationalVelocityState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleScaleState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleSpriteSheetState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleStateBase
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleTimeState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleUVState
setRenderState(stage3DProxy:away3d.core.managers:Stage3DProxy, renderable:away3d.core.base:IRenderable, animationSubGeometry:away3d.animators.data:AnimationSubGeometry, animationRegisterCache:away3d.animators.data:AnimationRegisterCache, camera:away3d.cameras:Camera3D) — method, class away3d.animators.states.ParticleVelocityState
setRenderState(vo:away3d.materials.methods:MethodVO, renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.methods.CascadeShadowMapMethod
setRenderState(vo:away3d.materials.methods:MethodVO, renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.methods.NearShadowMapMethod
setRenderState(vo:away3d.materials.methods:MethodVO, renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.methods.ProjectiveTextureMethod
setRenderState(vo:away3d.materials.methods:MethodVO, renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.methods.ShadingMethodBase
 | Sets the render state for a single renderable.
setRenderState(vo:away3d.materials.methods:MethodVO, renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.methods.SimpleShadowMapMethodBase
setRenderState(vo:away3d.materials.methods:MethodVO, renderable:away3d.core.base:IRenderable, stage3DProxy:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.materials.methods.SubsurfaceScatteringDiffuseMethod
setRenderTarget(target:flash.display3D.textures:TextureBase, enableDepthAndStencil:Boolean, surfaceSelector:int) — method, class away3d.core.managers.Stage3DProxy
setRenderTargets(mainTarget:flash.display3D.textures:Texture, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.BloomFilter3D
setRenderTargets(mainTarget:flash.display3D.textures:Texture, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.BlurFilter3D
setRenderTargets(mainTarget:flash.display3D.textures:Texture, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.DepthOfFieldFilter3D
setRenderTargets(mainTarget:flash.display3D.textures:Texture, stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.Filter3DBase
setRotationalVelocities(value:Vector$flash.geom:Vector3D) — method, class away3d.animators.states.ParticleRotationalVelocityState
setShadedTarget(shadedTarget:String) — method, class away3d.animators.data.AnimationRegisterCache
setSize(width:int, height:int) — method, class away3d.textures.TextureProxyBase
setSplitRatio(index:uint, value:Number) — method, class away3d.lights.shadowmaps.CascadeShadowMapper
setTextureAt(index:int, texture:flash.display3D.textures:TextureBase) — method, class away3d.core.managers.Stage3DProxy
 | Assign the texture in the Context3D ready for use in the shader.
setTextureSampling(smooth:Boolean, repeat:Boolean, mipmap:Boolean) — method, class away3d.materials.compilation.ShaderCompiler
setUv0Value(u:Number, v:Number) — method, class away3d.core.base.data.Face
 | uv0 u and v values
setUv1Value(u:Number, v:Number) — method, class away3d.core.base.data.Face
 | uv1 u and v values
setUv2Value(u:Number, v:Number) — method, class away3d.core.base.data.Face
 | uv2 u and v values
setUVat(index:uint, u:Number, v:Number) — method, class away3d.core.base.data.Face
 | To set uv values for either uv0, uv1 or uv2.
setUVSourceAndTarget(UVAttribute:String, UVVaring:String) — method, class away3d.animators.data.AnimationRegisterCache
setVelocities(value:Vector$flash.geom:Vector3D) — method, class away3d.animators.states.ParticleVelocityState
setVertexAt(index:uint, x:Number, y:Number, z:Number) — method, class away3d.core.base.data.Face
 | To set uv values for either v0, v1 or v2.
setVertexConst(index:int, x:Number, y:Number, z:Number, w:Number) — method, class away3d.animators.data.AnimationRegisterCache
setVertexConstFromMatrix(index:int, matrix:flash.geom:Matrix3D) — method, class away3d.animators.data.AnimationRegisterCache
shadedTarget — Property, class away3d.materials.compilation.ShaderCompiler
shadedTarget — Property, class away3d.materials.compilation.ShaderRegisterData
_shadedTarget — Property, class away3d.materials.passes.MaterialPassBase
SHADER — Constant Static Property, class away3d.core.pick.PickingType
 | Uses a render pass to pick objects based on a key color that is read back into the engine.
ShaderCompiler — class, package away3d.materials.compilation
ShaderCompiler() — Constructor, class away3d.materials.compilation.ShaderCompiler
SHADER_INVALIDATED — Constant Static Property, class away3d.events.ShadingMethodEvent
ShaderMethodSetup — class, package away3d.materials.methods
ShaderMethodSetup() — Constructor, class away3d.materials.methods.ShaderMethodSetup
ShaderPicker — class, package away3d.core.pick
 | Picks a 3d object from a view or scene by performing a separate render pass on the scene around the area being picked using key color values, then reading back the color value of the pixel in the render representing the picking ray.
ShaderPicker() — Constructor, class away3d.core.pick.ShaderPicker
 | Creates a new ShaderPicker object.
shaderPickingDetails — Property, interface away3d.core.base.IRenderable
shaderPickingDetails — Property, class away3d.core.base.SubMesh
shaderPickingDetails — Property, class away3d.entities.Entity
 | Used by the shader-based picking system to determine whether a separate render pass is made in order to offer more details for the picking collision object, including local position, normal vector and uv value.
ShaderRegisterCache — class, package away3d.materials.compilation
 | ShaderRegister Cache provides the usage management system for all registers during shading compilation.
ShaderRegisterCache() — Constructor, class away3d.materials.compilation.ShaderRegisterCache
 | Create a new ShaderRegisterCache object.
ShaderRegisterData — class, package away3d.materials.compilation
ShaderRegisterElement — class, package away3d.materials.compilation
 | A single register element (an entire register or a single register's component) used by the RegisterPool.
ShaderRegisterElement(regName:String, index:int, component:String) — Constructor, class away3d.materials.compilation.ShaderRegisterElement
 | Creates a new ShaderRegisterElement object.
ShadingMethodBase — class, package away3d.materials.methods
 | ShadingMethodBase provides an abstract base method for shading methods, used by DefaultScreenPass to compile the final shading program.
ShadingMethodBase() — Constructor, class away3d.materials.methods.ShadingMethodBase
 | Create a new ShadingMethodBase object.
ShadingMethodEvent — class, package away3d.events
ShadingMethodEvent(type:String, bubbles:Boolean, cancelable:Boolean) — Constructor, class away3d.events.ShadingMethodEvent
shadingModel — Property, class away3d.materials.methods.BasicSpecularMethod
 | The model used by the specular shader
shadingModel — Property, class away3d.materials.methods.CompositeSpecularMethod
 | The model used by the specular shader
ShadowCasterCollector — class, package away3d.core.traverse
 | The EntityCollector class is a traverser for scene partitions that collects all scene graph entities that are considered potientially visible.
ShadowCasterCollector() — Constructor, class away3d.core.traverse.ShadowCasterCollector
 | Creates a new EntityCollector object.
ShadowCasterPass — class, package away3d.materials.passes
 | DefaultScreenPass is a shader pass that uses shader methods to compile a complete program.
ShadowCasterPass(material:away3d.materials:MaterialBase) — Constructor, class away3d.materials.passes.ShadowCasterPass
 | Creates a new DefaultScreenPass objects.
ShadowMapMethodBase — class, package away3d.materials.methods
ShadowMapMethodBase(castingLight:away3d.lights:LightBase) — Constructor, class away3d.materials.methods.ShadowMapMethodBase
shadowMapper — Property, class away3d.lights.LightBase
_shadowMapper — Property, class away3d.materials.methods.ShadowMapMethodBase
ShadowMapperBase — class, package away3d.lights.shadowmaps
ShadowMapperBase() — Constructor, class away3d.lights.shadowmaps.ShadowMapperBase
shadowMethod — Property, class away3d.materials.MultiPassMaterialBase
 | The method to render shadows cast on this surface.
shadowMethod — Property, class away3d.materials.SinglePassMaterialBase
 | The method to render shadows cast on this surface.
_shadowMethod — Property, class away3d.materials.methods.ShaderMethodSetup
shadowMethod — Property, class away3d.materials.methods.ShaderMethodSetup
shadowMethod — Property, class away3d.materials.passes.CompiledPass
_shadowMethodVO — Property, class away3d.materials.methods.ShaderMethodSetup
_shadowRegister — Property, class away3d.materials.methods.BasicDiffuseMethod
shadowRegister — Property, class away3d.materials.methods.BasicDiffuseMethod
shadowRegister — Property, class away3d.materials.methods.BasicSpecularMethod
shadowRegister — Property, class away3d.materials.methods.CompositeDiffuseMethod
shadowRegister — Property, class away3d.materials.methods.CompositeSpecularMethod
_shadowsInvalid — Property, class away3d.lights.shadowmaps.ShadowMapperBase
_shareContext — Property, class away3d.containers.View3D
shareContext — Property, class away3d.containers.View3D
 | Defers control of Context3D clear() and present() calls to Stage3DProxy, enabling multiple Stage3D frameworks to share the same Context3D object.
_shareContext — Property, class away3d.core.render.RendererBase
shareContext — Property, class away3d.core.render.RendererBase
_sharedRegisters — Property, class away3d.materials.compilation.ShaderCompiler
sharedRegisters — Property, class away3d.materials.methods.CascadeShadowMapMethod
sharedRegisters — Property, class away3d.materials.methods.CompositeDiffuseMethod
sharedRegisters — Property, class away3d.materials.methods.CompositeSpecularMethod
sharedRegisters — Property, class away3d.materials.methods.NearShadowMapMethod
_sharedRegisters — Property, class away3d.materials.methods.ShadingMethodBase
sharedRegisters — Property, class away3d.materials.methods.ShadingMethodBase
shiftKey — Property, class away3d.events.MouseEvent3D
 | Indicates whether the Shift key is active (true) or inactive (false).
showBounds — Property, class away3d.entities.Entity
showDebug(mesh:away3d.entities:Mesh) — method, class away3d.tools.helpers.MeshDebugger
showDebugBounds — Property, class away3d.core.partition.DynamicGrid
showDebugBounds — Property, class away3d.core.partition.NodeBase
showDebugBounds — Property, class away3d.core.partition.Partition3D
showDebugBounds — Property, class away3d.core.partition.ViewVolumeRootNode
showInnerLines — Property, class away3d.materials.methods.OutlineMethod
showInnerLines — Property, class away3d.materials.passes.OutlinePass
sides — Property, class away3d.primitives.RegularPolygonGeometry
 | The number of sides of the regular polygon.
SimplePanVolumeDriver — class, package away3d.audio.drivers
 | The Simple pan/volume Sound3D driver will alter the pan and volume properties on the sound transform object of a regular flash.media.Sound3D representation of the sound.
SimplePanVolumeDriver() — Constructor, class away3d.audio.drivers.SimplePanVolumeDriver
SimpleShadowMapMethodBase — class, package away3d.materials.methods
SimpleShadowMapMethodBase(castingLight:away3d.lights:LightBase) — Constructor, class away3d.materials.methods.SimpleShadowMapMethodBase
SimpleVideoPlayer — class, package away3d.materials.utils
SimpleVideoPlayer() — Constructor, class away3d.materials.utils.SimpleVideoPlayer
SimpleWaterNormalMethod — class, package away3d.materials.methods
SimpleWaterNormalMethod(waveMap1:away3d.textures:Texture2DBase, waveMap2:away3d.textures:Texture2DBase) — Constructor, class away3d.materials.methods.SimpleWaterNormalMethod
since — Property, class away3d.errors.DeprecationError
SingleFileLoader — class, package away3d.loaders.misc
 | The SingleFileLoader is used to load a single file, as part of a resource.
SingleFileLoader() — Constructor, class away3d.loaders.misc.SingleFileLoader
 | Creates a new SingleFileLoader object.
SingleObjectDepthPass — class, package away3d.materials.passes
 | The SingleObjectDepthPass provides a material pass that renders a single object to a depth map from the point of view from a light.
SingleObjectDepthPass(textureSize:uint, polyOffset:Number) — Constructor, class away3d.materials.passes.SingleObjectDepthPass
 | Creates a new SingleObjectDepthPass object.
SinglePassMaterialBase — class, package away3d.materials
 | DefaultMaterialBase forms an abstract base class for the default materials provided by Away3D and use methods to define their appearance.
SinglePassMaterialBase() — Constructor, class away3d.materials.SinglePassMaterialBase
 | Creates a new DefaultMaterialBase object.
size — Property, class away3d.textures.CubeTextureBase
size — Property, class away3d.textures.RenderCubeTexture
skeleton — Property, class away3d.animators.SkeletonAnimator
 | Returns the skeleton object in use by the animator - this defines the number and heirarchy of joints used by the skinned geoemtry to which skeleon animator is applied.
Skeleton — class, package away3d.animators.data
 | A Skeleton object is a hierarchical grouping of joint objects that can be used for skeletal animation.
Skeleton() — Constructor, class away3d.animators.data.Skeleton
 | Creates a new Skeleton object
SKELETON — Constant Static Property, class away3d.library.assets.AssetType
SkeletonAnimationSet — class, package away3d.animators
 | The animation data set used by skeleton-based animators, containing skeleton animation data.
SkeletonAnimationSet(jointsPerVertex:uint) — Constructor, class away3d.animators.SkeletonAnimationSet
 | Creates a new SkeletonAnimationSet object.
SkeletonAnimator — class, package away3d.animators
 | Provides an interface for assigning skeleton-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.
SkeletonAnimator(animationSet:away3d.animators:SkeletonAnimationSet, skeleton:away3d.animators.data:Skeleton, forceCPU:Boolean) — Constructor, class away3d.animators.SkeletonAnimator
 | Creates a new SkeletonAnimator object.
SkeletonBinaryLERPNode — class, package away3d.animators.nodes
 | A skeleton animation node that uses two animation node inputs to blend a lineraly interpolated output of a skeleton pose.
SkeletonBinaryLERPNode() — Constructor, class away3d.animators.nodes.SkeletonBinaryLERPNode
 | Creates a new SkeletonBinaryLERPNode object.
SkeletonBinaryLERPState — class, package away3d.animators.states
SkeletonBinaryLERPState(animator:away3d.animators:IAnimator, skeletonAnimationNode:away3d.animators.nodes:SkeletonBinaryLERPNode) — Constructor, class away3d.animators.states.SkeletonBinaryLERPState
SkeletonClipNode — class, package away3d.animators.nodes
 | A skeleton animation node containing time-based animation data as individual skeleton poses.
SkeletonClipNode() — Constructor, class away3d.animators.nodes.SkeletonClipNode
 | Creates a new SkeletonClipNode object.
SkeletonClipState — class, package away3d.animators.states
SkeletonClipState(animator:away3d.animators:IAnimator, skeletonClipNode:away3d.animators.nodes:SkeletonClipNode) — Constructor, class away3d.animators.states.SkeletonClipState
skeletonComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when a skeleton asset has been constructed from a resource.
skeletonComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when a skeleton asset has been constructed from a resource.
skeletonComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when a skeleton asset has been constructed from a resource.
skeletonComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when a skeleton asset has been constructed from a resource.
skeletonComplete — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when a skeleton asset has been constructed from a resource.
skeletonComplete — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when a skeleton asset has been constructed from a resource.
SKELETON_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
SkeletonDifferenceNode — class, package away3d.animators.nodes
 | A skeleton animation node that uses a difference input pose with a base input pose to blend a linearly interpolated output of a skeleton pose.
SkeletonDifferenceNode() — Constructor, class away3d.animators.nodes.SkeletonDifferenceNode
 | Creates a new SkeletonAdditiveNode object.
SkeletonDifferenceState — class, package away3d.animators.states
SkeletonDifferenceState(animator:away3d.animators:IAnimator, skeletonAnimationNode:away3d.animators.nodes:SkeletonDifferenceNode) — Constructor, class away3d.animators.states.SkeletonDifferenceState
SkeletonDirectionalNode — class, package away3d.animators.nodes
 | A skeleton animation node that uses four directional input poses with an input direction to blend a linearly interpolated output of a skeleton pose.
SkeletonDirectionalNode() — Constructor, class away3d.animators.nodes.SkeletonDirectionalNode
SkeletonDirectionalState — class, package away3d.animators.states
SkeletonDirectionalState(animator:away3d.animators:IAnimator, skeletonAnimationNode:away3d.animators.nodes:SkeletonDirectionalNode) — Constructor, class away3d.animators.states.SkeletonDirectionalState
SkeletonJoint — class, package away3d.animators.data
 | A value obect representing a single joint in a skeleton object.
SkeletonJoint() — Constructor, class away3d.animators.data.SkeletonJoint
 | Creates a new SkeletonJoint object
SkeletonNaryLERPNode — class, package away3d.animators.nodes
 | A skeleton animation node that uses an n-dimensional array of animation node inputs to blend a lineraly interpolated output of a skeleton pose.
SkeletonNaryLERPNode() — Constructor, class away3d.animators.nodes.SkeletonNaryLERPNode
 | Creates a new SkeletonNaryLERPNode object.
SkeletonNaryLERPState — class, package away3d.animators.states
SkeletonNaryLERPState(animator:away3d.animators:IAnimator, skeletonAnimationNode:away3d.animators.nodes:SkeletonNaryLERPNode) — Constructor, class away3d.animators.states.SkeletonNaryLERPState
SkeletonPose — class, package away3d.animators.data
 | A collection of pose objects, determining the pose for an entire skeleton.
SkeletonPose() — Constructor, class away3d.animators.data.SkeletonPose
 | Creates a new SkeletonPose object.
SKELETON_POSE — Constant Static Property, class away3d.library.assets.AssetType
skeletonPoseComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when a skeleton pose asset has been constructed from a resource.
skeletonPoseComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when a skeleton pose asset has been constructed from a resource.
skeletonPoseComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when a skeleton pose asset has been constructed from a resource.
skeletonPoseComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when a skeleton pose asset has been constructed from a resource.
skeletonPoseComplete — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when a skeleton pose asset has been constructed from a resource.
skeletonPoseComplete — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when a skeleton pose asset has been constructed from a resource.
SKELETON_POSE_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
SkeletonUtils — class, package away3d.animators.utils
SkinExtrude — class, package away3d.extrusions
SkinExtrude(material:away3d.materials:MaterialBase, profiles:Vector$Vector$flash.geom:Vector3D, subdivision:uint, centerMesh:Boolean, closeShape:Boolean, coverAll:Boolean, flip:Boolean) — Constructor, class away3d.extrusions.SkinExtrude
SkinnedSubGeometry — class, package away3d.core.base
 | SkinnedSubGeometry provides a SubGeometry extension that contains data needed to skin vertices.
SkinnedSubGeometry(jointsPerVertex:int) — Constructor, class away3d.core.base.SkinnedSubGeometry
 | Creates a new SkinnedSubGeometry object.
_skyBox — Property, class away3d.core.traverse.EntityCollector
skyBox — Property, class away3d.core.traverse.EntityCollector
 | The sky box object if encountered.
SkyBox — class, package away3d.primitives
 | A SkyBox class is used to render a sky in the scene.
SkyBox(cubeMap:away3d.textures:CubeTextureBase) — Constructor, class away3d.primitives.SkyBox
 | Create a new SkyBox object.
SkyBoxMaterial — class, package away3d.materials
 | SkyBoxMaterial is a material exclusively used to render skyboxes
SkyBoxMaterial(cubeMap:away3d.textures:CubeTextureBase) — Constructor, class away3d.materials.SkyBoxMaterial
 | Creates a new SkyBoxMaterial object.
SkyBoxNode — class, package away3d.core.partition
 | SkyBoxNode is a space partitioning leaf node that contains a SkyBox object.
SkyBoxNode(skyBox:away3d.primitives:SkyBox) — Constructor, class away3d.core.partition.SkyBoxNode
 | Creates a new SkyBoxNode object.
SkyBoxPass — class, package away3d.materials.passes
 | SkyBoxPass provides a material pass exclusively used to render sky boxes from a cube texture.
SkyBoxPass() — Constructor, class away3d.materials.passes.SkyBoxPass
 | Creates a new SkyBoxPass object.
slerp(qa:away3d.core.math:Quaternion, qb:away3d.core.math:Quaternion, t:Number) — method, class away3d.core.math.Quaternion
 | Spherically interpolates between two quaternions, providing an interpolation between rotations with constant angle change rate.
_smooth — Property, class away3d.materials.MaterialBase
smooth — Property, class away3d.materials.MaterialBase
 | Indicates whether or not any used textures should use smoothing.
_smooth — Property, class away3d.materials.compilation.ShaderCompiler
_smooth — Property, class away3d.materials.passes.MaterialPassBase
smooth — Property, class away3d.materials.passes.MaterialPassBase
 | Defines whether smoothing should be applied to any used textures.
smoothed — Property, class away3d.paths.QuadraticPath
 | returns true if the smoothPath handler is being used.
smoothedHeightMap — Property, class away3d.extrusions.Elevation
smoothing — Property, class away3d.textures.WebcamTexture
 | Toggles smoothing on the texture as it's drawn (and potentially scaled) from the video stream to a BitmapData object.
smoothness — Property, class away3d.materials.methods.CelDiffuseMethod
 | The smoothness of the edge between 2 shading levels.
smoothness — Property, class away3d.materials.methods.CelSpecularMethod
 | The smoothness of the highlight edge.
smoothPath() — method, class away3d.paths.QuadraticPath
 | handler will smooth the path using anchors as control vector of the PathSegments note that this is not dynamic, the PathSegments values are overwrited
smoothScale — Property, class away3d.extrusions.PathExtrude
 | Defines if a scaling of a PathSegment defined from the scales array of Vector3D objects should affect the whole PathSegment evenly or be smoothly interpolated from previous PathSegment scale.
smoothSurface — Property, class away3d.extrusions.DelaunayMesh
 | Defines if the surface of the mesh must be smoothed or not.
smoothSurface — Property, class away3d.extrusions.LatheExtrude
 | Defines if the surface of the mesh must be smoothed or not.
smoothSurface — Property, class away3d.extrusions.PathExtrude
 | Defines if the surface of the mesh must be smoothed or not.
snapMesh(mesh:away3d.entities:Mesh) — method, class away3d.tools.utils.Grid
 | Apply the grid code to a single mesh
snapObject(object3d:away3d.containers:ObjectContainer3D, dovert:Boolean) — method, class away3d.tools.utils.Grid
 | Apply the grid code to a given object3D.
snapVertices(vertices:Vector$Number) — method, class away3d.tools.utils.Grid
 | Snaps to grid a given Vector.<Number> of vertices
SoftShadowMapMethod — class, package away3d.materials.methods
SoftShadowMapMethod(castingLight:away3d.lights:DirectionalLight, numSamples:int) — Constructor, class away3d.materials.methods.SoftShadowMapMethod
 | Creates a new BasicDiffuseMethod object.
sort(collector:away3d.core.traverse:EntityCollector) — method, interface away3d.core.sort.IEntitySorter
 | Sort the potentially visible data in an EntityCollector for rendering.
sort(collector:away3d.core.traverse:EntityCollector) — method, class away3d.core.sort.RenderableMergeSort
 | Sort the potentially visible data in an EntityCollector for rendering.
Sound3D — class, package away3d.audio
 | A sound source/emitter object that can be positioned in 3D space, and from which all audio playback will be transformed to simulate orientation. The Sound3D object works much in the same fashion as primitives, lights and cameras, in that it can be added to a scene and positioned therein.
Sound3D(sound:flash.media:Sound, reference:away3d.containers:ObjectContainer3D, driver:away3d.audio.drivers:ISound3DDriver, volume:Number, scale:Number) — Constructor, class away3d.audio.Sound3D
 | Create a Sound3D object, representing the sound source used for playback of a flash Sound object.
soundComplete — Event, class away3d.audio.Sound3D
 | Dispatched when end of sound stream is reached (bubbled from the internal sound object).
soundTransform — Property, class away3d.audio.SoundTransform3D
soundTransform — Property, interface away3d.materials.utils.IVideoPlayer
 | Provides access to the SoundTransform of the video stream
soundTransform — Property, class away3d.materials.utils.SimpleVideoPlayer
SoundTransform3D — class, package away3d.audio
 | SoundTransform3D is a convinience class that helps adjust a Soundtransform's volume and pan according position and distance of a listener and emitter object.
SoundTransform3D(emitter:away3d.containers:ObjectContainer3D, listener:away3d.containers:ObjectContainer3D, volume:Number, scale:Number) — Constructor, class away3d.audio.SoundTransform3D
 | Creates a new SoundTransform3D.
source — Property, class away3d.errors.DeprecationError
source — Property, interface away3d.materials.utils.IVideoPlayer
 | The source, url, to the video file
source — Property, class away3d.materials.utils.SimpleVideoPlayer
sourceEntity — Property, interface away3d.core.base.IRenderable
 | The entity that that initially provided the IRenderable to the render pipeline.
sourceEntity — Property, class away3d.core.base.SubMesh
 | The entity that that initially provided the IRenderable to the render pipeline (ie: the owning Mesh object).
sourceEntity — Property, class away3d.entities.SegmentSet
sourceEntity — Property, class away3d.entities.Sprite3D
sourceEntity — Property, class away3d.primitives.SkyBox
 | The entity that that initially provided the IRenderable to the render pipeline.
sourceRegisters — Property, class away3d.animators.data.AnimationRegisterCache
sourceSound — Property, class away3d.audio.drivers.AbstractSound3DDriver
sourceSound — Property, interface away3d.audio.drivers.ISound3DDriver
 | The sound object (flash.media.Sound) to play at the point of the sound source.
specular — Property, class away3d.lights.LightBase
 | The specular emission strength of the light.
specular — Property, class away3d.materials.MultiPassMaterialBase
 | The overall strength of the specular reflection.
specular — Property, class away3d.materials.SinglePassMaterialBase
 | The overall strength of the specular reflection.
specular — Property, class away3d.materials.methods.BasicSpecularMethod
 | The overall strength of the specular highlights.
specular — Property, class away3d.materials.methods.CompositeSpecularMethod
 | The overall strength of the specular highlights.
_specularB — Property, class away3d.lights.LightBase
SpecularBitmapTexture — class, package away3d.textures
 | A convenience texture that encodes a specular map in the red channel, and the gloss map in the green channel, as expected by BasicSpecularMapMethod
SpecularBitmapTexture(specularMap:flash.display:BitmapData, glossMap:flash.display:BitmapData) — Constructor, class away3d.textures.SpecularBitmapTexture
specularColor — Property, class away3d.materials.MultiPassMaterialBase
 | The colour of the specular reflection.
specularColor — Property, class away3d.materials.SinglePassMaterialBase
 | The colour of the specular reflection.
specularColor — Property, class away3d.materials.methods.BasicSpecularMethod
 | The colour of the specular reflection of the surface.
specularCutOff — Property, class away3d.materials.methods.CelSpecularMethod
 | The threshold at which the specular highlight should be shown.
_specularDataRegister — Property, class away3d.materials.methods.BasicSpecularMethod
_specularG — Property, class away3d.lights.LightBase
specularLightSources — Property, class away3d.materials.MultiPassMaterialBase
specularLightSources — Property, class away3d.materials.SinglePassMaterialBase
_specularLightSources — Property, class away3d.materials.compilation.ShaderCompiler
specularLightSources — Property, class away3d.materials.compilation.ShaderCompiler
_specularLightSources — Property, class away3d.materials.passes.CompiledPass
specularLightSources — Property, class away3d.materials.passes.CompiledPass
specularMap — Property, class away3d.lights.LightProbe
specularMap — Property, class away3d.materials.MultiPassMaterialBase
 | A specular map that defines the strength of specular reflections for each texel in the red channel, and the gloss factor in the green channel.
specularMap — Property, class away3d.materials.SinglePassMaterialBase
 | A specular map that defines the strength of specular reflections for each texel in the red channel, and the gloss factor in the green channel.
specularMap — Property, class away3d.textures.SpecularBitmapTexture
specularMethod — Property, class away3d.materials.MultiPassMaterialBase
 | The method to perform specular shading.
specularMethod — Property, class away3d.materials.SinglePassMaterialBase
 | The method to perform specular shading.
_specularMethod — Property, class away3d.materials.methods.ShaderMethodSetup
specularMethod — Property, class away3d.materials.methods.ShaderMethodSetup
 | The method to perform specular shading.
specularMethod — Property, class away3d.materials.passes.CompiledPass
_specularMethodVO — Property, class away3d.materials.methods.ShaderMethodSetup
_specularR — Property, class away3d.lights.LightBase
_specularR — Property, class away3d.materials.methods.BasicSpecularMethod
SpecularShadingModel — class, package away3d.materials.methods
_specularTexData — Property, class away3d.materials.methods.BasicSpecularMethod
_specularTextureRegister — Property, class away3d.materials.methods.BasicSpecularMethod
SphereGeometry — class, package away3d.primitives
 | A UV Sphere primitive mesh.
SphereGeometry(radius:Number, segmentsW:uint, segmentsH:uint, yUp:Boolean) — Constructor, class away3d.primitives.SphereGeometry
 | Creates a new Sphere object.
SPHERICAL — Constant Static Property, class away3d.tools.utils.Projector
SplatBlendBitmapTexture — class, package away3d.textures
SplatBlendBitmapTexture(blendingData:Array, normalize:Boolean) — Constructor, class away3d.textures.SplatBlendBitmapTexture
splitFace(mesh:away3d.entities:Mesh, indice:uint, subGeomIndice:uint, side:uint) — Static Method , class away3d.tools.helpers.FaceHelper
 | Divides a face into 2 faces.
splitFaces(mesh:away3d.entities:Mesh) — Static Method , class away3d.tools.helpers.FaceHelper
 | Divides all the faces of a mesh in 2 faces.
splitMesh(mesh:away3d.entities:Mesh, disposeSource:Boolean) — Static Method , class away3d.tools.helpers.MeshHelper
 | Splits the subgeometries of a given mesh in a series of new meshes
SpringController — class, package away3d.controllers
 | Uses spring physics to animate the target object towards a position that is defined as the lookAtTarget object's position plus the vector defined by the positionOffset property.
SpringController(targetObject:away3d.entities:Entity, lookAtObject:away3d.containers:ObjectContainer3D, stiffness:Number, mass:Number, damping:Number) — Constructor, class away3d.controllers.SpringController
Sprite3D — class, package away3d.entities
 | Sprite3D is a 3D billboard, a renderable rectangular area that is always aligned with the projection plane.
Sprite3D(material:away3d.materials:MaterialBase, width:Number, height:Number) — Constructor, class away3d.entities.Sprite3D
_src — Property, class away3d.audio.drivers.AbstractSound3DDriver
_stackLen — Property, class away3d.entities.Entity
stage3D — Property, class away3d.core.managers.Stage3DProxy
 | The base Stage3D object associated with this proxy.
Stage3DEvent — class, package away3d.events
Stage3DEvent(type:String, bubbles:Boolean, cancelable:Boolean) — Constructor, class away3d.events.Stage3DEvent
_stage3DIndex — Property, class away3d.core.managers.Stage3DProxy
stage3DIndex — Property, class away3d.core.managers.Stage3DProxy
 | The index of the Stage3D which is managed by this instance of Stage3DProxy.
Stage3DManager — class, package away3d.core.managers
 | The Stage3DManager class provides a multiton object that handles management for Stage3D objects.
_stage3DProxy — Property, class away3d.containers.View3D
stage3DProxy — Property, class away3d.containers.View3D
stage3DProxy — Property, class away3d.core.render.BackgroundImageRenderer
stage3DProxy — Property, class away3d.core.render.DefaultRenderer
_stage3DProxy — Property, class away3d.core.render.RendererBase
stage3DProxy — Property, class away3d.core.render.RendererBase
Stage3DProxy — class, package away3d.core.managers
 | Stage3DProxy provides a proxy class to manage a single Stage3D instance as well as handling the creation and attachment of the Context3D (and in turn the back buffer) is uses.
Stage3DProxy(stage3DIndex:int, stage3D:flash.display:Stage3D, stage3DManager:away3d.core.managers:Stage3DManager, forceSoftware:Boolean) — Constructor, class away3d.core.managers.Stage3DProxy
 | Creates a Stage3DProxy object.
start — Event, class away3d.animators.AnimatorBase
 | Dispatched when playback of an animation inside the animator object starts.
start() — method, class away3d.animators.AnimatorBase
 | Resumes the automatic playback clock controling the active state of the animator.
start() — method, class away3d.animators.ParticleAnimator
 | Resumes the automatic playback clock controling the active state of the animator.
start — Property, class away3d.paths.CubicPathSegment
 | The first anchor point.
start — Property, class away3d.paths.QuadraticPathSegment
 | Defines the first vector of the PathSegment
_start — Property, class away3d.primitives.data.Segment
start — Property, class away3d.primitives.data.Segment
 | Defines the starting vertex.
start() — method, class away3d.textures.WebcamTexture
 | Start subscribing to camera stream.
START — Constant Static Property, class away3d.events.AnimatorEvent
 | Defines the value of the type property of a start event object.
_startB — Property, class away3d.primitives.data.Segment
startBlend — Property, class away3d.animators.transitions.CrossfadeTransitionNode
startColor — Property, class away3d.animators.states.ParticleColorState
 | Defines the start color transform of the state, when in global mode.
startColor — Property, class away3d.primitives.data.Segment
 | Defines the startColor
_startG — Property, class away3d.primitives.data.Segment
startProfile — Property, class away3d.extrusions.PathExtrude
 | returns a vector of vector3d's representing the transformed profile coordinates at the start of the extrude shape null if "keepExtremes" is false or if the extrusion has not been builded yet.
_startR — Property, class away3d.primitives.data.Segment
startRotationOffset — Property, class away3d.extrusions.LatheExtrude
startTime — Property, class away3d.animators.data.ParticleAnimationData
startTime — Property, class away3d.animators.data.ParticleProperties
 | The start time of the particle.
_startTime — Property, class away3d.animators.states.AnimationStateBase
startVertexIndex — Property, class away3d.animators.data.ParticleAnimationData
startVertexIndex — Property, class away3d.core.base.data.ParticleData
_stateClass — Property, class away3d.animators.nodes.AnimationNodeBase
stateClass — Property, class away3d.animators.nodes.AnimationNodeBase
STATE_TRANSITION — Constant Static Property, class away3d.library.assets.AssetType
stateTransitionComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when an animation state transition has been constructed from a group of animation node resources.
stateTransitionComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when an animation state transition has been constructed from a group of animation node resources.
stateTransitionComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when an animation state transition has been constructed from a group of animation node resources.
stateTransitionComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when an animation state transition has been constructed from a group of animation node resources.
stateTransitionComplete — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when an animation state transition has been constructed from a group of animation node resources.
stateTransitionComplete — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when an animation state transition has been constructed from a group of animation node resources.
STATE_TRANSITION_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
StaticLightPicker — class, package away3d.materials.lightpickers
StaticLightPicker(lights:Array) — Constructor, class away3d.materials.lightpickers.StaticLightPicker
_staticNode — Property, class away3d.entities.Entity
staticNode — Property, class away3d.entities.Entity
 | Defines whether or not the object will be moved or animated at runtime.
steps — Property, class away3d.controllers.FirstPersonController
 | Fractional step taken each time the hover() method is called.
steps — Property, class away3d.controllers.HoverController
 | Fractional step taken each time the hover() method is called.
stepSize — Property, class away3d.filters.BlurFilter3D
 | The distance between two blur samples.
stepSize — Property, class away3d.filters.DepthOfFieldFilter3D
 | The amount of pixels between each sample.
stepSize — Property, class away3d.filters.HBlurFilter3D
 | The distance between two blur samples.
stepSize — Property, class away3d.filters.VBlurFilter3D
 | The distance between two blur samples.
stepSize — Property, class away3d.filters.tasks.Filter3DHBlurTask
stepSize — Property, class away3d.filters.tasks.Filter3DHDepthOfFFieldTask
stepSize — Property, class away3d.filters.tasks.Filter3DVBlurTask
stepSize — Property, class away3d.filters.tasks.Filter3DVDepthOfFFieldTask
StereoCamera3D — class, package away3d.stereo
StereoCamera3D(lens:away3d.cameras.lenses:LensBase) — Constructor, class away3d.stereo.StereoCamera3D
stereoEnabled — Property, class away3d.stereo.StereoView3D
stereoFocus — Property, class away3d.stereo.StereoCamera3D
stereoOffset — Property, class away3d.stereo.StereoCamera3D
StereoRenderer — class, package away3d.stereo
StereoRenderer(renderMethod:away3d.stereo.methods:StereoRenderMethodBase) — Constructor, class away3d.stereo.StereoRenderer
stereoRenderMethod — Property, class away3d.stereo.StereoView3D
StereoRenderMethodBase — class, package away3d.stereo.methods
StereoRenderMethodBase() — Constructor, class away3d.stereo.methods.StereoRenderMethodBase
StereoView3D — class, package away3d.stereo
StereoView3D(scene:away3d.containers:Scene3D, camera:away3d.cameras:Camera3D, renderer:away3d.core.render:RendererBase, stereoRenderMethod:away3d.stereo.methods:StereoRenderMethodBase) — Constructor, class away3d.stereo.StereoView3D
stiffness — Property, class away3d.controllers.SpringController
 | Stiffness of the spring, how hard is it to extend.
_stitchDirty — Property, class away3d.animators.nodes.AnimationClipNodeBase
_stitchFinalFrame — Property, class away3d.animators.nodes.AnimationClipNodeBase
stitchFinalFrame — Property, class away3d.animators.nodes.AnimationClipNodeBase
 | Defines if looping content blends the final frame of animation data with the first (true) or works on the assumption that both first and last frames are identical (false).
stitchSegment(start:away3d.paths:IPathSegment, middle:away3d.paths:IPathSegment, end:away3d.paths:IPathSegment) — method, class away3d.paths.CubicPath
stitchSegment(start:away3d.paths:IPathSegment, middle:away3d.paths:IPathSegment, end:away3d.paths:IPathSegment) — method, class away3d.paths.QuadraticPath
stitchSegment(start:away3d.paths:IPathSegment, middle:away3d.paths:IPathSegment, end:away3d.paths:IPathSegment) — method, class away3d.paths.SegmentedPathBase
 | Stitches two segments together based on a segment between them.
stop — Event, class away3d.animators.AnimatorBase
 | Dispatched when playback of an animation inside the animator object stops.
stop() — method, class away3d.animators.AnimatorBase
 | Pauses the automatic playback clock of the animator, in case manual updates are required via the time property or update() method.
stop() — method, class away3d.audio.Sound3D
 | Stop and rewind sound file.
stop() — method, interface away3d.audio.drivers.ISound3DDriver
 | Stop playback and reset playhead.
stop() — method, class away3d.audio.drivers.SimplePanVolumeDriver
stop() — method, interface away3d.materials.utils.IVideoPlayer
 | Stop playback and reset playhead.
stop() — method, class away3d.materials.utils.SimpleVideoPlayer
stop() — method, class away3d.textures.WebcamTexture
 | Detaches from the camera stream.
STOP — Constant Static Property, class away3d.events.AnimatorEvent
 | Defines the value of the type property of a stop event object.
stopImmediatePropagation() — method, class away3d.events.MouseEvent3D
stopPropagation() — method, class away3d.events.MouseEvent3D
strength — Property, class away3d.filters.MotionBlurFilter3D
strength — Property, class away3d.materials.methods.RimLightMethod
string(data:any) — Static Method , class away3d.utils.Cast
stripBuffer(offset:int, numEntries:int) — method, class away3d.core.base.CompactSubGeometry
subdivide(startVal:flash.geom:Vector3D, endVal:flash.geom:Vector3D, numSegments:int) — Static Method , class away3d.core.math.Vector3DUtils
subdivision — Property, class away3d.extrusions.LatheExtrude
 | Defines the subdivisions created in the mesh for the total number of revolutions.
subdivision — Property, class away3d.extrusions.LinearExtrude
 | Defines the subdivisions created in the mesh for the total number of revolutions.
subdivision — Property, class away3d.extrusions.PathExtrude
 | Defines the subdivisions created in the mesh for each PathSegment.
subdivision — Property, class away3d.extrusions.SkinExtrude
subdivisions — Property, class away3d.primitives.RegularPolygonGeometry
 | The number of subdivisions from the edge to the center of the regular polygon.
subGeometries — Property, class away3d.core.base.Geometry
 | A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc.
subGeometries — Property, class away3d.primitives.PrimitiveBase
 | A collection of SubGeometry objects, each of which contain geometrical data such as vertices, normals, etc.
subGeometry — Property, class away3d.core.base.SubMesh
 | The SubGeometry object which provides the geometry data for this SubMesh.
subGeometry — Property, class away3d.core.base.data.ParticleData
subGeometry — Property, class away3d.events.GeometryEvent
 | The SubGeometry object that is the subject of this event, if appropriate.
SubGeometry — class, package away3d.core.base
 | The SubGeometry class is a collections of geometric data that describes a triangle mesh.
SubGeometry() — Constructor, class away3d.core.base.SubGeometry
 | Creates a new SubGeometry object.
SUB_GEOMETRY_ADDED — Constant Static Property, class away3d.events.GeometryEvent
 | Dispatched when a SubGeometry was added from the dispatching Geometry.
SubGeometryBase — class, package away3d.core.base
SubGeometryBase() — Constructor, class away3d.core.base.SubGeometryBase
SUB_GEOMETRY_REMOVED — Constant Static Property, class away3d.events.GeometryEvent
 | Dispatched when a SubGeometry was removed from the dispatching Geometry.
SubMesh — class, package away3d.core.base
 | SubMesh wraps a SubGeometry as a scene graph instantiation.
SubMesh(subGeometry:away3d.core.base:ISubGeometry, parentMesh:away3d.entities:Mesh, material:away3d.materials:MaterialBase) — Constructor, class away3d.core.base.SubMesh
 | Creates a new SubMesh object
subMeshes — Property, class away3d.entities.Mesh
 | The SubMeshes out of which the Mesh consists.
subMeshes — Property, class away3d.extrusions.DelaunayMesh
 | The SubMeshes out of which the Mesh consists.
subMeshes — Property, class away3d.extrusions.LatheExtrude
 | The SubMeshes out of which the Mesh consists.
subMeshes — Property, class away3d.extrusions.LinearExtrude
 | The SubMeshes out of which the Mesh consists.
subMeshes — Property, class away3d.extrusions.PathExtrude
 | The SubMeshes out of which the Mesh consists.
subMeshes — Property, class away3d.extrusions.SkinExtrude
 | The SubMeshes out of which the Mesh consists.
SubsurfaceScatteringDiffuseMethod — class, package away3d.materials.methods
 | SubsurfaceScatteringDiffuseMethod provides a depth map-based diffuse shading method that mimics the scattering of light inside translucent surfaces.
SubsurfaceScatteringDiffuseMethod(depthMapSize:int, depthMapOffset:Number) — Constructor, class away3d.materials.methods.SubsurfaceScatteringDiffuseMethod
 | Creates a new SubsurfaceScatteringDiffuseMethod object.
success — Property, class away3d.loaders.misc.ResourceDependency
SuperShaderCompiler — class, package away3d.materials.compilation
SuperShaderCompiler() — Constructor, class away3d.materials.compilation.SuperShaderCompiler
SuperShaderPass — class, package away3d.materials.passes
 | DefaultScreenPass is a shader pass that uses shader methods to compile a complete program.
SuperShaderPass(material:away3d.materials:MaterialBase) — Constructor, class away3d.materials.passes.SuperShaderPass
 | Creates a new DefaultScreenPass objects.
supportsData(data:any) — Static Method , class away3d.loaders.parsers.AC3DParser
 | Tests whether a data block can be parsed by the parser.
supportsData(data:any) — Static Method , class away3d.loaders.parsers.AWD1Parser
 | Tests whether a data block can be parsed by the parser.
supportsData(data:any) — Static Method , class away3d.loaders.parsers.AWD2Parser
 | Tests whether a data block can be parsed by the parser.
supportsData(data:any) — Static Method , class away3d.loaders.parsers.AWDParser
supportsData(data:any) — Static Method , class away3d.loaders.parsers.DAEParser
 | Tests whether a data block can be parsed by the parser.
supportsData(data:any) — Static Method , class away3d.loaders.parsers.DXFParser
 | Tests whether a data block can be parsed by the parser.
supportsData(data:any) — Static Method , class away3d.loaders.parsers.ImageParser
 | Tests whether a data block can be parsed by the parser.
supportsData(data:any) — Static Method , class away3d.loaders.parsers.MD2Parser
 | Tests whether a data block can be parsed by the parser.
supportsData(data:any) — Static Method , class away3d.loaders.parsers.MD5AnimParser
 | Tests whether a data block can be parsed by the parser.
supportsData(data:any) — Static Method , class away3d.loaders.parsers.MD5MeshParser
 | Tests whether a data block can be parsed by the parser.
supportsData(data:any) — Static Method , class away3d.loaders.parsers.Max3DSParser
supportsData(data:any) — Static Method , class away3d.loaders.parsers.OBJParser
 | Tests whether a data block can be parsed by the parser.
supportsType(extension:String) — Static Method , class away3d.loaders.parsers.AC3DParser
 | Indicates whether or not a given file extension is supported by the parser.
supportsType(extension:String) — Static Method , class away3d.loaders.parsers.AWD1Parser
 | Indicates whether or not a given file extension is supported by the parser.
supportsType(extension:String) — Static Method , class away3d.loaders.parsers.AWD2Parser
 | Indicates whether or not a given file extension is supported by the parser.
supportsType(suffix:String) — Static Method , class away3d.loaders.parsers.AWDParser
supportsType(extension:String) — Static Method , class away3d.loaders.parsers.DAEParser
 | Indicates whether or not a given file extension is supported by the parser.
supportsType(extension:String) — Static Method , class away3d.loaders.parsers.DXFParser
 | Indicates whether or not a given file extension is supported by the parser.
supportsType(extension:String) — Static Method , class away3d.loaders.parsers.ImageParser
 | Indicates whether or not a given file extension is supported by the parser.
supportsType(extension:String) — Static Method , class away3d.loaders.parsers.MD2Parser
 | Indicates whether or not a given file extension is supported by the parser.
supportsType(extension:String) — Static Method , class away3d.loaders.parsers.MD5AnimParser
 | Indicates whether or not a given file extension is supported by the parser.
supportsType(extension:String) — Static Method , class away3d.loaders.parsers.MD5MeshParser
 | Indicates whether or not a given file extension is supported by the parser.
supportsType(extension:String) — Static Method , class away3d.loaders.parsers.Max3DSParser
supportsType(extension:String) — Static Method , class away3d.loaders.parsers.OBJParser
 | Indicates whether or not a given file extension is supported by the parser.
suppresAssetEvents — Property, class away3d.loaders.misc.ResourceDependency
_surfaceClosed — Property, class away3d.primitives.CylinderGeometry
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


T

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
T Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
tabSize — Static Property, class away3d.tools.serialize.Serialize
tabSize — Property, class away3d.tools.serialize.TraceSerializer
_tangentBufferIndex — Property, class away3d.materials.compilation.ShaderCompiler
tangentBufferIndex — Property, class away3d.materials.compilation.ShaderCompiler
_tangentBufferIndex — Property, class away3d.materials.passes.CompiledPass
tangentDependencies — Property, class away3d.materials.compilation.MethodDependencyCounter
tangentInput — Property, class away3d.materials.compilation.ShaderRegisterData
_tangentsInvalid — Property, class away3d.core.base.SubGeometry
tangentSpace — Property, class away3d.materials.compilation.LightingShaderCompiler
tangentSpace — Property, class away3d.materials.methods.BasicNormalMethod
tangentSpace — Property, class away3d.materials.methods.HeightMapNormalMethod
tangentVarying — Property, class away3d.materials.compilation.ShaderRegisterData
target — Property, class away3d.animators.PathAnimator
 | sets the object to be animated along the path.
target — Property, class away3d.events.Scene3DEvent
target — Property, class away3d.filters.tasks.Filter3DTaskBase
_targetObject — Property, class away3d.controllers.ControllerBase
targetObject — Property, class away3d.controllers.ControllerBase
 | Target object on which the controller acts.
targetRegisters — Property, class away3d.animators.data.AnimationRegisterCache
tasks — Property, class away3d.filters.Filter3DBase
TerrainDiffuseMethod — class, package away3d.materials.methods
TerrainDiffuseMethod(splatTextures:Array, blendingTexture:away3d.textures:Texture2DBase, tileData:Array) — Constructor, class away3d.materials.methods.TerrainDiffuseMethod
testGPUCompatibility(pass:away3d.materials.passes:MaterialPassBase) — method, interface away3d.animators.IAnimator
 | Verifies if the animation will be used on cpu.
testGPUCompatibility(pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.ParticleAnimator
 | Verifies if the animation will be used on cpu.
testGPUCompatibility(pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.SkeletonAnimator
 | Verifies if the animation will be used on cpu.
testGPUCompatibility(pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.UVAnimator
 | Verifies if the animation will be used on cpu.
testGPUCompatibility(pass:away3d.materials.passes:MaterialPassBase) — method, class away3d.animators.VertexAnimator
 | Verifies if the animation will be used on cpu.
testSubMeshCollision(subMesh:away3d.core.base:SubMesh, pickingCollisionVO:away3d.core.pick:PickingCollisionVO, shortestCollisionDistance:Number, ignoreFacesLookingAway:Boolean) — method, class away3d.core.pick.AS3PickingCollider
 | Tests a SubMesh object for a collision with the picking ray.
testSubMeshCollision(subMesh:away3d.core.base:SubMesh, pickingCollisionVO:away3d.core.pick:PickingCollisionVO, shortestCollisionDistance:Number, ignoreFacesLookingAway:Boolean) — method, class away3d.core.pick.AutoPickingCollider
 | Tests a SubMesh object for a collision with the picking ray.
testSubMeshCollision(subMesh:away3d.core.base:SubMesh, pickingCollisionVO:away3d.core.pick:PickingCollisionVO, shortestCollisionDistance:Number, ignoreFacesLookingAway:Boolean) — method, interface away3d.core.pick.IPickingCollider
 | Tests a SubMesh object for a collision with the picking ray.
testSubMeshCollision(subMesh:away3d.core.base:SubMesh, pickingCollisionVO:away3d.core.pick:PickingCollisionVO, shortestCollisionDistance:Number, ignoreFacesLookingAway:Boolean) — method, class away3d.core.pick.PBPickingCollider
 | Tests a SubMesh object for a collision with the picking ray.
texture — Property, class away3d.core.render.BackgroundImageRenderer
texture — Property, class away3d.entities.TextureProjector
 | The texture to be projected on the geometry.
texture — Property, class away3d.materials.TextureMaterial
 | The texture object to use for the albedo colour.
texture — Property, class away3d.materials.TextureMultiPassMaterial
 | The texture object to use for the albedo colour.
texture — Property, class away3d.materials.methods.AlphaMaskMethod
texture — Property, class away3d.materials.methods.BasicAmbientMethod
 | The bitmapData to use to define the diffuse reflection color per texel.
texture — Property, class away3d.materials.methods.BasicDiffuseMethod
 | The bitmapData to use to define the diffuse reflection color per texel.
texture — Property, class away3d.materials.methods.BasicSpecularMethod
 | The bitmapData that encodes the specular highlight strength per texel in the red channel, and the sharpness in the green channel.
texture — Property, class away3d.materials.methods.CompositeDiffuseMethod
 | The bitmapData to use to define the diffuse reflection color per texel.
texture — Property, class away3d.materials.methods.CompositeSpecularMethod
 | The bitmapData that encodes the specular highlight strength per texel in the red channel, and the sharpness in the green channel.
texture — Property, class away3d.materials.methods.FresnelPlanarReflectionMethod
texture — Property, class away3d.materials.methods.LightMapMethod
texture — Property, class away3d.materials.methods.PlanarReflectionMethod
 | The PlanarReflectionTexture used to render the reflected view.
TEXTURE — Constant Static Property, class away3d.library.assets.AssetType
Texture2DBase — class, package away3d.textures
Texture2DBase() — Constructor, class away3d.textures.Texture2DBase
textureComplete — Event, class away3d.library.AssetLibraryBundle
 | Dispatched when a texture asset has been constructed from a resource.
textureComplete — Event, class away3d.loaders.AssetLoader
 | Dispatched when a texture asset has been constructed from a resource.
textureComplete — Event, class away3d.loaders.Loader3D
 | Dispatched when a texture asset has been constructed from a resource.
textureComplete — Event, class away3d.loaders.misc.AssetLoaderToken
 | Dispatched when a texture asset has been constructed from a resource.
textureComplete — Event, class away3d.loaders.misc.SingleFileLoader
 | Dispatched when a texture asset has been constructed from a resource.
textureComplete — Event, class away3d.loaders.parsers.ParserBase
 | Dispatched when a texture asset has been constructed from a resource.
TEXTURE_COMPLETE — Constant Static Property, class away3d.events.AssetEvent
textureHeight — Property, class away3d.core.managers.RTTBufferManager
textureHeight — Property, class away3d.filters.Filter3DBase
_textureHeight — Property, class away3d.filters.tasks.Filter3DTaskBase
textureHeight — Property, class away3d.filters.tasks.Filter3DTaskBase
TextureMaterial — class, package away3d.materials
 | TextureMaterial is a material that uses a texture as the surface's diffuse colour.
TextureMaterial(texture:away3d.textures:Texture2DBase, smooth:Boolean, repeat:Boolean, mipmap:Boolean) — Constructor, class away3d.materials.TextureMaterial
 | Creates a new TextureMaterial.
TextureMultiPassMaterial — class, package away3d.materials
TextureMultiPassMaterial(texture:away3d.textures:Texture2DBase, smooth:Boolean, repeat:Boolean, mipmap:Boolean) — Constructor, class away3d.materials.TextureMultiPassMaterial
TextureProjector — class, package away3d.entities
 | TextureProjector is an object in the scene that can be used to project textures onto geometry.
TextureProjector(texture:away3d.textures:Texture2DBase) — Constructor, class away3d.entities.TextureProjector
 | Creates a new TextureProjector object.
TextureProxyBase — class, package away3d.textures
TextureProxyBase() — Constructor, class away3d.textures.TextureProxyBase
textureRatioX — Property, class away3d.core.managers.RTTBufferManager
_textureRatioX — Property, class away3d.core.render.RendererBase
textureRatioX — Property, class away3d.core.render.RendererBase
textureRatioX — Property, class away3d.textures.PlanarReflectionTexture
textureRatioY — Property, class away3d.core.managers.RTTBufferManager
_textureRatioY — Property, class away3d.core.render.RendererBase
textureRatioY — Property, class away3d.core.render.RendererBase
textureRatioY — Property, class away3d.textures.PlanarReflectionTexture
_textures — Property, class away3d.textures.TextureProxyBase
_textureScale — Property, class away3d.filters.tasks.Filter3DTaskBase
textureScale — Property, class away3d.filters.tasks.Filter3DTaskBase
 | The texture scale for the input of this texture.
texturesIndex — Property, class away3d.materials.methods.MethodVO
_textureSizeInvalid — Property, class away3d.stereo.methods.StereoRenderMethodBase
TextureUtils — class, package away3d.tools.utils
textureWidth — Property, class away3d.core.managers.RTTBufferManager
textureWidth — Property, class away3d.filters.Filter3DBase
_textureWidth — Property, class away3d.filters.tasks.Filter3DTaskBase
textureWidth — Property, class away3d.filters.tasks.Filter3DTaskBase
thickness — Property, class away3d.extrusions.LatheExtrude
 | Defines the thickness of the resulting lathed geometry.
thickness — Property, class away3d.extrusions.LinearExtrude
 | Defines the _thickness of the resulting lathed geometry.
thickness — Property, class away3d.primitives.WireframePrimitiveBase
_thickness — Property, class away3d.primitives.data.Segment
thickness — Property, class away3d.primitives.data.Segment
 | Defines the ending vertex.
thicknessSubdivision — Property, class away3d.extrusions.LinearExtrude
 | Defines the subdivision for the top, bottom, right and left if thickness is set higher to 0.
threshold — Property, class away3d.filters.BloomFilter3D
threshold — Property, class away3d.filters.tasks.Filter3DBrightPassTask
THROW_ERROR — Constant Static Property, class away3d.library.naming.ConflictStrategy
 | Specifies that an error should be thrown if a naming conflict is discovered.
tile6 — Property, class away3d.primitives.CubeGeometry
 | The type of uv mapping to use.
tiltAngle — Property, class away3d.controllers.FirstPersonController
 | Elevation angle of the camera in degrees.
tiltAngle — Property, class away3d.controllers.HoverController
 | Elevation angle of the camera in degrees.
time — Property, class away3d.animators.AnimatorBase
 | Gets and sets the internal time clock of the animator.
_time — Property, class away3d.animators.states.AnimationStateBase
time — Property, interface away3d.materials.utils.IVideoPlayer
 | Returns the actual time of the netStream
time — Property, class away3d.materials.utils.SimpleVideoPlayer
_timeDir — Property, class away3d.animators.states.AnimationClipState
toByteArray(data:any) — Static Method , class away3d.loaders.parsers.utils.ParserUtil
toEulerAngles(target:flash.geom:Vector3D) — method, class away3d.core.math.Quaternion
 | Fills a target Vector3D object with the Euler angles that form the rotation represented by this quaternion.
togglePlayPause() — method, class away3d.audio.Sound3D
 | Alternate between pausing and resuming playback of this sound.
toMatrix3D(target:flash.geom:Matrix3D) — method, class away3d.animators.data.JointPose
 | Converts the transformation to a Matrix3D representation.
toMatrix3D(target:flash.geom:Matrix3D) — method, class away3d.core.math.Quaternion
 | Converts the quaternion to a Matrix3D object representing an equivalent rotation.
top — Property, class away3d.materials.utils.MultipleMaterials
 | Defines the material applied to the top side of the cube.
TOP — Constant Static Property, class away3d.tools.utils.Projector
_topClosed — Property, class away3d.primitives.CylinderGeometry
topClosed — Property, class away3d.primitives.CylinderGeometry
 | Defines whether the top end of the cylinder is closed (true) or open.
_topRadius — Property, class away3d.primitives.CylinderGeometry
topRadius — Property, class away3d.primitives.CylinderGeometry
 | The radius of the top end of the cylinder.
topRadius — Property, class away3d.primitives.WireframeCylinder
 | Top radius of the cylinder
toRawData(target:Vector$Number, exclude4thRow:Boolean) — method, class away3d.core.math.Quaternion
 | Converts the quaternion to a Vector.<Number> matrix representation of a rotation equivalent to this quaternion.
TorusGeometry — class, package away3d.primitives
 | A UV Cylinder primitive mesh.
TorusGeometry(radius:Number, tubeRadius:Number, segmentsR:uint, segmentsT:uint, yUp:Boolean) — Constructor, class away3d.primitives.TorusGeometry
 | Creates a new Torus object.
toString() — method, class away3d.core.base.data.UV
 | returns the value object as a string for trace/debug purpose
toString() — method, class away3d.core.base.data.Vertex
 | returns the value object as a string for trace/debug purpose
toString() — method, class away3d.core.math.Plane3D
toString() — method, class away3d.core.math.Quaternion
 | Used to trace the values of a quaternion.
toString(data:any, length:uint) — Static Method , class away3d.loaders.parsers.utils.ParserUtil
toString() — method, class away3d.materials.compilation.ShaderRegisterElement
 | Converts the register or the components AGAL string representation.
toString() — method, class away3d.paths.CubicPathSegment
toString() — method, class away3d.paths.QuadraticPathSegment
total — Property, class away3d.animators.data.ParticleProperties
 | The total number of particles being processed by the particle animation set.
totalBytes — Property, class away3d.textures.ATFData
_totalDelta — Property, class away3d.animators.nodes.AnimationClipNodeBase
totalDelta — Property, class away3d.animators.nodes.AnimationClipNodeBase
_totalDuration — Property, class away3d.animators.nodes.AnimationClipNodeBase
totalDuration — Property, class away3d.animators.nodes.AnimationClipNodeBase
totalFrames — Property, class away3d.animators.nodes.ParticleSpriteSheetNode
 | Defines the total number of frames used by the spritesheet, when in global mode.
totalLenOfOneVertex — Property, class away3d.animators.data.AnimationSubGeometry
_totalLightColorReg — Property, class away3d.materials.methods.BasicDiffuseMethod
_totalLightColorReg — Property, class away3d.materials.methods.BasicSpecularMethod
totalTime — Property, class away3d.animators.data.ParticleAnimationData
trace(message:Object) — Static Method , class away3d.debug.Debug
TraceSerializer — class, package away3d.tools.serialize
 | TraceSerializer is a concrete Serializer that will output its results to trace().
TraceSerializer() — Constructor, class away3d.tools.serialize.TraceSerializer
 | Creates a new TraceSerializer object.
transform — Property, class away3d.containers.View3D
_transform — Property, class away3d.core.base.Object3D
transform — Property, class away3d.core.base.Object3D
 | The transformation of the 3d object, relative to the local coordinates of the parent ObjectContainer3D.
_transformComponents — Property, class away3d.core.base.Object3D
TRANSITION_COMPLETE — Constant Static Property, class away3d.events.AnimationStateEvent
translate(axis:flash.geom:Vector3D, distance:Number) — method, class away3d.core.base.Object3D
 | Moves the 3d object along a vector by a defined length
translateLocal(axis:flash.geom:Vector3D, distance:Number) — method, class away3d.containers.ObjectContainer3D
translateLocal(axis:flash.geom:Vector3D, distance:Number) — method, class away3d.core.base.Object3D
 | Moves the 3d object along a vector by a defined length
translation — Property, class away3d.animators.data.JointPose
 | The translation of the pose
translucency — Property, class away3d.materials.methods.SubsurfaceScatteringDiffuseMethod
 | The translucency of the object.
traverse(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.core.partition.Partition3D
 | Sends a traverser through the partition tree.
traversePartitions(traverser:away3d.core.traverse:PartitionTraverser) — method, class away3d.containers.Scene3D
 | Sends a PartitionTraverser object down the scene partitions
triangleThreshold — Property, class away3d.core.pick.AutoPickingCollider
 | Represents the number of triangles encountered in a SubMesh object over which PixelBender is used.
Trident — class, package away3d.debug
 | Creates a new Trident object.
Trident(length:Number, showLetters:Boolean) — Constructor, class away3d.debug.Trident
TridentLines — class, package away3d.debug.data
TridentLines(vectors:Vector$Vector$flash.geom:Vector3D, colors:Vector$uint) — Constructor, class away3d.debug.data.TridentLines
triFace(mesh:away3d.entities:Mesh, indice:uint, subGeomIndice:uint) — Static Method , class away3d.tools.helpers.FaceHelper
 | Divides a face into 3 faces.
triFaces(mesh:away3d.entities:Mesh) — Static Method , class away3d.tools.helpers.FaceHelper
 | Divides all the faces of a mesh in 3 faces.
TripleFilteredShadowMapMethod — class, package away3d.materials.methods
TripleFilteredShadowMapMethod(castingLight:away3d.lights:DirectionalLight) — Constructor, class away3d.materials.methods.TripleFilteredShadowMapMethod
 | Creates a new BasicDiffuseMethod object.
tryClass(name:String) — Static Method , class away3d.utils.Cast
tryColor(data:any) — Static Method , class away3d.utils.Cast
_tubeRadius — Property, class away3d.primitives.TorusGeometry
tubeRadius — Property, class away3d.primitives.TorusGeometry
 | The radius of the inner tube of the torus.
tweek — Property, class away3d.extrusions.LatheExtrude
 | Allows the building of shapes such as springs.
type — Property, class away3d.textures.ATFData
TYPE — Constant Property, class away3d.primitives.LineSegment
TYPE_CUBE — Constant Static Property, class away3d.textures.ATFData
TYPE_NORMAL — Constant Static Property, class away3d.textures.ATFData
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


U

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
U Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
u — Property, class away3d.core.base.data.UV
 | Defines the horizontal coordinate of the texture value.
U_AXIS — Constant Static Property, class away3d.animators.nodes.ParticleUVNode
uControlPoints — Property, class away3d.primitives.NURBSGeometry
 | Defines the number of control points along the U splines
uKnot — Property, class away3d.primitives.NURBSGeometry
 | Defines the knot sequence in the U direction that determines where and how the control points affect the NURBS curve.
UNCOMPRESSED — Constant Static Property, class away3d.loaders.parsers.AWD2Parser
_uniqueId — Property, class away3d.materials.MaterialBase
uniqueId — Property, class away3d.materials.MaterialBase
 | The unique id assigned to the material by the MaterialLibrary.
unit — Property, class away3d.tools.utils.Grid
 | Defines if the grid unit.
unproject(mX:Number, mY:Number, mZ:Number) — method, class away3d.cameras.Camera3D
 | Calculates the scene position of the given normalized coordinates.
unproject(mX:Number, mY:Number, mZ:Number) — method, class away3d.cameras.lenses.LensBase
 | Calculates the position of the given normalized coordinates relative to the camera.
unproject(mX:Number, mY:Number, mZ:Number) — method, class away3d.containers.View3D
 | Calculates the scene position of the given screen coordinates.
unprojectionMatrix — Property, class away3d.cameras.lenses.LensBase
unregisterPartition(entity:away3d.entities:Entity) — method, class away3d.containers.Scene3D
 | When a partition is removed from an object somewhere in the scene graph, remove the partition from the list
unregisterView(view3d:away3d.containers:View3D) — method, class away3d.debug.AwayStats
 | Remove a view from the list of those that are taken into account when calculating on-screen and total poly counts.
uOrder — Property, class away3d.primitives.NURBSGeometry
 | Defines the number of control points along the U splines that influence any given point on the curve
upAxis — Property, class away3d.animators.PathAnimator
upAxis — Property, class away3d.extrusions.PathDuplicator
 | The up axis to which duplicated objects' Y axis will be oriented.
upAxis — Property, class away3d.extrusions.PathExtrude
update(time:int) — method, class away3d.animators.AnimatorBase
 | Provides a way to manually update the active state of the animator when automatic updates are disabled.
update(time:int) — method, class away3d.animators.states.AnimationClipState
 | Updates the configuration of the node to its current state.
update(time:int) — method, class away3d.animators.states.AnimationStateBase
 | Updates the configuration of the node to its current state.
update(time:int) — method, interface away3d.animators.states.IAnimationState
update() — method, class away3d.audio.SoundTransform3D
 | updates the SoundTransform based on the emitter and listener.
update() — method, class away3d.controllers.ControllerBase
 | Manually applies updates to the target 3D object.
update() — method, class away3d.controllers.FirstPersonController
 | Updates the current tilt angle and pan angle values.
update() — method, class away3d.controllers.FollowController
update() — method, class away3d.controllers.HoverController
 | Updates the current tilt angle and pan angle values.
update() — method, class away3d.controllers.LookAtController
 | Manually applies updates to the target 3D object.
update() — method, class away3d.controllers.SpringController
update(stage:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.filters.DepthOfFieldFilter3D
update(stage:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.filters.Filter3DBase
update(stage:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.filters.HDepthOfFieldFilter3D
update(stage:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.filters.MotionBlurFilter3D
update(stage:away3d.core.managers:Stage3DProxy, camera:away3d.cameras:Camera3D) — method, class away3d.filters.VDepthOfFieldFilter3D
update() — method, class away3d.textures.VideoTexture
 | Draws the video and updates the bitmap texture If autoUpdate is false and this function is not called the bitmap texture will not update!
update() — method, class away3d.textures.WebcamTexture
 | Draws the video and updates the bitmap texture If autoUpdate is false and this function is not called the bitmap texture will not update!
update() — method, class away3d.tools.helpers.MeshDebugger
updateAABBPoints() — method, class away3d.bounds.BoundingVolumeBase
updateActiveBuffer(contextIndex:int) — method, class away3d.core.base.CompactSubGeometry
updateAnimatedData(value:Vector$Number) — method, class away3d.core.base.SkinnedSubGeometry
updateBackBuffer() — method, class away3d.containers.View3D
 | Updates the backbuffer dimensions.
updateBoundingRenderable() — method, class away3d.bounds.AxisAlignedBoundingBox
updateBoundingRenderable() — method, class away3d.bounds.BoundingSphere
updateBoundingRenderable() — method, class away3d.bounds.BoundingVolumeBase
updateBounds() — method, class away3d.cameras.Camera3D
 | Updates the bounding volume for the object.
updateBounds() — method, class away3d.entities.Entity
 | Updates the bounding volume for the object.
updateBounds() — method, class away3d.entities.Mesh
 | Updates the bounding volume for the object.
updateBounds() — method, class away3d.entities.SegmentSet
updateBounds() — method, class away3d.entities.Sprite3D
updateBounds() — method, class away3d.lights.DirectionalLight
 | Updates the bounding volume for the object.
updateBounds() — method, class away3d.lights.LightProbe
 | Updates the bounding volume for the object.
updateBounds() — method, class away3d.lights.PointLight
 | Updates the bounding volume for the object.
updateBounds() — method, class away3d.primitives.SkyBox
 | Updates the bounding volume for the object.
updateCollider(view:away3d.containers:View3D) — method, class away3d.core.managers.Mouse3DManager
updateConstants() — method, class away3d.filters.tasks.Filter3DHueSaturationTask
updateData(data:Vector$Number) — method, class away3d.core.base.CompactSubGeometry
 | Updates the vertex data.
updateDeltaTime(dt:Number) — method, class away3d.animators.ParticleAnimator
updateDeltaTime(dt:Number) — method, class away3d.animators.SkeletonAnimator
 | Applies the calculated time delta to the active animation state node or state transition object.
updateDeltaTime(dt:Number) — method, class away3d.animators.UVAnimator
 | Applies the calculated time delta to the active animation state node.
updateDeltaTime(dt:Number) — method, class away3d.animators.VertexAnimator
updateDepthProjection(viewCamera:away3d.cameras:Camera3D) — method, class away3d.lights.shadowmaps.CascadeShadowMapper
updateDepthProjection(viewCamera:away3d.cameras:Camera3D) — method, class away3d.lights.shadowmaps.CubeMapShadowMapper
updateDepthProjection(viewCamera:away3d.cameras:Camera3D) — method, class away3d.lights.shadowmaps.DirectionalShadowMapper
updateDepthProjection(viewCamera:away3d.cameras:Camera3D) — method, class away3d.lights.shadowmaps.NearDirectionalShadowMapper
updateDepthProjection(viewCamera:away3d.cameras:Camera3D) — method, class away3d.lights.shadowmaps.ShadowMapperBase
updateDrag() — method, class away3d.tools.utils.Drag3D
 | if an ObjectContainer3D is set this handler will calculate the mouse intersection on given plane and will update position and rotations of the ObjectContainer3D set accordingly
updateDummyUVs(target:Vector$Number) — method, class away3d.core.base.SubGeometry
updateDummyUVs(target:Vector$Number) — method, class away3d.core.base.SubGeometryBase
updateDynamicProperties(animationSubGeometry:away3d.animators.data:AnimationSubGeometry) — method, class away3d.animators.states.ParticleStateBase
updateFaceTangents() — method, class away3d.core.base.SubGeometryBase
 | Updates the tangents for each face.
updateFocusPoint() — method, class away3d.stereo.StereoCamera3D
updateFrames() — method, class away3d.animators.states.AnimationClipState
 | Updates the nodes internal playhead to determine the current and next animation frame, and the blendWeight between the two.
updateFrames() — method, class away3d.animators.states.SkeletonClipState
 | Updates the nodes internal playhead to determine the current and next animation frame, and the blendWeight between the two.
updateFrames() — method, class away3d.animators.states.UVClipState
 | Updates the nodes internal playhead to determine the current and next animation frame, and the blendWeight between the two.
updateFrames() — method, class away3d.animators.states.VertexClipState
 | Updates the nodes internal playhead to determine the current and next animation frame, and the blendWeight between the two.
updateFromVector3D(v:flash.geom:Vector3D) — method, class away3d.audio.SoundTransform3D
 | udpates the SoundTransform based on the vector representing the distance and angle between the emitter and listener.
updateGlobalPos() — method, class away3d.containers.View3D
updateImplicitVisibility() — method, class away3d.containers.ObjectContainer3D
updateIndexData(indices:Vector$uint) — method, class away3d.core.base.SubGeometryBase
 | Updates the face indices of the SubGeometry.
updateJointIndexData(value:Vector$Number) — method, class away3d.core.base.SkinnedSubGeometry
updateJointWeightsData(value:Vector$Number) — method, class away3d.core.base.SkinnedSubGeometry
updateLightConstants() — method, class away3d.materials.passes.CompiledPass
updateLightConstants() — method, class away3d.materials.passes.LightingPass
updateLightConstants() — method, class away3d.materials.passes.ShadowCasterPass
 | Updates the lights data for the render state.
updateLightConstants() — method, class away3d.materials.passes.SuperShaderPass
 | Updates the lights data for the render state.
updateLights() — method, class away3d.materials.passes.CompiledPass
updateLights() — method, class away3d.materials.passes.LightingPass
updateLights() — method, class away3d.materials.passes.MaterialPassBase
updateLights() — method, class away3d.materials.passes.ShadowCasterPass
updateLights() — method, class away3d.materials.passes.SuperShaderPass
updateMaterial(context:flash.display3D:Context3D) — method, class away3d.materials.MultiPassMaterialBase
updateMaterial(context:flash.display3D:Context3D) — method, class away3d.materials.SinglePassMaterialBase
updateMatrix() — method, class away3d.cameras.lenses.FreeMatrixLens
updateMatrix() — method, class away3d.cameras.lenses.LensBase
 | Updates the matrix
updateMatrix() — method, class away3d.cameras.lenses.ObliqueNearPlaneLens
updateMatrix() — method, class away3d.cameras.lenses.OrthographicLens
 | Updates the matrix
updateMatrix() — method, class away3d.cameras.lenses.OrthographicOffCenterLens
 | Updates the matrix
updateMatrix() — method, class away3d.cameras.lenses.PerspectiveLens
 | Updates the matrix
updateMethodConstants() — method, class away3d.materials.passes.CompiledPass
updateMethodConstants() — method, class away3d.materials.passes.SuperShaderPass
updateMouseChildren() — method, class away3d.containers.ObjectContainer3D
updateMouseChildren() — method, class away3d.entities.Entity
updateMouseChildren() — method, class away3d.primitives.WireframePrimitiveBase
updateNames(ns:String, nonConflictingName:String, oldAsset:away3d.library.assets:IAsset, newAsset:away3d.library.assets:IAsset, assetsDictionary:Object, precedence:String) — method, class away3d.library.naming.ConflictStrategyBase
 | Provided as a convenience method for all conflict strategy classes, as a way to finalize the conflict resolution by applying the new names and dispatching the correct events.
updateNumEntities(value:int) — method, class away3d.core.partition.NodeBase
updateOrAddSegment(index:uint, v0:flash.geom:Vector3D, v1:flash.geom:Vector3D) — method, class away3d.primitives.WireframePrimitiveBase
updatePosition — Property, class away3d.animators.AnimatorBase
 | Enables translation of the animated mesh from data returned per frame via the positionDelta property of the active animation node.
updatePositionDelta() — method, class away3d.animators.states.AnimationStateBase
 | Updates the node's root delta position
updatePositionDelta() — method, class away3d.animators.states.SkeletonBinaryLERPState
 | Updates the node's root delta position
updatePositionDelta() — method, class away3d.animators.states.SkeletonClipState
 | Updates the node's root delta position
updatePositionDelta() — method, class away3d.animators.states.SkeletonDifferenceState
 | Updates the node's root delta position
updatePositionDelta() — method, class away3d.animators.states.SkeletonDirectionalState
 | Updates the node's root delta position
updatePositionDelta() — method, class away3d.animators.states.SkeletonNaryLERPState
 | Updates the node's root delta position
updatePositionDelta() — method, class away3d.animators.states.VertexClipState
 | Updates the node's root delta position
updateProbes(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.passes.CompiledPass
updateProbes(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.passes.LightingPass
updateProbes(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.passes.ShadowCasterPass
updateProbes(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.passes.SuperShaderPass
updateProgram(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.passes.CompiledPass
 | Compiles the shader program.
updateProgram(stage3DProxy:away3d.core.managers:Stage3DProxy) — method, class away3d.materials.passes.MaterialPassBase
 | Compiles the shader program.
updateProgram3D(stage:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DTaskBase
updateProgress(t:Number) — method, class away3d.animators.PathAnimator
 | Calculates the new position and set the object on the path accordingly
updateProjectionFromFrustumCorners(viewCamera:away3d.cameras:Camera3D, corners:Vector$Number, matrix:flash.geom:Matrix3D) — method, class away3d.lights.shadowmaps.DirectionalShadowMapper
updateReferenceVector(v:flash.geom:Vector3D) — method, class away3d.audio.drivers.AbstractSound3DDriver
updateReferenceVector(v:flash.geom:Vector3D) — method, interface away3d.audio.drivers.ISound3DDriver
 | Change the position of the sound source relative to the listener, known as the reference vector.
updateReferenceVector(v:flash.geom:Vector3D) — method, class away3d.audio.drivers.SimplePanVolumeDriver
updateRegisterIndices() — method, class away3d.materials.passes.CompiledPass
updateRegisterIndices() — method, class away3d.materials.passes.LightingPass
updateRegisterIndices() — method, class away3d.materials.passes.ShadowCasterPass
updateSceneTransform() — method, class away3d.containers.ObjectContainer3D
 | Updates the scene transformation matrix.
updateSceneTransform() — method, class away3d.lights.DirectionalLight
 | Updates the scene transformation matrix.
updateScreenPasses() — method, class away3d.materials.MultiPassMaterialBase
updateScreenPasses() — method, class away3d.materials.TextureMultiPassMaterial
updateSecondaryUVData(uvs:Vector$Number) — method, class away3d.core.base.SubGeometry
updateSegment(segment:away3d.primitives.data:Segment) — method, class away3d.entities.SegmentSet
updateSegment(start:flash.geom:Vector3D, end:flash.geom:Vector3D, anchor:flash.geom:Vector3D, colorStart:uint, colorEnd:uint, thickness:Number) — method, class away3d.primitives.data.Segment
updateShaderProperties() — method, class away3d.materials.passes.CompiledPass
updateShaderProperties() — method, class away3d.materials.passes.LightingPass
updateShaderProperties() — method, class away3d.materials.passes.ShadowCasterPass
updateShadows() — method, class away3d.lights.shadowmaps.ShadowMapperBase
updateStitch() — method, class away3d.animators.nodes.AnimationClipNodeBase
 | Updates the node's final frame stitch state.
updateStitch() — method, class away3d.animators.nodes.SkeletonClipNode
 | Updates the node's final frame stitch state.
updateStitch() — method, class away3d.animators.nodes.UVClipNode
 | Updates the node's final frame stitch state.
updateStitch() — method, class away3d.animators.nodes.VertexClipNode
 | Updates the node's final frame stitch state.
updateTextures(stage:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DDoubleBufferCopyTask
updateTextures(stage:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DHBlurTask
updateTextures(stage:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DHDepthOfFFieldTask
updateTextures(stage:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DTaskBase
updateTextures(stage:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DVBlurTask
updateTextures(stage:away3d.core.managers:Stage3DProxy) — method, class away3d.filters.tasks.Filter3DVDepthOfFFieldTask
updateTime(time:int) — method, class away3d.animators.states.AnimationClipState
 | Updates the node's internal playhead position.
updateTime(time:int) — method, class away3d.animators.states.AnimationStateBase
 | Updates the node's internal playhead position.
updateTime(time:int) — method, class away3d.animators.states.SkeletonBinaryLERPState
 | Updates the node's internal playhead position.
updateTime(time:int) — method, class away3d.animators.states.SkeletonClipState
 | Updates the node's internal playhead position.
updateTime(time:int) — method, class away3d.animators.states.SkeletonDifferenceState
 | Updates the node's internal playhead position.
updateTime(time:int) — method, class away3d.animators.states.SkeletonDirectionalState
 | Updates the node's internal playhead position.
updateTime(time:int) — method, class away3d.animators.states.SkeletonNaryLERPState
 | Updates the node's internal playhead position.
updateTime(time:int) — method, class away3d.animators.transitions.CrossfadeTransitionState
 | Updates the node's internal playhead position.
updateTime() — method, class away3d.containers.View3D
updateTransform() — method, class away3d.core.base.Object3D
updateTransform() — method, class away3d.entities.Sprite3D
updateUVData(uvs:Vector$Number) — method, class away3d.core.base.SubGeometry
 | Updates the uv coordinates of the SubGeometry.
updateVertexData(vertices:Vector$Number) — method, class away3d.core.base.SubGeometry
 | Updates the vertex data of the SubGeometry.
updateVertexNormalData(vertexNormals:Vector$Number) — method, class away3d.core.base.SubGeometry
 | Updates the vertex normals of the SubGeometry.
updateVertexNormals(target:Vector$Number) — method, class away3d.core.base.CompactSubGeometry
updateVertexNormals(target:Vector$Number) — method, class away3d.core.base.SubGeometry
updateVertexNormals(target:Vector$Number) — method, class away3d.core.base.SubGeometryBase
 | Updates the vertex normals based on the geometry.
updateVertexTangentData(vertexTangents:Vector$Number) — method, class away3d.core.base.SubGeometry
 | Updates the vertex tangents of the SubGeometry.
updateVertexTangents(target:Vector$Number) — method, class away3d.core.base.CompactSubGeometry
updateVertexTangents(target:Vector$Number) — method, class away3d.core.base.SubGeometry
updateVertexTangents(target:Vector$Number) — method, class away3d.core.base.SubGeometryBase
 | Updates the vertex tangents based on the geometry.
updateViewSizeData() — method, class away3d.containers.View3D
uploadContent(texture:flash.display3D.textures:TextureBase) — method, class away3d.textures.ATFCubeTexture
uploadContent(texture:flash.display3D.textures:TextureBase) — method, class away3d.textures.ATFTexture
uploadContent(texture:flash.display3D.textures:TextureBase) — method, class away3d.textures.BitmapCubeTexture
uploadContent(texture:flash.display3D.textures:TextureBase) — method, class away3d.textures.BitmapTexture
uploadContent(texture:flash.display3D.textures:TextureBase) — method, class away3d.textures.PlanarReflectionTexture
uploadContent(texture:flash.display3D.textures:TextureBase) — method, class away3d.textures.RenderCubeTexture
uploadContent(texture:flash.display3D.textures:TextureBase) — method, class away3d.textures.RenderTexture
uploadContent(texture:flash.display3D.textures:TextureBase) — method, class away3d.textures.SpecularBitmapTexture
uploadContent(texture:flash.display3D.textures:TextureBase) — method, class away3d.textures.TextureProxyBase
uploadContent(texture:flash.display3D.textures:TextureBase) — method, class away3d.textures.WebcamTexture
uploadData(contextIndex:int) — method, class away3d.core.base.CompactSubGeometry
uploadData(contextIndex:int) — method, class away3d.core.base.SkinnedSubGeometry
upVector — Property, class away3d.core.base.Object3D
url — Property, class away3d.events.LoaderEvent
 | The url of the loaded resource.
url — Property, class away3d.loaders.misc.SingleFileLoader
useCondensedIndices — Property, class away3d.animators.SkeletonAnimator
 | Offers the option of enabling GPU accelerated animation on skeletons larger than 32 joints by condensing the number of joint index values required per mesh.
_useDiffuseTexture — Property, class away3d.materials.methods.BasicDiffuseMethod
useFaceWeights — Property, class away3d.core.base.SubGeometryBase
 | Indicates whether or not to take the size of faces into account when auto-deriving vertex normals and tangents.
uSegments — Property, class away3d.primitives.NURBSGeometry
 | Defines the number segments (triangle pair) the final curve will be divided into in the U direction
useMipmapping — Property, class away3d.materials.methods.MethodVO
USE_NEW_SYNTAX — Constant Static Property, class com.adobe.utils.AGALMiniAssembler
useNormals — Property, class away3d.animators.VertexAnimationSet
 | Returns whether or not normal data is used in last set GPU pass of the vertex shader.
_usePoint — Property, class away3d.materials.methods.SimpleShadowMapMethodBase
useRotations — Property, class away3d.tools.utils.Drag3D
 | Defines if the target object3d plane will be aligned to object rotations or not
usesCPU — Property, class away3d.animators.AnimationSetBase
 | Indicates whether the properties of the animation data contained within the set combined with the vertex registers aslready in use on shading materials allows the animation data to utilise GPU calls.
usesCPU — Property, interface away3d.animators.IAnimationSet
 | Indicates whether the properties of the animation data contained within the set combined with the vertex registers aslready in use on shading materials allows the animation data to utilise GPU calls.
usesCPU — Property, class away3d.animators.ParticleAnimationSet
 | Indicates whether the properties of the animation data contained within the set combined with the vertex registers aslready in use on shading materials allows the animation data to utilise GPU calls.
useSecondaryUV — Property, class away3d.materials.methods.AlphaMaskMethod
usesGlobalPosFragment — Property, class away3d.materials.compilation.MethodDependencyCounter
usesLights() — method, class away3d.materials.compilation.ShaderCompiler
usesLights() — method, class away3d.materials.passes.CompiledPass
usesLights() — method, class away3d.materials.passes.ShadowCasterPass
usesLightsForDiffuse() — method, class away3d.materials.compilation.ShaderCompiler
usesLightsForSpecular() — method, class away3d.materials.compilation.ShaderCompiler
useSmoothTextures — Property, class away3d.materials.methods.MethodVO
usesNormals — Property, class away3d.materials.compilation.ShaderCompiler
_usesNormals — Property, class away3d.materials.passes.CompiledPass
usesProbes() — method, class away3d.materials.compilation.ShaderCompiler
usesProbes() — method, class away3d.materials.passes.CompiledPass
usesProbes() — method, class away3d.materials.passes.ShadowCasterPass
usesProbesForDiffuse() — method, class away3d.materials.compilation.ShaderCompiler
usesProbesForSpecular() — method, class away3d.materials.compilation.ShaderCompiler
usesSoftwareRendering — Property, class away3d.core.managers.Stage3DProxy
 | Indicates whether the Stage3D managed by this proxy is running in software mode.
_useTexture — Property, class away3d.materials.methods.BasicAmbientMethod
_useTexture — Property, class away3d.materials.methods.BasicDiffuseMethod
_useTexture — Property, class away3d.materials.methods.BasicSpecularMethod
_usingSpecularMethod — Property, class away3d.materials.compilation.ShaderCompiler
usingSpecularMethod — Property, class away3d.materials.compilation.ShaderCompiler
_usingSpecularMethod — Property, class away3d.materials.passes.CompiledPass
uv — Property, class away3d.core.pick.PickingCollisionVO
 | The uv coordinate at the position of the collision.
uv — Property, class away3d.events.MouseEvent3D
 | The uv coordinate inside the draw primitive where the event took place.
UV — class, package away3d.core.base.data
 | Texture coordinates value object.
UV(u:Number, v:Number) — Constructor, class away3d.core.base.data.UV
 | Creates a new UV object.
uv0Index — Property, class away3d.core.base.data.Face
 | the index set for uv0 in this Face value object
uv0u — Property, class away3d.core.base.data.Face
uv0v — Property, class away3d.core.base.data.Face
uv1Index — Property, class away3d.core.base.data.Face
 | the index set for uv1 in this Face value object
uv1u — Property, class away3d.core.base.data.Face
uv1v — Property, class away3d.core.base.data.Face
uv2Index — Property, class away3d.core.base.data.Face
 | the index set for uv2 in this Face value object
uv2u — Property, class away3d.core.base.data.Face
uv2v — Property, class away3d.core.base.data.Face
UVAnimationFrame — class, package away3d.animators.data
 | A value object for a single frame of animation in a UVClipNode object.
UVAnimationFrame(offsetU:Number, offsetV:Number, scaleU:Number, scaleV:Number, rotation:Number) — Constructor, class away3d.animators.data.UVAnimationFrame
 | Creates a new UVAnimationFrame object.
UVAnimationSet — class, package away3d.animators
 | The animation data set used by uv-based animators, containing uv animation state data.
UVAnimator — class, package away3d.animators
 | Provides an interface for assigning uv-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.
UVAnimator(uvAnimationSet:away3d.animators:UVAnimationSet) — Constructor, class away3d.animators.UVAnimator
 | Creates a new UVAnimator object.
uvAttribute — Property, class away3d.animators.data.AnimationRegisterCache
_uvBuffer — Property, class away3d.core.base.SubGeometry
_uvBufferContext — Property, class away3d.core.base.SubGeometry
_uvBufferIndex — Property, class away3d.materials.compilation.ShaderCompiler
uvBufferIndex — Property, class away3d.materials.compilation.ShaderCompiler
_uvBufferIndex — Property, class away3d.materials.passes.CompiledPass
UVClipNode — class, package away3d.animators.nodes
 | A uv animation node containing time-based animation data as individual uv animation frames.
UVClipNode() — Constructor, class away3d.animators.nodes.UVClipNode
 | Creates a new UVClipNode object.
UVClipState — class, package away3d.animators.states
UVClipState(animator:away3d.animators:IAnimator, uvClipNode:away3d.animators.nodes:UVClipNode) — Constructor, class away3d.animators.states.UVClipState
UVData — Property, class away3d.core.base.CompactSubGeometry
UVData — Property, interface away3d.core.base.IRenderable
 | Retrieves the object's uvs as a Number array.
UVData — Property, interface away3d.core.base.ISubGeometry
 | Retrieves the object's uvs as a Number array.
UVData — Property, class away3d.core.base.SubGeometry
 | The raw texture coordinate data.
UVData — Property, class away3d.core.base.SubGeometryBase
UVData — Property, class away3d.core.base.SubMesh
UVData — Property, class away3d.entities.SegmentSet
UVData — Property, class away3d.entities.Sprite3D
UVData — Property, class away3d.primitives.SkyBox
uvDependencies — Property, class away3d.materials.compilation.MethodDependencyCounter
_uvDirty — Property, class away3d.extrusions.Elevation
_uvDirty — Property, class away3d.primitives.PrimitiveBase
UVOffset — Property, class away3d.core.base.CompactSubGeometry
UVOffset — Property, interface away3d.core.base.ISubGeometry
 | The offset into UVData vector where the UVs are placed
UVOffset — Property, class away3d.core.base.SubGeometry
UVOffset — Property, class away3d.core.base.SubGeometryBase
UVOffset — Property, class away3d.core.base.SubMesh
uvRotation — Property, class away3d.core.base.SubMesh
_uvs — Property, class away3d.core.base.SubGeometry
_uvsDirty — Property, class away3d.core.base.SubGeometryBase
_uvsInvalid — Property, class away3d.core.base.SubGeometry
_UVSource — Property, class away3d.materials.compilation.ShaderCompiler
UVSource — Property, class away3d.materials.compilation.ShaderCompiler
_UVSource — Property, class away3d.materials.passes.MaterialPassBase
UVStride — Property, class away3d.core.base.CompactSubGeometry
UVStride — Property, interface away3d.core.base.ISubGeometry
 | The distance between two consecutive UV elements
UVStride — Property, class away3d.core.base.SubGeometry
UVStride — Property, class away3d.core.base.SubGeometryBase
UVStride — Property, class away3d.core.base.SubMesh
uvTarget — Property, class away3d.animators.data.AnimationRegisterCache
_UVTarget — Property, class away3d.materials.compilation.ShaderCompiler
UVTarget — Property, class away3d.materials.compilation.ShaderCompiler
_UVTarget — Property, class away3d.materials.passes.MaterialPassBase
uvTransform — Property, interface away3d.core.base.IRenderable
uvTransform — Property, class away3d.core.base.SubMesh
uvTransform — Property, class away3d.entities.SegmentSet
uvTransform — Property, class away3d.entities.Sprite3D
uvTransform — Property, class away3d.primitives.SkyBox
UVTransform — Property, class away3d.tools.helpers.data.ParticleGeometryTransform
_uvTransformIndex — Property, class away3d.materials.compilation.ShaderCompiler
uvTransformIndex — Property, class away3d.materials.compilation.ShaderCompiler
_uvTransformIndex — Property, class away3d.materials.passes.CompiledPass
uvVar — Property, class away3d.animators.data.AnimationRegisterCache
uvVarying — Property, class away3d.materials.compilation.ShaderRegisterData
UV_VECTOR3D — Constant Static Property, class away3d.animators.nodes.ParticleSpriteSheetNode
 | Reference for spritesheet node properties on a single particle (when in local property mode).
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


V

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
V Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
v — Property, class away3d.core.base.data.UV
 | Defines the vertical coordinate of the texture value.
v0 — Property, class away3d.core.base.data.Face
v0Index — Property, class away3d.core.base.data.Face
 | set the index value for v0
v0x — Property, class away3d.core.base.data.Face
v0y — Property, class away3d.core.base.data.Face
v0z — Property, class away3d.core.base.data.Face
v1 — Property, class away3d.core.base.data.Face
v1Index — Property, class away3d.core.base.data.Face
 | set the index value for v1
v1x — Property, class away3d.core.base.data.Face
v1y — Property, class away3d.core.base.data.Face
v1z — Property, class away3d.core.base.data.Face
v2 — Property, class away3d.core.base.data.Face
v2Index — Property, class away3d.core.base.data.Face
 | set the index value for v2
v2x — Property, class away3d.core.base.data.Face
v2y — Property, class away3d.core.base.data.Face
v2z — Property, class away3d.core.base.data.Face
validate() — method, class away3d.core.base.Geometry
validate() — method, class away3d.primitives.PrimitiveBase
varyingsOffset — Property, class away3d.materials.compilation.ShaderRegisterCache
varyTime — Property, class away3d.animators.data.AnimationRegisterCache
V_AXIS — Constant Static Property, class away3d.animators.nodes.ParticleUVNode
VBlurFilter3D — class, package away3d.filters
VBlurFilter3D(amount:uint, stepSize:int) — Constructor, class away3d.filters.VBlurFilter3D
 | Creates a new VBlurFilter3D object
vControlPoints — Property, class away3d.primitives.NURBSGeometry
 | Defines the number of control points along the V splines
VDepthOfFieldFilter3D — class, package away3d.filters
VDepthOfFieldFilter3D(maxBlur:uint, stepSize:int) — Constructor, class away3d.filters.VDepthOfFieldFilter3D
 | Creates a new VDepthOfFieldFilter3D object
Vector3DUtils — class, package away3d.core.math
 | Vector3DUtils provides additional Vector3D math functions.
vectors — Property, class away3d.extrusions.DelaunayMesh
 | The "cloud" of vector3d's to compose the mesh
velocity — Property, class away3d.animators.states.ParticleVelocityState
 | Defines the default velocity vector of the state, used when in global mode.
velocityTarget — Property, class away3d.animators.data.AnimationRegisterCache
VELOCITY_VECTOR3D — Constant Static Property, class away3d.animators.nodes.ParticleVelocityNode
 | Reference for velocity node properties on a single particle (when in local property mode).
verbose — Property, class com.adobe.utils.AGALMiniAssembler
Vertex — class, package away3d.core.base.data
 | Vertex value object.
Vertex(x:Number, y:Number, z:Number, index:uint) — Constructor, class away3d.core.base.data.Vertex
 | Creates a new Vertex value object.
VertexAnimationMode — class, package away3d.animators.data
 | Options for setting the animation mode of a vertex animator object.
VertexAnimationSet — class, package away3d.animators
 | The animation data set used by vertex-based animators, containing vertex animation state data.
VertexAnimationSet(numPoses:uint, blendMode:String) — Constructor, class away3d.animators.VertexAnimationSet
 | Creates a new VertexAnimationSet object.
VertexAnimator — class, package away3d.animators
 | Provides an interface for assigning vertex-based animation data sets to mesh-based entity objects and controlling the various available states of animation through an interative playhead that can be automatically updated or manually triggered.
VertexAnimator(vertexAnimationSet:away3d.animators:VertexAnimationSet) — Constructor, class away3d.animators.VertexAnimator
 | Creates a new VertexAnimator object.
vertexAttributesOffset — Property, class away3d.materials.compilation.ShaderRegisterCache
 | Indicates the start index from which to retrieve vertex attributes.
_vertexBuffer — Property, class away3d.animators.data.AnimationSubGeometry
_vertexBuffer — Property, class away3d.core.base.CompactSubGeometry
_vertexBuffer — Property, class away3d.core.base.SubGeometry
_vertexBufferContext — Property, class away3d.core.base.SubGeometry
VertexClipNode — class, package away3d.animators.nodes
 | A vertex animation node containing time-based animation data as individual geometry obejcts.
VertexClipNode() — Constructor, class away3d.animators.nodes.VertexClipNode
 | Creates a new VertexClipNode object.
VertexClipState — class, package away3d.animators.states
VertexClipState(animator:away3d.animators:IAnimator, vertexClipNode:away3d.animators.nodes:VertexClipNode) — Constructor, class away3d.animators.states.VertexClipState
_vertexCode — Property, class away3d.materials.compilation.ShaderCompiler
vertexCode — Property, class away3d.materials.compilation.ShaderCompiler
_vertexCode — Property, class away3d.materials.passes.CompiledPass
vertexConstantData — Property, class away3d.animators.data.AnimationRegisterCache
_vertexConstantData — Property, class away3d.materials.compilation.ShaderCompiler
_vertexConstantData — Property, class away3d.materials.passes.CompiledPass
_vertexConstantOffset — Property, class away3d.materials.compilation.ShaderRegisterCache
vertexConstantOffset — Property, class away3d.materials.compilation.ShaderRegisterCache
 | Indicates the start index from which to retrieve vertex constants.
vertexConstantsIndex — Property, class away3d.materials.methods.MethodVO
_vertexConstantsOffset — Property, class away3d.materials.compilation.ShaderCompiler
vertexConstantsOffset — Property, class away3d.materials.compilation.ShaderCompiler
vertexConstantsOffset — Property, class away3d.materials.methods.MethodVO
_vertexConstantsOffset — Property, class away3d.materials.passes.CompiledPass
_vertexData — Property, class away3d.animators.data.AnimationSubGeometry
vertexData — Property, class away3d.animators.data.AnimationSubGeometry
vertexData — Property, class away3d.core.base.CompactSubGeometry
vertexData — Property, interface away3d.core.base.IRenderable
 | Retrieves the object's vertices as a Number array.
vertexData — Property, interface away3d.core.base.ISubGeometry
 | Retrieves the object's vertices as a Number array.
vertexData — Property, class away3d.core.base.SubGeometry
 | The raw vertex position data.
_vertexData — Property, class away3d.core.base.SubGeometryBase
vertexData — Property, class away3d.core.base.SubGeometryBase
vertexData — Property, class away3d.core.base.SubMesh
vertexData — Property, class away3d.entities.SegmentSet
vertexData — Property, class away3d.entities.Sprite3D
vertexData — Property, class away3d.materials.methods.MethodVO
vertexData — Property, class away3d.primitives.SkyBox
_vertexDataInvalid — Property, class away3d.core.base.CompactSubGeometry
vertexLife — Property, class away3d.animators.data.AnimationRegisterCache
_vertexNormalBuffer — Property, class away3d.core.base.SubGeometry
_vertexNormalBufferContext — Property, class away3d.core.base.SubGeometry
vertexNormalData — Property, class away3d.core.base.CompactSubGeometry
vertexNormalData — Property, interface away3d.core.base.IRenderable
 | Retrieves the object's normals as a Number array.
vertexNormalData — Property, interface away3d.core.base.ISubGeometry
 | Retrieves the object's normals as a Number array.
vertexNormalData — Property, class away3d.core.base.SubGeometry
 | The raw vertex normal data.
vertexNormalData — Property, class away3d.core.base.SubGeometryBase
vertexNormalData — Property, class away3d.core.base.SubMesh
vertexNormalData — Property, class away3d.entities.SegmentSet
vertexNormalData — Property, class away3d.entities.Sprite3D
vertexNormalData — Property, class away3d.primitives.SkyBox
vertexNormalOffset — Property, class away3d.core.base.CompactSubGeometry
vertexNormalOffset — Property, interface away3d.core.base.ISubGeometry
 | The offset into vertexNormalData where the normals are placed
vertexNormalOffset — Property, class away3d.core.base.SubGeometry
vertexNormalOffset — Property, class away3d.core.base.SubGeometryBase
vertexNormalOffset — Property, class away3d.core.base.SubMesh
vertexNormalOffset — Property, class away3d.entities.SegmentSet
vertexNormalOffset — Property, class away3d.entities.Sprite3D
vertexNormalOffset — Property, class away3d.primitives.SkyBox
_vertexNormals — Property, class away3d.core.base.SubGeometry
_vertexNormalsDirty — Property, class away3d.core.base.SubGeometryBase
vertexNormalStride — Property, class away3d.core.base.CompactSubGeometry
vertexNormalStride — Property, interface away3d.core.base.ISubGeometry
 | The distance between two consecutive normal elements This always applies to vertices, normals and tangents.
vertexNormalStride — Property, class away3d.core.base.SubGeometry
vertexNormalStride — Property, class away3d.core.base.SubGeometryBase
vertexOffset — Property, class away3d.core.base.CompactSubGeometry
vertexOffset — Property, interface away3d.core.base.ISubGeometry
 | The offset into vertexData where the vertices are placed
vertexOffset — Property, class away3d.core.base.SubGeometry
vertexOffset — Property, class away3d.core.base.SubGeometryBase
vertexOffset — Property, class away3d.core.base.SubMesh
vertexOffset — Property, class away3d.entities.SegmentSet
vertexOffset — Property, class away3d.entities.Sprite3D
vertexOffset — Property, class away3d.primitives.SkyBox
vertexOneConst — Property, class away3d.animators.data.AnimationRegisterCache
vertexStride — Property, class away3d.core.base.CompactSubGeometry
vertexStride — Property, interface away3d.core.base.IRenderable
 | The number of data elements in the buffers per vertex.
vertexStride — Property, interface away3d.core.base.ISubGeometry
 | The distance between two consecutive vertex, normal or tangent elements This always applies to vertices, normals and tangents.
vertexStride — Property, class away3d.core.base.SubGeometry
vertexStride — Property, class away3d.core.base.SubGeometryBase
vertexStride — Property, class away3d.core.base.SubMesh
vertexStride — Property, class away3d.entities.SegmentSet
vertexStride — Property, class away3d.entities.Sprite3D
vertexStride — Property, class away3d.primitives.SkyBox
_vertexTangentBuffer — Property, class away3d.core.base.SubGeometry
_vertexTangentBufferContext — Property, class away3d.core.base.SubGeometry
vertexTangentData — Property, class away3d.core.base.CompactSubGeometry
vertexTangentData — Property, interface away3d.core.base.IRenderable
 | Retrieves the object's tangents as a Number array.
vertexTangentData — Property, interface away3d.core.base.ISubGeometry
 | Retrieves the object's tangents as a Number array.
vertexTangentData — Property, class away3d.core.base.SubGeometryBase
vertexTangentData — Property, class away3d.core.base.SubMesh
vertexTangentData — Property, class away3d.entities.SegmentSet
vertexTangentData — Property, class away3d.entities.Sprite3D
vertexTangentData — Property, class away3d.primitives.SkyBox
vertexTangentOffset — Property, class away3d.core.base.CompactSubGeometry
vertexTangentOffset — Property, interface away3d.core.base.ISubGeometry
 | The offset into vertexTangentData where the tangents are placed
vertexTangentOffset — Property, class away3d.core.base.SubGeometry
vertexTangentOffset — Property, class away3d.core.base.SubGeometryBase
vertexTangentOffset — Property, class away3d.core.base.SubMesh
vertexTangentOffset — Property, class away3d.entities.SegmentSet
vertexTangentOffset — Property, class away3d.entities.Sprite3D
vertexTangentOffset — Property, class away3d.primitives.SkyBox
_vertexTangents — Property, class away3d.core.base.SubGeometry
_vertexTangentsDirty — Property, class away3d.core.base.SubGeometryBase
vertexTangentStride — Property, class away3d.core.base.CompactSubGeometry
vertexTangentStride — Property, interface away3d.core.base.ISubGeometry
 | The distance between two consecutive tangent elements This always applies to vertices, normals and tangents.
vertexTangentStride — Property, class away3d.core.base.SubGeometry
vertexTangentStride — Property, class away3d.core.base.SubGeometryBase
vertexTime — Property, class away3d.animators.data.AnimationRegisterCache
vertexTransform — Property, class away3d.tools.helpers.data.ParticleGeometryTransform
vertexTwoConst — Property, class away3d.animators.data.AnimationRegisterCache
vertexZeroConst — Property, class away3d.animators.data.AnimationRegisterCache
_verticesInvalid — Property, class away3d.core.base.SubGeometry
VideoTexture — class, package away3d.textures
VideoTexture(source:String, materialWidth:uint, materialHeight:uint, loop:Boolean, autoPlay:Boolean, player:away3d.materials.utils:IVideoPlayer) — Constructor, class away3d.textures.VideoTexture
view — Property, class away3d.events.MouseEvent3D
 | The view object inside which the event took place.
View3D — class, package away3d.containers
View3D(scene:away3d.containers:Scene3D, camera:away3d.cameras:Camera3D, renderer:away3d.core.render:RendererBase, forceSoftware:Boolean) — Constructor, class away3d.containers.View3D
viewDirDependencies — Property, class away3d.materials.compilation.MethodDependencyCounter
viewDirFragment — Property, class away3d.materials.compilation.ShaderRegisterData
viewDirVarying — Property, class away3d.materials.compilation.ShaderRegisterData
viewHeight — Property, class away3d.core.managers.RTTBufferManager
_viewHeight — Property, class away3d.core.render.RendererBase
viewHeight — Property, class away3d.core.render.RendererBase
viewPort — Property, class away3d.core.managers.Stage3DProxy
 | A viewPort rectangle equivalent of the Stage3D size and position.
viewProjection — Property, class away3d.cameras.Camera3D
 | The view projection matrix of the camera.
viewProjection — Property, class away3d.entities.TextureProjector
 | The matrix that projects a point in scene space into the texture coordinates.
_viewScissorRect — Property, class away3d.containers.View3D
ViewVolume — class, package away3d.core.partition
ViewVolume(minBound:flash.geom:Vector3D, maxBound:flash.geom:Vector3D, cellSize:Number) — Constructor, class away3d.core.partition.ViewVolume
 | Creates a new ViewVolume with given dimensions.
ViewVolumePartition — class, package away3d.core.partition
ViewVolumePartition() — Constructor, class away3d.core.partition.ViewVolumePartition
ViewVolumeRootNode — class, package away3d.core.partition
ViewVolumeRootNode() — Constructor, class away3d.core.partition.ViewVolumeRootNode
viewWidth — Property, class away3d.core.managers.RTTBufferManager
_viewWidth — Property, class away3d.core.render.RendererBase
viewWidth — Property, class away3d.core.render.RendererBase
visible — Property, class away3d.containers.ObjectContainer3D
visible — Property, class away3d.containers.View3D
visible — Property, class away3d.core.base.SubMesh
visible — Property, class away3d.core.managers.Stage3DProxy
 | The visibility of the Stage3D.
VISIBLITY_UPDATED — Constant Static Property, class away3d.events.Object3DEvent
 | Defines the value of the type property of a visiblityUpdated event object.
vKnot — Property, class away3d.primitives.NURBSGeometry
 | Defines the knot sequence in the V direction that determines where and how the control points affect the NURBS curve.
volume — Property, class away3d.audio.Sound3D
 | Defines the overall (master) volume of the 3D sound, after any positional adjustments to volume have been applied.
volume — Property, class away3d.audio.SoundTransform3D
_volume — Property, class away3d.audio.drivers.AbstractSound3DDriver
volume — Property, class away3d.audio.drivers.AbstractSound3DDriver
volume — Property, interface away3d.audio.drivers.ISound3DDriver
 | Master volume/gain after 3D modifications to pan/volume have been applied.
volume — Property, class away3d.audio.drivers.SimplePanVolumeDriver
volume — Property, interface away3d.materials.utils.IVideoPlayer
 | Master volume/gain
volume — Property, class away3d.materials.utils.SimpleVideoPlayer
vOrder — Property, class away3d.primitives.NURBSGeometry
 | Defines the number of control points along the V splines that influence any given point on the curve
vSegments — Property, class away3d.primitives.NURBSGeometry
 | Defines the number segments (triangle pair) the final curve will be divided into in the V direction
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


W

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
W Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
w — Property, class away3d.core.math.Quaternion
 | The w value of the quaternion.
w — Property, class away3d.primitives.data.NURBSVertex
warning(message:Object) — Static Method , class away3d.debug.Debug
warningsAsErrors — Static Property, class away3d.debug.Debug
water1OffsetX — Property, class away3d.materials.methods.SimpleWaterNormalMethod
water1OffsetY — Property, class away3d.materials.methods.SimpleWaterNormalMethod
water2OffsetX — Property, class away3d.materials.methods.SimpleWaterNormalMethod
water2OffsetY — Property, class away3d.materials.methods.SimpleWaterNormalMethod
WebcamTexture — class, package away3d.textures
WebcamTexture(cameraWidth:uint, cameraHeight:uint, materialSize:uint, autoStart:Boolean, camera:flash.media:Camera, smoothing:Boolean) — Constructor, class away3d.textures.WebcamTexture
WEBSITE_URL — Constant Static Property, class away3d.Away3D
Weld — class, package away3d.tools.commands
 | Class Weld removes the vertices that can be shared from one or more meshes (smoothes the mesh surface when lighted).
Weld() — Constructor, class away3d.tools.commands.Weld
width — Property, class away3d.containers.View3D
 | The width of the viewport.
width — Property, class away3d.core.managers.Stage3DProxy
 | The width of the Stage3D.
width — Property, class away3d.core.partition.ViewVolume
width — Property, class away3d.entities.Sprite3D
width — Property, class away3d.extrusions.Elevation
 | The width of the terrain plane.
width — Property, interface away3d.materials.utils.IVideoPlayer
 | Get/Set access to the with of the video object
width — Property, class away3d.materials.utils.SimpleVideoPlayer
width — Property, class away3d.primitives.CubeGeometry
 | The size of the cube along its X-axis.
width — Property, class away3d.primitives.PlaneGeometry
 | The width of the plane.
width — Property, class away3d.primitives.WireframeCube
 | The size of the cube along its X-axis.
width — Property, class away3d.primitives.WireframePlane
 | The size of the cube along its X-axis.
width — Property, class away3d.textures.ATFData
width — Property, class away3d.textures.RenderTexture
_width — Property, class away3d.textures.TextureProxyBase
width — Property, class away3d.textures.TextureProxyBase
width — Static Property, class away3d.tools.utils.Bounds
willTrigger(type:String) — Static Method , class away3d.library.AssetLibrary
willTrigger(type:String) — method, class away3d.lights.shadowmaps.CascadeShadowMapper
willTrigger(type:String) — method, class away3d.loaders.misc.AssetLoaderToken
WireframeAxesGrid — class, package away3d.debug
 | Class WireframeAxesGrid generates a grid of lines on a given planeWireframeAxesGrid
WireframeAxesGrid(subDivision:uint, gridSize:uint, thickness:Number, colorXY:uint, colorZY:uint, colorXZ:uint) — Constructor, class away3d.debug.WireframeAxesGrid
WireframeCube — class, package away3d.primitives
 | A WirefameCube primitive mesh.
WireframeCube(width:Number, height:Number, depth:Number, color:uint, thickness:Number) — Constructor, class away3d.primitives.WireframeCube
 | Creates a new WireframeCube object.
WireframeCylinder — class, package away3d.primitives
 | Generates a wireframd cylinder primitive.
WireframeCylinder(topRadius:Number, bottomRadius:Number, height:Number, segmentsW:uint, segmentsH:uint, color:uint, thickness:Number) — Constructor, class away3d.primitives.WireframeCylinder
 | Creates a new WireframeCylinder instance
WireframeMapGenerator — class, package away3d.materials.utils
 | WireframeMapGenerator is a utility class to generate a wireframe texture for uniquely mapped meshes.
WireframePlane — class, package away3d.primitives
 | A WireframePlane primitive mesh.
WireframePlane(width:Number, height:Number, segmentsW:int, segmentsH:int, color:uint, thickness:Number, orientation:String) — Constructor, class away3d.primitives.WireframePlane
 | Creates a new WireframePlane object.
WireframePrimitiveBase — class, package away3d.primitives
WireframePrimitiveBase(color:uint, thickness:Number) — Constructor, class away3d.primitives.WireframePrimitiveBase
WireframeSphere — class, package away3d.primitives
 | A WireframeSphere primitive mesh
WireframeSphere(radius:Number, segmentsW:uint, segmentsH:uint, color:uint, thickness:Number) — Constructor, class away3d.primitives.WireframeSphere
 | Creates a new WireframeSphere object.
WrapDiffuseMethod — class, package away3d.materials.methods
 | WrapDiffuseMethod is an alternative to BasicDiffuseMethod in which the light is allowed to be "wrapped around" the normally dark area, to some extent.
WrapDiffuseMethod(wrapFactor:Number, scatterTexture:away3d.textures:Texture2DBase) — Constructor, class away3d.materials.methods.WrapDiffuseMethod
 | Creates a new WrapDiffuseMethod object.
wrapFactor — Property, class away3d.materials.methods.WrapDiffuseMethod
wrapPanAngle — Property, class away3d.controllers.HoverController
 | Defines whether the value of the pan angle wraps when over 360 degrees or under 0 degrees.
writeBoolean(name:String, value:Boolean) — method, class away3d.tools.serialize.SerializerBase
 | Serialize Boolean
writeBoolean(name:String, value:Boolean) — method, class away3d.tools.serialize.TraceSerializer
 | Serialize Boolean
writeInt(name:String, value:int) — method, class away3d.tools.serialize.SerializerBase
 | Serialize int
writeInt(name:String, value:int) — method, class away3d.tools.serialize.TraceSerializer
 | Serialize int
writeQuaternion(name:String, value:away3d.core.math:Quaternion) — method, class away3d.tools.serialize.SerializerBase
 | Serialize Quaternion
writeQuaternion(name:String, value:away3d.core.math:Quaternion) — method, class away3d.tools.serialize.TraceSerializer
 | Serialize Quaternion
writeString(name:String, value:String) — method, class away3d.tools.serialize.SerializerBase
 | Serialize String
writeString(name:String, value:String) — method, class away3d.tools.serialize.TraceSerializer
 | Serialize String
writeTransform(name:String, value:Vector$Number) — method, class away3d.tools.serialize.SerializerBase
 | Serialize Transform, in the form of Vector.<Number>
writeTransform(name:String, value:Vector$Number) — method, class away3d.tools.serialize.TraceSerializer
 | Serialize Transform, in the form of Vector.<Number>
writeUint(name:String, value:uint) — method, class away3d.tools.serialize.SerializerBase
 | Serialize uint
writeUint(name:String, value:uint) — method, class away3d.tools.serialize.TraceSerializer
 | Serialize uint
writeVector3D(name:String, value:flash.geom:Vector3D) — method, class away3d.tools.serialize.SerializerBase
 | Serialize Vector3D
writeVector3D(name:String, value:flash.geom:Vector3D) — method, class away3d.tools.serialize.TraceSerializer
 | Serialize Vector3D
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


X

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
X Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
x — Property, class away3d.containers.View3D
_x — Property, class away3d.core.base.Object3D
x — Property, class away3d.core.base.Object3D
 | Defines the x coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D.
x — Property, class away3d.core.base.data.Vertex
 | To define/store the x value of the value object
x — Property, class away3d.core.managers.Stage3DProxy
 | The x position of the Stage3D.
x — Property, class away3d.core.math.Quaternion
 | The x value of the quaternion.
X_AXIS — Constant Static Property, class away3d.extrusions.LatheExtrude
X_AXIS — Constant Static Property, class away3d.extrusions.LinearExtrude
X_AXIS — Constant Static Property, class away3d.tools.commands.Align
X_AXIS — Constant Static Property, class away3d.tools.commands.Mirror
xml(data:any) — Static Method , class away3d.utils.Cast
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


Y

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
Y Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
y — Property, class away3d.containers.View3D
_y — Property, class away3d.core.base.Object3D
y — Property, class away3d.core.base.Object3D
 | Defines the y coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D.
y — Property, class away3d.core.base.data.Vertex
 | To define/store the y value of the value object
y — Property, class away3d.core.managers.Stage3DProxy
 | The y position of the Stage3D.
y — Property, class away3d.core.math.Quaternion
 | The y value of the quaternion.
yaw(angle:Number) — method, class away3d.core.base.Object3D
 | Rotates the 3d object around it's local y-axis
Y_AXIS — Constant Static Property, class away3d.extrusions.LatheExtrude
Y_AXIS — Constant Static Property, class away3d.extrusions.LinearExtrude
Y_AXIS — Constant Static Property, class away3d.tools.commands.Align
Y_AXIS — Constant Static Property, class away3d.tools.commands.Mirror
yFactor — Property, class away3d.controllers.HoverController
 | Fractional difference in distance between the horizontal camera orientation and vertical camera orientation.
yUp — Property, class away3d.primitives.CapsuleGeometry
 | Defines whether the capsule poles should lay on the Y-axis (true) or on the Z-axis (false).
_yUp — Property, class away3d.primitives.CylinderGeometry
yUp — Property, class away3d.primitives.CylinderGeometry
 | Defines whether the cylinder poles should lay on the Y-axis (true) or on the Z-axis (false).
yUp — Property, class away3d.primitives.PlaneGeometry
 | Defines whether the normal vector of the plane should point along the Y-axis (true) or Z-axis (false).
yUp — Property, class away3d.primitives.SphereGeometry
 | Defines whether the sphere poles should lay on the Y-axis (true) or on the Z-axis (false).
_yUp — Property, class away3d.primitives.TorusGeometry
yUp — Property, class away3d.primitives.TorusGeometry
 | Defines whether the torus poles should lay on the Y-axis (true) or on the Z-axis (false).
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z


Z

Away3D Documentation | All Packages | All Classes | Frames No Frames | Adobe Logo
Z Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
z — Property, class away3d.containers.View3D
_z — Property, class away3d.core.base.Object3D
z — Property, class away3d.core.base.Object3D
 | Defines the z coordinate of the 3d object relative to the local coordinates of the parent ObjectContainer3D.
z — Property, class away3d.core.base.data.Vertex
 | To define/store the z value of the value object
z — Property, class away3d.core.math.Quaternion
 | The z value of the quaternion.
Z_AXIS — Constant Static Property, class away3d.extrusions.LatheExtrude
Z_AXIS — Constant Static Property, class away3d.extrusions.LinearExtrude
Z_AXIS — Constant Static Property, class away3d.tools.commands.Align
Z_AXIS — Constant Static Property, class away3d.tools.commands.Mirror
zIndex — Property, interface away3d.core.base.IRenderable
 | The distance of the IRenderable object to the view, used to sort per object.
zIndex — Property, class away3d.core.base.SubMesh
 | The distance of the SubMesh object to the view, used to sort per object.
zIndex — Property, class away3d.core.data.RenderableListItem
zIndex — Property, class away3d.primitives.SkyBox
 | The distance of the IRenderable object to the view, used to sort per object.
_zIndices — Property, class away3d.entities.Entity
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Thu Nov 15 2012, 12:09 PM Z