首页

  • 产品概况

    UCHome 产品概况介绍

  • 安装升级

    UCHome 安装和升级方法介绍

  • 后台使用

    UCHome 后台使用介绍

  • 前台使用

    UCHome 前台使用介绍


产品概况

UCenter Home 产品概况

UCenter Home（简称 UCHome） 是一套采用 PHP+MYSQL 构建的社会化网络软件（Social Network Software，简称 SNS）。

通过 UCenter Home，建站者可以轻松构建一个以好友关系为核心的交流网络，让站点用户可以用迷你博客一句话记录生活中的点点滴滴；方便快捷地发布日志、上传图片；更可以十分方便的与其好友们一起分享信息、讨论感兴趣的话题；轻松快捷的了解好友最新动态。

UCenter Home 强调“家”的理念，充分认可每一个站点用户的个人隐私重要性。提供强大丰富的隐私设置功能。每一个人都有权限设置自己的个人主页、资料、日志、相册等是否公开、或只好友可看、或指定特别好友可看、或仅自己可看、或者需要输入密码才可看；并可完全控制将自己的哪些动作可以产生动态推送到好友面前。

UCenter Home 强调只提供用户愿意关注的信息，在信息噪音方面有着多级筛选控制。每一个人都可以将自己的好友进行分组，并选择屏蔽哪些用户组的动态；同时，可针对特定的好友、特定的动态进行单独屏蔽，确保因好友增多带来的信息噪音问题。

UCenter Home 以 UCenter 为多应用交换中心，既可以独立运作，又可以实现与多个应用挂接，包括 Discuz! 论坛、SupeV 视频、ECShop 商店等，用户在这些各类产品中的动作，都可以以动态的方式发送到 UCenter Home，让关注的好友们及时了解到自己的行为；同时，自己也可以在 UCenter Home 即可轻松理解好友在站内各种系统中的更新信息。

返回首页
康盛创想（北京）科技有限公司 © 2001 - 2009 Comsenz Inc.
问题和建议请反馈至：doc@comsenz.com


安装升级

UCHome 安装升级

  • Windows 系统环境搭建教程
  • Linux 系统环境搭建教程
  • UCenter 安装方法详细介绍
  • UCHome 安装方法详细介绍
  • 任意版本升级到 UCHome 1.5 升级方法
返回首页


Windows 环境搭建推荐教程

安装 —— Windows 环境搭建推荐教程

一、系统约定

环境软件下载后存放位置：X:\Server_Tools

环境软件安装位置：X:\Server_Core

PHP安装位置：X:\Server_Core\PHP

MySQL安装位置：X:\Server_Core\MySQL

Zend Optimizer安装位置：X:\Server_Core\Zend

IIS网站站点根目录：X:\wwwroot

MySQL 数据库位置：X:\Database

Php.ini存放位置：X:\Windows\php.ini

My.ini 存放位置：X:\Server_Core\MySQL\my.ini

二、系统环境检查以及准备所需软件

1. 检查系统是否已安装IIS

单击："开始"－"管理工具"，检查是否存在" Internet 信息服务(IIS)管理器 "

2. 查看磁盘分区容量并确定使用策略

打开"我的电脑"，查看除 C 区外各个磁盘分区的可用空间容量，使用容量较大的磁盘分区作为 WEB 根目录，且 MySQL 数据库存储目录(Database)，尽量不要与 WEB 根目录同在一个磁盘分区内。较小的磁盘分区可以作为服务环境软件的安装目录分区。

3. 下载环境软件

将所有软件均下载存放于Server_Tools文件夹中。

MySQL-essential-5.0.45-win32.msi

php-5.2.4-Win32.zip

ZendOptimizer-3.3.0-Windows-i386.exe

三、环境部署

1．安装MySQL

(1) 安装软件

进入 X:\Server_Tools 文件夹，双击 MySQL-essential-5.0.45-win32.msi ；如下图所示：

选择 Custom 自定义安装，如下图所示：

点击"Change"更改 MySQL 安装目录，如下图所示：

待文件复制安装完毕后，进行 MySQL 设置界面，单击 Finish 。如下图所示：

选择 Detailed Configuration 进行详细配置，如下图所示：

选择 MySQL 运行模式：Server Machine 如下图所示：

选择 MySQL 数据库默认存储方式：Non-Trans Only ( MYISAM) 如下图所示：

设定 MySQL 最大连接数：一般设置为 128 - 512 之间的整数。如下图所示：

设定 MySQL 网络参数，注意：不要启用 Strict Mode！ 如下图所示：

设定 MySQL 默认字符集：以用户站点语言为准。如下图所示：

Windows 环境设定，如下图所示：

修改设定 root 用户密码，注意：不要启动远程连接模式！ 如下图所示：

完成 MySQL 的安装，并启动 MySQL 服务。如下图所示：

(2) 测试 MySQL 工作是否正常。

打开 cmd 命令提示符窗口，输入命令：MySQL –u root –p

输入密码后，如果能够正常进入 MySQL 控制台则说明 MySQL 安装正常。

(3) 更改 MySQL 数据库目录

a) 打开 cmd 命令提示符窗口，输入命令：net stop MySQL 停止 MySQL 服务运行；

b) 打开X:\Server_Core\MySQL\my.ini

找到：

Datadir = "X:\Server_Core\MySQL\data"

修改为：

Datadir = "X:\Database"

c) 将 X:\Server_Core\MySQL\data 文件夹复制到 X:\ ，并重命名为X:\Database；

d) 打开 cmd 命令提示符窗口，输入命令：net start MySQL 启动 MySQL 服务。

e) 重新测试 MySQL 是否工作正常。

(4) 准备 LibMySQL 动态链接库

将 X:\Server_Core\MySQL\bin\libMySQL.dll 文件复制到 C:\Windows\System32 。

2. 安装 PHP

(1) 解压缩下载的 php-5.2.4-Win32.zip 文件，并将其复制到：X:\Server_Core\PHP ；

(2) 进入 X:\Server_Core\PHP 文件夹，将 php.ini-dist 重命名为 php.ini ；

(3) 打开 php.ini 文件，找到：extension_dir = "./"

将其改为；

extension_dir = "X:\Server_Core\PHP\ext"

(4) 找到：Windows Extensions

在 Windows Extensions 下方的动态模块配置中，需要打开以下模块支持：（去掉模块配置每行前面的；号即可）

extension=php_mbstring.dll

extension=php_gd2.dll

extension=php_MySQL.dll

(5) 找到：

disable_functions =

改为：

disable_functions = phpinfo,passthru,exec,system,chroot,scandir,chgrp,chown,shell_exec,proc_open,proc_get_status,ini_alter,ini_alter,ini_restore,dl,pfsockopen,openlog,syslog,readlink,symlink,popepassthru,stream_socket_server

(6) 保存 php.ini 文件，并将其复制到 C:\Windows\

3. IIS 与 PHP 的整合配置 － 新建一个网站

(1) 启动 IIS 管理器，并新建一个网站（虚拟主机）；如下图所示：

(2) 输入网站名称，改名称仅为 IIS 中的标识，可任意输入。如下图所示：

(3) 网站IP地址不用填写，端口如没有特殊要求则保持 80 即可，最后正确输入网站域名。如下图所示：

(4) 在网站分区中建立 wwwroot 以及下级站点文件夹 bbs。如下图所示：

(5) 对于 PHP 应用，需要给予该站点"读取"和"运行脚本"的权限。如下图所示：

(6) 至此，已经成功的新建了一个站点。如下图所示：

4. IIS 与 PHP 的整合配置 － 使站点支持 PHP

(1) 打开刚刚建立的网站属性，如下图所示：

(2) 在站点属性窗口中，单击"主目录"页签，单击"配置"按钮，在新弹出的"应用程序配置"对话框中，单击"添加"按钮，加入 PHP 的 ISAPI 支持，选择可执行文件：X:\Server_Core\PHP\php5isapi.dll 、扩展名为 .php 、限制动作为：GET,POST 。单击"确定"添加，并在"应用程序配置"窗口中查看 .php 扩展是否加载成功。若成功，则单击"确定"关闭配置窗口，回到站点属性主窗口。如下图所示：

(3) 单击"文档"页签，在默认内容文档中添加 index.htm、index.html、index.php 三个文件，并将所有默认文档排序，顺序按照下图所示。完成后，单击"确定"，关闭站点属性配置窗口，回到 IIS 管理器主界面。如下图所示：

(4) 右键单击"Web 服务扩展"，添加 PHP 扩展支持。如下图所示：

(5) 在如下图所示的"新建WEB服务扩展"对话框中，"扩展名"填写PHP，"文件"选择 X:\Server_Core\PHP\php5isapi.dll ，并设置该PHP扩展默认为允许。如下图所示：

(6) 重启 IIS 服务，如下图所示：

5、测试 PHP 支持是否正常

IIS与PHP的整合已经完毕，下面需要测试 PHP 支持是否正常。

(1) 进入 X:\wwwroot\bbs\ 目录，新建一个 phpinfo.php 文件，内容为：

(2) 打开IE浏览器，输入：http://www.domain.com/phpinfo.php ；

(3) 如果能够正常显示PHP支持信息则表明配置整合是成功的。

6、安装 Zend Optimizer

进入 X:\Server_Tools 文件夹，双击下载的 ZendOptimizer-3.2.6-Windows-i386.exe 文件，安装过程非常友好，也比较简单，因而此处不再进行截图说明。但需注意以下几点：

(1) Zend Optimzer 的安装目录要指定为 X:\Server_Core\Zend ；

(2) 在安装过程中提示 php.ini 的位置是，注意观察是否为 C:\Windows ，如果不是必须手动指定为 C:\Windows ；

(3) 安装过程中提示 IIS 网站根目录的位置，指定为： X:\wwwroot 。

Zend Optimizer 安装完成后会自动重启 IIS 服务，重启完成后需要再次打开IE浏览器窗口，查看 phpinfo.php 支持信息，观察是否包含了 Zend Optimizer 支持信息，如果没有，则说明 Zend Optimizer 没有安装成功！

最后，修改 php.ini 文件，将 phpinfo 函数加入到 disable_functions 中。


Linux 环境搭建推荐教程

安装 —— Linux 环境搭建推荐教程

一、系统约定

软件源代码包存放位置：/usr/local/src

源码包编译安装位置(prefix)：/usr/local/software_name

脚本以及维护程序存放位置：/usr/local/sbin

MySQL 数据库位置：/var/lib/MySQL（可按情况设置）

Apache 网站根目录：/home/www/wwwroot（可按情况设置）

Apache 虚拟主机日志根目录：/home/www/logs（可按情况设置）

Apache 运行账户：www:www

二、系统环境部署及调整

1. 检查系统是否正常

# more /var/log/messages（检查有无系统级错误信息）

# dmesg（检查硬件设备是否有错误信息）

# ifconfig（检查网卡设置是否正确）

# ping www.163.com（检查网络是否正常）

2. 关闭不需要的服务

# ntsysv

以下仅列出需要启动的服务，未列出的服务一律推荐关闭：

atd

crond

irqbalance

microcode_ctl

network

sendmail

sshd

syslog

3. 重新启动系统

# init 6

4. 配置 vim

# vi /root/.bashrc

在 alias mv='mv -i' 下面添加一行：alias vi='vim' 保存退出。

# echo 'syntax on' > /root/.vimrc

5. 使用 yum 程序安装所需开发包（以下为标准的 RPM 包名称）

# yum install ntp vim-enhanced gcc gcc-c++ gcc-g77 flex bison autoconf automake bzip2-devel ncurses-devel libjpeg-devel libpng-devel libtiff-devel freetype-devel pam-devel kernel

6. 定时校正服务器时钟，定时与中国国家授时中心授时服务器同步

# crontab -e

加入一行：

*/30 * * * * ntpdate 210.72.145.44

7. 源码编译安装所需包 (Source)

(1) GD2

# cd /usr/local/src

# tar xzvf gd-2.0.34.tar.gz

# cd gd-2.0.34

# ./configure --prefix=/usr/local/gd2

# make

# make install

(2) LibXML2

# cd /usr/local/src

# tar xjvf libxml2-2.6.30.tar.bz2

# cd libxml2-2.6.30

# ./configure --prefix=/usr/local/libxml2

# make

# make install

(3) LibMcrypt

# cd /usr/local/src

# tar xjvf libmcrypt-2.5.8.tar.bz2

# cd libmcrypt-2.5.8

# ./configure –prefix=/usr/local/libmcrypt

# make

# make install

(4) Apache日志截断程序

# cd /usr/local/src

# tar xzvf cronolog-1.7.0-beta.tar.gz

# cd cronolog-1.7.0-beta

# ./configure –prefix=/usr/local/cronolog

# make

# make install

8. 升级OpenSSL和OpenSSH

# cd /usr/local/src

# tar xzvf openssl-0.9.8e.tar.gz

# cd openssl-0.9.8e

# ./config --prefix=/usr/local/openssl

# make

# make test

# make install

# cd ..

# tar xzvf openssh-4.7p1.tar.gz

# cd openssh-4.7p1

# ./configure \

"--prefix=/usr" \

"--with-pam" \

"--with-zlib" \

"--sysconfdir=/etc/ssh" \

"--with-ssl-dir=/usr/local/openssl" \

"--with-md5-passwords"

# make

# make install

（1）禁用 SSH V1 协议

找到：

#Protocol 2,1

改为：

Protocol 2

（2）禁止root直接登录

此处先建立一个普通系统用户：

# useradd username

# passwd username

找到：

#PermitRootLogin yes

改为：

PermitRootLogin no

（3）禁用服务器端GSSAPI

找到以下两行，并将它们注释：

GSSAPIAuthentication yes

GSSAPICleanupCredentials yes

（4）禁用 DNS 名称解析

找到：

#UseDNS yes

改为：

UseDNS no

（5）禁用客户端 GSSAPI

# vi /etc/ssh/ssh_config

找到：

GSSAPIAuthentication yes

将这行注释掉。

最后，确认修改正确后重新启动 SSH 服务

# service sshd restart

# ssh -v

确认 OpenSSH 以及 OpenSSL 版本正确。

三、编译安装L.A.M.P环境

1. 下载软件

# cd /usr/local/src

httpd-2.2.6.tar.bz2

MySQL-5.0.45-linux-i686-glibc23.tar.gz

php-5.2.4.tar.bz2

ZendOptimizer-3.3.0-linux-glibc21-i386.tar.gz

2. 安装MySQL

# tar xzvf MySQL-5.0.45-linux-i686-glibc23.tar.gz

# mv MySQL-5.0.45-linux-i686-glibc23 /usr/local/

# ln -s /usr/local/ MySQL-5.0.45-linux-i686-glibc23 /usr/local/MySQL

# useradd MySQL

# chown -R MySQL:root /usr/local/MySQL/

# cd /usr/local/MySQL

# ./scripts/MySQL_install_db --user=MySQL

# cp ./support-files/MySQL.server /etc/rc.d/init.d/MySQLd

# chown root:root /etc/rc.d/init.d/MySQLd

# chmod 755 /etc/rc.d/init.d/MySQLd

# chkconfig --add MySQLd

# chkconfig --level 3 5 MySQLd on

# cp ./support-files/my-huge.cnf /etc/my.cnf

# mv /usr/local/MySQL/data /var/lib/MySQL

# chown -R MySQL:MySQL /var/lib/MySQL/

# vi /etc/my.cnf

修改以下内容：

(1) 在 [MySQL] 段增加一行：

default-character-set = GBK | latin1 | utf8 | BIG5

(2) 在 [MySQLd] 段增加或修改：

将 log-bin 注释

# bin/MySQLadmin -u root password 'password_for_root'

3. 编译安装Apache

# cd /usr/local/src

# tar xjvf httpd-2.2.6.tar.bz2

# cd httpd-2.2.6

# ./configure \

"--prefix=/usr/local/apache2" \

"--with-included-apr" \

"--enable-so" \

"--enable-deflate=shared" \

"--enable-expires=shared" \

"--enable-rewrite=shared" \

"--enable-static-support" \

"--disable-userdir"

# make

# make install

# echo '/usr/local/apache2/bin/apachectl start ' >> /etc/rc.local

4. 编译安装PHP

# cd /usr/local/src

# tar xjvf php-5.2.4.tar.bz2

# cd php-5.2.4

# ./configure \

"--prefix=/usr/local/php" \

"--with-apxs2=/usr/local/apache2/bin/apxs" \

"--with-config-file-path=/usr/local/php/etc" \

"--with-MySQL=/usr/local/MySQL" \

"--with-libxml-dir=/usr/local/libxml2" \

"--with-gd=/usr/local/gd2" \

"--with-jpeg-dir" \

"--with-png-dir" \

"--with-bz2" \

"--with-freetype-dir" \

"--with-iconv-dir" \

"--with-zlib-dir " \

"--with-openssl=/usr/local/openssl" \

"--with-mcrypt=/usr/local/libmcrypt" \

"--enable-soap" \

"--enable-gd-native-ttf" \

"--enable-ftp" \

"--enable-mbstring" \

"--enable-exif" \

"--disable-ipv6" \

"--disable-cgi" \

"--disable-cli"

# make

# make install

# mkdir /usr/local/php/etc

# cp php.ini-dist /usr/local/php/etc/php.ini

5. 安装Zend Optimizer

# cd /usr/local/src

# tar xzvf ZendOptimizer-3.3.0-linux-glibc21-i386.tar.gz

# ./ZendOptimizer-3.3.0-linux-glibc21-i386/install.sh

安装Zend Optimizer过程的最后不要选择重启Apache。

6. 整合Apache与PHP

# vi /usr/local/apache2/conf/httpd.conf

找到：

AddType application/x-gzip .gz .tgz

在该行下面添加

AddType application/x-httpd-php .php

找到：

将该行改为

找到：

#Include conf/extra/httpd-mpm.conf

#Include conf/extra/httpd-info.conf

#Include conf/extra/httpd-vhosts.conf

#Include conf/extra/httpd-default.conf

去掉前面的“#”号，取消注释。

注意：以上 4 个扩展配置文件中的设置请按照相关原则进行合理配置！

修改完成后保存退出。

# /usr/local/apache2/bin/apachectl restart

7. 查看确认L.A.M.P环境信息、提升 PHP 安全性

在网站根目录放置 phpinfo.php 脚本，检查phpinfo中的各项信息是否正确。

确认 PHP 能够正常工作后，在 php.ini 中进行设置提升 PHP 安全性。

# vi /etc/php.ini

找到：

disable_functions =

设置为：

四、服务器安全性设置

1. 设置系统防火墙

# vi /usr/local/sbin/fw.sh

将以下脚本命令粘贴到 fw.sh 文件中。

# chmod 755 /usr/local/sbin/fw.sh

# echo '/usr/local/sbin/fw.sh' >> /etc/rc.local

# /usr/local/sbin/fw.sh


UCenter 安装方法详细介绍

安装 —— UCenter 安装方法详细介绍

本教程讲解的是如何全新安装 UCenter 1.5.0。

在安装 UCenter Home、Discuz!、SupeSite、X-Space 等应用的时首先必须先安装 UCenter。目前 UCenter 提供两种挂接方式：MySQL 和 fopen，支持同一台服务器和不同服务器之间的应用挂接，这个是在产品安装过程中由程序自动选择。

一、所需环境要求

操作系统要求

UCenter 具备跨平台特性，可以运行于 UNIX/Linux/FreeBSD 及微软 Windows 等各种操作系统环境下。我们已在软件中针对上述操作系统做了大量的测试和实验，保证 UCenter 可以在上述系统中安全稳定的运行，但您仍然需要做好服务器操作系统级的安全防备措施，例如 Windows 用户需更改 MySQL for Windows 的初始 root 密码，避免跨目录的文件读写；类 Unix 用户需避免使用过于简单的密码，避免跨用户目录的文件读写，做好服务器上其他相关软件（如 Sendmail, ftpd, httpd）等的安全防范，使用较新的软件版本等。如果您租用虚拟主机，一般正规和技术力量较强的虚拟主机提供商会已经做好操作系统的各项准备，用户可不必关注此部分。

推荐使用 UNIX/Linux/FreeBSD 操作系统，不仅完全免费，而且可以获得更好的稳定性和负载能力。如果使用 Windows 系统，推荐 PHP 以 ISAPI（非 CGI）方式安装。

语言及数据库支撑环境要求

可用的 httpd 服务器（如 Apache、 Zeus、IIS 等）

php 4.3.0 及以上

MySQL 4.0 及以上

以上软件除了 httpd 软件有可能需要购买以外，其余均为跨平台的免费软件，推荐使用以上软件的最新稳定版本，不仅拥有更多的功能，而且通常已修复了已知老版本的安全漏洞。

推荐环境软件版本

php 5.0.0 及以上

MySQL 5.0 及以上

关于 Linux 和 Windows 主机上环境搭建的详细教程可以参考 Discuz! 用户手册中安装部分环境搭建的方法：Discuz! 最新用户手册

二、安装可能用到的工具软件

UCenter 开发组尽量使得安装步骤简单方便，但仍然可能会用到一些常用的工具软件。如果您通过网络将 UCenter 软件上传到服务器上，您将可能需要一个 FTP 客户端软件。通过您的服务器 FTP 账号，使用该 FTP 客户端软件将相关文件上传到服务器上。同时您可能需要一个简单的文本文件编辑软件，用以对配置文件进行参数修改，一般操作系统自带的如 Windows 的“记事本”或第三方软件如 UltraEdit 等都能胜任。

PS：UTF-8 编码的程序文件不建议使用 Windows 的“记事本”。

三、UCenter安装详细步骤：（以虚拟空间上安装 UCenter 为例演示）

第一步、在 http: //www.comsenz.com/downloads#down_ucenter下载适合自己的版本。

首先到 http: //www.comsenz.com/downloads#down_ucenter 下载所需版本的 UCenter 到本地或服务器。

在这里要说明一下：我们提供了 4 种不同的编码。包括 GBK 简体中文版(推荐)、UTF-8 简体中文版、BIG5 繁体中文版(推荐)、UTF-8 繁体中文版，请自己的需求选择相应版本的论坛程序下载。

第二步、解压并上传论坛程序到服务器上并且修改相应目录权限。

1、上传 UCenter 的程序到服务器上

本次演示以 GBK 版本为例下载到本地，解压缩后得到如下图所示文件：

upload：这个目录下面的所有文件是我们需要上传到服务器上的可用程序文件；

readme：目录为产品介绍、授权、安装、升级、转换以及版本更新日志说明；

utilities 目录为论坛附带工具，包括升级程序；

advanced：目录为如何开发其他应用接口的范例和说明文档。

将其中 upload 目录下的所有文件使用 FTP 软件上传到空间，如下图所示：

注：虚拟主机上传文件请一定使用二进制方式上传，独立主机直接在服务器上下载解压缩即可。

几种常见的 FTP 软件的二进制设置说明：http: //faq.comsenz.com/?action-viewnews-itemid-373

关于安装目录，以虚拟主机为例，比如您可以在根目录下新建名为 ucenter 或者 uc 的目录用来安装 UCenter ；在根目录下新建名为 bbs 的目录用来安装 Discuz! 7.0.0 ；在根目录下新建名为 supesite 的目录用来安装 SupeSite；安装其他应用类似可以这样在根目录新建个目录安装即可。

注意：不要把 UCenter 和 Discuz! 或者其他应用安装在同一个目录下。

2、设置相关的目录属性，以便数据文件可以被程序正确读写

使用 FTP 软件登录您的服务器，将服务器上以下目录、以及该目录下面的所有文件的属性设置为 777，Win 主机请设置 internet 来宾帐户可读写属性。

./data

./data/avatar

./data/backup

./data/cache

./data/logs

./data/tmp

./data/view

./data/config.inc.php

关于目录权限更详细的修改方法请参考：文件权限修改方法

第三步、安装过程

上传完毕后，在浏览器中运行安装程序（http://www.domain.com/ucenter/install）进入准备安装页面，如下图所示：

上图中阅读授权协议后点击“我同意”就进入到下面的环境检查和文件权限目录检查页面，如下图所示：

检查配置过关后点击“下一步”进入数据库信息配置页面，如下图所示：

注：如果是虚拟主机用户，数据库用户名和密码一般是由虚拟主机空间商提供；如果是独立主机，数据库用户名和密码就是你安装 MySQL 时填写的用户名（一般为 root）和密码（建议新建个数据库用户安装，使用 root 会有安全问题）。填写好数据库信息、创始人密码。点击“下一步”进入安装数据库页面，如下图所示：

数据库安装完毕点击“安装用户中心成功，点击进入下一步”则自此 UCenter 安装完毕，进入 UCenter 后台登录界面，如下图所示：

输入密码后点击“登录”进入到 UCenter 的后台，如下图所示：

安装完 UCenter 后我们就可以开始安装 UCenter home、Discuz!、SupeSite、X-Space 等应用了。

UCenter 后台 => 应用管理，如下图所示：

上图界面中选择“URL安装（推荐）”，填写好“应用的安装的URL”就可以开始安装各个应用了。

具体安装方法如下：

UCenter Home 安装方法详细介绍

Discuz! 7.0.0 图文安装教程


UCHome 安装方法详细介绍

安装 —— UCHome 安装方法详细介绍

本教程为大家介绍 UCenter Home 1.5 的安装方法（以虚拟主机为例）。在安装 UCenter Home 1.5 之前，请确认在服务器上已经安装过 UCenter ，UCenter 的安装方法请参考：UCenter 安装方法详细介绍

注意：您所安装的 UCenter Home 1.5 程序的字符集版本必须要和已经安装好的 UCenter 的字符集编码一致。

一、安装前的准备

1、下载 UCenter Home 1.5 程序包到本地，下载地址为：http://www.comsenz.com/downloads#down_uchome

下载解压缩之后如下图所示：

2、上传 upload 文件夹里的所有程序文件到服务器，如下图所示：

注：虚拟主机上传文件请一定使用二进制方式上传，独立主机直接在服务器上下载解压缩即可。

几种常见的 FTP 软件的二进制设置说明：http: //faq.comsenz.com/?action-viewnews-itemid-373

3、重命名 config.new.php 为 config.php

4、修改文件和目录属性

如果您的主机为 *nix 操作系统，请设置如下文件夹权限改为 777，Windows 主机设置 Internet 来宾帐号可读写的权限。

attachment

data

data/*.*

uc_client/date

config.php (安装完毕 777 取消)

如果你对修复文件属性不太明确，请参考更详细的教程：文件权限修改方法

二、开始安装

1、进入 UCenter 后台 => 应用管理 => 添加新应用，如下图所示：

选择安装方式：使用 URL 安装

应用程序安装地址：输入http://***.com/install /index.php

注意：***.com 是您的 UCenter Home 域名，见下图，我的 UCenter Home 的域名为 http://www.hellensu.com。

点击安装，开始安装 UCenter Home 1.5

安装界面如下图所示：

接受授权协议，开始安装 UCenter Home

2、填写 UCenter 的 URL 访问地址和创始人密码，创始人密码是您在安装 UCenter 时设置的。

提交配置信息。

3、进入下一步

说明：

数据库服务器本地地址：一般为 localhost 或者填写数据库服务器的 IP 地址。

数据库用户名：是指有权操作 UCenter Home 数据库的用户。

数据库密码：是指安装 UCenter Home 的数据库密码。

数据库字符集：这里选择 gbk ，这里的字符集要和程序的字符集以及 UCenter 的字符集保持一致。

数据库名：是指安装 UCenter Home 的数据库名称。

表名前缀：默认为 uchome_ ，也可以自定义填写，强烈建议使用默认配置。

填写完毕，提交进入下一步

继续下一步，至到最后一步。

4、输入用户名和密码，系统将这个用户名设为 UCenter Home 管理员，并开通管理员空间。

5、安装完成

三、后期操作

1、点击进入我的空间，效果如下图所示：

2、点击进入管理平台，输入管理员密码可以进入后台进行管理。

3、一切运行正常，删除 UCenter Home 目录下的 install 文件夹。

4、取消 config.php 文件 777 的权限。


任意版本升级到 UCHome 1.5 升级方法

安装 —— 任意版本升级到 UCHome 1.5 升级方法

UCenter Home 1.5 正式版为开源产品，升级之前请注意首先要将 UCenter 升级到 1.5.0 版本，UCenter 1.0.0 到 UCenter 1.5.0 图文升级教程。

本教程以虚拟主机为例为大家介绍任意版本到 UCenter Home 1.5 正式版升级方法。

一、备份数据

1、备份 UCenter Home 数据，请到 UCenter Home 的管理中心，点击“高级应用”里的“数据备份”，在此备份 UCenter Home 数据。如下图所示：

2、备份用户数据，到 UCenter 后台，点击“数据备份”，在此备份 UCenter 的数据。

同时您也可以利用 phpMyAdmin 来备份数据。

phpMyAdmin 备份数据的方法请参考：http: //www.discuz.net/thread-900419-1-1.html

二、上传新的程序

请到 http: //www.comsenz.com/downloads#down_uchome 下载 UCenter Home 1.5 的程序，解压如下图所示：

通过 FTP 软件上传新的 UCenter Home 程序，这里要求 upload 文件夹下除 config.new.php、 install 目录外，其他程序全部上传并覆盖原有文件。

注：虚拟主机上传文件请一定使用二进制方式上传，独立主机直接在服务器上下载解压缩即可。

几种常见的 FTP 软件的二进制设置说明：http://faq.comsenz.com/?action-viewnews-itemid-373

三、运行升级程序

将 update 目录中的 update.php 上传到根目录，并在浏览器运行。即如果你的 UCenter Home 访问地址为 http://www.domain.com，则运行 http://www.domain.com/update.php，如下图所示：

升级全自动完成，点击升级开始即可，如下图所示：

自此，UCenter Home 升级完毕！

升级完毕后，请删除 /update.php 以及 ./data/tpl_cache/ 目录下面的所有模板缓存文件。


后台使用

UCHome 站长后台使用

  • 基本设置
  • 批量管理
  • 高级应用


基本设置

UCHome 后台 — 基本设置

基本设置是针对 UCenter Home 系统的一些全局配置开关，包括下面的几项设置：

站点设置：对站点的一些全局设置，包括 基本设置、注册显示、系统功能、系统功能、上传图片设置、远程上传设置 和 邮件设置。

隐私设置：包括系统开放程度——可以根据自己的需求，决定系统的内容开放程度；新用户默认隐私设置——新用户将采用站内的默认隐私设置，用户可以修改自己的隐私设置；默认动态发布设置——设置系统默认将哪些动作发布到个人动态里面，用户可以修改这些默认设置。

防灌水设置：通过添加验证码、验证问答、自定义登录/注册识别名等来增加对灌水机的干扰，避免大量垃圾广告信息的产生。

随便看看设置：设置相应模块的取值条件，以及设置随便看看条件。会员可以通过点击随便看看，来看其他会员都做了些什么。

用户组：UCenter Home 的用户组的功能是将 UCenter 中的用户在 UCerter Home 系统中进行权限划分。UCenter Home 的用户组从类型上分为：普通用户组、特殊用户组、系统用户组。

积分规则：UCenter Home 的积分规则比较简单，主要有设置增加积分操作和减少积分操作。

用户栏目：用户栏目功能用于丰富已有的个人资料，站长可以根据自身的需要进行设置。

群组栏目：群组栏目实际就是一个群组的分类，用户可以在已设定的群组栏目分类下，创建自己的新群组。

选吧栏目：选吧，就是自己选择的志同道合的交流圈。在吧内，不仅可以结识与你有相同选择的朋友，更可以一起交流话题。网站管理人员可以根据网站的性质，设定好选吧的栏目，供会员选择加入。

广告设置：UCenter Home 系统内置多种广告位，为各位站长添加和管理广告带来便利，并且允许站长根据自身需求自定义广告列表。

全局动态：全局动态出现在站内任何一个成员的好友动态里面，每个成员都能第一时间看到。站长可以灵活使用全局动态来发布一些公开的信息。

MYOP应用：Manyou Open Platform（Manyou 开放平台 /MYOP）服务是由 Comsenz 公司为应用开发者提供的开放平台。

UCenter应用：将挂接到 UCenter 内的应用在 UCHome 前台页面聚合起来的设置。


站点设置

UCHome 后台 — 基本设置 — 站点设置

基本设置：包括站点名称、站点访问 URL 地址、站点 LOGO、站点模板的选择、站点关闭与否的选择等等一些最基本的全局设置。

注册显示：控制跟注册相关的各项设置，包括站点是否开放新用户注册、是否开启邀请注册功能、列表最大分页数、动态保留天数等等注册和显示方面的设置。

系统功能：关于系统的全局功能设置，包括站点默认好友用户和好友用户组个数、模块缓存、二级域名功能等设置。

实名认证设置：关于实名认证的具体设置，包括是否开启实名认证、未认证实名权限、实名是否需手动认证、认证实名可否再修改。

上传图片设置：关于上传图片的相关设置，包括预览缩略图大小、图片最大尺寸、是否开启图片水印和水印的具体设置等。

远程上传设置：关于远程附件的相关设置，包括是否开启远程附件、是否启用 SSL 连接、FTP 连接的具体信息等设置。

邮件设置：配置系统邮件设置，包括邮件发送方式、邮件头的分隔符、收件人是否显示用户名等设置。


基本设置

基本设置 —— 站点设置 —— 基本设置

UCenter Home 后台 => 基本设置 => 站点设置：

站点设置里包括七个方面的设置，分别是基本设置、注册显示、系统功能、实名认证设置、上传图片设置、远程上传设置和邮件设置。下面说明基本设置。

UCenter Home 后台 => 基本设置 => 站点设置 => 基本设置：

详细说明：

站点名称：是指站点的名字，如我的空间，这里的名称会显示在浏览器的标题处，如下图所示：

站点访问 URL 地址：这里一定要填写正确，站点地址末尾要加“/” ，如果这里设置错误，开启二级域名功能的话将无法正常使用。

站点LOGO：这里填写 LOGO 图片的地址。

站点模板：默认有三套模板供站长选择。

站点联系邮箱：填写可以联系到站长的邮箱地址，作用是当用户点页面底部的“联系我们”可以给站长发邮件。

站点时区：默认是 8 ，这里可以根据自己服务器所在地区的实际情况来填写。

显示授权信息链接：选择“是”，如果您购买了商业授权，点这里可以查看。

显示程序执行信息：是指是否显示程序执行的信息情况，从这里可以看出站点的速度。

ICP/IP/域名备案：填写站点的备案信息，效果如下图所示：

强制使用默认字符集：一般页面出现乱码了，可以使用这个功能。

URL Rewrite：选择“是”，开启 Rewrite 功能，同时服务器也要配置，详细的可以参考这里的教程：

如何在IIS环境下配置 Rewrite 规则：http://faq.comsenz.com/viewnews-11

如何在Apache环境下配置 Rewrite 规则：http://faq.comsenz.com/viewnews-12

记录在线时间：即用户的在线时间，超过这个时间没有动作显示为离线。

用户头像体系：这个功能可以让用户的头像他为两套。虚拟和真实头像体系，这里选择“使用真实头像体系”那么论坛等其它应用的头像将和 UCenter Home 的头像分开。

UCenter 的物理路径：默认留空即可，当 UCenter Home 连接不到 UCenter 的时候可以在这里填写物理路径，如：UCenter 已经升级到 1.5 正式版本，升级 UCenter Home 的时候还提示 UCenter 没升级的情况。

MYOP 的 IP：默认留空即可，如果您的服务器因 DNS 解析问题无法使用 MYOP 服务的时候，这里需要填写 MYOP 的 IP 地址。

站点关闭访问：选择“是”，站点将关闭访问，管理员不受此限制。

站点关闭说明：填写站点关闭的理由，用户访问站点的时候将会看到。

举报可选理由：填写当用户举报日志等信息的时候，可以选择的理由，每行一个理由。

当会员举报的时候，显示效果为：


注册显示

基本设置 —— 站点设置 —— 注册显示

UCenter Home 后台 => 基本设置 => 站点设置 => 注册显示

详细说明：

关闭新用户注册：选择“是”，新用户将不能直接注册。

关闭邀请注册功能：选择“是“将关闭邀请注册，如果想实现不允许会员直接注册，只开启邀请注册，那么这里关闭新用户注册选择“是”，关闭邀请注册功能选择“否”同时其它应用也要关闭直接注册。

注册服务条款：这里填写站长注册的服务条款。

列表最大分页数：允许用户查看的最大分页数。

动态保留天数：个人动态的保留天数。超过该天数的个人动态会被清理掉。

首页动态一页显示数：即首页的动态一页显示的数量。如每页显示 50 条 feed 。

首页动态默认显示设置： 这里设置好友数小于多少个的时候显示所有人的动态，超过这个数值显示好友动态。

同时设置首页默认显示哪种类型的动态。如下图所示：

注意：（本设置需开启MYOP服务才有效）

未安装应用的动态数：设置用户没有安装的应用产生的 feed 出现在该用户首页动态里面的最大个数，以避免对其带来太多信息噪音。设置的数量最小为1个。

动态链接打开模式：分为新窗口打开和在同一窗口打开。

记录动态阅读状态：选择“是”，该条动态被点击的时候，会变成灰色，以表示已经阅读。

禁止 MYOP 的更新提示：开启 manyou 功能后，当站点有了新的信息的时候 MYOP 会自动提示给管理员。

如何开启 manyou 功能请参考：http://faq.comsenz.com/viewnews-390

热门成员推荐：这里填写站长推荐的会员，多个之间用半角逗号","分割，会在随便看看页面显示，为空则不显示。如下图所示：

外部链接显示导航条：选择“是”，访问如论坛等其它应用的时候，连接地址是这样的：http://hellensu.com/link.php?url=http://www.hellensu.com%2Fbbs，如果不想以这种方式显示，这里选择“否”即可。

星星积分阀值：当用户积分数到此阀值时，增加一个星星。最小为2，否则此功能无效，不显示星星数。


系统功能

基本设置 —— 站点设置 —— 系统功能

UCenter Home 后台 => 基本设置 => 站点设置 => 系统功能

详细说明：

站点默认好友用户：在这里填写用户名，这些用户会自动将新注册用户添加为好友，并向其打个招呼。

注意：

1、指定的这几位用户浏览自己的首页时，可能会因其好友数众多而增加服务器负载。

2、从其它应用（如论坛）注册的用户，将不能自动将新注册用户添加为好友。

好友用户组个数：这里默认为 8 个用户组，如果想让会员有更多的用户组，可以修改为大于 8 的数字。登录后在好友里可以看到分组名，同时点小铅笔的图标可以修改分组名。如下图所示：

日志单次导入最大数：每次导入日志的最大数。比如一次导入 100 条日志，这里就填写 100。

邮件通知更新天数：指多少天没登录站点的用户，邮件的方式提醒。（设置邮件功能后有效）

设置为0，则不启用邮件通知功能，开启这个功能会轻微增加服务器负载。

UCenter应用标签相关信息：选择“是”则系统会通过 UCenter，获取到站内其他应用的标签相关信息否则，只显示本站内的标签相关日志。

缓存更新间隔：是指设置标签关联信息多长时间更新一次，建议设置 1 小时（3600 秒）以上，减轻对服务器的压力。为 0 则不更新。

模块缓存：推荐开启，这样在使用模块调用数据的时候，可以大幅度降低 MySQL 服务器负载。

缓存模式：分为存储到文本和存储到数据库。

分表（或目录）越多效率越高，但建立的数据表（或目录）越多。

二级域名功能：开启这个功能，会员将可以设置属于自己的个性二级域名，可以参考这个教程来设置：http://faq.comsenz.com/viewnews-327


实名认证设置

基本设置 —— 站点设置 —— 实名认证设置

UCenter Home 后台 => 基本设置 => 站点设置 => 实名认证设置

详细说明：

开启实名：如果是想用实名的站长，这里选择“是”。

如果开启了实名，那么可以在这里设置，不填写实名的会员即使注册了也无法进行相关的操作，这样也减少了垃圾信息的产生。

实名需手工认证：用户填写实名后，是需要站长手工认证，还是自动认证。

认证实名可再修改：指填写实名手，是否可以进行修改。选择“是”即可以如下图所示：

未认证实名权限：即没有通过实名认证的用户所拥有的权限。

可以全部选择“否”那么会员不通过认证不能进行上述的操作。


上传图片设置

基本设置 —— 站点设置 —— 上传图片设置

UCenter Home 后台 => 基本设置 => 站点设置 => 上传图片设置

详细说明：

预览缩略图大小：可以限制图片缩略图的显示大小，比如上传尺寸为 1024*768 的图片，这里可以限制预览缩略图显示大小

如这里设置为 100*100 ，那么显示效果如下图所示：

图片最大尺寸：这里可以限制上传图片的尺寸，如果用户上传一些尺寸很大的数码图片，则程序会按照本设置进行缩小该图片并显示，比如可以设置为 宽：600 px，高：600 px。但都不能小于300px。设置为 0，则不做任何处理。

注意：这里需要 PHP 环境支持 GD 才生效。

图片水印：选择“是”开启图片水印功能，这里也需要 PHP 环境支持 GD 才生效。

水印图片地址：这里可以填写指定的图片路径，默认为 image/watermark.png，只支持 JPG/GIF/PNG 格式，推荐用透明的 png 图片。

水印位置：分为顶端居左、顶端居右、底端居左、底端居右。以底端居右为例，其显示效果如下图所示：


远程上传设置

基本设置 —— 站点设置 —— 远程上传设置

说明：UCenter Home 的远程附件功能，主要是通过远程上传附件将一部分附件上传到 Web 空间以外的其他服务器或空间上，其作用主要有以下三个方面：

（1）减少服务器流量

（2）减轻服务器负载

（3）节约 Web 空间

1、设置方法

UCenter Home 后台 => 基本设置 => 站点设置 => 远程上传设置

如下图所示：

2、注意事项

1、确保 FTP 服务器地址、端口号、帐号及密码的正确。

2、被动模式（pasv）链接：一般情况下非被动模式即可，如果存在上传失败问题，可尝试打开此设置。

3、远程附件目录：远程附件目录的绝对路径或相对于 FTP 主目录的相对路径，结尾不要加斜杠“/”，“.”表示 FTP 主目录。

举例：我用的是虚拟主机，想把远程附件上传到 uchome/attchments 下面，那么我在这里可以填 ./uchome/attachments

4、远程访问 URL：支持 HTTP 和 FTP 协议，结尾要加斜杠“/”；如果使用 FTP 协议，FTP 服务器必需支持 PASV 模式。

举例：http://www.domain.com/uchome/attachments （其中 http://www.domain.com/uchome 为用于存放远程附件的 FTP 空间的访问地址，attachments 为存放远程附件的目录）

3、测试是否成功

回到 UCenter Home 主页，发表日志然后上传一个附件图片，然后连接 ftp，您会发现在 ./uchome/attachments 目录下多了一个类似日期命名的文件夹如下图所示：

打开里面便是刚刚上传的附件图片如下图所示：


邮件设置

基本设置 —— 站点设置 —— 邮件设置

UCenter Home 的邮件功能，对于站长来说是相当重要的，如果用户忘记密码，可以通过邮件直接取回，比较方便，下面为大家仔细讲解如何设置邮件功能。

一、UCenter Home 支持如下三种邮件发送方式

1、通过 PHP 函数的 sendmail 发送(推荐此方式)

这种方式是使用 PHP 的函数发送邮件，需要服务器上安装邮件系统，一般的虚拟主机都内置邮件系统，因此推荐使用这种方式。

2、通过 SOCKET 连接 SMTP 服务器发送（支持 ESMTP 验证）

这种方式适用于 Windows 或者 Linux 类服务器使用（适合于虚拟主机或者独立主机使用），并且支持 ESMTP 验证。需要站长拥有一个 SMTP 服务器，例如 Foxmail 的 SMTP 服务器。

3、通过 PHP 函数 SMTP 发送 Email（仅 Windows 主机下有效, 不支持 ESMTP 验证）

这种方式仅仅适合于 win 主机，对系统环境要求较高，不推荐使用。用户可以根据自己的情况来选择使用哪一种方式。

二、邮件头的分隔符分为三种

1、使用 LF 作为分隔符（通常为 Unix/Linux 主机）

2、使用 CRLF 作为分隔符（通常为 Windows 主机）

3、使用 CR 作为分隔符（通常为 Mac 主机）

这里根据您使用的邮件服务器系统选择邮件头的分隔符。

三、收件人显示用户名

选择“是”将在收件人的邮件地址显示 UCenter Home 站点的名称。

四、下面我们以第二种邮件发送方式为例详细介绍一下设置邮件功能的整个过程：

1、首先我们需要注册一个邮箱，如 Foxmail 的邮箱，邮箱名为：hellensu@foxmail.com

2、站点创始人登录 UCenter Home 的后台 => 基本设置 => 站点设置 => 邮件设置

3、邮件发送方式选择通过 SOCKET 连接 SMTP 服务器发送,邮件头的分隔符选择使用 CRLF 作为分隔符,然后填写相关 SMTP 服务器信息，如下图所示：

要求身份验证这里建议大家选择“是”。

这样做为站长管理员，我们的邮件功能就设置好了。

五、测试过程

要想知道设置的邮件功能会员是否能正常收到邮件，我们需要测试一下。

1、首先我们需要在自己的 UCenter Home 站点注册一名普通会员，如 （hellen）这里要注意的是，这个会员的 Email 一定是填写正确的。

2、会员登录 UCenter Home 站点 => 设置 => 账号设置，如下图所示：

登录密码：即登录 UCenter Home 站点的用户密码。

真实邮箱：填写你的真实邮箱名。

提交验证后，如下图所示：

这时会收到一封激活邮件

点击邮件中的激活链接，即可激活邮箱

3、会员退出站点，回到站点的登录页面，点击忘记密码，如下图所示：

然后取回密码，如下图所示：

然后您就会收到一封修改密码的邮件。如下图所示：

这样就证明您的邮件设置完成没有问题了。

如果不能正常发送邮件请参考这里的说明：http://www.discuz.net/thread-1156468-1-1.html


隐私设置

基本设置 —— 隐私设置

UCenter Home 是一个可以对用户的隐私信息控制得很好的系统，在“后台 => 基本设置 => 隐私设置”来设置。设置的项目包括：系统开放程度、新用户默认隐私设置、默认动态发布设置。

一、系统开放程度

可以根据自己的需求，决定系统的内容开放程度。如下图所示：

游客开放浏览：设置为“是”，则用户不需要登录也能浏览随便看看、未设置隐私的个人空间，同时，站内的信息也可以被搜索引擎收录。

允许访问的IP列表：只有当用户处于本列表中的 IP 地址时才可以访问站点，列表以外的地址访问将视为 IP 被禁止。每个 IP 一行，既可输入完整地址，也可只输入 IP 开头，例如 "192.168."(不含引号) 可匹配 192.168.0.0～192.168.255.255 范围内的所有地址，留空为所有 IP 均可访问。

禁止访问的IP列表：户处于本列表中的 IP 地址禁止访问站点。每个 IP 一行，既可输入完整地址，也可只输入 IP 开头。

二、新用户默认隐私设置

新用户将采用站内的默认隐私设置。用户可以修改自己的隐私设置。如下图所示：

空间首页：设置个人空间首页的查看权限。分为全站用户可见、仅好友可见、仅自己可见。

个人基本资料：设置个人基本资料的查看权限。分为全站用户可见、仅好友可见、仅自己可见。

好友列表：设置好友列表的查看权限。分为全站用户可见、仅好友可见、仅自己可见。

留言板：设置留言板的查看权限。分为全站用户可见、仅好友可见、仅自己可见。

个人动态：设置个人动态的查看权限。分为全站用户可见、仅好友可见。

记录：设置记录的查看权限。分为全站用户可见、仅好友可见。本隐私设置仅在其他用户查看您主页时有效；在全站的记录列表中可能会出现您的记录。

日志：设置日志的查看权限。分为全站用户可见、仅好友可见。本隐私设置仅在其他用户查看您主页时有效；相关浏览权限需要在每篇日志中单独设置方可完全生效。

相册：设置相册的查看权限。分为全站用户可见、仅好友可见。本隐私设置仅在其他用户查看您主页时有效；相关浏览权限需要在每个相册中单独设置方可完全生效。

分享：设置分享的查看权限。分为全站用户可见、仅好友可见。本隐私设置仅在其他用户查看您主页时有效；在全站的分享列表中可能会出现您的分享。

群组：设置群组的查看权限。分为全站用户可见、仅好友可见、仅自己可见。

三、默认动态发布设置

设置系统默认将哪些动作发布到个人动态里面。用户可以修改这些默认设置。如下图所示：


防灌水设置

基本设置 —— 防灌水设置

说明：您可以选择一些措施，来增加对灌水机的干扰，避免大量垃圾广告信息的产生，但这也会影响到新用户的使用体验。

UCenter Home 首页 => 设置 => 高级管理（输入密码进入后台）=> 基本设置 => 防灌水设置：

1、自定义登录识别名(必须为英文字母)

给登录页面设置个性名，可加大灌水机自动登录的难度，如果有必须要，可以不定期更改一下。

2、自定义注册识别名(必须为英文字母)

给注册页面设置个性名，可加大灌水机自动注册新用户的难度，如果有必须要，可以不定期更改一下。

注意：“自定义登录识别名”和“自定义注册识别名”的内容必须不同，如果填写相同，则会员无法注册。

举例：

如下图所示设置登录识别名和注册识别名：

则设置后的登录页面 URL 如下图所示：

设置后的注册页面 URL 如下图所示：

3、页面开启验证码功能

说明：对发布日志等发布操作是否开启验证码功能，您需要在用户组管理中，对用户组进行不同的开启设置。

选择在“登录页面”或在“注册页面”开启验证码，多选，两者都选择开启或者只开启一个都可以。

4、验证码采用个性提问模式

验证码采用个性提问模式有两种：“是，使用我自定义的问答（推荐，效果好）”、“否，使用系统验证码图片 ”。

“是，使用我自定义的问答（推荐，效果好）”：选择这种模式则验证码是问答模式，需要管理员在后台提前设置好个性问题和答案，举例如下图所示设置：

效果如下图所示，在注册或者登录的时候需要先回答之前设置好的问题，答对了才可以注册或者登录进去。

“否，使用系统验证码图片 ”：选择这种模式则验证码是验证码图片模式，开启后的效果如下图所示：

5、强制新用户验证激活邮箱

注意：网站必须设置好邮件配置才生效（UCenter Home 后台 => 基本设置 => 站点设置 => 邮件设置），邮件设置教程：

选择是的话，用户必须验证激活自己的邮箱后，才可以进行发布操作。用户收到的激活邮件如下图所示：

6、新用户见习时间（小时）

设置新注册用户必须等待多少小时后才可以发布操作。

7、强制新用户上传头像

选择是的话，用户必须设置自己的头像后才能进行发布操作。

8、强制新用户好友个数

设置用户必须拥有多少个好友后，才可以进行发布操作。

9、其他一些防灌水措施设置

1）您可以在站点设置中，关闭站点注册功能，仅允许好友邀请注册功能。

2）您可以在隐私设置中，关闭游客开放浏览功能。

3）您可以在随便看看设置中，对不同的数据模块的用户组调用条件进行过滤，比如屏蔽最低用户组发布的信息。


随便看看设置

基本设置 —— 随便看看设置

在 UCenter Home 中，会员可以通过点击随便看看，来看其他会员都做了些什么。

管理员可以在后台设置随便看看显示的信息，进入后台，点击 随便看看，如下图所示：

随便看看允许分页：可以设置是否允许列表分页显示信息，打开会增加服务器负担。

数据缓存更新时间：默认为300秒,设为0将不使用缓存机制，并会增加服务器负担。

随便看看有很多模块，可以点击这些模板后面的编辑进行编辑。如下图所示：

以成员为例，点击后面的编辑，如下图所示：

点击“否”，如下图所示：

指定成员uid：过滤指定的uid成员。

制定用户组：过滤指定用户组成员。

建立时间：按照建立时间过滤。

更新时间：按照更新时间过滤。

实名认证：按照是否实名认证过滤。

头像：按照是否上传头像过滤。

空间访问数范围：按照空间访问数过滤。

空间好友数范围：按照空间好友数过滤。

积分范围：按照积分过滤。

成员排序方法：可以根据建立时间、更新时间、空间访问数、空间好友数、积分的递增或者递减过滤。

数据设置：可以设置起始数据行数和显示的数据条数。


用户组

基本设置 —— 用户组

UCenter Home 的所有用户全部来自 UCenter（用户中心），类似的还有 Discuz!、SupeSite、SupeV、ECShop 等其他应用，各个产品应用中的用户，均来自与UCenter，从而实现用户的集中管理，站内同步登录退出。

UCenter Home 的用户组的功能是将 UCenter 中的用户在 UCerter Home 系统中进行权限划分，UCenter Home 的用户组只能将已有的 UCenter 中的会员进行分组并给其划分权限，但是没有添加和删除单个用户在 UCenter 中的记录的功能，所有用户的管理都在 UCenter 后台的用户管理里操作。

下面详细讲解下 UCenter Home 的用户组机制以及如何添加和编辑用户组，进入 UCHome 后台 => 基本设置 => 用户组：

UCenter Home 的用户组机制类似于 Discuz! 的用户组机制，UCenter Home 的用户组从类型上分为：普通用户组、特殊用户组、系统用户组。

一、普通用户组

普通用户组的用户级别，随着其积分的变化而自动升级或者降级。系统默认自带的普通用户组有以下四个：受限会员、普通会员、中级会员、高级会员。如下图所示：

站长可以根据自己的需求添加普通用户组，添加方法如下：

点击上图中左上方的“添加”按钮，进入到如下图所示的界面：

在这里设置该用户组成员对自己的个人空间的操作权限许可。

1、名称：即您要添加的用户组的名称；

2、用户组类型：选择您要添加的用户组的类型，普通用户组还是特殊用户组，系统用户组无法添加；

3、积分下限：成为本用户组的最低积分；

4、用户名显示颜色：设置该用户组的用户名颜色；

5、用户身份识别图标：该用户组的识别图标；

6、上传空间大小：该用户组可以在其空间上传附件的大小，单位为 M，0 为无限；

7、最多好友数：可以添加好友的数量上限；

8、两次发布操作间隔：该用户组的成员发布包括日志/评论/留言/话题/回帖等发布操作的间隔，单位:秒, 0为不限制；

9、发布操作需填验证码

10、两次搜索操作间隔

11、二级域名最短长度：该用户组的成员可以设置二级域名的最短长度限制，0 为禁止使用二级域名，在站点开启二级域名时有效，二级域名可在“站点信息”处开启；

12、发表记录：是否允许发表记录

13、发表日志：是否允许发表日志；

14、上传图片：是否允许上传图片；

15、发布分享：是否允许发布分享；

16、发表留言/评论：是否允许发表留言/评论；

17、创建新群组：是否允许创建新群组

18、发表群组话题：是否允许发表群组话题

19、编辑话题附加编辑记录：是否允许编辑话题附加编辑记录

20、发表群组回帖：是否允许发表群组回帖；

21、允许打招呼：是否允许打招呼；

22、允许加好友：是否允许加好友；

23、允许踩日志：是否允许踩日志；

24、允许自定义 css：是否允许使用自定义 css；

25、日志全 HTML 标签支持：谨慎允许，支持所有 HTML 标签可能会造成站点不安全因素；

26、忽略站点关闭和 IP 屏蔽：选择是则该用户组的成员在站点关闭和其 IP 被屏蔽的时候依旧可以正常登录浏览 UCHome 。

普通用户组的编辑类似于其添加的方法，也就是设置其对个人空间的操作权限许可。

二、特殊用户组

特殊用户组的用户的级别身份，不受积分的影响，始终保持不变。

系统用户组默认自带一个名为“贵宾VIP”的组，站长可以根据自己的需求添加和编辑特殊用户组的权限，特殊用户组的添加和编辑方法类似于普通用户组的添加和编辑方法，这里将不再赘述。

三、系统用户组

系统用户组是由系统内置，用户组不能被编辑或删除；用户级别身份，不受积分的变化的影响。

系统用户组默认自带两个用户组：站点管理员、信息管理员。无法添加其他的系统用户组。

站长可以根据需求编辑这两个系统用户组的管理权限，下图中点击“编辑”即可：

对站点管理员和信息管理员的权限编辑有两个方面：空间权限和管理权限。

1、空间权限

这部分的权限设置类似于添加普通和特殊用户组的时候的权限设置，所以此处不做赘述。

2、管理权限

设置该用户组成员是否拥有站点管理权限，这可能会影响到站点数据安全，请谨慎选择。

可在此设置该系统用户组是否可管理“标签”、“选吧”、“事件”、“迷你博客”、“分享”、“日志”、“相册”、“评论”、“话题”、“站点设置”、“随便看看”、“用户组”、“积分规则”、“用户栏目”、“选吧栏目”、“词语屏蔽”、“广告设置”、“缓存更新”、“标签模板”、“数据调用”、“模板编辑”、“数据备份”、“统计更新”、“计划任务”、“用户空间”操作。

允许管理选择“可管理”，不允许管理选择“禁止”。选择完毕，“提交”即可生效。


积分规则

基本设置 —— 积分规则

给会员增加积分是激励会员积极性和完善网站内容的有效办法。设置发布信息获得积分，可以增加网站内容。同时设置一些操作需要消费积分，也会让会员觉得积分大有用处，从而积极的发布新信息获取新积分。

UCHome 内置了强大的积分奖罚功能，分别分为“增加积分操作”和“减少积分操作”。

后台 => 基本设置 => 积分规则

一、增加积分操作

这里可以设置会员执行了相应的操作后所获得的积分数量。不希望获得积分的操作可以设置为 0 ，如下图所示：

发布日志 -- 可以设置会员新发表一篇日志后获得的积分奖励数量

上传图片 -- 可以设置会员新上传一张图片后获得的积分奖励数量

发布评论/留言 -- 可以设置会员新发表一篇评论或者留言后获得的积分奖励数量

发起话题 -- 可以设置会员新发起一个话题后获得的积分奖励数量

发布回帖 -- 可以设置会员新发布一个回帖后获得的积分奖励数量

邀请好友注册成功 -- 可以设置会员新邀请一个好友，并注册成功后获得的积分奖励数量

二、减少积分操作

这里可以设置会员执行了相应的操作后所减少的积分数量。注意这里不能设置为负数，否则会导致出现积分不减反而增加的情况。如下图所示：

日志被删除 -- 可以设置会员被删除一篇日志后被减去的积分数量

图片被删除 -- 可以设置会员被删除一张图片后被减去的积分数量

评论/留言被删除 -- 可以设置会员被删除一篇评论或者留言后被减去的积分数量

话题被删除 -- 可以设置会员被删除一个话题后被减去的积分数量

回帖被删除 -- 可以设置会员被删除一篇回帖后被减去的积分数量

获取注册邀请码 -- 可以设置会员获取一个邀请码后被减去的积分数量

搜索一次 -- 可以设置会员每进行一次搜索后被减去的积分数量

兑换1M的上传空间 -- 可以设置会员每兑换1M的上传空间后被减去的积分数量

日志导入 -- 可以设置会员每进行一次日志导入后被减去的积分数量

修改一次二级域名 -- 可以设置会员每修改一次二级域名后被减去的积分数量

修改一次真实姓名 -- 可以设置会员每修改一次真实姓名后被减去的积分数量


用户栏目

基本设置 —— 用户栏目

用户栏目功能用于丰富已有的个人资料，详细使用方法请看下面的讲解。

UCenter Home 后台 => 基本设置 => 用户栏目，如下图所示：

点击上图中的“添加”按钮，进入添加用户栏目的界面，如下图所示：

1、栏目名称：是您所要添加的个人资料栏目的名称，比如“星座”。

2、表单类型：是您给此栏目设定的输入方式，有两种选择“文本输入框”和“列表框”两种选择。

“文本输入框”提供给用户自己填写内容；

“列表框”只允许用户选择已经设定好的选项。

3、可填写的最多字符：如果选择输入框可填写的最多字符数，默认为 50 ，范围可选 1~255 。

4、必填：该用户栏目是否为必填项。

5、资料页面隐藏：该用户栏目信息是否在个人空间页面显示。

6、允许搜索：是否允许该用户栏目参与搜索。

7、简单介绍：关于该用户栏目的简单介绍。

8、显示顺序：如果添加了多个用户栏目，可以在这里设置其显示顺序。

我们设置一个名称为“星座”的用户栏目，如下图所示：

进入个人主页页面，如下图所示：

点击上图中的“编辑资料”，可以看到如下图所示界面：

从上图界面中，我们可以看到刚才设置的名称为“星座”的用户栏目选项，在这里选择一个自己的星座后提交即可。

回到自己的个人主页，我们就可以看到添加的名称为“星座”的个人基本资料信息，如下图所示：

用户栏目设置的方法基本如上所述，大家可以根据自身网站的需求，灵活应用这个功能以完善用户的个人资料信息。


群组栏目

基本设置 —— 群组栏目

群组栏目，实际就是一个群组的分类，用户可以在已设定的群组栏目分类下，创建自己的新群组。

下面详细讲解下其使用方法，进入 UCenter Home 后台 => 基本设置 => 群组栏目。

一、浏览

在“浏览”选项卡下，可以看到已存在群组栏目。可以编辑和删除这些群组栏目。点击“编辑”进入群组栏目编辑页面：

这里可以编辑该群组栏目的详细信息，重点介绍下“群组添加表单类型”，在它的下拉菜单中有三种类型可选：“文本输入框”，“单选列表框”，“多选列表框”，这里的设置会决定在该群组栏目下，用户是否可以创建新的自定义群组。只有当该群组栏目选择“文本输入框”时，用户可以输入自定义的群组名称来创建自定义的群组：

注意：群组群主手工指定：选择选择自动，则系统会自动将第一次使用某个群组的用户作为群主。

如果该群组栏目设置为 “单选列表框”或“多选列表框”，用户创建新群组时，只能选择加入该群组栏目下这里已定义的选项的群组，而不能在该群组栏目下自定义创建新的群组，例如自由联盟选择“单选列表框”，并且填入“北京”、“上海”两个选项：

用户创建新群组时，选择自由联盟，只能加入“北京”或“上海”群组，“多选列表框”同理。

二、添加

在“添加”选项卡下，可以添加新的群组栏目。

填写新群组栏目的信息，与上面编辑群组栏目类似。


广告设置

基本设置 —— 广告设置

广告可以对 UCenter Home 进行商业宣传或品牌推广，对论坛发展有一定的推动，可以使用广告获取收益。UCenter Home 后台 => 基本设置 => 广告设置，如图

一、系统内置广告

1、系统内置广告分为七个位置的广告，分别是：页面顶部、页脚、页面主区域上方、页面主区域下方、日志（话题）内容区域、对联广告、动态顶部。如图

1）页面顶部：宽 970 px，显示位置如图

2）页脚：宽 970 px，显示位置如图

3）页面主区域上方：宽 800 px，显示位置如图

4）页面主区域下方：宽 800 px，显示位置如图

5）日志（话题）内容区域：宽 300 px，显示位置如图

6）对联广告：宽 90 px，显示位置如图

7）动态顶部：宽 90 px，显示位置如图

2、UCenter Home 后台 => 基本设置 => 广告设置 => 添加新广告，如图

1）广告标题：后台界面显示的区别。

2）页面位置：可以设置七个位置的广告类型。

3）有效性：分为有效和无效。无效也就是前台不显示。

4）广告方式：方式有代码、Flash 、Image 、文字四种。广告方式可以自己设置按照熟悉的选项进行设置。如图

二、用户自定义广告：可以自由决定广告的显示位置，只需要获取广告代码(模板内嵌代码，或者Javascript代码均可)，然后将广告代码插入到模板任意位置即可显示。如图

1、模板内嵌代码：UCenter Home 后台 => 基本设置 => 广告设置 => 浏览全部广告，页面中可以看到自定义广告的选项，点击“模板内嵌代码”可以获取代码放到站点模板的任意页面的指定位置。如图

2、Javascript 代码：UCenter Home 后台 => 基本设置 => 广告设置 => 浏览全部广告，页面中可以看到自定义广告的选项，点击“Javascript代码”可以获取Javascript代码。如图


全局动态

基本设置 —— 全局动态

全局动态，就是会在站内任何一个成员的好友动态里面都会出现的动态，每个成员都能第一时间看到。站长可以灵活使用全局动态来发布一些公开的信息。

进入方法：登录网站 => 设置 => 高级管理 => 基本设置 => 全局动态，如下图所示：

在此页面您可以浏览、编辑、删除、添加动态信息。下面我们以添加一个新的动态信息为例：点击“发布新动态”按钮来添加新的动态信息，如下图所示：

注意事项：发布日期时间（填写日期时间格式为 2009-01-19 17:52，为空为当前的日期和时间。）

您也可以填写一个将来的日期和时间，那么这条动态会在这个将来的日期到来之前，一直显示在第一位。

确认动态信息无误后点击“提交保存”按钮，添加动态信息完成。在站内任何一个成员的好友动态里面都会出现的动态，每个成员都能第一时间看到。如下图所示：


MYOP 应用

基本设置 —— MYOP 应用

Manyou Open Platform（Manyou 开放平台 /MYOP）服务是由 Comsenz 公司为应用开发者提供的开放平台。

MYOP 被设计为能够满足大容量数据及频繁存取的需要，因此是应用服务器与 UCenter Home 用户网站之间的通信桥梁。MYOP 通过专有 API 与UCenter Home 进行通信，根据应用开发者的需要，调用 UCenter Home 的相应数据，并将其缓存，封装成若干 API 接口，以供应用开发者使用。

一、如何设置应用状态

UCenter Home 后台 => 基本设置 => MYOP 应用

点击这里的开启服务及可开通 Manyou，这样会员注册后，就可以玩游戏了。

启用应用之后，可以看到 Manyou 平台的所有应用，如下图：

如果无法正常开启应用，请查看常见问题：http://www.discuz.net/thread-1044418-1-1.html

在此可以设置应用的状态：默认应用、推荐的应用、开启和关闭应用、应用审核方式以及杂项设置。注意：会员只能使用开启的应用（开启的应用包括：默认应用，推荐的应用和站长手动开启的应用）。

默认应用：无论用户是否安装此应用，默认应用都会显示在所有用户的开始菜单里面。

已关闭的应用：用户不能安装处于关闭状态的应用，前台应用目录中也不会显示处于关闭状态的应用。

推荐的应用：被设置为推荐的应用将显示在您网站应用目录的推荐栏目下。

点击上图的各个选项卡，可以看到不同状态下的应用，如下图“已关闭的应用”

在点里点击“开启应用”可以把应用从关闭状态改为开启状态。

已开启的应用：将显示所有开启的应用。

在开启的应用中，可以设置该应用为默认应用或者设为站长推荐的应用，也可以关闭该应用，默认为 Manyou 推荐。

二、如何设置推荐应用方式

1、打开“已开启的应用”如下图所示：

点击“设为推荐应用”

2、打开“推荐的应用”，点击“修改推荐方式”，如下图所示：

使用 Manyou 推荐：使用此种推荐方式，Manyou 平台推荐的应用将显示在应用目录的推荐栏目下。

使用站长自己推荐：使用此种推荐方式，只有站长手动设置为推荐的应用才会显示在应用目录的推荐栏目下。

站长可以根据自己的需求设置不同的推荐应用方式，一种是由 Manyou 推荐，一种是站长自主推荐。这里以设置为站长自己推荐为例，推荐应用在网站前台显示的位置如下图所示：

三、如何设置应用审核方式

所有官方审核过的应用都会出现在开启 Manyou 的 UCenter Home 网站，站长可以设置是否默认开启应用，打开“应用审核方式”，如下图：

默认开启应用：选择此种审核方式后，默认 Manyou 平台上的全部应用都处于开启状态。您可以关闭某一应用，这样用户就不能看到和使用此应用。

默认关闭应用：选择此种审核方式后，默认 Manyou 平台上的全部应用都处于关闭状态，但是此前有用户安装的应用将自动处于开启状态。您只开启某一应用后用户才可以看到并使用此应用。

四、杂项设置

这里可以设置用户手动添加应用、默认应用自动添加和全部应用自动添加如下图所示

1、用户手动添加应用：选择此种安装方式后，如果用户未添加此应用，使用前需要添加此应用，并设置相应的“应用设置选项”。

2、默认应用自动添加：选择此种安装方式后，“默认应用”将不再要求用户安装便可使用，“非默认应用”仍需用户添加之后才能使用。站长必须为自动添加的应用设置默认的“应用设置选项”。

3、全部应用自动添加：选择此种安装方式后，所有被允许使用的应用将不再要求用户安装便可使用，站长必须为自动添加的应用设置默认的“应用设置选项”。

五、温馨提示

1、如果您的应用审核方式选择“默认关闭”，并且推荐应用方式选择“ Manyou 推荐”，那么将会出现网站前台的推荐列表为空的情况，这时候只有您将应用的推荐方式修改为“使用站长推荐”，您推荐的应用才能生效。

2、如果您的应用审核方式由“默认开启”过渡为“默认关闭”，那么有用户安装的应用，站长推荐的应用，默认应用仍会处于开启状态。

3、如果推荐应用方式选择“ Manyou 推荐”，那么站长自己推荐的应用不会出现在网站前台的推荐列表。

4、网站前台 Manyou 应用列表排序规则：

1）推荐应用列表：

A、推荐应用方式选择“ Manyou 推荐”：按照应用在 Manyou 的安装量倒序排序。

B、推荐应用方式选择“ 站长自己推荐”：按照应用在本站的安装量倒序排序。

2）全部应用列表：

如果按照“热度”排序：

A、选择“默认开启应用”：按照应用在 Manyou 的安装量倒序排序。

B、选择“默认关闭应用”：按照应用在本站的安装量倒序排序。

如果按照“时间”排序：

A、选择“默认开启应用”：按照应用在 Manyou 的审核时间倒序排序。

B、选择“默认关闭应用”：按照站长在站点后台对应用的操作时间倒序排序。


UCenter 应用

基本设置 —— UCenter 应用

UCenter Home 就像 UCenter 中用户的“家”，为使各个用户在“家”就能访问 UCenter 下的其他应用，及方便地看到其他应用中的相关信息，UCenter Home 提供了非常实用的后台设置功能。

使用该设置的前提是您的 UCenter 下不只安装了 UCenter Home，还安装了其他应用，否则您不必关心该功能。下面请看该功能的详细介绍：

一、UCenter Home 后台设置

使用管理员账号登录 UCenter Home 后台 => 基本设置 => UCenter 应用，即可看到下图所示：

1、导航中是否显示：选择“是”，将在 UCenter Home 导航显示该应用的链接，方便用户访问该应用。

2、标签相关显示条数：用户在浏览日志时，将在日志内容的右侧显示该应用下对应条数的内容（该内容与正在浏览的日志有相同的标签）；如果填写 0 ，就是不显示任何该应用的内容。

3、标签单条模板：显示标签相关的模板，可根据需要自己修改。

二、各个应用在 UCenter Home 的前台显示

根据第一步介绍设置后，更新缓存，登录 UCenter Home 前台，即可看到下图所示：

点击上图中的 Discuz! 即可进入论坛。

在 UCenter Home 打开一篇日志，即可看到标签相关，如下图所示：


批量管理

UCHome 后台 — 批量管理

批量管理功能主要是针对“日志”、“相册”、“图片”、“评论”、“话题”、“回帖”、“记录”、“事件”、“分享”、“用户”、“标签”、“群组”、“实名认证”和“举报管理”进行搜索、编辑、合并、锁定、批量删除等操作。

日志：针对日志进行搜索、编辑和批量删除操作。

相册：针对相册进行搜索、管理和批量删除操作。

图片：针对图片进行搜索、管理和批量删除操作。

评论：针对评论进行搜索和批量删除操作。

话题：针对话题进行搜索、批量删除、批量精华和批量置顶操作。

回帖：针对回帖进行搜索和批量删除操作。

记录：针对记录进行搜索和批量删除操作。

事件：针对事件进行搜索和批量删除操作。

分享：针对分享进行搜索和批量删除操作。

标签：针对标签进行搜索、删除、合并等批量操作。

群组：针对群组进行搜索、删除、合并、锁定、开放等批量操作。

用户：针对用户进行搜索、编辑用户权限、设置是否受保护、删除用户等操作。

实名认证：就是用户注册的时候必须填写真实的姓名和个人信息，好比是一个网上身份证，为广大网友提供了一个诚实可信的交流平台。

举报管理：针对用户的举报进行批量管理，比如禁止某个用户举报、删除该举报、还可以删除举报及日志信息。


日志

批量管理 —— 日志

用户在前台发布日志后管理员如何管理这些日志呢？登录 UCHome => 设置 => 高级管理 => 批量管理 => 日志，如下图所示：

这里默认会列出所有用户发布的日志信息，在这里可以批量删除某些日志，或者按照一定的搜索条件进行搜索并进行编辑或者删除管理。

已有的搜索条件有：作者UID、作者名、标题、内容、公开性质、发布IP、指定日志ID、查看数、回复数、发布时间、结果排序。

注意：删除的时候会有一个提示：“本操作不可恢复，确认删除？”选择“确定”则选中的日志被彻底删除，不可恢复。


相册

批量管理 —— 相册

UCHome 为用户提供了方便的上传相册功能，同时也为管理员提供了方便的相册管理功能。

进入后台 => 批量处理 => 相册，如下图所示：

可以根据 相册名、查看权限、相册id、作者uid、作者名、创建时间范围以及排序方式中的一个或者几个搜索出想要的数据。

默认看到所有的相册，可以直接选择相册执行删除。

也可以点击管理图片进入，如下图所示

可以直接选择图片，执行删除操作。

也可以点击评论管理进入，管理该图片的评论内容，如下图所示：

可以直接删除该评论。


图片

批量管理 —— 图片

您或许想对用户发表的图片进行编辑，或图片太多或是不符合要求的情况下，对过期或其他不必要的图片进行删除。UCenter Home 后台提供了方便的图片批量管理功能，可以满足您的这个需求。下面请看详细介绍：

1、图片的搜索

用 UCenter Home 的管理员帐号登录后台，点击页面点击左侧菜单“批量管理”中的图片，即可看到下图所示：

填写搜索条件，点击搜索按钮，即可进行图片的搜索结果。

这里需要注意：如果您想搜索默认相册里的图片，需要在上图中的“所在相册ID”处输入0。

2、图片的删除

在上一步操作中配置搜索条件后，点击“搜索”按钮可以看到下图所示:

在搜索结果所示中，如果需要删除第一个图片请选择第一个图片下方的选择框，然后点击“批量删除”按钮，如下图所示：

点击上图中的“确定”按钮后，在上图中选中的图片已经删除，如下图所示：


评论

批量管理 —— 评论

评论是网站内容的一个重要组成部分，丰富多彩的评论可以让会员的交流更活跃，更积极。

但往往有些心怀恶意的人，对会员发布的信息进行污蔑，造成会员间的不和谐。也有些广告商在评论上发布广告，弄得网站乌烟瘴气的。

所以，必须对评论进行有效的管理。评论管理功能在 UCHome 后台 => 批量管理 => 评论，如下图：

在“评论类型”内，可以选择按照“全部”，“留言”，“日志”，“图片”进行分类显示。

在“评论 ID”内，可以填入评论者的 ID 进行搜索。

在“评论 UID”内，可以填入评论者的 UID 进行搜索。

在“被评论 UID”内，可以填入被评论者的 UID 进行搜索。

在“发布时间”内，可以填入从什么时候到什么时候的时间段进行搜索。注意时间格式为 YYYY-MM-DD，比如 2008-08-08

在“内容”内，可以填入评论的相关内容进行搜索。

在“发布 IP” 内，可以填入评论者的 IP 进行搜索。

在“结果排序”内，可以让结果按照“默认排序”，“评论时间”进行排序显示。选择“递减”或者“递增”可以让结果按照从大到小，或者从小到大进行排序显示。在 每页显示 内，可以选择每页显示多少个评论信息。

用以上方法搜索出来恶意评论或者小广告后，可以勾选相应的评论前门的小方框，对这些信息进行批量删除。如下图：

选中相应信息前面的小方框后，点击“批量删除”即可删除相应内容。如果需要全部选中，这勾选“全选”即可。


回帖

批量管理 —— 回帖

管理员可以对群组中的主题和回帖进行批量管理，以简化管理操作。具体位置为，UCenter Home 管理后台 => 批量管理 => 回帖，进入回帖，如下图所示：

一、下面分别说明一下这里的选项

1、群组ID

因为会员在发表话题或者回帖前，必须要先创建或者加入一个群组。群组ID，就是将要选择群组的 ID 值。

2、话题ID

是指会员在哪个话题回帖的话题 ID 值。

3、作者UID

是指回帖的作者的 UID 值。

4、作者名

是指回帖的用户名。

5、发布时间

这里可以选择一个发布回帖时间的范围，格式为：(YYYY-MM-DD)即年-月-日。

6、内容*

是指回帖的内容。

7、IP

是指回帖人的 IP 地址。

8、是否主题帖

这里可以选择主题帖或者不限制。

9、结果排序

排序有三个选项，如下图所示

分为默认排序和按发布时间排序，同时，还可以选择递增或者递减，如下图所示：

除此之外，还可以选择每页显示的个数，如下图所示：

二、批量管理

设置搜索条件后，点击搜索，页面会显示搜索的结果，如下图所示：

在这里可以直接把选择的主题或者回帖批量删除掉。


话题

批量管理 —— 话题

UCenter Home的管理后台 => 批量管理 => 话题，进入话题以后如下图所示：

一、下面分别说明一下这里的选项

1、群组 ID

因为用户在发表话题前必须要先创建或者加入一个群组，群组 ID ，就是发表的话题在哪个群组里。

2、标题*

是指发表话题时的标题是什么，比如我这里要搜索标题是：“wild 宣言”的所有话题，那么效果如下图所示：

点击搜索结果中的群组名，出现更多操作选项，如下图所示：

3、作者 UID

是指发表话题的作者的 UID 号

4、作者名

是指发表话题的作者

5、发布时间

这里可以选择一个话题发布时间的范围，格式为：(YYYY-MM-DD) 即年-月-日

6、查看数

可以填写话题被查看的数字范围，比如 100-1000

7、是否精华

是指话题是不是被加为精华，这里有三个选项，如下图所示：

8、结果排序

分别有：按默认排序、按发布时间排序、按回复时间排序、按查看数排序、按回复数排序

同时还可以选择递减或者递增，如下图所示：

除此之外还可以选择每页显示的个数，如下图所示：

二、批量管理

1、可以批量删除话题

2、可以把话题批量设置为精华或者取消精华

3、可以批量置顶或者取消置顶


记录

批量管理 —— 记录

UCenter Home 记录可以记录日常的事件并查看同心情的记录，类似于留言板。

UCenter Home 后台 => 批量管理 => 记录，可以对前台发表的记录进行批量删除。

1、搜索：可以按照作者 UID 、作者名、部分记录内容、发表记录的 IP 、发布时间进行搜索，搜索的结果可以设置显示的排序。例如：按照发帖时间、递增、递减、每页显示数进行查看。

2、删除：选择一条或者多条记录前的方框，点击底部的批量删除即可进行删除。


事件

批量管理 —— 事件

事件是 UCenter Home 里比较活跃的元素，在 UCenter Home 的管理中心，可以对所有的事件进行批量的管理。

进入方法：登录 UCenter Home => 设置 => 高级管理 => 批量管理 => 事件，如下图所示：

这里会列出当前 UCenter Home 系统内的所有事件。当然，你也可以根据以上的搜索条件，比如作者 UID，作者名，事件类型，发布时间，来搜索出你要找寻的时间，同时也可以对此搜索结果进行排序以及控制每页显示的个数，这样方便管理员对事件的管理。填写好这些条件之后，点击搜索，可以搜索出想要的结果，如下图所示：

这样管理员就可以对搜索出的事件进行批量删除的管理了。


分享

批量管理 —— 分享

在 UCenter Home 中，用户可以分享自己的所见所闻，如一篇日志，一个视频，一首音乐等。作为站长，您可以在后台管理这些分享，请看下面详细介绍：

登录 UCenter Home 后台 => 批量管理 => 分享，即可看到下图所示：

您可以根据上述条件的填写来搜索对应的日志，下面注重讲解两点：

1、指定分享 ID：您可以指定您需要管理的具体分享 ID，这个 ID 您可以到数据库中查看。

2、事件类型：即这个分享属于那种类型的。网址是 link，视频是 video，音乐是 music，flash 是flash，日志是 blog 等。这个您可以把鼠标移动到相应的分类上，通过来观察浏览器状态栏中的地址来得到。

以“日志”为例，登录 UCenter Home 前台 => 首页 => 分享，把鼠标移动到“日志”，然后观察浏览器的状态栏，如下图所示：

填写好条件后，点击“搜索”，即可显示符合条件的分享，如下图所示：

您可以选中需要删除的分享，点击“批量删除”按钮，即可完成删除。


标签

批量管理 —— 标签

UCenter Home 中的标签是在发布日志时添加的，添加的标签可以在“后台 => 批量管理 => 标签”中管理。如下图所示：

上部粉红色的区域是搜索标签的搜索条件设置区域，可以通过设置标签名、是否锁定、创建时间、关联的日志数、结果的排序规则来搜索出需要查看的标签，并对其进行管理。其中标签的创建时间的时间格式为“YYYY-MM-DD”，即“2009-01-19”这样的格式。

下部则是标签的列表显示区域，显示的是根据上面的搜索条件搜索出的标签的结果列表。列表中显示的日志数表示该标签所关联到的日志的数量。

可以对标签进行的操作有：

删除：将选中的标签彻底删除，并清除标签与日志的关联。

合并到新标签：选中需要合并的标签后，在文本框中填入要合并到的目标标签名即可，目标的标签名可以是不存在的新标签。如下图所示：

锁定：将选中的标签锁定，则是禁止通过标签关联出日志，一个标签被锁定以后，其关联的所有日志记录将被清理。

开放：将锁定的标签重新启用，使其可以重新开始关联日志。


群组

批量管理 —— 群组

在 UCenter Home 家园可以根据不同的兴趣创建不同的群组（例如：“3D动画片爱好者”之类的群组），群组可以使群组成员产生真实的交互，增加网站的活跃度。当群组膨胀或对群组信息进行管理时管理员就可以在后台对群组进行管理。

在 UCenter Home 前台，用户登录后点击“群组”按钮，进入群组管理页面，如下图所示：

在前台群组页面，可以根据不同的兴趣创建群组、查看热门群组、查看群组最新话题、查看/发起我的话题。

在后台管理员可以对群组进行管理，后台进入管理群组页面：登录 UCenter Home => 设置 => 高级管理 => 批量管理 => 群组，如下图所示：

1、上图中的搜索部分，管理员可以根据群组的同步信息对群组进行搜索操作。

2、上图中的群组列表区域，会员在前台创建的所有群组或是对群组搜索的结果都可以展示在这部分区域。管理员可以对群组进行批量的删除、合并群组、锁定和开放操作。点击上图中的“群组管理”，即可进入具体群组的设置页面进行管理。

下面以删除操作为例讲解管理员对群组的批量管理。如下图所示：

选择上图中列表栏中的需要删除的群组名，然后再选择操作栏中一个删除按钮，最后点击“执行操作”按钮即可进行批量删除。如下图所示：

其他的操作栏中的操作类似删除操作，即此省略。


用户

批量管理 —— 用户

当网站注册会员越来越多的时候，站长会希望了解网站注册会员的情况。并向一些经常更新的会员或者贵宾们发去一些节日的问候。

UCenter Home 能对用户进行有效的查看和管理。后台 => 批量管理 => 用户，如下图：

在用户 UID 内，可以填入用户 UID 进行搜索。

在用户名内，可以填入用户名进行搜索。

在姓名内，可以填入姓名进行搜索。

在实名认证内，可以选择搜索的用户是否通过了实名认证。

在头像内，可以选择搜索的用户是否上传了头像。

在用户组内，可以选择要搜索的用户所在的用户组。

在用户积分内，可以填入用户的积分段进行搜索。

在空间创建时间内，可以填入用户的空间创建时间段进行搜索，注意时间格式为 YYYY-MM-DD，比如 2008-08-08

在上次更新时间内，可以填入用户的上次更新时间段进行搜索，注意时间格式为 YYYY-MM-DD，比如 2008-08-08

在结果排序内，可以通过选择按照“默认排序”，“建立时间”，“更新时间”，“访问量”，“积分数”，“好友数”进行“递增”或“递减”排序，并且可以选择每页显示的数量。

这个时候，就可以查看按照需要搜索出来的用户列表了。如下图：

可以根据需要，点击查看该用户的空间，或者看所在的用户组，并且对该用户的资料进行编辑。

这里不仅提供了单个用户编辑，还可以做一些批量操作。如下图

选择通过实名认证，可以对选中的用户进行全部通过实名认证操作。

选择取消实名认证，可以对选中的用户进行全部取消实名认证操作。

选择取消所填姓名，可以对选中的用户进行全部清空姓名的操作。

选择向其打招呼，可以对选中的用户打招呼。如下图：

选择发送邮件通知，可以对选中的会员发送邮件通知。如下图：

选择清空风格背景设置，可以对选中的用户进行全部清空风格背景的设置。


实名认证

批量管理 —— 实名认证

后台管理实名认证功能所在位置：UCenter Home 后台 => 批量管理 => 实名认证

这里可以查看和管理用户的认证情况。

一、如何查看会员的认证情况

要想知道某个会员是否通过实名认证，如下图所示

这里可以根据条件进行搜索。

用户 UID：这里填写用户的 UID 号。

用户名：这里填写用户的注册名称。

姓名：这里填写用户填写的实名名称。

实名认证：这里可以选择不限制、已认证或者未认证。

头像：这里可以选择不限制、已上传头像和未上传头像。

用户组：选择用户所在的用户组或者不限制。

用户积分：填写用户的积分范围。

空间创建时间：用户注册 UCenter Home 的时候范围。比如填写 2008-12-11~2009-1-11

上次更新时间：填写用户最近一次更新时间的范围，时间格式同上。

结果排序：即搜索结果的排序，如下图所示：

同时可以统一查看全部列表（包括已认证和未认证的所有会员）、未认证会员和已认证会员

二、如何管理实名认证

搜索到会员后，点击管理

在该会员的个人资料处可以修改其实名的认证情况。

同时也可以批量通过认证，搜索到未通过认证的会员，批量管理，如下图所示：

可以批量通过实名认证、批量取消实名认证、清空所填姓名和向其打招呼。


举报管理

批量管理 —— 举报管理

通过 UCenter Home 的举报功能，站点会员可以向站长举报违规信息。站长在后台可以看到会员的举报，进行举报信息的处理。该功能加强了站长和会员之间的互动，使得会员更容易的融入到站点的管理中去。下面请看该功能的详细介绍。

一、前台举报

会员在浏览站点内容时，如果发现违规信息，可以向站长举报该信息，比如举报一片日志，如下图所示：

二、后台管理举报信息

当会员向站长举报某些信息后，站长登录后台，可以看到这些举报信息，并对相应的举报和信息进行管理。

1、搜索一定条件下的举报

UCenter Home 后台 => 批量设置 => 举报管理，即可看到下图所示：

可以根据举报的类型，次数及举报现在所处的状态来搜索符合条件的举报，并设置举报的显示顺序。

设置好搜索条件及显示顺序后，点击“搜索”按钮，即可在下方显示出符合条件的举报，站长可以对这些举报进行管理操作。

2、管理举报及举报的信息

UCenter Home 后台 => 批量设置 => 举报管理，站长可以看到现有的待处理的举报，也可以通过上述的搜索来显示符合一定条件的举报，如下图所示：

在此说明几点：

禁止举报：要举报的对象被管理员视为没有违规，以后该对象将不允许会员举报。禁止某举报后，该举报被列入“已忽略举报”。

删除举报：删除该举报，不删除被举报的对象。

删除举报及信息或者空间：删除该举报，并删除举报的对象。

当需要批量操作举报时，可以多选或全选举报，然后选择批量操作，点击“批量操作”按钮即可。


高级应用

UCHome 后台 — 高级应用

缓存更新：更新模板文件、模块数据、系统配置以及随便看看的缓存。

有奖活动：通过有奖活动，您可以实现引导站内的新人更好的完善自己的头像、资料和发表信息；还可以实现在节日期间给用户发送积分；用户定期领取积分红包等各种活动。有奖活动可以带动用户更容易的融入到站内的气氛中来，增加网站的活跃度。

词语屏蔽：为站点设置禁止直接发布的词语，防止会员发布违规信息。

统计更新：如果发现站点某些统计出现问题（比如某些人的日志数有误）时候，就可以使用本功能进行更新统计。统计更新对服务器负载占用严重，建议选择站点访问人数较少的时候进行。

数据调用：数据调用会将站内的数据，通过你编写的查询SQL语句，进行查询并读取出来，生成一段调用代码。你将调用代码(模板内嵌，或者JS调用都可以)放置到站点页面上便可以将相应的查询结果展示给访客了，从而可以实现站内任意数据的显示调用。

系统计划任务：计划任务是每个站点必用到的一个功能，计划任务的作用是通过执行计划任务，使得系统在规定时间自动执行某些特定任务的功能。

数据备份：数据备份是每个系统很重要的一个功能，我们不管是进行升级还是其他一些操作，切记操作之前一定要备份好数据库。UCenter Home 后台的数据备份只可以备份 UCenter Home 的数据。


缓存更新

高级应用 —— 缓存更新

顾名思义，更新 UCenter Home 的缓存文件及有关数据表的数据。在 UCenter Home 的后台 -> 高级应用 -> 缓存更新，提供了四种更新缓存的类型：模板文件缓存、模板数据缓存、系统配置缓存、其他缓存。如下图所示：

一、模板文件缓存

当你通过 FTP 上传或者在线编辑等操作修改了站点模板后，如果显示页面没有及时显示出修改后的效果，你可以通过手工模板缓存操作进行立即更新。

模板文件缓存更新会将 UCenter Home 的 data\tpl_cache 下的缓存文件全部清除掉。

二、模板数据缓存

站点开启模块数据缓存功能后，站点区块显示数据（如最新日志、最新相册等区块数据）都将进行缓存，以大大提高站点访问速度，降低服务器负载。

通常，这些数据缓存会根据各自模块代码设置的更新间隔自动进行更新，不需要人工更新。

如果你想立即更新所有的模块数据缓存，可以选择本选项。

模板数据缓存会将 UCenter Home 的 data\block_cache 下缓存文件及其子目录的缓存文件全部清除掉。

注意：清空数据缓存后，由于站点需要重新生成各个区块缓存，因此会短时间内对服务器带来很大负载，所以请选择访问人数较少的时段进行本操作

三、系统配置缓存

系统配置缓存一般情况下都会在后台修改设定后自动更新，一般不需要手工更新。如果站点运行过程中出现错误，你可以尝试更新本缓存。

系统配置缓存所进行的工作有：

1、更新配置文件缓存。UCenter Home 从数据表 config 中取出各项参数及其值，重新写入 data\data_config.php；从 data 表中取出参数 setting、mail、spam 的值，分别写入 data\data_setting.php、 data\data_mail.php 和 data\spam.php。

2、更新用户组缓存。UCenter Home 从数据表 usergroup 中取出各项参数及其值，重新写入 data\data_usergroup.php。

3、更新用户栏目缓存。UCenter Home 从数据表 profilefield 中取出 fieldid, title, formtype, maxsize, required, invisible, allowsearch, choice 及其值，重新写入 data\data_profilefield.php。

4、更新群组栏目缓存。UCenter Home 从数据表 profield 中取出 fieldid, title, formtype, inputnum, mtagminnum, manualmoderator, manualmember 及其值，重新写入 data\data_profield.php。

5、更新词语屏蔽。UCenter Home 从 data 表中取出参数 censor 的值，分别写入 data\data_censor.php。

6、更新模块。UCenter Home 从数据表 block 中取出 fbid, cachetime 及其值，重新写入 data\data_block.php。

四、其他缓存

包括随便看看的数据缓存、默认应用的缓存、首页的数据缓存等。

首先，UCenter Home 清除随便看看的缓存文件 data/data_network.php；

然后，UCenter Home 将 data 表的 dateline 字段置为 0；

最后，更新 MYOP 默认应用，即 UCenter Home 从 myapp 表中取出各项参数及其值，分别写入 data\data_userapp.php。


有奖活动

高级应用 —— 有奖活动

通过有奖活动，您可以实现引导站内的新人更好的完善自己的头像、资料和发表信息；还可以实现在节日期间给用户发送积分；用户定期领取积分红包等各种活动。有奖活动可以带动用户更容易的融入到站内的气氛中来，增加网站的活跃度。

进入方法：登录 UCenter Home => 设置 => 高级管理 => 高级应用 => 有奖活动，如下图所示：

在此页面您可以浏览、添加、删除、编辑有奖活动。下面以添加有奖活动为例来进行说明。点击上图中的添加按钮进入添加有奖活动的页面，如下图所示：

1、有奖活动名

给添加的活动设置一个活动名称。

2、有奖活动图片

输入有奖活动图片的 URL 地址，不要太大，建议长 60px，宽 60px 的小图片 。

图片地址支持本地图片地址即服务器的相对地址，有奖活动的图片需要上传到服务器上的 UCenter Home 目录下的 image/task/ 目录下，如下图所示：

外部图片地址，如下图所示：

3、有奖活动说明

有奖活动的详细描述信息。PS：有奖活动说明支持 html 代码，文字换行请使用
标签。

4、有奖活动奖励积分

设置用户完成该有奖活动后可以获得的积分奖励。为 0，则不奖励积分。

5、有奖活动完成数限制

设置该有奖活动最多可完成多少人次。超过该人次后，该有奖活动将自动失效。为0，则不限制。

6、有奖活动处理 PHP 脚本

不能包含路径，程序脚本必须存放于 ./source/task/ 目录中

请参考系统自带的有奖活动脚本 ./source/task/sample.php 中的说明来编写。

本功能为高级应用，有奖活动脚本的编写，需要您懂一定PHP知识。邮件活动处理 PHP 脚本的存放地址如下图所示：

7、有效性

通过此项参数可以设置有奖活动是否有效或是无效。

8、开始日期

设置该有奖活动开始的日期。为空为立即开始。

PS：格式：2008-08-08 00:00:00

9、结束日期

设置该有奖活动结束的日期。为空为永久有效。

PS：格式：2008-08-08 00:00:00

10、用户重复执行周期

设置允许用户多长时间后可以重新执行该有奖活动。为0，则只允许用户执行一次。

PS：单位：秒，1小时为3600，1天为86400

11、优先顺序

有多项有奖活动时需要设置优先顺序。数字越小，排序越靠前，优先级越高。

有奖活动添加完毕并且设置为有效、优先级最高的话，在 UCHome 首页就可以查看所添加了有奖活动了。如下图所示：

PS：首页只显示优先级最高的有奖活动。点击有奖活动后就可以查看其他的有奖活动。


词语屏蔽

高级应用 —— 词语屏蔽

UCenter Home 后台 => 高级应用 => 词语屏蔽，主要针对前台发布的日志、回帖、记录等。可以是对不良词语进行禁止或者替换。

1、添加格式：每行一组过滤词语；不良词语和替换词语之间使用“=”进行分割；如需禁止发布包含某个词语的文字，而不是替换过滤，请将其对应的替换内容设置为 {BANNED} 即可；替换前的内容可以使用限定符 x 以限定相邻两字符间可忽略的文字，x 是忽略字符的个数；如 "a{1}s{2}s"(不含引号) 可以过滤 "ass" 也可过滤 "axsxs" 和 "axsxxs" 等等。

例如：

toobad=** (作用:将toobad文字替换为**)

badword=good (作用:将badword文字替换为good)

sexword={BANNED} (作用:禁止发布包含sexword词语的文字)

2、在前台显示结果

1）替换的词语在发表后的效果；

2）禁止发布的词语在发布时的效果；

点击发表后的提示：


统计更新

高级应用 —— 统计更新

如果发现站点某些统计出现问题（比如某些人的日志数有误）时候，才使用本功能进行重新统计。

注意：重新统计对服务器负载占用严重，建议选择站点访问人数较少的时候进行。

登录 UCenter Home => 设置 => 高级管理 => 高级应用 => 统计更新，如下图所示：

选择更新统计数类型有以下几种：

日志回复数

空间好友数

空间好友缓存

群组成员数

话题回复数

相册图片数

标签日志数

每次处理个数：默认为 10 ，建议不要设置的太慢，以免服务器负载太重。


数据调用

高级应用 —— 数据调用

UCenter Home 中的数据调用，会将站内的数据，通过你编写的查询 SQL 语句，进行查询并读取出来，生成一段调用代码。你将调用代码(模板内嵌，或者 JS 调用都可以)放置到站点页面上便可以将相应的查询结果展示给访客了，从而可以实现站内任意数据的显示调用。

添加数据调用的位置在 UCenter Home 后台 => 高级应用 => 数据调用，如下图所示：

一、添加数据调用

点击上图中的“添加”，出现数据调用的设置界面，如下图所示：

上图中顶部的选项卡表示可以添加对那种数据的调用，其中包括：日志、相册、话题、动态、用户、照片、群组，如果这些默认的数据调用项目不能满足您的需求，还可以选择“手写 SQL”一项。

日志、相册、话题、动态、用户、照片、群组，这些项目为默认项目，出现的设置界面均包括两部分：模块名称和过滤设置。

模块名称：为必填项，仅用于在后台数据调用列表中区别添加的不同调用。

过滤设置：为非必填项，不同的项目会出现不同的过滤设置，这些过滤设置用于在数据调用中对查询出来的数据进行过滤，显示的数据为符合过滤设置的数据。在这里设置了过滤的规则以后，便会根据设置的规则生成对应的 SQL 查询语句，用于添加数据调用的下一步。

手写 SQL 一项与上面几项相似，也有模块名称，但是没有过滤设置，取而代之的是“数据调用 SQL ”一项，该项为必填项，需要填写一个 SQL 语句。所以上面默认的几个项目中的过滤设置，目的就是辅助您生成一个这里需要的 SQL 语句了，所以在手写 SQL 一项中就需要您手写这个 SQL 语句了。本功能需要你掌握一定的 SQL 编写知识，而且本数据调用只支持编写 SELECT 开头的查询 SQL 。如下图所示：

这里以添加一个“日志”的数据调用为例：

填写“模块名称”，如“最新日志”，可以根据实际需求设置过滤的条件，如选择“排序设置”，“第一排序”中的“发布时间”和“递减”，这样就是取最新的日志了，然后点击“提交”即可进入添加数据调用的下一步。如下图所示：

这里是添加数据调用的第二步：

查询 SQL 语句：这里的这个 SQL 语句就是通过刚才设置的过滤条件生成的，例如“SELECT * FROM `uchome_blog` AS `blog` WHERE `blog`.`friend`='0' ORDER BY `blog`.`dateline` DESC”，其中“`blog`.`friend`='0'”表示取出的数据是用户允许全站浏览的日志，设置了隐私的日志则不被调用，“ORDER BY `blog`.`dateline` DESC”表示查询的日志根据发布时间从大到小排序，取出的即为最新的日志，这些都满足了刚才进行的过滤设置。如果想要修改这个 SQL 语句，可以点击“编辑SQL”来修改。

变量名：这个为在页面中调用时使用唯一的变量名，一般使用默认生成的名称即可。

缓存时间：设置一个缓存时间间隔，该模块数据将自动在指定的时间间隔内更新数据。缓存时间设置越大，对服务器的负载就越小，但数据的及时性就不够。设置为0，则不使用缓存，实时更新，这样会严重增加服务器负载。

获取数目：这里设置需要获取那一部分数据，可以设置只获取满足条件的第几至第几条数据，例如：只获取满足条件的第 0 至 10 条数据，表示取出前 10 条数据。或者全部获取，分页显示，每页显示几条，这会覆盖上面获取条目的设置。

数据显示 HTML 代码：用 HTML 语言，编写数据的显示样式。获取到的数据存放在数组 $_SBLOCK[变量名] 中(将“变量名”替换为你在上面设定的变量名)，可以使用 loop 语法对该数组变量进行循环展示。

数据预览：点击“预览”后可以查看调用的结果。

可调用字段实例：这里所列出来的字段名为可以调用的数据名称，后面的数据实例表示字段名对应的值。该项目为帮助您书写数据显示 HTML 代码使用。

设置好后，点击提交即可。

二、使用数据调用

数据调用可以使用在站内，还可以使用在站外。

在站点调用则使用“模块内嵌代码”，点击之后会得到这样的一段代码：“”，该代码可以放到 UCenter Home 模板的任意位置进行显示，如下图所示：

在站外调用则使用“Javascript调用代码”，点击之后会得到这样的一段代码：“”，该代码可以放到任意的位置进行显示，如下图所示：

三、修改和删除调用

编辑SQL：进入添加数据调用的第一步，可以重新编写用于调用的 SQL 语句。

参数设置：进入添加数据调用的第二步，可以重新设置调用参数。

删除：删除当前调用。

几个调用教程：

几个常用的 SQL 调用语句：http://www.discuz.net/thread-955778-1-1.html

如何调用 feed 事件：http://www.discuz.net/thread-1084529-1-1.html

如何调用最新日志：http://www.discuz.net/thread-1179206-1-2.html


系统计划任务

高级应用 —— 系统计划任务

计划任务是每个站点必用到的一个功能，计划任务的作用是通过执行计划任务，使得系统在规定时间自动执行某些特定任务的功能。登陆后台，点击顶部菜单栏中的“计划任务”或者点击左侧“高级应用”中的“计划任务”，即进入计划任务的界面，如下图：

本文分为四个部分讲计划任务：

一、计划任务的作用；

二、如何设置计划任务；

三、计划任务如何执行；

四、如何添加计划任务。

一、计划任务的作用：

UCenter Home 计划任务的作用：通过执行计划任务，使得系统在规定时间自动执行某些特定任务的功能。例如：在每天的某个时刻，通过执行计划任务，更新浏览数统计。

注意计划任务是与系统核心紧密关联的功能特性，不当的设置可能造成论坛功能的隐患，严重时可能导致论坛无法正常运行，因此请务必仅在您对计划任务特性十分了解，并明确知道正在做什么、有什么样后果的时候才

自行添加或修改任务项目。

二、如何设置计划任务：

UCenter Home 自带 4 项计划任务，如下图所示：

如果修改某一项计划任务执行的时间，请点击计划任务名称后面的“编辑”，看到如下图的界面，在此设置计划任务执行的时间。

注意：除非您非常了解 UCenter Home 结构，否则强烈建议不要修改计划任务的默认设置，并且在修改之前记录原有设置，不当的设置将可能导致论坛出现不可预期的错误。

三、计划任务如何执行：

在您设置的计划任务执行时刻，如果有人访问您的站点，计划任务才会执行；如果那个时刻没有人访问您的站点，一直到有人访问时才执行计划任务。在此说明，UCenter Home 计划任务的一个功能---“执行”，如果偶尔站点的

计划任务没有正常执行，您可以在论坛后台手工执行某一项计划任务，如下图：

四、如何添加计划任务：

1、自己写好计划任务的程序，然后存放到论坛目录下的 ./source/cron/中；

2、添加计划任务，如下图，添加计划任务的名称；

3、编辑新增计划任务的执行时间和任务脚本，如下图。例如自己添加的脚本名称是 update.php。

4、设置计划任务执行的时间


数据备份

高级应用 —— 数据备份

为了确保站点数据的安全性，定期的数据备份是相当重要的，下面详细介绍如何进行数据备份。

一、备份前的准备

关闭 UCenter Home

管理员登录 UCenter Home 管理后台 => 基本设置 => 站点设置 => 站点关闭访问，选择“是”。

二、备份数据

注意：关于站点数据的备份除了要备份 UCenter Home 的数据，同时还要备份 UCenter 的数据，站长可以选择从 UCenter 后台备份所有应用的数据，也可以选择单独在应用里备份，关于如何从 UCenter 备份数据，可以参考搬家教程中关于数据备份的说明：http://faq.comsenz.com/viewnews-504

登录 UCenter Home 的后台 =>高级应用 => 数据备份，在此备份 UCenter Home 数据。如下图所示：

默认选择“UCenter Home 全部数据”直接提交就可以了，点击更多选项，可以根据这里的条件进行备份

UCenter Home 分卷备份：文件长度限制，默认是 2048 kb ，如果是虚拟机或者内存有限制的主机，这里可以修改为 1000 kb。

其它项目按默认设置就可以了。

自定义备份：可以选择只备份某个表，或者某几个表。如下图所示：

这里按备份“UCenter Home 全部数据”为例进行备份，备份好的数据如下图所示：

备份好数据以后，打开站点。


前台使用

UCHome 前台使用

  • 好友
  • 隐私
  • 设置


隐私

前台使用 —— 隐私

隐私设置位于顶部导航栏的最右侧，隐私一项，如下图所示：

隐私设置中包括两项，个人隐私设置和好友动态筛选，如下图所示：

一、个人隐私设置

1、个人隐私设置

你可以完全控制哪些人可以看到你的主页上面的内容，如下图所示：

个人主页，个人基本资料，好友列表，留言板，群组项可以设置的权限有：全站用户可见、仅好友可见、仅自己可见。

个人动态，记录，日志，相册，分享项可以设置的权限有：全站用户可见、仅好友可见。

记录：本隐私设置仅在其他用户查看您主页时有效；在全站的记录列表中可能会出现您的记录。

日志：本隐私设置仅在其他用户查看您主页时有效；相关浏览权限需要在每篇日志中单独设置方可完全生效。

相册：本隐私设置仅在其他用户查看您主页时有效；相关浏览权限需要在每个相册中单独设置方可完全生效。

分享：本隐私设置仅在其他用户查看您主页时有效；在全站的分享列表中可能会出现您的分享。

2、个人动态发布设置

系统会将您的各项动作反映到个人动态里，方便朋友了解你的动态。你可以控制是否在下列动作发生时，在个人动态里发布相关信息。如下图所示：

这里可以针对发表记录、撰写日志、创建相册、上传图片、添加分享、发起话题、对话题回复、加入群组、添加好友、发表评论/留言、对日志踩一脚这些动作是否产生动态做详细的控制。

二、好友动态筛选

对于您查看到的好友的动态都可以在这里设置哪些您希望查看，哪些您不想查看到，屏蔽掉的信息将不再显示。

筛选规则一：屏蔽指定用户组的动态

你可以决定屏蔽哪些用户组的动态，屏蔽用户组内的组员所发布的动态都将被屏蔽掉。如下图所示：

筛选规则二：屏蔽指定好友指定类型的动态

点击一下首页好友动态列表后面的屏蔽标志，就可以屏蔽指定好友指定类型的动态了。如下图所示：

点击屏蔽后，弹出一个选择框，在这里可以选择“仅屏蔽该好友的”或是“屏蔽所有好友的”指定类型的动态，点击提交即可。在“筛选规则二”下面列出的就是您已经屏蔽的动态类型识别名和好友名，你可以选择是否取消屏蔽。如下图所示：

这里显示的则为我屏蔽了用户名为 cindy 这个用户的类型为“话题”的所有动态。

筛选规则三：屏蔽指定好友指定类型的通知

点击一下通知列表后面的屏蔽标志，就可以屏蔽指定好友指定类型的通知了。如下图所示：

点击屏蔽后，弹出一个选择框，在这里可以选择“仅屏蔽该好友的”或是“屏蔽所有好友的”指定类型的通知，点击提交即可。在“筛选规则三”下面列出的是您已经屏蔽的通知类型和好友名，你可以选择是否取消屏蔽。如下图所示：


设置

前台使用 —— 设置

功能所在位置：登录站点 => 设置

这里是关于会员的基本资料设置，下面详细说明每一个设置的功能。

一、我的头像

这里会员可以上传自己的头像，支持摄像头，如果您的电脑上安装有摄像头的话可以直接拍照。

从本地选择头像图片，上传，如下图所示

然后选择“预览头像”

最后点击“确定”。

这样头像就上传成功了。如果头像不能上传，请参考：http://www.discuz.net/thread-1008637-1-1.html

二、个人资料

这里填写会员的个人资料，如姓名、性别等，建议这里填写完整，以便更多的朋友找到您。

姓名：站长开启实名后，会员在真实姓名在这里填写。

性别：这里第一次填写完成后将不能进行修改。

下面是生日、血型、家乡等，如果站长还想在这里让会员填写更多的项目，可以到后台 => 基本设置 => 用户栏目里添加。同时这里添写的信息会在个人主页里显示，如下图所示：

三、主页风格

这里可以选择个人主页的个性风格，如下图所示：

有 14 种不同的风格供会员选择，同时也可以使用自定义的风格，当然这个需要撑握一定的 CSS。

如果站长想让会员使用自定我风格，需要在后台 => 基本设置 => 用户组 => 编辑让使用这个功能的用户组名 => 编辑 => 允许自定义CSS，选择“是”。

注意：允许自定义 CSS 可能会造成 javascript 脚本引起的不安全因素，所以要谨慎使用。

可以预览和启用其中的风格。启用其中的一种风格，访问个人主页，效果如下图所示：

四、邮件提醒

这个功能需要在后台 => 基本设置 => 站点设置 => 邮件通知更新天数，这里设置，同时要保证站点可以发送邮件。

会员超过多少天没有登录站点时，自动给您发送提醒邮件，你可以选择只接受某些类别的提醒。如下图所示：

如果不想实时收到邮件，邮件发送频率选择每天发送一次或者每周发送一次。

五、账号设置

这里可以修改登录密码以及进行邮件验证的设置。

进行邮箱验证的话，会收到不封验证邮件，激活及可，这里要保证站点可以发送邮件。

六、积分

这里可以参看自己的积分、所在用户组、兑换积分、兑换上传空间查看积分排行榜等

同时还可以查看积分的增减规则，如下图所示：

1、如何兑换上传容量

点击右侧的“兑换上传容量”，如下图所示：

注意看兑换的规则是：兑换 1M 的上传空间，需要积分数：10 这里管理员可以在后台控制。

要兑换的空间大小这里输入要兑换的容量，点击兑换即可。

2、积分兑换

这里如果提示“系统目前没有开启积分兑换功能”那么说明您还没有设置好积分兑换功能，请根据这里 http://www.discuz.net/thread-1144551-1-1.html 第 13 个问题的说明进行检查。

根据这里的提示说明，进行积分兑换。

3、积分排行榜

这里可以查看站点内所有会员的积分排行，如下图所示：

七、高级管理

管理员可以通过这里登录后台


好友

前台使用 —— 好友

生活中，好友是自己关心的人。在 UCenter Home 中，您也可以有自己的好友，并关注他们每天的动态。您可以添加好友，管理自己的好友，邀请站外好友加入进来等等，下面请看详细介绍。

一、管理和查看好友

登录 UCenter Home 前台 => 好友，如下图：

点击图中的“好友”，即可看到全部的好友，如图：

您也可以分类查看和批量操作管理好友，如下图所示：

点击屏蔽按钮，即可屏蔽该用户组的好友动态在首页的显示；

点击编辑按钮，即可编辑该用户组名称；

点击“批量分组”，即可对好友进行批量分组，如下图所示：

二、添加好友

点击“可能认识的人”，如下图所示：

也可以自己设置搜索条件，搜索出用户，添加为自己的好友，如下图所示：

设置好条件后，点击“搜索”按钮，即可搜索出符合条件的用户，如下图：

三、邀请好友

您可以邀请站外的朋友加入进来，并成为您的好友，点击“邀请好友”，即可看到下图所示：

也可以通过邮件发送：

您可以看到朋友收到邮件的内容，如下图：

站外朋友收到邀请后，打开地址将进入注册页面，注册本站点并成为您的好友。此时您将看到您邀请的好友，如图所示：